The Res Edit™

Serving Up America’s Best ResEdit Recipes!

Dave Ciskowski

Disk Includes ResEdit 2.1.1!
The ResEdit All-Night Diner

©1993 by Hayden Books, a division of Prentice Hall Computer Publishing

All rights reserved. No part of this book shall be reproduced, stored in a retrieval system, or transmitted by any means, electronic, mechanical, photocopying, recording, or otherwise, without written permission from the publisher. No patent liability is assumed with respect to the use of the information contained herein. Although every precaution has been taken in the preparation of this book, the publisher and author assume no responsibility for errors or omissions. Neither is any liability assumed for damages resulting from the use of information contained herein. For information, address Hayden, 11711 North College Avenue, Carmel, Indiana 46032.

International Standard Book Number: 1-56830-024-7

Library of Congress Catalog Card Number: 93-78058

This book is sold as is, without warranty of any kind, either express or implied. While every precaution has been taken in the preparation of this book, the publisher and author assume no responsibility for errors or omissions. Neither is any liability assumed for damages resulting from the use of the information or instructions contained herein. It is further stated that the publisher and author are not responsible for any damage or loss to your data or your equipment that results directly or indirectly from your use of this book.

95 94 93 4 3 2 1

Interpretation of the printing code: the rightmost double-digit number is the year of the book's printing; the rightmost single-digit number is the number of the book's printing. For example, a printing code of 93-1 shows that the first printing of the book occurred in 1993.

Printed in the United States of America
Trademark Acknowledgments

There are too many trademark acknowledgments to list on one page. To acknowledge every product and every company would require that we double the size of this book. However, because we are environmentalists, and because paper is a valuable (and costly) commodity, we are limiting our trademark acknowledgments to the following statement:

All products mentioned in this book are either trademarks of the companies referenced in this book, registered trademarks of the companies referenced in this book, or neither. We strongly advise that you investigate a particular product’s name thoroughly before you use the name as your own.

Apple, the Apple logo, and Macintosh are registered trademarks of Apple Computer, Inc. ResEdit is a trademark of Apple Computer, Inc.

APPLE COMPUTER, INC. ("APPLE") MAKES NO WARRANTIES, EXPRESS OR IMPLIED, INCLUDING WITHOUT LIMITATION THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, REGARDING RESEDIT. APPLE DOES NOT WARRANT, GUARANTEE OR MAKE ANY REPRESENTATIONS REGARDING THE USE OR THE RESULTS OF THE USE OF RESEDIT IN TERMS OF ITS CORRECTNESS, ACCURACY, RELIABILITY, CURRENTNESS OR OTHERWISE. THE ENTIRE RISK AS TO THE RESULTS AND PERFORMANCE OF RESEDIT IS ASSUMED BY YOU. THE EXCLUSION OF IMPLIED WARRANTIES IS NOT PERMITTED BY SOME STATES. THE ABOVE EXCLUSION MAY NOT APPLY TO YOU.

IN NO EVENT WILL APPLE, ITS DIRECTORS, OFFICERS, EMPLOYEES OR AGENTS BE LIABLE TO YOU FOR ANY CONSEQUENTIAL, INCIDENTAL OR INDIRECT DAMAGES (INCLUDING DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, AND THE LIKE) ARISING OUT OF THE USE OR INABILITY TO USE RESEDIT EVEN IF APPLE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. BECAUSE SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE LIMITATIONS MAY NOT APPLY TO YOU.

Apple's liability to you for actual damages from any cause whatsoever, and regardless of the form of the action (whether in contract, tort (including negligence), product liability or otherwise), will be limited to $50.
Dave Ciskowski

Dave Ciskowski is a development editor at Hayden Books; he now has firsthand knowledge of the pain and suffering he puts authors through. A devout Macintosh user since 1986, Dave has been a resource editor the whole time.

Dave majored in philosophy and mathematics at the University of California at Berkeley. He soon found that the large math firms weren't hiring, and that the philosophy industry was suffering cutbacks, so he combined his skills with his Macintosh knowledge and wound up as an editor of Mac books. He's a sports fan (Go Bears!) and enjoys a good cup of coffee.
We Want to Hear from You

What our readers think of Hayden is crucial to our sense of well-being. If you have any comments, no matter how great or how small, we'd appreciate your taking the time to send us a note, fax us a fax, rhyme us a rhyme, etc.

We can be reached at the following address:

    David Rogelberg, Publisher
    Hayden Books
    11711 North College Avenue
    Carmel, Indiana  46032

    (800) 428-5331 voice
    (800) 448-3804 fax

    E-Mail:
    America Online   Hayden Bks
    AppleLink        hayden.books
    CompuServe       76350,3014
    Internet         HaydenBks@aol.com

If you've enjoyed this book, please write and describe the euphoria you’ve experienced. If you develop your own cool ResEdit recipe, drop us a line describing your creation. If you have a cool book idea, contact us at the above address. We always welcome proposals—for marriage and otherwise.
Dedication

For Mom and Dad

Acknowledgments

This book came together due to the contributions of a host of people; without their help, it wouldn't have happened. I know I'll forget some crucial folks; please forgive my lapses.

Much thanks to my family, for their support and general wonderfulness. I wouldn't be here without you (wherever "here" is).

I'd like to thank Christian Wiedmann (and Ulrich, too!) for saving me from purchasing an inferior computer and convincing me that Macintosh was the way to go. Oh, and for teaching me about ResEdit, too!

Everyone at Hayden was crucial to the success of this book—not the least through their support and understanding. David Rogelberg helped build the foundation of the book, and made it into a different (and much better) book in the process. Karen Whitehouse provided fantastic input, and the patience of several saints. Marj Hopper did a wonderful job polishing the (many) rough edges, and deserves a medal for laughing at my chapter titles. And Mat Wahlstrom did a great job, doing that voodoo that he does so well.

Particular thanks go to Tom Chavez, for ensuring the technical accuracy of this book. Any mistakes were slipped in while he wasn't looking. Thanks also to Steve Costa, for his words of wisdom.

Thanks to Steak 'n Shake and Waffle House (and that great cafe on Hearst, just west of Euclid, in Berkeley) for inspiration and many cups of black coffee. And, of course, thanks to Apple Computer, Inc., for making computers that make so much sense.
# The ResEdit All-Night Diner Menu

<table>
<thead>
<tr>
<th>Chapter</th>
<th>Title</th>
<th>Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chapter 1</td>
<td>Open 24 Hours</td>
<td>1¢</td>
</tr>
<tr>
<td>Chapter 2</td>
<td>Why Resources Are Like Hash, and How to Sling Them</td>
<td>7¢</td>
</tr>
<tr>
<td>Chapter 3</td>
<td>Heimlich Maneuvers</td>
<td>18¢</td>
</tr>
<tr>
<td>Chapter 4</td>
<td>A Hot Cup of Icons</td>
<td>25¢</td>
</tr>
<tr>
<td>Chapter 5</td>
<td>Fresh Pointer Pie</td>
<td>65¢</td>
</tr>
<tr>
<td>Chapter 6</td>
<td>Golden Fried Patterns</td>
<td>79¢</td>
</tr>
<tr>
<td>Chapter 7</td>
<td>Fresh-Picked PICTs</td>
<td>$105</td>
</tr>
<tr>
<td>Chapter 8</td>
<td>Menu Melts</td>
<td>$119</td>
</tr>
<tr>
<td>Chapter 9</td>
<td>Dialog Box, Alert, and Window Casserole</td>
<td>$139</td>
</tr>
<tr>
<td>Chapter 10</td>
<td>Blue-Plate Special</td>
<td>$165</td>
</tr>
<tr>
<td>Chapter 11</td>
<td>Breakfast Special</td>
<td>$185</td>
</tr>
<tr>
<td>Chapter 12</td>
<td>Opening Your Own Diner</td>
<td>$201</td>
</tr>
<tr>
<td>Appendix</td>
<td>Resource Types</td>
<td>$211</td>
</tr>
<tr>
<td>Index</td>
<td></td>
<td>$219</td>
</tr>
</tbody>
</table>
Contents

1  Open 24 Hours ........................................................................... 1
   A Bit of Our History ................................................................. 2
   I Want to Get Started! ............................................................... 3
   What's the Book Like? .............................................................. 3
   What Do I Need? ................................................................. 4
   Surgeon General's Warning ........................................................ 4

2  Why Resources Are Like Hash, and How to Sling Them .... 7
   Why Resources? ....................................................................... 8
   What Is a Resource? ............................................................... 9
   Why Edit Resources? .............................................................. 11
   So What's ResEdit? ............................................................... 12
   Moving On ........................................................................... 16

3  Heimlich Maneuvers .................................................................. 17
   How to Know You've Got a Problem ....................................... 18
   General Solutions ................................................................... 19
      Discarding Your Changes ...................................................... 19
      Making Your Changes Work ................................................. 20
   System Solutions ................................................................... 22
      Getting the Macintosh Operating ........................................... 22
      Helping the Macintosh Find the System ............................... 23
   Problem Solving ................................................................... 24
4 A Hot Cup of Icons ................................................. 25
  Why a Calculator? .................................................. 29
    Ingredients ......................................................... 29
    Variations .......................................................... 39
  Environmental Special ........................................... 40
    Ingredients ......................................................... 41
    Variations .......................................................... 42
  Animation After Dark ............................................. 43
    Ingredients ......................................................... 43
    Variations .......................................................... 46
  File Sharing Makeover ........................................... 46
    Ingredients ......................................................... 47
    Variations .......................................................... 52
  Colorized Icons .................................................... 53
    Ingredients ......................................................... 53
    Variations .......................................................... 56
  The Flying W ......................................................... 56
    Ingredients ......................................................... 56
    Variations .......................................................... 60
  Savory Small Icons ............................................... 61
    Ingredients ......................................................... 61
    Variations .......................................................... 63
  The Macintosh Mainstay ......................................... 64
5 Fresh Pointer Pie .................................................. 65
  The Missing I-Beam ................................................ 66
Variations ................................................................. 155
WIN ding Up with the Calculator ............................... 157
Ingredients ............................................................... 157
Variations ................................................................. 162
Windowmania ............................................................ 163
10 Blue-Plate Special: .................................................. 165
Chili con Calculator ...................................................... 165
Ingredients ............................................................... 166
Window ...................................................................... 167
Pattern ...................................................................... 169
Strings ...................................................................... 175
Icon .......................................................................... 176
Finishing Up .............................................................. 181
Spice is Nice .............................................................. 183
11 Breakfast Special: .................................................... 185
Coffee and Muffins ...................................................... 185
Ingredients ............................................................... 186
Sounds ...................................................................... 187
Pictures ..................................................................... 190
Text .......................................................................... 193
Finishing Up .............................................................. 198
Continental Breakfast ................................................ 200
12 Opening Your Own Diner .......................................... 201
How to Edit .............................................................. 203
Make a Copy ............................................................. 203
Try One Thing at a Time .............................................. 203
Introduction

This is not a ResEdit book.

Okay, that’s not really true. This book talks an awful lot about ResEdit. You’ve probably heard about ResEdit; if you have, you’ve almost certainly been told that it’s a great tool for changing the way your Macintosh does things.

This book is designed to show how you can painlessly modify your Macintosh, using ResEdit. Most of the book is made up of step-by-step recipes that show you ways you can change your Macintosh with ResEdit. They’re easy; they’re pre-tested; they leave nothing up to chance. If you work through the recipes, you’ll have a Macintosh with personality. Moreover, after working through a few recipes, you’ll realize that resource editing isn’t that hard. I guarantee you that as you try out more and more recipes, you’ll start to think of ways to do things differently. Soon enough, you’ll be changing your Macintosh so that it reflects your personality, and you’ll know quite a bit more about how Macintosh programs work.

This won’t be because you studied ResEdit, it will be because you used ResEdit to examine your software. Although ResEdit is neat, you probably won’t want to learn how to use ResEdit per se. When you use ResEdit (either for fun or for serious purposes), you’re using it because you want to change the way something on your Macintosh works. With ResEdit, more than with any other program, you’re concentrating on what you’re going to do, rather than how you do it.

And that’s why this is a Macintosh book and not a ResEdit book. Sure, we’ll teach you how to use ResEdit, but we don’t concentrate on the program; we concentrate on what you do with it. The recipes all have specific goals, so you’ll always know what your goal is when you start. The knowledge you will gain about ResEdit—and about your Macintosh—will follow naturally.

If you like the idea of making your Macintosh different from all the others; if you think it would be interesting to see the way things work; if you want to know how to modify the innards of your Macintosh programs; then, this book is for you.
More than anything, you should have fun with this book. Too often, we forget that the Macintosh can be fun. Sure, you can make serious, productivity-enhancing modifications using ResEdit. But more than anything, you should experience that thrill of exploring the attic where nobody ever goes—where you find your grandmother’s old Victrola and collections of old photos that nobody’s seen in years. This book will show you a few things in the Macintosh attic; in the process, you’ll get used to moving around up there. The real fun, though, comes when you explore the attic yourself. Poke around. See what you can find. And, always, have fun.

Dave Ciskowski
July, 1993

Conventions Used

Our goal is to provide a fun and painless introduction to ResEdit. Most of the book is made up of step-by-step recipes that show you ways you can change your Macintosh using ResEdit. Here are a few of the conventions we used to make the recipes easier to understand.

Resource types, resource ID numbers, file names, and text that you type appear in a special font, like this.

Keystroke combinations are indicated as in the following example: “Press -P to print.” This means that you press and hold the Command key (the key at the bottom of your keyboard with a picture of a cloverleaf and/or an apple on it), and then press the key labeled P. Release both keys simultaneously.

You’ll meet the following people when you visit the diner:

Walt is the cook and manager of the diner. He keeps a steady banter going with the waitresses, the customers, Henry, or himself.
Rosa is a full-time waitress at the diner. She is usually cheerful, chatting with the customers, serving with a flair, and so forth.

Henry is the busboy. Normally meek, he occasionally becomes loquacious, rambling about politics, religion, physics, or philosophy.

Mr. Grigsby is a retired machinist. He sits at the counter and complains about everything: the food, the customers, the management, the economy, the nay-sayers, the yes men—whatever he's thinking about at the moment.

Ms. Kristen Finley is a very busy woman. She comes in either late at night or early in the morning. She always takes a large booth, spreads out piles of papers, and goes to work.
Welcome to the ResEdit Diner! For years (or months, or days) your friends have been telling you about our place. About the just-like-home cursor pie... the golden fried PICTs... the juicy alerts and dialog boxes (with or without cheese)... the menu with the forty different menu flavors... and, of course, our steaming hot bottomless cup of icons!

You've heard great things about us, but you just haven't stopped by. Maybe you heard there are potholes in the street and scraps of paper in the gutter. Or you heard of a friend of a friend who got mugged when he just wanted to get a slice of pattern topped with strawberries. So you stayed away. "Not for me," you thought. "I'll stick to fast food and the occasional PBJ for excitement."

Don't worry! We're here to help you order what you want. The intimidating characters you see are nice people, really. Take Walt over there, doing the cooking. He manages this place. Sure, he seems a little odd, gabbing on like he does,
but he's got a heart of sterling silver—and quite a talent for dialog boxes topped with grilled onions.

Thing is, you'll find quite a few friendly people here at the diner, and we'd like you to try a few of our favorite recipes. Some are classics, while others are more of an acquired taste. The beauty is that you can pick and choose your meal. Take your time, sample a few things, and we'll do our best to make you feel at home.

By the way, I'm Henry—the busboy. I know, I talk a lot for a busboy, but I like people, and Walt doesn't seem to mind. (Fact is, he talks a lot more than I do, so he can't really complain.)

Enjoy your meal!

A Bit of Our History

This diner is built on ResEdit. "ResEdit?" you're thinking. "Isn't that the Macintosh program that lets people change other programs? The one that causes people to destroy their computers and do thousands of dollars of damage?"

Well, not really. ResEdit stands for resource editor. We'll get into just what that means in the next chapter—but for now, here are the basics. Resources are a part of virtually every Macintosh program, and they can do lots of things. One thing they do is tell the rest of the program how to talk to you—how to control the user interface. ResEdit enables you to edit these resources and change the user interface in many different ways.

Most Macintosh programs are like fast food—they look, feel, and taste about the same, whether you're using McWrite or WhopperWord. Don't get me wrong—that's great! It's why the Macintosh is so easy to learn and use. McWrite and WhopperWord use the same resources. Whether they're broiled or seared, they're using the same beef from the same cows. Thus they don't surprise you. You know pretty much what you'll get every time you launch a new program—menus, icons, cursors, and so forth.

But a person can't live on bread and frozen beef patties alone. Sometimes it's nice to have a surprise. You're tired of vanilla menus, you'd like a chocolate fudge (or a rum-raisin) menu once in awhile. Strangely enough, those resources that make everything the same also make it easy to do things your own way.
That’s where we come in. We’ve got a full menu of choices for you. Some are old standards, with a twist of lemon. Others are Walt’s own creations. (To be honest, some of his ideas are pretty loony, but he does have a certain demented genius.)

I Want to Get Started!

So have a seat at the counter or in one of our booths (notice the vinyl, the chrome, the ergonomic keyboards) and pick a dish from our lineup. Flip to that page, follow the steps, and your dish will be served up in no time!

That doesn’t sound too hard, does it?

It’s a good idea to read the “Surgeon General’s Warning” at the end of this chapter. It also wouldn’t hurt to read the next chapter, “Why Resources Are Like Hash, and How to Sling Them.” But the meat is in the recipes themselves (to purée a metaphor).

What’s the Book Like?

This book requires absolutely no knowledge of ResEdit. You don’t have to know the difference between an acur and a curs, how to make a mask, or what a ditl is. All the knowledge you need is built into the recipes.

On the other hand, if you’re already comfortable with ResEdit, this book will provide you with a savory assortment of tricks and tidbits to whet your ResEdit appetite.

The next chapter, “Why Resources are Like Hash, and How to Sling Them,” discusses the basics of ResEdit and resource editing. Chapter 3, “Heimlich Maneuvers,” tells you what to do when things go wrong. If you ever have a problem, check out Chapter 3 for solutions.

The main part of the book begins with a set of chapters covering various Macintosh elements that you can change with ResEdit. (Not so coincidentally, these correspond to different resource editors that ResEdit uses—but more on that later.) The chapters serve up icons, pointers, patterns, pictures, menus, and dialog boxes.
The next part of the book presents a pair of recipes, each bringing together several of the above areas. These specials give you more involved projects to work on.

The final chapter, “Opening Your Own Diner,” gives you some tips on how to create your own ResEdit recipes.

What Do I Need?

First, you’ll need a Macintosh. Most (though not all) of our recipes are designed for System 7 and the color Macs. We’ve tried to provide alternatives so you don’t go hungry if you’re allergic to oysters or 8-bit color.

You’ll also need programs to edit. A number of our recipes work on the System and the things that come with it. But many recipes are designed for common applications. If you don’t have a particular application, you may be able to adapt the recipe to a similar program. At the very least, you can perform quite a few recipes using nothing more than the System you walked in with.

Surgeon General’s Warning

Okay, time to speak plainly. There’s no reason to fear ResEdit, but you should know:

You can hurt your software if you’re not careful.

When you’re working with System software, if you don’t watch out, you can put yourself in a very sticky situation. The first rule of ResEditing is:

Always work on a copy of the program.

This is built into the recipes, but it’s worth repeating here. Make sure you have a pure, unsullied copy of the software you’re editing, just in case something goes wrong. That’s the secret to ResEdit—as long as you back everything up, you’ll be okay.

There’s one other rule of thumb to keep in mind:

If you’re working on the System, have a startup floppy disk handy.
This is explained in Chapter 3, but the idea is that if something should go wrong with your System, you’ll need another way to start up your Macintosh so that you can fix the problem.

And now for our disclaimer: We can’t foresee everything. I know it’s hard to believe, but some situation may arise that we can’t predict. Some combination of hardware and software, or of different applications, or something of that nature may cause your recipe not to work. If so, you can vary the recipe (or your setup) to try to make things work, or you can restore your backup and go on. Remember, when you modify your programs (and in many cases your System software), the effects can be pretty drastic.

It’s a good idea to read Chapter 3, “Heimlich Maneuvers,” before you start. It provides you with tips on what to do if things should go wrong, so it’s a good chapter to be familiar with.

’Nuff said. Time to dig in!
Hello, and pleased to make your acquaintance! You've met Henry already. He's told you a little about the diner. My name's Walt. I do the cooking here. We're not too busy at the moment, so if you'd like, I can tell you a bit about what I know: resources.

The great thing about resources is that different people can do different things with them. For instance, Rosa, our waitress, likes to
make her Macintosh a little more friendly and inviting. Ms. Finley there, in the booth, changes resources to make her work more efficient. That's Grigsby over at the counter; he gets fed up from time to time and wants the computer to do things his way. Everyone has a different complaint, but they all get results by changing resources.

So have a seat and relax. I'll bring you a cup of coffee, and we can chat for awhile. I'll tell you about resources: what they are and how to change them.

Why Resources?

Back when the folks at Apple decided to create a new kind of computer, they knew they wanted it to make sense to people who didn't know diddley about computers. They knew they would have to do quite a few things differently. They had to pay close attention to the user interface—how the computer communicated with the user and vice versa. They had to make the programs consistent—each program should work pretty much like all the others.

These lofty goals meant that programs couldn't work the same way as on other computers. Take icons. Apple could make every program draw its icons from scratch, but that would be a real problem. It would take forever for the program to draw the icon, and there was no guarantee that other companies would use the same icons, use them in the same way—or even use icons at all.

The alternative was to make tools that any program could use—and that's what Apple did. Programs don't have to tell the computer how to draw icons; they just tell the computer which icon to draw and where to draw it. The Macintosh System software takes care of the rest. The same thing goes for just about every other aspect of Macintosh software.

Windows, dialog boxes, buttons, menus, sounds—all of these are handled by the System. That's great, because it means that every program is going to do things in the same way. When a program needs a button, for instance, it just tells the System to give it a button of such-and-such a size, at such-and-such location, with such-and-such a name. Because every program asks the Macintosh to draw its buttons for it, things are easier all around. Users don't have to guess how buttons work or what a button will look like, even when they try out a new program. Programmers can concentrate on what a program is supposed to do and not worry about picayune details like how to create a button or play a sound.
Programmers aren't obligated to use the Macintosh tools; if they want, they can do some things themselves. That's why a few programs have funny-looking buttons, or no menus, or whatever. Most programmers do things the Macintosh way because it's usually easier for both programmer and user.

What Is a Resource?

When a program asks the System to do something, the System needs specific information. For instance, if a program needs a dialog box drawn, it has to tell the System what size the dialog box should be, where to draw it, what buttons it has, what it should say... quite a bit of information. Again, the program could contain a description of all this information (and sometimes it does), but there's a faster way—the program can give the System a prefabricated list of details.

It's as if the program and the System were people trying to tell the user something. With the slow method, the program tells the System, "Hey! Ask that guy if he wants to save his work before he quits. Ask him if he wants to go ahead and quit without saving, if he wants to save the work and then quit, or if he wants to forget the whole thing. Oh, and tell me what he says." The System thinks about all this, then passes it on to the user.

With the fast method, the program simply says, "Hey, System! Give the user this note and let me know what he says." The program has a stack of notes for use in different situations. Programs don't worry about what the notes say; they just know they should use note #16 when the user wants to quit but hasn't saved his work yet, note #17 when the user hasn't saved his work for the last 15 minutes, and so on.

Those notes are resources. More specifically, resources are chunks of information that the program knows will come in handy. Often, the program can rely just on the resources contained in the System itself; a good example is the triangular Exclamation Point sign used for warnings. Other times, the program will want its resources to be different from the System's—each program needs its own menus, for instance.
Each resource describes a unique element that the program uses. For instance, one resource would describe the dialog box that appears when the user tries to quit without saving her document.

(Sometimes, resources are more general; a resource might describe a “generic” alert that can pass several different messages on to the user. The program has to tell the System what message to put in the alert, but the size and position of the alert are described by the resource.)

So the resources contain nuggets of information that the System needs to help programs work. Several different types of resources are available, each bearing a four-letter identifying code. Resources are used to describe such things as:

- mouse pointers (cursors)
- patterns
- icons
- windows
- dialog boxes
- alerts
- sounds
- pictures
- menus

These are but a few of the elements that resources control. Many resources contain information that doesn’t control such obvious elements—for instance, the BNDL resource tells the Finder which icons to associate with which documents. Programmers can create their own resources, too, that a program can use for its own purposes.

As I mentioned, programs don’t have to use resources. Generally they do, but the program itself can contain the same information usually found in resources. Maybe the programmer wants to control the information in a way that the resource can’t handle, or maybe the programmer just has a different personal style. Microsoft programs—Microsoft Word in particular—are known for their sparing use of resources.
Why Edit Resources?

Resources describe some of the most basic elements of the Macintosh interface, and that’s what makes them interesting for the average user. The whole point of resources is that the program doesn’t have to keep track of their contents. Remember our note-passing analogy? When the program passes a note to the System, it doesn’t pay attention to what’s in the note—it just knows that it wants note #16, for instance. The System in turn uses the information that the note contains to, say, display a dialog box. The System doesn’t judge what the note is supposed to contain; it just uses whatever information it finds.

Sometimes the contents of the resource do matter, because either the program or the System expects certain things of the resource. The program or the System may try to use a resource that it can’t handle—causing the program or the System to crash. That’s why resource editing can have unexpected results—you can’t predict exactly what the program and System can handle. The next chapter, "Heimlich Maneuvers," talks more about what can go wrong and what to do about it.

What does this idea of passing notes to the System mean for you? If you change a resource, you can change the information that the program uses. If you change the description of a dialog box, you change what the program displays in a specific situation. You don’t change the way the program works, for instance, when the program displays a specific dialog box. You just change what the dialog box says when the program displays it.

Because resources control so many aspects of the Macintosh, you can change an awful lot using ResEdit. By changing resources, you can change icons, dialog boxes, pointers, alerts, menus, windows, patterns...a whole range of information. Again, you can’t change the way these items work; that’s controlled by the program, not the resources. But you can change the information that the program uses to carry out its tasks.

Sorry to say, you can’t change everything. Some resources, like the standard mouse pointer, are stored in the Macintosh ROM. Other elements, like the appearance of windows, are contained within the System programs. These are
examples of programs that contain information normally assigned to resources; you can’t change that information the way you can change resources. However, even with those limitations, you can change quite a bit.

The bottom line? You can change the way your Macintosh programs look and sound.

**So What’s ResEdit?**

When Apple created resources, they knew that programmers would need a way to change them (and even make new ones). So, they created ResEdit—a resource editor. ResEdit is the tool programmers use to change resources, and you can use it to change resources too.

You can also use ResEdit to create new documents containing nothing but resources; these are useful mainly for transporting resources from place to place.

As I mentioned, each type of resource has its own four-letter code. ResEdit sorts out all the resources by these codes; when you open a program, ResEdit uses icons to show you what resources it found (see figure 2.1).

**Figure 2.1**

ResEdit displaying a program’s resources.
ResEdit knows what many of the four-letter codes represent, so it uses specific icons to indicate those resources. For instance, the CURS resource contains cursors (mouse pointers), so ResEdit displays a representative icon. If ResEdit doesn’t recognize a resource’s code, it displays an icon of binary numbers.

If you want to look at, say, all the pointer-type resources, you click on the CURS icon and select Open from the File menu; you can also double-click on the icon. Usually ResEdit displays a list of resources of a particular type (see figure 2.2). But for certain graphical elements such as icons, patterns, or pointers, ResEdit displays the resources in a resource picker instead (see figure 2.3). You can add individual resources to a program from either the list or the picker.

<table>
<thead>
<tr>
<th>ID</th>
<th>Size</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>128</td>
<td>110</td>
<td>&quot;Misc&quot;</td>
</tr>
<tr>
<td>129</td>
<td>1255</td>
<td>&quot;Edit menu&quot;</td>
</tr>
<tr>
<td>130</td>
<td>36</td>
<td>&quot;Resource menu&quot;</td>
</tr>
<tr>
<td>131</td>
<td>333</td>
<td>&quot;Errors&quot;</td>
</tr>
<tr>
<td>132</td>
<td>774</td>
<td>&quot;GNRL errors&quot;</td>
</tr>
<tr>
<td>150</td>
<td>749</td>
<td>&quot;ResCheck Alerts&quot;</td>
</tr>
<tr>
<td>160</td>
<td>1625</td>
<td>&quot;ResCheck Errors&quot;</td>
</tr>
<tr>
<td>161</td>
<td>583</td>
<td>&quot;ResCheck Operations&quot;</td>
</tr>
<tr>
<td>162</td>
<td>250</td>
<td>&quot;ResCheck Messages&quot;</td>
</tr>
<tr>
<td>163</td>
<td>117</td>
<td>&quot;ResCheck Diagnostics&quot;</td>
</tr>
<tr>
<td>164</td>
<td>52</td>
<td>&quot;ResCheck Progress&quot;</td>
</tr>
<tr>
<td>200</td>
<td>179</td>
<td>&quot;StationErry&quot;</td>
</tr>
<tr>
<td>1310</td>
<td>177</td>
<td>&quot;CURS alert strings&quot;</td>
</tr>
<tr>
<td>1312</td>
<td>15</td>
<td>&quot;CURS labels&quot;</td>
</tr>
<tr>
<td>1313</td>
<td>42</td>
<td>&quot;CURS undo&quot;</td>
</tr>
<tr>
<td>1330</td>
<td>521</td>
<td>&quot;Font editor Alerts&quot;</td>
</tr>
<tr>
<td>1331</td>
<td>16</td>
<td>&quot;Font LDEF&quot;</td>
</tr>
<tr>
<td>1351</td>
<td>481</td>
<td>&quot;TMPL errors&quot;</td>
</tr>
<tr>
<td>1370</td>
<td>28</td>
<td>&quot;PAT* strings&quot;</td>
</tr>
<tr>
<td>1410</td>
<td>21</td>
<td>&quot;PAT* undo&quot;</td>
</tr>
<tr>
<td>1411</td>
<td>194</td>
<td>&quot;PAT* undo&quot;</td>
</tr>
</tbody>
</table>

Each resource has a specific ID number. ID numbers are unique for each resource of a given type within a program. When a program needs a resource, it asks for a certain ID number. If a different resource has been given that number instead, the program takes that resource, without regard to what it was “supposed” to get.
To edit a specific resource within a list or picker, click on the resource to select it, then choose Open from the File menu (or simply double-click on the resource). If ResEdit doesn’t know how to display the resource, it displays a generic editor—the Hex editor (see figure 2.4). This editor is as basic as they come. It displays just the hexadecimal numbers, along with their ASCII equivalents—if the numbers represent text, this is what that text is.

If ResEdit knows more about the resource type, though, it can give you more help. For many resources, ResEdit displays a resource template (see figure 2.5). The resource template is like a form—it provides boxes where the user can enter values, names, or other information about the various resource elements.

For some resource types, ResEdit uses an editor, which provides a customized interface for editing the resource. Figure 2.6 shows editors for several different resource types.
The editors and templates are where resources get changed. When you alter or create resources, this is where you will do your work! Resource editors are the most convenient way to change resources, because they provide tools customized for each resource type. Resource templates are convenient, too, for certain kinds of resources. (If they weren’t, an editor would have been created instead!) The Hex editor isn’t very usable; sometimes you can change the information if you can recognize a text string, but usually such changes aren’t successful.
You can add editors and templates to ResEdit to handle resources that otherwise couldn't be edited (or to change the way a resource type is edited). The editors and templates are—surprise, surprise!—resources themselves.

**Moving On**

So, now you know that resources give you a way to change the appearance of your Macintosh. Changing resources isn't too hard, but sometimes things can get hairy. The next chapter, "Heimlich Maneuvers," describes the bad things that can happen and what to do when they do.
Okay. Time to be serious. Once in awhile, things don’t go as you think they will. Everything seems okay, but all of a sudden, here comes trouble.

Maybe you’re striking out on your own, adding extra ingredients to the recipes in this book. Or maybe you’re following a recipe, but something goes wrong anyway. Aack! That feeling of panic creeps up on you....

Really, though, there’s no reason to panic. Things aren’t as bad as they seem. This chapter helps get your computer back to normal if it chokes while you’re ResEditing. Don’t worry—your waitress knows all the Heimlich maneuvers!
If you've noticed, every recipe has you make a copy of your files before you edit them. This is very important! You at least have a "clean" copy to return to if things go wrong. Just get rid of the copy with the "bad" changes and return to the pristine files. You've saved yourself the headache of trying to edit the program back to its original state. In some cases, tossing the whole thing and starting over is not just the best way but the only way to solve the problem!

How to Know You've Got a Problem

Lots of things can happen when you're ResEditing. After all, changing the way programs work is not a trivial process. However, there's bad and there's not so bad. Some of the symptoms you may face are:

- The Macintosh won't restart.
- The application crashes.
- The application behaves strangely.
- Your changes don't work at all.

If you can't even restart your Macintosh, obviously you have a serious problem. When this happens, it usually has to do with the way you edited the System or Finder, or it could be caused by changes to an extension or control panel. Your immediate problem is to get your Macintosh running so that you can get at the problem and fix it.

If the application crashes when you run it, you know something's seriously wrong—but at least you have something to work with. Your goals in this case are to get back to where you started, then figure out how to actually make the change that you wanted. At least in this situation, you can still make the changes.

If the application (or the System) behaves strangely, you're not in serious trouble. Let's say you're working fairly well with an application, but it's not always doing what you want it to do. In this case, you're probably most concerned with
finding the reason for the unexpected effects. Sure, the odd behavior is annoying, but at least things are working. Of course, you can always go back to the original state, too.

If your changes don’t work at all, your goal is simply to make them work—other than that, there’s no problem.

Obviously, there’s quite a range of problems and severity here; for the same reason, there are quite a few solutions. As you can imagine, the more troublesome (and spectacular!) problems occur when you are editing the System or Finder. First we’ll describe some general solutions, then some solutions specific to System or Finder problems.

**General Solutions**

When your resource editing doesn’t work right, you have a choice—either return to the way things were, or try to make your changes work correctly. (Sometimes, you’ll want to first get back to where you started, then try to make your changes work.) Returning to the way things were is simple, if you were careful in your edits; making your changes work is often more difficult. We’ll discuss some tactics for each strategy.

**Discarding Your Changes**

The simplest way to fix your problem is to throw out your changes and return to the way things were before you started. As I said before, every ResEdit recipe in this book begins with making a copy of the program you want to edit. This is important! (That’s why I’m saying it again.) If you edit only on a copy, you can discard your changes just by discarding the copy. When you try out your own resource edits, always work on a copy of the program you’re editing.

To discard your changes, throw away the edited copy of the program and restore the unedited version to its original name and location. If you edited a System or Finder file (or related items, such as control panels), you may have to restart your Macintosh. If you changed application icons and rebuilt your Desktop to make them visible, you have to rebuild the Desktop again to reverse the changes. In general, just reverse any changes that you made that didn’t involve ResEdit.
As an example, suppose you were altering WhopperWord. When you started, you made a copy of the program—WhopperWord copy. You made all your changes to WhopperWord copy, saved them, changed the name of the original WhopperWord to something like Old WhopperWord, moved it to a Disabled Items folder, and renamed WhopperWord copy as simply WhopperWord.

To undo your changes, throw away WhopperWord (the version that you edited). Move Old WhopperWord to its original location, and change its name back to WhopperWord. That's all there is to it—you've removed your changes and restored the original version of the program.

**Making Your Changes Work**

Discarding your changes is easy, if you were careful when you started. Fixing your changes when they don't work is a lot harder.

First, ask yourself, "Am I using the right program?" That's not as silly a question as it sounds. Remember, you changed a copy of the program, not the original. Make sure you're actually using the copy with the changes.

This problem often occurs when you're using more than one hard disk. Or, it may happen when you're trying to rebuild the Desktop to make use of custom icons; the rebuilding process may still be looking up the icons in the old version of the program. One useful trick is to hide the older versions in the Trash under System 7. The older versions will still be in the Trash when you restart—you can then drag them out of the Trash to keep a backup—but the Finder won't look in the Trash for icons, so it's forced to use your edited icons.

Next, ask yourself, "Did I change what I thought I changed?" Maybe you edited another resource, or even another program. Maybe you forgot to save your changes. Whatever the reason, your changes just may not be where you think they are. Open the program again with ResEdit to make sure you changed what you wanted to change.

Keep in mind that the most important part of every resource is its ID number. If you pasted in a resource, or created a new resource, in most cases it won't do anything unless you changed the resource ID to something that the program knows to look for—an existing resource ID. (The exceptions are usually lists of resources—patterns, for instance.)
The most difficult question to answer is "Do my changes make sense?" Assigning the right resource ID is essential, as I mentioned. Or perhaps the resource you've created is too big for the program to handle (either in area, as in an icon, or in bytes). Maybe the program needs very specific things from the resource—like an icon of a particular shape, or a sound of a specific length.

Although programs don't usually pay attention to the details of the resources they use, sometimes the details matter, for various reasons. (For example, never edit code resources—which are actually small pieces of program code!) If the program finds something it can't handle, it may just crash. You have no way to know what the program can't handle, so you're left guessing. This can be the toughest problem to troubleshoot, and it can be even tougher to fix. Often the best you can do is experiment, working back toward what the resource was when you started. Maybe the resource will work if it's only slightly different from the original, instead of radically different.

Another problem can occur when the program doesn't use the resource as you would expect it to use it. For example, suppose McWrite uses an animated watch pointer to show that it's busy. You may edit that pointer, only to find that you still see the watch while you're waiting. What's probably happening is that the Finder is really doing the work—maybe saving a file—so you're seeing the Finder's pointer, which you didn't change. The same can happen within a program. The resource that you edit may be used only in a special case, so your changes won't work the way you'd like them to work.

Let's face it, sometimes your changes just won't work. Maybe for some reason the program needs exactly that icon in order to work. Maybe the program doesn't even use the resource at all—maybe it really uses something stored elsewhere.

Note

This often happens with basic System resources, like the arrow pointer. Although you can find an arrow pointer resource in the System file, the actual arrow pointer comes from resources in the Macintosh ROMs.

So, sometimes there's nothing you can do but go back to where you started. The good news is, that's not too hard. Besides, at least you've learned a little more about how your program works!
System Solutions

Working with the System and related files (such as the Finder) is a special challenge. You’re changing the very software that makes your computer run! Not only do you face the standard problems just described, but you also face problems inherent in manipulating the System. Help is on the way—read on.

The most important thing you need when you edit the System software is a startup floppy disk. If things get really bad, you may not be able to even start up the Macintosh. You’ll need another way to start up your computer just to restore the older version of the System. So make sure that you have a floppy disk with the System software for starting up the computer. The most common such floppy is the Disk Tools disk that comes with your System disks; you can also use the System installer to install a “minimum System” on a floppy disk.

This section covers three basic steps for fixing a problem with an edited System: getting your computer running, making sure your computer knows where your System is, and making sure your computer is using the right System.

Getting the Macintosh Operating

When you edit the System and something goes bad, spectacular things can happen. You may get:

- A Sad Mac icon.
- A blinking Question Mark icon.
- A Happy Mac icon that doesn’t go away.
- An error message before your computer finishes the startup process.

Of course, each of these errors occurs for different reasons, but the implication is the same: the System (or the Finder, or the extension you edited) isn’t working right. You know what you changed, you even know how to restore the original System—but you can’t do anything because the computer won’t start.
That's where your startup floppy comes in. Turn off your Macintosh, and insert the startup floppy disk. When you turn on the Macintosh again, it uses the floppy disk as the startup disk. (Notice that the floppy disk is the first startup disk the Macintosh looks for. Hmm, do you think Macintosh designers may have had something like this in mind?)

One easily-solved problem—particularly if you get the blinking Question Mark icon—is that the Macintosh just doesn't know it has a good System folder on the hard disk. See the next section for a discussion of this problem—you may not even need to reinstall the System.

Once you've got your computer started, you can move files around on your hard disk. As described in the "Discarding Your Changes" section, you need to restore your original System file (or whatever file you changed) to its original name and location. Again, this isn't hard once you've got the computer up and running.

Helping the Macintosh Find the System

Probably the most common problem in editing System files is that the Macintosh doesn't realize it has a System with which to work. In essence, it gives up without even trying. Remember how, when you finished editing the copy of the System, you moved the original out of the System folder? Maybe you noticed that when you did so, the System folder icon changed to a normal folder. The tiny System icon disappeared from the folder.

That folder with the tiny System icon is called the "blessed folder." The Macintosh knows that it's a folder it can use as the System folder—basically, it's got a System and a Finder. When you took the System out of the System folder, the Macintosh knew it could no longer use that folder as the System folder, so it changed the icon back to a normal folder icon.

Then, as you continued the recipe, you renamed the System copy file; you changed the name to System. Now, the System folder again has a System file and a Finder file, so it can be used as the actual System folder again. However, although the Macintosh is very good about changing a folder when you take away the System, it's not so good at recognizing when you've actually added the System to a folder.
You took out the original System from the folder, so the Macintosh changed the folder to a regular folder. You changed the System copy file name to System, so the folder had all it needs again. But the Macintosh doesn't actually know that; it still thinks the folder is just another folder.

The solution for this is simple. Just open and close the System folder. (You may have to do it a couple of times.) This will make the Macintosh take a look at the folder; when it does, it sees that there's a System and a Finder in the folder, so it makes it a "blessed" folder again. You'll see the little System icon on the folder icon. In fact, this is a good thing to do even before you restart your computer. If the System icon doesn't appear on the System folder before you restart, the Macintosh won't know it's a System folder.

A related problem can happen if you have more than one System folder on your hard disk, or on several hard disks. This is bad news in general; you really shouldn't have more than one System folder. This can inadvertently happen if you have a Disabled Items folder. Suppose you edit the Finder and put the original in the Disabled Items folder; suppose you then edit the System and put the original in the Disabled Items folder too. You now have a folder with a System and a Finder... so the Macintosh thinks it's a bona fide System folder. To combat this, rename the files Good System or Untouched Finder. As long as it's different from System or Finder, you'll be okay.

The idea is to make sure that the System and Finder that you want to use are in the only folder with a System icon on it. If that folder does not bear the System icon, make sure that it does; if other folders have the System icon on them, change them so that they don't. That will solve a great many System troubles.

**Problem Solving**

The good thing about solving ResEdit problems is that, even if you can't make your edits work the way you want them to, you can easily return to where you started. In a few cases, you may not be able to make the change that you want, but in most cases all you need to do is change a few things and you'll be back in business.

Okay, you have been warned; now it's time to cook! The next chapter, "Steaming Hot Cup of Icons," introduces you to ResEdit recipes. So tie the napkin around your neck, turn the page, and dig in!
A Hot Cup of Icons

Now, ask yer typical streetside Joe what makes a Macintosh a Macintosh, and you know what he's gonna say: "The mouse," maybe, or "the menus." Hhmph! Shows what people know. I've got one word for ya. Icons.

Sure, you could come up with all kinds of reasons, but icons make the difference. You think they don't? Imagine a Mac without icons. All words instead of those pictures. How easy would it be to find what you were looking for? You'd spend hours trying to find something and by the time you found it, you'd forget what you wanted to do with it.

So you got yer icons. Icons tell you things fast. I see that icon, I know what it means now, not ten seconds later when it's too late.
But those icons, they all look the same after awhile. Why do you wanna stick with the same old folderol? Walt, here, will show you the kinds of things you can do. I've seen him take tired old black-and-white icons from the mid-eighties and whip 'em up into the lip-smackin'est treats you can imagine.

And what's more, you think icons are just those things sitting on the Desktop? Ha! There's icons all over the place. Dialog boxes, windows, menus—they're just about everywhere. You start changing icons, you won't know where to stop!

Walt here says he'll show you the ropes. What're you waiting for?

A word of advice before you start: if you are modifying the System or Finder files, make sure that you have a startup floppy disk handy before you start. If you have any problems with the following recipes, check out Chapter 3, "Heimlich Maneuvers."

The Icon Editor

Okay, so you want to change icons. You'll need to know some basics. All the different icons use the same set of tools—the tools you'll find in the icon editor. The icon editor changes a bit, depending on the kind of icon you're editing, but a lot stays the same.

Take a look at the Icon Editor window (see figure 4.1). The main part is the big area in the middle; it shows you a closeup of the icon you're working on. (This is where you make all your changes.) Depending on the icon type, some kind of display on the right side shows you a normal-size view of your icon. On the left side, a toolbar enables you to choose among a slew of different editing tools. One or more boxes below the toolbar let you choose the pattern you'll be drawing with (and the colors, if you're editing a color icon).
A basic icon editor.

The tools (see figure 4.2) are really the same tools you’d find in your typical paint program, but I’d be happy to explain them to you. To choose from the toolbar, just click on the tool you want to use.

- Lasso
  Enables you to select an irregular group of icons; again, you can then cut, copy, paste, or move those pixels.

- Selection Rectangle
  Enables you to select a rectangular group of pixels. You can then cut, copy, paste, or move those pixels.

- Eraser
  “Erases” pixels (as you could’ve guessed). When you click on a pixel, it changes the pixel to the background color.
• Pencil
  Used to change one pixel at a time. When you click on a pixel, the
  Pencil tool changes the pixel to the foreground color; if the pixel's
  already in the foreground color, it changes to the background color.

• Eyedropper
  Lets you pick a color from an existing icon. If you want to use a color
  again, you don't have to guess what it was; use the Eyedropper tool to
  select it for you. (The Eyedropper tool doesn't appear on black-and-
  white icons.)

• Paint bucket
  Changes lots of pixels at once. When you click on a pixel with the
  Paint Bucket tool, all the adjoining pixels of the same color change to
  the foreground color.

• Line tool
  Used to draw—surprise, surprise—a straight line.

• Solid and Open Rectangles
  Draw rectangles when you click on a point and drag the mouse. The
  Solid Rectangle tool draws a solid rectangle of the foreground color.
  The Open Rectangle tool draws just the outline of the rectangle.

• Solid and Open Rounded Rectangles
  Draw rounded rectangles when you click on a point and drag the
  mouse; otherwise, they work the same as the regular rectangle tools.

• Solid and Open Circles
  It may surprise you, but these tools draw circles when you use them.

If you want to learn how to use the tools, the best way is to practice. Pick an
icon and start drawing—just make sure not to save your changes if you don't
intend to keep your practice icon. You'll be whipping up icons in no time!
Why a Calculator?

Okay, sure a calculator seems like an obvious tool for anyone in an office. But do I use a calculator? No! When I need to add up figures, I look for the cash register. A calculator doesn't help me any! But every time I open that Apple menu, I have to look at that Calculator icon. This recipe tells you how to get rid of it and change it into a cash register.

Ingredients

Calculator (comes with the System software)

1. Open the System folder, then open the Apple Menu Items folder (within the System folder).
2. Click on the Calculator to select it.
3. Choose Duplicate from the file menu (or press ⌘-D).

The Finder creates a duplicate of the Calculator, called Calculator copy (see figure 4.3).

5. If you haven’t changed ResEdit’s basic preferences, the splash screen will come up when you launch ResEdit. Click on it to remove it. Again, if you haven’t changed the preferences, the Open File dialog box will appear automatically. If it doesn’t, choose Open from the File menu (or press ⌘-O).
6. Using the Open File dialog box, find Calculator copy, click on it to select it, and click on the Open button (see figure 4.4).
ResEdit displays the resources from Calculator copy (see figure 4.5).

7. Double-click the ic18 icon.

ResEdit displays a list of icons from the Calculator (see figure 4.6).
The icl8 icons are used to create the Finder's Calculator icon. Specifically, icl8 is used when the Macintosh is in 256-color mode. The Macintosh uses other kinds of icons for the Finder in other situations, but ResEdit enables you to work on all different kinds of icons at once.

8. Double-click on the Calculator icon (number -16000).
   ResEdit displays the icon editor (see figure 4.7).

![Figure 4.7](image)
The Calculator icon, seen from the Icon Editor window.

You want to change this icon into something completely different, so you have to erase the old image.

9. Choose Select All from the Edit menu (or press `A`).

10. Press the Delete key (or choose Clear from the Edit menu).
   This completely removes the old icon. Next you'll draw the new icon.

11. Find two black boxes on the left side of the editor. The lower box displays the foreground color—the color you'll draw with. Open the Foreground Color box (as you would a menu) and drag the mouse pointer to select a tan color (see figure 4.8).
Figure 4.8
Choosing a new color.

Figure 4.9
Selecting the Filled Box tool.

The Foreground Color box displays different colors depending on the selection made in the Color menu. The colors shown in figure 4.6 are from the Standard 256 Colors selection. The other choices present different lists of colors; the Apple Color Picker choice brings up the usual color wheel.

12. Click on the Filled Box tool, as shown in figure 4.9.
13. Using the Filled Box tool, click and drag in the icon area to create two tan rectangles, as shown in figure 4.10.

![Figure 4.10](image)

**Figure 4.10**
Two tan boxes for the cash register base.

14. Click on the Filled Circle tool to select it, then draw a circle to complete the cash register body (as shown in figure 4.11).

![Figure 4.11](image)

**Figure 4.11**
A filled circle to round out the cash register body.

15. Use the Foreground Color box (as in step 11) to choose a dark gray color for the cash register keys.

16. Click on the Pencil tool and draw the cash register keys (as shown in figure 4.12).

17. Using the Foreground Color box again (as in step 11), choose a brown color.
18. Choose the Open Box tool and outline the lower part of the register (as in figure 4.13).

19. Of course, the register needs paper. Use the Foreground Color box to choose a lighter gray color.

20. Choose the Pencil tool and draw the paper (as in figure 4.14).
That creates the basic 256-color icon. But now you need to create icons for the other situations (16-color and black-and-white). You also need to create small icons—you want your register to appear in the Apple menu, right? Fortunately, ResEdit can help you with these tasks.

21. Position the mouse pointer over the ic1B box on the right side of the window; the pointer changes to a hand. Click and hold the mouse button, and drag the ic1B icon over the ic14 box (see figure 4.15). Release the mouse button.

ResEdit draws you a cash register icon in the ic14 box.

22. Repeat step 21 for all the other icons: Drag ic18 to ICN#, ics8, ics4, ics#, and the two Mask boxes.
Again, ResEdit creates the other icons. But notice that the ICN# and ics# icons—the black-and-white icons—don’t look very good (see figure 4.16). ResEdit made a bad guess when substituting for the colors, so you’ll have to fix those icons yourself.

Figure 4.16
ResEdit creates a defective icon.

23. Click on the ICN# box.

24. Using the various tools, repair the icon (see figure 4.17).

Figure 4.17
The refurbished black-and-white icon.

25. As you did in step 21, drag the ICN# icon to the ics# box. This creates the small black-and-white icon.

Having an edited big icon to work with, ResEdit creates a fine little icon.

26. Click on the various types of icons to view the results.
Using the Icon menu, you can preview the icon against different backgrounds. Choose among white, gray, or black backgrounds, or choose the background of your Desktop (see figure 4.18).

You’ve finished your icon, so it’s time to try it out.

27. Choose Save from the File menu (or press `⌘-S`).

28. Choose Quit from the File menu (or press `⌘-Q`).

29. Once you’re back in the Finder, open the Apple Menu Items folder again.

   Wait—it’s the old Calculator icon! You’ve been robbed!

Not really. The Finder doesn’t want to look at the Calculator every time to figure out what icon to use, so it creates a set of invisible files (the Desktop files) to keep track of the icons. The Desktop file doesn’t know about the new icon, so it keeps using the old icon.

Never fear—we can make the Desktop learn about the new icon, but we’ll have to hide the old Calculator first.

Figure 4.18
Viewing your icons against the Desktop.
30. Place the calculator file—the original—into the Trash, but don’t empty the trash!

The reason you’re moving the original Calculator into the Trash is so that the Finder knows which icon to use when it rebuilds the Desktop. It won’t look in the Trash for an icon, so you’re safe. Just don’t empty the Trash!

When you’ve finished rebuilding the Desktop, you can take the old Calculator out of the Trash. The Finder will use the cash register icon for both versions of the Calculator, but there’s no reason not to keep the original Calculator around. You might want to go back to the original icon at some point.

31. Now that you’ve hidden the older icon, shorten the calculator copy name to just Calculator.

32. Now we’re ready to “rebuild” the Desktop. Choose Restart from the Special menu. While the computer restarts, hold down the Command and Option keys.

Warning: Rebuilding the Desktop destroys all comments stored in the Get Info boxes. Make sure you don’t need any of that information before you proceed!

33. After awhile, the Macintosh will ask if you want to rebuild the Desktop on your hard disk. You do, so click on the Okay button.

34. When the Macintosh is finished, open your Apple Menu Items folder again. There’s your new icon! Open the Apple menu to see the new small icon next to the Calculator.

There you go—your new cash register. Okay, so it’s not the most artistic creation, but the idea was to try your hand at changing the icon. How attractive can a cash register get, anyway?
Variations

The obvious variation is to create a different icon. To change the icon into something new, replace steps 9 through 20 with your own icon. The tools for drawing icons aren’t that hard to learn, so go ahead and try your hand.

You can also use this procedure to change just about any program icon. Just make sure to keep a pristine copy around so you can go back to the original if desired.

Icons, Icons Everywhere

Okay, so what are all those things you were messing with—ICN#, ic18, ic14, and so on? They’re different kinds of icons. A black-and-white monitor can’t display color icons, now can it? So there are different kinds of icons for different situations. Here they are:

<table>
<thead>
<tr>
<th>Finder Icon Types</th>
</tr>
</thead>
<tbody>
<tr>
<td>Icon</td>
</tr>
<tr>
<td><img src="image1" alt="ic18" /></td>
</tr>
<tr>
<td><img src="image2" alt="ic14" /></td>
</tr>
<tr>
<td><img src="image3" alt="ICN#" /></td>
</tr>
</tbody>
</table>
The other icon you’ll see in the Icon Editor window is the Mask. The Mask tells the Finder what the icon should cover up. When you put an icon on the Desktop, for instance, the icon shows up where the Mask is black, and the Desktop shows through where the Mask is white. The Mask is really part of the ICN# resource (and the small Mask is part of the ics# resource); that’s why there’s always an ICN# for every icl8 or icl4.

Environmental Special

It seemed like such a cute idea at the time. A little trash can in which to toss your unwanted files. But these are the nineties. Trash just isn’t cute anymore—we’ve got to be environmentally conscious. Besides, that file isn’t really trashed; you just reuse the disk space! Sounds pretty earth-friendly to me.

This recipe will take your passé and politically incorrect Trash icon and replace it with a friendly recycling bin—in green, to
be exact. It uses the Recycle Icon file included on the disk, but feel free to design your own replacement.

Ingredients

System

Recycle Icon file (on the disk that came with this book)

1. Open the System folder. Click on the System to select it, then select Duplicate from the File menu (or press ⌘-D).

   This creates a copy of the System, called System copy.

2. Launch ResEdit. If you haven’t changed ResEdit’s basic preferences, the splash screen will come up when you launch ResEdit. Click on it to remove it. Again, if you haven’t changed the preferences, the Open File dialog box will appear automatically. If it doesn’t, choose Open from the File menu (or press ⌘-O).

3. Using the Open File dialog box, find the Recycle Icon file (on the disk). Select it and click on Open.

4. You’ll see a set of icons: ic18, ic14, ICN#, ics8, ics4, and ics#. Choose Select All from the edit menu (or press ⌘-A) to select all the icons.

5. Select Copy from the Edit menu (or press ⌘-C).

6. Click on the Close box of the Recycle Icon window (or press ⌘-W).

7. Select Open from the File menu. Using the Open File dialog box, find the System copy file. Click on it, then click on Open.

8. Select Paste from the Edit menu.

   A dialog box appears (see figure 4.19).

![Figure 4.19](image)

The “Replace resources with the same ID?” dialog box.
9. Click on the Yes button.

ResEdit replaces the old Trash icons with the new ones. You don’t see any changes yet; maybe it’s a good idea to check on the icons.

10. Double-click on the ic18 icon.

ResEdit displays a series of icons. Icon 130 will be your empty recycling bin, and icon 134 will be your stuffed recycling bin.

11. Select Save from the File menu (or press ⌘-S).

12. Select Quit from the File menu (or press ⌘-Q).

13. Open the System folder again. Select the System file and drag it out of the System folder (to another folder on your hard disk, perhaps called “Disabled Items”).


15. Close the System folder. If the small System icon appears on the System folder, go on to the next step. If the icon doesn’t appear, that means that the Macintosh doesn’t know that the folder is a valid System folder. Try opening and closing the folder again; that should make the System icon appear on the System folder.

16. Select Restart from the Special menu.

When your Macintosh restarts, you will have a politically correct way to delete files! Instead of throwing them in a landfill, you can now recycle and reuse that precious natural resource, disk space.

Variations

If you want to create your own icons rather than use the ones provided on the disk, replace steps 3 through 11 above. Instead, open the System copy file and use the icon editor to edit both the empty Trash icon and the stuffed Trash icon.
Animation After Dark

Did you ever notice those little icons along the bottom of the screen when you start up your Macintosh? The icons from all the loading extensions? Have you noticed the After Dark icon, the way the little meteor streaks across the night sky?

Do you ever get sick of that meteor? Do you ever ask, "Can't this computer do better than that?"

This recipe shows how to change that shooting star into a streaking plane, replete with fiery exhaust. Maybe it won't increase your productivity...but every time you start up your Macintosh, you'll be able to say, "That's my animation!"

Ingredients

After Dark

1. Open the Control Panels folder located in the System folder. (Or choose Control Panels from the Apple menu.)

2. Select the After Dark icon, then choose Duplicate from the File menu (or press ⌘-D).

   A new file is created, called After Dark copy.

3. Launch ResEdit. If you haven't changed ResEdit's basic preferences, the splash screen will come up when you launch ResEdit. Click on it to remove it. Again, if you haven't changed the preferences, the Open File dialog box will appear automatically. If it doesn't, choose Open from the File menu (or press ⌘-O).

4. Use the Open File dialog box to locate After Dark copy, and open it.

5. Double-click on the icon.

   ResEdit displays the icons used for the After Dark animation (see figure 4.20).
Now you need to change the icons. After Dark always displays the icons in the same sequence (128, 129, -4064, 130, and 128 again); make sure that your new icons are animated in the same sequence.

6. Double-click on icon 129.

The Icon Editor window appears (see figure 4.21).

7. Using the Pencil tool, change the meteor into a plane as shown in figure 4.22.

8. Close the icon editor; double-click on icon -4064.

9. Again, change the meteor into a plane, as shown in figure 4.23.

10. Close the icon editor; double-click on icon 130.

11. Once again, change the meteor into a plane (see figure 4.24).
**Figure 4.22**
Changing the meteor into a plane.

**Figure 4.23**
Changing the meteor into a plane, again.

**Figure 4.24**
Once again, changing the meteor into a plane.
12. Choose Save from the File menu (or press ⌘-S).
13. Choose Quit from the File menu (or press ⌘-Q).
14. Open the Control Panels folder (inside the System folder).
15. Place After Dark (the original) into another folder (perhaps a “Disabled Items” folder).
16. Change the name of After Dark copy to After Dark.
17. You’re finished! Restart the Macintosh, and watch the icons to see your new animation.

Variations
Changing the meteor to a plane is just one of many possibilities; figure 4.25 shows another choice. When choosing a subject for your animation, keep in mind that the animation is quite rapid, so minute changes in details won’t be noticed. Remember, the first and last image is icon 128, so the animation has to end up where it started. To use a different image, just draw your own animation in steps 7, 9, and 11, instead of the plane. (You also may want to change the starting and ending icon; just repeat steps 6 and 7 for icon 128.)

Other programs use this strategy for animated icons; if you see a small animation for some extension when you start up your Macintosh, use ResEdit to see if cicons comprise the animation. If so, you can do your animation thing!

File Sharing Makeover
I always have trouble with the System 7 File Sharing icons. They just aren’t obvious in the way they should be (see figure 4.26). Folders with belts and wires attached, folders with black tabs, folders with heads on them, abstract
geometrical shapes—these images don’t tell me anything! They’re hard to decipher, and I dislike anything that slows me down when I have work to do.

![Image of File Sharing icons]

Of course, there is something you can do. You can change the icons to images that mean something to you. For instance, why not change the black-tabbed folder—the folder that you own—to a folder that has a pipe attached to it? That way, if you look at the folder, it resembles the other File Sharing icons and you’ll know this is a shared folder. It makes sense!

**Ingredients**

_System 7_

_A networked Macintosh_

(You don’t strictly need a networked Macintosh, but if you edit the icon for a non-networked Mac, you won’t ever see your changes. For suggestions about non-networked Macs, see the Variations for this recipe.)

1. Open the System folder. Click on the System to select it, then select Duplicate from the File menu (or press ⌘-D).

   This creates a copy of the System, called System copy.

2. Launch ResEdit.

3. If you haven’t changed ResEdit’s basic preferences, the splash screen will come up when you launch ResEdit. Click on it to remove it. Again, if you haven’t changed the preferences, the Open File dialog box will appear automatically. If it doesn’t, choose Open from the File menu (or press ⌘-O).

4. Using the Open File dialog box, open the System copy.

5. Double-click on the ic18 icon.

   The System 7 Finder icons appear (see figure 4.27). We want to edit the Shared Folder icon.

The icon editor appears (see figure 4.28).

7. Open the Foreground Color box (as you would a menu) and choose the white color.

8. Click on the Pencil icon.

9. Using the Pencil tool, remove the black tab from the folder. Also remove part of the folder to make room for the pipe (see figure 4.29).

10. Open the Foreground Color box again and choose a gray color.

11. Again using the Pencil tool, add a pipe to the folder (see figure 4.30).
12. To indicate that you own the folder—you control access to it—add a faucet to the pipe on the folder (see figure 4.31).

Figure 4.29
Removing the black tab from the folder.

Figure 4.30
Adding a pipe to the folder.

Figure 4.31
Adding a faucet to the folder.
13. Position the mouse pointer over the ic18 box on the right side of the window; the pointer changes to a hand. Click and hold the mouse button, and drag the ic18 icon over the ic14 box. Release the mouse button.

ResEdit automatically draws you a folder icon in the ic14 box.

14. Repeat step 13 for all the other icons: Drag the ic18 icon to ICN#, ics8, ics4, ics#, and the two Mask boxes.

Again, ResEdit creates the other icons. But notice that the Mask doesn’t look very good (see figure 4.32). ResEdit made a bad guess, so you’ll have to fix it yourself.

15. Click on the Mask box.

16. Using the various tools, fix the Mask (see figure 4.33).
17. Click on the various types of icons to view the results.

You can preview an icon against different backgrounds, using the Icon menu. Choose among white, gray, or black backgrounds, or choose the background of your Desktop.

18. Select Save from the File menu (or press ⌘-S).
19. Select Quit from the File menu (or press ⌘-Q).
20. Open the System folder again. Select the System file and drag it out of the System folder (to the Desktop or to another folder on your hard disk).
22. Close the System folder. If the small System icon appears on the System folder, go on to the next step. If the icon doesn’t appear, that means that the Macintosh doesn’t know that the folder is a valid System folder. Try opening and closing the folder again; that should make the System icon appear on the System folder.
23. Select Restart from the Special menu.

Now when File Sharing starts up, your old black-tabbed icons make a little more sense.

If you have no shared folders right now, here’s how to create one so that you can check out the new icon.

To share a folder, you need to turn on AppleTalk from the Chooser, and you need to turn on File Sharing from the File Sharing Setup control panel. This must all be done before you proceed.

25. Open the Shared Volume folder, and again choose New Folder from the File menu. Rename this new folder Shared Folder.

27. The Shared Volume folder should still be selected; choose Sharing... from the File menu.

28. Click on the “Share this item and its contents” check box, then close the Sharing dialog box. When the Macintosh asks you if you want to save these changes, click on the Save button.

29. Double-click on the Shared Volume folder.

Your new icon appears as the Shared Folder icon (see figure 4.34).

Figure 4.34
The Shared Folder icon in use.

Now you have a new Shared Folder icon. No longer will you wonder what the black tab means (or worse, not notice it).

Variations
Several variations to this recipe are obvious. You could change the rest of the sharing icons to extend the “water” metaphor. For instance, you could use the above steps to change the Shared Volume icon to a water tank; you could change the Remote Volume icon to a spigot. Just change step 6 to open whichever icon you want to edit. Steps 23 through 29 will change, too; to preview your new icon, just create a new one—the process varies for the different File Sharing icons.

Actually you can use this recipe to change just about any System 7 icon. If you want to change the default Folder icon, or the default File icon, or the Macintosh icon, just follow the same steps; just change step 6 to open the icon you want to change, and replace steps 23 through 29 with the procedure that creates a new icon of the kind you edited—if you changed the Folder, just create a new folder.
Colorized Icons

Hey, how about those icons in the alert boxes. You know, the triangle/exclamation point, the octagon/hand, and the talking man. They show up all the time—usually to tell you something's wrong. And believe me, those suckers are dull, dull, dull. If they're going to carry bad news, couldn't they at least be a little more exciting?

We've got a recipe here for adding color to those black-and-white icons. Let's spice up octagon/hand icon. Maybe a colorful warning won't be so depressing!

Ingredients
System 7

1. Open the System folder. Click on the System to select it, then select Duplicate from the File menu (or press -D).

   This creates a copy of the System; it is called System copy.

2. Launch ResEdit.

3. If you haven't changed ResEdit's basic preferences, the splash screen will come up when you launch ResEdit. Click on it to remove it. Again, if you haven't changed the preferences, the Open File dialog box will appear automatically. If it doesn't, choose Open from the File menu (or press -O).

4. Using the Find File dialog box, open the System copy.

5. Double-click on the ICON icon.

   The System 7 icons appear (see figure 4.35). We're going to copy the octagon/hand icon, so that we can use it when we create the color icon.

6. Double-click on the octagon/hand icon (note its ID number—0).

   The Icon Editor window appears.

7. Choose Select All from the Edit menu (or press -A).

8. Choose Copy from the Edit menu (or press -C).
Figure 4.35
The System 7 ICONs.

9. Close the ICON=0 window, then close the ICON window.

10. Double-click on the icon icon.


12. Double-click on the new icon (icon number 128).

13. Choose Paste from the Edit menu (or press \-V).

   You now have the basic icon; it's time to colorize it.

14. Open the Foreground Color box (as you would a menu) and choose a red color.

15. Click on the Paint Bucket tool, then click on the black part of the octagon.

   ResEdit changes the black to red.

16. Open the Foreground Color box again and pick the skin tone of your choice.

17. Again using the Paint Bucket tool, click on the hand.

   ResEdit fills the hand with the skin tone.


19. Type 0 (zero) in the ID box.
Whenever a color icon (a *cicn*) has the same ID number as a black-and-white icon (an *ICON*), System 7 uses the color icon instead. So any time you want to colorize a black-and-white icon, just create a color icon with the same ID number.


21. Select Save from the File menu (or press $S-$S).

22. Select Quit from the File menu (or press $Q-$Q).

23. Open the System folder again. Select the *System* file and drag it out of the System folder (to another folder on your hard disk, perhaps named “Disabled Items”).

24. Click on the System copy file. Rename it System.

25. Close the System folder. If the small System icon appears on the System folder, go on to the next step. If the icon doesn’t appear, that means that the Macintosh doesn’t know that the folder is a valid System folder. Try opening and closing the folder again; that should make the System icon appear on the System folder.

26. Select Restart from the Special menu.

You’ve colorized your icon!

27. To test your changes, try dragging the icon for your startup hard disk to the Trash, just as if you were ejecting a floppy disk. An alert appears, informing you that you can’t remove the startup disk from the Desktop—and the alert has your colorized hand! (Click on the OK button to get back to where you started.)

Now you’ve got a color icon. It’s bold, it’s colorful—it says “STOP!” where a black-and-white icon says “…stop?” Help stamp out drab icons—go for the color!
Variations
This recipe works for colorizing any black-and-white icon under System 7. Just create a color icon with the same ID number as the black-and-white icon you want to colorize. Is that easy or what?

The Flying W
I have a problem with that Microsoft Word icon, the little sheet of paper with a ‘W’ on it. The problem wouldn’t exist if Word were the only word processor that began with a ‘W.’

But there’s WriteNow. And WordPerfect. And even MacWrite has a ‘W’ in it. I get documents from clients all the time, and I don’t want to spend time trying to divine their choice in word processors! There’s no reason the Macintosh can’t tell me right off the bat.

Well, I’m not one to sit around whining about a problem. Either I get it fixed or I shut up. So I asked the folks here at the diner if there was anything they could do, and they concocted this tasty recipe for me. They transformed the Microsoft Word icon into something a little more distinctive.

I bought my Macintosh to make life easier, and I don’t like it to play guessing games when I’m hard at work. With this recipe, I know precisely what program I’m choosing.

Ingredients
System 7
Microsoft Word

1. Click on the Microsoft Word icon to select it, then select Duplicate from the File menu (or press ⌘-D).

   This creates a copy of Word; it is called Microsoft Word copy.
2. Launch ResEdit.
3. If you haven’t changed ResEdit’s basic preferences, the splash screen will come up when you launch ResEdit. Click on it to remove it. Again, if you
haven't changed the preferences, the Open File dialog box will appear automatically. If it doesn't, choose Open from the File menu (or press \-O).

4. Using the Open File dialog box, open the Microsoft Word copy.

5. Double-click on the ic14 icon.

The Microsoft Word icons appear (see figure 4.36). We want to edit the basic document icon.

6. Double-click on the document icon—icon number 130.

The Icon Editor window appears (see figure 4.37).

7. Using the icon editor tools, change the icon to something a tad more descriptive. We changed it to the icon shown in figure 4.38. To do so, we just used the Pencil tool and a few colors.
8. Position the mouse pointer over the ic14 box on the right side of the window; the pointer changes to a hand. Click and hold the mouse button, and drag the ic14 icon over the ics4 box. Release the mouse button.

ResEdit automatically draws you a small folder icon in the ics4 box.

9. Repeat step 8 for all the other icons: drag the ic14 icon to the ICN#, ics#, and the two Mask boxes.

Again, ResEdit creates the other icons. But notice that the ICN# and ics# icons—the black-and-white icons—don’t look very good (see figure 4.39). ResEdit made a bad guess, so you’ll have to fix those icons yourself.

10. Click on the ICN# box.
11. Using the various tools, fix the icon (see figure 4.40). (This abstract pattern of dots actually looks like “Word” when shrunk down to the small icon size.)

![Image of fixed icon]

**Figure 4.40**
The hand-fixed black-and-white icon.

12. As you did in step 8, drag the **ICN#** icon to the **ics#** box. This creates the small black-and-white icon.

   From an edited big icon, ResEdit creates a fine little icon.

13. Click on the various types of icons to view the results.

   You can preview the icon against different backgrounds, using the Icon menu. Choose among white, gray, or black backgrounds, or choose the background of your Desktop.

14. Select Save from the File menu.

15. Select Quit from the File menu.

   The icon has been changed, but the Finder doesn’t know that yet. It will go on happily using the old Microsoft Word icon until you tell it otherwise by rebuilding the Desktop.
16. Place the Microsoft Word file—the original—into the Trash, but don’t empty the trash!

The reason you’re moving the original Word application into the Trash is so that the Finder knows which icon to use when it rebuilds the Desktop. It won’t look in the Trash for an icon, so you’re safe. Just don’t empty the Trash!

When you’ve finished rebuilding the Desktop, you can take the old Word application out of the Trash. You’ll then have a backup copy on hand.

17. Click on the Microsoft Word copy file. Rename it Microsoft Word.

18. Now we’re ready to rebuild the Desktop. Choose Restart from the Special menu. While the computer restarts, hold down the Command and Option keys.

Warning: Rebuilding the Desktop destroys all comments stored in the Get Info boxes. Before you proceed, make sure you don’t need any of that information!

19. After awhile, the Macintosh will ask if you want to rebuild the Desktop on your hard disk. You do, so click the OK button.

20. When the Macintosh is finished, look for a Microsoft Word document. It will have the new icon!

You’ve remodeled the Finder icon for Microsoft Word documents. When you look at a Word document, you won’t wonder, “Does that ‘W’ stand for ‘Word,’ WriteNow,’ or ‘WordPerfect?’” It’ll say “Word” right on it!

Variations

This procedure works for just about any document icon that you want to change. What else could you change? How about the Excel document icon? Or the TeachText PICT icon? Take your pick—any icon that you have trouble figuring out can be changed.
Savory Small Icons

Sure, the large icons have all the glamour. Glitzy, bold—they can be striking. But there are lots of little icons that you probably never notice. Though small, those icons have interesting uses.

Editing small icons adds a dash of flavor to your System. If you do it right, you can fine-tune the look of your System and make it distinctively your own. This recipe tells you how to change the Trash icon that you see whenever you open the Trash. See the small icon below the title bar? Why not change it to a recycle icon?

Ingredients
System 7

1. Open the System folder. Click on the Finder to select it, then select Duplicate from the File menu (or press ⌘-D).

   This creates a copy of the Finder, called Finder copy.

2. Launch ResEdit.

3. If you haven't changed ResEdit's basic preferences, the splash screen will come up when you launch ResEdit. Click on it to remove it. Again, if you haven't changed the preferences, the Open File dialog box will appear automatically. If it doesn't, choose Open from the File menu (or press ⌘-O).

4. Using the Open File dialog box, open the Finder copy.

5. Double-click on the SICN icon.

   The Finder's small icons appear (see figure 4.41).


   The small icon editor appears (see figure 4.42).

7. Using the Pencil tool, change the small Trash icon to a small Recycle icon, as shown in figure 4.43.
Figure 4.41
The System 7 small icons.

Figure 4.42
The small Trash icon.

Figure 4.43
The new Recycle icon.

8. Select Save from the File menu (or press ⌘-S).
9. Select Quit from the File menu (or press ⌘-Q).
10. Open the System folder again. Select the Finder file and drag it out of the System folder (to the Desktop or to another folder on your hard disk).

11. Click on the Finder copy file. Rename it Finder.

12. Close the System folder. If the small System icon appears on the System folder, go on to the next step. If the icon doesn’t appear, that means that the Macintosh doesn’t know that the folder is a valid System folder. Try opening and closing the folder again; that should make the System icon appear on the System folder.

13. Select Restart from the Special menu.

14. After the Macintosh restarts, double-click on the Trash icon to open it. Look on the left side of the window, below the title bar. You’ll see your new small icon (see figure 4.44)

![Figure 4.44](image)

You’ve added just a hint of spice to your System and given it your own touch. The Recycle icon is more earth-friendly than the Trash icon, and your System shows a little more personality.

Variations

Of course, you don’t have to choose a Recycle icon. You can draw anything you choose in that space. You also don’t have to limit yourself to the Trash icon. Small icons are used for many different tasks; peer into the ICON resources, and you’ll find other ICONs to edit.
The Macintosh Mainstay

What did I tell ya? You wanna change the look and feel of your Macintosh, icons are the place to start. Change a few of 'em and you’ve made that Macintosh your own.

- There's all kinds of icons: Finder icons, dialog box icons, list icons, window icons...if you look, you can find icons doing just about anything.

Now, you'll find hundreds of icons to change when you start looking around, but there's really only a few different pointers to choose from. In the next chapter, Walt's serving up some pointers that are gonna make your mouth water.
Fresh Pointer Pie

The first time I laid eyes on a Macintosh, it was maybe 1985. In those days, nobody had hard drives—everything was done from floppies. If you didn't have a startup floppy handy, the Macintosh just sat there, blinking its silly question mark at you.

I walked into the store and saw a cute little computer with a cute little question mark. And a funny-looking box attached to the computer with a cord, next to the keyboard. "The mouse," the salesman said. "Go ahead, try it."

So I palmed the mouse and for the first time saw that little arrow flitting across the screen. I had no idea what that pointer was for, but it was just me, the question mark, and the arrow, and it was great! I sat there making the arrow swoop all over the screen.
The salesman brought over a disk and booted up some software (MacPaint, I think it was), and I ended up walking out of there with that cute little computer. But from that day on, whenever I think about the Macintosh, I remember that little arrow, all by itself, flitting across the screen.

Walt, I told myself, that pointer gives the Mac its special flavor.

When I came to the diner, I found out all about changing that pointer and others. I found out I could give a Mac a special flavor of its own, just by tweaking a watch here and there. (I also found out that the arrow is built into the Macintosh ROM, so you can’t change it. But that’s okay—some things are classics, so to speak.) So now, whenever I whip up a tasty treat, I try to talk the customer into a little pointer on the side. Just for that added flavor.

Here are a few of my favorite pointer recipes. They’re pretty simple, but I hope they’ll inspire you to try a few ideas of your own. Then you can personalize your Mac by creating your own pointers.

---

**The Missing I-Beam**

Now, I don’t know about you, but I never did like the text entry pointer—that I-beam. Ever try to find it on a crowded screen? It doesn’t show up! I always thought, “There has to be a way to make that thing stick out when you’re lookin’ for it.” I came to the diner, and they’d already figured out how.

Here’s their recipe. Just follow the directions, and they’ll tell you how to change that skinny I-beam into something that’ll show up when you need it.

---
Ingredients
System 7

1. Open the System folder. Click on the System to select it, then select Duplicate from the File menu (or press ⌘-D).

   This creates a copy of the System, called System copy.

2. Launch ResEdit.

3. If you haven't changed ResEdit's basic preferences, the splash screen will come up when you launch ResEdit. Click on it to remove it. Again, if you haven't changed the preferences, the Open File dialog box will appear automatically. If it doesn't, choose Open from the File menu (or press ⌘-O).

4. Using the Open File dialog box, find the System copy. Click on it to select it, then click on the Open button.

5. Double-click on the CURS icon.

   ResEdit displays the System cursors (see figure 5.1).

6. Double-click on the I-beam cursor (resource number 1).

   ResEdit warns that the resource is compressed. Click on the Yes button (you do want to edit it).

7. ResEdit displays the I-beam in the Cursor Editor window (see figure 5.2).
8. Click on the Pencil tool to select it.

9. Use the Pencil tool to edit the I-beam, as shown in figure 5.3.

10. You've completed your changes. To try out the pointer, select Try Cursor from the CURS menu (or press ⌘-T).

   ResEdit temporarily replaces the arrow pointer with the pointer you're editing—the I-beam, in this case. Move the pointer over different backgrounds to try it out.

11. Select Save from the File menu (or press ⌘-S).

12. Select Quit from the File menu (or press ⌘-Q).

13. Open the System folder again. Select the System file and drag it out of the System folder (to the Desktop or to another folder on your hard disk).

15. Close the System folder. If the small System icon appears on the System folder, go on to the next step. If the icon doesn’t appear, that means that the Macintosh doesn’t know that the folder is a valid System folder. Try opening and closing the folder again; that should make the System icon appear on the System folder.

16. Select Restart from the Special menu.

You’ve changed your I-beam cursor! Now you’ll want to see it in action.

17. Click the mouse pointer on the name of an icon on your hard disk.

The Finder highlights the name of the icon, so that you can change the name.

18. Move the mouse pointer over the highlighted name.

The Finder uses your new cursor when you edit the text of the icon name.

Well, you’ve changed a cursor. That I-beam never did show up when you wanted it to. The new cursor will be more obvious—no more hunting for lost cursors!

**Variations**

This recipe works for changing just about any pointer except the basic arrow cursor—that’s stored in the Macintosh ROM.

Some programs use cursors from the System; others use their own cursors. Check out various applications for cursors that you can edit.

**Time to Eat**

You know, I’m not much of a clock-watcher. I hate the feeling that I’ve only got so many minutes to do something—I like to take my time. So you can understand why I’m a bit put off by the watch cursor that shows up whenever the Finder is busy. “Time’s a-wastin’” it says; it makes me nervous.

I asked Walt if there was anything he could do. “Sure,” he said, “but what would be better?” We thought about it awhile, and it occurred to us that maybe some advertising wouldn’t hurt. Hence the cursor we’ve cooked up here.
This recipe changes the animated watch cursor into a symbol that's a little more, shall we say, user-friendly.

**Ingredients**

The Finder (System 7)

**Time to Eat** file (included on the disk that comes with this book)

1. Open the System folder. Click on the Finder to select it, then select Duplicate from the File menu (or press ⌘-D).

   This creates a copy of the Finder, called Finder copy.

2. Launch ResEdit.

3. If you haven’t changed ResEdit’s basic preferences, the splash screen will come up when you launch ResEdit. Click on it to remove it. Again, if you haven’t changed the preferences, the Open File dialog box will appear automatically. If it doesn’t, choose Open from the File menu (or press ⌘-O).

4. Using the Open File dialog box, find the **Time to Eat** file on the disk. Click on the file to select it, then click on the Open button.

5. Click on the **CURS** icon to select it (see figure 5.4).

   ![Figure 5.4](image)

   Selecting the **CURS** icon from the **Time to Eat** file.

6. Choose Copy from the Edit menu (or press ⌘-C).

   ResEdit copies the prefabricated cursors included on the disk.

7. Select Open from the File menu (or press ⌘-O).

8. Using the Open File dialog box, find the Finder copy. Click on it to select it, then click on the Open button.

ResEdit pastes in the new cursors that the Finder will use to create the animated cursor. Now you need to tell the Finder to use the new cursors for its animation.

10. Choose Time to Eat from the Window menu.

11. Click on the acur icon to select it (see figure 5.5).

12. Choose Copy from the Edit menu (or press ⌘-C).

ResEdit copies the cursor animation included on the disk.

13. Choose Finder copy from the Window menu.


15. A dialog box appears, asking if you want to assign a unique ID number to this resource. Click on the Yes button.

ResEdit replaces the default animation sequence with the one from the disk.

16. Select Save from the File menu (or press ⌘-S).

17. Select Quit from the File menu (or press ⌘-Q).

18. Open the System folder again. Select the Finder file and drag it out of the System folder (to the Desktop or to another folder on your hard disk).

19. Close the System folder. If the small System icon appears on the System folder, go on to the next step. If the icon doesn’t appear, that means that the Macintosh doesn’t know that the folder is a valid System folder. Try opening and closing the folder again; that should make the System icon appear on the System folder.
20. Click on the Finder copy file. Rename it Finder.

21. Select Restart from the Special menu.

You've changed the animated cursor. Now you'll want to try it out. Make the Finder perform an action that takes awhile, such as launching a large application or copying a folder full of files. (What constitutes a time-consuming action varies from computer to computer.)

Now you have a friendly advertisement for the diner! Your new animated cursor gives you something to think about while you wait on the Finder.

Variations

It's not hard to create your own animated pointer. Essentially, you create a set of new pointers (using the Create New Resource command from the Resource menu), edit the pointers to make your animation, and tell the Finder to use your pointer instead of the default.

The acur resource (see figure 5.6) is just a list of the pointers you want to use for your animation. The first field in the resource tells how many frames are in the animation. This is the number of pointers you created for your animation.

The other crucial part of the acur resource tracks which pointers you want to use when—in other words, the order of animation. If you created a new acur resource, there won't yet be any fields for the sequence of pointers. Click on “Frame number 1” and choose Create New Field from the Resource menu (or press ⌘-K) once for each icon in your animation. Then, enter the ID number of the appropriate pointer in each frame box. If your animation begins with pointer number 128, enter 128 in the “Frame number 1” box.

This sounds complicated, but it's really not that hard. Just make sure that your ID numbers match the actual IDs of the pointers, and you'll be okay.

When you create new pointers, make sure the animation “loops,” or returns to the first frame, by making the last pointer look almost exactly like the first pointer. Otherwise, the animation will jump from the last frame to the first, resulting in jerky animation.

Many applications have their own animated pointers. However, they sometimes still use the Finder animation when they ask the Finder to perform some task (such as copying a file). So you may see your new animated pointer pop up in places other than the Finder.
I've learned in my business that it pays to be precise. That's why the PageMaker cropping tool drives me crazy. I can never tell where the "hot spot" is—the part of the pointer that does the pointing, like the tip of the arrow. So I asked the diner people if there was anything they could do, and they showed me a nice addition to the pointer that makes a world of difference. Try this recipe, and you'll have a cropping tool that's easy to follow.

**Bumper Crop**

I've learned in my business that it pays to be precise. That's why the PageMaker cropping tool drives me crazy. I can never tell where the "hot spot" is—the part of the pointer that does the pointing, like the tip of the arrow. So I asked the diner people if there was anything they could do, and they showed me a nice addition to the pointer that makes a world of difference. Try this recipe, and you'll have a cropping tool that's easy to follow.

**Ingredients**

Aldus PageMaker

1. Find the PageMaker icon. Click on PageMaker to select it, then select Duplicate from the File menu (or press _-D)._This creates a copy of PageMaker, called PageMaker copy (give or take a version number).

2. Launch ResEdit.
3. If you haven't changed ResEdit's basic preferences, the splash screen will come up when you launch ResEdit. Click on it to remove it. Again, if you haven't changed the preferences, the Open File dialog box will appear automatically. If it doesn't, choose Open from the File menu (or press 

4. Using the Open File dialog box, find the PageMaker copy file, select it, and click on the Open button.

5. Double-click on the CURS icon.

ResEdit displays the PageMaker pointers (see figure 5.7).

6. Double-click on the Cropping tool (resource number 273).

7. ResEdit displays the Cropping tool in the Pointer Editor window (see figure 5.8).

8. Click on the Pencil tool to select it.

9. Use the Pencil tool to edit the Cropping tool, as shown in figure 5.9. Essentially, you want to add a cross-hair for the pointer.
10. Click on the Mask box. Edit the Mask as shown in figure 5.10.

11. Click on the hot spot tool—the x tool. Click at the center of the crosshairs, as shown in figure 5.11, to move the hot spot.
The hot spot is the part of the pointer that actually does the pointing—the tip of the arrow, for instance. It’s how the Macintosh knows exactly what you are pointing at when you move the mouse.

12. You’ll probably want to try out your new pointer. Select Try Pointer from the CURS menu (or press ⌘-T).

Instead of the standard arrow cursor, you can now use the Cropping tool. Move it over different backgrounds to see how it looks.

13. Select Save from the File menu (or press ⌘-S).

14. Select Quit from the File menu (or press ⌘-Q).

You’ve changed the Cropping tool; now you’ll want to see it in action.


16. Create a new PageMaker document. Click on the Cropping tool; you can now try out your new tool!

The new Cropping tool is much more precise. Now you can tell exactly where it’s pointing; the crosshairs make it obvious. No more fumbling for the corners of a graphic.

Variations

Many tools and pointers are not very precise. Usually, you can change them by adding something like a crosshair at the hot spot. Also, if you leave a hole in the Mask at the hot spot, the background shows through so you can see where you’re about to click.

You can use this same procedure for other pointers. One suggestion would be the Paint Bucket. If you’re not used to it, you may have trouble understanding exactly where the hot spot is.
So now you know a few tricks of the pointer trade. Really, pointers all work the same; editing them is just a matter of being creative with the pointer editor. Hands, swords, crosshairs, beachballs...there are scads of different pointers you can whip up.

Yes, pointers are flashy—they show up pretty obviously. But patterns are a bit more subtle. They show up only when you ask for them and (usually) don’t appear when you don’t want them. The next chapter explores patterns in some very subtle flavors.
Patterns are pretty easy, actually. They're one of my staples. Sure, there's more satisfaction in redoing a whole set of icons, say, but people notice if you don't do a good job with patterns.

I guess that's because everyone has fiddled with patterns at one time or another. Yup, even you. Ever hear of the Desktop pattern? You know that control panel, the one that lets you change the pattern beneath your icons? Change that, and you're changing patterns.

Now some will say that's all the pattern editing you'll ever want to do. And yes, you can get by if you don't do more than play with the General Controls control panel—it does let you do some interesting things. But if you start changing patterns with ResEdit, you can really make things different. More colors. Bigger patterns. A lot that you can't do with that Control Panel, you can do with ResEdit.
Okay, so patterns are not the most glamorous or complicated resources. “I already know how to change them,” you say. But patterns are one of the basics, and if you try a few of these recipes, you’ll learn a bit more about what goes on inside that computer of yours. Trust me on this.

A word of advice before you start: if you are modifying the System or Finder files, make sure that you have a start-up floppy disk handy before you start. If you have any problems with the following recipes, check out Chapter 3, “Heimlich Maneuvers.”

**A Plethora of Patterns**

How’d the Macintosh get a reputation for “personality”? The Desktop patterns. From the General Controls control panel, you can pick any pattern you like and use different shading combinations—even full color, if you’ve got a color monitor.

But check out those stock patterns—tacky, tacky, tacky! I saw wallpaper like that in an apartment once. I made the landlord take it out before I’d move in.

Well, the good news is at least you can edit those patterns using the Control Panel. But what if you like that kind of wallpaper and want to make something even wilder?

The answer is, you add patterns rather than change the ones that are there. Using ResEdit, of course.

**Ingredients**

System 7

1. Open the System folder. Click on the System to select it, then select Duplicate from the File menu (or press ⌘-D).

   This creates a copy of the System, called System copy.

2. Launch ResEdit.
3. If you haven't changed ResEdit's basic preferences, the splash screen will come up when you launch ResEdit. Click on it to remove it. Again, if you haven't changed the preferences, the Open File dialog box will appear automatically. If it doesn't, choose Open from the File menu (or press `§-O).

4. Using the Open File dialog box, find the System copy. Click on it to select it, and then click on the Open button.

5. Double-click on the ppt# icon.

   ResEdit displays the color patterns used by the System (see figure 6.1).

   ![Figure 6.1](image)
   The System patterns.

6. Double-click on the Desktop patterns (resource number 0).

7. A dialog box appears, asking if these are patterns for your Desktop file (see figure 6.2).

   ![Figure 6.2](image)
   The ppt# dialog box.

   Click on Yes.
8. ResEdit displays the Desktop patterns in the pattern editor (see figure 6.3).

Figure 6.3
The Desktop patterns.


ResEdit creates a new, blank pattern.

10. There are two black boxes on the left side of the editor. The lower of the two displays the foreground color—the color you will draw with. Open the Foreground Color box (as you would a menu) and drag the mouse pointer to select a dark green color (see figure 6.4).

Figure 6.4
Selecting a green color.
11. Click on the Paint Bucket tool to select it.

12. Position the Paint Bucket tool inside the pattern box, and click the mouse button to fill the pattern with the green color (see figure 6.5).

13. As you did in step 10, open the Foreground Color box and select a gold color.

14. Click on the Pencil tool icon.

15. Using the Pencil tool, draw a fleur-de-lis to complete the pattern (see figure 6.6).
16. To test your pattern, select Try Pattern from the Pattern menu. ResEdit displays the pattern instead of the Desktop pattern.

17. (Optional) If you want to, you can create a black-and-white version of your pattern. Position the mouse pointer over the box labeled Color. Click and hold the mouse button, and drag the pattern to the box labeled B &W (see figure 6.7). Release the mouse button; ResEdit creates a black-and-white pattern.

Figure 6.7
Creating a black-and-white version of a pattern.

You can edit this pattern if you want to improve upon ResEdit’s guesses; simply use the Pencil tool.

The System needs a black-and-white version of this pattern only if you change your display to black and white; in that case, the System substitutes the black-and-white pattern for the color pattern. The default is a plain white pattern. If you don’t plan to set your display to black and white, you probably won’t need a black-and-white pattern.
18. You’ve created a new pattern. To create others, repeat steps 9 through 16 above. Each time, try drawing something different. You can replace steps 10 through 15 with your own pattern designs. Figure 6.8 illustrates a few ideas.

19. Select Save from the File menu (or press ⌘-S).

20. Select Quit from the File menu (or press ⌘-Q).

21. Open the System folder again. Select the System file and drag it out of the System folder (to the Desktop or to another folder on your hard disk).

22. Click on the System copy file. Rename it System.

23. Close the System folder. If the small System icon appears on the System folder, go on to the next step. If the icon doesn’t appear, that means that the Macintosh doesn’t know that the folder is a valid System folder. Try opening and closing the folder again; that should make the System icon appear on the System folder.
24. Select Restart from the Special menu.
Now that you’ve got your new patterns, you’ll want to try them out.

25. Select Control Panels from the Apple menu.
The Control Panels folder opens.

26. Double-click on the General Controls control panel.

27. Click on the arrows beneath the box that displays the Desktop pattern.
As you move through the patterns, you will eventually come to the new patterns you created.

28. If you want to use one of your new patterns, click on your chosen pattern when it appears in the box.

Now you have a whole new set of patterns to try out. You could have just changed the stock patterns using the General Controls control panel, but why go halfway? Using ResEdit you can add patterns and fancy them up with the whole complement of drawing tools. Cool!

Variations
You can create all the patterns you want using this method, as long as you use only eight colors—that’s all the Control Panel can handle. ResEdit will stop you if you try to use too many colors.

If you use a black-and-white monitor, you can edit the black-and-white patterns, too. In step 5, click on the PAT# icon instead of the one mentioned. (The dialog box mentioned in step 7 won’t appear; don’t worry about that.)

Editor, Edit Thyself

Of course I think ResEdit is a great program—that’s why I spend so much time at the diner. But it’s not perfect. Take the patterns it supplies, for instance (see figure 6.9). Certain patterns that I like to use just don’t show up in this menu.
Now, I can go in and create those patterns by hand, using the Pencil tool. But who can spend that kind of time? If I plan to use a pattern more than a few times, it makes more sense to add the pattern to ResEdit's supply. That way, I have the pattern "right at hand," so to speak.

This recipe shows how to do just that—add patterns to the ones that ResEdit already supplies.

**Ingredients**
ResEdit (included on the disk)

1. Click on the ResEdit icon to select it, then select Duplicate from the File menu (or press \\&-D).

   This creates a copy of ResEdit, called ResEdit copy.

2. Launch ResEdit.
3. If you haven’t changed ResEdit’s basic preferences, the splash screen will come up when you launch ResEdit. Click on it to remove it. Again, if you haven’t changed the preferences, the Open File dialog box will appear automatically. If it doesn’t, choose Open from the File menu (or press ⌘-O).

4. Using the Open File dialog box, find the ResEdit copy file. Click on it to select it, then click on the Open button.

5. Double-click on the PAT# icon.

ResEdit displays the black-and-white patterns used by ResEdit (see figure 6.10).

Figure 6.10
The ResEdit black-and-white pattern lists.

Note
ResEdit uses both black-and-white and color patterns. We’ll edit both, but if you like you can change only one or the other—you’ll just see different pattern lists in different editors.
6. Double-click on resource ID 3100—the patterns used for the ResEdit editors.

ResEdit displays the list of patterns (see figure 6.11).

7. You need to insert your new patterns at the right side of the list, rather than at the beginning. (You don’t want to change the default black pattern, for instance.) So, scroll through the list until you find the dark herringbone pattern (just before the plain white pattern), and click on it (see figure 6.12).


ResEdit creates a new, blank pattern.

9. Click on the Line tool to select it.

10. Using the Line tool, create a pattern of vertical stripes (see figure 6.13).
11. Now we want to create the second pattern. Scroll to the end of the list of patterns, and click on the white herringbone pattern—the last pattern in the list.


   ResEdit creates a new, blank pattern.

13. Click on the Line tool to select it.

14. Using the Line tool, create a pattern of horizontal stripes (see figure 6.14).

15. Close the PAT# Editor window and then close the PAT#s window.

   You have created the black-and-white patterns; the next step is to create the color patterns. The steps are virtually the same, with a few twists.
16. Double-click on the ppt# icon.

ResEdit displays the color patterns used by ResEdit (see figure 6.15).

![Figure 6.15](image)
The ResEdit color fill patterns.

17. Double-click on resource ID 3100—the patterns used for the ResEdit editors.

ResEdit displays the list of patterns (see figure 6.16).

![Figure 6.16](image)
ResEdit patterns seen in the Pattern Editor window.

*Note*

Yes, these are color patterns, even though they look black-and-white. I'll explain in a minute.
18. Again, you want to insert your new patterns at the right side of the list, rather than at the beginning. Scroll through the list until you find the dark herringbone pattern (just before the plain white pattern), and click on it (see figure 6.17).

![Figure 6.17](image)

Clicking on the dark herringbone pattern.

So far, this has been the same as editing the black-and-white patterns, but now things get a little bit different.

19. While holding down the Option key, open the Resource menu.

Notice that the Insert New Pattern menu item changes to Insert Relative Pattern (see figure 6.18).

![Figure 6.18](image)

Select Insert Relative Pattern. ResEdit creates a new, blank pattern.
This explains why the patterns look black and white even though they're really color patterns. (I told you I'd explain that!) With relative patterns, the black parts are replaced with the foreground color, and the white parts are replaced with the background color. This way, you can create a whole new range of patterns just by changing the foreground and background colors in the pattern editor.

20. Click on the Line tool to select it.


22. Position the mouse pointer over the Color box. Click and hold the mouse button, and drag the mouse pointer down to the B & W box (see figure 6.19). Release the mouse button.

ResEdit creates a black-and-white version of the color pattern.

23. Now we want to create the second pattern. Scroll to the end of the list of patterns, and click on the white herringbone pattern—the last pattern in the list—just as you did before.

24. While holding down the Option key, open the Resource menu. Select Insert Relative Pattern.

ResEdit creates a new pattern.
25. Click on the Line tool to select it.

26. Using the Line tool, create a pattern of horizontal stripes, just as you did in step 14.

27. As you did in step 22, position the mouse pointer over the Color box. Click and hold the mouse button, and drag the mouse pointer down to the B & W box. Release the mouse button.

ResEdit creates the black-and-white version of the color pattern.

28. Choose Save from the File menu (or press ⌘-S).

29. Choose Quit from the File menu (or press ⌘-Q).

30. To try out your changes, all you need to do is open some resource that uses a pixel editor—an icon, for example. Double-click on the ResEdit copy icon.

The Finder launches the copy of ResEdit that you modified.

31. Open a file to test your new patterns. (I used a System copy file.)

32. Double-click on a resource that uses a pattern editor—the ic18 icon, for example. Open up one of the icons within that resource.

ResEdit displays the familiar icon editor.

33. Open the Fill Pattern pop-up menu, as shown in figure 6.20. Your new patterns take their place on the right side of the pattern lists.

34. Once you’re happy with your changes, put away your old copy of ResEdit.

Figure 6.20
New patterns seen in the Fill Pattern pop-up menu.
Rename the original ResEdit file as Original ResEdit (or something similar). Change the name of the ResEdit copy file to ResEdit.

So, you've added a couple of patterns to ResEdit itself. If you find yourself creating the same patterns repeatedly in ResEdit, you can avoid the hassle by adding those patterns, just as you did these.

**Variations**

Of course, you can add more patterns to ResEdit, or add different patterns than those described here. Just repeat the process, changing the new patterns as you desire.

Most paint programs use fill patterns, too; you can use the same basic process to change their fill patterns. Just keep a pristine copy of your paint program on hand in case you want to return to the original.

**Calculated Patterns**

If you're moving through these recipes in order, you've already heard Walt complain about the Macintosh Calculator. He says it should really be a cash register. Earlier, he showed you a recipe that changed its icon to actually look like a cash register.

The only problem is, the Calculator doesn't look like a cash register inside—once you launch it, it still looks the same. Pretty bland, if you ask me. Blue-gray surface, with white buttons. (Sigh.) Not too exciting at all.

Say, why not spice it up a bit?

This recipe changes the boring front of the Calculator to a jazzier pattern. Doesn't look any more like a cash register...but it's a lot more fun!

**Ingredients**

Calculator (which comes with the System software)

1. Open the System folder; open the Apple Menu Items folder (enclosed within the System folder).
2. Click on the Calculator to select it.
3. Choose Duplicate from the file menu (or press `F-D`).

The Finder creates a duplicate of the Calculator, called Calculator copy.


5. If you haven't changed ResEdit's basic preferences, the splash screen will come up when you launch ResEdit. Click on it to remove it. Again, if you haven't changed the preferences, the Open File dialog box will appear automatically. If it doesn't, choose Open from the File menu (or press `F-O`).

6. Using the Find File dialog box, find Calculator copy, click on it to select it, and click on the Open button.

   ResEdit displays the resources from Calculator copy (see figure 6.21).

7. Double-click on the ppat icon.

   **Figure 6.21**
   The Calculator resources.

   ![Calculator resources](image)

   ResEdit displays the Calculator's single pattern—the pattern it uses for the front of the calculator (see figure 6.22).
The ppat resource is similar to the ppt# resource used in the previous two recipes. The difference is that the ppat resource is just one pattern, whereas the ppt# resource is a list of patterns.

We're going to create a pretty radical pattern—a series of lightning bolts. First we get rid of the old pattern.


ResEdit erases the entire pattern.

10. There are two black boxes on the left side of the editor. The lower of the two displays the foreground color—the color you will draw with. Open the Foreground Color box (as you would a menu) and drag the mouse pointer to select a blue color (see figure 6.24).

![Figure 6.24](image)

Selecting a blue color.

11. Click on the Paint Bucket tool to select it.

12. Position the Paint Bucket tool inside the pattern box, and click the mouse button to fill the pattern with the blue color.

13. As you did in step 10, open the Foreground Color box; this time select a yellow color.

14. Click on the Pencil tool icon.

15. Using the Pencil tool, draw a lightning bolt to complete the pattern (see figure 6.25).
16. Position the mouse pointer over the Color box. Click and hold the mouse button, and drag the mouse pointer down to the B & W box (see figure 6.26). Release the mouse button.

ResEdit creates a black-and-white version of the color pattern.

17. Choose Save from the File menu (or press ⌘-S).

18. Choose Quit from the File menu (or press ⌘-Q).

You've created the new pattern; now try it out.
19. Open the Apple menu; choose the Calculator copy.

The new Calculator appears, with the new pattern (see figure 6.27).

![Calculator](image)

**Figure 6.27**
The new Calculator.

20. You’re now essentially done; there’s no reason that you can’t use both calculators. However, you might want to change the name of the Calculator you created. Open the Apple Menu Items folder. Change the name of Calculator copy to Colorful Calculator, or something similar.

You have created a new, more vibrant Calculator! True, the new look doesn’t add functionality—or even look more like a cash register—but it’s far more electrifying than plain blue dots.

**Variations**

Naturally, you don’t have to use lightning bolts. Just modify steps 10 through 15, creating your own pattern instead.

This recipe works for changing just about any pattern. The catch is, different programs use patterns in different ways. Look for the ppat resources in different programs; you may find something interesting.

**Desktop Diversity**

So you think the Desktop patterns are pretty special, huh?. I bet you even think the patterns you created in the first recipe of this chapter are pretty neat.

I’ve got news for you.
Those patterns are kindergarten stuff! Think about it. You’re limited to eight colors in an eight-by-eight box. Whoopee. That’s not a lot to work with.

Now, what if I said you could make yer patterns bigger? With more colors? In non-square shapes? Now that would make for an interesting Desktop!

And that’s what we’re here to show you—how to liven up your Desktop. A few Desktop patterns are included on the disk. We’ll show you how to use ‘em.

**Ingredients**

*System 7*

**Desktop Patterns file (included on disk)**

1. Open the System folder. Click on the System to select it, then select Duplicate from the File menu (or press `⌘-D`).

   This creates a copy of the System, called *System copy*.

2. Launch ResEdit.

3. If you haven’t changed ResEdit’s basic preferences, the splash screen will come up when you launch ResEdit. Click on it to remove it. Again, if you haven’t changed the preferences, the Open File dialog box will appear automatically. If it doesn’t, choose Open from the File menu (or press `⌘-O`).

4. Using the Open File dialog box, find the Desktop Patterns file. Click on it to select it, and then click on the Open button.

5. Click on the *ppat* icon to select it.

6. Select Copy from the Edit menu (or press `⌘-C`).

7. Select Close from the File menu (or press `⌘-W`).

8. Choose Open from the File menu (or press `⌘-O`).

9. Using the Open File dialog box, find the *System copy*. Click on it to select it, then click on the Open button.

10. Double-click on the *ppat* icon.

   ResEdit displays the Desktop pattern used by the System (see figure 6.28).
11. Select Paste from the Edit menu (or press ⌘-V).

ResEdit adds the resources you copied from the Desktop Patterns file to the System copy (see figure 6.29).

12. Click on the standard Desktop pattern (ID number 16) to select it.


ResEdit displays the Resource Info window (see figure 6.30).

14. In the ID: box, change the number to 140 (or any number that isn't taken already).

15. Select Close from the File menu (or press ⌘-W).

16. Click on the pattern that you want to use as your Desktop pattern to select it.

18. In the ID: box, change the number back to 16.

19. Select Save from the File menu (or press ⌘-S).

20. Select Quit from the File menu (or press ⌘-Q).

21. Open the System folder again. Select the System file and drag it out of the System folder (to the Desktop or to another folder on your hard disk).

22. Click on the System Copy file. Rename it System.

23. Close the System folder. If the small System icon appears on the System folder, go on to the next step. If the icon doesn’t appear, that means that the Macintosh doesn’t know that the folder is a valid System folder. Try opening and closing the folder again; that should make the System icon appear on the System folder.

24. Select Restart from the Special menu.
When your Macintosh restarts, you'll have a whole new Desktop pattern! None of those wimpy patterns for you—you want a full-blown, large-scale pattern.

**Variations**

You don’t have to use the patterns created here; you can create your own. Open the `ppat` resource in the `System` copy, and select Create New Resource from the Resource menu. You will have a new resource to edit; however, you may want to try selecting Pattern Size from the `ppat` menu. You can then click on the new size of pattern you want to create—up to 64 pixels by 64 pixels.

Then, all you have to do is create your pattern and continue from step 12 above. Voila! You’ve created a new Desktop pattern, unlimited by the constraints of the General Controls panel.

> **Note**

When you create a Desktop pattern that goes beyond the normal constraints (eight by eight, with no more than eight colors), the General Controls control panel can no longer create color Desktop patterns. To return the System to its state of pristine innocence, assign ID number 16 to the original Desktop pattern. With the Desktop pattern back under its usual limits, the Control Panel will work normally once again.

**Fried Patterns Redux**

See, I told you patterns weren’t so hard. When you consider how much you can change your Mac’s appearance when you change the patterns, seems like pattern editing is pretty worthwhile after all!

Now, most of the patterns you’ll find are Desktop patterns; the rest are mainly fill patterns. But if you keep looking, you’ll find programs—like the Calculator—that use patterns for more than that. The thing is, programs use patterns to cover large areas. They just keep repeating the pattern. So, if you change a pattern, you can really affect the look of a program.
Most people wouldn't know a file type if it walked up and hit 'em over the head with a shovel. But they know what PICT means. They even know enough that they write "PICT," and not "pict" or "Pict."

Yep, lots of people recognize PICT files when they show up. But did you know there are PICT resources, too? D'you think that programs draw every graphic that they use from scratch? 'Course not—that could take forever. Besides, a program that says "put that picture over there" is a heckuva lot easier to write than a program that tries to describe every picture it uses.

Lots of programs use PICTs. All those fancy "splash screens" that appear when you start up a program? Those are PICTs. If you wanted to, you could probably dive in there and add all new splash screens.
Whoopee. That’s not a lot of fun, unless you’re into graffiti.

But from time to time, you’ll come across PICTs that are a little more interesting—worth the time it takes to edit them. And it does take time. ResEdit can’t edit PICTs; it only lets you look at them. So you need another program to change the PICTs.

And you can’t just go in and change every PICT in sight. Sometimes software gets ornery if it doesn’t find the PICT it’s looking for. Take the System, for instance. There are some neat PICTs in there—but change them to something that seems perfectly reasonable, and the whole thing can go to pot.

So changing PICTs isn’t a cakewalk. Why bother? Well, if you can find the right PICTs, and can change them without too much trouble, you can do a lot more than you could just using ResEdit on its own.

To make things easier, Walt has whipped up a few PICT resources that he put on the disk. He said he wanted people to get the chance to change a few things even if they didn’t have a paint program to edit PICTs with.

Here’s a few recipes to get you started with PICTs. No hassle, no fuss. That’s what the diner’s all about.

**Sound Slider**

You know, the Macintosh uses quite a few metaphors, and not all of them are really that intuitive.

Take the slider, for example.

When’s the last time you used a slider? Well, if you have a graphic equalizer on your stereo, you’ve seen that slider recently. (When’s the last time you fiddled with your graphic equalizer?)

But if you’re like me (and prefer not to add all that potential noise into your stereo system), you don’t often see sliders.

So why does the slider have to look like it does?

Sure, there’s no practical reason to change what you’ve got. But who needs a practical reason? There’s not a lot you can do with that limited space, but sometimes, it’s nice to change something just to change it.

And no, that does not apply to graphic equalizers and stereos.
Ingredients
Sound control panel (which comes with System 7)
NewSlider file (included on disk)

1. Open the Control Panels folder. Click on the Sound control panel to select it, then select Duplicate from the File menu (or press ⌘-D).

   This creates a copy of the Sound control panel; it is called Sound copy.

2. Launch ResEdit.

3. If you haven’t changed ResEdit’s basic preferences, the splash screen will come up when you launch ResEdit. Click on it to remove it. Again, if you haven’t changed the preferences, the Open File dialog box will appear automatically. If it doesn’t, choose Open from the File menu (or press ⌘-O).

4. Using the Open File dialog box, find the NewSlider file. Click on it to select it, and then click on the Open button.

   Since the NewSlider file is a ResEdit file, you could just double-click on the file to open it, if you wanted to. Other files and applications don’t work that way—applications have a habit of launching themselves when you double-click them, for instance—but you can use the System 7 drag-and-drop feature to open any file with ResEdit. Just drag the file or application you want to edit to the ResEdit icon, watch the icon become highlighted, and let go of the mouse button. ResEdit will launch, and it will open your file. Just a handy little trick to keep around, for future reference!

5. Click on the PICT icon to select it.

6. Select Copy from the Edit menu (or press ⌘-C).

7. Select Close from the File menu (or press ⌘-W).

8. Choose Open from the File menu (or press ⌘-O).

9. Using the Open File dialog box, find the Sound copy. Click on it to select it, then click on the Open button.
10. Double-click on the PICT icon.

ResEdit displays the PICTs used by the Sound control panel (see figure 7.1).

![Figure 7.1](image)
The Sound control panel’s PICTs.

ResEdit displays the PICTs in squares; if the PICT is bigger than the square, ResEdit reduces the PICT to make it fit the square. (It may even reduce the PICT disproportionally, creating a rather squashed PICT.) To see a PICT at full size, double-click on it.

11. Select Paste from the Edit menu (or press ⌘-V).

A dialog box appears, asking if you want to replace the PICTs with the same ID (see figure 7.2).

![Figure 7.2](image)
The "Replace resources...?" dialog box.

12. Click on the Yes button.

ResEdit replaces the slider PICTs with the PICTs you copied from the NewSlider file.

13. Select Save from the File menu (or press ⌘-S).
14. Select Quit from the File menu (or press ⌘-Q).

15. To test your changes, double-click on the Sound copy file. Your new slider will be in the same location.

16. Under System 7, you can use either control panel—Sound or Sound copy. However, if you find it confusing to have duplicate control panels around, you can move the original out of the way.

To do so, select the Sound file and drag it out of the Control Panels folder (to the Desktop or to another folder on your hard disk).

17. Click on the Sound copy file. Rename it Sound.

Now, you're using a Sound control panel with a whole new look.

**Variations**

If you have a program that can edit PICT bitmaps, such as Adobe Photoshop or Claris MacPaint, you can create your own slider. (We'll tell you how to edit PICT resources in a moment.) Just be sure you don't make the new PICTs any bigger than the old PICTs.

Many programs use sliders like the one in the Sound control panel. If you find another program that uses a slider, you may be able to replace it, too, with the NewSlider PICTs. Just change the Resource ID numbers so that the NewSlider PICTs have the same ID number as the slider resources in the program that you're changing. (To change resource ID numbers, select the resource, choose Get Resource Info from the Resource menu—or press ⌘-I—and change the number in the Resource ID text box.) Remember, the slider PICTs in the program must exactly match the size of the slider PICTs in the NewSlider file.

---

**Editing PICT Resources**

Editing PICTs requires a program that has that capability—usually a color paint program. Almost every paint program can handle PICTs, so you're limited only by what you want the program to do.

The first step in editing a PICT resource is to get the resource into your paint program. To do so, follow these steps:
1. Launch ResEdit.

2. Open the program that has the PICT you want to change.

3. Double-click on the PICT icon.

4. Double-click on the PICT you want to edit.

5. Select Copy from the Edit menu (or press `C-C ).


7. Launch your paint program.

8. Create a new document that’s at least as big as the resource you’re going to edit.

9. Select Paste from the Edit menu (or press `C-V ).

   You now have the PICT in your paint program; you can edit as you would a normal picture. When you’ve made the changes you want, follow the steps below to complete the process.

10. Using the rectangular selection tool from your paint program, select the picture you edited. Your selection should be exactly the same dimensions as the original image.

11. Select Copy from the Edit menu (or press `C-C ).

12. Quit your paint program.

13. If you haven’t changed ResEdit’s basic preferences, the splash screen will come up when you launch ResEdit. Click on it to remove it. Again, if you haven’t changed the preferences, the Open File dialog box will appear automatically. If it doesn’t, choose Open from the File menu (or press `O ).

14. Open the program or file that has the PICT you want to change.

15. Double-click on the PICT icon.

16. Double-click on the PICT you want to edit.

17. Select Paste from the Edit menu (or press `V ).
ResEdit replaces the old PICT with the one that you copied from the paint program. It’s really not that hard, as long as you have a paint program that can handle PICTs.

Not all programs can handle changes to their PICTs this easily; that’s why you keep a backup copy of the program. But if you look around, you’ll find quite a few programs with PICTs that work well when edited.

If you save your edited picture as a normal paint document, you can easily reopen the picture when you want to make more changes.

**Alarm Alterations**

I really get depressed if I can’t shake things up once in awhile. I hated wearing this uniform until I started changing my hairstyle and wearing different shoes—just to avoid the same old boring thing every day.

Hey, that’s the way I feel about a lot of things, the Macintosh included. One day I’m setting the Alarm Clock on my computer, and I notice I’m getting pretty tired of those funky little controls (see figure 7.3). So I say to myself, how about doing something different?

Well, Walt showed me how, and I came up with my own set of controls. They work just like the old ones, but they’re my very own creation. Know what’s even better? I can change them again whenever I want.
This recipe shows you how to change the Alarm Clock controls by adding the controls I made up. They don’t work any different but, hey, why not make a change for a change?

**Ingredients**

Alarm Clock desk accessory (which comes with System 7)

NewAlarm file (included on disk)

1. Open the Apple Menu Items folder. Click on the Alarm Clock to select it, then select Duplicate from the File menu (or press `~D`).

   This creates a copy of the Alarm Clock, called *Alarm Clock copy*.

2. Launch ResEdit.

3. If you haven’t changed ResEdit’s basic preferences, the splash screen will come up when you launch ResEdit. Click on it to remove it. Again, if you haven’t changed the preferences, the Open File dialog box will appear automatically. If it doesn’t, choose Open from the File menu (or press `~O`).

4. Using the Open File dialog box, find the NewAlarm file. Click on it to select it, then click on the Open button.

5. Click on the **PICT** icon to select it.

6. Select Copy from the Edit menu (or press `~C`).

7. Select Close from the File menu (or press `~W`).

8. Choose Open from the File menu (or press `~O`).

9. Using the Open File dialog box, find the *Alarm Clock copy*. Click on it to select it, then click on the Open button.

10. Double-click on the **PICT** icon.

    ResEdit displays the PICT used by the Alarm Clock desk accessory (see figure 7.4).
11. Select Paste from the Edit menu (or press $\mathsection-V$).

A dialog box appears, asking if you want to replace the PICTs with the same ID (see figure 7.5).

12. Click on the Yes button.

ResEdit replaces the PICT with the PICT you copied from the NewAlarm file.

13. Select Save from the File menu.

14. Select Quit from the File menu.

15. To test your changes, double-click on the Alarm Clock copy file. Your new controls will appear. Click on the button on the right side of the window to see the expanded set of controls (see figure 7.6).
16. There’s no reason not to keep both alarm clocks around; you can use either one depending on the occasion. However, you might not want to keep two alarm clocks in your Apple menu—that menu gets crowded pretty quick.

If you want to remove the older alarm clock, select the Alarm Clock file and drag it out of the Apple Menu Items folder (perhaps to the Desktop, or to another folder on your hard disk).

17. Click on the Alarm Clock copy file. Rename it Special Alarm Clock, or something similar.

Now, when you set the Alarm Clock, you’ll see a brand new set of controls. Don’t just run with the herd—be the leader of the pack.

Variations

As with the Sound control panel recipe, if you have a program that can edit PICT bitmaps, you can create your own slider for the Alarm Clock (see the sidebar on editing PICT resources, above). You have to be careful, though. When you edit the PICT, don’t move any of the elements, and don’t make any of the elements too big. Try out your changes; if they don’t work, you can always go back to the original Alarm Clock and start over.

Other programs out there also use one PICT to contain a set of controls. If you can edit PICTs, you can change them, but again, be careful. As with the Alarm Clock, the program will be looking for controls of a specific size at a specific spot within the PICT. With care, though, you can do quite a bit to change the program’s interface.

Clock of Ages

When I first came to work here, the owner loved to collect antiques. He had this mantle clock that he put over the counter.

I hated that darn clock.
It was hideous; it looked like something out of an alien spaceship. It just wasn’t right for a diner, not with all the chrome and Formica we have. Maybe you’ve seen that clock. It’s the Antique Clock that Berkeley Systems put it in their After Dark Clock module (see figure 7.7).

As I was saying, it wasn’t my favorite piece of diner decor. Nothing I could do about it, of course; he loved that old clock. But then he was bought out by a corporation. I worried that they’d change everything, but they let me manage the diner pretty much as I saw fit.

The first thing I saw fit to do was get rid of that clock.

I didn’t want anything too modern—I did like having a bit of wood around—so I found an antique schoolhouse clock. Okay, it’s not really chrome and Formica either. But at least it’s better than that other thing.

So, in honor of the real antique clock, I came up with a recipe to change the clock in After Dark, too. This is it.

**Ingredients**

Clock After Dark module (which comes with the original After Dark package)

NewClock file (included on disk)

1. Open the After Dark Files folder. Click on the Clock module to select it, then select Duplicate from the File menu (or press ⌘-D).

   This creates a copy of the Clock module, called Clock_copy.

2. Launch ResEdit.

3. If you haven’t changed ResEdit’s basic preferences, the splash screen will come up when you launch ResEdit. Click on it to remove it. Again, if you haven’t changed the preferences, the Open File dialog box will appear automatically. If it doesn’t, choose Open from the File menu (or press ⌘-O).
4. Using the Open File dialog box, find the NewClock file. Click on it to select it, then click on the Open button.

5. Click on the PICT icon to select it.

6. Select Copy from the Edit menu (or press ⌘-C).

7. Select Close from the File menu (or press ⌘-W).

8. Choose Open from the File menu (or press ⌘-O).

9. Using the Open File dialog box, find the Clock copy. Click on it to select it, then click on the Open button.

10. Double-click on the PICT icon.

ResEdit displays the PICTs used by the Clock module (see figure 7.8).

Figure 7.8
The Clock module's PICTs.
ResEdit displays the PICTs in squares; if the PICT is bigger than the square, ResEdit reduces the PICT to make it fit. (It may even reduce the PICT disproportionally, creating a rather squashed PICT.) To see a PICT at full size, double-click on it.

11. Select Paste from the Edit menu (or press ⌘-V).

A dialog box appears, asking if you want to replace the PICTs with the same ID (see figure 7.9).

![Replace resources with the same ID?]

Replace resources with the same ID?

12. Click on the Yes button.

ResEdit replaces the Clock PICTs with the PICTs you copied from the NewClock file.

13. Select Save from the File menu.

14. Select Quit from the File menu.

15. To test your changes, open the After Dark control panel.

16. Scroll through the list of modules until you find the Clock copy module. (You'll see both the original Clock and the Clock copy.) Click on the Clock copy to select it.

17. Select Antique from the Type pop-up menu.

18. Click on the Demo button.

After Dark displays your new clock (see figure 7.10).
You don’t have to get rid of the old Clock module; After Dark can keep track of both old and new modules. However, if you want to, you can remove the Clock file from the After Dark Files folder and rename Clock copy as simply Clock.

You’ve now got a clock that I can live with (you never know when I might come over for a visit).

**Variations**

As with the other two recipes in this chapter, if you have a program that can edit PICT bitmaps (such as Adobe Photoshop), you can create your own clock (see the sidebar on editing PICT resources, above). Take a look at a few other clock items in the Clock module—you might think about editing the digital numbers (although that would be quite a few resources to edit...).

**PICTs, One More Time**

Like I said, there’s lots you can do with PICTs. They’re kind of a catch-all for any graphic element the programmer wants to put in, so all kinds of strange things can be found in PICTs.

‘Course, since there are so many strange things in PICTs, you can get strange results when you change PICT resources. But you also get some results that are pretty interesting, so it’s worthwhile experimenting on your own.
Probably the most utilitarian aspect of the Macintosh is the menus. Pointers, icons, and patterns all change from program to program, but the menus almost always look the same. Black on white, in 12-point Chicago. Very simple, very useful.

Now perhaps you’ve seen a splash of color in an occasional menu, or seen an icon beside a menu item or two. You don’t usually see such unusual features on an everyday workhorse like a word processor or spreadsheet. I wonder why? Sparse and spartan has its place, but I don’t mind a pinch of spice to make my workday more enjoyable.

Making your menus more entertaining isn’t the only outcome. You can do things to make them more functional, too.

Here are three recipes that do a little of both: they’ll make your menus more attractive and more functional. Go ahead—you work hard, you deserve it!
A word of advice before you start: If you are modifying the System or Finder files, make sure that you have a startup floppy disk handy before you start. If you have any problems with the following recipes, check out Chapter 3, “Heimlich Maneuvers.”

A Balloon for Balloon Help

(Sigh.) Some days it seems like every menu in my life is the same. Ever get that feeling? Nothing new, no excitement, just the same black words, over and over and over again. Boring!

Now what if I could, say, add pictures to the menus? Now that would perk me up! When you’ve got pictures to work with, you can add real pizzazz.

As usual, Walt has read my mind, and this recipe is the result. It shows how to add an icon to a menu item. Read on, and learn how to add the Speaking Man (famous from System alerts) to the Show (or Hide) Balloons item in the Balloon Help menu.

Ingredients

System 7

1. Open the System folder. Click on the System to select it, then select Duplicate from the File menu (or press ⌘-D).

   This creates a copy of the System; the copy is named (surprisingly) System copy.

2. Launch ResEdit.

3. If you haven’t changed ResEdit’s basic preferences, the splash screen will come up when you launch ResEdit. Click on it to remove it. Again, if you haven’t changed the preferences, the Open File dialog box will appear automatically. If it doesn’t, choose Open from the File menu (or press ⌘-O).
4. Using the Open File dialog box, find the System copy. Click on it to select it, then click on the Open button.

5. Only icons with certain ID numbers can be used with menus, so we'll need to create the correct icon.

Double-click on the ICON icon.

ResEdit displays the System's icons (see figure 8.1).

Figure 8.1
Icons from the System.

6. Click on the Speaking Man icon (icon 1) to select it.

7. Select Duplicate from the Edit menu (or press ⌘-D).

A dialog box appears, warning you that the resource is compressed, and that the copy will not be compressed (see figure 8.2).

Figure 8.2
A warning.
8. Click on Yes.

ResEdit creates a copy of the Speaking Man icon, identifying it as icon 128. Menus can use icons only with ID numbers between 257 and 511, so we'll have to give the icon a new number.


10. The Resource Info dialog box appears (see figure 8.3).

Figure 8.3
The resource ID dialog box.

Type: ICON Size: 128

ID: 128
Name:

Owner type

Owner ID: DRUR
Sub ID: MDEF

Attributes:
System Heap ☐ Locked ☐ Preload ☐
Purgeable ☑ Protected ☐ Compressed ☐

11. Type 257 in the text box labelled ID.

12. Close the Resource ID dialog box; close the ICON window.

You can use a colorized icon, if you want to. Chapter 3, “A Hot Cup of Icons,” has a recipe that shows you how to colorize the System icons. The idea is quite simple; all you do is create a color icon—a color icon—with the same ID number as the black-and-white icon you want to colorize. In this case, you’d just have to create a colorized icon (color) with an ID number of 257.


ResEdit displays the System’s menus—menus that are generic to every application (see figure 8.4).
14. Double-click on the Balloon Help menu (number \(-\text{16490}\), with the title "rANdy").

ResEdit displays the Balloon Help menu in the menu editor.

15. Click on the Show/Hide Balloons menu item to select it.

16. Select Choose Icon from the \textit{MENU} menu.

(Now, how many books can claim a sentence quite like that?)

ResEdit displays the icons available for use with the menu (see figure 8.5).

\begin{figure}[h]
\centering
\includegraphics[width=\textwidth]{figure8.4}
\caption{The System’s menus.}
\end{figure}

Most of the icons are grayed out. This is because—all together now—only icons with ID numbers from 257 to 511 can be used with menus. The other icons are shown, but you can’t select any of them.

17. Click on the Speaking Man icon (icon 257) to select it.

18. Click on the OK button.
19. To test your new menu icon, open the rANdy menu.

When you're editing a menu, ResEdit displays that menu in the menu bar so that you can see the fruits of your labor. You can’t actually use any of the menu items, of course, but you can open the menu to see what it will look like.

20. Select Save from the File menu (or press ⌘-S).

21. Select Quit from the File menu.

22. Open the System folder again. Select the System file and drag it out of the System folder; place it in a folder named “Disabled” on your hard disk.

23. Click on the System copy file. Rename it System.

24. Close the System folder. If the small System icon appears on the System folder, go on to the next step. If the icon doesn’t appear, that means that the Macintosh doesn’t know that the folder is a valid System folder. Try opening and closing the folder again; that should make the System icon appear on the System folder.

25. Select Restart from the Special menu.

When your Macintosh restarts, you’ll have a new icon in your Balloon Help menu—just open that menu to try it out (see figure 8.6).
Variations

Use this recipe to add as many icons as you like to menus. (Some menu items don’t let you add icons because the menu items change from application to application. The Finder Shortcuts item in the Balloon Help menu is an example.) Just follow the basic procedures above. If you want to add a different icon, you can either duplicate a different icon, or create your own icon. Just make sure you give the icon an ID number between 257 and 511.

Another variation you can try is to use smaller icons. In the Choose Icon dialog box (shown in figure 8.5), notice that there are radio buttons for Normal Icons, Reduced Icons, and Small Icons. The first radio button—the default—indicates that a normal icon (of the ICON resource type) will be used. The second button—Reduced Icons—takes the normal icons and reduces them to half normal size—usually 16 by 16 pixels. The third button—Small Icons—enables you to choose icons from the SIGN type (small black-and-white icons).

As mentioned earlier, if you create a color icon with the same ID number as a black-and-white icon, the color icon will be used instead. See Chapter 3, “A Hot Cup of Icons,” for details. And for even more variations, notice that color icons—cicons—don’t have to be 32 by 32 pixels....

You can, of course, use different menu items, different menus, or even menus from different programs. The results won’t always be what you expect—a menu may be used only part of the time, for instance—but opportunities abound out there!
Radical ResEdit Menus

Sometimes, functional isn’t really functional. What I mean is, you can make your environment so streamlined and flawless that it stifles creativity. You take away so many distractions that your imagination can’t find a spark of inspiration.


Your Macintosh is the perfect place to do it. Even if you’re in the most tyrannical, antiseptic environment, you can liven up your software, and nobody will say anything.

Okay. Honestly, I’m not going to claim that making your ResEdit menus more colorful is going to create a burst of creativity for you. But follow this recipe, and you’ll have a program that’s a little more fun, and maybe—just maybe—you’ll get a flash of inspiration that would have otherwise fizzled out.

Ingredients

ResEdit (included on the disk)

1. Click on the ResEdit icon to select it, then select Duplicate from the File menu (or press ⌘-D).

   This creates a copy of ResEdit, called ResEdit copy.

2. Launch ResEdit.

   Make sure that you launch ResEdit and not the copy. You can’t safely use ResEdit to modify itself; that would be like asking a surgeon to operate on herself—not a good idea. So create a copy of ResEdit, then edit it using the original.

3. If you haven’t changed ResEdit’s basic preferences, the splash screen will come up when you launch ResEdit. Click on it to remove it. Again, if you
haven't changed the preferences, the Open File dialog box will appear automatically. If it doesn't, choose Open from the File menu (or press `Ctrl-O`).

4. Using the Open File dialog box, find the ResEdit copy file. Click on it to select it, then click on the Open button.

5. Double-click on the MENU icon.

   ResEdit displays the menus used by, well, ResEdit (see figure 8.7).

   ![Figure 8.7](image)
   
   ResEdit menus—a new perspective.

6. If you scroll through the list, you'll notice that ResEdit uses quite a few menus, most of them only in specific situations. For that reason, we'll edit only the basic ResEdit menus: the File, Edit, Resource, Window, and View menus.

   To begin, double-click on the File menu (resource 2).

   ResEdit displays the ResEdit File menu (see figure 8.8).

7. First we want to change the defaults for the menu. Three color swatches appear on the right side of the Menu Editor window. Position the mouse pointer over the third swatch—the one called Menu Background—and click and hold the mouse button.
The File menu in the menu editor.

ResEdit displays a list of colors; drag the mouse to select a dark green color, as shown in figure 8.9.

Selecting a dark green Menu Background color.

Okay, suppose you have a black-and-white machine. Is there anything you can do? Sure! You have the option to make your menu background black and the Item Text Default white. This will create reversed menus—not as luxurious as color, but pretty stylish nonetheless.
8. When you select the dark green color, ResEdit warns that it is creating an `mctb` resource—the resource that keeps track of the menu colors. Click the OK button.

ResEdit changes the menu background to dark green. If you want to see the effects of your changes, open the File menu that appears toward the right side of the menu bar (the name is surrounded by a box). This menu doesn’t do anything, but it gives you the chance to see what your menu is going to look like.

9. Open the Item Text Default color swatch (as you did with the Menu Background in step 7), and select a gray-green color (see figure 8.10). Make sure that the color you choose contrasts well with the dark green background.

![Figure 8.10]
Choosing a gray-green Item Text Default color.

Again, you can see the results by opening the (rightmost) File menu. If you want, you can change the Title color—the color of the menu title in the menu bar—but for now let’s leave it black. (We’ll keep the menu bar pretty much normal, and let the changes be a surprise....)

10. Now that you’ve changed the defaults, you need to change some individual menu items. In the menu editor window, click on the New item.

ResEdit changes the menu editor slightly (see figure 8.11).

11. Now we want to change all the Command-key equivalents to gold. Open the Cmd-Key color swatch and choose a gold color (see figure 8.12).
Figure 8.11
The menu editor with a menu item selected.

Figure 8.12
Choosing a gold Command-key color.

12. Repeat steps 10 and 11 for each menu item that has a Command-key equivalent: Open, Close, Save, Print, and Quit. Also, click on the Open Special menu item and change the triangle color to gold.

13. Now, click on one of the separator lines to select it.

14. Using the Text color swatch, change the color to a darker green than the background.

15. Repeat step 14 for each of the separator lines.
16. We want to emphasize certain menu items—the ones used most often, for instance. Click on the Open item to select it.

17. Choose a brighter green color for the Text color (see figure 8.13).

18. Repeat step 17 for the other important menu items: Save, Get Info For This File, and Quit.

   As always, you can open the (rightmost) File menu to observe your changes in action.

19. Click on the Open Special menu item again. Notice that because it has a submenu, it also has a box for the ID of that submenu—132. We want the submenu to match the main menu, so close the MENU ID = 2 window (the File menu window) by pressing ⌘-W, or by clicking on the window’s close box.

20. To edit the submenu, double-click on the Open Special menu (ID number 132). Repeat steps 7, 8, and 9 for the Open Special menu.

   Now the submenu will match the main menu.

21. Close the Open Special menu.

22. We want all of the menus to match, and we’ve just changed the File menu. So repeat steps 6 through 15 for each of the other menus we wanted to change: Edit (3), Resource (128), Window (131), and View (130). You’ll have to pick out menu items to emphasize in steps 16 and 17, but I have faith that you’ll do a good job.
In the Edit, Resource, and Window menus, all the items are grayed out. Don’t let that stop you; you can change the colors just as before.

23. Once you’ve edited the main menus, you’re almost done—but there’s one step left. Double-click on the Apple menu from ResEdit copy (menu ID 1). Change the Item Default Text and the Menu Background to match the other menus, then close the Apple menu.

You can’t edit the appearance of most of the Apple menu’s contents—those items are determined by the System, not by ResEdit. So fancy formatting is out, except for the About ResEdit menu item.

24. Okay, now you’re finished. Choose Save from the File menu (or press ⌘-S).

There’s nothing to stop you from colorizing all the menus—just continue with the process you’ve started here. That can take awhile, because there’s no easy way to colorize all of a program’s menus at once. You’re welcome to try, though.

25. Choose Quit from the File menu (or press ⌘-Q).


The Finder launches the copy of ResEdit that you modified.

27. Now, try out the menus. You’ll have all-new, wonderful green menus.

So, you’ve added some great-looking menus to ResEdit. You haven’t made ResEdit easier to use or more powerful, but you’ve sure made ResEdit more pleasing to the eye.

**Variations**

Pick any color scheme you like. In fact, you can create some pretty hideous menus without even trying. It’s more of a challenge to create an attractive color scheme, and it takes quite an effort to apply your scheme to every menu in a program. But if you do a good job, it’s worth it. Make your plan consistent and use a text color that contrasts well with the menu background. (Actually, making the item text the same color as the menu background might be an interesting effect, if you really know a program well... but that’s only if you really, really like the daredevil life.)

You can also change the appearance of menu text by using the familiar text styles—bold, italic, outline, and so forth. Simply select a menu item in the editor and choose your desired style from the Style menu. (This works only for individual items, though; you can’t create a “default style” for a menu.)

Just about every program uses menu resources. As with the Apple menu, not every menu item can be formatted through the ResEdit menu editor. However, you can create quite an effect even if you change only the menu background and the default text color.

**A Keystroke Away**

Yes, so far the recipes in this chapter have been fairly frivolous, and I promised you they would be useful. Well, here’s a recipe that oozes utility.

I don’t have the time or patience to reach for my mouse every time I want to choose a menu item. Nobody does; that’s why the Macintosh has Command-key equivalents. If you had to select Save from the File menu every time you wanted to save your work, you’d go crazy—and lose data fairly often. Instead, you press ⌘-S. Simple.
Why doesn't every menu item have a Command-key equivalent? There are several good reasons—but none to keep you from adding your own Command-key equivalents if you see fit!

That's what this recipe does. In System 7, one of the most-used menus is the Application menu. It gives you the power to switch easily between applications—and to hide the application windows when, for instance, you need to see your desktop.

So why not add some Command-keys to the Application menu? There is one problem. Because the Application menu is available from every application, what if another application uses a Command-key sequence, the same one that you assigned to the Application window, for its own purposes?

Well, that can be a problem; if you look hard enough, you'll find a program that uses any Command-key combination you can imagine. But as a result, the Application menu's Command keys are ignored—the active application's Command keys take precedence.

This recipe shows how to add Command-key equivalents to your Application menu. If that isn't useful, I don't know what is.

**Ingredients**

System 7

1. Open the System folder. Click on the System to select it, then select Duplicate from the File menu (or press ⌘-D).
   
   This creates a copy of the System, named System copy.

2. Launch ResEdit.

3. If you haven't changed ResEdit's basic preferences, the splash screen will come up when you launch ResEdit. Click on it to remove it. Again, if you haven't changed the preferences, the Open File dialog box will appear automatically. If it doesn't, choose Open from the File menu (or press ⌘-O).

4. Using the Open File dialog box, find the System copy. Click on it to select it, then click on the Open button.

5. Double-click on the MENU icon.

   ResEdit displays the System's menus—menus that are generic to every application (see figure 8.14).
6. Double-click on the Application menu (number -16489 with the title "Maura").

ResEdit displays the Application menu in the menu editor (see figure 8.15).

7. Click on Hide ^0 (which really means "hide the current application") to select it.
8. Click in the Cmd-Key text box.

9. Type a left bracket—[—in the Cmd-Key text box.

ResEdit adds the Command key to the menu (see figure 8.16).

Figure 8.16
A new Command key in the Application menu.

10. Click on the Hide Others menu item, and repeat steps 8 and 9, only this time type a right bracket—]—in the Cmd-Key text box.

Again, ResEdit adds the Command key to the menu.

11. Click on the Show All menu item, and repeat steps 8 and 9. This time, type a backslash—\—in the Cmd-Key text box.

Once more, ResEdit adds the Command key to the menu.

12. Select Save from the File menu (or press ⌘-S).

13. Select Quit from the File menu (or press ⌘-Q).

14. Open the System folder again. Select the System file and drag it out of the System folder; place it in a folder named “Disabled” on your hard disk.

15. Click on the System copy file. Rename it System.

16. Close the System folder. If the small System icon appears on the System folder, go on to the next step. If the icon doesn’t appear, that means that the Macintosh doesn’t know that the folder is a valid System folder. Try opening and closing the folder again; that should make the System icon appear on the System folder.

17. Select Restart from the Special menu.
When your Macintosh restarts, you'll have Command-key equivalents for the Application menu. Open that menu to try it out (see figure 8.17).

| Hide Finder   | ⌘H |
| Hide Others  | ⌘J |
| Show All     | ⌘L |

**Variations**

Use this procedure to add Command-key equivalents to any menu item—with a few caveats:

- Menu items that don’t appear in the menu resource (such as the individual applications in the Application menu) and the items in the Apple menu can’t receive Command-key equivalents.

- Remember, if you add Command keys to the Balloon Help or Application menus, other applications may use the same Command keys for different menu items. Also, avoid duplicating Command-key equivalents already used for other menu items.

- Applications such as Microsoft Word let you modify menus and Command keys within the program itself, so there’s no reason to change the Command keys with ResEdit. (Probably for this very reason, Microsoft Word doesn’t even use MENU resources.)

If you avoid these pitfalls, you can add some wonderfully useful Command keys to programs. Most large-scale commercial applications already have a well-thought-out system of Command keys, but many shareware and freeware programs have left some leeway for Command keys of your own.
More on Menus

As you can see, there's much you can do to modify your menus. Admittedly, some of it is window dressing (so to speak), but with ResEdit you can actually add functionality.

You can do more than these recipes have described, too. For instance, you can rename all the menu items. However, that won't change what the menus do; even if you named the first item in the File menu "Save" instead of "New," your program would still open a new document when you selected that first item.

Despite the limitations, you don't see this combination of aesthetics and functionality every day.
What do you look at most of the time when you work with your Macintosh? No, not the menu bar, not the pointers—I mean, what do you actually look at most of the time? Windows. And dialog boxes. And alerts. That's where most of your Macintosh work gets done. Everything's contained in a window or frame of some sort. Great thing
is, these are very functional. Take your typical alert box. Lots of empty white space... words are easy to read and make sense... buttons are well labelled and (usually) easy to figure out. Very functional.

But not very interesting.

So why not change them once in awhile? You don’t have to look at the same dialogs and alerts all the time. Don’t you get fed up when your computer tells you something’s wrong with such a bland face? Or feel a bit bored when you see the same dialog box or window that you’ve seen thousands of times before? Sure you do.

Besides, not all dialog boxes are completely functional. Did you ever accidentally click on the wrong button, or spend several seconds figuring out the meaning of a button? You can fix these nuisances, rather than worry about them.

All it takes is a few recipes.

A word of advice before you start: if you are modifying the System or Finder files, make sure that you have a startup floppy disk handy before you start. If you have any problems with the following recipes, check out Chapter 3, “Heimlich Maneuvers.”

From One, Many

We’ve got a bunch of terms floating around here. Alerts, dialog boxes, windows, and so forth—what’s the difference? Which resources do they involve? How does this whole mess fit together? What’s going on!?!?

Okay, you can stop hyperventilating—it’s not too complicated. We’ll look at the qualitative differences first, then check out the quantitative differences.

Alerts tell the user about something that happened or is about to happen. The ultimate alert is the Bomb notice: “Hey you—your Macintosh just went belly-up!” Alerts include warnings (“This will cause the Macintosh to
restart."), cautions ("Do you want to erase this file?"), and information ("You cannot erase this file, because it is locked."). They usually have only a few buttons—like Cancel, OK, and Continue.

Alerts are "modal"—you can’t ignore them; you must deal with them before moving on. That’s why they usually appear in windows without title bars or close boxes: you can’t do anything else until you respond to the problem.

**Dialog boxes** are a little more user-friendly. They get you to input information that the Macintosh needs. Dialog boxes range from alert-like sparseness ("Please name the disk...") to full-blown complexity as in Page Setup dialog boxes. Dialog boxes have all kinds of controls—buttons, check boxes, text entry boxes, and so forth.

Dialog boxes can be either modal ("Please Name the disk...") or modeless (as in a spelling checker dialog box). Modeless dialog boxes have title bars—you can move them or switch back to other windows as you see fit.

The term **window** is used to describe quite a few different formats, but in general, a window is where the user works. Windows are fairly generic, and special elements are usually added as part of a program rather than as resources.

So how do resources fit into this? The following table lists different window-like resources and describes what they control.

### WINDOW-LIKE RESOURCE TYPES

<table>
<thead>
<tr>
<th>Icon</th>
<th>Code</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Icon]</td>
<td>ALRT</td>
<td>Alert</td>
<td>Controls position and characteristics of alerts</td>
</tr>
<tr>
<td>![Icon]</td>
<td>actb</td>
<td>Alert color table</td>
<td>Contains custom colors for alerts</td>
</tr>
</tbody>
</table>

*continues*
### WINDOW-LIKE RESOURCE TYPES

<table>
<thead>
<tr>
<th>Icon</th>
<th>Code</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="DLOG" /></td>
<td>DLOG</td>
<td>Dialog box</td>
<td>Controls position and characteristics of dialog boxes</td>
</tr>
<tr>
<td><img src="image1.png" alt="DLOG" /></td>
<td>DLOG</td>
<td>Dialog box</td>
<td>Controls position and characteristics of dialog boxes</td>
</tr>
<tr>
<td><img src="image1.png" alt="dctb" /></td>
<td>dctb</td>
<td>Dialog box color table</td>
<td>Contains custom colors for dialog boxes</td>
</tr>
<tr>
<td><img src="image1.png" alt="dctb" /></td>
<td>dctb</td>
<td>Dialog box color table</td>
<td>Contains custom colors for dialog boxes</td>
</tr>
<tr>
<td><img src="image1.png" alt="WIND" /></td>
<td>WIND</td>
<td>Window</td>
<td>Controls position of windows</td>
</tr>
<tr>
<td><img src="image1.png" alt="WIND" /></td>
<td>WIND</td>
<td>Window</td>
<td>Controls position of windows</td>
</tr>
<tr>
<td><img src="image1.png" alt="wctb" /></td>
<td>wctb</td>
<td>Window color table</td>
<td>Contains custom colors for windows</td>
</tr>
<tr>
<td><img src="image1.png" alt="wctb" /></td>
<td>wctb</td>
<td>Window color table</td>
<td>Contains custom colors for windows</td>
</tr>
<tr>
<td><img src="image1.png" alt="DITL" /></td>
<td>DITL</td>
<td>Dialog item</td>
<td>Controls elements of dialog boxes and alert</td>
</tr>
<tr>
<td><img src="image1.png" alt="DITL" /></td>
<td>DITL</td>
<td>Dialog item</td>
<td>Controls elements of dialog boxes and alert</td>
</tr>
</tbody>
</table>

The **DITL** is a crucial resource type. It controls the actual buttons, text, icons, and so forth that go into alerts and dialog boxes. The **ALRT** and **DLOG** resources control the overall characteristics—such as color and position—of the alert or dialog box.

It's really not that complicated. Just remember that **WINDS**, **ALRTS**, and **DLOGs** control position, color, and appearance; **ctbs** contain color information if custom colors are used; and **DITLs** determine the buttons and such for the **ALRTS** and **DLOGs**. Simple!
Renovated ResEdit Alerts

While trying recipes in this book, perhaps you've encountered the ResEdit alert that asks whether you want to replace the resource with the same ID. Did that alert confuse you?

Of course not—you were following the recipe, so you knew just what to click. But what if you were making up your own recipe? You might need some time to figure out what the alert was asking.

So why not rephrase the alert? Why puzzle out the meaning when you can reword it to make sense to you. Do that, and you'll never have to fumble for the correct answer—nor click the wrong button by mistake.

The debate, of course, is whether changing the alert involves more work than puzzling out its meaning once and for all. I don't have an answer for you, except to ask: do you just accept what's there, or do you take an active role in solving the problem?

This recipe shows how to alter that alert message to make it easier to understand. At the very least, you'll know exactly who made that alert read as it does—and how to change it should the mood strike you.

Ingredients

ResEdit (included on the disk)

1. Click on the ResEdit icon to select it, then select Duplicate from the File menu (or press ⌘-D).

      This creates a copy of ResEdit, called ResEdit copy.

2. Launch ResEdit.

Note

Make sure that you launch ResEdit, and not the copy. You can't safely use ResEdit to modify itself; that would be like asking a surgeon to operate on herself—not a good idea. So create a copy of ResEdit, then edit it using the original.
3. If you haven't changed ResEdit's basic preferences, the splash screen will come up when you launch ResEdit. Click on it to remove it. Again, if you haven't changed the preferences, the Open File dialog box will appear automatically. If it doesn't, choose Open from the File menu (or press \-O).

4. Using the Open File dialog box, find the ResEdit copy file. Click on it to select it, then click on the Open button.

5. Double-click on the DITL icon.

   ResEdit displays the ResEdit alerts (see figure 9.1).

6. Double-click on DITL number 129 ("Overwrite").

   ResEdit displays the "Same ID" alert (see figure 9.2).
If you open ResEdit’s ALRT resources, you’ll notice an ALRT with the same number, 129. Open it, and you see a version of the same dialog box (see figure 9.3); double-click on that, and you see the same DITL as in figure 9.2.

The ALRT controls the details of the alert’s appearance—position on the screen, colors of the window, and so forth. The DITL controls exactly what the window contains. In short, the DITL tells the Macintosh what to say; the ALRT tells the Macintosh how to say it.

Figure 9.2
The alert in question.

Figure 9.3
An ALRT.
7. After you double-click on DITL number 129, you see the alert displayed, ready to edit. Double-click on the block of text.

   ResEdit displays the text (see figure 9.4).

8. To enter your new explanation of the dialog box, type the following text:

   A resource you want to add has the same ID number as a resource that already exists. Press Replace to use the new resource instead of the old one.


10. Click on the text you just added. Drag the box in the lower right corner of the text to make the text box smaller (see figure 9.5).

11. Click on the Static Text area of the palette to the right of the DITL window and hold the mouse button down. Drag the Static Text box to the position shown in figure 9.6.
A resource you want to add has the same ID number as a resource that already exists. Press Replace to use the new resource instead of the old one.

Unique ID  No  Yes

This adds another text box.

12. Double-click on the text box you just added, and type:

   Press Unique ID to change the ID of the new resource.

   ResEdit adds the new text to the text box.


14. As before, drag the box in the lower right corner of the text box to resize it as shown in figure 9.7.

15. Drag the Unique ID button next to the new text box, as shown in figure 9.8.


18. Drag the Replace and Cancel buttons to center them in the window, as shown in figure 9.9.

19. Okay, now you’re done. Choose Save from the File menu (or press ⌘-S).

20. Choose Quit from the File menu (or press ⌘-Q).


   The Finder launches the copy of ResEdit that you modified.

22. To try out the new dialog box, open a file (I used a System copy file). Double-click on any of the resource types, and click on a resource to select it. Choose Copy from the Edit menu, then choose Paste from the Edit menu.

   ResEdit displays your new alert (see figure 9.10).
23. Click the Cancel button and choose Quit from the File menu to get out of your test.


You've changed a pesky ResEdit alert. The new one is bound to be less confusing—with less chance of doing something you'll regret.

**Variations**

If you have a better idea for how to make this alert easier to understand, try it out. You'll be surprised how tough it is to be both concise and clear, but it can be done.

Many dialog boxes and alerts are confusing, but not all of them can be edited in this way. Some programs insert strings of text into generic alerts or dialog boxes rather than designing specialized ones. If ever you're mystified by a message, look for it in ALRT, DITL, or DLOG resources.

What to do when you find it is another story. The idea is to change the message and buttons to something that makes sense to you. That takes careful thinking, but even deciding what makes sense will help you better understand what the message means. Just remember that no matter what names you give the buttons, they still have the same effect—if you change a button name from Quit to Save.... (Don't even think it. That would be a really, really mean practical joke. I could never condone such tomfoolery.)
Your Name in Lights

My computer belongs to me.

Of course it does. That doesn’t surprise you any. “Tell me something I care about,” you groan. Well, listen up, because I’m not done talkin’ yet.

The point is, I can do any dern thing to my Macintosh that I want, and I want to make it personal! If I get hit by a bus and some stranger has to turn on my computer, I want him to say, “Yep, that’s Mr. Grigsby’s Macintosh.”

Sure, I can make fancy desktops and all, but that’s not me. I want something with my name on it. Old buddy Walt came up with a way to put my name somewhere out of the way, so that if someone’s lookin’, they’ll find it.

That’s what we’ll show you next. If you want to get yer name in lights, so to speak, follow this recipe.

Ingredients

The Finder (System 7)

1. Open the System folder. Click on the Finder to select it, then select Duplicate from the File menu (or press ⌘-D).

   This creates a copy of the Finder, called Finder copy.

2. Launch ResEdit.

3. If you haven’t changed ResEdit’s basic preferences, the splash screen will come up when you launch ResEdit. Click on it to remove it. Again, if you haven’t changed the preferences, the Open File dialog box will appear automatically. If it doesn’t, choose Open from the File menu (or press ⌘-O).

4. Using the Open File dialog box, locate the Finder copy file. Click on it to select it, then click on the Open button.

5. Double-click on the DLOG icon.

   ResEdit displays a list of the Finder’s dialog boxes (see figure 9.11).
6. Double-click on resource ID number 5066.

ResEdit displays the About the Finder dialog box in the DLOG editor (see figure 9.12).

7. Drag and center the image of the dialog box on the preview screen, so that you can see the changes you make.
At any time during the following process, you can see the effects of your changes by selecting Preview at Full Size from the DLOG menu. ResEdit displays the dialog box as it will appear when in use; click anywhere to return to the DLOG editor.

**8.** First we want to change the appearance of the dialog box. Click on the Window with Title Bar icon above the preview screen, as shown in figure 9.13.

![Figure 9.13](image)

Changing the window type.

ResEdit changes the window type from a box with shadow to a modal window.

**9.** Next we want to change the window colors. Click on the Custom radio button.

ResEdit displays a series of color swatches for different elements of the window.
10. Open the Content swatch (as you would a pop-up menu) and select a light gray color (see figure 9.14).

![Figure 9.14](image)

Selecting a Content color.

11. ResEdit displays a warning that you are creating a dctb resource by adding color to the dialog box. Click on the OK button.

12. As you did in step 10, open the Frame color swatch; choose a dark blue color.

13. Next, we want to add your name to the dialog box. Double-click on the image of the dialog box. ResEdit displays the dialog box in the DITL editor (see figure 9.15).

14. Click on the Static Text area of the palette next to the DITL window and hold the mouse button down. Drag the Static Text box to the position shown in figure 9.16.

This adds a text box to the dialog box.

15. Double-click on the text box you just added, and type:

   James Grigsby's Macintosh

   (Feel free to use your own name.)

17. The text item you added has a small size box in the lower right corner; drag it to the size shown in figure 9.17.

18. Choose Center Horizontally in Window from the Alignment menu.


20. We want to move the window back where we found it. Enter 0 in the Top text box (located at the bottom left corner of the DLOG window).

21. Enter 0 in the Left text box.

22. You've finished your changes. Select Save from the File menu (or press Z-S).

23. Select Quit from the File menu (or press Z-Q).
24. Open the System folder again. Select the Finder file and drag it out of the System folder; place it in another folder called “Disabled” or something similar.

![Figure 9.17](image)

Resizing the text box.

Make sure that your “Disabled” folder doesn’t have a System file in it; if it does, the Macintosh may think that the Disabled folder is really the System folder!

25. Click on the Finder copy file. Rename it Finder.

26. Select Restart from the Special menu.

27. To try out your changes, hold down the Option key, open the Apple menu, and select About the Finder.

The Finder displays your edited dialog box (see figure 9.18).

So you’ve personalized your Macintosh a bit. Now, when you feel an identity crisis coming on, you can open your About the Finder dialog box and avert the crisis.

**Variations**

You can change elements of the dialog box as you see fit, reflecting your personalized style. Change the colors, add more or different text, add an icon, or change the size and position of the dialog box. These attributes are controlled in different ways.
You already changed the colors to an extent; there's not much more to tell you. Not all color swatches have an effect on the dialog box, and different window types use the colors in different ways. Try out your ideas and preview them by selecting Preview at Full Size from the DLOG menu.

You also know how to add text; just follow the same procedure.

Adding an icon is more complicated. Add an icon to the DITL just as you added the text box—by dragging it from the palette next to the window. Double-click on the icon placeholder, and enter the ID number of the icon you want to use. (You could even add your own icon to the ICON resources—your face, perhaps?—and use that in the dialog box.)

To change the window's position, select Auto Position from the DLOG menu. The window is currently set to appear in the automatic alert position; use the pop-up menus to change to either Centered or None. If you choose None, drag the window in the preview screen to where you want it to appear; that will be its location.

A host of other dialog boxes await your changes; feel free to seek out and alter them. Your search may be complicated by the use of generic dialog boxes, and by multiple dialog boxes for similar situations, but that's no reason not to try.
WINDing Up with the Calculator

You may have heard us complain before about the Calculator. Actually, we've gone a little too far. The Calculator is pretty cool. When the Macintosh first came out, it was amazing—you could instantly get a calculator on the screen when you needed one, and it actually looked like a calculator! So, I suppose we've been criticizing it unfairly.

But why stop now?

And we've changed just about everything else about it, so why not change it one last time? Only one thing is left unchanged—the Calculator window itself. So let's take a look and see what we can do.

If you've tried the other Calculator recipes in this book, your own Calculator may differ from what you see here. I hope you're not surprised!

Ingredients

Calculator (which comes with the System software)

1. Open the System folder; open the Apple Menu Items folder (enclosed within the System folder).

2. Click on the Calculator to select it.

3. Choose Duplicate from the file menu (or press ⌘-D).

   The Finder creates a duplicate of the Calculator, called Calculator copy.


5. If you haven't changed ResEdit's basic preferences, the splash screen will come up when you launch ResEdit. Click on it to remove it. Again, if you haven't changed the preferences, the Open File dialog box will appear automatically. If it doesn't, choose Open from the File menu (or press ⌘-O).
6. Using the Open File dialog box, find Calculator copy; click on it to select it, then click on the Open button.

7. Double-click on the WIND icon.

ResEdit displays the resource for the single window that it uses to display the Calculator itself.

8. Double-click on the calculator's WIND (icon number -16000).

ResEdit displays the window in the WIND editor (see figure 9.19).

Figure 9.19
The Calculator window.

9. The first step is to center the Calculator on the monitor. Choose Auto Position from the WIND menu.

ResEdit displays the Auto Position dialog box (see figure 9.20).

10. Choose Center from the first pop-up menu.

11. Click on the OK button to close the Auto Position dialog box.

You won’t see the centered alignment in the WIND editor; you’ll have to wait until you open the Calculator.
12. Now we'll add some color to the Calculator. Notice that there are a series of color swatches next to the Calculator in the WIND editor (see figure 9.21).

At any time during the following process, you can see the effects of your changes by selecting Preview at Full Size from the WIND menu. ResEdit displays the dialog box as it will appear when in use; click anywhere to return to the WIND editor.
13. Open the Content swatch (as you would a pop-up menu) and select a bright gold color (see figure 9.22). (This is the color that you will see in the buttons and display area of the Calculator.)

**Figure 9.22**
Selecting a Content color.

14. As you did in step 13, open the Frame color swatch; choose a dark red color.

15. Now open the Title text color swatch and choose a darker gold color.

As you change colors, ResEdit displays your changes.

16. Now, let's change the window type. Click on the icon that represents a window with a title bar and close box, as shown in figure 9.23.

17. We want to make one last change. The word “Calculator” doesn’t fit in the title bar of the new window. Drag the size box at the lower-right corner of the Calculator window to make the window bigger. It should look like figure 9.24).

18. Choose Save from the File menu (or press ²-S).

19. Choose Quit from the File menu (or press ²-Q).

You've created the new Calculator window; you'll want to try it out.
Figure 9.23
Changing the window type.

Figure 9.24
Changing the window size.
20. Open the Apple menu; choose the Calculator copy.

The made-over Calculator appears, sporting its new colors (see figure 9.25).

Figure 9.25
The new Calculator.

21. There's no reason not to keep both calculators around; you can use either one depending on the occasion. However, you might not want to keep two calculators in your Apple menu—that menu gets crowded pretty quick.

If you want to remove the older calculator, select the Calculator file and drag it out of the Apple Menu Items folder (perhaps to the Desktop, or to another folder on your hard disk).

22. Click on the Calculator copy file. Rename it Special Calculator, or something similar.

Your Calculator now has a brighter, fresher appearance! You can revel in the satisfaction of having controlled the appearance of your Calculator. (Or, you can just sit back and enjoy it.)

Variations
Choose different colors, positions, or sizes for the Calculator. Experiment—find something that's uniquely you. Some of the color swatches don't have an effect, but try them for yourself.

You can also change the window's appearance by clicking on different window types at the top of the WIND editor. You'll probably want to stick with windows that have title bars and close boxes, but there's no law saying you can't do something else—you'll just have to close the Calculator from the File menu, and you won't be able to move it.
Windowmania

We've merely scratched the surface of possible window, alert, and dialog box modifications. Other things you can do are:

- Change the default text in a text entry box (such as the Player Names from a game.
- Add spurious buttons and check boxes to a dialog box.
- Add icons to an alert or dialog box.
- Add PICTs to a dialog box.

Don’t be limited by the current size and shape of an alert, dialog box, or window; for instance, you can make the alert bigger and add a PICT below the existing elements.

Feel free to experiment. You’ll easily come up with your own innovative ideas. For inspiration, look around in different programs just to see how they handle dialog boxes and alerts. You’ll discover interesting possibilities.
Blue-Plate Special:

Chili con Calculator

You're probably wondering why I create so many recipes for the Calculator. Well, there are a few reasons. Everybody has it, so I'm not leaving anyone out. It's a small program, so you can easily figure out what's happening. And it has many interesting resources to edit.

It's not the most complex program around, but in a way that adds to its classic charm. Apple did a fine job, there's nothing really wrong with it—it's just not particularly interesting. Sometimes that's the cook's biggest challenge: to take an old standby, add some flavorings, and make it something new.
So that's what we'll do here. You've probably seen some of our other recipes for the Calculator; we'll do many of the same things, but with a different flavor. We'll also add some new ideas.

**Ingredients**
Calculator (which comes with the System software)

Figure 10.1 shows the original Calculator.

![Figure 10.1](image)

The original Calculator.

1. Open the System folder; open the Apple Menu items folder (enclosed within the System folder).
2. Click on the Calculator to select it.
3. Choose Duplicate from the file menu (or press ⌘-D).
   The Finder creates a duplicate of the Calculator, called Calculator copy.
4. Change the name of the copy to Spicy Calculator. (There's no reason not to have two Calculators; if you get tired of one or the other, you can always move it to a Disabled Items folder.)
5. Launch ResEdit.
   If you haven't changed ResEdit's basic preferences, the splash screen comes up when you launch ResEdit. Click on the splash screen to remove it. Again, if you haven't changed the preferences, the Open File dialog box appears automatically. If it doesn't, choose Open from the File menu (or press ⌘-O).
6. Using the Open File dialog box, find Spicy Calculator, click on it to select it, then click on the Open button.
Window

The first thing we'll do is change the details of the window that contains the Calculator. Since that's really all there is to the Calculator—that one window—the shape it takes really affects the appearance of the Calculator.

7. Double-click on the WIND icon.

   ResEdit displays the resource for Calculator’s single window—the window it uses to display the calculator itself.

8. Double-click on the calculator’s WIND (icon number -16000).

   ResEdit displays the window in the WIND editor (see figure 10.2).

9. The first step is to make the Calculator center itself on the monitor. Choose Auto Position from the WIND menu.

   ResEdit displays the Auto Position dialog box (see figure 10.3).
10. Choose Center from the first pop-up menu.

11. Close the Auto Position dialog box.

You won't see the centered alignment in the WIND editor; you'll have to wait until you open the Calculator.

12. Now we'll add some color to the Calculator. Open the Content swatch (as you would a pop-up menu) and select an orange color (see figure 10.4). (This is the color that you will see in the buttons and display area of the Calculator.)

Figure 10.4
Selecting a Content color.

At any time during the following process, you can see the effects of your changes by selecting Preview at Full Size from the WIND menu. ResEdit displays the dialog box as it will appear when in use; click anywhere to return to the WIND editor.
13. As you did in step 12, open the Title Text color swatch; choose a reddish-purple color.

14. Once more, open the Frame color swatch and choose a dark red color.

As you change the colors, ResEdit displays your changes.

15. There's one last window change to make: the window title. (Pretty obvious that it's a calculator, don'cha think?)

Choose Set 'WIND' Characteristics from the WIND menu.

ResEdit displays the 'WIND' Characteristics dialog box (see figure 10.5).

![Figure 10.5](image)
The 'WIND' Characteristics dialog box.

16. Type Spicy! in the Window title text area, and click on the OK button.

17. You'll want to check your changes, so select Preview at Full Size from the WIND menu.

ResEdit shows you what you've done; click once to remove the preview.

18. Close the WIND ID = -16000 window (either by clicking in the window's close box, by selecting Close from the File menu, or by pressing \(\text{⌘} - \text{W}\)); then, close the WIND window in the same manner.

19. Choose Save from the File menu (or press \(\text{⌘} - \text{S}\)).

**Pattern**

The next thing we'll do is change the pattern that makes up the body of the Calculator. In Chapter 6, we changed the pattern to a lightning bolt motif; here, we'll do something a little more, well, spicy.
20. Double-click on the ppat icon.
ResEdit displays the Calculator's single pattern—the pattern it uses for the front of the calculator.

ResEdit displays the pattern editor (see figure 10.6).

Figure 10.6
The Calculator's pattern.

We're talking about a spicy calculator (whatever that is), so let's make the pattern a bunch of chili peppers.

22. To make the pattern recognizable, we'll need to make the pattern bigger than the default 8 x 8. Choose Pattern Size from the Pattern menu.
ResEdit displays the Pattern Size dialog box (see figure 10.7).

Figure 10.7
The Pattern Size dialog box.

23. The Pattern Size dialog box displays the current pattern in various tiles representing different sizes. Click on the 16 x 16 tile—that should be big enough.
24. Click on the Resize button. ResEdit changes the pattern editor to represent the larger size.


26. Look for two black boxes on the left side of the editor. The lower of the two displays the foreground color—the color you will use to draw.

When you click on the Foreground Color swatch, ResEdit displays a pop-up menu of colors. Since we'll be changing colors often, however, we'll use the tear-off palette feature.

Move the mouse pointer over the Foreground Color swatch, and click and hold the mouse button (just as you would to open any pop-up menu). Now (while holding down the mouse button) move the mouse pointer outside the area of the menu.

A dotted line is created to represent the position of the palette (see figure 10.8).

---

**Note**

ResEdit offers you several different color palattes from which to choose. In the following example, we used the “Standard 256 Colors” palate. To make sure you're using the same palette, open the Color menu and choose Standard 256 Colors. You can use other color palattes, if you want, but you won't see the same spread of colors that we show here.

---

**Figure 10.8**

Creating a palette.
27. Release the mouse button.

ResEdit creates a palette of colors for the foreground (see figure 10.9).

**Figure 10.9**
The color palette, indicating the colors we'll use.

28. Click on the Pencil tool icon.

29. Click on the red color (as indicated in figure 10.9) to select it.

30. Using the Pencil tool, draw the body of the pepper (see figure 10.10).

**Figure 10.10**
The body of the chili pepper.

31. Click on the green color (again, as indicated in figure 10.9) to select it.

32. Using the Pencil tool, draw the stem of the pepper (see figure 10.11).
33. Click on the darker red color to select it.

34. Using the Pencil tool, draw details in the body of the pepper—the wrinkles (see figure 10.12).

35. Click on the darker green color to select it.

36. Using the Pencil tool, draw details in the stem of the pepper (see figure 10.13).

37. Now we want to change the background color from white to orange. Click on the orange color (as indicated in figure 10.10) to select it.

38. Click on the Paint Bucket tool to select it.

39. Position the Paint Bucket tool inside the white part of the pattern, and click the mouse button to fill the pattern with the orange color.
40. You’ve drawn the color pepper; now, let’s create the black-and-white version.

Click on the black-and-white version. ResEdit brings up the black-and-white pattern editor.

Black-and-white patterns can only be 8 pixels by 8 pixels, so you can’t just copy the color pattern to the black-and-white pattern. You have to create the black-and-white pepper manually.

41. Using the Pencil tool, draw a (smaller) pepper, as shown in figure 10.14.
42. Close the ppat ID = -15999 window (either by clicking in the window's close box, by selecting Close from the File menu, or by pressing Ctrl-W); then, close the ppat window in the same manner.

43. Choose Save from the File menu (or press Ctrl-S).

**Strings**

We've changed the basic appearance of the Calculator, so let's tweak some of the details. One detail that's interesting to tweak is the text the Calculator uses in certain situations. Rather than report an error when you divide by zero, the Calculator displays infinity (for a positive number divided by zero), -infinity (for a negative number divided by zero), or not a number (for zero divided by zero, and other undefined results). That wording is contained in the STR# resource—so we can change it.

44. Double-click on the STR# icon.

ResEdit displays a list of strings from the Spicy Calculator. There's only one, with an ID number of -16000.

45. Double-click on ID number -16000.

ResEdit displays the Calculator resources in the STR# template (see figure 10.15).

46. To change the strings, all we do is type the new string in the box that contains the old string.

Type **Too hot!** in text box 2 (the “infinity” box).
47. Type Too mild! in text box 3 (the "-infinity" box).

48. Type Flavorless! in text box 4 (the "not a number" box).

There's also text box 1, which contains 0. You can change that one, too; it's the text the Calculator uses whenever it gets zero as an answer. (When you clear the Calculator, however, it displays 0 no matter what this string is.) Zero is pretty common, so we thought it'd be too confusing to change this string. If you want to, though, there's no reason you can't change it—maybe to Just right!

49. Close the STR# ID = -15999 window (either by clicking in the window's close box, by selecting Close from the File menu, or by pressing `&-W); then close the STR# window in the same manner.

50. Choose Save from the File menu (or press `&-S).

**Icon**

Of course, the ultimate detail that we have to fix is the icon, so let's get to it!

51. Double-click on the ic$ icon.

ResEdit displays the Calculator icon.

The ic$ icons are used to create the Finder icon of the Calculator. Specifically, the ic$ icon is used when the Macintosh is in 256-color mode. The Macintosh uses other kinds of icons for the Finder in other situations, but ResEdit allows you to work on all the different kinds of icons at once.

52. Double-click on the Calculator icon (icon number -16000).

ResEdit displays the icon editor (see figure 10.16).
We want to change this icon into something completely different, so you have to erase the old image.

53. Choose Select All from the Edit menu (or press ⌘-A).

54. Press the Delete key (or select Clear from the Edit menu).

This completely removes the old icon. Now you need to start drawing the new icon.

Again, we will use the "Standard 256 Colors" palette. Choose Standard 256 Colors from the Color menu if your list of colors looks different from what you see here.

55. As you did in step 26 with the pattern editor, open the Foreground Color pop-up menu and create a color palette (see figure 10.17).

The Foreground Color box may display different colors depending on the selection made in the Color menu. The colors shown in figure 10.17 are from the Standard 256 Colors selection. The other choices will present different lists of colors; the Apple Color Picker choice brings up the usual color wheel.
56. Draw the icon for the Spicy Calculator.

Rather than describe each step in drawing the icon, we'll show you the result in figure 10.18.

The icon uses the colors indicated in figure 10.17 as follows:

- Red for the pepper body.
- Green for the stem.
- Light gray for the upper and left edges of the buttons and display.
- Dark gray for the bottom and right edges of the buttons and display.
- Yellow for the center of the display.

If you want, add detail to the pepper's body and stem, using dark red and dark green.

That creates the basic 256-color icon. However, you now need to create icons for the other situations (16-color and black-and-white); you also need to create small icons, so the pepper will appear in the Apple menu.
57. Position the mouse pointer over the ic18 box on the right side of the window; the pointer changes to a hand. Click and hold the mouse button, and drag the ic18 icon over the ic14 box (see figure 10.19). Release the mouse button.

ResEdit draws you a chili pepper icon in the ic14 box.
58. Repeat step 57 for the other icons: drag the ic18 icon to the ICN#, ics8, and Mask boxes.

The ICN# (black-and-white) and ics8 (small 256-color) icons could use some tweaking—they didn’t come out quite like you might hope (see figure 10.20).

**Figure 10.20**
The bad ICN# and ics8 icons.

59. Click on the ICN# box.

60. Using the various tools, fix the icon (see figure 10.21).

**Figure 10.21**
The hand-fixed black-and-white icon.
61. As you did in step 57, drag the \texttt{ICN#} icon to the \texttt{ics#} box. This creates the small black-and-white icon.

62. Now click on the \texttt{ics8} box.

63. Again, hand-fix the icon, as shown in figure 10.22.

64. Now, drag the \texttt{ics8} icon to the \texttt{ics4} and small Mask boxes. This creates the small 16-color icon, and the small icon Mask.

65. Click on the various types of icons to view the results.

66. Choose Save from the File menu (or press F5-S).

**Finishing Up**

Okay—you’ve changed just about everything you can in the Calculator. Now it’s time to check out your changes! All the changes will work when you launch the
Spicy Calculator—except the new icon. As in Chapter 4, you’ll have to rebuild your Desktop before that will show up. Let’s continue.

67. Choose Quit from the File menu (or press ⌘-Q).

68. Once you’re back in the Finder, open the Apple Menu Items folder again (if it’s not still open).
As we expected, the Spicy Calculator still has the same icon. We’ll have to fix that!

69. Place the Calculator file—the original—into the Trash, but don’t empty the trash!
The reason you’re moving the original Calculator into the Trash is so that the Finder knows which icon to use when it rebuilds the Desktop. It won’t look in the Trash for an icon, so you’re safe. Just don’t empty the Trash!

70. Now we’re ready to rebuild the desktop file. Choose Restart from the Special menu. While the computer restarts, hold down the Command and Option keys.

**Warning:** Rebuilding the desktop file destroys all comments stored in the Get Info boxes. Make sure you don’t need any of that information before you proceed!

71. After awhile, the Macintosh asks if you want to rebuild the desktop file on your hard disk. You do, so click on the OK button.

72. When the Macintosh is finished, open your Apple Menu Items folder again. You’ll see your new icon! Open the Apple menu to see the new small icon next to the Spicy Calculator.
73. Double-click on the Spicy Calculator (or select it from the Apple menu) to launch it.

When it appears, you’ll see the—dare I say it?—spicier version of the Calculator (see figure 10.23).

74. There’s one more thing to check. Enter the problem \( \frac{1}{0} = \).

You’ll get the answer Too hot!

75. Check the other strings: try \( 0 - 1 / 0 = \), and \( 0 / 0 = \). You’ll see the other strings you changed. (Try \( 0 = \) if you changed the string for zero.)

**Spice is Nice**

You’ve created a spicier Calculator that may make your checkbook-balancing a bit less painful!
Weekday mornings for the past 23 years, I've come to the diner for a cup of coffee and a muffin. That's every morning, except for vacations or Christmas. (Once, the diner was closed when they were renovating the kitchen, but I figure that doesn't count.)

Now that I'm retired, I can spend some time with my breakfast rather than rushing off to work. There's nothing more enjoyable than a nice leisurely cup of coffee.
I think that's why Walt created this recipe—it's like a little poke at me. That Walt can't leave well enough alone, he's always got to make his little jokes. So this time, the joke's on me. Guess I can handle it. After all, he does make a fine cup of coffee.

What Walt did is take the Flying Toasters module, from After Dark, and change it into a Flying Mugs & Muffins module. Cups of coffee hurtling through space, chased by flying muffins. The whole thing's pretty hectic, but I suppose that's Walt's way of telling me how good things are for me now.

Or maybe not, but for once I think I'll give him the benefit of the doubt.

**Ingredients**

Flying Toasters module, which comes with After Dark

*Either* the Flying Mugs files, included on the disk

*Or* a color paint program and (optional) a means to digitize sounds

Figure 11.1 shows the original Flying Toasters (with the toast).

![Figure 11.1](image)

The original Flying Toaster, with toast.

1. Open the System folder; open the After Dark Files folder (enclosed within the System folder).

2. Click on the **Flying Toasters** file to select it.

3. Choose Duplicate from the file menu (or press ⌘-D).

   The Finder creates a duplicate of the Flying Toasters, called **Flying Toasters copy**.
4. Change the name of the copy to Flying Mugs. (There’s no reason not to have both modules; you’ll be able to select either one from the After Dark control panel.)


   If you haven’t changed ResEdit’s basic preferences, the splash screen will come up when you launch ResEdit. Click on it to remove it. Again, if you haven’t changed the preferences, the Open File dialog box will appear automatically. If it doesn’t, choose Open from the File menu (or press ⌘-O).

6. Using the Open File dialog box, find Flying Mugs, click on it to select it, and click on the Open button.

**Sounds**

First we’ll change the module’s sounds. After all, if no wings are involved, why use the sound of flapping wings?

To use the files included on the disk:

7. Select Open from the File menu (or press ⌘-O).

8. Using the Open File dialog box, find the Mug Resources file. Click on it to select it, and click on the Open button.

9. Double-click on the snd icon.

   ResEdit displays the snd resources from the Mug Resources file (see figure 11.2).

![Figure 11.2](image)

The snd resources from the Mug Resources file.

<table>
<thead>
<tr>
<th>ID</th>
<th>Size</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>128</td>
<td>7442</td>
<td>&quot;clenk1&quot;</td>
</tr>
<tr>
<td>129</td>
<td>17194</td>
<td>&quot;clenk2&quot;</td>
</tr>
<tr>
<td>130</td>
<td>47914</td>
<td>&quot;pour&quot;</td>
</tr>
</tbody>
</table>

10. Choose Select All from the Edit menu (or press ⌘-A).
ResEdit selects all the snd resources.

11. Choose Copy from the Edit menu (or press ⌘-C).

12. Select Flying Mugs from the Window menu (or click on the Flying Mugs window).

   ResEdit switches to editing the After Dark module (which you opened previously).

13. Choose Paste from the Edit menu (or press ⌘-V).

   ResEdit asks if you want to replace the resources with the same ID number (see figure 11.3).

**Figure 11.3**
Replacing the resources with the same ID number.

14. Click on the Yes button.

15. Choose Save from the File menu (or press ⌘-S).

You've added the new sounds to the After Dark module.

---

**Recording Your Own Sounds**

If you have a means to digitize sounds, you can record your own. Newer Mac models come with a microphone; you can also use third-party products such as the MacRecorder.

The easiest way to record sounds is through the Sound control panel (see figure 11.4).

Click on the Add button; you'll see the audio recording palette (see figure 11.5).
When you're ready to record your sound, click on the Record button. Record your sound, then click on the Stop button. Click on the Play button to hear what you've got; when you're happy with it, click on the Save button.

The Macintosh presents a dialog box that asks you to name your sound; give it a name you'll remember. To modify all the sound in the Flying Mugs module, you'll need three different sounds; repeat the steps above to record each one.

When you're finished, close the Sound control panel and open the System folder. Double-click on the System file; you'll get a window that displays, among other things, the sounds for your System. Drag the three sounds that you recorded to your Desktop (or someplace where you'll find them). Close the System file (and the System folder).
(At this point, if you’re really ambitious, you can edit the sounds using a program such as SoundEdit. That’s beyond the scope of this book, but if you already know how to do so, great!)

Launch ResEdit. Open one of the sounds that you created, and double-click on the snd icon. You’ll see just one sound resource; select it (actually, it should already be selected), and change its ID number to 128. Choose Copy from the Edit menu, and close the sound file.

Open the Flying Mugs module. Choose Paste from the Edit menu. ResEdit will ask if you want to replace the resources with the same ID number; click on the Yes button.

Now, open the other sounds that you created, and change their ID numbers to 129 and 130. Repeat the rest of the process: copy them and paste them into the Flying Mugs module.

You’ve added your own sounds to the module. Wasn’t too hard, was it?

Pictures

The next step is to add pictures of mugs and muffins. After all, that’s the heart of the module! (If you want to create your own animated figure, we provide a brief description of how to do that as well.)

16. If you still have the Mug Resources file open (and you should, if you haven’t deviated from the recipe), move to that window (using the Window menu, or by clicking on the window). Then skip to step 18.

If not, select Open from the File menu (or press ⌘-O).

17. Using the Open File dialog box, find the Mug Resources file. Click on it to select it, then click on the Open button.

18. Double-click on the PICT icon.

ResEdit displays the PICT resources from the Mug Resources file.

19. Choose Select All from the Edit menu (or press ⌘-A).

20. Select Copy from the Edit menu (or press ⌘-C).
21. Select Close from the File menu (or press `±-W) to close the PICT window; then select Close again (or press `±-W again) to close the Mug Resources window.

22. If you still have the Flying Mugs module open (and again, you probably do), you should be back at the Flying Mugs window. Skip to step 24.

If not, choose Open from the File menu (or press `±-O).

23. Using the Open File dialog box, find the Flying Mugs module. Click on it to select it, and then click on the Open button.

24. Double-click on the PICT icon.

ResEdit displays the PICTs used by the Flying Mugs module (see figure 11.6).

![Figure 11.6]
The Flying Toasters' PICTs.

25. Select Paste from the Edit menu (or press `±-V).

The “Replace?” dialog box appears again (see figure 11.7), asking whether to replace the resources with the same ID.
26. Click on the Yes button.

ResEdit replaces the Toaster PICTs with the PICTs you copied from the Mug Resources file.

27. Select Save from the File menu (or press ⌘-S).

You’ve added the new PICTs to the Flying Mugs module. Now, you’ll actually get flying mugs!

**Creating Your Own PICTs**

Editing PICTs requires a program with the necessary editing capability, usually a color paint program such as Adobe Photoshop. Almost every paint program can handle PICTs, so you’re limited only by what you want the program to do.

You can even use the ResEdit ppat editor to create PICTs up to 64 pixels by 64 pixels. First, choose Create New Resource from the Resource menu; in the dialog box, type ppat and click on the Okay button. Next, choose Pattern Size from the ppat menu; click on the 64 by 64 pixel box (at the lower right corner of the grid). Create your PICT, using ResEdit’s tools. Then, choose Select All from the Edit menu (or press ⌘-A), and choose Copy from the Edit menu (or press ⌘-C). You can then paste your PICT into the resource, as described below.

The Flying Toasters module uses ten PICT resources. There are four PICT resources for the color toaster—one for each position of the wings in the animation sequence—and there’s one PICT resource for the color toast. There are five corresponding resources for the black-and-white versions of the toaster and toast.
The four frames of the animation constantly cycle in the sequence 1-2-3-4-3-2- and so on. You don’t have to make the fourth frame match the first frame for a smooth flow, since the fourth frame moves back to the third. The PICTs are 64 pixels by 64 pixels square, on a black background. You’ll probably want to keep within those limitations.

So, the first step is to open your favorite paint program and create the first frame of the animation. Make sure you create exactly 64 x 64 pixels on a black background. Within those limitations, everything else is up to you.

You can save your edited picture as a normal paint document to simplify reopening the picture when you want to make changes later. You can also easily create the four animation frames by saving the file under four different names.

Use the rectangular selection tool, and select the 64 x 64 area. Choose Copy from the Edit menu.

Now launch ResEdit, and open the Flying Mugs module. Double-click on the PICT icon. Double-click on the PICT that you want to replace—probably the first color frame of the animation. ResEdit displays the PICT in a window; select Paste from the Edit menu, and ResEdit replaces the PICT with the PICT that you created.

Now, all you have to do is repeat the process for the other PICTs in the module. It’s not difficult at all; it’s just tedious. Don’t forget the black-and-white PICTs, unless you never use black-and-white mode on your Macintosh.

That’s all there is to it—not too bad, huh? The only tough part is coming up with the actual illustration, and that’s only as tough as you make it. No sweat!

**Text**

To finish up the module, we should clean up a few details of text. In the module’s control panel, a slider controls the toast color. Since we don’t have toast anymore, we’ll want to change that. There’s also a description of the module, and
without taking credit away from the original creators, we probably want to add a note of our own.

28. If you still have the Flying Mugs module open (you should, if you're following the recipe), skip to step 30.

If not, select Open from the File menu (or press \O).

29. Using the Open File dialog box, find the Flying Mugs module. Click on it to select it, and then click on the Open button.

30. Double-click on the TEXT icon.

ResEdit displays information on the one TEXT resource in the module.

31. Double-click on the TEXT resource (ID number 1000).

ResEdit displays the TEXT resource itself (see figure 11.8).

32. You may want to expand the window so that you can see all the text. At any rate, click at the end of the text (to add more to the resource).

33. Type two returns, then add the following text:

This Flying Mugs variation is a product of the All-Night Diner, and is inspired by Mr. Albert Grigsby. Never again shall he have to drink his coffee, eat his muffin, and run -- now, he'll have to run just to catch his food!
Your result will look like figure 11.9.

Your result will look like figure 11.9.

34. Close the TEXT ID = 1000 window (by selecting Close from the File menu, or by clicking in the close box), then close the TEXT resources window in the same manner.

35. Double-click on the sVal icon.

ResEdit displays the sVal resources from the Flying Mugs module (see figure 11.10).

A few resource types have the same icon. Make sure you get the sVal resources. We’ll check out another resource with the same icon in just a bit. Oh, by the way, “sVal” just might stand for “slider values....”
36. Click on the Toast resource (ID number 1001).

37. Choose Get Resource Info from the Resource menu (or press ``).

   ResEdit displays the info for the Toast sVal resource (see figure 11.11).

![Figure 11.11](image)

The Toast sVal resource info.

38. Change the resource name to Muffin Type.

39. Close the resource info window, and close the sVal window.

40. Double-click on the sUnt icon.

   ResEdit displays the sUnt resources from the Flying Mugs module.

   See, I told you we'd check out another resource type with the same icon! And do you think that “sUnt” may stand for “slider units?”

41. Double-click on the “Doneness Units” resource (resource ID 1001).

   ResEdit displays the “Doneness Units” resource (see figure 11.12).
Note that this is the dreaded hex editor. Never fear, we'll talk you through it!

What do the three columns of information mean? The first column indicates—in hexadecimal numbers—the length of the info to that point. The second column shows the actual data of the resource—the hexadecimal numbers that make up the resource. The third column displays the text translation of the hex numbers in the second column. Sometimes the text makes sense, and sometimes it doesn't; ResEdit just figures that the text might have some usefulness to you.

When you edit a resource using the Hex editor, you can make your changes in two ways. You can change the hex numbers that actually make up the resource, or you can change the text. If you change the text, ResEdit will decode the text into hex numbers. The important thing to remember is that the hex numbers are what matter—that's what the program is going to work with. If the text makes sense, fine; if it doesn't, the program doesn't care.

In this case, you can see that some of the text is useful—you can see "Light," "Medium," and "Dark"—but there are also some digits that don't make sense. The odd boxes and the exclamation point are ResEdit's attempt to make sense of the hex numbers as ASCII, but those characters don't help you very much. For that reason, we're going to change the hex numbers directly, rather than changing the text.

42. Choose Select All from the Edit menu (or press ⌘-A).

ResEdit selects all the hex numbers.
43. Type the following numbers, \textit{exactly} as indicated here:

0003 0000 0950 6F70
7079 7365 6564 0021
0942 6C75 6562 6572
7279 0043 084F 6174
2042 7261 6E

Your resource should now look like figure 11.13. Notice the new terms that show up in the text column.

![Figure 11.13](image)

New Doneness units.

When you type numbers, you'll notice some slightly unusual behavior. For instance, suppose you type 6F. When you press the “6” key, ResEdit displays 06. Then, when you press the “F” key, ResEdit displays 6F. This is because the hex numbers come in groups of two. An odd number of digits just wouldn't make sense, so the Macintosh assumes that “6” means “06” until you tell it otherwise. This sounds more complicated than it is—as soon as you try it for yourself, you'll see what we mean.

44. Choose Save from the File menu (or press \\text{⌘}-S).

\textbf{Finishing Up}

Now we're finished—we've changed the important details to make a true Flying Mugs module. Now, let's try it out!

45. Choose Quit from the File menu (or press \\text{⌘}-Q).
46. Open the Control Panels folder (from the Apple menu).
47. Open the After Dark control panel.
48. Scroll down the list of modules until you get to the Flying Mugs module. (If you've got a lot of modules, press the 'f' key on your keyboard to hasten the journey.)
49. Click on the Flying Mugs name in the list of modules.
   You'll see the control panel for your flying mugs (see figure 11.14).

50. Try moving the Muffin Type slider to see the effects of those changes.
51. Click on the credits at the bottom of the window.
   The window scrolls up to reveal the extended credits—with your additions. Click to dismiss the extended credits.
52. Now, click on the Demo button to see your new module! It should look something like figure 11.15.
Continental Breakfast

You now have a true breakfast module—steaming hot cups of coffee and flavorful muffins, all streaming across your screen. Boy, the caffeine just perks you up from here, doesn’t it?
Well, by now you've probably spent some time in the diner, trying our recipes and getting an idea of what we do here. I hope you've had fun—I know we do! But I've got a confession to make:

You don't really need us.

Oh, we're happy to help, and we really get a kick out of teaching you a few tricks. But the truth is, you can invent your own ResEdit recipes without too much trouble. ResEdit can be rough to get used to at first, but it really becomes easy after awhile.

ResEdit provides a window into other programs; in that respect, it's different from just about any other Macintosh program. Sometimes it's hard to understand just
how cool ResEdit is, especially if you haven’t used it yet, because it just doesn’t seem to make sense that you could do so much without working very hard. It’s easy to think, “I don’t know how to program, so even if I use ResEdit, I won’t know what to do.” That’s not the way it works, though; you’ve already seen how resource editing is very simple and intuitive. True, sometimes things don’t work the way you might expect them to, but you’ll soon develop a feel for what works and what doesn’t.

After trying a few of the recipes, you probably found yourself saying, “Okay, okay! I know I’m supposed to do that—you told me half a dozen times already!” And you’re right! The steps are very similar. Once you learn a few recipes, you know ninety percent of what you need to edit just about everything.

That’s not an accident. It’s due to the interface. Because Apple kept everything so consistent, things are pretty much the same from program to program. So there’s not a lot to learn when you edit a new program—things work pretty much the same as they did before.

To get you started on your own, we’ll give you a few tips. But really, if you’ve tried a few recipes, you’ve learned these already—we’re just pointing them out to you. We’ll also tell you where to find more information.

So get out there and edit resources! Come up with your own recipes. And hey, if you come up with any that you especially like, let us know. The diner is always seeking more treats for its customers!

The scariest thing about resource editing is when things go wrong. Sooner or later they probably will go wrong; that’s the price of using a program that has this much power.

The good news is, it’s not too hard to overcome these problems. Once you’ve done it once or twice, you’ll become very confident in your abilities. But just in case you need a little advice, check out Chapter 3, “Heimlich Maneuvers,” where we guide you past the sticky parts.
How to Edit

Really, if you’ve used any recipes in this book, you’ve learned most of what you need to edit resources. Maybe you just don’t realize it! This section reminds you to keep a few important things in mind as you strike out on your own.

Make a Copy

Always, always work on a copy of the file you’re editing. You can’t perfectly predict the effects of your edits, even if the edits seem straightforward. That’s because not everyone uses resources in the standard manner (and yes, that includes Apple programmers). If something goes wrong, you need a way to get back to where you started. Or maybe everything will go right, but you’ll decide you just like things better the way they were. The point is, you always need an unmolested copy of the software you edit, because you never know what will go wrong.

Try One Thing at a Time

Don’t try to edit everything at once, especially when you’re trying out your own edits. The reason is simple—if something doesn’t work, you need to know what caused the problem. If you’ve changed two dozen things, there’s no way to know what caused the problem, so fixing it will be tough. If you edit just one thing at a time, then if something goes wrong, you’ll know exactly where the problem came from.

Don’t Overdo It

This is more a matter of taste than anything, but it does have its practical aspects. If you change everything in sight, you’ll have a hard time figuring out what’s going on—and others who want to use your Macintosh will have ten times as many problems. Also, the more things you change, the more likely something will go wrong. Keep things simple—at least at first—and you’ll have fewer problems than if you change everything including the kitchen sink.
Editors

Many of the resource types are tough to edit; some are downright impossible. Programmers create new resource types all the time, and ResEdit doesn't know how to deal with most of them.

However, there is some relief. Many new editors are available for ResEdit; they enable you to edit resource types that were formerly difficult (if not impossible) to edit. Improved resource editors are available for sounds (snd resources) and animated pointers (acur resources). ResEdit editors are available from many sources, including online services and user groups.

ResEdit editors are actually RSSC resources (possibly with other resources as well). You install editors into the ResEdit Preferences file, using ResEdit. (Isn't this circularity great?) Simply copy all the resources in the editor document, open the ResEdit Preferences file, and paste them in. (Technically, it's safer to make a copy of the ResEdit Preferences file, paste the editor's resources into the copy, and then do the usual name- and place-swapping routine. However, pasting editors into the active Preferences file is usually safe—you won't be using the resources that you're pasting, after all.)

You could actually paste the editors into ResEdit itself, rather than into the Preferences file. However, that's a little more tricky—you have to swap the copies around—and you'll lose the editors if you move to a new version of ResEdit. If the editors are in the Preferences file, you'll still have them with the new version of ResEdit.

Really, that's about all you need to know before you start to edit resources. You'll learn more as you go along, of course, but if you follow these suggestions, you'll have little trouble.

What to Edit

When you first start editing resources, it seems like there's not much you can do. Very soon, though, you start seeing little tidbits pop up as you use your Macintosh, and you think, "Ah, I'll bet that's a resource! I wonder what would happen if I...?"
Another way to find interesting things to edit is to launch ResEdit, then open up programs and look around. (If you don’t make a copy of the program, be sure not to save any changes—you don’t want to change something unless you have a backup in case things go wrong!) If you browse through programs for awhile, you’ll soon find resources that just beg to be edited.

To get you started, we’ll point out a few areas where you might check for interesting resources. But if you just look around and are the least bit curious, you’ll soon be telling us what to edit!

**System**

Editing System files can yield the biggest rewards, because the edits you make will probably appear in many different situations. That’s because you’re editing a “program” that’s in operation no matter what you’re doing with your computer. The System files include the Finder, which you probably use more than any application, and a host of extensions, control panels, and auxiliary programs.

Of course, working with such powerful software carries a price: the editing is much more difficult. Especially when things go wrong, difficult problems can arise. For instance, if your System edit doesn’t work, you may not even be able to start your Macintosh.

That can be scary. But these problems often aren’t as bad as they seem, and you can do some really neat things when you edit the System files. In short, it’s worth the risk.

---

**Note**

Before you edit System files, make sure you have a floppy disk with which you can start your Macintosh. If things don’t go well, you need a startup disk to get your computer running so that you can fix the problem (or get back to where you started). The Disk Tools disk (which comes with the System installation disks) can be used for this purpose, or you can use the System installation disks to install the System on a blank floppy. Just choose “Minimum System” when you install. See Chapter 3, “Heimlich Maneuvers,” for more information on what to do when things go wrong.
The System itself is chock full of interesting resources to edit. Be aware, though, that not all of them take well to editing. Most do, however, and editing System resources can be fun just because you’re dealing with the heart of the Macintosh.

The Finder provides many opportunities for entertaining editing. Several resources that you observe in the Finder—icons and such—are actually contained in the System, so don’t be discouraged if at first you don’t find the resource you’re looking for.

Control panels often have interesting resources, although few in number, as control panel programs are pretty small. Desk accessories—with System 7, these are really small applications—have quite a few resources to play with. Extensions are easily overlooked, because you hardly ever have to bother with them, but they can have fun resources, too.

Poke around in your System folder and you’ll find many resources that you recognize just from using your Macintosh.

**General Applications**

Looking for resources to edit in applications, you get either feast or famine. Many large applications don’t have a lot of resources, because their publishers tend to build resource-like items into the programs themselves. (Microsoft is particularly prone to do this.) Developers use the program itself to do the work of the resources for any number of reasons—maybe it gives them more flexibility; maybe they are used to DOS.... The point is, some applications just don’t allow you to do much with ResEdit.

On the other hand, many applications have scads of resources to edit. Different types of programs have different types of resources. For instance, drawing and painting programs usually have a wide variety of pointers, because they have so many tools; they also often have patterns to edit.

Sometimes programs don’t use resources in quite the standard way, so your edits won’t work the way you expect them to work. But there’s no harm in trying.

Games deserve special mention, because they offer interesting possibilities. Many include sounds—and you can paste in new sounds using ResEdit. Spaceships can make more than one sound when they explode....
Watch out for software that's copy-protected. Some programs have special code that prevents you from copying the program. When you try to copy it (as a good ResEditor should, before editing software), the copy just won’t work. In this case, better safe than sorry—don’t try to work on the original file. You’re better off leaving the whole thing alone.

When editing applications, don’t overlook ResEdit itself. ResEdit uses lots and lots of resources, and you know you’ve got it already! Just make doubly sure that you work on a copy of the program.

When you use applications, keep an eye out for editable items. Sounds are good candidates, because they’re almost always stored as resources. Icons are other good candidates, as are pointers. If you see something that interests you, take a look at the program with ResEdit. You never know what you’ll find.

**Shareware and Freeware**

With proprietary applications, your resource options may be limited. But with freeware and shareware applications, you can often find a gold mine of editing possibilities. Such applications are often created by a single programmer or small team that may not have the time or funding to do things the hard way. They’re prone to use resources as much as possible, because Macintosh programmers have done most of the work already.

Shareware programmers develop some creative uses for resources. They may use a series of icons to create an animated figure, or use PICT resources to draw parts of the user interface. These folks aren’t dominated by management teams telling them what won’t work or won’t sell; they can take chances and do things differently. So check out freeware and shareware for rewarding resource editing possibilities. (And don’t forget to send in your shareware fees!)

**Keep Your Eyes Open**

As you use your Macintosh, open your eyes to what it’s showing you. Much of what you see is contained as resources. If something interests you, surprises you,
or just bugs you, check out the program’s resources. You may find an interesting resource to change; at worst, you’ll learn a little bit more about that program.

**Resources**

Lest the title of this section mislead you, I’m talking about resources for you, not for your computer. You can turn to quite a few sources for help in your ResEditing. These sources can provide editing tips, suggest things to edit, and furnish resources (icons, sounds, and the like) to use in your editing. Here are some places to check.

**Print**

Magazines regularly print tips involving ResEdit. Usually they’re solutions to problems posed by readers, but sometimes they’re just fun things to try out. The three most popular Macintosh magazines are *Macworld, MacUser,* and *MacWEEK*; check them out for cool ResEdit tips.

Books are also available for the resource editor (as you might have noticed). One that may prove useful is *ResEdit Complete,* by Peter Alley and Carol Strange, published by Addison Wesley. It provides an in-depth look at ResEdit and quite a few details about how resources and ResEdit work. It’s not for the beginner—but you’re not a beginner anymore! If you want a more introductory book, you might check out *Zen and the Art of Resource Editing,* by Derrick Schneider, Hans Hansen, and Noah Potkin, and published by BMUG through Peachpit Press.

**Online Services**

Online services, such as America Online and CompuServe, make available many files of resources to edit, plus additional editors for ResEdit. AppleLink provides valuable ResEdit information, but its coverage is directed more towards developers than recreational ResEditors.
User Groups

User groups can be your most valuable source. They often provide disks with ResEdit, resource editors, and resources; but even more important, they provide ResEdit advice and information that you won’t find elsewhere.

The two largest user groups are BMUG (the Berkeley Macintosh User Group) and BCS•Mac (the Boston Computer Society’s Macintosh arm). Memberships aren’t limited to the immediate geographic area, and these groups have incredible expertise that you can tap.

There’s probably a local user group, too. Call the Apple Customer Service line at (800) 538-9696 for a list of user groups in your area. At your local user group meeting, you will most assuredly find someone happy to advise you on resource editing.

Be Your Own Boss

There’s much more to learn about ResEdit and resource editing, and the best way is to try it for yourself. Resource editing isn’t something you can toss off without thinking, but it’s not that hard if you’re careful and give it some thought. The rewards can be great. It’s really satisfying to say, “I don’t like the way that program works,” and be able to change it yourself. It’s also rewarding to build a little of your own personality into your Macintosh—and be able to say, “I made the computer do that!”

So go on, go out and edit some resources. But don’t be a stranger—we’re always happy to see you back here at the diner, and our doors are always open!
There are quite a few different types of resources—especially when you consider that programmers can add their own resources as they choose, for whatever purpose they choose. There are, however, a few resource types that are fairly common. These resources will crop up often when you look for resources to edit, so we created this appendix to give you a little more information to help you find other resources.

Icons

There are many different icon resource types, but they are really very similar. Essentially they give you a space to edit the icon, a few tools to use in editing the
icon, and a normal-size view of the edited icon. There’s some variation beyond that, but once you’re comfortable editing one icon type, you’ll be comfortable with all of them.

The most basic icon type is the ICN# type. It’s used to contain basic black-and-white Finder icons. The icons are all 32 pixels by 32 pixels—the normal Finder icon size. The ICN# is the basic icon type; it contains the mask, which is essential to all the basic Finder icon types. The mask tells the Finder what parts of the icon block out the background—for instance, where to stop drawing the Desktop pattern and start drawing the icon. The mask also helps the Finder figure out how to change the appearance of the icon when it’s selected or opened.

The ic18 resource is used for 8-bit color icons—the icons your Mac uses when you’ve got a 256-color monitor. The ic18 editor is pretty much the same as the ICN# editor, except that it has a foreground color swatch and a background color swatch. The ic14 resource is the same as the ic18 resource, except that it has 4-bit color icons, used for 16-color monitors.

The ics resources are used for the small Finder icons—the icons you see when you have the view set to “by Small Icon” in the Finder. They’re also the icons you generally see in menus, such as the Application and Apple menus. These icons measure 16 pixels by 16 pixels. The ics# resource is used for small black-and-white icons. It also contains the mask for the small icons, just like the ICN# resource contains the mask for the larger icons.

The ics8 resource is used for small 8-bit color icons, and the ics4 resource is used for small 4-bit color icons.

ResEdit provides a standard editor for all the Finder icon types. When you open one of the icon types listed above, the editor actually has spaces for all of the icon types above; ResEdit displays all the icons of the various types that have the same ID number—for instance, the ICN# with ID = 4, the ic18 with ID = 4, the ic14 with ID = 4, and so on. This enables you to edit the different faces of the same icon without switching between editors. You can also create different representations of the same icon by dragging an icon of one type (say, ic18) to another type of icon (ICN#, for instance). ResEdit guesses at the best way to represent the icon in the different resource type—how to convert, for instance, the color icon to a black-and-white icon, or to a small icon.

ResEdit provides different color palettes for the color icon editors. For instance, in the ic18 editor you can choose between the standard Apple icon colors (recommended by Apple for use in icons) or a palette of 256 colors.
The **ICON** resource is used for all the non-Finder icons used by the Macintosh. These icons are used for such things as alerts, dialog boxes, menus, small animated sequences... just about anywhere the programmer wants a small graphical image. The **ICON** resource is used for black-and-white icons; it has a size of 32 by 32 pixels.

The **cicon** resource contains color icons comparable to the black-and-white **ICON** resources; in fact, a color Macintosh will replace an **ICON** with the **cicon** of the same ID, if one is available. The other difference between **ICONs** and **cicon**s is that **cicon**s can be resized; they can be any size from 8 pixels by 8 pixels up to 64 pixels by 64 pixels, and they don't have to be square.

The **sicon** resource is used to contain small (8 x 8) black-and-white icons. The resources, though often single icons, can actually contain lists of icons; thus, one resource can contain several different small icons. The **sicon** editor is about the same as any other black-and-white icon editor, except that it has a scrolling list that displays the different icons in the resource.

## Pointers

There are three basic pointer resource types. The **CURS** resource is easily the most common. This resource contains mouse pointers (sometimes called cursors), which are what you move onscreen when you move the mouse on your desk. These are much like small (8 x 8) black-and-white icons; they also have masks, like the Finder icons. The most common pointer—the arrow—is stored in the Macintosh ROMs, so you can’t edit it directly, but just about every other mouse pointer you see is stored in a **CURS** resource somewhere.

The **crsr** resource is used for color pointers. Color pointers aren’t too common; not many programs use them. They’re basically the same as black-and-white pointers, with color added.

The **acur** resource represents animated pointers, commonly used while waiting for the Macintosh to complete a task. Two common **acur**s are the watch with moving hands and the spinning beachball. The **acur** resource doesn’t actually contain pointers; instead, it contains a list of **CURS** pointers that are used to make the animation. The **acur** actually changes the pointer from one **CURS** to the next, giving the impression of motion. (The **acur** also controls the time delay between changes of **CURS**; this affects the speed of the motion.)
Patterns

Patterns are very similar to icons, in that they are small bitmapped images. Patterns, however, are generally used repetitively (like tiles in a bathroom) to cover an area. The PAT resource is a black-and-white pattern; it has a size of 8 pixels by 8 pixels. The ppat resource is the color version of the PAT resource. The ppat resource also differs from the PAT resource in that it can have different sizes. A ppat can have a height and width of 8, 16, 32, or 64 pixels; furthermore, the height and width don't have to be equal, so the ppat can be rectangular.

The PAT# resource is similar to the PAT resource, except that it consists of lists of patterns. The ppt# resource is the color version; it consists of lists of color patterns. (The ppt# patterns can be resized, like the ppat resources.) These are often used in programs that need to present a selection of patterns, such as paint programs. The editors are similar to the PAT and ppat editors, respectively, with the addition of a scrolling list of the patterns on the right side of the editor.

As we've said before, all resource names are four characters in length. PAT isn't an exception; the actual name is 'PAT ', with a space following the T. The snd resource is another resource with a trailing space. This is important to know if you type in a resource name—for instance, if you are creating a new resource in a program that had no such resources before. (Don't forget to pay attention to capitalization, too.)

Windows, Alerts, and Dialog Boxes

There are many different resource types in this broad category. The differences between windows, dialog boxes, and alerts are explained in Chapter 9; here, we'll just give a quick explanation of the different resource types.
The **WIND** resource describes the properties of windows. It controls the position and size of windows. It also controls the window type, which controls such elements as whether the window has a close box and what the window’s title bar looks like.

The **wctb** resource describes windows’ custom colors. Such elements as the window content, the frame, and the title bar can be assigned colors; each set of those colors are stored in a **wctb** resource.

The **DITL** resource is the key to both alerts and dialog boxes. It controls the actual contents of the alert or dialog box—the text, icons, buttons, check boxes, and so forth.

The **ALRT** resource describes alerts. The **ALRT** resource describes the position and size of the alert, while the **DITL** resource (of the same ID number) describes the actual contents. The **ALRT** resource also controls the alert behavior of a given resource, which is controlled by the *alert stage*—essentially, how many times the alert has occurred in a row. So, the alert can be set to beep the first time the user commits that mistake; the second time, the alert appears.

The **actb** resource controls custom colors for the **ALRT** resources, in much the same manner as the **wctb** resource.

The **DLOG** resource is analogous to the **ALRT** resource—it controls the position and size of dialog boxes. The contents of the dialog box are determined by the **DITL** resource of the same ID number, just as with the alerts.

The **dctb** resource controls custom colors for the **DLOG** resources, just as with the **actb** and **wctb** resources. (The **ctb** in these resource types stands for “color table,” as in “window color table” and “dialog color table.”)

## Text Resource Types

The **TEXT** resource type contains just that—text. It’s used for any large blocks of text, and there are no limits to its length.
The STR resource is just one text string. In both the TEXT template and the STR template, you can choose the font used to display the text. This doesn’t affect the font actually used by the program to display the font; the option is provided for your own convenience when editing the strings.

The STR# resource is a list of text strings. STR# resources are often used to contain lists of error messages.

**Menu Resources**

There are two main menu resources. The MENU resource, as you might expect, controls the actual menus. It determines the command names that appear in the menus, the menu title, command-key equivalents, any icons that appear in the menu, and other characteristics.

The motb resource, again as you might expect, controls the menu colors when custom colors are used. (Custom colors can be used for such elements as the menu background, the item text, and the command-key text.)

**Font Resources**

Formerly, font resources were a lot of fun to play with—you could use the font editor in ResEdit to create your own fonts. Such advances as PostScript fonts and TrueType fonts, however, have limited the number of useful changes you can make to fonts with ResEdit.

For your information, here are the common font resource types. The FONT resource actually contains the bitmapped font description. Using the FONT editor, you can edit bitmapped fonts, and even create your own bitmapped fonts (with a lot of work). Each font size has its own resource.

The FOND resource contains general information for the font, such as the leading and the maximum character width.
ResEdit Resources

There are two resource types used primarily by ResEdit that you might encounter. The TMPL resource contains information that helps ResEdit create a template for different resource types. When a new resource template is needed, a new TMPL resource is created.

The PICK resource is used to create new resource pickers for ResEdit. It describes the details of the resource picker. The PICK and TMPL resources are interesting not because you’re likely to edit them, but because you’ll see them if you obtain new resource pickers, templates, or editors from other sources.

Miscellaneous Resources

Many of the common resources you’ll see don’t fall into any specific category, although they can prove very interesting.

Two of the most common resource icons you’ll see are the HEXA icon and the CODE icon. The HEXA resource is used for hexadecimal numbers, and the HEXA icon is used for any resource ResEdit doesn’t know how to handle. That’s because hexadecimal numbers are the lowest common denominator—any of the data on the computer can be described in terms of hexadecimal (or simply hex, as it’s sometimes called).

The CODE resource is used for segments of program code. Often programs will have program code contained in other resource types, too, so you’ll see this icon with other resource types. Don’t try to edit CODE resources (or any other resources that use the CODE icon)—they are too closely related to the program itself, so the program probably won’t take well to having these resources change. In short, the program will probably crash.

CNTL resources are used to describe dialog box and window controls, such as scroll bars and sliders. ResEdit doesn’t provide a template for the CNTL resources—just a template—so there’s not much you can do to edit them.

The clut resource is used to tell the Macintosh what colors to use in the display—exactly which 256 colors to use when in 256-color mode, and so forth. ("clut" stands for “color look-up table.”) Different cluts are used for 256-color mode, 16-color mode, and so forth.
You’ve encountered PICT resources; they contain (oddly enough) PICT images. (PICT is a graphical format that supports both bitmapped elements and object-oriented elements, such as text, lines, and circles.)

Sounds are contained in snd resources. These can be fun to replace, because you can create quite a few interesting sound effects, and sounds can be more fun than many graphical changes.

The BNDL resource is used by the Finder to determine, among other things, what icons to associate with what documents, such as an application’s different file types.

The vers resource contains a program’s version information—primarily the version number.

The R0v# resource is used to replace ROM resources. The Macintosh ROMs actually contain many resources; the R0v# resource tells the computer to ignore a specific resource in the ROM and to use another resource instead.

Wrapping Up

There are many other resource types; some common, some obscure. However, these are some of the resources that you’ll commonly come across as you explore your programs. Some are easy to edit, some are difficult, and some are better left alone, but they all can be interesting to examine!
Index

Symbols

16-color icons, 39-40
256-color icons, 39-40
creating, 32-35

acur (animated cursor) resources, 72, 213
Time to Eat, 71-72
Adobe Photoshop, 109
After Dark control panel
Clock, replacing, 114-118
Flying Toasters, replacing with Flying
Mugs & Muffins, 186-200
icon, replacing streaking meteor with
airplane, 43-46
Alarm Clock desk accessory, replacing
controls, 111-114
Aldus PageMaker, adding crosshairs to
cropping tool, 73-76

About the Finder dialog box, adding
owner's name, 150-156
actb (alert color table) resources,
141-142, 215
alerts, 140-141
  adding colors to black-and-white icons, 53-56
  editing messages, 143-149
  resource types, 141-142, 215
Alignment menu commands, Center Horizontally in Window, 154
ALRT (alert) resources, 141-142, 215
  versus DITL resources, 145
animated cursors, creating, 69-72
animation within icons, changing, 43-46
Apple menu commands, Control Panels, 43, 86
Apple Menu Items folder
  Alarm Clock desk accessory, 112-114
  Calculator desk accessory, see Calculator desk accessory
Application menu commands, adding keyboard shortcuts to, 134-137
Auto Position command
  DLOG menu, 156
  WIND menu, 158
Auto Position dialog box, 158

background
  colors in menus, 127-129
  previewing icons against, 37
Balloon Help menu commands, Show/Hide Balloons, adding Speaking Man icon to, 120-125
BCS•Mac (the Boston Computer Society's Macintosh arm), 209
bitmapped font resources, 216
black-and-white icons, 39-40
  adding colors, 53-56
  creating, 35-36
monitors, colorizing menu items, 128
  patterns, 84
  ResEdit, creating, 89-90
blinking Question Mark icon, 22-23
BMUG (the Berkeley Macintosh User Group), 209
BNDL resources, 218
books, 208

C
Calculator desk accessory
  patterns, 95-100, 169-181
  preparing for changes, 166
  replacing icon with cash register icon, 29-39
  text strings, 175-176
  viewing changes, 181-183
  window, 157-162, 167-169
cash register icon, replacing calculator icon with, 29-39
Center Horizontally in Window (Alignment menu) command, 154
centering windows on-screen, 158
chili peppers pattern, 169-181
Choose Icon (MENU menu) command, 123
Choose Icon dialog box, 125
Choose Icon dialog box, 125
clon (non-Finder color icon) resources, 213
  After Dark, 43-46
Claris MacPaint, 109
clocks
  After Dark, replacing, 114-118
  Alarm Clock DA, replacing controls, 112-114
close boxes, 169
closing windows, 169
clut (color look-up table) resources, 217
CNTL (dialog box/window controls) resources, 217
CODE (program code) resources, 217
coffee mugs, replacing After Dark
Flying Toasters with Flying Muffins &,
186-200
color look-up table resource type, 217
Color menu commands, Standard 256
Colors, 177
color palettes
for color icon editors, 212
tear-off, 171-172
colors
black-and-white icons, adding to, 53-56
Calculator, adding to, 159-160
foreground, 31-32
ResEdit
menus, adding to, 126-133
patterns, creating, 90-94
windows, changing, 152-153,
155-156
Command-key equivalents, see
keyboard shortcuts
commands
adding icons to, 120-125
adding keyboard shortcuts to, 133-137
applying styles to, 133
Auto Position
DLOG menu, 156
WIND menu, 158
Center Horizontally in Window
(Alignment menu), 154
Choose Icon (MENU menu), 123
Control Panels (Apple menu), 43, 86
Create New Resource (Resource menu), 54
Finder copy (Window menu), 71
Get Resource Info (Resource menu),
54, 102-103
Icon menu, 37
Insert New Pattern (Resource menu), 82
Insert Relative Pattern (Resource menu), 92
Pattern Size (Pattern menu), 170-171
Preview at Full Size
DLOG menu, 152
WIND menu, 159
Set 'WIND' Characteristics (WIND menu), 169
Standard 256 Colors (Color menu), 177
Time to Eat (Window menu), 71
Try Cursor (CURS menu), 68
Try Pattern (Pattern menu), 84
control panels, resources for editing, 206
Control Panels (Apple menu)
command, 43, 86
Control Panels folder
After Dark
Clock, 117-118
Flying Mugs, 199-200
icon, replacing streaking meteor with airplane, 43-46
General Controls, 86
Sound, 107-109
Create New Resource (Resource menu)
command, 54
crosshairs cursor, adding to PageMaker
cropping tool, 73-76
crsr (color cursor) resources, 213
CURS (cursor) resources, 213
PageMaker, 74
System, 67-69
Time to Eat file, 70-72
CURS menu commands, Try Cursor, 68
cursor editor
editing Cropping tool, 74-76
editing I-beam, 67-68
cursors
crosshairs, adding to PageMaker
cropping tool, 73-76
hot spots, 74-76
I-beam, editing, 66-69
resource types, 213
watch, changing, 69-72

dctb (dialog box color table) resources, 142, 215
Delete key, 31
desk accessories
   Alarm Clock, replacing controls, 112-114
   Calculator, 29-39
      patterns, 95-100, 169-181
      preparing for changes, 166
      text strings, 175-176
      viewing changes, 181-183
      window, 157-162, 167-169
   resources for editing, 206
Desktop
   patterns
      advanced, 100-104
      for Control Panels, 80-86
      rebuilding, 38
Desktop files, 37-38
DeskTop Patterns file, 101-104
dialog boxes, 141
   About the Finder, adding owner’s name, 150-156
   Auto Position, 158
   Choose Icon, 125
   Pattern Size, 170-171
   resource types, 141-142, 215
   'WIND’ Characteristics, 169
DITL (dialog item) resources, 142, 215
   ResEdit, 144-149
DITL editor, adding names to About the Finder dialog box, 153-154
DLOG (dialog box) resources, 142, 215
   Finder, 150-156
   DLOG editor, adding names to About the Finder dialog box, 151-153
DLOG menu commands
   Auto Position, 156
   Preview at Full Size, 152
document icons, editing text, 56-60
drag and drop, opening files with ResEdit, 107

editing
   alert messages, 143-149
   freeware/shareware resources, 207
   I-beam cursor, 66-69
   PICT resources, 109-111
      Flying Mugs, 192-193
   program resources, 206-207
   resources
      guidelines, 203-204
      reasons for, 11-12
   System files, 205-206
text in document icons, 56-60
editors, 14-16
cursor
   editing Cropping tool, 74-76
   editing I-beam, 67-68
   DITL, adding names to About the Finder dialog box, 153-154
   DLOG, adding names to About the Finder dialog box, 151-153
hex, 14
   Flying Mugs, 197-198
icon
   colorizing icons, 53-55
   editing Shared Folder icon, 48-51
   editing small icons, 61-62
   editing text in document icons, 57-59
   replacing After Dark streaking meteor with airplane, 44-46
replacing Calculator icon with cash register icon, 31-37
tools, 26-28
types, 212
menu
adding icons to menu items, 123-124
adding keyboard shortcuts to menu items, 135-136
colorizing menu items, 127-133
pattern
adding patterns to Calculator, 97-99
adding ResEdit patterns, 88-95
Calculator, 170-175
creating and adding patterns, 82-85
WIND, modifying Calculator window, 158-162, 167-169
Eraser tool, 27
extensions, resources for editing, 206
Eyedropper tool, 28

fill patterns, creating for paint programs, 95
Filled (Solid) Circle tool, 28
Filled Box (Solid Rectangle) tool, 28
Filled Rounded Box (Solid Rounded Rectangle) tool, 28
Finder
adding owner's name to About the Finder dialog box, 150-156
Desktop files, 37-38
icon resources, 39-40
resources for editing, 206
small icons, changing, 61-63
watch cursor, changing, 69-72
Finder copy (Window menu) command, 71
finding System, troubleshooting, 23-24
flapping wings in Flying Mugs, 187-190
floppy disks, startup, 22-23
Flying Toasters, replacing with Flying Mugs & Muffins
pictures, 190-193
preparing for changes, 186-187
sounds, 187-190
text, 193-198
viewing changes, 198-200
folders
After Dark Files
Clock, replacing, 115-118
Flying Toasters, 186-200
Apple Menu Items
Alarm Clock, 112-114
Calculator, 29-39, 95-100, 157-162, 166-183
Control Panels
After Dark, 43-46
General Controls, 86
Sound, 107-109
sharing, 51-52
System, see System folder

faucets, adding to File Sharing icons, 46-52
File Sharing icons, adding pipes and faucets, 46-52
files
Desktop, 37-38
Desktop Patterns, 101-104
NewAlarm, 112-114
NewClock, 115-118
NewSlider, 107-109
opening with ResEdit, 107
Recycle Icon, 41-42
ResEdit Preferences, 204
System, 41-42
editing, 205-206
Time to Eat, 70-72

Index 223
FOND (font information) resources, 216
FONT (bitmapped font) resources, 216
Foreground Color box, 31-32
freeware, resources for editing, 207

G

games, resources for editing, 206
General Controls, Desktop patterns, 86
generic editor, 14
Get Resource Info (Resource menu)
command, 54, 102-103
graphics, mugs and muffins in Flying
Mugs, 190-193
grayed icons, 123

H

Happy Mac icon, not leaving, 22
help, sources for, 208-209
hex editor, 14
	Flying Mugs, 197-198
HEXA (hexadecimal number)
resources, 217
Hide Balloons (Balloon Help menu)
command, adding Speaking Man
icon to, 120-125
hot spot (x) tool, 75
hot spots, 74-76

I-J

I-beam cursor, editing, 66-69
ic14 (large 16-color Finder icon)
resources, 39, 212
	Calculator, 179
	Microsoft Word, 57
ic18 (large 256-color Finder icon)
resources, 39, 212
	Calculator, 30-38, 176-178
	System 7 Finder, 47

ICN# (large black-and-white Finder icon)
resources, 39, 212
Calculator, 180
ICON (non-Finder black-and-white icon)
resources, 213
System 7, 53-56, 121-122
icon editors
colorizing icons, 53-55
editing
	Shared Folder icon, 48-51
small icons, 61-62
text in document icons, 57-59
Foreground Color box, 31-32
replacing
	After Dark streaking meteor with
airplane, 44-46
	Calculator icon with cash register
icon, 31-37
tools, 26-28
types, 212
Icon menu commands, 37
icons
actb resource, 215
acur resource, 213
adding
to dialog boxes, 156
to menu items, 120-125
After Dark, replacing streaking
meteor with airplane, 43-46
ALRT resource, 215
black-and-white, adding colors,
53-56
blinking Question Mark, 22-23
BNDL resource, 218
cash register, replacing calculator
icon with, 29-39
cien resource, 213
c1ut resource, 217
CNTL resource, 217
CODE resource, 217
crsr resource, 213
CURS resource, 213

dctb resource, 215

DITL resource, 215

DLOG resource, 215

document, editing text, 56-60

File Sharing, adding pipes and faucets, 46-52

FOND resource, 216

FONT resource, 216

grayed, 123

Happy Mac, not leaving, 22

HEXA resource, 217

ic18 resource, 212

ICON# resource, 212

ICON resource, 213

ics# resource, 212

ics8 resource, 212

Mask, 40

mctb resource, 216

MENU resource, 216

PICK resource, 217

PICT resource, 218

ppat resource, 214

ppt# resource, 214

previewing against different backgrounds, 37

recycling bin, replacing Trash icon with, 40-42

resource types, 12, 39-40, 211-213

ROv# resource, 218

Sad Mac, 22

sicon resource, 213

small, changing, 61-63

snd resource, 218

STR resource, 216

STR# resource, 216

System folder, 23

TEXT resource, 215

TMPL resource, 217

vers resource, 218

wctb resource, 215

WIND resource, 215

Window with Title Bar, 152

window-like resources, 141-142

ics# (small black-and-white Finder icon) resources, 40, 212

Calculator, 181

ics4 (small 16-color Finder icon) resources, 40, 212

Calculator, 181

ics8 (small 256-color Finder icon) resources, 40, 212

Calculator, 180-181

ID numbers, resources, 13

-11330 (Trash small icon), 61

-15999 (Calculator ppat icon), 97, 170

-16000 (Calculator window), 31, 158

-16489 (Application menu), 135

-16490 (Balloon Help menu), 123

-3980 (Shared Folder icon), 48

-4064 (After Dark icon), 44

0 (Desktop patterns), 81

0 (octagon/hand icon), 53

1 (I-beam cursor), 67

1 (Speaking Man icon), 121

1000 (Flying Mugs TEXT), 194

1001 (Toast slider value), 196

128 (After Dark icon), 44

128 (Resource menu), 131

129 (After Dark icon), 44

129 ("Overwrite"), 144

130 (After Dark icon), 44

130 (document icon), 57

130 (empty recycling bin icon), 42

130 (View menu), 131

131 (Window menu), 131

132 (Open Special menu), 131

134 (stuffed recycling bin icon), 42

16 (Desktop pattern), 102-103

2 (File menu), 127

273 (Cropping tool), 74
3 (Edit menu), 131
3100 (ResEdit patterns), 89
5066 (About the Finder dialog box), 151
for menu icons, 122-123

Ingredients
After Dark control panel, 43-46
Alarm Clock desk accessory, 112-114
Aldus PageMaker, 73-76
Calculator desk accessory, 29-39, 95-100, 157-162, 166-183
Clock After Dark module, 115-118
color paint programs, 186-200
Desktop Patterns file, 101-104
Finder, 70-72, 150-156
Flying Mugs files, 186-200
Flying Toasters After Dark module, 186-200
Microsoft Word, 56-60
NewAlarm file, 112-114
NewClock file, 115-118
NewSlider file, 107-109
ResEdit, 87-95, 126-133, 143-149
Sound control panel, 107-109
System 7, 47-63, 67-69, 80-86, 101-104, 120-125, 134-137
System file, 41-42
Time to Eat file, 70-72
Insert New Pattern (Resource menu) command, 82
Insert Relative Pattern (Resource menu) command, 92

K

keyboard shortcuts
adding to commands, 133-137
Close (⌘-W), 169
colorizing menu listings of, 129-130
Copy (⌘-C), 41
Create New Resource (⌘-K), 54
Duplicate (⌘-D), 29
Get Resource Info (⌘-I), 54

L

Lasso tool, 27
Line tool, 28
lists of resources, 13

M

Macintosh, ResEdit requirements, 4
MacPaint (Claris), 109
magazines, 208
Mask icon, 40
masks, 212
Calculator, 180-181
mctb (menu color table) resources, 216
ResEdit, 129-133
MENU (menu) resources, 216
ResEdit, 127-133
System 7, 122-125, 134-137
menu editor
adding to menu items
icons, 123-124
keyboard shortcuts, 135-136
colorizing menu items, 127-133
MENU menu commands, Choose
Icon, 123
menus
adding icons to items, 120-125
adding keyboard shortcuts to items, 133-137
applying styles to items, 133
ResEdit, colorizing, 126-133
resource types, 216
messages, alert, editing, 143-149
Microsoft Word, editing text on icon, 56-60
modal
    alerts, 141
dialog boxes, 141
modeless dialog boxes, 141
monitors, black-and-white, colorizing
    menu items, 128
Muffins, replacing After Dark Flying Toasters with Flying Mugs & Muffins, 186-200

name (owner's), adding to About the Finder dialog box, 150-156
networks, changing File Sharing icons, 46-52
NewAlarm file, 112-114
NewClock file, 115-118
NewSlider file, 107-109
numbers, hexadecimal resource type, 217

octagon/hand icon, adding colors, 53-56
online services, 208
Open Circle tool, 28
Open Rectangle (Box) tool, 28
Open Rounded Rectangle (Box) tool, 28
opening files with ResEdit, 107
owner's name, adding to About the Finder dialog box, 150-156

PageMaker (Aldus), adding crosshairs to cropping tool, 73-76
Paint Bucket tool, 28

paint programs
    creating fill patterns, 95
    replacing Flying Toasters with Flying Mugs & Muffins, 186-200
    resources for editing, 206
palettes
    for color icon editors, 212
tear-off, 171-172
PAT (black-and-white pattern) resources, 214
PAT# (lists of black-and-white patterns) resources, 86, 214
ResEdit, 88-90
pattern editors
    adding ResEdit patterns, 88-95
    Calculator, 97-99, 170-175
    creating and adding patterns, 82-85
Pattern menu commands
    Pattern Size, 170-171
    Try Pattern, 84
Pattern Size (Pattern menu) command, 170-171
Pattern Size dialog box, 170-171
patterns
    black-and-white, 84
    creating, 89-90
    Calculator
        adding to, 95-100
        modifying, 169-181
    Desktop
        advanced, 100-104
        for Control Panels, 80-86
    relative, 93
    ResEdit, creating and adding, 86-95
    resource types, 214
Pencil tool, 28
Photoshop (Adobe), 109
PICK (resource picker) resources, 217
pickers, resource, 13, 217
PICT (PICT image) resources, 218
After Dark Clock, 116-118
Alarm Clock, 112-114
displaying, 108
editing, 109-111, 192-193
Flying Mugs, 190-193
Sound control panel, 107-109
pictures, mugs and muffins in Flying Mugs, 190-193
pipes, adding to File Sharing icons, 46-52
pointers
crosshairs, adding to PageMaker cropping tool, 73-76
hot spots, 74-76
I-beam text entry, editing, 66-69
resource types, 213
watch cursor, changing, 69-72
ppat (color pattern) resources, 214
Calculator, 96-100, 170-175
System, 101-104
ppt# (lists of color patterns) resources, 81-86, 214
ResEdit, 91-95
Preview at Full Size command
DLOG menu, 152
WIND menu, 159
previewing icons against different backgrounds, 37
program code resource type, 217
programs
Adobe Photoshop, 109
Aldus PageMaker, 73-76
Claris MacPaint, 109
editing resources in, 206-207
freeware, resources for editing, 207
Microsoft Word, 56-60
paint
creating fill patterns for, 95
replacing Flying Toasters with Flying Mugs & Muffins, 186-200
restoring unedited originals, 19-20
shareware, resources for editing, 207

displaying, 108
editing, 109-111, 192-193
Flying Mugs, 190-193
Sound control panel, 107-109
pictures, mugs and muffins in Flying Mugs, 190-193
pipes, adding to File Sharing icons, 46-52
pointers
crosshairs, adding to PageMaker cropping tool, 73-76
hot spots, 74-76
I-beam text entry, editing, 66-69
resource types, 213
watch cursor, changing, 69-72
ppat (color pattern) resources, 214
Calculator, 96-100, 170-175
System, 101-104
ppt# (lists of color patterns) resources, 81-86, 214
ResEdit, 91-95
Preview at Full Size command
DLOG menu, 152
WIND menu, 159
previewing icons against different backgrounds, 37
program code resource type, 217
programs
Adobe Photoshop, 109
Aldus PageMaker, 73-76
Claris MacPaint, 109
editing resources in, 206-207
freeware, resources for editing, 207
Microsoft Word, 56-60
paint
creating fill patterns for, 95
replacing Flying Toasters with Flying Mugs & Muffins, 186-200
restoring unedited originals, 19-20
shareware, resources for editing, 207

Q-R

Question Mark icon, 22-23
rebuilding Desktop, 38
recording sounds, flapping wings in Flying Mugs, 188-190
Recycle Icon file, 41-42
recycling bin icon, replacing Trash icon with, 40-42
small icon, 61-63
relative patterns, 93
replacing
After Dark Clock, 114-118
Flying Toasters with Flying Mugs & Muffins, 186-200
Alarm Clock controls, 112-114
calculator icon with cash register icon, 29-39
Sound slider, 106-109
streaking meteor with airplane in After Dark icon, 43-46
Trash icon with recycling bin icon, 40-42
small icon, 61-63
ResEdit, 12-16
alert messages, editing, 143-149
guidelines, 4-5
menus, colorizing, 126-133
opening files with, 107
patterns, creating and adding, 86-95
requirements, 4
resource types, 217
ResEdit Complete, 208
ResEdit Preferences file, 204
Resource menu commands
Create New Resource, 54
Get Resource Info, 54, 102-103
Insert New Pattern, 82
Insert Relative Pattern, 92
resource pickers, 13, 217

228 The ResEdit All-Night Diner
resources, 2-3, 9-10
actb (alert color table), 141-142, 215
acr (animated cursor), 72, 213
Time to Eat, 71-72
ALRT (alert), 141-142, 215
versus DITL resources, 145
BNDL, 218
Calculator icons, 30
cicn (non-Finder color icon), 213
After Dark, 43-46
clut (color look-up table), 217
CNTL (dialog box/window controls), 217
CODE (program code), 217
crsr (color cursor), 213
CURS (cursor), 213
PageMaker, 74
System, 67-69
Time to Eat file, 70-72
dctb (dialog box color table), 142, 215
displaying for editing, 14-16
DITL (dialog item), 142, 215
ResEdit, 144-149
DLOG (dialog box), 142, 215
editing
guidelines, 203-204
reasons for, 11-12
FOND (font information), 216
FONT (bitmapped font), 216
HEXA (hexadecimal number), 217
ic14 (large 16-color Finder icon), 39, 212
Calculator, 179
Microsoft Word, 57
ic18 (large 256-color Finder icon), 39, 212
Calculator, 30-38, 176-178
System 7 Finder, 47
ICON (non-Finder black-and-white icon), 213
System 7, 53-56, 121-122
ics# (small black-and-white Finder icon), 40, 212
Calculator, 181
ics4 (small 16-color Finder icon), 40, 212
Calculator, 181
ics8 (small 256-color Finder icon), 40, 212
Calculator, 180-181
ID numbers, 13
locations, 204-208
mctb (menu color table), 216
ResEdit, 129-133
MENU (menu), 216
ResEdit, 127-133
System, 122-125, 134-137
PAT (black-and-white pattern), 214
PAT* (lists of black-and-white patterns), 86, 214
ResEdit, 88-90
PICK (resource picker), 217
PICT (PICT image), 218
After Dark Clock, 116-118
Alarm Clock, 112-114
displaying, 108
editing, 109-111
Flying Mugs, 190-193
Sound control panel, 107-109
ppat (color pattern), 214
Calculator, 96-100, 170-175
System, 101-104
ppt* (lists of color patterns), 81-86, 214
ResEdit, 91-95
reasons for, 8-9
R0v# (replace ROM resource), 218
RSSG (editor), 204
sicn (small non-Finder black-and-white icon), 213
Finder, 61-63
snd (sound), 218
STR (text string), 216
STR# (lists of text strings), 216
     Calculator, 175-176
sUnt (slider unit), Flying Mugs, 196-198
sVal (slider value), Flying Mugs, 195-196
TEXT (text), 215
     Flying Mugs, 194-198
TMPL (template), 217
vers (version information), 218
wctb (window color table), 142, 215
WIND (window), 142, 215
     Calculator, 158-162, 167-169
restoring unedited originals of programs, 19-20
ROv# (replace ROM resource) resources, 218
RSSC (editor) resources, 204

Sad Mac icon, 22
selecting tools from toolbar, 27
Selection Rectangle tool, 27
Set 'WIND' Characteristics (WIND menu) command, 169
Shared Folder icon, adding pipes and faucets, 46-52
shareware, resources for editing, 207
sharing folders, 51-52
Show Balloons (Balloon Help menu) command, adding Speaking Man icon to, 120-125
sicn (small non-Finder black-and-white icon) resources, 213
     Finder, 61-63
slider, replacing, 106-109
small icons, changing, 61-63
snd (sound) resources, 218
     Flying Mugs, 187-188
Solid (Filled) Circle tool, 28
Solid Rectangle (Filled Box) tool, 28
Solid Rounded Rectangle (Filled Rounded Box) tool, 28
Sound control panel
     creating flapping wings in Flying Mugs, 188-189
     slider, replacing, 106-109
sounds, flapping wings in Flying Mugs, 187-190
sources for help, 208-209
Speaking Man icon, adding to Show/Hide Balloons (Balloon Help menu), 120-125
Spicy Calculator
     patterns, 169-181
     preparing Calculator for changes, 166
text strings, 175-176
     viewing changes, 181-183
     window, 167-169
Standard 256 Colors (Color menu) command, 177
starting System, troubleshooting, 22-23
startup floppy disks, 22-23
STR (text string) resources, 216
STR# (lists of text strings) resources, 216
     Calculator, 175-176
strings, text
     Calculator, modifying, 175-176
     resource types, 216
styles, applying to menu items, 133
submenus, colorizing, 131
sUnt (slider unit) resources, Flying Mugs, 196-198
sVal (slider value) resources, Flying Mugs, 195-196
System
     files, editing, 205-206
     Trash, 41-42
troubleshooting, 22
  finding, 23-24
  starting, 22-23
System 7
  adding to menu items
    icons, 120-125
    keyboard shortcuts, 134-137
  alert box icons, colorizing, 53-56
Desktop patterns
  adding, 80-86
  advanced, 101-104
document icons, editing text, 56-60
I-beam cursor, editing, 67-69
Shared Folder icon, editing, 47-52
small icons, changing, 61-63
System folder, 23-24
  After Dark Files folder
    Clock, replacing, 115-118
    Flying Toasters, 186-200
Apple Menu Items folder, see Apple Menu Items folder
Control Panels folder, see Control Panels folder
Finder
  adding owner's name to About the Finder dialog box, 150-156
  replacing watch cursor, 70-72
  small icons, changing, 61-63
System 7, see System 7
System folder icon, 23

T
  tear-off palettes, 171-172
  technical support, 208-209
  templates, 14-16
  text
    editing in document icons, 56-60
    in Flying Mugs, 193-198
    menus, colorizing, 129-131
    resource types, 215-216
  strings, modifying in Calculator, 175-176
  styles, applying to menu items, 133
TEXT (text) resources, 215
  Flying Mugs, 194-198
text entry pointer, editing, 66-69
Time to Eat (Window menu)
  command, 71
Time to Eat file, 70-72
titles in menus, colorizing, 129
TMPL (template) resources, 217
toolbar, 26-28
Trash icon, replacing with recycling bin icon, 40-42
  small icon, 61-63
troubleshooting
  checking general trouble spots, 20-21
  discarding changes, 19-20
  symptoms, 18-19
  System, 22
  finding, 23-24
  starting, 22-23
Try Cursor (CURS menu) command, 68
Try Pattern (Pattern menu)
  command, 84

U-V
  user groups, 209
vrs (version information)
  resources, 218

W
  watch cursor, changing, 69-72
  wctb (window color table) resources, 142, 215
WIND (window) resources, 142, 215
  Calculator, 158-162, 167-169
  'WIND' Characteristics dialog box, 169
  WIND editor, modifying Calculator window, 158-162, 167-169
WIND menu commands
   Auto Position, 158
   Preview at Full Size, 159
   Set 'WIND' Characteristics, 169
Window menu commands
   Finder copy, 71
   Time to Eat, 71
Window with Title Bar icon, 152
windows, 141
   alerts, see alerts
   Calculator desk accessory, modifying,
      157-162, 167-169
   centering on-screen, 158
   changing positions, 156
   closing, 169
   dialog boxes, see dialog boxes
   icon editor, 26-27
   resource types, 141-142, 215
wings, flapping in Flying Mugs, 187-190
Word (Microsoft), editing text on icon,
   56-60

X-Z

x (hot spot) tool, 75

Zen and the Art of Resource Editing, 208
About the Disk

The disk included with this book contains ResEdit 2.1.1 and six resource files to use with the recipes in this book. The disk is an 800K Macintosh (HFS) format disk. ResEdit requires at least System 6.0.2 and 1M of memory. The recipes in this book generally require System 7; although color is generally not necessary, several of the recipes also make use of color. A hard disk, though not absolutely necessary, is strongly recommended.

To use the disk, copy the contents to your hard disk. ResEdit is now ready to use. (You can run ResEdit off the floppy, but it's much better to use your hard disk.)

The other element of the disk is a folder that contains resources to use with some of the recipes in this book. (The folder also includes a Read Me file, describing the resources.) The files are compressed. To extract them, double-click on the Diner Files.sea icon. Click on the Continue button; you will then see a Save File dialog box. Choose a location on your hard disk to save the files, then click on the Save button. After the files are extracted, click on the Quit button in the dialog box that appears. The files are now ready for use.

ResEdit 2.1.1

ResEdit is a resource editor—it enables you to edit special parts of your Macintosh programs, called resources. This book explains what that means; essentially, it means that you can change the way your programs work. ResEdit requires no programming knowledge.

Diner Files

The Diner Files are six files of resources that are designed for use with some of the recipes in this book. For details on how to use the files, see the appropriate chapters:

- Time to Eat: see Chapter 5, “Fresh Pointer Pie”
- Desktop Patterns: see Chapter 6, “Golden Fried Patterns”
- New Slider: see Chapter 7, “Fresh-Picked PICTs”
- New Alarm: see Chapter 7, “Fresh-Picked PICTs”
- New Clock: see Chapter 7, “Fresh-Picked PICTs”
- Mug Resources: see Chapter 11, “Blue-Plate Special”
The ResEdit™ All Night Diner

At the ResEdit All Night Diner, we bring you the tastiest treats for your Macintosh! We use recipes that take away all the guesswork. You don’t even need to know how to use ResEdit or how to program. We take care of the details and let you enjoy your more flavorful Mac.

ResEdit (included on a bound-in disk) lets you edit parts of your Mac software, such as icons, menus, dialog boxes, pointers, patterns, and more. Just follow the wonderful collection of recipes inside. They’ll show you how to painlessly change the way your Mac looks and works. Find your favorite dishes. Dig in — and enjoy!

Today’s Specials!
Tempting Mac power platters! At the diner we use only the finest ingredients, assembled in step-by-step, no-hassle recipes. Try out these savory treats!

- Environmental Special .................................................. Chapter 4
- File Sharing Makeover .................................................. Chapter 4
- Missing I-Beam ......................................................... Chapter 5
- Calculated Patterns .................................................... Chapter 6

ResEdit Chef’s Creations!
Walt and his staff have created an inviting array of specialties that will tempt your Macintosh taste buds! Sample these garden-fresh dishes — they’re delicious!

- Colorized Icons ......................................................... Chapter 4
- Savory Small Icons ..................................................... Chapter 4
- Desktop Diversity ....................................................... Chapter 6
- Alarm Alterations ....................................................... Chapter 7
- A Balloon for Balloon Help .......................................... Chapter 8

Mouth-Watering Desserts! Power-Boosting Libations!
Save room for these amazing creations fresh from the ResEdit kitchen! These divine selections give your plain-vanilla Macintosh a double-fudge burst of flavor!

- Bumper Crop .......................................................... Chapter 5
- Clock of Ages .......................................................... Chapter 7
- Renovated ResEdit Alerts ............................................ Chapter 9
- Blue-Plate Special ..................................................... Chapter 10
- Breakfast Special ...................................................... Chapter 11

$24.95 US/$31.95 CAN
Category: General Macintosh
Hayden Books