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Introduction
by T. Kelley Boylan

Microsoft Office for the Macintosh puts remarkable presentation and organization power in a single package. Each of its components is a complete application-not a pared version, as in Microsoft Works or ClarisWorks-and each
component is a powerhouse unto itself. Microsoft Word and Excel are the
current market leaders in word processing and accounting, respectively.
PowerPoint has taken Aldus Persuasion head-to-head. There is a trade-off in
having so much power all at once-a full installation of Microsoft Office will
take considerable hard drive space, but it's quite a package.
Office for the Mac brings the Macintosh Office applications in line with those
in the Microsoft Windows version. They now match nearly feature for fea-

ture. Previous versions of Word, Excel, and PowerPoint were different on the
PC and Mac, but with these latest versions, you'll be able to work in a crossplatform environment much easier. You won't have to hunt for items on one
platform that might not even be available on the other.

Who Should Use This Book?
Using Microsoft Office 4.2 for the Macintosh, Special Edition, describes the basic
operation of Microsoft Office for the user who is familiar with the Macintosh
operating system, knows how to use a mouse, and can navigate through standard open dialog boxes. It describes not only the functionality of each of the
Office applications but details how to go about creating, saving, and linking
documents.
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How This Book Is Organized
Using Microsoft Office 4.2 for the Macintosh, Special Edition, is divided into
eight parts.

Part 1: An Improved Software Team
Chapter 1, 11 Members of the Team," introduces the members of the Microsoft
Office team, describing what applications are included and how Microsoft
intended them to be used. It discusses the common parts of the user interface
and how the applications work with each other as a suite. Some functions are
replicated in the suite; for example, should you create a table in Word or
Excel? You'll find out in Chapter 1.
Chapter 2, 11 Using Common Features to Create Documents," introduces the
list of common features-parts of the Office suite that are common to all
applications. It also describes how to install and launch each of the different
parts and shows you how they work as a whole. You also find out how to
move between applications. A discussion of the new tool bars and their
implementation lets you know what parts of the Office suite exist across all
applications and which are specific to one application. If you're not entirely
familiar with the Macintosh operating system, there are a few tips on using a
windowing environment and navigating through dialog boxes, menus, scroll
bars, and so on. A number of features may be new to some users, like drag
and drop and the toolbars. There's more to using an application than just
knowing basic operations, so Chapter 2 also includes descriptions of keyboard shortcuts and formatting tricks. Finally, it covers the integrated help
system and wizards, and provides a quick demonstration.
Chapter 3, 11 Managing Files and Work Areas," is devoted to how Office fits
into the Macintosh environment and covers opening, closing, and saving
files. It also details file dialog boxes, disks and drives, and contains descriptions of the Mac operating system's folder hierarchy. Because keeping up with
all the files on a hard drive or just within Office can be daunting, there's a
section on finding files via the Search dialog box. Printing, another part of
the Macintosh environment, is covered in Chapter 3 as well. One of the hallmarks of the Mac is built-in multitasking, so switching between applications
and documents is included here, too. At the end of Chapter 3 is a quick description of each of the document types that you'll find in Microsoft Office,
Word, Excel, and PowerPoint.
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Part II: Using Word
Chapter 4, 11 Creating and Editing Documents," gets you started using
Microsoft Word by discussing the text window, the cursor, and various tools
to create documents. You'll learn how to save, close, and open documents, as
well as how to open and save groups of documents.
Chapter 5, 11 Formatting Text and Documents," takes on basic formatting
issues and the different ways of viewing a document. Fonts and their styles
and sizes are discussed, as are paragraphs and their attributes. In handling the
text, you find out how to work with tabs, indentations, and page formats as
well.
Chapter 6, 11 Proofreading and Printing," moves into the final steps of document creation. It discusses the built-in thesaurus, dictionary, and AutoCorrect
as part of the proofing process. For output, it discusses both document and
envelope printing.
Chapter 7, 11 Managing Files," takes you through file management procedures--keeping everything you've created in an organized structure. You may
want to use the Summary Info function to track documents, and you may
need to keep up with statistical information within and throughout documents. Viewing and previewing documents are also discussed, as are sorting
and selecting, so you can get to the information you need.
Chapter 8, 11 Customizing Word," shows you how to make your copy of Word
personal. Word allows you to change almost any attribute of the menus,
command keys, or the various settings. You can customize printing, revisions,
grammar, spelling, save options, and so on.
Chapter 9, 11 Working with Large Documents," shows you how to outline
larger documents. Once you're comfortable with the basics learned in previous chapters, you'll want to move on to advanced formatting and style
sheets. Word includes a style gallery and wizards to help you automatically
format a document.
Chapter 10, 11 Working with Tables, Charts, and Graphics," introduces you to
tables, charts, and graphics that allow you to dress up your documents and
make them more specific. Simply describing data may not be enough, and a
graphic or table of that data may be what you need. Working with tables and
charts is a little different from working with standard text files, and how to
handle tables and text is described in detail. For example, Microsoft Graph
can help you create graphs even though it's actually a separate application
from Word.
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Chapter 11, "Automating with Macros and Mail Merge," takes you further
into the esoteric abilities of Word. You can create and save macros as well as
use Word's standard macro set. Mail merge has its own rules and regulations,
which range from identifying a source to merging data and a final document.

Part Ill: Using Excel
Chapter 12, "Creating Worksheets," introduces basic worksheet operations,
defining the terms to be used and illustrating keyboard and mouse controls.
Following that, it covers entering text, data, and dates, as well as formulas.
Because it handles each in a slightly different manner, there is separate coverage of text, numbers, and dates. In using Excel, you'll be creating Workbooks
and maybe even using other file formats.
Chapter 13, 11 Editing Worksheets," takes you into the worksheets: editing
existing data and manipulating new data--everything from copy/paste to
drag-and-drop. It also includes information on inserting and deleting columns, rows and entire spreadsheets, plus descriptions of how to name each
of them. Because a Worksheet can grow to large sizes, you may need to do a
search and replace to keep up with changing data.
Chapter 14, "Formatting Worksheets," illustrates how to format the
worksheets you learned to create in previous chapters, detailing column
width and heights, aligning data and text, formatting text, and applying
colors and borders. This chapter also covers style sheets that can simplify
creating and maintaining your text styles. Excel also handles graphic
objects; that process is described in the latter sections of the chapter.
Chapter 15, "Using Formulas and Functions," introduces you to the use of
formulas, and tells you how to create them and what they consist of. After
you create a macro, you may need to debug it or use some of the internal
functions built into Excel. In order to make the formulas more powerful,
Excel allows them to be linked to each other and to other Workbooks. And
because Workbooks may grow to be large, it allows you to work with ranges
of them.
Chapter 16, "Creating and Printing Reports and Charts," tells you how to
output your documents, sending either an entire Worksheet or only selected
data to a printer (large Worksheets may need to be broken down into vertical
and horizontal sections). Information you can put in headers and footers lets
you keep track of what pages you have as well as their dates of creation and
modification. You can also create different views of a report to make it easier
to handle the data. Similarly, you may want to see only a chart rather than
the entire data set.
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Chapter 17, "Managing and Analyzing Data," shows you how to create and
edit lists, sort and filter the data in those lists, and begin making subtotals.
Functions for pivot tables are described, too, as are functions to use in forecasting. Here the program begins to get complicated, so Excel provides a
Problem Solver to help you, along with several What If scenarios. After you've
analyzed the data, it allows you to annotate your worksheets. A similar function is that of note taking, which is covered here.
Chapter 18, "Automating with Excel Macros," confines itself strictly to Macros-how to plan, create, and use them. Macros can even be added to the
Microsoft Toolbar.

Part IV: Using PowerPoint
Chapter 19, "Getting Acquainted with PowerPoint," introduces you to the
various parts of PowerPoint and how they interrelate. PowerPoint has slightly
different toolbars, rulers, and guides from the other components in the suite,
and they are described in detail. Because PowerPoint is presentation software,
chapter sections are devoted to the Templates that allow you to create attractive visual effects faster than you could by yourself.
Chapter 20, 11 Creating, Saving, and Opening Presentations," demonstrates
creating, opening, and saving presentations. You learn how to build a presentation from scratch, use a template as a basis, or combine the two processes
via the AutoContent Wizard. Once you have a presentation to work with,
you learn how to add and delete slides and how to zoom in and out of them.
There are six different views, plus Master views, of a presentation.
Chapter 21, "Entering Slide Content," describes the process of entering data
into the slides, whether it be via the AutoLayout functions or by creating
your own objects. PowerPoint also includes a spell checker and several internal modules, like Microsoft Graph and Chart, which are separate components
of PowerPoint. They are applications that run within the suite. The whole
point of a suite is putting the parts together, and this chapter discusses inserting Word and Excel tables and worksheets into a suite, as well as inserting
graphs, charts, and objects from non-Office applications.
Chapter 22, "Working with Objects," covers handling objects: from inserting
to copying, and flipping to rotating. Objects may be scaled, aligned, or locked
to a grid.
Chapter 23, 11 Drawing Shapes, Curves, and Lines," shows you how your artistic talents can be brought into play via the drawing tools in PowerPoint. You
can use the AutoShapes function to bring in predefined shapes or draw your
own objects. Tools exist for creating arcs, lines, and freeform shapes.
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Chapter 24, Enhancing a Presentation," illustrates ways to improve your
presentation with templates, fonts, colors, and lines. Individual objects or
whole presentations may be shaded and colored. Attributes and entire color
schemes may be copied from one presentation to another.
11

Chapter 25, "Creating Charts," brings the details of Microsoft Graph into
focus. Microsoft Graph is a separate utility for creating graphs that uses many
functions found in Excel. Data can be plotted by row or column, and the
resulting graphs (pie, bar, or line) may be colored in any number of schemes.
Because data alone rarely tells the whole picture, this chapter describes how
to create labels and set the fonts and colors for them. Finally, it describes how
a finished graph is inserted into a slide.
Chapter 26, 11 Creating Output," discusses displaying and printing the results
of your operations. Power Point has a number of ways to print a presentation-notes, handouts, outlines, or slides. And of course, you want to create
and view a whole presentation, whether it's on a slide or on-screen.

Part V: Working Together with Microsoft Office
Applications
Chapter 27, 11 Viewing and Organizing Files and Working with System 7.5,"
takes you outside the Microsoft Office applications and illustrates how the
Macintosh organizes files. It describes hard drives, folders, and methods of
searching for and moving files. Office applications have a function called
Summary Info that you can use to help organize your data.
Chapter 28, 11 Working with Wizards, Multiple Documents, and Cut, Copy,
and Paste," is devoted to Wizards and interapplication communications.
It discusses ways to move material between Excel, Word, and PowerPoint,
plus how to frame pictures inside the applications.
Chapter 29, 11 Sharing Data between Applications with Linking and
Embedding," is similar to Chapter 28 in that it covers some interapplication
issues, but this chapter is devoted to OLE (Object Linking and Embedding).
You may need to link information in an Excel spreadsheet to a document in
Word, and this chapter tells you how to do so.
Chapter 30, "Sharing Data between Applications with Publish and Subscribe,"
continues in the direction started by Chapters 28 and 29 but covers Publish
and Subscribe and how to use it.
Chapter 31, 11 Using Mail with Other Microsoft Office Products," describes
how to send the data you have compiled out into the world via Microsoft
Mail.
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Chapter 32, "Using Office Applications with PowerTalk," adds to Chapter 31
by covering Microsoft Office's implementation and use of PowerTalk, as found
in System 7.5.
Chapter 33, "Sending a Mass Mailing," details the preceding chapters by going
into mass mailings and mail merge. Data from several applications can be
used, and both recipients and incoming mail can be sorted and selected. To
help keep up with who's where, the mailer provides a search facility and mailing lists.
Chapter 34, "Using Office Applications to Create a Presentation," illustrates
how to use Microsoft Office to create a complete presentation: from the Word
outline through charts and graphs to embedding the whole project in a mail
message.
Chapter 35, "Using Office Applications to Create a Newsletter," is similar to
Chapter 34 but illustrates the creation of a newsletter with headers, footers,
and graphics. It covers both the drawing tools in Word and PowerPoint as well
as charts from Excel.

Part VI: Customizing Microsoft Office
Chapter 36, "Changing Toolbars and Menus," provides details for making
Microsoft Office your own with custom toolbars and menus. It also discusses
the Microsoft Office Manager and its uses.
Chapter 37, "Using Visual Basic for Applications," brings in the latest in
Word's capabilities. It's a complete programming language built into the Word
application.
Chapter 38, "Using AppleScript with Office Applications," covers AppleScript,
a scripting language you can use from within or outside the Microsoft Office
applications. With it you can automate repetitive tasks and simplify complex
tasks.
Chapter 39, "Exchanging Data with Microsoft Windows Versions of the
Office Applications," closes the main body of the book with information
on moving data between the Mac and IBM versions of Office applications.
With this release of Office, this task has been simplified considerably.

Part VII: Appendixes
Appendix A gives you an overview of the installation process-what parts you
might need or might not want. It is followed by Appendix B, Index of Common Problems, which references the troubleshooting tips found throughout
the book. You can use this index to help you if something goes awry. Finally,
the standard index puts everything in the book at your fingertips.
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Introduction

Conventions Used in This Book
Messages that appear on-screen are printed in a special font: Document 1. New
terms are introduced in italic type. Text that you type appears in boldface.
The programs included with Office provide toolbars for your convenience.
By clicking a button in the toolbar, you can execute a command or access a
dialog box. Button icons are provided in the margins where appropriate,
indicating which button you can click to perform a task.
Tip
This paragraph
format suggests
easier or alternative methods
of executing a
procedure.

Note
This paragraph format indicates additional information that may help you avoid
problems or that should be considered in using the described features.

Caution
This paragraph format warns the reader of hazardous procedures (for example,
activities that delete files).

Troubleshooting
This paragraph format provides guidance on how to find solutions to common
problems.

Using Microsoft Office 4.2 for the Macintosh, Special Edition, uses margin crossreferences to help you access related information in other parts of the book .
..,. See "Section
Title," p. xx

Right-facing triangles point you to related information in later chapters.
Left-facing triangles point you to information in previous chapters.

Part I

Quick Preview
EHamples And Demo~

·------

An Improved
. = oftware
Team
1~g1g%
:o:::::•::::::.::•::•:•::::o:::.~.~
.
.. ......................... -. . .............................
· -~
llihJi:vi[@I~IIF~I~ ~ Z~

rm

::o:::::::::::::::'::::::':' r:h.;t·+

.,,J.

Lc;:::r:::::z::z::~~~~:r.::::::::::~~:.:::::;;:~::::zz:!l:~~+4ra._.

D 00_ ·.

~. ··..[~I

L~J. ~!J. W ··":'~

llJizard.- St~p ~- o~_4
1:Table V·lizard builds ani nte
1ze::; datEJ fr-orn Microsoft Ex:c

!
i

i

l

.I

l

I

II

!L.·c:.......·- - - -

(... E:de r n;3 1 Data Source
c· t··lulti ple Consolidation ReruJe

.JIIUL&...J

U U t i U U I I '-'

Quick Preuiew
EHamples find Demos

r.t

·•

··0
::

., AutoSh:;p,.s!

0 0 \] 0
lo1o 0 BJ

-··· Ctl ·:t- rt. !!iiil;~g ;;;g ~~Hftiii!;i~~;~

··········g:-:;:::::::::
::::::::::
•• t····n··••· .
.....................

llll.l·J ~I [§]~

r>

~

h
'b
~

......

___ :~-~~

~~

0
0
{f .0.

*

6 ~~

,- PiuotTable UJizard - Ste

=-.:;;:::::::;:;.:....:..--::=--

The PivotTabh: V·li~ard

1

b~ild '

s ummarizes d:~te from Mtcros'
-sour,~e

CrMte p 1votTsble from data ir

t-licrosoft Excel List o
0 External Date Source
0 r·lulti ple Consolidatio!
(i"

G

WHHHH~. ,W??/.rH/.W/."

~-

- =

.. •

ntT ,••lo?

Tip: To learn more about Pivo

Produ 9 ,
'--__..~~

(

Help

)(

Cancel

)

l 'Ba~l!

-

Chapter 1

Members of the Team
by Tom Negrino

Combining a number of a vendor's individ ual software products to sell as one
unit is not new. Software bundles have been around for years. However, what
is new is the full integration of these software products. Integration no longer
means just switching between different applications, or using one application
that unsuccessfully attempts to do the work of four applications. True integration allows you the freedom to easily combine documents from different
applications, and to draw on the full power of any application to modify that
document, regardless of which application you're using.
In what is termed the office suite, leading software vendors provide core office
applications such as word processing, spreadsheet, and presentation graphics,
along with auxiliary applications. The core products are the award-winning
applications in their categories. The auxiliary applications the vendors add
often include such items as electronic mail, graphing, personal information
management, and organization charting. The entire suite of products is offered for as much as SO percent less than the sum of the individual product
purchase prices.
Microsoft Office leads the way with key applications that work together and
offer a common user interface. The applications look alike and work alikethus reducing the learning curve and improving productivity. Microsoft
Office makes it easy for users to share data, documents, and graphics across
applications. Using Office applications on the Macintosh also makes it easier
to share documents with coworkers that use the corresponding Office
programs on their Windows-based IBM PC-compatibles. With Office for
Macintosh 4.2, the latest version of the product, Microsoft has brought parity
to the Windows and Mac versions of Office. Mac and Windows versions of
the programs look and work almost identically, so similar are they in fact that
Microsoft offers the same set of user manuals for both platforms.
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In this chapter, you learn
• What's included in Microsoft Office
• The design goals of Microsoft Office
• How to determine which application to use

What's Included in Microsoft Office
The standard edition of Microsoft Office includes the following applications:
• Microsoft Word, Version 6.0
• Microsoft Excel, Version 5.0
• Microsoft PowerPoint, Version 4.0
On the Windows platform, there is a professional edition of Office that
includes a relational database, Microsoft Access. At press time, Microsoft has
not announced a Mac version of Access, and there is no comparable database
product in the Mac version of Office.

Design Goals of Microsoft Office
The goal of Microsoft Office is to provide users with the following:
• A common user interface (standardized operation of menus, toolbars,
and dialog boxes)
• Quick access to one office suite application from another
• Data shared across applications
• Resources shared across applications
• In the future, a common task automation language
Microsoft strives to meet these goals. Many of the core applications underwent (and continue to undergo) revisions to meet these goals. To some longtime users of a core product, the resulting menu or toolbar changes may be
annoying. In the long run, however, a common user interface across applications increases efficient and effective use of all applications.

Design Goals of Microsoft Office
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Providing a Common User Interface
A clear benefit of a common user interface across applications is that by
learning one application in the suite, you know the operational basics of the
other applicatio ns. Figu re 1.1 illustrates the similarity between the Excel and
Word menu bars and toolbars. Notice that Word has a Table m enu option,
but Excel has a Data menu option . Although the goal is to provide one common user interface, some degree of uniqueness remains in each application.
However, common key fea tu res such as the Open and Find commands can be
found in exactly the same p lace in each applicatio n.
Word menus and toolbars

Fig. 1.1
Menus and
toolbars are
consistent across
applications.
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Microsoft Office applications provide consistency in m ore th an just similar
toolbars and m enus. Dialog boxes, customizable featu res, and operational
features are similar, too. On-line help is available in several forms in all
applications:

~

See "On-Line
Help," p. 51

~

See "'How To'
Windows and
Cue Cards,"
p.56

~

See "Wizards,"
p.56

~

See "Tip of the
Day," p. 54

• Help Application
• Cue Cards
• Wizards
• Tip of the Day

Quick Access to Other Applications
Microsoft Office provides a control panel called Microsoft Office Manager
(MOM). Office Manager appears as a menu icon on the right side of the menu
bar, next to the Help menu icon (see fig. 1.2).
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Fig.1.2
The Office
Manager menu
provides easy
access to the Office
applications.

You can use Office Manager to do the following:
• Switch between Microsoft Office applications
• Launch Microsoft Office applications
• Add other applications and documents to the Office Manager toolbar
• Access Office features such as Setup and Cue Cards
Office Manager is just one way that Microsoft Office provides quick access to
applications. In each Microsoft Office application, the application toolbar
provides direct access to pertinent features of other applications. For example,
in Word you can insert an Excel Worksheet into a document by simply clicking a toolbar button. Doing so launches Excel and provides the full features
of Excel for that embedded worksheet (see fig. 1.3). Notice that without hav·
ing to leave Word, the menu and toolbars change to Excel when you edit the
worksheet.
II> See "Switching

between
Documents,"
p. 79
II> See "Switching

between
Applications,"

p.Sl

Sharing Data Across Applications
Microsoft Office products provide several methods for sharing data between
applications:
Method

Description

Copying

Copies the data from the source application to the target
application using the Clipboard.

Design Goals of Microsoft Office

Method

Descriptio n

Linking

Links a copy of the data to the original document
(saves data with the original document).

Embedding

Embeds data from the source document into the target
document (saves data with the target document).

..
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Fig . 1.3
Connectivity
between applications allows you to
insert an Excel
worksheet into a
Word document,
and edit the
worksheet using
Excel menu and
toolbars without
leaving Word.
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The Microsoft Office applications share data effortlessly. When you copy a
table from Excel to Word, for example, you get a Word table that retains all
the font and formats from Excel. You do not need to reformat your table, as
you might with some other products.
Linking and embedding features take advantage of the new Microsoft OLE 2.0
specification s. OLE stands for Object Linking and Embedding. Linked documents automatically update wh en a source document changes. Embt!dded
documents provide access to the source application while storing the data in
the target application. Each feature has its pros and cons and serves a specific
purpose.
Microsoft Office extends data sharing beyond application integration, by
providing workgroup integration with Microsoft Mail. Users can mail documents, spreadsheets, and data files from within the source application.
Routing slips can be attached to files that are sent to the Mail server, then
broadcast to the group all at once-or routed to each person, in sequence,
one at a time.

....

See "Copying
Spreadsheet
Information"
p. 593

.... See "Inserting
Clip-Art
Pictures,"

p. 460
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Sharing Resources Across Applications
A key element in Microsoft Office is the recognition that certain resources are
needed by each application. Clip art is needed to perform word processing
tasks, spreadsheet tasks, database tasks, and presentation graphic tasks, for
example. Rather than duplicating program overhead, Microsoft Office provides an auxiliary application, Microsoft ClipArt Gallery, for use with all applications. The same is true of the need for a query engine (to ask questions
of your data), a graphing tool (see fig. 1.4), and an organization chart drawing tool. And Microsoft Office deals with them all in the same manner by
providing a single auxiliary application.
Fig. 1.4
Microsoft Graph,
one of the
auxiliary applications that ship
with Microsoft
Office, is used by
all applications to
draw graphs.

Providing a Common Language
Providing a common language across applications is the most challenging
goal of Microsoft Office. In the past, each product has had a different programming and/or macro language. Excel Version 5.0 is the first Microsoft
Office suite product to provide what will be the common language of the
Office products: Visual Basic, Applications Edition (VBA). VBA uses OLE 2.0 and
can send keystrokes to other applications (making it possible for VBA to run a
cross-application process).
Until VBA is added to the other suite products, users will have to learn both
WordBasic (Word's macro language) and VBA to automate common office

Determining Which Application to Use
tasks with Microsoft's language tools. Apple has a solution that can be used
today, however. System 7.5's AppleScript scripting language can serve as a
go-between for VBA and WordBasic, as both of these languages are accessible
from AppleScript. You can write scripts that trigger macros in either program,
transfer data between programs, or perform a complex series of tasks using
both programs.

Determining Which Application
to Use
The following table lists some common office tasks and the suggested application tools to accomplish the tasks.

Task

Application

Comments

Mailing lists

Word

Merge data into Word to print
personalized cover letters,
brochures, and labels

Table of financial
data to be used in
a presentation

Excel

Create a table in Excel

Powerpoint

Embed table into
PowerPoint slide

Send a document to a
group of people for
feedback, and receive
a response

Word, Excel, Mail

Create the document,
spreadsheet, or presentation
in the desired application(s);
Send the file(s) using Mail's
routing feature

Provide audit trail
between supporting
spreadsheet data and
annual report document

Excel

Create the supporting
schedules needed in Excel.

Word

Create the annual report
document in Word. Use OLE to
link the data from Excel to the
Word document. Whenever the
spreadsheet data changes, the
annual report document is
updated automatically

Word

Create newsletter in Word

Mail

Distribute newsletter
electronically using Mail's Send
feature

Create, print and
distribute department
newsletter
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~

See "Using
Macros," p. 212

~

See "Using the
Macro Recorder
to Automate a
Task," p. 398

~

See "Understanding Visual
Basic for
Applications,"
p. 743

18

Chapter 1-Members of the Team
With three or four new software applications so tightly integrated, deciding
on which product to use for which task could be difficult. Experience with
each application is the best guide on how to combine the powers of each
application to meet your needs. The rest of this book is dedicated to helping
you in this endeavor. The next few chapters review the common features
found in all suite applications and point out any digressions. Parts II through
IV guide you through the features and capabilities of each product. Part V
provides business scenarios to illustrate how Microsoft Office products work
together. Part VI teaches you how to customize Microsoft Office with your
own toolbars, menus, and automation (macros and VBA).
Sit back and enjoy the new way of working that Microsoft Office provides.

From Here ...
Now that you are familiar with the new way of working that Microsoft Office
offers, you are ready to begin learning the common features of Microsoft
Office. The following chapters explain some of these common features:
• Chapter 2, "Using Common Features to Create Documents," teaches
you how to start Microsoft Office, use menus, toolbars, dialog boxes
and Help, and how to navigate the windows.
• Chapter 3, "Managing Files and Work Areas," teaches you how to work
with files and print documents, and guides you through the work areas
of each application.

Chapter 2

Using Common
Features to Create
Documents
by

Tom Negrino

One of the benefits of Macintosh applications is that after you know one
application, each new application you learn is easier than the previous program. This is especially true with Microsoft Office 4.2 applications. Microsoft
has redesigned each of the programs for consistency with the other applications in the suite. Microsoft reorganized menus, toolbars, and dialog boxes so
that the products are now even more similar. For experienced users, this can
be a little disconcerting. If you're a former Word 5.1 user and are looking for
Document format, it's no longer on the Format menu; it is now called Document Layout, and you'll find it on the File menu. These changes can be annoying at first, but the benefit of finding the same commands in the same
place across numerous applications is worth the initial bother.
In this chapter, you learn to
• Start and exit programs and files
• Move between programs
• Move around the screen
• Use menus and dialog boxes
• Type, edit, copy, and move text
• Use Help
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Launching Programs
just as with other Macintosh procedures, you can launch an application in
several different ways. You can use the keyboard or the mouse or both together. Microsoft Office 4.2 even adds a new way to launch programs
through the Office Manager menu.

Launching a Program from the Finder
The standard way to begin any application is to double-click the folder icon
where the application is located, thereby opening the folder, and then to
double-click the program icon for the application you want to start. Depending on how you installed the Office applications, each program-Word, Excel, and PowerPoint-is probably in its own folder. If you installed all the
applications in one folder, double-click the folder icon (you probably named
it Microsoft Office) and then double-click the desired program icon.
Each Office program's files can be easily identified in the Finder, because they
have distinctive icons. Table 2.1 shows the programs and their icons.

Table 2.1

Icons for the Office Applications

Program

Application Icon

Word

~

Excel
PowerPoint

•
~

Document Icon

•
~

fi

Looking at Microsoft Office
Microsoft Office 4.2 has added a new control panel, the Microsoft Office
Manager, that makes it much easier to start programs and move between
them when they're open (see fig. 2.1). The Office Manager is a menu that
appears at the right edge of the menu bar, and includes all the Office applications. You also can customize Microsoft Office Manager to include additional
applications and documents on its menu.

Quitting Programs

W.

About Office Manager•••
Quick Start •••

'P Microsoft Word

S Microsoft EHcel
{J Microsoft PowerPolnt

IJ4i Find File •••
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Fig. 2.1
The Microsoft
Office Manager
menu includes
all the Office
applications.

IE) Customize •••
~ Setup and Unlnstall •••
Iii Office Cue Cards
Office Help

Installing Microsoft Office
If you haven't installed Microsoft Office, insert the Setup disk from one of the

applications and double-click the Setup application icon. Click the Continue
button and follow the instructions on-screen. Be prepared for a lot of disk
swapping; the complete Office installation runs more than 30 high-density
floppy disks. For more information on setting up Microsoft Office and the
applications, see Appendix A, 11 1nstalling Microsoft Office."
If you've already installed Office, double-click one of the Office applications'

icons to start it, or choose an application from the Microsoft Office Manager
menu.

Moving between Programs
You can move between programs in three different ways. You can choose an
application from the Microsoft Office Manager menu to start or switch to a
program. You also can switch back to the Finder and double-click another
program icon. Or, you can use System 7.S's application menu (at the far right
of the menu bar) to switch between open programs.

..,. See "Switching
between
Applications,"
p.81

Quitting Programs
After you've worked in an application and no longer need to use its features,
you'll probably want to quit the application, especially if you have limited
memory. All Macintosh programs quit the same way. You can do one of the
following:
• Open the File menu and choose Quit.
• Press

~+Q.

If you haven't saved changes to your documents, you'll see a dialog box ask-

ing if you want to save changes to each of your open documents. You'll probably want to save your documents. If prompted, fill in the Save As dialog box.

..,. See "Moving
between Office
Programs,"
p.S76
..,. See "Saving,
Opening, and
Closing Files,"
p.62
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Note
Don't confuse closing a document with quitting an application. If you close a document window by clicking its close box o r choosing Close from the File menu, the
application program that created that document is still open and taking up system
memory. To free up RAM so that you can open up other programs, you must quit
the application that you're in.

Viewing Parts of the Window
....

See "Using the
Word Screen,"

p.88

....

See "Defining
Excel Terms,"
p.229

....

See "Getting
Familiar with
the PowerPoint
Window,"

p.414

One of the best parts of using the Macintosh is the similarity between different applications. When you learn one program, the next and subsequent
programs are easier to learn. This is especially true because parts of the window are similar.

Common Window Elements
Figure 2.2 shows the basic elements on a screen that are common to each
application. Each application usually displays the application window itself
and usually at least one document window. Table 2.2 lists the common elements on the application window and the document window.

Fig. 2 .2
The screen
provides many
choices you can
manipulate using
the mouse.

Menu bar
Toolbars

As a new m ember, you're entitled to:

12 issues of our award-winning newsletter,
Mac Digest
Access to our Bulletin Board System (BBS),
which is graphically based, and has 12lines,
each running at 14,400 bps.
Attend any of more than two dozen monthly
meetings, including the General Meeting, which
showcases major vendors and their newest
software and hardware products.

Scroll bars

Viewing Parts of the Window

Table 2.2

Common Window Features

Feature

Description

Use

Menu bar

Line at top of the
screen, beginning with
the Apple symbol.

Click to pull
down menu.

Title bar

At top of document
window. Dark if active.
light if another
window is active.

Shows name of the
document.

Scroll bar

Gray area between scroll
arrows on right and bottom
of document window.

Click above or below
scroll box on vertical
scroll bar or to the
left or right of scroll
box on horizontal
scroll bar to move view
of document a full
screen up, down, left,
or right.

Thumb

Gray square box inside
scroll bars.

Drag thumb to position
view of document.

Scroll arrows

Arrows on either side
of scroll bar.

Click arrow to move view
one line in the direction of
the arrow. Hold down mouse
cursor on arrow to scroll
quickly.

Document window

Area inside the window.

Location where document
resides and where editing
takes place.

Table 2.3 lists items that generally occur just on application windows,
but are common to most applications. Microsoft Word, Excel,
PowerPoint, and Mail call the pictorial strip of buttons below the menu
bar, but above the document window, toolbars.

Table 2.3

Features Common to Office Application Windows

Feature

Description

Use

Toolbar(s)

Picture buttons
below menu bar or
other places
on-screen.

Click button for the
most used commands.
Sometimes the button
only gives you one
feature for a command.
See the menu for more
options on a feature.
(continues)
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Table 2.3

Continued

Feature

Description

Use

Status bar

Bottom line of
application window.

Can tell information about
insertion point location
on document and status of
some toggle keys on the
keyboard such as the
numlock key. In some
programs, describes menu
or tool bar choices in more
detail. In some programs,
can double-click status
bar to accomplish tasks.

Document window

Area between toolbars
and status bar.

Shows open document,
scroll bars, and possible
title of document in title
bar.

Microsoft Applications Toolbars
One of the improvements Microsoft made with the upgrades from Word 5.1
to Word 6, Excel4 to Excel 5, and PowerPoint 3 to PowerPoint 4 was the
reorganization and improvement of the toolbars so the tools are more consistent across the Microsoft Office applications. Although many buttons are
unique to each application, many buttons are also common to all or some of
the applications. Microsoft also changed the name of the ribbon in Word 5.1
to the Formatting toolbar. You can now choose from more than one toolbar
in all the applications. You also can customize the toolbars (add or remove
buttons) .
..,.. See "Customizing Application
Toolbars,"
p. 735

To turn a toolbar on or off, follow these steps:
1. Hold down the control key and click an active toolbar.
2. A pop-up menu shows a list of possible toolbars. Microsoft displays the

active toolbars with a check mark to the left of the name.
3. Select the toolbar you want to turn on or off. If the toolbar is floating,

you can click the toolbar's Close box.
Note
If the program doesn't show any toolbar, choose View Toolbars, and choose the
toolbar(s) you want to display.

Viewing Parts of the Window
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Some buttons change on toolbars when you change the view. For example,
Word adds an outline toolbar when you change to outline view.

I

Standard Toolbars
Figure 2.3 shows the standard toolbar for each Microsoft Office application.
Notice how many of the buttons are the same. Table 2.4 lists the common
buttons for Word, Excel, and PowerPoint toolbars and their purpose.
Microsoft Word Standard Toolbar

Fig. 2.3
The standard
toolbars for
Word, Excel, and
PowerPoint show
many similarities.

Open

Print Spelling

Format
Painter

Copy

Insert Excel
Insert Zoom
Auto
Chart Control
Redo Text
Drawing

Microsoft Excel Standard Toolbar
Sort
Save

Cut

Painter
Copy

Box

Repeat

Drawing
Descending

Microsoft PowerPolnt Standard Toolbar
Format
Painter

Open

Cut

Insert Excel Pick a Look
Worksheet
Wizard

Undo
Insert MSWord
Table

Clip
Art
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Table 2.4

Common Buttons on the Standard Toolbars

Button

w

E

p

Use

New

X

X

X

Create a new, blank document.

Open

X

X

X

Open an existing document.

Save

X

X

X

Save the active document
on screen.

Print

X

X

X

Print the document.

Print Preview

X

X

Cut

X

X

X

Remove the selection from
the document and place a
copy on the Clipboard.

Copy

X

X

X

Copy the selection from the
document and place a copy
on the Clipboard.

Paste

X

X

X

Copy the contents of the
Clipboard into the
document at the location
of the insertion point.

Format Painter

X

X

X

Copy the formatting from
the selected items to the
next selection.

Undo

X

X

X

Reverse your last action.

Insert Chart

X

X

Insert a chart into the
document.

Zoom Control

X

X

X

Change the size of your
display (does not affect
printing).

Help

X

X

X

Click Toolbar button, or
menu choice for help on
that choice. Double-click to
search for help on a topic
you type.

Preview a document as it
will look when printed.

W, E, P columns are for the Word, Excel, and PowerPoint standard toolbars.

Viewing Parts of the Window
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Formatting Toolbars

I

Many of the buttons are also similar on the formatting toolbars. Figure 2.4
shows the Formatting toolbars for Word, Excel, and PowerPoint. Table 2.5
shows the common buttons and their uses in Word, Excel, and PowerPoint.
Microsoft Word Formatting Toolbar
Align
Numbering
Left Align
Right

Underline

Decrease
Indent

Microsoft Excel Formatting Toolbar
Center Across Colum

Decrease
Decimal
Percent Style

Microsoft PowerPolnt Formatting Toolbar
Increase

Font Size

Bold

Text Shadow

Bullet

Text Color

Decrease Underline
Point Size

Center

Promote

Fig. 2.4
The formatting
toolbars for Word,
Excel, and
PowerPoint are
very similar.
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Table 2 .5

Common Buttons on the Formatting Toolbars

Button

w

E

p

Use

Font

X

X

X

Click pull-down arrow to
the right of font name to
display a list of typefaces.
Click the desired font.

Font Size

X

X

X

Click pull-down arrow to display
and choose desired size for text.

Bold

X

X

X

Bold the selected text.

Italic

X

X

X

Italicize the selected text.

Underline

X

X

X

Underline the selected text.

Align Left

X

X

X

Align the items so the left side of
each is lined up.

Center

X

X

X

Align the items so each is
centered.

Align Right

X

X

Bullet

X

Align the items so the right side
of each is lined up.
Place a bullet before each line of
selected text.

X

W, E, P columns are for the Word, Excel, and PowerPoint formatting too/bars.

Drawing Toolbars
The Drawing toolbars for Word, Excel, and PowerPoint also have common
buttons, as shown in figure 2.5. Table 2.6 shows the common buttons and
their purpose.
Fig. 2.5

Microsoft Word Drawing Toolbar

The drawing
toolbars for Word,
Excel, and
PowerPoint are
also similar.

Bring to Front

Bring in front of text
Group Objects

Ellipse
Freeform

Save
Line Color

Send to
Back

Select Drawing
Objects

Ungroup
Objects

Align Drawing Objects

Reshape

Rotate

Insert Frame

Right Snap to

Send behind
text
Flip
Vertical

Grid

Viewing Parts of the Window

Microsoft Excel Drawing Toolbar
Filled Ellipse
Text box

Select Drawing Objects
Filled

Send to Back

Line

Freeform
Create Button
Filled Rectangle
Bring to Front

Microsoft PowerPolnt Drawing Toolbar
Free Rotate

Select Drawing
Objects

Line

Arc
Auto Shapes
Freeform

Drop Shadow

Table 2.6 Common Buttons on the Drawing Toolbars
Button

w

E

p

Use

line

X

X

X

Click and drag to start and draw
the line. Release the mouse
button to end the line. Use the
shift key to draw lines at 30, 45,
and 60 degree angles.

Rectangle

X

X

X

Click and drag from one corner
to the opposite corner. Release
the mouse button to complete
the rectangle. Use the shift key
to draw a square.

Ellipse

X

X

X

Click and drag from one corner
to the opposite corner. Release
the mouse button to complete
the ellipse. Use the shift key to
draw a circle.

Arc

X

X

X

Click and drag to start and draw
the arc. Release the mouse
button to end the arc.
(continues)
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Table 2.6

Continued

Button

w

E

p

Use

Freeform

X

X

X

Drag the mouse to draw.
Double-click to end the drawing.

Selection Tool

X

X

X

To select multiple objects, drag
the mouse from upper left
corner to bottom right corner
and release mouse. Black
binding boxes tell you the object
is selected.

Bring to Front

X

X

With two objects stacked on
each other, bring the selected
object to the top (or front).

Send to Back

X

X

With two objects stacked on
each other, send the selected
object to the bottom (or back).

Group Objects

X

X

Combine more than one drawn
object into a single object for
editing and moving.

Ungroup Objects

X

X

Separate grouped objects into
their original drawings.

Reshape

X

X

Drag black binding boxes to
reshape freeform object.

Drop Shadow

X

X

Apply a shadow to the bottom
and right of the object.

W, E, P columns are for the Word, Excel, and PowerPoint drawing too/bars.

Using Menus
Along with the advent of common toolbars, Microsoft has also reworked the
menus on the applications within Microsoft Office to create similar placement for commands.

General Description of Menus
At the top of the screen is the menu bar. In all Microsoft Office applications,
the menu bar begins with the File, Edit, and View menus and ends with the
Window and Help menus. When the mouse pointer is on a menu, the
pointer changes to a black arrow. To pull down a menu, click and hold the
mouse button on the menu. When you open a menu, a list of commands

Using Menus

appears. Drag down the menu to the command you want, and when that
command is selected, release the mouse button. As you select menu choices,
the status bar on the bottom of the screen shows a description of the menu or
command.
If you accidentally go into the wrong menu, you can do any of the following:

• Release the mouse button over the name of the menu. Nothing will
happen, because you didn't have a menu command selected when you
released the mouse button.
• Move the cursor into the document window and release the mouse
button. Again, nothing will happen.
Menus throughout Mac applications have common symbols that indicate
what will happen when you select the command and that give you shortcuts
to do the commands. The symbols include ellipses, keyboard shortcuts,
arrows, check marks, and option bullets. Horizontal lines divide each menu
into sections. The sections generally group similar commands together (such
as Save, Save As, and Save All) or group commands that are mutually exclusive (see the following option bullets). This list describes common menu
symbols:
• Three dots, or an ellipsis, after a command indicates that a dialog box
appears after you select the command. For example, the command Print
in the File menu occurs in all four applications and an ellipsis indicates
that the Print dialog box follows the selection of this command. For
more information on dialog boxes, see "Using Dialog Boxes" later in
this chapter.
• To the right of some commands are keyboard shortcuts. Instead of using the menu, you can press the shortcut key or key combination to
choose the command. Most shortcuts begin with holding the command
key ()::() down in combination with a letter. For example, to undo your
latest action, press )::C+Z in all applications. Shortcut keys also include
function keys (for example, F7 for Spelling), and editing keys (for example, delete to erase the selection).
• Some Microsoft Office applications have arrows on the right side of
some menus indicating that another pop-up menu will appear. This is
sometimes called a hierarchical menu. After you choose the command
with an arrow, you choose another command on the resulting menu.
Figure 2.6 shows that in Excel if you choose Format Column, you get
another menu that begins with Width.
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Arrow here...

Fig. 2.6
An arrow on the
right side of a
command
indicates another
menu follows.

. .. leads to second menu here

Sheet
Rutofonnat ...
Style ...
Placement

~

• Another character on some menus is a check mark to the left of the
menu choice. A check mark indicates that the choice is selected and
that the choice can be on or off. For example, the Window menu of all
Microsoft Office applications shows a list of open documents on the
bottom of each menu. The active open document is indicated by a
check mark.
• Another on or off indicator in Word and PowerPoint is an option bullet
to the left of a menu item. The bullet indicates that only one item in a
menu section (the area between two horizontal lines) can be selected at
a time. If you choose any other command in the same section, the bullet moves to the selected item. For example, the View menu of Word in
figure 2.7 indicates you can only choose Normal, Outline, Page Layout,
or Master Document at one time and Normal is currently selected.
Fig. 2.7
Normal is the
exclusive choice in
this menu section.

Only one of
these four
options can
be selected
at any time
Tool bars...
"'Ruler
Header and Footer

root notes
Annot11t1ons
Zoom ...

Using Menus

Menu Similarities In Microsoft Office Suite
Along with the common symbols on menus, Microsoft has also repositioned
menu commands to appear on the same menus within each application as
much as possible. Table 2. 7 lists the menus and their general functions.

Table 2.7

Common Menus in Microsoft Office Applications

Menu

w

E

p

M

Similar Command Functions

File

X

X

X

X

Open, create new, save, close, print
files, and exit program.

Edit

X

X

X

X

Copy, move, paste from other
applications, delete selections; undo
last command, search and replace
text.

View

X

X

X

X

Change the way the document and
screen items such as toolbars display
on-screen.

Insert

X

X

X

Insert objects into the document.

Format

X

X

X

Change font, line spacing, or row
height, add Jines, have program pick
out a "look" for your document with
pre-determined formatting.

Tools

X

X

X

Check spelling, create macros,
customize the way the keyboard,
menus, and toolbars look.

Window

X

X

X

X

Arrange document windows on the
screen; switch between documents.

Help

X

X

X

X

Show step-by-step procedures,
definitions, and examples. Do onscreen tutorials, list Microsoft
technical support phone numbers
and procedures.

W, E, P columns are for the Word, Excel, and PowerPoint menu bars. M is for Mail menu bar.

Shortcut Menus
Microsoft has also added shortcut menus to Word, Excel, and PowerPoint. To
access a shortcut menu, select the item you want to change, hold down the
control key, and click the mouse button in the selected area. The menu that
appears gives you options for only the selection. You don't have to wade
through the menu bar to figure out what menu items go with what you are
doing.
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Shortcut menus are available for more than just toolbars. There are also shortcut menus for selected text, drawing and graphics objects, rows, columns,
and others depending on your application.

Using Dialog Boxes
When you choose a command with an ellipsis, a dialog box appears. The
dialog box can be very simple with only one button (such as OK), or the dialog box can have many choices. Just as the menus have common symbols, so
do dialog boxes. Figures 2.8 and 2.9 show examples of two dialog boxes.
Fig. 2.8
Word's Index and
Tables dialog box.
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Fig. 2.9
Excel's Format
Cells dialog box.
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Dialog boxes let you see all the current settings for a command as well as
change them. On the newer applications, Microsoft added tabs (the Font tab
appears in the Format Cells dialog box as shown in fig. 2.9). Click a tab to go
to that area of the dialog box. Sometimes you may need to see your underlying document to make a choice on the dialog box. Drag the title bar of the
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dialog box to move the dialog box out of the way. Within a dialog box you
click an object to select or change the value. For example, on the Font Style
list box, click Italic to select italic. Within a dialog box you generally click an
object, type a value, or select from a list. For more detail, refer to figure 2.9.
Besides using the mouse to make selections within a dialog box, you can also
use the keyboard. Press tab to move to each section of a dialog box or press
shift+tab to move backward through the dialog box. When you get to a list,
click the up or down arrow, or use the up or down arrow keys on the keyboard, to make a selection. In most dialog boxes, you can hold down the
command key, which will cause the labels for items in the dialog box to gain
an underlined character. Pressing ):(+[the underlined character] selects that
item.
To get out of a dialog box without selecting any of the settings, choose the
Cancel command button or press esc. To use the settings, click the OK command button or press the enter or return keys. In some cases, you must
choose the Close command button to finish your selections. Notice that
some command buttons have ellipses (refer to Mark Entry and AutoMark in
fig. 2.8). This indicates that another dialog box will appear when you choose
this button.

Typing and Editing
Typing and editing within different Macintosh applications is similar. When
you're working within an application, there are three different kinds of
modes: text, cell, and object. Each of the Microsoft Office applications can
include any of these modes. Editing items are different depending on the
mode.

Text, 1-Beam Mouse Pointer, and Insertion Point
The normal Word screen is an example of text mode. When you come to the
margin, text will automatically wrap to the next line. As you type, a blinking
vertical line called the cursor or insertion point moves. When you move the
mouse across an area in text mode, the mouse pointer becomes an I-beam as
shown in figure 2.10. Click the I-beam mouse pointer to position the insertion point. As you type, the insertion point pushes existing text after the
insertion point. If you want to replace text, drag the 1-beam mouse pointer to
select the text to replace. When you begin typing, the new text replaces any
selected text.

...

...

See "Editing
Worksheet
Data," p. 249
See "EditingText,"
p.94
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Fig. 2.10
Typing in a Word
document is much
the same as typing
in a Text box in
any application.

1-beam

Selected text

Moving the mouse pointer across a document within word shows the !-beam
mouse pointer. Click the !-beam mouse pointer to position the insertion
point and type or drag the !-beam mouse pointer across text to select it and
type to replace the selected text.
This method of editing works the same in a text box within a dialog box,
such as the Save Current Document As text box in the Save As dialog box
shown in figure 2.11. In a dialog box, the 1-beam replaces the arrow when the
mouse pointer enters a text box. Drag the mouse pointer across text to select
the text and type the new entry. In this example, text was selected and the
words LAMG Welcome were entered.
Fig. 2.11
Typing within a
text box of a
dialog box is
similar to typing
in a document
window.
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Within Excel, the mouse pointer normally appears as a thick white plus sign
as you move the mouse pointer across the screen. When your cursor enters
the formula bar at the top of the screen, however, the mouse pointer changes
to an 1-beam and you can drag across to select text or click to position the
insertion point. You can also edit in a cell if you move the plus sign to the
cell and double-click. The mouse pointer changes to an !-beam while you are
in the cell and the blinking insertion point appears. This is called edit mode
in Excel.

Typing and Editing

Within PowerPoint, when you move the mouse pointer across most text
items, the mouse pointer is an !-beam. While you are in outline view, you
can click and drag on any text as if you are in a Word document. However,
editing a slide is slightly different. You can't drag to select text within a text
object (title, bullet item, or added text) until you click the object to select it.
When you click, you position the insertion point within the text and select
the text object at the same time. When the text object is selected, a hatched
outline appears around the object (see fig. 2.12). After this outline and Insertion point appear, you can drag to select text and edit as mentioned previously. If you include text boxes in other applications, you also need to first
select the text object (the text box) and then edit the text as you do for
PowerPoint.
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.,.. See "Selecting
Cells and
Ranges," p. 237
.,.. See "Entering
and Editing
Text," p. 452

Fig. 2.12
Editing text within
a selected text
object in
PowerPoint.

Cells, Text Boxes, and Fields
Excel worksheets and Word tables are organized in rows and columns (see
figs. 2.13 and 2.14). Th e intersection of a row and column is called a cell.
When you press tab, you move to the next cell. If you press shift+tab, you
move to the previous cell. When you move to a cell with tab or shift+tab
in Word, the text within the cell is highlighted. When you type, new text
replaces the existing text within a cell. In Excel, when you press tab or
shift+tab, the text is not highlighted in a cell. Type the new entry for the
cell and press return or tab to replace the entry.
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Fig. 2.13
A Word table.

Fig. 2 .14
An Excel
worksheet.
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See "Moving
Around in a
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p.230
See "Working
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Forms and dialog boxes work similar to tables. On a dialog box, if you press
tab or shift+tab until you come to a text box, the current item in the text box
is highlighted. As soon as you type the first character, the old entry is erased.
Word data-entry forms, Excel data fo rms, and the upper part of a Mail message contain fields for entering or editing information. When you press tab or
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shift+tab to move to a field, the entry within a field is highlighted. When you
type, the old entry is replaced with the new entry. If you want to edit an
entry instead, click the !-beam mouse pointer to position the insertion point.

Objects
In some cases, you'll have objects attached to your document. Objects can
include charts, pictures, clip art, WordArt, and other documents. If you click
an object, an outline appears around the object with small square binding
boxes at each corner and halfway between each corner on each line surrounding the object. You can perform any of the following actions:
• To delete the object, press delete.

...
...

...

• To move the object, move into the object (or on the border surrounding the object) until the mouse pointer changes to a white
arrow, and drag the mouse to the new position on the document.
• To change the size, stretch, or flatten the object, move the mouse
pointer on top of one of the binding boxes until the pointer changes
to a small, black, double arrow (see fig. 2.15). Drag the double arrow
to make the object smaller or larger.

...

See "Working
with Charts,"
p.201
See "Working
with Graphics,"
p.ZOS
See "Selecting
and Grouping
Objects," p. 471
See "Linking an
Excel Worksheet to a Word
Document,"
p. 611

Fig. 2.15
This organization
chart was created
with Insert,
Object, Organizational Chart 1.0.
Notice the binding
boxes and the note
on the status bar.

SuzyPr1eto
ExecU1ive Director

TomNeg~no

Vice President
Peggl Sturm
Treasurer

Status bar

You can size
dragging a
sizing handle
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• To edit the object, you can usually double-click the object. You may
enter the program that created the object, or the menu and toolbar
of your current program change to the menu and toolbar of the
source object. Figure 2.16 shows an example of an Excel worksheet
within a Word document. If you go into the source program,
finish editing by choosing File Exit and Return to Document. If you
remain in the target document and the menu and toolbar change,
click outside the object and in the target document to finish editing.
Fig. 2.16
In Word, when
you insert an Excel
worksheet, the
menu and toolbar
change to Excel's
menu and toolbar,
and you can edit
directly in the
Word document.

Note
MS Organizational Chart 1.0 is provided as an applet (small program) with
PowerPoint. Even if you don't use PowerPoint, you can use Organizational Chart to
create organization charts within your Word and Excel documents.

Most products work by clicking the object once to bring up the binding box.
In PowerPoint, if you click a text object once, you get a cross-hatched outline
around the text that enables you to select text within the box. Move to the
cross-hatched outline and click a second time to bring up the binding box.

Selecting Text
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Selecting Text
As mentioned in the preceding section, to select an object, click it. However,
you have much more flexibility when you want to select text. To edit, change
the appearance, copy, or move text, you first need to select the text, and then
do the procedure to make the change. There are some similarities between
the applications. For example, you can always drag across the area with the
1-beam mouse pointer. You can also hold down the shift key and use your
movement keys to expand the selection or click the mouse at the end of the
selection. There are also some differences between the applications, as shown
in table 2.8. For example, to select a row in Word and Excel, position the
mouse pointer before the row and click. However, in Word the mouse pointer
changes to a right-pointing arrow; in Excel the pointer is a white cross.
I

....

See "Selecting
Text," p. 92

....

See "Selecting
Cells and
Ranges," p. 237

....

See "Selecting
Cells, Rows,
and Columns,"
p.528

....

See "Moving
around in a
Worksheet,"
p.230

....

See "Moving
throu gh a
Presentation,"
p.439

Table 2.8 Selecting with the Mouse
Application

To Select

Use Mouse
Pointer

And ...

All

Text

1-beam

Drag

All

Word

1-beilm

Double-click word

Word

Line(s)

White arrow

Click or drag before text (in
left margin)

Excel

Row(s)

White cross

Click or drag number(s) in
worksheet frame

Word

Table column(s) Black down
arrow

Click or d rag above first
row of table

Excel

Column(s)

White cross

Click or d rag column
letter(s) in worksheet frame

Word

Entire

White arrow
document

Hold down control and
click left margin

Excel

Entire

White cross
worksheet

Click Select All button
above row numbers and to
left of column letters

42

Chapter 2-Using Common Features to Create Documents

Moving around the Document
To move throughout the document, you can use both the mouse and the
keyboard. Moving around a document is similar in each application. To position the insertion point or cell pointer, click a visible area on-screen.

Scroll Bars
Scroll bars enable you to scroll the view of the document. Be careful when
using the scroll bar, however; the cursor remains in the location before the
scroll took place and may not be visible on-screen. You may start typing in
the wrong place. To avoid typing in the wrong place, make sure the cursor is
visible by clicking where you want to begin typing.
The scroll bars are divided into three parts: the scroll arrows, scroll box, and
scroll bar. Use each part as follows:

• Down or Up Scroll Arrow. Click to move one line at a time. This is true
except in PowerPoint. Although this works in outline view, clicking the
scroll arrows in Slide view moves you one slide at a time.

• Scroll Box. Drag the scroll box in the scroll bar. When you drag the box
all the way to the bottom, you are at the bottom of the document, no
matter how many pages there are.

• Scroll Bar. Click between the scroll box and a scroll arrow to move one
screen at a time.

• Horizontal Scroll Bar. Drag to move left and right on wide documents.
• Double Arrows. In Word page layout view and PowerPoint Slide view,

you have two double arrows at the bottom of the vertical scroll bar.
Click the double arrows to move down or up a page at a time.

Movement Keys
The movement keys on the keyboard are similar, depending on which mode
you are working in. Movement keys do the following:
• Left- and right-arrow keys move one character to the left or right in text
mode or one column to the left or right in cell mode.
• Up- and down-arrow keys move one line or row up or down.
• Page-up and page-down keys move one screen up or down.

Copying and Moving
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• ):(+home moves to the top of the document.
• ):(+end moves to the bottom of the document. In Excel, this moves to
the last cell containing data.
• Home moves to the beginning of the line in Word. In Excel, home takes
you to the first column in cell mode or the beginning of entry in edit
(text) mode.
• End moves to the end of the line in Word or end of entry in Excel edit
mode. End works differently in Excel. You press end followed by an
arrow to move to the end of a continuous range of cells.
•

):(+~and

):C+r in text mode move you one word at a time.

• ):(+up and ):(+down in text mode move you one paragraph at a time.
• FS is the Go To key. Press FS in Word and then type the page number to
go to. Press FS in Excel and type the cell reference.

Copying and Moving
The procedure for copying and moving is generally the same for all Microsoft
Office applications. The procedure works for copying information from one
area of a document to a different place on the document, as well as copying
information from one document to a different document. This same procedure even works for copying information from a document in one application (such as Excel) to a document in another application (such as Word).
The item that you are copying can be text, numbers, a chart, a picture, or any
other object.

Using the Clipboard
The procedure for copying and moving is the same because of the Clipboard.
This feature holds a copy of the item when you cut or copy. When you use
cut, the item is removed from the source application and goes into the Clipboard. When you use copy, the item remains in the source application and
also goes into the Clipboard. When you use paste, a copy of the item you cut
or copied goes from the Clipboard into the active application. Because all
Macintosh applications share the Clipboard, you can easily copy information
between applications.

....

See "Editing
Text," p. 94

....

See "Copying
Worksheet
Data," p. 252

....

See "Moving
Worksheet
Data," p. 257

....

See "Moving
and Copying
Objects," p. 476

....

See "Copying
Text between
Word Documents," p. 589
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Using Cut, Copy, and Paste
The procedure for copying or moving is as follows:
1. Select the item you want to copy or move. If the item is text, this
usually involves dragging the I-beam mouse pointer or some other
shortcut. If the item is a picture, chart, or object created in another
application, this usually involves clicking the object to show the
binding box.

2. Do one of the following:
• To move the selected item, choose Edit Cut, or press ):C+X.
• To copy the selected item, choose Edit Copy, or press ):C+C.

IIJ

3. Use the scroll bars and movement keys to position the cursor in the
document.
4. Choose Edit Paste, or press ):C+V.

All Macintosh applications have the Edit menu from which you can choose
Cut, Copy, or Paste. In some minor cases, you may not even be able to use
the menu (for instance, when editing within a field such as To or cc in Mail).
In these cases, you can use the keyboard shortcuts.

Troubleshooting
I clicked the Paste button, but it didn't paste what I wanted.
If you didn't use Cut or Copy at the right time and then click the Paste button, you
get a copy of whatever is in the Clipboard. Click the Undo button immediately or
choose the Undo command in the Edit menu to remove any unwanted copy.

Moving with Drag-and-Drop
Microsoft Word, Excel, and PowerPoint have another capability that makes
moving even easier. This feature is called drag-and-drop. You first select the
text or cells to move and then drag the selection to the new location. In some
cases, this new location can be on a different document or even in a different
application.

Copying and Moving

The drag-and-drop mouse pointer changes an insertion point and then
changes to a left-facing arrow when you position the mouse pointer in the
selected text (the normal mouse pointer points to the right). In Word and
PowerPoint, you position the mouse pointer anywhere within the selected
area. In Excel, you point to the outline surrounding the selected cells. When
you drag the mouse in Word and PowerPoint, two additional shapes are
added to the left-arrow mouse pointer. A small rectangle appears under the
mouse pointer and a dashed vertical line (ghost cursor) appears where the
new text will be inserted when you release the mouse button. In Excel, a gray
outline appears where the new text will appear when you release the mouse
button.
The drag-and-drop feature is limited in PowerPoint. You can move text only
from one area of the current text object to another area of the same text object on the slide. In Excel, you can drag and drop items from one area of a
spreadsheet to another area of the same spreadsheet. You can even drag the
selection into a document in an open Word or PowerPoint window. However, you can't drag the selection between two open documents in the same
Excel program window. With Word, you can drag the selection to another
place on the same document, to another open document window within the
Word program window, and to an Excel worksheet or PowerPoint slide. Table
2.9 summarizes these relationships in terms of whether drag and drop works
between two different applications or two different document windows
within the same application.

Table 2.9

limitations of Drag-and-Drop

From

To
Word

Excel

PowerPolnt

Mall

Word6

Yes

Yes

Yes

No

ExcelS

Yes

No

Yes

No

PowerPoint 4

No

No

No

No

Mail3.1

No

No

No

No

If you want to copy rather than move the selected item, hold down option

and then begin to drag. The mouse pointer becomes a small plus. Release the
mouse button to perform the copy.
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Troubleshooting
I tried to copy, but the drag-and-drop didn't leave the original.
The operation of the option key is essential. Hold down option before you start the
drag, and release option after you release the mouse button. If you need to restore
the source application, return to the source application and click the Undo button or
choose Edit Undo.

Formatting Documents
Formatting text involves changing the font (typeface), font size, font characteristics (such as bold, italic, and underline), and alignment of text. The general procedure to format text is the same in the different applications. First
you select the text to format, and then you do the formatting. If nothing is
selected, formatting applies only to new text entered at the insertion point.
As with other procedures, you can use buttons on toolbars, menu items,
shortcut menus, and keyboard shortcuts.

Using Toolbars and Keyboard Shortcuts to Format
....

See 11 Formatting Text,"
p. 108

....

See 11 Changing
Fonts, Sizes,
and Styles,"
p.285

....

See "Enhancing
Text," p. 505

Formatting is usually quicker when you use buttons on the toolbar or keyboard shortcuts instead of the menu.
The procedure for formatting is as follows:
1. Select text to format.
2. Choose one of the buttons or press the keyboard combination listed in

table 2.10.

Table 2.10

Formatting Buttons and Keyboard Shortcuts

Command

Button

Note

Keyboard

Note

Bold

IJ

W,E,P

):(+8

W,E, P

Italic

ml

W,E,P

):(+1

W, E, P

Underline

[II

W, E, P

):(+U

W, E, P

W, E, P

):(+l

w, p

Align left

•

Formatting Documents

Command

Button

Note

Keyboard

Note

Center

[IJ

W,E, P

):(+E

W,P

W, E

):(+R

W,P

w

:l=C+J

w, p

Align Right
justify
Font
Font Size

••

lcour;er

W,E,P

[!0

W,E, P

In the Note column, W, E, and P represent Word, Excel, and PowerPoint.

To use the Format Painter button, select the text with the formatting you
want to copy. The mouse pointer changes to include a paintbrush icon. Select
the text to receive the format. When you release the mouse, the target range
receives the formatting of the source range.

Using Undo
If you want to undo the formatting or the last procedure, you can immedi-

ately choose the Edit Undo menu or press ):C+Z.
Word has a multiple level undo that lets you undo more than the last procedure. To use Word's undo feature, click the Undo button to undo the last
procedure. Click the pull-down arrow portion of the button to show a list of
procedures and select the procedure you want to undo.
Word also has a Redo button that lets you repeat the last action you did. For
example, you can apply the same formatting you did on the last selection.
The Redo button also reverses an undo. If you want to undo your undo, use
Redo. The Redo button also has a pull-down arrow that shows a list of procedures you can redo.

Using Menus to Format
The formatting toolbars give you the most-used choices for formatting. If you
want more complete choices, use the menu bar. Word, Excel, and PowerPoint
have Format menus. Word and PowerPoint display different formatting categories on the Format menu itself. Excel displays the formatting categories on
tabs on the Format Cells dialog box, as shown in figure 2.17. Table 2.11 summarizes some of the formatting possible on the Format menu of Word, and
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PowerPoint and the Format Cells dialog box of Excel. As with the toolbar and
shortcut keys, you first need to select the text to format. When you finish
with a dialog box, click OK.

Fig. 2 .17

Format Cells

This Excel dialog
box enables you to
change many
ch aracteristics of
t he font.
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Formatting Commands

Command

Word

PowerPolnt

Excel

Font,
Font size,
Font color,
Underline

Format then
menu item
Font

Format then
menu item
Font

Format Cells
then tab
Font

Bo rder
(lines)

Borders
and Shading

Colo rs and Lines

Border

Shading
(patterns)

Borders and
Shading

Colors and Lines

Patterns

Alignment

Paragraph

Alignment

Alignment

Line spacing

Paragraph

Line Spacing

Use Format, Rows,
Height

Troubleshooting
I accidentally chose the wrong format.

Immediately choose Undo. If you've waited too long, you can sometimes click the
same button to undo the format or another button to change th e format. For exam ple, click the Bold button to bold or unbold. You can also click Align Left to
change from any other alignment.

Formatting Documents
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Changing Column Width
Changing the column width of tables in Word, or spreadsheets in Excel, is
essentially the same. You move above the document to the column marker
until the mouse pointer changes to a double black arrow, and drag the mouse
to the desired width. In Word, the area you change is called the mler and the
insertion point must be inside the table. In Excel, the area you change is
called the worksheet frame and the mouse pointer is between the column
letters.

Letting the Application Do the Formatting for You
Although formatting is fun, you can spend a Jot of time and still not get a
professional look for your effort. The Microsoft Office suite of applications
is starting to give you choices of a series of formats that will automatically
format the document for you. These will automatically add fonts, shading,
colors, and borders. If you want to maintain a consistent image with your
documents, using the predefined formats is worthwhile.
To apply automatic formatting to your document, do the following:
• For a Word document, choose Format AutoFormat. In the AutoFormat
dialog box, click OK. After Word formats the document, you can accept
or reject the changes or choose the Style Gallery command button and
choose from displayed examples (see fig. 2.18).
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• For Excel, position the cell pointer within the area to format and
choose Format AutoFormat. Choose from a list of examples in the Table
Format list box (see fig. 2.1 9).

.... See "Using
Template Wizards," p. 190

....

See "Creating
and Applying a
Style," p. 290

.... See "Creating a
Presentation
Using a Wizard," p. 432

.... See "Creating a
Presentation
Using a Ternplate," p. 436

Fig. 2.18
Choose the Style
Gallery to change
the automatic
formatting that
Word created for
you.
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Fig. 2.19

Rutorormot

Choose from a list
of table formats
provided by Excel
on the AutoFormat
dialog box.

OK

I

CIKtl

• For PowerPoint, choose the Format Presentation Template command
and select from the File Name list of file templates in one of the template folders (see fig. 2.20).
Fig. 2.20

'

On PowerPoint's
Presentation
Template, choose
the file template
that has the
formatting features
you want to apply
to your presentation.
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You can also use professionally designed formats through Wizards. See the
next section, "Using Help."

Using Help
Microsoft has significantly added tools to help you become more productive
quicker. In addition to the standard on-screen help, table 2.12 shows which
features are available in each of the products.

Table 2.12

...

See "Learning
More with OnLine Help,"
p. 745

Help Features in Microsoft Office Applications

Feature

Description

Applications

On-line Help

Enables you to look up help on a
topic by searching through an
index or searching for a specific
help topic.

W, E, P

Help Pointer

Enables you to point to an item
on the screen for a description
of the item.

W, E, P

Using Help

Feature

Description

Tips of the Day

Provides a helpful hint when
you first start the program.

Quick Preview

Shows you an overview of the
basics of the program, what's new,
and possible tips for users of
competing software products.

W, E, P

Examples and Demos

Illustrates features of the product
as you watch a computer-based
demonstration.

W, E

Cue Cards

Shows you the steps to perform
via an open window that you use
along with your document.

p

How To Window

Shows you the steps to performing
an open window that you use along
with your document.

W, E

Wizards

Takes you step-by-step through a
process of dialog boxes. You are
prompted for choices throughout
the process that are required to
build your document.

W, E, P

Applications

w, p

W =Word, E =Excel, P = PowerPoint.

On-Line Help
You can find help on a topic in a number of ways. Table 2.13 describes some
of the ways to enter a help topic.

Table 2.13

Finding Help on a Topic

To find help on options
in a dialog box

Press Fl while you are in the dialog box or
click the Help command button if available.

To find help on a button
on a toolbar

Click the Help button on the Standard
toolbar and then click the button.

To find help on a menu item

Open the menu, move to item on menu and
press Fl, or click Help button and then menu
item.

To search for help on a topic

Choose Help, Search for Help, or from within
a Help window, click the Search button. See
steps that follow to use the Search window.

To display a list of help

Choose Help Contents to see a topics list of
topics organized by procedures or Index to see
an alphabetical list.
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If you are searching for a topic, a Search window appears similar to the one

shown in figure 2.21. Begin typing the topic name in the first text box. As
you type, the list of topics scrolls down to the characters you type. When you
see your topic, click the topic and choose the Show Topics button. The second list box shows the related topics. Select one of the topics and choose the
Go To button.
Fig. 2.21
The Word Help
Search window.
Clicking the Go To
button will display
the detailed help
on the selected
topic.

Type a word, or select from the
lis t. Then choose Show Topics.

(Show Topics)

ltoolbar~

I (Cancel)

i.taalbers.
Toolbars command (Uiew menu)
Toomps
Trace R&D Center
Trace RosourceBook
tracking reulslons
trademark sqmbol
Select n topic, then choose Go To.

i
CE:

Microsoft Wlltd HCC8111b lily
Customizing nnd Optimizing Word
Switching between Microsoft appli cations
Toolbars and to olbar buttons tips
Parts of the Word Screen nnd Tool bars

•

After you choose Help in one of the methods mentioned above, you enter a
Help window with its own menu, buttons, and scroll bar (see fig. 2.22). To see
more of the Help window, use the scroll bar or maximize the Help window.
Table 2.14 describes the features in the Help window.
Fig. 2.22
This Help window
shows a jump
topic and the Help
navigation
buttons.
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Table 2.14 Items on Help Windows
Help Item

Description

Applications
(All Unless Indicated)

Menus
File

Opens a different help file,
prints the help topic,
exits help.

Edit

Copies information from a
help topic or adds your own
notes.

Bookmark

Creates p lacemarkers for
the most used pages of help.

Help

Tells you how to operate
help. Enables you to place
help on top of you r window
so it doesn't disappear when
you return to the application.
Tells you the version of help
and how much memory is free.

Buttons
Contents

Goes to the help table of
contents of topics
organized by procedure.

Search

Enables you to search for
a help topic by typing
the name of the topic.

Back

Moves back to the previous
page you viewed in help.

History

Shows a list of all the
help topics you've viewed
in this help session.
Double-click a topic name
to return to that topic.

Index

Shows the alphabetical
listing of help topics.

W, E, P

>>

Shows the next topic in
the series.

p

<<

Shows the previous topic
in the series.

p

(continues)
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,

Table 2.14 Continued
Help Item

Description

Applications
(All Unless Indicated)

Screen Elements

W

Solid green
underline

jump topic-choose to move
to a different page in help.

Dotted green
underline

Glossary topic-choose to
see pop-up definition of
highlighted term. Click
the Help window to turn
off the definition.

Examples and
practice
buttons

Goes to a demonstration
of the help topic.

W, E

= W ord, E =Excel, P =PowerPoint.

Tip of the Day
Word and PowerPoint display a dialog box with a helpful tip when you start
the program (see fig. 2.23). To remove the tips, deselect the Show Tips At
Startup check box. To see additional tips, choose the More Tips button and
choose one of the topics in the Help window. You can also display the Tip of
the Day dialog box by choosing Help, Tip of the Day.
Fig. 2.23
The Tip of the Day
appears when you
start the program
or when you
choose the Help
menu item.
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Quick Preview
When you first use Word, Excel, or PowerPoint, a Quick Preview screen appears similar to the one in figure 2.24. The Quick Preview displays a series of
automated screens showing features of the application. This preview screen
will appear a few times after you start your application. If you want to see the
preview screen, you can also choose the Help Quick Preview command. Topic
buttons on the screen enable you to choose getting started, new features of
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the current release, and tips for other users. Choose one of the topics or click
the Return button to return to the application. If you choose a topic, the
application loads the demonstration and then prompts you after each screen.
Choose the Next button. If you want to return to the opening screen, choose
the Cancel or Close button.
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Fig. 2.24
Quick Preview
enables you to get
a jump start on
the program and
see what's new.
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Examples and Demos
Examples and Demos expand on the automated screens of the Quick Preview.
They are available in Word and Excel. Examples and Demos are also automated screens, but they show you more features of the product, as shown
in figure 2.25. You can enter an Example and Demo by choosing the Help
Examples and Demos command, or by selecting the Examples and Demos
button that displays on some help topics. You then see a series of pictures
illustrating the topic. Click a balloon topic to move to that area in the demo.
Click the Close button to turn off the demo.
Fig. 2.25
Example and
demo screens
show details of
difficult procedures.
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"How To" Windows and Cue Cards
As you go through Help in Word and Excel, sometimes you get a separate
Help window with a How To title bar. Click the On Top button to keep this
window displayed as you work in your document. A How To window describes a series of steps for a process. You can work in your document at the
same time you scroll through the How To window. To close the How To
window, click the Close button.
PowerPoint has Cue Cards instead of a How To window (see fig. 2.26). Cue
Cards and the How To window are similar in that they display step-by-step
instructions. (On Cue cards, click the Next button to go to the next step.) Cue
Cards also have more background information, such as defining what is a
database. Cue Cards differ from How To windows because they automatically
appear on top of your application. To see the application window, you need
to minimize the Cue Card window (and the icon remains on top of the application) or close the Cue Card window by double-clicking the Control menu
box.
Fig. 2.26
Cue Cards give
you an overview
and step-by-step
instructions on
tasks.
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Wizards
One of the greatest help features in the Microsoft Office applications is not
really a help feature at all. Wizards don't appear on the Help menu but appear throughout the applications. Wizards are special dialog boxes that ask
you questions about the document you want to create and then use your
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answers to layout and fo rmat the document. Excel started with the Chart
wizard in Version 4, and now all the applications have wizards to help you
build documents.
When you enter a wizard as shown in figure 2.27, the wizard asks you to
enter text in text boxes or choose from a list of options. When you finish
filling in one step of the wizard, you choose the Next button to go to the
next step. You can skip to the last step if you know the default settings for
your wizard by choosing the Finish button. If you want to cancel the wizard,
click the Cancel button or press esc. On some dialog boxes, you also have the
capability to return to a previous step by choosing the Back button.

wtnl

the IIIIo or lhewt~~

l ~~ean~S>tell Gu~

You activate a wiza rd by different means in the programs. Table 2.15 lists
some of the wizards.

Table 2.15

See "Using
Template
Wizards,"

p. 190
~

See "Creating a
Presentation
Using a
Wizard," p. 432

Fig. 2.27
Word's Award
Wizard prompts
you for a name
and a title as well
as other optio ns.
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Wizards Available to Make Your Work Easier

Program and Wizard

How to Start

What It Does

Word Agenda Wizard

File, New Agenda Wizard

Creates a meeting
agenda

Word Award Wizard

File, New Award Wizard

Creates an award
certificate

Word Calendar Wizard

File, New Calendar Wizard

Creates a monthly
calendar

Word Fax Wizard

File, New Fax Wizard

Creates a fax cover
sheet

Word Letter Wizard

File, New Letter Wizard

Creates a business o r
personal letter
(continues)
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Table 2.15

Continued

Program and Wizard

How to Start

What It Does

Word Memo Wizard

File, New Memo Wizard

Creates a memo

Word Newsletter

File, New Newsletter Wizard

Creates a newsletter
with Wizard formatting and table of
contents

Word Resume Wizard

File, New Resume Wizard

Creates a resume

Word Table Wizard

File, New Table Wizard or
Table, Insert Table, Wizard

Creates or inserts a
formatted table

Excel Chart Wizard

Click Chart Wizard button

Creates a chart and
drag mouse area
where chart will
appear

Excel Pivot Table

Data, Pivot Table

Analyzes and
summarizes a Wizard
list of data

Excel Text Import Wizard

File, Open and choose
Text Type

Separates data into
columns

Excel Text Wizard

Data, Text to Columns

Separates (parses)
data from a long line
of text into columns

PowerPoint AutoContent
Wizard

Click AutoContent Wizard
button

Enables you to
choose from a series of
presentation types and
helps you create the
title and supporting
slides

PowerPoint Pick a Look
Wizard

Click Pick a look Wizard
button

Helps you format your
slides

From Here ...
To continue your introduction to working with the applications, you may
want to review the following chapters:
• Chapter 3, "Managing Files and Work Areas," shows you how to save,
open, print, and close files, work with drives and folders, and switch
among your applications.

From Here...

• Chapter 4, Creating and Editing Documents," gives you the basics for
creating a Word document.
11

• Chapter 12, Creating Worksheets," gives you the fundamentals of
creating an Excel worksheet.
11

11

• Chapter 20, Creating, Saving, and Opening Presentations," gives you
the basics on how to create a slide presentation.
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Managing Files and
Work Areas
by Tom Negrino

As you learned in Chapter 2, "Using Common Features to Create Documents,"
many features are common to the Microsoft Office suite of applications. In
addition to starting the programs, using Help, and typing and editing text,
these mutual features enable you to manage your files similarly across applications. The procedures for opening, closing, saving, and printing documents
are much the same. You also use similar steps to find a document, attach a
summary, and move between applications.
In this chapter, you learn to
• Open, save, and close documents
• Work with disk drives and folders
• Attach summary information to a file
• Find a file by name, contents, or summary info
• Switch to different documents and applications
• Compare work areas of the applications

Working with Files
For most applications, when you are working on-screen, the work you do is
only in the computer's memory. If the power fails or some other accident
happens, you could lose all or part of your work. The process of saving a file
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copies the information from memory to a file on disk (floppy disk or hard
disk). You can manually save the file or set up the program to save the file
automatically.
When you close a file, you are removing the information only from the
computer's memory or from your screen. During the close process, the program prompts you to save the file if you have made any changes since the
last save, or if you have not yet saved the file. Opening a file involves copying
the information from a disk into memory. When you create a new file, a new
document window opens.

...

...
...

Saving, Opening, and Clo sing Files
See "Saving,
Closing, and
Opening a
Document,"
p.98
See "Saving
vVorkbooks,"
p. 246
See "Saving a
Presentation,"
p.447

The procedures for saving, opening, and closing files are similar. You choose
the necessary commands by using a button on the toolbar, a menu item, or a
shortcut key. In most cases, a dialog box opens, requesting information about
the file name, location (drive and folder), and type of file you are using.
Sometimes, this dialog box does not open. When you save a file after naming
it, the program assumes that you want to use the default choices in the File
dialog box for the name, location, and file type. You can rename the file with
the Save As command.
Table 3.1 shows the different methods of saving, opening, and closing files.

Table 3.1

Saving, Closing, and Opening Files

Action

Button

Menu Comm and

Shortcut Key

Save

[!;I

File Save

)::(+S

File Save As

Save As
Open

New

Close

~
[lQJ

File Open

)::(+0

File New

)::(+N

click document's
close button in
upper left
corner

File Close

)::(+W
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You also can easily find one of the last files you worked with. At the bottom
of the File menu is a list of your most recent files (see fig. 3.1). Choose the file
name to open the desired file .

..

Fig. 3.1
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Quit
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If you have not saved changes to your new file and you close the file by using

any method, including quitting the application, you are asked whether you
want to save your changes. If you choose Yes, the Save As dialog box appears.
When you click the New button, or press ~+N, a new blank document window opens. If you use the New command from the File menu, you may be
prompted for a template or wizard. Templates are files that may have stored
formatting, macros, styles, text, and different menus and toolbars. After you
open a template, you still need to give the document a name to save it.
Wizards are a series of dialog boxes that lead you through the steps of
creating a document or performing a function.

Using File Dialog Boxes
When you save a file for the first time, change the file name, or open a file,
the program you are using displays a dialog box similar to the one shown in
figure 3.2, asking you the name of the file and its location. File names can be
up to 31 characters in length. The location of the file is defined as the drive
and folder where it is stored.

~

See "Using
Template
Wizards,"
p. 190

....

See "Understanding
Masters and
Templates,"
p.421

~

See "Creating a
Presentation
Using a
Wizard,"
p.432
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The pop-up menu showing the
folder where the file is saved

The drive where
the file is saved
I

I

Fig. 3.2

I

The Save As dialog
box displays the
destination of the
file you are saving.
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When you open a Save As file dialog box, the File Name text box usually is
highlighted. You can change the folder in which the file is saved by clicking
the pop-up menu at the top of the file list; or change the disk by clicking the
Desktop button, and then double-clicking the resulting list of disks. You also
can click the New Folder button to create a new folder. You'll be asked to
name the new folder, then the file will be saved into the new folder.
In addition to the Save and Open commands that bring up a dialog box, table
3.2 shows more commands that bring up a file dialog box.

Table 3.2

Commands that Bring Up a File Dialog Box

Command

Description

Application

Insert File

Places an existing document
inside the current document.

w

Insert Picture

Inserts a graphic file into
the document

W, E, P

Insert Database

Inserts a table into the
document.

w

Insert Object

Inserts a file into your
document so you can later
edit the object with the
application that created
the source file.

W, E
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Command

Description

Application

Insert Clip Art

Inserts a picture from
the clip-art library.

p

Insert Microsoft Word Table

Inserts a Word table
object that can be
formatted like Word tables.

p

Insert Microsoft Graph

Inserts a graph (chart)
into the document.

p

W = Word, E =Excel, P = PowerPoint

Troubleshooting
When /look for a file, the file name does not appear in the file list box.
The file name may not appear in a file list box for several reasons. First, you may have
to use the scroll bars to display more files in the list. Second, the file may not be the
correct type of file. In the list Files of Type list box, select All Files, and see whether
your file is listed. Third, you may have to look in a different drive or folder. Finally, if
all else fails, use the Find File feature, discussed in "Finding Files" later in this chapter.

Working with Disks and Drives
Whenever you save a file, the file goes to a disk somewhere. In the simplest
case, you may have a hard disk inside your computer and one floppy disk
drive. However, your Macintosh computer may have additional floppy and
hard drives, removable disk cartridges and optical drives, and a CD-ROM.
Your computer also could be connected to a network, giving you access to
computer drives that are not directly attached to your Macintosh. No matter
the configuration, in the File Open dialog box, you can tell if you're looking
at a hard disk, a floppy disk, or a networked drive by checking the type of
icon next to the name of the disk. To change the drive, click the Desktop
button in the File Open dialog box, and then double-dick the name of the
new drive (see fig. 3.3).
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Fig. 3.3
Choosing a new
drive after clicking
the Desktop
button.
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Working with Folders
Macintosh drives are organized with folders. An analogy is a file cabinet. The
drive is divided into folders that can contain subfolders, which can in turn
have their own subfolders. To change to different folders, you use the Folders
pop-up menu in the file dialog box (see fig. 3.4). Th e name of the current
folder appears next to the icon of the open folder in the pop-up menu, or
n ext to an icon of a hard drive. To the right of the folder and file list is the
name of the current drive.
Fig. 3.4
The Open file
dialog box.
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To open one of the folders, double-click the folder name. The file list will
change to show you what is in that folder, and the folder name will appear in
the pop-up folder menu.
To move back up the chain of folders, click and hold the pop-up folder
menu; then drag the menu to the desired folder.
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Working with File Types
In dialog boxes relating to files, you see a pop-up menu that is labeled List
Files of Type, or something similar. This box is usually in the bottom-left
comer of the dialog box. The default choice for this list box is the file type for
the program in which you are working. If you are saving a Word document,
for example, this box displays Word Document.
You also can use the Save File as Type pop-up menu to save files in a different
file format (see fig. 3.5). You usually change the file type when you want to
convert a file from one kind of worksheet (Excel to Lotus 1-2-3, for example),
or one word processing document (such as Word to WordPerfect for DOS or
Windows) to another. You should understand, however, that Office applications assume that you are just changing the file type for the current save
operation. After you change the file type and save a file, the Save File as Type
setting reverts to Normal. Subsequent saves of that file will again bring up the
Save As dialog, set to Normal, unless you click the Default for File check box.
Clicking Default for File keeps the file in the changed file type.
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If you frequently share files with coworkers who have PC-compatible computers, it's also common to change the file type so that you can save a file in
an older version of Word or Excel for DOS or Windows. In some cases, however, you may want to open a different kind of file. You can, for example,
open an Excel worksheet file in a Word document. Table 3.3 shows some
possibilities for opening different kinds of files.

Fig. 3.5
To save a file in a
different format
than the Word
Document type,
use the Save File
as Type pop-up
menu.
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Table 3.3

•

File Types You Can Open in a Different Application

Application
Opening File

File Type Opened
In Application

Word

Excel worksheet

Word table (can be
a merge data document)

PowerPoint

Word outline

Heading 1 = slide title,
Heading 2, 3 = points
and subpoints

PowerPoint

Excel worksheet

Each row becomes the
title of the slide

Result

Using Save Options
Although most applications require that you save files, Word and Excel enable you to create backup files and set up automatic saving. Because these
features are backups, you should still use the Save button, the menu command, or the shortcut key to save your files regularly-especially after you
spend a significant amount of effort making your document look the way
you want, or before you perform a major procedure on your file (such as spell
checking, sorting, replacing, automatic formatting, or importing). You may
want to use the Save As feature to save different revisions of the same file
until your project is complete.
A backup file has the form Backup of [Filename]. You create a backup file
after you have saved the file at least once. When you save a file all subsequent times, the backup procedure renames the old file on disk with the same
file name, but with the Backup of prefix, and saves the document on-screen
with the name of the document. Word may shorten the filename to keep
it within the 31 character filename limit. To start the backup procedure,
choose the Save As command from the File menu, click the Options button,
and then click Always Create Backup. If you need to use your backup file,
open the Backup of[Filename] document.
In Word and Excel, you can set up the automatic save feature so that
the program regularly saves your work at time intervals that you specify. In
Word, automatic save places a temporary copy of your document in a hidden
folder in the top level of your hard disk, called Temporary Items. If your machine crashes, look in the Temporary Items folder (which becomes visible if
you set the Open dialog box to All Files), or check the Trash for a folder called
Rescued Items. In Excel, the program prompts you for a file name if you have
not already saved the file.
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Using Summary Info
As mentioned earlier, when you name a file, you are limited to 31 characters.
While this is usually enough to describe a file, Word, Excel, and PowerPoint
feature a Summary Info dialog box that enables you to use an even longer
title and to add a subject, the author's name, keywords, and comments to
your file.

..,. See "Creating

Summary Info
Records,"
p. 140

To save summary information with a file, follow these steps:
1. From your document, choose the File Summa ry Info command.

The Summary Info dialog box appears, as shown in figu re 3.6.
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2. Type your description, longer than 31 characters if necessary, in the

Title text box (you can include spaces).
3. If desired, type a subject, author name, keywords, or comments.

To move between fields, press tab or click the field.
Word automatically fills in the author name, based on the User Info.
To change the author, type a new name in the text box. To change the
User Info, choose the Tools Options command, select the User Info tab,
and change the name in the Name box.
4. In Word, if you want to see the number of words or other document

statistics, click the Statistics button .
5. When you finish, click OK.

Finding Files
Have you ever tried to find a file when you forgot where you put it or what
you called it? Life can be difficult when you cannot find a fil e and have to recreate it. Word, Excel, and PowerPoint now have a Find File feature that enables you to search for a file based on the file name, summary information,
file contents, or file dates. You can look for a file in either of two ways: Using
the Search dialog box or using the Advanced Search dialog box. After you
search for files, they appear in the Find File dialog box.

..,. See "Working
in Find File,"
p. 15 1
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Using the Search Dialog Box
To find files through the Search dialog box, follow these steps:
1. Open the File menu and choose Find File. The Search dialog box
appears (see fig. 3.7).

Fig. 3.7
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Note
You may see the Search dialog box or the Find File dialog box, depending on
your last search. If the Find File dialog box appears, click the Search button to
go to step 2.

2. Enter the file criteria in the File Name text box. If you enter a partial
filename, the search will include all filenames that have those
characters.
3. If necessary, choose the file type from the File Type pop-up menu.
4. Choose the drive from the Location pop-up menu in the Location text
box.
5. To start the search, click OK.

The results of your search appear in the Find File dialog box (see the section
"Using the Find File Dialog Box" later in this chapter).
Using the Advanced Search Dialog Box
The Advanced Search dialog box enables you to go beyond searching for file
names. You also can search fo r text within the file, look for the file by date,
or look for the file based on other information in the Summary Info dialog
box. Although the Advanced Search takes more time to complete than the
basic Search, it performs a more extensive search and is more likely to find
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your exact file. The Advanced Search dialog box has three tabs, which are
described in the following sections.
To find a file by using the Advanced Search dialog box, follow these steps:
1. Open the File menu and choose Find File. The Search dialog box appears. (If the Find File dialog box appears instead, click the Search

command button to go to step 2.)
2. In the Search dialog box, choose the Advanced Search command but-

ton . The Advanced Search dialog box appears, with three tabs. To move
to a tab, click it.
3. Select options in any or all of the tabs to define your sea rch criteria.
4. When you finish selecting options in the tabs, click OK. The Find File

dialog box appears (see "Using the Find File Dialog Box" later in this
chapter).
Using the Advanced Search Location Tab
In the Advanced Search dialog box, select the Location tab to display the
location options. The dialog box changes as shown in figure 3.8. The purpose
of this tab is to build a list of drives and folders in the Search In list box.
Fig. 3.8
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To change the search criteria, follow these steps:
1. If you want to clear the existing folder search criteria, choose the

Remove All command button .
2 . If you want to remove one folder from the search criteria, select the

folder in the Search In list box and then choose the Remove command
button.

The Advanced
Search dialog box,
showing the
Location tab.
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3. To add a folder to the search list, choose the Add command button.

An Open File dialog box appears. Navigate to the folder you want to
add, then click the Select button at the bottom of the Open dialog.
The folder appears in the Search In list box.
4. To include additional folders, repeat step 3.
S. To search within the subfolders of the selected folders in the Search In

list box, select the Include Subfolders option.
6 . To choose specific application files, select a file type in the File Type

pop-up menu.
7. To add more search criteria, select another tab, or click OK to return to

the Search dialog box.
Using the Advanced Search Summary Tab
Use the Summary tab to change the search criteria to include infor mation
from the Summary Info dialog box, or text within the file.

In the Search dialog box, select the Summary tab. The dialog box changes as
shown in figure 3.9.
Fig. 3.9
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of the Advanced
Search dialog box.
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Do any of the following things to fu rther specify the parameters of your
Advanced Search:
• Type the title of the document (from the Summary Info dialog box) in
the Title text box.
• Type the author's name in the Author text box.
• Type a keyword in the Keywords text box.
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• Type a word or phrase in the Subject text box.
• In the Containing Text area, type a word or phrase that is in the file
you want to find.
• If you want the capitalization to match the search criteria, select Match
Case.

When you finish with the Summary tab, click OK to return to the Search
dialog box, or select another tab.
Using the Advanced Search Timestamp Tab
In the Advanced Search dialog box, select the Timestamp tab to display the
portion of the search criteria that lets you search for files by when they were
saved or created. The dialog box changes, as shown in figure 3.10.
Fig. 3.10
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The Timestamp tab contains two sections. Use the Last Saved section to
search for the file based on when the file was last saved (with the File Save or
Save As command). Use the Created section to search for the file based on
when the file was created (with the File Save command). In either section,
type the starting and ending dates for which you want to search. The file date
must fall between those two dates. In the By text box in either section, type
the name of the user. This name is the user's name, as defined in User Info,
and does not have to be the author's name, as shown in the Summary tab
(although these names usually match).
When you finish with the Timestamp tab, click OK to return to the Search
dialog box, or select another tab.
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Saving and Using Saved Search Criteria
After you identify the file name, location, summary information, text, or
dates, you can save these settings. To do so, follow these steps:
1. If you are in the Advanced Search dialog box, click OK to return to the
Search dialog box.
2. Choose the Save Search As button.

3. Type the name of the search.
When you want to use a previously named search, select the search from the
Saved Searches pop-up menu. To delete the search, choose the Delete Search
command button. Figure 3.11 shows a list of saved searches.
Search
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Using the Find File Dialog Box
After you click OK in the Search dialog box, the program builds a list and
displays the files within drives and folders that match the criteria that you
specified on the left side of the Find File dialog box (see fig. 3.12). As in the
Finder, you can click the small triangles next to the folder names to expand
or collapse the list of files with that folder. The right side of the dialog box
can show files in any of three views.

You can select the following views in the View pop-up menu:

• Preview. Shows an image of the file (see fig. 3.12).
• File Info. Shows the file name, title, size, author, and date and time
saved.
•

Summary. Shows the title, author, keywords, comments, date, time, and

statistics.
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You can open the file by choosing the Open command button. If you choose
the Commands pop-up menu, you can perform any of the following
operations:
• Open a read-only copy of the file. When you try to save the file, you are
asked for another name.
• Print the file.
• Display the summary.
• Delete the file.
• Copy the file.
• Sort the list by name, date, title, author, or size.
As in the Finder, you can select multiple files by holding down the Shift or ~
keys and clicking additional files. When you select multiple files, you also can
open, print, delete, or copy them .

Printing Documents
As mention ed in the preceding section, you can print one or more files by
selecting the Commands Print option in the Find File dialog box. To print or
preview the current document, you can use menu commands, toolbar buttons, or shortcut keys.
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Fig. 3.12
The results of your
search show in the
Find File dialog
box.
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Printing All or Part of the Document
~~

To print the document, choose the File Print command or press J::(+P.
When you use the Print button or shortcut key, the entire document prints.
If you use the menu command, a dialog box similar to figure 3.13 appears,
displaying more choices.

Fig. 3.13
The Print dialog
box in Word. The
other application's
Print boxes are
similar.
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Options in the different applications' Print dialog boxes enable you to print
the entire document, the current page, specific pages, or selected text. You
also can specify the number of copies to print.

Changing Printing Options
If you want to make additional printing choices, use the Page Setup dialog
box, shown in figure 3.14, by choosing Page Setup from the File menu. The
options in this dialog box enable you to set margins, print headers and
footers, specify the print orientation, and change the printer settings.
Fig. 3.14
The Word Page
Setup dialog box.
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Printing Documents

To access Page Setup to change margins, paper size, and other features, use
the following commands:
Application

Menu Command

Button In Print
Dialog Box

Word

File Page Setup

None

Excel

File Page Setup

Page Setup

PowerPoint

File Slide Setup

None

To change the printer, open the Apple menu, choose the Chooser, and select
the printer you want to use.

Using Print Preview
Although your screen usually shows what you will see on the printed page,
Word and Excel have a Print Preview option that enables you to see the entire page (or more than one page), including headers and footers, page numbers, and margins. Print Preview is useful because Word and Excel sometimes
display things differently on-screen than they will appear when printed.
Print preview shows you exactly how your document will look on paper.
You enter the preview by choosing the Print Preview command from the File
menu. Table 3.4 shows the features available while you are in preview mode.

Table 3.4

Features Available in Print Preview

Feature

Word

Excel

Change margins

X

X

Magnify

X

X

Zoom to different sizes

X

Multiple pages

X

Shrink to fit

X

X

Print

X

X

Edit

X
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Figure 3.15 shows Print Preview for Word, and figure 3.16 shows Print
Preview for Excel.
Fig. 3.15
The Word Print
Preview screen box
can show multiple
pages of your
document at once.
~::;.
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Fig. 3.16
The Excel Print
Preview screenbox
lets you change
column margins
so more of a
document can
fit on a page.

- ~

Drag the
doubleheaded black
arrow to
change the
margins

Switching between Documents
If you want to use Print Preview, you can use the following options:

• To change margins, click the Margins button, move the mouse pointer
to the top or side until the pointer changes to a double-headed black
arrow, and drag the margin.
• To magnify, click the Magnify button, and click the document where
you want magnification.
• To turn magnification off, click the document again.
• To edit the document in Word, click the Magnify button to turn
magnification off, and editing on.

Switching between Documents
When you open more than one file at a time, you have a window for each
file. You can switch between open documents in the following ways:
• Choose the desired, open document from the bottom of the Window
menu.
• Press ;)::(+F6 to cycle through the open documents.
• If parts of documents are visible on-screen, click them to bring them to

the front.
If you want to copy information between documents, you may want to dis-

play two or more windows, as follows:
• In Word, choose the Window Arrange All command to display the
documents as shown in figure 3.17.
• In Excel, choose the Window Arrange command. A dialog box appears,
asking how you want to arrange the windows. The Tiled option displays
the windows in small rectangles (see fig. 3.18). Horizontal displays the
windows in rows across the screen (like Word). Vertical displays the
windows in columns across the screen. Cascade stacks the windows,
with the title bar of each window showing, like tabs.
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Fig. 3.17
Word's Arrange All
command stacks
the windows
horizontally.
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Excel's Arrange All
command lets you
tile documents
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Looking at the Work Areas of the Different Applications
• In PowerPoint, choose the Window Arrange All command to show the
documents in tiled form. You also can choose the Window Cascade
command to stack the windows in a manner similar to Cascade in
Excel.
When several documents are visible, the title bar with thin horizontal lines in
it indicates which window is active. To make another window active, click
that window. To show one of the windows full-screen, click the Maximize
button or double-click the title bar. In Word, you can use the drag-and-drop
feature to move text between document windows.

Switching between Applications
In addition to switching between documents within an application, you can
switch between applications. You can switch between open applications in
the following ways:
• Open the Microsoft Office Manager menu, then choose an Office
application. The application will open, if it isn't already active.
• Open the application menu, and choose any other open application.
• If part of the application window is visible, click it.

When several applications are visible, a dark title bar indicates which window
is active. To make another window active, click that window. You can use the
drag-and-drop feature to move information from Excel and PowerPoint to a
Word document. You also can use drag-and-drop to go from Word and Excel
to PowerPoint and from Word to Excel.

Looking at the Work Areas of the
Different Applications
The Microsoft Office applications, like all Macintosh applications, have many
similarities-for example, all applications have at least one document window, a menu bar, toolbars, and status bars. Because the Microsoft Office applications are different from one another, however, each application has a
different focus and a different kind of work area.
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Word Document
The work area of Word is the document (see fig. 3.19). The document window is like a blank sheet of paper on which you can type. When your typing
reaches the margin, the text automatically wraps to the next line. The focus
of Word is text. Although you can place numbers and data in Word documents, the strength of Word is its capability to format text documents, such
as letters, memos, and reports. The length of your document is virtually
unlimited.
Fig. 3.19

Text is the focus
of the Word
document
window.
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Excel Worksheet
The work area of Excel is a grid of columns and rows (see fig. 3.20). The Excel
document is called a worksheet and is similar to a table in Word or Access. The
focus of Excel is a cell, which is the intersection of a row and column. All data
must go into cells. Although you can place text boxes across a range of cells;
long sections of text are better left to Word; Excel's strength is its capability
to summarize and analyze numbers. Excel also has significant charting capabilities that enable you to create many types of pie, bar, column, and line
charts.

looking at the Work Areas of the Different Applications
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An Excel worksheet has 256 columns (indicated by letters A to IV) and 16,384
numbered rows. Each cell is indicated by the column Jetter and the row number. E6, for example, is the cell in the fifth column and sixth row. An Excel
worksheet can have several sheets.

PowerPoint Slide
The focus of PowerPoint is the slide (see fig. 3.21). PowerPoint is used primarily to make presentations. You can create slides for uses such as overhead
transparencies, 3Smm slides, or on-screen presentations.
Each slide has attached objects, which may include a title, bulleted items,
other text, and graphics. To edit an object, you first have to select the object.
You can view PowerPoint slides in different ways. Outline view shows the
titles of all slides in list format with their attached bulleted items. Slide view
(the normal view) shows one slide at a time. Slide Sorter view shows more
than one slide at a time. Notes Pages view enables you to type notes for each
slide.
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Fig. 3.20
The Excel
worksheet is where
you enter numbers
and formulas.
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Fig. 3.21
The PowerPoint's
main working area
is the slide.

From Here...
To continue your introduction to the Microsoft Office applications, you may
want to review the following chapters:
• Chapter 4, "Creating and Editing Docu ments," covers the basics of
creating a Word document.
• Chapter 12, "Creating Worksheets," explains the fundamentals of
creating an Excel worksheet.
• Chapter 20, "Creating, Saving, and Opening Presentations," gives you
the basics of creating a slide presentation .

Part II

Using Word
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Chapter 4

Creating and Editing
Documents
by Peter Durso

II
Of all the applications included with Microsoft Office, Word 6 may be the
one you use most. You probably need a word processor to produce letters,
envelopes, and so on in your everyday work. Using Word, you also can create
memos, fax cover sheets, reports, newsletters, mailing labels, brochures, and
many other business documents.
In this chapter, you learn to
• Identify the parts of the screen and the toolbar buttons
• Enter text
• Select text
• Edit text
• Reverse the last editing action
• Start a new document
• Save a document
• Close and open documents
Word offers many commands and features that help you complete your work
quickly and easily. Word provides easy graphics handling, outlining, calculations of data in tables, the capability to create a mailing list, list sorting, and
efficient file management. In addition, you can perform many desktop publishing tasks, such as formatting fonts, creating display type, aligning text,
adding graphic borders, and adding shading.
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Microsoft Office offers another advantage of using Word as your day-to-day
word processor. Whether you use Word with Office or as a stand-alone
Macintosh application, you have flexibility and control of data shared with
Excel, PowerPoint, Mail, and any other Macintosh application you may use.

Understanding Word Basics
~

See "Using
Help," p. SO

Word is an excellent program offering many features that help you perform
your word processing tasks efficiently. If you are familiar with Macintosh
applications, you already know quite a bit about operating Word. You know,
for example, how to use such features as the Apple menu, the Window menu,
and the Help Balloon. Additionally, you understand the use of the mouse,
scroll bars, dialog boxes, and other features of a Macintosh application.
For more information about Word for Macintosh, refer to Que's book,
Using Word Version 6 for Macintosh, Special Edition.
This section shows you how to use some features and screen elements that
are featured in the Word program, including the toolbar, scroll bars, and
status bar.

Using the Word Screen
~

See "Viewing
Parts of the
Window," p. 22

~

See "Using
Menus," p. 30

When you start the program, Word displays specific screen elements as defaults, including the title bar, menu bar, two toolbars, a ruler, and scroll bars.
You can, of course, hide these elements or show different components at any
time by choosing a command from the View menu. Suppose that you want
to hide the ruler. Open the View menu and choose Ruler to hide it; open the
View menu and choose Ruler again to display the ruler.
Figure 4.1 illustrates the default Word screen and indicates the components
of the screen.
The following list describes the screen elements. The toolbars are covered in
more detail in the next chapter.
•

Title bar. The title bar contains the name of the document, the Close
box, and the Zoom box.

•

Menu bar. The menu bar contains specialized menus containing related

commands. Choose commands from the Format menu, for example,
to change fonts, set tabs, add a border, and so on. Additionally, the
Microsoft Office Manager icon located between the time display and

Using the Word Screen
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the Help menu at the right end of the Menu bar gives you access
to Office Help, other Microsoft Office programs, Microsoft's Find File
utility, and more.
Menu bar

Microsoft Office

Fig. 4.1
Using Word's
screen elements
can help you
complete tasks
quickly and
efficiently.
Formatting toolbar
L - - - - - - - - - - - - - - - - - - - --14-

Mouse pointer

' - - - - - - - -- -- -- - -- - - - - - - - - -++- End marker

- - - - - ----1-+-- Text area
bars

View buttons

Status bar

• Standard too/bar. This toolbar contains buttons you click to perform
common tasks, such as starting a new document, saving a document,
checking spelling, and undoing an action. The buttons in the Standard
toolbar provide shortcuts for menu commands.
• Fonnatting too/bar. The buttons in the Formatting toolbar provide shortcuts for choosing fonts, font sizes, styles, alignments, and so on. Use
this toolbar to format text as you work.

.,.. See "Formatting
Paragraphs,"
p. 112

• Ruler. The ruler provides a quick and easy method of setting tabs and
indents in your text. For more information about the ruler, see ChapterS, "Formatting Text and Documents."
~

• Text area. The text area consists of a blank "page" in which you enter
text or place pictures, graphics, and so on.

See "Viewing
Parts of the
W indow," p. 22

II
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See "Moving
Around the
Document,"

• Scroll bars. Use the scroll bars to move quickly to another area of the
document.

p.42

• Status bar. The status bar lists information and displays messages as you
work in Word. When you position the mouse pointer on a toolbar button, for example, a description of that button's function appears in the
status bar.

Entering Text
When you start the Word program, Word supplies you with a new, blank
document (named Document1 in the title bar). You can begin to type at the
blinking insertion point. When you enter text, that text appears at the insertion point.
This section describes the basic techniques of entering text, moving around
in a document, and selecting text for editing.

Typing Text
When entering text, you type as you would in any word processor. Word
automatically wraps the text at the end of a line, so you do not have to press
return to begin a new line. Press return only when you want to start a new
paragraph or create a blank line. Word defines a paragraph as a letter, word,
or sentence ending with a paragraph mark.
A paragraph mark is a nonprinting character inserted whenever you press
return. You can view paragraph marks by clicking the Show/Hide Cj{ button in
the Standard toolbar. To hide the paragraph marks, click the Show/Hide 'II
button again. Figure 4.2 illustrates paragraph marks and the Show/Hide 'II
button in the Standard toolbar. In addition, the right margin in the figure is
set at 4 1/2 inches so you can see the automatic word wrap.
Following are some useful shortcuts and features you can use when entering
text in Word:
• If you make a mistake while typing, press the delete key to erase a
character to the left of the insertion point.
• To repeat the text you just typed, open the Edit menu and choose
Repeat Typing; or press j::C+Y.
~
~

• To erase the text you just typed, open the Edit menu and choose Undo
Typing; or press j::C+Z. You also can click the Undo button in the Standard toolbar.

Entering Text
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• To start a new line without inserting a paragraph mark, press
shift+return. Word inserts a line-break character.
• Double-click the OVR indicator in the status bar to use overtype mode,
in which the text you enter replaces existing text. Double-click the
indicator again to turn off overtype mode.
Show/Hide ~

button

Fig. 4.2
Paragraph marks
are nonprinting
characters; they do
not print, whether
they are displayed
or not.
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Paragraph marks

Positioning the Insertion Point

Tip

To move the insertion point, move the I-beam mouse pointer to the new
location and click the mouse button. You can position the insertion point
anywhere in the text area except below the end marker, which is the short
horizontal line displayed in the text area. You can move the end marker by
inserting paragraph returns (pressing return) before the marker.

The insertion
point always
stays within the
page margins. If
you click outside the margin,
Word places the
insertion point
in the nearest
text.

If you want to move the insertion point to a location that doesn't appear in

the current window, you can use the horizontal or vertical scroll bar to move
to the new location. When the new location is displayed in the window,
place the !-beam pointer where you want to position the insertion point and
click the mouse button.
Additionally, you can press some of the keys on the keyboard to move the
insertion point to a new location. Sometimes, using the keyboard to move
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around in a document is faster and easier than using the mouse. Table 4.1
lists common keys you can use to move around in your documents:

Table 4.1

Common Keys to Move Insertion Point

Key

Moves Insertion Point

Arrow keys

One character up, down, left, or right
One word to the left or right

Seledlng Text
After entering text, you may want to delete or move a word, sentence, or
paragraph. In addition, you may want to format the text by changing the
font or font size, indenting text, and so on. Before you can perform one of
these actions on the text in your document, you must select the text. Selecting, or highlighting, the text shows Word where to perform the action.
You can select text by using the mouse, the keyboard, or a combination of
methods, depending on how much text you want to select. The following list
describes the methods of text selection:
• To select one word, position the 1-beam pointer anywhere in a word
and double-click. The word and the space following the word are
selected.
• To select a sentence, hold down the ;)::( key while clicking anywhere in
the sentence. Word selects all words in the sentence to the ending
punctuation mark, plus the blank space following the punctuation
mark.
• To select a paragraph, triple-click the paragraph.
• To select specific text, click and drag the 1-beam pointer over one character, one word, or the entire screen.
• To select one line of text, place the mouse pointer in the selection bar
and click. The selection bar is an invisible vertical band to the left of the
text area. When you point the mouse in the selection bar, the 1-beam
pointer changes to an arrow (see fig. 4.3).
• To select the entire document, hold down the ;)::( key while clicking the
selection bar. Alternatively, press ):C+A to select the entire document.

Entering Text
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• To select a vertical l.Jlock of text-the first lt!ttt!rs of words In a list, for
example-ho ld down the option key and then click and drag the mouse
po inter across the text. Figure 4.4 shows a vertical block of selected text.
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• To select text with the keyboard arrow keys, position the insertion
point where you want to start selecting, press and hold down the shift
key, and then press the appropriate arrow key to move up, down, left,
or right.
To deselect text, click the mouse anywhere in the document or text area, or
press any of the arrow keys.
Troubleshooting
I began typing the text, but nothing changed on-screen.
You must click the mouse to position the insertion point before you begin typing the
text. A blinking vertical line indicates the insertion point.

I tried to select text with the mouse, but I had trouble controlling the selection.
It takes practice to control the mouse when you select text. Try one of the alternative
methods of selecting text that were described in this section. For example, try positioning the insertion point at the beginning of the selection, holding down the shift
key, and then clicking the mouse at the end of the selection.

Editing Text
~

See "Typing
and Editing,"

p.35

With Word, changes and corrections are easy to make. You can select any
text in your document and delete it, copy it, or move it. You also can make
other changes easily. How many times have you typed text, only to discover
that the Caps Lock feature was on? Don't type the text again; use Word's
Change Case command. This section shows you how to edit your document
quickly and easily.

Undoing a Mistake
~

usa

Many mistakes can be reversed by using the Undo command. Suppose that
you type a sentence and decide you don't like the way it reads. You can delete it by opening the Edit menu and choosing Undo, or by pressing either
of the shortcut keys: ~+Z or option+delete. If you make a correction and
change your mind, you can use the Undo command to reverse the action.
Word also provides a Redo command (found within the Edit menu) that you
can use to reverse the last Undo. The keyboard shortcut for the Redo command is ~+Y. Both the Undo and Redo commands describe the action you
just performed: For example, Undo Typing, Redo Clear, and so on.

Editing Text
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The Undo and Redo commands allow you to sequentially undo actions one
at a time until you reach the desired previous action. For example, if you Bold
a word, Unbold it, change the font size from 12 pt. to 18 pt. and then Italicize the word, repeated selections of Undo would move you through the edits
backwards. You would go from Italicized 18 pt. text after the first selection of
Undo to Plain Text 18 pt. the first time you selected Undo. The second time
you select Undo, you would go from 18 pt. back to 12 pt., and so on through
your document. Word also supplies Undo and Redo buttons in the Standard
toolbar that enable you to undo or redo all of your recent actions by moving
th rough a pop-up menu. Figure 4.5 shows the Undo pop-up menu displaying
five of the most recent actions.
Undo pop-up menu

Flg.4.5
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Deleting and Moving Text
To delete any amount of text, select the text and then press the delete key.
When you press delete, the text is erased; the only way to recall the text is to
choose the Undo command. Alternatively, you can delete text by selecting it
and then open the Edit menu and choose Clear. The Edit Clear command
deletes the text just as the delete key does.
You also can use the Cut command to remove the text. Choose the Cut
command to move the selected text from the document to the Macintosh

Tip
lf you make a
mistake while
typing text, or
if you discover
a misspelled
word or misplaced punctuation, you
can press delete
to erase the
mistake.

II
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Tip
The shortcut key
for Cut is ~ +X;
the shortcut key
for Paste is ~+ V.
You also can use
the Cut and Paste
buttons in the
Standard toolbar.

Clipboard. The text remains on the Clipboard until you use the Cut command again.
To move text that you cut to another location in the same document or to
another document, position the insertion point where you want the text to
appear, and then open the Edit menu and choose Paste. The cut text reappears at the insertion point. You can paste this text again and again until you
cut or copy new text.

Copying Text
To copy text, select the text and then open the Edit menu and choose the
Copy command; or press the shortcut key :FC+C. Word copies the text to the
Clipboard. You then can paste the copied text in a new location or document
by positioning the insertion point and then opening the Edit menu and
choosing Paste or by pressing :FC+V.
Copying text-<Jr other elements in your documents, such as pictures and
charts-is one way to share data between applications. You can, for example,
create text in Word, copy it, and paste it in PowerPoint. You also can copy a
worksheet from Excel and paste it to a table in Word.

Drag-and-Drop Editing
An additional method you can use to move or copy text is called drag-anddrop editing . Word supplies this shortcut for moving or copying selected text a
short distance-one screen at a time, for example. You also can use drag-anddrop editing to copy or move graphics.
Tip
To copy the
text or graphic
instead of
moving it, hold
down the
option key as
you point to
the selected
text or graphic
and drag the
dotted insertion point to a
new location.

To use drag-and-drop editing to move text or graphics, follow these steps:
1. Select the text or graphics that you want to move.

2. Point to the selected text or graphic, and hold down the mouse button.
The drag-and-drop pointer appears (see fig. 4.6).
3. Drag the pointer and the dotted insertion point that appears to the new
location, and then release the mouse button.
Note
The drag-and-drop editing option is activated by default. If you do not want to use
drag-and-drop editing, you can turn the feature off by opening the Tools menu and
choosing the Options command. In the Edit tab, select Drag-and-Drop Text Editing
to turn the option off.

Editing Text
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Insertion point
Fig. 4.6
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Converting Case
Word includes a handy command you can use to convert the case of text that
you entered earlier. Suppose that you decide you do not want a heading to
appear in all caps. You can use the Change Case command to make the
change.
To change the case of text, open the Format menu and choose the Change
Case command. The Change Case dialog box appears. Select any of the following options:

• Sentence Case. Capitalizes the first letter only in selected sentences.
• Lowercase. Changes all selected text to lowercase.
• Uppercase. Converts all selected text to all caps.
• Title Case. Changes each word of selected text to initial caps.
• Toggle Case. Changes uppercase to lowercase and lowercase to uppercase
in all selected text.

Tip
You also can use
the shortcut key to
change case. Select
the text, and then
press ~+Shift+C.
Each time you
press the shortcut
key, Word toggles
the case from
lowercase to uppercase to title case.
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Troubleshooting
I accidentally deleted or cleared text that I did not mean to delete.

Click the Undo button in the Standard toolbar, and select Clear in the pop-up menu
to reverse that action.
I pasted selected text in the wrong place.

Press ):(+Z to undo the paste. Then position the insertion point in the correct location and open the Edit menu and choose the Paste command again.
I accidentally get the drag-and-drop editing pointer when I do not want it.

Be careful not to click a text block after selecting it. If you do, however, click the
mouse one more time to cancel the drag-and-drop pointer, which also cancels the
text selection. Then simply select the text again. If you do not use the drag-and-drop
pointer, consider turning the option off by opening the Tools menu and choosing
the Options command.

Saving, Closing, and Opening a
Document
~

See ~~working
with Files,"

p.61

This section shows you how to save and close a document, open an existing
document, and start a new one. The following discussion is specific to the
Word program; for information about basic file management, refer to Chapter 3, 11 Managing Files and Work Areas."

Saving a Document
Tip
Save your documents early and
save often as you
work on them. If
a power failure
occurs while you
are working on
your document
and you have not
saved it as a file,
you will lose the
document.

As in other Microsoft Office programs, you save a Word document by assigning it a name and a location in a folder on your drive. After naming the file,
you can save changes made in that document without renaming the file by
pressing a shortcut key or clicking a button in the Standard toolbar.
Naming a Document

The first time you save a document, open the File menu and choose the Save
As command. Word displays the Save As dialog box, shown in figure 4.7.
When you save a document, Word places the file in the folder that you
specify on your hard drive. Word also suggests a file name for the document;
you can either accept the suggested name or rename the document to suit
yourself by typing a new name in the File Name text box. To save a

Saving, Closing, and Opening a Document
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document with a new name, in a different file format, or in a different location,
type a n ew filename. A filename can contain up to 31 characters, including
spaces. You can use any character on the main keyboard except a colon(:).
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Enter the name of
the document in
the Save Current
Document As text
box, or accept
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You can save a file to a hard drive, floppy drive, network drive, and so on;
available drives are shown when you click the Desktop Button in the Save As
dialog box. Finally, in the Save File as Type box, you can select a format other
than Word in case you want to use the file in another application, such as
WordPerfect, Ami Pro, or Word for Windows.
To save a document, follow these steps:
1. Open the File menu and choose the Save As command. The Save As
dialog box appears.

2. Select the drive, folder, and file type, if you do not want to save with
Word's defaults.
3. Enter the name of the file in the File Name text box, or accept Word's
suggested file name.
4. Click OK to save the document.

II

Tip
You also can
customize
settings for
saving your
documents.
See Chapter 8,
"Customizing
Word,"
for more
information.

Saving Changes to a Named Document
After you have saved your document by assigning it a name and location on
the disk, you can continue to work on it. The changes you make are not
saved, however, unless you tell Word to save them. You do not have torename the document file to save changes; you can simply use the Save command.

After modifying or editing an already-named document, choose Save or press
):C+S. Word saves the changes in a few seconds, and you are ready to proceed.

1!1)
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Saving All

The Save All command saves all open documents. Additionally, using this
command saves any open templates, macros, and AutoText entries. When
you use the Save All command, Word displays a message box, asking you to
confirm that you want to save each open document. If you have not named
a document, Word displays the Save As dialog box.

Opening a Document
To open a saved document in Word, choose the Open command or press
~+0. Word displays the Open dialog box (see fig. 4.8).
Fig. 4.8
Select the file from
the list of files,
and then click OK
to open the
document.

Select a Document:

! ~ P e te

,..I

=Blues Power HD
253952K auallabl e

~

CJ Wilmington Moue
CJ DOWNLOADED MUSIC ITEMS
CJJOB S£RRCH •••••
CJMaclnfo
CJ Mortgage Calculations
CJOdd Stuff

~

(

~(

Open

l

Cancel

(Find File ... )

Eject

( Desktop

(

Help

0

0
0

llst Flies or Type:

IWord Documents

H

I

l
l

neod Onl y
Conflrm Conuerslons

In the Open dialog box, select the file name from the list of files, if you saved
in Word's default folder. Otherwise, you can change the drive and folder, or
even the file type, to access the desired file.

Starting a New Document
You can start a new document at any time by choosing the New command or
by pressing j::C+N. The New dialog box appears, as shown in figure 4.9.
Fig. 4.9
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template on
which you want
to base the new
document.
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The New dialog box lists several templates. A template is a basic document
design, including page size and orientation, font sizes, fonts, tab settings,
page margins, and columns. For more information about templates, see
Chapter 9, ~~working with Large Documents."
The Normal template is Word's default. The Normal template has the following
characteristics:
• Uses an 8 1/2-by-11-inch portrait-oriented page.
• Includes l-inch top and bottom margins and 1 1/4-inch left and right
margins.

....

See "Formatting
Text," p. 108

....

See "Formatting
Paragraphs,"
p. 112

....

See "Formatting
with Styles,"
p. 182

....

See "Using
Template
Wizards,"
p. 190

• Uses Times 12-point body text.
• Supplies three headings: Helvetica 14-point bold, Helvetica 12-point
bold italic, and Times 12-point bold. All three headings are left-aligned
and use single line spacing.
To accept the Normal template, click OK. Word displays a new, blank
document.
Troubleshooting
I wanted to save a file in a different file format, but that format is not listed in the file
types.

You did not install that file converter when you installed Word. See Appendix A,
"Installing Microsoft Office," for more information about installing the file converters.
I opened a document that was created in another file format, and now I want to save it.

Click the Save button in the toolbar or choose the File Save command. Word displays
the Save Format dialog box, in which you can select the correct file format.

From Here ...
In this chapter, you learned to create text in a document and then edit that
text by copying, moving, deleting, and so on. Additionally, you learned to
save the document in Word and then open that document for further editing. For more information about working in the Word application, see the
following chapters:
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• Chapter 5, 11 Formatting Text and Documents," covers how to change
the views of your document; how to format such items as the font, type
size, and style; how to adjust spacing between lines and paragraphs,
indent text, and set tabs; and how to change margins and page
orientation.
• Chapter 6, 11 Proofreading and Printing," covers using the Spelling
Checker and Grammar Checker to proofread your documents, and
provides information about previewing and printing documents.
• Chapter 9, 11 Working with Large Documents," covers formatting with
styles and using template wizards.

Chapter 5

Formatting Text
and Documents
by Peter Durso

II
Many of Word's distinctive features and commands pertain to formatting
documents. Formatting a document includes assigning fonts and font sizes,
adjusting the spacing between lines and paragraphs, aligning text, dividing
text into columns, and setting page margins. Many of these tasks are considered to be part of desktop publhl1ing--<lesigning and formatting a document so
that it is attractive and professional looking. Word provides many desktop
publishing features and commands you can use to enhance your business
documents.
In this chapter, you learn to:
• View the document in the way that best fits the task
• Change font, font size, and format styles
• Adjust line and paragraph spacing
• Set tabs and indents
• Left-align, right-align, center, or justify text
• Create columns and set page margins
• Change page size and orientation
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Word not only supplies methods for improving the look of your documents,
but also makes formatting quick and easy. You can use menu commands and
toolbar buttons to transform an ordinary business document into an eyecatching piece.
This chapter shows you how to format text, paragraphs, and pages, using the
easiest and fastest methods.

Understanding Views
np
No matter what
view or magnification you
use, the insertion point
remains where
it was in the
preceding view.

Word enables you to view your document in a variety of ways. Each viewnormal, outline, page layout, and master document-offers advantages for
text editing, formatting, organizing, and similar tasks. You may prefer one
view, but you also will use the other views while formatting documents. This
section covers the two most commonly used views: normal and page layout.
In addition, Word provides various magnification options for viewing a document. You can magnify the view to 200 percent, for example, or reduce it to
fit the entire page (or even the entire document) on-screen. Finally, you can
remove or display the various screen elements to produce a better view. This
section describes the views and their advantages and disadvantages.

Viewing the Document
..,. See "Previewing
a Document,"
p. 131

The two most common views are normal and page layout. Normal view is
mainly for entering and editing text; page layout view is perfect for formatting the text and page .

..,. See "Outlining
a Document,"

Two other views-outline and master document-are more specialized views.
Outline view is covered in detail in Chapter 9, 11 Working with Large Documents." Master document view is a method of viewing and organizing several
files at one time; this view is not discussed in this book. Finally, print preview
is discussed in detail in Chapter 6, 11 Proofreading and Printing."

p. 176

Normal VIew

II

Normal view, which is the default view in Word, shows the basic document
and text. Although you can view various fonts and font sizes, tabs, indents,
alignments, and so on, you cannot view formatted columns, page margins, or
the appearance of the formatted text on the page (see fig. 5.1).

Understanding Views
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Fig. 5.1
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Normal View button

Use normal view for entering and editing text or for formatting text. Figure
5.1 shows the Normal View button. You Jearn aboul the other view buttons
in the following sections. You can use the view buttons in the horizontal
scroll bar to switch between views quickly.
Page Layout VIew

Page layout view shows how the text, columns, margins, graphics, and other
elements look on the page. Page layout view provides the WYSIWYG (whatyou-see-is-what-you-get) view of your document.
Editing and formatting may be slower in page layout, but you can get a better
idea of how your document looks as you format and when you finish formatting. Figure 5.2 shows the same document as in figure 5.1, but in page layout
view.
To change views by using the View menu, follow these steps:
1. Open the View menu and choose Normal for text editing and entering.
2. Open the View menu and choose the Page Layout command to format

the text and page.
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Hiding Screen Elements
.,. See "Modifying
Viewing
Options,"
p. 159

Tip
To set your own
magnification,
click the down
arrow next to the
Zoom Control
box, and then
select a percentage, or en ter any
number between
10 and 200.

In addition to changing views, you can display or hide the screen elements so
you can see the document design better. Use the View menu to remove the
rulers and toolbars. You also can choose the View Full Screen command to
view a document with nothing b ut the Macintosh Standard Toolbar (with the
Microsoft Office Manager icon to the right) o n-screen with the document.
Figure 5.3 illustrates the full screen view. You can enter and edit text in this
view as well as move pictures and objects. To return to normal or page layout
view, press the esc key or click the Full Screen button .

Magnifying the View
You can change the magn ification of the view to better control how m uch of
your document you see on-screen at any time. Word provides two methods
of changing views: the View Zoom command and the Zoom Control button
in the Standard toolbar.
Figure 5.4 illustrates the who le page view. The docu ment also is in page layo ut view.

Understanding Views
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Fig. 5 .3
Full screen view
enables you to see
your document
with no screen
elements or
obstructio ns.
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Fig. 5.4
You can format
the text and
document at any
view magnification.
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Tip

To change magnifications by using the Zoom dialog box, follow these steps:
1 . Open the View menu and choose the Zoom com mand . The Zoom

dialog box appears.

The Zoom
dialog box
enables you to
view more than
two pages at a
time in page
layout view.
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Tip
The Zoom
dialog box also
offers the Many
Pages option, in
page layout
view only, in
which you click
the monitor
button and
select the number of pages
you want to
view at one
time (1 to 6).

2. In the Zoom To area, select the magnification you want or enter a
percentage in the Percent box.
3. Click OK to close the dialog box.
Troubleshooting
My document is in landscape view, but I cannot see enough of it to edit the text.
Landscape view turns your document 90 degrees so that the page is longer from left
to right than it is from top to bottom. This could cause text at the extreme right or
left margins to disappear from the side of your monitor's viewing area.
Use the Zoom Control button in the Standard toolbar to change the view to Page
Width or Whole Page.

I formatted two columns, but I see only one column on the page.
You are in normal view. Choose the View Page Layout command.

My page is formatted with many fonts, font sizes, and graphics, and screen redraw is
slow.
Choose the View Normal command to view the less-formatted version of the document and speed screen redraw.

Formatting Text
Tip
To display the
Formatting
toolbar, choose
View Toolbars,
select Formatting, and then
click OK.

~

See "Using
Template
Wizards,"

p. 190

Word provides many options for formatting text; you can select a variety of
fonts, sizes, and styles to enhance your documents. In addition, Word provides a Formatting toolbar that makes text formatting easy. Alternatively, you
can use the Font dialog box, which is described later in this section.
You can format text by first selecting the text and then making the formatting changes. Alternatively, you can position the insertion point, make the
formatting changes, and then enter the text. All text entered from that point
on will be formatted according to your specifications until you change the
formatting again.

Changing Font
Font is the typeface of the text. A typeface can, for example, be Helvetica.

The font you choose helps create an impression or set the mood for the document. Suppose that you want to create an informal flyer for a sale. You can
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use a light italic font, such as Brush, Cooper, or Univers italic. A formal, sophisticated font could be Shelley, Old English, or Caston Openface.

.•

Select the font you want to use from the Formatting toolbar's Font pop-up
menu, shown in figure 5.5.
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Fig. 5 .5
Word lists the
most recently used
fonts at the top of
the list so you can
find them quickly.
The rest of the
available fonts are
listed in alphabetical order.
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Chang ing Font Size
Font size is measured in points. Points and picas are typesetter's measurements
used for measuring spacing, line thickness, and so on. There are 12 points to
a pica and 6 picas to an inch; therefore, there are 72 points to an inch.
All text you enter in a new, Normal template document is 12-point Times by
default. You can, of course, change the type size. Use the pop-up Font Size
menu in the Formatting toolbar to select the size you want.
The font sizes available in the Font Size pop-up menu depend on your
printer. If you know that your printer can print a size that is not listed in the
box-126 point, for example-type the number in the Font Size text box and
then press return.

Choosing Font Styles
Type styles, also called type attributes and character formats, are characteristics applied to text. The Formatting toolbar supplies buttons for three type

Tip
When you are
formatting
documents, you
may find it
easier to see the
results of your
changes if you
view the document in page
layout view.
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Tip
Another possibility for formatting
text is to use
Word's styles and
your own to
format the sa me
style of text over
and over. for
more information about styles,
see Chapter 9.

Fig. 5.6
Use the Font dialog
box to perform
many changes at
one time to the
selected text.

styles: Bold, Italic, and Underline. To apply any of these attributes, simply
click the B, I, or U button . You can apply one, two, or all three attributes at
the same time.
Besides these three type styles, Word supplies several effects-including
strikethrough, superscript, subscript, and all caps- in the Font dialog box.

Using the Font Dialog Box
You can use the Format Font command to display the Font dialog box. Use
this dialog box to format the text all at once; fo r example, you can use the
dialog box options to change the font, size, and style of the selected text.
Figure 5.6 shows the Font tab of the Font dialog box.
Font
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Usi ng the Font tab of the Font dialog box, you can select a font and style,
and see the results in the Preview box. You also can choose among more
styles th an in the Formatting toolbar, including single, double, or dotted
underlines and colors. After you select the options you want, click OK to
close the dialog box.

Copying Formats
Word makes formatting text easy with the Format Painter feature, which
enables you to format an entire document quickly and easily.
When you format text-such as a heading, complicated tabs, or indentsand need to forma t other text in the document the same way, you can save
time and energy by copying the formatting of the original text. Suppose that
you formatted a heading as 18-point Univers, bold and italic, center-aligned,
and with 5 points spacing below the head. Rather than select and format

Formatting Text

111

each head in your document separately, you can use the Format Painter to
copy the format to another head.
First, select the formatted text-the text with the format you want to copyand then click the Format Painter button in the Standard toolbar. The pointer
changes to a plus symbol and !-beam (see fig. 5.7). Select the text to be formatted, and that text automatically changes to the copied text format.
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The status bar
explains the next
step in copying the
format of the
selected text.
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Format pointer

Troubleshooting
I have changed the font, font size, font style, and alignment of the selected text, and now
I want to change the text back to its original formatting.

Undo the formatting, using the Undo pop.up menu in the Standard tool bar.
I just formatted some text with the Format Font command, and I want to use the same
formatting for text on the next page of my document .

Select the text, and then choose Edit Repeat or press "'+Y. Word repeats the last
formatting command you used.

Status bar
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Formatting Paragraphs
A large part of formatting a page of text occurs when you format the paragraphs of body text, headings, lists, and so on. When producing an attractive,
professional-looking document, you want to present a unified arrangement of
the text elements. You can accomplish this by specifying line, word, and
paragraph spacing; aligning the text; setting tabs and indents; and specifying
how the text flows on the page.
Note
Word's definition of a paragraph is any amount of text-one character or 10 sentences-ending with a paragraph mark.

Tip
You can enter
text, select it,
and then format it, or you
can specify the
formatting
before you
enter the text.

Word enables you to select a paragraph of text and change its arrangement
by choosing commands or clicking buttons in the Formatting toolbar.
This section shows you how to format paragraphs of text.

Adjusting Spacing
You can use spacing to change the design and readability of your text. For the
most part, Word's default spacing works quite well for most of your documents, but sometimes you may want to apply specific spacing. This section
shows you how to change line and paragraph spacing, and gives you a few
tips on when to adjust spacing.
Line Spacing

Line spacing, also called leading (pron ounced LED-ing), is the space that separates a line of text from the text above and below it. Without line spacing,
uppercase letters, ascenders (the top strokes oft, b, d, and so on), and descenders (the bottom strokes of g, j, y, and so on) in one line would touch
those in the n ext line.
Tip
Never use
different line
spacings in one
documen t, as
in figure 5.8.
Different spacings confuse
the reader and
make the text
hard to read.

Word's default line spacing is single. Word measures spacing in points or in
lines: 10-point text uses approximately 12-point spacing, or one line (single);
12-point text uses 14-point spacing, which is still one line. The "line" spacing
depends on the size of the type. The larger the type size, the greater the line
spacing: 24-point text, for example, would use about 27-point line spacing.
Typesetting guidelines generally call for leading to be about 120 percent of
the point size of the text.
Word enables you to change the line spacing in your text. You can set spacing to single, double, or 1 1/2 lines, or you can set a specific measurement in
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points. Figure 5.8 shows three paragraphs of text with different line spacings.
The top paragraph is Word's default: single spacing, or 12-point text on 14point spacing. The second paragraph is 12 on 16, and the third paragraph is
12 on 20.
Fig. 5.8
Line spacing
affects readabili ty
and page design.
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To set line spacing, follow these steps:
1. Choose the Format Paragraph command . The Paragraph dialog box
appears, as shown in figure 5.9.
Paragraph
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2. Select the Indents and Spacing tab.

.,

Fig. 5.9
The Paragraph
dialog box, with
the Indents and
Spacing tab
displayed. Use the
Spacing area to
control line
spacing.
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3. In the Line Spacing pop-up menu, select the option you want; enter
a value in the At box, if necessary. Th ese options are described in
table 5.1.
4. Click OK to close the dialog box.

Table 5 .1

Line Spacing Options

I

Option

Result

Single

Default line spacing (2 to 5 points larger than text size).

1.5 Lines

Spacing that is one and a half times the size of the text. For 12-point
text, the spacing would be 18 points.

Double

Spacing that is twice the size of the text. For 12-point text, the
spacing would be 24 points.

At Least

Accommo dates larger font sizes within a line of text. In the At box,
enter an amount that Word can use as minimum spacing.

Exactly

Limits Word to a certain amount of spacing, w hich you enter
in the At box.

Multiple

Decreases or increases line spacing by the percentage you enter in
the At box. To increase spacing by 20 percent, for example, enter
1.2; to decrease spacing by 20 percent, enter .8.

Paragraph Spacing
You can add extra space between paragraphs to improve readability in your
documents and to add valuable white space. White space, or areas of a page
that contain no text or graphics, provides rest for the reader's eyes and prevents the page from being too crowded. Readability often is improved when
you add space between paragraphs.
Use extra paragraph spacing instead of a first-line indent when you use leftaligned body text, as shown in figure 5.10. The reader's eyes can find the
beginning of a paragraph easily without the indent. You also can add more
spacing after headings or subheadings, between items in a list, within tables,
and in outlines.
To add extra paragraph spacing, follow these steps:
1. Choose the Format Paragraph command. The Paragraph dialog box

appears (refer to fig. 5.9).
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2 . Select the Indents and Spacing tab.

3. In the Spacing area, enter a value in the Before box, the After box,
or in both boxes. You can en ter the measurement in either lines (li)
or points (pt).
4. Click OK to close the dialog box.

AJ1 recordings are dtgitally cleaned up and recorded onto the recital
tape IIIith coosis1eot volume levels from son8 to song. I compensate
for the differences in timbre and volume that exist m the original
material when the Recital is recorded from CO's. old records, and
tapes from who knows where!

Fig. 5.10
Extra spacing
makes the
begin ni ng of each
paragraph easy to
fi nd and provides
valuable white
space.

My goal is to eliminate the need for constant adjUSimentlto the
sound or the program by the tape oper.~tor at the performance.

II

After a rehearsal and/or a sound check volume levels Will be
basically sel There lllill be no need to jump at the sound board to
tame down a sudden blast of Hip-Hop following a delicate Lyncal
ballad, nor will it be necessary to 'crank it up• when a rousing Rock
number follows a latd back 8allet performance.
Shuftling the order of the dance pteces and/or refinement! or
recordmgs (EQ, Aural Exciter, BBE Enbancemenl Digttal Echo or
Reverb) for reasons ofsound quality and/or arbstic intent are
included in the above package.

Setting Tabs
You can set tabs in a document by using either the Tabs dialog box or the
ruler. This section describes using the ruler to set tabs because it is a quick
and easy method for the task. The ruler also is handy for other kinds of paragraph for matting, such as indenting text and changing margins.
If you want to use leaders (pronounced feed-ers) with your tabs, first choose
Format Tabs, and then select tab position, align ment, and leader options in
the Tabs dialog box. Sometimes, items in a list, such as a product name typed
at the left of the page, and the product's price typed at the right of the page,
can appear unconnected without some visual help. The different options
presented for leaders will l ead the eye from left to right across the page. This
can make it much easier to scan the list to find a particular product and its
associated price, or vice versa.

Tip
When you position the insertion point in
any paragraph of
text, tab and
indent settings
for that pa ra·
graph appear in
the ruler.
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Note
Whether you use the ruler or the Tabs dialog box, you can select the text and then
set the tabs, or set the tabs and then enter the text.

To use the ruler to set tabs in your text, first choose the tab alignment. The
horizontal ruler contains a Tab alignment button, shown in figure 5.11 . Click
the Tab alignment button until the type of tab you want appears. Then click
the place in the ruler where you want to set the tab.
Fig. 5 .11
Click the ruler to
set a tab; drag a
tab in the ruler to
reposition the tab.

You can reposition any tab in the ruler by clicking and dragging it to a new
location. To remove a tab, drag it off the ruler.

Indenting Text
You can use the ruler or the Paragraph dialog box to set indents for text.
Using the ruler, you can indent the left side, the right side, or only the first
line of a paragraph. Figure 5.12 shows indents for selected text.
Word also supplies an Increase Indent and a Decrease Indent button in the
Formatting toolbar. Each time you click one of these buttons, you increase
an indent of the selected text to the next tab stop or decrease the indent
to the preceding tab stop. (You can set the tab stops or use the default halfinch tabs. )
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Fig. 5.12
Word supplies a
dotted guideline
to help you align
indents and tabs
when using the
ruler.

Left-~~~~~~~~~~~~~~~~~~~~~~~RI~~

indent
marker

II
In addition, you can create a hanging indent, shown in figure 5.13. To create
a hanging indent, position the insertion point in the paragraph, and drag the
left indent marker to the position where you want lines 2, 3, and so on of the
paragraph to begin. Then drag the first-line indent marker to the position
where you wa nt the overhanging line to start.
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Fig. 5 .13
Create a hanging
indent by first
dragging the left
indent marker and
then dragging the
first-line marker
into position.
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Adjusting Alignment
Tip

Alignment is a way of organizing your text. The way you align the text in a

You can select existing text and then
align it, or you can
select an alignment
and then enter the
text.

document makes the text easy to read, decorative, eye-catching, formal and
sophisticated, or casual and flexible. Word enables you to left-align, rightalign, center, or justify the text in your documents.
Figure 5.14 illustrates the four alignments and the corresponding toolbar
buttons.
Troubleshooting
I set the line and paragraph spacing in the Paragraph dialog box, and I don't like the
results. I want to change the line spacing back to the way it was, but I don 't want to
change the paragraph spacing.

Choose the Format Paragraph command, and then select the Indents and Spacing
tab. In the Line Spacing list, select Single. Then click OK to close the dialog box.
I want to see how the tabs or indents are set in a specific paragraph of text.

Position the insertion point in the paragraph, and view the indent and tab markers in
the ruler. (To display the ruler, choose the View Ruler command.)
I justified the text in a paragraph, and now there are large gaps between the words.

Turn on the hyphenation feature by choosing the Tools Hyphenation command and
then selecting Automatically Hyphenate Document. Click OK to close the dialog box.

Left

Center

Fig. 5.14
Align your text so
the reader can
easily follow the
message and so
the page is
attractive.
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Note
When you use justified text, be sure you turn on the hyphenation feature. To do so,
choose Tools Hyphenation. In the Hyphenation dialog box, select Automatically
Hyphenate Document, and then click OK.

Formatting the Page
Formatting the page includes changing page size, orientation, setting margins, and creating columns. The way you format the page depends on the
amount of text, the size and orientation of graphics, the type of document,
and so on. Keep in mind that you wa nt to create an attractive, eye-catching
page of easy-to-read text.
Suppose that you have several drawings of cars to go into an ad with very
little text. You can create the ad in landscape (wide) orientation with l-inch
margins. On the other hand, if your text contains two long lists of items and
no graphics, you can use portrait (tall) orientation with two columns and halfinch margins.
Word's page-formatting commands are flexible and easy to use. You can

change the page to fit your text so that you present the most professionallooking document possible. This section describes page formatting.

Changing Size and Orientation
The size and orientation of the paper you use depends mostly on your
printer. Some printers take 8 1/2 x 11-inch sheets only; others can print
sheets ranging from small envelopes to legal-size paper. Most laser and inkjet
printers can print in either orientation. Check your printer manual before
changing paper size and orientation.
To change page size and orientation, use the Page Setup dialog box. Figure
5.15 shows the Media Size pop-up menu and the Orientation icons in the
Page Setup dialog box.
To change paper size and orientation, follow these steps:
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Fig. 5.15
Choose document
orientation by
selecti ng the
Portrait icon (left)
or the Landscape
icon (right). To
select the proper
Media Size, use
the Media Size
pop-up menu
immediately
above the
Orientation icons.
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1. Open the File menu and choose the Page Setup command. The Page
Setup dialog box appears.

2 . Select a size in the pop-up Media Size list.
Tip

3. In the Orientation area, select the Portrait icon or the Landscape icon.

When you set
margins, Word
applies those
measurements
to all pages in
the document,
unless you
divide your
document into
sections.

4 . Click OK to close the dialog box.

Fig. 5.16
You can change
the margins to
shorten the line
length and to add
valuable white
space.

Setting Margins
You can change the margins of your document from the default settings to
any margin you want. Word's Normal template uses l-inch top and bottom
margins and 1 1/2-inch left and right margins. You can set the margins by
using the Document Layout dialog box, shown in figure 5.16.
To ch ange the margins of your document, follow these steps:
Document Layout
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1. Open the File menu and choose the Document Layout command.

The Document Layout dialog box appears.
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2. Select the Margins tab.
3. Enter measurements in the Top, Bottom, Left, and Right boxes.
4. Click OK to close the dialog box.

Creating Columns
You can divide the page into one, two, three, or more columns to make the
text well organized and easy to read. Documents such as books, magazines,
catalogs, newsletters, brochures, and even advertisements often are divided
into columns. Word makes dividing your documents into columns easy.
Note
Normally, divide an 8 1/2 x 11-inch portrait-oriented page into no more than three
columns; divide the same-size landscape-oriented page into no more than five columns. When you use too many columns on a page, the lines of text become too
short and are hard to read.

II

You divide a document into columns by using the Columns dialog box (see
fig. 5.17). You can select a preset number of columns and designs or enter a
number of columns and each column width, if you prefer. When you enter
your own column width, you must specify spacing, called gutter space, between the columns.
Columns
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If you like, you can add a line between the columns by selecting the Line
Between option. Word even enables you to start a new column at the insertion point by selecting the Start New Column option. Preview your column
choices in the Preview box before accepting or rejecting the changes in the
dialog box.

Fig. 5.17
Use equally wide
columns or, in this
case, m ake one
column wider than
the other for an
interesting effect.
View the result in
the Preview box
before clicking OK.
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Tip
For best results
in creating
columns, use
your judgment
as follows: too
little gutter
space makes the
text in the
columns run
together; too
much space
creates wide
gaps and makes
the text hard to
follow.

To format the columns in your document, follow these steps:
1. Open the Format menu and choose the Columns command. The Columns dialog box appears.

2. In the Presets area, select the number and type of columns you want.
3. Use the other options in the dialog box to customize columns.
4. Click OK to accept the changes and close the dialog box.

Troubleshooting
I created an 8 1/2 x 14-inch document, and now I can't print it.
Check your printer manual. You may have changed the page to a size larger than
your printer can print.

I made my margins narrower than 7/4 inch, and now some of the edges of the text will
not print.
Most printers have a required margin-usually 1/4 or 3/8 inch-because they cannot
print to the edge of the page. Check your printer manual. Make it a habit to allow at
least 3/8 inch of margin space in all your documents.

From Here ...
In this chapter, you learned to format text, paragraphs, and pages by using
Word's commands and toolbars. You now can change the font, font size, and
font style; align text; adjust spacing, indents, and tabs; and set page size, page
orientation, and margins. For more information about creating documents in
Word, see the following chapters:
• Chapter 6, "Proofreading and Printing," covers checking the spelling
and grammar in a document, using the thesaurus, previewing and editing a document in Print Preview, and printing a document.
• Chapter 7, 11 Managing Files," covers using Word's Find File feature to
display summary information; view file information; and preview, sort,
select, and delete files.

Chapter 6

Proofreading
and Printing
by Peter Durso

After you finish entering and editing text, you will want to proofread and
then print your documents. Word supplies three tools that make proofreading easy. You can use Word's Spell Check, Thesaurus, and Grammar Check to
proofread your documents and supply suggestions for improvement.
No matter how long or short a document is, using the Spell Check is well
worth the time it takes. Word quickly reviews the text and alerts you if it
finds a misspelled word. Additionally, you can use Word's Thesaurus to find
alternative words, so that your text is not monotonous and repetitive. Finally,
Word supplies a Grammar Check that critiques your writing and offers suggestions for improvement.
After your document is complete, you can print it. Word has a special Print
Preview mode in which you can view the document and make last minute
changes in the design before printing. Finally, you can print your document
using default settings, or by setting options in Word.
In this chapter, you learn to
• Use the Spell Check
• Use the Thesaurus
• Use the Grammar Check
• Preview a document before you print it
• Print a document

II
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Spell Checking
Tip
You can check the
spelling of the
entire document,
or you can select
text and check
spelling on ly in
the selected text.

Tip
You also can start
the Spell Check by
clicking the Spelling button in the
Standard toolbar.

Word's Spell Check reads text and notifies you when it finds a word that is
not in its working dictionary. The Spelling dialog box shows you the word in
question, suggests a replacement word, and displays a list of other words that
are similar in spelling as additional alternatives.
To solve a spelling problem, you can use a va riety of options. You can change
the word, ignore the word, add the word to the dictionary, and so on. This
section describes each of these options.
Additionally, Word includes a feature called AutoCorrect. Using AutoCorrect,
you can instruct Word to correct spelling mistakes as you make them. If, for
example, you often type teh rather than the, Au toCorrect can fix the error
immediately after you make it, as you continue to type. This section also
discusses how to use the AutoCorrect feature.

Using the Spell Check
The Spell Check looks for words that are not in Word's dictionary. ln addition, it alerts you to punctuation and capitalization problems. You can
choose to change the spelling or ignore the problem; you even can add the
word to the dictionary for later use.
To use Word's Spell Check, open the Tools menu and choose Spelling, or
press ~ +option+L. The Spelling dialog box appears (see fig. 6.1).
-

Fig. 6.1
Select a word in
the Suggestions
box or en ter the
correct word in
the Change To
text box to correct
the mistake in the
text.
.,. See "Changing
Spelling
Options,"
p. 169

Spelling: Enqllsh (US)

Not In Dftlfor.rv- lchlld>
Cllt091T0o

s._u...,

child's

~~
hill'•
hl\d
11\de>

Add W-Io-

lcu.~o.. Dfotl..,r~

0

ltMn

'

c.....

It

Mol

)[

~ (

3

) ( ,, ..,..An )

(

( AIIUCorroct ) ( o,t1ou_ ) ( Uodo Lnt ) (

CN... AII)

c..-1 ) (

~~

)

HeI'

)

The following table describes each option in the Spelling dialog box.

Table 6.1

Spelling Features

Option

Description

Not in Dictionary

Displays the word in question.

Spell Checking

Option

Description

Change To

Suggests an alternative spelling; you can enter your own new
spelling in this text box.

Delete

If the Change To text box is empty, the Change button
becomes Delete, which deletes the word.

Delete All

If the Change To text box is empty, the Change All button
becomes Delete All, which deletes all occurrences of the word in
the document.

Suggestions

Select a word in the Suggestions list box to replace the
misspelled word.

Ignore

Skips this word.

Start

The Ignore button changes to Start when you click outside the
Spelling dialog box to edit your document. The dialog box
remains on-screen; choose the Start button to resume the
spelling check.

Ignore All

Skips all occurrences of this word in the document.

Change

Substitutes the selected or entered word for a misspelled word.

Change All

Substitutes the selected or entered word for all occurrences of
this word in the document.

Add

Updates the dictionary to include a word that you often type.
The added word must appear in the Not in Dictionary text box.

Suggest

If the Always Suggest option in the Options dialog box is
deactivated, choose Suggest to list suggestions for correcting
the misspelled word.

Add Words To

If you installed more than one dictionary, select the dictionary
to which you want to add from the pop-up list.

AutoCorrect

Adds frequently misspelled words to the AutoCorrect list.
See the following section, "Using AutoCorrect," for more
information.

Options

Enables you to choose default settings or customize the Spell
check. For more information on spelling options, see Chapter 8,
"Customizing Word."

Undo Last

Choose Undo Last to change your mind about the last spelling
change.

Close/Cancel

Cancel ends the spelling check and cancels any changes; Close
ends the spelling check and saves any changes. The Cancel
button changes to Close after you make a change in the
document.

Help

Choose this button for detailed help on the Spelling dialog box
options.
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Using AutoCorrect
The AutoCorrect feature automatically corrects spelling mistakes and formatting errors, or replaces characters you enter with specific words or phrases.
Using this feature saves you time. Suppose that you consistently type
anohter instead of another or WHen instead of When. You can enter
these common mistakes into AutoCorrect, and the next time you make the
mistake, Word corrects it automatically.
To set options and make entries for AutoCorrect, choose the Tools
AutoCorrect command. Figure 6.2 shows the AutoCorrect dialog box
with a new entry.
Fig. 6 .2
You can add
shortcuts to the
AutoCorrect entry
list. For example,
enter two letters to
represent a name
or company name
that you often
type.
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The AutoCorrect dialog box lists five options-including converting quote
marks and correcting capitalization problems-that you can choose to turn
on or off. The Replace and With text boxes enable you to enter your own
items, and the list at the bottom of the AutoCorrect dialog box displays
Word's default list plus any items you add. You can add or delete items at
any time. For related information, see Chapter 8, "Customizing Word."
To use the AutoCorrect feature, follow these steps:
1. Open the Tools menu and choose AutoCorrect. The AutoCorrect dialog

box appears.
2. Select the options you want to use.
3. If you enter items in the Replace and With text boxes, choose Add to

add them to the list. To remove an entry from the list, highlight the
item in the list box, and then choose Delete.
4. Click OK to close the dialog box.

Using the Thesaurus
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Troubleshooting
I have a lot of words that contain numbers, such as measurements, in my document, and
I want Word to ignore those words.

Open the Tools menu and choose the Options command and then select the Spelling tab. In the Ignore area, select Words with Numbers. Click OK to close the dialog
box.
I want to edit some of the words in a custom dictionary.

Open the Tools menu and choose the Options command; then select the Spelling
tab. In the dictionaries area, select the dictionary you want to modify, and then
choose the Edit button.
I want to add an AutoCorrect entry without opening the Spell check.

Open the Tools menu and choose the AutoCorrect command. In the Replace text
box, type the misspelled word. In the With text box, type the correct spelling of the
word. Click OK to close the dialog box.

Using the Thesaurus
The Thesaurus supplies a variety of synonyms you can use to replace the
word you are looking up. To use the Thesaurus, position the insertion point
in the word you want to look up, and choose the Tools Thesaurus command
(or press ):(+option+R). Word automatically highlights the word, and the
Thesaurus dialog box appears.
Suppose that you want to find a synonym for the word under. Using the
words in the Meanings list box, you can look up either below or obedient to
(see fig. 6.3). Selecting a word in the Meanings list on the left displays several
synonyms in the Replace with Synonym list on the right. The synonyms
shown in the Replace with Synonym list reflect the various shades of meaning that each word in the Meanings column has in the same context as the
word that was looked up. This is where a Thesaurus helps you to fine-tune
your message. Additionally, you can look up new words, either related to the
original word or not, or go back to a word you looked up earlier. If you want
to look up a word that is different from the original word, position the insertion point in the Replace with Synonym text box, type a new word, and then
choose Look Up.

•
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Fig. 6 .3
Replace the
selected word
with any of the
displayed synonyms, or
continue to look
up words until you
find the correct
meaning.
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The following table describes the options in the Thesaurus dialog box.

Table 6 .2

Thesaurus Features

Option

Description

Looked Up/Not Found

A pop-up list of all the words you have looked up
since you opened the Thesaurus dialog box; the list
disappears when you close the dialog box. The text
box name changes to Not Found if the currently
selected word is not in the Thesaurus.

Meanings/Alphabetical List

Definition and part of speech of selected word;
selecting a different meaning results in a new list of
synonyms. Alphabetical List appears if the word is not
in the Thesaurus.

Replace with Synonym

The word in the text box is the selected word that you
can Look Up or Replace when you choose either of
those command buttons. The list of words below the
text box is a list of synonyms you can select.

Replace with Antonym

If Antonyms is available in the Meanings list box, you
can highlight it and then select an antonym from this
list box.

Replace

Choose this button to substitute the selected word (in
the Replace with Synonym text box) for the original
word in the text.

Look Up

Displays meanings and synonyms fo r the selected
word (in the Replace with Synonym text box).

Cancel

Closes the dialog box.

Previous

Displays the last word you looked up. Works only in
the current Thesaurus dialog box.

To use the Thesaurus, follow these steps:

Checking Grammar
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1. Position the insertion point in the word you want to look up.
2. Open the Tools menu and choose the Thesaurus command. Word automatically highlights the word, and the Thesaurus dialog box appears.

3. In the Meanings list, select the meaning you want.
4. In the Replace with Synonym list, select the word you want to use as a

replacement.
5. Choose Replace to close the dialog box and substitute the new word for
the old one, or choose Cancel to close the dialog box without replacing
the word.

Troubleshooting
/looked up several meanings, and now I want to go back to the original word /looked up
in the Thesaurus.

Choose Looked Up or click the down arrow to the right of that option. A pop-up list
of the words you looked up during this session appears. Select the original word.
I want to go back to the last word /looked up.

Choose the Previous command button.

Checking Grammar
If you have problems with your writing, Word may be able to help you.
Word's Grammar Check reviews text in your document and reports possible
problems, such as passive verbs, pronoun errors, punctuation errors, jargon,
and double negatives. You can review the error and suggestion, and then
decide whether to change the text. You even can ask for a further explanation of the grammar rule.

To check the grammar in a document, open the Tools menu and choose the
Grammar command. The Grammar dialog box appears (see fig. 6.4).
When the Grammar Check finds an error, it displays the Grammar dialog box
that indicates the problem discovered during the check. If it doesn't find any
problems, the dialog box does not appear. The Grammar Check also checks
spelling, so you may see the Spelling dialog box first if the check finds an
unfamiliar word.

Tip
Double-click a
synonym or meaning to display
more synonyms.
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Fig. 6.4

Grammar: English (US)

You can choose to
ignore or change
the problem,
ignore the rule for
this document,
or ask for an
explanation of
the problem.

Tip
You can set grammar rules and
styles by using the
Customize Grammar Settings dialog box. For more
information, see
Chapter 8, "Customizing Word."
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See "Customizing Options,"
p. 1S6
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Note
You must read the suggestions carefully. You may find that the suggestion is not
valid and that the problem, as the Grammar Check sees it, is not really a problem.

The following table describes the options in the Grammar dialog box.

Table 6.3 Grammar Features
Option

Explanation

Sentence

The sentence in question appears in this text box, where you can
edit the sentence.

Suggestions

Word defines the p roblem and may suggest alternative solutions.

Ignore

Choose this command button if you want to ignore the
problem.

Next Sentence

Moves to the next grammar problem, ignoring the current one.

Change

Changes the sentence if an alternative suggestion was made in
the Suggestions box.

Ignore Rule

Choose this button if you want to ignore a specific rule for the
rest of the document.

Cancel/Close

Cancel closes the dialog box without making a change; after you
make a change, the Cancel button changes to Close. Choose
Close to return to your document.

Explain

Displays a message box that further explains the rule and often
offers examples (see fig. 6.5).

Options

Enables you to customize rules and style for the Grammar Check.
For more information, see Chapter 8, "Customizing Word."

Undo Last

Choose this button if you change your mind about the last
grammar change you made.

Previewing a Document
Option

Explanation

Help

Choose this button for more information about the Grammar
dialog box.

Start

Appears in place of the Ignore command button when you click
the document. The Grammar dialog box remains on-screen
while you edit your document; choose Start to continue the
grammar check.
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Ch oose Explain to
learn more about
the grammar rule
in question;
d ouble-click the
Control-menu
box to close the
message box.

Troubleshooting
I don't want to check the spelling at the same time I check the grammar.

Open the Tools menu and choose the Options command, and then select the
Grammar tab. Click the Check Spelling option to deactivate it. Then click OK.
I changed my mind about the last change I applied in the Grammar dialog box.

Choose the Undo Last button in the dialog box.

Tip

Previewing a Document
After you enter, edit, format, and proofread your text, you are ready to print
your document. Sometimes, when you format a page of text in normal view,
problems are revealed when you print the document. The margins may be
too wide, a headline may break in an odd place, a paragraph may be indented
by mistake, and so on. You can save time, effort, and paper if you view your
document in Print Preview before you print it by opening the File menu and
choosing Print Preview. Of course, you can certainly go directly to the Print
command if you desire. For more information, see "Printing a Document"
later in this chapter.

You can edit and
format your document in Print
Preview, just as
you can in page
layout or n ormal
view. Use the
menus and commands, or d isplay
any of the toolbars
to use as shortcuts.

II
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.,.. See "Printing
Documents,"

p.

7S

Figure 6.6, which shows a document in Print Preview, reveals a problem with
graphic lines that are too short to extend from the left edge of the body text
to the right edge. You can quickly fix the problem in this view before you
print; drag the ma~gin markers in the rulers to set new margins for the lines
and the text.

Fig. 6.6
Drag the left and
right margin
markers (in the
horizontal ruler)
or the top and
bottom margins
(in the vertical
ruler).
Varying
margins
=S:eti.~~~-=:i
-~-=-=··_,,_

__,.. . :

.::::-----......

I
I
I

:

,__~
~~~\:'~!
:.:t:=-:...::~-=-::.."':7.:.-. :
I

Margin guideline

Using the Rulers
By default, Word does not display the rulers in Print Preview (File menu). You
can, however, choose the View Rulers command to display both the horizontal and vertical rulers. Use the rulers as you would in any other view: set tabs,
adjust indents, and change the margins.
Tip
The default view in
Print Preview is a
view of the whole
page, which is best
for adjusting m ar·
gins.

To adjust the margins by using the ruler, position the insertion point at the
point you want to change. Any margin changes occur from the insertion
point on; so if you want to change margins in the entire page, position the
insertion point at the top of the page.
Move the mouse pointer over the margin marker on the ruler until you see
the double-headed arrow (at the point where the white ruler meets the gray
arrow). Click and drag the arrow left or right (in the horizontal ruler) or up or
down (in the vertical ruler) to change the margin. A dotted guideline appears
across the page as you drag the margin; use the guideline to align elements
on the page.

Previewing a Document
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Using the Preview Toolbar

Tip

Print Preview includes a special tool bar you can use to edit your document.
The Preview toolbar works in much the same way as the other toolbars. You
can place the mouse pointer on a toolbar button to view the TooiTip and the
description of the button in the status bar.

Choose Undo immediately to reverse the
Shrink to Fit operation. Because the
Print Preview toolbar
does not include an
Undo button, you
must open the Edi t
file and choose Undo.

You can use a toolbar button to print your document, view one page or multiple pages, display or hide the ruler, view the full screen (without screen
elements such as the title bar, scroll bars, and so on), exit Print Preview, and
get help on a specific topic. Two toolbar buttons are particularly useful:
Shrink to Fit and the Magnifier.
The Shrink to Fit button adjusts elements in a document, such as line and
paragraph spacing and ma rgins, so you can fit a little bit more on the page.
Suppose that your document fills one page, and one or two sentences overflow to a second page. Try clicking the Shrink to Fit button to squeeze all the
text onto the first page.
The Magnifier enables you to toggle between the normal mouse pointer and
the magnifier pointer. When the magnifier pointer contains a plus sign (+),
you can magnify the document up to 100 percent. When the magnifier
pointer contains a minus sign(-), as shown in figure 6.7, clicking the page
reduces the view to whole page view (32 percent). To change the magnifier
pointer back to the normal pointer, click the Magnifier button again.

...

File Ed II

Ulew

Inse rt Format

Tools Tobie

Window

8:55 PM ~

FDH

\21

[jJ I!IDil ~aID~ !m1 I a- I~ I
SS PRICES(7/94)W6 (Proulew)

[!J • • • I
Iii.

• • •

• • • I • • • I • • o I • • •

2• •

o

I • o •

3 •• •

I o o o <II o • • I o • •

$ • •

o

I • • o

o • •

I • • •

1•

..

•
:!

Sta rStru ck Sou nd La be
Wh a t W e Ca n Do For You

-

, . , . &11

N

t ) Pun Strme A.mmbl)(T'lvl31or· (,OUt- rectlll orpocW\t '>t>O). lro:hld":
COruuht.don, ~mbtu. e.rd Reeotd.lrlt of mmic ont) the Recital Tepe

f\1s1 6 fev .SUCC~ du:rlpt~lDS of Yb!t f CU c10 fOC )CU.:

AD

-

-mmc•.,. 4J(tlllbl clt&oo4 op

~~~~~~-~~~•

••., 1be nc:tlllepe vth

c:onsb1rnt votwm knb tmm Xlfl( a 30DC. J compema• for 1be 4.Utertoca in d:nlmJ mt.
.-al'az:l:le 1batemttn tbe od(bl:ma.•·tbJ. Ybl.n 1he Rtdtal b acord.td tromCD's, ol1
nt:CJJU, m! 1lpU from who klows vbtrel

"

M7ccelb Ottimtta• U:le'Det4 !orCOII:S'U.IIdfwtmentiO dll XI'G!!Id. 0(4:e

procam b., the • .,. opeabr a.t 1!lt pei!orme.ra.

-

fa

A!teranhemtlm1Jor&JOand ebeckwlume2ftb vm be btsbily set Tbm:
'WiD be no netd.D jump&t tht JOWlld. board t:1 tllm!! 4ovnasu:1~en b~torHip-Hop
!ollovtnc a~elic&.tl L)'tbl be.lal. nor vW.hbe Dtte'~ l:l •cran)c. Uup• YhenamusJnc

.

¥

Rock nwnber ronow •leJd bec:k De.llel pnfonnaru.

-

S'hamtac tht order or ttlt: dance pie:ets an1/or reJwmenu ot ncomtnc, (EQ. Aural
·GI~

[ r>ot-2

i.!_

Sto_L

21~,

{;\Lt:..__.JaJ

.coL

LHL¥L ~a~~~liBlirFjiii ~:"

••

II

ITII

Fig. 6.7
Reduce a specific
area of th e
document by
clicking the
pointer on that
area.
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Using the Print button on the Preview toolbar prints the document using the
default options in the Print dialog box. If you want to make changes to any
printing options, see the following section, "Printing a Document."
Troubleshooting
I have a 20-page document, but I want to print only the page(s) that I have worked on.
Enter the From and To page numbers where they are asked for in the Print dialog. If
you only want to print one page, simply put the same page number in each box.

I have trouble setting the margins for the document with the ruler in Print Preview.
Choose the File Page Setup command, and select the Margins tab.

Printing a Document
..,.. See "Customizing Printing,"
p. 162

When you print from Word, you generally use the default settings for the last
printer that you used. You can, however, change these defaults in the Print
dialog box. Most often, however, you will print with the default options in
the Print dialog box.
The default options print one copy of all the pages in the document.
Figure 6.8 shows the Print dialog box.

Fig. 6.8
To print using the
default options in
the Print dialog
box, click OK.

DeslcWrlter "DeslcWriter"
Quality:
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Table 6.4 describes the options in the Print dialog box.

Word Help )
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Table 6.4 Print Features
Option

Description

Print pop-up menu

Specify what to print: the document, summary sheet, a
list of styles, key assignments, annotations, o r auto text
assignments associated with the document.

Copies

Enter the number of copies to be printed.

Pages

Select All to print all pages in a document, or Enter a page
range in the From and To boxes to print a selected range
of pages.

All Pages In Range

Select text in the document you want p rinted. Before
choosing the Print command, select the Print Selection
Only box.

Print

Specify which pages to print: all pages, even pages, or
odd pages in the page range.

Collate Copies

Select this option to print copies in order. Print pages 1 to
5 in the first copy, for example, before printing pages 1 to
5 in the second copy.

Options

Choose this button to customize printing options. For
more information, see Chapter 8, "Customizing Word."

Help

Choose this button for more information about printing
options.

Cancel

Choose this button to cancel all changes and close the
dialog box without printing the document.

OK

Choose this button to send the selected pages to the
printer.

Troubleshooting
I created a form, and I want to print the data in my form without printing the table lines
and fill.

Choose the Word Options button in the Print dialog box. In the Print tab, select Print
Data Only for Forms.
I want to change to a different printer before printing a document.

In the Chooser, select a different prin ter before you elect to Print.

II
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Printing Envelopes
~

See "Modifying User
Info," p. 165

You can print envelopes in Word quickly and easily by opening the Tools
menu and c hoosing the Envelopes and Labels command. Word makes it easy
to enter the d elivery and return addresses, choose an e nvelope size and
method of feed, and then print an envelope. This information will run by
default, but can be changed easily.
Figure 6.9 shows the Envelopes and Labels dialog box.
£nuelopes and labels

Fig. 6.9
Eaver.,..

Enter the delivery
and return
addresses, and
then click OK to
print the envelope.

Ltbol$

(

Oellveri)Addr...

Prhl

I

( -t•Doc•..•t l

I

I

(
(
(

CaKal

o,u.....

""'•

·-

l
l
l

~...·-. . . .~~-····:··"""' ~
1- "I ~

~

P.J. Dur30

'WIIiM pr~ bV

~

See "Customizing Options, "
p. 156

tht pr-httr. Ntd-. f'fYVtloft tt \IOII'l ~ttr•s~Nt~~M1 ''""'

Table 6.5 describes the options in the Envelopes and Labels dialog box.

Table 6 .5

Envelopes and Labels Features

Option

Description

Delivery Address

Enter the name and address to whom the envelope
will be mailed.

Return Address

Enter your name and address.

Omit

Choose this option to exclude the return address.

Preview

Click the envelope in the Preview box to display the
Envelope Optio ns dialog box (Envelope Options tab).
Select the size, bar code, placement, and font for the
addresses in this dialog box.

Feed

Click the Feed box to display the Envelope Options dialog
box and the Printing Options tab. Select the method of
feeding envelopes that best fits your printer.

Options

Displays the Envelope Options dialog box.

Add to Document

Adds the envelope style and contents to the document so
you can save it for later use.

From Here...
Option

Description

Help

Choose this button to see more information about the
dialog box and envelope options.

Print

Choose this button to send the envelope to the printer.

Cancel

Choose this button to cancel your choices and close the
dialog box without printing the envelope.

To print an envelope in Word, follow these steps:
1. Insert an envelope into the printer.
2. Open the Tools menu and choose the Envelopes and Labels command.
The Envelopes and Labels dialog box appears.

3. Select the Envelopes tab.
4. Enter a Delivery Address and Return Address.

5. Select envelope and feed options, if necessary.
6. Click OK.

From Here ...
After your document is complete, you can print it. Use Word's Print Preview
feature to view the document and make last-minute changes in the design
before you print it. Then print your document by using Windows defaults or
by setting options in Word.
For more information about working in Word, see the following chapters:
• Chapter 7, ''Managing Files," covers creating summary information for
your documents. It also includes information about Find File, ways of
viewing file information, how to organize and search for specific files or
documents, and how to sort and select files.
• Chapter 8, "Customizing Word," covers options that you can change or
modify to better suit your working style, including options for viewing,
printing, saving, spelling, and grammar.
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Chapter 7

Managing Files
by Peter Durso

After you work with any program for a significant amount of time, the files
you saved start piling up. Locating the file you need in a disk that contains
tens, hundreds, even thousands of files becomes harder and harder. All you
want to do is to open, edit, and print one letter you wrote last week, but you
cannot find it. Word supplies a file manager that you can use to search for
and find files.
In addition to the never-ending file search, you need to clean your disk
periodically by copying some files to floppies and perhaps deleting others.
Instead of using the Macintosh File Find Utility, you can use Word's File
Manager called Find File to copy, delete, sort, and print files.
In this chapter, you learn to
• Create records to help identify and sort document files by title,
keywords, author, and other criteria
• Set and save search criteria for finding files
• Find any file by using different types of information
• Select one or more files
• Copy files to other drives and folders
• Delete one or more files without leaving Word

II
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Creating Summary Info Records
..,. See "Changing
Save Options,"
p. 167

A Summary Info record helps you keep track of your documents. Suppose that
you type 20 letters each day: letters to advertisers, clients, employees, and
others. When you need to look up one specific letter or a group of related
letters, how can you find it? Summary Info records help you organize, manage, and find the documents you need quickly and easily.

Note
You also can organize your files by folder OANUARY, FEBRUARY, MARCH), and by file
name (LETTER TO SMITH, LffiER TO JONES, LffiER TO ROBIN).

Summary information includes the document's title, subject, author, any
keywords that would help identify the document, and comments about the
document. You can use any or all of these supplied categories.

Tip
To determine
whether Word
automatically
prompts you for
summary information, use the Tools
menu.

Fig. 7 .1
Use the Summary
Info dialog box to
enter information
about your
document. You
can enter text in
any or all of the
text boxes.

One of the best uses for Summary Info records is Find File, a file-management
program included with Word. This program enables you to search for files by
using any of the data you enter as summary information. For more information about this program, see "Using Find File" later in this chapter.

Displaying Summary Info
Word's default is to prompt for summary information each time you save a
document by choosing Save As. To display the Summary Info dialog box,
open the File menu and choose Save As. Name a document, and click OK to
close the dialog box. Word displays the Summary Info dialog box (see fig.
7.1). Alternatively, you can choose the File Summary Info command to display the dialog box any time you are working on a document.
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Entering Summary Info
In the Summary Info dialog box, enter any text that will help you recognize
the document later. Suppose that you write a letter to a client named David
Walkup. You quote six hours of consulting for installation of a peer-to-peer
network to four computers. This is the third quote on the same subject, but
with different configurations.
Because you already have two other letters dealing with this client and this
same consulting job, use Summary Info records to help distinguish this letter
from the others. figure 7.2 shows a suggested Summary Info dialog box for
this letter to David Walkup.
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Viewing Statistics
Withi n the Summary Info dialog box is a button labeled Statistics. When you
choose this button , Word displays information about your documen t, including its location, creation and last-saved date, file size, total editing time, and
so on. Review this information when you want to know more about a file or
document. figure 7.3 shows the Document Statistics dialog box.
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Fig. 7 .2
When entering
summary information, use keywords,
a title, comments,
and other items
you will easily
recognize months
from now when
doing an Advanced Search
under Word Find
File.

Fig. 7 .3
View Document
Statistics when you
need to know the
last-saved or lastprinted date, the
number of pages or
words, or even the
template used for a
document.
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Note
..,. See "Printing a
Document,"
p. 134

You can print the summary information by opening the File menu, choosing the Print
command and clicking the Word Options button.

Troubleshooting
I didn't enter a title in the Summary Info dialog box, but Word shows a title.

Word displays the first several words of a document as a title unless you create your
own title. To create a title, choose the File Summary Info command . In the Title box,
enter the proper title. Then click OK to close the dialog box.
I want to add several keywords, but I'm not sure how many Word accepts.

Word accepts a maximum 255 characters in each of the Summary Info text boxes.

Using Find File
To locate specific files, Find File enables you to search folders on your
computer's hard drive, network drives, floppy drives, and so on. You can
search for a file with a particular creation date, author, type of summary information, or other search criteria.
In addition, Find File enables you to select, copy, delete, and sort files. You
even can view a document before opening it to make sure that the file is the
right one. This section shows you how to use Find File. You' ll find more information on this subject later in this chapter in "Viewing Files" and "Working in Find File."
Caution
Any time you choose to delete a file or files, make su re that you are deleting the
correct files! Use Find File features to help you distinguish the files you want to delete
from the ones you want to keep. Additionally, Word displays a confirmation box
when you attempt to delete a file or files. Choose Yes to delete the selected file(s);
choose No to cancel the command.

Locating Files
Find File is a mini-program within Word that enables you to find and manage files. When you choose Find File under the File menu and then click the

Using Find File
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Search button, Word displays the Search dialog box that enables you to designate search criteria. Search criteria can include the following:
• Location of file, such as the drive, folder, or file type.
• Summary information, such as the title, author, keywords, and subject.
• Timestamp for last date and time saved or created, and by whom.
You must specify search criteria in order to use Find File. After you specify
search criteria the first time, Find File uses the same criteria the next time you
open Find File. You then can change the criteria, if you want. Figure 7.4
shows the Search dialog box.
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Search Criteria
Table 7.1 describes the options in the Search dialog box.

Table 7.1

Search Dialog Box Options

Option

Description

Saved Searches

After selecting the search criteria, save them for quick
reference and later use. You also can delete or modify the
saved search criteria.

Save Search As

Choose this button to enter a name for the defined search
criteria. You can create search criteria that display the
folder (Word Documents, for example) and save the
criteria as a saved search. The next time you want to
search the folder, you can select it in a list instead of
describing it in the Search dialog box.

Delete Search

Erases the saved search criteria. Since no criteria are saved
in the example, this button is grayed out.
(continues)
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Table 7.1

Continued

Option

Description

File Name

In the Search For area, type the name of the file.

File Type

Here you can narrow the search down to specific text file
types, such as the different Word file types that might be
on a networked volume or text only files.

Location

Select the drive for the search in this pop-up menu list.

Rebuild File List

Replaces previously found files with files that meet the
new search criteria.

Clear

Removes the preceding search criteria from the text
boxes.

Advanced Search

Choose this button to set more specific search criteria. For
details, see the following section, "Advanced Search
Criteria."

To search for a file using location criteria, follow these steps:
1. Open the File menu and choose the Find File command. The Search
dialog box appears if there were no previous search criteria. If the Find
File dialog box appears, click the Search button to display the Search
dialog box.
2. In the File Name field, enter the file name.

3. In the File Type pop-up menu, select the text file type to search for.
4. In the Location pop-up menu, select the drive name.

5. Choose the Save Search As button. The Save Search As dialog box
appears (see fig. 7.5).
Fig. 7.5
Use this dialog
box to save the
search criteria for
later use. This
example search
will be saved
under the name
Job Search.
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6. Click OK to close the Save Search As dialog box and return to the Search
dialog box. Figure 7.6 shows sample search criteria in the Search dialog box.
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Fig. 7.6
Enter the search
criteria and click
OK to close the
dialog box and
display Find File.

l
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7. Click OK to close the dialog box. The Find File dialog box appears. For

further instructions on using Find File, see "Viewing Files" later in this
chapter.
Advanced Search Criteria
You can specify additional or different search criteria before closing the
Search dialog box by choosing the Advanced Search button. In the Advanced
Search dialog box, you can specify location, summary info, or time-stamp
criteria for use in your search.

II

Caution
The more search criteria you use, the longer it takes Find File to complete the search.
On the other hand, the more search criteria, the more accurate the search.

Figure 7.7 shows the Advanced Search dialog box, which has three tabs. Select
the Location tab.
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Use the Location
tab to select the
drive, folder, and
even subfolders
for the search.
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Figure 7.8 shows the Summary tab. Enter any or all of the information
used in the Summary Info sheet for the specific document or a group of
documents. Enter only the author's name, for example, to search for all
documents created by that author, or narrow the search by entering the
author's name, the title, and the subject.

Fig. 7.8
For very specific
searches, enter
search criteria in
the Summary tab
as well as the
Location and
Timestamp tab.
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Pattern Matching enables you to establish special
operators and expressions for the text search

Note
You must use the exact wording and spelling you entered in the Summary Info sheet
for such categories as Subject, Author, and Title. Otherwise, Find File cannot match
the correct Summary Info.

Figure 7.9 shows the Timestamp tab. If you know the approxi mate date and/
or time the file was last saved or created, you can en ter the information in
this tab as search criteria.
Fig. 7.9
Enter a range of
dates-such as
From 8-9-94 To
9-21-94-and,
optio nally, the
author's name as
additional search
criteria.
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Note
To use a saved search, select it in the Saved Searches pop-up menu list in the Search
dialog box. If you want to change any of the search criteria in the saved search,
select any of the search options a nd then choose the Rebuild File List command.
Choose the Save Search As command if you want to save the new list.

Troubleshooting
I'm having trouble locating a specific file with the search criteria I chose.

Widen the search. If your search criteria are too narrow, you may not have included
enoug h information for Find File to target the correct file. Try searching two or three
subfolders, or include subfolders in the search.
I want to search for specific text within a document, such as computer programming.

Choose the Advanced Search button in the Search dialog box, and select the Summary tab. In the Containing Text box, enter the text for which you are searching.
You also can use wild cards in your search, such as a question mark-for this example, you could enter computer ?. Using this wild card includes in the search such
phrases as computer programming and computer software, but not personal computer.

Tip
A wild card in
a computer
search means
that anything
in the position
occupied by the
wild card is
valid if the rest
of the requirements of the
search are met.

Viewing Files
After you enter the search criteria in the Search dialog box and click OK to
begin the search, the Find File dialog box appears, displaying a list of files
described by the search criteria. Figure 7.10 shows the Find File dialog box in
preview view.

Fig. 7.10
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Tip
To change
views in Find
File at any
time, select a
different view
in the View
drop-down list.

Tip
You can select
several files in
the Listed Files
box and then
print, delete, or
copy those files
by selecting a
command in
the Commands
pop-up menu
list.

Find File provides three modes in which you can view files and file information: preview, file info, and summary. Each view provides specific information about the selected files, and you can change views at any time to get
more information about the files. Additionally, each view uses the same buttons at the bottom of the dialog box. This section describes the buttons, the
three views, and how to make the best use of each view.

Using the Find File Commands
The buttons at the bottom of the Find File dialog box are the same for all
three views. You can choose a command button and perform a command at
any time while in Find File. The following list describes each command button and pop-up menu:
• View. Displays preview, summary, or file info view, each of which uses
file information in a different way.
• Search. Displays the Search dialog box, in which you can specify new

search criteria to display different folders and files.
•

Commands. Displays a pop-up menu containing six commands and

dialogs that you can invoke in any selected file. The commands and
dialogs are as follows:
Open Read Only

Opens a file so you can read it but not edit or modify it
in any way.

Print

Opens the Print dialog box so you can print the
selected file or files. When you click OK to print the file,
Word returns to the document Window, closing Find
File.

Summary

Displays the Summary Info dialog box, in which you
can add or change summary data. When you click OK
to close the Summary Info dialog box, Word returns to
the Find File dialog box.

Delete

Deletes the selected file or files. This command displays
a confirmation box. Choose Yes to delete the selected
file or files; choose No to cancel the request.

Copy

Displays the Copy dialog box, in which you can enter a
location to copy the file to; alternatively, you can create
a new folder to copy to. When you click OK to close the
Copy dialog box, Word returns to the Find File dialog
box.

Sorting

Displays the Options dialog box, in which you can
select various methods of sorting the files in the file list.
When you click OK to close the Options dialog box,
Word returns to the Find File dialog box.

Viewing Files
•
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Open. Opens the selected file.

• Close. Closes the Find File dialog box.
• Help. Displays help information about using Find File.

Using Preview View
Preview view enables you to select a file in the Listed Files list box and view it
in the Preview Of box. The Listed Files list box includes only the drive and
directory or folders specified in the search criteria. You can scroll through the
list of files and select any file to preview.
The Preview Of list box displays the formatted document selected in the list
of files. You can scroll through the previewed document, but you cannot edit
or alter the previewed document.
If the selected file is not a Word document, Find File displays the Convert File
dialog box (see fig. 7.11). Word can convert files from other programs-including Excel, WordPerfect, earlier versions of Word for Macintosh, Word for
DOS, and Word for Windows-by using one of the displayed file filters.
Fig. 7.11
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Select the file filter
to convert the
file to a Word
document so you
can preview and/
or open the
document in
Word.

Using File Info View
File Info View lists information about the specified files in the search criteria,
including the file name, size, and last-saved date. Figure 7.12 shows the file
info view of the JOB SEARCH RESUMES******* Folder.
The following list describes the information displayed in File Info View:
• File Name. Lists the drive, folder name, and file names that fit the search

criteria.
• Size. Lists the file size in thousands of bytes (kilobytes), such as 7K or 6K.

• Author. Lists the author according to the Summary Info sh eet. If no
summary sheet was completed for the file, Word displays the name
in the User Info text box. For more information, see Chapter 8,
"Customizing Word."

Tip
Use File Info
View when you
want to sort
files by file
name, kind,
title, size, and
so on. For more
information,
see "Sorting
Files" later in
this ch apter.
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• Last Saved. Lists the date when the file was last saved.
Flg.7.12
Use File Info View
to identify files by
location, title, size,
and other criteria.
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Using Summary View
If you completed Summary Info sheets for your documents, you can use that

information to search for files. When you display a file in summary view,
Find File sh ows summary info rmation as well as date saved, number of revisions, document size, and so on. Figure 7.13 shows a documen t in summary
view.

Fig. 7.13
You can review
Summary Info to
see wh ether the
file is the one you
want before you
open it.
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The Listed Files list box in summary view is the same as in preview view. The
drive, folder, and files fit the search criteria. When you select a file, info rmation about that file appears in the Summary Of area. The name of the file
follows Summary Of. The following list describes the information sh own in
the Summary Of area:

• Summary Info. The first section lists the title, sub ject, keywords, the
template's exact location, and comments in the Summary Info sheet.

Working in Find File

Only information in the Summary Info sheet appears in this section; if
you did not fill out the sheet, only a title appears in this area.

• Created By: The second section lists the author and creation date, the
person who last revised the document and the revision date.
• Editing and Size. The third section lists the document size in bytes,
words, pages, and characters.
Troubleshooting
Why am I seeing what looks like a spinning beach ball on my screen?
This icon appears while Word is updating information in the Find File dialog box.
When the icon disappears, the information is up to date, and you can continue
your work.

I want to copy or delete several files at one time.
Select the files you want to copy or delete by holding down either the Shift or the
):!; key as you click the various files. Choose the Commands button, and then choose

either the Copy or the Delete command to perform the action on all selected files at
one time.

I want to print several files at one time without opening and printing each file.
Select the files by holding down either the Shift or the ):C key while clicking each file.
Then choose Commands Print. Find File prints the documents while you continue
your work.

Working in Find File
Find File provides quick and easy file management within the Word program.
Using the buttons in the Find File dialog box, you can manage and organize
files as well as find the file you want to open. When you manage files with
Find File, you can delete and copy files without the hassle of switching to the
Finder and then opening the File menu and choosing Find.
This section describes some of the intricacies of managing files in Find File.

Sorting Files
When you use the Sorting command, you can sort and display files by author, creation or revision date, file name, or file size. In addition, you can
display either the file name or the title of the file as the file list.
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To use the Sorting command while in the Find File dialog box, follow these
steps:
1. In the View pop-up menu list, choose File Info.
2. Choose Commands Sorting. The Options dialog box appears.

Figure 7.14 shows the Options dialog b'o x that appears when you use
the Sorting command.
Fig. 7.14
Use this dialog
box to sort and list
files in any way
that makes it
easier for you to
find the file you
want.
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3. In the Sort Files By area, select an option. Alternatively, you can choose
to list fi les by Title; the default is Name.
Tip
The files remain sorted in
this man ner
each time you
open the Find
File dialog box
until you
choose the
Commands
Sorting command and
change the
sort order.

4. Click OK to close the dialog box and return to the Find File dialog box.

Selecting Files
No matter which view you use in the Find File dialog box, you must select
files before you can delete, print, or copy them. Use the mouse to select one
or several files. You can perform an action on several files by selecting them,
choosing the Commands button, and then choosing the command from the
pop-up menu.
To select several files in a row, click the first file, press and hold down the
Shift key, and then click the last file. To select several files that are not in
sequence, click the first file, press and hold down the ;)::( key, and th en click
the other files individually.
After you select the files, click the Commands button and then choose Copy,
Delete, or Print.

From Here...

From Here ...
You can use Word's Find File program to organize and manage your files
without the inconvenience of leaving Word to use the Finder's File Find utility. Find File enables you to search for specific files; sort a list of files; and
delete, copy, or print one or several files without leaving Find File.
For related information, see the following chapters:
• Chapter 8, "Customizing Word," covers how to modify and alter
Word's default settings to better suit your working style, including
viewing, editing, printing, and spelling and grammar options.
• Chapter 9, "Working with Large Documents," covers creating and
editing an outline for a document, formatting a document with styles,
using AutoFormat, and using templates to help speed your work in
Word.
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Customizing Wor
by Peter Durso

As you work in Word, you will discover many ways to speed up your work.
Word not only provides shortcuts for commands and procedures, but it also
offers ways to customize the program to your working habits and preferences.
You can change many of Word's default settings to make the program more
suitable for you.
Ways of customizing Word include changing measuremen t units, selecting
various grammar and style rules for the grammar checker, instructing Word
to create backup copies automatically, and prompting for summary information. In addition, you can change the default file locations, such as the location of documents, clip art, and templates.
In this chapter, you learn to
• Change the default location to a directory you create for document
files
• Modify User Info to place your company's name and address
automatically in the return-address area of envelopes
• Set save options
• Establish spelling- and grammar-checking options
• Select printing options
• Establish editing options
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Customizing Options
Word provides various methods for customizing the program to meet your
needs. Using the Tools Options command, you can modify Word's default
settings-the predetermined selections Word makes when you install the
program. When you install Word, for example, the program automatically
displays the status bar and the scroll bars on-screen. You can change this
default setting. When you change any option in the Options dialog box, that
option then applies to all documents and occurrences until you change th e
option again.
You can change Word's default settings in two ways. One way is to choose
the Tools Options command, which displays 12 tabs containing options for
customizing. Figure 8.1 shows the Options dialog box.
Fig. 8.1
The Options dialog
box enables you to
modify several
options at one
time.
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Alternatively, you can customize specific options in certain dialog boxes.
The Save As dialog box, for example, includes the Options command button,
sh own in figure 8.2. When you choose the Option s command button in any
dialog box, the Options dialog box appears; all tabs except the applicable one
are dimmed and thus unavailable.
To customize various options in Word, follow these steps:
1. Open the Tools menu and choose Options. The Options dialog box

appears.
2. Select the tab or tabs representing the options you want to modify.
3. Make your changes.

4. When you finish, click OK to close the dialog box.

Customizing Options
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Fig. 8.2
You can modify
options in a dialog
box before you
complete the
command.
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To customize specific options from a dialog box, follow these steps:
1. Click the Options command button in the dialog box. The Options
dialog box appears, with only one tab available.

2. Make you r changes.
3. When you finish, click OK to close the Options dialog box and return
to the preceding dialog box.
Note
Options that show an X in the check box are activated. If you select an option with
an X in the check box, you deactivate that option. Selecting an option with no X in
the check box activates that option and places an X in the box.

The following section briefly describes each option in the General tab.

Changing General Settings
The General tab in the Options dialog box includes options that affect the
common operations of Word. You can select one, several, or all the options
in the General Options area. The following list describes these options:
• Background Repagination. Background Repagination governs how Word

handles page breaks as you enter or edit text. When the option is on,
Word automatically adjusts the text on each page as you type. Background Repagination is on all the time in page layout view and print
preview; you cannot turn it off in either view. You can turn this option
off in normal and outline views, however.

Tip
When you turn
Background
Repagination
off, you may
notice a slight
increase in the
program's
speed and
efficiency.
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• Use Short Menu Names. This option condenses menu names on the
Macintosh menu bar by abbreviating them. This saves space on the
menu bar and leaves room for utilities that you may have installed on
your Macintosh, such as the system clock or a menu that allows you to
use a Fax modem.
• Include Formatted Text in Clipboard. When you copy text to the Clipboard from your Word document, the text will retain character formatting (Bold, Italic, Small Caps) and paragraph formatting (centered text
or borders).
• Blue Background, White Text. This option changes the Word screen's
background to blue and the text to white.
• Beep On Error Actions. By default, Word beeps when you make an error
or perform a wrong action, such as clicking outside a dialog box. This
option governs whether the program beeps to warn you of an error.
• 3D Dialog and Display Effects. Changes the display from the defaultgray dialog boxes with a three-dimensional appearance-to plain white
dialog boxes.
..,.. See "Using
Common
Steps to Link
Documents,"
p.605

• Update Automatic Links at Open. If you have included links in your
document by using object linking and embedding (OLE), this option
automatically updates data added to other files when you open your
document in Word. It's a good idea to keep the Update Automatic Links
at Open option activated if you use Microsoft Office to its full capacity.
• Mail as Attachment. This option connects a document to a message that
is to be sent via a mail program, such as Microsoft Mail. This option
works only if a mail program is installed.
• Recently Used File List. This option enables Word to display the most
recently used files at the end of the File menu. You must enter the number of files (0 to 9) to be displayed in the Entries text box. Figure 8.3
shows the File menu listing the last four files opened.

Customizing Options
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Fig. 8 .3
You can open one
of these files
quickly by clicking
the fi le name
instead of choosing
the File Open
command.
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• Measurement Units. This option governs the default unit of measurement in Word. The unit you specify-inches, picas, points, or centimeters-is the unit of measurement that appears in dialog boxes and in
the rulers.

Modifying Viewing Options
View options represent another tab in the Options dialog box. Using the
View tab, you can specify whether to show or hide Window elements,
non printing characters, and various other components of Word.
The options you can customize vary slightly from view to view. For example,
you can hide or show the vertical ruler in page layout view, but since there is
no vertical ruler in normal view, that option is available only in page layout
view. To set the options for a certain view, change to that view before opening the Options dialog box. Figure 8.4 shows the View tab for page layout
view.

~

See "Viewing
the Document, "
p. 104
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Fig. 8.4
Use the View tab
of the Options
dialog box to
select the screen
and window
elements you
want to view.
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The following list describes the options in the View tab for page layout view.
The options are divided into three categories: Show, Window, and
Nonprinting Characters.
•

Show. The Show area contains several elements you can choose to hide

(no X in the check box) or show (X in the check box). Following is a
brief description of each option:
Drawings. In page layout view, this option displays a box that represents each object created by using the drawing tools in Word. It also
speeds scrolling and displaying the document.
Object Anchors. Object Anchors show or hide the anchors for all ob-

jects, including spreadsheets, charts, and graphs. This option is
found in page layout view.
Text Boundaries. Select this option in page layout view to display
dotted lines around page margins, text columns, objects, and frames.

Tip

Picture Placeholders. If selected, this option displays empty frames

Use the Picture
Placeholder
option to
quickly print a
proof without
pictures or to
speed up screen
redraw.

that show picture placement to save memory and speed scrolling
throughout the document.
Field Codes. This option shows or hides the field-code names when a

field is inserted into the document.
Bookmarks. Select this option to view bookmarks in the document;

it's especially useful to show bookmarks when you want to edit
them.

Customizing Options

161

Field Shading. Select this option to add shadi ng to a field. Shading
makes fields easier to find in a large document . When Selected shows
you when you have selected text that is part of a field. Always allows
all fields in a document to stand out from regular text. Never does
nothing to the display of a given piece of text, regardless if it's a data
entry or merge field.
• Window. This area enables you to specify which window elements appear on-screen and which elements are hidden. You can hide or show
the following elements: Status Bar, Horizontal Scroll Bar, Vertical Scroll
Bar, and Vertical Ruler (in page layout view). You also can modify the
Style Area Width here.
• Nonprinting Characters. This option enables you to show or hide any of
the following nonprinting ch aracters: Tab Characters, Spaces, Paragraph
Marks, Optional Hyphens, Hidden Text, or All.

Changing Editing Options
The Edit tab of the Options dialog box enables you to find out how overtype
mode works, and to determine whether typing replaces selection. Figure 8.5
shows the Edit tab in the Options dialog box.
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The following list describes the Edit tab's options:

• Typing Replaces Selection. If selected, this option deletes the selected text
as you type new text.

..,.. See "Formatti ng
with Styles,"
p. 182

Fig. 8.5
Modify the editing
settings by
specifying
whether to use
drag-and-drop
editing and
wh ether to
remove spaces
during a cut-andpaste procedure.
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• Drag-and-Drop Text Editing. Drag-and-drop is a method of editing text
without cutting, copying, or pasting. When this option is activated, you
can select the text and then click and drag the selection to another
location in the document.
• Automatic Word Selection. This option selects the entire word when you
select part of it. If this option is activated, you cannot drag the 1-beam
pointer across one character in a word and select only that character;
the whole word is selected.
• Use the INS Key for Paste. This option enables you to paste items from
the Clipboard by pressing the INS key, which is part of the extended
keyboard.
• Overtype Mode. When selected, this option replaces existing text as you
type, one character at a time.
• Use Smart Cut and Paste. This option removes unneeded spaces when
you delete text and adds spaces when you add text.
• Allow Accented Uppercase. This option suggests that Word add an accent
mark to uppercase letters formatted as French.
1111-

See "Working
with Graphics,"
p.205

• Picture Editor. Use the pop-up menu to specify the program Word displays when you edit a picture. If, for example, you double-click an imported clip-art graphic, Word's default Picture Editor selection is the
Word drawing program. If you prefer, select a different program in the
pop-up menu, such as PowerPoint Presentation or PowerPoint Slide. For
more information about PowerPoint, see Chapter 19, "Getting Acquainted with PowerPoint."

Customizing Printing
~

See "Printing a
Document,"
p.l34

~

See "Printing
Documents,"
p. 75

The Print tab offers various options for printing documents, including how
the documents print and what elements print. As with any option in this
dialog box, your choices apply to all documents and instances. If you select
Draft Output as a printing option, for example, all documents printed from
this point on will print in draft form.
Figure 8.6 shows the Print tab of the Options dialog box.
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Fig. 8 .6
In the Print tab,
select options that
affect all documents you print.
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The following Jist describes the options in the Print tab:

II

• Printing Options. This option offers various choices for printing:
Reverse Print Order. Reverse Print Order changes the page-printing
order-3, 2, 1 instead of 1, 2, 3, for example.
Update Fields. This option revises fields (codes that instruct Word to
insert elements into the document automatically) in the document
before printing.
Update Links. Update Links brings links (i nformation created in another document and connected with the Word document) up to date
before printing.
• Include with Document. This option prints additional information with
your document: Summary Info, Field Codes in place of field results,
Annotations on a separate page, Hidden Text, and Drawing Objects.
• Options for Current Document Only. These options apply only to the
active document:
Print Data Only for Forms_ Word prints only the input for a form instead of the input and the actual form lines and text.
Fractional Widths. This option improves the spacing of characters in
proportionally spaced fo nts such as Helvetica. This option is available only on LaserWriter printers. Fractional widths affect screen
display and line and page breaks. To more clearly display or print

.,. See "Adding
Field Names to
Your Letter,"

p.681
.,. See "Using
Embedding
to Link
Information,"

p.602
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monospace fonts, such as Courier, clear the Fractional Widths check
box. If you plan to use fractional widths, select the Fractional Widths
check box before h yphenating or setting final page breaks in documents that contain TrueType or proportionally spaced fonts.

Print Postscript Over Text. This option prints PostScript graphics on
top of text or other graphics in a document. To print text or other
graphics on top of PostScript graphics, deselect this check box. This
o ption is available only with LaserWriter printers.
Tip
You usually use
revision marks
when more
than one person works on a
document and
you need to see
what has been
added, deleted,
and modified.

Changing Revisions Options
The Revisions tab governs the display o f revision marks. You can select diffe rent options for inse rted text, deleted text, and revised lines. Inserted text is
text that has been added to the original text; deleted text has been erased from
the original; and revised lines describes h ow Word will mark all lines of text
that have been modified in any way.
Each a rea offers similar options (but with different hot keys) and sh ows the
results in the Preview box. Figure 8.7 sh ows the Revisions tab o f the Option
dialog box.

Fig. 8.7
Select different
marks for each
area so you can
tell inserted text
from deleted or
revised text.

If you use

your docu~~§~~~~~~~iE~~~U~ inment,
underlining
select

~

Revised Lines
make
it easier_--4~~~e~~~~~~~ij!~~~
to find
revisions when
you scan
through a
document.

another mark
or color for
Inserted Text
to prevent
confusion.

The following list describes the Revisions options:

• Inserted Text. This area en ables you to specify the mark Word uses to
ide ntify added text: no mark, underline, bold, italic, or double underline. Additionally, you can specify a Color to h elp identify the added
text.
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• Deleted Text. You can mark text that has been deleted from the docum ent with either Strikethrough or Hidden Text forma t. Additionally,
you can choose a color to mark the text.

• Revised Lines. You can mark lines of text that have been altered with a
vertical border at the left margin, right margi n, or (for odd and even
pages) outside margi n . You also can specify a color for the border.
• Preview. A Preview box appears beside each area so you can see the
results of your choices before closing the dialog box.

Modifying User Info
The User Info tab of the Options dialog box lists the name that was entered
when Word was installed. The name may be yours, the person who installed
the program, and/or your company. The name entered when Word was installed also is the name that appears in the Mailing Address text box. The
information in the Mailing Address text box is inserted automatically into
the Return Address text box in the Envelopes tab of the Envelopes and Labels
dialog box.
Other information in the User Info tab is used elsewhere in Word. Name is
used as the author in Summary Info records, and Initials are used to identify
the person who entered annotation marks.

....

See "Printing
Envelopes,"
p. 136

....

See "Attaching
Word, Excel, or
PowerPoint
Files to Your
Message, "
p.661

You easily can change the Name, Initials, and Mailing Address text boxes in
the User Info tab. Figure 8.8 shows the User Info tab.
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Enter a name and
address in the
Mailing Address
text box, and that
address appears as
the return address
any time you use
the Envelopes and
Labels dialog box
in Word.
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Changing File Locations
~

See "Saving,
Closing, and
Opening a
Document,"
p.98

To change the location of document files, clip-art files, templates and so on,
use the File Locations tab of the Options dialog box. Suppose that you want
to create a Document folder within the Microsoft Word folder so you can
save specific documents in one place. Use this tab to direct saved documents
to the new folder automatically. Figure 8.9 shows the File Locations tab.

Fig. 8.9

Options
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To change the location for specific files, follow these steps:
1. In the File Locations tab, select the File Types you wan t to relocate.
2. Click the Modify button. The Modify Location dialog box appears

(see fig. 8.10).
Fig. 8.10
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3. Select the new folder from the dialog box, click Use Selected Folder, or
click the New button to create a new folder.
4. Click OK to close the Modify Location dialog box and return to the File

Locations tab.
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Changing Save Options
The options available in the Save tab affect how and when Word saves your
document. In addition, you can add a protection device, such as a password,
to specific documents.

..,. See "Saving,
Opening, and
Closing Files,"

p. 62

Figure 8.11 shows the Save tab of the Options dialog box.
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The following list describes the options in the Save tab:

• Save Options. This area provides options for saving your documents and
certain elements of those documents.
• Always Create Backup Copy. Select this option to tell Word to create a
copy of each docu ment you create.
• Allow Fast Saves. Activate this option to save only the ch anges to your
document.
• Prompt for Summary 111(0 . Select this option to display the Summary Info
dialog box each time you save a new document.
• Prompt To Save Normal. When activated, this option warns you when
you have changed the Normal template by displaying a message to save
changes. You may wa nt to save the changes to the template. However if
you want to be reminded in the even t that changes have occurred to
the Normal Template, select this option .
• Save Native Picture Formats Only. This option saves imported gra phics in
the Windows version only. If you import a graphic from a Macintosh
program, for example, you can save disk space by saving the graphic

..,. See "Creating
Summary In fo
Records,"
p. 140
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only in the native picture format (Windows version) instead of in the
Macintosh format.

• Embed TrueType Fonts . This option implants TrueType fonts in the document so that the fonts display correctly, even if the document is being
used on a computer that does not support TrueType fonts.
• Save Data Only for Forms. This option saves the data in a form as a single
record for use in a database.
• Automatic Save Every. Select this option to tell Word to save your document automatically; set the interval in the Minutes text box.

Use the Automatic Save Every option all the time so that if a power failure
occurs, Word recovers the document when you restart the program. Word
then prompts you to save, delete, or continue to work on the saved version of
your document. The amount of time you set for automatic save depends on
how critical the document is and on personal preference.

• File-Sharing Options for Dommentl. Select the following protection
options for the current document:
Protection Password. Enter a password (up to 12 characters) to keep
other users from opening the document. Word displays an asterisk
for each character you enter. You must remember your password;
you cannot open a password-protected file without the password.
Write Reservation Password. This option permits anyone to open the
document, but only users who know the password can modify or
edit the document. Enter a password, and then click OK. Word
prompts you for confirmation; enter the password and click OK
again.
Read-Only Recommended. This option means that when the document
is opened, Word suggests that the document be opened as read-only.
The reader can open the document either way. If the document is
opened as read-only, no changes can be made in the document; the
document is available only for reading, not for alteration.

Customizing Options

169

Changing Spelling Options
Although Word's spelling dictionary is sufficient for most documents, you
may have a special need for a medical, legal, or foreign-language dictionary.
You can add a third-party dictionary for use with Word by using the Spelling
tab in the Options dialog box (see fig. 8.12). Additionally, you can customize
other options that handle the spell checker.
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The following list describes the options in the Spelling tab:

• Suggest. This area handles the suggestions Word offers fo r misspelled
words during a spelling check. You can select either or both options:
Always Suggest. If this option is selected, Word displays a list of likely
candidates to replace the misspelled word.
From Main Dictionary Only. This option limits Word's suggestions to
the main dictionary. If you have another dictionary in which the
word may appear, such as a legal dictionary, do not select this
option.
• Ignore. You can ignore all Words in UPPERCASE and/or Words with
Numbers. A third option in this area-Reset Ignore All-returns the
Ignore All list to its original state. Thereafter, Word again questions
any words for which you used the Ignore All command earlier in the
session.
• Custom Dictionaries. This option displays all installed dictionaries; you
can select up to 10 for use during any session. Within this area are several more options:

II
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New. This option creates a new custom dictionary.

Edit. This option opens the selected dictionary so you can edit it.

Add. This option adds a third-party dictionary from another location.

Remove. This option deletes a dictionary from the list, but not from
your disk.
Language. When you are using a custom dictionary, select the language in the pop-up menu to apply special formatting for that language. Make sure that the correct custom dictionary is selected.

Customizing Grammar Options
<1111

See "Checking
Grammar,"
p. 129

Word enables you to select various grammar rules and styles of writing for
checking the grammar in your documents. The default style is business writing. You also can choose a stricter style or an informal writing style, or create
your own custom styles. Additionally, you can review the grammar rules used
with a specific style and even deactivate some of those rules.
Figure 8.13 shows the Grammar tab of the Options dialog box.

Fig. 8 .13
Select the style you
want the Grammar
Checker to use
when checking
your documents,
or customize the
settings by
selecting your
own rules.
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Note
To view all grammar and style rules attached to the highlighted item in the Use
Grammar and Style rules list box, click the Customize Settings button. In the Customize Grammar Settings dialog box, dick either the Grammar button or the Style button, and scroll through the list of rules. You can click the Explain button for further
information about any rule. Click OK to exit the dialog box.
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When you specify grammar and style rules, you can select options from the
following categories in the Use Grammar and Style Rules pop-up menu:
• Strictly (All Rules). This option applies all grammar and style rules, in-

cluding checking for cliches and checking for quoted text, homonyms,
jargon, pretentious words, redundant expressions, and so on.
• For Business Writing. This option includes all grammar rules, but leaves

out the style rules mentioned for Strictly, plus a few more.
• For Casual Writing. This option, which is informal in both grammar and

style rules, leaves out three grammar rules: format errors, informal usage, and jargon words. In addition, this option leaves out about half the
style rules.
•

Custom 1, Custom 2, or Custom 3. You can create your own set of rules

by selecting one of these options and then choosing the Customize
Settings button. The Customize Grammar Settings dialog box appears
(see fig. 8.14). All the check boxes are marked when this dialog box
opens; you deselect the rules you do not want to use. When you finish,
click OK to close the dialog box and return to the Grammar tab.
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In addition to choosing grammar and style rules, you can specify whether
you want Word to Check Spelling while checking the grammar and whether
to Show Readability Statistics. The Readability Statistics dialog box displays
the number of words, characters, paragraphs, and sentences in the document
and the average number of sentences per paragraph, words per sentence, and
characters per word. In addition, the dialog box shows readability indexes

II

Fig. 8.14
Specify which
grammar and style
rules you want the
Grammar Checker
to follow by
creating your own
custom options in
the Customize
Grammar Settings
dialog box.
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based on the average number of syllables per word and average number of
words per sentence. These readability indexes are Reading Ease and Grade
Level values.
Additionally, the Catch area of the Customize Grammar Settings dialog box
enables you to specify when Word should catch (alert you to) split infinitives,
consecutive nouns, prepositional phrases, and long sentences. You can select
options for each of these settings; for example, you can catch split infinitives
always, by more than one word, two words, three words, or never. Also, you
can limit the number of words a sentence can contain-IS, 30, or 40, for
example.

Changing AutoFormat Options
<Ill

See "Formatting
with Styles,"

p. 182

Fig. 8.15
Select the options
you want
AutoFormat to
apply when
formatting your
documents.

Tip
To use
AutoFormat,
choose the
Format
AutoFormat
command. For
more information, see Chapter 9, "Working
with Large
Documents."

AutoFormat is a formatting tool within Word that automatically applies
built-in styles and a template to your document. You can select various options for AutoFormat to apply. Figure 8.15 shows the AutoFormat tab of the
Options dialog box.
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The following list describes the options in the AutoFormat tab:

• Preserve. This area has only one option: Previously Applied Styles. Select
this option to keep any styles you have already assigned within your
document.

From Here. . .
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• Apply Styles To. Select the types of text to which you want to assign the

styles: Headings, Lists, and Other Paragraphs (such as subheads, tabs,
and indented text).
• Adjust. Select the elements you want Word to fit to the style: Paragraph

Marks, Tabs and Spaces, and Empty Paragraphs. When adjusting these
elements, Word may take extra spaces or tabs out, remove extra blank
lines, and so on.
• Replace. Select the elements you want to substitute: Straight Quotes

with Smart Quotes (also called open and closed quotes), Symbol Characters with Symbols (replaces TM, for example, with TM), and Bullet
Characters with Bullets (replaces the plus sign or asterisk with bullets
that your printer can print).

From Here ...
You can customize many Word settings to speed up your work and increase
efficiency. You can change spelling and grammar options, file locations, editing choices, and more. Setting the options to suit your preferences and work
habits makes the program all the more beneficial and useful.
You learn even more about the Word program in the following chapters:
• Chapter 9, "Working with Large Documents," covers outlining documents and editing the outline, formatting text with styles, using
AutoFormat to speed up your work, and using templates.
• Chapter 10, "Working with Tables, Charts, and Graphics," covers creating and editing tables, producing and modifying charts, and adding
lines, borders, and pictures to your documents.
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Chapter 9

Working with Large
Documents
by Peter Durso

When you are producing a document that contains many pages-from
10 or 15 to hundreds-you need special organizational and managerial
techniques. Word provides several features that help you manage long
documents. (You can use these features for short documents as well.)
In this chapter, you learn to
• Create an outline by using Word's Outline view and Outline toolbar
• Edit an outline by rearranging text and headings
• Use Word's built-in styles to format the text in a document
• Use AutoFormat and Style Gallery to have Word format a document
for you
• Create and edit your own styles
• Use template wizards to format your documents
One organizational feature you can use in a large document is outlining. Word
provides special outlining features, including an outline view that helps you
organize your text. You can arrange headings and text, move headings to new
positions in the outline, and print the outline as you work on it.
Word also provides document-formatting methods that make your work
easier. You can use sty/es-preformatted fonts and paragraph attributes-to
format your documents quickly and to guarantee consistency within the
document.

II
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Outlining a Document
When creating a large document, use an outline and outline view to get an
overview of how the document is put together. You can also easily rearrange
headings and text to better suit the flow of information. Finally, use outlining in long documents to quickly move to a specific location and then view
the text.

Creating an Outline
You create an outline by entering, formatting, and assigning headings in
Word's Outline view. The view provides helpful features used to organize
your document. After creating your outline, you easily can change heading
levels, add text, and otherwise edit your document by using the Outline
toolbar and other features of Outline view.
To start the outline, choose the View Outline command. In Outline view, use
the Outline toolbar to specify various levels of headings and body text. Word
indents each heading and its text, and formats the text for you. Outline view
also includes the Outline toolbar (see fig. 9.1).
Figure 9.1 shows an initial outline for a document. This sample outline contains three levels of headings. As you enter more headings and body text, you
can format the text, arrange the headings, and move text around to better
organize the document.
Outline view provides an Outline toolbar (see fig. 9.1) that enables you to
assign headings to your text, hide body text or headings, and rearrange your
outline. You can outline an existing document or create a new document in
outline view.
Following is a brief description of each of the tools in the Outline toolbar:

• Promote. Elevates a heading to a higher level.
• Demote. Reduces a heading to a lower level.
• Demote to Body Text. Reduces the heading to body text.
• Move Up. Repositions the selected heading up one line in the outline.
• Move Down. Repositions the selected heading down one line in the
outline.

• Expand. Shows subheadings and body text under selected heading.
• Collapse. Hides subheadings and body text under selected heading.

Outlining a Document
•
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Show Headings 1 through 8. Expands or collapses the outline to a specific

level.
•

Show All. Expands or collapses the entire outline.

•

Show First Line Only. Shows all body text or only the first line.

•

Show Formatting . Shows or hides character formatting.

Promote
Demote

Fig. 9.1
You can plan a
document from
scratch in outline
view, assigning
levels of importance to headings
as you write.

L - - - - - --1-1--- Master document view

Show headings 1-8
Show
Show first line only
Show formatting

In summary, to outline a document, assign headings to the text to signify
different levels of topic development. You can create up to nine different
levels of text, including body text. Word formats and indents each level so
you can organize the text quickly. The headings remain formatted in other
views as well, although the indents appear.

Tip
To change to
Outline view,
simply click the
third page button
from the left in the
horizontal scroll
bar at the bottom
of the screen
(see fig. 9.2).
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Flg.9.2
Place the mouse
pointer on a
button in any
toolbar to view
the Too!Tip and a
description of the
button in the
status bar.

Body text

Note
You can reformat any text formats easily by using styles. For more information, see
the section "Formatting with Styles" later in this chapter.

Entering Text

..
..
..

See "Viewing
the Document," p. 104
See "Entering
Text," p. 90
See "Formatting Text,"
p. 108

You can enter text as you normally would by typing paragraphs, heading
text, and so on in normal, page layout, or outline view. You can assign
Heading styles to existing text by using the Formatting toolbar.
The Formatting toolbar includes a pop-up menu of styles (see fig. 9.3).
Heading 1 style is used for the broadest topics; Heading 2 is used for the
subdivisions of Heading 1 topics; and so on .
Alternatively, you can designate outline levels as you enter text. Simply select
a style from the pop-up menu and type the heading. Then change the style,
if necessary, and type the next heading or body text (Normal is the same as
the body text style; see the section "Formatting with Styles" later in this
chapter).

Outlining a Document
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Fig. 9.3
You can assign
heading styles by
using the formatting toolbar.
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Selecting Text

Outline view provides a slightly different m ethod of selecting text than do
the other views. Each paragraph of text, whether that text is a heading or
body text, is preceded by a plus sign (+)or a minus sign (-). If you position
the mouse pointer on one of these symbols, the pointer changes to a fourheaded arrow. When the pointer changes shape, simply click the plus sign or
minus sign to select the associated paragraph and any lower-level headings
and body text below it.
Note
The plus and minus signs also indicate whether more text has been entered under
that level of the outline. A plus sign next to a Heading 1 entry, for example, means
that other headings and/or body text have been entered under that heading.
A minus sign always appears next to body text, which is the lowest level.

Suppose that you click the plus sign preceding the Marketing Summary heading (refer to fig. 9.2). By doing so, you select all text from that point to the
next Level 1 heading. (In this case, all the text would be selected.) Similarly, if
you click the plus sign preceding the Level 2 head Introduction, you select all
text from that point to the next Level 2 heading (Customer List). You also can
select text by clicking the selection bar, which is to the left of the text area, or
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by dragging the 1-beam pointer across specific text. After you select the text,
you can then choose the level of the heading you want to assign.
Promoting and Demoting Heads
After assigning various heading levels to your text, you might decide to
change those levels. You can do so by using the Promote and Demote buttons in the Outline tool bar. Simply select the text and then click the Promote
or Demote button.

The Promote button-the first button from the left in the Outline toolbarlooks like an arrow pointing left. Each time you click the button, the selected
text moves up one level (until it reaches Level 1). Similarly, the Demote button-an arrow pointing right-bumps the selected text down one heading
level at a time (until it reaches Level 9). Remember, when you select a heading, you select all text and subheadings within that heading. When you promote or demote the heading, all subheadings follow suit.

Tip
Double-click the
plus sign that
precedes a heading to display all
of the text below
that heading.
Double-click
again to hide all
the text.

To change a selected head to body text in a single step, click the Demote to
Body Text button-a double arrow pointing right.

Editing an Outline
You can edit an outline by adding, deleting, or rearranging body text and
headings. In outline view, you can add or delete text as you would in any
view. But outline view also provides two features that make it easier for you
to rearrange your text: viewing and moving outline levels.
You can use the Outline toolbar to view specific levels of the outline. In addition, you can rearrange topics easily without cutting and pasting text.
Collapsing and Expanding Outlines
You can view various levels of an outline by using the Show Heading buttons-the buttons numbered 1 through 8 in the Outline toolbar. If you click
the Show Heading 1 button, for example, only Heading 1 text appears onscreen. If you click the Show Heading 2 button, you see only Heading 1 and
Heading 2 text.
If you show only headings with no body text, you are collapsing the outline.

the outline means just the opposite. If only Heading 2 text is showing, for example, click the Show Heading 3, Show Heading 4, or Show All
button to expand the outline.

Expanding

Outlining a Document
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Figure 9.4 shows a collapsed outline. The plus sign n ext to each heading indicates that more text levels exist within that heading. If a minus sign appears
next to a heading, the heading contains no further text levels.
heading 1
Show h ead ing 2

- · '\hnw

Fig. 9.4
Use the Expand
and Collapse
buttons to reveal
text below the
selected head .
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Rearranging Heads and Text

You can rearrange topics in your document by selecting and moving h eadings in outline view. The easiest method is to collapse the outline to the level
to be moved, select the heading you want to move, and drag the heading to
its new position. Subheads and body text move with the selected heading.

Caution

-

If you d o not collapse the o utline before moving the text, you might leave some
body text behind. Be sure to select all text to be moved.

Figure 9.5 illustrates moving a head, plus its subheads and body text, to a
new position. The mouse pointer changes to a double-headed arrow, and a
guideline moves with the mouse to help you position the heading.
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Fig. 9 .5
For the most
efficient and
easiest rearranging
of topics, collapse
the outline to the
heading level to be
moved.
" StarStruclc Soundlabs
o What We Can Do For You
• These are just a few suggestive descriptions of what I
do for

Double-headed arrow
Dragging heading up

---+---'

Troubleshooting
Tip
To print the
o utline at any
level, choose the
File Print command or click the
Print button.

I collapsed the outline so I could focus on the headings while scrolling through the
document, but I want to remind myself about the contents of the body text below
each heading.

Click the Show First Line Only button in the Outline toolbar to display the first line of
body text below each heading.
I want to print only the headings and first lines of body text.

Word prin ts only what is displayed on-screen. Display the level of headings you want
to print, and then click the Show First Line Only button in the Outline toolbar.

Formatting with Styles
A style is a collection of text attributes th at you can assign to selected text in
a documen t. Each style includes attributes such as fon t, type size and style,
spacing, leading, alignment, indents, and tabs. Styles enable you to for mat
your documents quickly and consistently. Word provides a large number of
ready-to-use styles; you also can create your own styles as you work.

Formatting with Styles
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One of Word's styles, for example, is the Heading 1 style used to outline a
document. Heading 1 text initially appears in the 14-point Aria! font, bold
and left-aligned. You can assign this style, or any other style, as often as necessary in your documents.
Word's styles are associated with its templates, which are a preset collection
of page, paragraph, and text formatting styles that you can use to develop a
particular type of document. Each time you start a new document, the New
dialog box lists many different templates. The Normal template (Word's default) offers three heading formats and a body-text format. Other templates,
such as the Invoice, Letter, and Memo templates, provide different styles for
your use.
Styles are particularly useful when you are working on a large document.
Rather than moving from page to page and formatting each head, list, tab
setting, and so on, you can format a style one time and then assign the style
to all occurrences within the text.
Note
I

Examine some of Word's templates by choosing the File New command. In the New
dialog box, select any template and then click OK. Open the Style pop-up menu in
the Formatting tool bar to view the available styles for that template. Enter some text
on the page, assigning different styles to the text to see how each style is formatted.
When you finish, choose the File Close command; when you are prompted to save
changes, choose No.

Using Word's Styles
To apply a style, first select the text you want to format. Then open the Style
pop-up menu in the Formatting toolbar and select the style you want to apply (see fig. 9.6).
You can change the format of text after applying a style. You could, for example, change the Dance Schools heading shown in figure 9.6 to 14-point or
center-aligned. Changing a particular heading, however, does not change the
style itself or other headings to which you applied that style. For more information about changing the attributes of styles, see "Editing a Style" later in
this chapter.
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Fig. 9.6
The Heading 2
style is 12-poi nt
Helvetica, bold
italic, left-aligned,
with spacing set at
12 points before
and 3 points after
th e paragraph.
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Creating a Style
Creating your own styles in Word is easy. Suppose that you want to create a
heading style for use throughout your document. This style is 18-point Times
New Roman, bold and center-aligned. You can create this style, add it to the
pop-up menu, and use it as you would any other Word style.
To create your own style, follow these steps:
1. Select the text on which you want to base your style, and apply the
desired formatting.

2. With the text still selected, position the insertion point in the Style box
in the Formatting toolbar.
3 . Delete the style name in the text box, and enter your own name for the
style (see fig. 9. 7).
4. Press return to add the name to the Styles list.

Editing a Style
You can edit any style (changing font, size, alignment, tab stops, and so on),
whether it is a preset style provided with Word or a style you created. To edit
a style, follow these steps:
1. Open the Format menu and choose the Style command. The Style

dialog box appears (see fig. 9.8).

Formatting with Styles

185

Fig. 9.7
When you enter a
new name in the
Style box, you do
not actually delete
the original style;
you are just adding
a new style to the
list.
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Fig. 9.8
You can view the
attributes of a style
in the Description
area at the bottom
of the dialog box.

I(

Help

)
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2. In the Styles list box, select the style you want to modify. Samples of

the text as it is now formatted appear in the Paragraph Preview and
Character Preview boxes.
3. Choose Modify to edit the style. The Modify Style dialog box appears

(see fig. 9.9).
4. Click Format to display a pop-up menu of the style attributes you can

<1111

edit.
5. Select an attribute-Font, Paragraph, Tabs, and so on-in the list, and

then make the desired changes in the dia log box that appears. (This
dialog box is exactly like the one that appears when you choose the
corresponding command from the Format menu.) Click OK to return to
the Modify Style dialog box.

<1111

See "Formatting
Text," p. 108
See "Formatting
Paragraphs,"
p. 112
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Fig. 9.9
Modify a style by
selecting an option
in the Format popup menu.
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Tip
To save the styles
you create or edit
in a document,
save the document. After that,
the styles will
always be available with that
document.

6. Repeat step 5 as often as necessary to modify additional style attributes.
7. After making all desired changes, click OK in the Modify Style dialog
box. You return to the Style dialog box.
8. Choose Apply to apply the style changes.

Using Autoformat
AutoFormat is a feature of Word that analyzes your document and automatically applies styles (such as headings, subheads, bulleted lists, and tabs) to
your document. Then you can review Autoformat's choices an d accept or
reject them. Using Autoformat can save you time because Word assigns styles
for you. The formatting may not be exactly what you want, but you can still
change fon ts, styles, sizes, and so on after using AutoFormat.
You can use AutoFormat with unformatted text, or you can begin formatting
(by creating and applying a few styles) and then let AutoFormat complete
the process. AutoFormat finds similar text and assigns the same styles.
If you choose the latter method, you have more control over which styles
Autoformat uses. Experiment with both methods and see which you prefer.

~

See "Changing
AutoFormat
Options,"
p. 172

Formatting Text Automatically
To start Autoformat, choose the Format Autoformat command. A message
box-the first AutoFormat dia log box-appears, announcing that formatting
is about to begin (see fig. 9.10). Click OK to begin formatting.

Using AutoFormat

Fig. 9.10
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Accepting or Rejecting Changes
After AutoFormat completes the formatting, another dialog box appears (see
fig. 9. 11). Choose Accept to accept all changes. lf you choose Accept too hastily, you can reverse your decision by clicking the Undo button in the Standard toolbar. If you do not like the changes you see behind the AutoFormat
dialog box, choose Re ject All. Alternatively, choose Review Changes or Style
Gallery.
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You can choose to
review changes,
reject changes, or
accept changes.

If you choose to Review Changes, Word shows you each change to the fo rmatting by highlighting the change and displaying a dialog box with a
description of the change. You can choose to accept o r reject individual
changes. If you choose the Style Gallery, you can apply different templates
and styles to the document to see what they look like.

Reviewing Changes
If you choose to review the changes, Word takes you th rough the document
step-by-step, enabling you to examine each change that AutoFormat m ade.
Figure 9.12 shows the Review AutoFormat Changes dialog box.
Reulew RutoFonnat Chan es

Fig. 9.12
In this dialog box,
examine each
change and decide
whether to keep or
reject the changes.
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The Review AutoFormat Changes dialog box enables you to accept or reject
changes. To accept a change, choose one of the Find buttons. Find with a left
arrow moves to the previous change; Find with a right arrow moves to the
next change. If you do not like the formatting, choose the Reject button.
Word changes the selection back to its original formatting.
Choose Close after reviewing the changes, or at any time, and Word displays
the initial AutoFormat dialog box again. You can choose to accept or reject all
changes.
Note
You can click the mouse outside the Review AutoFormat Changes dialog box to work
in your document. The dialog box remains on-screen. This way, you can scroll
through the document to compare changes, format text, and add or edit text.

Using Style Gallery
Tip
You also can
choose Style
GaLlery in the
AutoFormat
dialog box to
select a different template
and style for
the document.
~

See "Changing
AutoFormat
Options,"
p. 172

Style Gallery is a special dialog box that contains Word's various templates.
Each template contains preset page formatting and preset styles. You can use
Style Gallery to apply various templates and styles to your document, and
view an example in the dialog box before choosing to accept the style.
You can use the Style Gallery with or without AutoFormat. When you use
AutoFormat, Word automatically applies a template and style sheet. If you do
not Hke Word's choice, you can choose the Style Gallery button and choose a
different template and style for your document. On the other hand, you may
format your document yourself, by applying styles to the text and paragraphs, and then decide to look at the document with various templates
applied. Style Gallery gives a formatted document a different look using
various styles of fonts, indents, type sizes, and so on.
To open Style Gallery from the AutoFormat dialog box, choose Style Gallery.
Figure 9.13 shows the Style Gallery dialog box with the Report3 template
displayed.
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Apply any of the
templates and
styles to your
document, or
choose to preview
examples of the
template.
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Note
Before you can apply a template from Style Gallery to a document, the document
must contain styles such as Heading, Index, and List. Therefore, you must have formatted the document with Word's styles or your own.

To use the Style Gallery, follow these steps:
1 . In the second AutoFormat dialog box, choose Style Gallery. The Style
Gallery dialog box appears.

2 . Select a template in the Template list. A sample appears in the Preview
Of box.

3. If you find a template and style you like, click OK. If you do no t find a
template you like, click Cancel. Word returns to the AutoFormat dialog
box.
4. Choose to Accept o r Reject All changes. The dialog box closes, and you

return to the document.
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Troubleshooting
I want to use the styles with a particular template, but I can't find the style names.

Choose the View Tool bars command and display the Formatting toolbar; then click
OK. The Style box is the first box at the left end of the toolbar. In addition, change
the view from normal or outline to page layout (View menu) to display all formatting
in the document.
AutoFormat does not seem to change the formatting of my document.

AutoFormat assigns styles only to paragraphs formatted in Normal or Body Text style.
If you have selected some text and applied a style, or if you used commands in the
Format menu to format some text, AutoFormat will not change any of the styles.
I want to format only a section of a document.

Select the text you want to format, and then choose Format AutoFormat.

Using Template Wizards
A template wizard is a special template that asks questions and uses your
answers to format a document automatically. The available template wizards
include Agenda, Award, Calendar, Fax Cover sheet, Letter, Memo, Newsletter,
Legal pleading papers, Resume, and Table.
If you use a template wizard, you must use it before you actually enter text in

a document. Choose File New to display Word's list of templates. Select the
type of template wizard you want to use, and then answer the questions as
they appear on-screen. This section describes the questions, answers, and
formatting associated with the Memo Wizard.

Choosing a Wizard
To begin a wizard document, open the File menu and choose New. The New
dialog box appears (see fig. 9.14). Select the template wizard you want to use
(for this example, select Memo Wizard), and then click OK.

Using Template Wizards
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Fig. 9 .14
Select a template
wizard, and view a
brief description in
the Description
area. Click OK
to accept the
template wizard.
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Choosing Text Options
Word displays the Memo Wizard dialog box (see fig. 9.15). The dialog box
shows you an example of the memo the wizard will format for you. Each
dialog box that appears asks you questions about the text and formatting of
the document. You choose general text, such as the headings "Interoffice
Memo," "To," "From," and so on, from these dialog boxes and Word will
apply them to the final memo. You fill in specific text-such as the name,
date, and subject-after the memo is created. Additionally, Word asks about
other formatting concerns, such as the addition of page numbers, graphics
lines, and so on.
The first dialog box asks if you want to use a heading and what text you want
to use as a heading. After making your decision, choose Next to continue
formatting the memo.
Word displays a second dialog box, asking whether you want a separate page
for your distribution list. Choose Yes if you are sending the memo to several
people; choose No if you are sending the memo to only one or two people.
Choose Next to move to the next dialog box (see fig. 9.16).
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Fig. 9.15
Answer the
questions and
choose Next to
continue creating
the memo with
the Memo Wizard
template.
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Select the options
you want to
include, and enter
text in the
appropriate text
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In this dialog box, select the options you want to use: Date, To, CC, From,
Subject, Priority, and Separator Line. Enter text in the Date and From text
boxes, replacing the date if it is incorrect.
After you select options, choose Back to return to the preceding dialog box or
Next to continue. The next dialog box asks whether you want to include the
Writer's and Typist's Initials, Enclosures, and/or Attachments. Select the options you want and then choose Next.
Next, you can select a header, or title, for your memo. The header can contain
a Topic, Date, and/or Page Number; select one, two, or all three to include as
a header. Additionally, you can select a footer, which can include the Date,
the Page Number, or the word Confidential. Select one, two, or all three of the
options for your footer, and then choose Next.

Formatting the Memo
The next Memo Wizard dialog box governs the formatting of the document.
Figure 9.17 shows the wizard's prompt for the style of memo to be used.

Using Template Wizards
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The style Word assigns to the document includes margins, text formatting,
tab settings, graphics lines, and so on.
Memo Wizard

Which o111•wuld vou lltt?

IIJ!;I..,tc

9 Cin"mPOrer~
Qil~i'O"il'rfter

-

You can select Classic, Contemporary, or Typewriter style. Most of the
wizards ask this style question about the formatting of documents. Classic
usually is plain, formal-looking, and straightforward. Contemporary, which
often contains various fonts and graphics lines, is more modern in design.
Typewriter looks as though the document was typed on a typewriter.
When you select one of the styles, an example displays in the dialog box.
Select the style that best suits your memo or document. After selecting the
style, choose Finish to close the dialog box.
Word then creates the memo document for you, adding text and formatting
the style with the choices you made. Word displays the memo, as shown in
figure 9.18. This memo was created in the Contemporary style. Fill in the
specific text and your memo is complete.
Troubleshooting
I want to use a wizard that is not listed in the New dialog box.

Make sure that you are in the Template folder in the Word program folder. If you
installed the templates to another folder, change to that folder. Alternatively, you
may need to run Word Setup and install the templates, if you did not install them
with the original program. See Appendix A, "Installing Microsoft Office," for more
information.

Fig. 9.17
Select a style that
best suits your
needs; you can
modify the styl e
later.

II
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Fig. 9.18
Fill in the text to
complete your
memo. You can
select and format
the text, just as
you can in any
other Word
document.

To:
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From:
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From Here ...
Word offers several features that make organizing and managing large documents easier. In addition, you can use Word's features to format a large document quickly, easily, and professionally. The next chapters show you some
advanced techniques for working with Word for the Macintosh.
• Chapter 10, "Working with Tables, Charts, and Graphics," covers inserting a table, entering text in a table, and modifying the text and table
attributes. Additionally, this chapter covers creating and editing
charts, as well as adding borders, lines, shading, and pictures to your
documents.
• Chapter 11, "Automating with Macros and Mail Merge," covers how to
use Word's built-in macros, record your own macros, and run macros.
This chapter also covers creating a mailing list and letter for use with
the mail merge feature in Word.

Chapter 10

Working witth Tab

Charts, and Gra h
by Peter Durso

II
You can enhance and illustrate your documents by adding tables, charts, and
graphics. Added elements, such as these, illustrate, define, and explain the
text in your documents.
You can create tables to organize columns of numbers, produce forms, or add
spreadsheets to your documents. Word enables you to enter and format text
in a table, as well as to format the table itself. You can add rows and columns,
adjust spacing, add borders, adjust row height, and more.
Additionally, you can create charts to add to your documents. Word includes
an applet, or mini-application, called Graph that enables you to create charts
and embed them in your document. Embedding is an efficient method of
placing the product of an other application into Word. This chapter shows
you how to use Graph and how to embed the chart in your documents.
Finally, Word enables you to add graphics such as lines, borders, shading,
and even pictures to your documents to illustrate them and add interest.
In this chapter, you learn to
• Insert a table into a document
• Enter, edit, and format the text in a table
• Modify row height and column width
• Create and edit data for charts
• Add lines, borders, and shading to a document
• Insert pictures, such as Microsoft Office's clip art
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Working with Tables
A table is a convenient method of organizing text. You can use a table to
create forms, reports, spreadsheets, and columns of numbers. You even can
use tables to produce side-by-side paragraphs, such as those in a resume.
Tables consist of columns and rows. Columns are the vertical divisions of the
table; rows are the horizontal divisions. The box formed by the intersection
of a column and row is called a cell. You can fill cells with text and graphics.
When you type text into a cell, the text wraps from one line to the next,
enlarging the cell as you enter more text.
When you insert a table, you enter the number of columns and rows for the
table. After the table is inserted, you can modify the table and its contents by
adding borders and shading, formatting the text, adjusting column width
and row height, and so on. This section introduces table basics. For information about adding borders and shading to a table, see "Working with Graphics" later in this chapter.

Inserting a Table
You can insert a table by using the Table menu or the Insert Table button in
the Standard toolbar. To use the menu, open the Table menu and choose
Insert Table. The Insert Table dialog box appears (see fig. 10.1).
Fig. 10.1
Enter the number
of columns and
rows in the Insert
Table dialog box.

OK

r

Number or Ro'ol$:

lAuto

Column Width:
Teblo Forme!?.

(non.)

Help

The following list describes the options in the Insert Table dialog box:
• Number of Columns. Enter the number of columns for the table.
• Number of Rows. Enter the number of rows for the table.
• Column Width. Set a specific column width for all columns, or leave the
option at Auto. Auto column width divides the space between the left
and right margins. You can adjust the width of any column at any time.

Working with Tables
•

Table Format. If you used AutoFormat to format the table, this option
displays the predefined format.

•

Wizard. Starts the Table Wizard; answer the wizard's questions and
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choose options for formatting the table.
•

AutoFonnat. Displays the Table AutoFormat dialog box, in which you

~

See " Using
AutoFormat, "
p. 186

~

See " Using
Template
Wizards,"
p. 190

choose styles, borders, fonts, and so on. AutoFormat is very much like
the Style Gallery. For more information, see Chapter 9, "Working with
Large Documents."
•

Help. Displays help on inserting a table.

When you insert a table, Word displays table gridlines. If you do not see
any gridlines, open the Table menu and choose Gridlines to display the
nonprinting guides.
To insert a table, follow these steps:
1. Position the insertion point where you want to insert the table.
2 . Open the Table menu and choose Insert Table. The Insert Table dialog
box appears.

3. Enter the Number of Columns and the Number of Rows.
4. Optionally, enter a value in the Column Width box.

5. If you choose Wizard o r AutoFormat, answer all queries in the dialog
boxes.

Tip
You always can
add or delete
rows and columns by choosing the Table
Insert Rows/
Columns or
Table Delete
Rows/Columns
commands.

6 . Click OK to insert the table and close the Insert Table dialog box.

Note
If you click the Insert Table button in the Standard toolbar, a grid appears. Drag
the mouse pointer across the grid to specify the number of columns and down
the grid to specify the number of rows. When you release the mouse button,
Word inserts a table with the specified number of columns and rows.
~

See "Formatting Paragraphs," p. 112

~

See "Formatting Text,"
p. 108

Adding Text to a Table
After you insert the table, you can add text. Enter text in a table much the
same way that you enter text in any document. Moving around in a table,
however, is a bit different. You also edit the text in a table as you would any
text. After you enter the text, you can select it to apply various types of fo rm atti ng, such as type sizes and alignments.

II
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Entering Text
To enter text in a table, first position the insertion point in a cell, and then
type the text. To move to another cell in the table, use the arrow keys. The
arrow keys move from cell to cell and from row to row. If a cell contains text,
an arrow key first moves one character at a time and then moves from cell to
cell.
Pressing the tab key moves the insertion point to the right from one cell to
another, selecting any text in the cell. Press shift+tab to move one cell to the
left. To insert a tab in a cell, press control+tab and then set the tab as you
normally would.
Selecting Text in a Table
Selecting text in a table is similar to selecting text in any document. You can
drag the 1-beam pointer over the text to highlight it, or click the selection bar
to select an entire row. In addition, you can use some techniques that are
specific to selecting text in a table. Following is a list of those techniques:
• To select one cell, triple-click that cell or click the left inside edge of the
cell.
• To select an entire column, drag the mouse down the column. Alternatively, place the mouse pointer at the top of the column; the pointer
changes to a black down arrow. Then click to select the column, or click
and drag across columns to select more than one column.
• Select an entire row by clicking the selection area to the left of the
table; drag up or down to select more than one row.
• To select the entire table, position the cursor in the table and press
option+clear (on the numeric keypad). Alternatively, place the insertion
point in the table and open the Table menu and choose Select Table.

Tip
Use the ruler
to adjust text
indents. For
more information, see
Chapter 5,
"Formatting
Text and
Documents."

After selecting the text, you can format it as you would any other text by
applying various fonts, font sizes, alignments, and so on. Figure 10.2 shows a
selected column, centered and bold headings, and right-aligned numbers.

Modifying a Table
You use commands in the Table menu to insert or delete rows and columns,
change cell height and width, and make other modifications. When you
modify a table element, you first must select that element. You select a row,
column, or cell the same way you select text in a table; refer to the preceding
section for more information.
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Fig. 10.2
Select text in a
table to format it.
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Inserting and Deleting Columns and Rows
Inserting columns and rows is relatively simple, after you understand how
Word does it. To insert one row, select a row in the table and open the Table
menu and choose Insert Rows. Word inserts one row before the selected row.
To insert two or more rows, select two or more rows in the table and then
open the Table menu and choose Insert Rows. Word inserts as man y rows as
you selected before the selected rows.

Similarly, to insert one column, select one column and then open the Table
menu and choose Insert Columns. Word inserts one column to the left of, or
before, the selected column. Select two or more columns to insert two or
more rows before the selected columns.
To delete a row or column, select it and then choose Table Delete Rows or
Table Delete Columns.
Adjusting Cell Height
You can change the height of a cell or the height of a row in the Cell Height
and Width dialog box. Open the Table menu and choose Cell Height and
Width. Select the Row tab. Figure 10.3 shows the Cell Height and Width
dialog box with the Row tab displayed.

Tip
The Table
menu commands change,
depen ding on
what you select
in the table.
When you
select a column, fo r example, the
Table menu
contains the
Insert Columns
and Delete
Columns commands. If you
select a cell, the
command reads
Insert Cells and
Delete Cells.
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Cell Height ond Width

Fig. 10.3
Adjust the height
of the rows and
indent or align
one row in the
Row tab of the
Cell Height and
Width dialog box.
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To adjust the height of the row, select one of the following options in the
Height of Row pop-up menu:
• Auto. Word adjusts the height of the row to the tallest cell.
• At Least. Enter the minimum row height in the At box. Word adjusts
the height of the rows to the contents of the cells.

• Exactly. Enter a row height in the At box. If the cell contents exceed the
height you entered, Word prints only what fits in the cell.
To adjust either the previous row or the next row, choose Previous Row or
Next Row. Choose either button to move from row to row as you adjust the
height of the rows. Click OK when you are finished adjusting the rows, or
continue with adjusting columns.
Note
If no row is selected when you open the Cell Height and Width dialog box, the
Height of Row option applies to all rows in the table. When you select a row, Height
of Row applies only to that row.

Tip
Click the Previous Column
and Next Column buttons
to move from
column to
column as you
adjust the
width.

Adjusting Column and Cell Width
You also can adjust column and cell width in the Cell Height and Width
dialog box. Open the Table menu and choose Cell Height and Width.
Select the Column tab (see fig. 10.4).
To adjust the column width, enter a new width in the Width of Column box.
Space Between Columns is the amount of blank space between column
boundaries and cell contents. AutoFit automatically resizes all columns in the
table to fit the contents of the cells.

Working with Charts
Fig. 10.4
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Use the Column
tab to specify each
column's width
and to add space
between columns.

Troubleshooting
I inserted several rows or columns in the wrong place.

Click the Undo button in the Standard toolbar or open the Edit menu and choose
Undo. Then select the rows or columns, keeping in mind that the new rows or
columns are inserted before the selected ones.

II

I want to add another column to the right of a table.

Position the insertion point just outside the last column and open the Table menu
and choose Select Column. Then click the Insert Columns button in the Standard
toolbar.

Working with Charts
Word includes an applet, or mini-application, called Graph that enables you
to create a chart and insert that chart into your Word document. You can use
data from a table or spreadsheet in your Word document, or you can enter
data directly into the Graph program's worksh eet.
After creating the data, you choose the chart type, add labels, and otherwise
format the chart. When the chart is finished, you embed the chart in your
Word document by using object linking and embedding (OLE), a feature that
enables programs to share information.
Embedding a chart means that the chart is part of the document; you can
resize and move the chart. You also can double-click the chart at any time to
open the Graph applet and edit the chart information.
Note
For information about OLE and embedding objects, see Chapter 29, "Sharing Data
between Applications with Unking and Embedding."

.,.. See "Linking
an Excel Chart
to a Word
Document,"
p. 614
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Creating Chart Data
You can create a chart quickly by selecting data in a table or spreadsheet in
your Word document. Alternatively, you can start the Graph applet and enter
data in the Graph datasheet. Entering data in a Graph datasheet is similar to
entering and editing data in an Excel worksheet.
Note
For more information about using datasheet--entering and editing data, getting
around in a datasheet, and so on-see Chapter 12, "Creating Worksheets."

Tip
Alternatively,
you can click
the Insert
Chart button
in the Standard
toolbar. The
Graph applet
opens, ready to
receive data.

To use existing data from a table or spreadsheet, select the data (including
headings and labels), and then start the Graph applet.

Starting Graph
To start the Graph applet, open the Insert menu and choose Object.
The Object dialog box appears. Select Microsoft Graph (see fig. 10.5).
Click OK to start the Microsoft Graph applet.

Fig. 10.5
Select Microsoft
Graph in the list
of Object Types to
open the Graph
applet.

Tip
You can select
the Datasheet
window at any
time and edit
the data. Any
changes you
make are reflected in the
Chart window
immediately.

The Microsoft Graph applet opens, as shown in figure 10.6, with a data sheet
containing the selected data in a window and a chart with data and labels
already in place in another window. Both windows appear in the Microsoft
Graph work area.

Working with Charts
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Fig. 10.6
The Graph applet
opens with a data
sheet and a chart
containing
the selected
information.

II
Note
If you did not select data before opening Graph, you see the same windows for the
datasheet and the chart; however, the data in the windows is sample data. You must
delete the sample data and enter your own.

Modifying the Chart
You can select the Chart window and use menu commands to modify the
chart-change chart types, labels, titles, axes, and so on.
Note
Microsoft Graph offers superb techniques for presenting data in chart form. This
section presents only the basics of creating a chart. Look at all the Graph menus and
experiment with all the commands, including the Gridlines command in the Chart
menu and the 3-D View and Chart commands in the Format menu.

To change the chart type, choose an option from the Chart Type menu,
which lists various chart types: Area, Bar, Column, Line, Pie, Scatter, Combination, 3-0 Area, 3-0 Bar, 3-0 Column, 3-D Line, and 3-D Pie.
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The currently selected chart type is diplayed on the Chart Type button next
to its arrow on the Toolbar. This can be seen more clearly if you look at the
Chart Type button in fig. 10.6.

Fig. 10.7
Select a 3-D
Column chart in
the Chart Gallery
dialog box.

ChortWizard- Step I

or 4

Embedding the Chart
When you are satisfied with the chart, you simply go back to work by clicking the text area outside of the chart and typing.
Figure 10.8 shows a completed graph in a Word document.
Fig. 10.8
When you want to
edit the graph,
double-click
anywhere in the
chart and the
Graph toolbar
appears.
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Note
If you choose not to update the chart before exiting the Graph applet, Graph displays a message box, asking whether you want to update. Choose Yes to update or
No to close the applet without updating the chart.

Troubleshooting
I have data in Excel, Microsoft Works, and ClarisWorks, and I want to use it in a Word
chart.

To import data from another application, open the Graph program and click the
worksheet. Click the File Import Data button (at the far left of the toolbar) and select
the file you want to import. Click OK to import the data.

II

Working with Graphics
Word includes many graphic elements that you can add to your documents,
including lines, borders, shading, and pictures. Use graphics to attract attention to your document, break the monotony of straight text, emphasize text,
and pique the reader's interest.
You can add a line above headings to make them stand out or add lines to a
table to help divide the data. Create a shaded border to attract attention to
text, or add clip art to a newsletter to make it more interesting.
You can add borders and shading to text, tables, charts, and other elements
by using the Borders tool bar. To add pictures, you use commands in the Insert menu. This section introduces adding graphics to your documents.

Adding Lines, Borders, and Shading
Word enables you to add graphic lines and bo rders with the Borders toolbar

or menu commands. The toolbar method is by far the easier method.
Displaying the Borders Toolbar
To display the Borders toolbar, place the mouse pointer on the Border button
on the Formatting Toolbar and click once, or select View Toolbars.

Figure 10.9 shows the Borders toolbar. Pop-up menus contain options for
various line thicknesses (Line Style) and various fills and screens (Shading).
The rest of the buttons enable you to specify the border's location.

Tip
Alternatively,
you can click
the Borders
button in the
Formatting
toolbar to
display the
Borders toolbar.
If you click the
Borders button
again, Word
hides the Borders toolbar.

206

Chapter 10-Working with Tables, Charts, and Graphics

Fig. 10.9
Use the Borders
toolbar to assign
borders to text,
pages, tables,
pictures, and other
elements.
Line

<tVIP<•---1

Applying a Border

To apply a border, place the insertion point where you want the line or border to appear, or select the table, picture, or frame. Choose the Line Style
pop-up menu from the Borders toolbar; select a line style. Then in the Border
toolbar, click the Border button that you want to use. When you click a Border button, Word inserts the border from margin to margin or side to side
(for objects). If you click the Border button again, Word removes the border.
Following is a list of the Border buttons:
Top Border. Inserts a border along the top of a table, frame, or
picture, or above a line of text.

Inserts a border along the bottom of a table, frame,
or picture, or below a line of text.
Bottom Border.

Left Border.

Inserts a border along the left side of the object or

text.
Right Border.

Inserts a border along the right side of the object or

text.
Inside Border.

Inserts a border along the inside lines of a table.

Outside Border.

Applies a border to the outside of any object or

frame.
Before you use this button to remove a border, select
the bordered text or object.

No Border.

Working with Graphics
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You can apply more than one border to an object or text. You can, for example, apply a 3/4-point top border and a 6-point bottom border. To that,
you can add a 3-point left and right border, creating a somewhat strange box
around the object or text. You can also apply shading to the same text or
object to which you have applied a border.
You can apply various shading and patterns by selecting the object or the
text, or by positioning the insertion point. Choose a shading from the popup Shadi ng menu in the Borders toolbar. The list provides shading that is
stepped in percentages from 5 to 100 percent (or solid). Additionally, Word
displays a variety of patterns you can apply to text or objects. The pattern list
follows the shading list.

Tip
Ad just the

length of a line
by selecting it
and moving the
indent markers
in the ruler.

Figure 10.10 shows a table with a double 3/4-point outside border, a single
3/4-point inside border, and 20 percent shading for the heading row.
Fig. 10.10
You can choose
different borders
for the inside and
outside of a table,
a nd add shading to
specific areas of
the table.

Inserting Pictures and Objects
In the preceding section, you learned to insert an object from another application: Microsoft Graph . You also can insert other ob jects, including clip art
and pictures. Pictures you can add include files from other programs, such as
Adobe Illustrator or MacDRAW!, and clip art from the MSOFFJCE folder.

II
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To add a picture to your document, open the Insert menu and choose Picture.
The Insert Picture dialog box appears (see fig. 10.11 ).

Fig. 10.11
Choose any
compatible picture
file from any
folder.
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If you want to insert clip art, the Insert Picture dialog box opens, by default,

to the Microsoft Office clip-art folder. You can select one of the files in the
File Name list. Additionally, select the Preview Picture check box to see what
the picture looks like before you add it.
If you want to use a different file type, choose List Files of Type and select the

file type you want to add. Your choices include Pict, MacPaint, TIFF, EPS,
Windows Bitmaps, and Windows Megafiles.
Select the volume and folder, and then choose the name of the file you want
to insert. Click OK to close the dialog box and insert the picture.
Figure 10.12 shows an inserted clip-art picture. Notice that a box surrounds

the picture and that small black boxes called selection handles appear at the
corners and sides of this box. The box and handles indicate that the picture is
selected. You can add borders to any selected picture or object.
Additionally, you can resize the picture by clicking and dragging any
selection handle.

Working with Graphics
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Fig. 10.12
You can insert a
picture from
Microsoft Office's
clip-art collection
or fro m a drawing
program.

II
Using Frames
Word includes a special feature that enables you to move a picture, object,
or text around on the page freely. This feature is a frame. You can insert an
empty frame anywhere on the page and then fill the frame with text or a
picture or object. Alternatively, you can insert a picture or object, select it,
and then put it in a frame.
Note
If you choose to insert a frame without selecting a picture or object, the insertion
point changes to a crosshair. Position the crosshair and drag it diagonally to draw the
frame. Release the mouse button when the frame is the right size.

After inserting the frame, you can move the frame and its contents around
the page. You also can apply borders and shading to a frame. You can move
an object, such as a picture or graph, around the page even if you do not use
a frame, but it is difficult because the object is linked to the text. Therefore, if
the object moves, the text also moves. When you insert the object in a frame,
you have much more flexibility.
Figure 10.13 shows a chart with a frame inserted. The gray border indicates
the frame. You can select a handle and resize the frame and its contents.
You also can move the frame around the page.

210

Chapter 1 0-Working with Tables, Charts, and Graphics
To insert a frame, first select the text, obj ect, or picture. Open the Insert
menu and choose Frame. If you select an object, Word inserts a frame around
th e object. If you did not select an object, the pointer changes to a crosshair.
You can then use the mouse to draw th e frame.

~

Fig. 10.13
The mouse
pointer, wh en
placed inside a
frame, becomes a
four-headed arrow.
Use this pointer to
drag the frame to a
new position on
the page.
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From Here ...
Add interest to your documents and illustrate the text by using tables, charts,
and graphic lines, borders, shading, and pictures. These chapters introduce
more advanced techniques for working in Word:
• Chapter 11, "Automating with Macros and Mail Merge," covers the use
of Word's built-in macros, creating and running your own macros, and
creating an address list and a letter for use with Word's mail merge
feature.

• Chapter 12, "Creating Worksheets," introduces you to some Excel terms
and explains how to move around in a worksheet, enter data, select
cells and ranges, and save a file.

Chapter 11

Automating wi h
Macros and M il M rge
by Peter Durso

Word supplies many features that enable you to complete your work quickly
and efficiently. Two of these features are macros and mail merge. Both of
these features save you time by automating your work; you define parameters
one time, and Word takes care of your commands time after time.
You can automate your work with macros, or mini-programs, by recording
several commands, saving the recording, and then playing it back any time
you want to perform those commands. Instead of choosing the menus and
commands yourself, the macro automatically performs the task for you with
a click of the mouse.
Word's mail merge feature also saves you time and energy. The Mail Merge
Helper guides you to create an address list and the letter or document to
merge. The Mail Merge Helper then helps you print your merged documents
easily. Because this feature is so intuitive, you should never have to dread
mail merge again.
In this chapter, you learn to
• Use Word's prerecorded macros for tables, page and text layout, and
converting files
• Create your own macros by recording, saving, and testing the macros
• Create and edit a form letter for use with mail merge
• Create the data source-address list or database-that you will merge
with the letter or other document
• Print the merged documents or save them to a file for later use

II
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Using Macros
Tip
Word records
macros in the
WordBasic language. If you
know programming, in addition
to recording your
actions to create
macros, you can
write your macros
in WordBasic.

Macros can speed your work by performing everyday tasks automatically.
A macro is a mini-program-a series of commands recorded to work as one
command. You can, for example, create a macro to assign a specific font, font
size, and alignment to selected text by pressing a shortcut key, instead of
accessing the Format menu and the Font and Paragraph commands.
Word supplies several macros you can use (if you used a complete install
program); you also can create macros to fit your personal needs. You can use
macros to speed regular editing and formatting, automate an elaborate set of
tasks, or combine several commands into one. You can even assign a macro
to a shortcut key, m enu, or button in the toolbar so that it's easier to use.
This section introduces Word's macros and explains how to record and run
your own macros.

Using Word's Macros

Tip
If your Word
folder does not
have a Macros
subfolder, you will
have to run the
Word Setup program to install the
templates.

Word provides many macros that you can use with your documents, including macros that speed formatting, create an organizational chart, or find and
replace symbols in a document. Word stores these macros in templates that
are installed in the Macros folder.
Before you can use Word's macros, you must add them as a global template.
Global templates are templates available for use with all documents. Adding

the macros as a global template, therefore, enables you to use them with any
open document.
Note
You can easily view the macro names and their descriptions in the Macro dialog box;
see "Running Predefined Macros" later in this chapter for more information.

Adding Word's Macros
To add Word's macro templates as global templates, choose the ~il e Templates
command. The Templates and Add-ins dialog box appears (see fig. 11.1).

To add the templates, follow these steps:
1. Choose Add; the Add Template dialog box appears.
2 . Change fold ers to the MACROS folder in the Microsoft Word folder and
select one of the macro templates, as shown in figure 11.2.
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3. Click OK. The templates are added to the Global Templates and Add-ins

list in the Templates and Add-ins dialog box.
Note

II

Templates in the Global Templates and Add-ins list box that are checked with an X
are loaded for use in all documents. To prevent a template from loading into all
documents, deselect that template to remove the X from its check box.
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Running Predefined Macros
You can view each template and the macros it contains in the Macro dialog
box. Choose the Tools Macro command to display the Macro dialog box (see
fig. 11.3).

To display macro names, select the macro template in the Macros Available
ln pop-up menu; all macros contained in that template appear in the Macro
Name list box. Select any macro, view the description, and choose the Run
button to start the macro.

Select the template
containing the
macros you want
to use.
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Fig. 11.3
To view a
description of a
macro, select the
macro in the list
and view the
Description box.
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Creating Your Own Macros
Even though Word's menus and toolbars provide many useful built-in
features, you probably will want to create your own macros to perform
commands you use repeatedly. You can record a macro, for example, that
automatically switches from normal to page layout view, shows the ruler,
displays the Formatting and Borders toolbars, and zooms to 100 percent.
After recording the macro, you can assign a keyboard shortcut to it. Any time
you want to perform these commands, press the shortcut keys; Word performs the commands.
Tip
You can use up to
36 characters in a
macro name;
however, the
shorter and more
concise the macro
name is, the easier
it is to remember.

To create your own macros, you first name the macro and assign a shortcut
key. Then turn on the macro recorder. Using the mouse, the keyboard, or a
combination of both, perform the commands you want to include in the
macro. Then just turn the recorder off.
Naming the Macro

You use the Tools Macro command to access the Macro dialog box (see
fig. 11.4).
Choose the Record button. Word displays the Record Macro dialog box (see
fig. 11.5). You can assign the macro to a toolbar, the menu, or the keyboard.
For more information about customizing the toolbars and menus, see Chapter 36, "Changing Toolbars and Menus."
Assigning Keys

When you choose Keyboard, for example, the Customize dialog box appears
with the Keyboard tab in view (see fig. 11.6). The insertion point is already in
the Press New Shortcut Key text box; press a key combination to use as the
shortcut.

Using Macros
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Name the macro
by entering a name
in the Macro Name
text box. Word
considers spaces,
commas, or
symbols in the
macro name to be
illegal characters.
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Press a key
combination to
assign to the
macro; don' t use a
key combination
that is already in
use.
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If the key combination is already assigned, Word displays its current use in

the Currently Assigned To area below the Press New Shortcut Key text box.
If the key combination is assigned, press the Delete key and try again. If the
combination is not assigned, choose the Assign button. Word adds the assignment to the Current Keys list box. Choose the Close butto n to begin
recording the macro.

Tip
To find an unused
key combination,
try using one
that starts with
con trol+option or
control+shift.
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Recording the Macro

Tip
You can start
and stop
recording
a macro by
double-clicking
the REC indicator in the status
bar.

Word returns to the Word screen with the Macro Recording toolbar and the
modified mouse pointer (see fig. 11. 7). Everything you do with the mouse or
the keyboard is recorded as part of the macro. Ch oose menus and commands
or click toolbar buttons to carry out the actions you want to record. You also
can enter text and format it, open or close files, and arrange windows with
macros; the possibilities are endless.
To record a macro, follow these steps:
1. Open the Tools menu and choose the Macro command. The Macro

dialog box appears.
2. Enter a name in the Macro Name text box.

3. Choose the Record button. The Record Macro dialog box appears.

Tip
If you accidentally
choose a command or enter
something you
do not want to
record, choose the
Edit Undo command. During
playback, the
macro skips anything you undo.

4. Choose to assign the macro to the Keyboard. The Customize dialog box

appears with the Keyboard tab in view.
5. Press the key combination you want to represent the macro; the key
combination appears in the Press New Shortcut Key text box.
6 . Click the Assign button and then the Close button. The dialog box
closes, and Word returns to the screen.
7. Using the mouse or the keyboard, record the commands for the macro.
8. Click the Stop Recording button in the Macro Recording toolbar.

Fig. 11.7
Choose the
commands you
want to record;
click the Stop
Recording button
in the Macro
Recording toolbar
when you finish.
Macro Recording

tnn,lh~r-'

Stops recording --+-.......J
Pauses the recorcler·-+-----1
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Running the Macro

After recording a macro, run the macro to test it. To test and run the macro,
press the shortcut key combination or choose the Tools Macro command,
select the macro name, and choose Run. Word runs the macro.
If you do not get the results you want, delete the macro and re-record it. To
delete the macro, select the macro in the Macro dialog box and choose the
Delete button. Word displays a confirmation dialog box; choose Yes to delete
the macro.
Note

Consider the position of the insertion point when creating a macro. If, for example,
the macro will check spelling, press Command+Home before choosing the Tools
Spelling command so your insertion point will be at the top of the document.

II
Writing Your Own Macros
If you are familiar with Basic programming, you can v,rrite your own macros
in Word. Word's programming capability is known as WordBasic. Although
WordBasic is not the same as Visual Basic, which is used in Excel, Word is
compatible with Visual Basic for Applications. Visual Basic for Applications is
based on the Visual Basic for Windows programming language. The advantage is that because Word is compatible, it can be controlled by another application, such as Excel. For more information about Visual Basic, see Chapter
37, "Using Visual Basic for Applications."

To write your own macro while in the Word program, choose Tools Macro.
The Macro dialog box appears. Enter the new macro name, or the name of a
macro you want to edit, in the Macro Name text box. Choose the Create/Edit
button. The button reads Create if you entered a new name in the Macro
Name text box and Edit if you entered the name of a macro that already
exists. If the macro already exists, its contents appear in the macro-editing
window.
The macro-editing window appears, with the Macro toolbar (see fig. 11.8).
You can write the entire macro in the text area, or you can use a combination
of recording and writing by using the Macro toolbar.
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Record Next

Fig. 11 .8
Use the m acro-

editing window
and Macro toolbar
to write your
own macros in
Word Basic.

Un.del:line:

Font.S i ze: 28
End Sub

Note
Word includes extensive help on programming with WordBasic. Choose Help Search
for help information. In the Type a Word text box, type macros. In the Select a Topic
text box, select WordBasic Help. Then click OK.

When you fi nish writi ng the macro, save both the macro and the template
by choosing File Save Template or by pressing Command+S. Word displays
a dialog box, asking whether you want to keep the changes in the macro.
Choose Yes. Choose File Close to close the macro-editing window and return
to the document window.
Troubleshooting
I'm recording a macro to move the insertion paint and select text; however, I cannot use
the mouse to move the cursor within the text.

The macro recorder cannot record mouse actions within document text, such as
moving the cursor, creating an insertion point, or selecting text. Use the keyboard to
record any actions within the text. You can, however, use the mouse to choose
menus and commands.

Using Mail Merge

I want to load Word's macros, but I cannot find the Macros folder.

The templates may not have been installed when you installed the program. Run the
Word Setup program to install the folder and the templates. See Appendix A, "Installing Microsoft Office," for more information.
I want to move a macro from the Normal template to another template for use in a
specific document.

Choose Tools Macro Organizer. In the Macros tab, copy any macros from the current
template to the selected template. Choose Close when you finish. Run the macro to
test your edits.

Using Mail Merge
Using Word's mail merge feature, you can personalize letters-such as announcements, change of address, advertising, and so on-so each letter contains a different name, address, and company name. In addition, you can
include the addressee's title, phone number, and other personal information.
You can even position the information in the address, salutation, or anywhere within the text.
To perform a mail merge in Word, you must complete several steps. You
identify the type of document you want to create, such as a letter. Then you
create or open a file containing the address list. You can create the address list
in Word or use an existing list from another program-Access, for example.
Next, you create the letter containing general text that is common to all
recipients; you also enter fields that represent information specific to each
recipient. Finally, you merge the address list with the letters to produce the
completed letters.

Identifying the Document
The first step in creating a mail merge is to identify the document type in
Word's Mail Merge Helper. Mail Merge Helper is an assistant of sorts that
leads you step by step through the merging process. To use the Mail Merge
Helper, choose the Tools Mail Merge command. The Mail Merge Helper
dialog box appears, as shown in figure 11.9.
Select the first option in the Mail Merge Helper dialog box: Main Document.
Then choose the Create button; a pop-up menu appears. You can create Form
Letters, Mailing Labels, Envelopes, or a Catalog. Select Form Letters to begin
the mail merge process.
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Fig . 11.9
Follow the stepby-step instructions in Mail
Merge Helper;
choose Create to
identify the
document type.
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Word displays a message box, stating that you can use the active document
window to create your letter or start a new document. If you already have a
letter typed, or if you just started a n ew document, you can use the active
document window. Otherwise, you can start a new document for the letter.
Choose the appropriate response, and Word returns to the Mail Merge
Helper. You will create the actual letter later.

Choosing a Data Source
The next step is to choose option number 2: Data Source. The Data Source is
the address list. Choose the Get Data button; a pop-up menu appears. If you
already have a database of names and addresses-in Access, for exampleselect Open Data Source. If you do not have a data source, select Create Data
Source to enter names and addresses into Word.
Opening a Data Source
If you choose to open a data source, the Open Data Source dialog box appears
(see fig. 11.10). Select the volume, folder, and file name; then click OK to
open the data source.
Fig. 11.10
The Open Data
Source dialog box
enables you to
open a data source
from another
program to use as
your address list.
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Word displays a message, asking whether you want to add fields to your main
document. Choose Edit Main Document. Word returns to the document
screen but adds the Merge toolbar for you to use. You will learn how to create
a letter doing just this in "Creating the Letter," later in this chapter.
Creating a Data Source
If you do not have an existing data source, choose Create Data Source to
enter the names and addresses in Word. The Create Data Source dialog box
appears, as shown in figure 11.11.
Fig. 11.11
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To accept all the field names in the Field Names in Header Row list, click OK.
Probably, however, you will want to remove some of Word's fields and enter
some of your own. To add your own fields, type the new names in the Field
Name text box, and then choose Add Field Name. To remove fields from the
Field Names in Header Row list, select the fields, and then choose Remove
Field Name. You might choose, for example, to keep Title, FirstName,
LastName, Company, Addressl , City, State, and PostaiCode. Click OK when
you're satisfied with the field names. Word displays the Save Data Source
dialog box (see fig. 11.1 2) .

Tip
If you have problems adding a field
name, make sure
that the name
contains no
spaces, symbols,
or punctuation.
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Select a volume and folder, and enter the file name of the data source you are
about to create. Word displays a message box, asking whether you want to enter
the records in the data source or work on the main document (the letter). Choose
to Edit Data Source; Word displays the Data Form dialog box (see fig. 11.13).

Fig. 11.13
Enter the data in
the fields for the
first record; choose
Add New to
continue.
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As you enter the data for each record, you can review records by choosing
Record and entering the record number. Additionally, you can delete records
by choosing Delete. Choose Help if you need more information about the
data form. When you finish entering records, click OK to close the Data Form
dialog box. Word displays the document screen and the Merge toolbar.

Creating the Lette r
When you finish entering data, or when you have opened a data source file, Word
displays the editing screen and the Merge toolbar, as shown in figure 11.14.
Fig. 11.14
To insert personalized information
into the document, select the
field you want to
place from the
Insert Merge Field
list.
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Type and format the letter as you normally would, with one exception: insert
a merge field wherever you want to insert personalized information. Position
the insertion point, and then click the Insert Merge Field button in the Merge
toolbar. Select the field from the drop-down list.
Be sure to add spaces, paragraph returns, and punctuation before, between,
and after the fields. Between «City>> and « State>> fields, for example,
enter a comma and a space; after the <<State>> field, enter a space or two to
separate the state and the ZIP code.
When you fi nish entering the letter and the merge fields, save the document.
Viewing Data
Use the Merge toolbar to view the data in place of the merge fields by clicking
the View Merged Data button, as shown in figure 11.1 5.

II

Go to record text box
Merge to printer

Fig. 11 .15

September 28. 1994

Mr. ~terDurso
Owner/OperatorStarStruck Sound Labs
Dear ~ter:
It is that bmeofyear agaml That"s righ~ we are heading at top
speed mto the new school year. and that means tt"s time to begin
planning for the round or reotals and pageants that 111111 start in the
winter and conllllue through next summer.

You also can use the Record buttons to view each record or specific records in
the data source. View the first, last, next, or previous record by clicking the
appropriate toolbar button. Alternatively, enter the number of the record in
the Go To Record text box in the toolbar.

Click the View
Merged Data
button to see what
the data looks like
in the letter; use
the record buttons
to view different
letters with
personalized
informati on.
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Editing the Data Source
If you find that you need to edit the data source, add a record, or delete a

record, click the Edit Data Source button (the last button on the right in the
toolbar). Clicking this button displays the Data Form dialog box, with your
records in view. Make any editing changes, and click OK to close the dialog
box. Word returns to the document.

Merging the Data and the Document
You can merge the data and the document to a new document or to the
printer by clicking buttons in the Merge toolbar. Most of the time, you will
merge your files to the printer.
Merging the files to the printer prints each letter with its personalized information. The letter file remains separate from the data source file, but the
information is merged just before printing.
If you click the Merge to New Document button, Word creates a document
containing one letter for each record in the data source. The reasons you
would merge the data to a new document are to check each letter (and perhaps add personal comments to some of the letters) and to start printing
where you left off if your printer jams.

Caution
If you have many records in your data source-hundreds or even thousands-a
merged file may be unmanageable; it could slow your system considerably.

To merge the files to the printer, click the Merge to Printer button in the
Merge toolbar.

From Here ...
Learning to use macros and mail merge can save you time and energy. You
can automate your work with macros by recording several commands, saving
the recording, and then playing it back any time you want to perform those
commands. Additionally, you can use Word's Mail Merge Helper to create an
address list and a letter, and then print your merged documents. For related
information on these topics, see the following chapters:

From Here...

• Chapter 12, "Creating Worksheets," covers common terms used in
Excel, moving around a worksheet, entering data, selecting cells and
ranges, entering series data, and saving and naming a file.
• Chapter 13, "Editing Worksheets," covers editing, copying, and moving
worksheet data; inserting and deleting columns, rows, and cells; inserting and deleting worksheets; finding and replacing data; and spellchecking text in a worksheet.

225

Quick PreL•iew

Part Ill

EHam

es Rnd Demos

Using Excel

12 Creating Worksheets
13 Editing Worksheets
14 Formatting Worksheets

~Table Wtzjr d butl•15 en 1 nt~
~e5 data from M1crosoft Ex(,

15 Using Formulas and Functions
16 Creating and Printing Reports and Charts
17 Managing and Analyzing Data

JVotTeble from d3ta 1n

18 Automating with Excel Macros

L------------~-------r---__~,11

(' E

rc• nft E eel Llst or Data
nel [late Source

rer

C rlult1 pie Con'l011dation Ran•Jt

r:

-----------

~~
Producl~

T1 p· To leern more about PwotTable..,

(

Help

) (

Cancel

)

{rN;

l.._·_ _ _

Quick Preuietll
Euamples And Demos

,n,

Auto<:h~.;.~

ll.DO D
,jr-J!CJ

..... ······:··········. ·::::;;:·:
-·:mr·:r····a·m
f:D::::
... :lli. H!it::~:::.. r·h
~ I art fE!i!i:!:!Ht::ffi!!:::::t:U
·~
E.
[1••1""1 l~l~l

I
~----

:-:.,:- ~.

--~ ~ ~""~

0

/'·
v

[jJ

0
~-k 0
Pv .c!,.
[)

-

..,1'!1 ~6£r._,

PiLtotTable Wizard n.e Pivr.rtTable 't.'uard builds f
summanc:es d.'lte from Mtcroso
iource

. =---

-

~ ~·

Create PivotTeble from ·1Ma 1 r'
(i'. M1cr~oft Ex~;d List or

(' External Data ~urce
---

C

-----rn~--::=

~

J----- -- --==-:=-=

c

Multiple Consol1dation

==--~

Tlp: To learn more about PivDt'

------ ---~----

fl?

m:

('l<

l.---H-e-1p--.J- (

Cancel

__j 1._~

_.,.
_ _ _(

Chapter 12

Creating Worksheets
by Todd Knowlton

In this chapter, you Jearn the basic techniques for creating worksheets in
Excel. Once you've mastered these techniques you'll have the confidence to
create nearly any type of worksheet.
In this chapter, you Jearn to
• Move around the worksheet
• Enter text, numbers, and formulas
• Select cells and ranges
• Repeat and undo Excel commands
• Save a worksheet

Defining Excel Terms
When you start Excel, a blank workbook appears in the document window.
The workbook is the main document used in Excel for storing and manipulating data. A workbook consists of individual worksheets, each of which can
contain data. Initially, each new workbook you create contains 16 worksheets; you can add more worksheets.
Each worksheet is made up of 256 columns and 16,384 rows. The columns
are lettered across the top of the document window, beginning with A
through Z and continuing with AA through AZ, BA through BZ, and so on
through column IV. The rows are numbered from 1 to 16,384 down the left
side of the document window.

Ill
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The intersections of rows and columns form cells, which are the basic units
for storing data. Each cell takes its name from this intersection and is referred
to as a cell address. The address of the cell at the intersection of column C and
row 5, for example, is referred to as cell C5.
At the bottom of each workbook is a series of sheet tabs, which enable you to
identify each worksheet in the workbook. The tabs initially are labeled Sheet1,
Sheet2, and so on, as shown at the bottom of the screen in figure 12.1.

Fig. 12.1
An Excel worksheet is made
up of columns,
rows, cells, and
worksheets.
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Each workbook can contain as many as 255 sheets. In Excel, you can create
up to six different types of sheets. You can create a worksheet, chart sheet,
visual basic module, dialog box, Microsoft Excel 4.0 macro sheet, and a
Microsoft Excel 4.0 international macro sheet.

Moving Around in a Worksheet
In a new worksheet, the cell at the intersection of colum n A and row 1 is
highlighted, indicating that cell A1 is the active cell. The active cell is the cell
where data appears when you type. You can move the highlight using either
the mouse or keyboard.
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Mouse Movements
Using the mouse, you can activate a cell quickly by placing th e mouse
pointer on the cell and clicking. Figure 12.2 sh ows the mouse pointer highlighting the active cell.
Fig. 12.2
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Keyboard Movements
You can use the arrow, page up, and page down keys on your keyboard, or
various key combinations, to move to another cell. The keys that you use to
move to new locations are listed in table 12.1.
N~e

·

Ill
The st andard (no n-extended) Macintosh keyboards do not have the home, end,
page up, or page down keys.

Table 12.1
Keys

Using the Keyboard to Move among Cells
Description
Moves one cell to the left, righ t, up, or down, respectively
Moves to the left edge of the current data region (*)
(continues)
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Table 12.1

Continued

Keys

Description
Moves to the right edge of the current data region (*)
Moves to the top edge of the current data region (*)
Moves to t he bottom edge of the current data region (*)

tab

Moves one cell to the right

shift+tab

Moves one cell to the left

home

Moves to column A of the active row

):(+home

Moves to cell A1 of the worksheet

):(+end

Moves to the last cell used in the worksheet

page up

Moves up one screen

page down

Moves down one screen

option+page up

Moves one screen width to the left

option+page down

Moves one screen width to the right

):(+page up

Moves to the preceding worksheet

):(+page down

Moves to the following worksheet

• A data region is a block of cells bou11ded by blank cells.

Use the Go To command to move to a specific cell. Open the Edit menu and
choose the Go To command; or press the FS function key to display the Go
To dialog box (see fig. 12.3).
Fig. 12.3
The Go To dialog
box enables you to
move to a specific
cell.
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When the Go To dialog box appears, type the address of the cell you wa nt to
move to in the Reference text box and click the OK button. To move to cell
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DS, for example, type DS and then click the OK button. The highlight moves
to cell DS, which becomes the active cell.
You also can move to a spedfic cell by using the name box, located at the left
end of the formula bar. Click the box, type the address of the cell to which
you want to move, and then press return or enter. (The formula bar is discussed in the section "Entering Data" below.)

Moving Around by Scrolling
To view another section of the worksheet without moving the active cell, use
the vertical and horizontal scroll bars to reposition the screen. Using the
mouse, click the up or down scroll arrow to scroll line by line. You also can
scroll the screen by dragging the scroll box up and down the scroll bar. If you
click the scroll bar above the scroll box, the screen scrolls up one page. If you
click the scroll bar below the scroll box, the screen scrolls down one page.
To scroll through a worksheet by using the keyboard, press the scroll lock key
on your keyboard, and use the arrow keys, page up, and page down to scroll
to the section of the worksheet you want to view. To move greater distances
while scroll lock is on, press the j::t key in combination with the arrow keys.
Scrolling moves the screen but does not change the active cell.

Entering Data
After you activate the cell in which you want to enter data, you can type text,
numbers, dates, times, or formulas in the cell. As you type, the data appears
in the active cell and in the area above the worksheet called the formula bar
(see fig. 12.4). The cell displays the insertion point, a blinking bar that indicates where the next character you type will appear. If you click in the formula bar, the insertion point will appear there, rather than in the cell.
When you are entering data, three small buttons appear between the name
box and the insertion point in the formula bar. The first two buttons enable
you to reject or accept the data you entered. To reject your entry, click the
cancel box or press esc. To accept your entry, click the enter box or press
enter to leave the same cell active. You can press return to accept the data as
well as move the highlight to the cell below.
The third button in the formula bar activates the Function Wizard, a dialog
box that enables you to build formulas by using Excel's built-in functions.
Chapter 15, "Using Formulas and Functions," describes how to enter formulas with the Function Wizard.

np
If you want to see

the active cell
when it is not
visible in the
current window,
press ~+delete.
The window scrolls
to display the
active cell and
selected ranges
remain selected.
This works
whether scroll
lock is on or off.
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Enter box: Click here to accept data
. - - - - - - - -Click here to activate the
Function Wizard
Fig. 12.4
When you enter
data in a cell, the
data appears in
the cell and in
the formula bar.
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Entering Text
Text entries consist of alphanumeric characters such as letters, numbers, and
symbols. You can enter up to 255 characters in a single cell, although Excel
may not be able to display all the characters if the cell is not wide enough or
if an entry appears in the cell to its right. When you enter text in a cell, Excel
stores that entry as text and aligns it to the left edge of the cell.
When you enter data that consists of numbers and text, Excel evaluates the
entry to determine its value. If you type an entry such as 1098 Adams Street,
for example, Excel automatically determines that it is a text entry because of
the letters.
If you want to enter a number as text, such as a ZIP code, precede the entry
.,.. See "Changing
Column Width
and Row
Height," p. 276
.,.. See "Formatting Numbers,"
p.269

with an apostrophe. Excel uses the apostrophe label prefix to denote a text
entry. You can use the apostrophe when you want to enter a number but do
not want Excel to interpret it as a value to be used in calculations.

Entering Numbers
Numeric entries are constant values and consist only of numeric values. You
can enter integers (such as 124), decimal fractions (such as 14.426), integer
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fractions (such as 1 1/5), and values in scientific notation (such as 1.23E+08).
Numbers are aligned with the right edge of the cell.
If you enter a long number in a cell and the cell displays ##### or the number
appears in scientific notation (1.23E+08), the current column width is too
small to display the number in its entirety.

Entering Dates and Times
In addition to entering text and numbers, you can enter dates and times in a
worksheet cell. When you enter a date or time, Excel converts the entry to a
serial number. This serial number represents the number of days from january 1, 1904 to the date you type.
Because Excel converts dates and times to serial numbers, you can perform
calculations on these values as you would with any number. For example,
you could determine the number of days that have passed between two dates.
To enter a date, type the date using any of these formats:
3/12/94
12-Mar-94
12-Mar
Mar-12
To enter a time, use any of these formats:
14:25
14:25:09
2:25PM
2:25:09 PM

Entering Formulas

Tip
To quickly enter
the current date in
a cell, hold down
the :Fe key and
press - (hyphen).
To enter the current time, hold
down the :Fe key
and press;.

One of the most valuable features of Excel is its capability to calculate values
by using formulas. Excel formulas can range from the simple, such as adding
a range of values, to the complex, such as calculating the future value of a
stream of cash flows.
You can calculate values based on numbers that you type directly into the
formula. For example, you can enter the formula =4+5+7 to add the values 4,
5, and 7. However, the power of Excel's formula capability lies in the fact that

..,. See "Creating
Formulas,"
p.297
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formulas also can refer to data in other cells in the worksheet. The formula
=B2+B3+B4, for example, adds the values in cells B2, B3, and B4. When the
values in these cells change, Excel automatically updates and recalculates the
formula, using the new data in these cells.
Excel recognizes a formula in a cell if the entry starts with an equal sign(=) or
a plus sign(+). To enter a formula, first type = and then type the formula. The
active cell and the formula bar display the formula as you enter it. After the
formula is complete, press return; the active cell displays the result of the
formula (see fig. 12.5). The formula bar continues to show the formula when
the cell is the active cell.
Formula

Fig. 12.5
When you enter a
formula in a cell,
Excel displays the
result.
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Troubleshooting
A formula used to colculate a range of cells does not calculate properly.

Make sure that values in the range have not been entered as text. To do so, highlight
each cell in the range, and check for the appearance of an apostrophe at the beginning of the entry. If an apostrophe appears, press l=e+U to enter edit mode, delete
the apostrophe, and press return. Continue with these steps until all cell entries have
been checked.
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Excel converted a date to a number.

You must enter dates in a format that Excel recognizes-for example, 3/12/94 or
12-Mar-94. Other characters may not produce a valid date. Sometimes a cell in
which you enter a date may already contain a numeric form at. Use the Cells command in the Format menu to assign a different format.
A formula appears as a label in a cell.

If you neglect to enter an equal sign or plus sign in front of a cell reference, Excel
interprets the entry as a label. To fix this problem, highlight the cell and press ~ +U.
Then press the home key, type the equal sign, and press return.

Selecting Cells and Ranges
Many commands in Excel require that you select a cell or range of cells. You
already have learned how to select a single cell. You also can select several
cells at the same time. A group of cells is called a range. A range is a group of
cells that can be acted upon with Excel commands.
You can use the keyboard or the mouse to select a range. To select a range
with the mouse, follow these steps:
1. Point to the first cell of th e range you want to select.
2 . Drag the mouse over the range.

3. When you reach the end of the selection range, release the mouse
button.
To select a range with the keyboard, follow these steps:
1. Move to a cell at a corner of the range you want to select.

2. Press and hold down the shift key, and then press the arrow keys to
select the range.
Figure 12.6 shows a selected range.
Note
If you select a range of cells and then click the mouse in a cell, the range is deselected. If this happens, just select the range again.

Ill
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Active cell

Selected range

Fig. 12.6
The first cell of the
selected range is
the active cell and
has a white
background.

Excel also enables you to select more than one range of cells at a time with
the same ease as selecting a single range.
To select multiple ranges with the mouse, follow these steps:
1. Drag the mouse over the first range you want to select.

2. Press and hold down the ;)::( key, and continue selecting other ranges.
To select multiple ranges with the keyboard, follow these steps:
1. Press and hold down the shift key, and use the arrow keys to select the

first range.
2. Press shift+F8. The indicator ADD appears in the status bar at the bottom

of the screen indicating that you can extend a selection.
3. Move to a cell at a corner of the next range you want to select.
4. Press shift and an arrow key to select the range. ADD disappears from the

status bar. To add another range, press shift+F8 to go back to add mode,
and repeat steps 3 and 4.
To select the entire worksheet, click the rectangle directly above the row
numbers and to the left of the column headings, or press :l=e+s hift+space bar.
To deselect a range, click any cell outside the range.

Selecting Cells and Ranges
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Caution
When you select an entire worksheet, any command or action you perform affects
the worksheet as a whole.

To select an entire row, click the heading of the row you want to select. You
also can highlight a cell in the row you want to select and press shift+space
bar. Figure 12.7 shows two ranges selected in a worksheet.
~
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Two nonadjacent
ranges are selected
at the same time.
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To select an entire column, click the heading of the column you want to
select. You aJso can highlight a cell in the column you want to select and
press ):(+space bar (see fig. 12.8) .
Note
Some Excel commands require a specific action before you can use the command.
If you do not cut or copy something to the Clipboard, for example, the Paste command in the Edit menu is not available and appears grayed (dimmed). If an object is
not selected, the commands that are relevant only to selected objects are dimmed
and unavailable.
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Fig. 12.8
Click a column
heading to select
entire column;
click a row
heading to select
entire row.
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Entering a Series of Text, Numbers,
and Dates
When creating budgets and forecasts, you often need to include a series
of dates, numbers, or text. Excel relieves this tedious task by offering the
AutoFill feature, which enables you to create a worksheet quickly by filling a
range of cells with a sequence of entries. For example, you can fill a range of
cells with consecutive dates or create a series of column headings.
You can create a series of entries in two ways: use the mouse to drag the
A utoFill handle (the small square at the bottom right corner of the active cell),
or open the Edit menu, choose Fill, and then choose the Series command.

Creating a Series of Text Entries
Excel recognizes common text entries, such as days, months, and quarterly
abbreviations.
To fill a range of cells with text entries, follow these steps:
1. Select the first cell that contains the data.

2. Drag the AutoFill handle over the range of adjacent cells that you want
to fill (see fig. 12.9). The pointer becomes a large+ when positioned
over the AutoFill handle.
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3. Release the mouse button. Excel fills the range of selected cells with the
appropriate text entries (see fig. 12.10).

Fig. 12.9
The AutoFill
h and le is dragged
to the right to
create a series of
column headings.
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Fig. 12.10
Excel fills the
selected range of
cells with a series
of column
headings.
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Excel's AutoFill feature recognizes numbers, dates, times, and key words, such
as days of the week, month names, and quarterly abbreviations. Excel knows
how these series run and correctly extends the series. Table 12.2 shows examples of series that Excel can use with Autofill.

Table 12.2 Fill Sequences
Data You Enter

Sequence Returned

Qtr 1

Qtr 2, Qtr 3, Qtr 4

Product 1

Product 2, Product 3, Product 4

1993

1994, 1995, 1996

jan

Feb, Mar,Apr

]an-93

Feb-93, Mar-93, Apr-93

Mon

Tue, Wed, Thu

2,4

6, 8, 10

Creating a Series of Numbers
You can enter a series of numbers that increment by 1 or that increment by
values that you specify.
To fill a range of cells with a series of numbers, follow these steps:
1. Enter the starting number in the first cell of the range. If you want to
increment the numbers by a value you specify, enter the first two values
in adjacent cells.

Tip
To prevent a series
from incrementing. hold down
the option key as
you drag the
AutoFill handle.

Excel uses these two values to determine the amount to increment in
each step.
2 . Select the range containing the numbers.

3. Drag the fill handle over the range of adjacent cells you want to fill.
4 . Release the mouse button. Excel fills the range of selected cells with the
appropriate numeric entries (see fig. 12.11).
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To increment by a value other than 1, enter desired
values in the first two cells of the range.

Fig. 12.11
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100.
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Creating a Series of Dates
You can fi ll a range of cells with a series of consecutive dates that increment
by a specific value.
To fill a range of cells with dates, follow these steps:
1. Enter the starting date in the first cell in the range. If you want to incre-

ment the date by a specific value, enter the appropriate date in the next
cell in the ran ge.
2. Select the range containing the dates.

3. Drag the AutoFill handle over the range of adjacent cells you want
to fill.
4. Release the mouse button. Excel fills the range of selected cells with the

appropriate dates (see fig. 12.12).
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Fig. 12.12
The AutoFill
handle created this
series of dates in
increments of one
week.

~ file

Edit

Ulew Insert Format Tool s Data

Window

6:32PM

I1J 5

m

~~llt~11$1®1~1~.H!J~(ffi!lli1K1111J~I!•oo•
1~
p;e,..,.
18 ITD8 L!I!I!) IP:1•11111mll111l%JI, ),:dllk~lli8El~[jjg
9/1 / 1994
Workbook!

K

1:

-.---- L

ShoelZ

5Jl00t3

Entering a Series with the Edit Fill Series Command
The Series command enables you to fill a range of cells with greater precision
than with the AutoFill handle. For example, with the Series command, you
can specify a stop value as well as a start value.
To fill a range of cells with the Series command, follow these steps:
1. Enter the starting number or date in the first cell of the range you want
to fill.
2. Select the range of cells you want to fill.

3. Open the Edit menu, choose Fill, and then choose Series.
The Series dialog box appears (see fig. 12.13).
Fig. 12.13
In the Series dialog
box, select the
type of series and
the step and stop
values.
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4. Specify the Type of series you want to create.
5 . If you are creating a series of dates, specify the Date Unit.
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6. Enter the Step Value. This value represents the amount by which the
series changes from cell to cell.
7. Enter the Stop Value. This value represents the last value in the series.
(If the number of stops is more than or less than the range of cells se-

lected, it stops short or stops early.)
8. Click OK.

Troubleshooting
AutoFi/1 filled the entire range with the same label entered in the first cell of the range.

When Excel cannot recognize the correct pattern for entering labels, AutoFill copies
the starting label to the entire range. Make certain that the starting label is one that
AutoFill can recognize. For example, Qtr 1 or January.
I tried to use AutoFi/1 to extend a series, but numbers were not incremented by the
difference of the first two numbers of my series.

If the increment in the AutoFill range was 1, you probably d id not select the first two
cells before using AutoFill. Be sure to select the two cells because that is what Excel
uses to determine the increment or it defaults to 1 . If the increment was not the
difference between your first two cells or 1, you probably selected more than two
cells and Excel averaged the difference to determine the increment. Again, be sure to
just select two cells.

Repeating and Undoing a Command
Excel has a built-in safety net that enables you to reverse many commands or
actions. The Undo command reverses the last command you selected or the
last action you performed. To undo a command or action, open the Edit
menu and choose Undo, click the Undo button on the toolbar, or press ~+Z.
No~

·

Excel retains only the last action or command. You must choose the Undo command
immediately after the command or action.

Undo is not available for all commands. If you choose Delete Sheet from the
Edit menu and delete a worksheet from a workbook, for example, the Edit
menu shows Can't Undo as a dimmed command. Although Undo can reverse
many actions, you still must use certain commands with caution.
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To reverse the Undo command, choose Redo from the Edit menu, click the
Undo button on the toolbar again, or press ~+Z again.
Excel also enables you to repeat the last command or action you performed.
To repeat a command or action, choose Repeat from the Edit menu, click the
Repeat button on the tool bar, or press ;):C+Y.

Saving Workbooks
When you create a new workbook, Excel assigns to it a temporary name. You
must save the file to disk to make the workbook permanent. To save a file in
Excel, choose Save from the File menu, click the Save button on the toolbar,
or press ~+S. Enter a name for the file and specify the location to which the
workbook should be saved.
<1111

See "Working
with Files,"
p.61

In addition to saving new workbooks, you can also save files to other file
formats, such as older versions of Excel and several Lotus 1-2-3 formats.
Excel also enables you to save workbook settings in a workspace file.

Saving Files to Other File Formats
In the Save dialog box, you can use the Save File as Type drop-down list to
save an Excel file in another file format. To save an Excel file for use in Lotus
1-2-3, for example, drop down the Save File as Type list, and then select the
1-2-3 Lotus file format you want (see fig. 12.14).
Fig. 12.14
You can save an

Excel file in a
1-2-3 file format.
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If you use a worksh eet feature that is not supported by earlier versions of

Excel or other spreadsheets, the value result of that feature is calculated and
saved with the worksheet.

Saving a Workspace File
If you work with the same set of workbooks on a daily basis, Excel enables
you to save information about what workbooks are open an d how they are
arranged on-screen. The next time you want to work with these workbooks,
you only need to open the workspace file, and all the workbooks are opened
and arran ged as they were when you saved the file.
The Save Workspace command in the File menu creates a workspace file that
contains the name and location of each workbook in the workspace and the
position of each workbook when the workspace was saved.
To create a workspace file, follow these steps:
1. Open and arrange the workbooks as you want them to be saved in the

workspace.
2 . Open the File menu and choose the Save Workspace command.
The Save Workspace dialog box appears (see fig. 12.15).

3. Type a name for the file in the Save As box.
4 . Click Save.
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Note
When you create a workspace file, do not move any of the workbook files to a new
location. If you do, Excel will not be able to locate the files when you open the
workspace file.

Fig. 12.15
Type a name fo r
t he workspace
file in the Save
Workspace
dialog box.
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You can open a workspace file just as you do any other Excel file. After you
have opened the file, you can save and close the individual workbooks in the
workspace as you normally do. When you make changes to a workbook in
the workspace, you must save the file using the Save command. The Save
Workspace command saves only information on which workbooks are open
and how they are arranged on-screen.

From Here ...
In this chapter, you learned the basic skills for creating and working with
Excel worksheets. For more information about working with worksheets and
data, see the following chapters:
• Chapter 13, 11 Editing Worksheets," shows you how to edit worksheet
data.
• Chapter 14, 11 Formatting Worksheets," presents the formatting features
of Excel that enable you to improve the appearance of data in the
worksheet.
• Chapter 15, 11 Using Formulas and Functions," teaches you how to create
formulas and use Excel's built-in functions to calculate values.
• Chapter 16, 11 Creating and Printing Reports and Charts," shows you
how to print Excel worksheets and how to present worksheet data in
graphs.
• Chapter 17, ''Managing and Analyzing Data," explains how to manage
lists of information and how to analyze worksheet data.
• Chapter 18, 11 Automating with Excel Macros," shows you how to create
macros to automate Excel features.

Chapter 13

Editing Wor
by Todd Knowlton

After creating a worksheet, you will spend the majority of your time editing
the work you have done. You may need to move data from one area of the
worksheet to another, or you may want to copy a range of data. This chapter
presents the basics for editing a worksheet in Excel.
In this chapter, you learn to
• Edit the contents of a cell
• Clear the contents of a cell
• Copy, cut, and paste worksheet data
• Insert and delete columns, rows, and worksheets
• Find and replace worksheet data
• Spell-check your worksheet

Ill

Editing Worksheet Data
After you enter data in a cell, you can edit the contents of the cell. You can
edit the contents using the formula bar, or you can use Excel's in-cell editing
feature to edit the contents directly in the cell.
Note
To use the in-cell editing feature, you must make sure the feature has been enabled.
To double-check, open the Tools menu, choose the Options command, and choose
the Edit tab. The Edit Directly in Cell option should be selected. If it isn't, click the
check box to the left of the option. Click OK when you finish.
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Editing an Existing Cell Entry
.,.. See "Formatting Numbers,"

p.269

To edit the contents of a cell in the formula bar, firs t select the cell you want
to edit, and then click the formula bar. The contents of the cell appear in the
formula bar with a blinking insertion point.
To edit the contents of a cell directly in the cell, double-click the cell,
or select the cell you wan t to edit and press )::(+U.
To edit the entry, use the left and right arrow keys to reposition the insertion
point in the formula bar, or move the mouse and use the on-screen !-beam to
reposition the insertion point in the formula bar or in the cell. The insertion
point appears where the !-beam is positioned when you click the mouse.
Press delete to delete characters to the left of the insertion point. If your keyboard has the forward delete key (del), shown in figu re 13.1, you can use it to
delete characters to the right of the insertion point.

Fig. 13.1
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When editing a cell, you can reposition the insertion point by using the
mouse or the keyboard . Table 13.1 lists the editing keys on the keyboard.
You must press ):C+u before using the ed iting keys.

Table 13.1
Key

Editing Keys
Action
Moves one character to the left.
Moves one character to the right.
Moves to the next word.
Moves to the preceding word.

end

Moves to the end of the cell entry.

delete key

Editing Worksheet Data

Key

Action

home

Moves to the beginning of the cell entry.

del

Deletes next character to the right.

delete

Deletes next character to the left.
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Deleting Worksheet Data
In addition to editing the contents of a cell, you can delete the data in a cell.
To replace an existing cell entry, select the cell and type the new entry. When
you do, the new entry replaces the current contents of the cell. If you want to
delete the contents of a cell or range altogether, the easiest way to do it is to
select the cell or range of cells and then press the del key. When you do,
Excel clears the contents of the cell or range.

Clearing Cell Contents
When you use the delete key to clear a cell, Excel clears the contents of the
cell, but the formatting is unchanged. The Clear commands, on the other
hand, enable you to clear the format and notes from the cell.
To clear the contents of a cell or range, select the cell or range and then
choose a command from the Clear submenu on the Edit menu, shown in
figure 13.2.
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Fig. 13.2
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~

See "Changing
Fonts, Sizes,
and Styles,"
p.28S

~

See "Annotating Worksheets," p. 392

Choose All to clear everything from the cell, including cell formatting and
cell notes. Choose Formats to clear only cell formatting from the cell. To clear
the contents of a cell, but leave formatting and cell notes intact, choose Contents. To remove only cell notes from a selected range of cells, choose Notes.

Caution
A common error many new users make when clearing cells is selecting the cell and
then pressing the space bar. Although the cell may appear to be blank, Excel actually
is storing the space in the cell. Spaces can cause problems in worksheet calculations.
Don't press the space bar to clear a cell. Instead, use the methods outlined in this
section.

Copying Worksheet Data
Excel provides several options for copying worksheet data. You can copy data
by using the drag-and-drop method, copy data to the Clipboard, or copy data
to adjacent cells by using the AutoFill feature.

Copying Data with Drag-and-Drop
The quickest way to copy worksheet data is to use the drag-and-drop method.
As its name implies, you simply drag the data you want to copy to another
area of the worksheet.
~

~

See "Copying
and Moving,"
p.43
See "Copying

To copy data with drag-and-drop, follow these steps:
1. Select the range of cells you want to copy.

2. Position the mouse pointer on the border of the selected data.

Formulas,"

p.312

3. Hold down the option key, and drag the selection to the new location.
When you press the option key, the mouse pointer appears as an arrow
with a plus sign(+) next to it.
As you move the mouse pointer, Excel displays an outline indicating
the size and location of the copied data (see fig. 13.3).
4. Release the mouse button to drop the copied data in its new location.

Copying Worksheet Data
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Copying Data with Copy and Paste
When you need to make multiple copies of worksheet data, the easiest way is
to use the Copy and Paste commands. When you use the Copy command, a
copy of the selected data is stored on the Clipboard. You then can paste as
many copies in the worksheet as you need.

~

See "Copying
and Moving,"

p.43

To copy data using Copy and Paste, follow these steps:
1. Select the range of data you want to copy.
2. Open the Edit menu and choose the Copy command, or press

~ +C.

Ill

You also can choose the Copy command by clicking the Copy button
on the toolbar.
A marquee surrounds the selection you copied, and the status bar at the
bottom of the screen prompts you to select the location to copy the
data to (see fig. 13.4).
3. Select the cell in which you want to paste a copy of the data.
4. Open the Edit menu and choose the Paste command, press ~+V, or
click the Paste button on the toolbar. If you want to paste a single copy

of the selection, press enter on the numeric keypad.

le,J
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Fig. 13.4
A marquee
surrounds the
copied data.
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Note
As long as the marquee surrounds the copied data, you can continue to use the Paste
command to paste copies of the data in the worksheet. If you press enter to paste a
copy of the data in the worksheet, Excel clears the copied data from the Clipboard.

Copying Data with AutoFill
The AutoFill command lets you copy cell contents to adjacent cells quickly.
As a bonus, if the entry consists of a date, day of the week, or alphanumeric
item such as Product 1, Excel automatically extends the series in the selected
cells (see fig. 13.5).
~

See "Ente ring a
Series of Text,
Numbers, a nd
Dates," p. 240

To use the AutoFill command to copy data, follow these steps:
1. Select the cell that contains the data you want to copy.

2 . Position the mouse pointer on the fill handle that appears in the lower
right corner of the cell.

3. Drag the fill handle over the adjacent cells in which the copied data
will appear, and release the mouse button.
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Fig. 13.5
The AutoFill
command fills the
selected cells with

a series.
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Copying and Applying Formats
Another option for copying data in your worksheet is to copy cell formatting
from one range to another. This feature is handy if you want to apply formatting to a range of cells but don't want to create a style.

.,._ See "Creating
and Applying a

Style," p. 290

To copy formatting from one range to another, follow these steps:
1. Select the range of cells that contains the formatting you want to copy.
2. Click the Format Painter button on the toolbar, or double-click the
button if you want to apply the formatting to more than one range.
Figure 13.6 shows the result of using the Format Painter.

3. Select the cell or range of cells where you want to apply the formatting.
When you release the mouse button, Excel applies the formatting.
4. Continue selecting each additional range of cells. If you douhle-clicked

the Format Painter button, click the button again to turn off the feature.

Ill
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Fig. 13.6
With the Format
Painter button you
can copy formatting from one
range of cells to
another.

Selected range to which
formats will be copied

Mouse pointer while copying
formats with the Format Painter

Troubleshooting
I tried to copy data, using drag-and-drop, but it wasn't working. Excel would just select
the range of cells rather than copy the data.

The cell drag-and-drop feature is probably turned off. To check, open the Tools
menu and choose the Options command, and then click the Edit tab. Make sure that
the Allow Cell Drag and Drop check box is selected (if it is, an X appears in the check
box). Click OK.
If the drag-and-drop feature is enabled, remember that you must drag from the outer
edge of the selected range.
I used the Copy and Paste commands to copy a range of data in my worksheet. I pressed
enter to paste the data in the new location, and it worked without a hitch. But when I
tried to use the Paste command to paste another copy, the Paste command was
unavailable.

When you use the Copy command to move a range of data, Excel does indeed copy
the data to the Clipboard. But when you press enter to paste the data, Excel clears
the contents of the Clipboard. Notice also that the marquee surrounding the data
disappears.
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If you want to paste multiple copies of the data in the worksheet, don't press the
enter key to paste the data. Instead, continue to choose the Paste command to paste
the copies in the worksheet. You can use the enter key to Paste the final copy.

I tried to copy a range of data by using AutoFi/1, but I just moved the selected cell when I
dragged it.
You probably dragged the edge of the cell rather than the AutoFill handle. The
AutoFill handle is located on the lower right corner of the cell, and the mouse pointer
changes to a solid plus sign(+) when placed on the AutoFill handle.

Moving Worksheet Data
As with copying, you can move worksheet data from one area of the
worksheet to another. You can use the drag-and-drop method to move a
range of data quickly, or you can use the Cut and Paste comma nds to cut a
range of data and paste it in another location.

Moving Data with Drag-and-Drop
Unlike copying data, which enables you to copy a range of data while keeping the source data intact, when you use the drag-and-drop method to move
data, you are physically moving the range of data from one area to another.
To move a range of data with drag-and-drop, follow these steps:
1. Select the range that contains the data you want to move.

2. Position the mouse pointer on the border of the selected data.

3. Click and drag the selection to the new location. As you move the
mouse, a border appears in the worksheet, indicating the location in
which the data will appear.
4. Release the mouse button to drop the selected data in the new location.

Note
Excel does not allow you to accidentally overwrite existing data w hen you use dragand-drop. An error message appears, warning you that you are about to overwrite
existing data. Choose Cancel and indicate a new position, or click OK if you want to
overwrite cells.

Ill
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Moving Data with Cut and Paste
When you use the Cut (;}:(+X) command to move worksheet data, a copy of
the data is stored on the Windows Clipboard. You then can paste the data in
another area of the worksheet.
To move data using the Cut command, follow these steps:
1. Select the range of data you want to move.

2. Open the Edit menu and choose the Cut command, press :l=1:+X, or click
the Cut button on the toolbar.
A marquee surrounds the selection you cut, and the status bar at the
bottom of the screen prompts you to select the location where you
want to paste the data.
3. Select the cell in which you want the data to appear, and then choose
the Paste command from the Edit menu, press ;}:(+V, or click the Paste
button. You also can press enter.
Note
When using the Paste command to paste data from the Clipboard, indicate a single
cell, rather than a range of cells, in which to paste the data. If you select a range of
cells, the range you select must be the same size as the range you placed on the
Clipboard.

Troubleshooting
I tried to move a range of data by using drag-and-drop, but the data I was trying to
move was instead copied to the range of cells I wanted it to move to.

You probably dragged the AutoFill handle rather than the edge of the cell. The
AutoFill handle is located on the lower right corner of the cell and is used to quickly
fill a range of cells with the data. When the mouse is positioned on the AutoFill
handle, the mouse pointer changes to a solid plus sign(+) instead of an arrow.
To move the data, position the mouse pointer on an edge of the cell, and then d rag
the mouse to move the data.
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Note
When copying and moving formulas, keep in mind that Excel adjusts cell references
in the formula to reflect the new location. See Chapter 15, " Using Formulas and
Functions," for more information.

Inserting and Deleting Columns,
Rows, and Cells
Another area of editing you can work with in Excel is inserting and deleting
columns, rows, and cells. Sometimes, restructuring a worksh eet entails more
than moving data to another location. For example, if you add another sales
region to your sales tracking worksheet, you can insert a new column to hold
the data. Likewise, if you remove a product from your product line, you can
delete the rows that contain the data.

Inserting Columns, Rows, and Cells
When you need to insert additional space in your worksheet, you can insert
columns, rows, and cells in the middle of existing data. When you insert
columns, rows, and cells, existing data shifts to accommodate the insertion .
To insert a column, follow these steps:
1. Select a cell in the column where the new column should appear.

2. Open the Insert menu and choose the Columns command. Excel inserts
a new column, and existing columns shift to the right.
To insert a row, follow these steps:
1. Select a cell in the row below where the new row should appear.

2. Open the Insert menu and choose the Rows command. Excel inserts a
new row, and existing rows move down.
To insert a cell or range, follow these steps:
1. Select the cell or range where the new cells should appear.

2. Open the Insert menu and choose the Cells command. The Insert
dialog box appears (see fig. 13.7).

Ill
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3. Select Shift Cells Right to insert the new cells to the left of the selection.

Select Shift Cells Down to insert the new cells above the selection.
4. Click OK. The selected cells move in the direction you specified.
Fig. 13.7
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Deleting Columns, Rows, and Cells
You can delete columns, rows, and cells from your worksheet when they
contain data that is no longer needed. When you delete columns, rows, and
cells, existing data moves to close the space.
To delete a column, follow these steps:
1. Click the letter of the column you want to delete. To delete multiple
columns, highlight each additional column.
2. Open the Edit menu and choose the Delete command. The selected
column is removed from the worksheet, and existing columns move to
the left.

To delete a row, follow these steps:
1. Click the number of the row you want to delete. To delete multiple
rows, highlight each additional row.
2. Open the Edit menu and choose the Delete command. The selected row
is removed from the worksheet, and existing rows move up.

Caution
Use care when using commands that insert or delete cells. When you use these
commands, the entire worksheet is affected by your action. If a formula refers to a
cell that is deleted, for example, the cell containing the formula returns the #REF!
error value. If this occurs, choose the Undo command from the Edit menu immediately after making a deletion.

To delete a cell or range of cells, follow these steps:
1 . Select the range of cells you want to delete.

Inserting and Deleting Sheets
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2. Open the Edit menu and choose the Delete command. The Delete
dialog box appears (see fig. 13.8).
3. Select Shift Cells Left, and the existing data will move to the left.
Choose Shift Cells Up, and the existing data will move up.
4. Click OK after you make your selection.

Fig. 13.8
In the Delete
dialog box, specify
the direction in
which the existing
cells should move.

Inserting and Deleting Sheets
Excel 5.0 provides true 3-D functionality, which enables you to create workbooks that contain multiple sheets of data. Each new workbook you create
contains 16 worksheets; but you can insert worksheets up to a maximum of
255 worksheets. You can also delete worksheets you no longer need.

Inserting Sheets
When you insert a worksheet, Excel inserts the sheet before the current
worksheet. To insert a worksheet, select the sheet to the right of where the
new worksheet should appear, and choose the Worksheet command from the
Insert menu. Excel inserts a sheet and assigns a name to the sheet.

Deleting Sheets
To delete a sheet, move to the sheet you want to delete, and then choose the
Delete Sheet command from the Edit menu. You will be warned that the
sheet is about to be deleted. Click OK to delete the sheet or Cancel to keep
the sheet in the workbook.

Moving Sheets
In addition to inserting and deleting sheets, you can rearrange worksheets in
the workbook by moving them to a new location.
Excel employs the drag-and-drop method for moving sheets. To move a
sheet, point to the tab of the sheet you want to move. Hold down the mouse
button, and drag the sheet to the new position in the workbook. While dragging, the mouse pointer appears as a piece of dog-eared paper with an arrow
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on it. When you release the mouse button, the sheet is dropped in its new
location .

Naming Sheets
Initially, Excel names each worksheet in the workbook Sheetl, Sheet2, and so
on, right on up to Sheet255. You can, however, easily rename a sheet to reflect the data it contains. In a Monthly Sales worksheet, for example, you can
use a separate sheet for each sales region. You then could name each sheet
North, South, East, and West. Thereafter, anyone else who uses the worksheet
will be able to tell what the worksheet contains just by looking at the name.
To rename a worksheet, double-click the sheet tab of the worksheet you want
to rename. The Rename Sheet dialog box appears (see fig. 13.9).
Fig. 13.9
Type a name for
the worksheet in
the Rename Sheet
dialog box.
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Enter a name for the worksheet in the text box, and click OK. Excel displays
the name on the selected sheet's tab.

Finding and Replacing Worksheet
Data
Excel provides the capability to find and (optionally) replace specific data in
your worksheet. You can, fo r example, search for all occurrences of the value
1994 and replace it with 1995.

Finding Worksheet Data
You can search th e entire worksheet, or you can search only a selected range.
To search the entire worksheet, select a single cell. To search a specified
range, select the range that you want to search .
1 . Open the Edit menu and choose the Find command, or press ):C+F.

The Find dialog box appears (see fig. 13.10).
2. In the Find What box, type the data you want to find. Then specify the
search options, described in table 13.2 (which follows these steps).
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3. Choose Find Next to begin the search. When Excel locates the charac-

ters, choose Find Next to find the next occurrence, or choose Replace
to access the Replace dialog box (this option is discussed in the next
section).
4. Choose Close to end the search and close the dialog box.
Fig. 13.10
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If you're not sure of the specific string you are looking for, you can specify wild-card
characters in the search string to locate data that contains some or all of the characters. You can use an asterisk (*) to search for any group of characters and a question
mark (?) to search for any single character.

Table 13.2

The Find command enables you
to locate specific
data in your
worksheets .

Find Options

·

Option

Action

Search

Specifies whether to search across rows or down
columns.

Look In

Selects the location of the data: cell formulas, cell
values, or cell notes.

Match Case

Finds only characters that match the case of the
characters you specified.

Find Entire Cells Only

Searches for an exact match of the characters you
specified. It does not find partial occurrences.

Find Next

Finds the next occurrence of the search string.

Close

Ends the search and returns to the worksheet.

Replace

Opens the Replace dialog box (discussed in the next
section).

Tip
If the Find
dialog box is
obstructing
your view of
the worksheet,
click and drag
the title bar of
the dialog box
until you can
see the active
cell in the
worksheet.
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Replacing Worksheet Data
The Replace command (~+H) is similar to the Find command in that it
enables you to locate specific characters in your worksheet. The Replace
command then lets you replace the characters with new data.
To replace worksheet data, follow these steps:
1. To search the entire workbook, select a single cell. To search a specified

range, select the range you want to search.
2. Open the Edit menu and choose the Replace command; or press

~+H.

The Replace dialog box appears (see fig. 13.11).
3. In the Find What box, type the data you want to replace. In the Replace

With box, type the data with which you want to replace th e current
data.
4. Specify the replace options, as described in table 13.3 (which follows

these steps).
Tip

Caution

If you m ake a

mistake when
replacing data,
close th e dialog
box, and choose
the Undo comm and from the
Edit menu (:l:l:+Z)
immediately to
reverse the
replacement.

Make sure that Find Entire Cells Only is activated if you are replacing values or
formulas. If it isn't selected, Excel will replace characters even if they are inside
other strings. For example, replacing 20 with 30 will also make 2000 become
3000.

5 . Choose Find Next to begin the search. When Excel locates the first

occurrence of the characters, choose the appropriate replace option
(see table 13.3).
6 . Click Close to close the dialog box.

Fig. 13.11
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Replace Options

Optio n

Action

Search

Specifies whether to search across rows or down
columns.

Match Case

Finds only characters that match the case of the
characters you specified.

Find Entire Cells Only

Searches for an exact match of the characters you
specified. It does not find partial occurrences.

Find Next

Finds the next occurrence.

Replace

Replaces the characters in the active cell with those
specified in the Replace With text box.

Replace All

Replaces all occurrences of the characters with those
specified in the Replace With text box.

Close

Closes the Replace dialog box.

Caution

-

When replacing data in your worksheet, use Replace All with care, because the results
may not be what you expect. Whenever you use the Replace command, it's a good
idea to fi rst locate the data you want to replace to make sure you really want to
replace it.

Spell Checking the Worksheet
Excel's Spelling command enables you to check worksheets, macro sheets,
and charts for misspellings and to correct the errors quickly. The spelling
checker offers a standard dictionary and also enables you to create an alternate customized dictionary to store frequently used words not found in the
standard dictionary. When you run the spelling checker, Excel then looks in
the standard dictionary and the custom dictionary for the correct spelling.
In addition to finding spelling errors, Excel finds repeating words and words
that might not be properly capitalized. You can check spelling in an entire
worksheet, or a selected range. You can check more than one sheet by selecting the sheets you want to check.

Ill

266

Chapter 13-Editing Worksheets
To check the spelling of data in your worksheet, follow these steps:
1. Specify the worksheet range you want to check. To check an entire
worksheet, select cell A1 of that sheet. Excel starts checking from the
active cell and moves forward to the end of the workbook. To check a
specific range, select the range you want to check. To select multiple
sheets, hold down the command key while clicking the sheet tabs of
the sheets you want to select.

2. Open the Tools menu and choose the Spelling command, or click the
Spelling button on the toolbar. When Excel finds a spelling error, the
Spelling dialog box appears (see fig. 13.12).

Fig. 13.12

-

~-

Soelllna ·"-··-"···"' -"'-'

The Spelling
dialog box appears
when Excel finds a
spelling error in
the worksheet.

Table 13.4lists the options that are available to correct a spelling error.

Table 13.4

Spelling Dialog Box Options

I

Option

Action

Change To

Types a replacement for the word.

Suggestions

Selects a replacement word from a list of suggested
words.

Add Words To

Selects the dictionary to which you want to add words
that are spelled correctly but not found in the standard
dictionary.

Ignore

Ignores the word and continue the spell check.

Ignore All

Ignores all occurrences of the word.

Change

Changes the selected word to the word displayed in
the Change To box.

Change All

Changes all occurrences of the word to the word
displayed in the Change To box.

From Here...

Option

Action

Add

Adds the selected word to the custom dictionary.

Suggest

Displays a list of proposed suggestions.

Always Suggest

If selected, Excel automatically displays a list of
proposed suggestions whenever a word is not found in
the dictionary.

Ignore UPPERCASE

If selected, the spelling checker skips words that are all
uppercase.

Undo Last

To undo the last spelling change.

Cancel/Close

Closes the dialog box (the Cancel button changes to
Close when you change a word or add a word to the
dictionary).

From Here ...
For additional information on editing worksheets, you may want to review
the following chapters:
• Chapter 14, 11 Formatting Worksheets," shows you how to format
worksheets.
• Chapter 15, 11 Using Formulas and Functions," discusses copying and
moving Excel formulas.
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Formatting
by Todd Knowlton

After you create a worksheet, the next step is to change the appearance of
data in your worksheet to make it more visually appealing. Excel provides
many features and functions that enable you to produce high-quality
worksheets. You can include such formatting options as applying different
fonts, and you can add graphics, colors, and patterns to worksheet elements.
In this chapter, you learn to
• Format numbers
• Change column widths and row heights
• Align text
• Change fonts, sizes, and styles
• Apply patterns and borders
• Create and apply a style
• Create and work with graphic objects

Formatting Numbers
When you enter numbers in the worksheet, don't be concerned with the way
they look. You can change the appearance of numbers by applying a numeric
format.
Excel provides many common numeric formats; you can create your own as
well. For example, you can apply a predefined currency format that uses two
decimal places or create a currency format that uses an international currency
symbol.
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To apply a numeric format, follow these steps:

Tip
When formatting
worksheets in
Excel, keep the
Formatting toolbar
handy so you can
access it quickly.
For details, see the
fo llowing section,
"Applying Number
Formats Using the
Tool bar."

1. Select the cells containing the numbers you want to format.
2. Open the Format menu and choose the Cells command; or press ;)::(+1.
The Format Cells dialog box appears (see fig. 14.1). If necessary, select

the Number tab in the Format Cells dialog box.
3. Choose the type of number format you want to apply from the Cat-

egory list. A listing of numeric formats for the corresponding Category
is displayed in the Format Codes list box. Some common symbols used
in these formats are listed in table 14.1 (following these steps).
4. Choose the number format you want to use from the Format Codes list.

A sample of the selected format appears in the Sample area of the dialog
box.
5. Click OK. Excel applies the selected number format to the selected cells
in your worksheet.

Fig. 14.1
The Format Cells
dialog box displays
a list of predefined
number formats.

~

See "Microsoft
Applications
Toolbars,"
p.24

Table 14.1

Numeric Formatting Codes

Code

Description

#

Place holder for digits.

0

Place holder for digits. Same as #, except that zeros on either
side of the decimal point fo rce the numbers to match the
selected format.

$

Currency symbol is displayed with the number.
Place holder for thousands separator.

Formatting Numbers

Code
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Description
Place holder for decimal point.

%

Multiplies number by 100 and displays number with a
percent sign.

Applying Number Formats Using the Toolbar
You can quickly apply commonly used number formats-such as Currency,
Comma, and Percentage-by using the Formatting toolbar (see fig. 14.2).
Decrease Decimal
Currency

Increase
Decimal

The Formatting toolbar is displayed by default. If the Formatting toolbar is
not visible, choose the Toolbars command from the View menu, select Formatting from the list of toolbars, and click OK.
To apply a number format using the Formatting toolbar, select the cells containing the numbers you want to format and then click the appropriate button in the toolbar.

Formatting Numbers Using the Style Menu
You also can format numbers by using styles. To apply one of the predefined
number formats listed as a style, select the cells containing the numbers you
want to format and then choose the Style command from the Format menu.
The Style dialog box appears (see fig. 14.3). Select the desired style in the
Style Name drop-down list, and then click OK.
Table 14.2 describes the formatting choices.

Fig. 14.2
The Formatting
toolbar contains
five buttons that
enable you to apply
common number
formats quickly.
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Fig. 14.3

Style

Format numbers
using the pred efined styles in
the Style dialog
box.
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Table 14.2 Number Formats in the Style Name Pop-up List in the
Style Dialog Box

"" See "Customizing Application Toolbars,"

Format

Description

Comma

Adds two decimal places to the number, and adds
commas to numbers that contain four or more digits.
A number entered as 1000 is formatted as 1 ,000.00.

Comma (0)

Rounds decimals and adds commas to numbers that
contain four or more digits. A number entered as
1000.55 is formatted as 1,001.

Currency

Adds a dollar sign and two decimal places to the number.
Also adds a comma to numbers that contain four or more
digits. A number entered as 1000 is formatted as
$1 ,000.00.

Currency (0)

Adds a dollar sign to the number and rounds decimals.
Also adds a comma to numbers that contain fou r or more
digits. A number entered as 1000.55 is formatted as
$1,001.

Normal

Applies the style that defines normal or default character
formatting. A number entered as 1000 is formatted as
1000.

Percent

Multiplies the number by 1 00 and adds a percentage
symbol to the number. A number entered as .15 is
formatted as 15 percent.

You also can use the following shortcut keys to format numbers:
Key

Format

Control+shift+-

General format

Control+shift+!

Comma format with two decimal places

p. 735

Formatting Numbers

Key

Format

Control+shift+$

Currency format with two decimal places

Control+shift+%

Percent format

Control+shift+"

Scientific notation format
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Creating a Custom Number Format
Although Excel provides most of the common number formats, at times you
may need a specific number format that the program doesn't provide. For
example, you may want to create additional numeric formats that use various
international currency symbols. Excel enables you to create custom number
formats. In most cases, you can base your custom format on one of Excel's
predefined formats.
To create a custom number format, follow these steps:
1. Open the Format menu and choose the Cells command; or press

~+1.

If necessary, select the Number tab in the Format Cells dialog box.
2. Select the category from the Category list that contains the format you

want to modify. Then select the predefined format in the Format Codes
list. The formatting symbols appear in the Code text box, and a sample
appears below the text box (see fig. 14.4).
3. Select the Code text box, and edit the selected format.
4. Click OK. The dialog box closes. Choose Cells from the Format menu

again. The custom format appears at the end of the Format Codes list.
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You can enter a
custom format in
the Code text box.
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Note
You can select and delete custom formats from the list; however, you cannot delete
any of Excel's predefined number formats.

Changing Date and Time Formats
•

See "Entering
Dates and
Times," p. 235

Excel recognizes most dates and times entered in a worksheet cell. If you
enter 1-1-95 in a cell, for example, Excel assumes you are entering a date and
displays the number in a date format. (The default date format is 1/1/95.) If
you enter 9:45, Excel assumes you are referring to a time and displays the
entry in a time format. You can change to another date o r time format.
To apply a date or time format, follow these steps:
1. Select the cell or range containing the data you want to format.

2. Open the Format menu and choose the Cells command, or press ~ +1.
3. Select Date from the Category List to display the list of date formats (see

fig. 14.5). To apply a time format, select Time from the Category list.
Fig. 14.5
A list of predefi ned date
formats appears in
t he Date section
of the Format
Cells dialog box.
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4. Select the format you wa nt to use from the Format Codes list box.
5. Click OK. Excel applies the format to the data.

You also can use the following shortcut keys to enter and format the current
date and time:

Formatting Numbers

Key

Format

J::t:+-(hyphen)

Current date (entering)

J::t:+;

Cu rrent time (entering)

Control+shift+3

Date format d-mmm-yy (formatting)

Control+shift+2

Time format h:mm AM/PM (formatting)
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To create custom date and time formats, use the same procedure as custom
number formats; the only difference is that you use date and time format
codes. Table 14.3 lists these codes.

Table 14.3

Date and Time Format Codes

Code

Description

m

Month as a number with no leading zero

mm

Month as a number with leading zero

mmm

Month as a three-letter abbreviation

mmmm

Month as a full name

d

Day of week with no leading zero

dd

Day of week with leading zero

ddd

Day of week as a three-letter abbreviation

dddd

Day of week as a fu ll name

yy

Year as a two-digit number

yyyy

Year as a four-digit number

h

Hour with no leading zero

hh

Hour with leading zero

m

Minute with no leading zero

mm

Minute with leading zero
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Troubleshooting
Excel fills a cell with##### when I apply a numeric format to a number in my worksheet.
When a cell isn't wide enough to accommodate a formatted number, Excel displays
the number as#####. To display the complete number in the cell, adjust the column
width of the cell. When you widen the column sufficiently, Excel displays the fully
formatted number in the cell. For more information on changing column widths, see
the following section, "Changing Column Width and Row Height."

I want to create a numeric format that uses an international currency symbol. How can I
use an international symbol in a custom format?
To create a custom numeric format with an international currency symbol, choose
the Cells command from the Format menu, and select the Number tab. In the Category list, select Currency; then select the format that closely resembles the format
you want to use from the Format Codes list box. In the Code text box, highlight the
currency symbol used by that format, and press delete to delete the symbol. You
then can enter special characters to display the currency symbols. To use the pound
symbol(£), press option+3. To use the yen symbol('), press option+Y. The appropriate currency symbols are inserted into the Code text box. Click OK to save the custom numeric format.

Changing Column Width and
Row Height
When you enter data into a cell, the data often appears truncated because the
column is not wide enough to display the entire entry. If a cell can't display
an entire number or date, Excel fills the cell with pound signs or displays the
value in scientific notation (for example, 4.51E+08). After you adjust the
width of the cell, the entire number or date appears.
You can change the column width by using the mouse or menu commands.
When you use the mouse to change the column width, drag the column
border to reflect the approximate size of the column. When you use the Column Width command, you can specify an exact column width.

Using the Mouse to Change Column Width
To change the column width by using the mouse, follow these steps:
1. · Position the mouse pointer on the right border of the heading of the

column whose width you want to change. The mouse pointer changes

Changing Column Width and Row Height
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to a double-headed horizontal arrow when positioned properly. To
change the width of multiple columns, select the columns you want to
change and position the pointer on the right border of the heading of
any of the selected columns.
2. Drag the arrow to the right or left to increase or decrease the column
width, respectively. A dotted line indicates the column width (see
fig. 14.6).
3. Release the mouse button when the column is the width you want.
Double-headed arrow for changing column widths

12:07 PM

I.1J 5

Workbook!
D

G

Fig. 14.6
Drag the doubleheaded arrow to
change the
column w idth.

Ill
New column Original column
border
border

Using the Column Width Command to Change
Column Width
To change the column width by using the Column Width command, follow
these steps:
1. Click the heading of the column whose width you want to change.
To change the width of multiple columns, select the columns you
want to change.
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2 . Open the Format menu, choose Column, and then choose the Width

command from the submenu. The Column Width dialog box appears
(see fig. 14.7).
Fig. 14.7
Enter a specific
column width in
the Column
Width dialog box.
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3. Enter the column width in the Column Width text box.
4 . Click OK. Excel adjusts the width of the selected columns.

Adjusting Column Width Automatically
In addition to changing column width manually, Excel enables you to adjust
the column width to accommodate the widest cell entry in a column.
Tip
To quickly change
the column width
to fit the widest
entry, position
the mouse pointer
on the right
border of the
column heading
and then doubleclick the mouse.

To adjust the column width to the widest entry, select the cell containing the
widest entry, and then open the Format menu, choose Column, and then
choose AutoFit Selection. Excel adjusts the width of the column.

Adjusting the Row Height
Excel automatically adjusts the row height based on the font you are using,
but you can change the row height to accommodate additional white space
or to minimize the row height in your worksheet. You can use both the
mouse and Excel commands to change the row h eight.
To adjust the row height by using the mouse, follow these steps:
1. Position the mouse pointer on the bottom border of the heading of the

row whose height you want to change. The mouse pointer changes to a
double-headed vertical arrow when positioned properly. To change the
height of multiple rows, select the rows you want to change and position the pointer on the bottom border of the heading of any of the
selected columns.
2. Drag the arrow down or up to increase or decrease the row height,
respectively. A dotted line indicates the row height (see fig. 14.8).
3. Release the mouse button when the row is the height you want.

Changing Column Width and Row Height
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Fig. 14.8
Drag the doubleheaded arrow to
change the row
height.
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To adjust the row height by using the Row Height command, follow these
steps:
1. Click the heading of the row whose height you want to change. To

change the height of multiple rows, select the rows you want to change.
2. Open the Format menu, choose Rows, and then choose the Height
command from the submenu. The Row Height dialog box appears (see

fig. 14.9).
Row HeiQhl
RoY Htfolll:

~

I

01

I

~
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3. Enter the row height in the Row Height text box.
4. Click OK. Excel adjusts the height of the selected rows.

Fig. 14.9
Enter a specific row
height in the Row
Height dialog box.
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Note
The row height is measured in points and is based on the size of the default font used
in the worksheet. The default font used by Excel is 10-point Geneva.

Aligning Data
Excel provides several formatting options for changing the appearance of
data in the worksheet. For example, you can change the alignment of text or
numbers within a cell so that they appear left-aligned, right-aligned, or centered. You also can format lengthy text to wrap within a cell, center text
across a range of columns, or align text vertically within a cell.
To align data, follow these steps:
1. Select the cell or range that contains the data you want to align.

2. Open the Format menu and choose the Cells command, or press :J:\:+1.

The Format Cells dialog box appears. Select the Alignment tab (see
fig. 14.10).

Fig. 14.10
Change the
alignment of data
in the Alignment
section of the
Format Cells
dialog box.
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3. Specify the horizontal and vertical alignment you want to use. See table
14.4 for descriptions of alignment options.
4. Click OK.

Aligning Data

Table 14.4
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Alignment Options

Option

Description

General

Aligns text to the left edge of the cell and numbers to the
right edge of the cell

left

Aligns text and numbers to the left edge of the cell

Center

Centers text and numbers within a cell

Right

Aligns text and numbers to the right edge of the cell

Fill

Repeats the contents until the cell is full

Justify

When text is wrapped within a cell, aligns text evenly
between the cell borders

Center across selection

Centers text and numbers across a selected area

Top

Aligns text vertically against the top of the cell

Bottom

Aligns text vertically against the bottom of the cell

Left, center, and right alignment can be chosen from the Formatting toolbar
(see fig. 14.11).
Align Right

Center

Wrapping Text within a Cell
You can align text entries to wrap within a single cell or a range of cells. To
wrap text within a cell or range, select the cell or range of cells containing the
entry, and then choose Cells from the Format menu, or press ~+1. In the
Format Cells dialog box, select the Alignment tab. Then select Wrap Text and
click OK. Excel wraps the text (see fig. 14.12).

Fig. 14.11
Use the Formatting toolbar to
quickly set
alignment.
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Fig. 14.12
Column headings
are wrapped
within each cell.

~

File

Edit

Ulew

Insert

Formot Tools Do to

Window

12:22 PM

IIQI&!J~lX.l~]j)~ffi~WOOJ~It aoll

17) 5

I~

IW

I~ rr::::JIEJII!Ji!IOOJifJ!flf!l$1 JfliiJf8lttJj-~J.~I~WE)[j]B

@e neve
043

~

Uocotlon Tracker

c

Stu1

Lngt h of Yicatton

Dete

Service

-; 3/8/9 4
2/ 4/ 9 1
7/B/92-----r--972193

-----y

-

D•vs

5
10
10

s

Excel automatically
adjusts row heights
for rows with
wrapped text in cells

Centering Text across Columns
To center text over multiple columns, enter the text to be centered in the
leftmost cell of the range across which you want to center the text. Th en
select the range, including the cell with the text to be centered across the
columns. The other cells defining the range of columns must be blank.
Click the Center Across Columns button from the Formatting toolbar.
You also can perform the task from the Format Cells dialog box. Select the
Alignment tab in the Format Cells dialog box. Then select Center Across
Selection and click OK.

Whether you use the toolbar or the Format Cells dialog box, Excel centers the
text across the specified columns (see fig. 14.13).

Aligning Data
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Fig. 14.13
Text is centered
across the selected
columns.

Text centered across
columns A-D

Aligning Text Vertically or Horizontally
Excel enables you to align text either vertically or horizontally in a cell.
To format text vertically or horizontally, follow these steps:

Tip

1. Select the cell or range of cells containing the text you want to format.

2. Open the Format menu and choose the Cells command, or press
The Format Cells dialog box appears. Select the Alignment tab.

~+1.

3. In the Orientation section, select the vertical or horizontal orientation.
If you select a vertical orientation, you also must select a specific vertical alignment (Top, Center, or Bottom) in the Vertical box.
4. Click OK. Excel aligns the text (see fig. 14.14).

When aligning
text vertically or
horizontally,
double-click the
borders in the
column and row
headers to ad just
the column width
or row height
quickly.

Ill

284

Chapter 14-Formatting Worksheets

Fig. 14.14
Text is aligned
vertically in row 3.
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Troubleshooting
I used the Center Across Selection command to center a text entry across a range of
columns, but the entry would not center.

Make sure the text you want to center across the columns is in the leftmost column
of the range. It could also be that one of the cells in the selection contains a space
character or some other entry. To remove these characters, select the range of cells
(except for the cell containing the entry you want to center) and then press delete.
After I aligned text vertically in a cell, some of the characters did not display.

When a row height is set to the default row height, only a few characters of vertically
rotated text appear. To display the entire contents, position the mouse pointer on
the bottom border of the row and double-click, or click the row heading and open
the Format menu, choose Rows, and then choose the AutoFit command from the
submenu to adjust the height to best fit the row's contents.

Changing Fonts, Sizes, and Styles
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Changing Fonts, Sizes, and Styles
Excel provides several formatting options for changing the appearance of text
in your worksheets. You can, for example, choose a different font, change the
size of the selected font, and apply a font style to cells in your worksheet.

Changing Fonts
The list of fo nts available in the Font dialog box depends on the fonts you
have installed.
To change a font, follow th ese steps:
1. Select the cell or range of cells that you want to change.

2 . Open the Format menu and choose the Cells command; or press

~ +1.

In the Format Cells dialog box, select the Font tab.
3. In the Font list box, select the font you want to use; to change the text

size, select a size in the Size list or type any size in the Size text box (see
fig. 14.15).
4. Click OK.

.. ,

Fig. 14.15
The Font section
of the Format Cells
dialog box displays
the currently
installed fonts.
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Applying Text Formats
In addition to changing the font and size of data in your worksheets, you can
apply text attributes to the data. For example, you can assign such attributes
as bold, italic, and underline, and change the color of text.
To apply a formatting attribute, follow these steps:
1 . Select the cell or range of cells you want to format.
2 . Open the Format menu and choose the Cells command, or press

In the Format Cells dialog box, select the Font tab.

~+1.

286

Chapter 14-Formatting Worksheets

Note
As you make changes in the dialog box, Excel applies the selections to the text

in the Preview box. The changes aren't made to the selected cells until you
click OK.

3. Select the style you want to apply in the Font Style list box. Use the
Underline drop-down list to select an underline style. To change the
color of the data, click the Color drop-down list and select a color.
Select Strikethrough, Superscript, Subscript, Outline, or Shadow, if
you want.
4. When you finish, click OK.

Bold, italic, and underline styles can be chosen without accessing the
Format Cells dialog box by clicking buttons on the Formatting toolbar
(see fig. 14.16).

Fig. 14.16
The Italic, Bold,
and Underline
styles are available
on the Formatting
toolbar.

Formatting Characters In a Cell
You can apply formatting to individual characters in a text entry. For example, you can assign the Bold format to a single character in a cell.

Tip
When formatting
characters in a
cell, you also can
use the formatting
buttons in the
Formatting toolbar
to change the
appearance of text.

To format characters in a cell, follow these steps:
1. Double-click the cell containing the data you want to format, or select

the cell and then press

~+U .

2. In the cell or formula bar, select the characters you want to format.
3. Open the Format menu and choose the Cells command, or press ~+1.
In the Format Cells dialog box, select the Font tab.
4. Select the attributes you want, and then click OK.

Applying Patterns and Borders
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Applying Patterns and Borders
In addition to formatting numbers or text, you can format cells. For example,
you can add a border to a cell or range of cells and fill a cell with a color or
pattern.

Applying a Border
Borders enhance a worksheet's appearance by providing visual separations
between areas of the worksheet. Borders also improve the appea rance of
printed reports.
To apply a border, follow these steps:
1. Select the cell or range you want to format.

2. Open the Format menu and choose the Cells command, or press

~+ 1.

In the Format Cells dialog box, select the Border tab (see fig. 14.17).
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In the Format Cells
dialog box, select a
border to add to a
cell.
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3. Choose the placement of the border by selecting Outline, Left, Right,

Top, or Bottom in the Border box. The Outline option puts a border
around the outer edges of the selection. The Left, Right, Top, and Bottom options place a border along the specified edges of each cell in the
selection.
4 . In the Style area, select the type of border you want. To change the

color of the border, select the color from the Color drop-down list.
5. When you finish, click OK.

Applying Patterns
You can enhance a cell with patterns and colors. The Format Cells dialog box
enables you to choose foreground and background colors as well as a pattern.

Tip

liEI8 Use the
Formatting
toolbar to apply
borders quickly.
Select the cell or
range you want to
format, and click
the arrow next to
the Borders button to display the
Border buttons.

Ill
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To format a cell with colors and patterns, follow these steps:
1. Select the cell or range you want to format.

2. Open the Format menu and choose the Cells command, or press )::C+l.
3. Set the foreground color (text color) in the Font section of the dialog
box.
4. In the Format Cells dialog box, select the Patterns tab (see fig. 14.18).
Fig. 14.18

Apply patterns
and colors to a
cell with the
Format Cells
dialog box.

5. Select a background color for the cell in the Color section. The Sample
box in the bottom right corner of the dialog box shows you what the
color looks like.
6. Select a pattern in the Pattern drop-down list by clicking the down

arrow. To specify a background color for the pattern, select a pattern
color from the Pattern pull-down list. If the foreground and background
colors are the same, the cell displays a solid color. The Sample box
shows you what the formatting looks like.
7. Click OK.
Tip
To apply the same
formatting to a
different area,
select the new area
and then click the
Repeat button or
press ~ +Y immediately after
you apply the
formatting.

Using Automatic Range Formatting
If you aren't sure which colors and formats work well together, Excel's
AutoFormat feature can eliminate much of the guesswork. AutoFormat lets
you make choices from a list of predefined formatting templates. These formats are a combination of number formats, cell alignments, column widths,
row heights, fonts, borders, and other formatting options.

To use the AutoFormat feature, follow these steps:
1. Select the range you want to form at.

Applying Patterns and Borders

289

2 . Open the Format menu and choose the AutoFormat command. The

AutoFormat dialog box appears (see fig. 14.19).
Fig. 14.19
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3. Select one of the format types in the Table Format list box. Excel dis·
plays the selected format in the Sample box.
4 . Click OK to apply the format.

Note
To copy the formats from a range of cells to another range in the worksheet, select
the range of cells containing the formats and click the Format Painter button in the
Standard toolbar. Then, using the mouse, highlight the range of cells to which you
want to copy the formats. When you release the mouse button, Excel applies the
formats to the selected range.

Troubleshooting
After I changed the calor of a cell, the entf}' was no longer displayed.

When the backgro und color of a cell is the same color used by the cell entry, you will
not see the entry. To change the color of the cell entry, select the cell and choose the
Cells command from the Format menu. Select the Font tab, select a color from the
Color drop-down menu, and click OK.
After I choose the AutoFormat command, Excel displays an error message, stating that it
cannot detect a table around the active cell.

You probably selected a single cell before choosing the AutoFormat command.
You must select more than one cell for AutoFormat to work.

The AutoFormat
dialog box displays
formatting
templates.
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Creating and Applying a Style
When you find yourself applying the same worksheet formats over and over,
you can save yourself some time by saving the formats in a style. Then,
when you want to use the formats, you can apply all of them with a single
command.
You can create a style based on cell formats that already appear in the
worksheet, or you can create a new style by using the options in the Style
dialog box.

Creating a Style by Example
You can define a style based on existing formats in your worksheet. When
you create a style by example, Excel uses the formats of the selected cell to
create the style.
To create a style by example, follow these steps:
1. Select the cell that contains the formats you want to name as a style.
2. Open the Format menu and choose the Style command. The Style

dialog box appears (see fig. 14.20).
Fig. 14.20
The Style dialog
box displays the
options you can
use to defin e a
style.
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3. Type a name for your new style in the Style Name box, and then choose

Add. The style appears in the Style Name drop-down list.
4 . Click OK.

Defining a Style
To create a new style, follow these steps:
1. Open the Format menu and choose the Style command to display the

Style dialog box.

Creating and Working with Graphic Objects
2. Type a name for the style in the Style Name text box. (Normal is the
default style.) The current format appears in the Style Includes box.
3. Choose the Modify button. The Format Cells dialog box appears.
4. Select the tab for the attribute you want to change. The dialog box for

the selected attribute appears.
5. Enter the changes you want to make. Click OK to return to the Style
dialog box.
6. After you make all the necessary style changes, click OK. The dialog box
closes, and Excel applies the style to any selected cells in the worksheet.

Applying a Style
To apply a style, follow these steps:
1. Select the cell or range to which you want to apply the style.
2. Open the Format menu and choose the Style command to display the
Style dialog box.

3. Select the name of the style you want to apply in the Style Name list.
4. Click OK. Excel applies the style to the selected cell or range.

Creating and Working with Graphic
Objects
Excel makes it easy to enhance your worksheets with graphic objects by providing a full set of drawing tools. You can create objects such as circles,
squares, and rectangles and add them to your worksheet.

Creating an Object
To create a graphic object, click the Drawing button in the Standard toolbar
to display the Drawing toolbar. Select the Drawing tool that represents the
object you want to create.
Position the mouse pointer in the area of the worksheet where you want to
start drawing (the mouse pointer changes to a small cross when you position
it in the worksheet area). Click and hold down the mouse button, and drag
the mouse until the object is the size you want. Then release the mouse button. Excel adds the drawing to the worksheet (see fig. 14.21).
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Fig. 14.21
A rectangle is
added to the
worksheet.
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Selecting, Moving, and Resizing Objects
After placing an object in the worksheet, you can move that object to a new
location or resize it.
To Select an Object

Before you can move or resize an object, first select it by placing the mouse
pointer next to the object and clicking the mouse button. The mouse pointer
becomes an arrow when positioned on the border of the object. Handles
appear around the object, indicating that it is selected (see fig. 14.22).
To Move an Object
Tip
To resize an object
without altering
the ratio of height
to width, hold
down the shift key
while resizing from
a corner handle.

Select the object you want to move, and then position the mouse pointer on
the border of the object. When the mouse pointer becomes an arrow, click
and hold down the mouse button, drag the selected object to the desired
location, and release the mouse button.
To Resize an Object

Select the object you want to resize. Handles appear around the object; these
handles enable you to resize the selected object.
Position the mouse pointer on one of the black handles. The mouse pointer
changes to a double-headed arrow when properly positioned. To make the
object wider or longer, position the mouse pointer on one of the middle
handles. To resize the object's height and width simultaneously, position the
mouse pointer on one of the corner handles.

Creating and Working with Graphic Objects
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Click and hold down the mouse button, drag the handle until the object is
the size you want (see fig. 14.23), and then release the mouse button.
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Formatting Objects
As you can with text, you can add color, patterns, and borders to graphic
objects in your worksheet.
To format an object, follow these steps:
1. Select the object you want to format.

2. Open the Format menu and choose the Object command, or press ):(+1.
The Format Object dialog box appears (see fig. 14.24). If necessary, click
the Patterns tab.
Fig. 14.24
Change the
appearance of a
drawn object with
the Format Object
dialog box.

Tip
To format an
object quickly,
position the
mouse pointer on
the object you
want to format.
When the pointer
changes to an
arrow, doubleclick the object to
display the Format
Object dialog box.

3. Select a border style in the Border section of the dialog box. Select a

color and pattern in the Fill section of the dialog box. The Sample area
in the bottom right comer of the dialog box shows what the formatting
will look like.
4 . Click OK to close the dialog box and apply the selected formats.

Grouping Objects
In creating a graphic or picture, you might draw several separate objects. If
you want to work with multiple objects at the same time-for example, if you
want to move the object to another area in the worksheet or want to create a
copy of the drawing-you can group the objects to form a single object.
To group objects, first select the objects. (You can use the Drawing Selection
button in the Drawing toolbar or hold down the shift key as you click each
object.) Open the Format menu, choose Placement, and then choose the
Group command from the submenu. Excel groups the objects together.
A single set of selection handles appears around the grouped object (see
fig. 14.25).
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To break a grouped object back into multiple objects, select the grouped object, and then open the Format menu, choose Placement, and then choose
Ungroup from the submenu. Individual objects appear, with handles surrounding each object.

Creating a Text Box
Excel enables you to create text boxes in your worksheets for adding paragraphs of text.
To create a text box, click the Text Box button and position the mouse
pointer in the worksheet (the mouse pointer becomes a small cross). Drag the
pointer in the worksheet area. After you release the mouse button, the insertion point appears in the top left corner of the text box, ready to accept the
text you type. The text wraps according to the size of the box (see fig. 14.26).
You can format, move, and resize a text box as you can any other object in a
worksheet. When you resize a text box, the text au tomatically wraps to fit the
new size of the box. You can apply formats to all the text in the text box or
only to individual words. To make the entire text bold, for example, select
the text box and click the Bold button in the Formatting toolbar. To make a
single word of the text bold, place the mouse pointer inside the text box. The
mouse pointer changes to an !-beam. Select the text you want to format by
clicking and dragging the 1-beam over the text. Then use standard formatting
commands, tools, or shortcuts to format the selected text. As long as the
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insertion point appears inside the text box, you can use normal fo rmatting
and editing procedures. For information on formatting, refer to sections
"Formatting Numbers, " "Aligning Text Vertically or Horizontally, " and
"Ch anging Fonts, Sizes, and Styles," earlier in this chapter.

Fig. 14.26
Text wraps within
this text box.
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Text box

To select and move a text box, click the text box, position the mouse pointer
(arrow) on the border of the text box and then drag the box to a new location. You can move an unselected text box by dragging it, without first selecting it. Using this method, you do not h ave to drag from the border.

From Here ...
For additional information on formatting documents, you may want to
review the following chapters:
• Chapter 13, "Editing Worksheets," shows you how to copy and move
documen t formatting.
• Chapter 16, "Creating and Printing Reports and Charts," provides
information on printing Excel worksheets.

Chapter 15

Using Form las
Functions

d

by Todd Knowlton

The greatest benefit in using an electronic spreadsheet program, such as
Excel, is the program's power to calculate formulas based on values in the
worksheet. You can, for example, create a formula that calculates the difference between sales figures on a quarterly basis. In addition, you can use
Excel's built-in functions to calculate the average of a range of values or the
monthly payment on a loan.
In this chapter, you learn to
• Create a formula
• Create a formula by using Excel's built-in functions
• Use the Function Wizard to enter a function
• Copy formulas
• Name cells used in formulas

Creating Formulas
You can create formulas in Excel in two ways: type the entire formula directly in the cell, or click the cells that you want included in the formula.
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Creating a Formula by Typing
~

See "Entering
Data," p. 233

To create a formula by entering the cell addresses and numeric operators in a
cell, follow these steps:
1. Select the cell in which you want to enter a formula.
2. Type= (equal sign) to start the formula.

Note
You can enter a plus sign (+)or minus sign(-) to begin a formula; Excel will
convert the formula to the appropriate format. If you enter +84+85, for
example, Excel will convert the formula to =+84+85.

Tip
To display
formulas instead of calculated values in
a worksheet,
select any blank
cell and press
~+' (left single
quote mark
located left of
the 1 key). Press
~+'again to
display the
formula result.

~

See "Moving
Around in a
Worksheet,"
p.230

3. Type the cell addresses containing the values to be computed, entering
the appropriate operator. To find the difference between the two values
in cells 85 and B11, for example, enter =B5-Bll in cell 814.
4. Press enter on the numeric keypad. Excel displays the result of the for-

mula in the active cell, and the formula appears in the formula bar.

Creating a Formula by Pointing
It's impossible to avoid errors completely when typing cell addresses in a
formula. To minimize errors that occur when you use cell addresses in formulas, build a formula by clicking cells rather than by typing the cell addresses.
Clicking Cells with the Mouse
Suppose you want to enter, in cell 814, a formula that subtracts the total in
cell Bll from the total in cell 85. To build a formula by clicking cells with the
mouse, follow these steps:
1. Select the cell in which you want to enter a formula.
2. Type= (equal sign) to start the formula. For this example, type = in
cell 814.

3. Click the cell whose address you want to add to the formula. For this
example, click cell 85 to add the cell address in the formula bar.
4. Type - (minus sign).
5. Click the next cell address you want to add to the formula.

For this example, click cell B11.

Creating Formulas
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6. Click the enter button in the formula bar or press enter to complete the

formula entry. The result appears in the active cell (see fig. 15.1).
~

File Edit Ulew

Insert Format Tools

Dolo Window

C'l.J 5

4:50PM

lQlfiJill~l ~~~]i@lffi~!iiiiillmtiOO!l

tl3 ~

113 ITDI3 f!Jj'!l101iflii!!UflltJ$1 r l.~le'"lii§BISJJB!ii3
:65-B I I
Product Soles
D

-,

H

Q31

To tel • orTote1
7270
SUI
2512
17ll
460D
32ll
14382"

QI ~ Q ~
- 1840
400
552
704
I ODD.__ l.!fl.OJ
12DD
515D~- 3447i
3744
1750.~._ _
17~..

IIOD
250
45D
IBOD

! - - ' - 1"3..,
5Dl

liDO
250
375
1725°

liDO
275
400
1715 ~

IIOD
_2 DD
425
_!!___~

Fig. 15.1
The result of the
formula appears
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formula appears in
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•
Entering Cell References with the Keyboard

Suppose that you want to build, in cell D9, a formula that finds the difference
between the totals in cells B9 and C9 . To enter cell references with the keyboard, follow these steps:
1. Select the cell in which you want to enter a formula.

2. Type = (equal sign) to start the formula. For this example, type = in

cell D9.
3. Use the arrow keys to highlight the cell that contains the data you want
to use. For this example, press (i) twice to select cell B9. Notice that the

marquee is positioned in cell B9. Cell B9 is added to the formula.
4. Type- (minus sign).

5. Use the arrow keys to highlight the next cell you want to use. For this

example, press -> to select cell C9. Cell C9 is added to the formula.
6. Press enter or click the enter button in the formula bar to complete the

entry.
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Using Mathematical Operators
In addition to using Excel's built-in functions to perform calculations, you
can use mathematical operators to perform a calculation on worksheet data.
Following are the mathematical operators used in basic calculations:
Operator

Purpose

+

Addition
Subtraction
Multiplication
Division

%

Percentage

1\

Exponentiation

Most formula errors occur when the mathematical operators are not entered
in the proper order of precedence-the order in which Excel performs mathematical operations. Following is the order of precedence for mathematical
operations in a formula:
Negation (for example: -18)
o/o

Percent

1\

Exponentiation

*,I

Multiplication, division

+,-

Addition, subtraction

Exponentiation occurs before multiplication or division in a formula, and
multiplication and division occur before addition or subtraction. For example, Excel calculates the formula =4+10*2 by first multiplying 10 by 2 and
then adding the product to 4, which returns 24. That order remains constant
whether the formula is written as =4+ 10*2 or =10*2+4.
If a formula includes mathematical operators that are at the same level, the

calculations are evaluated sequentially from left to right.
You can change the order of precedence by enclosing segments of the
formula in parentheses. Excel first performs all operations within the
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parentheses and then performs the rest of the operation s in the appropriate
order. For example, by adding parentheses to the formula =4+10*2 to create
=(4+ 10)*2, you can force Excel first to add 4 and 10 and then multiply the
sum by 2 to return 28.
Note
Each open parenthesis must be matched by a closed parenthesis, or Excel won't
accept the formula. The program displays a message stating that the parentheses
don't match. When you use parentheses in a formula, compare the total number of
open parentheses with the total number of closed parentheses.

In addition to performing mathematical calculations with formulas, you can
manipulate text, perform comparisons, and refer to several different ranges in
the worksheet with references.
By using text operators, you can concatenate (join) text contained in quotation marks or text in other cells. The text concatenation operator is the:znd
sign(&). For example, entering the formula ="Total Sales: "&84 returns Total
Sales: 28 when cell 84 contains the value 28.
To compare results, you can create formulas with comparative operators,
which return TRUE or FALSE, depending on how the formula evaluates the
condition. For example, the formula =A4>30 returns TRUE if the value in cell
A4 is greater than 30; otherwise, it returns FALSE. A comparative operator
might be used to indicate when a limit has been exceeded or when you r
checkbook drops below a minimum balance.
Following are the comparative operators you can use in a formula:
Operator

Purpose
Equal to

<

Less than

>

Greater than

<=

Less than or equal to

>=

Greater than o r equal to

<>

Not equal to
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Reference operators enable you to refer to several different ranges in a single
formula. For example, entering the formula SUM(A4:A24) uses a range operator(:) to sum the values located in cells A4 through A24. The union operator
(,) allows you more flexibility. For example, the formula SUM(A4,A24) sums
the values in A4 and A24, but not the values in the cells between them. The
final reference operator is the least commonly used. The intersection operator, indicated by a space, references cells at the intersection of other references. For example, SUM(C2:C12 A6:F6) sums the values in the cells common
to both of the specified ranges.

Entering Dates and Times in Formulas
~

See "Entering
Dates and
Times,"

p.235

You also can create formulas to calculate values by using dates and times.
When you use a date or time in a formula, you must enter the date or time in
a format that Excel recognizes, and you must enclose the entry in double
quotation marks. Excel then converts the entry to its appropriate value. To
find the number of days that elapsed between two dates, for example, you
would enter a formula such as ="3/20/95"-"2/5/95." In this example, Excel
returns 43, the number of days between February 5, 1995, and March 20,
1995.
If Excel doesn't recognize a date or time, it stores the entry as text and

displays the #VALUE! error value.

Debugging Formulas
Several errors can occur when you enter formulas in Excel. In many cases,
Excel displays an error value that enables you to debug your formulas based
on that value. Following are the error values and their possible causes:
Error

Cause

#DIV/0!

The formula is trying to divide by zero

#N/A

The formula refers to a value that is not available

#NAME?

The formula uses a name that Excel does not recognize

#NULL!

The formula contains a reference that specifies an invalid
intersection of cells

#NUM!

The formula uses a number incorrectly

#REF!

The formula refers to an invalid cell

#VALUE!

The formula uses an incorrect argument or operand
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You can use Excel Help to guide you when an error occurs. To access Excel's
error-values Help screens:
1. Choose the Microsoft Excel Help command from the balloon help
menu, as shown in figure 15.2. The MS Excel Help window appears.
~

File

Edit Ulew

AI

"

ln•ert Format Tool•

Data Window
1D:59 AM
About Balloon Help •••
Show Urtlloons

Workbook!

c

Help for Lotus 1-2-3 Users .••

D

Fig. 15.2
The guide menu is
located near the
right end of the
menu bar.

Quick Preulew
EHamples And Demos

Sheet!

Shert2

51'0013

S-4

Sl1o01

Sl1o016

2. Click the Search button. The Search dialog box appears.

3. Type error values in the text box as you key the search.

~
Tip

4. Click Show Topics.

5. From the topic list at the bottom of the dialog box, choose Overview of
Error Values.
6. Click Go To. The Help window displays the information, as shown in

figure 15.3.
7. Click the close box to close the Help window.

When an
error value
appears in the
worksheet, click
the Tip Wizard
button to see a
d escriptio n o f

the error value.
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Fig. 15.3
The Help window
displays the list of
error values and
their causes.
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Converting Formulas to Values
In many cases, after you create the formula, you need only the result rather
than the formula itself. After you calculate your monthly mortgage payment,
for example, you no longer need the formula. In such a situation, you can
convert the formula to its actual value.
To convert a single formula to a value, follow these steps:
1. Select the cell that contains the formula.

2. Press ):t+U, or double-click the cell.
3. Press the F9 function key. Excel replaces the formula with the value.
To convert a range of formulas to values, follow these steps:
1. Select the range that contains the formulas you want to convert.
2. Open the Edit menu and choose the Copy command, or click the Copy
button on the toolbar. A marquee surrounds the selected range.
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3. Open the Edit menu and choose the Paste Special command. The Paste

Special dialog box appears (see fig. 15.4).
Fig. 15.4
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Select the Values
option in the Paste
Special dialog
box to convert
formulas to values.

4. Choose the Values option.
5. Click OK. Excel replaces the formulas in the selected range with values.

Troubleshooting
After I enter a formula, Excel displays an alert box, warning that an error exists in the
formula.

When this happens, click the Help button (if one is available). Excel displays a Help
window that displays the error message and a possible cause. If, after reading the
Help screen, you can't find the error in the formula, delete the equal sign that appears at the beginning of the formula. When you do, Excel enters the formula in the
cell as text. You then can return to the formula later and work on it. To turn the text
back into a formula, reenter the equal sign at the beginning of the formula, and press
enter.
After I enter a formula that uses parentheses, Excel displays the error message

Parentheses do not match.
When you use parentheses in formulas, remember that for every open parenthesis,
there must be a closed parenthesis. In many cases, Excel highlights matching pairs of
parentheses as you move the insertion point through the formula. As you move the
insertion point across an open parenthesis, watch for the closed parenthesis to appear highlighted. If the highlighted parenthesis does not enclose the correct term,
you have found the term that requires another parenthesis.
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Using Built-In Functions
Excel provides more than 200 built-in functions, or predefined formulas, that
enable you to create formulas easily for a wide range of applications, including business, scientific, and engineering applications.
Each function consists of the equal sign(=), the function name, and the
argument (cells used for carrying out the calculation). The SUM function, for
example, adds the numbers in a specified range of cells (see fig. 15.5). The
addresses of the specified cells make up the argument portion of the function.
The active cell shows the result of the function.
Fig. 15.5
This formula uses
the SUM function
to total the entries
in cells B2, B3,
and B4.

1100.
250

Tip
If you're a
Lotus 1-2-3
user, you can
enter a 1-2-3
function,
such as
@SUM(Al..A4),
and Excel will
convert it to
the appropriate
Excel function.

1100
1100
2 75 - - 300

~00

4400
1075

62"
151l>

37S

425

1650

23111

1725

1775

1825

l125- -

Excel comes with a large number of built-in worksheet functions, including
mathematical, database, financial , and statistical functions. The program also
includes date, time, information, logical, lookup, reference, text, and trigonometric functions.

Entering Functions
To enter a function in the active cell, type= (equal sign), followed by the
function name (for example, SUM), followed by an open parenthesis. Then
specify the cell or range of cells you want the function to use, followed by a
closed parenthesis. When you press enter or click the enter button in the
formula bar to enter the function in the cell, Excel displays the result of the
formula in the cell.
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Note
You don't need to enter the last parenthesis if you are creating a fonnula with Excel's
built-in functions. Excel automatically adds the last parenthesis when you enter the
fonnula.

Using the AutoSum Button to Sum Ranges
You can use the AutoSum button, located in the Standard toolbar, to sum a
range of cells quickly. You can, for example, use the AutoSum button to total
the values in adjacent columns or rows. To do so, select a cell adjacent to the
range you want to sum, and then click the AutoSum button. Excel inserts the
SUM function and selects the cells in the column above the selected cell or in
the row to the left of the selected cell.
Note
When you allow AutoSum to select the cells to sum, it will stop at the first empty cell.
Also, AutoSum looks to the left and above the selected cell, not below or to the right.

You also can highlight the range of cells you want to sum. To do so, select
the range of cells (including blank cells) to the right of or below the range,
and then click the AutoSum button. Excel fills in the totals.

Using the Function Wizard
If you're not sure how a particular function works, the Function Wizard can

guide you through the process of entering the function.
To display the Function Wizard, open the Insert menu and choose the Function command, or click the Function Wizard button on the Standard toolbar.
The Function Wizard dialog box appears (see fig. 15.6).
Function Wizard - Step I or 2

~t Reeentl\l lbtd
~11
Ftnentftl
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~NO
IH E

Texl
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Information

0
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It •

{JftJDAv

I -· I ""'''

~~~

Fig. 15.6
In the Function
Wizard dialog box,
select the functio n
you want to use.
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The Function Category list displays categories of Excel's built-in functions,
and the Function Name list shows an alphabetized list of functions available
for the highlighted category. To access the DATE function, for example, select
Date & Time in the Function Category list, and then select DATE in the Function Name list. When you select a function, the function appears in the formula bar, and the formula bar is activated.
Note
If you know how to use the function, choose the Finish button. The function and its
arguments appear in the formula. Type the required arguments, and press enter or
click the enter button in the formula bar to enter the function in the cell.

After you select the function you want, choose Next or press enter to display
the next Function Wizard dialog box. The Step 2 dialog box prompts you to
enter the arguments required for the function (see fig. 15.7). An argument
can be a single cell reference, a group of cells, a number, or another function.
Some functions require a single argument; others require multiple arguments.
Function arguments are enclosed in parentheses, and arguments are separated
by commas.
Fig. 15.7
Enter the required
arguments for the
fun ction in the
Function Wizard
dialog box.
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Each of the argument text boxes must contain a cell address or data. If an
argument is required, the label to the left of the text box is bold.
To enter the argument data, click the mouse or press tab to position the insertion point in the first argument text box. The Function Wizard displays a
description of the argument in the display area above the text boxes. Enter
the values to be used for the arguments, use the mouse to select the cell(s) in
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the worksheet to be used for the argument, or use the keyboard to enter the
cell address(es). The Function Wizard displays the value to the right of the
text box (see fig. 15.8).
Fig. 15.8
Th is dialog box
contains multiple
arguments for the
Date fu nction.
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To enter the first argument for the function, select the cell that contains the
data you want to use. To indicate a range of cells, select the range you wa nt
to use in the formula. You also can enter the cell addresses fro m the keyboard. If, for example, you want to sum the numbers in cells 81, 82, and 83,
enter Bl:B3 or Bl,B2,B3 in the argument text box. Each argument appears
between the parentheses in the formula bar.
When you finish entering the arguments requ ired by the function, the result
of the formula appears in the Value box in the top right corner of the Function Wizard dialog box. Choose Finish to enter the function in the cell. The
dialog box disappears, and the result of the formula appears in the cell. ln
this case, the result is formatted as a date. To see the date as a serialized number, you must format the cell in a Number format. If the formula contains an
error, an alert box appears (see fig. 15.9).

6

Errer h fera111.

~·OK I
Click the Help button in the alert box to find out more about the function
error. A help window appears, displaying possible reasons for the error. Click
the window's close box to close it. To clear the error message, click OK.
In some cases, Excel highlights the part of the function that contains the
error. Edit the function in the formula bar, and when the formula is corrected
or complete, click the enter button or press enter on the numeric keypad.

Tip
If the Function
Wizard dialog
box is in the
way, move the
dialog box by
clicking and
dragging its title
bar.

Fig. 15.9
This alert box
appears if your
fo rmula contains
an error.
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Editing Functions
~

See "Editing
Worksheet
Data," p. 249

After entering a function, you can edit it. You can use the Function Wizard to
edit a function, or you can edit the formula and function directly in the cell.
To use the Function Wizard to edit a formula, follow these steps:
1. Select the cell that contains the function you want to edit.

~
~

2. Open the Insert menu and choose the Function command, or click the
Function Wizard button on the Standard toolbar. The Function Wizard
appears, displaying the function used in the formula.
3. Change any of the arguments as necessary.
4. Choose Finish when you complete the function. If the formula contains

another function, choose Next.
5. Repeat steps 3 and 4 for each function you want to edit.
To edit a function manually, follow these steps:
1. Select the cell that contains the function you want to edit.

2. Double-click the cell or click the formula bar.
3. Select the argument you want to change.
4. Enter the new argument.

5. Press enter or click the enter button in the formula bar.

Getting Help with Functions
As you are using Excel's functions, you can use Excel's help system for assistance. To get help while you are entering a function with the Function
Wizard, click the Help button.
To access Excel's on-line help for functions:
1. Choose the Microsoft Excel Help command from the guide menu

(the menu with the question mark icon).
2. Click the Search button.
3. Type functions in the text box in the Search dialog box.
4. Choose Functions, Worksheet from the displayed list and click Show

Topics.
5. Choose Alphabetical List of Worksheet Functions from the topic list at
the bottom of the dialog box and click Go To. Excel displays a Help
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window with an alphabetized list of functions (see fig. 15. 10). Click any
of the function names for help with a specific function. Click the close
box of the Help window when you finish viewing it.
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Troubleshooting
After I click the AutoSum button, Excel does not produce a total amount.
If you click the AutoSum button and there are no surrounding cells with numbers to
add, the SUM function does not recognize a range address to sum. Select the range
of cells you want to sum, and the range address appears within the parentheses.
Remember that to use the Auto Sum button, you must select a cell adjacent to the
values you want to sum, or you must select the range of cells (including any blank
cells) and then click the AutoSum button.

After I enter a function, Excel displays the error value #NAME? in the cell.
There are two possible causes: you specified a range name that does not exist, or you
misspelled the function name. To check, press ):(+U, and remove the equal sign(=)
from the beginning of the formula. Then double-check the spelling of the function.
If this spelling is incorrect, correct it, and then enter the equal sign. If the function
name is spelled correctly, the next step is to make sure that the range to which you
referred exists in the worksheet. To do this, click the arrow at the left end of the
formula bar, and check the range names in the drop-down list. If the name does not
appear in this list, use the Define command from the Name submenu on the Insert
menu to create the range name. When you do, the formula will return the correct
result.

Fig. 15.10
Sel ect the function
for which you
want help.
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Copying Formulas
When you copy a formula that contains cell addresses, the cell addresses
adjust to their new location. For example, when you copy the formula
=B5-B11 from cell 814 to cell C14, the cell addresses adjust to =C5-Cll (see
fig. 15.11). In Excel, these cell addresses are called relative cell references.
Fig. 15.11
When copied,
relative cell
references ad just
to their new
locations.
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See "Copying
Worksheet
Data," p. 252
See "Movi ng
Worksheet
Data," p. 257

If you want the cell add resses to remain the same when copied, use absolute
cell references in the formula. In an absolute cell reference, a dollar sign appears to the left of the column and/or row address- for example, $F$5 (see
fig. 15.12).

Create a mixed cell reference when you want either the column or row reference to be absolute and the other reference to be relative. $C9 is an example
of a mixed cell reference. When you copy a formu la that contains this type of
cell reference, the column reference remains the same, and the row reference
changes. Alternatively, when you copy a formula that includes a reference
such as C$9, the column reference changes, and the row reference remains
the same.

Linking Formulas
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Before you copy the formula that contains the cell reference, make the cell
reference absolute. Follow these steps:
1. Select the cell that contains the formula.

2. Press

~ +U.

3. Use the left- or right-arrow key or the mouse to position the insertion
point to the left of the cell or row referen ce, and th en type a dollar
sign (S).
4 . Press enter, or click the enter button in the formula bar.

Linking Formulas
When you use multiple worksheets in Excel, your formulas may need to refer
to cells in other worksheets. For example, if each sheet in your worksheet
contains sales data for each sales region, you can create a total worksheet and
sum the values for each region by linking formulas.

Creating Linking Formulas
To link formulas, follow these steps:
1. Enter the form ula as you normally would, up to the point where you

want to reference the cell.
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2. Click the tab of the worksheet that contains the cell you want to
reference. The formula displays the worksheet name.

3. Select the cell or range of cells you want to reference.
4. Press enter, or click the enter button in the formula bar. Excel displays
the worksheet name and cell references in the formula. For example,
cell B20 of figure 15.13 contains a reference to the sheet named Dallas
and appears as =Dallas 1814.
Fig. 15.13
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Creating Formulas That Link Workbooks
In addition to referring to cells in other worksheets, a formula can refer to
cells in other workbooks. Before you can link a formula to another workbook,
that workbook must be open.
To link to an other workbook, follow these steps:
1 . Enter the formula up to the point of reference.
2. From the Window menu, choose the workbook that contains the data

you want to reference.
3. If necessary, select the worksheet that contains the data you want to

reference. Then select the cell that contains the data you want to
reference.
4. Press enter, or click the enter button in the formula bar.
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Working with Range Names
As you become more proficient in writing formulas, you will find that cell
references are sorely lacking in describing the data that is being calculated. If
you saw the formula =B9-C9 in a worksheet, it wouldn't be clear which data
is being used.
Note
To display the cells to which a formula refers, select the formula in the worksheet and
choose the Trace Precedents command from the Auditing submenu on the Tools
menu. Use the Remove All Arrows command in the same submenu to remove the
graphics added by the Trace Precedents command.

By assigning a name to a cell or range of cells, you can describe the data in
your worksheets. The form ula +Total_Sales-Total_Expenses, for example,
instantly tells you what data the formula uses.
When naming a cell or range, keep the following naming rules in mind:
• The first character must be a letter or an underscore(_).
• The other characters can be letters, numbers, periods, or underscores (_).
• You cannot include spaces in the name. You can use an underscore
to separate words.
• The name can be up to 255 characters long.
• The name can use uppercase and lowercase letters.

Ill
Creating a Range Name
To create a range name, follow these steps:
1. Select the cell or range of cells you want to name.

2 . Click the Na me box located at the left end of the formula bar.
3. Enter the name you want to assign to the selected range.
4. Press enter.
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To create a range name by using an alternative method, follow these steps:

Tip
To move to a
range quickly,
type the range
to which you
want to go in
the Name box.

1. Select the cell or range of cells you want to name.

2. Open the Insert menu, choose Name, and then choose the Define
command from the submenu (or choose command+L). The Define
Name dialog box appears.
3. Type a name in the Names in Workbook text box.

4. Click OK.

To display a list of range names in the active worksheet, click the arrow next
to the Name box in the formula bar. The drop-down list displays all range
names in the worksheet (see fig. 15.14).
Fig. 15.14
This drop-down
list displays all
range names in the
worksheet.
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Inserting Names
After you assign a range name, you can refer to that range name the way you
refer to cell addresses.
To insert a name into a formula, follow these steps:
1. To create a formula that uses range names, type = (equal sign) to start
the form ula.
2. Open the Insert menu, choose Name, and then choose the Paste
command from the submenu. The Paste Name dialog box appears.
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3. In the Paste Name dialog box, select the name you want to insert.
4 . Click OK to close the dialog box.
5. Type the rest of the form ula, and press enter or click the enter button in

the formula bar when you finish (see fig. 15.15).
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Deleting Range Names
To delete a range name, follow these steps:
1. Open the Insert menu, choose Name, an d then choose the Define

command from the submenu. The Define Name dia log box appears
(see fig. 15.16).
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Fig. 15.16
You can delete
range names in
the Define Name
dialog box.
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2. In the Names in Workbook list, select the range name you want to

delete.
3. Click the Delete button.
4. Click OK.
Note
When you define names in the Define Name dialog box, use the Add and Delete
buttons to make multiple changes. Click OK when you finish making changes.

Creating Range Names from Existing Text
Excel enables you to create range names by using existing text from a
worksheet. Yo':! can, for example, use text that heads rows and columns to
name the ranges beside or below those heads. For example, figure 15.17
shows a range that has column headers at the top of the range and row headers in the left column of the range. The Create Names dialog box can be used
to automatically name the data in the range.
Fig. 15.17
Names will be
created from the
text that appears
in the first column
and the first row
of the selected
range.
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To create a range name using the Create Names command, follow these steps:
1. Select the range of cells that contains the text and the cells to be
named, as in figure 15.17.
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2. Open the Insert menu, choose Name, and then choose the Create
command from the submenu. The Create Names dialog box appears
(see fig. 15.18).
Fig. 15.18
Because of the
selected range, the
Top Row and Left
Column options
are chosen by
default.

3. Select the check box that shows the location of the cells containing the
text you want to use for range names. In our example, the correct options are chosen by default.
4. Click OK.

In our example, the range B4:B8 is named Week_1, and the range BS:DS is
named Kaley.
Troubleshooting
After I deleted a range name, Excel replaced some of the formulas in the worksheet with
the value #NAME?.

When you delete a range name, any formula that refers to the range name returns
#NAME?. To correct a formula that refers to a deleted range name, replace the
#NAME? reference with the appropriate cell address, or re-create the deleted range
name.
(continues)
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(continued)

After I create a formula that uses a name, Excel interprets the formula as a text entry.
When you use a range name as the first item in a formula, you must begin the formula with an equal sign (=), as in =SALES*4.05. Otherwise, Excel thinks you are
entering a text label.

From Here ...
For additional information on using formulas and functions in Excel, see the
following chapters:
• Chapter 12, "Creating Worksheets," introduces basic techniques such as
selecting cells and entering data.
• Chapter 13, "Editing Worksheets," shows you how to edit worksheet
data.
• Chapter 14, "Formatting Worksheets," teaches you how to format
numeric entries.
• Chapter 17, "Managing and Analyzing Data," presents the Excel
commands.

Chapter 16

Creating an Pri
Reports and Cha
by Todd Knowlton

Excel provides sophisticated charting capabilities that enable you to display
your worksheet data in graphical form. When you create a chart, you can
embed the chart in a worksheet alongside the data on which it is based, or
you can create a separate chart sheet. When you're ready to print worksheet
data and charts, you can create reports that consist of multiple worksheet
areas.
In this chapter, you learn to
• Define the area to be printed
• Define page settings
• Preview and print worksheet data
• Create and print reports
• Create a chart
• Enhance a chart
• Print a chart

Printing Worksheet Data
Excel provides many options that enable you to control the printed output of
your worksheets and charts. You can use the Print Preview command to

Ill

322

Chapter 16-Creating and Printing Reports and Charts

preview worksheet data before printing. The Page Setup command enables
you to define margin settings and to create headers and footers.

Printing a Particular Area
You can print the entire workbook, a specific worksheet in the workbook,
or a selected range of data. By default, Excel automatically selects and
prints the current worksheet. You can, however, define a portion of the
worksheet to be printed.
Printing a Specific Range
To print a specific range in the worksheet, follow these steps:
1. Select the range to be printed, using the mouse or the keyboard.
2. Open the File menu and choose the Print command, or press ;):C+P.
The Print dialog box appears, as shown in figure 16.1.

Fig. 16.1
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3. In the Print section of the dialog box, choose the Selection option.
4. Click OK. Excel prints the selected worksheet range.

Defining a Print Area
If you are printing the same range in a worksheet over and over, you can

define that range as the print area so that you no longer need to specify the
range each time you print the worksheet.
To define the print area, follow these steps:
1. Open the File menu and choose the Page Setup command. The Page
Setup dialog box appears.
2. Click the Sheet tab, as shown in figure 16.2.
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Fig. 16.2
You can define a
specific range of
the worksheet to
be printed.

a Down, tbiA Acroa
Q-.tiiOnOO..n

3. Click the Print Area text box, and define the area to be printed by selecting the range in the worksheet or by typing the range address. A
dashed border appears around the defined print area. Excel assigns the
name Print_Area to the selected worksheet range.
4. Click OK when you finish.

Removing a Defined Print Area
To remove a defined print area, choose Page Setup from the File menu, and
click the Sheet tab, if necessary. Delete the reference in the Print Area text
box, and click OK. Alternatively, choose the Name Define command from the
Insert menu, select the Print_Area name from the Names in Workbook list,
click Delete, and click OK. The name Print_Area will be preceded by the sheet
name.

Inserting and Removing Page Breaks
When you define a print area, Excel inserts automatic page breaks into the
worksheet. Automatic page breaks, which appear as dashed lines in the
worksheet, control the data that appears on each printed page. Excel also
inserts automatic page breaks when a selected print range cannot fit on a
single page. If you aren't satisfied with the location of the automatic page
breaks, you can insert manual page breaks.
You can insert two types of page breaks: vertical page breaks, which break
the print range at the current column, and horizontal page breaks, which
break the page at the current row.
Inserting a Vertical Page Break
To insert a vertical page break, follow these steps:
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Tip
You can set a
horizontal and
vertical page break
simultaneously by
selecting a single
cell below the row
and to the right of
the column where
you want the break
to appear, and
choosing Page
Break from the
Insert menu.

1. Click the heading of the column to the right of where the page break
should occur.
2. Open the Insert menu and choose the Page Break command. A dashed

line appears in the worksheet, indicating the page break.
Inserting a Horizontal Page Break
To insert a horizontal page break, follow these steps:
1. Click the heading of the row below where the page break should occur.
2. Open the Insert menu and choose the Page Break command. Excel adds

the page break.
Figure 16.3 shows a horizontal page break added to a worksheet.

Fig. 16.3
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Removing Page Breaks
To remove a page break, select the cell below or to the right of the page-break
intersection, and then choose Remove Page Break from the Insert menu.

Printing Worksheet Data
Fitting the Print Range to a Single Page
If the specified print range is a few lines too long to print on a single page,
you can fit the worksheet to the page. When you use this method, Excel
scales the worksheet so that it fits on a single page.

To fit the print range on a single page, follow these steps:
1. Open the File menu and choose the Page Setup command.
2. Click the Page tab.

3. Select the Fit To option. By default, the Fit To option is one page wide
by one page tall.
4. Click OK. When you print, Excel scales the worksheet range to a single

page.

Modifying the Page Setup
The Page Setup command enables you to define the page settings for the
printed output. You can change the orientation of the page, change the
margins and text alignment, and set print titles.
Changing the Page Orientation
The default setting for printed output arranges the data in portrait orientation-that is, the data is arranged vertically on the page. You may, however,
want the data to print in landscape orientation-arranged horizontally on
the page. If the data range is wide, for example, you may want to print it in
landscape orientation, across the width of the page.

To change the page orientation, follow these steps:
1. Open the File menu and choose the Page Setup command.
2. Click the Page tab.

3. Select the desired orientation option.
4. Click OK.

Changing Margins
The margins define the distance between the printed output and the edges of
the page. Excel enables you to change the top, bottom, left, and right margin
settings. In addition, you can specify margins for the headers and footers, as
well as center the print range between the margins, either horizontally or
vertically.
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To change the margins, follow these steps:
1. Open the File menu and choose the Page Setup command.

2. Click the Margins tab.
3. Enter the measurements, in inches, in the appropriate text boxes. You

also can click the up and down arrows to change the margin settings by
increments. Figure 16.4 shows the margins for the current print range.
Fig. 16.4
Use the Margins
tab of the Page
Setup dialog box
to change the
margins and the
alignment of data
on a page.

Tip
You also can
change the margins
from within print
preview by dragging the margin
borders. See
"Changing Margins
and Other Settings
in Print Preview"
Iater in this
chapter.
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4. To indicate the header and footer margins, specify the measurement in
the From Edge section of the dialog box.
5. To center the data between the top and bottom margins on the page,
select the Vertically option. To center the data between the left and
right margins, select the Horizontally option. To center the text both
horizontally and vertically on the page, select both options.
6. Click OK.

Setting and Removing Print Titles
When you print large worksheets, you can set print titles so that information,
such as worksheet titles, column headings, and row headings, appears on
each page in the printout.

To create print titles, follow these steps:
1. Open the File menu and choose the Page Setup command.

2. Click the Sheet tab.
3. If you want to define titles across the top of each page, select the Rows
to Repeat at Top box. If you want to define titles down the left side of
each page, select the Columns to Repeat at Left box (see fig. 16.5).
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Fig. 16.5
In the Page Setup
dialog box, define
the area to be used
as the print title.

ll

4. If you are defining titles to appear across the top of each page, select the

row headings containing the data you want to use as titles, or enter the
row addresses.
If you are defining titles to appear down the left side of the page, select
the column headings containing the data you wa nt to use as titles, or
enter the column addresses.
No~

·

When you print a worksheet that contains print titles, don't select the range
containing the titles when you define the print area. Otherwise, the titles will
appear twice on the first page of the printout.

5 . Click OK.

To remove print titles, follow these steps:
1. Open the File menu and choose the Page Setup command.

2. Click the Sheet tab, if necessary.
3. Delete the cell references in the Print Titles section of the dialog box.
4. Click OK.

Setting Other Print Options
You can define additional print settings in the Page Setup dialog box. You
can include the worksheet grid lines in the printout; print notes that have
been added to cells; print the data in black and white, even if color has been
applied to the worksheet; and include the row and column headings.
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Open the File menu, choose Page Setup, and then click the Sheet tab. In the
Print section of the dialog box, select or deselect the check box adjacent to
the appropriate print option.

Creating Headers and Footers
Headers and footers enable you to add text-such as the current date, page
number, and file name-to the top and bottom of the printed page. Excel
provides default header and footer information (the name of the current
sheet is centered in the header, and the current page number is centered in
the footer). You also can select additional options, and define your own
header and footer information.
Using Predefined Headers and Footers

To select one of Excel's predefined header and footer options, follow these
steps:
1. Open the File menu and choose the Page Setup command.
2. Click the Header/Footer tab. Figure 16.6 shows the predefined header

and footer options.
Fig. 16.6
Select the text you
want to use in the
header and foote r
area of the printed
page.

( ~r1o1 Prevlev

J

Opllou...
Holp

..,.,
3. Click the arrow next to the Header box, and select a header from the

drop-down list.
4 . Select the data you want to use as a footer from the Footer list.

5 . Click OK.

Note
To remove a header or footer, select None from the appropriate list.

Printing Worksheet Data

329

Creating Custom Headers and Footers
Instead of using a predefined header and footer, you can define your own
custom header and footer. Follow these steps:
1. Open the File menu and choose the Page Setup command.
2 . Click the Header/Footer tab.
3. If appropriate, select an existing header or footer that resembles the

header or footer you want to create.
4. Select the Custom Header or Custom Footer option to display a new

dialog box. Figure 16.7 shows the Custom Header dialog box.
Header

text,'""·•otto•.
t•• ••:
text-·'""·-, ..

To rorMIIut: ooloct IM
lllo rut
Te faaart a,... •••..r. Ute,. tiM, ftla••· er
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tM '""'rloto httu.

Each text box that appears in the dialog box controls the alignment of
the text in the header or footer. Data can be left-aligned, centered, or
right-aligned. Excel uses codes to create certain types of text in the
headers and footers. The Page Number code, for example, is used to
insert page numbering. Th e buttons that appear above the text boxes
are used to insert the codes. Table 16.1, which follows these steps, describes the code buttons you can use in the header and footer.
5. Select one of the three text boxes, and then type the header or footer
text, or click a button to enter a header or footer code. To apply text
formatting to the header or footer information, click the Font button to
display the Font dialog box, and select the appropriate options.
6. Click OK.

Fig. 16.7
Create custom
headers and
footers by using
text boxes and
buttons that
appear in this
dialog box.
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Table 16.1

Button

Header and Footer Codes

Name

Code

Description

Font

None

Displays the Font dialog box

Page Number

&[Page]

Inserts the page number

Total Pages

&[Pages]

Inserts the total number of pages

Date

&[Date]

Inserts the current date

Time

&[Time]

Inserts the current time

Filename

&[File]

Inserts the file name

Sheet Name

&[Tab]

Inserts the name of the active sheet

Previewing a Worksheet
You can preview the data before you print the worksheet to make sure that
the data appears the way you want. You also can change the margin settings
and column widths, if necessary.
To preview the data, follow these steps:

1. Open the File menu and choose the Print Preview command, or click
the Print Preview button on the Standard toolbar. Excel switches to
Print Preview and displays the print range, as shown in figure 16.8.
Tip
In Print Preview,
you also can press
the page up and
page down keys to
display each page
in the document.
Press the home key
to move to the first
page; press the end
key to move to the
last page.

2. Click the Next and Previous buttons to move from page to page. Notice
that these buttons appear dimmed if the data you are previewing fits on
a single page.
Zooming In and Out
For a closer look at data, you can zoom in and view an enlarged display;
when you want to see more of the data, you can zoom out.

To zoom in on the worksheet, click the Zoom button, or position the mouse
pointer over the section you want to view, and click. The mouse pointer
changes to a magnifying glass when positioned over the page. To view other
areas of the page, use the vertical and horizontal scroll bars. To zoom out,
click the Zoom button again, or click anywhere on the displayed page.

Printing Worksheet Data
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Fig. 16.8
Print Preview
shows what the
worksheet will
look like when
printed.

Changing Margins and Other Settings In Print Preview
If, while previewing the worksheet, you find that the current margins or col-

umn widths are not adequate, you can change them in Print Preview. When
you click the Margins button, light-gray boundaries appear around the page,
indicating the margins. Black handles also appear, indicating the top, bottom, left, and right margins. Square handles appear along the top of the page,
with lines indicating the width of each column. Figure 16.9 shows margin
and column markers in print preview.
Fig. 16.9
You can change
margins and
column widths by
dragging the
markers.
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To adjust th e margins, position the m ouse po inter over the handle that represents the margin you want to change. When you do, the m ouse pointer
changes to a crossbar. Press and hold the m ouse button . The status bar shows
the actual m argin setting. Drag the hand le to the appropriate location. When
you release the mouse button, the margi n adjusts, and the data is reposition ed on the page.

~

See "Changing
To change a column width, click the square handle that indicates the co lumn
Column Width
wid th you want to change. The status bar displays the current column wid th.
and Row Height," Drag the marker to increase or decrease the colum n width. When you release
p.276
the mo use butto n, the colum n width and data adj ust to fit the new size.
When you're satisfied with th e way the data appears, click the Print button to
print the worksheet. To return to the worksheet, click the Close button.
Note

Changes made to column widths while in Print Preview will be applied in the
worksheet and will remain changed after printing.

Printing the Worksheet
After you define the print settings and preview the data, you're ready to print
the worksheet. The File Print command enables you to specify the number of
copies you want to print, as well as the number of pages (if the print range
spans multiple pages). Yo u also can specify the da ta you want to print, if you
have not already defined a print area.
To print the worksheet, follow these steps:
1. Open the File menu and choose th e Print command, or press ~ + P.
The Print dialog box appears. The Print dialog box will vary slightly,
depending o n your printer type and th e driver you are using.
2. If you have not defined a print area, you can specify the data you wa nt
to print by selecting options in the Print section of the dialog box (see
fig. 16. 10).
3. Choose the Selectio n option to print the selected range of cells; choose
the Selected Sheets option to print the selected worksheets in the workbook; or choose the Entire Wo rkbook option to print every worksh eet
in the current workbook.
4. To specify the number of copies to be printed, enter the amount in the
Copies box.
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Fig. 16.10
The Print dialog
box contains
options that enable
you to specify what
you want to print.

I
I
I

5. To specify a specific range of pages to be printed, enter the range in the

Pages section of the dialog box.
6. When you're ready to print the worksheet, click Print.
Note
The Print dialog box also includes buttons that enable you to access the Page Setup
command and Print Preview.

Troubleshooting
While attempting to remove a page break, I pulled down the Insert menu, but the
Remove Page Break command was not displayed in the menu.

To remove a manual page break, you first must select the cell that contains the
manual page-break setting. When the highlighted cell is correctly positioned, the
Remove Page Break command appears in the Insert menu. To minimize the chance
for error, select a range of cells surrounding the page break. When you open the
Insert menu, the Remove Page Break command should appear.
After selecting the entire worksheet, I chose the Remove Page Break command, but Excel
removed only some of the page breaks.

A print area must be defined for the worksheet. When you define a print area, Excel
automatically inserts page breaks into the worksheet. Although these page breaks
appear similar to the manual page breaks that you insert into the document, you
can't use the Remove Page Break command to delete them; instead, you must delete
the defined print area.
To delete a defined print area, choose Page Setup from the File menu, and click the
Sheet tab. Delete the range address in the Print Area text box, and click OK. When
you return to the worksheet, the page breaks no longer appear.

Tip
Click the Print
button in the
Standa.rd toolbar
to bypass the Print
dialog box and
send the output
di.rectly to the
printe.r with the
default print
settings.
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Using Views and Reports
Excel provides two add-ins that enable you to create and generate printed
reports: the View add-in lets you assign names to worksheet ranges and to
include the print settings and display options for the ranges; the Report Manager add-in enables you to create a report consisting of named views and
scenarios.

Installing the View and Report Manager Add-Ins
Before you can define a named view or create a report, you must install the
View Manager and Report Manager add-ins.
To install the add-ins, follow these steps:
..,. See "Creating
a Scenario,"
p.385

1. Open the Tools menu and choose the Add-Ins command. The Add-Ins

dialog box appears (see fig. 16.11).
Rdd-lns I

Fig. 16 .11
Use the Add-Ins
dialog box to
install Excel
add-ins.
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2. Select the Report Manager add-in and the View Manager add-in from
the Add-Ins Available list. If an add-in is not listed, you will need to run
Excel Setup to install it on your hard disk.
3 . Click OK. The Print Report command is added to the File menu; the

View Manager command is added to the View menu.

Creating a View
With the View Manager command, you can define multiple print ranges with
differen t display and page-setup characteristics in a single worksheet. Normally, every print area of a worksheet must contain the same display characteristics. By using named views, however, you can print multiple ranges with
different print settings at the same time.
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To create a view, follow these steps:
1. Select the range of cells you want to define as a view.

2 . Open the View menu and choose the View Manager command. The

View Manager dialog box appears (see fig. 16.12).
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Fig. 16.12
Create multiple
views of worksheet
data in the View
Manager dialog
box.

3 . Click the Add button . Th e Add View dialog box appea rs (see fig. 16.13).

4. Enter a name for the view in the Name text box.
5 . Click OK.
Rdd Ulew
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__j ( Hol• )
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Fig. 16.13
Enter a name for
the view in the
Add View dialog
box.

Creating a Report
If your worksheet consists of m ultiple views of your worksheet, or scenarios
of data, you can print those different views and scenarios as a report.
Scenarios are used to analyze data in worksheets.
To create a report, follow these steps:
1. Open the File menu and choose the Print Report command. The Print

Report dialog box appears (see fig. 16.14).
2. Click the Add button to create the report. The Add Report dialog box

appears (see fig. 16. 15).

~

See "Performi ng
What-If Analysis
with Scenarios,"
p.38S
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Fig. 16.14
The Print Report
dialog box
manages reports.
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3. Enter a name for the report in the Report Name text box.
4 . Select the view you want to add to the report from the View drop-down

list, and then choose Add. The view you added appears in the Sections
in this Report list.
5. Select the scenario you want to add to the report from the Scenario

drop-down list, and then choose Add. The scenario you added appears
in the Sections in this Report list.
6 . To change the order of the views and scenarios in the Sections in this

Report list, select a view or scenario, and then click the Move Up or
Move Down button to rearrange the order.
7. Repeat steps 4-6 until you finish adding views and scenarios to the

report.
8. Select Use Continuous Page Numbers to number the pages

consecutively.
9. Click OK. You return to the Print Report dialog box.
10. Click Print to print the report, or click Close to close the dialog box

without printing the report.

Using Views and Reports

Editing and Printing a Report
If you want to change the contents of a report or print a report, you can use

the Print Report command to do so.
To edit a report, follow these steps:
1. Open the File menu and choose the Print Report command. The Print

Report dialog box appears.
2. Select the name of the report yol want to edit from the Reports list, and

then choose Edit.
3. Change the views and scenarios, as outlined in the preceding section.
4. Click OK.

To print a report, follow these steps:
1. Open the File menu and choose the Print Report command. The Print

Report dialog box appears.
2. Select the report you want to print from the Reports list.

3. Click the Print button. The Print dialog box appears.
4. Specify the number of copies to be printed.
5. Click OK to print the report.

Troubleshooting
I want to create a report, but the Print Report command does not appear in the File
menu.
When the Print Report command does not appear in the File menu, it means that the
Report Manager add-in has not been installed. To install the Report Manager add-in,
choose the Add-Ins command from the Tools menu. In the Add-Ins Available list,
check marks appear next to the names of the add-ins that are currently installed.
Select Report Manager to add a check mark to the left of the name, and click OK.
The Print Report command now appears in the File menu.

When I print a report, Excel numbers each page in the report as page 1.
To use consecutive page numbers in the report, choose the Print Report command
from the File menu, select the name of the report from the Reports list, and click Edit.
Select the Use Continuous Page Numbers option, and click OK. The next time you
print the report, Excel will number the pages consecutively.
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Using Charts
By using a chart, you can present worksheet data in graphical form. When
you create a chart, the worksheet data used to create the chart is linked to it.
When the worksheet data changes, the chart is updated to reflect those
changes. In Excel, you can create an embedded chart, which is added directly
to a worksheet. You also can create a chart in a chart sheet, which is a separate sheet in the workbook. After creating a chart, you can add titles and grid
lines. Use autoformats to change the format of a chart and to edit the data
used in the chart.

Creating a Chart with the ChartWizard
To create an embedded chart with the ChartWizard, follow these steps:
1. Select the data you want to chart.

2. Click the ChartWizard button. The mouse pointer changes to a chart
with a plus sign.
3. Position the mouse pointer in the worksheet where you want the chart

to appear; then click and drag the mouse to draw the boundaries.
4. Release the mouse button when the chart is the size you want.

The Step 1 ChartWizard dialog box appears (see fig. 16.16).
Fig. 16.16
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5. If the selected range address that appears in the Range text box is correct, choose Next. Otherwise, select the range of cells in the worksheet
that you want to chart or enter the range address; then choose Next.
The Step 2 dialog box appears.
Note
The chart is linked to the cells you indicate in the Step 1 ChartWizard dialog
box. When the data in the selected range changes, the chart is updated to
reflect the changes.
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6 . Select a chart type (see fig. 16.17).
ChertWlzenl - step 2

or 5

Fig. 16.17
Select the chart
type in this
dialog box.

7. Choose Next. The Step 3 dialog box appears.
8. Select a chart format (see fig. 16.18).
Chert Wizard - Step 3 or 5

Fig. 16.18
Select the chart
format in this
dialog box.

9 . Choose Next. The Step 4 dialog box appears, displaying a sample of the
chart in the Sample Chart area (see fig. 16.19).
ChertWizerd - Step 4 or 5

Fig. 16.19
A sample of the
chart appears in
this dialog box.
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10. If the sample chart is incorrect, select other options, and then choose

Next. The Step 5 ChartWizard dialog box appears.
11 . If you want to add titles to the chart, enter them in the Chart Title and

Axis Titles text boxes (see fig. 16.20).
Fig. 16.20
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12. Click the Finish button. The chart appears in the worksheet

(see fig. 16.21).
Fig. 16.21
The completed
chart is added to
the worksheet.
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Note
If you need to return to the preceding ChartWizard dialog box, click Back. You can
close the ChartWizard during any step by choosing Finish. When you click Finish, the
ChartWizard makes the selections for you.
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To create a chart sheet, follow these steps:
1. Select the cells that contain the data you want to chart.
2. Open the Insert men u, choose Chart, and then choose the As New

Sheet command from the submenu; or press F11. The Step 1
ChartWizard dialog box appears. (Refer to the preceding section for
instructions on how to use the ChartWizard.)
3. Click Finish. Excel bypasses the ChartWizard and creates a chart based
on the default chart settings (see fig. 16.22).
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Fig. 16.22
A new chart sheet
is added to the
workbook.
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Moving and Sizing a Chart Object
If the chart you create is added to a worksheet, you can resize the chart or
move it to another location. Before you can move or resize a chart, you must
select the chart.
To select a chart that is on a worksheet, position the mouse pointer in the
chart area and click. Small black squares called handles appear on the boundaries of the chart, indicating that it is selected (see fig. 16.23).

Tip
You can copy a
chart, created in a
separate sheet, to
another worksh eet
by using the Copy
and Paste commands from the
Edit menu.
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Fig. 16.23
Handles appear on
the chart boundaries when a chart
is selected.
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To resize a chart, follow these steps:
1. Select the chart.
2. Drag a handle until the chart reaches the desired size (see fig 16.24).

To size the object horizontally and vertically at the same time, drag one
of the corner handles. To increase or decrease the chart either horizontally or vertically, drag one of the middle handles.
Fig. 16.24
Drag one of the
handles to resize
the chart.
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To move a chart, simply select the ch art and drag the chart to a new location.

Changing the Chart Type
You can change the type and format of a chart at any time. When you
change a cha rt type, Excel redraws the chart to reflect the new type.
To change the chart type, follow these steps:
1. Double-click the chart whose type you wa nt to change. A dashed border

outlines the chart (see fig. 16.25).
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The dashed border
indicates that the
chart can be
edited.
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2. Open the Format menu and choose the Chart Type command.
The Chart Type dialog box appears (see fig. 16.26).

3. Select the type of chart you want to use.
4. Click OK. Excel displays the chart in the new chart type (see fig. 16.27).
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Fig. 16.26
Use the Chart
Type dialog box to
change a chart to
another form.

I

Fig. 16.27
The column chart
is now displayed
as a bar chart.

You also can change the chart type using the Chart toolbar. Click the down
arrow next to the Chart Type button and choose a chart type from the icons
that appear.

Enhancing a Chart
Excel provides many commands that enable you to enhance your charts. You
can, for example, add data labels to a chart to annotate the chart elements.
You also can add grid lines and titles to a chart.
To add data labels to a chart, follow these steps:
1. Double-click the chart you want to enhance, or activate the chart sheet.
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2. Open the Insert menu and choose the Data Labels command. The Data
Labels dialog box appears (see fig. 16.28).
Fig. 16.28
Use the options in
the Data Labels
dialog box to
annotate the chart
elements.
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3. Select the type of data labels you want to display.
4. Click OK. Excel adds the data labels to each data series in the chart

(see fig. 16.29).
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Fig. 16.29
In this figure, the
actual data values
appear on the
chart.
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To add grid lines to a chart, follow these steps:
1. Double-click the chart you want to enhance, or activate the chart sheet.

2. Open the Insert menu and choose the Gridlines command.
The Gridlines dialog box appears (see fig. 16.30).
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Fig. 16.30
Use this dialog
box to add major
and minor grid
lines to a chart.
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3. Select the type of grid lines you want to display.
4. Click OK. Excel adds the grid lines to the chart (see fig. 16.31).
Fig. 16.31
In this figure,
ma jor grid lines
have been added
to the x-axis.

II
Tip
To add horizontal
grid lines to a
chart quickly, click
the Horizontal
Gridline button.
Click this button
again to remove
the grid lines.

To add titles to a chart, follow these steps:
1. Double-click the chart to which you want to add titles, or activate the

chart sheet.
2. Open the Insert menu and choose the Titles command. The Titles dialog box appears (see fig. 16.32).

3. Select the type of titles you want to add, and then click OK. The dialog
box closes, and you return to the chart, in which the title objects now
appear.
4. Type the text for the selected title, and press return.

5. If you added any other titles, click them and type text for them as well.
The titles appear in the chart (see fig. 16.33).
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Fig. 16.32
Use the Titles
dialog box to select
titles.
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Fig. 16.33
In this figure, titles
have been added
to the chart.

To apply an autoformat to a chart, follow these steps:
1. Double-click the chart you want to format.
2. Open the Format menu and choose the AutoFormat command.

The AutoFormat dialog box appears (see fig. 16.34).
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Fig. 16.34
Select a built-in
autoformat to
apply to a chart.
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3. Choose the Built-In option, if necessary.
4. Select the type of chart you want from the Galleries list.
5. Select the format you want to use from the Formats area.
6. Click OK. Excel applies the autoformat to the chart.

To create a custom chart format, follow these steps:
1. Double-click the chart that contains the formats you want to define as a
custom chart format, or activate the chart sheet.
2. Open the Format menu and choose the AutoFormat command. The

AutoFormat dialog box appears.
3. Select the User-Defined option. After you select that option, the buttons
in the dialog box change.
4. Click the Customize button. The User-Defined AutoFormats dialog box
appears (see fig. 16.35).
Fig. 16.35
Customized chart
formats appear in
the Format Sample
area.
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5. Click the Add button. The Add Custom AutoFormat dialog box appears
(see fig. 16.36).
Fig. 16.36
Enter a name and
description for the
custom
autoformat.
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6. Enter a name for the autoformat in the Format Name text box and a

description in the Description text box.
7. Click OK. You return to the User-Defined AutoFormats dialog box,

where the custom autoformat now appears in the Formats list (see
fig. 16.37).
User- Defin ed RutoFormats
Thb dfatog t11ova vou to f'QIIke tiM ectlw 'bert a ~.Det·deffned
au1oformet or to dtltte 1 ustr- det'1 ned autoformat frorn the
Formtts 11Jt.
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~
I

( ~~elite

[~ ,I

Fig. 16.37
The custom
autoformat has
been added to the
Formats list.

Formot O..Orfplfon:

8. Click Close.

To apply a custom autoformat, follow these steps:
1. Double-dick the chart you want to format, or activate the chart sheet.

2. Open the Format menu and choose the AutoFormat command. The
AutoFormat dialog box appears.
3. Choose the User-Defined option.

4. Select the format you want to use from the Formats list.

II
Tip
To remove an
autoformat and
return to the
default chart
fo rmat, cl ick the
Default Chart

button.
5. Click OK.

Ill
Editing a Chart
When you use the ChartWizard to create charts, Excel plots the data according to the selected worksheet range. You can use several commands to edit an
existing chart. For example, you can delete a data series from a chart, add a
new data series to a chart, and change the order in which the data series appears.
To delete a data series from a chart, select the data series you want to remove,
press the delete key, and dick outside the chart. Excel removes the data series
and redraws the chart to reflect the deletion.
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To add a data series, follow these steps:
1. Double-click the chart to which you want to add new data, or switch to

the chart sheet that contains the chart.
2. Open the Insert menu and choose the New Data command. The Add

Data dialog box appears (see fig. 16.38).
Fig. 16.38
Indicate the range
that contains the
data you want to
add.
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3. Enter the range in the worksheet that contains the data you want to
add.
4. Click OK. Excel adds the data series to the chart.

To change the order of the data series, follow these steps:
1. Double-click the chart you want to modify, or switch to the chart sheet.
2. Open the Format menu and choose the Chart Type command.

The Chart Type dialog box appears.
3. Click the Options button.
4. Select the Series Order tab.

5. Select the series you want to change, and then click the Move Up or
Move Down button until the series a.re listed in the order you want
(see fig. 16.39).
6. Click OK.
Fig. 16.39
Change the order
of the data series
markers as they
appear in the
chart.
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Printing Charts
Printing charts in Excel is no different than printing any worksheet range.
You can specify print options for charts in much the same way that you do
for data that appears in the worksheet. You can, for example, specify the size
of the chart and the printing quality, and preview the chart before printing.
Before you print a chart, you need to specify the chart print settings. Follow
these steps:
1. Double-click the chart you want to print, or move to the chart sheet

that contains the chart you want to print.
2. Open the File menu and choose the Page Setup command.

Tip
To prin t the chart
with the default
print settings, click
the Print button in
the Standard
toolbar.

3. Click the Chart tab. Figure 16.40 shows the printing options that are
available for a chart.
4. Select the appropriate chart size in the Printed Chart Size area of the

dialog box.

( Pr1ol PnYIOY )

Fig. 16.40
The Chart tab of
the Page Setup
d ialog box
includes options
for printing charts.

O~lloao ••.

lllilp

Ill
5 . To print the chart in black and white, select the Print in Black and

White option in the Printing Quality area.
6 . When you finish specifying the print settings, you can print the chart.

Click the Print button in the Page Setup dialog box. The Print dialog
box appears.
7. Click Print to accept the print settings and begin printing the chart.
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Troubleshooting
I want to access the chart commands when I embed a chart in my worksheet.

To access the chart commands for an embedded chart, you must double-click the
chart you want to edit. When you do, Excel changes the menu commands in the
Format and Insert menus to reflect commands for editing charts. When you create a
chart in a separate chart sheet, the Insert and Format menus automatically contain
these commands.
When I use the Autoformat command to change the chart type, /lose some of the
formats from my chart.

When you use the AutoFormat command in a chart that has already been custom
formatted, you lose some or all of the chart's formatting. To change the chart type of
an existing chart, yet retain the custom formatting, choose the Chart Type command
from the Format menu, or select a chart type from the Chart Type list on the Chart
tool bar.

•
r

'

My chart has only one data series, so I don't want to display the legend with the chart.

To remove the legend box from a chart, select the chart and then click the Legend
button in the Chart toolbar. Excel removes the legend box from the chart.
I want to print a chart that is embedded in a worksheet. But when I select the chart and
choose Print from the File menu, Excel prints the entire worksheet.

To print an embedded chart, first double-click the chart to select it, and then choose
Print from the File menu. Excel will print only the selected chart. To print an embedded chart along with a selected range of cells, you must highlight the range of
worksheet cells that contain the data and the chart.

From Here ...
In this chapter, you learned the basic techniques for printing data and charts
in your worksheets. You may want to explore the following chapters for additional information:
• Chapter 17, "Managing and Analyzing Data," shows you how to use
the Scenario Manager and other features to analyze worksheet data.
• Chapter 25, "Creating Charts," teaches you how to create graphs with
Microsoft PowerPoint.
• Chapter 29, "Sharing Data between Applications with Linking and
Embedding," shows you how to link a chart to a Word document.

From Here...

• Chapter 31, "Using Mail with Other Microsoft Office Products,"
explains how to distribute worksheet information electronically.
• Chapter 34, "Using Office Applications To Create a Presentation,"
shows you how to create a presentation with charts created in Excel.
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Managing a d
Analyzing D ta
by Todd Knowlton

With Excel, you can manage data by creating a list. A list is a simple database.
After information is organized into a list format, you can find and extract
data that meets certain criteria. You also can sort information in a list to put
data into a specific order, and you can extract, summarize, and compare data.
You also can create a Pivot Table to summarize information in an Excel list.
Excel 5.0 provides many tools that enable you to analyze and perform more
complex calculations than the typical worksheet formula allows. The Goal
Seeker command and Solver add-in enable you to calculate an answer based
on one or more calculations. When you need to generate different answers
for what-if analysis, the Scenario Manager enables you to do just that. Annotating worksheet cells helps both you and others who use your spreadsheet to
understand formulas and logic.
In this chapter, you learn to
• Create a list
• Use a data form to enter and edit records
• Sort and filter data in a list
• Generate subtotals and grand totals
• Create pivot tables
• Use the Goal Seeker to calculate a defined result
• Find answers to problems using the Solver
• Annotate formu las with n otes

Ill
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Creating and Editing a List
A list is information in worksheet cells that contain similar sets of data. A list
is a simple database. If you have ever used Microsoft Works, you've probably
seen databases similar to what Excel calls a list. When information is organized in a list, you can sort, filter, and summarize data with subtotals. Each
column in a list represents a category (called a field) and determines the type
of information required for each entry in the list. Each row in a list forms a
record.

For example, figure 17. 1 shows a sample list. The columns labeled Store, Last
Name, First Name, Position, Start Date, and Sales Points are the fields for the
list.
Fig. 17.1
In this sample list,
employees and
their sales points
are tracked.
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To create a list, enter a column heading in each column in the section of the
worksheet where you want to start the list. You can create a list in any area
of the worksheet. just make sure that the area below the list is clear of any
data so that the list can expand without interfering with other data in the
worksheet.
You enter data in the rows im mediately following the colum n heading to
form a record. Every record m ust have the same fields, but you don't have to
enter data into all fields.
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To facilitate entering and editing records in a list, Excel provides a data form
that presents an organized view of the data and makes data entry easier and
more accurate. The form displays field names, text boxes for data entry, and
buttons for adding, deleting, and finding records. You can enter new records,
edit existing records, find records, and delete records using the data form.

Adding Records with the Data Form
The data form provides text boxes, using the column headings or the field
names from your list. You enter the data for each field in each text box on
the form .
To add a record and enter data using the data form, follow these steps:
1. Select any cell in your list and the column headings.
2. Open the Data menu and choose the Form command. The Data Form
dialog box appears, as shown in figure 17.2.
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3. To add a new record to th e list, click the New button. A new blank form
appears.
4 . Enter the appropriate data in each text box on the for m.
Press tab to move forward to the next text box. Press shift+tab to move
to the previous text box.

Fig. 17.2
The data form
displays the field
names and text
box to the right of
each field name.

358

Chapter 17-Managing and Analyzing Data
5. When you have finished entering data for the record, press return to

add the new record to the list. Another blank form appears, enabling
you to enter another new record.
Tip
If you type
data fo r a new
record in the
list and then
decide you
don't want to
add th e record,
click the Restore button to
erase the entry
from the form.
The Resto re
button must be
clicked before
you enter the
new record.

6 . Click the Close button to return to the worksheet.

Viewing Records w ith the Data Form
You can use the data form to view records in your list. Click a cell in your list,
and choose the Form command from the Data menu. The Data Form appears
with the first record displayed.
Use the following procedures to view records in a list:
To

Do this

View the next record

Click Find Next or press down arrow

View the previous record

Click Find Prev or press up arrow

Move to a new record form

Press Control+page down

View the fi rst record

Press Control+page up

You also can use the scroll bars to view each record in your list.
If you click the Find Next button to view the next record in the list and Excel
beeps, you are viewing the last record in the database. As you view each
record in the list, the data form displays the current record number in the top
right corner of the dialog box, as shown in figure 17.3.
Record number

Fig. 17.3
This screen
displays the 11th
record in a list of
18 records.
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Deleting Records with the Data Form
The data form also can be used to delete records from your list. When you use
the form to delete records, you can delete only one record at a time.
To delete a record with the data form, follow these steps:
1. Select any cell in your list.

2. Open the Data menu and choose the Form command. The data form
appears.
3. Click the Find Next or Find Prev button, use the scroll bar, or press the

up or down arrow to move to the record you want to delete.
4. When the record you want to delete appears in the form, click the

Delete button to delete the record.
The records below the deleted record will be renumbered to account for
the deleted record. Excel prompts you with the dialog box shown in
figu re 17.4 to verify that you want to delete the record.

ot ....... ,_,.. vlll ... ,......

at,, ..,""·
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Ok

B

Fig. 17.4
A m essage box
appears reminding
you that the record
wil l be perman ently deleted.

5. Click OK or press return to delete the record, or click Cancel to keep the

record.
6. Click the Close button to return to the worksheet.

Finding Records with the Data Form
You can use the data fo rm to find particular records in your database. When
you use the data form, you can view only one found record at a time.
To find records from the data fo rm, follow these steps:
1. Select a cell in the list.
2. Open the Data menu and choose the Form command.
3. Click the Criteria button.
4. Select a text box and enter the criteria or pattern for which you want to

search, as shown in figure 17.5.

Ill
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5 . Click the Find Next button or press the down arrow after you have
entered the criteria. If no matches exist, you hear a beep. Click the Find
Prev button or press the up arrow if you want to search backward
through the database to find a match. Click Find Next again to see if
more than one match exists.
6. Click the Close button to close the dialog box.

Fig. 17.5

Employee list

In this example,
the search
criterion is a Sales
Points greater
than 18.
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Note
You can use multiple criteria when searching for records. To do so, enter the criteria
values in the appropriate text boxes.

Troubleshooting
After I choose the Form command from the Data menu, Excel displays an error message
stating that no list was found.

Select any cell within the list on your worksheet, and choose the Form command
again. In order to use the Form command to manage information in your list, you
must first select the list you want to modify before you choose the command.
When I choose New to add a new record to the list in the data form, Excel displays the
message Cannot extend list or database, and I can 't enter a new record.

The data form wi ll not allow you to add new records to the list if there aren't enough
blank rows below the current list range. Click OK to close the dialog box, and then
click Close to close the data form. If any data is below the list range, use the Cut and
Paste commands from the Edit menu to move the data to a new location. When you
create a list, remember to select a location in the worksheet with enough room to
expand the list.

Sorting and Filtering Data in a List
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Sorting and Filtering Data in a List
An Excel list provides you with flexibility so that you can organize data to
meet your needs. You can sort the list to display data in a certain order.
You also can filter the list so that it only displays certain records.

Sorting Data in a List
Excel sorts lists based on fields. Any field name you have created in the list
can be used as a sort field for reorganizing the list.
To sort a list, follow these steps:
1. Select a cell in the list you want to sort. Or, if you want to sort only
selected records in a list, highlight the records you want to sort.
2. Open the Data menu and choose the Sort command. The Sort dialog
box appears, as shown in figure 17.6.
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3. To prevent the column labels from being sorted with the rest of the list,
select Header Row in the My List Has section of the dialog box.
4. The Sort By text box is selected. Use the drop-down list box to replace
the field name in this text box with the field name by which you want
to sort. Select the Ascending or Descending option for the order in
which. you want to sort the selected records.
S . To sort records using additional fields, press tab or select the Then By

text box and specify the field. Select the Then By text box if you wan t
to sort by a third field.
6. Click OK or press return. Excel sorts the data in the list, as shown in

figure 17.7.

You can sort a list
based on multiple
field names.

[i:IIJift1]
Tip
To quickly sort
a list, select a
cell in the
column by
which you
want to sort,
then click the
Sort Ascending
or the Sort
Descending
button.

Ill
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Fig. 17.7
The selected
records are sorted
according to the
options in the Sort
dialog box.

Filtering Data in a List
Tip
If you perform

a sort that is
incorrect, open
the Edit menu
and choose
Undo Sort; or
press ~ +Z
immediately to
reverse the sort
and return the
list to the
original order.

When you need to work with a subset of data within the list, you can filter
the list so that only certain records appear. After you have filtered a list, you
can modify the records; generate subtotals and grand totals; and copy the
data to another area of the worksheet.
When you filter a list, Excel displays only those records that meet the criteria,
while hiding the other records from view. Two methods are available for
filtering the records in a list. You can use the AutoFilter command to quickly
filter data in a list. To filter data using additional criteria, you can use a custom AutoFilter.

Using AutoFilter to Filter Records
To filter a list with the AutoFilter command, follow these steps:
1. Select a cell in the list you want to filter.

2. Open the Data menu, choose Filter, and then choose the AutoFilter
command from the submenu. Excel inserts drop-down arrows next to
each column heading in your list, as illustrated in figure 17.8.

Sorting and Filtering Data in a List
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3. Click the drop-down arrow in the column that contains the data you
want to display. Excel displays a menu listing all the unique items in
the column, as shown in figure 17.9.
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4. Select the item you want to display. Select Blanks to display empty cells
or NonBlanks to display cells that have value.
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Tip
To remove the
AutoFilter
drop-down
arrows from
your list,
choose the
AutoFilter
command
again.

5. Repeat steps 3 and 4 for each additional column you want to filter.

Excel displays only those records that meet the filter criteria. Excel displays
the row headings of records that match in a different color.
To return the list to its original state, select All from the drop-down menu of
each column.

Creating a Custom AutoFilter
You can define a custom AutoFilter when the data you want to filter must
meet specified criteria.
To create a custom AutoFilter, follow these steps:
1. Select a cell in the list you want to filter.

2. Open the Data menu, choose Filter, and then choose the AutoFilter
command from the submenu.
3. Click the drop-down arrow in the column that contains the data you
want to filter, and choose Custom. Excel displays the Custom AutoFilter
dialog box, shown in figure 17.10.
Fig. 17.10
Define a custom
filter in the
Custom AutoFilter
dialog box.
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4. Click the arrow in the drop-down list of comparative operators, and

select the comparative operator with which you want to compare the
data. Enter the data you want to compare in the text box, or click the
arrow to display a list of items and select an item.
5. To add a second set of criteria, select And to indicate that the records

must meet both sets of criteria. Select Or to indicate that the records
must match either set of criteria. Define the second set of criteria.
6 . Click OK or press return.
Excel filters the list and displays those records that match the criteria
(see fig. 17.11).
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Troubleshooting
After sorting the database, Excel sorts the column headings along with the data in the
list.
To prevent the column headings from being sorted with the rest of the list, select
Header Row in the M y List Has section of the Sort dialog box.

I selected multiple filters, but my list doesn 't display any records.
Select All from the Auto Filter drop-down menu to redisplay the records. When you
use multiple filters, each record in the list must contain each of the specified criteria.
If a record contains one of the specified criteria but not the other, that record will
not be displayed. To remove the AutoFilter drop-downs from the list, choose the
AutoFilter command from the Filter submenu on the Data menu.

Adding and Removing Subtotals
When you sort data in a list, Excel allows you to summarize the data with
subtotals. When you summarize a list, Excel calculates subtotals based on
subsets of the data and also calculates a grand total.
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Creating Subtotals
To add subtotals to a list, follow these steps:
1. Sort the data according to the order in which you want to create subto-

tals. To generate subtotals based 'o n store, for example, first sort the list
by store.
2. Select a cell in the list you want to summarize.
3. Open the Data menu and choose the Subtotals command. The Subtotal

dialog box appears, as shown in figure 17.12.
Fig. 17.12
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l!ton

~I

u-

( c.-1

\be funotlon:

....I

l~um

I

I

(Ro-4111

tlddSUI>IolaiTo:
la1 Heme

rtrst Name
Pcsftlon
Star1 O.te

Ill! Ropltco Curroot SUblollla

~

(

Hol,

I

~

•

~~ B~t~nGnu~
~Summorv

811.., Dlla

4. Select the group to define the subtotals. To generate automatic subtotals

by store, for example, select the Store field from the At Each Change In
drop-down list.
5 . Select the Subtotal function from the Use Function drop-down li.st.

To create subtotals, make sure that Sum is selected.

6. Ch oose the data you want to subtotal in the Add Subtotal To box.
To subtotal the data found in the Sales Points field, for example, select
Sales Points.
7. Click OK or press return to add the subtotals to your list, as shown in

figure 17.13.
Note
If your list is not sorted prior to selecting the Subtotal command, Excel creates a
subtotal for each entry in the list. To prevent this from occurring, sort the list before
you choose the command.
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Hiding and Displaying Data in a Subtotaled List
When you add automatic subtotals to a list, Excel displays the list in Outline
view. You can expand and contract the level of detail in the list to display
only the subtotals and grand totals of data.
Figure 17. 13 shows the list displayed in Outline view. The icons that appear
along the left edge of the worksheet window enable you to expand and contract the level of detail.
To hide detail level, click the Hide Detail Level button of the subtotal for
which you want to hide the detail. Excel contracts the list to display the subtotal detail only. Figure 17.14 shows the list with the detail of every subtotal
hidden.
To display a detail level, click the Show Detail Level button that corresponds
to the subtotal for which you want to show the detail. Excel expands the
list to show the detail Level.
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Fig. 17.14
Click the Hide
Detail Level
button to hide
summary detail
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Removing Subtotals from a List
To remove subtotal data from a list, select a cell in the subtotaled list and
choose the Subtotals command from the Data menu. Choose the Remove All
button from the Subtotals dialog box.

Summarizing Data with Pivot Tables

Tip
Click a cell in
a list in your
worksh eet
before choosing
PivotTable.
Excel pastes the
list's range in
the Range text
box. Click Next
if that's the list
you want to
use.

Excel 5.0 includes a new capability called the pivot table that enables you to
quickly and easily summarize and compare data found within a list. When
you want to summarize your data in another way, you only need to drag and
drop fields to create a whole new report, without changing the structure of
the data in your worksheets.
You use the automated PivotTable Wizard to create pivot tables in Excel. The
PivotTable Wizard guides you step by step through the process of creating a
pivot table. The PivotTable Wizard prompts you to define the pivot table
information, using the fields defined in a list.

Creating a Pivot Table with the PivotTable Wizard
When you create a pivot table from a list, the column headings in the list are
used as Row, Column, and Page fields. The data in the columns become items
in the pivot table. When the data in your list contains numeric items, Excel
automatically uses the Sum function to calculate the values in the pivot table.

Summarizing Data with Pivot Tables
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If the data in your list contains text items, Excel uses the Count function to
calculate a count of the source items in the pivot table.
To create a pivot table from a list in your worksheet, follow these steps:
1. Open the Data menu and choose the PivotTable command. Step 1 of
the PivotTable Wizard appears, as shown in figure 17.1 S.
PluotTable Wlzord- Step 1 of 4 -
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Fig. 17.15
Specify the data to
use for the pivot
table in Step 1 of
the PivotTable
Wizard.
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2. Specify the data you will be using in the Pivot Table. Select Microsoft
Excel List or Database, and click the Next button. Step 2 of the
PivotTable Wizard appears, as shown in figure 17.16.
PluotTable Wi zard - Ste 2 of 4
Tvpeor ttltct ttre wrbheet r1lf'l9llllllt contlint Ute(tt\llJ)uonnt to utt.

3. Specify the location of the list in the Range text box (by typing the
range address or by highlighting the range with the mouse), and then
click Next. Step 3 of the PivotTable Wizard appears, as shown in
figure 17.17.
4. Define the layout of the pivot table by dragging the field names dis-

played on the right side of the dialog box to the Row, Column, or Page
area. Fields placed in the Row area appear in each row in the pivot
table. Fields placed in the Colum n area appear in each column of the
pivot table. Fields placed in the Page area filter the data shown in the
pivot table.

Fig. 17.16
Specify the range
of data in Step 2
of the PivotTable
Wizard.

Tip
Don't spend too
much time
deciding where
to place the
fie lds. You can
always rearrange the fields
after you have
added the pivot
table to your
worksh eet.
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Fig. 17.17
Define the pivot
table layout in
Step 3 of the
PivotTable
Wizard.
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5. Click Next to display the final step in the PivotTable Wizard

(see fig. 17.18).
PluotTable Wizard • Step 4 of 4

Fig. 17.18
Specify the
location of the
pivot table in Step
4 of the PivotTable
Wizard.
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6 . Enter a cell address in the PivotTable Starting Cell text box. If you leave

this text box empty, Excel creates a new worksheet and adds the pivot
table to it. Click Finish. The PivotTable Wizard displays the results in a
table on the worksheet (see fig. 17. 19).
When you add a pivot table to the worksheet, Excel automatically displays
the Query and Pivot toolbar. The toolbar contains buttons for the most frequently used pivot table commands, as shown in figure 17.19.
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Column area field

Fig. 17.19
Thispivottable
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Editing and Updating a Pivot Table
After you have added a pivot table to your worksheet, you can quickly rearrange the fields in the pivot table to display an entirely different view of
your data. Each field in the list is represented by a shaded cell in the pivot
table. Figure 17.19 shows the fields. You change the view of the data by
dragging the fields to other areas in the pivot table.
The field dragged to the data section will be the field from which data is
displayed in the intersection of your rows and columns. The field dragged to
the page section allows you to filter the data appearing from the fields you
dragged to you r rows and columns sections.

Rearranging a Pivot Table
To change the data displayed on the current page, click the drop-down arrow
displayed in the Page area of the pivot table. A list of items for the current
field appears. Select an item from the list to filter the data in the pivot table
to display data for that item only (see fig. 17.20).

Tip
To display each
page in the
data table on
a separate
worksheet in
t he workbook,
click the Show
Pages button.
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Fig. 17.20
The pivot table
displays sales
points for sales
representatives
only.

To change the data displayed in the columns of the pivot table, drag a row or
page field to the column area of the pivot table. When you do, the pivot table
displays a columnar view of the data (see fig. 17.21).
Fig. 17.21
The columns in
the pivot table
show sales points
by Store and
Position.

4:03PM~

~ File Edit UJew I nsert Form•t Tools D•t• Window

ID]t&l'(.JJ~I~I~eJ~II..,I,n-l~[t!'Wl~II OO$
Fl!-

I~ U0131:!I!li!JI~l•lilllmi i..111]%]• ,]A8]•'2JifEI9~~

A

8

SumofSeles Potnts

lon

c

list

~ l•li•lr:~o:J[!Jfm

[

D

2

A"t. Ma

r

r+
7 Btlh<e

0
0
0
0
0
0

Behr

- --- --

C~urchll1
c~.~rtts

Dod>On
~ rteldtr

14!- Hill

-

~
1 5 Mlftttr

m
l'+b
1-J.!

N!bon

D'Gorman
Phom

!-!!- Plh>
1-Mt Porterlleld
Sttn.10n
~

-

Thurtnl!ln
~
z~ WaQnon
24 Grend Totel
~ ~Sbeot l
Reedy

o,
15

0
0
0
0

-·-

0
0
0
0

_o

15 '

15

EmPlOIIOt lot

-

0
0

5

t2

0
0
0
0
0
0

0
0
0
0

0
0
0
0
0
0
0
0
17

_

o
o.
o"

0
-

0
0

0
0
16

0
- 0

0
0
0
0
0

9

16

-

17
0
15
0
15
0
0
0
9
0
16

0

0
9
0
0
0
0
0

0
0
0
0
0
72

Sheit4

,

I'

-• r

~
llo>

0
0

0
0
0
0
0
0
0

0
0
0
0
0

-

0

811oe13

Sen frenelset~

_ o_

17

-

0

0
0
0

g.-

-

NNYork

Oonvtr

0
0
0

15
0
0
0
0
0

~
a Kllnl:enbero
,...rtlnu

Asst Maneoor To~l
Dell as

b ton

5

~

..

...

AI

Emp lo~ee

r+

I7J

I~ I"~Jl~?)

lllUB'

•

1!1

Summarizing Data with Pivot Tables

373

To change the data displayed in the rows of the pivot table, drag a page or
column field to the row area of the pivot table. The pivot table displays data
in a row field in each row (see fig. 17 .22).
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The rows in the
pivot table show
sales points by
Position and Last
Name.
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Adding and Re moving Fields in a Pivot Table
You can change the data used in a pivot table by adding new fields to the
pivot table or by removing fields from the pivot table that you no longer
need. When you add a new field to the pivot table or delete an existing field,
Excel automatically updates the pivot table.
Note
When you add and remove data from a pivot table, the action has no effect on the
source data in the list.

To add a field to the pivot table, follow these steps:
1 . Select a cell in the pivot table.
2. Click the PivotTable Wizard button on the Query and Pivot toolbar, or

choose PivotTable from the Data menu.
3. Add the field using the PivotTable Wizard.
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Modifying a Pivot Table
Tip
You can remove a
pivot table field
directly from the
pivot table in the
worksheet. To
remove a field,
drag it outside the
pivot table area.
When you have
moved outside the
table area, the
mouse pointer will
appear with an X
on it. Excel then
removes the data
from the table.

Excel provides special formatting commands for modifying the appearance of
a pivot table. When you use these commands, Excel retains the format, even
when you reorganize and recalculate the data in the pivot table.
You can change the numeric format of the data displayed in the data area,
format an entire pivot table, and rename fields and items in the table.
Note
When you update a pivot table, Excel recalculates and reformats the data in the
table. Because of this, you should avoid manually formatting the table.

Applying a Numeric Format
To change the numeric formatting in the data area of the pivot table, follow
these steps:
1. Select a cell in the pivot table.
2. Open the Data menu and choose the PivotTable Field command, or

click the PivotTable Field button on the Query and Pivot toolbar.
The PivotTable Field dialog box appears (see fig. 17.23).
Fig. 17.23
The PivotTable
Field dialog box.
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3. Click the Number button in the PivotTable Field dialog box.
The Format Cells dial og box then appears (see fig. 17.24).
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4. Select the numeric format you want to apply to the data area.

5 . Click OK twi ce to return to the worksheet.

Formatting the Pivot Table
When you create a pivot table and select the AutoFormat Table check box in
the PivotTable Wizard, Excel auto matically fo rmats the table for you. To use
another fo rmat, select a cell in the pivot table and choose AutoFormat from
the Format menu. Select the format you want to use fro m the AutoForma t
dialog bo x, and click O K (see fig. 17.25).
Fig. 17.25
The pivot table
has been formatted with the
Classic 2
AutoFormat.
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Changing the Calculation Used in a Pivot Table
When the items displayed in the data area of a pivot table are numeric, Excel
automatically uses the Sum function to summarize the data in the list. When
the items are text, the Count function is used to summarize the text items.
You can change the summary function used by a data field, for example, to
calculate an average or maximum value. You also can change the calculation
type used in the data area.
Changing the Summary Function
To change the summary function used by the pivot table, follow these steps:
1. Select a cell in the field you want to change in the data area of the pivot
table.
~
~

2. Open the Data menu and choose the PivotTable Field command, or

click the PivotTable Field button on the Query and Pivot toolbar.
3. In the Summarize By list box, select the function you want to use to
summarize the data.
4. Click OK or press return.

Changing the Summary Type
Excel can calculate values used in the data area based on the values of other
cells. You can calculate the difference between items in a field, for example,
or calculate the items as percentages of the total.

To change the summary type used by the data field in the pivot table, follow
these steps:
1. Select a cell in the field you want to change in the data area of the pivot

•

table .
2. Open the Data menu and choose the PivotTable Field command, or
click the PivotTable Field button on the Query and Pivot toolbar.

3. Click the Options button in the PivotTable field dialog box (see
fig. 17.26).
4. Click the arrow in the Show Data as text box to display the calculation

types available (see fig. 17 .27).
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Fig. 17.26
The PivotTable
Field dialog box
expands to display
the summary type
options.
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The PivotTable
Field dialog box
displays the
calculations type
options.
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5. Select the calculation type you want to use from the Summarize By list
box, and then select the fields and items you want to use.
6. Click OK or press return.

Refreshing Data in a Pivot Table
When you update the data in the source list in your worksheet, you must
refresh the pivot table to include the new information. To refresh data in the
pivot table, select any cell in the pivot table and choose the Refresh Data
command from the Data menu or click the Refresh Data button from the
Query and Pivot toolbar.
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If you add new records to your source list, you must redefine the source range

used to create the pivot table, using the PivotTable Wizard.
To extend the source range to include additional records in the pivot table,
select a cell in the pivot table and choose the PivotTable command from the
Data menu, or click the PivotTable Wizard button from the Query and Pivot
toolbar.
Excel displays Step 3 of the PivotTable Wizard. Click Back to display Step 2.
Respecify the source data range, and click Finish. You can specify the source
data range while the PivotTable Wizard dialog box is on-screen by selecting
the cells behind the dialog box. Excel adds the new records to the pivot table.

Forecasting with the Goal Seeker
Excel's Goal Seek command enables you to perform simple forecasting in
your worksheets. You can find a specific value for a defined result by adjusting the value of other cells in the worksheet. For example, you can find
out how many houses need to be sold to generate a total sales figure of
$1,600,000. The benefit of using the Goal Seek command is that Excel uses
the data known-in this case, the total sales amount and the amount per
product-and performs the calculation instantaneously, without your having
to try many inputs, to come up with the answer.
Tip
To proceed
through the
Goal Seek by
one calculation
at a time, click
the Pause
button and
then click the
Step button
until you are
finished.

To use the Goal Seeker, begin by setting up the problem and entering the
known variable in the worksheet. The worksheet shown in figure 17.28 contains the data variable for a sales forecasting worksheet.
To use the Goal Seeker, the variable you want to adjust must be a formula,
and the formula must refer to the other cells in the worksheet. You specify
the cell containing the formula as the Set Cell. Then the cell to adjust must
be referred to by the formula in the set cell. In the worksheet in figure 17 .28,
the Total Sales cell contains the formula =B4*BS. In this case, we know the
average price of a house is $150,000. So, we want to see how many houses
must be sold.

Forecasting with the Goal Seeker
ti file Edit Ulew Insert Fonnat Tools Data Window
9:58 RM
11J ..
~~IJ.]~JjJ~~§!!JWWJ!rii'Muoo•
18 ~

181ICJI9 ~l.,lei•IDI,sli"l, , !f!l•.o.s![EBW:J~

f"'nev•
86

=B4•as

379

Fig. 17.28
Goal Seek adjusts
the amount in cell
B4 to meet the
proposed sales
amount.

To forecast with Goal Seek, follow these steps:
1. Open the Tools menu and choose the Goal Seek command. The Goal

Seek dialog box appears, as illustrated in figure 17.29.
Goal seek

2. Specify the cell containing the formula as the Set Cell.
3. In the To Value text box, enter the value the cell must reach.
4. Specify the cell to adjust in the By changing cell text box.
5. Click OK or press return when you have specified the cells. Figure 17.30

shows the Goal Seek Status dialog box that informs you of the status of
the operation.

Fig. 17.29
You indicate three
input cells in the
Goal Seek dialog
box: the cell
containing the
formula, the goal
you want to seek,
and the cell to be
adjusted.
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Fig. 17.30
The Goal Seek
Status dialog box
shows the status
of the problem.
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6. Click OK or press return. Excel displays the results in the worksheet
cells (see fig. 17.31).
Fig. 17.31
The Goal Seek
returns the result,
indicating that 11
houses must be
sold to reach a
value of 1.6
million in sales.
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Finding the Best Solution with Solver
The Goal Seek command enables you to generate values based on a single
input cell. By contrast, the Solver add-in enables you to calculate the values
needed to reach a particular result by adjusting the value of one or more cells.
Furthermore, you can define constraints, which Solver must meet when generating the optimum solution.
In the case of the real estate agency determining the number of houses that
must be sold in order to meet its annual sales forecast, for example, you must
take other considerations into account besides the average price of the house
and the goal that must be met.

Finding the Best Solution with Solver
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Loading the Solver Add-In
Before you can use the Solver, you must first load the Solver add-in into
memory. When you installed Excel, you were given the option of installing
the add-ins that ship with Excel. If you chose to install the add-ins, you can
use the Add-Ins command from the Tools menu to load Solver into memory.
U you did not install the add-ins, you must do so before you can use Solver.
To load Solver into memory, follow these steps:
1. Open the Tools menu and choose the Add-Ins command. Figure 17.32
shows the currently installed Add-ins.
2. From the list of installed add-ins, select Solver Add-ln.

3. Click OK or press return. The Solver command appears in the Tools
menu.
Fig. 17.32
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Setting Up the Problem
To use the Solver in your worksheets, you must first define the problem that
you need to solve. With Solver, each of the constraint cells is based on formulas. The changing values are the values to which each of the constraint cells
refers. Therefore, to set up the problem, determine which of the cells will
be used as the constraints and make sure that they contain formula s. The
worksheet shown in figure 17.33 illustrates a problem that the Solver will
help solve.
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Fig. 17.33

Solver will adjust
the data in the
range BS:DS until
the total commission in cell E9
equals $96,000.

Running Solver
After you have set up the worksheet and located the cells to use, follow these
steps to run Solver:
1. Open the Tools menu and choose the Solver command to start the
Solver add-in. Figure 17.34 displays the Solver Parameters dialog box.
Fig. 17.34

Use the Solver
Parameters dialog
box to define the
target cell, the
cells to adjust, and
the constraints.

to tiiO eo..trototo.
SC$5 •lnteQer
$0$5 •lni"J"r

2. Indicate the cell that contains the formula you want to solve for in the
Set Target Cell tex t box. In our example, the cell E9 is the target cell,
because that is where the total commission is calculated.
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3. Use the Equal To section of the dialog box to indicate the optimum
value for the cell: either the Maximum value, Minimum value, or a
specific value. To meet a specific value, select the Value of option and
then enter the value in the text box. In our example, we want the value
to be equal to $96,000.
4. In the By Changing Cells text box, indicate the cell or range of cells

that the Solver will need to adj ust to reach the optimum value. In our
example, cells {B5 :05) are the cells to change because they hold the
values for the number of condos, houses, and plots sold.
5. To specify constraints, click the Add button to add each constraint to
the problem. Figure 17.34 has three constraints already entered. These
constraints make sure that the number of condos, houses, and plots of
land are integers. You can't sell half of a house. Figure 17.35 shows the
Add Constraint dialog box.
Fig. 17.35
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6. To create a constraint, specify the cell containing the formula on which
the constraint is based in the Cell Reference text box. Click the dropdown arrow to display the list of constraint operators, and select the
appropriate operator. In the final text box, enter the value the constraint must meet. In figure 17.35, the constraint requires that at least
$20,000 of our commissions come from house sales. Click the Add button to add the current constraint to the problem and create another, or
click OK to add the constraint and return to the Solver Parameters dialog box.
7. The constraints you have defined appear in the Subject to the Constraints list box. Click Solve to start the Solver. The Solver begins calculating the optimal solutions. When Solver finds a solution , the Solver
Results dialog box appears, as shown in figure 17.36.

Specify the
constraint to use
for the problem
in the Add
Constraint dialog
box.
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Fig. 17.36
The Solver Results
dialog box gives
you options for
using the solution
that has been
found.
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8. Excel adds the solu tions to the worksheet. Select Keep Solver Solution
to use the offered solutions. Select Restore Original Values to return to
the original worksheet values. Figure 17.37 shows the worksheet after
the Solver has found th e solutions for the problem.
Fig. 17.37
The resu lts
produced by
Solver show that 8
condos, 16 houses,
and 5 plots of land
must be sold to
generate $96,000
in commissions.
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Creating Solver Reports
Solver enables you to generate reports summarizing the results of its solutions. You can create three types of reports: Answer, Sensitivity, and Limit.
An answer report shows the original and final values for the target cell and
the adjustable cells, as well as the status of each constraint. The sensitivity
report shows the sensitivity of each element of the solution to changes in
input cells or constraints. A limit report shows the upper and lower values of
the adjustable cells within the specified constraints.

Performing What-If Analysis with Scenarios
To create a report, select the report from the list that appears in the Solver
Results dialog box, and click OK. Excel creates the report in a separate sheet.

Performing What-If Analysis with
Scenarios
For most spreadsheet users, a large portion of analysis involves performing
what-if analysis. What effect does changing the average price of home sales
have on my forecast? If I sell more condos than houses, will that have a
negative impact on total sales?
The solution to each of these questions requires that input values in the
worksheet change. When these values change, however, the original results
are also changed, making it difficult to compare one outcome with another.
To account for these changing variables, many users construct multiple data
tables to test the outcome of each variable. This allows them to compare the
original result to the new result.
One of the pitfalls in creating various solution tables is that it becomes increasingly difficult to monitor the difference between the tables. When the
worksheet is used by multiple people, keeping track of the ranges proves to be
an exercise in frustration. Finally, as each additional table is created to test a
scenario, the worksheet grows larger and more unwieldy.
Excel 5.0 provides a tool that enables you to track these scenarios with ease.
The Scenario Manager feature provides a mechanism that saves each iteration
of a problem and then enables you to view one solution at a time.

Creating a Scenario
Before you create a scenario, you must first identify the worksheet range that
contains the data, as well as the input cells that will change for each scenario.
The worksheet shown in figure 17.38 illustrates a sales worksheet that enables
you to track the change in Total Sales and Total Commission, based on the
number of properties sold.
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Tip
You can create
more than one
Solver report by
pressing Command while
you select the
report names.
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Fig. 17.38
The Sales
worksheet lets you
perform what-if
analysis using the
#Sold cells.
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After you have identified the data, follow these steps to create a scenario:
1. Open the Tools menu and choose the Scenarios command. The
Scenario Manager dialog box appears, as shown in figure 17.39.
Fig. 17.39
The Scenario
Manager dialog
box is used to
create scenarios.
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2 . Click the Add button to display the Add Scenario dialog box, as shown
in figure 17.40.
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Fig. 17.40
The Add Scenario
dialog box enables
you to name the
scenario and define
the cells that will
change.
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3. Enter a name for the scenario in the Scenario Name text box.
4. In the Changing Cells text box, indicate the cell or range of cells that

will change for each scenario.
5. In the Comment field, Excel has automatically entered your name and

the date the scenario was created. Enter additional information in the
text box as necessary.
6. To prevent changes from being made to the cells in the worksheet,
select the Prevent Changes option in the Protection section of the dialog box. To hide the cell data from view, select the Hide option.
7. Click OK when you have finished defining the Scenario. Figure 17.41
shows the Scenario Values dialog box, in which you enter the data for
each of the cells in the scenario.
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Note
When creating scenarios, use the Define command in the Name submenu on
the Insert menu to assign a name to each of the cells in the scenario. When
you do, Excel uses those names in the Scenario Values dialog box and in
scenario reports.

Fig. 17.41
Enter the data for
each of the cells
in the Scenario
Values dialog box.
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Each of the displayed text boxes relates to each of the specified cells for
the scenario. The cell address of each cell is displayed for reference.
8. Enter the data that represents the data to be used for the scenario.
9. When you' re finished, click OK or press return. The Scenario Manager

dialog box reappears, as shown in figure 17 .42.
Fig. 17.42
The Scenario
Manager dialog
box displays each
of the defined
scenarios.
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The name of the newly defined scenario appears in the Scenarios list
box. When you select a scenario from the list, the Changing Cells field
displays the cell addresses of the scenario. The Comments field displays
the comments you entered to describe or annotate the scenario.
10. To view the scenario, select the scenario name from the list and click

the Show button. Excel displays the values in each of the cells in the
worksheet. If the dialog box prevents you from seeing the data, click
and drag the title bar of the dialog box to move it out of the way.
11. At this point, you can click the Add button to define a new range of

values as a scenario, or you can click the Edit button to edit the values
used by the current scenario.
12. To return to the worksheet, click the Close button. Excel displays the

values defined by the scenario in the worksheet.
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Note
Use the Scenario button found in the Workgroup toolbar to quickly switch between
scenarios in the worksheet. To display the Workgroup toolbar, choose the Toolbars
command from the View menu, select Workgroup from the Toolbars list, and click
OK. To display a scenario, click the drop-down arrow in the Scenarios button, and
select the scenario you want to view.

Editing and Deleting Scenarios
You can edit an existing scenario or delete a scenario altogether. When you
edit a scenario, you can rename the scenario, specify other worksheet cells as
the changing cells, and edit the comment. Furthermore, you can change the
values defined by the scenario.
To edit a scenario, follow these steps:
1. Open the Tools menu and choose Scenarios to display the Scenario

Manager dialog box. Select the scenario you want to edit from the
Scenarios list box, and click the Edit button. Excel displays the Edit
Scenario dialog box, as shown in figure 17.43.
Fig. 17.43
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2. Make any modifications necessary to the data shown in the text boxes,

and click OK. The Scenario Values dialog box is displayed.
3. Enter the new values, and click OK.

Excel automatically adds the
modification date
to the Comment
field.
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To delete a scenario, select the scenario you want to delete and click the
Delete button. Excel removes the scenario from the Scenario listing.

Summarizing Scenarios with Reports
Excel provides two methods of displaying scenarios in a concise report.
The Scenario Summary creates a simple report in table form, showing the
data for each of the changing cells and their effect on the results of formulas
in a range. You also can generate a Pivot Table Summary from a multiple
scenario set.
Creating a Summary Report
To create a summary report, follow these steps:
1. Open the Tools menu and choose the Scenarios command.
2. Click the Summary button to display the Scenario Summary dialog box,

as shown in figure 17.44.
Fig. 17.44
Choose the type of
summary report to
create.
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3. Choose Scenario Summary, if it isn't already selected, from the Report
Type area of the dialog box.
4. In the Result Cells text box, indicate the range of cells that contain

formulas based on the input cells.
5. Click OK. Excel displays a new sheet with a summary table of the
scenario inputs and results, as illustrated in figure 17.45.
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Creating a Scenario PlvotTable Report
To create a pivot table from the scenarios in your worksheet, follow these
steps:
1. Open the Tools men u and choose the Scenarios command.
2. Click the Summary button.

3. In the Scenario Summary dialog box, choose the Scenario PivotTable
option.
4 . In the Result Cells text box, indicate the range of cells that contain

formulas based on the input cells.
S . Click OK. Excel displays a new sheet with a pivot table of the scenario

inputs and resu lts, as illustrated in figure 17.46.
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Fig. 17.46
A summary pivot
table report
showing scenarios.

You can manipulate the pivot table summary report as you would any pivot
table. If you change a scenario, however, the pivot table is not updated.
You must create a new pivot table to account for the changes.

Annotating Worksheets
When you use many formulas and functions fo r analysis in your worksheets,
it can become difficult to remember exactly what each formula is calculating
and what data it is using in its calculations. Excel enables you to annotate
cells with notes so that you can enter descriptive data about a formula.
When you share your worksheets with other users, the notes provide a handy
mechanism for describing the contents of a cell or for additional information.

Adding a Note
To annotate a cell, follow these steps:
1. Select the cell, and choose the Note command from the Insert menu.
The Cell Note dialog box appears, as shown in figure 1 7.4 7.

Annotating Worksheets
Fig. 17.47
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2. Enter the cell address (or point to it with the mouse) of the cell you
want to annotate in the Cell text box.
3. Type the data of the note in the Text Note text box.
4. Click the Add button to add the note to the worksheet. The Notes in
Sheet list box displays the cell address, as well as the fi rst few words of
the note.
5. Click OK to return to the worksheet.

Viewing a Note
When a cell in the worksheet has a note attached to it, a small red box
appears in the upper-right corner of the cell. To display the contents of the
note, select the cell and choose the Note command from the Insert menu.
The text of the note appears in the Text Note text box. Click OK when you
h ave finished viewing the note.
Note
If the note indicators don't appear in the worksheet, choose the Options command
from the Tools menu, click the View tab, select the Note Indicator option in the
Show portion of the dialog box, and click OK.

Removing a Note
To remove a note from a worksheet cell, select the cell, and then open the
Edit menu, choose Clear, and ch oose the Notes command from the submenu.

Tip
You also can
view a note's
contents by
double-cl icking
the cell. First
turn off in-cell
editing. Choose
Options from
the Tools
menu, select
the Edit tab,
uncheck Edit
directly in cell,
and click OK.
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From Here ...
This chapter showed you how to work with lists to organize and summarize
data in your worksheets. You also learned how to use Excel commands to
analyze the data in your worksheets. You may want to read the following
chapters for additional information, as well as to learn how to use list information with other applications in Microsoft Office:
• Chapter 15, "Using Formulas and Functions," discusses how to create
formulas and use Excel's built-in functions to perform calculations,
using data in the worksheet.
• Chapter 16, "Creating and Printing Reports and Charts," explains how
to print worksheet data.
• Chapter 28, "Working with Wizards, Multiple Documents, and Cut,
Copy, and Paste," discusses how to use information from a list in Excel
to generate form letters in Microsoft Word.
• Chapter 33, Sending a Mass Mailing," provides information on creating mailings and using Excel data in Microsoft Word.
11

Chapter 18

Automatin
Macros

wit

by Todd Knowlton

A key feature of any serious application today is the capability to help users
automate repetitive tasks. Since the introduction of macros (originally termed
the "typing alternative") more than 10 years ago, users have pushed macro
languages farther than ever imagined. Vendors responded by enhancing their
macro languages, adding more and more features usually only found in
higher-level programming languages, such as BASIC, FORTRAN, and C. Macros have evolved into complex programs that create and display custom
menus, prompt users for input, and perform complex analysis of data.
Excel provides the power of an advanced macro language without requiring
you to learn a complex programming language. Using the macro recorder,
you can record your keystrokes and mouse clicks in macros. Then, when you
need to repeat that process, just run the macro and let Excel do the work for
you!
In this chapter, you learn to
• Record a macro
• Run a macro
• Change macro options
• Attach a macro to a toolbar button
• Attach a macro to the Tools menu
• Use the Personal Macro Workbook
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Recording a Macro
When you find that you are repeating the same set of keystrokes and mouse
clicks over and over again, it's time to automate the process by recording a
macro. A macro is a list of instructions that you want Excel to run. The macro
recorder captures your keystrokes and mouse clicks, translates them into the
macro language instructions that Excel understands, and writes them on a
module sheet in your workbook. You then can run the macro instead of
pressing the same keys and mouse buttons over and over again.
The macro recorder can record the process of selecting ranges, menu commands, or dialog-box options. Some common tasks to record include the
following:
• Setting up a new worksheet
• Importing or exporting data
• Applying a common set of formats to a specified range
• Changing data in a specified column
• Setting up for a certain printer and printing a specified range
• Opening workbooks and selecting a certain view
• Performing a query
• Selecting cells and playing sound notes
~

See "Understanding Visual
Basic for
Applications,"
p. 743

Note
Excel Version 5.0 is the first Microsoft Office product to implement the common
macro language called Visual Basic, Applications Edition (VBA). Microsoft plans to
incorporate this powerful application language across Microsoft Office products so

~

~

See "Understanding Why
Objects Are
Special," p. 744
See "Learning
More with OnLine Help,"
p. 745

there is only one programming language to learn.
The old Excel macro language of Excel Version 4.0 can be used in Excel Version 5.0.
In fact, you can choose to record a macro in Excel Version 4.0 language. How ever,
Microsoft does not plan to make many future enhancements to the Excel Version 4.0
macro language.
In this chapter, macros will be recorded in VBA format. This chapter covers the basics
of recording and playing a macro, along with some tips on using macros. Chapter

37, "Using Visual Basic for Applications," introduces you to the language of Visual
Basic, Applications Edition.

Recording a Macro
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Planning the Macro
Before starting to record a macro, you should take some time to plan the task
that you want to record. Although you can edit recorded macros, it is always
easier to do it right the first time. Verify that all files you need in your macro
are where they should be. Walk through the process a few times manually, so
that your recording session produces the desired result. Consider other methods to accomplish the same task. Wherever possible, make macros generic so
that they can be used on other worksheets or in other areas of the same
worksheet.

Starting the Macro Recorder
To start the macro recorder, follow these steps:
1. Click the Record Macro button on the Visual Basic toolbar; or open the
Tools menu, choose Record Macro, and then choose the Record New
Macro command from the submenu. Excel displays the Record New
Macro dialog box (see fig. 18.1).

Fig. 18.1
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The Record New
Macro dialog box
prompts you to
name and describe
your macro.

2. Enter a name for the macro in the Macro Name text box. When naming

your macro, keep these guidelines in mind:
• Begin the macro name with a letter.
• The name can contain letters, numbers, or underscores.
• Do not include spaces or punctuation marks.
• Names can be up to 255 characters long.
3. (Optional) Enter a description for the macro in the Description text

box.
4. Click OK. Excel opens a Stop Macro button in its own toolbar, returns

to the worksheet, and displays Recording in the status bar (see fig. 18.2).
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Fig. 18.2
You can tell that
the macro recorder
is on by checking
for the Recording
message in the
status bar and the
Stop Macro
button.

5. Perform the actions you need to record.
6. When you finish recording, click the Stop Macro button; or open the
Tools menu, choose Record Macro, and then choose the Stop Recording
command from the submenu.

Using the Macro Recorder to Automate a Task
Suppose that each week you receive an income statement as a DIF file.
Each week you need to do the following:
1. Open the file in Excel.
2. Set column widths.

3. Add a report title.
4. Print the income statement.

5. Save the file in Excel format.
Rather than baby-sit the computer each week, you could record a macro and
let Excel handle the entire task for you. Figures 18.3 through 18.7 illustrate
the recording of this process as a macro named lmport_Weekly_IS. Note that
dialog box selections, mouse drags, and file-save settings are recorded.

Recording a Macro

Fig. 18.3
Recording the
opening of a DlF
file.
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Fig. 18.5
The macro can
insert a row to
make room for a
title.

Fig. 18.6
You can automate
the process of
changing format
settings, such as
fonts, and
entering data,
such as a report
header.
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wrong area. The macro works, but each time it runs, the mistakes are repeated.

....

You can edit the mistakes out. Excel records the macros on the Module pages of your
workbook. You can view and edit the macros on these pages. See Chapter 38, "Using
Visual Basic for Applications," for more information on how to safely edit your recorded macro.

See " Recording
a Procedure,"
p. 746

....

See "Stopping
the Recorder,"
p. 74 7

Troubleshooting
When I recorded the macro, I chose some incorrect menu commands and painted the

I need to record more steps in an existing macro.

To record new steps in an existing macro, choose Tools Macro, select the desired
macro, and click Edit. Excel displays the macro module page. Place the insertion
point where you want to start recording. Open the Tools menu, choose the Record
Macro command, and then choose Mark Position for Recording from the submenu.
Go to the sheet where the macro is applied. Choose Tools Record Macro, and then
choose the Record at Mark command from the submenu to begin recording new
steps.
While recording my macro, I pressed the undo key. Now each time the macro runs, the
data changes are discarded.

You need to remove the undo command from your recorded macro. See Chapter 37,
"Using Visual Basic for Applications," for more infor mation on how to safely edit your
recorded macro.
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Running a Macro
..,. See "Running
the Procedure,"

After you have recorded a macro, the next step is to test it. Before testing the
macro, make backups of any worksheets on which the macro operates.

p. 749

To run a macro, follow these steps:
1. Open the Tools menu and choose the Macro command, or click the

Run Macro button on the Visual Basic toolbar. Excel opens the Macro
dialog box (see fig. 18.8).
Fig. 18.8

To run a macro,
open the Macro
dialog box and
click Run.
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2. Select or type the name of the macro you want to run.
3. Click Run. Excel runs the macro.

..,. See "Understanding the
Procedure,"
p. 750
..,. See "Using the
Debugging
Tools," p. 787

Press esc to stop running a macro at any time, or click Pause or Stop on the
Visual Basic toolbar. Pressing esc will produce a message alerting you that the
macro has been interrupted.
After you run the Import_Weekly_IS macro, the worksheet looks like figure
18.9. The macro runs uninterrupted, except for one pause to ask for confirmation on saving the file, since the file name previously existed. The final
step in the macro prints the worksheet.
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Fig. 18.9
The
Import_Weekly_IS
macro produces
this Excel
worksheet.

- •

Changing Macro Options
When you record a new macro, you can set various macro options by using
the Options button in the Record New Macro dialog box (see fig. 18.10).
Following is a description of the options available:

• Assign to Menu Item on Tools Menu. Select this box and enter a macro
name to be listed on the Tools menu (see fig. 18.11).
• Assign to Keyboard Shortcut. Select this box to assign a shortcut key of
option+;):(+ a letter that you designate. Note that this keyboard shortcut
will not appear on the Tools menu unless you add it to the name to be
listed on the menu.
• Store in Personal Macro Workbook. Select this radio button to save the
macro to the Personal Macro Workbook. For more information, see
"Using the Personal Macro Workbook" later in this chapter.
• Store in This Workbook. Select this radio button to save the macro in the
current workbook.
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• Store in New Workbook. Select this radio button to save the macro in
another workbook.
• Language Visual Basic. Select this radio button to record the macro using
Visual Basic for Applications (VBA).
• Language MS Excel 4.0 Macro. Select this radio button to record the
macro using the old macro language in Microsoft Excel Version 4.0.
Fig. 18.10
The Options
button allows you
to determine
where the macro is
stored, assign a
macro to the Tools
menu, assign a
keyboard shortcut,
and select the
macro language in
which to record.
Fig. 18.11
You can add the
macros you use
m ost often to the
Tools menu.
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For existing macros, use the Options button in the Macro dialog box to access
different options. Now the Macro Options dialog box contains a Help Information section, instead of the Store In and Language sections (see fig. 18.12).
The Help Information section includes the following options:

• Status Bar Text. Enter text to display in the status bar when the macro
runs.
• Help Context JD. Enter the text 10 (number) to make the h elp contextsensitive.
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• Function Category. Select the function category.
•

Help File Name. Enter the name of the file that contains the Help Infor-

mation.
Fig. 18.12
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Troubleshooting
I assigned a keyboard shortcut to my macro, but it doesn't work.

Check to make sure that the workbook containing the macro is open. Then choose
the Macro command from the Tools menu, select the macro name, and click the
Options button. Verify the keyboard shortcut assigned. Finally, check to see if another
macro is using the same shortcut key. Excel will run the first macro that has that
shortcut key.
I get a Macro Error dialog box when I run my macro.

The worksheet that the macro operates on must be active for the macro to run.
The macro I recorded is on a worksheet tab called Macro 1, and the commands all start
with an equal sign.

You have recorded an Excel 4.0 macro. If you meant to record a Visual Basic macro,
click the Options button in the Record New Macro dialog box and select the Visual
Basic language option. Then record the macro again.
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Adding Macros to Sheet Buttons
and Toolbars
In the last section, you learned how to add a macro to the Tools menu to
make a macro more accessible. You also can assign macros to a button object
on your sheet or to a toolbar to make them even more accessible.
To assign a macro to a sheet button, follow these steps:
1. Display the Drawing toolbar by clicking the Drawing button on the

toolbar.
2. Click the Create Button button on the Drawing toolbar.
3. Position the mouse pointer where you want to create the button, and
drag until the button is the desired size.
4. Excel displays the Assign Macro dialog box (see fig. 18.13).

Fig. 18.13
You can assign a
macro to a button
object on a sheet.
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To add a macro
to a custom
toolbar button,
choose View
Toolbars, click
Customize,
select the Custom category
and drag the
desired button
icon to the
toolbar.

5. Select an existing macro and click OK, or click Record to create a new
macro that will automatically be assigned to the button.
6 . With the button still selected, click the label and type an appropriate
name for the button.
7. Click anywhere on the sheet to deselect the button.
8. Test the button.
To assign a macro to a button on a toolbar, follow these steps:
1. Choose View Toolbars. Then click the Customize button. Excel displays
the Customize dialog box (see fig. 18.14).
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Fig. 18.14
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Using the Personal Macro Workbook
Sometimes you need to use the same macro in different workbooks. Excel
provides a special workbook, called the Personal Macro Workbook, which
stores macros that can be used by many workbooks. Excel automatically creates the Personal Macro Workbook the first time you record a macro and

Fig. 18.15
The Custom
category provides
many buttons you
can use to create a
custom toolbar.
just drag the
desired button
to a toolbar.
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select the macro recorder option, Store in Personal Macro Workbook (see
fig. 18.16). You can show the Personal Macro Workbook by choosing the
Unhide command from the Window menu and selecting the Personal Macro
Workbook. Figure 18.17 shows a macro recorded in the Personal Macro
Workbook (note that recorded macros are automatically translated into Visual Basic commands).

Fig. 18.1 6
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The ability to record and store global macros allows you to create a toolbox of
handy macros. You also can use global macros and the Personal Macro Workbook to help standardize spreadsheet development in your organization. By
providing everyone with the same macro toolbox, you will enhance productivity and efficiency for everyone using Excel.

From Here...

From Here ...
Now that you are familiar with working with Excel, you are ready to use Excel
with some of the other Microsoft Office applications. To learn more about
using Excel with other Microsoft Office applications, refer to the following
chapters:
• Chapters 27 to 35 in Part V, "Working Together with Microsoft Office
Applications," provide real life business scenarios that illustrate how to
use the Microsoft Office programs together to accomplish various business tasks.
• Chapter 36, 11 Changing Toolbars and Menus," shows how to customize
toolbars and menus.
• Chapter 37, ~~using Visual Basic for Applications," teaches you the
Visual Basic for Applications (VBA) language in ExcelS.O.
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Chapter 19

Getting Ac<f1uainte
with Powe Point
by

T. Kelley Boylan

PowerPoint is the component of Microsoft Office that helps you create
professional-quality overhead, paper, 3Smm slide, photoprint, and on-screen
presentations. Before working with PowerPoint, you need to familiarize yourself with the PowerPoint window and understand the theory and process
behind presentations created by PowerPoint.
In this chapter, you will learn the following:
• Starting and exiting PowerPoint
• Looking at PowerPoint window elements
• Examining components of PowerPoint presentations
• Understanding templates, masters, objects, and layouts
• Adding visuals to PowerPoint slides

Starting and Exiting PowerPoint
You start and exit PowerPoint just like you start and exit any of the applications in Microsoft Office. Click the PowerPoint button in the Microsoft
toolbar or double-click the PowerPoint icon in the Microsoft Office program
group. After a few seconds, the PowerPoint window appears. Like other
Microsoft Office applications, PowerPoint displays the Tip of the Day dialog
box, which contains a new tip each time you start PowerPoint. If you don't
want to see the Tip of the Day each ti me you start PowerPoint, go to the Tip
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Tip
If you don't see

the Microsoft
toolbar on-screen,
return to the
Finder and
double-click the
PowerPoint icon
in the Microsoft
Office group.

of the Day dialog box and remove the X in the Show Tips at Startup check
box by selecting it, then click OK. (You can display tips at any time by choosing the Help Tip of the Day command.)
When you finish using PowerPoint, choose the Quit command on the File
menu. If the current file is unsaved, PowerPoint displays a dialog box asking
if you want to save the changes you made to the current file. Choose Yes if
you want to save, No if you don't want to save, or Cancel to return to your
file without saving.

Getting Familiar with the
PowerPoint Window
After you close the Tip of the Day, Power Point automatically displays the
dialog box shown in figure 19.1. This dialog box lets you choose how you
want to create a presentation. Power Point offers a variety of methods for
creating presentations, which you learn about in Chapter 20, "Creating,
Saving, and Opening Presentations."
Fig. 19.1

The opening
window in
PowerPoint.
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way to ortatt a
presentation.

Tip
If the slide

is not
full-screen, click
the size box in the
upper right corner
of the slide window or click and
drag it to resize
the window in the
lower right corner.

Figure 19.2 shows what a typical PowerPoint presentation screen might look
like after you begin working. The relocatable Microsoft toolbar appears at the
upper left corner of the window. PowerPoint's standard toolbar and menu bar
are shown at the top of the screen. A drawing toolbar is displayed down the
left side of the window. Surrounded by a gray border, the first slide in the
presentation is represented by the white area in the middle of the screen
(slides are the individual pages in a presentation that become overheads,
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3Smm slides, or on-screen slide shows). At the left end of the horizontal
scroll bar are view tools used for displaying different views of your presentation . You learn about displaying different views in PowerPoint in Chapter 20,
"Creating, Saving, and Opening Presentations."
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W indow Elements
The men us in PowerPoint are similar to the menus in other Microsoft Office
applications. Table 19.1 describes each PowerPoint menu and the types of
commands that you find o n each.

Table 19.1

PowerPoint Menus

Menu

Description

File

This is a standard File menu.

Edit

This menu contains commands for undoing, cutting, copying, and
pasting text. Find (~+F) and Replace ( ~ +H ) commands are also
located on this menu, along with commands for creating links to
other files and editing objects.
(continues)

olll See "Using

Menus," p. 30
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Table 19.1

..,.. See "Viewing a
Presentation,"
p.440

Continued

Menu

Description

View

Use this menu to choose the presentatio n view you want to display o n
your screen o r to display masters. This menu also contains commands
fo r activating the display of toolbars, rulers, and g uides (you learn
about rulers and g uides in the "Displaying Rulers and Guides" section
of this chapter). Use this menu to control the zoom percentage used
in a particular view.

Insert

This menu contains commands that let you insert a variety of
elements in a p resentation, from a simple date or time to ClipArt,
grap hs, o r other o bjects.

Format

This contains commands for chang ing all aspects (font, alignment,
spacing, color, and shadow) of text and o bjects in a presentation. This
also contains commands for selecting templates, wizards, and layouts,
w hich are described in this chapter and Chapter 20.

Tools

This menu contains typical Microsoft Office tools, such as Spelling, as
well as tools that are unique to PowerPo in t. Use the commands on
this menu to create transitio ns between slides, hide slid es, o r recolo r
or cro p a picture. You also find commands for customizing toolbars
and setting PowerPoint optio ns.

Draw

Use the commands o n this menu to manip ulate drawn objects in a
presentation. For example, you can group several objects as o ne,
rearrange the stacking o rder or layers of objects, and rotate, flip, and
change the scale of objects.

Window

This is a standard Window men u.

Along the lower edge of the PowerPoint window is the status bar, which displays the number of the current slide, Slide Master, Outline Master, Handout
Master, or Notes Master at the left end. The right end contains three buttons:
• The New Slide button makes it easy for you to add a new slide to
your presen tation without choosing New Slide from the Insert menu
(or :t:C+M).
• When you click the Layout button, the Slide Layout dialog box appears,
from which you can choose a specially designed slide layout .

..,.. See "Using
PowerPoint's
Drawing
Tools," p. 48 7

• The Template button is used to display the Presentation Template dialog box. You can choose a new template fo r your presentation at an y
time by clicking this button . Layouts and templates are described in
detail in th e sections "Understanding Masters and Templates" and
"Understanding Objects and Layouts," later in this chapter.
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Above the status bar at the bottom of the screen is the horizontal scroll bar
(see fig. 19.2). At the left end are four view buttons. Each button displays a
different view of the current presentation. The four buttons are described
in the section, "Components of a PowerPoint Presentation," later in this
chapter.

PowerPoint's Standard Toolbar

Tip

Table 19.2 describes each button on PowerPoint's Standard toolbar. Each
button represents a PowerPoint m enu command. You learn how to use most
of these buttons in subsequent chapters. Refer to Chapter 23, "Drawing
Shapes, Curves, and Lines," fo r an explanation of the tools on the Drawing
toolbar.

PowerPoint provides several nonstandard toolbars,
which you can
display on-screen
at any time by
using the View
Toolbars comm and. You can
also customize
toolbars using this
command.

Table 19.2
Button

Buttons on PowerPoint's Standard Toolbar
Description
Displays the New Presentation dialog box.

Displays the Open dialog box, from which you can choose a
presentation file to open.
Saves the current presentation under the current name and file type.
If the presentation has not yet been saved, displays the Save As
dialog box.
Displays the Print dialog box.

Checks the spelling in the current presentation. Displays the Spelling
dialog box if errors are found.
Removes the selected text or object from the slide and places it on
the Clipboard.
Places a copy of the selected text or object on the Clipboard,
leaving the original text or object unchanged.
Pastes the contents of the Clipboard into the current slide.

Records all attributes (such as color, font, shadow, and pattern) of
the selected object so you can copy all attributes to another object.

(continues)
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Table 19.2
Button

Continued
Description
Undoes the most recent action taken. Note that not all actions
(commands) can be reversed.
Embeds a Microsoft Word table in your presentation, using the data
(number of rows and columns) you specify.
Embeds an Excel worksheet in your presentation, using the data you
specify.
Embeds a graph in your presentation, using the data you specify.

Embeds an organization chart in your presentation.

Allows you to insert clip art from Microsoft's ClipArt Gallery.

Starts the Pick a Look Wizard, used for creating a presentation for
which you define the style or look.
Creates an RTF (Rich Text Format) file in Word using the content of
the current presentation.
Increases font size of selected text to the next available size.

Decreases font size of selected text to the previous available size.

The mouse p ointer changes to a question mark, which you can use
to click any PowerPoint menu command, button, or toolbar for
help.

11211

I [!]I
ITimes New Roman

Lets you zoom in and out of your presentation.

Displays a list of available font sizes.

l f!!ll

Displays a pop-up list of
avai lable fonts.

Displaying Rulers and Guides
Table 19.2
Button

Continued
Description
Adds or removes boldface in selected text (this button toggles on
and off with each click).
Adds or removes italics in selected text (this button toggles on and
off with each click).
Adds or removes underlining in selected text (this button toggles on
and off w ith each click).
Adds or removes shadow in selected text (this button toggles on
and off with each click).
Displays eight colors for text in a pop-up menu. To choose a
different color, click the Other Color option, which displays the
Other Color dialog box.
Left-aligns selected text.

Centers selected text.

Adds bullets to selected text (this button toggles on and off with
each click).
Moves selected text to next higher level in an outline.

Moves selected text to next lower level in an outline.

Displaying Rulers and Guides
When you work with text documents in Word, it's helpful to display horizontal and vertical rulers in the Word window. Because presentation slides
primarily contain only text, rulers can be useful in PowerPoint as well. Rulers
give you a reference point within a slide so that you can see where (in inches)
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a text or drawn object appears. They also help you utilize and o rganize space
on a slide and en sure th at all slide elem ents fall within reason able ruler and
border limits.

Tip
To quickly turn
rulers and gu ides
on and off, go to
View an d choose
Rulers a nd/or
Guides. You can
also press ~ +G
for Guides.

To display rulers in the PowerPoint window, go to View and choose Rulers.
Rulers appear in o ne of two forms- drawing or text- depending on the
objects that are currently selected on the slide. In figure 19.3, rulers are
shown in the drawing form, w hich places the zero poin t at the center of each
ruler. This allows you to correctly positio n objects from the cen ter point to
the outer edges of a slide. The positio n of the mouse is indicated on each
ruler by a dashed line. In figure 19.3, the mouse position o n each ruler is at
approximately 2 1/2 inches. You also can see that the slide is 10 inches wide
and 7 1/2 inches high .
Rulers

Fig. 19.3
Rulers and guides
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Vertical and
horizontal
positions of
mouse
pointer
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Wh en you need to precisely position slide elements or align certain elements
vertically or horizontally, go to View and choose Guides. This displays dotted
lines vertically and h orizontally through th e center point of a slide. Use
guides to help you visually align elem ents on a slide. Guides, shown in
figure 19.3, d on 't appear on printed copies of your slide. They o nly appear
on-screen while you're working in PowerPoint.

Components of a PowerPoint Presentation

Components of a PowerPolnt
Presentation
At first you may think PowerPoint is an application that only lets you create
slides for a presentation, but PowerPoint offers much more. It helps you plan,
create, and deliver a presentation in a practical way. Think about how speakers give presentations: They may plan the presentation by first creating the
outline, then completing the style and content of the slides, then finally
printing them. While they speak, they may refer to printed copies of the
slides that contain their own handwritten notes. They may also provide copies of their slides to the audience so the audience can follow along or take
notes.
Key components of a PowerPoint presentation include the following:
• Slides
• Outlines
• Notes
• Audience Handouts
Creating each of these components without the proper tools could take a
great deal of time, but PowerPoint makes it easy for you by automatically
creating each feature. You can use just one component or any combination
of the four, depending on your specific needs.
You can view any of the four components on-screen or you can print copies.
PowerPoint displays slides by default (see fig. 19.2). Outline pages look like a
typical outline, with main headings aligned at the left margin and lower-level
headings indented (see fig. 19.4). A speaker's notes pages contain a reduced
version of the slide at the top of the page with space at the bottom of the
page for the speaker's notes (see fig. 19.5). Audience handouts can contain two
or six slides per printed page, as shown in figure 19.6. Notice that when you
view audience handouts on-screen, PowerPoint doesn't display the actual
slides. Instead, you see dotted frames that outline the location of the slides
on the page.
To view slides, the outline, or notes, go to View and choose View Slides, View
Outline, or View Notes Pages. Master slides are available from a hierarchy
menu within View. After you choose a view, the status bar indicates theselected view. See Outline in figure 19.4, Notes 1 in figure 19.5, and Handout
Master in figure 19.6.
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Fig. 19.4
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Fig. 19.6
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You can quickly display a presentation component by clicking the view buttons at the
left end of the horizontal scroll bar. Click the Slide View, Outline View, or Notes View
buttons to display any of these elements. To display handout pages, press and hold
the shift key and click Slide Sorter.

Understanding Masters and
Templates
For every presentation you create, PowerPoint creates a set of masters: a Slide
Master, Outline Master, Notes Master, and Handout Master. Masters correspond directly to the slides, outline, speaker's notes, and handout components of a presentation . Masters contain the elements (text or pictures) that
you want to appear on each compo nent page. If, fo r examp le, you want your

.,.. See "Viewing a
Presentation ,"
p.440
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company logo to appear on each of your slides, you don't need to insert the
logo on individual slides. Add the logo to the Slide Master and it automatically appears on each slide. Other elements you may add to a master include
pictures or clip art, page numbers, the date, the title of the presentation, or
reminders such as "Company Confidential."
To display a master, choose View Master in the View Master hierarchy menu.
Notice that the left end of the status bar indicates the master currently displayed (Slide Master). The Slide Master shown in figure 19.7 includes a company name, slide number, and date.
A template is a saved presentation file that contains predefined text formatting, color, and graphic elements. Templates are designed by professional
graphic artists who understand the use of color, space, and design. Each template is designed to convey a certain look, feel, or attitude. Figure 19.8 shows
how the EMBOSSDC.PPT template looks.

Fig. 19.7
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Fig. 19.8
The
EMBOSSDC.PJYf
template conveys
a formal image.
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Note
You can quickly display a master by using the view buttons at the left end of the
horizontal scroll bar. Press and hold the Shift key, then click the slide view (for Slide
Master), outline view (for Outline Master), slide sorter view (for Handout Master), or
notes view (for Notes Master). To return to slide, outline, slide sorter, or notes view,
choose the appropriate item from the View menu or click the View button at the
lower left corner of the window.

Because a template is a saved presentation file, it contains a Slide Master, in
which all the formatting, color, and graphic elements are defined. You select
a template based on the look you want for your presentation, then apply the
template to your new or existing presentation file. The template applies to all
slides in the presentation, and you can apply a new template to a presentation at any time. If you want selected slides in a presentation to look different
than the template, you can change any aspect of a slide on an individual
basis.
PowerPoint contains template files for black-and-white overheads, color
overheads, and on-screen slide shows. Each contains templates of the same
style, but the colors are different depending upon the output you'll be using.

.,._ See "Creating a
New Presentation," p. 431
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For example, templates designed for black-and-white overheads use several
shades of gray. Templates designed for color overheads use a wide variety of
colors, but they seldom use dark backgrounds for a slide. Templates for onscreen slide shows make the most dramatic use of color, often using dark
backgrounds and high-contrast colors for text. Templates are located in the
PowerPoint folder in the template subfolder, under the names B & W
Overheads, Color Overheads, and On Screen & 3Smm Slides.
When you create a new presentation, you use PowerPoint's default template
DEFAULT.PPT (refer to fig. 19.3). It doesn't appear to be a template at all
because it contains no color (except black and white), no graphic elements,
and no stylistic formatting. Use the default template if you want complete
control over your presentation's design, color scheme, and graphic elements-the template enables you to start as much from scratch as possible.
You can, however, modify aspects of any template, not just the DEFAULT.PPT
template.

Understanding Objects and Layouts
PowerPoint slides are comprised of objects, which are the key elements in any
slide. Any time you add text, a graph, a drawing, an organization chart, clip
art, a Word table, an Excel spreadsheet, or any other inserted element into
a slide, it becomes an object. To work with an object, select it and either
change its content or size, move it, copy it, or delete it: You also can change
attributes of an object, such as its color, shadow, and border.
...,. See "Reviewing
AutoLayout,"
p.449

If you don't feel confident positioning or arranging objects on a slide, you

can use AutoLayouts, which lets Power Point do the work for you.
AutoLayouts saves you the time and trouble involved with creating, arranging, positioning, and aligning new objects for a new slide. Each AutoLayout
contains placeholders for various types of objects (such as text, clip art, and
organization charts). Placeholders look like faint dotted lines on the slide and
contain identifying text, such as Double click to add clip art or Click to
add text (see fig. 19.9).
Each AutoLayout contains different object placeholders in different arrangements. For example, AutoLayout's presentation title page contains two text
placeholders: one for a slide title and one for a subtitle. AutoLayout's title
page is shown earlier in figure 19.3. The AutoLayout in figure 19.9, however,
shows three placeholders: one for a slide title, one for text, and one for
clip art.
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Wh enever you add a new slide to a presentation, PowerPoint automatically
displays the New Slide dialog box (see fig. 19.10).

IV
Fig. 19.9
AutoLayout takes
the busywork out
of arranging
objects on a slide.

.- - - - - - - - - -- - - - - -- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -t

!

Click to add title

L_ ------ -------------------------------------

Object
placeholders

:-; -a;;;i<-t.O-addtext ___

!

:

:
:

W i

I
I
I

Double click to add
clip art

I
I
I
I
I

I
I
I

I

I

:
:

:
I

0

!

;_______----------- ____: ---------------------I

Fig. 19.10
The New Slide
dialog box
displays a variety
of AutoLayouts.
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Visuals You Can Add to PowerPoint
Slides
There is no reason for a PowerPoint presentation to contain dull slides full of
only text. PowerPoint enables you to add several types of objects to your
slides to grab an audience's attention, add interest or humor, or illustrate a
particular point. You can create some objects from within PowerPoint; others
can be imported from other applications. To insert an object in a PowerPoint
slide, choose an option within the Insert menu or use one of the buttons on
the Standard tool bar. Table 19.3 summarizes options available on the Insert
menu. See Chapter 21, 11 Entering Slide Content," for more information about
inserting objects in a presentation.

Table 19.3

Objects You Can Insert in PowerPoint Slides

Object Type

Description

ClipArt

The ClipArt Gallery is a collection of prepared illustrations
that depict a wide variety of items and topics. ClipArt is an
excellent choice if you're not confident with your drawing
abilities.

Picture

If you have access to other prepared artwork, such as a
bitmap file, you can insert it in a PowerPoint slide.
(PowerPoint recognizes 19 picture file formats, including
Quicklime.)

Microsoft Word Table

Because Microsoft Word is part of Microsoft Office, you
have quick and easy access to Word if you want to insert a
table in a slide. The Word table can contain up to 15
columns and up to 4 rows.

Microsoft Graph

Microsoft Graph is an embedded application that enables
you to create a chart or graph from spreadsheet data. You
create the graph similar to the way you create a graph
from spreadsheet data in Excel.

Object

The Object option on the Insert menu provides you with
access to a wide variety of object types such as Microsoft
Excel spreadsheets and charts, Microsoft Equation, Word
documents, Paintbrush pictures, Microsoft WordArt, NoteIt, and OrgCharts. You even can add sound as an object.

From Here...

From Here ...
This chapter has provided you with a brief overview of PowerPoint, its design,
and its capabilities. For in-depth discussions of specific topics, refer to the
following chapters:
• Chapter 20, "Creating, Saving, and Opening Presentations," describes
the various methods for creating a new presentation file and describes
how to switch your view of a presentation. You also learn how to save,
close, and open a PowerPoint presentation file.
• Chapter 21, "Entering Slide Content," describes the basics of entering
the content of a presentation and labeling objects. This chapter also
describes how to create a Word table, an Excel spreadsheet, and an
organization chart in a PowerPoint presentation. You also learn how to
insert objects from sources outside PowerPoint.
• Chapter 22, "Working with Objects," describes objects, how to select
and group them, and how to move, copy, resize, align, rotate, flip, and
stack objects.
• Chapter 23, "Drawing Shapes, Curves, and Lines," describes how to use
PowerPoint's drawing tools to add objects to your slides.
• Chapter 24, "Enhancing a Presentation," describes how to add color,
borders, shadows, and other enhancements to your presentation.
• Chapter 25, "Creating Charts," teaches you how to use Microsoft
Graph, an embedded application that lets you create a wide variety of
graph types from spreadsheet data.
• Chapter 26, "Creating Output," describes how to print all the components of a presentation and explains how to create an on-screen slide
show.
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To work with PowerPoint, you need to understand h ow to create a new presentation, save a presentation, and open an existing presentation.
In this chapter, you learn to
• Create a new presentation, using a variety of methods
• Change your view of a presentation
• Add, insert, and delete slides
• Save and close a presentation
• Open an existing presentation

Creating a New Presentation
To provide you with flexibility, Power Point offers a variety of ways to create a
new presentation. You can create a blank presentation that contains no color
or style enhancements. You can copy the appearance of an existing presentation. Or you can get step-by-step help in creating a presentation by using a
wizard (wizards are described in the following section of this chapter).
The options for creating a presentation appear in the New Presentation dialog
box (see fig. 20.1). This dialog box is displayed by choosing New from the File
menu or by pressing :l=e+N.

~
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Fig. 20.1
Use the New
Presentation
dialog box to
choose a method
of creating a
presentatio n .
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Note
The first time you start PowerPoint, the dialog box shown in figure 20.1 has a
PowerPoint title. After you begin working with PowerPoint, the name of the dialog
box changes to New Presentation.

The following sections describe each method of creating a new presentation .

Creating a Presentation Using a Wizard
A wizard is a guided, on-line script that asks you to respond to questions related to the task you're performing-in this case, creating the framework for a
new presentation. Through a series of dialog boxes, enter your responses to
specific questions related to the task. Then the wiza rd uses the information
you supply to create the new presentation fi le. Wizards are designed to help
you perform unfamiliar tasks and tasks with which you may need help. In
PowerPoint, a wizard creates a presentation when you want to define all aspects of the presentation at the time you create it. The wizard ensures you
don't forget any steps in the process.
Using the AutoContent Wizard

The AutoContent Wizard suggests the content and outline of your presentation based on the type of presentation you're creating. For example, if your
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presentation is designed to introduce or sell a new product, the AutoContent
Wizard suggests that you include the following:

• Objective
• Custo mer Requirements
• Features
• Competitive Strengths
• Key Benefits
• Next Steps
You can use the topics exactly as suggested or modify them to suit your
needs. The presentation selections include the following (see fig. 20.2):
• Recommending a Strategy
• Selling a Product, Service, or Idea
• Training
• Reporting Progress
• Communicating Bad News
• General
If you're unsure of your presentation type, use the General option, which
suggests generic contents such as the topic of discussion, main ideas, examples, and summary.
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Suggested topics for a product presentation

Fig. 20.2
This dialog box
lists presentation
types and shows
suggested topics.
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To use the AutoContent Wizard, follow these steps:
1. Choose New fro m the File menu or press j:C+N. PowerPoint displays the

New Presentation dialog box.
2. Choose the AutoCon tent Wizard option and cllck OK. The

AutoContent Wizard dialog box appears (see fig. 20.3). Notice that the
title bar reads step 1 of 4.
Fig. 20.3
The AutoContent
Wizard dialog box.
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3. Read the information in the Step 1 dialog box and then click Next. The

AutoContent Wizard - Step 2 of 4 dialog box appears (see fig. 20.4).
Fig. 20.4
The Step 2 of 4
dialog box enables
you to specify
information for a
title page.
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4 . Type the information for creating a title slide and click Next. The

AutoContent Wizard - Step 3 of 4 dialog box appears (refer to fig. 20.2).
5. Choose the type of presentation you're going to give and click Next.

The AutoContent Wizard -Step 4 of 4 dialog box appears.
6 . Click Finish to exit the wizard and create your presentation.

When you complete the steps, PowerPoint displays the presentation in outline view. You can use outline view to enter the content of the slides or, if
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you prefer, you can switch to slide view (for information about outline view
and slide view, see "Viewing a Presentation," later in this chapter). The presentation contains a title page and a slide for each of the suggested topics.
Using the Pick A Look Wizard

The second wizard you can use to create a presentation is the Pick a Look
Wizard, which enables you to specify the look of the presentation. You
choose the type of output you want for your presentation (black-and-white
slides, color slides, on-screen presentation, or 3Smm slides) and a template
design. Then you determine the information you want to add to the presentation masters (slide master, speaker's notes master, handout master, and
outline master).
To choose a template, go to the Format menu and choose Presentation
Template.
Templates are stored in the Templates folder and are divided into subcategories. The B & W Overheads folder contains templates for black-and-white
overheads. The Color Overheads folder contains templates designed for color
overheads. The On Screen & 35 mm Slides folder contains templates designed
for on-screen slide shows. When you select a template, a preview of the template appears on the left side of the dialog box.
To use the Pick a Look Wizard, follow these steps:
1. Choose New from the File menu or press ):::(+N. The New Presentation
dialog box appears.
2. Choose the Pick a Look Wizard option and click OK. The Pick a Look
Wizard dialog box appears. Notice that the title bar reads Pick a Look
Wizard Step 1 of 9.

3. Read the information in the Step 1 dialog box and click Next. The Step
2 of 9 dialog box appears.
4. Choose the type of output you want for your presentation (Black and
White Overheads, Color Overheads, or On-Screen Presentation/3Smm
Slides) and Click Next. The Step 3 of 9 dialog box appears.
5. Choose one of the four template designs that appear in the dialog box
or click More. When you click More, PowerPoint displays an Open dialog box that contains more templates.
6. Open a template folder and choose a template. To use the selected tem-

plate, click Apply. When the Step 3 dialog box reappears, click Next and
the Step 4 of 9 dialog box appears.

Tip
To preview a
template, highlight the File
Name list and use
the up- and downarrow keys to
scroll through the
different templates. A sample of
the highlighted
template appears
on the left side of
the selection box.
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7. Choose the printed output options you want (Full-Page Slides, Speaker's
Notes, Audience Handout Pages, or Outline Pages) and click Next.
8. The remaining dialog boxes that appear are determined by the printed
output options you selected in Step 7. For each option, PowerPoint
displays a separate dialog box that enables you to add text, the date,
and page numbers to masters. When you finish with each dialog box,
click Next. The Step 9 of 9 dialog box is the final step.
9. In the Step 9 of 9 dialog box, click Finish to exit the wizard and create
your presentation.

When you complete the steps, PowerPoint displays the presentation in slide
view. When you enter the content of your presentation, you can remain in
slide view or switch to another view. Unlike a presentation created with the
AutoContent Wizard, a presentation created with the Pick a Look Wizard
contains only the first slide and Cue Cards are not automatically displayed.

Creating a Presentation Using a Template
As pointed out in the preceding sections, a wizard helps you establish the
specific aspects of your presentation when you want to select a template,
specify options for the masters, and use the suggested topics for a presentation. Sometimes, however, you want to apply only a template to a presentation. In this case, choose the Template option in the New Presentation dialog
box.
To use a template to create a presentation, follow these steps:

g

1. Choose New from the File menu or press ):C+N. The New Presentation
dialog box appears.
2. Choose the Template option and click OK. The Presentation Template
dialog box appears.

3. Choose a template folder and choose a template. To apply the highlighted template, click Apply. Slide 1 of the new presentation in slide
view appears.

Creating a Blank Presentation
When you create a blank presentation, PowerPoint uses the DEFAULT.PPT
template. The default template uses no color (black and white only) and includes no stylistic enhancements. Creating a blank presentation puts you in
complete control of the your slides' color scheme, layout, and style characteristics. You can leave the presentation blank or you can add a template, colors,
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and other enhancements selectively at any time by using menu or toolbar
commands. Use the blank-presentation method when you want the maximum degree of flexibility.

IV

When you select the Blank Presentation option in the New Presentation dialog box, the New Slide dialog box appears (see fig. 20.5). Use this dialog box
to choose the layout you want for the first slide in the new presentation.
PowerPoint automatically highlights the first layout, which is used for the
title page. You can accept this layout or select another.
Fig. 20.5
Choose a layout
for your slide in
the New Slide
dialog box.

New Slldo

ca..... •• Awt•LIIIwt:

EJI ~~~

m~m
mJ ~ [ii]~ 1:

I

OK

I

I c.-1 I

---

~

nUoSIIM

~l

To create a blank presentation, follow these steps:
1. Choose New from the File menu or press
dialog box appears.

~+N.

The New Presentation

2. Choose the Blank Presentation option and click OK. The New Slide
dialog box appears (refer to fig. 20.5).

3. Choose the layout you want to use for the first slide and click OK.
The first slide in your new presentation appears, using the layout you
specified.

Creating a Presentation Using the Current
Presentation Format
In subsequent chapters, you learn how to refine your presentations by formatting and aligning text, inserting objects, and adding special enhancements such as color, shadows, and patterns. Sometimes you've worked hard
to develop a special design for a presentation and you want to use the same
design for a new presentation. You can do this simply by copying the style of
the existing presentation to a new presentation. PowerPoint uses the template, colors, and features of the presentation masters for the existing presentation and applies them to the new presentation.

1[51
~
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To create a new presentation based on an existing presentation, you first
must open the existing presentation and follow these steps:

BJ

1. To open the existing presentation, Choose Open from the File menu or
press )::( +0.

2. Choose New from the File menu or press J:C+N. The New Presentation
dialog box appears.
3. Choose the Current Presentation Format option and click OK. The New
Slide dialog box appears (see fig. 20.5).
4. Choose the layout you want to use for the first slide and click OK. The
first slide in your new presentation appears, using the layout you specified. All other aspects of the presentation are identical to those of the
presentation you copied.

The original presentation file remains open, but the new presentation is
the active file. After creating the file, you can change any aspect of the new
presentation.

Troubleshooting
The template I chose for my presentation has a background that is much too dark for my
overhead slides. I want to use the same template style, but with a lighter background.
B&W Overheads, Color Overheads, and On Screen & 35 mm Slides are directories
that contain templates. Templates in the On Screen & 35 mm Slides folder generally
have dark backgrounds, so you may have mistakenly selected a template in this
folder. Look for the corresponding template name in B&W Overheads and Color
Overheads. Templates in these folders generally have lighter backgrounds.
You also may consider changing only the background color of the template you
chose. See Chapter 24, "Enhancing a Presentation," for details about working with
color.

I used a wizard to create a presentation, but I selected the wrong template by mistake.
How can I change it?
If you have not yet exited the wizard when you discover the error, click Back to
return to the Presentation Template dialog box and correct the error. If you have
already exited the wizard, choose Presentation Template from the Format menu and
choose the correct template in the Presentation Template dialog box.

Adding, Inserting, and Deleting Slides

Moving Through a Presentation
When a presentation contains more than one slide, you must be able to display the slide you want easily. The left end of the status bar displays the number of the current slide. To move from one slide to another in slide view or
notes pages view, use the vertical scroll bar. To display the preceding slide,
click the Previous Slide button (it contains two up arrows). Click the Next
Slide button (it contains two down arrows) to display the slide that follows.
You also can use the page-up and page-down keys to move from one slide to
another.
When a presentation contains several slides, the Previous Slide and Next Slide
buttons are not efficient for making large jumps (for example, moving from
slide 3 to slide 28). You can quickly move to a specific slide by dragging the
scroll box in the vertical scroll bar. As you drag the box up or down, a slide
number appears near the scroll bar. When you see the number of the slide
you want, release the mouse button. PowerPoint moves directly to the slide
you specify.
Another useful way to move quickly from slide to slide is to switch to Slide
Sorter view and double-click the slide you want to view. PowerPoint automatically switches back to slide view and displays the slide you select.

Adding, Inserting, and Deleting
Slides
After you create your presentation file, you can add, insert, or delete slides
whenever necessary. To add a slide after the last slide in a presentation, display the last slide and then click the Insert New Slide button on the toolbar
or the New Slide button at the right end of the status bar. You also can add a
new slide by choosing the Insert New Slide command or by pressing :FC+M.
When you want to insert a new slide between two existing slides, use the
same method. Before you insert the new slide, be sure to display the slide that
you want to precede it.
As you work on refining a presentation, you may find that you don't need a
slide you created. You can delete a slide at any time by displaying the slide
and choosing Delete Slide from the Edit menu.
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Troubleshooting
Tip
If you're u sing
slide sorter view
or outline view,
you can delete
mo re than one
slide at a time by
highlighting all
slides you want
to delete and
choosi ng Edit
Delete Slide.

Can I insert or add slides in outline, slide sorter, or notes pages view?

Yes. Click the New Slide button at the right end of the status bar, or choose New
Slide from the Insert menu, or press ):(+M. In outline and notes pages views,
PowerPoint inserts a new slide after the selected slide. In slide sorter view, PowerPoint
also inserts a new slide after the selected slide-unless you click the mouse button
between slides before you insert a new slide. For more information about working in
different views, see "Viewing a Presentation," later in this chapter.
I accidentally deleted a slide from my presentation. How can I retrieve it?

In any of the views (slide, outline, slide sorter, and notes pages), you can click the
Undo button in the toolbar, or choose Undo from the Edit menu, or press ):(+Z.
Remember that you must use Undo immediately after deleting the slide. If you execute any other actions first, the slide cannot be restored.
I inserted a new slide in the wrong location in my presentation. Can I move it?

Yes. It's best to use slide sorter view to rearrange slides in a presentation. For specific
instructions, see "Using Slide Sorter View," later in this chapter.

Viewing a Presentation
PowerPoint offers several ways to view your presentation. Each view has a
particular purpose and advantage. The four views are summarized in table
20.1 and described in detail in the sections that follow.

Table 20.1

PowerPoint Views

View

Description

Slide

Displays individual slides in fu ll-slide view, which enables you to
see the slide in detail.

Outline

Displays all slides in the presentation, giving you an overview of
the content of the presentation.

Slide sorter

Displays a miniature version of every slide in the presentation in
proper order. Gives you an overview of the look and flow of the
presentation.

Notes pages

Displays a miniature version of an individual slide at the top of
the screen and speaker's notes below the slide. Enables you to
review your notes while viewing the slide.

Viewing a Presentation

VIew

Description

Slide show

Displays slides as they would appear during an on-screen slide
show by using the entire screen area. Press page down and page
up or click the mouse to move from slide to slide. Press esc to
end slide show view.
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To switch from one view to another, you can use the items listed in the
View menu. The quickest way, however, is to click the view buttons in the
bottom-left corner of the PowerPoint window. From left to right, the buttons
are Slide View, Outline View, Slide Sorter View, Notes Pages View, and Slide
Show View (see fig. 20.6). Simply click the button for the view you want to
use. Each time you click a view button, PowerPoint changes your view of the
current presentation.
Fig. 20.6
View buttons
appear in the
bottom left corner
of the PowerPoint
window.
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By holding down the shift key when you click a view button, you display the
master that corresponds to the selected view. If, for example, you hold down
the shift key and click the Slide View button, Slide Master appears. When you
hold down the shift key and click the Outline View button, Outline Master
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appears. Because Slide Sorter has no corresponding master, holding down the
shift key and clicking the Slide Sorter button displays Handout Master. To
display masters by using a menu command, choose Master from the View
menu and choose the appropriate master from the submenu that appears.

Zooming In and Out
Regardless of the view you choose, your presentation appears at a preset percentage of its full size (such as 60 percent). The display percentage is the
zoom setting that PowerPoint uses depending on the screen resolution you
use and the size of your monitor. If you choose Zoom from the View menu,
the percentage appears in the Zoom dialog box. Other predefined percentages
appear as options in the dialog box. The current zoom percentage also appears in the standard PowerPoint toolbar.
PowerPoint uses a different zoom percentage in each view. The default percentages are designed to provide an optimal view within the window. If you
zoom in closer by setting a higher zoom percentage, you see only a portion of
the displayed page.
To change the zoom percentage in any view, select an option from the Zoom
Control pop-up list in the toolbar or type a new percentage in the Zoom
Percentage box. To change the percentage by using a menu command,
choose Zoom from the View menu to display the Zoom dialog box, select a
zoom option or type a custom percentage in the Percent box, and click OK.

Using Slide View
Slide view shows individual slides in the current PowerPoint window (see fig.
20.7). This view provides a detailed picture of each slide. Slide view also is
useful when you're entering or changing slide content. To switch from one
slide to another, press the page-up and page-down keys or use the scroll bar,
as described in ''Moving Through a Presentation" earlier in this chapter.

Using Outline VIew
When you're concerned only about the text in a presentation, outline view is
the best view to use because it shows only the text of a presentation-without
pictures or other objects. Outline view shows the content of multiple slides,
each in outline form (see fig. 20.8). A numbered slide icon appears to the left
of each slide's title. When a slide contains no pictures or graphical objects,
the slide icon is empty except for a narrow line near the top indicating the
title. When a slide contains a picture or other object, the slide icon also contains a graphical representation. This difference helps you quickly identify
the slides that contain objects and the slides that contain only text.

Viewing a Presentation
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Fig. 20.7
An example of
slide view.

Zoom
percentage

Fig. 20.8
Outline view
displays only the
text of each slide
in outline format.
- Short-term vision
- Long-term vision

El Goals and Objectives
• Easily-measured goals

• Procedures 10 be used

El Historical Perspective
• Other companies
• Success stories
• Our position

Outline view in PowerPoint is derived from outline view in Microsoft Word.
If you've worked with o utline view in Word, you already know how to use
outline view in PowerPoin t.
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Using Slide Sorter VIew
.,. See "Setting
Slide Timings
and Transitions," p. 552

Slide sorter view gives you an overall perspective of your presentation by
displaying a miniature version of each slide on a single screen (see fig. 20.9).
The number of slides you can view at one time depends on your monitor (as
well as on the zoom percentage used). The lower the zoom percentage, the
more slides you can view.

Fig. 20.9
Slide sorter view
displays miniature
versions of
multiple slides.

In slide sorter view, the slide number appears near the bottom right corner of
each slide. When your presentation output is intended to be a slide show, the
amount of time each slide is displayed during the slide show appears near the
bottom left corner of each slide.
You cannot edit slides in slide sorter view; you must return to slide view or
outline view to change the content of slides. You can, however, change the
order of slides and copy slides in slide sorter view. First, you must select a
slide.

Viewing a Presentation
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To select a slide in slide sorter view, use the arrow keys to move to the slide or
click the slide you want to select. A bold outline surrounds the selected slide
(refer to fig. 20.9). To select multiple slides, hold down the shift key while
clicking on all of the slides you want to select. You also can select multiple
slides by holding down the mouse button as you drag an outline around the
slides you want to include. To cancel any selection, click any blank area of
the slide sorter view window.
In slide sorter view, rearranging slides is as simple as selecting a slide and
dragging it to a new location. As you drag the mouse, the mouse pointer
changes to a miniature slide with a down arrow. When you move the pointer
between two slides, a vertical bar appears to mark the location where the slide
will be inserted if you release the mouse button. You can move multiple
slides using this method as well. Suppose you want to move slides 3 and 4 to
the end of your presentation. Select slides 3 and 4, drag them to the right of
the last slide in the presentation, and release the mouse button. PowerPoint
automatically renumbers rearranged slides.
Slide sorter view is the best view to use when copying slides. Just select the
slide (or slides) you want to copy and hold down the option key as you drag
the slide to the copy location. The mouse pointer changes to a miniature
slide with a plus symbol (+) and a vertical bar appears between slides to mark
the location where the slide will be inserted. When you release the mouse
button, a copy of the selected slide is inserted in the new location.

Using Notes View
When giving a presentation, many people prefer to work from prepared
speaker's notes. PowerPoint provides a special page on which you can type
speaker's notes. The top half of the page displays a reduced version of the
slide; the bottom portion of the page contains a text object in which you can
type the text of your notes (see fig. 20.10).
At PowerPoint's default zoom percentage, notes view displays an entire page
on-screen. When you're typing or editing speaker's notes, however, it's difficult to read the text at the default percentage. If you use a larger percentage
(such as 66 or 75), the text you type is more readable and you still can view
part of the slide content as you type.

Tip
Press :):t+Home
to select slide 1.
Press :):t+End to
select the last
slide.
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Fig. 20.10
Use notes view to
enter and display
speaker's notes.
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Using Slide Show View
Slide show view enables you see each slide in your presentation at maximum
size. When you use this view, the PowerPoint window isn't visible; each slide
occupies the complete screen area (see fig. 20.11). If your final output is intended to be an on-screen slide show, slide show view is useful for previewing
your slides to see how they will look during the actual slide show.
To move from one slide to another, press the page-up and page-down keys or
click the left mouse button to move forward and the right mouse button to
move backward. You can also use the right- or down-arrow key to move forward and the left- or up-arrow key to move backward. To exit slide show view
and return to the last view you used, press esc.
Note
Slide show view displays your slides starting with the slide that was displayed before
you switched views. If you want the slide show to begin at slide 1, be sure to select
slide 1 before switching to slide show view. You can also press home to move to the
first slide and end to move to the last slide in a presentation.

Saving a Presentation

Fig. 20.11
In slide show view,
each slide uses the
entire screen area.

Transparent Reality
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• Why we're here

• Where we' ve come from
• Where we're headed

Saving a Presentation
When you save a presentation, PowerPoint saves all components of the presentation (slides, outline, speaker's notes, and handout pages) in one file.
You save a file in PowerPoint the sam e as you save a file in any other
Microsoft Office application. The first time you save a file, the Save As dialog
box appears (see fig. 20. 12) whether you choose Save or File Save As from the
File menu. Choose File Save As when you want to save an existing file under
a different name, on a different disk or folder, o r as a different file type.

..,. See "Saving,
Openi ng, and
Closing Files,"
p.62

..-1

Fig. 20.12
The Save As dialog
box enables you to
select a drive,
folder, and file
type.
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Opening an Existing Presentation
Open a PowerPoint presentation with the same method you use to open any
file in any of the Microsoft Office Applications. For specific information
about opening files, refer to Chapter 3, "Managing Files and Work Areas."
..,.. See "Enhancing
Text," p. 505

As in many applications, you can open several presentations at the same
time. The active presentation appears on top of the others, and its title bar is
highlighted. As with all Windows applications, the names of all open presentation files are listed in the menu.

Closing a Presentation
To close an existing presentation, choose Close from the File menu or click
the presentation window's close box in the upper left corner. If you have
made changes in the file since you last saved it, PowerPoint asks whether you
want to save those changes. Choose Yes to save the changes, No to ignore the
changes, or Cancel to return to the presentation without saving the file.

From Here ...
In this chapter, you learned how to create, save, and open PowerPoint presentations. For information about related topics and topics referenced in this
chapter, see the following chapters:
• Chapter 21, "Entering Slide Content," describes how to insert clip art,
pictures, tables, spreadsheets, graphs, organization charts, and many
other types of objects into your slides.
• Chapter 24, "Enhancing a Presentation," describes how to add color,
borders, shadows, and other enhancements to objects.
• Chapter 26, "Creating Output," describes how to print all the components of a presentation and how to create an on-screen slide show.

Chapter 21

Entering Slide C
by

PowerPoint slides can contain much more than just text. You can insert clip
art, pictures, tables, worksheets, graphs, organization charts, and many other
types of objects. This chapter begins by teaching you how to choose a slide
layout and how to enter and edit slide text. You also learn the steps required
for entering information other than text (such as pictures, tables, and
graphs).
In this chapter, you learn the following:
• How to work with AutoLayout
• How to enter and edit text
• How to insert clip art, tables, and worksheets
• How to insert graphs, organization charts, and other objects

Reviewing AutoLayout
In Chapter 19, "Getting Acquainted with PowerPoint," you were briefly introduced to AutoLayout, a PowerPoint feature that includes 21 prepared slide
layou ts with different object placeholders and arrangements. Using
AutoLayout, you can choose a slide layout that contains the object placeholders you need for your current slide. A title slide, for example, contains
two text-object placeholders-one for a title and one for a subtitle. After you
select a slide layout, you insert the actual content of your presentation-text,
pictures, and graphs-into the placeholders in the slides.
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W henever you add a new slide to a presentation, PowerPoint automatically
displays the Slide Layout/New Slide dialog box (see Note), which contains the
21 AutoLayouts (see fig. 21.1). To add a n ew slide, si mply click the New Slide
button at the bottom of your screen.

,

Note
The dialog box shown in figure 21.1 is entitled Slide l ayout or New Slide, depending
on the method you use to display it. The contents of the dialog box are always the
same regardless of the name shown in the title bar. To avoid confusion, this chapter
refers to the dialog box as the Slide l ayout/New Slide dialog box.

Fig. 21 .1
Use the Slide
Layout/New Slide
dialog box to
choose a layout for
a new or existing
slide.

New Slide
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Scan the dialog box to see h ow objects are arranged in each layout. Use the
arrow keys to highlight a layout o r click a layout. A d escription of the highlighted layout appears in the bottom right corne r of the dialog box. This
description shows the types of objects included in the layout.

Tip
Use the scroll bar,
arrow keys, or
page up/page
down keys in the
Slide Layout/New
Slide dialog box
to view all
AutoLayout
options.

The solid gray line a t the top of each slide layout represents the slide title.
Other text in a slide layout is represented by faint gray lines. Text nearly
always is formatted with bullets. The placeholders that contain vertical bars
represent graphs, and those with pictures re present clip art or pictures. The
empty boxes represent placeholders for other objects that usually are imported from other applications, such as Excel.
Highlight the layout you want to use for your new slide and click OK or
double-click the layout you want to u se. PowerPoint automatically applies
the selected layout to the n ew slide. After you choose a layout, replace the
sam ple text in each placeh older with actu a l text or anothe r object, such as a
graph o r table.

Reviewing Autolayout
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Note
Notice that the last slide layout in the Slide Layout/New Slide dialog box is blank; it
contains no placeholder. Use this layout when you want complete control of the
objects in a slide.

If you select the wrong layout or change your mind about the layout you
want to use for the current slide, you can display the Slide Layout/New Slide
dialog box at any time by clicking the Layout button at the bottom of the
PowerPoint window or by choosing Format Slide Layout.

After you enter information in a placeholder, be careful abo ut changing the
slide layout. The objects that contain information remain in the slide while
the placeholders for the new layout are added. PowerPoint tries to rearrange
objects so that all of them will fit, but this isn't always possible. The slide can
become cluttered with overlapping objects and placeholders, as shown in
figure 21.2.

Items You Must Bring

Fig. 21.2
Objects and
placeholders can
overlap if you
change the slide
layout after
entering information.

Object placeholders from
new slide
layout
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Entering and Editing Text
In any slide presentation, text is the most important component. Virtually
every slide contains text of some kind, even if ies just a title. The following
sections describe how to enter the text content of your slides and how to edit
the text when necessary.

Typing the Content for Your Slides
Whenever you choose a slide layout (other than the blank layout), you' ll
replace the sample text in a placeholder with real text. The slide shown in
figure 21.3, for example, includes two placeholders for text: one that contains
a sample title and one that contains a bulleted list. The third placeholder is
for clip art. A faint dotted line appears around each placeholder.
Fig. 21.3
This slide layout
contains two
placeholders for
text and one
placeholder for
clip art.
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To select a text placeholder, click anywhere within that placeholder. The
faint outline is replaced by a wide-hashed border, as shown in figure 21.4.
This line indicates that the current placeholder is selected. The sample text
disappears, and an !-beam insertion point appears inside the placeholder,
indicating that you now can enter text. In a title or subtitle placeholder, the
insertion point is centered because titles nearly always are centered. In a
bulleted-list placeholder, the sample text disappears and the bullet remains,
with the insertion point positioned where the text begins.

Entering and Editing Text
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Selected placeholder

Fig. 21.4
A selected text
placeholder is
indicated by a
wide-hashed
border; the sample
text is automatically removed by
PowerPoint.
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Type the actual text for your slide inside the selected placeholder. In the case
of titles and subtitles, press return only when you want to begin a new centered line of text. With bullets, press return only when you want to begin
a new bulleted item. If your bulleted text is too long to fit on one line,
PowerPoint automatically wraps the text to the next line and aligns the
text appropriately.
When you finish entering text, deselect the object by clicking a blank area of
the slide or the gray border around the slide. Notice that the object no longer
is defined by the faint dotted line (see fig. 21.5). The absence of the dotted
line provides you with a better representation of the slide's appearance. (You
can, however, add a border to any object in a slide. See Chapter 24, "Enhancing a Presentation.")

Creating New Text Objects
Sometimes you want to add text to a slide. Suppose that your slide contains a
title and a bulleted list like the one shown in figure 21.6. You decide to add a
note below the bulleted list. To do this, you need to make the note a separate
object. Otherwise PowerPoint formats the note text as a bulleted-list item.
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Fig. 21.5
When an object
contains actual
text, it's no longer
defined by a
dotted line.
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Fig. 21.6
Add a note as a
separate object
below the bulleted
list.

• Greece and its islands, seven days
• Japan, eight days
• Korea, four days
• Mazatlan sun special, four days

Drawing toolbar

Separate text object needed here

Entering and Editing Text
To add a note at the bottom of the slide in figure 21.6, create a new object by
using the Text button in the Drawing toolbar (see fig. 21.6). When you click
Text and move the mouse pointer into the slide area, the pointer changes to a
vertical bar with a cross at the bottom. (Be sure that the text object with the
bullets isn't selected.) Drag this pointer to draw the text box you want. As
you drag the mouse, PowerPoint draws an outline for your text box. It's important to make the text box the correct width, but the depth of the box isn't
important. Regardless of the depth you draw, PowerPoint shrinks it to one
line of text and expands the depth of the box only if you type additional
lines of text.
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Tip

If you aren't certain what text you
want to enter in a
new text box, type
at least a few characters. Otherwise,
the text box is
deleted.

To draw a text box, follow these steps:
1. Click the Text button in the Drawing toolbar.
2 . Position the pointer (now a vertical bar) where you want to begin the
top left corner of the text box.

3. Click and drag the mouse diagonally (down and to the right) to form a
box of the appropriate width.
4. Release the mouse button. Your text box is bordered by wide-hashed
lines, indicating the box is selected. The 1-beam insertion point appears
inside the box, ready for you to enter new text.

Figure 21.7 shows how the slide in figure 21.6 looks with a text object.
Fig. 21.7

The slide in figure
21.6 now contains
a text object below
the bulleted list.

• Greece and its islands, seven days
• Japan, eight days
• Korea, four days
• Mazatlao suo special, four days
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Labeling Objects
Suppose that your slide contains a clip-art drawing that you want to label.
You don't need a large text object, as you might for a note. Your label is likely
to contain fewer than SO characters.
You can quickly create a text box that expands to the required width as you
type. The steps are similar to those for creating a larger text box, but with this
method, you don't specify the dimensions of the box. Follow these steps:
1. Click the Text button in the Drawing toolbar.
2. Place the mouse pointer where you want to begin typing and click and

release the mouse button. PowerPoint displays a text box large enough
for one character. The text box is selected, as indicated by the widehashed border.
3. Begin typing the label. With each character you type, the text box expands to the left. To type text on a new line, press return and continue
typing.
4. When you finish, deselect the box by clicking a blank area of the slide

or the gray border surrounding the slide.

Changing Text and Correcting Errors
After you enter text into a text box, you probably will want to change the
text or correct errors. Making changes in a text box is as easy as clicking and
retyping. Use standard editing conventions to change text, as summarized in
table 21.1. If you're familiar with Microsoft Word, you already know these
conventions. See Part II, 11 Using Word," for more information.

Table 21.1
~

See "Editing
Text," p. 94

Editing Conventions for Text Boxes

Action

Result

Arrow keys

Moves the insertion point right, left, up, and down within
the text

Backspace or del

Erases characters (to the left and right, respectively) of the
insertion point

Entering and Editing Text

Action

Result

Click and drag the mouse Selects a string of characters
Double-click a word

Selects the entire word

Triple-click a word

Selects the entire line
Selects all text in a text object

Del

Clears selected text from the object without placing it in
the Clipboard
Cuts selected text and places it in the Clipboard
Copies selected text to the Clipboard
Pastes text from the Clipboard

in addition to the keyboard shortcuts listed in table 21.1, you can edit text by

using the Cut, Copy, Paste, Clear, and Select All commands in the Edit menu.
When you finish editing text in a text box, be sure to deselect the text box by
clicking any blank area of the slide or the gray area surrounding the slide.

Checking Your Spelling
Because presentations primarily contain text, and because slides are highly
visible, remember to check your spelling before you print or produce slides
for your presentation.
The spell checker in PowerPoint compares all the words in your document
with an on-line dictionary file. When the spell checker finds a word that's
not in the dictionary file, it highlights the word in your slide and displays the
word in the Spelling dialog box (see fig. 21.8).
Note
The spell checker checks text in all objects in a presentation file except those that
contain text imported from other applications.
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Fig. 21.8
The Spelling
dialog box
displays an
unrecognized
word in the Not in
Dictionary box.

Suggested replacement word

Other possible replacements

The spell checker moves through your presentation one slide at a time, and
then checks the speaker's notes (if any) before closing the Spelling dialog box.
(If slide 1 isn 't displayed when you choose the Spelling command, the spell
checker checks all previous slides after the last slide is checked.) You can stop
using the spell checker at any time by clicking the Close button in the Spelling dialog box.
Note
A highlighted word isn't necessarily misspelled-it just isn't included in the on-line
dictionary. For this reason, the spell checker occasionally questions correctly spelled
words simply because it doesn't recognize them. This situation occurs frequently with
technical terms and industry-specific jargon. One of your options is to add these
words to the dictionary file so that the spell checker recognizes them in the fu ture.

When checking the spelling in a presentation, you have several options for
dealing with words that the spelling ch ecker questions. Table 21.2 describes
the functions of the command buttons in the Spelling dialog box.

Entering and Editing Text

Table 21.2

Spelling Command Buttons

Button

Function

Ignore

Skips the highlighted word without changing it.

Ignore All

Skips all instances in which the highlighted word appears throughout the presentation without changing the word.

Change

Changes the highlighted word to the word shown in the Change To
box.

Change All

Changes all instances in which the highlighted word appears
throughout the presentation to the word shown in the Change To
box.

Add

Adds the highlighted word to the on-line dictionary file.

Suggest

Shows a suggested replacement word in the Suggestions box. By
default, PowerPoint always displays words in the Suggestions box.
If you don't want PowerPoint to automatically display suggested
words, choose Tools Options, remove the X from the Always
Suggest box, and click OK.

Close

Closes the Spelling dialog box without checking the remainder of
the file.

Tip
If a word is mis-

spelled and the
spell checker offers
no suggested
replacement
words, you must
look up the word
in a dictionary,
type the correct
spelling in the
Change To box,
and click the
Change, Change
All, or Add button.

To check the spelling in a presentation file, follow these steps:
1. Choose Spelling from the Tools menu or press F7, and the Spelling

dialog box appears. The spell checker highlights the first unrecognized
word in the presentation file and shows the word in the Not in Dictionary box.
2. Click the appropriate command button (Ignore, Ignore All, Change,
Change All, or Add). If you want the spell checker to suggest a replacement word, click Suggest and click Ignore, Ignore All, Change, Change
All, or Add. The spell checker takes the appropriate action and then
highlights the next unrecognized word.
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3. Repeat step 2 until the spelling checker displays a message saying that
the entire presentation has been checked.
4. Click OK.

Troubleshooting
I selected an AutoLayout that contains bullets, but I've decided not to use bullets.
Select all the bulleted text and click the Bullet toggle button on the right end of the
toolbar. Or go to Format, choose Bullet, deselect the Use a Bullet check box, and
click OK. (You also can use this dialog box to change the bullet style.)

I don't understand the difference between drawing a text object and simply creating a
label.
A text object has a definite width that PowerPoint uses to automatically wrap text to
the next line when your text exceeds that width. A label has no definite width; it
expands with each character you type. You can type beyond the boundary of the
slide border and PowerPoint won't automatically wrap the text. To begin a new line
in a label, press return.

Inserting Clip Art Pictures
One of the best ways to spice up a slide show is to insert a clip art drawing.
Clip art drawings are especially appreciated by users who don't feel confident
drawing their own pictures. The ClipArt Gallery contains more than 1,000
drawings that cover a wide range of topics.
You can insert clip art into a slide in several ways. In uReviewing AutoLayout"
earlier in this chapter, you learned that some slide layouts include placeholders for clip art. When you use one of these slide layouts, simply double-click
the placeholder to choose a clip art file to insert. The first time you do this,
PowerPoint asks if you want to add clip-art files from Microsoft Office. A Yes
response makes the clip art files available for you to insert into your slides.
You also can insert clip art by choosing Insert Clip Art. Regardless of the
method you use, the next step involves choosing a file in the ClipArt Gallery
dialog box.

Inserting Clip Art Pictures

A list of categories appears at the top of the ClipArt Gallery dialog box. The
box below the category list shows a sample of each clip-art file in the current
category. Use the scroll bar, page up/page down, or the arrow keys to see each
picture in a category. If you prefer to scroll through the entire selection of
clip-art files, choose the All Categories option in the category list box.
To add a clip-art drawing to your slide, follow these steps:
1. Display the slide into which you want to insert clip art.
2. Choose Clip Art from the Insert menu. Or if your slide contains a clip
art placeholder, double-dick it. The Microsoft ClipArt Gallery dialog
box appears.

3. Choose a category in the category list.
4. Choose a picture and click OK. PowerPoint closes the ClipArt Gallery

dialog box and inserts the picture into your slide.

Troubleshooting
I want to change the colors in a clip art picture.

You can change the colors and other attributes of the object such as the line width,
fill or line color, shading, and pattern. First convert the clip art picture to a group of
PowerPoint objects. Highlight the clip art picture and choose Ungroup from the
Draw menu. When PowerPoint asks if you want to convert the picture to PowerPoint
objects, click OK. PowerPoint shows the resize handles of every object that makes up
the picture. Highlight the object you want to change and choose the appropriate
command to change the object's attributes. To learn how to change object attributes
such as colors, patterns, shading, shadows, and line styles, see Chapter 24, "Enhancing a Presentation."
I want to add clip art files from other programs to the ClipArt Gallery dialog box in
PowerPoint.

Click the Options button in the ClipArt Gallery dialog box. Click Add in the Options
dialog box. The Add Clipart dialog box appears. Choose the drive and folder in
which the file is located. In the Picture name list, choose the file name and click OK.
The Add Clipart dialog box changes, asking you to select a category for the new
picture (you also can add a short description if you want). To add the picture, click
Add.
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Inserting a Word Table or Excel
Worksheet
In a slide, a table or worksheet can convey useful information as long as it's
simple and large enough to read. When you use PowerPoint's text-editing
tools, however, you don't have the resources to create a table or worksheet, so
PowerPoint enables you to use Word and Excel tools.

To create a table or worksheet, click the Insert Microsoft Word Table button
in the Standard toolbar. A drop-down grid of cells appears. This grid enables
you to define the size of your table or worksheet (see fig. 21.9). Click and drag
the mouse pointer across the cells in the grid to indicate how many rows or
columns you want in your table or worksheet. The cells you select are highlighted and the dimensions are listed below the grid. (You can select up to 5
columns and up to 9 rows.)

Fig. 21.9
Use the pop-up
grid to specify the
number of rows
and columns in an
inserted Word
table.

Pop-up grid is identical for the Insert
Excel Worksheet button

Inserting a Word Table or Excel Worksheet
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When you release the mouse button, a window like the one shown in figure
21.10 appears. Notice that PowerPoint's Standard toolbar and menu bar are
temporarily replaced by the Word menus; all Word features and commands
are available to you while you create your table. In effect, you're using Word
inside a PowerPoint window.

........................ .... , ... ··························r·················· ·············
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Fig. 2 1.10
A Word table
inserted into a
PowerPoint slide .
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See "Editing
Text," p. 94
See "Formatting
Text," p. 108
See "Modifying
a Table," p. 198

Tip

To create the content of your table, click the area in wh ich you wan t to add
text or press the tab key to move the insertion point from left to right across
the cells in the table. Press the up- and down-arrow keys to move the insertion point from one row to another. Use standard editing conventions to
enter and edit text in the table (some of these conventions are listed in
table 21.1).
If you need to adjust the width of rows or columns, add rows or columns, or
perform more complex tasks while working with the table, see Chapter 10,
"Working with Tables, Charts, and Graphics."

If you prefer, you
can choose
Microsoft Word
Table from the
Insert menu to
create a Word
table. In the Insert
Word Table dialog
box, specify the
number of columns and rows for
the table.
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When your table is complete, deselect it by clicking any blank area outside
the table or the gray area that surrounds the slide. When the table no longer
is the selected object, the PowerPoint menus and toolbar return. You can
make changes in the table at any time by double-clicking inside the table.
When the table is selected again, the Word menus and toolbar automatically
return.
The same principles that govern Word tables hold true for Excel worksheets.
When you click the Insert Excel Worksheet button in the PowerPoint toolbar,
a drop-down grid appears. Click and drag the mouse pointer across the cells
in the grid to indicate the number of rows and columns for your worksheet.
PowerPoint inserts a special worksheet object into your slide and PowerPoint's standard menus and toolbar are replaced by the Excel menus and
toolbar (see fig. 21.11). Notice that column width and row height in figure
21.11 are enlarged to a size consistent with other slide content.

Fig. 21.11
You can insert an
Excel worksheet
into a PowerPoint
slide.

Use Excel's commands and tools to create and edit your worksheet. When the
worksheet is complete, deselect it by clicking any blank area of the slide or
the border of the slidei the standard Power Point menus and toolbar return. If
you aren't familiar with Excel, see Chapter 12, "Creating Worksheets," Chapter 13, "Editing Worksheets," and Chapter 14, "Formatting Worksheets. "

Inserting an Organization Chart

Inserting a Graph
Graphs, or charts, are graphic representations of data in worksheets. In a presentation, a bar, pie, or area chart often can depict data much more clearly
than words. In PowerPoint, you can insert a graph into a slide by using an
application called Microsoft Graph. Because Microsoft Graph is an application in itself, Chapter 25, Creating Charts," is devoted to this subject. Refer
to this chapter for instructions on creating data for your graph, charting the
data, and enhancing the graph before you insert it into your PowerPoint
slide.
11

Inserting an Organization Chart
Organization charts commonly are included in slide presentations. An organization chart can convey information about new management, a group or
department reorganization, or people to contact for specific types of information.
You may have discovered how difficult it is to create an organization chart in
a word processing program or a drawing application such as Microsoft Draw.
Word processing programs may not provide the flexibility you need to draw
and connect the boxes uniformly, and drawing applications often have limited text and text-formatting features. Neither is ideally suited to the task. To
solve this problem, Microsoft created an application called Microsoft Organization Chart, which is specifically designed to create organization charts.
To insert an organization chart into a PowerPoint slide, you can use a slide
layout that includes a placeholder for an organization chart. You also can
choose Object from the Insert menu and select Microsoft Organization Chart
1.0. To use the slide-layout method, choose Slide Layout from the Format
menu or click the Layout button at the bottom of the PowerPoint window to
display the Slide Layout/New Slide dialog box (see fig. 21.12).
In the dialog box, highlight the layout that includes the organization chart
and click OK. PowerPoint applies the layout to the current slide, inserting an
organization-chart placeholder. To access Microsoft Organization Chart,
double-click the placeholder. After a few seconds, the Microsoft Organization
Chart window appears. Figure 21.13 shows a sample organization chart.
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Fig.21.12
The Org Chart
layout is selected
in the Slide
Layout/New Slide
dialog box.
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The Microsoft
Organization
Chart window
appears on top of
the PowerPoint
window.

Ort cur1

1:

Chari THie

Enter the appropriate information in the sample organization chart, using
Microsoft Organization Chart commands. Because Microsoft Organization
Chart is a separate application, it contains its own help files.
When tbe organization chart is complete and you're ready to return to your
PowerPoint presentation, choose Quit from the File menu or click the close
box in the upper left corner of the window or Return to [File name] command from the Microsoft Organization Chart File menu. The organization
chart is inserted into the current slide. To deselect the organization chart,
click any blank area of the slide or the gray area surrounding the slide.
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In this chapter, you have learned how to insert clip art, a Word table, an
Excel worksheet, and an organization chart into a PowerPoint slide. You can
insert many other types of objects by choosing Object from the Insert menu.
This command opens another application on top of your PowerPoint window, enabling you to create a new file or open an existing file within that
application. When you're ready to return to PowerPoint, choose the Quit
command from the other application's File menu. When you choose this
command, the open application closes and the object you created is inserted
into your PowerPoint presentation slide.
After you return to PowerPoint, you can change the object you inserted by
double-clicking it to redisplay the appropriate application window. If, for
example, you inserted a chart that you created in Microsoft Works and want
to change it, double-click the chart to start the Microsoft Works application.
To return to PowerPoint after changing the chart, choose the Exit and Return
command from the File menu in Microsoft Works. Microsoft Works closes,
and the chart is updated in your PowerPoint presentation.
To show the types of objects you can insert, choose Object from the Insert
menu in PowerPoint and the Insert Object dialog box appears (see fig. 21.14).
The Object Type list shows all the types of files you can insert into a
PowerPoint slide.
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Because the Insert Object feature of PowerPoint works by opening another
application, you must have that application installed on your computer. If,
for example, Microsoft Works is installed on your computer, you can choose
any of the Works options listed in the Insert Object dialog box and then
create a new file or insert an existing one. If you don't have Works installed
on your computer, you cannot open Works and create or insert a file from
that application.
Before selecting the type of object to be inserted, choose Create New or Create from the File menu. The Create New button enables you to create a new
file of the object type you selected; the Create from File button enables you to
insert an existing file that was created with the application you selected in
the Object Type list. The Result area at the bottom of the dialog box tells you
what will be inserted into your PowerPoint slide when you select an item in
the Object Type list.
The Display As Icon check box (located below the command buttons in the
Insert Object dialog box) enables you to display the inserted object in the
form of an icon rather than as a full-size object. This feature is most useful
when your presentation is a slide show, enabling you to conserve space in a
slide or hide the inserted object until you're ready to reveal its contents. You
also can use this feature to make backup data for an on-screen presentation
readily available.
To insert a new file from another application, follow these steps:
1. Display the PowerPoint slide into which you want to insert an object.

2. Choose Object from the Insert menu. The Insert Object dialog box
appears.

3. Click the Create New button.
4. This step is optional: choose the Display As Icon option if you want to
display the object as an icon.
5. In the Object Type list, choose the object you want to insert, and click
OK. The Insert Object dialog box closes and the window for the appropriate application opens on top of the PowerPoint window.
6. Use the application as you normally would. Create a new file if neces-

sary or simply choose an item (such as an equation or a clip-art file). If
you choose an item, PowerPoint inserts the item and closes the application. If you create a new file, return to PowerPoint by choosing Quit
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from the open application's File menu. The application window closes,
and the file you created is inserted into the current PowerPoint slide.
7. Click any blank area of the slide or the gray area surrounding the slide

to deselect the object.
When you insert an existing file from another application, the file is automatically inserted into the PowerPoint slide. PowerPoint doesn't open the
application that you used to create the file. If you want to modify the file,
you must open the application by double-clicking the object after it is inserted into your PowerPoint slide.
When you choose the Create From File option in the Insert Object dialog
box, PowerPoint shows a standard Open dialog box (see fig. 21.15).
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To insert an existing file from an other application, follow these steps:
1. Display the PowerPoint slide into which you want to insert an object.
2. Choose Object from the Insert menu. The Insert Object dialog box

appears.
3. This step is optional: choose the Display As Icon option if you want to
display the object as an icon.
4. Choose an item in the Ob ject Type box.
5 . Click the Create from File button. PowerPoint modifies the Insert Ob-

ject dialog box to match the one shown in figure 21.15.
6 . Choose the correct file name and click OK. After you're through and

you've chosen an item, return to the Insert Object dialog box, where
the file name you selected now appears above the Browse button. If you
want to ex pand your search, click Browse.

Fig. 21.15
When you're
inserting an object
from an existing
file, the Insert
Object dialog box
enables you to
search for the
correct file name.
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7. Click OK in the Insert Object dialog box. The file you specified is inserted into your PowerPoint slide without opening the application you
used to create the file.
8. Click any blank area of the slide or the gray area surrounding the slide
to deselect the inserted object.

From Here ...
Refer to the following chapters for information related to entering slide
content:
• Chapter 22, uworking with Objects," describes how to manipulate objects, including moving, copying, deleting, resizing, grouping, and
ungrouping.
• Chapter 23, "Drawing Shapes, Curves, and Lines," describes how to use
PowerPoint's drawing tools to add drawn objects to your slides.
• Chapter 24, 11 Enhancing a Presentation," describes how to add color,
borders, shadows, and other enhancements to objects.
• Chapter 25, ucreating Charts," describes how to use Microsoft Graph,
an embedded application that enables you to create a wide variety of
chart types from worksheet data.

Chapter 22

IV

bjects

You were in troduced to object s in Chapter 19, "Getting Acquainted with
PowerPoint," and you learned more about entering conten t in objects in
Chapter 21, "Entering Slide Content." Objects are the building blocks of
slides that contain primarily text, graph ics, or pictures but also can contain
other elements such as tables, spreadsheets, or organization charts. You need
to understand how to work with objects because they are the key compon ents of a PowerPoint slide.
In this chapter, you Jearn to
• Select and group ob jects
• Move, copy, resize, and delete objects
• Align objects
• Use the grid
• Rotate and flip objects
• Stack objects

Selecting and Grouping Objects
Before you can make any kind of a change to an object- add color, ch ange its
size, move, or delete it-you m ust select the object. Selectin g a single object is
as simple as clicking it. When you click an object such as a chart, ClipArt
drawing, or organization chart, resize handles surround the ob ject in a rectangular sh ape (see fig. 22.1). Resize handles are small boxes th at appear at the
four corners and on each of the four sides of the rectangle. When you see
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the resize handles, you know an object is selected. In the section "Resizing
and Scaling Objects" later in this chapter, you learn how to use these handles
to change the size of an object.

Fig. 22.1

An object is
selected when its
resize handles are
visible

Click to add title
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Selecting Multiple Objects
In PowerPoint, you generally select an object to move, copy, or resize it, or to
change one or more of its attributes. An attribute is any characteristic that is
applied to an object, such as colo r, border, fill, and shadow. Som etimes you
may want to select mo re than one object at a time. Selecting m ultiple objects
can save you the time of applying the same attribute to several objects individually. Wh en you select multiple objects, any attribute you change is applied to all selected o bjects. To change the colo r of several objects to blue, fo r
instance, select all o bjects and then apply the blue fill color.
To select multiple o bjects at once, press and hold the Shift key and then click
each object you want to include in the selection . The resize handles appear
around each ob ject you select (see fig. 22.2). If you select an object by mistake
and want to rem ove it from your selectio n, continue holding the Shift key
while you click the object again. PowerPoint removes that object from the
selection . Release the Shift key wh en you have selected all objects.
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Fig. 22.2
In a multiple
selection, resize
handles appear
around each
selected object.

Selection tool

Another way to select multiple objects at once is to use the Selection tool on
the Drawing toolbar (the first button, shaped like a mouse pointer arrow, on
the toolbar). Click the Selection tool, and drag the mouse across all objects
you want to include in the selection. As you drag the mouse, PowerPoint
draws a dashed rectangle that encloses all selected objects. When you release
the mouse button, the rectangle disappears and the resize handles of each
object in the selection are visible.
Note
You must fully enclose all objects within the selection rectangle you draw. If a portion
of any object is not enclosed within the rectangle, that object is excluded from the
selection. You can add an object to any selection by holding the Shift key and clickIng the object.

To quickly select every object on a slide, choose the Select All from the Edit
menu or press the keyboard shortcut, ;}:(+A. PowerPoint immediately displays
the selection handles of all objects on the slide.

L1
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Tip
To cancel any
multiple selection,
click anywhere in
a blank area of the
slide. To remove
one or more objects from a multiple selection,
press and hold
down the Shift key
and then click the
object you want to
remove.

Troubleshooting
When I draw a selection box around several objects, some objects are not selected.

Remember that you must fully enclose all objects you want to select in the selection
box. If a portion of an object falls outside the selection box, it isn't selected.
Can I select objects on multiple slides at once?

No. The only way to view multiple slides at once is to use slide sorter view, and you
cannot select objects in this view.
I try to select the company logo on my slide, but nothing happens. Why?

The logo probably was inserted into the slide master rather than the individual slide.
To select the logo, switch to slide master view (choose Master Slide from the View
menu or press )::( and click the Slide Master button in the lower-left corner of the
window), and then select the object. Any changes you make will affect the object on
all slides.

Grouping Objects
Grouping objects enables you to treat several objects as a single object. Suppose, for example, you used PowerPoint's drawing tools to handle several
objects at once. Without grouping the objects that compose the group (see
fig. 22.3), moving or resizing the group as a whole is difficult. You could
inadvertently move or delete a component of the group or change one of its
attributes by mistake. But when you select and group all the objects that
make up the group, the objects are treated as a single item. Any attributes you
choose are applied to the entire object as a whole; the object can be moved,
copied, resized, scaled, rotated, or flipped as a whole.
To group several objects, select the objects by using one of the methods you
just learned (using the Shift key, the Selection tool, or the Edit Select All command). The resize handles for each object are displayed. Now choose Group
from the Draw menu. The object is now surrounded by an invisible rectangle,
indicated by resize handles at the four corners and along each side of the
rectangle. When you select the object in the future, it will appear as a single
object with one set of resize handles (see fig. 22.4).
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Fig. 22.3
A drawing is
comprised of
many individual
objects.

Fig. 22.4
Individual objects
are grouped as a
whole.

Sometimes you only want to group multiple objects temporarily. Suppose
that you have moved or resized your group drawing, and now you wan t to
apply different attributes to the various components of the group. To separate

IV
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objects that are grouped, select the grouped object, then choose Ungroup
from the Draw menu. PowerPoint separates the objects, and each object's
selection handles are visible once again on the slide, as they appeared earlier
in figure 22.3.

Moving and Copying Objects
Tip
When moving an
object, use the
arrow keys to make
minor adjustments
up, down, right, or
left. First select the
object, and then
press any of the
arrow keys. Press
Esc when the
object is positioned correctly.

•
•

Occasionally, you need to move or copy objects in a presentation. Moving an
object within a slide is as simple as clicking and dragging the object to a new
location. As you drag the mouse to a new location, the original object stays in
its current location on the slide while a 11 ghost" image (a dotted-line silhouette) of the object follows your mouse movements around the screen. Release
the mouse button when the silhouette of the object is positioned correctly.
PowerPoint then moves the object to its new location.
To move an object from one slide to another or from one presentation to
another, use the Edit Cut and Edit Paste commands or the keyboard shortcuts
;):(+X and ;):(+V, respectively. Follow these steps:
1. If you are moving an object from one presentation to another, open
both presentations, making the active presentation the one that contains the object to be moved.

2. Select the object to be moved .
3. Choose Cut from the Edit menu, or press ;):(+X. The selected object is
removed from the current slide and placed on the Clipboard.
4. If you are moving the object to another slide in the same presentation,
display that slide. If you are moving the object to another presentation,

make it the active presentation and display the correct slide .
5. Choose Paste from the Edit menu, or press ;):(+V. PowerPoint pastes the
object on the current slide.
6. Reposition the object appropriately on the current slide by clicking and
dragging the object to the correct position.
7. Click any blank area of the slide to deselect the object, or press esc.
The steps for copying an object are similar to those for moving an object
except that you use Copy from the Edit menu rather than Cut (the keyboard
shortcut for the Copy command is ;):(+C). As when moving an object, you
can also copy an object within a slide, within a presentation, or to another
presentation.
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To copy an object, follow these steps:
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1. If you are copying an object from one presentation to another, open

both presentations, making the active presentation the one that contains the object to be copied.
2. Select the object to be copied.
3. Choose Copy from the Edit menu, or press :l:t+C. The selected object
remains unchanged on the current slide and a copy is placed on the
Clipboard.
4. If you are copying the object to another slide in the same presentation,
display that slide. If you are copying the object to another presentation,
make it the active presentation and display the correct slide.
5. Choose Paste from the Edit menu, or press :l:t+V. PowerPoint pastes the

object on the current slide.
6. Reposition the object appropriately on the current slide by clicking and
dragging the object to the correct position.
7. Click any blank area of the slide to deselect the object, or press esc.

Resizing and Scaling Objects
Throughout this chapter you have already seen several examples of the resize
handles that become visible when you select an object. To resize an object,
you first click the object to select it, and then drag any resize handle to a new
position .
The resize handles that appear on the sides of the selection box resize in one
dimension only. For instance, if you click the resize handle at the top of th e
selection box, you can stretch or shrink the height of an object on its top
only; the bottom remains anchored. If you click the right resize handle, you
can stretch or shrink the width of an object on its right side only; the left side
remains anchored. Release the mouse button when the object is the size you
want.
The resize handles that appear at the corners of an object enable you to resize
an object in two dimensions at once. If you click the resize handle in the
upper-right corner of an object, for instance, you can change the height or
width of the object by dragging the handle in any direction. Whenever you
drag a corner handle, the handle in the opposite corner remains anchored
while you expand or contract the object's height and width.

ltll
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Tip
If you change your

mind about an
object's new size,
choose Undo from
the Edit menu, or
press ~+Z .

When you resize in two dimensions at once, you may want to maintain an
object's height-to-width ratio. To do so, hold the Shift key as you drag any
corner resize handle. The handle in the opposite corner remains anchored
while you resize the object. Or you might want to resize in two dimensions at
once, from the center of the object outward. To do so, hold down the Option
key as you drag any corner handle. By holding both the Shift and Option
keys as you drag a corner handle, you can maintain an object's height-towidth ratio and resize from the center outward, all In one step.
Another way to resize an object is to scale it. Scaling enables you to specify an
object's size by percentage. If you want an object to be half its current size,
for example, you scale it by SO percent. To scale an object, choose Scale from
the Draw menu, which displays the Scale dialog box shown in figure 22.5.

Fig. 22.5
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To scale an object, follow these steps:
1. Select the object.
2. Choose Scale from the Draw menu. The Scale dialog box appears.
3. In the% box, enter a number greater than 100 to enlarge the object;
type a number smaller than 100 to reduce the object. You can either
type a number or click the up or down arrows to change the setting.
4. (Optional) To preview the object, choose the Preview button. If neces-

sary, repeat step 3 to resize the object.
5. Click OK.

As an alternative to the preceding steps, you can have PowerPoint determine
a scale for you by selecting the Best Scale for Slide Show option in the Scale
dialog box. This option automatically chooses the best scale for an object to
ensure optimal viewing during an on-screen slide show.
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Troubleshooting
My object is a rectangle 1 inch wide by 2 inches high. How can I use the resize handles to
add approximately 1/2 inch to the top and bottom of the object uniformly?

Hold down the Option key as you drag either the top or bottom resize handle. You
also can use the Option key with a side resize handle to add or subtract width uniformly. When used with a corner resize handle, the Option key enables you to resize
in two dimensions from the center of the object outward.
I entered 100% in the Scale dialog box to restore an imported picture to its original size,
but the picture is still the wrong size and its dimensions are not correct.

When the original dimensions of an imported picture have been altered, choosing
100% scale will not restore them. You must select the Relative to Original Picture Size
option as well. This option restores the picture's original height-to-width ratio to the
scale you specify (use 100% for the original picture size). If, for example, you select
the Relative to Original Picture Size option and enter 200% for the scale, the original
dimensions are restored and the object is twice its original size.

Aligning Objects
Sometimes you may want to align objects in a slide to give the slide a neater,
more polished appearance. PowerPoint takes the guesswork out of aligning
objects by offering a variety of automatic alignment options. You can use the
traditional left-, center-, or right-alignment styles, or you can align the tops,
bottoms, or middles of objects. Each of these alignment options is illustrated
in the slide sorter view shown in figure 22.6. In the figure, slide 1 shows the
objects aligned to the left, slide 2 is center-aligned, and slide 3 is rightaligned. Slides 4, 5, and 6 show how the objects are aligned at the top, vertical mid-point, and bottom of the slide.
To use any of PowerPoint's alignment options, follow these steps:
1. Select the objects you want to align.

2. Choose Align from the Draw menu. (You must select two or more
objects on the current slide to enable the Draw Align command.)
The Align cascading menu shown in figure 22.7 appears.

Tip
You can add any of
the six alignment
buttons to your
toolbar by choosing View Tool bars.
just select which
toolbars you want
from the ensuing
dialog box.
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Fig. 22.6
PowerPoint offers
six automatic
alignment styles.

3. From the cascading menu, choose an alignment option. PowerPoint
realigns the selected objects.
Fig. 22.7
Choose an
alignment style
from the Align
cascading menu.
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Using the Grid
To help you align and position objects on a slide, PowerPoint includes three
tools-guides, rulers, and the grid-which can be toggled on and off with a
simple menu command. Guides and rulers are visible markers that appear on
a slide to give you a visual reference point. Using guides and rulers is discussed in Chapter 19, "Getting Acquainted with PowerPoint."

Rotating and Flipping Objects
Unlike visible guides and rulers, the grid is an invisible set of lines that run
horizontally and vertically on a slide. The lines (approximately every 1/8
inch) form a grid similar to that of a very fine graph paper. When the grid is
turned on , objects that you draw or move "snap" into alignment at the nearest intersection of the grid. Using the grid h elps to make alignment of objects
an easier task. Use the grid when you don't n eed to align objects more precisely than approximately 1/8 inch.

~

To turn the grid on and off, choose Snap to Grid in the Draw menu. When
the grid is turned on, a check mark appears next to the Snap to Grid command on the menu (no indicators appear in the PowerPoint window). You
also can turn the grid on and off temporarily by holding the ~ key as you
drag an object to a new location on a slide. If you experiment with pressing
the ~ key on and off as you drag an object, you can see how the grid works
as you watch the object track smoothly across the screen or "snap" into place.

Tip

Rotating and Flipping Objects
One way to add visual interest to your slides is to rotate or flip an object.
Rotating refers to turning an ob ject around a 360-degree radius. Flipping
refers to "turning an object over" -either horizontally or vertically-to create
a mirror image of that object. You can rotate or flip any PowerPoint object.
Note
A PowerPoint object is defined as an object created within PowerPoint using a
PowerPoint tool (such as the drawing tools) or an object imported from another
program and then converted to a PowerPoint object. To convert an object to a
PowerPoint object, you must be able to ungroup its components and then regroup
them using the Draw Group command. If you cannot do this, the object cannot be
converted to a PowerPoint object and, therefore, cannot be rotated or flipped.

PowerPoint enables you to rotate an object in either of two ways. You can
rotate an object to any position in a 360-degree radius, or you can rotate an
object in 90-degree increments to the left or right, which has the effect of
turning the object 1/4 turn. When you flip an object, you flip it either horizontally or vertically 180 degrees. These choices are illustrated on the Rotate/
Flip cascading menu shown in figure 22.8.
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See " Displaying
Rulers and
Guides," p. 419

If you change your
mjnd about the
alignment you
choose, you can
restore the origin al
position of the
selected objects by
choosing Undo
from the Ed it
menu or by pressing ~+Z.
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Fig. 22.8
Rotation and
flipping options
are shown on the
Rotate/Flip
cascading menu.
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To rotate an object by 90 degrees or flip an object 180 degrees, follow these
steps:
1. Select the object to rotate.
2. Choose Rotate/Flip from the Draw menu.
3. From the cascading menu, choose the Rotate Left or Rotate Right command to rotate the object, or the Flip Horizontal or Flip Vertical command to flip the object. PowerPoint immediately rotates or flips the
object in the direction selected.
4. To rotate the object another 90 degrees, repeat steps 2 and 3.

5. Click any blank area of the slide to deselect the object.

To rotate an object to any angle in a 360-degree radius, you use the Free Rotate tool on the Drawing toolbar or the Free Rotate command on the Rotate/
Flip cascading menu. In either case, the mouse pointer changes as shown
below:

8

This mouse pointer indicates that the Free Rotate command or
tool is currently selected.

Jlt:p" This mouse pointer indicates that the pointer is in position (over
IIC

:~~~

a resize handle) for you to begin rotating the selected object.

To rotate an object to any position on a 360-degree radius, follow these steps:
1. Select the object to rotate.
2. Click the Free Rotate Tool on the Drawing toolbar, or choose the Draw
Rotate/Flip command and then choose the Free Rotate command.

Rotating and Flipping Objects
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The mouse pointer changes to two curved arrows that form a circle with
a cross in the center.
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3. Position the cross in the mouse pointer on top of any of the object's
resize handles. The mouse pointer ch anges again to a cross in the center
with four outward-pointing arrows.
4. Click and hold down the mouse button as you rotate the object either

left or right until it is positioned correctly; then release the mouse button.
5 . Click any blank area of the slide to deselect the object.

You can rotate or flip several objects at once, and you can rotate or flip objects that are grouped. When you select multiple objects to rotate or flip, each
object rotates or flips independently of the others around its own center
point, and each object rotates to the same angle as all others. When you rotate or flip objects that are grouped, however, the individual objects do not
rotate or fljp independently; they rotate or flip as a whole. This djfference is
illustrated in figure 22.9.
Fig. 22.9
Multiple objects
rotate or fli p
differently
depending on
their grouping.
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Changing the Stacking Order of
Objects
As you add objects to a slide and overlap them, you quickly discover that the
object drawn first appears underneath and the object drawn most recently
appears on top of the others. Think of the objects being "stacked" on the
slide as you draw them. The most recently drawn object appears and remains
at the top of the stack unless you change the stacking order. In figure 22.10,
the circle was drawn first, then the square, and then the rectangle. No matter
where you move the objects on the slide, the circle is on the bottom, the
square in the middJe, and the rectangle on top.
Fig. 22.10
Objects ,overlap
one another in
the order they
are drawn.

PowerPoint lets you change the stacking order of objects in several ways. The
Draw Bring Forward and Draw Send Backward commands let you move an
ob ject one step at a time forwa rd or backward through a stack of objects. So,
if you have six objects stacked on top of one another and the sixth object is
selected, that object becomes the fifth object in the stack if you choose the
Bring Forward command. If you choose the Send Backward command, nothing happens because the selected object is already at the bottom of the stack.
The other way to move objects is by choosing the Draw Bring to Front and
Send to Back commands. These commands move a selected object to the top
or to the bottom of the entire stack, regardless of its current position or the
total number of objects in the stack. In figure 22.11, all three objects were
align ed to the left, and the circle was selected and brought to the front.

From Here...
Fig. 22.11
The circle is
brought to the
front, and all
objects are left
aligned.

Note
Small objects can easily become completely obscured by others. If you cannot find an
object to select, select any object on the slide, then press the Tab key until the object
you want is selected. Each time you press the Tab key, a new object on the current
slide is selected.

From Here ...
In this chapter, you learned all the skills you need to know to work with
objects, including selecting and grouping, moving and copying, aligning,
rotating, flipping, and stacking. For related information about working with
objects, refer to the following chapters:
• Chapter 23, "Drawing Shapes, Curves, and Lines," describes how to use
PowerPoint's drawing tools to add drawn objects to your slides.
• Chapter 24, "Enhancing a Presentation," describes h ow to add color,
borders, shadows, and other enhancements to objects.
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One of the easiest and most effective ways to enhance a slide is to add a
drawn object. In PowerPoint, you can draw common shapes, such as ellipses
and rectangles, or more unusual shapes, such as stars, arrows, and cubes. You
also can draw lines, arcs, and freeform shapes by using the drawing tools in
PowerPoint.
In this chapter, you learn to
• Use the drawing tools in PowerPoint
• Draw shapes, AutoShapes, and perfect shapes
• Draw lines, arcs, and freeform shapes
• Modify shapes

Using PowerPoint's Drawing Tools
By now, you should be fami liar with the Drawing and Drawing+ toolbars in

PowerPoint, since they are displayed in the PowerPoint window automatically whenever you start the program. The tools on the Drawing+ tool bar (the
leftmost toolbar in the PowerPoint window) are used primarily to change the
look of objects on a slide. You learn more about these tools in Chapter 24,
"Enhancing a Presentation." In this chapter, you learn h ow to use the tools in
the Drawing toolbar. These tools are described in table 23.1.
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Table 23.1

Button

•
~
~

Tools in PowerPoint's Standard Drawing Toolbar

Drawing Tool

Function

Selection

Displays an arrow-shaped mouse pointer
that enables you to select objects in a
slide.

Text

Displays an inverted T-shaped insertion
point that enables you to enter text in
a slide.

Line

Draws straight lines in any direction from
the point at which you click the mouse.

Rectangle

Draws rectangles of any dimension.

Ellipse

Draws curved shapes, including ellipses
and circles.

Arc

Draws arched or curved lines. When
filled, the shape becomes a quarterellipse.

Freeform

Draws any irregular shape.

Free Rotate

Displays a special mouse pointer that
enables you to rotate a selected object to
any angle on a 360-degree radius.

AutoShapes

Displays the AutoShapes toolbar, which
contains buttons for 24 predefined
shapes, including a star, a cube, and an
arrow.

Fill On/Off

Adds or removes the default fill characteristics (color, shade, and pattern) of the
selected object.

Line On/Off

Adds or removes the default line
characteristics (color, style, and width) of
the selected object.

Shadow On/Off

Adds or removes the default shadow
characteristics (color and offset) of the
selected object.

To activate a drawing tool, simply click it. When you click the Text tool, the
mouse pointer changes to an inverted T-shaped insertion point. When you
click the Line, Rectangle, Ellipse, Arc, Freeform, or AutoShape tool, the mouse
pointer changes to a crosshair. To activate any of the remaining tools-Free
Rotate, Fill On/Off, Line On/Off, and Shadow On/Off-you must select an
object before you click the tool.

Drawing Shapes
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In the context of this chapter, a shaped object, or shape, is defined as a closed
object that you draw with a PowerPoint drawing tool, including circles, ellipses, squares, and rectangles. All of the shapes in the AutoShapes toolbar
also are considered to be shapes; these are discussed in the next section of
this chapter.
To draw a shape, follow these steps:
1. In the Drawing toolbar, click the Rectangle or Ellipse tool to select that

shape.
2. Move the mouse pointer to the approximate location in the slide where
you want to draw the object. The mouse pointer changes to a crosshair.
3. Click and drag the mouse in any direction. As you drag the mouse, a
solid outli ne of the shape appears in the slide.
4 . When the object is the shape and size you want, release the mouse

button. The object is selected automatically.
5. Click any blank area of the slide to deselect the object.
Figure 23.1 illustrates what you see on-screen while you draw an object. As
you draw, don' t feel that you must position your object perfectly the first
time; you can move, copy, resize, rotate, flip, or align any object you draw.
Fig. 23.1
As you draw, a
solid outline
indicates the size
and shape of the
object.

Crosshair mouse pointer
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Note
Depending on the presentation template you are using when you draw an object,
PowerPoint automatically fills the object with a color called the fill color (in some
templates, the fill color might be white). The fill color is determined automatically by
the color scheme of the template you are using. In Chapter 24, "Enhancing a Presentation," you learn how to work with color schemes and change the fill color of an
object. For now, don't worry about changing the colors of the objects you draw.

Drawing AutoShapes
The AutoShapes tool is a unique drawing tool because it displays its own
toolbar when you click it. The toolbar contains 24 predefined shapes that you
can draw instantly simply by clicking and dragging the mouse. You don't
have to use the Line tool to draw a perfect star, diamond, or arrow, because
these shapes are available in the AutoShapes toolbar (see fig. 23 .2). Other
shapes in this toolbar include the parallelogram, trapezoid, triangle, pentagon, hexagon, octagon, cube, cross, and seal (starburst). The Au toShapes
toolbar makes it easy for you to draw shapes that you frequently might include in your slides.
Fig. 23.2
Choose a shape
from the
AutoShapes
toolbar.
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To draw an AutoShape, use the same technique as you would for an ellipse or
rectangle, except that you must select an AutoShape before you begin drawing. Follow these steps:

Drawing Shapes
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1. Click the AutoShapes tool in the Drawing toolbar. The AutoShapes
toolbar appears.

2. Click an AutoShape to activate it.

3. Place the mouse pointer in the slide where you wa nt to draw the object.
The mouse pointer changes to a crosshair.
4. Click and drag the mouse in any direction. As you drag, a solid outline

of the shape appears.
5. When the object is the shape and size you want, release the mouse
button. The object is selected automatically.
6. Click any blank area of the slide to deselect the object.

IV
Tip
When you click
the AutoShapes
tool, the toolbar
pops up as shown
in figure 23.2.
You can move or
reconfigure the
toolbar simply by
dragging it to
another location
on-screen .

Drawing Perfect Shapes
To draw a perfect or uniform shape, you follow the same basic steps for drawing a shape, except that you use the shift key as the constraint key; it keeps
the object in proportion. In other words, holding down the shift key maintains the horizontal and vertical distance from the mouse pointer as you
draw. You can use the Ellipse tool, for example, to draw a perfect circle. You
can draw a perfect square with the Rectangle, Rounded Rectangle, Cube, or
Balloon tool. Figure 23.3 shows several uniform shapes.
Fig. 23.3
You can d raw
these uniform
shapes by holding
down the shift
key.

+
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To draw a uniform shape, follow these steps:
1. Click the drawing tool you wa nt to use.

2. Place the mouse pointer in the slide where you want to draw the object.
The mouse pointer changes to a crosshair.
3. Press and hold down the shift key.
4. Click and drag the mouse pointer in any direction .
5. When the object is the uniform shape and size you want, release the
mouse button . The object is selected automatically.
6. Click any blank area of the slide to deselect the object.

Drawing from the Center Outward
You have learned how to draw a shape by starting at one of the corners and
drawing in any direction . Sometimes, you might wan t to draw a sh ape from
the center outward. For example, you might wa nt to center several objects on
top of one another. To draw an object from the center outward, use the option key. When you press the option key as you draw a shape, the center of
the object remains anchored at the point where you placed the crosshair
when you began drawing.
To draw fro m the center outward, follow these steps:
Tip
You can hold
down both constraint keysoption an d shiftto draw uniform
shapes from the
center outward.

1 . Click the drawing tool you want to use.

2 . Position the crosshair in the slide where you want the center of the
object to be located.
3. Press and hold down the option key.
4. Click and drag the mouse in any direction. As you draw, the center

point of the object remains anchored .
5. When the object is the shape and size you want, release the mouse
button . The object is selected automatically.
6. Click any blank area of the slide to deselect the object.
Note
To center several objects on a specific point, draw two intersecting lines (one horizontal and one vertical) to mark the point. Then position the crosshair on the point
of intersection when you begin to draw the object. You can re move the lines after
you draw and center all your objects.

Switching and Adjusting Shapes
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After you draw a sh ape, you can change it to a d ifferent shape. You might
have enclosed some special information in a star, for example, and then decide to change the star to an octagon. Rather than delete the star and start
over, you can change it to a different shape easily. To change a shape, use the
Change AutoShape command in the Draw menu, which displays the cascade
menu shown in figure 23.4.
Fig. 23.4
The Change
AutoShape cascade
menu resembles
the AutoShape
tool bar.

+
To change a shape, follow these steps:
1. Select the shape you want to change.

2. Open the Draw menu and choose Change AutoShape. PowerPoint displays a cascade menu similar to the AutoShapes toolbar.
3. Click the AutoShape you want to use. PowerPoint immediately converts
the original shape to the new AutoShape. The object remains selected .
4 . Use the resize handles to resize th e shape, if necessary.
5. Click any blank area of the screen to deselect the object.

Some objects have unique shape characteristics that you can adj ust. For example, you can make the arms of the cross AutoShape thicker or thinner; you
also can adjust the width of an arrowhead or the length of the sides of an

Tip
You can chan ge
the shape back
again by choosing
Undo from the
Edit menu, pressing ;):t+Z, or clicking the Undo tool
in the toolbar.
You must undo
the change before
taking any other
action.
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octagon. Objects that can be adjusted display a diamond-shaped adjustment
handle, as shown in figure 23.5.
Note
Symmetrical objects do not have adjustment handles.

Fig. 23.5
Use the adjustment handle to
adjust an object's
unique shape
characteristics.

Cross with
thinner arms

Cross with thicker arms

To adjust an object, follow these steps:
1. Select the object you want to adjust.
2. Click the adjustment handle and drag it in any direction until you are

satisfied with the adjustment. Then release the mouse button. The object remains selected.
3. Click any blank area of the slide to deselect the object.

Drawing Lines and Arcs
The technique for drawing lines and arcs is similar to that used for drawing
shapes. The only difference between drawing lines and arcs and drawing
other types of shapes is that lines and arcs are not enclosed objects. Lines and
arcs have a beginning point and an end point, with resize handles at each of
those points. Figure 23.6 shows a drawing made with lines and arcs.

Drawing Lines and Arcs
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Fig. 23.6
Examples of lines
and arcs in a
drawing.

Lines

Arcs

To draw a line or arc, follow these steps:
1. Click the Line or Arc tool in the Drawing toolbar.
2. Place the mouse pointer in the slide area. The mouse pointer changes to
a crosshair.

3. Click where you want the line or arc to begin, and then drag the mouse
until the line or arc is complete.
4. Release the mouse button. The line or arc is selected automatically.

5. Click any area of the slide to deselect the line or arc.

Drawing Perfect Lines and Arcs
In the "Drawing Perfect Shapes" section earlier in this chapter, you learned
that the shift key can be used to draw uniform objects. Used in conjunction
with the Line tool, the shift key enables you to draw vertical lines, horizontal
lines, and lines at a 45-degree angle.
To draw a vertical line, press and hold down the shift key, and then drag the
mouse vertically from the starting point of the line. To draw a horizontal
line, press and hold down the shift key, and then drag the mouse horizontally from the starting point. To draw a line at a 45-degree angle, press and
hold down the shift key, and then drag the mouse diagonally in the direction
you want to draw the line.

IV
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Experiment with the various angles by holding down the shift key and moving the mouse in a circle around the beginning point of the line. A straight
line appears at 45, 90, 135, 180, 225, 270, 315, and 360 degrees from the
starting point.
When you use the shift key in conjunction with the Arc tool, you can draw a
uniform arc-that is, the shape of the arc you draw (regardless of the size) is
always a quarter-circle. A perfect arc is one in which two lines drawn perpendicular to the arc's end points form a right angle (90 degrees).

Drawing Lines and Arcs from a Center Point
just as you use the option key to draw shapes from the center outward, you
use the option key to draw lines and arcs from a center point outward. The
point at which you place the crosshair in the slide becomes the center point
for the line or arc. As you drag the mouse in any direction, this center point
remains anchored.
You also can use the option and shift keys in conjunction with the Line and
Arc tools to draw uniform lines and arcs outward from a center point.
Troubleshooting
I can use the shift key with the Line tool to draw lines ot 45-degree angles, but I want to
draw a line at an angle other than 45 degrees.
To draw a line at any angle around a 360-degree radius, press and hold down the
option key as you move the mouse in a circular motion.

I want to change the length or direction of a line and the size or shape of an arc.
Lines contain two resize handles, one at each end of the line. Drag either handle to
change the length of a line or its direction. Arcs are defined by eight resize handles,
one at each corner plus one on each side of a rectangle. Drag any of the eight
handles to change either the size or shape of an arc.

Drawing Freeform Shapes
Using the Freeform tool, you can draw any type of freeform shape or polygon. A freeform shape can consist of curved lines, straight lines, or a combination of the two. You might use the Freeform tool to draw a cartoon, create
an unusual shape, or write your name. A freeform shape can be open (that is,
the beginning point and end point don't meet) or closed (the beginning

Drawing Freeform Shapes

point and end point meet to form an object). A closed shape made up of
straight lines is called a polygon.
To draw a shape (open or closed) consisting of straight lines, click and release
the mouse button at each vertex in the shape. A vertex is the point at which
you click and release the mouse button while drawing a freeform shape. To
draw freehand shapes, drag the freeform tool and then double-click where
you want the shape to end. The Freeform tool remains active until you complete the shape you're drawing by double-clicking or by pressing return.
To create a closed object, click near the beginning point of the shape.
PowerPoint automatically connects the beginning and end points to create
an object.
To draw an open or closed shape consisting of straight lines, follow these
steps:
1. Click the Freeform tool in the Drawing toolbar.

2. Place the mouse pointer at the point where you want to begin drawing.
The mouse pointer changes to a crosshair.
3. Click the mouse button, and then release it.
4. Place the crosshair where you want the first line to end and the second
line to begin, and then click and release the mouse button.
5. Repeat step 4, clicking and releasing the mouse button at each vertex.
6. To make the object an open shape, double-click after you draw the last

line. To close the shape, place the mouse pointer near the beginning
point, and then click the mouse button. PowerPoint draws a straight
line connecting the beginning and end points.
To draw an open or closed freehand shape, follow these steps:
1. Click the Freeform tool in the Drawing toolbar.

2. Place the mouse pointer at the point where you want to begin drawing.
The mouse pointer changes to a cross hair.
3. Click and drag the mouse in any direction, drawing the shape you
want.
4. To create an open object, double-click when you finish drawing, or
press return. To create a closed shape, double-click near the point where
you began drawing. PowerPoint automatically connects the beginning
and end points.
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As you draw freehand shapes, you can pause at any point by releasing the
mouse button. Before beginning to draw again, place the crosshair where it
was located before you paused, and then click and drag to continue drawing.
To mix straight and curved lines in the same drawing, alternate between
clicking a vertex and dragging the mouse.

Editing Freeform Shapes

Tip
To work with small
or detailed objects
easily, use the
Zoom Control
button on the
tool bar or choose
the View Zoom
command to zoom
in on an object.

Fig. 23.7
The control
handles at the
bottom of this
Freeform object
work together to
form a curve.

When you click a freeform shape to select it, it displays the usual eight resize
handles. You can drag any of the resize handles to make a freeform shape
larger or smaller. Freeform shapes, unlike other shapes, also contain control
handles. Control handles enable you to modify th e freeform shape in addition
to simply resizing it.
A control handle appears at each vertex of a freeform shape or polygon.
Control handles also appear along the areas where you drag the mouse while
drawing a freeform shape. The faster you drag, the fewer the control handles
that appear; the slower you drag, the more the control handles that appear. If
you look closely at the control handles of a freeform shape, you can see that
the curves of a shape created by dragging the mouse are not actually curves;
they are a series of short lines connected to one another (see fig. 23. 7).

Editing Freeform Shapes
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You can adjust the shape of a freeform object by dragging an existing control
handle to a new position, deleting a control handle, or adding a control
handle. Curves that you draw slowly often contain more control handles
than are necessary; deleting some handles can make working with the curve
easier. If an object contains straight lines that you want to convert to gentle
curves, add a few control handles so you can curve the line. In figure 23 .8,
the bottom edge of the freeform shape shown has changed from an upward
curve to a new shape.

IV

Fig. 23.8
You can move,
add, and delete
control handles to
change the shape
of a Freeform
object.

To display an object's control handles, double-click the object. When you
place the mouse pointer on a control handle, the pointer changes to a
crosshair. To move a control handle, position the crosshair over the control
handle, and then click and drag the handle in any direction. To add a control
handle, press and hold down the shift and option keys, and then click the
original line where you want to add the handle. To delete a control handle,
press and hold down the option key, and then click the handle.
Note
When the Draw Snap to Grid command is turned on, control handles snap into place
when you move them. To temporarily tum off the grid so you can move control
handles mor-e precisely, hold down the aft key as you move a control handle.
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From Here ...
In this chapter, you learned how to create all types of shapes and objects with
PowerPoint's drawing tools. Refer to the following chapters for more information on working with objects:
• Chapter 22, "Working with Objects," describes how to manipulate objects by moving, copying, deleting, resizing, grouping, and ungrouping
them.
• Chapter 24, "Enhancing a Presentation," describes how to work with
templates, enhance text, and add color, borders, shadows, and other
enhancements to objects.

Chapter 24

by T.

You can do many things to enhance the appearance of slides in a presentation, whether the slides contain text objects, drawn objects, or inserted
objects. When you take the time to add special touches to objects, your slides
are easier to read and help hold the attention of your audience. Audiences
appreciate interesting slides! A good presentation should have slides with
color, patterns, shadows, and attractive fonts.
In this chapter, you learn the many different techniques you can use to give
your sUdes a powerful presence. You don't have to be a graphic arts expert;
even the simplest touches can make a world of difference in the appearance of
a presentation.
In this chapter, you learn to
• Work with templates
• Enhance text by changing the font, style, and color
• Work with line spacing, bullets, and alignment of text
• Work with colors, fills, and line styles of objects
• Add patterns, shading, borders, and shadows to objects
• Work with color schemes
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Working with Templates
In Chapter 19, "Getting Acquain ted with PowerPoint," you learned that templates are saved presentation files for which special graphic elements, colors,
font sizes, font styles, slide backgrounds, and other special effects have been
defined. PowerPoint includes templates specially designed for black-andwh ite overheads, color overheads, and on-screen slide shows.
Using a template is by fa r the q uickest and easiest way to create professionallooking presentations, because it takes the guesswork and experimentation
out of designing a presentation. PowerPoint templates are designed by
graphic arts professionals who understand the elements required to achieve a
certain effect and to convey a particular attitude. In Chapter 19, you saw
examples of the fiesta (FIESTAC.PPT), world (WORLDC.PPT), and embossed
(EMBOSSDC.PPT) templates for colo r overheads. Figure 24.1 shows the music
(MUSICC.PPT) template.
Fig. 24.1
Use this template
to convey a
musical theme.

In the music template, a musical staff appears across the top of each slide.
The notes in the staff are shadowed. Title text is displayed in blue in the
44-point Helvetica fo nt; subtitle text is displayed in black in the 32-point
Helvetica font. The template's color scheme is shown in the Slide Color
Scheme dialog box (see fig. 24.2), displayed by selecting Slide Color Scheme
from the Format menu.

Working with Templates

Fig. 24.2
The Slide Color
Scheme dialog
box displays all
colors used in a
template.

Slide Color Scheme
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The MUSICC.PPT template's color scheme is predominately blue, with a
light-blue slide background, medium-blue fill for objects, dark-blue title text,
and midnight-blue shadows. Red, orange, and white are used as accent colors,
and black is used for text and lines. The sample on the left side of the dialog
box shows how each of these colors might look on a slide.

Choosing a Template
You can specify a template when you create a new presentation. Select the
Template option in the PowerPoint dialog box that appears automatically
when you start the program.
To change the template of the active presentation, follow these steps:

~

See "Creating a
Presentation
Using a
Template,"

p.436

1. Click the Template button in the bottom right corner of the PowerPoint

window, or choose Presentation Template from the Format menu.
A standard open dialog box appears (see fig. 24.3).
Preulow

Iell On Screen I} 35mm Slides ... I
0 • azures.ppl - Azure
0
~ banners.ppt - Danner
~ beuels.ppt - Deuel
~ blo cks.ppt - Bl ock
~ blstrtps.ppt - Blue Stripes
~ bludiogs.ppt - Blue Ologonels
~ blu eboHs. ppt - Blue BoHes
Q'l bluegrns.ppl - Bl ue Gree n
l;[ibrknbors. ppt- Broken Bars ~

2. Select a template; for example, azures . ppt.

=Indeed
( find Flle ...

l

llelp
(

(jecl

(

Cancel

J

R

Apply

1

Fig. 24.3
Select a template
in the Presentation Template
dialog box.
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Note
To preview each template, highlight a template in the File Name list, and then
click the up and down arrows in the scroll bar to highlight different templates.
A sample of the highlighted template appears o n the left side of the dialog
box.

Tip
To identify the
template used
in a presentation, choose
Summary Info
from the File
menu. The
template file
name appears
in the Summary Information d ialog
box.
..,.. See "Working
with Color
Schemes,"
p.S17

3. Double-click a template name, click the Apply button, or press return to
select the highlighted template. The dialog box closes, and PowerPoint
applies the new template to the active presentation.

Altering a Template
After you select a template for your presentation, you might want to change
several of its characteristics. You might decide to use a different font and
larger point size for your slide titles or to add a graphic element (such as your
company logo) to the templa te. To make these changes, which affect all slides
in the presentation, change the slide master after you select a template. Likewise, you might want to change the outline master, handout master, and
notes master to make changes that apply to all outline, handout, and notes
pages .
You do not have to display the slide master to change colors defined by a
template. Instead, choose Slide Color Scheme from the Format menu to display the Slide Color Scheme dialog box. Here, you can change individual
colors in the current color scheme or specify a different color scheme for the
current template.
Troubleshooting
How can I use more than one template in a presentation?

Templates apply to all slides in a presentation; you cannot use more than one template in a single presentation. You can, however, change colors, fonts, shadows,
patterns, and other enhancements in individual slides, as described throughout this
chapter.
How can I create a custom template so I don 't have to alter a PowerPoint template each
time I create a new presentation?

First choose the PowerPoint template on which you want to base your custom template. Then save the file as a Stationary Pad (by choosing File, Save, and opening the
pull-down menu in the Save dialog box). After closing the fi le, you can use it as a
template on your next presentation.

Enhancing Text
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If I make changes to the slide master in my presentation, how is the PowerPoint template
I'm using affected?
Any changes you make to a presentation master affect the current p resentation only;
the PowerPoint template file you are using is not altered.

Enhancing Text
When you enter text in a slide, the font, style (regular, bold, or italic), size,
color, and special effects (underline, shadow, and so on) of the text conform
to the settings specified in the current template. Earlier in this chapter, you
learned that the MUSICC.PPT template uses the 44-point Helvetica font in
blue for slide titles and the 32-point Helvetica font in black for slide text. In
both cases, the font style is regular (no bold or italic), and no special effects
are added. If you want to use a different font, style, size, color, or effect, you
can change these settings (collectively called font settings) fo r all slides in a
presentation by altering the slide master, or you can change font settings
only for selected text objects.

Choosing a Font, Style, and Color for Text
To change font settings, select the text you want to change, and then choose
Font from the Format menu to display the Font dialog box (see fig. 24.4). The
Font, Font Style, Size, and Color settings are self-explanatory; these options
appear in most word processing, spreadsheet, and graphics programs. The
Effects box, however, contains some options with which you might not be
familiar.
Fig. 24.4
In the Font dialog
box, you can select
a font, style, size,
color, and special
o u•rlloo
0 0•111•
0]5Qf•Mn

effects.
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In the Effects area, the Shadow option adds a shadow at the bottom and the
right side of each character. The Emboss option gives the text the appearance
of raised letters by using a light color for the characters and a faint shadow
behind them. Figure 24.5 shows an example of each option.
Fig. 24.5
The Shadow and
Emboss options
draw attention to
the text and make
it stand out.
Shadowed
text

Embossed
text

The Subscript option drops a selected character slightly below the normal line
level, as in H20. The Superscript option raises a selected character, as in 105•
When you choose either of these options, you can specify the Offset percentage-that is, the percentage by which characters are dropped or raised.
There are defaults for each presentation that you can set. To change font
settings, follow these steps:
1. To change font settings in the slide master, press and hold down the

shift key, and then click the Slide Master button in the bottom left
corner of the PowerPoint window. To change font settings for selected
text objects, select all objects you want to change.
2. Choose Font fro m the Format menu. The Font dialog box appears

(refer to fig. 24.4).
3. Choose settings in the Font, Font Style, Size, Color, and Effects boxes.
If you choose the Subscript or Superscript setting, specify a percentage
in the Offset box or use the default setting.
4. Click OK to apply the changes.

Enhanci ng Text
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You also can change specific format settings by clicking the following buttons
in the Formatting toolbar.
Button

lttim Nw Rolll8n
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Button Name

Description

Font

Changes the font of
selected text

Font Size

Changes the font size of
selected text

Increase Font Size

Increases the font size

Decrease Font Size

Decreases the font size
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Changing Line and Paragraph Spacing
just as the template defines colors, fonts, and other characteristics for a presentation, the template defines the line spacing for text in a text object.
PowerPoint enables you to set the spacing between lines, as well as the
amount of space before and after paragraphs. In most templates, the default
spacing is 1 line, the space after paragraphs is 0, and the space before paragraphs is 0.2 or 0.
You might want to change line or paragraph spacing, depending on the
content of your slides. If a slide contains only four bullets, for example,
you might want to increase the line spacing so that the bullets fill the slide.
If your slide contains several paragraphs of text, you might want to set the
space before paragraphs to 0.2 so that each paragraph is distinctly separate
from the one before it.
To change line and paragraph spacing, choose Line Spacing from the Format
menu to display the Line Spacing dialog box (see fig. 24.6). The Line Spacing,
Before Paragraph, and After Paragraph options use lines as a un it of measure.
If you prefer to use points rather than lines, you can choose the Points option
in each of the pop-up menus. (One point equals 1/72 inch.)
Fig. 24.6
Use the Line

Spacing dialog box
to set line and
paragraph spacing.
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Tip
When setting
paragraph
spacing, specify
a setting for
Before Paragraph or After
Paragraph. If
you specify two
lines for both
Before Paragraph and After
Paragraph, for
example, the
net effect is
four lines.

To set line or paragraph spacing, follow these steps:

1. Select the text for which you want to adjust line or paragraph spacing.
2. Choose Line Spacing from the Format m enu. PowerPoint displays the
Line Spacing dialog box.

3. In the Line Spacing, Before Paragraph, and After Paragraph boxes, enter
the number of lines or points to be used. If you prefer to use points
rather than lines, be sure to choose the Points setting in each pop-up
menu.

4. Click OK or press return. PowerPoint returns to your slide and reformats
the selected text.

Aligning Text
Alig11ment generally refers to the horizontal positioning of text in a text object. In presentation slides, text generally is left-aligned (for paragraphs or
bullets) or centered (for titles). However, you also can justify or right-align
text (see fig. 24.7). Alignment options appear in a cascading menu when you
choose Alignment from the Format menu.
Left alignment aligns text along the left edge of a text object. Right alignment

Fig. 24.7
The text in the
clip art picture is
right-aligned.
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aligns text along the right edge. The Center alignment option aligns text at
the center point of the text object so that an equal n umber of characters
appear to the right and left of the center point. The justify option aligns text
along both the right and left edges so that the characters in a line cover the
entire width of a text object.
Because alignment involves horizontal positioning of text at margins or at
the center point, alignment affects entire paragraphs. In other words, you
cannot align a single word or line in a paragraph.
You don't have to select any text to align a single paragraph; PowerPoint
aligns the entire paragraph in which the insertion point is located. To align
several paragraphs, select a portion of text in each paragraph and then choose
an alignmen t style.
Note
Left Alignment and Center Alignment buttons appear in PowerPoint's Formatting
toolbar. You can add Right Alignment and justify buttons to the Formatting toolbar
by customizing it.

Tip
Individual
bullet items are
separate paragraphs. To
realign a set of
bullets, select a
portio n of text
in each bullet
item.

To change the alignment of text, follow these steps:
1. Select the object that contains the text you want to align.
2 . Place the insertion point anywhere in the paragraph you want to align,

or select a portion of each paragraph you want to align.
3. Choose Alignment from the Format menu. The Alignmen t cascading
menu appears.
4 . Choose Left, Right, Center, or justify. PowerPoint immediately realigns

the current paragraph or selected paragraphs.

Working with Colors and Line Styles
All objects that you draw in PowerPoint (except lines) have a fill color, a line,
and a line style. The fill color is the color inside an object; the line is the frame
that defines the bounda ries of an object; and the line style defines the width
or style of the object's fra me.

~

See "Microsoft
Applicatio ns
Toolbars," p. 24
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For any given object, you can turn off the fill color and the line color. Turning both options off makes an object invisible (unless it contains text), so this
practice is not as common as turning off one option or the other. In most
templates, for example, the line that frames a text object is turned off, because text generally looks better in the slide without a frame. For other objects (such as shapes that you create with the drawing tools), the object's
frame usually is visible, and the object has a fill color.
In most templates, an object's line style is a narrow solid line. You can choose
any of five wider line styles or any of four double or triple lines. In addition,
you can change a solid line to a dashed, dotted, or mixed line by choosing
one of the four dash ed-line options. If an object is a straight line or arc rather
than a shape, you can add arrowheads to either end or to both ends of the
line or arc.

Choosing Fill and Line Colors and Line Styles
To set line, fill, and line style options, use the Colors and Lines dialog box
(see fig. 24.8). You display this dialog box by choosing Colors and Lines from
the Format menu.
Fig. 24.8
Use the Colors and
Lines dialog box
to define an
object's color and
frame style.
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To change an object's fill color, follow these steps:
1. Select the object.
2. Choose Colors and Lines from the Format menu. The Colors and Lines

dialog box appears, displaying the current fill color in the Fill box.
3. Click the arrow to open the Fill pop-up menu, which displays the
options shown in figure 24.9.
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Colors and Lines
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No fill
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Fig. 24.9
The Fill pop-up
menu displays fill
options.
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4. Do one of the following:

• Select the No Fill option to remove the fill color from the object.
• Select one of the colors (derived from the current template).
• Select the Other Color option, which displays the Other Color
dialog box (see fig. 24.10). Select a color in the Color Palette, and
then click OK.
Fig. 24.10
The Oth er Color
dialog box
displays a color
palette.

5. Click OK in the Colors and Lines dialog box. PowerPoint returns to
your slide and changes the fill color of the selected object.
6. Click any blank area of the screen to deselect the o bject.

To change an object's line color or line style, or to add dashed lines or arrowheads, follow these steps:
1. Select the object.

2. Choose Colors and Lines from the Format menu. The Colors and Lines
dialog box appears, displaying the current line color in the Line box.
3. Click the arrow to open the Line pop-up menu, which displays the
options shown in figure 24.11.
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Fig. 24.11
The Line pop-up
menu displays
line color options.

rm:

U•Sijloo

--

Pet11ro
Otbtr C.tor-

--

4 . Do one of the following:

• Select the No Line option to remove the object's line color.
• Select one of the colors (derived from the current template).
• Select the Other Color option, which displays the Other Color
dialog box (refer to fig. 24.10). Select a color in the Color Palette,
and then click OK.
5. To select a different line style, highlight a style in the Line Styles list.
6. To use a dashed line, highlight a style in the Dashed Lines list.

7 . To add arrowheads to a line or arc, select an option in the Arrowheads

list.
8. Click OK in the Colors and Lines dialog box. PowerPoint returns to

your slide and changes the line color and style for the selected object.
9. Click any blank area of the screen to deselect the object.

A quick way to change an object's fill, line color, line style, dashed lines, or
arrowheads is to use the respective tools in the Drawing+ toolbar. Select the
object, and then click any of the tools shown in the following table. In each
case, a pop-up menu appears, enabling you to select a new color or style.
Tool

~
~

El
~
~

Tool Name
Fill Colo r

Line Color

Line Style
Dashed Line
Arrowheads
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To turn fill or line options on or off, click either of the following tools in the
Drawing toolbar:
Tool

Tool Name

~

Fill On/Off

[21

Line On/Off
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Using Shading and Patterns
In a slide presentation, filled objects usually are more interesting than plain
ones. Two effective va riations for filled objects are the shaded color and the
two-color pattern.
A shaded color is a dark-to-light or light-to-dark variation of an object's color.
This variation can run vertically, horizontally, diagonally, from the center
outward, or from any corner. You also can adjust the intensity of the color.
To shade an object, choose Format Colors and Lines from the Format menu.
The Colors and Lines dialog box appears, displaying the current fiU color in
the Fill box. Select the Shaded option to display the Shaded Fill dialog box
(see fig. 24.12).

OK'
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To shade an object, follow these steps:
1. Select the object you want to shade.
2. Choose Colors and Lines from the Format menu. The Colors and Lines

dialog box appears. The current fill color is shown in the Fill box.
3 . Click to open the Fill pop-up menu, which displays the options shown

in figure 24.9.
4 . Select the Shaded option . The Shaded Fill dialog box appears (refer to

fig. 24.12).

Fig. 24.12
The Shaded Fill
dialog box displays
many shade
variations.
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5. Select an option in the Shade Styles list. The Variants box reflects the
choice you make.

6. In the Variants box, highlight one variant.
7. To adjust the brightness, drag the scroll box in the Dark/Light scroll
bar.
8. Use the Color option in the Shaded Fill dialog box if you want to
change the fill color.
9. If you want, choose the Preview button to preview the shade in the
selected object.
10. Click OK in the Shaded Fill dialog box. You return to the Colors and

Lines dialog box.
11. Click OK to close the dialog box. PowerPoint applies the shaded color

to the selected object.
An alternative to shading an object is patterning. A pattern is a design (such as
lines, dots, bricks, or checkerboard squares) that contains two colors: a foreground color and a background color.
To add a pattern to a filled object, follow these steps:
1. Select the object to which you want to add a pattern.
2 . Choose Colors and Lines from the Format menu. The Colors and Lines

dialog box appears.
3. Click to open the Fill pop-up menu.
4. Select the Pattern option. The Pattern Fill dialog box appears

(see fig. 24.13).
Fig. 24.13
Select a pattern
and colors in the
Pattern Fill dialog
box.
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5. In the Pattern box, highlight the pattern you want to use.

6. In the Foreground and Background pop-up menus, select the colors for
your pattern.
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7. If you want, choose the Preview button to preview the pattern in the

selected object.
Note
When you click the Preview button in the Pattern Fill dialog box, move the
Colors and Lines and Pattern Fill dialog boxes if they obscure the selected
object.

8 . Click OK to close the Pattern Fill dialog box. You return to the Colors

and Lines dialog box.
9. Click OK to close the dialog box. PowerPoint applies the two-color

pattern to the selected object.
10. Click any blank area of the screen to deselect the object.

Adding Shadows to Objects
A final way to enhance objects is to add shadows. You learned earlier in this
chapter that shadowed text has shadows at the bottom and the right side of
each character. When you shadow an object, you have flexibility because you
can specify the direction of the shadow and the degree of offset from the
original object. For example, you might want the shadow to project up and
to the left, as shown in figure 24.14.
Fig. 24.14
This object's
shadow is offset up
and to the left.

A Star with Depth
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To apply a shadow to an object, choose Shadow from the Format menu to
display the Shadow dialog box (see fig. 24.15). The shadow color that appears
in the Color box is determined by the current template. To use a different
shadow color, select an option in the pop-up menu.

Fig. 24.15
Use the Shadow
dialog box to
specify shadow
direction and
offset.
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To determine the shadow's offset, select Up or Down for the horizontal offset,
or Left or Right for the vertical offset. You can combine the horizontal and
vertical offsets by choosing a combination of these options. The box to the
right of each pair of offset options enables you to set the degree of offset in
points. The default setting for each offset pair is 6 points; you can specify any
number from 0 to 120. Depending on the shape of the object you are shadowing, you may want to choose the Preview button to determine the best
offset.
To apply a shadow to an object, follow these steps:
1. Select the object.
2. Choose Shadow from the Format menu. The Shadow dialog box

appears.
3. To change the color of the shadow, select a color in the Color pop-up

menu.
4. To set a horizontal shadow offset, select the Up or Down option, and
then enter the number of points in the Points box.
5. To set a vertical shadow offset, select the Left or Right option, and then

enter the number of points in the Points box.
6. If you want, choose the Preview button to preview the shadow on the

selected object.
7. Click OK or press return to apply the shadow to the selected object.
8. Click any blank area of the screen to deselect the object.

Working with Color Schemes

You can apply a shadow to an object quickly by clicking the Shadow Color
tool in the Drawing+ toolbar. Select an object, and then click the Shadow
Color tool. A pop-up menu appears, displaying eight color options. Select a
color in the pop-up menu, or select the Other Color option to choose a different color. PowerPoint automatically applies the shadow to the selected object. Be aware that this method does not allow you to specify a shadow's
offset.
To turn a shadow on or off quickly, you can click the Shadow On/Off tool in
the Drawing toolbar.

I[Dl

Copying Attributes from One Object to Another
Suppose that you have taken care to apply a special color, shade or pattern,
line width, line style, and shadow to a particular object. You can apply all
these attributes to another object quickly by clicking the Format Painter tool
in the Formatting toolbar. When you click this tool after selecting an object,
PowerPoint "memorizes" all the attributes of the selected object. The mouse
pointer changes to a paintbrush, and the next object you click immediately
takes on the same attributes. This process is called picking up and applying an
object's style to another object.
The Format Painter tool is equivalent to Pick Up Style and Apply Style in the
Format menu. Using the menu commands requires two steps, whereas using
the Format Painter tool requires only one step.
To use the menu commands to apply attributes from one object to another,
follow these steps:
1. Select the object from which you want to copy attributes.

2. Choose Pick Up Object Style from the Format menu.
3. Select the object to which you want to copy the attributes.
4. Choose Apply Style from the Format menu.

Working with Color Schemes
A color scheme is a set of colors that are chosen because they complement
one another. As you learned earlier in this chapter, every template has a
predefined color scheme that consists of specific colors for the slide background, title text, text and lines, fills, shadows, and accent colors. Even the
DEFAULT.PPT template, which PowerPoint calls a "blank" presentation, has a

~

517

518

Chapter 24-Enhancing a Presentation
predefined color scheme. You can use the colors defined in a template,
choose a different color sch eme, or change individual colors in a color
scheme.

Changing Individual Colors in a Color Scheme
To change individual colors in a color scheme, use the Slide Color Scheme
dialog box (see fig. 24.16). You display this dialog box by choosing Slide
Color Scheme from the Format menu. The dialog box displays a sample of
the background, text and lines, title text, shadows, fills, and accent colors
defined by the current template.
Fig. 24.16
The Slide Color
Scheme dialog box
displays every
color in the
current color
scheme.

Slide Color Scheme
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You can change an individual color in the current color scheme and apply
the new color to the current slide or to all of the slides in the presentation by
following these steps:
1. Choose Slide Color Scheme from the Format menu. The Slide Color

Scheme dialog box appears (refer to fig. 24.16).
2. In the Change Scheme Colors area, highlight the color you want to

change.
3. Click the Change Color button. PowerPoint displays a dialog box (see

fig. 24.17). The title of the dialog box reflects the color you are changing, such as Background Color or Text and Line Color.
4. In the Color Palette area, highlight the color you want to use, and then

click OK. The Slide Color Scheme dialog box returns.
5. Repeat steps 2 and 3 to change other colors in the current color scheme.
6. In the Slide Color Scheme dialog box, click the Apply button to apply

the change to the current slide. Choose the Apply to All button to apply
the new color to all slides in the current presentation.
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Fig. 24.17
Select a new color
in the palette.

Choosing a Different Color Scheme
Suppose that a template contains all t he graphic elements you want to use,
but the color scheme is not appropriate for the topic you are presenting.
Rather than change individual colors in the template's color scheme, you can
choose a different color scheme for the current template. When you choose a
new color scheme, you are choosing a new set of predefined colors. As always, you can change individual colors in the scheme later if you choose.
To choose a new color scheme for the current template, use the Choose
Scheme dialog box, shown in figure 24.1 8. To display this dialog box, choose
Slide Color Scheme from the Format menu, and then select the Choose
Scheme button. When the dialog box opens, colors appear in the Background
Color list only; the Text & Line Color and Other Scheme Colors lists are
blank. The dialog box "fills in" as you make your choices-that is, after you
select a background color, color choices appear in the Text & Line Color list.
After you select a Text & Line Color option, color choices appear in the Other
Scheme Colors list.
Choose Scheme
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To choose a color scheme, follow these steps:
1 . Choose Slide Color Scheme from the Format menu. PowerPoint displays
the Slide Color Scheme dialog box (refer to fig. 24.16).

Fig. 24.18
The Choose
Scheme dialog box
displays color
scheme options.
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2. Choose the Choose Scheme button. PowerPoint displays the Choose
Scheme dialog box (see fig. 24.18).
3. Select a color in the Background Color list. Coordinated colors appear
in the Text & Line Color list. Be sure to use the scroll bar to view all
possible colors.
Tip
At any time,
you can choose
a new color
scheme by
repeating steps
3, 4, and 5.

4. Select a color in the Text & Line Color list. Coordinated colors appear in
the Other Scheme Colors box.
5. Select a set of colors in the Other Scheme Colors box.
6. Click OK to close the Choose Scheme dialog box. The new colors appear
in the Slide Color Scheme dialog box.
7. Click the Apply button to apply the new color scheme to the current
slide. Click the Apply to All button to apply the new color scheme to all
slides in the current presentation.

Note
To create a custom color scheme, follow the preceding steps, selecting the background color, text color, and line color you want to use. When options appear in the
Other Scheme Colors box, select the one that most closely matches what you want
in your custom color scheme. Then return to the Slide Color Scheme dialog box and
change individual colors, if necessary.

From Here...
This chapter discussed the variety of techniques you can use to enhance objects in a PowerPoint presentation. Refer to the following chapters for more
information about working with objects:
• Chapter 23, "Drawing Shapes, Curves, and Lines," describes how to use
PowerPoint's drawing tools to add drawn objects to your slides.
• Chapter 25, "Creating Charts," teaches you how to use Microsoft Graph
to create, format, and enhance charts that you can insert into your
PowerPoint slides.

Chapter 25

Creatin
by

If you have worked with spreadsheet programs such as Microsoft Excel, you

know that you can create graphical representations of the data you enter in a
spreadsheet. A graph, or chart, is an effective tool for presenting data in a clear
way that provides instant visual impact. In other words, charts are easier to
understand at a glance than are rows and columns of data. Because of the
high impact that charts provide-especially in a presentation-PowerPoint
includes a charting program caiJed Microsoft Graph so that you can create
charts in PowerPoint.
In this chapter, you learn to
• Start Microsoft Graph
• Enter and edit data in the datasheet window
• Choose a chart type and add chart elements
• Choose colors, patterns, borders, and fonts
• Return to Graph after you exit to edit a chart

Starting Microsoft Graph
Microsoft Graph is a charting application, separate from PowerPoint, that is
accessible from within PowerPoint. When you start Graph, a sample chart
appears in the current slide of your presentation, and a datasheet appears on
top of the chart. The chart appears in the slide as an object; the datasheet
appears in a separate window with its own title bar. The datasheet and chart
are displayed on-screen simultaneously and are dependent on each other.
When you change data in the datasheet, Graph automatically updates the
chart to reflect the new data.

IV
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Note
In PowerPoint and Microsoft Graph, the terms chart and graph are used
interchangeably.

Tip
If the datasheet
window obscures the
graph, drag the
window to a
different location. You also
can resize the
datasheet
window.

Fig. 25.1
The New Slide
dialog box
includes three
layouts that
contain graph
placeholders.

Before accessing Microsoft Graph, you must create a new PowerPoint presentation or open an existing presentation. After opening the presentation, display the slide in which you want to insert a chart, or add a new slide to the
presentation. The slide should either be blank or contain a placeholder for a
chart.
As you learned in Chapter 20, "Creating, Saving, and Opening Presentations," whenever you add a new slide to a presentation, PowerPoint automatically displays the New Slide dialog box, in which you select a slide layout
(see fig. 25.1). Three of the 18 available slide layouts include placeholders for
graphs (indicated by pictures of bar graphs) and a layout-description area in
the bottom right corner of the dialog box. Select a layout that includes a
graph placeholder.
New Slide
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Note
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If you access Microsoft Graph from a slide that contains objects or placeholders other
than for a graph, the graph you create will appear on top of other objects (such as
text or drawn objects). To avoid obscuring other objects with a graph, select a blank
slide layout or a slide layout that contains a graph placeholder before you access
Microsoft Graph.

When you select one of the three slide layouts shown in figure 25.1,
PowerPoint displays a slide similar to the one shown in figure 25.2. A dotted
frame defines the boundaries of the graph placeholder. Inside the placeholder
is a small picture of a bar graph with the instruction: Double click to add

Tip
If the datasheet
window obstructs the
chart, you
can drag the
datash eet
window to a
more convenient location.

graph.

Fig. 25.2
Graph placehold·
ers contain a small
picture of a bar
graph .
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!
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•

Double click to add gtaph

Starting Microsoft Graph is as easy as the instructions indicate: simply
double-click the graph placeholder. After a few seconds, a sample bar chart
appears in the graph placeholder in your slide. The datasheet appears on top
of the chart in a separate window (see fig. 25.3). The sample data in the
datasheet is used to create the sample bar chart.
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To access Microsoft Graph when your slide is blank or does not contain a
graph placeholder, simply click the Insert Graph button in the Standard
toolbar, or choose Microsoft Graph from the Insert menu. The sample chart
and datasheet window appear.
Fig. 25.3
Microsoft Graph
displays a sample
chart in the slide
and sample data
in the datasheet
window.

Chart
legend

Category labels

Troubleshooting
I don't want to use any of the Autolayouts that include graphs. How can I add a graph to
my slide and arrange other objects on the slide myself?

Choose the blank Autolayout for your slide. When you create a chart using Microsoft
Graph, the chart is centered in the middle of the slide. You can resize the chart object, move it, and add other objects to the slide where you want them.
I closed the datasheet window in Microsoft Graph before I finish ed using it. Haw can I
redisplay it?

In Microsoft Graph, choose Datasheet from the View menu, or click the View
Datasheet button in the Graph toolbar. (This button is indicated in table 25.1.)

Using Microsoft Graph Menus and Toolbars

Using Microsoft Graph Menus and
Tool bars
Notice in figure 25.3 that the Standard PowerPoint toolbar is replaced by the
Graph toolbar when Microsoft Graph is active. The menus are identical to
those in PowerPoint, except that Graph also includes a Data menu. The
commands in each menu, however, are specific to graphs rather than to
PowerPoint slides.
The buttons in Graph's Standard toolbar greatly simplify working with charts.
For example, you can change the color or pattern of a set of bars in a bar
chart by clicking the Color or Pattern button. This chapter emphasizes the
use of these buttons, and it also explains menu-command techniques. Table
25.1 explains the functions of the buttons in the Graph Standard toolbar.

Table 25.1

Microsoft Graph's Standard Toolbar

Button

Button Name

Purpose

mmil1

Import Data

Imports data from another application into
the Graph datasheet

Import Chart

Imports a chart from an Excel worksheet

View Datasheet

Displays the datasheet for the current chart

Cut

Cuts selected objects

Copy

Copies selected objects to the Clipboard

Paste

Inserts the contents of the Clipboard

Undo

Reverses the last action taken

By Row

Causes Graph to use rows of data as data
series

By Column

Causes Graph to use columns of data as
data series

Chart Type

Displays a pop-up list of chart types

Vertical Gridlines

Inserts vertical grid lines into the current
chart

~

~
~

(continues)
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Table 25.1

Continued

Button

Button Name

Purpose

II

Horizontal Gridlines

Inserts horizontal grid lines into the
current chart

II

Legend

Turns the chart legend on or off

~

Text Box

Inserts a new text box into a chart

~

Drawing

Displays or hides a Drawing tool bar for
drawing objects in a chart

Color

Displays a pop-up fill-color palette

Pattern

Displays a pop-up color and pattern
palette

~

6

Working with the Datasheet
A Microsoft Graph datasheet, made up of rows and columns, is similar to a
Microsoft Excel worksheet. Rows are numbered 1 through 3,999; columns are
labeled A, B, C, AA, AB, AC, and so on, through column EWU. The intersection of each row and column is a cell, in which you enter text or a number.
Unlike an Excel worksheet, however, a Microsoft Graph datasheet cannot use
formulas.

Understanding How Data Is Plotted
In figure 25.3, the sample datasheet shows three rows, or series, of data: East,

West, and North. A data series contains individual data points that are plotted
along the y-axis (vertical axis) of a chart as columns, lines, or pie slices. From
the first column of the datasheet, the row headings-which identify each
data series-are translated to the chart's legend. The column headings in the
first row of the datasheet (the row above row 1) represent categories of data.
These column headings are translated to the x-axis (horizontal axis) of the
chart as category labels. Thus, categories appear as groups in a chart.

Arranging Data by Rows or Columns
By default, Microsoft Graph assumes that data series appear in rows and that
categories appear in columns, so Graph plots all charts accordingly. In figure
25.3, this series-in-rows arrangement emphasizes time spans: 1st Qtr, 2nd
Qtr, 3rd Qtr, and 4th Qtr.

Working with the Datasheet
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If you prefer, you can reverse the data series arrangement so that Graph uses

columns as data series and rows as categories of data. Simply click the By
Rows or By Columns button in the toolbar. In figure 25.4, the series-incolumns arrangement emphasizes regions-East, West, and North-rather
than time spans. The arrangement you use depends on personal preference
and on the data you want to emphasize. Unless otherwise indicated, the examples in this chapter use the series-in-rows arrangement.
By glancing at the datasheet, you can tell whether rows or columns are represented as data series. When rows are plotted as the data series, miniature
graphic representations of the chart type (such as bars or lines) appear next to
the row numbers. When columns are plotted as the data series, the graphics
appear next to the column labels (A, B, C, and so on). You can see examples
of these miniature graphics in figures 25.3 and 25.4. The graphics are colorcoded to match the colors of each data series in the chart (bars, lines, pie
slices, and so on).
Fig. 25.4
Switching from
series in rows to
series in columns
changes the way a
chart is plotted.

These indicate that data
series appear in columns

To specify the arrangement of data in a chart, you can also choose Series in
Rows or Series in Columns from the Data menu. You can switch back and
forth between the two arrangements to decide which one represents your
data most effectively.
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Entering Data
When you're ready to enter data in the datasheet, simply type over the
existing sample data. You might replace East, west, and North with Sales,
Service, and Training, or atr 1, atr 2, atr 3, and atr 4 with January,
February, March, and April. You can add more data to the datasheet by
filling in blank rows and columns.
To highlight a cell in the datasheet, use the arrow keys or click a cell. The
active, or highlighted, cell is outlined with a bold border. Overtype mode always is active in the datasheet, so any entry you type in a cell automatically
replaces the current contents of a cell. To complete an entry, press return or
press any of the arrow keys to move to another cell.

Editing Data
Editing refers to changes that you make in data after it is entered in the
datasheet. You change data in a datasheet the same way you do in other
spreadsheet programs. Editing includes changing individual entries; cutting,
moving, and copying entries; and inserting and deleting rows and columns.
Before you can edit cells, however, you must know how to select them.

Selecting Cells, Rows, and Columns
You already know that to select a single cell, you use the arrow keys or click a
cell. But as you enter and edit data in the datasheet, you may want to work
with a group of cells rather than just one. You might want to move a group
of cells to a new location, for example. In the datasheet, you can select a
range of cells, entire rows, or entire columns.
A range of cells is any rectangular group of cells. To select a range, click the
cell in the top left corner of the range and drag the mouse to the cell in the
bottom right comer of the range. The entire range is highlighted.
In the datasheet, selecting an entire row or column is as easy as clicking the
row number or column label. To select all cells in row 3, for example, click
the row number; to select all cells in column D, click the column label. You
also can select multiple rows or columns by dragging the mouse across row
numbers and column labels. To select rows 1, 2, and 3, for example, click and
drag the mouse across the row numbers 1, 2, and 3. All cells in each row are
highlighted. You also can press and hold down the shift key as you highlight
cells with the arrow keys.

Editing Data
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To cancel any selection, whether you have selected a range of cells or a group
of columns or rows, press esc or click any single cell.

Editing an Entry
Earlier in this chapter, you learned that to enter new data in a datasheet, you
actually change the sample data Microsoft Graph provides by typing over it.
Overtyping, however, is not the only way to change data in a cell. When an
entry that you type contains a minor error, you might consider editing the
entry rather than overtyping. Editing enables you to change only selected
characters in an entry. If a cell contains a part number such as BXN-231-781S
and you discover that B should be C, you can simply correct the error rather
than retype the entire part number.
To edit an entry, double-click the cell in which it appears. An insertion point
appears in the cell. (If the cell contains a text entry, the insertion point appears after the last character. If the cell contains a number, the insertion
point appears before the first digit.) Use the arrow keys to position the insertion point, then press delete or del to correct an error. Delete deletes characters to the left of the insertion point, and del deletes characters to the right of
the insertion point. New characters that you type appear to the left of the
insertion point. When you finish editing, press return, or press any of the
arrow keys to move to another cell.

Clearing Cells
Clearing refers to removing the contents, format, or both from cells. You
might clear a cell when you realize that you entered the wrong data; you
might choose to clear sample data from a datasheet if you prefer to work with
a blank datasheet.
To clear cells, choose Clear from the Edit menu. This selection has a cascading menu that gives you the option of clearing the contents of a cell, the
format of a cell, or both. Cell contents refers to the data contained in a cell,
such as a number or text character. The format of the cell refers to a variety of
characteristics, such as the font, font size, and color, as well as attributes such
as number format, underlining, strikethrough, subscript, and superscript.
To clear a cell, follow these steps:
1. Select the cell or cells you want to clear.

2. Choose Clear from the Edit menu. A cascading menu appears. Select All
to clear the contents and formats, Contents to clear only the entries, or
Formats to clear only the format assigned to the cell and retain the
contents.

Tip
To remove only
the contents of
a cell and leave
the cell blank,
select the cell
and then press
the del key.
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Inserting and Deleting Rows and Columns
As you enter your own data into the datasheet, you may find it necessary to
insert a new row or column or to delete an existing row or column. Suppose
that in your columns of monthly data, you inadvertently left out March. You
would want to insert a new column between February and April. If you accidentally entered a data series twice, you would want to delete the duplicate
row.
You can insert a single row or column, or multiple rows or columns. Before
inserting rows or columns, however, you must select the correct row or column. Before inserting a single row, select the row below the place where you
want a new row. To insert a row before row 4, for example, select row 4. Before inserting a single column, select the column to the right of the place
where you want the new column. To insert a new column before column D,
select column D.
To insert a single row or column, select the correct row or column and then
choose Cells from the Insert menu.
If you select a single cell rather than an entire row or column, Microsoft

Graph doesn't know what you want to insert, so the Insert dialog box appears. In the dialog box, choose the Entire Row or Entire Column option and
then click OK.
To save you time, Microsoft Graph makes it easy for you to insert several rows
or columns at once. Highlight the number of rows or columns you want to
insert, then choose Cells from the Insert menu. Microsoft Graph automatically inserts the number of rows or columns you highlighted. If you highlight
columns B, C, and D, for example, Graph inserts three new columns beginning at column B (see fig. 25.5).
To remove rows or columns from the datasheet, select the appropriate rows
or columns; then choose Delete from the Edit menu. Notice that the del key
on the keyboard does not have the same function as Delete from the Edit
menu. The delete key clears the content of cells, but the cells themselves
remain part of the datasheet.

Editing Data
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Fig. 25.5

Three new
columns were
inserted a t B, C,

and D.

Cutting, Moving, and Copying Data
Three common editing tasks are cutting, moving, and copying. Cut from the
Edit menu removes the contents of selected cells and places the data in the
Clipboard. (You also can press ;):(+X.) The cells themselves remain intact in
the datasheet. You use the Cut feature when you want to remove data from
the datasheet or to move the selected data within the datasheet.
Note
At first glance, Clear and Cut seem to perform the same function: removing data
from selected cells. However, the two commands are different. Cut moves the data
to the Clipboard, whereas Clear permanently removes the data without storing it
anywhere. Be sure to use Cut if you think you might want to move the data elsewhere in the datasheet.

Follow these steps to cut data from the datasheet:
1 . Select the cell or cells from which you want to remove data.

2. Choose Cut from the Edit menu, or press ~ +X. Th e data is removed

from the worksheet and placed in the Clipboard.
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When you want to move data to a new location in the datasheet, cut the selected
data, and then choose Paste from the Edit menu or press ~+V. The new location
you choose should not contain data; if it does, the data you move overwrites the
existing data.
To move data within the datasheet, follow these steps:
1. Select the cells from which you want to move data.

Tip
When cutting,
moving, or
copying data,
you can restore
the data to its
original location if you
click the Undo
button in the
toolbar, choose
Undo from the
Edit menu, or
press ~+Z
before performing any other
action.

2. Choose Cut from the Edit menu, or press ):(+X. The data is placed in the

Clipboard.
3. Select the first cell in the range to which you want to move the data.
•

4. Choose Paste from the Edit menu or press ~+V.

A quick way to move a selection is to drag it. Select the cell or cells you want to
move, and then point to the border of the selection until the mouse pointer
changes to an arrow. Click and drag the selection to a new location, and then
release the mouse button. If the new location contains data, PowerPoint asks
whether you want to replace the existing data.
Unlike cutting or moving data, copying data allows the original data to remain
intact in the datasheet, and a copy of the data is placed in the Clipboard. After
the data is in the Clipboard, you can paste the data to any other location in the
datasheet. When you move data, the new location should not contain data; if it
does, the original data is overwritten.
To copy data, follow these steps:

•
•

1. In the datasheet, select the cells from which you want to copy data .
2. Choose Copy from the Edit menu or press

~+C.

The data is copied to the

Clipboard.

3 . Select the first cell in the range to which you want to copy the data.
~+V. The data is copied to the
new location in the datasheet and remains intact in the original location.

4. Choose Paste from the Edit menu or press

just as you move a selection by dragging it, you can copy a selection by dragging
it. Select the cell or cells you want to copy, and then point to the border of the
selection until the mouse pointer changes to an arrow. Press and hold down the
option key; a plus sign (+) appears next to the mouse pointer, indicating that you
are copying a selection. Hold down the option key as you click and drag the selection to a new location, and then release the mouse button.
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Caution

IY

When you drag a selection to copy it, PowerPoint overwrites any data in the new
location.

Excluding Rows or Columns
Rather than delete rows or colum ns, sometimes you simply want to exclude
them from a chart. Suppose that you r datasheet contains sales figures for 20
retail departments, but you want to plot the sales performance of only the
firstS departments. To plot this chart, you exclude rows 6 through 20 so that
Graph plots only rows 1 through S.
To exclude rows or columns from a chart, follow these steps:
1 . Select the rows or columns that you want to exclude from a chart.
2 . Choose Exclude Row/Col from the Data menu.

When you exclude cells from a chart, the entries in the cells are grayed, and
the buttons for the row n umbers or column labels become "flat" (lose their
3-D attributes), as shown in figure 25.6. At the same time, the current chart is
updated to reflect the excluded data.
Column D is grayed

Fig. 25.6
Column Dis
excluded from the
current chart.

Chart shows only
Qtr 1, Qtr 2, and
Qtr 3
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To restore excluded cells to a chart, select the appropriate rows or columns,
and then choose Data Include Row/Col. The normal attributes return to the
entries in the cells, the row numbers, and the column label buttons.

Choosing a Chart Type
When you start Microsoft Graph, a three-dimensional column chart is created
from the sample data in the datasheet. A column chart, however, is not the
only type of chart you can create in Microsoft Graph. You also can create the
following types of two-dimensional charts:
• Area
• Bar

• Column
• Line
• Pie
• Doughnut
• Radar
• Scatter
To create charts with depth, you can select any of the following threedimensional chart types:
• Area
• Bar
• Column
• Line
• Pie
• Surface
~

WIIWEiJ

You select a chart type in the Chart Type dialog box. (To display this dialog
box, choose Chart Type from the Format menu.) In the dialog box, choose
either the two-dimensional or three-dimensional option in the Chart Dimension area; the available chart types appear below the Chart Dimension area.
Figure 25.7 displays three-dimensional chart types in the Chart Type dialog
box.

Choosing a Chart Type
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Fig. 25.7
Select a chart type
in this dialog box.
Displays chart subtypes

Help

-D Surf•c•

For most chart types, Microsoft Graph offers at least one or two variations,
or subtypes. If you select the three-dimensional area chart type, for example,
you then can select one of three subtypes of that style. In the first threedimensional area subtype, data series are stacked on top of one another. In
the second subtype, data series are stacked on top of one another, but they
fill the entire chart area, showing how each series contributes to the whole.
In the third subtype, data series are depicted separately. For each subtype you
highlight, the bottom portion of the dialog box displays a sample chart that
uses your data.
To display a chart's subtypes, click the Options button in the Chart Type
dialog box. The Format three-dimensional area Group dialog box appears
(see fig. 25.8).

s ubtvpe

Cencel

( Chert Type ...
Help

0
1st 2nd 3rd
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Fig. 25.8
The Format threedimensional Area
Group dialog box
displays subtypes
and a sample
chart using your
data.

IV
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To select a chart type, follow these steps:
1. Choose Chart Type from the Format menu. The Chart Type dialog box
appears.
2. In the Chart Dimension area, select the two-dimensional or threedimensional option.

3. Highlight the chart type you want to use.
4. To display chart subtypes, click the Options button. The Format Group

dialog box appears.
5. In the Subtype area, highlight a chart variation, and then click OK.
You return to the Chart Type dialog box.
6. Click OK. The new chart type is applied to the current chart.

When you're not sure what chart type you want to use, experiment by choosing different chart types. To try different chart types, follow the preceding
steps, but choose the Chart Type button rather than the OK button in step 6.
The Chart Type dialog box appears again, enabling you to select a different
chart type.

Using AutoFormats
Microsoft Graph's AutoFormat feature provides an alternative to selecting a
chart type in the Chart Type dialog box and specifying chart elements (such
as data labels and grid lines) individually. AutoFormats are predefined formats
that specify a chart type and subtype, as well as other chart characteristics,
such as color, font, and patterns. Using an autoformat often gives you more
chart-subtype choices.
When you choose AutoFormat from the Format menu, Graph displays the
AutoFormat dialog box. Select a chart type in the Galleries list, and then
select a chart subtype in the Formats area.
Figure 25.9 shows that many three-dimensional pie-chart variations are available when you use an AutoFormat, whereas pie-chart subtypes are limited
when you use the Chart Type dialog box.

Adding Visual Elements to a Chart

537

To use an AutoFormat, follow these steps:
1. Choose AutoFormat from the Insert menu. The AutoFormat dialog box
appears.
Fig. 25.9
Select a format in
the AutoFormat
dialog box.

AutoFormet

~i~J~~~ ~ lc •:
3-D Column
3DBIIr
3-Dltne

r.::;

~3~-D~S~u~rfece
::::=~i~

f•: ~~-~~r- 0.:; :- - :H-:~el-p-....,

CC~[I
-

_

--

-

2. In the Formats Used area, select the Built-in option.
3. In the Galleries list, select a chart type.
4. In the Formats area, select a chart subtype.

5. Click OK. Microsoft Graph applies the AutoFormat to the current chart.

Adding Visual Elements to a Chart
Aside from the chart itself-that is, the actual bars, lines, slices, or columnsmost charts contain additional elements that make the chart easier to read
and interpret. For example, you can add a title to describe the purpose of the
chart. You also can add titles (such as Thousands of dollars, Percentage, or
1994) to identify the units used in the x-axis (horizontal) andy-axis (vertical).
If your chart is self-explanatory and does not require axis labels, you can turn
off the x- and y-axes. To identify each data series represented in a chart, you
use a legend. You also can add grid lines, which help readers find the values
of data points more accurately. Figure 25.10 shows these chart elements.
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Fig. 25.10
Chart elements
make a chart more
readable

Adding Titles
To add a chart title, x-axis title, or y-axis title, use the Titles dialog box (see
fig. 25.11). You can display th is dialog box by choosing Titles from the Insert
menu. In the dia log box, select those that represent the titles you want to
add. For each one you select, Graph inserts a text object into the current
chart. You edit the text object to add the text of the title.
Fig. 25.11
The Titles dialog
box enables you to
add titles to a
chart.
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Note
The options in the Titles dialog box vary, depending on the type of chart you are
using.

Adding Visual Elements to a Chart

To add titles to a chart, follow these steps:
1. Choose Titles from the Insert menu. The Titles dialog box appears.
2. Check all titles you want to add to your chart.
3. Click OK. Microsoft Graph adds text objects to the chart.
4. Click a text object to select it, and then click anywhere inside the text
object to produce an insertion point.
5. Enter the correct text for the title.
6. Click any blank area of the chart to deselect the text object.
If necessary, you can resize the title text box, just like any other text box.
If you add a title to a chart and then decide you don't want to use it, you can

remove it. Simply select the text object, and then choose Clear from the Edit
menu or press Del.
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Tip
To change any of
the text attributes
of a title, doubleclick the title text.
The Format Chart
Title dialog box
appears. In this
dialog box, select a
font, style, size,
color, and special
effects (such as
subscript).

•
•

Adding a Legend
A legend uses color-coded boxes to identify the data series in a chart. If the
East data series is represented in a bar chart by red bars, for example, the
legend shows a small red box next to East. Microsoft Graph automatically
adds a legend to every new chart, so you don't need to choose a command.
If you prefer not to include a legend in a chart, you can remove the legend.

•.
1

Select the legend, and then choose Clear from the Edit menu or press del.
To place a legend in the chart again, choose Legend from the Insert menu.

Adding Data Labels
Data labels mark the exact value or percentage represented by a data point.
Data labels often are used in bar or column charts to pinpoint values when
data points are close together. These labels also are commonly used in pie
charts to identify the exact percentage represented by each pie slice.
To add data labels to a chart, you use the Data Labels tab in the Format Data
Series dialog box, shown in figure 25.12. Display this dialog box by doubleclicking a bar in the chart. In the dialog box, you can select more than one
data-label option. The Show Value and Show Percent options display numbers, and the Show Label option displays the category label next to the data
point. The Show Label and Show Percent options are commonly used in pie
charts to identify each pie slice, as well as to pinpoint the percentage.

np
To tum a legend on or off
quickly, click
the Legend
button in the
standard Graph
tool bar.
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Fig. 25.12
Select one or more
options in the
Data Labels dialog
box.
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The Show Legend Key next to Label check box, at the bottom of the Data
Labels dialog box, enables you to display a legend key (a small color-coded
box) alongside each data label. To use this option, click its check box.
To add data labels to a chart, follow these steps:
1. Choose Data Labels from the Insert menu. The Data Labels dialog box
appears.
2. Select one or more options.
3. If you want the legend key to appear with the data label, select the

Show Legend Key Next to Label check box.
4. Click OK.

Turning the Axes On and Off
All sample column charts that Microsoft Graph creates include an x-axis and
a y-axis. Each axis is labeled with the scale (dollars, percentages) or unit of
measurement (mon ths, quarters) represented in the axis. For some charts,
you might find that the x- andy-axes are unnecessary. When a chart's exact
data points fo r each data series are not important and when the data markers
(bars, lines, columns, and so on) clearly illustrate the differences in values,
you might not want to include the x- and y-axes in your chart.

Adding Visual Elements to a Chart
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To turn off the x- or y-axis in a chart, follow these steps:
1. Choose Axes from the Insert menu. The Axes dialog box appears

(see fig. 25.13).
Fig. 25.13
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2. For each axis you want to remove, deselect the appropriate option.

3. Click OK. Microsoft Graph removes the axes you specify from the
current chart.
To return an axis to a chart, follow the same steps but select the appropriate
axis options.

Adding Grid Lines
Grid lines are horizontal and vertical lines that overlay a chart. These lines

help you follow a point from the x- or y-axis to identify a data point's exact
value. Grid lines are useful in large charts, charts that contain many data
points, and charts in which data points are close together.
The sample column chart that Microsoft Graph creates includes horizontal
grid lines. When you choose a new chart type, at least one set of grid lines
(horizontal or vertical, depending on the orientation of the chart) is included
to make the chart easier to read. You can add the opposite set of grid lines,
change from one set to another, or remove all grid lines.
To specify which grid lines to use, you can choose from options in the
Gridlines dialog box, shown in figure 25.14. You can display this dialog
box by choosing Grid lines from the Insert menu. Notice that the dialog

Use the Axes
dialog box to add
and remove axes
in a chart.
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box contains options for major and minor grid lines. The grid lines in the
sample column chart that Microsoft Graph creates occur at the major intervals on the axis. Using major grid lines helps you pinpoint exact locations in
a chart without cluttering the chart. When major grid lines don't provide
enough detail, however, you can use minor grid lines, which fall between the
major intervals on the axis.

Fig. 25.14
Use the Gridlines
dialog box to
choose gridline
options.

Cancel
Help

Tip
To turn grid
lines on and off
quickly, click
the Horizontal
Gridlines or
Vertical
Gridlines button in Graph's
Standard
tool bar.

To turn gridlines on or off in a chart, follow these steps:
1. Choose Gridlines from the Insert menu. The Gridlines dialog box
appears.
2. For each axis, turn major and minor grid lines on or off. (Grid lines are

on when an
3. Click OK.

x appears in the check box.)
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Specifying Colors, Patterns, Borders,
and Fonts in a Chart
Throughout this chapter, you have seen how Microsoft Graph creates a
sample chart from sample data. just as you can change the chart type used for
the sample chart, you can change the colors, patterns, borders, and fonts
used in the sample chart. Changing these attributes can greatly improve the
appearance of a chart.
You can apply colors, patterns, and borders to almost any element in a chart.
In the sample column chart shown in figure 25. 15, columns that represent
the data series are red, green, and blue. Each column is bordered in black. All
columns appear in a solid color rather than a two-color pattern. The legend
box and the walls of the chart (m ade visible by the horizontal grid lines)
appear in white, and the grid lines themselves appear in black. You can
change the colors of all these elements.
Fig. 25.15
The chart elements
allow you to
specify a color,
pattern, border,
and font.
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To change a chart element's color, pattern, or border, begin by selecting the
element that you want to change. If you want grid lines to appear in red
rather than black, for example, click one of the grid lines. The element's
resize handles appear, showing that the element is selected. Open the Format
menu, and notice that the first command in the menu is Selected [Element]
(Element refers to the chart element you selected). In this example, the command is Selected Gridlines. If you selected the chart's walls or legend, the
command would be Selected Walls or Selected Legend.

Tip
You can
double-dick
any chart element to display
the Format
[Element]
dialog box.

When you choose Selected [Element] from the Format menu, Microsoft
Graph displays a dialog box like the one shown in figure 25.16. The Patterns
tab is selected by default. (Depending on the element you select, a different
tab might be selected in the dialog box.) In the Border area of the dialog box,
you can select the border's style, color, and weight, or turn off the border by
choosing None. In the Area section, you can select a color and pattern for the
element.

Fig. 25.16

Use the Format
Data Series dialog
box to change
element attributes.
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To change a chart element's color, pattern, or border, follow these steps:
1. Select the element you want to change. The element is selected when its

resize handles become visible.
2. Choose Selected [Element] from the Format menu. The Format
[Element] dialog box appears.
3. In the Border area, select the appropriate options. To restore Graph's
default style, select Automatic.

Specifying Colors, Patterns, Borders, and Fonts in a Chart
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4. In the Area section, select the appropriate options. To restore Graph's
default color and pattern, select Automa tic.
5. Check the Sample box in the bottom right corner of the dialog box.
Repeat steps 3 and 4 to change any colors or styles with which you are
not satisfied.

6 . When you are satisfied with your choices, click OK.
For any text object in a ch art, you can change the font, size, style, color, and
background color. You also can specify underlining or add special effects,
such as strikethrough, subscript, and superscript. These attributes are listed
on the Font tab of the Format [Element] dialog box (see fig. 25.17). To display
this dialog box, select the text object, choose Selected [Element] from the
Format menu, or double-click the text object.
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Follow these steps to change the format of text:
1. Select the text object that you want to format, and then choose Selected

[Element] from the Format menu, or double-click the text object. The
Format [Element] dialog box appears.
2. If the Font tab is not visible, click it or press option+tab.

3. Select one item each in the Font, Font Style, and Size list boxes.
4. To change the text color, select a color in the Color pop-up list.
5. If you want, select special effects in the Underline and Effects sections.

6. Check the Preview area of the dialog box. If you are not satisfied with
any of the changes, repeat steps 3 through S, selecting different items.
7. When you are satisfied with your choices, click OK.

Fig. 25.17
Use the Font tab in
the Format Chart
Title dialog box to
change font
attributes.
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Inserting a Chart into a Presentation
While you are working in Microsoft Graph and making changes in your
chart, the changes you make are updated in your PowerPoint slide. As long as
you continue working in Graph, the Graph menu bar and toolbar remain
active. When you are satisfied with your chart and want to return to PowerPoint, click any blank area of the slide outside the chart area. The chart becomes an object in the slide, and PowerPoint's menus and toolbar return to
the screen.
lrfil~

To save the chart, choose Save from the File menu or press

~+S.

Editing a Chart
After returning to PowerPoint, you might want to edit an existing chart.
To restart Microsoft Graph, simply double-click the chart. The Graph menus
and toolbar replace the PowerPoint menus and toolbar.

From Here ...
In this chapter, you learned how to work with a separate applicationMicrosoft Graph-to create charts for your presentation slides. Refer to the
following chapters for information about other types of objects you can add
to slides:
• Chapter 21, "Entering Slide Content," describes the basics of entering
the content of a presentation and labeling objects. This chapter also
describes all aspects of enhancing text, such as selecting fonts, styles,
and colors; aligning text; adding bullets; and checking your spelling.
• Chapter 23, "Drawing Shapes, Curves, and Lines," describes how to use
PowerPoint's drawing tools to add drawn objects to your slides.
• Chapter 24, "Enhancing a Presentation," describes how to add color,
borders, shadows, and other enhancements to objects.

Chapter 26

Creatin

As you learned in Chapter 19, "Getting Acquainted with PowerPoint," you
can print a variety of components of a PowerPoint presentation, including
slides (on paper or overhead transparencies), audience handouts, an outline,
and speaker's notes. You also can prepare an on-screen slide show as a special
kind of "output."
In this chapter, you learn to
• Choose a setup for presentation components
• Set up your printer
• Print presentation components (slides, notes,
handouts, and an outline)
• Create and run an on-screen slide show

Choosing a Setup for Presentation
Components
A setup determines the dimensions and orientation to be used for printing
each component of a presentation. PowerPoint is set to print slides that are
10 x 7 inches in landscape orientation. If you want to use different dimensions or portrait orientation, you must choose setup options in the Slide
Setup dialog box, shown in figure 26.1. Display this dialog box by choosing
Slide Setup from the File menu.
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In the dialog box, the Slides Sized For pop-up menu offers options for different types of paper, on-screen slide shows, and 35mm slides. When you
choose an option, the dimensions set for that option automatically appear in
the Width and Height boxes.

Fig. 26.1
Use the Slide Setup
Dialog box to set
up all presentation
components.
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As shown in figure 26.1, the On-Screen Show option uses an area 10 x 7.5
inches so the slides fill the screen. You can use other Slides Sized for options:
• The Letter Paper option sets the width to 10 inches and the height to
7.5 inches. Use this option when you are printing on 8 1/2 x 11-inch
paper or transparencies.
• The A4 Paper (2 10 x 297 mm) option sets the width to 10.833 inches
(26 em) and the height to 7.5 inches (18 em).
• The 35mm Slides option sets the width to 11.25 inches and the height
to 7.5 inches so that the content fills the slide area.
• The Custom option allows you to choose the dimensions you want
wh en you are printing on nonstandard paper. Before you specify custom dimensions in the Width and Height boxes, the width and height
default to the maximum area your printer is capable of printing.
The Orientation section of the dialog box offers Portrait and Landscape as
options. When you choose Portrait, the slide is taller than it is wide. Landscape creates slides that are just the opposite of Portrait; that is, each slide is
wider th an it is tall. Slides often are printed in Landscape orientation ,
whereas notes, handouts, and outlines are most often printed in Portrait
orientation. Therefore, PowerPoint offers separate orientation options for
slides and notes, handouts, and outlines.

Printing Presentation Components
PowerPoint allows you to begin numbering slides with a number other than 1
by entering that number in the Number Slides From box.
To choose a setup for slides, notes, handouts, and outlines, follow these steps:
1 . Open the presentation for which you want to specify a setup.

2 . Choose Slide Setup from the File menu. The Slide Setup dialog box
appears.
3. Choose the appropriate option in the Slides Sized For pop-up menu.
4. To begin numbering slides with a number other than 1, enter a number

in the Number Slides From box.
5. To change the print orientation for slides, choose either Portrait or

Landscape.
6. To change the print orientation for notes, handouts, or an outline,
choose either Portrait or Landscape.
7. When all settings are correct, click OK.
Note
It's best to set the slide setup before you create a new presentation. If you change
the slide setup after your slides are created, you might need to make adjustments to
your slides, depending on the setup dimensions you choose.

Printing Presentation Components
PowerPoint allows you to print any component of a presentation: slides,
notes pages, handouts, and an outline. To print any component, choose Print
from the File menu. The Print dialog box appears. In this dialog box you
choose the component you want to print, the number of copies, the specific
pages to print, and other printing options.

Printing Notes Pages
Notes pages contain a reduced slide at the top of the page and speaker's notes
at the bottom of the page, as shown in figure 26.2.
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Fig. 26.2
A notes page
displays a reduced
slide at the top of
the page and
speaker's notes at
the bottom.
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Because notes pages print one slide per page, specify the range you want to
print. If, for example, you want to print notes pages only for slides two
through six, type 2-6 in Range and select Notes from the Print What menu.

Printing Handouts
PowerPoint lets you print handouts using one of three differe nt layout styles.
The first layout includes two slides per page. Other layouts let you print three
or six slides per page. To see how a handout page looks with each of these
layout options, display the Handout Master by holding the shift key and
clicking the Slide Sorter button. You see a slide like the on e shown in figure
26.3. The small dotted lines outline the three- and six-slides-per-page layouts.
(If you choose to print three slides per page, the slides are printed on the left
side of the page; the right side is blank.) The long dotted lines outline the
two-slides-per-page layout.
To print handouts, use the same basic steps. In the Print What area of the
Print dialog box, choose Handouts (2 Slides Per Page), Handouts (3 Slides Per
Page), or Handouts (6 Slides Per Page), as shown in figure 26.4.
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Fig. 26.3
Layout options for
handouts include
two, three, or six
slides per page.
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To print selected handout pages, it isn't necessary to determine o n which
page a slide will print. Specify th e slide numbers that you want to print. If, fo r
example, you choose 3 slides per page and you want to print slides 4, 5, and
6, type 4 -6 in the Range boxes of the Print dialog box. PowerPoint prints the
second h andout page.
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Printing an Outline
When you print a presentation outline, it is printed just as it was last displayed in Outline view. If you clicked the Show Titles button on the Outlining toolbar to display only titles (no body text), for example, PowerPoint
prints only the slide titles. (You must be in Outline view to see the Outlining
toolbar.) If you change the display scale using the Zoom Control button on
the Standard toolbar, the outline prints in the current scale percentage. If you
click the Show Formatting button on the Outline toolbar to display the outline text without formatting, the outline is printed exactly as displayed onscreen.
To print an outline, follow the steps outlined previously for printing slides,
except select Outline from the pop-up menu at the bottom of the Print dialog
box. If you enter 1, 4, S-9, as the range, PowerPoint includes only those slides
on the printed outline page.

Setting Up and Running a Slide Show
On-Screen
One of the most effective ways to present your slides is to use your computer
screen as an output medium. When you use your computer for an on-screen
slide show, the entire screen area is used; PowerPoint's title bar, menu, and
toolbars are cleared from the screen, and each slide is displayed using the full
screen.
...,. See 11 Annotating a Slide
Show,"

p.SS9

..,.. See "Running a
Slide Show,"

p.SS6

An on-screen slide show offers several advantages over transparencies or
3Smm slides. An on-screen slide show saves you the expense of producing
slides, it requires no projection equipment, and you can use your computer's
color capability to its fullest extent. You also can annotate your slides as you
give your presentation.
You can run a PowerPoint slide show manually (using the mouse or keyboard
to advance to the next slide when you're ready); you can set up a slide show
to run in a continuous "loop" for demonstration purposes; or you can set up
a slide show to advance slides automatically.

Setting Slide Timings and Transitions
When you set up a slide show to automatically advance to the next slide, you
can set the amount of time each slide remains on-screen, and you can specify
a transition style between slides. The transition style determines how one

Setting Up and Running a Slide Show On-Screen
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slide is removed from the screen and the next one is presented. Dissolving
from one slide to the next and fade througll black are two examples of transition styles. PowerPoint offers 46 transition styles from which to choose.

IV

To set timings and transitions, you use the Transitions dialog box (shown in
fig. 26.5). From any of PowerPoint's display views, you can display this dialog
box by opening Tools and selecting Transition. When using Slide Sorter view,
you can display the Transition dialog box by clicking the Transition button at
the left end of the toolbar.
Transition button

Fig. 26.5
Use the Transition
dialog box to set
slide timings and
tran sitions.
Transition
Effects

button

Tip

Transition styles are listed in the Effect pop-up menu. To see a demonstration
of how transitions actually work on-screen, open the Effect pop-up menu,
and then highlight a new transition style. Each time you highlight a new
style, the transition is demonstrated on the sample slide in the lower right
corner of the dialog box. Try varying the speed (Slow, Medium, or Fast) to see
how it affects a transition.
You specify timing options in the Advance section of the Transition dialog
box. Select the Only on Mouse Click option to set slides to advance manually
whenever you click the mouse. Select Automatically After_Seconds to set a
specific transition time for the slide; then enter the number of seconds in the
box.

You can
quickly set slide
transitions
using the Transition Effects
button on the
Slide Sorter
toolbar. Select a
slide; then
select an item
from the Transition Effects
pop-up menu.

554

Chapter 26- Creating Output
To set timing between slides and specify transitions, follow these steps;
1. Display your presentation in Slide Sorter view.
2. Select the slide for which you want to set timing and transition. If you

want to use the same settings for multiple slides, select those slides as a
group.
3. Click the Transition button at the far left end of the toolbar, and choose
Tools, Transition. PowerPoint displays the Transition dialog box.
4 . Select a transition style from the Effect pop-up menu.

5 . Select the appropriate option in the Speed box.
6 . Select the appropriate option in the Advance box.

7 . Click OK.

Power Point displays the transition time below the bottom left corner of the
slide. When you set a transition for the slide, an icon that looks like the Transition button appears alongside the transition time in the bottom left corner
(see fig. 26.6). You can click any transition icon to see a demonstration of the
transition effect.
Fig. 26.6
Transition
symbols and
timings appear in
the lower left
corner of slides.

Transition icon

Slide time

Setting Up and Running a Slide Show On-Screen
You can change transitions or timing at an y time by repeating these steps.
You also can change slide timing when you rehearse a slide show, as described in th e next section .

Rehearsing a Slide Show
Before you actually give your presentation, you' ll probably want to rehearse it
several times. You can rehearse using manual advance or using the slide timings you set. If you want to set new timings, you can do so as you rehearse.
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Tip
You can specify
more than 60
seconds if you
wan t the slide
to remain onscreen longer
than one
min ute.

To rehearse using manual advance or the current slide timings, follow these
steps:
1. From any view, choose Slide Sh ow from the View menu. The Slide

Show dialog box shown in figu re 26.7 appears.

SbllY
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cancel

I Screen_
• Manual Advan~
Use Slide Timings

0

If

)
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Rebarse NeY Timings

Run Conti nuousl g Until COMMAND+ •. •

2. In the Slides section, choose All or specify the slides you want to

rehearse in the From and To boxes.
3. In the Advan ce section, choose Ma nual Advance or Use Slide Timings;
then click the Show button. Your slide presentation begins running.
4. If you chose Manual Advance, click the mouse, press return, or press

page down when you're ready to advance to the next slide.
If you chose Use Slide Timings, the slides advance automatically using

the current timings. When the last slide is complete, PowerPoint returns to slide sorter view. You can manually advan ce, however, by
pressing return, clicking the mouse, or pressing page down.

Fig. 26.7
The Slide Show
dialog box allows
you to con trol
the timing of a
presentation.

IV

556

Chapter 26-Creating Output

Tip
From Slide
Sorter view,
you can start a
slide show to
rehearse new
slide timings
by clicking the
Rehearse Timings button on
the Slide Sorter
tool bar.

To set new slide timings as you rehearse a presentation, follow these steps:
1. From any view, choose Slide Show from the View menu. The Slide
Show dialog box appears.

2. In the Slides section, choose All or specify the slides you want to
rehearse in the From and To boxes.
3. In the Advance section, choose the Rehearse New Timings option; then
click the Show button. Your slide presentation begins running, and a
clock timer appears in the lower left comer of the screen, counting
seconds.
4. Begin rehearsing your presentation. When you are ready to advance to
the next slide, click the mouse button, press return, or press page down.
5. Repeat step 4 until all slides are shown. A message appears telling you
the total time for the new slide timings.

Tip
If you want to

record new
timings selectively during a
rehearsal, press
0 to use the
original time,
press T to use
the new time,
or press M to
hold a slide onscreen until the
mouse is
clicked.

Choose Yes to record the new timings; choose No to ignore the new
timings and retain the previous timings.

Running a Slide Show
You can run a PowerPoint slide show in several ways. You can run a slide
show from within PowerPoint by first opening the presentation and then
choosing Slide Show from the View menu, or by clicking the Slide Show button in the lower left comer of the PowerPoint window. When you choose
Slide Show, the Slide Show dialog box appears. Use this dialog box to specify
the slides to view and how you want the slide show to run. When you choose
the Slide Show button, you bypass the display of the Slide Show dialog box,
and PowerPoint uses whatever settings appear in that dialog box.
To run a slide show after choosing Slide Show from the View menu, use these
steps:
1. Open the presentation for which you want to run a slide show.

2. Choose any view.
3. Choose Slide Show from the View menu. The Slide Show dialog box
appears.
4. In the Slides section of the dialog box, choose All.

5. In the Advance section, choose Manual Advance or Use Slide Timings,
then click Show. Your slide presentation begins running.

Setting Up and Running a Slide Show On-Screen
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If you chose the Manual Advance option in stepS, click the mouse, press

Tip

return, or press page down when you're ready to advance to the next slide.
If you chose Use Slide Timings, the slides advance automatically using the
current timings.

To end a slide
show at any
time, press esc.
PowerPoint
returns to the
view that was
displayed before
you began the
slide show.

It's rare that you have an opportunity to run through a slide show completely
without interruption. At times, you might want to pause, view a previous
slide, or tum a slide 11 off" by making the screen go black (or white). Table
26.2 lists the methods for controlling your movements through a slide show.
I

Table 26.2

Methods for Controlling a Slide Show

I

Function

Method

Show the next slide

Click the left mouse button or press space
bar, or use the page down or down arrow
button.

Show the preceding slide

Click the right mouse button or press delete,
or use the left arrow or up arrow button,
or press ):C+shift+tab.

Show a specific slide

Type the number and press return.

Toggle the mouse pointer on
or off (Show or Hide)

Type A or equal sign (=).

Toggle between a black screen
and the current slide

Type B or period (.).

Toggle between a white screen
and the current slide

Type W or comma (,).

End the slide show and return
to PowerPoint

Press esc, ):C+(.), or ):C+(-).

Pause and resume an automatic
slide show

TypeS or plus sign(+).

Another method for running a slide show is to simply click the Slide Show
button at the lower left corner of the PowerPoint window. When you click
this button, PowerPoint immediately runs the slide show, beginning with the
slide that is currently selected. The slide show runs using current slide timings. If there are no timings set, you must advance each slide manually. To
run a slide show from the beginning using this method, be sure to select the
first slide in the presentation before you click the Slide Show button.

558

Chapter 26-Creating Output
A third method for running a slide show is to use the PowerPoint Viewer, a
special program that runs outside PowerPoint. The PowerPoint Viewer lets
you run a slide show even if the PowerPoint program itself is not installed on
the computer. The PowerPoint Viewer is particularly useful if you need to
present a slide show on a computer other than your own (perhaps at a
customer's office or at a trade show).
To run a slide show using the PowerPoint Viewer, follow these steps:
1. Go to the Finder by either clicking the Desktop or choosing Hide

Microsoft PowerPoint from the Application icon in the upper right
corner of the monitor.
2. Open the PowerPoint 4.0 folder and double-click the PowerPoin t

Viewer program icon. The Microsoft PowerPoint Viewer dialog box
appears, as shown in figure 26.8.
Fig. 26.8
The Microsoft
PowerPoint
Viewer dialog
box allows you
to select the
presentation you
wan t to view.
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3. Highlight the PowerPoint file you want to display.
4. To run th e slide show con tinuously, select the Run Continuously Until
~ +' .'check

box at the bottom of the dialog box.

5. Click the Show button to begin the slide presentation.

Refer to table 26.2 to con trol a ru nning slide show.

Setting Up and Running a Slide Show On-Screen

Annotating a Slide Show
When you deliver a presentation using overhead transparencies, you may
often circle or underline a specific point, or write notes on the slide in response to audience questions or comments. If you use a dry-erase marker, you
can easily wipe off your annotations so that the transparencies are not permanently marked.
When you run an on-screen slide show, PowerPoint gives you the ability to
electronically annotate your slides in freehand form using the mouse. For instance, you might want to draw a check mark beside an important point or
underline it. As with overhead transparencies and dry-erase markers, electronic annotations are not permanent. They are automatically removed when
you move to the next slide in a slide show. You can remove annotations
manually as you present your slides.
To annotate slides during a slide show, follow these steps:
1. Start your slide show either in PowerPoint or in the PowerPoint Viewer.
2. Click the Annotation icon, which appears in the lower right corner of

your screen. The mouse pointer changes to a pencil.
3. Press and hold the mouse button as you write or draw on-screen, using
it as you would a pencil. Release the mouse button to stop drawing or
writing. The Annotation tool is still active; the Annotation icon toggles
on and off (see fig. 26.9).
4. Repeat step 3 to write or draw again on the slide.

5. If you want, press E to erase all annotations to the current slide.
6. When you are finished annotating the current slide, click the Annota-

tion icon again to restore the mouse pointer.
If you don't press E to erase all annotations on the current slide (see step 5),

PowerPoint erases all annotations automatically when you move to the next
slide in the slide show.
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Fig. 26.9
During a slide
show, the
Annotation icon
appears in the
lower right corner
of the screen.

From Here ...
This chapter, which describes how to prepare your printer, print slide show
components, and run a slide show in PowerPoint, concludes the PowerPoint
section of Using Microsoft Office 4.2 for the Macintosh, Special Edition. Toreview information about using PowerPoint, refer to any of these chapters:
• Chapter 19, "Getting Acquainted with PowerPoint," describes how to
start and exit PowerPoint and describes the PowerPoint window. You
also learn about templates, masters, objects, layouts, and visuals that
you can add to a PowerPoint presentation.
• Chapter 20, "Creating, Saving, and Opening Presentations," describes
the various methods for creating a new presentation file and how to
switch your view of a presentation. You also learn how to save, close,
and open a PowerPoint presentation file.
• Chapter 21, "Entering Slide Content," describes the basics of entering
the content of a presentation and labeling objects. This chapter also
describes how to create a Word table, an Excel spreadsheet, and an
organization chart in a PowerPoint presentation. You also learn how to
insert objects from sources outside PowerPoint.
• Chapter 22, "Working with Objects," defines objects and shows you
how to select and group them, and shows you how to move, copy,
resize, align, rotate, flip, and stack objects.

From Here...

• Chapter 23, "Drawing Shapes, Curves, and Lines," describes how to use
PowerPoint's drawing tools to add objects to your slides.
• Chapter 24, "Enhancing a Presentation," describes how to add color,
borders, shadows, and other enhancements to objects.
• Chapter 25, ''Creating Charts," describes how to use Microsoft Graph,
an embedded application that lets you create a wide variety of chart
types from spreadsheet data.
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v
Suppose that you are working in a brand new office. The office has new desks
and chairs, new computers, and a new copy of Microsoft Office. Th e nonprofit organization you work for is catching on so fast that it's hard for you to
keep up with everything you have to do. And as the first real employee, you
have to do everything-answer the phone, create correspondence, manage
volunteers, brainstorm, and even organize the di rector. Your most basic task
is to organize your work.
In this chapter, you learn to
• Find and organize files with the Finder and Find File
• Identify and find files with summary information
• Move between Office programs

Using the Finder to Organize Files
In the same way you set up an office by labeling file drawers and organizi ng
files in the drawers, you need to organize the files on your hard disk. To find
out wha t files you have on your hard disks and floppy disks, use the Finder
(also called the Macintosh desktop). The Finder is actually the program that
creates the desktop and runs automatically when you boot your Macintosh.
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Looking at the Hard Disk
To see how your files are organized, you need to navigate through the Finder,
shown in figure 27.1. Double-click each drive icon to see the folders and the
files on that drive. There are two ways to open a folder and see its contents:
you can double-click the folder icon or just click it once and then open the
File menu and choose the Open command.
Fig. 27.1
The Finder creates
the Macintosh
desktop, and lets
you create folders
for organization.

CJ

Microsoft orne.

The Microsoft Office folder is now open. To get a better overall view of your
hard disk's contents, open the View menu and choose the By Name command. The Finder window changes to a list view, as shown in figure 27.2.
In any list view, click the small triangles next to a folder to see an indented
view of that folder's contents.
Suppose that you look in each program folder and notice that your boss
saved all document files to the program's folder. (You can tell because there
were new worksheet files in the Excel folder and new document files in the
Word folder.) You call your boss, who tells you to organize things any way
you want-as long as you don't lose any files. You decide to organize the disk
drive so that the files are listed by project.

Using the Finder to Organize Files
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Fig. 27.2
V iewing by Name
gives you a useful

list view.
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Caution
Be careful when you m ove files on your hard disk; you don't want to destroy som eone else's organization. Make sure that all users of the computer know where you are
putting their files. Also, make sure that you have a good backup of all files on your
hard disk before you do any major rearranging. Do not delete files unless you know
the files' contents or purpose.

Creating a Folder
To create a new folder, follow these steps:
1. Click th e window in which you want to create the folder.
2. Open the File menu and choose the New Folder command. You get a

new folder, with the highlighted name, untitled folder.
3. Type in the name you want the new folder to have, and th en click the

mouse button on the window next to the new folder to deselect the
folder and lock in the name.
You now have a new, em pty folder.
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Organizing Your Hard Drive
When you create folders to organize your hard drive, keep the following
questions in mind:
• How often will you use the files?
• Will you expect to find your work by date, by person, by project, or by
the software that created the files?
• How does your backup procedure work?
• Who else sees your work?
• Who else is going to need access to your files?
• Do your files need to be protected from unauthorized use?
Using the new Find File feature available in most Microsoft Office programs,
you can find files based on summary information, such as the date, the
project, and the name of the person who created the file. Even with this
capability, you want to organize your hard disk to make finding files easier
for you and for others who need to view or use your files.
Figure 27.3 shows one way of organizing a folder structure for your hard
drive. In the figure, the hard disk called Harder Disk has four main folders:
Applications, Documents, Microsoft Office, and System Folder. The System
Folder contains the Mac's operating system, and doesn't need to be modified.
You may want to back up your documents daily and your programs monthly,
or whenever you change a program. Therefore, you can create one folder for
documents and one for programs. If you are on a network or have a security
application, you may want to have limited security for programs and tighter
security for data. With network programs, you can assign security to a folder,
and the security will flow to the subfolders and files of the folder.
Figure 27.3 also shows subfolders organized by client, by date, and by project.
Below the Documents folder are subfolders for Clients, Finances, MS Office
Figures, and Writing. The Clients subfolder is broken down by client name.
One of the clients, LAMG (Los Angeles Macintosh Group), is broken down by
date (93 Files, 94 Files, and History), as well as by project (General Meetings
and Mac Fair). Documents are displayed within the 94 Files folder.

Using the Finder to Organize Files
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Fig. 27.3
This list view of a
folder structure in
the Finder shows
just one possibility
of how you can
organize your hard
drive.
- - - - Client subfolders

The main folders for this hard drive

Searching for Files
When you have a folder structure in place, you m ay forget wh ere you put a
file. You can look for a file through the Finder's Find feature or through the
Find File procedure in the applications. Find is of limited use, because it only
looks sequentially through your hard disks for file names, or other Finder
attributes such as size or creatio n date. The Find File feature in the applications has the capability to preview the document and its summary information. Find is described in this section; Find File is described in the section
"Using Find File to Organize Files," later in this chapter.
To search for a file by the file name or a portion of the file name, follow these
steps.
1. In the Finder, open the File menu and choose the Find command.
The Find File dialog box appears (see fig. 27.4).
Find File

Find Items
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Find
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Fig. 27.4
The Finder's basic
Find File dialog
box.
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2. In the Find File text box, type the name of the file, and then click the

Find button or press return. The Finder searches for the first occurrence
of the text you entered, opens the window containing the file, and
highlights the file.
3. Click Find again (or press ):C+G) to find the next occurrence of the

searched text.
Note
If you click the More Choices button in the Find File dialog box, it expands the window. The expanded window has pop-up menus that allow you to expand the search
criteria and select the drives to be searched (see fig. 27.5).

Fig. 27.5
The expanded
Find File box.

Find File
Find Items
~----,-··

lj

I
I

nome
kind

siz e

=

I

on nil disks

•I whose

...

•I I
•I I
·I I

contolns

•l jLRMG
~

Is

·II

Is less than

·11128

{M ore Choices) { Fewer Choices)

....

document

,(~

IK II

I

Find

J

Moving and Copying Files
When you have the file you want in the folder window, you can move or
copy one or more files. First, select the files and then use the mouse to drag
the files to their new location. To see where your files are and where they are
going, it may be necessary to click the title bar of a window and drag it to
one side.
To select files, do one of the following things:
• To select one file, click the file's icon.
• To select multiple files, hold down the shift key while you click each of
the files. To select all files within a folder, press ~+A .
To move the files, click a highlighted file and drag the file to the desired drive
or folder. To copy files, you can hold down the option key while you drag the
files.

Using Find File to Organize Files
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Using Find File to Organize Files
Rather than going through files one by one in the Finder's Find featu re, you
can use the Find File feature within an Office application to preview the files
and move them in groups to the correct subfolder. An application's Find File
feature has different options from the Finder's, including the capability to
preview files, check their summary information, search across multiple drives,
and search for multiple file name criteria.

~

See "Finding
Files," p. 69

Listing Files In Find File
To use the Find File feature, first open Word, Excel, or PowerPoint. Open File
and choose the Find File command. The Search dialog box appears (see fig.
27.6). If you did a previous search, the Find File dialog box appears (see fig.
27.7). To return to the Search dialog box, choose the Search button.
Fig. 27.6
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Type in the name of the file you're looking for. If you provide a partial name,
Search returns all the files that have that partial name in their title. To search
for a file by its type, choose the type from the File Type pop-up menu. If you
want to give the search criteria a name-so that you can repeat the search at
a later time-click the Save Search As command button and type the name in
the Search Name text box. Finally, pick a drive to search from the Location
pop-up menu.

Using Find File Advanced Search
To figure out what files should go into what subfolder, you can use the Advanced Search dialog box, shown in figure 27.8. With Advanced Search, you
can search for the file by its contents, its summary information, the user of
the file, and the date.
Fig. 27.8
Find File's
Advanced Search

dialog.
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To use the Advanced Search feature of Find File, click the Advanced Search
button in the Search dialog box. The Advanced Search dialog box appears.
The Advanced Search dialog box has the following three tabs:

• Location. This tab enables you to select multiple drives and folders by
using buttons-instead of typing-in the Search dialog box.
• Summary. This tab enables you to look for summary information and to
search within the file for words or phrases.
• Timestamp. This tab enables you to search for files by user name, by
when they were created, or by when they were last saved.

Suppose that you want to search for all files that contain the word meeting
and move them to the LAMG folder. In the Location tab, you would select
only files in the Documents folder. In the Summary tab, you would type
Meeting in the Containing Text box.

Using Find File to Organize Files
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After moving ail the meeting files to the LAMG directory, you decide to look
for all files that a certain person has used since January l-in this case Suzy
Prieto. When Microsoft Office or each of the applications is installed, the
computer asks for a user name; the name you type at this point is the default
user name. Because the user for whom you are searching started working
exclusively on this computer for this project on january 1, you would find
other files (without the word meeting) that should be part of the LAMG directory. Enter the date and user name in the Timestamp tab of the Advanced
Search dialog box, as shown in figure 27.9. After you finish filling out the
dialog box, click OK. The results appear in the Find File dialog box.
Fig. 27.9
Type date and user
information in the
Timestamp tab of
the Advanced
Search dialog box.
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Suppose that after you find the LAMG documents, you want to look at their
contents. You can preview the documents by selecting Preview from the View
pop-up menu in the Find File dialog box (see fig. 27.10).
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Opening and Closing Flies
To open a file in Find File, double-click the file name, or select the file and
click the Open command button.

Troubleshooting
I tried to search a network drive, but Find File would not search it.
Find File cannot search a network drive to which you are not connected. Make sure
you use the Chooser to connect to the network drive. Find File will now search this
drive if you include it in your search criteria.

I searched for a string of text that I know is in a document, but Find File didn't find the
file.
If you save files with the Allow Fast Saves option, Word's Find File cannot search for
text in them. You need to turn off Allow Fast Saves. Open the Tools menu and
choose the Options command, and then choose the Save tab. Deselect Allow Fast
Saves, and click OK. This fixes the problem for any files you save in the future, but it
does not fix your problem for files you have already saved until you open and save
them again.

Using Summary ln~o
~

See "Using

Summary
Info,'' p. 69

You may have noticed that it would be much easier to find and organize files
if you had more information about the files. The Summary Info option enables you to add longer titles, the author's name, and other descriptive text to
your documents.

Adding Summary Information to Your Document
In Word, Excel, and PowerPoint, you can add a summary to the document.
The Summary Info dialog box contains five text fields (Title, Subject, Author,
Keywords, and Comments), each of which has room for up to 255 characters-including spaces and special characters. In Word, you can also see document statistics, such as total number of pages, words, and paragraphs.
To add summary information, complete the following steps:
1. Open the File menu and choose the Summary Info command.

The Summary Info dialog box appears (see fig. 2 7.11).

Using Summary Info

Fig. 27.8
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In the Summary
Info dialog box,

you can enter
information that
will help you find
the file later.

2. In the Title text box, type a description that is longer than the file name

of your document.
3. In the Subject text box, type a category.
4. In the Author text box, type your name.

Note
The user's name-the name entered during installation-is entered in the
author text box automatically. You can keep this name or change it.

5. In the Keywords text box, type words or phrases that describe your
document.
6. In the Comments text box, type any other notes you have.
7. Click OK.

Viewing Summary Information in Find File
When you use Find File in Word, Excel, and PowerPoint, you can see a preview of your file and two other views: file info and summary. File info view
shows the file name, document title, file size, and the date and time when it
was last saved. Summary view shows the information in the Summary Info
dialog box, as well as information about the time when the file was created
and saved.
To see the Summary Info before you open a file, complete the following
steps:
1. Open File and choose the Find File command. The Search dialog box or

your last Find File dialog box appears (depending on your last use of the
Find File command).

v
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2. If the Search dialog box appears, fill in the dialog box and click OK.

This begins the search and takes you to the Find File dialog box.
3. In the Find File dialog box, select Summary from the View pop-up
menu.
4. Select the file for which you want to see information. The Find File
dialog box displays information similar to that shown in figure 27.12.
Fig. 27.12
In addition to
showing a preview
of a file, the Find
File dialog box
also shows
summary
information.
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5. To see other information about the file, select File Info from the View
pop-up menu. The dialog box displays information similar to that
shown in figure 27.13.
Fig. 27.13
File Info view
shows some of the
same information
as Summary view
and enables you to
view more than
one file at a time.
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6. When you finish, click Open to open the file or click Close to close the

dialog box.
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Note
If you want to open more than one file at a time, you can select multiple files. To
select adjacent files, click the first file, hold down the shift key, and click the last file.
To select nonadjacent files, hold down the )::( key and click each file. After you select
the files, click Open.

Opening Files and Searching for Text
Suppose that you went through the files in the LAMG directory, glanced at
the major files, and added summary information. Now that you have the files
in the right area, you decide to make notes for your phone calls. Open the
Apple menu and choose the Note Pad to open your phone messages. To find
out where the answers to the questions in the Note Pad are, use Find File and
go into the documents that you suspect contain the answers.
To open the file in the Find File dialog box, first make sure you are in the
right application. You can double-click the file name or click the Open button. You also can open the File menu and choose the Open command.

v
-. See "Finding
and Replacing
Worksheet
Data," p. 262

To search for text when you are in the file, follow these steps:
1. Open Edit and choose the Find command. The Find dialog box appears.

2. In the Find What text box, type the characters you want to find, as
shown in figure 27.14.
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3. Choose one of the Find buttons (No Formatting, Format, or Special).
4. Click the Find Next button to begin the search.

Fig. 27.14
Type the text you
want to search for
in the Find What
text box.
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Say you remember that a list in the Proposal file lists your associate Leon
Kelly. After you open the Proposal in Word, you use the Find feature to go to
the page you want.

Moving between Office Programs
~

See "Switching
between
Documents,"

p. 79
~

See "Switching
between
Applications,"
p.81

To move to the Word document you have open (Proposal), open the application menu and choose Word. To move back to the phone message note in
the Note Pad, simply choose Note Pad from the application menu. The phone
message note will appear. If you have the Microsoft Office menu active, you
can press ):C+tab to scroll through the open applications. In the Office Manager menu, choose the application name to switch to the application. If the
application is not open, choose it from the Office Manager menu.
Because you are working with several Word documents at once, you decide to
open all the important ones. When the documents are open, you can choose
a document from the bottom of the Window menu (see fig. 27.15).

Fig. 27.15
To work with
more than one
document (to
copy informa·
tion, for ex·
ample), use the
Window menu to
switch between
the documents.
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To enter the answers to the questions in your phone message document, you
switch back and forth between Word and the Note Pad a lot (writing down
the names of the documents and, in some cases, the page numbers).

From Here...

From Here ...
This chapter shows you how to become more organized by using the
Microsoft Office menu, organizing your folder structure, and summarizing
information in your files.
After you organize your files, you may want to create documents. For more
information about creating documents, refer to the following chapters:
• Chapter 4, "Creating and Editing Documents," covers the basics of
creating a Word document.
• Chapter 12, 11 Creating Worksheets," covers the fundamentals of
creating an Excel worksheet.
• Chapter 20, 11 Creating, Saving, and Opening Presentations," gives you
the basics on how to create a slide presentation .
• Chapter 28, 11 Working with Wizards, Multiple Documents, and Cut,
Copy, and Paste," shows you how to use multiple open documents and
gather information into one document.
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Chapter 28

Cu
by Tom Negrino

v
Look at figure 28.1. This page from the Note Pad (available as a desk accessory
in the Apple menu) shows a couple of names and addresses of important
contacts that you noted during a phone call. These contacts want some more
information about the organization you work for. You could write each contact a customized letter, but it would be more efficient to create standardized
documents that you could quickly send out when you receive inquiries. Some
of the information about your organization already exists in documents
you've previously created. This information about your organization is scattered throughout your hard drive and everyone else's. Instead of retyping the
information into your new standard document, you can use the Cut, Copy,
and Paste procedures to reuse existing information. To start your standardized documents and save time, try the Wizards that come with the Office
applications.
This situation calls for you to create a letter in Word and copy information
from other Word documents, a PowerPoint slide, and an Excel worksheet. In
this chapter, you learn how to start a letter with one of Word's wizards and
copy information from the other Office applications, and then paste this
information into your Word document.
In this chapter, you learn to
• Use wizards to start letters
• Switch between programs
• Copy text, data, and pictures between programs
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Fig. 28.1
This page from the
Note Pad shows
some contact
info rmation that
you want to use in
a Word document.

Note Ped
Requests for Further Info
John Jessup
1980 E. Her'\lerd Drt YB
Culver City, CA 90311
310 555-9656

Interested In volunteering
Cheryl Smllhee
967 Wlldllower Ln
Cenoge Per1<, CA 91306
BIB 555-9120

Wents to see more Info on group's goels,
events; has been en event coordfnetor for
other nonproflts.

Starting a Letter with Letter Wizard
~

See "Wizards,"
p.S6

~

See "Using
Template
Wizards,"
p. 190

As mentioned in Chapter 2, "Using Common Features to Create Documents,"
a wizard asks you a series of questions about what task you want to accomplish. Through your answers, the wizard creates a format for your document
and adds some text to get you started. To begin a wizard in Word, use the
New command from the File menu.
To start the Letter Wizard, follow these steps:
1. Choose the New command from the File menu. The New dialog box
appears, displaying a list of templates and wizards (see fig. 28.2).

Fig. 28.2
Templates are
shown in the New
dialog box.
Wizards are a
subset of templates that walk
you through
creating a
document.
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2 . Scroll down and select Letter Wizard in the Template list box.

3. Click OK.
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Note
You can choose Summary in the New dialog box and enter Summary Info for the
new document, and then enter the first of the wizard dialog boxes.

After you choose OK in the New dialog box, the Letter Wizard' s first dialog
box appears, as shown in figure 28.3. The dialog box asks whether you want
to select a prewritten business Jetter, write a business Jetter, or write a personal letter. If you select prewritten business letter, a Jist of 15 letters appears.
This Jist, shown in figure 28.4, includes a press release, a collection letter, a
resume cover letter, and various thank-you letters.
Fig. 28.3
The first Letter
Wizard dialog box
enables you to
select different
types of letters.
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If none of the prewritten letters are appropriate, choose the Back button to
return to the Letter Wizard dialog box shown in figure 28.3. Select the Write
a Business Letter option, and choose the Next button. The n ext Letter Wizard
dialog box, shown in figure 28.5, asks which items you want to appear in

Fig. 28.4
Select a prewritten
business letter
from the list box.

v
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your letter. Some choices are: page numbers, enclosures, writer's initials, and
the date. These items are check boxes; turn each one on by clicking the box,
or off by clicking a box that has an "X" in it.

Fig. 28.5
Click a check box
to turn the item
on (with an X) or
off (without an X).

letter Wizard
Wb1dttte.msdo tpU'Wnt to'nc.lude f" .purle:l&r?

The next dialog boxes ask whether or not your letter is on letterhead and, if it
is, where to place the letterhead on the page.

Copying Information into a Dialog Box
~

See "Copying
and Moving,"

p.43
~

See "Switching
between
Applications,"
p.Sl

Fig. 28.6
Type or copy the
recipient's name
and address in the
Letter Wizard.

The dialog box shown in figure 28.6 requests the recipient's name and address and your name and return address. You can type the information or
copy it from somewhere else, such as the Note Pad or another document.
Your name and return address should already be filled in if you created a
previous letter with a wizard, or if you entered the information in the Tools,
Options, User Info tab of the Options dialog box. The recipient's name and
address already appear in your Note Pad.
letter Wizard
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To copy information from the Note Pad into the Letter Wizard dialog box,
follow these steps:
1. Drag the 1-beam mouse pointer over any existing information in the

recipient's text-box area to highlight all the information you will
replace, as shown in figure 28.6.
2. Switch to the open Note Pad by choosing Note Pad from the application menu. Alternatively, if it is visible, click the Note Pad to bring it to
the foreground.

3. In the Note Pad window, select the information you want to copy.
4. To copy the highlighted text, choose the Copy command from the Edit
menu or press :l=C+C.
5. Choose Word from the application menu to return to the Letter Wizard
dialog box in Word.

v

6. The old entry in the recipient's text box should still be highlighted.

Press ~+V to copy the information from the Clipboard to the text box.
Figure 28.7 shows the completed text box.
Letter Wlzord

lvPI 1111 .... r,tonl's Mmt ond aodms.
CM:r ul Smithee
987 Wl1clflwer Ln

c.- Park, CA 9130~

Finishing the Letter Wizard
To finish the interactive portion of creating a letter, fill out other dialog
boxes in the Letter Wizard by following these steps. (Click the Next button to
move to each successive step.)
1 . After you insert the names and addresses, choose the Next button to
continue to the next dialog box.
2 . Select an option button to specify the style you want for your letter:

classic, contemporary, or typewriter.

Fig. 28.7
The information
from the Clipboard is pasted
into the text box.
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3. The Letter Wizard dialog box displays a checkered finish flag (see fig.
28.8), and then asks whether you want to create an envelope or mailing
label, display help, or display the Jetter. To create an envelope, for example, select the Create an Envelope or Mailing Label option. Click
Next to go to the next dialog. If you click Finish, you will go directly to
the end of the process and you will not have the option of creating
envelopes or mailing labels.

Fig. 28.8
To create an
envelope or
mailing label for
your letter, click
the option at the
final Letter Wizard
screen.
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Tip
You also can enter
the Envelopes and
Labels dialog box
by choosing the
Tools Envelopes
and Labels
command.

Fig. 28.9
The Wizard takes
you to the
Envelopes and
Labels dialog box,
where you can edit
addresses.

4. If you select the Create an Envelope or Mailing Label option, the Enve-

lopes and Labels dialog box appears (see fig. 28.9). The name of the
recipient appears in the Delivery Address text box, and your address
appears in the Return Address text box. If necessary, edit these entries
in the dialog box.
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5 . To create an envelope, select the Envelopes tab.

6. To create a label, select the Labels tab. In the Labels tab, you can specify

the label size, which label to print on a label sheet, and whether or not
a bar code prints with the label.
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7. Your name and address automatically appear in the Return Address text
box. If you have preprinted envelopes, click the Omit check box to
remove the return add ress.
8. To change the envelope size, add or remove a bar code, change the
fonts for the delivery or return addresses, or change the placement of
the addresses on the envelope, click the Options button.
9. To add the envelope as a separate page in your document, click the Add

to Document button. This option also enables you to preview the envelope before you print it.
10. To go directly to the printer, click the Print button.

Whether or not you print an envelope, your letter appears with the current
date and the recipient's information. Throughout the letter, information that
you need to replace is indicated by brackets and italics, as shown in figure
28.10. Highlight the markers, including the brackets, and type your replacement text.

v
Fig. 28.10
Highlight [Recipient] and type the
salutation for the
letter.

Sep!Mrb« 2, 1994
ChtfyiSm~

997 Wllctlowor Ln

canoqa PaiiC, CA 91306

Copying Information from the Note
Pad to Word
You can copy items from the Note Pad into your letter. Choose Note Pad
from the Apple menu to open the Note Pad.

/
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To place the information in the Clipboard, follow these steps:
1. In the Notepad document, select the text you want to copy.
2. Choose the Copy command from the Edit menu or pres

~+C.

Note
To remove the information from the Notepad and place it in the Clipboard, choose
the Cut command in the Edit menu or press ~+X.

To copy the information from the Clipboard to your Word document, follow
these steps:
1. Return to the Word document by clicking the Word document on the

screen, or by using the application menu.
2. In your document, position the insertion point where you want to
place the copy.

lfftl

3. Choose the Paste command from the Edit menu, or pres

~+V.

Using the Styles from the Letter
Wizard
<Ill See "Format-

ting with
Styles," p. 182

When you use a template or wizard, more than just text comes with the
document. Styles, glossary items, and macros are added to the normal template entries to give you added flexibility in creating your documents. The
first item in the Formatting toolbar shows you the current style for theselected text. Figure 28.11 shows that Return Address is the style when the
insertion point is in the letter's return address.
If you select the date, address, or body of the letter, the style changes to Date,

Address, or Body Text, respectively. You can apply a style by selecting the
text, clicking the Style pull-down arrow, and selecting the style. In this
case, the Lead-in Emphasis style was selected.

Copying Text between Word Documents
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Fig. 28.11
The Letter Wizard
adds a returnaddress style and
uses it for the
return address.
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In this example, return was pressed between each question and changed the
style back to the default style, Normal. To return to the Normal style, press
):t+Shilt+N.

Copying Text between Word
Documents
The information for you r documen ts may be scattered throughout existing
documents. Learning how to copy text between documents is worthwhile if
you dislike typing the same thing repeatedly.

Opening Word Documents
Part of the process of working with mul tiple documents in Word is opening
those documents. You can open each document separately by choosing the
Open command from the File menu, and you can have multiple documents
open at the same time.
To open more than one document, follow these steps:
1. Choose the Open command from the File menu. The Open dialog box

appears.
2 . If necessary, naviga te to the appropriate folder and drive in the Open
File dialog box.

<1111

See "Switching
between
Documents,"
p. 79

/
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3. Select a file.
4. Click the Open button. The selected file will open.
5. Repeat steps 1-4 for each document you wish to open.

Switching between Documents
When you have several documents open, you need to switch between the
documents to copy information between them.
To switch between open documents in Word, do one of the following:
• Select one of the documents from the bottom of the Window menu.
• Press

~+F6

to cycle through the open documents.

Copying Information from One Word Document to
Another
After you open your documents, you can copy information between them.
Use the Clipboard method described in this section or the drag-and-drop
feature mentioned in the section, "Using Drag and Drop to Copy Information
between Documents," later in this chapter.
<1111

See "Copying
and Moving,"
p.43

To copy information between documents, follow these steps:
1. Select the text you want to copy.

2. Choose the Edit Copy command or press

~+C.

3. Switch to the document that is to receive the copy, and position the
insertion point where you want to place the copy.
4. Choose the Edit Paste command or press ):(+V.

After you copy the text into your document, you may have to reformat the
text so it matches the surrounding text.
Note

<1111

See "Copying
Formats,"
p. 110

The Format Painter button is handy for copying formats. Position the insertion point
within the text that has the format you want, and click the Format Painter button.
Drag the mouse-pointer 1-beam across the text you want to change. When you
release the mouse button, the selected text changes format.

Copying Text between Word Documents
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Tip

Note
When you use the normal paste procedure in step 4, the text retains some form atting
from the original document. If you want the text to assume the formatting of the
text at the insertion point in your target document, choose the Paste Special command, and then select the Unformatted Text option in the Paste Special dialog box.

Arranging Documents

You can point to
selected text,
press control,
and hold down
the mo use button to display a
shortcut menu
that lets you cut,
copy, and paste.

If you want to see more than one document at a time, you can display parts

of each document window.
To arrange the documents, follow these steps:
1. Open the documents you want to view.

v

2. Choose the Arrange All command from the Window menu. The docu-

ments are tiled within the window, as shown in figure 28.12.
Fig. 28.12
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3. To change the size or shape of the window, click and drag in a
window's resize box.
4. To move a window, drag the title bar.

Two documents,
17 AR.TN rev and
NAVGSAW
sponsor letter, are
open and visible.
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Using Drag-and-Drop to Copy Information
between Documents
When you have more than one document visible, you can drag text between
the two documents.
To move or copy information with drag and drop, follow these steps:
1. Select the text you want to move or copy.
<1111

See "Moving
Data with
Drag-andDrop," p. 257

2. Position the mouse pointer in the middle of the selected text.

3. To move the text, drag the mouse pointer.
To copy text, hold down the option key and drag the mouse pointer.
The mouse pointer changes as you drag, as shown in figure 28.13.

Fig. 28.13
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4. Drag the text into the new window to receive the copy. The gray

vertical bar indicates the position of the new text.
5. Release the mouse button to complete the copy procedure.

Note
Use the same drag-and-drop procedure when you move or copy text within the
same document.

Copying Spreadsheet Information

Troubleshooting
When I copy information with drag and drop, the original document loses its information.
You used the move feature instead. Make sure that you hold down the ):( key
throughout the process. Release the mouse button first, and then release the):( key.

My copied text appears in the middle of existing text.
Don't forget to watch the gray dashed line that is part of the mouse pointer. This line
shows where the copied text will be inserted.

I get a black circle with a slash through it when I try to copy.
The black circle with the slash on the title bar or status bar indicates that you cannot
drop as you drag the mouse with a copy. Make sure you go all the way into the other
document before you release the mouse button.

Copying Spreadsheet Information
The procedure for copying information from an Excel spreadsheet to a Word
document is essentially the same as copying between two Word documents.
Select the area you want to copy, choose the Copy command from the Edit
menu, move to the location where you want the copy to appear, and choose
the Paste command.

Copying from Excel to Word
To copy information from an Excel worksheet to a Word document, follow
these steps:
1. Choose Excel from the Microsoft Office Manager menu.

2. Choose the Open command from the File menu, or press )::(+0.
3. Select the name of the file you want to open, and click OK.
4. To select the range you want to copy, do one of the following:

• With the thick white-cross mouse pointer, drag across the range
to copy, as shown in figure 28.14.
• Hold down the shift key and use the arrow keys to highlight the
range.
5. Choose the Copy command from the Edit menu or press ):C+C.
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Fig. 28.14
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Caution
Be careful when you drag the mouse pointer. Make sure that it is a thick white
cross and not an arrow (used for drag-and-drop) or a black plus sign (used for
automatic fi ll).

....

See "Selecting
Cells and
Ranges," p. 237

6. Return to the Word document by using the Microsoft Office Manager
m enu or the application m enu.

7. Position the insertion point where you wa nt the spreadsheet information to appear.

liJ

8. Choose the Paste command from the Edit menu or press ~+V.
Note
When you perform a normal paste operation in step 8, the information goes into a
table in Word, as shown in figure 28.15. The light gray grid lines do not print. If you
want additional lines to appear, choose the Format Borders and Shading command.
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Fig. 28.15
To change your
columns in Word,
drag the column
marker.

,....---- Column marker

v
Using Paste Special with a Spreadsheet
If you don't want text to appear in a table in your Word document, you can
use the Paste Special option . To use Paste Special with spreadsheet data in the
Clipboard, choose the Paste Special command from the Edit menu. The Paste
Special dialog box appears, as shown in figure 28.16.
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See "Working
with Tables,"
p. 196

Fig. 28.16
Select one of the
options in the
Paste Special
dialog box to
format your text.
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The options in the Paste Special dialog box enable you to link, embed, or
specify a format for the spreadsheet. You can do any of the following:
• To link information to the spreadsheet, select the Paste Link option.
• To insert the Excel spreadsheet as an object, select Microsoft Excel 5.0
Worksheet Object.

..,.. See "Linking
an Excel
Worksheet
to a Word
Document,"
p. 611
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• To insert the spreadsheet as a table in your Word document (the default
wh en you choose the Edit Paste command), select the Formatted Text
(RTF) option.
• To insert the spreadsheet with tabs separating data that was in columns,
as shown in figure 28.17, select the Unformatted Text option. If you
select this option, you probably will have to select the data and change
the tabs if you want the information to align.

Fig. 28.17
When you copy
information from
the spreadsheet,
set a tab stop to
separate the items
that were in
columns in the
worksheet.
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Total
$ 260,190
a tab stop

_. See "Setting
Tabs,"p. 115

• To insert the spreadsheet as a graphic, select the Picture option in the
As list box. To edit the picture, first select the picture to display the
small black handles. To resize the picture, point to one of the handles
until the mouse pointer changes to a double-headed black arrow, and
then drag. To move the picture up or down in the document, drag the
drag-and-drop white arrow and rectangle mouse pointer.

Copying Pictures from PowerPoint
In addition to copying text or data, you may want to copy a picture from
PowerPoint or a chart from Excel. The procedure is essentially the same: select the object, choose the Copy command from the Edit menu, and then
choose the Paste command from the Edit menu.

Copying Pictures from PowerPoint
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To copy a PowerPoint picture, follow these steps:
1. Switch to PowerPoint by using the Office Manager menu.
2 . If necessary, choose the Open command from the File menu to open

the presentation.
3. Go to the next slide in your presentation by clicking the Next Slide or
Preview Slide buttons (double arrows) in the scroll bar, or by using the
Slide Sorter View button and double-clicking the slide you want.
Fig. 28.18
The black handles
show that the
object is selected
and ready to copy.

v

LAMG General Meetings
CD-ROM Software Night

~

4. Click the object to copy. Black handles surround the object to show
that it is selected.
5. Choose the Copy command from the Edit menu or press ):(+C.
6 . Return to the position in your Word document where you want to

place the copy.
7. Choose the Paste command from the Edit menu or press ):(+V.
The picture appears in your Word document.
The Paste Special option does not do anything different from the Edit Paste
command. You cannot link or embed the object with Paste Special.

See "Moving
Through a
Presentation,"
p.439
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To select the picture, click the picture. To change the size of the picture in
Word, drag a handle. To move the picture vertically in the document, drag it
to the new position. To move the picture vertically or have text wrap around
the object, however, you need to frame the picture first, as described in the
following section.

Framing a Picture
When you paste a PowerPoint picture or an Excel chart, or select Picture or
Bitmap in the Paste Special dialog box, the graphic is one object in your
Word document. For better control in positioning the object, you can frame
it. Figure 28.19 shows an unframed picture object in page layout view. Text
does n ot wrap around th e picture, and you cannot move it horizontally on
the page.
Fig. 28.19

In this example,
the picture had to
be made smaller.
Notice the text
does not wrap
around the picture.
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To frame a picture, follow these steps:
1. Select the object.
2. Click the Frame button in the Drawing toolbar or choose the Insert

Frame command.
3. Choose Yes if the program prompts you to go to page layout view.
You'll see this prompt if you are not already in page layout view.
When the object is framed, you can move it horizontally on the page and
position text to the left or right of the object. To edit the properties of the

From Here...

frame, choose the Format Frame command. You can specify whether you
want text to wrap around the picture, set the size and location of the picture,
or remove the frame.

From Here ...
This chapter focuses on copying information from different sources into a
Word document. In some cases, you may want to link information instead.
This added capability means that when the source document changes, the
link automatically updates the target document. For more information, refer
to the following chapters:
11

• Chapter 29, Sharing Data between Applications with Linking and Embedding," focuses on linking information so that the document remains
updated.
• Chapter 31, Using Mail with Other Microsoft Office Products," shows
you how to pass documents among different users on your network.
11

• Chapter 33, "Sending a Mass Mailing," shows how you can avoid typing the name and address in every letter by using your existing Excel
spreadsheet.
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Chapter 29

by Tom Negrino

Earlier chapters in this part of the book assume you are working for a new
nonprofit organization and suggest ways you can use Microsoft Office. As
part of your work, you have already created a variety of documents explaining the organization and its goals. Many parts of the existing documents
could be useful for requests for information and for other reports and documents that may need to be created. Those who would need the information
include prospective donors, sponsors, participating organizations, the press,
parents, schools, prospective scholarship recipients, event attendees, paid
staff, volunteers, the executive director, and the board of directors. Trying to
provide information to everyone is a huge task. By using Microsoft Office's
capabilities to link and embed information, you can streamline the task of
supplying information to a diverse audience.
In this chapter, you learn to
• Link information between documents

• Update links
• Edit links
• Embed information within documents
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Moving beyond Copy and Paste to
Link Information
You also may have documents or portions of documents that you need to use
over and over. With Microsoft Office applications, you have different options
to accom plish the same task. The first option is a simple copy and paste.
Whenever you need information from one document, open the document
and select and copy the information. Then open the second document and
paste the information at the appropriate point.
~

See "Copying
Text betvveen
Word Documents," p. 589

Although the copy and paste procedure is the easiest to master, there are two
drawbacks. First, if the original information changes, you have to continually
repeat the procedure if you want to keep your documents current. The second
drawback is you have to remember the application that created the info rmation and where you put the files. If you want to edit the data, you may have
to return to the original application.
To overcome these drawbacks, you have additional options for sharing data
between files (and applications). One option is to create a link between two
files. Whenever the data in the source file changes, the destination file will
receive the update. The technical term for this is dynamic data exchange or
DDE.
Note
This chapter describes the source application and document as the application and
file on disk that supply data. The destination or target application and document is
the application and the file o n disk that receive the data.

Using Embedding to Link
Information
Another option is to embed the information into your destination document.
When you embed the information, you can use the source application to
update the information. You have two ways to get to the tools (menus and

Using Embedding to Link Information
toolbars) of the source application. You can launch the source application
from within the destination document, and a window appears with the
source application showing the information to edit. The other possibility is
new for Microsoft Office 4.2 applications. This is called in-place editing. When
you select the object to edit, your menu and toolbar change to the source
application, but you remain in the document and can see the surrounding
text or data. The technical term for this kind of sharing is object linking and
embedding (OLE). If you can edit the data without leaving the destination, the
source application is OLE 2.0 compliant.
Note

·

This chapter mentions objects. An object can be text, a chart, table, picture, equation, or any other form of information that you create and edit, usually with an application different from your source application.

One difference between linking and embedding is where the information is
stored. Linked information is stored in the source document. The destination
contains only a code that supplies the name of the source application, document, and the portion of the document. Embedded information is stored in
the destination document.
In some cases, you cannot launch the source application by itself; you have
to use your destination application to start the application. These applications are called applets (small applications) and include WordArt, Microsoft
Graph, and others.
You may want to look at your existing documents and see if you will continually use different portions in other documents. Table 29.1 shows lists of
the existing available documents for your organization. Suppose, as the office
manager, you use Excel to list the original document and divide the document into parts that might be used in multiple documents. You decide it
would be better to create separate documents for each frequently used part of
a larger document. You also include a column for which application might be
best for the subdocuments.

<Ill
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See "Embedding
the Chart," p.
204
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Table 29.1 Portions of Documents That Can Be Linked with Other
Applications
.
Portion of Document
That Can Be
Used Elsewhere

Proposed
Application

Business Plan Logo

PowerPoint

Will this change in many
documents?

Purpose

Word

Queries, brochure, many documents

New-chapter networking

Word

Also instruct new chapters

Timeline for development

Word

Goals, manage timeline, board
notes

Geographic development

Word

Goals, board notes

Distribution of funds

Excel

Goals, board notes

Reasons to donate

Word

Donors, sponsor presentations,
brochure

Benefits to your company

Word

Sponsor presentation, brochure

History

Word

Queries, press release, brochure

Equipment needed
for startup

Excel

Need to update as new numbers,
info received

Orgchart

Organization
Chart

Will change; board notes

Budget

Excel

Summary, internal management,
board notes

Factsheet
Logo

PowerPoint

Will this change in many
documents?

Purpose

Word

Queries, brochure, many
documents

Eligibility

Word

New-chapter notices, scholarship
queries

Scholarship amount

Word

New-chapter notices, scholarship
queries

Submission process

Word

New-chapter notices, scholarship
queries

Where Else Needed

Using Common Steps to Link Documents

Using Common Steps to Link
Documents
The procedure for linking any kind of application to any other application is
essentially the same regardless of the source or destination application. You
copy the source into the Clipboard and then use the Link option in the Paste
Special dialog box to create the link. In the Paste Special dialog box, you also
can specify the type of format in which the information is presented.
In some cases, you may not be able to use the Paste Special dialog box to
create the link. To link a PowerPoint slide to a Word document, for example,
you may have to use the Insert Object dialog box to create the link. This
procedure is described in "Linking a PowerPoint Picture to a Word Document" later in this chapter.
To copy an item to the Clipboard and link the item to another document,
follow these steps:
1. Select the item in the source document.

2. Open the Edit menu and choose the Copy command or press ):(+C.
3. Move to the target application and document. Position the insertion
point where you want the link to appear.
4. Open the Edit menu and choose the Paste Special command. A Paste

Special dialog box appears, as shown in figure 29 .1.
Several format types may be available, depending on the source application. Two options usually are available: Paste and Paste Link. The Link
option is grayed if the source document for the selected format cannot
be linked.
5. Select a format option in the As list box.
6. Select Paste Link.
7. Click OK.
The As list box shows different formats. These formats change, depending on
the source and target applications. In general, four different formats appear in
most links. One of the formats usually is Object. In figure 29.1, the specific
format is Microsoft Word 6.0 Document Object. When you insert, or embed,
an object, you can double-dick the object or its icon (if the Display as Icon
option is active) and then edit the object with the source application.

lliJ
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Fig. 29.1
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Another format option is Formatted Text. This option means that the object
appears in your target document with most of the formatting (fonts, borders,
and so on) from the source document. This option is different from Unformatted Text, in which the text takes on the format of the target document.
The last option is to add a picture of the document. Whether the original
document is a picture or text, the link becomes a picture, and you can size
and move the picture as one item.

Linking Two Word Documents
When you want to link two Word documents, you can use Paste Special to
create the link, or you can use the Insert File feature. To insert a portion of a
file, use the Paste Special feature, which is helpful if the source document is
not a complete paragraph. To insert an entire document, use the Insert File
feature.
To link two Word documents, follow the steps in the preceding section, "Using Common Steps To Link Documents." Select and copy the text you want
to link, and then move to your target document. Open the Edit menu, and
choose Paste Special. In the Paste Special dialog box, select the Unformatted
Text option in the As list box to enable the linked text in the target document to assume the format of the target document.
Table 29.1 shows that the purpose for Org Name TK is mentioned in the business plan, fact sheet, and in most other documents. As office manager for Org
Name TK, you may want the changes to be updated in all documents containing the purpose. Therefore, you might create the separate document

Linking Two Word Documents
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"Purpose" to describe the purpose of Org Name TK. Because the text is formatted diffe rently in the documents, you would link the text using the
Unformatted Text option in the As list box of the Paste Special dialog box.

Displaying the Link
When you move within the linked section, as shown in figu re 29.2, the link
is highlighted in gray. Although you can edit the li nked text, the editing
changes disappear when the link is updated (wh en you open the file again;
print the file; or press F9, the Update Field sh ortcut key). The gray highlight
reminds you not to edit this part of the document. If the link is not highlighted, open the Tools menu, choose the Options command, and then select
the View tab. In the Field Shading pop-up menu, select When Selected or
Always.

[iJ • I

Fig. 29.2
The lin ked area in
the documen t is
high lighted in
gray.

• , •
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If you want to see the name of the source document, you can display the
field name codes rather than the actual text. Open the Tools menu and
choose the Options command. In the View tab, select the Field Codes option .
(To display the text, deselect Field Codes.) Figure 29.3 shows field code used
in place of text.
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Fig. 29.3
Field code used in
place of text.
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Troubleshooting
Changes in my source document oren 't reflected in my destination document.
The link may be an automatic link or may require manual updating (see the section
on updating links). You also can do the following:
To update any manual links, go to each field code by pressing Fll. To update the
code or link, press F9 or ):(+shift+option-U.
To make sure your document updates any automatic links when you open the file,
Open the Tools menu and choose the Options command. In the General tab, make
sure Update Automatic Links on Open is active.
To make sure your document prints with the latest information, open the Tools menu
and choose the Options command. In the Print tab, make sure Update Links is active.

Editing Links
When you link a document, you must keep both the document name and
the document in the same location (drive and folder) . If you rename, delete,
or move a document, the link is broken, and you get an error in your destination document. In some cases, you can break the lin k so that the source
document is inserted into the target document without a link; in other cases,
you can change the name of the source document.

Inserting a File into a Document
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To change links, follow these steps:
1. In Word, open the Edi t menu and ch oose the Links command (be sure

th e insert ion point is in the target document, not the source document). The Links dialog box appears, as shown in figure 29.4.
links
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Fig. 29.4
The Links dialog
box allows you to
update, change, or
break links.

~Ptolur.tnOtedllltnl

v
2 . Select the files in the Source file list box.
3. Do one or more of the following:
• Click the Update Now button to update the link with any changes
in the source file.
• Click the Change Source button to change the file name or location of the linked file in the Change Source dialog box.
• Click the Break Link button to insert th e object into the document and unlin k it. When Word displays a message box, asking
whether you are sure you want to break the selected links, choose
Yes.
4. Click OK when you finish .

Inserting a File into a Document
You also can link documents by using the Insert File feature, which enables
you to insert the entire file, rather than just a part of the file. When you use
Paste Special to link a file, you can only insert text before or after the sourcedocument information, so the target document does not include the entire
text. Insert File alleviates this problem . The file you insert can be from the
same application or a differe nt application .
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To insert a file into a document, follow these steps:
1 . Move to the position in the target document where you want to insert
the file.
2. Choose the Insert File command. The File dialog box appears, as shown
in figure 29.5.

Fig. 29.5
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3. Identify the file you want to insert, including the drive and directory if
necessary.
4. Select the Link to File option.
5. Click OK.

As in the Paste Special example earlier in this chapter, you can display the
linked document with a gray highlight or show the field codes. In figure 29.6,
the revised business plan document shows field codes for the linked documents.
Note
If you want to insert several documents into a single larger document, give your
documents a consistent appearance by using the same formats for each one. You
also can use templates and styles to help ensure consistency among documents. For
more information, see "Formatting with Styles" in Chapter 9, "Working with large
Documents."

Linking an Excel Worksheet to a Word Document
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Fig. 29.6
The field code
INCLUDETEXT
appears for the
Word documents
Title TK, Title TK,
and Title TK.
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Linking an Excel Worksheet to a
Word Document
The procedure for linking a range or an entire Excel worksheet to a Word
document is the same as for linking Word documents. You can use either the
Paste Special command or the Insert File command, although it's easier to
format a document when you use the Paste Special command. When you use
the Insert File command, the resulting table sometimes is hard to center on
the page because of extra space for the last column or extra cells. In the Paste
Special dialog box, you have the same formatting choices when you Paste
Link as when you Paste (see fig. 29.7).

_. See "Copy
ing Text Between Word
Documents,"
p.589
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The following list describes the formatting options in the Paste Special dialog
box shown in figure 29.7. The results appear in figure 29 .8.
• To insert the Excel spreadsheet as an object, select Microsoft Excel 5.0
Worksheet Object. In a Word document, when you double-click the
object, you enter the application that created the object. You then can
edit the object, using the source application's menus, toolbars, and
other commands.
• To insert the spreadsheet as a table in your Word document (the default
choice when you choose the Edit Paste command), select Formatted
Text (RTF). You may need to change the column widths for the table to
line up properly, as is the case in figure 29 .8.
• To insert the spreadsheet with tabs separating data, choose Unformatted Text. You may have to select the data and change the tabs for
the selection if you want the information to align.
.. See "Working
with Graphics,"
p.205

• To insert the spreadsheet as a graphic, select Picture. This option inserts
the spreadsheet as a diagram. In figure 29 .8, however, there is almost no
discernible difference between Microsoft ExcelS.O Worksheet, Object,
and Picture. In fact, these three options perform the same function:
they all insert a picture into the Word document, and you can doubleclick all three options to go to Excel to edit the object. To edit the picture, first select the picture to show the small square handles. To resize
the picture, point to one of the handles until the mouse pointer
changes to a small double-headed black arrow; then drag. To move the
picture up or down in the document, drag the drag-and-drop white
arrow and rectangle mouse pointer. To go to Excel to change the data,
double-click the picture.
Suppose you need to create a quarterly report which contains text, Excel
worksheets, and Excel charts. To do this, you would begin by inserting some
introductory text at the beginning of the report which includes the purpose
and history of the organization. You would then link the "Purpose" and "History" Word documents to the quarterly report file. In order to report on the
donations for the first three months, you might want to show the amount in
a table, a pie chart by type of donation, and a bar chart of donations by
month.
Figure 29.9 shows a formatted Excel worksheet. Because the numbers will
change, you will want to link rather than paste the worksheet and the charts.

Linking an Excel Worksheet to a Word Document
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Fig. 29.8
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To copy this worksheet into a Word document, follow these steps:
1. In Excel, highlight the range to be linked (Al:E6).
2 . Choose Copy from the Edit menu or press

~+C.

v
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See "Switching
between Applications," p. 81

3. Switch to Word.
4. Choose Paste Special from the Edit menu. The Paste Special dialog box
appears.
5 . Select Paste Link and As Picture. Click OK. The result appears in figure
29.10. Notice the picture is left-justified .

Fig. 29.10
The worksheet
picture appears
left-justified in the
Word document.
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6. If you want to center the worksheet, select the picture and then click
the Center button.

Linking an Excel Chart to a Word
Document
~

See "Creating a
Chart with the
ChartWizard,"
p.338

Suppose you want to add a pie chart and bar chart to this page in your
quarterly report document. You can create charts quickly by clicking the
ChartWizard button in Excel's Standard toolbar.

Linking an Excel Chart to a Word Document
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Creating a Pie Chart
To create a pie chart, follow these steps:
1. Drag the white-cross mouse pointer to highlight the titles in A3 to AS.
2. Hold down the

~

key and drag to highlight E3 to ES.

3. Click the ChartWiza rd button. The mouse pointer changes to a graph
and a plus sign, as shown in figure 29 .11.
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4. Click SheetZ to draw the chart where you want it.
S. Drag from the top-left corner to the bottom-right corner of the range

where you want the chart to appear. The ChartWizard dialog box appears, displaying five steps.
6 . Choose Next to go to the Step 2 ChartWizard dialog box.

7. Select 3-D Pie, and then click the Next button, as shown in figure 29.12.
8. Click Next until you get to the StepS ChartWizard dialog box. Type

Donations YTD in the Chart Title text box, and then choose Finish.
The chart appears in the second sheet of the workbook, as shown in
figure 29.13.

~

Fig. 29.11
After you select
the ranges for your
chart and click the
ChartWizard
button, the mouse
pointer changes to
a graph-and-plussign icon.
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Fig. 29.12

ChertWIZDrd - St ep 2 of S

The ChartWizard
dialog boxes
enable you to
select chart types
and other settings.

Fig. 29.13
The chart appears
in Sheet2,
surrounded by
handles.

9 . You can copy the chart the same way you do a range. Because the chart

already is selected (handles surround the chart), choose the Copy command from the Edit menu or press :l=e+C.
10. Return to the quarterly report document.

11 . Open the Edit menu and choose the Paste Special command. The Paste

Special dialog box appears.

Linking an Excel Chart to a Word Document
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12. Select Picture and Paste Link. Click OK. The chart appears in the Word

document, surrounded by handles. If the handles do not appear, click
the picture.
13. Open the Format menu and choose the Paragraph command. In the
Indents and Spacing Tab, select Center from the Alignment pop-up
menu, or press :1=e+E to center the picture.

Creating a Bar Chart
To create a bar chart, follow these steps:
1. Drag the white-cross mouse pointer to highlight the range A2

through OS.
2. Click the ChartWizard button.

v

3. Move to Sheet3, and highlight the range where the chart will appear.
4. Fill in the ChartWizard dialog boxes, including the 3-D column chart in
Step 2 and format 4 in Step 3, and type Donations by Month in the

Chart Title text box in StepS. After you finish the ChartWizard dialog
boxes, the chart is selected, with handles.
5. Open the Edit menu and choose the Copy command, or press ):t;+C.
6. Return to the quarterly report document.

7. Open the Edit menu and choose the Paste Special command. The Paste

Special dialog box appears.
8. ln the As list box, select Picture, and select the Paste Link option.

Choose OK. The chart appears in the Word document, with handles.
The third diagram on the page from the quarterly report is shown in figure
29.14. When the final numbers come in, simply go to the Excel range and
edit them. Figure 29.15 shows an updated Word document with the new
number (15,000) for March corporate donations.
Note
To remove the border surrounding the charts, change the charts in Excel rather than
Word. In Excel, click to select the chart. In the middle of the chart, hold down the
control key and choose Format Object from the shortcut menu. In the Patterns tab,
select None in the Border section.

1\®D
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Fig. 29.14

Gramercy Project Donations
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Word document.

Donations YTD
Corporate
11%

Individual
39%

Donations by Month
10,000
• Individual
• Events
DCorporate

5 ,000

0
Jan

Feb

Mar

Linking an Excel Chart to a Word Document

Gramercy Project Donations

Fig. 29.15
After you update the Excel
worksheet, the
changes occur
in the Word
document.
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Linking a PowerPoint Picture to a
Word Document
<1111

See "Adding,
Inserting, and
Deleting
Slides," p. 439

Suppose you went through your documents and noticed the organization
logo was on almost every document. If this was an established organization,
simply pasting the logo would be appropriate. However, linking the logo may
be inappropriate if there is a chance that the logo might ch ange. If you want
to link a PowerPoint slide to a Word document, the Paste Special command
does not allow you to choose the Paste Link option . Insert File also does not
have a PowerPoint option. To do the link you need to use the Insert Object
command, and the first slide of the presentation must be the picture you
want to link.
To create your PowerPoint slide, follow these steps:
1. Go to PowerPoint.

2. To insert pictures into your slide, choose the Insert Clip Art command
(if the picture is part of Microsoft ClipArt Gallery) or the Insert Picture
command (if you got the picture from another source).
3. To type text, click the Text tool. Then click the location in the document where you want to add text, and type.
4. To create rotated text, click the Free Rotate tool, and drag the mouse

pointer as shown in figure 29.16.
Fig. 29.16
Click the Free
Rotate tool, and
drag the top right
handle to change
the orientation of
the text.
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5. Save the document.

To link a PowerPoint slide to Word, follow these steps:
1. Create a PowerPoint slide with a picture and/or text you want to link to
you r Word document.
2 . Save the PowerPoint presentation.
3. Go to the location in your Word document where you want to position

the picture.
4 . Choose the Insert Object command. The Object dialog box appears, as

shown in figure 29.17.
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5. Click the Create from File tab, and select the file name.
6. Select the Link to File option, and then click OK.

The picture appears in your Word document. You can resize the picture by
dragging the handles. To move the picture horizontally, you need to frame
the picture. Choose the Insert Frame command. If you are prompted, choose
Yes to go to page layout view. When the picture is in a frame, you can drag
the frame to position the picture. You also can use the Frame command in
the Format menu, and indicate where you want to position the picture (such
as centered horizontally or vertically on the page) and whether text should
wrap around the picture. Figure 29.18 shows the picture in a document.

You use the
Object dialog box
to select the type
of information
you want to
insert.

V
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Fig. 29.18
The PowerPoint
slide inserted into
a Word document.
Attend any of more than two dozen monthly
meetings, including the General Meeting, which
showcases major vendors and their newest
software and hardware products.

LAMG General Meetings
CD-ROM Software Night

If your PowerPoint presentation is more than one slide, you can double-click

the picture in Word, and you will launch PowerPoint or the PowerPoint presentation. If you launch PowerPoint, you can edit the slide. If you launch the
presentation, you can play the presentation by clicking each slide to move to
the next slide.
To change the object to a PowerPoint presentation within Word, follow these
steps:
1. Select the PowerPoint object.
2. Choose Edit.

3. Choose MS PowerPoint 4.0 Slide Object.
4. Choose Convert. The Convert Object dialog box appears.
5. Select the Convert To option, select MS PowerPoint 4.0 Presentation,

and click OK.

Linking Data between Excel
Worksheets
In some cases, you may want to repeat text or data in an Excel worksheet.
For example, you may want to include a summary of actual numbers on a

Linking Data between Excel Worksheets
separate sheet of the workbook. You can copy the labels and numbers, or you
can create a formula to copy the text and values. If you link through a formula, when the numbers or labels in the source part of the document
change, they also change in the target part of the document.

~
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See "Linking
Formulas,"
p. 313

The formula is simple: type an equal sign (=), move to the cell you want to
copy, and press return. The cell you want to link can be in the same sheet, in
a different sheet of the same workbook, or in a different workbook file. Figure
29.19 shows an example. The budget worksheet on the left contains monthly
numbers. To see only the categories and the year totals, you could hide
columns or create the formula.
Fig . 29 .1 9
After you link the
cell, the reference
contains the file
name, the sheet
name, and an
absolute reference
to the cell ($A$3).

To link the worksheets, follow these steps:
1 . Choose New from the File menu to create a blank worksheet, and type
Budget 1994 in cell Al.
2. Move to cell A3, and type =.
3 . Move to the source worksheet (identified as "Budget" in the Org Name

TK example).
4 . Click A3 in the "Budget" worksheet, and then press return.

Notice in figure 29.19 that when you use this method, the reference to the
cells includes the file name (Budget), the sheet name (Budget!), and an

[QJ

V
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See "Creating
Formulas;" p.
297

absolute reference to the cell ($A$3). If you want to copy the information, as
in this example, remove the dollar signs to make the reference absolute. Then
you can copy cell A3 from A4 through All to link the other cells. Notice in
figure 29.20 that the cell reference has no dollar signs (A3).

Fig. 29.20
To copy the cell
information,
change the
reference so no
dollar signs
appear, as shown
in the edit line
(A3).

I

Note
To arrange your worksheets side by side, as shown in figure 29.19, choose the
Arrange command from the Window menu, and then select the Tiled option in the
Arrange Window dialog box. You don't have to arrange your worksheets this way,
however; you could move to the other worksheet by choosing the document name
from the bottom of the Window menu.

The formula automatically contains the file name (if the reference is to a cell
in a different workbook), the sheet name (if the reference is to another sheet),
and the cell name. The default formula includes dollar signs; thls means if
you copy the formula, the reference does not change. In the example, payroll
would be in every cell in column A. Delete the dollar signs so the copy will
work correctly.

Embedding Information in Your Documents
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Embedding Information in Your
Documents
As mentioned at the beginning of the chapter, in addition to linking information, you can embed information within a document. When you embed
an object, the information resides in the destination document, but the
source application's tools are available for use in editing.
You can use any of the following methods to embed information in a document:
• Copy the information to the Clipboard, open the Edit menu and
choose Paste Special, and select an object format. (This method was
discussed earlier in this chapter in the section 11 Using Common Steps
To Link Documents," along with other Paste Special formats.)
• Arrange two windows side-by-side, and use drag-and-drop to copy
information between the applications.
• Open the Insert menu and choose Object, and open an existing file.
(This method was discussed in 11 lnserting a File into a Document"
earlier in this chapter.)
• Choose Object from the Insert menu, and create a new object.
The following section will describe this method.

Inserting a New Object Into Your Document
If you want to use the features of another application in your document, you

can open the Insert menu, choose the Object command and select an application from a list. In addition to the standard Microsoft Office applications,
the list contains applets and some other Microsoft applications. Applets are
small applications that cannot be run by themselves. When you purchase an
application, one or more applets may be available.
Following is a list of applets that come with Microsoft Office. If you purchased your applications separately, you may not have all the applets.

~

See "Moving
with Drag and

Drop," p. 44
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Applet

Use

Microsoft WordArt

To create logos and other special text effects

Microsoft Equation

To create mathematical expressions

Microsoft Graph

To insert charts from data in a Word table

Microsoft ClipArt Gallery

To insert clip-art pictures

Microsoft Organization Chart

To create organization charts

To use the tools from anoth er application or applet within your document to
create a new object, follow these steps:

1. Position the insertion point in the destination docu ment.
2 . Open the Insert menu and choose Object. The Object dialog box
appears, as shown in fig ure 29.21.
Fig. 29.21
The Insert Object
dialog box lists
applets as well as
Office applications.

Object
ObjtctTvpe:
Mtcrnort ttl pArt Gellen~

Mfel'""n EquaHon z.o
MlcrO>Ofl El<e<l 5.0 Chert
Miero,on Exeel 5.0 Worb~t
Mlcr030tl Graph 50
Miercson Movie

:l!

M{erCDGft WordAr1 2 0

I

( Fro• Ftlo- )

(

.

Mier~n Yotee Annotation
Mlercnott Wo rd 6.0 Dol:ument
Mfer0300 Wo rd 6.0 Plc:tu rt

~

:n

0

ililp

l

l)japiiVO>ICOn

ollonffi
~ ....,.., • ...,MJ«osoll
Or'91MZ•tton Clur11.0 otl)tet
I'! to V*' doci.INnt.

3. In the Create New tab, select an application or applet from the Object
Type list.
4. If you want to only see an icon for the object, select the Display as Icon
option.
5. When you finish with the Object dialog box, click OK.

After you complete these steps, one of two things will occur, depending on
the exact operation you're performing. You may enter a separate window fo r
the application or the applet, as shown in figure 29.22. The other possibility
is you will remain in your destination document window, but the m enu
bar and toolbar will change to reflect the source application, as shown in
figure 29.23.

Embedding Information in Your Documents
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Fig. 29.22
When you choose
Microsoft
Organization
Chart, a separate
window opens.
After you finish
with the chart
program, choose
Quit to return
to the Word
document .

Size:

100

Thank you for your interest in The Gramercy Project. The Project is an
innovatiw hou;ing project, designed 1o serve the needs of upper- andmiddl&-incoms holii!Ovrf!rs, vhile simullamously addressing the need for
affordablo ho\ISing for the disadvantaged vho vould norrmlly not he ablo
1o considor horne ovnership. The brealtdovn of our proposed population is

liS

~·~~~

Complete the object, using the application's toolbar and menus.
When you finish creating the object, you can exit the object in either of two
ways. If you launched a separate window for the application or applet, open
the File menu and choose Quit. If you stayed in your destination document,
click outside the object.

Fig. 29.23
When you choose
Microsoft Excel
5.0, you get inplace editing. The
menu bar and
toolbar change to
Microsoft Excel,
enabling you to
use Excel features
such as the AutoSum button.
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Editing an Embedded Object
Regardless of which of the four methods you use to embed information into
your document, you can edit the embedded object with the tools of the
source application.
To edit the object, follow these steps:
1. Click the object. Handles appear around the object, and the status bar
tells you to double-click the object (see fig. 29.24).
Fig. 29.24
The status bar
displays instructions on how to
get to the sourceapplication tools.
Thank you for yoW' in1erast in The Gramercy Projecl The Project is on
innovatiw housing projec~ designed t.o serve the med.< of upper- andmiddll!-ill:omo homoovnen, vhile simultateously llddressing the lllOd for
affordable housing for the dislldvantosecl vho vould normally not be able
t.o consider homo ovnersbip. The breUdovn of OW' proposed population is
asfoUovs:

2. Double-click th e object. Depending on the source and destination ap-

plications, a separate window for the program appears, or the current
window's toolbar and menu bar change to those of the source application.
3. Complete the object, using the application's toolbar and menus.
4. When you finish creating the object, exit the object. If you launched a

separate window for the application or applet, choose Quit from the
File menu. If you stayed in your destination document, click outside
the object.

From Here...

From Here ...
This chapter showed you how to create links and embed information between different source applications and Word. Because you may need to
know the basics of the other Microsoft Office applications, you may want to
review the following chapters or continue with other sharing-information
chapters:
• Chapter 12, "Creating Worksheets," covers the fundamentals of creating an Excel worksheet.
• Chapter 20, "Creating, Saving, and Opening Presentations," shows you
how to create a slide presentation.
• Chapter 31, "Using Mail with Other Microsoft Office Products," tells
you how to use Microsoft Mail to send your files to other members of
your network.
• Chapter 33, "Sending a Mass Mailing," explains how to use database
sources to send a Word document to many people.
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As you learned in the previous chapter, an application need no longer be an
island, with the Clipboard its only method of sharing data. Today much computer work involves sharing files-by network, e-mail, bulletin board, and
fax-and we share data from one application to another. You may need to
paste a graphic into a Word file or an Excel workbook, or both Word and
Excel data into a PowerPoint presentation.
You could do a simple copy and paste to bring an Excel spreadsheet into
Word, but you also can do a live copy and paste. Both Publish and Subscribe
and Object Linking and Embedding (OLE), described in the last chaper, allow
this.
Because problems in data sharing may arise from differing file formats, this
chapter begins with a discussion of file formats. It then discusses the major
methods of data sharing between Office applications. The chapter covers the
following topics:
• Understanding file formats
• Copying and pasting via the Clipboard and the Scrapbook
• Publishing and subscribing
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Understanding File Formats
A file format is a set of conventions that determines how information is
stored. If you can read the following words: siht daer ot yrt," you are translating a foreign convention into your native convention.
11

Similarly, each Office application creates, saves, and manipulates data in its
own native file format. When you transfer data in from a different application,
the first application needs to be able to read or translate the foreign file format.
The major reason for varying format types is that different applications store
different kinds of information. Word, for example, needs to store fonts, sizes,
styles, margins, and spacing. PowerPoint uses bitmaps and vector graphics to
store line width, color and fill, and coordinates for each pixel. Excel needs to
store the widths of columns and rows, as well as numbers and formulas.
There are various ways of dealing with different file formats. With some
methods (OLE in particular), the applications take care of translating file
formats for you.

Transferring Static Data
When you want to transfer some information from one application to another, and you don't plan to update the information or share it over the network, you can choose one of the following methods of transferring data
(once the data has been transferred by these methods, it cannot be changed
except by another transfer; it is static):
• Copying and pasting via the Clipboard
• Copying and pasting via the Scrapbook

Using the Clipboard
Unless you are a brand-new Macintosh user, you probably know how to use
the Clipboard to transfer data within an application (see fig. 30.1).
If you aren't familiar with the process, here are the steps to allow you to

transfer data:
1. Select some text or a graphic, or both.

2. Open the Edit menu and choose Cut or Copy, or press ):(+X or )::t+C
from the keyboard.

Transferring Static Data
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3. Place your cursor where you want the selection to appear.
4. Choose Paste from the Edit menu, or press J:C-V from the keyboard.
~:Gi

Clipboard
These words exist on the Clipboard.

Fig. 30.1
Copied text and
graphics can be
viewed in the
Clipboard.

But even experienced users don't know-or tend to forget-that the Clipboard can transfer data between applications. They may struggle with more
difficult methods, when a simple copy and paste would do.
As a rule of thumb, when you want to do a simple transfer of static graphics
or text (or even sound and QuickTime movies) from one application to another, consider the Clipboard first.
Understanding Clipboard Formatting
When you cut text from one application and paste it into another, the pasted
copy usually retains the formatting style of the source document. But sometimes it doesn't-the font, or its size or style are changed, or you can't edit
what you've pasted. To make the results more predictable, it helps to understand how the Clipboard works.

Most applications store the data you cut or copy to the Clipboard in several
versions, each in a different format (though only one version is visible in the
Clipboard window, with the Show Clipboard command).
These formats are similar to file formats, but are designed especially for the
Clipboard. Generally, each application stores one version of the information
in its own native Clipboard format. Thus, if you paste within the same application, the information will usually retain its exact formatting.
Other versions of the information may be stored in one or more of the
following standard Clipboard formats:
• PICT. This format stores data, whether a graphic or text, as a picture

(either object-oriented or bit-mapped). Text stored in PICT format is not
editable.
• TEXT. This format stores data as text only. Text stored in this format

loses its font and style information.

v
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• sty/. This format stores data as text, complete with font and formatting

information.
•

MooV. If you have Apple's QuickTime extension installed, this format is

used to store QuickTime movie frames.
• snd. This format stores sounds, either those supplied with the system

software or those you record yourself, for transferring between applications that support sounds.
Applications store multiple versions of Clipboard data in order to give applications on the paste side of the process a chance to find a format they understand, and thus preserve as much of the original formatting as possible.
For example, when you copy cells from an Excel spreadsheet and paste them
into a Word document, one of the formats Excel uses in the Clipboard is RTF
(Rich-Text Format), an interchange format that Word understands as well.
Word chooses the copy with that format, and thus is able to paste it with the
original formatting.
To get out of the Clipboard what you put into it, the destination application
must either understand the source application's native Clipboard format, or
both applications must have another format in common.
The data is displayed in the Scrapbook in only one format, though it is probably stored in others you don't see. Therefore, the data may look as if it's incorrectly formatted. But if the application you paste into can find a format it
can read, it will restore the original formatting, or as much of the formatting
as it can read.
The Paste Special command (under the Edit menu) enables you to choose
among the available Clipboard formats (see fig. 30.2).
Fig. 30.2
The Paste Special
command will let
you paste data
in a number of
formats.
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Transferring Static Data
With the latest version of the Macintosh system software, System 7.5, the
Clipboard works more effectively with graphics than in the past. With applications that support this new power, graphics transfer more accurately and
predictably.
In addition, System 7.5 offers a new method of transferring data that is even
easier than the Clipboard-Drag-and-Drop. You can simply drag a block of
data (text, graphics, etc.) from an open document to a new location in another document-whether in the same document, the same application, or a
different application. (As when you copy rather than cut data to the Clipboard, the original data remains in place when you drag-and-drop it in a new
location. You are actually dragging a copy of the data.)
You also can drag-and-drop a selection (text, graphic, or sound) from a document onto the desktop, where it becomes a Clippings file that you can name.
Then you can drag that Clippings file directly to any new location. The Clippings file remains on the desktop so you can use it repeatedly. As with the
Scrapbook (see the section,"Using the Scrapbook," later in this chapter for
more information), Clippings files are useful for storing frequently used data,
such as your mailing address and the company logo.
Clipboard Tips and Tricks
The following are tips and tricks about using the Clipboard:

• You can transfer entire files via the Clipboard, even large ones, by just
selecting all the data. If the data exceeds what can be held in memory,
the application will save it to disk. The size of information you can
copy to the Clipboard is limited only by the space available on your
hard disk.
• You can copy the current time and date from the Alarm Clock desk
accessory and paste it at the beginning of a file.
• You can copy the results of a calculation made with the Calculator desk
accessory, then paste it.
• You can go the other direction and paste a numerical problem,
including common math symbols, from a file to the Calculator.
The Calculator's keys flash to reflect what you have pasted, and the
answer appears. Then you can paste the answer back into your file.
(The Calculator beeps for any symbol it doesn't recognize.)
• If you can record sound, you can Copy and Paste sounds.

• You can transfer QuickTime movie frames.
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• If you cut or copy something, and then realize you want what was previously held on the Clipboard, you can undo the cut or copy with ;}::(-Z,
which will return the Clipboard to its previous state.
• You can keep what is currently on the Clipboard by using the delete key
instead of the Cut command to delete unwanted items in your document. (Cut places the selected item in the Clipboard, replacing the item
stored there previously.)

Using the Scrapbook
The Scrapbook, a desk accessory normally located under the Apple menu, is
often overlooked as a means of transferring data. Unlike the Clipboard, Scrapbook data is saved to disk, and thus isn't destroyed when you paste something else or turn off the computer.
Using the Scrapbook, you can save as many text or graphics items as you
wa nt for later use (see fig. 30.3).
Fig. 30.3
The Scrapbook can
handle a variety of
data and keeps it
stored on disk

until you
remove it.

These are the rules for th e Scrapbook:
• You don't select something from the Scrapbook to cut or copy. You
simply choose Cut or Copy while the page you want to cut or copy is
displayed and the Scrapbook window is active.

Transferring "Live" Data

• Each time you paste to the Scrapbook, you add a new page to the Scrapbook. You can't paste over an existing page. What you paste affects
either the page before or the page after the one displayed.
• The number of the current page is displayed at the bottom left of the
Scrapbook window, along with the total number of pages in the Scrapbook. You use the scroll bar to display different pages.
• As explained in the section on the Clipboard, pasted data is often saved
in multiple formats. The name of the format or formats appears at the
bottom right of the Scrapbook screen.
Scrapbook Tips and Tricks
Here are some tips and tricks concerning the Scrapbook:

• What you store in the Scrapbook file is kept in the startup volume's
System folder under the name Scrapbook File. You can transfer that file
from one disk or volume to another.
• You can create and store multiple Scrapbooks and name them according to contents. For example, you might have Scrpbk.Excel and
Scrpbk.Word. Then you can use one of these files by renaming it
Scrapbook File and moving it into the System folder.
• ClickPaste by Mainstay (Camarillo, CA) is a utility that allows you to
store Scrapbook pages in hierarchical folders.
• SmartScrap by Portfolio Systems (Cupertino, CA) lets you store multiple
scrapbooks, which you can access without renaming them. You can
select any portion of a stored image for copying, name each page of
each scrapbook, search through the contents by name, and build a table
of contents with thumbnail views of each page. To open a page, you
click its thumbnail image.
In System 7.5, you can drag graphics directly from the Scrapbook into your
document, if the document is in an application that supports drag-and-drop.

Transferring 11 Live" Data
As useful as copying and pasting can be, it has one major limitation: once
information is transferred, it's disconnected from its source. If the original
information changes, you have to go back and recopy, then repaste. If the
information changes frequently or if you need to paste into multiple files,
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this can be a tedious task. It also can be unreliable because you might not
remember all the places where the information has been pasted. There's also
the constant danger involved in version control-getting the latest version to
all the affected documents.
Three other methods of exchanging data address these problems in different
ways: publish and subscribe, linking, and embedding. All three methods keep
information connected to its source in some way, and so can be considered
11
live."

Deciding on a Method
To help you decide which method of transferring live data to use in a particular situation, find the category of information you are dealing with in the
following list and read about the recommended method(s). You might also
want to see Table 30.1 for a comparison of the advantages and limitations of
the three methods.

Table 30.1

Comparison of Methods of live Data Exchange

Publish &
Subscribe

Linking (OLE 1.0)

Embedding (OLE 1.0)

Especially suitable
for information that
occurs frequently or
changes frequently,
or for networked
information

Especially suitable
for cross-reference
and other information
within the same document or group of
documents

Especially suitable
for including information created in another
application, or for documents to be transported
by floppy

Works over the
network

Doesn't work over
the network

Doesn't work over
the network

Multiple files can
be updated simultaneously

Multiple files can be
updated simultaneously

Each file containing
embedded data must be
updated individually

File sizes virtually
unaffected

Requires two files,
making transport difficult

Requires one self-contained
file, fully transportable

Data updated on
save or manually

Data updated automatically or manually

Data updated automatically

Multiple copies can be
updated simultaneously

Multiple copies can be
updated simultaneously

Each copy must be
updated individually

Source applications
not needed

All source applications
needed

All source applications
needed

Renaming or moving
source file or Edition
files OK on same hard
disk

Renaming or moving
source file can disturb
the link

Renaming or moving
source file OK anywhere

Transferring "Live" Data
Publish &
Subscribe

Linking(OLE 1.0)

Embedding (OLE 1.0)

Memory to run two
applications simultaneously not required

Memory to run two
applications simultaneously required

Memory to run two
applications simultaneously required

• Information Subject to Change.
You may create files containing information that is subject to
change, such as financial data, product descriptions, and project
schedules. To keep the files up-to-date when the original information
changes, you can use linking, or publish and subscribe. Linking is
easier, but it works only with a single Macintosh, and requires that
all source applications be available. If the information is to appear
over the network, use publish and subscribe.
• Information from Other People on the Network.
If you want to create a file that includes information created by dif-

ferent people, such as a flyer with contributions from various writers
and graphic artists, use publish and subscribe.
• Information to be Used by Other People on the Network.
If you want to create or maintain information to be used by others

over the network, such as a corporate logo, a mission statement or
slogan, and legal disclaimers, use publish and subscribe.
• Cross-References.
You may want to update cross-references automatically so that when
figures, chapters, or sections are renumbered or renamed, the references to them change accordingly. The simplest way to do this is to
use linking.
• Information for a Specific Document
You may want to create information especially for a document, using
another application. For example, within a sales report, you may
want to include a chart you would create in Excel. Use embedding to
create the information within the document.
• Information for Transporting by Floppy Disk.
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If you plan to transfer a document by using a floppy disk, and the

document has information from other sources, use embedding,
which stores all the information in a single file.

Using Publish and Subscribe
Publish and subscribe is probably System 7's most under-utilized feature.
Introduced as a "sophisticated Copy and Paste," many users seem to think it's
too sophisticated.
It may be a little more complicated than other methods, but it's worth using,
particularly if you work with information that is subject to change, or information that appears in various documents throughout an organization.
Comparing publish and subscribe to copy and paste may help explain how it
works. Instead of copying the source information, you publish it. Instead of
going to the Clipboard, and thus being held in memory, the published information goes to a special file called an Edition, which is saved on disk. Then
instead of pasting the information, you subscribe to the Edition, causing it to
appear in your document. Table 30.2 shows the similarities between the two
methods up to this point.

Table 30.2

Publish and Subscribe in Analogy to Copy and Paste

Source

Holding Area

Destination

Copy

Clipboard, (in memory)

Paste

Publish

Edition, (on disk)

Suscribe to

Once information appears in a destination, the two methods are very different. After you perform a copy and paste, the information in the destination is
static and can only be changed by another copy/paste. But after you perform
a publish and subscribe, the information in the destination is dynamic-it
remains linked to the source information via the Edition file. When the
source information changes, those same changes appear in the Edition, and
in the destination either automatically or on command.
The other major difference is that the data in an Edition is saved to the hard
disk, and therefore stays around until you delete it. You can subscribe to the
same Edition from as many documents and applications as you want. If you
share the Edition over the network, other users can subscribe to it as well.

Using Publish and Subscribe

What Can You Do with Publish and Subscribe?
Clearly, the more places a piece of information appears, or the more times it
changes, the more useful, even essential, the publish and subscribe method
becomes. Over a network, it can save the time of many people, and ensure
that everyone is working with the latest information.
If you find it difficult to envision how you can benefit by using publish and

subscribe, the following list of possible uses may help you think of some. It is
not meant to be an exhaustive list; categories and items overlap a good deal,
but are designed only to spur ideas.
Use publish and subscribe for information subject to regular or frequent
updating, such as:
• Spreadsheet data (such as sales figures, expenses, and price lists)
• Product descriptions, product identification numbers, graphics or
photographs of products
• Customer and employee databases
• Employee resumes
• Corporate or organizational mission statements, slogans, blurbs, legal
disclaimers, or copyright notices
• Templates for brochures, manuals, memos, status reports, invoices, and
soon
• Meeting minutes
• Proposals
• Contracts
• Schedules, calendars, and project tracking
• Employee worksheets and contract invoices
• Error reports, customer questions, and complaints
Work being created at one source, but used (or edited) in other locations, also
can be handled with publish and subscribe:
• Logos and icons
• Product presentations and internal presentations
• Screen shots and descriptions of software or other products under
development
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Publish and subscribe is useful for composite work pulled in from several
sources:
• Flyers, n ewsletters, and brochures
• Data sheets
• Presentations
• Excel data used in Word
Use publish and subscribe to create master repositories or catalogs of information subscribed to by multiple users:
• "Boiler plate" blurbs or phrases, such as product descriptions
• Scanned photographs or slides
• QuickTime movie clips
• Recorded messages
Home uses for publish and subscribe include:
• Graphic designs you use in multiple places, perhaps as you work to
improve them over time
• Updates from employers or clients over the modem via Apple Remote
Access
Note
Here's an idea for creating a design. Create a graphic or scanned photo, then
subscribe to it any number of times on the same page. When you edit the original, you get a new design. Do a Save As and repeat to create different designs.
In addition to editing or replacing the published graphic, you can rearrange the
subscribers on the page for a variety of effects.

A Publish and Subscribe Scenario
Suppose you are in charge of producing an internal monthly sales report.
Every month you must gather the latest Excel graph of sales figures from
other staff and write a column about the Employee of the Month.

Using Publish and Subscribe
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Each contributor to the report publishes his or her information, thus creating
Editions that you subscribe to from the layout you created in Word. A copy of
each Edition file is placed in your Word document. You can resize the information if you want.
In May, your report might look like the one shown in figure 30.4.
H

z news woman rna

After the report is distributed, your Word documen t will receive updates
(manually or automatically) made by your contributors fo r the june issue.
After you have received your updates, your report might look like the one
shown in figure 30.5.

Fig. 30.4
A report is created
in Word with text,
graphics, and
spreadsheets
produced and
published by
contributors over
the network. Each
contribution is
subscribed to
from the Word
document.
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Fig. 30.5
As contributors
work on the latest
information in
their published
documents, the
Word report is
updated for next
month's edition.
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If you want, you can edit the published information by selecting Open Pub-

lisher from the Edit menu, an option that launches the other application and
file directly from your Word document. Or you can leave the editing to your
contributors, receiving their updates.

Procedure for Publishing Data
Wh en you publish information, a copy of it is sent to an Edition file, which
you and others with the relevant access privileges can subscribe to. Then
when the publisher (the information you publish) changes, the Edition and
all subscribers (copies of the published information) to it change accordingly.

Procedure for Publishing Data
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To publish data, follow these steps:
1. In your document, select the information you want to publish. (You

can select as little as one character or as much as the entire document.
If you publish the entire document including the final paragraph mark,
anything you add later to the document will be included in the Edition
file.)
2 . Highlight Publishing in the Edit menu, and from the cascading menu
attached to it, select Create Publisher. The dialog box shown in figure
30.6 appears.

ell Editions ..,.

Preulew

KYZ Corpot'11tlon
1234 tt.ldt St .

s., rr..,tsco, CA ' ' 234

C dlsclnlmer
employees dotnbnse
employees dfttebnst!'l60n2
togo
product detebase
product II dotasheet

c
c
c
c
o

Name or new edition:
!untilled Edition

= Motlntosh HD

I

Ejec t

( Desktop
( New

I
I

CJ )

(

Cancel

)

I~

Publish

I

3. Select a name and location for the Edition file.
The Edition is the intermediary file where the data you publish is kept.

Note
To help you keep track of your Editions, it's a good idea to leave the word
"Edition" in the file name. You may want to create a new folder to hold all
your Editions. Alternatively, you may want to keep your Editions in the same
folders as the published information. Consistency is Important.

4 . Click Publish in the dialog box.

Caution
After an Edition file is created, you can rename it and move it to another
location on the same volume if you want. However, if you move an Edition to
a different volume, the System will not be able to find it. The System will also
lose t rack if a volume has been renamed. Make sure people with whom you're
publishing and subscribing don't change their hard drive names.

Fig. 30.6
Word's Create
Publisher dialog
box lets you see a
preview of the
data you are
publishing as an
Edition file.
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Now you or anyone else can subscribe to the Edition you just created.
You may want to choose when changes made to the published information
(called the publisher) are sent-it can be either when you save the document
(the default) or manually. See the next section, "Choosing Publisher
Options," for more information.

Choosing Publisher Options
To make changes to publisher options, follow these steps:
1. In the document where it was created, place your cursor within the

published material.
Note
To help you find published information in a document, many applications
surround publishers with gray borders. In some applications, there is an option
to Show/Hide Borders in the Edit menu. In others, borders are controlled by
the command that shows and hides other markers, such as paragraph
markers.

2. Choose Edit Publishing Publisher Options from the Edit menu.

The dialog box in figure 30.7 appears.
Fig. 30.7
The Publisher
Options dialog
box en ables you to
decide when
updates will occur.

Publisher to:

IC

Un11tled Edition

•I

send Editions:- - - - - - - - - ,

® on saue
O Manually

0

CanceiPubllsher

J

( Send Edition Now J

Send Edition When Edited

3. Select the option or options you want.
• Send Editions/On Save/Manually. If you choose to send On Save,
updates will be sent to all subscribers as soon as changes are
saved.
If you choose to send updates Manually, click that button. Then
whenever you want, you can send the changes by clicking the
Send Edition Now button.

Procedure for Subscribing to Data

Note

647

·

Sending updates to the Edition is not the same as having each subscriber
receive them. Final control of when the changes are actually made is up to
each subscriber, through the Subscriber Options dialog box.

•

Send Edition Now. This button allows you to send editions when-

ever you want. If the Manually radio button is selected, this button is the only way to send updates. If the On Save button is selected, you canuse this button to send an update between saves.
•

Cancel Publisher. This button breaks links from this published data

to all current subscribers. The contents of the publisher remain in
your document, and the Edition remains on disk, but changes are
no longer sent to the Edition or to subscribers. If you don't want
users to subscribe to the disconnected Edition as it currently
stands, delete it from the Finder. When you click this button, you
will be asked to confirm.
•

Send Edition When Edited. This option sends changes even before

they are saved, which can slow down performance while changes
are being made.
4. Click OK.

Editing Published Information
You can edit published information just as you edit any other information in
a document. (But remember, your changes also will be made in any other
locations where the same published information is subscribed to.)
To edit the publisher, open the document that contains it, find the publisher,
and make any changes you want. The changes are sent according to the
selection in the Publisher Options dialog box (usually either On Save or
Manually). Refer to the section "Choosing Publisher Options" for more
information.

Procedure for Subscribing to Data
If you have previously created an Edition by publishing some information , or

if you have access to an Edition created by someone else, you can insert a
copy of the published information in your document by subscribing to the
Edition.
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To subscribe to published data, follow these steps:
1. If the Edition is on another Macintosh, connect to that Macintosh.

2. Position your cursor in your document where you want a copy of the
Edition to appear.

3. Choose Subscribe to from Publishing in the Edit menu. A dialog box
resembling the one in figure 30.8 appears.
Fig. 30.8

Word's Subscribe
to dialog box
displays only
Edition files, and
lets you see a
preview of any
Edition file you
select to remind
you what's in the
file. You can
choose a file
format to
subscribe from
with a short popup menu.
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4. Navigate through the folders until you see the Edition you want. (If the
Edition is located on another hard disk or another Macintosh, click the
Desktop button first.)

Office applications help you find the Edition you want by displaying
the first part of any Edition you select in a small Preview box.
5. Select the Edition you want.
6. If there is a choice of file formats, choose the one you want.

The TEXT and PlCT formats, similar to those used in the Clipboard, are
usually available, in addition to private formats. (Refer to the section
"Understanding File Formats" for more information on formats.)
Don't worry if you don't know which format to choose. You can easily
resubscribe if the data is not displayed properly. You also can change
the format from the Subscriber Options dialog box.
7. Choose Subscribe.

Now that you have subscribed to an Edition, you may want to choose when
changes sent from the publisher will be made in your document-automatically or whenever you choose to send them manually. See the next section,
"Choosing Subscriber Options," for more information.

Procedure for Subscribing to Data
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Choosing Subscriber Options
Once you have subscribed to a copy of published data, you can select several
subscriber options. When changes sent from the subscriber are to be made
(either automatically or manually), the file format to be used in the subscriber, whether formatting changes made in the subscriber are to be kept,
and when the information is updated. You also can open the publisher to
edit it, and you can cancel the subscriber so no more updates will be sent.
To select subscriber options, follow these steps:
1. In the file that subscribes to published data, select that data.
Note that the data is selected as a block, so that you cannot edit it, except for cosmetic font changes or for changes to the size and shape of a
graphic.

2. Select Subscriber Options from the cascading menu under Publishing in
the Edit menu. The dialog box in Figure 30.9 appears.

Io

Subscriber to:

Clipboard Edition

Fig. 30.9
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0 Manually
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i

1

l

Lattst Edition:

Friday, August 5, 1994 7:16 :02 PM

I

( Cancel Subscriber

)

Open Publisher

!---·······························································-······-·····-··················-·······-···································

D Keep

Subscriber Formatting Changes

Subscribe with:
Best Format

I

[ Cancel )

(l

OK
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3. Select the option or options you want.

• Get Editions/Automatically/Manually. If you choose Automatically,
changes will be made as soon as they are sent from the publisher.
If you choose Manually, you must access this dialog box again
whenever you are ready for an update, and click the Get Edition
Now button. The latest changes will then appear in your document if any updates have been sent by the publisher.

The Subscribe
dialog box
presents a number
of options.
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Note
Choosing when you get Editions only affects when you get changes
that have been sent by the publisher. Publisher Options determine
when changes are sent. For more information, refer to the section
"Choosing Publisher Options" earlier in this chapter.

• Get Edition Now. Whether you have chosen the Automatically or
the Manually button, pressing Get Edition Now immediately
brings in changes that have been sent from the publisher.
• Cancel Subscriber. If you click this button, this particular subscriber
will no longer receive changes from the publisher. The information will remain in your document and you will be able to edit it
normally. You will be asked to confirm.
• Open Publisher. Clicking this button takes you directly to the published data, even if it is in another application. This allows you to
edit the source data if you want.

Caution
When collaborating with other people on a network, be certain that the
editing you do to the publisher is desired by all subscribers.

• Subscribe with. The TEXT and PICT formats used in the Clipboard
are usually available, in addition to private formats. Refer to the
section "Understanding File Formats" for more information on
formats.
The following option appears in Word and a few other applications:

• Keep Subscriber Fonnatting Changes. This option keeps formatting
changes you make to this instance of the published data, such as
font changes, or changes to the size and shape of a graphic, when
the data content is updated. (Such cosmetic formatting changes
are usually allowed only to the whole block of information, n ot to
parts of it.)
4. Click OK.

Procedure for Subscribing to Data
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Note
You can cut, copy, and paste subscribed data at will, without losing the connection
to the published data.

Editing Subscriber Information
Word allows you to change fon ts and fo nt characteristics in the subscriber.
Generally, the changes must be to the entire block of information . For example, you may be able to make the entire block of subscriber information
appear in boldface type, but you probably cannot make a single word appear
in boldface type.
Ch anges you make in the subscriber are usually overridden when the subscriber is updated, unless you select a publisher option to maintain the
changes.
To change the content of a subscriber, such as to delete a word from a word
processing application, a line from a graphics application, or a number from
a spreadsheet, you must edit the publisher. Refer to the section "Editing Published Information" earlier in this chapter for more information.

Troubleshooting
I have trouble keeping track of Editions: where they are located, who has subscribed to
each one, and which subscribers have been updated and which haven't.
Use a consistent system for what to name and where to store Editions, and be sure
everyone understands the system. You might want to write a set of rules, such as the
following:
•

Whenever anyone publishes information, they are to send an e-mail message to
the entire group of potential subscribers describing what they published, w here
its Edition is located, and in what documents it should appear. The same rules
apply w hen someone changes published information.

•

(If it fits your situation, the following rule ensures consistency.) Anyone publishing information should choose the option Send Editions Automatically. Anyone
subscribing to information should choose the Get Editions Automatically button.

•

Editions should not be moved or renamed unless there is a good reason to do
so, and everyone is informed of the changes.
(continues)
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(continued)

The updated information my document receives doesn't always match the publisher
exactly.
There may be two versions of the publisher. This can happen in two ways. (1) You or
someone on the network may have done a Save As to save the document with the
publisher under a different name. Changes may then be made from both documents
to the same Edition. (2) You or someone else may have copied and pasted information containing a publisher. Changes may then be made from both instances of the
publisher to the same Edition.
The publisher may be set to send changes manually, or the subscriber may be set to
receive changes manually. Though changes have been made to the publisher, they
either have not been sent from the publisher or received at the subscriber. To send
the latest changes, put your cursor in the publisher and select the Send Editions Now
button. To receive the latest changes, put your cursor in the subscriber and select the
Get Editions Now button.

From Here ...
This chapter showed you how to publish and· subscribe to information between different source applications. Because you may need to know the basics
of the other Microsoft Office applications, you may want to review the following chapters or continue with other sharing-information chapters:
• Chapter 12, Creating Worksheets," covers the fundamentals of creating an Excel worksheet.
11

• Chapter 20, Creating, Saving, and Opening Presentations," shows you
how to create a slide presentation.
11

• Chapter 29, Sharing Data between Applications with Linking and Embedding," describes the process of making dynamic data links between
files.
11

• Chapter 31, Using Mail with Other Microsoft Office Products," tells
you how to use Microsoft Mail to send your files to other members of
your network.
11

Chapter 31

Using Mail witn Qther
Microsoft Office
Products
by Carman and Donna Minarik

v
Microsoft Mail is an electronic mail (e-mail) package that enables you to send
messages to people on your network. Your messages appear on the recipients'
computer screen. Documents created using other Microsoft Office packages
can be sent or routed to selected people on the network. You can also copy
portions of a document or attach entire docu ments to a Mail message.
Microsoft Mail isn't included when you buy Microsoft Office. You do receive
an additional license to use Mail on any network you connect to. The Mail
package is available from Microsoft at an additional charge. If you don't have
a network, this chapter may not be relevant to you, but it will provide an
overview of what Microsoft Mail has to offer.
Note
The figures in this chapter reflect the use of Microsoft Mail on an AppleTalk Network.
Your figures may vary slightly if you have another type of network.

In this chapter, you learn to
• Start Mail and create a message
• Copy information from a Word document to a Mail message
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• Send a document through Mail or through the Routing commands in
your File menu
• Attach other Office files to your Mail message

Opening Microsoft Mail
Starting Mail is similar to opening any other Office program. When you install the Office packages, the Microsoft Office menu appears at the top of
your screen. Choose Microsoft Mail from this menu, or switch to Mail using
the application menu if it's already open. Figure 31.1 shows the Summary
window in Mailbox view.
Click to compose a message

Fig. 31.1
The title bar of the
Summary window
shows that the
Mailbox folder is
open.
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If you've already sent or received messages, the Mailbox folder stores those

messages and displays them in this window. The Outbox folder stores messages that are waiting to be sent. You can save messages in default folders,
(WasteBasket, Outbox, and Sent Mail) or in custom folders that you create.
(See "Reading a Sent Document" later in this chapter for more information
on creating folders.) The title bar of the Summary window changes to indicate the open folder. In this case, the title is Mailbox for Network Manager
because the Mailbox folder is open.
The buttons and menu choices in Microsoft Mail enable you to compose,
read, reply to, move, or delete a message.

Creating a Message
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Creating a Message
You can create and send a message to anyone on your network if they have
been added to Mail's address list by your network manager.
To create and address a message, follow these steps:
1. Click the Note button in the upper-left corner of the window.

The Address Mail window appears, as shown in figure 31.2.
Fig. 31.2

The selected

The Address Mail
window enables
you to choose who
will receive the
message.

---t--t~~- recipient

name(s) will
appear in this
list

2. To address the message, do one of the following:

Tip

• Type the names of the individuals or groups in the text box.

'

• Choose the names from the Choose Names list and click the Add
button or double-click the names.
3. Click the Close button.
4. Type your message in the Send Note window as shown in figure 31.3.
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5. Click Send.

If you click
each of the
icons in the
Mailbox dialog
box, you'll be
shown an
example of the
form that will
result.
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The message is sent to the recipient, who can read, reply to, file, or delete the
message.

Reading a Sent Document
When a message is sent to you, you are alerted by a dialog box with the subject of your message in the title bar as shown in figure 31.4. The dialog box
shows who the message is from and the subject of the message.
Fig. 31.4
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receive mail.
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[

Delete
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Note
If you would rather not have your work interrupted by mail notification, you can
disable notification features by changing your Mail preferences. Choose Mail Preferences and click the Notifier option to set your personal notification preferences.

To open the message and read it immediately, click the Read Now button. If
you click the Read Later button, you can read the message by following these
steps:
1. Start or switch to the Mail program by choosing Microsoft Mail from

the Microsoft Office menu.
2. Open your Mailbox folder.
3. Double-click the message you want to read. Messages that haven't been
read appear in bold type as shown in figure 31.5.
4. Read the message and close the window.

Or. ..
Use the buttons along the bottom of the message window to perform
the following functions:
• Reply. The note appears in a Reply window. Enter your reply as

shown in figure 31.6 and click Send.

Read ing a Sent Document
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From: Bailey on Thu, Sep 22. 1994 3:09PM
Subject: Client Tracking
To: Network Manager
To provide better service to the clients of Minarik a. Associates, all
clien t Inquiries, whether by phone or In per son, will be recorded This
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• Forward. Click this button to send a message you have received to oth-

ers on the Mail network. The Address Mail dialog box will open as described previously (refer to fig. 31.2).

• Print. Use this option to print a hard copy of the message.
• Move. This option allows you to store the message for future reference
in any of the folders shown at the bottom of the Mail wi ndow.
Note
Additional folders can be created by choosing Mail, New Folder. Enter a folder
name in the dialog box that appears.

• Delete. Moves the message to the Wastebasket folder. Messages in the
Wastebasket folder will be removed when you close and sign out from
the Mail system. To retrieve a message from th e Wastebasket folder,
simply move the message to another folder.
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Fig. 31 .6
Click the Reply
button in the
Mailbox window
to open this
window and type
your reply.
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Creating a Personal Group
Often, in a company or organization, messages are sent to more than one
person. Usually these people perform similar work or work together on a
particular project, so many mail messages are relevant to the same group of
people. For example, perhaps you send price updates to seven salespeople in
your organization regularly. Rather than send the information to each of
seven people, you could create a personal group called Salespeople and send
the message once, and each person in the defined group would receive it.
Tip
Be sure to
update your
personal
groups if som eone joins o r
leaves the Mail
system.

To create a personal group, follow these steps:
1. Choose the Personal Groups command from the Mail menu. The Per-

sonal Groups dialog box appears, showing a list of the current groups.
2. To create a new group, type an appropriate group n ame in the New
Group Name box and click the New button. An Address window will
open.
3. Select the name you want to add.

4. Choose the Add button, or double-click the name.
S. Repeat steps 4 and 5 for all the names you want to add to your group.

6. When you finish adding names, click Save.

Sending and Receiving a Document
Documents created in any of the Office applications can easily be sent directly to others on your network if you are signed in to Microsoft Mail.
To send a document from an Office application to another network user,
follow these steps:
1. Open the application and the file you want to send.

2. In Word, choose File, Send. In Excel and PowerPoint, choose File, Mail,
and then Send from the cascading menu.
Note
If the Send option is not shown on the File menu in Word, choose Tools,
Options. In the General tab, select Mail as Attachment.

Sending and Receiving a Document
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3. An Address window will appear as discussed previously (refer to
fig. 31.2). Address the message as desired and click Close.
4. Enter a subject and any additional message, and click Send, as you
would in any Note window.

When a sent document is received, the receiver is notified as with any Mail
message. The message includes an enclosure, as illustrated in figure 31.7.
Client Refernl ,Bailey
~From:
Date:
Thu, Ssp 22, 1994 9: I 3 PM
Subject: Client Referral

Fig. 31.7
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This message
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that a document is
enclosed in the
message.
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Delete
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When you receive a document, click the Enclosure button to retrieve it.
A dialog box similar to the one shown in figure 31.8 opens. Choose the location, rename the file if desired, and click the Save button. The document can
now be opened in the application of origin.
Fig. 31.8
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Routing a Document
An alternative to sending a document is routing it to selected parties. You can
track a routed document's location and you can send it automatically to consecutive recipients.

Creating a Routed Mail Message
To route a document from an Office application, be sure you are signed in to
Microsoft Mail and follow these steps:
1. In Word, choose the File, Add Routing Slip command. In Excel or
PowerPoint, choose File, Mail, and then Add Routing Slip from the
cascading menu. The Routing Slip dialog box appears, as shown in
figure 31.9.

2. Choose Address, and select the names of the people to whom you want
to send your document.
3. To change the order of the address list, select a name and use the up or
down arrow beside the list box. The order of names in the address list
will be the order in which recipients receive the routed document.
4. To remove a name from the list, click the Remove button.
5. In the Route to Recipients area, specify whether you want to route this

file simultaneously to every recipient or to consecutive recipients.
6 . If you want to be notified via your Mail Inbox of the status every time
someone reads the document, select Track Status.

From Here...

7. If you want the final document returned to you at the end of the routing, select Return When Done.
8. In the Protect For pop-up menu box, specify whether you want to pro-

tect part or all of your document so that recipients can't make changes.
9. When you finish, click the Add Slip button to begin routing the

document.

Attaching Word, Excel, or
PowerPoint Files to Your Message
When you send or route a document, you start in the document's application. You can also send documents from within Microsoft Mail, by using the
Enclosures button to attach documents. By using the Enclosures button, you
can attach more than one document to each message.
To attach a document to your message, follow these steps:
1. Create a new mail message.
2. Click the Enclosures button. The Enclosures dialog box appears.
3. Identify the name and location of the files to be sent.
4. When you finish choosing files, click the Done button.

5. Finish the message, and send it by clicking the Send button.

From Here ...
This chapter showed you how to work with Mail and other Office applications to send electronic messages to people on your computer network.
See the following chapters for more information:
• Chapter 4, "Creating and Editing Documents," tells more about creating documents.
• Chapter 7, 11 Managing Files," provides steps for saving documents and
working with files.
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Using Offi~e
Applications witH
Powe alk
by Cyndie Klopfenstein

AOCE (Apple Open Collaboration Environment) is Apple's operating system
framework for communication services. Most companies have not yet subscribed to this technology, but Microsoft once again is a leader. PowerTalk is
the first software released by Apple that is based on the AOCE technology.
You use PowerTalk on individual networked Macintoshes to provide an easy
and consistent way of working with mail, messaging, and on-line services.
Even though you need a network, you do not have to be connected through
a file server, as opposed to Microsoft Mail which does require a server.
In this chapter you'll be introduced to the connectivity of PowerTalk and
you' ll learn about
• Catalogs and adding information cards
• Sharing your information cards with servers and other users
• Retrieving your mail from the in-basket
• Sending mail to unconnected users
• Passing messages to other users of your network
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PowerTalk-The Look
PowerTalk, like most other interface systems, provides icons, menus, and
other methods for working with it, such as information cards. The most noticeable icons are the three placed on your desktop: Catalogs, Key Chain, and
Mailbox. PowerTalk is automatically installed during a regular installation of
System 7.5. The major features of PowerTalk are:
Key Chain

A key" (master password) to other passwords and
information of and about the file servers and on-line
information that you connect to. This master password is storage for all the other passwords and requires only that you use the master to open each of
those contained within.

Catalogs

The catalog most closely resembles a Rolodex system. It has a card of information about each of the
people, servers, or services to which you connect.

Mailbox

This area, represented by the mailbox icon on your
desktop, is where your incoming and outgoing electronic data waits to be processed.

AppleMail

AppleMail is very similar to Microsoft Mail-both
perform the same primary function. They are used
to turn a regular document into a piece of mail to be
sent via PowerTalk.

Digital Signature

This service of PowerTalk signs an electronic signature to your correspondence so that PowerTalk receivers can verify who sent the file and make sure
that it was untouched since its sending.

11

PowerTalk can be used as a stand-alone system or to share mail and information cards with a server. The server in this case is called the PowerServer and
it enables you to share the set of information cards, or Catalogs, with other
PowerTalk users on the same network. You also can automatically verify the
addresses of the senders and receivers as well as ensure the security of the
e-mail.
The best feature of PowerShare for those on the go is the ability to send mail
to the server where it will wait for the receiver to log back on before sending.
This enables you to either receive your mail when you return to your office or
to have others receive mail you've sent when they return.

Putting It to Work
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Putting It to Work
Microsoft Mail and PowerTalk won't work together. You must use one or the
oth er. If you are connected to others in your office via a network but not a
server, PowerTalk is your best choice. It doesn't require a server, but Microsoft
Mail does. PowerTalk changes the File menu of the Microsoft Office suite.
When PowerTalk is on, the File menu contains, among other mailing features, the menu option for attaching the header to send mail. Since this is the
first step in sending mail to another user, we'll explore it first.

Caution
If you have already installed System 7.5 or System 7 Pro and are currently using
PowerTalk, it will interfere with the installation of Microsoft Office. Turn PowerTalk off
in the Control Panel and restart your Macintosh with extensions off (hold down the
shift key while restarting) or you will be unable to install the Microsoft Office suite.

v

If this is the first time you've sent mail and you have not previously established an access code, PowerTalk will intervene and ask you to establish your
Key Chain (access code). To establish your Key Chain, follow these steps:
1. From the File menu, choose Add Mailer. You are greeted by the Key

Chain dialog box.
2 . Type your name and access code in the fields provided. You are then
greeted by a second dialog box asking you to type the Key Chain access
code again.
3. Type your access code again, exactly as you did the first time. This field
is case-sensitive, so watch your capital letters; you'll need to repeat
them exactly.

Tip
The second
dialog box is
for accuracy
verification, so
it's important
to be careful
when typing.

From here forward, each time you choose Add Mailer from the File menu you
will need to sign on with your access code. Watch capital and lowercase letters when you sign on or you may be denied access to your own system.
Figure 32.1 shows the sign-on dialog box.
Once you have entered your access code, another dialog box appears (see fig.
32.2). Type the subject matter in the subject field and choose recipients and
enclosures by clicking the icons next to these field names.
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Fig. 32.1
Type your access
code in the dialog
box for the Key
Chain services of
PowerTalk.

Fig. 32.2
In this dialog box,
choose recipients
and enclosures.
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The names that are listed in the recipient field are those you have saved
in the information cards. You can remove or add names by going to the
PowerTalk folder and locating the Untitled Info Card icon. Double-dick the
icon to add a name to the blank information card.
To choose a new recipient for the mail to which you are adding the header,
click the recipient button. A dialog box appears (fig. 32.3). In this dialog box
you can search your Personal Catalog for the intended recipient, browse, use
the Zoom tool to search, or type in an address that you have not previously
stored in an information card.
The Personal Catalog is a collection of information cards you create. When
you click the Recipient button and use the dialog box, you are actually
searching or browsing the Catalogs icon located on your desktop.
To create a new information card to be included in the catalog, go to the
PowerTalk folder on your hard disk and follow these steps:

Putting It to Work
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1. Click the Untitled Info Card icon and choose Duplicate from the File

menu

(~+D).

2 . Rename the copy of the icon with the name of the person for whom

the information card is being established.
3. Double-click the icon to open it. This prompts a dialog box where you

can enter the data about the person you want to add.
4. Click each field and type the information it names (see fig. 32.4).
5. Click the Close box in the upper left corner of the window to close the
window and save the changes.

To place the information card in the catalog folder, double-click its icon on
the desktop and drag the named icon to the AppleTalk icon inside the Catalog folder.

Tip
If you can't
find the Personal Catalog
folder, use the
Find command
from the desktop ():(+F).

Once you've added the information card, it will appear as one of the list of
people (or destinations) available when you click the Recipient button.
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After you've added the information, open the Catalogs icon on your desktop
and copy the information card to the AppleTalk icon. Since catalogs can be
shared, you might want to make one for yourself so that others on your network have pertinent information about you.

Fig. 32.4
Finish typing in
the information,
close the dialog
box, and move the
information card
to the AppleTalk
icon in the
Catalogs folder
on your desktop.
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When you've finished choosing the recipients, type your letter or other correspondence in the Microsoft Word document below the Mailer header (you
may also type the mail before attaching a mailer header). Then from the File
menu, choose Send. A dialog box will appear like the one in figure 32.5.
Fig. 32.5
From this dialog
box you can send
the letter, sign it
(if you've initiated
Digital Signature),
assign a priority
level, or cancel the
Send.
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Priority:

0

~~~~It fGnNts
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If you click the Sign Letter button, a dialog box appears asking you to locate
your Digital Signature file. Use the buttons in the dialog box to locate the file,
or click Cancel to close the dialog box without assigning a signature. Click
the check box again to tum off that feature; otherwise you will be required to
find the signature file and attach it.

The multiple formats button allows you to send the correspondence in
formats other than as Microsoft Office mail. You may choose to send it as
a picture by clicking the Snapshot button or as another word processing
format.
The priority buttons will identify your correspondence accordingly. Recipients will be notified of the importance of the mail when you choose one of
these buttons.
Click the Send button when you have finished making your choices; the file
is then placed in your outbasket. If you and the recipient are both connected,
either to one another or to the server, the file is transferred to the Mailbox for
that person or group.
If you have added a header to correspondence that you decide not to send,

return to the File menu and choose Delete Mailer. The header is removed,
and the document is returned to a normal Microsoft Word page.
Choosing Mail from the File menu also enables you to reply to mail you've
opened, reply to everyone who received the mail, or forward it to another
recipient. Choose the appropriate option from the File menu.

Key Chain Services
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Changing and Locking the Key Chain
You're not stuck with your access code forever-it is editable and also lockable. To change it, just double-click the Key Chain icon on your desktop and
then click the Change Code button. Type your current code in the first field
and the new code in the next field. Click OK when you've finished, and after
the verification dialog box appears, type the new code again and click OK.
To lock the access code, and thereby your catalog and mailbox, choose Lock
Key Chain from the Special menu. You're not warned, but access to your
mailbox and catalog is terminated. You can use this option if you're stepping
away from your computer for awhile and want to protect sensitive documents from being read by others who may use your computer. When you
return, choose Unlock Key Chain from the Special menu and retype your
access code.

Key Chain Services
You are always connected to at least one service, the AppleTalk mail service.
This software is an inherent part of PowerTalk. Even without Microsoft Mail,
you will be able to s~nd and receive documents-all as a part of AOCE.
The services which you are employing are listed when you click the Key
Chain icon on your desktop. If you want to check which are active, doubleclick the Key Chain icon to display the window. Services are listed in the
Service field (fig. 32.6), along with the name of the host computer and the
type of service it is. Your network administrator is responsible for setting up
the different services available to you. For instance, with certain software you
can connect to Internet on-line service without even being aware of the
change in software.
Ke Ch11ln
Key Ch!lln For Cyndle Klopfenst...

Fig. 32.6
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This dialog box is
for adding and
removing servers
and services.
A service is made
available to you
by your network
administrator.
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With some services, you'll be able to set up your software without a network
or an administrator. If you use on-line information systems such as America
Online or CompuServe, you can add them to your list. Connect to the service
first, and as you enter the password for that service, PowerTalk displays a
dialog box asking whether you would like to add that server to your Key
Chain. If you click Yes, the password you just used to connect is added under
the protective services of the Key Chain system and the service is listed in the
Key Chain dialog box.
To add another type of service, click the Add button in the Key Chain dialog
box. Delete a current service by clicking the Remove button, also found in
the Key Chain dialog box.

Working with the Catalogs
There are two types of catalogs for PowerTalk: Personal and Shared. Every
Mac using PowerTalk has both of these catalogs. If you want to view the catalog, double-click the Catalog icon on your desktop and then double-click the
AppleTalk icon.
The Personal Catalog resides in the Apple Menu under the Mail and Catalogs
entry, although you can place it anywhere you like. In the Apple Menu the
Personal Catalog is very easy to access, but you might want to make aliases
and place them in other easily accessible locations on your hard disk.
Personal Catalogs are empty until you add information cards. The information cards, as you saw earlier, closely resemble Rolodex cards so you can use
them to store information about people or services. You also can have several
different Personal Catalogs that contain specific types of data. Name them
anything you like and place them where they're handy.
In the Get Info dialog box (click the Personal Catalog icon and choose Get
Info from the File menu of the Finder) for a Personal Catalog, you can mark a
catalog as Preferred. This will become the default catalog. This places a small
bookmark on the left page of the Personal Catalog icon. All applications that
use PowerTalk are able to find items in your Preferred Personal Catalog,
regardless of its location on your hard disk.
To create additional Personal Catalogs, open your main Personal Catalog
(in the Apple menu or open the Catalogs icon on your desktop), and a new
menu appears to the right of the Finders Special menu. Choose New Personal

Simplifying Mail

Catalog from the Catalogs menu, and a new catalog is placed on the desktop.
Change the name and place it where it is easily found when sending mail.

Information Cards
The servers, people, and services are all represented in the catalogs by three
different types of information cards:
• User information cards
• Group information cards
• File server information cards
A user information card includes a person's name, postal address, electronic
address, telephone numbers, and other details that you might find informative (or easy to forget). You can create a new user card by choosing New User
from the Finder's catalog menu.
A group card contains aliases for user information cards. You'd use this
method to repeat send information to a selected group of individual users.
Use the Catalogs menu to create a group card and then select and drag those
individual users that you want to include in the group to this icon. The
aliases are copied into the group icon and you can view them by doubleclicking the group icon. Rename the icon if you choose.
A file server information card is used to connect to file servers. It contains the
registered user name and the password, if there is one. If you open one of the
icons, it'll mount the volume or open the volume and log on.

Simplifying Mail
Even though it's very simple to send mail from inside Microsoft products, it's
not necessary to launch the program to do so. You can simply drag the icon
for the document to the icon for the user or group information card and
PowerTalk will step in and do all the rest.
When you drag mail to an icon, the correspondence is placed in the Mailbox.
This in/out basket icon on your desktop is a centralized location for all mail
that you send and receive without consideration for its origin or destination.
This basket system also will hang on to documents that are being sent to
unconnected users until they connect.
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Checking the Mailbox
To open mail you have received is simple as double-clicking the Mailbox on
the desktop and double-clicking the desired correspondence. All of your incoming mail is listed in the window. Delete the mail by dragging the file to
the trash. Copy mail by dragging it to a folder (other than the Mailbox) on
your hard disk.
Anytime you double-click or open the Mailbox icon, a Mailbox menu is
added to the right of the Finder's special menu. Use this menu to go directly
to either the In Tray or the Out Tray of your Mailbox. When you select one of
these options a window appears with a list of the mail that you have received
(In Tray) or that is waiting to be sent (Out Tray).
Sometimes it's important to categorize your mail. You can do this by displaying the Mailbox window (double-click the icon), choosing the files you want
to mark, and choosing Tags from the Finders Mailbox menu. You also can
attach multiple markers by using the Tags option repeatedly. Remove all
attached tags by selecting the file and choosing Preferences (fig. 32. 7) from
the Mailbox menu.
Fig. 32.7
Use Mailbox
Preference to Tag
items, remove
outdated items,
and to warn you
of incoming mail,
among other
options.
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The Preference dialog box check boxes allow other settings, too. From here
you can ask that the most recent mail be displayed first (Show most recent
first), or to let others check their mailboxes from your computer (Allow
visitors mailbox). For in-bound mail, your Macintosh can alert you when it
arrives (Display alert), causing the icon in the menu bar to blink (Blink icon
in menu bar) or play a user-defined sound (Play this sound:). In the Out Tray
you can define a number of days to wait before unsent mail is
deleted.
Back in the Mailbox menu, with the Mailbox window open you can access
the Out Tray. It displays a list of items you have recently sent or the status of

Signing Documents
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those still waiting to transfer. Unfortunately, you cannot tell from here
whether or not the message has been received or read-just that it has been
sent.

Signing Documents
With the technology that allows us to protect our documents comes the technology for someone else to snoop, edit, or even delete our electronic mail. To
help with this problem, PowerTalk also incorporates digital signatures. Using
this, a receiver can verify the authenticity and originality of mail he or she
has received-it's just as though a handwritten signature appeared at the
bottom. The digital signature is verified by using the Get Info dialog box of
the File menu. Click the icon of the file you want to verify and choose Get
Info ():(+I) and then click the digital signature button to the right of the
Comments window.
To use the digital signature, you must first have one. Use the document that
was shipped with System 7.S to register your digital signature, or signer. There
is an application called DigiSign that you use to register the signature.
Once you have received the digital signature, you can add it to the mail you
want to send by dragging the file to your Signer. From Microsoft, use the Sign
Letter option in the Send dialog box (fig. 32.8).
Select a Signer file:
les~ Powerlallc

Fig. 32.8
•I

c::lUntltled
(

Eject

)

Select

You'll then have to enter the DigiSign identification code that you assigned
yourself when you applied for the signature. To attach the digital signature,
enter the access code in the field provided (see fig. 32.9). This further protects
documents, since no one else should know the code that will enter your signature to the document.

When you click
the Sign Letter
button in the Send
dialog box, you
will be asked to
locate the signature. You may also
drag a file to send
to the digital
signature icon.
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Fig. 32.9
The access code
that protects your
digital signature is
a backup security
system so that
someone who does
not have the
proper code will
not be able to
attach the
signature.

Signing as "Demonstration Only (••• NOT A
RERL PERSON •••)".
DlgiSign ldentlflc:atlon Code:

( Signer ... )

PowerShare Servers
PowerTalk is made even more adept by using a server. A server, in the most
basic of terms, is a computer traffic controller. All the computers in a network
may be connected to one another using a network such as AppleTalk or
EtherNet or to a central system (file server) also using AppleTalk or EtherNet
(or a host of other brand names). You must install the PowerShare software
on the Mac that is the server. Once installed, you have additional services
available to PowerTalk, which are:
• Shared Catalogs
• Authentication and Privacy
• Messaging Store and Forward
Shared catalogs were discussed earlier in this chapter; they give you the option of sharing and using shared catalogs-catalogs that reside either on the
server, or shared computers. The network administrator is responsible for
sharing catalogs with users. It works in the same way that you share your
catalog (using the Configure Catalogs option in the Catalogs menu). You
must be connected to a server in order to share your catalog. Likewise, the
server must be connected to the network in order to share its catalogs with
you.
The Authentication process is a method for ensuring that a message was sent
from the place that it claims, which helps to guarantee that the e-mail remains secure. As a part of a PowerShare network, you are included in the
catalog of the server. You have an authentication key that enables you to
access the server. Without this key, you can't send or receive correspondence
with the server. Further, the server encrypts data sent through it so that persons who might gain access to the correspondence being sent can't decipher
the coded contents.

From Here...
Finally, with Store and Forwarding, mail that is sent to unconnected persons
is held until those persons log-on to the server. At that time, the mail is automatically placed in a connecting user's mailbox.
Whether or not you use a server will not make a difference to how well
PowerTalk works for you. It's a convenient, easy-to-use mail system that
you'll find approachable and worthwhile for e-mail. If you've never used
e-mail, now's a good time to try it out.

From Here ...
Microsoft Office is a demonstration of connectivity. OLE and menu bar sharing are just two examples of how seamless the applications are when sharing
data. Turn to these chapters to find out more about these and other types of
data sharing:
• Chapter 8 "Customizing Word," shows you how to customize menu
bars and how they share characteristics with the other applications of
the Microsoft Office suite.
• Chapter 30, "Sharing Data between Applications with Linking and Embedding," walks you through OLE and how you can use it to move
between Microsoft and other OLE applications.
• Chapter 31, "Using Mail with Other Microsoft Office Products," is a
discussion on the operations of Microsoft Mail. Although PowerTalk
and Mail cannot be used together, in a network with a server, Mail may
be a better solution for your data sharing needs.
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Sending a
by Donna Minarik

This chapter focuses on an efficient way to mail a personalized letter to many
people. Combining the Mail Merge feature of Microsoft Word with addresses
stored in Word or in external software sources allows you to quickly prepare a
mass mailing.
In this chapter, you learn to
• Begin a mail merge with the Mail Merge Helper
• Create, edit, and use Word, Excel, and database files to address the letter
• Make envelopes and labels from the data files
• Create a list of the contents of the data file

Creating a Letter
You can prepare your form letter as you would any other letter in Word.
You can open the File menu, choose New, and then select the Letter Wizard.
When you create the letter, do not include the name and address of the addressee. Then, save the file and position the insertion point where you want
to insert name and address information. Figure 33.1 shows a portion of the
letter before placeholders for the name and address are added.

v
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Fig. 33.1
Create a letter as
you normally
would, and
position the
insertion point
where the
addressee's
name will go.
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Using the Mail Merge Helper
CrossWord 6 conta ins a Ma il Merge Helper d ialog box to gu ide you through
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merge d ocu ment, attach your dat a file, and t hen merge t he letter and th e
data file.
To get to t he merge helper, ch oose Tools, Ma il Merge. Th e Mail Merge Helper
dialog box app ears, as shown in figu re 33.2.
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During the merge process, you may need to return to the Mail Merge Helper.
To do so, open the Tools menu and choose Mail Merge again. If you are editing the Jetter, you can click the Mail Merge Helper button in the Mail Merge
toolbar, as shown in figure 33.3.
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Identifying the Letter as a Merge Document
In the Mail Merge Helper dialog box, you must identify your letter as the
main document you will use for the merge.
To identify the letter you are working on as a merge letter, follow these steps:
1. Open Tools and choose Mail Merge. The Mail Merge Helper dialog box

appears.
2. In the Main Document section, choose Create.
3. In the drop-down-list, select Form Letters.
4. A dialog box appears, asking whether you want to use the active win-

dow or a new window. Because the letter you want to use is currently
open, click the Active Window button.
You will then need to identify where you will get the names and addresses for
your letter. Return to the Mail Merge Helper dialog box, where you have a
number of options:

~

See "Identifying
the Document," p. 219

v

680

Chapter 33-Sending a Mass Mailing
• If you want to create or use an existing table in Word, see the section

"Using a Data File in Word" later in this chapter.
• If you want to use names from an Excel spreadsheet, see the section
"Using Data from Excel" later in this chapter.
• If you want to use names from a database, see the section "Using Data

from Databases and Other Spreadsheets" later in this chapter.

Using a Data File in Word
~

See "Choosing
a Data Source,"
p.220

If you do not already have the names and addresses of the recipients of your

letter stored in the computer, you may want to create a data file in Word and
add the names and addresses in that file. Complete the following steps to
create a data document:
1 . Open Tools and choose Mail Merge. Th e Mail Merge Helper dialog box

appears. (This step is unnecessary if you left Mail Merge open in the
preceding procedure.)
2. In the Data Source section, click the Get Data command button.
3 . In the pull-down list, select Create Data Source. The Create Data Source

dialog box appears, as shown in figure 33.4.
Fig. 33.4
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4 . Change a field in the Create Data Source dialog box, as shown in figure

33.4, by doing any of the following:
• Add a field name to the suggested Jist by typing a new field name
in the Field Name text box, and clicking the Add Field Name
button.
• Remove a field name from the suggested list by selecting a name
in the Field Names in Header Row Jist box and then choosing the
Remove Field Name button.

Adding Field Names to Your Letter
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• Change the order of the field names in the list by selecting a
name and then choosing the up or down arrow.
5. When you're finish ed, choose OK.

6. Identify the File Name and location of the file for your data in the Save

Data Source dialog box. This dialog box is the same as the File Save As
dialog box.
7. After you name the file, Word asks you whether you want to add

records to the data file or edit the main document. Choose Edit Data
Source to add your records now. A Data Form dialog box appears, showing the fields you identified in step 4 (see fig. 33.5).
Fig. 33.5
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8. Type the information in each field. Press Tab to go to the next field;
press Shift+Tab to go to the preceding field. Choose the Add New button to add someone else's information.
After you create the data file, click OK to return to your letter. If you need to
make changes to the data, click the Edit Data Source button. Data records are
edited in the Data Form dialog box, as shown in figure 33.5.

Adding Field Names to Your Letter
After you identify your letter as a main document and create or attach your
data file, you need to tell Word where each field name appears in the main
document. From your letter, click the Insert Merge Field button in the Mail
Merge toolbar and select the field name to insert, as shown in figure 33.6.

<Ill See "Creating a

Data Source,"
p.221
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Fig. 33.6
The Insert Merge
Field button in the
Mail Merge
toolbar shows you
a list of field
names in your
data fi!e.

I
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Merge Field button.
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Each field name appears in the letter in chevrons(«>>). Don't forget to add
spaces between field names and any necessary punctuation (such as a comma
between the city and state). If you need to delete a field, you can highlight
the field name, including the chevrons, and press delete.

Completing the Merge
After you identify the main document and the data source and insert the
merge fields, you are ready to merge the names and addresses with the letter.
You can merge through the Mail Merge toolbar or through the Mail Merge
Helper dialog box. The Mail Merge Helper dialog box gives you more options,
such as selecting some of the names and addresses and sorting the names.
For more information on selecting whom you want to send to, see the section
"Selecting Who Receives the Document" later in this chapter. For more information on sorting, see the section "Sorting the Mailing" later in this chapter.
<01111

See "Merging
the Data
and the
Document,''
p.224

You can merge and create a new document or send the merged letters directly
to the printer. Unless you are certain that the merge will turn out correctly,
you should merge to a new document so you can preview the merged document before you print it. You can do any of the following things at this
point:

Completing the Merge
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• To merge to a new document from the main document, click the Merge
to New Document button in the Mail Merge toolbar.
• To see whether you have the wrong field names or other problems,
click the Check for Errors button.
• To send the merged document directly to the printer, click the Merge to
Printer button.
• To return to the Mail Merge Helper dialog box, click the Mail Merge
Helper button.
In addition to using the buttons in the Mail Merge toolbar, you can use the
Mail Merge Helper so you have more options during the merge. To merge to
a new document from the Mail Merge Helper, complete the following steps:
1. Choose the Tools Mail Merge command. The Mail Merge Helper dialog
box appears.

v

2. Click the Merge button in section 3, as shown in figure 33.7. The Merge

dialog box appears, as shown in figu re 33.8. You can also use the Merge
button on the Print Merge toolbar to access this dialog box.
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Fig. 33.8
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3. In the Merge To drop-down list, select New Document.
4. If you have several letters, you can select only the first few records to
test the merge. In the Records to Be Merged section, select All to merge
all the data, or type the desired record range in the From and To text
boxes.
5. Click Merge to perform the merge. If you use the Merge to New Document button on the Mail Merge Helper toolbar, the results appear in a
new document, as shown in figure 33.9.
Fig. 33.9
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Note
Generally, it is not recommended that you save a merged document, especially when
you have a large data file. The merged document can take a lot of space. If you need
to regenerate the merged document, simply complete the merge again.
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After scrolling through the document to check for problems, print the document as you would any other by opening the File menu and choosing Print.
If you want to print specific pages of the merge, enter the specific pages in
the Pages text box in the Print dialog box.
To print directly to the printer instead of creating a new document on-screen,
select one of the following options:

~

See 11 Printing a
Document,"
p. 134

• Click the Merge to Printer button.
• In the Merge dialog box (refer to fig. 33.8), select Printer in the Merge
To drop-down list, and then click Merge.

~

lEI

Using Data from Excel
One of the advantages of Word 6 is the ease with which you can perform
merges with data sources other than Word documents. In fact, if your data is
stored in Excel, or if you are knowledgeable in Excel, you may want to use it
to create the data file because you have more search, calculation, and reporting capabilities than in a Word data file.
To merge your letter with an Excel spreadsheet, follow these steps:
1. Open the Tools menu and choose Mail Merge. The Mail Merge Helper

dialog box appears.
2. Identify your letter as a main document, as described in the section
11
1dentifying the Letter as a Merge Document" earlier in this chapter.
3. Return to the Mail Merge Helper dialog box, and click the Get Data
button in the Data Source section.
4. Select Open Data Source in the pull-down list. The Select a Data File
dialog box appears, as shown in figure 33.10.
5. Pull down the List Files of Type list, and select Microsoft Excel S.x

worksheet.
6. Select the desired file from the appropriate folder. Click OK to continue.

~

See "Using Mail
Merge," p. 219
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Fig. 33.10
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Note
Before you link (temporarily share data) to Excel, that application must be
installed on your computer. You cannot link to a source file without having its
native application available.

7. Another dialog box prompts you to enter the name or the cell range.
Leave the Named or Cell Range entry as Entire Spreadsheet, as shown in
figure 33.11, and click OK to use all of sheet 1 in the workbook file. The
Mail Merge Helper reappears, as shown in figure 33.12.
Fig. 33.11
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Sorting the Mailing

8. If necessary, change the field names as described in the section Adding
Field Names to Your Letter" earlier in this chapter.
11

9. Complete the merge, as described in the section "Completing the

Merge" earlier in this chapter.

Using Data from Databases and
Other Spreadsheets
If your data is in a database source, Word may be able to use that file directly.

For example, you can use FileMaker Pro files as a data source by exporting
them directly to Word as a merge data file. Because FileMaker Pro and
Microsoft Word both support Apple Events, this process can be automated
with a macro.
If your data is in a spreadsheet file format, try opening the spreadsheet in
Excel. Because Excel can read many different file formats, it is likely that the
file can be translated. Once the file is opened, save the spreadsheet in Excel
format by opening the File menu and choosing Save As. In the List Files of
Type pull-down list, change the type to Microsoft Excel. After you convert
the file, perform the steps in the section "Using Data from Excel" earlier in
this chapter.

Sorting the Mailing
You can sort the letters based on up to three fields in the data source. First
specify the main document and data source (you can't set query options until
you do this). Then, sort the letters by following these steps:
1. Open Tools and choose Mail Merge. The Mail Merge Helper dialog box
appears.
2. Choose Query Options. (You also can click the Query Options button in
the Merge dialog box.) The Query Options dialog box appears.
3. Select the Sort Records tab. The Query Options dialog box appears, as
shown in figure 33.13.
4. You can sort up to three fields. In the Sort By drop-down list, select one
of your fields. The example in figure 33.13 shows Zip.
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Fig. 33.13
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If your list is long, you may want to sort by another field. In figure

33.13, your list is sorted first by ZIP code. For all names with the same
ZIP code, the sort is then organized by company name.
5 . If you want to sort from lowest to highest (A to Z or 1 to 9), select Ascending. If you want to sort from highest to lowest, select Descending.
6. When you finish using the Sort Records tab, click OK. You return to the

Mail Merge Helper dialog box.
7. Finish your sort by clicking the Merge button in the Mail Merge Helper

dialog box, as described in "Completing the Merge" earlier in this chapter.

Selecting Who Receives the
Document
You may not want to send the letter to everyone in the data source. If you
want to send only to selected people, you can complete the merge and
choose Current Page or fill in the Pages area in the Print dialog box, as described in "Completing the Merge" earlier in this chapter. You also can use
the Mail Merge toolbar and Query Options dialog box to select specific
records.

Sending to One Person
If you want to send the letter to only one person in the data source, you can
use the Mail Merge toolbar to find the person and then print the letter like a
normal document.

Selecting Who Receives the Document
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To show the merge for one person, follow these steps:
1. After identifying the main document and the data source, return to the
main document.

2. Click the View Merged Data button in the Mail Merge toolbar. The first
name in the data source shows where the field codes were in the letter,
as shown in figure 33.14.
Fig. 33.14
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3. You can choose the record by scrolling through the list with the same
buttons that are in the Data Form dialog box (refer to fig. 33.5). Go to
the first record or last record and scroll to find the name you want.
Figure 33.14 shows the selection buttons in the Mail Merge toolbar.
4. Find a name by clicking the Find Record button and then entering the

appropriate data in the Find in Field dialog box, shown in figure 33.15.
5. After the name appears in the letter, click the Print button to print the

letter.

111)
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Fig. 33.15
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Troubleshooting
When I try to find a record, the program does not find one that I know exists.

Make sure that you select the right field from the In Field drop-down list box in the
Find in Field dialog box. If the program prompts you to search from the beginning of
the file, choose Yes.

Searching for Matching Criteria
You also can find the record you want by using the Query Options dialog
box. You may want to use this dialog box instead of the Mail Merge toolbar if
more than one record meets your criteria. You may, for example, have many
names from New York and want to send your letter only to those people. If
you use the Mail Merge toolbar, you have to find each record and print it. If
you use Query Options, you can select, merge, and print only New York
records.
To search for many records with the same text, follow these steps:
1. Open the Tools menu and choose Mail Merge. The Mail Merge Helper
dialog box appears.
2. Choose Query Options. (You also can click the Query Options button in

the Merge dialog box.) The Query Options dialog box appears.
3. Select the Filter Records tab, as shown in figu re 33.16.
4. In the Field drop-down list, select the name of the field. You can select

up to six fields.
5. In the Comparison drop-down list, you can select Equal To to match
the text you type in the next column. You also can select options such
as Is Blank, Is Not Blank, and Greater Than.
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6 . In the Compare To text box, type the text or value that you wa nt to

match for th e field. If, fo r example, you want to find Atlanta in the city
field, type Atlanta. If you want salaries above $50,000, type 50000
and select Greater Than in the Comparison list.
7 . If you have more than one line of criteria, you can indicate that you

wan t every record that meets all criteria by choosing And beside the
field names or every record that meets any of the criteria by choosing
Or.
8. When you complete the Filter Records tab, click OK.

9 . Finish your sort by clicking the Merge button in the Mail Merge Helper
dialog box, as described in "Completing the Merge" earlier in this chapter.

Marking Records for Selection
If not all the letters you want to print have the same criteria, it may be easier

to create an extra column or field in the source file and then perform the
merge. For example, you can open an Excel data file, create an extra column
(such as Send), and place an X in each row for data that you want to include
in your merge, as shown in figure 33.17.
When you return to Word, select the Filter Records tab of the Query Options
dialog box and type Send in the Field column, Equal To in the Comparison
column, and X in the Compare To column.

v
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Fig. 33.17
The X's in the
Send column
designate the
people to whom
you want to send
the letter.
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Addressing Envelopes and Mailing
Labels
After you merge a Jetter, you probably want to address envelopes or mailing
labels for each Jetter. The process is essentially the same as creating the letter.
To create envelopes or mailing labels, follow these steps:
1. Open Tools and choose Mail Merge. The Mail Merge Helper dialog box

appears.
2. In the Main Document section, click Create.
3. In the pull-down list, select either Envelopes or Mailing Labels.
4. You are prompted to use the existing active document or a new docu-

ment. Choose New Main Document. The Mail Merge Helper dialog box
reappears.
5. Select or create a data source, using one of the methods described in the

sections for Word and Excel earlier in this chapter.
6. After you select or create the data source, Word notifies you that the

main document needs to be set up. Click the Set Up Main Document
button.

Addressing Envelopes and Mailing Labels
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Depending on your choice in step 3, the Envelope Option s or Label
Options dialog box appears. See "Filling in the Envelope Options Dialog
Box" or "Filling in the Label Options Dialog Box" later in this chapter.
Note
If you later want to edit the Label or Envelope settings, open the Tools menu
and choose Envelopes and Labels.

7. When you finish creating the address, return to the Mail Merge Helper
dialog box. Choose Merge to merge the addresses with the envelope o r
label form. Figure 33. 18 shows completed mailing labels.
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Filling in the Label Options Dialog Box
To set up labels after step 6 in the preceding section , follow these steps:
1. In the Label Options dialog box, select the type of p rinter and the location of the paper tray to which you want to print (see fig. 33.19).
2. The Label Products pull-down list gives you a choice of Avery Standard
labels or other types of labels. Most labels have an equivalen t Avery
number. Figure 33.19 shows Avery Standard.

Merging the
addresses with the
label form results
in completed
labels.

v
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Fig. 33.19

Lebel Options

The Label Options
dialog box enables
you to specify the
type of label and
printer you have.
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3. In the Product Number list box, select the label type by its Avery

number.
4. Verify that the label information is correct for your label.

5. If you want to customize the size or spacing for the label, choose the
Details command button.
6. When you finish with the Custom Information dialog box, click OK to
return to the Label Options dialog box.
7. When you finish with the Label Options dialog box, click OK.
The Create Labels dialog box appears, as shown in figure 33.20.
Fig. 33.20
The Create Labels
dialog box enables
you to enter merge
fields for the label.
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8. Click Insert Merge Field, and select a field from the list. Make sure that

you add spaces and punctuation as necessary to create your label.
9 . When you finish with the label, click OK.

10. When you finish creating the address, you return to the Mail Merge
Helper dialog box. Click Merge to merge the addresses with the label
form.

Add ressing Envelopes and Maili ng Labels
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Filling in t he Envelope Opt ions Dialog Box
To set up envelopes after step 6 of the process of creating envelopes or
mailing labels, follow these steps:
1. In the Envelope Optio ns tab of the Envelope Optio ns dialog box,
select an envelope size in the Envelope Size drop-down list box
(see fig. 33.21).
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Fig. 33.21
The Envelope
Options dialog box
enables you to
change the size
of the envelope
as well as the
orientation of the
envelope in the
printer.

2. In the Delivery Address and Return Address areas, you can change the
fonts or placement of the addresses.
3 . In the Printing Options tab, you can select the orientation fo r the envelope and placement for the addresses.
4 . After you finish filling out the Envelope Options dialog box, click OK.
The Envelope Address dialog box appears, as shown in figure 33.22.
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Fig. 33.22
The Envelope
Address dialog box
allows you to enter
merge fields for
the envelope.
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5. Click Insert Merge Field, and select a field from the list of fields. Make

sure that you add spaces and punctuation as necessary to create your
envelope.
6. When you finish with the envelope, click OK.
7. When you finish creating the address, you return to the Mail Merge

Helper dialog box. Click Merge to merge the addresses with the envelope form.

Creating a List of What You Mailed
If you mailed many different letters, you may want to create a log of each of
the data sources. You can use the log to compare the lists and remove duplicates.
To create a list of each data source, follow these steps:

~

1. Open Tools and choose Mail Merge. The Mail Merge Helper dialog box

appears.

2. In the Main Document section, click the Create button, and then select
Catalog.

...

See "Working
w ith Tables,"
p. 196

3. Answer the prompt to edit the active window, and select the data
source to use data from Word or Excel.
4. After you select your data source, Word reports that it found no fields.

Click the Edit Main document button to return to your document.

5. When you return to the main document, open the Table menu and
choose Insert Table, and create a table that contains one row and the
same number of columns as you have fields.
6. Use the Insert Merge Field button to add field names in each cell of the

table.
Note
Because you may have several lists, make sure that you sort them the same
way by choosing the Query Options button in the Mail Merge Helper d ialog
box and by filling in the Sort Records tab, as discussed in "Sorting the Mailing" earlier in this chapter.

From Here...

7. Complete the merge by clicking the Merge to New Document button in
the Mail Merge toolbar. Each record of your database now appears in a
row of your new table.
In some cases, it may make sense to combine all data sources into one file.
. This may be true if you were using the list for just one purpose. However, you
may want to keep data sources in separate files if you use the lists for different
purposes, such as mailing, accounting, and reporting. Maintaining multiple
data sources increases the possibility of duplicate or conflicting information.
To assist in maintaining your records without duplicate or conflicting information, it is helpful to include a date field in each record showing when the
record is created or updated. You can then refer to the latest date if you have
a conflict.

From Here ...
This chapter explained how to create a Word document and merge the document with a data source. The Word document could be a letter, an envelope,
or a label form. The data source could be a Word data file, Excel spreadsheet,
or some other compatible file type. A merge is completed through the automated process of the Mail Merge Helper. If you want to merge different kinds
of information, read the following chapters:
• Chapter 31, "Using Mail with Other Microsoft Office Products,"
shows you how to send one mail message to multiple network users.
• Chapter 35, "Using Office Applications to Create a Newsletter,"
shows you how to create a newsletter-style mailer.

~
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Chapter 34

Using Office
Applicatior71s to Creat
Presentation
by Donna Minarik

This chapter focuses on integrating Microsoft Office applications with
PowerPoint. If you need overhead transparencies, 3Smm slides, a graphical
report, or an on-screen presentation, it would be most efficient to use
PowerPoint to create the presentation. If the information you wish to present
already exists in other sources, such as Word or Excel, you can copy or link
the information from the source application to PowerPoint.
In this chapter, you learn to do the following:
• Organize a presentation
• Use a Word outline to create slides
• Copy information from other Microsoft Office Applications to
Power Point

Organizing the Presentation with a
Word Outline
An outline of your presentation can be created in Word and used to create
slides in PowerPoint. Suppose that you need to create a presentation and you
already have the information for the presentation compiled in a report in
Word. PowerPoint uses Word's heading styles for the title and bullets of

...,. See "Formatting
with Styles,"
p. 182
...,. See "Outlining
a Document,"
p. 176
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slides. Therefore, you must be sure that the Word document includes these
styles: Heading 1 for the planned title of the slide, Heading 2 for each major
bullet item, and Heading 3 for each minor bullet item. For detailed information regarding outlining in Word, see Chapter 9, "Working with Large
Documents."
To view the document as an outline, choose the View Outline command or
click the Outline View button beside the horizontal scroll bar in the lower left
corner of the screen. The view changes to show your indents for each heading level (see fig. 34.1).

Fig. 34.1
Outline view
enables you to
organize your text
fo r use in a
presentation.
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Heading 1 is the first level
indent. When you convert
to PowerPoint, this level
becomes the slide title
Heading 2 is the second
level indent. This level
becomes first level bullets
in PowerPoint
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Outline View button
Heading 3 is the third level indent. This level becomes the second level indents in PowerPoint

When you choose the View Outline command, the document changes to
show different heading levels, and the Outlini ng toolbar becomes available.
You can use the Outlining toolbar to show 1-8 levels in the outline. The
numbered buttons on the toolbar correspond to Heading styles of the same
numbers. If you have three levels defined, for example, only three buttons

Organizing the Presentation with a Word Outline
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will be active. Figure 34.2 shows the outline when you click the Show Heading 1 button. Click the All button to show your entire document. You also
can use the Outlining toolbar to alter levels in the outline.
Fig. 34.2

o Street =
o Gang
er
a Associate Gang MEmber
a
Levels Of Gang InvolvEment
a Level l - Make Believe
a Level II - AI Risk
a Level ill - Vo.Qnna-be (Associate)
a LoveiiV- Gang MEmber
a
Level V - Hard Core Gang MEmber
a Why Kids Join Gangs
a
Ear1yVo.Qmlng Signs or GangiDrugAcliYily

The numbered
buttons along the
Outlining toolbar
enable you to see
one or more levels
in your outline.

v

Text form atted with
Heading 1 styles

Show Head ing 1

If a head ing (for example, Heading 1) does not contain supporting text, a
minus sign appears to the left of the heading. If a heading does contain sup-

porting text, a plus sign appears to the left of the text. Double-click the plus
sign to show other headings and body text. Double-click the plus sign again
to compress the text.
To move a heading (along with all subheadings and text below the heading),
place the mouse pointer on the plus or minus sign before the text. The mouse
pointer changes to a black, four-headed arrow (see fig. 34.3). Drag the mouse
up or down to the desired position. You also can use th e Move Up or Move
Down button in the Outlining toolbar. The Move Up button moves theselected text up in the outline. The Move Down button moves the text down in
the outline. To change a level in the outline, use the Promote and Demote
buttons in the toolba r, or ch ange the style to a different heading. Th e Promote button changes the selection to a higher level (from Heading 2 to
Heading 1). The Demote button changes the selection to a lower level.

~

See "Editing a
Style," p. 184
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Demote Button
Promote Button

Fig. 34.3
Drag the plus o r
minus signs, or
use the buttons in
the Outlining
toolbar, to change
the order of text
for your slides.

When you finish organizing your outline, save and close the document.

Using a Word Outline to Create Slides
Once your outline is complete, you can use it in PowerPoint to create a new
presentation or to add slides to an existing presentation. To start a new presentation, follow these steps:
~~~

1. Within PowerPoint, open the File menu and choose Open.
Note
If you are not in PowerPoint, you will see a Tip of the Day dialog box when
you first open the program. To close the Tip of the Day, choose Open an
Existing Presentation and click OK.

2. In the List Files of Type menu, choose All Readable Outlines to display
Word documents.
3. Locate the Word outline in the appropriate folder, if necessary.

Using a Word Outline to Create Slides
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Note
You also can use Excel worksheets to create slides.

4. Choose the outline file by clicking to highlight it.
5. Click Open.

Figure 34.4 shows the outline view of the presentation. The number 3 slide
shows Gang Member. To switch to Slide View, click the Slide View button in
the bottom left corner of the presentation window or use the View menu.
Figure 34.5 shows the slide view of the Gang Member definition slide. Compare this slide with figure 34.1. Heading 1 style became the title of the slide,
Heading 2 became the first bullet, and Heading 3 items became subpoints of
the bullet. Figure 34.5 also shows that editing text for a slide presentation
may be necessary if there is too much text for the slide.

~

See "Viewing a
Presentation,"
p.440

v
Fig. 34.4
A Word document
opened in
PowerPoint
becomes an
outline.

• An ongoing organization, association, or
group of three or more persons, wbether

forma l or informal. who have a common
name or common identifying sign or symbol,
wbose members individually or collectively,
engage in a pattern of unlawful or criminal
activity.

El Gang Member
• An individual wbo has been positively
1dentilied as being a member of a particular
gang. Examples of positive identification

are:
- I) ..tr Zl!miiWXe to a lav enforcement officer;

The Outlining toclbar fer the presentation in
PowerPoint works the same as it does in Word

I
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Fig. 34.5
The heading styles
shown in figure
34. 1 create each
slide.
Heading 1 becomes the title
Heading 2 becomes a bullet

Heading 3 beco mes a
second-level bullet

• An individual who has been pa;itively
identified as beiog a mem ber of a particular
gaog. Examples of positive identification
- 1) relf admittance to a law enforcement officer:
- 2) rattoos identifying a particular gang
- 3) participating in gang related activity or
- 4) any other circurrutances when an officer can
articulall! obvious
membership. i.e. a
combination of

After you open a Word file to create a PowerPoint presentation, you can select a format more interesting than simple black text on a white background.
To change the format, click the Pick a Look Wizard button (see fig. 34.6) or
use the Format Pick a Look Wizard command.
Fig. 34.6
Use t he Pick a
Look Wizard to
change the
formatting of your
presentation.
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Click the Next button to go
through each step of the wizard

Follow the steps in the Wizard dialog box to select the formatting for the
slide, notes pages, outline, and handout pages. To accept all the default
choices or choices you made for the last wizard, click Finish. Figure 34. 7
shows the formatted and edited slide fro m figure 34.5.

Automating the Process from Word to PowerPoint

Member
An indvid.Jal who has been positively
identified as being a member cl a particular
gang. Examples cl p ositive tdentification are:
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Fig. 34.7
The original slide
in figure 34.5 is
edited and
formatted.

• I) sell'atinitt.'l/lt."d It> a t.~w Wlll>n:<lfllt'l/f l¥11<-'dt;
• ~') Wf<><>-~ idt1111/J}1i1!l a paf11,:U.~r p;~np
• .1)p:wicip.<lillflin !A"~ Nated.'it:liri~<>r
• 4)
t>fhen:/n:un<t.<n<:es H'htlll .111 t>!!ft:drt:..'il/
.wt/cuLNe o/lrlt><JS gmpm<KTJ/IdJol¥p

·"o/

Note
You can insert the Word outline into an existing presentation. The Word outline
assumes the format of the existing PowerPoint presentation. To insert a file into the
presentation, choose the Insert, Slides from Outline command and identify the file

v

name and location.

Troubleshooting
I cannot open my file.

You may not have closed the Word document before you returned to PowerPoint
Click the Word button in the Microsoft Office toolbar. If necessary, choose the Window command and select the document name. Choose the File Close command to
close the document Click the PowerPoint button to return to PowerPoint

Automating the Process from Word
to PowerPoint
Word provides a macro that automates the process involved with converting
a Word outline to a slide presentation. The Presentlt macro is in the Macro
folder located in the Word 6 folder. You can attach the macro to your current
document by opening File and choosing Templates Attach. You can then run
the Presentlt macro to automate the conversion process. If you create many

~

See "Using
Template
Wizards, "
p. 190

~

See "Using
Macros," p. 212
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presentations, however, you may want to add the Presentlt macro to your
Normal template and a corresponding button to your toolbar so this feature
is readily available.
To add the Presentlt macro to your normal template, follow these steps:
1. Open File, choose Templates. The Templates and Add-Ins dialog box

appears.
2. Click the Organizer command button. The Organizer dialog box
appears, as shown in figure 34.8.
Fig. 34.8
Select Presentit
from the scrolling
list on the left and
copy it to Normal
(Global Template)
on the right.
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3. In the Macros tab, select Presentlt from the ln Normal scrolling Jist on

the left, and then click the Copy command button. Presentlt appears in
the To Normal (Global Template) Jist on the right.
4. Click Close to finish copying the macro.

To run the Presentlt macro, follow these steps:
1. Open Tools and choose Macro (see fig. 34.9).
2. Choose the Presentlt macro and click Run.
lf you want to display the Presentlt macro with a button representation on
the toolbar, follow these steps:

1. Open View and choose Toolbars.
2. Click the Customize button.
3. Choose Macros from the Categories list.
4. Drag the Presentlt macro to the desired position on the toolbar

(see fig. 34.10).

Summarizing Data in Excel and Linking a Range to PowerPoint

Fig. 34.9
The Macro
command under
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enables you to
choose and run
the Presentlt
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Fig. 34.10
Using the
customize feature,
you can drag the
Presentlt macro to
the toolbar.

...,

5 . Choose the desired button appearance wh en prompted.
6 . Click the Assign button.

Now you' ll be able to quickly convert a Word outline to a PowerPoint Presentation by simply clicking the button you've just added to the toolbar.

Summarizing Data in Excel and
Linking a Range to PowerPoint

<Ill

If you have info rmation in Excel that you want to bring to the presentation,
you can copy and paste the information or link the information. If you want

<Ill

the data in the presentation to be updated each time the Excel worksheet
changes, link the information from Excel.

See "Copying
and Moving,"

p.43
See "Copying
Spreadsheet
Information,"

p.593

v
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You first must create a new slide to accept the data. To create a new slide that
accepts data from Excel, follow these steps:
1. Open Insert and choose New Slide. Or click the New Slide button in the

lower right part of the screen.
2. Highlight the graph layout and click OK (see fig. 34.11). A new slide

appears with instructions for adding the title and graph (see fig. 34.12) .
3. To remove the graph instructions, click where the slide says Double
click to add graph and press delete.
Fig. 34.11
Select the graph
style by choosing
Insert New Slide,
or by clicking the
New Slide button
in the lower right
part of the screen.

Fig. 34.12
Click once in the
graph area and
press delete to
remove the
instruction to
add a graph.

Now Slide

c•• 1111 Aatolllpat:

I

El ~ l~l~
~~m

~~M

0~

I

~

--

~

_I

Gro•~

ij

J

,--------------------------------------------1

I

I

I

!Click to add title
I

l

......... ... ......... ... ... ... ....... ............ ...... ... ............ ... ...... ...... ... ... ... ... ... ...... ... ... ... ... ... ... ... .
I

:
:

•
Double click to add graph

i:
I

:

:
:
I

I
I

·---------------------------------------------..!

Now you're ready to copy information from Excel to the slide. To copy the
information from Excel, follow these steps:
1. From within PowerPoint, click the Excel button on the Microsoft

toolbar (if displayed). Or use the application menu to either switch to
Excel or to the finder to open Excel.
2. Open the file containing the information that you want to copy.
3. Drag the mouse pointer (a white cross) to select the range in Excel

(see fig. 34.13).

Summarizing Data in Excel and Linking a Range to PowerPoint
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Fig. 34.13
Highlight the
range you wan t to
copy in Excel.

v
4. Open Edit and choose Copy.

5 . Use the application menu to return to PowerPoint.
6. Open Edit and choose Paste Special. The Paste Special dialog box

appears (see fig. 34.14).
Post e Speclol

Fig. 34.14
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7. To paste a picture of the Excel range, choose the Paste As command,

and then choose Picture in the list box.
Or, to paste the contents of the Clipboard into your presentation (so
that you can double-click the worksheet data to enter Excel and edit the
worksheet), choose Microsoft Excel 5.0 Worksheet Object.

The Paste special
box provides you
with two options
fo r pasting
information
fro m Excel.
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Note
If you click the Paste button in the toolbar or open Edit and choose Paste, the
spreadsheet is unformatted when it arrives in the slide. For optimal appearance, it's better to use the Paste Special options. The Unformatted Text and
Formatted Text options bring the information from the worksheet as text

8. Click OK in the Paste Special dialog box. The worksheet appears in your
slide (see fig. 34.15). Complete the slide as necessary.
Fig. 34.15
The worksheet
appears in the
slide

Click the title
area and type
a title

-----------------------·- -----··--------------·'
'

''

~~3~~~~~~~~~L--~Drag the
~

handles to
resize the
picture

Troubleshooting
When I copy to PowerPoint, the data from my Excel spreadsheet is not lined up.

Make sure that you select the Picture option in the Paste Special dialog box. Don't
open Edit and choose Paste and don't click the Paste button to bring in your copy.
The Excel worksheet is too big for my PowerPoint slide.

Try simplifying the worksheet before you copy it to PowerPoint. You also can change
the size of the worksheet in PowerPoint by dragging the picture handles, but remember that your viewers must be able to read the slide.

Creating Charts in Excel and Copying
to PowerPoint
Adding an Excel chart to the presentation is essentially the same as adding a
worksheet.

Creating Charts in Excel and Copying to PowerPoint
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To add an Excel chart to a slide, follow these steps:
1. Click the middle of a chart in a worksheet to display handles on the
chart (see fig. 34.16).
Olulslon Sol es

C

D

Fl scnl Veor Sal es

lfl
Otr

2nd

!rd

Otr

Otr

Select the chart
you want to copy.

41h
01r

2 . Open Edit and choose Copy.

3. Return to the PowerPoint slide.
4. Open Edit and choose Paste Special. The Paste Special dialog box

appears (see fig. 34.14).
5. Click the Paste radio button. Then, in the As list box, select Microsoft
Excel 5.0 Chart Object. The object choice enables you to double-click
the chart to return to Excel and edit the object. Or, choose Picture to
see only the chart.
6. Click OK in the Paste Special dialog box.

You also may need to resize the chart (drag the handles) and add a title to the
slide. Figure 34.17 shows the completed slide.
Note
If you want the slide background to match the chart background, make sure that you
format the chart in Excel by using the Format Object command. Choose None for
Borders and None for Fill.

Fig. 34.16

v
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Fig. 34.17
The edited slide
appears, containing the Excel
chart.

• a
Embedding the Presentation 1n
Mail Message
If you want to send your finished presentation to others on your network for
review, you can embed the presentation in a Mail message. See Chapter 31,
"Using Mail with Other Microsoft Office Products," for step-by-step
instructions.

From Here ...
This chapter shows you how to work with the different applications in
Microsoft Office to create documents and presentations. If you want more
details about how to create presentations and work with graphics, refer to the
following chapters:
• Chapter 10, "Working with Tables, Charts, and Graphics," helps you
with these Word features.
• Chapter 16, "Creating and Printing Reports and Charts," shows you
how to create and enhance a chart in Excel.
• Chapter 23, "Drawing Shapes, Curves, and Lines," explains how to add
additional drawing items to your PowerPoint slides.
• Chapter 26, "Creating Output," shows you how to print your slides or
run your PowerPoint presentation on-screen.

Chapter 35

Using Office
Applicat·ons t
Newsle ter___
by Donna Minarik

v
Microsoft Office provides powerful and capable tools to create professionalquality newsletters and flyers. For most purposes, page layout software is no
longer necessary to prepare basic publications. This chapter focuses on combining text and graphics from various sources in Microsoft Office to design a
newsletter.
In this chapter you learn to
• Use Word to create text in multiple columns
• Place page numbers, mastheads, and text in Headers and Footers
• Use section breaks to create headlines
• Add and position Graphics from WordArt, Excel, and PowerPoint

Creating Multiple Columns of Text
A page of text in Microsoft Word can be divided into more than one column
to make the text well organized and easy to read. Documents such as books,
magazines, catalogs, newsletters, and brochures are often divided into columns. To divide a document into multiple columns of text that flow from
one column to the next, follow these steps:

<0111

See "Creating
Columns,"
p. 121
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1. Select the text you would like to format in columns or leave text
unselected to format the entire document.

2. Choose the Format Columns command. The dialog box shown in
figure 35.1 allows you to choose one, two, three, or a wider left or right
column. You also can enter the Number of Columns desired in the text
box.
Alternatively, you can click the Columns button on the Standard
toolbar, and drag to choose the number of columns you want.
These will be equal width columns.
Fig. 35.1

Columns

This example
in the Preview
section shows one
column wider
than the other for
effect.

0

r

"'''

Ollne-n

'!f

0 Slort ,..,_Column

3. Select the desired column numbers and adjust the Width and Spacing.
View the result of the choices in the Preview box.
4. If you want a vertical line between the columns, activate the Line

Between check box.
5. Click OK.

Note
For best results, divide an 8 1/2-by-11-inch portrait-oriented page into no more than
three columns. If you use too many columns or make columns too narrow, the lines
of text become too short and are hard to read. Also, use care when choosing space
between columns. Too little space makes the text in columns run together; too much
space creates wide gaps and makes the text harder to follow.

In Normal view, the document will show only one narrow column on the left
side of the window as shown in figure 35.2.

Creating Multiple Columns of Text
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Fig. 35.2
Text appears in a
single column in
Normal view.
~

See "Viewing
the Document," p. 104
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To view multiple columns on the screen, switch to page layout view by
choosing the View Page Layout command or clicking on the Page Layout
button along the left of the bottom scrollbar (see fig. 35.3).

v

II
Fig. 35.3
Page Layout view
shows the columns
as they will
actually appear
when the docum ent is printed.

Welcome to Scouting
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attend PttCkmeetittct olona with
their scoutt.
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column marker on the
horizontal ruler to
adjust the column
width
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If you would like to change the column width once the columns are created,
you can choose Format Columns and adjust the measurements, or drag the
left or right column marker on the horizontal ruler (see fig. 35.3).

Controlling Sections and Section
Breaks
Word documents are composed of one or more sections. Each section can
have its own formatting for such things as columns, headers, and footers.
Documents start out as a single section, and you add section breaks to create
additional sections.
If you apply column formatting to a selected block of text, Word automatically inserts section breaks before and after the selected text. Figure 35.4
shows the document previewed in figure 35.1 in Normal view with section
breaks displayed. Section breaks can be displayed in page layout view by
clicking on the Show/Hide 'I button on the toolbar.
Fig. 35.4
Section breaks
are displayed in
Normal View,
showing where
the change in
formatting begins
and ends.
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Section breaks also are useful in creating a headline or title that spans the top
of several columns as shown in figure 35.5.
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Breaks

Controlling Sections and Section Breaks
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The title in this
document is
centered in one
column, but the
body text is two
columns.
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To create the look in figure 35.5, complete the following steps:
1. Type the headline text at the top of the left-hand column, above the

rest of the text in the column.
2 . Press return so the headline appears in its own paragraph.
3. Select the headline text.

4. Click the columns button and drag to select a single column.

Word creates a section break beneath the selected text.
5. Center the text using the Center button on the toolbar and apply the
fon t size or style you want.

At times it is more efficient to add your own section breaks and column
breaks to achieve the look you want for your document. Choosing the Insert
Break command will display the Break dialog box needed (see fig. 35.6) to
add one of the following:
• Page Break. Use to break text before the bottom margin, sending any

following text to the next page.
• Column Break. Use to break text in a column, sending any remaining

text in that column to the next column (see fig. 35.7).

v
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• Section Break. Use to break text into sections with different formatting
possibilities. Next Page, Even Page, Continuous, and Odd Page allow
you to choose where the text will continue following the break.

Fig. 35.6
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Adding Headers and Footers
A header or footer is text or graphics added to the top or bottom of each page
in a document. A header appears at the top of the page and a footer appears
at the bottom. In a newsletter consisting of more than one page, you may
want to add page numbers or a masthead in the header or footer so it will
appear on all the pages in the publication. To attach a page number to the
bottom of each page, perform the following steps:
1. Choose the View Header and Footer command. The document shows

the header-a text block contained by dotted lines at the beginning of
the document or section. The Header and Footer ruler also appears.

Adding Headers and Footers
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2. Click the Switch Between Header and Footer button on the Header and
Footer ruler to view the footer as shown in figure 35.8.
Fig. 35.8
This footer
contains the page
number centered
o n the page.

. - - - - - - - - - - - - - - - - - - - lE -1- Switch between
Header and
Footer button

v
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:
'
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The tab key centers the information

3. The insertion point lines up on the left edge of the foo ter automatically.
If you would like the page number centered, press the tab key once. To

align the number to the right, press the tab key twice.
Tip

4. Type any preceding text you want, such as the word Page in figure
35.8. Then click the Page Num ber button on the Header and Footer
ruler. This inserts a field that will seq uentially number each page in
your section .
5. From the View m enu, return to the original page form.

Note
Word allows yo u to select different formatting for your page numbers. You may
choose ABC instead of 123, for example. Use the Insert Page Numbers command
and click the Format button to select the desired formatting.

To o mit page
numbers or o ther
Header and Footer
info rmation from
the first page, click
the Document
Layout butto n in
the Header and
Footer toolbar, and
choose Different
First Page o n the
Layout tab.
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While this example illustrates adding page numbers to a footer, the procedure
is the same for addjng any information or graphics to a header or footer. Text
in a header or footer can be forma tted like any other text. The Header and
Footer ruler provides buttons to add printing date and time fields as well.
Normally, the left and right edges of the Header and Footer areas align themselves with the margins set for the document. Figure 35.9 shows a document
that contains a header that has been adjusted horizontally to extend into the
margin.

Fig. 35.9

This document
contains both a
Header and a
Footer.

Drag the indent
markers on the
ruler to move the
header position
into the margin

The page number is centered in the footer

Adding Graphics
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See "Working

with Tables,
Charts, and
Graphics,"
p. 195

Newsletters, brochures, and flyers are normally m ore visually pleasing and get
more attention if they contain graph ics or illustrations. Graphics can come
from many sources. They can be drawn using Word's built in drawing tools,
or pasted from PowerPoi n t or Excel.

Using Borders and Lines
Borders are a simple way to draw attention to a block of text, o r to divide
different newsletter areas. The d iv iding line previously shown in figure 35.9,
for example, was created as a border beneath the paragraph.

Adding Grap hics

721

To add borders to your document, follow these steps:
1. Select the paragraph or paragraphs to which you wa n t to add a border.

2. Choose Format Borders and Shading. The Paragraph Borders and
Sh ading dialog box appears (see fig. 35.10).
Fig. 35.10
The Border
box displays a
representation
of selected
paragraphs.

--
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This line was created using the settings in the dialog b ox shown here

3. Click in the Border box at the desired border locations.
4. Choose a li ne style and color from the lists on the right.
S. Click OK.

Drawing with Tools in Word and PowerPoint
Word's drawing tools allow you to draw shapes and arra nge them directly on
your document. They can be accessed in one of two ways:
• Choose the View Toolbars command and activate the Drawing option.
• Click the Draw button on the Toolbar.

<1111

See "Working
with Tables,
Charts, and
Graphics,"
p. 195
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Either method will activate the Drawing Toolbar, which normally appears at
the bottom of the screen . Figure 35.11 shows the Drawing Toolbar, with the
various tools labeled.

Fig. 35.11
Word's Drawing
Toolbar provides
strong graphics

capabilities.

Line Style - - - - - - - - - - - '
Select Drawing Objects - - - - - - - '
Bring to Front - - - - - - - - - - '
Send to Back
Bring in Front of Text _ _ _ _ _ _ _ ____.
Send Behind Text - - - - - - - - - - - - - '

' - - - - - - Rotate Right

To use the drawing tools, follow these steps:
1. Click the desired tool to select it for use.

2. Position your mouse pointer at the location in your document where
you want the shape to begin.
3. Drag the shape to the desired size.
After a shape is created, you can control its appearance in several ways:
• Reposition the shape by pointing at its border and dragging to the new
position.

Adding Graphics
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• Resize the shape by pointing at any of the size handles on the border
and dragging.
• Use the appropriate tools on the toolbar to change the shape's fill
pattern, fill color, line pattern, and line color.
PowerPoint contains a nearly identical drawing tool set. A portion of the
tools are automatically displayed along the Drawing toolbar on the left side
of the screen when the software is opened. Additional tools are available by
choosing View Toolbars and choosing the Drawing+ tool bar. Shapes can be
created in PowerPoint, if you prefer, and moved to your Word document
using the Edit Copy and Paste commands.
Note
To wrap text around a draw object, you can select the object and choose Insert
Frame. See the section on positioning graphics later in this chapter for step-by-step
instructions.

Formatting Text with Word Art
Word comes with a supplementary application called WordArt which allows
you to create interesting effects to enhance newsletters, flyers, and brochures.
Using WordArt, you can arrange any TrueType or Adobe Type Manager
(ATM) font into a variety of shapes and alignments, add 3-D effects and
more.
To create a special effect with WordArt, complete the following steps:
1. Place the insertion point where you would like the special text to

appear.
2. Choose Insert Object.
3. In the Object Type box (see fig. 35.12), choose Microsoft WordArt 2.0.
4. Click OK. The WordArt dialog box shown in figure 35.13 appears.

5. Select the text effect options you want to try from the dialog box.
Choose Update Preview to view your text changes. Figure 35.14 shows
text using the Button shape.

v
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Fig. 35.12
Select Microsoft
WordArt 2.0, an
application that
uses OLE to add
objects to a Word
document.
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The Update
Preview Button
allows you to view
your effects.

Tip
For more information on the
text effect
options, click
the Help button in the
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6. When you have created the desired effect, click OK. The WordArt object
will automatically be inserted into your document where the insertion
point was placed.
Once the object has been placed in your newsletter, you can resize it by dragging the black handles. To edit the text or change the effect once the object

Adding Graphics
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has been placed, double-click it and you will return to the WordArt dialog
box. Figure 35.15 shows the WordArt button placed, resized, and positioned.
See "Positioning Graphics" later in this chapter for more details.
Fig. 35.15
WordArt 2.0
effects can be used
to enhance a
newsletter.
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Adding Charts and Tables from Excel
Charts and tables are often used in newsletters and other similar publications
to illustrate numeric topics in an interesting, understandable way. Chapter 10
of this book discusses using Word's built-in application Graph . However if
you have charts in Excel that you would like to add to your newsletter, follow
these steps:
1. Click the middle of a chart in a worksheet to display handles on the

chart.
2. Choose the Edit Copy command.
3. Return to the newsletter in Word and place the insertion point where
you wan t the chart to be placed.
4. Choose the Edit Paste Special command. The Paste Special dialog box

appears.
5. Choose the Paste as Picture command.
6. Click OK in the Paste Special dialog box.

<1111

See "Using
Charts," p. 338
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You also may need to resize the chart (drag the handles) and add a title to the
slide. Figure 35.1 6 shows the chart added to the newsletter.
Fig. 35.16
Adding a pie chart
to the newsletter
may help readers
better understand
the information in
the text.

~
~

Adding Clip Art from Word and PowerPoint
Both Word and PowerPoint contain extensive clip art libraries with graphics
on a wide variety of topics. Helpful, professionally designed illustrations such
as maps, organizational charts, and even humorous graphics are available.
Word's graphics are stored in the Clip Art Folder inside the Word program
folder. To add clip art from Word:
1. Choose the Insert Picture command and locate the Clip Art Folder.
2. Select the Preview Picture check box.

3. In the Jist of file names, select the name of the file you want to see.
4. When you find the graphic you want, click the Insert button to insert

the selected graphic into the document.
~

See "Inserting
Clip-Art
Pictures,"
p.460

To place clip art from PowerPoint's ClipArt Gallery into Word, complete the
following steps:
1. Choose the Insert Clip Art command or click the Insert Clip Art button
on the toolbar.
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2. Select the image you want. See Chapter 21 , "Entering Slide Content,"
for additional details on choosing an image.

3. Click OK. The image now appears on a slide.
4. Select the image.
5. Choose Edit Copy.

6. Use the application menu to return to the newsletter document in
Word.
7. Choose Edit Paste.
8. Resize or position the image as necessary.

Positioning Graphics

v

Graphics placed in your n ewsletter from any of the sources discussed previously in th is chapter can be positioned in the same way. Graphics can be
centered, left-, or right-aligned with the text using the text alignment tools
on the toolbar. Figure 35.17 shows a graphic that has been centered in the
column in this way.
Fig. 35.17
Select the graphic
and choose the
Centering tool on
the toolbar.
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You can use a frame when you need more control over a graphics position.
To position a graphic using a frame, it's easiest to work in page layout view.
Switch to page layout view and complete these steps:
1. Select the graphic.

2. Choose the Insert Frame command.
3. Drag the framed graphic to the desired position. When you release the
mouse button, the graphic will move to its new position (see fig. 35.18).
Fig. 35.18
This graphic was
resized and
dragged into
position using a
frame in page
layout view.
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Text can be framed and positioned using a frame also. An example of positioned text is a pull quote. Pull quotes are used in magazines and newsletters
to draw the reader's attention to a particular article. To use a frame to create a
pull quote and position text, follow these steps:
1 . Select the text you would like to frame.
2. Choose the Edit Copy and Edit Paste commands to duplicate the text.

3. Select one copy of the text as shown in figure 35.19.
4. Choose Insert Frame.

5. Resize the frame as necessary.
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Fig. 35.19
The sentence is
selected and ready
for the frame to be
inserted.
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6. Drag the framed graphic to the desired position. When you release the

mouse button, the graphic will move to its new position. Text will wrap
around the graphic as shown in figure 35.20.
Fig. 35.20
Text wraps around
a pull quote
positioned by
using a frame.
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I

Note
Tables can be used to caption graphics. Create a one column, two row table as
directed in Chapter 10. Paste the graphic in one cell and type the caption in the
other. Select and frame the table and position the graphic and the caption.

From Here...
Refer to the following chapters for information related to creating a
newsletter.
• Chapter 6, "Proofreading and Printing," will assist in assuring quality
output of your finished product.
• Chapter 10, "Working with Tables, Charts, and Graphics," contains
additional tips on placing graphics in a Word document.
• Chapter 21, "Entering Slide Content," includes details of PowerPoint's
ClipArt Gallery.
• Chapter 33, "Sending a Mass Mailing," explains how to print labels and
envelopes to mail your newsletter.
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Chapter 36

Changing
Menus
by Tom Negrino

Microsoft Office m akes it easy for you to customize application toolbars and
menus to meet your n eeds. You can add, remove, or change the order of the
application features in the menus and toolbars. You even can create your own
tool bars. Better yet, when you know how to customize toolbars and menus in
one applicatio n, yuu can du so in all applications.
In this chapter, you learn to
• Customize Office Manager
• Customize application toolbars
• Customize application m enus

Customizing Office Manager
You can customize the Office Manager menu to meet your needs. You can
add applications or documents to the Office Manager menu. To customize
Office Man ager, open the Office Manager menu and choose the Customize
command. Office Ma nager displays the Custo mize dialog box (see fig. 36.1).

<Ill

See "Looking
at Microsoft
Offi ce," p. 20

<Ill

See "Using
Dialog Boxes,"
p.34

VI

734

Chapter 36-Changing Toolbars and Menus

Fig. 36.1
The Customize
dialog box lets
you add or
subtract applications from the
Office Manager
menu.
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Customizing the Menu
By default, the Office Manager menu lists the Microsoft Office programs and
other Microsoft application programs (refer to fig. 36.1). Select the check
boxes to include or exclude an application from the menu.
The New button enables you to add your own menu items. When you click
the New button, an Open dialog box appears (see fig. 36.2).
Fig. 36.2
Select an application you want to
add to the Office
Manager menu,
and then click the
Add button.
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To add menu items, follow these steps:
1 . Choose Customize from the Microsoft Office menu. The Office Manager

control panel appears.
2 . Click the New button.

3. From the Open dialog box, navigate to the application or document file
you want to add.
4_ Select the file, and then click the Add button.

Customizing Application Toolbars

5. (Optional) Use the Move up or Move down arrows to place the new file
where you want in the menu.
6. Close the Customize control panel.

To edit the settings for an existing item, select the item and click the Edit
button. The Remove button enables you to remove menu items that you add.
When you complete your selections, close the Customize control panel.

Other Office Manager Customizations
Directly below the list in the Office Manager control panel are two check
boxes. One allows you to disable the Office Manager menu, and the other,
when checked, adds the icons of the applications installed to the Office Manager menu.
The QuickSwitch area of the Office Manager control panel lets you turn the
QuickSwitch feature on or off. QuickSwitch allows you to cycle through the
currently open applications by pressing ):(+tab. If desired, QuickSwitch also
can tell you information about the memory usage of the program to which
you are switching. Turn on QuickSwitch and the QuickSwitch memory info
by clicking the appropriate check boxes in the Office Manager control panel.

Customizing Application Toolbars
Customizing toolbars in Microsoft Office applications gives you a great deal
of flexibility in setting up the applications to meet your particular working
style. The applications give you many customizing options.

Customizing Predefined Toolbars
Each application comes with several built-in toolbars, some of which appear
automatically. For example, by default, Microsoft Word displays the Standard
and Formatting toolbars. In addition to these, you can display the following
predefined toolbars:
• Borders
• Database
• Drawing
• Forms
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• Microsoft
• Word for the Macintosh 5.1
• Mail
• PowerBook
Excel and PowerPoint provide sets of predefined toolbars. Excel has 13, and
PowerPoint has 7. You can customize any of the built-in toolbars to better
meet your needs, or you can create your own toolbar. You could have a
toolbar for every type of task you perform (for example, one for mail merges
and one for desktop publishing) or a separate tool bar for each user of the
computer.
To customize a built-in toolbar, follow these steps:
1. Open the View menu and choose the Toolbars command. The Toolbars
dialog box appears (see fig. 36.3).
Fig. 36.3
The Tool bars
dialog box lets
you set which
tool bars will be
visible, and lets
you customize a
toolbar.
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2. Choose the Customize button. The Customize dialog box appears
(see fig. 36.4).
Fig. 36.4
The Toolbars tab
of the Customize
dialog box enables
you to drag
buttons to any
toolbar displayed
on-screen.
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Customizing Application Toolbars
3. To add items to a bui lt-in toolbar, select the category that contains the
buttons or other items that you want to add.
4. Drag the desired buttons or items from the Buttons section to the builtin toolbar.
5. To remove items from the built-in toolbar, drag the buttons or items

from the toolbar to the Customize Tool bars dialog box.
6. To move buttons or items, drag them to a new location or a different
tool bar.
7. To copy buttons or items, press the option key while dragging them to
the destination toolbar.
8. Click Close to close the Customize Toolbars dialog box.
Note
You can move, delete, or copy a toolbar button without opening the Customize dialog box. To move a button, hold down the ~ key and drag the button
to the new location. To delete a button, hold down the ~ key and drag the
button to the document window. To copy a button, hold down the option
key and drag the button.

Creating a Custom Toolbar
In addition to modifying the default toolbars of Microsoft Office applications,
you can create your own custom toolbar (except in PowerPoint, which does
not allow you to create new toolbars). For example, you could have a toolbar
for every type of task you do, such as one for mail merge and one for desktop
publishing.
To create a custom toolbar, follow these steps:
1. Choose the View Toolbars command to display the Tool bars dialog box.

Note
For information about each application's Standard toolbar, see Chapter 2,
"Using Common Features to Create Documents," or see the chapters pertainIng to the individual application.
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2. Click the New button. (In Excel, the New button is not available until
you enter a name for the toolbar in the Toolbar Name text box.) The
New Toolbar dialog box appears (see fig. 36.5).

Fig. 36.5
The New Tool bar
dialog box allows
you to name your
new custom
tool bar.
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3 . Enter a name for the toolbar in the Toolbar Name text box.

4. In Word, select the template in which you want to store the toolbar
from the Make Toolbar Available To pop-up menu.
5. Click OK. The Customize dialog box appears, along with the new
(empty) toolbar.
6. Select the category that contains the buttons or other items that you

want to add to the new toolbar.
7. Drag the desired buttons or items from the Buttons section to the new

tool bar.
8. Repeat steps 6 and 7 until you fi ll your custom toolbar with the desired

features (the toolbar expands to accommodate your selections).
9. Click the Close button to close the Customize dialog box.

Note
Although Word screens are used in this section to illustrate the process of creating
custom tool bars, the screens in Excel are similar. Any exceptions are noted.

Troubleshooting
The new too/bar I created contains no buttons.

A new tool bar is empty until you add buttons. With the new toolbar visible onscreen, return to the Customize dialog box. Select the category containing the
buttons you want to use, and drag the button images to your custom toolbar.
Someone customized the default too/bar. I need to get the standard too/bar back.

Choose the View Toolbars command, select a toolbar, and click the Reset button to
return to the built-in version of the selected toolbar.

Customizing Application Menus
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The colored too/bars are hard to see on my black-and-white monitor.

Choose the View Toolbars command, and deselect the Color Toolbars check box at
the bottom of the Toolbars dialog box. Deselecting this option gives the toolbar
buttons better contrast.

Customizing Application Menus
Consistency among products is not as good when it comes to customizing
the application menus. No interactive method of modifying the application
menus exists in Excel or PowerPoint. Excel requires you to use Visual Basic,
Application Edition. Currently, only Word provides an interactive method of
customizing built-in menus and creating custom menus.

Customizing Word Menus
You can change the organization, position, and content of default Word
menus. To do so, follow these steps:
1. Open the Tools menu and choose the Customize command. The Customize dialog box appears (see fig. 36.6).
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2. Select the Menus tab.
3. Select the category that contains the command you want to use.

4 . In the Commands list, select the command.
5. To assign a command to another menu, select the menu name from the

Change What Menu pop-up menu.

Fig. 36.6
Word enables you
to customize its
built-in menus.
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6. To change the position, select the desired position from the Position on

Menu pop-up menu. (Select Auto if you want Word to position the
menu item for you.)
7. To change the name of the menu item or the shortcut key, edit the text

in the Name on Menu text box.
8. In the Save Changes ln pop-up menu, select the template in which you

want to save the customized menu.
<IIIII

See "Using
Template
Wizards,"
p. 190

9. Click the Close button when you complete your changes.

Creating Custom Menus
In addition to modifying the built-in menus, you can add your own custom
menus to Word's built-in menu bar. The Menus tab of the Customize dialog
box provides easy access to this helpful feature.
To create custom menus, follow these steps:
1. Open the Tools menu and choose the Customize command.
The Customize dialog box appears.
2. Select the Menus tab.
3. Choose the Menu Bar button. The Menu Bar dialog box appears

(see fig. 36.7) .
Fig. 36.7
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4. In the Name on Menu Bar text box, enter the name of the first menu

item.
5 . Select a position from the Position on Menu Bar list.
6. Click the Add button.

7. Repeat steps 4 through 6 until you finish creating your menu.

From Here...
8. Click Close to exit the Menu Bar dialog box. You return to the Custom-

ize dialog box.
9. Close the Customize dialog box. The new menu should appear onscreen.

Troubleshooting
I find some of the names of menu items are confusing. I'd like to know how to rename an
item to something more meaningful.
As an example, let's rename the Edit Links menu command. Choose the Customize
command from the Tools menu, and then select the Menus tab. From the Category
list on the left, select the Edit category and then from the right-hand list, choose the
Editlinks menu item. In the Name on Menu text box, enter a name for the new
menu item. Choose the Rename button to save your change.

Someone customized the default menus. I need to get the standard menus back.
Open the Tools menu and choose the Customize command. Select the desired template in the Save Changes In drop-down list. Choose the Reset All button to return to
the built-in versions of all menus in the selected template.

I pressed 'j::t;.+option+minus sign(-) and lost a menu item.
You pressed a special shortcut key combination that deletes menu items. Word provides shortcut keys that help you add and delete menu items as you work. Rather
than open the Customize dialog box, you can press 'j::t;.+option+minus sign(-) to
delete an item from the selected menu, or 'j::t;.+option+plus sign(+) to add a menu
item to the selected menu. When you press these keys, the cursor turns into a thick
minus or plus sign. Then choose a menu command to delete or add a menu item. If
you press these keys by mistake, you can press 'j::t;.+period (.)to cancel the customizing operation. See the preceding troubleshooting item for directions on resetting the
menus.

From Here ...
Now that you are familiar with customizing toolbars and menus, you are
ready to begin automating with Visual Basic, Application Edition (VBA), and
working with other applications. To learn more about working with
Microsoft Office applications, refer to the following chapter:
• Chapter 37, 11 Using Visual Basic for Applications," shows you how to
use VBA to automate common tasks.
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Using Visual B~sic
Applications
by Carman Minarik

The applications of Microsoft Office provide a varied and divergent set of
environments for accomplishing business tasks. The binder that ties all these
environments together is OLE 2.0, and the program that controls OLE 2.0 is
Visual Basic for Applications (VBA). VBA is a programming environm ent for
OLE 2.0 objects that eventually will be the macro language for all the applications in Microsoft Office.
In this chapter, you learn:
• What VBA is
• What makes VBA different from other versions of the Basic language
• How to use VBA to automate tasks
• How to program in VBA language

Understanding VBA
Some form of the Visual Basic language is included in several current
Microsoft applications, including Word, Excel, and Project. The implementation of the language differs in each application, however. Microsoft plans to
make all its mainstream applications compliant with a single version of Visual Basic known as VBA. Currently, Excel has the most developed VBA capability, so most of the examples in this chapter are developed in Excel. As VBA
is implemented in other applications, the procedures developed here can be
moved to those other applications with few, if any, changes.
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Understanding Why Objects Are
Special
The difference between VBA and other Basic programming languages is that
VBA is object-oriented. You already have seen objects in action in Microsoft
Office. In Chapter 28, 11 Working with Wizards, Multiple Documents, and Cut,
Copy, and Paste," you embedded graphics (Graphic objects) and ~eel ranges
(Range objects) into Word documents. These objects possess internal capabilities for control and display, even when they are embedded in another
application's document. VBA takes advantage of this capability to control
those objects. This capability to control another application using the other
application's objects is known as OLE automation.

Understanding Objects in VBA
The objects of Visual Basic can be visualized as a series of containers
(see fig. 37.1). The largest container is the Application object, which is the
current program you are running, such as Excel. In Excel, the Application
object contains Menu objects, Control objects, Workbook objects, and so
forth. Within the Workbook objects are Sheet objects (worksheets, macro
sheets, modules, dialog sheets, and so on), and within the Sheet objects are
Range objects (cell ranges). Other applications have similar objects to cover
their particular needs. See the documentation and the on-line help for the
different applications of Microsoft Office for a list of the objects in each
application.
Fig. 37.1
The VBA object
model: containers
within containers.

Worksheets
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Note

I

Individual cells are not objects in Excel but are accessed as Range objects, which
contain a single cell or cell range.

Learning More with On-Line Help
VBA has many more features than this chapter describes, such as the unique
syntax and special options of the commands and functions. To learn about
the details of these features, use the on-line help system within each application. Choose the Help Microsoft Excel Help command or press the help key,
and then look for the "Programming with Visual Basic" section in Excel or
Project, or the "Programming with Microsoft Word" section in Word. When
you are in the language section of on-line help, you can list all the language
elements or select one of the individual language elements' sections to display an alphabetical list of those elements. You also can use the application's
search capability to locate specific topics.
Note
You can switch to the help files of other applications without having to start the
other application and then choose the help command. Start help in one application,
and then use the File Open command in help to switch to some other application's
directory, where you can open that application's help file. Most applications have a
separate help file for VBA, and you must be in that help file for help's search capability to locate terms related to Visual Basic.

Creating Procedures with the Macro
Recorder
The best way to learn how to use VBA is to create procedures with it by using
the Macro Recorder as you.did in Chapter 18, "Automating with Excel Macros." When you turn on the Macro Recorder and create a worksheet, the recorder writes the Visual Basic code that performs the same actions you are
performing by hand. By examining that code, you learn how to use VBA to
access and change an application's objects.
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In the following sections, you create a simple worksheet that calculates the
tax on the cost of an item and then calculates the total cost. The worksheet
has an input cell and two calculated output cells. The input cell accepts a
cost, and the output cells display the tax and the total cost.

Starting the Recorder
To prepare the worksheet and display the Record New Macro dialog box,
follow these steps:

[Q]

1. Open a new workbook by choosing File New.

2. Choose Tools Record Macro Record New Macro, and then click
the Options button. The Record New Macro dialog box appears
(see fig. 37.2) .
Fig. 37.2
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3. In the Macro Name field, type FigureTax.
4. In the Description field, type Create a worksheet to calculate the
tax on an item.
5. Leave the other fields at the default values shown in figure 37.2, and

click OK.
The Stop Recording button appears in a floating toolbar (see fig. 37.3), and
the Macro Recorder records what you do, recording all your keystrokes and
mouse clicks until you click the Stop Recording button.

Recording a Procedure
You can create the procedure simply by creating the worksheet as you
normally do. To create the worksheet, follow these steps:
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1. Select cell B4, and type Cost.
2. Select cell BS, and type Tax.
3. Select cell B6, and type Total

~

See "Entering
Data," p. 233

~

See "Selecting
Cells and
Ranges," p. 237

~

See "Formatting
Numbers,"
p.269

4. Select cell C4, and type 12.43.

5. Select cell CS, and type= C4*0.0825.
6. Select cell C6, and type = C4 + C5.
7. Select cells C4:C6, choose Format Cells, and select the Number tab.
Select the Number format type, select the #,##0.00);(#,##0.00) format, and
click OK.
8. Select cell CS, choose the Format Cells command, and select the Border
tab.
9. In the Borders dialog box, click the Bottom box and click OK.

The worksheet should look like figure 37.3.
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Fig. 37.3
This is the
completed
worksheet before
the recorder is
turned off.
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Status bar indicates a macro is recording

Stopping the Recorder
Stopping the recorder is easy; simply click the Stop Recording button.
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Examining the Procedure
To examine your newly created procedure, find the Modulel tab at the bottom of the screen and click it. Your procedure appears on-screen and looks
like figure 3 7.4.
Fig. 37.4
The Macro
Recorder places
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commands in a
module.
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The listing of the procedure is:
' FigureTax Macro
' Create a worksheet to calculate the tax on an item.
Sub FigureTax ()
Range( "B4 ' ) . Select
ActiveCell. FormulaR1 C1
"Cost"
Range( "B5 ") .Select
ActiveCell.FormulaR1C1
"Tax"
Rang e ( "B6 ") . Select
ActiveCell.FormulaR1C1
"Total "
Range( "C4 ").Select
ActiveCell . FormulaR1C1
' 12.43'
Range( ' C5 ' ) . Select
ActiveCell.FormulaR1C1
' =R[_1)C*0.0825'
Range( ' C6 ' ) . Select
ActiveCell.FormulaR1C1
' =R[_2]C+R[_1]C '
Range( "C4 :C6") .Select
Selection.NumberFormat
' #,##0.00; · # ,##0 .00 "
Range( "C5 ") . Select
Selection.Borders(xlLeft).LineStyle = x!None

IL

_IL
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Selection.Borders(xlRight).LineStyle = xlNone
Selection.Borders(xlTop) .LineStyle
xlNone
With Selection.Borders(xlBottom)
.Weight = xlThin
.Colorindex = xlAutomatic
End With
Selection.BorderAround LineStyle:=xlNone
End Sub

If you examine this listing and compare it with the steps you just took, you
see that each step results in one or more lines of code inserted into the procedure. Many extra lines also are in the procedure; these lines set parameters
that you did not explicitly set when you recorded the macro. These extra
lines result when you click OK in a dialog box that sets several parameters.
Although you may change only one parameter in the dialog box, closing the
box sets all the parameters displayed in that box and inserts corresponding
lines into the procedure being recorded. In the Borders dialog box, for example, you set only the Bottom option (step 9), but eight lines were inserted
into the procedure, setting the values of all the other options. In many cases,
you can delete these extra lines from the procedure without changing its
results.
The procedure appears in color, with comments in green, keywords in blue,
and everything else in black. Visible in the procedure window is the Visual
Basic toolbar. The toolbar can be floating or docked on any side. Figure 37.5
shows the function of each button in the Visual Basic toolbar.
Toggle
Breakpoint

Step Into
Record Step
Menu Run
Macro Over
Editor Macro
Resume
Insert
Macro
VVatch

Running the Procedure
To run this procedure, first select an unused worksheet. Make sure that the
sheet is unused or has nothing useful in the B4:C6 range because the procedure overwrites that area. Choose the Tools Macro command. The Macro
dialog box shown in figure 37.6 appears, showing all procedures available in

Fig. 37.5
The Visual Basic
toolbar contains
tools for executing
and debugging a
program.
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this sheet and in the global sheet (currently, none). In the dialog box, select
the FigureTax procedure and choose Run. The worksheet appears and the
procedure runs, setting the contents and formatting the worksheet cells.
The completed worksheet is identical to the one you created by hand.

Fig. 37.6
The Macro dialog
box allows you to
select and run
procedures.
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Understanding the Procedure
To learn how the macro works, take a closer look at the listing of the procedure by selecting the Modulel tab. The first few lines of the procedure are
comments. Comments are ignored during program execution and can contain any text. Text following a single quotation mark is interpreted as a comment. Comments can appear at the beginning of a line or to the right of any
valid VBA statement.
' FigureTax Macro
' Create a worksheet to calculate the tax on an item .

Following the comments is the procedure header, which names the procedure.
Sub FigureTax()

Following the procedure header are 12 statements that alternatively select
each cell in the range B4:C6 and insert a label or a formula . The last four lines
insert formulas, but they are written in the RlCl style instead of the Al style
of cell addressing. This is the default method for saving inserted formulas, no
matter what method was used to create the worksheet while the recorder was
running. When this procedure is played back, the formulas are automatically
converted into whatever style is the default in the active worksheet.

Creating Procedures with the Macro Recorder
Range( "B4 " ).Select
ActiveCell.FormulaR1C1
Range (" BS ' ).Select
ActiveCell.FormulaR1C1
Range( ' B6' ).Select
ActiveCell.FormulaR1C1
Range( "C4 ' ).Select
ActiveCell.FormulaR1C1
Range ("CS " ).Select
ActiveCell.FormulaR1C1
Range( "C6' ).Select
ActiveCell.FormulaR1C1
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"Cost"
"Tax

II

"Total '
"12.43"
"=R[_1]C*0.0825 "
' =R[_2]C+R[_1]C '

The next two statements select the range C4:C6 and apply the number
format to those cells.
Range( "C4:C6 ") . Select
Selection.NumberFormat = "#,##0.00;·$#,##0 . 00'

The last nine lines of the procedure are the result of selecting cell CS and
making changes in the Borders dialog box. Notice that you selected only the
Bottom box, but the procedure set values for all the options in the dialog
box. The values xlNone, xlBottom, xlThin, and so on are built-in Excel
constants. See on-line help for a list of the constants available for use
with different properties and methods.
Range( ' CS' ).Select
Selection.Borders( xlLeft) . LineStyle = xlNone
Selection.Borders( xlRight) .LineStyle = xlNone
Selection.Borders(xlTop) . LineStyle = xlNone
With Selection.Borders(xlBottom)
. Weight = xlThin
.Colorlndex = xlAutomatic
End With
Selection.BorderAround LineStyle:=xlNone

Note

VI
The With, End With structure in the procedure is a method of decreasing the size of
a procedure and arranging together all statements that apply to a specific object.
The With statement works by inserting the object that follows the word With just
before the period in each line below it. Thus, the following two blocks of code are
equivalent.

With Selection.Borders( xlBottom)
.Weight = xlThin
.Colorlndex = xlAutomatic
End With
Selection . Borders( xlBottom) .Weight = xlThin
Selection.Borders(xlBottom).Colorlndex = xlAutomatic
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The last statement in the procedure is the procedure footer, which marks the
end of the procedure.
End Sub

Understanding Objects
....

See 11 Adding
Macros to
Sheet Buttons
and Toolbars,"

p.406

....

See "Linking
an Excel
Worksheet
to a Word
Document,"

p. 611

....

See "Linking
Data between
Excel
Worksheets,"

p.622

Visual Basic for Applications uses an object-oriented programming model. If
you understand object-oriented programming (OOP), you easily will understand VBA's implementation of it. If you don't, hang in there-it's not as
complicated as it sounds.
Visual Basic for Applications' objects are just a convenient way of storing and
hiding data and code in a program. Instead of writing a program to manipulate some data values, you encapsulate the data and the code that manipulates that data in an object. From then on, you have only to access the object
to use or display its data. You don't write code to manipulate the data; you
send the object a message, and the object does the work for you.
You see this capability in action when you embed an object from one application into another. The embedded object takes care of itself, and the embedding object has only to give the embedded object a place to display itself.
When you attach a Visual Basic button to a worksheet, for example, the
worksheet does not have to know how to make the button work when you
click it-the button handles that. In code, you do much the same thing. You
don't try to manipulate an object's data directly-you send messages to the
object and let it do the work.
Visual Basic for Applications' objects include such things as buttons, menu
items, ranges of worksheet cells, and even a worksheet itself. Almost everything you can see on-screen while an application is running is an object.

Accessing Objects
To access a specific object in VBA, you start with the outermost container
object, followed by a period, the next inner container object, another period,
and so on until you reach the object you want. To access cell BS in an Excel
worksheet named Sheet3 in a workbook named Book2, for example, you
could use the following reference:
Application. Workbooks ( "Book2") •Worksheets ( • Sheet3 •) . Range ( "BS")

Understanding Classes and Collections
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Because VBA deals with objects, any application that registers its objects with
the Macintosh operating system makes those objects available to VBA. Thus,
even if you are running VBA in another application, you still can access an
object in Excel in much the same way as you would if you were in Excel itself. The only difference is that you must include the name that the other
application used when registering itself, to specify which Application object
to use. For example, you could use the following reference in Project to access
a cell in Excel:
Excel. Application. Workbooks ( "Book2 ' ) . Worksheet s ( "Sheet3" ) .Range ( "85" )

This reference is somewhat cumbersome, so VBA makes an assumption that
enables you to leave out some of these containers. For each container not
included on the left side of a reference to an object (such as the workbook or
worksheet reference), VBA assumes that the currently active object of that
type is the one being referenced.
Thus, you almost always can leave out the application, as well as the workbook. Leaving out the containers has the positive effect of making your procedures more portable. If you leave out all but the Range object, your code
always applies to the currently active sheet, so you don't have to change the
sheet name to apply your code to a different sheet. In addition to the named
sheets and workbooks, you can use the objects Activeworkbook, ActiveSheet,
ActiveCell to reference the currently active objects without having to know
their names.
Note
Keep in mind that if you use specific workbook and sheet names in your procedures,
the procedures will work only in those named workbooks and sheets. By leaving out
parts of an object's specification, you make your code applicable to all objects of the
class you left out.

Understanding Classes and
Collections
A class of objects is a reference to a general type or classification of objects.
In VBA, for example, each cell or cell range in a worksheet is a Range object,
which is an example of the Range class.

VI
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If you combine all the objects of a specific class into a group, that group is

known as a collection. Thus, all the workbooks in the Application object are in
the collection Workbooks, and all the worksheets in a workbook are in the
collection Worksheets. All the worksheets also are in the collection Sheets,
which includes all types of sheets (worksheet, chart, module, and dialog) in a
workbook.

Accessing Collections
Collections are used to access most objects. To access a specific member of a
collection, follow the collection name with either a string containing the
object name or an integer in parentheses. Thus, Worksheets( "Sheet1") refers
to the sheet named Sheetl, and Worksheets(2) refers to the second worksheet
in the collection of all worksheets in the active workbook. If you want to
access cell BS in the third worksheet in a workbook named Book2, you could
use the following reference:
Workbooks( ' Book2").Worksheets(3).Range("B5 ' )
If you leave out the parentheses and object descriptor in the reference to a

collection, the reference is to all the members of the collection.

Caution
Be careful when using numbers to select objects in a collection. If you add or delete
members of a collection, the numbering of all the other members of that collection
can change, and your number may select a different object.

Understanding Properties
An object contains data, and data that you can access from outside an object
is a property of that object. Most properties are readable, but not all can be
written or changed. See the VBA section of on-line help for a description of
each of the properties. In the description of each object is a list of the properties that apply to it.
For a Range object (one or more worksheet cells), the font, color, font size,
contents, and so on are read/write properties, but the location is read-only
(cells don' t move). Properties can refer to the direct data contained in an
object, such as the value of a cell, or to data values that control how an object
looks and behaves, such as color.

Accessing Properties
Property values can be strings of text, numbers, logicals (True or False), or
enumerated lists. An enumerated list is a numbered list of options, where the
number is used to select a specific option. For example, the Color property of
most objects is an enumerated list in which 0 is none, 1 is black, 2 is white,
3 is red, 4 is green, 5 is blue, and so on.
For enumerated lists, VBA and other compliant applications in Microsoft
Office contain predefined constants to use in place of the numbers. Using the
constants is much more informative than using the numbers. The constants
that are applicable to a property are listed in the description of the property
in on-line help.

Accessing Properties
The easiest way to see what properties to set and what values to set them to
is to start the Macro Recorder, perform whatever changes you want to perform, tum off the recorder, and then copy the recorded property changes
into your program. Both Excel and Word currently have macro recorders.
Following is the syntax for accessing an object's properties:
object.property

In this example, object is the object whose properties you want to change or
view, and property is the name of the property. If the preceding construct is
on the right side of a statement, you are reading the value of the property
from the object. If the construct is on the left side of a statement, you are
setting the value of the property. To set the value of the Formula property
(the contents of the cell) of cell BS to =ABS(B4) when cell BS is in the Sheet 1
worksheet (which is in the 8ook2 workbook), you could use the following
statement:
Workbooks (a 8ook2" ) . WorkSheets (. Sheet1 • ) . Range (. 85" ) . Formula =

II

=A8S ( 84) •

To read the same property from the same cell and store it in the variable
myFormula, you could use this statement:
myFormula = Workbooks("8ook2").WorkSheets("Sheet1").Range("85").Formula

The rules concerning omitting container objects (described in "Accessing
Objects" earlier in this chapter) apply here. Because you must include an
object with the property, however, you cannot leave off the Range object and
thus place the formula in whatever cell is active. For these and similar cases
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involving other objects, some special properties return the currently active o r
selected object. Table 37.1 lists these special properties.

Table 37.1

Special Properties that Return the Active Objects

Property

Description

ActiveCell

The active cell in the active window

ActiveChart

The active chart in a workbook

ActiveDialog

The active dialog sheet in a workbook

ActiveSheet

The active worksheet, chart, module, or dialog sheet in a
workbook

ActiveWorkbook

The active workbook in an application

Selection

The currently selected object in the currently selected
sheet

"

Caution

-

Be sure that an object of the expected type is the active object before you try to use
the active properties, such as ActiveSheet, in a procedure. If an object of the specified
type is not the active object, these properties return nothing, and a procedure that
uses them is likely to crash.

To get the formula contained in the active cell of the Sheet3 worksheet, for
example, you could use the following statement:
myFormula

=

Workbooks ( "Book2") . WorkSheets ( "Sheet3 ") .ActiveCell . Formula

If Book2 and Sheet3 are the currently active workbook and worksheet, you
could use this statem ent:
myFormula

= ActiveCell .Formula

If Book2 is the active workbook, but Sheet3 is not necessarily the active
worksheet, you could use this statement:
myFormula

= WorkSheets("Sheet3 ' ).ActiveCell .Formula

If you wanted to access cell BS in wh atever worksheet is active in Book2, you
could use this statement:

Accessing Methods
myFormula

= WorkBooks("Book2").ActiveSheet.Range("B5").Formula

Everything to the left of the last period must evaluate to an object or a collection of objects.

Understanding Methods
VBA methods are the blocks of code stored in an object that know how to
manipulate the object's data. In the Range object, for example, the Calculate
method causes the formulas in the selected cells to be recalculated, and the
Clear method clears the cell's contents. Methods do things to objects and the
data they contain, as opposed to properties which set values. To learn more
about the specifics of different methods, and to find out which methods
apply to which objects, see the VBA section of on-line help. You also can use
the Object Browser to see which methods are available for certain objects
(see 11 Finding Objects with the Object Browser" later in this chapter).

Accessing Methods
You access or execute an object's methods in nearly the same way that you
access an object's properties. The main difference is that a property always is
accessed as part of a formula, but a method must be part of a formula only if
it returns a value.
The Rows method, for example, returns a collection containing all the rows in
the range. To use this method to set the RowHeight property of all the rows in
the currently selected range to 20, use a formula like the following:
Selection.Rows.RowHeight

= 20

To get the number of rows in the current selection, you could use the Rows
method to return a collection and the Count property to return the number
of items in the collection, as follows:
numRows

=Selection.Rows.Count

Some methods require arguments to make them work. For example, the
Insert method, when applied to a range object, needs an argument to tell
it how to move the cells that are already in the selection; the Rows method
needs an index number to select a single row in the collection of rows. If the
method is part of a formula, the arguments must go in parentheses. To get
the RowHeight of the second row in the collection of rows, you could use the
following statement:
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theHeight

= Selection.Rows(2).RowHeight

If the method is only being executed and is not part of a formula, place the
arguments to the right of the reference to the method. To use the Inse r t
method to insert blank cells for the current selection and to move the current
selection down to make room, you could use this statement:
Selection.Insert xlDown

The argument actually is an integer, but the built-in constant is used here to
make the code more readable. You can view the built-in constants that apply
to a method in the description of the method in on-line help. To see the
Excel constants, use the Object Browser described in the following section to
search the Excel library for the Constants object.

Finding Objects with the Object
Browser
The number of available objects can be large, and keeping track of all the
names, which properties go with which methods, and which objects are contained in which applications can become difficult and confusing. On-line
help is a good reference for the objects and methods in the current application, but if you want to see which applications have made their objects available by registering them with the Macintosh operating system, use the Object
Browser in Excel.
Before you can use the Object Browser, you must register any external object
libraries (other OLE-compliant applications) with Excel. To register the external libraries, a Module sheet must be active. When you choose the Tools
References command, the dialog box shown in figure 37.7 appears.
Fig. 37.7
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dialog box to
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object libraries
with Excel.
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In the dialog box, mark the check boxes for the ob ject libraries you want to
register with Excel, and then click OK. As more applications support OLE
automation, they also appear in the References list.
To use the Object Browser, choose the View Object Browser command.
The Object Browser dialog box appears, as shown in figure 37.8.
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In the Libraries/Workbooks field at the top, you select the object library, such
as Excel, Visual Basic for Applications (VBA), external libraries, or other modules in open worksheets.
If you select Excel, as shown in the figure, all the objects and modules con-

tained in Excel appear in the Objects/Modules list on the left side of the dialog box. If you select one of the objects, such as the Worksheet object, all that
object's properties and methods appear in the Methods/ Properties window on
the righ t. If you select one of the methods or properties, such as Range, the
method- along with its syntax-appears at the bottom. If you click the
question-mark button in the bottom left corner, you go directly to the online help topic that explains that method or property. If you choose the Paste
button, the selected object or method is inserted into the active module at
the current insertion-point location.

Understanding Functions and
Procedures
A procedure is the smallest programming object in VBA. VBA uses two types of
procedures: Sub procedures and Function procedures.

Fig. 37.8
The Object
Browser allows
you to view and
use any available
objects.
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Sub Procedures
Sub procedures generally are called procedures. Sub procedures can be sent
arguments and can make changes to those arguments. The syntax of a procedure is as follows:

Sub procedurename()
o

Procedure Body

End Sub
Sub procedures always start with a procedure h ead er that begins with the
keyword Sub, followed by the procedure name and parentheses. The names of
any arguments to be passed to the procedure are placed between the parentheses. Arguments are the data values that a calling procedure is passing to this
procedure to work on; they also can contain the values that a procedure is
passing back to the procedure that called it. Sub procedures must end with
the End Sub procedure footer. Between the procedure header and footer is the
procedure body, which can contain declarations, statements, and commands
that the procedure executes. To execute a Sub procedure, select it in the
Macro dialog box, call it from another procedure, or click a button or other
object to which the procedure is attached.
For example, a simple procedure to calculate the tax on an item could be
written as follows:
o

Calculate the tax on an item.

Sub GetTax(Cost, Tax)
Const TaxRate = 0 . 0825
Tax = Cost * TaxRate
End Sub
This procedure receives the cost of an item from the calling procedure, and
calculates the tax by multiplying the cost by the tax rate. The calculated tax is
then passed back to the calling program in the second argument.
Note
In the GetTax procedure, the constant TaxRate is defined in the procedure by the
Const declaration, and then the constant is used in place of the actual number.
Although this step may seem unnecessary, it makes the procedure much more
readable.

Understanding Functions and Procedures

User-Defined Functions
Function procedures are similar to Sub procedures except that the function's

name returns a value. These functions are identical in operation to worksheet
functions-you can define new functions with VBA and then use them in the
worksheet. The main restriction on functions that are used in the worksheet
is that they can do only calculations. These functions cannot access and
change other cells in the worksheet, nor can they execute menu commands.
Functions have a procedure header and footer similar to that used for Sub
procedures, and they must assign a value to the procedure name before
completing.
Function functionname()
function body
functionname = value
End Function

After you define a function, you can use it in the worksheet as though it was
one of Excel's built-in functions.
The following example performs the same calculation as the preceding example, but does it as a function. The function accepts the cost of an item as
an argument, and then calculates and returns the tax on that cost in the
function's name.
' Calculate the tax on an item.
Function theTax(Cost)
Const TaxRate = 0.0825
theTax = Cost * TaxRate
End Function

You can use this type of function in another procedure or in a worksheet as a
user-defined function.
To use the preceding function in a worksheet, switch to the workbook used
for the Macro Recorder example shown in figure 37.3. Create a module by
choosing the Insert Macro Module command. Type the preceding listing into
the module as shown in figure 37.9.
Select Sheetl by clicking the tab at the bottom, and insert the following
formula into cell CS:
=theTax(C4)
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Fig. 37.9
The Module
contains a userdefined function
named theTax.
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The new function now can be used in the worksheet like any of the built-in
functions. The worksheet returns the same result as the one shown in figure
37.3, but now the tax is calculated with a user-defined function.

Event Procedures
Event procedures are regular Sub procedures that are attached to specific

events. Events that are attachable to procedures include buttons being
clicked, worksheets opening or closing, or values being changed in cells. See
the documentation for the specific objects for a list of the events to which
procedures can be attached. An object's events that can cause a procedure to
be executed are listed as properties of that object. Procedures are attached to
an object's events by storing th e procedure's name in the property. For example, most objects have an OnAction property. Depending on the object, if
the object is clicked (button or graphic) or changed (text box or list box), the
procedure whose name is stored in the OnAction property is executed.

Understanding Variables and
Assignment Statements
Variables are named places in memory for storing data. Like naming cells in
a worksheet, using variables to name storage locations in memory makes a
program much more readable. You don't have to explicitly name a specific

Creating an Application
location in memory to use a variable; VBA takes care of that for you. Simply
using a name in a formula causes VBA to define storage for it. After defining a
variable, you can use it in assignment statements to store data.
An assignment statement consists of a variable or property name on the left, an
equal sign, and a constant value or formula on the right. A formula can consist of a single constant value or a mixture of variables, constants, mathematical operators, and functions. All the following statements are assignment
statements:
myFormula = ActiveSheet.Range(aesa).Formula
Selection.Rows.RowHeight = 20
myVariable = 17
someThing = Log(3.5)
yourvariable = myvariable * 33

Creating an Application
Now that you know about objects, properties, and methods, you can start
putting some of that information together to create an application. The application you are going to create is a receipt maker, similar to one you might use
at a checkout stand where you don't have a regular cash register. The program inputs data with a dialog box, inserts the data into a form in an Excel
worksheet, and prints the form.
The basic structure of this program-input data, store it, do something with
it-forms the basis of many programs, such as an inventory program or a
personal organizer. You should be able to adapt the methods shown here for
many different applications.
The program uses a worksheet and a module. The worksheet contains the
receipt form that stores the data until you are ready to print it. The module
contains the code that gets the data, stores it in the sheet, and prints it. First,
create the worksheet. Don't worry if you don't understand what the code
does; it will be explained in the next few sections.
To create the worksheet, follow these steps:
1. Select an unused worksheet. Choose Format Sheet Rename, or doubleclick the tab at the bottom of the sheet and change the sheet's name to
Receipt in the dialog box.
2. Select cell AZ, and type The XYZ Company.
3. Select cell A3, and type 1127 Somewhere St..
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4. Select cell A4, and type RightHere, CA 12345.
5. Select cell B6, and type Item.
6. Select cell C6, and type Cost.

7. Select cell A7, and type 1.
8. Select cell AS, and type 2.

9. Select cells A7:A8, select the fill handle at the bottom right corner, and
drag it down to A16 to create the series of numbers from 1 to 10.
10. Select C16, choose Format Cells, select the Border tab, select a thick line
style, click the Bottom box, and click OK.
11. Select cells C7:C19, choose Format Cells, select the Number tab, select
the Number type, select the format #, ##0. 00) ; ( #, ##0. 00), and click OK.
12. Select the bar between the B and C column headings, and drag it until
the column width is 27 characters.
13. Select cell B7 and name it TopOfList, using the Insert Name Define
command or the name box at the left end of the edit bar.
14. Select cells A1:020, and name them PrintRange.

15. Choose the File Page Setup command, select the Header/Footer tab, and
set both the header and footer to none. Select the Sheet tab, deselect all
the check boxes, and click OK.

The worksheet should look like figure 37.10, without the two buttons on the
right side.
The next step is to create the procedures in a module and attach those
procedures to two buttons in the form.
To create the procedures, perform the following steps.
1. Choose the Insert Macro Module command to insert a new module.
2. Select the module, and rename it ReceiptMaker by choosing the Edit

Sheet Rename command or by double-clicking the module's name tab.
3. Type the procedures shown in listing 37.1 into the module.

Creating an Application
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Fig. 37.10
Layout of the
Receipt Maker
worksheet.
[Ham

le•

[ Make Receipt

( Print Racalpl

Listing 37.1

I
I

The Receipt Maker Program

' Receipt Maker
' A program to make receipts .
' Force the declaration of all variables.
Option Explicit
Dim theSheet As Object
' Pointer to the worksheet.
Dim OutputRange As Object ' Pointer to the list of items.
Const MaxNumitems = 10
' Maximum number of items allowed.
' Get entries.
Sub GetEntries()
Dim theitem As String, theCost As Currency
Dim th eRow As I nteger, Numitems As Integer
' Define the pointer to the worksheet .
Set theSheet = Application.Workbooks( ' Examples ' ).
Worksheets( ' Receipt ' )
' Define the pointer to the top of the table of items.
Set OutputRange = theSheet.Range( ' TopOflist ' )
ClearRange OutputRange
'Clear the table of items.
Numitems = 1
' Ask for the name and cost for up to 10 i tems .
Do While Numitems <= MaxNumitems
' Get the name.
theltem = InputBox("Item Name : " , "Make Re ceipt")
' If the user didn't enter anything,
he must be done, so quit.
If theitem = •• Then Exit Do

VI

(continues)
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Listing 37.1

Continued

'Get the cost.
theCost = Val(InputBox( ' Item Cost : ' , ' Make Receipt'))
'Insert the items name a nd cost on the worksheet .
OutputRange.Cells(Numitems, 1).Formula = theitem
OutputRange.Cells(Numitems, 2) .Formula = Str(theCost)
Numitems = Numitems + 1 'Increment the number of items .
Loop
Totalit
' Calculate and print the total s.
'Make the Totalit procedure an event procedure
'attached to the worksheet.
t heSheet .OnEntry = "Totalit' ' Retotal it if the user
makes changes .
End Sub
' Calc ulate subtotal and total .
Sub Tot alit ()
Dim theRow As Integer
Dim SubTotal As Currency, ItemTax As Currency
Dim theTotal As Currency
SubTotal = 0
'Calculate the total by extracting the values from the worksheet.
For theRow = 1 To MaxNumitems
SubTotal= SubTotal+ Val(OutputRange.Cells(theRow, 2).Value)
Next theRow
' I nsert the subtotal, tax, and total on the worksheet .
With OutputRange
' Subtotal '
.Cells(MaxNumitems + 1, 1).Formula
Str(SubTotal)
.Cells(MaxNumitems + 1, 2) . Formula
.Cells(MaxNumitems + 2, 1).Formula
' Tax '
ItemTax = theTax(SubTotal) 'Calc ulate the tax .
. Cells(MaxNumi tems + 2, 2).Formula Str(ItemTax)
theTotal = SubTotal + ItemTax
"Total '
.Cells(MaxNumitems + 3, 1).Formula
.Cells(MaxNumitems + 3, 2).Formul a
Str(theTotal)
End Wit h
End Sub
' Clear the output range.
Sub ClearRange(theRange As Object)
Dim theRow As Integer
For theRow = 1 To MaxNumitems + 3
'Clear the cells. Use Cl earConte nts to only clear the values
'and not the formatting.
theRange . Cells(theRow, 1) . ClearContents
theRange . Cells(theRow , 2) . ClearContents

Creating an Application

Next theRow
End Sub
' Print the receipt.
Sub PrintReceipt()
theSheet.OnEntry = "" 'Turn off the automatic retotaling.
theSheet.Range("PrintRange").PrintOut 'Print the worksheet.
End Sub
' Calculate the tax on an item.
Function theTax(Cost As Currency) As Currency
Const TaxRate = 0.0825
theTax = Cost * TaxRate
End Function

4. Switch to the worksheet, and display the Drawing toolbar by choosing
the View Toolbars command.
5. Click the Button tool in the Drawing toolbar, and draw the Make Receipt button as shown in figure 37.10. When the Assign To dialog box
appears, select GetEntries for the macro and click OK.

IFAl1

6. The button should still be selected; if not, click the Selection tool in the
Drawing tool bar and select the button. Select the text on top of the
button, and change it to Make Receipt.

11

7. Create the Print Receipt button, attach it to the macro PrintReceipt, and
make the title Print Receipt.
8. Save the workbook as Examples.
The worksheet should look like figure 37.10. If you did everything correctly,
you can use the program to create a receipt. Switch to the Receipt worksheet,
and click the Make Receipt button. In the first dialog box that appears, type
the name of an item and press return. In the second dialog box, type the cost
of the item and press return. Continue typing names and costs until you have
entered all the items you want to use in this receipt. To end the list, press
return or click the Cancel button in the Item Name dialog box. The totals are
calculated and displayed in the receipt, as shown in figure 3 7 .11. Click the
Print Receipt button to print the receipt.

~
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Fig. 37.11
The Receipt Maker
worksheet after
inputting a receipt.
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Using Declarations and VBA Data
Types
Not all data values are the same type in VBA. If you don' t declare any variables, all variables have a data type of Va riant. The variant type is useful
because it can store anything from strings to pictures to floating-point numbers. The problem with a variant-type variable is that to hold anything, it
must check every time to see what kind of data is being stored in it-and
must have a lot of memory ava ilable to store that data. Thus, a variable of the
variant data type wastes time and memory. For a few small items, this waste
won't matter, but it becomes important if you are storing many data items.
If you declare the type of a variable before you use the variable, VBA does not
have to check every time to see what the variable's data type is and then
reserve space for it. If the variable is declared, the type is known and the
space is reserved ah ead of time.
Another reason to declare all variables is to help ensure that you did not misspell something, which creates a program bug. VBA does not force you to
declare everything, but you can do it yourself by placing Option Explicit at
the top of a module (refer to the start of listing 37.1). If you do this, VBA
forces you to explicitly declare the data type of every variable in that module
before you use it.

Using Declarations and VBA Data Types
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Note
If you have not yet en countered a program bug, you are living a charmed life. But
never fear-you undoubtedly will see many in the near future. A bug in a program
actually is an error of some sort caused by using improper syntax (syntax errors),
improper calculations or assignments (run-time errors), or improper program logic
(logical errors).

VBA h as several built-in data types, which are listed in table 37.2. Of t h ese,
Variant is the most general but th e least conservative in terms of resources.
A few things, such as pictures, m ust be stored in variables with a Variant
type, but most nume ric and string values should be stored in the appropriate
type of variable to save time and space.

Table 37.2

Built-In Data Types in VBA

Data Type

Size (bytes)

Boolean

2

Integer

2

5

-32,768 to 32,767

l ong

4

10

-2.15E9 to 2.15E9

Single

4

7

-3.402E38 to 3.402E38

Double

8

15

-1 .797E308 to 1.797E308

Currency

8

19

-9.22E14 to 9.22E14

Date

8

String

Number of
characters
+1

Object

4

Array

Depends on
type and
number of
elements

Digits

Approximate Range
True or False

1/1 / 100 to 12/ 31/ 9999

To declare the type of a variable, use the Dim statement. At t h e top of a procedure or module, type the keyword Dim, followed by a variable name, and
then type the keyword As, followed by the variable's data type. If the type is
not specified, the variable is the variant type. You can put mu ltiple variabletype declarations in a single line, separating the declarations with com mas.
All the following statements are variable declaration statements:

VI
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Dim
Dim
Dim
Dim

theSheet As Object
OutputRange As Object
theitem As String, theCost As Currency
theRow As Integer, Numitems As Integer

Variables passed as arguments to a procedure are declared in the procedure
header. The following procedure header defines the arguments being passed
to another procedure as an integer and a string:
Sub myProcedure(aVariable As Integer, AnotherVariable As String)
The type of value returned by a fun ction procedure is declared by placing the
type at the right side of the function h eader. The following function takes a
Single type value as an argument and returns a Double type value:
Function myFunction(aVariable As Single) As Double

Arrays
Arrays are not really a new data type; they are lists of one of the existing
types, such as Integer or String. An array is an indexed list of data values,
where the array name is followed by one or more integers in parentheses.
The integer selects the specific element (data value) of the array. The number
of integers in the parentheses determines the dimension of the array.
A one-dimensional array has a single-integer index and is a sequential list of
values. The index selects which element of the list to use, counting from the
beginning. For example, the statem ent
Dim myArray(10) As Integer
declares a list of 11 memory elements for storing integers (elements 0
through 10). In a formula, the value myArray(3) selects the fourth integer in
that list, and myArray( 7) selects the e ighth.

Note
When you examine array indexes, everything may seem to be off by one. This occurs
because the default starting point in VBA for an array index is 0, which makes the
number of elements in an array one more than the value of the upper limit specified
in the Dimstatement. You can modify the default property by placing an Option
Base 1 statement at the top of a module, which changes the default starting point to
1. You also can use constructions like Dim anArray ( 5 to 7) to force the index to
range between specific limits

A two-dimensional array uses two integers in the parentheses and is a twodimensional table of numbers, with the first index selecting the row a nd the

Using Declarations and VBA Data Types
second index selecting the column. Higher-order arrays are allowed, but
arrays are a little difficult to imagine when the dimensions exceed three.
Following are declarations for arrays:
Dim anArray(S) As Single, thedigits(50,2) As Integer
Dim an0ther(5,3,10) As Long

User-Defined Types
In addition to the built-in data types, you can define your own data types to
make storing data more convenient. Suppose that you want to store five
strings and an integer in a personal organizer. You could store these elements
in five different variables, but it makes sense to create a new data type that
combines them in a single user-defined type. A user-defined type is a data type
that you create to fit the specific circumstances of whatever program you are
creating. A user-defined type can be nearly any combination of the existing
data types, including other user-defined types.
To create a user-defined data type, place a Type statement at the top of the
module that needs the type. The Type statement consists of a Type header
containing the keyword Type, followed by the new type name, one or more
named subvariables with As-type clauses, and an End Type statement. An
address-book program, for example, stores the names and addresses of a large
number of people. It would be confusing to store the Name, Address, City,
State, ZIP, and Telephone data in six separate variables, so create a compound
variable type that stores all this data in a single variable. Following is a userdefined data type that can accomplish this task:
Type myType
Name As String
Address As String
City As String
State As String
Zip As Integer
Phone As String
End Type
To use this type, you must declare a variable in a Dim statement and use the
new type name as the type. For example,
Dim theData(100) As myType
creates an array of 101 elements of myType variables (remember that array
indexes start at 0). To access the parts of a user-defined type, follow the variable name with a period and the part name. To get the ZIP-code part from
element number 34, for example, you would use the following variable:
theData(34).Zip
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The Scope of Variables
In listing 37.1, some of the variable declarations are placed at the top of the
module outside the procedures. The type definitions and variable declarations
placed here are available to all the procedures within the module. If the declarations were placed within a procedure, the values stored in the variables
would be available only within that procedure. The same variable could be
defined in each of the five procedures, and each of those variables would be
independent of the other four, even though they have the same name.
If you have more than one module in a program, and you want a variable to

be available to all the procedures in all the modules, you must declare that
variable at the module level and use Public instead of Dim in the declaration.

Constants
One more declaration appears at the top of the module:
Const MaxNumitems = 10

An entry of this type declares a constant. When a constant is declared at the
top of a module, it is available to all the procedures in that module. If the
keyword Public precedes the Canst in the constant declaration, the constant
is available to all procedures in all open modules. A constant is not a variable,
so you cannot change its value in a running program. When you use a
constant, it behaves exactly as if you had typed the value of the constant
everywhere the name is used. Using constants makes programs easier to understand and easier to change. In the Receipt Maker program, if you want to
increase the maximum number of items allowed in a single receipt, you need
only change the value of the constant. If you didn't use the constant, you
would have to change the code everywhere the maximum value is used.

Branching and Decision Making
As you read down the listing of the Receipt Maker program, you come across
the following line:
If theitem = •• Then Exit Co

The line is an If statement that tests the value of the Item to see whether it
contains an empty string. The variable the Item contains the text name of the
item to be added to the receipt. If it is empty, the user is finished entering
data, and you execute the Exit Do statement to exit from the Do- Loop
structure. Thus, the If statement controls a branch in the structure of the
program.

Branching and Decision Making

Block If Structures
A block If structure enables you to use a logical condition equation to decide
which block of code to execute. The block If structure follows:
If condition1 Then
statements1
Elseif condition2
statements2
Else
statements3
End If

When the If statement is executed, condition1 is tested, and if the result is
True, the block statements1 is executed. If condition1 is False, condition2 is
tested, and if the result is True, the block statements2 is executed. There can
be multiple Elself clauses, and each is tested in turn, looking for one whose
condition is True. If none of the conditions is True, the statements following
the Else clause are executed. Only the block of statements following the first
condition that returns True is executed; all the others are skipped, even if
their conditions would have returned True.

Logical Formulas
The conditions used in the If statements are logical values, formulas that
result in a logical value, or numeric formulas that result in a value of zero
(False) or nonzero (True). Logical formulas usually are created by comparing
two values, using one of the comparison operators shown in table 37.3. Logical expressions also can be combined with the Boolean operators listed in
table 37.4. For more information, search for comparison operators and logical in
the VBA section of on-line help.

Table 37.3

Operator

Comparison Operators

Description
Equal to

<>

Not equal to

>

Greater than

<

Less than

>=

Greater than or equal to

<=

Less than or equal to
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Table 37.4 Logical Operators
Operator

Description

And

Logical and

Eqv

Logical equivalence

I mp

Logical implies

Not

Logical negation

Or

Logical or

Xor

Logical exclusive or

Select Case
The Select Case structure performs a function similar to that of the block If
structure in that an expression is used to select a particular block of statements. In Select case, the expression returns a value, and that value is used
to determine which block of statements to execute. The syntax of the Select
Case structure follows:
Select Case expression
Case list1
statements1
Case Else
statements2
End Select

When the Select case statement is executed, expression is evaluated. Following the Select Case statement are one or more case statements. The value of
expression is compared with the comma-delimited list of values in listl. If
one of the values matches, the block statements1 is executed. Otherwise, that
block is skipped, and the next Case statement is checked for a match. If none
of the Case statements results in a match, the block statements2 following the
case Else statement is executed. As with the block If structure, only one of
the blocks of statements is executed.

Accessing Worksheet Cells
In the example, after the user provides an item's name and cost, that information is inserted into cells in the worksheet. Following is the code that
performs the insertion:

Accessing Worksheet Cells

Set theSheet = Application.Workbooks(•Examples"). _
Worksheets(•Receipt")
'Define the pointer to the top of the table of items.
Set OutputRange = theSheet.Range("TopOflist")

'Insert the items name and cost on the worksheet.
OutputRange.Cells(Numitems, 1).Formula = theitem
OutputRange.Cells(Numitems, 2).Formula = Str(theCost)
You use a range reference and a Set statement to define an object variable
that points to the cell named TopOfList in the worksheet. That range reference is used with the Cells method to select worksheet cells in positions
relative to the cell TopOfList. After obtaining a range reference to a cell, use
the Value or Formula properties to get or set the value of a cell. Notice that the
Value property contains the value of a cell-that is, the result displayed in
the worksheet-whereas the Formula property contains what was typed in the
cell. In this case, because none of the cells contains a formula, the Value and
Formula properties are the same.
The range reference in the OutputRange variable refers to a named cell. This
reference is preferable to referencing an explicit cell because you can rearrange the worksheet and the code still gets the value from the correct cell.
You can reference the cells by using a cell reference, or reference a cell by row
and column by using Cell, which also returns a Range object. The following
three statements reference the contents of cell C7 in the example:
theCost = theSheet.Range("C7").Value
theCost = theSheet.Range("TopOfList"). Cells(1, 2).Value
theCost = theSheet.Cells(7, 3).Value
The Totallt procedure demonstrates both reading and changing the values of
worksheet cells. The first part of the procedure gets the value in each cell in
column C that contains a value and calculates a subtotal.
SubTotal = 0
'Calculate the total by extracting the values from the worksheet.
For theRow = 1 To MaxNumitems
SubTotal= SubTotal+ Val(OutputRange.Cells(theRow, 2).Value)
Next theRow
The For and Next statements form a loop that executes the SubTotal statement one time for each row in the data range of the receipt. The value of the
cell is obtained and totaled in the variable SubTotal.
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Note

Notice how the Val () function is applied to the contents of the cell to ensure that a
number is passed to the variable. Without the Val () function, the user could type
into a cell a string that would crash your code if you attempted to store it in a numeric variable. The Val ( ) function converts a string to a number and prevents that
potential problem.

The second half of the procedure writes the labels and values for the subtotal,
the tax, and the total in the worksheet:
With OutputRange
.Cells(MaxNumitems + 1, 1) .Formula
"Subtotal '
Str(SubTotal)
. Cells(MaxN umitems + 1, 2).Formula
.Cells(MaxNumitems + 2, 1).Formula
' Tax'
ItemTax = theTax(SubTotal) 'Calculate the tax .
Str(ItemTax)
. Cells(MaxNumitems + 2, 2).Formula
theTotal = SubTotal + ItemTax
' Total'
.Cells(MaxNumitems + 3, 1).Formula
.Cells(MaxNumitems + 3, 2).Formula
Str(theTotal)
End With
This block of statements also demonstrates the use of the With statement to
block cells together and to save some typing. The statements are logically
blocked together because they refer to the same object, and they save some
typing because you have to type the first object only once. The object following the With clause (outputRange) is assumed to attach before the period to a ll
the statements between the With and End With statements.

Calling Procedures
The Totalit procedure is an example of a Sub procedure that is called by
other procedures. The Get Entries procedure needs to be able to calculate
and display the totals in the worksheet, and it calls the Totalit procedure
to do so.
At the beginning of the GetEntries procedure, any old entries must be cleared
from the receipt. The ClearRange procedure is called to perform that action.
Sub ClearRange(theRange As Object)
Dim theRow As Integer
For theRow = 1 To MaxNumitems + 3
'Clear the cells. Use ClearContents to only clear
'the values and not the fo r matting .
theRange.Cells(theRow, 1).Clearcontents
theRange.Cells(theRow, 2) . ClearContents
Next theRow
End Sub

Calling Procedures
The procedure needs one object for an argument named theRange in the
ClearRange procedure. In the GetEntries procedure, the ClearRange procedure
is called with the following statement:
ClearRange OutputRange

'Clear the table of items.

Because this procedure call is not part of a formula, you do not need to
include parentheses around the argument.
The function procedure theTax is another procedure that is called from
elsewhere in the program.
' Calculate the tax on an item.
Function theTax(Cost As Currency) As Currency
Const TaxRate = 0.0825
theTax = Cost * TaxRate
End Function
Notice that in this procedure, the argument is a Currency-type variable named
cost. The function is called as part of a formula in Totalit.
ItemTax

= theTax(SubTotal)

'Calculate the tax.

In Totalit, the function theTax is passed to the variable SubTotal as an argument. This variable points to a memory location, and that memory location
is passed to the theTax function, where it is named Cost. Both names point to
the same memory location, so if the value of Cost were changed in the Tax,
the value of SubTotal would be changed in Totalit when the function completes executing.
In some cases, you want to make sure that a procedure does not change an
argument, so you must pass the argument as a value instead of a memory
address. You can do this in the procedure heading or in the calling program.
In a procedure heading, for example, precede the argument with the keyword
ByVal, as follows:
Function theTax(ByVal Cost As Currency) As Currency
The other way is to turn the argument in the calling program into a formula.
Instead of the addresses of any of the variables, the address where the result
of the formula is stored is sent to the procedure. You make a variable into a
formula simply by enclosing the variable name in parentheses, as follows:
ItemTax

= theTax((SubTotal))

'Calculate the tax.

The Totallt procedure also is an event procedure attached to the worksheet.
This attachment is done at the end of the GetReceipt procedure, as follows:
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'Make the Totalit procedure an event procedure attached
'to the worksheet.
theSheet.OnEntry = "Totalit" 'Retotal it if the user makes changes
Later in the program, the Totalit procedure is unattached from the
worksheet in the PrintReceipt procedure, as follows:
theSheet.OnEntry

= "" 'Turn off the automatic retotaling.

The OnEntry property of a worksheet contains the name of a procedure to
be executed whenever the user changes the contents of a worksheet cell.
By making the Totalit procedure an event procedure, the user can make
changes in the receipt before printing, and those changes will immediately
be included in the totals at the bottom of the receipt.

Using Loops
The Totalit procedure has to search through the cells in the worksheet and
add the contents to calculate the subtotal. If you were to write range references to alllO of the cells in the worksheet, you could add them up that way,
but you probably don't want to spend your time typing the same statement
over and over. To handle cases like this, you use loops.

For/Next
The most common loop is the For/Next loop, which executes a block of
statements a specified number of times. The syntax of the For/Next loop
is as follows:
For loopvariable = start To end Step stepval
.statements
Next loopvariable
In the For/Next loop, loopvariable is a standard variable. The first time the
loop executes, loopvariable has the value start, and all the statements down
to the Next statement are executed. The second time the loop executes,
stepval is added to loopvariable, and that value is compared with end.
If loopvariable is greater than end, the loop terminates; otherwise, the statements within the loop are executed again. The Step stepval clause can be
omitted, in which case the stepval is 1. If stepval is negative, the loop counts
down instead of up untilloopvariable is less than end.
The Totalit procedure uses a For/Next loop to select all the cells that might
contain values in the worksheet, and calculates a total for all the values
found.

Using Loops

For theRow = 1 To MaxNumitems
SubTotal= SubTotal+ Val(OutputRange.Cells(theRow, 2).Value)
Next theRow

In this example, theRow is the loop variable, and it ranges from 1 to
MaxNumEntries. Each time the loop executes, a different worksheet cell is
selected using the Cells method.

Do/Loop
The Do 1Loop loop uses a condition to determine how many times to execute
the loop. The condition can be tested at the beginning or the end of the loop,
and the loop can continue While the condition is True or until the condition
becomes True (while it is False). Thus, there are four variations of the syntax,
as follows:
Do While condition
.statements
Loop
Do

Do Until condition

.statements

Loop
Do

.statements

.statements

Loop While condition

Loop Until condition

The GetEntries procedure uses a Do/Loop structure to loop over the 10 allowed
lines of input in the receipt. In this case, the Do While construction is used
with a condition that remains True until the value of Numitems is less than or
equal to MaxNumitems.
Do While Numitems <= MaxNumitems
'Get the name.
theitem = InputBox("Item Name:•, "Make Receipt")
'If the user didn't enter anything, he must be done, so quit.
If theitem = •• Then Exit Do
'Get the cost.
theCost = Val(InputBox("Item Cost:", "Make Receipt"))
'Insert the items name and cost on the worksheet.
OutputRange.Cells(Numitems, 1).Formula = theltem
OutputRange.Cells(Numitems, 2).Formula = Str(theCost)
Numitems = Numltems + 1 'Increment the number of items.
Loop

All the statements between the Do statement and the Loop statement are
executed until the condition becomes False. An exception occurs if the user
clicks Cancel and the If statement within the loop has a True condition.
If theitem = •• Then Exit Do
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If the condition is True, the Exit Do statement is executed, immediately terminating the loop and starting execution at the statement following the Loop
statement. An Exit For statement also exists for exiting a For/Next loop early.

For Each
The For Each loop is used to perform some action for all the elements of an
array or collection. The syntax is as follows:
For Each element In group
statements
Next element

The For Each loop applies to arrays and collections only. The loop executes
once for each element in the array or collection. This loop is useful when you
don't know (or don't care) how many elements are in a collection. The loop
variable element is of the data type of the elements in the group collection.
Each time the loop is calculated, element takes on the value of another member of the collection.

Accessing Disk Files
If you have been experimenting with the example, you may have noticed

that each time you create a new receipt, all the existing data values are
cleared. You might, however, want to know how many items of what type
were sold, or you might want to calculate the total receipts for the day to
compare with receipts in the cash box. What is missing is a way to save the
data so that it can be retrieved and used.
You have at least two options: you could store the data in another worksheet
so that the data is saved with the workbook, or you can open a disk file and
store the data immediately. These methods have different advantages,
depending on what you plan to do with the data. If you save the data in
a worksheet, you can apply all Excel database functions to it. If you save the
data in a disk file, other programs could open it directly. In this example, you
are going to save the data in a disk file. Add code to the PrintRange procedure
to add the data to the end of a data file, as shown here (the added lines are in
bold):
• Print the receipt.
Sub PrintReceipt()
Dim theRow As Integer
theSheet.OnEntry = ... 'Turn off the automatic retotaling.
theSheet.Range("PrintRange").PrintOut 'Print the worksheet.

Accessing Disk Files
'Save the data from the receipt.
Open •Hard Disk Example Data• For Append As #1
For theRow = 1 To MaxNumitems
Write #1, OutputRange.Cells(theRow, 1).Value,
Write #1, OutputRange.Cells(theRow, 2).Value
Next theRow
'Write the subtotal, tax, and total.
With OutputRange
Write #1, "Subtotal",
Write #1, .Cells(MaxNumitems + 1, 2).Value
Write #1, •rax•,
Write #1, .Cells(MaxNumitems + 2, 2).Value
Write #1, •rotal•,
Write #1, .Cells(MaxNumitems + 3, 2).Value
End With
Close #1
End Sub

In the added lines, the file is opened for appending, using a file number of 1.
Appending places each new entry at the end of the file. The loop then copies
the data from the worksheet and writes it to the file. The program still appears to work the same, but now the data is saved every time the Print Receipt button is clicked. After you enter the data shown in figure 37.11, the
following text is in Example Data:
•pencils",2.35
"Accounting pad•,1.8
"Printer paper · box•,18.95

•' Subtotal", 23.1
"Tax",1.9058
"Total",25.0058

Notice that the Write statement delimits the data in the file by placing quotation marks around the strings of text and placing commas between items
written to disk. These delimiters make it easy for the Input statement to be
used to read the data back into a program for further processing. If you use
Print instead of Write, the text and strings are written to the file without
delimiters, creating a text file suitable for printing rather than for reading
back into another program.
For more information about reading and writing files, search for input in the
VBA section of on-line help, and select the topic "Input and Output Keyword
Summary."
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Using Built-in Dialog Boxes
VBA has two built-in dialog boxes that you can use in your programs to send
data to the user and to get data from the user. The two dialog boxes are created with the MsgBox () and InputBox () functions. You already have used the
InputBox () function to get data from the user in the Receipt Maker program.
The MsgBox ( ) function displays a dialog box containing a message and one or
more buttons to be clicked to close the dialog box. Both functions take one or
more arguments to set the prompt text, box title, number and type of buttons, and so on. See on-line help for a complete list of arguments.
In addition to these two dialog boxes, you can use two Excel dialog boxes to
enhance your programs when opening and saving files. The two dialog boxes
are displayed with the GetsaveAsFilename and GetOpenFilename methods.
The GetSaveAsFilename method displays the standard File Save As dialog box
and gets a file name from the user. The dialog box does not really save anything; it only provides you with a path and file name to use. You then must
use the Open statement to actually create the file and save something in it.
The GetOpenFilename method operates in the same way, but it displays the
standard File Open dialog box instead.

Creating Custom Dialog Boxes
In addition to the built-in dialog boxes, you can create your own custom
dialog boxes and attach them to a VBA program. The Receipt Maker program
could use a data-entry form to replace the two dialog boxes necessary to input a single entry.
To make this change, perform the following steps:
1. Open the Examples workbook and save it as Examples 2.
2. Choose the Insert Macro Dialog command. Your worksheet should look
like figure 37.12, with a blank custom dialog box and the Forms toolbar. The Forms toolbar can be floating or can be docked at the top
or bottom of the page. The tools in the Forms toolbar are listed in
table 37.5.

Creating Custom Dialog Boxes
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Table 37.5 Tools in the Forms Toolbar
Tool

Tool Name

Descriptio n

~

Label

Creates a text label.

~

Edit Box

Creates an edit box for inputting
data.

Group

Creates a group frame to visually
group other controls and to
functionally group option buttons.

~
~.
[11

Button

Creates a command button that can
execute a procedure.

Check Box

Creates a check box with a label for
selecting non-exclusive options.

Option Button

Creates an option button with a label
for setting exclusive options. (Create
an option-button group with the
Group frame.)

~

List Box

Creates a list box for selecting a value
from a list of values in a scrollable
box.

91.

Pop-up

Creates a pop-up menu for selecting
a value.

c

-

(continues)
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Table 37.5

Continued

Tool

Tool Name

Description

II

List-Edit

Creates a list-edit box (a combination
of a list box and an edit box).

Pop-up Edit

Creates a pop-up edit box (a
combination of a pop-up menu and
an edit box).

Scroll Bar

Creates a scroll bar for inputting a
value by sliding a slider.

Spinner

Creates a spinner for quickly stepping
through a list of integer values.

Properties

Displays the Properties dialog box for
setting the properties of the selected
control.

Edit Code

Jumps to the procedure attached to
the selected control.

Toggle Grid

Turns on or off a grid to simplify the
alignment of controls in a dialog box.

Run Dialog

Activates the dialog box so that
changing values or clicking buttons
execute the attached procedures.

•
•a
•
!Pill
[I)

[II

3. Select the dialog caption, type Receipt Maker, and click a blank
portion of the dialog sheet.
4. Choose the Format Sheet Rename command, and change the dialog
sheet name to ItemDialog.
~

1!!!11

5. Using the Label button in the Forms toolbar, draw two labels in the
dialog box, as shown in figure 37.13. Select the caption of the first
and type Item Name:. Select the caption of the second and type
ItemCost:.
6. Using the Edit Box button, draw two edit boxes in the dialog box, as

shown in figure 37.13.
7. Select the edit box next to the Item Name label, and change its name to

ItemNameBox.
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Note

To change the name of a control in a dialog sheet, select the control; then
click the name box on the left side of the edit bar, type the new name, and
press return.

8. Select the edit box next to the Item Cost label and name it
ItemCostBox.
9. Choose the Format Object command, and select the Control tab. In the

dialog box, choose the Number button in the Edit Validation group,
and click OK. This procedure forces the user to type a number in this
box before the dialog box closes.
10. Choose the Tools Tab Order command. Select the ItemNameBox and
move it to the top of the list; select the ItemcostBox, and move it just
below the ItemNameBox. This procedure makes ItemNameBox the first thing
selected when the dialog box appears; ItemCostBox is selected second,

when the user presses the tab key. Click OK to complete the change in
tab order.
11 . Switch to the ReceiptMaker module and make the following changes in

the GetEntri es procedure (the changes are in bold):
' Get entries.
2Sub Get Entries()
Dim the l tem As String, theCost As Currency
Dim theRow As Integer , Num! tems As Integer
Dim theDialog As Object
'Define the pointer to the worksheet.
Set t heSheet = Application.Workbooks( ' Examples 2') .Worksheets( ' Receipt ' )
'Define the pointer to the top of the table of items.
Set OutputRange = theSheet.Range( ' TopOfList ")
Set theDialog = Applica tion .Workbooks ("Examples 2" ).Dia1ogSheets("ItemDialog ")
'Clear the table of items .
ClearRange OutputRange
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Numitems = 1
'Ask for the name and cost for up to 10 items .
Do While Numitems <= MaxNumitems
'Clear the edit boxes.
theDialog.EditBoxes("ItemNameBox").Text
theDialog.EditBoxes("ItemCostBox " ) . Text
theDialog.Show
'Get the name.
theitem = theDialog.EditBoxes( ' ItemNameBox" ).Text
'If the user didn ' t enter anything, he must be done, so quit.
If theitem = '" Then Exit Do
'Get the cost.
theCost = Val(theDialog.EditBoxes( "ItemCostBox" ).Text)
' Insert the items name and cost on the works heet.
OutputRange . Cells(Numit ems, 1).Formula = theitem
OutputRange.Cells(Numi tems, 2) . Formula = Str(theCost)
Numitems = Numitems + 1 ' Increment the number of items .
Loop
Totalit
' Calculate and print the totals.
' Retotal it if the user makes changes .
theSheet.OnEntry = "Totalit"
End Sub

12. Save the workbook.

The first change in the procedure defines a new object named th eDial og that
references the dialog sheet. That object is used with the EditBoxes collection
to clear the two edit boxes. The Show method is used to display the dialog
box. After the user clicks the OK button, the contents of the two edit boxes
are returned to the procedure and processed as before.
When you run the program by clicking the Make Receipt button in the
worksheet, the dialog box appears, as shown in figure 37.14. Type the item's
name, press tab, type the item's cost, and press return. The first item is inserted into the receipt, and the dialog box appears again. To end entry, press
return without typing anything in the dialog box. The totals are calculated.
Fig. 37.14
The Receipt Maker
dialog box.
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Using the Debugging Tools

Using the Debugging Tools
Program bugs are a fact of life for computer programmers. No matter how
careful you are, bugs almost always appear; you must find them and remove
them from your code.
The simplest bugs are syntax errors, such as placing a comma in the wrong
position or using a keyword improperly. Syntax errors normally are found by
VBA as soon as you type them.
Run-time errors are caused by using the wrong type of variable or by perform-

ing an improper numeric calculation (for example, taking the square root
of 1). These errors are found by VBA as soon as the improper statement is
executed.
Logical errors result in a program which does not do what you want it to. Logi-

cal errors are the most difficult to find because everything seems to work; it
just works incorrectly.
VBA has a set of powerful debugging tools to help you find and correct program bugs. For example, you can set breakpoints anywhere in your programs
to force them to stop executing at that point. After you stop your program,
choose Tools Instant Watch to view the value of any variable or expression.
You then can continue executing a program or step through it one statement
at a time until you find your problem. You also can set watchpoints that
automatically break a program when a variable or expression reaches a
certain value.

Break Mode
Break mode is used to halt an executing program with all its variables still

intact. Normally, when you end a program, the contents of all the variables
are lost. However, break mode actually is a pausing of the executing program,
so the contents of the variables that have been assigned values during program execution still are available. A running program enters break mode
when it receives the keystrokes :l=C+period or Esc, when it encounters an error,
or when it encounters a breakpoint or watchpoint. When a program enters
break mode by encountering an error, or when you press :l=C+period or Esc,
the Macro Error dialog box appears (see fig. 37.15), giving you the choice to
quit, continue, or open the Debug window.
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Fig. 37.15
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Breakpoints
Breakpoints and watch points also put a program into break mode. A breakpoint is a marker in a line of code that forces a program to stop executing
when VBA attempts to execute the marked line. A watchpoint is a marker in
the value of a variable or a simple formula. When the value of a watchpoint
changes in some specific way, the program is stopped and placed in break
mode.
To set a breakpoint, open the module containing your procedure, and select
the line of code where you want the program to stop. Choose the Run Toggle
Breakpoint command to set a breakpoint. Choose the command again to
remove a selected breakpoint, or choose the Run Clear All Breakpoints command to remove all breakpoints. Then run your code. When the procedure
reaches a breakpoint, it stops and enters break mode. When a procedure enters break mode by encountering a breakpoint or watchpoint, it goes directly
to the debug window, which is discussed in the following section.

The Debug Window
If you choose Debug in the Macro Error dialog box, or if the procedure encounters a breakpoint or watchpoint, the Debug window appears (see fig.
37.16). The Debug window is a split window, with the currently executing
procedure in the bottom half and the Immediate pane or the Watch pane at
the top. In the bottom half of the window, you can select lines of code, add
or remove breakpoints, and select code for watch points.

The Debug window shown in figure 37.16 shows that the code
stopped at a breakpoint set in the If statement highlighted in the Code
pane. The Watch pane shows the current value of the Item, theCost, and
theDialog. Edi tBoxes ( • ItemcostBox • ) . Text as watch variables. Notice th at
theCost has no value yet because it has not yet been passed the value in
theDialog. Edi tBoxes ( " ItemCostBox") . Text. At this point, you can continue
execution of a procedure, set or delete more watchpoints, examine the value
of variables, or step through the procedure one statement at a time.

Using the Debugging Tools

789

Fig. 37.16

The Debug
window for code
stopped at a
breakpoint.

Watch
Expressions

If-!
F-=~~~~==~~~============================~0
~~
Do lbile N\m..Iteu <• no.x..'lualte~
• ~
'C lear the edit boxes

r-'

••
Text • ••

~heDieloq . Edi~Boxu(•IteallaaeBox•) . Tex~-

tbeD1alog . Ed.itBous(*lteJCo~tBol•)

theD1aloo. Shov
'Cet the r.aAO

~~~~~~= ~~~e~~~~,· ~~~;o::;~~~:.:~:o:~~)b;e~~ne.

n••rmng

,rmwmwm•

~
~..

30

~

qu1t .

tho cost. .
theCost • Va.l ( theDialoq . EditBoxes( *Ite.CostBox• ). Text)
' lruert the 1 tea.s noae aoo cost on the vorksbeot.
·~t

•

Reedu

I

t•l!l

I

Code Pane

The Immediate Pane
In the Immediate pane of the Debug window, you can type and execute almost any VBA command. The only restriction is that the command must be
only one line long. The Immediate pane also receives any printed values
caused by the Debug. Print statement, used to print values from a running
program.

The Watch Pane and Watch Expressions
The Watch pane displays the current value of watchpoints and wa tch expressions. Watch points, and watch expressions displayed in the Watch pane,
continuously show the current value of variables and expressions. The difference between these two is that although both show a value, a watchpoint can
stop your code if the selected value changes in some specified way. The Instant watch is used to show the current value of a variable or expression with·
out placing it in the Watch pane.
Figure 37.17 shows the result of selecting the variable theltem in the Debug
window and choosing the Tools Instant Watch command. If you choose the
Add button, the Instant watch variable is changed into a watch expression
and added to the Watch pane.
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Fig. 37.17
The Instant Watch
dialog box.

The Step Commands
At this point, you can use two step commands to execute one line of your
program and stop again in break mode. Those commands are Run Step Into
and Run Step Over. The Run Step Into command makes the program execute
one line at a time. If the program reaches a procedure call, the next step
occurs in that called procedure.
The Run Step Over command is similar, but when it reaches a procedure call,
it executes the procedure completely before stopping and going into break
mode again. Thus, the Step Over command appears to step over procedure
calls in the procedure you are executing.

The Calls Window
The Calls window is on the top right side of the Debug window, shown in
figure 37.16. The Calls window shows the name of the procedure that contains the current point of execution. If you select the Calls window, it expands and lists all the active procedures in this program. Active procedures
are those that have not finished running, either because they contain the
current execution point or because they are among the calling procedures
that eventually called the procedure containing the execution point.

From Here ...
Now that you understand the basics of VBA, you are ready to begin building
programs of your own. To build your own programs efficiently, you need the
details of the syntax for all the Visual Basic objects and statements. On-line
help is one of the best sources of information about the syntax and usage of
the VBA commands and functions. Select the VBA section, and then explore
all the different functions and methods.
The Object Browser is another helpful feature because it looks at the actual
library files and extracts the real procedure names and properties directly
from the procedures themselves.

From Here...

Other chapters that relate to VBA include the following:
• Chapter 11, 11 Automating with Macros and Mail Merge,"gives you
examples of Word Basic code that can be accessed by VBA.
• Chapter 18, 11 Automating with Excel Macros," shows you several
examples of working code that you can examine and run.
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Like a macro, AppleScript is a way of saving repetitive steps into a simple
move. In this case, the move is called a script. As for many programs offering
macro capabilities, a script can be recorded or written.
The new System 7.5 disks or CD-ROM contain everything you need to begin
writing scripts, the most important of which is the ScriptEditor. With this
application you can write or record scripts for Microsoft Office applications.
The Microsoft Office is AppleScript-savvy-that is, it's scriptable. You can
write scripts that any of the applications of Microsoft Office can follow, and
you don't have to be a programmer to do it.
In this chapter, you'll learn the basics of AppleScripting-the easy way to
create high-end macros. You'll learn to
• Record a script
• Create scripts that are editable or play only
• Use the ScriptEditor to write, check the syntax, and run your scripts
• Edit previously written scripts
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Understanding AppleScript
Anyone who has worked with macros or even used a keyboard equivalent has
experienced the basics of AppleScripting. This program, which is included
with System 7.5 or System 7 Pro, is a low-end programming application or a
high-end macro application. You can use AppleScripting to perform repetitive
tasks or to perform tasks that are time-consuming while you are away from
your computer.
You don't have to be a programmer to write a script. Some scripts you can
record, just as you would record a conversation with a tape recorder. You'll
find similarities between recording a script and recording a macro with an
application such as Quickeys.
Scripts can be written for any application that is scriptable. It is a technology
that certain companies subscribe to but is not required. Not all applications
are scriptable, and even applications that are System 7 savvy may not be.
However, Microsoft Office is scriptable.
Scripts written for an application belong to the application and can be used
on any document that application creates unless you specify that the script
only works with a document of a specific name. You'll learn later how to
direct AppleScript to know which document and which application to work
with.

Scriptable and Recordable
The language of scripts is similar to English and not very much like typical
programming jargon. This is why even an inexperienced person can write a
script. Recorded scripts are even easier. If you can click with the mouse, you
can record a script. However, not all scripts are recordable; only those that
follow steps can be repeated. You cannot record a script that prompts you for
information, such as a dialog box, but you can write a script. There are some
steps you just have to write into a script.
There are two types of AppleScript compliance that applications can have.
The first level is scriptable. This refers to an application for which you can
write a script. The second type is recordable. This denotes an application for
which you can record a script. Within these two different types of scripts
there also are levels. These levels determine how a script is activated. A script,
whether recorded or written, can be saved as an application-making it fully
functional on its own. Just double-click its icon and the script goes to work.

Understanding the Language of AppleScript

There also are scripts called droplets that are activated when you "drop" a file
onto them. Run-only scripts can be played, but not edited. This is convenient
if you're writing scripts for someone else and you don't want them to see
your wording of the script. Scripters and programmers can be a protective
bunch.
The Microsoft Office suite applications are both recordable and contained
within the applications. To write scripts for Microsoft Office applications, you
should first become proficient in the application to keep from inadvertently
recording incorrect steps or becoming frustrated because you don't know the
steps to create. However, because the applications are recordable, it's feasible
to struggle and learn as you go with the types of processes that are recordable.

Understanding the Language of
AppleScript
If you've worked at all in different applications on the Macintosh, you have
some idea of how little the different manufacturers of applications agree
about the way things should be done. The layout of the menus and the
keyboard shortcuts are good examples. Microsoft has nearly eliminated this
discrepancy with the Office products, which is a good thing for scripts.

How do you know what words and phrases to use when writing scripts? By
looking in the dictionary, of course. All scriptable applications have a dictionary, outlining the collection of terms that the program is capable of understanding and acting out through scripts.
To get a look at the dictionary, you need to launch the AppleScript application called ScriptEditor, which is installed by 7.5 in a folder called Apple Extras. This application, like all Macintosh applications, provides you with a
menu bar, windows, and dialog boxes for writing scripts. You will run
ScriptEditor concurrently with the Microsoft Office application for which you
are writing or recording a script. You don't need to have the application running to view the dictionary.
Follow these steps if you want to see the dictionary listings for an application:
1. Launch the AppleScript application ScriptEditor (see fig. 38.1), which is
found in System 7.5's Apple Extras folder.

2. From the File menu, choose Open Dictionary. The Open Dictionary
dialog box appears.
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Fig. 38.1
The ScriptEditor
application,
when launched,
provides you a
new document for
writing a script.

3. Locate the application whose dictionary you want to view, and double-

click the title. The dictionary for that application is opened. In figure
38.2, the dictionary for Microsoft Word 6 is shown.
4. Use the scroll bar at the right of the listings to scroll through the listed

words.
Fig. 38.2
The dictionary
lets you view the
available scripting
terms for that
application.
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5. Click the Close box to dismiss the window.

Recording Simple Scripts
During the installation of System 7 Pro or 7.5, you can choose to install the
AppleScript supporting software and documentation (ReadMe files). This will
create a folder called Apple Extras that contains a folder titled AppleScript,
where you'll find all you need to write and record scripts.

Recording an AppleScript
Launch the application for which you want to record a script. Double-click
the ScriptEditor icon in the Apple Extras folder to launch that application as

Recording Simple Scripts
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well. The upper portion of the ScriptEditor window is a large field where you
can type information about the script you are writing or recording. For instance, you might type the name, a description, or even some suggestions
about the type of requirements that must be met in order to run the script.
Below this field are four buttons: Record, Stop, Run, and Check Syntax.
Record and Stop initiate and end a recording session for a script. Just as with
the buttons on a tape recorder, click Record to instruct ScriptEditor to begin a
recording session for a script. After clicking this button, you perform the steps
that you will want to repeat as part of a script, and then click Stop when you
finish the steps.
In the following example, you can put these buttons to work by creating a
small script for Microsoft Word 6.
Once you launched the application and the ScriptEditor, you can record by
following these steps:
1. Click the description field of the ScriptEditor and type a name and
description for your script.

2. Click the Microsoft Word window (or the window of the application
you're recording in).
3. Select the script type and then select the text you want the script to act
on, if any.
4. Click the ScriptEditor window to make it active, and click the Record
button.
5. Return to the Microsoft Word (or the application you're recording in)
and choose the commands you want to record, making dialog box selections and clicking OK when you're finished.
6. Click the ScriptEditor window to make it active, and then click the Stop

button. The recorded script is displayed in the field area at the bottom
of the window.
The script in the window can be replayed for as long as it remains in the open
AppleScript window by pressing the Run button. Choose Save from the File
menu if you would like to keep the script and run it again. In the section
"Saving Scripts" later in this chapter, saving options are discussed.
Syntax is the structure with which a script sentence is constructed. A script

will only operate if it contains proper syntax. This not a concern if you are

Tip
You'll get the
best idea of how
things work if
you reduce the
size of both
applications'
windows and
move them side
by side.
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recording a script, because the ScriptEditor automatically interprets your
moves and records them properly. If you are writing a script, however, you
can use the Check Syntax button to ensure that you have written it correctly.

Running a Script
To apply the script that you have recorded, return to the Microsoft Word
document and type a new sentence and select it. From ScriptEditor, click the
Run button. The steps you recorded are applied to the new sentence. You've
now recorded and applied your first script.
Note
To prevent a function of your script from operating, comment out by placing two
hyphens in front of the line. AppleScript ignores lines that are preceded by two
hyphens. To comment out an entire routine, precede the routine with an open
parenthesis and an *, and end the routine with an * and a close parenthesis.

Editing Scripts
Your ScriptEditor and Microsoft Word windows may look something like the
windows shown in figure 38.3. In this figure, bold formatting was added to
the third word. If you read the script carefully, you can find where it states
that this will happen. To edit this script, select the word bold and change it to
read italic. Select text in the Microsoft Word document and click the Run
button again to watch the results.
Fig. 38.3
Side-by-side
windows make
writing the scripts
somewhat simpler.

Formatting and Identifying Parts of a Script
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Formatting and Identifying Parts of a
Script
The formatting that ScriptEditor applies to the parts of a script helps you
identify each of the component types. When working in ScriptEditor, you
can change the formatting by choosing AppleScript Formatting from the Edit
menu. This displays the window shown in figure 38.4, where you can edit the
formatting by clicking a line to make a selection and using the Font and Style
m enu of Script Editor to choose new attributes. You cannot select single
words of your script and change the formatting; you must make the changes
here so that they are applied globally throughout the script.
RppleScrlpt
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There are eight components you can use when writing scripts. Each of these
components has a different job. In table 38.1, these components and their
functions are listed. Use this table to help you identify the parts of the script
that you recorded. They help you even more as you begin writing scripts.

VI
Table 38.1

Script Terminology and Functions

Term

Function

New Text

Text added to a script that has not yet been saved ,
run, or had its syntax checked. Also text that will
not compile or run due to a syntax error.

Operators

Characters that perform an operation. A+ symbol
adds, a- symbol subtracts, and so on. Most
operators produce a result; for instance, 1 +1 (the
operator being the plus symbol) p roduces the
result 2. If you want to view the results of the
(continues)

800

Chapter 38-Using AppleScript with Office Applications

Table 38.1

Continued

Term

Function
operators, choose Show Result from the Control
menu. (The Result window, shown in fig. 38.5, also
is used to display some error messages, so it's a
good window to have open when writing and
recording scripts.)

Language Keywords

Scripting terms available to all applications that are
built into AppleScript.

Application Keywords

Scripting terms that are available specifically to the
application.

Comments

Descriptive words, phrases, or sentences embedded into your script that are ignored by the
computer and therefore are not considered when
compiling the script. You can embed instructions
or d escriptions in the middle of a script by adding
two hyphens in front of the comment. This is called
commenting it out. It's placed at this point in the
script for clarification but ignored by the script
because of the hyphens (similar to an annotation
process).

Values

Characters of info rmation that AppleScript uses.
The number of paragraphs in a selection is a value.

Variables

Terms (numbers or words) that are used as
containers for values. Variables usually contain an
inner cap so that they are easy to find in the script
text. For instance, you might ask the script for the
number of paragraphs in a selection and then set
that number to numOfgraphs. Though this word in
itself is just something made up by the script
writer, it is descriptive in and of itself.

References

Phrases used to identify specific objects so that the
script can identify it. For example, word 3 of
document 1 is a reference. References can be
pasted into a script by selecting that object in the
source application, copying it, and pasting it into
the script. The reference for the object appears
when you use the Paste command (the object itself
does not appear).

Writing Simple Scripts
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Fig. 38.5
The Result window
shows the results
of operators but
also d isplays some
error messages.

the result

li

Writing Simple Scripts
Writing an AppleScript is more difficult than recording one. With writing,
you're actually doing low-level programming, although some programmers
will have more difficulty writing scripts than average users. What programmers know that you might not know (if you're not a programmer) is how to
formulate commands, in what order to place commands, and how to nest
commands.
The Check Syntax button is your closest ally in writing usable scripts, especially for those of you who are new to scripting. When you write a script, you
attempt to match the type of terminology you see when you record a script.
If you write the script correctly and click the Ch eck Syntax button, the steps
of the script are formatted and compiled, like those you see on the left side of
figure 38.6.
To write a script you need to launch the application ScriptEditor. You don't
need to launch the program, nor open the document for which you want to
write the script, since you can instruct your script to do this for you. However, if you want to apply a script to a specific document, it is usually easier
to open the document and the script and click the Run button. Follow these
steps for writing a script:
1. Launch the Microsoft Office application and open an existing docu-

ment or begin a new document.
2. Launch the application ScriptEditor.
3. Type the script in the window of ScriptEditor. Be sure to use only the

words listed in the dictionary of the application or of ScriptEditor.

VI
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Tip
If you can't
remember the
words and
phrases of an
application, use
the Open Dictionary command in the
ScriptEditor File
menu.
Fig. 38.6
The example on
the left is a script
with proper
syntax. The
example on the
right is very
simi.lar-in fact,
an attempt at the
same script. Using
the Check Syntax
button, the first
word out of syntax
is highlighted.

4 . Check the syntax of your script as you go along and make the necessary
changes.
5. When your script is com plete, click the Run button.

If your script does not perform the functions you requested, make the
necessary changes. Sometimes you are only missing an operator; sometimes you won't have defined a variable. To a new scripter, many errors
are made just in how the instructions are worded.

6. Save the Script by choosing Save from the File menu.

It's also possible to record portions of the script and then write additional
information or add subrou tines. If you're having t rouble writing a routine, try
recording a similar sequence in a new ScriptEditor window and look closely
at the syntax. Copy and paste the portions of the recorded script that apply
into your written script.

Troubleshooting
I have written script, but every time I check the syntax, it comes up with an error. How do
I know what to type?

Correct syntax is the toughest part about scripting. There are several places you can
get help. Table 38.1 has a vocabulary list for ScriptEditor. Check here if you don't
understand the meaning of a word in your error dialog box. If the word is not understood by the script, check the dictionary of ScriptEditor or Microsoft to see if you
have used the correct phrase or reference. Lastly, try to record a similar sequence to
see how the application prefers the syntax.
I am progressing in my scripting and want to save my work, but when I return to the
script later I sometimes forget what I was working on and what a routine is supposed
to do.

Saving Scripts
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Tip
You can embed lines of text to explain a routine or to remind you of its fu nction right
in the script. This is called a comment line. A comment line is preceded by two hyphens with no space in between. When Script Editor comes to a line preceded by
two hyphens it ignores the information contained in that line or routine. Adding
hyphens to a line is called commenting it out.

Saving Scripts

Tip

After you have a script, you need to save it. Like any document, you should
save your work as you go along. When your script is complete, you need to
choose a saving method that controls how the script is used or edited in the
future. You save a script in the same way as you would any Microsoft Office
document, but you have three formatting options. The Save dialog box is
shown in figure 38.7. Following are the options:
• Application. Can be launched on its own without ScriptEditor and

activated like other Macintosh applications.
•

You can copy
words from the
dictionary of the
application and
paste them into
the script.

You may find it
helpful to write an
o utline or flowchart about what
you want to include in your
script. However,
you may fare just
as well jumping
right in to
ScriptEditor.

Compiled script. Can only be opened by ScriptEditor.

• Text file. This save method does not require that the script contain
proper syntax or that it be Run [compiled], but you do need to hold
down the shift key as you select Save from the File menu.
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When you save a script as an application, you also can choose Stay Open
(the script remains open after it has been run), or Never Show Startup Screen
(this is a description of the script displayed in a startup screen).
Another type of script is a Run-Only Script. These scripts can be run but not
opened in ScriptEditor. Instead of Save, choose Save As Run-Only from the
File menu.

Fig. 38.7
Use the Save dialog
box to save a
recorded or written
script. Choose
the type of save
method from the
pop-up menu at
the bottom of the
window.
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If you're serious about wanting to write scripts, the documentation on the
System 7.5 disks can get you started. The more complex the task, the more
complex the scripts will be. Use the documentation and try the examples.
They are designed to introduce you slowly to the concept of total automation, but AppleScripting for applications will take some time to master. Try
creating simple scripts for setting tabs, or indents, or some other fairly easy
task, and then you'll learn about the syntax through trial and error and become a better programmer.

From Here ...
Other parts of Microsoft Office are prime targets for AppleScripting.
PowerTalk can benefit from a custom script. Text formatting and nonconsecutive page printing are functions that are candidates for scripting.
Turn to these chapters for more information on those topics.
• Chapter 2, 11 Using Common Features to Create Documents," can offer
you a refresher course on getting around in the Office suite of applications .
• Chapter 16, 11 Creating and Printing Reports and Charts," takes a look at
how to print handouts for PowerPoint, a great scripting place.
• Chapter 32, 11 Using Office Applications with PowerTalk," introduces
new Apple software for connectivity.

Chapter 39

Version
Applications
by Carman Minarik

Microsoft Office is available both for Macintosh computers and PCs running
Microsoft Windows. In many organizations, Macintosh and IBM-compatible
versions of the Office package must coexist and exchange information. Home
Macintosh users also may need to exchange data with PC users. In this chapter you will explore the various methods of transferring files between the
Macintosh and PC computing platforms.
In this chapter, you learn the following:
• The difference between file transfer and file translation
• How to transfer files using floppy disks, networks, or other cabling
• How to use Apple File Exchange to transfer files
• How software utilities can make the file transfer process easier
• Differences between Macintosh and PC file types
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Understanding General Concepts
The two questions you must ask yourself when transferring files between a
Macintosh and a PC are How do I move the file from one computer to the other?
and How do I use the file on the other computer? While each question raises
unique issues, they are rarely addressed independently.
The first step toward exchanging information between a Macintosh and a PC
is to physically transfer the file from one machine to the other. While both
Macintosh computers and PCs use similar media (hard disks, floppy disks,
CD-ROM, and so on) to store information, the manner in which data is arranged on the media is drastically different on each platform.
After the file has been moved to the computer where it is needed, the issue
becomes how the file can be made usable. Microsoft Office applications address this issue elegantly. Office applications for Macintosh can open Office
for Windows files directly, and Office for Windows applications can open
Office for Macintosh files directly.

Transferring Files to Another
Platform
File transfer is the process of moving a file from one machine to the other.
You can transfer a file using floppy disks, network systems, or direct cable
connections between computers.

Transferring from Disks
The most common method of transferring files from one platform to another
is to use a floppy disk. Both PCs and Macintosh computers can use a 3.5-inch
floppy disk, but the formats are different. If you place a Macintosh-formatted
floppy disk in a PC, it can't be read. Similarly, a Macintosh without special
software will be unable to read any PC-formatted disk placed in its drive.
To alleviate this problem, Macintosh computers with high-density drives can
read and write PC-formatted disks. High-density drives are able to use 1.44M
disks, and have been standard on all Macintosh models since the SE/30 was
introduced. In order for the Macintosh operating system to recognize a PCformatted disk, however, software such as Apple File Exchange or Macintosh
PC Exchange must be loaded.

Transferring Files to Another Platform
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Using Apple File Exchange

Even though the Macintosh high-density drive is physically able to read
PC disks, special software is needed to actually transfer files. The Macintosh
comes with an application called Apple File Exchange, which is a software
program designed to transfer files between the Macintosh and a PC-formatted
floppy disk. Some Macintosh models also ship with Macintosh PC Exchange,
which is discussed in detail later in this chapter.

Caution
Apple File Exchange must be launched before the PC floppy disk is inserted in
the floppy drive. Otherwise, the Macintosh will treat the disk like any other nonMacintosh formatted disk, and prompt you to initialize it. This situation is alleviated
if PC Exchange is loaded.

Launch Apple File Exchange by double-clicking its icon. Apple File Exchange
is often found in the Utilities folder on the hard disk.

Tip
Apple File
Exchange is not
copied to the
hard disk automatically as
part of the
system installation process.
You may need
to manually
copy the applicatio n from the
Tidbits system
installatio n disk
to the hard
d isk.

When launched, Apple File Exchange shows a transfer window similar to that
shown in figure 39.1.
Fig. 39.1
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Initially, the left side of this window displays the contents of the Macintosh's
hard drive. When a PC disk is placed in the floppy drive, the contents of that
disk are displayed in the right side of the window.

VI
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Use the following guidelines while working with Apple File Exchange:
• A file can be selected in either window by clicking the desired file.
• Hold down the shift key while clicking files to select a continuous range
of files.
• Hold the control key while clicking files to select discontinuous files.
• The arrows on the Translate button confirm the direction of the
transfer.
• Click the Translate button to transfer the files.
You can use the standard Macintosh file dialog controls in the Apple File
Exchange window to choose other disks, folders, and so on. Be sure you have
selected the appropriate folder into which to transfer files.
Using Commercial File Exchange Utilities
Apple File Exchange can be used effectively to transfer files from one platform to another. The software is somewhat cumbersome, however, in that
you must remember to run the application before you place a PC-formatted
disk in the floppy drive. Commercial utility programs exist which allow
PC disks to be mounted on the Macintosh desktop in the same way that
Macintosh disks are mounted.

~

See "Working
with Disks and
Drives," p. 65

The most popular of these utilities are DOS Mounter from Dayna Corporation, Access PC, and Macintosh PC Exchange from Apple. All of these packages allow the Macintosh to mount, format, and copy information to and
from PC disks as well as Macintosh disks.
Each of these utilities operate in much the same manner. The software is in
the form of a Control Panel which automatically launches at system startup
time. The Control Panel extends your operating system's ability to recognize
and use floppy disks to include PC-formatted disks as well as Macintosh disks.
Figure 39.2 shows a PC-formatted disk as it would appear on a Macintosh
with Apple's Macintosh PC Exchange software installed.

Fig. 39.2
PC Exchange
allows the PC disk

to be used exactly
like a Macintosh
disk.

Translating Files
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Caution
When using floppy disks to transfer files between PCs and Macintosh computers, be
sure the disks are formatted properly. High-density PC disks (those with an "HD"
stamped on them, and two square corner holes rather than one) must be formatted
1.44M, and standard PC disks must be formatted 720K. If a standard disk is formatted 1 .44M, the Macintosh will not be able to read the disk.

Transferring Over a Network
Files also can be transferred from one platform to another using network
wiring. If the Macintosh computers and PCs are connected to a compatible
network (such as AppleTalk, Novell, or Tops) files can usually be transferred
either peer-to-peer or via a file server.

Tip
The Special
menu option
Erase Disk
allows you to
choose whether
to format the
disk as a
Macintosh disk
or as a PC disk.
Both high
density and low
density disks
are supported.

Commercial software such as Farallon's PhoneNET PC allows PC users to
connect to Macintosh file servers and transfer files much in the same manner
as a Macintosh user would. Products such as Novell's NetWare for Macintosh
allow Macintosh users to connect with Novell file servers.

Transferring via Cable or Modem
Other common methods of transferring files include direct cable connection
or connection over phone lines using modems.
Utilities such as MacLinkPlus/PC allow direct connection of Macintosh computers and PCs via a special cable and software. Modems can be connected to
both Macintosh and IBM-compatible computers allowing files to be transmitted over standard telephone lines. Software to communicate via modem
varies greatly, but nearly every communication software package includes
standard file transfer options.

VI

Translating Files
Once the Office for Windows documents are transferred to the Macintosh,
they can be used in their corresponding Office for Macintosh applications.
Documents created using Macintosh and Windows versions of Microsoft
Office use the same file type. Therefore, each of the Office for Macintosh
applications can directly open documents created by its Windows counterpart. For example, Word for Windows 6.0 documents can be opened directly

<Ill See "Saving,

Opening,
and C losing
Files," p. 62
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by Word for Macintosh 6.0. Likewise, Excel and PowerPoint documents can
be read across platforms. Choosing File Open in any Office application displays a dialog box similar to the one in figure 39.3. Files created in either
Macintosh or Windows versions of the Office software will appear in the
open dialog file list.

Fig. 39.3
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Understanding File Name Differences
between Platforms
When transferring a file between Macintosh and PC platforms, keep in mind
how to name the file. The Macintosh allows long file names and use of most
characters, while PCs have more stringent naming rules. Table 39.1 lists the
naming differences on Macintosh and PC systems.

Table 39.1

File Name Conventions

File System

Number of Characters

Illegal Characters

MS-DOS (PC)

8 maximum with an
optional 3-character
extension

angle brackets<>
asterisk*
comma,
colon:
equal sign=
pipe I
null
plus sign+
quotation marks ""
question mark ?
slashes/\
square brackets []
space

Macintosh

31 maximum

colon:
null

Converting Fonts
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Not only do PCs and Macintoshes require different naming conventions, but
they also recognize files in different ways. PCs rely on the three-character
extension in a file name to determine which application was used to create
the file. Macintosh applications check the file's type and creator information,
which is stored within the file itself. Table 39.2 shows the file type equivalents between Macintosh and PC platforms for Office applications.

Table 39.2

File Types

File Type

PC Extension

Microsoft Excel Worksheet

.XLS

Microsoft Excel Chart

.XLC

Microsoft Excel Workbook

.XLW

Microsoft Excel Macro Sheet

.XLM

M icrosoft Word

.DOC

Microsoft PowerPoint

.PPT

Converting Fonts
If you create a file using a certain font on one platform and then transfer that
file to another platform, the document will look different unless an equivalent font is available.
To address this issue, Microsoft Office for Macintosh is shipped with
TrueType versions of many commonly used Windows fonts. Font conversion
problems can be kept to a minimum by using fonts in your documents, presentations, and spreadsheets, which are available on both platforms.
If a font is used in a Wi ndows application that has no counterpart on the
Macintosh, a similar font will be substituted. The Word and PowerPoint
applications provide additional font conversion control.

Using Word
In Microsoft Word, follow these steps to control font substitution:
1 . Choose Tools Options.

<1111

See "Formatting
Documents,"
p.46
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2. Click the Compatibility tab.

3. Click the Font Substitution button. If there are fonts in th e active document which are not available on your system, a dialog box similar to
the on e shown in figure 39.4 appears.
Fig. 39.4
Use this d ialog
box to select the
fonts to be
substituted.

Font Subs titution
foot Sohlltatlo..
MIUirw;J Oocumont Fo11_t

r

Subl~tute<!

'

OK

~

Sub!tltll\«1 Font:

Mis:Jlfl9 Ooc:ument Font:

I a~·

Font

I

lrrilio>

.,..._...

J(

...,n.,t~spl,...,

Cea~l

l

~

""''"'"""'*>9 -r....-.

( c. .vort Ptrll!lttDIII- )

(

Help

l

4. Choose the missing font for which you want to set a substitute from the

list.
5. Select the font to substitute for the missing font from the Substituted

Font pop-up list.

Using PowerPoint
PowerPoint also allows control over font substitution. Choose Tools, Replace
Fonts to access a dialog box similar to figure 39.5.
The top fi eld shows the fonts used in the current presentation , and the bottom field allows you to choose the desired substitute for each missing font.
Fig. 39.5
Choose the fonts
to substitute in
this dialog box.

Replace Font

From Here...

From Here ...
In this chapter, you have learned the basics for transferring Office files between the Macintosh and PC platforms. You have seen several methods of
transferring files, and have looked at issues impacting the translation of files
between platform.
• Chapter 3, "Managing Files and Work Areas," shows you how to open
and save files.
• Chapter 5, "Formatting Text and Documents," and Chapter 24,
"Enhancing a Presentation," provide information on font use in
Microsoft Office applications.
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Appendix A

Installing Microsaft
Office

The standard edition of Microsoft Office consists of Word, Excel, PowerPoint,
and Mail.
If you've already installed an older version of Office but need to update an

individual application (from Excel 4.0 to 5.0, for instance, or PowerPoint 3.0
to 4.0), refer to the later section in this appendix, "Updating an Existing
Installation."
In this appendix, you learn how to
• Install Microsoft Office for the first time
• Install Microsoft Office on a network
• Update an existing installation of Microsoft Office

Preparing to Install Office
Before you install Microsoft Office, you should take a few minutes to check
your system and back up important system files. Hints for preparing to install
Office are described in the sections that follow.

Checking Your System Requirements
Verify that your system can run Microsoft Office. Microsoft Office requires
System 7.0 or later (7.1.2 or later for Power Macs), which should already be
installed on your computer. The computer must have at least a 68020 CPU
and 4M of RAM. If you want faster processing, you should have a 68040based Macintosh and increase your RAM to at least 8M. The Office applications
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can also run on Power Macintoshes under emulation, and native Power Mac
versions are also available. If you have a Power Macintosh, you should always
run the native-mode version of the Office applications to get the best performance. Power Macs require at least 8M of RAM to run Office.
You'll especially notice the difference that more RAM can make if you run
multiple applications simultaneously. The Office applications each require at
least 2M of RAM to run. If you run out of real RAM, you can turn on virtual
memory in the Memory Control Panel. If you're not familiar with virtual
memory, it's a scheme that allows your Mac to use part of its hard disk as
though it were RAM. Because disk access is so much slower than RAM access,
however, this results in noticeable sluggishness. Everything still runs, but it
runs much more slowly than if actual RAM were available.
If you notice Jots of drive accesses (and delays) when shifting from one application to another, consider installing additional RAM so that you're less
dependent upon you r hard disk for virtual memory.
Note
The following Macs, because they are based on the 68000 processor, cannot run
Microsoft Office: Mac 128K, Mac 512K and 512KE, Macintosh Plus, SE, Portable,
Classic, and the PowerBook 1 00.

Verifying Your Hard Disk Space
The amount of space you need depends upon how much of the suite you
choose to install. If you install everything in the standard package, you need
a whopping 73M of disk space.
If you don't have that much disk space free, you can select a portion of
Microsoft Office to install now and install the rest later. You'll have to make
room for it, of course, by deleting files from you r hard drive. If you don't
already use a disk compression utility, you can also gain space by installing
one. Each application also allows for a partial installation, so you can forego
features that you may not need in a particular application. For example, if
you're a grammar whiz, you can omit installation of the grammar checker
in Word.

Deactivating Other Programs
To be on the safe side, you shouldn't be running any other programs when
you install Microsoft Office. Quit any open programs, then choose Restart

Installing Office for the First Time
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from the Special menu in the Finder. As your machine restarts, hold down
the shift key to disable any system extensions, such as virus checkers, from
running.

Installing Office for the First Time
After you have verified that you have enough space and no other programs
are running, you are ready to run Microsoft's Setup programs to install Office
onto your hard drive.

Running the Setup Program
Word, Excel, PowerPoint, Mail, and the Microsoft Office Manager each have
their own Setup programs. To install an Office application, insert the Setup
Disk for that application into your floppy drive (the floppy disks shipped
with the Office package are 1.4M floppies).
Open the Setup floppy disk by double-clicking its icon, if necessary. Doubleclick the icon of the Setup application. This icon will be named slightly differently, depending on the application you are installing. For example, it will
be named Microsoft Word Setup for Word, Microsoft Excel Setup for Excel,
and so on.
After a few moments, you will see the initial Microsoft Office installation
screen. The installation screen provides some brief copyright information, as
well as options to continue the installation (OK), exit the installation, or get
help. Be prepared to wait while Setup checks and prepares your system for
installation.

Entering Your Name, Organization, and
Serial Number
When Setup finishes preparing your system, the Welcome to Setup screen
appears. The first time you run the Office Setup programs, you are prompted
to enter the name and organization to use for the installation. You can't
install the Office applications unless you enter a name here, but the organization name is optional.
This information is written to the installation disk, into the Registration Database file in the Preferences folder inside the System Folder. This file is read
on subsequent passes through the Setup program, so that you don't have to
enter the information again. The name and organization you enter are displayed on the opening screens when you start a Microsoft Office program.

Tip
You can retrieve
your serial number
in any Office
application. just
choose About
menu at the top of
the Apple menu of
the application.
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After you have entered the name and organization, your Microsoft Office
application's serial number appears.

Selecting Folders
You will be prompted for a folder in which to store your Microsoft Office
program files. The Setup program will suggest creating a folder called
Microsoft (Word, Excel, or PowerPoint) in the top level of your hard disk.
You can accept the suggested location or choose another one.
You can choose the Desktop button, and then choose another disk if you
want the files to be installed somewhere else, or you can navigate into a
folder by double-clicking the folder's name. Whether you choose a folder
or a disk, Setup creates a new folder for each Office application.

Choosing the Installation Type
Office lets you choose how much of each program you want to install. The
choices are for Typical, Complete/Custom, or Minimum configurations.
Choose an installation type based on the space available on your hard drive
and how much of the programs you need installed. As you proceed with the
installation, Setup informs you of how much disk space your selections
require.
By default, the Complete/Custom installation installs everything. It gives you
the option to deselect portions of each program, so you can omit selected
example files, for instance. If you don't want to install part of a program's
files, select the category of optional files in the Options list box, and then
click the small triangle next to that category of features. An indented list of
files in that category appears. Deselect any files you don't want to install, and
then scroll down to the next category of files. Repeat this procedure for any
other categories for which you want to install only part of the files. When
you have only the files you want to install for all the categories, click the
Continue button to install the selected items.
The Minimum Installation configuration installs only those files that are
absolutely necessary to run the programs. No examples or help files are included. Bare-bones installation of Word requires SM, Excel needs 6M, and
PowerPoint needs 7M.
The Typical installation falls somewhere in between. You get all the files that
are minimally sufficient to run the programs, of course, but you also get the
Help files and the Microsoft Office Manager. Total disk space needed: about
40M.

Installing Office for the First Time

You can return to Setup anytime to modify your installation; you don't have
to do everything at one sitting (and, with 36 high-density disks among the
whole Office suite, you may not want to).
If an option is grayed out on the menu and can't be chosen, Setup has determined that you don't have enough disk space for it. If this happens and you
want to install an Office application according to an option that isn't available, you don't necessarily have to cancel the installation. Instead, you could
do one of the following:
• Try installing on a different drive that may have more space. Click the

Desktop button; it permits you to choose another drive.
• Switch to the Finder to free more space on the drive. Click the desktop
visible behind the Setup window to make the Finder active. Drag files to
the Trash to delete files until you have enough space. Remember to
empty the Trash from the Finder's Special menu before you return to
the Setup program.
If these options don't work, you may have to consider another installation

type, or exit and wait until you can consider your options more completely.
While the custom installation provides the greatest flexibility, each option
gives you some control over what is installed. The minimum configuration
lets you decide only which applications to install. Note that Change Option
is grayed out; there is nothing left to pare away from the minimum installations of any of the programs.

Installing Office on a Network
Microsoft Office can be installed on a network using the Setup program that
comes with the software. However, before doing so, you must consult
Microsoft and obtain a license agreement.
Installing Office on the Network Server
The Setup program for networks is very similar to the stand-alone installation. The network administrator should perform a Complete installation onto
the file server. Naturally, you need to have write access to the file server. No
one else should have access to the network during the installation process.
Installing Office from the Network to Workstations
After the network administrator installs Office on the network server, each
user who will use Office needs to run the Setup program to install it on the
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workstation. The network administrator needs to contact Microsoft to secure
a license for the appropriate number of workstation installations.
The workstation installation will be very similar to the stand-alone installation. You connect to the file server, and then open the folder on the file
server that contains the Setup program for the Office application you are
installing. The installation will proceed just like the stand-alone installation,
choosing any of the installation options (Typical, Complete/Custom, or Minimum Installation).

Updating an Existing Installation
Microsoft Office provides for maintenance of existing installations. You can
use this to add or remove parts of Office in your installation. If you run an
application's Setup program again after an earlier Office installation, you will
see the Setup maintenance screen. From this screen, you can choose to add or
remove components of the Office application.

Choosing Installation Options
If you click the Add/Remove button in the installation maintenance screen,
you see a selection menu just like the one used for a custom installation of
Microsoft Office. You just select the boxes corresponding to the files you
want to add (or remove), and Setup handles the rest.

If you want even finer control, you can click the small triangle next to a file
category to determine which of its subcomponents to install.
If an option is not installed, its check box will be blank. To install a new

option, select its check box and click OK. Setup then prompts you for the
installation disks as needed.

Removing Programs and Installing Newer Versions
Each program in Microsoft Office has its own development schedule, so
version upgrades of individual programs aren't likely to be issued simultaneously. This makes the purchase of the suite somewhat vexing, since you
may not get all the most current versions of each program packaged together.
You might have the 680XO-only version of Word or the version that includes
installers for both 680XO and Power Macintosh, for example, depending on
when you bought Office.
Many people purchased or upgraded to the previous version of Microsoft
Office with the understanding that automatic upgrades (for example, Excel

Updating an Existing Installation

5.0 and PowerPoint 4.0) would be forthcoming. Others may eventually want
to upgrade only various modules of the suite. Managing changing versions of
individual Office modules is simplified by the maintenance menu's Add/
Remove option.
If you want to remove an older version of a single program before installing
an upgrade, choose Add/Remove from the maintenance menu. You will see
which programs are installed on your system. If an item is currently installed,
an X is marked in its check box. Otherwise, the box is blank.

However, you may not need to remove older programs before upgrading
them. Setup typically lets you install over older installations. If you have
Excel 4.0, PowerPoint 3.0, or Word 5.1, run the Setup program that comes
with your new version of Excel 5.0, PowerPoint 4.0, or Word 6.0.
At the highest level, you can deselect the single box corresponding to any
program in the suite and completely remove it from your system. If you are
ready to install the newest version of Excel and want to delete the older one
to avoid any possible conflicts between the two versions, for example, deseIect the Excel box and click OK. Setup will remove all the Excel files you
previously installed with Office.
If you want to remove only certain elements of a program, choose Change
Options while that program is highlighted on the menu list. You will see the
currently installed options for each program. To delete items, remove their
marks. When you click OK, the items you have changed will be removed.
If, for any reason, you want to reinstall all of your Microsoft Office programs
(you may have had a problem with your hard drive, for example, and some
files were corrupted), choose Reinstall. Setup determines what programs you
originally installed, and will reinstall any files that have been lost or damaged.
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Index of Commo
Problems

All Office Applications and Application Integration
If you have this problem ...

You'll find help here ...

Black circle with slash appears when
trying to copy

p.593

Copied text appears in middle of existing
text

p.593

Copy between documents with drag-anddrop didn't leave original

p.593

Copy of unwanted material appears when
I paste

p. 44

Copy with drag-and-drop didn' t leave
original

p. 46

Document file won't open

p. 705

Editions are difficult to track; can't
find where they're stored, which
subscribers have been updated, etc.

p. 65 1

Excel data doesn't line up properly in
PowerPoint

p. 710

Excel worksheet too big to fit in
PowerPoint
File name doesn't appear in File List box

p. 710
p. 65
(continues)
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All Office Applications and Application Integration
If you have this problem ...

Continued

You'll find help here ...

Find File doesn't find documents with
specified text

p. 574

Find File doesn't search specified
network drive

p.574

Find in Field doesn't find a record
I know exists

p.690

Formatted with wrong format

p.48

Menu descriptions need to be edited

p. 741

Menu disappears after pressing
~+op t i on+ m i n us sign (·)

p. 741

Menus have been customized

p. 741

Script: is recalling what routines do

p. 803

Script syntax has error

p. 802

Source document changes don't appear
in destination document

pp. 608-609

Standard toolbar has been modified

p. 738

Toolbar contains no buttons

p. 738

Toolbars hard to see on a monochrome
monitor

p. 739

Updated information doesn't match publisher

p. 652

Word
If you have this problem ...

You'll find help he re ...

AutoCorrect makes additions without running
Spell Checker

p. 127

AutoFormat doesn't change document's
formatting

p. 190

AutoFormatting is part of document

p. 190

Column is missing on-screen when text is
formatted in two columns

p. 108

Index of Common Problems

If you have this problem ...
Data from Excel, Microsoft Works, and
ClarisWorks: importing into Word

You'll find help here...
p.205

Deleted or cleared text accidentally

p.98

Drag-and-drop pointer appears when I
do not want it

p.98

File Find cannot find desired file with
search criteria

p. 147

File Find: searching in text for a file

p. 147

File format for saving not listed in
file types

p. 101

Files: copy, delete, or print multiple
files

p. 151

Formatted text with fonts and alignments
changes needs to be changed to
original formatting

p. 111

Formatting quickly in more than one
place in document

p. 111

Grammar Checker stops on spelling changes

p. 131

Grammar Checker: undoing changes

p. 131

Justified text has large gaps between words

p. 118

Line spacing needs to change without
changing paragraph spacing

p. 118

Macro folder cannot be found

p.219

Macro recording doesn't record mouse steps

p.218

Macro: moving from Normal template to
another template

p.219

Margins cannot be set accurately with
ruler in Print Preview

p. 134

Outline doesn't display body text when
outline is collapsed

p. 180

Outline levels: printing only certain
levels

p. 182

Pasted selected text in wrong place

p.98
(continues)
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Word

Continued

If you have this problem ...

You'll find help here...

Printing an 8 1/ 2·by·14-inch document

p. 122

Printing data without printing data form

p. 135

Printing leaves off edges of text

p. 122

Printing only selected pages

p. 134

Printing to a different printer

p. 135

Saving a document that was created in
another file format

p. 101

Screen doesn't display enough of document
to edit

p.

Screen redraws slowly with many fonts
and graphics

p. 108

Selecting text difficult with mouse

108

p.94

Spell Checker must ignore words with
numbers

p. 127

Spelling dictionary (custom) needs editing

p. 127

Spinning ball icon on-screen

p. 151

Summary Info has title even though you
didn't add title

p. 142

Summary Info limit on number of keywords

p. 142

Tab and indent settings for a paragraph
needed

p. 118

Table: adding another column at the
right side

p. 201

Table: inserted rows or columns in wrong
place

p. 201

Template's style names cannot be found

p. 190

Thesaurus: going back to the last word
looked up

p. 129

Thesaurus: reverting to the original word

p. 129

Typed text doesn' t appear on-screen

p.94

Wizard is not listed in the New dialog box

p. 193

Index of Common Problems

Excel

If you have this problem ...

You'll find help here...

##### appears in a filled cell

pp. 235 &: 276

#NAME? displays in a cell with a formula

p. 319

#NAME? displays in a cell with a function

p. 311

Aligning characters vertically hides
display of some characters

p.284

AutoFill fills the entire range with
the same data

p.245

AutoFill fills with wrong increment

p. 245

AutoFill won't copy a range of data

p.257

AutoFormat displays a message saying it
cannot detect a table

p.289

AutoSum does not produce a total

p. 311

Cell entry isn't displayed after color
change

p.289

Centering a selection across a range
doesn't work

p.284

Chart commands with chart embedded in
worksheet

p. 352

Chart formats are lost when using
AutoFormat

p. 352

Chart needs to display without legend

p. 352

Column headings are sorted with data
in list

p. 365

Data Form command displays error message
that no list was found

p. 360

Date converted to a number

p.237

Drag-and-drop copies cells instead of
moving them

p.258

Drag-and-drop won't copy data

p.256

Error in a formula

p. 305

Filtered list doesn't display any records

p. 365
(continues)
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Excel

Continued

'

If you have this problem ...

You'll find help here ...

Formula appears as a cell label instead
of calculating

p.237

Formula used to calculate range doesn't
calculate properly

p.236

Formula with name treated as a text entry

p. 320

International currency symbol used with
custom number format

p.276

Macro changes data but changes are undone

p.401

Macro commands start with an equal sign

p.405

Macro Error dialog box appears when
macro runs

p.405

Macro needs steps recorded/added

p.401

Macro recording mistakes are repeated when
macro runs

p. 401

Macro shortcut key doesn't work

p.405

Page break: can't remove

p.333

Page breaks: only some removed

p.333

Parentheses do not match in formula

p. 305

Paste won't paste a second copy of
copied cells

p.256

Printing selected embedded chart instead
of entire worksheet

p. 352

Record can't be added to list

p. 360

Report cannot be created because Print
Report doesn't appear in File menu

p. 337

Report printed with all pages numbered 1

p. 337

Index of Common Problems

PowerPoint
If you have this problem ...

You'll find help here ...

Background is too dark in template

p.438

Bullets: deleting them from an Autol ayout

p.460

Clip-Art Gallery: adding clip art from
other programs

p. 461

Clip-art picture: changing colors

p. 461

Deleted a slide from presentation

p.440

Graph: adding a graph on a slide that
doesn't include a graph in the Autolayout

p. 524

Lines and arcs: changing the length and
direction

p.496

Lines: drawing at an angle other than 45
degrees

p.496

Microsoft Graph: closed datasheet window
before I was finished with it

p. 524

Resizing an object by the same amount on
opposite sides

p.479

Selecting objects on multiple slides can't
be done

p.474

Selecting the company logo on a slide
doesn't work

p.474

Selection box doesn't select all objects
it should

p.474

Size and scale of imported picture are
wrong

p.479

Slide inserted in the wrong location

p.440

Slide master changes in a presentation
affecting the template

p.505

Slides: inserting or adding

p.440

Template: can't use more than one template
in a presentation

p.504

Template: creating a custom template

p.504
(continues)
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PowerPoint

Continued

If you have this problem ...

You'll find help here ...

Template: selected wrong template when
creating presentatio n with Wizard

p.438

Text object and label differences

p.460

Index

Symbols
o/o (percentage sign)

mathematical operator,
300
& (ampersand)
concatenation operator,
301
* (asterisk)
mathematical operator,
300
wild-card character, 263
+ (plus sign) mathematical
operator, 300
- (minus sign)
mathematical operator,
300
... (ellipsis) menu
commands, 31
I (backslash)
mathematical operator,
300
, (comma) union operator,
302
: (semicolon) range
operator, 302
< (less than sign)
comparative operator,
301
comparison operator
(Visual Basic for
Applications), 773
< > (not equal to sign)
comparative operator,
301
comparison operator
(Visual Basic for
Applications), 773

<<>>(chevrons) Mail
Merge, 682
<= (less than or equal
to sign)
comparative operator,
301
comparison operator
(Visual Basic for
Applications), 773
=(equal sign)
comparative operator,
301
comparison operator
(Visual Basic for
Applications), 773
formulas, 236
> (greater than sign)
comparative operator,
301
comparison operator
(Visual Basic for
Applications), 773
>= (greater than or equal
to sign)
comparison operator, 301
comparison operator
(Visual Basic for
Applications), 773
? (question mark) wildcard character, 263
" (caret) mathematical
operator, 300
_(underscore) range
names, 315
'II (paragraph marks), 90

2-D graphs, 534
3-D
dialog boxes, 158
graphs, 534

A
accent marks (uppercase
letters), 162
access codes (PowerTalk),
see passwords, PowerTalk
Access PC, 808
active windows, 81
Add Clipart dialog box,
461
Add Custom AutoFormat
dialog box, 348
Add Mailer command (File
menu) (PowerTalk), 665
Add Report dialog box,
335
Add Routing Slip
command (File menu)
(Word), 660
Add Scenario dialog box,
386
Add Template dialog box,
212
Add View dialog box, 335
add-ins
Report Manager, 334-336
Solver, 380-381
View Manager, 334-335
Add-Ins command (Excel
Tools menu), 334, 381

834

Add-Ins dialog box

Add-Ins dialog box, 334
addition mathematical
operator, 300
Address Mail dialog box
(Mail), 657
addressing
e-mail, 655-656
envelopes (Mail Merge),
695-696
Advanced Search dialog
box,69, 71,145,572
Agenda Wizard, 57, 190
Align comma nd (Draw
menu) (PowerPoint), 479
alignment
slide objects,479-480
text
documents, 118-119
slides, 508-509
worksheet cells,
280-284
Alignment command
(Format menu)
(PowerPoint), 508
ampersand (&)
concatenation operator,
301
anchors, see object anchors
And logical operator
(Visual Basic for
Applications), 774
annotations
slides, 559
worksheets
deleting, 393
inserting, 392-393
viewing, 393
answer reports (Solver),
384
Apple File Exchange,
807-809
Apple menu commands
Chooser, 77
Mail and Catalogs
(PowerTalk), 670
Note Pad, 577
Apple Open Collaboration
Environment (AOCE),
663
AppleMail (PowerTalk),
664

AppleScript, 1 7, 793-794
language, 795-796
ScriptEditor, 795-796
scripts
commenting out,
798, 803
editing, 798
fo rmatting, 799-800
recording, 794-798
run ning, 798
saving, 802-804
troubleshooting, 802
writing, 794-795,
799-803
AppleScript Formatting
command (File m enu)
(ScriptEditor), 799
AppleTalk m ail, 669-670
applets
Cli pArt Gallery, 16, 428,
626
Equation, 626
Graph, 626
Organization Chart, 40,
465-466, 626
WordArt, 626, 723-725
application keywords
(scripts), 800
applications
AppleScript
recordable
applications, 794-795
scriptable applications,
794-795
copying elements
between applications,
96
DigiSign (PowerTalk), 673
exiting, 21-22
OLE (Object Linking and
Embedding), 15
opening other
application files, 68
pasting elements between
applications, 96
Script Editor
(AppleScript), 795-796
starting, 20
switching between
applications, 21, 81, 578

transferring data between
applications, 632
Clipboard, 632-636
Scrapbook, 636-637
Visual Basic for
Applications, 763-767
see also applets; utilities
Apply Style command
(Format menu)
(PowerPoint), 517
arcs, drawing, 494-496
arguments (Visua l Basic
for Applications
methods), 757
Arrange All command
(Window menu)
(PowerPoint), 8 1
Arrange All command
(Window menu) (Word),
79
Arran ge command
(Window menu) (Excel),
79
arrays (Visual Basic for
Applications}, 770-771
arrowheads (lines}, 511
arrows (m enus), 31
Assign Macro dialog box
(Excel), 406-407
assigning
macros (Excel)
keyboard shortcuts,
403
sheet buttons, 406
toolbar buttons,
406-407
macros (Word) to keys,
214-215
passwords to files, 168
assignment statements
(Visual Basic for
Applications), 763
asterisk (*)
mathematical operator,
300
wild-card character, 263
audien ce handouts, see
handouts
AutoCorrect command
(Tools menu) (Word), 126

catalogs
AutoContent Wizard,
58,432-435
AutoContent Wizard
dialog box, 434
AutoCorrect (Spelling
Checker), 124-127
AutoCorrect dialog box,
126
AutoFill (worksheets),
240-245
AutoFilter, 362-364
AutoFormat command
(Format menu) (Excel),
289,347
AutoFormat command
(Insert menu) (Graph),
537
AutoFormat command
(Format menu) (Word),
172, 186
AutoFormat dialog box,
187,289,347,348,537
AutoFormats, 49-50,
172-173, 186-190, 375
charts, 34 7-349
Graph, 536-53 7
Style Gallery, 188-189
tables, 197
worksheet cells, 288-289
AutoLayouts (slides),
426, 449-451
AutoShapes toolbar
(PowerPoint), 490-491
AutoSum (formulas), 307
Avery mailing labels, 693
Award Wizard, 57, 190
axes (graphs), 540-541
Axes command (Insert
menu) (Graph), 541
Axes dialog box, 541

B
background repagination,
157
backgrounds
presentation templates,
438
screen display, 158
backslash (/) mathematical
operator, 300

backups (files), 68, 167
barcharts,617
beeps, setting, 158
blank presentations,
436-437
block If Structures (Visual
Basic for Applications),
773
boldfacing text, 110
bookmarks, 160
borders
charts, 617
deleting, 206
documents, 720-721
frames, 209
graphics, 206-210, 294
graphs, 543-545
line styles, 206
paragraphs, 721
patterns, 207
shading, 207
shapes
colors, 510-513
dashed lines, 5 11
patterns, 513-5 15
shading, 513-515
text, 206-210
worksheet cells, 287
Borders and Shading
command (Format menu)
(Word), 721
Borders toolbar, 205
Break command (Insert
menu) (Word), 717
Break dialog box, 717
breaks
column breaks
(documents), 717
page breaks
background
repagination, 157
documents, 717
worksheets, 323-325,
333
section breaks
(documents), 716, 718
Bring Forward command
(Draw menu) (Power
Point), 484
Bring to Front command
(Draw menu) (Power
Point), 484
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bugs (Visual Basic for
Applications), 787
bulleted lists (slides), 453
bullets (menus), 32
buttons (toolbars), 737
By Name command
(Finder View menu), 566

c
calculations
Calculator, 635
formulas, 300
pivot tables, 376
summary functions,
376
summary types,
376-377
worksheets
forecasting (Goal
Seeker), 378-380
Solver, 380
what-if analysis
(scenarios), 385-392
Calculator, 635
Calendar Wizard, 57, 190
calling procedures (Visual
Basic for Applications),
776-778
Can't Undo command
(Edit menu), 245
cards, see information
cards (PowerTalk
catalogs)
caret (") mathematical
operator, 300
Cascade command
(Window menu)
(PowerPoint), 81
cascading windows, 79
case (text), converting, 97
case-sensitivity (PowerTalk
passwords), 665
catalogs, 219-224
catalogs (PowerTalk), 664
information cards, 666
copying to network,
667
creating, 666
file server information
cards, 671
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catalogs

group information
cards, 671
user information
cards, 671
Personal Catalogs,
670-671
Shared Catalogs, 670-671
Catalogs menu commands
(PowerTalk)
New Personal Catalog,
670
Cell Height and Width
command (Table menu)
(Word), 199-200
Cell Height and Width
dialog box, 199-200
Cell Note dialog box
(Excel), 392
cell references
formulas, 299, 313-314
range names, 315-320
to another workbook,
314
Visual Basic for
Applications code,
774-776
cells
data sheets
clearing, 529
copying, 531-533
cutting, 531-533
moving, 531-533
selecting, 528-529
tables, 37, 196
adjusting height,
199-200
adjusting widths,
200-201
selecting, 198
worksheets, 37, 230
aligning contents,
280-284
annotations, 392-393
AutoFill, 240-245
AutoFormats, 288-289
borders, 287
characters, formatting,
286-287
checking spelling,
265-267
clearing contents,
251-252
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colors, 287-289
copying contents,
252-257
copying formatting,
255
dates, 235, 237
deleting contents, 251
editing, 249-251
finding, 262-263
formatting numbers,
269-276
formulas, 235-236
inserting, 259-260
insertion point, 250
moving, 257-259
moving between cells,
231-233
numbers, 234-235
patterns, 287-288
ranges, 237-239
replacing, 264-265
selecting, 231
text, 233, 234
times, 235
Cells command (Format
menu) (Excel), 237, 270,
273,285
Cells command (Insert
menu) (Excel), 259
Cells command (Insert
menu) (Graph), 530
Change AutoShape
command (Draw menu)
(PowerPoint), 493
Change Case command
(Format menu) (Word),
97
Change Case dialog box,
97
Change Source dialog box,
609
characters, see text
Chart command (Insert
menu) (Excel), 341
chart sheets, 341
Chart Type command
(Format menu) (Excel),
343,350
Chart Type command
(Format menu) (Graph),
534

Chart Type dialog box
(Excel), 343, 350
Chart Type dialog box
(Graph), 534
ChartWizard, 58, 341-352
charts (Excel charts), 338
bar charts, 617
borders, 617
chart sheets, 341
data labels, 344
data series, 350
editing, 349-350
embedding, 338-341
formatting
AutoFormats, 347-349
custom formats,
348-349
gridlines, 345
inserting, 725-726
legends, 352
linking, 614-617
moving, 343
objects
moving, 341-343
sizing, 341-343
organizational charts,
465-466
pie charts, 615-617
printing, 35 1
sizing, 342
slides, 465-466, 710-711
titles, 346
troubleshooting, 352
types, selecting, 343-344
see also graphs
ChartWizard dialog boxes,
338
check marks (menus), 32
chevrons(<<>>) Mail
Merge, 682
Choose Scheme dialog
box,520
Chooser command (Apple
menu), 77
classes (Visual Basic for
Applications), 753-754
Clear All command (Edit
menu) (Excel), 252
Clear command (Edit
menu), 95

commands
Clear command (Edit
menu) (Graph), 529
Clear Contents command
(Edit menu) (Excel), 252
Clear Formats command
(Edit menu) (Excel), 252
Clear Notes command
(Edit menu) (Excel}, 252
clearing
datasheets cells, 529
Clipboard, 636
worksheet cells, 251-252
see also deleting
ClickPaste (Mainstay), 637
clip art
documents, 726-727
slides, 428
ClipArt Gallery,
460-461
inserting, 460-461
troubleshooting, 461
Clip Art command (Insert
menu) (PowerPoint), 65,
460
ClipArt Gallery, 16, 428,
626
ClipArt Gallery dialog box
(PowerPoint}, 460
Clipboard, 43, 632
Calculator, 635
clearing, 636
copy and paste
operations, 96, 632-636
cut and paste operations,
96, 632-636
date, 635
file formats, 633-635
QuickTime movies, 635
saving
contents, 636
text formatting, 158,
633-635
size limitations, 635
sound files, 635
time, 635
Clippings files, 635
Close command (File
menu),62, 183,448
closing
files, 62-63, 149, 574
presentations, 448
see also exiting

code (Visual Basic for
Applications), colors, 749
see also Visual Basic for
Applications
collections (Visual Basic
for Applications),
753-754
color schemes (slides),
505-507, 517-518
editing colors, 518
selecting, 519-520
colors
graphs, 543-545
shapes
borders, 510-513
fills, 490, 510-513
Visual Basic for
Applications code, 749
worksheets
cells, 287-289
graphics, 294
printing, 327
Colors and Lines
command (Format menu)
(PowerPoint}, 510, 513
Colors and Lines dialog
box, 510, 513
Column AutoFit command
(Format menu) (Excel),
278
column breaks
(documents), 717
Column Width dialog box,
278
columns
datasheets
data series, 526-527
deleting, 530
excluding from
graphs, 533-534
inserting, 530
selecting, 528-529
documents, 713-716
adjusting widths, 716
breaking, 717
setting, 121-122
viewing, 715
pivot tables, rearranging
data, 371
tables, 196
adjusting widths, 49,
196, 200-201
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deleting, 199
inserting, 199, 201
selecting, 198
worksheets, 229
adjusting widths, 49,
276-278
centering text across
columns, 282
deleting, 260
inserting, 25 9
printing column
headings, 327
selecting, 239
Columns command (Insert
menu) (Excel), 259
Columns command
(Format menu) (Word),
122, 714
Columns dialog box, 121
comma{,) union operator,
302
commands
Apple menu
Chooser, 77
Mail and Catalogs
(PowerTalk), 670
Note Pad, 577
Catalogs menu
New Personal Catalog
(PowerTalk), 670
Data menu
Exclude Row/Column
(Graph), 533
Filter (Excel), 362
Form (Excel), 357
PivotTable (Excel), 369
PivotTable Field
(Excel), 374
Series in Columns
(Graph), 527
Series in Rows
(Graph), 527
Sort (Excel), 361
Subtotals (Excel), 366
dimmed commands, 239
Draw menu (Power Point)
Align, 479
Bring Forward, 484
Bring to Front, 484
Change AutoShape,
493
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commands

Group,474
Rotate/Flip, 482
Scale, 478
Send Backward, 484
Send to Back, 484
Snap to Grid, 481
Ungroup, 476
Edit menu
Can't Undo, 245
Clear, 95, 529
Clear All (Excel), 252
Clear Contents (Excel),
252
Clear Formats (Excel),
252
Clear Notes (Excel),
252
Copy,253,477,532
Cut, 95, 476, 531
Delete, 260, 530
Delete Sheet (Excel),
261
Delete Slide
(PowerPoint), 439
Edit Publishing
Publisher Options,
646
Fill Series, 244-245
Find, 577
Find (Excel), 262
Go To, 232
Links (Word), 609
Open Publisher, 644
Paste, 96, 253, 476,
532
Paste Special, 305, 591,
725
Publishing, 645
Redo,94,246
Repeat, 111, 246
Repeat (Word), 111
Replace (Excel), 264
Select All (Power
Point), 473
Subscribe to from
Publishing, 648
Undo, 94, 245-246
File menu
Add Mailer
(PowerTalk), 665
Add Routing Slip
(Word), 660

AppleScript
Formatting
(ScriptEditor), 799
Close,62, 183,448
Create (PowerPoint),
468
Create New
(PowerPoint), 468
Delete Mailer
(PowerTalk), 668
Duplicate (PowerTalk),
667
Find File, 70, 575
Find (Finder), 569
Get Info (PowerTalk),
673
Mail (Excel), 660
Mail (PowerPoint), 660
Mail (PowerTalk), 668
New, 62, 100, 183
New Folder (Finder),
567
Open, 62, 100, 566
Open Dictionary
(ScriptEditor), 795
Page Setup, 76, 120,
323,325
Print, 76, 322, 549
Print Preview, 77, 330
Print Report (Excel),
334
Quit, 21, 414
Save,62,99,246,447
Save All (Word), 100
Save As, 98, 447
Save Workspace, 247
Send (PowerTalk), 668
Slide Setup
(PowerPoint), 547
Summary Info, 69, 574
Templates (Word), 212
Format menu
Alignment
(PowerPoint), 508
Apply Style
(PowerPoint), 517
AutoFormat (Excel),
289,347
AutoFormat (Word),
172, 186
Borders and Shading
(Word), 721

Cells (Excel), 237, 270,
273,285
Change Case (Word),
97
Chart Type (Excel),
343,350
Chart Type (Graph),
534
Colors and Lines
(PowerPoint), 510,
513
Column AutoFit
(Excel), 278
Columns (Word), 122,
714
Font (PowerPoint),
505-506
Font (Word), 110
Frame (Word), 599
Line Spacing
(PowerPoint), 508
Object (Excel), 294
Paragraph (Word), 113
Pick Up Style
(PowerPoint), 517
Placement (Excel), 294
Presentation Template
(PowerPoint), 435,
503
Rows (Excel), 279
Selected [Element]
(Graph), 545
Shadow (PowerPoint),
516
Slide Color Scheme
(PowerPoint), 502,
504,518
Style (Excel), 271, 290
Style (Word), 184
Tabs (Word), 115
Insert menu
AutoFormat (Graph),
537
Axes (Graph), 541
Break (Word), 717
Cells (Excel), 259
Cells (Graph), 530
Chart (Excel), 341
Clip Art (PowerPoint),
65,460
Columns (Excel), 259

Copy dialog box
Data Labels (Excel),
34S
Data Labels (Graph),
S40
Database (Word), 64
File (Word), 64, 610
Frame (Word), 210,
728
Function (Excel), 307
Gridlines (Excel), 34S
Gridlines (Graph), S41
Macro Dialog (Excel),
782
Microsoft Graph
(PowerPoint), 6S, S24
Microsoft Word Table
(PowerPoint), 6S
Name (Excel), 316
New Data (Excel), 3SO
New Slide
(PowerPoint), 439
Note (Excel), 392
Object (Excel), 64
Object (PowerPoint),
46S
Object (Word), 64, 202
Page Break (Excel), 324
Page Numbers (Word),
719
Picture (Excel), 64
Picture (PowerPoint),
64
Picture (Word), 64,
726
Remove Page Break
(Excel), 324
Rows (Excel), 2S9
Titles (Excel), 346
Titles (Graph), S39
Worksheet (Excel), 261
Mail menu
New Folder, 6S 7
Personal Groups, 6S8
repeating, 47, 94,
24S-246
Special menu, Lock Key
Chain (PowerTalk), 669
Table menu
Cell Height and
Width, 199-200
Delete Columns, 199
Delete Rows, 199

Gridlines, 197
Insert Columns, 199
Insert Rows, 199
Insert Table, 196
Select Table, 198
Tools menu
Add-Ins (Excel), 334,
381
AutoCorrect (Word),
126
Customize (Word),
739
Envelopes and Labels
(Word), 136
Goal Seek (Excel), 379
Grammar (Word), 129
Instant Watch (Excel),
787
Macro (Excel), 402
Macro (Word), 213
Macro Organizer
(Word), 219
Mail Merge (Word),
678
Options (Word), 1S6
Record Macro (Excel),
397
Replace Fonts
(PowerPoint), 812
Scenarios (Excel), 386
Solver(Excel), 381
Spelling (PowerPoint),
4S9
Spelling (Word), 124,
266
Thesaurus (Word), 127
Transistion
(PowerPoint), SS3
undoing, 47, 94, 98,
24S-246
View menu
By Name (Finder), S66
Datasheet (Graph),
S24
Guides (PowerPoint),
420
Header and Footer
(Word), 718
Normal (Word), lOS
Page Layout (Word),
lOS, 71S
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Rulers (PowerPoint),
420
Rulers (Word), 132
Slide Show
(PowerPoint), SSS
Toolbars, 24, 271
View Manager (Excel),
334
View Notes Pages
(PowerPoint), 421
View Outline
(PowerPoint), 421
View Slides
(PowerPoint), 421
Zoom (PowerPoint),
442
Zoom (Word), 107
Window menu
Arrange (Excel), 79
Arrange All
(PowerPoint), 81
Arrange All (Word), 79
Cascade (PowerPoint),
81
Unhide (Excel), 408
comments
scripts, 798, 800, 803
Visual Basic for
Applications, 749
comparative operators, 301
comparison operators
(Visual Basic for
Applications), 773
compatibility of Mail and
PowerTalk, 665
concatenation operator,
301
constants (Visual Basic for
Applications), 772
control panels, 20-21
Convert File dialog box,
149
Convert Object dialog box,
622
converting
case (text), 97
formulas to values,
304-30S
Copy command, 253,477,
532
Copy dialog box, 148
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copying

copying, 44
buttons (toolbars), 73 7
cells
datasheets, 531-533
worksheets, 252-25 7
data between
applications, 96
files, 148, 151, 570
formatting
text, 110-111, 158
worksheet cells, 255
formulas, 312-313
shape attributes, 517
slides, 445
slide objects, 477
sounds, 635
text, 96
between documents,
589-593
note pad into
documents, 58 7-588
see also transferring files
correspondence
(PowerTalk)
file formats, 668
forwarding, 668
headers, 668
replying, 668
sending, 668, 671
sending to users on other
networks, 6 75
Create command (File
menu) (PowerPoint), 468
Create Data Source
dialog box, 221, 680
Create Labels dialog box,
694
Create Names dialog box,
318
Create New command (File
menu) (PowerPoint), 468
cross-references, 639
Cue Cards, 51, 56
currency, international
symbols, 276
Customize command
(Office Manager menu),
733
Customize command
(Tools menu) (Word), 739
Customize dialog box
(Excel), 406

Customize dialog box
(Office Manager), 733
Customize dialog box
(Word), 739
Customize Grammar
Settings dialog box, 171
Customize Toolbars dialog
box, 736-737
customizing
Grammar Checker,
170-172
Office Manager, 733
menus, 734-735
QuickSwitch, 735
Spelling Checker, 169170
toolbars, 735-737
Word 6, 156-173,
739-740
Cut command (Edit
menu), 95, 476, 531
cutting, 44
cells (datasheets),
531-533
text, 95-96
see also deleting

D
dashed lines (shape
borders), 511
Data Form dialog box, 222,
357,689
data forms, see forms
data labels
charts, 344
graphs, 539-540
Data Labels command
(Insert menu) (Excel), 345
Data Labels command
(Insert menu) (Graph),
540
Data Labels dialog box
(Excel), 345
Data Labels dialog box
(Graph), 540
Data menu commands
Exclude Row/Column
(Graph), 533
Filter (Excel), 362
Form (Excel), 357
PivotTable (Excel), 369

PivotTable Field (Excel),
374
Series in Columns
(Graph), 527
Series in Rows (Graph),
527
Sort (Excel), 361
Subtotals (Excel), 366
data series
charts, 350
datasheets, 526-527
data types (Visual Basic for
Applications), 769-771
Database command (Word
Insert menu), 64
database files and form
letters, merging, 687
databases, see lists
Datasheet command (View
menu) (Graph), 524
datasheets (Graph), 202,
526
cells
clearing, 529
copying, 531-533
cutting, 531-533
moving, 531-533
selecting, 528-529
columns
deleting, 530
excluding from
graphs, 533-534
inserting, 5 30
selecting, 528-529
data series, 526-527
rows
deleting, 530
excluding from
graphs, 533-534
inserting, 530
selecting, 528-529
text
editing, 529
entering, 528
viewing, 524
see also worksheets
dates
files, 635
formulas, 302
worksheets
automatically filling
cells, 243

dialog boxes
entering, 235, 237
formatting, 274-275
Dayna Corporation (DOS
Mounter), 808
DDE (dynamic data
exchange), 602
Debug window (Visual
Basic for Applications),
788
calls window, 790-791
immediate pane, 789
step commands, 790
watch expressions, 789
watch pane, 789
debugging
formulas, 302-303
Visual Basic for
Applications, 78 7
break mode, 787
breakpoints, 788
Debug window,
788-790
watchpoints, 788
declarations (Visual Basic
for Applications),
768-770, 772
defaults, see customizing
Define Name dialog box,
316
Delete Columns command
(Table menu) (Word), 199
Delete command (Edit
menu), 260, 530
Delete dialog box, 261
Delete Mailer command
(File menu) (PowerTalk),
668
Delete Rows command
(Table menu) (Word), 199
Delete Sheet command
(Edit menu) (Excel), 261
Delete Slide command
(Edit menu)
(PowerPoint), 439
deleting
annotations (worksheets),
393-394
borders, 206, 617
buttons (toolbars), 737
columns
datasheets, 530

tables, 199
worksheets, 260
e-mail, 657
fields (pivot tables), 373
files, 148, 151
macros, 217
records (lists), 359
rows
datasheets, 530
tables, 199
worksheets, 260
scenarios, 389-390
slides, 439-440
subtotals (lists), 368
text, 90, 94-96
worksheet cell contents,
251
worksheets (workbooks),
261
demonstrations (Help), 51,

55
desk accessories, see by
name
desktop publishing, 103
destination documents
embedded documents,
603
linked documents, 603
dialog boxes, 34-35
3-D dialog boxes, 158
Add Clipart, 461
Add Custom AutoFormat,
348
Add Report, 335
Add Scenario, 386
Add Template, 212
Add View, 335
Add-Ins, 334
Address Mail, 65 7
Advanced Search, 69-71,
145,572
Assign Macro, 406-407
AutoContent Wizard, 434
AutoCorrect, 126
AutoFormat, 187, 289,
347-348, 537
Axes, 541
Break, 717
Cell Height and Width,
199-200
Cell Note, 392
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Change Source, 609
Chart Type, 343, 350, 534
ChartWizard, 338-341
Choose Scheme, 520
ClipArt Gallery, 460
Colors and Lines, 510,
513
Column Width, 278
Columns, 121
Convert File, 149
Convert Object, 622
Copy, 148
Create Data Source, 221,
680
Create Labels, 694
Create Names, 318
Customize (Excel), 406
Customize (Office
Manager), 733
Customize (Word), 739
Customize Grammar
Settings, 171
Customize Toolbars,
736-737
Data Form, 222, 357, 689
Data Labels (Excel), 345
Data Labels (Graph), 540
Define Name, 316
Delete, 261
Document Statistics, 141
Edit Scenario, 389
Enclosures, 661
Envelope Options, 136,
693, 695-696
Envelopes and Labels,
136
File,610
Find, 262
Find File, 70, 74-75,
147-149, 569, 575
Find in Field, 689
Font, 110, 285, 505-506
Format [Element], 545
Format Cells, 270, 273,
280,285
Format Object, 294
Function Wizard, 307
Get Info, 673
Go To, 232
Goal Seek 3 79
Goal Seek Status, 3 79
1
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dialog boxes

Grammar, 129
Gridlines (Excel), 345
Gridlines (Graph), 541
Insert, 259
Insert Object, 468
Insert Picture, 208
Insert Table, 196
Key Chain, 665, 670
Label Options, 693-694
Letter Wizard, 583
Line Spacing, 508
Links, 609
Macro (Excel), 402
Macro (Word), 213
Macro Error (Excel), 405,
788
Macro Option (Excel),
404
Mail Merge Helper, 219,
678
measurement units,
setting, 159
Merge, 683
Microsoft PowerPoint
Viewer, 558
Modify Location, 166
Modify Style, 185
New, 100, 183
New Presentation, 431
New Slide, 427, 437, 450
New Toolbar, 738
Open, 100, 469
Open Data Source, 220
Open Dictionary, 795
Open File, 589
Options, 156
Organizer, 706
Other Color, 511
Page Setup, 76, 119
Paragraph, 113
Paragraph Borders and
Shading, 721
Paste Special, 305, 591,
725
Pattern Fill, 5 14
Personal Groups, 658
Pick a Look Wizard, 435
PivotTable Field, 374
plain dialog boxes, 158
Preference, 672
Presentation Template,
436

Print, 134-137, 322, 337,
549
Print Report, 335
Query Options, 68 7, 690
Readability Statistics, 171
Record Macro (Word),
214
Record New Macro
(Excel), 403, 746
Rename Sheet, 262
Replace, 263, 264
Routing Slip, 660
Row Height, 279
Save, 246
Save As, 98, 447
Save Data Source, 221,
681
Save Format, 101
Save Search As, 144
Save Workspace, 247
Scenario Manager, 386
Scenario Summary, 390
Scenario Values, 389
Search, 69-70, 143, 572,
575
Select a Data File, 685
Send, 673
Series, 244
Shaded Fill, 513-514
Shadow, 516
Slide Color Scheme, 502,
504,518
Slide Layout, 450
Slide Setup, 547
Slide Show, 555
Solver Parameters, 382
Sort, 361
Spelling, 124-125, 266,
457
Style, 186, 271, 290-291
Style Gallery, 189
Subtotal, 366
Summary Info, 69, 140,
574
Table AutoFormat, 197
Tabs, 115
Templates and Add-ins,
212
text boxes, 38
Thesaurus, 127
Tip of the Day, 413
Titles, 346, 538

Toolbars, 736
Transitions, 553
User-Defined
AutoFormats, 348
View Manager, 335
Visual Basic for
Applications, 782-786
WordArt, 723
Zoom, 107, 442
dictionaries (ScriptEditor),
795-796
DigiSign application, 673
digital signatures
(PowerTalk), 664, 673
dimmed commands, 239
disk drives, see drives
disks, see floppy disks
displaying
bookmarks, 160
field codes, 160
fonts (TrueType fonts),
168
frames, 160
graphics, 160
nonprinting characters,
161
object anchors, 160
rulers, 161
subtotals (lists), 367
text boundaries, 160
window elements, 161
#DIV /0! error, 302
division mathematical
operator, 300
Do/Loop loops (Visual
Basic for Applications),
779-780
Document Statistics dialog
box, 141
document windows, 23-24,
591
documents
arranging on-screen, 591
breaks
column breaks, 717
page breaks, 717
section breaks,
716-718
charts
inserting, 725-726
linking, 614-617

drawing
clip art, inserting,
726-727
creating, 100-101
cross-references, 639
drawing, 721-723
e-mail, 158
editing in print preview,
133-134
embedding, 602-604,
625-628, 638-640
destination
documents, 603
editing objects, 628
files, inserting, 609-610
footers, 718-720
frames, inserting,
209-210
grammar check, 129-131
graphics, 720
borders, 720-721
inserting, 207-208
lines, 720-721
positioning, 727-730
pull quotes, 728-730
word wrap, 723
headers, 718-720
linking, 602, 605-607,
609-610, 638-640
automatically
updating links, 158
destination
documents, 603
displaying links, 607
editing links, 608-609
source documents,
603,607
troubleshooting, 608
Mail messages, attaching,
661
movement keys, 42-43
naming, 98-99
note pad text, inserting,
587-588
objects, 39-40
opening, 100,589-590
outlines, 176
collapsing, 180-181
creating, 176-180
editing, 180-183
expanding, 180-181
formatting, 177

printing, 182
troubleshooting, 182
page numbers, 718-720
pictures
importing, 596-598
inserting, 207-208
previewing, 131-134
printing, 76, 134-135,
163-164
print preview, 77-79
reverse print order,
163
troubleshooting, 135
Publish & Subscribe,
638-644
editing, 65 1
naming, 645-646
publishing, 644-646
sending, 646-64 7
setting publisher
options, 646-64 7
setting subscriber
options, 649-651
subscribing, 64 7-648
receiving, 658-659
revision marks, 164-165
routing, 660-661
saving, 98-100, 167-168
scroll bars, 42
sections, 716
sending, 658-659
slides, linking, 620-622
Spelling Checker, 124
AutoCorrect, 124, 126
troubleshooting, 127
switching between
documents, 79-81, 590
tables, inserting, 196-197,
725-726
templates, 101
text
converting case, 97
copying, 96
copying between
documents, 589-593
cutting, 95-96
deleting, 94-96
drag-and-drop editing,
96,98
moving, 95-96
pasting, 96
selecting, 92-94
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typing, 90, 90-94
WordArt text, 723-725
text area, 89
title bars, 88
views, 104
hiding screen
elements, 106
landscape view, 108
magnifying, 106-108
Normal view, 104-105
Page Layout view,
105-112
troubleshooting, 108
work area, 82
worksheets
importing, 593-596
linking, 595, 611-614
see also files
DOS Mounter (Dayna
Corporation), 808
drag-and-drop editing,
44-46,96,98,162,635
Clippings files, 635
copying text between
documents, 592
Draw menu commands
(Power Point)
Align, 479
Bring Forward, 484
Bring to Front, 484
Change AutoShape, 493
Group, 474
Rotate/Flip, 482
Scale, 478
Send Backward, 484
Send to Back, 484
Snap to Grid, 481
Ungroup, 476
drawing
arcs, 494-496
in documents, 721-723
in worksheets, 291
lines, 494-496
shapes, 489-490
AutoShapes, 490-491
freeform shapes,
496-498
from center outward,
492
perfect shapes,
491-492

844

Drawing toolbar

Drawing toolbars, 28-30,
294, 487-488
Drawing+ toolbar, 512-513
drives (disk drives)
files, 566-567
closing, 57 4
copying, 5 70
finding, 569-5 70,
572-573
listing, 5 71-5 72
moving, 570
opening, 574, 577
organizing, 568
troubleshooting, 574
folders, 66
selecting, 65
Duplicate command (File
menu) (PowerTalk), 667
dynamic data exchange
(DOE), 602

E
e-mail
AppleMail (PowerTalk),
664,675
Mail, 17, 653-654
mailing lists, 658
addressing, 655-656
attaching documents,
158,661
creating, 655-656
deleting, 657
forwarding, 65 7
printing, 657
reading, 656-65 7
replying, 656
storing, 65 7
see also correspondence
(PowerTalk); Mail
Edit menu commands
Can't Undo, 245
Clear, 95, 529
Clear All (Excel), 252
Clear Contents (Excel),
252
Clear Formats (Excel),
252
Clear Notes (Excel), 252
Copy,253,477,532
Cut, 95, 476, 531

Delete, 260, 530
Delete Sheet (Excel), 261
Delete Slide (PowerPoint),
439
Edit Publishing Publisher
Options, 646
Fill Series, 244-245
Find, 262, 5 77
Go To, 232
Links (Word), 609
Open Publisher, 644
Paste, 96, 253, 476, 532
Paste Special, 305, 591,
725
Publishing, 645
Redo,94,246
Repeat, 111, 246
Replace, 264
Select All (Power Point),
473
Subscribe to from
Publishing, 648
Undo, 94, 245-246
Edit Scenario dialog box,
389
editing, 35-40
charts, 349-350
color schemes (slides),
518
datasheets, 529
documents in print
preview, 133-134
drag-and-drop editing,
162,635
Edition files (Publish &
Subscribe), 647, 651
embedded objects, 628
frames, 598
freeform shapes, 498-499
functions, 310
graphs, 546
key chains (PowerTalk),
669
lists, 356-35 7
OLE (Object Linking and
Embedding) in-place
editing, 603
outlines, 180-183
pivot tables, 371
presentation templates,
504
reports (worksheets), 337

scenarios, 389-390
scripts, 798
slide text, 456-457
styles, 184-186
summary information
(files), 148
user info, 165
worksheets, 249-251
Edition files (Publish &
Subscribe)
creating, 645-646
editing, 647, 651
naming, 645
subscribing, 647-648
electronic mail, see e-mail
electronic signatures
(PowerTalk), 664, 673
ellipsis (... )menu
commands, 31
embedding
charts, 204-205, 338-341
documents, 602-604,
625-628, 638-640
destination
documents, 603
editing objects, 628
presentations in Mail,
712
embossed effect (slide
text), 506
enclosures (Mail), 661
Enclosures dialog box
(Mail), 661
Envelope Options dialog
box, 136,693,695-696
envelopes
creating, 219-224, 586
Mail Merge
addressing, 695-696
creating, 692-696
printing, 136-137
Envelopes and Labels
command (Tools menu)
(Word), 136
Envelopes and Labels
dialog box, 136
equal sign (=)
comparative operator,
301
comparison operator
(Visual Basic for
Applications), 773
formulas, 236

files

Equation, 626
Eqv logical operator
(Visual Basic for
Applications), 774
errors
beeps, 158
formulas
calculation errors, 300
debugging, 302-303
Visual Basic for
Applications, 78 7
event procedures (Visual
Basic for Applications),
762-770
examples (Help), 51, 55
Exclude Row /Column
command (Data menu)
(Graph), 533
exiting applications, 21-22
see also closing
exponentiation
mathematical operator,
300
exporting
pictures to documents,
596-598
worksheets to
documents, 593-596
see also transferring files

F
Farallon (PhoneNET PC),
809
Fax Cover Sheet template
wizard, 190
Fax Wizard, 57
field codes
displaying, 160
hiding, 160
updating before printing,
163
fields
pivot tables
deleting, 373
inserting, 3 73
shading, 161
FigureTax Macro, 748-7 49
File command (Word
Insert menu), 64, 610

File dialog box (Word), 610
file exchange utilities
Access PC, 808
Apple File Exchange,
807-809
DOS Mounter (Dayna
Corporation), 808
Macintosh PC Exchange,
808
file formats, 632
Clipboard, 633-635
correspondence
(PowerTalk), 668
MooV, 634
PICT, 633
RTF (Rich-Text Format),
634
snd,634
styl, 634
TEXT, 633
file information, 149-150
File menu commands
Add Mailer (PowerTalk),
665
Add Routing Slip (Word),
660
AppleScript Formatting
(ScriptEditor), 799
Close,62, 183,488
Create (PowerPoint), 468
Create New (PowerPoint),
468
Delete Mailer
(PowerTalk), 668
Duplicate (PowerTalk),
667
Find File, 70, 575
Find (Finder), 569
Get Info (PowerTalk), 673
Mail (Excel), 660
Mail (PowerPoint), 660
Mail (PowerTalk), 668
New, 62, 100, 183
New Folder (Finder), 567
Open, 62, 100, 566
Open Dictionary
(ScriptEditor), 795
Page Setup, 76, 120, 323,
325
Print, 76, 322, 549
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Print Preview, 77, 330
Print Report (Excel), 334
Quit, 21, 414
Save,62,99,246,447
Save All (Word), 100
Save As, 98, 44 7
Save Workspace, 247
Send (PowerTalk), 668
Slide Setup (PowerPoint),
547
Summary Info, 69, 574
Templates (Word), 212
file server information
cards (PowerTalk
catalogs), 671
filenames, 63-65, 98-99
files, 61-62, 566-567
Clippings files, 635
closing, 62-63, 149, 574
copying, 148, 151, 570
dates, 635
deleting, 148, 151
displaying names in
menus, 158
documents, inserting,
609-610
Edition files (Publish &
Subscribe)
creating, 645-646
editing, 647, 651
naming, 645
sending, 646-64 7
subscribing, 64 7-648
file information, 149-150
finding, 65, 69-75,
569-573
by author, 72
by creation date, 73
by last saved date, 73
by name, 72
keyword searches, 72
search criteria, 71-75,
142-147
listing, 571-572
moving, 166, 5 70
naming, 63-65
opening, 62-63, 68, 149,
574, 577
previewing, 149
printing, 148, 151
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files

protecting, 168
saving, 62-63
backups, 68
in other formats,
67-68, 101
Scrapbook files, 63 7
selecting, 152
slides, importing,
468-470
sorting, 148, 151-152
summary information,
69, 140, 574-577
displaying, 140
editing, 141, 148
finding, 150-151
printing, 142
statistics, 141-142
troubleshooting, 142
text, finding, 577-578
times, 635
transferring between
platforms (Mac to
Windows), 805-806
floppy disks, 806-809
font conversion,
811-812
modems, 809
networks, 809
translating between
platforms (Mac to
Windows), 809-811
see also documents;
worksheets
Fill Series command (Edit
menu) (Excel), 244-245
fills (shapes)
colors, 490, 510-513
patterns, 513-515
shading, 513-515
Filter command (Data
menu) (Excel), 362
filtering lists, 362-364
Find command (Edit
menu), 262, 569, 577
Find dialog box, 262
Find File command (File
menu), 70, 575
Find File dialog box, 70,
74-75, 147-149, 569, 575
Find File program,
142-147, 151-152
Find in Field dialog box,
689

Finder, 565-574
finding
cells (worksheets),
262-263
errors (formulas), 303
files, 65, 69-75, 569-573
by author, 72
by creation date, 73
by last saved date, 73
by name, 72
by summary
information, 150-151
drives, 569-5 70,
572-573
keyword searches, 72
search criteria, 71-75,
142-147
Mail Merge form letters,
688-691
objects (Visual Basic for
Applications), 758-759
records (lists), 359-360
text in files, 577-578
flipping slide objects,
481-483
floppy disks, transferring
files, 806
Apple File Exchange,
807-808
commercial file exchange
utilities, 808-809
folders, 66
creating, 567
Mail, 657
naming, 567
opening, 66
subfolders, 66
Font command (Format
menu) (PowerPoint),
505-506
Font command (Format
menu) (Word), 110
Font dialog box, 110, 285,
505-506
fonts
font conversion (file
transfers), 811-812
graphs, 543-545
point sizes, 109
slides, 505-507
spacing (fractional
widths), 163

styles, 109-110
text, 108-109
TrueType fonts, 168
worksheets, 285-286
footers
documents, 718-720
worksheets, 328
creating, 329-330
deleting, 329
predefined footers,
328-329
For Each loops (Visual
Basic for Applications),
780
For/Next loops (Visual
Basic for Applications),
778-779
forecasting (worksheet
calculations), 378-380
foreign currency symbols,
276
foreign languages (Spelling
Checker), 170
Form command (Data
menu) (Excel), 357
form letters
creating, 219-224,
582-587, 677
Mail Merge, 679-680
finding, 688-691
merging with database
files, 687
merging with name
and address data
files, 680-685
merging with
worksheets, 685-687
printing, 685, 688-691
sorting, 68 7-688
Format [Element]
dialog box, 545
Format Cells dialog box,
270,273,280,285
Format menu commands
Alignment (PowerPoint),
508
Apply Style (PowerPoint),
517
AutoFormat (Excel), 289,
347
AutoFormat (Word), 172,
186

formulas
Borders and Shading
(Word), 721
Cells (Excel), 237, 270,
273,285
Change Case (Word), 97
Chart Type (Excel), 343,
350
Chart Type (Graph), 534
Colors and Lines
(PowerPoint), 510, 513
Column AutoFit (Excel),
278
Columns (Word), 122,
714
Font (PowerPoint),
505-506
Font (Word), 110
Frame (Word), 599
Line Spacing
(PowerPoint), 508
Object (Excel), 294
Paragraph (Word), 113
Pick Up Style
(PowerPoint), 517
Placement (Excel), 294
Presentation Template
(PowerPoint), 435, 503
Rows (Excel), 279
Selected [Element]
(Graph), 545
Shadow (PowerPoint),
516
Slide Color Scheme
(PowerPoint), 502-504,
518
Style (Excel), 271, 290
Style (Word), 184
Tabs (Word), 115
Format Object dialog box,
294
Format Painter, 110
formats (files), see file
formats
formatting, 4 7-48
AutoFormats, 49-50,
172-173, 186-190
accepting changes,
187-188
rejecting changes,
187-188
reviewing changes,
187-188

Style Gallery, 188-189
troubleshooting, 190
charts
AutoFormats, 347-349
custom formats,
348-349
Clipboard, 158, 633-635
keyboard shortcuts, 46-4 7
outlines, 177
page numbers, 719
pages, 119
columns, 121-122
margins, 120-121
orientation, 119-120
sizes, 119-120
troubleshooting, 122
paragraphs, 112
alignment, 118-119
spacing, 112-115
troubleshooting,
118-119
pivot tables, 3 7 4
AutoFormats, 375
numeric format,
374-375
scripts, 799-800
shapes, 517
slide text, 505-507
styles, 182-183
applying, 183
creating, 184
editing, 184-186
naming, 184
template wizards,
192-193
text, 108
copying, 110-111
copying to Clipboard,
158
fonts, 108-109
point size, 109
styles, 109-110
tables, 198
troubleshooting, 111
worksheets
AutoFormats, 288-289
borders, 28 7
cells, 255
characters, 286-28 7
colors, 287-289
dates, 274-275
graphics, 294
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numbers, 269-276
patterns, 287-288
times, 274-275
Formatting toolbars, 27,
46-47, 89, 178, 271, 507,
509
forms
records
deleting, 359
finding, 359-360
inserting, 35 7-358
viewing, 358
text boxes, 38
Forms toolbar, 783-784
formulas
cell references, 299,
313-314
range names, 315-320
to another workbook,
314
comparative operators,
301
concatenation operators,
301
converting to values,
304-305
copying, 312-313
creating, 297-299
dates, 302
errors
calculation errors, 300
debugging, 302-303
functions, 306
AutoSum button, 307
editing, 310
entering, 306-307
Function Wizard,
307-309
Help, 310-311
troubleshooting, 311
Help, 303
linking, 313-314
mathematical operators,
300-302
reference operators, 302
times, 302
troubleshooting, 236, 305
Visual Basic for
Applications logical
formulas, 773-774
worksheets, entering,
235-236
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forwarding

forwarding
correspondence
(PowerTalk), 668
e-mail, 657
Frame command (Format
menu) (Word), 599
Frame command (Insert
menu) (Word), 210, 728
frames, 209-210
borders, 209
displaying, 160
editing, 598
hiding, 160
inserting, 209-210
moving, 209
pictures, 598-599
text, 728
freeform shapes
drawing, 496-498
editing, 498-499
Function command (Insert
menu) (Excel), 307
Function Wizard, 307-309
Function Wizard dialog
box,307
functions, 306
AutoSum button, 307
editing, 310
entering in formulas,
306-307
Function Wizard,
307-309
Help, 310-311
summary functions
(pivot tables), 376
troubleshooting, 311
Visual Basic for
Applications, 761-762

G
Get Info command (File
menu) (PowerTalk), 673
Get Info dialog box, 673
global templates, 212
Go To command (Edit
menu), 232
Go To dialog box, 232
Goal Seek command (Tools
menu) (Excel), 379
Goal Seek dialog box, 379

Goal Seek Status dialog
box,379
Goal Seeker, 378-380
grammar check, 129-131
customizing, 170-172
readability, 171
troubleshooting, 131
Grammar command (Tools
menu) (Word), 129
Grammar dialog box, 129
Graph,201,626
datasheets, 202, 526
clearing cells, 529
copying cells, 531-533
cutting cells, 531-533
data series, 526-527
deleting columns, 530
deleting rows, 530
editing text, 529
entering text, 528
excluding columns
from graphs, 533-534
excluding rows from
graphs, 533-534
inserting columns, 530
inserting rows, 530
moving cells, 531-533
selecting cells, 528-529
selecting columns,
528-529
selecting rows,
528-529
viewing, 524
graphs
AutoFormats, 536-537
axes, 540-541
borders, 543-545
colors, 543-545
data labels, 539-540
editing, 546
elements, 537-538
embedding, 204-205
fonts, 543-545
gridlines, 541-542
legends, 539
patterns, 543-545
slides, inserting, 428,
465, 521-524, 546
titles, 538-539
types, 203-204,
534-536
worksheets, inserting,
205

menus, 525-526
starting, 202-203,
521-524
toolbars, 525-526
troubleshooting, 524
see also charts (Excel
charts)
graphics, 205
borders, 206-210
deleting, 206
patterns, 207
shading, 207
displaying, 160
documents, 720
borders, 720-721
lines, 720-721
positioning, 727-730
pull quotes, 728-730
word wrap, 723
frames, 209-210, 598-599
hiding, 160
inserting, 207-208
moving, 598
Postscript graphics,
printing over text, 164
selecting, 598
sizing, 598
word wrap, 598
worksheets
formatting, 294
grouping, 294-295
moving, 292
selecting, 292
sizing, 292-293
ungrouping, 295
see also clip art; pictures;
shapes
graphs
2-D graphs, 534
3-D graphs, 534
AutoFormats, 536-53 7
axes, 540-541
borders, 543-545
colors, 543-545
data labels, 539-540
datasheets, 526
data series, 526-527
entering text, 528
non-plotting data,
533-534
viewing, 524
editing, 546

Insert menu commands
elements, 537-538
embedding, 204-205
fonts, 543-545
gridlines, 541-542
legends, 539
patterns, 543-545
slides, inserting, 428, 465,
521-524, 546
titles, 538-539
types, 203-204, 534-536
worksheets, inserting,
205
see also charts (Excel
charts)
grayed out commands, 239
greater than or equal to
(>=)

comparative operator,
301
comparison operator
(Visual Basic for
Applications), 773
greater than sign (>)
comparative operator,
301
comparison operator
(Visual Basic for
Applications), 773
gridlines
charts, 345
graphs, 541-542
slides, 481-483
tables, 197
worksheets, 327
Gridlines command (Insert
menu) (Excel), 345
Gridlines command (Insert
menu) (Graph), 541
Gridlines command (Table
menu) (Word), 197
Gridlines dialog box, 345,
541
Group command (Draw
menu) (Power Point), 474
group information cards
(PowerTalk catalogs), 671
grouping graphics,
294-295
guides, 419-420
Guides command (View
menu) (PowerPoint), 420

H
handouts (presentations),
421
masters, 423
orientation, 548-549
printing, 550-SS 1
hard disk drives, see drives
hard disk space
requirements (Microsoft
Office), 818
Header and Footer
command (View menu)
(Word), 718
headers
correspondence
(PowerTalk), 668
documents, 718-720
worksheets, 328
creating, 329-330
deleting, 329
predefined headers,
328-329
Help
Cue Cards, 51, 56
demonstrations, S1, 55
examples, 51, 55
Find File program, 149
formulas, 303
functions, 310-311
How to windows, 51, 56
macros (Excel), 404
Mail Merge, 219
on-line Help, S0-54
pointers, SO
Quick Preview, 51, 54-SS
tables, 197
Tip of the Day, 51, 54
wizards, 51, 56-59
WordBasic, 218
see also troubleshooting
hiding
bookmarks, 160
field codes, 160
frames, 160
graphics, 160
nonprinting characters,
161
object anchors, 160
paragraph marks, 90
rulers, 161
screen elements, 106
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subtotals (lists), 367
text boundaries, 160
window elements, 161
highlighting, see selecting
horizontal alignment
(worksheet cell contents),
283
How to windows (Help),
51,56

I
I-Beam mouse pointer,
35-37
illustrations, see clip art;
graphics; pictures; shapes
Imp logical operator
(Visual Basic for
Applications), 774 .
importing, see inserting;
transferring files
in-place editing (OLE), 603
indents, 116-117
information cards
(PowerTalk catalogs), 666
copying to network, 66 7
creating, 666
file server information
cards, 671
group information cards,
671
user information cards,
671
Insert Columns command
(Table menu) (Word), 199
Insert dialog box, 259
Insert menu commands
AutoFormat (Graph), 537
Axes (Graph), 541
Break (Word), 717
Cells (Excel), 259
Cells (Graph), 530
Chart (Excel), 341
Clip Art (PowerPoint), 65,
460
Columns (Excel), 259
Data Labels (Excel), 345
Data Labels (Graph), 540
Database (Word), 64
File (Word), 64, 610
Frame (Word), 210, 728
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Insert menu commands

Function (Excel), 307
Gridlines (Excel), 345
Gridlines (Graph), 541
Macro Dialog (Excel), 782
Microsoft Graph
(PowerPoint), 65, 524
Microsoft Word Table
(PowerPoint), 65
Name (Excel), 316
New Data (Excel), 350
New Slide (PowerPoint),
439
Note (Excel), 392
Object (Excel), 64
Object (PowerPoint), 465
Object (Word), 64, 202
Page Break (Excel), 324
Page Numbers (Word),
719
Picture (Excel), 64
Picture (PowerPoint), 64
Picture (Word), 64, 726
Remove Page Break
(Excel), 324
Rows (Excel), 259
Titles (Excel), 346
Titles (Graph), 539
Worksheet (Excel), 261
Insert Object dialog box,
468
Insert Picture dialog box,
208
Insert Rows command
(Table menu) (Word), 199
Insert Table command
(Table menu) (Word), 196
Insert Table dialog box,
196
inserting
annotations (worksheets),
392-393
buttons (toolbars), 737
cells (worksheets),
259-260
charts (documents),
725-726
clip art (documents),
726-727
columns
datasheets, 530
tables, 199, 201
worksheets, 259

fields (pivot tables), 373
files
documents, 609-610
slides, 468-4 70
frames, 209-210
graphics, 207-208
graphs (slides), 546
note pad text
(documents), 587-588
objects (slides), 428
pictures (documents),
207-208, 596-598
records (lists), 357-358
rows
datasheets, 530
tables, 199, 201
worksheets, 259
slides, 439-440
tables, 196-197, 725-726
worksheets
documents, 593-596
Graph, 205
workbooks, 261
insertion point, 35-37
moving, 91-92
table cells, 198
worksheet cells, 250
installation
add-ins
Report Manager, 334
Solver, 381
View Manager, 334
Microsoft Office, 21,
819-822
conflicts, 665
network installation,
821-822
upgrades, 822-823
PowerShare, 674
PowerTalk, 664
Instant Watch command
(Tools menu) (Excel), 787
interfaces, 13
international currency
symbols, 276
intersection operator, 302
italicizing text, 110

J-K
joining text strings
(worksheets), 301
Key Chain dialog box,
665,670
key chains (PowerTalk),
664
editing, 669
locking, 669
services, 669-670
setting, 665
keyboard shortcuts, 31
formatting, 46-4 7
macros (Excel), assigning,
403
keys
macros (Word),
assigning, 214-215
movement keys, 42-43
keywords
scripts, 800
Visual Basic for
Applications, 749

L
Label Options dialog box,
693-694
labels
mailing labels
Avery mailing labels,
693
creating, 219-224, 586
Mail Merge, 692-694
slides objects, 456
landscape orientation, 108,
120, 548
language keywords
(scripts), 800
layout
pages, 119
margins, 120-121
orientation, 119-120
sizes, 119-120
troubleshooting, 122
views, lOS
hiding screen
elements, 106

Macro command

landscape view, 108
magnifying, 106-108
troubleshooting, 108
leaders (tabs), 115
leading (paragraphs),
112-114
legal pleading papers, 190
legends
charts, 352
graphs, 539
less than or equal to(<=)
comparative operator,
301
comparison operator
(Visual Basic for
Applications), 773
less than sign(<)
comparative operator,
301
comparison operator
(Visual Basic for
Applications), 773
Letter Wizard, 57, 190,
582-587
prewritten letters, 583
styles, 588-589
Letter Wizard dialog
boxes, 583
letters
form letters
creating, 219-224,
582-587, 677
Mail Merge, 679-691
prewritten letters, 583
limit reports (Solver), 384
line spacing
paragraphs, 112-114
slide text, 507-508
Line Spacing command
(Format menu)
(PowerPoint), 508
Line Spacing dialog box,
508
line styles (borders), 206
lines
arrowheads, 511
documents, 720-721
drawing, 494-496
see also borders

linking
charts to documents,
614-617
documents to
documents, 602,
605-610, 638-640
automatically
updating links, 158
destination
documents, 603
displaying links, 607
editing links, 608-609
slides, 620-622
source documents,
603,607
troubleshooting, 608
formulas, 313-314
slides to worksheets,
708-710
worksheets
to documents, 595,
611-614
to worksheets, 622-624
Links command (Edit
menu) (Word), 609
Links dialog box, 609
listing
files (drives), 571-572
names and addresses
(Mail Merge), 696-697
listings
3 7.1 The Receipt Maker
Program, 765-770
FigureTax Macro,
748-749
lists, 355
bulleted lists (slides), 453
creating, 356-35 7
editing, 356-357
forms, 357
pivot tables, 368
calculations, 376-377
creating, 368-370
editing, 371
fields, 373
formatting, 3 74-3 78
rearranging data,
371-373
updating, 371,
377-378

851

records
deleting, 359
filtering, 362-364
finding, 359-360
inserting, 35 7-358
sorting, 361
viewing, 358
subtotals, 366
deleting, 368
displaying, 367
hiding, 367
troubleshooting, 360
Lock Key Chain command
(Special menu)
(PowerTalk), 669
locking key chains
(PowerTalk), 669
logical errors (Visual Basic
for Applications), 787
logical formulas (Visual
Basic for Applications),
773-774
logical operators (Visual
Basic for Applications),
774
loops (Visual Basic for
Applications)
Do/Loop loops, 779-780
For Each loops, 780
For/Next loops, 778-779

M
Macintosh PC Exchange,
808
Macintoshes
transferring files to
Windows, 805,806
floppy disks, 806-809
font conversion,
811-812
modems, 809
networks, 809
translating files to
Windows, 809-811
MacLinkPlus/PC, 809
Macro command (Tools
menu) (Excel), 402
Macro command (Tools
menu) (Word), 213
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Macro dialog box

Macro dialog box (Word),
213
Macro dialog box (Excel),
402
Macro Dialog command
(Insert menu) (Excel), 782
Macro Error dialog box
(Excel), 405, 788
Macro Options dialog box
(Excel), 404
Macro Organizer
command (Tools menu)
(Word), 219
Macro Recorder, 398
starting, 397-398
Visual Basic for
Applications
procedures, 745-752
Macro Recording toolbar,
216
macros
Excel macros, 395
FigureTax Macro,
748-749
Help, 404
inserting on menus,
403
keyboard shortcuts,
assigning, 403
Microsoft Excel
Version 4.0
programming
language, 404
naming, 397
pausing, 402
Personal Macro
Workbook, 403,
407-408
Presentlt macro,
705-707
recording, 396-401
running, 402
sheet buttons,
assigning, 406
status bar text, 404
stopping, 402
toolbar buttons,
assigning, 406-407
troubleshooting,
401,405

Visual Basic for
Application, 396, 404
workbooks, storing,
403
Word macros, 211-212
creating, 214-217
deleting, 217
keys, assigning,
214-215
naming, 214
predefined macros,
212-213
recording, 214, 216
running, 213, 217
saving, 218
troubleshooting,
218-219
writing, 217-219
magnifying views, 106-108
Mail, 653-654
compatibility with
PowerTalk, 665
documents
receiving, 658-659
routing, 660-661
sending, 658-659
folders
creating, 65 7
Mailbox folder, 654
naming, 657
Outbox folder, 654
mailing lists, creating,
658
messages
addressing, 655-656
attaching documents,
661
creating, 655-656
deleting, 65 7
forwarding, 65 7
printing, 657
reading, 656-65 7
replying, 656
storing, 65 7
networks, 653
presentations,
embedding, 712
servers, 665
starting, 654
Mail and Catalogs
command (Apple menu)
(PowerTalk), 670

Mail command (File
menu) (Excel), 660
Mail command (File
menu) (PowerPoint), 660
Mail command (File
menu) (PowerTalk), 668
Mail menu commands
New Folder, 65 7
Personal Groups, 658
Mail Merge, 211, 219
data source
creating, 221-222
editing, 224
listing, 696-697
opening, 220-221
selecting, 220
document source,
679-680
creating, 222-223
finding, 688-691
merging with database
files, 687
printing, 688-691
selecting, 219-220
sorting, 68 7-688
viewing merge fields,
223
envelopes
addressing, 695-696
creating, 692-696
Mail Merge Helper, 219
mailing labels, 692-694
merging
document source and
data source, 224,
680-685
document source and
worksheets, 685-687
printing, 685
Mail Merge command
(Tools menu) (Word), 678
Mail Merge Helper, 219,
678-679
Mail Merge Helper dialog
box,219,678
Mailbox (PowerTalk), 664,
671-673
Mailbox folder (Mail), 654
mailing labels
Avery mailing labels, 693
creating, 219-224, 586
Mail Merge, 692-694

New Personal Catalog command
mailing lists (Mail), 17,
658
Mainstay (ClickPaste), 637
margins
documents, 120-121
worksheets, 325-326,
331-332
mass mailings, see Mail
Merge
masters (presentations)
Handouts Master, 423
Notes Master, 423
Outline Master, 423
Slide Master, 423
viewing, 424
mathematical operators,
300-302
maximizing windows, 81
measurement units,
setting, 159
Memo Wizard, 58, 190
menu bars, 23, 88
menus, 30-34
arrows, 31
bullets, 32
check marks, 32
displaying filenames in
menus, 158
ellipsis (... ) in
commands, 31
Graph, 525-526
keyboard shortcuts, 31
macros (Excel), inserting,
403
Office Manager, 734-735
PowerPoint, 415-417
shortcut menus, 33-34
troubleshooting, 741
Word
creating, 740-741
condensing, 158
customizing, 739-7 40
see also by names
Merge dialog box, 683
Merge toolbar, 222-224
merging, see Mail Merge,
merging
methods (Visual Basic for
Applications), 757-758
Microsoft ClipArt Gallery,
see ClipArt Gallery

Microsoft Equation,
see Equation
Microsoft Graph command
(Insert menu)
(PowerPoint), 65, 524
Microsoft Graph,
see Graph
Microsoft Mail, see Mail
Microsoft Office
hard disk space
requirements, 818
installation, 21, 819-822
conflicts, 665
network installation,
821-822
upgrades, 822-823
interfaces, 13
starting, 21
system requirements,
817-818
Microsoft Office Manager,

see
Microsoft Organization
Chart, see Organization
Chart
Microsoft PowerPoint
Viewer dialog box, 558
Microsoft Word Table
command (Insert menu)
(PowerPoint), 65
Microsoft WordArt, see
WordArt
minus sign(-)
mathematical operator,
300
modems, transferring files,
809
Modify Location dialog
box, 166
Modify Style dialog box,
185
MooV file format, 634
mouse pointers, 35-37
movement keys, 42-43
moves, see scripts
movies (QuickTime
movies), transferring
frames, 635
moving,44
cells
datasheets, 531-533
worksheets, 257-259
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charts, 343
files, 166, 570
frames, 209
graphics, 292
insertion point, 91-92
pictures, 598
slide objects, 4 76
text, 95-96
worksheets (workbooks),
261-262
multiplication
mathematical operator,
300
music template
(presentations), 502-503

N
#N/A error, 302
#NAME? error, 302
Name command (Insert
menu) (Excel), 316
naming
backup files, 68
documents, 98-99
files, 63-65
folders, 567, 657
macros, 214
macros (Excel), 397
styles, 184
worksheets, 262
NetWare for Macintosh
(Novell), 809
network installation
Microsoft Office, 821-822
PowerShare, 674
networks
Mail servers, 653, 665
PowerTalk servers, 664
transferring files, 809
New command (File
menu), 62, 100, 183
New Data command
(Insert menu) (Excel), 350
New dialog box, 100, 183
New Folder command (File
menu) (Finder), 567
New Folder command
(Mail menu), 657
New Personal Catalog
command (Catalogs
menu) (PowerTalk ), 670
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New Presentation dialog box

New Presentation
dialog box, 431
New Slide command
(Insert menu)
(PowerPoint), 439
New Slide dialog box,
427,437,450
New Toolbar dialog box,
738
Newsletter Wizard, 58, 190
newsletters, 713
borders, 720-721
charts, 725-726
column breaks, 71 7
columns, 713-716
adjusting widths, 716
viewing, 715
creating, 17
drawing, 721-723
footers, 718-720
graphics, 720, 727-730
headers, 718-720
lines, 720-721
page breaks, 717
page numbers, 718-720
pull quotes, 728-730
section breaks, 716, 718
sections, 716
tables, 725-726
word wrap, 723
WordArt text, 723-725
nonprinting characters,
161
Normal command (View
menu) (Word), 105
not equal to sign (< >)
comparative operator,
301
comparison operator
(Visual Basic for
Applications), 773
Not logical operator
(Visual Basic for
Applications), 774
Note command (Insert
menu) (Excel), 392
note pad, 577-578, 587-588
Note Pad command (Apple
menu), 577

notes
presentations, 421
orientation, 548-549
printing, 549-550
viewing, 421
slides, 559
worksheets
deleting, 393-394
inserting, 392-393
printing, 327
viewing, 393
Notes Pages view
(presentations), 440
Notes view (presentations),
445
Novell (NetWare for
Macintosh), 809
#NULL! error, 302
#NUM! error, 302
numbering pages
(documents), 718-720
numbers
pivot tables, formatting,
374-375
worksheets
automatically filling
cells, 242
entering, 234-235
formatting, 269-276
styles, 271-273

0
object anchors, 160
Object Browser (Visual
Basic for Applications),
758-759
Object command (Format
menu) (Excel), 294
Object command (Insert
menu) (Excel), 64
Object command (Insert
menu) (PowerPoint), 465
Object command (Insert
menu) (Word), 64, 202
objects (Visual Basic for
Applications), 744-745,
752-753
finding, 758-759

Office Manager, 13-14,
20-21
customizing, 733
menus, 734-735
QuickSwitch, 735
Office Manager menu
commands (Customize),
733
Office, see Microsoft Office
OLE (Object Linking and
Embedding), 15
in-place editing, 603
Visual Basic for
Applications, 743
see also embedding;
linking
on-line Help, S0-54, 745
Open command (File
menu), 62, 100, 566
Open Data Source dialog
box,220
Open dialog box, 100, 469
Open Dictionary
command (File menu)
(ScriptEditor), 795
Open Dictionary dialog
box, 795
Open File dialog box, 589
Open Publisher command
(Edit menu), 644
opening
documents, 100, 589-590
files, 62-63, 149, 574, 577
in other applications,
68
folders, 66
presentations, 448
workspace files, 248
operators
comparative operators,
301
comparison operators
(Visual Basic for
Applications), 773
concatenation operator,
301
logical operators (Visual
Basic for Applications),
774

pausing macros
mathematical operators,
300-302
reference operators, 302
scripts, 799
Options command (Tools
menu) (Word), 156
Options dialog box, 156
Or logical operator (Visual
Basic for Applications),
774
order of precedence
(mathematical
operators), 300
Organizational Chart, 40,
626
inserting in slides,
465-466
Organizer dialog box, 706
organizing drives, 568
orientation
pages, 119-120
slides, 54 7-549
worksheets, 325
Other Color dialog box,
511
Outbox folder (Mail), 654
Outline toolbar, 176, 180
Outline view
(presentations), 440-443
outlines, 176
collapsing, 176, 180-181
creating, 176-178
editing, 180-183
expanding, 176, 180-181
formatting, 177
headings
demoting, 176, 180
demoting to body text,
176, 180
moving, 176, 181
promoting, 176, 180
notes
masters, 423
presentations, 421
creating from Word
outlines, 699-702
masters, 423
orientation, 548-549
printing, 552
viewing, 421
printing, 182

slides, inserting, 702,
705-707
text
entering, 178
moving, 181
selecting, 179-180
troubleshooting, 182
Outlining toolbar
(PowerPoint), 552
overheads, 425
overtype mode (typing),
162

p
Page Break command
(Insert menu) (Excel), 324
page breaks
documents, 717
worksheets, 323
deleting, 324
horizontal page
breaks, 324
troubleshooting, 333
vertical page breaks,
323-324
Page Layout command
(View menu) (Word),
105, 715
page numbers, 718-720
Page Numbers command
(Insert menu) (Word),
719
Page Setup command (File
menu), 76, 120, 323-325
Page Setup dialog box,
76, 119
pages (documents), 119
AutoFormats, 186-190
breaks, 717
background
repagination, 157
columns, 121-122
margins, 120-121
numbering, 718-720
orientation, 119-120
sizes, 119-120
troubleshooting, 122
Paragraph Borders and
Shading dialog box, 721
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Paragraph command
(Format menu) (Word),
113
Paragraph dialog box, 113
paragraphs
borders, 721
formatting, 112
alignment, 118-119
AutoFormats, 186-190
spacing, 112-115
troubleshooting,
118-119
indents, 116-117
paragraph marks, 90
slide text, spacing,
507-508
tabs, 115-116
see also text
passwords
files, assigning, 168
PowerTalk, 664
case-sensitivity, 665
editing, 669
locking, 669
setting, 665
Paste command, 96, 253,
476,532
Paste Special command
(Edit menu), 305, 591,
725
Paste Special dialog box,
305, 591, 725
pasting, 44
data between
applications, 96
dates (files), 635
sounds, 635
text, 96
time (files), 635
see also transferring files
Pattern Fill dialog box, 514
patterns
borders, 207
graphs, 543-545
shapes
borders, 513-515
fills, 513-515
worksheets
cells, 287-288
graphics, 294
pausing macros (Excel),
402
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percentage sign(%)

percentage sign(%)
mathematical operator,
300
Personal Catalogs
(PowerTalk), 670-671
personal groups (Mail),
658
Personal Groups command
(Mail menu), 658
Personal Groups dialog
box,658
Personal Macro Workbook
(Excel macros), 403,
407-408
PhoneNET PC (Farallon),
809
Pick a Look Wizard, 58,
435-436
Pick a Look Wizard dialog
box,435
Pick Up Style command
(Format menu)
(PowerPoint), 517
PICT file format, 633
Picture command (Insert
menu) (Excel), 64
Picture command (Insert
menu) (PowerPoint), 64
Picture command (Insert
menu) (Word), 64, 726
Picture Editor, 162
pictures
documents, inserting,
207-208, 596-598
frames, 209-210, 598-599
displaying, 160
hiding, 160
moving, 598
selecting, 598
sizing, 598
slides, 428
word wrap, 598-599
see also clip art; graphics;
shapes
pie charts, 615-617
pivot tables, 368
calculations, 376
summary functions,
376
summary types,
376-377

columns, rearranging
data, 371
creating, 368-370
editing, 371
fields
deleting, 373
inserting, 3 73
formatting, 374
AutoFormats, 375
numeric format,
374-375
rows, rearranging data,
371-373
scenarios, 391-392
updating, 371, 377-378
PivotTable command
(Data menu) (Excel), 369
PivotTable Field command
(Data menu) (Excel), 374
PivotTable Field dialog
box,374
PivotTable Wizard,
58, 368-373
placeholders (slides), 426,
450,452
Placement command
(Format menu) (Excel),
294
platforms
transferring files between
pia tforms, 805-806
floppy disks, 806-809
font conversion,
811-812
modems, 809
networks, 809
translating files between
platforms, 809-811
pleading papers,
see Pleading Wizard
Pleading Wizard, 190
plus sign (+) mathematical
operator, 300
point sizes (fonts), 109
pointers
Help pointers, SO
mouse pointers, 35-37
Portfolio Systems
(SmartScrap), 637
portrait orientation, 120,
548

Postscript graphics,
printing over text, 164
PowerPoint Viewer, 558
PowerShare, 664, 674-675
PowerTalk, 663
AppleMail, 664
catalogs, 664
information cards,
666-667, 671
Personal Catalogs,
670-671
Shared Catalogs,
670-671
compatibility with Mail,
665
correspondence
file formats, 668
forwarding, 668
headers, 668
replying, 668
sending, 668, 671
sending to users on
other networks, 675
DigiSign application, 673
digital signatures,
664, 673
installation, 664
key chains, 664
editing, 669
locking, 669
services, 669-670
setting, 665
Mailbox, 664, 671-673
servers, 664, 674-675
predefined macros (Word),
212-213
Preference dialog box
(PowerTalk), 672
Presentation Template
command (Format menu)
(PowerPoint), 435, 503
Presentation Template
dialog box, 436
presentations
blank presentations,
436-437
closing, 448
creating, 431-438
handouts, 421
masters, 423
orientation, 548-549
printing, 550-551

procedures
Mail, embedding, 712
notes, 421
masters, 423
orientation, 548-549
printing, 549-550
viewing, 421
opening, 448
outlines, 421
creating from Word
outlines, 699-702
masters, 423
orientation, 548-549
printing, 552
viewing, 421
saving, 447
slides, 421
annotations, 559
AutoLayouts, 426,
449-451
charts, 465, 710-711
clip art, 428, 460-461
color schemes,
517-520
copying, 445
deleting, 439-440
drawing shapes,
489-498, 509-S 17
files, 468, 469-4 70
graphs, 428, 465, 521524,546
inserting, 439-440
masters, 423
objects, 426-427,
467-470
organizational charts,
465-466
orientation, 547-549
outlines (Word
outlines), 702,
705-707
pictures, 428
placeholders, 426, 450
rearranging, 445
selecting, 445
shapes, 493-494
sizes, 54 7-549
slide shows, 552-559
switching slides,
439,446
tables, 428, 462-464
text, 452-460, 505-509
troubleshooting, 440

viewing, 421
worksheets, 462-464,
703-7051 708-710
Spelling Checker, 459460
templates, 424-426,
435-436, 502-503
backgrounds, 438
creating, 437-438
editing, 504
music templates·,
502-503
overhead templates,
425
saving, 437-438
selecting, 503-504
slides, 425
troubleshooting,
504-505
troubleshooting, 438
views
Notes Pages view, 440
Notes view, 445
Outline view, 440,
442-443
Slide Show view, 441,
446
Slide Sorter view, 440,
444-445
Slide view, 440, 442
switching views, 441
zooming in/out, 442
wizards
AutoContent Wizard,
432-435
Pick A Look Wizard,
435-448
Presentlt macro, 705-707
Preview toolbar, 133-134
previewing
files, 149
printouts, 77-79, 131-134
worksheets, 330-332
prewritten letters, 583
Print command (File
tncnu), 76, 322, 549
Print dialog box, 134-137,
322,337,549
Print Preview command
(File menu), 77, 330
Print Report command
(File menu) (Excel), 334
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Print Report dialog box,
335
print titles (worksheets),
326-327
printers, selecting, 77
printing, 163-164
charts, 351
documents, 76, 134-135
print preview, 77-79
troubleshooting, 135
e-mail, 657
envelopes, 136-137
files, 148, 151
Mail Merge form letters,
6851 688-691
outlines, 182
Postscript graphics over
text, 164
presentations
handouts, 550-SS 1
notes, 549-550
outlines, 552
reports (worksheets), 337
reverse print order, 163
slides
orientation, 547-549
sizes, 547-549
summary information,
142
worksheets, 321-322,
332-333
a specified area,
322-323
color worksheets, 327
fitting to a single page,
325
gridlines, 327
notes, 327
preview printouts,
330-332
printing column
headings, 327
printing row headings,
327
procedures (Visual Basic
for Applications), 759
calling, 776-778
creating with Macro
Recorder, 745-752
event procedures, 762
functions, 761-762
sub procedures, 760
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programming

programming
Visual Basic for
Applications, 16, 217,
396,404,743
applications, 763-767
arrays, 770-771
assignment
statements, 763
block If Structures, 773
bugs, 787-790
calling procedures,
776-778
classes, 753-754
collections, 753-754
comments, 749
constants, 772
data types, 769-771
debugging tools,
787-790
dialog boxes, 782-786
Help, 745
keywords, 749
logical formulas,
773-774
loops, 778-780
methods, 757-758
Object Browser,
758-759
objects, 744-745, 752
procedures, 745-752,
759-762
properties, 754-757
saving data to files,
780-781
select case structures,
774
variables, 762,
768-770, 772
worksheet cell
references, 774-776
WordBasic, 16
Help, 218
macros, 217-219
proofreading
grammar check, 129-131
presentations, 457-460
revision marks, 164-165
Spelling Checker, 124127
Thesaurus, 127-129
properties (Visual Basic for
Applications), 754-757

protecting files, 168
Publish & Subscribe,
638-644
Edition files
creating, 645-646
editing, 647, 651
naming, 645
publishing, 644-646
sending, 646, 647
subscribing, 647-648
setting publisher options,
646-647
setting subscriber
options, 649-65 1
Publishing command
(Edit menu), 645
pull quotes, 728-730

Q
Query and Pivot toolbar,
370,377
Query Options dialog box,
687,690
question mark (?) wildcard character, 263
Quick Preview (Help),
54-55
QuickSwitch (Office
Manager), 735
QuickTime movies,
transferring frames, 635
Quit command (File
menu), 21, 414
quitting, see closing;
exiting
quotes (pull quotes),
728-730

R
range names (formulas),
315
creating, 315-319
deleting, 317-318
inserting, 316-317
troubleshooting, 319-320
range operator, 302

ranges (cells)
fitting to a single page,
325
inserting, 259-260
printing, 322
searching, 262-263
worksheets
automatically filling
with dates, 243
automatically filling
with numbers, 242
automatically filling
with text, 240-242
selecting, 237-239
read-only files, 168
readability
documents (Grammar
Checker), 171
text, 114-115
Readability Statistics
dialog box, 171
reading e-mail, 656-657
receiving documents,
658-659
Record Macro command
{Tools menu) (Excel), 397
Record Macro dialog box
(Word), 214
Record New Macro dialog
box (Excel), 403, 746
recording
Excel macros, 396-401
Word macros, 214, 216
scripts, 794-798
records (lists)
deleting, 359
filtering, 362-364
finding, 359-360
inserting, 35 7-358
sorting, 361
viewing, 358
Redo command (Edit
menu), 94, 246
#REF! error, 302
reference operators, 302
references
scripts, 800
Visual Basic for
Applications, 774-776
registering digital
signatures (PowerTalk),
673

scenarios
rehearsing slide shows,
555-556
Remove Page Break
command (Insert menu)
(Excel), 324
Rename Sheet dialog box,
262
Repeat command (Edit
menu), 111, 246
repeating commands, 4 7,
94,245-246
Replace command (Edit
menu) (Excel), 264
Replace dialog box, 263,
264
Replace Fonts command
(Tools menu)
(PowerPoint), 812
replacing worksheet cells,
264-265
replying
correspondence
(PowerTalk), 668
e-mail, 656
Report Manager, 334-336
reports
scenarios, 390-392
Solver, 384-385
worksheets
creating, 335-336
editing, 337
printing, 337
troubleshooting, 33 7
Resume Wizard, 58, 190
revision marks, 164-165
ribbons, see toolbars
Rich-Text Format (RTF)
files, 634
Rotate/Flip command
(Draw menu) (Power
Point), 482
rotating slide objects,
481-483
routing documents,
660-661
Routing Slip dialog box,
660
Row Height dialog box,
279

rows
datasheets
data series, 526-527
deleting, 530
excluding from
graphs, 533-534
inserting, 530
selecting, 528-529
pivot tables, rearranging
data, 371-373
tables, 196
adjusting height,
199-200
deleting, 199
inserting, 199, 201
selecting, 198
worksheets, 229
adjusting heights,
278-280
deleting, 260
inserting, 259
printing row headings,
327
selecting, 239
Rows command (Format
menu) (Excel), 279
Rows command (Insert
menu) (Excel), 259
RTF (Rich-Text Format) file
format, 634
rulers, 89
displaying, 161
hiding, 161
measurement units, 159
print preview, 132
tabs, setting, 115-116
Rulers command (View
menu), 132, 420
run-time errors (Visual
Basic for Applications),
787
running
Excelmacros,402,405
Word macros, 213, 217
scripts, 798
slide shows, 552, 556-558
Solver, 382-384
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s
Save All command (File
menu) (Word), 100
Save As command, 98, 44 7
Save As dialog box, 98, 44 7
Save command (File
menu),62,99,246,447
Save Data Source dialog
box,221,681
Save dialog box, 246
Save Format dialog box,
101
Save Search As dialog box,
144
Save Workspace command
(File menu), 247
Save Workspace dialog
box,247
saving
automatic saves, 168
backups, 167
Clipboard contents, 636
documents, 98-100,
167-168
fast saves, 167
files, 62-63
backups, 68
in other formats,
67-68, 101
macros, 218
presentations, 447
scripts, 802-804
templates, 167, 437-438
workbooks, 246
workspace files, 247-248
Scale command (Draw
menu) (Power Point), 478
scaling slide objects,
477-479
Scenario Manager dialog
box,386
Scenario Summary dialog
box,390
Scenario Values dialog
box,389
scenarios, 385
creating, 385-389
deleting, 389-390
editing, 389-390
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scenarios

pivot tables, 391-392
reports, 390-392
worksheets, 335-336
Scenarios command (Tools
menu) (Excel), 386
Scrapbook, 632, 636-637
ClickPaste (Mainstay),
637
SmartScrap (Portfolio
Systems), 63 7
Scrapbook files, 637
screen display
backgrounds, 158
hiding elements, 106
rulers, 419-420
ScriptEditor (AppleScript),
795-796
scripts, 17, 793-794
commenting out, 798,
803
editing, 798
formatting, 799-800
language, 795-796
recording, 794-798
running, 798
saving, 802-804
troubleshooting, 802
writing, 794-79 5, 801-803
application keywords,
800
comments, 800
language keywords,
800
operators, 799
references, 800
text, 799
values, 800
variables, 800
scroll arrows (windows),
23
scroll bars, 23, 42, 90, 161
Search dialog box, 69-70,
143,572,575
searching, see finding
section breaks
(documents), 716-718
sections (documents), 716
Select a Data File dialog
box,685
Select All command (Draw
menu) (Power Point), 473

select case structure (Visual
Basic for Applications),
774
Select Table command
(Table menu) (Word), 198
Selected [Element]
command (Format menu)
(Graph), 545
selecting
cells
datasheets, 528-529
tables, 198
worksheets, 231
chart types, 343-344
color schemes (slides),
5I9-520
columns
datasheets, 528-529
tables, 198
worksheets, 239
disks, 65
drives, 65
files, 152
graphics, 292
pictures, 598
printers, 77
ranges (cells), 237-239
rows
datasheets, 528-529
tables, 198
worksheets, 239
slides, 445
slide objects, 472-474
tables, 198
template wizards, 190
templates, 503-504
text, 41, 92-94
automatic word
selection, 162
outlines, 179-180
tables, 198
worksheets, 238
semicolon(:) range
operator, 302
Send Backward command
(Draw menu) (Power
Point), 484
Send to Back command
(Draw menu) (Power
Point), 484
Send command
(PowerTalk File menu),
668

Send dialog box
(PowerTalk), 673
sending
correspondence
(PowerTalk), 668, 671,
675
documents, 658-659
Edition files (Publish &
Subscribe), 646-647
sensitivity reports (Solver),
384
Series dialog box, 244
Series in Columns
command (Data menu)
(Graph), 527
Series in Rows command
(Data menu) (Graph), 527
servers
Mail, 665
PowerTalk, 664, 674-675
services (PowerTalk key
chains), 669-670
Shaded Fill dialog box,
513-514
shading
borders, 207
fields, 161
shapes
borders, 5I3-515
fills, 513-515
Shadow command (Format
menu) (PowerPoint), 516
Shadow dialog box, 516
shadows
shapes, 515-517
slide text, 506
shapes, 509-510
attributes, copying, 5I7
borders
colors, 5 I 0-5 13
dashed lines, 5 II
patterns, 513-515
shading, 513-515
centering, 492
drawing, 489-490
AutoShapes, 490-491
freeform shapes,
496-498
from center outward,
492
perfect shapes,
491-492

Sort dialog box
fills
colors, 490, 510-513
patterns, 513-515
shading, 513-515
shadows, 515-517
sizing, 493-494
Shared Catalogs
(PowerTalk), 670-671
sheet buttons, assigning to
Excelmacros,406
shortcut menus, 33-34
signatures (PowerTalk),
664,673
sizing
charts, 342
graphics, 292-293
pictures, 598
shapes, 493-494
slide objects, 477-479
Slide Color Scheme
command (Format menu)
(PowerPoint), 502, 504,
518
Slide Color Scheme dialog
box,502,504,518
Slide Layout dialog box,
450
Slide Setup command (File
menu) (PowerPoint), 54 7
Slide Setup dialog box, 54 7
Slide Show command
(View menu)
(PowerPoint), 555
Slide Show dialog box, 555
Slide Show view
(presentations), 441, 446
Slide Sorter view
(presentations), 440,
444-445
Slide view (presentations),
440,442
slides, 83, 421
AutoLayouts, 426,
449-451
charts, 710-711
inserting, 465
organization charts,
465-466
clip art, 428
ClipArt Gallery,
460-461

inserting, 460-461
troubleshooting, 461
color schemes, 517-518
editing, 518
selecting, 519-520
copying, 445
deleting, 439-440
documents, linking,
620-622
graphs, 521-524
inserting, 428, 465,
546
inserting, 439-440
masters, 423
objects, 426-427
aligning, 4 79-480
copying, 477
flipping, 481-483
grouping, 474-476
importing from other
applications, 468-470
inserting, 428, 467-470
labels, 456
moving, 476
rotating, 481-483
selecting, 472-474
sizing, 477-479
stacking, 484-485
orientation, 547-549
outlines (Word outlines),
702-707
pictures, 428
placeholders, 426, 450,
452
rearranging, 445
selecting, 445
shapes, 509-510
colors, 510-513
copying attributes to
another shape, 517
drawing, 489-492,
494-498
patterns, 513-515
shading, 513-515
shadows, 515-517
sizing, 493-494
sizes, 547-549
slide shows, 552
annotations, 559
PowerPoint Viewer,
558
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rehearsing, 555-556
running, 552, 556-558
timing, 552-556
transistions, 552-555
switching slides, 439, 446
tables, 428, 462-464
templates, 425
text, 505
alignment, 508-509
bulleted lists, 453
color, 505-507
editing, 456-45 7
embossed effect, 506
entering, 452-453
fonts, 505-507
inserting, 453-455
line spacing, 507-508
paragraph spacing,
507-508
shadows, 506
Spelling Checker,
457-460
styles, 505-507
text boxes, 455
troubleshooting, 460
troubleshooting, 440
viewing, 421
worksheets, 703-705
fitting onto slide, 710
inserting, 462-464
linking, 708-710
SmartScrap (Portfolio
Systems), 637
Snap to Grid command
(Draw menu) (Power
Point), 481
snd file format, 634
Solver, 380
installation, 381
reports, 384-385
running, 382-384
setting up problems,
381-382
Solver command (Tools
menu) (Excel), 381
Solver Parameters dialog
box,382
Sort command (Data
menu) (Excel), 361
Sort dialog box, 361
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sorting

sorting
files, 148, 151-152
lists, 361
Mail Merge form letters,
687-688
sound files, 635
source documents (linked
documents), 603,607
spacing
fonts (fractional widths),
163
line spacing
paragraphs, 112-114
slide text, 507-508
paragraph spacing
paragraphs, 112-115
slide text, 507-508
special effects (text),
723-725
Special menu commands
Lock Key Chain
(PowerTalk), 669
Spelling Checker
customizing, 169-170
documents, 124
AutoCorrect, 124-126
troubleshooting, 127
foreign languages, 170
presentations, 45 7-460
worksheets, 265-267
Spelling command (Tools
menu) (PowerPoint), 459
Spelling command (Tools
menu) (Excel), 266
Spelling command (Tools
menu) (Word), 124
Spelling dialog box,
124-125, 266, 457
spreadsheets, see
datasheets; worksheets
stacking slide objects,
484-485
Standard toolbars, 25-26,
89, 417-419, 525-526
starting
applications, 20
Graph, 202-203, 521-524
macro recorder (Excel),
397-398
Mail, 654
Microsoft Office, 21
PowerPoint, 413-414

statistics (files), 141-142
status bars, 24, 90
Excel macros, 404
displaying, 161
hiding, 161
stopping macros (Excel),
4Q2
storing e-mail, 65 7
strikethrough text, 110
styl file format, 634
Style command (Format
menu) (Excel), 271, 290
Style command (Format
menu) (Word), 184
Style dialog box, 186, 271,
290-291
Style Gallery, 188-189
Style Gallery dialog box,
189
styles, 182-183
applying, 183
creating, 184
editing, 184-186
fonts, 109-110
Letter Wizard, 588-589
naming, 184
slide text, 505-507
Style Gallery, 188-189
templates, 183
worksheets
applying, 291
creating by example,
290
defining, 290-291
numbers, 271-273
sub procedures (Visual
Basic for Applications),
760
subfolders, 66
Subscribe to from
Publishing command
(Edit menu), 648
subscribing to Edition files
(Publish & Subscribe),
647-651
subscript text, 110, 506
Subtotal dialog box
(Excel), 366
subtotals (lists), 366
deleting, 368
displaying, 367
hiding, 367

Subtotals command (Excel
Data menu), 366
subtraction mathematical
operator, 300
summary functions (pivot
tables), 376
Summary Info command
(File menu), 69, 574
Summary Info dialog box,
69,140,574
summary information
(files), 69, 140, 574-577
displaying, 140
editing, 141, 148
finding, 150-151
printing, 142
statistics, 141-142
troubleshooting, 142
summary reports
(scenarios), 390
summary type (pivot
tables), 376-377
superscript text, 110, 506
switching
applications, 21, 81, 578
documents, 79-81, 590
slides, 439, 446
views (presentations), 441
syntax errors (Visual Basic
for Applications), 787
System 7.5
Clipboard, 635
drag-and-drop editing,
635
system requirements,
817-818

T
Table AutoFormat dialog
box, 197
Table menu commands
Cell Height and Width,
199-200
Delete Columns, 199
Delete Rows, 199
Gridlines, 197
Insert Columns, 199
Insert Rows, 199
Insert Table, 196
Select Table, 198

text

Table Wizard, 58, 190, 197
tables, 196
autoformats, 197
cells, 37, 196
adjusting height,
199-200
adjusting widths,
200-201
selecting, 198
columns, 196
adjusting widths, 49,
196, 200-201
deleting, 199
inserting, 199, 201
selecting, 198
creating, 17
documents, inserting,
196-197, 725-726
gridlines, 197
Help, 197
insertion point, 198
rows, 196
adjusting height,
199-200
deleting, 199
inserting, 199, 201
selecting, 198
selecting, 198
slides, inserting, 428,
462-464
text
entering, 196, 198
formatting, 198
selecting, 198
word wrap, 196
worksheets, inserting as
tables into documents,
596
see also pivot tables
tabs
leaders, 115
setting, 115-116
worksheets, 230
Tabs command (Format
menu) (Word), 115
Tabs dialog box, 11 5
template wizards, 190
formatting, 192-193
selecting, 190
text options, 191-192
troubleshooting, 193

templates
documents, 101
global templates, 212
predefined templates, 183
presentations, 424-426,
435-436, 502-503
backgrounds, 438
creating, 437-438
editing, 504
music template,
502-503
overhead templates,
425
saving, 43 7-438
selecting, 503-504
slides, 425
troubleshooting,
504-505
saving, 167
styles, 183
Templates and Add-ins
dialog box, 212
Templates command (File
menu) (Word), 212
testing timing on slides
shows, 556
text
accent marks, 162
alignment, 118-119
borders, 206-210
deleting, 206
patterns, 207
shading, 207
boundaries, 160
converting case, 97
copying, 96
copying between
documents, 589-593
cutting, 95-96
datasheets
editing, 529
entering, 528
deleting, 94-96
drag-and-drop editing,
96-98
finding, 5 77-5 78
formatting, 108
AutoFormats, 186-190
copying, 110-111
copying to Clipboard,
158
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fonts, 108-109
point size, 109
styles, 109-110
troubleshooting, 111
frames, 209-210, 728
graphs, 543-545
indents, 116-117
moving, 95-96
outlines
entering, 178
selecting, 179-180
pasting, 96
readability, 114-115
scripts, 799
selecting, 41, 92-94, 162
slides, 505
alignment, 508-509
bullets, 453
color, 505-507
editing, 456-45 7
embossed effect, 506
entering, 452-453
fonts, 505-507
inserting, 453-455
labels, 456
line spacing, 507-508
paragraph spacing,
507-508
shadows, 506
Spelling Checker,
457-460
styles, 505-507
text boxes, 455
troubleshooting, 460
styles, 182-183
applying, 183
creating, 184
editing, 184-186
naming, 184
tables
entering, 196, 198
formatting, 198
selecting, 198
word wrap, 196
tabs, 115-116
typing, 90
corrections, 90
insertion point, 91-92
overtype mode, 91,
162
repeated words, 90
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text

replacing text, 161
troubleshooting, 94
undoing, 94-95
word wrap, 90
WordArt special effects,
723-725

worksheets
automatically filling
cells, 240-242
entering, 233-234
fonts, 285-286
joining, 301
point size, 285-286
styles, 290-291
word wrap, 281
see also paragraphs
text boxes
dialog boxes, 38
forms, 38
slides, 455
worksheets, 295-296
text concatenation
operator, 301
TEXT file format, 633
Text Import Wizard, 58
Text Wizard, 58
Thesaurus, 127-129
Thesaurus command
(Tools menu) (Word), 127
Thesaurus dialog box, 127
three-dimensional graphs,
534

thumbs (windows), 23
tiling windows, 79
time
files, 635
formulas, 302
worksheets
entering, 235
formatting, 274-275
timing slide shows,
552-556

Tip of the Day, 51, 54
Tip of the Day dialog box,
413

title bars, 23, 88
titles
charts, 346
graphs, 538-539
print titles (worksheets),
326-327

Titles command (Insert
menu) (Excel), 346
Titles command (Insert
menu) (Graph), 539
Titles dialog box, 346, 538
toolbars, 23-25
AutoShapes toolbar,
490-491

Borders toolbar, 205
buttons
assigning to Excel
macros, 406-407
copying, 737
deleting, 737
inserting, 73 7
creating, 737-739
customizing, 735-737
Drawing toolbars, 28-30,
294, 487-488

Drawing+ toolbars,
512-513

Formatting toolbars, 27,
46-47, 89, 178, 271,
507,509

Forms toolbar, 783-784
Macro Recording toolbar,
216

Merge toolbar, 222-224
Outline toolbar, 176, 180
Outlining toolbar, 552
Preview toolbar, 133-134
Query and Pivot toolbar,
370,377

Standard toolbars, 25-26,
89, 417-419, 525-526

troubleshooting, 738-739
turning on/off, 24
Visual Basic toolbar, 402,
749

Workgroup toolbar, 389
Toolbars command (View
menu), 24, 271
Toolbars dialog box, 736
Tools menu commands
Add-Ins (Excel), 334, 381
Auto Correct (Word), 126
Customize (Word), 739
Envelopes and Labels
(Word), 136
Goal Seek (Excel), 379
Grammar (Word), 129

Instant Watch (Excel),
787

Macro (Excel), 402
Macro (Word), 213
Macro Organizer (Word),
219

Mail Merge (Word), 678
Options (Word), 156
Record Macro (Excel),
397

Replace Fonts
(PowerPoint), 812
Scenarios (Excel), 386
Solver (Excel), 381
Spelling (Excel), 266
Spelling (PowerPoint),
459

Spelling (Word), 124
Thesaurus (Word), 127
Transition (PowerPoint),
553

transferring files
between applications,
632-637

between platforms,
805-806

floppy disks, 806-809
font conversion,
811-812

modems, 809
networks, 809
see also copying; cutting;
pasting
Transition command
(Tools menu)
(PowerPoint), 553
transitions (slide shows),
552-555

Transitions dialog box
(PowerPoint), 553
translating files between
platforms, 809-811
troubleshooting
AutoCorrect {Spelling
Checker), 127
AutoFill (worksheets),
245

AutoFormats, 190
charts, 352
drawing, 496
files (drives), 574

View Outline command

Find File program, 14 7
formatting
pages, 122
paragraphs, 118-119
text, 111
formulas, 236, 305,
319-320
functions, 311
grammar check, 131
Graph, 524
linking documents, 608
lists, 360
macros (Excel), 401, 405
macros (Word), 218-219
menus, 741
outlines, 182
page breaks (worksheets),
333
presentations, 438
slides, 460
templates, 504-505
print preview, 134
printing, 135
reports (worksheets), 337
scripts, 802
slides, 440, 461
Spelling Checker, 127
summary information
(files), 142
template wizards, 193
Thesaurus, 129
toolbars, 738-739
typing, 94
views, 108
TrueType fonts, 168
turning on/off toolbars, 24
two-dimensional graphs,
534
typefaces, see fonts
typing, 35-40
corrections, 90
datasheets, 528
insertion point, 35-37,
91-92
overtype mode, 91, 162
repeated words, 90
replacing text, 161
slides, 452-453
starting new line, 91
tables, 196-198
troubleshooting, 94

undoing, 94-95
word wrap, 90
worksheets, 233-23 7

u
underlining text, 110
underscore (_) range
names, 315
Undo command (Edit
menu), 94, 245-246
undoing mistakes, 4 7,
94-95, 98, 245-246
Ungroup command (Draw
menu) (Power Point), 476
Unhide command
(Window menu) (Excel),
408
union operator, 302
upgrades, 822-823
upgrouping graphics, 295
uppercase letters (accent
marks), 162
user info, 165
user information cards
(PowerTalk catalogs), 671
User-Defined AutoFormats
dialog box, 348
utilities
Apple File Exchange,
807-808
ClickPaste (Mainstay),
637
file exchange utilities
Access PC, 808
Apple File Exchange,
807-809
DOS Mounter (Dayna
Corporation), 808
Macintosh PC
Exchange,808
MacLinkPlus/PC, 809
NetWare for Macintosh
(Novell), 809
PhoneNET PC (Farallon),
809
SmartScrap (Portfolio
Systems), 63 7
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v
#VALUE! error, 302
values (scripts), 800
variables
scripts, 800
Visual Basic for
Applications, 762-763
declarations, 768-770
scope, 772
VBA, see Visual Basic for
Applications
vertical alignment
(worksheet cell contents),
283
video (QuickTime movies),
transferring frames, 635
View Manager, 334-335
View Manager command
(View menu) (Excel), 334
View Manager dialog box,
335
View menu commands
By Name (Finder), 566
Datasheet (Graph), 524
Guides (PowerPoint), 420
Header and Footer
(Word), 718
Normal (Word), 105
Page Layout (Word),
105, 715
Rulers (PowerPoint), 420
Rulers (Word), 132
Slide Show (PowerPoint),
555
Toolbars, 24, 271
View Manager (Excel),
334
View Notes Pages
(PowerPoint), 421
View Outline
(PowerPoint), 421
View Slides (PowerPoint),
421
Zoom (PowerPoint), 442
Zoom (Word), 107
View Notes Pages
command (View menu)
(PowerPoint), 421
View Outline command
(View menu)
(PowerPoint), 421
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View Slides command

View Slides command
(View menu)
(PowerPoint), 421
viewing
annotations (worksheets)
393
files (drives), 566-567
masters (presentations)
424
notes (presentations), 421
outlines (presentations),
421
records (lists), 358
slides, 421
views, 104
hiding screen elements,
106
landscape view, 108
magnifying, 106-108
Normal view, 104-105
Page Layout view,
105-112
presentations
Notes Pages view, 440
Notes view, 445
Outline view, 440,
442-443
Slide show view, 441,
446
Slide Sorter view, 440,
444-445
Slide view, 440, 442
switching views, 441
zooming in/out, 442
troubleshooting, 108
worksheets, 334-335
WYSIWYG (what you see
is what you get), 105
Visual Basic for
Applications, 16, 217,
396,404,743
applications, 763-767
arrays, 770-771
assignment statements,
763
block If Structures, 773
bugs, 787
classes, 753-754
collections, 753-754
comments, 749
constants, 772
I

I

data types, 769-771
debugging tools, 787
break mode, 787
breakpoints, 788
Debug window,
788-790
watchpoints, 788
dialog boxes, 782-786
Help, 745
keywords, 749
listings (37.1 The Receipt
Maker Program),
765-770
logical formulas, 773-774
loops
Do/Loop loop,
779-780
For Each loop, 780
For/Next loop,
778-779
methods, 757
accessing, 757-758
arguments, 757
Object Browser, 758-759
objects, 744-745, 752-759
operators
comparison operators,
773
logical operators, 77 4
procedures, 759
calling, 776-778
creating with Macro
Recorder, 745-7 52
event procedures, 762
functions, 761-762
sub procedures, 760
properties, 754-757
saving data to files,
780-781
select case structures, 77 4
variables, 762-763
declarations, 768-770
scope, 772
worksheet cell references,
774-776
Visual Basic toolbar, 402,
749

w
what-if analysis
(worksheets), 385-392
wild-card characters, 263
Window menu commands
Arrange (Excel), 79
Arrange All (PowerPoint)
81
I
Arrange All (Word), 79
Cascade (PowerPoint), 81
Unhide (Excel), 408
Windows
transferring Mac files,
805-806
floppy disks, 806-809
font conversion,
811-812
modems, 809
networks, 809
translating Mac files,
809-811
windows
active windows, 81
cascading, 79
Debug window (Visual
Basic for Applications),
788
calls window, 790-791
immediate pane, 789
step commands, 790
watch expressions, 789
watch pane, 789
document windows,
23-24,591
How to windows, 51, 56
maximizing, 81
menu bars, 23
rulers, 161
scroll arrows, 23
scroll bars, 23, 161
status bars, 161
thumbs, 23
tiling, 79
title bars, 23
wizards, 51, 56-59, 432
Agenda Wizard, 57
AutoContent Wizard, 58,
432-435
Award Wizard, 57

worksheets
Calendar Wizard, 57
Chart Wizard, 58,
341-352
Fax Wizard, 57
Function Wizard,
307-309
Letter Wizard, 57,
582-587
prewritten letters, 583
styles, 588-589
Memo Wizard, 58
Newsletter Wizard, 58
Pick a Look Wizard, 58,
435-436
PivotTable Wizard, 58,
368-373
Resume Wizard, 58
Table Wizard, 58, 197
template wizards, 190
formatting, 192-193
selecting, 190
text options, 191-192
troubleshooting, 193
Text Import Wizard, 58
Text Wizard, 58
word processing, see
typing
word wrap, 90-91
graphics, 723
pictures, 598-599
table cells, 196
worksheets, 281
WordArt, 626, 723-725
WordArt dialog box, 723
WordBasic, 16
Help, 218
macros, 217-219
workbooks, 229-230
macros (Excel)
Personal Macro
Workbook, 407-408
storing, 403
saving, 246
worksheets
deleting, 261
inserting, 261
moving, 261-262
naming, 262
workspace files
opening, 248
saving, 24 7-248

Workgroup toolbar
(Excel), 389
Worksheet command
(Insert menu) (Excel), 261
worksheets, 229-230
annotations
deleting, 393-394
inserting, 392-393
printing, 327
viewing, 393
cells, 3 7, 230
aligning contents,
280-284
AutoFormats, 288-289
borders, 287
characters, formatting,
286-287
clearing contents,
251-252
colors, 287-289
copying contents,
252-257
copying formatting,
255
deleting contents, 251
finding, 262-263
inserting, 259-260
insertion point, 250
moving, 257-259
moving between cells,
231-233
patterns, 287-288
replacing, 264-265
selecting, 231
Visual Basic for
Applications
references, 774-776
charts
embedding, 338-341
moving objects,
341-343
sizing objects, 341-343
checking spelling,
265-267
columns, 229
adjusting widths, 49,
276-278
centering text across
columns, 282
deleting, 260
inserting, 259
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printing column
headings, 327
selecting, 239
dates
automatically filling
cells, 243
entering, 235, 237
formatting, 274-275
deleting, 261
documents
exporting, 593-596
linking, 595, 611-614
drawing, 291
editing, 249-251
footers, 328
creating, 329-330
deleting, 329
predefined footers,
328-329
form letters, merging,
685-687
formulas
cell references, 299
converting to values,
304-305
copying, 312-313
creating, 297-305
dates, 302
debugging, 302-303
entering, 235-236
functions, 306-311
Help, 303
linking, 313-314
mathematical
operators, 300-302
times, 302
troubleshooting, 305
Goal Seeker, 3 78-380
Graph, inserting, 205
graphics
formatting, 294
grouping, 294-295
moving, 292
selecting, 292
sizing, 292-293
ungrouping, 295
gridlines, 327
headers, 328
creating, 329-330
deleting, 329
predefined headers,
328-329
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worksheets

inserting, 261
linking, 622-624
lists, 355
creating, 356-35 7
editing, 356-35 7
filtering, 362-364
forms, 357
pivot tables, 368-3 78
records, 35 7-360
sorting, 361
subtotals, 366-368
troubleshooting, 360
margins, 325-326,
331-332
moving, 261
naming, 262
navigation, 230-233
notes, see annotations
numbers
automatically filling
cells, 242
entering, 234-235
formatting, 269-276
styles, 271-273
orientation, 325
page breaks, 323
deleting, 324
horizontal page
breaks, 324
troubleshooting, 333
vertical page breaks,
323-324
previewing, 330-332
print titles, 326-327
printing, 321-322,
332-333
a specified area,
322-323
color worksheets, 327
fitting to a single page,
325
reports
creating, 335-336
editing, 33 7
printing, 33 7
troubleshooting, 337
rows, 229
adjusting heights,
278-280
deleting, 260
inserting, 259

printing row headings,
327
selecting, 239
scenarios, 335-336, 385
creating, 385-389
deleting, 389-390
editing, 389-390
pivot tables, 391-392
reports, 390-392
selecting, 238
slides, 703-705
fitting onto slide, 710
inserting, 462-464
linking, 708-710
Solver, 380
installation, 381
reports, 384-385
running, 382-384
setting up problems,
381-382
styles
applying, 291
creating by example,
290
defining, 290-291
tabs, 230
text
automatically filling
cells, 240-242
entering, 233-234
fonts, 285-286
joining, 301
point size, 285-286
word wrap, 281
text boxes, 295-296
times
entering, 235
formatting, 274-275
views, 334-335
work area, 82-83
zooming in/out, 331
see also datasheets
workspace files
opening, 248
saving, 24 7-248
wrapping words, see word
wrap
writing
macros, 217-219
on slides, 559

scripts, 794-795, 801-803
application keywords,
800
comments, 800
language keywords,
800
operators, 799
references, 800
text, 799
values, 800
variables, 800
WYSIWYG (what you see is
what you get), 105

X-Y-Z
Xor logical operator
(Visual Basic for
Applications), 774
Zoom command (View
menu) (PowerPoint), 442
Zoom command (View
menu) (Word), 107
Zoom dialog box, 107,442
zooming in/out
presentation views, 442
worksheets, 331

