Understanding the Macintosh

Rick Dayton

A Reston Computer Group Book
Reston Publishing Company, Inc.
A Prentice-Hall Company
Reston, Virginia
CONTENTS

Preface, xi

1 UNDERSTANDING THE MACINTOSH COMPUTER, 1

Introduction to the Macintosh Hardware, 3
The Mouse, 4
The Cabinet, 4
The computer, 5
The display screen, 6
The built-in disk drive, 6
The Macintosh Device Connectors, 7
The Macintosh Keyboard, 8
The Macintosh Printer, 8
Hardware Enhancements, 10

Understanding the Macintosh Application Environment, 10
User—Friendliness Criteria, 11
Mouse Clicking, 12
Icon Symbols, 12
Windows and Scroll Boxes, 14
Pull-down Menus, 16
Software Environment and Accessories, 18

Applications Overview, 19
Understanding Application Approaches, 19
Pull-down Menus, 18
Specific purpose software packages, 20
General purpose software packages, 20
The Macintosh General Purpose Software Packages, 20
MacPlan, 20
MacWrite, 20
MacChart, 21
MacPaint, 21

2 USING MACPLAN, 23

What MacPlan Can Do For You, 25
MacPlan Overview, 25
CONTENTS

Benefits to be Derived from Using MacPlan, 27
   Eliminate manual calculations, 27
   Answer what-if questions, 28
   Facilitate better financial decisions, 28

Working with MacPlan Features, 29
   Creating a MacSheet Document, 29
MacPlan Concepts, 29
   Understanding the MacSheet components, 29
   Entering data, 30
   Modifying MacSheets, 33
   Modifying the contents of a MacSheet, 34
   Modifying the appearance of a MacSheet, 38
Calculating Results, 42
   Automatic calculation, 42
   Circular references, 42
   Iterative calculations, 43
Protecting MacSheets, 44
Printing MacSheets, 44
Saving MacSheets, 45
MacPlan Shortcuts, 45
Transferring MacSheet Data, 47

Getting Formulas to Work For You, 48
Understanding MacPlan Formulas, 48
   Formula components, 49
   Arithmetic operators, 49
   Relational operators, 50
   Text operator, 51
   Control constants, 51
Using MacPlan’s Built-In Functions, 52

Ideas for MacPlan Applications, 60
Case Study—Building a MacPlan Spreadsheet, 61
   Amortization table, 68
   Budgets, 69
   Capital expenditures, 70
   Cash flow, 71
   Cash disbursements, 72
   Checkbook reconciliation, 73
   Commission calculation, 74
   Cost analysis, 75
   Depreciation, 76
   Expense reports, 77
CONTENTS

Financing alternatives, 78
Impounds, 79
Income taxes, 80
Inflationary effects, 81
Inventory analysis, 82
Market analysis, 83
Overhead allocation, 84
Payroll, 85
Personnel compensation, 86
Projections, 87
Productivity analysis, 88
Revenue analysis, 89
Salary analysis, 90
Selling expense analysis, 91
Stock portfolio, 92
Time management, 93
Variance analysis, 94

3 USING MACWRITE, 95

What MacWrite Can Do for You, 97
Document life cycle, 97
Benefits to be Derived from Using MacWrite, 100
Reduction in clerical effort, 100
Shorter life cycle, 101
Enhanced control, 101
Professional looking documents, 102

Ideas for Using MacWrite, 102
Who Can Benefit from Using MacWrite, 102
Recurring Documents, 104
Nonrecurring Documents, 105
When to Use MacWrite, 106
Where to Use MacWrite, 106

Working with MacWrite Features, 107
Adjusting MacWrite's Comfort Control Features, 107
Setting up for your MacWrite Document, 110
Modifying a MacWrite Document, 115
  Modifying the contents of a MacWrite document, 115
  Modifying the appearance of a MacWrite document, 118
Printing MacWrite Documents, 120
Saving MacWrite Documents, 120
CONTENTS

Using MacWrite's Shortcuts, 121
Transferring Text Between MacWrite Documents, 121

Case Study—Creating and Modifying a MacWrite Document, 122

USING MACCHART, 125

Understanding Numeric Graphics, 127
Graphic Shapes, 127
Amounts, 127
Titles, 128

What MacChart Can Do for You, 128
Overview of MacChart, 129
Benefits to be derived from Using MacChart, 129

Working with MacChart Features, 131
Understanding MacChart Concepts, 131
Understanding the basic MacChart components, 132
Understanding MacChart terminology, 133
Understanding the chart components, 134
Understanding MacChart's data types, 134

How to Enter and Modify Data, 136
Entering data, 136
Modifying data, 137

Generating Analysis Graphs, 138
The MacChart generated graphs, 138
Creating generated graphs, 139

Modifying MacChart Graphs, 140
Changing the graph shape, 141
Modifying the border, 143
Modifying the chart, value and category titles, 144
Modifying the axes, 144
Adding grid lines, 148
Modifying value or category prefixes and suffixes, 148
Modifying value or category alignment and format, 150
Modifying main chart and overlay chart formats, 150
Modifying a legend, 152
Adding and modifying an arrow, 153
Changing the location or size of a chart component, 156
Overlaying a graph with another graph, 157
Sorting values, 157
CONTENTS

Changing the pattern of a component, 157
Using the Special Keys with MacChart, 158
Printing MacChart Graphs, 159
Saving MacChart Graphs, 160
Retrieving saved Graphs, 161
Transferring Data between MacCharts, 161
  Copying data, 162
  Linking MacCharts, 162
Guidelines for Using MacChart, 163
  How much graphics to use, 163
  What should be graphed, 163
  Which shape to use, 163
  An approach to using MacChart, 164
Ideas for MacChart Applications, 164
  General, 167
  Budgets, 167
  Taxes, 167
  Investments, 167
  Financing alternatives, 167
  Inflationary effects, 167
  School, 167
Case Study—Creating and Modifying a MacChart Graph, 168

USING MACPAINT, 177

Overview of MacPaint, 179
Ways to Use MacPaint, 179
  Creating useful end-products, 179
  Having fun, 180
Working with MacPaint Features, 180
  Understanding MacPaint components, 180
  Using MacPaint's tools, 182
  Changing fill patterns, 187
  Modifying MacPaint drawings, 187
  Keyboard commands and other shortcuts, 189
  Storing, retrieving and printing MacPaint paintings, 190
  A MacPaint Illustrated Idea, 190
CONTENTS

6 TRANSFERRING DATA BETWEEN MACINTOSH APPLICATIONS, 191

Understanding Which Applications Can Transfer Data, 193
Benefits of Transferring Application Data, 193
How to Transfer Application Data, 194

7 COMING ATTRACTIONS, 197

New Software, 199
How You Can Influence Software Development, 200

Index, 203
PREFACE
If you are thinking about purchasing a desktop computer or you have recently bought a Macintosh™ computer, this book is for you. If you want to use a microcomputer for business or personal use, read on. This book illustrates what the Macintosh computer can do for you and how to get the most out of it. A few of the benefits you will derive follow:

- Are you familiar with state of the art software and the electronic "mouse"? Chapter 1 will acquaint you with the Macintosh software and hardware.
- Electronic spreadsheets are responsible for the desktop computer boom. See what MacPlan™ can do for you in Chapter 2.
- If you are still using pen, pencil and/or typewriter for letters, forms and other word processing applications, you are wasting valuable time. See how MacWrite™ can help increase productivity in Chapter 3.
- Voluminous columns and tables divert attention away from important matters. Explore the exciting world of Mac graphics in Chapter 4.
- One picture is worth a thousand words. See how MacDraw™ can help you draw presentation quality pictures and diagrams in Chapter 5.
- Put a MacChart™ in your MacWrite document to illustrate your thoughts. See how to exchange information between Macintosh documents in Chapter 6.
- What else is in store for the Macintosh computer? See what’s planned and how you can influence further development in Chapter 7.

HOW TO USE THIS BOOK

Specific challenges. If you are interested in an individual topic, such as "What are the specific features of MacPlan?", turn to the Contents or Index to locate the page number of the chapter which discusses that topic.

General challenges. If you can relate your challenge to one of the following general areas, direct your initial reading toward the related relevant chapters.

<table>
<thead>
<tr>
<th>General area</th>
<th>Chapter</th>
</tr>
</thead>
<tbody>
<tr>
<td>Macintosh computer software and hardware</td>
<td>1</td>
</tr>
<tr>
<td>MacPlan spreadsheet applications</td>
<td>2</td>
</tr>
<tr>
<td>MacWrite word processing applications</td>
<td>3</td>
</tr>
<tr>
<td>MacChart graphic applications</td>
<td>4</td>
</tr>
<tr>
<td>MacPaint diagram and picture applications</td>
<td>5</td>
</tr>
<tr>
<td>Macintosh application exchangeability</td>
<td>6</td>
</tr>
<tr>
<td>Macintosh coming attractions</td>
<td>7</td>
</tr>
</tbody>
</table>
APPLICATIONS PERSPECTIVE

This book emphasizes how to use the Macintosh application software from the personal business and home use perspective. Others, including engineers and programmers, will also find this book helpful for obtaining an overall understanding of the Macintosh software and hardware and the needs of users.
Understanding the Macintosh
Chapter 1

UNDERSTANDING
THE MACINTOSH
COMPUTER
During 1983, Apple Computer, Inc. ("Apple") introduced the Lisa computer, a revolutionary machine in personal computing. Over 100 man years of effort were devoted to developing the Lisa. While there are many functional similarities, the Macintosh™ ("Mac"), Lisa's little brother, differs in one significant respect—price. Mac sells for $2,500, while big sister Lisa costs more than twice as much. Functionally, however, Mac had the benefit of all those years of hard work in developing Lisa and resembles her in many respects while bearing a price tag that many households and businesses can afford. With that bit of background, let's see what Mac is all about. In this chapter, we'll start by exploring the Mac hardware and application environment. The remaining chapters are all devoted to applications. That's as it should be; after all, what good is a computer if it doesn't do anything? As we will see, Mac does a lot!

**INTRODUCTION TO THE MACINTOSH HARDWARE**

The Mac computer system has four main parts, the first three of which are illustrated in Figure 1.1

- The mouse.
- The cabinet, which houses the computer itself as well as the display screen and built-in disk drive.
- The keyboard.
- The printer.

![Figure 1.1 Front View of the Macintosh Computer.](image)

*Apple® is a registered trademark of Apple Computer, Inc.
*Macintosh™ is a trademark of Apple Computer, Inc.
The Mouse

Like a real mouse, the electronic mouse has a long tail connected to the computer, is small enough to fit in the palm of your hand, and can nimbly scurry around your desktop. Viewed from the top, the electronic mouse looks similar to the device used for remote slide projectors (rectangular in shape with a clicking button). However, when you turn the mouse over, you see a small metal ball that rotates when you move it around your desktop. What the mouse does is translate movement around your desk, both in terms of speed and direction, into electronic impulses that are sent through its tail into the computer.

The primary purpose of the mouse is to enable you to select options (and eliminate the need for you to memorize commands). When you move the mouse around your desktop, you also move the pointer (cursor) on the screen. As it moves around the screen, the mouse pointer itself changes shape according to the nature of the items on the screen. Figure 1.2 shows us some of the shapes. For example, the pointer assumes the arrow shape when pointing to objects. It turns into an "I beam" to help you indicate where you want to insert or delete text. After you click the mouse button, the I beam changes into a flashing insertion point line. Other shapes include the cross and directional pointers.

When you sit down at your desk (start the system up), the screen displays, among other things, tiny images of the tools available to you and the documents you have created and stored. You use the mouse to point to and select which documents you want to retrieve or which function you want to perform. When you are finished manipulating your data and documents, you use the mouse to tell Mac that you want to print your reports and graphs. After printing is completed, the mouse is used to store and save your documents until the next time you need them.

The Cabinet

The cabinet weighs approximately 20 pounds and, accordingly, is light enough to carry it with you should the need or desire to do so arise. Measuring less than 12 inches square at its base and 14 inches high, Mac is both light enough and

![Figure 1.2 Examples of Mouse Pointer Shapes.](image)

Figure 1.2 Examples of Mouse Pointer Shapes.
Understanding the Macintosh

small enough to be taken aboard airplanes, carried back and forth from office to home, or simply carried from room to room at home. A closer look indicates that the cabinet houses the computer itself, the display screen, a built-in floppy disk drive and connectors for attaching peripheral devices and other accessories.

THE COMPUTER

Inside the cabinet is the heart of the Mac computer, the microprocessor and memory. The microprocessor is the device that performs all the necessary computing work such as executing machine instructions to add, subtract, multiply, and divide or perform logic functions such as comparing two numbers to determine which is larger. Mac’s microprocessor is a Motorola 68000™, a powerful 16/32 bit processor, which is the same as that used by big sister Lisa.

You may be wondering what the term “16/32 bit processor” means. Without going into a lot of unnecessary engineering trivia, the term simply stands for the amount of information that can be dealt with by the computer and generally the degree of sophistication of the machine instruction set. The first number (16) is the amount of data that potentially can be transferred in or out (“external data path”) of main memory to and from peripheral devices (such as a disk drive) in a single pass. Mathematically then, a 16-bit external data path is physically capable of transferring approximately 2.1 million bytes of information (such as the letters of the alphabet or numeric digits). The second number (32) represents the amount of memory that can be directly addressed (accessed) for processing (“internal architecture”). Mathematically, this equates to over 30 billion characters of information. In other words, the Mac microprocessor is capable of supporting over 30 billion bytes of main memory. Equally important is the fact that the Motorola 68000 processor has a sophisticated instruction set that directly affects the computer’s processing speed. By way of comparison, most personal computers use processors with 8-bit internal data paths and 8- or 16-bit internal architecture. Suffice it to say, Mac’s Motorola 68000 processor provides an outstanding foundation for growth for the balance of the 1980s.

As is the case with other personal computers, Mac’s memory consists of two types: “ROM” (read only memory) and “RAM” (random access memory). The principal differences between ROM and RAM are: (1) price (ROM is more expensive), and (2) information retention. When the power is turned off, the information in RAM is lost, whereas with ROM, it is saved. In this regard, ROM is used to store information that doesn’t change (such as machine operating instructions), whereas RAM is used for information that varies over time (such as application programs and user data).

The initial release of the Macintosh computer includes 128 kilobytes (equivalent to approximately 131,000 characters) of random access memory. Having previously noted that Mac’s microprocessor is capable of accessing over 20,000 times that much memory, why then did Apple choose to use a
Motorola 68000 in Mac? From a user's perspective, there are two answers to this question. First, because of the speed and sophistication of its instruction set, the Motorola 68000 has the capacity to execute application program instructions very quickly and supports the sophisticated abilities of big sister Lisa. Second, it would appear that Apple may be laying the foundation for a family of Macintosh computers for many years to come. Although this is pure speculation, it may be Apple's strategy to provide larger amounts of RAM in subsequent versions of the Macintosh. Whether existing Mac owners will be permitted to upgrade if and when enhanced versions of Mac are introduced is a matter that only time will tell. For our purposes, assume that this will not be the case and judge Mac on its present merits (which are quite impressive in and of themselves).

**THE DISPLAY SCREEN**

Video screen displays are comprised of a rectangular area of rows and columns. At each intersection of a row and column is a dot. Characters and shapes are formed by a series of these dots displayed in a color contrasting with other parts of the screen. The closer together the dots, the greater the clarity or "resolution" of the images displayed. Measured diagonally, Mac has a 9-inch black and white display screen. As to characters, in text mode Mac's screen displays a normal 24 rows of 80 characters. High-quality graphics are created by the "bit-mapped" display featuring 512 lines of 342 dots.

**THE BUILT-IN DISK DRIVE**

As we saw earlier, information stored in RAM memory is lost when the power is turned off. Because we will want to save processing results frequently, some storage medium will be necessary. In addition, we also need a device for loading application programs and user files into memory. The built-in disk drive is the primary device for saving processing results and loading application programs and user data files in RAM memory (an external disk drive is optional but should be seriously considered). Mac's built-in disk drive uses 3½ inch floppy diskettes, which are capable of storing 400 kilobytes of data. Assuming that an average page of printed text contains approximately 4,000 characters, each of these floppy diskettes could store the equivalent of over 100 pages of text.

The concept of floppy disk drives is fairly straightforward. The diskette itself can be thought of as a magnetic record comprised of concentric circles or tracks. The disk drive contains a "head," which can move directly to any of these tracks (random access) and either read information from, or write infor-
Understanding the Macintosh

imation to; the diskette presently in the drive. Because the diskettes themselves cost only a few dollars each, floppy disk drives provide an inexpensive means for storing huge amounts of data.

Of particular interest is the size of the disk drive/diskettes and the density of the information stored. By way of comparison, the IBM Personal Computer presently uses 5¼ inch diskettes containing 360 kilobytes of data. In this regard, Mac stores more data in less space. As you may have guessed, the secret lies in the density of recording data. Mac simply packs the same amount of information into a smaller area on the diskette.

Mac's disk drive has the same built-in safety feature that big sister Lisa has. When you insert the diskette, Mac senses it and pulls it inside the cabinet. The purpose of bringing it inside the cabinet is to prevent you from inadvertently damaging either the diskette, the drive, or both by removing the diskette at the wrong time. When you are finished with the diskette, you retrieve it via a menu selection.

A few words of caution are in order before moving on. As their name implies, floppy diskettes are flexible. Although Mac's diskettes are more rigid (similar to a tape cassette) than larger floppy diskettes, they still need some care. If they are bent out of shape, the disk drive won't be able to perform read/write functions properly (and may be damaged). Accordingly, handle them carefully and store them inside their jackets in a safe, cool place (covered diskette trays are best). Touching the magnetic surface (which is covered by a movable metal bracket until the diskette is inserted into the disk drive) can damage the information on the diskette. Move the little red "write protect" button into place when appropriate (if you don't want data written to the diskette) and save your data and backup your diskettes frequently.

In general, assume the worst case regarding disasters. For example, both of my books were written on micros using word processing. While writing my first book, during the early chapters I followed the practice of storing my work only at the end of a work session. One Saturday I worked straight through without storing my work. As you recall, when the power is turned off, all data in memory is lost. Can you imagine my frustration when, accidentally, my daughter pulled the power plug for my micro out of the electrical wall socket? The entire day’s effort was lost. As the wise man said, "One ounce of prevention is worth a pound of cure."

THE MACINTOSH DEVICE CONNECTORS

The keyboard connects to the front of the cabinet. Connectors for other devices and accessories are located in the back of the cabinet.

The rear of the cabinet has connectors for a security device, the mouse, an external disk drive, and two serial devices (a printer and modem). (See Figure 1.3)
The Macintosh Keyboard

Mac’s keyboard is attached to the cabinet by a flexible cable that permits you to place it anywhere on a table within four feet of the Mac cabinet. In fact, you can also place it on your lap if that is more comfortable for you.

The keyboard itself, containing 58 keys, is very similar to a typewriter with a few extra keys, as illustrated in Figure 1.4. The Caps Lock key has the same effect on alphabetic keys as does the Shift key; punctuation keys are not affected by the Caps Lock key. The Tab key and the Return key function as arrow keys to enable you to move around the screen. The Tab key moves the cursor to the right and when used with the Shift key moves the cursor to the left. The Return key moves the cursor down, and when used with the Shift key moves the cursor up. The Enter key is used to enter data without moving the cursor. The functions of the other special keys, such as the Command and Option keys, vary according to the application package being used. A separate key pad with numeric and other special keys is available as an option.

The Macintosh Printer

The printer (optional) sold by Apple for the Mac computer is the Imagewriter dot matrix printer. With the Imagewriter, characters can be printed in a variety of sizes, densities, and shapes, including condensed, bold, elongated, en-
Figure 1.4 The Macintosh Keyboard.

Larged, underlined, and proportionally spaced. The Imagewriter does an excellent job with graphics, as illustrated in Figures 1.5 and 1.6. Changing ribbons is particularly easy because the printer uses a snap-in cartridge ribbon, which doesn’t require ribbon threading.

Figure 1.5 Portrait.
Hardware Enhancements

It is impossible to predict the extent to which Apple will offer Mac hardware enhancements in the future. If you are considering buying a Mac, my advice is to assume that there won't be any enhancements. Salesmen will make representations to the contrary, most of which are based on hearsay and speculation; all are based on their desire to sell you a computer. If today's software and hardware meet your needs then by all means consider purchasing a Mac; if not, look elsewhere and at least you won't be disappointed if enhancements are delayed or if some don't materialize at all.

At this point we have concluded the technical portion of this book in which I have been purposefully brief. From here on we'll see what Mac can really do for us. We'll begin by exploring Mac's software environment. After that we'll overview the application packages and then review each one of them in detail, including "how to" examples and ideas for using Mac.

UNDERSTANDING THE MACINTOSH APPLICATION ENVIRONMENT

As I see it, the Macintosh theme parallels that of big sister Lisa—make it user-friendly! Let's see how Mac measures up to this goal by exploring the following topics:
Understanding the Macintosh

• User-friendliness criteria
• Mouse clicking
• Icon symbols
• Windows and scroll boxes
• Pull-down menus
• Software environment and accessories

User-friendliness Criteria

If we are to measure whether Mac accomplishes the goal of user-friendliness, then we should establish the criteria in advance. We need to do this because every microcomputer manufacturer claims that their computer is user-friendly. I'll characterize the criteria for us; if you don’t agree, modify the criteria to suit your own needs.

The first criterion is that the terms used must be expressed in lay (noncomputerese) terms, whose derivation is the common English language. For example:

• If I want the computer to print some rows and columns, I don’t want to enter “/PA1.C10.”
• If I want to correct a misspelled word, I don’t want to enter “ESCAPE,C” or “CONTROL-G.”
• If I want to make a back-up copy of a file on my diskette, I don’t want to enter “COPY A:LETTER.TXT B:LETTER.BAK.”

My second criterion is that I must be able to learn the software quickly and easily. After all, I want to become productive, not make a career out of mastering the software package. Accordingly, I don’t want to refer continually to a user’s manual to figure out how to do something. I’m willing to read through the manual once; after that, I’d prefer never to see it again (I’ll settle for referring to it once a month!). I’m reminded of a popular software program that has two user manuals. The first manual appears to be a tutorial to give you an overview; it is over 100 pages long! To go through the entire tutorial would take you several days or more. You would probably be ready to retire by the time you finished the second manual.

My third and final criterion for user-friendliness is that the system must be visual and centered. By that I mean I want to know where I’m at. I don’t want the focus of my attention (my work product) to be replaced continuously by a series of submenus within which I become lost. I want to use my intuition to accomplish tasks, and for that purpose “one picture is worth a thousand words.”
Ideally, I would simply talk to my computer. It would be smart enough to understand my every word as well as the tone of my voice. In fact, my computer should anticipate what I want to do, much as “Kitt” does for Michael Knight on the television series, “Knight Rider.” Because I can’t quite afford a computer that smart, I’ll have to settle for one with which I’ll communicate through its keyboard. With that in mind, let’s see what Mac’s operating environment is like.

Mouse Clicking

We saw earlier that the mouse is used for selecting objects and performing other tasks. When the mouse is used, it replaces functions that would otherwise have to be performed using the keyboard. It is this very characteristic that eliminates the need to memorize cryptic commands. It also permits us to move around the screen much faster than with the arrow keys. To illustrate these features, let’s use examples.

Suppose I want to perform a task such as opening a file. Instead of entering a cryptic command, I simply move the mouse until the arrow that it represents points to a symbolic representation of my file. I click the mouse and behold! The file is opened for me. Now, let’s see what else mouse movement can do for us.

The display portion of the screen itself is a rectangle of rows and columns. The coordinate at which I am presently situated is referred to as the cursor location. The cursor itself may be visible or invisible. When it is visible, it may be represented by a symbol (more on this later); for now, let’s assume that it is a flashing rectangle the size of a text character. Imagine that the cursor presently resides at the intersection of row 33 and column 10. For whatever reason, suppose you would rather have the cursor at row 6, column 40. Depending on the type of computer, you could generally get there in one or both of two ways. First, you could certainly get there by pressing the up arrow key 27 times and then pressing the right arrow key 30 times! If you had a home key, you could press it first to get to row 1, column 1; then you would press the down arrow key five times; and, finally, you would press the right arrow key 39 times to get to column 40 for a total of 45 keystrokes. Not much better! Wouldn’t it make sense to simply move the mouse until it points to where you want to be and then simply click the mouse button? Chalk up number two for “MacMouse.”

Icon Symbols

An icon is a picture or symbolic representation of an object. The icon and our friendly mouse replace the cryptic commands at which I have been throwing darts. While the icons themselves may vary according to the software package, icon examples are illustrated in Figure 1.7. Please look at it before continuing reading.
Notice that the icons are symbolic representations of familiar objects such as folders, a clipboard, and a trash can, which is itself a file for unwanted documents. Manipulating these objects consists of moving the mouse until it points to:

- The folder: click the mouse button twice to open it.
- An obsolete document: click the mouse button and hold it down. Then "drag" the unwanted document to the trash can and let go of the mouse button to trash the document.

I've discussed the use of a mouse with numerous people. Those who say that it is not a significant benefit all have the same comment—using a mouse requires that one of your hands leave the keyboard. Fair enough and true! I'll leave it up to you to judge whether you are better off using a mouse or having to:

- Press arrow keys 50 or more times.
- Memorize cryptic commands such as "/PRA1.L30."

Figure 1.7 Icon Examples.
Before moving on, I have been requested by MacMouse to throw out another alternative to you. MacMouse points out that Apple allows you to pick and choose. Neither the cursor movement keys nor the keyboard commands have been eliminated. As to the latter, Mac gives you a simplified command set in which single letters can be used to substitute for the mouse. The benefit to you is that you can quickly become productive using the mouse. As you become more familiar with the package, you can selectively substitute keyboard commands if those are faster. However, as MacMouse points out, you are not forced to do so.

**Windows and Scroll Boxes**

We have seen how icons help us through visual imagery and intuitive understanding. Now it’s time to see how we work with the documents represented by icons.

Using the mouse to point to a document and clicking the mouse button twice opens the document so that we can work with it. Figure 1.8 shows us what the document looks like when it has been opened.

Notice what the screen looks like in Figure 1.8. The visible portion of the document is referred to as the “window.” At the top left of the document is a little box; clicking in this box closes the window. At the top and center of the document is its name, which was previously displayed under the icon (more visual information so that you always know where you are and with which document you are working). On the right-hand side of the screen are:

- A little black rectangle
- An arrow pointing up
- A square with a gray area below it
- The gray area
- An arrow pointing down
- Another square with a square inside it

By pointing the mouse arrow to the little black rectangle, pressing and holding the mouse button down, and “dragging” the mouse arrow down the screen, you can split the view of the document into two (see Figure 1.9). Two views are helpful if you want to see information that would otherwise scroll off the screen or if you want to move or otherwise alter a portion of a document. The mouse eliminates the need to memorize cryptic commands to perform this task and enables it to be performed much more rapidly. The arrows and gray
area enable you to move up or down a line at a time and a view at a time, respectively, by clicking them with the mouse arrow.

The square with the gray area below it is a scroll box and the gray area is the scroll area. Holding the mouse button down while clicking in the scroll box and dragging it to the bottom of the scroll area moves the view to the bottom of the document. You can also stop and let go of the mouse button proportionately anywhere in-between.

The little square with the square inside it is a window-size control box and, you guessed it, permits you to adjust the window size. You would want to make it smaller in order to:
Figure 1.9 An Open Document Split into Two Views.

- See more than one document on your screen (as you see more than one on your desk top) at the same time.
- Move or copy some of one document into another while the documents are open.
- Copy a document (by duplicating its icon) into another folder.

The size of the window is adjusted by holding down on the mouse button while the mouse arrow is in the window-size control box and dragging the corner in any direction. Figure 1.10 illustrates the various shapes that can be made to permit viewing multiple documents.

**Pull-down Menus**

Pull-down menus complete the circuit of eliminating cryptic commands. They are the primary means by which we accomplish important tasks such as:
• Copying portions of documents
• Duplicating documents
• Eliminating unwanted documents
• Creating new documents and folders
• Selecting character size for screen display or printing
• Selecting special character features such as bold, underlining, etc.
• Printing documents
• Saving documents and filing them away
• Backing up files and entire diskettes

The traditional approach to performing functions such as those listed are cryptic commands or nested submenus. MacMouse performs these functions using pull-down menus. Holding down the mouse button while pointing at any of the menus in the menu bar causes the menu to appear as illustrated in Figure 1.11. With the mouse button held down, we can move the mouse arrow down through the menu. When the arrow points to a function, that function is highlighted. To perform a highlighted function, all we have to do is let go of the mouse button. Mac does the rest.
SOFTWARE ENVIRONMENT AND ACCESSORIES

Apple has encouraged software developers to program applications for Mac. Recognizing that software firms would use different approaches, Apple concluded (correctly so) that multiple approaches could be confusing to users. Accordingly, Apple created a standard Mac development environment. The idea is that the user should expect to see similar pull-down menus with common commands for identical functions across all applications. We'll discuss these commands in detail in the application chapters. In general, you should expect to see three very similar pull-down menus in every application:

- An edit menu, which contains common editing commands such as Copy, Cut, and Paste and a clipboard for transferring data.
- A file menu, which contains common commands to (1) obtain information about documents and (2) save and print documents.
• An Apple menu, which contains, among other things, software accessories always available to you:
  • A four-function calculator.
  • A clock for maintaining time and date information as well as an alarm that will ring at your specified time.
  • A note pad for keeping small notes.

Particularly noteworthy and novel is the “clipboard.” The purpose of the clipboard is to enable us to select some or all of the data from one application and use that same data in another application. In addition, it is used for making additions and deletions within an application. You can copy, for example, a paragraph or formula to the clipboard and “paste” it in another location. We’ll discuss the clipboard again in subsequent chapters.

There are many more features to be discussed, and we’ll explore them all in subsequent chapters. At this point we are ready to determine whether Mac accomplishes our goal of creating a user-friendly environment. Our criteria were:

• Easily understood terminology
• Ability to learn easily and quickly
• Visual imagery and focus

I’ll leave it up to you to make the determination. If you are still not sure, reserve judgment until you have read the application chapters. Your individual needs may not require the use of all the Mac applications. To facilitate your reading, we’ll preview each of them.

APPLICATIONS OVERVIEW

Understanding Application Approaches

It doesn’t make sense for you and me to learn a programming language and write a program every time we want to perform a task. Our time is better spent on more productive things, and we should leave the programming function to those more qualified than we. Recognizing this, programmers use two approaches to developing application software:

• Specific-purpose packages
• General-purpose software packages
SPECIFIC-PURPOSE SOFTWARE PACKAGES

Specific-purpose software packages consist of programs written to perform specific tasks. Examples include accounting software such as accounts receivable or an airline reservation system.

GENERAL-PURPOSE SOFTWARE PACKAGES

General-purpose software packages perform specific functions, but they leave a great deal of flexibility regarding the specific tasks to be performed. In effect, these packages can be thought of as providing a framework within which users can define the specific tasks to be performed. It is this group of software packages for the Macintosh that we are interested in.

The Macintosh General-purpose Software Packages

There are four general-purpose packages that are of potential interest:

- MacPlan
- MacWrite
- MacChart
- MacPaint

MacPlan

MacPlan is an electronic spreadsheet and financial modeling tool that makes mathematical calculations for you, lets you quickly review calculation results, helps you model "what if" questions, and facilitates better financial decision making.

MacWrite

MacWrite is a word processor and text editor that can enable you to produce letters, articles, memos, etc. faster and better than using traditional tools such as pen, pencil, and typewriter.
MacChart

MacChart is a graphics tool that enables you to create a wide variety of graphics shapes, such as bar and line diagrams and pie charts.

MacPaint

Whereas MacChart focuses solely on numeric data, MacPaint enables you to produce free-form charts or pictures.

The format for each of the application chapters is similar. Each chapter begins with a discussion of the tool itself and what it can do for you. Next, the specific application features are discussed in detail followed by a work-product ideas review section. Each chapter concludes with sample applications that show you "how to" effectively and quickly implement use of the tool. If you aren't sure which of the tools you can or should use, read the first section in each chapter in which the specific benefits to be derived are discussed. With that in mind, let's see what Mac can do for you.
Chapter 2
USING MacPlan
Like it or not, we all have to work with figures during the year. Each month we have to balance our checkbooks; if you have a personal budget, listing actual expenditures and comparing actual to budget can be a time-consuming process. Periodically, there are investment decisions to be made such as buying a car, devising a savings plan, etc., all of which are time-consuming tasks. Annually, there is the abhorrent task of gathering our income tax data. Finally, many of us work with figures at the office either from the standpoint of original preparation or analyses. If we had a better tool to help us, much of the drudgery could be eliminated. That’s where MacPlan comes in. In this chapter we’ll explore the following topics:

- What MacPlan can do for you
- Working with MacPlan features
- Getting formulas to work for you
- Ideas for MacPlan applications
- Case study—building a MacPlan spreadsheet

WHAT MacPlan CAN DO FOR YOU

MacPlan is an electronic spreadsheet and modeling tool that can (1) eliminate the need for you to perform mathematical calculations and let you review calculation results quickly, (2) help you model answers to “What if” questions, and (3) facilitate better financial decision making. That sounds pretty good, but how is MacPlan going to do all these things? To answer this question we’ll begin by examining how MacPlan works and then elaborate on how these benefits are derived.

MacPlan Overview

MacPlan is an electronic spreadsheet that can be pictured as a columnar work sheet (I’ll refer to it as the “MacSheet”) with many rows and columns as illustrated in Figure 2.1.

Each intersection of a row and column is referred to as a “cell” and is designated by its row and column numbers (e.g., R1C1, which stands for row 1, column 1). Each cell is capable of storing numeric constants, formulas, dates, words, and other characters. The formulas are the means by which you perform mathematical and “what-if” calculations. Let’s illustrate the concept:
In this example, column 1 contains the captions (e.g., cell R2C1 contains "sales"). Column 2 contains the actual data for year “19X1.” However, note that cell R4C2 has a formula in it. Instead of entering the result of subtracting cost of sales from sales, you can enter the formula R2C2-R3C2. This formula instructs the computer to subtract the value contained in cell R3C2 (60) from the value contained in cell R2C2 (100). Now suppose that you want to forecast figures for “19X2.” The data in column C illustrate how that might be done. Suppose you forecast a 10 percent increase in sales and a 9 percent increase in cost of sales. The formulas in cells R2C3 and R3C3 instruct the computer to multiply the constants 1.10 (10 percent increase) and 1.09 (9 percent increase)
by the values contained in cells R2C2 and R3C2, respectively. Cell R4C3 contains the formula to calculate gross profit for "19X2." This example illustrates how you can let the computer perform mathematical calculations for you. Now as to "what-if" calculations, suppose you want to change the sales assumption to a 15 percent increase over "19X1." Simply change the constant in cell R2C3 from 1.10 to 1.15, and the computer recalculates all the results.

The remaining key concept deals with duplication of formulas. In the preceding example, suppose you also want to forecast figures for 19X3 to 19X6, including both dollar amounts and percentages. If you were using pencil and paper, you would (1) enter the actual figures and percentages for 19X1, (2) determine the assumptions, and (3) calculate the dollar amounts and percentages for the five-year forecast period. What happens if you want to vary the assumptions? You have to erase the results and recalculate all the figures, a time-consuming process. Suppose you want to change the assumptions once more. Erase and recalculate again. Whoops, the paper just tore from erasing it too much: result—frustration and inefficient use of time. Is there a better way? You bet! Use MacPlan. Enter the dollar amounts for 19X1. Then enter formulas for the related 19X1 percentages and 19X2 dollar amounts. Copy the formulas and let the computer do the rest. Want to change an assumption? Simply change a formula and let the computer recalculate. When you are finished, store the model and use it again the next time you want to forecast.

Benefits to be Derived from Using MacPlan

Now that we have a conceptual understanding of how MacPlan works, we can explore the benefits to be derived:

- Eliminate manual calculations
- Answer "What-if" questions
- Facilitate better financial decisions

ELIMINATE MANUAL CALCULATIONS

Formulas are a critical element in the MacSheet. They can be used to automatically calculate column and row subtotals, grand totals, and percentages, look up values by reference to tables, calculate net present value by discounting a series of positive and negative cash flows, calculate the average value of a series of figures, compute effective interest rates, and much, much more. To the extent that you let MacPlan perform all the math for you, MacPlan will save you time, a commodity of which we have precious little. In this regard, time to be saved includes:
UNDERSTANDING THE MACINTOSH

- Original preparation time
- Time to be devoted to checking the accuracy of manual calculations
- Time to find and correct manual errors

ANSWER “WHAT-IF” QUESTIONS

Whether at home or in the office, we are continuously faced with “what-if” questions. A what-if question seeks answers to financial alternatives and frequently begins with the phrase “what if. . . ,” “what is the effect on. . . ,” or “how much. . . .” Examples include:

- What is the effect on our monthly budget if we purchase new appliances?
- What if inflation increases by X percent instead of Y percent?
- What is the effect on our bottom line if we increase selling prices?
- How much more do we have to save if college tuition increases to X?
- How much less will the monthly payments be if the interest rate decreases to X?

Answers to what-if questions require us to recalculate results. It was time-consuming and fatiguing enough to have made the calculation manually the first time. Changing one or more of the variable amounts requires that we calculate the results all over again. Time constraints are not the only consideration. Consider the possibility of making errors in the calculations. Experience demonstrates that most math errors result from changes. We’ll leave exploration of that phenomenon to the psychologists. Suffice it to say that there must be some instinctive rebellion or fear that results from the thought of having to recalculate, which causes us to make errors frequently. Doesn’t it make sense to let the computer do both the original math and also the recalculation? After the variables and the formulas have been entered, all you have to do is enter the new variables and MacPlan instantaneously gives you the results. Further, MacPlan doesn’t make mistakes.

FACILITATE BETTER FINANCIAL DECISIONS

Whether by necessity or choice, we sometimes make decisions that otherwise would not have been made had we more or better information. Time constraints are certainly one of the factors. Faced with deadlines, we are forced at some point to quit making calculations and commence the decision-making process. If we had more time, we might have made more calculations. On other occasions, we have enough time to extend our analysis but are simply too
fatigued from it all to continue the math exercise. Finally, the calculations may be sufficiently complex that we forego them and substitute approximations. Having explored what MacPlan can do for us and why, it's time for MacMouse to take over and acquaint you with the MacSheet details.

WORKING WITH MACPLAN FEATURES

Our end product is a printout or a screen display. In this section we'll explore the steps that lead up to obtaining our end product. Accordingly, our topics are:

- Creating a MacSheet document
- MacPlan concepts
- Modifying MacSheets
- Calculating results
- Protecting MacSheets
- Printing MacSheets
- Saving MacSheets
- Shortcuts
- Transferring MacSheet data

Creating a MacSheet Document

To create a blank MacSheet you will need to start up ("boot") the MacPlan program. Insert the MacPlan diskette into the built-in drive and turn on the power switch. When the start-up program has been loaded, select MacPlan, using the mouse.

You should now see a blank MacSheet with the word "Untitled" above the row numbers as illustrated in Figure 2.2. We will give the blank MacSheet a name a little later.

MacPlan Concepts

To get started using MacPlan simply requires that you understand the MacSheet components and how to enter data.

UNDERSTANDING THE MACSHEET COMPONENTS

Figure 2.2 illustrates the components of a MacPlan window. At the top of the screen is the menu bar, which contains pull-down menus. We will discuss the
pull-down menus as we go along. Immediately below the menu bar is a status panel line with two boxes. The box on the left indicates the cell currently selected, and the box on the right (with the blinking cursor) displays that cell’s contents (now blank). Below the status panel is our view of the MacSheet.

At the bottom and right-hand sides of the screen are the scroll areas and view-control devices discussed in Chapter 1. These devices enable you to move around the document and split the window into multiple views.

**ENTERING DATA**

MacPlan uses three types of data:
In addition to containing the above data types, a cell may contain a formula. A formula consists of one or more data types, references to other cells, and arithmetic and logic operators. To illustrate both the use of formulas and the process of entering data, we'll use the following example:

<table>
<thead>
<tr>
<th></th>
<th>1</th>
<th>2</th>
<th>3</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td>Amount</td>
<td>Percent</td>
</tr>
<tr>
<td>2</td>
<td>Sales</td>
<td>100000</td>
<td>100</td>
</tr>
<tr>
<td>3</td>
<td>Costs</td>
<td>56000</td>
<td>RC[-1]/R[-1]C[-1]*100</td>
</tr>
<tr>
<td>4</td>
<td>Profit</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Once a cell has been selected, it will then be highlighted and ready for you to enter data. In our example, select the cell at the intersection of row 2, column 1 (abbreviated R2C1). Enter the label “Sales” and press the Enter key. The label has then been accepted and should be displayed both in its cell and in the status panel (if not, repeat the process). Next, select the cell R3C1, enter “Costs,” and press the Return key. Pressing the Return key accepts the data and selects the cell immediately below it. Next, enter “Profit” and press the Enter key. Notice that when you enter data with the Enter key, the cursor stays in the currently selected cell. Our row headings are now complete, and we are ready to enter the headings. Using the mouse, select cell R1C2, type “Amount,” and press the Tab key. The Tab key accepts the data and moves the cursor to the right. Type “Percent” and press Return. Our column headings are now complete.

We are ready to enter the numeric constants and formulas. You should presently be in R2C3 (if not, use the mouse to select this cell). Type 100 and press down on the Shift and Tab keys at the same time. Pressing these two keys at the same time accepts the data and moves the cursor to the left. Now type the value 100000 (no commas) and press the Return key. Now enter the value 56000 in cell R3C2 and press the Tab key to get to cell R3C3.

The next entry is our first formula, RC[-1]/R[-1]C[-1]*100. It may look like Greek to you now, but in a moment it should become much clearer. To enter a formula, the formula itself must be preceded by an equals sign (“=”). Enter the equals sign and type the formula exactly as you see it (the bracket keys are immediately above the quote/apostrophe key and are lower case symbols). If you have typed it correctly, the figure 56 will be displayed in the cell while the formula is displayed in the status panel.

Let’s break up the formula into its component parts:
UNDERSTANDING THE MACINTOSH

- RC[−1]—This part says to get the value in the same row (because it isn't followed by a row number in brackets) but one column over to the left. That value is 56000. The −1 tells us two things:
  - The minus sign tells us the cell we want is to the left (if it were a plus sign, it would be to the right).
  - The one following the minus sign tells us to move one column.
- /—The division sign
- R[−1]C[−1]—This part says to get the value that is one row up and one column to the left. That value is 100000.
  - R[−1] tells us the cell we want is one row up.
  - C[−1] tells us the cell we want is one column to the left.
- *—The multiply sign.
- 100—The value 100.
- Putting this all together, the formula means:

\[
\frac{56000}{100000} \times 100
\]

Perhaps you are wondering why we didn’t use the formula R3C2/R2C2*100 to do the same thing. Actually, we could have! Both of these formulas do exactly the same thing. You can enter a formula with cell references either by explicitly stating the cell’s coordinates or by indicating where the cell is relative to the currently selected cell. The latter method is referred to as “relative referencing.” While it takes a little longer to enter, it has a very important function. Suppose we wanted to

- Add two more columns (4 and 5) with amounts and percentages
- Copy nonrelative formulas in columns 2 and 3
- Paste these formulas into columns 4 and 5

Cell R3C5 would have a formula in it identical to that in R3C3. The references would be to column 2, and that’s not what we would want in R3C5. Rather, we would want the references in R3C5 to be to column 4. By making the cell references relative when appropriate, we can copy and paste them into other cells, and the references will be relative to the appropriate cells. Congratulations! You have just learned one of the most important things about MacPlan—The concept of relative referencing. Let’s continue with our example and practice this new concept.

Our example now looks like the following (on your screen you will see the figure 56 in R3C3):
What we want to do now is enter a formula to calculate profit (sales - costs) using relative cell references. The formula for cell R4C2 to calculate profit would be

\[ R[-2]C - R[-1]C \]

The formula says to get the value in the cell that is two rows up and in the same column and subtract from it the value in the cell that is one row up and also in the same column. Select R4C2, enter the formula (don’t forget the equals sign first), and press the Enter key.

Our last step is to calculate the percentage that goes in cell R4C3. We could enter a formula again, but there is a better way. Do the following:

• Enter the Edit menu using MacMouse and, while holding the mouse button down, select the Copy command.
• Select cell R4C3.
• Reenter the Edit menu and select Paste.

If you followed the steps correctly, your MacSheet should display the value 44 in R4C3. Notice the formula in the display panel. Now select R4C2 and look at the formula in the display panel. They are identical, and both are based on relative referencing. Pat yourself on the back. You’ve just mastered entering data, relative cell referencing, and copying and pasting formulas. From here on in it’s all downhill. The rest of our work will be easy. Keep your MacSheet on the screen; we’ll refer back to it later.

**Modifying MacSheets**

In this section we’ll examine the two ways in which you can modify MacSheets:

• Modifying the contents of a MacSheet
• Modifying the appearance of a MacSheet
MODIFYING THE CONTENTS OF A MACSHEET

When you modify the contents of a MacSheet you actually change the data contained therein. This process is referred to as editing the MacSheet. We previously saw that we could use formulas to get Mac to make calculations for us and copy formulas for us as well. As we'll shortly see, MacPlan's edit features will do that for us and much, much more.

With minor exception, all the MacPlan edit features begin with the same two steps. First, a cell or group of cells is selected. Second, a feature is selected from MacPlan's edit menu. Point your mouse to the word "Edit" at the top of the screen and hold the mouse button down. Your screen should display the pull-down menu illustrated in Figure 2.3.

Figure 2.3 Edit Menu.
With the mouse button held down, move the mouse arrow down through the menu. As you move through the menu, MacMouse will tell you whether you can select a menu item by highlighting that item in reverse video (black on white). If a menu item cannot be selected at this time, the menu item itself will display in gray. For example, it doesn't make sense to select a menu item before a cell has been selected. MacMouse knows this and tells you by displaying menu items in gray. At other times, some of the menu items aren't applicable based on the cells you selected; accordingly, MacMouse displays them in gray.

Cells are selected for editing as follows:

- To select a contiguous group of cells in the same row or column, begin in the leftmost or uppermost cell and drag the mouse to the last cell in the row or column.
- You may also select cells from multiple rows and columns, provided that they form a rectangle. For example, to select all the cells in columns 1 through 10 located in rows 1 through 15, drag the mouse from R1C1 to R15C10 and release the mouse button. The selected cells will be highlighted and form a rectangle.
- To select all cells in either (a) one or more rows or (b) one or more columns, point the mouse arrow to the first row or column number, press down on the button, drag the mouse to the last row or column number, and then release the mouse button.
- To select all cells in the document, enter the Select menu and release the mouse button when the arrow points to the menu item, "Select all."

To make a single copy of one or more cells, use the above procedures for selecting cells. To make multiple copies of one or more cells, follow the instructions in the Fill Down/Right discussion below.

With that introduction, let's explore the features in the Edit menu.

**Cut.** Cut removes the selected cell(s) from the worksheet and places them on the clipboard. Use cut to either (1) eliminate entire rows or columns—the rows (columns) following the cut rows (columns) will move in to fill the void or (2) move entire rows or columns elsewhere in the same MacSheet.

Be particularly careful to guard against cutting rows (columns) when other cells refer to them. The cells containing references to the cut cells will display "# REF!" to tell you there is a problem (see Undo below for recovering from these types of problems).

**Copy.** Copy places a mirror image of the selected cell(s) onto the clipboard. The original cells are not affected. Use copy when you want to duplicate data contained in the cell(s) and place a copy elsewhere in the same MacSheet or another MacSheet.
Paste. Use Paste to place one or more copies of the cells on the clipboard into a MacSheet. Be particularly careful if there are cell references in any of the cells on the clipboard. Absolute references that were either Cut or Copied and relative references that were Copied, will be duplicated exactly when pasted into the new location. Relative references that were Cut will be adjusted when they are placed in the new location. For example, if row 2 has been cut and is on the clipboard, and the cells previously contained references to row 1, if pasted to row 10, the references will be adjusted to continue to refer to row 1.

Make sure that you select the new location before you select Paste. After selecting Paste, a copy of the cells remains on the clipboard. Accordingly, you can Paste the same clipboard cells into more than one new location.

When selecting the new location for Pasting, it is not necessary to select all the cells. You can select just the starting location, and a floating menu will appear. You will then be given an opportunity to indicate what you want to do.

Undo/Redo. Undo/Redo is a group of commands that permits you to reverse the effect of having performed any other command in the Edit menu and, once having reversed the effect, you can also restore it. Thus, if for example you accidentally Cut something you didn’t intend to Cut, you can recover from the error. That is, whatever you cut will be replaced. Then, having Undone the Cut, you could also Redo the Cut. These commands also work with Copy, Paste, Blank, and Sort.

Show Clipboard. When you Cut or Copy from your MacSheet, a copy of the most recently Cut or Copied cells are placed on the Clipboard. They remain there until you perform the next Cut or Copy function, at which time they are replaced. The Show Clipboard feature will tell you how many cells are currently on the Clipboard.

Paste Name. The Select menu contains an option to give a cell a name that you can then refer to in formulas. In addition, the Edit menu permits you to Paste the Name. To illustrate, let’s use our example. Select R4C2, which is the amount of profit. Select Define Name from the Select menu. You will be asked to provide a name; enter the name “PROFIT.” Now select R1C4, enter the Edit menu, and select Paste Name. A floating menu will appear and you will be asked to select a name; note that the menu shows the names you have selected. Click in the box for PROFIT and then click in the OK box. Now look at cell R1C4. It contains the formula, PROFIT, and the value displayed is 44, which is the value of R4C2. This is a handy feature because it permits you to use meaningful names instead of cell references.

Paste Function. A little later we will explore MacPlan’s built-in functions. MacPlan will show you the shopping list of functions when you select this feature; you can then check the box for the desired function and it will be pasted
into your selected cell. At this point I'll just point out to you that functions require the entry of one or more variables. Once MacPlan has pasted your desired function into a selected cell, MacMouse will help you paste in the variable. Just select the cells and MacMouse will paste them in. That's a pretty smart mouse!

**Fill Right/Down.** The Fill Feature enables you to copy (1) a single cell into a range of cells in the same row (Fill Right) or column (Fill Down) or (2) a range of cells in the same row or column into one or more adjacent areas. For example, you can Copy rows 1 through 10 in column 1 to rows 1 through 10 in columns 2 through 20 using Fill Right. To use the Fill features, first Copy the target cell(s). Then select both the cells that you want to copy and the cells to be copied into, enter the Edit menu, and select the Fill feature. MacPlan will then place exact copies of the target cell(s) into the destination cells.

**Clear.** If you have entries that you want to eliminate, select the cells, enter the Edit menu, and select Clear. The contents of the selected cells will be eliminated.

**Sort Ascending/Descending.** Yes, MacPlan also sorts as well. Use MacMouse to select (1) a range of cells in a column or row or (2) entire rows or columns. Enter the Edit menu and select whichever sort sequence (ascending or descending) you would like. MacPlan will then sort them for you. In our example, select R2C1 through R4C1 (the row labels), enter the Edit menu, and select Sort Ascending. Rows 2 through 4 are sorted based on alphabetical order of these labels. Now look at the formula for profit in column 2; its been adjusted based on the newly sorted sequence. Reenter the Edit menu and select Undo Sort, and they will be put back in their original order.

**Absolute/Relative Reference.** Recall earlier in our example that keying in relative references looked like it might be a tedious task. Here's another alternative for you. You could key in the explicit (absolute) reference, enter the Edit menu, and select Relative Reference. Your formulas would all be converted for you. No muss, no fuss! The Absolute Reference and Relative Reference commands convert relative and absolute references into absolute and relative references, respectively. To use this feature, create an insertion point within the reference in the Formula Bar. Then select this feature in the Edit menu and MacPlan will convert the reference.

You may also insert blank rows or columns. To insert one or more blank rows (columns), point the mouse arrow to the line dividing two rows (columns) within the area of the row (column) number. Press down on the shift key and then press down on the mouse button. The cursor will change from a cross to an arrow. Drag the mouse down (rows) or to the right (columns). Notice that the row (column) numbers move to make room for the new row(s) or column(s).
Release the Shift key, and the mouse button and MacPlan will complete the insertion process. If you have formulas with references to other cells in your MacSheet, MacPlan will automatically adjust them.

The Edit menu features described previously make MacPlan a very useful and powerful tool. For example, consider our example from Figure 2.1. We could copy columns 2 and 3 and Paste them across columns 4 through 15. Over each group of two columns we could enter labels for January through December and Grand Total, respectively. Just that easily we could create a MacSheet for the entire year.

It may be necessary at times to modify the contents of a cell. For example, you may type the wrong character or want to change a formula. If you have not yet pressed the Enter key, you can press the Backspace key to erase erroneous characters and then continue on. You can also use the Undo feature. After you have pressed the Enter key, corrections may be made by selecting the cell and doing one of the following:

- Use the Undo feature;
- Type the new data and enter it. The old data will be replaced; or
- Position the mouse cursor within the display panel to the left of the first character ("the insertion point") you want to replace. Hold down the mouse button and drag the mouse to the right until all of the characters you want to replace are highlighted. Then release the mouse button and select cut from the Edit menu. The unwanted characters will disappear. Type the new characters and press the Enter key to insert them.

You can also transfer a portion of one cell to another as follows:

- Select the first cell.
- Locate the insertion point and click the mouse button.
- Hold down on the mouse button, drag the mouse to the right until all the data to be transferred is highlighted, and release the mouse button.
- Enter the Edit menu and select copy.
- Locate the new insertion point (use the formula area for formulas) and click the mouse button.
- Enter the Edit menu and select Paste, Paste Adjusting, or Paste Values as appropriate.

MODIFYING THE APPEARANCE OF A MACSHEET

MacPlan provides you with many features to enhance the appearance of your MacSheet both on the screen display and as hard copy output. Referred to as "Format" options, these features enable you to create a professional looking
document. Menu items and cells are always selected in the manner previously described. The Format features in the Format menu are illustrated in Figure 2.4.

**Decimal points, commas, and dollar signs.** Cells can be formatted to display numbers according to your preferences. The initial setting, General display, does not use dollar signs or commas and does use decimal places. You can selectively increase or decrease the number of decimal places and insert dollar signs and commas or display the numbers in scientific notation. Examples follow:

![Figure 2.4 Format Menu.](image-url)
Dollar: Amounts are preceded by the dollar sign; negative numbers are shown in brackets.

Percent: The cell contents are multiplied by 100 and the % sign is displayed.

No decimal: Numbers are displayed to the nearest whole number.

Decimal: Decimals are displayed up to a maximum of 14 decimal places.

Scientific: Scientific notation always displays a one-digit number to the left of the decimal point. The number of decimal places will be selected from a floating menu and is followed by a positive or negative exponent. The exponent indicates how many places the decimal point is to be moved to the left or right to convert to decimal notation. For example, the number 678.25 in scientific notation would be displayed as 6.7825E + 2 (move the decimal point two places to the right to convert to decimal notation).

Bar graph: The cell is filled with a pattern in proportion to its size.

Fixed decimal: A floating menu is used to select the number of decimal places you want.

Display Alignment. Unless you choose to change them, labels and numbers are always aligned to the left and right sides of the cell, respectively. Use the menu items Align Left, Align Center, and Align Right to change how they display and print to suit your preference. Select the cells (including blank cells) you wish to change and then select your option in the Format menu.

Column Width. Column widths are preset to 13 digits wide. You can select Column Width from the Format menu and make them range from 0 (invisible column) to a single column as wide as the entire 63-column width of the MacSheet. If a number is too wide to display in the width of the column, it will be displayed in scientific notation.

When you revise the number of decimal places for display, the actual number of decimal places maintained internally by MacPlan remains unchanged. Accordingly, calculated totals may be slightly different than those based on amounts displayed due to the effects of rounding.

The Options menu, illustrated in Figure 2.5, also contains three features that affect the appearance of either the printed output or the screen display.

Freeze/Unfreeze Titles. To prevent row or column headings from scrolling off your screen, select a row or column to the right or below the column or row you wish to prevent from scrolling off the screen. Then enter the Options menu and select Freeze Titles. Frozen titles may be unfrozen by use of the Unfreeze Titles command.
Page Breaks. MacPlan displays a series of broken dashes representing page boundaries for the bottom and right-hand side of each printed page. You cannot move MacPlan's calculated page boundaries to cram more rows or columns onto a page since they would run generally off the page anyway. However, you can insert page marks to print fewer rows or columns if that will enhance your printed output. Naturally, you can remove a page mark you have inserted if you don't like the results.

Show Formulas/Values. The normal mode is to show formulas in the display panel and the results (values) of those formulas in the MacSheet. At times, you will want to print and/or display the formulas in the MacSheet. Enter the
Options menu and select Show Formulas; when you wish to return to normal display, select Show Values.

Calculating Results

In this section we'll explore automatic recalculation of MacSheets, circular references, and iterative calculations.

AUTOMATIC CALCULATION

When you create a new MacSheet, MacPlan is set to recalculate the entire MacSheet automatically every time a value changes. While automatic recalculation is a very handy feature, it can be very distracting and time consuming if there are numerous values in your MacSheet and recalculation takes place every time a single value changes. Recognizing this, MacPlan provides you with a feature, Manual Calculation, which can be selected from the Calculate menu illustrated in Figure 2.6.

Should you find the automatic recalculation feature distracting or time consuming, select Manual Calculation from the menu; however, don't forget to select Calculate Now when you are finished. Otherwise, your MacSheet won't be accurate.

CIRCULAR REFERENCES

A circular reference occurs when a cell contains a reference either directly or indirectly to itself. For example

- If the cell in R1C1 contains the formula R1C1 + 1, this is a direct reference and MacPlan will alert you to it.
- If R1C1 contains the formula R2C1 + 1, and R2C1 contains the formula R1C1 + 1, this is an indirect circular reference that is also detected by MacPlan. You will be informed that MacPlan can't resolve the circular request.

MacPlan will try to detect other types of reference problems as well. For example, a cell in column 1 might refer to a cell above it in column 2, which in turn refers to a cell that has already been calculated in column 1. If you see the error message "#Value!," MacPlan is alerting you to a reference problem.

Here is a technique you can use to minimize the possibilities of indirect circular references (as well as generally decrease recalculation time and logic errors). Structure your layout such that references to other cells are always to
cells located to the left or above the dependent cell. MacPlan begins recalculation in row one, column one, and works downward and to the right. Unless you use the Iteration feature discussed below, MacPlan uses whatever results are available when the cell is calculated. So, if the results needed by a dependent cell are already available, MacPlan will provide a correct answer. If those results are not available, your MacSheet will contain incorrect results. For this reason, you should always use the strategy described above.

ITERATIVE CALCULATIONS

MacPlan also has the ability to perform iterative calculations. Iterative calculations involve intentional circular references in which two or more cells depend on one another. In addition, you can create your own criteria for recalculation of
your MacSheet using the Completion Test features in the Calculation menu. For details on these subjects, refer to the application user manual.

**Protecting MacSheets**

We noted earlier that the Undo/Restore commands in the Edit menu are powerful tools to help you prevent and correct inadvertent errors. In addition, to minimize further the possibility of entering something in the wrong cell, you can use the Protection features contained in the Options menu previously illustrated in Figure 2.5.

In general, use the Protect Document feature to safeguard a backup copy of a document or to help prevent someone else from altering your MacSheet. A Protected MacSheet will display menu selections in gray (not accessible). When you select Protect Document from the Options menu, you will be asked for a password:

- If you enter a password, you will need that password to Unprotect your MacSheet or you won't be able to make changes to it.
- You can press the Enter key instead of entering a password. The MacSheet will appear to be protected by password, but in fact you will be able to Unprotect it in the Options menu without entering a password. Use this feature when you are simply Protecting a MacSheet from your own inadvertent errors.

In addition to Protecting an entire MacSheet, you can Protect specified cells. Here's how. Select the cell or range of cells you want to Protect. Enter the Options menu and select Remove Cell Protection. Then reenter the Options menu and select Protect Document. The specified cells will be underlined in your MacSheet and can be modified. All other cells are Protected and cannot be modified until the document is Unprotected (don't forget your password). You might consider this form of Protection for a working copy of your MacSheet and Protect Document for the backup copy.

**Printing MacSheets**

Not only is it easy to create and set up MacSheets, it's also easy to print them. MacPlan provides you with easy-to-use features for printouts of both drafts and final product. The File menu contains two options as follows:

- Page Setup
- Print
PAGE SETUP

The Page Setup option displays a floating menu, which has two print features. You can select a page length of either 11 or 14 inches. In addition, the Orientation feature permits you to print the MacSheet sideways (“Wide”). This feature is particularly useful if your MacSheet is fairly wide but not very deep; using it will enable you to print more information per page.

PRINT

The Print option contains four features:

• You can choose high or low resolution, or you can print a draft quality report. High resolution produces the highest quality character images.

• You can choose to print the entire report or just selected pages (e.g., pages 1 to 3). This is really handy, for example, when you have made some changes that affect only a portion of your MacSheet and you want to print just that portion.

• You can also specify the number of copies you want printed and continue working while they are printed.

• Finally, you have your choice between single sheets of paper or fanfold.

Saving MacSheets

MacSheets are saved by selecting the Save option from the File menu. When you are setting up a MacSheet or making revisions to one you previously set up, you should save your MacSheet every 15 minutes or so. It only takes a few seconds to save it and is well worth the time. To save your MacSheet and continue working, select Save from the File menu. When you are through with the MacSheet, select Save to save any further changes and then select Close. You can then create a new MacSheet by selecting New from the File menu or recall an existing MacSheet by selecting Open.

MacPlan Shortcuts

As we have seen, the mouse is the primary device for selecting options in MacPlan’s pull-down menus. After you become acquainted with MacPlan, you may want to consider using some or all of MacPlan’s keyboard shortcuts. For example, you may ultimately find that using the mouse for all of the selection
UNDERSTANDING THE MACINTOSH

process seems to slow you down. In this regard, MacPlan gives you the best of both worlds.

The frequently used menu items (e.g., paste) may be selected from the keyboard. Selecting an option from the keyboard is very simple. While holding down the Apple key, you enter a one-letter abbreviation for a command. The advantage in using the keyboard is that your hands do not have to leave the keyboard to manipulate the mouse. The disadvantage, of course, is memorizing the one-letter abbreviations. Do whichever seems easiest and most expedient for you.

The menu options that may be selected from the keyboard are as follows:

<table>
<thead>
<tr>
<th>Character</th>
<th>Function</th>
<th>Menu</th>
</tr>
</thead>
<tbody>
<tr>
<td>(*)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>X</td>
<td>Cut</td>
<td>Edit</td>
</tr>
<tr>
<td>C</td>
<td>Copy</td>
<td>Edit</td>
</tr>
<tr>
<td>V</td>
<td>Paste</td>
<td>Edit</td>
</tr>
<tr>
<td>Z</td>
<td>Undo/Redo</td>
<td>Edit</td>
</tr>
<tr>
<td>R</td>
<td>Fill Right</td>
<td>Edit</td>
</tr>
<tr>
<td>D</td>
<td>Fill Down</td>
<td>Edit</td>
</tr>
<tr>
<td>B</td>
<td>Clear</td>
<td>Edit</td>
</tr>
<tr>
<td>A</td>
<td>All Cells</td>
<td>Select</td>
</tr>
<tr>
<td>S</td>
<td>Show Active Cell</td>
<td>Select</td>
</tr>
<tr>
<td>N</td>
<td>Define Name</td>
<td>Select</td>
</tr>
<tr>
<td>F</td>
<td>Align Left</td>
<td>Format</td>
</tr>
<tr>
<td>G</td>
<td>Align Center</td>
<td>Format</td>
</tr>
<tr>
<td>H</td>
<td>Align Right</td>
<td>Format</td>
</tr>
<tr>
<td>=</td>
<td>Calculate Now</td>
<td>Calculate</td>
</tr>
<tr>
<td>P</td>
<td>Set Page Break</td>
<td>Options</td>
</tr>
<tr>
<td>U</td>
<td>Remove Cell Protection</td>
<td>Options</td>
</tr>
</tbody>
</table>

(*) Hold down the Command key when entering

In addition to the keyboard shortcuts for entering commands, you can use the mouse for shortcuts in the Select menu:

**All Cells.** When you select All Cells, the entire MacSheet is highlighted. This feature is useful for formatting an entire MacSheet at the same time (afterwards, you can change the format of specific cells to handle them on an exception basis). It is also useful for clearing the entire MacSheet while retaining the cell formats previously specified.

**Last Cell.** Selecting Last Cell moves you to the intersection of the highest row and column numbers presently active in the MacSheet and selects that cell (it
may be blank). This cell is also known as the bottom right corner of the active cells.

**Name.** Selecting the Name feature selects the cells identified (see further) by that name. Names may be up to 32 characters in length.

**Link.** The Link option selects those cells that are linked with another MacSheet (see Transferring MacSheet data).

**Show Active Cell.** There may be times when you scroll away from a selected cell. For example, you may have moved elsewhere to view a formula or data contained in another cell. The Show Active Cell moves you back to the selected cell.

**Define Name.** Using the Define Name feature, you can tie together a group of cells that are noncontiguous; or, you can use a name to represent a single cell. The cell(s) must be selected prior to defining the name. When you select the Define Name feature, a floating menu will appear and you can either (1) scroll through and select a name from the list of names previously used or (2) key in a new name. After you have defined a group of cells by a name, you can use that name in a formula (see Name).

**Delete Name.** You can delete a previously defined name with the Delete Name option. The cells referred to are not affected. However, if you have referred to a name in a formula, MacPlan will display the error message, #NAME?, in the cell containing the reference.

**Transferring MacSheet Data**

Not only does MacPlan provide a great deal of flexibility in constructing MacSheets, it also permits you to transfer data between MacSheets freely. There are several reasons why you might want to do this:

*First,* you might want to use specific formulas you have created in another MacSheet; this will save you time in designing your new MacSheet.

*Second,* while creating a new MacSheet, you might recall a layout (row and column headings, calculation formulas, etc.) that you used in another MacSheet and want to transfer it to your new MacSheet.

*Finally,* you might want to “link” together two or more MacSheets. For example, suppose you have detail and total columns in a monthly MacSheet (or category details, department details, etc.). Suppose further that you want to create a master MacSheet that contains the total columns from the detail MacSheets and a grand total column for all the individual MacSheets. You could
rekey the details, but that’s a horrible duplication of effort. An easier way to do this would be to link the MacSheets together. With the exception of the very last step, all of the steps to either transfer data or link MacSheets together are identical. Let’s see how we do it.

- Open the source MacSheet.
- Select the desired cells (if you have named the cells, use the Name feature in the Select menu).
- Select Copy from the Edit menu to place the cells on the Clipboard.
- Save the source MacSheet.
- Open the destination MacSheet, or, if it hasn’t been created yet, use the New command in the File menu and when prompted, give it a name.
- Select the insertion point (starting location) cell or range of cells in which the cells on the Clipboard will reside in the destination MacSheet.
- To transfer the Clipboard cells, select Paste from the Edit menu.
- To Link MacSheets, select Paste and Link from the Edit menu. The MacSheets are now Linked together. If you want to dissolve a link, select Unlink from the Edit menu and indicate which link in the list of links you want to dissolve.
- Save, and if you are done with it, Close the destination MacSheet.

GETTING FORMULAS TO WORK FOR YOU

Formulas are the key to making MacPlan work for you. In the previous section we discovered that we could copy formulas from one location to another using the Copy and Paste features. This ability takes much of the drudgery out of building MacSheets. In this section we’ll examine formulas in more detail and see how MacCalc’s built-in functions take the remaining drudgery out of creating formulas.

Understanding MacPlan Formulas

MacPlan formulas can be thought of as instructions telling MacPlan what to do for you. Provided that you communicate these instructions correctly, MacPlan will dutifully obey your every wish. Accordingly, let’s see how we communicate these instructions. Our topics are:

- Formula components
- Arithmetic operators
FORMULA COMPONENTS

Simply stated, a formula consists of one or more things upon which we want to take action and the action(s) we want to take. The things we want to take action upon are known as "operands." The actions we want to take are known as "operators." For example, if we want to add the numeric constant, 5.6, to the numeric constant, 3.4, these two numbers are the operands and the action "add" is the operator. An operand can be one of the following:

- A numeric constant (e.g., 512)
- A cell reference (e.g., R1C1)
- A label

ARITHMETIC OPERATORS

MacPlan has six arithmetic operators as follows:

<table>
<thead>
<tr>
<th>SYMBOL</th>
<th>MEANING</th>
<th>EXAMPLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Add</td>
<td>5 + 2 = 7</td>
</tr>
<tr>
<td>-</td>
<td>Subtract</td>
<td>5 - 2 = 3</td>
</tr>
<tr>
<td>*</td>
<td>Multiply</td>
<td>5*2 = 10</td>
</tr>
<tr>
<td>/</td>
<td>Divide</td>
<td>5/2 = 2.5</td>
</tr>
<tr>
<td>%</td>
<td>Divide by 100</td>
<td>5% = .05</td>
</tr>
<tr>
<td>~</td>
<td>Exponentiation</td>
<td>5^2 = 25</td>
</tr>
</tbody>
</table>

(raise to the power)

Confusion can arise when a formula contains more than one operator. For example, the formula "5 + 2*3" could mean:

- Add 5 to 2 and multiply the result (7) by 3; or
- Multiply 2 by 3 and add the result (6) to 5

To avoid potential confusion, MacPlan assigns each of the mathematical operators a priority as follows:
Consider the formula "2 + 5 * 3 ^ 2 - 1" for which MacPlan performs the exponentiation calculation \((3^2)\) first. The exponentiation result (9) is then multiplied by 5, yielding 45. The lowest level operators are performed last going from left to right \((2 + 45 - 1 = 46)\).

Given the example above, suppose you want to add the 2 and 5 before performing higher level mathematic operations. Not to worry! MacPlan uses parentheses to permit lower level operations to be performed first. In our example, we could have MacPlan add 2 to 5 first by entering the formula as follows:

\[(2 + 5) * 3 ^ 2 - 1\]

We can construct simple formulas using the arithmetic operators. However, there is another type of operator that may be useful to us, the relational operator.

**RELATIONAL OPERATORS**

If relational operators is a new concept for you, just scan the following material. You can come back to it at a later date when it will be more meaningful to you. In this regard, there may be occasions when you will want to compare two numbers and perform specified actions depending on the results of the comparison. MacPlan provides relational operators to perform such comparisons. The relational operators and their meanings are:

<table>
<thead>
<tr>
<th>OPERATOR</th>
<th>MEANING</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;</td>
<td>Less than</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Less than or equal to</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Greater than or equal to</td>
</tr>
<tr>
<td>=</td>
<td>Equal to</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>Not equal to</td>
</tr>
</tbody>
</table>
The relational operators are used in formulas in the exact same way as are the arithmetic operators. That is, they can be used in formulas containing the four types of operands (numeric constants, cell references, text, and functions). However, the results they produce are significantly different. Whereas arithmetic formulas produce a numeric result, relational formulas produce a logic result. A logic result can either be “True” or “False.” Let’s illustrate:

<table>
<thead>
<tr>
<th>FORMULA</th>
<th>RESULT</th>
</tr>
</thead>
<tbody>
<tr>
<td>Numeric formula</td>
<td>3*5</td>
</tr>
<tr>
<td>Logic formula</td>
<td>3&gt;5</td>
</tr>
</tbody>
</table>

In the example above, since 3 is not greater than 5, the result of the comparison is False.

**TEXT OPERATOR**

MacPlan permits you to join text together by using the text operator, “&.” This is typically useful with functions as we’ll see a little later.

**CONTROL CONSTANTS**

MacPlan anticipates that errors will creep into the results of formula calculations and that unexpected results may be obtained. Further, MacSheets may be constructed before some of the data needed for calculations are available. MacPlan provides some special control constants to alert and enable you to cope with these types of situations. These control constants are described below.

<table>
<thead>
<tr>
<th>CONSTANT</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>#Null!</td>
<td>If you specify an intersection of areas that don’t intersect, MacPlan will display “#NULL!” for you. If you meant to include two rows or columns in a list (e.g., (R1, R2)) and forgot to separate them by a comma, this control constant will appear.</td>
</tr>
<tr>
<td>#NAME?</td>
<td>If you use a name that you haven’t defined, MacPlan will display “#NAME?.”</td>
</tr>
<tr>
<td>#DIV/O</td>
<td>If a formula results in a division by zero, MacPlan inserts the value “#DIV/O” and displays it on the screen.</td>
</tr>
<tr>
<td>#N/A</td>
<td>If a number you need to enter in a cell is not available, you can enter the NA() function in that cell. Cells containing formulas that refer to this cell will also have the result “#N/A.”</td>
</tr>
</tbody>
</table>
#NUM! If you use a function incorrectly, MacPlan will display the "#NUM!" constant.

#REF! If you refer to a nonexistent cell (e.g., a row or column number greater than 63 and 255, respectively) the cell will display "#REF!". You will get the same result in a cell that refers to a named area you have deleted.

#VALUE! If you used a number when a label/text should have been used (or vice-versa), MacPlan will display the constant "#VALUE!".

##### Pound signs are used in cells for which the number of digits is greater than the column width. Widen the column to display the value.

**Using MacPlan’s built-in functions**

Let’s suppose that you have a large column of numbers and you would like MacPlan to calculate their total. You could construct a formula to add the values as follows:

Cell 1 + cell 2 + cell 3 + ......................... + cell x

It would be nice if MacPlan had a shortcut for us. As you may have guessed, MacPlan does! MacPlan has a built-in function named "SUM," which would be entered as:

SUM (cell 1:cell x)

The built-in function, SUM, adds the contents of all cells in the range from cell 1 to cell x. Built-in functions eliminate the drudgery from constructing many formulas. There isn’t very much you need to know in order to use MacPlan’s built-in functions. In fact, all you need to know is their general format, which is as follows:

name (argument 1, argument 2, .........................)

The number of arguments and what the arguments can be differs according to the specific function. In general, however, there are three categories of arguments: a single cell, a range of cells, or a list of noncontiguous cells. Let’s see what each of the functions are and what they do. After that we’ll see how to enter them.
<table>
<thead>
<tr>
<th>Function</th>
<th>Format</th>
<th>Type of value</th>
<th>Purpose</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>ABS</td>
<td>Abs (Value)</td>
<td>Number</td>
<td>Returns a positive number (absolute value).</td>
<td>ABS (−5) = 5</td>
</tr>
<tr>
<td>AND</td>
<td>AND (list)</td>
<td>Logical expressions or values. Periods for the annuity.</td>
<td>Returns the value True if all the items in the list are true; otherwise, returns the value False.</td>
<td>AND (R2C1&gt;1, R3C2&gt;100000)</td>
</tr>
<tr>
<td>AVERAGE</td>
<td>Average (List)</td>
<td>Any combination of numbers or logical values.</td>
<td>Returns the arithmetic mean of the values in the list; blank cells are ignored.</td>
<td>Average (R1C10, 14.2, 100)</td>
</tr>
<tr>
<td>COLUMN</td>
<td>Column ()</td>
<td></td>
<td>Returns the column number.</td>
<td>Column 3 Column() = 3</td>
</tr>
<tr>
<td>COUNT</td>
<td>Count (List)</td>
<td>Any combination of values.</td>
<td>To count the number of items in the list (references to blank cells are ignored).</td>
<td>Count (cell 1:cell 6)</td>
</tr>
<tr>
<td>DELTA</td>
<td>Delta () value</td>
<td>Number</td>
<td>Calculates the difference between values from one iteration to the next.</td>
<td>Delta () &lt;0.000001</td>
</tr>
</tbody>
</table>
DOLLAR

Format
Dollar (value)
Type of value
Number
Purpose
Returns a number with two decimal places, adds a dollar sign and converts to text.
Example
Dollar (2.321) = $2.32

EXP

Format
Exp (value)
Type of value
Any number
Purpose
To return the exponential function of value which, mathematically, is:
\[ e^\text{value} \]
Example
Exp (1) = 2.71828 . . . . .

FALSE

Format
False ()
Purpose
Returns the value FALSE.
Example
IF (5>4, TRUE (), FALSE () = False

FIXED

Format
Fixed (value, number of decimals)
Type of value
Number
Purpose
Returns a text value with the stated number of decimal places.
Example
Fixed (13.333, 0) & “percent” = 13 percent

IF

Format
If (value 1, value 2, value 3)
Type of value 1
Logical formula
Type of value 2
Any value
Type of value 3
Any value
Purpose
To take on the value of value 2 if value 1 is True; otherwise the value of value 3 is used.
Examples
If (Cell 1 < 0, “Negative”, cell 1)—If the value of cell 1 is less than 0, this cell contains the label “Negative” and if not, this cell will contain the value in cell 1.
If (cell 1 < 2 And Cell 2 < 2, Min (cell 10: cell 20), Max (cell 10: cell 20)—If the values in cells 1 and 2 are both less than 2, then this cell contains the smallest value contained within the range from cells 10 to 20; otherwise, this cell contains the largest value in that range.
INDEX

Format: Index (range, value 1, value 2)
Type of range: Rectangular area within MacSheet
Type of value 1: Row number
Type of value 2: Column number
Purpose: Index returns the value in a cell that is value 1 number of rows within the range and value 2 number of columns within the range, both measured from the top left corner of the range.

Example:

<p>| | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>20</td>
<td>30</td>
<td>40</td>
<td>50</td>
</tr>
<tr>
<td>2</td>
<td>5</td>
<td>6</td>
<td>7</td>
<td>8</td>
</tr>
<tr>
<td>3</td>
<td>10</td>
<td>15</td>
<td>20</td>
<td>25</td>
</tr>
</tbody>
</table>

INDEX (R1C1:R3C4,2,4) = 8

INT

Format: Int (value)
Type of value: Number
Purpose: Returns a number by deleting all of the decimal places present.

Example:

Int (5.53) = 5

ISERROR

Format: Iserror (value)
Type of value: Any value
Purpose: Return the value TRUE if value is a MacPlan error value; otherwise returns the value FALSE.

Example:

Cell 1 = #NAME?
ISERROR (Cell 1) = TRUE

ISNA

Format: ISNA (value)
Type of value: Any value
Purpose: Returns the value TRUE if the value is #N/A; otherwise returns FALSE.

Example:

ISNA (R1C1)

ITERCNT

Format: Itercnt ()
Purpose: Itercnt returns the number of the current iteration.

Example:

IF (ISNA (ITERCNT ()), R2C2,R3C2)
UNDERSTANDING THE MACINTOSH

LEN

Format: Len (text)
Purpose: Len returns the number of characters in the text.
Example: LEN ("length") = 6

LN

Format: Ln (value)
Type of value: Positive number
Purpose: Returns the natural logarithm of value to the base e.
Example: Ln (2.7182818284591) = 1

LOG 10

Format: Log10 (value)
Type of value: Positive number
Purpose: Returns the logarithm of value to the base 10.
Example: Log10 (2.7182818284591) = .43429448190326.

LOOKUP

Format: Lookup (value, range)
Type of value: Any number
Type of range: All of the items in the row or column being searched must be numbers in ascending order.
Purpose: To perform table lookup functions. MacPlan searches the first row or column for the largest number less than or equal to or less than the lookup value. If the number of rows is greater than or equal to the number of columns, then the search is down the first column; otherwise the search is across the first row. All of the values in the search row or column must be numbers in ascending order. When a number is found that is greater than the search value, MacPlan backs up one cell and finds the corresponding cell in the last row or column and returns the value in that cell (which need not be a number).

Example: Value = 16

<table>
<thead>
<tr>
<th>Column 1</th>
<th>Column 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>30 + .10*(20-value)</td>
</tr>
<tr>
<td>12</td>
<td>31 + .15*(22-value)</td>
</tr>
<tr>
<td>15</td>
<td>33 + .20*(25-value)</td>
</tr>
<tr>
<td>20</td>
<td>36 + .25*(30-value)</td>
</tr>
</tbody>
</table>

In the example, column 1 is searched until a value greater than 16 is found (in this case, the value, 20), at which time the next smallest value (15) is used. Then the value in the corresponding cell in column 2 is returned.
Since the value in column 2 is a formula, the formula is evaluated (in this case $33 + .20 \times 9 = 34.8$).

### MAX

<table>
<thead>
<tr>
<th>Format</th>
<th>Max (list)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type of list</td>
<td>Any combination of numbers, or labels (labels are equal to 0)</td>
</tr>
<tr>
<td>Purpose</td>
<td>To find the largest value in a range.</td>
</tr>
<tr>
<td>Examples</td>
<td>Max (2.45, -290, 4) = 4</td>
</tr>
<tr>
<td></td>
<td>Max (.456, &quot;True&quot;, 1) = 1</td>
</tr>
</tbody>
</table>

### MID

<table>
<thead>
<tr>
<th>Format</th>
<th>Mid (text, value 1, value 2)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type of value 1</td>
<td>Number—the starting position in the text</td>
</tr>
<tr>
<td>Type of value 2</td>
<td>Number—the number of characters to return</td>
</tr>
<tr>
<td>Purpose</td>
<td>To return a specified number of characters starting with a specified location within the text.</td>
</tr>
<tr>
<td>Example</td>
<td>MID (&quot;EXAMPLE&quot;, 3,5) = AMPLE</td>
</tr>
</tbody>
</table>

### MIN

<table>
<thead>
<tr>
<th>Format</th>
<th>Min (list)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type of list</td>
<td>Any combination of numbers or labels (labels are equal to 0)</td>
</tr>
<tr>
<td>Purpose</td>
<td>To find the smallest value in a range.</td>
</tr>
<tr>
<td>Examples</td>
<td>Min (2.45, -290, 4) = -290</td>
</tr>
</tbody>
</table>

### MOD

<table>
<thead>
<tr>
<th>Format</th>
<th>Mod (value 1, value 2)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type of value 1</td>
<td>Number to be divided</td>
</tr>
<tr>
<td>Type of value 2</td>
<td>Number to divide by</td>
</tr>
<tr>
<td>Purpose</td>
<td>To return the remainder.</td>
</tr>
<tr>
<td>Example</td>
<td>Mod (12,5) = 2</td>
</tr>
</tbody>
</table>

### NA

<table>
<thead>
<tr>
<th>Format</th>
<th>NA()</th>
</tr>
</thead>
<tbody>
<tr>
<td>Purpose</td>
<td>Returns #N/A to indicate that a number isn’t available.</td>
</tr>
</tbody>
</table>

### NPV

<table>
<thead>
<tr>
<th>Format</th>
<th>Npv (value, range)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type of value</td>
<td>Number, representing the discount rate.</td>
</tr>
<tr>
<td>Type of range</td>
<td>Numbers, representing the cash flow during the periods.</td>
</tr>
</tbody>
</table>
UNDERSTANDING THE MACINTOSH

**Purpose**
To calculate and return the present value of a series of cash flows.

**Example**
Assume cell 1 contains a discount rate of 11%, and cells 2 through 4 contain payments of $9,000 and cash receipts of $3,667, $3,667 and $5,667 in years 1, 2, and 3, respectively. The formula would be as follows:

\[
\text{npv (cell 1, cell 2:cell 4)} = 1281.7
\]

**OR**

<table>
<thead>
<tr>
<th>Format</th>
<th>OR (list)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type of list</td>
<td>Logical expressions</td>
</tr>
<tr>
<td>Purpose</td>
<td>If any item in the list is true, returns TRUE; otherwise returns FALSE.</td>
</tr>
<tr>
<td>Example</td>
<td>OR(3&gt;2,2&gt;3) = TRUE</td>
</tr>
</tbody>
</table>

**PI**

<table>
<thead>
<tr>
<th>Format</th>
<th>PI()</th>
</tr>
</thead>
<tbody>
<tr>
<td>Purpose</td>
<td>Returns the value of PI to 13 places.</td>
</tr>
</tbody>
</table>

**REPT**

<table>
<thead>
<tr>
<th>Format</th>
<th>Rept (text, value)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type of value</td>
<td>Number</td>
</tr>
<tr>
<td>Purpose</td>
<td>To repeat text the stated number of times; if value &gt;256, MacPlan will subtract 256 repeatedly until the number is less than or equal to 256.</td>
</tr>
<tr>
<td>Example</td>
<td>REPT (&quot;X&quot;,3) = XXX</td>
</tr>
</tbody>
</table>

**ROUND**

<table>
<thead>
<tr>
<th>Format</th>
<th>Round (value 1, value 2)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type of value 1</td>
<td>Number</td>
</tr>
<tr>
<td>Type of value 2</td>
<td>Whole number; value 2 can be zero</td>
</tr>
<tr>
<td>Purpose</td>
<td>Same as INT except numbers are rounded up, as applicable, instead of being truncated as is the case with INT.</td>
</tr>
<tr>
<td>Examples</td>
<td>Round (1.9857) = 2</td>
</tr>
<tr>
<td></td>
<td>Round (19857, -2) = 19900</td>
</tr>
<tr>
<td></td>
<td>Round (1.9857,2) = 1.99</td>
</tr>
<tr>
<td></td>
<td>Round (1250 days, -2) = 1300</td>
</tr>
</tbody>
</table>

**ROW**

<table>
<thead>
<tr>
<th>Format</th>
<th>Row()</th>
</tr>
</thead>
<tbody>
<tr>
<td>Purpose</td>
<td>Returns the row number.</td>
</tr>
<tr>
<td>Example</td>
<td>Row number = 5 ROW() = 5</td>
</tr>
<tr>
<td>Function</td>
<td>Format</td>
</tr>
<tr>
<td>----------</td>
<td>--------</td>
</tr>
<tr>
<td>SIGN</td>
<td>Sign (value)</td>
</tr>
<tr>
<td>SORT</td>
<td>Sqrt (value)</td>
</tr>
<tr>
<td>STDEV</td>
<td>Stdev (list)</td>
</tr>
<tr>
<td>SUM</td>
<td>Sum (list)</td>
</tr>
<tr>
<td>TRUE</td>
<td>True()</td>
</tr>
<tr>
<td>VALUE</td>
<td>Value (text)</td>
</tr>
</tbody>
</table>

In addition to the arithmetic and financial functions shown, MacPlan also has the trigonometric functions ATAN, COS, SIN, and TAN (arctangent, cosine, sine, and tangent), all of which follow the same format. For illustrative purposes, we'll use SIN.

<table>
<thead>
<tr>
<th>Function</th>
<th>Format</th>
<th>Type of value</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>SIN</td>
<td>Sin (value)</td>
<td>Number, in radians.</td>
<td>To return the Sine of value.</td>
</tr>
</tbody>
</table>
Indeed, that's an impressive list of functions. But there are so many of them to remember! Not to worry. MacMouse to the rescue. You don't have to memorize them at all. MacPlan has memorized them for you, and MacMouse will lead you to them. Let's see how.

In column 1, row 5 of your MacSheet, enter the number 1 and press the Return key. Then enter the formula =R[-1]C+1, and press the Enter key. Now drag MacMouse from R6C1 to R18C1 and release the mouse button. Next, select Fill Down from the Edit menu. Your MacSheet should display the numbers 1 to 14. Press Return to get to R19C1. Now, enter the Edit menu and select Paste Function. Point MacMouse to the down arrow in the floating menu. Press down on the mouse button and hold it down. You will scroll through the function menu. There they all are, waiting for you!

No need to memorize the functions when MacMouse is around. When you get down to the bottom of the shaft, point MacMouse to the box next to the SUM function and click it. Then click the OK box. Now look at cell R19C1. MacMouse put the function there for you. Notice that the cursor is blinking between the two parentheses. MacPlan is waiting for you to tell it which cells you want to SUM. Select R5C1 and, holding down the mouse button, drag it until it reaches R18C1; let go and press the Enter key. My, oh my! MacMouse has done it for you again. Notice that you only used the keyboard to enter data twice: once for the number 1 and once for the formula. MacMouse took care of the rest.

Whenever you are entering a formula, you can use MacMouse to point to a cell that you want to refer to. MacMouse will scurry over to the cell, retrieve its relative location, and come back and enter the cell reference in the formula for you. The cell reference is a relative reference. In fact, if you have several cells to refer to, just keep pointing MacMouse to the cells and click his button. He'll keep retrieving the references for you until you are done. That's how easy MacPlan is to use. However, if at any point while you are using MacPlan you are uncertain as to how to proceed, enter the Apple menu and select "About Multiplan." A "help" facility will provide you additional information about MacPlan's features.

You may want to take a break now or peruse some of the functions again. When you are ready to continue, we'll move on to the "Ideas" section.

IDEAS FOR MACPLAN APPLICATIONS

Now that we know how to use MacPlan's features and built-in functions, it's time to move on to the sole purpose for which MacPlan exists: to do useful work for you. You probably already have some ideas for how you could use MacPlan. Whether you intend to use Mac at home, at work, or both, the extent to which you can use MacPlan is limited only by your imagination. In this section we'll look at some ideas for both. For each application area, we'll begin with a very brief discussion followed by a specific example. Each example shows the report layout and the key formulas used. If you decide to create a MacSheet for the
Using MacPlan

sample application area, you may want to tailor the example to suit your own circumstances and needs. Our sample application areas are:

- Amortization tables
- Budgets
- Capital expenditures
- Cash flow
- Cash disbursements
- Checkbook reconciliation
- Commissions
- Cost analysis
- Depreciation
- Expense reports
- Financing alternatives
- Impounds
- Income taxes
- Inflationary effects
- Market analysis
- Overhead allocation
- Payback period
- Payroll
- Personnel
- Projections
- Productivity analysis
- Revenue analysis
- Selling expense analysis
- Statistical analysis
- Stock portfolio
- Time management
- Training analysis
- Variance analysis

CASE STUDY—BUILDING A MacPlan SPREADSHEET

At this point you are probably anxious to get started using MacPlan. If you are not an experienced electronic spreadsheet user, you may be asking yourself questions such as:

- How do I get started?
- What is my first step?
- How should I set up my MacSheet?

These are all valid and appropriate questions to ask. To help you with the answers, we'll go through the entire process, step by step, and build an entire MacSheet. Our steps are as follows:

Step 1 Turn off the automatic calculation feature.
Step 2 Prepare a table of variables.
Step 3 Enter the column headings.
Step 4 Enter the row titles.
Step 5 Enter the formulas for the monthly calculations.
Step 6 Duplicate the monthly formulas.
Step 7 Enter the formulas for the totals.
Step 8 Calculate the MacSheet.
Step 9 Save your MacSheet.
Step 1  Turn Off the Automatic Calculation Feature

When the automatic calculation feature is on, your MacSheet will be recalculated every time you enter something. While we are setting up the MacSheet, automatic calculation will be both distracting and time consuming. Enter the Calculation menu and select Manual Calculation.

Step 2  Prepare a Table of Variables

Table 2.1 shows the loan amortization schedule we will create. You could insert variables such as the interest rate, principal amount, etc. directly in the formulas. However, if you decide to change any of the variables, you would then have to change all of the formulas in the cells that use the changed variables. You can create a little table at the top of your MacSheet to list the variables and have the calculation formulas refer to these variables. That way, if you want to change a variable, you can change it in the table and not have to worry about changing the formulas. So our second step is to build the table of variables. To select a cell, point the mouse arrow to the desired cell and click the mouse button. When entering data, directional movement is accomplished as follows:

- Return —down
- Shift return —up
- Tab —right
- Shift tab —left

Push the Caps Lock key down and use the mouse to select R3C1. Then enter the table as follows:

<table>
<thead>
<tr>
<th>CELL</th>
<th>ENTRY</th>
<th>KEY TO PRESS</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>R3C1</td>
<td>PRINCIPAL AMOUNT</td>
</tr>
<tr>
<td>2</td>
<td>R4C1</td>
<td>INTEREST RATE—ANNUAL</td>
</tr>
<tr>
<td>3</td>
<td>R5C1</td>
<td>INTEREST RATE—MONTHLY</td>
</tr>
<tr>
<td>4</td>
<td>R6C1</td>
<td>NUMBER OF MONTHS</td>
</tr>
<tr>
<td>5</td>
<td>R7C1</td>
<td>REQUIRED PAYMENT</td>
</tr>
<tr>
<td>6</td>
<td>R3C4</td>
<td>13000</td>
</tr>
<tr>
<td>7</td>
<td>R4C4</td>
<td>.13</td>
</tr>
<tr>
<td>8</td>
<td>R5C4</td>
<td>= (TO INDICATE FORMULA) CLICK R4C4</td>
</tr>
<tr>
<td></td>
<td></td>
<td>/12</td>
</tr>
<tr>
<td>9</td>
<td>R6C4</td>
<td>36</td>
</tr>
<tr>
<td>10</td>
<td>R7C4</td>
<td>= CLICK R3C4</td>
</tr>
</tbody>
</table>
Don’t worry about centering things or number of decimal places yet. We’ll attend to those things later. Three points are notable:

- When you enter text in a cell and, if the cell to its right is blank, if the text cannot fit in the column’s width, it “spills over into the next column.” The spill over ability means we don’t have to enter text in more than one column in our table.

- The entries in R7C4 are a formula to calculate the payment amount. The formula is:

\[
PMT = PV * i (1 - 1/(1 + i)^n)
\]

Where \(PV\) = the present value, \(i\) = periodic interest rate and \(n\) = the number of payments. You might want to put this formula in a MacPlan file so you can retrieve it when you need it. You also might want to jot down the following formula for computing the present value of an annuity:

\[
PV = PMT*(1 - (1/(1 + i)^n))/i
\]

- Notice how easy it was to let MacMouse retrieve the cell references for us instead of entering them ourselves.

### Step 3 Enter the Column Headings

Select R10C1 and enter the column headings as follows:

<table>
<thead>
<tr>
<th>CELL</th>
<th>ENTRY</th>
<th>KEY(S) TO PRESS</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>R9C4</td>
<td>BEGINNING, TAB, TAB</td>
</tr>
<tr>
<td>2</td>
<td>R9C6</td>
<td>PAYMENT, TAB, TAB</td>
</tr>
<tr>
<td>3</td>
<td>R9C8</td>
<td>ENDING, MOUSE-CLICK R10C1</td>
</tr>
<tr>
<td>4</td>
<td>R10C1</td>
<td>MONTH, TAB</td>
</tr>
<tr>
<td>5</td>
<td>R10C2</td>
<td>YEAR, TAB, TAB</td>
</tr>
<tr>
<td>6</td>
<td>R10C4</td>
<td>BALANCE, TAB</td>
</tr>
<tr>
<td>7</td>
<td>R10C5</td>
<td>INTEREST, TAB</td>
</tr>
<tr>
<td>8</td>
<td>R10C6</td>
<td>PRINCIPAL, TAB</td>
</tr>
<tr>
<td>9</td>
<td>R10C7</td>
<td>TOTAL, TAB</td>
</tr>
<tr>
<td>10</td>
<td>R10C8</td>
<td>BALANCE, MOUSE-CLICK R12C1</td>
</tr>
</tbody>
</table>
Our column headings are now complete so we can proceed to enter the names of the months.

**Step 4  Enter the Row Titles**

<table>
<thead>
<tr>
<th>CELL</th>
<th>ENTRY</th>
<th>KEY TO PRESS</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 R12C1</td>
<td>JAN</td>
<td>TAB</td>
</tr>
<tr>
<td>2 R12C2</td>
<td>1985</td>
<td>RETURN, SHIFT TAB</td>
</tr>
<tr>
<td>3-13 R13C1-R23C1</td>
<td>FEB-DEC</td>
<td>RETURN</td>
</tr>
</tbody>
</table>

Now what we will do is copy the names of the months for 1986 and 1987:

- Point MacMouse to R12C1; press down and drag him to R23C1 and let go (all the months should be highlighted).
- Enter the Edit menu and select Copy.
- Click MacMouse in R24C1.
- Enter the Edit menu and select Paste.
- Click MacMouse in R24C2; type 1986.

Since the names of the months are still on the Clipboard, click MacMouse in R36C1; enter the Edit menu and select Paste; click in R36C2 and type 1987. You're done with the row titles with the exception of the total label. Click MacMouse in R48C1 and enter the label, TOTALS.

**Step 5  Enter the Formulas for the Monthly Calculations**

<table>
<thead>
<tr>
<th>CELL</th>
<th>ENTRY</th>
<th>KEY TO PRESS</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 R12C4</td>
<td>=</td>
<td>CLICK IN R3C4 TAB</td>
</tr>
<tr>
<td>2 R12C5</td>
<td>=</td>
<td>CLICK IN R12C5 *R5C4 TAB</td>
</tr>
<tr>
<td>3 R12C6</td>
<td>=</td>
<td>R7C4</td>
</tr>
<tr>
<td></td>
<td>-</td>
<td>CLICK IN R12C5 TAB</td>
</tr>
<tr>
<td>4 R12C7</td>
<td>=</td>
<td>CLICK IN R12C5 TAB</td>
</tr>
<tr>
<td></td>
<td>+</td>
<td>CLICK IN R12C6 TAB</td>
</tr>
</tbody>
</table>
The monthly formulas are now all filled in. Before we copy the formulas, let's adjust the appearance of the view screen to make things easier to see. Select columns 4 through 8 by pressing the mouse button down in the column number 4 and dragging through to column 8. Now enter the format window and select Column Width. Click in the box for New Column Width and press Backspace until the existing number disappears. Then enter the number 8 and press OK. The columns will be 8 characters wide. Now position MacMouse in the column headings between the numbers 3 and 4. Press down and drag to the left until the line that used to separate them is dragged to the right of column 2. Let go and column 3 will be covered up (you can uncover it by reversing these actions). Adjust column 2's width until column 8 is entirely visible on the screen. Finally, point MacMouse to the little black rectangle in the shaft on the right side of the screen. Press down and drag the rectangle (view control) until it coincides with the bottom of row 7; now let go of the mouse button. The screen will split into two views.

### Step 6  Duplicate the Monthly Formulas

<table>
<thead>
<tr>
<th>CELL</th>
<th>ENTRY</th>
<th>KEY TO PRESS</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 R12C5</td>
<td>= CLICK AND HOLD DOWN, DRAG FROM R12C5-R12C8 SELECT COPY CLICK AND HOLD DOWN DRAG FROM R12C5-R47C8 SELECT FILL DOWN SELECT SHOW ACTIVE CELL FROM SELECT MENU</td>
<td>SELECT SHOW CLICK IN R13C4</td>
</tr>
<tr>
<td>2 R13C4</td>
<td>= SELECT COPY CLICK AND HOLD DOWN DRAG FROM R13C4-R47C4 SELECT FILL DOWN SELECT SHOW ACTIVE CELL FROM SELECT MENU</td>
<td>CLICK IN R48C4 IN BOTTOM VIEW</td>
</tr>
</tbody>
</table>
Notice how easy it was to copy 175 formulas in procedure 1 above. Also, using the feature Show Active Cell brought you back into view of the starting point for the Fill Down procedures, which made them easier to perform.

Step 7  Enter the Formulas for the Totals

<table>
<thead>
<tr>
<th>CELL</th>
<th>ENTRY</th>
<th>KEY TO PRESS</th>
</tr>
</thead>
<tbody>
<tr>
<td>R4C4</td>
<td>CLICK IN R3C4 (TOP VIEW)</td>
<td>CLICK IN R4C5</td>
</tr>
<tr>
<td>R4C5</td>
<td>= SELECT PASTE FUNCTION SELECT SUM () SCROLL TOP WINDOW UNTIL R12C5 IS VISIBLE; DRAG FROM R12C5-R4C5</td>
<td>PRESS ENTER</td>
</tr>
<tr>
<td>R4C5</td>
<td>COPY R4C5 COPY FROM R4C5-R4C7 SELECT FILL RIGHT</td>
<td>CLICK IN R4C8</td>
</tr>
<tr>
<td>R4C8</td>
<td>COPY R4C8 DRAG FROM R4C8-R4C8 SELECT FILL DOWN</td>
<td></td>
</tr>
</tbody>
</table>

Notice again how the split views make it easier to manipulate the MacSheet as well as to keep your bearings on what is happening. You can split both horizontal and vertical views at the same time.

Step 8  Calculate the MacSheet

Now we can reap the benefits of all that "hard" work! Enter the Calculate menu and select Calculate Now; also, select Manual Calculation in case you want to make any changes and see the effects. Notice, however, the lack of consistency of decimal places and how illegible the MacSheet looks without the numbers lining up. Select rows 4 through 8. Enter the Format menu and select Decimal format. Then, for R4C4 and R5C4, select Number of Decimals; when the menu appears, select 3 decimal places. Now, doesn't that look a lot better? Your MacSheet should look something like the one illustrated in Figure 2.7.

Before we wrap it up, try changing the interest rate to .125 per year and then change the principal amount to 11500. It sure is easy to do financial modelling with a friendly mouse!
Figure 2.7 Case Study-Amortization Table.

**Step 9   Save Your MacSheet**

Since you may want to use your amortization table again, be sure to save it before you go on to your next MacSheet. You might want to name it Amortization Table when you are asked for a name. After that, when you’re ready, let’s move on to MacWrite.
<table>
<thead>
<tr>
<th>ROW</th>
<th>COLUMN</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>LOAN AMORTIZATION SCHEDULE</td>
</tr>
<tr>
<td>2</td>
<td>PRINCIPAL AMOUNT</td>
</tr>
<tr>
<td>3</td>
<td>3000</td>
</tr>
<tr>
<td>4</td>
<td>INTEREST RATE—ANNUAL</td>
</tr>
<tr>
<td>5</td>
<td>0.13</td>
</tr>
<tr>
<td>6</td>
<td>INTEREST RATE—MONTHLY</td>
</tr>
<tr>
<td>7</td>
<td>0.0108333</td>
</tr>
<tr>
<td>8</td>
<td>NUMBER OF MONTHS</td>
</tr>
<tr>
<td>9</td>
<td>36</td>
</tr>
<tr>
<td>10</td>
<td>REQUIRED PAYMENTS</td>
</tr>
<tr>
<td>11</td>
<td>438.02</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>MONTH</th>
<th>YEAR</th>
<th>BEGINNING BALANCE</th>
<th>INTEREST</th>
<th>PRINCIPAL</th>
<th>TOTAL</th>
<th>ENDING BALANCE</th>
</tr>
</thead>
<tbody>
<tr>
<td>JAN</td>
<td>1985</td>
<td>13000.00</td>
<td>140.83</td>
<td>297.19</td>
<td>438.02</td>
<td>12702.81</td>
</tr>
<tr>
<td>FEB</td>
<td>1985</td>
<td>12702.81</td>
<td>137.61</td>
<td>300.41</td>
<td>438.02</td>
<td>12402.40</td>
</tr>
<tr>
<td>MAR</td>
<td>1985</td>
<td>12402.40</td>
<td>134.36</td>
<td>303.66</td>
<td>438.02</td>
<td>12098.74</td>
</tr>
<tr>
<td>APR</td>
<td></td>
<td>12098.74</td>
<td>131.07</td>
<td>306.95</td>
<td>438.02</td>
<td>11791.79</td>
</tr>
<tr>
<td>MAY</td>
<td></td>
<td>11791.79</td>
<td>127.74</td>
<td>310.28</td>
<td>438.02</td>
<td>11481.51</td>
</tr>
<tr>
<td>JUN</td>
<td></td>
<td>11481.51</td>
<td>124.38</td>
<td>313.64</td>
<td>438.02</td>
<td>11167.87</td>
</tr>
<tr>
<td>JUL</td>
<td></td>
<td>11167.87</td>
<td>120.99</td>
<td>317.03</td>
<td>438.02</td>
<td>10850.84</td>
</tr>
<tr>
<td>AUG</td>
<td></td>
<td>10850.84</td>
<td>117.55</td>
<td>320.47</td>
<td>438.02</td>
<td>10530.37</td>
</tr>
<tr>
<td>SEP</td>
<td></td>
<td>10530.37</td>
<td>114.08</td>
<td>323.94</td>
<td>438.02</td>
<td>10206.43</td>
</tr>
<tr>
<td>OCT</td>
<td></td>
<td>10206.43</td>
<td>110.57</td>
<td>327.45</td>
<td>438.02</td>
<td>9878.98</td>
</tr>
<tr>
<td>NOV</td>
<td></td>
<td>9878.98</td>
<td>107.02</td>
<td>331.00</td>
<td>438.02</td>
<td>9547.98</td>
</tr>
<tr>
<td>DEC</td>
<td></td>
<td>9547.98</td>
<td>103.44</td>
<td>334.58</td>
<td>438.02</td>
<td>9213.40</td>
</tr>
<tr>
<td>JAN</td>
<td>1986</td>
<td>9213.40</td>
<td>99.81</td>
<td>338.21</td>
<td>438.02</td>
<td>8875.19</td>
</tr>
<tr>
<td>FEB</td>
<td>1986</td>
<td>8875.19</td>
<td>96.15</td>
<td>341.87</td>
<td>438.02</td>
<td>8533.32</td>
</tr>
<tr>
<td>MAR</td>
<td>1986</td>
<td>8533.32</td>
<td>92.44</td>
<td>345.58</td>
<td>438.02</td>
<td>8187.74</td>
</tr>
<tr>
<td>APR</td>
<td>1986</td>
<td>8187.74</td>
<td>88.70</td>
<td>349.32</td>
<td>438.02</td>
<td>7838.42</td>
</tr>
<tr>
<td>MAY</td>
<td>1986</td>
<td>7838.42</td>
<td>84.92</td>
<td>353.10</td>
<td>438.02</td>
<td>7485.32</td>
</tr>
<tr>
<td>JUN</td>
<td>1986</td>
<td>7485.32</td>
<td>81.09</td>
<td>356.93</td>
<td>438.02</td>
<td>7128.39</td>
</tr>
<tr>
<td>JUL</td>
<td>1986</td>
<td>7128.39</td>
<td>77.22</td>
<td>360.60</td>
<td>438.02</td>
<td>6767.59</td>
</tr>
<tr>
<td>AUG</td>
<td>1986</td>
<td>6767.59</td>
<td>73.32</td>
<td>364.70</td>
<td>438.02</td>
<td>6402.89</td>
</tr>
<tr>
<td>SEP</td>
<td>1986</td>
<td>6402.89</td>
<td>69.36</td>
<td>368.66</td>
<td>438.02</td>
<td>6034.23</td>
</tr>
<tr>
<td>OCT</td>
<td>1986</td>
<td>6034.23</td>
<td>65.37</td>
<td>372.65</td>
<td>438.02</td>
<td>5661.58</td>
</tr>
<tr>
<td>NOV</td>
<td>1986</td>
<td>5661.58</td>
<td>61.33</td>
<td>376.69</td>
<td>438.02</td>
<td>5284.89</td>
</tr>
<tr>
<td>DEC</td>
<td>1986</td>
<td>5284.89</td>
<td>57.25</td>
<td>380.77</td>
<td>438.02</td>
<td>4904.12</td>
</tr>
<tr>
<td>JAN</td>
<td>1987</td>
<td>4904.12</td>
<td>53.13</td>
<td>384.89</td>
<td>438.02</td>
<td>4519.23</td>
</tr>
<tr>
<td>FEB</td>
<td>1987</td>
<td>4519.23</td>
<td>48.96</td>
<td>389.06</td>
<td>438.02</td>
<td>4130.17</td>
</tr>
<tr>
<td>MAR</td>
<td>1987</td>
<td>4130.17</td>
<td>44.74</td>
<td>393.28</td>
<td>438.02</td>
<td>3736.89</td>
</tr>
<tr>
<td>APR</td>
<td>1987</td>
<td>3736.89</td>
<td>40.48</td>
<td>397.54</td>
<td>438.02</td>
<td>3339.35</td>
</tr>
<tr>
<td>MAY</td>
<td>1987</td>
<td>3339.35</td>
<td>36.18</td>
<td>401.84</td>
<td>438.02</td>
<td>2937.51</td>
</tr>
<tr>
<td>JUN</td>
<td>1987</td>
<td>2937.51</td>
<td>31.82</td>
<td>406.20</td>
<td>438.02</td>
<td>2531.31</td>
</tr>
<tr>
<td>JUL</td>
<td>1987</td>
<td>2531.31</td>
<td>27.42</td>
<td>410.60</td>
<td>438.02</td>
<td>2120.71</td>
</tr>
<tr>
<td>AUG</td>
<td>1987</td>
<td>2120.71</td>
<td>22.97</td>
<td>415.05</td>
<td>438.02</td>
<td>1705.66</td>
</tr>
<tr>
<td>SEP</td>
<td>1987</td>
<td>1705.66</td>
<td>18.48</td>
<td>419.54</td>
<td>438.02</td>
<td>1286.12</td>
</tr>
<tr>
<td>OCT</td>
<td>1987</td>
<td>1286.12</td>
<td>13.93</td>
<td>424.09</td>
<td>438.02</td>
<td>862.03</td>
</tr>
<tr>
<td>NOV</td>
<td>1987</td>
<td>862.03</td>
<td>9.34</td>
<td>428.68</td>
<td>438.02</td>
<td>433.35</td>
</tr>
<tr>
<td>DEC</td>
<td>1987</td>
<td>433.35</td>
<td>4.67</td>
<td>433.35</td>
<td>438.02</td>
<td>0.00</td>
</tr>
<tr>
<td>TOTAL</td>
<td></td>
<td>13000.00</td>
<td>2768.72</td>
<td>13000.00</td>
<td>15768.72</td>
<td>0.00</td>
</tr>
</tbody>
</table>

Formulas—

- \( R5C4 = R4C4/12 \)
- \( R7C4 = R3C4 R5C4/(1 - 1/(1 + R5C4)^- R6C4) \)
- \( R12C5 = RC[-1]*R5C4 \)
- \( R12C6 = R7C4 - RC[-1] \)
- \( R12C7 = RC[-2] + RC[-1] \)
- \( R12c8 = RC[-4] - RC[-2] \)
- \( R4BC5, R4BC6, R4BC7 = SUM(R[-36]:RC[-1]) \)
- \( R4BC8 = RC[-4] - RC[-2] \)

Copy the formula in R13C4; select R13C4 to R47C4; edit menu-fill down. Copy the Formulas in the range R12C5 to R12C8; select R13C5 to R47 C8; edit menu-fill down.
### TABLE 2.2. BUDGETS

<table>
<thead>
<tr>
<th>ROW</th>
<th>COLUMN</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>CATEGORY</td>
</tr>
<tr>
<td>2</td>
<td>FOR 1985</td>
</tr>
<tr>
<td>3</td>
<td>NET SALARY</td>
</tr>
<tr>
<td>4</td>
<td>EXPENDITURES:</td>
</tr>
<tr>
<td>5</td>
<td>AUTO PAYMENT</td>
</tr>
<tr>
<td>6</td>
<td>CLOTHING</td>
</tr>
<tr>
<td>7</td>
<td>ENTERTAINMENT</td>
</tr>
<tr>
<td>8</td>
<td>GIFTS</td>
</tr>
<tr>
<td>9</td>
<td>GROCERIES</td>
</tr>
<tr>
<td>10</td>
<td>HOUSE PAYMENT</td>
</tr>
<tr>
<td>11</td>
<td>LUNCHES</td>
</tr>
<tr>
<td>12</td>
<td>PROPERTY TAX</td>
</tr>
<tr>
<td>13</td>
<td>REPAIRS</td>
</tr>
<tr>
<td>14</td>
<td>RESTAURANTS</td>
</tr>
<tr>
<td>15</td>
<td>TELEPHONE</td>
</tr>
<tr>
<td>16</td>
<td>UTILITIES</td>
</tr>
<tr>
<td>17</td>
<td>VACATION</td>
</tr>
<tr>
<td>18</td>
<td>TOTAL</td>
</tr>
<tr>
<td>19</td>
<td>CASH FLOW</td>
</tr>
</tbody>
</table>

Using MacPlan, you can create MacSheets for annual budgets by month, current year budget compared to prior year actual with columns for both dollar and percent increases, current year actual with forecasts for subsequent years, and so forth. The above table illustrates a personal budget by month. You can add or delete budget categories and vary the monthly data until the results are acceptable. Key MacPlan formulas are:

- \( R9C3 = RC[ -1 \) ENTER THIS FORMULA; COPY IT; SELECT R9C3 TO R9C13; FILL ACROSS
- \( R5C14 = \text{SUM(RC[ -12:RC[ -11])} \) ENTER THIS FORMULA; COPY IT; SELECT R5C14 TO R23C14; FILL DOWN
- \( R23C2 = \text{SUM(R[ -14:C:R[ -1])C} \) ENTER THIS FORMULA; COPY IT; SELECT R23C2 TO R23C14; FILL ACROSS
- \( R25C2 = \text{R[ -20]:R[ -2]} \) ENTER THIS FORMULA; COPY IT; SELECT R25C2 TO R25C14; FILL ACROSS
TABLE 2.3. CAPITAL EXPENDITURES

<table>
<thead>
<tr>
<th>Row</th>
<th>COLUMN</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>NET PRESENT VALUE—ITEM X</td>
</tr>
<tr>
<td>2</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>YEAR 0</td>
</tr>
<tr>
<td>5</td>
<td>NET PRESENT VALUE OF</td>
</tr>
<tr>
<td>6</td>
<td>INCOME STREAM</td>
</tr>
<tr>
<td>7</td>
<td>$9736</td>
</tr>
<tr>
<td>8</td>
<td>PURCHASE PRICE</td>
</tr>
<tr>
<td>9</td>
<td>$10000</td>
</tr>
<tr>
<td>10</td>
<td>NET PRESENT VALUE</td>
</tr>
<tr>
<td>11</td>
<td>($264)</td>
</tr>
<tr>
<td>12</td>
<td>DISCOUNT RATE</td>
</tr>
<tr>
<td>13</td>
<td>0.11</td>
</tr>
<tr>
<td>14</td>
<td>INVESTMENT TAX CREDIT</td>
</tr>
<tr>
<td>15</td>
<td>1000</td>
</tr>
<tr>
<td>16</td>
<td>DEPRECIATION*</td>
</tr>
<tr>
<td>17</td>
<td>1667  1667  1666</td>
</tr>
<tr>
<td>18</td>
<td>OTHER SAVINGS**</td>
</tr>
<tr>
<td>19</td>
<td>1500  1500  3000</td>
</tr>
<tr>
<td>20</td>
<td>ANNUAL CASH FLOW</td>
</tr>
<tr>
<td>21</td>
<td>4167  3167  4666</td>
</tr>
</tbody>
</table>

One of the key factors leading to a capital expenditure purchase is whether or not the purchase will yield a net positive present value. Table 2.3 illustrates how to set up a model to calculate net present value. The model assumptions could then be revised as desired, and the net present value of the revised cash flows recalculated. The key MacPlan formulas are:

\[ R11C5 = SUM(R[ - 4]C:R[ - 2]C) \]
\[ R22C6 = SUM(R[ - 6]C:R[ - 2]C) \]

*NET OF TAXES ASSUMED TO BE AT 50%.
**COST REDUCTION LESS TAXES AT 50%.
### Table 2.4. Cash Flow

<table>
<thead>
<tr>
<th>ROW</th>
<th>COLUMN</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>CASH FLOW-FIRST SIX MONTHS</td>
</tr>
<tr>
<td>2</td>
<td>ASSUMPTIONS</td>
</tr>
<tr>
<td>3</td>
<td>JAN</td>
</tr>
<tr>
<td>4</td>
<td>SALES ASSUMPTIONS</td>
</tr>
<tr>
<td>5</td>
<td>% INCREASE</td>
</tr>
<tr>
<td>6</td>
<td>15</td>
</tr>
<tr>
<td>7</td>
<td>% COLLECTED IN:</td>
</tr>
<tr>
<td>8</td>
<td>MONTH OF SALE</td>
</tr>
<tr>
<td>9</td>
<td>5</td>
</tr>
<tr>
<td>10</td>
<td>MONTH AFTER SALE</td>
</tr>
<tr>
<td>11</td>
<td>93</td>
</tr>
<tr>
<td>12</td>
<td>NEVER COLLECTED</td>
</tr>
<tr>
<td>13</td>
<td>2</td>
</tr>
<tr>
<td>14</td>
<td>TOTAL</td>
</tr>
<tr>
<td>15</td>
<td>100</td>
</tr>
<tr>
<td>16</td>
<td>PURCHASE ASSUMPTIONS:</td>
</tr>
<tr>
<td>17</td>
<td>% COST OF GOODS SOLD</td>
</tr>
<tr>
<td>18</td>
<td>60</td>
</tr>
<tr>
<td>19</td>
<td>% PURCHASED IN MONTH</td>
</tr>
<tr>
<td>20</td>
<td>PRIOR TO SALE</td>
</tr>
<tr>
<td>21</td>
<td>100</td>
</tr>
<tr>
<td>22</td>
<td>% PAID IN:</td>
</tr>
<tr>
<td>23</td>
<td>MONTH BEFORE SALE</td>
</tr>
<tr>
<td>24</td>
<td>95</td>
</tr>
<tr>
<td>25</td>
<td>MONTH OF SALE</td>
</tr>
<tr>
<td>26</td>
<td>5</td>
</tr>
<tr>
<td>27</td>
<td>TOTAL</td>
</tr>
<tr>
<td>28</td>
<td>100</td>
</tr>
<tr>
<td>29</td>
<td>RESULTS</td>
</tr>
<tr>
<td>30</td>
<td>SALES (start February)</td>
</tr>
<tr>
<td>31</td>
<td>0</td>
</tr>
<tr>
<td>32</td>
<td>COST OF SALES</td>
</tr>
<tr>
<td>33</td>
<td>0</td>
</tr>
<tr>
<td>34</td>
<td>GROSS PROFIT</td>
</tr>
<tr>
<td>35</td>
<td>0</td>
</tr>
<tr>
<td>36</td>
<td>COLLECTIONS</td>
</tr>
<tr>
<td>37</td>
<td>0</td>
</tr>
<tr>
<td>38</td>
<td>PAYMENTS</td>
</tr>
<tr>
<td>39</td>
<td>171</td>
</tr>
<tr>
<td>40</td>
<td>CASH FLOW</td>
</tr>
<tr>
<td>41</td>
<td>-171</td>
</tr>
<tr>
<td>42</td>
<td>CUMULATIVE CASH FLOW</td>
</tr>
<tr>
<td>43</td>
<td>-171</td>
</tr>
</tbody>
</table>

### TABLE 2.5. CASH DISBURSEMENTS

<table>
<thead>
<tr>
<th>ROW</th>
<th>DAY</th>
<th>CHECK #</th>
<th>AMOUNT</th>
<th>PAYEE</th>
<th>PURPOSE</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>1</td>
<td>101</td>
<td>10.79</td>
<td>JOHN’S GROCERY</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>1</td>
<td>102</td>
<td>275.60</td>
<td>ABC S &amp; L ASSOCIATION</td>
<td>MORTAGE</td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>18</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>19</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>21</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>22</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>23</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>24</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>25</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>26</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>27</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>28</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>29</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>30</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>31</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>32</td>
<td>31</td>
<td>R[-1]C</td>
<td>42.39</td>
<td>XYZ COMPANY</td>
<td>GIFT</td>
</tr>
<tr>
<td>33</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>34</td>
<td>TOTALS</td>
<td></td>
<td>SUM(R[-31]C:R[-1]C)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Cash disbursements is one of the easiest MacSheets to create. Table 2.5 illustrates an approach to setting it up. Note the use of a formula not only for the amount column, but also the check numbers.
**TABLE 2.6. CHECKBOOK RECONCILIATION**

<table>
<thead>
<tr>
<th>COLUMN</th>
</tr>
</thead>
<tbody>
<tr>
<td>ROW</td>
</tr>
<tr>
<td>1</td>
</tr>
<tr>
<td>2</td>
</tr>
<tr>
<td>3</td>
</tr>
<tr>
<td>4</td>
</tr>
<tr>
<td>5</td>
</tr>
<tr>
<td>6</td>
</tr>
<tr>
<td>7</td>
</tr>
<tr>
<td>8</td>
</tr>
<tr>
<td>9</td>
</tr>
<tr>
<td>10</td>
</tr>
<tr>
<td>11</td>
</tr>
<tr>
<td>12</td>
</tr>
<tr>
<td>13</td>
</tr>
<tr>
<td>14</td>
</tr>
<tr>
<td>15</td>
</tr>
<tr>
<td>16</td>
</tr>
<tr>
<td>17</td>
</tr>
<tr>
<td>18</td>
</tr>
<tr>
<td>19</td>
</tr>
<tr>
<td>20</td>
</tr>
<tr>
<td>21</td>
</tr>
<tr>
<td>22</td>
</tr>
<tr>
<td>23</td>
</tr>
<tr>
<td>24</td>
</tr>
</tbody>
</table>

Reconciling your bank balance need not be a frustrating experience. Table 2.6 illustrates how to set up a template you can easily use with MacPlan every month.
### TABLE 2.7. COMMISSION CALCULATION

<table>
<thead>
<tr>
<th>ROW</th>
<th>COLUMN 1</th>
<th>COLUMN 2</th>
<th>COLUMN 3</th>
<th>COLUMN 4</th>
<th>COLUMN 5</th>
<th>COLUMN 6</th>
<th>COLUMN 7</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>COMMISSION FOR MONTH OF</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Product A</td>
<td>Product B</td>
<td>Total</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Salesperson</td>
<td>Rate—6%</td>
<td>Sales</td>
<td>Commission</td>
<td>Rate—8%</td>
<td>Sales</td>
<td>Commission</td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>R. Jones</td>
<td>345</td>
<td>20.70</td>
<td>239</td>
<td>14.34</td>
<td>584</td>
<td>35.04</td>
</tr>
<tr>
<td>8</td>
<td>M. Henry</td>
<td>389</td>
<td>23.34</td>
<td>422</td>
<td>25.32</td>
<td>811</td>
<td>48.66</td>
</tr>
<tr>
<td>9</td>
<td>L. Smith</td>
<td>456</td>
<td>27.36</td>
<td>123</td>
<td>7.38</td>
<td>579</td>
<td>34.74</td>
</tr>
<tr>
<td>10</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>18</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>19</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>21</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>22</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>23</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>24</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>25</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>26</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>27</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>28</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>29</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>30</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>31</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>32</td>
<td>Grand totals</td>
<td>11456</td>
<td>687.36</td>
<td>9268</td>
<td>741.44</td>
<td>20724</td>
<td>1428.80</td>
</tr>
<tr>
<td>33</td>
<td>Average rate</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Sales commissions are easy for MacPlan to calculate as illustrated in Table 2.7. In the above illustration, commissions are calculated by product by salesperson in order to produce a daily graph that is generated by MacChart. The key formulas are:

- \( R8C3 = R(C+1)R(C+4) \)
- \( R8C6 = R(C+4) + R(C+2) \)
- \( R8C7 = R8C6 \)
- \( R32C2 = \text{SUM}(R(C+24):R(C+2)) \)
- \( R32C3 \) to \( R32C7 = R32C2 \)
- \( R34C7 = R(C+2)C(R(C+2)C) \)
### TABLE 2.8. COST ANALYSIS

<table>
<thead>
<tr>
<th>ROW</th>
<th>COLUMN</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td><strong>COST ANALYSIS FOR</strong></td>
</tr>
<tr>
<td>2</td>
<td><strong>Material</strong></td>
</tr>
<tr>
<td>3</td>
<td><strong>Labor</strong></td>
</tr>
<tr>
<td>4</td>
<td><strong>Grand Total</strong></td>
</tr>
<tr>
<td>5</td>
<td><strong>Part</strong></td>
</tr>
<tr>
<td>6</td>
<td>A</td>
</tr>
<tr>
<td>7</td>
<td>B</td>
</tr>
<tr>
<td>8</td>
<td>C</td>
</tr>
<tr>
<td>9</td>
<td>D</td>
</tr>
<tr>
<td>10</td>
<td>E</td>
</tr>
<tr>
<td>11</td>
<td>F</td>
</tr>
<tr>
<td>12</td>
<td>G</td>
</tr>
<tr>
<td>13</td>
<td>H</td>
</tr>
<tr>
<td>14</td>
<td>I</td>
</tr>
<tr>
<td>15</td>
<td>J</td>
</tr>
<tr>
<td>16</td>
<td>K</td>
</tr>
<tr>
<td>17</td>
<td>L</td>
</tr>
<tr>
<td>18</td>
<td>M</td>
</tr>
<tr>
<td>19</td>
<td>N</td>
</tr>
<tr>
<td>20</td>
<td>O</td>
</tr>
<tr>
<td>21</td>
<td>P</td>
</tr>
<tr>
<td>22</td>
<td>Q</td>
</tr>
<tr>
<td>23</td>
<td>R</td>
</tr>
<tr>
<td>24</td>
<td>S</td>
</tr>
<tr>
<td>25</td>
<td>T</td>
</tr>
<tr>
<td>26</td>
<td>U</td>
</tr>
<tr>
<td>27</td>
<td>V</td>
</tr>
<tr>
<td>28</td>
<td>W</td>
</tr>
<tr>
<td>29</td>
<td>X</td>
</tr>
<tr>
<td>30</td>
<td>Y</td>
</tr>
<tr>
<td>31</td>
<td>Z</td>
</tr>
<tr>
<td>32</td>
<td><strong>TOTALS</strong></td>
</tr>
<tr>
<td>33</td>
<td><strong>Averages</strong></td>
</tr>
</tbody>
</table>

Cost analyses are easy for MacPlan to calculate as illustrated in Table 2.8. In the above illustration, material quantities and labor hours are inserted into the MacSheet. MacPlan does the rest. The key formulas are:

- $R9C4 = RC[-2]*RC[-1]$  
- $R9C7 = R9C4$  
- $R9C8 = RC[-4] + RC[-1]$  
- $R33C2 = SUM(R[-24]:R[-2])$  
- $R33C4, R33C5, R33C7, R33C8 = R33C2$  
- $R35C3 = R[-2]C[+1]/R[-2]C[-1]$  
- $R35C6 = R35C3$
The above table illustrates depreciation using the straight line method. In addition, another template could be created to calculate Accelerated Cost Recovery System depreciation. Key formulas above are:

\[
R6C6 = IF(RC[-4]/RC[-2] > RC[-4] - R[C-1], RC[-4] - RC[-1], RC[-4]/RC[-2])
\]

Note the use of the "IF()" function. The general form of the function is: if the condition being tested is true, use the value immediately following the commas; if it's false, use the second value. In this case, the condition being tested is whether or not annual depreciation is greater than the remaining depreciation to be taken (cost less accumulated depreciation). If annual depreciation is greater, then depreciation is limited to cost less accumulated depreciation; otherwise annual depreciation is used. Use the Fill Down feature to copy all of the formulas in columns 6 and 8.

\[
R6C8 = RC[-3] + RC[-2] - RC[-1]
\]

\[
R15C2 = SUM(R[-9]:R[-1])
\]

\[
R15C5 TO R15C8 = R15C2
\]
TABLE 2.10. EXPENSE REPORTS

<table>
<thead>
<tr>
<th>ROW</th>
<th>COLUMN</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
<th>7</th>
<th>8</th>
<th>9</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>EXPENSE REPORT FOR WEEK OF</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>EMPLOYEE NAME</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>ITEM</td>
<td>SUN</td>
<td>MON</td>
<td>TUE</td>
<td>WED</td>
<td>THU</td>
<td>FRI</td>
<td>SAT</td>
<td>TOTAL</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>HOTEL</td>
<td>4.00</td>
<td>3.75</td>
<td>3.95</td>
<td>4.50</td>
<td>5.50</td>
<td>21.70</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>BREAKFAST</td>
<td>6.00</td>
<td>6.00</td>
<td>6.00</td>
<td>6.00</td>
<td>30.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>LUNCH</td>
<td>12.50</td>
<td>15.00</td>
<td>13.00</td>
<td>30.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>DINNER</td>
<td>5.60</td>
<td>5.60</td>
<td>11.20</td>
<td>30.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>TAXI</td>
<td>85.00</td>
<td>85.00</td>
<td>85.00</td>
<td>85.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Templates can be set up for recurring types of forms using a "fill-in-the-blanks" approach. The obvious advantage of this is that all of the math can be delegated to MacPlan. The above form illustrates how to set up these types of fill-in-the-blanks forms. Notice the control formula in R21C9, which ensures that the MacSheet "crossfoots." Key formulas follow:

R8C9 = SUM(RC(-7):RC(-1)) FILL DOWN TO ROW 20
R21C2 = SUM(R(-13):R(-1):C) R21C3 TO R21C8 = R21C2
R21C9 = IF(SUM(R(-13):R(-1):C) = SUM(RC(-7):RC(-1)), SUM(RC(-7):RC(-1), "ERROR")
### TABLE 2.11. FINANCING ALTERNATIVES

<table>
<thead>
<tr>
<th>ROW</th>
<th>BANK FINANCING</th>
<th>SELLER FINANCING</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>CASH PURCHASE PRICE 10000</td>
<td>UNEQUAL ANNUAL PAYMENTS</td>
</tr>
<tr>
<td>4</td>
<td>BANK BORROWING RATE 0.13</td>
<td>SHOWN IN TABLE BELOW;</td>
</tr>
<tr>
<td>5</td>
<td>ANNUAL PAYMENTS 2843.14</td>
<td>OWNERSHIP PASSES TO</td>
</tr>
<tr>
<td>6</td>
<td></td>
<td>BUYER AT END OF LEASE</td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>BANK</td>
<td>LEASE</td>
</tr>
<tr>
<td>12</td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>1985</td>
<td>2843</td>
</tr>
<tr>
<td>15</td>
<td>1986</td>
<td>2843</td>
</tr>
<tr>
<td>16</td>
<td>1987</td>
<td>2843</td>
</tr>
<tr>
<td>17</td>
<td>1988</td>
<td>2843</td>
</tr>
<tr>
<td>18</td>
<td>1989</td>
<td>2844</td>
</tr>
<tr>
<td>19</td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>TOTAL</td>
<td>14217</td>
</tr>
<tr>
<td>21</td>
<td></td>
<td></td>
</tr>
<tr>
<td>22</td>
<td></td>
<td></td>
</tr>
<tr>
<td>23</td>
<td></td>
<td></td>
</tr>
<tr>
<td>24</td>
<td>NET PRESENT VALUE</td>
<td>10000</td>
</tr>
</tbody>
</table>

We are frequently confronted with a financial decision between two alternatives that are difficult to evaluate. The above illustrates one of these circumstances. While the payments to the seller are lower in the earlier periods, they are higher in the later periods. As MacPlan indicates, we are better off with the bank financing because it has a lesser present value and is therefore more favorable. The key formulas are:

\[
\]

\[
R20C5 = \text{SUM}(R[-6]C:R[-1]C)
\]

\[
R14C7 = RC[-2] - RC[-1]
\]

\[
R24C5 = \text{NPV}(R5C4, R[-10]C: R[-5]C)
\]
### TABLE 2.12. IMPOUNDS

<table>
<thead>
<tr>
<th>ROW</th>
<th>COLUMN</th>
<th>PROPERTY</th>
<th>DESCRIPTION</th>
<th>TAX</th>
<th>XMAS</th>
<th>UTILITIES</th>
<th>VACATION</th>
<th>TOTAL</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
<td>ANNUAL PAYMENT—)</td>
<td>1200</td>
<td>1500</td>
<td>2400</td>
<td>1800</td>
<td>6900</td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td>MONTHLY DEPOSIT—)</td>
<td>100</td>
<td>125</td>
<td>200</td>
<td>150</td>
<td>575</td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
<td>BALANCE 1/1/198X</td>
<td>200</td>
<td>0</td>
<td>0</td>
<td>900</td>
<td>1100</td>
</tr>
<tr>
<td>9</td>
<td></td>
<td></td>
<td>ADDITIONS</td>
<td>100</td>
<td>125</td>
<td>200</td>
<td>150</td>
<td>575</td>
</tr>
<tr>
<td>10</td>
<td></td>
<td></td>
<td>WITHDRAWALS</td>
<td>0</td>
<td>0</td>
<td>85</td>
<td>0</td>
<td>85</td>
</tr>
<tr>
<td>11</td>
<td></td>
<td></td>
<td>BALANCE 1/31/8X</td>
<td>300</td>
<td>125</td>
<td>115</td>
<td>1050</td>
<td>1590</td>
</tr>
<tr>
<td>12</td>
<td></td>
<td></td>
<td>ADDITIONS</td>
<td>100</td>
<td>125</td>
<td>200</td>
<td>150</td>
<td>575</td>
</tr>
<tr>
<td>13</td>
<td></td>
<td></td>
<td>WITHDRAWALS</td>
<td>0</td>
<td>0</td>
<td>380</td>
<td>0</td>
<td>380</td>
</tr>
<tr>
<td>14</td>
<td></td>
<td></td>
<td>BALANCE 2/28/8X</td>
<td>400</td>
<td>250</td>
<td>-65</td>
<td>1200</td>
<td>1785</td>
</tr>
<tr>
<td>15</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>18</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>19</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>21</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>22</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>23</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>24</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>25</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>26</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>27</td>
<td></td>
<td></td>
<td>BALANCE 12/31/8X</td>
<td>250</td>
<td>140</td>
<td>100</td>
<td>220</td>
<td>710</td>
</tr>
</tbody>
</table>

Everyone has some expenses for which payments are not made ratably throughout the year. By using the impound approach, you can plan ahead to determine how much you have to deposit in a savings (or money market checking) account each month such that, when payments are due, there will be sufficient amounts in the account to make the payments. In addition to assuring that you won’t get caught short, you will even earn interest on the account balance. The way it works is as follows: in row 5, enter your estimate of the annual amounts. The formulas in row 6 calculate the monthly payments and the formulas in rows 9, 12, 15, etc. use these amounts (you can change any amount, which causes the formulas in succeeding rows to use the new amount). When payments are due, enter them in rows 10, 13, 16, etc. The formulas in rows 11, 14, and 17, etc., calculate your new balance for each account and in total. Each month, you transfer to (from) your savings account the difference between the additions and payments. In addition to the formulas that sum the rows across, the formulas are:

- \( R6C2 = R[-1]C12 \)
- \( R6C3 \) TO \( R6C6 = R6C2 \)
- \( R9C2 = R[-3]C \)
- \( R9C3 \) TO \( R9C6 = R9C2 \) (and rows 12, 15 etc.)
- \( R11C3 \) TO \( R11C6 = R11C2 \)
Table 2.13. INCOME TAXES

<table>
<thead>
<tr>
<th>ROW</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>1984</td>
<td>1983</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>GROSS SALARY:</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>JOHN</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>MARY</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>TOTAL</td>
<td>R[-2]C + R[-1]C</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>LESS EMPLOYEE BUSINESS EXPENSES</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>NET SALARY</td>
<td>R[-3]C - R[-2]C</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>INTEREST (INCOME)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>GROSS INCOME</td>
<td>R[-2]C + R[-1]C</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>DEDUCTIONS:</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>MEDICAL</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>INTEREST</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>TAXES</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>CONTRIBUTIONS</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>OTHER</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>ZERO BRACKET</td>
<td>- 3400</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>TOTAL DEDUCTIONS</td>
<td>SUM(R[-7]C,R[-2]C)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>TAXABLE INCOME</td>
<td>R[-12]C - R[-2]C</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td>TAX</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>18</td>
<td>WITHHOLDING</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>19</td>
<td>ESTIMATED PAYMENTS</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>21</td>
<td>TAX TABLE</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>22</td>
<td>TAXABLE INCOME</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>23</td>
<td>TAX</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>24</td>
<td>INCOME</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>25</td>
<td>NA</td>
<td>#N/A</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>26</td>
<td>16000</td>
<td>**</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>27</td>
<td>20200</td>
<td>**</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>28</td>
<td>24600</td>
<td>**</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>29</td>
<td>29800</td>
<td>**</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*The formula is LOOKUP (R[-2]C,R[-12]C[-1]:R[-16]C[-1]). In this mini-example, MacPlan gets the value, taxable income, and searches through rows 37 through 41 of column 3. When it finds a number exceeding it, MacPlan goes back one row and gets the corresponding value in column 4. If you want to use this format, the values in column 4 (which actually compute the tax) should be obtained from a tax table for that year.

**The formula is IF(OR(R24C4<x,R24C4<y),NA(),d+e*(R24C4-y) where x = the next highest tax bracket (R[-1]C[-1]), y = RC[-1] (this tax bracket), d = the minimum tax for this tax bracket, and e = the tax rate for this tax bracket. For example:

\[
\text{IF(OR(R[-4]C[-1]:24600,R[-14]C[-1])(20200),NA(),2.644 + 0.23*(R[-14]C[-1] - 20200))}
\]
<table>
<thead>
<tr>
<th>ROW</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
<th>7</th>
<th>8</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>ITEM A</td>
<td>ITEM B</td>
<td>ITEM C</td>
<td>ITEM D</td>
<td>ITEM E</td>
<td>ITEM F</td>
<td>ITEM G</td>
<td>ITEM H</td>
</tr>
<tr>
<td>11</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>18</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>19</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>21</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>22</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>23</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>24</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>25</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

This little schedule, together with MacPlan's help, calculates effects of inflation. For any year or years, just drop in the inflation amounts in row 6, columns 3 through 5, and the related dollar amounts beginning in row 11. MacPlan then uses the deflator index in row 6, columns 6 through 8, to deflate the dollar amounts in columns 3 through 5. The key formulas are:

\[
\begin{align*}
R6C6 &= \frac{R[-3]}{R[-3]} \\
R6C7 &= \frac{R[-4]}{R[-3]} \\
R6C8 &= \frac{R[-5]}{R[-3]} \\
R11C6 &= R[-3] \times R6C6 \\
R11C7 &= R[-3] \times R6C7 \\
R11C8 &= R[-3] \times R6C8
\end{align*}
\]
<table>
<thead>
<tr>
<th>ROW</th>
<th>PART</th>
<th>QUANTITY</th>
<th>WHERE</th>
<th>DAILY AVERAGE</th>
<th>UN SOLD</th>
<th>DAYS</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>DESCRIPTION</td>
<td>ON HAND</td>
<td>USED</td>
<td>UNITS SOLD</td>
<td>SALES ORDERS</td>
<td>INVENTORY ON HAND</td>
</tr>
<tr>
<td>1</td>
<td>2 3 4 5 6</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>PART A</td>
<td>1005</td>
<td>PRODUCT 1</td>
<td>25</td>
<td>305</td>
<td>28</td>
</tr>
<tr>
<td>8</td>
<td>PART B</td>
<td>2000</td>
<td>PRODUCT 2</td>
<td>30</td>
<td>1233</td>
<td>26</td>
</tr>
<tr>
<td>9</td>
<td>PART C</td>
<td>1500</td>
<td>PRODUCT 3</td>
<td>22</td>
<td>987</td>
<td>23</td>
</tr>
<tr>
<td>10</td>
<td>PART D</td>
<td>170</td>
<td>PRODUCT 4</td>
<td>6</td>
<td>56</td>
<td>19</td>
</tr>
<tr>
<td>11</td>
<td>PART E</td>
<td>6000</td>
<td>PRODUCT 5</td>
<td>55</td>
<td>2800</td>
<td>58</td>
</tr>
<tr>
<td>12</td>
<td>PART F</td>
<td>4500</td>
<td>PRODUCT 6</td>
<td>43</td>
<td>2100</td>
<td>56</td>
</tr>
<tr>
<td>13</td>
<td>PART G</td>
<td>699</td>
<td>PRODUCT 7</td>
<td>12</td>
<td>57</td>
<td>54</td>
</tr>
</tbody>
</table>

Inventory is a key factor in determining the success or failure of any product-oriented business. Carrying too much inventory reduces cash liquidity, whereas carrying too little can result in lost sales or untimely sales-order fulfillment. The example below is a sample analysis of quantities on hand to pinpoint problem areas. The key formula is:

\[ R7C6 = \text{ROUND}((\text{RC[-4]} - \text{RC[-1]})/\text{RC[-2]},0) \]

R8C6 TO R13C6 = R7C6
### TABLE 2.16. MARKET ANALYSIS

<table>
<thead>
<tr>
<th>ROW</th>
<th>PART DESCRIPTION</th>
<th>COMPANY UNITS SOLD</th>
<th>INDUSTRY UNITS SOLD</th>
<th>ACTUAL MARKET SHARE</th>
<th>PLANNED MARKET SHARE</th>
<th>PERCENT INCREASE</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1983 ACTUAL</td>
<td>1984</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>PRODUCT 1</td>
<td>7625</td>
<td>91500</td>
<td>8.33%</td>
<td>8.50%</td>
<td>2.00%</td>
</tr>
<tr>
<td>3</td>
<td>PRODUCT 2</td>
<td>38990</td>
<td>487000</td>
<td>7.60%</td>
<td>7.98%</td>
<td>5.00%</td>
</tr>
<tr>
<td>4</td>
<td>PRODUCT 3</td>
<td>21714</td>
<td>250000</td>
<td>8.69%</td>
<td>8.12%</td>
<td>-6.50%</td>
</tr>
<tr>
<td>5</td>
<td>PRODUCT 4</td>
<td>1096</td>
<td>15000</td>
<td>7.31%</td>
<td>7.96%</td>
<td>9.00%</td>
</tr>
<tr>
<td>6</td>
<td>PRODUCT 5</td>
<td>154000</td>
<td>2000000</td>
<td>7.70%</td>
<td>7.47%</td>
<td>-3.00%</td>
</tr>
<tr>
<td>7</td>
<td>PRODUCT 6</td>
<td>90300</td>
<td>1100000</td>
<td>8.21%</td>
<td>8.74%</td>
<td>6.50%</td>
</tr>
<tr>
<td>8</td>
<td>PRODUCT 7</td>
<td>6840</td>
<td>78000</td>
<td>8.77%</td>
<td>7.72%</td>
<td>-12.00%</td>
</tr>
</tbody>
</table>

The analysis above compares company units sold to industry units sold to calculate the actual market share for the prior year. Then, the current year forecast is compared to the prior year actual, and the percentage increase or decrease is calculated. As the analysis demonstrates, MacPlan can be used to make market share calculations as well as accounting calculations. The key formulas are:

- \( R7C4 = \frac{RC[-2]}{RC[-1]} \)
- \( R8C4 \) TO \( R13C4 = R7C4 \)
- \( R7C6 = \left( \frac{RC[-1]}{RC[-2]} \right) / RC[-2] \)
- \( R8C6 \) TO \( R13C6 = R7C6 \)
## TABLE 2.17. OVERHEAD ALLOCATION

<table>
<thead>
<tr>
<th>ROW</th>
<th>PRODUCT</th>
<th>UNITS</th>
<th>MATERIAL COST</th>
<th>LABOR COST</th>
<th>ALLOCATED</th>
<th>TOTAL COST</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>ITEM 1</td>
<td>25+</td>
<td>1.67</td>
<td>424.18</td>
<td>1.15</td>
<td>292.10</td>
</tr>
<tr>
<td>4</td>
<td>ITEM 2</td>
<td>143</td>
<td>2.11</td>
<td>301.73</td>
<td>5.32</td>
<td>760.76</td>
</tr>
<tr>
<td>5</td>
<td>ITEM 3</td>
<td>502</td>
<td>0.85</td>
<td>326.3</td>
<td>0.98</td>
<td>491.96</td>
</tr>
<tr>
<td>6</td>
<td>ITEM 4</td>
<td>165</td>
<td>1.12</td>
<td>184.8</td>
<td>1.98</td>
<td>326.70</td>
</tr>
<tr>
<td>7</td>
<td>ITEM 5</td>
<td>187</td>
<td>1.32</td>
<td>246.84</td>
<td>2.23</td>
<td>417.01</td>
</tr>
<tr>
<td>8</td>
<td>ITEM 6</td>
<td>654</td>
<td>0.98</td>
<td>640.92</td>
<td>1.12</td>
<td>732.48</td>
</tr>
<tr>
<td>9</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>18</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>19</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>21</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>22</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>23</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>24</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>25</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>26</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>27</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>28</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>29</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>30</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>31</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>32</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>33</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>34</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

While the primary purpose of this example is to illustrate how MacPlan can calculate and allocate overhead for you, the example also illustrates how a MacSheet can be set up to price the entire inventory. After setting up the MacSheet, the user would enter the number of units, and MacPlan would do the extensions of the material cost, labor cost, and, after the overhead calculation, calculate the total cost column as well. The key formulas are:

- \( R4C4 = RC[-2]*RC[-1] \)
- \( R5C4 \) to \( R30C4 = R4C4 \)
- \( R4C6 = RC[-4]*RC[-1] \)
- \( R5C6 \) to \( R30C6 = R4C6 \)
- \( R4C7 = RC[-1]/R32C6*R32C7 \)
- \( R5C7 \) to \( R30C7 = R4C7 \)
- \( R4C8 = RC[-4] - RC[-2] + RC[-1] \)
- \( R5C8 \) to \( R30C8 = R4C8 \)
- \( R32C4 = SUM(R[-28]:R[-2]:C) \)
- \( R32C4 \) to \( R32C8 = R32C4 \)

84
### TABLE 2.18. PAYROLL

<table>
<thead>
<tr>
<th>ROW</th>
<th>COLUMN</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>EMPLOYEE WORKED</td>
</tr>
<tr>
<td>2</td>
<td>J. Jones</td>
</tr>
<tr>
<td>4</td>
<td>M. Smith</td>
</tr>
<tr>
<td>6</td>
<td>N. Layton</td>
</tr>
<tr>
<td>7</td>
<td>H. Able</td>
</tr>
</tbody>
</table>

Payroll is not only an area that is extremely sensitive, it is easily susceptible to error. If you don't want to use a bank payroll service or if you want to precalculate salary expense, let MacPlan do it for you. In addition to calculating gross pay, you could expand the MacSheet to include deductions by using the Lookup function illustrated in Table 2.13. In addition to the row and column totals, the key formulas are the regular and overtime pay as follows:

\[
R4C5 = (R4C3 - 0.5) \times R4C2
\]

\[
R5C5 \text{ TO } R30C5 = R4C5
\]

\[
R4C6 = \text{IF}(R4C4 < 40, R4C3 \times R4C2, R4C4 - 40) \times R4C2
\]

\[
R5C6 \text{ TO } R30C6 = R4C6
\]
People are generally your most important assets. Maintaining information on compensation history is a valuable tool for evaluating and awarding compensation increases. Other applications include requirements planning. In addition to calculating the increase as a percentage, it could be supplemented with the absolute dollar increase. The key formula for the percentage increase by employee and in total is illustrated by the formulas in row 4 as follows:

\[
\text{R4C4} = \frac{(\text{RC}[ -1] - \text{RC}[ -2])}{\text{RC}[ -2]}
\]

\[
\text{R4C6} = \frac{(\text{RC}[ -1] - \text{RC}[ -3])}{\text{RC}[ -3]}
\]

<table>
<thead>
<tr>
<th>ROW</th>
<th>EMPLOYEE</th>
<th>1982 AMOUNT</th>
<th>1983 AMOUNT</th>
<th>INCREASE</th>
<th>1984 AMOUNT</th>
<th>INCREASE</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td>2 3 4 5 6 7</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>J. Smith</td>
<td>15750</td>
<td>17325</td>
<td>10.00%</td>
<td>18538</td>
<td>7.00%</td>
</tr>
<tr>
<td>5</td>
<td>B. Doe</td>
<td>16500</td>
<td>18480</td>
<td>12.00%</td>
<td>19404</td>
<td>5.00%</td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>18</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>19</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>21</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>22</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>23</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>24</td>
<td></td>
<td>483690</td>
<td>536896</td>
<td>11.00%</td>
<td>569962</td>
<td>5.60%</td>
</tr>
<tr>
<td>25</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>26</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>27</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>28</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>29</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>30</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>31</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>32</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>33</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>34</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### TABLE 2.20. PROJECTIONS

<table>
<thead>
<tr>
<th>ROW</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
<th>7</th>
<th>8</th>
<th>9</th>
<th>10</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>UNIT VOLUME</td>
<td></td>
<td>UNIT PRICING</td>
<td></td>
<td>EXTENDED DOLLARS</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>1984</td>
<td>% Incr</td>
<td>1985</td>
<td>% Incr</td>
<td>Price</td>
<td>% Incr</td>
<td>Price</td>
<td>1984</td>
<td>1985</td>
<td>% Incr</td>
</tr>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>18</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>19</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>21</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>22</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>23</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>24</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>25</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Using MacPlan, you can easily project entire income statements such as the one illustrated above. You can vary the percentage volume and price increases/decreases and see the effect thereof on all of the revenue, product cost, and gross profit calculations. All of the totals are also automatically calculated. In addition, percentage increases are calculated for selling, administrative, and interest expense. Key formulas are:

\[
R8C4 = \frac{RC(-2) \cdot RC(-1)}{100} \quad R9C4, R8C7, R9C7, R12C7, R13C7 = R8C4
\]

\[
R8C8 = \frac{RC(-6) \cdot RC(-3)}{100} \quad R9C8 = R8C8
\]

\[
R8C9 = \frac{RC(-5) \cdot RC(-2)}{100} \quad R9C9 = R8C9
\]

\[
R8C10 = \frac{(RC(-1) - RC(-2)) \cdot RC(-2)}{RC(-2)} \quad R8C10 = R8C10
\]
### TABLE 2.21. PRODUCTIVITY ANALYSIS

<table>
<thead>
<tr>
<th>ROW</th>
<th>COLUMN</th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td>Total</td>
<td>Total</td>
<td>Units</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td>hours</td>
<td>units</td>
<td>produced</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td>worked</td>
<td>produced</td>
<td>per hour</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Employee</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>A</td>
<td>2704</td>
<td>3304</td>
<td>1.22</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>B</td>
<td>2392</td>
<td>3409</td>
<td>1.43</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>C</td>
<td>2184</td>
<td>3243</td>
<td>1.48</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>D</td>
<td>1976</td>
<td>3198</td>
<td>1.62</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>E</td>
<td>2090</td>
<td>3300</td>
<td>1.58</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>Totals</td>
<td>11346</td>
<td>16454</td>
<td>1.45</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>Minimum</td>
<td>1976</td>
<td>3198</td>
<td>1.22</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>18</td>
<td>Maximum</td>
<td>2704</td>
<td>3409</td>
<td>1.62</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>19</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>Average</td>
<td>2269</td>
<td>3291</td>
<td>1.47</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Employee productivity is critical to the success of a business. Even more critical is timely management followup. However, reviewing quantitative data and calculating averages or other data necessary for management purposes is frequently a time-consuming process. In this regard, MacPlan can save you time and identify key items for followup. The table above illustrates that working more hours doesn’t necessarily result in continued productivity; to the contrary, frequently it results in declining productivity. The key formulas are:

\[
R16C3 = \min(R[(-10):C:C], R[(-6):C]) \quad \text{R16C5, R16C7} = \text{R16C3}
\]
\[
R18C3 = \min(R[(-12):C:C], R[(-8):C]) \quad \text{R18C5, R18C7} = \text{R18C3}
\]
\[
R20C3 = \text{AVERAGE}(R[(-14):C:C], R[(-10):C]) \quad \text{R20C5, R20C7} = \text{R20C3}
\]
TABLE 2.22. REVENUE ANALYSIS

<table>
<thead>
<tr>
<th>ROW</th>
<th>COLUMN</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Jim's Store</td>
</tr>
<tr>
<td>2</td>
<td>Revenue Analysis</td>
</tr>
<tr>
<td>3</td>
<td>1985 Forecast</td>
</tr>
<tr>
<td>4</td>
<td>1985</td>
</tr>
<tr>
<td>5</td>
<td>Product</td>
</tr>
<tr>
<td>6</td>
<td>Jan</td>
</tr>
<tr>
<td>7</td>
<td>1984</td>
</tr>
<tr>
<td>8</td>
<td>A:</td>
</tr>
<tr>
<td>9</td>
<td>Units</td>
</tr>
<tr>
<td>10</td>
<td>Price</td>
</tr>
<tr>
<td>11</td>
<td>Sales</td>
</tr>
<tr>
<td>12</td>
<td>Total</td>
</tr>
<tr>
<td>13</td>
<td>B:</td>
</tr>
<tr>
<td>14</td>
<td>Units</td>
</tr>
<tr>
<td>15</td>
<td>Price</td>
</tr>
<tr>
<td>16</td>
<td>Sales</td>
</tr>
<tr>
<td>17</td>
<td>C:</td>
</tr>
<tr>
<td>18</td>
<td>Units</td>
</tr>
<tr>
<td>19</td>
<td>Price</td>
</tr>
<tr>
<td>20</td>
<td>Sales</td>
</tr>
<tr>
<td>21</td>
<td>Total</td>
</tr>
<tr>
<td>22</td>
<td>TOTALS</td>
</tr>
</tbody>
</table>

The above table illustrates an approach to setting up a monthly forecast of revenues by product. For each product, the unit quantities and selling prices are inserted into the MacSheet, and MacPlan does the rest. The key formulas are:

- \( R10C14 = \text{SUM}(R[C-12]:R[C-1]) \)
- \( R12C2 = \text{INT}(R[-2]C*R[-1]C) \)
TABLE 2.23. SALARY ANALYSIS

<table>
<thead>
<tr>
<th>ROW</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
<th>7</th>
<th>8</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>UNADJUSTED</td>
<td>ADJUSTED FOR INFLATION</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Year</td>
<td>Increase</td>
<td>%</td>
<td>Salary</td>
<td>Inflation factor</td>
<td>Real salary</td>
<td>Increase</td>
<td>%</td>
</tr>
<tr>
<td>5</td>
<td>19×1</td>
<td>2800</td>
<td>9.6%</td>
<td>32000</td>
<td>9.0%</td>
<td>29358</td>
<td>-158</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>19×2</td>
<td>2800</td>
<td>8.8%</td>
<td>34800</td>
<td>5.0%</td>
<td>33143</td>
<td>3785</td>
<td>12.9%</td>
</tr>
<tr>
<td>7</td>
<td>19×3</td>
<td>2500</td>
<td>7.2%</td>
<td>37300</td>
<td>3.0%</td>
<td>36214</td>
<td>3071</td>
<td>9.3%</td>
</tr>
<tr>
<td>8</td>
<td>19×4</td>
<td>2400</td>
<td>6.4%</td>
<td>39700</td>
<td>4.0%</td>
<td>38173</td>
<td>1959</td>
<td>5.4%</td>
</tr>
</tbody>
</table>

Near and dear to all of our hearts is our own compensation. Since we are all impacted by inflation, you might want to see what your own compensation increases look like when they are adjusted for the effects of inflation. While you would not use this MacSheet very frequently, nonetheless it is useful should you need some documentation during salary "negotiations," and it will also give you some good practice in working with MacPlan. The key formulas are:

\[
R8C3 = R[-1]/R[-1]C[+1]
\]
\[
R8C6 = R[-2] / (1 + R[-1]C[-1])
\]
\[
R8C7 = R[-1] - R[-1]C[-1]
\]
\[
R8C8 = R[-1] / R[-2]
\]
TABLE 2.24. SELLING EXPENSE ANALYSIS

<table>
<thead>
<tr>
<th>ROW</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
<th>7</th>
<th>8</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>BUDGET</td>
<td>ACTUAL</td>
<td>VARIANCE</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Amount</td>
<td>%</td>
<td>Amount</td>
<td>%</td>
<td>Amount</td>
<td>%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>Sales</td>
<td>500000</td>
<td>100.0%</td>
<td>525000</td>
<td>100.0%</td>
<td>25000</td>
<td>5.0%</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Selling expenses</td>
<td>45000</td>
<td>9.0%</td>
<td>4875</td>
<td>10.8%</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Override</td>
<td>10000</td>
<td>2.0%</td>
<td>10500</td>
<td>3.1%</td>
<td>500</td>
<td>5.0%</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Trade shows</td>
<td>25000</td>
<td>5.0%</td>
<td>28000</td>
<td>5.3%</td>
<td>3000</td>
<td>12.0%</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Travel</td>
<td>15000</td>
<td>3.0%</td>
<td>17500</td>
<td>3.3%</td>
<td>2500</td>
<td>16.7%</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Totals</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Comparing actual to budget is purely an exercise in mathematics, for which MacPlan is ideally suited. While the example above illustrates selling expenses, MacPlan is equally adept in all categories that require comparisons. The key formulas are:

- \( R5C6 = R[-2] - R[-4] \)
- \( R5C7 = (R[-1]/R[-5]) \)
- \( R11C3 = R[-1]/R5C2 \)
- \( R11C5 = R[-1]/R5C4 \)
- \( R11C7 = R[-1]/R5C6 \)
TABLE 2.25. STOCK PORTFOLIO

<table>
<thead>
<tr>
<th>ROW</th>
<th>Security</th>
<th># of Shares</th>
<th>Date purchased</th>
<th>Cost</th>
<th>Market value</th>
<th>Gain/loss</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Security</td>
<td># of Shares</td>
<td>Date purchased</td>
<td>Cost</td>
<td>Market value</td>
<td>Gain/loss</td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>A</td>
<td>100</td>
<td>6-24-80</td>
<td>12.50</td>
<td>1250.00</td>
<td>13.25</td>
</tr>
<tr>
<td>6</td>
<td>A</td>
<td>50</td>
<td>8-24-81</td>
<td>14.00</td>
<td>700.00</td>
<td>13.25</td>
</tr>
<tr>
<td>7</td>
<td>B</td>
<td>200</td>
<td>3-11-82</td>
<td>3.75</td>
<td>750.00</td>
<td>5.75</td>
</tr>
<tr>
<td>8</td>
<td>C</td>
<td>175</td>
<td>4-15-83</td>
<td>5.75</td>
<td>1006.25</td>
<td>6.00</td>
</tr>
<tr>
<td>9</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Total</td>
<td></td>
<td></td>
<td></td>
<td>3706.25</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

If you own stocks or keep track of stocks for others, let MacPlan do all of the calculations for you. The key formulas are:

\[
R5C5 = RC[-3] * RC[-1]
\]

\[
R5C7 = RC[-5] * RC[-1]
\]

\[
R5C8 = RC[-1] - RC[-3]
\]

\[
R10C5 = SUM(R[-5]:R[-2])
\]
TABLE 2.26. TIME MANAGEMENT

<table>
<thead>
<tr>
<th>ROW</th>
<th>HOURS</th>
<th>ACTUAL</th>
<th>FORECAST</th>
<th>VARIANCE</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>6</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>7</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>A</td>
<td>125</td>
<td>155</td>
<td>30</td>
</tr>
<tr>
<td>8</td>
<td>B</td>
<td>63</td>
<td>60</td>
<td>-3</td>
</tr>
<tr>
<td>9</td>
<td></td>
<td>7.5%</td>
<td>2.9%</td>
<td>-0.1%</td>
</tr>
<tr>
<td>10</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td>Subtotal</td>
<td>1876</td>
<td>1900</td>
<td>24</td>
</tr>
<tr>
<td>18</td>
<td></td>
<td>90.2%</td>
<td>91.3%</td>
<td>1.2%</td>
</tr>
<tr>
<td>19</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>Admin</td>
<td>230</td>
<td>180</td>
<td>-50</td>
</tr>
<tr>
<td>21</td>
<td></td>
<td>11.1%</td>
<td>8.7%</td>
<td>-2.4%</td>
</tr>
<tr>
<td>22</td>
<td>Total</td>
<td>2106</td>
<td>2080</td>
<td>-26</td>
</tr>
<tr>
<td>23</td>
<td></td>
<td>101.3%</td>
<td>100.0%</td>
<td>-1.3%</td>
</tr>
<tr>
<td>24</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Analyzing the difference between actual and forecast hours can be a significant time consumer. Delegating the calculations to MacPlan will free up your time, which is better spent on improving how your current time is being spent. The key formulas for the above table are:

\[ R8C3 = \frac{RC[-1]}{2080} \]
\[ R8C5 = \frac{RC[-1]}{R[-1]C[-1]} \]
\[ R8C6 = \frac{RC[-2] - RC[-4]}{} \]
\[ R8C7 = \frac{RC[-1]}{R22C4} \]
### TABLE 2.27. VARIANCE ANALYSIS

<table>
<thead>
<tr>
<th>ROW</th>
<th>COLUMN</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>VARIANCE ANALYSIS—MONTH 8</td>
</tr>
<tr>
<td>3</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>1984</td>
</tr>
<tr>
<td>6</td>
<td>1983 Actual</td>
</tr>
<tr>
<td>7</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Category</td>
</tr>
<tr>
<td>11</td>
<td></td>
</tr>
<tr>
<td>12</td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>Auto</td>
</tr>
<tr>
<td>14</td>
<td>Rent</td>
</tr>
<tr>
<td>15</td>
<td>Water</td>
</tr>
<tr>
<td>16</td>
<td></td>
</tr>
<tr>
<td>17</td>
<td></td>
</tr>
<tr>
<td>18</td>
<td></td>
</tr>
<tr>
<td>19</td>
<td></td>
</tr>
<tr>
<td>20</td>
<td></td>
</tr>
<tr>
<td>21</td>
<td></td>
</tr>
<tr>
<td>22</td>
<td></td>
</tr>
<tr>
<td>23</td>
<td></td>
</tr>
<tr>
<td>24</td>
<td></td>
</tr>
<tr>
<td>25</td>
<td></td>
</tr>
<tr>
<td>26</td>
<td></td>
</tr>
<tr>
<td>27</td>
<td>Totals</td>
</tr>
<tr>
<td>28</td>
<td></td>
</tr>
</tbody>
</table>

Whether for business or personal use, this model should provide you with all of the data you need to track overages so that you can take corrective action. The key formulas are:

\[
\begin{align*}
R14C3 &= R[-1]/12 & R14C5 &= R14C3 \\
R14C9 &= R[-1]/R[-6] \\
R14C10 &= R[-3] - R[-5] \\
R14C11 &= R[-1]/R[-6]
\end{align*}
\]
Chapter 3
 USING MacWrite
If you presently use traditional tools such as pencil, paper, and typewriter, MacWrite will be of significant benefit to you. In this chapter, we'll explore the following topics:

- What MacWrite can do for you
- Ideas for using MacWrite
- Working with MacWrite features
- Case study—creating and modifying a MacWrite document

WHAT MacWrite CAN DO FOR YOU

MacWrite is a word processor that can (1) save you time, (2) put you in control over textual documents, (3) reduce the turnaround time to create a finished document, and (4) help you produce a professional looking document. To illustrate how these benefits can be derived, we'll begin by taking a close look at the document life cycle. After that, we'll explore the details of the benefits to be derived.

Document Life Cycle

Whether they be short memos or voluminous manuscripts, all documents have the same steps in their life cycle. Consider the illustration in Figure 3.1.

PREPARE FIRST DRAFT

The first step in the life cycle is the creation of a document. In many instances, the document is originated with pencil and paper. In some cases, it is created with dictating equipment.

TYPE DRAFT

After a document has been created, typically it is converted to typewritten form. In an office environment, that process is handled by a secretary or typist in a typing pool. At home, the document is converted either by you, a relative, a friend, or a paid second party. The important point is not who converts it; rather, it is the conversion process itself that is of interest and leads us to the next step.
Figure 3.1 Flow Chart of the Document Life Cycle.
REVISE DRAFT

Irrespective of who converts the document, the conversion process itself introduces the opportunity for error. After all, we’re only human, and we do make mistakes. Our mistakes are many and varied. They range from simple typing errors to omissions of whole portions of documents. Collectively, these are conversion errors. However, there is another group of revisions that inevitably takes place.

Our human qualities not only lead us to make conversion errors, they also lead us to revise documents without regard to typing errors. A document looks totally different in print than it did in pencil form or as an idea in our heads. Perhaps it is the stark nakedness of the typed document itself. Be that as it may, upon reading the typed document, the originator frequently wants to make changes. Perhaps a thought is missing and needs to be added. Or, the grammar itself might need some fine tuning. Worse yet, from the originator’s perspective, the document doesn’t say what he or she thought it said. More changes! Finally, revisions are frequently made as a result of suggestions by third parties. And so, the typed draft must be corrected.

TYPE CHANGES

The document’s life cycle continues with the second conversion. Here again, the extent of conversion takes on a different form. It may consist of “cutting and pasting” portions of the original typed draft to produce another draft. On the other hand, revisions all too frequently result in retyping whole pages. Since revisions are another form of conversion, the revised document frequently finds its way back to the originator and the cycle continues.

READ CHANGES

Prepared for another round of surgery, the revised document meets again with its originator. The document is read again. If the originator isn’t satisfied, the poor document revisits the operating room (some documents never do recover) and undergoes more changes. However, if the document’s shining star is glowing, it is fortunate enough to see the light of day; off it goes to its final destination. If you are a party to the document life cycle, substantial benefits await you.
Benefits to be Derived from Using MacWrite

There are at least four benefits to be derived from using Macwrite:

- Reduction in clerical effort
- Shortened document life cycle
- Enhanced control
- Professional looking documents

REDUCTION IN CLERICAL EFFORT

The first benefit to be derived is a significant reduction in clerical effort. Instead of using pencil and paper (or typewriter), use MacWrite to prepare the first draft. In this regard, compare the approach in Figure 3.2.

As Figure 3.2 illustrates, the use of pencil drafts creates an unnecessary step (as does a typewriter or dictaphone). It doesn’t take any more time to create the draft on the computer screen than it does to create the draft on paper.
and using MacWrite will totally eliminate the need to convert a document. Gone is the clerical effort involved in creating a typed draft. You can create your document on the screen, revise it as necessary, and print it when you decide to do so.

At this point you may be thinking that typing is the work of a secretary. If that is your view, you certainly are not alone. Many others continue to support that view. In fact, if you examine closely who are the loudest supporters, you may find that they are the paper and typewriter manufacturers. Why shouldn’t they support that view? They would like to continue to sell us paper and typewriters. They have already felt the impact of losing business as a result of larger companies converting to word processing. The use of word processing by smaller businesses and for personal use will cause them to have to be innovative and create new, more efficient products. If you and I don’t motivate them to be more innovative, who will? As to the view that typing is the work of a secretary, many others are changing their attitude for the very reasons described in this section. Perhaps you should consider changing too; if you don’t, you might find that you are left behind. Finally, if you are thinking of the poor secretary whose job is being eliminated, fret no more! The role of the secretary is changing. Freed from some of their clerical typing responsibilities, they are increasingly developing other skills and taking over tasks previously performed (and now delegated) by their employers. It’s a “win-win” situation for everyone involved.

**SHORTER LIFE CYCLE**

Because MacWrite eliminates the clerical conversion effort, documents are completed much faster. In this regard, several steps are eliminated. Gone is the time required to convert the original document as well as the time involved in converting changes. In addition, gone is the time required to:

- Answer questions or provide instructions regarding what is intended (you and you alone can do that); and
- Physically transport the document back after conversion.

Given a shortened life cycle, you can devote your time to more productive things.

**ENHANCED CONTROL**

If you are involved in the office environment, you know only too well the trials and tribulations of priorities regarding document conversion. While the document may be your top priority, it may not be the office’s top priority (as viewed
by, for example, the office manager or, sometimes even the secretary). Using MacWrite will put you in the driver's seat and allow you to control the destiny of the document.

PROFESSIONAL LOOKING DOCUMENTS

The last benefit to be derived is the appearance of the document itself. Nothing detracts more from a document than a messy, raggedy appearance. That need not be the case inasmuch as today's microcomputers have word processing capabilities that approach those of computers costing tens of thousands of dollars. Using MacWrite, your documents can look like they were professionally produced.

While I've indicated four benefits to be derived from using MacWrite, I'm sure that you can think of some others. Before you move on to the next section, start a list of "benefits and ideas" of your own. It will serve you well. When you're ready, we'll move on to our next topic, "Ideas for using MacWrite."

IDEAS FOR USING MacWrite

Having seen the benefits to be derived from using MacWrite (which is the answer to the "why" question), you still might have some questions regarding:

• Who can benefit from using MacWrite?
• What should MacWrite be used for?
• When to use MacWrite.
• Where to use MacWrite.

Good questions, all of them! Let's get the answers.

Who Can Benefit from Using MacWrite

I'm tempted to answer the "who" question by saying "Everyone can benefit from using MacWrite." In fact, since I've just written it, I've said it. Literally speaking, I think the answer is technically correct. Everyone can benefit from using MacWrite. If for no other reason, using MacWrite is an educational process for anyone who has never used a word processor. If you only use it to become familiar with the concept of word processing, it will have been well worth the effort.

Whereas, literally speaking, "everyone" is a technically correct answer, it begs the issue of practicality. So let's take a look at the practical side of things.
Practically speaking, those who can benefit from using MacWrite include (in alphabetical order):

- Accountants
- Architects
- Authors
- Chiropractors
- Consultants
- Dentists
- Department heads
- Dieticians
- Doctors
- Educators
- Engineers
- Large businesses
- Lawyers
- Medium-size businesses
- Novelists
- Office personnel
- Ophthalmologists
- Pen pals
- Small businesses
- Students

If I've left you out, you have my apologies—it wasn’t intentional. What I did intend, however, was to demonstrate that the potential using group is varied and diverse. The common bond that they all share is written communication. Obviously, the greater the volume of written communication, the greater are the potential benefits; but, the point is that many of us have to deal with written communications. Since that’s the case, why not reap the benefits we previously discussed?

You may be thinking that the “human touch” is more important for many written communications. My response to that is “Why not have the best of both worlds?” for those communications for which you believe handwriting adds an important ingredient, use word processing for the content of the message and close with a little handwritten personal message. My reason for encouraging word processing centers on the very heart of this issue—human response. Handwriting simply consumes more space, is more difficult to interpret, and is less likely to receive the reader’s undivided attention. The mind’s eye searches for the main purpose of the communication. If the main purpose can’t be found rapidly, the mind quickly wanders off to other things. Since your written communication is important, give it every chance to succeed.

What Should MacWrite Be Used For

As we turn to the “what” question, we’ll begin to get more specific. MacWrite can be used to create two types of documents:

- Recurring documents
- Nonrecurring documents
RECURRING DOCUMENTS

MacWrite can be used to make changes (add, delete, or modify) to documents efficiently. That concept (making changes) is the key to maximizing the use of word processing. Consider the nature of recurring documents themselves:

- Most or all of the subject matter is identical, but the recipients are different.
- The subject matter varies only slightly over time, but the recipient is the same.
- The subject matter is dissimilar, but the recipient receives correspondence frequently.
- The subject matter is dissimilar, and the recipient is not frequently corresponded with.

The first three categories represent your opportunities regarding recurring documents. Let's see how MacWrite can be used regarding each of these.

- Maintain a MacLibrary of standard documents and subject matters. If the subject matter is identical, use the standard document and change the recipient's name. If some of the subject matter is different, delete inapplicable material and use the subject matter library to add applicable material. If proper nouns (e.g., recipient's name) are referred to in the "customized" document, insert "dummy" proper nouns in the standard document; then use the "search for/change to" feature to locate and change all these references.
- If the subject matter varies only slightly over time but the recipient is the same, retain the prior version in your MacLibrary. When it is time to issue the document again, call it up on the screen and modify only the material that requires changes.
- If the subject matter is dissimilar but the recipient recurs, maintain a MacMailing list for mailing labels.

The following examples are provided for illustrative purposes to stimulate your thinking as it relates to your specific needs and opportunities. As you peruse the list, update your personal benefits and ideas list.

- Billing invoices
- Engagement letters
- Financial statements
- Form letters
  - Prospective and current clients/customers
  - Dunning notices
NONRECURRING DOCUMENTS

Clearly it makes sense to use MacWrite for recurring documents. Does that mean that we shouldn't use it for nonrecurring documents? The answer to that question is an emphatic "no!" In fact, MacWrite offers a greater payback for some recurring documents. I'll leave it to you to determine the sufficiency of the payback. From an idea perspective, consider using MacWrite for the following types of nonrecurring documents:

- Articles
- Book reports
- Briefs
- Letters
- Memos
- Minutes
- Presentations
- Projects
- Research papers
- Speeches
Specific strategies
Term papers
Theses

Lengthy nonrecurring documents (such as this book) are natural candidates for using MacWrite. However, don’t overlook the shortest of documents as potential candidates. To illustrate, I’ll use my own experience. As an author, I wouldn’t consider writing a book without word processing. I don’t recall writing a single page for which I didn’t make at least one change. More often than not, I made multiple changes, some of which were mandatory (correcting typos, etc.), while others were optional (moving sentences around, clarifying thoughts, deleting superfluous material, etc.). Using word processing made these changes simple and quick.

On the other hand, as a businessman, I create many nonrecurring documents including: memos to coworkers; memos to files; and reports and letters to clients. Substantially all of the nonrecurring documents I create are done on my desktop with a word processor. It’s just as fast, sometimes faster, as writing with pencil and paper. I can see what the document looks like in printed form, make revisions, and when I’m satisfied with it, print and distribute it. I am no longer dependent on my secretary for typing and can control the destiny of my documents.

When to Use MacWrite

The “what” question just about takes care of the “when” question as well. In this regard, use MacWrite whenever you have text to write, no matter how little.

Where to Use MacWrite

Since Mac is portable, you and he can work together anywhere you go. You can start your day writing a memo with MacWrite (perhaps at home), pack Mac up and stop at the library to use MacWrite in connection with a research project, and finish your day somewhere else (perhaps with a client, in the office, etc.). Of course, if you need to work late, take Mac home with you again. This morning, I had to make a stop where I would be alone for a couple of hours. Without even thinking about it, I grabbed my Mac and took him with me. I’m grateful that I did because I was able to accomplish some things that otherwise would have waited until later in the day.

Unless I miscounted, we’ve answered the who, what, when, where, and why questions. All that remains is “how” to use MacWrite. For that answer, let’s look at MacWrite’s features.
WORKING WITH MACWRITE FEATURES

We will discuss the MacWrite features in the same sequence that we would normally use them. If you already have a Macintosh computer, start up the MacWrite application and get ready for a treat. Our topics are:

- Adjusting MacWrite's comfort control features
- Setting up for your MacWrite documents
- Modifying MacWrite documents
- Printing MacWrite documents
- Saving MacWrite documents
- Using MacWrite's shortcuts
- Transferring text between MacWrite documents

Adjusting MacWrite's Comfort Control Features

Apple recognized that we all have different styles, preferences, and expectations, including how the keyboard reacts to our touch, the loudness of the alert bell, which tells you that you have attempted to do something you shouldn't have, etc. Recognizing this is one thing; doing something about it is quite another. In this regard, Apple has done a lot to enable you to adjust what I'll refer to as your comfort control.

Using MacMouse, enter the Apple menu at the top left of your screen. Select the Control Panel feature, and the Control Panel becomes visible on your screen, as illustrated in Figure 3.3. At first glance, the dials and numbers may remind you of the instrument panel on commercial aircraft. However, take a closer look and see how the little icons intuitively begin to make sense. The control panel enables you to adjust the loudness of the alert bell, adjust the touch of the keyboard and its repeat key feature, adjust the mouse button clicking delay, and the darkness of the screen background. Here's how.

ADJUSTING THE ALERT BELL

At the extreme left of the control panel is a vertical elongated oval with several horizontal lines in it. The line that is highlighted represents the current bell setting. The settings range from very loud at the top to very quiet at the bottom. To change the setting, point the mouse arrow to the current setting, press down on the mouse button, drag the mouse in the desired direction and then let go of the mouse button. When you release the mouse button, the alert bell beeps at
you to indicate how loud that setting is. If you don't like the loudness setting, repeat the dragging process (up to make it louder, down to make it quieter).

**FIGURE 3.3 CONTROL PANEL.**

**ADJUSTING KEYBOARD TOUCH AND REPEAT CHARACTERISTICS**

You can also adjust the responsiveness of the keys to touch and the speed at which they repeat when a key is pressed down. To the right of the keyboard image is a rectangle with two sets of numbers ranging from 0 to 3 with little icons to the left and right of the numbers. The set of numbers on top controls the repeat key feature. When the repeat key feature is active and a key is held down, it will continue to generate the same character repeatedly until the key is released. The control settings allow you to adjust the speed with which characters are repeated (0 for no repeat and ranging up to 3 for very fast repeat).

The set of numbers on the bottom controls the sensitivity of the keys to touch. If you set the sensitivity to 3, barely touching the key will generate a character. The lower the setting, the more firmly you have to press a key to generate a character. To change either characteristic, point the mouse arrow to the desired setting and click the mouse button. The new setting will be highlighted.
ADJUSTING MOUSE CLICKING

In the bottom right corner is a mouse icon and little images of mouse feet. From left to right, the feet get closer together. You can control Mac's recognition of the mouse button clicking. If you select the setting to the extreme right, you will have to double-click the mouse very rapidly for Mac to recognize that you mean double-click rather than two separate single clicks (the specific use of mouse button clicking depends on the application software). Selecting a lower setting results in a greater time interval being permitted to recognize double-clicking.

ADJUSTING THE SCREEN BACKGROUND

You may prefer a very dark screen background or a very light screen background to contrast with the icons, text, etc. on the screen. At the bottom center of the control panel are two squares. The square on the left may resemble a checkerboard, but it's not. It is the tool for adjusting the darkness of the screen background. Move the mouse until the arrow is sitting inside the square and click the mouse button. When you click a little square area, it changes from black to white and vice versa. The more black squares selected, the darker the background will be. The square to the right illustrates the darkness. You can see the change much easier if you drag the mouse around inside the square to the left. With an equal amount of black and white, the screen background will appear gray. You will be able to observe the background after you are through with the Control Panel.

The Control Panel settings you select will stay in effect even when the Mac is turned off. When you are through adjusting the Control Panel, click in the "close box" (the little square at the top left corner of the Control Panel). To change them again, simply reenter the Apple menu and select the Control Panel again (once you adjust them to your preference, you won't need to change them very often, if at all).

Before we move on to the next section, a few comments about other features in the Apple menu are in order. Open up the Apple menu again and you will notice the four standard tools (Calculator, Clock, Note Pad, and Scrapbook). Since these are standard to all applications and were discussed in Chapter 1, we won't describe them here or in succeeding chapters (refer back to Chapter 1 if you are unsure of what they do). All of the standard tools are available to you in MacWrite. In addition, note the About MacWrite feature. When you enter About MacWrite, a dialog box (sometimes referred to as a "floating menu") will
When you start up the MacWrite program, the screen displays the menu bar and the Ruler as illustrated in Figure 3.4.

We will explore each of the menus in the menu bar as we go along. For now, let’s focus on the Ruler. Its component parts are:

- **Measurement area**
- **Margin and tab line**
- **Tab and decimal wells**
- **Line spacing options**
- **Justification options**

**Measurement area.** The measurement area shows you exactly where you are within the left and right sides of a document. Its primary purpose is to enable you to set margins and tabs precisely where you want them. The scale is expressed in inches, and each inch is divided into 1/6th inch intervals.

**Margin and tab line.** At the bottom edge of the measurement area is the margin and tab line. Notice the little symbols directly below the line, which appear to point to the line. From left to right, these little objects are the first line indent marker, the left margin (solid black triangle), a tab setting (unfilled triangle), and the right margin (solid black triangle). To move a symbol, point the mouse arrow to it, press down on the mouse button, and move the mouse button (collectively—“drag”) horizontally to the left or right. To see the effects of moving these symbols, key in the first two or three sentences above and then drag the symbols in a horizontal direction.
When you move the margins to the left or right, all of the text controlled by these margins in your document is realigned in accordance with the new settings (we’ll see how to change the margins anywhere in a document shortly). To set up a document, determine the settings for the left and right margins and drag the margin symbols to those settings. That’s all there is to it. If you don’t like the initial settings, drag the symbols again, and the text will be realigned.

Some people prefer block-style paragraphs, while others prefer to have the first line of a paragraph indented. If you want an indentation for the first line of each paragraph, drag the first line indent marker to the right of the left margin. The first line of each paragraph will begin at the marker location.

Tab and decimal tab wells. Tab stops are a convenient way to skip to a predetermined location within a document. They can be used for additional indentation, inserting a column of figures in the text, etc. The tab and decimal tab wells at the bottom left of the Ruler contain an endless supply of tabs for these purposes. In particular, the decimal tab is used to align figures with
decimal points, which you enter directly through the keyboard or paste from a MacChart document.

To set a tab or decimal tab stop, point the mouse arrow to the desired well and drag a tab until the top of the tab just touches the margin and tab line. The tab will cling to the line when you release the mouse button. To insert more tab stops, go back to the well and repeat the process. To move the cursor to a tab stop, just press the Tab key. To delete a tab stop, point the mouse to the tab, drag the tab down a little, and let go of the mouse button. The tab instantly vanishes.

**Line spacing options.** You can choose from three different line spacing options: single space; space and a half; and double space. The three boxes in the middle of the Ruler represent your line spacing choices from left to right, respectively. To select the line spacing that you want, click the mouse in one of the boxes. The text instantly changes to your new selection.

**Justification options.** MacWrite uses the automatic "wraparound" concept. What this means is that if there isn't enough space on a line to fit in the next word, MacWrite automatically moves that word to the next line. Wraparound is a great time saver. You don't have to waste your time worrying about whether or not a word will fit at the end of a line or whether to use a hyphen to split a word. MacWrite keeps track of the number of unused spaces on a line for you. You may be wondering what happens to the unused spaces in a line. The answer lies in your justification selection.

At the bottom right of the Ruler are the four justification boxes which, from left to right, represent: left justify; center; right justify; and fully justify. To select a justification mode, click inside the box representing that particular mode. The examples illustrating how text looks for each option follows:

<table>
<thead>
<tr>
<th>LEFT MARGIN</th>
<th>RIGHT MARGIN</th>
</tr>
</thead>
<tbody>
<tr>
<td>This is left justified</td>
<td>This is fully justified</td>
</tr>
<tr>
<td>This is centered</td>
<td></td>
</tr>
<tr>
<td>This is right justified</td>
<td></td>
</tr>
</tbody>
</table>

As the examples illustrate, when you select left or right justify, the unused spaces in a line appear at the right or left side of the line, respectively. When you select center justification, the unused spaces are positioned equally to the left and right of the text. Finally, when you select fully justify, MacWrite inserts the extra spaces in between words; there aren't any extra spaces at the left or right margins. Whew, what a relief! MacWrite takes all of the drudgery out of creating a text document.
At this point, if you are not familiar with word processing, you may wish to experiment with the Ruler options. Enter a few lines of text and go through the options one at a time to see the effects they create.

USING THE FORMAT MENU

You may also be wondering how to change settings later on in a document and not have the changes affect the text that precedes the changes. In addition, you may want to make the Ruler go away so you can see more of your document. Not to worry! The options in the Format menu will enable you to do these things and much, much more. Point the mouse arrow to Format in the menu bar, press down on the mouse button, and hold it down to display the Format pull-down menu illustrated in Figure 3.5.

The first two features in the Format menu are Insert Ruler and Hide Rulers/Show Rulers (as to the latter, they alternate back and forth). After you have entered some text, you may want to indent a paragraph or two, change tab
stops, change line spacing, etc. Should you desire to do so, simply enter the Format menu and select Insert Ruler. A new Ruler will instantly appear at your new location in the document. Select your new Ruler settings and you are ready to continue. Or, if you prefer, you can copy any other Ruler in the document (we’ll see how when we get to the Edit menu). Since the Ruler occupies a portion of the screen, thereby reducing the number of lines of text that are visible, you may want to hide them. Enter the Format menu and select Hide Rulers. The Rulers instantly disappear from view (the settings remain in effect). Reenter the Format menu and you will find that the command Hide Rulers has changed to Show Rulers so that you can display them again if you want to.

These are certainly handy features. But, what are those other features in the format menu? Let’s explore them.

**Show Header and Show Footer.** When you are setting up a document, you may want to have one or more lines of special text at the top and/or bottom of the page. For example, at the top of the page you might want to have a title, a name, or a preset heading for recurring documents. At the bottom of the page you might want to have the page number or an explanatory note. MacWrite provides a built-in header and footer at the top and bottom of the page, respectively, for this purpose. To insert text in either of them, enter the Format menu and select Show Header or Show Footer. MacWrite then displays whichever one you have chosen by overlaying the screen. You can then insert text or revise text previously entered. In addition, note the three little icons. These icons represent pagination, clock, and date, respectively. To use any of them, drag the icon to the location in the text where you want the page number, time, or date to appear.

**Set page #.** If you have a large document or a series of documents that are too large to fit in as a single document, you will have to break them up into separate documents. To facilitate consecutive page numbering, MacWrite permits you to set the page number. To do so, enter the Format menu and select Set page #. A floating menu will appear with a box, displaying the current page number. Click in the box to create an insertion point, use the Backspace key to erase some or all of the current page number, key in the changes, and click the OK box or press the Enter key. MacWrite then returns to your text.

**Insert page break.** In a multipage document or a standard set of forms, you may want to “force” MacWrite to continue your document on a new page. To do so, enter the Format menu and select Insert page break. MacWrite will insert dotted lines as a marker to indicate the page break.

**Title page.** Not only does MacWrite provide built-in headers and footers, it also provides us with a Title page feature. The Title page feature can be used for a
cover page or a recurring form. To use the title page feature, enter the Format menu and select Title page. MacWrite will overlay the screen with your title page. At that point you may insert new text for the title page or revise the title page you previously created.

With MacWrite's built-in Format features, setting up a new document is a piece of cake. However, after you have created a document, you may want to revise it. Accordingly, let's move on to that topic and see how MacWrite handles revisions.

Modifying a MacWrite Document

As with all Mac applications, there are two broad categories of modifications to be made: modifying the contents of a MacWrite document, and modifying its appearance.

MODIFYING THE CONTENTS OF A MacWrite DOCUMENT

After you have created a document or, for that matter, while you are creating it, you may want to change its contents. Examples of changes that you might want to make include:

- Correcting a typographical error ("typo")
- Adding a word, sentence, or paragraph
- Deleting a character, word, sentence, or paragraph
- Relocating a portion of the text

With many word processors, making these types of changes can be a real chore entailing moving through nested menus, pressing arrow keys many times, or inserting special characters to "mark" text to be changed. The problem with this type of approach is that not only is it cumbersome, it also isn't natural to us. That's not how we are used to making changes with pencil and paper. For example, consider the process that we are used to for rearranging text. If we wanted to move a paragraph from one location to another, we would:

- Use scissors to "cut" out the paragraph to be moved.
- Cut the document at the insertion location.
- Use scotch tape to place it ("paste") in the new location.

Guess what? That's exactly the process that MacMouse uses! Here's how:
• Point MacMouse to the beginning of the text to be relocated.
• Press down on the mouse button and drag it to the end of the text to be relocated [it will be displayed in reverse video ("highlighted")].
• Enter the Edit menu and select Cut to place the text on the Clipboard.
• Point MacMouse to the new location and click the mouse button to create an insertion point.
• Enter the edit menu and select Paste to insert the text at its new location.

Making changes in MacWrite documents is simple because MacWrite works the way we do. Here is a summary of the steps for each of the types of changes, followed by definitions of the shortcut terms we’ll use.

<table>
<thead>
<tr>
<th>CORRECT</th>
<th>ADD</th>
<th>DELETE</th>
<th>COPY</th>
<th>REARRANGE</th>
</tr>
</thead>
<tbody>
<tr>
<td>TYPOS</td>
<td>TEXT</td>
<td>TEXT</td>
<td>TEXT</td>
<td>TEXT</td>
</tr>
<tr>
<td>Point</td>
<td>Point</td>
<td>Point</td>
<td>Point</td>
<td>Point</td>
</tr>
<tr>
<td>Click</td>
<td>Click</td>
<td>Drag</td>
<td>Drag</td>
<td>Drag</td>
</tr>
<tr>
<td>Backspace</td>
<td>Type</td>
<td>Cut</td>
<td>Copy</td>
<td>Cut</td>
</tr>
<tr>
<td>Type</td>
<td>Type</td>
<td>Type</td>
<td>Point</td>
<td>Point</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Click</td>
<td>Click</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Paste</td>
<td>Paste</td>
</tr>
</tbody>
</table>

*Point*—Point MacMouse to the desired location.

*Click*—Press down on the mouse button.

*Backspace*—Press the Backspace key to delete the character to the left of the cursor.

*Drag*—Press and hold down the mouse button, move the mouse to the right (and/or down a line(s) ) and release the mouse button.

*Cut*—Enter the Edit menu and select Cut.

*Copy*—Enter the Edit menu and select Copy.

*Paste*—Enter the Edit menu and select Paste.

If you want a change and are not sure how to do it, just do what your intuition tells you to do. Don’t worry about doing something wrong, because MacMouse has another trick he can do for you. He can Undo what you have done. For example, suppose you have pasted a paragraph into the wrong location. Just enter the Edit menu and select Undo—MacMouse will take the Pasted paragraph back out. Click in the correct location and Paste it where it should be. MacMouse to the rescue! The rule for Undo is quite simple—it undoes the very last step you performed. If, for example, you had Pasted the paragraph in the wrong location and then typed a character, Undo would delete
Using MacWrite

the character you just typed (the very last step); it would not delete the paragraph. Naturally, you could Cut and Paste it again.

One more point, about Undo—if you look at the Edit menu immediately after you use the Undo feature, you will notice that it changed to Redo. Redo undoes the Undo. That is, suppose you decided you really did want the paragraph where it was but you used the Undo feature to take it back out. If that’s the case, select Redo. MacMouse will grab the text off the Clipboard and put it back for you. Redo then changes back to Undo and so forth. Now, that’s flexibility!

As I mentioned previously, when you drag MacMouse, the text is highlighted for you. If, after you release the mouse button, you conclude that you wanted the next word (or more) also, press down on the Shift key and continue dragging MacMouse. He’ll add the additional text to your selection.

We’ve covered all the items in the Edit menu except for one—Show Clipboard. If you aren’t sure what is on the Clipboard from time to time, select the Show Clipboard feature and the Clipboard will open up on your screen. Click the close box to close up the Clipboard when you are through with it.

Using the Backspace key (or Cut feature) to erase text and key in new text is fine for making one-of-a-kind changes. Suppose, however, that the same word or phrase appears many times. It would take a long time to change them using this technique. Does MacMouse have a shortcut for these types of changes? The answer is yes. Notice that the title bar contains the menu item Search. The Search menu contains two features, Find and Change.

When you select the Find feature in the Search menu, a dialog box displays “Find what.” Enter the letter, word, or phrase you want to locate (“the search criteria”) and press the Enter key. MacMouse scurries through the document looking for the search criteria. He begins at the cursor location and scurries through the end of the document, at which time he goes to the beginning of the document and continues until he reaches the cursor. If MacMouse finds the search criteria, he’ll highlight it for you. You can use the Find feature to locate text that you want to change, see how a phrase was used, or add additional explanatory comments. To leave the Find feature, click its close box. Alternately, you can continue the search by clicking the Find Next box.

The Change feature in the Search menu is primarily used to replace text. Select the Change feature, and the floating menu illustrated in Figure 3.5 will appear.

To use the Change feature, enter the search criteria in the Find what box. Then enter the replacement text in the Change to box. If you just want to delete text or make the change manually, leave the Change to box blank. When you are ready to send MacMouse on the hunt, click in one of the following boxes:

*Find Next*—Locates the search criteria without changing it.

*Change, then find*—Changes the text and highlights the next occurrence (if any) of the search criteria.
Figure 3.6 Change Menu.

*Change*—Replaces located text with the replacement text.

*Change all*—Changes all occurrences and highlights the last change made.

As you can see, MacWrite lets you make changes selectively or will change all occurrences if you prefer. When you are finished, click the Close box. Speaking of being finished, we’ve completed our discussion of modifying the contents. Let’s move on to the cosmetic changes we can make.

MODIFYING THE APPEARANCE OF A MACWRITE DOCUMENT

Earlier we discussed how to change margin settings, etc. which certainly modify the appearance of existing text. But that type of change really relates to setting up your document. In this section we will deal with changes of a dramatic nature, which permit us to draw the reader’s attention to a specific part of the text. We’ll begin with font changes and then look at all our style options.
In addition to the "system" font that MacWrite uses, the Font menu contains other fonts you can use if they suit your fancy. Some of them produce characters that are only slightly different from the system font, while others produce characters (e.g., script), which are dramatically different. You can change a font any time you want to, using a different font for every other character. In addition, each of the fonts can be combined with one or more of the style features.

Pull down the Style menu and MacWrite presents you with the following style options, together with eight different sizes of type:

- Plain text
- Bold
- Italic
- Underline
- Outline
- Shadow

*Plain text*—Plain text is the default value. When you select other options, MacWrite will place a checkmark next to them. To revert back to plain text, select it, and MacWrite will clear out all other selected options.

*Bold*—Bold thickens the pattern used to create the character. While it takes a little longer to print, it does produce a finer quality of printed character.

*Italic*—You can italicize text with the system font or any of the other fonts in the Font menu.

*Underline*—As its name implies, Underline underscores each character while Underline is in effect.

*Outline*—When you select the Outline feature, the text characters are created by outlining them.

*Shadow*—Shadow is a variation of Outline, in which the background surrounding the character is darkened to create the shadow effect.

MacWrite provides you with eight different type sizes. Perhaps you prefer to print titles larger than the body of the text. Further, you might want to print a subtitle or paragraph heading in a size larger than the main body of the text but smaller than the title. Whatever your preference is, MacWrite can accommodate it with this variety of type sizes. In addition, each character in the document can be printed in a different combination of font, special emphasis, and type size. Now that really is flexibility. Equally important is the fact that you will see on the screen exactly what the document will look like when it is printed. As MacMouse says, "What you see is what you get."
Printing MacWrite Documents

The File menu contains two print features, Page setup and Print.

PAGE SETUP

The Page setup menu contains selection options as follows:

• Size of paper (letter or legal size)
• Margin settings
  • Left and right margin settings by tenths of an inch
  • Top and bottom margin settings by number of lines

PRINT

Print options consist of

• Quality of print resolution
  • High (dense)
  • Standard
  • Draft
  • Continuous form
  • Cut sheet (single sheets)

Saving MacWrite Documents

At any time you may save the current document (which you should do fairly frequently). To save your work, enter the File menu and select Save (to save a document under a new name) or Save (to replace an existing document on file with the version currently in memory). Enter the name of the document in the space provided for that purpose (use the Backspace key to erase typing errors). If you enter a name that is already on file, MacWrite will ask you if you want to replace the document. Since MacWrite's memory limit is approximately nine single spaced pages, you will also need to make a longer document as several smaller documents with unique names (e.g., CHAPTER 1, CHAPTER 2, etc.).

The other save features consist of:

Drive—If you have an external disk drive, click the drive button to save the document on a diskette in the other drive.
Using MacWrite

**Eject**—The eject button allows you to switch diskettes so that the document can be saved on another diskette.

If for any reason you don't want to save your current work but do want to continue working with MacWrite, use the New option in the File menu. New erases *all* data. To retrieve a document that you have previously saved, enter the File menu and select the Open command.

**Using MacWrite's Shortcuts**

Personally, I don't like to memorize or use keyboard commands. I had my fill of that process with earlier generation micros. In fact, I made a deal with MacMouse. He agreed to do all the work for me and I agreed to give him Sundays off to visit his girlfriend. However, Apple recognized that some people might prefer to use keyboard commands after they became familiar with the Macintosh computer. Accordingly, MacWrite gives you the option of holding down the Command key while entering the following letters to perform the indicated functions:

- **Z** Undo/Redo
- **X** Cut
- **C** Copy
- **V** Paste
- **P** Plain text
- **B** Bold
- **I** Italic
- **U** Underline
- **O** Outline
- **S** Shadow

In addition to the keyboard commands, you can double-click MacMouse to select an entire word in lieu of dragging him through the word.

**Transferring Text Between MacWrite Documents**

There will undoubtedly be occasions during which you would like to use part of the text from another MacWrite document. MacWrite makes that easy for you. If you are currently working with a document, Save it, and then

- Open the other document
- Select the text you want to use
• Copy the text to the Clipboard
• Close the document
• Open the destination document
• Paste the text wherever you desire

Should you want to use all of the other document instead of part of it, you can
Open the other document, make the desired changes, and Save the docu-
ment under a new name. The first document will remain intact.

CASE STUDY—CREATING AND MODIFYING A MACWRITE DOCUMENT

You may be pleased to discover that I'm not going to ask you to key in a
novelette just so we can practice with MacWrite. To the contrary, I'll minimize
the effort in that regard. Our case study steps are:

Step 1 Creating a MacWrite document
Step 2 Using the Ruler
Step 3 Entering text
Step 4 Correcting typos
Step 5 Deleting text
Step 6 Moving text

Step 1 Creating a MacWrite document

Turn on your Mac and insert the diskette containing MacWrite. Double-click
the MacWrite icon and in a few seconds a blank MacWrite document will
appear.

Step 2 Using the Ruler

Locate the Indent marker on the left side of the Ruler. Using the mouse, drag it
to the right until it lines up with the two-inch line. Then, drag the left margin
marker to the right until it lines up a 1 3/4 inches. When the Indent marker is to
the right of the left margin marker, the first sentence of each paragraph will be
indented. To make the Ruler disappear, enter the Format menu and select Hide
Ruler.
Step 3  Entering text

Begin by keying in the following (without the quotes):

"This is sentence nuber"

The word "nuber" is intentionally mispelled and should be followed by a space. To make the task of entering the example easier, we’ll use the Copy feature. Point the mouse in front of the first letter in the sentence. Then drag the mouse to the right until the words are highlighted as well as the space at the end. Enter the edit menu and select Copy to place the highlighted text on the Clipboard. Now type the number 1, followed by a period and two blank spaces. Then proceed to enter the rest of the text as follows:

<table>
<thead>
<tr>
<th>MENU</th>
<th>KEYBOARD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Paste</td>
<td>2. (followed by two spaces)</td>
</tr>
<tr>
<td>Paste</td>
<td>2. (followed by two spaces)</td>
</tr>
<tr>
<td>Paste</td>
<td>3. (followed by two spaces)</td>
</tr>
<tr>
<td>Paste</td>
<td>5. (followed by two spaces)</td>
</tr>
<tr>
<td>Paste</td>
<td>6. (followed by two spaces)</td>
</tr>
<tr>
<td>Paste</td>
<td>4. (followed by two spaces)</td>
</tr>
</tbody>
</table>

In addition to having mispelled words, our example has a superfluous sentence, and a sentence out of order.

Step 4  Correcting typos

Place the mouse cursor in between the letters “u” and “b” in the word “nuber” in the first sentence. Click the mouse button to create an insertion point. Key in the letter “m” and press the Enter key to insert the letter. That’s one way to correct a mispelled word. Since the same word is mispelled six more times, let’s try another technique. Enter the Search menu and select Change. When the dialog box appears

- Type “nuber” in the Change what box
- Place the mouse cursor inside the Change to box and click the mouse button
- Type “number”
- Click inside the Change All box
Notice how quickly MacMouse made all the changes. Next, we'll put him to work on eliminating the superfluous sentence.

### Step 5  Deleting text

Sentence number 2 is fine, but it appears twice. To eliminate the duplicate sentence:

- Place the mouse cursor at the beginning of the second sentence number 2.
- Drag the mouse to the right and stop immediately before the next sentence.
- Let go of the mouse button.
- Enter the Edit menu and select Cut.

If you made a mistake, select Undo from the Edit menu and start over.

### Step 6  Moving text

Our last change is to move sentence number 4, which is out of order. Proceed as with Step 5. After you Cut sentence 4, place the mouse cursor immediately in front of sentence number 5 and select Paste. There, it's in its proper order. Experiment with the font and style features. Select one of the sentences and change a font, etc. When you are ready to continue, we'll see what MacChart can do for us.
Chapter 4
USING MacChart
There are times when we would like to have a visual image to supplement numeric results. As we will see in this chapter, imagery is what MacChart is all about. Our topics are:

- Understanding numeric graphics
- What MacChart can do for you
- Working with MacChart features
- Guidelines for using MacChart
- Ideas for MacChart applications
- Case study—Creating and modifying a MacChart graph

UNDERSTANDING NUMERIC GRAPHICS

Before the advent of the personal computer, the use of graphics lay in the province of the elite. Given today’s technology in general and the Macintosh computer in particular, we all can take advantage of this important feature. For purposes of our discussion, we’ll break up the subject of graphics into two categories. The first category, numeric graphics, will be dealt with in this chapter. We’ll explore the second category, which I’ll categorize as all other types of graphics, in Chapter 5. With that in mind, let’s review the basic elements of numeric graphics:

- Shapes
- Amounts
- Titles

Graphic Shapes

From a numbers perspective, graphics shapes of interest to us are illustrated in Figure 4.1.

Lines and rectangles have one thing in common—their length. In this regard, their length can be used to illustrate quantities. The longer the length, the greater the quantity. Circles provide yet another perspective. Using dividers, you can create pie slices to illustrate size. Finally, there are area shapes. Area shapes are like rectangles with the intervening spaces removed.

Amounts

While the shapes in Figure 4.1 convey a mental image of relative size, the reader has no way of measuring magnitudes. Accordingly, amounts need to be
inserted. For lines, rectangles, and areas, the amounts could be inserted along the axis used to illustrate their length or height. For pie shapes, the amounts can be inserted inside the circle.

**Titles**

Titles are a critical element of effective business graphics. The graphics shapes in Figure 4.1 are meaningless because the reader doesn’t have any idea as to what data the shapes purport to illustrate. Also, it is important to choose the titles carefully. For example, consider the following comparisons:

- “income” vs. “revenue by product”
- “amount” vs. “expense category”

**WHAT MacChart CAN DO FOR YOU**

The use of numeric graphics is certainly not new. Just pick up the daily newspaper and turn to the business section. Bar diagrams are used to indicate relative market shares for companies in a given industry. Pie charts are used to display a company’s lines of business. From time to time the weather section uses a bar diagram to illustrate the number of inches of rainfall for this year compared to prior periods. We see graphics used in corporate annual reports to shareholders to depict sales growth over time and so forth. So, there is certainly nothing new about using graphics to represent numbers. What is new is the ability to produce presentation quality graphics on microcomputers coupled with the ease with which they can be produced. Before we get into the details of how MacChart works, let’s see what MacChart can do for us. We’ll begin with an overview of MacChart and then explore the benefits of using MacChart.
Overview of MacChart

MacChart is a graphics tool with which you can create visual images to represent numeric figures. The visual images are presented in the form of graphs such as the bar chart and pie diagram illustrated in Figure 4.1.

Using MacChart, you can quickly and easily create seven different types of graphs both on the screen and in the form of hard copy printouts. As with all Macintosh applications, what you see on the screen is what you get on paper. In other words, unlike many other graphics packages, you can feel confident that the hard copy output will have the exact same perspective and proportions as did the graph illustrated on the screen. As if that wasn't enough, MacChart will actually generate new information and graphs for you such as trends and percentage increases. Whether you use MacChart at the office or in your home, MacChart offers you some significant benefits. Let's explore them.

Benefits to be Derived from Using MacChart

I have identified at least six specific benefits to be derived from using MacChart (you probably can identify some others based on your individual needs) as follows:

- Communicate better
- Generate new information automatically
- Facilitate better financial decisions
- Supplement voluminous numeric data
- Create professional looking charts
- Eliminate manual effort

COMMUNICATE BETTER

Whether you are working with a forecast of future events or an analysis of past events, a basic problem in working with the details of naked figures is just that—they are details! In a world of ever-increasing information, these details seem to grow faster than we can keep up with them. Therein lies the essence of the problem. We are frequently required to look at so many details that we often lose sight of the key points, such as:

- Why is after-tax income forecasted to increase at a lesser rate?
- Why is it taking more effort to produce the same amount of work?
- Where did all the money go?
Details frequently focus our attention away from the answers to these types of questions. When our attention is diverted, we tend to communicate too much. That is, we tend to communicate all of the details. It is precisely in this area that MacChart can help us communicate better. By its very nature, a visual representation of financial graphics makes important things stand out. The mind’s eye is immediately drawn to the unusual. For example, if a particular type of expenditure is out of line, MacChart ensures that that fact will come through loud and clear.

GENERATE NEW INFORMATION

Not only does MacChart provide graphic representation of the data that you input, it also generates new information for you. For example, suppose you input expenses for two periods, say 1982 and 1983. In addition to displaying graphic representations of the 1982 and 1983 data, MacChart can generate trends, growth rates, and so forth.

FACILITATE BETTER FINANCIAL DECISIONS

Given that MacChart can help you communicate better (to yourself or others) and generate new information for you, you will be in a position to make better financial decisions. In this regard, the likelihood of important factors being recognized will have been increased.

SUPPLEMENT VOLUMINOUS NUMERIC DATA

Consider the response that frequently results when voluminous columns of figures are presented—borrinnggg! Rightfully so: just consider the disadvantages of a voluminous presentation of columnar figures. From a reader's standpoint they are:

- Time consuming to:
  - Read and digest
  - Determine the relevance
- Difficult to:
  - Interpret
  - Identify trends or significant changes

Instead of being intensely studied, the numeric data can be scanned in general. Specific attention to the financial graphics can then be devoted to reviewing trends, changes, and other significant items.
CREATE PROFESSIONAL LOOKING DOCUMENTS

The Macintosh Imagewriter coupled with MacChart’s graphic capabilities create a high quality, high resolution document of professional appearance.

ELIMINATE MANUAL EFFORT

If you are presently drawing charts manually, MacChart will free you of that chore. Further, because MacChart will help you identify what is important, you may very well be in a position to reach decisions faster, thus saving you additional time.

WORKING WITH MacChart FEATURES

Our work product is a financial graph displayed either on the screen, in hard copy form, or both. In this section we’ll explore the steps that lead up to obtaining our end product. Our topics are:

- Understanding MacChart concepts
- How to enter and modify data
- Generating analysis graphs
- Modifying MacChart graphs
- Printing MacChart graphs
- Using the special keys with MacChart
- Saving MacChart graphs
- Retrieving saved graphs
- Transferring data between MacCharts

Understanding MacChart Concepts

If you have a Macintosh computer and the MacChart software, insert the diskette and turn on the power. When the Organizer menu appears, select MacChart and follow along as we discuss MacChart concepts and features.

MacChart is an extremely flexible financial graphics program. By flexible, I mean that you and I have considerable choice as to the extent of data we can enter and how our graph will look. It may be tempting for you to jump right in and begin exploring MacChart features. If you do this, you run the risk of becoming extremely confused. That’s not because MacChart is difficult to use. To the contrary, MacChart is extremely easy to use. The confusion may arise as
a result of not understanding MacChart’s basic concepts. If you take the time to follow our concepts discussion carefully, your likelihood of success will be considerably increased. Our topics for this section are:

- Understanding the basic MacChart components
- Understanding MacChart’s terminology
- Understanding the chart components
- Understanding MacChart data types

UNDERSTANDING THE BASIC MacChart COMPONENTS

When you enter the MacChart program, the start-up screen will display the following three basic components as illustrated in Figure 4.2:

- The New Series window
- The Chart
- The menu bar

The New Series window. The New Series window is the vehicle for entering values. For example, if you wanted to enter the numeric values for expenses during 1983, the New Series window is the starting point for entering those

Figure 4.2 The Basic MacChart Components.
values (we'll see how shortly). The New Series window must be active (in front) in order for you to enter data or select menu items that pertain to such data.

The Chart. The Chart is the graphic display of user data. When the MacChart program is started up, the Chart area is blank. The Chart area must be active to select menu items pertaining to the Chart display.

The menu bar. The menu bar contains the MacChart pull-down menus as illustrated in Figure 4.2. We will discuss the menu items in detail in the next section.

UNDERSTANDING MacChart TERMINOLOGY

MacChart uses two terms that are particularly important for you to understand. These terms are "values" and "categories." Values are the primary measurement units. Categories are the descriptors of what is being measured. Let's illustrate by reference to Figure 4.3.

Values and categories are most easily understood by relating them to the axes of a graph such as those shown in Figure 4.3. Along one axis are the years 1983 through 1985, which in this case describe the time periods being measured. The years are the categories and are accompanied by a category title, sales. Along the other axis are the measurements 100 through 300, which are the values. The values have a value title—amount. The specific axis used for values and categories varies according to the type of graph (bar chart, column chart, etc.) you select.

Figure 4.3 Values and Categories.
UNDERSTANDING THE MACINTOSH

UNDERSTANDING THE CHART COMPONENTS

Having defined the key terms, let's look at the components of the chart display. These are illustrated in Figure 4.4.

Figure 4.4 illustrates the chart components, each of which is described below.

<table>
<thead>
<tr>
<th>#</th>
<th>Name</th>
<th>Description</th>
<th>Default setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Border</td>
<td>As a picture has a frame, the Chart has a border.</td>
<td>Normal</td>
</tr>
<tr>
<td>2</td>
<td>Chart title</td>
<td>The main theme.</td>
<td>Blank</td>
</tr>
<tr>
<td>3</td>
<td>Y axis</td>
<td>The vertical plot line.</td>
<td>Displayed</td>
</tr>
<tr>
<td>4</td>
<td>Value prefix</td>
<td>An area in which a prefix may be inserted.</td>
<td>Blank</td>
</tr>
<tr>
<td>5</td>
<td>Value</td>
<td>A measurement.</td>
<td>Blank</td>
</tr>
<tr>
<td>6</td>
<td>Value suffix</td>
<td>An area in which a suffix may be inserted.</td>
<td>Blank</td>
</tr>
<tr>
<td>7</td>
<td>Value title</td>
<td>Unit of measure.</td>
<td>Blank</td>
</tr>
<tr>
<td>8</td>
<td>Graph type</td>
<td>Measurement shape.</td>
<td>Y</td>
</tr>
<tr>
<td>9</td>
<td>Cluster space</td>
<td>Distance between graph objects.</td>
<td>Column</td>
</tr>
<tr>
<td>10</td>
<td>X axis</td>
<td>The horizontal plot line.</td>
<td>50%</td>
</tr>
<tr>
<td>11</td>
<td>Category prefix</td>
<td>An area in which a prefix may be displayed.</td>
<td>Blank</td>
</tr>
<tr>
<td>12</td>
<td>Category</td>
<td>Measurement descriptor.</td>
<td>Blank</td>
</tr>
<tr>
<td>13</td>
<td>Category suffix</td>
<td>An area in which a suffix may be inserted.</td>
<td>Blank</td>
</tr>
<tr>
<td>14</td>
<td>Category title</td>
<td>Typically the item or time period being measured.</td>
<td>X</td>
</tr>
<tr>
<td>15</td>
<td>Legend</td>
<td>An annotation area for value descriptions.</td>
<td>Blank</td>
</tr>
</tbody>
</table>

To simplify things for you, MacChart sets initial default values for each of the components as shown above. At this point don't worry about how to modify the components. All that's important is that you understand that the components exist and you can modify them.

UNDERSTANDING MACCHART'S DATA TYPES

MacChart has four data types: sequential, date, text, and numeric. Data type describes the type of data to be entered for categories such as the following:
The specific data type you should select will depend upon the specific information to be graphed. For example, if you wanted to graph income by month or by year, you could use the Date type in which case MacChart can generate the categories for you. On the other hand, if you wanted to graph various categories of expenses for 1983, you would use the Text type, in which case you would enter the names of the specific expense categories to be graphed. With that in mind, we're ready to enter data.
How to Enter and Modify Data

For the balance of this section I will continue to assume that you have a Macintosh computer with the MacChart start-up screen in front of you. If that is not the case, the illustrations will enable you to follow the discussion as we go along.

ENTERING DATA

Entering new data is accomplished by activating ("selecting") the New Series window. If the Chart is in front, you can select the New Series window as follows:

- If you can see an edge of the New Series window select any part of it with the mouse.
- If the New Series window is hidden from view, point the mouse at the top of the Chart, press down on the mouse button and drag the Chart out of the way until the New Series window can be seen. Then select the New Series window.

The default for a new series is Sequential data type. Let's assume we want to enter income by quarter for 1982 and will use the labels "1," "2," "3," and "4" for each of the quarters. The default is already set for this. Accordingly, MacChart will create the category labels automatically for you and assumes that the first number you will enter is a value. Enter the number, 100, and press Return. MacChart will instantly create a new series for you as illustrated in Figure 4.5.

After MacChart creates a new series, the New Series window moves to the background. Note the default values illustrated in Figure 4.5:

- The series title is "9:50:00"; the default Chart title is the time of day.
- The Plot Series box is blank.
- The category and value titles are "X" and "Y", respectively.

As we noted in the table earlier, all default values can be modified (we'll modify them shortly). Also notice the first entry. The number 1 appears under the category title and the number 100 under the value title. Immediately following these numbers is a line drawn across the window. The line is MacChart's way of telling you that it accepted the previous value and is waiting for you to either enter another value or do something else.
FIGURE 4.5 MacChart Series Windows.

MODIFYING DATA

If you made a mistake entering the first value, you can:

- Position the cursor immediately after the value, 100, and click the mouse button to create an insertion point. Then use the Backspace key to erase, enter the correct value, and press Return.
- Cut the entire value and reenter a correct value.

We will go through a step-by-step approach in the case study at the end of this chapter; accordingly, we won’t do that now. Rather, let’s discuss conceptually what we could do next:

- Finish entering values for 1982.
- Select the New Series window.
• Enter the value for the first quarter of 1983. MacChart would automatically create another series (with a new time as its title) for us.

Recall that the graph default type is "column." Let's see what it looks like. Point the mouse to the box next to the words "Plot Series" and click in the box. The Chart becomes active and a columnar graph is drawn. That's all there is to it.

You could also create a new series by using the Copy feature in the Edit menu. To do this, point the mouse arrow to the first "X" entry, press the mouse button down and drag it to the last "Y" entry. Then enter the Edit menu and select Copy. Select the New Series window, enter the Edit menu, and select Paste. Presto, a new series! Now, create an insertion point, backspace, and modify an entry. Or, Cut the entire value and replace it with the new entry. To delete or totally modify a series, select all the X and Y entries and cut them. You will then be asked if you want to delete the series. Click "OK" to delete the series or "Cancel" to start a new one. Remember, if you inadvertently Cut something, you can either use the "Undo" feature in the Edit menu or immediately Paste it back. At any time, you can see what has been Cut or Copied to the Clipboard by selecting Show Clipboard in the Edit menu.

Conceptually, the New Series window is a well from which we draw new series whenever we want them. For example, next year you could enter 1984 data by creating a new series.

Before leaving Figure 4.5, note the right and bottom sides of the Series window. They contain the familiar scrolling and view facilities. In fact, the window is similar to that used in MacPlan. You can adjust the window size, scroll through it and move the window around the screen to suit your preferences. MacMouse does it again!

GENERATING ANALYSIS GRAPHS

Suppose you have entered values for 1982 and 1983 expenses. Perhaps you want to see what a graph of the 1983 increase or decrease looks like. One way to do this would be to create a new series, calculate the differences between the 1983 and 1982 amounts and enter such differences in the new series. Is there a better way? You bet! Let's see what MacChart can generate for us automatically.

The MacChart Generated Graphs

Enter the Data menu and select Analyze. You will be presented with the following choices, which perform the indicated tasks (on a single series of data—"original series"): 
**Using MacChart**

*Trend*—Using the data in the original series, MacChart will generate trend data.

*Growth*—MacChart calculates the growth rate.

*Average*—MacChart adds up all the items and calculates their average.

*Cumulative sum*—MacChart adds up the cumulative to date amounts.

*Difference*—Each of the increases or decreases are calculated.

*Percent*—MacChart calculates the percent of the total of the items in the original series that each item represents.

*Statistics*—MacChart will calculate seven statistics for you. The categories are maintained as text type and, of course, the statistics can be plotted. The statistics maintained are as follows:

- Number of points
- Maximum value
- Minimum value
- Average value
- Median value
- Standard deviation
- Correlation coefficient

**Creating Generated Graphs**

When you select an analysis graph from the menu, MacChart instantly generates a new series window for you. The categories used are those you already set up in manually created series. The values are calculated by MacChart. The important points to note are:

- Since the categories and values are based on the other series you created, you can't modify them. If you try to change them, MacChart will tell you they can't be changed. To change a category, first change the manually created series. There should not be any reason for you to change a value in a generated series unless the manually created series contains an error (in which case you should fix the manually created series).

- To display a generated graph, select the Plot Series box in the generated series window.

- To otherwise modify the appearance of a generated graph series, follow the instructions in the next section.
In the previous section we saw that we can have many series windows. We can display them all in the graph or choose just the ones we want to display, thus changing the graph's appearance. To include a specific series:

- Enter the Data menu and select List. A floating menu will appear in which each series will be listed. For each series you can select whether or not you want to show the series window, plot the series, or both; or
- Select a series window directly by clicking in it. Then click the box next to Plot Series to activate or deactivate plotting that series.

In addition to selective inclusion of a specific series, you can modify the graph appearance by changing the default values (the Chart window must be...
activated first). The most meaningful way to discuss graph modifications is by
the nature of the change. If you are going to make a lot of changes and unless
you want to see the effect of each change, you will want to turn off the graph
feature until the changes are done. Just as MacPlan has automatic and manual
calculation features, so does MacChart have them for graphing. The Chart
menu contains the Redraw now, Automatic redraw, and Manual redraw fea-
tures, which enable you to control when the graph is drawn. With that in mind,
our topics are:

- Changing the graph shape.
- Modifying the border.
- Modifying the chart, value and category titles.
- Modifying the axes.
- Adding grid lines.
- Modifying value or category prefixes and suffixes.
- Modifying value or category alignment and format.
- Modifying main chart and overlay chart formats.
- Modifying a legend.
- Adding an arrow.
- Modifying labels.
- Adding a label.
- Changing the size or location of a component.
- Overlaying a graph with another graph.
- Sorting values.
- Changing the pattern of a component.

Changing the Graph Shape

Shapes can be selected in MacChart's Gallery menu. Enter the Gallery menu
and MacChart will provide you a choice between eight different shapes as
follows:

- Area chart
- Hilo chart
- Scatter diagram
- Bar chart
- Line chart
- Combination chart
- Column chart
- Pie chart
AREA CHART

An area chart is basically a line chart of the plotted values for which the area between the line and the axis has been filled in.

BAR CHART

A bar chart consists of rectangles, the length of which is determined by the values. The bars begin at the Y axis and extend to the left for negative values and to the right for positive values.

COLUMN CHART

The column chart, which is the default chart, is similar to the bar chart except that the rectangles emanate from the X axis.

HILO CHART

The hilo chart consists of lines drawn between the highest and lowest plotted points.

LINE CHART

In a line chart, each of the values is plotted and a line is drawn connecting the plotted points.

PIE CHART

In a pie chart, "wedges" of the pie represent each of the values. The size of each wedge is proportional to the total circle.

SCATTER DIAGRAM

A scatter diagram consists of a series of plotted points. It differs from the line chart in that the points are not connected.
COMBINATION CHART

In a combination chart, each of the series utilizes a different chart shape. Not only does MacChart provide us with a choice of eight different shapes of charts, it also allows us to choose from several variations of the same basic shape. When you select a chart shape from the Gallery menu, MacChart displays the variations for you. Selection of a variation is accomplished by clicking inside the shape itself. If you decide you don’t want to change, select the Cancel option.

When you make a selection from the Gallery, the Gallery changes other formats you have selected to match the formats it needs for the shape you specified. You can also change the graph shape by selecting Main Chart in the Chart menu (see Figure 4.7). None of the other formats you have selected will be changed.

Modifying the Border

The perimeter of the Chart area is referred to as the Border. MacChart provides you with a choice between five different Border types as follows:

Figure 4.7 Main Chart Menu.
• Normal (default)
• Bevel
• Double
• Round
• Shadow

To change the Border type, enter the Chart menu and use the Select Chart feature. Then enter the Format menu and select Patterns. A floating menu will display choices for style and thickness. To make a selection from any of the MacChart floating menus, point the mouse arrow to the box or circle next to the selection item and click the mouse button. MacMouse inserts an x to indicate that the item has been selected. To deselect, click again and the x disappears.

Modifying the Chart, Value, and Category Titles

The default values for titles are time of day the series was created, Y and X. To change them, enter the Data menu and select the appropriate data type (sequential, date, text, or numeric). A series properties menu will appear. Click in the title area for the title you want to change. An insertion point is created at the location you click. To change the title, you can either use the Backspace key to erase one character at a time or drag the mouse as you would with any text material to select it; then use the Cut feature in the Edit menu.

Modifying the Axes

You can choose whether or not you want to display the x and y axes, their respective labels and the grid lines. Enter the Chart menu and select Axes. The following floating menu will appear:

Notice in Figure 4.8 that, for both categories and values, there is a selection box next to axis, tick labels, and major and minor grid lines. To turn them off, click in the box next to their name, and the x within the box will disappear. To reinstate them, click in the box, and the x will reappear. Click the OK box when you are finished with your selection.

You can also make other important changes by clicking the axes themselves and then selecting the Axis command in the Format menu. Figures 4.9 and 4.10 illustrate the floating menus.

LOCATION OF AXES INTERSECTION

The default value causes the axes to intersect at the first value and first category (to form an “L” shape) irrespective of the values you enter. If your values are all positive numbers, the default value is acceptable. However, if
Using MacChart

Axes

For categories

- Axis
- Tick mark labels
- Major Grid lines
- Minor Grid lines

For values

- Axis
- Tick mark labels
- Major Grid lines
- Minor Grid lines

Figure 4.8 Chart Axes Menu.

Category Axis

Other Axis crosses at Category Number

Number of categories Between tick Mark Labels

- Other Axes Crosses Between Categories
- Categories in Reversed Order

Figure 4.9 Format Axis Menu.
your values range from negative numbers to positive numbers, you may want to change where they intersect. MacChart permits you to control the number of the category at which the value axis will intersect it. For example, in a bar graph, suppose you had three values: -2, 0, and 2. You might prefer to have the intersection occur at the second category to form a cross for which -2 would appear to the left of the cross and 2 would appear to the right. To change the intersection, enter the category number at which you want the intersection in the box next to “Other Axis Crosses at.”

You can also control the intersection position within the category. When an x appears in the box next to Other Axis Crosses Between Points, the value axis crosses through the category center. To make the value axis cross at a category intersection (in between categories), deselect the option, and the x will disappear.
NUMBER OF CATEGORIES TO DISPLAY

The default value for the number of categories between tick mark labels is one. To change the number of categories, click in the box labelled Number of Categories Between Tick Mark Labels, use the Backspace key to erase the present value, and enter the new value.

VALUE AXIS SCALE

When drawing the value axis, MacChart uses the smallest value in your data series window(s) as its minimum value and the largest value as its maximum value. You can change the minimum and maximum values by entering them in the respective boxes. If you have values less than the minimum value and greater than the maximum value in your data series window, they will not be displayed.

You can also control the number of intervals between the minimum and maximum values. The default intervals are:

- For major units (intervals), the default number is the greatest power of 10 less than the maximum value.
- For minor units, there is one interval if there are two or more major units; if there is only one major unit, the default number is ten.

To change the default intervals, enter your desired interval values in the appropriate boxes. In addition, you can use the logarithmic scale. The default values are:

- Minimum value—Largest power of ten smaller than the lowest value but not less than one
- Maximum value—Smallest power of ten larger than the highest value but not less than one
- Major unit—the interval is a power of ten
- Minor unit—Same as nonlogarithmic scale

CHANGING THE ORDER OF THE DISPLAY

The default order for category and value labels is the order in which they appear in the data series window. To reverse the order, click the box labelled Categories/Values in Reverse Order.
PATTERNS

Procedures to change the width of a line or the pattern used to display it are discussed under Changing the Pattern of a Component later in the chapter.

Adding Grid Lines

MacChart offers you two types of grid lines for each of the two axes (the default is Don't Display):

- **Major grid lines**—The major grid lines relate to the category and value labels along the axes. They are, in effect, a continuation of the little separators on the axes that separate the labels.

- **Minor grid lines**—In addition to the major grid lines, you can have MacChart draw grid lines in between the major grid lines to provide further definition.

At the bottom of the diagram illustrated in Figure 4.8 are the choice boxes for the grid lines. To change whether or not grid lines are displayed, enter the Chart menu, select Axes, and click the appropriate box.

Modifying Value or Category Prefixes and Suffixes

Each of the value and category labels along the axes can be preceded and followed by a label. To illustrate, let's take a slice of the X axis, starting from the extreme left (the X origin) and moving right to the first separator (we'll assume we are working with a category label in a column chart but the concept holds true for values and other chart types as well). Our slice follows:

```
+-------------------+                   X axis
| PREFIX CATEGORY SUFFIX |
```

Let's see how we might use the prefix and suffix fields:

- Suppose we have two columns that represent sales for 1983 and 1982. We could use the label "sales" for the category label and 82 and 83 for the prefix and suffix, respectively.
- Suppose our main chart title is auto expense and we are graphing budget, outlook and actual. We could use budget as a prefix and actual as a suffix with
outlook being the category label. The labels would be positioned directly under the column rectangles.

As you can see, MacChart makes it easy for us to customize labels. To use the prefix or suffix field, enter the Format menu and select categories or values, respectively. The floating menu for category formatting is illustrated in Figure 4.11.

The elongated rectangles at the bottom of Figure 4.11 are for editing the prefix and suffix, respectively. You can modify them using either the insertion point or cut and paste approaches.

As to the category and value labels, they too are optional. Refer back to Figure 4.8. The two boxes labelled “Tick Mark labels” are for displaying the category and value labels. When the box contains an X, the label is displayed. Click in the box and the X disappears (or reappears if the box was blank). In a date series, you could, for example, display portions of dates using a prefix and

![Category Format Menu](image)

**Figure 4.11 Category Format Menu.**
suffix according to your own preference and omit the category label generated by MacChart.

**Modifying Value or Category Alignment and Format**

In addition to creating a prefix or suffix, you can modify the category or value label alignment and formats as illustrated in Figure 4.11. Labels can be aligned to the left, centered, or aligned to the right. For numbers, you can choose the number of decimal places (default is zero) and/or use a dollar or percent sign. Selection is made by clicking in the circle or box next to the option and clicking the OK box when you are through.

**Modifying Main Chart and Overlay Chart Formats**

Enter the Format menu and select Main Chart or Overlay Chart. A chart properties floating menu, such as the one illustrated in Figure 4.12, will appear.

Here again MacChart provides us a great deal of flexibility. The specific formats that will appear depend on the type of chart itself, as illustrated below.

<table>
<thead>
<tr>
<th>Format</th>
<th>Area</th>
<th>Bar</th>
<th>Column</th>
<th>Line</th>
<th>Pie</th>
<th>Scatter</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stacked</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>100%</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Vary by Categories</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Drop Lines</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Hi-Lo Lines</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Overlapped</td>
<td></td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Percent Overlap</td>
<td></td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Percent Cluster</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Spacing</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Lines Connecting</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Data Points</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Markers for Data</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Points</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Angle of First Wedge</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Stacked. In stacked format, each graph series begins where the preceding series left off.
Applicable to stacked graphs, the 100% format results in normalizing the values in each category to add up to 100 percent.

Vary by Categories. For charts with a single series, selecting this format permits different patterns for each data point.

Drop Lines. Selecting drop lines results in lines extending from the highest value in each category to the category axis.
Hi-Lo Lines. Hi-Lo Lines consist of a line drawn from the highest value to the lowest value.

Overlapped. In bar and column charts, the rectangle shapes may be overlapped in gradations from 1 to 100%.

Percent Cluster Spacing. The space between the shapes can be increased or decreased by changing the cluster spacing percentage that represents the percentage of the width of the shape itself.

Lines Connecting Data Points. Lines will be drawn between plotted data points when this format is selected.

Markers for Data Points. To place a marker at the location of a data point’s value, use the Markers for Data Points format.

Modifying a Legend

For graphs with many figures, a legend can be used to annotate the figures. To use a legend, enter the Chart menu and select Show Legend. When the Legend has been selected, the Plot area will be moved to the left to make room for the Legend. To hide a legend being displayed, enter the Chart menu and select Hide Legend (when the Legend is displayed, the Chart menu changes the option Show Legend to Hide Legend). To customize the Legend, click inside the Legend, enter the Format menu and select Legend. The floating menu illustrated in Figure 4.13 will appear.

As Figure 4.13 illustrates, the Legend format command controls the following properties:

Font—Font controls the character style. Characters may be displayed in Modern, Roman, or Chicago fonts; these three fonts may also be combined with bold and/or italics.

Type—Type controls the general placement of the Legend.

Spacing—Spacing controls the amount of space between items shown in the Legend.

In addition, you can control the size and positioning of the Legend by deselecting Automatic Size and Automatic Positioning, respectively (see Changing the size or location of a Chart component).
Adding and Modifying an Arrow

The most effective graph is one that is precise and uncluttered. However, there may be occasions when you need to highlight a particular point you want to emphasize (e.g., achieving a milestone, exceeding a challenging target, etc.). MacChart provides us an Arrow for this purpose.

To create an arrow, point the mouse to the location you want the arrow to start from. Hold down the Shift key and drag the mouse to the location where you want the arrow to point to. Let go of the mouse button and then the Shift key. Choose Add arrow from the Chart menu. The arrow will appear on the graph. The arrow’s appearance (line thickness, width, style, and length of the
arrow can be modified using the Patterns command in the Format menu (see Changing the pattern of a Chart component).

To delete an arrow, select the arrow and use Cut in the Edit menu (a cut arrow cannot be pasted back).

Modifying Labels

The Chart category and value titles come from entries you made in the data series properties floating menu (or the default values times of day, x and y, respectively). When more than one data series window exists, MacChart uses the titles of the first Series (Series Order #1). For next type series, the individual category labels come from entries in the category column of the first series. To change these labels, move the mouse arrow until it touches any character in the label and click the mouse button to select the label. When selected, the entire label is highlighted. You can then change the label by creating an insertion point, backspacing until unwanted characters, if any, are deleted and keying in new characters.

You can also change the location, label assignments, content of the category display, alignment, type style, and size of these labels. Here’s how. Select the label, enter the Format menu, and select Text. The text menu illustrated in Figure 4.14 will appear on the screen.

CHANGING THE LOCATION OF A LABEL

The labels are initially attached to a predetermined location. To relocate them, click in the circle marked Unattached, which is illustrated in Figure 4.14. After making any other desired changes, click the OK box. You can now drag the label to a new location.

CHANGING LABEL ASSIGNMENTS

Labels displayed in the graph are taken from the categories in the data series window, which is ordered number 1. When a data series window is active, you can change the order. Here’s how:

- Select the data series window whose category labels you would like to have displayed in the graph.
- Click the Order box.
- Backspace to erase the present order number and enter the number 1.
- MacChart will reorder the other series windows.
**Using MacChart**

Figure 4.14 Text Menu.

**CHANGING THE CONTENT OF A CATEGORY DISPLAY**

For individual category labels, the default display is text. MacChart permits you to change the display to the pattern key or data point value. If you click the Show key box, MacChart will display the pattern associated with the series. If you click the Show value box, MacChart will display the value of the data point instead of the label.

**CHANGING LABEL ALIGNMENT**

Labels are initially centered within the label area. To change the alignment, click the circle next to one of the other choices (left or right for labels on a horizontal axis and top or bottom for labels on a vertical axis).
CHANGING THE TYPE STYLE

The default type style for labels is Modern. Click in the other boxes to change the style. In addition, you may also use bold and/or italics with any of the type styles.

CHANGING LABEL TYPE SIZE

The default value for type size is Small type. You can also select the Medium or Large type sizes by clicking in the respective boxes.

Adding a Label

In addition to the standard labels previously discussed, you can add as many other labels as you need. For example, you might want to have a subtitle to supplement the main chart title or add an explanatory comment to the graph. To add a label, position the mouse arrow at the desired location for the new label. Hold down the Shift key and click the mouse button. Key in your new label and press the Enter key (the Return key adds a carriage return to the label). Your new label is then added to the Chart. You can then modify it by selecting Text in the Format menu.

Changing the Location or Size of a Chart Component

Although the Chart, Plot, Legend, and Text labels occupy a specific position on the screen and in relation to one another, each can be relocated or sized at will. Here is how to do it:

• First, select the component. For the Chart or Plot areas, enter the Chart menu and use the Select Chart area or Select Plot area options. For other components, move the mouse arrow until it touches the desired component and click the mouse button to select the component.

• Next, deselect automatic size and positioning by using the appropriate floating menu
  • Chart or Plot—Main chart in the Format menu
  • Legend—Legend in the Format menu
  • Labels and Arrow—Text in the Format menu

• To change the size of the Plot or Legend, drag one of the size boxes in the desired direction (the corner boxes control both horizontal and vertical size) and release the mouse button when you are satisfied with the new size.
Chart size can be changed by using the size control box in the bottom right corner.

- To change the location of a component, locate the mouse arrow inside the component (don't touch the size boxes), drag it to the new location and release the mouse button.
- To deactivate the size control boxes, click the mouse button outside the selected component.

**Overlaying a Graph with Another Graph**

In addition to being able to modify all of the graph components, you can create a second graph with its own characteristics and overlay it on the first graph. To create a second graph, enter its categories and values. Next, select Overlay chart type from the chart menu and Overlay chart from the Format menu to define its characteristics. Finally, enter the Data menu and select List. Check the Plot box next to the applicable series and your overlay chart will be displayed.

**Sorting Values**

If you have entered the values in an unsorted order, MacChart will sort them for you. Enter the Data menu and select Sort. A floating menu will appear to explain your options (ascending or descending order, etc.). After you select your sort order, click OK, and MacChart will sort the values for you.

**Changing the Pattern of a Component**

MacChart initially draws lines and fill areas with predetermined patterns. You can, for example, change the area fill patterns and the thickness of lines for axes, grid lines, shape of markers, etc.). To change a pattern:

- Click the desired component.
- Enter the Format menu and select Pattern. A floating menu will appear to display your options (width of lines, solid or broken lines, fill patterns, etc.).
- Click the boxes that suit your fancy and then click the OK box.
- MacChart will then redraw the graph according to your newly selected patterns (note—you can also choose to hide the component by selecting the invisible option, as applicable).
Using the Special Keys with MacChart

The special keys on the Mac keyboard perform the following functions in MacChart.

OPTION KEY

For text and data, the Option key, when used with another character key, enters the alternate character set.

ENTER KEY

In floating menus (dialog boxes), the Enter key has the same effect as clicking OK.

In a data series window, the Enter key used to accept data and move to the next category or value.

RETURN KEY

In floating menus, the Return key also has the same effect as OK.

In labels, the Return key inserts a carriage return.

TAB KEY

In floating menus, the Tab key moves to the next field.

SHIFT KEY

The Shift key, when used with the mouse (a) by dragging the mouse, extends (adds to) an existing selection in a data series window or label and (b) by clicking the mouse, creates an insertion point anywhere in the Chart in which to insert a label.

COMMAND KEY

The Command key, when used with the following letters, can be used in lieu of menu selections:
All of the MacChart menus contain a Cancel feature, which cancels the changes selected in the menu and returns you to the graph. Use the Cancel feature if you change your mind before you click the OK button. As we have just seen, we can modify every one of the components. When you are satisfied with the appearance of the graph, you will no doubt want to print it. Let’s see what our print options are.

**Printing MacChart Graphs**

The file menu contains two print features, Page setup and Print.

**PAGE SETUP**

The Page setup menu contains selection options as follows:

- **Size of paper** (letter or legal size)
- **Orientation**
  - Tall (vertical/portrait orientation)
  - Wide (horizontal/landscape orientation)
  - Tall 'n Square (Square orientation)
- **Page header** (heading at top of page)
- **Page footer** (heading at bottom of page)
- **Margin settings**
  - Left and right margin settings by tenths of an inch
  - Top and bottom margin settings by number of lines

MacChart also has built-in commands which can be used for headers and footers. To use them, individually or in combination, press down on the Command key when entering the following command letters:

- **L** Align the following characters at the left margin
- **C** Center the following characters
- **R** Align the following characters at the right margin
• P  Print the page number
• D  Print the current date
• T  Print the current time

All of the settings you select are saved with the graph.

PRINT
You can print both the Chart and the data series windows. When you are ready to print, select the window to place in front on the screen. MacChart prints whichever window is in front. Print options consist of:

• Quality of print resolution
  • High (dense)
  • Standard
  • Draft
• Page range (applicable only to data series windows that have more plot points than can fit on one page)
• Paper fee
  • Continuous form
  • Cut sheet (single sheets)

Saving MacChart Graphs
At any time you may save the current formats and data. To save your work, enter the File menu, and select the Save or Save as options.

SAVE AS
The Save as option is used to save MacCharts under a new name. Use this option if the MacChart is new or if you don’t want an existing MacChart file to be replaced by the current MacChart you want to save. Enter the name of the document in the space provided for that purpose (use the Backspace key to erase typing errors). If you enter a name that is already on file, MacChart will ask you if you want to replace the document.
SAVE

The Save option is used to replace a MacChart file that was previously saved (with the Save as option).

The other save features consist of:

- Drive—if you have an external disk drive, click the drive button to save the document on a diskette in the other drive.
- Eject—The eject button allows you to switch diskettes so that the document can be saved on another diskette.
- Format
  - SYLK—Use the SYLK format if the document is going to be transmitted to another computer
  - Normal—Use the Normal format for all other purposes

If for any reason you don’t want to save your current work but do want to continue working with MacChart, use the New option in the File menu. New erases all data if a data series window is active (including other data series windows that are not active) or erases all formats if the Chart is active (returns the Chart to the default values).

Retrieving Saved Graphs

To retrieve a graph that you have previously saved, enter the File menu and select the Open command. Options consist of:

- Retrieving data (series windows)
- Retrieving formats (Chart formats)
- Retrieving both

To see the names of files you have saved, click the List button. If you retrieve either the data or the formats but not both, your Chart will be labelled “Untitled.” If you retrieve both, the Chart will contain the file name. You can Open a file on another diskette (click the Eject button to change diskettes) and/or on an external disk drive if you have one (click the Drive button).

Transferring Data Between MacCharts

There are three ways by which data can be transferred between MacCharts:
UNDERSTANDING THE MACINTOSH

- Opening an existing file (discussed above)
- Copying
- Linking

COPYING DATA

To copy data for use in another graph, select the window you want to copy to make it active.

- If the active window is the Chart, enter the Edit menu and select Copy Chart
- If the active window is a data series window
  - Position the mouse arrow at the beginning of the first category to be copied and click the mouse button to create an insertion point
  - Drag the mouse through the data you want to copy and release the mouse button
  - Enter the Edit menu and select Copy

MacChart will then place a copy of the data on the Clipboard. At that point you can either save the current graph or erase it with the New feature in the File menu. In either case, the data remains on the Clipboard. You can then either create a new graph or Open another file to retrieve its contents. When you have done this, click the window you want to activate (Chart, existing data series window, or New Series window), enter the Edit menu and select Paste to transfer the data from the data from the Clipboard. Your data will then be copied. At any time, you can examine the data on the Clipboard by entering the Edit menu and selecting Show Clipboard.

LINKING MacCharts

There may be occasions for which you would like to use the same data in more than one file. MacChart provides the Paste and Link option for this purpose. To link two MacCharts, place a copy of the information to be linked on the Clipboard and, instead of using the Paste option, use the Paste and Link option. The information will be both pasted and linked. Thereafter, when you Open the second file, MacChart will read the first file to get the linked data. Note however that a linked file cannot be changed; to change the linked file you have to change the source file first. If MacChart cannot make a link, it will so inform you.

Having reviewed MacChart’s features, let’s move on to some practical advice on using MacChart.
GUIDELINES FOR USING MacChart

MacChart is certainly a very powerful and useful tool to create financial graphs. If you would like some practical advice on how to use MacChart, read on. If not, skip to the next section, which provides some ideas for using MacChart. Our topics in this section are:

- How much graphics to use
- What should be graphed
- Which shape to use
- An approach to using MacChart

HOW MUCH GRAPHICS TO USE

Graphics can be an effective tool for communication. On the other hand, if they are used too liberally, their impact will be diminished. Use them to supplement other materials and use them sparingly.

WHAT SHOULD BE GRAPHED

Given that you can illustrate absolute values (totals, increases, etc.), percentages, dollars, units, and so on, you'll have to make choices. In this regard, consider what you believe the reader needs to know. For example, if income is increasing but costs are increasing even faster, illustrate the rates of increase.

WHICH SHAPE TO USE

Which shape you should use is a function of what you want to illustrate. As a general rule:

- Rectangles—Use multiple rectangles (bar or column) when you want to compare two or more like items (e.g., current and prior year data) over time.
- Lines, filled areas and points—Use line, hilo, area, and scatter diagrams when you want to illustrate trends.
- Circles—Use pie shapes when you want to illustrate the relative size of components for a single period (e.g., revenues by line of business, sources of income, composition of expenses, etc.).
- Combinations—Use combination charts when you want to illustrate causal or other unusual relationships (income and advertising, etc.).
An Approach to Using MacChart

If you are a hobbyist with lots of time to devote to exploring and using MacChart, scan the material that follows. If not, then your time is most likely limited. If that is the case, you would probably like to produce a good graph in the shortest possible time. The material that follows will help you accomplish that goal. Our topics are:

- Getting acquainted with MacChart
- An approach to a MacChart session

GETTING ACQUAINTED WITH MacChart

Don’t wait until you are under the gun to produce a graph to use MacChart for the first time. Long before that, set aside 2 to 3 hours for exploring. Enter some data and then go through the menus one at a time. Become acquainted with each of the floating menus and sample all of MacChart’s features. Experiment with different shapes and sizing the Chart and Plot areas. Play with the prefix and suffix features (“Text before” and “Text after”) for categories and values in the Format menu. This will not only give you some experience with using MacChart it will also further stimulate your thoughts as to how you might use MacChart.

Approach to a MacChart session

After you have experimented with MacChart, consider the following. You can probably produce the essentials of a good graph (appropriate titles, etc.) in two to three minutes. However, expect to spend an hour or two if you want to incorporate all of the options. Rather than do that for all of your graphs, reserve them for those special occasions when they are absolutely essential. The flowchart in Figure 4.15 illustrates steps to produce a basic graph together with the options available to you. The flowchart begins with a new Chart and an active New Series window.

The flowchart in Figure 14.5 should help you create a MacChart. As to specifically what you might use MacChart for, let’s look at some ideas.

IDEAS FOR MacChart APPLICATIONS

Financial graphics are particularly useful for comparing numbers. Whether you intend to use MacChart in the office or at home, the comparisons you can make and illustrate with MacChart are limited only by your imagination. To get you started, here are some ideas:
Figure 4.15 Flowchart for Creating a MacChart.
Select series type and enter titles

Enter amounts for categories and values; click Show Plot box

Modify graph?

Generate data series?

Click New Series window

Enter Data menu, select Analyze and choose:
- Trend
- Growth
- Average
- Cum sum
- Difference
- Percent
- Statistics

Yes

More changes?

No

NO

END

Click Chart, enter Chart menu and select:
- Area
- Bar
- Column
- Hilo
- Line
- Pie
- Scatter
- Combination

Add Arrow

Add a Label

Click Chart, enter Gallery and select:
- Area
- Bar
- Column
- Hilo
- Line
- Pie
- Scatter
- Combination
- Select format

Click Chan.

Enter Chart menu enter Gallery

and select:

Area
Bar
Column
Hilo
Line
Pie
Scatter
Combination

Select format

Add Arrow Label.

in Chan menu

2

2

2

2

2

2

2

2
<table>
<thead>
<tr>
<th>General</th>
<th>Business</th>
<th>Personal</th>
</tr>
</thead>
<tbody>
<tr>
<td>Income sources</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Compensation over time</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Assets</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Expenses</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>New worth</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Cash flow</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Consumption</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Maintenance</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Variances</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Line of business</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Major customers</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Market share</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Price increases</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Commissions</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Advertising</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Productivity</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Utilization</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Backlog</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Cost analysis</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Budgets</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Expense categories</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Savings</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Comparison to actual</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Comparison to prior year</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Capital expenditures</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Taxes</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Percent of taxable income</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Absolute amounts over time</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Investments</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Rates of return</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Composition</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Retirement plans</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Present values</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Financing alternatives</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Rate comparisons</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Payment amounts</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Inflationary effects</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Income comparisons</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Expense comparisons</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Income taxes</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>School</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Grades</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Rankings</td>
<td>x</td>
<td></td>
</tr>
</tbody>
</table>
CASE STUDY—CREATING AND MODIFYING A MACCHART GRAPH

In this section, I will illustrate, step by step, how easy it is to use MacChart and how quickly you can produce a high quality graph. Our end product is a graph of the goals I set for myself when writing my first book compared to my actual progress. In that regard, I began writing November 1, 1982 and the overall goal was to submit my manuscript by February 15, 1983. That worked out to 25 pages semimonthly. Having established my plan, I graphed my actual progress. The individual steps are as follows:

Step 1  Select series type and enter labels
Step 2  Enter the categories and values for the plan
Step 3  Create a new series for the actual data
Step 4  Enter the actual data
Step 5  Display a graph of the plan data
Step 6  Modify the chart type
Step 7  Add the actual data to the graph
Step 8  Add grid lines
Step 9  Add a legend
Step 10  Final cosmetic changes
Step 11  Save the graph
Step 12  Critique

Step 1  Select series type and enter labels

Enter the Data menu and select Text. When the text series properties menu appears, enter the following titles:

- Title  PLAN
- Title for categories  Progress
- Title for values  Pages

Correct any typing errors and click the OK box to accept the titles.
Step 2  Enter the categories and values for the plan

Since the New Series window has created a text series, we can begin entering data. For a text series, MacChart expects to see entries for both categories (a blank label is an acceptable entry) and values. After a category has been keyed in, press the Enter key, and the cursor will move to the values area on the same line. You can then enter a value, press the Enter key, and continue entering data until you are through. Enter the following data:

<table>
<thead>
<tr>
<th>Categories</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>11/15</td>
<td>25</td>
</tr>
<tr>
<td></td>
<td>50</td>
</tr>
<tr>
<td>12/15</td>
<td>75</td>
</tr>
<tr>
<td></td>
<td>100</td>
</tr>
<tr>
<td>1/15</td>
<td>125</td>
</tr>
<tr>
<td></td>
<td>150</td>
</tr>
<tr>
<td>2/15</td>
<td>175</td>
</tr>
</tbody>
</table>

Since our categories are the same for both goal and actual, we can save a little time by using them again for the actual data. Place the cursor to the left of the first category, 11/15, press down on the mouse button, and drag it to the end of the last value, 175. Release the mouse button, enter the Edit menu, and select Copy to place a copy on the Clipboard.

Step 3  Create a new series for the actual data

Click in on any visible portion of the New Series window and it will become active. Enter the Data menu and select Text. When the text series properties menu appears, enter the following labels:

<table>
<thead>
<tr>
<th>Title</th>
<th>ACTUAL</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title for categories</td>
<td>Progress</td>
</tr>
<tr>
<td>Title values</td>
<td>Pages</td>
</tr>
</tbody>
</table>

Step 4  Enter the actual data

Since we have a copy of the plan data on the Clipboard, let's Paste it in now. Enter the Edit menu and select Paste. MacChart enters all of the data on the Clipboard. All we have to do is replace the goal figures with the actual figures.
Position the cursor to the right of the first value (25), click the mouse button to create an insertion point, and backspace enough times to erase the plan value. Then enter the actual value. Do this now for the actual values:

11/15   33
       68
12/15   103
       139
1/15    168
       188
2/15    188

Step 5  Display a graph of the plan data

Our series windows are set for the default (don’t display chart). We can activate each window and click in the Plot box or do them both at one time by using the List option in the Data menu and clicking the Plot box for each series in the Series list. If you have numerous series windows, use the List option in the Data menu. We’ll use the Plot box and illustrate a point or two along the way. Do the following:

• Click in any area of the “plan” series window.
• Click in the box next to Plot.
• Click in any area of the Chart.

When the Plot box is clicked, MacChart plots the data and displays the Chart. To move the series window to the back of the screen, click in any area of the Chart. At this point, your graph should resemble the graph illustrated in Figure 4.16.

Step 6  Modify the chart type

The default shape is a Column graph that is acceptable for comparing semi-monthly values. However, we would also like to view any trend that might be developing. Let’s use a Line graph for that purpose. Accordingly, do the following:

• Enter the Gallery menu and select Line.
• When the floating menu of sample line graphs appears, click in the box of the line graph that shows both markers (for the plot points) and lines.
• Click the OK box.
Step 7  Add the actual data to the graph

To keep abreast of my progress in writing the book, I entered the actual data beginning on November 15, 1982, and produced a graph on a semimonthly basis. Since we have all the actual figures, we’ll see what the graph looks like with all the actual data in it. Click in the series window for the actual data and click the box next to Plot. MacChart adds the actual data to the graph.

Step 8  Add grid lines

When two sets of values are fairly close together (such as is the case in this case study), you may want to use grid lines to help distinguish the relative values. Let’s add them to see if they help:

- Enter the Chart menu.
- Select Axis.
- When the Chart axes menu appears, click in the box next to major grid Lines.
MacChart adds the major grid lines. At this point you may wish to experiment with the other grid lines to see how they appear on the graph.

ADD A LEGEND

Although our line shapes are perfect for what we want to display, we can’t tell from the graph which line represents plan data and which represents actual data. In this regard, the Legend can help us. Enter the Chart menu and select Show Legend. A Legend automatically appears. Reenter the Chart menu and observe that the legend command has changed to Hide Legend. The legend command switches back and forth between Show Legend and Hide Legend to permit us to display it or hide it whenever we want.

When we added the Legend, MacChart automatically resized the Plot area to make room for the Legend. The Legend displays each type of Marker used in drawing the line graphs. Notice that the Legend labels, Plan and Actual, correspond to the Series titles we used. Now each of our line graphs are explained in the Legend area.

Step 10  Final cosmetic changes

As indicated earlier, you can change every single component in the Chart, including the size and location of text labels, and you can add a label if you desire. To illustrate how to use some of these features, let’s make some final cosmetic changes to our graph.

CHANGING THE VALUES LABEL

Enter the Chart menu and choose Select Plot Area. The Plot area should now be surrounded by little black boxes. The boxes in the middle are for changing the size of the Plot in one dimension only. For example, try to drag the bottom middle box. It will only move up and down to shorten or lengthen the width of the Plot area. If you press down on the mouse button anywhere inside the Plot area (except in a size box), you can reposition the Plot. The same is true for the other components.

Point the mouse inside the Plot area, press down on the mouse button, and drag the Plot a couple of inches to the right. Notice that the values label, Pages, moves with the Plot. It does so because it’s automatically set to do so. Let’s change that. Position the mouse directly on the values label, Pages. Click the mouse button to select it. Enter the Format menu and select Text. The Text menu illustrated in Figure 4.14 will appear. Notice that there are selection boxes for attaching the label, selecting font style and size and aligning the
label. Click the mouse button in the Unattached box to detach it from the axis. Click OK and we can move the values label. Drag it to the left of the screen and let go of the mouse button.

**POSITIONING AND SIZING THE PLOT**

Select the Plot area using the Select Plot Area option in the Chart menu. Drag it back to the left just short of the values label. Position the mouse pointer inside the middle-size control box on the right side of the Plot area. Press down and drag the mouse to the left just enough to make room for the Legend (if the Legend moves with the Plot, click inside the Legend, enter the Format menu, and select Legend and deselect Automatic Size and Position); click the OK box to continue.

**POSITIONING AND SIZING THE LEGEND**

Click inside the Legend. It too can now be adjusted as to size and position. Move it around and adjust its size until you feel comfortable with the cosmetics. Experiment with the features in the Legend Properties floating menu (select Legend from the Format menu).

**CHANGING THE TITLE**

Our main title is “PLAN,” which isn’t very descriptive. Initially, MacChart uses the Series title (for the data series ordered #1) for the main title. Let’s change it. Click inside the title, PLAN. Enter the Format menu and select Text. Deselect automatic positioning. Select large type size and bold. We’re ready to change the title.

Click in front of the last letter to create an insertion point. Use the Backspace key to erase Plan. Key in the title, “STATUS OF BOOK” (no quotes). Press enter to accept the title. Now drag the title until it is positioned where you think it should be. That’s all there is to it. Your finished graph should resemble the graph illustrated in Figure 4.17.

**Step 11 Save the graph**

Had we actually created a graph on a bimonthly basis, we would have saved the graph after each update. To save our example, enter the File menu and select Save As. Use a descriptive file name such as “PROGRESS ON BOOK” (use any combination of characters except for the colon).
Step 12  Critique

As I indicated earlier, it isn't necessary to use every MacChart feature for every graph. Several of the steps above were added to illustrate the features. There were other alternatives available to us. For example, we could have:

- Used a Column graph
  - Entered blanks for all categories
  - Used a prefix of "P" for Plan and "A" for Actual
  - Used a category axis title of "Semimonthly Progress"
- Added new labels (e.g., Plan and Actual) adjacent to the line graphs instead of using the Legend. We also could have had a two-title heading by adding a label:
  - USING THE Macintosh COMPUTER
  - Progress on book

Our alternative approaches indicate just how flexible MacChart really is.
CLEARING DATA AND FORMATS

After you have saved the graph, you might want to make further modifications or work on a new graph. Do the following:

- If the Chart is not in front of the data windows, select it.
- Enter the File menu and select New to erase all the formats and return to the default formats.
- Select any data window.
- Enter the File menu and select New to erase all the data windows.

When you are ready for some fun, we'll move on to MacPaint.
Chapter 5
USING MacPaint
MacPaint is essentially a free-form drawing tool. Whereas MacPlan, MacWrite, and MacChart are designed to produce structured end-products (i.e., spreadsheets, textual documents, and financial graphs), MacPaint isn't structured to produce anything at all! However, it can produce every shape imaginable. Our topics are:

- Overview of MacPaint
- Ways to use MacPaint
- Working with MacPaint features
- A MacPaint illustrated idea

OVERVIEW OF MacPaint

Imagine that you won a prize in a drawing. Your prize is unlimited use of everything in an artists' supply store. As you look around the store, you see pencils, erasers, paint brushes of assorted sizes, cans of spray paint, regular paint cans, rulers, templates for drawing shapes and characters, and a seemingly endless supply of paper. In the beginning, you might experiment with the various templates to see what patterns develop. Add a dab of spray paint and perhaps paint some swirls, etc., to get the feel of the paint brushes. When you are through experimenting, you marvel at the kaleidoscope of patterns you have created. You begin to visualize some specific things you might create.

If you are wondering what the introduction above has to do with MacPaint, then wonder no more. Having MacPaint is like being in that artists' store. MacPaint provides you with all of the artists' tools and turns you loose with an endless supply of paper. With MacPaint, you can create anything you want.

WAYS TO USE MacPaint

While there are many ways to using MacPaint, they all fall into two general categories—creating useful end-products and having fun.

Creating Useful End-Products

While visualizing the artists' supply store, you might have concluded that sketches and paintings are the only primary end product. While it is certainly true that MacPaint can help you produce sketches and paintings, these are but one class of end-products you can create. Set aside your artists' smock and don your business hat for a moment. If you had a tool that could produce squares, straight lines, dotted lines, arrows, various shapes, and text, you could find a
business use for that tool. With such a tool, you can illustrate organizational relationships, office arrangements, relative locations, floor maps, street maps, document flowcharts, procedure flowcharts, etc. In that regard, MacPaint can help you produce end-products useful for business purposes. Similarly, if you are a student, these end-products might be equally useful to you.

Having Fun

You have probably devoted a lot of time and effort reading the preceding chapters. At this point, you deserve to have some fun. Take off your shoes and get comfortable. If you have a family, assemble the other family members. Let them enjoy playing with MacPaint too. After a work session of writing this book, my wife and daughter were eager to join in, take hold of MacMouse, and have some fun. Mesmerized by the endless patterns and shapes, we took turns using MacMouse to create yet a new design. MacMouse never ceased to amaze us with his endless variety of tricks. Caught up in the process, we found that hours would pass before we knew it. After a long day of work and school, we deserved it.

WORKING WITH MacPaint FEATURES

Having been turned loose in an artists' supply store, let's begin by looking around the store to see more clearly what is in it. After that, we'll see how to use things and what to do with them when we're done. Our topics are:

- Understanding MacPaint's components
- Using MacPaint tools
- Changing patterns
- Modifying MacPaint paintings
- Keyboard commands and other shortcuts
- Storing, retrieving, and printing MacPaint paintings

Understanding MacPaint's Components

When you load in the MacPaint application program, MacPaint will display a blank piece of paper surrounded by shapes and patterns. As illustrated in Figure 5.1, the basic components consist of:

- MacPaint tools
- Line thickness box
• MacPaint patterns
• Current pattern box

**MacPaint TOOLS**

Our tools are stored to the left of our blank piece of paper. We’ll explore each tool shortly.

**LINE THICKNESS BOX**

At the bottom left of the screen is the line thickness box. To change the thickness, point MacMouse to the desired thickness and click the mouse button.

![Figure 5.1 MacPaint’s Components.](image-url)
MacPaint PATTERNS

To help get you started, MacPaint has created an array of patterns to choose from. To select a pattern, point MacMouse to the pattern and click the mouse button.

CURRENT PATTERN BOX

When you select a pattern, it is displayed in the current pattern box.

Using MacPaint's Tools

MacPaint’s tools are represented by the icons in Figure 5.2. To facilitate our discussion of MacPaint’s tools, I have inserted their names alongside the icons. To select a tool, point MacMouse to the tool and click the mouse button. Let’s see what each of them does.

LASSO

The lasso is used to capture objects with irregular shapes, including portions of a drawing. To capture an object (anything on the screen, including text), press down on the mouse button, drag the lasso around it, and release the mouse button. The lasso will then tighten up around the object at which time it can be modified (we’ll discuss modifications in the next section).

DOTTED RECTANGLE

The dotted rectangle is also used to capture objects. Whatever is inside the rectangle, including any background area, will be captured. To capture an object with the dotted rectangle, press down on the mouse button, drag the mouse diagonally, and when the object is surrounded by the rectangle, release the mouse button. The object can then be modified. If you don’t want to modify the object, click another tool.

HAND

Notice that the hand is turned and appears to be pulling or grabbing at something. The hand is pulling at the paper on the screen. What you see on the screen is only a portion of the drawing area you can use. To move the drawing
Figure 5.2 MacPaint Tools.
paper, press down on the mouse button and drag the mouse in any direction. The paper moves in the same direction, exposing other areas of the drawing paper.

To view the entire page, enter the Goodies menu and select Show Page. The view will then change to include the entire page. To return to the normal view, enter the Edit menu and Select Undo.

TEXT

You can create text anywhere you want to on the page. After clicking the Text box, position the mouse cursor at the desired location and click the mouse button to create an insertion point. Enter the Font, FontSize and/or Style menus to select the font type, size, and special features (bold, etc.), respectively.

PAINT CAN

The paint can is used to quickly fill an enclosed area (circle, rectangle, etc.). However, be careful using the paint can; if the area to be filled is not entirely enclosed, the paint will leak through and fill the next largest enclosed area. The paint used to fill an area is based on the current pattern selection. To fill an area, simply click inside the area. MacMouse will see to the rest.

SPRAY CAN

Unlike spray paints that we buy at the store, our MacPaint spray can never run out of paint. The type of paint is based on the current pattern box. Like a spray paint, the spray can sprays lots of little dots. Point the mouse to the desired location and drag the mouse around in any direction, including swirls, circles, etc. To stop spraying, let go of the mouse button.

BRUSH

Our store contains a large variety of paint brushes. The selection includes brushes of different lengths, shapes, and thicknesses. In addition, there are some brushes that paint dotted lines instead of solid lines. Like the paint and spray cans, the brush uses the paint in the current pattern box. To use the brush, press down on the mouse button and away you go.

Brush selection. To select a brush, enter the Goodies menu and select Brush Shape. The floating menu illustrated in Figure 5.3 will appear.
Figure 5.3 Brush Selection Menu.

Click the brush you want to use and the menu will disappear. By the way, you don’t have to clean your brushes; MacMouse does that too. Love that mouse!

Brush Mirrors. As a mirror reflects an image, so do the Brush Mirrors. Enter the Goodies menu and select Brush Mirror. The floating menu illustrated in Figure 5.4 will appear.

Figure 5.4 Brush Mirror Menu.
To select one or more mirrors, simply click them. To deselect the mirrors, click the None box. When you paint with the paint brush, using mirrors creates a symmetrical pattern. Use a swirling motion to create a kaleidoscope effect. This little goodie provides hours and hours of entertainment.

**PENCIL**

Use the pencil for free-hand drawing. The thickness of the lead can be adjusted in the line thickness box illustrated in Figure 5.1. To begin drawing with the pencil, click anywhere you want to and drag the mouse. Let go of the mouse button to stop drawing. If you need some help with straight lines, enter the Goodies menu and select Grid. Grid creates imaginary grid lines to help you draw straight lines.

**LINE**

Select the line and you can draw perfectly straight lines. The thickness of the line can also be adjusted in the line thickness box. As with the pencil, drag to draw and let go to stop.

**ERASER**

You can use the eraser to erase mistakes or create special effects. We’ll discuss the eraser in the next section.

**RECTANGLE, OVAL, CIRCLE, AND POLYGON**

Selecting one of these enables you to create the respective shapes. Point the mouse to a desired location and drag it. The farther away you drag, the larger the shape you create.

Notice that the tool box contains two of each of these shapes. The shape that is filled in creates a shape, the fill pattern of which is based on the current selection box.

**FREE FORM**

Use the Free form to create an enclosed shape of your choice. The Free form will continue drawing until you create an enclosed shape. As with Rectangle, etc., you can choose unfilled or filled.
Changing Fill Patterns

In addition to using the standard fill patterns provided by MacPaint, you can customize existing fill patterns. To do this, click the pattern to be customized, enter the Goodies menu and select Edit Pattern. A floating menu will appear, which contains two boxes. The box on the left contains rows and columns of squares, some of which are white and others are black. The black squares represent the fill pattern. To change a square from white to black or vice-versa, click the square. The box on the right shows the revised fill pattern. In addition to clicking a square, you can drag the mouse through the box; every square that is touched will change.

When you are through editing the fill pattern, click the OK box to accept the changes you made or Cancel to revert back to the former fill pattern. The fill patterns are saved when you save your drawing.

Modifying MacPaint Drawings

You can modify your existing drawing whenever you desire. To facilitate making changes, use one of the following:

- Undo
- Erasing
- Overlay
- Fat Bits

UNDO

As with all Mac applications, Undo enables you to undo the most recent action.

ERASING

Since none of us are perfect (except MacMouse), we will make mistakes from time to time. Perhaps your pencil strayed too far or the spray can sprayed outside an area. MacPaint provides us five different ways that we can erase.

Use the Eraser. Click the Eraser box and MacMouse will pass you the Eraser. Point to an area on the screen, press down on the mouse button, and hold it down. The mouse cursor turns into an Eraser. If you release the mouse button without dragging the mouse, only the area immediately under the Eraser will be erased. Dragging the mouse erases whatever comes underneath the Eraser.
So, for example, if a line extends too far (1) place the Eraser on top of the portion of the line you want to erase and click the mouse button or (2) drag the mouse until the portion of the line you want to eliminate is gone.

You can also use the Eraser to create a white on black drawing. Using the Paint Can, fill the screen with black paint. Then use the eraser to eliminate portions of the black paint.

**Double-click the Eraser box.** Double clicking the mouse button in the Eraser box erases the entire contents of the screen.

**Use the Lasso or Dotted Rectangle.** Click the Lasso or Dotted Rectangle box. Then select an area with either tool. Enter the Edit menu and select Erase. The area enclosed by the tool will disappear.

**Drag the page.** Select Show Page from the Goodies menu. When the page appears, position the mouse arrow outside the dotted rectangle and drag the image off the screen to erase it.

**OVERLAY**

Irrespective of the pattern fill previously used, you can use the same or another pattern to paint or draw on top of an area. For example, fill the screen with black paint. Then use the Eraser to paint over it (erasing is really overlaying). Finally, use the Pencil (or anything else for that matter) to draw in the area where the Eraser was used. The result is a double overlay (there isn’t any limit to overlays).

**FAT BITS**

If you are familiar with a little data processing terminology, then you know that a “bit” is short for binary digit. There are two numbers used in the binary numbering system—one and zero. In data processing, a one bit is used to designate an “on” state and a zero to designate an “off” state. Now, let “on” stand for the color black and “off” for the color white. If everything is off, our screen is white.

We saw previously that we can change the fill pattern by selecting the Edit Pattern feature. Do you recall that the box on the left magnified the dots? Fat Bits (enlarged white and black squares—ho, ho, ho) does the same thing to the screen as Edit Pattern does to the Fill pattern—it zooms in on a highly magnified portion of the screen. When you select Fat Bits, you can use the Pencil to make a white square (“off” bit) change to black (“on” bit) and vice-versa. Fat Bits is useful for making little Bitty changes in an image. When Fat
Using MacPaint

Bits is displayed, a small portion of the screen displays a split screen image of the entire screen to enable you to

• Determine which portion of the screen is being displayed
• See the effect of Fat Bits changes

To leave Fat Bits, double-click the pencil. In addition to the features described above, you can invert, flip or rotate a selected shape by using the commands in the Edit menu.

Keyboard Commands and Other Shortcuts

Some features can be performed using the keyboard either as a substitute for the menus or to create additional features. In addition, double-clicking the mouse provides other shortcuts.

KEYBOARD SUBSTITUTES

Backspace  Erases the selection
Tilde ~     Undo

ADDITIONAL KEYBOARD COMMANDS

Pressing down on the following indicated keys while dragging the mouse results in:

<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command key</td>
<td>Copies a selected object</td>
</tr>
<tr>
<td>Option key</td>
<td>Stretches or shrinks an object</td>
</tr>
<tr>
<td>Option key and Command key</td>
<td>Makes multiple copies</td>
</tr>
<tr>
<td>Shift key</td>
<td>Constrains mouse movement to horizontal, vertical or diagonal directions</td>
</tr>
</tbody>
</table>

DOUBLE-CLICKING

Double-clicking the mouse when it is positioned in the following boxes results in:

<table>
<thead>
<tr>
<th>Box Type</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dotted rectangle</td>
<td>Selects entire window</td>
</tr>
<tr>
<td>Brush</td>
<td>Display Brush Shapes</td>
</tr>
<tr>
<td>Pencil</td>
<td>Leave or enter Fat Bits</td>
</tr>
</tbody>
</table>
Eraser
Current pattern

Erases entire window
Display Edit Pattern

Should you forget any of the above, enter the Goodies menu and select Short Cuts to display the related "help" screen. Click OK when you are ready to continue.

Storing, Retrieving, and Printing MacPaint Paintings

Inasmuch as the procedures for Saving, Opening, and Printing are similar to those for applications discussed in previous chapters, refer back to those chapters if you have forgotten any of them. However, if you have edited a fill pattern with the Edit Pattern feature, remember to Save your drawing or the pattern will be lost.

A MacPaint ILLUSTRATED IDEA

In addition to special purpose drawings such as those illustrated in Figures 5.1 through 5.4 (as well as many of the illustrations elsewhere in this book), you can use MacPaint to create other charts such as the organization chart illustrated in Figure 5.5.

Whereas, we're finished with the individual chapters, we still have one more application topic to cover—transferring data between applications.

Figure 5.5 Organization Chart.
Chapter 6
TRANSFERRING DATA BETWEEN MACINTOSH APPLICATIONS
Each of the applications individually is a treat. As if that weren’t enough, you can transfer data between some of them. In this brief chapter, we’ll look at:

- Applications that exchange data
- Benefits of exchanging application data
- How to exchange application data

UNDERSTANDING WHICH APPLICATIONS CAN TRANSFER DATA

At the date this book was written, data transfer was planned as follows:

<table>
<thead>
<tr>
<th>FROM</th>
<th>TO</th>
</tr>
</thead>
<tbody>
<tr>
<td>MacPlan</td>
<td>MacChart</td>
</tr>
<tr>
<td>MacPlan</td>
<td>MacWrite</td>
</tr>
<tr>
<td>MacChart</td>
<td>MacWrite</td>
</tr>
<tr>
<td>MacPaint</td>
<td>MacWrite</td>
</tr>
</tbody>
</table>

BENEFITS OF TRANSFERRING APPLICATION DATA

There are three principal benefits of the ability to transfer data from one application to another:

- Time savings
- Error elimination
- Ability to consolidate data from multiple sources

Time Savings

Suppose that you have a recurring MacPlan application for which the results of calculations are used to prepare a MacChart graph. In the absence of data exchange, the MacPlan results must be manually entered into a MacChart data series window. If the data is voluminous or if the application is used frequently or repeatedly, the process of manually entering MacPlan results into MacChart could be time-consuming. In this regard, the ability to transfer data saves you time.
Eliminate Error Sources

There are basically two types of errors that can result from relying on manual procedures to transfer data from one application to another:

- Keying errors
- Omissions

The first type of error results from keying the data incorrectly. In our example, MacPlan results are manually transferred to MacChart. If the MacPlan results are keyed incorrectly, then the MacChart will contain errors. The second type of error, omissions, results from the failure to transfer MacPlan results. Whatever the cause, be it fatigue, forgetfulness, or lack of training, if the data simply isn’t transferred, then the second application will contain erroneous results.

Ability to Consolidate Data Into One Document

For illustrative purposes, assume that you are preparing a MacWrite report. Perhaps the report discusses the results of a forecast and contains recommendations. You could end up with three separate documents: the MacWrite report itself; a MacPlan spreadsheet, which contains the forecast; and a MacChart graph depicting key observations. Instead of having three separate documents, why not consolidate the three documents into one? You could transfer the key numeric tables from MacPlan and the graph from MacChart right into the MacWrite document.

HOW TO TRANSFER APPLICATION DATA

The specific procedures used to transfer data from one Mac application to another vary according to the specific application and are subject to change in updated software releases. However, we’ll discuss the initial procedures by application.

Transferring Data From MacPlan to MacChart

The steps to transfer data from MacPlan to MacChart are as follows:

- Select the columns in MacPlan that you want to transfer.
- Copy the selected columns onto the Clipboard.
Transferring Data Between Macintosh Applications

- Exit MacPlan and load MacChart.
- Paste the contents of the Clipboard into a data series window, thereby establishing a link between the two.

After a link has been established, the linked data in MacChart cannot be manually altered. When you Open the related MacChart file, MacChart will search the diskette looking for the MacPlan source file containing its data; accordingly, you should plan to have both files on the same diskette.

Transferring Data to MacWrite

The procedures to transfer data from MacPlan, MacChart, and MacPaint to MacWrite are simpler and do not create a permanent link. Accordingly, you can transfer data whenever you desire.

To transfer data into MacWrite

- Copy the data to be transferred onto the Clipboard and exit the source application.
- Enter MacWrite and create an insertion point for the data to be transferred.
- Paste the contents of the Clipboard into your MacWrite document.

It probably wouldn't make much sense to transfer, for example, a large graph or painting into MacWrite if, once transferred, an entire page of a MacWrite document were to be consumed. Accordingly, after the transfer has been made, you can shrink a MacChart graph or MacPaint painting. To shrink them, click anywhere inside the graph or painting. A rectangle with three black size control boxes along its bottom edge will appear.

- Drag the middle box up or down to adjust the vertical size.
- Drag the left or right box in a horizontal direction to adjust the horizontal size.
- Drag the left or right edge of the rectangle in a horizontal direction to relocate the insert.

If you have already purchased a Mac, you have many hours of enjoyment ahead of you. If you are considering purchasing a Mac, the information contained in Chapters 1 through 6 should help you make your decision. In either case, for a glimpse into Mac's future and the role you can play, read Chapter 7.
Chapter 7

COMING
ATTRACTIONS
In Chapter 1 I indicated that it is impossible to predict whether planned enhancements will be forthcoming or whether, if forthcoming, they will be available on a timely basis. In that regard, purchase decisions should be made based on what is available today to avoid disappointments should enhancements, be they software or hardware, not materialize. With these caveats in mind, we'll discuss coming attractions as it relates to additional software and the role you can play to influence software and hardware development. Our topics are

- New software
- How you can influence software development

NEW SOFTWARE

In Chapters 1 through 4 we discussed four general-purpose software packages: MacPlan, MacWrite, MacChart, and MacPaint. Based on the author's experience, observations at trade shows, and a review of other vendor systems, we should expect to see additional software for the Macintosh computer. Although no assurance can be given that the software discussed below will materialize, it seems reasonable that, if it does materialize, we should expect to see the following (note—some of the following software may be available at the time you read this book).

Data management

Noticeably absent is a mouse-oriented package to manipulate data as follows:

- Data retrieval
- Sorting
- Search based upon selective criteria
- User defined fields

Programming languages

Expect to see, as a minimum, a version of BASIC. BASIC is one of the most popular languages for end-users to develop simple programs that accomplish specific purpose tasks. Given the mouse and pull-down environment, it is likely that the version of BASIC will use these aids, thereby making programming easier for end-users. You can also expect to see a version of Pascal for the Macintosh.
Communications software

Most microcomputers have communications software to enable users to transfer files from one location to another (office to home, etc.) or access public databases. Given that the Mac has two serial ports, it has the physical capacity to support a modem. There is a good possibility, then, that software will be developed to support communications.

Provided that the Macintosh is successful in the marketplace, other software that probably would be developed includes:

- Calendar functions
- Electronic mail
- Specific purpose templates
- Tax planning and tax return calculations
- Investment management
- Games
- Small business accounting functions

If any of the software listed above or other software you desire is not available when you read this chapter, there is something you can do about it. Let's see what that is.

HOW YOU CAN INFLUENCE SOFTWARE DEVELOPMENT

There are two and only two reasons why commercial application software is developed:

- In anticipation of market demand
- In response to market demand

The application software available when the Macintosh was introduced (and shortly thereafter) was developed in anticipation of market demand. Its developers undoubtedly did their homework in the market research area before committing substantial resources to software development. Nonetheless, those resources were committed in anticipation of the market demand that might exist when the Macintosh was introduced.

The second reason that commercial software is developed is in response to market demand. It is this class of software that you and I can influence. If there is software that is not available that you would want, there is something you can do about it. Individually, our impact on market demand is negligible. Collectively, we, and others like us, represent the entire market demand curve.
If we let the appropriate parties know that there is a market for undeveloped software, we can influence its development and create our own coming attractions. So who are the appropriate parties and what can you do? A key player is, of course, Apple Computer, Inc., the creator of the computer. If you want to be heard and desire to influence software development for the Macintosh computer, send a letter to, as a minimum, the parties listed below (tell others to do so as well). In addition, form a Macintosh Users Group and send letters from the user group:

1. Steve Jobs, Chairman
   Apple Computer, Inc.
   20525 Mariani Avenue
   Cupertino, Ca 95014
   (408) 996-1010

2. Vice President—Marketing
   Apple Computer, Inc.
   20525 Mariani Avenue
   Cupertino, Ca 95014

3. Vice President—Marketing
   Microsoft Corporation
   10700 Northrup Way
   Bellevue, Wa 98004

4. Editor
   Reston Computer Group
   Reston Publishing Co., Inc.
   11480 Sunset Hills Road
   Reston, Va 22090

5. Your Apple dealer

   I sincerely hope that you have enjoyed this book. I (with a little help from MacMouse) certainly enjoyed writing it for you.
INDEX

Coming attractions, 197
Device connectors, 7
Disk drive, 6
Display screen, 6
Icons, 12
Keyboard, 8
Microprocessor, 5
Mouse, 4
  Clicking, 12
Printer, 8
Pull down menus, 18
Software environment, 16
Transferring data, 191, 194, 195
  Plan to Chart, 21, 194
  To MacWrite, 20, 195
User-friendliness, 11
Windows and Scroll Boxes, 14

MacChart
  Benefits, 129
  Case study, 61, 168
  Components, 132, 134
  Copying, 162
  Data types, 134
  Entering data, 136
  Graphics shapes, 127, 163
  Guidelines, 163

Ideas, 164
Linking, 162
Modifying data, 136, 137
  Alignment and format, 150
  Arrow, 154
  Axes, 144, 148
  Border, 144
  Labels, 154
  Legend, 152
  Locations, 156
  Order, 148
  Overlay chart, 157
  Patterns, 157
  Prefixes and suffixes, 148, 149
  Shapes, 127, 142
  Size, 156
  Sorting, 157
  Special keys, 158
  Titles, 145
Overview, 129
Printing, 159
Retrieving, 161
Saving, 160, 161
Terminology, 133
Transferring, 161
MacPaint
Components, 180
Features, 180
Fill pattern, 187
Keyboard commands, 190
Modifying, 187
   Erasing, 187
   Fat bits, 188, 189
   Overlaying, 188
   Shortcuts, 189
Undo, 187
Tools, 182
   Brush, 183, 184, 185
   Dotted rectangle, 182
   Eraser, 183, 186, 188
   Free form, 183, 186
   Hand, 182, 183
   Text, 183, 184
   Lasso, 182, 183, 188
   Line, 183, 186
   Paint can, 183, 184
   Pencil, 183, 186
   Shapes, 186
   Spray can, 184
Overview, 179

MacPlan
Absolute reference, 37
Benefits, 27
Calculating results, 42
Case study, 61
Circular references, 42
Clear, 37
Column width, 40
Commas, 39
Copy, 35
Cut, 35
Decimal points, 39
Display alignment, 40
Dollar signs, 39
Electronic spreadsheet, 25, 26
Entering data, 30
Features, 29
Fill, 37
Formulas, 48
   Components, 49
Control constants, 51
   Built-in functions, 52
   Relational operators, 50
   Text operator, 51
Freeze, 40
Ideas, 60
Modifying, 33, 34, 38
Show clipboard, 36
Show formulas and values, 41
Paste, 36
Paste function, 36
Paste name, 36
Printing, 44
Protecting, 44
Selecting, 34, 35
Shortcuts, 45
Sort, 37
Transferring data, 47
Undo, 36

MacWrite
Benefits, 100
Case study, 121
Document life cycle, 97
Documents, 97, 101, 109, 121
   Nonrecurring, 104, 105
   Recurring, 103
Features, 106
   Comfort control, 106
   Footer, 113
   Header, 113
   Page break, 113
   Page #, 113
   Ruler, 109
   Title page, 113
Ideas, 102
MacLibrary, 104
Modifying, 114
   Change, 117
   Find, 116
   Modifying appearance, 117
   Modifying contents, 115
Printing, 119
Saving, 119
Shortcuts, 120
Transferring text, 121
UNDERSTANDING THE MACINTOSH COMPUTER

Written for the beginner, *Understanding the Macintosh™* is a concise introductory guide that will answer your questions about the Apple Macintosh™ computer and accompanying software applications.

What can a Macintosh™ do? How does the Macintosh™ operate? And, what are the meanings and uses of the Mouse, Windows, Electronic Spreadsheets, Word Processing and High Resolution Graphics on the Macintosh™? These are just some of the questions answered clearly in this book.

Understanding the Macintosh™ is the perfect companion to your new Macintosh™ computer. The author has included many examples as they appear on the computer screen so you can see exactly what the computer does as you work. The book will also show you how to get the most from the four unique software packages available with the Macintosh™: *MacPlan®*—An electronic spreadsheet and modeling tool; *MacWrite™*—A word processor and text editor; *MacChart®*—A financial graphics tool, and *MacPaint™*—A free form graphics generator.

A unique book on a most unique and exciting personal computer, *Understanding the Macintosh™* works with your Macintosh™ computer to provide you with a powerful and versatile tool for both business and pleasure.

**Contents**

*Understanding the Macintosh™* Computer

- Using MacPlan
- Using MacWrite
- Using MacChart
- Using MacPaint
- Exchanging Data between Macintosh™ Applications
- Coming Attractions

Macintosh™ is a trademark licensed to Apple Computer, Inc. MacPlan® and MacChart® are registered trademarks of Microsoft Corporation.

Reston Computer Group
Reston Publishing Company, Inc.
A Prentice-Hall Company
Reston, Virginia

Cover Photograph by Richard V. Simon
Cover Design by Debbie Balboni

0-8359-8054-5