Macintosh Multimedia Machine

David S. Mash

- An Interactive Guide to Sound, Music, and Multimedia on the Mac
- Includes a FREE CD Containing Media Tools, a Powerful Multimedia Authoring Program; a Full Demo of Adobe Premiere 3.0; and Four Full-Length Audio CD Tracks
- Foreword by Bob Moog
Multimedia Machine guides you through the steps to learning the many ways that sound and music can be integrated into multimedia projects, demystifying all the buzz words as you go. Learn about QuickTime, Sound Manager, digital audio, CD audio, MIDI, SMPTE, MTC, LTC, VITC, AIFF, SMF, SND, SDII, EPS, TIF, PICT, ASCII, and many other multimedia concepts!

**LEARN HOW TO:**

- **Edit digital video** and add music and sound to pictures using Adobe Premier—a limited version is included on the CD-ROM!

- Create and edit digital audio files using Digidesign's TurboSynth—a limited version is included on the CD-ROM!
Build exciting multimedia projects using a powerful set of tools for integrating media into HyperCard projects—Media Tools—a limited version is included on the CD-ROM!

Create MIDI sequence files for multimedia using Opcode Systems' MusicShop—a limited version is included on the CD-ROM!
For every kind of computer user, there is a SYBEX book.

All computer users learn in their own way. Some need straightforward and methodical explanations. Others are just too busy for this approach. But no matter what camp you fall into, SYBEX has a book that can help you get the most out of your computer and computer software while learning at your own pace.

Beginners generally want to start at the beginning. The ABC's series, with its step-by-step lessons in plain language, helps you build basic skills quickly. Or you might try our Quick & Easy series, the friendly, full-color guide.

The Mastering and Understanding series will tell you everything you need to know about a subject. They’re perfect for intermediate and advanced computer users, yet they don’t make the mistake of leaving beginners behind.

If you’re a busy person and are already comfortable with computers, you can choose from two SYBEX series—Up & Running and Running Start. The Up & Running series gets you started in just 20 lessons. Or you can get two books in one, a step-by-step tutorial and an alphabetical reference, with our Running Start series.

Everyone who uses computer software can also use a computer software reference. SYBEX offers the gamut—from portable Instant References to comprehensive Encyclopedias, Desktop References, and Bibles.

SYBEX even offers special titles on subjects that don’t neatly fit a category—like Tips & Tricks, the Shareware Treasure Chests, and a wide range of books for Macintosh computers and software.

SYBEX books are written by authors who are expert in their subjects. In fact, many make their living as professionals, consultants or teachers in the field of computer software. And their manuscripts are thoroughly reviewed by our technical and editorial staff for accuracy and ease-of-use.

So when you want answers about computers or any popular software package, just help yourself to SYBEX.

For a complete catalog of our publications, please write:
SYBEX Inc.
2021 Challenger Drive
Alameda, CA 94501
Tel: (510) 523-8233/(800) 277-2346 Telex: 336311
Fax: (510) 523-2373

SYBEX is committed to using natural resources wisely to preserve and improve our environment. As a leader in the computer book publishing industry, we are aware that over 40% of America's solid waste is paper. This is why we have been printing the text of books like this one on recycled paper since 1982.

This year our use of recycled paper will result in the saving of more than 15,300 trees. We will lower air pollution effluents by 54,000 pounds, save 6,300,000 gallons of water, and reduce landfill by 2,700 cubic yards.

In choosing a SYBEX book you are not only making a choice for the best in skills and information, you are also choosing to enhance the quality of life for all of us.
This Book Is Only the Beginning.


Now you can download the source code for the material covered in this book. From the privacy of your own home or office, you can have access to a wide variety of source code, utilities and shareware. Plus you'll be able to talk to SYBEX authors and editors, and other forum members who share your interests.

Expert Advice at No Extra Charge.

As a SYBEX Forum member, you'll have access to expert tips and hints about your computer and the most popular software programs. Just access CompuServe and enter GO SYBEX.

What's more, you can download the source code from programs covered in SYBEX books, discover professional quality shareware, suggest topics for future books, share information with other SYBEX Forum users and more—for no additional charge. All you pay for is your CompuServe membership and connect time charges.

Get a Free Serving of CompuServe.

If you're not already a CompuServe member, try it for free. Call, toll-free, 800-848-8199 and ask for representative #560. You'll get a personal ID number and password, one FREE month of basic service, a FREE subscription to CompuServe Magazine, and a $15 credit towards your CompuServe connect time charges. Once you're on CompuServe, simply enter GO SYBEX and start to explore the SYBEX Forum.

Tune In Today.

The SYBEX Forum can help make your computer an even more valuable tool. So turn on your computer and visit the SYBEX Forum on CompuServe. You'll be glad you did.

SYBEX. Help Yourself.
Macintosh® Multimedia Machine

David S. Mash

San Francisco  •  Paris  •  Düsseldorf  •  Soest
SYBEX warrants the enclosed compact disc (CD) to be free of physical defects for a period of ninety (90) days after purchase. If you discover a defect in the CD during this warranty period, you can obtain a replacement CD at no charge by sending the defective CD, postage prepaid, with proof of purchase to:

SYBEX Inc.
Customer Service Department
2021 Challenger Drive
Alameda, CA 94501
(800) 227-2346
Fax: (510) 523-2373

After the 90-day period, you can obtain a replacement CD by sending us the defective CD, proof of purchase, and a check or money order for $10, payable to SYBEX.

SYBEX makes no warranty or representation, either express or implied, with respect to this software, its quality performance, merchantability, or fitness for a particular purpose. In no event will SYBEX, its distributors, or dealers be liable for direct, indirect, special, incidental, or consequential damages arising out of the use or inability to use the software even if advised of the possibility of such damage.

The exclusion of implied warranties is not permitted by some states. Therefore, the above exclusion may not apply to you. This warranty provides you with specific legal rights; there may be other rights that you may have that vary from state to state.

None of the programs on the CD is copy-protected. However, in all cases, reselling these programs without authorization is expressly forbidden.
For Erica, Reesa, and Sasha;
my inspiration, and muse.
I would like to extend my heartfelt thanks to the following people and companies for their support and help in this project:

## Contents at a Glance

<table>
<thead>
<tr>
<th>Introduction</th>
<th>xxv</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Getting Started</td>
<td>1</td>
</tr>
<tr>
<td>2 Music, Sound, and the Mac</td>
<td>27</td>
</tr>
<tr>
<td>3 Video and the Mac</td>
<td>65</td>
</tr>
<tr>
<td>4 Working with Digital Audio</td>
<td>111</td>
</tr>
<tr>
<td>5 Working with Audio from CDs</td>
<td>161</td>
</tr>
<tr>
<td>6 Working with MIDI</td>
<td>191</td>
</tr>
<tr>
<td>7 Music and Sound in Multimedia</td>
<td>229</td>
</tr>
<tr>
<td>8 Interactivity—The Key to Multimedia</td>
<td>267</td>
</tr>
<tr>
<td>A CD Contents</td>
<td>301</td>
</tr>
<tr>
<td>B Recommended Hardware and Software</td>
<td>323</td>
</tr>
<tr>
<td>C Media Tools Instructions</td>
<td>331</td>
</tr>
</tbody>
</table>

Index | 351
Contents

Introduction xxv

Chapter 1
Getting Started 1

System Requirements 1
  Hardware 2
  Software 2
Installation 3
  Installing the System Files 4
  Installing Media Tools 9
Part 1: Preparing HyperCard for Media Tools 12
Part 2: Installing Media Tools into HyperCard 14
Part 3: Enabling the Limited Version of HyperCard 2.1 17
Part 4: Setting the User Level to 5—Scripting 18
Using Media Tools 20
Installing the Multimedia Machine CD Interactive 20
Explorations
  If You Are Using MediaTools Runner 21
  If You Are Using HyperCard 21
Exploring Multimedia Machine with MediaTools Runner 22
Exploring Multimedia Machine with HyperCard 24
Using the Demo Software 24
Chapter 2  
Music, Sound, and the Mac  
27

The Role of Music in Multimedia  
Exploration 2.1: The Role of Music in Multimedia  
Using Sound on the Macintosh  
   Digital Audio  
   Exploration 2.2: Playing Digital Audio on the Mac  
   Audio from CD  
   Exploration 2.3: Playing Audio from CD
   MIDI  
   Exploration 2.4: Playing Back Sound from a MIDI Synthesizer  
   Exploration 2.5: Comparing the Three Sound Formats
A Closer Examination of Sound  
   Digital Audio  
   Exploration 2.6: Sampling Rates and Resolutions  
   Audio from CD  
   Exploration 2.7: Controlling an Audio CD  
   MIDI  
   Exploration 2.8: Changing Sounds on a MIDI Synthesizer
Review

Chapter 3  
Video and the Mac  
65

Using QuickTime  
   Exploration 3.1: Using MoviePlayer  
   Exploration 3.2: Using the Movie Tools
QuickTime Revealed  
   Capturing Video—the Digitizing Process  
   Saving Space—QuickTime Compression Schemes
Editing Movies

Exploration 3.3: Editing QuickTime Movies
Part 1: Setting In and Out Points
Part 2: Removing Unwanted Sections
Part 3: Combining Video Segments
Part 4: Adding Transitions
Part 5: Volume Envelopes
Part 6: Using Filters

Chapter 4

Working with Digital Audio

Using Sound Manager
Sound Manager
The Sound Control Panel
Exploration 4.1: Adding an Alert Sound and Setting the System Beep
Exploration 4.2: Setting the Input Device
Exploration 4.3: Setting the Output Device
Sound Playback
Exploration 4.4: Playing Back a Disk File with Audio Tools
Sound Recording
Exploration 4.5: Recording to RAM with Audio Tools
Exploration 4.6: Recording a Disk File with the Audio Tools
Editing Digital Audio
Exploration 4.7: Editing Digital Audio with TurboSynth
Synthesizing Sound
Exploration 4.8: Sound Design Concepts
Exploration 4.9: Understanding Modules and Patches
Exploration 4.10: Creating a Patch
Making System 7 Alert Sounds
Exploration 4.11: Converting a Sound to a System Beep
Chapter 5

**Working with Audio from CDs**

161

CD Audio as Music for Multimedia 161
Controlling the CD Player from HyperCard 162
   Using the CD Tools 162
   *Exploration 5.1: Working with the CD Tools* 162
Adding CD Audio to a Slide Show 168
   *Exploration 5.2: Synchronizing Slides to Music From CD* 168
Importing QuickTime Movie Soundtracks from Audio CDs 173
   *Exploration 5.3: Converting Audio CDs to QuickTime Soundtracks* 174
   *Exploration 5.4: Editing the Music as a QuickTime Movie In Premier* 179
   *Exploration 5.5: Converting QuickTime Soundtracks to AIFF Files* 182
   *Exploration 5.6: Playing the Converted AIFF from HyperCard* 186

Chapter 6

**Working with MIDI**

191

The Macintosh, MIDI, Music, and Multimedia 191
   *Exploration 6.1: Musicians on MIDI* 192
Configuring the System 193
   Direct MIDI Connections 194
   MIDI Manager 195
   Open MIDI System 198
   *Exploration 6.2: Synchronizing Slides with a MIDI Soundtrack* 198
Media Tools 202
   MIDI Recorder 202
Exploration 6.3: Recording a MIDI Sequence Using MIDI Tools
MIDIFile Player 202

Exploration 6.4: Playing and Editing a Standard MIDI File with MIDI Tools 204

MusicShop 211

Exploration 6.5: Playing and Editing a Standard MIDI File with MusicShop 211

Exploration 6.6: MIDI 'n' Synths 226

Chapter 7
Music and Sound in Multimedia
229

Aesthetics—The Motivational Aspects of Music 229

Exploration 7.1: Musical Choices 230

Elements of Music 231

Density 231

Instrumentation and Timbre 232

Tempo and Rhythm 232

Modality and Tonality 233

Contextual Reference 233

Macintosh Media Types 234

Text 234

Exploration 7.2: Using Text with Media Tools 235

Graphics 238

Exploration 7.3: Working with Graphics in Media Tools 240

Moving Pictures 246

Synchronization 247

Combining Media 248

Adding Music to Video in Adobe Premier 248

Exploration 7.4: Adding Music to Video 249

Combining Media with Media Tools 259
Chapter 8

Interactivity—The Key to Multimedia

267

What Is Interactivity? 267

Exploration 8.1: Interactive MIDI 268

HyperCard 269

Fields 269

Exploration 8.2: Working with Fields 269

Buttons 273

Exploration 8.3: Working with Buttons 274

Cards and Backgrounds 280

Exploration 8.4: Cards and Backgrounds 282

Authoring and Scripting in HyperCard 285

Exploration 8.5: Creating Links 285

Exploration 8.6: Buttons and Navigation 289

Other Multimedia Authoring Environments 297

Director 297

Passport Producer Pro 298

Appendix A

CD Contents

301

Software 301

Media Tools and MediaTools Runner 301

Adobe Premier Demo 302

Digidesign TurboSynth Demo 302

Opcode MusicShop Demo 303

SndConverter 303

MIDI 'n' Synths 303
Appendix B

**Recommended Hardware and Software**

323

Hardware
- Powered Speakers 323
- Audio Cards 324
- MIDI Synthesizers 325
- MIDI Sound Cards—Digidesign SampleCell II 326
- Video Digitizers 327

Software
- MIDI Sequencers 328
- Audio Editors 328
- Video Editors 329
- Multimedia Authoring 329

Appendix C

**Media Tools Instructions**

331

License Agreement 331

The Media Menu Commands
- Import ➤ EPS File 333
- Import ➤ Picture 333
- Import ➤ Text 334
- CD Tools 334
- MIDI Tools 336
- Audio Tools 339
- Movie Tools 343
- Preferences 344
<table>
<thead>
<tr>
<th>Command</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>ResCopy</td>
<td>345</td>
</tr>
<tr>
<td>Stack Tools</td>
<td>346</td>
</tr>
<tr>
<td>Card Tools</td>
<td>346</td>
</tr>
<tr>
<td>Object Lister</td>
<td>347</td>
</tr>
<tr>
<td>Mouse Locator</td>
<td>347</td>
</tr>
<tr>
<td>Rect Getter</td>
<td>348</td>
</tr>
<tr>
<td>Alignment Tools</td>
<td>348</td>
</tr>
<tr>
<td>Numbering Tools</td>
<td>350</td>
</tr>
<tr>
<td>Object Mover</td>
<td>350</td>
</tr>
</tbody>
</table>

Index 351
Foreword

I've been collaborating with musicians for the past four decades, helping them to use the latest electronic technology in their work. Together, we've addressed a very wide range of conceptual problems—from the “patch cord jungle” of the Moog modular synthesizers to the hundreds of functions neatly hidden behind the two-line display of the Kurzweil 250 digital sampling synthesizer. Through all these years, I've learned one universal truth: Explaining technical systems to musicians, videographers, and other artists, so they feel comfortable with them and can use them creatively, is an art in itself. The best user's guides are carefully and elegantly composed works, using just the right words and images to convey technical principles to artistic minds.

Dave Mash is at the top of my list of teacher/writers for his understanding of music/multimedia technology and his ability to explain it to his colleagues and students. I first met Dave about ten years ago at the Berklee College of Music. He was in charge of their music synthesis program, responsible for designing a full range of hands-on courses. His program has been very popular, with hundreds of students enrolling yearly. In fact, Berklee now has a music/multimedia lab with over 100 workstations—one of the largest in the world.

Dave has applied his teaching experience and his belief in the importance of hands-on learning to this book and CD-ROM. Multimedia technology involves many disciplines: Video, computer image processing, digital audio synthesis and recording, MIDI sequencing, synchronization, and—last but not least—interactive systems. In this book, Dave explains each of these and tells how they work on the Mac. Then, in the final chapters, Dave explains how the components are integrated to produce a multimedia work and to incorporate interactive elements.

The companion CD-ROM provides hands-on opportunities for learning by doing. It contains demo versions of some of the best music and video production software around, as well as Dave's own Media Tools extensions for HyperCard, and tutorial examples of MIDI sequences, digital audio files, and QuickTime movies. With this book and CD-ROM, you can learn and
practice everything you need to know to start multimedia production. The book guides you through the steps you need to take to produce your own multimedia works. The only hardware you need to start out with is a Mac and a CD-ROM player!

Perhaps the best aspect of Multimedia Machine is Dave Mash's friendly, informative style. Through this book and CD-ROM, you will have a skillful, sympathetic teacher explaining how the component technologies of multimedia work and providing you with opportunities to learn by doing.

Bob Moog
Introduction

An old Chinese proverb says "I hear and I forget. I see and I remember. I do and I understand." This is the fundamental principle behind the format of this book—you will learn by doing. The text will introduce and explain concepts, demystify buzz words, and define the myriad terms and acronyms used in multimedia. The accompanying CD-ROM contains many examples that form the basis of interactive exercises you should do at your computer. These exercises are the doing that will lead to understanding; and, while you will certainly benefit from reading the text by itself, real learning will come from performing the tasks while reading along.

The CD-ROM and Its Function in This Book

The examples included on the disk include digital movies, music and sound effects in a variety of formats, pictures, useful system extensions and utilities, and interactive exercises using software contained on the CD-ROM. This software includes a limited version of The Media Mashine's Media Tools for HyperCard, and demo versions of Adobe's Premier, Opcode Systems' MusicShop, and Digidesign's TurboSynth SC.

The Role of Music in Multimedia

Music is too often an overlooked component of multimedia. Color graphics, moving pictures, and animation are exciting media elements and are the focus of most multimedia authoring software. This book will help you understand the various ways to incorporate sound and music into multimedia, and give you practical examples and useful exercises to guide you and help you master sound and music on the Macintosh.
How This Book Is Organized

The book is divided into eight chapters and three appendices.

Chapter 1: Getting Started outlines the system requirements, both hardware and software, for running the multimedia CD and its programs. It also steps you through installation of the software. The installation is broken into two parts: one for those using just the MediaTools Runner software, the other for those with a full version of HyperCard. The chapter concludes with an exploration of the demo software included on the CD.

Chapter 2: Music, Sound, and the Mac explores sound on the Mac. You'll learn the difference between digital audio, CD audio, and MIDI by performing "explorations." You'll also find a detailed examination of the nature of sound, as well as a brief overview of MIDI.

Chapter 3: Video and the Mac covers the video capabilities of the Mac, focusing largely on QuickTime. You will also learn how to edit movies.

Chapter 4: Working with Digital Audio outlines the various Mac components for working with digital audio, including the Sound Manager and the Sound control panel. You will explore various input and output devices, and use the Audio Tools to do some recording and editing of digital audio. The chapter concludes with an overview of synthesizing sound.

Chapter 5: Working with Audio from CDs examines the role of CD audio in multimedia. You will learn to create a slide show with synchronized music, as well as convert and edit QuickTime and AIFF soundtracks.

Chapter 6: Working with MIDI is a full exploration of the power of MIDI in multimedia. You'll learn to configure your system properly, and you'll also get a chance to play and edit MIDI files with MIDI Tools and MusicShop.

Chapter 7: Music and Sound in Multimedia is a detailed examination of the role of music in multimedia. Musicians everywhere will find the discussion of the elements of music instructive.
and useful. Music concepts such as synchronization are explored both in theory and in practice.

**Chapter 8: Interactivity—The Key to Multimedia** is where you'll learn to put it all together. This chapter covers HyperCard in all its multiplicity as a multimedia authoring environment. There are also discussions of several other multimedia environments.

**Appendix A: CD Contents** is a detailed list of all the files, programs, sounds, etc. on the Multimedia Machine CD.

**Appendix B: Recommended Hardware and Software** lists other hardware and software you might wish to add to your multimedia panoply.

**Appendix C: Media Tools Instructions** provides an overview of the Media Tools software.

---

**Conventions**

I will use a number of conventions in the book that will help you to better understand certain procedures. They include the following:

- Text that you are to type will appear in bold as in "type **Multimedia** into the field."

- Menu commands will be provided with the menu name followed by ▶ then the command name. So, for example, if we say "choose File ▶ Save" it means to pull down the File menu and choose the Save command.

- Explorations, the exercises you will perform at the computer, will be indicated with this heading:

**EXPLORATION 2.1: THE ROLE OF MUSIC IN MULTIMEDIA**

I hope these conventions will make the book easier to follow, and more fun to read. So, let's get started!
Getting Started

I designed this book for you to read while performing the interactive exercises on the Multimedia Machine CD-ROM. I feel this hands-on approach will help you to learn about music, sound, and multimedia. In this chapter, we will install the Media Tools software, several demonstration versions (demos) of other software, and the necessary system files, getting familiar with the contents of the Multimedia Machine CD as we go along.

System Requirements

Multimedia demands a lot from your computer. Color graphics, digital audio, and video files take up a lot of hard disk space and need plenty of RAM (random-access memory) for temporary work space. Working with large files that are time-dependent (such as audio and video) can tax even the most powerful CPUs. Most newer Macs, however, have enough horsepower to run even the most demanding multimedia programs. Some of the explorations on the Multimedia Machine CD will need extra memory and disk space as well as specialized system software files, which are included on the compact disc. Now let's look at the minimum computer configurations you will need for exploring the Multimedia Machine CD.
Hardware

In order to run the exercises contained on the Multimedia Machine CD you need a Macintosh computer with hard disk, CD-ROM drive, and either a color or gray-scale monitor capable of displaying at least 256 colors or shades of gray. You will also need at least 4 MB of RAM in your Macintosh. The exercises that use the Adobe Premier software require a minimum of 8 MB of RAM. (Premier needs 4 MB for the software itself, and when you add the memory needed for the system software, allowing some extra memory for overhead, your Mac will need at least 8 MB of RAM.) You will also need at least 3.5 MB of available hard disk space, although it's preferable to have a total of 5.5 MB.

The speed of your Mac's processor, as well as that of your CD-ROM drive, will determine the performance level of the Multimedia Machine explorations and the multimedia software. While these exercises can be run on any color Mac, from the LC on up, newer, faster Macs will deliver better performance: videos will run more smoothly, audio may sound better, and color pictures and other large files will open more quickly. Newer CD-ROM drives run at two or even three times the speed as the first Apple CD-ROM SC drives, allowing for faster data transfer from disk and giving better performance. The rule of thumb for working with multimedia is you can never have too fast a computer, too much RAM, or a too big of a hard drive!

Software

You should be running System 7 or later on your Mac to ensure that all the files and software on the Multimedia Machine CD work properly. The Multimedia Machine CD also contains a number of system extensions. In order for you to use the digital audio and video files and related multimedia software programs on the CD, these extensions must be installed on your computer's hard drive. The CD also contains multimedia software and software demos that are used in hands-on exercises (called Explorations) throughout the book.

If you experience any conflicts due to system extensions or control panels, try disabling other extensions while performing the exercises in this book.
Many of these explorations are based on Apple Computer's HyperCard software, augmented with Media Tools from the Media Machine. HyperCard was originally written by Bill Atkinson and released by Apple Computer at the MacWorld Expo in August 1987. For many years, HyperCard was included free with every Macintosh computer. In fact, HyperCard was so important to Apple's vision of the "computer for the rest of us" that Apple management once joked that HyperCard was professionally priced software (at $2000) that came with a free Mac!

HyperCard is a powerful yet simple environment for assembling multimedia projects. The assembly process is often called authoring. Using a building-block technique, HyperCard allows you to organize data (including pictures, text, movies, and sounds) and control how that information is displayed and accessed. Modeled after the familiar Rolodex, HyperCard orders information into cards, which are in turn ordered into stacks. Files are then stored as collections of information called stacks, and may often appear to the user as complete applications.

Media Tools provides a set of enhancements to Apple's HyperCard software, simplifying the integration of various media files into a complete production. The tools allow you to combine music, sound, pictures, text, and movies into HyperCard projects in a simple, intuitive manner. If you don't own a copy of HyperCard version 2.1 or higher, you may use the MediaTools Runner software included on the Multimedia Machine CD. This software will allow you to run the various explorations that use HyperCard, even if you don't have the actual HyperCard software on your disk.

It is better, though, to use the complete version of HyperCard, since it has additional production tools and is easier to use. If you plan to continue working with interactive multimedia projects beyond the scope of this book, I strongly suggest you purchase the complete HyperCard Developer's Package, available through most mail order houses for about $100.

Now that you understand the basic hardware and software requirements, let's start installing.

Installation

Let's begin by installing the software on your hard disk. If you have limited disk space, you may install just the system files and the Media Tools
software, as these are the foundation for most of the interactive exercises in the book. If you don't have the supplied system files installed in your system folder, and don't have HyperCard already on your hard disk, you will need approximately 5 MB of available storage space. If you have limited disk space, you might choose to copy the example files chapter by chapter only as you need them. This technique will save you almost 2 MB, but makes the installation more complicated.

There are a lot of other files and programs on the CD than the ones we'll be installing here. For instance, there are software demos that would take up a lot of space on your hard drive if you installed all of them at once. You might decide instead to run these software demos directly from the CD-ROM or copy them to your hard drive only when needed. This way, you can make the best use of your available hard disk space. For the best bang for your buck, please follow along and perform all exercises in the book. Remember, we learn best by doing, and the exercises make learning more fun.

### Installing the System Files

You can enhance the Macintosh operating system with files called *system extensions*. Many multimedia programs need these files to run properly. The Multimedia Machine CD includes a number of *extensions* and *control panels* as well as special files called *device drivers* and *desk accessories*, all of which will help in assembling your multimedia projects. You install these extensions, control panels, desk accessories, and other files into your system by dragging them into your closed System Folder.

**WARNING**

Be sure that your System Folder is closed before starting. It must be closed in order for the system to place the files in their proper locations.

Follow these simple steps:

1. Insert the Multimedia Machine CD into the CD-ROM drive.
2. Double-click on the CD disk icon to open its window.
3. Open the System Extras folder on the CD-ROM by double-clicking on its icon in the Multimedia Machine CD window. See Figure 1.1.
A convention we will use in this book is to indicate menu commands with menu name ➤ command. So, for example, if we say "choose File ➤ Save" it means to pull down the File menu and choose the Save command.

4. Open the Extensions folder by double-clicking its icon in the System Extras folder.

5. Choose Edit ➤ Select All (⌘-A).
Another convention we will use in this book is to show the **command key shortcuts** (sometimes called **hot-key combinations**) for menu commands. The notation we will use is `⌘-key`, where `⌘` is the command key on your Mac and `key` is the letter you press in conjunction with the command key. This means, simply, hold down `⌘` and press the indicated letter. Macintosh convention is to use uppercase letters, as in `⌘-A`, since the letters are uppercase on the keyboard. You don’t have to press Shift when using these key combinations. In fact, pressing Shift will often perform an entirely different command. If we do want you to press another key (such as Shift or Option), we will say so explicitly, as in “press `⌘-Shift-6`.”

6. Drag all the files into the System Folder (remember, it must be closed) on your *hard disk*, as shown in Figure 1.2.

7. Click OK when you see the prompt asking if you want to store the files in the appropriate locations.

8. Close the Extensions folder.

Now let’s install the control panel files. To do so, follow these steps:

1. Open the Control Panels folder on the CD-ROM by double-clicking its icon, found in the System Extras window (it should still be open from the previous steps).

2. Choose Edit ➤ Select All.

3. Drag the file into the System Folder (remember, it must be closed) on your *hard disk*.

4. Click OK when you see the prompt asking if you want to store the files in the appropriate locations.

5. Close the Control Panels folder.
FIGURE 1.2: Drag the files from the Extensions folder on the CD-ROM into the System Folder on your hard disk.

Finally, we'll complete the installation of system files by dragging the remainder of the files to the System Folder.

1. Drag the Vision keyboard layout file and the Sonata font file into the System Folder (remember, it must be closed) on your hard disk.

2. Click OK when you see the prompt asking if you want to store the files in the appropriate locations.

3. If you have an audio card from Digidesign, such as one of the Audio-media or Sound Accelerator families, open the Digidesign Extensions folder and choose Edit > Select All. Drag all the files into the System Folder (remember, it must be closed) on your hard disk, then click OK when you see the prompt asking if you want to store the files in the appropriate locations. Close the Digidesign Extensions folder.
4. Close the System Extras folder on the Multimedia Machine CD.

You've now successfully installed all the necessary system files for exploring Multimedia Machine. For those of you who want to know exactly what files we've added and where they are stored, the following list summarizes these files and their proper locations:

<table>
<thead>
<tr>
<th>File</th>
<th>Size</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apple CD Extension</td>
<td>30K</td>
<td>Extensions folder within the System Folder</td>
</tr>
<tr>
<td>Foreign File Access</td>
<td>40K</td>
<td>Extensions folder within the System Folder</td>
</tr>
<tr>
<td>Audio CD Access</td>
<td>10K</td>
<td>Extensions folder within the System Folder</td>
</tr>
<tr>
<td>High Sierra Access</td>
<td>20K</td>
<td>Extensions folder within the System Folder</td>
</tr>
<tr>
<td>ISO 9660 Access</td>
<td>20K</td>
<td>Extensions folder within the System Folder</td>
</tr>
<tr>
<td>Sound Manager</td>
<td>80K</td>
<td>Extensions folder within the System Folder</td>
</tr>
<tr>
<td>QuickTime</td>
<td>830K</td>
<td>Extensions folder within the System Folder</td>
</tr>
<tr>
<td>Sound</td>
<td>50K</td>
<td>Control Panels folder within the System Folder</td>
</tr>
<tr>
<td>Vision keyboard layout</td>
<td>10K</td>
<td>System file</td>
</tr>
<tr>
<td>Sonata font</td>
<td>160K</td>
<td>System file</td>
</tr>
<tr>
<td>Digidesign Sound Drivers</td>
<td>70K</td>
<td>Extensions folder within the System Folder</td>
</tr>
<tr>
<td>Digisystem INIT</td>
<td>40K</td>
<td>Extensions folder within the System Folder</td>
</tr>
</tbody>
</table>
Before continuing, restart your computer to load the new system extensions.

**Installing Media Tools**

On the compact disc, you will find a limited version of Media Tools for HyperCard from the Media Machine. This software is needed to run most of the Multimedia Machine explorations. If you have HyperCard 2.1 or later, Media Tools will be a valued addition to your multimedia work, even beyond the context of this book. In order to use the Media Tools software, you will need either HyperCard or MediaTools Runner installed on your hard disk. MediaTools Runner was created with HyperCard 2.2 as a “stand-alone” application for you to use in the explorations in this book. It contains the HyperCard “engine” and can run the explorations as if it were HyperCard. It has certain limitations—for instance, you can’t create or save HyperCard files—but is fine for this book, since you can use it in the Multimedia Machine explorations.

From here on out, the installation instructions are divided into two sections: one for those of you who will be using the MediaTools Runner software; the other for those of you using your own copy of HyperCard.

**If You Will Be Using MediaTools Runner**

To install Media Tools using MediaTools Runner, follow these simple steps:

1. Create a new folder on your hard drive by opening the folder where you want it to go and choosing File > New Folder (⌘-N). Name it **Multimedia Files**.

2. Drag the MediaTools Runner icon and Media Tools folder from the Multimedia Machine CD into the Multimedia Files folder on your hard drive.

3. Double-click on the hard-drive copy of the MediaTools Runner icon to launch the software. A standard file dialog box appears and asks you “Where is Toolkit?”
4. Use standard Macintosh file navigation to locate the Toolkit file. It is in the Media Tools folder inside your Multimedia Files folder on your hard drive. Figure 1.3 shows the hierarchical location of the Toolkit file in the dialog box. Select Toolkit and click on the Open button or just double-click on the file.

![Figure 1.3: The location of the Toolkit file](image)

5. Another standard file dialog box will appear and ask “Where is Toolkit Resources?” It is inside the Toolkit Files folder within the Media Tools folder inside your Multimedia Files folder on your hard drive. The location of the Toolkit Resources file is shown in Figure 1.4.

Select Toolkit Resources and click on the Open button or just double-click on the file. Media Tools is now installed on your hard disk. MediaTools Runner will remember the location of these files for future startups and won’t ask you to locate them again.

If You Will Be Using HyperCard

Be careful not to confuse HyperCard with HyperCard Player, a limited version of the program that Apple distributed for a short time.

If you have HyperCard version 2.1 or later, you may install Media Tools into your HyperCard Home stack using the following steps.

Although fully compatible with HyperCard 2.2, Media Tools requires at least HyperCard version 2.1 to work.
Getting Started

Part 1: Preparing HyperCard for Media Tools

To prepare HyperCard to use the Media Tools software, follow these steps.

1. Be certain that HyperCard and the Home stack are already installed on your hard drive. It is helpful, but not essential, to put them in a folder called HyperCard Folder.

HyperCard uses a special stack called Home to store user preferences and other information necessary for the proper operation of HyperCard. This Home stack should always be stored in the same folder as the HyperCard application. Media Tools will make several changes to the Home stack to allow HyperCard to access the new features it provides.

2. Media Tools requires that the amount of allocated memory for HyperCard be set to at least 2 MB. You set the amount of memory by clicking once on the HyperCard application icon (in the Finder) and then choosing File ➤ Get Info (⌘-I). You should then see the window shown in Figure 1.5.

3. Click in the text field labeled "Preferred size:" and type 2048. This will set the memory partition to 2 MB.

4. Click in the close box to put away the Get Info window and set the memory partition.

5. Insert the Multimedia Machine CD disc into your CD-ROM drive and locate the Media Tools folder.

6. Drag the Media Tools folder onto your hard drive into the same hierarchical location as HyperCard and your Home stack. This means that if, for example, you've HyperCard and Home in a folder called HyperCard Folder (as recommended above), your files should be organized as shown in Figure 1.6, which is in Icon view.
Correct placement of Media Tools on your hard disk is essential to its successful operation. Be sure you install the files in the right place, using Figure 1.6 above as a guide. If you dragged the folder to your hard drive as described above, all of the Media Tools files will be in the right place. Don’t rename any of these files, though, or Media Tools won’t work properly.
Part 2: Installing Media Tools into HyperCard

To install Media Tools into HyperCard, follow these steps:

1. After installing the folder onto your hard drive, open the Media Tools folder and launch the Toolkit stack by double-clicking on its icon.

2. After HyperCard has finished launching, you will see the splash screen shown in Figure 1.7, telling you about Media Tools. Click on the OK button to proceed.

3. Click on the Install Toolkit button, as shown in Figure 1.8.

4. A standard open file dialog box appears. Find your Home stack and click the Open button. Media Tools will now be installed into your Home stack, which takes a few moments. Media Tools gives you progress reports as it goes through the installation. The tools install some external commands and functions as well as a few lines of script so the complete set of tools will be available as long as the Media Tools folder remains on your disk.
Use the "Install Toolkit" button to install the tools into your Home stack. This process will install several key resources and add a few lines of script to Home. The following files must be in the "Media Tools" folder at the same hierarchy level as Hypercard and Home: Toolkit and the Toolkit Files Folder containing: Toolkit Resources, Media Resources, Additional Resources, and Toolkit Help.

Media Tools is ©1993 by David S. Mash.

**Special Thanks to:**
Apple Computer for their support of this project and to:
Richard Boulanger, Joe Zobkiw, Tony Marvuglio, Andrew Calvo, and Scott McCormick for their valuable help and input!

<table>
<thead>
<tr>
<th>XCMDs</th>
<th>RecordToRAM, RecordToDisk, and PlayFromDisk by Joe Zobkiw</th>
</tr>
</thead>
<tbody>
<tr>
<td>XFCNs</td>
<td>MIDplay 2.0 by Opcode Systems</td>
</tr>
<tr>
<td>by:</td>
<td>HyperMIDI 1.11 by Ear Level Engineering</td>
</tr>
</tbody>
</table>

**FIGURE 1.7:** The splash screen for Media Tools

5. You will be prompted to quit HyperCard in order to activate the tools. Restart HyperCard by double-clicking the HyperCard application icon. As HyperCard restarts, it will ask you to locate the Toolkit.

6. Using the Macintosh open file dialog box, navigate to the Toolkit stack; it is inside the Media Tools folder.

7. Select the Toolkit stack and click on the Open button. You will then be asked to locate Toolkit Resources.

8. Locate the Toolkit Resources stack, which can be found in the Toolkit Files folder.

9. Select the Toolkit Resources stack and click on the Open button. HyperCard will finish starting up and load the Media Tools.
Getting Started

This toolkit contains resources to enhance your "Home" stack, so that the tools provided within this stack are available in any stack you use. This toolkit is designed to augment the standard HyperCard tools for media integration. You will need the following stacks in a folder entitled "Media Tools" in the same folder as Hypercard and Home: "Toolkit" and "Toolkit Files", a folder which should contain the stacks "Toolkit Resources", "Media Resources", "Additional Resources" and "Toolkit Help".

FIGURE 1.8: The Media Tools card showing the Install Toolkit button

HyperCard will remember the locations of these files for future startups, and will no longer ask you to locate these files. From this point on, Media Tools will always load automatically whenever HyperCard is launched.

You are now ready to use Media Tools. You will never need to open the Toolkit or any of the other stacks in the Media Tools folder again. Their features and functions will always be available from any stack, as long as they are installed on your hard drive.
If you're using the version of HyperCard 2.1 that came with your computer, you may have a disabled version. If you don't have HyperCard 2.2 or aren't sure if you've the full version of HyperCard 2.1, follow the next few steps, otherwise you may skip to "Part 4: Setting the User Level to Scripting."

**Part 3: Enabling the Limited Version of HyperCard 2.1**

If you're using the version of HyperCard 2.1 that came with your computer, you may have a disabled version. Follow these steps to enable it.

1. If you've just completed step 9 above, you should be at the Home card. If not, select Go ➤ Home (⌘-H).

   A very important and handy key combination to remember is ⌘-H. This is the same as choosing Go ➤ Home, and can get you out of a lot of trouble. Use this command either when you're lost or when you want to get back to a starting point.

2. Press the left-arrow key on your keyboard (←) to get to the Home Preferences card. If it looks like Figure 1.9, then you've the disabled version and need to perform the following conversion process.

3. With the Preferences card showing on screen, select Go ➤ Message (⌘-M).

4. Type the word **magic** and press Return. Magically, levels three through five will appear, allowing you access to HyperCard's Authoring and Scripting levels.

Now that you've uncovered the hidden levels, go on to the next section to set the user level to scripting, level 5.
FIGURE 1.9: The Preferences card of the disabled HyperCard version

Part 4: Setting the User Level to 5—Scripting

HyperCard offers the user five levels of use:

1 Browsing Allows you to explore existing stacks and navigate through existing buttons, but doesn't allow changes.

2 Typing Allows you to enter text into fields in addition to browsing.

3 Painting Adds the painting tools, which will let you alter the appearance of cards in a stack as well as type and browse.

4 Authoring Allows you to create buttons and fields, paint, type, and browse. Much multimedia design work can be produced at this level.
5 Scripting  This is the most advanced level; it lets you perform all of the above functions with the added ability of writing scripts, which control the actions of buttons and other objects.

Now let's set the user preferences that will support our work with multimedia:

1. Choose level 5 by clicking on the large number 5.
2. Click in the Blind Typing and Power Keys check boxes to enable them and to complete the transformation. Your completed Preferences card should now look like Figure 1.10.

---

**FIGURE 1.10:** The completed Preferences card

The Blind Typing option allows you to type commands into HyperCard without opening the Message Box window. This isn't essential for use in these exercises, but will be helpful as you progress as a HyperCard user. The Power Keys option allows certain key combinations to be used to simplify tasks.
Again, this isn't essential for our work here, but won't detract from your efforts either. It will be of value to you in your future work, so we will set these options now. The Arrow Keys in Text option allows you to use the left and right arrows (← and →) to move the cursor in text fields. Since this disables the arrow keys from standard HyperCard navigation, we will leave the box unchecked.

**Using Media Tools**

Media Tools adds a new menu called Media to HyperCard's menu bar. This menu contains the media tools we will use in the book including digital audio, text, pictures, movies, and also controls audio from the CD. This limited version of Media Tools can be upgraded to the complete version, which adds another menu called Utilities and provides additional tools for HyperCard-based multimedia authoring. Upgrade information is included in Appendix C and an upgrade order form is included in the Media Tools Manual file on the Multimedia Machine CD.

**Installing the Multimedia Machine CD Interactive Explorations**

The Multimedia Machine CD contains a series of exercises called *explorations* to give you hands-on training with the concepts explored in the text. You must put these exploration files on your hard drive or they won't work. Again, the instructions for installing are divided into two sections: one for using MediaTools Runner to install the explorations and the other for using HyperCard.
If You Are Using MediaTools Runner

If you’re using MediaTools runner to install the explorations, follow these steps:

1. Drag the Explorations folder (this will ensure that all of its contents will be copied) from the Multimedia Machine CD into the Multimedia Files folder on your hard drive.

2. Check to be sure you have three folders in the Multimedia Files folder on your hard disk: MediaTools Runner, Media Tools, and Explorations.

If you don’t have the required 2 MB of disk space for these files, you may instead follow these steps.

1. Create a new folder in the Multimedia Files folder on your hard drive. Do this by going to the Finder, opening the Multimedia Files folder, and choosing File ➤ New Folder (⌘-N).

2. Name this new folder Explorations.

3. Drag the Ch.2 Music and Sound folder from the Multimedia Machine CD into this Explorations folder on your hard drive.

4. When you’ve finished performing all the explorations in Chapter 2, drag the Ch.2 Music and Sound folder from your hard drive into the trash. This will free up space for the next set of explorations.

5. Repeat steps 3 and 4 as needed for each chapter in the book.

If You Are Using HyperCard

If you’re using HyperCard to run the explorations, follow these steps:

1. Drag the entire Explorations folder (this will ensure that all of its contents will be copied) from the Multimedia Machine CD into the HyperCard Folder on your hard drive.
2. Check to be sure you have four items in this HyperCard Folder: HyperCard, your Home stack, the Media Tools folder, and the Explorations folder.

**NOTE**

If you don't have the required 2 MB of disk space for these files, you may instead follow these steps.

1. Create a new folder in the HyperCard Folder on your hard drive. Do this by going to the Finder, opening the HyperCard Folder, and choosing File > New Folder (⌘-N).

2. Name this new folder **Explorations**.

3. Drag the Ch.2 Music and Sound folder from the Multimedia Machine CD into this Explorations folder on your hard drive.

4. When you've finished performing all the explorations in Chapter 2, drag the Ch.2 Music and Sound folder from your hard drive into the trash. This will free up space for the next set of explorations.

5. Repeat steps 3 and 4 as needed for each chapter in the book.

**TIP**

Placing the exploration files on your hard drive will make the interactive exercises run faster. In addition, many of the exercises create objects that must be written to disk; this is impossible if the explorations are running from the CD since the Multimedia Machine CD is read-only (CD-ROM).

**Exploring Multimedia Machine with MediaTools Runner**

As the MediaTools Runner software runs the Multimedia Machine explorations, you will always start from the Runner card. The following steps explain how to use MediaTools Runner to open the Multimedia Machine Explorations. The files and folders you will need are in the Multimedia Files folder, shown in Figure 1.11.
1. Double-click the MediaTools Runner icon to launch the application. You should see the Runner card as shown in Figure 1.12.

2. Each chapter has a popup menu that lists its explorations. (Not every exploration uses Media Tools, so only those that do are in the popup menu.) Click and hold the mouse button down on the Chapter 2 menu. You will see the list of available explorations for Chapter 2, as shown in Figure 1.13.

3. Release the mouse button while pointing to Exploration 2.1 Music in Multimedia to open that exercise file.

4. Choose Go > Home (⌘-H) to return to the Runner card.
Exploring Multimedia Machine with HyperCard

Unlike MediaTools Runner, HyperCard is a general-purpose Macintosh application. Like most Mac programs, you can either open the files from within the program or open the program by double-clicking on the exploration files in the Finder. If you want to open the files from within HyperCard, choose File ➤ Open (⌘-O) and select the desired exploration. You can move directly from one exploration to the next or return to the Home stack between explorations.

Using the Demo Software

Also included on the CD-ROM are demo versions of Adobe Premier (a powerful video recording and editing environment) Opcode Systems' MusicShop (an excellent MIDI recording and editing software package), and
Digidesign's TurboSynth SC (intuitive software for recording, editing, and processing digital audio). These packages will be used to perform various tasks and exercises throughout the book. All of these demo programs give you access to most of the functions of the full programs, but don't allow you to save files. For our purposes, however, these demo programs will allow you to get a sense of how the tools work, learn about the primary issues of multimedia development, and get some hands-on experience with music and sound in multimedia. As mentioned earlier, you may run the demo software either directly from the CD-ROM or copy it to your hard drive (where it will run faster). Information about how to obtain the full versions of these demo software programs is found in Appendix A.

Also included on the CD-ROM are system alert sounds, music files, video files, interactive study files not referenced directly by the text but related to our studies, and productivity tools to help make your multimedia work more smooth. A complete listing of all the files and their uses can be found in Appendix A.
If you've successfully completed the installations listed in this chapter, you're ready to proceed with the remaining chapters of the book. Remember that you'll get the most out of this book if you follow along and perform all of the explorations at your computer. The fun is in the doing, so let's get started...
Music, Sound, and the Mac

The Macintosh was built for sound. Even the earliest 128K Mac had an internal speaker and speaker output jack. Today's more powerful Macintosh computers, like the Quadra family, can produce high quality stereo sound and have built-in sound recording (input) and playback (output) capabilities. This chapter introduces basic issues of audio, examining the many ways of creating and playing music and sound with the Macintosh.

The Role of Music in Multimedia

Before we begin exploring sound, let's do a short exercise to help us understand the importance of music in multimedia. From now on, I will assume that you've loaded the Media Tools software and have either MediaTools Runner or your own copy of HyperCard on your hard drive. If necessary, refer to Chapter 1 for installation instructions.
EXPLORATION 2.1: THE ROLE OF MUSIC IN MULTIMEDIA

In this exercise, we will explore how sound and music can underscore the inherent emotional quality of visuals. We will view a QuickTime movie, first without any audio, then with the musical score. This exercise will also help you become familiar with playing back and controlling digital video.

1. Open the exercise called 2.1 Music in Multimedia using the techniques learned in Chapter 1. Choose the appropriate method for the software you’re using.

2. Click on the button called Play Mute Movie. The movie María Lionza by Hector Mendez Caratini will begin. Watch the movie and see if you can tell what the video is about. Figure 2.1 illustrates how your screen should look.

FIGURE 2.1: Playing the mute movie
Click on the question mark icon to read information about the movie.

3. Click on the Stop Mute Movie button to stop it from playing.
4. Now click on the Play Complete Movie button to watch the movie again, this time with sound. The experience is totally different. The music sets the mood, one of mystery—almost ominous.

In the second example, the standard QuickTime movie controller is present under the movie window (see Figure 2.2). Use this controller to start and stop playback, scroll through the movie, step one frame at a time in either direction, and control the volume of the sound. We will experiment with the controller to get a feel for navigating around a QuickTime movie.

5. The speaker icon controls the sound level. Click and hold the mouse button down on the speaker icon to pop up the level controller. Slide it up and down to set the volume.
6. The play/pause button is directly to the right of the speaker icon. Each mouse click toggles it between playback and pause modes.
7. The horizontal slider under the movie window is a location control; you can drag it in either direction to advance or return to any frame.
8. The last two buttons are frame forward and backwards; each button steps in the appropriate direction by a single frame. These are used to locate a specific point in the video.

We often refer to these controllers as transport controls because they emulate the analogous functions of video or audio tape transport controls.
Now with sound and music, the mood is set as somewhat mysterious, perhaps even a bit ominous. While the movie is playing, you may control the sound level by clicking and dragging on the speaker icon...

**FIGURE 2.2:** Playing the complete movie—and using the controller

Now that you’ve had a chance to see the impact of music and sound in multimedia, let’s look at the various ways we can use sound on the Macintosh.

**Using Sound on the Macintosh**

There are basically three ways that we can use sound on the Mac—digital audio, audio from CD, and through control of a MIDI synth. In this chapter you’ll learn about each of these approaches, studying each in more detail in later chapters.

**Digital Audio**

All Macintosh computers can play sound right out of the box—a fact that seems so obvious that we forget how rare this is in the PC world. One of the first things people do when personalizing their Macs is to choose their
system alert sound (*beep*). SoundMaster, a popular shareware program, allows users to set specific sounds for various functions of the Mac. By using such software, the acts of inserting or ejecting disks, starting up, and shutting down can each have their own sounds. I've provided a number of system alert sounds for you to play with, when the time comes. These are located in the System Beeps folder at the root level of the Multimedia Machine CD (see Figure 2.3).

These are System 7-style sounds that can be played directly from the Finder by double-clicking their icons. We will examine these in greater detail later, and learn how to create our own sounds and convert them into System 7 alerts. For now, why not take a few moments to enjoy these sounds by double-clicking on each one.

![Multimedia CD](image)

**FIGURE 2.3:** Double-click these icons to listen to the system alert sounds
Music, Sound, and the Mac

While many of us delight in playing with system alerts and performing other minor customizing of our Macs, most of us never go any further in exploring sound possibilities. Let’s do a brief exercise to see how we can play back a full piece of music using just the internal Mac speaker.

**EXPLORATION 2.2: PLAYING DIGITAL AUDIO ON THE MAC**

In this exercise, we will play back sound from HyperCard. HyperCard provides an intuitive but powerful environment for multimedia work, and we will use it for many of our explorations.

1. Locate and open the exercise 2.2 Digital Audio, found in the Ch. 2 Music and Sound folder in the Explorations folder.

2. Click on the Play Audio button. If you want to stop the music before it’s finished, just click the Play Audio button again.

```
Click the question mark icon to read more about the music you’re hearing. A very important and handy key combination to remember is ⌘-H. This is the same as choosing Go ➤ Home, and can get you out of a lot of trouble. Use this command either when you’re either lost or when you want to get back to a starting point.
```

The sound in this example was recorded or sampled into the Macintosh, then stored on disk as a stream of numbers (zeros and ones), hence the term digital. The file of this music (often called a sound file) is on the Multimedia Machine CD. We are able to play such a long file because it is playing back directly from disk.

```
Computers store information either temporarily in random access memory (RAM) or more permanently to some form of storage media, such as a magnetic disk. The temporary work space, RAM, is much smaller and more expensive than the storage space; furthermore it’s shared between the system software, applications, and data. Since this space is limited, RAM can hold only very small amounts of data, meaning we can record only very short snippets of music. It’s therefore better to record to the hard disk, where we can store longer selections of music.
```
Recording sound straight onto disk is sometimes called *direct-to-disk* audio. You can record and play back sounds of any length with this technique, limited only by disk space. This particular example takes over 7 MB of disk space. Look inside the AIFFs folder, found in the Music folder on the Multimedia Machine CD, to find the Darker Shade of Gray.22K file. Click on the file, then choose File ➤ Get Info (in the Finder) to see how much disk space the file uses. To play this sound from RAM, you would need at least 12 MB of memory in your computer (12 MB because: 7.5 for the sound + 2 for HyperCard + 2.5 for the system = 12 MB total).

While all Macs play sound, you can get additional hardware to improve the Mac’s digital audio capabilities. These enhancements range in sophistication from adding simple external speakers to installing advanced sound playback cards. Here is a list of the most popular audio add-on equipment for the Mac:

**Speakers** External speakers plug directly into the sound output port on the back of the Macintosh, bypassing the small single internal speaker. External speakers are usually self-amplified and are optimized for the computer’s digital audio. The AppleDesign powered stereo speakers are an example of external speakers. These are also specially shielded to avoid magnetic interference with the computer monitor.

**Sound Input Devices** If your Mac doesn’t have built-in audio input, you can add a low cost digitizer, such as the MacRecorder from MacroMedia. The MacRecorder has a small, built-in microphone as well as an input jack that will accept audio signals from devices like tape decks, CD players, and stereo systems. The microphone and input jack are optimized for low-quality monophonic recording, such as speech, but can be used for music when high fidelity reproduction isn’t important. We’ll explore the issue of audio fidelity in more depth later in this chapter.

**High Quality Audio Cards** These cards provide you with the facility to record and play back digital audio with CD fidelity. A popular choice is Audiomedia II from Digidesign, which offers stereo recording and playback with CD quality sound, including both analog and digital inputs and outputs.
Perhaps the most common way to improve the sound of your Mac is to connect external speakers to the computer or connect the Mac to a stereo system. In order to do either, you must understand the basic hardware of connecting audio—jacks, plugs, cables, and adapters. **Jacks** are the receptacle connectors where you insert **plugs**. Jacks and plugs are often referred to as **female** and **male** connectors. **Cables** are the wires that carry signals; they usually have either plugs or jacks at each end. **Adapters** are devices that allow jacks and plugs of differing configurations to be used together without the need for specialized cables (although such cables do exist). Adapters usually have a jack on one end and a plug of a different size and shape at the other. In general, most devices (stereos, computers, etc.) have jacks on their panels for both input and output, and cables with plugs at both ends are used to make connections between devices.

All Macs have 1/8th inch connectors called **mini phone jacks** for audio hookup. Macs with stereo capability use three-conductor jacks, mono Macs use two-conductor jacks. If the sound system you wish to connect to is stereo and uses **standard phono jacks** (often called **RCA jacks**), you will need to purchase adapters to make the connections. Figure 2.4 shows common plugs and adapters for connecting the Mac to speakers or stereos.

Figure 2.5 shows complete solutions for the two most common Macintosh sound connections: Mac to powered (amplified) speakers and Mac to stereo system.

While internal sound cards are a fact of life for PC users, most Mac users don’t feel the need to add them, because of the built-in sound capabilities of all Macs. However, you can get much higher quality audio output by installing a sound card.

**WARNING**

Most sound cards can be inserted in the Mac’s **NuBus slot**. Compact Macs (such as Classics and LCs) don’t have NuBus slots, but they usually have Processor Direct Slots (PDS). There are cards designed for this slot as well, so you must determine what type of expansion card your computer takes before buying a digital audio card. Refer to your Macintosh owner’s guide to determine what type of expansion slot your computer has.
<table>
<thead>
<tr>
<th>Connector Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MONO 1/8&quot; phone plug</td>
<td>Hot and ground connections. Used to adapt RCA phono plug to insert into MAC</td>
</tr>
<tr>
<td>MINI phone jack to RCA phono plug</td>
<td>Used to adapt 1/8&quot; MINI phone plug to connect to stereo equipment</td>
</tr>
<tr>
<td>STEREO 1/8&quot; phone plug</td>
<td>Right, left, and ground connections. &quot;Y&quot; adapter used to connect mono output of MAC into both inputs of stereo equipment</td>
</tr>
<tr>
<td>MONO 1/8&quot; phone plug to (2) RCA phono plugs</td>
<td>'Y' adapter used to connect stereo MAC to stereo equipment</td>
</tr>
<tr>
<td>RCA phone plug</td>
<td>Hot, left, and ground connections. &quot;Y&quot; adapter used to connect mono output of MAC into both inputs of stereo equipment</td>
</tr>
<tr>
<td>RCA phone jack</td>
<td>Left and right connections. &quot;Y&quot; adapter used to connect stereo MAC to stereo equipment</td>
</tr>
<tr>
<td>RCA phono jack to 1/8&quot; MINI phone plug</td>
<td>Used to adapt RCA phono plug to insert into MAC</td>
</tr>
</tbody>
</table>

**FIGURE 2.4:** Common audio jacks, plugs, and adapters
Audio from CD

You already have a CD-ROM drive attached to your Macintosh, which you can use to play audio compact discs as well. CD audio is the industry standard for high quality digital sound. By connecting the audio outputs
from your CD-ROM to a stereo speaker system, you can easily use CD audio for multimedia projects. Figure 2.6 shows the common connections for CD-ROM audio.

**FIGURE 2.6:** Connecting your CD-ROM's audio
The Multimedia Machine CD-ROM is a *mixed mode* disk, which means it has both computer data as well as CD audio tracks. You can access the data with your computer as if the CD were a large (but slow) hard drive; you can play the audio tracks either from your CD-ROM drive or by playing the Multimedia Machine CD on a standard audio CD player. Let’s do a short exercise to explore how to play back music from the CD-ROM drive.

Do not attempt to play track 1 of the Multimedia Machine CD, because the data may be played as full volume noise, which can damage your stereo system.

**EXPLORATION 2.3: PLAYING AUDIO FROM CD**

In this exercise, we will use HyperCard to play back sound and control the CD-ROM drive.

1. Open the exercise stack called 2.3 Play CD, using the techniques learned in Chapter 1.

Click on the question mark icon for information about the music.

2. Click on the Play CD button.

This is the same music you heard in the previous example, but it sounds much better. The reason CD audio is of higher quality than the audio you normally get from the Mac will become clear as we continue to delve deeper into digital audio.

**MIDI**

*MIDI* is an acronym for the *Musical Instrument Digital Interface*. By connecting your Macintosh to a MIDI synth, you can access the high quality sounds stored in the instrument’s memory. Since MIDI information contains only the instructions for playback, rather than the sound data itself, MIDI data takes up relatively little space on your disk. For example, a four-minute song stored in CD quality audio takes up 40 MB of disk space; the
same piece saved as MIDI information uses only 70K! Thus, by making a relatively small investment in the MIDI sound module, you can get high quality sound without the high data-storage overhead normally associated with CD quality audio.

If you have a MIDI synth, you can connect it as shown in Figure 2.7, or according to its user's manual.

Assuming you have a MIDI synth connected to your Mac, let's perform another simple exercise to explore playing back music through MIDI.

**FIGURE 2.7:** Connecting a MIDI synth
EXPLORATION 2.4: PLAYING BACK SOUND FROM A MIDI SYNTHESIZER

This exercise will use HyperCard to introduce playing back a MIDI sequence.

1. Open the exercise stack called 2.4 Play MIDI.
2. Click on the Play MIDI button.

Click on the question mark icon for information about the music.

You may have noticed that the last three exercises we've performed all used the same music, each in a different format. As a review, let's do one more exercise to directly compare the three sound formats—digital audio, CD audio, and MIDI—using the same short phrase of music.

EXPLORATION 2.5: COMPARING THE THREE SOUND FORMATS

This exercise gives us a chance to compare the three formats for sound on the Macintosh by playing the same phrase of music through each one.

1. Open the exercise stack called 2.5 Comparing Sound Types. You should see the screen shown in Figure 2.8.
2. Click on one of the playback buttons. When the phrase of music is finished, click on another. Compare and contrast the different qualities of audio as you listen to the same phrase of music in each example.

To stop the music once playback has begun, just click the button a second time.
A Closer Examination of Sound

A Closer Examination of Sound

Now that we have a better idea of how we can use sound on the Macintosh, let's take a closer look at the technology behind each sound type. By understanding more about the nature of sound, how it's recorded and stored, and how it can be manipulated, we will be better equipped to make decisions about audio and be far more creative when using sound in multimedia.

Digital Audio

To better understand the issues of digital audio, we must first examine the very nature of sound, including how computers store information and the conversion of natural sound into computer data.
The Nature of Sound

Technically speaking, sound itself isn't a physical entity. Rather, sound is our perception of a vibratory phenomenon. We perceive sound when changes in the air pressure (often called sound waves) reach our ears, causing the ear drum to vibrate sympathetically, stimulating nerves that then carry the impulses to the brain. It's the brain which then interprets these signals as sound.

For our purposes, we will use the word sound to describe the physical air waves that we perceive as sound. Capturing sound in any medium involves the transduction (changing of media) of air pressure fluctuations into some other continuously changing waveform. Sound may be expressed as changes in electricity, hence the term analog—an analogy between the changes in air pressure and changes in voltage. When sound is recorded on standard audio tape, it's stored as an analog waveform. Let's examine the tape recording process, as it will help us understand more about digital audio.

Capturing Audio in the Analog Domain

In analog tape recording, the continuous changes in air pressure, which we perceive as sound, are converted into analogous changes in voltage by a transducer called a microphone. Changes in air pressure cause a diaphragm inside the microphone to move in a sympathetic manner within an electromagnetic field, which in turn creates a fluctuating current of electricity analogous to the original air pressure changes. This electrical signal is then changed into an electromagnetic waveform by a recording head, which etches the waveforms onto tape—a band of plastic coated with metallic particles. The changes in the electromagnetic field cause analogous changes in the metal particles on the tape, capturing and storing the analogous waveform for future playback. This is why we call this process analog recording (see Figure 2.9).

When the tape is played back, the metal particles etched onto it travel across a playback head (another electromagnet), which recreates the electrical signal that is then sent to yet another transducer (a speaker), which is simply an electromagnet that pushes and pulls against a diaphragm to recreate the original movements in the air. If every step in this process is successful, we
FIGURE 1.9: The tape recording process

should hear a faithful reproduction of the original sound. The term *fidelity* refers to the truthfulness of the reproduced sound to the original.

In practical terms, it takes very high quality equipment to ensure high fidelity throughout the analog process. Each element in the transduction process—microphone, recording head, playback head, amplifier, and speakers—can potentially introduce noise into the system. The capture media itself, the tape, is also a potential source of background noise. We often speak of *tape hiss* in describing one of the inherent problems with analog recording. But there are bigger problems than just noise: the difficulty in editing, the tedious fast-forwarding and rewinding necessary to find a specific location in the music, and the lack of ability to control the playback from a computer. For all these reasons, digital audio provides a compelling solution for music in multimedia.
Capturing Audio in the Digital Domain

Capturing audio into the digital domain is often called sampling. Sampling is the digital equivalent of analog recording. In digitizing (sampling) a sound, analog voltage from a microphone or other source is sent to an analog-to-digital converter, which is very much like a digital voltmeter or battery tester. The analog-to-digital converter then converts the analog signal as follows:

- The converter continually measures the voltage of the electrical signals, usually at a rate of 11,000–48,000 times per second (which is quite fast), and assigns numeric values to the measurements.
- These numeric values are then stored as binary numbers in the computer's memory.

On playback, the computer sends the samples to a digital-to-analog converter, which recreates the original voltage. This voltage is then sent to an external amplifier and speaker to reproduce the original changes in air pressure. The fidelity of reproduction depends on the various transducers involved (microphone and speakers) and on the analog-to-digital and digital-to-analog converters (see Figure 2.10). The rate of sampling and the resolution of storage (both discussed next) are also important.

Sample Rate and Fidelity of Reproduction

The computer "takes pictures" of a signal between 11,000 and 48,000 times per second, converting each "picture" or sample into a binary number. The number of times per second that "pictures" are taken is called the sample rate. The sample rate is largely responsible for the range of sounds that may be captured. This range is called the frequency range. In general, the highest pitched sound that can be captured by sampling will be roughly ½'s of the sample rate.
A generic measurement of frequency is **hertz** (often abbreviated as **Hz**). The term **hertz** simply means the number of "times per second" (the rate) that something occurs. For example, if a sound wave oscillates 12,000 times per second, we'd said its frequency was 12,000 Hz. One **kilohertz** (abbreviated **kHz**), is equal to one thousand hertz. Kilohertz is a useful measurement for very large frequencies. For instance, in our above example, we could say that the frequency of the wave was 12 kHz.
For example, if the sample rate is set to 44,000 times per second, the highest pitched sound captured will be around 20,000 hertz (Hz). Since the optimal range of human hearing is approximately 20–20,000 Hz, a sample rate of 44 kHz is theoretically the minimum rate for accurately reproducing the spectrum of the human audio frequency range. In practice, however, it's usually fine to sample at a lower rate, because most musical sounds have very few frequency components above 12,000 Hz. Furthermore, after the age of 18, our hearing gradually declines, so that most adults—especially males (for some reason, women seem to retain their high frequency hearing longer than men)—won't miss the high frequency sounds that are lost with lower sample rates.

The graphs shown in Figure 2.11 represent the relationship of sample rate to reproduction fidelity.

Note the effect the slower sample rate has on the resultant waveshape. The first example shows fairly high fidelity to the original, while the second example bears little resemblance to the original signal. This loss in fidelity may also be compounded by resolution factors.

FIGURE 2.11: Sample rate and its relationship to audio fidelity
High quality digital audio comes at a price, though. There is a direct relationship between the sample rate and the amount of memory consumed by a recording (the more samples taken, the more samples to store), so often we will trade-off a little quality for memory savings. Remember that very good quality samples can be made at rates of 22,000 Hz (22 kHz), and even rates as low as 11,000 Hz (11 kHz) don’t sound bad.

**Sample Resolution and Fidelity of Reproduction**

Since analog voltages are continuous and digital numbers are discrete units, the analog-to-digital converter must divide the total range of voltage into as many numbers as possible in order to accurately reproduce changes in amplitude (loudness). This division is called the *sample resolution* and it’s measured in bits—the number of digits in the binary number used to store the amplitude of the sample.

To determine the number of parts the amplitude range will be divided into, just use this formula: parts = \(2^x\) where \(x\) is the number of bits. For example, if you have 12-bit resolution, \(2^{12} = 4096\), so you will have 4096 parts.

A sampler with 8 bits of sample resolution divides the amplitude range into 256 parts. A resolution of 12 bits divides the amplitude into 4096 parts, and 16 bits gives 65,536 parts. Generally speaking, each bit of sample resolution makes the recorded sound about 6 dB (decibels, a standard measurement of loudness) louder than the background noise. This is often called *signal-to-noise ratio* (abbreviated S/N). So, an 8-bit resolution has a S/N ratio of 48 dB which means the loudest sound is 48 decibels louder than the background noise level. A resolution of 16 bits provides over 96 dB of signal to noise. For comparison, a $25 cassette recorder provides about 48 dB of signal-to-noise ratio. This is usually not considered high fidelity, but is fine for non-critical listening or for recording voice.

If a value at a given sample point is between two divisions of the sample resolution, the analog-to-digital converter must *quantize* (round off) the value to the nearest division, and this will result in a distortion in the waveform, which will introduce additional noise. As with sample rates, a higher sample resolution gets closer to the original sound and makes the
recording sound better. The graphs in Figure 2.12 illustrate the relationship of sample rate and resolution to reproduction quality.

Earlier in this chapter, we mentioned that adding expansion cards for digital audio can significantly improve the Macintosh’s sound output. Now that we’ve discussed sample rates and resolutions, you should have a better understanding of why this is true. Since most Macs are capable of playing back sound at only 22 kHz, 8-bit resolution, an audio card capable of 44 kHz, 16-bit resolution will provide much higher sound quality. Let’s do a simple experiment to listen to audio at different sample rates.

**FIGURE 2.12:** Sampling resolution and its effect on sound quality
EXPLORATION 2.6: SAMPLING RATES AND RESOLUTIONS

This exercise will give us a chance to directly compare the quality of sound at different sample rates and resolutions.

1. Open the exercise entitled 2.6 Audio Quality. You should see the screen shown in Figure 2.13.

2. Click on the Best Quality button. This example is sound in 44 kHz, 16-bit format. Notice the clarity and excellent sound fidelity. (By the way, this example “cheats” a bit. I’ve assumed you don’t have an additional internal sound card to play 16-bit, 44 kHz sound, so this example plays from the CD.)

3. Click on the Good Quality button. This is 22 kHz, 16-bit audio. Your Mac may not be able to play 16-bit sounds, in which case you may only hear this example in 8-bit sound quality—but it will still sound better than the next example due to the sample rate.

FIGURE 2.13: The Audio Quality example screen
4. Finally, click on the Low Resolution button. This is 11 kHz, 8-bit sound. This is the lowest sound quality available on the Mac, except for sound in compressed format, which produces fidelity too low for most musical use. Note that even the low resolution example is usable for many musical applications.

Note the differences in sound quality in relation to frequency response and signal-to-noise ratio. The high quality example is clean and pure sounding, while the low quality one is dull and noisy. Since there is a trade-off between high quality audio and data overhead (both in disk space and CPU power), it's useful to have a good feel for the relative qualities of sound as we decide which formats to use.

**Sound Formats**

Sound can be stored in a number of different file formats, but generally they break down into two categories: those meant to be played from random access memory (RAM), and those meant to be played back from disk. As we discussed earlier, sounds to be played from RAM will necessarily be short snippets, while disk files are limited only by available space.

RAM-based audio files are generally in either *System 7 alert sound* format or *SND* format. Earlier in this chapter we had the opportunity to explore some System 7 “beep” sounds. The SND format is usually stored inside a Macintosh file, such as a HyperCard stack. Since the sound becomes a part of the file, it’s called a *resource*. These resources are invisible to any user without either an editing program, such as Apple’s ResEdit, or a sound editing program that gives access to resources, such as SoundEdit or Sound Designer, discussed below. Because sounds played from RAM must first be loaded into memory, they will always be limited to the amount of memory in your computer. A 44 kHz, 16-bit stereo sample takes about 10 MB of memory per minute, making it impossible to play on a Macintosh computer with 5 MB of RAM. Therefore, with RAM-based sound we must always trade off audio quality and length in favor of storage/playback needs. A one minute, 22 kHz, 8-bit mono sound clip, by comparison, takes only a little more than a megabyte of memory to store.

Since disk space is much less expensive than RAM (just look at the falling prices of hard drives) it’s far more economical to record to and play back
A Closer Examination of Sound

sounds from disk. Sound files are generally stored either as AIFF (Audio Interchange File Format) files or as application-specific files. The most common application-specific file formats are SoundEdit (low-end use) and Sound Designer (professional use). SoundEdit is a popular editing program from MacroMedia, and Sound Designer is a professional audio editing program from Digidesign. Most multimedia programs use AIFF files, and both SoundEdit and Sound Designer can create and store sounds in this format.

Audio from CD

The standard for CD audio is to capture it at 44,100 Hz and store it at 16 bits of resolution. This standard gives extremely high quality sound reproduction. Although this format demands a very high data storage overhead (10 MB per stereo minute), the compact disc can store large amounts of data in a small and convenient disk size. An audio CD can store as much as 72 minutes of music—over 700 MB of data! This makes the CD-ROM drive very effective for sound on the Macintosh. We can access large quantities of data, in this case high quality sound, from an accessible compact medium. As we've already seen, playing back sound from CD is easy and takes little CPU overhead. Once the music has begun, the computer is free to handle other tasks.

Audio on CDs is referenced against clock time, beginning at the first track on a CD. This time is measured in tracks, minutes, seconds, and frames; each second is divided into 75 frames, numbered 0-74. This timing information is often expressed as "01:05:36:58," which says that five minutes, thirty six and 58/75ths seconds have passed from the start of the CD and we are playing track 1. This timing information is often called a time code and is recorded into every CD. Since the CD-ROM drive is under computer control, we can instantly access any frame of the CD at any time! Let's do an experiment to see how we can control the CD via the CD-ROM drive.

EXPLORATION 2.7: CONTROLLING AN AUDIO CD

This example will allow us to experiment with direct access to specific frames of an audio CD from within HyperCard.

1. Open the exercise entitled 2.7 CD Control. You should see the screen shown in Figure 2.14.
2. This screen contains a number of buttons, each of which accesses a specific region of the audio tracks on the Multimedia Machine CD. Click on the 1. Intro button. The computer plays four measures of the song ¡ACINCHA!

**NOTE**

This button instructs the CD-ROM to search to track 3, time 51:35:72, and play until time 52:45:54.

3. Click on various buttons to jump around the piece, randomly accessing various parts of the song.

**NOTE**

Notice that you can stop the music by clicking the button a second time once the music has started playing.
Since we can instantly begin at any frame of the CD, we can play back specific segments of audio from CD as sound tracks for multimedia projects. There are a great number of products on the market that function this way, examples being the Voyager Company's *Beethoven's Ninth* CD and Warner New Media's *The Magic Flute*.

Let's look a little closer at the CD-ROM drive and the software used to control it. Macintosh CD-ROM drives can handle different kinds of disks, each holding a variety of information. The Multimedia Machine CD, for example, contains both computer data and audio tracks. The computer data is stored in track 1 of the disk in Macintosh Hierarchical File System (HFS) format. The audio tracks are CD audio—16-bit, 44 kHz stereo sound. The data on this disk can be read only by a Macintosh computer. The audio tracks can be played on any standard audio CD player, but be careful not to play track 1, because the data may be played as full volume noise, which can damage your stereo system—and your nerves! Some newer audio CD players will recognize a data track and mute the audio, but you're best advised not to play the disk through your stereo system.

Do not attempt to play track 1 of the Multimedia Machine CD, because the data may be played as full volume noise, which can damage your stereo system.

While the data track on the Multimedia Machine CD can be read only by a Macintosh, there are disks created in file formats that can be played on multiple computer platforms, provided the data can be read by applications that run under multiple operating systems. A text-only disk could be stored in one of these formats, as word processors are available for virtually every computer and almost all word processing programs can read text files. Disks read in this way are generally stored in either ISO 9660 or High Sierra file formats—standardized formats for this purpose. Kodak recently introduced a standard file form for storing pictures on compact disc called Photo CD. This format can be read by applications running on many differing computers as well as by stand-alone Photo CD players connected directly to a video monitor. When shopping for CD-ROMs, be sure that any disks you buy are in one of these formats so your Mac can read them.

The Apple system software allows the Macintosh to read any format compact disc through an extension called *Foreign File Access*. This allows you to read non-Macintosh (thus foreign) files as if they were Mac HFS files.
The extension uses a series of translators to accomplish this feat, which are stored in the Extensions folder within the System Folder. The translators include Audio CD Access, ISO 9660 Access, High Sierra Access, and Apple Photo Access. These files tell the Foreign File Access extension how to translate the respective CD formats into Macintosh HFS language.

In addition to the Foreign File Access extension, Apple’s CD-ROM system software includes the Apple CD-ROM extension, which is the software (called a device driver) that allows the Mac to mount CDs on the desktop as if they were floppy disks.

There are also commercially available software applications that allow you to catalog your audio CD collection, control the order that tracks are played, and provide remote control functions. One example of this is Audioshop, from Opcode Systems.

**MIDI**

The Musical Instrument Digital Interface was introduced in 1983, and its original purpose was to allow musicians to connect multiple keyboard synths in order to layer sounds. Before MIDI, if a keyboard player wanted to have two synths play identical notes at the same time, he or she had to play the same thing on both keyboards simultaneously. MIDI was conceived to allow the musician to play the notes on a single keyboard with multiple synths generating their own sounds. The keyboard being played is called the master, and it sends out performance data to other synths, called slaves, which play the same pitches. For this to work, the synths have to be connected (the hardware) and have a common language (the software); so when middle C is played on one synth, all other synths, regardless of make or model, know which note to play.

The real power of MIDI, though, is only now being realized with the growth in personal computers. With a Macintosh connected to a MIDI synth, a single musician can compose an entire score, hearing each part as it’s being written, and print out complete scores and instrumental parts in standard music notation. This musical “word processing” has revolutionized the way musicians compose and produce music.
The most common application for MIDI and computers is sequencing. A musical performance can be stored as a list (or sequence) of actions created by the musician. Each key press and release on a MIDI keyboard generates two action events—turning a note on and turning it off. The hardness of the key strike, which note is played, and the duration it is on can all be inferred from these two action events. In this way, sequencing software can store a musical performance for editing and playback with a high degree of accuracy and limited data overhead. Since MIDI describes performance not sound, and as the sounds themselves are stored in the MIDI synth, the data for playback takes up very little space. Each note played (and released) takes a maximum of six bytes—whole songs can be stored in as little as 30K. Perhaps more than any other MIDI application, sequencing has revolutionized the way musicians create. Sequencing provides a powerful medium for playback of recorded works, with high quality audio, at a fairly low cost and small data overhead.

In order for musicians to work on one MIDI synth and play back their work on different synths, the MIDI standard needed to be refined to guarantee that MIDI sequences would work when played back on any synth. This refinement was created a few years ago and is called the General MIDI specification. General MIDI (GM for short) specifies that synths must contain a minimum of 128 instrumental sounds, and that they be stored in specific locations. Program 1 on a GM synth will always be acoustic grand piano; program 35 will be electric bass; program 57 is trumpet. This program mapping ensures that a GM sequence file will be played by the appropriate instrument sounds on every GM synth.

Furthermore, the General MIDI specification details that a GM synth must be able to play at least 16 different instrumental sounds at a time, with at least 24 notes being able to sound simultaneously. This ensures the synth will be able to play all the notes in a GM composition. We've already had the opportunity to explore playing back a MIDI sequence—let's look at MIDI in greater detail.

**What Is a MIDI Synthesizer?**

MIDI synths come in three basic forms—keyboard-based synths, sound modules, and internal computer MIDI sound cards. While their physical forms may differ, and the way they generate sound varies among brands and models, all MIDI synths share the same basic architecture (see Figure 2.15).
As you can see in Figure 2.15, information about which notes to play is received by the synth's internal microprocessor, which then controls the voice generation. The number of voices (often referred to as polyphony) that can be generated varies, but the General MIDI standard is no fewer than 24 voices. How the sound is generated will vary by instrument but, these days, most General MIDI synths use some form of sample (digital audio) playback. Digital samples (recordings) of a wide variety of acoustic and electric instruments as well as sound effects are stored in the MIDI synth's permanent memory (Read Only Memory, or ROM) and are played back as MIDI performance information is received by the synth.

Each GM synth has the capability of playing at least 16 different timbres (instrumental sounds) at once, and is therefore called multitimbral. We may then say that GM synths are 16-part multitimbral, 24-voice polyphonic sound generators. Because of this multitimbral polyphonic capability, a single General MIDI sound module can function as a virtual orchestra—ready to play music according to the instructions of the musician.
**MIDI Hardware**

MIDI synths generally have two types of jacks on their back panels—audio and MIDI. It’s very important to distinguish between these two types of jacks. MIDI doesn’t carry audio—rather, MIDI is a type of computer data that conveys the performance information. The audio output jacks, conversely, can be connected to external amplification and speakers. Most GM synths have stereo outputs, but it’s not uncommon to have four or more outputs to allow for more complex external mixing and processing. The MIDI jacks carry data, and are configured for input of data to the synth—MIDI In—output from the synth—MIDI Out—and an echoing function—MIDI Thru. The latter allows multiple synths to be connected in a chain. Figure 2.16 shows the routing of MIDI data in contemporary synths. Refer also to Figure 2.15 above to see the relationship between the synth architecture and the flow of MIDI data.

**FIGURE 2.16:** MIDI signal routing in a synth
Multiple MIDI synths can be connected to one another and to the computer in a variety of ways. Figure 2.17 shows some of the common MIDI hardware configurations.

You can also install a MIDI synth card into your computer, provided you have a NuBus slot available. One such card is Digidesign's SampleCell II. SampleCell II is a 16-part multitimbral, 32-voice polyphonic, professional quality sample player with eight individual outputs. SampleCell comes with hundreds of megabytes of digitally sampled instruments and sound effects stored on CD-ROM. Figure 2.18 shows the SampleCell II NuBus MIDI sample playback card, along with the rest of the SampleCell II package.

**MIDI Software**

Remember that MIDI data doesn’t carry audio—only information about a musical performance. The MIDI language transmits a performer’s actions as standard data between instruments. The most common MIDI messages are

- Note on/off
- MIDI volume control
- Pitch bend
- Modulation controller (used to add vibrato)
- Sustain pedal on/off
- MIDI program changes

Program changes instruct the synth to change to a different instrumental sound, so a musical part recorded with piano sound can be played back with a guitar or flute sound. Since the MIDI information isn’t audio data, the performance becomes independent of the sound itself! Let’s do a quick experiment to see how this works.

**EXPLORATION 2.8: CHANGING SOUNDS ON A MIDI SYNTHESIZER**

In this exercise we will play a short, single-part MIDI sequence, send out MIDI program-change commands, and explore how different instrumental sounds affect our perception of the piece.
FIGURE 2.17: Common MIDI hardware configurations
FIGURE 2.18: The SampleCell II NuBus MIDI sample playback card package

1. Open the 2.8 MIDI Program Change exercise. You should see the screen shown in Figure 2.19.

2. Click on the Play Sequence button. The name of the button will change to Stop Sequence and a short musical phrase will play and repeat until you click the button again.

3. Click and hold down the Piano button. A popup menu will appear with a number of instruments listed, as shown in Figure 2.20. Choosing a sound by name will send out the appropriate patch-change command to the synth, and you will hear the phrase played with the new instrument.

Try a few different sounds and listen to how the instrumental timbre changes the emotional impact of the music. Sending patch changes to audition various sounds is an excellent orchestration tool for composers in creating music for multimedia.
For MIDI to become useful in the multimedia world, a standard file format was needed to ensure that music files could be played by a wide variety of software applications. (This is analogous to AIFF, discussed earlier.) One solution is the Standard MIDI File format, SMF, developed by Opcode Systems. Almost all Macintosh (as well as PC) sequencers now support this file format and can save or play sequences in SMF format. The previous exploration used an SMF sequence as its source material, it's stored within the MIDIfiles folder within the Music folder on the Multimedia Machine CD.

**Review**

For review, return to Exploration 2.5 where we compared sound formats. Once again, listen to each of the excerpts, paying close attention to the
sound quality. Now let’s examine the file sizes in each example, just to stress the correlation between file size and sound quality.

<table>
<thead>
<tr>
<th>Example</th>
<th>Quality</th>
<th>Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>Digital Audio</td>
<td>22 kHz, 8-bit, monophonic</td>
<td>5 MB</td>
</tr>
<tr>
<td>Audio from CD</td>
<td>44 kHz, 16-bit, stereo</td>
<td>40 MB</td>
</tr>
<tr>
<td>MIDI</td>
<td>44 kHz, 16-bit, stereo</td>
<td>70K</td>
</tr>
</tbody>
</table>

As you can see, MIDI provides high quality audio with low data overhead. Of course, there is an additional hardware investment, and you must be sure that every delivery system that will be used to display your work also
has a GM synth to guarantee correct playback of your audio. The use of MIDI for multimedia, however, continues to grow and it won’t be long before GM sound modules are commonplace in multimedia systems.

We’ve now explored the most common ways of using sound on the Macintosh: digital audio, audio from CD, and MIDI. We will return in future chapters to focus on each of these approaches. Let’s now move on to examine how we can use digital video on the Mac.
Video and the Mac

The very first 128K Macintosh computers were shipped with MacWrite and MacPaint software. This bundling allowed early Mac users to work easily with text and graphics, helping to set the stage for the Mac's early dominance of desktop publishing. Similarly, the Mac's built-in sound capability set the stage for its dominance in multimedia. Until recently, text, graphics, and sound were the most widely available media for integration on the desktop. The newest and most exciting media component for computers is digital video, and Apple was quick to lead the industry in a standardized multi-platform digital video format—QuickTime. In this chapter we'll explore this new medium get some hands-on experience to help you understand how digital video works on the Macintosh.

Using QuickTime

Any Macintosh with color capability can play back QuickTime movies. We had the opportunity to play a movie in Chapter 2, but let's take a closer look at QuickTime movie playing software.
EXPLORATION 3.1: USING MOVIEPLAYER

MoviePlayer, as its name suggests, is an application from Apple Computer that plays back QuickTime movies. In this exercise, we will use MoviePlayer to learn the basics of opening and playing QuickTime movies.

Copy MoviePlayer to your hard drive, even if only temporarily, to speed things up.

1. Find and open MoviePlayer. You will find it at the root level of the Multimedia Machine CD.
2. To better focus on the QuickTime window, hide any other open windows on your desktop by choosing the Hide Others command from the application menu. Figure 3.1 shows this menu option.
3. Choose File ➔ Open....
4. Find the Maria Lionza movie. It's located in the QuickTime Movies folder.
5. Your screen should now look like Figure 3.2.
6. Click on the play button to begin playing the movie.

FIGURE 3.1: Choosing Hide Others
7. Choose Movie > Get Movie Info. MoviePlayer will list a number of facts about Maria Lionza including the file size, length, and normal image size.

8. You can select a single frame for editing, or specify a selection range. Select a frame simply by moving to the desired frame using the transport controls. You select a region by selecting a start frame, pressing and holding Shift, and then going to the end frame and releasing the shift key. Select a range within Maria Lionza, (the exact selection doesn't matter for now—just choose a range for this exploration). The selected
area will be indicated by a black bar spanning the chosen frames. See Figure 3.3.

You can select the entire movie by choosing Edit ➤ Select All (⌘-A). Notice that the standard Cut, Copy, and Paste options are available on the Edit menu as well, and they work as you'd expect.

9. Choose Edit ➤ Copy (⌘-C). The range of frames you've selected will be placed on the Clipboard.

10. Select File ➤ New (⌘-N). MoviePlayer will create a new, empty movie window. See Figure 3.4.

FIGURE 3.3: A selected region in MoviePlayer
11. Select Edit ➤ Paste (⌘-V). The selected frames on the Clipboard will now be pasted into the empty movie window, as shown in Figure 3.5.

12. Using the transport controls, play the new movie.


TIP

You will be presented with a save file dialog box and given two choices for saving the movie. Checking the Make movie self-contained option will write all of the frames to disk, taking considerable space! Click in this check box, and MoviePlayer will tell you how much space the file will require (my selection would require 6 MB). Uncheck this box, and
MoviePlayer will create a file that contains only pointers to the frames within the "parent" movie file, which requires very little disk space (in my example, only 12K). As long as the Maria Lionza movie is available to be played, this new file can be saved without being self-contained.

Save your movie in the “not self-contained” form onto your hard drive.

14. Choose Movie ➤ Get Movie Info for your new movie. Notice that the information about your new movie shows the file size, the movie size (not the same now!), and that this movie uses data from one other file: Maria Lionza.
15. You can loop the entire movie or a selection of frames and control whether the loop plays forwards and backwards or only forwards by using the commands on the Movie menu. Experiment with these options.

16. You can also change the size of the movie by using the sizing commands found on the Movie menu; try experimenting with these options as well.

QuickTime allows you to select a frame as the movie's Poster Frame. This is the frame displayed in file dialog boxes that provide a preview facility, or used as the icon displayed for the file on the desktop. MoviePlayer allows you to go to the poster frame or set one for a new movie through commands found on the Movie menu.

17. Click in the Maria Lionza window to make it active, then choose Movie ▶ Go To Poster Frame. MoviePlayer will move to the first frame, which is the designated poster.

18. Click in your new movie window to make it active, choose a frame that would make a good poster for your movie, then choose Movie ▶ Set Poster Frame. The selected frame will become the poster frame for the file.

19. Choose File ▶ Quit to end this exploration.

You can cut and paste frames within a movie to reorganize the playback order, or paste into a graphics program for detailed editing of the frame and to save the single frame as a PICT or other graphic format file.

There are many ways to use QuickTime movies, ranging from simply opening and playing back video, as we did in the previous example, to creating multimedia presentations. Let's explore how we can use HyperCard and Media Tools to create an interactive example that plays a QuickTime movie.
EXPLORATION 3.2: USING THE MOVIE TOOLS

In this exercise, we will create an interactive presentation that will play a specific portion of a QuickTime movie when the user clicks on a button. We will learn how to open a QuickTime movie from within HyperCard, set a region to be played, determine how and where the movie should be displayed, and finally create a button that, when clicked, will present our movie. Also, you will get hands-on experience with an intuitive palette that comes with Media Tools called the Movie Tools. This palette allows you to record movies (if you have a QuickTime digitizer card), to open QuickTime movies, and to determine how and where these movies will be shown.

1. Open the 3.2 Movie Tools example file.

2. Choose Media ➤ Movie Tools.... You will see the Movie Tools Palette, shown in Figure 3.6.

![Figure 3.6: The Movie Tools Palette](image-url)
3. Click on the Open... button and find the *Maria Lionza* movie. It's in the QuickTime Movies folder on the Multimedia Machine CD. Click on the Open button.

4. *Maria Lionza* will open in a standard QuickTime window to the right of the Movie Tools palette.

5. Find the Capture Start and End Time buttons on the Movie Tools palette. These are shown in Figure 3.7.

![Figure 3.7: The Capture Start and End Time buttons](image)

6. Start playing the movie. You can use either the QuickTime transport controller or the Play button on the Movie Tools palette.

7. Choose a beginning point for the segment you wish to play, and click on the Capture Start Time button at that point. For this example, I have chosen as the "in point" the first clear shot of the woman carrying the banner. This is at frame number 10,800. Note that you can also type numbers directly into the start and end time fields.

8. Allow the movie to run for a few moments. Click on the Capture End Time button when you want the movie to end. For this example, I have used the first shot of the musicians playing as my "out point." This is frame number 20,800. The start and end times are now displayed in the appropriate fields in the Movie Tools palette, as shown in Figure 3.8.

> **NOTE**
> We have now defined the segment of the movie *Maria Lionza* that will be shown when the Play Movie button is clicked.

9. Click on the Play Region button to view the selected segment of the movie. If for any reason the region is not exactly what you want, type new frame numbers into the start and end time fields to tailor the region to precise frames.
10. Move the Movie Tools palette to one side of your screen, so the center of the Movie Tools example card is showing.

11. Drag the QuickTime window to the center of the example card, or to some other location of your choice.

12. Click on the Save Location button. When you click on this button, the Movie Tools grab the current location of the QuickTime window, and when the Play Movie button is created, the movie’s location will be stored as well.

13. Click the Show Controller option box so that it becomes unchecked. Notice the standard QuickTime controller is now hidden. For this exercise, we will leave it hidden.

14. Click to enable the Frameless option box. The close box will vanish from the QuickTime window. This is a handy type of window to use when displaying a selected region of a movie, as it keeps the user from interrupting your planned presentation. The movie can always be closed by clicking anywhere inside the movie frame.

15. Click to enable the Close at end option. With this option checked, the movie will close when it finishes playing. Your palette should now look something like Figure 3.9.
FIGURE 3.9: The settings in the Movie Tools palette

16. Click on the Make Button button. You will be asked to choose a name for the new button.

17. Type **Play Movie** as the name for the button and click OK.

18. Media Tools will report that the button has been successfully created; click OK. If anything goes wrong, however, Media Tools will report the error; repeat this exercise after solving the problem. One potential problem might be that HyperCard cannot write to the file (if, for instance, you didn't copy the exercise to your hard drive).

**NOTE**

We have now created a button that, when clicked, will open the *Maria Lionza* movie in a frameless window at the location we specified and will play the selected region.

19. Put away the Movie Tools palette by clicking on its close box. The movie will also close.
20. If you’re using HyperCard, you can skip this step and go on to step 21. If you’re using MediaTools Runner, hold down the Option key and click and hold down the mouse button on the Play Movie button. While holding down the mouse button and the option key, you can drag the Play Movie button to a location of your choice on the Movie Tools example card. Release the mouse button when you’ve placed the button at the chosen location. Releasing the mouse button is the same as clicking on the Play Movie button, so you will inadvertently perform step 22 when you do so.

21. If you’re using the full version of HyperCard, the button tool will be active and the Play Movie button selected, so you can drag it to a location of your choice on the Movie Tools example card. Place the button in a location where it won’t be obscured by the movie when it plays. When you’ve finished placing the button, choose the browse tool from the Tools menu, as shown in Figure 3.10.

22. Click on the Play Movie button. The selected segment of Maria Lionza will be played at the specified location in a frameless window with no controller, as shown in Figure 3.11.

FIGURE 3.10: Choose the Browse tool
FIGURE 3.11: The completed Movie Tools example

**QuickTime Revealed**

The Macintosh operating system has a few standard routines that all applications may use and that are part of the Macintosh Toolbox. These routines are handled by a series of “managers” that take care of these functions for the application—one reason that Mac programs have a common look and feel. Some of these routines are fairly visible to the user, such as the standard file Open and Save routines. Almost all Macintosh programs allow you to save and open files; finding files is usually done using a dialog box like the one shown in Figure 3.12, which in turn is handled by a file manager.

Another system level “manager” of interest is the Sound Manager, which we will discuss in Chapter 4.

Other routines are not so apparent to the user. One of which is QuickDraw, the set of routines that handles all of the Mac’s screen activity.
Every time you use the Mac you see the results of QuickDraw, but you’re never consciously aware of its presence.

QuickTime works the same way, but with time-dependent data rather than screen activity. QuickTime provides system-level synchronization between time-based media, such as moving pictures (video) and sound. Because it’s a system-level approach, any QuickTime-aware application can open and play back movies with a consistent user interface. And because QuickTime is part of the operating system, any color Mac can play back movies.

QuickTime is a system extension that is stored in the Extensions folder within the System Folder. You placed it there during installation (Chapter 1). If, for some reason, you’ve not yet installed the software, please return to Chapter 1 and do so now. All of the exercises in this chapter require QuickTime.

We’ve already seen that digital audio files can be quite large, especially at CD quality. A four minute song in 44 kHz, 16-bit stereo audio requires about 40 MB of disk storage. Digital video, and movies with both audio and video, can take hundreds of megabytes per minute, depending on the
audio and video quality desired. But we can record video with a smaller window size, rougher motion, or with fewer colors to save disk space. And, as we saw with digital audio, when we reduce the file size the fidelity decreases proportionally. To completely understand the power of QuickTime, let's examine digital video—how it's captured, stored, and played back.

Capturing Video—the Digitizing Process

When we look at video, be it analog or digital, we only think we're seeing moving action. In fact, what we're seeing is a series of still images, which, when played back fast enough, appear to be continuous motion. Capturing video is a lot like capturing audio—a number of discrete samples are taken over time, then stored for future playback. With digital audio, we sample sound many thousands of times per second. With video, we sample at a rate of up to 30 times per second, each sample being one frame of video. We store each sample as a frame that consists of many discrete dots called pixels (Picture Elements), each with a specific number of possible colors (the color depth), and measured in bits. The image size depends on the number of pixels captured, and the image quality depends on the color resolution.

Macintosh color ranges in resolution or bit depth from 16 colors (4 bits) to 16,777,216 colors (24 bits). 24-bit color is often referred to as millions of colors and 16-bit color is called thousands of colors. Most Macs use 8-bit color, which provides a palette of 256 different colors. More powerful Macs, or those equipped with specialized graphics cards, may provide 16- or 24-bit color—providing a palette with thousands or millions of colors. A standard frame of video at full size consists of $640 \times 480$ pixels. A $640 \times 480$ frame consists of 307,200 pixels. If each of these pixels is stored at 24 bits of color depth, a single frame of video takes over 900K. The number of frames per second to provide full-motion video according to the NTSC (National Television Standards Committee) standard is 30 fps (frames per second). Therefore, one second of full-frame, full-motion, 24-bit color video will consume almost 28 MB of storage space—and this is without sound! This quality of video (full-frame, full-motion, 24-bit color) is often called broadcast quality as it meets the NTSC guidelines for video for television use. We can see then that broadcast quality video with CD quality stereo sound consists of almost 2 gigabytes (GB) per minute of data. Whew!
In order to make this more manageable for multimedia, QuickTime provides a standard interface for various data compression schemes. Some of these are able to compress the amount of data necessary for storage by a factor of 50:1 with almost no visible loss of quality. Other methods of reducing the data overhead are

- Capturing a smaller image, say $320 \times 240$ or even $160 \times 120$
- Reducing the color depth
- Using slower frame rates

A $640 \times 480$ image stored with 8-bit color resolution at 30 fps will consume $\frac{1}{3}$ the data space, or roughly 560 MB per minute. Reduce the image size to $320 \times 240$, and the amount of data is reduced to 140 MB per minute. If the frame rate is lowered to 20 (only 4 fps less than film), the data is reduced to 100 MB per minute.

Lower sample rates for the audio will reduce the data overhead as well. If we sample at 22 kHz at 16-bit, mono, we will shave even more off file size. Add data compression to these methods and digital video becomes quite manageable. The Maria Lionza video is $160 \times 120$, 8-bit color, 8-bit mono sound at 11 kHz, and only 15 fps with data compression. As a result, the file size is only 23 MB for a movie that lasts over 5 minutes.

**Saving Space—QuickTime Compression Schemes**

There are a number of standardized compression/decompression schemes provided within QuickTime. These are often called codecs, (COMpression/DECompression), and QuickTime allows for third-party codecs to be added as plug-ins. Compression schemes come in two forms: *spatial* and *temporal*.

*Spatial* compression affects how much data is stored for a single frame of video and often results in a loss of image quality (referred to as *lossy* compression). Spatial compression often causes blurring, blockiness, or streaking.

*Temporal* compression affects the manner of storing data between adjacent frames of video. Some common approaches to temporal compression (referred to as *algorithms*) include eliminating redundancy from frame to frame...
(not storing repetitive data between frames), storing only the difference between frames (frame differencing), and estimating motion between frames. Some temporal compression schemes are *lossless* in that they don’t inherently cause a deterioration in image quality. Some compression schemes use either temporal or spatial compression, while others use both, allowing you to choose how much of either type you wish to use.

The following lists the standard QuickTime codecs:

**Apple Video** This is the best compression algorithm for capturing and compressing analog video. This codec supports both temporal and spatial compression and can play movies at rates of up to 30 fps. This codec also allows for repeated compressions for further data reduction with minimal quality degradation. Apple Video offers a range of quality settings from Least to Most, as well as variable frame rates, key frames, and frame differencing (see Figure 3.13).

**Apple Photo** Uses the JPEG (Joint Photographic Experts Group) compression algorithm. It can compress images at a 10:1 ratio with virtually no detectable loss of image quality. Apple Photo is best used on still frame images, as the current software version is not fast enough to decompress images at a rate suitable for moving pictures. There are hardware implementations of the JPEG compression scheme that are fast enough for video, but they require an additional investment. One such example is the SuperMac Digital-Film system, which contains the C-Cube JPEG codec chip. This can give very good results on full-motion, full-frame video with compression at up to a 50:1 ratio.

**Apple Animation** Best used on digital material, such as computer generated animation or graphic simulations, because it has problems handling the noise associated with digitized analog video. This scheme uses both temporal and spatial compression and can play back full-frame, full-motion digital graphics.

**None** Doesn’t compress the image, but it lowers the bit depth from 24 down to 8 bits. This is a good compressor to use while recording because it provides excellent picture quality and high frame rates, but at the price of consuming the most disk space. It’s a good choice when your plan is to capture video first and compress later.
Apple Graphic  Works on 8-bit images, and works well when used to capture analog video for display only on 8-bit monitors. This codec doesn’t achieve high compression ratios so it doesn’t work well for video that will be played from CD-ROM.

Apple Compact Video  Compresses video specifically to be played from CD-ROM. A high compression level coupled with limited data rate allows playback directly from CD-ROM at frame rates
dependent on CPU speed, available RAM and data transfer speed (CD-ROM drive and SCSI speed).

In addition to these standard codecs that come with QuickTime, third-party companies may develop other codecs that are either software based (like the Apple codecs) or hardware based, like the SuperMac DigitalFilm JPEG system described above. This card has a JPEG processing chip on the board to handle real-time compression/decompression on the fly. Another such scheme is the MPEG (Motion Picture Expert Group) codec, which at this point is available only in desktop playback systems. MPEG recording systems are still extremely expensive, but will no doubt become affordable eventually. The video on the Multimedia Machine CD-ROM was compressed using SuperMac's CinePak codec, which is specifically designed to provide smooth video playback from compact disc with minimal data size and transfer rates.

Several factors affect the playback timing of movies besides file size and compression scheme. These include the speed of the CPU, the playback media, and the depth of color resolution used by the monitor display. There are a wide range of QuickTime capable Macintosh computers, from the Mac LC, which uses a 16 mHz, 68020 processor up to the Quadras, which use a 68040 processor running at speeds up to 33 mHz. Obviously, the faster the CPU, the better it will be able to process the data required by digital video. QuickTime allows Macs of varying power to play the same movies, but slower computers will not achieve the same frame rates as the more powerful models. Jerkiness, hesitation, and dropped audio segments are symptoms of slower CPUs trying to keep up with a QuickTime movie's heavy data load.

The speed of the playback media can also slow down the playback of QuickTime movies. Playing a movie from hard disk is always more effective, but requires that space be available. SCSI hard drives frequently can achieve data transfer rates of 1 or 2 megabits (millions of bits) per second, whereas CD-ROMs can usually provide a transfer rate of only 150K–300K per second. To playback a movie from CD-ROM, it must have a limited data rate and be compressed.

The depth of color displayed by the computer can also affect the reliability of movie playback. If the display depth of the computer is less than the resolution of the monitor, QuickTime must dither (reduce the bit depth of) the video to display it. And this must happen in real time (a heavy
computational task), while the CPU is busy decompressing video frames and trying to keep up with the intense incoming data stream!

The video on the Multimedia Machine CD has been optimized for playback from compact disc (with its limited data transfer rate), for display on 8-bit monitors, and has been compressed to be playable on the greatest number of CPUs. There are some alternative files (Big River Movies and Big Musicians) provided for those with faster, more powerful machines or specialized cards, so that they can enjoy higher quality movie output.

Capturing video requires a special piece of hardware called a video digitizer. These are available in a wide variety of models, ranging from those that capture small images with slow frame rates to full-frame, full-motion digitizers. The most popular low-end video digitizer for the Mac is SuperMac's VideoSpigot. For less than $400 (street price) including software, this board adds video capture capability to almost any QuickTime-capable Macintosh. As mentioned above, SuperMac also makes DigitalFilm—a full-frame, full-motion audio and video capture package with an integrated 24-bit color graphics board for high quality video input and output. Additional recommended video digitizing hardware can be found in Appendix B.

### Editing Movies

You don't need a capture card to edit video, as there are already many sources of clip movies, providing canned video for most popular needs. Once we have access to digital video, either through our own digitization or through purchased media clips, we can edit it to meet our specific needs. My personal favorite video editing software for the Macintosh is Adobe Systems' Adobe Premier. Premier features an intuitive user interface, which makes editing video and placing music and sound effects to picture a simple process. But complete video production isn't easy—it requires the skills of several different disciplines.

Premier uses a number of windows to simplify the organization of materials and processes in video editing. The first is the Project window, where all of your materials are held. You can import clips from a variety of sources in a variety of formats into the Project window, and use them at a later time. Music and sound effects in AIFF format, video in QuickTime movie format, Graphics in PICT format, and PICS animation files can all be imported into the Project window (see Figure 3.14).
The place where you do your editing in Premier is the construction window. This window features A and B video tracks, transition tracks, superimposition tracks, and up to 99 stereo audio tracks. You drag clips from the Project window to specific locations in the Construction window, where you then perform your edits. Figure 3.15 shows a Premier Construction window with an editing project in process.

The Construction window features a number of tools for working with the tracks, which are found in the lower-left portion of the window. We'll use these tools when we do the editing exploration below. The final window
FIGURE 3.15: The Premier Construction window

of interest is the Transitions window, which contains many available special effects for use on video clips. Each transition effect is represented by a moving icon (sometimes called a micon), which demonstrates how the transition functions. Figure 3.16 shows the Transitions window.

The following exercise will show some of the many ways that we can edit QuickTime movies using Adobe Systems' powerful Adobe Premier software.

EXPLORATION 3.3: EDITING QUICKTIME MOVIES

In this exercise we will examine some of the ways we can edit and combine video using Adobe Premier. We will take four different videos of the Niagara river and combine segments of all of them to form a single QuickTime movie.
**Transitions**

**Additive Dissolve**
Image A fades into image B.

**Band Slide**
Image B slides over Image A in horizontal or vertical bars.

**Band Wipe**
Image B is revealed under Image A by horizontal or vertical bars.

**Barn Doors**
Image B is revealed under Image A from the center outwards.

**Center Merge**
Image A splits into 4 parts and slides to the center to reveal image B.

**Center Peel**
Image A curls from the center, with a shaded back, revealing image B.

**Center Split**
Image A splits into 4 parts and slides to the corners to reveal image B.

**Channel Map**
Selected Channels from images A and B are mapped to the output.

**CheckerBoard**
Two sets of alternating boxes wipe to reveal image B under image A.

**Clock Wipe**
A wipe from the center of image A sweeps to reveal image B.

---

**FIGURE 3.16**: The Premier Transitions window
Part 1: Setting In and Out Points

As we saw with our previous explorations, it's often useful to specify a region of a movie. With MoviePlayer, we selected a range of frames using the QuickTime controller. With Movie Tools, we did this by clicking on the Capture Start and End Time buttons. Although the process is somewhat different in Adobe Premier, the concept is the same.

You may want to drag the entire Adobe Premier Demo folder to your hard disk for this exercise. It's located in the Demo Software folder on the Multimedia Machine CD. Running the software from your hard drive will make all steps in this exploration operate more efficiently. Note also that Premier requires 4 MB of RAM, so you will need at least 5 MB and preferably 8 MB of RAM in your computer to work effectively.

1. Open the demo version of Premier. You will see a list of preset Project options. Choose Presentation—160×120. This is a general purpose preset that works well with small QuickTime movies. Click OK to confirm your choice. You will see now see the blank Construction and Project windows. This is where we will perform most of the work in this exploration.

Our first step will be to import the four movies we will work with in this exploration.

2. Choose File ➤ Import ➤ Folder..., as shown in Figure 3.17.

The Folder... option is the quickest way to import a number of files at once, as all files in the chosen folder will be brought into Premier in one step. The other options on the Import submenu are File... (⌘-I), which brings in a single file, and Multiple..., which allows you to work in a loop, importing single files until you've imported all the ones you want.
3. Using the standard file dialog box, locate the Little Rivers folder, which contains the four movies we wish to import. It is in the River Movie Files folder within the QuickTime Movies folder on the Multimedia Machine CD. Click on the Select Little Rivers button.

4. You should now see the project window with the imported files. If it’s not visible, select Windows > Project to bring it to the front. It should now contain the four imported movies Small River Segment 1, Small River Segment 2, Small River Segment 3, and Small River Segment 4. Figure 3.18 shows the Project window with the imported movies.
If you have a Macintosh Quadra or other powerful Mac with more than 12 MB of RAM, and a double speed or faster CD-ROM drive, you may instead import the Big Rivers folder, found in the QuickTime Movies folder. These are the same movies but in 240 x 180 resolution rather than the 160 x 120 versions found in the Little Rivers folder. You will also want to start with a new Project using the Presentation—240 x 180 preset. If you have enough disk space, copying the movie files...
to a hard drive allows the movies to play back at higher frame rates.

5. Double-click on the Small River Segment 1 icon in the Project window. A Clip window will open, ready to play the movie, with a variety of transport controls. Figure 3.19 shows the Small River Segment 1 movie in the Premier Clip window.

6. Play the movie by clicking on the Play button in the Clip window. When it stops, the Clip window should look like Figure 3.20. This shows the last frame of the movie at time 00:00:31:12 (0 hours, 0 minutes, 32 seconds and 12 frames—there are 30 fps).

   This frame shows the word Out to the right of the movie, indicating that this is where playback ends. We want to change the out point to be somewhat earlier, at time 00:00:30:20.

7. Using either the Frame Backwards button or the location slider, move to frame 00:00:30:20. This is the last frame showing the river in this clip. Click the Frame Forward button to advance one frame

**FIGURE 3.19:** The Premier Clip window
and see that the river has disappeared. Step backwards again to 00:00:30:20.

8. Click on the Out button to instruct Premier to stop playback at this frame. Premier will display the word Out now at this frame to the right of the movie (see Figure 3.21).

**NOTE**
For now, we will leave the in point set at the first frame of this clip. If we wanted to change it, we would move to the desired frame, then click on the In button.

9. Click on the Goto: button to see the pop up menu. Choose In from this popup menu.

10. Click on the Play button. Watch the clip to view our selected region, from 00:00:00:00 to 00:00:30:20. Note the clip will still play to the end in the Clip window. When placed in the Construction window, however, it will display only up to our new out point.

11. Click in the close box to complete this portion of the exercise.
Part 2: Removing Unwanted Sections

Another common need in movie editing is to remove an unwanted section from a movie clip. To accomplish this, we determine the frames that mark the boundaries of the area to be removed, cut out the region between the boundaries, then move the outer segments together. In this exercise, we will continue working with Small River Segment 1. This movie has a portion where a visitors' information plaque ruins the panoramic view of the river. Our job is to remove it from the movie.

1. Open the clip window for the Small River Segment 1 movie by double-clicking on the segment's icon in the Project window.
2. Using the location slider, scroll to frame 00:00:11:09, the first frame where the visitors' information plaque begins to come into view.
3. Step back one frame to 00:00:11:08. This will be the last frame of the first remaining portion of the segment. Let's mark this frame for later cutting.
4. Click on the Mark: button and hold down the mouse button to view the marker pop up menu. Figure 3.22 shows the marker pop up menu.
5. Select 0 to set marker number 0 at frame 00:00:11:08. Your clip window should now look like Figure 3.23.

**NOTE**

Next we want to mark the frame that will begin the last segment of the movie. This will be the first frame after the visitors' plaque has disappeared from view.

1. Move to frame 00:00:17:24. This should be the final frame containing the plaque.
2. Step forward one frame to 00:00:17:25.
3. Select 1 from the Mark: pop up menu to set marker 1 at frame 00:00:17:25. Your clip window should now look like Figure 3.24.
4. Click in the close box to return to the Project window.

**NOTE**

Our next step is to remove the area between marker 0 and marker 1. We do this work in the Construction window.

1. Drag the icon of the Small River Segment 1 movie from the Project window into track 1 (labelled A) of the Construction window. You will see it laid out sequentially in blocks of frames.

2. Click in the Construction window to make it active. Zoom out to a viewing resolution of 4 seconds by using the zoom selector at the bottom of the Construction window. Notice that the two markers, 0 and 1, are now visible in the window. Figure 3.25 shows the clip in the Construction window.

**FIGURE 3.25:** The Small River Segment 1 clip in the Construction window
You can view the Construction window at a variety of resolutions. In the bottom-left corner of the Construction window is the slider that we already used to zoom to a resolution of 4 seconds. We can view in resolutions between 20 seconds and a single frame. Experiment with this by moving the slider in increments down to 1 frame.

3. With the resolution zoomed to 1 frame, choose the razor blade tool from the tool bar at the lower left of the Construction window.

4. Locate marker 0 in the clip. Use the scroll bar at the bottom of the window or use Project ▶ Goto/Search to move to frame 00:00:11:08.

5. Click right on the line at the frame marked 0 with the razor blade tool, as shown in Figure 3.26.

6. Now move to marker 1, using either the scroll bar or the Goto/Search command to move to frame 00:00:17:25 as in step 4 above.

FIGURE 3.26: Using the razor blade tool at marker 0
7. Again choose the razor blade tool and click at the frame marked 1 to cut the film at that point.

8. Zoom out to 4 seconds again, so that the region designated by markers 0 and 1 is in full view in the Construction window.

9. Click at the middle region defined by the markers. It will become selected, indicated by the moving marquee around its boundaries.

10. Press the delete key on your keyboard to remove the selected region. You will now have a gap where the region used to be, as shown in Figure 3.27.

11. Repeat steps 9 and 10 above for the audio track. You can remove video without audio and vice versa. In this example, though, we want to remove both the video and audio tracks.

12. Select the "double arrow" tool. This tool allows us to move tracks forward or backwards in time maintaining proper relative positions and timings.

FIGURE 3.27: The missing region shown in the Construction window
13. Drag the last segment to meet the first. This removes the blank time, and creates a new single movie with the unwanted section removed. This is illustrated in Figure 3.28.

**WARNING** If you are having trouble moving the splices together exactly, be sure you have cut out both the video and audio tracks at the same place. If you haven't, the pieces will not fit together.

14. Now let's watch a preview of our edited version of the movie. Drag the yellow preview area selector so that it covers the entire movie. Press the Enter key or select Project ➤ Preview. Premier will build a temporary preview file, updating you on its progress as it works. After a few moments, you should see the preview with the unwanted segment removed.

**FIGURE 3.28:** The unwanted region removed
Part 3: Combining Video Segments

Standard video editing involves integrating multiple *takes* or *shots* into a single production. We will now explore the possibilities for combining two or more video segments into a single movie.

1. Drag the Small River Segment 2 clip from the Project window into video track A of the Construction window at the end point of our edited version of Small River Segment 1.

2. Drag the yellow bar across the top to indicate the area to be previewed. The area should be the entire project, encompassing both video segments. Figure 3.29 shows the completed splice, ready for preview.

3. Press Enter to watch a preview of the combined segments.

*NOTE*

This type of edit is called a **butt-end splice** because the two segments are butted up together end to end. What is the effect of this type of splice?

**FIGURE 3.29:** The splice ready for preview
Part 4: Adding Transitions

Rather than using a butt-end splice, it's often preferable to create a smooth transition between video segments. Premier gives you many different visual effects to use as transitions. This part of the exploration will investigate how transitions are applied; you will also have the chance to experiment with a number of special effects.

1. After the end of Segment 2 of track A, drag the Small River Segment 3 clip from the Project window into track B of the Construction window. Your construction window should look like Figure 3.30.

2. Zoom in so you're viewing at a resolution of 1 second. Use the resolution slider at the lower-left side of the Construction window.

3. Drag Segment 3 so that there is a 1 second overlap between the two tracks. Your Construction window should now look like Figure 3.31.

FIGURE 3.30: Segment 3 in the B video track
4. We’re now ready to add a transition. Let’s try Cross Dissolve. Click in the window to bring it to the front, or select Window ➤ Transitions.

5. Locate the Cross Dissolve effect in the Transition window, click on it and drag it into the transition track so that it fits the overlapping area between tracks A and B. Your screen should now look like Figure 3.32.

6. Drag the yellow preview area selector so that it covers the time period from the start of segment 1 to the end of segment 3.

7. Double-click on the transition block in the Construction window to open the Cross Dissolve Settings dialog box.

8. Click to enable the Show actual sources option to display the video from tracks A and B in the dialog box, as shown in Figure 3.33.

9. Now drag the controller bar under the left window to preview the transition effect. Click on OK to proceed.

10. Press Enter to view the transition.
Editing Movies

After you preview the transition effect, try substituting different effects to see how they all work. To remove an effect, simply select it in the Construction window, then hit delete. You can then drag a new transition into place and experiment with its settings.

Part 5: Volume Envelopes

When you overlap two video segments that have audio, you may want to create an audio transition in addition to the video effect. Most of the time, all that is needed is to fade out the first segment while the second segment fades in. Fortunately, Premier has a simple way of controlling the volume of audio segments in each audio track in the Construction window. Figure 3.34 shows a detail of an audio track with the components labeled.

In the next part of our video exploration we will work with audio volume envelopes. We will perform several experiments, learn to control overall
volume levels for a track, and to create cross fades between two video segments.

1. Move the cursor into audio track A over the audio volume control band. The cursor will turn into a hand with the index finger extended.

2. Press and hold down the Shift key. The cursor will change into a horizontal bar with up and down arrows.

3. While holding down Shift, click the mouse on the audio volume control band, then move the mouse up and down. You should see the level move higher and lower as you move the mouse up and down.

   This is the volume control for the entire track. We will spend more time experimenting with this later, for now we will leave the volume set at the mid-point. We will instead focus here on fading the audio out for track A as the volume increases.
for track B. This is often called a **cross fade**, as we smoothly change volumes across two different soundtracks.

4. Move the cursor again into Audio Track A over the volume control band. Click the mouse at the beginning of the B track as shown in Figure 3.35. This will leave a small dot in the band, which functions as an *envelope control point*. This concept will be more fully examined in Chapter 4.

5. Click on the dot at the very end of Audio Track A and drag it down to the bottom of the track, then release the mouse button. The volume control band will show a gradual decrease in level from the start of Audio Track B to the end of Audio Track A, as shown in Figure 3.36.

6. Move the cursor into Audio Track B over the volume control band. Click the mouse at the end of the A track to create an envelope control point in Track B.
FIGURE 3.35: Beginning the audio cross fade

FIGURE 3.36: Audio Track A set to fade out

7. Click on the dot at the beginning of Audio Track B and drag it down to the bottom of the track, then release the mouse button. The volume control band will show a gradual increase in level from the start of Audio Track B to the end of Audio Track A, as shown in Figure 3.37.

We have now created a visual cross dissolve between video segments and an audio cross fade between tracks. Preview the video project at this point by pressing Enter. Next, we will add the last video segment to the project and explore more features of the Premier editing software.
Part 6: Using Filters

Premier provides powerful tools for manipulating the appearance and sound of video and audio. We have already seen a sample of these; let's now look at the concept of filters.

1. Zoom the view resolution out to 10 seconds so you can see the entire project in the Construction window.

2. Drag Small River Segment 4 from the Project window into video track A of the Construction window roughly at the end of track B.

3. Zoom in to a resolution of 1 second and again overlap tracks A and B by about 1 second.

4. Add a transition of your choice between the two video tracks. Your Construction window should now look like Figure 3.38.

5. Add an audio cross fade as we learned above in Part 5 of this exploration.

6. Zoom out to a view resolution of 10 seconds and drag the preview band from the beginning to the end of the project. We're now ready
FIGURE 3.38: The final segment added
to preview the completed construction before examining the concept of filters; press Enter to preview the project.

Filters are effects added to a video or audio track that enhance their appearance or sound upon playback. These work like sun glasses in that they’re applied over the actual image to change the appearance. Let’s first examine an audio filter.

1. Move your cursor into an audio track over its waveform portion.
2. Press and hold down the Option key. The cursor changes into a mini popup menu. Press and hold down the mouse button and select the word Filters... and release the mouse. You will see the Audio Filters dialog box, shown in Figure 3.39.
3. Drag the Echo filter from the Available window into the Current window. You will see the Echo Settings dialog box.
4. Drag the Delay slider over toward the Long setting and choose the Loud setting for Intensity.
5. Click OK to accept these settings.

6. Click OK to close the Filters dialog box.

7. Drag the preview selection band over the audio track where you added the filter, then preview the track by pressing Enter. Since the soundtrack is fairly close to white noise, it will be difficult to perceive the echo. Listen closely!

Now let's use the technique to experiment with a video filter.

1. With the mouse over the last video segment, press and hold down the Option key. The cursor again changes into a mini popup menu. Press and hold down the mouse button and select the word Filters... and release the mouse. You will now see the Video Filters dialog box.

2. Drag the Brightness and Contrast Filter into the Current window to view the Brightness and Contrast Settings dialog box, shown in Figure 3.40.

3. Move the sliders to change the brightness and contrast levels; the results will appear in the preview frame.

4. Click on Cancel to exit the Brightness and Contrast Settings dialog box and again in the Video Filters dialog box.
We have explored just a few of the editing techniques available with Premier; there are many more tools to be explored, but you can do that on your own. Hopefully, you now have an understanding of the basics of digital video editing on the Macintosh, and feel the excitement that these powerful editing tools can generate.

In this chapter, we examined QuickTime as a technology and digital video editing as one possible application. We will continue to build on these concepts and skills when we return to multimedia issues in Chapters 7 and 8. Now let's return to our study of music and sound and delve deeper into the concepts of digital audio.
In Chapter 2 we used some previously recorded digital audio files to understand how sound is digitized and stored. In this chapter we will further explore digital audio on the Mac and get some more hands-on experience in recording, creating, editing, and manipulating digital audio.

**Using Sound Manager**

In Chapter 3 we discussed QuickTime and its function as a system-level manager of time-based events. We will begin our work in this chapter by examining another system-level manager, Sound Manager. Sound Manager handles sound services behind the scenes so that programs can focus on functionality and user interface. The diagram in Figure 4.1 shows how Sound Manager works to provide system-level services to applications.

The above illustration shows that, by working at the system level, Sound Manager handles all sound input and output for the application. So at any time you can add a new audio card or take advantage of new capabilities offered by other sound hardware, while still using the same software. Sound Manager also directly processes digital audio and provides for
FIGURE 4.1: Sound Manager and its system-level sound services to applications

on-the-fly sample rate and sample resolution conversions. Thus, any Mac can play any type of sound regardless of original sample rate and resolution.

Theoretically, multimedia developers can record a sound in the highest quality format, knowing that it can be played on every Mac. In practice, however, Sound Manager requires a lot of CPU overhead and may have problems changing sound formats in real-time on lower-level Macs. Sound Manager works through two additions to the system software: the Sound Manager extension and the Sound control panel.

**Sound Manager**

You added Sound Manager during the installation you performed in Chapter 1. This file is in the Extensions folder (found within the System Folder) and loads at startup to enhance the system’s capacity to handle sound. Sound Manager (Figure 4.2) interprets the various system-level sound calls that occur in recording and play back, as well as the sample rate and resolution conversions.
The Sound Control Panel

The Sound control panel allows you to select your system beep, to choose the hardware for sound input and output, and to control volume levels for sounds using various hardware. Let's look at Sound (Figure 4.3) and see how it is a traffic conductor for sound.

Alert Sounds

In Chapter 2 we experimented with the alert sounds on the Multimedia Machine CD; we simply double-clicked each icon to listen to the sound. Now let's actually add an alert sound to the System file and select it to be the new system beep.

EXPLORATION 4.1: ADDING AN ALERT SOUND AND SETTING THE SYSTEM BEEP

In this exercise we will learn how to add sounds to the system, to set the alert sound the Mac will use as the system beep, and to remove sounds from the system file.
1. Open the System Beeps folder on the Multimedia Machine CD.
2. Be sure your System Folder is closed but visible behind the opened System Beeps window, as shown in Figure 4.4.
3. Drag the file named bucket-o-fish into your closed System Folder. You will be given the prompt asking if you want the Mac to put bucket-o-fish into the System file.
4. Click OK, and the file will be copied to your hard disk and installed into the System file.
5. Select Control Panels from the Apple menu. The Control Panels window will open.
6. Double-click on Sound. You will see the Alert Sounds page of Sound as shown in Figure 4.5.

**FIGURE 4.4:** The opened System Beeps window with the closed System Folder visible
Using Sound Manager

7. Select bucket-o-fish as your system beep by clicking on it in the available Alert Sound list.

8. You may set the volume for this sound by adjusting the slider to the left of the sound list. The Mac will play the sound at the chosen level each time the mouse button is released.

9. Close Sound by clicking in its close box.

10. Open your System Folder and locate the System file. If you use the View ➤ by Icon option for your System Folder window the System file will look like a suitcase with a Mac on it.

11. Open the System file by double-clicking on it. You should see a window listing your available sounds and keyboard layouts.

12. Drag a sound file out of the System file to the desktop. This file will be removed from the system and will no longer be displayed in the available alert sounds list in Sound. Drag it back into the System file window to reinstall the sound.

FIGURE 4.5: The Alert Sounds page of the Sound control panel
Sound Input Devices

Now that we've seen how to add and remove sounds, set the alert sound, and set the alert sound volume, let's see how Sound allows us to choose the sound input hardware for recording sounds.

EXPLORATION 4.2: SETTING THE INPUT DEVICE

In this exercise we will learn how to use Sound to set the hardware to be used for sound input, and how to use the standard record dialog box for adding a new alert sound to your system.

Follow along with this exercise even if you don't have sound recording capabilities on your Macintosh. You can always add sound input hardware later, and understanding the process now will help you in the other explorations in this chapter.

1. Open Sound.

2. At the top left of the control panel there is a popup menu labeled Alert Sounds. Click and hold down the mouse button while pointing at the words Alert Sounds. You will see the menu shown in Figure 4.6.

3. Select Sound In from the popup menu. You will be shown the Sound In page of Sound, illustrated in Figure 4.7.

In Figure 4.7, there are three input device icons: Built-in, DigitalFilm, and Digidesign. This is because the Mac I use is a Quadra 800, which has built-in sound along with two NuBus cards that can record sound: DigitalFilm from SuperMac, and Audiomedia II from Digidesign. I can select any of these three input devices as the hardware that will provide sound input to Sound Manager. The illustration shows that Built-in is the selected input device.

4. If your Mac has sound input hardware, you will see the input driver(s) currently available. For now, select Built-in to use the internal sound input on your Mac.

5. Return to the Alert Sounds page using the popup menu.
The Add... and Remove buttons allow you to record new sounds and delete existing sounds from your system. In the exercise above, when we dragged a sound out of the System file, we only removed it from the list. The Remove button here will permanently delete the sound from disk. Use this with caution!

6. Connect the microphone that came with your Mac to your Macintosh's sound input jack. See Figure 4.8 for proper configuration.

7. Click on the Add... button. You will see the standard record dialog box, as shown in Figure 4.9.

8. Talk into the microphone. You will see sound waves coming from the speaker, these indicate the input level. If the level is too high you will see a vertical line to the right of the sound waves, indicating that the input is too high and that the sound will be distorted.
CHAPTER 4 Working with Digital Audio

Choose a source for recording:

9. When the level is set correctly, click on the Record button and say the word Test.

10. Click on the Stop button. Notice that the seconds bar below the transport controls show how much of the total RAM you have used. The total shown reflects how much RAM you have available in your computer.

11. Click on the Play button to hear your recording.

12. Click on the Save button to save this sound to disk, and install it into your System file. You will be prompted to give the sound a name. Name it Test and click the OK button.

13. Test will now appear in the Alert Sound list and is selected as the current system beep. Click on it to listen one more time.

14. Now, with Test selected, click Remove. You will get an alert asking you if you want to remove the sound Test.
15. Click OK to permanently erase this sound. The Mac will select Simple Beep as the system beep by default.

16. Select an available sound from your list, then close the control panel.
Sound Output Devices

Just as we were able to select from an available list of sound input devices, Sound Manager also allows us to choose the sound output hardware through Sound. Let’s do a short exercise to familiarize ourselves with the sound output options.

EXPLORATION 4.3: SETTING THE OUTPUT DEVICE

In this exercise we will explore the Sound Out and Volumes pages of Sound.

1. Open Sound as in previous explorations.
2. Choose Sound Out from the popup menu. You will see the page as shown in Figure 4.10.

FIGURE 4.10: The Sound Out page of the Sound control panel
Like the Sound In page above, the Sound Out page has three output devices listed: Built-in, DigitalFilm, and Digidesign. Under the list of available drivers is a popup menu for selecting the sample rate for playback and radio buttons for selecting the resolution and specifying whether playback will be stereo or mono. Depending on the device chosen, these options may vary. In this illustration Built-in has been selected, indicating sound will be played from the internal speaker or through external speakers if they have been connected to the sound output jack (discussed in Chapter 2).

3. For now, choose Built-in to select internal sound playback.

4. Using the popup menu, select Volumes. You will see the page shown in Figure 4.11.

**FIGURE 4.11:** The Volumes page of the Sound control panel
5. If you have multiple output devices, you can use these volume slid- 
ers to set the output level for each individual device.

6. Close Sound by clicking in its close box.

Now that we understand the principles of Sound Manager and have 
learned to use Sound to direct traffic, let’s do a few explorations to get 
some hands-on use of digital audio on the Mac.

**Sound Playback**

For our next exploration, let’s create a button to play a specific sound 
from a HyperCard stack.

**EXPLORATION 4.4: PLAYING BACK A DISK 
FILE WITH AUDIO TOOLS**

In this exercise we will create a button that, when clicked, will open a 
sound file from disk and play back the sound. We will do this using the 
Audio Tools component of the Media Tools package.

1. Open the stack entitled 4.4 Playing a Disk File. You should see the 
   screen shown in Figure 4.12.

2. Select Media ➤ Audio Tools…. You will see the Audio Tools palette 
   shown in Figure 4.13.

3. Click on the Disk radio button in the section listed as Record To: 
   This will alter the palette to show the Record to Disk and Play from 
   Disk buttons—indicated by Tape Recorder and Speaker icons respec- 
   tively. This is shown in Figure 4.14.

4. Click on the speaker icon. You will be given a standard file dialog 
   box and prompted to open an AIFF file.

5. Select the Fall Equinox.22 file. It is located in the AIFFS folder within 
   the Music folder on the Multimedia Machine CD.

6. You will be notified that the file was opened and installed in the Fall 
   Equinox.22 button. Answer OK to the prompt.

7. Close the Audio Tools palette by clicking in its close box.
FIGURE 4.12: The Playing a Disk File screen

FIGURE 4.13: The Audio Tools palette
CHAPTER

Working with Digital Audio

Choose "Record to RAM" to create an 'snd' resource or "Record to Disk" to create an 'AIFF' file. When recording to RAM use the "Set Name:" and "Set Stack:" buttons. Click

FIGURE 4.14: The changed Audio Tools palette

8. Move the button to the center of the card screen. If you are using HyperCard, you can simply drag the button to the desired location, size it as you wish, choose the browse tool, then click on the button. If you are using MediaTools Runner, hold down the Option key, click on the button, and drag it to the desired location. When you release the mouse, it will be as if you clicked on the button.

9. You can stop the music by clicking again on the button as the music is playing.

10. Choose Go ➤ Home (⌘-H) to end this exploration.

The Audio Tools component of the Media Tools package makes it very easy to create buttons to play disk files from HyperCard, taking care of all the necessary scripting for you. You simply click a button, select the file, and Media Tools does the rest! See Figure 4.15.
Sound Recording

If you have a Mac with recording capability (either built-in or through add-on hardware) we can explore the recording process. If you don't know whether your computer is capable of sound input, check your owner's manual or look on the back panel to see if you have a jack with the icon shown in Figure 4.16 over it.

EXPLORATION 4.5: RECORDING TO RAM WITH AUDIO TOOLS

In this exercise, we will first record a short sound to RAM, install it into a HyperCard stack as an snd resource, and then create a button to play the sound.

1. Connect a microphone to the sound input jack on the back of your Macintosh or according to the instructions that came with your additional audio hardware. If necessary, select the appropriate sound input device, as detailed earlier in this chapter.
2. Open the 4.5 Recording to RAM example file.

3. Choose Media ➤ Audio Tools.... The Audio Tools palette (floating window), shown earlier in Figure 4.13, will appear.

4. Select the Record to RAM option by clicking on the RAM radio button if it is not already selected.

5. Click on the Set Name: button and enter 1-2-3 as a name for the sound in the dialog box. Click OK to confirm the name.

6. Be certain that the name showing to the right of the Set Stack: button is 4.5 Recording to RAM. If not, click on the Set Stack: button and find the 4.5 Recording to RAM stack on your hard drive using the standard file dialog box. Click on the Open button to set this stack as the target for the sound installation.

7. Click on the tape recorder button to bring up the standard audio recording dialog box. Your screen should now look like Figure 4.17.

8. Adjust the level by moving the microphone or speaking louder or softer, until the speaker icon flashes large audio waves but does not produce a flat vertical line—an indication of distortion.

Setting the level correctly is a key element in obtaining a good recording.
FIGURE 4.17: The standard audio record dialog box in the Audio Tools palette

9. When the level is optimal, click on the Record button and record your sound. Say the words *one...two...three* with spaces between the words.

10. Click on the Stop button to end the recording.

11. Click on the Play button to listen to your sound. If it is acceptable, click on the Save button. A button will be created and placed on the screen.

12. You will be prompted that the sound was successfully installed into the stack 4.5 Recording to RAM and that the button 1-2-3 was created to play the sound. Click the OK button to confirm.

13. Close the Audio Tools palette by clicking in its close box.

14. Move the button to the center of the card screen. Use the appropriate method, depending on which version of the software you are using. If you are using HyperCard, click on the button to hear your sound. See Figure 4.18.

15. Choose Go ➤ Home (⌘-H) to end this exploration.
Where is the sound now? You will not find it anywhere on the disk. It is now stored as a resource within the 4.5 Recording to RAM stack on your hard disk. The sound can only be accessed by clicking on the button, or by removing the sound from the stack using some external editing program. We will use this file later, so do not throw it away just yet!

Media Tools makes it easy to record a sound to RAM using the standard record dialog box, installing it into a HyperCard stack as an snd resource, then creating a button to play the sound. The Audio Tools perform all the complex tasks behind the scenes, creating the button and writing the script for you! Next let's explore how we can use Media Tools to record a sound and save it as a disk file.
EXPLORATION 4.6: RECORDING A DISK FILE WITH THE AUDIO TOOLS

In this exercise we will learn how to record a sound, save it to disk as an AIFF file, then create a button to play it from HyperCard. Once again we will use the Audio Tools.

1. Open the exercise entitled 4.6 Recording to Disk from your hard drive.
2. Choose Media ➤ Audio Tools....
3. Select the Record to Disk option by clicking on the Disk radio button. Your screen should look like Figure 4.19.
4. Click on the tape recorder icon. You will be given a standard save dialog box, and be asked to name the sound and select a file location.

FIGURE 4.19: The Audio Tools palette for recording to disk
Working with Digital Audio

5. Set the levels as we learned above, then click Record to begin recording the sound.

6. Click Stop to end the recording process.

7. Click Play to listen to your sound. If it is acceptable, click Save. A button will be created and placed on the screen. If all goes well, you will get a prompt telling you that the sound file was saved to disk and that the button was created and installed.

8. Close the Audio Tools palette by clicking in its close box.

9. Use the appropriate method to move the button to the center of the card screen, then play your sound!

10. Choose Go ➤ Home (⌘-H) to end this exploration.

Where is the sound now? Locate it on your hard drive. It is stored as a disk file in AIFF format. The sound can now be accessed with most sound editing or multimedia programs.

Now that we’ve seen several ways of recording on the Mac, let’s look at some of the ways to edit and manipulate digital audio. Since digital audio is just a stream of stored numbers, it is very easy for the computer to change the numbers in some useful ways. Our first experiment will be to change the order of words in a digital recording.

Editing Digital Audio

One of the advantages of digital audio is that we can instantly access any point in a sound and edit it in any number of ways. For this next exercise, we will use the TurboSynth 2.2 Demo software from Digidesign to explore random access audio and digital audio editing. TurboSynth from Digidesign is a powerful digital audio processing package, providing tools for
recording, playing, editing, and synthesizing digital sounds. We will use this software for the next three explorations. You must copy the software to your hard drive before starting these explorations, as TurboSynth will not run properly from the CD-ROM. TurboSynth is designed to work like an old modular analog synthesizer, providing three audio source modules (sample, noise, and oscillators), 14 signal processing modules, and three operational tools. Figure 4.20 shows the TurboSynth tool bar with modules labeled.

EXPLORATION 4.7: EDITING DIGITAL AUDIO WITH TURBOSYNTH

You must copy the TurboSynth 2.2 Demo software to your hard drive before beginning this exercise; it will not run properly from the CD-ROM.

Our first task will be to open a sound from disk into a TurboSynth sample playback module. Here's how:

1. Launch the TurboSynth 2.2 Demo. You should see the window shown in Figure 4.21.

2. Locate the sample module; it is the second module in the third row. Click on the sample icon, then move your mouse into the TurboSynth window. Notice the cursor looks like the sample module.

3. Click in the window towards the top of the screen to place a sample module into the patch.

The term patch comes from the days of analog modular synths where patch cords were used to make connections between modules. Today we use the term to mean the collective set of parameters used to define a sound. TurboSynth follows the analog synth model very closely; we will eventually patch the output of the sample module to the input of the speaker output.
Tools
- Arrow tool (for moving and selecting objects)
- Patch cord tool (for connecting modules)
- Eraser (for deleting connections and modules)

Sound Sources
- Oscillator
- Sample
- Noise

Signal Processors
- Amplitude envelope (controls level over time)
- Filter envelope (controls timbre over time)
- Pitch envelope (controls pitch over time)
- Mixer
- Time
- Delay
- Expander
- Compressor
- Transposer
- Modulator
- Spectrum
- Inverter
- Resonator
- Diffuser
- WaveShaper

FIGURE 4.20: TurboSynth's tools and sound modules
4. Double-click the sample module. A standard file open dialog box will appear. Open the file 1-2-3.AIFF, which can be found in the Ch. 4 Digital Audio folder within the Explorations folder on your hard disk. You will see the window shown in Figure 4.22.

5. Use the scroll bar at the bottom of the window to move through the audio file. Notice there are three discrete events separated by a flat line. These are the three words, *One...Two...Three*.

6. Click and hold the mouse down on the small speaker icon in the sample module window to hear the sound. The sound continues until it finishes or until you release the mouse.
Now that we’ve opened the sound file into TurboSynth, our next task will be to edit the sound, reordering the words.

1. Find the start of the second word, Two.... Click and hold the mouse button down at the start point, as shown in Figure 4.23.

2. Drag the mouse to the right until the start of the third event. The complete second word and following silence will appear in inverse video indicating it has been selected (see Figure 4.24).

3. Check your selection by clicking and holding down the mouse button on the sample module’s speaker icon, it will play only the selected region. You should hear the word two.


5. Use the scroll bar to return to the beginning of the sound.

6. Click at the start of the sound to set the insertion point for editing.

7. Select Edit ➤ Paste (⌘-V).

8. Click in the sample window to deselect the pasted region of sound.
FIGURE 4.23: The start of the second word

FIGURE 4.24: The second word completely selected
CHAPTER 4

Working with Digital Audio

9. Click and hold the mouse down on the small speaker icon in the sample module window to again listen to the sound. It should now say, Two...One...Three.

Several points are important to consider here. First, you haven’t changed the original sound at all. You’ve simply told the computer to play a region of the sound from disk, jump to another region and play, then jump to a third point and play until the end. This is called non-destructive editing, and is the most compelling reason for editing in the digital domain. Second, digital editing is so much easier than splicing tape. Just think of how much work you would have had to do with analog tape. Finally, this method of editing can be dangerous—just think of what you can do to a recorded speech by an elected official!

We will finish this example by connecting the output of the sample module to the sound output, to complete the TurboSynth patch.

1. Close the sample window by clicking in its close box.
2. Choose the patch cord tool (it is the second tool in the first row).
3. Click in the sample module icon and drag the cord down to the output jack, then release the mouse button. The completed patch is shown in Figure 4.25.
4. Click on the speaker icon in the main tool bar to hear the sound.
5. Quit TurboSynth to complete this exploration.

**Synthesizing Sound**

Another powerful capability of TurboSynth is to generate or synthesize sounds from scratch. This is extremely useful in creating sound effects for video and multimedia projects. There is much to learn about sound design, so we will stay fairly basic in our explorations here. However, there is an overview of sound design techniques in an interactive HyperCard stack.
called MIDI 'n' Synths on the Multimedia Machine CD. It is located in the Software folder, but for this next exercise, we can open it from within the Explorations folder, through the aid of an alias file.

An alias is a System 7 feature that allows files to be opened from multiple locations on a hard drive without having to have multiple copies of the files. This is fairly important in multimedia, where files tend to be quite large, and you might have a large number of files on a CD-ROM. Alias files are simply pointers to the actual file, and take up very little space, yet are extremely helpful in organizing your files. You can easily identify alias files from "real" files because their file names are shown in italics.
EXPLORATION 4.8: SOUND DESIGN CONCEPTS

In this exercise we will examine several key sound design concepts by using an interactive HyperCard stack. We will get hands-on experience using these concepts in Exploration 4.9. For this exercise we will only navigate through a relatively small part of the information in the MIDI 'n' Synths stack, but you can peruse the rest at your convenience. We will also come back to this stack in Chapter 6, when we delve further into MIDI.

1. Open the 4.8 MIDI 'n' Synths stack. You will see the screen shown in Figure 4.26.

2. Click on the topic Synthesizers. You will be taken to a card called Synthesizers with further topics listed. The return arrow in the bottom right corner of the screen will always take you back to the last place you were, or you can Option-click on the arrow to return to the main overview screen.

FIGURE 4.26: The MIDI ‘n’ Synths Overview screen
3. Click on the topic Sound Generation. When you get to the sound generation card, the most common types of sound design techniques are listed. We will focus here on subtractive synthesis, as it is a very intuitive way to create sound effects.

4. Click on the Subtractive Synthesis topic and read about it. Notice that after the text there is an arrow pointing to the right with the legend More.... This means that this topic has further information, which may be accessed by clicking on the right arrow. You may continue clicking on these right arrows until you reach the final page (card) called Control Sources, where you will see a left arrow. Clicking on that arrow completes the study of subtractive synthesis and returns you to the Sound Generation card, where you can continue investigating this subject. Again, clicking on the return arrow will take you back to the last main topic and Option-clicking will return you to the main overview menu.

This type of interactive information retrieval is often referred to as HyperText, where clicking on a word or topic brings further explanations. Searching through information in this manner is quite rewarding, and when the information contains more than just text, as this example does (it also contains pictures), we call it HyperMedia. I prefer the term interactive multimedia, as it sounds less like nervous broadcasters!

5. Continue to browse through this material until satisfied; remember that we will come back to this stack in Chapter 6.

6. Choose Go ➤ Home (⌘-H) to end this exploration.

The main concept to learn from the above interactive study is that, when creating a sound, it is helpful to begin with a sound source, then modify it with signal processors that change the sound as it evolves over time. This is the basis of many forms of synthesis techniques, and one we will continue to explore through the next exercise.
Before we start, let's review a few terms and concepts learned in Exploration 4.8:

**Oscillator** A device that creates a repetitive, fluctuating, electronic wave, which often takes a geometric shape like a square wave or triangle wave. This is called a *waveform*, or sometimes a *waveshape*. The shape of the waveform generated is directly related to the tone color (timbre) of the sound. The oscillator is generally the raw sound source responsible for providing the original pitch (frequency), timbre (waveform), and loudness (amplitude) of the sound.

**Signal Processor** Any number of devices that change the sound in some way. Examples of these may be filters, amplifiers, pitch shifters, and time delays. By passing the original sound through a chain of these processors, we modify the sound and affect it as it evolves over time.

**Envelope** A control that affects the shape of a sound over time. This may affect the pitch, timbre, or amplitude of the sound.

**Filter** A device that changes the timbre of the sound by removing key portions called harmonics or overtones. When coupled with an envelope, you can change the timbre of the sound over time, for instance a sound may begin very bright and buzzy, then get duller over time.

**Amplifier** A device that controls the amplitude or loudness of a sound. By applying an envelope to the amplifier, we can change the loudness of a sound over time.

**Time Delay** A device that replicates the original sound, delays it for a set amount of time, then replays the sound in conjunction with the original. This is often used to add a type of echo to the sound or may be used without playing the original sound to delay the onset of the sound.

Let's use TurboSynth to experiment with these concepts, trying out each of these various modules to see how they work.

**EXPLORATION 4.9: UNDERSTANDING MODULES AND PATCHES**

In this exercise, we will return to Digidesign's TurboSynth software to further explore the concept of sound design. Unlike Exploration 4.7 where
we worked entirely within a single module to edit the sound source (the sampled recording 1-2-3), this time we will work with a number of different modules to see and hear how they work.

1. Launch the TurboSynth 2.2 Demo software. You will see a blank patch window.

2. Click on the oscillator tool (it’s the first tool in the third row) then move your mouse into the patch window and click at the top left portion of the screen to place an oscillator module into the patch.

3. Double-click on the oscillator to open its editing window, as shown in Figure 4.27. This illustration shows labels for the various parts of the oscillator’s editing window.

4. Click on the sine wave, the first tool in the third row, then move the mouse into the oscillator window and click at the far left to place the sine wave, as shown in Figure 4.28.

5. Click on the speaker icon to play this waveform.

6. Click on the sine wave in the oscillator window to select it, then press delete. This removes the sine wave from the oscillator window.

7. Repeat steps 4 through 6 with each of the waveforms to audition each wave’s sound.

<table>
<thead>
<tr>
<th>Tools</th>
<th>Waveforms</th>
</tr>
</thead>
<tbody>
<tr>
<td>Waveform view</td>
<td>Sine</td>
</tr>
<tr>
<td>Pointer</td>
<td>Triangle</td>
</tr>
<tr>
<td>Eraser</td>
<td>Sawtooth</td>
</tr>
<tr>
<td>Harmonic view</td>
<td>Square</td>
</tr>
<tr>
<td>Get sound info</td>
<td>Altered sine</td>
</tr>
<tr>
<td>Play sound</td>
<td>Altered square</td>
</tr>
</tbody>
</table>

Non-standard waveforms
Open waveform file

FIGURE 4.27: The annotated oscillator editing window
We might try to categorize the four most basic geometric waveforms by describing their sounds as follows:

<table>
<thead>
<tr>
<th>Wave</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sine wave</td>
<td>Dull, simple</td>
</tr>
<tr>
<td>Triangle wave</td>
<td>Plain, flute-like</td>
</tr>
<tr>
<td>Sawtooth wave</td>
<td>Buzzy, string-like</td>
</tr>
<tr>
<td>Square wave</td>
<td>Hollow, clarinet-like</td>
</tr>
</tbody>
</table>

Let's continue our exploration by choosing a sawtooth wave, then passing the oscillator through several signal processors to hear how they affect the sound.

1. Place a sawtooth wave into the oscillator window using the techniques learned above, then close the oscillator window by clicking in its close box.

2. Select the filter tool, the second tool in the fourth row, then move your mouse into the patch window and click below the oscillator module to place the filter.

3. Click on the patch cord tool, the second tool in the top row, then click in the oscillator module and drag down to the filter module. Release the mouse button while inside the filter module. This will connect the output of the oscillator into the input of the filter, as shown in Figure 4.29.
4. Select the pointer tool, then double-click on the filter module to open its editing window.

5. Click on the speaker icon to play the sound. It should be the same as the oscillator's playback, as we've not yet begun the filtering process. When this module is first opened, a flat line envelope shape is displayed as the filter does not change over time, and the no portion of the sound is being filtered. See Figure 4.30 for an annotated view of the filter window.

6. Click once on the first envelope tool—the first icon in the fifth row down. This tool lowers the envelope amplitude slightly, removing some of the higher components (harmonics) of the sound.

**FIGURE 4.29:** The oscillator patched into the filter
FIGURE 4.30: The annotated filter window

7. Click on the speaker to hear the sound. It is less buzzy. Use the Edit ➤ Undo command to remove the filtering you just added so you can compare the two sounds. The command toggles between Undo and Redo so you can go back and forth between the two sounds.

8. Continue lowering the filter amplitude and listening to the effect by clicking on the first envelope tool. Each click results in a slightly less buzzy, more mellow sound.

You might think of the filter like a window shade on a sunny day. When the window shade is fully open, all of the light comes through the window. As you pull the shade down, less light is able to enter until the shade is completely down and no light comes through the window. So it is with the filter; when it is fully open, the complete sound comes through. As we close the filter, less of the high components of the sound come through. If we've a perfect filter, when it is completely closed, no sound will come through. This type of filter is sometimes called a low pass filter, as the low frequency components of the sound pass through and the high harmonics are filtered away.
Let's continue our investigations by experimenting with different envelope shapes for the filter.

1. Click on the first envelope shape in the filter window; it is in the third row.

2. Click on the speaker icon to hear the sound. The filter has a fast beginning (attack); it rises to full brilliance quickly. The filter then rapidly falls to a mid-level point (we call this decay), holds there (sustains), then quickly closes (releases) at the end. This type of envelope shape is called an ADSR indicating the various stages in the event: Attack, Decay, Sustain, and Release. The times for each of these stages can be altered by dragging the envelope handles (the small square points) forward or backward in the time line.

3. Click on the second envelope shape. Notice that the new shape replaces the former envelope in the filter window.

4. Click on the speaker icon to hear this envelope's effect. It begins at full brightness, then gradually gets duller over time.

5. Click on the third envelope shape, then listen to its effect. It begins dull, gradually gets brighter, then returns to dullness again.

6. Click on the remaining envelope shapes and listen to the sounds.

7. When you've tried all the envelope shapes, choose the third shape in the third row as our selection, then close the filter module.

Let's continue investigating TurboSynth modules by patching the filter output to the amplifier's input. Here's how:

1. Click on the Amplifier module in the tool bar of the main window. It is the first tool in the fourth row. Move your mouse into the patch window and click below the filter to place the amplifier module into the patch.

2. Choose the patch cord tool, click in the filter module, drag down into the amplifier module, and release the mouse. Your screen should look like Figure 4.31.

3. Select the pointer tool, then double-click on the amplifier module to open its editing window. Note that the amplifier window looks remarkably similar to the filter window. This is because the means of changing loudness over time is the same as changing timbre over
time—we use envelopes, and there is no difference in operation between an amplitude envelope (one that changes loudness) and a filter envelope (one that changes timbre).

4. Use the same techniques learned above for filters to experiment with different amplitude envelope shapes. Note that we still hear the changes in timbre as we add the changes to loudness.

5. Choose the same envelope shape (the third shape in the third row) that we chose for the filter. This helps accentuate the shape of change.

6. Close the amplifier window by clicking in its close box to complete our investigation of the amplifier module.
Let's experiment with one more signal processor—the time delay module.

1. Place the time delay module into the patch using the techniques learned above. The time delay is the first icon in the fifth row of the main toolbar.

2. Connect the output of the amplifier to the input of the time delay using the patch cord tool.

3. Using the pointer tool, double-click on the time delay module to open its editing window. Figure 4.32 shows the time delay editing window.

The time delay has three main parameters to be adjusted: the delay time, feedback amount, and mix level. The delay time is the amount of time that passes before the input sound is played. This is split into two parameter sliders: Course, which adjusts the time in 10 millisecond (ms) increments (there are 1000 ms in a second), and Fine, which adjusts the delay in tenths of a millisecond. Feedback refers to how much the delayed sound is fed back into the module, creating additional repetitions of the delay. The higher this percentage setting, the greater the amplitude of the repetitions and the longer the repetitions occur. The mix level refers to how much of the delayed signal is output with the original signal. The higher this number, the more the delayed signal is mixed with the original sound.

---

**FIGURE 4.32:** The time delay editing window
Let's continue by exploring the time delay parameters.

1. Set the delay time to 250 ms (a quarter of a second) using the coarse slider.
2. Set the feedback to 50%.
3. Set the mix level to 100%.
4. Click on the speaker icon to hear the sound. This setting gives an echo type of effect to the sound.
5. Experiment with a variety of settings to understand some of the possibilities for using this module. When done, reset the time delay module to the settings given above, then close the module by clicking in its close box.
6. Use the patch cord tool to connect the output of the time delay module into the sound output (the jack at the bottom of the screen). This will allow us to play the sound by clicking on the speaker icon in the main toolbar. The finished patch is shown in Figure 4.33.

We now have a basic understanding of the building-block, modular concept used to create sounds using TurboSynth. Let's examine a more complex patch that uses these same modules, to get a better idea of how each of these modules affect the total sound.

1. Locate and open the file 4.9 AnnounceChime. It is found in the Ch. 4 Digital Audio folder within the Explorations folder on your hard disk. You should see the screen shown in Figure 4.34.
2. Click on the speaker icon to hear this sound. It is a simple chime-like sound effect.
3. Double-click on the first oscillator module at the top left of your screen.
4. Click on the speaker icon within the oscillator module to hear this component's contribution to the sound. Note that this waveform is the sawtooth wave, and its sound is quite buzzy.
5. Close the oscillator window and again click on the main speaker icon to hear the entire patch again. We will continue to use this technique of switching between the individual module speaker and the patch speaker throughout the remainder of this exercise. This will help you hear how each module contributes to the entire sound effect.
6. Open the second oscillator module and listen to it. It is a square wave and is less buzzy than the first oscillator. Close the second oscillator window to return to the main patch window.

Note that the two oscillators are combined by the mixer module in the middle of the screen. Oscillator 1 is filtered, oscillator 2 goes to a module that changes its pitch, is then filtered, and finally is sent to a delay module before the two oscillators are mixed together. Let's follow each step of the path that each oscillator signal follows.

1. Following the path of oscillator 1 to the mixer, we pass through a filter module. Open the filter window for oscillator 1. You will see that
its envelope is a steady rising line, meaning that the sound will gradually get brighter over time. Click the speaker icon in the filter window to listen to this effect.

2. Close the filter window for oscillator 1 and return to the main patch window. The next step along the path for this oscillator is the mixer, so let's move to oscillator 2's signal path.
3. Following the right side of the oscillator chain, oscillator 2 goes to a pitch shifter module. This is a new module for us, one that allows us to tune the pitch of the oscillator. Double-click the pitch shifter module to open its window. Using the Fine slider, we can tune the pitch of the oscillator by cents; there are 100 cents to a semitone (half-step), which is the smallest musical increment in western music. Using the Coarse slider we can transpose the pitch of the oscillator by semitones. You will see that this module has transposed the pitch up by 7 semitones or, in more musical terms, up an interval of a perfect fifth. Click on the speaker to hear the effect of this module. Return to the main screen and compare this module to the main patch.

4. Oscillator 2 next moves to a filter module. Open the filter window and note the envelope shape: the sound gets brighter quickly, then duller again.

5. The next module in oscillator 2's path is a time delay. When you open its window you will see that there is a delay time of 125 ms. As there is no feedback, the delay occurs only once. You may not notice it in the context of this module, but it is the reason the higher pitch sound enters slightly later than the first pitch. Return to the main screen to hear this.

6. Let's now move to the mixer module, where the two oscillators' outputs are mixed together. Open the mix window, which is shown in Figure 4.35.
7. Experiment with moving the sliders up and down, hearing the effect of mixing the two oscillators at a variety of levels. Filter-1 refers to the output of filter 1, which has oscillator 1 as its source. Delay-1 is the final stage of the oscillator 2 chain.

8. Returning to the main screen, there are three more modules in the chain: two amplifiers and another time delay. Open the first amplifier and examine its envelope. You can see that it starts at full volume, decays slightly, then abruptly falls to silence. Listen to this module by clicking on its speaker icon.

9. Open the delay module. The settings here are similar to the settings of the echo effect we created in our earlier exploration. Listen to this effect.

10. The final module is another amplitude envelope. Open the window for this module. This envelope begins at full volume, stays fairly high, then decays to silence. You will need to scroll through the envelope to see its full shape; use the scroll bar at the bottom of the module's window for this. Listen to this module. This is the same output as that of the main screen. The final connection to the output jack allows us to preview the sound by clicking on the main speaker icon.

11. Quit TurboSynth to complete this exploration.

Now that we've explored some of TurboSynth's signal generating and processing modules, investigated an existing patch, and explored how the various modules affect sound, let's try building a complete sound effect from scratch.

**EXPLORATION 4.10: CREATING A PATCH**

In this exercise, we will create a space-like sound effect by patching together a number of TurboSynth modules. This will give us practical experience in designing sounds that could be used as sound effects in multimedia projects. The sound we create here will also serve as material for an exercise in creating System 7 alert sounds.

You may wish to return to Figure 4.20 above to review the TurboSynth tools and modules.
Our first task will be to set up our basic sound source—an oscillator. Follow these steps:

1. Launch the TurboSynth 2.2 Demo software. We will begin by choosing a sound source—an oscillator.
2. Place an oscillator module into the patch window using the techniques learned above.
3. Open the oscillator module by double-clicking on it. Notice that when a new oscillator is placed, there is no waveform in the window.
4. Place a sawtooth waveform into the oscillator window at time 0.000 seconds.
5. Play the raw sawtooth waveform by clicking on the speaker icon.
6. Let’s set the pitch of the oscillator two octaves higher. Click on the \( i \) button (the international “information” icon). Set the frequency to 880.000 Hz instead of 220.000. This will produce a pitch of A, two octaves above the initial setting. Click OK to save the new settings.
7. Listen to the oscillator to confirm the new pitch setting.
8. Close the oscillator window by clicking in its close box.

Now let’s place a filter into the patch to change the timbre of the sound:

1. Place a filter module below the oscillator by clicking on the filter icon, then clicking in the patch window.
2. Connect the output of the oscillator to the filter input using the patch cord tool.
3. Open the filter module. We want to place an envelope in the window to control the change in timbre over time. The effect we want is a gradual increase in brightness, lasting about one quarter of a second, becoming gradually duller by one half second. To do this place the third envelope selection in the window.
4. We now need to adjust the timing of the envelope. Click on the high point of the envelope shape (found at 0.500 seconds) and drag it to about the 0.250 second point, then release the mouse. Your screen should look like Figure 4.36.
5. Similarly, drag the end point of the filter envelope so the low point occurs at approximately 0.500 seconds.
6. Click on the speaker icon to hear the filter envelope.
7. Close the filter module by clicking in its close box.

Now let's add an envelope to control the pitch of the sound, to create a special warbling effect:

1. Place a pitch envelope module into the patch; it's the second module in the sixth row of the toolbar.
2. Using the patch cord tool, connect the output from the filter module to the pitch envelope module's input.
3. Open the pitch envelope window and place a steadily falling envelope, using the second icon in the third row. Listen to the effect—a smooth falling pitch. We want to make a number of breaks in this fall in order to create a warbling effect.
4. Place three consecutive points on the envelope band as shown in Figure 4.37.
5. Drag the middle point of these three down to the −12 level as shown in Figure 4.38. This will create a small chirp in the fall.
FIGURE 4.37: Three points placed in the pitch envelope band

FIGURE 4.38: The middle point pulled down
6. Repeat steps 4 and 5, above, at approximately 100 ms intervals to finish the warbling effect. Don’t worry about being exact; the effect will not suffer if the warbles are not placed at perfectly even intervals. Listen to the effect when you’ve added all the points to the envelope, then close this module.

Now let’s go for the space effect by adding a delay. Although it may seem simplistic, adding an echo to a sound seems to connote “space” to most listeners.

1. Place a time delay module after the pitch envelope in the patch window and connect the modules using the patch cord tool.

2. Set the delay module for a 200 ms delay with a 50% feedback level.

3. Let’s add a second delay to make the sound even more ambient and space-like. Place another delay module to the right of the first, then, using the patch cord tool, drag another connection from the pitch envelope to the second delay. These delays are said to be in parallel with each other. See Figure 4.39 for the proper configuration.

FIGURE 4.39: The parallel delay modules
4. Open the second delay module and set it for a 75 ms delay time (you will need to use both the coarse and fine sliders) and a feedback level of 50%. Listen to this module by clicking on its speaker icon, then close the delay module by clicking in its close box.

5. Now we will mix the two delays together using a mixer module—the first icon in the second row of the toolbar. Place the mixer module into the patch window below the two delays, then connect both delays to the mixer input using the patch cord tool.

6. Open the mixer window and set the levels to 75% and 100% for delay-1 and delay-2 respectively. Listen to this module then close the mixer window.

7. Connect the mixer output to the output jack so we can hear the sound by clicking on the speaker icon in the main screen. Your finished patch should now look like Figure 4.40.

8. Quit TurboSynth to end this exploration.

Using the full version of TurboSynth, we could save the file as a patch document, and also save the output as a soundfile in either Sound Designer or AIFF file formats. Since you can’t do this with the demo version, I have saved my versions for you. In the Ch. 4 Digital Audio folder within the Explorations folder you will find both the patch file and the soundfile. The patch file is called 4.10 Space Noise and the soundfile is entitled TurboSynth Space Noise. You can open the 4.10 Space Noise file with the TurboSynth 2.2 Demo software and compare it to the example you created. We will use the soundfile in our next exploration, but you could also import it into Adobe Premier to use it as a sound effect for video.

Making System 7 Alert Sounds

Our final exploration will be to convert a soundfile into a System 7 alert sound, otherwise known as a system beep. I have included a piece of software called sndConverter by Joe Zobkiw on the CD-ROM. This application will extract a sound resource from a file and create a System 7-savvy alert sound. Not all soundfiles have sound resources within them, but we have access to several that do, so we will transform these into system beeps.
EXPLORATION 4.11: CONVERTING A SOUND TO A SYSTEM BEEP

In this exercise we will create two system beeps that will play from the Finder when double-clicked, using sounds we've made in previous explorations.

1. Launch the sndConverter software. It is located in the Software folder on the Multimedia Machine CD. You will see a very simple dialog box, shown in Figure 4.41.
2. The instructions are found at the bottom of the screen; basically just select the sound you want to convert. Locate your completed Exploration 4.5 Recording to RAM stack. Select it in the dialog box, then click on the Convert button. You will see the alert dialog box shown in Figure 4.42.

3. Choose Extract from the alert dialog box, then name and save the file. I accepted the default snd title, **1-2-3**. When ready, click Save.

4. sndConverter now tells you that it has created a System 7 alert sound from the selected file; click OK to acknowledge. You are returned to the first dialog box so you can continue this process.

5. This time select the TurboSynth Space Noise file located in the Ch. 4 Digital Audio folder within the Explorations folder on your hard disk.

6. Repeat steps 3 and 4 above with the TurboSynth Space Noise file.

7. When complete, click Quit to quit the application.
Working with Digital Audio

8. Locate the converted files and try them out by double-clicking on them. They are now fully compatible, System 7 alert sounds and may be dragged into your System file to be used as system beeps.

In this chapter we've had the opportunity to experiment with recording, editing, synthesizing, and playing back digital audio in a variety of environments. Hopefully, you now have a good sense of the many ways we can use digital audio, and are beginning to get a grasp of the available tools. Let's move on to further explore ways we can use audio from CD.
Working with Audio from CDs

In Chapter 2 we touched on the options for playing audio from CD. We played a CD audio track from the Multimedia Machine CD by clicking on a button in HyperCard. We also saw how HyperCard buttons could provide random access to any of the audio on the CD. In this chapter we’ll further explore the use of audio from CD in multimedia, focusing on ways to control the playback of standard audio CDs from a CD-ROM player. We will also explore ways of converting audio from CDs into QuickTime audio tracks that can be exported as AIFF format digital audio tracks.

CD Audio as Music for Multimedia

The most obvious role for CD audio in multimedia is as the soundtrack for some visual media. Working with mixed media offers a number of possibilities as well as posing a few problems.

One issue is defining the section of music to play from the CD. This is usually done by setting start and end points in the music and having the computer play the defined region as the soundtrack.
### Controlling the CD Player from HyperCard

There are many good uses for CD audio in the multimedia world. HyperCard is an excellent environment for developing and displaying mixed media presentations that use CD audio. Media Tools augments HyperCard with a powerful tool set for controlling a CD-ROM, called the CD Tools. This next exploration will introduce these tools, giving you hands-on experience using CD audio in mixed media environments.

### Using the CD Tools

The CD Tools give you flexible control over a CD-ROM player; they allow you to specify playback regions, and to create buttons that, when clicked, play the selected regions. In our next experiment we'll explore the various controls and features of the CD Tools.

#### EXPLORATION 5.1: WORKING WITH THE CD TOOLS

This exercise will demonstrate how the CD Tools control a CD-ROM player through HyperCard, and how we can use these tools to access audio from CD.
1. Open the 5.1 Working with CD Tools stack.

2. Choose Media >> CD Tools.... You will see the CD Region Builder palette, shown in Figure 5.1.

The current times are shown in the top of the palette in track:minute:second:frame format, where seconds are divided into 75 frames, numbered 0–74. Most programs don’t use the track number to access the CD by frame, but use only the last three components. These numbers are usually given in absolute time code, that is, time measured in minutes, seconds, and frames from the beginning of the CD. Sometimes CD players offer a relative time view, which shows the elapsed time from the start of a particular track. All of the CD Tools timings are given in absolute time.

FIGURE 5.1: The CD Tools Region Builder palette
The keypad in the center of the controller features the following controls, starting at the top row first button (labeled 1:1, meaning row 1 column 1):

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scan Back (1:1)</td>
<td>Causes the CD player to continuously scan backwards at high speed until the mouse is clicked a second time (note that some CD players ignore this command)</td>
</tr>
<tr>
<td>Play (1:2)</td>
<td>Plays audio from the CD beginning at the current time point</td>
</tr>
<tr>
<td>Scan Forward (1:3)</td>
<td>Causes the CD player to continuously scan forward at high speed until the mouse is clicked a second time (note again that some CD players ignore this command)</td>
</tr>
<tr>
<td>Previous Track (2:1)</td>
<td>Skips back to the last track and begins playing audio from the CD</td>
</tr>
<tr>
<td>Stop (2:2)</td>
<td>Pauses the CD without resetting the time</td>
</tr>
<tr>
<td>Next Track (2:3)</td>
<td>Skips ahead to the next track and begins playing audio from the CD</td>
</tr>
<tr>
<td>Capture Start Time (3:1)</td>
<td>Captures the current time information and places it into the start time fields for editing</td>
</tr>
<tr>
<td>Eject (3:2)</td>
<td>Closes the CD driver, resets time to 00:00:00:00, and ejects the CD from the drive</td>
</tr>
<tr>
<td>Capture End Time (3:3)</td>
<td>Captures the current time information and places it into the end time fields for editing</td>
</tr>
</tbody>
</table>

Below the controls are two sets of fields with triangular buttons to their left. These are the start and end time fields (minutes, seconds, and frames fields for each). The triangle buttons are play buttons and are used for fine tuning the timings. You can type directly into these fields to edit the timings with precision. As you can search for any specific frame on the CD, these timings are said to be frame accurate.

The next area contains two buttons for playing the selected region (from start point to end point) and for creating a button that, when clicked, will play the selected region. Finally, there's a search button that allows you to skip directly to the beginning of a specified track.
3. Click on the Play button to play back the CD.
4. Click on the Next Track button to move to the next track.
5. Click on the Previous Track button to return to the previous track.
6. Click on the Search... button. The CD Tools tell you the number of audio tracks on this CD, allowing you to enter a number for the track you wish to skip to. See Figure 5.2.
7. Enter 3 and click OK. The CD player will skip to track 3 and begin playing.

Now that we've explored the features of the Region Builder palette, let's create some buttons to play specified regions of music from the CD.

1. Start playing again at the first audio track. Click on the Capture Start Time button.

**NOTE**
The time isn't captured until the mouse button is released. This makes it possible to click and hold on the capture buttons and wait for the appropriate time to let up the mouse button. You may find this technique faster and more accurate in time grabs.

![FIGURE 5.2: The CD Tools Search... dialog box](image_url)
2. Allow the CD to play for a bit, then click on the Capture End Time button.

3. Click on the Stop button to end playback.

4. Click on the Play Region button, as shown in Figure 5.3.

5. Fine tune the start point by adjusting the timings in the minutes, seconds, and frames fields for the start times.

6. Click on the Play From Start Point button—the small triangle to the left of the start time fields. This will let you audition the exact start point.

FIGURE 5.3: The Play Region button
Controlling the CD Player from HyperCard

Remember larger numbers indicate later start points (those further into the piece); smaller numbers are earlier points in time.

7. Use the Stop button in the main control area to pause the CD.
8. Repeat steps 5 and 6 to fine tune the end times.
9. Test the complete region again by clicking the Play Region button.
10. When satisfied with the region settings, click on the Button button to create a button that will play the selected region. You will be asked to name the button; choose a descriptive name, for instance First phrase, then click OK.
11. You will be alerted that the button was created successfully; click OK to acknowledge.
12. Move the button to a good spot on the screen, then test the play-region button you’ve created.
13. Choose Go > Home (⌘-H) to end this exploration.

The CD Tools’ Region Builder palette doesn’t need to be open for this button to work. However, you must have Media Tools installed on your computer to use this stack. Also note that you can stop playback by clicking again on the button while the region is playing.

Define a few more regions, creating a button to play each region. This is precisely how example 2.7 in Chapter 2 was created. CD Tools makes it very easy to create stacks that offer complete control over CD audio playback.

Let’s now explore how we can play regions in a multimedia context by creating a slide show synchronized to music playing from a CD track.
Adding CD Audio to a Slide Show

Another useful tool provided on the Multimedia Machine CD is the Scroll-It stack. This stack scrolls cards synchronously with music. This has a number of potential uses, including scrolling music notation with audio playback or changing slides (pictures) in time with music. We will use the native Scroll-It stack later in Chapter 7 of this book, but our next exploration will use a simplified variation on the stack, optimized for creating a slide show that plays CD audio. This exploration already has a set of pictures installed in the stack, and our task will be to synchronize the music playback from CD. When we use the native Scroll-It stack in Chapter 7, we'll learn to import pictures, too.

EXPLORATION 5.2: SYNCHRONIZING SLIDES TO MUSIC FROM CD

Although this exercise appears to be a stand-alone application, it's built upon the Media Tools and uses the CD Tools commands behind the scenes. Exploration 5.2 uses a modified version of the Scroll-It stack found on the Multimedia Machine CD, but altered to allow us access only to CD audio, and with a number of pictures set to be displayed on separate cards. In this exercise we'll instruct HyperCard to change pictures in time to music to create a synchronized slide show.

1. Open the Exploration 5.2 CD Slide Show stack. You will see the first slide on card 1 (Figure 5.4).

2. Navigate through the six slides by pressing the right and left arrow keys (↔, →). Each time you press an arrow key, you'll go to either the next (→) or previous (←) card in the stack. Each card is numbered (1–6) for your convenience.

3. Return to card 1. You can use the arrow keys or type ♂-1.

4. Notice there's a new menu—Scroll. The options are shown below in Figure 5.5.

5. Select Scroll ▶ Fields. Two blank fields will appear at the left and right bottom corners of the card (Figure 5.6).
Controlling the CD Player from HyperCard

FIGURE 5.4: The first slide in the 5.3 CD Slide Show stack

FIGURE 5.5: The Scroll menu
These two text fields are "locked". That is, you can't type directly into them. In HyperCard, when a field is locked, it can act like a button that performs an action. These fields do, in fact, perform actions. When you click on one of these fields, it calls a CD Tools routine, gets the current CD time, and places it into the clicked field. This allows us to set the region of music that plays while the given card is shown. When the end time is reached, a message is sent to HyperCard to go on to the next card.

6. Select Scroll ➤ Transport Controls.... A small palette, shown in Figure 5.7, will appear in the upper-left area of the screen. This palette provides Play, Stop, Next Track, Previous Track, and Eject buttons, all of which call CD Tools routines to perform their functions.
Now that we've examined the basic functions of this stack, let's synchronize the slides to music on the CD.

1. Be sure you're at the first slide. Return to card 1 using any of the navigation techniques we discussed above.
2. Press the Play button to begin CD playback.
3. Use the Next Track button to move to the third music track.
4. As soon as the music begins, click in the bottom left (start time) field. The current time will be placed into the field.

   This timing information can be edited later, so don't worry about perfect accuracy at this point.

5. Wait for an appropriate phrase point before moving to the next slide. At the desired time, click in the bottom right (end time) field. The current time will be entered, the slide will advance, and the time will appear in the next slide's start time field.
6. Repeat step 5 for each of the next slides until you've reached slide 6. Click in the end time for slide 6 at the point you wish the music to stop. This will mark the end of the slide show.
7. Click on the Stop button in the floating transport control palette.
8. Click in the close box of the transport control palette to put it away.
9. If you aren't at slide 1, navigate there using any of the methods described above.
10. Click on the CD icon at the top right corner of your screen. The slide show will begin. When slide 6 is displayed, the music will stop at the time shown in the end time field.

11. Choose Go ➤ Home (***H) to end this exploration.

The speed at which the cards advance depends on your computer and hard drive. The faster your processor and hard disk, the quicker the slides will open. If your computer opens the pictures too slowly to synchronize with the audio playback, you might want to edit the timings, making the end times earlier than you had chosen. You can edit any of the times in the following ways:

- To edit the current time in a field, hold down the Shift and Option keys, then click in the field. You will be given a dialog box with the current times for editing. The time is given as minutes, seconds, and frames, separated by commas. HyperCard treats each of these comma-delimited numbers as separate items, so be sure you enter the new timings with this exact format. See Figure 5.8.

- To edit the fields while the music is playing, simply click in an end time field as you did during the original process.

- To completely clear a field, hold the Option key (without the Shift key) and click in the field; it will be cleared.

![Figure 5.8: The edit field timings dialog box](image)
You can also clear all the fields by choosing Scroll ➤ Clear Timings. After confirming that you really want to clear all the timing information, the time fields in the stack will be erased.

Try using music from your audio CD collection as material for this slide show. This stack (and all of the CD Tools routines) will work with any standard audio CD. What type of music works best with these pictures? What mood do the images suggest, and what music helps underscore that mood? These questions raise the issue of aesthetics, which we'll discuss in more detail in Chapter 7. Hopefully, this exercise will have sparked some thought about using music from CD as background for simple mixed media projects. If you're feeling inspired, experiment on your own with placing different music from your audio CD collection to the pictures in this exercise.

Let's now look at other ways of using audio from CDs.

**Importing QuickTime Movie Soundtracks from Audio CDs**

QuickTime and Sound Manager (both on the Multimedia Machine CD and installed in Chapter 1) work together to get more out of our CD-ROM players by using audio tracks from standard CDs as QuickTime movie soundtracks. With these system extensions, we can import the audio from a standard audio CD as a digital audio file at a variety of sample rates and resolutions, without having to re-sample the music or convert from analog to digital. This is a powerful way to use audio from CD as digital audio in situations where multimedia delivery from a CD-ROM drive is unavailable. This use requires ample hard drive space, but also allows us to access the editing tools we experimented with in Chapter 4. Let's explore accessing sound from audio CD as digital audio data.
EXPLORATION 5.3: CONVERTING AUDIO CDs TO QUICKTIME SOUNDTRENKES

The first step in accessing the sound from an audio CD is to convert the audio track to a QuickTime movie. Since this will be handled at the system level by QuickTime and Sound Manager, we can use any QuickTime application. There are two applications up to the task on the Multimedia Machine CD—MoviePlayer and Adobe Premier, but the supplied version of Adobe Premier doesn't allow us to save files, so we'll use MoviePlayer instead.

You must drag a copy of the MoviePlayer application from the Multimedia Machine CD to your hard drive, as you will be placing a standard audio CD into your CD-ROM drive for this exploration. We should also note that the NEC drives do not support the importing of CD tracks as QuickTime movies. If your drive does not support this feature, contact the manufacturer. Even if your drive doesn't support this feature, you can follow along with the process, as I will provide you with my saved file to use in later explorations.

1. With any standard audio CD in your CD-ROM drive and visible on the desktop, open MoviePlayer from your hard drive.

2. Choose File ➤ Open....

3. Click on the Desktop button to view the available drives on your computer. You should see the audio CD listed in the Desktop window.

4. Double-click on the audio CD to open its directory. You should see audio tracks listed as Track 1, Track 2, etc.

5. Select Track 1 by clicking on it in the window.

6. Click on the Convert... button. You will see the audio conversion dialog box, shown in Figure 5.9.

7. Select a location on your hard drive to save the converted audio file, and name it Converted Audio 1, but don't click on the Save button yet!

8. Click on the Options... button. You will see the Audio CD Import Options dialog box, shown in Figure 5.10.
The Audio CD Import Options dialog box allows you to select the sample rate and resolution for the imported digital audio file, as well as letting you choose to save it as either a stereo or mono audio file. You can also choose to import only a region of audio, and the dialog box provides a simple tool for setting the start and end points for the selected region.

We will now set the parameters for the import file. To conserve disk space we'll save the file in mono format and use a low sample rate with 8-bit resolution. If you can play back stereo at higher sample rates and resolutions, and have ample disk space, you may instead elect higher quality settings. You should have enough understanding from our work in Chapters 2 and 4 to make these determinations yourself.
FIGURE 5.10: The Audio CD Import Options dialog box

1. Set the sample rate to 22.050 kHz. This is the default. Pull down the menu to see the other available options—44.100 kHz and 11.025 kHz.

2. Click on the 8 bit radio button to choose that sample resolution. Depending on your hardware and Sound control panel settings, 8 bit may be the default resolution.

3. Click the Mono radio button to save the file in monophonic format.
Figure 5.11 explains the various components of the Audio Selection portion of the Audio CD Import Options dialog box. Review these components on your screen before continuing to step 4.

4. Set the start point for your region by moving the Start Point Slider Thumb. You can audition the start point by moving the Play Pointer to the Start Point Thumb then clicking on the Play button. You can stop playback by clicking on the Stop button.

5. Set the end point for your region by moving the End Point Slider Thumb. You can audition the end point by moving the Play Pointer to a point just before the end point and clicking on the Play button. Playback will stop at the end point.

![Diagram of Audio Selection components](image_url)

**Figure 5.11:** The Audio Selection components explained
You can use the Start and End fields to fine tune the timings as in the CD Tools, except that here the timings are shown in a single field. The up and down arrows advance or rewind the timings by 2 frames each click. To edit to the single frame you must select the number and type the desired value.

6. Audition the complete region by moving the Play Pointer to the Start Point Thumb then clicking on the Play button. You can stop playback by clicking on the Stop button.

7. When you're satisfied with the region, click OK to store it and return to the Save file dialog box.

8. Click on the Save button to import. You will see the progress window, shown in Figure 5.12. When the import process is complete, the sound file will appear in a QuickTime movie window as an audio-only movie. See Figure 5.13.

9. Play the audio movie track by clicking on the Play button.

You can use the various transport controls to move around this new audio movie file. Remember that the space bar will toggle playback and pause modes, and the arrow keys will move forward and backward in the file.

10. Quit MoviePlayer to end this exploration.

FIGURE 5.12: The Importing Movie progress dialog box
The audio file is now in QuickTime movie format. To edit the file at this point we need to be in a QuickTime editing environment. We may also want to be able to work with the file in audio editing environments, so we'll need to convert the file to AIFF format. We will explore both of these options in the next several exercises.

I've provided the example that I created in the above exercise on the Multimedia Machine CD. It's located in the AIFFs folder within the Music folder on the Multimedia Machine CD. To make it more accessible for these exercises, there's also an alias file located in the Ch.5 CD Audio folder within the Explorations folder on your hard drive. You can use it as material for your work in subsequent examples if you're low on available disk space and need to delete the file we just created.

**EXPLORATION 5.4: EDITING THE MUSIC AS A QUICKTIME MOVIE IN PREMIER**

In this exercise we'll open the file we created in Exploration 5.3 in Adobe Premier and explore the various editing options available to us in that environment.

1. If you haven't already done so, exit MoviePlayer by choosing File > Quit (⌘-Q).
2. Open Adobe Premier.
3. Choose File > Import > File... (⌘-I).
4. Locate and open the Converted Audio 1 file we just created. You may instead use the file provided on the Multimedia Machine CD as mentioned above. It will open into the Project window.
5. Open the Clip window for this file by double-clicking on its icon in the Project window. You will see the window shown in Figure 5.14.
6. Note that in this window you can set start and end points, place markers, and play the file. If necessary, review these operations from Chapter 3.

7. Close the Clip window by clicking in its close box.

8. Drag the icon for the file from the Project window into Audio Track A of the Construction window. Your Construction window should now look something like Figure 5.15.

9. In this window, you can set a volume envelope for the file, cut sections out, and apply audio filters. We’ve seen how to create audio fades and have removed sections with the razor blade tool in Chapter 3. Let’s do a quick experiment with audio filters. With the mouse in Audio Track A, hold down the Option key and click and hold down the mouse. When the Filters... menu appears, select it to view the Audio Filters window.

10. Drag the Backwards [Audio] filter into the Current list so your window looks like Figure 5.16.

11. Click on the OK button to add the filter to the audio track.

12. Zoom out to a view resolution of 2 seconds in the Construction window.

13. Drag the Preview selection bar so that the entire audio file is selected.
Importing QuickTime Movie Soundtracks from Audio CDs

**FIGURE 5.15:** The clip in the Premier Construction window

**FIGURE 5.16:** The Backwards [Audio] filter in the Current list
Working with Audios from CDs

14. Choose Construction ➤ Preview or press Enter.

15. In a few moments you will hear the audio file with the Backwards filter applied.

Premier offers a few basic audio editing tools, but we may wish to work in a more complete audio editing environment. For this we need to have the file in AIFF format. The next exercise will show us this conversion.

**EXPLORATION 5.5: CONVERTING QUICKTIME SOUNDTRACKS TO AIFF FILES**

In this exercise we'll learn how to convert audio files from the QuickTime movie format into the AIFF format. Unfortunately, the supplied demo version of Adobe Premier won't allow us to save files, so you can follow along through step 4 on screen, then use the text and screen shots in this book to finish the exercise.

1. If you still have Premier open from the last exploration, close the current project by clicking in the Project window's close box. Then, choose File ➤ New Project (⌘-N). If you've already quit the program, open it again so a new project window is showing.

2. Import the Converted Audio 1 file from the Multimedia Machine CD, using the techniques learned above.

3. Open the Clip window for this file by double-clicking on its icon in the Project window.

4. With the Clip window open, select the File ➤ Export ➤ AIFF Audio File..., as shown in Figure 5.17. You will be prompted that the demo version of Adobe Premier doesn't support this feature. If you had the full version, you would instead see the AIFF conversion dialog box shown in Figure 5.18.

**NOTE**

If you had the full version you would perform the following steps on your computer. We will still list each step here, in case you do have the full version, or so, if you later purchase it and wish to return to this exercise, you will be able to follow along. We will provide screen shots for each step to show you what you would see if you could follow along on screen.
5. Pull down the Audio Rate menu. You will see the following available sample rates from which to choose: 5 kHz, 11 kHz, 22 kHz, 44 kHz (Figure 5.19).
Working with Audios from CDs

FIGURE 5.18: The Premier AIFF conversion dialog box

6. Pull down the Audio Format menu. You will see the following available formats from which to choose: 8 bit - Mono, 8 bit - Stereo, 16 bit - Mono, and 16 bit - Stereo (Figure 5.20).

7. When you’re satisfied with the settings, name the file and select a location for saving it, using standard techniques.

8. Click on the Save button to convert. You will see a progress window, as illustrated in Figure 5.21.

9. Premier will open the new AIFF in a new Clip window. Click on the Play button to listen to the file.

10. Quit Premier to complete this exploration.
Importing QuickTime Movie Soundtracks from Audio CDs

As you may not have been able to perform this exercise, I've provided you with the converted AIFF file for the QuickTime movie Converted Audio 1 file, also supplied on the Multimedia Machine CD. It's located in the AIFFs folder within the Music folder on the Multimedia Machine CD. To make it more accessible for these exercises, there's also an alias file located in the Ch. 5 CD Audio folder within the Explorations folder on your hard drive.

FIGURE 5.19: The Audio Rate pull-down menu

NOTE
Our final step in using audio from CD as digital audio is to import the file into HyperCard so we can create a button to play the file.

**EXPLORATION 5.6: PLAYING THE CONVERTED AIFF FROM HYPERCARD**

In this exercise we'll complete the process of using audio from CD as a digital audio file. We will see how we can import and play the file as a QuickTime movie, as well as how to import and play the file as an AIFF.
1. Open the 5.6 Converted CD Audio stack.
2. Select Media ➤ Audio Tools... to open the Audio Tools palette.
3. Click on the Disk radio button to access the AIFF recording and playback tools.
4. Click on the speaker icon to access the standard open file dialog box.
5. Locate and select the Converted Audio 1.AIff file.
6. Click on the Open button.
7. Media Tools will create a button and inform you the button has been successfully installed. Click OK to acknowledge.
8. Close the Audio Tools palette.
9. Drag the button to a desired location using the appropriate method, and listen to the audio file.

You could also use the CD Tools to create a button that would play the same region from the CD. Let’s do that now. (This assumes you’re using my supplied Converted Audio 1.AIff file.)

1. Select Media ➤ CD Tools....
2. Enter 46:59:36 as the starting point in the Start Time fields.
3. Enter 47:12:17 as the ending point in the End Time fields.
You could also play the track using the Play button, and capture the appropriate timings using the Capture Start Time and Capture End Time buttons, as described earlier in this chapter. This would give you additional practice in using the tools; but, if time is an issue, simply enter the timings provided here by clicking in the text fields and typing the numbers.

4. Click on the Play Region button to audition the selected region.
5. Click on the Button button to create a button that will play the selected region from the CD.
6. At the prompt, name the button Play CD Region.
7. Using the appropriate techniques, drag the button to a desirable location and audition the region.

Now let's create one more button to play the audio as a QuickTime movie. This way, we can compare all three ways of using this same phrase of music from the audio CD.

1. Select Media ➤ Movie Tools....
2. Click the Open... button on the Movie Tools palette.
3. Locate and select the Converted Audio 1 movie file.
4. Click on the Open button. The QuickTime movie controller will appear with no movie frames (since it's only an audio track movie).
5. Drag the movie controller window to an appropriate location on the screen.
6. Click on the Save Location option to place a check in the box.
7. Click the Close at end option to place a check in the box.
8. Be certain that the Show Controller option is checked, and that the Frameless and Loop options aren't checked.
9. Click on the Make Button button.
10. At the prompt, name the button Play Movie Region. Media Tools will create the button and inform you that it's been successfully created. Acknowledge by clicking on the OK button.
11. Close the Movie Tools palette; the movie controller window will also close.

12. Using the appropriate techniques, drag the button to a desirable location and audition the region. Your completed example should look something like Figure 5.22.

Your buttons may look different than those illustrated here. Using the full version of HyperCard and the upgraded complete Media Tools package, I've made all the buttons the same size (larger than the standard default size) and spaced them equally to give a professional appearance. For our purposes, however, it doesn't matter that the buttons be resized and exactly aligned and spaced.

**NOTE**

**FIGURE 5.22:** The completed 5.6 Converted CD Audio exercise
13. Click on each of the three buttons to experience the playback of this selection of music as AIFF, QuickTime movie, and CD audio.

14. Choose Go ➤ Home (⌘-H) to end this exploration.

Through the exercises in this chapter, you should now have a strong grasp of the ways to use audio from CD in multimedia projects. Let's now take a closer look at MIDI and the many exciting ways that we can use MIDI to combine music and sound in our multimedia undertakings.
Working with MIDI

In Chapter 2 we explored MIDI as a sound source for the Macintosh. In this chapter, we'll look at other ways of creating and playing back high quality sound using MIDI synth hardware and software. While you'll need a General MIDI synth to do Explorations 6.2 through 6.5, you can still learn a lot about MIDI and its uses in multimedia by reading the text.

The Macintosh, MIDI, Music, and Multimedia

The Macintosh has long been the computer of choice for professional musicians. The Mac's intuitive interface and powerful music production applications have made MIDI on the Macintosh the standard choice for professional musicians. But, even if you are not a professional musician, MIDI can be a powerful tool for use in multimedia. In this next exploration, we'll hear and see what some of contemporary music's leading professionals say about the Mac, MIDI, and the way they make their music.
EXPLORATION 6.1: MUSICIANS ON MIDI

In 1987, Apple Computer produced a video called *Macintosh, MIDI, and Music: The Open Door* to promote the possibilities for producing music on the Mac. This video featured a number of musicians who were creating their work using the Mac and MIDI. Included in the video were famed jazz keyboardists Chick Corea, Herbie Hancock, and Tom Coster, as well as a number of jazz, rock, and pop musicians such as Carlos Santana, Laurie Anderson, Tony Williams, and others. I was also fortunate to be included in the video (the token music educator). This exercise gives us a chance to hear (and see) a snippet of what a few of these musical greats had to say about how MIDI and the Mac has helped them with their creative work.

1. Open the 6.1 Musicians on MIDI example. You will see the following screen, shown in Figure 6.1.

2. Click on the button that with Herbie Hancock’s name. You will see a short QuickTime movie featuring Herbie Hancock.

![FIGURE 6.1: The Musicians on MIDI screen](image-url)
3. Click on each of the remaining buttons to watch QuickTime movies of the named musicians.

4. To read what the artists say in their video clip, first click on the Text button, then on their names. Click on the text field to put it away and continue.

   You can click on the question mark icon to view information and brief instructions on using this stack. Each click on the question mark icon toggles between showing and hiding the information.

5. Choose Go ➤ Home (⌘-H) to end this exploration.

The Multimedia Machine CD also contains a version of this exercise for people with digital film systems. You will need to copy the Big Musicians folder onto a fast hard drive for it to run properly. The example is located in the folder and is called Musicians on MIDI.df.

Now let’s see how you can make MIDI work for you. Let’s start with a little more detail on how to configure a MIDI system for multimedia.

### Configuring the System

There are at least three components in a Macintosh MIDI system: The Mac, the MIDI synth, and a MIDI interface that translates information between them. In addition, there are cables that connect them, software that controls the synth, and optional extensions to the system that provide additional features for MIDI power users. Review the diagrams in Chapter 2 that illustrate the most common hardware connections for MIDI synths, then let’s look at how the Mac and its software communicate with the synth.
Direct MIDI Connections

Many MIDI software titles (including Media Tools and Opcode’s Music­Shop) send MIDI data directly to the serial ports. This makes it very easy for the casual MIDI user to set up a system, but allows little flexibility for serious power users. When the MIDI program sends data directly to the ports, the only software configurations you need to make are to tell the program the communications speed of your MIDI interface and to which serial port (modem or printer) your interface is connected. This is usually done with a menu command named something like MIDI setup. In Media Tools, these options are set by pressing the button that looks like a MIDI plug, which brings up the dialog box shown in Figure 6.2.

In MusicShop, you would choose the Setups ➤ MIDI setup… command to get the setup dialog box shown in Figure 6.3.

While there are slight differences between the two dialog boxes, basically they offer you the chance to tell the software where your interface is connected and its communications speed. Most Mac MIDI software programs provide this type of dialog box in some variation of a settings or setup title.

---

**FIGURE 6.2:** The Media Tools MIDI settings dialog box
FIGURE 6.3: The MusicShop MIDI setup dialog box.

While this direct configuration makes it very easy to get up and running, it doesn’t allow the power user to exchange MIDI data between programs, to synchronize two different programs, such as MIDI sequencer and a QuickTime movie player, or to connect many multitimbral synths to a single computer. To better address these power-user needs, Apple developed the MIDI Manager.

**MIDI Manager**

MIDI Manager is a system extension, device driver, and desk accessory/application that allows more complex MIDI setups to be configured inside the Macintosh. MIDI Manager works with MIDI data and the serial ports in much the same way that the Sound Manager works with audio and sound hardware. Software programs that can use MIDI Manager don’t talk directly to the serial ports. They send commands to MIDI Manager, which then works behind the scenes to communicate either with the serial ports or other MIDI programs in the Mac. Figure 6.4 illustrates the way MIDI manager handles hardware and synchronization tasks for software programs.

Using a graphic front-end program or desk accessory called PatchBay, MIDI Manager allows you to connect multiple MIDI applications by dragging
patch cords from one program's output to another's input, much like modules in TurboSynth's patch window.

Figure 6.5 shows a MIDI Manager configuration where MusicShop and Adobe Premier communicate through PatchBay.

Figure 6.5 also shows Adobe Premier sending MIDI timing information into MusicShop, which in turn gets and sends MIDI data to MIDI Manager's Modem port driver. This patch lets MusicShop play a MIDI sequence synchronized to Premier's QuickTime movie playback. This configuration would require at least 16 MB of RAM and a very fast computer to be at all useful!

MIDI Manager also allows us to direct MIDI output from a software program to an internal NuBus MIDI playback card. Figure 6.6 shows MusicShop sending MIDI data to Digidesign's SampleCell II MIDI sample playback card.
FIGURE 6.5: A PatchBay connection between Adobe Premier and MusicShop

FIGURE 6.6: MusicShop connected to SampleCell via PatchBay
MIDI Manager allows you to make a variety of MIDI configurations, depending on your hardware, software, and working needs. However, it’s an imperfect solution in that it has some *operational anomalies* (I dislike words that remind me of insects) and requires too much CPU overhead to be useful in multimedia applications except on the most powerful machines. Apple also stopped development support several years ago when sued by the Beatles’ Apple Records for competing in the music business. (Apple licensed the name and trademark from the Beatles, and as a condition of that license they were prohibited from making music-related products.) Although that suit has been settled, Apple still has no announced plans to continue support of MIDI Manager. For the past few years, various Mac music software companies have tried to establish a new standard system-level MIDI extension to replace MIDI Manager, and at least one contender has arrived: OMS, the Open MIDI System from Opcode.

**Open MIDI System**

The *Open MIDI System* works much like Apple’s MIDI Manager, except more efficiently. It also adds more features, such as a database that holds the names of your synths as well as the names all of their internal programs and publishes it so that any OMS program can let you choose synth and program changes by name rather than by number. OMS consists of the Open MIDI System extension, the OMS Setup application, and a number of MIDI drivers. Figure 6.7 shows an OMS Setup window.

In Figure 6.7, OMS talks to each of the three external MIDI synths as well as to the Digidesign SampleCell II NuBus MIDI sample playback card.

Now that we understand how programs talk to MIDI synths, let’s try our first multimedia exploration with MIDI.

**EXPLORATION 6.1: SYNCHRONIZING SLIDES WITH A MIDI SOUNDTRACK**

This exercise, like the CD Slide show in Chapter 5, is based on the Scroll-It stack, but limited to playing MIDI sequence files. Again, so we can focus totally on MIDI here, I’ve already installed a series of eight color slides to be synchronized with the music.

1. Open the 6.2 MIDI Slide Show exercise. You should see the screen shown in Figure 6.8.
Configuring the System

**FIGURE 6.7:** An OMS Setup window

**FIGURE 6.8:** The MIDI Slide Show screen
2. Navigate through the eight slides by pressing on the right and left arrow keys on your keyboard (←, →). Each time you press an arrow key, you will go to either the next (→) or previous (←) card in the stack. The cards are numbered (1–8) for your convenience. How fast each color picture is opened depends on the speed of your CPU and CD-ROM drive.

3. Return to card 1. You can use the arrow keys or type %1.

4. Select the Scroll Fields option. Two blank fields will appear at the left and right bottom corners of the card. These fields will be used to grab the current time as the music plays, and will control when the slides change as the slide show runs.

5. Select Scroll Transport Controls.... A small palette, shown in Figure 6.9, will appear in the upper left of the screen. This palette provides Open File, Play, Pause, and Continue buttons in that order, all of which utilize Media Tools routines to perform their functions.

6. Click on the Open File button. A standard file dialog box will appear asking you to select a MIDI file. Locate a standard MIDI sequence file (SMF) to use for this slide show. For consistency’s sake, let’s use the New Groove file located inside the Grooves folder in the MIDIfiles folder within the Music folder on the Multimedia Machine CD. Click the Open button to open the MIDI file.

7. Click the Play button to listen to the music, when ready to begin defining the timings for slide changes, stop the music by clicking on the Pause button.

We’ll begin by entering the time for the beginning of the music. We’ll do this without the music playing. Music is counted in measures, beats, and fractions of beats. This piece is in common time also referred to as 4/4 time.

FIGURE 6.9: The MIDI transport control palette
signature which means there are 4 beats in each measure, and the quarter note is the beat reference. In most Macintosh MIDI applications, beats are divided into very small increments called ticks (as in ticks of a clock). All of the software we’ll explore divides the beat into 480 equal parts. Therefore, we’ll count timings in measures, beats, and ticks where each beat is divided into 480 ticks, numbered 0–479.

1. Hold the Option and Shift keys down, then click in the lower-left field, the Start Time field. You will be prompted to enter the time, separated by commas.

2. Type 1,1,0, which refers to the beginning of the piece: measure 1, beat 1, 0 ticks. Click OK to enter the timing.

3. Press the Start button (not Continue) to begin playing the music from the beginning.

4. Wait until an appropriate phrase point for moving to the next slide. At the desired time, click in the bottom-right (End Time) field. The current time will be entered, the slide will advance, and the time will automatically be entered into the next slide’s Start Time field.

5. Repeat step 4 for each of the slides until you’ve reached slide 8. Click in the end time for slide 8 at the point you wish the music to stop. This will mark the end of the slide show.

6. Click on the Stop button in the floating transport control palette.

7. Click in the close box of the transport control palette, to put it away.

8. If you are not now at slide 1, navigate there using any of the methods described above.

9. Click on the MIDI icon at the top right corner of your screen. The music will begin and the slides will advance at the appropriate times. When slide 8 is showing, the music will stop at the time indicated in the End Time field.

10. Choose Go ➤ Home (⌘-H) to end this exploration.

You can edit the timings as you did in the CD Slide Show example from Chapter 5. Review those instructions if necessary. You can also hide the fields again by choosing Scroll ➤ Fields. The complete Scroll-It stack on the Multimedia Machine CD allows you to elect either MIDI or CD as the soundtrack choice from the Scroll menu. We’ll explore this further in Chapter 7. As you can see, it’s quite easy to use MIDI as a sound source for
multimedia projects. Since it's been Media Tools working behind the scenes to simplify our work, let's now explore the MIDI Tools component of Media Tools.

**Media Tools**

Media Tools provides two sets of tools for using MIDI in HyperCard: the MIDI Recorder and the more powerful MIDIFile Player. Let's start with the MIDI Recorder.

**MIDI Recorder**

The MIDI Recorder is a simple tool for recording single-part music directly into HyperCard. This is useful for recording a simple accompaniment using one instrumental timbre like piano or strings.

**EXPLORATION 6.3: RECORDING A MIDI SEQUENCE USING MIDI TOOLS**

For this example, you'll need some kind of MIDI input device such as a MIDI keyboard, guitar, or woodwind controller. Many MIDI synths have keyboards built into them (these are called _integrated instruments_ because controller and sound generator are included in one box) and these will work just fine. We'll record a short selection of music, and create a button that, when clicked, will play our music.

1. Open the 6.3 Recording MIDI example.
2. Select Media ▶ MIDI Tools.... You will see the MIDI Recorder palette as shown in Figure 6.10.
3. Click on the Record button; it's the first button in the top row with the small circle in the center. You will be prompted: "Now Recording MIDI DATA...Press STOP when finished..."
4. Play anything on your MIDI controller, then press the Stop button when finished (the second button with the square in the center).
5. Press the Play button to hear the playback of your recording.
That was simple. And that's all you can do—no editing, overdubbing, no re-orchestrating. A plain and simple MIDI recorder in HyperCard—but useful if you just want to record a simple musical example to accompany something in HyperCard. Our next task will be to create a button that will play our newly recorded music.

1. Play your music again to be sure it's still there. (It shouldn't disappear unless you click the record button again, open a file from disk, or close the MIDI Recorder palette.)

2. Click on the Export to button button.
3. Name the button, using a short but descriptive name like **Play my song**, then click the OK button.

4. Close the palette by clicking in its close box, then move the button to the center of the card using the appropriate technique, and listen to your song.

5. Choose Go > Home (⌘-H) to end this exploration.

You can also save this sequence as a text file and reload it into the MIDI Recorder palette at a later time, using the Open File and Save File buttons. There are four other buttons on the palette—three of these are used to set MIDI and memory settings; the fourth takes us to the MIDIFile Player palette. We'll explore that button in the next exercise. Detailed instructions for setting the memory and MIDI setups are discussed in Appendix C.

**MIDIFile Player**

The second component of the MIDI Tools is MIDIFile Player, a more powerful toolset for opening pre-recorded standard MIDI files, editing the performance, and then creating buttons to play back the sequences from disk, complete with edits. Its palette allows you to open any standard MIDI file (SMF), change the tempo (speed of playback) without changing pitch, transpose the pitch without changing the tempo, set regions to repeat, change the overall volume, and create buttons that will play the file with all of your changes.

**EXPLORATION 6.4: PLAYING AND EDITING A STANDARD MIDI FILE WITH MIDI TOOLS**

In this exercise we'll open a MIDI file, change various aspects of the music, then create a button to play the edited music.

1. Open the 6.4 Standard MIDI Files example.

2. Select Media ➤ MIDI Tools.... At the top-right corner of the MIDI Recorder palette, which we used in the previous exploration, you'll see an icon that looks like a file icon with a MIDI jack in the center. Click on this button to open the MIDIFile Player palette, shown in Figure 6.11.
You can also call the MIDIFile Player palette directly by holding down Option as you choose Media > MIDI Tools.... This shortcut will save you from having to pass through the MIDI Recorder palette every time you want to use the MIDIFile Player palette.
3. Click on the Open MIDI file button—it's the one with the file icon with a MIDI jack in the center and the word OPEN running down the right side. Use the standard file dialog box to locate and open the MIDI file called Modal Groove. You will find it in the Grooves folder within the MIDIfiles folder in the Music folder on the Multimedia Machine CD.

4. Click on the Play button to listen to this file.

5. Use the Pause and Continue buttons as you did earlier with the MIDI Slide Show exploration.

The last button in the top row returns you to the MIDI Recorder palette. We won't use that button in this exercise. The remainder of the palette is devoted to various editing parameters. Our next few tasks will focus on the three buttons shown and annotated in Figure 6.12.

These are referred to as global event editors because they affect all events in the sequence. The Transpose button will change the pitch of all the notes played, except the specified drum track (because transposing the drums wouldn't change the pitch of the drums, but rather which drum sounds are played, as each percussion sound—triangle, bass drum, etc.—is assigned specific note number by the General MIDI specification). The Volume button affects the loudness of all notes on all instruments, and the Tempo button changes the speed of the entire sequence. Let's experiment with each of these editors, starting with the volume editor.

1. Start the MIDI file playing from the beginning.

---

**FIGURE 6.12:** The global MIDI event editors

- Volume editor (changes velocity)
- Transpose editor (changes pitches)
- Tempo editor (changes playback speed)
2. Click on the Volume button (the speaker icon). This tool will scale all the velocity values (how fast the key went down, which results in loudness changes) by a percentage, where 100% is the stored value. Enter 50 and click the OK button. Notice how the music gets very soft. (Your synth must be velocity-sensitive, able to respond to note-on velocity information, to hear this effect. All GM synths are velocity sensitive.)

3. Click again on the Volume button, this time accept the default value of 100 to return to normal levels.

4. Click again on the Volume button and enter a value of 200. As you might expect, the music gets louder. The resulting volume changes will depend on the stored original values, and the way your synth responds to velocity changes.

5. Click one last time on the Volume button and enter a value of 110. This should make the sequence play slightly louder, and will be the value we choose to store in the button we make later in this exploration.

6. Stop the sequence by clicking on the Pause button.

Next we'll look at the Tempo control. This controller simply changes the speed that MIDI data is played back, and unlike recordings of sound, when you change the playback speed of MIDI data you don’t change the pitch or timbre.

1. Start the MIDI file playing from the beginning.

2. Click on the Tempo button (the metronome icon). This tool will scale the playback tempo by a percentage, where 100% is the stored tempo.

3. Enter a value of 75 and hear the music slow down by 25% with no change in pitch.

4. Click again on the Tempo button, this time accept the default value of 100 to return to normal speed.

5. Click again on the Tempo button and enter a value of 110. The music will play back slightly faster. We’ll use this as the value for the button we create later in this exploration.
The final global editor we’ll examine here is the transposer. This changes the note numbers in all the tracks except the specified drum track. We must first tell Media Tools which track (not MIDI channel) contains the drum information. In many commercially available MIDI files this will be track 10, as the GM standard specifies drum information should be on MIDI channel 10. This sequence uses track 5 for the drums, even though the information is on channel 10.

The confusion between track and channel is one of linguistics and can be traced to the old concept of multitrack tape where each instrument is recorded onto a separate longitudinal piece of the tape called a track. Many MIDI sequencing programs use a multitrack analogy to make learning easier for musicians used to tape recording. Confusion results because, unlike tape, computers don’t have equal divisions of their memory in physical tracks, and so the concept of tracks is simply an analogy, not a reality.

We use the term MIDI channel to describe a means of addressing a specific instrumental timbre. MIDI has 16 channels, that work like the channels of a television set. On a TV, all the available broadcast channels are present at the antenna or cable, but only one program can be viewed at a time. At any given point in time you can determine which channel you are watching—ever channel surf? With MIDI, all 16 MIDI channels are present in the MIDI cable, but a GM synth can play all of them at once. Each channel usually contains an instrumental part and is played back with its own instrumental timbre.

So the term MIDI channel is an absolute term that addresses an instrumental part, and a MIDI track is an obscure undefined word that refers to some division of computer memory. Anyway, the drums in this example are on MIDI channel 10 but stored in memory in track 5. Let’s try out the transposer tool:

1. Type 5 into the Drums: field. This tells Media Tools that the drums are on track 5.
2. Start the MIDI file playing from the beginning.
3. Click on the Transpose button, the musical sharp and flat symbols icon. This tool transposes all instruments except the drums up or down by half steps (semitones). To transpose up we enter positive numbers, to move down we enter negative values. A value of zero is the original stored pitch.
4. Enter 3 to transpose the piece up three semitones (an interval of a minor third).

5. Click again on the Transpose button and accept the default value of 0. The music returns to the original key.

6. Click on the Transpose button one last time and enter a value of -2. This will transpose the sequence down a major second (two semitones). We'll use this as the value we'll store in the button we create later in this exploration.

This palette also lets you grab start and end times while the music is playing to create regions to play, like the CD and Movie Tools. We can also easily identify regions by typing in musical values using measures and beats. We can set these regions to repeat a specific number of times, so that we can stretch a short phrase of music to fit a longer multimedia project. Figure 6.13 identifies the region and repeat controls found in the palette; familiarize yourself with the controls before going on.

![Figure 6.13: The region and repeat tools in the MIDIFile Player palette](image)
There are three distinct musical phrases in this piece. Let's find the third one, and set it to play three times. The first phrase begins at measure 1, beat 1 and continues through the end of bar 8. The second phrase runs from bar 9 through 16, at which time phrase 1 repeats. Phrase 3 begins at bar 25 and plays through bar 32.

1. Type 25 into the Start Measure field.
2. Type 1 into the Start Beat field.
3. Type 33 into the End Measure field.
4. Type 1 into the End Beat field. This enters the information for setting the region that begins at measure 25 and plays for 8 bars.
5. Type 2 into the Times To Play field. This instructs Media Tools to play the region twice.
6. Click the Loop button. This indicates that MIDIFile Player should perform the indicated repeat. Note that this is a toggle switch with on and off states.
7. Click on the Play Region button to listen to our example. It should play twice, at 110% the tempo, 110% the volume, and transposed down a major second from the original sequence.

We are now ready to create a button that will play this region with all of our edits. Here's how:

1. Click in the Use Region check box to instruct Media Tools to use our designated region when creating the button. If this box is not checked, Media Tools will apply all edits (including repeats) to the entire sequence when it creates the button.
2. Click on the Make Button button. Name the button Modal Region and click on the OK button.
3. Media Tools will inform you that the button has been successfully created: click OK to acknowledge.
4. Use the appropriate technique to move the button to the center of the screen and play your example.
5. Choose Go ➤ Home (⌘-H) to end this exploration.
Media Tools allows you to incorporate MIDI into HyperCard in a simple, intuitive manner. While it's not as powerful as many dedicated professional MIDI software programs, it handles most needs for using MIDI in multimedia environments. Let's now look at Opcode Systems' MusicShop, a complete MIDI sequencing and notation program for creating and editing standard MIDI files.

**WARNING**

MIDI Tools connects a device directly to the specified serial port. You have to manually disconnect the device with MIDI Tools before quitting HyperCard or you might not be able to use the port for other applications; do this with the MIDI Setup dialog box.

**MusicShop**

MusicShop is an easy to use MIDI sequencing and notation package from Opcode Systems. The Multimedia Machine CD includes a demo version of this software that contains all of the program's features, but does not allow you to save your work. For the purposes of these explorations, though, you'll be able to learn how to use these excellent tools and see how you can use MIDI to create your own music for multimedia.

Let's start with a broad overview of the MusicShop Edit window. Figure 6.14 shows an annotated view of the main MusicShop screen.

Let's do a hands-on exploration of MusicShop to learn the basic features. We'll build on the concepts we learned in the previous MIDIFile Player exploration: we'll open a standard MIDI file and experiment with some of the basic editing elements we learned above.

**EXPLORATION 6.5: PLAYING AND EDITING A STANDARD MIDI FILE WITH MUSICSHOP**

In this exercise, we'll explore many things we can do with pre-recorded MIDI sequence files. Since this is a demo version of the software, we won't be able to save any of our work. However, with the full version we could save our edits as a new MIDI sequence file and play it back from HyperCard using Media Tools.
You may want to copy the entire MusicShop Demo folder to your hard drive before performing the following explorations, as they will run much faster from the hard drive than from the CD-ROM.

1. Open the MusicShop Demo application. You will see the main edit window shown back in Figure 6.14.

2. Select the File ➤ Import... command (Option-O). Use the standard file dialog box to locate and open the C-Vamp file from the Grooves folder within the MIDIfiles folder inside the Music folder on the Multimedia Machine CD.

3. You will get an alert that says the Track Setup was changed. Click on the OK button to acknowledge this fact.
4. Click on the play button to hear the sequence file.

5. Hold down the Shift key and click on each of the tracks with numbers in bold type. This will allow us to view all of the MIDI data in a single screen. If you have a color monitor, each track's music will show in a different color. Figure 6.15 shows the C-Vamp file with all MIDI data in the edit window.

6. Click on one of the horizontal bars that represent notes. You will hear the pitch with the associated instrumental sound.

When your mouse is in the center of a note bar, the cursor turns into a cross-hair with arrows pointing up and down. If you click in the note while your cursor looks like this, you'll hear the note sound, and if you hold the mouse button down, you can drag the note up or down in pitch, hearing the sound of each step. If you move your mouse over the last half
of the note, it turns into a cross-hair with arrows behind it, each pointing left or right. Clicking in the note and dragging will lengthen or shorten the duration of the note. Moving the mouse to the front of a note turns the cursor to a cross-hair with left and right arrows on either side. Clicking in the front section of the note and dragging will move the note forward or backward in time.

Let's use the click and drag technique to transpose the music to a new key. Here's how:

1. Click on track number 1 to unselect the other tracks.
2. Holding down the Shift key, select tracks 2, 3, and 4. You should now have selected tracks 1–4 (all the instrumental tracks except drums).
3. Choose the Do ➤ Select All command (⌘-A).
4. With all the notes in tracks 1–4 selected, click and hold down the mouse button on any note. You will hear that note sound.
5. Drag the mouse up until you hear the pitch sound twice more (moving up two semitones), then release the mouse.
6. Click on the play button to listen to the music; it's now transposed up a major second to the key of D minor.
7. Choose Edit ➤ Undo Transpose (⌘-Z) to return to the original key of C minor.

MusicShop uses the click and drag interface throughout the program to effect changes, closely adhering to the Macintosh user interface. Let's see how we can click and drag to change the tempo.

1. So that we may work for a longer time than the four bars of this example, let's first set the piece to repeat. Do this by selecting track 1, then clicking in the Length field, at either side of the double bars. This will put a repeat sign (two vertical dots) on both sides of the phrase. Figure 6.16 shows the repeat placed in the Length field.
2. Repeat step 1 for each of the remaining four tracks (2, 3, 4, and 10).
3. Start the music by clicking on the play button.
4. Click the mouse button on the metronome marker number. It will invert to indicate that it's selected. As you move the mouse toward the top of the number, the cursor will turn into an up arrow; toward the bottom it will turn into a down arrow.

5. Click and hold the mouse button down on the metronome marker number, then drag up or down to change the tempo. You will hear the music speed up as the mouse moves upward and slow down when you drag the mouse down.

Let's experiment to modify a given track's volume, stereo placement, and instrumental sound. All of these edits are done by simply clicking, dragging, and selecting from a popup menu.

1. Select track 1 by clicking on its track number. You will see the trumpet part in the edit window.

2. At the top right of the edit window is a popup menu icon that lets us choose the other windows available in MusicShop. Click and hold the mouse button down, as shown in Figure 6.17, and select the Mixer window.

3. You will now see the Mixer window shown in Figure 6.18.

4. Start the music playing by pressing the space bar.

5. Experiment with the relative dynamic levels of the tracks by moving sliders 1, 2, 3, 4, and 10 up and down. This sends out MIDI volume change commands to each respective MIDI instrumental part. Note that you need to have a synth that responds to MIDI volume change commands to hear the result of your edits. However, all GM synths do respond to volume commands.
FIGURE 6.17: The windows popup menu

FIGURE 6.18: The MusicShop Mixer window
6. Click on the S button below track 1. This will "solo" that track so that we hear just the trumpet part. Raise the volume for the track if you lowered it in step 5 above.

7. Click and hold the mouse down on the pan slider just above the volume slider for track 1. You will see the pan popup slider shown in Figure 6.19.

8. This slider controls where in the stereo field the sound will be placed, from full right to full left or anywhere between. Note that you need to have a synth that responds to these MIDI pan commands to hear the result of your edits. However, all GM synths do respond to MIDI pan commands. You will also need to have your synth's outputs connected to a stereo playback system or stereo headphones.

9. Return to the main Edit window by clicking in it or using the windows popup menu.

10. Click on the MIDI program popup menu (the button with the trumpet icon) as shown in Figure 6.20.

![Mixer](image)
11. The current instrumental sound, trumpet, is selected when the menu pops up. While holding down the mouse button drag the mouse up to the Pizzicato program and release the mouse. The sound will change to pizzicato strings. Note that since this track has the trumpet program stored in it, each time the section repeats, it will return to trumpet. Experiment with a number of different instrumental sounds.

12. Return to the Mixer window and unselect the solo button for track 1 to hear the changes in context with the other parts.

13. Select other tracks by clicking on their track numbers, and change their instrumental sounds by using the popup menu.
Let's now investigate a few other powerful ways to work with MIDI sequence files in MusicShop. Our next task will be to open several different short sequence files and combine them into a longer piece of music using MusicShop's Arrangement window. Before we start this next experiment, return all mixer settings to a normal state, which means resetting all volumes back to maximum (127), all pans to center (0), and all solo buttons to off position (unselected). Close the Edit window and select File ➤ New. We now have a clean slate to begin our next experiment. Our first step will be to import three standard MIDI files into MusicShop as source materials for our new arrangement.

1. Choose File ➤ Import.... Using the standard file dialog box, locate and open the file Ab groove from the Grooves folder within the MIDIfiles folder in the Music folder on the Multimedia Machine CD.

2. Listen to this 4-bar sequence by clicking on the play button or by pressing the space bar.

3. Click and hold down the mouse button on the Sequence popup menu (the button with the letter A icon). You should see the menu shown in Figure 6.21.

![Figure 6.21: The Sequence popup menu](image-url)
4. MusicShop allows you to create or import 25 different MIDI sequences into a sequence file, each associated with a letter of the alphabet from A to Y. The letter Z is reserved for the Arrangement sequence. Select sequence B (currently empty) from the Sequence popup menu.

5. Choose File ▶ Import.... Using the standard file dialog box, locate and open the file C-Vamp from the Grooves folder within the MIDI-files folder in the Music folder on the Multimedia Machine CD.

6. Select sequence C (currently empty) from the sequence popup menu.

7. Choose File ▶ Import.... Using the standard file dialog box, locate and open the file F Vamp from the Grooves folder within the MIDI-files folder in the Music folder on the Multimedia Machine CD.

8. Select any of the three sequences from the popup menu or type their letters on the keyboard. Listen to each of them at least once before continuing.

We now have three short musical phrases from which to create a complete arrangement. We can now combine these, then re-arrange them in any order using click and drag techniques in MusicShop's Arrangement window.

1. Open the Arrangement window by choosing it from the Windows popup menu. Note that you can also open it by selecting sequence Z from the Sequence popup menu or by typing Z.

2. Type B to add the C-Vamp sequence into the Arrangement window.

3. Type B again to add another copy of the C-Vamp sequence into the Arrangement window.

4. Type C to add the F Vamp sequence to the Arrangement window.

Your screen should look like Figure 6.22.

5. Click on the play button in the Arrangement window to hear the current state of our arrangement.

MusicShop makes it very simple to combine short sequence phrases into a longer musical phrase. This is sometimes called chaining sequences, and
some sequencer programs call this kind of arrangement technique song mode. Others call them sub-sequences or patterns. Let's try another arrangement of the same material:

1. Click on the second B sequence and, while holding down the mouse button, drag it to the end of the C sequence. Your window should now look like Figure 6.23.

2. Play this arrangement by clicking on the play button in the Arrangement window or by pressing the space bar.

3. Let's add another copy of the C-Vamp before F Vamp so the arrangement contains the following order of sequences: B, B, C, B. Click before the C sequence to place the insertion point at measure 5, then type B to add the new copy of the B sequence.
4. Click on the magnifying glass with the - in its center to reduce the block sizes so all sections are visible in the Arrangement window, as shown in Figure 6.24.

5. Click at the end of the window and add some more sequences. I added another B, two A's, two C's, and two B's. My final form is B, B, C, B, B, A, A, C, C, B, B. You may also want to reduce the block size again to see your complete arrangement. Mine is shown in Figure 6.25.

If you had the complete version of MusicShop, you could save this project as a MusicShop sequence file and export the arrangement as a new standard MIDI file. Since you can't do that with this demo version, I've saved my version of this project for you; it's in the Ch. 6 MIDI folder within the Explorations folder. The MusicShop file is called 6.5 Playing SMFs with MusicShop and the standard MIDI file is named 6.5 Arrangement.smf.
Let’s do one last experiment with this file before finishing this exploration. MusicShop lets us view and work with MIDI information displayed in standard music notation. Let’s explore this feature starting with a new sequence.

1. Close any MusicShop sequences that are open, then select File ▶ New.
2. Import the C-Vamp sequence.
3. Click on track 1 to view the trumpet track.
4. Click on the Notation View button, the one with the treble clef icon.
5. In the upper-right corner of the edit window is a button with a note value on it. Click it to show the note value popup menu and select the sixteenth note, as shown in Figure 6.26.
6. Play the new arrangement by clicking on the play button in the Arrangement window or by pressing the space bar.
7. Select the bass track (track 3). You should see the screen shown in Figure 6.27.
8. Let’s display this in the correct octave for bass guitar. Move the cursor to just below the time signature so that it turns into an 8.
9. Click and hold the mouse down to bring up the octave popup menu, shown in Figure 6.28.

FIGURE 6.26: Select the sixteenth note as the view resolution
10. Select 15ma bassa to bring the notation into the proper position for electric bass. This is shown in Figure 6.29.

11. Select tracks 1–4 by Shift-clicking them as we learned above. All tracks will be shown in the edit window with music notation view.
FIGURE 6.19: The bass line in the proper octave

12. Use the magnifying glasses for both the vertical and horizontal axes to fit the music into a single screen as shown in Figure 6.30. This view is much like a complete musical score.

The final aspect of viewing the music is to print the score. This demo version does not allow you to print, but you can view the print preview and see the MusicShop tools for setting up your score page.

1. Choose File ➔ Print Preview…. You will see the screen shown in Figure 6.31.
2. Click in the field labeled Bars per line.
3. Click on the number and drag it up to 3. Try values of 4 and 1 to see how MusicShop redraws the score to fit the desired number of bars per line.
4. Experiment with the other parameters in this window. Note that any number in **bold** type can be edited by clicking and dragging on it.
5. Quit MusicShop to end this exploration.
Since we cannot save any work with this demo version, we'll not attempt to record a sequence. But it's as easy to record a new sequence as it is to edit a pre-recorded piece of music—except you have to play it in...

For those who want more technical information about MIDI, we can return to the MIDI 'n' Synths stack, which we saw in Chapter 4. There we focused on the sound design aspects of the stack. This time, we'll browse the information about MIDI.

**EXPLORATION 6.6: MIDI 'N' SYNTHS**

This stack provides an interactive way to explore information about MIDI and the ways it has impacted music making.

1. Open the 6.6 MIDI 'n' Synths example.
2. Click on the topic MIDI.
3. Use one of the following navigational techniques to explore this stack:
   - Click on any topic with a bullet (●) to get more information about that topic.
   - Use the return arrow at the lower-right corner of the screen to return to the previous level topic.
   - Use the right-pointing arrows to go to further information about a topic.
   - Use the left-pointing arrows to go back to the current topic heading.

Explore this stack to your heart’s content. Those of you with technical leanings will find plenty of details about the language of MIDI.

4. Choose Go ➤ Home (⌘-H) to end this exploration.
Music and Sound in Multimedia

In this chapter we'll explore the various media types found in the Macintosh world, then learn how to put all the diverse pieces together. We'll first explore each individual media type, then do an exercise that integrates a variety of media into a single production. We'll also study how music underscores the motivational and emotional impact of multimedia elements.

Aesthetics—The Motivational Aspects of Music

In Chapter 2, we watched two versions of the same movie—Maria Lionza. First we watched it without no sound track and couldn't understand what it was about. Then we watched it with the musical score, and experienced the emotional impact of the music and the visuals. Let's do a hands-on experiment to see how different musical styles can affect the mood of a movie.
EXPLORATION 7.1: MUSICAL CHOICES

In this exercise, we’ll try out three different musical approaches to the same visual material. We’ll use a QuickTime movie of the Niagara River rushing downstream. As there is no dialog, nor human action to relate to, the reference for emotional content will come primarily from the music.

1. Open the 7.1 Musical Choice exploration file from your hard drive. You’ll see the screen shown in Figure 7.1.
2. Click on the Play Movie button. The movie of the Niagara River will play back with its natural ambient sound.
3. Click on the SoundTrack 2 radio button to select the first musical score for this same movie (SoundTrack 1 is the ambient sound).
4. Click on the Play Movie button to load the new soundtrack.
5. Click on the Play button in the QuickTime movie controller to begin playback. How does this music affect the mood of the movie?

FIGURE 7.1: The musical choice screen
6. Click on the SoundTrack 3 radio button to select the second musical score.

7. Click on the Play Movie button to load the new soundtrack.

8. Click on the play button in the QuickTime movie controller to begin playback. How does this music affect the mood of the movie?

9. Click on the SoundTrack 4 radio button to select the third musical score.

10. Click on the Play Movie button to load the new soundtrack.

11. Click on the play button in the QuickTime movie controller to begin playback. How does this music affect the mood of the movie?

12. Choose Go ➤ Home (⌘-H) to end this exploration.

SoundTrack 2 is kind of New Age music. Most people will find that this score gives the river movie a calm, relaxing feeling. SoundTrack 3 is like a theme for a chase scene—suspenseful and menacing. It almost seems like we’re racing uncontrollably toward the falls and impending doom. SoundTrack 4 is a circus theme; it seems most out of place in this context. Although the visual content remains the same, each soundtrack substantially changes our response to the scene. But what are the musical elements that induce these emotional responses?

**Elements of Music**

We could spend volumes on the study of music. However, there are a few general principles that might help explain how music affects our emotions. Let’s take a brief look at these principles to help us understand how the music we just heard influenced our response to the movie.

**Density**

Music can give a sense of space and time. How heavily populated is the space in a piece of music? Are there a lot of notes close together in time? Are there a lot of notes closely spaced in pitch? We react strongly to our sense of personal space. In large, wide, open spaces most people tend to feel calm and relaxed; in tight, cramped spaces we get more nervous and excited.
Let's review the three sound tracks in terms of this element of music. SoundTrack 2 has an open sense of space. The music is sparse and quiet. There are not a lot of notes happening closely spaced in time. The piece begins with a solo marimba playing a single note line. Then a piano enters playing a simple chordal accompaniment. Each part is separate, distinct, and widely spaced in terms of time, timbre, and pitch.

SoundTrack 3 is much more densely populated. The notes occur rapidly and repetitively. The pitches are close together as well, with the violins screeching in clusters of notes spaced only a minor second apart. There are a lot of instrumental sounds, and they are crammed into a small space in time and pitch. It's no wonder we feel agitated. SoundTrack 4 is somewhere between these two extremes and, as a result, doesn't give a strong sense in either direction.

Instrumentation and Timbre

The orchestration, or types of sounds used in a piece of music, can also affect our emotional response. Are the timbres thin and nasal, rich and lush, or buzzy and harsh? Electronic sounds can imply unreal and possibly threatening situations; acoustic instrumental sounds can be reassuring and comforting. While these are learned responses, and will certainly vary with context, there are psychoacoustical principles that do underlie our responses to sound, even in a simplified overview.

SoundTrack 2 uses familiar instrumental sounds, all of which have warm textures. SoundTrack 3 uses sounds of a more electronic nature, which have thick, buzzy timbres. SoundTrack 4 uses instruments that connote a circus atmosphere—calliope, tuba, and accordion.

Tempo and Rhythm

The speed of music and the rhythmic content also affect our emotional response. Our bodies respond to tempo and rhythm—it's a normal response to move or dance to music. Our minds also react to this element. Fast music suggests action, slow music provides relaxation. Strong and unusually accented rhythms make us tense, while steady beats reassure us.

SoundTrack 2 has a regular pulse, especially when the piano enters. It is slow and calming. SoundTrack 3 is fast with complex rhythmic accents
and percussive attacks. This tends to make us uneasy. SoundTrack 4 is steady rhythmically and is a medium tempo.

**Modality and Tonality**

The most critical element in governing the emotional impact of music is *modality* or *tonality*, which refers to the set of notes that make up the music. The musical scale (the series of notes organized from lowest pitch to highest) used for a composition is often responsible for the feelings induced by the music. Music based on a minor scale (those with three half steps between the first and the third note of the scale) is said to imply sadness, while major tonality (scales with four half steps between the root and third note) supposedly connotes happiness. While this is an oversimplification, it holds true surprisingly often.

SoundTrack 2 begins with a major feeling, although when the bass enters it suggests the relative minor key. This particular effect of major moving to minor is a key element in establishing the calming mood of the piece. The set of pitches in SoundTrack 3 is less familiar than a simple major versus minor tonality. In fact, it’s the chromatic nature of the piece (the use of half steps and diminished fifth intervals—6 half steps) that adds to the instability and rising tension of the music. SoundTrack 4 uses a major tonality that enhances its happy, circus-like mood.

**Contextual Reference**

An often overlooked component of music is the *context* that it suggests. For instance, every element of SoundTrack 4 implies the circus. This reference is so incongruous to the visuals that it seems out of place. SoundTrack 3 has a contextual reference to the familiar television chase scene; we hear and see so much of this on TV and in films that we subconsciously react with tension and apprehension. This element is societal in nature and may vary greatly among audiences.

Watch the three versions of this movie again, and think about how these various elements are used to create or underscore the emotional content of the visual experience. These are very important issues to examine as you compose or choose music to underscore your multimedia projects.
Music and Sound in Multimedia

Macintosh Media Types

The basic Macintosh media types are text, graphics, sound, and moving pictures. Each media type has a number of different standard file formats. Let's take a closer look at each of these media types and file formats so we can make better informed decisions when we begin to combine them into multimedia projects.

Text

We sometimes take text for granted since it was one of the earliest forms of data available with computers. Text is made up of characters—letters, numbers, and symbols—displayed in a typeface, often referred to as a font, and formatted in some stylized manner. The size of the characters is measured in points as in 14 point size. Text can be styled and displayed as bold, underlined, italicized, outlined, and shadowed characters. The indentation, margins, and spacing between characters and lines, are all part of the formatting of text.

Text itself can be stored in a standardized format called ASCII (pronounced ask-key)—an acronym that stands for American Standard Code for Information Interchange. ASCII specifies that characters are represented by 7-digit binary words, giving us a character set of 128 letters, numbers, and symbols. ASCII text files don't contain style or formatting information, as there is no standardized way for representing it. Several proposals have surfaced to address this need, but no standard for representing rich text has yet been adopted. Word processing programs usually save text in their own native file format, but most allow you to save or import text in ASCII format. This allows the text to be transportable among programs and even across platforms.

This next exercise will give us a chance to work with HyperCard's standard text editing tools as well as allow us to import a standard ASCII text file into our project to examine the use of text in this multimedia authoring environment.
EXPLORATION 7.2: USING TEXT WITH MEDIA TOOLS

In this exploration we'll enter text into an existing HyperCard field and edit it, then import an ASCII text file into a HyperCard field.

1. Open the 7.2 Text exploration stack. You'll see the screen shown in Figure 7.2.

2. Click in the blank text field on the right side of the screen.

3. Type the following words into the field: I am typing text into a field in HyperCard.

4. Select the word text by double-clicking on it.
5. Choose Style ➤ 24 to make the word text appear in 24 point Palatino font.

6. Select the word HyperCard by double-clicking on it.

7. Choose Style ➤ Bold to change the style of the word to bold type. Your screen should now look like Figure 7.3.

![Image of styled text in HyperCard field]

**FIGURE 7.3:** The styled text in the HyperCard field

You can type up to 32,000 characters of text into this field; when there is more text than the field can display, use the vertical scroll bar to the right of the field. You can use standard text editing functions, such as cut, copy, and paste on the Edit menu, as well as standard formatting commands on the Font and Style menus.

Our next task will be to import a standard text file from disk into a HyperCard field.
1. With the example 7.2 Text still on your screen, choose Media ➤ Import Text.... Using the standard file dialog box, open the text file Media Tools Text, located in the Other Media folder on the Multimedia Machine CD.

2. Media Tools will present a list of available fields from this stack that can accept the text import. We'll create a new field to hold the text. Click on the New... button as shown in Figure 7.4.

3. Name the new field **Imported Text** and click on the OK button. The new field will now be shown in the Object List dialog box.

4. With the Imported Text field highlighted in the Object List dialog box, click on the Import button, as shown in Figure 7.5.
CHAPTER 1

Music and Sound in Multimedia

*object list*

Please select the field to place text into:

- card field id 2
- card field "Info"
- card field "Type Text Here"
- card field "Imported Text"

New...
Cancel
Import

**FIGURE 7.5:** Import the text to the Imported Text field.

5. The text will be placed into a new scrolling field in the center of the screen, as shown in Figure 7.6.

If you have the complete HyperCard package, you can resize this text field and place it anywhere on the card. You can also change the style of the field, as well as the default font and layout. We'll explore these options in Chapter 8. Using either HyperCard or MediaTools Runner you can change the font and style with the commands on the Font and Style menus.

6. Choose Go ➤ Home (⌘-H) to end this exploration.

**Graphics**

When we speak of graphics we usually mean static pictures like photographs, slides, or paintings. These images can appear in black and white,
gray scale, or color (up to millions of colors). There are several types of image file formats on the Macintosh and across platforms. **TIFF**, or Tagged Image File Format, is a standard developed by Aldus Corporation and is usually associated with scanned images. TIFF images are large files that contain accurate bitmaps of the screen images. Each picture element (pixel) of the screen is represented in the bitmap, and may be stored at almost any resolution in color or gray scale.

**PICT** is a file format for graphics that originated with the Mac, developed by Apple Computer. These files can represent bitmapped screen images as well as object oriented pictures. Object oriented images are those created by drawing programs such as MacDraw or Illustrator, where circles, rectangles, and other graphic elements are represented by equations rather than collections of bits.

**EPS** stands for Encapsulated PostScript, a page description language designed for print output rather than screen imaging. EPS is a powerful
format, but not an easy one to work with, and not quite as formally standard-ized. In Media Tools, EPS files are first converted to PICT format and then imported into the stack as resource files for screen display, rather than print output.

**EXPLORATION 7.3: WORKING WITH GRAPHICS IN MEDIA TOOLS**

In this exercise we'll use HyperCard's painting tools to create a simple picture, and import a 24-bit color picture into HyperCard that will appear when a button is clicked.

1. Open the 7.3 Graphics exploration file.
2. Click on the Tools menu to display the Tools palette (Figure 7.7).

![Tools menu palette](image)

**FIGURE 7.7:** The Tools menu palette
3. While holding the mouse button down, drag the tools palette from the menu bar to the right side of the screen. This will tear the palette from the menu bar and place it on the card for your continued use. See Figure 7.8.

![Figure 7.8: The Tools palette torn from the menu and placed on the screen](image)

4. You can now use the painting tools to create a graphic. Figure 7.9 lists these tools.

5. Choose the Browse tool (the hand) from the Tools palette.

6. Put away the Tools palette (as well as the Patterns palette if you've opened it) by clicking in its close box.

NOTE

The creator of HyperCard, Bill Atkinson, also is the author of the popular MacPaint program that shipped with the original Macintosh computers, and which is now sold through Claris as MacPaint Pro.
Now that you've experimented with HyperCard's built-in painting tools, let's explore ways we can use the power of Media Tools to import existing graphic files into HyperCard.

1. Click on the right arrow at the bottom of the screen of the 7.3 Graphics stack. This will take you to a blank card.

2. Choose Media ➤ Import Picture. You'll see the Import Picture dialog box, shown in Figure 7.10.

3. There are three radio buttons in this dialog box: From resource in this stack, From file on disk, and As QuickTime photo. Click on the From file on disk radio button to indicate that the file we'll import is stored on a disk.
4. To the right of the first two radio buttons are four pictures that allow you to select the style of window in which the imported picture will be shown. These pictures represent the following window styles:

- Top left—rectangular window with just a box around the picture
- Top right—shadowed window, like the plain window, but with a drop shadow on the right and bottom sides
- Bottom left—windoid: like a palette window with a close box
- Bottom right—standard window with a striped top bar and a close box

Choose the rectangle option (the top-left picture) by clicking on it as shown in Figure 7.11.
5. Click on the Continue... button. A standard file dialog box will appear to allow you to select the picture to import. This tool works with files saved in PICT format only.

6. Choose the flat rocks.pict file, located in the MIDI Slide Show Picts folder within the Other Media folder on the Multimedia Machine CD, then click on the Open button.

7. You'll be prompted to click where you want the top-left corner of the picture to be shown. Click someplace in the upper-left quadrant of the screen. The picture will be displayed and a button will be created to allow you to open or close the picture.

8. Click the button to put away the picture.
We've now learned how to import a PICT file and display it in one of four types of windows. This picture is a 24-bit color PICT file, although it'll be displayed at the current resolution of your monitor. Let's explore one more way to display a PICT file, using QuickTime.

1. Choose the Edit ➤ New Card command (⌘-N) to create a new, blank card in this stack.
2. Choose Media ➤ Import Picture....
3. This time we'll choose the QuickTime option by clicking on the As QuickTime photo radio button. The window style selectors disappear, since this option will paint the picture onto the card (as opposed to opening it into a window). See Figure 7.12. This option also lets you to import files directly from a Photo CD.

![Import Picture dialog box](image.png)

**FIGURE 7.12:** The QuickTime option selected in the Import Picture dialog box
4. Click on the Continue... button. A standard file dialog box will appear, allowing you to select the picture to import. This tool enables you to open either PICT format files or files from Photo CD.

5. Choose the sea scape.pict file, located in the MIDI Slide Show Picts folder within the Other Media folder on the Multimedia Machine CD, then click on the Open button.

6. You'll be prompted to click the top-left corner of where you want the picture displayed. Click someplace in the upper-left quadrant of the screen. The picture will be shown and a button will be created, enabling you to open and close the picture.

7. Click the button to display the picture.

**NOTE**

If anything is displayed in front of this picture, such as a dialog box, the picture or parts of it will disappear when HyperCard redraws the screen. Using this tool displays the picture faster than creating a window for it, but presents some problems with HyperCard's screen redraw, since Media Tools (not Hyper-Card) paints the picture.

8. Click the button again to put away the picture.

9. You can navigate among the three cards of this stack by using → and ←.

10. Choose Go ➤ Home (⌘-H) to end this exploration.

**Moving Pictures**

We explored digital video and QuickTime at length in Chapter 3. There are several other ways of using moving pictures in Macintosh multimedia projects. One is to control an external source of analog video, such as a video cassette recorder (VCR) or laserdisc player, using a serial connection as a control source. Both Apple Computer and Voyager provide external command sets (XCMDs) that allow HyperCard to control a laserdisc player or controllable VCR (such as Pioneer's PC-VCR). The problems with this method are that the images are not in the computer, so editing is complicated, and it's difficult to know whether the analog video playback device will be compatible with the development machine.
It is also possible to use computer-generated animations in multimedia using the standardized PICS file format. Programs that can generate these files include MacroMind Director and Add-Motion, which is now included with HyperCard 2.2.

**Synchronization**

One of the most complex issues in multimedia is the *synchronization* of time-based elements. We can speak of synchronization issues in musical as well as mechanical terms. Musical synchronization deals with the aesthetics we discussed earlier—making the sound fit the visuals in a meaningful way. There are many mechanical issues, however, that complicate this issue beyond aesthetic decisions.

Within a single computer we might encounter synchronization problems due to any number of technical limitations. The speed of the CPU, the data transfer rates from storage to processing, and the amount of available RAM can all contribute to these problems. We experienced a bit of this when we worked with creating slide shows in Chapters 5 and 6. The music would begin and play continuously, but the ability to open the picture in time to the music was determined by the speed of your computer. Once you've fine-tuned a project to your machine, you may find it doesn't synchronize properly on a slower or faster machine. CPU dependence is a critical factor in multimedia design.

Synchronizing multiple machines presents a different set of problems—principally the lack of standardized timing signals. There are a number of ways to synchronize machines; the three most common are MIDI clock, SMPTE time code, and MTC. Lots of acronyms here! *MIDI clock* is a part of the MIDI language that specifies that a clock pulse is transmitted 24 times for every quarter note. This is a good scheme for musical instruments, because it works in musical increments. But it doesn't work very well for video that doesn't use musical time keeping. MIDI clock fails somewhat with music as well, because it provides only pulses (24 pulses per quarter note—PPQ) and doesn't keep track of measures and beats.

*SMPTE time code* is the collection of standards used by the Society of Motion Picture and Television Engineers. It divides time into hours, minutes,
seconds, and frames. The frame rates is where the standards vary: 24 fps (frames per second) for film, 30 fps (actually 29.97) for US color TV, and 25 fps for European TV. As if this didn’t confuse matters enough, the method for recording SMPTE also varies by machine type. Audio tape recorders store SMPTE time code longitudinally along the tape (LTC—Longitudinal Time Code), while video decks often record the code vertically in each frame (VITC—pronounced vit-see, for Vertically Integrated Time Code). When a video tape is stopped, the machine can still display the current frame, while audio tape can only show the last frame read before the stop, which isn’t very accurate as tape transport mechanisms don’t start or stop very precisely in fast forward or rewind modes.

SMPTE works well for video, but neither deals with musical time nor communicates directly with MIDI instruments. Therefore, MIDI Time Code (MTC) was invented. MTC is part of the standard MIDI data stream, clocked in musical time, but also contains within the code a translation of SMPTE’s hours, minutes, seconds, and frames. Unfortunately, to use MTC, you need external devices that convert between SMPTE and MTC so that all the machines can be connected together and speak the same language. This can be costly and confusing, although each year products get more reliable and less expensive.

Fortunately, we’ll be dealing only with intra-machine synchronization, and while there may be some minor problems due to varying speeds among CPUs, we don’t need any external devices to translate one synchronization signal into another. Let’s turn our focus now toward integrating the various media elements inside a single machine—the Mac.

Combining Media

Our first project in combining media will be adding music and sound effects to pictures, to create a complete QuickTime movie.

Adding Music to Video in Adobe Premier

Adding music and sound effects to pictures involves many skills. First, of course, we must choose appropriate music for the video and decide where it will be used. These decisions are often called spotting. Second we must compose the audio tracks; this doesn’t necessarily mean writing the music,
but rather assembling the files along a time line to complete the sound tracks. Finally, we must balance or mix the audio levels. The following exploration will teach us these skills and demonstrate their importance in multimedia projects.

**EXPLORATION 7.4: ADDING MUSIC TO VIDEO**

In this exercise, we’ll add music and sound effects to pictures using Adobe Premier. We’ll begin by first importing video, music, and sound effects into a new Premier project.

You may want to copy the Adobe Premier folder from the Multimedia Machine CD to your hard drive before beginning this exercise, as the software will run faster from hard disk than from the CD-ROM.

1. Launch the Adobe Premier 3.0 Tryout program.
2. When presented with the New Project Presets window, choose Presentation—160×120 as your template.
3. Choose File ➤ Import ➤ Multiple....
4. Select the River Movie from the QuickTime Movies folder on the Multimedia Machine CD and click the Import button.
5. Select the chase Audio file from the AIFFS folder within the Music folder on the Multimedia Machine CD and click the Import button.
6. Select the NewAge Audio file from the AIFFS folder within the Music folder on the Multimedia Machine CD and click the Import button.
7. Select the Chimes file from the sfx folder within the Music folder on the Multimedia Machine CD and click the Import button.
8. Select the Liquid file from the sfx folder within the Music folder on the Multimedia Machine CD and click the Import button.
9. Select the Flex file from the sfx folder within the Music folder on the Multimedia Machine CD and click the Import button.
10. Click the Done button.

Your project window should now look like Figure 7.13.
FIGURE 7.13: The Project window with the files imported
Our next task will be to place the movie into the video A track and watch the clip to determine where music and sound effects might be desired.

1. Drag the River Movie clip into the Video A track of the Construction window. Your construction window should look like Figure 7.14.

2. Double-click on the clip in the Construction window to open the Clip window.

3. Click on the play button to begin watching the movie. If necessary, review the Clip window controls in Chapter 3.

4. Note that the sound begins at frame 00:00:05:21 as the video fades in under the title. Perhaps we might want some opening music right at the beginning.

FIGURE 7.14: The River Movie in the Construction windows Video A track
It is helpful to jot down notes during this spotting process. I'll even stop the movie and shuttle the film to find exact frame numbers for specific events, often called hit points. Film composers usually generate cue sheets that are detailed listings of events and actions that might need musical underscoring or sound effects.

5. There is an obvious fade from frame 00:00:28:23 to frame 00:00:29:24. We might want to highlight this in some fashion. Using the Mark: pop-up menu, place Marker 0 at frame 00:00:28:23, and marker 1 at 00:00:29:24. Refer to Chapter 3 if you've forgotten how to place markers.

6. There is another transition from 00:00:39:07 to 00:00:41:04 and still another from 00:00:53:06 to 00:00:55:14. The movie fades out from frame 00:01:03:27 to 00:01:16:26. Place markers 2, 3, 4, 5, 6, and 7 at each of these respective frames.

7. Close the Clip window to complete the spotting process.

We now know that there are no specific events that need underscoring and that the only actions besides the river are the transitions we noted in step 5. We need to choose the style and feel of music we want to use and decide if we want to alternate the music as the visuals change. For now, we'll begin with a calm feeling, bring in some contrasting music in the middle, and end by returning to the calm music. This is rather arbitrary, but will present some technical challenges that will help us learn some valuable skills and techniques. Let's begin the music track assembly.

1. Click on the Project window or select Windows ➤ Project to bring it to the front.

2. Drag the NewAge Audio clip into the start of the Audio B track of the construction window so your window looks like Figure 7.15.

3. So that we can more easily work with the audio, let's add two additional tracks. Choose Project ➤ Add/Delete Tracks....

4. Set the total video tracks to 3, and the total audio tracks to 5, as shown in Figure 7.16.
FIGURE 7.15: The NewAge Audio clip placed in the Construction window

FIGURE 7.16: The settings for the Add/Delete Tracks dialog box
5. Zoom out to a view resolution of 4 seconds.

6. Drag the preview selector bar so that the first 20 seconds are selected.

7. Choose Project ➤ Preview or press the Enter key to preview your work.

You probably will notice that the music is too soft in relation to the river sounds. Our next task will be to balance the levels of these tracks. Here's how to mix tracks:

1. While holding the Shift key down, drag the volume band for audio track A down to half its normal value (about 25% of the total volume setting).

2. While holding the Shift key down, drag the volume band for audio track B up to approximately 75% of the total volume range setting. Your audio tracks should look like Figure 7.17.

![Figure 7.17: The A and B track volumes adjusted](image)

3. You might notice that the entry of the ambient sound is a bit abrupt; let's fade that track in. Click on the track A volume band at the exact start of the sound to place a volume handle point.

4. Place another volume handle point a little to the right of the first point, so you have a spot to fade up to.

5. Drag the first handle down to the zero volume level.

6. Drag the beginning point of the track down to zero as well, so the sound will fade in from the first to the second point. Your construction window should look like Figure 7.18.

7. Choose Project ➤ Preview or press the Enter key to preview our work.
The entrance is smooth, and the volumes are mixed well, but let's add a sound effect to enhance the transition.

1. Click on the Project window or select Windows ➤ Project to bring it to the front.
2. Drag the Liquid clip into Audio Track X1, below the fade-in point. Your screen should look like Figure 7.19.

3. Choose Project ➤ Preview or press the Enter key to preview the effect.
4. The effect is a bit loud, so we need to lower it in the mix. Hold the Shift key down, then drag the volume slider down to about the 25% level.
5. Press the Enter key to preview the new mix. Repeat the volume changes until you are satisfied with the overall mix.

Now we want to fade from the calm music to a contrasting musical selection and back. We’ll need to add yet another clip to the Construction window, create the fades, and properly mix the levels.

1. Click on the Project window or select Windows > Project Window so it becomes the active window.
2. Drag the Chase Audio file into audio track X2.
3. Zoom out to a view resolution of 10 Seconds. Your screen should look like Figure 7.20.

4. Drag the Chase Audio clip in the X2 track so it aligns with marker 2.
5. Zoom the view resolution to 2 Seconds.
6. Raise the overall track volume for X2 up to 75% (the same as track B’s level) by holding the Shift key down as you drag the volume band upward.
7. Place a volume handle in track X2 at marker 3 by clicking on the band.
8. Drag the start handle down to zero to create a fade-in for track X2.
9. Place a volume handle in track B at marker 2 by clicking on the band.
10. Place a volume handle in track B at marker 3 by clicking on the band.
11. Drag the marker 3 handle down to zero to create a fade out for track B.

12. Zoom out to 10 seconds so you can see the end of the B track. Drag its final volume handle to zero to complete the fade.

13. Drag the end of the B track to just after the fade to end that track. Your completed fade should look like Figure 7.21.

![Figure 7.21: The complete fade](image)

14. Drag the preview selector out to marker 4, then press the Enter key to preview our work.

Our final step will be to finish the picture with calming music, so we'll fade back to the NewAge Audio clip.

1. Click on the Project window or select Windows ➤ Project so it becomes the active window.

2. Drag the NewAge Audio file into audio track X1.

3. Align the end of the audio file with the end of the video clip.

4. Zoom in to a view resolution of 4 Seconds.

5. Raise the level of track X1 to 75%.

6. Place volume handles on track X1 at markers 4 and 5.

7. Place volume handles on track X2 at markers 4 and 5.

8. Drag the start handle and the marker 4 handle for track X1 to zero; this sets the fade in.
9. Drag the end handle and the marker 5 handle for track X2 to zero; this sets the fade out.

10. Drag the end of the clip for track X2 back to the end of the fade.

11. Drag the preview selector bar all the way to the end and press the Enter key to preview our fades.

Our next step in assembling this soundtrack will be to add more sound effects.

1. Click on the Project window or select Windows ➤ Project Window so it becomes the active window.

2. Drag the clip Flex into track X3.

3. Drag the clip Chimes into track B.

4. Zoom in to a view resolution of 1 Second.

5. Drag the Flex effect to align with marker 2.

6. Select the Flex clip by clicking on it.

7. Choose Edit ➤ Copy (⌘-C).

8. Click to the right of the Flex clip, then choose Edit ➤ Paste (⌘-V).

9. Repeat step 8 three more times so that there are five Flex files in the X3 track.

10. Raise the level of the first Flex to maximum, raise the second to 75%; the third is at the mid point, the fourth is at 30%, the last should be at 15%. This creates a kind of fading echo effect (see Figure 7.22).

11. Scroll to the right until you find markers 4 and 5 and locate the Chimes effect in track B.

12. Align the end of the Chimes file to marker 5.

13. Press the Enter key to preview our new effects.

Our last step will be to create a final audio fade to match the video fade at the end.

1. Place a volume handle for track X1 at marker 6.

2. Drag the end handle for track X1 to zero; this creates the fade-out for the track over the same period as the video fade.
FIGURE 7.11: The finished effect

3. Press the Enter key to preview our completed work.
4. Quit Premier to end this exploration.

While some of these effects are a bit contrived, we learned a number of valuable skills: spotting, assembling music and effects tracks, and mixing.

Combining Media with Media Tools

Let's now examine how we can combine all the elements we've explored into a simple multimedia project.

EXPLORATION 7.5: CREATING A SIMPLE MULTIMEDIA EXAMPLE

In this exercise we'll create a button that paints a picture across the card as a backdrop, another that plays a video, and a third that plays an AIFF audio file from disk. Our first steps will create the button that displays the backdrop picture.

1. Open the 7.5 Combining Media exploration file.
2. Choose Media ➤ Import Picture....
3. Click on the From file on disk radio button to indicate that the file we’ll import is stored on a disk.

4. Choose the rectangle window style option (the top-left picture) by clicking on it.

5. Click on the Continue... button. A standard file dialog box will appear to allow you to select the picture to import.

6. Choose the BackDrop file located in the Other Media folder on the Multimedia Machine CD, then click on the Open button.

7. You'll be prompted to click the top left corner of where you want the picture to go. There are guidelines to indicate where the top and left edges of this picture should be placed. Click at the upper-left corner of these guides. The picture will be shown and a button will be created enabling you to open or close the picture.

8. Place the button to the left of the BackDrop picture.

Next we’ll create the button to play the audio file. Here’s how:

1. Choose Media ➤ Audio Tools....

2. Click on the Record To: Disk radio button.

3. Click on the speaker icon to bring up the standard file dialog box.

4. Locate the Fall Equinox.11 file in the AIFFS folder within the Music folder on the Multimedia Machine CD. Click on the Open button.

5. Audio Tools will create a button to play this file; acknowledge this by clicking on the OK button, then put away the Audio Tools palette by clicking in its close box.

6. Place the button directly below the BackDrop button.

Next we’ll open the QuickTime movie and create a button that, when clicked, will play the movie.

1. Choose Media ➤ Movie Tools....

2. Click on the Open... button within the Movie Tools palette.

3. Locate the River Movie file in the QuickTime Movies folder on the Multimedia Machine CD. Click on the Open button to open the movie.
4. Move the Movie Tools palette to the left portion of the screen to make room for you to move the River Movie window into the area marked by the guidelines.

5. Drag the movie window into the center of the area marked by the guidelines.

6. Click in the Save Location check box to grab the current location of the movie.

7. Set the parameters as indicated in Figure 7.23.

8. Click on the Make Button button.

9. Name the button **Play Movie** and click on the OK button.

10. Acknowledge that the button was created by clicking on the OK button, then close the Movie Tools palette by clicking in its close box.
11. Move the Play Movie button directly below the Fall Equinox.11 button. Your screen should look like Figure 7.24.

**Figure 7.24:** The completed screen

We’ve now completed the entire project. Let’s watch our multimedia example:

1. Click on the Backdrop button to open the backdrop.
2. Click on the Fall Equinox.11 button to start playback of the music.
3. Click on the Play Movie button to begin the movie.
4. Adjust the volume of the movie sound so it’s softer than the music by using the QuickTime volume slider control. Once all is in motion, your screen should look like Figure 7.25.
5. The movie will most likely end before the music since it’s shorter in duration. Simply click on the Fall Equinox.11 button to stop the music.
FIGURE 7.25: The completed multimedia project in action

6. Close the movie window by clicking in its close box.
7. Put away the BackDrop picture by clicking on the BackDrop button.
8. Choose Go > Home (⌘-H) to end this exploration.

EXPLORATION 7.6: CREATING A SLIDE SHOW

In this exercise we'll build a slide show similar to the ones we used in Chapters 5 and 6. This example is built on the Scroll-It stack included on the Multimedia Machine CD, but with some additions to allow it to work with MediaTools Runner. Our first step will be to set up a few cards to receive pictures that will be displayed as each card opens.

1. Open the 7.6 Slide Show exploration file. You'll see the screen shown in Figure 7.26.
2. Choose Edit ➤ New Card (⌘-N) three times. This will create three new cards for a total of four cards in this stack.
3. Choose Go ➤ First (⌘-1) to return to card 1.

4. Locate the number 1 in the upper-right corner of the first card. Click on the number. The cursor turns into the spinning beach ball momentarily as the cards are numbered sequentially. Use the right and left arrow keys (→, ←) to move through each of the four cards and see that each card now has its number showing in its top-right corner. Return to card 1.

5. Choose Edit ➤ Background (⌘-B). This allows us to work on the background layer so that any changes we make will affect every card in the stack.

The menu bar appears with diagonal lines to indicate that we’re in the background layer.
6. Select the words Title and Composer by dragging through them in the text field. Type My Slide Show and hit Return, then type your name.

7. Choose Edit ➤ Background again (⌘-B) to return to the card layer.

8. Use → and ← to move through each of the four cards and see that each card now shows the title My Slide Show and your name in the title field. Return to card 1.

Our next task will be to import four pictures to use as slides. Here's how:

1. Choose Media ➤ Import Picture....
2. Click on the From file on disk radio button.
3. Click on the Shadow window style (the top-right picture).
4. Click on the Continue... button.
5. Using the standard file dialog box, locate the Falls in hole file in the CD Slide Show Picts folder in the Ch. 5 CD Audio folder within the Explorations folder on your hard drive.
6. Click on the Open button.
7. Click the mouse about ¼" below the title field and about ½" in from the left side of the card. This will be where the top-left corner of the picture will be.
8. Move the button so the top edge aligns with the top of the picture.
9. With the picture still showing, press → to move to the next card. (The picture will close when you move to the next card.)
10. Repeat steps 1 through 9 for card 2, using the file River Rocks from your hard drive.
11. Repeat steps 1 through 9 for card 3, using the file Two Guys in a Canoe from your hard drive.
12. Repeat steps 1 through 9 for card 4, using the file Whirlpool from your hard drive.
13. Use → and ← to view all four cards and their respective slides.

Now we're ready to add the music. We'll use the CD as the source for our sound. Those of you with MIDI synthesizers may want to repeat this entire procedure later, using MIDI as a sound source. For now, we'll all use
the Looking Back audio track of the Multimedia Machine CD as our soundtrack.

1. Choose Scroll ➤ Play CD.

2. With the Multimedia Machine CD in the CD-ROM drive, choose Scroll ➤ Transport Controls... to bring up the CD control palette.

3. Click three times on the next track button to move to track 4, Looking Back.

4. At an appropriate phrase point, click in the Start Time field (the lower-left field). This will mark the start of the slide show.

5. Wait for an appropriate time to move to the next slide, and click in the End Time field. The current time will be entered into the End Time field, the slide will advance, and the time will also be placed into the next slides Start Time field.

6. Repeat step 5 for cards 2 and 3. This will leave you at the final slide—card 4.

7. Click in the End Time field for card 4 at the point you want the slide show to end. This will bring you back to slide 1.

8. Click the stop button to stop the CD playback.

9. Put away the Transport Control palette by clicking in its close box.

10. Click on the CD icon at the top right of the screen to play back the slide show.

11. Choose Go ➤ Home (⌘-H) to end this exploration.

Now that we're all media gurus, let's focus our sights on the last piece of the multimedia puzzle—interactivity.
When all is said and done, the difference between multimedia and ordinary movies is interaction between the audience and the media. Indeed, active audience participation is the key to successful multimedia. A movie pulls viewers in on a passive, emotional level. Multimedia demands action of users as they decide what to hear and see. In this chapter, we'll explore the issues facing multimedia producers and the tools they use to build interactive works.

What Is Interactivity?

*Interactivity* connects the audience with the media content. The audience takes an active role in viewing the content, making conscious decisions that determine how the information is delivered. The following exercise combines various media elements into an interactive study of MIDI.
EXPLORATION 8.1: INTERACTIVE MIDI

In this exercise you'll explore MIDI using a variety of media to enrich the subject matter.

1. Open the 8.1 Interactive MIDI exploration file. If you have a MIDI synthesizer connected, it'll begin playing a MIDI sequence. You can play it again at any time during this exercise by clicking on the button with the speaker and MIDI icon.

2. Click on the words What is MIDI? A new card will appear offering you the option of viewing information about MIDI hardware or MIDI software.

3. Click on the MIDI Hardware topic. A picture appears showing the architecture of a synthesizer.

4. Click on the Show MIDI Routings... button to see how MIDI signals flow inside a synthesizer.

5. Click on the return arrow to return to the What is MIDI? topic card.

6. Click again on the return arrow to return to the MIDI Overview card.


8. Click on the Professional Musicians topic.

9. Click on the Herbie Hancock button to view him commenting on MIDI.

10. Continue clicking on topics and buttons to interactively explore the subject of MIDI.

11. Choose Go ➤ Home (⌘-H) to end this exploration.

This stack contains a wealth of information on MIDI, enhanced by a variety of media elements. Information is textual, graphical, aural, and visual. Most importantly, the way the information is presented allows viewers to explore it any way they want to. This is the interactivity of multimedia—an active interchange among the audience, the media, and the content.

Viewers access information in this example by clicking on topics of interest. There are links between text, sound, pictures, and movies that connect the information. Let's examine the underlying technology that makes this possible—HyperCard.
HyperCard

As we discussed in Chapter 1, HyperCard is an authoring environment that uses an intuitive, building-block approach in constructing projects. Using the metaphor of a Rolodex file, HyperCard stores information on cards, grouping them into files called stacks. Each card is a screen that provides a number of ways of storing and presenting information. A card can contain a variety of objects—pictures, buttons, and fields—to accomplish user interaction. Let's examine each of these object elements.

Fields

Fields are objects that hold text. We explored fields during our work with text in Chapter 7. We saw then how we could type text into a field, edit the text, and import an ASCII text file into a HyperCard field. With the complete version of HyperCard, we can also change many characteristics of the fields themselves, such as the look, the default font, size, and style, and the size and shape of the field itself. These characteristics are called field attributes and are edited through the Field Info dialog box. Through this dialog box, we can set the field’s name, style, and text characteristics. Let's do a short exercise to explore field attributes.

If you have the complete version of HyperCard, you can perform this next exploration, otherwise follow along with the text and look at the screen shots to learn how we work with fields.

EXPLORATION 8.2: WORKING WITH FIELDS

In this exercise we will explore the attributes of a HyperCard field object.

1. Open the 8.2 Working with Fields exploration stack.
2. Choose Objects ➤ New Field. HyperCard places a new field in the center of the screen. HyperCard chooses the field tool, and selects the field automatically, so you can immediately begin working with the new field.
3. Double-click the field to open the Field Info dialog box, which is shown in Figure 8.1.
Interactivity—The Key to Multimedia

FIGURE 8.1: The HyperCard Field Info dialog box

The screen shown here is from HyperCard 2.2. The Field Info dialog box in earlier versions has a slightly different appearance.

4. Type the name **My New Field** into the Field Name: box.

5. Choose Style ➤ Shadow from the popup menu. The changes we make are displayed in the preview area in the center of the dialog box, as shown in Figure 8.2.

The attributes listed in the Style menu control global aspects of the field and are briefly defined here:

- **Lock Text** Prevents viewers from entering or editing the text in the field. This is useful for presenting information but not for
entering data. When a field is locked it can also act like a button—that is it can perform an action when clicked. In the Interactive MIDI example, you clicked on text and actions occurred. The text was locked and a script was executed in response to a mouse click.

**Don't Wrap** Turns off the default text-wrapping feature that automatically moves text to the next line as you type when you reach the right edge of the field. This setting is useful if you want to limit the user to entering a specified line of data.

**Auto Select** Combined with the above two properties, causes a field to behave like a list. If the text is locked and Don't Wrap is turned on, clicking on a word in a line will cause the entire line to be selected and appear in inverse video.

**Multiple Lines** Becomes available with the Auto Select feature and enables the user to select multiple lines of the field.
**Wide Margins** Creates a slightly wider margin at the top and bottom of the field which can improve text appearance.

**Fixed Line Height** Maintains a constant size for each line, regardless of the font size setting.

**Show Lines** Allows the grid lines for each text line to be displayed in the field.

**Auto Tab** When on, pressing the Return key at the end of a non-scrolling field will send a tab key message to HyperCard, moving the insertion point into the next field.

**Don’t Search** Instructs HyperCard not to search this field when doing a find routine. This can speed up searches if the field will never hold information that will be needed in searches.

Returning to our exploration of fields, let's examine the text options for fields.

1. While in the Field Info dialog box, press the Text Style... button, as shown in Figure 8.3.
2. HyperCard will now show the Text Properties dialog box (Figure 8.4), which lets you set the font, size, style, and alignment for the field.
3. Choose Palatine from the font list. Note that changes made in this dialog box are shown in the text field in the lower-right corner, and are applied to the word Sample.
4. Choose 14 from the size list to select Palatine 14 point as the font size.
5. Select Italic and Extend from the Style: check boxes.
6. Select the Center option from the Align: radio buttons.
7. Your completed settings should look like Figure 8.5.
8. Click the OK button to confirm these settings.
9. You can now move the field around the screen by dragging while the mouse is inside the field.
10. You can change the size of the field by clicking on one of the corners and dragging outward to make it larger or inward to make it smaller.
11. Choose the browse tool (the hand) from the Tools menu, then click inside the field to begin typing.
FIGURE 8.3: Click the Text Style... button

12. Type the words **This is my first field**! into the field to see the effect of the settings you have made.

13. Choose Go ➤ Home (⌘-H) to end this exploration.

**Buttons**

Buttons are objects that cause an action to occur. We have clicked on HyperCard buttons before, and have even used Media Tools to generate buttons. Like fields, buttons have attributes—characteristics that determine appearance—and scripts that are the sets of instructions that execute when a button is clicked. The attributes for a button include the button name, style, contents (for HyperCard 2.2 popup buttons), and text style. These attributes are set using the Button Info dialog box, which can be reached by choosing Objects ➤ Button Info in HyperCard. Let's explore these button attributes.
EXPLORATION 8.3: WORKING WITH BUTTONS

Although we have used and generated buttons, we have not yet seen how buttons work. This exercise will give us the chance to explore buttons as objects and learn to set their attributes.

1. Open the 8.3 Working with Buttons exploration file.
2. Choose Objects ➤ New Button. A button named New Button will be placed in the center of the screen. HyperCard will automatically choose the button tool and select the new button.
3. Open the Button Info dialog box by double-clicking on the new button. You will see the dialog box shown in Figure 8.6.

Notice the similarity between this dialog box and the previous Field Info dialog box. HyperCard is consistent when working with objects to simplify the authoring process. In earlier versions of HyperCard, this dialog box looked slightly different.
4. Type **My First Button** into the Button Name: field. Note that the new name is reflected in the Preview window.

5. Choose Style > Shadow from the popup menu. Again, you'll see the changes reflected in the Preview window.

The Family: popup menu is used to create groups of radio buttons so that only one button within a family can be selected at any given time. Since we have not chosen the radio button style, we won't explore this option here. The three attributes below the Family: popup menu deal with global button attributes and are briefly defined here:

**Show Name**  Determines whether the button's name is displayed. Often, buttons have icons that describe their function rather than text names. For instance, the help button in all the Exploration stacks simply shows a question mark icon, with no name. In those instances, the Show Name attribute is turned off. The default value is on, and you can see that our button's name is showing.
Auto Hilite  Determines whether the button will automatically highlight when clicked, then unhighlight when the mouse is released. There are two actions to every mouse click: MouseDown and MouseUp. These are both actions to which a button can respond. In Auto Hilite, the MouseDown highlights the button and the MouseUp unhighlights it. You can write scripts that control the highlight so buttons stay highlighted while a process occurs, then unhighlight when the process is over, or that function like a switch (turn the button on and the highlight is on, turn it off and the highlight goes off). This is how the help buttons work; when the help is on and the information field is shown, the button is highlighted—turn the help off and the field goes away while the button unhighlights. Since this was all under the control of the button script, I turned the Auto Hilite off.

Enabled  Allows us to gray-out buttons so they’re not active. When Enabled is off, the button doesn’t function. Usually this attribute is
set under script control so when some action occurs a disabled button can be activated.

Let’s continue our exploration by looking at some of the remaining button options.

1. Click on the Icon... button. This option lets us choose an icon to display in a button. HyperCard will present the Choose Icon dialog box, shown in Figure 8.7.

2. Scroll through the list until you find the six dice icons. Select the four die by clicking on it.

3. Click the OK button to confirm the choice for the icon.

4. The dialog box will close, returning you to the card where our new button is, but you’ll see that the button isn’t large enough to display the full icon or name. See Figure 8.8.

![Figure 8.7: The Choose Icon dialog box](image-url)
FIGURE 8.8: The new button needs to be re-sized

5. Click on the lower-right corner of the button and drag downwards to enlarge it. Release the mouse when the button is large enough to show both the icon and the name.

6. Click in the center of the button and drag it to the center of the screen.

7. Double-click on the button to re-open the Button Info dialog box.

8. Click in the Auto Hilite box to set the button to automatically highlight when clicked.

9. Click the OK button to accept these settings.

10. Choose the browse tool from the Tools menu.

We now have a button that highlights when the mouse is clicked; it doesn't do anything else, though. To make the button perform an action or a series of actions, which is more often the case, it needs to have instructions on what to do and how to do it. These instructions are called a script, and are entered via a script editor using an authoring language.
called *HyperTalk*. *HyperTalk* is very much like English, but is still a computer language, and as such takes a bit of time to learn. The *HyperTalk* language is beyond the scope of this book, but there are many good sources for information, including the *HyperCard Script Language Guide* included with HyperCard 2.2. For now, let's try a few simple lines of *HyperTalk* just to get a feel for the script editor and to see how we can make buttons do virtually anything we want them to!

1. Choose the button tool from the Tools menu.
2. Double-click on the button to re-open the Button Info dialog box.
3. Click on the Script... button to open the script editor, shown in Figure 8.9.

---

**FIGURE 8.9:** The HyperCard script editor
You can also open the script editor by holding down the ⌘ and Option keys, then clicking on the button. When you open the script editor for the first time, HyperCard helps by providing the start of the handler. Here the script begins with \texttt{on mouseUp}. Whatever follows this line will be initiated when the mouse button is released. The end of the handler is also provided: \texttt{end mouseUp}. This tells HyperCard that the instructions are complete.

4. In the vacant line between \texttt{on mouseUp} and \texttt{end mouseUp}, type the word \texttt{beep} and press the Return key. This simple instruction tells HyperCard to play the currently selected system beep.

5. In the line below the word \texttt{beep} type the word \texttt{flash}. This tells HyperCard to flash the screen. Your script should now look like Figure 8.10.

6. Click in the close box to put away the script editor. You will be asked to save changes; click Yes to save this script.

7. Choose the browse tool from the Tools menu.

8. Click on our button. First you’ll hear the beep, then the screen will flash three times.

9. Choose Go \textgreater \ Home (⌘-H) to end this exploration.

This is of course a very simple example, but one that shows you how scripting works and gives you a sense of how we work with buttons. We will come back to scripting as we explore authoring.

### Cards and Backgrounds

A card appears to us as a single screen that can contain or present information. Every card is built of two parts; the card and background layers. The card layer can be thought of as a foreground laminated to a background as shown in Figure 8.11.

Information in the background layer will be shown on every card that shares the same background. Information in the card layer is unique to each individual card. Many cards can share the same background, so
FIGURE 8.10: The completed script

FIGURE 8.11: The background and card layers
repetitive data need only be entered once. Let's do a short experiment to learn more about these two layers.

**EXPLORATION 8.4: CARDS AND BACKGROUNDS**

In this exercise we will explore the card and background layers of HyperCard, and develop a strategy for properly placing objects during the authoring process.

1. Open the 8.4 Cards and Backgrounds exploration stack. Figure 8.12 shows the screen with elements listed by layer.

2. Choose Edit > New Card (⌘-N). HyperCard creates a new card with only the background elements. You can see now that the black and white picture is a background element, and the text and button on the first card are in the card layer. You can go back and forth between

---

**FIGURE 8.12:** The Cards and Backgrounds screen
these two cards to see the card and background objects by using the left and right arrows (← and →).

3. While the second card (with only the background picture) is showing, choose Edit ➤ Background (⌘-B). The Menu bar will change to show diagonal lines, indicating we’re working with the background layer.


5. Make the field smaller, and drag it to the lower right corner of the screen, as shown in Figure 8.13.

6. Choose Edit ➤ Background (⌘-B) again to return to the card layer. You will still see the field, but the diagonal lines will disappear from the menu bar.

7. Go to the first card using either the arrow keys or by choosing Go ➤ First (⌘-1).

---

**FIGURE 8.13:** The field placed in the lower-right corner
8. Notice that the field appears on card 1 as well; since it's in the background layer, it'll appear on all cards of this background.

9. Choose the browse tool from the Tools menu.

10. Click in the field and type 1.

11. Go to the second card, click in the field and type 2. We have now created a card number field, and placed the card numbers into the field. We could now edit the characteristics of this field using the techniques learned above.

12. Choose Go > Home (⌘-H) to end this exploration.

This concept of background and card layer is quite simple, yet it's a very powerful tool when authoring multimedia projects. All art and design work intended to give the project a coherent look and feel can be done once in the background, with unique data being entered onto each individual card. This makes for consistency among cards, as well as among stacks. All the exploration stacks in this book have a similar look and feel, because HyperCard allows you to copy backgrounds when you create new stacks, as shown in the New Stack... dialog box (Figure 8.14).

FIGURE 8.14: The New Stack... dialog box
Authoring and Scripting in HyperCard

If interaction is the key to multimedia, then certainly one of the most important features of an authoring environment is ease in setting up links between pieces of information. Creating these links allows users to explore information at their own pace and according to their own interests; this is the big difference between interactive and linear presentations, such as books. Let's take a closer look at how to create interactive links between information displayed on cards.

EXPLORATION 8.5: CREATING LINKS

Now let's learn how to link information. First, we'll explore HyperCard's built-in linking tools, found in the Button Info dialog box.

1. Open the 8.5 Creating Links exploration stack. This stack contains seven cards: an overview card, two cards about cats, two about dogs, and two about pigs. Our first step will be to link the overview card to the first information card of each animal.

2. Choose the button tool from the Tools menu.

3. Double-click on the • Cat button to open the Button Info dialog box.

4. Click on the LinkTo... button, as shown in Figure 8.15.

5. You will see the Link To dialog box as shown in Figure 8.16. Press the right arrow key (→) once to move to the Cat card, then click on the This Card button. You will be returned to the overview card.

6. Choose the browse tool from the Tools menu.

7. Click on • Cat. You will hear the word Cat followed by a sound effect; move to the Cat card to hear a recording of a cat meowing.

8. Press the left arrow key (←) to return to the overview card.

We will now repeat the above process for the dog and pig cards. Here's how:

1. Choose the button tool from the Tools menu.

2. Double-click on the • Dog button to open the Button Info dialog box.

3. Click on the LinkTo... button.
4. Press the right arrow key (→) twice to move to the Dog card, then click on the This Card button. You will be returned to the overview card.

5. Double-click on the • Pig button to open the Button Info dialog box.

6. Click on the LinkTo... button.
7. Press the right arrow key (→) three times to move to the Pig card, then click on the This Card button. You will be returned to the overview card.

8. Choose the browse tool from the Tools menu.

9. Click on Dog. After you hear the sounds and see the definition card, return to the overview card by typing ⌘-1.

10. Click on Pig. After you hear the sounds and see the definition card, return to the overview card by typing ⌘-1.

Our next task will be to create a button that returns us to the overview card, so the user doesn’t have to know the command keys or menu commands.

1. Click on Cat to go to the Cat definition card.

2. Choose Objects > New Button. A new button will be placed in the center of the screen.

3. Double-click on the new button to open the Button Info dialog box.

4. Type return in the Button Name: field.

5. Choose Style > Transparent from the popup menu.

6. Uncheck the Show Name box.

7. Check the Auto Hilite box.

8. Click on the Icon... button to open the Choose Icon dialog box.

9. Locate and select the Fleet Return Arrow, shown in Figure 8.17.

10. Click on the OK button to confirm the icon choice.

11. Resize the button and place it in the bottom corner of the definition field, as shown in Figure 8.18.

12. Double-click the button to re-open the Button Info dialog box.

13. Click on the LinkTo... button.

14. Press the left arrow key (←) to return to the overview card.

15. Click on the This Card button. You will be returned to the Cat definition card.

16. Choose the browse tool from the Tools menu.

17. Click on the return arrow button to return to the overview card.
FIGURE 8.17: The Fleet Return Arrow

We have now completed the link between the overview card and the Cat definition card. We now need to copy the return arrow button to the dog and pig cards to finish the linking process.

1. Click on • Cat to go to our Cat definition card.
2. Choose the button tool from the Tools menu.
3. Select the return arrow button by clicking on it.
4. Choose Edit ➤ Copy Button (⌘-C).
5. Press → once to move to the Dog definition card.
7. Press → once more to move to the Pig definition card.
9. Choose the browse tool from the Tools menu.
10. Click on the return arrow button to return to the overview card.
According to Webster:

Cat: A small, domesticated, carnivorous mammal with retractile claws. Any animal of the cat family, as a lion, tiger, lynx, ocelot, etc.

**FIGURE 8.18:** The return arrow button sized and placed

11. Try clicking on each animal, then click on the return arrow button to see the complete linking of these cards.

We have now seen how easy it is to link cards together to create an interactive experience that allows users to selectively browse through information at their own discretion. Let's explore more concepts of navigation and scripting to complete our study of authoring interactive multimedia projects with HyperCard.

**EXPLORATION 8.6: BUTTONS AND NAVIGATION**

In addition to HyperCard's built-in linking function, we can also write our own scripts to control linking and navigation through idea paths. This next exploration will give us the opportunity to investigate scripting in greater detail.

1. Open the 8.6 Navigation exploration stack. This stack is the same as our completed exploration from 8.5 Creating links above.
2. Choose the button tool from the Tools menu.
3. Double-click on the • Cat button to open the Button Info dialog box.
4. Click on the Script... button to open the script editor for this button. You will see the following script:

```plaintext
on mouseUp
  go to card id 4025
end mouseUp

on mouseDown
  play Cat
end mouseDown
```

The first handler (*mouseUp*) was generated by HyperCard when you used the LinkTo... command in Exploration 8.5. This command instructs HyperCard to navigate to a specific card—card id 4025—the Cat definition card. The second handler (*mouseDown*) was provided for you, and it simply plays a recording of me saying the word *cat*.

Let's see how we can write our own script that will allow the viewer to see a picture of a cat after reading a provided definition. The first step will be to create a new View Cat button. Follow along:

1. Close the script editor by clicking in the close box.
2. Press → once to go to the Cat definition card.
3. Choose Objects ➤ New Button. A new button will be placed in the center of the screen.
4. Double-click on the new button to open the Button Info dialog box.
5. Type View Cat in the Button Name: field.
6. Check the Auto Hilite option by clicking on the button.
7. Choose Style ➤ Shadow from the popup menu.
8. Click on the Icon... button to open the Choose Icon dialog box.
9. Choose the Closer Look icon (the magnifying glass) as shown in Figure 8.19.
10. Click on the OK button to confirm the icon choice.
11. Size the button so the name and icon are visible, and place it to the right of the definition field, as shown in Figure 8.20.
FIGURE 8.19: The Closer Look icon

Now we need to write a script that will take the viewer to the card containing the cat picture. Here's how:

1. Double-click on the View Cat button to open the Button Info dialog box.
2. Click on the Script... button to open the script editor for this button.
3. In between the `on mouseUp` and `end mouseUp` lines, type the following:
   ```
   visual effect dissolve slow
   go card "Cat Picture"
   ```

Figure 8.21 shows how your script should look.
CHAPTER 8

Interactivity—The Key to Multimedia

According to Webster:

Cat: A small, domesticated, carnivorous mammal with retractile claws. Any animal of the cat family, as a lion, tiger, lynx, ocelot, etc.

**FIGURE 8.20:** The View Cat button sized and placed

4. Close the script editor by clicking in its close box.
5. Save the changes to the script by clicking on the Yes button.
6. Click on the return arrow button to select it.
7. Choose Edit ➤ Copy Button (⌘-C).
8. Choose the browse tool from the Tools menu.
9. Click on the View Cat button.
11. Choose the browse tool from the Tools menu.
12. Click on the return arrow button to return to the overview card.
We were able to write this script to navigate to the Cat Picture card because the cards already had appropriate names. This was accomplished through the Card Info dialog box, which functions much like the Button Info dialog box. Let's take a quick look at the Card Info dialog box for the Cat Picture card.

1. Click on the Cat button to go to the Cat definition card.
2. Click on the View Cat button to navigate to the Cat Picture card.
3. Choose Objects > Card Info.... You will see the Card Info dialog box, shown in Figure 8.22.
4. Close the Card Info dialog box.
CHAPTER 8
Interactivity—The Key to Multimedia

FIGURE 8.22: The Card Info dialog box

As you can see, the Card Info dialog box is very similar to the dialog box for fields and buttons. Our next step will be to repeat this process for the dog card.

1. Click on the • Cat button.
2. Choose the button tool from the Tools menu.
3. Click on the View Cat button to select it.
4. Choose Edit ➤ Copy Button (⌘-C).
5. Press → to navigate to the Dog definition card.
7. Double-click on the View Cat button to open the Button Info dialog box.
8. Type View Dog in the Button Name: field.
9. Click on the Script... button.
10. Replace the word *Cat* in the script with the word **Dog**, as shown in Figure 8.23.

11. Close the script editor by clicking in the close box; answer Yes to save the changes.

12. Click on the return arrow button to select it.

13. Choose Edit ➤ Copy Button (⌘-C).

14. Choose the browse tool from the Tools menu.

15. Click on the View Dog button.


17. Choose the browse tool from the Tools menu.

18. Click on the return arrow button to return to the overview card.

---

**Figure 8.23:** The edited Dog script
Our final step is to complete this process for the pig cards.

1. Click on the Dog button.
2. Choose the button tool from the Tools menu.
3. Click on the View Dog button to select it.
4. Choose Edit ➤ Copy Button (⌘-C).
5. Press → to navigate to the Pig definition card.
7. Double-click on the View Dog button to open the Button Info dialog box.
8. Type View Pig in the Button Name: field.
9. Click on the Script... button.
10. Replace the word Dog in the script with the word Pig, as shown in Figure 8.24.

FIGURE 8.24: The edited Pig script
11. Close the script editor by clicking in the close box; answer Yes to save the changes.
12. Click on the return arrow button to select it.
13. Choose Edit ➤ Copy Button (⌘-C).
14. Choose the browse tool from the Tools menu.
15. Click on the View Pig button.
17. Choose the browse tool from the Tools menu.
18. Click on the return arrow button to return to the overview card.

You can now browse the completed stack on cats, dogs, and pigs. This was a fairly easy example, and shows how simple it can be to use HyperCard to author interactive multimedia projects. Now let's take a brief look at some other multimedia authoring environments.

**Other Multimedia Authoring Environments**

While the scope of this book doesn't allow for a complete examination of every multimedia authoring environment, I want to mention two excellent Macintosh programs for authoring multimedia.

**Director**

*Director* from MacroMedia was one of the first multimedia authoring systems for the Macintosh. Using a theatre metaphor, Director uses a cast, stage, and directions for producing interactive presentations. Many professionally released productions have been created with Director, and it's a must for every multimedia authoring tool chest. Figure 8.25 shows a screen from Director.
FIGURE 8.25:  MacroMind Director

**Passport Producer Pro**

Passport's *Producer Pro* is one of the newest multimedia authoring programs for the Mac. *Producer Pro* uses a timeline metaphor much like Adobe Premier's except the timeline travels from top to bottom rather than from left to right. *Producer Pro* features tracks that contain cues—these can be QuickTime movies, digital audio, CD tracks, slides, or MIDI sequences (see Figure 8.26). The method for adding interactivity and editing media elements is less direct than those in other programs, but *Producer Pro* is nonetheless a powerful collection of authoring tools.

The world of multimedia is an exciting one, and one that is growing by leaps and bounds. I hope this book has explained some of the many issues involved in producing interactive multimedia works, and demystifying the various ways sound can be used on the Mac. I also hope the book has helped you appreciate the value of sound and music in underscoring emotional content in the mixed media environment.
The Appendices that follow give you additional information on hardware and software products for multimedia, more detailed instructions in the use of Media Tools for HyperCard, and a complete list of all the files on the Multimedia Machine CD-ROM.
CD Contents

The Multimedia Machine CD contains 350 MB of software and data files, as well as almost 20 minutes of CD audio, for a total of about 600 MB of data! This first section provides an overview of and information about the contents of the CD-ROM.

Software

This section outlines the software applications on the Multimedia Machine CD, including their copyright notices and information on obtaining complete versions of demo software.

Media Tools and MediaTools Runner

Media Tools and MediaTools Runner are copyrighted ©1993 by David S. Mash, with all rights reserved. Under copyright law, this software may not be duplicated in whole or part without the written consent of David S. Mash. This is a limited version of Media Tools. The full version can be
obtained by returning the upgrade order form contained in the Media Tools Manual file on the CD to:

The Media Mashine
PO Box 3028
Framingham, MA 01701

Full Licensing information is found in the Media Tools Instructions section of this appendix as well as in the Media Tools Manual on the CD.

Adobe Premier Demo
Adobe Premier is a powerful QuickTime movie and digital video editing environment. The current version is 3. Information on obtaining the full version of Adobe Premier is available from:

Adobe Systems
1585 Charleston Road
PO Box 7900
Mountain View, CA 94039
(415) 962-7200

Digidesign TurboSynth Demo
TurboSynth is a multi-purpose application for designing, editing, and creating digital sound. The current version is 2.2. Information on obtaining the full version of TurboSynth SC is available from:

Digidesign, Inc.
1360 Willow Road Suite 101
Menlo Park, CA 94025
(415) 688-0600
**Opcode MusicShop Demo**

MusicShop is a simple-to-use, full-featured MIDI sequencing and notation program. Information on obtaining the full version of MusicShop is available from:

Opcode Systems  
3950 Fabian Way  
Suite 100  
Palo Alto, CA 94303  
(415) 856-3333

**SndConverter**

SndConverter is by Joe Zobkiw. It converts SND resources to System 7 sounds, and is distributed as freeware. You may copy it freely from the Multimedia Machine CD and give it away to all your friends! You may not, however, sell or distribute it as part of a compilation of software without written permission from Joe Zobkiw.

**MIDI 'n' Synths**

This interactive study on MIDI synthesizers and sound design is copyright ©1993 by David S. Mash, and may not be distributed in any form. It is provided for use in Explorations 4.8 and 6.6.

**Desktop Music Production**

This interactive HyperCard stack allows you to explore ways of producing music in the digital domain using the Macintosh computer. Desktop Music Production is copyright ©1993 by David S. Mash and may not be distributed in any form.

**Scroll-It!**

The Scroll-It! stack is copyright ©1993 by David S. Mash and may not be distributed in any form. It is provided as the underlying tool for Explorations 5.3, 6.2, and 7.6. You may use Scroll-It! in producing your own multimedia work, but may not sell or distribute any stacks that contain the Scroll-It! core routines.
Explorations

Multimedia Machine is meant to be read while performing interactive exercises at the computer. The following lists all of the Explorations by chapter, noting what software and files are used for each exercise.

Chapter 2

<table>
<thead>
<tr>
<th>Exploration</th>
<th>Application</th>
<th>File(s) Used</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.1: The Role of Music in Multimedia</td>
<td>HyperCard</td>
<td>Maria Lionza, Mute</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Maria Lionza</td>
</tr>
<tr>
<td>2.2: Playing Digital Audio on the Mac</td>
<td>HyperCard</td>
<td>Darker Shade of Gray.22k</td>
</tr>
<tr>
<td>2.3: Playing Audio from CD</td>
<td>HyperCard</td>
<td>Track 2—CD Audio</td>
</tr>
<tr>
<td>2.4: Playing Back Sound from a MIDI Synthesizer</td>
<td>HyperCard</td>
<td>ADSOG</td>
</tr>
<tr>
<td>2.5: Comparing the Three Sound Formats</td>
<td>HyperCard</td>
<td>22kHz Phrase, Track 2—CD Audio, ADSOG</td>
</tr>
<tr>
<td>2.6: Sampling Rates and Resolutions</td>
<td>HyperCard</td>
<td>Track 2—CD Audio, 22kHz Phrase, 11kHz Phrase</td>
</tr>
<tr>
<td>2.7: Controlling an Audio CD</td>
<td>HyperCard</td>
<td>Track 3—CD Audio</td>
</tr>
<tr>
<td>2.8: Changing Sounds on a MIDI Synthesizer</td>
<td>HyperCard</td>
<td>Patch Change Seq</td>
</tr>
</tbody>
</table>
Chapter 3

<table>
<thead>
<tr>
<th>Exploration</th>
<th>Application</th>
<th>File(s) Used</th>
</tr>
</thead>
<tbody>
<tr>
<td>3.1: Using MoviePlayer</td>
<td>MoviePlayer</td>
<td>Maria Lionza</td>
</tr>
<tr>
<td>3.2: Using the Movie Tools</td>
<td>HyperCard</td>
<td>Maria Lionza</td>
</tr>
<tr>
<td>3.3: Editing QuickTime movies (Part 1: Setting In and Out Points)</td>
<td>Adobe Premier</td>
<td>Small River Segment 1</td>
</tr>
<tr>
<td>3.3: Editing QuickTime movies (Part 2: Removing Unwanted Sections)</td>
<td>Adobe Premier</td>
<td>Small River Segment 1</td>
</tr>
<tr>
<td>3.3: Editing QuickTime movies (Part 3: Combining Video Segments)</td>
<td>Adobe Premier</td>
<td>Small River Segment 1</td>
</tr>
<tr>
<td>3.3: Editing QuickTime movies (Part 4: Adding Transitions)</td>
<td>Adobe Premier</td>
<td>Small River Segment 1</td>
</tr>
<tr>
<td>3.3: Editing QuickTime movies (Part 5: Volume Envelopes)</td>
<td>Adobe Premier</td>
<td>Small River Segment 2</td>
</tr>
<tr>
<td>3.3: Editing QuickTime movies (Part 6: Using Filters)</td>
<td>Adobe Premier</td>
<td>Small River Segment 4</td>
</tr>
</tbody>
</table>
## Chapter 4

<table>
<thead>
<tr>
<th>Exploration</th>
<th>Application</th>
<th>File(s) Used</th>
</tr>
</thead>
<tbody>
<tr>
<td>4.1: Adding an Alert Sound and Setting the System Beep</td>
<td>System</td>
<td>Bucket-o-fish</td>
</tr>
<tr>
<td>4.2: Setting the Input Device</td>
<td>Sound</td>
<td></td>
</tr>
<tr>
<td>4.3: Setting the Output Device</td>
<td>Sound</td>
<td></td>
</tr>
<tr>
<td>4.4: Playing Back a Disk File with Audio Tools</td>
<td>HyperCard</td>
<td>Fall Equinox.22</td>
</tr>
<tr>
<td>4.5: Recording to RAM with Audio Tools</td>
<td>HyperCard</td>
<td></td>
</tr>
<tr>
<td>4.6: Recording a Disk File with Audio Tools</td>
<td>HyperCard</td>
<td></td>
</tr>
<tr>
<td>4.7: Editing Digital Audio with TurboSynth</td>
<td>TurboSynth</td>
<td>1-2-3.AIFF</td>
</tr>
<tr>
<td>4.8: Sound Design Concepts</td>
<td>HyperCard</td>
<td>MIDI 'n' Synths</td>
</tr>
<tr>
<td>4.9: Understanding Patches</td>
<td>TurboSynth</td>
<td>4.9 Announce-Chime</td>
</tr>
<tr>
<td>4.10: Creating a Patch</td>
<td>TurboSynth</td>
<td>4.10 Space Noise, TurboSynth Space Noise</td>
</tr>
<tr>
<td>4.11: Converting a sound to a system beep</td>
<td>sndConverter</td>
<td>4.5 Recording to RAM, TurboSynth Space Noise</td>
</tr>
</tbody>
</table>
## Chapter 5

<table>
<thead>
<tr>
<th>Exploration</th>
<th>Application</th>
<th>File(s) Used</th>
</tr>
</thead>
<tbody>
<tr>
<td>5.1: Working with the CD Tools</td>
<td>HyperCard</td>
<td>Track 2—CD Audio</td>
</tr>
<tr>
<td>5.2: Synchronizing slides to music from CD</td>
<td>HyperCard</td>
<td>Track 4—CD Audio, Falls 1, Falls 2, Falls in Hole, River Rocks, Two Guys in a Canoe, Whirlpool</td>
</tr>
<tr>
<td>5.3: Converting Audio CDs to Quick-Time Soundtracks</td>
<td>MoviePlayer</td>
<td>Track 2—CD Audio</td>
</tr>
<tr>
<td>5.4: Editing the Music as a QuickTime Movie in Premier</td>
<td>Adobe Premier</td>
<td>Converted Audio 1</td>
</tr>
<tr>
<td>5.5: Converting QuickTime Soundtracks to AIFF Files</td>
<td>Adobe Premier</td>
<td>Converted Audio 1</td>
</tr>
<tr>
<td>5.6: Playing the Converted AIFF from HyperCard</td>
<td>HyperCard</td>
<td>Converted Audio 1.AIFF</td>
</tr>
</tbody>
</table>

## Chapter 6

<table>
<thead>
<tr>
<th>Exploration</th>
<th>Application</th>
<th>File(s) Used</th>
</tr>
</thead>
<tbody>
<tr>
<td>6.1: Musicians on MIDI</td>
<td>HyperCard</td>
<td>Carlos, Herbie, Laurie, Tom, Tony</td>
</tr>
</tbody>
</table>
CD Contents

Exploration | Application | File(s) Used
--- | --- | ---

6.3: Recording a MIDI Sequence Using MIDI Tools | HyperCard | Modal Groove

6.4: Playing and Editing a Standard MIDI File with MIDI Tools | HyperCard | C-Vamp, F Vamp, Ab groove

6.5: Playing and Editing a Standard MIDI File with MusicShop | MusicShop | MIDI 'n' Synths

6.6: MIDI 'n' Synths | HyperCard | MIDI 'n' Synths

Chapter 7

Exploration | Application | File(s) Used
--- | --- | ---
7.1: Musical Choices | HyperCard | New Age River Movie, River Chase Movie, Circus River Movie

7.2: Using Text with Media Tools | HyperCard | Media Tools Text

7.3: Using Graphics with Media Tools | HyperCard | flat rocks.pict, sea scape.pict
<table>
<thead>
<tr>
<th>Exploration</th>
<th>Application</th>
<th>File(s) Used</th>
</tr>
</thead>
<tbody>
<tr>
<td>7.4: Adding Music to Video</td>
<td>Adobe Premier</td>
<td>River Movie, Chase Audio, NewAge Audio, Chimes, Liquid, Flex</td>
</tr>
<tr>
<td>7.5: Creating a Simple Multimedia Example</td>
<td>HyperCard</td>
<td>BackDrop, Fall Equinox.11, River Movie</td>
</tr>
<tr>
<td>7.6: Creating a Slide Show</td>
<td>HyperCard</td>
<td>Falls in hole, River Rocks, Two Guys in a Canoe, Whirlpool, Track 4—CD Audio (Looking Back)</td>
</tr>
</tbody>
</table>

**Chapter 8**

<table>
<thead>
<tr>
<th>Exploration</th>
<th>Application</th>
<th>File(s) Used</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exploration 8.1: Interactive MIDI</td>
<td>HyperCard</td>
<td>8.1 Interactive MIDI</td>
</tr>
<tr>
<td>Exploration 8.2: Working with Fields</td>
<td>HyperCard</td>
<td>8.2 Working with Fields</td>
</tr>
<tr>
<td>Exploration 8.3: Working with Buttons</td>
<td>HyperCard</td>
<td>8.3: Working with Buttons</td>
</tr>
<tr>
<td>Exploration 8.4: Cards and Backgrounds</td>
<td>HyperCard</td>
<td>8.4: Cards and Backgrounds</td>
</tr>
<tr>
<td>Exploration 8.5: Creating Links</td>
<td>HyperCard</td>
<td>8.5: Creating links</td>
</tr>
<tr>
<td>Exploration 8.6: Buttons and Navigation</td>
<td>HyperCard</td>
<td>8.6: Buttons and navigation</td>
</tr>
</tbody>
</table>
Music

The Multimedia Machine CD contains a number of music files in a variety of formats. All music on this disc is copyrighted ©1993 by David Mash, with all rights reserved. No portion of this music may be duplicated for any purpose or be used or distributed for profit in any form. The following lists each file and its intended use in the context of this book.

Digital Audio Files

Except where noted, these are all stored as AIFF files.

11kHz Phrase This is a short phrase from the piece A Darker Shade of Gray and is used in Exploration 2.6 in exploring various sample rates and resolutions.

22kHz Phrase This is a short phrase from the piece A Darker Shade of Gray and is used in Explorations 2.5 and 2.6 in exploring various sample rates and resolutions.

Chase Audio This is the basis of the soundtrack for the River Chase Movie as well as for Exploration 7.4.

Circus Audio This is the basis for the soundtrack of the Circus River Movie.

Converted Audio 1 This is a QuickTime movie soundtrack created in Exploration 5.4.

Converted Audio 1.AIFF This is the AIFF file created from the QuickTime movie soundtrack above, used in Explorations 5.6 and 5.7.

Darker Shade of Gray.11k A low-resolution version of Track 2 (CD Audio).

Darker Shade of Gray.22k A medium-resolution file version of Track 2 (CD Audio) used in Exploration 2.2.

Darker Shade of Gray.44k A high-resolution version of Track 2 (CD Audio) useful only if you have a 16-bit sound card capable of 44kHz
playback (such as the Media Vision Pro Audio Spectrum 16, or Digidesign Audiomedia II cards).

**Fall Equinox.11** A low-resolution version of Track 5 (CD Audio) also used in Exploration 7.5.

**Fall Equinox.22** A medium-resolution version of Track 5 (CD Audio).

**Looking Back.11k** A low-resolution version of Track 4 (CD Audio).

**Looking Back.22k** A medium-resolution version of Track 4 (CD Audio).

**NewAge Audio** This is the basis of the soundtrack for the New Age River Movie as well as for Exploration 7.4.

**NewAge Audio 44** A high-resolution file in Sound Designer II format for use with Digidesign's Audiomedia II card.

**NewAge Audio 44AIFF** A high-resolution file in AIFF format for use with 16-bit sound cards.

**¡Acincha! AIFF.11kHz** A low-resolution version of Track 3 (CD Audio).

**¡Acincha! AIFF.22kHz** A medium-resolution version of Track 4 (CD Audio).

**¡Acincha! Moov.22** A medium-resolution version of Track 4 (CD Audio) in QuickTime movie format.

**MIDI Files**

These are all stored as standard MIDI file (SMF) format.

**ADSOG** A MIDI format version of A Darker Shade of Gray (Track 2 CD Audio), also used in Exploration 2.4.

**Chase.smf** A MIDI format version of the sound track for the River Chase Movie.

**Circus.smf** A MIDI format version of the sound track for the Circus River Movie.
CD Contents

**New Age.smf** A MIDI format version of the sound track for the New Age River Movie.

**Patch Change Seq** A MIDI sequence file used for Exploration 2.8.

**Ab Groove** A MIDI sequence file used for Exploration 6.5.

**C-Vamp** A MIDI sequence file used for Exploration 6.5.

**F Vamp** A MIDI sequence file used for Exploration 6.5.

**Modal Groove** A MIDI sequence file.

**New Groove** A MIDI sequence file used for Exploration 6.2.

**Sound Effects**

These are all stored in AIFF format.

**Chimes** Woodstock chimes used for Exploration 7.4.

**Cluk** AIFF version of system beep file provided on CD.

**Dog** AIFF version of system beep file provided on CD.

**Flex** Woodstock chimes used for Exploration 7.4.

**Glass** AIFF version of system beep file provided on CD.

**Gun Shot** AIFF file for use as sound effect.

**Hi Hit** AIFF file for use as sound effect.

**Hit 2** AIFF file for use as sound effect.

**Horse Steps** AIFF file for use as sound effect.

**Liquid** Woodstock chimes used for Exploration 7.4.

**Percussive Hit** AIFF file for use as sound effect.

**Telephone** AIFF version of system beep file provided on CD.
System Beeps

These are all System 7 style alert sounds.

**BiederBells** A sound made from bells used at my friend Kurt Biederwolf's wedding.

**Bucket-of-fish** My drum and cymbal crash response to a bad joke.

**Chimes** Woodstock wind chimes.

**Cluk** Finger in cheek popping sound.

**Dog** A dog bark. Woof!

**Glass** Plate glass window breaking. Don’t try this at home!

**Harp** An ethereal sound effect.

**HeadSpace** Analog synthesizer (Oberheim Xpander) sound effect.

**Hey** Just me yelling “Hey!”

**Huey** Analog synthesizer (Oberheim Xpander) sound effect.

**Liquid** Pouring liquid into a glass.

**Lo Chimes** The Chimes from above, with pitch shifted down.

**Oh No!** Just me, reacting while working at the computer!

**Reactor** Analog synthesizer (Oberheim Xpander) sound effect.

**Telephone** An old bell ringer telephone—nothing electronic here, just answer it already!

**Woops** Me again—another accident!
QuickTime Movies

Here is a complete list of the QuickTime movies on the CD-ROM.

Maria Lionza

*Maria Lionza* is a film, copyright ©1992 by Hector Mendez Caratini, with all rights reserved. Hector shot this film while vacationing in Venezuela, and digitized and edited it at the Kodak Center for Creative Imaging (CCI) in Camden, Maine. I met Hector while he was working on the project and I was teaching a seminar on digital audio, MIDI, and music for multimedia at CCI. I composed the soundtrack for *Maria Lionza*. I performed the music into Opcode’s Vision software, recorded it to hard disk and edited it using Digidesign’s Sound Designer II software. Hector then laid the audio into Adobe Premier to complete the process. The entire soundtrack was produced on a single synthesizer—the Korg 01/W fd—and completed in under 2 hours!

Hector entered the project in the 1992 Annual International QuickTime Movie Festival Awards, and won Best Movie in the documentary category. *Maria Lionza* was released on the compact disc *QuickTime: The Movies—the Winners of the 1992 International QuickTime Movie Festival Awards* published by Sumeria.

This movie is used for Explorations 2.1 and 3.1.

Mute Maria

This is the *Maria Lionza* movie with the soundtrack deleted. It is used in Exploration 2.1 as contrast to the complete movie with music.

Big Musicians: Carlos, Herbie, Laurie, Tom, Tony

These are all 30 fps, 320×240, JPEG encoded movies. You will need to have SuperMac’s Digital Film system to play them. Used by the HyperCard stack, Musicians on MIDI.df, these are movies of well-known musicians telling how MIDI has helped them with their work.
**Musicians: Carlos, Herbie, Laurie, Tom, Tony**

These are all 15 fps, 160×120, QuickTime movies used by the HyperCard stack, Musicians on MIDI for Explorations 6.1 and 8.1. They are movies of well-known musicians telling how MIDI has helped them with their work.

**New Age River Movie**

This is the Niagara River movie with a new age sound track, used in Exploration 7.1.

**River Chase Movie**

This is the Niagara River movie with a chase scene sound track, used in Exploration 7.1.

**Circus River Movie**

This is the Niagara River movie with circus music for a sound track, used in Exploration 7.1.

**Large River Movie**

This is a 240×180 version of the *River Movie* in case you have a very fast machine with lots of hard drive space and want to watch a larger version of the *River Movie*.

**River Movie**

A 160×120 QuickTime movie of the Niagara River used in Exploration 7.4.

**River MovieFiles: Big Rivers:Large River Project**

These folders and files contain the source files for the Large River Movie. You may also use the Large River Segment files for Exploration 3.3 if you have a very fast computer with lots of hard disk space.
River MovieFiles: Little Rivers: River Project, Backdrop, And Title

These folders and files contain the source files for the River Movie. The Small River Segment files are used for Exploration 3.3.

• Pictures

Here is a complete list of the pictures on the CD-ROM.

BackDrop This is a 24-bit color graphic used as a background screen for Exploration 7.5.

Falls 1 This is an 8-bit gray scale image of Niagara Falls used in Exploration 5.2.

Falls 2 This is an 8-bit gray scale image of Niagara Falls used in Exploration 5.2.

Falls in Hole This is an 8-bit gray scale image of Niagara Falls used in Exploration 5.2.

River Rocks This is an 8-bit gray scale image of the Niagara River used in Exploration 5.2.

Two Guys in a Canoe This is an 8-bit gray scale image of two editors of the Middlesex News (Framingham, MA) canoeing on the Sudbury River, used in Exploration 5.2.

Whirlpool This is an 8-bit gray scale image of the Niagara River used in Exploration 5.2.

Chairs.pict This is a 24-bit color picture taken with a Canon XapShot camera in Rockport, MA used in Exploration 6.2.

flat rocks.pict This is a 24-bit color picture taken with a Canon XapShot camera in Rockport, MA used in Exploration 6.2.

harbor.pict This is a 24-bit color picture taken with a Canon XapShot camera in Rockport, MA used in Exploration 6.2.
mantis.pict  This is a 24-bit color picture taken with a Canon XapShot camera in Rockport, MA used in Exploration 6.2.

Rockbg1.pict  This is a 24-bit color picture taken with a Canon XapShot camera in Rockport, MA used in Exploration 6.2.

Rockbg2.pict  This is a 24-bit color picture taken with a Canon XapShot camera in Rockport, MA used in Exploration 6.2.

Rockbg3.pict  This is a 24-bit color picture taken with a Canon XapShot camera in Rockport, MA used in Exploration 6.2.

seascape.pict  This is a 24-bit color picture taken with a Canon XapShot camera in Rockport, MA used in Exploration 6.2.

Musician at Work  This is a 24-bit color picture developed as a PhotoCD file, featuring Dennis Thurmond at Berklee College of Music in Boston, MA.

Teacher and Student  This is a 24-bit color picture developed as a PhotoCD file, featuring Robin Coxe-Yeldham and Kazuhiko Gomi in a MIDI lab at Berklee College of Music in Boston, MA.

System Extras

These files are installed during Chapter 1 and add functionality to the system.

QuickTime  This allows the Macintosh to play movies, synchronize sound and picture, and use the compression/decompression schemes.

Apple CD Extension  This allows the Macintosh to mount and access CD-ROMs as if they were floppy disks.

Foreign File Access  This allows the Mac to use the following file translators to read CDs as Macintosh disks:

- Audio CD Access
- High Sierra Access
- ISO 9660 Access
CD Contents

Sound Manager 3 This file allows the Mac to record and play back digital audio at a variety of sample rates and resolutions.

Sound This control panel allows you to choose input and output devices, control the volumes of various sound devices, and set the current system alert sound.

DigiSystem INIT This file keeps track of what Digidesign sound cards are in your Mac, and directs audio traffic to the most appropriate card.

Digidesign Sound Drivers These drivers allow you to record and play back 16-bit, 44 kHz digital audio files on a Digidesign card using the Sound Manager and Sound control panel.

Sonata This is the music notation screen font used by the MusicShop demo application.

Vision This is the keyboard layout file used by the MusicShop demo application.

CD Audio Tracks

Here is a complete list of the audio tracks on the CD-ROM. The CD was cut using the JVC Personal ROMMaker.

A Darker Shade of Gray

The title of this tune refers to my color blindness. People are always giving me directions like “turn left at the yellow house.” My response is always, “which house is yellow?” After pointing out the particular house in question they invariably ask, “What color does it look like to you?” My response is usually either a lighter or darker shade of gray...

This tune was produced using Opcode Systems’ Studio Vision software. I performed all the tracks, except for the saxophone, on MIDI synthesizers. A simplified version, orchestrated for General MIDI synthesizers, is included on the Multimedia Machine CD as a standard MIDI file called ADSOG. Bruce Nifong plays the alto saxophone on the track. I recorded him directly into the computer using Digidesign’s Pro Tools multitrack recording hardware system and the Studio Vision software. The tracks were mixed
using a Macintosh Quadra 800 computer, and the following synthesizers:

- Korg 01/W, S3, and Wavestation
- Kurzweil 250
- Oberheim Xpander
- Digidesign SampleCell II card

The tracks were mixed down to DAT tape, brought back into the Mac using a direct digital interface, then edited for storage on the CD-ROM using Digidesign’s Sound Designer II software.

¡Acincha!

This tune is named for an old friend of mine, Cynthia Hilts. Her younger sister couldn’t pronounce her name properly—it came out “Cincha.” The name is a play on this and the Latin quality of the music.

I played all of the tracks except for guitar and saxophone using MIDI synthesizers. I played the guitar track using a Hohner “Steinberger” G3 model electric guitar through a Zoom digital signal processor. Bruce Nifong played alto saxophone, and everything was laid down using Opcode Systems’ Studio Vision software and Digidesign’s Pro Tools hardware. The tracks were mixed using a Macintosh Quadra 800 computer, and the following synthesizers:

- Korg 01/W, S3, and Wavestation
- Kurzweil 250
- Oberheim Xpander
- Roland D110
- Kawai K4r
- Digidesign SampleCell II card

The tracks were mixed down to DAT tape, brought back into the Mac using a direct digital interface, then edited for storage on the CD-ROM using Digidesign’s Sound Designer II software.
Looking Back

This tune was the first piece of music I ever created using Opcode Systems' Studio Vision software. The title refers to my looking back to a former part of my life in relation to this first time experience of incorporating my guitar into the Macintosh as a fundamental element of the compositional process. I began writing this piece by playing the guitar arpeggio into the Mac, copying and pasting sections of it to create the complete form, then adding the MIDI synthesizers. This software changed my life, allowing me to combine both electronic and acoustic instruments into my favorite composing environment—Vision sequencing and the Macintosh.

I played all of the parts on this piece and, except for the guitar, everything is performed on a MIDI synthesizer. The synthesizers used include:

- Korg 01/W, S3, and Wavestation
- Kurzweil 250
- Oberheim Xpander
- Roland D110
- Kawai K4r
- Digidesign SampleCell II card

The tracks were mixed down to DAT tape, brought back into the Mac using a direct digital interface, then edited for storage on the CD-ROM using Digidesign's Sound Designer II software.

Fall Equinox

I created this piece for a multimedia show put on by United Digital Artists at the Apple Center in New York City. It was written on September 21, 1993—the autumnal equinox. Well, they didn't use it (they used another piece I submitted at the same time) so I'm including it here!

This piece features the Korg Wavestation synthesizer and Digidesign SampleCell II card, but also uses a Korg 01/W and Kurzweil 250 synthesizer. I played all of the tracks, including the classical guitar track—using a Yamaha APX 10N electric classical guitar.
The tracks were mixed using a Macintosh Quadra 800 computer, recorded down to DAT tape, brought back into the Mac using a direct digital interface, then edited for storage on the CD-ROM using Digidesign's Sound Designer II software.
Recommended Hardware and Software

This appendix is provided to help you find representative multimedia products to assist your production work. No product endorsements are intended, nor should you be discouraged from investigating products I've omitted. These are simply popular multimedia products that I am personally familiar with.

Hardware

Multimedia hardware includes powered speakers, audio cards, MIDI synthesizers, MIDI sound cards, and video digitizers.

Powered Speakers

In the category of powered speakers, there are three brands that have proven quite popular.
Recommended Hardware and Software

Appledesign Speakers
These are made by Apple Computer and feature a frequency response of 70 Hz–15 kHz. They are magnetically shielded, have 5 watts of power per channel, two sets of stereo inputs, headphone and subwoofer outputs, master volume and balance controls. List price: $179.

Persona Technologies Mac Speaker
Mac Speakers feature a frequency response of 70 Hz–18 kHz. They are magnetically shielded, have 10 watts of power per channel, stereo mini jack inputs, headphone and stereo outputs, master volume, bass boost, and ambiance controls. List price: $199.95.

Korg PM-5
The Korg PM-5 speakers feature a frequency response of 100 Hz–20 kHz. They are magnetically shielded, have 5 watts of power per channel, two sets of stereo inputs, headphone and subwoofer outputs, and volume. List price: $225.

Audio Cards
In the category of audio cards, there are several popular choices.

Media Vision Pro Audio Spectrum (PAS) 16
The PAS 16 card comes in NuBus and LC PDS versions and provides 16-bit 44.1 kHz digital audio recording and playback with four stereo analog audio inputs, a microphone input, stereo headphone output, and a set of stereo analog outputs as well as MIDI in and out jacks. Bundled software includes Sound Edit Pro, which can only record at 22 kHz sample rate and doubles each sample to simulate 44 kHz playback. List Price $299.

Digidesign Audiomedia II
Audiomedia II is a 16-bit professional NuBus sound card that allows up to four tracks of digital audio recording and playback with sample rates of up to 48 kHz. The card has digital ins and outs as well as stereo analog inputs
and outputs. The card comes bundled with Sound Designer II software—an industry standard for high quality digital audio editing. The card also features a Motorola Digital Signal Processing chip (DSP) that allows for real time processing including graphic equalization, parametric equalization, time compression and expansion, and dynamics compression. List price: $1295.

**Digidesign Pro Tools**

Pro Tools is a high-end multitrack digital audio recording, mixing, and editing package with MIDI sequencing and playback. Hardware may be expanded to up to 16 channels of hard-disk recording, including professional level XLR balanced inputs and outputs for each channel. Digital inputs and outputs support AES/EBU and S/PDIF protocols. Pro Tools software allows for digital recording, editing, and mixing of unlimited numbers of virtual channels. Also available is PostView software for precise frame synchronization among digital audio, MIDI, and QuickTime movie playback of any frame rate. List Price: $5995 and up.

**MIDI Synthesizers**

The following are recommended GM synthesizers.

**Keyboard Workstations**

MIDI keyboard workstations are those that incorporate a keyboard and a MIDI synthesizer into one instrument.

**Korg X3** The X3 is a 32-voice polyphonic, multitimbral, 61 note keyboard synthesizer based on samples and subtractive synthesis. It contains a 16-track sequencer, features General MIDI compatibility, and has a disk drive as well as expansion card slots. The X3 is a perfect all around instrument for MIDI file creation for multimedia. List Price: $1949.

**Roland JV30** The JV30 is a 24-voice polyphonic, 16-part multitimbral synthesizer with 61 note velocity and pressure sensitive keyboard. The JV30 uses PCM samples as its basic sound building block with subtractive synthesis techniques. Over 400 sound setups can be accessed from internal memory. List price: $1195.
Recommended Hardware and Software

Sound Modules
MIDI sound modules are, more or less, synths without the keyboard.

Korg 05r/W The Korg 05r/W is a low cost, half-rack space module with integrated MIDI interface. It features 32-voice polyphony with 16-part multitimbral playback. List price: $799.

Korg Audio Gallery The Audio Gallery is much like the 05r/W but with fewer controls on the front panel. It has audio input and output and is specifically designed for multimedia applications. List price: $399.

Roland Sound Canvas The Sound Canvas is a 24-voice, 16-part multitimbral sound module in a small desktop package. Using PCM samples and subtractive synthesis techniques, the SC-155 produces sounds much like the Roland JV30 listed above. List price: $895.

Yamaha TG100 The TG100 is a 28-note polyphonic, 16-part multitimbral sound module that uses sampled sound as its basic sound generation technique. The TG100 also includes a built-in MIDI interface and may be directly connected to the Mac's serial port. List price: $449.95.

MIDI Sound Cards—Digidesign SampleCell II
SampleCell II is a high-quality digital 32-voice polyphonic, 16-part multitimbral sample player, capable of playing back 44.1 kHz, 16-bit stereo (CD-quality) samples created using Digidesign's Sound Designer II software. Included with SampleCell are two CD-ROM disks containing hundreds of megabytes of data featuring a wide variety of acoustical instrument timbres and useful sound effects. SampleCell can be configured with up to 32 MB of on-board memory for instant access to a wide variety of sounds. List Price: $1995.
Video Digitizers
Let's look at four video digitizers.

SuperMac VideoSpigot
VideoSpigot is a low-cost video digitizer with video input only. It can capture at frame rates of up to 30 fps at window sizes of up to 320×240. NTSC, PAL, and SECAM input are supported, and bundled software includes Adobe Premier and ScreenPlay. List price: $279 (LC) or $429 (NuBus).

SuperMac DigitalFilm
DigitalFilm is a professional video editing system supporting frame rates of up to 30 fps (60 fields) and resolutions of up to 640×480. NTSC, PAL, and SECAM input and output is supported, and bundled software includes Adobe Premier, Director, Cosa After Effects, Diaquest DQ, Time Coder, and Disk Express. Stereo sound inputs and outputs are also provided. List Price: $3999.

Radius VideoVision Studio
VideoVision Studio includes two video and stereo audio inputs, and supports frame rates of up to 30 fps (60 fields) and resolutions of up to 640×480. NTSC, PAL, and SVHS input and output is supported, and bundled software includes Adobe Premier and VideoFusion. List Price: $4499.

RasterOps MediaTime with MoviePak Daughter Board
This system supports 30 fps, 640×480 resolution recording and playback, with 16-bit stereo audio input and output. NTSC, PAL and SECAM input and output are supported. Bundled software includes Media Grabber. List price: $2999.

Software
Multimedia software includes sequencers, audio editors, video editors, and multimedia authoring packages.
MIDI Sequencers

Let's look at three noteworthy MIDI sequencers.

**Opcode MusicShop**

MusicShop is a 16-track sequencer with graphic and notation displays. MusicShop features full MIDI editing functions including arrangement, quantizing, and mixing in an easy to use, intuitive package. List price: $149.

**Passport Trax**

Trax is a 16-track sequencer with list and graphic editing. Trax features full MIDI editing functions with an intuitive interface. List price: $99.

**Mark of the Unicorn Performer**

Performer is a professional-level sequencer with unlimited tracks, but with a non-standard user interface. Performer's windows do not support the standard Macintosh interface, but are attractive art-deco-like alternatives. List Price: $495.

Audio Editors

Let's look at four audio editors.

**MacroMedia Sound Edit Pro**

Sound Edit Pro is a popular digital audio editor with some basic editing tools and special effects. Sound Edit Pro allows you to record, edit, and playback sounds with 8- or 16-bit resolution at sample rates of up to 22 kHz. Faster sample rates are simulated by doubling each sample. List price: $295.

**Digidesign Sound Designer II**

Sound Designer II software is the industry standard sound recording and editing package. Sound Designer II allows you to record sound and edit using cut, copy, and paste techniques as well as very sophisticated digital signal processing algorithms such as mixing, graphic and parametric equalization, sample rate conversion, pitch shifting, time compression/expansion, and more. List price: $995, but included free with Audiomedia II cards.
**Digidesign TurboSynth**
TurboSynth is a modular synthesis, sound design, and editing package for the Macintosh. Sample recording, editing, and processing are performed in an intuitive graphic environment. List price: $349.

**Opcode Systems AudioShop**
AudioShop is a combination digital audio recording and editing and CD audio control program. Using an attractive CD player interface, AudioShop allows you to set regions of CD audio to play, to edit digital audio, and to convert between AIFF, Sound Edit, QuickTime, and resource file formats. List price: $89.95.

**Video Editors**
Let’s look at two popular video editors.

**Adobe Premier**
Adobe Premier is a powerful digital video editing package featuring up to 99 video tracks and 99 audio tracks. AIFF, QuickTime, Filmstrip, PICT, PICS, Sound Edit, Illustrator, and Photoshop files are all supported. List price: $695.

**Avid VideoShop**
VideoShop allows unlimited audio and video tracks and supports AIFF, QuickTime, PICT, PICS, Sound Edit, PhotoCD, and CD audio files. VideoShop doesn’t offer as many options for effects or output as Adobe Premier but does provide most useful functions. List price: $499.

**Multimedia Authoring**
Here are four multimedia authoring packages.

**Apple HyperCard**
HyperCard is a simple but powerful authoring environment. Its greatest strength is its extendibility through external commands. Coupled with
enhancements like Media Tools, HyperCard makes a good all purpose authoring environment. Apple price: about $100.

**Passport Producer Pro**

Producer Pro uses a timeline metaphor much like Adobe Premier's except the timeline travels from top to bottom rather than from left to right. Producer Pro features tracks that can contain cues—each of which can be QuickTime movies, digital audio, CD tracks, slides, or MIDI sequences. List price: $1295.

**AuthorWare Professional**

AuthorWare Professional is a powerful multimedia authoring environment. Designed originally as an educational tool for building software-based courses, AuthorWare Professional uses a logic-flow, object-oriented approach to building a presentation. Although icon-driven, the program requires the multimedia producer to understand basic principles of logic and software design, but provides a powerful graphic language for creating interactive presentations. List price: $4995.

**MacroMedia Director**

Director from MacroMedia was one of the first multimedia authoring systems for the Macintosh. Using a theater metaphor, Director uses a cast, stage, and directions for producing interactive presentations. List price: $1195.
Media Tools
Instructions

There is a complete manual in soft form on the Multimedia Machine CD. This section is a summary of the main Media Tools functions.

License Agreement

Media Tools is copyrighted ©1993 by David S. Mash, with all rights reserved. Under copyright law, this software may not be duplicated in whole or part without the written consent of David S. Mash. Carefully read all the terms and conditions of this license agreement prior to using this package. Use of all or any portion of this package indicates your agreement to the following terms and conditions.

The Media Machine grants you, the purchaser, a non-exclusive license to use the software in this package (the “Software”), under the terms and conditions stated in this agreement.
Media Tools Instructions

You may:
- Use the Software on a single machine.

You may not:
- Make copies of the user manual or the Software in whole or in part except as expressly provided for in this agreement.
- Make alterations or modifications to the Software (or any copy) or disassemble or decompile the Software (or any copy), or otherwise attempt to discover the source code of the Software.
- Sublicense, lease, lend, rent, or grant other rights in all or any portion of the Software (or any copy) to others.
- Make verbal or media translations of the manual.
- Make telecommunications data transmissions of the Software.

**NOTE**
This agreement is effective until terminated. You may terminate it at any time by destroying the Software together with all copies in any form. It will also terminate if you fail to comply with any term or condition in this agreement.

Special thanks to:
- Joe Zobkiw
- Tony Marvuglio
- Scott McCormick
- Andrew Calvo
- Richard Boulanger

The Media Menu Commands

These instructions hold for the limited version of the Media Tools included on the Multimedia Machine CD. A software version of this
The documentation is also included on the CD as a stand-alone application called Media Tools Manual (CD rev).

**Import ➔ EPS File**

This utility allows you to directly import EPS files, including music notation in EPS file format, into an external window in HyperCard. Select File ➔ Import EPS, then locate the desired EPS file to import (note that many current publication-quality, music notation programs—regardless of platform—support this file format; consult your notation program's manual to find out how to compile an EPS file). When your file is located and selected, you will be prompted to name the button that will open the external window.

The file is actually imported into the stack as a PICT resource and called from the newly created button. The most useful application for this is to import the file, then use a screen capture utility such as Flash-It (included) to copy the PICT and paste it as a card graphic. Once done, if you do not plan to reopen the file in an external window, you can delete both the button and the resource (by using ResCopy). Note that once the graphic is imported, it will print as a bit-mapped image from within HyperCard, but will still look fine on screen.

**Import ➔ Picture**

PICT files, resources, or Photo CD files from disk at resolutions up to 24 bits can be used. Select Import ➔ Picture, then specify whether the picture is a PICT file, resource, or a Photo CD file. You can also choose the window style for PICT files and resources. Next, locate and select the desired file. You will be prompted to click where you want the top-left point of the window. A button will be created to either open an external window to display the selected picture (PICT files) or to paint the photo onto the screen (Photo CD files).

If you write a button script that points to an exact file location and you later move the file, you may also have to remake the button, or update the button script by specifying the new path.
A Useful Script

Here is a useful script for replacing a pointer to a direct file location; it assumes, however that the file to be opened is in the same folder as the stack from which it is called. Once substituted, the stack and file can be moved to any location without concern for the script finding the file.

This was the original script pointing to a specific location:

"driveName:folderName:folderName:fileName"
put "CTMI IIfx:HyperCard-f:QT Example:Cadence" into pictureName

Replace the pointer with this script:

put the long name of this stack into thePath
delete word 1 of thePath
set itemdelimiter to colon
delete last item of thePath
put ":Cadence" & quote after thePath --use the fileName
put thePath into pictureName

This script finds the location of the current stack and replaces its name with the name of the file.

Import ➤ Text

This utility allows you to import text from a file of type TEXT into a card field (note that HyperCard restricts text in field to 32K; but that's a lot of text). Select Import ➤ Text and locate the text file to import. Once selected, you will be asked which card field to place the text into (if there are existing card fields) or to name the new field to hold the text. Note that you can create a new field, even if there are already existing fields, by clicking on the NEW button.

CD Tools

The CD Tools allow you to set regions from an audio CD that can be played back at the click of a button. Using a remote control metaphor, the CD Tools enable you to fast forward or rewind, move ahead or back by track, play, stop, and eject the CD. In addition, you can set beginning and end points for regions by clicking at the appropriate times on the startTime and endTime buttons. See Figure C.1. (Note that some CD-ROM players
FIGURE C.1: The CD Region Builder Palette

such as the CD Technology drive do not respond to the fast forward or rewind commands.)

Once you have specified approximate start and end times, you can audition the region by clicking on the play region button. You can also fine-tune the start and end times by typing into the number fields; note that these are given in minutes:seconds:frames format, with 74 fps. When the region is perfected, click on the [make region] BUTTON button, and name the region. A button with complete script to play the selected region is added to the card layer, and you can proceed with creating additional buttons. Remember that you can move these region buttons among stacks
with the Object Mover, but you must have the correct CD for the music to be correct.

**MIDI Tools**

These tools allow you to record simple single-track sequences directly into HyperCard and to play back standard MIDI sequence files. Click on the record button to begin recording, the stop button to end, and the play button to hear your recording (see Figure C.2).

**FIGURE C.2:** The MIDI Recorder palette
You can save and load files you create using the appropriate buttons, as well as create a button to play the recorded example. The Set Buffers buttons (the chips with in and out arrows) allow you to set the size of the memory buffers. The defaults are 8K for input and 2K for output. This will be sufficient for most work within HyperCard. For longer pieces of music you may wish to expand these memory allocations by entering larger numbers into the dialog boxes. Always enter these numbers as full integers; i.e. 8K is entered as 8000.

You can go directly to the MIDIFile Player palette by holding down Option while selecting Media ➤ MIDI Tools....

Click on the MIDI file icon to enter the MIDIFile player (see Figure C.3). This tool allows you to open a standard MIDI file for playback and modification. Click on the "Open" button and select the desired file using the standard Macintosh dialog box. Use the transport controls for play, stop, and continue commands.

The Speaker icon allows you to scale the velocities of the sequence, where 100 equals the velocities stored in the file, 120 would be 20% higher velocities and 80 would be 20% lower levels. The flat and sharp icon allows you to transpose in either direction—a setting of 5 would transpose up a perfect fourth; −7 would transpose down a perfect fifth. The metronome icon allows you to scale the tempo.

When creating MIDI files for this tool, save them with tempos of 100, so when you scale tempos, the percentages entered will also be the absolute beats per minute.

Press the loop icon to create a playback loop, and type into the loop field the desired number of times to play the sequence. You can create a button that will play the sequence file complete with all of the modifications. The MIDI keyboard button will return you to the MIDI recording tool.

You can set which track (not MIDI channel) the drums are assigned to so that they will not be transposed.
You can also set the MIDIFile tool to use MIDI manager with the MIDI settings dialog box, using the MIDI icon button. This is especially handy when using a Digidesign MacProteus or SampleCell card for MIDI playback. Press the MIDI icon to get the MIDI Setup dialog box, shown in Figure C.4.

When you close this window, Media Tools will remember the settings. (They are stored in a file in the system folder called Opcode XCMD settings because MIDI Tools use Opcode's MIDiplay external command set for MIDI file playback. Media Tools uses HyperMIDI 1.1 by Nigel Redmond for the recording tool.) Until you change the setup using either
the MIDI icon button or PatchBay, Media Tools will remember the connections.

When you create a button to play back the MIDI File (with all the settings made with the MIDI Tools), it will point to the exact file location as selected when opening the MIDI file. If you later move the MIDI file, you will have to update the button script to show the path to the file. See the "Import ➔ Picture" section (above) for more information and a suggested script to use in place of this direct pointer.

**Audio Tools**

To maximize the benefit of this tool, you should install a Digidesign AudioMedia, Sound Accelerator, or Pro Tools card in your Mac. If you have one of these cards, the Audio Tools allow you to record high quality sounds for playback from buttons while in HyperCard. This tool uses the Sound Manager from Apple, which is included with the Media Tools package (see Figure C.5).

Use the Sound Control Panel to set the input device. Open this Control Panel (Figure C.6) by selecting Control Panels from the Apple menu, or by
Choose "Record to RAM" to create an 'snd' resource or "Record to Disk" to create an 'AIFF' file. When recording to RAM use the "Set Name:" and "Set Stack:" buttons. Click on "Set Name:" to create a name such as "Media Tools Sound." Click on "Set Stack:" to select a stack such as "Home."
locating the Control Panels folder within the System Folder. Choose Sound In from the popup menu.

Choose the appropriate input device from the Icon List in the Sound Input page of the Sound Control Panel (see Figure C.7). Set the sampling frequency (the higher the setting, the better the sound quality) and the appropriate settings for your input card under the Options portion of the sound input device. Set the output device by selecting Sound Out from the popup menu.

Click on the appropriate output device to set the sound to play out from an audio card. Choose Built-in to use the Macintosh's internal speaker. Close the control panel and return to HyperCard.

There are two radio buttons that allow you to select whether you will record to RAM, creating an SND format resource, or record to disk, creating an AIFF file. To record a resource, select the Record to: RAM radio button,
then name the sound and choose the destination stack for the resource by using the Set Name: and Set Stack: buttons. Click on the tape recorder icon to bring up the standard record dialog box (see Figure C.8).

![Record dialog box](image)

**FIGURE C.8:** The record dialog box

Set the level from the sound source using the speaker icon as a meter. When the level is acceptable, click Record to begin recording. Click on Stop to complete the recording and Play to play back the sound. Click the Save button to install the sound as a resource in the chosen stack, and create a button to play the sound.

To use AIFF files, select the Record to: Disk radio button. You will be given two options: to create a play button for an existing sound file (Speaker ICON), or to record a new disk file (see Figure C.9).

To create a button to play an existing sound file, click on the speaker icon. Locate the file you wish to use, then click on the Open button. A button will be created with a script to play the sound file.

To create a new sound file, click on the tape recorder icon button. You will be prompted to name the sound file and choose the location on the disk. When you get the standard record dialog box, set the level at the sound
source using the speaker icon as a meter. When the level is acceptable, click Record to begin recording. Click on Stop to complete the recording and Play to play back the sound. Click on the Save button to create a button to play your sound. If desired, use Digidesign's Sound Designer II software to further edit the sound.

**Movie Tools**

Movie Tools (Figure C.10) allows you to record and display QuickTime Movies in HyperCard. You must have the QuickTime extension (provided in the package) installed. If you want to record movies you will also need to have a video capture card such as SuperMac's VideoSpigot and related VDIG extension. With QuickTime Movie Region Builder palette you can view and record live video provided you have an appropriate QuickTime compatible video capture card with an installed VDIG extension. Even without a capture card, you can still play QuickTime movies and create regions to be called from buttons, just as with the CD and Video Tools.

Use the palette to play and pause the movie, and to set start and end points for the movie region. You can play the region, set loop to on or off and specify forward or palindrome style looping. When satisfied with the
region, press the Make Button button and the tool will install a button with the script already written to open the movie window and play the selected region. Note that these buttons point to the exact file location of the movie you selected. If you later move the movie to a new location, you will have to update the button script to show the path to the file. See “Import ➤ Picture” (above) for a suggested script.

**Preferences**

Use the preferences dialog box to specify whether or not the tools will load automatically upon startup (see Figure C.11). When you select this option, the Tools will be installed each time you launch HyperCard.
The Utilities Menu Commands (Available with Upgrade Only)

The following sections summarize the commands found in the complete version of Media Tools, which adds a Utilities menu to HyperCard.
Information on obtaining the upgrade can be found in the Media Tools Manual on the Multimedia Machine CD.

**ResCopy**

ResCopy is a utility that allows you to copy resources between stacks, remove resources from stacks, and renumber or rename resources. Use this utility to install resources contained in the toolkit stacks into your own stacks so that you can use them when the toolkit stacks are not present. ResCopy can be called from the Utilities menu or by typing `⌘-0` (zero) when the toolkit menus are displayed. There is built-in help on the ResCopy dialog box! Thanks to Apple Computer!!

**Stack Tools**

The Stack tools include the following:

**Split Stack**  Allows you to split an existing stack into two different stacks. The tool prompts you to define the range of cards to split into stacks 1 and 2, and allows you to select existing stacks or create new stacks to receive the split.

**Merge Stacks**  Allows you to combine two stacks into one. You can merge the stacks into an existing stack, or create a new stack to receive the merge.

**Export Stack Scripts**  Creates a text file containing all the scripts in a chosen stack. By opening this file with a word processor, you can examine all the scripts at once.

**Make Stacks Menu**  An enhanced version of a tool found in Apple's Power Tools stack, it adds a menu that creates a list of the currently open stacks. Select a stack from the menu to bring its window to the front and make it active. To remove the Stacks menu, choose Dismiss This Menu.

**Make Stacks in Use Menu**  Another enhanced version of a tool found in Apple's Power Tools stack, it adds a menu that lists the stacks that are in use (installed in the message-passing order between the current stack and the Home stack). To go to a stack, choose it from the menu. To remove the StacksInUse menu, choose Dismiss This Menu.
Card Tools

These were all inspired by Apple’s Power Tools, Ready-Made Buttons and Fields stacks, and are enhancements of those great ideas.

Make First, Make Last, and Make ???  Allow you to automatically set the current card to be either the first card in a stack, the last card in a stack, or to set the desired number for the current card.

Mini CD Pict  Creates a miniature picture of the current card—useful for creating icons or graphics for navigation.

Show CD Pict and Hide CD Pict  Show or hide the card picture graphic layers. Show and Hide BG Pict do the same actions for the background picture graphic layer.

Print Area  Allows you to define a region of the card to print. You are prompted to drag a selection rectangle across the desired area, which is then sent to the printer.

Object Lister

Often in building a stack, you will need to refer to objects you have created. This is complicated by HyperCard’s ability to hide objects. This utility will allow you to review the objects on the current card, hide or show multiple objects, edit the script of an object, or print out the list. Choose Utilities ➤ Object Lister (⌘-L). You will be presented with a list window showing all objects on the current card. Any hidden objects will be listed in brackets—[object name]. You can select multiple objects by Shift-clicking contiguous selections, or ⌘-clicking for discontiguous selections. Once the list is presented you have four options:

Print  Sends the list to the printer for a hard copy record as you work.

Visible  After you’ve selected an object within the list, this button changes the visible property of the selected object. Visible objects will be hidden; hidden objects will be shown. This is a quick way to find a missing object!
Media Tools Instructions

Script  After you’ve selected an object in the list, this button opens the script window for that object. This is a quick way to edit the script of hidden objects without having to first make them visible.

Delete  Deletes the selected object(s).

Mouse Locator

Selecting Utilities ➤ Mouse Locator item will allow you to view the mouse coordinates displayed in the message box. Clicking the mouse will freeze the current mouse location in the message box so that you can copy it into your scripts as needed. This utility is helpful for placing objects under script control, etc.

Rect Getter

Often in scripting, you will want to set the rectangle property of an item to a specific set of coordinates. This utility simplifies the process. Choose Utilities ➤ Rect Getter and you are prompted to click on a desired object, after which its rectangle coordinates will be displayed in the message box for your use in copying into a script.

Alignment Tools

This set of utilities simplifies the operations of moving and aligning groups of objects. The first step in any of these operations is to define the object or grouping of objects you wish to work with. Do this by clicking the group object button on the alignment tools palette. You are prompted to identify the object(s) by clicking on them, then finishing the selection by pressing ⌘ to complete the group. You can then perform the following operations:

Group  Creates a group to perform various operations on. When the icon hilights, the cursor becomes a cross. Click on objects you wish to include in the group. As you click each object, the cursor will become a watch momentarily as the object is identified. If you have clicked on a valid object you will hear two tones (a major 3rd interval), if you clicked outside of an object, you will hear the error beep. When you have completed selecting the objects in your group, press ⌘. The group will be entered. Note that if there are no objects
in the group, you will get an error sound and an alert dialog box. Note that the group will be kept in memory until you enter a new one or quit HyperCard. Therefore, you can perform a number of operations on the same group without having to regroup each time!

**Move** Once you have created a group, enables you to drag the group of objects around the screen as a unit. Use normal Macintosh click and drag technique—simply click on an object in the group and while holding down the mouse button, drag the group to the desired location. When you release the mouse button, the action is complete.

**Resize** Sets a number of objects to the same size as another object. Once you have created the group to resize, click on the resize icon. The cursor will become a cross, awaiting your selection of the reference object. Click on the object whose size will be duplicated for each member of the group. The objects will then be resized.

**Copy** Creates a copy of each member of the group. Once the group is created, click on this icon. If the group is not empty, you will be asked whether or not you wish to duplicate the group. If you OK the duplication, the cursor will become a cross once for each member of the group. While the cursor is a cross, click at the location for the duplicate object. Each object will be placed according to the original positions relative to your mouse-click.

The **Delete** operation is not undoable—use with caution!!

**Delete** Quickly deletes a number of objects. Once you have grouped the objects to be deleted, click on this icon. You will be asked to confirm the deletion. If confirmed, all objects in the current group will be deleted.

**Align** There are five alignment options, indicated by icons 6, 7, 8, 9, and 12. They are (in order) Centered, Left Aligned, Right Aligned, Top Aligned, and Bottom Aligned. After creating the group, click the appropriate icon for the desired alignment. The cursor will turn into the cross hairs, prompting you to click at the location for the
alignment to occur. As soon as you click the mouse, the objects will align at the click location.

**Spacing** The remaining two icons (10 and 11) represent the spacing options—vertical and horizontal. Create a group of objects, then select the spacing icon as appropriate for your situation. You will be asked to enter a number that will represent the amount of space (measured in pixels) between the objects. It may take some practice to get to know just how many pixels to enter, but you can keep adjusting the space without having to regroup the objects.

**Numbering Tools**

This utility will allow you to change the number of a selected object. This is most useful for fields, where the field number determines the tab order. Choose the menu option, then click on the desired object. A dialog box will show presenting the current object number, and allowing you to type in the desired number. Click on OK and the tool will automatically renumber the chosen object to the specified number. As objects change numbers they shift other objects’ numbers as per HyperCard’s revolving scheme (if an object replaces a previous number, it in turn renumbers one higher, etc...).

**Object Mover**

Object Mover is a tool to help simplify the repetitive tasks associated with building or modifying a stack. This tool allows you to move any number of objects from a source card to a destination card, either in the card or background layers. Select Utilities ➤ Object Mover and choose the source and destination stacks (they might be the same) and cards (they might also be the same). Select the objects to be moved by using the check boxes, or check Selected... to be able to select the desired objects by clicking on them. Don’t forget to set the target layer (card or background) with the layer radio buttons, and specify whether or not you wish to watch the process or go out for coffee....
Index

Note to the Reader  Boldfaced numbers indicate pages where you will find the principal discussion of a topic or the definition of a term.  *Italic* numbers indicate pages where a topic is illustrated in a figure.

A

¡Acincha! music, 319
adapter cards.  See cards
adapters, digital audio, 34
Add/Delete Tracks dialog box, Adobe Premier, 252–254, 253
Adobe Premier software, 84–110, 179–186.
See also digital video; Movie Tools; MoviePlayer; QuickTime
adding music to video, 248–259
Add/Delete Tracks dialog box, 252–254, 253
adding sound effects, 255–256, 255, 258
fading between selections, 256–259
importing video, music, and sound effects, 249, 250
mixing tracks, 254, 255
placing movie into video A track and watching, 251–252, 251
Audio Filters dialog box, 108–109, 109
Brightness & Contrast Settings dialog box, 109, 110
Clip window, 91–92, 91, 179–180, 180
Construction window, 85, 86, 96–107
adding transitions, 101–103
audio volume envelopes, 103–107, 180–182, 181
Backwards [Audio] filter, 180–182, 181
combining video segments, 100
overview of, 85, 86
removing unwanted segments, 93–99
converting QuickTime movie format to AIFF files, 182–186
AIFF conversion dialog box, 183–184, 184
Audio Format pull-down menu, 184, 186
Audio Rate pull-down menu, 183, 185
File/Export/AIFF Audio File command, 182, 183
Saving File progress window, 184, 187
Cross Dissolve Settings dialog box, 102, 104
editing CD audio in QuickTime movie format, 179–182
editing movies, 84–110
adding transitions, 101–103
audio volume envelopes, 103–107, 180–182, 181
butt-end splices, 100
combining video segments, 100
importing files, 88–91, 89
overview of, 84–87
removing unwanted segments, 93–99
setting in and out points, 88–92
using filters, 107–110
marker popup menu, 93–96, 94
MIDI Manager and, 196, 197
overview of, 24–25, 84–86, 302, 329
Project window, 84, 85, 89, 90, 249, 250
Transitions window, 86, 87
Video Filters dialog box, 109
AIFF conversion dialog box, Adobe Premier, 183–184, 184
AIFF files
  converting QuickTime movie format to, 182–186
defined, 51
playing from HyperCard, 186–190
saving recorded sounds as, 129–130
alert sounds
  adding and setting system beep, 113–115
  converting sounds to system beeps, 158–160
  on Multimedia Machine CD, 313
System 7 alert sounds
  creating, 157–160
defined, 50
algorithms, video compression, 80–83
alias files, 137
Alignment tools, Media Tools, 348–350
amplifiers, digital audio, 140
amplitude, sample resolution and, 47
analog recording, 42–43, 43
analog video, 246
analog-to-digital converters
  amplitude and, 47
defined, 44, 45
  quantizing and, 47
animation, 247
Apple Animation compression algorithm, 81
Apple CD-ROM extension, 54, 317
Apple Compact Video compression algorithm, 82–83
Apple Graphic compression algorithm, 82
Apple Photo compression algorithm, 81
Apple Video compression algorithm, 81, 82
Apple design speakers, 324
architecture, of MIDI synthesizers, 55–56, 56
Arrangement window, MusicShop, 220–222, 221
ASCII files
  defined, 234
importing into HyperCard, 237–238, 237, 238, 239
audio cards
  adding, 33, 34
  fidelity and, 48
MIDI audio cards, 326
  recommended, 324–325
Audio Conversion dialog box, MoviePlayer, 174, 175
audio editors, 328–329
Audio Filters dialog box, Adobe Premier, 108–109, 109
Audio Format pull-down menu, Adobe Premier, 184, 186
Audio Gallery MIDI module, 326
Audio Import Options dialog box, MoviePlayer, 174–178, 176, 177
Audio Interchange File Format.
  See AIFF files
Audio Quality screen, 49, 49
Audio Rate pull-down menu, Adobe Premier, 183, 185
Audio Tools, 122–130, 123, 339–343, 340. See also digital audio;
  Media Tools
  creating buttons to play sounds, 122–125, 260, 342
  overview of, 339–343
  playing
digital audio files, 122–125, 260, 342
  QuickTime movie format and AIFF files, 186–187
  record dialog box, 126–127, 127, 342, 342
  sound recording, 125–130, 341–342, 342
to RAM, 125–128
  recording disk files, 129–130
  audio volume envelopes, 103–107, 180–182, 181
Audiomedia II audio card, 324–325, 339
AudioShop editor, 329
authoring software, 297–299. See also
  HyperCard
  AuthorWare Professional software, 330
  MacroMedia Director, 297, 298, 330
  Passport Producer Pro, 298, 299
recommended, 329-330
Avid VideoShop editor, 329

B
beeps. See alert sounds
boards. See cards
Brightness & Contrast Settings dialog box, Adobe Premier, 109, 110
broadcast quality video, 79
butt-end splice, 100
Button Info dialog box, HyperCard, 274-280, 276
Family popup menu, 275-277
Link To button, 285-289, 286
Script button, 279
buttons
creating
for CD audio playback, 165-167, 187-188, 189
for digital audio playback, 122-125, 260, 342
to display backdrop pictures, 259-260
in HyperCard, 274-275, 287, 289-297
for video playback, 74-76, 75, 76, 77, 260-262
HyperCard, 273-280
assigning attributes, 275-277
choosing icons for, 277, 277, 287, 288
creating, 274-275, 287
highlighting, 278
navigating cards with, 289-297
overview of, 273
scripting, 278-280, 279, 281

C
cables, digital audio, 34
capturing digital video, 79-80, 84
Card Info dialog box, HyperCard, 293, 294
Card tools, Media Tools, 347
cards (extension)
audio cards
adding, 33, 34
fidelity and, 48
MIDI audio cards, 326
recommended, 324-325
MIDI synthesizer cards, 58, 60
cards (HyperCard)
backgrounds and, 280-284
defined, 269
linking, 285-289
navigating with buttons, 289-297
CD audio, 36-38, 51-54, 161-190. See also CD-ROM drives
Apple CD-ROM extension, 54, 317
clock time and, 51
connecting, 36-37, 37
controlling from HyperCard, 51-54, 162-173
exploration, 51-54, 52
overview of CD Tools, 162-167
synchronizing slides to CD audio, 168-173
creating buttons for CD audio playback, 165-167, 187-188, 189
explorations
comparing digital, CD, and MIDI audio, 40, 41
controlling an audio CD, 51-54, 52
converting CD audio to QuickTime movie format, 173-179
converting QuickTime movie format to AIFF files, 182-186
editing CD audio in Adobe Premier, 179-182
playing CD audio, 38
playing QuickTime movie format and AIFF files from HyperCard, 186-190
synchronizing slides to CD audio, 168-173
working with CD Tools, 162-167
Foreign File Access extension, 53-54, 317
on Multimedia Machine CD, 318-321
¡Acínchal!, 319
A Darker Shade of Gray, 318-319
Fall Equinox, 320-321
Looking Back, 320
overview of, 51, 161-162
CD audio—converting

playing, 38, 165–167, 187–188, 189
CD data track (track 1), 38, 53
creating buttons for, 165–167, 187–188, 189
QuickTime movie format, 173–190
converting CD audio to, 174–179
converting to AIFF files, 182–186
editing in Adobe Premier, 179–182
playing as AIFF files from HyperCard, 186–190
storage capacity, 51
CD Region Builder palette, 163–167, 163, 334–335, 335
creating buttons for CD audio playback, 165–167, 187–188, 189
overview of, 162–167, 334–336
Play Region button, 166, 166
Search dialog box, 165, 165
synchronizing slides to CD audio, 168–173
CD-ROM drives. See also CD audio
audio tracks versus data tracks, 38, 53
controlling from HyperCard, 51–54, 162–173
exploration, 51–54, 52
overview of CD Tools, 162–167
synchronizing slides to CD audio, 168–173
mixed mode disks, 38
video playback and, 83
chaining sequences, 220–221
changing
tempo in MusicShop, 214–215, 215
track volume, stereo placement, and instrumental sound in MusicShop, 215–218, 216, 217, 218
Choose Icon dialog box, HyperCard, 277, 277
Clip window, Adobe Premier, 91–92, 91
clock time, CD audio, 51
codecs. See compression schemes (video)
color depth, in digital video, 79, 83–84
command key shortcuts, book's convention for, 6
commands, book's convention for, 5
common time, 200–201
compression schemes (video), 80–84
Apple Animation compression algorithm, 81
Apple Compact Video compression algorithm, 82–83
Apple Graphic compression algorithm, 82
Apple Photo compression algorithm, 81
Apple Video compression algorithm, 81, 82
JPEG compression algorithm, 81, 83
spatial compression, 80
SuperMac DigitalFilm system, 81, 83, 84, 327
temporal compression, 80–81
connecting
CD audio, 36–37, 37
digital audio equipment, 34, 35, 36
MIDI synthesizers, 38–39, 39
connectors, digital audio, 34
Construction window, Adobe Premier, 85, 86, 96–107
adding transitions, 101–103
audio volume envelopes, 103–107, 180–182, 181
combining video segments, 100
overview of, 85, 86
removing unwanted segments, 93–99
contextual reference, of music, 233
control panels, installing, 2, 4, 6
controlling
CD audio from HyperCard, 51–54, 162–173
exploration, 51–54, 52
overview of CD Tools, 162–167
synchronizing slides to CD audio, 168–173
VCRs and laserdisc players from HyperCard, 246
converting
CD audio to QuickTime movie format, 173–179
QuickTime movie format to AIFF files, 182–186
sounds to system beeps, 158–160
creating

buttons
for CD audio playback, 165–167, 187–188, 189
for digital audio playback, 122–125, 260, 342
to display backdrop pictures, 259–260
in HyperCard, 274–275, 287, 289–297
for video playback, 74–76, 75, 76, 77, 260–262
graphics with HyperCard painting tools, 240–241, 242
HyperCard stacks, 284
slide shows, 263–266
System 7 alert sounds, 157–160
Cross Dissolve Settings dialog box, Adobe Premier, 102, 104

D
A Darker Shade of Gray music, 318–319
density, of music, 231–232
desk accessories, installing, 4
Desktop Music Production software, 303
device drivers, installing, 4
Digidesign. See also TurboSynth
Audiomedia II audio card, 324–325, 339
Pro Tools audio card, 325, 339
SampleCell II MIDI audio card, 326
Sound Designer file format, 51
Sound Designer II audio editor, 328
See also Audio Tools; multimedia; music; sound; TurboSynth
alert sounds
adding and setting system beep, 113–115
converting sounds to system beeps, 158–160
on Multimedia Machine CD, 313
software for, 31, 31
System 7 alert sounds, 50, 157–160
amplifiers, 140
analog-to-digital converters
amplitude and, 47
defined, 44, 45
quantizing and, 47
audio cards
adding, 33, 34
fidelity and, 48
MIDI audio cards, 326
recommended, 324–325
creating buttons for digital audio playback, 122–125, 260, 342
digital-to-analog converters, defined, 44, 45
direct-to-disk recording, 33
editing, 130–136. See also TurboSynth envelopes
audio volume envelopes, 103–107, 180–182, 181
defined, 140
in TurboSynth, 143–144, 154–156, 155
equipment for, 33–34, 35, 36
explorations
adding alert sounds and setting system beep, 113–115
comparing digital, CD, and MIDI audio, 40, 41
converting sounds to system beeps, 158–160
creating patches, 152–157
editing digital audio, 131–136
playing digital audio from HyperCard, 32–33
playing disk files with Audio Tools, 122–125, 260, 342
recording disk files with Audio Tools, 129–130
recording to RAM with Audio Tools, 125–128
sampling rates and resolutions, 49–50, 49
setting sound input devices, 116–119
setting sound output devices, 120–122
sound design concepts, 138–140
understanding modules and patches, 140–152
file formats, 50–51
filters
defined, 140
low pass filters, 144
in TurboSynth, 143–146, 144, 146, 149–151, 153–154
mixers
in Adobe Premier, 254, 255
in MusicShop, 215–218, 216
in TurboSynth, 149–152, 151
on Multimedia Machine CD, 310–311
non-destructive editing, 136
oscillators
defined, 140
in TurboSynth, 141–143, 141, 142, 143, 148–149, 153
patches
creating, 152–157
defined, 131
exploration, 140–152
playing
creating buttons for, 122–125, 260, 342
disk files with Audio Tools, 122–125
from HyperCard, 32–33
recording, 125–130, 341–342
to RAM, 125–128
recording disk files, 129–130
sampling
defined, 44
sample resolution and fidelity, 47–48, 48
sampling rate and fidelity, 44–47, 46
sampling rate and resolution exploration, 49–50, 49
signal processors, 140
signal-to-noise ratio (S/N), 47
sound input devices
defined, 33
microphones, 42, 117–119
setting, 116–119
Sound Manager, 111–122, 112, 113, 318
adding alert sounds and setting system beep, 113–115
Alert Sounds page of control panel, 114, 115
overview of, 111–112
record dialog box, 117–118, 119
setting sound input devices, 116–119
setting sound output devices, 120–122
Sound control panel overview, 113, 113
Sound In page of control panel, 116, 118
Sound Out page of control panel, 120–121, 120
Sound popup menu, 116, 117
Volumes page of control panel, 121–122, 121
speakers
adding, 33, 34
recommended, 323–324
setting volume, 120–122
synthesizing sound, 136–157. See also TurboSynth
creating patches, 152–157
overview of, 136–137
sound design concepts, 138–140
understanding modules and patches, 140–152
time delays
defined, 140
in TurboSynth, 147–148, 147, 151, 156–157, 156
waveforms, 140. See also synthesizing sound
digital video, 66–110, 248–259. See also Adobe Premier; Movie Tools; MoviePlayer; multimedia; QuickTime
adding music to, 248–259
adding sound effects, 255–256, 255, 258
fading between selections, 256–259
importing video, music, and sound effects into Adobe Premier, 249, 250
mixing tracks, 254, 255
placing movie into video A track and watching, 251–252, 251
broadcast quality, 79
capturing, 79–80, 84
color depth, 79, 83–84
compression schemes (codecs), 80–84
Apple Animation compression algorithm, 81
Apple Compact Video compression algorithm, 82–83
Apple Graphic compression algorithm, 82
Apple Photo compression algorithm, 81
Apple Video compression algorithm, 81, 82
JPEG compression algorithm, 81, 83
spatial compression, 80
SuperMac DigitalFilm system, 81, 83, 84
temporal compression, 80–81
dithering, 83
editing, 84–110, 179–182. See also Adobe Premier; Movie Tools
adding transitions, 101–103
audio volume envelopes, 103–107, 180–182, 181
butt-end splices, 100
combining video segments, 100
importing video files, 88–91, 89
overview of, 84–87
QuickTime movie format in Adobe Premier, 179–182
removing unwanted segments, 93–99
setting in and out points, 88–92
using filters, 107–110
explorations
adding music to video with Adobe Premier, 249–259
editing QuickTime movies, 86–110
impact of music on video, 229–231
role of music in multimedia, 27–30, 28, 30
using Movie Tools, 72–77
using MoviePlayer, 66–71
file size, 78–80
importing into Adobe Premier, 88–91, 89, 249, 250
pixels, 79
playback speed, 83–84
playing with Movie Tools, 72–76, 72
creating buttons for video playback, 74–76, 75, 76, 77, 260–262
selecting movie segments, 73, 74
viewing movie segments, 73
playing with MoviePlayer, 66–71, 67
creating new movie window, 68, 69
editing frames, 68–69, 70
looping movies, 71
opening files, 66
retrieving movies, 70
saving movies, 69–70
selecting frames and segments, 67–68, 68, 71
sizing movies, 71
toggling between playback and pause modes, 67
video digitizers, 84, 327
DigitalFilm system, 81, 83, 84, 327
digital-to-analog converters, 44, 45
direct MIDI connections, 194–195
Director authoring software, 297, 298, 330
direct-to-disk recording, 33
disk storage. See hard disks
dithering, digital video, 83

E
Edit window, MusicShop, 211, 212–215, 212, 213
editing. See also Adobe Premier; Media Tools; Movie Tools; MusicShop
digital audio, 130–136
digital video, 88–110, 179–182
adding transitions, 101–103
audio volume envelopes, 103–107, 180–182, 181
butt-end splices, 100
combining video segments, 100
importing video files, 88–91, 89
overview of, 84–87
QuickTime movie format in Adobe Premier, 179–182
removing unwanted segments, 93–99
setting in and out points, 88–92
using filters, 107–110
MIDI files
with MIDIFile Player, 204–211, 205
with MusicShop, 211–226
editors. See also Adobe Premier; Media Tools; TurboSynth
audio editors, 328–329
video editors, 329
emotion, music and, 233
envelopes
audio volume envelopes, 103–107, 180–182, 181
defined, 140
in TurboSynth, 143–144, 154–156, 155
EPS (Encapsulated PostScript) file format, 239–240
equipment, for digital audio, 33–34, 35, 36
event editors, MIDIFile Player, 206–211, 206
exercises. See explorations
expansion cards. See cards
explorations, 20–22, 304–309
CD audio
comparing digital, CD, and MIDI audio, 40, 41
controlling CD audio, 51–54, 52
converting CD audio to QuickTime movie format, 173–179
converting QuickTime movie format to AIFF files, 182–186
editing CD audio in Adobe Premier, 179–182
playing CD audio, 38
playing QuickTime movie format and AIFF files from HyperCard, 186–190
synchronizing slides to CD audio, 168–173
working with CD Tools, 162–167
contents, 304–309
Chapter 2, 304
Chapter 3, 305
Chapter 4, 306
Chapter 5, 307
Chapter 6, 307–308
Chapter 7, 308–309
Chapter 8, 309
digital audio
adding alert sounds and setting system beep, 113–115
comparing digital, CD, and MIDI audio, 40, 41
converting sounds to system beeps, 158–160
creating patches, 152–157
editing digital audio, 131–136
playing digital audio from HyperCard, 32–33
playing disk files with Audio Tools, 122–125
recording disk files with Audio Tools, 129–130
recording to RAM with Audio Tools, 125–128
sampling rates and resolutions, 49–50, 49
setting sound input devices, 116–119
setting sound output devices, 120–122
sound design concepts, 138–140
understanding modules and patches, 140–152
digital video
adding music to video with Adobe Premier, 249–259
editing QuickTime movies, 86–110
impact of music on video, 229–231
role of music in multimedia, 27–30, 28, 30
using Movie Tools, 72–77
using MoviePlayer, 66–71
HyperCard (interactive multimedia)
buttons, 274–280
controlling CD audio, 51–54, 52
creating links, 285–289
fields, 269–273
installing, 21–22
navigating cards with buttons, 289–297
playing CD audio, 38
playing digital audio, 32–33
running, 3, 9, 24
installing, 20–22
in HyperCard, 21–22
with MediaTools Runner, 21
MIDI synthesizers
changing sounds, 58–61, 61, 62
comparing digital, CD, and MIDI audio, 40, 41
Macintosh, MIDI, and Music: The Open Door video, 191–193, 192
MIDI information in MIDI 'n'
Synths stack, 226–227
playing and editing MIDI files with MIDIFile Player, 204–211, 205
playing and editing MIDI files with MusicShop, 211–226
playing MIDI sequences, 40
recording MIDI sequences with MIDI Recorder, 202–204, 203
synchronizing slides with MIDI soundtrack, 198–202, 199
multimedia. See also HyperCard; interactive multimedia
adding music to video with Adobe Premier, 249–259
combining media with Media Tools, 259–253
creating a slide show, 263–266
impact of music on video, 229–231
using graphics with Media Tools, 240–246
using text with Media Tools, 235–238
overview of, 2–3, 3
QuickTime
converting CD audio to QuickTime movie format, 173–179
converting QuickTime movie format to AIFF files, 182–186
editing CD audio in Adobe Premier, 179–182
editing QuickTime movies, 86–110
importing PICT files into HyperCard as QuickTime photos, 245–246, 245
playing QuickTime movie format and AIFF files from HyperCard, 186–190
role of music in multimedia, 27–30, 28, 30
running
with HyperCard, 3, 9, 24
with MediaTools Runner, 22–23, 23, 24, 25
extensions. See also QuickTime
Apple CD-ROM extension, 54, 317
Foreign File Access extension, 53–54, 317
installing system extensions, 2, 4–6, 5, 7

f
fading, with Adobe Premier, 256–259
Fall Equinox music, 320–321
female digital audio connectors, 34
fidelity
analog recording and, 43
audio cards and, 48
defined, 43
MIDI file size and, 61–63
sample resolution and, 47–48, 48
sampling rate and, 44–47, 46
Field Info dialog box, HyperCard, 269–272, 270
Style menu, 270–272
Text Style options, 272–273, 273
fields (HyperCard), 235–238, 269–273
defined, 269
entering text in, 235–236, 235, 236
exploration, 269–273
importing ASCII text files into, 237–238, 237, 238, 239
file formats
AIFF files
converting QuickTime movie format to, 182–186
defined, 51
playing from HyperCard, 186–190
saving recorded sounds as, 129–130
for digital audio, 50–51
EPS (Encapsulated PostScript), 239–240
for graphics, 239–240
PICT, 239
SND, 50
Sound Designer, 51
SoundEdit, 51
Standard MIDI File (SMF) format
defined, 61
fidelity and file size, 61–63
importing into MusicShop, 219–220
on Multimedia Machine CD, 311–312
playing and editing with MIDIFile Player, 204–211, 205
playing and editing with MusicShop, 211–226
System 7 alert sound format, 50
TIFF, 239
files
  alias files, 137
digital video files, 78–80
Multimedia Machine CD system files
  listed, 8
filters
  audio and video, 107–110
defined, 140
  low pass filters, 144
  in TurboSynth, 143–146, 144, 146,
  149–151, 153–154
fonts, 234
frequency range, 44

G
General MIDI specification (GM), 55, 56
global MIDI event editors, MIDIFile Player,
  206–211, 206
graphics, 238–246, 316–317. See also
  multimedia
  creating with HyperCard painting
tools, 240–241, 242
file formats, 239–240
importing PICT files into HyperCard,
  242–245, 243, 244
importing PICT files as QuickTime
  photos, 245–246, 245
on Multimedia Machine CD, 316–317

H
hard disks
  versus RAM, 32, 50–51
  storing MIDI information, 38–39
  storing sound files, 50–51
  video playback from, 83
hardware
  MIDI, 57–58, 57, 59
  Multimedia Machine CD requirements,
  1–2
  recommended, 323–327
  audio cards, 324–325
  MIDI audio cards, 326
  MIDI keyboards, 325
  MIDI sound modules, 326
  MIDI synthesizers, 325–326
  powered speakers, 323–324
  video digitizers, 327
hertz (Hz), 45
highlighting HyperCard buttons, 278
hot-key combinations, 6
HyperCard, 269–297. See also
  authoring software; interactive multimedia;
  multimedia
  authoring and scripting, 285–297
  linking cards, 285–289
  navigating cards with buttons,
  289–297
  Button Info dialog box, 274–280, 276
  Family popup menu, 275–277
  Link To button, 285–289, 286
  Script button, 279
buttons, 273–280, 289–297
  assigning attributes, 275–277
  choosing icons for, 277, 277, 287, 288
  creating, 274–275, 287, 289–297
  highlighting, 278
  navigating cards with, 289–297
  overview of, 273
  scripting, 278–280, 279, 281
Card Info dialog box, 293, 294
cards
  backgrounds and, 280–284
  defined, 269
  linking, 285–289
  navigating with buttons, 289–297
Choose Icon dialog box, 277, 277, 287, 288
controlling CD audio from, 51–54,
  162–173
  exploration, 51–54, 52
  overview of CD Tools, 162–167
  synchronizing slides to CD audio,
  168–173
controlling VCRs and laserdisc players
  from, 246
creating graphics with painting tools,
  240–241, 242
explorations
  buttons, 274–280
  controlling CD audio, 51–54, 52
  creating links, 285–289
  fields, 269–273
installing, 21–22
navigating cards with buttons, 289–297
playing CD audio, 38
playing digital audio, 32–33
running, 3, 9, 24
exploring Multimedia Machine CD with, 24
Field Info dialog box, 269–272, 270
Style menu, 270–272
Text Style options, 272–273, 273
fields, 235–238, 269–273
defined, 269
entering text in, 235–236, 235, 236
exploration, 269–273
importing ASCII text files into,
237–238, 237, 238, 239
HyperTalk language, 279–280
installing Media Tools, 11–20
enabling HyperCard 2.1, 17, 18
into HyperCard, 14–17, 15, 16
preparing HyperCard, 11–13, 13, 14
setting HyperCard user level,
18–20, 19
Link To dialog box, 285–287, 286
MIDI 'n' Synths stack, 136–140, 138,
226–227
MIDI information in, 226–227
overview of, 136–137
sound design concepts exploration,
138–140
New Stack dialog box, 284, 284
overview of, 329–330
Playing a Disk File screen, 122, 123
playing QuickTime movie format and
ALFF files, 186–190
saving recorded sounds as snd
resources, 125–128
script editor, 279–280, 279, 281
 scripting, 278–280, 279, 281, 285–297
stacks
creating, 284
defined, 269
text
entering in HyperCard fields,
235–236, 235, 236
importing ASCII text files into
fields, 237–238, 237, 238, 239
Text Properties dialog box, 272–273,
274, 275
Tools palette, 240–241, 242
using Media Tools in, 20
HyperTalk language, 279–280
HyperText and HyperMedia, 139
Hz (hertz), 45
icons
for HyperCard buttons, 277, 277, 287,
288
sound input jack and icon, 125, 126
Import menu, Media Tools
EPS File command, 333
Picture command, 333
Text command, 334
Import Picture dialog box, Media Tools,
242–246, 243, 333
QuickTime option, 245–246, 245
importing
ASCII files into HyperCard, 237–238,
237, 238, 239
MIDI files into MusicShop, 219–220
music into Adobe Premier, 249, 250
PICT files
into HyperCard, 242–245, 243, 244
into HyperCard as QuickTime pho­
tos, 245–246, 245
sound effects into Adobe Premier, 249,
250
video files into Adobe Premier, 88–91,
89, 249, 250
Importing Movie progress dialog box,
MoviePlayer, 178, 178
input devices, digital audio, 33
installing, 3–20
control panels, 2, 4, 6
desk accessories, 4
device drivers, 4
explorations, 20–22
in HyperCard, 21–22
with MediaTools Runner, 21
extensions, 2, 4-6, 5, 7
Media Tools, 9–20
enabling HyperCard 2.1, 17, 18
into HyperCard, 14–17, 15, 16
installing—Media Tools

with MediaTools Runner, 9-10, 10, 11
preparing HyperCard for, 11–13, 13, 14
setting HyperCard user level, 18–20, 19
overview of, 3–4
system files, 4–9, 5, 7
instrumentation, of music, 232
interactive multimedia, 139, 267–299. See also HyperCard; multimedia
defined, 139, 267
interactive MIDI exploration, 268

J
jacks
digital audio, 34, 35
sound input jack and icon, 125, 126
JPEG (Joint Photographic Experts Group) compression algorithm, 81

K
keyboard shortcut, 6
keyboards, MIDI, 325
kilohertz (kHz), 45
Korg
  05r/w MIDI module, 326
  Audio Gallery MIDI module, 326
  PM-5 speakers, 324
  X3 synthesizer, 325

L
laserdisc players, 246
license agreement, Media Tools, 331–332
linking, HyperCard cards, 285–289
Looking Back music, 320

M
Macintosh, MIDI, and Music: The Open Door video, 191–193, 192
MacroMedia
  Director authoring software, 297, 298, 330
  SoundEdit file format, 51
  SoundEdit Pro audio editor, 328
male digital audio connectors, 34
Mark of the Unicorn Performer MIDI sequencer, 328
marker popup menu, Adobe Premier, 93–96, 94
media. See multimedia
Media Tools, 9–20, 72–76, 122–130,
  162–173, 187–190, 202–211,
  301–302, 331–350
Audio Tools, 122–130, 123, 339–343, 340
creating buttons to play sounds, 122–125, 260, 342
overview of, 339–343
playing digital audio files, 122–125, 260, 342
playing QuickTime movie format and AIFF files from HyperCard, 186–187, 189
record dialog box, 126–127, 127, 342, 342
recording disk files, 129–130, 341–342, 342
recording to RAM, 125–128, 341–342, 342
  CD Region Builder palette, 163–167, 163, 334–335, 335
creating buttons for CD audio playback, 165–167, 187–188, 189
overview of, 162–167, 334–336
Play Region button, 166, 166
Search dialog box, 165, 165
synchronizing slides to CD audio, 168–173
combining media, 259–263
creating buttons to display backdrop pictures, 259–260
entering text in HyperCard fields, 235–236, 235, 236
Import Picture dialog box, 242–246, 243, 333
QuickTime option, 245–246, 245
importing text into HyperCard fields, 237–238, 237, 238, 239
installing, 9–20
enabling HyperCard 2.1, 17, 18
into HyperCard, 14–17, 15, 16
with MediaTools Runner, 9–10, 10, 11
preparing HyperCard for, 11–13, 13, 14
setting HyperCard user level, 18–20, 19
license agreement, 331–332
Media menu, 332–334
Import>EPS File command, 333
Import>Picture command, 333
Import>Text command, 334
MIDI settings dialog box, 194, 194
MIDI Tools, 202–211, 336–339
MIDI Recorder, 202–204, 203, 336, 336
MIDI Setup dialog box, 194, 194, 211, 338–339, 339
MIDIFile Player, 204–211, 205, 337–338, 338
overview of, 336–339
Movie Tools, 72–76, 72, 188–190, 343–344, 344. See also Adobe Premier; QuickTime
creating buttons for CD audio playback, 188–190, 189
creating buttons for video playback, 74–76, 75, 76, 77, 260–262
overview of, 72, 343–344
selecting movie segments, 73, 74
viewing movie segments, 73
overview of, 301–302
Preferences dialog box, 344–345, 345
running explorations, 3
using in HyperCard, 20
utilities, 345–350
Alignment tools, 348–350
Card tools, 347
Mouse Locator, 348
Numbering tools, 350
Object Lister, 347–348
Object Mover, 350
Rect Getter, 348
ResCopy, 346
Stack tools, 346
Media Vision Pro Audio Spectrum 16 audio cards, 324
MediaTime software with MoviePak daughter board, 327
MediaTools Runner explorations installing, 21
running, 22–23, 23, 24, 25
exploring Multimedia Machine with, 22–23, 23, 24
installing Media Tools with, 9–10, 10, 11
overview of, 3, 9, 301–302
memory
Multimedia Machine CD requirements for, 2
RAM versus hard disk space, 32
RAM-based sound files, 50
microphones, 42, 117–119. See also sound input devices
MIDI
General MIDI specification, 55, 56
MIDI messages, 58
overview of, 54–55
sequencing and, 55
Standard MIDI File (SMF) format, 61
MIDI audio cards, 326
MIDI channels, 208
MIDI clock synchronization, 247
MIDI event editors, MIDIFile Player, 206–211, 206
MIDI files. See Standard MIDI File (SMF) format
MIDI keyboards, 325
MIDI Manager, 195–198, 196, 197
MIDI 'n' Synths stack, 136–140, 138, 226–227, 303
MIDI information in, 226–227
overview of, 136–137, 303
sound design concepts exploration, 138–140
MIDI program popup menu, MusicShop, 217–218, 218
MIDI Recorder, 202–204, 203, 336, 336
MIDI sequencers, 328
MIDI Setup dialog box
MIDI Tools, 194, 194, 211, 338–339, 339
MusicShop, 194, 195
MIDI sound modules, 326
MIDI synthesizers, 38–40, 54–63, 191–227, 325–326. See also
MIDI 'n' Synths stack; MIDI Tools;
MusicShop
architecture of, 55–56, 56
connecting, 38–39, 39
disk storage and, 38–39
explorations
changing sounds, 58–61, 61, 62
comparing digital, CD, and MIDI audio, 40, 41
Macintosh, MIDI, and Music: The Open Door video, 191–193, 192
MIDI information in MIDI 'n'
Synths stack, 226–227
playing and editing MIDI files with
MIDIFile Player, 204–211, 205
playing and editing MIDI files with
MusicShop, 211–226
playing MIDI sequences, 40
recording MIDI sequences with
MIDI Recorder, 202–204, 203
synchronizing slides with MIDI soundtrack, 198–202, 199
hardware configurations, 57–58, 57, 59
MIDI synthesizer cards, 58, 60
multitimbral, 56
polyphony and, 56
recommended, 325–326
system configuration, 193–198
direct MIDI connections, 194–195
MIDI Manager, 195–198, 196, 197
Open MIDI System (OMS), 198, 199
types of, 55, 56
MIDI Time Code (MTC), 248
MIDI Tools, 202–211, 336–339
MIDI Recorder, 202–204, 203, 336, 336
MIDI Setup dialog box, 194, 194, 211, 338–339, 339
MIDIFile Player, 204–211, 205, 337–338, 338
activating, 204–205
global MIDI event editors, 206–211, 206
overview of, 337–338
region and repeat tools, 209–211, 209
Tempo control tool, 207
Transposer tool, 208–209
Volume control tool, 207
MIDI tracks, 208
mini phone jacks, 34, 35
mixed mode disks, 38
mixers
in Adobe Premier, 254, 255
in MusicShop, 215–218, 216
in TurboSynth, 149–152, 151
modality, of music, 233
modules, sound synthesis and, 140–152
Mouse Locator utility, Media Tools, 348
Movie Tools, 72–76, 72, 188–190, 343–344, 344. See also Adobe Premier; digital video; Media Tools; QuickTime
creating buttons for CD audio playback, 188–190, 189
overview of, 343–344
playing digital video, 72–76, 72
creating buttons for video playback, 74–76, 75, 76, 77, 260–262
selecting movie segments, 73, 74
viewing movie segments, 73
MoviePak daughter board, 327
See also Adobe Premier; digital video; MovieTools; QuickTime
converting CD audio to QuickTime movie format, 173–182
Audio Conversion dialog box, 174, 175
Audio Import Options dialog box, 174–178, 176, 177
audio only QuickTime movie window, 178, 179
Importing Movie progress dialog box, 178, 178
playing digital video, 66–71, 67
creating new movie window, 68, 69
editing frames, 68–69, 70
looping movies, 71
opening files, 66
retrieving movies, 70
saving movies, 69–70
selecting frames and segments, 67–68, 68, 71
sizing movies, 71
toggling between playback and
pause modes, 67
movies. See digital video
MTC (MIDI Time Code), 248
multimedia, 234-266. See also digital
audio; digital video; media; music;
sound
combining media, 248-266
adding music to video in Adobe Pre-
mi er, 248-259
creating slide shows, 263-266
with Media Tools, 259-263
spotting, 248, 251-252
explorations
adding music to video with Adobe
Premier, 249-259
combining media with Media Tools,
259-253
creating a slide show, 263-266
impact of music on video, 229-231
using graphics with Media Tools,
240-246
using text with Media Tools,
235-238
graphics, 238-246
creating with HyperCard painting
tools, 240-241, 242
file formats, 239-240
importing PICT files into Hyper-
Card, 242-245, 243, 244
importing PICT files as QuickTime
photos, 245-246, 245
interactive multimedia, 139, 267-299.
See also HyperCard
declared, 139, 267
interactive MIDI exploration, 268
slide shows
creating, 263-266
synchronizing with MIDI sound-
track, 198-202, 199
synchronizing to CD audio, 168-173
synchronization, 247-248
text, 234-238
ASCII text files, 234, 237-238
entering in HyperCard fields,
235-236, 235, 236
importing ASCII files into Hyper-
Card, 237-238, 237, 238, 239
typefaces and fonts, 234
VCRs, laserdisc players, and animation,
246-247
Multimedia Files folder, 22, 23
Multimedia Machine CD, 301-330
CD audio tracks, 318-321
¡Acinchal!, 319
A Darker Shade of Gray, 318-319
Fall Equinox, 320-321
Looking Back, 320
exploration contents, 304-309
Chapter 2, 304
Chapter 3, 305
Chapter 4, 306
Chapter 5, 307
Chapter 6, 307-308
Chapter 7, 308-309
Chapter 8, 309
exploring
with HyperCard, 24
with MediaTools Runner,
22-23, 23, 24
hardware requirements, 1-2
music contents, 310-313
digital audio files, 310-311
MIDI files, 311-312
sound effects, 312
system beeps, 313
picture contents, 316-317
playing data track (track 1), 38, 53
QuickTime movies, 314-316
Scroll-It! stack
creating slide shows, 263-266
overview of, 303
synchronizing slides with MIDI
soundtrack, 198-202
synchronizing slides to CD audio,
168-173
sndConverter software, 157-160, 159,
160, 303
software contents, 301-303. See also in-
dividual entries for software
Adobe Premier demo, 302
Desktop Music Production, 303
Digidesign TurboSynth demo, 302
Media Tools and MediaTools Runner, 301–302
MIDI 'n' Synths stack, 136–140, 138, 226–227, 303
Opcode MusicShop demo software, 303
Scroll-It! stack, 303
sndConverter, 157–160, 159, 160, 303
software requirements, 2–3
system extras, 317–318
video playback and, 84
multitimbral synthesizers, 56
music, 27–30, 229–233. See also MIDI; multimedia; MusicShop; sound
adding to video, 248–259
adding sound effects, 255–256, 255, 258
fading between selections, 256–259
importing video, music, and sound effects into Adobe Premier, 249, 250
mixing tracks, 254, 255
placing movie into video A track and watching, 251–252, 251
common time, 200–201
elements of, 231–233
contextual reference, 233
density, 231–232
instrumentation and timbre (orchestration), 232
modality and tonality, 233
tempo and rhythm, 232–233
emotion and, 233
explorations
impact of music on video, 229–231, 230
Macintosh, MIDI, and Music: The Open Door video, 191–193, 192
role of music in multimedia, 27–30, 28, 30
importing into Adobe Premier, 249, 250
on Multimedia Machine CD, 310–313, 318–321
¡Acincha!, 319
A Darker Shade of Gray, 318–319
digital audio files, 310–311
Fall Equinox, 320–321
Looking Back, 320
MIDI files, 311–312
sound effects, 312
system beeps, 313
ticks, 201
transposing to a new key in MusicShop, 214
MusicShop software, 211–226, 303, 328
Arrangement window, 220–222, 221
changing
tempo, 214–215, 215
track volume, stereo placement, and instrumental sound, 215–218, 216, 217, 218
combining sequence files, 219–222, 219, 222
Edit window, 211, 212–215, 212, 213
importing MIDI files, 219–220
MIDI Manager and, 196, 197
MIDI program popup menu, 217–218, 218
MIDI Setup dialog box, 194, 195
Mixer window, 215–218, 216
notation view, 223–225, 226
octave popup menu, 223, 224
overview of, 24–25, 303, 328
pan popup slider, 217, 217
printing scores, 225–226, 227
Sequence popup menu, 219–220, 219
transposing music to a new key, 214

N
New Stack dialog box, HyperCard, 284, 284
non-destructive editing, 136
notation view, MusicShop, 223–225, 226
NuBus slots, 34
Numbering tools, Media Tools, 350

O
Object Lister utility, Media Tools, 347–348
Object Mover utility, Media Tools, 350
octave popup menu, MusicShop, 223, 224
Opcode Systems. See also MusicShop
AudioShop editor, 329
Open MIDI System (OMS), 198, 199
Standard MIDI File (SMF) format, 61
orchestration, of music, 232
oscillators
defined, 140
in TurboSynth, 141–143, 141, 142, 143,
148–149, 153

pan popup slider, MusicShop, 217, 217
Passport
Producer Pro authoring software, 298,
299, 330
Trax MIDI sequencer, 328
patches
creating, 152–157
defined, 131
exploration, 140–152
patterns, sequence, 221
PDS (Processor Direct Slots), 34
Performer MIDI sequencer, 328
Persona Technologies Mac speakers, 324
phono jacks, 34, 35
PICT files
defined, 239
importing into HyperCard, 242–245,
243, 244
as QuickTime photos, 245–246, 245
pictures. See also digital video; graphics;
multimedia; slide shows
on Multimedia Machine CD, 316–317
pixels, 79
playing
AIFF files, 186–190
CD audio, 38, 165–167, 187–188, 189
CD data track (track 1), 38, 53
digital audio
creating buttons for, 122–125, 260,
342
disk files with Audio Tools, 122–125
from HyperCard, 32–33
digital video with MovieTools,
72–76, 72
creating buttons for video playback,
74–76, 75, 76, 77, 260–262
selecting movie segments, 73, 74
viewing movie segments, 73
digital video with MoviePlayer,
66–71, 67
creating new movie window, 68, 69
editing frames, 68–69, 70
looping movies, 71
opening files, 66
retrieving movies, 70
saving movies, 69–70
selecting frames and segments,
67–68, 68, 71
sizing movies, 71
toggling between playback and
pause modes, 67
digital video playback speed, 83–84
MIDI files
with MIDIFile Player, 204–211, 205
with MusicShop, 211–226
MIDI sequences, 40
QuickTime movie format, 186–190
plugs, digital audio, 34
PM-5 speakers, 324
polyphony, 56
Poster Frames, QuickTime, 71
powered speakers, 323–324
Preferences dialog box, Media Tools,
344–345, 345
printing scores, in MusicShop, 225–226,
227
Pro Audio Spectrum 16 audio cards, 324
Pro Tools audio card, 325, 339
Processor Direct Slots (PDS), 34
Producer Pro authoring software, 298, 299,
330
Project window, Adobe Premier, 84, 85, 89,
90, 249, 250

quantizing, 47
QuickTime, 65–110. See also Adobe Pre-
mier; digital video; Movie Tools;
MoviePlayer
compression schemes (codecs), 80–84
Apple Animation compression algo-
rithm, 81
Apple Compact Video compression
algorithm, 82–83
Apple Graphic compression algorithm, 82
Apple Photo compression algorithm, 81
Apple Video compression algorithm, 81, 82
JPEG compression algorithm, 81, 83
spatial compression, 80
SuperMac DigitalFilm system, 81, 83, 84, 327
temporal compression, 80–81
dithering video display, 83
editing digital video, 84–110
adding transitions, 101–103
audio volume envelopes, 103–107, 180–182, 181
butt-end splice, 100
combining video segments, 100
overview of, 84–87
removing unwanted sections, 93–99
setting in and out points, 88–92
using filters, 107–110
explorations
converting CD audio to QuickTime movie format, 173–179
converting QuickTime movie format to AIFF files, 182–186
editing CD audio in Premier, 179–182
editing QuickTime movies, 86–110
importing PICT files into HyperCard as QuickTime photos, 245–246, 245
playing QuickTime movie format and AIFF files from HyperCard, 186–190
role of music in multimedia, 27–30, 28, 30
overview of, 77–79
Poster Frames, 71
QuickTime movie format, 173–190
converting CD audio to, 174–179
converting to AIFF files, 182–186
editing in Adobe Premier, 179–182
playing as AIFF files from HyperCard, 186–190
QuickTime movie window, MoviePlayer, 178, 179
QuickTime movies, on Multimedia Machine CD, 314–316
QuickTime option, Media Tools Import Picture dialog box, 245–246, 245

R

Radius, VideoVision Studio video digitizer, 327
RAM
versus hard disk space, 32
RAM-based sound files, 50
RasterOps, MediaTime with MoviePak daughter board, 327
RCA jacks, 34, 35
recommended hardware, 323–327
recommended software, 327–330
record dialog box
Audio Tools, 126–127, 127, 342, 342
Sound Manager, 117–118, 119
recording
analog audio recording, 42–43, 43
digital audio, 125–130, 341–342, 342
to RAM, 125–128
recording disk files, 129–130
direct-to-disk recording, 33
MIDI sequences, 202–204, 203
Rect Getter utility, Media Tools, 348
Region and Repeat tools, MIDIFile Player, 209–211, 209
reproduction quality. See fidelity
ResCopy utility, Media Tools, 346
resources, 50
rhythm, of music, 232–233
Roland
JV30 synthesizer, 325
Sound Canvas MIDI module, 326
running explorations
with HyperCard, 3, 9, 24
with MediaTools Runner, 22–23, 23, 24, 25

S

SampleCell II MIDI audio card, 326
sampling. See digital audio
Saving File progress window, Adobe Premier—sound effects

Saving File progress window, Adobe Premier, 184, 187
script editor, HyperCard, 279–280, 279, 281
scripting. See also authoring software;
HyperCard
in HyperCard, 278–280, 279, 281, 285–297
Scroll-It! stack
creating slide shows, 263–266
overview of, 303
synchronizing slides with MIDI sound-track, 198–202
synchronizing slides to CD audio, 168–173
Search dialog box, CD Tools, 165, 166
Sequence popup menu, MusicShop, 219–220, 219
sequencers, recommended, 328
sequencing
chaining sequences, 220–221
combining sequence files, 219–222,
219, 222
MIDI and, 55
recording MIDI sequences with MIDI
Recorder, 202–204, 203
sub-sequences or patterns, 221
tracks versus channels, 208–209
shortcut keys, 6
signal processors, 140
signal-to-noise ratio (S/N), 47
slide shows
creating, 263–266
synchronizing with MIDI soundtrack, 198–202, 199
synchronizing to CD audio, 168–173
slots, NuBus versus Processor Direct Slots
(PDS), 34
SMF. See Standard MIDI File (SMF) format
SMPTE time code, 247–248
S/N (signal-to-noise ratio), 47
snd resources, saving sounds as, 125–128
sndConverter software, 157–160, 159, 160,
303
software, 2–3, 301–303, 327–330
See also individual entries for software
Adobe Premier demo, 302
Desktop Music Production, 303
Digidesign TurboSynth demo, 302
Media Tools and MediaTools Runner, 301–302
MIDI 'n' Synths stack, 136–140,
138, 226–227, 303
Opcode MusicShop demo, 303
Scroll-It! stack, 303
sndConverter, 157–160, 159, 160,
303
recommended, 327–330
audio editors, 328–329
authoring software, 329–330
MIDI sequencers, 328
video editors, 329
requirements for Multimedia Machine
CD, 2–3
Sonata software, 318
sound, 136–160. See also CD audio; digital
audio; MIDI; music
alert sounds
adding and setting system beep, 113–115
converting sounds to system beeps, 158–160
creating System 7 alert sounds, 50,
157–160
software for, 31, 31
analog recording, 42–43, 43
explained, 42
frequency range, 44
hertz (Hz) and kilohertz (kHz), 45
synthesizing, 136–157. See also
TurboSynth
creating patches, 152–157
overview of, 136–137
sound design concepts, 138–140
understanding modules and
patches, 140–152
waveforms and, 142
sound cards
adding, 33, 34
fidelity and, 48
MIDI audio cards, 326
recommended, 324–325
Sound Designer II audio editor, 328
sound effects
adding to video, 255–256, 255, 258
importing into Adobe Premier, 249, 250
on Multimedia Machine CD, 312
sound input devices
- defined, 33
- microphones, 42
- setting, 116-119
Sound Manager, 111-122, 112, 113, 318.
  See also digital audio
- adding alert sounds and setting system beep, 113-115
- overview of, 111-112
- record dialog box, 117-118, 119
- setting sound input devices, 116-119
- setting sound output devices, 120-122
Sound control panel
  - Alert Sounds page, 114, 115
  - overview of, 113, 113
  - Sound In page, 116, 118
  - Sound Out page, 120-121, 120
  - Volumes page, 121-122, 121
Sound popup menu, 116, 117
sound modules, MIDI, 326
sound output devices. See speakers
sound quality. See fidelity
SoundEdit file format, 51
SoundEdit Pro audio editor, 328
SoundMaster software, 31
spatial compression, 80, 80
speakers
  - digital audio and, 33, 34
  - recommended, 323-324
  - setting volume, 120-122
splicing movies. See Adobe Premier;
  - Movie Tools
spotting, 248, 251-252
Stack tools, Media Tools, 346
stacks (HyperCard)
  - creating, 284
  - defined, 269
Standard MIDI File (SMF) format
  - defined, 61
  - fidelity and file size, 61-63
importing into MusicShop, 219-220
on Multimedia Machine CD, 311-312
playing and editing with MIDIFile
  - Player, 204-211, 205
  - playing and editing with MusicShop, 211-226
standard phono jacks, 34, 35
storage
  - of MIDI information, 38-39
  - of sound files, 50-51
  - storage capacity of CDs, 51
sub-sequences, 221
SuperMac
  - DigitalFilm system, 81, 83, 84, 327
  - VideoSpigot video digitizer, 327
synchronization, 247-248
synchronizing slides
to CD audio, 168-173
with MIDI soundtrack, 198-202, 199
synth cards, 58, 60
synthesizers. See MIDI synthesizers
synthesizing sound, 136-157. See also digital audio; TurboSynth
  - creating patches, 152-157
  - overview of, 136-137
  - sound design concepts, 138-140
  - understanding modules and patches, 140-152
system alert sounds
  - converting sounds to system beeps, 158-160
on Multimedia Machine CD, 313
  - software for, 31, 31
System 7 alert sounds
  - creating, 157-160
  - defined, 50
system extensions. See extensions
System Extras folder, 4, 5, 317-318
system files
  - installing, 4-9, 5, 7
  - listed, 8

T

Tagged Image File Format (TIFF), 239
tempo, of music, 232-233
Tempo control tool, MIDIFile Player, 207
temporal compression, 80-81, 80-81
text, 234-238. See also multimedia
  - ASCII text files, 234, 237-238
entering in HyperCard fields, 235-236, 235, 236
importing ASCII files into HyperCard,
  - 237-238, 237, 238, 239
typefaces and fonts, 234
Text Properties dialog box, HyperCard—Yamaha TG100 MIDI sound module

Text Properties dialog box, HyperCard, 272–273, 274, 275

ticks, 201
TIFF file format, 239
timbre, of music, 232
time delays
  defined, 140
  in TurboSynth, 147–148, 147, 151, 156–157, 156
tonality, of music, 233
Tools palette, HyperCard, 240–241, 242
tracks, MIDI, 208
transducers, 42
transitions, video, 101–103
transposing
  in MIDI, 208–209
music to a new key, 214
Trax MIDI sequencer, 328
TurboSynth software, 130–157. See also digital audio
  editing digital audio, 130–136
  overview of, 25, 130–131, 132, 133, 302, 329
synthesizing sound, 136–157
  creating patches, 152–157
  envelope module, 143–144, 154–156, 155
  filter module, 143–146, 144, 146, 149–151, 153–154
  mixer module, 149–152, 151
  oscillator module, 141–143, 141, 142, 143, 148–149, 153
sound design concepts, 138–140
  time delay module, 147–148, 147, 151, 156–157, 156
  understanding modules and patches, 140–152

typefaces, 234

U

utilities, Media Tools, 345–350
  Alignment tools, 348–350
  Card tools, 347
  Mouse Locator, 348

V

video. See Adobe Premier; digital video;
  Movie Tools; MoviePlayer;
  QuickTime
  video cassette recorders (VCRs), 246
  video digitizers, 84, 327
  video editors, 329. See also Adobe Premier
  VideoSpigot video digitizer, 327
  VideoVision Studio video digitizer, 327
  Vision software, 318
  Volume control tool, MIDIFile Player, 207
  volume envelopes, audio, 103–107, 180–182, 181

W

waveforms. See also sound
  defined, 140
  sound and, 142

X

X3 synthesizer, 325

Y

Yamaha TG100 MIDI sound module, 326
The Macintosh is supposed to be one of the easiest computers to use. But even the Mac has its problems. That's when it's time to reach for Murphy's Laws of Macs. This simple, plain-English, problem-solving book gives you the answers you need and lets you have fun in the bargain.

Whether you're new to computers or just new to the Mac, you'll find a gold mine of useful information in this book. Learn how to buy a Macintosh computer, find the best programs for your Mac, get tips for avoiding Mac pitfalls and more.

You'll get all of this and more in an entertaining and easy-to-reference format. The Mac is a fun machine to use. Murphy's Laws of Macs helps you get more from your Macintosh.

SYBEX. Help Yourself.

2021 Challenger Drive
Alameda, CA 94501
1-510-523-8233
1-800-227-2346
Find out everything you need to know about System 7.1, the Mac's feature-rich operating system. This is the first book to give you authoritative, expert coverage of advanced System 7.1 topics, while covering the basics for beginners.

Start with a step-by-step primer for starting up the Macintosh Finder and control system. Then move on to intermediate features, like multi-tasking and font management. You'll also find in-depth coverage of memory management, Inter-Application Communication and more.

Advanced Mac users will appreciate learning about Finder Desktop customization; QuickTime, for multimedia applications; and At Ease, the finder alternative. Everything you need is right here.

SYBEX. Help Yourself.

2021 Challenger Drive
Alameda, CA 94501
1-510-523-8233
1-800-227-2346
Macintosh System 7.1 at Your Fingertips is a no-nonsense guide to every feature and function of System 7.1 for the Mac. Even if you’ve never used a Mac before, you’ll find the answers you need in this palm-sized book.

This handy guide gives you a concise description of new System 7.1 features and capabilities and a comprehensive overview of the operating system. What’s more, this book is organized by important features and cross-referenced for ease of use.

Whether you’re a Mac maven or mortal, you’ll get everything you need in this book—at your fingertips. Make sure this book is at your side every time you sit down at your Macintosh.

SYBEX. Help Yourself.
PageMaker 5.0 for the Mac Page Design is the graphic designer's guide to getting the most out of PageMaker. This friendly handbook will give beginners and experienced users alike hands-on instruction for PageMaker for the Mac.

This book starts with a basic overview of the program, complete with hands-on examples. Then coverage moves on to text and graphics, timesaving tips and print production.

Upgraders will get an overview of the differences between PageMaker 4.2 and 5.0 and experts will find the special section on program shortcuts and electronic design resources especially useful.

SYBEX. Help Yourself.
The Quickest Way to Learn QuickTime.

The QuickTime How-To Book is a comprehensive introduction to multimedia desktop presentation with QuickTime—one of the most talked about and least understood developments in Mac computing today.

The QuickTime How-To Book gives you a solid guide to multimedia fundamentals, step-by-step treatment of QuickTime features and a complete introduction to real-world principles to creating presentations for business and other uses.

As an added bonus, this book includes a FREE disk packed with samples of each of the different QuickTime media types. This high-density disk includes three QuickTime movies, two sound-only movies, two full-screen images and two animations, specially designed for you to edit as you like.

SYBEX. Help Yourself.

2021 Challenger Drive
Alameda, CA 94501
1-800-227-2346
Help Yourself with
Another Quality Sybex Book

The Mac Book of Excel 4
Marvin Bryan

This comprehensive guide to spreadsheet power on the Mac offers engaging, hands-on treatment of every aspect of the software. Look for dozens of practical examples, highlighted coverage of new features, and in-depth discussion of advanced techniques—along with details on database management, presentation graphics, macros, and more.

650pp; 7 1/2" x 9"
ISBN: 0-7821-1108-4

Available at Better Bookstores Everywhere

Sybex Inc.
2021 Challenger Drive
Alameda, CA 94501
Telephone (800) 227-2346
Fax (510) 523-2373

Sybex. Help Yourself.
Page Design with QuarkXPress 3.2 for the Mac is a thoroughly practical guide to this sophisticated page layout program. You’ll find logical, easy-to-follow coverage of everything from QuarkXPress fundamentals to advanced features.

Start with step-by-step instructions for creating your first QuarkXPress document. Then learn about layout templates, word processing, typography and graphics. You’ll even learn about pre-press color separation.

You’ll also find complete descriptions of more than 100 commercial and shareware QuarkX- Tensions for a wide assortment of applications.

SYBEX. Help Yourself.
Finally there's a guide that helps you fulfill the promises of computer convenience you've always heard about—Exploring the World of Online Services.

With the help of this book, you can discover the myriad conveniences you can enjoy by using your computer and a modem. Find out how to send electronic mail and messages, or tap into over 5,500 public online databases. Get money-saving advice for choosing modems and communication software, and for saving money on your online bills.

Online veterans will especially enjoy the in-depth coverage of WinCIM, the new Windows version of the CompuServe Information Manager (CIM), and the in-depth discussion of a range of online service providers.

SYBEX. Help Yourself.

2021 Challenger Drive
Alameda, CA 94501
800-227-2346
Get quick answers to common questions about the Internet commands, customs, tools, resources and organizations. You'll find everything you need right here in the Internet Instant Reference.

This convenient pocket-sized reference features step-by-step instructions to Usenet, Gopher, World Wide Web and more. You'll also find extensive information about U.S. government on-line resources.

The Internet is one of the most important resources in your future. With the Internet Instant Reference, you can be sure you won't be left behind.

SYBEX.
Shortcuts to Understanding.
**The Next Best Thing to a Personal Translator.**

*Xbase Cross Reference Handbook* is a remarkable compilation of all the commands, functions, operators and keywords for every major Xbase program: FoxPro, dBASE IV, Clipper, dBASE III Plus, and FoxBASE+ for the Mac.

Each alphabetical entry is fully cross-referenced, providing exact syntax, complete definitions and example code. You'll know instantly which programs support any command or function.

Beginning programmers will be able to see which programs support the commands and functions they need most often. Intermediate and advanced programmers will find this book indispensable.

SYBEX. Help Yourself.
The PC User’s essential, accessible Pocket Dictionary is the most complete, most readable computer dictionary available today. With over 2,000 plain-language entries, this inexpensive handbook offers exceptional coverage of computer industry terms at a remarkably affordable price.

In this handy reference you’ll find plenty of explanatory tables and figures, practical tips, notes, and warnings, and in-depth entries on the most essential terms. You’ll also appreciate the extensive cross-referencing, designed to make it easy for you to find the answers you need.

Presented in easy-to-use alphabetical order, The PC User’s essential, accessible Pocket Dictionary covers every conceivable computer-related topic. Ideal for home, office, and school use, it’s the only computer dictionary you need!

SYBEX. Help Yourself.
GET A FREE CATALOG JUST FOR EXPRESSING YOUR OPINION.

Help us improve our books and get a FREE full-color catalog in the bargain. Please complete this form, pull out this page and send it in today. The address is on the reverse side.

Name ____________________________ Company ____________________________
Address ____________________________ City ________ State _____ Zip ________
Phone (________) ____________________

1. How would you rate the overall quality of this book?
   - Excellent
   - Very Good
   - Good
   - Fair
   - Below Average
   - Poor

2. What were the things you liked most about the book? (Check all that apply)
   - Pace
   - Format
   - Writing Style
   - Examples
   - Table of Contents
   - Index
   - Price
   - Illustrations
   - Type Style
   - Cover
   - Depth of Coverage
   - Fast Track Notes

3. What were the things you liked least about the book? (Check all that apply)
   - Pace
   - Format
   - Writing Style
   - Examples
   - Table of Contents
   - Index
   - Price
   - Illustrations
   - Type Style
   - Cover
   - Depth of Coverage
   - Fast Track Notes

4. Where did you buy this book?
   - Bookstore chain
   - Small independent bookstore
   - Computer store
   - Wholesale club
   - College bookstore
   - Technical bookstore
   - Other ____________________________

5. How did you decide to buy this particular book?
   - Recommended by friend
   - Recommended by store personnel
   - Author’s reputation
   - Sybex’s reputation
   - Read book review in ____________
   - Other ____________________________

6. How did you pay for this book?
   - Used own funds
   - Reimbursed by company
   - Received book as a gift

7. What is your level of experience with the subject covered in this book?
   - Beginner
   - Intermediate
   - Advanced

8. How long have you been using a computer?
   - years ____________
   - months ____________

9. Where do you most often use your computer?
   - Home
   - Work

10. What kind of computer equipment do you have? (Check all that apply)
    - PC Compatible Desktop Computer
    - PC Compatible Laptop Computer
    - Apple/Mac Computer
    - Apple/Mac Laptop Computer
    - CD ROM
    - Fax Modem
    - Data Modem
    - Scanner
    - Sound Card
    - Other ____________________________

11. What other kinds of software packages do you ordinarily use?
    - Accounting
    - Databases
    - Networks
    - Apple/Mac
    - Desktop Publishing
    - Spreadsheets
    - CAD
    - Games
    - Word Processing
    - Communications
    - Money Management
    - Other ____________________________

12. What operating systems do you ordinarily use?
    - DOS
    - OS/2
    - Windows
    - Apple/Mac
    - Windows NT
    - Other ____________________________
13. On what computer-related subject(s) would you like to see more books?

__________________________________________________________________________

__________________________________________________________________________

__________________________________________________________________________

__________________________________________________________________________

14. Do you have any other comments about this book? (Please feel free to use a separate piece of paper if you need more room)

__________________________________________________________________________

__________________________________________________________________________

__________________________________________________________________________

__________________________________________________________________________
The Multimedia Machine CD is a goldmine of audio tracks, QuickTime movies, MIDI files, digital images, software, and other useful stuff. Turn to Chapter 1 and install the programs to start learning multimedia on the Mac right away! The CD includes:

**CD Audio Tracks**
A Darker Shade of Gray
!Acincha!
Looking Back
Fall Equinox

**QuickTime Movies**
Maria Lionza (160x120)
Mute Maria (160x120)
Big Musicians: Carlos, Herbie, Laurie, Tom, Tony (320x240 Motion JPEG)
Musicians: Carlos, Herbie, Laurie, Tom, Tony (160x120)
River Movie Suite

**Software**
Media Tools and MediaTools Runner
Adobe Premier Demo
Digidesign TurboSynth Demo
Opcode MusicShop Demo
SndConverter
Scroll-It!
Exploration stacks

**Plus ...**
Digital audio files
Standard MIDI files
System beeps
Pictures
And lots, lots more!
Macintosh Multimedia Machine is a comprehensive, learn-by-doing guide to multimedia production on the Mac. Thoroughly integrated and completely hands-on, this book/CD-ROM combination helps you tackle the issues of video, audio, MIDI synthesizers, and more. You'll explore:

- **Sound fundamentals.** Gain a firm understanding of audio, including its role in multimedia, and how it is created and played back on the Mac.
- **Digital video and audio.** Discover QuickTime and how it works, and learn to record and integrate sound with video.
- **Audio CDs.** Examine different ways of controlling the playback of standard audio CDs from a CD-ROM player, and convert a portion of an audio CD track into a QuickTime movie track.
- **Synthesizer hardware.** Learn how MIDI expands your ability to create and play back remarkably high-quality sound.
- **Interactivity.** Explore the issues multimedia producers face and the tools they use when creating interactive works.

**About the Author:**
David S. Mash is Assistant Dean of Curriculum for Academic Technology at Berklee College of Music, and a recognized authority on multimedia technologies. He has collaborated on projects with Adobe Systems, Apple Computer, Kodak, Korg, and other industry leaders.

The enclosed CD-ROM contains Media Tools, a HyperCard application offering a wide array of multimedia authoring capabilities. You will also find hundreds of megabytes of QuickTime movies; MIDI files; digital audio files; still images; and demonstration versions of Adobe's Premiere 3.0, Digidesign's Turbosynth, and Opcode Systems' MusicShop. The CD includes four audio tracks that can be played on a Mac, a home stereo, or a portable CD player.