Macintosh
The Definitive User's Guide
Publishing Director: David Culverwell
Acquisitions Editor: Susan Love
Production Editor: Roberta Glencer
Text Designer: Michael Rogers
Art Director/Cover Design: Don Sellers
Assistant Art Director: Bernard Vervin
Cover Photography: George Dodson
Manufacturing Director: John A. Komsa

Typesetter: Mid-Atlantic Photo Composition, Baltimore MD
Printer: R. R. Donnelley and Sons Company, Harrisonburg, VA
Typefaces: Aster (text), Helvetica (display)

All photographs of the Macintosh computer used with permission of Apple Computer, Inc.
About the Author

Dr. John M. Allswang is Professor of History at California State University, Los Angeles. As a historian, he has published four books and numerous articles and papers. He has served as Visiting Professor of History at the Hebrew University of Jerusalem, Israel, and at the University of Leiden, the Netherlands.

He has been involved with computers, large and small, for over 15 years, and was one of the developers of his university’s basic computer literacy course, which he has taught for ten years. He is the owner of Computer Explanations, a Los Angeles-based microcomputer consulting firm.

Dr. Allswang has written dozens of articles and hardware and software evaluations for several computer magazines. He is presently a Contributing Editor for Interface Age and IBM PC UPDATE magazines, and writes monthly columns for both of them. He is currently completing a book on computers and computing for physicians.

Dr. Allswang lives in Los Angeles with his wife, two daughters, and four computers.
Contents

Preface / ix

Part I: The Macintosh System / 1
  1. The Fundamental Macintosh / 3
  2. The Desktop / 25
  3. The Finder / 51
  4. Managing Documents & Disks / 79

Part II: Doing Work / 111
  5. MacWrite / 113
  6. MacPaint / 149

Part III: Reference / 185
  Appendix A: BASIC Programming / 187
  Appendix B: The Internal Macintosh / 211
  Appendix C: Macintosh Quick Reference / 221

Index / 235
Limits of Liability and Disclaimer of Warranty

The author(s) and publisher of this book have used their best efforts in preparing this book and the programs contained in it. These efforts include the development, research, and testing of the theories and programs to determine their effectiveness. The author(s) and publisher make no warranty of any kind, expressed or implied, with regard to these programs or the documentation contained in this book. The author(s) and publisher shall not be liable in any event for incidental or consequential damages in connection with, or arising out of, the furnishing, performance, or use of these programs.

Note to Authors

Have you written a book related to personal computers? Do you have an idea for developing such a project? If so, we would like to hear from you. Brady produces a complete range of books for the personal computer market. We invite you to write to David Culverwell, Publishing Director, Brady Communications Company, Inc., Bowie, MD 20715.

Registered Trademarks

Macintosh, MacWrite, and MacPaint are registered trademarks of Apple Computer, Inc.
Preface

Introduction / x
Structure / xi
Scope / xii
Acknowledgments / xii
Introduction

This is a book for two fairly distinct groups of people. First, it is for those who currently own an Apple Macintosh computer and want some help in getting maximum use out of it. Secondly, it's for those who are thinking about buying a Macintosh but would like to first understand what it does before buying one.

The book can be viewed as a supplement to or replacement for the manuals that come with the Macintosh system, including its word processing and drawing programs, MacWrite and MacPaint. Those are not bad manuals as computer manuals go, but they have not proved satisfactory to many users. They are also incomplete, ignoring some basic aspects of Macintosh operation. Moreover, even if Macintosh owners have been able to make good progress with the Macintosh manuals, they may want the assistance of the different instructional approach and format, plus greater thoroughness, provided in this book.

*Macintosh—The Definitive User's Guide* is just that—a user's guide. It is not a technical manual, nor is it an "advanced" user's handbook. It is geared to beginners, and to teaching them how to fully use the computer and its programs. Its approach is tutorial, which is one of its main differences from the Apple manuals. You will be taken through exercises using the Macintosh, where you will see precisely how things work, and will be able to check your results against those in the book. Since the results of all tutorial actions are presented in the book, you will be able to develop a very good sense of how the Macintosh works even if you do not currently own one.

An additional advantage of the tutorial format is that we will not need to go into lengthy explanations about how to operate the computer. Such explanations are built into the exercises you will be doing. Your learning of terms, concepts, and specific skills will come about automatically as you proceed from one exercise to another. By concentrating on actual tasks, we can avoid much of the confusion often associated with learning computing, because you will not have to use any Macintosh facility until there is a logical reason for using it. As
such, the skill is learned in a meaningful context and is readily remembered.

When you have gone through all the exercises in the book, you will have used all the facilities of the Macintosh and the MacWrite and MacPaint applications programs as well. You will also, if you wish, understand how the two versions of the BASIC programming language available for the Macintosh operate, and be able to make an intelligent decision about which is best for you if you want to do some programming.

Structure

_Macintosh—The Definitive User's Guide_ is divided into three parts. Part I is a brief introductory chapter presenting the computer itself and some of its basic concepts and modes of operation. The tutorial begins in Chapter 2. This, plus Chapters 3 and 4, focuses on the Macintosh system—learning how the computer operates no matter what you may be using it for. Here, you will master the skills needed to operate the Macintosh whether you are doing word processing, drawing, spreadsheets, or anything else. You will learn how to handle disks, files of information, and programs; how to store things and retrieve them again, and all the other tools this computer system provides. All of this proceeds logically as we move from one task to another.

Each chapter ends with a CHECKLIST covering the main skills learned. You can use it to double-check your own mastery of the chapter’s materials and for later reference. Along with the Macintosh Quick Reference section and the index, this makes this Macintosh guide useful for long-term reference as well.

Part II continues the tutorial approach, adding mastery of the Macintosh’s two most basic applications programs, MacWrite and MacPaint. We will go through each of them, learning their many facilities and preparing you to do serious work on the Macintosh.

Part III features three appendices. Appendix A is an introduction to Apple's Macintosh BASIC and Microsoft's MS-BASIC, for those who are interested in programming. Appendix B provides some technical information about the insides of the Macintosh. Appendix C, the Macintosh Quick Reference, is a handy summary of frequently-used operations and commands.
As of the date of this writing, there are two hardware versions of the Macintosh, varying only in the amount of main memory provided (the original "128K" Macintosh and the "512K" Macintosh, or "Fat Mac"). There are now two versions of the Macintosh system software, and three versions of MacWrite and MacPaint. The first came with the original release of the computer, in January 1984, and the second was provided as a free upgrade to all Macintosh owners in the late spring of 1984. The third versions of MacWrite and MacPaint (the latter applies only to the "512K" Macintosh) were scheduled for release in December 1984. This book covers all versions of the hardware and software, noting changes and differences. Whichever you have will be included in the following chapters.

To the best of my knowledge, every basic facility of the Macintosh, its operating system, MacWrite, and MacPaint is covered in this book, including some that escaped the Macintosh manuals. This is based on about 1,000 hours of using the computer. Nothing is based on hearsay, company handouts, or any other external sources. Everything is described and presented as it works in actuality, not in theory. No effort has been made to gloss over the computer's weaknesses, and it has some; nor to minimize its strengths, which are many. The entire focus of the book is to make your use of the Macintosh system easier and more powerful.

All of the illustrations in this book, except for the photographs, were done on the Macintosh. Moreover, I did them all myself, despite my lack of any particular artistic aptitude. This is a good testimonial to the computer's powers, and suggests what you can expect to be able to do after a very short time.

Acknowledgments

Macintosh—The Definitive User's Guide is not an "official" or "authorized" manual. I do not have any relationship with Apple Computer, Inc. Either of these would undercut the book's independence and, possibly, its thoroughness. It is the result of my own extensive experience with both the Macintosh and Apple's Lisa, from their early pre-release stages of development, where I had the chance to work with them while preparing reviews for a magazine. I have "lived" with a Lisa for over a year, and with a Macintosh for almost as long,
developing the understanding of these computers that can only come from day-to-day practical use.

I have, however, benefited from the cooperation of people at Apple Computer in resolving some needs and questions that emerged in the course of my work. John Rizzo, John Duhring, Joe Shelton, Kevin Jones, and Louise Egan all helped at one time or another, and I would like to thank them for it.

And, as usual when I am writing books, Suzanne, Eden, Yael, and the late Kosena Allswang, put up with the aggravation and madness with unremitting patience and graciousness, and I thank them as well.

JMA
Los Angeles, CA
January, 1985
The Macintosh System

1 The Fundamental Macintosh / 3
2 The Desktop / 25
3 The Finder / 51
4 Managing Documents & Disks / 79
The Fundamental Macintosh

Introduction / 4

The Physical Macintosh / 6
  Video Display / 7
  Auxiliary Storage / 7
  Keyboard / 9
  Mouse / 11
  Imagewriter / 12
  Rear Panel / 13
  System Setup / 14

The Macintosh System / 15
  The Desktop / 15
  Icons / 17
  The Cursor or Pointer / 18
  Windows / 19
  Applications and Documents / 22

Checklist for Chapter 1 / 22
Introduction

The basic things we must learn in order to use any computer system are unusually easy with the Macintosh. We can provide all the essential background in one introductory chapter, and then move on to the exercises that will make you a master of this computer. Our task is greatly eased by the Macintosh's integration of the three key elements that make up any computer system: hardware—the metal, plastic, and, not least, silicon components which are the physical machine; system software—the programs which actually run the computer, whose presence is generally invisible to the user; and applications software—the programs which you will load into the computer for specific purposes, such as word processing or programming.

The Macintosh hardware includes the very powerful Motorola 68000 microprocessor—its "brain" as it were—plus numerous additional integrated circuits and other electronic components for memory, video display, and so on. An understanding of these electronic elements is not at all essential for successful use of any computer; they

Figure 1-1. A basic Macintosh system.
are described in some detail in Appendix B, however, for those interested in learning more about them.

More practically useful is an understanding of those parts of the Macintosh hardware that the user does deal with on a regular basis. This includes the keyboard and mouse for putting information into the Macintosh, the screen and printer for getting it out, and the disk drive(s) for storing it for later use. We shall look at each of these in some detail.

The system software, which gives the Macintosh its particular personality and mode of operation, works for us regardless of the specific task in which we are engaged. It consists of a group of computer programs that call upon one another as necessary. Some of these programs are permanently installed inside the machine, in what is called ROM (read-only memory), and are constantly available. Others are on the diskettes you will use to run programs, and are automatically loaded into the computer when needed.

What really distinguishes the Macintosh is that the hardware and system software were created to match one another much more intimately than is the case with most other computers. The system software provides, for example, the graphic images that you will manipulate on the screen with the mouse, easily accomplishing tasks that on other computers would require a good deal of typing.

Applications software, that is, programs, provides our main tools for using the computer (under the Macintosh system they are usually referred to as "applications"). With this software we can write letters, create drawings, develop spreadsheets, and so forth. Each user will have his or her own main interests here, and choose from the increasing variety of programs available. But all users will benefit from the fact that their programs have been specifically designed for the Macintosh and make extensive use of its hardware and system software. This means that, more than with other computers, you will apply the same physical motions, terminology, and concepts, no matter which applications software you are using. Learning new programs becomes much easier than with other computer systems, and moving information from one to another is readily accomplished.

This chapter will focus on acquainting you with the main characteristics of the hardware and system software of the Macintosh. The hardware description will be strictly practical—how you connect things together, what each part does and how it works, and so on. The system software introduction will be similar. We will learn what
“windows” and “icons” are, for example, and how the Macintosh uses them. The amount of material we require for this introduction is not great, and the Macintosh system lets us learn it quite easily. Once that is done, we can go on to the ensuing chapters which, using an interactive tutorial approach, will take us to mastery of the machine.

The Physical Macintosh

Figure 1-2 is a photo of a rather extensive Macintosh system. The main unit houses the computer itself, the video screen, and the internal disk drive, plus a variety of connectors for other parts of the system. For all users, those additional parts will include the keyboard, mouse, and, most likely, an Imagewriter printer. Some users will also have the numeric keypad, a second, external disk drive, a modem for telecommunications, a carrying case, and, as time goes by, various other peripherals as well. The external appearance of the “128K” and “512K” Macintoshes is identical.
Video Display

The video screen is the Macintosh's most important output device, displaying the results of its labors. It is 9 inches across, measured diagonally, and has a medium high resolution of 175,104 pixels—512 horizontally by 342 vertically. (Pixels are picture elements, or dots, that can be illuminated or not.) It displays images in black and white, plus numerous shades in between. Whereas most current computers display a green or amber on black video image, the Macintosh relies primarily on black and white, to maintain its philosophy of keeping computing as similar to the "real world" as possible.

The Macintosh is also unlike most other computers in that it does not have totally distinct "graphics" and "text" modes for the separate handling of words and pictures. Rather, the two facilities are highly integrated, which explains the versatility of the Macintosh display. Pictures and words, for example, are simultaneously displayed on the screen with ease, and the screen can show things exactly as they will appear on paper—italics, for example, or other unusual type faces. This requires the moving about of a great deal of data (an image of each dot used in each picture must be remembered) and slows the computer down a bit. But the expanded ease of use and simplicity of operation, as well as the materials that can thus be displayed, more than justify the time taken. Figure 1-3 is a printed example.

The only video control available to the user is the brightness control knob. It is below and behind the Apple symbol on the front of the computer. Turn it clockwise or counter-clockwise to establish a brightness level you find agreeable. Do not, however, leave it turned very high if your computer will be sitting unused for some hours—that could ultimately damage the tube.

Auxiliary Storage

Just below the screen on the front of the Macintosh is the internal disk drive. It is a Sony micro-floppy drive, using 3½-inch floppy diskettes housed in a rigid plastic case, as illustrated in Figure 1-4. Each side of a diskette can hold 400,000 characters, or bytes of data, the equivalent of about 250 typewritten, double-spaced pages (generally, the term K is used to denote 1,000 bytes, so these are 400K diskettes). While that sounds like a lot, diskettes can become filled quite quickly; system software and programs take a lot of space, as do graphic images. When double-sided disk drives become available (cur-
You can mix text and graphics almost everywhere on the Macintosh!

Which means that the computer must manipulate vast amounts of data.
This picture is made up of 12,000 characters (bytes)!

Figure 1-3. The Macintosh mixes words and pictures easily, but uses up a lot of memory in the process.
rently, only one side of the disk is used), diskette capacity will be 800K. This will make using the Macintosh a good deal easier, especially for those with a single disk drive. Most users will quickly discover that a second, external drive is a very useful addition to their systems.

Figure 1-4. A micro-floppy diskette.

The micro-floppy diskettes (in this book, we will use the terms disk and diskette interchangeably) are much better protected than their larger 5¼- or 8-inch cousins. The rigid case and sliding shutter door make them relatively impervious to bending or scratching; so long as the spring on the shutter is working, you can carry them in pocket or purse, or mail them, without much danger. Still, the medium itself is quite fragile, and diskettes should be handled with some care, and kept away from heat, liquids, and magnetic fields.

Keyboard

The keyboard, shown in Figure 1-1, attaches by a modular telephone-type connector to the lower front of the main unit. (If you also bought the optional numeric keypad, as seen in Figure 1-5, the keyboard plugs into it, and it plugs into this connector.) It is quite like a typewriter keyboard, with a few additions and minor differences to
take full advantage of the power of the computer. With almost all computers, for example, the Caps Lock key affects only the letter keys—the number keys remain unshifted unless you use the Shift key. As we shall discover in Chapter 2, the action of the keyboard, and the characters it generates, can be easily controlled by the user.

Figure 1-5. The Macintosh numeric keypad.

The Macintosh has three special keys, enlarged in the drawing in Figure 1-6, which you would not find on a typewriter. The Option keys and the Command key, with a symbol looking more like a square four leaf clover than anything else, are function keys. They work rather like Shift or Caps Lock in that, when held down while depressing another key, they change the latter's meaning. They permit the keys to do extra duty, and facilitate much of what you will be doing on the Macintosh. The Enter key is used primarily by some applications programs for data entry; most of the time it works the same as the Return key or is inactive. We will explore each of these in greater detail below.
Mouse

The mouse is central to the entire Macintosh way of doing things. Technically, it is an analog input device, using a small ball in its

Option

Enter

3 Special Macintosh Keys

Figure 1-6. The Macintosh's Option, Command, and Enter keys.

Figure 1-7. The Macintosh mouse.
bottom, whose motion as you move the mouse across your table is transmitted to the computer and interpreted by the software. The mouse button provides an additional form of input—by clicking it once or twice, you can tell the computer to do a variety of things. What on other computers requires carefully typing in words or phrases, can be done on the Macintosh simply by moving the mouse and then clicking its button. The Macintosh mouse makes computing both simpler and, often, faster. The mouse cord connects via a special connector to the back of the Macintosh.

**Imagewriter**

The Imagewriter printer was specifically designed to take advantage of the capacities of the Macintosh, and Apple’s Lisa as well. Most particularly, its graphics capabilities enable it to duplicate anything you see on the computer's screen. (Actually, its resolution is somewhat higher than that of the screen, and so what you print will be a bit sharper than what the screen shows.) Unlike with most computers, where often-complicated control codes have to be sent to the printer in order to specify various special effects, with the Macintosh and Imagewriter it is all done automatically.

The Imagewriter uses *dot-matrix* printing technology, with a group of wires in a matrix of seven horizontal by nine vertical positions. A print hammer hits wires in any of those positions, which in turn hit the ribbon and transfer the image to paper. Consequently, a single, very small dot can be printed anywhere on a page, which explains how the Macintosh/Imagewriter combination can produce such striking print effects.

The Imagewriter feeds paper with either friction or sprocket mechanisms, chosen by flipping the switch on its top left. This means that it can use single sheets, fanfold sprocketed paper, or even paper rolls. The sprocket feed is adjustable, to handle paper widths from 4½ to 10 inches (17 inches with the wider model); thus, mailing labels and other specialized forms can easily be printed. The Imagewriter can move paper both forward and backward as well, permitting superscripts and subscripts, overstriking, and other special effects in your documents. It attaches to the rear of the computer with a special cable. Most important, the Imagewriter is so integrated into the computer system that you can pretty much forget about it. You are free to concentrate on using the Macintosh's programs—whatever you create will be correctly transmitted to the Imagewriter when you tell the Macintosh to print.
Rear Panel

The back of the Macintosh has a number of connectors for necessary and optional parts of the system, as seen in Figure 1-8. In keeping with Macintosh's graphic and international orientation, every item is pictorially represented, by icons, which illustrate its use. On the top right is a small compartment for replacing the battery, which keeps the Macintosh's internal clock running even when the computer is off. Beneath that is the on-off switch, and beneath that the connector for the power cord. And at the left side is a slot for the optional security system—a special cord attaches to this slot and one on the keyboard, and around some secure item like a table leg; it can then be locked to deter thievery.

Figure 1-8. The Macintosh back panel, showing security connector, power receptacle, and five connectors for peripherals.

There are five connectors in a row at the bottom, each distinguished pictorially. (Figure 1-8 illustrates an early production Macintosh—on yours, the placement of the printer and modem connectors will probably be reversed.) From left to right in Figure 1-8, they are for: (1) connecting the mouse; (2) connecting an external second disk drive; (3) connecting a modem for telecommunications; (4) connecting the Imagewriter printer; and (5) connecting additional audio output devices.
The mouse and printer connectors will be of immediate use to virtually all Macintosh owners; the others will probably be employed later, if at all. Note, however, that the modem and printer ports (what are called RS-422 serial ports) are actually very versatile, and can be used for numerous other purposes as well. Apple and other vendors are producing many additional peripherals that can be plugged into these ports, and into one another.

**System Setup**

Most readers will probably have their computers up and running by the time they read this. If you don’t, or haven’t bought a Macintosh yet, we can quickly go over the process; it is extraordinarily simple.

Unpack the components carefully, spreading out all the cords and other parts on an uncluttered workspace. Attach the mouse and printer cables to their designated connectors on the computer, being sure to tighten the knurled knobs for a solid connection and to minimize radio/TV interference. Then you can plug the keyboard cable into the keyboard and into its connector on the front of the Macintosh (unless you have the numeric keypad, in which case the keyboard plugs into it, and it, in turn, plugs into the front of the computer).

Follow the Imagewriter instructions on unpacking the printer, inserting paper and ribbon, and doing a power-on test. Then connect the second end of the printer cable to it. If you have purchased an external disk drive, attach it to the connector between those for the mouse and the Imagewriter. Then plug the Macintosh power cord into the computer and into a grounded outlet. That is really all there is to it.

These are the hardware features that every Macintosh user will be employing from the start. We shall use each extensively, and learn more about them, in the following chapters. You probably also received the Programmer’s Switch with your system; this is a small plastic device that can be inserted in the back left side of the computer, toward the bottom. It permits restarting the Macintosh without turning it off (called a *reset* in the computer world), but is primarily designed for the use of programmers. Most users would do well to forget about it, and follow standard Macintosh procedures in their computing. You can therefore simply put it away.
The Macintosh System

The most notable feature of the Macintosh's system software is its "user interface," a fancy term for the way in which it presents itself to people using it. Through the use of a desktop analogy, readily recognizable objects to manipulate, and so on, the Macintosh makes computing easy with no sacrifice of power. In this chapter, we will cover the basic system software concepts so that you have an elementary sense of what is going on. Then, as with hardware, we will learn more about each of them through extensive practice and examples.

A key to the Macintosh's user interface is the idea of intuitive computing—making the use of the computer correspond as closely as possible to the way in which we work in the real world outside. The Macintosh and Lisa have gone well beyond other computers in achieving this, and you will be surprised at how often things will function just about as you guessed or hoped they would, based on the way you work with pencil and paper. This is not often the case with computers, where everything from conceptualization to vocabulary seems entirely new and often threatening.

The Desktop

The desktop analogy is a good example of this. When you start up your Macintosh, you are greeted with a desktop, usually almost empty, as in the example in Figure 1-9. As you begin to do work, your desktop will get busier; "pieces of paper" and other images will overlap one another. You can move things around on the desktop, put them away and bring them back, write on anything available, and reorganize the stuff that is there. You can put your clock on the desktop, and your wastebasket, plus folders for storing things. Compare Figure 1-9 to 1-10, which illustrates a very busy desktop, with numerous objects partially visible, just as might be the case on your physical desk. Although the Macintosh's desktop has capacities well beyond the most expensive mahogany one, the analogy remains, making the use of your computer easier. So long as you continue to think of it as just that, a desktop, your computing will indeed be intuitive.
Figure 1-9. A nearly-empty desktop.

Don't forget to tell Charlie to watch out for Joe's rambling digressions when you send out the memo on next week's meeting.

Figure 1-10. A busy Macintosh desktop.

Here are my comments on your group meeting next week.

1. Moving Date: Let's wait awhile. Seems premature, since there are so
2. Technical Presentation: I'm concerned.

Frank has a technical presentation. He's been out

development. You can do

3. Party: A party for

The rest of the agenda is fine. As always, in the interest of keeping Joe from straying off the subject, you can reach me if you have questions:
Icons

The Lisa and Macintosh are perhaps most famous for their use of *icons*, that is, pictorial images. Critics sometimes dismiss this as "computing for illiterates," but they are in fact missing the point. Icons actually have several justifications. First, they are easy to understand—nothing represents the ability to file material better than an image of a file folder, after all. Moreover, they save time—you simply point to an icon rather than typing in both a name and an action. And they save space on the screen, as well.

Icons fit in nicely with the desktop analogy, since it is intuitive to move an object on a desktop, and that is precisely what you do with icons. Everything, to the Macintosh—be it a program, a diskette, a letter you write—is an object, represented by an icon, as we see in Figure 1-11. Here, there are icons for a diskette, a pointer, a folder, a program, an individual document, and a trash can. Icons have a great variety of images, depending upon what they represent. The meanings of most of them are immediately obvious; a few may take a bit of experience before they become intuitive.

![Figure 1-11. Macintosh Icons.](image-url)
On the whole, however, the meanings of the icons are sufficiently clear that, even for those things you may use only occasionally, the need to stop and think or to consult reference manuals is greatly minimized. And, the same kinds of icons are used across the spectrum of Macintosh applications—word processing, spreadsheeting, or whatever—so that moving from one task to another is simple because you continue to use the same images and actions.

The Cursor or Pointer

The term cursor is quite standard in the world of computing, denoting the small, usually blinking, box or dash on a video display that shows where the next typed character will appear. This is not really an adequate concept for the Macintosh, however, and we will more often refer to the pointer. Technically, we should use the term “cursor” with the Macintosh only for the vertical bar that appears when we are

![The ARROW. For making selections.](image)

![The I-BEAM. For manipulating text.](image)

![Two PLUS SIGNS, used by various applications for selecting areas to be acted upon.](image)

![The CURSOR or INSERTION POINT, usually flashing. Shows position at which text will be inserted.](image)

![THE WRISTWATCH. Wait, Macintosh is working.](image)

Figure 1-12. Macintosh Pointer shapes.
entering text. The Macintosh pointer is much more versatile than the cursor on other computers. Consequently, it assumes a variety of shapes, reflecting the choices that confront us at a given time, as illustrated in Figure 1-12. Indeed, the shape of the pointer often intuitively suggests what kind of action is appropriate in a given situation.

Most often, the pointer is an arrow-shape, which we move around the screen with the mouse, finally depressing the mouse button to initiate an action. Sometimes, especially when we are typing in text, we have both the I-Beam pointer and the vertical bar, which is indeed a cursor—showing where the next typed character will appear. But the pointer will use several additional images, not least the wrist watch that is the symbol for “wait a minute, Macintosh is working.”

The appearance of the pointer, and its usage, are also consistent across Macintosh applications. With icons and the mouse, we can easily use the pointer to manipulate our work, and rapidly become masters of what is in fact a highly sophisticated system.

**Windows**

Equally central to the operation of the Macintosh is the concept of *windows*. A window, as its name suggests, is a view into something, usually just part of a greater whole. If you are doing some word processing with MacWrite, for example, at any one time you have a window showing part of the letter or report you are creating. You will soon learn how to open and close windows, to make them larger or smaller, to move them around the desktop, and to *scroll* through any window so that the part you want to see is actually on the screen. In Figure 1-10 we got a glimpse of this feature, with several windows on the screen, some of which showed only a part of their contents.

Windows are used for many purposes by the Macintosh. Most icons, such as those for disks and applications, can be “Opened,” creating a window. We open a diskette icon for a window that shows us the contents of that diskette, or open the Trash icon to see what we have thrown away, so that we can reconsider whether we want that stuff permanently junked or not. Figure 1-13 shows the desktop with both the Trash icon and the window that emerges when we open that icon; in this case, four items were sitting in the trash.

There are also a number of special windows, sometimes called “boxes,” which the Macintosh uses to provide us with cautions and information. Figure 1-14 illustrates two of them. The upper one is an
Figure 1-13. The window created by opening up the Trash icon.

Alert box, which warns us of the potentially dangerous consequences of certain choices we may make. This is one of the ways the Macintosh makes computing relatively painless. Beneath it is a Dialog box, which is used by the Macintosh when it needs more information in order to complete a given action. We will see some additional special Macintosh windows as we go along.

As with other aspects of the Macintosh, using the window soon becomes entirely intuitive. In many respects it is similar to paging through a document that is longer than a single page. But it is much easier to scroll through a window than to turn pages; moreover, parts are less likely to be lost, and can easily be moved from one window to another.
Save changes before quitting?

Yes
No  Cancel

An ALERT BOX to warn against a potentially irreversible action.

Save document as:  Book Figs,...

Eject  Save  Cancel  Drive

A DIALOG BOX where the Macintosh asks us for additional information.

Figure 1-14. Helpful Macintosh windows.
Applications and Documents

The Macintosh makes a useful distinction between applications and documents, the first being used to create the second. Applications can also be thought of, more generally, as tools, since the Macintosh manual uses the former term somewhat restrictively. Programs, such as MacWrite and MacPaint, are what are formally referred to as applications by the Macintosh; but facilities such as the Note Pad and Clipboard, which we will learn about in Chapter 2, are essentially similar. The pointer is a tool, whose use will vary from place to place; the keyboard and mouse are physical tools, as is the video screen on which you see the development of your labors. And individual programs, such as MacPaint, have their own special collections of software tools to achieve their specific capabilities.

Documents, on the other hand, are the end result of the process of computing, the reason you bought a computer in the first place. You write a report, or make a drawing, or perhaps write a BASIC program, creating a Macintosh document. Any such document can then be further manipulated, if desired, by other Macintosh applications. Conceptually, this is all quite logical, and makes intuitive sense. The end result of computing, obviously, is the document—the work you want done. Icons, windows, the desktop, and so on, are all there to facilitate this process.

With this introduction behind us, we have enough general understanding of the nature of the Macintosh's hardware and system software to permit us to move ahead. Through extensive practice and examples, the ensuing chapters will clarify what we have seen here. We will begin in Chapter 2.

Checklist for Chapter 1

1. System software consists of the programs that run the computer, some of which are permanently installed within it, others of which are on the diskettes we use to get it going.
2. Applications software consists of the programs that do the practical tasks we want done.
3. Macintosh micro-floppy disks/diskettes hold 400,000 individual characters, or bytes, the equivalent of about 250 pages of double-spaced typewritten text.
4. The Macintosh desktop, like a physical one, is where we organize and do our work. We can move things around on the desktop, put one thing atop
another, and immediately access any of the items sitting there.

5. *Icons* are graphic representations of objects, physical or otherwise. We manipulate the icon in order to either use or act upon the object it represents.

6. The *pointer* is used for making choices of many kinds, as well as for positioning the *cursor*. It takes on a variety of shapes, depending upon where we are and what we are doing at a given time.

7. *Windows* are the way the Macintosh lets us see the contents of things, from physical objects to the end results of our computing. Windows can be opened, closed, moved, and changed in size. When any item is larger than what its window can display, we can *scroll* through it so that the part we want to see appears in the window.

8. *Applications or tools* are the things we use, such as programs, in order to get work done on the Macintosh.

9. *Documents*, such as written reports or drawings, are what we create with Macintosh applications.
The Desktop

Introduction / 26

The Menu Bar / 26

The Apple Menu / 32
   About the Finder / 32
   Alarm Clock / 33
   Calculator / 34
   Key Caps / 37
   Control Panel / 41
   Scrapbook / 45
   Note Pad / 46
   Puzzle / 49

Checklist for Chapter 2 / 49
Introduction

The Macintosh's desktop analogy, along with icons, windows, and the mouse, makes using this computer a pleasure. And now is the time to apply what we discussed in Chapter 1 to make your Macintosh work. In this chapter, we will focus on general tasks and techniques that are applicable no matter what the Macintosh is doing. This will be a "learning while doing" exercise—in the process of learning some of the Macintosh's features, you will also be learning how to use its most basic and important facilities. If your Macintosh is not currently on, put the Write/Paint disk (its label says MACWRITE-MACPAINT) into the drive and turn it on. We will go through the elements that appear on the screen, and start to see how the thing actually works.

Don't be concerned if your screens are not absolutely identical to those in the figures; they may well have additional icons. The Macintosh system software is being regularly upgraded with additional features, not all of which we want to discuss at this point. All of them will be covered as we go along.

The Menu Bar

Your screen should show your desktop with two icons—one of the Write/Paint disk itself and another of the Trash basket. And across the top left of the screen is the menu bar with an apple and four headings, as seen in Figure 2-1. The screen itself represents the desktop—rather neat right now, but we will fill it up presently.

Move the mouse so that the pointer is on the desktop (not on the disk icon), and depress then release the mouse button. Then move the pointer back and forth from the desktop to the disk icon several times, pressing and releasing the mouse button when the pointer is over each of them. Note how the icon inverts with each click, from black (highlighted) to white. (If, by mistake, you click twice in rapid succession, the disk icon will open to reveal a window. For now, if that happens, just click in the little box at the upper left corner of the window and it will close.) Everything we use in the Macintosh will become visibly highlighted in some way when it is selected—ready for some sort of action. In fact, the word active is used as a synonym for selected. We select icons (and some other things, as we shall see) by using the mouse to move the pointer to them and then clicking—depressing and immediately releasing the mouse's button.
Now make sure the Write/Paint icon is selected (black). Move the pointer along the menu bar at the top until it is over the File title, and now depress the mouse button and **hold it down**: this is called *pressing*, as opposed to clicking where we release it immediately. The File menu unfolds. Those choices which are in black are applicable to where you are now; those in gray are not and cannot be chosen. With the mouse button still depressed, move the pointer down to Get Info, so your screen looks like Figure 2-2, and release the button. This is called *dragging* the pointer, that is, moving the mouse while its button is pressed (down). It is used extensively with the Macintosh. You will hear the disk whir a bit, and then the result of your action appears—some information about the Write/Paint disk, as seen in Figure 2-3. Move the pointer to the small square at the top left of the Information about Write/Paint window—it is called the *Close box*—and click once. The window returns to whence it came. You are beginning to learn how to use the system.
Figure 2-2. Desktop with File menu opened by clicking on File title.

Figure 2-3. The Get Info window for the Write/Paint diskette.

Congratulations--
You are learning to use the Macintosh!
Now move the pointer back to the Menu bar, point at the File heading and press once again. You have two more choices—Open and Eject. (Note that to the right of some of the choices is the Command symbol and a letter. Macintosh will let you use the keyboard as well as the mouse for many frequently selected choices: you could have chosen Get Info by holding down the Command key while you typed the letter “I” as well.) The Eject option is an important one—this is how you get Macintosh to spit out the disk currently in the disk drive. You ask and Macintosh delivers, but only after it makes sure that everything on the disk is in order.

With the File menu still open, drag the pointer to Open and release the button. Because the Write/Paint icon was active, this opens a window that shows what is on the disk, as seen in Figure 2-4. There are icons for three applications (MacWrite, MacPaint, and Font Mover—if the last is not there, that is quite okay); a System Folder icon (containing programs the Macintosh needs but which you should ignore); an

![Figure 2-4. The Window that appears when we Open the Write/Paint icon.](image-url)
icon for an empty folder to hold your work; and one or more icons of sample documents created by MacWrite or MacPaint. There is also a line of type that says that this disk contains six items and is currently using 364K (that is, 364,000 bytes or characters) of disk space, with 35K more space available. (The actual number of icons on your Write/Paint disk, and the number of bytes used and available, will vary depending upon when you purchased your Macintosh and whether or not you have used the disk previously.)

Note the various shapes and forms along the right side and bottom of the window. These permit scrolling—moving around in the window to see more information. Figure 2-5 shows the names and functions of the bars and boxes for manipulating windows. Not all of them are available in every type of window. At this stage they won’t do anything because all the information can already be seen. But you will soon be using windows that can reveal, at any one time, only a fraction of their contents, and the scrolling tools will be constantly used to bring whatever information you want into the window.

Now use the mouse to move the pointer to any part of the top bar of the window—except for the little Close box at the left. Depress the button and hold it, dragging the mouse down and to the right, then release the button. You can move any window anywhere you want it on the desktop. Now move the pointer to the extreme lower right of the window, where you see the Size box (one square overlapping another). Press the button and move the mouse down and to either side—windows can be made larger and smaller at will.

Practice moving the window and changing its size a few times, until you are comfortable with the process. Then put it back to about the place and size it originally was—this need not be exact, it really doesn’t matter.

When you were moving the window around and changing its size, you may well have covered the Write/Paint or Trash icons—they were still there even if you could not see them. Just as on a real desktop, one thing can be put over another, and to get to the one below you need only move the first so that the second can again be seen. It can then be made the active window by clicking on it. We will do this many times as we go along.

The menus at the top of the screen will vary according to what you are doing and the program you are currently using. Some of the menus you see now will not appear at some places, but other ones will. And the choices available within each menu will also change—what is
in gray now will be in black (that is, selectable) at other times, and vice versa. This is how the Macintosh makes life easier; it will not let you do things that make no sense to the kind of work you are currently doing. Nor will it let you destroy things easily.

The File menu is used to manipulate the applications and documents you are currently working with. The Edit menu is used primarily for making changes in documents. And the View and Special menus provide utilities for housekeeping chores. Each of these will be dealt with in detail as we go along. For now, you have learned how to open a menu and make choices from it.
The Apple Menu

The Apple menu is somewhat different. First of all, it is always available, no matter what else you may be doing. Second, it provides a number of useful features that you will often employ while using other applications on the Macintosh. So we will go through them in some detail.

About the Finder...

This is simply an informational window, providing a brief description of the Macintosh Finder, which we will consider in detail in Chapter 3. (Under other applications, the information will be about that application rather than the Finder.) Move the pointer to the Apple and press, then drag the pointer to About the Finder... (as demonstrated in Figure 2-6) and release the button—the box of information appears. To close this box, just move the pointer anywhere over it and click once. The other menu choices are more significant, providing a
number of tools and storage devices that help make Macintosh so versatile.

**Alarm Clock**

Move the pointer to the Apple symbol, press the button to open the menu, drag the mouse until *Alarm Clock* is inverted, and release the button. The disk will whir a bit and then the clock appears, showing the time in minutes and seconds. Try moving it around the desktop just as you did the Write/Paint window—but don’t click on the Close box at the left—that will put the Alarm Clock away.

You can put the clock anywhere, for example, keeping it at the bottom of the screen while you are working; if you leave it there when you quit your work, it will be put away for you when you turn the Macintosh off. If you click on the little switch icon at the right, the clock will open up, as seen in Figure 2-7, permitting you to set time,

![Figure 2-7. The Alarm Clock opened, with the alarm selected and set to go off at five p.m.](image-url)
date, and the alarm. The three icons in the bottom boxes control what will appear in the middle bar—and what is in the middle is there to be changed, if desired. Click on the calendar icon. Now the middle bar will show the current date; if you move the pointer over any part of the middle bar, it changes into a plus (+) sign, which means you can change text. Try clicking over the number of the month—it inverts. You can change it if necessary, either by typing a new number or by using the tiny up and down arrows. The same applies to day and year.

If you select the clockface icon at the bottom left, a copy of the current time appears in the middle bar and can be similarly changed. If you select the alarm clock icon on the right, the same choice applies for setting the alarm—plus a tiny button icon at the left that lets you turn the alarm itself either on (up) or off (down). Whenever the Macintosh is on, the alarm will sound once at the preset time if you have set it to go off, and the Apple menu symbol will continue to blink until you open and then close the clock. (So, if you ever turn your Macintosh on and see the Apple blinking, this is because the alarm had been set and has gone off.)

Click the switch icon in the top bar, and the clock returns to its smaller state, showing the time only. If you wanted to put it away, you could either click on the Close box to the left of the time or select Close from the File menu. For now, however, just move the clock down to the lower left-hand corner of the desktop and leave it there.

**Calculator**

Now go back to the Apple menu and select Calculator. After a moment, the calculator will appear on the screen, as seen in Figure 2-8. This, too, is always available, so that when you are using any other program, you can call up the Calculator, do some work with it, and, if you wish, paste the results into the document you are currently working on. Let's try it: Enter "45 \* 72 =" into the calculator. You can either use the mouse button to click the numbers and the symbols on the screen (all computers use the asterisk for multiplication) or use the keyboard—the Macintosh doesn't care. Now go to the Edit menu and select Copy. Then go to the Edit menu again and choose Show Clipboard.

Voila! We have a new window, as seen in Figure 2-9, which can also be opened, closed, moved, and changed in size. Anything we Cut (that is, delete) or Copy via the Edit menu goes to the Clipboard and stays
there until we Cut or Copy something else. And what is on the Clipboard can be moved into any other document we are working on. (We could have copied the time from the Clock in the same way.) This is how the Macintosh permits us to move information from one document to another—it is a very powerful characteristic of the computer.

Right now, you should have both the Clipboard and the Calculator on your desktop, plus the Write/Paint window and the clock, although the last may be covered by the Clipboard. Your desktop is getting busier, and it also shows the Trash icon and the shadow of the Mac-Write/MacPaint disk icon (where the window came from). Move the pointer back and forth among the windows and click on any of them. Notice that the appearance of the title bar of whichever window you have selected highlights to show that it is active—you can have many icons and windows on your desktop, but only one is active at any one time. Icons turn to black when selected, whereas windows indicate selection with a darkening of their title bars. You can only work on the active one, but can readily select another for action whenever you wish.
Let's close the Write/Paint window: make sure it is selected, then move the pointer to the File menu and, pressing the button, drag it until the Close option is highlighted (white on black) and release the button. The Write/Paint window returns to its icon. Note that you can close a window by either clicking on its Close box or by selecting Close from the File menu.

Now select the Clipboard and move it (remember, you grab it by placing the pointer on the title bar and then pressing the mouse button) so that it covers part but not all of the Calculator, just as if you put a sheet of paper on your desk on top of a physical calculator. Then move the pointer to any part of the Calculator and click—\textit{whatever is selected will come to the front, and overlap other documents or icons on the desktop}, as we see in Figure 2-10. Even if some icon is completely covered, it is still there—and can be seen if you move or shrink or Close whatever is covering it. (If you want to move something without Selecting it, hold down the Command key when you press and drag on its title bar.)
Try using the Calculator for a while—it is quite standard in operation (the E is for exponential notation, something computers use for very large numbers). When finished, go to the File menu and select Close All. This puts the Clock, Calculator, and Clipboard back where they came from, on the MacWrite/MacPaint disk. You can always Close just the thing you are currently working on by using its Close box or selecting Close from the File menu. And you can close everything that is open on the desktop by selecting Close All.

**Key Caps**

Now go to the Apple menu and select Key Caps, which will give you a window showing the Macintosh keyboard with a small rectangular screen at its top, as we see in Figure 2-11. This window can also be moved around, but its size is not adjustable. It is used as a reminder of just what the keyboard can do for us. When it first appears, we see what each key will type—hit a few keys and what you have typed
appears in the small screen, moving the vertical cursor bar to the right with each character typed. Now hold down the Shift key and watch how the display on each key changes. Then try it with the Caps Lock key—this key does not shift the numeric keys, which makes sense for most computer applications. And try it again with the Option key held down and then Option and Shift together—these show the alternate characters that the Macintosh keyboard can generate and send to its printer, for foreign language and other specialized applications. Square boxes appear to indicate a keystroke without any function—unless you want to type square boxes.

![Figure 2-11. Key Caps with some writing on its screen.](image)

Any key currently being represented can be typed. For example, hold down the Option key and type a "w"—the sigma for "sum" appears on the little screen. By the way, as you might expect by now, the letters can be typed either by hitting the appropriate keys or by clicking on the screen image of the key you want.

Now type in a number of letters or numbers so that there is some text in the small Key Caps screen. Then use the mouse to move the pointer until it is also in that screen, in the middle of what you have typed. Note how its shape changes from an arrow to an I-beam, denoting text insertion. Move it between any two characters and click the mouse button—the flashing line that is your actual cursor or *insertion point* is now where you have clicked. Type a letter or two—it will go in at the point you have selected, pushing the rest of the text to the right. Try the Backspace key as well, to erase from the point of the cursor backwards. Now move the "I" to the left of the very first letter.
Press the mouse button down and drag the mouse a few characters to the right—your text highlights, meaning that it has been selected. Type in three or four characters: they replace the selected ones, as in Figure 2-12.

![Figure 2-12. Key Caps showing new text inserted.](image)

Now move the “I” pointer to the left of the first character on the screen; press the button and drag all the way across. Everything you have typed is now selected. Move the pointer up to the Edit menu, open it, and select Cut (Command-X does the same thing from the keyboard). Your selected text has been deleted. But it is not yet gone entirely—go back to the Edit menu and select Show Clipboard. Your most recent Cut replaces what had previously been Cut to there from the Calculator, as in Figure 2-13.

Reactivate Key Caps by clicking on it; note that the flashing cursor is at the left edge of the Key Caps screen. Now go to the Edit menu and select Paste (Command-V from the keyboard), and whatever is on the Clipboard is inserted back into your “document”—in this case, the Key Caps screen. (With actual applications programs you can also select Undo from the Edit menu to reverse your most recent action; this does not work with Key Caps, however.) Close the Clipboard and try it again—just select all the text in the screen by moving the cursor across it, then select Cut from the Edit menu and it disappears. Select Paste and it is back again. There is no need to actually open the Clipboard. This will work everywhere in the Macintosh.

Finally, select all the text in the screen again, then hit the Backspace key. This also deletes whatever you have selected, but in this case it is
gone forever. Unlike Cut, material removed with Backspace does not go to the Clipboard. Often, however, this is faster and more efficient for permanently getting rid of errors—or deleting stuff without affecting what is on the Clipboard. You can also select Clear from the Edit menu; it has the same effect as the Backspace key. With most applications, unlike Key Caps, you can use Undo to reverse deletion made by the Backspace key.

Key Caps is handy for reminding ourselves of all the characters which can be typed, particularly since it can be checked while we are using any application. It illustrates the many foreign and other special characters that are constantly available with the use of the Option key. Several of these are "dead keys" that do not move the cursor ahead, so that we can easily type characters like "à" and "é". Compare the difference between hitting the "'" key and then the "Option '" combination—in the latter case, the typed character is not put on the screen until we type another character to go with it.

While investigating Key Caps, we have also learned more about the Edit menu choices, text manipulation, and how the form of the cursor...
changes, depending on what we are doing. Moreover, what applies in working with the Clock, or with Key Caps, is essentially the same when you are doing word processing, calculations, or whatever. This is why the Macintosh is so easy to use—mouse actions, menu selections, text manipulation, and so on are identical no matter what you are doing.

Control Panel

Now put everything away (Close All) so that all you have on the desktop are the MacWrite/MacPaint and Trash icons. You now know enough Macintosh basics to learn how to fine-tune the Macintosh to your liking with the Control Panel. Go to the Apple menu and select Control Panel. There are lots of things we can adjust to make computing more personal and agreeable. Figure 2-14 illustrates the Control Panel as you should see it on your desktop, and Figure 2-15 is an exploded version for easier labeling (created, by the way, with MacPaint).

Figure 2-14. The Control Panel from the Apple menu.

First, we see the clock once again; the time and date, but not the alarm, can be changed here as well as from the Alarm Clock itself. As before, when we move the cursor over part of the time or date, it becomes a "+." We can select any number, then either type in what we want or use the arrows that suddenly appear. Selecting date or time freezes the clock; select something else or hit the Return key to get it going again.
To the left of the clock is an analog gauge permitting the selection of speaker volume, from silent operation through very loud indeed. Simply move the pointer to the white bar and drag it; wherever you stop, Macintosh will beep, showing you what the volume level will be.

To the right of the clock, a bit less obvious, is your means of choosing the blinking rate for items selected from menus. When you make a menu selection, that action can be implemented immediately or there can be a brief pause while the name of your selection blinks at you.
Click 0, 1, 2, or 3 to control the number of blinks, which means the speed at which the selection is implemented. To see its effect, just go to the Edit menu and select Undo (it won’t actually undo anything here) and watch what happens to the word Undo with each rate.

Beneath the blinking rate box is one that controls the blinking rate of the cursor under any application. As you choose 1, 2, or 3, the blinking rate of the cursor above shows you how rapidly it will flash in practice.

In the middle are two controls related to the auto-repeat action of the keyboard; all typing keys are capable of automatically repeating when held down. The lower one—with the finger symbols—controls how long you must keep a key depressed before it begins to auto-repeat. It varies from a very brief delay (4) to no repeat action at all (0). If you find keys unintentionally auto-repeating, select a lower number. The upper control, with tortoise and hare, sets the actual speed of keyboard repeating. The higher the number, the more rapid the repeat action will be. The nature of your typing skills will determine what works best for you. Since the Control Panel can be called up at any time, you may find it easiest to adjust keyboard characteristics when you start using MacWrite for word processing.

There are also two controls for mouse movement. The one on the left affects how far the pointer moves on the screen relative to mouse movement on your tabletop. At setting 1, the pointer will move further when you speed up mouse movement on your table; at setting 0, the pointer moves the same distance regardless of mouse speed. The second mouse control relates to double-clicking; we will be learning that one Macintosh shortcut is to click the mouse button twice, rather than clicking once to select and then going up to a menu to choose an action for that selection. This control determines how long the Macintosh will wait between clicks and still assume you are double-clicking. Newcomers may prefer the longest delay (where the arrows are further apart); after you get used to the Macintosh, you may want things to go faster.

Finally, in the lower middle of the Control Panel, you have the means to create a different pattern for your desktop. In the two boxes are, on the left, a magnified dot or bit image of a pattern (comparable to what is called FatBits, which we will encounter when discussing MacPaint), and, on the right, the way that pattern will look as our desktop. There are numerous preset patterns, which can be viewed by clicking on the white bar above the right-hand box. As you click at either the left or right side of that little bar, the available patterns fill
the box below and their magnified image appears in the box to the left. If you want any of these patterns for your desktop, move the cursor into the right-hand box itself and click the mouse button—you whole desktop will take on that pattern.

You can even customize your desktop with a pattern of your own design, by manipulating the dots in the box on the left. Click on a white area and drag the mouse—the white dots you cover turn to black; click on a black dot, and the black ones you drag over turn white. Its effects are immediately seen in the changing pattern of the box on the right. Again, click in the middle of that box and your actual desktop pattern will correspond. Play around with it and you will see the possibilities. It is not a terribly meaningful facility, perhaps, but does suggest how the Macintosh tries to make computing correspond to your own preferences. In Figure 2-16, we have created an “A for Apple” pattern for our desktop.

Whatever choices you make with the Control Panel will be stored on the current diskette, and will come up automatically the next time

![Figure 2-16. Control Panel showing a customized desktop pattern.](image-url)
you turn your Macintosh on, if you are using that diskette. By setting the Control Panel differently with different disks, you can, if you wish, have one customized setup for one application and a different one for another. Once you have all the choices as you want them for the moment, click the Control Panel's Close box to put it away.

**Scrapbook**

Now select *Scrapbook* from the Apple menu. The Scrapbook can be thought of as a more permanent version of the Clipboard. Remember that anything we Cut or Copy automatically goes to the Clipboard, from where it can be pasted into another document, if desired. The Clipboard can hold a lot, even several pages of text, but it holds only one thing at a time—as soon as we do another Cut or Copy, that material replaces what is currently on the Clipboard.

The Scrapbook, on the other hand, is for longer-term storage, particularly of things we use often—a letterhead, perhaps, or a company logo. Anything we create with MacPaint or MacWrite or some other Macintosh application can be Cut or Copied to the Clipboard and then Pasted into a screen of the Scrapbook. From there it can be copied back onto the Clipboard and then into whichever document we are currently working on. Note that the Scrapbook window, like that for the Calculator, can be moved around the desktop but its size cannot be changed.

When you start out, the Scrapbook has five screens, the first of which has some information on it; the other four have sample pictures, which you can get rid of whenever you want. The left and right scroll arrows at the bottom of the Scrapbook let you scroll from one picture to another (there are no up and down arrows because the full height of the Scrapbook's window is already there). And between the scroll arrows we make our first use of the *scroll bar* and *scroll box*, as illustrated above in Figure 2-5. Put the pointer anywhere in the gray scroll bar and click—the scroll box jumps in that direction and you have scrolled to the next window, as seen in Figure 2-17. Alternatively, you can drag the scroll box itself to any position on the bar you desire. When you begin to work with larger documents, the scroll bar and scroll box will permit rapid movement through them, both horizontally and vertically, as applicable.

The Scrapbook numbers its screens, and always tells you just where you are ("1 of 6," "2 of 5," and so on). It also tells you whether the screen's contents are text or a picture. The Scrapbook does not always
Figure 2-17. Screen 2 of the Scrapbook, showing the Scroll box moved along the Scroll bar.

seem to be storing documents exactly as they were created—text, for example, will be small and not show actual type fonts used in its creation. But Scrapbook remembers, and when you transfer its contents back to an actual document, it will look exactly as it did when you created it. Any one Scrapbook screen can be deleted by simply selecting Cut from the Edit menu when that screen is showing. To add something to the Scrapbook, just Paste it wherever you want—whatever is there will be automatically pushed to the next page. There is no limit to the number of pages you can have. Now you can put the Scrapbook away—click on its Close box or choose Close from the File menu.

Note Pad

Open the Apple menu and select Note Pad; your pad of notepaper appears on the screen. In some ways, the Note Pad is comparable to the Scrapbook and Clipboard, in that text from other documents/programs can be Cut or Copied and stored there, and will
remain as long as you wish. It works only for text, however; pictures will not transfer to it. Moreover, unlike the Scrapbook, it has a finite number of pages, only eight. But text can be directly typed into the Note Pad, whereas in the Scrapbook and Clipboard information has to be transferred from the application that created it.

The Note Pad is useful for keeping notes to yourself—a “things to do” file, as in Figure 2-18, that will not get lost on the desk or inadvertently thrown out. If you become a Macintosh adventure game fanatic, the Note Pad is a good place for entering things you want to keep track of. You can move easily from page to page. At the lower left-hand corner of any page, click on the turned-up corner to page forward or on the flat corner beneath it to page back.

![Figure 2-18. The Note Pad with some text entered on page 3.](image)

Right now, turn to page two of your Note Pad, which should be empty. Type in a few lines of text. Watch how the Note Pad, like a word processor, does word-wrap—if a word is too long for its line, it is automatically moved to the next. You do not have to use the Return key. Now move the pointer to some point in the middle of what you have typed—it should turn into the I-beam shape when you are prop-
erly situated. Press the mouse button and drag down and to the right until some of your text is highlighted; then release the button. Now choose Cut from the Edit menu (or Command-X from the keyboard) to delete the selected text. Then go back to the Edit menu and choose Undo (or Command-Z from the keyboard), as in Figure 2-19, for your first try at changing your mind. Undo is extremely valuable, and even works for text deleted with the Backspace key. You can even Undo an Undo, and the Undo of an Undo, and so on, in case you have difficulty making up your mind. Now move the pointer to a clear part of the page and click the button once—the text is deselected.

Figure 2-19. Cutting and then Undoing a Cut in the Note Pad.

This is a good place to practice a bit of text manipulation. Try inserting a letter or two in the middle of a word—just move the pointer to where you want the new text to start, click, and then type. Next, try to select just one word or a single character by moving the cursor next to it, pressing, and dragging left or right over what you want selected. Note that selected text can not only be Cut or Copied, it can also be replaced by just typing—anything you type in, regardless of length, will replace what is highlighted. This ability, too, is always
available in all Macintosh applications, and makes editing text of any kind very simple. After you have experimented a bit, close the Note Pad.

**Puzzle**

Finally, the Apple menu provides an electronic equivalent of an old tiles-in-a-box game, to resort to when serious computing becomes tedious. Select **Puzzle** and click to move the tiles around the box until you have them lined up in correct numeric sequence, across in rows from top to bottom, with the empty space in the bottom-right corner. When you get it right, the Macintosh will let you know.

In this chapter, we have dealt with two very important things. First, we have gone over the Apple menu, and learned what its options provide for us. Second, and more important, we have learned a lot about the desktop, windows, and the pointer, and have used most of the basic Macintosh techniques for creating, editing, and manipulating information. We are now ready for the Finder.

**Checklist for Chapter 2**

1. The *mouse* moves the pointer, and *clicking* the mouse button initiates an action.
2. When we click on an icon, it is *selected* or *active*—prepared for some further action. Clicking elsewhere deselects.
3. When we depress the mouse button and hold it down, this is called *pressing*, as opposed to clicking, where we release it immediately.
4. We *drag* the mouse by moving it to a chosen place, depressing its button and continuing to hold it down while moving the mouse. This is used to make a choice from a menu or to select a range of text.
5. The pointer has a variety of shapes (arrow, I, +, etc.) depending upon where it is and what actions are available.
6. We open a *menu* by pressing on its title in the menu bar, then dragging the pointer down to our selection and releasing the button.
7. *Windows* can be moved, and *made* larger or smaller, and we can *scroll* through their contents by clicking on their arrows or by clicking in the *scroll bar* or dragging the *scroll box*.
8. Many windows and icons can be on the desktop, but only one is selected at any time. We select one by clicking on it; its appearance will change slightly (*highlight*), and it will move to the foreground.
9. We close a window by selecting Close from the File menu or clicking in its Close box. If more than one window is open, selecting Close All will close all of them automatically.

10. An insertion point within a body of text is set by moving the pointer to a chosen location and clicking. We can then type in new text, or drag the mouse to highlight any text for further action.

11. Selected text can be replaced by typing or pasting in new text. It can be deleted by choosing Cut from the Edit menu (Command-X from the keyboard) or with the Backspace key.

12. Selected text can be copied by choosing Copy from the Edit menu or Command-C from the keyboard.

13. Text that has been Cut or Copied goes to the Clipboard, from which it can be Pasted elsewhere (by selecting Paste from the Edit menu or Command-V). Text cut with the Backspace key or with Clear from the Edit menu does not go to the Clipboard.

14. The Undo selection from the Edit menu (or Command-Z) lets us reverse our most recent action.

15. All of the tools on the Apple menu are constantly available, and can be used whenever the Macintosh is on.
The Finder

Introduction / 52
Disk Displays / 52
Copying and Moving / 55
  Copying a Whole Disk / 55
  Copying Files / 60
  Duplicating / 62
Storing / 64
  Folders / 64
  Directories / 69
  Trash / 71
  File and Disk Locking / 71
  Closing and Putting Away / 73
  Ejecting / 74
Other Finder Services / 75
Checklist for Chapter 3 / 77
Introduction

If you open the System Folder on either your System or Write/Paint diskette, you will find several miniature Macintosh icons. Two of them—System and Finder—make up most of what on other computers would be called the operating system. They are important parts of the system software we discussed in Chapter 1, and, for your own use, the Finder is the most significant. The Finder does all kinds of crucial housekeeping chores that keep the Macintosh operating efficiently—copying disks and parts of them, saving and storing documents, getting back stuff you have previously stored, and so forth.

In this chapter, we will go over most of the things the Finder does (reserving a few advanced ones for Chapter 4), learning how to use them, and at the same time learning a few more standard Macintosh procedures. The Finder is actually an application or program, although you cannot open it directly. You should consider it as such, however, in order to understand its operation, as we shall see. It is automatically opened and run when the Macintosh is turned on, unless you have specified that another application should replace it; this will be covered in Chapter 4.

Disk Displays

If your Macintosh is not on, put in the Write/Paint disk and turn it on. You should see the Write/Paint disk icon and the Trash icon on your desktop. Make sure the Write/Paint icon is not selected; that is, if it is black, click on a blank part of the desktop, so that it becomes white. Now move the pointer to the Write/Paint icon and click twice in rapid succession—if you have done it correctly, the icon will open and the Write/Paint window appears. (If you didn’t click quickly enough, you may have just selected and then deselected the icon—try again.)

This is double-clicking, a much-used shortcut with the Macintosh. Rather than clicking once on an icon to select it, and then moving up to the File menu to select Open, you can simply double-click on any icon to select and open it simultaneously. We will encounter additional uses for double-clicking as we go along. (Some of the emerging applications for the Macintosh also employ triple-clicking, but it is not used by anything we are dealing with in this book.)

You should now have the Write/Paint window in front of you, with icons for the MacWrite, MacPaint, and Font Mover programs, the
System Folder and Empty Folder, and one or more sample documents. There may be others, as well, or the Font Mover may not be there, depending on when you purchased your Macintosh. Now move the pointer to the View heading and press to open the menu. Your screen should look like Figure 3-1. The Finder offers us a variety of ways in which to display the contents of any disk or folder window. Note the check in front of by Icon—the default format in which the Macintosh normally displays the contents of any disk or folder. But it also offers the option to display those contents alphabetically by Name, chronologically by Date, by Size of each item (largest first), or by Kind (such as document or folder).

![Figure 3-1. The Write/Paint disk window with the View menu open.](image)

Try each of these options to see what the display looks like. Note that, while the by Icon option has a bar at the top telling us the total space used and available on the disk, the other options do not offer this. Each of them, however, does give us more precise information—the size of each individual item and the date of its most recent modification. Examples of each of these windows are given in Figure 3-2. Size is often important when we want to transfer a document from one disk to another—the by Icon display will tell us how much
space is available on the destination disk, and any of the other displays tells how big the document we want to transfer is.

**VIEWING THE CONTENTS OF A DISK**

By **SIZE**, largest first:

<table>
<thead>
<tr>
<th>Size</th>
<th>Name</th>
<th>Kind</th>
</tr>
</thead>
<tbody>
<tr>
<td>22K</td>
<td>CAP</td>
<td>folder</td>
</tr>
<tr>
<td>12K</td>
<td>YAEL</td>
<td>folder</td>
</tr>
<tr>
<td>11K</td>
<td>ch2-drawing</td>
<td>MacPaint document</td>
</tr>
<tr>
<td>6K</td>
<td>macfonts</td>
<td>document</td>
</tr>
<tr>
<td>3K</td>
<td>grandma</td>
<td>MacWrite document</td>
</tr>
<tr>
<td>0K</td>
<td>Empty folder</td>
<td>folder</td>
</tr>
</tbody>
</table>

By **NAME**, Alphabetically:

<table>
<thead>
<tr>
<th>Size</th>
<th>Name</th>
<th>Kind</th>
</tr>
</thead>
<tbody>
<tr>
<td>22K</td>
<td>CAP</td>
<td>folder</td>
</tr>
<tr>
<td>12K</td>
<td>YAEL</td>
<td>folder</td>
</tr>
<tr>
<td>0K</td>
<td>Empty folder</td>
<td>folder</td>
</tr>
<tr>
<td>11K</td>
<td>ch2-drawing</td>
<td>MacPaint document</td>
</tr>
<tr>
<td>6K</td>
<td>macfonts</td>
<td>document</td>
</tr>
<tr>
<td>3K</td>
<td>grandma</td>
<td>MacWrite document</td>
</tr>
</tbody>
</table>

By **DATE**, most recent first:

<table>
<thead>
<tr>
<th>Size</th>
<th>Name</th>
<th>Kind</th>
</tr>
</thead>
<tbody>
<tr>
<td>12K</td>
<td>YAEL</td>
<td>document</td>
</tr>
<tr>
<td>3K</td>
<td>grandma</td>
<td>folder</td>
</tr>
<tr>
<td>22K</td>
<td>CAP</td>
<td>folder</td>
</tr>
<tr>
<td>11K</td>
<td>ch2-drawing</td>
<td>MacPaint document</td>
</tr>
<tr>
<td>6K</td>
<td>macfonts</td>
<td>document</td>
</tr>
<tr>
<td>0K</td>
<td>Empty folder</td>
<td>folder</td>
</tr>
</tbody>
</table>

By **ICON**:

By **KIND**, within kinds by size:

Figure 3-2. The Finder offers us five different ways to View the contents of a diskette.
Any one display may be preferable at one time or another, so the Finder permits us to use whichever we want. If a disk has many documents, display by means other than Icon takes up less space on the screen, so that we can see more information in a single window without having to scroll. And the way we leave the display when we close the window is the way it will be when we next open it.

Make sure that you have the display by Icon, and we will look further into the Finder.

Copying and Moving

One of the Finder's main tasks is to copy things for us, whether it be an entire disk, a tool of some sort, or just a single document. Every important diskette should be backed up—that is one of the first principles of computing. Moreover, the storage capacity of diskettes is easily exceeded, so you will often need to move your documents from the diskette with an application on it to another diskette for storage. Copying with a single-drive system is somewhat laborious (less so with a 512K Macintosh than a 128K one), and can be a little confusing. But the Finder keeps track of things for us to help avoid errors. We will look at copying for both single- and two-drive systems, and for earlier and later versions of the Finder as well. We will also cover the differences between copying an entire disk and copying only parts of a disk, and between copying onto the same disk or to a different one. The procedures remain quite consistent.

Copying a Whole Disk

To try disk copying, we will need a second disk. If you have a single disk drive, click on the Write/Paint window's Close box, and then choose Eject from the File menu (Command-E from the keyboard). The Finder ejects the disk but keeps a shadow of its icon on the desktop; it remembers what is on the disk and is ready to refer back to it, or to tell us to reinsert it, when necessary.

Now insert a blank disk in the drive, or, with a two-drive system, put the blank disk in the external drive. The Finder presents a Dialog box saying the disk is unreadable and asking whether you want it initialized. Diskettes require initializing (also often called formatting) before they can be used. This is a process of electronically marking them into the divisions the computer uses for storing data. Click on
Initialize, and give the Finder a few moments to prepare the disk. An information box tells us that the process is underway, and when done it takes on the appearance of Figure 3-3. The Finder wants us to give each diskette a name so that it can be manipulated without confusion. Since this will be our main backup disk (permitting us to store the Write/Paint disk in a safe place), let’s name it W/P Copy. Type that in. Use the Backspace key if you make an error, or use the mouse to edit text just like you did in Chapter 2. Then click OK, and the Finder puts a second diskette icon on our desktop (this looks the same whether your system has one drive or two), which should look like Figure 3-4. Note that the Write/Paint icon is still in shadow form on single disk systems, since that diskette is not currently in the drive. (The Get Info window for any disk icon will tell you whether it is “in internal drive,” “in external drive,” or “not in any drive.”)

![Image](https://example.com/image.png)

Figure 3-3. A Dialog box after diskette initialization, asking us to name the newly formatted diskette.

Now, what we want to do is copy the whole Write/Paint disk. (If you have the newer version of Macintosh software, with the Disk Copy application, read on to page 58 first, since you have a faster way to do this. It never hurts, however, to learn all possible ways to do things.) Press on the Write/Paint icon to select it, and drag it over the W/P icon, until the latter highlights; then release the mouse button. The Macintosh provides us with a Dialog box, as in Figure 3-5 (if you have a dual-drive system, with W/P Copy in the external drive, references to “not in any drive” are replaced by “external drive”) to give us a chance to back out if we wish. But we do want to replace the contents of W/P Copy with the contents of Write/Paint, and so we click OK.

The Finder now provides step-by-step instructions for disk switching for single-drive systems, while it copies as much as memory allows in each pair of disk swaps. It also gives us some indication of its progress, as seen in Figure 3-6. With the earlier version of the Finder
Figure 3-4. The desktop with two disk icons.

Figure 3-5. The Finder provides a Dialog box when we do a total disk copy.

and a 128K system, you will have ten to twelve swaps—this is something that sells a lot of second disk drives and 512K upgrades to Macintosh users! On dual-drive systems, of course, there will be no swapping instructions; the Finder just copies from one drive to the other (the Finder doesn’t care which has the original diskette and which the copy). Eventually, it finishes and you have copied an entire disk.
Now is a good time to put your original Write/Paint disk away in a safe place. Select whichever diskette is in the drive, then choose Eject and turn the Macintosh off. Wait a moment, put the W/P Copy disk in the drive, and turn the Macintosh back on. If you wish, you can rename it anything you like, including Write/Paint—just avoid having two diskettes with the same name in the Macintosh at any one time, because the Finder can be confused by this. If you ever do this accidentally, just rename the last disk you inserted before you do anything else.

Most Macintosh owners should have the upgraded version of the system software, released in the late spring of 1984. (If you do not, you should go to your Apple dealer and request it; the upgrade is free.) The upgraded software has several changes and additions, one of which is of interest here—the Disk Copy application, whose icon can be seen in Figure 3-7 (this is from a disk other than the one we have been using for examples so far). If you do have this program, which is for single-drive systems and for whole disk transfers only, you should use it, because it is much faster than the procedure outlined above, particularly for 128K systems.

With Disk Copy, you can copy any one disk to any other disk; neither need have been inserted previously. Also, Disk Copy will automatically initialize a new diskette, so you will not have to go through initialization beforehand. You simply open the Disk Copy icon, which produces a window similar to that illustrated in Figure 3-8. If you click OK,
Disk Copy prompts you on inserting the original and copy diskettes, with only four swaps needed to get the job done. You have the option of canceling and quitting at any time. As the text in Figure 3-8 notes, Disk Copy works by taking over some of the display memory, so you will get some odd stuff on the screen during copying; this is quite normal.

![Figure 3-7. A disk window showing the Disk Copy icon.](image)

**About Disk Copy**

With Disk Copy you can copy entire disks quickly using a one-drive system.

Messages at the bottom of the screen will ask you to insert alternately the disk you want to copy and the destination disk. Any uninitialized destination disk will be initialized automatically.

To minimize the number of disk swaps needed, Disk Copy uses the space in memory that's allocated to the screen display; therefore, unusual patterns will appear on the screen during the copying process.

![Figure 3-8. The Disk Copy information screen.](image)
Copying Files

While we will occasionally want to copy an entire disk, far more often we need to copy just one or a few documents, or perhaps an application. The term *file* is universal in computing, referring to anything stored on a disk—a program, a document, or whatever. First, let’s initialize another disk to use for file transfers: eject W/P Copy and put in a new disk (with two-drive systems, put the new disk in the external drive). Follow the Finder’s instructions for initialization, and then name it DATA #1—it will be a disk for storing documents created by applications on other disks. Since we won’t have any of the system files on it, there will be lots of room for storage.

Make sure DATA #1 is in the drive—if not, eject W/P Copy and then put it in. Now open W/P Copy; note, on single-drive systems, that you can do so, and see its contents window even though it is not in the disk drive. Select the Sample Memo icon by clicking on it, then drag it to the DATA #1 icon; the Finder will tell you to insert the W/P Copy diskette, so it can read in the file, and present a window like Figure 3-9.

![Figure 3-9. Copying a single file from one diskette to another.](image-url)
Again, depending upon the size of the file being transferred, this can take one or several disk swaps.

If you have a number of files to move from one disk to another, you can provide all the instructions at one time by selecting them all together. This is a technique that you will use for other purposes in the Macintosh as well. Make sure the icons on the W/P Copy window are so set up that MacWrite is just above System Folder, as in Figure 3-10, with the pointer slightly above and to the left of the MacWrite icon. Press, then drag the pointer down and to the right, so that the box of dotted lines you are creating includes both icons; release the mouse button and both are selected, as in Figure 3-11. If you don't get them both, just release the button and click on any blank area of the window, which will deselect everything; then start over. Now, if you wanted to copy them, you would press and drag either one; both images would be dragged to the icon of the diskette you wanted to copy to. This would be a practical way to create a separate MacWrite diskette, with more room for documents.

There is another way to select multiple icons, which is even easier, especially when the items to be selected are not adjacent. This is by shift-clicking. Make sure all icons in the W/P Copy window are deselected (just click on an empty area of the window). Now, while you hold down the Shift key, move the mouse and click on MacWrite, MacPaint, and System Folder—all three are selected. As with drawing

![Figure 3-10. Setup of W/P Copy window for double selection exercise.](image-url)
Figure 3-11. This is how the window should look after you have made the selection by drawing a box around the two icons.

a selection box, this technique is also used within all Macintosh applications. Here, we see their use for copying files from one disk to another; obviously, the techniques are equally time-saving when we want, for example, to trash a number of objects. Now click away from the icons to deselect them.

The Select All choice from the Edit menu (Command-A from the keyboard) is also used for multiple selections. If only one window is open, whether active or not, this choice selects all its icons. If more than one window is open, it selects all the icons in the active one. And if no window is open, it selects all icons on the desktop; this is useful, for example, to select both disk icons in a dual-drive system, so they can be ejected with one Eject.

Note that there is no way with the Macintosh to simply move a file from one disk to another; the process always involves copying, with the original application or document or folder remaining where it was. This is for our own safety, but does require an additional step if you don’t want the original—you have to drag it to the Trash after you have completed the Copy.

**Duplicating**

So far, we have dealt only with copying from one diskette to another. Sometimes, we want to make a copy of something and keep it on the
same diskette the original is on. For this, we use Duplicate from the File menu (Command-D from the keyboard). Select Sample Memo, then choose Duplicate; the result is as we see in Figure 3-12—a copy is made and automatically named “Copy of” . . . whatever we have copied. It is also automatically selected, so that we can immediately type in a new name for it.

![Figure 3-12. Making a copy of an item to the same diskette.](image)

There are various reasons why we might want copies of some documents on the same disk. This is one of the ways (we will see another later) in which we can maintain the original copy of something, while modifying it under a different name. It is also useful for things like creating a letterhead—you can use MacWrite to create any number of different letterheads, with the heading, margins, and other features you want, and then keep the master copies on the disk. Every time you want to write a letter, you need only duplicate the appropriate document, rename the copy, and open it as a MacWrite document. You have a piece of preprinted stationery ready to go. Sometimes, also, we make a copy of some document because we want to leave it out on the desktop, perhaps for later copying elsewhere or as a reminder of its need for more work. You can eject the diskette and even turn off the computer; when you turn it back on, the copy will be in the same place on the desktop where you left it, as we see in Figure 3-13.

This would be a good time to practice your disk copying skills by creating a couple more work disks, one with MacWrite and the System
Figure 3-13. An item left out on the desktop will still be there the next time we turn on the Macintosh.

Folder, and the other with MacPaint and the System Folder. You might call the first WRITING and the second DRAWING. Each will leave you with more elbow room for creating documents on a single drive system. (In the next chapter, we will look at this topic, and the Font Mover, in detail, to see how even more room can be made.) As you do some work, try moving completed documents to the DATA #1 diskette; it is generally a good idea to store documents on such a diskette, freeing up room on your work disks. Even more, you should have backup copies of anything of value. It can be disastrous if you let the minor aggravation of disk swapping with a single-drive system discourage you from proper backing-up procedures.

Storing

Folders

The Finder also helps us to store information simply and logically. As in most physical office systems, the Finder uses folders—we can
put documents, and other things as well, inside folders. And we can even store folders inside of other folders, permitting a very powerful and sophisticated system of what, on other computers, would be called "hierarchical file handling." You can readily organize all your information, within folders, in a scheme that emulates the real-life method of storage of file cabinet to file drawer to individual folder.

Let's try it. Turn off your Macintosh, insert your W/P Copy disk, and turn it back on. Double-click on its icon to open its window and then select Empty Folder. Type Command-D for Duplicate. Type Command-D again, then once again. You now have Copy of Empty Folder, Copy of Copy of Empty Folder, and Copy of Copy of Copy of Empty Folder, as illustrated in Figure 3-14. This could go on forever! Maybe that's one too many—make sure that Copy of Copy of Copy of Empty Folder is selected, and drag it to the Trash icon. Now we're rid of that.

![Figure 3-14. W/P Copy window after three duplications of Empty Folder.](image)

Now select Copy of Empty Folder and type in a new name: Trial Folder1. Then select the Copy of Copy of Empty Folder and name it Trial Folder2. Now we can do some practice organization. We want to select MacWrite, MacPaint, and Font Mover, which you can do either by shift-clicking or by dragging a selection box around all three. Use whichever means you wish, so that your window looks like Figure
3-15. If you missed and all three are not selected, just deselect and start over. Remember that you can enlarge the window and move icons around if you need more space.

![Figure 3-15. W/P Copy Window with new folders and three icons selected.](image)

Now click on any of the three selected icons and drag to Trial Folder1; the outlines of all three will move together, as in Figure 3-16. And when any one is over Trial Folder1, the folder’s icon will highlight—release the button and all three are deposited therein. Now select the System Folder icon and drag it to Trial Folder2. Then select Trial Folder1 and drag it also to Trial Folder2. Your W/P Copy window is much less cluttered now, as seen in Figure 3-17, although this would not be a very efficient organization for real-world applications. Still, you are getting the idea.

Now double-click on Trial Folder2. It opens and we see its contents: the two folders we put there. Then double-click on Trial Folder1; its window appears, showing the stuff we put in there. The shadow of Trial Folder1 remains in Trial Folder2, to show that that is its official location. Your desktop should now look more or less like Figure 3-18, depending on the size of each window. Folders can hold documents and other folders, which in turn can themselves hold documents and
Figure 3-16. Moving three application icons to a folder for storage.

Figure 3-17. The W/P Copy window after storing icons inside folders and one folder inside another.
other folders—and this can be carried to many levels. In a practical sense, think, for example, of a Letters folder, which in turn holds, perhaps, twelve monthly folders, or a group of subject folders, each of which has the actual documents. That would be much more efficient than a single window for the whole disk, displaying dozens of individual documents.

As with a physical filing system, a little thought in advance, plus the Finder’s storing facilities, will permit efficient handling of large numbers of documents. If you do find a need for reorganization over time, it is certainly much easier to do under the Macintosh system than with manila folders and steel filing cabinets.

![Image of a Macintosh desktop with windows]

Figure 3-18. Desktop with W/P Copy window and two folder windows.

While the three windows are still open on your desktop, try selecting first one, then another. Remember that only one window is active at a time, but that by clicking on any part of any window, you activate it and it will come to the foreground. Remember, also, that you can move any window around by pressing in its title bar and dragging it wherever you want on the desktop, and that you can change the window’s size by pressing on its size box and dragging. Try this,
moving the three windows and changing their sizes. Then select Trial Folder1, choose by Name from the View menu, and expand its window so that all the information can be seen, as in Figure 3-19. Now make sure your printer is on, and also make sure that the Caps Lock key is up, not down. Then, simultaneously depress the Shift, Command, and 4 (the number 4) keys. Your printer should give you a copy of Figure 3-19.

Figure 3-19. The Trial Folder1 window, showing the folder’s contents by name.

Directories

A common practice in computing is to get a “directory” or “catalog,” that is, a listing of all the files on a disk, or a subgroup of those files. You already know how to do this on the screen—by simply opening an icon, you automatically see its contents, in any one of five ways. If you want to have hardcopy printout of the contents of any window, you follow the procedure just outlined: depress the Command-Shift-4 combination with the Caps Lock key not engaged. (If the Caps Lock key is down when you type Command-Shift-4, the Macintosh will print out the entire screen instead of just the active window, which is discussed below.) We will look into some additional printing features in Chapter 4.

Now change the Trial Folder1 display back to by Icon, then resize the windows and move them so that they look about like those in Figure 3-20. Remember that you can move a window without selecting it by holding down the Command key while you press on its title bar and drag. Select the System Folder icon and drag it back to anywhere in the W/P Copy window. Then select Trial Folder1 and
choose Select All from the Edit menu or Command-A from the keyboard. Then drag those icons back to the W/P Copy window. Now Trial Folder1 is empty and Trial Folder2 shows only the shadow of Trial Folder1. Select the latter and click in its Close box—it returns to Trial Folder2. Close Trial Folder2, and it returns to W/P Copy; you don’t need it any more, so drag it to the Trash.

![Three Open Windows](image)

**Figure 3-20.** The three open windows, ready to move icons back to their correct places.

Finally, make sure the W/P Copy window is active. The various icons may well be sloppily situated in the window. So open the Special menu and choose *Clean Up*—the Finder will reorganize all the icons for you. Of course, if you disagree with the Finder’s placements, just drag any icon to where you want it. Be careful with the Special menu—you don’t want to select *Erase Disk* by mistake; this is a Finder utility for getting rid of everything on a diskette. Fortunately, the Finder will always provide an Alert box to let you change your mind about Erase Disk. Moreover, it will refuse to erase the startup disk (see Chapter 4)—you must restart the system with a startup disk other than the one you want to erase.
Trash

The Finder protects us in numerous ways. For example, double-click on the Trash icon to see its window, which should look like Figure 3-21. Trial Folder2 is there (with Trial Folder1 inside), and so is Copy of Copy of Copy of Empty Folder, which we put there earlier. The Finder holds onto stuff you throw away for a while, to give you a chance to change your mind. It will preserve what you trash, but only until you either select Empty Trash or open any application or turn off the Macintosh. This time, we don't want to resurrect any of this stuff, so go to the Special menu and select Empty Trash. Then move the pointer to the Trash window's Close box and double-click: this is another use of double-clicking, to both close and deselect any icon.

Figure 3-21. The Trash window.

File and Disk Locking

Another means of protecting things is by locking them. Let's try this: select the MacPaint icon, then enter Command-I from the keyboard or select Get Info from the File menu. We get the descriptive window we have looked at before, illustrated in Figure 3-22. Note, first, the box at the bottom of the window which permits us to enter any notes we might wish, as I have done here. This is available for each Get Info window and is a useful device for keeping notes on our documents, etc. But note also the Locked box, which has just been clicked on in this example. When you click on the box, it changes its state from X'ed (locked) to blank (not locked) and back again.

Any Macintosh application or document can be locked via its Get Info box, in which case it cannot be trashed or replaced (by saving a new version or copying one from another disk) until you unlock it.
This is a way to avoid inadvertent destruction, and can be useful for things you do not plan to change. It is not a bad idea to lock programs and tools, and even some documents. Note that some Macintosh applications won’t work correctly when locked; the Macintosh will give you an error message if this is the case. Under no circumstances, however, should you get into the habit of using locking as a substitute for the best method of data and program security—backup copies. It can happen that everything on a diskette is destroyed, locked or not. The habit of backing up important materials regularly is one of the most important any computer user can develop.

You can also lock an entire disk by moving the small sliding write-protect tab at its upper right-hand corner from down to up, so that the hole is uncovered. When a diskette is write-protected in this way, nothing can be written on it; its icons can be opened, copied from, and usually printed, but they cannot be removed or changed in any way. Many applications, including MacPaint, will not work when the disk is locked in this fashion, because temporary files are created during their use. But it is a useful device for protecting the original copies of all your diskettes—they should never be used in any case.
Closing and Putting Away

Now make sure the W/P Copy window is active. Select the Sample Memo icon, drag it down to the lower part of the desktop, and leave it there. Then click the Close box of the W/P Copy window, so that it closes and returns to its disk icon. Then select Sample Memo again, and go to the File menu and select Put Back, as illustrated in Figure 3-23. The Sample Memo icon goes back to its proper location, inside the closed W/P Copy icon.

![Figure 3-23. Put Back returns icons to the folder and/or disk they came from.](image)

The Put Back option can be very handy. Suppose you do some work on a document, then decide to leave it on the desktop in case you want to do some more work on it later. Then, after doing some other things, perhaps with other diskettes, you decide you want to put it away. Rather than opening a folder (or, perhaps, more than one folder) and dragging the document's icon to it, you can just select Put Back—and it will go to its place automatically, even if its folder is not visible. It is also useful when you have items out on the desktop from two or more
disks; the Finder knows where each belongs (even if you have forgotten!), and Put Back will do the job.

Another Finder facility from the File menu, which we encountered in Chapter 2, is Close All. Open the W/P Copy icon, then open the System Folder icon and the Empty Folder icon as well. This should provide three windows on the screen, as in Figure 3-24. Select Close All from the File menu, and each will return to its proper place and be closed. Close All is like Put Back, but is for windows. It is identical to selecting each window individually and closing it from the File menu or its Close box.

![Figure 3-24. Three open windows on the desktop ready for simultaneous closing.](image)

**Ejecting**

At this point, we should also clarify a few points about ejecting diskettes, which you have done many times by now. You already know that a diskette icon has to be selected before it can be ejected; if it is not highlighted, choosing Eject from the File menu or Command-E
from the keyboard will not work. The Finder insists on controlling the Eject process, to make sure all files are closed and the disk has a record of where everything is.

In addition to Command-E, there is another way to eject diskettes under keyboard control, which does work whether or not the desired disk is selected. Command-Shift-1 will eject the disk in the internal drive, and Command-Shift-2 will eject the disk in the external drive. This technique can frustrate the Finder's record-keeping, however, and should not be used unless a normal Eject fails to work.

Occasionally, for one reason or another (a power failure, for example, or some temporary hardware or software problem, or an error on your part), the Macintosh will be turned off while a disk is in a drive. Just turn the Macintosh back on while holding the mouse button down; the diskette(s) will be ejected during the power-on sequence. Only if this doesn't work should you use the mechanical alternative—inserting a straightened heavy paper clip into the little hole to the right of the drive. That will work, but shouldn't be done unless you have to.

Other Finder Services

The services that the Finder provides vary with what you are doing with your Macintosh and the applications you are using. So far, we have concentrated on general Finder capabilities for the desktop and disk windows. When an application, such as MacWrite or MacPaint, is active, that application is in control of what Finder facilities are available. Thus we will learn some additional things about it in Chapters 5 and 6, which explore those programs, as well as in Chapter 4, where we look more closely at document and disk management.

We will note here, therefore, only a few general things we will find of use from within applications. The Finder permits us, for example, to save documents we have created, rename them, and so forth. When we work on any document, we can save it under whatever name it currently has (if "Untitled," the Macintosh will ask us to name it), or we can use Save as . . . , which lets us provide a new name at that time. Thus, we could make a change in a document and save it under a new name, in which case both the former document and the new one will be maintained; this can be done repeatedly. It is an alternative to the use of Duplicate, illustrated above, for working on several versions of the same document.
Usually, you will want to instruct the Finder to Save the document you are currently working on as you develop it. This puts it on disk and avoids losing all your work, in case there is a power failure, for example, or something else goes wrong. **Next to backing up all files, frequent saving while working is the most important security measure we have.** The Finder will also let you simply Quit, if you decide to stop work on a document; or Close, if you want to put it away, but to continue using the same application. In all of these cases, the Finder provides a Dialog box to give you a chance to change your mind.

The Finder also provides a connection to the printer, guiding us in selecting just how we want a document printed; we will look at this in detail in the next chapter. In addition to permitting us to print any document, the Finder will also let us print an image of the screen, generally referred to as a *screen dump*. We saw above (Figure 3-19) that by depressing Shift-Command-4 we would get an automatic printout of the active window. If we do the same thing with the Caps Lock key in the *down* position, we get a printout of the entire screen—desktop, titles, and all. Numerous examples of this can be found in the illustrations for this chapter. Try it now: make sure the Caps Lock key is in the *down* position and your printer is on; then hit the Shift-Command-4 combination and see your current screen print out. This is very useful indeed, especially if you decide to write your own book about the Macintosh.

Another, related facility is the Finder's ability to send a screen dump not to the printer but to a separate file on the disk, which automatically becomes a MacPaint document. By holding down the Shift-Command-3 combination (the position of the Caps Lock key doesn't matter), the Finder takes a "snapshot" of the current screen, and places it on the disk, as illustrated in Figure 3-25. You can then open and use it just like any other MacPaint document. These snapshots are always named *Screen x*, where *x* will be number between zero and nine, since up to ten such snapshots can be taken in any one Macintosh session.

The Finder, then, along with application programs, is the link between you and the Macintosh. It is quite invisible; indeed, you will know it only by its tools, which you use constantly. Its name simply provides a convenient label for all that it does. Its powers, no matter what we call it, are considerable, and are at the heart of what makes this computer so easy to use.
Figure 3-25. The W/P Copy window showing a MacPaint document created by taking a snapshot of the current screen.

Checklist for Chapter 3

1. **Double-clicking** will both Select and Open an icon, or both De-select and Close it. It has other applications as well.
2. The **View** menu offers five ways of viewing the contents of any window.
3. We **copy** all or part of the contents of one diskette to another diskette by dragging the icon(s) of what we want copied to the icon of the diskette we want to copy to.
4. **Disk Copy** is a special application that speeds up the process of copying an entire diskette with single-drive systems.
5. We create additional copies of any file on the same diskette by selecting **Duplicate** from the File menu or **Command-D** from the keyboard.
6. Selection of more than one icon is done by dragging a **Selection box** or by **Shift-Clicking**.
7. All icons in a window or on the desktop can be simultaneously selected with **Select All** from the File menu or **Command-A** from the keyboard.
8. **Folders** are used to organize file storage. Applications, documents, and other folders can be stored in them. New ones are created with Duplicate.
9. **Shift-Command-4** with the Caps Lock key **up** prints a copy of the active window.
10. **Shift-Command-4** with the Caps Lock key **down** prints a copy of the entire screen, often referred to as a **screen dump**.
11. *Shift-Command-3* takes a snapshot of the screen, turning it into a Mac-Paint document.
12. To move a window without selecting it, hold down the Command key while you press and drag.
13. Select *Clean Up* from the Special menu to have the Finder reorganize the icons in the active window or on the desktop.
14. Select *Erase Disk* from the Special menu to delete the entire contents of a diskette.
15. The *Trash* window holds trashed materials until you open an application, turn the Macintosh off, or select *Empty Trash* from the Special menu.
16. *Locking* an application or document in its Get Info window prevents its being trashed or replaced.
17. An entire disk can be mechanically locked by sliding its *write-protect tab* up; its contents cannot then be changed in any way.
18. Select *Put Back* from the File menu to return an icon to its proper folder and/or window, whether that folder or window is open or not.
19. Diskettes should be ejected by selecting *Eject* from the File menu or *Command-E* from the keyboard (Command-Shift-1 for the internal drive and Command-Shift-2 for the external drive also work). If diskettes are accidentally left in the Macintosh when it is turned off, holding the mouse button down while turning it back on will eject them. They can also be mechanically ejected, if necessary, by inserting the end of a straightened paper clip in the little hole to the right of the disk drive(s).
Managing Documents & Disks

Introduction / 80
Document Management / 80
  Saving / 80
  Quitting / 84
  Closing and Open...ing / 85
Disk Management / 87
  Startup Disks / 88
  Font Mover / 92
  Setting Up Work Disks / 97
Printing / 103
Checklist for Chapter 4 / 110
Introduction

Most of the basic techniques for using the Macintosh were introduced in Chapters 2 and 3. In this chapter, you will learn to apply those techniques to its overall control. This will help you master the system and prepare you for the specific tasks covered in Part II. Just as actions like pointer movement, clicking, and window control are basic techniques, correct and efficient management of documents and diskettes are equally important to using your Macintosh to its fullest. So we will look in more detail at the use of documents and disks, and investigate the Macintosh's printing capabilities as well.

Document Management

You have already learned some things about document management. You know a lot about how the Finder handles documents: opening and closing them; copying them to another disk or duplicating them in order to have two copies on the same disk; editing text within them, and cutting, copying and pasting as well. Now we can move on to the more general aspects of document management that you can direct the Finder to do for you. For this, we will need something to work with, so put your working copy of the Write/Paint diskette in the Macintosh and turn it on.

There are several ways to get a document to work on. If it is an entirely new document, simply Open the application you want to use for creating it. If it is an old document, on which you want to do more work, just Open that document—there is no need to touch the application icon at all. Or, to retain an old document but make changes in a new version, you can Duplicate it, give the copy a new name, and Open the copy. The last, however, is somewhat less efficient than using the Save as . . . option, which we will get to momentarily.

Saving

For our first exercise, we want an entirely new document and will use MacWrite to create it. Select the MacWrite icon and then select Open from the File menu—or just double-click on the MacWrite icon, which accomplishes the same thing. We will not be learning MacWrite now (that comes in Chapter 5); we are using it only as a tool for learning about document management. Just type in a few letters or
words on the first line when the window appears, as seen in Figure 4-1. What you type is irrelevant—we simply want to have a document to manipulate. Note that the window is labeled "Untitled."

Figure 4-1. A MacWrite window with a few characters typed in.

Now go to the File menu and choose Save. The Macintosh will provide us with a Dialog box like that of either Figure 4-2 or 4-3. Since we have not yet given the document a name, the Finder prompts us for one, and it gives us the opportunity to reconsider (Cancel) if we wish. It also permits us to save text only; this means that differing type fonts and styles, as well as pictures transferred from other applications, will not be saved. Its main utility is a considerable saving of space, which makes sense if you don’t think you will need exactly the same document again, but simply want a copy of its text. (Text Only saves are also used for documents that will be sent to another computer via telecommunications, since only the Macintosh's text format can be used by other computers.) Enter a name, as in the example. If you make any mistakes, you can edit this text like any other; the pointer will not turn into an I-beam shape, but you can use the arrow pointer to select any text and remove, replace, or whatever. Don't click on Save yet.
The difference between the two figures reflects alternative operation with single-drive (Figure 4-2) or dual-drive (Figure 4-3) systems. With the latter, the Dialog box offers another choice, labeled Drive. As you click on it, the diskette name above will switch back and forth between the diskettes in the two drives, permitting you to specify the one on which you want the file saved. (In this example, the word “Drive” is in shadow because there was no disk in the second drive, another example of the Macintosh’s efforts to protect us from errors.) Moreover, with either a single- or dual-drive system, you can also save the document to any other disk by choosing Eject from the Dialog box. Your diskette will be ejected and you can insert any other diskette you want; then you click Save and the document will be saved to that diskette. You will then be prompted to reinsert the original diskette. Any additional Saves will result in an automatic prompt to reinsert
the diskette you Saved to before. This greatly facilitates getting around the storage problems of single-drive systems.

Now click Save and the document is saved to the Write/Paint disk; then you are returned to your document. The Finder does not assume you have finished just because you have saved a document. Indeed, as already noted, saving should be done at regular intervals—every ten minutes or so—as a safety precaution in case something goes wrong. Now enter a few more characters on the screen, and then pull down the File menu and choose Save once more. Note that this time there is no Dialog box; the document already has a name and a disk designation, so the current version replaces the previous one on the correct disk.

Type another few characters, and now select Save as . . . from the File menu. This provides a screen identical to that of Figure 4-2 or 4-3, with the current document in the name bar, but highlighted so that it can be changed immediately, which will most often be your intention. Now you can save the new version under a different name, or to a different diskette, or only in text form, etc. In fact, you can do this even if you have made no changes at all, but simply want another copy under a different name or on another disk.

Save as . . . can be used like Save for naming a document when you have opened it by clicking on the application icon and its current name is "Untitled." It is also used when you are working on an old document and want to retain both it and a copy of your changes. And it can be used to create two or more identical versions of a document on one or more diskettes. Be aware, however, that all subsequent Saves will be to the new document (the one created with the most recent Save as . . .) rather than to the original one. In most cases this is exactly what you will want, but if not, you can compensate by using another Save as . . . to save to the earlier version or diskette, or to yet another one.

Save as . . . also permits an efficient way to maintain "stationery pads." You can create a letterhead, for example, under MacWrite, and save it to disk with headings and margins set just the way you generally use them. Then, whenever you want to use a "piece of this stationery," just open the document and immediately use Save as . . . to give the current version a new name. The original will be unaffected and can be used in this way again and again. This is faster and simpler than first duplicating the document on the desktop and then naming and opening the duplicate.
Enter a name to replace My Memo; let's call it My Other Memo, and then click on the Save bar. You now have two documents on the disk.

Just remember that whichever document name you have used in your most recent Save or Save as . . . becomes your current document, with its name in the title bar of the active window. The Finder will assume that you want to continue work with that document, and that any Saves you do will be to it. If this is not the case—if you later want to save the current text to another name that may or may not have already existed—then use Save as . . . once more. You can also use Close, which we will discuss below.

The Finder also tries to protect you from inadvertently overwriting (thus permanently removing) an existing file with a Save as . . . If that name already exists, even with different capitalization, you will see an Alert box like that in Figure 4-4, reminding you that such a name is already in use. The heavy lines around the No mean that it is the default choice—it can be selected with either the Return or Enter key, as well as by clicking.

![Replace existing "my memo"?]

Yes  No

Figure 4-4. An Alert box when saving with a document name that already exists.

**Quitting**

Now type a few more characters in your MacWrite window and then select Quit from the File menu. The Finder beeps and presents you with a Dialog box like that in Figure 4-5. It always keeps track of what you are doing. If you have not made any changes since your last save, you are immediately sent back to the desktop. But if any changes have been made, the Finder reminds you of that fact and let's you decide whether you, in effect, want to Save again before you stop. For this box, Yes is the default choice. In this case, click on No, and the Finder puts everything away and returns you to the desktop.
Managing Documents & Disks

Figure 4-5. A Dialog box that appears when we Quit an application with any changes since the last Save.

Closing and Open...ing

Your Write/Paint window should now include two new icons, one for My Memo and one for My Other Memo. In fact, that window may be getting a bit full, so that you may have to scroll a bit or enlarge it in order to see all its contents. Let's double-click on MacWrite to open another document. When the window appears, type in a few characters, then go to the File menu and select Close. You get the same Dialog box we saw in Figure 4-5, except that "closing" replaces "quitting." The Finder wants to know if you want this document saved in its current state or as it was at the last Save, and will save it accordingly. In this case, since we never did a Save on the document, not saving the changes would result in it not being saved at all.

We really don't want to keep this document, since it was just a device to get us to Close and Open..., so click on No. This produces the blank screen illustrated in Figure 4-6; on yours, of course, the File menu will not be open until you press on it. Note that we don't have too many choices available to us at this point. The Apple menu is there, and so is the Edit menu, but the latter will only permit us to view the Clipboard. Here, you would usually be using one of the three selections available from the File menu, which is why we have it showing in the illustration.

Whereas Quit returns us to the desktop with no application active, Close just stores the current document in its proper place, while keeping the current application—in this case MacWrite—active. So, at this point, as we see in Figure 4-6, the Quit selection will let you change your mind, cancel the application, and return to the Desktop. New, on the other hand, has exactly the same effect as if we were at the
desktop, looking at the MacPaint/MacWrite window, and opened the application icon. It provides us with a new document to work on, labeled Untitled, under whatever application we have been using.

*Open* ... is more interesting, so select it. This produces a Dialog box like Figure 4-7. On the left is an alphabetical list of all the documents on the current disk which were *created by the active application*. When there are more than the small window can display, you can scroll up and down to see them. If you click on any of these names, the Open bar turns from shadow to black, and if you then click on Open the document is opened for you (you can also double-click on the document name to open it directly). If you have a two-drive system the Drive box will also be there to let you see relevant documents on the diskette in the other drive. And, as before, you can also choose Eject and insert a different diskette, in which case all of its relevant documents will appear. There is no need to Quit and then open some other document from the desktop level. Obviously, since an application—in this case, MacWrite—is still active, there is no need for documents created under other applications to be shown, and they aren't.
Figure 4-7. The Dialog box when Open . . . is selected.

The New and Open . . . selections can speed up your work considerably, when you want to continue with the same application. With one or the other of these two selections, you can quickly start work on a new document under that application, or do some additional work on an old one. In combination with Save as . . . , you can work on or create many different versions of several documents without ever going back to the desktop.

At this point, we really don't want to do any more work with this stuff, so select Cancel, and then, from the File menu, select Quit.

Note that while we used MacWrite for this demonstration, the operations associated with saving, opening, closing, and quitting will be quite constant across Macintosh applications. Some may offer additional choices, but these are the basics, which will apply no matter which application you may be using. To a much greater degree with the Macintosh than any other computer, once you have learned any one application, you know most of what you will need for any other.

Disk Management

You learned a bit about diskettes in Chapters 2 and 3—how to handle them, initialize them, copy them, and so on. But there is quite a bit more you should know in order to make the operation of your Macintosh as efficient as possible. For example, you will want to be able to maximize the free space on your disks. And you should understand differences in operations between single- and dual-drive systems.
The term *startup* disk really has two meanings. First, it relates to what is on the diskette. If a diskette has the *System documents* on it (they are usually in the System Folder), it is technically a startup disk because it can be used when you *boot* the system (that is, turn the Macintosh on). If you try to boot your Macintosh with a nonstartup diskette, it will be ejected. Let’s look at these system files for a moment, for a better understanding. Make sure your Write/Paint diskette is active, Open it, and then open the System Folder. You should see up to six icons for the items illustrated in Figure 4-8; the Clipboard and Scrapbook files are sometimes not there, which is okay. Here we have displayed them by Name rather than by icon so we can get more information.

<table>
<thead>
<tr>
<th>Size</th>
<th>Name</th>
<th>Kind</th>
<th>Last Modified</th>
</tr>
</thead>
<tbody>
<tr>
<td>0K</td>
<td>Clipboard File</td>
<td>System document</td>
<td>Sun, Jun 3, 1984</td>
</tr>
<tr>
<td>46K</td>
<td>Finder</td>
<td>System document</td>
<td>Wed, May 2, 1984</td>
</tr>
<tr>
<td>17K</td>
<td>ImageWriter</td>
<td>System document</td>
<td>Sun, Jun 3, 1984</td>
</tr>
<tr>
<td>2K</td>
<td>Note Pad File</td>
<td>System document</td>
<td>Fri, Jun 1, 1984</td>
</tr>
<tr>
<td>10K</td>
<td>Scrapbook File</td>
<td>System document</td>
<td>Fri, Apr 20, 1984</td>
</tr>
<tr>
<td>133K</td>
<td>System</td>
<td>System document</td>
<td>Sun, Jun 3, 1984</td>
</tr>
</tbody>
</table>

*Figure 4-8. The System documents in the System Folder on a startup disk.*

Three of these System documents are quite small—files for holding whatever is currently in the Note Pad, Scrapbook, or Clipboard. ImageWriter is a special file for printer operations, and is automatically activated when you choose Print. Finder holds the Finder’s programs, which you use constantly. And System consists of a large number of programs that make the Macintosh go. You never call on these programs directly; indeed, it is impossible to Open them the way you do other icons. But virtually everything you do, from turning the computer on, through running applications, and then turning it off again, uses them extensively. They can safely stay in a separate folder, quite invisible to the user running the Macintosh. Now Close the System Folder.
Startup has a second, special meaning to the Finder: the startup disk is the one you actually used when you turned on the computer (in a two-drive system, either drive can be used for this purpose). Even if you eject that first diskette while working and replace it with another startup disk, the Finder still considers the first one as the startup disk up to a certain point. It will continue to insist on the reinsertion of that diskette when any System functions are called for, and it will not permit Note Pad or Scrapbook access to or from other disks. So long as the Finder is active, both startup disk icons will remain on the desktop, but the first one continues to be the startup. This is worth remembering, to facilitate your being able to keep track of where things are.

However, whenever any application is opened, it overrides the Finder in memory. When you finish with that application, the Finder is reconnected, but it does not remember everything that was on the desktop before that application was opened. It will therefore consider any startup disk it finds in the drive (the internal drive if you have two) as the startup disk.

For example, with a single-drive system, if you remove the startup disk and replace it with one that does not have the System Folder, all reads to and writes from the Scrapbook or Note Pad will be to the startup disk; the Finder will not permit you to use these features on the second disk. And you will be obliged to reinsert the startup disk when the Finder needs something, since the original disk is used to keep track of all saves, changes, and so forth. But if you replace your startup disk with one that does have the System Folder on it, once you open an application from that disk it becomes the startup disk. Calling up the Scrapbook or Note Pad will result in reads or writes to the ones on the new disk. And when you quit the application, you will find that the original disk's icon is no longer on the desktop. Now the active Finder is the one on the second disk, not the first.

With a two-drive system, it works a bit differently. The Finder of the startup disk is in control at all times, except when an application on the disk in the external drive is being used. Even if the disk in the external drive does not have the System Folder, any applications on it will displace the Finder. Thus the active Scrapbook and Note Pad before using an application and after quitting it will be those of the startup disk in the internal drive. But while using an application on the external drive, its Scrapbook and Note Pad will be active.

This can be a bit confusing at first, but you will readily get used to it. An awareness of what is happening will help avoid looking for
things like Scrapbook entries when they are not available. Fortunately, the contents of the Clipboard are unaffected by disk swaps or application openings; the most recent Cut or Copy will be there regardless of which disk is in control.

In addition to startup disks, beginning with the second version of the system software you can also have a *startup application*. That is, you can so configure a diskette that any desired application on it will be automatically selected and opened when the computer is turned on. For example, make sure the Write/Paint window is open, and click once on MacWrite to highlight it. Then open the Special Menu and select Set Startup, as in Figure 4-9. You are immediately presented with the Dialog box illustrated in Figure 4-10. If you click OK, MacWrite becomes the startup application. Any time you turn on the computer with this diskette inserted, you will automatically be presented with an “Untitled” MacWrite window. For now, just select Cancel.

If you regularly do a lot of work with any one application, you may find it worthwhile to configure one or more disks for this type of startup. This is usually referred to as “auto-booting” in the computer world in general. To undo an automatic application startup, open the System folder, select Finder, and then use Set Startup to make Finder the startup application. This is the standard way the Macintosh works.

Some users may wonder how many disk icons they can safely have on a desktop before the Finder becomes confused. So far as the Finder actions described in Chapter 3 are concerned, four is the practical limit and five the maximum; user confusion is a good deal more likely to emerge first. (You will get an Alert box if you exceed the Finder’s capabilities.) The extra icons will be retained on the desktop only so long as no application other than the Finder is open; once you open an application, the Finder loses track of any disks not in a drive, and their icons will disappear. As a general rule, you should not have more disk icons out than are really being used, because it *can* get confusing—certainly for you, and on rare occasions for the Finder. If your desk gets too cluttered, just remove the excess icons by dragging their shadows to the Trash. Trashing shadow (that is, not currently inserted) disk icons has no effect on the disks themselves; it simply removes the icons from the desktop. The Finder will protect you from yourself by refusing to trash the startup disk.

The System documents needed by a startup disk take up just about one-half of the diskette’s capacity. In fact, they can take up more than
Managing Documents & Disks

Figure 4-9. Selecting Set Startup from the Special menu, after having selected the application wanted for automatic startup.

Are you sure you want to make "MacWrite" the startup application?

Figure 4-10. The Dialog box that selecting Set Startup generates.
that because your applications will often also be on the startup disk. This is especially true on a single-drive system; otherwise, the amount of disk swapping called for is excessive. It is therefore quite important to understand when you want disks to have startup capacities and when you don’t. This is one of the reasons we are looking more deeply into the management of both documents and the disks themselves.

Font Mover

One of the things that makes the System file so large, taking up anything from about 130K to over 200K on a diskette, is that it includes the numerous type fonts and styles that the Macintosh makes available to its applications programs. For a font to be available, it must be in the System file. And as the number of available fonts is increased, the size of the System file becomes correspondingly greater, taking up more and more space on a startup disk. For some applications you won’t need some of the fonts stored in System; for others, you will want to add a font that is not yet in System. This is the job of the Font Mover application—it permits us to remove fonts from the System file, either to the Trash or to a separate file for storage. And it permits us to add fonts to the System file from a separate file holding them.

Turn off your Macintosh, then insert the System Disk that came with your Macintosh (our first time using that disk), and turn it on. In the first version of the Macintosh system software, everything that was on the System Disk was also on Write/Paint. But most readers will have the upgraded version, including Disk Copy and more fonts. And those additional fonts create a quantity of information too great for a single diskette—they, along with the Font Mover application, are on the System Disk, but not on Write/Paint. Open the System Disk and you should see a window pretty much like that of Figure 4-11. We have the Font Mover application itself, the Fonts file with a number of fonts in it, and a separate Seattle file with one more font. Additionally, of course, we have numerous fonts already in the System file.

You can use the Font Mover application to remove any fonts in the System file that you have no use for, or to move fonts from the Fonts or Seattle files to the System file so they can be used. Double-click on the Font Mover icon to open it, just like any other application. This creates a window like that of Figure 4-12. On the left is a window showing the fonts currently in the System file, and on the right those currently in the Fonts file. The Font Mover is ready to move any single font from one to another, or to trash it. (If you have the first version of the
software, the right window will be empty, because all fonts are already in the System file. You would therefore use the Font Mover only to remove any fonts you didn’t want.)

Figure 4-11. Window into System Disk of second release of Macintosh systems software.

Figure 4-12. The Font Mover window, showing the fonts in the System and Fonts files.
Try scrolling up and down through both windows to see the names of all the fonts in the System and Fonts files. If you want to see what any one of them looks like, just click on it, as in Figure 4-13. This display also tells us how much disk space the selected font takes up—in this case, almost 14K! Font Mover also has a Help option: if you click on it, several screens explaining the application will appear.

Figure 4-13. Selecting any font under Font Mover provides an example of it, and an indication of the space it takes on disk.

You may notice that the System file does not list every size of every font you may have been using. This is because some of the style possibilities are created with combinations of others. A couple of warnings apply to moving fonts out of the System file: First, those preceded by an asterisk cannot be removed; they are used by the Macintosh for some of its own displays (when you remove a font from the System file, it is being removed for screen display as well as printing purposes). Second, if you plan to use High quality printing as well as Standard (see below, on printing), don’t remove the doubled size of any font you will be using. For example, to get high resolution of New York 12 point type, New York 24 point type must also be available.
To move any font, simply click on it; the arrows around the word Copy will switch to point in the opposite direction, and then clicking on Copy will move a copy of that font to the other window. In Figure 4-14, we have chosen San Francisco-18 in the Fonts file and copied it to the System file. You can also shift-click or drag to select several fonts at one time. Note that copying does not remove the font from its source; it simply creates a copy in the other file. If, for example, you want to remove a font from the System file and keep it in the Fonts file, you first do a Copy, and then, with the original font still selected, click on Remove to get rid of it.

![Font Mover](image)

**Figure 4-14. Selecting Copy moves a copy of the selected font to the other file.**

Generally, you would not want to remove fonts from the Font file; more likely, you would just copy the whole file to another disk for storage or simply trash it. But often you will want to remove fonts from the System file—since you have additional copies of the Fonts file on your backup diskettes, there is no good reason to keep extra copies of any font. It is a good idea, however, to put a note in the Get Info window of any System or Fonts file, noting how you have changed it, so that you can easily remind yourself of what is where, as in Figure 4-15. This kind of on-disk documentation is not likely to get lost, and
makes it easy to keep track of just what you have done and what is where.

Information about System

Kind: System document
Size: 131828 bytes, accounts for 132K on disk
Where: System Disk, internal drive
Created: Wednesday, May 2, 1984 at 8:04 AM
Modified: Monday, June 4, 1984 at 8:53 AM
Locked

Customized for word processing; several fonts removed and trashed. If others are needed, copy in a full Fonts file and transfer with Font Mover.

Figure 4-15. Documentation in a System file Get Info window, specifying how its original fonts collection has been changed.

For practice, try copying one or two fonts, and then removing them from their new locations only. You don't actually want to make any permanent changes at this point. When you begin to set up work diskettes, you will have a clearer idea of what you will be using them for. You can then make sensible decisions about which fonts you want to retain and which you can do without. When you are done practicing, just click on Quit and you will be returned to the desktop.

The Seattle file contains two additional fonts. If you Open it, Font Mover is run with the Seattle file loaded into it. (Opening Font Mover itself, or the Fonts file, results in only the Fonts file being loaded.) The right-hand window will have the two Seattle sizes and the left-hand window the current System fonts. You would not want to move anything from the System file to this font file, but might want to add one or both of the Seattle fonts to the System file on some of your diskettes. (The Seattle font, printed in High Quality mode, creates a near "letter quality" printing effect, excellent for business correspondence.)
Setting Up Work Disks

Because the System documents on startup disks take up so much space, it is important to learn how to maximize the free space on those disks. This is particularly the case with single-drive systems, since disk-swapping is time-consuming and clumsy. And it provides greater efficiency to two-drive systems as well. On single-drive systems, any application should be on a startup disk. You learned earlier that with a Save or Save as . . . you can Eject the disk you are using and do the save to another diskette, and that for subsequent Saves the Finder will prompt for reinserting that diskette. Still, you may want to be able to save, at least temporarily, to the startup disk itself. This can be done with a little planning and organization.

Let's learn by example, setting up a word processing startup diskette. The first step will be to make a copy of your Write/Paint diskette. Follow the instructions for your system, as given in Chapter 3. (Be sure to use Disk Copy if yours is a single-drive system and you have that application.) Name the new disk WRITING, turn your Macintosh off, insert WRITING in the drive and turn the power back on. Then open WRITING and you should have a window pretty much like that of Figure 4-16. Note that over 80 percent of the disk is already full (332K on this one). This leaves very little room for documents: 67K is not all that much, and the Macintosh reserves some space for its own use. (It periodically writes to the disk a temporary copy of what you are working on so you will have a reasonably current copy there if power is disrupted. That temporary file is automatically erased if there are no problems, so you may never see it.)

So now let's see how we can improve the situation, particularly for single-drive systems. First, since this will be a word processing diskette, select MacPaint and drag it to the Trash. Click OK when the Alert box comes up, and then select Empty Trash from the Special menu. Very good; you have considerably increased the available space to about 128K (the actual figure will vary slightly from one time to another, based, for example, on the number of fonts in the System file).

Now we want to use the Font Mover, so eject WRITING, insert your System Disk, select the Font Mover icon, and drag it to the shadow WRITING icon. That is, follow what we learned in Chapter 3 to transfer a single file from one diskette to another. After that is done, reinsert WRITING in the drive and drag the System Disk icon to the trash (this is not necessary, but it will minimize confusion at this
time). When you are done, your WRITING window should have Font Mover added; we have lost a little space, but that is only temporary.

Now we want to run the Font Mover application, so double-click to get it going. The Font Mover window shows nothing in the right-hand window, as illustrated in Figure 4-17, since we do not have the Fonts file on this disk—our current interest is in getting rid of fonts rather than adding them. Similarly, we will now delete fonts rather than copy them to a new Fonts file. Remember, we have copies of that file on our System and backup diskettes, and can always get them back if we wish. Let's first get rid of London-18; it is a decorative font of little use in most word processing. Select it, and then click on Remove, as in Figure 4-17. Then do the same to Athens-18 and Venice-14, which we also don't need.

Now scroll through the window until the seven New York fonts are evident. This is a commonly used font, and let's assume you think you might use the 9-, 10-, and 12-point versions, and that you might also want to print some letters in High resolution, meaning that you also need the 18-, 20-, and 24-point ones (later, if you find you never really use High quality, you can remove them). So select New York-14 and remove it—that will add another 3,352 free bytes to our disk. Then select one or two examples of Monaco and Geneva, and look at their Samples. They are really quite similar, so let's select Monaco-12 (Monaco-9 is reserved) and remove it. This leaves the one reserved Chicago
Figure 4-17. Removing the London-18 font from the System file.

font and quite a number of Geneva fonts. We'll keep Geneva 9, 10, and 12, plus their doubles, and remove Geneva-14.

Now select Quit, and wait a while for the Font Mover to update the System file. When the WRITING window reappears, move the Font Mover icon also to the Trash—you have no further need for it on this disk. Empty the Trash, which leaves you with about 148K available on your disk, as seen in Figure 4-18. You might well find, when you do real word processing, that you use only one font, in which case you could copy Font Mover back to this disk and remove the extras. Similarly, if you later wanted to add one or more fonts from the Fonts or Seattle files, you could copy those to this disk, and then use Font Mover to add them to the System file. Here, we are just looking into an example of maximizing diskette room for documents.

There is more we can do, as well. First, trash the Sample Memo—that is a learning example that you wouldn’t really want on a work diskette once you had some experience with MacWrite. That gives you 3K more. Now pull down the Apple menu and choose Scrapbook, which currently has five sample screens, each of which takes up storage space. Then, with the first page showing, go to the Edit menu and select Cut, as in Figure 4-19. This will remove that screen, and the
former Screen 2 now becomes Screen 1. So select Cut (or Command-X) four more times, to empty out the Scrapbook. You are now up to about 158K of free space.

Then return to the Apple menu and select Note Pad. You have no need for this instructional first page, so move the pointer in front of the first word. It takes on the familiar I-beam shape. Drag it down and to the right until all the text is highlighted. Then select Cut or just hit the Backspace key, and it is gone—not much of a saving, but all useless material should be routinely removed.

You now have 160K available on this word processing work diskette, as seen in Figure 4-20. This leaves a reasonable amount of room for document development on this startup disk. If you move documents to backup diskettes as you finish with them, this diskette can be used with reasonable ease on a single-drive system for all your word processing work. Moreover, you can always use Save or Save as . . . to put some documents on another diskette as you are writing them. That way you are sure of having sufficient disk space for whatever you are doing.

You can now put this diskette away for use in word processing, or, if you wish, simply Erase it. (Remember that the Finder won’t let you erase the startup disk for security reasons—you will have to restart the Macintosh with another startup disk, then reinsert WRITING and select Erase.) This might be a good time to practice by creating a DRAWING diskette with MacPaint, following the same process used
Figure 4-19. Cutting material from the Scrapbook to create more free space on disk.

Figure 4-20. The WRITING diskette ready for work.
above. For that disk, you might well want to add a number of decorative fonts from the Fonts file, to the point, indeed, that the diskette will get quite full. (You can, however, trash Imagewriter from the System Folder, because MacPaint doesn’t use it.) In that case, you will want to save your work to another diskette with the first Save, to be sure you don’t run out of room, and move finished work off the startup disk as soon as possible. Try, if you can, to have at least 60K available on any startup disk each time you use it; this will avoid “disk full” messages from the Finder, and the interruption of your work.

Macintosh owners with two-drive systems have it considerably easier, since they can have a startup disk in one drive and a data disk in the other. For the latter, simply initialize a blank diskette and give it a name. Figure 4-21 illustrates this with a disk named JANUARY DATA, assuming we might want to back up all applications programs for a given month to a single diskette. We have an Empty Folder for storage, provided by the initialization process, and nothing more, leaving us with 399K for our documents. In such a situation, dual-drive system owners can have more than one application on their startup disks (for example, MacWrite and MacPaint). Or they could have a drawing disk with MacPaint and with every possible font in the System file, which would take up almost the full capacity of a diskette.

Figure 4-21. A non-startup data diskette with lots of room for documents.

An even more efficient format, with two-drive systems, is to use a copy of the System Disk for startup, with all fonts loaded into the System file, and to have individual applications on separate diskettes. That is, the second diskette (in the external drive) would contain only
MacWrite or some other application, plus a great deal of room for storage. You will also have to keep a copy of Imagewriter on that diskette (except with MacPaint) because the Finder looks for that file on the same disk as the application you are using. Those with single-drive systems can work almost as well, but they will have to do some disk swapping as they develop their documents.

If you remember the above principles, using your Macintosh will be a good deal easier and less frustrating, whether with one drive or two. A bit of experience with any applications program will teach you how much free space you require, which fonts you actually need, etc.

**Printing**

The combination of the Macintosh and Imagewriter printer offers printing possibilities that are both extraordinarily versatile and uniquely simple to execute. Because of the system's integration, user's have no need to learn complex codes or other printer controls. You just type or draw in whatever you want, based on an individual application's capacities and menus, and then tell the Finder to Print. What you see on the screen will appear, in slightly higher resolution, on paper.

The actual printing options available will vary from one application to another. What MacWrite offers is, logically enough, somewhat different than the possibilities of MacPaint. Other applications also will have printing capacities and limitations which reflect their primary uses and, perhaps, the strengths or weaknesses of their designs. All Macintosh applications, however, are more similar than they are different, and we will discuss the similarities here. Whatever might be unique to individual applications will be considered in later chapters.

First, we can note a few constraints. For example, the Macintosh is not able to print a document without first opening it. Insert your Write/Paint disk and select—don't Open, just click once to highlight—Sample Memo. Then go to the File menu and select Print, as in Figure 4-22. Note that the screen blanks and there is some disk activity, as the file is opened. Since you selected Print, you do go directly to a Print Dialog box rather than to the document itself, but nonetheless the document has been opened. This is a minor inconvenience, since it takes more time than if the document could be printed without Opening. We will get to the Dialog box itself shortly; for the moment just select Cancel, which returns us to the desktop.
Also worth realizing is that the Macintosh cannot simply print what is currently in its memory. As you begin to create documents, and then request a Print, you will get a message telling you that a copy is being written to the disk. To illustrate this, Open Sample Memo and, as soon as it appears, select Print from the File menu. Take note of the Dialog box, which we will discuss in a moment, and then click OK. The Macintosh will then tell you it is writing a copy to disk before it actually begins printing. It does this in order to make room for the Imagewriter application in memory, and to have the file in a format Imagewriter can use. Once printing is done, this special version of the file is automatically erased.

We do have the ability to select multiple documents for printing at the same time. Just select the document icons you want to print by drawing a selection box around them or by shift-clicking. Then, when you select Print from the File menu, they will automatically be printed, one after the other.

The advantages of the Macintosh’s rather slow printing characteristics clearly outweigh the disadvantages. Not least of these is the
incredible variety of possibilities available in text format alone via its numerous fonts, font sizes, and styles. Figure 4-23 shows the richness of customization available in font characteristics, in this case the standard menus available in MacPaint. The combinations available, using each font in one or more Styles and any of the numerous possible FontSizes, is considerable enough that one would need the Macintosh's calculator to determine their number.

**Macintosh Menus**

**FOR FONT CHARACTERISTICS**

<table>
<thead>
<tr>
<th>Font</th>
<th>Style</th>
<th>FontSize Choices. Those in outline are recommended for the selected Font.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Seattle</td>
<td>✓Plain builder</td>
<td>9 point</td>
</tr>
<tr>
<td>Toronto</td>
<td>✓Bold</td>
<td>10</td>
</tr>
<tr>
<td>San Francisco</td>
<td>✓Italic</td>
<td>✓12</td>
</tr>
<tr>
<td>Los Angeles</td>
<td>✓Underline</td>
<td>14</td>
</tr>
<tr>
<td>Cairo</td>
<td>✓Outline</td>
<td>18</td>
</tr>
<tr>
<td>Chicago</td>
<td>✓Shadow</td>
<td>24</td>
</tr>
<tr>
<td>Geneva</td>
<td>✓Align Left</td>
<td>36</td>
</tr>
<tr>
<td>New York</td>
<td>✓Align Middle</td>
<td>48</td>
</tr>
<tr>
<td>Monaco</td>
<td>✓Align Right</td>
<td>72</td>
</tr>
<tr>
<td>Venice</td>
<td></td>
<td></td>
</tr>
<tr>
<td>London</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Athens</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Font Choices. Up to 12, if all possible fonts are loaded into System File.

<table>
<thead>
<tr>
<th>Style and Alignment Choices. Available with all Fonts.</th>
</tr>
</thead>
<tbody>
<tr>
<td>✓Plain builder</td>
</tr>
</tbody>
</table>

Figure 4-23. The three menus generally available for Font choice and characteristics.

Exploring all these possibilities is something Macintosh owners can do for themselves. Only with some experimentation will you really understand the appearance of each font in its various Styles and FontSizes. You should generally follow the Macintosh recommendations and use any font only in its suggested sizes, as noted by the size being in outline rather than black. Usually, the nonrecommended ones are less clear. Figure 4-24, quite obviously, is not a comprehensive illustration of all the possibilities, but rather an example of the variety available. And Figure 4-25 illustrates the pictorial Cairo font, with the
This is default Geneva 12 point.
Ten point is considerably smaller.

Eighteen point looks like this.
This is 12 point Toronto.
Nine point Toronto looks larger than 10 point Geneva.

24 Point Toronto boldface.

San Francisco is rather strange.
Los Angeles 12 point is almost italics.
And this is New York 10 point in italics.
And New York 12 point boldface and italic.
Chicago has a very printed kind of appearance.
Monaco 12 point has a delicate appearance.
And its nine point type is quite easy to read.

Venice 14 point is very elegant.
In outline form its appearance is quite distinct.
London should be used in 18 point.
In shadow form it looks very formal.

Athens also looks best at 18 point.
Seattle is an informal sort of type, 12 point.
In boldface its appearance changes considerably.

Figure 4-24. Examples of the varieties available in font characteristics.
Figure 4-25. The pictorial Cairo font; the keystroke used for each character is beneath it.
key to strike for each character given beneath it, to save you some time. This font permits “drawing” of sorts to those who can “only type.” And when you get more involved with MacPaint, and learn in Chapter 6 how to stretch any image, you can turn the dinosaur into a monster.

When you select Print you will also be confronted by the Dialog box you saw a moment ago, asking for some decisions relative to the way you want the document printed. Not all applications will offer this, and specific options will vary from one application to another; Figure 4-26 is from MacWrite. You can specify whether you are using continuous (the default) or cut sheet paper; if the latter, the Imagewriter will stop after each page and prompt you to insert another piece of paper. You can also specify the number of copies you want, and have the whole document printed (the default) or only a selected range of pages. And you have three print qualities available, as illustrated in Figure 4-27.

<table>
<thead>
<tr>
<th>Quality:</th>
<th>○ High</th>
<th>○ Standard</th>
<th>○ Draft</th>
<th>OK</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Range:</td>
<td>○ All</td>
<td>○ From:</td>
<td>To:</td>
<td></td>
</tr>
<tr>
<td>Copies:</td>
<td>1</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Paper Feed:</td>
<td>○ Continuous</td>
<td>○ Cut Sheet</td>
<td></td>
<td>Cancel</td>
</tr>
</tbody>
</table>

Figure 4-26. A standard Dialog box for printing.

Draft quality is fastest, since it is text rather than graphics printing, and the Imagewriter can print it in both directions. It will not show alternate fonts, styles, and sizes, and does not look too great because of its spacing. But it will often be adequate for preliminary copies of documents. Standard quality is relatively fast and includes all the type fonts, sizes, and styles available; it can print combinations of text and pictures. This is what you should regularly use. High quality prints everything twice, for a considerably darker image. But it also prints at half the speed of Standard quality, and with some font sizes or styles may be actually harder to read. Be aware that the Imagewriter can use up printer ribbons rapidly, especially if you do a lot of drawings; often what you really need is not High resolution printing, but Standard resolution with a new ribbon.

Finally, in some applications such as MacWrite, the File menu will also offer a Page Setup option, as illustrated in Figure 4-28. The four Paper choices relate to different sizes of paper. Once chosen, display on
This text is being entered in the default Geneva, 12 point, plain type. This will be printed in standard quality format, using a reasonably new ribbon in the printer.

This text is being entered in the default Geneva, 12 point, plain type. This will be printed in high quality format, using a reasonably new ribbon in the printer.

This text is being entered in the default Geneva, 12 point, plain type. This will be printed in draft format, using a reasonably new ribbon in the printer.

Figure 4-27. Examples of Standard, High, and Text Quality printing.

the screen, as well as on paper, will reflect the selection you have made. US Letter (8.5 by 11 inches) is the default. Orientation relates to the placement of text on the printed page. Tall is the default—standard vertical printing. Wide, on the other hand, rotates each page image 90 degrees, and prints horizontally on the paper (this is not shown on the screen). This is of somewhat limited utility on the Macintosh, particularly with MacWrite, because you cannot change page width to maximize use of an 11 inch wide page, but may sometimes be useful. Tall Adjusted is used mainly when you have pictures inserted in a MacWrite document, as it provides a more precise placement of them; in most cases the differences are minimal.

Figure 4-28. Dialog box for Page Setup in MacWrite.

We have now covered in considerable detail the operation, both basic and more advanced, of what can be called the Macintosh way of doing things. You are ready to use what you have learned with any Macintosh application; little adaptation will be required as you move from any one of them to others. In Part II we will probe in detail the basic Macintosh applications, and get you using those as well.
Checklist for Chapter 4

1. **Save** puts a copy of the current document on the disk. The first Save produces a Dialog box that permits us to name the document and select the disk we want it saved to, via the **Drive** and **Eject** options. Subsequent Saves replace the file on the disk with the current contents of the document.

2. **Save as**... permits us to save a copy of the current document with a different name or on a different disk.

3. **Quit** cancels the current application and returns us to the desktop.

4. **Close** returns the current document to its proper place, but keeps the current application active.

5. **New**, after a Close, opens an entirely new document under the current application.

6. **Open**... , after a Close, provides a window showing all documents created by the active application, allowing you to select a document for reopening.

7. A **startup** disk is one with the **System** documents present. The Macintosh needs these to **boot** (get started).

8. **Startup** is also, to the Finder, the disk that was used to start the current Macintosh session. The Finder will find a new startup disk each time it is disconnected by the opening of an application.

9. **Set Startup**, from the Special menu, permits the selected application to open automatically when the Macintosh is turned on.

10. **Font Mover** is an application for moving fonts into or out of the **System** file.

11. **Erase** removes the entire contents of a diskette, but does not deinitialize it. A startup disk can be erased only if it was not used to boot the system.

12. Documents must be **Open** before they can be printed, and a copy is always written to disk before the **Print** takes place.

13. Dialog boxes associated with printing permit selection of paper type, number of copies, print characteristics, and page characteristics.
Doing Work

5 MacWrite / 113
6 MacPaint / 149
MacWrite

Introduction / 114

Using MacWrite / 114
  MacWrite Menus / 117
  MacWrite Rulers / 125

Expanding MacWrite / 132
  Headers and Footers / 132
  Text and Pictures / 137
  Forms / 140
  Tables / 143

Checklist for Chapter 5 / 146
Introduction

MacWrite is the Macintosh's word processor, which most users will have received or bought when they acquired the computer. It is a reasonably full-featured word processing program, but does lack a few of the powers of some of the more sophisticated equivalents on other computers. Since it keeps the entire document in memory, for example, MacWrite on a 128K Macintosh is quite limited in terms of the size of any document it can create—about ten single-spaced pages. If you have a 512K Macintosh, however, MacWrite can hold about eight times as much. (The third version of MacWrite is disk-rather than memory-based, meaning that it can deal with larger documents, although at a sacrifice of slower operation.) The program has, however, the general Macintosh advantages of extraordinary ease of use and highly versatile print formatting, plus the mixing of text and pictures. It is also better supported by Apple in terms of documentation than is the case for the Macintosh generally or MacPaint, which we will consider in the next chapter. The Apple MacWrite manual is quite useful, but we will go through the program in our own fashion here.

We will build here on what we have learned in Chapters 1 through 4. You now have considerable command of the Macintosh technique, of manipulating text, using windows and menus, handling disks and documents, and so on. All of those skills are used by MacWrite in pretty much the same way as you have used them so far. Thus we will not reintroduce them now, but, rather, tell you to take actions without further prompting, when they are things you should know how to do. If in doubt, go back over the relevant sections of Chapters 1 through 4, or check the Macintosh Quick Reference in Part III.

Using MacWrite

Let's begin. Use your copy of the Write/Paint diskette rather than the one you configured for word processing only, because we will make some use of the Scrapbook a bit later. Make sure it contains a copy of Sample Memo—the document that came on your original Write/Paint disk—and then duplicate Sample Memo and name the new copy Trial Memo, so that we can mess around with it without concern. (If, by chance, you don't have a copy of Sample Memo, you can just open a new document and type in what you see on the screen shown in Figure 5-1.) Then Open Trial Memo, which will provide a window looking like Figure 5-1.
Date: July 16, 1984
To: Robert
From: Elizabeth
Re: Finance Meeting Agenda

Here are my comments on your proposed agenda for the Finance group meeting next week.

1. Moving Date: Let's wait awhile. Discussing the moving date seems premature, since there are so many unknowns.

Figure 5-1. The Trial Memo window before making any changes.

Much of what you see will seem natural by now. The document’s text occupies most of the screen. Most of the menu titles at the top are quite familiar—Apple, Edit, Font, Style—although some of their contents are a bit different here because they are customized for MacWrite. The two new menus, Search and Format, we will get to presently. The Ruler, at the top of the document, is used extensively by MacWrite to control margins, tabs, line spacing, and line format. At the top left of the document window you will see the flashing cursor, and somewhere in the window the pointer.

This is a good time to quickly review your text manipulation techniques. Move the pointer into the document window and it will take on the familiar I-shape. Click the mouse button and the cursor creates an insertion point where you have clicked. Try inserting text between any two words, then removing it with the Backspace key. Note how MacWrite automatically reformats text as you enter and delete characters. Select a few characters by dragging, then replace them by typing in new text. Select a whole word by double-clicking in front of or on it, then deselect it by clicking anywhere else. Select a word or two and remove it with the Backspace key; you can go to the Edit
menu and select *Undo typing* to get it back. Then return to the Edit menu, where you will find the same selection now says *Redo typing*, which really means "undo the undo." Try selecting the space between two words—spaces are just like other characters and can be replaced or deleted.

Now practice a bit of cutting and pasting. Select a paragraph or more by dragging down and across. If you select too much but have not yet released the mouse button, just back up to deselect any part; if you have already released the button, hold down the Shift key and drag back to deselect any part. Use Command-X to delete it. Then use the scroll bar to go down a bit in the document, select an insertion point, and do a Command-V to Paste what you have deleted there. Try the same thing with Command-C (Copy) rather than Command-X, so that the original text is not removed; Paste that somewhere also. All of these choices, of course, can be made from the Edit menu as well as from the keyboard.

Go to the first line of the memo, which reads “Re: Finance Meeting

![Trial Memo]

**Date:** July 16, 1984  
**To:** Robert  
**From:** Elizabeth  
**Re:** Finance Meeting Agenda

![Trial Memo]

**Date:** July 16, 1984  
**To:** Robert  
**From:** Elizabeth  
**Re:** Finance Meeting Agenda

*Here are my comments on your proposed agenda for the Finance*

Figure 5-2. Using the Backspace key to delete a carriage return and move a line up.
Agenda,” and click an insertion point in front of the first character, as in the top window of Figure 5-2. Now hit the Backspace key, to see that a carriage return is also a character, and can be deleted, as in the bottom window of Figure 5-2. Hit the Return key and that line moves back down to where it was.

MacWrite offers two distinct ways of selecting large blocks of text. If you drag the pointer all the way off the bottom or top of the window, text will continue to scroll and be selected until you either release the mouse button or move the pointer back into the window. Alternatively, you can shift-click. Go to the top of the document and click just in front of the word “Date.” Then use the scroll box to scroll down to the end of the document and shift-click. Everything between the click and the shift-click is selected—in this case the entire document. You could now delete or copy all this text, change its type font or style, change its ruler settings, etc., which is often very useful. For now, however, just click in the margin to deselect.

We will continue to use Trial Memo for what follows, so, if you have changed it drastically while practicing, just Close it without saving the changes and then Open it again.

**MacWrite Menus**

Figure 5-3 illustrates the six menus (not including the standard Apple menu) available with MacWrite. Three of them are quite familiar by now. The Font and Style menus we have probed in some detail already. Note that with the illustrated choice of New York font, all six sizes are available; this will not be the case with all fonts. (Remember that the contents of this menu will vary, based on the version of MacWrite you are using and the fonts you may have added or deleted with Font Mover.) All of the major Style choices can be selected from the keyboard as well as the Style menu; each is a toggle, so just select it again to turn the feature off, or select Plain Text to cancel all current choices. For example, select the first short paragraph of the memo, as in the top window of Figure 5-4; then do a Command-B for boldface, and deselect the text to see its changed appearance, as in the second window.

Then select the same short paragraph, and use the Style menu or Command-B or Command-P to cancel the Bold; now select 18 Point, Shadow, and Underline. Deselect the text and it should look like the third window in Figure 5-4. Note that MacWrite automatically refor-
mats text as its size changes. This can be seen even more clearly in the fourth example, where we have selected just two words and changed them to plain text and 9-point in size.

Superscript and Subscript are choices we have not encountered before (if you have the earliest version of MacWrite, you will not see them on the Style menu). They are essential for some writing applications. Go back to the first line again, as in Figure 5-5, and click an insertion point after the word "Agenda." Then use Command-H to select superscript and type a "1," which will produce the footnote number seen in the second window of Figure 5-5; do a second Command-H to turn superscripting off. Subscripts work the same way. Be aware, however, that superscripts and subscripts will make your line

---

**Figure 5-3. The six MacWrite menus.**

<table>
<thead>
<tr>
<th>Format</th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert Ruler</td>
<td>Show Rulers</td>
<td>Open Header</td>
<td>Open Footer</td>
<td>Display Headers</td>
<td>Display Footers</td>
<td>Set Page #...</td>
<td>Insert Page Break</td>
<td>Title Page</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Font</th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Seattle</td>
<td>Los Angeles</td>
<td>Cairo</td>
<td>Toronto</td>
<td>San Francisco</td>
<td>Chicago</td>
<td>Geneva</td>
<td>New York</td>
<td>Monaco</td>
<td>Venice</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>New York</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Style</th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Plain Text</td>
<td>Bold</td>
<td>Italic</td>
<td>Underline</td>
<td>Outline</td>
<td>Shadow</td>
<td>Superscript</td>
<td>Subscript</td>
<td>9 Point</td>
<td>10 Point</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Here are my comments on your proposed agenda for the Finance group meeting next week.
spacing uneven as MacWrite makes room for them. This is a weakness of the program. You can compensate for it, to some degree, by doing your superscripts and subscripts in smaller type, as in the third window in Figure 5-5, where we have selected both superscript and 9-point type.

![Figure 5-5. Using superscripts with MacWrite.](image)

The rest of the Font and Style choices offer nothing new, and so can be left for your own exploration. Likewise, the File menu includes only materials we have dealt with in detail in Chapters 3 and 4. The printing controls (Page Setup and Print ...), which were explained in Chapter 4, used examples from MacWrite.

The Edit menu is also the same as we have worked with before, except that the top choice—Undo—is somewhat more specific. It will
specifically refer to our most recent action, usually saying “Undo Typing,” because that is what we are most often doing. In Figure 5-3 it says “Undo Hide Rulers,” because that had been the most recent action (it is explained below). Also, after an Undo, it will say “Redo,” again specifying the most recent action. This makes clear just what the Undo or Redo can accomplish, but actually the command is working exactly as we have experienced it before.

The Search menu is new to us, and relates to one of the most powerful characteristics of word processing: the ability to automatically search through a document for any string (the computer world’s term for any group of characters), and, if desired, replace it with something else. The longer the document, the more useful this ability will be. Let’s scroll to the top of Trial Memo. Assume that, after writing, we suddenly realize that we may have referred to Tim without using his last name, and we want to be sure about this. Go to the Search menu and select Find . . . , which produces the Find window of Figure 5-6. We can then type in Tim, as the string to search for. We have a choice of searching for the Whole Word (the default) or Partial Word, in which case any string in which the characters “Tim” existed would be found. Generally we want the former. MacWrite ignores case in searches, so capitalization is irrelevant.

Click on Find Next and MacWrite searches through the text until it encounters the string specified, which it highlights. We could now click on the Trial Memo window and add a last name, if we had neglected to use it. Then click on Search again, select Find . . . , and note that Tim is still in the Find what box. So click on Find Next once more, and MacWrite tells us that no more occurrences of that string have been found, as in the second window in Figure 5-6. We can also use a shortcut approach, by just hitting the Return key instead of clicking on Find Next; repeated hitting of Return will keep MacWrite looking for additional occurrences until it has searched the entire document.

Let us suppose, additionally, that we realize we have used the term Finance when we really wanted to say Financial Department. We can go to the Search menu and pick Change . . . , which produces the third window of Figure 5-6. We enter what we want found and what we want to replace it with. You can move back and forth between these two boxes by clicking or by using the Tab key. We then have three immediate choices. By clicking on Find Next, the next instance of Finance will be searched for and highlighted. Then the “Change” and “Change, Then Find” bars become active, permitting us to make the
Figure 5-6. Windows for Find . . . and Change . . . from the Search menu.

change, or make it and automatically move on to the next occurrence. Alternatively, we can just click on Find Next and not implement the change for this occurrence. Hitting the Return key instead of clicking on Find Next accomplishes the same thing.
We can also just click on Change All, in which case MacWrite will automatically search through the entire document, changing every occurrence of Finance to Financial Department without pause for user interaction. It provides us with the Alert box seen in Figure 5-6 as a warning of this, because it can sometimes have undesired effects. If you use Change All with Partial Word, for example, the string you specify will be changed when it is part of other strings, regardless of capitalization. (Changing "rest" to "remainder" with Change All and Partial Word, for example, would turn "poorest" into "pooremainder" and "RESTAURANT" into "REMAINDERAUANT"!)

The third version of MacWrite offers some additional features based on the Search menu, which are not included in these illustrations. Find Next can be chosen from the Search menu itself, or with Command-F from the keyboard, which avoids having to reopen the Dialog box, therefore saving time. The Search menu also offers a Goto Page option (Command-G from the keyboard), tied into another new feature—the Scroll box shows the page number you are currently working on. It will sometimes be handy to be able to scroll to a given page.

Try some changes, to get a feel for how Find . . . and Change . . . actually work. They are simple and extremely useful. Among other things, Change . . . can be used to simplify typing. If you have a long and clumsy name or chemical formula, for example, which you will be using often in a document, you can simply type in one or two characters to represent it (for example, a "@" or a "+"); then, when you are all done, automatically replace all occurrences of "@" with the actual name. You do not have to be at the start of a document to search entirely through it. MacWrite will always go forward from where you are, and then loop around from the beginning of the document back to where it started. You can also use Copy and Paste to insert text in the Search Dialog boxes—copying in the document itself and then pasting after opening Find . . . or Change . . . ; usually, however, it is easier just to type the text in.

The Format menu also provides a number of MacWrite's distinctive capabilities, some of which we will discuss a bit later. A few of them can be handled here. For example, Title Page, when selected, results in the text of any header or footer we have designed (for example, page numbering) not being printed on the first page of the document; blank lines are inserted instead. Set Page # . . . permits us to specify that the first page of the document be numbered something other than one, with all subsequent pages in that document being numbered sequentially after it. It is set via a special window, as seen in Figure 5-7. Its
main use is when we are creating something longer than MacWrite's memory permits for a single document. We can then create as many separate MacWrite documents as necessary (sections, chapters, and so on), and still be able to correctly paginate the whole thing.

![New page number?](image)

**Figure 5-7.** The Dialog box provided when Set Page # ... is selected from the Format menu.

Insert Page Break does just that—it puts in a page break wherever we want it, regardless of how much text is on a page. MacWrite inserts page breaks automatically when the capacity of a single page has been reached (the number of lines will of course vary based on the type fonts and styles we have selected). But if you definitely want some text on a new page, you can force a page break anywhere you like. For example, in Trial Memo scroll down to the end of numbered paragraph 3, and click an insertion point at its end, after the word “down.”

![Insert Ruler](image)

The rest of the agenda is fine. As always, in the interest of brevity, keep Joe from straying off the subject. You can reach me as follows if you have questions:

New York  
Washington  
Cleveland  

The J and L  
Emery's  
Mother's

**Figure 5-8.** Manually inserting a page break in MacWrite.
Then go to the Format menu and select Insert Page Break, which will result in a window looking like Figure 5-8. The dotted horizontal line is MacWrite's page delineation marker, and the material at the bottom of the window is now on page two.

All the empty space now on the lower part of page one is, to MacWrite, a group of characters. As with other things in the Macintosh, those characters can be replaced, removed, copied, and so forth. Just move the pointer above the page break line and click—the empty space is highlighted. You can now remove it with the Backspace key, and the page break you inserted is removed as well; this is similar to the removal of carriage returns we saw earlier.

**MacWrite Rulers**

MacWrite uses rulers for a number of text formatting characteristics, and new rulers are inserted whenever you wish to make a change. Figure 5-9 illustrates and labels a typical standard ruler that MacWrite inserts at the beginning of every new document you create. We will look at each of its icons, and then see how variations can be created. Rulers are themselves windows and, like other windows, can be copied, cut, etc. (the starting ruler, however, cannot be removed).

An important MacWrite limitation is that only about six inches of horizontal space are allotted on the screen for text. One inch on the left cannot be used in any way; your left margin can only be at that point or further to the right. The default is one and one-eighth inches (the margin marker was moved further in on Sample Memo, a copy of which you are using here). And on the right, you can see only up to slightly past the seven inch marker, leaving a default margin of one and one-half inches on that side.

You can get closer to the right-hand edge of the paper by moving the whole window to the left and then increasing its size with the size box, to about the eight-inch mark, as in Figure 5-10. But this results in your not seeing all of the window on the screen, which is very clumsy for entering text. (You can, however, type in your text in the standard window, so that you see what you are doing, and then expand the window and change the margins just before printing.) Overall, you must learn to live with the window size MacWrite provides; by using the smallest type font with its smallest size you can get 100 or so characters on a line. This is less than the printer is capable of, but MacWrite will not easily permit more.
Figure 5-9. The MacWrite Ruler.
July 16, 1984
Robert
Elizabeth

Finance Meeting Agenda

Figure 5-10. The MacWrite window moved and the right margin extended as far as it will go.

On the right side of the ruler are four boxes for selecting line justification. The default, leftmost, is highlighted when any document is started, providing left justification, meaning that the lines are all flush on the left side but not the right. The user can choose, moving from left to right, centering of all text; right justification (as for headings and return addresses, for example); and full justification, where spaces are automatically added so that both the left and right edges of all lines (except short ones) are flush.

Click on each of these boxes to see how the appearance of the document changes. MacWrite does the reformatting instantaneously, which is one of the advantages of its keeping the whole document in memory.

The three boxes further to the left are for line spacing: single-space (the default), space and one-half, and double-space. This is the spacing MacWrite will insert as it word-wraps automatically from one line to the next, and is also the spacing created whenever the user hits the Return key—normally at the end of a paragraph. Click on each and observe the changes. Any ruler change can be undone by reselecting the previous setting, or by selecting Undo Ruler Change from the Edit menu (Command-Z from the keyboard). The latter is available, however, only immediately after you have changed the ruler.

The last box, labeled 6 lines/inch, is an addition to the third version of MacWrite. It lets MacWrite documents conform to the most standard form of computer printing, and will be useful for preprinted
forms and so on. It is also better for superscripts and subscripts, since it avoids the uneven line spacing which otherwise results.

The black triangles set left and right margins; they can be easily moved by just dragging them with the pointer to wherever you want them. Note that on the left there are actually two markers, as we can see more clearly in Figure 5-11. The larger triangle is the left margin proper, while the smaller one (with the "tail") is a paragraph indentation marker. It denotes where new lines created with a Return rather than via word-wrap should start. Thus, if you want an indent or an outdent for paragraphs, you would move the smaller marker to the right or left, respectively, of the left margin marker. If you want all lines to be flush on the left, you would keep the two together.

![Indent Demo](image)

When we enter text it will wrap around to wherever we have set our left margin marker, and then it will continue to start each line at that place. But when we use the Return key for a new paragraph, such as NOW, MacWrite will automatically begin the new line at the paragraph indentation marker.

Figure 5-11. A MacWrite ruler showing the left margin and paragraph indentation markers separated.

Finally, the two boxes with hollow triangles are tab wells, providing an endless supply of regular and decimal tabs, to be placed anywhere along the ruler we wish. You simply press on the box and drag the shadow of a triangle to where it is wanted. In Figure 5-12 we have added a standard tab marker at the three-inch mark and a decimal tab at the four-inch mark. To remove a tab marker, just drag it toward the bottom of the ruler; when it becomes boldfaced, release the mouse button and it will disappear.

The Tab key will move the cursor to the next tab marker, going on to the following line if there are no more on the line currently addressed. The decimal tab is for entering numbers, as for tables. Unlike a standard tab, which aligns things from the tab position rightwards, the decimal tab will line up decimal points at the tab marker, with the associated numbers to their left and right.
Here we have dragged two new tabs from the tab wells, a regular tab at the three-inch mark and a decimal tab at the four-inch mark. Now if I hit Tab >> the insertion point jumps to the next tab stop.

And if I want to enter numbers, with their decimal points aligned, I Tab to the decimal tab >>

<table>
<thead>
<tr>
<th>Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>4.55</td>
</tr>
<tr>
<td>26.347</td>
</tr>
<tr>
<td>1,892.044</td>
</tr>
</tbody>
</table>

and everything lines up correctly.

Figure 5-12. A MacWrite ruler with two new tabs set.

All of this provides a good deal of readily available versatility, so let's try it out. Scroll to the end of Trial Memo and click an insertion point after the word “Mother’s.” Then, from the Format menu, select Insert Ruler, which will give us a new ruler, as in the top window of Figure 5-13. Note that an inserted new ruler is a copy of the current one. Let's make some changes, as in the bottom window of Figure 5-13. Move the standard margins to the two- and six-inch marks, and the paragraph indent marker to one and one-half inches. Drag one standard tab to three and one-half inches and the decimal tab to five inches, discarding the other standard tab. Click on the box for one and one-half line spacing and the box for full justification.

The cursor should be beneath the ruler at the paragraph indent mark; if it is not, hit the Return key. Then begin typing text as in Figure 5-14. Don't use the Return key in the first paragraph—just let MacWrite word-wrap around. You should use a Return after the word “spacing” and then use the Return and Tab keys to insert the columnar items. (There may appear to be an additional, unset tab stop at the two-inch mark; that is because you are using an outdent, and MacWrite sees the standard margin marker as a tab also.)
This is a test of the operation of MacWrite's rulers. I have inserted a new ruler here so that I can observe its effects. I am using an "outdent" so that the first line of each paragraph extends five spaces to the left of the rest of the paragraph. I am also using one and one-half line spacing.

<table>
<thead>
<tr>
<th>Name</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Charles</td>
<td>$49.95</td>
</tr>
<tr>
<td>William</td>
<td>$132.50</td>
</tr>
<tr>
<td>Sam</td>
<td>$0.87</td>
</tr>
</tbody>
</table>

Figure 5-14. Entering text under a new ruler.
Now scroll to the beginning of Trial Memo and select the ruler there by clicking anywhere along its top (where the numbers are); it will invert. Copy it with Command-C. Then scroll back to the bottom, click an insertion point after "$0.87," and then do a Command-V for paste. You now have inserted a copy of the original ruler and any more text you type will conform to its specifications. This is easier than inserting another new ruler if you want the same format as before, but either method can be used.

Open the Format menu and select Hide Rulers, as in the top of Figure 5-15. This removes rulers from the screen, giving you more room to view the text you are entering. All rulers are still active,

Figure 5-15. Selecting Hide Rulers and Show Rulers from the Format menu.
however, and will control the format of any new text you insert in the areas beneath them. You can always select Show Rulers from the Format menu, as in the bottom of Figure 5-15, when you want to see them.

Now select the new ruler you have just copied after the entry for "Sam." Hit the Backspace key and it is gone. Then scroll up to the new ruler we created in Figure 5-14, select it, and hit Backspace again. Note how the nature of your inserted text immediately changes, as its formatting is now controlled by the original ruler at the top of the document. Then go to the Edit menu and select Undo Typing—your ruler is reinserted. It says "Undo Typing" because using the Backspace key, to MacWrite, is a typing action; if you delete the Ruler with Cut, the Edit menu will say Undo Cut.

The ability to insert new rulers with any desired settings at any point, and to cut, copy, and paste them, is really quite powerful. In some cases it is rather cumbersome, for example if you just want to center or right-justify one line of type. Sometimes you can achieve such an end simply by spacing to where you want to type, but often you will have to use a new ruler for even such simple changes.

Whenever you change a ruler's settings, all text between it and the next ruler (or the end of the document if there is no next ruler) will be affected. This should not be forgotten. For now, you can delete the new ruler and the new text; select the ruler and then drag down until all the new text is highlighted along with the ruler, then use the Backspace key. We will use the original Trial Memo to explore some additional features of MacWrite.

**Expanding MacWrite**

What you have learned in this chapter so far, plus your understanding of earlier chapters, will permit you to take extensive advantage of MacWrite's capabilities. You are already well prepared for productive word processing. But there are some additional MacWrite features that make it even more versatile, and we will look at those now. Make sure Trial Memo is open, and scroll to the top of the document.

**Headers and Footers**

Headers and footers are text that we want inserted at the top or bottom, respectively, of each page of the document we are working on
(except for the first page, if we have selected Title Page from the Format menu). They can be as simple as just a single page number, or as extensive as about one-third a page of text or pictures. We create them in special Header and Footer windows which are comparable to other windows in the Macintosh—we can change their size, copy material into them, delete it from them, and so on. They also have some unique features, such as icons that automatically report the time, date, or page number.

Go to the Format menu and select Open Footer, which will provide the window we see in the top of Figure 5-16. (The Header window is identical.) Note that it is a standard MacWrite window with its own ruler, size box, etc., but that it also has three special icons just below

![Image of Footer window](image)

Figure 5-16. The Footer window, blank and with text and icons entered for display in the document.
its title bar. Note also that the standard menus for Font, Style, and so on are available for this window also. The window, as provided, will permit up to six lines of text, but it can be made larger or smaller. Let’s insert a simple footer appropriate to the purpose of Trial Memo. We will use only the top line of the window; if we were to space down, the actual space reserved on each page for the footer would be increased.

Type in the name “Robert” followed by a comma and a space. Then go up to the calendar icon just under the window’s title, and drag it down just to the right of what you have typed. Now use the space bar to move the insertion point to just under the five and one-half-inch mark on the ruler, and type the word “page” followed by a space. Then drag the page icon (with the # sign) to the right of what you have typed. The window should now look like the bottom illustration of Figure 5-16. Then click on the window’s Close box. Scroll all the way down to the bottom of Trial Memo and you will see your Footer properly inserted, as in Figure 5-17. (If it does not appear, you probably clicked on Title Page in the Format menu, which would impede printing the footer on the first page of the document. Open the Format

![Figure 5-17. The bottom of a Trial Memo page showing the footer created by the window of Figure 5-16.](image-url)
menu and, if Title Page has a check in front of it, select it, which will toggle it off.)

Now select Open Header and click on its ruler box for centering text. Then, from the Style menu, select Shadow and 18 Point, hit the Return key twice, and enter the text you see in the top window of Figure 5-18. Then close the Header window, select Hide Rulers from the Format window so you can see the appearance of your document better, and the start of your new Trial Memo will appear like the bottom part of Figure 5-18. The added spaces, here, have increased the size of the top header margin, which you will sometimes want in

Figure 5-18. Creating a header in the Header Window, and its appearance in Trial Memo.
either a header or footer, but which obviously leaves less room for text on each page.

Note, in Figure 5-19, the selections for Display Headers and Remove Footers. These relate to display on the screen and in printing. If you create a header or footer and then choose Remove, it will not be seen on screen or in the printed document. It does remain in the file, however, and can be used later simply by selecting Display. If you want to completely remove a header or footer, select Open Header or Open Footer from the Format menu, then select and delete all of its text.

![Figure 5-19. The Format menu permits us to have headers and footers displayed or hidden.](image)

In addition to the provided icons for page number, date, and time, and text you type in, headers and footers can contain any Macintosh text, such as pictures transferred via the Clipboard—so long as they are not larger than about one-third of a page. Headers and footers can also simply include space—if you insert only carriage returns in the header or footer window, you will increase the size of top and bottom margins accordingly. This may not be useful very frequently, but will permit, for example, the use of preprinted letterhead stationery with MacWrite documents.

Note that there is no relationship between the Set Page #... facility of MacWrite and the Page Range specification available when you select Print. That is, you may have told MacWrite to number the current document starting with page number 43, so that its pages range from 43 to 49. So far as Print is concerned, however, you have pages 1 through 7, and partial printing instructions have to refer to them as such, regardless of the page numbers that may be printed in a header or footer.
Text and Pictures

One of the great advantages of MacWrite is its ability to incorporate all or part of documents created with other Macintosh applications, not least MacPaint. The combination of text and pictures is powerful, indeed. The techniques for doing this involve the same cutting or copying and pasting we have used before, with a couple of added features provided by MacWrite. The picture itself must be on the Clipboard, having been transferred there directly from MacPaint or from the Scrapbook; it is then pasted into your MacWrite document wherever you want it.

As an example, make sure Trial Memo is open, and click an insertion point at the end of the first line, after the word "Agenda." Then, from the Apple menu, select Scrapbook, and page through it, if necessary, until you see the picture in Figure 5-20 (if you no longer have that picture, you can use any other). Choose Copy from the File menu, and then close the Scrapbook. Now, with the insertion point as above, do a

Figure 5-20. Calling up the Scrapbook from MacWrite to copy a picture to the Clipboard, preparatory to transferring it into a MacWrite document.
Command-V for paste, and the result, as in Figure 5-21, is the drawing inserted where we have asked, with the continuing text automatically moved down to accommodate it.

![Figure 5-21](image)

Here are my comments on your proposed agenda for the Finance group meeting next week.

**Figure 5-21.** The same picture, after being pasted from the Clipboard into the MacWrite document.

Once inserted, the picture can be readily moved and also resized. To move it up or down, just click an insertion point to the left of the picture, and then use the Return or Backspace key to add or delete lines, thus moving the picture. To move it horizontally, first click on

![Figure 5-22](image)

**Figure 5-22.** Clicking on a picture provides a border, which can be dragged to move it horizontally.
the picture itself, which produces a border around it, as in Figure 5-22. Then position the pointer on either the left or right vertical border and drag to move, as we have done here. You can also use the three boxes on the bottom border to change the size and proportions of the figure. We have lengthened it in Figure 5-23 by dragging on the middle box. The two corner boxes permit both lengthening or widening, or both simultaneously, depending on the direction you drag them, as seen in Figure 5-24.

Figure 5-23. The center box permits lengthening or shortening a picture.

One thing that MacWrite does not permit is the addition of text to the right or left of any picture you have pasted into one of its documents. The picture, in effect, covers the width of the page regardless of its actual size. If you plan ahead, however, you can add text next to the picture when you create it in MacPaint, and then transfer the whole thing into your MacWrite document. If you use the same font in both instances, the effect can be very professional.

With these few techniques, combined with MacPaint’s sophisticated abilities to create pictures in the first place, you have considerable power over graphic displays in MacWrite documents. Moreover, the same techniques can be used to move tables from spreadsheets, data or diagrams created by BASIC programs, and so forth, also into
MacWrite documents. As more and more applications for the Macintosh emerge, there will be that many more formats of materials that can be merged into MacWrite.

**Forms**

The current version of MacWrite does not have true "boilerplate" capabilities, where you can store frequently-used text in a set of files, and automatically read any one file or group of files into the one you are working on. You can achieve this end with cutting and pasting, which is super for what the Macintosh does well, but not adequate to the demands, for example, of a legal office which wants to insert lengthy standard sections into developing documents. But it is possible to create forms for many uses, greatly expediting their use under MacWrite. Letterhead stationery is the most obvious example, but others will appear as you begin to turn the Macintosh to practical applications.

We can use a letterhead for an example of forms creation, however, that will suggest the possibilities. Whether for business or personal
use, there is no need to constantly enter the same text for each new letter. Rather, as we have seen above, you can create the basic form, and then, whenever a "piece of stationery" is required, either duplicate it or use Save as . . . to create new copies. Let's Close Trial Memo from the File menu, and then select New for a new MacWrite document. We will set up our rulers and headings for a business stationery pad.

In this case, we want our original ruler to specify centered align-

![Figure 5-25. Developing a letterhead form in MacWrite.](image-url)
ment and single spacing, and will use also some distinctive text styles for a nice appearance. We could even design a logo in MacPaint and make it part of our letterhead. The effect of this is seen in the top of Figure 5-25. Next, we will enter the word “date,” having reselected plain 12-point type, and then insert a second ruler that we want for the body of our letters. On this ruler, we specify a paragraph indent, tabs at the two- and four-inch marks (the latter for automatic placement of our closing and name), and left justification. And we then insert the word TO where the recipient’s address will be. This is reflected in the second window of Figure 5-25.

There are specific reasons for the insertion of “date” and “TO,” related to the way in which MacWrite handles rulers and changes of font without any text present. If we did not have the word “TO” there, for example, any text we began to enter would still be controlled by the original ruler, unless we have the second ruler displayed, which interferes with seeing how our document will look. Since our whole aim with this exercise is to save time and effort, that would not be a good way to proceed. Now, however, we can select Hide Rulers from the Format menu and save the document with the rulers hidden. Then, when we open a copy, we just select the word “date” and replace it with the current date, and then select “TO” and replace it with the address we are writing to, and we are automatically entering text under the control of the second ruler, as in Figure 5-26.

![Figure 5-26. Using our letterhead replacing the dummy entries.](image-url)
Needless to say, our standardized text could be much more elaborate, not only with pictures and font selections, but also with standardized headers and footers. You should now try designing one of your own, saving it with an easily recognizable name. Then just Open it, and use Save as . . . to have a fresh copy without disturbing the original whenever you require a piece of "stationery"—all the busy setup work will have been done ahead of time. And the same can be done for statements, invoices, whatever, with all fields defined and only the pertinent data waiting to be filled in.

**Tables**

Creating tables and columnar data with MacWrite is possible, but a bit clumsy. The inability of the MacWrite user to turn word-wrap off and to have no justification at all can make it frustrating to try to precisely position things on the page. Indeed, it is often easier to create your tables with MacPaint, and then copy and paste them into your MacWrite documents. But simple tables can be created directly in MacWrite by the judicious use of the space bar and tabs, and we will review the process here.

Close the current document and open a new one. We will now create the screen illustrated in Figure 5-27. The default ruler is changed only in clicking on the box for centering all text, and then the headings are put in (the first line is in 24-point boldface, underlined, and the second line is in 14-point plain text). Then the second ruler should be inserted, with one and one-half line spacing and left justification. We have moved the default tab stop from the 5½-inch mark to 4¾ inches, and inserted two additional tab stops at the 2½- and 3½-inch marks, plus a decimal tab stop at 6 inches.

If we want the column headings centered over their associated data, as is the case with the words "Delicious" and "Revenue," we have to use the space bar for positioning them. This is rather clumsy with MacWrite because of our inability to turn word-wrap or justification off, but using auto-repeat of the space bar helps. Then the actual items are easily entered, using the Return key for each line and the Tab key to move from column to column.

In Figure 5-28, we are adding a new column. To do this, first add another tab marker where it is wanted; in this case, we have moved the other tab markers first to make room. Then click an insertion point just in front of each Revenue amount—in this case we are up to the third line ($696.50). Type in the new entry, as we are doing here,
and then hit the Tab key to move the amount over to its new place. The values in the Revenue column are changed quite simply by just selecting the text and typing in the new amounts. MacWrite does not have the ability to define “column blocks” and work on a whole column at one time, so we have to do it line by line. Once again, if we want all the column headings centered over their values, we will have to use the Backspace key and space bar with care; backspacing, for example, will often remove the spacing of the tab as well. With some experience, this will become more intuitive, but never really easy.

To remove a column, we must also work line by line. In this case, as in Figure 5-29, we are removing the Pippin column. We select the text we want to remove plus all the empty space up to the next tab marker, and delete it with Cut or the Backspace key. This will remove everything in that tab position and bring the next column leftward. There is still a bit of work left relative to centering the column headings in this example.

Thus it is possible to create nice looking tables with MacWrite; certainly, you have powerful display abilities with the use of varying type fonts, sizes, and styles. But it will look even better, and be considerably easier if the columnar setup is complex, to do it in

<table>
<thead>
<tr>
<th>Month</th>
<th>Macintosh</th>
<th>Pippin</th>
<th>Delicious</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>January</td>
<td>42</td>
<td>37</td>
<td>18</td>
<td>$384.80</td>
</tr>
<tr>
<td>February</td>
<td>67</td>
<td>46</td>
<td>32</td>
<td>$414.90</td>
</tr>
<tr>
<td>March</td>
<td>85</td>
<td>60</td>
<td>56</td>
<td>$696.50</td>
</tr>
<tr>
<td>April</td>
<td>90</td>
<td>65</td>
<td>60</td>
<td>$795.90</td>
</tr>
</tbody>
</table>

*Figure 5-27. Creating a table with MacWrite.*
### Figure 5-28. Adding a new column in the table.

<table>
<thead>
<tr>
<th></th>
<th>Mac</th>
<th>Pippin</th>
<th>Del</th>
<th>Golden</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>January</td>
<td>42</td>
<td>37</td>
<td>18</td>
<td>20</td>
<td>$406.80</td>
</tr>
<tr>
<td>February</td>
<td>67</td>
<td>46</td>
<td>32</td>
<td>22</td>
<td>$499.50</td>
</tr>
<tr>
<td>March</td>
<td>85</td>
<td>60</td>
<td>56</td>
<td>37</td>
<td>$696.50</td>
</tr>
<tr>
<td>April</td>
<td>90</td>
<td>65</td>
<td>60</td>
<td></td>
<td>$795.90</td>
</tr>
</tbody>
</table>

### Figure 5-29. Removing a column from the table.

<table>
<thead>
<tr>
<th></th>
<th>Mac</th>
<th>Del</th>
<th>Golden</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>January</td>
<td>42</td>
<td>18</td>
<td>20</td>
<td>$406.80</td>
</tr>
<tr>
<td>February</td>
<td>67</td>
<td>32</td>
<td>22</td>
<td>$499.50</td>
</tr>
<tr>
<td>March</td>
<td>85</td>
<td>60</td>
<td>56</td>
<td>$696.50</td>
</tr>
<tr>
<td>April</td>
<td>90</td>
<td>65</td>
<td>60</td>
<td>$795.90</td>
</tr>
</tbody>
</table>
MacPaint or another application and paste the results into your Mac-Write document.

You now have both the general tools and specific MacWrite skills required to do extensive and sophisticated word processing. If MacWrite is not the most powerful word processor around, it is nonetheless quite satisfactory for a wide variety of purposes. Moreover, its ease of use plus its considerable number of distinctive abilities (such as type selection, easy cut and paste, and movement of material from other applications) make it in fact very powerful in its own right. As with any application, the more you use and explore it, the more you will be able to take advantage of its abilities, and the easier it will become.

Checklist for Chapter 5

1. _Clicking_ and then _shift-clicking_ permits easy selection of large blocks of text. This can also be done by dragging the pointer off the top or bottom of the screen.
2. _Double-clicking_ in front of or on any word or space selects the whole word or space.
3. After selecting a block of text, using the shift key while dragging permits _partial deselecting._
4. _Superscript_ and _subscript_ are accessed from the Style menu (or Command-H and Command-L from the keyboard). Use small type to minimize clumsy line spacing.
5. _Undo_ and _Redo_ in MacWrite specify the action that can be undone or redone.
6. _Find . . ._ from the Search menu permits finding any occurrence(s) of any _string_ in the document.
7. _Change . . ._ from the Search menu permits finding and, if desired, automatically replacing any string in the document.
8. Selecting _Title Page_ from the Format menu results in the text of headers and footers not being printed on the first page of the document.
9. _Set Page # . . ._ in the Format menu permits starting the document with a page number other than one.
10. _Insert Page Break_ from the Format menu permits forcing a page break anywhere one is desired.
11. _Rulers_ permit formatting of all the text beneath them, up to the next ruler or the end of the document. Changing any ruler setting automatically reformats all text under its control.
12. New rulers can be inserted at any point, and they can be cut, copied, and pasted. All rulers can be shown or hidden via _Show Rulers_ and _Hide Rulers_ in the Format menu; either way, they remain active.
13. Practically, there is a maximum of six inches of horizontal space available for each line of text.
14. Lines can be left-justified, right-justified, left- and right-justified, or centered.
15. Line spacing can be one, one and one-half, or two; or it can be set to six lines per inch.
16. Margins are set by dragging the black margin markers where wanted on the ruler’s inch scale.
17. The paragraph indent marker permits automatic indenting or outdenting of the first line of each paragraph, as defined by use of the Return key.
18. Standard and decimal tabs are dragged from the tab wells and placed on the inch scale of the ruler.
19. Headers and footers have their own windows, and can be up to one-third of a page in size. They work just like standard MacWrite windows, but also have special icons for date, time, and page number. They can be shown or hidden by selecting the Display and Remove Headers/Footers choices in the Format menu; either way, they remain part of the document.
20. Pictures or text from other applications can be pasted into MacWrite documents. Click on a picture to create a border for its manipulation.
21. Select Tall Adjusted from the window created from Page Setup on the File menu for more accurate printing of MacWrite documents that contain pictures.
22. Standardized forms, such as letterheads, can be created with fonts, rulers, etc., all established, and then saved. By using Duplicate or Save as . . ., we have a preformatted form for filling in.
23. Tabular material can be created in MacWrite through the careful use of rulers and tabs. Complex tables should be created in other applications and pasted into MacWrite.
MacPaint

Introduction / 150

Using MacPaint / 151
  MacPaint Tools / 152
  MacPaint Menus / 160

Expanding MacPaint / 164
  Selecting and Manipulating Objects / 164
  FatBits / 168
  Brush Mirrors / 172

Advanced MacPaint Facilities / 175
  Constraining and Stretching / 176
  Advanced Copying / 180
  Saving Time / 181

Checklist for Chapter 6 / 183
Introduction

MacPaint is the Macintosh's creative drawing program. It is quite extraordinary in the world of personal computers in terms of its power and ease of use, comparable only to the more structured LisaDraw on Apple's Lisa computer. MacPaint's specialty is really free-form as opposed to structured drawings (Apple is releasing MacDraw for the latter); however, with some experience and care, diagrams, flow charts, floor plans, and the like can be created. Moreover, it has some creative and artistic facilities that clearly exceed those of LisaDraw. One of its larger drawbacks is its ability to only deal with slightly less than one-third of a page at a time, and a general clumsiness in extending any one element across more than that space. This can be done, however, by applying the techniques we will learn in this chapter.

The program is extremely versatile, with what sometimes seems an infinite variety of tools. Whole books devoted exclusively to MacPaint will appear but its key elements can and will be covered in one chapter. However, regardless of how much you may read, MacPaint is really something that can be fully learned only by exploration and experimentation. Fortunately, as with everything else on the Macintosh, you can get into it very easily, and learn its advanced operations over time, as they are needed. Moreover, they are all fun.

In this chapter, we will cover all of MacPaint's basics. As with earlier chapters, we will learn all the menus, plus, in this case, the specific MacPaint tools. We will also try to adhere to our established tutorial procedure, although this is a bit clumsier with MacPaint than with what we have covered in Chapters 1 through 5. Just try to duplicate what is described and demonstrated in the figures, but don't worry too much if your drawings are rather different. So long as you understand what is going on, you will be well on your way to mastering MacPaint.

Because MacPaint documents tend to be rather large, it is important to leave sufficient room on your diskettes. With a single-drive system, you will want the System Folder (minus Imagewriter) and MacPaint on the disk, but you should remove some fonts to save space. A few of the more decorative fonts are useful with MacPaint, but only one of the more standard fonts (New York, Toronto, Geneva, Monaco) is usually necessary. Also, when you finish with a drawing, copy it to a backup disk; try to leave about 60K free on your working diskette. With dual-drive systems, you can use your System Disk in the internal
drive, loaded with every font if you wish. And in the external drive you can have a diskette with only MacPaint; this will leave a great deal of room for documents.

Using MacPaint

Double-click on the MacPaint icon, and the application will open, providing a screen like that of Figure 6-1. The menus are quite familiar, although some of the choices under them are different from what we have seen before, and the Goodies menu is new. Also, the two boxes or bars along the left side and the one along the bottom are unique to MacPaint. The blank drawing window, where we compose our drawing, is actually a window into a bit less than one-third of a printed page. Open the Goodies menu and select Show Page, which will produce the window seen in Figure 6-2. The portion inside the dotted-line box represents what we are currently working with. We will often want to use Show Page so that we can drag that box horizontally or vertically, in order to get to other parts of the full page for our drawings. For now, just click on Cancel to return.

Figure 6-1. A MacPaint screen ready for drawing.
MacPaint Tools

In Figure 6-3 we have exploded the three tool boxes in order to label them more clearly. We will refer to each as we go along. To start, click on the hollow rectangle icon, then go to the upper left-hand corner of the screen (note that the pointer turns into a + sign), press the mouse button, and drag down and to the right for an inch or so, which will produce a figure similar to that in the upper-left of Figure 6-4. Then select the filled oval icon, and go to the pattern bar and click on any pattern other than black (note that what you have clicked on now fills the leftmost, larger box). Go, also, to the line-selection box, and click on the top, dotted line. Move to the window, to the right of the box you drew, and drag again to create a borderless filled oval shape, as in the upper right of Figure 6-4.

Now select the hollow kidney-shaped icon, and also click on the middle line width in the line selection box. Go below the rectangle you drew (note that the + is thicker, reflecting your change in line thick-
Figure 6-3. The basic MacPaint tools.

ness), and draw a freehand shape of some kind—make sure you connect the lines to make a closed shape. Then select the hollow polygon icon and an even thicker line width; draw a shape under your oval. This works a bit differently: every time you want to end one side of the polygon, you click the mouse button, then release it to continue; also, when through, double-click to stop. (With filled freehand shapes, MacPaint will help you by closing the outline even if you don’t, but with the hollow ones you must make sure they are closed yourself.) When finished, you should have four shapes drawn, roughly like those of Figure 6-4.

Now select the paint can icon (also called the “bucket”), and click on a different pattern in the pattern bar. Note, as you move onto the
Figure 6-4. Drawing hollow and filled shapes with varying line widths for borders.

drawing window, that the pointer becomes a paint can. Move the icon so that the dripping paint is inside the hollow rectangle you originally drew, and click—any fully enclosed shape, including hollow text (or even thick black characters), can be filled with any pattern by the paint can. Fill the other two shapes you have drawn with different patterns. If you don’t like what you have done (or if you didn’t fully close the shape, in which case the paint will “spill over” onto the whole window!), remember the Undo selection from the Edit menu, which is available also under MacPaint.

Select the hand icon (also called the “grabber”), move the pointer to the drawing window (it becomes a hand), and drag your picture down a bit—the whole thing moves together, but only to a limited degree in a 128K Macintosh. You can move it more with a 512K Macintosh because of its expanded memory (the third version of MacPaint is changed only in terms of permitting faster operation with the “Fat Mac”). Then click on the text icon (the letter A) and click an insertion point in the top center of the drawing window. Select a font and font size from the appropriate menus, and from the Style menu select Align Middle. Then type in, “My First MacPaint Drawing.” (When you enter text, even using the Return key, so long as you don’t click the
mouse button you can make new font and style selections, and the text will be automatically reformatted.) You should then have something looking generally like Figure 6-5.

![Figure 6-5. The original drawing—titled and with shapes filled.](image)

Click on the selection box icon, position the pointer above and to the left of your oval shape, and drag so that the flashing line covers the whole shape. Now, when you move the pointer into the outlined shape, it changes from a + to an arrow; press and drag the whole shape to another position. Click anywhere else in the window to deselect. Then choose the lasso icon, and use it to draw a selection "rope" around another of your shapes; the shape's outline flashes to show it is selected. Move it, also, somewhere else in the window. The two selection icons do the same thing, but the lasso is easier to use for irregularly shaped objects, and it selects only the object without any surrounding space.

Now with the last shape still selected, do a Command-C for Copy and, when the disk stops whirring, a Command-V for Paste. You now have a copy of the shape, and the copy is selected. You cannot predict where MacPaint will put the copy, sometimes it may even be right over the original—but you can drag it where you want it. Then select the pencil icon, and use it to draw a free-hand shape or text in the drawing
window—it writes when the mouse button is depressed, and stops when it is released. The end result will be a window like that of Figure 6-6.

Let's leave this part of the drawing as it is and work on another part of the page. Go to the Goodies menu and select Show Page. Put the pointer anywhere on the page shown outside the box, and drag to position your drawing at the top center of the page. Then put the pointer inside the box, and drag the box itself below your drawing, as in Figure 6-7. The pointer, under Show Page, depending upon where you place it, can be used to move the whole drawing on the page or to select which part of the page will be available in the drawing window. (It can also be used to delete the whole drawing by dragging its image from the page to the desktop—don't do that now, since that action is not Undo-able.) Then click on OK, and the drawing window reappears, with our selected blank part of the page showing. As you begin to do full-page drawings, you will use Show Page frequently.

Select the straight line icon (below the paintbrush), and the thickest line width. Go into the drawing window and start to draw a line—note, as you move from straight to diagonal, its edges are rippled; that
is a function of the degree of resolution of the screen. Try it again, holding down the Shift key—this works as a constraint, forcing lines to be perfectly horizontal or vertical, even if your hand is not as steady as a brain surgeon's. You can easily do boxes or other closed shapes with the line icon, by releasing and then again depressing the mouse button at each corner, as in Figure 6-8. And if you do make a closed shape, you can then fill it with the paint can just as you do with predefined shapes.

Now select the spraycan icon and any pattern you wish, and use it just like the pencil for free-hand drawing. It can use any pattern, but its thickness is not adjustable. Try, also, using the Eraser, for any part of your line or spray painting that you don't like. You can Undo each individual erasure, but once you have released and again depressed the mouse button while erasing, you are engaging in a new action so far as MacPaint is concerned. So make sure you are happy with each erasure before you continue with it or select another icon.

The paintbrush icon is one of the most versatile in MacPaint. Go back to the Show Page selection and move the box to give us more room in the drawing window (if you have run out of room, you can
save or trash this document and open another one). Select the paintbrush icon, and then draw a shape or some free-form text in the drawing window. Note that it combines the powers of the pencil and the spraycan—we can draw anything with it, using any selected pattern. Now go to the Goodies menu and select *Brush Shape*, which provides the selection box we see in Figure 6-9. We can select any one of these shapes and sizes by simply clicking on it—the current selection is denoted by being surrounded by a box. You click on the one already selected if you do not wish to change the shape.

Select a few different brush shapes and patterns to get a feel for how they work, as in Figure 6-10. The illustrated box with three patterns in it was created by selecting a long vertical brush shape and using the Shift key to constrain to perfectly horizontal as the lines were drawn.

These are the basic MacPaint tools, all of which we have now covered in an introductory fashion. Several of them have advanced features, which we will cover below. But even what we have already dealt with is quite powerful, and capable of various combinations and manipulations that permit a good deal more creativity than these few
Figure 6-9. The Brush Shape selection box from the Goodies menu.

Figure 6-10. Using the paintbrush with varying shapes and patterns.

examples suggest. For now, print a copy of your document if you wish, and save it or trash it; then choose Close and then New from the File menu, to give us a blank page for a new MacPaint drawing.
MacPaint Menus

Figures 6-11 and 6-12 duplicate the menus available when using MacPaint. Note, in Figure 6-11, that these three menus are virtually identical to what we have used before. The main new element is the Align section in the Style menu. When we have selected text (the A icon), the Align choice affects the way the text we type will relate to our insertion point—centered around it, or left- or right-justified from it. In this figure, the title used Align Middle, whereas all other typing used Align Left. Since we are using MacPaint, we do have some additional capabilities from these menus, such as font sizes up to 72 point, and the ability to fill thick text characters with the paint can, as was done in Figure 6-11.

The File and Edit menus illustrated in Figure 6-12 are essentially similar to those we have seen before, but do have some additions. The first five choices on the File menu are entirely familiar, as is the last one. Revert, however, is new, and is best thought of as a large-scale Undo. If you have made more than one change to a document, so that something you want to undo can no longer be undone or easily erased, you can select Revert, which produces the Dialog box illustrated in Figure 6-13—if you click OK (or hit Return), the current version of the document will be junked and replaced with the last version saved. Be careful using Revert, since everything since the last save will be irrevocably lost. However, if you develop the correct habit of saving often as you work, it is a good way to undo a number of unwanted changes, particularly ones that may have ruined your drawing.

Printing from MacPaint is automatic, in that you do not have the paper size and page options available under MacWrite; it prints single copies in a standard 8-by-10-inch size only. You can select Print Draft rather than Print Final from the File menu, which prints a faster, somewhat lower resolution copy, but still retains all the fonts and patterns; the difference, in fact, is slight. Sometimes, with very dark drawings or a new ribbon, Print Draft will actually be preferable.

Print Catalog is a nice feature. When selected, it sends to the printer a listing of all the MacPaint documents on the current disk, including miniatures of the actual documents, as in Figure 6-14. The miniatures are not entirely clear, but are usually distinct enough to remind you of just what that picture was all about.

In the Edit menu, Clear works exactly the same as the Backspace key. Select any part of the drawing window with the selection box or lasso, and then choose Clear or use Backspace to delete it without
First,
choose font type.

Then,
select an outlined font size.

& then,
use the keyboard or Style menu to select a style, and the type of alignment you wish.

Figure 6-11. MacPaint menus for text manipulation.
Figure 6-12. The main MacPaint menus.
Revert to the last version saved?

OK Cancel

Figure 6-13. Dialog box for Revert selection from File menu.

MacPaint documents on disk DRAWING

Figure 6-14. Using Print Catalog from the File menu of MacPaint.

sending it to the Clipboard. The bottom six choices in the Edit menu deal with manipulation of any part of a drawing we have selected, permitting us to change their shading or orientation, as noted in Figure 6-12. We will demonstrate the operation of each of them in the next section.

The Goodies menu also contains some of the more advanced aspects of MacPaint. We have already looked at Show Page and Brush Shape. _Grid_ is a toggle, showing a check in front of it when on. It provides an invisible "magnetic" grid in the drawing window, which forces all drawing and writing to adhere to its lines. It is useful for structured graphics when you want to line things up very carefully; most of the time, however, it is best left off.

_FatBits_ we will use in some detail below; it is a superb tool permitting customization and precise editing of everything we draw and write. _Edit Pattern_ is identical to what we learned in Chapter 2 concerning customizing the desktop; it provides us with a Dialog box as in Figure 6-15, showing the currently selected pattern on the right and its magnified bit pattern on the left. By dragging the pointer through the latter, turning bits on and off, you can create customized patterns to use for filling your objects. _Brush Mirrors_ will also be considered shortly; it permits doing symmetrical drawings with the paintbrush.
Figure 6-15. The Edit Pattern Dialog box.

Select Introduction from the Goodies menu, and you will see a screen that summarizes the basic tools we have been discussing. Then select Short Cuts, which provides another information window illustrating keystrokes and double-clicks that eliminate the need to use the menus, thus saving some time. We will also deal with those in the Advanced section below.

For now, we have dealt with the immediately useful menu options as well as the basic tools, and this is a good time to explore a bit. Try to do a few drawings, using all the tools and all the menu choices you currently understand. Use Show Page to move the drawing window both horizontally and vertically on the page so that you can draw on all of it. And when you feel reasonably comfortable with what we have covered so far, go on to the next section, where we will expand our control of MacPaint.

Expanding MacPaint

Now that we have mastered the basics of MacPaint, we can increase our drawing abilities with some of its more powerful manipulative tools. By using the selection box or lasso to select one or more objects, or a part of a single object, and then applying these tools in a variety of ways, our control over drawings is considerably increased, and the variety of things we can do increases as well.

Selecting and Manipulating Objects

Make sure you have a new MacPaint window open, then select the paintbrush and draw a shape more or less like that on the left in
Figure 6-16—we want the arrow at one end distinctly larger than that at the other. Then use either the selection box or lasso to select the shape. Now select Clear and then Undo from the Edit menu, and then hit the Backspace key and then Undo from the Edit menu—either one entirely removes the selected object, without sending it to the Clipboard.

Now select Cut from the Edit menu or Command-X from the keyboard. The object is removed from our document and sent to the Clipboard; even though there is no Show Clipboard selection in MacPaint, what we have Cut is there. Then select Paste or Command-V, and it returns. As in other applications, this is how we can move things from one place to another, or from one application to another. Now choose Copy and then Paste, which creates a copy of our object. If you still see only one, that is because MacPaint has put the copy right on top of the original—drag the selected object and the original will appear from beneath it.

Deselect the copy by clicking anywhere else in the window, then select the Eraser and erase it completely. Then reselect the original, make sure it is in the upper left of the window, and do a Command-C
to copy once again. Now move to the right and draw an empty selection box _larger_ than the original object; then do a Paste—the copy appears in the selection box, filling it. By drawing a selection box we can predetermine both the location and the size of a copy of any object. This may distort the copy, however, so that for an exact copy you may not want to follow this procedure. You can enable the Grid from the Goodies menu to help in constructing the selection box more precisely.

Now we want to look at some of the ways the Edit menu permits us to change one or more objects. Get rid of the copy you just made, and then select the original object and copy it once more. Do a simple Paste and drag the new copy to the center of the window, leaving it selected. Select _Invert_ from the Edit menu and it becomes white-on-black; the whole area that had been selected is affected by this. Make another copy and select _Trace Edges_; look at what happens and then select Trace Edges again—this turns solid lines into outlines, and puts borders around all hollow ones. If you hold down the Shift key while selecting Trace Edges, a shadowed border is created. For Invert, it is better to use the lasso rather than the selection box, so that only the object itself is inverted. But for Trace Edges you must use the selection box and not the lasso.

![Diagram showing original object, inverted copy, trace edges copy, and copy with selected area filled.](image)

Figure 6-17. Using Invert, Trace Edges, and Fill from the Edit menu.
Now make one more copy, use the lasso to draw a selection circle around the lower arrow only, and then select Fill from the Edit menu—this fills any selected object with the current pattern, just like the paint can does. Unlike the paint can, however, this procedure covers the shape's border also, creating a borderless shape, like when the dotted line is selected for borders. The results of our actions so far appear in Figure 6-17.

Now select the original object once more and do a Command-C for a copy. Then select Show Page from the Goodies menu, put the pointer inside the dotted-line box, and pull the box down to a clean part of the page. Click on OK, and when the drawing window reappears, do a Command-V to Paste. Drag the object to the upper-left, and do another copy with Command-V, then drag the new copy to the center of the drawing window. Make sure it is selected with a selection box rather than the lasso, as that is required for what follows. Select Flip Horizontal from the Edit menu, and the object is reversed in the horizontal plane; if you did a perfectly proportioned drawing, you may not see any noticeable change. Then select Flip Vertical, and the reversal of the vertical plane will be quite clear, as in Figure 6-18.
Make another copy of the original object, and then select *Rotate* from the Edit menu; look at what happens and select Rotate three more times. As seen in Figure 6-18, this moves a selected object or objects 90 degrees counter-clockwise.

Seeing how these tools work is only the beginning. They become truly powerful when used with a group of objects or, sometimes even more, only part of an object. In Figure 6-3, for example, a "snapshot" of a MacPaint screen was taken using Shift-Command-3, as described in Chapter 3. Then individual parts of that document were selected and moved or deleted in order to have the exploded view the figure provides. A more complex application of this procedure was followed for Figure 5-9, which presents the MacWrite ruler in a vertical plane. This required extensive manipulation of the snapshot window, selecting parts of the ruler and rotating them individually, and then reuniting the parts. Such actions are complicated by the relatively small area a drawing window provides; if you do a rotation that forces part of an object outside the window, it will be lost. But with some care and experience, these tools in the Edit menu permit some effective graphics capabilities.

**FatBits**

Probably the most powerful editing and manipulating tool in MacPaint is *FatBits*, which we can now explore. If you still have a drawing current, Save and Close it, and then select New once more to get a fresh page on which to work. Select the paintbrush and draw, as in Figure 6-19, a rough approximation of the apple you see on the front of your Macintosh. Depending on your artistic ability, it may be better or worse than what you see in the figure, but that really doesn’t matter—

![Figure 6-19. Original apple drawing, with copy to work on.](image)
among other things, FatBits allows those of us who are not innately artistic to improve our drawings. Then make a copy of the drawing, so you will always have the original and can start over if you mess up with your editing.

Now we are ready to make modifications to our drawing. Drag a selection box over the top of the copy, as in Figure 6-20, and then select FatBits from the Goodies menu, the result of which will be a window like Figure 6-21. This is a highly magnified view of part of what we have selected—the actual part now being shown is indicated, regular sized, in the little window in the upper left-hand corner. If we realize that each character the Macintosh shows on its screen, drawing or text, is made up of a grouping of bits or dots, then the purpose of FatBits becomes intuitively clear: it permits us to turn on or off any individual dot on the screen.

Figure 6-20. Selecting a section of a drawing for manipulation under FatBits.

When using FatBits, all the other MacPaint tools remain available. We can erase with the Eraser, drag selection boxes, draw with any of the drawing tools, and so on—but, here, their actual bit patterns will be shown. The most useful tool, generally, is the pencil, because of its precision: if we click on a dot, it will be erased, and as we drag the
pencil all other dots we cover will be erased. Conversely, if we click on a white area, its dot will be turned on, and as we drag over other white areas they will be turned on as well.

In this drawing, we will use the hand icon to drag the very top of the stem into the window. As we can see, in the top of Figure 6-22, it does not really come to a nice point. So we can click on the pencil icon, and click two more rows of dots, the first with two dots and the second with one, as in the second part of Figure 6-22, the effect of which is immediately seen in the little window at the upper left. At any time, we can look at the overall effect of our FatBits editing by just clicking in that little window, which changes the display back to the drawing window; when we reselect FatBits, we go back to just where we were.

Now use the hand icon to drag down to the bitten-out part of the apple, and see if you can smooth it out a bit by adding and deleting dots. You will never get a curve smoother than what the Macintosh's screen resolution permits, but this is much more precise than free-hand drawing in the drawing window. Go back and forth to the drawing window to see how the whole thing looks. Note that the smaller the area you select while in the drawing window, the more
Figure 6-22. The apple stem's point before and after adding three dots to make it sharper.

precise you can be about which part of it appears under FatBits. As in the drawing window, you can use the Shift key with the pencil, eraser, etc., under FatBits to constrain their action to a straight horizontal or vertical line.

As illustrated in Figure 6-23, we have used the pencil to turn some dots on and off in the “bitten” part of the apple, and used the eraser to remove the whole right “shoulder” of the apple, then redrew it within FatBits using the paintbrush. We have also used the eraser to remove the part of the stem that extended down into the apple. And finally, from within FatBits we drew the dividing lines that permitted us to create with the paint can the rather bizarre combination of patterns this apple shows.

The point here is not whether or not this right-hand apple—or the one on your Macintosh—really looks better than the original, but, rather, to get a sense of how we can use FatBits to alter or create on a very precise scale. As your drawings get more complex, with various
shapes and text superimposed over one another, or carried from one
document to another, the ability to do such precise editing is ex-
tremely useful. In Figure 5-9, referred to above, when the MacWrite
ruler was taken apart, rotated, and put back together, small parts of
each end of the ruler were lost. Using FatBits, it was possible to
reconstruct a perfect match for the lost parts, even including ruler
hash marks and parts of numbers, with one small exception (which
you can search for when you have nothing better to do!).

Figure 6-23. The original apple and the copy altered with FatBits.

Brush Mirrors

Quite different in scale and effect from FatBits, but also very power-
ful, is Brush Mirrors, a selection that permits the easy creation of
complex symmetrical shapes with the paintbrush. Go to the Goodies
menu and select Brush Mirrors, that produces a Dialog box like that of
Figure 6-24. By clicking on any one or more of the lines shown, you
create a mirror or mirrors which will duplicate whatever you draw
with the paintbrush from one or more alternative perspectives. You
deselect any given mirror by clicking on its line, returning it from
thick to thin; and you turn off Brush Mirrors completely by clicking in
the None box. You can quickly tell if some Brush Mirrors pattern is
active by opening the Goodies menu—a check in front of Brush Mir-
rors tells you that it is on.

For now, just click on the vertical line, as in Figure 6-24; then click
OK to return to the drawing window, and select the paintbrush. You
have the option of using any of the paintbrush’s shapes and any
pattern, but we will start simply, with the default shape and black. In
Figure 6-25, we have simple examples of the operation of Brush Mir-
rors, with each labeled to show where the drawing started. Note that the closer you are to the center of the drawing window, the closer together the elements created will be.

Try a drawing somewhat like the first one in Figure 6-25; if it does not develop as you expect, just erase or undo. Then go back to Brush Mirrors and select the horizontal line, leaving vertical also selected. Try something like the second illustrated pattern. For the third pattern, we have clicked the horizontal and vertical lines to deselect those mirrors, and then clicked on the two diagonal ones. And for the final design, we have turned on all four mirrors. Try numerous combinations to get a feel for how they work; and try starting further away from the center of the drawing window in order to see its effect, as well.

If any of your designs went off the end of the drawing window, the parts outside the window are lost. This is a weakness of MacPaint, but also another place where FatBits can come in handy. You can use Show Page to move the drawing window horizontally or vertically, and then use FatBits to repair your drawing. Figure 6-26 only suggests some of the design possibilities, using varying brush sizes and patterns for drawing. The bottom one was slightly edited with FatBits and then the enclosed areas were filled using the paint can.
Brush Mirrors

VERTICAL

VERTICAL AND HORIZONTAL

BOTH DIAGONALS

ALL FOUR MIRRORS

Figure 6-25. Drawing with the paintbrush with Brush Mirrors in effect.
Advanced operations in MacPaint involve two fairly distinct capacities. The first consists of somewhat more sophisticated and precise ways to alter things we have already drawn, while the second involves shortcuts for getting things done faster by avoiding having to open
menus. Most of these actions are summarized, in one way or another, in the Short Cuts information window available from the Goodies menu. In Figure 6-27, we have exploded that window to permit somewhat greater labeling, and will be referring back to it as we go through this section.

![Short Cuts window, exploded for labeling](image)

**Constraining and Stretching**

Make sure you have a fresh drawing window available, and then create a drawing more or less like that in Figure 6-28. The stick figure can be created any way you like (this one was done with the oval and line icons, rather than free-hand), but you should try to enter the text
exactly as you find it in the figure. Before going any further, drag a
selection box around the whole illustration—stick figure and text—and then do a Command-C for copy. Then, using Show Page, move the
box down twice, and do a Command-V each time, so that you have
three separate copies of the same drawing window at different parts of
the page. Once done, use Show Page to move back up to the top copy.

This is some text entered in
12 point Geneva using Align
Middle to keep it centered. I
will use it to demonstrate
constraining and stretching of text.

Figure 6-28. Drawing and text to be used for Constraining and Stretching
eexercise.

Now drag a selection box around the stick figure. While depressing
the Shift key, drag the stick figure downward, then try to move it to
the right or left at the same time. As we learned before, Shift is a
constraint—it will let us use any tool only in a vertical or horizontal
(with some, also a 45-degree) plane; indeed, we can't even switch
from vertical to horizontal without first releasing the mouse button.
With the rectangular and oval shape icons, by the way, the Shift key
constraint permits them to produce only squares and circles, respect-
ively. Undo your change.

Now, with the stick figure still selected, hold the Command key
down while you drag it downward and to the right. This is the Stretch
control, permitting us to change the shape and proportions of our
objects. Select Undo from the Edit menu to get the figure back as it
was. Then select the block of text and do the same thing—holding
down the Command key, drag it down and to the right. It works also
for text, but the distortion can be even more noticeable, as seen in
Figure 6-29. Select Undo to get the text also back where it was.

Reselect the stick figure, and this time hold down both the Shift and
Command keys while you drag down and to the right. This could be
called constrained stretching, since it lets us stretch a selection but
maintains the same proportions as the original. The same applies to
blocks of text (remember that to the Macintosh there are no great
differences between pictures and letters), but, in order to maintain
proportion, this permits less latitude relative to the space required.
Figure 6-29 shows our stick figure stretched with Shift-Command, and
the text rearranged with Command alone.
This is some text entered in 12 point Geneva using Align Middle to keep it centered. I will use it to demonstrate constraining and stretching of text.

The stick figure was stretched using both the Shift and Command keys, while dragging, so that its proportions were not changed.

The text above was stretched by using the Command key while dragging it in its selection box.

Figure 6-29. A figure stretched with Shift-Command-drag, and some text stretched with Command-drag.

By a judicious use of stretching and constraining, alone or together, and in combination with other MacPaint tools, one can achieve a good deal of original creativity. In Figure 6-30, for example, we have made use of the pictorial Cairo type font, printing characters in the suggested 18 point size, and also in 36 and 72 point. And we have also used Shift-Command-drag to change the size of the original 18 point characters. Note also how solid characters (the big dinosaur) as well as hollow ones (the big locomotive) can be filled with the paint can. FatBits could be used on the larger figures to smooth out their contours, if desired.
Figure 6-30. Using the Cairo font, in various FontSizes and with Shift-Command-drag to stretch.
Advanced Copying

We have already noted that copying, cutting, and pasting work the same in MacPaint as they do in other Macintosh applications. One of the nice things available to us is the ability to create a drawing in MacPaint, and cut or copy all or part of it to the Clipboard or the Scrapbook. Then, it can be pasted into another part of the same drawing, a different drawing, or a MacWrite document.

There are also some special copying capabilities associated with MacPaint, since the process is so useful in this application. Use Show Page to get to another part of your page, where you have the original figures, as in Figure 6-28. Select the stick figure and then, while holding down the Option key, drag downwards—we have an automatic copy, without having to use the Edit menu or the Command-C/Command-V processes. Then select the block of text and do the same thing, with the same effect, as in Figure 6-31.

Now remove all the text and the copy of the stick figure from the drawing window, so that all you have is a single stick figure in the upper left part of the window. Use the lasso to draw a selection rope around the figure.

---

This is some text entered in 12 point Geneva using Align Middle to keep it centered. I will use it to demonstrate constraining and stretching of text.

This is some text entered in 12 point Geneva using Align Middle to keep it centered. I will use it to demonstrate constraining and stretching of text.

---

Figure 6-31. Making copies with Option-drag in MacPaint.
around the stick figure. Then, while holding down both Option and Command, drag the stick figure, which will create a chain of repeating copies as on the left in Figure 6-32.

The speed and smoothness you use while dragging will affect the placement and overall appearance of the copies, and it requires a good deal of experimentation to become good at it. The spacing of copies can be controlled, to some extent, by choosing varying line widths from the line-selection box; selecting a thicker line makes the copies stay further apart. The reason for using the lasso with the stick figure is that, if you use a selection box, the blank space in what you have selected will also be copied and the repeating pattern will not look as good. Since the lasso selects an object only, and not its surrounding space, this problem is avoided. Shapes like the repeating filled boxes on the right in Figure 6-32 can be selected with a selection box, since it can be made to fit the object precisely.

![Figure 6-32. Using Option-Command-drag to create repeating copies.](image)

Saving Time

The remaining items in Figure 6-27, and in the Short Cuts information window in the Goodies menu, relate to using the keyboard or double-clicking to save time with various editing actions. The upper-left-hand key (←), for example, does the same thing as Command-Z or Undo from the Edit menu (except, of course, in text mode, when it actually prints its characters). The left and right arrow keys (upper-
lower-case, it doesn't matter) can be used to automatically change FontSize (with the Command key) or the Font itself (with Shift-Command). Logically enough, the ⟨ key switches to the next item up on the relevant menu, and the ⟩ key to the next item down.

You can double-click on the selection box, to select the entire drawing window—for copying, deleting, etc. And you can double-click on the Eraser to erase the entire drawing window. Remember, also, that from Show Page you can delete the entire drawing by dragging it off the page to the desktop. If you change your mind before leaving Show Page, put the pointer back on the page image and drag in the other direction to bring it back; once you leave Show Page, this action cannot be undone.

Double-clicking on the hand icon automatically produces the Show Page window, and double-clicking on the pencil icon automatically selects FatBits, with the pencil selected as your tool; you can also double-click on the pencil again to return to the drawing window. When the pencil is selected while in the drawing window, holding down the Command key while clicking the mouse button also switches you to FatBits; and the same action in FatBits returns you to the drawing window. When you are working in FatBits with the pencil icon, holding down the Option key turns it into the hand icon to let you move a different part of the picture into the FatBits window; when you release the Option key, the pencil reappears.

Double-clicking on the paint brush icon takes you directly to the Brush Shape window, and double-clicking on any pattern selects it and produces the window for customizing that pattern. And if you hold down the Option key while dragging any shape, it will have one of two effects: with a hollow shape, the border will be in the current pattern rather than black (providing the easiest way to achieve this effect); and a filled shape will be made borderless. This procedure can create patterned lines also.

You should try all of these actions to see how they work. They are easy enough to forget if not used regularly, but just remembering that they exist can make your use of MacPaint easier and more powerful. That is why MacPaint provides the Short Cuts window from the Goodies menu—for a constantly available reminder of what these actions can do.

We have now covered all of MacPaint—every tool and menu selection, and all of its specific facilities. There remains a lot more that can be done, however, with these tools and facilities, as you will discover only by extensive use and experimentation. Particularly useful will be
the process of moving part or all of drawings to documents created with other applications, such as MacWrite. Whether your interest is in business-oriented designs and graphics, or just drawing for fun, MacPaint offers extraordinary possibilities which are there for your exploration.

**Checklist for Chapter 6**

1. The *drawing window* is where we draw; it can present almost one-third of a printed page at one time.
2. *Show Page* lets us choose what part of the page will appear in the drawing window, and move the whole drawing on the page.
3. The three *tool boxes* to the left and below the drawing window provide MacPaint’s basic tools.
4. *Hollow shapes* use whatever line thickness has been selected; *filled shapes* use the selected line thickness and the selected pattern for filling.
5. The *kidney* and *polygon* shapes permit freehand shaping; MacPaint will automatically close the filled ones, but not the hollow ones.
6. The *paint can* will fill any enclosed shape, including thick text characters, with the selected pattern.
7. The *hand* icon can move everything in the window, but only to a limited distance.
8. The *selection box* and *lasso* are dragged to select any part of the window for further action.
9. The *pencil* icon is for precise free-hand drawing.
10. The *straight line* icon can use any line width.
11. The *spraycan* will spray the selected pattern, but its width is not adjustable.
12. The *paintbrush* has many available shapes, selected from *Brush Shape* in the Goodies menu, and can use any selected pattern. It can also provide symmetrical drawings through selection of *Brush Mirrors* from the Goodies menu.
13. The *Align* choice from the Style menu affects justification of text relative to the insertion point.
14. *Revert*, from the File menu, replaces the current document with its most recently saved version.
15. *Print Draft* provides slightly faster and slightly lower resolution drawings than *Print Final*.
16. *Print Catalog* prints the name and a miniature representation of all MacPaint documents on the current disk.
17. *Clear* is equivalent to Backspace: it deletes the selected material without sending it to the Clipboard.
18. *Grid* is a toggle, providing an invisible “magnetic” grid that forces pictures and text along its lines.
19. *FatBits* provides a highly magnified view of any selected material, permitting bit-by-bit editing thereof. All standard tools can be used in FatBits.

20. *Edit Pattern* provides a highly magnified view of any selected pattern, permitting bit-by-bit editing thereof.

21. The *Eraser* can be used to erase anything in the drawing window.


23. *Flip Horizontal*, *Flip Vertical*, and *Rotate*, from the Edit menu, permit changing the orientation of the selected object(s).

24. Selected objects can be *constrained* and *stretched* by using the Shift or Shift-Command keys while dragging. They can be automatically *copied* by using the Option key while dragging. *Chained multiple copies* are created by using the Option and Command keys while dragging.

25. The *Short Cuts* window, available from the Goodies menu, summarizes numerous shortcut keystrokes that can be used with MacPaint.

26. Holding down the Option key while dragging a line or border, draws it in the currently selected pattern rather than black.
Reference

A  BASIC Programming / 187
B  The Internal Macintosh / 211
C  Macintosh Quick Reference / 221
BASIC Programming

Introduction / 188
BASIC / 189
Microsoft BASIC / 190
  MS-BASIC on the Macintosh / 191
  Using MS-BASIC / 192
  MS-BASIC Menus / 195
  MS-BASIC Features / 197
Macintosh BASIC / 200
  Using Macintosh BASIC / 201
  Macintosh BASIC Menus / 205
  Additional features / 207
Introduction

Many Macintosh buyers will not be interested in learning to write computer programs. They are buying the computer for what it can do with programs written by others. Indeed, the long-term success of the Macintosh will be determined, more than anything else, by the quantity and quality of the software written to operate on it.

There is certainly no great need for most computer users to learn to program. For all but the simplest tasks, programming is demanding and time-consuming, both to learn and to implement. And, on the whole, professionals are better at it than amateurs. Certainly, sophisticated programs like the word processors, spreadsheets, and graphics programs that most Macintosh owners want to use are well beyond the capacities of all but the most accomplished programmer.

Some Macintosh buyers will be very interested in programming, however, not least the university students who are buying the computer in large numbers, and may well be required to program. Moreover, there are some benefits for any computer user in learning a bit about programming if he or she has the time. It increases one's general sense of understanding the machine and feeling the master of it, since much of the mystery of computing disappears. It is not really terribly difficult to learn, given a modest expenditure of concentrated time. It can even be fun, to a certain degree, since programming uses the same kind of logical and puzzle-solving activities that many people find agreeable elsewhere.

More practically, some mastery of programming can be useful for any computer owner—less for grand designs than for quite simple ones. Often, you may want some simple things done that your sophisticated software does not bother with. A program of one or two dozen lines can fill that gap nicely. This can also save considerable money, when the alternative is buying another expensive program, only part of whose power you really need.

For example, spreadsheets and, particularly, accounting programs, are often rather weak on statistics, because statistics are little needed in the business applications for which those programs were written. Data base management systems are powerful for manipulating large bodies of data, but are often too clumsy or complex for small, specialized bodies of information you want controlled in a specific way. Both of these are areas where a little programming knowledge can come in handy for any computer user.
If you do decide to give programming a try, you will soon encounter an interesting phenomenon in the world of computing—people tend to identify with one or another computer language with the intensity of religious fanatics. This is amusing, but, for newcomers, frustrating as well. You certainly don’t want to put in a lot of time and effort learning a language that won’t be suitable for what you may later want to do but are not currently able to predict.

You will not have to go far to find people who assure you that Pascal is the only language for beginners to learn, that its “structured” format makes it the most powerful of the “easy” languages. And you need go only a bit further to find advice that C is the “most transportable,” that Logo is “recursive,” that Ada or Forth or Modula-2 is “the language of the future,” and so on. Certainly, you can very easily encounter arguments against learning BASIC, because it is “not structured,” “not standardized,” “too slow,” and so on, all of which is, to a degree, true.

But it is also true that BASIC is the universal language of microcomputers, used everywhere. BASIC is also, without doubt, the easiest broadly useful programming language to learn, particularly for people who remain amateur and occasional programmers. It is probably the only programming language that “ordinary” computer users can really teach themselves from a book. And there is little that cannot be done with BASIC—some quite sophisticated accounting programs and database managers, for example, have been written in that language. It remains at present the best language for newcomers to start out with, and, probably, for most people to stay with over the long term.

Moreover, two versions of BASIC have already appeared for the Macintosh, one issued by Apple Computer and the other by Microsoft, Inc. (Apple is also releasing a version of Pascal for the Macintosh, and other languages are already coming as well.) So in this chapter we will look into these BASICs, and their general characteristics.

This is not the place to teach BASIC programming, and no effort to do that will be made here. Books on BASIC for the Macintosh are already appearing. Rather, we will look into these two BASICs to define their general characters, and the ways in which they integrate into the Macintosh system. Our intention is to provide nonprogrammers with a “feel” for the languages on the Macintosh—how they look and, generally, how they operate. And for programmers, we hope to
suggest the ways in which each of these BASICs is similar to or different from what they have used elsewhere.

Given that we are not teaching BASIC here, and that most readers probably haven’t bought BASIC for their Macintosh yet, this appendix will not follow a tutorial format. Our focus will be on description, but those who do have BASIC can work along and try to duplicate the screens illustrated.

**Microsoft BASIC**

The main advantage of Microsoft BASIC (also called MS-BASIC on the Macintosh) is that it is as close to being an industry standard as anything in the world of microcomputers. Most 8-bit computers operating under the CP/M operating system, for example, use Microsoft BASIC. The BASICs on the Apple II and Radio Shack computers are, if slightly different, still by Microsoft and generally the same. This is true, also, of the BASICs that come with the popular current 16-bit computers, such as the IBM PC and its many “compatibles” that use the MS DOS operating system.

Thus, with MS-BASIC on the Macintosh, you can expect that BASIC programs written on most other microcomputers will run without requiring extensive changes; similarly, programs you write on the Macintosh will run equally easily on other computers. Moreover, if you have already used Microsoft BASIC on another computer, you will find yourself switching to the Macintosh version with almost no time needed for learning. Also, because Microsoft BASIC is so widely used, it is easy to get help with your own programming. Most microcomputer BASIC teaching guides and reference manuals use it as their model, and most professional or amateur programmers you may turn to for help will be familiar with it as well.

One important qualification, however, is that with implementations of BASIC, even among those written by Microsoft, there are always some differences. The number of statements (“commands”) tends to vary from one implementation to another. And there are often differences based on individual computer hardware characteristics (for the Macintosh, not surprisingly, BASIC is expanded with some commands to take specific advantage of its graphics and mouse). Thus, some conversion from one computer’s Microsoft BASIC to that of another computer is generally required. Overall, however, the greater part of programming, and certainly all the most frequently used statements, will be consistent with what is found on other computers.
MS-BASIC is an interpreted language. If that does not mean a lot to you, you needn't worry about it. But an interpreter, as opposed to a compiler, executes each line of programming individually, in series, rather than first turning the whole program into the binary codes that the computer understands. From the user's standpoint, this makes BASIC programming easier to write and test. Large programs do run considerably slower when they are interpreted, but for most Macintosh users that is not really a problem. Newcomers to computing are generally better off with interpreted BASIC, and many experienced programmers continue to use it for everything they do. Because of the Macintosh's powerful 16/32-bit microprocessor, the interpreted MS-BASIC runs quite fast—appreciably faster on the Macintosh than, for example, on the IBM PC.

**MS-BASIC on the Macintosh**

The main distinctiveness of Microsoft's Macintosh version, apart from some added graphics and mouse commands, is its integration in the general Macintosh environment—using the mouse, pull-down menus, windows, etc. This integration is not as full-scale as it should be, and some of the facilities you have found in such applications as MacWrite and MacPaint are not present. But you still have the Apple menu, windows, the desktop, some ability to cut and paste, and a general environment that, to the Macintosh user, will seem familiar. Moving data between MS-BASIC and other applications is not really easy, although Microsoft does provide information for doing it with its own MultiPlan spreadsheet program, and has turned the Clipboard into a device (comparable to the disk, screen, or a printer) which a program can write information to or read from.

Generally, Microsoft has retained traditional BASIC syntax, while adding the Macintosh way of doing things as an alternative. Thus you can select RUN from a menu, or type it in as would be the case on other computers, and you can type the traditional SYSTEM command as well as choosing Quit from the File menu.

The Microsoft manual, like most of those that come with BASICSs, is not really a teaching tool. If programming is new to you, you should look for a teaching book that uses Microsoft BASIC as its focus. The manual contains an introductory section of about 45 pages that really focuses on the program's use within the Macintosh environment, introducing a few special Macintosh commands and describing a few of the basic functions this version of the language provides. This is followed by a 140-page Reference Manual, where each individual
statement and function is described, with minimal examples. There are also eight appendices, some of general interest and some useful only to skilled programmers.

**Using MS-BASIC**

A startup disk containing MS-BASIC will produce a window looking like that of Figure A-1. The application icon is the one labeled MS-BASIC; the other icons with hand pointers are actual BASIC programs supplied as examples by Microsoft. To start a new program or just get BASIC up and loaded, you Open the MS-BASIC icon. If you want to directly run a program that already exists, you Open it. The menus at the top of the screen are the standard Macintosh ones, and not specific to this application.

![MS BASIC window](image)

**Figure A-1. The desktop under MS-BASIC.**

When we open MS-BASIC, we immediately see, as in Figure A-2, two of the application's three standard windows. Either one can be the active window and, as elsewhere in the Macintosh, the windows can be resized and moved, although these two cannot be scrolled through. The Command window is for entering program statements; most menu choices can also be typed into the Command window, if desired. The larger Output window shows the results of what we do—in this case, the lines of programming, which are transferred to it each time the Return key is pressed. In the figure, line 150 has just been typed, but the Return key has not yet been pressed. The Output window is also the place where the results of program execution will be seen. We
cannot do anything with the Output window, other than resize it; MS-BASIC uses it to communicate with us.

```plaintext
100 REM Demo program to illustrate MS-BASIC's windowing.
110 print "This program will count up to 10."
120 for x = 1 to 10
130 print x
140 next
150 end
```

Figure A-2. The Command and Output Windows of MS-BASIC.

When we type "run" or select it from the Control menu, the program executes and its results appear in the Output window, as in Figure A-3. One of the truly nice features of MS-BASIC consists of the List windows it offers us, as in Figure A-4. The List window shows us our program as we have entered it; we can change its size and also scroll vertically or horizontally through it, to quickly see whatever section of a program we want. Moreover, we can have up to three List windows on the desktop, permitting us to look at different parts of the program simultaneously. This is a great improvement over other computers' implementations of BASIC.

In Figure A-5, we have a rather busy desktop, which illustrates these capabilities. The Output window shows the execution of a program provided by Microsoft. ("Break in 150" indicates that the program has been stopped.) We have opened three List windows, each showing a different part of the program. And we have selected one of those windows, and then one programming line therein by clicking on it.
Figure A-3. The Output window showing the results of a RUN command.

Figure A-4. A List window.
This sends it automatically to the Command window. Now we have selected part of that line of programming with the pointer, and are prepared to change, cut, or copy it. These are the facilities that make MS-BASIC relatively pleasant to use on the Macintosh. The ability to have one or more List windows available at the same time a program is running, to scroll easily through them, and to quickly edit by moving lines to the Command window, makes writing and correcting programming easy. It would be more efficient, however, if we could edit in the List window itself, saving the extra step of copying the line first. Moreover, we have no ability to make changes in more than one line at a time, something that is generally easy to do in the Macintosh environment.

![Figure A-5. The desktop with three List windows showing, and a line of programming moved from a List window to the Command window for editing.](image)

**MS-BASIC Menus**

In Figure A-6 we see the four menus available from within MS-BASIC. The Apple menu is the same as under other applications; here
is one place where the presence of a calculator can come in handy. The File menu is also quite standard, although the Close choice will never be in black, since it is not implemented in MS-BASIC (at least in the first released version). As noted in Figure A-6, Microsoft has skimped on the implementation of Open ..., in that this does not produce a listing of the programs available on the disk. Rather, you must first use the standard BASIC "FILES" command to see what is available, and then, under Open, type in the name of the program you want.

Unfortunately, the use of Cut, Copy, and Paste from the Edit menu is quite limited under MS-BASIC. You can Cut or Copy selected text from the Command window to the Clipboard, and you can Paste from the Clipboard to the Command window. But the Command window can hold only one line of programming at a time; this has some value in editing the programs you are writing, but is not very powerful. The editing power provided is greater than is common with BASIC on other computers, but it actually takes little advantage of the Macintosh.

The Control menu is distinct to MS-BASIC, and includes the main commands one usually issues to BASIC programs. All of the commands can also be entered from the keyboard, either with the Command key (which works, under MS-BASIC, like the CONTROL key on other computers) or by typing in the command, or both. Run executes the program. It will stop automatically when it is done, or can be stopped at any point by selecting Stop (the standard Control-C), which will halt execution and indicate the line number being executed when interrupted. You can then go on to other things, or restart execution with Continue ("cont" from the keyboard).

The Suspend choice from the Control menu is equivalent to Control-S in other BASICS. It temporarily suspends program execution until any other key is pressed. Unlike other BASICS, Suspend is not used to halt program listings, since you scroll through List windows with the standard Macintosh scrolling controls. The Trace On and Off commands are also common to most BASICS and of use in debugging programs. When Trace is on, each line number will be printed to the Output window while the program executes, to permit seeing what line was executing if an error occurs.
MS-BASIC Features

There are a few additional features of MS-BASIC that are worth mentioning to further clarify its distinctiveness on the Macintosh. For one thing, MS-BASIC does away with many of the constraints found in other BASICs, which are really imposed by the operating systems under which they are working. For example, filenames can...
be up to 255 characters long; extensions to the names are entirely optional. Only alphanumeric characters are permitted, according to the manual, but we have used others without difficulty. Variable names can be up to forty characters long, all of which are significant. And strings or string variables can be very large indeed—up to 32,767 characters.

Instead of the usual disk drive designators (A:, B:, etc.), MS-BASIC uses the Macintosh convention of addressing volumes, which correspond to the names you give disks when they are initialized. If, for example, the disk in the external drive is named MY PROGRAMS, you load the program “picture” from that disk via Open from the File menu by calling it: “MY PROGRAMS:picture.” As noted, MS-BASIC does not provide you with a catalog of filenames when you choose Open. More important, it also fails to offer the EJECT option to permit loading a file from or storing it to a disk not currently in the drive(s). This is a very serious omission, and is particularly frustrating for owners of single-drive systems.

You have to be careful with output to the screen under MS-BASIC, because any lines created by program execution that extend beyond the borders of the Output window are lost. There is a WIDTH command, which can specify the working width of the screen, clipboard, and printer and communications ports; it is important to use it to control printing to the screen. Generally, with maximum screen width for the output window, you can have about 60 characters printed in one line, rather than the industry standard of eighty. Since MS-BASIC does not support any alternative type fonts, this cannot be changed, another unnecessary irritation.

There are a number of useful functions in MS-BASIC for support of Macintosh graphics and the mouse. Figure A-7 demonstrates a simple example, showing both the content of the program and its output. Line 100 is just a remark, and line 110 clears the screen. Line 120 uses the CIRCLE function to draw a circle; we need only specify the horizontal and vertical coordinates, and the diameter, all in terms of pixels. Additional refining commands are also available. Line 130 uses LINE for a straight line, specifying starting and ending coordinates. And line 140 uses LINE to draw a box: the line coordinates become the opposite corners, “B” tells MS-BASIC to draw the box, and “F” tells it to fill the box; 33 specifies using black as the color.

You can always specify black or white for any drawing action. And MS-BASIC has special commands (POINT and PSET) for addressing each pixel on the screen. Thus it is possible, working pixel by pixel, to
create variegated patterns, such as those in MacPaint, but MS-BASIC has no automatic functions for doing this.

There are special functions for reading mouse button status and the current horizontal and vertical positions of the mouse, as well as the starting and ending horizontal and vertical positions of mouse movement. This means the programmer can easily use the mouse as a dynamic device, and incorporate mouse movements into his or her programs.

**MS-BASIC Demonstration**

<table>
<thead>
<tr>
<th>Command</th>
<th>List</th>
</tr>
</thead>
<tbody>
<tr>
<td>100 REM Demo module to draw circle, 1</td>
<td></td>
</tr>
<tr>
<td>110 CLS</td>
<td></td>
</tr>
<tr>
<td>120 CIRCLE (320, 120), 50</td>
<td></td>
</tr>
<tr>
<td>130 LINE (320,60)-(320,180)</td>
<td></td>
</tr>
<tr>
<td>140 LINE (300,100)-(340,145),33,BF</td>
<td></td>
</tr>
</tbody>
</table>

*Figure A-7. Drawing three shapes with MS-BASIC.*

Beyond these features, one has all the standard characteristics of Microsoft BASIC, which is certainly a good and well-proven implementation of that language. The Macintosh version, however, is generally somewhat less powerful, in terms of number of statements, than the Microsoft BASICs on the IBM PC and compatibles. However, users who have done some programming on other computers will find it easy to continue their work habits with MS-BASIC on the Macintosh, which is probably its strongest recommendation. Moreover, Microsoft should have released Version 2.0 of MS-BASIC for the Macintosh by the end of 1984, and it is supposed to correct a number of the deficiencies noted above.
Moving from Microsoft's BASIC to Apple Computer's Macintosh BASIC is, in many respects, like moving from an early Apple II computer up to the Macintosh. It is a truly innovative and powerful implementation of BASIC, and one that takes full advantage of the Macintosh's many features by integrating fully into it.* Experienced programmers, and certainly those who want to write professional Macintosh applications programs, will be delighted with its powers. And newcomers to programming, although they may need a bit more time to get going, will never be bothered with some of the constraints common to most other versions of the language.

Some of Macintosh BASIC's key characteristics merit mention at the outset. First of all, it is not an interpreted BASIC, but, rather, a semicompiled one. That is, as each line of programming is entered, it is evaluated for correctness and then compiled into what Apple calls "B-code." Then, when the whole program has been written, only a very brief additional check of its structure is done before running. It is the B-code that is executed, rather than the source code typed by the user, which makes for much faster operation than is normal with interpreted BASICs. It is also quite "compact," requiring less memory and disk space than source code.

You lose relatively little of the interactivity of an interpreted BASIC in this implementation, since each line is checked when written, and also because of Macintosh BASIC's extraordinary debugging and editing facilities. And the increase in speed of execution is remarkable: close to truly compiled code without the long wait usually required for the process of compiling. In a number of standard comparative tests, for example, Macintosh BASIC executed programs much faster than MS-BASIC, and anywhere from 30 to 60 percent faster, or more, than the interpreted BASIC on the IBM PC.

Macintosh BASIC is also, to a certain degree, multi-tasking—able to do several things at one time. It can run more than one program at a time, and has unusually effective capabilities for one program to run inside another or to call other programs at any point, passing all kinds

---

*This is the only place in this book where software not yet commercially available is being discussed. This section is based on the "Alpha" pre-release version of Macintosh BASIC, supplied for review by Apple Computer. As such, Apple makes no representations relative to this software, and it is possible that the final version of the software will be not be identical to what is described here.
of information between themselves. It is also closer to being a structured language than other BASICs. Macintosh BASIC includes a number of procedures and structures that permit a more structured approach to programming, and may satisfy some of the criticisms generally applied to the language by its critics.

Macintosh BASIC also does away with line numbers. You can number your lines, if you wish, but the numbers will just be considered labels, and could as easily be replaced by words. Any line referenced by another line in the program does need a label, but that need not be a number. Consequently, Macintosh BASIC will not reorder programs according to their numbers as interpreted BASICs do. You have to put things precisely where you want them. The use of labels rather than numbers, and the removal of line numbers as a requirement, does make programming much more powerful and, once you are used to it, easier.

Most notably, Macintosh BASIC is fully integrated into the Macintosh system. Unlike MS-BASIC, this is unqualified. You can, for example, use alternate type fonts, extensive filing and editing selections, and easy cutting or copying and pasting; and you can easily move disks into and out of the system.

**Using Macintosh BASIC**

Macintosh BASIC starts up with a window like that in Figure A-8. The application's icon is the one with a flow chart and a hand; program icons, as on the right, are larger images of flow charts. When you open the Macintosh BASIC icon, this produces an entirely empty desktop with six menus, which will be discussed momentarily. Selecting New from the File menu produces a Listing window, always titled "Text of" followed by your program name, as in Figure A-9. Note that this is a typical Macintosh window—it can be moved, resized, scrolled through, and so forth. More important, you have the full complement of Macintosh editing characteristics right in that window. We can move the I-beam pointer anywhere, click an insertion point or drag, and change, add, or delete any text we want. This is certainly the easiest-to-edit BASIC in existence. Another lovely touch is that Macintosh BASIC automatically puts all reserved words (BASIC statement and function names) into a different font, to make them easy to spot.

The RUN command produces Macintosh BASIC's second standard display, the Output window, as in Figure A-10. Again, it is a fully functional window, unlike that of MS-BASIC, and what runs off the
top is still there. We are aware of no other BASICS that have this facility; what scrolls off the top of the screen in program output is always lost, except with Macintosh BASIC. You can easily print everything in the Output or Listing window (including what is not showing) from the File menu. Again, with most BASICS, if you forget to turn on

![Figure A-8. The Macintosh BASIC window on the desktop.](image)

![Figure A-9. A Macintosh BASIC Listing window.](image)
the printer before you start or from within your program, this is simply not possible. The program can be rerun, changed or not, in the same Output window, or, if the Listing window is active when the RUN command is given, new Output windows will be created each time. Any window can be closed from the File menu or its own Close box.

One feature of Macintosh BASIC that both beginning and experienced programmers will enjoy is the interactivity of its debugging or program correction features. When a programming error is discovered during execution, a Dialog box appears, such as in Figure A-11. It prints the line that caused the problem, along with an error message. And you can choose to proceed, or click on Debug to have Macintosh BASIC automatically identify the offending line in the Listing window, as in Figure A-12. Especially since Macintosh BASIC does not use line numbers, this is a very useful feature indeed.
Figure A-11. A Dialog box noting an error in programming.

for i = 0 to size%

Figure A-12. Macintosh BASIC's way of pinpointing errors in the Listing window.
Macintosh BASIC Menus

Macintosh BASIC is so full-featured that not all of its facilities can be covered here. But looking at its six menus can suggest some of these abilities, and they are presented in exploded form, with comments, in Figure A-13. The Apple menu is standard, as is the Fonts menu. The latter offers eleven fonts (including the pictorial Cairo) in five sizes, which can be applied to either window, permitting some nice effects in BASIC programs. The File menu has a number of facilities we have not seen before, and which are also quite distinctive to BASIC. In addition to opening a program, for example, we can also open a text file for viewing or editing; no other BASIC offers such an ability. Save Text permits saving the original text, rather than the B-code, to disk; and Save a Copy in . . . permits saving the text to a different disk. Save Output is also extremely clever, letting us automatically save the text in the Output window to disk. We can also print either a quick copy of the contents of any window, or a standard resolution copy, with a Dialog box for printing controls.

The Edit menu provides most of the facilities we have used in other Macintosh applications, including, here, the ability to paste materials directly from the Clipboard into the Listing window, thus immediately changing our program. Among other things, this is one way that standard programming procedures or subroutines can be added to any program. And Copy Picture permits us to copy any graphics created by Macintosh BASIC to the Clipboard, from where they can be pasted into MacPaint or some other application. This offers the option of combining graphics of your own creation with those created by MacPaint, or of using the latter to manipulate what you have created under Macintosh BASIC.

The Search menu will be appealing to anyone who has done much BASIC programming. It is essentially identical to the same facility in MacWrite, permitting searching and, if desired, replacing of any string in a window. A simple but useful example would be a case where we have defined a variable as a real number rather than an integer, realizing later that it should have been the latter. Rather than going through a listing changing every occurrence of variable name “month” to “month%,” we can just use Replace All and the change is made throughout the program instantaneously. In combination with Macintosh BASIC’s full-screen editor, which lets us edit the Listing window just the same as in MacWrite, for example, the overall editing abilities of Macintosh BASIC are outstanding.

The Program menu provides most of the standard program con-
### Macintosh BASIC Menus

#### Standard Apple Menu

<table>
<thead>
<tr>
<th>File</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Create new Listing window.</td>
</tr>
<tr>
<td>Open Program file...</td>
<td>Retrieve program file.</td>
</tr>
<tr>
<td>Open Data File...</td>
<td>Retrieve text file.</td>
</tr>
<tr>
<td>Close</td>
<td>Put file away, BASIC still active.</td>
</tr>
<tr>
<td>Save Text</td>
<td>Store copy of program.</td>
</tr>
<tr>
<td>Save a Copy In...</td>
<td>Store copy of program to other disk</td>
</tr>
<tr>
<td>Save Output</td>
<td>Store copy of Output window.</td>
</tr>
<tr>
<td>Print Quick</td>
<td>Standard printout of file.</td>
</tr>
<tr>
<td>Print Document...</td>
<td>Printout via Dialog box.</td>
</tr>
<tr>
<td>Quit</td>
<td>Leave BASIC, return to Finder.</td>
</tr>
</tbody>
</table>

#### Standard Macintosh actions:

- **Undo** (`%Z`)
- **Cut** (`%H`)
- **Copy** (`%C`)
- **Paste** (`%V`)
- **Clear**  
- **Select All** (`%A`)
- **Show Clipboard**  
- **Copy Picture**

**Fonts**

- Select Font and Size, no Style selection.

**Search**

- Find (`%F`)
- Replace (`%R`)
- Replace All (`%W`)
- What to Find (`%W`)

**Program**

- Run (`%H`)
- Halt (`%G`)
- Save Binary (`%U`)
- Check Syntax (`%U`)
- Checking Off (`%U`)
- Debug (`%D`)
- Step (`%S`)
- Trace (`%T`)
- Block Trace (`%B`)

**Figure A-13. The Macintosh BASIC menus.**
trols, plus a few more. For some reason, Macintosh BASIC does not offer a keyboard option for the RUN command, which is a bit clumsy. But most others, as the figure shows, can be entered with Command key combinations. Halt and Go are the Macintosh BASIC equivalents of the standard Control-C, to halt a program, and Continue to get it going again. Save Binary permits saving a binary code form of the program to disk; this is more compact for storage and runs faster. It cannot be read or changed, however, nor can it be converted back to text code. You can keep both text and binary versions of the same program on a disk, however.

Checking On/Off is a toggle. When On (the default condition), all lines of programming are checked for errors when entered. If Checking is Off, Macintosh BASIC will not check your syntax until you choose Check Syntax from the Program menu or run the program.

The last four choices permit sophisticated debugging of programs, and will be of interest primarily to more advanced programmers. Debug is a toggle, turning Macintosh BASIC's interactive debugger on or off. Step (Command-space bar) permits executing the program one line at a time; Trace runs it full speed, with the Tracing finger icon pointing at the line being executed. And Block Trace runs the program full speed within control blocks (defined by FOR/NEXT, IF/ENDIF, GOSUB, etc.), and one line at a time between them.

The effect of all this is both a powerful implementation of BASIC and considerable ease of use. People who have used the Macintosh but are new to programming will find the progression to BASIC smooth because of the consistent Macintosh format this BASIC uses. And more experienced programmers will find that Macintosh BASIC's mode of operation makes programming and debugging extremely agreeable.

Additional Features

Not surprisingly, Macintosh BASIC has extensive graphics capabilities, including support for the mouse. As with MS-BASIC, graphics development focuses on the pixel and lines. But it is also shape-centered, having built-in OVAL, RECTANGLE, and ROUNDRECT (rectangles with rounded corners) statements. Moreover, unlike MS-BASIC, Macintosh BASIC has Paint and Pattern commands, for filling shapes, and an Erase command for erasing them.

Figure A-14 is a simple example using the default patterns; any MacPaint pattern could be used, or you can design your own. The first
line draws a rectangle, whose corners are defined by the two pairs of horizontal and vertical pixel positions. The second statement makes the program wait for the mouse button to be pressed while the pointer is inside the Output window. Then the oval is drawn by line 3, and

\begin{verbatim}
frame rect 10,10;200,200
btnwait
frame oval 12,12;198,198
paint oval 12,12;198,198
\end{verbatim}

\begin{figure}
\centering
\includegraphics[width=\textwidth]{listing_and_output_windows.png}
\caption{Listing and Output windows for a graphics program.}
\end{figure}

filled with default black by line 4. Needless to say, much more sophisticated stuff can be done, but the programming involved is relatively painless, and Macintosh BASIC provides enough built-in commands and functions to make it easy for the new user as well as the advanced.

A few other characteristics of Macintosh BASIC also merit mention, even in a brief overview. Sometimes, little things can be significant. For example, Macintosh BASIC permits using either single or double quotation marks interchangeably, for example, for the delineation of strings. And this, in turn, permits actually using quotation marks inside of strings, which no other BASIC we have seen permits without the use of much clumsier programming steps. Even more impressive are Macintosh BASIC's control structures, which permit sophisticated looping procedures. One of these is the DO/LOOP structure and another is the FOR/NEXT structure, both of which have EXIT features.
The DO/LOOP permits an infinite loop of any size (other loops, of course, can be inside it), with any number of IF . . . EXIT statements to control the ending of the loop. It permits rapid and powerful looping with easy cessation of the loop or branching elsewhere. It is both easier to use and potentially more powerful than the WHILE/ WEND of other BASICS. And the fact that Macintosh BASIC's FOR/ NEXT loops can include an EXIT function avoids the potentially dangerous effects of jumping out of uncompleted FOR/NEXT loops characteristic of other BASICS.

Macintosh BASIC's PERFORM statement is also very useful. It summons another program and runs it, passing any desired values to the called program. Then, when the summoned program ends, control passes back to the original program, with any values from the called one which the original program asks for. The called program, moreover, can summon other programs as well. This provides extremely powerful and simple programming, not least for the use of some program modules inside numerous others. As such, it becomes a more powerful variant of using extensive subroutines.

Even with a pre-release version of Macintosh BASIC, which was not fully implemented and still had a number of bugs, it is easy to see that it is a distinctive BASIC, both in its own terms and in its tight integration into the Macintosh system. You lose, of course, a certain amount of compatibility with other BASICS, although primarily when going from the Macintosh to other computers. Of the seven standard speed measurement tests I tried, six of them ran with only insignificant modifications from what I used on an IBM PC, and the seventh failed to run apparently because of a bug in this pre-release version of Macintosh BASIC rather than because of incompatibility.

If you will be primarily using the Macintosh, certainly Macintosh BASIC is the BASIC dialect of choice; it is far more powerful than Microsoft's MS-BASIC, and, with a bit of experience, also easier to use. Even if you do use BASICS on other computers, Macintosh BASIC is worth trying out for your Macintosh programs because of its characteristics and abilities. Only if you really want to move programs between computers should you approach this BASIC with care, since a good deal of additional programming will be required.

By the time this book appears, Macintosh BASIC should be available, as well as the 2.0 version of Microsoft's MS-BASIC. If you are interested in BASIC programming, you should look at both of them.
The Internal Macintosh

Introduction / 212

The Motherboard / 215
  The Motorola 68000 Microprocessor / 215
  The Macintosh ROMs / 216
  Random Access Memory / 217
  Programmable Array Logic / 218
  Other Main Components / 218

The Analog Board / 218
Introduction

Any effective modern computer should permit people to make effective use of it without mastering extensive technical concepts or vocabulary. All do, to some degree, but with varying levels of success. The Macintosh, and Apple's Lisa also, are indeed distinct in developing this ability to focus on the work at hand to a degree well beyond that of other computers. To be sure, each application bears some of the responsibility for creating ease of use. But the Macintosh system does play a large role in facilitating the process.

Thus, in the body of this book we have been able to avoid technical detail, beyond some rudimentary descriptions of topics like the nature of the Macintosh's video display. We have also been able to avoid the extensive vocabulary of operating system commands that users of other computers have to master, because the Macintosh functions without them. You have no particular need to look any further into this computer's technical characteristics—any more than you need to know the intricacies of its systems software—unless, of course, you are interested in them.

For those who would like to know a bit about the innards of their computers, this appendix provides a brief description of some of the salient characteristics of the Macintosh's internal hardware. This will be a layperson's guide, noting where some of the main components are and what they do. In the process, you can learn a bit more about the nature of computers generally.

Unlike many other microcomputers, the Macintosh is not designed to be opened by its owners. There are no user-serviceable parts inside, nor is there any place to plug in an additional circuit board, as would be the case, for example, with an Apple II or an IBM PC. Even individual integrated circuits ("chips") are not user-replaceable, since they are soldered in. This is all part of the Macintosh design philosophy, and also relates to some of its economies of production. Thus, unless you are a certified electronics engineer, you would be well advised to keep your screwdriver at bay. Moreover, any attempt to open your Macintosh will void its warranty, which is an additional incentive to leave well enough alone.

Figure B-1 is a cut-away photo of a Macintosh, with a few items labeled. The CRT (cathode ray tube) used for video display is #1, the largest single item inside the computer's case. Second in terms of size is the disk drive, #2. To have had a larger video display, or two disk drives, would have required that the Macintosh be larger than it is,
and Apple engineers had to constantly weigh the advantages of small size and portability against those of possible features that could be included if the computer were bigger.

The Macintosh uses only two *boards* or *cards* of integrated circuits and other electronic components. The vertical one, #3, is the analog

---

*Figure B-1. Cut-away photo of a Macintosh.*
board; and the horizontal one, #4, barely visible in this photo, is the digital board, often also referred to as the motherboard, because it contains the most elemental components of the computer. Notable by its absence is a fan, which most computers require. The Macintosh's relatively high vertical space and its advanced engineering that uses far fewer components than usual, both help to hold down the amount of heat generated by the computer. Thus, the Macintosh operates in blessed, and relatively unusual, silence, except when some disk drive activity is taking place.

The Motherboard

Figure B-2 provides a better view of the motherboard, where the Macintosh's processing really takes place. Most readily noted are the integrated circuits that we tend to associate with computing. And those chips on the Macintosh are indeed marvels of advanced engineering, not least in terms of the small number of them required to make the computer go. The Macintosh design team was unusually successful in compressing what needed to be done onto just two boards and a relatively small number of chips, permitting the Macintosh to be both compact, even portable, and reasonably priced.

The Motorola 68000 Microprocessor

At the heart of the motherboard is its largest chip, the Motorola 68000 microprocessor, labeled #1, "a computer on a chip." The 68000 is one of the most powerful microprocessors currently available for small computers, equivalent to about 68,000 transistors, and has the capability to provide all the processing power even a multi-user system might require.

Microprocessors are generally classified in terms of their word size—the number of bits (Binary digits) which they are capable of processing at one time. The Apple II, for example, and the many business computers that operate under the CP/M operating system, are classed as 8-bit machines, since their word size is one byte (8 bits). That is, they can process information in 8-bit chunks, and move the data they are processing in 8-bit chunks along the BUS that connects their various parts. Since two words are generally used for addressing main memory, word size is also important in determining how much memory any computer system can use. The 8-bit machines, for example, can generally make use of only 64K of main memory, because with two 8-bit words that is the most they can keep track of.
Figure B-2. The Macintosh motherboard.

A 16-bit computer operates, generally, much faster than an 8-bit one, since it deals with information in larger chunks. It can also address much more memory, because using two 16-bit words to keep track of addresses, up to one million memory locations can readily be handled. This is why such machines are so popular today, particularly for business and professional applications. The IBM PC is a 16-bit machine, but of a hybrid sort. Its Intel 8088 microprocessor does use a 16-bit word size for processing and addressing, but moves data only 8 bits at a time, just like an 8-bit machine. That is why in many applica-
tions it is not much faster than a computer like the Apple II. Many of IBM's rivals are using the Intel 8086 microprocessor, among others, that uses 16-bit words for all purposes, including the transfer of data. They are, therefore, often much faster than the IBM.

This sets the stage for the 68000, which is also a hybrid, but at a higher level. For processing and addressing, it is a true 32-bit microprocessor—one of the very first to achieve that level of power on a single chip. This means that it is not only much faster at processing information than an IBM PC, but also that it can address much more memory—up to 16 million bytes (megabytes) in fact. But for the transfer of data, the 68000 uses a 16-bit word size, which is slower than if it used 32 bits for data transfer as well, but still more than double the rate of an IBM PC. Thus, while Apple advertises the Macintosh and the Lisa—which uses the same microprocessor—as 32-bit machines, this is only partially true, but not really incorrect.

Another important characteristic of any microprocessor is what is generally termed its clock speed or frequency, generally expressed in megahertz (MHz). Two computers using the same microprocessor will do their work at different speeds if the clock speeds of their microprocessors differ, which is not at all unusual. Some 8-bit machines operate at only 1 or 2 MHz, for example, while others operate at 4 or 6 MHz. The IBM PC's 8088 operates at 4.77 MHz, but some of its rivals have 8088's that run at 7 MHz, which results in overall speed of operation that is 30 to 50 percent greater.

The clock speed of the Macintosh's 68000 is 7.83 MHz, which is not the fastest among 68000 implementations (some run at up to 10 MHz), but is nonetheless quite respectable. And, when compared to other single-user microcomputers, the increased clock speed along with the 32-bit word size make this a powerful machine, indeed. All of that power, however, is constrained by the 128K main memory of the original version of the Macintosh, which really fails to take advantage of it.

The Macintosh ROMs

Just above the 68000 are the two Macintosh ROM (read only memory) chips, #2, containing together 64K of information that is permanently installed in the computer, available to all applications. The ROM programs, generally referred to as routines, are an extension of the operating system, and make many of the Macintosh's operating characteristics (drawing graphics to the screen, monitoring mouse
and keyboard, creating menus and windows, for example) readily available to programmers. They thus serve as an aid to those who write new applications for the Macintosh, minimizing the programming that has to be done to integrate any application into the Macintosh system.

Another advantage of the Macintosh's highly sophisticated and relatively large ROM is that it leaves more free space on startup disks and more of the computer's main memory free for other purposes. This is very important in a computer as short of available memory space as the 128K Macintosh.

**Random Access Memory**

The two rows of eight chips each, labeled #3, are the main or random access memory (RAM) of the Macintosh. Each chip holds 64K bits of memory in the 128K version or 256K bits in the 512K version, so each row of eight holds 64K or 256K bytes, respectively. (Remember that one byte is equivalent to eight bits, which is what is used to represent a single character.) And since memory is always described in terms of bytes, this explains the Macintosh's total RAM of 128K or 512K.

As you can readily see, there is not much empty room on the motherboard, which is the main reason the original Macintosh has only 128K despite the fact that its microprocessor can address far more. And this is, in fact, one of the computer's main weaknesses—it limits the size of documents you can create with MacWrite, for example, and is the reason for the disk swapping you have to do when copying disks. It will also impede the development for the Macintosh of some of the more interesting applications programs currently being developed for 16-bit computers like the IBM PC; many of them require larger amounts of RAM in order to function.

The increased availability of 256K-bit chips permitted the release of the 512K "Fat Mac" earlier than Apple had originally anticipated. And it does provide its owners with a considerably more powerful machine, although at a fairly stiff price. Not only will it run current applications faster and more efficiently, but, increasingly, applications will be coming along that will work only in the expanded machine. Owners of the 128K Macintosh can go to their dealers for a replacement motherboard with the expanded memory. If and when this can be combined with double-sided disk drives, permitting 800K storage per diskette, the power and ease of use of the Macintosh will increase enormously.
Programmable Array Logic

Above and to the left of the 68000 are a group of Programmable Array Logic (PAL) chips, #4. Like ROMs, they contain programming or routines used for a variety of purposes by the Macintosh. But they are different in that each one really does the work of an entire circuit board that would contain many individual chips. They are therefore highly compacted programming, and are important in keeping the Macintosh as small and as cool-running as it is.

Other Main Components

The large chip labeled #5 is the Macintosh's disk controller, also something that on most computers requires a rather large circuit board containing numerous integrated circuits. Next to it, #6, is the serial communications controller, which is in charge of the two high-speed serial communications ports. These are officially dedicated to the Imagewriter printer and a modem, but are in fact quite versatile and can be used for other things as well. Networking of numerous Macintoshes into an integrated system, when it comes, will use one of these ports.

Next to the serial communications controller, labeled #7, is the Versatile Interface Adapter, which serves the integration of the microprocessor with mouse, keyboard, and so on. And the small chip above it, #8, is the Macintosh's real-time clock. This is used both for the clock you can access from the Apple menu and for any activities inside applications that make reference to the time or date. At the upper left of the motherboard, #9, are the reset and interrupt switches, which are activated by the Programmer's Switch if you have installed it.

There are, as you can see, numerous other components on the motherboard, including a variety of additional electronics and connectors. Several connectors tie the motherboard into the other components of the internal Macintosh, and the rest, which we have discussed in Chapter 1, connect it to external devices.

The Analog Board

The analog board, illustrated in Figure B-3, contains some of the less "interesting" circuitry of the computer, which is nonetheless essential to its operation. Not least of these is the power supply, whose level of power and consistency of performance is crucial for trouble-
free operations. It consists of several components on this board, the most evident of which are the transformer, #1, and the line filter, #2. Together, they work to keep the Macintosh's power supply clean and steady, which is very important.

The speaker, #3, is part of what is, for a computer, a very sophisticated sound generation system. This is hardly apparent from the early applications software available for the Macintosh, but should be taken advantage of in the future. It is a four-voice system—capable of playing four notes at a time—covering a wide spectrum of sound. With the proper software, it is entirely capable of speech synthesis. You have the option of replacing the speaker with a higher fidelity unit by

Figure B-3. The Macintosh analog board.
simply connecting an external speaker to the audio jack at the rear of the Macintosh; it uses a standard audio connector.

The video connector is at #4, with a couple of additional video controls above it. And the thing that looks like a stethoscope is another transformer, whose end attaches to the video display.

These are the primary components of the internal Macintosh, generally analogous to equivalents on other computers as well. You can easily afford to entirely forget about them, if you wish, and use the Macintosh quite successfully. But it doesn’t hurt to understand a bit about what is inside the computer and how those parts fit together. Moreover, as additional peripherals and other add-ons begin to appear, this kind of knowledge can help you better appreciate both the possible advantages and possible pitfalls of such additions or changes to your Macintosh system.
Macintosh Quick Reference
Macintosh Quick Reference

In this section will be found most of the definitions provided in the CHECKLISTS for each individual chapter. By bringing them together, and providing an indication of the type of item being defined, readers will have a convenient place for quickly reminding themselves of the meanings and uses of various Macintosh concepts, tools, and applications. The descriptions in the CHECKLIST for each chapter, and in the text of that chapter, provide more complete information.

Chapter 1: The Fundamental Macintosh

Desktop
The basic Macintosh screen, analogous to a physical desktop. Where work is organized.

Icons
Graphic representations of objects

Pointer
Used to make choices or to position the cursor; shape varies with the action being undertaken.

Windows
Show the contents of physical objects, documents, etc. Can be opened, closed, moved, etc. Scrolling permits the window to show any part of the thing being displayed. This is facilitated by clicking on the scroll bar or scroll arrow, or by dragging the scroll box.

Applications
Or tools, such as programs, that we use to get work done.
Documents
What the applications create, such as reports or drawings.

Mouse
The physical device used to position the pointer for various actions.

Chapter 2: The Desktop

Clicking
Quickly depressing and then releasing the mouse button.

Pressing
Depressing and holding the mouse button.

Dragging
Pressing the mouse button and then moving the mouse.

Selecting
An object is selected or made active by moving the pointer to it and then clicking. Selection is indicated when the object becomes highlighted.

Menu
A list of actions available; accessed by pressing on its title. The selection is made by dragging to it, and then releasing the mouse button.

Closing
Returning an icon to its proper storage place by clicking on its Close Box, or selecting Close from the File menu.
**Insertion Point**
Where new text will be inserted. Chosen by moving the pointer to desired location, and clicking.

**Cutting**
Removing unwanted material, which goes automatically to the Clipboard, by selecting Cut from the Edit menu or Command-X from the keyboard.

**Copying**
Making a duplicate of selected material, which goes automatically to the Clipboard, by selecting Copy from the Edit menu or Command-C from the keyboard.

**Pasting**
Moving material from the Clipboard to the active document, by selecting Paste from the Edit menu or Command-V from the keyboard.

**Backspace**
Deletes selected material but does not send it to the Clipboard. **Clear**, from the Edit menu, when available, does the same thing.

**Undoing**
Undoes most recent action, by selecting Undo from the Edit menu or Command-Z from the keyboard.
Clipboard

A special file where material that has been cut or copied is temporarily stored (until anything else is cut or copied). Pasting automatically places a copy of what is on the Clipboard into the current document.

Chapter 3: The Finder

Double-Clicking

Process of quickly clicking the mouse button twice, to effect two actions at one time. Use varies with what is currently being done (e.g., to simultaneously select and open an icon, or to select a whole word).

View menu

Offers five different ways to view the contents of a disk window.

Disk copying

All or part of any diskette is copied by dragging the desired icons to the icon of a second diskette.

Disk Copy

An application permitting rapid copying of an entire diskette for single-drive systems.

Duplicate

Make a copy of any file(s) to the same diskette by selecting Duplicate from the File menu or with Command-D from the keyboard.

Selection box

Select multiple icons by dragging a selection box around them.
Shift-clicking

Alternate method for selecting multiple icons; hold down Shift key while clicking on desired icons.

Select All

Select all icons in a window or on the desktop by choosing Select All from File menu or Command-A from the keyboard.

Folders

Used to organize file storage. Any item, including other folders, can be stored inside a folder.

Shift-Command-4

With the Caps Lock key up, prints a copy of the currently active window.

Shift-Command-4

With the Caps Lock key down, prints a copy of the entire screen (a "screen dump").

Shift-Command-3

Takes a snapshot of the screen, and stores it on disk as a MacPaint document.

Clean Up

Select from Special menu to have the Finder reorganize icons in active window or on desktop.

Erase Disk

Select from Special menu to have a diskette completely erased.
Trash

Used to get rid of any icon. Trashed materials stay in the Trash until it is emptied, an application is opened, or the Macintosh is turned off.

Locking

Process of making a file or an entire disk protected; nothing can be erased or changed. Done for files from Get Info window, for entire disks by moving the Write Protect tab.

Put Back

Select from File menu to return an icon to its proper folder or window, whether the latter is open or not.

Eject

To remove a diskette from a disk drive, select Eject from the File menu of Command-E from the keyboard.

Chapter 4: Managing Documents and Disks

Save

Saves copy of current document to disk; first save provides Dialog box permitting naming document and selecting diskette to be used with Drive and Eject options.

Save as...

Saves copy of current document under name and on disk specified via Dialog box.
<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Quit</td>
<td>Cancel current application and return to desktop.</td>
</tr>
<tr>
<td>Close</td>
<td>Returns current document to proper place, but keeps current application active.</td>
</tr>
<tr>
<td>New</td>
<td>Opens new document under current application.</td>
</tr>
<tr>
<td>Open...</td>
<td>After a Close, provides window showing all available documents for current application.</td>
</tr>
<tr>
<td>Startup disk</td>
<td>A diskette with system documents on it, required for starting up (booting) the system.</td>
</tr>
<tr>
<td>Set Startup</td>
<td>Select from Special menu for the application to start immediately when Macintosh is turned on.</td>
</tr>
<tr>
<td>Font Mover</td>
<td>An application for moving fonts into or out of the System file.</td>
</tr>
</tbody>
</table>
Chapter 5: MacWrite

Click & Shift-Click  Permits rapid selection of large blocks of text.

Double-Click        Selects entire word or space.

Shift-drag          For partial deselecting of selected text.

Find...             Select from Search menu to find any string.

Change...           Select from Search menu to find and replace any string.

Title Page          Select from Format menu to suppress headers and footers from first page of document.

Set Page...         Select from Format menu to start document with a page number other than one.

Insert Page Break   Select from Format menu to force a new page at desired location.

Rulers              Format appearance of text under their control.
Margin markers Are dragged on ruler to desired margin position.

Paragraph Indent marker Dragged on ruler to desired position for automatic indent or outdent of new paragraphs.

Tab wells Source of standard or decimal tabs; drag from well to desired position on ruler.

Headers & Footers Have own windows, automatic page, date, and time icons. Display and Remove from Format menu control their being shown on screen and paper.

Chapter 6: MacPaint

Drawing window Where drawing is done; shows less than one-third of the page at any time.

Show Page Shows whole page, for moving location of drawing window or moving whole drawing on page.

Tool boxes To left and bottom of drawing window, provide MacPaint tools for drawing.
Shapes
Use selected line thickness. Filled shapes fill with selected pattern.

Paint can
Fills any enclosed shape with selected pattern.

Hand
Moves everything in window.

Selection box & Lasso
Drag to select any part of window.

Pencil
For free-hand drawing in standard thickness.

Straight line
Can use any line width.

Spraycan
Sprays selected pattern in standard width.

Paintbrush
Draws in selected pattern and Brush Shape, and symmetrically with Brush Mirrors.

Align
Selected from Style menu, controls justification of text.
Revert  Select from File menu to replace current document with most recently saved version.

Print Draft  Slightly faster and lowe resolution alternative to Print Final.

Print Catalog  Prints name and miniature of all MacPaint documents on current disk.

Clear  Same as Backspace; deletes selected material without sending it to Clipboard.

Grid  Provides invisible "magnetic" grid for aligning text and pictures.

FatBits  Provides magnified view of selected material for precise editing.

Edit Pattern  Provides magnified view of selected pattern for precise editing.

Eraser  Can erase anything in drawing window.
Trace Edges

Turns solid shapes into outlines; puts borders around hollow shapes. With Shift, creates shadowed borders.

Flip Horizontal, Flip Vertical, Rotate

Select from Edit menu to manipulate selected materials.

Short Cuts

Select this window from Goodies menu for description of shortcut keystrokes for standard MacPaint actions, and for constraining, stretching, chained multiple copies, etc.
Index

A (text icon), 154, 160
About the . . . , 32
Active, 26, 29
   see also Selected
Alarm Clock, see Clock
Alert box, 20, 70, 84, 90
Align Left/Middle/Right, 154, 160, 183
Analog Board, 213-214, 218-219
Apple Symbol
   for Clock, 34
Apple II, 190, 212, 215, 216
Application, 22
Auxiliary Storage, see Disks and Disk Drives
Backspace key, 38, 39-40, 50
BASIC, 22, 139, 189-209
Bit (Binary digit), 215
Boldface, 117
Boot, 88
   Auto-booting, 90
Boxes, 19
   see also Windows
Brightness control knob, 7
Brush Mirrors, 163, 172-174, 183
Brush Shape, 158, 182, 183
BUS, 215
Byte, 7, 30, 215
By Icon/Date/Kind/Name/Size, see Menu, View

Cairo font, 105-108, 178, 201
Calculator, 34-37
Calendar, 34
   In Clock, 34
Cancel, 81, 87
Caps Lock Key, 10, 38

Chained multiple copies, see
   Repeating copies
Change . . . , 121, 123, 146
Change All, 123
Change, Then Find, 121
Clean Up, 70, 78
Clear, 40, 50, 160, 183
Click, 26, 34, 49, 146
Clipboard, 34-35, 39, 45, 46, 85, 90, 137, 165
   File, 88
Clock, 33-34, 35, 218
   On Control Panel, 41-42
Clock speed, 216
Close, 36, 37, 50, 76, 84, 85, 110
Close All, 37, 41, 50, 74
Close box, 27, 30, 33, 36, 50
Command Key, 10
   For MacPaint shortcuts, 182
   To stretch (MacPaint), 177, 178
   With Option, for repeating copies (MacPaint), 181
Command-A, see Select All
Command-B, see Boldface
Command-C, see Copy
Command-D, see Duplicate
Command-E, see Eject and Trace Edges
Command-G, see Goto Page
Command-H, see Superscript
Command-I, see Get Info
Command-L, see Subscript and Align Left
Command-M, see Align Middle
Command-P, see Plain Text
Command-R, see Align Right
Command-S, see Shadow
Command-U, see Underline
Command-V, see Paste
Command-X, see Cut
Command-Z, see Undo
Command-Shift . . . , see Shift-Command . . .
Connectors
   Rear panel, 13-14
Constraining (MacPaint), 176-177, 184
Control Panel, 41-45
Copy, 34-35, 45, 50, 116, 123
Copying, 77
   Advanced (MacPaint), 180-181
   Disks, 55-59
   Files, 59-62
   see also Duplicating
CP/M, 215
CRT, see Video Display
Cursor, 18-19, 23
   Blinking rate, 43
   see also Pointer
Cut, 34-35, 39, 45, 50, 116
Deselect, see Select
Desktop, see Select
   Pattern adjustment, 43-45
Dialog box, 20, 76, 81, 84, 85
   Print, 103, 108, 110
Digital board, see Motherboard
Directory, see Disks, displays
Disk Copy, 56, 58-59, 77, 92, 97
Disk drives, 5, 212
   Controller, 218
   Double-sided, 217
   External, 6, 9, 56
   Internal, 6, 7
   One or two drive systems, differences, 55, 57, 58, 82, 86, 87, 89, 90, 92, 97, 100, 102-103, 150-151
Disks (Diskettes), 7, 9, 22
   Displays, 52-55, 69
   Managing, 87-103
   Maximizing space on, 60, 97-100
   Naming, 56
   see also Startup
Display Footers/Headers, 136, 147
Document, 22, 23, 110
   Management, 66, 80-87
   Double-Click, 52, 66, 71, 77, 80, 85, 146, 153
   For MacPaint shortcuts, 182
Drag, 27, 39, 49
Drive
   In Dialog box, 82
   Duplicate, 62-64, 65, 75, 77
   see also Copying
Edit Pattern, 163, 184
Eject, 29, 74-75
   In Dialog box, 82, 97
Empty Trash, 71, 78, 97
   see also Trash
Enter key, 10, 84
Erase Disk, 70, 78, 100, 110
Erasor, 157, 165, 182, 184
FatBits, 53, 163, 168-172, 173, 182, 184
"Fat Mac", see 512K Macintosh
File, 60
   Handling, 64-69, 81-87
   Moving, 62
   Names, 84
   Temporary, 97, 104
   see also Copying, Duplicating, Folders
Fill, 167
Filled oval/rectangle/kidney/polygon (MacPaint), 152, 153, 183
   Borderless, 167
Find . . . , 121, 123, 146
Find Next, 121-122
Find what, 121
Finder, 32, Chapter 3, 83, 84, 85, 88, 89, 90, 97, 100
512K Macintosh, x, xi, 7, 55, 57, 114, 154, 217
Flip Horizontal/Vertical, 167, 184
Folders, 64-69, 78
   Empty, 30
Font Mover, 29, 52, 64, 92-96, 97-99, 110, 117
Fonts, 94, 105-108
  Change, in MacPaint, 181-182
File, 92, 94, 95, 98, 99
  Recommended sizes, 105
  see also Font Mover
Footers, 132-136, 147
  Removing, 136
Format, see Initialize

Get Info, 29, 56, 71
  For keeping records, 95-96
Goto Page, 123
Grid, 163, 166, 183

Hand (icon), 154, 170, 182, 183
Headers, 132-136, 147
  Removing, 136
Hide Footers/Headers, 136
Hide Rulers, 131-132, 135, 146
Highlight, 26, 35, 39, 49
  see also Select
Hollow oval/rectangle/kidney/polygon (MacPaint), 152, 153, 183
  Borderless, 167

IBM PC, 190, 191, 199, 200, 209, 212, 215, 216, 217
Icons, 6, 17-18, 19, 23, 26, 30, 35
Disk, 26, 35, 90
  In MacWrite Footers/Headers, 134, 135
  In MacPaint, see MacPaint, Tools
Shadow, 55, 56
Imagewriter file, 88, 102, 103, 150
Imagewriter printer, 6, 12, 14, 103, 108, 218
Ribbons, 108
Insert Page Break, 124-125, 146
Insert Ruler, 129
Insertion point, 38, 50, 115, 117
  see also Pointer and Cursor
Initialize, 55-56, 58
Intel 8086/8088, 215, 216

Introduction (MacPaint Window), 164
Invert, 166

Key Caps, 37-41
Keyboard, 5, 6, 9-10, 14, 218
  Auto-repeat adjustment, 43
  see also Key Caps
Keypad, numeric, 6, 9

Lasso, 155, 165, 166, 167, 183
Line filter, 219
Line justification (MacWrite), 127, 147
Line selection box, 152, 153
  For repeating copy spacing, 181
Line spacing (MacWrite), 127, 147
Lisa Computer, 15, 17, 150, 212, 216
LisaDraw, 150

Locking
  Disks, 72, 78
  Files, in Get Info box, 71-72, 78

MacDraw, 150
Macintosh BASIC (Apple), 200-209
MacPaint, 22, 29, 30, 45, 72, 103, 105, 114, 137, 139, Chapter 6
  Drawing window, 151
  Edit menu, 154, 160-163, 165, 166
  File menu, 160
  Goodies menu, 150, 156, 158, 163-164, 167, 172, 176, 181
  Menus, 160-164
  Style menu, 154, 160
  Tools, 152-159

MacWrite, 19, 22, 29, 30, 45, 63, 80, 85, 87, 103, 108, Chapter 5
  Font menu, 117
  Format menu, 115, 123-124, 133, 146
  Forms in, 140-143
  Menus, 117-125
  Style menu, 117, 146
  Tables in, 143-146
Margins (MacWrite), 128, 147
Megabyte, 216
Megahertz (MHz), 216
Menu bar, 26, 29
Menus, 28-29, 49
Apple, 32-49, 85
Blinking rate, 42-43
Edit, 31, 34, 85, 116, 120
File, 29, 31, 34, 35, 85, 104, 108
Special, 31, 90
View, 31, 53-55, 77
see also MacPaint and MacWrite
Microprocessor (Macintosh), 4, 91, 215-216, 218
Modem, 6, 218
Motherboard, 214, 215-218
Motorola 68000, see Microprocessor
Mouse, 5, 6, 11-12, 14, 26, 30, 34, 49, 218
Movement adjustment, 43
MS-BASIC (Microsoft), 190-199

Networking, 218
New, 85-86, 87, 110
Note Pad, 46-49, 89, 100
File, 88

Open, 19, 29
Open . . . , 86-87, 110
Open Footer/Header, 133, 135, 136
Option Key, 10, 38, 40
In MacPaint, 180, 181, 182, 184
Option-Shift, 38

Page Setup, 108-109, 120, 136, 147
Paint can, 153-154, 183
Paint brush, 157-158, 172-174, 182, 183
Paragraph indentation marker, 128, 147
Partial word (MacWrite), 121, 123
Pascal, Apple, 189
Paste, 39, 45, 50, 116, 123
Pattern bar, 153, 182
Pencil (icon), 155-156, 182, 183

In FatBits, 169-170, 182
Pixel, 7
Plain text (MacWrite), 117
Pointer, 19-20, 24, 30, 49, 115
Shapes, 20, 38, 152, 155
Power supply, 218-219
Press, 27, 49
Printing, 103-109, 110
Printing (MacPaint), 160
Print Draft, 160, 183
Print Final, 160, 183
Print Catalog, 160, 183
Printing (MacWrite)
Draft quality/resolution, 94, 108
High quality/resolution, 94, 96, 98, 108
Standard quality/resolution, 94, 108
Tall Adjusted, 109
Wide, 109
Programmable Array Logic (PAL), 218
Programmer’s Switch, 14, 218
Programming, uses, 188
Put Back, 73-74, 78
Puzzle, 49

Quick Reference, 221
Quit, 76, 84-85, 110

RAM (Random Access Memory), 217
see also 512K Macintosh
Redo, 116, 121, 146
see also Undo
Reference, Quick, 221
Remove
In Font Mover, 95
Remove Footer/Header, 136, 147
Repeating copies (MacPaint), 181, 184
Reset switch, 14, 218
Return Key
In Find . . . and Change . . . , 121-123
In MacWrite, 129
Revert, 160, 183
ROM (Read-Only Memory), 5, 216-217
Rotate, 168, 184
RS-422, see Serial ports
Ruler (MacWrite), 115, 125-132, 141-142, 143, 146
Save, 75, 80-84, 100, 110
Text only, 81
Save as . . . , 75, 83-84, 100, 110
Scrapbook, 45-46, 89, 90, 99, 137
File, 88
Screen, see Video display and Snapshot
Screen dump, see Shift-Command-4
Scroll, 19, 20, 30
Scroll bar, 45
Scroll box, 45, 123
Seattle
File, 92, 96, 99
Font, 96
Select/Desel ect, 26, 30, 35, 39, 49, 78, 165
And replace, 48-49, 50
Blocks of text (MacWrite), 117, 146
Multiple icons, 61-62
See also Selection Box and Lasso
Select All, 62, 70, 78
Selection box, 61, 78
In MacPaint, 155, 165, 166, 177, 182, 183
Serial communications controller, 218
Serial ports, 14, 218
Set Page #, 124-125, 136, 146
Set Startup, 90, 110
Setup, system, 14
Shadow type, 117, 135
Shift key (MacPaint), 157, 158, 171, 177
Shift-Command, 177, 178
Shift-Click, 61, 78, 117, 146
Shift-Command-4
With Caps Lock up, 69, 76, 78
With Caps Lock down, 69, 76, 78
Shift-Command-1/2, 75, 78
Shift-Command-3, 76, 78, 168
Short Cuts (MacPaint), 164, 176, 181-182, 184
Show Clipboard, 34, 165
Show Page, 151, 156, 157, 167, 173, 182, 183
Show Rulers, 132, 146
Six lines/inch (MacWrite), 127
Size box, 30
Snapshot, see Shift-Command-3
Software
Application, 5, 23
System, 4, 7, 22, 26, 52, 58
Speaker, 219-220
Volume control, 42
Spraycan, 157, 183
Startup application, 90
Startup disk, A, 7, 88, 92, 97, 110, 217
Startup disk, The, 70, 89-90, 102, 110
Storage, auxiliary, see Disk Drives and Disks
Storing, see Folders
Straight line (icon), 156-157, 183
Stretching (MacPaint), 176-177, 184
Subscripts, 118-119, 128, 146
Superscripts, 118-119, 128, 146
System Disk, 92
System file, 52, 88, 92, 93, 94, 99
Using Get Info, 95
See also Software, System
System Folder, 29, 52, 53, 63-64, 88, 89, 150
See also Software, System
Tab key, in Search . . . , 121
Tab wells, 128, 147
Tabs
Regular, 128, 147
Decimal, 128, 147
Text only (Saves), 81
Index

Title bar, 39
Title Page (MacWrite), 123, 134, 146
Tool, 23
Tool boxes (MacPaint), 152, 183
Trace Edges, 166, 184
Transformer, 219
Trash, 20, 26, 30, 71, 78
   Emptying, see Empty Trash
   Put disk icons in, 90
Triple-Click, 52

Undo, 39, 40, 48, 50, 116
   In MacPaint, 154, 156, 160, 165, 181
   In MacWrite, 120-121, 127, 132, 146
“Untitled”, 83
Underline, 117

Video connector, 220
Video Display, 5, 6, 7, 212, 220
Versatile Interface Adapter, 218

Windows, 6, 19-20, 23, 26, 27, 29, 30, 35, 68-69
Closing, see Close
Drawing, in MacPaint, 151, 168, 183
Footer and Header, 133
Moving, 33, 36, 37, 49, 69
Moving, in MacWrite, 125
Moving without Selecting, 36, 78
Printing, 69
   See also Shift-Command-4
Sizing, 30, 49
Word-wrap, 47, 129
Write-protect, see Locking, disks
Whole word (MacWrite), 121