MAC OS 7.6
FOR DUMMIES

A Reference for the Rest of Us!

by Bob LeVitus

Author of Macintosh System 7.5 For Dummies

The Fun and Easy Way to Configure and Customize Apple's Mac OS 7.6

Your First Aid Kit for Surviving Crashes, Freezes, and Software Conflicts

Make Your Mac Work the Way You Want it to — Explained in Plain English

FREE Mac OS 7.6 " Cheat Sheet " Inside!
Top Six Things You Should Never Do

6. Shut off your Mac by pulling the plug or flipping the power switch. Always use the Shut Down command in the Special menu or the *Shut Down DA in the Apple menu.

5. Pay attention to anyone who says that Windows is just like the Mac. Yeah, right. And Yugo is the Eastern-European cousin of Mercedes.

4. Bump, drop, shake, wobble, dribble, drop kick, or play catch with a hard disk while it's running. Don't forget that your Mac (unless it's ancient) has a hard disk inside it too.

3. Pay list price for any hardware or software. What lists for $499 at Pierre's Chrome and Glass Computer Boutique may only cost $275 at Bubba's Mail-Order Warehouse and Chili Emporium.

2. Get up from your Mac without saving your work. Just before your butt leaves the chair, your fingers should be pressing Command-S. Make it a habit.

1. Keep only one copy of your work. Make at least two backups and keep one of them in a safe place. Period.

Finder Keyboard Shortcuts

Learn these shortcuts. The less time you spend working, the more time you have to waste.

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Close All</td>
<td>Command-Option-W</td>
</tr>
<tr>
<td>Close Window</td>
<td>Command-W</td>
</tr>
<tr>
<td>Copy</td>
<td>Command-C</td>
</tr>
<tr>
<td>Cut</td>
<td>Command-X</td>
</tr>
<tr>
<td>Duplicate</td>
<td>Command-D</td>
</tr>
<tr>
<td>Eject Disk</td>
<td>Command-E</td>
</tr>
<tr>
<td>Find</td>
<td>Command-F</td>
</tr>
<tr>
<td>Find Again</td>
<td>Command-G</td>
</tr>
<tr>
<td>Get Info</td>
<td>Command-I</td>
</tr>
<tr>
<td>Make Alias</td>
<td>Command-M</td>
</tr>
<tr>
<td>New Folder</td>
<td>Command-N</td>
</tr>
<tr>
<td>Open</td>
<td>Command-O</td>
</tr>
<tr>
<td>Paste</td>
<td>Command-V</td>
</tr>
<tr>
<td>Print</td>
<td>Command-P</td>
</tr>
<tr>
<td>Put Away</td>
<td>Command-Y</td>
</tr>
<tr>
<td>Select All</td>
<td>Command-A</td>
</tr>
<tr>
<td>Undo</td>
<td>Command-Z</td>
</tr>
</tbody>
</table>

Cheat Sheet $2.95 value. Item 0103-8.

For more information about IDG Books, call 1-800-434-3422 or 415-312-9650

...For Dummies: #1 Computer Book Series for Beginners
### Keyboard Shortcuts in Open and Save Dialog Boxes

- Eject Disk: Command-Shift-1
- Desktop: Command-D
- Cancel: Command-period or Escape
- Open/Save: Return or Enter
- Move up one folder: Command-up arrow
- Move down into the highlighted folder: Command-down arrow (also Return or Enter)
- Switch disks: Command-left arrow or Command-right arrow

Repeat after me: The Open and Save dialog boxes are just another view of the Finder.

![Diagram showing folder navigation]

### Adjusting an Application's Preferred Size

1. Make sure that the application is not open.
2. Select the application's icon in the Finder.
3. Choose File→Get Info or use the keyboard shortcut Command-I.
4. At the bottom of the Info window, double-click the Preferred size text box.
5. With the number in the Preferred size text box highlighted, do one of the following:
   - If you want to give the application more RAM (to improve performance, enable it to open larger documents, or prevent out-of-memory errors), type a higher number in the Preferred size text box.
   - If you want to give the application less RAM (to make room to run more applications at once), type a lower number in the Preferred size text box. You shouldn't go below the application's Minimum size.

6. Close the Info window by clicking its close box (on the left side of the title bar) or by pressing the keyboard shortcut Command-W.
References for the Rest of Us!

COMPUTER BOOK SERIES FROM IDG

Are you intimidated and confused by computers? Do you find that traditional manuals are overloaded with technical details you'll never use? Do your friends and family always call you to fix simple problems on their PCs? Then the ...For Dummies® computer book series from IDG Books Worldwide is for you.

...For Dummies books are written for those frustrated computer users who know they aren't really dumb but find that PC hardware, software, and indeed the unique vocabulary of computing make them feel helpless. ...For Dummies books use a lighthearted approach, a down-to-earth style, and even cartoons and humorous icons to diffuse computer novices' fears and build their confidence. Lighthearted but not lightweight, these books are a perfect survival guide for anyone forced to use a computer.

"I like my copy so much I told friends; now they bought copies."
Irene C., Orwell, Ohio

"Quick, concise, nontechnical, and humorous."
Jay A., Elburn, Illinois

"Thanks, I needed this book. Now I can sleep at night."
Robin F., British Columbia, Canada

Already, hundreds of thousands of satisfied readers agree. They have made ...For Dummies books the #1 introductory level computer book series and have written asking for more. So, if you're looking for the most fun and easy way to learn about computers, look to ...For Dummies books to give you a helping hand.
MAC® OS 7.6 FOR DUMMIES®

by Bob LeVitus

Foreword by Steven Bobker

IDG Books Worldwide, Inc.
An International Data Group Company

Foster City, CA • Chicago, IL • Indianapolis, IN • Southlake, TX
About the Author

Bob LeVitus (pronounced Love-eye-tis) was the editor-in-chief of the wildly popular MACazine until its untimely demise in 1988. Since 1989, he has been a contributing editor/columnist for MacUser magazine, writing the “Help Folder,” “Beating the System,” “Personal Best,” and “Game Room” columns at various times in his illustrious career. In his spare time, LeVitus has written 25 popular computer books, including WebMaster Macintosh, Second Edition, the “everything you need to build your own Web site on a Mac” book and CD-ROM; and his latest book/CD before this one, Cheap and Easy Internet Access for Macintosh, the painless way to get connected.

Always a popular speaker at Macintosh user groups and trade shows, LeVitus has spoken at more than 100 international seminars, presented keynote addresses in several countries, and serves on the Macworld Expo Advisory Board. He was also the host of Mac Today, a half-hour television show syndicated in over 100 markets, which aired in late 1992.

LeVitus has forgotten more about the Macintosh than most people know. He won the Macworld Expo MacJeopardy World Championship an unbelievable four times before retiring his crown. But most of all, LeVitus is known for his clear, understandable writing, his humorous style, and his ability to translate “techie” jargon into usable and fun advice for the rest of us.

He lives in Austin, Texas, with his wife, two children, and several dogs.
ABOUT IDG BOOKS WORLDWIDE

Welcome to the world of IDG Books Worldwide.

IDG Books Worldwide, Inc., is a subsidiary of International Data Group, the world’s largest publisher of computer-related information and the leading global provider of information services on information technology. IDG was founded more than 25 years ago and now employs more than 8,500 people worldwide. IDG publishes more than 275 computer publications in over 75 countries (see listing below). More than 60 million people read one or more IDG publications each month.

Launched in 1990, IDG Books Worldwide is today the #1 publisher of best-selling computer books in the United States. We are proud to have received eight awards from the Computer Press Association in recognition of editorial excellence and three from Computer Currents’ First Annual Readers’ Choice Awards. Our bestselling For Dummies® series has more than 30 million copies in print with translations in 30 languages. IDG Books Worldwide, through a joint venture with IDG’s Hi-Tech Beijing, became the first U.S. publisher to publish a computer book in the People's Republic of China. In record time, IDG Books Worldwide has become the first choice for millions of readers around the world who want to learn how to better manage their businesses.

Our mission is simple: Every one of our books is designed to bring extra value and skill-building instructions to the reader. Our books are written by experts who understand and care about our readers. The knowledge base of our editorial staff comes from years of experience in publishing, education, and journalism — experience we use to produce books for the 90s. In short, we care about books, so we attract the best people. We devote special attention to details such as audience, interior design, use of icons, and illustrations. And because we use an efficient process of authoring, editing, and desktop publishing our books electronically, we can spend more time ensuring superior content and spend less time on the technicalities of making books.

You can count on our commitment to deliver high-quality books at competitive prices on topics you want to read about. At IDG Books Worldwide, we continue in the IDG tradition of delivering quality for more than 25 years. You’ll find no better book on a subject than one from IDG Books Worldwide.

John Kilcullen
CEO
IDG Books Worldwide, Inc
Dedication

For Jodie, Andy, Robyn, Dad, Cousin Nancy, and all my other friends and relatives with new Macs. Now you can stop calling me at all hours.

Author's Acknowledgments

Special thanks to my friends at Apple, who were there for me every step of the way: Bob Filice, Tim Holmes, Doedy Hunter, Vito Salvaggio, Tim Swihart, Keri Walker, and everyone on the Mac OS 7.6 development team, the Apple evangelists, and the Apple Fellows. Thank you all. I couldn't have done it without your help.

Thanks also to superagent Carole “Still Swifty After All These Years” McClendon of Waterside Productions, for deal-making beyond the call of duty. You're even more awesome than last acknowledgment page!

Big-time thanks to the gang at IDG Books: Mike Kelly, Diane Steele, and the big guy himself, John Kilcullen. Nobody does it better.

Extra special thanks to my editor, Tim “the Whipcracker” Gallan, who has been better than great.

Thanks to my family for putting up with my all-too-lengthy absences during this book's gestation.

And finally, thanks to you for buying it.
Publisher's Acknowledgments

We're proud of this book; please send us your comments about it by using the Reader Response Card at the back of the book or by e-mailing us at feedback@dummies@idgbooks.com. Some of the people who helped bring this book to market include the following:

**Acquisitions, Development, and Editorial**

<table>
<thead>
<tr>
<th>Position</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project Editor</td>
<td>Tim Gallan</td>
</tr>
<tr>
<td>Senior Acquisitions Editor</td>
<td>Jill Pisoni</td>
</tr>
<tr>
<td>Acquisitions Editor</td>
<td>Mike Kelly</td>
</tr>
<tr>
<td>Product Development Director</td>
<td>Mary Bednarek</td>
</tr>
<tr>
<td>Copy Editor</td>
<td>Felicity O'Meara</td>
</tr>
<tr>
<td>Technical Editor</td>
<td>Dennis Cohen</td>
</tr>
<tr>
<td>Editorial Manager</td>
<td>Kristin A. Cocks</td>
</tr>
<tr>
<td>Editorial Assistant</td>
<td>Chris H. Collins</td>
</tr>
</tbody>
</table>

**Production**

<table>
<thead>
<tr>
<th>Position</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Associate Project Coordinator</td>
<td>E. Shawn Aylsworth</td>
</tr>
<tr>
<td>Layout and Graphics</td>
<td>Brett Black,</td>
</tr>
<tr>
<td></td>
<td>Elizabeth Cárdenas-Nelson,</td>
</tr>
<tr>
<td></td>
<td>J. Tyler Connor,</td>
</tr>
<tr>
<td></td>
<td>Angela F. Hunckler,</td>
</tr>
<tr>
<td></td>
<td>Todd Klemme,</td>
</tr>
<tr>
<td></td>
<td>Ruth Loiacano,</td>
</tr>
<tr>
<td></td>
<td>Mark C. Owens,</td>
</tr>
<tr>
<td></td>
<td>Brent Savage,</td>
</tr>
<tr>
<td></td>
<td>Michael Sullivan</td>
</tr>
<tr>
<td>Proofreaders</td>
<td>Christine D. Berman, Rachel</td>
</tr>
<tr>
<td></td>
<td>Garvey, Rob Springer, Carrie</td>
</tr>
<tr>
<td></td>
<td>Voorhis, Karen York</td>
</tr>
<tr>
<td>Indexer</td>
<td>Sharon Hilgenberg</td>
</tr>
</tbody>
</table>

**General and Administrative**

**IDG Books Worldwide, Inc.:** John Kilcullen, CEO; Steven Berkowitz, President and Publisher

**IDG Books Technology Publishing:** Brenda McLaughlin, Senior Vice President and Group Publisher

**Dummies Technology Press and Dummies Editorial:** Diane Graves Steele, Vice President and Associate Publisher; Judith A. Taylor, Brand Manager; Kristin A. Cocks, Editorial Director

**Dummies Trade Press:** Kathleen A. Welton, Vice President and Publisher; Stacy S. Collins, Brand Manager

**IDG Books Production for Dummies Press:** Beth Jenkins, Production Director; Cindy L. Phipps, Supervisor of Project Coordination, Production Proofreading and Indexing; Kathie S. Schutte, Supervisor of Page Layout; Shelley Lea, Supervisor of Graphics and Design; Debbie J. Gates, Production Systems Specialist; Tony Augsburger, Supervisor of Reprints and Bluelines; Leslie Popplewell, Media Archive Coordinator

**Dummies Packaging and Book Design:** Patti Sandez, Packaging Specialist; Kavish+Kavish, Cover Design

*The publisher would like to give special thanks to Patrick J. McGovern, without whom this book would not have been possible.*
Contents at a Glance

Foreword ................................................................. xxiii
Introduction ............................................................... 1

Part I: Basic Training ...................................................... 5
Chapter 1: Mac OS 7.6 101 (Prerequisites: None) ...................... 7
Chapter 2: Meet the Desktop ........................................... 19
Chapter 3: A Bevy of Delectable Menus ................................ 49
Chapter 4: Polishing the Apple (Menu) ................................ 87
Chapter 5: Save Yourself Heartache: Master the Save and Open Dialog Boxes .... 111

Part II: Making It Purr ................................................... 129
Chapter 6: File Management Made Simple ................................ 131
Chapter 7: Publish or Perish: The Fail-Safe Guide to Printing ......... 153
Chapter 8: File Sharing for the Rest of Us ............................ 181
Chapter 9: Memory and Other Seemingly Complicated Arcana ........... 207

Part III: U 2 Can B A Guru .............................................. 223
Chapter 10: Sure-Fire, Easy-to-Use, No (Or Low)-Cost Timesaving Tips .... 225
Chapter 11: Advanced Techniques for Beginners ...................... 235
Chapter 12: Control Tweaks ............................................ 245
Chapter 13: How to Write an AppleScript in 21 Minutes .............. 281
Chapter 14: What Can Stay and What Can Go .......................... 291
Chapter 15: Internet-Working ........................................... 323

Part IV: The Infamous Part of Tens ..................................... 337
Chapter 16: Ten Pieces of System Software You Might Someday Need .... 339
Chapter 17: Ten Ways to Make Your Mac Better by Throwing Money at It .... 351
Chapter 18: At Least Ten Things to Try When Good System Software Goes Bad ......................................................... 353

Part V: Appendixes ......................................................... 373
Appendix A: Anyone Can Install Mac OS 7.6 .......................... 375
Appendix B: Back Up Now or Regret It Later ......................... 387

Index ............................................................................. 391

Reader Response Card .............................................. Back of Book
Cartoons at a Glance
By Rich Tennant • Fax: 508-546-7747 • E-mail: the5wave@tiac.net

The 5th Wave
By Rich Tennant

"Put him in front of a terminal, and he's a genius. But otherwise, the guy is such a freaking bloody ditz, he'll never break into management."

page 223

"A brief announcement comes—an open-faced teakly butler, carrying us for an inappropriate replacement for a missing mousepad."

page 5

"Now when someone rings my doorbell, the crane goes to an array that displays the video image and sends the image to this box where it's converted to a TELX. The image is then downloaded, compressed, and sent via high-speed modem to an international phone service that sends an e-mail message back to tell me someone was at my door."

page 129

The 5th Wave
By Rich Tennant

page 337

The 5th Wave
By Rich Tennant

page 373

The 5th Wave
By Rich Tennant

page 223

The 5th Wave
By Rich Tennant

page 373

The 5th Wave
By Rich Tennant

page 5

The 5th Wave
By Rich Tennant

page 129
# Table of Contents

*Foreword* ................................................................. xxiii

*Introduction* .............................................................. 1
  - Why a Book for Dummies? ........................................... 1
  - How to Use this Book .................................................. 2
  - How This Book Is Organized .......................................... 2
    - Part I: Basic Training ............................................... 3
    - Part II: Making It Purr ........................................... 3
    - Part III: U 2 Can B A Guru ...................................... 3
    - Part IV: The Infamous Part of Tens ............................... 3
    - Part V: Appendixes .................................................. 3
  - Icons Used in This Book ............................................. 4
  - One Last Thing ....................................................... 4

*Part I: Basic Training* .................................................. 5

**Chapter 1: Mac OS 7.6 101 (Prerequisites: None)** ................. 7
  - What Is System Software? ............................................ 8
  - What Does System Software Do? ................................... 8
  - A Safety Net for the Absolute Beginner — or Any User ........... 9
  - What You Should See after Turning the Power On .................. 11
  - What's Happening Here? (The Startup Process Revealed) ....... 13
    - You're not a failure .............................................. 14
    - Question Mark and the Mysterians ............................... 14
    - The ultimate startup disks ...................................... 15
    - Now what? .......................................................... 16
  - One Last Thing before You Move On ................................ 17

**Chapter 2: Meet the Desktop** ...................................... 19
  - I Think ICON, I Think ICON ........................................ 19
    - The look you want to know better ................................ 20
    - Open sesame ....................................................... 22
    - The name game .................................................... 24
    - Other various and sundry icons .................................. 24
    - Windows (Definitely Not the Microsoft Kind) .................. 27
    - Doin' windows ..................................................... 27
Zooming right along ................................................................. 28
Cutting windows down to size .................................................... 29
A scroll new world ................................................................... 30
Transportable windows ............................................................... 31
Ladies and gentlemen, activate your windows ......................... 32
Shuttin' yo' windows ................................................................. 32
The remarkable WindowShade effect ..................................... 35
Congrats: You now do windows ................................................ 35
Disk Could Be the Start of a Beautiful Friendship ...................... 36
Initialization and erasure ............................................................ 36
Surprise: PC disks work as well! .................................................. 36
Getting disks out of your Mac ................................................... 37
Up the Organization: Copying and Moving Files and Folders ....... 39
Know when to hold 'er, know when to folder ............................ 40
Meet the desktop .................................................................... 46

Chapter 3: A Bevy of Delectable Menus .................................. 49

Menu Basics ............................................................................ 49
  Command performance .......................................................... 50
  It's elliptical .......................................................................... 50
  Dialog box featurettes .......................................................... 50

File Management and More: Meet the File Menu .................... 53
  New Folder (Command-N) ..................................................... 54
  Open (Command-O) ............................................................. 54
  Print (Command-P) .............................................................. 54
  Close Window (Command-W) ................................................ 55
  Get Info (Command-I) .......................................................... 55
  Sharing (no keyboard shortcut) ............................................. 58
  Duplicate (Command-D) ....................................................... 58
  Make Alias (Command-M) .................................................... 59
  Put Away (Command-Y) ....................................................... 60
  Find (Command-F) ............................................................... 60
  Find Again (Command-G) ..................................................... 62
  Page Setup (no keyboard shortcut) ....................................... 63
  Print (no keyboard shortcut) ................................................ 63

The Edit Menu (Which Shoulda Been Called the Clipboard Menu) 64
  Undo (Command-Z) ............................................................. 66
  Cut (Command-X) ................................................................ 66
  Show Clipboard (no keyboard shortcut) ............................... 67
  Copy (Command-C) .............................................................. 68
  Paste (Command-V) ............................................................. 68
  Clear (no keyboard shortcut) ................................................ 68
  Select All (Command-A) ....................................................... 69

A View from a Window: The View Menu .................................. 69
  By Icon .............................................................................. 69
# Table of Contents

By Small Icon ................................................................. 70
The list views ........................................................................ 70
Another way to switch between list views ......................... 72
The triangles ........................................................................ 73
Don't Label Me: Introducing the (Near-Worthless) Label Menu ........ 76
Something Special in the Menu Bar: The Special Menu ............. 77
Clean Up ............................................................................. 78
Empty Trash ......................................................................... 79
Eject Disk and Erase Disk ..................................................... 79
Restart ............................................................................... 80
Shut Down ........................................................................... 81
Sleep .................................................................................. 81
Not Just a Beatles Movie: Help and the Help Menu ................. 81
About Help (no keyboard shortcut) ........................................ 82
Show Balloons (no keyboard shortcut) .................................... 82
Mac OS Guide (Command-?) ................................................ 83
Shortcuts (no keyboard shortcut) .......................................... 85

## Chapter 4: Polishing the Apple (Menu) .................................. 87

About This Computer (Yours) ............................................... 88
From the Desk (Accessories) of ............................................. 90
Profile THIS: Apple System Profiler ...................................... 91
Sounds good to me: AppleCD Audio Player ............................ 91
A calculated risk: Calculator ................................................... 92
Be choosy: Be a Chooser user ................................................. 93
Finder of lost files: Find File (again) ....................................... 94
Fakin' it with Graphing Calculator (Power Macs only) ............. 94
Better than puzzles of old, it's Jigsaw Puzzle .......................... 94
The key to all your fonts: It's Key Caps ................................... 96
Take note of the Note Pad ....................................................... 98
Remote Access Disconnect ..................................................... 98
The not-so-scrappy Scrapbook .............................................. 99
SimpleSound ....................................................................... 100
Don't be stuck up: Use Stickies .............................................. 100
Another way to shut down .................................................... 100
Those Interestingly Named Folders in the Apple Menu .......... 102
The Control Panels folder ...................................................... 104
Recent Applications, Recent Documents, and Recent Servers ... 104
Automated Tasks ................................................................. 105
Roll Your Own: Customizing Your Apple Menu ..................... 105
Doing the right thing with your desk accessories .................. 106
Putting your stuff into the Apple menu .................................. 107
My Deep, Dark Secret ......................................................... 108
Table of Contents

Scale ................................................................................................................. 160
PostScript options ........................................................................................... 161
The Print Dialog Box: Printing to Most Printers .............................................. 163
The Print General dialog box .......................................................................... 165
The Print Background Printing dialog box .................................................... 167
The Print Cover Page dialog box ................................................................... 168
The Print Color Matching dialog box .............................................................. 169
The Print Layout dialog box ............................................................................ 170
The Print Error Handling dialog box .............................................................. 170
The Print Save As File dialog box ................................................................... 170
One last thing . ............................................................................................... 171
The Hip New Thing: Desktop Printers ............................................................ 171
What is a desktop printer, anyway? ................................................................. 171
Using desktop printers .................................................................................... 172
What is QuickDraw GX (And Should I Use It?) ............................................. 175
What you get when you install QuickDraw GX .............................................. 176
Another GX advantage: The print to disk PDD format .................................. 178
QuickDraw GX: The last word ......................................................................... 179
Font Mania ....................................................................................................... 179
How to install fonts ......................................................................................... 179
Type formats .................................................................................................... 180
Font advice in brief ......................................................................................... 180

Chapter 8: File Sharing for the Rest of Us ....................................................... 181
What It Is .......................................................................................................... 182
Portrait of a LocalTalk network ....................................................................... 182
Getting Turned On .......................................................................................... 184
Setting Up Sharing Setup ................................................................................. 186
Get a network identity ..................................................................................... 186
Turn file sharing and program linking on ....................................................... 187
Users and Groups and Guests (Oh My) .......................................................... 187
Users ................................................................................................................ 188
Groups ............................................................................................................. 190
Be our guest ..................................................................................................... 191
Removing Users or Groups ............................................................................. 191
Access and Privileges (Who Can Do What) .................................................... 192
Sharing a folder or disk ................................................................................... 192
Setting access privileges ................................................................................ 193
Useful settings for access privileges ............................................................. 194
The Actual Act of Sharing ................................................................................ 196
Connecting to a shared disk or folder ............................................................. 196
Getting on your own computer from a remote computer .............................. 200
Disconnecting from a shared folder or disk .................................................... 200
# Table of Contents

- ATM .............................................................. 248
- AutoRemounter (PowerBooks Only) .......................... 249
- Brightness ....................................................... 250
- Color .............................................................. 251
- ColorSync System Profile ..................................... 251
- Control Strip .................................................... 252
- Date & Time ....................................................... 252
  - To set the date or time ........................................ 253
  - Time and date formats ........................................ 253
  - The rest of it .................................................. 254
- Desktop Patterns ............................................... 255
- Dial Assist ....................................................... 256
- Editor Setup (OpenDoc Only) .................................. 256
- Energy Saver ..................................................... 257
- Extensions Manager ............................................ 258
- File Sharing Monitor ........................................... 260
- General Controls ................................................ 260
  - Desktop options .............................................. 261
  - Shut Down Warning .......................................... 261
  - Folder Protection ............................................. 262
  - Insertion Point Blinking ...................................... 262
  - Menu Blinking ................................................ 262
  - Documents ..................................................... 262
- Keyboard .......................................................... 263
- Labels .............................................................. 264
- Launcher ........................................................... 265
- Mac OS Easy Open ............................................. 266
- MacLinkPlus Setup ............................................. 268
- Map ................................................................. 268
- Memory ............................................................. 268
- Modem .............................................................. 269
- Monitors & Sound .............................................. 269
  - Monitor .......................................................... 269
  - Sound ............................................................ 269
  - Alerts (beep sounds) ......................................... 270
- Mouse .............................................................. 272
- Numbers ........................................................... 272
- PC Exchange ...................................................... 273
- PPP ................................................................. 274
- QuickTime Settings ............................................. 275
- Remote Access Setup .......................................... 275
- Sharing Setup ................................................... 275
- Speech ............................................................. 275
- Startup Disk ...................................................... 276
TCP/IP ........................................................................................................... 277
Text ............................................................................................................... 277
Users and Groups ...................................................................................... 278
Views ......................................................................................................... 278
WindowShade ............................................................................................. 279

Chapter 13: How to Write an AppleScript in 21 Minutes ......................... 281
What the Heck Is an AppleScript, Anyway? .............................................. 282
What the Mac OS Installer Installs and Where It Installs It ..................... 283
The AppleScriptLib and AppleScript extensions .................................... 283
The Scripting Additions folder .................................................................. 283
AppleScript Guide ...................................................................................... 284
Script Editor ............................................................................................... 284
The Automated Tasks folder .................................................................... 284
But wait, there's more ............................................................................... 285
What it all means ...................................................................................... 286
Writing a Simple Script ............................................................................ 286
If a Script Is Any Good, It Should Be Saved ............................................ 288

Chapter 14: What Can Stay and What Can Go ........................................ 291
Reclamation Theory ................................................................................... 292
Life After Death: The Truth about Restoring Deleted Files ................... 292
Back up first ............................................................................................... 292
Install Mac OS: Restorer of lost items .................................................... 293
What, Exactly, Are Extensions and Control Panels? ............................. 294
Disabling 'em all with the Shift key .......................................................... 294
Discriminating disabling with Extensions Manager ................................ 295
Control Panels .......................................................................................... 297
Control panels by RAM used ................................................................. 304
Control panels by disk space used .......................................................... 304
Extensions .................................................................................................. 306
System extensions ...................................................................................... 306
Chooser extensions .................................................................................... 313
Other items in the Extensions folder ...................................................... 314
Folders in the Extensions folder ............................................................. 316
Extensions by RAM used ......................................................................... 317
Extensions by disk space used ................................................................. 317
The Rest of the Stuff in Your System Folder .......................................... 318

Chapter 15: Internet-Working ................................................................. 323
Internet Overview (Brief) .......................................................................... 323
Getting Set Up for Surfing ....................................................................... 324
It starts with the modem .......................................................................... 324
Your Internet service provider and you .................................................. 326
Go configure: PPP and TCP/IP ................................................................. 326
Table of Contents

One Cool Puppy: Meet Your New Cyberdog .................................................. 328
Logging On ................................................................................................. 329
Meet your pup .............................................................................................. 331
Riding the Information Superhighway ......................................................... 336

Part IV: The Infamous Part of Tens ...................................................... 337

Chapter 16: Ten Pieces of System Software
You Might Someday Need ........................................................................... 339
PowerBook Options and Other Stuff .......................................................... 339
Easy Access ............................................................................................... 340
CloseView .................................................................................................. 343
OpenDoc & OpenDoc Essentials ............................................................... 344
Cyberdog .................................................................................................... 345
Open Transport PPP .................................................................................. 345
MacLinkPlus ............................................................................................... 345
QuickDraw 3D ............................................................................................ 346
Apple Remote Access Client ........................................................................ 347
English Text-to-Speech ........................................................................... 348
QuickDraw GX ........................................................................................... 348
LaserWriter Utility ..................................................................................... 349
Paper Type Editor ....................................................................................... 349
Type 1 Enabler ........................................................................................... 350

Chapter 17: Ten Ways to Make Your Mac Better
by Throwing Money at It ................................................................. 351

Chapter 18: At Least Ten Things to Try When
Good System Software Goes Bad .................................................... 353
Dem Ol’ Sad Mac Chimes of Doom Blues ........................................... 354
Flashing Question Mark Problems ............................................................. 355
Start with something easy: Rebuild the desktop .................................. 356
Send for the Ambulance: Run Disk First Aid .......................................... 358
Installing new hard disk drivers ................................................................. 360
The latest dance craze: Zapping the PRAM ............................................. 361
SCSI voodoo .............................................................................................. 362
Reinstalling the System software .............................................................. 363
If nothing has worked so far ................................................................. 364
If You Crash at Startup .......................................................................... 364
Restart without extensions and control panels ...................................... 364
Resolving extension and control panel conflicts .................................... 365
Dealing with recalcitrant extensions and control panels ....................... 367
How to perform a clean System reinstallation .......................................... 370
Part V: Appendixes .......................................................... 373

Appendix A: Anyone Can Install Mac OS 7.6 ............................................. 375
  Installing Mac OS 7.6 ....................................................... 376
  Custom Installs ............................................................ 379
    OpenDoc ................................................................. 380
    OpenDoc Essentials ................................................... 380
    QuickDraw 3D ............................................................ 381
    MacLinkPlus ............................................................ 381
    Apple Remote Access Client ........................................ 382
    Cyberdog ................................................................. 382
    Open Transport PPP .................................................... 382
    English Text-to-Speech ............................................... 383
    Optional Mac OS Items ................................................ 383

Appendix B: Back Up Now or Regret It Later ............................................. 387
  Backing Up Is (Not) Hard to Do ........................................ 387
    The manual, "brute force" method ................................ 387
    Commercial backup software ....................................... 388
    Why You Need Two Sets of Backup Disks ....................... 388

Index .................................................................................. 391

Reader Response Card ................................................. Back of Book
Apple Computer's Macintosh computers are still the leader in PC innovation and ease of use. Nothing, not this year's Windows 95 release whatever (or next year's) even begins to match up. And you, perceptive reader, know that. What you also know as great a technology company as Apple is, they are one of the worst companies in history when it comes to marketing and explaining their latest wonders. You must turn to outsiders to tell you what Apple has provided and then tell you how to make the most of it. There's no one better at analyzing and explaining the works of Apple than Bob LeVitus.

His name is a working definition for Not Dull. No matter where you run into Bob — in conversation, around the poker table, or in his writings about the Mac — you are not going to be bored. You will pay attention, not that he'll give you much of a choice. And that's good. His opinions tend to be provocative and well thought out, his poker playing skilled enough to empty your wallet if you're not both good and lucky, and his knowledge of the Mac and ability to communicate it to readers unparalleled.

Mac OS 7.6 is big news. It adds a lot of power to the already stunning power of System 7.5. OT/PPP, Cyberdog, and more make it the state-of-the-art Internet access system. No matter what System software version you're using, the upgrade to Mac OS 7.6 will make your Mac a more powerful tool.

Of course, Apple manuals are Apple manuals; don't expect a lot of explanation or help from them. To get at the new power, you could hire a consultant, but that's expensive and not at all necessary: Just read this book. It's a wonderful guide to all of Mac OS 7.6.

This book, Mac OS 7.6 For Dummies, might be better called The Best Mac System Software Book Ever. Bobby has gone past his usually really good writing level here, and taken a dry subject (Who really gets excited about an operating system? A game, sure, and maybe even that exceptional productivity application, but the system software?) and created a book that makes you want to learn and use this important advance in Mac software.

He's also achieved the difficult trick of writing a book that works for first-time users as well as power users who have been using Macs since January 1984. That's no mean accomplishment. I've been writing for and editing Mac magazines since 1985 and understand (and stand in awe of) the magnitude of Bobby's achievement here.
This book is not free; Apple manuals come with the product. Why buy this book? Why not stick with the oh-so-pretty Apple manuals? Surely, they have everything you’re going find here? Well, no, that’s not so. The Apple manuals are pretty. But readable? I don’t think so. They’re so dry that they should be declared a fire hazard. They’re very full of themselves and at the same time so carefully worded that it seems certain their final editing was at the hands of Apple’s legal staff.

They tell you the good parts, not the bad parts. And they’d choke before admitting that there are power tips that can really make you productive. Their “avoid all risks, take no shortcuts because it might not be perfectly 110-percent safe” approach means that the Apple manuals are incomplete. That’s where Mac OS 7.6 For Dummies comes in. It goes beyond the too-dry manuals and too-brief magazine articles and tells you everything about Mac OS 7.6. After you digest it, you have the choice of doing things the Apple manual way or really using and enjoying your Mac.

The greatest strength of Mac OS 7.6 For Dummies is the breadth and depth of its content. Mac OS 7.6 opens a lot of new ground for Mac users, and this book covers it all. You’re not going to find a better helper as you move into Mac OS 7.6.

The second greatest strength of Mac OS 7.6 For Dummies is its solid dose of in-your-face attitude. This is a readable helper that cares. All too many computer books today are either chores to read or in a couple of cases, simply unreadable because they seem to think dry seriousness is a “business-like” virtue. They’re wrong. Readability counts big-time, and Mac OS 7.6 For Dummies can be as hard to put down as the latest potboiler. You not only learn from it, but you enjoy the process.

With a wonderful and refreshing attitude for a person who didn’t grow up (or even ever live) in New York, Bobby gets vital information, like his instructions on backing up, right in your face. He’s never been shy, and if something is important, he makes sure you get it.

Mac OS 7.6 For Dummies jumps right to the top of the class in Mac system software books, easily surpassing all the others I’ve read (and that’s just about all them; it’s part of my job). Any book that surpasses it is going to have to be awfully good. And it wouldn’t surprise me if Bob LeVitus is the author.

Steven Bobker
Introduction

You made the right choice twice: Mac OS 7.6 and this book.

Take a deep breath and get ready to have some fun. That's right. This is a computer book and it's going to be fun. What a concept! Whether you're brand spanking new to the Mac or a grizzled old Mac-vet, I guarantee that learning Mac OS 7.6 my way will be easy and fun. They couldn't say it on the cover if it weren't true!

Why a Book for Dummies?

Because there wasn't a Dummies book about the Mac OS (though DOS For Dummies, Windows For Dummies, and Windows 95 For Dummies are huge hits), and because the nice folks at IDG Books asked me if I wanted to write one. The result was the international bestseller Macintosh System 7.5 For Dummies, an award-winning book so good it was offered by Power Computing instead of a System software manual.

And now I'm back with the all-new, totally revised, Mac OS 7.6 For Dummies, which combines all the old, familiar features of my earlier book with totally updated information about the latest, greatest offering from Apple.

So why a ...For Dummies book about Mac OS 7.6? Mac OS 7.6 is a big, complicated personal computer operating system. Mac OS 7.6 For Dummies is a not-so-big (about 9 x 7 inches and not very thick), not-very-complicated book that teaches you about Mac OS 7.6 without boring you, confusing you, or otherwise making you uncomfortable.

In fact, you'll be so darned comfortable that I wanted to call this book Mac OS 7.6 Without The Discomfort but they wouldn't let me. There are apparently some rules we Dummies authors have to follow, and using the word "Dummies" in the title is one of them.

And speaking of dummies, remember that it's just a word. I don't think you're dumb. Quite the opposite. I wanted to call this book Mac OS 7.6 For People Smart Enough to Know They Need Help, but you can just imagine what IDG Books thought of that. (If you're reading this in a bookstore, approach the cashier with your wallet in your hand and buy it, and I'll think you're even smarter!)

This book is chock full of information and advice, explaining everything you need to know about Mac OS 7.6, plus how to do it and why, in language you'll understand.
It is supplemented with tips, tricks, techniques, and steps, served up in generous quantities. It all adds up to the only book in the world that makes learning Mac OS 7.6 both painless and fun. Can your beer do that?

**How to Use this Book**

We're gonna start off real slow. The first few chapters are where we get to know each other and discuss the basic, everyday things you need to know to operate your Mac or Mac-compatible effectively.

The first part, in fact, is so basic it will probably bore you old-timers to tears. But hey, it's my sworn duty to show you all there is to know in the most painless manner possible. And I can't do that without a solid foundation. So long-time Mac users should feel free to skip through stuff they know to get to the better stuff faster.

A word of warning: If you skip over something important, like why you absolutely *must* back up your hard drive (see Appendix A), don't come crying to me when you lose all your valuable data in a horrendous disk crash. In other words, it's probably not a bad idea to read it all, even if you think you already know it all.

Another thing: We learn by doing. Perform the hands-on tutorials while sitting at your Mac. They're much less effective if you read them anywhere else.

Here are a couple of conventions I use in this book:

- When I refer to an item in a menu, I use something like File|Save, which means "Pull down the File menu and choose the Save command."

- For keyboard shortcuts, something like Command-A means hold down the Command key (the one with the little pretzel on it) and press the letter A on the keyboard. Command-Shift-A means hold down the Command and Shift keys while pressing the A key.

Finally, there are extensive cross-references throughout the book and an better-than-average index at the back. Use them freely.

**How This Book Is Organized**

*Mac OS 7.6 For Dummies* is divided into five logical parts, logically numbered Parts I through V. It's better if you read them in order, but if you already know a lot or think you know a lot, feel free to skip around and read the parts that interest you.
**Part I: Basic Training**

The first part is very, very basic training. From the mouse to the desktop, from the menus to the tricky-for-beginners Open and Save dialog boxes, it's all here. Everything you need to know to operate Mac OS 7.6 safely and sanely. Old-timers can skim through it; you newbies should read every word. Twice.

**Part II: Making It Purr**

Here, I discuss hands-on stuff, with chapters on organizing, printing, sharing (files, that is), and memory management. By the time you finish Part II, your system will be a finely tuned and running like a champ.

**Part III: U 2 Can B A Guru**

Now we're cooking. This part is about how things work and how to make them work better.

Tips, tricks, techniques, control panels, scripts and much more, plus the most useful chapter in the whole book, Chapter 14, “What Can Stay and What Can Go,” which details each and every gosh darn file in your System Folder and why you need it or don't. If your Mac ran like a champ after Part II, wait'll you see it after Part III.

**Part IV: The Infamous Part of Tens**

The Part of Tens is mostly a Letterman rip-off, though it does include heaping helpings of tips, troubleshooting hints, and optional software and hardware ideas.

**Part V: Appendixes**

I end the book with a little info on installing Mac OS 7.6 and backing up your hard drive. Installation is a breeze these days, as Appendix A describes. As for backups, you should be doing them already. If not, read Appendix B and beg forgiveness from whatever god you believe in.

And that retires the side . . . almost.
Icons Used in This Book

Put on your propeller beanie hat and pocket protector. This is truly nerdy stuff. It's certainly not required reading but it must be interesting or informative or I wouldn't have wasted the space.

Read these notes very, very, very carefully. Did I say "very?" Warning icons flag important information. The author and publisher will not be responsible if your Mac explodes or spews flaming parts because you ignored a Warning icon.

Just kidding. Macs don't explode or spew (with the exception of a few choice PowerBook 5300s last year). But it got your attention, didn't it? It's a good idea to read Warning notes carefully.

This is where you'll find the juiciest morsels: shortcuts, tips, and undocumented secrets. Try them all; impress your friends.

This icon warns you that a hands-on tutorial with step-by-step instructions is coming. It's best to be at your Mac when you read these and perform the steps as you read them.

Me, ranting or raving about something. Imagine foam coming from my mouth. Rants are required to be irreverent or irrelevant or both. I also try to keep them short, more for your sake than mine.

One Last Thing

I'm thrilled at how this book came out — I think it's the best thing I've ever written. But I didn't write it for me. I wrote it for you and would love to hear how it worked for you. So please drop me a line or fill out the registration card at the back of the book for me.

You can send snail mail care of IDG Books (they'll see that I receive it), or send e-mail to me directly at LEVITUS@cis.compuserve.com

I appreciate your feedback and try to respond to all e-mail within a few days.

Bob LeVitus
Winter 1996

P.S. What are you waiting for? Go enjoy the book!
Part I
Basic Training

The 5th Wave
By Rich Tennant

"A BRIEF ANNOUNCEMENT CLASS - AN OPEN FACED PEANUT BUTTER SANDWICH IS NOT AN APPROPRIATE REPLACEMENT FOR A MISSING MOUSEPAD."
In this part...

Mac OS 7.6 sports tons of new goodies and features. And I'll get to the hot new goodies soon enough, but you have to learn to crawl before you can walk.

In this part, you discover the most basic of basics, such as the de rigueur-for-books-with-Dummies-in-the-title section on how to turn your Mac on (it's very short). Next I acquaint you with the Mac OS 7.6 desktop: icons, windows, menus, disks, and trash — the whole shmeear.

So get comfortable, roll up your sleeves, fire up your Mac if you like, and settle down with Part I, a delightful little ditty I like to think of as "The Hassle-Free Way to Get Started with Mac OS 7.6."
Choosing Mac OS 7.6 was a good move. It's more than just a System software upgrade; Mac OS 7.6 includes dozens of new or improved features that make using your Mac easier, and dozens more that help you do more work in less time. In other words, it'll make you more productive, give you fewer headaches, reduce your cholesterol level, and make you fall in love with your Mac all over again.

I know you're chomping at the bit, but I'm going to start at the very beginning. This chapter mostly talks about Mac OS 7.6 in abstract terms. Don't bother to turn your Mac on yet, as there's no hands-on stuff here either. What you'll find is a bunch of very important stuff that will save the beginner from a lot of headaches.

If you already know what System software is and does, how to avoid disasters, what a startup disk is, and how the startup process works, I suggest you read those sections anyway — to refresh your memory — and skim the rest.

Everyone else: Please read every word.
**What Is System Software?**

Along with the code in its read-only memory (ROM), the System software (often called the *operating system* or *Mac OS*) is what makes a Mac a Mac. Without it, your Mac is a pile of silicon and circuits, no smarter than a toaster. It's got a brain (ROM), and it's got memory (RAM), and it's got ten fingers and toes (other stuff), but it doesn't know what to do with itself. Think of System software as an education, and Mac OS 7.6 as an Ivy League education. (A PC clone with Windows dropped outta high school in the 10th grade and flips burgers for a living.)

With Mac OS 7.6, your Mac becomes an elegant, powerful tool that's the envy of the rest of the computer industry. (Or so we Macintosh lovers like to think!)

Most of the world's personal computers use Windows. Poor schmucks. You're among the lucky few with a computer whose operating system is intuitive, easy to use, and, dare I say, fun. Windows — even Windows 95 — is a cheap imitation of the Macintosh System software. Try it sometime. Go ahead. You probably won't suffer any permanent damage. In fact, you'll really begin to appreciate how good you've got it. Feel free to hug your Mac or give it a peck on the floppy drive opening. Just try not to get your tongue caught.

**What Does System Software Do?**

Good question. It controls the basic (and most important operations) of your *computer*. In the case of Mac OS 7.6 and your Mac, the System software manages memory, controls how windows, icons, and menus work, keeps track of files, and does *lots* of other housekeeping chores. Other forms of software, such as a word processor, rely on the System software to create and maintain the environment in which the application software does its work.

When you create a memo, for example, the word processor provides the tools for you to type and format the information. The System software provides the mechanism for drawing and moving the window in which you write the memo; it keeps track of the file when you save it; it helps the word processor create drop-down menus and dialog boxes and communicate with other programs, and much, much more.

Now you have a little background in System software. Before you do anything else with your Mac, take a gander at the next section.
A Safety Net for the Absolute Beginner — or Any User

If you’re a first-time Mac user, please, please read this section of the book very carefully. It could save your life. Well, now I’m just being overly dramatic. *It could save your Mac* is what I meant to say. I deal with the stuff that the manual that came with your Mac doesn’t cover in nearly enough detail, if at all. If you’re an experienced Mac user, read this section anyway. Chances are, you need a few reminders.

- **If you don’t know how to turn your Mac on, get help.** Don’t feel bad. Apple, in its infinite wisdom, has manufactured Macs with power-on switches on every conceivable surface: the front, side, back, and even the keyboard. Some Macs (most PowerBooks) even hide the power-on button behind a little plastic door.

  In his bestseller *Macs For Dummies*, David Pogue devotes several pages to locating the on switch for every current model of Macintosh. If you’re having trouble, it’ll be worth your while to check out the latest edition of his book. Or you can always look in the manual that came with your Mac.

  Like personal fouls in the NBA, authors are only allowed so many weasel-outs per book. I hate to use one so early, but in this case, I think it’s worth it for both of us. I promise this is the first and only time I’ll say, “Look in the manual.” Maybe.

- **Always use the Shut Down (Apple or Special menu) commands, or press the Power key once and then click the Shut Down button to turn off your Mac.** Turning the power off without shutting your Mac down properly is one of the worst things you can do to your poor Mac. It can screw up your hard disk real bad or scramble the contents of your most important files, or both.

  Of course, most of us have broken this rule several times without anything horrible happening. Don’t be lulled into a false sense of security. Do it one time too many and your most important file will be toasted.

  Mac OS 7.6 actually scolds you if you don’t shut down properly. If you break this rule, the next time your Mac is turned on, it will politely inform you that your Mac was shut down improperly, as shown in Figure 1-1.

  **TIP**  If you find the little “this Mac was shut down improperly” reminder annoying, you can turn it off in the General Controls control panel. I actually like it and leave the warning enabled. You should too.
Don’t unplug your Mac when it’s turned on. See my blurb in the preceding bullet.

Don’t use your Mac when lightning is near. Lightning strike = dead Mac. ’Nuff said. Oh, and don’t place much faith in inexpensive surge protectors. A good jolt of lightning will fry the surge protector right along with your computer. There are surge protectors that can withstand most lightning strikes, but they’re not the cheapies you buy at your local computer emporium. Unplugging your Mac from the wall during electrical storms is safer and less expensive. (Don’t forget to unplug your modem as well — lightning can fry it, too!)

Don’t jostle, bump, shake, kick, throw, dribble, or punt your Mac, especially while it’s running. Unless your Mac is ancient, it contains within it a hard disk drive that spins at 5400+ rpm. A jolt to a hard disk while it’s reading or writing a file can cause the head to crash into the disk, which can render many or all the files on it totally and irreversibly unrecoverable.

Turn off your Mac before plugging or unplugging any cables. This advice may be overkill, as even Apple seems to say that you can safely plug cables into the serial ports — the modem or printer ports — while your Mac is turned on. But other cables, specifically SCSI cables and ADB cables, should never under any circumstances be plugged or unplugged without first shutting down your Mac.

Okay, that about does it for bad stuff that can happen. If something bad has already happened to you, see Chapter 18.
A pop quiz on mousing

For those of you who need to hone your mousing skills, here's a little quiz.

1. How do you select an icon on the desktop?
   A. Stare at it intently for five seconds.
   B. Point to it with your finger, slap the side of your monitor, and say, "That one, stupid!"
   C. Move the mouse pointer on top of the icon and click once.

2. When do you need to double-click?
   A. Whenever you find yourself saying, "There's no place like home."
   B. When you're using both hands to control the mouse.
   C. When you want to open a file or folder.

3. How do you select multiple items or blocks of text?
   A. Get several people to stare intently at the items you want to select.
   B. You need to attach multiple mice to your Mac.

4. How do you move a selected item?
   A. Call U-Haul.
   B. Pick up and tilt your monitor until the item slides to the proper location.
   C. Click the item and hold down the mouse button. With the mouse button still held down, drag the pointer to the new location and let go of the mouse button.

If you haven't figured it out by now, the correct answer to each of these questions is C. If any other answer sounded remotely plausible for you, sit down with your Mac and just play with it for a while. If you have kids at your disposal, watch them play with your Mac. They'll be showing you how to use it in no time.

What You Should See after Turning the Power On

After a small bit of whirring, buzzing, and flashing (the System software is loading) you should see a cheerful little happy Mac in the middle of your screen like the one in Figure 1-2.

Soon thereafter comes a soothing blue Mac OS logo with the message "Welcome to Mac OS 7.6" followed by "Starting Up" and the infamous march of the icons across the bottom of the screen. Makes you feel kind of warm and fuzzy, doesn't it? These things indicate that Mac OS 7.6 is loading properly.
This might be a good time to take a moment to think good thoughts about whoever convinced you that you wanted a Mac. They were right.

Anyway, in a few more seconds, the familiar Macintosh desktop will materialize before your eyes. If you haven't customized, configured, or done any other tinkering, your desktop should look something like Figure 1-3. Don't worry if you don't see a desktop printer icon on your desktop (mine is named HP LaserJet 4ML); I discuss desktop printers in Chapter 7. And don't worry if you do see a little control strip hanging out near the bottom of your screen; I cover the ingenious control strip in Chapter 12.

In the unlikely event you didn't see the smiling Mac, soothing messages, and familiar desktop, read the next section — "What's Happening Here?" — very carefully. If this section doesn't set things right, skip to Chapter 18.
Chapter 1: Mac OS 7.6 101 (Prerequisites: None)

SCSI, ADB, and other conversation topics for parties

SCSI is the acronym for Small Computer System Interface, the relatively high-speed bus chosen by Apple to connect peripheral devices such as hard disks, tape drives, scanners, and even some printers, to your Macintosh. SCSI is pronounced "scuzzy" and is fun to say aloud. Try it:

"I got a 1 gigabyte hard disk, a pair of big SyQuests, a 4mm DAT, and a 24-bit scanner on my scuzzy bus."

A movement to pronounce SCSI as "sexy" instead of "scuzzy" never really got off the ground.

Bus, of course, is nerd-speak for the hardware, cabling, and protocols used to connect peripherals to the computer. The Mac has other busses, most notably its expansion slots (the PCI bus in newer models; the NuBus bus in older ones) and the Apple Desktop Bus (ADB) bus for keyboards, mice, and the like.

A typical Mac can have up to seven SCSI devices connected simultaneously in a daisy-chain on the SCSI bus. One device is connected to the next, and so on, until the last device, which connects to your Mac's SCSI port.

Every Macintosh since the Mac Plus has a SCSI port; internal hard disks are often a part of the SCSI chain.

ADB is the TLA (three-letter acronym) for Apple Desktop Bus, another Apple bus scheme for keyboards and pointing devices (and sometimes drawing tablets and modems). It's slower than the SCSI bus but fast enough for mice, trackballs, and tablets. Every Macintosh since the Macintosh SE has an ADB port, and many Macs have two. A Mac can have several ADB devices connected simultaneously to each ADB port in a daisy chain. Though in theory you can connect a bunch of devices — like 12 or 16 — to each ADB port, in practice you should limit yourself to 2 or 3 per ADB port. More than that can cause your Mac to behave erratically.

What's Happening Here? (The Startup Process Revealed)

When you turn on your Macintosh, you set in motion a sophisticated and complex series of events that culminates in the loading of Mac OS 7.6 and the appearance of the familiar Mac desktop. Fortunately, the mechanics of the process are unimportant. In brief, your Mac tests all your hardware — slots, ports, disks, memory (RAM), and so on. If everything passes, you hear a pleasing chord and see the happy Mac, the Mac OS logo, and "Welcome to Mac OS 7.6/Starting Up" on your monitor as your Mac loads the System software it needs from disk to RAM.
You’re not a failure

If any of your hardware fails when tested, you see a black screen with the dreaded Sad Mac icon (see Figure 1-4) and hear a far less pleasing musical chord known by Mac aficionados as the Chimes of Doom. The fact that something went wrong is no reflection on your prowess as a Macintosh user. Something inside your Mac is broken, and it probably needs to go in for repairs (usually to an Apple dealer). If it’s under warranty, dial 1-800-SOS-APPL and they’ll tell you what to do.

Before you do anything, though, skip ahead to Chapter 18. It’s entirely possible that one of the suggestions there will get you back on track without spending even a moment on hold.

Question Mark and the Mysterians

Although it’s unlikely that you’ll see a sad Mac, all users eventually encounter the flashing question mark (shown in Figure 1-5) in place of the usual happy Mac at some time in their lives. Don’t worry. This one is a breeze. This icon means that your Mac can’t find a startup disk, a floppy disk, hard disk, or CD-ROM containing valid System software.
When you turn on your Mac, the first thing it does (after the aforementioned hardware tests) is check the floppy disk drive for a startup disk (something with Mac OS 7.6 on it). If it doesn't find one there, it scans the SCSI bus. At this point, your Mac usually finds your hard disk, which contains a System Folder, and the startup process continues on its merry way with the happy Mac and all the rest.

Think of the flashing question mark as your Mac's way of saying, "Please provide me with a disk that contains some System software."

If Apple can figure out a way to put a flashing question mark on the screen, why the heck can't the software engineers find a way to put the words "Please insert a startup disk" on the screen as well. The cuteness of the flashing question mark is one of my pet peeves about the Macintosh.

I know, you're clever and smart (you're reading Mac OS 7.6 For Dummies, aren't you?), so you know that a flashing question mark means that you should insert a startup disk. But what about everyone else?

Get with the program, Apple.

The ultimate startup disks

Chances are you have a copy of the ultimate startup floppy right there on your computer table. It's called Disk Tools, and it's one of the disks that you get with most versions of System 7. If you've got a flashing question mark, pop Disk Tools into your floppy drive and your Mac will boot, just like magic.

Or, if your Mac (or System software upgrade) didn't include floppy disks, it instead included a bootable CD-ROM disk. To boot from a CD-ROM you need to hold down the "C" key during startup on most Mac models. If that doesn't work, try holding down these four keys in the infamous four-finger salute: Delete-Option-Command-Shift.

A good way to remember this keyboard combination — which is generally used to start up from a disk other than your internal hard drive, including a bootable CD-ROM — is to think of the mnemonic device DOCS (Delete-Option-Command-Shift).

Disk Tools or a bootable System Software CD make the ultimate startup disks because, in addition to a System and Finder (the two files that must be present on a startup disk), they also have copies of Disk First Aid, Apple HD SC Setup, and Drive Setup, three programs that you may need if you see a flashing question mark. Disk First Aid can repair hidden damage to your hard disk; HD SC Setup or Drive Setup can install new hard disk drivers. Both Disk First Aid and Apple HD SC Setup/Drive Setup are described more completely in Chapter 18, and Apple HD SC Setup and Drive Setup are described in Appendix A.
The legend of the boot

Boot this. Boot that. "Did it boot?" "I booted my Mac and..." It seems nearly impossible to talk about computers for long without hearing the word.

But why boot? Why not shoe or shirt or even shazam?

It all began in the very olden days, maybe the 1970s or a little earlier, when starting up a computer required you to toggle little manual switches on the front panel, which began an internal process that loaded the operating system. The process became known as "bootstrapping" because if you toggled the right switches, the computer would "pull itself up by the bootstraps." It didn't take long for the phrase to transmogrify into "booting" and "boot."

Over the years, booting has come to mean turning on almost any computer or even a peripheral device like a printer. Some people also use it to refer to launching an application: "I booted Excel."

So the next time one of your gear-head friends says the B word, ask if he or she knows where the term comes from. Then dazzle your friend with the depth and breadth of your knowledge.

Now what?

Okay, so you've gotten your Mac to boot from the Disk Tools disk or System software CD-ROM but there's still this little problem. Like you'd prefer that your Mac boot from your (much faster) hard disk than that piddly little Disk Tools floppy or System software CD-ROM. Not to worry. All you need to do is reinstall Mac OS 7.6 (see Appendix A).

Those of you who are going to upgrade from System 7.x to Mac OS 7.6 may want to read Appendix A right about now. The rest of you, the ones whose Macs already booted from a hard drive with Mac OS 7.6 installed, can breathe a sigh of relief and skip ahead to the next chapter.

How do you know which version of the Mac OS your computer has? Simple. Just pull down the Apple menu and choose About This Computer, the very first choice in the list. A window pops up in the middle of your screen (see Figure 1-6). In the upper-right corner of this window you'll find the version number of your System software. As you can see, the About This Computer window not only tells you the version number of the Mac OS you're using, but also details your RAM usage. (I deal with RAM usage and memory in Chapter 9.)
If the stuff on your hard disk means anything to you, you must back it up. Not maybe. You must. Which is why I recommend you read Appendix B right now instead of later. Unlike an earlier section in this chapter, Appendix B is a safety net for everyone. Before you do any significant work on your Mac (or even if your most important file is your last saved game of Marathon Infinity), you need to realize how important it is to back up.

Dr. Macintosh sez, "There are only two kinds of Mac users — those who have never lost data, and those who will." Which kind will you be?

I beg you: Please read Appendix B now before something horrible happens to your valuable data.
Part I: Basic Training
Chapter 2

Meet the Desktop

In This Chapter
- Using icons
- Using windows
- A treatise on folder management

This is where we get down to the nitty-gritty; this is the chapter about the Macintosh desktop. Your desktop is the center of your Macintosh universe. Just about everything you do on your Mac begins and ends with the desktop. The desktop is where you manage files, store documents, launch programs, adjust the way your Mac works, and much more. If you ever expect to master your Mac, the first step is to master the desktop.

Once again, those of you who have been using Mac OS for a while may find some of the information presented in this chapter repetitive; many of the features discussed in this chapter are unchanged from earlier versions of System 7. Still, you’d be foolish to skip it completely. If you do, I assure you you’ll miss sarcasm, clever wordplay, shortcuts, awesome techniques, a bad pun or two, and lots of good advice on making the desktop an easier place to be. If that’s not enough to convince you, there’s also a bunch of stuff Apple didn’t bother to tell you. (Like you read the manual anyway.)

Tantalized? Let’s rock.

I Think ICON, I Think ICON

Icons, those funny little pictures on your desktop and in your windows, represent containers, and these containers hold things that you work with on your Mac, like programs, documents, System software items, discarded files (the Trash icon), and more. All icons appear on your screen as little pictures with their names attached.

The first icon you should become familiar with is the icon for your hard disk. It’s in the upper-right corner and is named Macintosh HD unless you’ve renamed it (see Figure 2-1).
The look you want to know better

Icons come in all shapes and sizes. After you’ve been around the Macintosh for a while, you get a kind of sixth sense about what an icon contains just by looking at it. For example, application (that is, program) icons are often diamond shaped. Unless, of course, they’re rectangular or square or oddly shaped (see Figure 2-2).

Okay, so application icons are all over the place. Document icons, on the other hand, are almost always reminiscent of a piece of paper (as shown in Figure 2-3).

See? You’re already acquiring that sixth sense. Application icons are all over the place; document icons look like paper. Kind of.

Now let’s talk about the four kinds of icons: application, document, folder, and System software.

(There are actually five kinds of icons. Aliases are an icon type in their own right. But I’m trying to keep things simple; I cover these most excellent icons soon enough. Like in the very next chapter!)
Applications are programs, the software that you use to accomplish tasks on your Mac. Your word processor is an application. So are America Online and Prodigy. Titanic: Adventure Out of Time and Marathon are applications (they're also great games).

Documents are files created by applications. Letter to Mom, which you can create in a program like ClarisWorks, is a document. So are Bob’s Calendar and Expense Report.

Folders are the Mac’s organizational containers. You put icons, usually application or document icons, into folders. You can also put folders inside other folders. Folders look like, well, folders. Some folder icons have pictures; most don’t (see Figure 2-4).

System software is the stuff in your System Folder — the System, the Finder, control panels, extensions, and almost everything else. The files that make up your System software have many purposes, most of which will be second nature to you by the end of this book. For now, I'll just talk about the icons, though.

System software icons usually have a distinctive look as well. For example, the System and Finder have distinctive Mac-flavored icons (see Figure 2-5).

Control panel icons usually have a slider bar at the bottom or on one side (as illustrated in Figure 2-6).

Extension icons usually look like jigsaw puzzle parts (see Figure 2-7).

But that’s where the metaphor breaks down. The rest of your System software icons may look like just about anything (see Figure 2-8).
There's lots more to be said about all of these kinds of icons, and I do so in upcoming chapters. But that's enough about what icons look like. I'm sure you're anxious to do something with icons already.

Open sesame

There are three ways to open any icon. (Okay, there are four ways, but as I said, I'm saving aliases for later. You don't need to know just yet.) Anyway, here are the ways:

✓ Click the icon once to select it; then point to the File menu (it's the one that says File) and press on the word File. Remember, a press is half a click. Don't release the mouse button yet. A menu will drop down. Move the pointer downward until the word Open is highlighted (see Figure 2-9).
(I probably could have saved a whole paragraph by simply saying "Choose File→Open." But you may have been pulling down a menu for the first time. I wanted to be safe.) The icon opens.

By the way, in case you hadn't noticed, you just learned how to choose an item from a menu. Don't go hog-wild. There's a lot more to know about menus, but it's in the next chapter. In fact, all of Chapter 3 is about menus.

- Double-click the icon by clicking it directly twice in rapid succession. If it doesn't open, you double-clicked too slowly.

- Select the icon and then use the keyboard shortcut, Command-O. That means you press the Command key, the one with the pretzel and the apple on most keyboards, and then press the O key while continuing to hold down the Command key.

If you look at Figure 2-9, you'll see that the keyboard shortcut appears on the menu after the word Open. Pretzel-O. Any menu item with one of these pretzel-letter combinations after its name can be executed with that keyboard shortcut. Just press the pretzel (Command) key and the letter shown in the menu — Command and N for New Folder, Command and F for Find, and so on — and the appropriate command is executed.

It's never too soon to learn good habits, so I'll mention here that experienced Macintosh users use the keyboard shortcuts as often as possible. Keyboard shortcuts let you get things done without opening the menu, which means that you don't have to reach for the mouse, which means that you get more done in less time. It's a good idea to memorize shortcuts for menu items you use frequently.

Although the letters next to the Command-key symbol (I'm done calling it a pretzel now) in the Finder's menus are capital letters, you don't have to press the Shift key to use the keyboard shortcut. Command-P means hold down the Command key and press P. Some programs have keyboard combinations that require the use of Command-Shift, but these programs let you know by calling the key combination something like Command-Shift-S or Command-Shift-O. You don't have to worry about the capitalization of the letter.
The name game

Icon, icon, bo-bicon, banana fanna fo ficon. Bet that you can change the name of any old icon. Here are two ways:

- Click the icon's name directly. Don't forget to release the mouse button.
- Click the icon and then press the Return or Enter key on your keyboard once.

Either of these ways selects the icon's name and puts a box around it, waiting for you to type (see Figure 2-10).

In addition to selecting the name, the cursor changes from a pointer to a text-editing I-beam. An I-beam cursor is your Mac's way of telling you that it's okay to type now. At this point, if you click the I-beam cursor anywhere within the name box, you can edit the icon's original name. If you don't click and just begin typing, the icon's original name will be completely replaced by what you type.

If you've never changed an icon's name, give it a try.

And don't forget: If you click the icon itself, the icon gets selected and you won't be able to change its name. (Selecting the icon itself enables you to move, copy, print, or open it, but we're getting ahead of ourselves.)

Other various and sundry icons

Before I get off the subject of icons completely, and because this is the chapter where you meet your desktop, I'd be remiss if I didn't mention a couple of other icons that you'll probably find there. The most important of these is . . .
**The Trash**

The Trash is a special container where you put the icons that you no longer want on your hard or floppy disk. Got four copies of SimpleText on your hard disk? Drag three of them to the Trash. Old letters that you don't want to keep? Drag them to the Trash as well. To put an icon in the Trash, drag it on top of the Trash icon. When the tip (cool people call it the *hot spot*) of the pointer is directly over the Trash icon, the icon inverts (as shown in Figure 2-11).

When the Trash inverts, release the mouse button and, voilà, whatever you dragged to the Trash is trashed. But it's not gone forever until . . .

. . . you choose Special→Empty Trash. You know how the garbage in the can in your kitchen sits there until the sanitation engineers come by and pick it up each Thursday? The Macintosh Trash works the same. When you put something in the Trash, it sits there until you choose the Special→Empty Trash command.

Think twice before you Empty Trash. Once the Trash has been emptied, the files it contained are gone forever. (Of course, you read Appendix B and you've backed up your hard disk several times, right? So even though the files are gone forever from your hard disk, you *can* get them back if you like, right?)

As with all icons, you can open the Trash (you know at least three ways to open an icon) to see what's in there. You can tell there's something in the Trash because the Trash icon bulges when it's full (as shown in Figure 2-12).
Part I: Basic Training

What the heck's the Finder, anyway?

You may have noticed that I use the words Finder and desktop interchangeably. As you probably know, the Finder is one of the files in your System Folder. The Finder is a superprogram. Among other things, it creates the desktop metaphor — the icons, windows, and menus that make up the Macintosh desktop. Unlike ordinary programs, you can never quit the Finder. Like Katz's Deli, the Finder never closes. And unlike ordinary programs, you don't have to open the Finder to use it. The Finder is always open; it opens automatically when you turn on your Mac.

Because the Finder is, among other things, responsible for creating the desktop and its menus, many people, myself included, use the words Finder and desktop interchangeably. You can too.

The only time it gets confusing is when you are talking about the Finder icon in your System Folder. Just say "the Finder icon" instead of "the Finder" and you'll sound like a pro. It can also be confusing when you're talking about the gray desktop.

By the way, you can quit the Finder if you really want to and you're handy with ResEdit, Apple's resource editing utility. But that's power-user voodoo and you'll have to buy a different book, preferably one from IDG Books, such as *Macworld Mac and PowerMac SECRETS* (he says, scoring massive brownie points with his publisher), if that kind of hacking turns you on.

There are utility programs available that let you retrieve a trashed file after you empty the Trash. Norton Utilities and the recently discontinued MacTools are the two most popular. They don't have a 100-percent success rate, so you should still consider the Empty Trash command fatal to files.

If you drag an icon that's locked to the Trash, you'll see a message telling you to hold down the Option key when you choose Special→Empty Trash to delete locked items. (To unlock locked icons, select the icon and then choose File→Get Info or press its keyboard shortcut, Command-I, and then click the little box marked "locked.")

Close encounters of the icon kind

If you've used System 7.5 or Mac OS 7.6 for very long, you've probably encountered a couple of other icons. You probably have an icon for a desktop printer on your desktop, which Figure 2-13 illustrates.
Chapter 2: Meet the Desktop

Each desktop printer icon represents one printer available to your Mac or one set of printer-specific settings (scale, tile, crop, and so on). You may even have more than one desktop printer icon. If you don't have even one, don't fret. I show you how to make one in Chapter 7.

If you have any other icons on your desktop, ignore them for now. They probably won't hurt anything.

Windows (Definitely Not the Microsoft Kind)

Windows are such a fundamental part of the Macintosh experience that Microsoft blatantly ripped off the name for their operating system add-on.

Do your friends a favor. Before they buy a personal computer, make sure they know that Windows is not a Mac, regardless of what the lousy salesperson at the computer store says.

If you're relatively new to the Mac, you might want to read this section while sitting at your computer, trying the techniques as you read them. I've always found it easier to remember something that I read if I actually do it. If you've been abusing your Mac for a while, you've probably figured out how windows work by now, but there's still some stuff in here you may not have tried. Your mileage may vary.

Doin' windows

Windows are a ubiquitous part of Macintosh computing. Windows on the desktop show you the contents of disk and folder icons; windows in applications usually show you the contents of your documents.
You've already discovered three different ways to open an icon, so you know how to open a window. When you open a window, its icon turns fuzzy gray (see Figure 2-14), which is your Mac's way of letting you know that that icon's window is open. Clever, eh?

**Figure 2-14:**
A fuzzy gray (that is, open) icon.

---

**Zooming right along . . .**

Notice how the Macintosh HD window in Figure 2-15 says "4 Items" near the top, but only one item seems to be showing. That's easily remedied. To make a window larger, click the zoom box in the upper-right corner (see Figures 2-16). This action causes the window to grow, which should reveal the rest of its contents.

**Figure 2-15:**
This window says that it contains four items, but you only see one. What gives?

---

I say "should" because if a window contains more icons than the window can display, it grows as large as it can and still leave room for your disk and Trash icons on the right side of the screen when you click the zoom box.

Click the zoom box again to return the window to its original size.
Figure 2-16: When you click the zoom box in the upper-right corner of the window (left), the window expands to show all the items it contains (right).

Cutting windows down to size

Another way to see more of what’s in a window is by using the size box in the lower right corner. It’s shown in Figure 2-17 on the left. Click the size box and drag downward and to the right to make the window larger, as shown on the right in Figure 2.17. You use the size box to make a window whatever size you like.

Figure 2-17: Click and drag the size box (detailed at left); then drag down and to the right to make a window larger (as shown on the right) or up and to the left to make it smaller.
Notice the faint white lines; they're there to show you the size the window will be when you release the mouse button. Go ahead and give it a try; it's fun, it's easy, and it's free.

**A scroll new world**

Yet another way to see more of what is in a window is to scroll. You scroll using *scroll bars*, which appear on the bottom and right sides of any window that contains more icons than those that you can see in the window (see Figure 2-18).

There are four ways to scroll:

**Way #1:** Click a *scroll box* and drag, as shown in Figure 2-19.

**Way #2:** Press on a *scroll arrow* (see Figure 2-20).

**Way #3:** Click in the gray *scroll bar* area, as shown in Figure 2-21.
If the scroll bar is white, then there are no items to scroll to — everything that the window contains is visible.

Clicking the gray scroll bar scrolls the window a lot; clicking a scroll arrow scrolls the window a little; and pressing and dragging the scroll box scrolls the window an amount that corresponds to how far you drag it.

Way #4: Use the keyboard. Select an icon in the window first and then use the arrow keys to move up, down, left, or right. Using an arrow key selects the next icon in that direction and automatically scrolls the window if necessary.

You can also press the Tab key on the keyboard to select the next icon alphabetically. So if I clicked SimpleText and then pressed the Tab key, the System Folder (the icon that comes next alphabetically) would be selected. If the System Folder wasn’t showing when I selected SimpleText, the Macintosh HD window would scroll automatically to reveal the System Folder after I pressed the Tab key.

For what it’s worth, the Page Up and Page Down keys on extended keyboards function the same as clicking the gray scroll bar area (the vertical scroll bar only) in the Finder and many applications. But these keys don’t work at all in some programs, so don’t get too dependent on them.

Transportable windows

To move a window, click anywhere in the title bar (shown in Figure 2-22) and drag the window to its new location. Figure 2-23 shows an example of moving a window. The title bar is the striped bar at the top of the active window. It contains the window’s name as well as the close box and the zoom box.
The window moves to its new position as soon as you release the mouse button.

![Figure 2-23: Click and drag the title bar to move a window to a new location.](image)

Just below the title bar is the window's status line, which tells you the number of items the window contains (4), the amount of used space on this hard disk (22.1 MB), and the amount of space available on this hard disk (132 MB).

**Ladies and gentlemen, activate your windows**

In order to work with a window, the window must be active. Only one window at a time may be the active window. To make a window active, click it anywhere — in the middle, on the title bar, on a scroll bar. It doesn’t matter where.

The active window is always the front-most window, and inactive windows always appear behind the active window. The active window’s title bar has black lines; its size, zoom, and close boxes are defined, as are its scroll bars. Inactive windows show the window’s name but none of those other distinctive window features. See Figure 2-24 for an illustration of active and inactive windows.

**Shuttin’ yo’ windows**

Now that you know just about all there is to know about windows, I suppose I ought to tell you how to close them. Here we go again with the ways. There are three ways to close an active window:
Way #1: Click the close box in the upper-left corner of the title bar (see Figure 2-25).

Way #2: Choose File→Close Window (see Figure 2-26).

Way #3: Use the keyboard shortcut Command-W. Note that in Figure 2-26, the Close Window command in the File menu has this keyboard shortcut listed next to it.

If you’re like me, by the end of the day, you’ve got windows open all over your desktop, sometimes a dozen or more. Wouldn’t it be nice if there were a way to close them all at once with a single “close all windows” command? But you don’t see a Close All command in the menus, do you?
Part I: Basic Training

Figure 2-26:
You can use the Close Window command in the File menu to close an active window.

You will in a second. There is a way, but Apple, in its infinite wisdom, has hidden it from mere mortals. To make this useful command come out and play, merely hold down the Option key as you close the active window using Ways #1, #2, or #3. In other words, hold down the Option key when you click the active window's close box, hold down the Option key when you choose File→Close Window, or hold down the Option key and the Command key while you press the W key (Command-Option-W).

Apple didn't hide the Close All command very well. As Figure 2-27 illustrates, if you press the Option key before pulling down the File menu, Close Window is magically transformed into Close All.

Figure 2-27:
Hold down the Option key while pulling down the File menu and you'll see the Close All command instead of the Close Window command.
Chapter 2: Meet the Desktop

The remarkable WindowShade effect

System 7.5 introduced a new wrinkle to windows, the WindowShade effect. The WindowShade effect doesn't actually close windows; it rolls them up. You get a chance to play with this feature in Chapter 12, but I thought it important to mention here. If you can't wait to try it, turn on WindowShade (it's in the Control Panels folder inside your System Folder) and then double-click the title bar of a window. Figure 2-28 shows an example.

![Figure 2-28: Double-click the title bar of a window to roll it up.](image)

The window “rolls up” and only the title bar remains. To unroll the window, double-click the title bar again.

You can control WindowShade’s behavior — turn the WindowShade effect or its associated whooshing sound on or off, or change the trigger keys — with the WindowShade control panel, which I talk about in Chapter 12.

Congrats: You now do windows

That retires the side. You now possess a massive, all-encompassing, thoroughly pervasive knowledge of windows and how they work. You can do windows with the best of them.

And I have good news for you: Windows in 99 percent of all applications (programs) that you will ever encounter work the same as windows in the Finder. Just about every application has active and inactive windows with title bars, close boxes, zoom boxes, scroll bars, scroll arrows, and scroll boxes.

Windows are windows, for the most part. As you use different programs, you'll probably notice that some of them (Microsoft Word, for example) take liberties with windows by adding features such as page counters and style indicators to the scroll bar area. Don't worry. You know how to do windows. That stuff is just window dressing (pun intended).
Disk Could Be the Start of a Beautiful Friendship

Groan. I apologize but assure you that you don't want to hear the alternatives. While I don't think there's such a thing as a good pun, in retrospect, this one is particularly odious. Sorry.

You should think of the disk icons that appear on your desktop as if they were folders. When you double-click them, their windows open. You can drag stuff in and out of a disk's window, and you can manipulate the disk's window in all the usual ways.

Initialization and erasure

Brand new disks usually need to be initialized — prepared to receive Macintosh files — before you can use them. I say usually because you can buy new disks that are preformatted and are already initialized. It only takes a couple of minutes to initialize a disk, so don't pay a whole lot more for preformatted disks unless you really believe that time is money.

When you pop an uninitialized disk into your Mac, it will walk you through all the steps necessary to initialize it. If you need extra help, see Macs For Dummies.

If you want to re-initialize a disk that already been initialized (say you want to turn a DOS disk into a Mac disk, or vice versa) just pop the disk in your drive and choose the Erase Disk command from the Special menu.

Surprise: PC disks work as well!

One of Mac OS 7.6's most excellent features (if you have friends unfortunate enough not to own Macs and you want to share files with them) is the fact that it reads both Mac and DOS floppy disks without any user intervention. DOS disks are formatted for use with personal computers running DOS or Windows. If a friend has a Windows computer, you can now read his or her disks by just sticking them in your floppy drive. Your unfortunate friend, on the other hand, can't do diddly squat with your Mac-formatted disks — yet another reason why Macs are better.

When you insert a disk formatted for DOS, you'll see a distinctive PC disk icon like the one in Figure 2-29. PC files on the disk sport distinctive PC icons as well (shown in Figure 2-30).
There are two other disk formats that you might run into: ProDOS is the Apple II format, rarely used any more, and Macintosh HFS Interchange Format is a weirdo format nobody I know uses for anything.

**Getting disks out of your Mac**

You know about everything there is to know about disks except one important thing: how to eject a disk. Piece of cake, actually.

And, of course, there are four ways.

**Way #1:** Click the disk's icon to select it. Then choose Special→Eject Disk. Notice how even though the disk has been ejected and is probably in your right hand, its icon still appears on the desktop, albeit with an unusual ghostly gray pattern (see Figure 2-31).
The ghostly gray indicates that the disk is not currently mounted (inserted). Note that a dismounted disk's icon is not the same as that of a disk with its window open. The icon of a disk with its window open is shown in Figure 2-32.

Figure 2-32: The icon of a disk with its window open. See the difference?

Why would you want the icon for an ejected disk on your desktop? So you can copy files from one floppy disk to another even though you have only one floppy disk drive. There's a whole section on copying files coming up in a few pages.

Way #2: Use the keyboard shortcut Command-Shift-1. This action also ejects the disk but leaves its icon on the desktop.

Way #3: Drag the disk's icon to the Trash. The disk's icon does not remain on the desktop after you trash it (see Figure 2-33).

Figure 2-33: You can drag a disk's icon to the Trash to eject it.

Way #4: Select the disk and then choose File → Put Away (or use its Command-key shortcut, Command-Y).

If you drag a disk's icon to the Trash or use the Put Away command, the disk's ghost icon is not left on the desktop. If you used Way #1 or Way #2 to eject your disk, you can get rid of its ghost image by dragging the ghost icon to the Trash or selecting it and choosing File → Put Away. Unless you plan to copy files from one floppy to another, you don't want floppy disk icons on your desktop after you eject the disks. Ways #3 and #4 are the most commonly used methods of ejecting a disk.
If you insist on leaving ghost icons of long-ago-ejected disks on your desktop, it's only a matter of time before your Mac presents you with the dreaded "Please insert the disk" dialog box, which is shown in Figure 2-34.

Notice that there is no OK or Cancel button in the dialog box in Figure 2-34. There's no way out but to insert the disk your Mac is asking for.

Okay, I lied. There is a way out. Press Command-period. This keyboard shortcut cancels the dialog box and lets you drag the ghost disk icon to the Trash. Command-period is a good shortcut to remember. In most dialog boxes, pressing Command-period is the same as clicking the Cancel button.

The dreaded "Please insert the disk" dialog box usually appears if you try to open the icon for an unmounted disk or try to open any of the files in the unmounted disk's window.

Get in the habit of dragging disks to the Trash or using the Put Away command to get disks off your desktop. Both techniques eject the disk and get rid of its pesky ghost icon. Unless you plan to copy files from one floppy to another, which you don't do all that often, these methods are the best ways to eject a disk.

Up the Organization: Copying and Moving Files and Folders

Now that you know icons and windows and disks, it's time to get serious and learn something useful, like how to work with folders and how to move and copy icons from folder to folder and from disk to disk.
Know when to hold 'er, know when to folder

If your hard disk is a filing cabinet, folders are its folders. Duh. You use folders to organize your icons.

Makin' folders

To create a new folder, first decide which window you want the new folder to appear in. Make that window active by clicking it. Now either choose File→New Folder or use the shortcut Command-N. A new, untitled folder appears in the active window with its name box already highlighted and ready for you to type a new name for it (see Figure 2-35).

Name your folders with relevant names. Folders entitled sfdgghb or Stuff — or worst of all, names like Untitled — won’t make it any easier to find something six months from now.

Usin' 'em

Folders are icons; icons are containers. Folder icons (like disk icons) can contain just about any other icon.

You use folders to organize your stuff. There's no limit to how many folders you can have, so don't be afraid to create new ones and put stuff in them.

At the very least, you should have a System Folder (if you don’t, go back and read Chapter 1 again). Until you get a lot of stuff, may I suggest that you start out with Application and Document folders, at the very least. You can even have the Mac create these two folders automatically by using the General Controls control panel (more about that in Chapter 12).
Later, when you get more files, you can subdivide the Documents folder into meaningful subfolders like those shown in Figure 2-36.

![Figure 2-36: The Documents folder contains numerous subfolders, each of which contains sub-subfolders.](image)

As your subfolders get fuller, create subfolders within them. The idea is to have enough folders so that no one folder ever has hundreds of items in it, while simultaneously avoiding folders with only one or two items in them. Strive for balance. And try not to go deeper than four or five levels. If you find yourself creating subfolders that you have to open eight folders to get to, consider reorganizing the stuff in levels five through eight so that your folder hierarchy is no more than five levels deep. Trust me, you'll save a lot of time if you don't stash stuff ten folders deep.

**Moving and copying and folders**

You can move icons around within windows to your heart's content. Just click and drag within the window.

Now let's look at how you move an item into a folder. For example, let's see how you move one folder into another. As you might expect from me, the King of Ways, there are two ways to do it.

As shown in Figure 2-37, drag the icon for One Folder onto the icon for Another and release when Another folder is highlighted. This technique works regardless of whether Another folder's window is open. If its window is open, you can use the second way.
Drag the icon for One Folder into the open window for Another folder (or disk), as shown in Figure 2-38.

Notice the little gray border that appears around Another folder's window in Figure 2-38. This is your Mac telling you that if you release the mouse button right this second, the One Folder icon will be moved into Another folder. If you move the pointer out of the Another folder window, the gray border disappears.

You use these two techniques to move any icon — folder, document, System software, or program icons — into folders or disks.

Before you read the next section, you should know that if you try to move an item from one disk to another disk, it will be copied, not moved. Always. Without exception. If you want to move a file or folder from one disk to another, you have to trash the original manually after the copying is complete.

But what if you don't want to move something from one place to another on your hard disk? What if instead you want to copy it, leaving the icon in its original location and an identical copy in the destination window?
Chapter 2: Meet the Desktop

You might be thinking, why would I want to do that? Trust me, someday you will. Say you’ve got a file called Long Letter to Mom in a folder called 1987 Correspondence. You figure Mom’s forgotten it by now, so you want to send the letter again. But before you do, you want to change the date and delete the reference to Clarence, her pit bull, who passed away last year. So you want a copy of Long Letter to Mom in your 1997 Correspondence folder.

There are three ways to copy, but the first two are the same as you saw in the One Folder and Another example, with one small difference — you must hold down the Option key during the dragging portion of the move. In the Finder, Option-dragging an icon to any folder icon or window copies it instead of moving it. So you Option-drag the Letter to Mom icon onto either a folder icon or an open window to deposit a copy.

Now you have two copies of the file Long Letter to Mom, one in the 1987 Correspondence folder and another copy in the 1997 Correspondence folder. Open the one in the 1997 folder and make your changes. Don’t forget to save. (There’s more about saving in Chapter 5.)

If I were you, I’d change the name of the 1997 copy, as it’s not a good idea to have more than one file on your hard disk with the same name, even if the files are in different folders. Trust me, having ten files called Expense Report or 15 files named Randall’s Invoice can be confusing, no matter how well organized your folder structure is. Add something distinguishing to file and folder names so that they’re Expense Report 10/95 or Randall’s Invoice 10/30/95. You’ll be glad you did.

The third way to copy a file is to use the File › Duplicate command, which is covered in the very next chapter.

Moving and copying and disks

Moving an icon from one disk to another works the same as moving folders in the previous example. Because you’re moving the icons from one disk to another disk, the copy part is automatic; you don’t need the Option key. As I mentioned before, when you move a file from one disk to another, you’re automatically making a copy of it. The original is left untouched and un­moved. If you want to move a file from one disk to another, copy it. You can then delete the original by dragging it to the Trash.

Copying the entire contents of a floppy disk to your hard disk works a little differently. To do this task, select the floppy disk’s icon and drag it onto your hard disk’s icon or onto your hard disk’s window, as shown in Figure 2-39 and 2-40. A progress bar appears (see Figure 2-41).
Figure 2-39:
To copy the entire contents of a floppy disk to your hard disk, you can drag the floppy disk's icon onto your hard disk's icon.

Figure 2-40:
You can also drag a floppy disk's icon onto a hard disk's open window to copy the floppy's entire contents to the hard disk.

Figure 2-41:
When you copy items, a progress bar shows you what's happening.
When the progress bar disappears, a folder bearing the same name as the floppy disk appears on your hard disk, as Figure 2-42 shows.

![Figure 2-42: The entire contents of the floppy named Mac Underground have been copied to a folder of the same name on the hard disk.](image)

The folder on your hard disk now contains each and every file that was on the floppy disk of the same name.

By the way: You can drag a floppy disk icon onto any folder icon or window on your hard disk if you like, not just onto the first level of your hard disk (that first level is sometimes called the root level). Just substitute the folder's icon or window for the Macintosh HD icon and window in the previous example.

Be careful when copying disks containing System Folders to your hard disk. You never want to use the aforementioned technique to copy a floppy to your hard disk if the floppy has a System Folder. One hard and fast rule of the Mac is that there should never be more than one System Folder on your hard disk.

If a floppy disk contains a System Folder and you want to copy everything else to your hard disk, do the following: Create a new folder on your hard disk. Then select every icon in the floppy disk's window except the System Folder and drag all the selected icons onto the new folder's icon or window.

To select more than one icon, click once and drag. You see an outline of a box around the icons as you drag, and icons within the box are highlighted (see Figure 2-43).

Another way to select multiple icons is to click one and then hold down the Shift key as you click others. As long as you hold down the Shift key, each new icon you click is added to the selection. To deselect an icon, click it a second time while still holding the Shift key down.
Be careful with multiple selections, especially when you drag icons to the Trash. It's easy to accidentally select more than one icon, so it's possible to put an icon in the Trash by accident if you're not paying close attention. So pay close attention.

**Meet the desktop**

Earlier, I said that the terms *Finder* and *desktop* were used interchangeably, referring to the total Macintosh environment you see — icons, windows, menus, and all the other cool stuff. Well, just to make things confusing, the background you see on your screen, the gray or patterned backdrop behind your hard disk icon and open windows, is also called the desktop.

Any icon can reside on the desktop. Just move icons to the desktop from any window. It's not a window, but it acts like one. You can move any icon there if you like; the desktop is a great place for things you use a lot, like folders, applications, or documents that you use every day.

It's even better to use aliases of things you use often so that you can keep the originals tucked away in one of your perfectly organized folders. But I'm not going to talk about aliases until Chapter 3, so for now, just tuck that little tidbit away in the back of your mind.

In Figure 2-44, you see five items (six if you count the Macintosh HD window) on my desktop: Macintosh HD (disk icon), Documents (folder icon), SimpleText (application icon), Read Me (document icon), and the Trash icon.

Disk icons always appear on the desktop, as does the Trash icon. The other icons — a document, a folder, and an application — were moved from the root level of Macintosh HD to the desktop by me to make them easier to use.

Items on the desktop behave the same as they would in a window. You move them and copy them in the same way as you would an icon in a window — except that they're not in a window; they're on the desktop, which makes them more convenient to use.
Chapter 2: Meet the Desktop

Figure 2-44: My desktop, with some stuff on it.


But not too much. If you keep putting stuff on the desktop, eventually it gets very cluttered. That's the time to put infrequently used icons on the desktop back in the folder or disk window they came from. Fortunately, your Mac makes this task easy, even if you've forgotten which folder they were in. Select the icon or icons that you want moved back to where they came from and then choose File→Put Away. The icon is magically transported back into the folder or disk icon from which it came and no longer appears on the desktop. Neat, eh?

Many users cover their desktops with icons, sometimes dozens or more. That's because the desktop is the most convenient place for things that you use often. You save time and effort because you don't have to open any windows to open an icon on the desktop.

I talk more about convenience, the desktop, and cool techniques for making life with your Mac easier and more productive in Chapter 6.
In This Chapter
- Menu basics
- The File menu
- The Edit menu
- The View menu
- The (near-worthless) Label menu
- The Special menu
- Help and the Help menu
- The Application menu

Like icons and windows, menus are a quintessential part of the Macintosh experience. In this chapter, you’ll take a brief look at each and every Finder menu item.

I’m trying to provide an appropriate level of detail based on the menu item’s importance. On the other hand, I think the entire Label menu is dumb; you may think it’s the best thing about Mac OS 7.6. (I hope not!)

Anyway, I start with a few menu basics and then move on to the menus in almost the order they appear on your screen: File, Edit, View, Label, Special, Help, and Application. Because it’s so long, I’m going to give the Apple menu its own chapter, the very next one after this one.

Menu Basics

Mac menus are often referred to as pull-down menus. That’s because to use them, you press on their name to make the menu appear and then pull (drag) down to select an item. Piece of cake, eh?
Command performance

As noted previously, many menu items have Command-key shortcuts after their names. These key combinations indicate that you can activate that menu item without using the mouse by pressing the Command (notice I refrained from calling it a pretzel) key and then pressing another key without releasing the Command key. And as I've said before and will say again, it pays to memorize the shortcuts you use often.

It's elliptical

Ellipses, in case your English teacher forgot to mention them, are the three little dots (…) that appear after certain menu items' names. According to the Bible (actually, the Chicago Manual of Style, but for writers it might as well be the Bible), “Any omission of a word or phrase, line or paragraph . . . must be indicated by ellipsis points (dots). . . .”

Apple is true to this definition. Ellipsis points in a menu item mean that choosing it will bring up a dialog box where you can make further choices. Choosing a menu item with an ellipsis never actually makes anything happen other than opening a dialog box, where you make further choices and then click a button to make things happen.

Dialog box featurettes

Dialog boxes may contain a number of standard Macintosh features such as radio buttons, pop-up menus, text entry boxes, and check boxes. You'll see these features again and again, in dialog boxes, control panels, and elsewhere. So let's take a moment to look at each of these featurettes and I'll demonstrate how they're used.

Radio, radio (buttons)

Radio buttons are called radio buttons because, like the buttons on your car radio, only one can be pushed at a time. Radio buttons always appear in groups of two or more; when you push one, all the others are automatically unpushed. I think eggheads call this setup "mutually exclusive." Take a look at Figure 3-1 for an example of radio buttons.
Chapter 3: A Bevy of Delectable Menus

Figure 3-1: A group of radio buttons.

Set the print time priority to:
- Normal: print now
- Urgent: print before other documents
- Print at: 10:53 AM 5/22/94
- Hold document in printer “Bob’s Printer”

In Figure 3-1, Normal: print now is currently selected. If you click any of the other choices, Normal: print now will be deactivated.

*Menus redux: Pop-up style*

Pop-up menus are called pop-up menus because that’s what they do — they pop up when you press on them. You can always tell a pop-up menu because it appears in a rectangle with a shadow and a down-pointing arrow. Figure 3-2 shows a pop-up menu before you click it; Figure 3-3 shows the same menu after you click it and hold the mouse button down.

Okay, so now you’ve looked at two features, radio buttons and pop-up menus, and they both do the exact same thing: allow you to make a single selection from a group of options. Sometimes a radio button is associated with a text entry box, which happens to be the feature I cover next.
Chapter 3: Text Entry and Checkboxes

Championship boxing: Text entry style

Text entry boxes let you enter text (including numbers) from the keyboard. When a text entry box appears in conjunction with a radio button, the text entry box or boxes only matter if the associated radio button is pressed. Take a look at Figure 3-4. You can enter text in the two text entry boxes next to the From radio button, but if you click the All radio button, your text disappears. Conversely, if you click in one of the text entry boxes and type, the From radio button automatically becomes selected.

Had Apple chosen to use a pop-up menu instead of radio buttons in the Figure 3-4 example, the menu would have taken up more valuable screen real estate. So that's the reason for two featurettes that do the same thing.

And now you know how to use both.

---

Checkmate

The last featurette you'll see frequently is the check box. Check boxes are used to choose items that are not mutually exclusive. In a group of check boxes, you can turn each one on or off individually. Check boxes are on when they contain an X and off when they're empty. Figure 3-5 shows two check boxes that are both on.

---

Figure 3-4: Type letters or numbers into text entry boxes such as these.

---

Figure 3-5: In this example, both check boxes are checked.

---

Show alert:
- Before printing starts
- After printing finishes
Unlike radio buttons, which force you to choose one and only one item, check boxes are independent. Each one can either be on or off.

Here's a nifty and undocumented shortcut: Check boxes and radio buttons can usually be activated by clicking their name (instead of clicking the button or box). Didn't know that, did you?

File Management and More: Meet the File Menu

The File menu (shown in Figure 3-6) contains commands that let you manipulate your files and folders.

Eagle-eyed readers may have noticed that I have a larger hard disk (2 gigabytes) in this screen shot than in previous chapters (160 megabytes). You can tell by looking in the window header — add the two numbers together to get the approximate disk size. I want to thank Dr. Paul McGraw at APS Technologies for supplying a fast 2-gigabyte drive for me to use until the end of the book.

Menu items that can be used to act upon the item or items selected in the active window (or on the desktop) appear in black and are currently available; menu items not available at the current time are displayed in gray. You cannot select a gray menu item.
In this example, only two items are disabled — Print and Put Away. That’s because you can only print documents, not folders, and the selected item in the active window is a folder (Docs). And the Put Away command is dimmed because you can only put away items that reside on the desktop. The rest of the commands appear in black and are valid selections at this time.

**New Folder (Command-N)**

I talked about this command in the last chapter, but just for the record, New Folder creates a new, untitled folder in the active window. If no window is active, it creates a new folder on the desktop.

You’ll probably do a lot of new-folder making, so it might be a good idea to memorize this command’s keyboard shortcut, Command-N. It’ll come in handy later, as most software uses the shortcut Command-N to create a new document, another thing you’ll do a lot of.

If your memory is bad, use this mnemonic device — N is for New.

Most menu items, or at least most common ones, have keyboard shortcuts that have a mnemonic relationship to their name. For example, New is Command-N, Open is Command-O, Get Info is Command-I, Make Alias is Command-M (which is good news because in earlier versions of System 7, there was no keyboard shortcut for Make Alias), and so on.

**Open (Command-O)**

This command opens the selected item. Not much more to say, except to remind you that in addition to the menu command and its shortcut Command-O, a double-click also works.

**Print (Command-P)**

This command, which prints the selected item, is only active if the selected item is a document. Furthermore, it only works if you have the application that created the document on your hard disk. If you try to print (or open) a document when you don’t have the application that created it, you see a dialog box like the one shown in Figure 3-7.
I talk about translators when I discuss Macintosh Easy Open in Chapter 12. For now, leave it at this: If you select a document icon and then use the Open or Print command, the command will only work if you have the application that created the document or another application that is capable of opening that type of document.

That's where the translator part comes in (refer to Figure 3-7 again). Many programs can open files created by another program, but only if the proper translator is available. I'll save the details for later.

**Close Window (Command-W)**

This command closes the active window. Duh. Don't forget, if you hold down the Option key before you click the File menu, this command changes to Close All.

I talked about this command in Chapter 2, so I'll just move on.

**Get Info (Command-I)**

When you select any icon and choose the Get Info command (or use its keyboard shortcut Command-I), a Get Info window opens (see Figure 3-8).
The top portion of the Get Info window provides details about the icon, such as what it is (application, document, disk, folder, and so on), how big it is, where it is on your disk, when it was created, when it was last modified, and its version number.

The middle section is called the Comments box because that's where you type your comments about the icon. Don't get too fond of comments. I don't recommend ever using this Comments box because the comments may disappear after you rebuild your desktop or restore from a backup, and as I discuss in Chapter 12 and Appendix B, you should rebuild your desktop and back up your hard disk on a regular basis.

The bottom section of an application's Get Info box deals with its memory requirements. This stuff gets a little complicated, so I won't go into it here. (If you just can't wait, skip ahead to my dandy and easy-to-understand explanation in Chapter 9.)

The last item in an application's Get Info box is the Locked check box. When an application is locked, its name can't be changed, and it can't be emptied from the Trash. (I mentioned locked files and the Trash briefly in Chapter 2 as you may remember.)

If you try to empty the Trash when there's a locked item in it, you'll see a message telling you to hold down the Option key before you choose Special>Empty Trash. Holding down the Option key when you choose Empty Trash empties the Trash even if there are locked items in it.
Artistic icons

The Get Info box serves another more frivolous but fundamentally fun function — it lets you change any icon's icon to anything you like.

Don't like the Mac's folder icon? Give it a new one. Here's how. Find an icon you like — let's say it's an armadillo (hey, I'm a Texan!). Select it and select the Get Info command. Now select the folder that you want to give the 'dillo icon to and bring up the Get Info window. In the upper-left corner of the 'dillo's Get Info box, you'll see the 'dillo (see below).

Click the 'dillo in its Get Info box. A box will appear around the 'dillo icon, indicating that it's now selected. Choose Edit: Copy, as shown in the following figure.

Now click the folder icon in its Get Info window and choose Edit: Paste. The results of this last step are shown below.

There you go! This technique works on any icon — disk, folder, application, or document. And if you can't find an icon you like, you can create a picture in any graphics program, select it, choose Edit: Copy, and then paste it into the Get Info box of any icon.

Furthermore, online services like CompuServe and America Online, as well as Macintosh user groups and the Internet, offer humongous collections of icons for your pasting pleasure.
While I’m on the subject, do you hate the dialog box you see each time you try to empty the Trash (you know, the one that says: “The Trash contains X items. It uses X K of disk space. Are you sure you want to permanently remove it?”)? If you never want to see this pain-in-the-bottom dialog box again, select the Trash icon, the Get Info command (Command-I), and uncheck the Warn before emptying check box.

Documents, folders, and disks each have slightly different Get Info boxes. Folders and disks can’t be locked; documents and applications can. And the Get Info box for documents includes an additional check box to make the document a Stationery pad. (Stationery pads are neat. They’re also covered in Chapter 5.)

Sharing (no keyboard shortcut)

The Sharing command lets you decide who can share your files. There’s so much to say about Macintosh file sharing that I could write an entire chapter about it. And in fact, I have. If you’re interested, take a look at Chapter 8.

Duplicate (Command-D)

Duplicate duplicates the selected icon. More precisely, it makes an exact copy of the selected icon, adds the word copy to its name, and places the copy in the same window as the original icon. Figure 3-9 shows the results of using the Duplicate command.

The Duplicate command can be used on any icon except a disk icon.
Chapter 3: A Bevy of Delectable Menus

Make Alias (Command-M)

Aliases are a wonderful, fabulous organizational tool introduced with System 7.0. An alias is a tiny file that automatically opens its parent file. To create an alias for any icon, select the icon (the parent) and then choose File→Make Alias or press Command-M.

When you open an alias, the parent opens.

An alias is different from a duplicated file. For example, my word processor, Microsoft Word 6.0.1, uses 7.8 megabytes of disk space. If I duplicated it, I would have two files, each using almost 8 megabytes of disk space. An alias of Microsoft Word, on the other hand, uses a mere 32K.

Due to a variety of complicated and unimportant reasons having to do with sector size and hard disk size, your mileage may vary depending on the size of your hard disk. In general, the smaller the disk, the smaller the aliases will be.

When you make an alias, it has the same icon as its parent, but its name appears in italic type and the suffix alias is tacked onto its name. Figure 3-10 shows an alias and its parent icon.

You can put aliases in convenient places like the desktop or the Apple Menu Items folder (so that they appear in your Apple menu).

There must be at least a dozen ways aliases can help organize your Macintosh existence, and I talk about all of them in Chapter 6.
**Put Away (Command-Y)**

Choose Put Away to move the selected icon from your desktop to the window it was in before you moved it to the desktop. This command even works if it's been years since the icon was moved to the desktop and you don't remember which folder it came out of.

The Put Away command is only active when an icon on the desktop is selected; it is dimmed whenever any icon in a window is selected. Put Away is also dimmed when the Trash icon is selected.

And as mentioned previously, the Put Away command can eject a floppy disk and remove its ghost icon from the desktop. In other words, Put Away has the same effect on a floppy disk as dragging its icon to the Trash does.

**Find (Command-F)**

Use this command when you need to find an icon on your hard disk and you can't remember where you put it. This is a Mac OS 7.6 feature that really kicks earlier versions' butts. The Find command (first implemented in System 7.5) is awesome.

There are three different ways to invoke the Find dialog box (here I go again with the ways).

- Choose File→Find.
- Use the keyboard shortcut Command-F.
- Choose Find File from the Apple menu.

Whichever way you choose, the next thing you'll see is the Find dialog box (shown in Figure 3-11).
Chapter 3: A Bevy of Delectable Menus

Just type in the name of the file that you're looking for and then click the Find button or press the Return key. In a flash (Mac OS 7.6's Find is even faster than earlier incarnations), you see the Find File Results window (see Figure 3-12) showing every file on the disk you searched that matches the word you typed in the text entry box.

In Figure 3-12, the file Letter to Bob is in the Letters folder, which is in the Documents folder, which is on the Macintosh HD.

At this point there are three ways to open the file:

- Choose File→Open Item.
- Use the keyboard shortcut Command-O.
- Double-click the file in the top or bottom part of the Find File Results window.

If you prefer to open the folder that contains the item, there are three ways to do that:

- Choose File→Open Enclosing Folder.
- Use the keyboard shortcut Command-E.
- Double-click the folder in the bottom part of the Find File Results window.
If searching by name alone finds too many files, you can narrow your search by clicking the More Choices button in the Find dialog box and adding one or more additional criteria for the search. These criteria include the following:

- Size of file
- Kind of file (application, alias, and so on)
- Label (see the Label menu section later in this chapter)
- Creation Date (date the file was created)
- Modification Date (date the file was last saved)
- Version Number (is or is not)
- Lock Attribute (file is locked or not)
- Folder Attribute (empty, shared, or mounted)
- File Type code
- Creator Type code

Figure 3-13 shows what the Find dialog box looks like after you click the More Choices button.

**Find Again (Command-G)**

I dunno. This seems pretty dumb to me. As far as I can tell, it does the exact same thing as the Find command — opens the Find dialog box. I think it's a relic from earlier versions of System 7.
Page Setup (no keyboard shortcut)

Choosing Page Setup brings up the Page Setup dialog box (shown in Figure 3-14), which is where you specify the type of paper in your printer (letter, legal, envelope, and so on), page orientation (longways or wideways), and scaling (100% = full size).

In addition to the one here in the Finder, there is a Page Setup command in almost every program that you use. There’s a whole chapter on printing coming up in a little while (Chapter 7, to be exact), so I’ll leave this topic alone for now.

Print (no keyboard shortcut)

This command is a little tricky. If no windows are open, the command is called Print Desktop. If a window is open, the command’s name changes to Print Window.

If you choose Print Desktop, your Mac prints a picture of your desktop, with its icons and Trash (but not the menu bar), exactly as you see them on the screen. If you have anything but a 9” built-in monitor, this image requires two pieces of paper.

If you choose Print Window, your Mac prints a picture of the active window, showing all the icons it contains, even if you would have to scroll to see the icons on the screen. If the window contains a lot of icons, printing this document may require more than one sheet of paper.

And if a document is selected when you choose the Print command, the application that created the document launches automatically and opens a Print dialog box. (Printing is covered in full and loving detail in Chapter 7)
The Print dialog box, which appears when you select the Print command, is shown in Figure 3-15.

Again, Chapter 7 covers printing, so let's move on.

The Edit Menu (Which Shoulda Been Called the Clipboard Menu)

In contrast to the File menu, which has commands that mostly deal with file management and are exclusive to the Finder, the Edit menu’s commands and functions are available in almost every Macintosh program ever made (see Figure 3-16).

<table>
<thead>
<tr>
<th>Edit</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>⌘Z</td>
</tr>
<tr>
<td>Cut</td>
<td>⌘X</td>
</tr>
<tr>
<td>Copy</td>
<td>⌘C</td>
</tr>
<tr>
<td>Paste</td>
<td>⌘V</td>
</tr>
<tr>
<td>Clear</td>
<td>⌘U</td>
</tr>
<tr>
<td>Select All</td>
<td>⌘A</td>
</tr>
<tr>
<td>Show Clipboard</td>
<td></td>
</tr>
</tbody>
</table>

Memorize these five keyboard shortcuts even if you never memorize anything else.
Because almost every program has an Edit menu, and because almost every program uses the same keyboard shortcuts on its Edit menu, it will behoove you to learn these keyboard shortcuts by heart, even if you learn no others.

The Edit menu should probably have been called the Clipboard menu because most of its commands deal with the Macintosh Clipboard.

If you read the little sidebar about the Clipboard, you’ll learn 75 percent of what you need to know about the Edit menu. Still, because IDG’s paying me to be thorough, and because the Finder’s Edit menu has a couple of commands that aren’t Clipboard-related, I’ll go through the Edit menu’s commands one by one.

---

**The Clipboard**

Essential to your understanding of the Mac and essential to your understanding of the Edit menu is an understanding of the concept of the Macintosh Clipboard. In a sentence, the Clipboard is a holding area for the last thing that you cut or copied. A thing can be text, a picture, a portion of a picture, an object in a drawing program, a column of numbers in a spreadsheet, or just about anything that can be selected. In other words, the Clipboard is the Mac’s temporary storage area.

As a storage area, the Clipboard is ephemeral, which means that its contents are temporary. Very temporary. When you cut or copy an item, that item remains on the Clipboard only until you cut or copy something else. Then the Clipboard’s contents are replaced by the new item, which remains on the Clipboard until you cut or copy something else. And so it goes.

To place the item that’s on the Clipboard somewhere else, click where you want the item to go and then paste. Pasting does not remove the item from the Clipboard; the item remains there until another item is cut or copied.

Almost all programs have an Edit menu and use the Macintosh clipboard properly, which means that you can usually cut or copy something in a document in one program and paste it into a document from another program. Usually.

The Clipboard commands in the Edit menu are relatively intelligent. If the currently selected item can be cut or copied, then the Cut and Copy commands in the Edit menu are enabled; if the item can’t be cut or copied, the commands are unavailable and grayed out. And when nothing at all is selected, the Cut, Copy, Paste, and Clear commands are grayed out.

The contents of the Clipboard don’t survive a restart, a shut down, or a system error or crash. The Clipboard is ephemeral in the sense that any of these events purges its contents, so when your Mac comes back to life, the Clipboard will be empty.
Undo (Command-Z)

This is a great command! You're gonna love it. Undo undoes the last thing you did. Try it.

1. Create a new folder in any window or on the desktop. (It will be called untitled folder.)
2. Change the name untitled folder to Undo Me.
3. Without clicking anywhere else or doing anything else, choose Edit→Undo or use the keyboard shortcut Command-Z.

The folder's name should magically undo itself and change back to untitled folder.

Neat, huh? Don't forget about this command 'cause it can be a lifesaver. Almost every program has it.

Now for the bad news: The Undo command is ephemeral, like the Clipboard. It only undoes your last action and as soon as you do something else, you lose the ability to undo the original action. To see what I mean, repeat the exercise and change untitled folder to Undo Me. But this time, click another icon before you undo. What's that, you say? The Undo command is grayed out and not available anymore? I told you. When you clicked the other icon, you forfeited your chance to use Undo.

Unfortunately, Undo doesn't work with things like moving icons or copying files. In fact, as you learn more about using your Mac, you'll discover lots of actions that can't be undone. Still, it's a great command when it's available, and I urge you to get in the habit of trying it often.

Incidentally, the Undo command toggles (that is, switches back and forth) between the new and old states as long as you don't do anything else. So in the first example, if you chose Edit→Undo again without clicking anywhere else, the name would transform back to Undo Me. And if you chose Edit→Undo again, it would change back to untitled folder. You can continue to undo and redo until you click somewhere else.

Cut (Command-X)

The Cut command removes the selected item and places it on the Clipboard. Let's see this command in action:

1. Create an untitled folder.
Chapter 3: A Bevy of Delectable Menus

2. Select only the word untitled (untitled should be black with white letters; folder should be white with black letters).

3. Choose Edit→Cut or use the keyboard shortcut Command-X.

The word untitled disappears from the folder's name. Where did it go? You cut it! It's removed from the folder and is now waiting on the Clipboard.

(You can, of course, use the Undo command at this point to make untitled reappear as long as you haven't clicked anything else.)

**Show Clipboard (no keyboard shortcut)**

I know I'm not covering the commands in the order that they appear on the Edit menu, but there's a method to my madness. If you don't believe that the word untitled, which you cut in the previous section, is on the Clipboard, choose Edit→Show Clipboard. A window will appear, telling you the type of item (text, picture, sound, and so on) on the Clipboard and displaying it if it can be displayed (see Figure 3-17).

There is another way to display the Clipboard's contents — open the Clipboard icon in your System Folder. Because some programs don't have a Show Clipboard command, it's convenient to make an alias of the Clipboard file and put the alias in your Apple Menu Items folder so that it appears in your Apple menu. (Don't panic. I'm going to talk about the Apple menu in the very next chapter.) Then, even if you're in a program that doesn't have a Show Clipboard command, you can select the Clipboard alias from the Apple menu. This technique saves you two steps. Without it you'd have to first go back to the Finder and then choose Edit→Show Clipboard. Choosing the Clipboard alias from the Apple menu does both steps automatically.
Copy (Command-C)

Copy makes a copy of the selected item and places it on the Clipboard. The original is not removed as it is when you cut. Try it. Select your System Folder and choose Edit→Copy or use the keyboard shortcut Command-C. Now choose Edit→Show Clipboard. The Clipboard contains the text “System Folder.”

It's that simple.

Paste (Command-V)

We've been cutting and copying but not doing much with the stuff on the Clipboard except looking at it to make sure it's really there. Now let's learn to use what we've cut or copied. Do this:

1. Create a new folder.
2. Change the folder's name to Elvis Costello.
3. Copy the word Elvis to the Clipboard. (C'mon, you know how.)
4. Create another new folder and select its name, which should be "untitled folder" if you've been following my instructions.
5. Choose Edit→Paste.

The new folder is now called Elvis. Pasting doesn't purge the contents of the Clipboard. Don't believe me? Choose Edit→Show Clipboard to confirm that Elvis is still alive and well and on the Clipboard.

Which is where he'll stay until you cut, copy, crash (the three C's of Macintosh computing), or restart or shut down.

Clear (no keyboard shortcut)

Clear deletes the selected item without involving the Clipboard. It works the same as pressing the Delete key on your keyboard. Use it when you want to make something disappear forever.

Clear can be undone as long as you haven't done anything else like click, type, save, or use a menu.
Select All (Command-A)

Select All selects all. If a window is active, Select All selects every icon in the window, regardless of whether you can see them. If no window is active, Select All selects every icon on the desktop.

Go ahead and try it a couple of times. I'll wait.

Select All has nothing whatsoever to do with the Clipboard. So why is it on the Edit menu? Who knows? It just is.

A View from a Window: The View Menu

The View menu offers seven ways to look at icons in a window. Choosing a command in the View menu changes what the icons look like in the active window. If no window is active, the View menu is unavailable, grayed out.

Although there are seven commands in the View menu, there are really only two ways to view the contents of windows: icon views and list views. Icon views include both small icons and big icons. The rest are list views: by Name, by Size, by Kind, by Label, and by Date.

By Icon

Viewing by icon is the "Macintosh" view, the one most closely associated with the Macintosh experience. It's also, in my humble opinion, the least useful view, as those big horsy icons take up far too much valuable screen real estate. And, as you'll see in a minute, the list views offer a nifty navigational extra. The window in Figure 3-18 uses the Icon view.

In all fairness, I must say that there are many perfectly happy Mac users who love the icon view and refuse to even consider anything else. Fine. But as the number of files on your hard disk increases (as it does for every Mac user), screen real estate becomes more and more valuable.

By the way, if you like the big icon view, they make monitors as big as 21 inches.
Figure 3-18:  
The icon (big icons) view. Pretty and very Mac-like, but a total waste of perfectly good screen real estate.

By Small Icon

The small icon view (shown in Figure 3-19) is better and wastes less screen space than those blocky big icons, but I still say that the list views are better.

The only thing the icon views have over list views is the ability to move icons anywhere you like within a window. Big deal.

The list views

The list views are lumped together because they all look the same with one small exception — the order in which the icons appear varies.

by Name
Displays the icons in alphabetical order (see Figure 3-20).
by Size
Displays the icons in descending order by size, with document and applications sorted together by size, followed by folders in alphabetical order (see Figure 3-21).

If you have the Calculate Folder Sizes option turned on in the Views control panel (I recommend that you keep it turned off — it seems to make the Finder feel a bit sluggish), the icons, including folders, are sorted in descending order from biggest to smallest (see Figure 3-22).
by Kind
Displays the icons in this order: applications, documents, folders. Not usually very useful.

by Label
See the section on the Label menu.

by Date
Viewing by date displays the icons by modification date, with the most recently modified icon first (see Figure 3-23).

Use this view for folders with lots of documents in them. That way, the ones you used most recently are listed first. If that gets confusing, you can easily switch to the name view for a second to find things alphabetically.

Figure 3-23: Viewing by date displays the most recently modified file first in its list.

Another way to switch between list views

Notice how the appropriate column title is underlined in Figures 3-20 through 3-23 — how Name is underlined in Figure 3-20, Size is underlined in Figure 3-21, and so on. This underline tells you which of the list views is in use.

Now for the shortcut: You don't need to use the View menu to switch between list views. Instead, just click directly on the column title, and the window's view changes. Go ahead, give it a try. The only proviso is that you must be in a list view in the first place (the column titles don't appear in icon views).
The triangles

In list views, folder icons have a little triangle to the left of their name. This is the outline metaphor, and it's only available in the list views. You click the triangle to reveal the folder's contents right there in the same window.

In my humble opinion, this is a much better way to get to an icon buried three or four folders deep. Figure 3-24 shows the slow and tedious way of getting to the icon; Figure 3-25 shows the cool, savvy, and efficient way of getting to the same icon.

In Figure 3-24, I had to double-click three folders to get to Ch01-Nose Running.txt. When I got to it, I had four windows open on the desktop.

In Figure 3-25, I had to single-click three triangles to get to Ch01-Nose Running.txt. When I got to it, only one small window was open, keeping my desktop neat and tidy.

There are other advantages to the triangle/outline metaphor. First and foremost, you can copy or move items from separate folders in one move, as Figure 3-26 illustrates.
Part I: Basic Training

Figure 3-25: Getting to the document Ch01-Nose Running.txt the fast way, using the outline triangles.

In the list views, you can copy or move items from different folders with a single motion, without opening multiple windows. In either of the icon views, on the other hand, moving files from two separate folders requires opening several windows and two separate drags.

Another feature of the triangles appears when you hold down the Option key and click a triangle. This action reveals all subfolders to the deepest level (see Figures 3-27 and 3-28).

The bottom line is that I have almost all of my windows displayed in the list view by name. If I want to switch to a different list view, I always click the column name and never use the View menu. Finally, I almost always use the triangles to reveal the contents of folders and rarely have more than one or two windows open at a time.
Figure 3-27: A regular click on the Mystery Novels triangle reveals only the next level of folders.

Figure 3-28: An Option-click on the Mystery Novels triangle expands all of its subfolders.

The Views control panel, which I talk about in Chapter 12, offers additional controls. You choose options such as the size of the icons and the columns that appear in list views. You can also change the font used in all views. If you feel adventurous, go ahead and play with it a little now.

You can move among icons using the keyboard. If a window is active, make sure that no icons are selected and then type the first letter of a file’s name. Regardless of which view you chose, the first icon that starts with that letter is selected. To move to the next icon alphabetically, press the Tab key. To move to the previous icon alphabetically, press the Shift and Tab keys at the same time.
If no window is active, typing a letter selects the first icon on the desktop that starts with that letter. The Tab and Shift-Tab commands work the same with desktop icons as they do with icons in a window.

If you have many icons that start with the same letter, you can type more than one letter (that is, type sys to select the System Folder, even if you've got folders called Stuff and Slime in the same window).

Don't Label Me: Introducing the (Near-Worthless) Label Menu

Maybe it's just me, but I've never really gotten the hang of the Label menu. And I hardly know anyone who uses it diligently, which is the only way it's useful. Anyway, the Label menu, which looks a lot neater in color than it does in Figure 3-29, lets you organize your files yet another way, by label.

To apply a label to an icon, select it and then choose the appropriate label from the Label menu. Again, labels are more useful on a color screen, as they tint the icon the appropriate color. On black-and-white or grayscale monitors, the only way you know a label has been applied to an icon is by looking in the Label column of a list view (see Figure 3-30).

Because the Find command can search by label, you have reason to use labels. Still, unless you're very organized and remember to label every file (which, unfortunately, has to be done in the Finder, not when you save from within an application, when it might actually be useful), labels aren't much use.
The Dilemma: On one hand, several users (well, actually just two) took the time to write me and say they found Labels useful. On the other hand, thousands of people didn’t.

On the other other hand, severely obsessive, compulsive, or anal-retentive Mac users will have hours of pleasure assigning those pretty labels to their icons.

So Labels: Yea or Nay? It’s your call.

You can change the names and colors of your labels in the aptly named Labels control panel, which is discussed in Chapter 12.

**Something Special in the Menu Bar: The Special Menu**

The Special menu is a repository for a group of unrelated functions that don’t really fit in any of the other menus: cleaning up (rearranging) icons, emptying the Trash, erasing and ejecting disks, and the Restart, Shut Down, and Sleep commands, to be precise. Figure 3-31 shows the Special menu.

Interestingly, only the Eject Disk command has a keyboard shortcut. One explanation might be that you wouldn’t want to accidentally erase a disk or restart or shut down your Mac with something as easy to do as pressing the wrong key combination.
Clean Up

The Clean Up command aligns icons to an invisible grid; it is used to keep your windows and desktop neat and tidy. (If you like this invisible grid, don't forget that you can turn it on or off in the Views control panel.) Clean Up is only available in icon views or when no windows are active. If no windows are active, the command's name changes to Clean Up Desktop.

If you're like me, you have taken great pains to place icons carefully in specific places on your desktop. Clean Up Desktop destroys all your beautiful work and moves all your perfectly arranged icons around.

Here's how the Clean Up command works. Figure 3-32 shows a window before and after cleanup.

You can force the Clean Up command to use one of the list view criteria (name, size, type, and so on) to determine the order of the icons. It's easier to show than to explain, so:

1. Open a window and choose the list view that you want to use as the criteria for cleaning up. In this example, I'll choose by Name.
Chapter 3: A Bevy of Delectable Menus

2. Switch to either icon view — by Icon or by Small Icon.

3. Hold down the Option key and choose Special>Clean Up by Name. Figure 3-33 shows what happens.

Notice that the command changes from Clean Up to Clean Up by Name when you hold down the Option key. And notice how the icons are now in alphabetical order in the window.

Had you chosen another list view in Step 1 (by Size, by Date, and so on), the command would change accordingly to Clean Up by Size, Clean Up by Date, or whatever, and the order of the cleaned-up icons would reflect that command.

Empty Trash

I've already talked about the Trash (just last chapter, as a matter of fact). And I talked about it earlier in this chapter when I showed you the Get Info box.

I've said it before and I'll say it again: Use this command with a modicum of caution. After a file is trashed and emptied, it's gone. (Okay, maybe Norton Utilities or MacTools can bring it back, but don't bet the farm on it.)

Eject Disk and Erase Disk

See Chapter 2 for more information than you need on ejecting and erasing disks.
Restart

The Restart command shuts down your Mac briefly and then starts it back up. Why do you need such a thing? Every so often, your Mac may act wonky. By wonky, I mean things don't seem to work right. You can't launch a program that used to launch fine. You can't rename an icon. You can't use the keyboard. Or something. That's when to use Restart.

You see, computer problems often disappear when you clear the computer's memory, which is one of the things that occurs when you restart.

One of the best pieces of advice I give people when they call me in a panic is to restart their Mac and try it again. At least half the time, the problem goes away and never comes back after restarting. I'm a little paranoid about things going wrong, so I often restart my computer in the middle of the day, just in case something is about to go wrong. It couldn't hurt.

Sometimes when your Mac gets really wonky, you'll be unable to choose Special+Restart for one reason or another. If you can't, because the cursor won't move or for any other reason, try pressing the Command and Option keys while you press the Escape (Esc) key. If things aren't too messed up, you should see a dialog box asking if you're sure you want to force the current application to quit. You do. Your Mac is so wonked that you had to resort to the Command-Option-Escape technique, so click the Force Quit button. If it works, the current application quits. If you're in the Finder, the Finder quits and then reappears automatically. You'll lose any unsaved changes in the application that you quit, but you may regain the use of your Mac. If you do, immediately save any documents you have open in other applications and restart. The Force Quit command leaves your Mac in an unstable state, and you should always restart as soon as possible after using it. After, of course, saving any unsaved documents.

If that trick doesn't work, try pressing both the Command and Control keys while you press the Power-On key (the one with the little left-pointing triangle on it). This technique forces your Mac to restart. Unfortunately, it doesn't work all the time or on all Macintosh models. But it usually does.

If Command-Control-Power-on doesn't work for you, look for the reset and interrupt switches on the front or side of your Mac and press the reset switch, which is the one with a triangle. This technique also forces your Mac to restart. Unfortunately, not all Macs have these switches.

If you're still having problems and still can't choose Special+Restart, turn the power off using the power switch and leave your Mac off for at least ten seconds before you try to start up again.
Chapter 3: A Bevy of Delectable Menus

Shut Down

Shutting down is the last thing you do at the end of every session at your Mac. When you’re all done using it, choose Special:› Shut Down.

Because I ragged on endlessly in the last chapter about how important the Shut Down command is, I’m not going to do it again.

Use it or lose it.

Sleep

Puts your Mac and monitor into a state of suspended animation complete with lower power consumption. Waking up from sleep mode is much faster than restarting. You can control when your Mac goes to sleep automatically with the Energy Saver control panel, discussed in Chapter 12.

Not Just a Beatles Movie: Help and the Help Menu

One of System 7.5’s niftiest new features was its built in interactive assistance system, Apple Guide. It’s back and it’s even better now. Faster, too. You’ll find it in the Help menu, which isn’t actually titled Help. It’s easy to find, though; it’s the one with the question mark (see Figure 3-34).

For what it’s worth, Balloon Help is still available, but Mac OS Guide goes it one (actually, a few) better.

Figure 3-34: The Help menu is the one with the question mark instead of a name.
About Help (no keyboard shortcut)

Choose the About Help command to read about the Help menu. You may never need to do so because you're reading *Mac OS 7.6 For Dummies*, and my text is usually better than theirs.

If you insist, you'll see a single little screen that doesn't say much.

Show Balloons (no keyboard shortcut)

The Show Balloons command turns on Balloon Help. When Balloon Help is on, pointing at almost any item on the screen causes a little help balloon to pop up and explain it (as illustrated in Figure 3-35).

After you choose Show Balloons, the command in the Help menu changes to Hide Balloons until you choose it again, at which time the command changes back to Show Balloons. And so on.

I rarely use Balloon Help myself, but if you're relatively new to the Mac, you may find it helpful. Some (but not enough) applications include excellent Balloon Help, so don't forget that you can turn balloons on in programs as well as in the Finder.
**Mac OS Guide (Command-?)**

In the beginning, there wasn't much help built into your Mac. In fact, before System 7.0, there was none. System 7 introduced Balloon Help, and it was good. Well, actually, it was kind of lame, and not that many developers implemented it at first, but it was better than nothing.

Now that most software does include Balloon Help, Apple raised the bar in System 7.5 with Apple Guide, an interactive, step-by-step guidance system for accomplishing tasks on your Mac. It's hot. Apple calls it an electronic assistant, and for once I don't think it's oversell. Mac OS Guide (its new name in Mac OS 7.6) is neat.

It's like having a consultant at your side. But there's nothing to open your eyes like a demonstration, so here's how to have your new assistant, Mac OS Guide, answer a question for you. Follow along if you like.

1. Choose Mac OS Guide from the Help menu (or use the keyboard shortcut Command-?).

2. When the Mac OS Guide window appears (see Figure 3-36), click the Topics button at the top of the window. Then click Application Programs in the topic list on the left, and in the list on the right, click the Switch between programs? option. Click OK.
3. Glance at the arrow in the upper-right corner of your screen directing you to the Application menu. Read what the Guide has to say in this first screen and then click the right-arrow button at the bottom right of the windoid (as this type of window is called) to receive further instructions.

4. When windoid 2 appears (look between the arrows to see the windoid number), your assistant tells you what to do and even draws a circle around where you should do it (see Figure 3-37).


Mac OS Guide has circles, arrows, and a whole arsenal of other visual cues to help you figure out how to do things on your Mac. There's even a Huh? button in case you don't understand (unfortunately, it's not active in all screens). Mac OS Guide is an excellent resource, especially for those of you who are new to the Mac. I urge you to explore it further at your leisure.

Incidentally, the Mac OS Guide engine is built into the System software. That means your word processor, spreadsheet, or graphics program can use it as easily as Apple uses it in the Finder. Although it may be a while before third-party developers (that is, the folks who publish application software) implement Mac OS Guide in their programs, look for "Includes Mac OS Guide" on the box and in advertisements as a selling point. I know I'd rather buy a program that has it than one that doesn't.
Shortcuts (no keyboard shortcut)

The Shortcuts command brings up a series of help screens that teach you shortcuts about icons, windows, list views, dialog boxes, and more. It wouldn't be a bad idea for you to take a look at these shortcuts. There are only a few screens for each category, and even though I've already taught you many of the shortcuts, you may learn something that you didn't know.

I doubt it, but you might.

Apply Yourself: The Application Menu

Last but not least is the Application menu. It's the one in the upper-right corner. Because all of this menu's functions are related, I'm going to skip describing its commands one at a time and try to convey the gestalt of the Application menu instead.

If the Finder is the active application, the Application menu displays a little Mac icon like the one shown in Figure 3-38.

If another application is currently active, a little version of that application's icon represents the Application menu instead (see Figure 3-39).
The Application menu enables you to choose which program you want to use. As with windows, only one application is active at a time. Because Mac OS 7.6 allows you to open more than one application at a time (if you have enough RAM), the Application menu is one of the ways to switch between all currently running applications and the Finder (I discuss the other methods near the end of this section).

If a program is running, its name appears in the Application menu; the Finder's name always appears in it.

For illustration purposes, imagine that two programs, the Finder and Microsoft Word, are running. If the Finder is currently active and you want to switch to Microsoft Word, choose its name in the Application menu. Microsoft Word's menus appear in the menu bar, and if there's a document open (or an untitled new document), its window becomes the active window.

To switch back to the Finder, you choose Finder in the Application menu. Piece of cake, right?

Wrong. When you switch back to the Finder, Microsoft Word's document window may obscure items on the desktop. Finder windows aren't a problem — they float to the front. But icons on the desktop may be covered.

This is where the Hide and Show commands come into play. You could switch back to Microsoft Word and quit it, but there's an easier way to free up desktop real estate. Choose Hide Others from the Application menu, and the Microsoft Word window is hidden from view. Microsoft Word is still running, but its window or windows are hidden from view.

To make the Microsoft Word window visible again, choose Show All from the Application menu.

Open any application and play around with the Hide and Show commands on the Application menu. They're easier to understand after you play with them a little.
Chapter 4
Polishing the Apple (Menu)

In This Chapter
- About This Computer (yours)
- Desk accessories
- Those interestingly named folders in the Apple menu
- Customizing your Apple menu
- A deep, dark secret

The Apple menu is beneath the little Apple logo, an apple with a bite taken out of it, that graces the upper-left corner of your screen. It gets its own chapter because, unlike the menus I discussed previously, it's entirely configurable by you, the user. This is one of the finest features of the Mac — the ability to create your own, customized, file-launching and folder-accessing environment.

System 7.5's Apple menu broke new ground. It's still wonderful in Mac OS 7.6. Most significant was the addition of hierarchical submenus, which power users have loved in the form of Now Software's NowMenus and other, similar programs for years. Finally, everyone else can see what the power-user elite have been raving about for so long. Submenus in the Apple menu are fantastic!

So I'll show you the basics of configuring your Apple menu in this chapter, but I'm telling you in advance: I'm saving the really cool tricks for Chapter 11.

Before I talk about how to customize your Apple menu, I describe the stuff that's already in it: desk accessories, the little miniprograms (Jigsaw Puzzle, Calculator, and so on) that Apple thoughtfully stuck in your Apple menu along with several special folders. In all fairness, I also show you how to use the essential and useful desk accessories such as the Scrapbook and the Chooser, so don't that think all desk accessories are lame. Only most of them are.

Oh, and one last thing: At the end of this chapter, I let you in on a deep, dark secret that you probably figured out already.
About This Computer (Yours)

Before we do anything, let me tell you a bit about the Apple menu's only permanent item, About This Computer.

The first item on every Apple menu (at least if the Finder is the active application) is the About This Computer command. Take a peek at it from time to time — it lets you know how much of your memory (RAM) is currently being used, how much of it is real RAM and how much of it is virtual memory, which programs are using it, and how much is left for programs yet to be launched. Those are good things to know. It also tells you what version of the System software is running.

In Figure 4-1 you can see that my System software is using 7,166K of RAM (random access memory).

7,166K of RAM is a lot for System software. But I'm running all the options Mac OS 7.6 has to offer — QuickDraw 3D, QuickDraw GX, QuickTime, file sharing, AppleScript — the whole shebang. In Chapter 14, I show you how to turn this stuff off (or get rid of it completely), as well as give you advice on when it's safe for you to do so. For now, let's just say that your System software will probably use somewhat less RAM than mine.

In Figure 4-1, the Jigsaw Puzzle application is using 500K, and SimpleText is using 512K. The bars to the right of the programs' names and numbers are especially meaningful. The light gray part of each bar reflects the amount of memory the program has grabbed (the number just to the left of the bar). The dark gray part shows how much of that memory the program is actually using at the moment. My System software looks like it's using almost all of its allocation; SimpleText looks like it's using almost none. Jigsaw Puzzle seems to be using a little more than half.
Why is the information in the About This Computer window important? I'll tell you why. First, you can see how much RAM is left (the Largest Unused Block) for launching additional programs. I have approximately 58 megabytes (Wow!) but I have a lot of RAM (32MB of real RAM, 32 additional megabytes of virtual memory). If you try to launch a program that requires more RAM than the Largest Unused Block at any given time, your Mac will politely inform you that there's not enough memory to launch this program.

The other thing that's important is that I can see that SimpleText gobbled up 512K when I launched it, but it's only using 58K of its allocation at this time. (I found that out using the Balloon Help tip.) So it's grabbing over 400K of precious RAM and not using it.

What can I do about it? Well, I can tell SimpleText to grab less RAM next time I launch it. Here's how:

Oops. Almost forgot. If SimpleText is open, quit before performing this following procedure. An application cannot be running when you adjust its Preferred Memory Size.

1. Select the SimpleText icon.
2. Choose File-Get Info or use the keyboard shortcut Command-I.

   The SimpleText Info window appears (as shown in Figure 4-2).

3. In the lower portion of the SimpleText Info window, change the Preferred size from 512K to a smaller number, somewhere between the Minimum and Suggested size.


---

Figure 4-2: Reduce the Preferred size from 512K to a lower number (but not lower than the minimum size above it).
The change doesn't take effect until the Get Info window is closed.

When I say "a smaller number," it's not because I don't want to tell you what number to use. Memory management is not a precise science. I don't know how big the documents you open with SimpleText are, and that's what determines how much RAM it needs. Try 256K. If you someday discover that you can't open a document due to low memory (your Mac will tell you so), increase this number a bit — to 384K or even 450K. It still saves you a little over the old setting of 512K.

Don't perform the preceding procedure haphazardly. Most programs run better with their Preferred memory set higher than the suggested size. But (and it's a big but) if you're short on RAM for other programs and you can see that a program is only using a fraction of the RAM that it requests, you can probably reduce its Preferred size at least a little and maybe a lot.

**From the Desk (Accessories) of . . .**

You use items in the Apple menu the same way that you use any menu item — click the Apple and drag down to the item. When you release the mouse button, the item opens. If the item is a folder, it will have a submenu; you can see its contents by dragging down until the folder is highlighted and stopping. Don't release the mouse button, or the folder will pop open. To choose an item in the submenu, drag to the right.

If you haven't modified your Apple menu, it probably looks something like Figure 4-3.

Ignoring the folders for now (I'll talk about them after I ridicule a few desk accessories), let's take a look at each desk accessory in turn.

Technically, only a few of the items in the Apple menu are *desk accessories* (known affectionately as DAs), special types of miniprograms that are a little different from regular applications and are a holdover from System 6 and earlier. The rest are regular old applications. Even so, most people refer to the programs Apple sticks under the Apple menu as desk accessories, and so will I. Desk accessories are basically small applications, and they're discussed along with control panels and extensions in Chapter 14.
Profile THIS: Apple System Profiler

Apple System Profiler is new in Mac OS 7.6. It's a little program that gives you information about your Mac. What a concept. If you're curious about things like what processor your Mac has or what devices are on its SCSI bus, give it a try. Poke around the Select menu and check it out if you like; this little puppy is benign and won't hurt anything.

If you ever have occasion to call for technical support for your Mac, software, or peripherals, you will probably be asked to provide information from Apple System Profiler. So don't get rid of it just because you don't care about this kind of stuff.

So? Apple finally provides a useful tool and then stupidly leaves out the most useful features: the ability to save your profile as a text file (to e-mail to technical support???) and the ability to print (to fax to technical support???). Sigh. I guess it's better than nothing.

Sounds good to me: AppleCD Audio Player

Next on the Apple menu is the CD Audio Player. It's a little program you use to play regular old stereo CDs on your CD-ROM drive (see Figure 4-4). Just pop your Brutal Youth CD into the CD-ROM drive, select AppleCD Audio Player from the Apple menu, and then click the Play button. Your room will be filled with the mellow tones of Elvis Costello and the Attractions.
You may have to plug a pair of amplified stereo speakers into the stereo output jacks on some external CD-ROM drives. If you have an internal CD-ROM drive, you may need to select Internal CD from the Sound Input pop-up menu in the Monitors & Sound control panel before you hear music through your Mac's built-in speaker. Finally, you must have the Audio CD Access extension in the Extensions folder within your System Folder for the AppleCD Audio Player to function.

Because the internal speakers in most Macs suck, a good pair of multimedia speakers is a good investment; then you'll be able to rattle the walls when you slap that Elvis CD in your drive.

A calculated risk: Calculator

The Calculator has been in the Apple menu as long as I can remember, and it hasn't changed one iota since it was introduced. (All right, it got a spiffy new icon when System 7 first arrived, but that's the extent of it.) Figure 4-5 shows what the ol' Calculator looks like.
Chapter 4: Polishing the Apple (Menu)

The Calculator DA is the pixel (for Picture EElement, the little dots that make up your screen) equivalent of the cheesy calculators that cheap companies give away — or the kind you see at the grocery store for $1.99. The Apple Calculator does have one feature that makes it different from all those Taiwan specials — cheap calculators don’t require a four-figure investment in computer equipment.

I’m kidding, of course. Even though it’s looking a little long in the tooth (Hey, Apple — how about a facelift for the old fellow? Maybe some pastel colors? More graceful-looking buttons? A paper tape? And a Clear Entry button instead of only Clear All?), it still comes in handy more often than you might expect. For example, my wife used it to balance our checkbook for years (till we discovered Quicken).

If you’re lucky enough to own a Power Mac, with a blazing fast PowerPC chip inside, then you’ve probably already run across the awesome new Graphing Calculator that crunches equations into graphs in real time. It’s too cool for words (especially if you have a use for its features — if you need to cheat to pass Algebra this semester), but it would run like a snail on Quaaludes on a non-Power Mac.

The Calculator DA works just like a real calculator. Use the numeric keypad on your keyboard; the keys correlate to their on-screen counterparts.

Unfortunately, the Calculator lacks all but the most basic features. It doesn’t have a paper tape, a Clear Entry key, or even a single memory recall. There are shareware and commercial calculators galore, with features galore. If you need a calculator DA, almost anything you can buy or download will be better than the Calculator DA that comes with Mac OS 7.6.

**Be choosy: Be a Chooser user**

The Chooser is a desk accessory that lets you choose two things: which printer to use and which computer(s) to share files with.

If you click a printer icon on the left side of the window, all the printers available on the network appear in a list on the right side of the window (see Figure 4-6).

The Chooser is also where you choose other Macs to share files with. If you click the AppleShare icon on the left side of the Chooser, every Mac on your network that has file sharing turned on will appear in the list on the right.

The Chooser is also where you create desktop printer icons, but since there’s an entire chapter on printing and yet another one about file sharing. I think you know enough about the Chooser to hold you till you get to them.
Finder of lost files: Find File (again)

Choosing Find File from the Apple menu is the same as choosing File→Find in the Finder (try saying that fast three times). The only advantage this DA has is that, because it is in the Apple menu, you can choose it even if the Finder isn't currently the active application. If you've forgotten how Find File works, reread Chapter 3.

Fakin' it with Graphing Calculator (Power Macs only)

I still have no idea what this thing is really supposed to do. I do enjoy running its demos for my friends and pretending I do, though. If Graphing Calculator appears in your Apple menu, here's how to fake it. Choose 3D Surfaces from the Demo menu. You should see something like Figure 4-7.

Click the Stop button and then use your mouse to spin the graph. Mumble something half-intelligibly about "PowerPC processors and real-time 3D surface mapping capabilities." I guarantee you'll impress 'em.

Better than puzzles of old, it's Jigsaw Puzzle

Better than the old 15-numbers-in-16-squares puzzle of System software of old, the Jigsaw Puzzle is only a little less lame. It's a jigsaw puzzle. Click the pieces to move them around (see Figure 4-8).
Figure 4-7: The 3D Surfaces demo in Graphing Calculator.

Figure 4-8: It's a jigsaw puzzle. What did you expect?

One cool thing is that you can Paste another picture onto the puzzle and that picture becomes the jigsaw puzzle. It’s kind of fun. Here’s how to do it with any icon:

1. Select any icon and choose File>Get Info or use the keyboard shortcut Command-I.
2. Click the icon’s picture at the top of the Info window to select it.
3. Choose Edit>Copy.
4. Open Jigsaw Puzzle and choose Edit>Paste.

In Figure 4-9, I’ve pasted the Jigsaw Puzzle’s icon into Jigsaw Puzzle.
And there you have it — a new puzzle for you to solve. This technique works with any picture that you can copy to the Clipboard, not just with icons.

**The key to all your fonts: It's Key Caps**

Want to know what every character in a font looks like? Or where the funny optional characters like ™, ©, ™, and • are hidden on your keyboard? Sounds like a job for Key Caps, a modest little desk accessory that shows you a lot about your installed fonts.

If you’re not sure what a font is, choose Apple menu→Key Caps. After Key Caps opens, pull down the Key Caps menu (see Figure 4-10).

The items in the Key Caps menu are your fonts. If you haven’t installed any fonts yourself, your Key Caps menu should look like mine in Figure 4-10.

To see what a font looks like, choose it in the Key Caps menu and type a few words. They appear in the white text entry box at the top of the Key Caps window. If you want to see what those words look like in another font, choose that font from the Key Caps menu.

Of course, you could do the same thing in any program that has a font menu. In fact, you can do more because Key Caps only displays the font in a single size, 12 point; other programs let you change the size as well as the font, and you can also apply character styles such as bold, italic, and outline.

So what good is Key Caps? It’s the easiest way to find special symbols like ™, ©, ™, ™, and • or ©, $, ®, and ®. Just open Key Caps, choose a font, and hold down the Option key. Key Caps displays the special symbols and
characters on the keyboard. For example, to type TM in your document, hold down the Option key and press the 2 key on your keyboard. Instant TM.

What Key Caps doesn’t show you is how to create diacritical marks such as acute accents and umlauts. To type them, follow these instructions:

- To type a grave accent (¨), type Option-¨ and then type the character. So to accent an e, you type Option-¨ and then type e. It will come out looking like this: è. (The ` key is usually in the top row to the left of the "1" key.)

- To type an acute accent (´), type Option-e and then type the character. So to accent an e, you type Option-e and then type e. It will come out looking like this: é.

- To type a circumflex (ˆ), type Option-i and then type the character. So to put a circumflex over an i, you type Option-i and then type i. It will come out looking like this: î.

- To type a tilde (˘), type Option-n and then type the character. So to put a tilde over an n, you type Option-n and then type n. It will come out looking like this: ñ. I'm pretty sure that the n is the only character you can put a tilde over; I tried to put it over other characters, but they came out looking like this: -b.

- To type an umlaut (¨), type Option-u and then type the character. So to put an umlaut over a u, you type Option-u and then type u. It will come out looking like this: ü, as in Motley Crüe.
Take note of the Note Pad

Note Pad is a handy, dandy little note-taking utility that lets you store gobs of unrelated text items without saving a zillion different files all over your hard disk. Everything that you type into Note Pad is automatically saved in the Note Pad File, which is in your System Folder. Figure 4-11 shows Note Pad in action.

Note Pad uses a page metaphor. Click the dog-ear corner at bottom left to change the page or choose File: Go to Note and type in the page number of the note that you want to go to.

The Note Pad in Mac OS 7.6 has several improvements over Note Pads of old. Most welcome is the Find command. Also, the Note Pad window is resizable and has scroll bars. Finally, the pages seem to hold a lot more text than older versions. Oh, and you can choose a font in the Preferences dialog box; the older Note Pads gave a choice of Geneva or Geneva.

You can print notes, and Note Pad (like almost every Mac application ever made) includes full support of Cut, Copy, or Paste, so you can easily get text in and out of Note Pad by using the Clipboard.

For a freebie, Note Pad is relatively well equipped. If you have a lot of random thoughts that you’d like to type, you might want to leave it open all day (it only uses a little RAM).

Remote Access Disconnect

Chapter 4: Polishing the Apple (Menu)

The not-so-scrappy Scrapbook

The Scrapbook is like the Note Pad, but you use it to store graphics, text, and sounds. Instead of pages, the Scrapbook uses an item metaphor. You move from item to item by using the scroll bar in the lower part of the Scrapbook window (see Figure 4-12).

To put something into the Scrapbook, copy it to the Clipboard; then open the Scrapbook and choose Edit→Paste or use the keyboard shortcut Command-V. The pasted item becomes the item before the current item. So if you're looking at item 1 when you paste, the pasted item becomes item 1 and the former item 1 becomes item 2, and so on.

Here are the various ways to use the Scrapbook:

- To remove an item from the Scrapbook and use it elsewhere, choose Edit→Cut or use the keyboard shortcut Command-X. This action removes the current item from the Scrapbook and place it on the Clipboard for pasting into another document.

- To use a Scrapbook item in another document without deleting it, choose Edit→Copy or the keyboard shortcut Command-C. Then open a document and choose Edit→Paste.

- To delete a Scrapbook item forever, choose Edit→Clear or use the keyboard shortcut Command-B. Doing so deletes the item from the Scrapbook without placing it on the Clipboard.

You can't always paste a picture or sound into a document. The determining factor is the kind of document that you're trying to paste into.
For example, you can’t paste a picture into cells in spreadsheets or most fields in databases. And you can’t usually paste a sound into a graphics file.

If you try to paste an inappropriate item into a document, your Mac will either beep at you or do nothing. If nothing happens when you paste, assume that the document can’t accept the picture or sound you’re trying to paste.

You can paste text into the Scrapbook, but it’s probably easier to paste it into the Note Pad where you can select only a portion of it or edit it. After text is pasted into the Scrapbook, it can’t be selected or edited, so if you want to change it, you have to copy and paste the entire chunk of text into an application that supports text editing (such as Note Pad, SimpleText, or a word processor).

If you want to replace the old version of an item in the Scrapbook with a changed version, you have to copy the new version to the Clipboard and then paste it into the Scrapbook. Don’t forget to delete the old version by scrolling until it appears and choosing Edit::>Clear (Command-B) to delete it.

**SimpleSound**

A simple little DA for recording your own alert sounds. You have to have a proper microphone; contact your nearest Apple or clone dealer for details. Just open SimpleSound, click the Add button, the Record button, and then the Save button, and just like that you have a new beep sound.

SimpleSound has one other feature: its Sound menu lets you choose between CD Quality, Music Quality, Speech Quality, and Phone Quality sound. Frankly, I can’t tell the difference even when using excellent amplified speakers.

**Don’t be stuck up: Use Stickies**

Stickies, which were new in System 7.5, are electronic sticky notes for your Mac. They are akin to the Note Pad; they’re a slightly different but no less convenient place to jot notes or phone numbers. Stickies are shown in Figure 4-13.

Stickies are nothing if not flexible. They can be moved around on-screen (just drag ’em by the title bar). They can display text in any font you desire. They can be collapsed by Option-clicking their grow boxes. They can be any color you like (if you have a color monitor). You can import and export text files. And of course, you can print Stickies.
As with the Note Pad, anything that you type on a Sticky is saved automatically as long as you keep that note open. But when you close a note (by clicking its close box, choosing File→Close, or using the keyboard shortcut Command-W), you lose its contents forever. Fortunately, Stickies gives you a warning and a second chance to save the note in a separate file on your hard disk.

If you like to live dangerously, you can turn the warning off by choosing Edit→Preferences and unchecking the Confirm Window-Closing option. In the Preferences dialog box, you can also tell Stickies to save all notes every time you switch to another application (safer), set the zoom box so that it collapses the window without the Option key, and set whether Stickies should launch automatically at startup (if you check this item, Stickies creates an alias of itself and puts it in your Startup Items folder).

Another way to shut down

The Shut Down desk accessory does the same thing as the Shut Down command in the Finder's Special menu. Like the Finder's Shut Down command (in case you've forgotten already), the Shut Down DA performs an orderly shut-down of your Macintosh, closing all files and then killing the juice.
The only advantage the DA has over the Shut Down command in the Special menu is that it can be invoked when you're not in the Finder. So you can Shut Down without first quitting ClarisWorks (or whatever). Your Mac will always give you the opportunity to save any files that need saving when you use either Shut Down command.

Those Interestingly Named Folders in the Apple Menu

There are a handful of folders in your Apple menu spread out amongst the desk accessories. You may see little triangles to the right of their names (if you don't, I'll show you how to turn them on in a minute). The triangles indicate that these folders have hierarchical submenus and will reveal their contents when you pull down the Apple menu and drag the cursor onto them. Submenus are a new feature, introduced with System 7.5, though commercial programs like NowMenus and shareware programs like MenuChoice have provided this functionality since the early days of System 7.

To select an item in the submenu, drag to the right and highlight it, as shown in Figure 4-14.

To choose Note Pad in the Recent Applications folder (see Figure 4-15), click the Apple, drag down until the Recent Applications folder is highlighted, drag to the right and down until Note Pad is highlighted, and then release the mouse button.
Chapter 4: Polishing the Apple (Menu)

What is a control panel, anyway?

Control panels are little programs that you use to adjust and configure your Mac. Each one has one or two specific functions — set the Mac clock (Date & Time), change menu blinking (General Controls), configure memory (Memory), adjust the mouse (Mouse) and keyboard (Keyboard), and so on.

Control panels go in the Control Panels folder inside your System Folder. The Installer automatically creates an alias of the Control Panels folder and puts it in your Apple menu for you when you install Mac OS 7.6.

If you get a new control panel (many screen savers and other utilities are control panels), simply drag it onto the System Folder icon, and Mac OS 7.6 automatically puts it in its proper place, the Control Panels folder. (Incidentally, Mac OS 7.6 is smart about extensions, fonts, and sounds as well. If you drag an extension, font, or sound onto the System Folder, Mac OS 7.6 puts it in its proper place automatically.)

There's a whole chapter on control panels and how to configure them (Chapter 12), so I'll leave it at that for now.

If you don't see the little triangles to the right of your folders, here's how to turn them on:

2. Open the Apple Menu Options control panel.
3. Click the On radio button, as shown in Figure 4-15.

Now that you know how submenus work, let's talk about the five or six folders you may see in your Apple menu.

Figure 4-15: Turning on the hierarchical submenus in the Apple Menu Options control panel.
The Control Panels folder

As previously noted, the Installer creates an alias of the Control Panels folder and puts it in your Apple menu that so you always have access to your control panels, even when you’re using an application other than the Finder. Before submenus were introduced (1994), you would have to choose the Control Panels folder from the Apple menu. That action would automatically switch you to the Finder (if you were in another application) and open the Control Panels folder’s window. Then you had to open the icon for the control panel manually. Ugh. Mac OS 7.6, with its marvelous submenus, is much nicer.

Recent Applications, Recent Documents, and Recent Servers

I cover these two Apple menu items together because they’re related and work the same way.

If you don’t see them in your Apple menu, open the Apple Menu Options control panel (choose Apple menu→Control Panels→Apple Menu Options) and check the Remember recently used items check box (see Figure 4-15). This action will create the folders in your Apple Menu Items folder as soon as you open an application, document, or server. If you never open a server (access another Macintosh over a network), the Recent Servers folder will never be created.

Even if you do see these items in your Apple menu, you may want to use the Apple Menu Options control panel to change the number of applications, documents, and servers that the folders remember. I find that 15 is a good number — enough to ensure that the application or document (I rarely use the server folder) that I am looking for is still there, but not so many that the submenu scrolls off the screen.

These three folders track the last x-many applications, documents, and servers that you opened. Each time you open one of these three types of icons, the System makes a mental note of it and then creates an alias of that application, document, or server and pops it into the appropriate folder in your Apple Menu Items folder. The system also limits the number of items in each folder based on the Apple Menu Options control panel’s settings. So when you open your 16th application, the oldest application alias in the Recent Applications folder disappears.
Why are these folders useful? Often the document or application that you’re looking for is one you had open earlier in the day or yesterday. These special folders in the Apple menu keep recently used items handy. Chances are, if you used it recently, you’ll want to use it again soon. If so, look in one of these folders (hint: use the submenu — it’s faster).

Automated Tasks

The Automated Tasks folder contains a collection of useful AppleScript scripts. AppleScript is the Mac’s internal scripting language. Scripts can perform many Macintosh tasks that would take several steps to perform manually, such as turning file sharing on and off, changing the number of colors that you see on your monitor, and adjusting the speaker’s volume. Many people refer to what a script does as a macro.

AppleScript is kind of neat and it’s included with Mac OS 7.6 at absolutely no charge. If you’re the kind of person who likes to climb under the hood and get your fingers dirty, there’s a whole chapter (Chapter 13) about AppleScript, the scriptable Finder, and tips on creating your own scripts. Don’t miss it.

Roll Your Own: Customizing Your Apple Menu

Do you remember Figure 4-3, way back there in the beginning of the chapter? Can you say “Boooorrting.” The Apple menu is fully configurable. Whatever is in the Apple Menu Items folder appears in the Apple menu. It’s that simple.

So let’s start to transform your Apple menu from a dull repository for barely useful software to a turbocharged powerhouse that lets you open any file in seconds. (You finish the transformation in Chapter 11.)

So open your Apple Menu Items folder (it’s in your System Folder) and get ready to rock.

Before you do anything else, choose View ﹥ by Name. Now the Apple Menu Items folder’s contents reflect the order that they appear in the Apple menu.
Doing the right thing with your desk accessories

As you've seen, most of the desk accessories are pretty lame. You probably won't use most of them very often. You're going to rearrange your Apple menu now so that they don't take up as much space while preserving your ability to open them quickly. Here's how:

1. Open the System Folder by double-clicking its icon.

2. Open the Apple Menu Items folder (it's in the System Folder) and create a new folder inside it. (To create a new folder, choose File: New Folder or press Command-N.) Name the new folder Desk Accessories.

3. Select all the icons in the window except the folders (see Figure 4-16). There are two ways to do this: the easy way and the hard way. Easy way first: press Command-A (or drag a selection box around the entire contents of the window) to select all the icons; then hold down the Shift key and click each folder. Hard way: Click Apple System Profiler, hold down Shift key, click AppleCD Audio Player, hold down Shift key, click Calculator, hold down Shift key, and so on until all the nonfolder icons are selected.

![Figure 4-16: Select all the icons except the folder and folder alias icons and drag them into the Desk Accessories folder.](image-url)
This exercise illustrates one of the Finder's finer points. You can extend or unextend your selection by using the Shift key. In other words, if you hold down the Shift key and then click an icon, it is added to or subtracted from the selection; if you don't hold down the shift key when you click an icon, only that single icon is selected.

4. Drag these icons onto the Desk Accessories folder that you created in Step 2; when you release the mouse button, all the desk accessories, applications, and aliases that aren't folders move into the Desk Accessories folder.

5. Pull down your Apple menu and revel in your handiwork. It should look like Figure 4-17.

**Putting your stuff into the Apple menu**

Okay, that last trick was pretty easy, wasn’t it? Try one more thing before you move on. Why not add your favorite applications — the programs you use most often — to the Apple menu.

1. Find a favorite application on your hard disk, select it, and make an alias of it (File→Make Alias or Command-M).
2. Move the alias to the Apple Menu Items folder.
3. Repeat Steps 1 and 2 for the any additional applications that you wish to appear in your Apple menu.

If you have a lot of programs that you use often, you can create a folder called My Favorite Programs in the Apple Menu Items folder and put all the application aliases there instead, which keeps your Apple menu short and sweet (see Figure 4-18).
My Deep, Dark Secret

I can't go on with this charade any longer. The figure caption for that last picture did it. "My short and sweet" my butt. I confess: The screen pictures you've been looking at aren't from my Mac at all. They're from a Mac I borrowed from Apple to create the screen shots for this book. My Mac looks totally different.

I'm a power user. I've got my Mac souped up and tricked out to the max. I've got strange icons in the menu bar. My menus and Finder file names are in Vintage Typewriter font. I've got a Trash can in each corner (though you can only see one of them in this screen shot).

I didn't want to confuse you, so I borrowed a Mac that has nothing on it except Mac OS 7.6-related stuff. It makes for much cleaner screen shots and lets me avoid explaining every last difference between your Mac and mine. For the record, my Mac really looks like Figure 4-19.
I'll just point out a few highlights. First, I have a 20-inch Sony Trinitron monitor. The clock and telephone in the menu bar let me look at my appointments or phone book file without launching my calendar (Now Up-To-Date) or contact database (Now Contact) programs. The small font and all other nifty handiwork in my Apple menu — the divider lines, the lack of icons, and so on — are courtesy of another fine Now Software product, NowMenus. The fruit icon near the Special menu is my Big Island YoYo, a way-cool CallerID device for the Mac; the CC icon next to the Help menu is for Conflict Catcher, a kind of Extensions Manager (see Chapter 12) on steroids from Casady & Greene. I use Stickies to remember my web page addresses.

I have six volumes (disks) mounted — five of them are partitions of my APS 4-gigabyte hard disk, and the Macintosh HD icon represents the Mac I'm using for the screen shots, which I access through Mac OS 7.6's file sharing.

At bottom left you see a window (The Aliai) that contains my collection of frequently used aliases. I stick them in a folder so I can use the small icon view (one disadvantage of using the desktop for icons is that you can only have large icons).

There, I feel better having gotten that off my chest. You'll learn most of these tricks and more before I'm through with you.
Part I: Basic Training
Chapter 5

Save Yourself Heartache: Master the Save and Open Dialog Boxes

In This Chapter

- Nested folders and paths
- Save your document before it's too late
- Save versus Save As?
- The Open dialog box

Mark my words, this is the most important chapter in this book. If you don't understand the Open and Save dialog boxes, the doohickies that appear when you choose File::>Open or File::>Save in most programs, you'll never quite master your Macintosh. Yet mastering these essential techniques is perhaps the biggest problem many users have. I get more phone calls that begin, “Well, I saved the file, and now I don't know where it went.”

This chapter is the cure. Just pay attention and it’ll become crystal clear. And keep saying to yourself, “The Save and Open dialog boxes are just another view of the Finder.” I'll explain in a moment.

The Open and Save dialog boxes are virtually unchanged from earlier versions of the operating system, which means that they’re just as confusing now as they were before. Too bad. While Apple was souping up Mac OS 7.6, it could have made the Open and Save dialog boxes a little easier to use.

Never mind. They’re not that bad. And after you figure out how they work, you'll never forget. Using them will soon become second nature to you, and you'll cruise through Open and Save dialog boxes just like the pros, barely thinking about them as your fingers type and click at high speeds.
Nested Folders and Paths (It’s Not as Bad as It Sounds)

Before we get started, I need to remind you that you work with Open and Save dialog boxes within applications. I assume that you know how to launch your favorite application and that you know how to create a new document. If you can’t do these things, I recommend that you read Mr. Pogue’s Macs For Dummies. That book has a section on getting the beginning user started with popular Mac programs.

For the rest of this chapter, I’m going to use SimpleText as the sample application. SimpleText comes with Mac OS 7.6, so you should have it. In fact, you’ve probably already used SimpleText to read any Read Me files that came with Mac OS 7.6.

So if you want to follow along, keystroke by keystroke, launch SimpleText and use File->New to create a new document. Type a few words in your document, like “Let us go then, you and I, when the evening is spread out against the sky like a Macintosh sitting on a table.” Or something like that (forgive me, T. S. Eliot).

Switch from SimpleText to the Finder (you remember how). You may find the next part easier if you hide SimpleText (you know how to do that, too!) while you work in the Finder. If you’ve forgotten how to do either, pull down the Application menu, the one at the far right; everything you need is right there.

1. Open your hard disk’s icon and create a new folder at root level (that is, in your hard disk’s window). Name this folder Folder 1 to reflect the fact that it’s one level deep on your hard disk.

2. Open Folder 1 and create a new folder in its window. Name this folder Folder 2 to reflect the fact that it’s two levels deep on your hard disk.

3. Open Folder 2 and create a new folder in its window. Name this folder Folder 3 to reflect the fact that it’s three levels deep on your hard disk.

You should now have a set of nested folders looking something like Figure 5-1.

Let me make this perfectly clear: Stuff inside Folder 3 is four levels deep. Folder 3 itself is three levels deep. Folder 2 itself is two levels deep, but stuff inside Folder 2, such as Folder 3, is three levels deep. And so on. Got it?

What’s important here is that you are able to visualize the path to Folder 3. To get to Folder 3, you open Macintosh HD, open Folder 1, open Folder 2, and then open Folder 3. Remember this concept. You’ll need it in a moment when you look at the Save dialog box.
An easy way to see the path to any open folder is to Command-click its name in the title bar of its window (hold down the Command key before you press the mouse button). This action displays a drop-down path menu for that folder starting at the desktop level, as shown in Figure 5-2.

This path menu is live, which means that you can choose another folder from it by sliding the cursor to the folder's name and releasing the mouse button.

Try out this feature with Folder 3. Command-click its title bar, move the cursor down until Folder 1 is highlighted, and then release the mouse button. Folder 1 will pop to the front and become the active window. Try to remember this shortcut, as Command-clicking title bars can save you lots of time and effort.

Okay, our preparatory work in the Finder is through. Use any of the techniques you know to make SimpleText the active application. And don't forget what that path to Folder 3 looks like.
Save Your Document before It's Too Late

Back in SimpleText, it's time to save your masterpiece. Choose File→Save (Command-S). This command brings up the Save dialog box (shown in Figure 5-3). Don’t panic. These dialog boxes are easy as long as you remember that they're just another view of the folder structure in the Finder.

When the Save dialog box appears, the first thing I want you to do is click the Desktop button to view the icons on your desktop.

![Figure 5-3: The Save dialog box for SimpleText after clicking the Desktop button.]

The Save dialog box contains that other view of your hard disk I talked about earlier. You’re looking at the icons on your desktop right now. You know that they’re the icons on your desktop because the active item is the desktop. Its name appears on the drop-down menu at the top and center.

In programs other than SimpleText, the Save dialog box may look slightly different because it contains additional options. Don’t worry. The Save dialog box always works the same, no matter what options are offered. Once you can navigate with the SimpleText Save dialog box, you’ll be able to navigate with any program's Save dialog box. So don’t worry if the one you’re used to seeing doesn’t look exactly like Figure 5-3; just follow along and learn.

Click Macintosh HD (that is, your hard disk, whatever its name is) in the scrolling list (known as the file list box) and then click the Open button or press the Return or Enter key on your keyboard. (In all dialog boxes, the Return or Enter key activates the default button, which is the one with the heavy border around it.) Double-clicking Macintosh HD will open it as well.

Open Folder 1 the same way. Open Folder 2 the same way. Open Folder 3 the same way. Your Save dialog box should look like Figure 5-4.
In other words, you navigate through folders in the Save dialog box the same way you navigate through folders in the Finder: by opening them to see their contents.

In the Save dialog box, the name at the top in the drop-down menu is the name of the active item (a folder, disk, or the desktop). Think of the active item in a Save dialog box as the active window in the Finder. That’s where your file will be saved if you click the Save button. That’s an important concept. The file will always be saved in the active folder (or disk or the desktop) — the folder (or disk or the desktop) whose name appears at the top of the dialog box in the drop-down menu.

To make comprehension easier, think back to when I asked you to remember the path to Folder 3 in the Finder. Now look at the current path to Folder 3 in the Save dialog box by clicking the drop-down menu. Like the drop-down path menu in the Finder (Command-click the window’s name in the title bar), the drop-down menu in the Save dialog box is also live, so if you slide the cursor down to another folder (or Macintosh HD or the desktop), that item will become the active item (see Figure 5-5).

The Save (and Open) dialog boxes treat disk icons and the desktop the same as they treat folders. Though they’re not really folders, you can save items to the desktop or root level (your hard disk’s window).

You always move through the hierarchy in the same way. The desktop is the top level. When you’re at the desktop level, you can see all mounted disks and any folders on the desktop. If you open a disk icon, you see its folder structure. You always navigate up and down the tree. Your most deeply nested folders are at the very bottom; the desktop is at the very top.

If you have more than one disk mounted, make sure that the disk name, which appears in the top right next to a little disk icon (hard disks have a hard disk icon; floppies, a floppy disk icon), is correct. If it’s not, navigate back up to the desktop level and choose the correct disk.
Get into the habit of noticing the disk name in the Open and Save dialog box if you often have multiple disks mounted. Nothing is more frustrating than saving a file to the wrong disk and not being able to find it later.

Your file is saved to the active item in the drop-down menu when you click Save. In other words, when the desktop is the active item (as it is in Figure 5-3), your document will be saved on the desktop if you click the Save button. When Macintosh HD is the active item, your document will be saved in the Macintosh HD window if you click the Save button. When Folder 3 is the active item, your document will be saved in Folder 3 if you click the Save button. Try these steps:

1. In the Save dialog box, navigate to Folder 3; that is, make Folder 3 the active item.

2. When Folder 3 appears as the active item, select the words “untitled 1” and type in a more descriptive name. (I called mine Masterpiece.)

3. Click the Save button (or press the Enter or Return key).

That’s it. If you switch to the Finder and open up Folder 3 (if it’s not already open), you’ll see that the file is saved right there in Folder 3.

Congrats. That’s all there is to it. You now know how to navigate in a Save dialog box.

Remember the path I asked you to remember, the one you saw when you Command-clicked the title bar of Folder 3’s window? Just remember that the path in the Save dialog’s drop-down menu (shown in Figure 5-5) is the same.

If that information makes sense to you, you’re golden. If you’re still a little shaky, go back and try the exercise again and keep trying to understand the relationship between the three folders that you created (one inside the other inside the other) and the drop-down path menus you see when you
Command-click Folder 3's title bar or click its name in the drop-down menu in the Save dialog box. Keep reviewing the illustrations. Eventually it'll just click, and you'll slap yourself in the head and say, "Now I get it."

Don't read on until you get it. This idea of paths and navigating is crucial to your success as a Macintosh user.

There's a little more, but if you get it so far, you're home free.

**The rest of what you should know about Save dialog boxes**

One thing you need to know is that the file list box and the file name field are mutually exclusive. Only one can be active at a time. You're either navigating the folder hierarchy or you're naming a file. When a Save dialog box first appears, the file name field is active, ready for you to type a name (as shown on the right in Figure 5-6).

Notice the border around the file list box when it is active. Also notice how the bottom button changes from Open to Save when the file name field is active. You'll hear more about this phenomenon in a few pages.

When you want to navigate, click anywhere in the file list box to make it active. In Figure 5-6, this box is beneath the active item (Macintosh HD), which contains several folders. When you click anywhere in the box, it becomes active and displays a double-lined border around it. If you type something while the file list box is active, the list will scroll and select the folder that most closely matches the letter(s) you typed. Go ahead and give it a try. It's easier to experience than explain.
For what it's worth, you can also type the first letter or two in any Finder window to select the icon closest alphabetically to the letter or letters you typed.

When the file list is active, the letters that you type do not appear in the file name field. If you want to type a file name, you have to activate the file name field again in order to type in it. Here's how:

Regardless of which is active at the time, when you press the Tab key on your keyboard, the other will become active. So if the file name field is active, it becomes inactive when you press Tab, and the file list box becomes active. Press Tab again and they'll reverse — the file name field becomes active again.

If you don't feel like pressing the Tab key, you can achieve the same effect by clicking either the file list box or the file name field to activate them.

Try it yourself and notice how visual cues let you know which is active. When the file list is active, it displays a border; when the file name field is active, the file list has no border and the file name field is editable.

**The buttons**

There are five buttons in SimpleText's Save dialog box: Eject, Desktop, New Folder, Cancel, and Open/Save. The first four are straightforward and almost explain themselves, but the fifth requires a bit of concentration.

**Ejector seat**

The Eject button is only active when an ejectable disk is selected in the file list box. It's mostly used to save a file to a different floppy than the one currently in the drive. Use the Eject button to eject that floppy so that you can insert another. When you insert a floppy disk, it becomes the active item automatically. You can tell because its name appears in two places (see Figure 5-7).

- At the top-right of the Save (or Open) dialog box above the buttons
- In the drop-down menu above the file list box

**Do it on the desktop**

The Desktop button takes you rocketing up the hierarchy of folders to the very top level, as high as you can go. When you click the Desktop button, the desktop becomes the active folder (I know that the desktop isn't really a folder, but play along) in the Save dialog box. From here you can navigate your way down into any subfolder.
If you get lost in a Save (or Open) dialog box, the best thing to do is click the Desktop button and start from the top (the desktop), which should make it easy to find your way to the folder you desire. Just remember to navigate down through folders in the same order you would in the Finder.

**Something new: the New Folder button**

This button is a nice touch. If you click the New Folder button, a new folder is created inside the active folder in the Save dialog box. You can then save your document into it. Not every program has this button; in fact, most don’t. So don’t get too used to it.

What usually happens is that you don’t think about needing a new folder until the Save dialog box is on-screen. And in most Save dialog boxes, there’s not a thing you can do about it.

What I do in these cases is save my file on the desktop. Later, when I’m back in the Finder, I create a new folder in the proper place on my hard disk and then move the file from the desktop to its folder.

**That’s an 86: Cancel**

The Cancel button dismisses the Save dialog box without saving anything anywhere. In other words, the Cancel button returns things to the way they were before you brought up the Save dialog box.

The keyboard shortcut for Cancel is Command-period (the Esc key sometimes works too). I said it before and I’ll say it again: Command-period is a good command to memorize. It cancels almost all dialog boxes, and it also cancels lots of other things. If something is going on (for example, your spreadsheet is calculating or your database is sorting or your graphics program is rotating) and it’s taking too long, try Command-period. It works (usually).

**The Open/Save button: the exception to the rule**

If you’ve been paying extra careful attention to the illustrations, you’ve no doubt noticed that the button near the bottom sometimes says Save and other times says Open. I even called your attention to it a few pages ago. So? What gives?
In particular, how do you save something when there's no Save button (see Figure 5-8)?

Say I want to save the file A Magnus Opum in Folder 1. I navigate my way to Folder 1. I see it at the top in the drop-down menu. I'm ready to save it but there's no Save button, as is the case in Figure 5-8.

That's because Folder 2 is selected in the file list box, and if a folder is selected in the file list box, the button says Open, not Save. To deselect Folder 2, click anywhere in the file list box except on Folder 2 or press the Tab key. When Folder 2 is no longer selected in the file list box, the Open button becomes the Save button, and you can now save (see Figure 5-9).

I know. It doesn't really make sense, but that's how it works. Try it a couple of times. It's not as straightforward as other parts of the Mac interface, but once you get it, you get it for life.
I could have just as easily pressed the Tab key instead of clicking. The net result would be exactly the same — the Open button would change to the Save button.

If this little section confuses you, look again at Figures 5-8 and 5-9. Folder 1 is where I want to save the file. But there's no Save button in Figure 5-8 because a folder, Folder 2, is currently selected. When I click anywhere in the file list box (anywhere except on Folder 2) or press the Tab key on my keyboard, Folder 2 is deselected, the Open button changes into the Save button, and I can save the file named A Magnus Opum in Folder 1.

If you still aren't sure what all this stuff means, try it. It's not particularly intuitive, but it's relatively easy to get the hang of.

1. Select Folder 2 in the file list box of the Save dialog box (Folder 1 is the active folder).
2. Click the file list box anywhere but on Folder 2. Notice the Open or Save button before and after you click.
3. Press the Tab key. Notice the Open or Save button before and after you press Tab.

When the button says Save and you click the button or press Return, the file is saved in Folder 1. When the button says Open (because Folder 2 is selected) and you click the button or press Return, you move down one level and Folder 2 becomes the active folder.

Got it?

It Looks Like Save, It Acts Like Save, So Why Is It Called Save As?

The Save As command, which you'll find in the File menu of almost every program ever made, lets you save a file that's already been saved and give it a different name.

Why might you want to do that? Let's say you have two sisters, Jodie and Zelda. You write Jodie a long, chatty letter. You save it as Letter to Jodie. Now you decide you want to send it to Zelda too, but you want to change a few things. So you change the part about your date last night (Zelda isn't as liberated as Jodie) and replace all references to Steve (Jodie's husband) with Zeke (Zelda's husband). Aren't computers grand?
Save Early, Save Often = No Heartache

This is as good a time as any to talk about developing good saving habits. Needless to say, it's a very good idea to save your work every few minutes.

After you've saved a file for the first time (and named it something distinctive), you should (re)save it every few minutes while you work on it. You won't see the Save dialog box again; saving after you've named and saved a file once is transparent.

In most programs, either choose File > Save or use the keyboard shortcut Command-S. Think of Save as updating the file on your disk to include everything you've done since your last save.

Here's my advice:

- Always save before you switch to another program.
- Always save before you print a document.
- Always save before you stand up.

If you don't heed this advice and your Mac crashes while switching programs, printing, or sitting idle (which, not coincidentally, are the three most likely times for it to crash), you'll lose everything you've done since your last save.

So save early and save often. Command-S is the keyboard shortcut for Save in almost every program I know. Memorize it. See it in your dreams. Train your finger muscles to do it unconscious. Use it (the keyboard shortcut) or lose it (your unsaved work).

You've made these changes to Letter to Jodie, but you haven't saved again since you decided to make the changes. So now the document on your screen is actually a Letter to Zelda, but its file name is still Letter to Jodie. Think of what would happen if you were to save now.

I'll tell you: If you save now, the file named Letter to Jodie will reflect the changes you just made. The stuff in the letter that was meant for Jodie will be blown away and replaced by the stuff you said to Zelda. If you save now, the file name Letter to Jodie will be inaccurate.

That's what Save As is for. If you use Save As now (it's a different command from Save — look on the File menu and see), you get a Save dialog box where you can type in a different file name. You can also navigate to another folder, if you like, and save the newly named version of the file there.

Now you have two files on your hard disk — Letter to Jodie and Letter to Zelda. Both contain the stuff they should.

That's what Save As is for.

It might not be obvious at first, but you can also use Save As to provide a backup when you make massive changes to a document. I use it to hang on to earlier versions of stuff I write. It's kind of like a giant Undo command.
_ Chapter 5: Save Yourself Heartache: Master the Save and Open Dialog Boxes

For example, I finished writing this chapter late last night. This morning I had a whopper of an idea about how to make the step-by-step instructions clearer. This is where the giant Undo comes into play — I wanted to retain the option of going back to the way the chapter was if my great idea doesn’t work out.

So I opened the file (it’s called MOS764D.Ch05 if you must know) and used Save As to save a new version for me to experiment with (I called this one MOS764D.Ch.05 Rev1).

I then worked on MOS764D.Ch.05 Rev 1 for a couple of hours, saving every few minutes as a conscientious Macintosh user should. In the end, I hated it. So I dragged MOS764D.Ch.05 Rev 1 to the Trash and thanked my lucky stars that I’d had the presence of mind to use Save As before I began revising.

I’m now putting the finishing touches on MOS764D.Ch05, picking up where I left off last night. Had I not done a Save As before I started this morning, things would have been much harder.

Open (Sesame)

You already know how to use the Open dialog box; you just don’t know you know yet.

Using the Open dialog box

Guess what? If you can navigate using a Save dialog box, you can navigate using an Open dialog box. They work exactly the same way except for a couple of very minor differences.

First, there’s no file name field. Of course not. This dialog box is the one you see when you want to open a file! There’s no need for the file name field 'cause you’re not saving a file.

There’s also no New Folder button. You don’t need it when you’re opening a file. (It sure comes in handy when you’re saving a file though, doesn’t it? Sure wish every program had one.)

Anyway, that’s it. Those are the differences. Navigate the same way as you would in a Save dialog box. Don’t forget your mantra, “The Open and Save dialog boxes are just another view of the Finder.”
Figure 5-10 shows two different ways of viewing the same file. The Open dialog box, at top, has navigated to the file Masterpiece in Folder 3. I clicked the drop-down menu in the Open dialog box to show you the path to the file Masterpiece.

Below the Open dialog box is the Finder view of the path to the file Masterpiece.

If you aren’t 100-percent comfortable with the relationship between the two views, please go back and try the hands-on exercises earlier in this chapter again. Please. Keep reviewing the pictures and instructions until you understand this concept. If you don’t, your Mac will continue to confound and confuse you. Do yourself a favor — don’t read any further until Open and Save dialog boxes feel like the most natural thing in the world to you.

**A really big show — Show Preview**

Okay, there’s something else about the Open dialog box that’s different. As you can see back in Figure 5-10, the Open dialog box for SimpleText has a
check box called Preview. What does this little box do? It lets you create little previews for PICT files, which are the type of files created by many popular graphics programs. Click the check box and then click the Create button when a PICT file is highlighted in the file list. After a moment, a little picture will appear (see Figure 5-11). From now on, every time that file is highlighted in an Open dialog box, its preview picture automatically appears (as long as the Show Preview check box remains checked).

As you might guess, previews are a nice feature to have. Many graphics programs include previews in their Open dialog boxes. At least one, Adobe Photoshop, creates a custom icon for its documents that reflects their contents when it saves them (see Figure 5-12).

Unfortunately, you have to be in the Icon view, which you know I dislike, to see these icons. Still, they're pretty cute.
Weird folder or file names

Every so often, you'll see some weird folder names — such as Move & Rename, or Network Trash Folder, or Desktop DB or DF, or VM Storage — in the Open dialog box (see Figure 5-13), but you don't see these folders when you look at the corresponding windows in the Finder. Don't worry. It's perfectly natural.

In Figure 5-13, you can see that there are two items shown in the Open dialog box that don't appear in the Macintosh HD window in the Finder. The Macintosh HD window says it contains five items; all five are showing in its window.

Here's what's going on:

Move & Rename and VM Storage are invisible files. You aren't supposed to see them. The System uses them to keep track of stuff that you don't need (or want) to know about. They're invisible when you look in the Macintosh HD window but they show up in some applications' Open dialog boxes. This anomaly is known as a bug. You shouldn't be able to see those files. Just ignore them and they won't bother you. If you're lucky, you won't even see them on your Mac (many people don't).
How many of you have done the math and come up short? There are six folders in the Open dialog box. Two of them are invisible in the Finder. But there are five items in the Macintosh HD window. Add two invisible folders and there should be seven in the Open dialog box, not six. Why don't things add up?

Bzzzzt. Time's up. The items don't add up because you can see the SimpleText application's icon in the Finder but not in the Open dialog box (because SimpleText can't open itself).

Selectively displaying certain items in Open dialog boxes is a feature of most applications. When you use a program's Open dialog box, only files that the program knows how to open appear in the file list. In other words, the program filters out files that it can't open, so you don't see them cluttering up the Open dialog box. Pretty neat, eh?

On the other hand, not seeing every item in an Open dialog box can be a little disconcerting when you're trying to envision the correlation between the Finder and the Open dialog box. Stuff you see in the Finder doesn't always appear in the Open dialog box. That's why I showed you the Save dialog box first. It always includes everything. In a Save dialog box, items that you can't select appear grayed out, but they do appear. Open dialog boxes usually show only files that you can select and open with the current application.
"Now when someone rings my doorbell, the current goes to a scanner that digitizes the audio impulses and sends the image to the Mac where it's converted to a Tiff file. The image is then animated, compressed, and sent via high-speed modem to an automated phone service that sends an e-mail message back to tell me someone was at my door about 40 minutes ago."
In this part...

The chapters in this part show you how to perform important hands-on tasks. But don't get all worked up: This stuff is easy. In fact, I think of this part as "The Lazy Person's How-To Guide."

Chapter 6 deals with how to organize your Mac. You discover, among other things, how to do routine file-management and navigating tasks the easy way.

Next is the how-to-print chapter, Chapter 7. It includes info on how to decipher Print options and plenty of other hows and whys that will help you become a modern-day Gutenberg.

In Chapter 8, you find out how to share. Files, that is. It's easy, it's convenient, it's free, and it beats the heck out of sneakernet.

Finally, there's a wonderful chapter (numbered, conveniently enough, 9) on how to manage memory (and other seemingly complicated arcana), an easy-to-understand, almost jargon-free primer on how the whole memory thing works.
Chapter 6

File Management Made Simple

In This Chapter
- Using Launcher (or not)
- Getting yourself organized (or something like it)
- Using aliases
- Looking at other people's Macs

In Chapters 1 through 5, I detail for you the basics about windows and icons and menus. In this chapter, you apply that knowledge as you begin a never-ending quest to discover the fastest, easiest, most trouble-free way to manage the files on your Mac.

I can help. I'm not a doctor, but I play one in books and magazines. I've been wrangling with the Macintosh interface for more than ten years now, and I've learned a lot about what works and what doesn't — at least what works for me. This chapter will spare you at least part of the ten-year learning curve.

Remember, we're talking about Mac OS here. And we're talking about developing your own personal style. There is no right way to organize your files, no right way to use aliases, no right way to use the Apple menu, and no right way to use drag and drop. The only thing for sure is that these features are useless if you don't use them.

Please take the time to understand these wonderful features. They make your Mac so much easier to use. I'll show you how I do it and then give you a glimpse of how a few of my friends do it. After absorbing that info, you'll have all the ammunition you need to create your own personal Macintosh experience, a Mac environment designed by you, for you.
Launcher (Or Not)

Launcher is a relatively new (unless you have a Performa — Apple's included a similar Launcher with Performas for a while) control panel, introduced in System 7.5, that creates a window in the Finder with single-clickable icons that launch (open) frequently used files.

If you don't see Launcher, choose Apple Menu › Control Panels › Launcher. If you want Launcher on all the time, choose Apple Menu › Control Panels › General Controls and click the box marked Show Launcher at system startup.

The advantage of Launcher is that the icons in the Launcher window can represent items in many different folders on your hard disk (see Figure 6-1).

So Launcher, at least in theory, saves you time by saving you from rooting through folders every time you need one of these items.

Launcher is easy to configure. Just drag anything you want to add to the Launcher window onto the Launcher window.

Here's what happens when you drag an icon onto the Launcher window:
Your Mac creates an alias of that icon and places that alias in the Launcher Items folder, which you can find in your System Folder (see Figure 6-2).
If you want something to appear in the Launcher, put an alias of it in the Launcher Items folder or drag its icon onto the Launcher window. To remove an item, hold down the Option key and drag it to the Trash. That’s it. The whole enchilada.

Well, almost the whole enchilada. There’s one other feature I feel obligated to mention. You can create categories for Launcher by creating folders in the Launcher Items folder and starting their names with the bullet character (•), which you create by typing Option-8. Using bullets creates categories, with different buttons for different stuff, as shown in Figure 6-3.

For what it’s worth, I couldn’t find anything about Launcher in my Apple manual, but I got a great demo of this trick by searching for Launcher in Mac OS Guide. Yet another reason for you to check out Apple’s cool new active assistance.

I think I’ve been objective up to this point. Now I’ll tell you why I think Launcher stinks:

- It doesn’t float in front of other Finder windows, so it’s easy to lose behind other windows.
- It has only a Large Icon view, so it wastes valuable screen real estate.
- It can’t be chosen from the Application menu.
It's no different from a regular window in View by Icon mode except that . . .

. . . It uses single clicks to open icons, a clear violation of *Macintosh Human Interface Guidelines*, the bible of Macintosh interface design.

So why did Apple start including Launcher, first with Performas and now with System 7.5 and Mac OS 7.6? And why, after ten years of rabid insistence that double-click means *open*, did Apple change its mind?

My take on this subject is that Apple is afraid that new users are too stupid to grasp the concept of double-clicking to open a file. And too stupid to realize that you can do everything Launcher does and more by customizing your Apple menu (as you'll see later in this chapter).

I don't think you're that dumb. I say get rid of the lame-o Launcher. (See Chapter 14 for complete instructions on shuffling Launcher off this mortal coil.)

With what you discover in this chapter, you'll instead be able to create your own customized environment, which I promise will let you find and launch items faster and more flexibly than Launcher.
On the other hand, if for some unfathomable reason you like Launcher, by all means enjoy it. It doesn’t use that much disk space or RAM, so there’s no great advantage to trashing it.

No advantage, that is, besides never seeing Launcher again (which I consider a big advantage). If a single-click file launcher tickles your fancy, there are excellent commercial offerings like DragStrip and Square One that make Launcher seem even crummier. There are probably shareware solutions that are miles better than Launcher as well, but I don’t know any offhand.

**Getting Yourself Organized (Or Something Like It)**

I won’t pretend to be able to do this task for you. Organizing your files is as personal as your taste in music. You develop your own style with the Mac. So in this section, I give you some food for thought, some ideas about how I do it, and some suggestions that should make organization easier for you, regardless of how you choose to do it yourself.

**And it’s root, root, root for the root level**

Root level is the window you see when you open your hard disk’s icon. It’s the first level down in the hierarchy of folders. How you organize root level is a matter of taste, but let me try to give some guidance.

**KISS: Keep it simple, stupid**

I find that less is more when it comes to organizing files and folders. I try to use the simplest structure that meets my needs. For example, if I have more than a handful of icons at root level, I begin to look for ways to reorganize. I shoot for no more than ten items at root level; fewer is better.

**At the very least . . .**

Root level must contain the System Folder. It won’t work properly if you put it somewhere else (like in another folder or on the desktop). Beyond that, what you place on the root level is up to you.

I think most people should start with two other folders, Applications and Documents, at the very least, but even these don’t have to go at root level. The desktop is an equally good place for them, as you’ll see in a later section.
Documentary evidence: 
the Documents folder

Remember, you don’t have to have a Documents folder, but if you do, here are some tips for organizing it:

✔ Don’t create subfolders (within the Documents folder) until you need them.

✔ Creating a bunch of empty folders because you think that you might need them someday is more work than creating them when you need them. You end up opening an empty folder when you’re looking for something else — a complete waste of time.

✔ I recommend saving everything in the Documents folder for a week or two (or a month or two, depending on how many new documents you save each day). Once a decent-size group of documents has accumulated in the Documents folder, take a look at them and create logical subfolders to put them into.

✔ Let your work style decide file structure.

You should create the subfolders based on a system that makes sense to you. Here are some ideas for subfolders:

✔ By type of document: Word Processing documents, Spreadsheet documents, Graphics documents

✔ By date: Documents May-June, Documents Spring ’97

✔ By content: Memos, Outgoing Letters, Expense Reports

✔ By project: Project X, Project Y, Project Z

When things start to get messy and you start noticing some folders bulging (that is, filled up with tons of files), subdivide them again and use a combination of the methods I just mentioned.

For example, if you start by subdividing your Documents folder into four subfolders — Memos, Expense Reports, Letters, and Other Documents (as shown in Figure 6-4) — a few months later, when those folders begin to get full, you might subdivide them in one or more of the ways, as shown in Figure 6-5.

The folder called Other Documents hasn’t required subdividing yet, as it only contains five items. If I accumulate a few more poems there, I might consider creating a Poems subfolder inside the Other Documents folder.
The point is that your folder structure should be organic, growing as you need it to grow. Let it happen. Don't let any one folder get so full that it's a hassle to deal with. Create new subfolders when things start to get crowded.

How full is too full? That's impossible to say. If I find more than 15 or 20 files in a single folder, I begin thinking about ways to subdivide it. On the other hand, some of my subfolders that contain things I don't often need, such as my Correspondence 1992 folder, contain more than 100 files. Because I don't use the folder that much (but want to keep it on my hard disk just in case), its overcrowded condition doesn't bother me. Your mileage may vary.

After almost ten years of growth, my Documents folder contains only about a dozen subfolders, most of which contain their own subfolders (see Figure 6-6). Being a nonconformist, I call my documents folder Stuff.
Other folders at root level

You can follow this same philosophy for other folders at root level, subdividing them as needed. If you use a particular folder a great deal, move it from the Documents folder to root level or to the desktop (more about that in a few pages) to make it easier to use.

The only thing I might caution you against is storing stuff in the System Folder that doesn't belong there. There's no harm in it, but the System Folder is already the repository for many files used by the System software and by applications. For most people, the System Folder is the most crowded folder on their disk, so sticking items that don't belong in it only causes further clutter. Word processing documents and spreadsheets (and indeed almost all documents) don't belong in the System Folder. You know how the file system works. Create a folder somewhere else for your documents.

Other than that, the only rule is that there are no rules. Whatever works for you is the best way.
Apply here: the Applications folder

I recommend having an Applications folder for all your programs. The best place for this folder is either at root level or on the desktop. Your Applications folder can also be subdivided when the need arises. Given what I do for a living, I have a lot of programs, so mine has subfolders for business programs, graphics programs, writing tools, utilities, and online (modem) stuff, as shown in Figure 6-7.

It'll probably be a while before you need so many subfolders — unless you're like me and try a lot of new software. Either way, organize your applications the same way you organized your documents — in a way that makes sense to you. Follow this advice and I promise that you'll always be able to find what you're looking for.

The Greatest Thing Since Sliced Bread: Aliases

When System 7 first arrived several years ago, many of its features were heralded as breakthroughs. But of these features, none has proved to be more useful than the alias.

An alias, if you've forgotten, is a quick-opener for another file. With aliases, a file can be in two (or more) places at once. When you create an alias of a disk, file, or folder, opening its alias is the same as opening the item. And an alias takes up only the tiniest bit of disk space.

Why is this feature so great? First, it lets you put items in more than one place, which on many occasions is exactly what you want to do. For example, it's convenient to keep an alias of your word processor on your desktop and another in your Apple menu. You may even want a third alias of it in your Documents folder for quick access. Aliases let you open your word processor quickly and easily without navigating into the depths of your Applications folder each time you need it.
Here's another example: If you write a memo to Fred Smith about the Smythe Marketing Campaign to be executed in the fourth quarter, which folder does the document go in? Smith? Smythe? Marketing? Memos? 4th Quarter?

With aliases, it doesn’t matter. You can put the actual file in any of the folders and then create aliases of it and place them in all the other folders. So whichever folder you open, you’ll be able to find the memo.

Finally, many programs need to remain in the same folder as their supporting files and folders. Some programs can't function properly unless they are in the same folder as their dictionaries, thesauri, data files (for games), templates, and so on. Ergo, you can’t put these programs on the desktop or in the Apple Menu Items folder without impairing their functionality.

**Icons on the desktop**

How about a little hands-on training? In the following steps, you create an alias for your favorite application and put it on the desktop, a very good place for it.

1. **Find** your favorite application — ClarisWorks, Microsoft Word, Titanic, whatever — and select its icon, not the folder that it’s in. Be sure and select the program’s icon.

2. **Choose** File > Make Alias, or press Command-M, as shown in Figure 6-8.

   An alias of the application appears right next to the original. The alias’s file name is the same as the original’s, except that it is in italics and has the word *alias* appended at the end.

3. **Drag** the alias onto the desktop and move it to a convenient place.
Directly under the hard disk icon is one prime location (see Figure 6-9). Along the bottom of the screen is another.

There. You've just made it easier to use your favorite program. Next time you need your favorite program, just open its alias right there on your desktop instead of opening several folders and cluttering up your screen.

Frequently used folders or documents are good candidates for aliases-on-the-desktop. In fact, any icon you use more than a couple of times a day is a good candidate for an alias on the desktop.

Remember, aliases don't take up much disk space, so there's no penalty for making an alias and later deciding that you don't like it. Big deal. Drag it to the Trash.

**The temporary alias theory**

I use a lot of temporary aliases on my desktop. When I first create a file, I save it in its proper folder, inside my Documents folder somewhere. If it's a document that I plan to work on for more than a day or two, such as a magazine article, I make an alias of the document and put it on the desktop. When the article is done and I've submitted it to my editor, I trash the alias. The original file is already stashed away in its proper folder.

With bigger projects like books, which have multiple subfolders of their own, I keep an alias of the parent folder on the desktop for easy access. When I submit the last chapter, the alias goes into the Trash.

Incidentally, a similar technique can be used without the aliases. Just save all your new documents on the desktop (click the Desktop button in the Save dialog box or use the shortcut Command-D). Later, when you're done with them, you can file them away in their proper folders.
My point is that the desktop is an excellent place for the things that you need most often. Whether you use aliases of documents or save the actual files on the desktop until you figure out where you want to store them, the desktop is a fine place for the things you use most. Keep frequently used programs on the desktop forever, and use the desktop as a temporary parking place for current projects.

Whatever you do, I encourage you to do it on the desktop.

**What a drag it is not to drop**

Macintosh drag and drop deals with dragging text and graphics from one place to another. But there’s another angle to drag and drop, one that has to do with documents and icons.

You can use drag and drop to open a file using a program other than the one that would ordinarily launch when you open the document. This concept is easier to show than to tell, so follow along on your own computer:

1. Make a screen shot picture of your desktop by holding down the Command and Shift keys and pressing the 3 key. Command-Shift-3 takes a picture of your desktop.

2. You hear a cute snapshot sound, and a document called Picture 1 automatically appears in your hard disk’s root level window. Open it.

3. Assuming that there’s a copy of SimpleText on your hard disk, SimpleText will launch and display Picture 1.

   But you don’t want to use SimpleText. SimpleText can open and display a picture file but can’t make changes to it. You want to open the picture with a program that can edit it. What do you do? Use drag and drop.

4. Quit SimpleText.

5. Drag the icon for Picture 1 onto the alias of your favorite program that you created earlier. Figure 6-10 shows how I made changes to Picture 1.

   If the alias of your favorite program didn’t highlight when you dragged Picture 1 on top of it, or if dragging Picture 1 onto the alias launched the program but didn’t open Picture 1, then your favorite program isn’t capable of opening picture files.

   Your solution if your favorite program couldn’t open Picture 1: Get a different favorite program. Just kidding. The solution is to try dragging Picture 1 onto other program icons (or aliases of program icons) until you find one that opens it. When you do, you might want to put an alias of that application on the desktop, too.
What happens if you don't have a copy of SimpleText on your hard disk when you try to open Picture 1? Mac OS Easy Open kicks in and offers you a choice of other programs that can open it (see Figure 6-11).

Figure 6-11:
Mac OS Easy Open lets you choose from compatible applications if you try to open a document created by a program you don't have on your hard disk.
When I trashed SimpleText and tried to open Picture 1, Figure 6-11 is what I saw. In a more technical book, I'd go on to explain about file type and creator codes and how they have to do with which program gets launched when you open a document. But this is Mac OS 7.6 For Dummies, so I won't.

Suffice it to say that Mac OS 7.6 is smart enough to figure out which applications can open what documents and offer you a choice. Earlier versions weren't that smart.

**Smart Apple menu tricks**

Remember when I called the Launcher lame? Here's something way better. I talk a bit about the Apple menu in Chapter 4; here I show you how to make it work for you.

First, make sure that you've turned the wonderful submenus on in the Apple Menu Options control panel. If you don't see little black triangles to the right of all the folders in the Apple menu, they're not turned on.

Now do something useful. Let's make a file launcher that enables you to open every file on your hard disk from a single Apple menu item!

**The hard-disk-alias-in-the-Apple-menu trick**

1. Select your hard disk icon and make an alias of it by selecting your hard drive and choosing File→Make alias or by using the shortcut Command-M.

2. Put the alias of your hard disk in the Apple Menu Items folder (which is in your System Folder).

3. Pull down the Apple menu and admire your handiwork (see Figure 6-12).

If having your hard drive on the Apple menu is too overwhelming for you, consider putting an alias of your Documents folder or your Applications folder in the Apple menu. It's easy, it's fast, and it's convenient. Get in the habit of putting frequently used items (it's not just for desk accessories and folders anymore) in the Apple menu. You'll be glad you did.

**A quick trick for adding an alias to the Apple menu**

1. Select the icon of the item that you want to appear in the Apple menu.

2. Choose Apple menu→Automated Tasks→Add Alias to Apple Menu.

This script automatically creates an alias of the selected item and puts it in the Apple Menu Items folder, as shown in Figure 6-13.
Chapter 6: File Management Made Simple

**Figure 6-12:**
Put an alias of your hard disk in the Apple Menu Items folder to gain easy access to every file on your hard disk.

**Figure 6-13:**
When I release the mouse button, an alias of the Documents folder is created and placed in my Apple Menu Items folder for me.
The old alias-of-the-Apple-Menu-Items-folder-on-the-desktop trick

Are you growing fonder of your Apple menu? You should be. It's a great resource and it's easy to customize. If you find yourself customizing yours a lot, here's a tip to make it easier to use.

Make an alias of the Apple Menu Items folder and put it on your desktop for easy access.

If you make frequent changes to your Apple menu, this tip saves you at least one step. And here's another tip: You can also put an alias of the Apple Menu Items folder in the Apple menu so that you can select it even if a window is covering the alias on your desktop (see Figure 6-14).

When you put an alias of the Apple Menu Items folder in your Apple menu, it doesn't have subfolders, which makes sense when you think about it. If it had subfolders, they would create an endless loop.

By the way, I present some more very cool Apple menu tricks in Chapter 11.
Macstyles of the Not So Rich and Famous

Earlier in the chapter, I promised you a peek at some of my friends' desktops. Personally, I find electronic voyeurism fascinating. I hope you will too. You can learn a lot about people (and a lot of cool tricks to use on your own Mac) by looking over their shoulders at their Macs.

So here are some glimpses into the Macs of a few of my friends.

Robin Williams: Renaissance Woman

Robin Williams (no, not Mork or the voice of Genie) is the author of The Little Mac Book, The Mac Is Not a Typewriter, and The Non-Designer's Design Book.

I'd have never expected her desktop to be so ... well, so austere, but take a look at Figure 6-15.

---

Figure 6-15: Robin Williams's austere desktop and Apple menu.
Steven Bobker: The Godfather of MacUser

Steven Bobker is a legend in Mac circles as the crusty but benevolent Editor-in-Chief of MacUser magazine during its first golden age. He's forgotten more about the Mac than most of us will ever know. Figure 6-16 shows how he keeps house.

Lofty Becker: Triple Threat

Loftus E. Becker, Jr., known to all as Lofty, is a triple Mac threat. He's a consummate power user who uses his Mac for three (count 'em) diverse jobs, often all three at the same time. First, he's a law professor. Then he's a sysop for CompuServe's popular MAUG forums. In his spare time, he's an ace product reviewer for MacWEEK magazine. A busy guy like that has to make the most of his time. Let's look at Lofty's desktop (in Figure 6-17).
Glenn Brown: Federal Agent and Extension King

Glenn Brown works in international customs for Revenue Canada. He's also the king of customizing Macs. In fact, Glenn and I once wrote a book called, coincidentally enough, *Customizing Your Mac for Productivity and Fun*. Glenn holds the world record for running a Mac with the most extensions and control panels at the same time, over 150 at once! Figure 6-18 shows Glenn's highly customized desktop.

Rich Wolfson: The Unkempt Professor

Rich Wolfson is a professor of technology at Montclair State College as well as the supervisor of their Mac lab. He's also the author of *The PowerBook Companion* and a frequent contributor to *MacUser* magazine. Figure 6-19 shows his desktop.
Part II: Making It Purr

Figure 6-18: Glenn's desktop is as customized as they come.

Figure 6-19: Rich doesn't keep things very tidy, does he?
Robyn Ray: Bad Influence

By now I’m sure you’re asking yourself, “Okay, so that’s what the desktops of a bunch of hot-shot writer-types look like. But what about normal folks? What about beginners? What do their desktops look like?”

To answer that question, I turn to my childhood friend Robyn Ray, who is now a casting director for feature films like Threesome, Frank & Jesse, and Bad Influence, and a close personal friend of the Jackson 5. She got her first Macintosh a few weeks ago. Figure 6-20 shows what her desktop looks like today.

Figure 6-20: New user Robyn’s desktop.
Guy Kawasaki: A Marketing Pro

I asked Guy Kawasaki, author of The Macintosh Way, to submit his desktop for this little section of my book. Never shy about self-promotion, Guy sent me a giant screen shot of his desktop with his next book, How to Drive the Competition Crazy: Disrupting the Marketplace for Fun and Profit, prominently displayed in the middle. He figured I'd run the picture full size and his book would get a nice little dose of free publicity. He even sent me a note that said, "Just for this chutzpah, you should put the whole thing in."

Nice try, Guy. His desktop was boring anyway. The only remotely interesting part is the Apple menu (see Figure 6-21).

In spite of my lack of largesse, Guy did say this about the book you're holding in your hand: "If you're only going to buy a book that I didn't write, buy this one!"

For that I am grateful. Especially considering I'm still not going to pimp his book here.

So thanks again, Guy.
Chapter 7

Publish or Perish: The Fail-Safe Guide to Printing

In This Chapter
➤ Choosing a printer
➤ Setting up your page with Page Setup
➤ Printing to most printers
➤ Using desktop printers
➤ Using QuickDraw GX (or maybe not)
➤ Printing PDD documents
➤ Font mania

Printing is like being. It just is. Or at least it should be. It should be as simple as typing Command-P and then pressing the Return key. And usually that's how it is. Except when it isn't, and printing turns into a raging nightmare.

You won't be having any nightmares. If you get your printer and printing software configured properly, printing is simple as can be. And that's pretty darn simple. QuickDraw GX adds a few wrinkles, but it's nothing you can't manage.

So this is a chapter about avoiding nightmares. I go through the entire process, as if you just unpacked a new printer and plugged it in. If you upgraded from an earlier version of System 7 and are able to print with Mac OS 7.6 already, you can probably skip some of the steps. The objective here is to familiarize yourself with the printing process from start to finish.

One thing I suggest is that you read the documentation that came with your specific printer. There are hundreds of different printer makes and models available for the Mac, so I may contradict something that your printer manual says. If you run into this discrepancy, try it the way the manual says first. If that doesn't work, try mine.
Another thing you need to know is that every application can use its own custom Print and Page Setup dialog boxes. Though many will look like the ones in this chapter, others won’t. For example, the Print and Page Setup dialog boxes for Microsoft Word include choices not covered in this chapter, such as Even or Odd Pages Only, Print Hidden Text, and Print Selection Only. If you see commands in your Print or Page Setup dialog boxes that aren’t explained in this chapter, they’re specific to that application and should be explained in its documentation. I’ll be using Apple’s SimpleText program for this demonstration.

Don’t forget about balloon help and Mac OS Guide. Many programs support these excellent Apple technologies; they can be the fastest way to figure out a feature that has you stumped.

To get started, connect the printer to the Printer port on the back of your Mac (with both the Mac and the printer turned off, of course — but you knew that, didn’t you?). If you don’t have a cable (and many Apple printers don’t come with cables), contact your printer manufacturer and ask where it is. Plug the printer into an outlet. Turn it on. If the printer came with software, install it on your hard disk, following the instructions that came with the printer. That’s it.

Ready, set, print!

**Ready: Choosing a Printer in (What Else?) the Chooser DA**

The path to printing perfection begins with the humble Chooser DA. In earlier versions of the Mac OS, it was a necessary evil, but with Mac OS 7.6’s desktop printers, you use it once to set up your printer, and under ordinary circumstances, you rarely use it again.

Note that this chapter describes Mac OS 7.6 without QuickDraw GX installed. There’s a section near the end of the chapter that briefly describes QuickDraw GX and why you might want to install it. If you want to know more about the optional QuickDraw GX, check out Chapter 16. And if you want to install it, look in Appendix A for complete instructions.

Many of the steps involving the Chooser require that the printer be turned on and warmed up, so if yours isn’t, it should be. Do that now so that you’ll be able to choose a printer.
From the Apple menu, grab the Chooser. The Chooser desk accessory opens. If you have previously chosen a printer, its icon is selected when the Chooser opens; if you've never printed before, the Chooser appears with no printer icon selected.

The Chooser is also used to choose network connections. You will see an icon for AppleShare and may also see one for your fax modem. Don't mess with them yet. I talk about file sharing in the next chapter.

If no icon is selected in your Chooser, click the printer icon that matches your printer. If you have an Apple printer, there should be an icon that matches it. If you have an Apple printer and there is no icon that matches your printer, try clicking the one that sounds most like your printer.

If you have a non-Apple printer, see its manual for instructions on installing printer drivers for your printer. Or try clicking one of the Apple printer drivers (if it's a laser printer, try LaserWriter 8; if it's an inkjet, try the StyleWriter 1200).

Most of the icons in the Chooser represent printer drivers. Printer drivers translate between your Mac applications and your printer, ensuring that what you see is what you print. Technically, a printer driver is a special piece of software called a Chooser extension. When you drag a printer driver onto your System Folder, Mac OS 7.6 automatically places it in the Extensions folder for you. As long as a printer driver is in the Extensions folder, you should see an icon for it in the Chooser DA.

If you have a printer made by someone other than Apple, you might want to contact the manufacturer about getting the latest, greatest driver. Many printer manufacturers are offering new drivers with enhanced functionality. If you have a modem, you may find new drivers for your printer on America Online, CompuServe, or the Internet. Check with your printer manufacturer for details. The About QuickDraw GX document, installed with QuickDraw GX, has contact information for many printer manufacturers.

Apple printer drivers are installed automatically when you install the Mac OS. You remove them by dragging them from the Extensions folder to the Trash. It's perfectly safe to remove printer drivers for printers that you never intend to use. Removing unneeded printer drivers can free up more than a megabyte of hard disk space.

Now let's get down to business. The left side of the Chooser should be displaying a selection of printer icons; the right side of the Chooser should be displaying either your printer's name (see Figure 7-1) or a pair of icons (see Figure 7-2).
If you have an AppleTalk printer

If you have an AppleTalk printer, click your printer's name to select it — even if only one name appears, as shown in Figure 7-1.
If you have a serial printer

If you have a serial printer, you see two icons on the right side of the Chooser instead of a printer name. Choose whichever port — Printer or Modem — the printer cable is connected to on the back of your Mac.

If you have a SCSI or server-based printer

If you have a SCSI or server-based printer, you’re on your own. What you see on the right side of the Chooser depends on the SCSI printer’s manufacturer or your server’s setup. I couldn’t beg or borrow one, so I don’t know what you’ll see. With luck, you’ll figure it out.

My printer is a Hewlett Packard LaserJet 4ML, a compact, inexpensive 300-dots-per-inch PostScript AppleTalk laser printer. I’ve had the HP for more than a year and it’s performed like a champ. At some point I plan to upgrade to a 600- or 800-dpi printer, but it’s not mission critical as long as the faithful HP keeps chugging along.

The AppleTalk Active/Inactive radio buttons

Here’s something I can help you with. Should AppleTalk be active or inactive? My answer: Inactive unless you need it.

How do you know if you need AppleTalk? Well, for starters, if you’re on a network and use file sharing, you need it. If your printer is an AppleTalk-only printer (many are), you need it. If you’re in neither of these situations, you probably don’t need AppleTalk. There’s no reason to keep it turned on if you don’t need it.

If in doubt, just give it a try. You’ll know if your printer works with AppleTalk inactive if your printer spits out a page.

That’s it for the Chooser. Go ahead and close it. A desktop printer will be created automatically on your desktop for the printer you chose. I talk much more about those desktop printers later in the chapter. For now, just know that if, for some strange reason you hate it, you can trash it later. (But much like the proverbial bad penny, it’ll keep coming back every time you select a printer in the Chooser.)
Before you close the Chooser...

You’re going to go through the rest of this exercise using my printer, an AppleTalk printer, as the example. If you have a different kind of printer — a serial, SCSI, or server — and you can print to your printer at this point (close the Chooser, open a document, and choose File$Print — if the document comes out of the printer, you can print to your printer), everything in the rest of the chapter should work the same for you.

Set: Setting Up Your Page with Page Setup

The hard part is done. Now you should be able to print a document quickly and easily. Right? Not so fast, bucko. Though you may not need it right this second, you need to know about the Page Setup dialog box.

Almost every program that can print a document has a Page Setup command on its File menu. Some programs call it Page Setup and others call it Print Setup. (Print Setup is the quaint, old-fashioned term, more popular in the System 6 era than today.) Either way, this dialog box allows you to choose paper type, page orientation, scaling percent, page flipping, and page inverting.

The Page Setup dialog box should look like Figure 7-3.

![Figure 7-3: The Page Setup dialog box.](image)
Chapter 7: Publish or Perish: The Fail-Safe Guide to Printing

Paper type

The objective here is to choose the type of paper currently in the paper tray of your printer, or choose the type of paper that you’re about to feed manually.

To do that, click the Paper pop-up menu (see Figure 7-4) and choose the type of paper you plan to use for your next print job.

Page Setup dialog box settings remain in effect until you change them. So if you are printing an envelope this time, don’t forget to change back to US Letter before trying to print to letter-size paper.

Page orientation

Page Orientation lets you tell the printer whether the page you’re about to print is a portrait-oriented (letter, longways) or landscape-oriented (spreadsheet, sideways) page (see Figure 7-5).
The Page Setup dialog box offers a choice of portrait or landscape, as shown in Figure 7-6.

Figure 7-6: Portrait (left) and landscape (right) orientation buttons.

**Scale**

The Scale control (see Figure 7-7), lets you print pages bigger or smaller than their size on the screen.

![Scale control image](image)

Figure 7-7: The Scale control lets you enlarge or reduce your image for printing.

Just type a new value into the text entry box, replacing the number 100. In old-style Page Setup dialog boxes, you can also use the arrow buttons on the screen to change the value.

The range of scaling is 25% to 400%. If you try to enter a higher or lower number, your Mac will beep at you and change it automatically to the closest acceptable number. Nice touch.
Chapter 7: Publish or Perish: The Fail-Safe Guide to Printing

PostScript options

But wait, there's more. The Page Setup dialog box offers two additional sets of options if you choose PostScript Options from the pop-up menu (see Figure 7-8) — Visual Effects and Images & Text.

Visual Effects

Flipping the page vertically or horizontally merely requires that you check the appropriate check box. The dogcow on the miniature page reflects your choices (see Figure 7-9).
Checking the Invert Image option inverts your page, making light areas dark and dark areas light, like a photograph negative.

Note that this option will generally use a lot of toner or ink. And printing a large number of inverted pages could cause a laser printer to overheat or an inkjet printer to clog. So use this feature sparingly.

I suppose that the Invert Image option is useful for creating artsy effects or making negative images of documents that will be printed to film. I've never used it in the eleven years I've used a Mac.

**Image & Text**

These next five options are thrilling. I could spend two pages explaining them, but I'm going to invoke another weasel-out (See Chapter 1) and tell you to look at the Balloon Help to find out what they do.

To do that, while the Page Setup PostScript Options dialog box is on the screen, choose Show Balloons from the Help (question mark) menu and point at each of the five checkboxes, as shown in Figure 7-10.
One last thing...

Most programs also offer their own Page Setup choices. To see them (if your program offers them, of course), choose the program from the pop-up menu below the words “LaserWriter 8 Page Setup.” Photoshop and Microsoft Word have them (Figures 7-11 and 7-12); SimpleText doesn’t.

---

Figure 7-11: Photoshop’s Page Setup choices.

Figure 7-12: Microsoft Word’s Page Setup choices.

---

The Print Dialog Box: Printing to Most Printers

Now we come to the final step before that joyous moment when your printed page pops out of the printer. It’s the Print dialog box, and it’s the last thing standing between you and your output.
While most of you will see Print dialog boxes that look like the ones in this chapter, and others won't. The features in the Print dialog box are strictly a function of the program with which you're printing. Many programs choose to use the standard-issue Apple dialog boxes as shown in this chapter, but others don't. If a feature isn't explained in this chapter, chances are it's a feature specific to the application that you're using and should be explained in that program's documentation.

Your printer is chosen in the Chooser. Your page is set up in Page Setup. If, up to this point, you haven't been working with a document that you want to print, find one now and open it because it's time to . . .

1. Choose File→Print (Command-P).

One of the best things about the Mac is that Apple has published a set of guidelines that all Mac programs should use. Consistency among programs is one of the Mac's finest features. Notice how 99 percent of all programs have Open, Close, Save, Save As, Page Setup, Print, and Quit commands in their File menus and Undo, Cut, Copy, and Paste commands in their Edit menus. That's the kind of thing Macintosh Human Interface Guidelines recommends.

According to Apple's guidelines, the Print command should always appear in the File menu, which is good. Macintosh Human Interface Guidelines also says that the keyboard shortcut Command-P should be reserved for plain text (the way Command-B is often used for bold or Command-I for italic). This is bad.

Fortunately, software developers listened to Apple about the first item and ignored Apple about the second, so Command-P is almost always the shortcut for the Print command in the File menu.

Every so often, you come across a program that doesn't follow these conventions, but I'd say at least 90 percent of commercial Mac programs put the Print command in the File menu and use Command-P for its keyboard shortcut.

The point is that there is a slight chance that Step 1 won't work for you. If the Print command is on a different menu, if there is no Print command, or the keyboard shortcut is anything but Command-P, you'll have to wing it.

Then write the software company a brief note mentioning that they could make things easier on everyone by putting the Print command in the proper place and using the generally agreed-upon keyboard shortcut.

Anyway, the Print dialog box appears. It looks like Figure 7-13 when it first appears.
Chapter 7: Publish or Perish: The Fail-Safe Guide to Printing

The Print dialog box has a pop-up menu that offers seven options (Figure 7-14). I cover each of these options and their sub-options one at a time.

---

**The Print ➔ General dialog box**

The choices you make in the Print ➔ General dialog box are as follows:

- How many copies to print
- Which page numbers to print
- Automatic or manual feed paper
- Which printer to use for this print job
- Destination: printer or PostScript file
- Whether or not to save these settings permanently
Try pressing the Tab key and watching what happens. The active field jumps to each of the text fields in the dialog box in rotation — from Copies to From to To. Shift-Tab makes the active field jump backward. Try it; you'll like it.

**Copies**

How many copies do you want to print? The Print dialog box defaults to one copy in most applications, so you'll probably see a 1 in this field when the dialog box appears. Assuming that's the case, don't do anything if you only want to print one copy. If you want to print more than one copy of your document, select the 1 that appears in the Copies field and type in a new number (see Figure 7-15).

**Pages**

Which pages do you want to print? All of them? Or just some? This option is easy. If you want to print your entire document, click the All radio button. If you only want to print a specific page or range of pages, type them in the From and To text entry boxes.

For example, say you have a ten-page document. You print the whole thing and then notice a typo on page 2. You fix the typo and then print only page 2 by typing a 2 in both the From and To fields, as shown in Figure 7-16.

You can type any valid range of pages into the To and From fields.
Chapter 7: Publish or Perish: The Fail-Safe Guide to Printing

Paper Source
Your choices are Paper Cassette or Manual Feed. For your first page or all your pages.

If you plan to use the paper in your printer's paper tray, choose Cassette. If you plan to feed a single sheet, choose Manual Feed.

If you want the first page to come from one place and the remaining pages to come from another, click the appropriate radio button and make the appropriate choices from the pop-up menus.

It's that simple.

Destination: Printer or PostScript file
The pop-up menu in the dialog box's upper right corner lets you choose to print to your printer or create a PostScript file on disk instead. When you choose File, the Print button becomes a Save button. When you click the Save button, a standard Save dialog box appears.

Save Settings
This button saves the current settings and makes them the default for future print jobs. If everything is just as you like it, click this button and all future print jobs will use these settings.

The Print→Background Printing dialog box
Choosing Background Printing from the Print dialog box's pop-up menu lets you turn background printing on or off and set a print time if you so desire (Figure 7-17).

Figure 7-17: The Print dialog box's Background Printing options.
Print in foreground or background

Background printing has been around for a while. It's the thing that allows you to continue using your Macintosh while it's printing. Wonderful stuff.

It didn't used to be that way. In the bad old days, in the pre-System 6 era when there was no background printing, you sat and waited until the printing was done before you could use your Mac again.

Under Mac OS 7.6, background printing is turned on unless you specifically turn it off. You may notice your Mac feeling a little twitchy or jerky when a document is printing in the background. That's normal. Ignore it. After a while, you hardly notice it at all. And it's much better than the alternative — being unable to work until your print job is done.

Print Time

To set a printing time for your document (see Figure 7-17), click the radio button next to your desired print time priority. Here's what the priorities mean:

- The Normal option prints the document now. If other documents are in the print queue, it takes its place behind documents printed before it.
- The Urgent option prints the document now but places it ahead of any documents in the print queue.
- The Print at option lets you choose a specific time. When you click its radio button, you can adjust the time and date.
- The Put Document on Hold option lets you prepare a document for printing but not print it at this time.

The Print to Cover Page dialog box

Clicking the Before Document or After Document radio button (see Figure 7-18) adds a page at the beginning or end of your print job. The cover page contains your name, the program and document names, date and time, and printer name. In other words, a page that looks like pretty much like this:

User: Bob LeVitus
Application: ClarisWorks
Document: Brief Bio (WP)
Date: Tuesday, August 14, 1994
Time: 3:54:02 AM
Printer: HP LaserJet 4ML 1
I may have used this feature once in the past ten years. I suppose if you’re on a network sharing a printer, there might be a reason to waste trees by printing useless pages with hardly anything on them. But unless you must have a cover page, leave the None button selected and save a tree.

**The Print > Color Matching dialog box**

Here’s where you choose from Black and White, Color/Grayscale, or ColorSync Color Matching for your output. Use your best guess (Figure 7-19).
The Print→Layout dialog box

Choose the number of pages per printed sheet and whether or not you prefer a border (Figure 7-20).

![Print dialog box](image)

**Figure 7-20:** The Print dialog box's Layout options.

The Print→Error Handling dialog box

This dialog box provides options in case a PostScript error occurs; leave it alone unless you have a reason to change it.

The Print→Save As File dialog box

These options let you save your file as a PostScript file on disk. One pop-up menu lets you choose between raw PostScript and several flavors of Encapsulated PostScript. Another pop-up menu lets you include no fonts, all fonts, or only nonstandard fonts. (Nonstandard fonts are fonts other than the ones the Install Mac OS program installs.) Choose whichever setting is appropriate for the recipient of your document.

The safest bet is to include all fonts, just in case. The downside to this solution is that the PostScript file will be much larger than the original. For example, a SimpleText file used only 5K of disk space in its original form (that is, saved as a SimpleText document). When saved as a PostScript file with all fonts included, it grew more than tenfold, requiring a whopping 80K of disk space.

Several things can inflate the size of the PostScript file. Including all fonts adds a lot of K. High-resolution images add a lot of K. And long documents use a lot of K. It's common for color artwork or page layout documents printed to disk as PostScript files to be larger than a high-density floppy
disk. So if you plan to save a PostScript file to your hard disk and then copy it to a floppy disk, you may have to use a backup or compression utility to segment the file so that it can fit on several floppy disks.

I can't tell you much about the PostScript Level and Data Format choices; ask the recipients of your files what they prefer.

**One last thing . . .**

StyleWriter users, as well as users of other inkjet printers and/or non-PostScript printers, may see slightly different versions of the Print and Page Setup dialog boxes. The differences should be minor enough not to matter.

**The Hip New Thing: Desktop Printers**

Desktop printers are unique and a huge improvement over earlier printing schemes; the new architecture for printing makes the entire experience easier.

**What is a desktop printer, anyway?**

A desktop printer is an icon on your desktop that represents a printer that is connected to your computer. It's created automatically when you select a printer in the Chooser DA. To print a document, drag its icon onto a desktop printer (jump ahead to Figure 7-22).

In Figure 7-21, when I release the mouse, Great American Novel will print.
Technically, SimpleText, the application that created the Great American Novel document, launches, and its Print dialog box opens automatically. Click the Print button, or press Return or Enter, and the document prints and then SimpleText quits automatically.

What if SimpleText isn't available? If you have a translator that can open SimpleText documents, you'll see a dialog box where you can choose another application. If you don't have a compatible application or translator, you'll see an error message telling you that the document cannot be opened.

If you foresee that you may not have a compatible application for printing a document, read the section on QuickDraw GX PDD documents, which can be used as a work-around for any situation where you're not sure that the right application is available for your document.

**Using desktop printers**

Before I talk about using desktop printers, I need to tell you why you should use desktop printers. Three words: It saves steps. Rather than open a document, choose File: Print, and diddle around in the Print dialog box, you can drag that document onto a desktop printer, click Print (or press Enter or Return) then go out for a Jolt cola or whatever. In a word, it's easy. No muss, no fuss. Just drag and drop and click (or press) and in a few moments, paper starts popping out of your printer.

So basically, you use desktop printers by dragging documents onto them. As long as the application that created the document is available, they'll be printed after you click Print (or press Enter or Return) with no further ado.

Another handy use for desktop printers is to create desktop printers for special kinds of print jobs. For example, create one for envelopes that uses the landscape, manual feed, and black and white settings. Create another for grayscale portrait mode printing. And so on. Just drag your file onto the appropriate desktop printer (be sure and give them descriptive names) and you'll avoid all those messy adjustments in the Page Setup and Print dialog boxes.

But there's more to using desktop printers than just drag and drop. When you select a desktop printer (by single-clicking it), a new Printing menu appears in the menu bar, as shown in Figure 7-22. To view the print queue, open the desktop printer icon. (In case you forgot, you open an item by double-clicking its icon or by selecting its icon and choosing File: Open [Command-O].)
You'll notice a set of tape recorder-like icons in the Desktop Printer window. From left to right, these are stop the print queue, start the print queue, set the print time for the selected item or items, and delete the selected item from the queue. Also note that you can click any of the column heads — Document Name, Pages, Copies, or Print Time — to change the sorting order of the items in the list.

In Figure 7-22, there are three documents in the queue. Bad American Novel is currently printing. Clicking the stop button would suspend the printing of Bad American Novel until I choose to resume. Clicking the delete button would permanently remove Bad American Novel from the printing queue, and it would never print.

Figure 7-22: The Desktop Printer window and menu.

So what do the menu commands do?

- **Start Print Cue and Stop Print Queue** are like the Play and Pause buttons on your VCR. To pause the printing process and be able to resume later where you left off, choose Stop Print Queue. To resume, choose Start Print Queue.

- **Get Printer Info** brings up a dialog box that provides information about your printer (Figure 7-23) and its fonts (Figure 7-24).

- **Change Setup** lets you choose another PPD (PostScript Printer Description) file for this printer.
Part II: Making it Purr

Figure 7-23: Choose Printing ➤ Get Printer Info and then click the Update Info button to learn more than you ever wanted to know about your printer.

Figure 7-24: Choose Fonts from the pop-up menu and then click the Get Font List button to get a list of your printer's installed fonts.

- **Show Manual Feed Alert** lets you decide whether or not your Mac pauses to ask you to insert a sheet of manual feed paper before a manual feed print job. A check beside this item means it's turned on.

- **Set Default Printer** lets you decide, if you have more than one printer attached, which one will be the default printer (that is, the one that's selected when you choose Print) in the Print dialog box.
One last thing about these here desktop printers: You can choose your desktop printers from the pop-up menu in the Print dialog box! That’s right, the Print To pop-up menu in the Print dialog box gives you a choice of any printer that appears on your desktop. No more trips to the Chooser! Hooray! This feature makes it almost painless to have a dedicated label or envelope printer, something I’ve considered but rejected in the past as too much trouble with all those trips to the Chooser.

What is QuickDraw GX (And Should I Use It?)

Here’s Apple’s pitch: “QuickDraw GX is setting the stage for the next generation in graphics. QuickDraw GX greatly extends and expands the graphics capabilities of the Macintosh, creating a new standard for desktop graphics computing and reaffirming the place of Macintosh as the premier publishing platform in the personal computer industry. It offers significant improvements to all customers, from generalist users to publishing professionals.”

QuickDraw GX allegedly offers greater efficiency and power to Macintosh users by providing:

- Simplified printing and print management via a new, customizable print architecture and user interface
- The capability to create portable documents from any application that allows other users to print and view the document without having the original application or fonts
- Consistent color between scanners, displays, and printers via ColorSync color-management technology
- Powerful type and text capabilities that, in conjunction with updated or new applications, enable the display and printing of any typeface, in any of the world’s myriad script systems
- Tools for developers that will result in new applications that offer greater sophistication in graphics, type, and printing

Apple has set some noble goals, but it remains to be seen if they’re achieved. Enabling technologies depend on third-party developers to create programs to take advantage of them. And while QuickDraw GX offers many tantalizing possibilities to developers, such as superior type handling, more powerful graphics handling, and resolution-independent output to any device, not many developers are jumping on the bandwagon. Most developers say they plan to add QuickDraw GX support when and if the market demands them. In other words, it will be a while before you can buy many programs that take advantage of QuickDraw GX’s advanced features.
QuickDraw GX does provide some functionality right out of the box — in other words, without the addition of third-party products. These include

- Simplified and more powerful printing
- Better management of print jobs
- The ability to view and print documents without the original applications or fonts (kind of like Adobe Acrobat, No Hands Software’s Common Ground, and Farallon’s Replica)

**What you get when you install QuickDraw GX**

When you install QuickDraw GX (see Appendix A for complete instructions), the first thing you’ll notice is that your System software now uses approximately 500K more RAM than before.

Here’s what else happens: a folder called “Archived Type 1 Fonts” is created in your System folder; your Type 1 fonts are enabled for QuickDraw GX, and your original Type 1 fonts are moved to the Archived Type 1 Fonts folder; several extensions and control panels, including a version of Adobe Type Manager, are installed in your Extensions and Control Panels folders; and a bunch of utilities are installed in the Apple Extras: QuickDraw GX Extras folder.

After installing GX, you’ll notice that Page Setup and Print dialog boxes are slightly different, with enhanced capabilities (see Figures 7-25 and 7-26).
Another thing you'll notice is additional options in your Desktop Printer menu (shown in Figure 7-27).

Some non-Apple printers require a new printer driver in order to work correctly with QuickDraw GX. While one of the Apple QuickDraw GX printer drivers may work with your non-Apple printer, I strongly recommend that you read the About QuickDraw GX file in the Apple Extras: QuickDraw GX Extras folder. Not only does it contain important information about GX compatibility with applications you may own, it also includes complete contact information for many major printer manufacturers.
Another GX advantage: The print to disk PDD format

System 7.5 was the first version of the operating system to include a way to view and print documents without the original applications or fonts. QuickDraw GX includes a new type of document file format, known as a portable digital document (Apple calls it “print and view”; I call it “print to disk”). PDD documents can be opened, viewed, and printed on any other Macintosh with QuickDraw GX installed.

Even if the other Macintosh doesn’t have the same application or typefaces that were used to create the document, the file is a perfect representation of the document, complete with all the graphics and typographic information of the original document. It looks like the original document on-screen and will look like the original document when you print it. No new software is required; portable documents can be created using any of today’s applications.

You can create a desktop printer to create PDD documents if you like.

1. Open the Chooser desk accessory (Apple menu<>Chooser).
2. Click the PDD Maker GX icon on the left.
3. Click the Create button.

A PDD Maker GX icon appears on your desktop. To create a PDD document, drag any document onto the PDD Maker icon. A PDD version of the file will appear on the desktop.

You can select a default folder for all future PDD documents by selecting the PDD Maker GX icon and then choosing Printing<>PDD Maker Setup.

When you open a PDD document, you may see the translation dialog box asking if you want to open the file in SimpleText. You do.

SimpleText is the only PDD viewer I know of, so it’s a good idea to keep a copy on your hard disk even if you don’t use it for anything else. I don’t know of another program (yet) that can open QuickDraw GX PDD documents.

PDD documents, when viewed in SimpleText, look exactly the same as they would if you printed them out on a printer even if the Mac you’re viewing them on doesn’t have the fonts in the document or the application that created the document.

PDD documents aren’t the first attempt at paperless paper. There have been many other products — Adobe Acrobat, No Hands Software’s Common Ground, and Farallon’s Replica, to name a few. They all cost money, and PDD documents don’t.
So will the PDD format become ubiquitous? Will programs other than SimpleText support it? Will Read Me files start coming in PDD format? Stay tuned. We'll know soon, or, as they say in the computer business, RSN — real soon now.

**QuickDraw GX: The last word**

The benefits of QuickDraw GX look good on paper. But Apple's was touting this technology publicly for years before System 7.5, which was its first public appearance. And only a few developers have released products that take full advantage of QuickDraw GX. These facts worry me.

It may be worth using GX for the out-of-the-box features (remember, most programs have not yet been rewritten to take advantage of QuickDraw GX, and there's no telling how long that will take), but it uses an awful lot of memory (half a megabyte) for those features alone.

If you have a printer made by someone other than Apple and you have an older printer driver, one of the souped-up new Apple GX drivers (they have "GX" after their names) may work with your particular printer. The only way to find out is to try it. If a page prints and it looks okay, the driver probably works.

The bottom line is that I don't recommend you install GX unless you discover a feature it offers that you just can't live without, or if you use a program that offers enhanced functionality under QuickDraw GX.

**Font Mania**

To a computer user, *font* means typeface. Although professional typographers will scream, I'll go with that definition for now.

Each font looks different. There are tens of thousands of different fonts available for the Macintosh. You can buy single fonts and font collections anywhere you can buy software. There are also plenty of shareware and public domain fonts available from online services and user groups. Some people have thousands of them.

**How to install fonts**

This is a very short section. To install any font except a Type 1 font, drag it onto your System Folder. When you drag a font onto your System Folder, your Mac will ask if you want to place it in the Fonts folder. Click OK.
When you click OK, the deed is done and the font is installed. To remove a font, drag it out of the Fonts folder (which is in the System Folder). After a font is installed, it appears in the font menu of all your applications.

You can store fonts anywhere on your hard disk, but a font will only be available in an application if it's in the Fonts folder when you launch that application.

**Type formats**

There are four different kinds of fonts that you need to know about:

- **Bitmap** fonts, unlike other font formats, come in different sizes. You need a separate bitmap file for each size of the font that you want to display or print.

- **TrueType** fonts come with System 7.5. They are the Apple standard issue and are in wide use on Macs as well as on Windows machines. These fonts are scalable, which means that there is only a single outline for the font, and your Mac makes it bigger or smaller when you choose a bigger or smaller font size in a program.

- **Type 1** fonts, sometimes referred to as PostScript Type 1 fonts, are the standard for desktop publishing on the Mac. There are tens of thousands of Type 1 fonts available (and not nearly as many TrueType fonts exist).

  Type 1 fonts come in two pieces, a bitmap font suitcase and a second piece, called a printer font. Some Type 1 fonts come with two, three, or four printer fonts. They usually have related names.

- **TrueType GX** is the latest font format. The advantages of TrueType GX are primarily features for the professional typographer such as alternate and swash character sets, true drawn small caps, oldstyle figures, extensive kerning and tracking capabilities, style variations, and more. There are also some features for nonpros, such as automatic character substitution, automatic hanging punctuation, even rebus functions that automatically substitute pictures and symbols for words.

**Font advice in brief**

You don’t need to know a thing about font types. Really. When you get a font, just drag it (or all of its parts) onto your System Folder. If you're interested in all the ins and outs of the various kinds of fonts, see the Poguemeister’s *Macs For Dummies*. 
Chapter 8

File Sharing for the Rest of Us

In This Chapter

► What is file sharing
► Users and groups and guests
► Access and privileges
► The actual act of sharing
► Remotely sharing
► A few other things you ought to know

Computer networking has a well-deserved reputation for being complicated and nerve-wracking. The truth is, there’s nothing scary or complicated about sharing files, folders, and disks (and printers, for that matter) among computers. As long, of course, as the computers are Macintoshes.

If you have more than one computer, file sharing is a must. It’s fun, it’s easy, and it’s way better than SneakerNet*:

Your Macintosh includes everything you need to share files and printers. Everything, that is, except the printers and the cables. So here’s the deal: You supply the printers and cables, and I’ll supply the rest.

This chapter is kind of unusual. I don’t show you how to actually share a file until the next-to-the-last section. The first four sections provide an overview and tell you everything you need to know to share files successfully. Trust me, there’s a method to my madness. If you try to share files without doing all of the required prep work, the whole mess becomes confusing and complicated — kind of like networking a pair of PC clones.

So just follow along and don’t worry about why you’re not sharing yet. You’ll share soon.

*SneakerNet: Moving files from computer to computer on a floppy disk; i.e., walking from one computer to the other with floppy disk in hand.
What It Is

Macintosh file sharing lets you use files, folders, and disks from other Macs on the network as easily as if they were on your own local hard disk.

Devices connected directly to your computers, such as hard disks or CD-ROM drives, are local. Devices you access (share) over the network are remote.

File sharing also lets any computer on the network access (if you desire) your files, folders, and disks as easily as if they were on someone else’s local hard disk.

Finally, file sharing lets you link programs on your computer to programs on other computers. Why would you want to do that? You’ll find out.

For our purposes, a network is two or more Macs connected by LocalTalk-compatible cables.

This chapter assumes that you’re working on a small network, the kind typically found in a home or small business. There are also huge corporate networks, spaghetti-like mazes with thousands of computers and printers connected by cable, phone, infrared link, and ISDN, complete with confusing-sounding hardware such as routers and hubs and hublets and transceivers and netmodems. That kind of network is complicated, even if the computers are Macs. And, of course, this chapter isn’t about that subject.

If you’re part of a mega-monstrous corporate network and you have questions about your particular network, talk to the P.I.C. (person in charge, a.k.a., your network administrator).

If you’re trying to build one of these mega-networks, I regret to inform you that you’ll need a book a lot thicker than this one.

Portrait of a LocalTalk network

This chapter describes my office network. It consists of two Macintoshes and a network laser printer. (By the end of the chapter, that’s not all we’ll be sharing, if you know what I mean.)

This two-person network is merely an example. In real life, a network can, and often does, have dozens or hundreds of users. Regardless of whether your network has two nodes or two thousand, the principles and techniques in this chapter are the same.

My little network looks like what’s shown in Figure 8-1.
The black lines between the devices are cables; the gray box near each device is a connector. You need one connector for each device and enough cable to run between them. We happen to use the Apple LocalTalk Locking Connector Kits (part number M2068) and Apple Locking Cable Kits (M2066). LocalTalk connectors look like Figure 8-2.
We could have used PhoneNet connectors from Farallon instead of the Apple connectors. The big difference is that PhoneNet connectors use regular telephone cord from Radio Shack (or Target or anywhere) instead of expensive Apple Locking Cables. PhoneNet connectors are also less expensive than Apple LocalTalk connectors. Finally, PhoneNet connectors perform as well as (if not better than) Apple's LocalTalk connector. So why did I use the Apple cables? Because they were here. They came with my loaner computer. If I were paying my own money, I'd have gone with PhoneNet instead.

When discussions of networks take place, you're likely to hear the words AppleTalk, EtherTalk, TokenTalk, and/or LocalTalk bandied about with great regularity. The first three are protocols, a kind of language networks speak. The last, LocalTalk, is a collection of wires and connectors. I talk more about this aberration in a moment.

Of the three network protocols, AppleTalk is the slowest but it's also the cheapest — it's free. Your Mac includes all the software and ports that you need to set up an AppleTalk network; all you have to provide are LocalTalk-compatible cables and connectors (such as the Apple or Farallon products mentioned earlier).

LocalTalk is an aberration. It's not a protocol even though it sounds like one. In the old days, Apple referred to both the wires and the protocol as AppleTalk. Then one day a few years ago, Apple decreed that AppleTalk was a protocol and LocalTalk was the wires and connectors.

I suppose disassociating the protocol and the wires makes sense. LocalTalk sounds like a protocol (AppleTalk, EtherTalk, and TokenTalk), even though it's not. Anyway, LocalTalk refers to the physical connections that an AppleTalk network uses.

Got it? AppleTalk, EtherTalk, and TokenTalk are protocols, the languages that the network speaks. LocalTalk is a collection of physical parts — connectors (LocalTalk connectors), ports (like the Modem or Printer port), and cables (LocalTalk-compatible cables) — that hook the machines together.

**Getting Turned On**

The first thing to do is turn AppleTalk on. No network activity can take place until it is.

1. Open the Chooser (Apple menu ➤ Chooser).
2. Click the Active radio button to turn on AppleTalk (see Figure 8-3).
3. Close the Chooser by clicking its close box in the upper-left corner or by choosing File $\Rightarrow$ Close (Command-W).

4. Open the AppleTalk control panel (Apple menu $\Rightarrow$ Control Panels $\Rightarrow$ AppleTalk) and choose the appropriate connection from the pop-up menu (see Figure 8-4).

5. Close the AppleTalk control panel by clicking its close box in the upper-left corner or by choosing File $\Rightarrow$ Close (Command-W).

If you're using a LocalTalk network, that's all there is to getting started.

If your network has multiple zones, you'll also have to choose a zone in the Chooser at this time.

Zones are mini-networks connected together. Once a network gets to about 50 users, zones help network managers keep network traffic under control. If you have zones, there's probably somebody around whom you can ask if you need to know more.
Part II: Making It Purr

Setting Up Sharing Setup

Okay. AppleTalk is on and you're ready for a quick game of Name That Mac before you turn file sharing on.

Get a network identity


The Sharing Setup control panel opens (see Figure 8-5).

2. Type in all three pieces of information in the Network Identity section at the top: your name, a password, and a name for your Mac.

- Owner Name: This one should be self-explanatory — type your name.
- Owner Password: Your password can be any combination of up to eight letters and numbers. When you click anywhere outside the Password field, the letters or numbers in your password turn into bullets, as shown in Figure 8-5.
- Macintosh Name: Select a Macintosh name that's unique and memorable. Lisa's Macintosh is a better choice than Mac.

You can press the Tab key to move from field to field in the Sharing Setup control panel.
Turn file sharing and program linking on

File sharing and program linking each have a Stop/Start button. It's a toggle: If it's turned on, the button reads "Stop." If it's not turned on, the button reads "Start." Turn file sharing and program linking on if they're not on already by clicking each section's Start button.

The status of file sharing and program linking appears to the right of their buttons, as seen in Figure 8-5. Both are presently on. How do I know? The buttons read Stop and the status boxes to the right of the buttons say that they're on.

You want your Sharing Setup control panel to look like Figure 8-5, so if file sharing and program linking aren't on, click their Start buttons (click each one once). In other words, if your buttons say Start, click them. If they say Stop, don't click them.

Program linking lets certain Macintosh programs exchange information with other programs. Programs implement linking in various ways and not all programs can link. Check the documentation that came with your program to see if linking is supported and how to use it.

There is no penalty for turning program linking on, so I keep it running — even though I can't recall ever using it — in case I need it someday. You allow or disallow program linking for specific users in the Users & Groups control panel (more on that subject in a second).

If program linking is not on (in the Sharing Setup control panel), other users on your network cannot program link even if the Allow user to link check box is checked in the User Privileges window of the Users and Groups control panel.

Users and Groups and Guests (Oh My)

Macintosh file sharing is based on the concept of users and groups. Shared items — disks or folders — can be shared with no users, one user, or many users. Access to items on your local hard disk is entirely at your discretion. You may configure your Mac so that nobody but you can share its folders and disks, so that only one other person can share its folders and disks, or so that many people can share its folders and disks. People who share folders or disks are called users.
Users

Before you can go any further, you need to create User identities for the people on your network. You perform this little task with the Users & Groups control panel. I'm going to demonstrate on Lisa's Mac:

1. Open the Users & Groups control panel (Apple menu > Control Panels > Users & Groups).

A Users & Groups window appears, as shown in Figure 8-6. If you haven't previously created users or groups, two user icons appear in the window:

- **Owner**: Lets you configure sharing for the owner of your Mac, the person whose name appears in the Owner Name field of the Sharing Setup control panel. This icon should have your name on it.

- **<Guest>**: Allows you to configure a guest account for your Mac.

Notice how the File menu changes slightly when the Users & Groups window is the active window (see Figure 8-6). The New Folder command disappears and is replaced by two commands: New User (Command-N) and New Group.

2. Choose File > New User to create a New User. (The Users & Groups window must be the active window.)

3. Rename the new user something meaningful.

4. Open the icon with your name on it (the name that you typed in the Owner Name field of the Sharing Setup control panel).

5. Open the new user's icon.
You should see something similar to Figure 8-7. Use the following descriptions to determine how to configure the check boxes.

The check boxes set the privileges of each user. Because Lisa and I are partners and want full access to each others’ computers, we check all the choices.

- **Allow user to connect**: Lets the user connect to this Mac from a remote Mac (as long as he or she knows the proper password).
- **Allow user to change password**: Does what you expect. Lets that user choose his or her own password and change it at any time.
- **Allow user to see entire disk**: This choice is only available for the owner of the Mac. It means you can see every file on your hard disk if you connect from a remote machine.
- **Allow user to dial in**: This choice allows the user to connect via Apple Remote Access (covered later in this chapter).

When you create a new user, you have the option of assigning a password. If network security is unimportant to you (if only people you trust use the network), it’s okay to leave the password field blank.
When you close a User window, you'll be asked if you want to save any changes you've made. The answer is usually yes. After you click the Save button, that user is said to be registered. In a forthcoming section, I discuss the three categories of users on the network; registered users are one of the three.

**Groups**

Groups are a convenient way to deal with a bunch of users at once. In the preceding example, I set privileges for a single user, Lisa. Say I want to create a group so that I can assign the same privileges to everyone in our family: Lisa; our daughter Allison and son Jacob, who occasionally use our computers; and myself. First, I open the Users & Groups control panel (Apple menu→Control Panels→Users and Groups). Next, I create new user icons for Allison and Jacob. Then I create a new group (File→New Group) and name it The LeVitus Family. Finally, I drag the icons for Lisa, Bob, Jacob, and Allison onto the group icon. The group icon inverts as shown in Figure 8-8.

![Figure 8-8: Creating a group for the LeVitus family.](image)

If you open a group icon and look inside, you see icons representing the individual users. They appear in little picture frames (see Figure 8-9). Opening one of the little picture frame icons is the same as opening its user icon in the Users & Groups window. In other words, the little Bob LeVitus icon in the LeVitus Family group icon is like an alias of the bigger Bob LeVitus icon in the Users & Groups window.

Giving privileges to a group is the same as giving those same privileges to each individual member of the group.
Figure 8-9: Opening either Jacob LeVitus icon—the big one in the Users & Groups window or the smaller one in the LeVitus Family group window—brings up the user privileges window for Jacob (lower left).

Be our guest

Notice the icon in your Users & Groups window called <Guest>. The <Guest> icon represents any users who haven’t been assigned individual access privileges. Use this icon to allow or disallow guests to connect to your shared folders or disks. Even when guest access is on, no one but you has access to any of your folders or disks until you specifically share them. I talk about assigning access privileges to disks and folders in the next section.

Removing Users or Groups

To remove a user or group icon from the Users & Groups window, drag it to the Trash. It's that simple.
Access and Privileges
(Who Can Do What)

Now that file sharing is on and you've created users and/or groups for your networks, you're ready to begin deciding who can use what.

Sharing a folder or disk

To share a folder or disk with another user, take the following initial steps.

1. Select the folder or disk icon and choose File→Sharing.

The access privileges window for the selected item opens (see Figure 8-10).

![Image of Access Privileges window]

**Figure 8-10:**
The Access Privileges window for the Documents folder on Macintosh HD.
2. Click the Share this item and its contents check box.

   If you want to be the owner of the folder, leave the Owner pop-up menu alone (more about ownership in a sec).

3. Choose a user or group from the User/Group pop-up menu (the LeVitus Family group in Figure 8-10).

4. For the owner and each user or group, click in the appropriate See Folders, See Files, and Make Changes check boxes to assign access privileges for the folder or disk. Each of these access categories is explained in the following sections.

You may not see exactly what’s in Figures 8-9 and 8-10 on your screen. Well, of course you won’t. I’d be surprised if your network’s users were named LeVitus. But there are other differences you might see as well:

- If you’ve selected a folder inside another shared folder, the check box at the top will say “Same as enclosing folder” instead of “Share this item and its contents.”
- If you’ve selected a folder on another computer, the Owner and User/Group areas are text entry boxes, not pop-up menus.
- If you’ve selected a folder that someone else owns, all the check boxes and their labels are dimmed.

**Setting access privileges**

The check boxes to the right of the Owner and User/Group pop-up menus control the access. In other words, they control who can use what and how much they can use it.

There are three categories of users on the network:

- **The owner:** The owner of a folder or disk can change the access privileges to that folder at any time. The name in the Owner Name field of the Sharing Setup control panel is the default owner of shared folders and disks on that machine. Ownership may be given away (more on that in a moment).

- **A registered user or a group:** A registered user has access to shared disks and folders over the network as long as the user or group has been granted access by the folder or disk’s owner. A registered user is any user who has an icon in the Users & Groups window. A group is nothing more than a bunch of registered users.

- **Everyone:** This category is an easy way to set access privileges for everyone at once — the owner, registered users and groups, and guests.
Useful settings for access privileges

Here are some ways you can combine access privileges for a folder or disk:

Allow everyone access

Figure 8-11 shows the settings that allow access for everyone on a network.

Allow nobody but yourself access

Figure 8-12 shows the appropriate settings that allow only the owner access.

Allow one person or one group access

Figure 8-13 shows the settings that allow only one person or group (in addition to the owner) access.
Allow others to deposit files and folders without giving them access (a drop box)

Figure 8-14 shows the settings that allow users drop files or folders without being able to see or use the contents of the disk or folder.

<table>
<thead>
<tr>
<th>See Folders</th>
<th>See Files</th>
<th>Make Changes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Owner: ☑</td>
<td>☑</td>
<td>☑</td>
</tr>
<tr>
<td>User/Group: ☐</td>
<td>☐</td>
<td>☐</td>
</tr>
<tr>
<td>Everyone: ☐</td>
<td>☐</td>
<td>☑</td>
</tr>
</tbody>
</table>

After a file or folder is deposited in a drop folder, the dropper cannot retrieve it, as he or she doesn’t have access privileges to see the items in the drop folder.

Read-only bulletin boards

Figure 8-15 shows the settings that allow everyone to access the contents of the disk or folder without the ability to make changes.

<table>
<thead>
<tr>
<th>See Folders</th>
<th>See Files</th>
<th>Make Changes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Owner: ☐</td>
<td>☐</td>
<td>☑</td>
</tr>
<tr>
<td>User/Group: ☑</td>
<td>☑</td>
<td>☐</td>
</tr>
<tr>
<td>Everyone: ☑</td>
<td>☑</td>
<td>☐</td>
</tr>
</tbody>
</table>
The two other privileges

There are two more check boxes at the bottom of the Access Privileges window. The “Make all currently enclosed folders like this one” option does exactly what its name implies. This feature is a fast way to assign the same privileges to many subfolders at once.

The second check box, “Can’t be moved, renamed, or deleted,” protects the folder (this check box doesn’t appear in the Access Privileges window for disks) from being moved, renamed, or deleted by users whose privileges would otherwise allow them to move, delete, or rename that folder.

The Actual Act of Sharing

Okay, this is the moment you’ve all been waiting for. You’ve done everything leading up to the big moment: Sharing is set up; users & groups are registered; and access privileges are assigned.

If you’ve been following along, you know how to do all of the prep work and more. So make sure that you’ve shared at least one folder on your hard disk and you have full access privileges to it. Now go to another computer on the network and I’ll show you how to access that folder remotely.

Interestingly, file sharing doesn’t have to be turned on on the other machine. A Mac can access shared files over the network even with file sharing turned off. If file sharing is turned off, you can’t create users & groups or assign access privileges, but you can access a remote shared disk or folder if you have been granted enough access privileges by its owner, even with file sharing turned off on your Mac.

If file sharing is turned off, though, others aren’t able to access your disk or folders, even if you’ve shared them previously.

Connecting to a shared disk or folder

Continuing my little network example, I’m going to access the Documents folder on Lisa’s Mac, which Lisa owns but has granted me full access to (see Figure 8-16).
Chapter 8: File Sharing for the Rest of Us

On my computer, I choose Apple menu→Chooser and then click on the AppleShare icon.

**TECHNICAL STUFF**

AppleTalk, of course, is active on my machine. If it’s not, I won’t be able to use the network. While file sharing doesn’t have to be turned on for me to access a remote disk or folder, AppleTalk does.

I select Lisa’s Macintosh in the Chooser’s file server list and then click OK (see Figure 8-17).

---

**Figure 8-16:**
The Documents folder on Lisa’s HD. I have full privileges, so I’m able to access this folder from my (remote) computer.

**Figure 8-17:**
The Chooser on my Mac as I connect to Lisa’s Mac.
After I click OK, the Connect dialog box appears. Because I'm the owner of this Mac, my name appears in the Name field. I type in my password and then click OK (see Figure 8-18).

I now encounter another dialog box where I can select one or more items to use on my Mac. Because that single folder, Documents, is the only file on Lisa's Mac that has been shared with me, it's the only one that appears in Figure 8-19.

I click OK, and the Documents icon appears on my desktop, as shown in Figure 8-20.
The unique icon for the Documents folder clearly indicates that this is a shared folder accessed over the network. Those are, of course, wires coming out the bottom of the icon. This icon is what you see whenever a remote disk or folder is mounted on your desktop.

If there are multiple items in the item selection dialog box (refer to Figure 8-19) and you want to select more than one, click on the first item, hold down the Shift key, and click once on each item that you want to add to the selection. After you’ve selected all the items that you want to use, click the OK button, and they are all mounted on your desktop.

**Connecting automatically at startup**

If I wanted the Documents folder, which is on Lisa’s Macintosh, to appear automatically on my Mac’s desktop every time I turn it on, I would click the check box to the right of Documents in Figure 8-19.

I only expect to use this folder occasionally, so I won’t.

**Reopening the remote Documents folder quickly and easily**

Now that I’ve mounted the Documents folder on my desktop for the first time, I can make it easier to use in the future by creating an alias for it. Next time I want to use the Documents folder, I open the alias and the Connect dialog box appears. I type in my password and the folder appears (is mounted) on the desktop. No Chooser; no other dialog boxes; no muss and no fuss.

If you use remote folders often, mount each one on your desktop, create an alias for each one, and put the aliases in a folder called Remote Folders. Move the Remote Folders folder to your Apple Menu Items folder, and you’ll be able to mount these remote folders on your desktop almost instantly.
Getting on your own computer from a remote computer

Because Lisa is the owner of her computer, if she walks over to my computer, she can mount her entire hard disk on my desktop. She checked the Allow user to see entire disk check box in her owner window in the Users & Groups control panel. In other words, after she opened the icon representing herself in her Users & Groups control panel, she gave herself the privilege of seeing her entire disk remotely by checking the appropriate check box.

Anyway, if Lisa's at my Mac and wants to use her hard disk, she'd do almost the same things that I did to mount the Documents folder on my desktop, with one small difference.

Here's how she'd do it: First, she'd walk over to my Mac. Then she'd select Apple menu:Chooser. In the Chooser, she'd select her Macintosh from the list of servers. Now, here's where the procedure is a little different. When the password dialog box appears, it has the owner's name in it, as shown back in Figure 8-18. She would delete the "Bob" part and replace it with "Lisa." Then she would click OK. After typing her password, instead of seeing a list of folders, she'd see her hard disk in the next dialog box. (If Lisa had logged on as a guest or used my name and password, she'd have seen the Documents folder instead of her hard disk in the dialog box.)

Here's a great tip for Lisa. If she plans to use her hard disk while working at my Mac, there's an even easier way. Before she leaves her computer, she should make an alias of her hard disk and copy it to a floppy disk.

When she gets to my computer, all she has to do is insert that floppy and open the alias of her hard disk. The Connect dialog box will appear, and as long as she types the correct password, her hard disk will mount on my desktop. Neat.

This technique is often called office-on-a-disk. If you work in a largish office and find yourself trying to connect to your hard disk from someone else's computer, carry one of these office-on-a-disk floppies with you at all times.

Disconnecting from a shared folder or disk

When you finish using the shared disk or folder, close any open files or programs on the shared disk or folder and then disconnect using one of these three methods:

1. Select the shared disk or folder icon and choose File:Put Away (Command-Y).
Drag the shared disk or folder icon to the Trash.

If you're done working for the day, choose Special->Shut Down. Shutting down automatically disconnects you from shared disks or folders.

A Few Other Things You Ought to Know

That's the gist of it. But there are still a few aspects of file sharing you might want to know about. For example, how do I know who is using the network? How do I change my password? How can I unshare a folder or disk? And how do I connect to my shared computer remotely via modem?

The answers to these and other fascinating questions await you. Read on.

Monitoring file sharing

When file sharing is on, you can see what's going on out on the network with the File Sharing Monitor control panel (see Figure 8-21).

A list of shared folders and disks appears on the left, and a list of connected users appears on the right. To disconnect a user at any time, select his or her name in the list and then click the Disconnect button. A dialog box appears asking you how many minutes until the selected user is disconnected (see Figure 8-22).

Type in a number and click OK. When that amount of time has passed, the user will be disconnected. The shared disk or folder icon becomes grayed out on the user's desktop, indicating that the item is no longer available. The disconnected user will see a dialog box saying that he or she has been disconnected (see Figure 8-23).
Figure 8-22: Type in a number and click OK; the user will be disconnected after that many minutes have passed.

In the dialog box shown in Figure 8-22, if you set the number to zero and click OK, the user is disconnected immediately.

The File Sharing Activity monitor at the bottom of the screen tells you how much activity there is on the network. If yours is always up in the busy range, you may need to rethink your network strategy.

AppleShare file servers can ease network traffic — so can hardware add-ons like hubs and routers. If your network appears busy in the File Sharing Activity indicator most of the time, you should beef up your network with one or more of the aforementioned items.

Changing your password

You can change your password at any time.

1. Open the Sharing Setup control panel (Apple menu->Control Panels->Sharing Setup) from your own computer.
2. Delete your old password.
3. Type in a new password.

Your new password is now in effect.

Unsharing a folder or disk

To unshare a folder or disk you own, merely select it, choose File>Sharing, and uncheck the Share this item and its contents check box. The folder or disk becomes inaccessible over the network as soon as you close the Sharing window.

Logging on remotely via modem

Mac OS 7.6 is the first version of the Mac OS to offer Apple Remote Access at no extra charge. It used to be an “additional-cost add-on.” This change is a very good thing.

What remote access means is that if you’re at another location with a Mac and modem, and your Mac has a modem that’s been configured for remote access (I’ll show you how in a moment), you can access your home hard disk from the remote Mac!

Before you can use remote access, you have to install it (see Appendix A). Remote access is not automatically installed because many users never need its functionality.

Preparing your Mac for remote access

Preparing your Mac so that you can log on to it remotely is simple. Because remote access uses the same Users & Groups and Sharing Setup as network file sharing, if you’ve followed along so far this chapter, you’re almost ready for remote access. There’s just one last thing to do:

1. Open the Remote Access Setup control panel (shown in Figure 8-24).
2. Choose your modem from the pop-up list.
3. Turn your modem speaker on or off by clicking the appropriate radio button.
4. Select your dialing method by clicking the appropriate radio button.
5. Leave the Ignore dial tone and Use MNP 10 check boxes unchecked (if you can’t make things work, try checking one or both later).

That’s it! Your Mac is now ready for registered users to access it remotely.

**Getting files from your Mac while you’re on the road**

When you installed Apple Remote Access, an Remote Access Client folder was created on your hard disk. Inside it are two items: Read Me and Remote Access Client. I strongly recommend you read the one called Read Me. Go on, do it now. There may be something important in there that isn’t in here.

Okay, now take the one called Remote Access Client with you when you travel. It only weighs about 300K so it easily fits on a floppy disk.

Upon arriving in your remote location, copy Remote Access Client to the hard disk of the Mac you’re using to connect to your home Mac. Launch Remote Access Client. Fill in the fields for your name, password, and the phone number of the modem connected to your home Mac (see Figure 8-25).

![Figure 8-25: Fill in the blanks and then press Connect to mount your home computer’s hard disk on this remote computer’s desktop.](image)

Save this connection if you expect to use it again by choosing File ➤ Save (Command-S).
Chapter 8: File Sharing for the Rest of Us

If you click the "Save my password" option, you don't have to type your password when you connect. On the other hand, people who get their hands on this document can connect to your home computer and wreak havoc with your files. So don't check it unless you're certain that you won't misplace the disk with the Remote Access Client document on it.

That's it. Almost. There are two other things you need know about before you're a Ph.D. in remote access: the Options dialog box and the DialAssist control panel.

The Options dialog box, shown in Figure 8-26, lets you specify whether and when to redial, lets you choose an alternate phone number, and reminds you of your connection if you forget.

DialAssist is a control panel that helps you remember and dial complicated phone number sequences. If you click the check box Use DialAssist and then click the Setup button, the DialAssist control panel will open (see Figure 8-27).
If dialing home involves anything more complicated than dialing a 9 before your phone number — a country code, long distance access number, credit card number, and so on — check out DialAssist.

Tip

Notice that DialAssist has Balloon Help, so if you need to know more about how a feature works, turn it on. A nice touch.

After you’ve used DialAssist’s pop-up menus to create your custom dialing string, you can preview the results in the Remote Access Client window (see Figure 8-28).

There. That's it! You know how to share files with the best of them, no matter where you are.
In This Chapter

- Running out of RAM
- The Memory control panel
- The disk cache
- Virtual memory
- The RAM disk
- Memory-related troubleshooting

The Mac lets the user — that's you — get along fine without knowing much about memory. Many users go through their entire lives with a Macintosh without knowing anything more than "it has 16 megs."

On the other hand, a working knowledge of the way your Mac's memory works can be invaluable in getting the most out of your Mac.

In other words, you don't have to know this stuff, but it's likely to come in handy someday. It's not particularly complicated nor particularly technical, so it wouldn't hurt to just jump right in.

Baby, Baby, Where Did Our RAM Go?

RAM is the TLA (three-letter acronym) for Random Access Memory. RAM is the special kind of memory in which your System software and applications live while your Mac uses them. System software (including most extensions and control panels) loads into RAM on startup; applications load into RAM when you open them.
Your Mac probably came with 4, 5, 8, or 16 megabytes of RAM. Depending on what you want to do, that amount may or may not be enough.

If you never plan to do anything more than use a single program that doesn't require a massive amount of RAM (that is, not Photoshop or PageMaker, both of which require a great deal of RAM) and never plan to use two or more programs at once, an 8MB Mac may let you squeak by.

If you have 8 or less megabytes of RAM, read this chapter and Chapter 14 very, very carefully. The less RAM you have, the more important it is to manage it wisely.

If you want to keep a word processor, a calendar, a phone book, and a graphics program all open at the same time, an 8MB Mac may not have enough RAM for you. I actually consider 16MB the functional minimum for using Mac OS 7.6 effectively.

The simple rule is that the more stuff you want to run at once, the more RAM you're gonna need. If you have one or more programs that require a lot of RAM, you'll need enough RAM to run them and your System software simultaneously. You'll also need even more RAM if you want to keep several programs open at the same time.

---

**Go ahead: Add more RAM**

You can add more RAM to most Mac models easily and relatively inexpensively (between $5 and $10 per megabyte today, but prices change quickly, so check around before you buy).

If you are so inclined, you can install RAM yourself with a minimum of technical skills. Memory comes mounted on cute little printed circuit boards called SIMMs (fancy acronym for single inline memory module) or DIMMs (fancy acronym for dual inline memory module) that snap into little printed circuit board-holders inside your Mac. Installing RAM yourself will, of course, void your warranty. (On the other hand, if your Mac is more than 366 days old, it doesn't have a warranty.)

If you are technologically challenged and never want to lift the lid off your Mac (I don't blame you), you can have RAM installed for you at any Apple dealer. But this service costs significantly more than doing it yourself.

I'm a klutz. I don't repair things around the house. But I've managed to install RAM upgrades in several Macs without incident. It's not terribly difficult, and it doesn't require soldering or other specialized skills. If you can turn a screwdriver, you can probably handle the task.

If you do decide to go the do-it-yourself route, I recommend TechWorks (800-234-5670 or 512-794-8533). Their prices are fair, their support and manuals are superlative, and they offer a lifetime guarantee on every RAM chip they sell.
Essentially, you should remember that three things use RAM:

- The System and Finder
- Extensions and control panels
- Applications

The first, the System and Finder, you have no control over. That dynamic duo is going to chew up about 1,800K of RAM no matter what you do.

You do, however, have control over extensions, control panels, and applications, and you use this control to make the most of the memory you have.

RAM is used primarily for three things. There's other stuff — PRAM (parameter RAM), debuggers, rdev and scri files — that could be rattling around in there, using up small amounts of your RAM. But their impact on the amount of RAM that you have to work with is negligible, so they're not important to this discussion. Besides, most people will never need to know what a scri file is.

Sigh. Okay, just this once. A scri file is a special kind of extension that automatically loads before all other extensions. The old System Update 3.0 that you should have been using with System 7.1 (but don't need with Mac OS 7.6) is a scri file. So is Apple's WorldScript Power Adapter.

**System software memory theory: Where some of the RAM goes**

To observe how RAM is being used on your Mac, look at the About This Computer window (Apple menu ▸ About This Computer).

Figure 9-1 shows a Mac running Mac OS 7.6. No extensions or control panels are loaded. The System software uses 3,503K of RAM.

How do you get Mac OS 7.6 alone to load, without loading any extensions or control panels? Easy. Hold down the Shift key during startup until you see the "Extensions Off" message on the Welcome to Macintosh screen. Memorize this tip; it's a good thing to know. If you run into memory problems (that is, you see error messages with the word memory in them), starting up with your extensions off allows you to run your Mac so that you can pinpoint problems related to any of your control panels or extensions.
Figure 9-1:
Mac OS 7.6 alone, with no extensions or control panels loaded, uses 3,503K of RAM on this Mac.

On this 32MB Mac, after the System software eats up its share of RAM, 29,144K of RAM is available for extensions, control panels, and applications.

Your mileage will vary and you'll probably see a slightly different number on your Mac. Don't worry about it. The System software for each Mac model requires slightly different amounts of RAM.

When I restart my Mac the old-fashioned way, without holding the Shift key down, the extensions and control panels load as usual, and the System software expands to take up a whopping 9,612K (see Figure 9-2). See what I mean about 16MB being the functional minimum?

Figure 9-2:
Mac OS 7.6, with its full complement of extensions and control panels loaded at startup, uses 9,612K of RAM.

This situation often causes confusion. When you look at the bar for System software in the About This Computer window, it displays not only the RAM used by your System and Finder but also the RAM used by your extensions and control panels that load at startup.
If you're good at math, you can figure out that loading the full complement of Mac OS 7.6 extensions and control panels costs 6,109K of RAM.

9,612K – 3,503K = 6,109K.

On my 32-meg Mac, I'm left with almost 23 megabytes available for applications.

You can free up a bit more RAM for applications by turning off extensions and control panels in the Extensions Manager control panel. Read Chapter 14 for details on exactly how much RAM each extension and control panel uses and what happens if you turn them off.

**Application memory theory: Where the rest of the RAM goes**

If you haven’t read the first part of Chapter 4, which explains the About This Computer item in the Apple menu and provides you with your first glimpse of memory management, you should do so now. There's a very important technique there — how to adjust Application memory — and I'm not going to waste space repeating it.

Sigh. I guess I have to repeat at least part of it. This *is*, after all, a chapter about memory management.

When you launch an application, the application grabs a chunk of memory (RAM). You can see how big a chunk of RAM it grabs by going back to the Finder after you launch it and choosing Apple menu > About This Computer (see Figure 9-3).
The beginning of Chapter 4 has a lengthy discourse on changing the amount of RAM a program grabs when you launch it and why you may want to do so. If you weren’t paying attention, you diddle a program’s RAM usage by selecting its icon and either choosing File→Get Info or using the keyboard shortcut, Command-I (see Figure 9-4).

Here’s a brief review of what these memory sizes mean:

- The Suggested size is the size the manufacturer of the program recommends. In most cases, the Preferred size should be set to at least this amount. You can’t change the Suggested size.
- The Minimum size is the smallest amount of memory the program needs to run. It is usually (but not always) slightly smaller than the Suggested size.
- The Preferred size is the amount of memory the application requests (and will get) as long as there is that much memory available when the application is launched. Your Mac doesn’t let you set the Preferred size lower than the Minimum Size.

When you try to open an application, if the available RAM (Largest Unused Block in the About This Computer window) is less than the Suggested size but more than the Minimum size, the program still launches. But its performance may be degraded, or you may encounter memory-related errors.
In summation

Make sure that you're clear on this theory stuff before you move on to execution. RAM is used by three things: System software, extensions and control panels, and applications.

You can make more RAM available for your programs by holding down the Shift key at startup, which disables all extensions and control panels.

You can fiddle with the amount of RAM that a program uses in its Get Info box.

Everything else you need to know about memory involves the Memory control panel, which you're about to meet.

The Shift key at startup technique is wonderful, but it's absolutely absolute. Either your control panels and extensions are on, or they're off. The Shift key provides no way to turn some off and leave others on. When they're all off, you lose the ability to share files, to use desktop printers, and much more.

That's why Apple provides the Extensions Manager control panel, and it's received a total face-lift in Mac OS 7.6. You use it to selectively disable and enable control panels and extensions. As I keep saying, this dandy tool is discussed in Chapter 14, a chapter designed to help you figure out which extensions and control panels you truly need. You find out how much precious RAM and disk space each control panel and extension uses, and you also discover how to get rid of the ones that you don't want (both temporarily and permanently).

In other words, Chapter 14 may be the most useful chapter in this book.

Memories Are Made of This: The Memory Control Panel

You configure memory-related functions for your Mac in the Memory control panel, which is in the Control Panels folder. You can open the Memory control panel by choosing Apple menu → Control Panels → Memory.

Here's a look at the Memory control panel's components, which are for the most part unrelated.
Cashing in with the disk cache

The disk cache (pronounced cash) is a portion of RAM set aside to hold frequently used instructions. In theory, if you set a reasonable-size cache, say 5 percent of your total RAM, your Mac should feel like it's running faster. In reality, many people can't tell the difference.

The first important thing to know is that the size of the disk cache is added on to the RAM used by the System software. Therefore, memory assigned to the disk cache is not available for programs to use. In Figure 9-2, the System software is using 9,612K of RAM. The disk cache is set to 512K.

If I increase the size of the disk cache to 1,536K (see Figure 9-5) and restart the Mac, the System software balloons to 10,702K (see Figure 9-6).

![Figure 9-5: The disk cache is increased to 1,536K; see the results below.](image)

![Figure 9-6: The System software uses 1,090K more RAM than before (see Figure 9-2).](image)
Those of you who caught the math thing a few pages ago have certainly noticed that the numbers here don't add up correctly. 10,702 - 9612 = 1,090, not 1,024 (or 1,536 - 512).

The vagaries of RAM usage are well known. The amount of RAM that System software uses changes from hour to hour, seemingly at random. I opened About This Computer three times today and got three different numbers, ranging from a low of 9,602 to a high of 9,752.

In other words, RAM usage is not a precise science. Take all numbers in this chapter with at least one grain of salt.

**How to set your disk cache**

If RAM usage is an imprecise science, telling you how to set your disk cache is imprecise science fiction. Bearing that in mind, here's some excellent advice on figuring out the best setting for you.

As I said, some people don’t notice the speed improvement provided by a larger disk cache. So first you must determine whether you can tell the difference in speed by cranking the disk cache size way up. Here's how to crank up the disk cache size:

1. Choose Apple menu>Control Panels>Memory to open the Memory control panel.

2. Click the up-arrow key labeled Cache Size repeatedly until it won't increase any further (see Figure 9-7).
3. Click the down-arrow key two or three times (so you leave enough RAM available to open an application).

4. Restart your Mac.

You now have a huge disk cache, larger than you would actually use in real life. But I want you to exaggerate its effects for this experiment.

When your Mac gets back to the Finder, proceed to Step 5.

5. Open the System Folder, noticing how long it takes for the window to appear completely.

6. Close and then reopen the System Folder window, again noticing how long it takes to appear on-screen.

The difference in speed (the second time the System Folder should have opened noticeably faster) is a result of the increased size of the disk cache.

You should also notice a speed improvement when you scroll through documents. Launch your favorite application and scroll around a document for a while.

If you don’t notice any speed improvement in the Finder or in your favorite application, return to the Memory control panel, set the Cache Size to its lowest setting (32K), and be done with it.

If you notice (and like) the speed improvement, you still have a little more work to do. As you may remember, memory assigned to the disk cache is not available for applications. So you want to set the disk cache to the lowest possible number that still feels fast to you.

To lower the disk cache, repeat the preceding steps, lowering the disk cache one click each time. Restart after each change. Then close and reopen the System Folder two times and note the difference in speed the second time. When you begin to notice sluggishness when closing and opening or when scrolling through documents, then you’ve discovered your threshold. Return to the Memory control panel, increase the Cache Size one click, and be done with it.

The old rule of thumb about the disk cache is to allow 32K per megabyte of RAM. I’ve always thought that this suggestion was bunk, as many people can’t tell the difference between a 32K disk cache and a 1,024K disk cache. And why should they waste a megabyte of perfectly good RAM? So I’ve always encouraged people to try the experiment I’ve just described and see for themselves.

That said, I have to admit that the disk cache in Mac OS 7.6 feels a bit zippiest than earlier disk caches. I notice a definite speedup with the disk cache set to 512K. Under System 7.1 and earlier versions, the speedup didn’t feel as great.
For what it's worth, I'm leaving mine set to 512K for now and may even bump it up to 1,024K. That leaves me plenty of RAM for applications, so I'm willing to trade a few hundred K of RAM for the speedup. Once again, your mileage may vary.

**It's not real, it's virtual (memory)**

Virtual memory lets you use spare hard disk space in place of RAM. If it sounds too good to be true, it is. For the most part, virtual memory is a loser.

The truth is that you should have enough real RAM to use your favorite application or applications (if you like to keep more than one program running) comfortably. You should have enough real RAM to open all the documents and programs you need.

If you can't afford that much RAM, pop for a copy of Connectix RAM Doubler 2, which does what virtual memory does but does it better and faster for about $50 (see the "RAM Doubler 2" sidebar). If you can't manage to find $50, you're stuck with virtual memory.

What's wrong with virtual memory? The only thing it has going for it is that it's free. Though the Mac OS 7.6 incarnation is better than earlier versions, I still prefer RAM Doubler 2. Why?

- Virtual memory is slow. If you don't have enough real RAM to open a program, you can open the program using virtual memory, but the program works more slowly. Sometimes MUCH more slowly. The effect if you use RAM Doubler 2 is less noticeable.

- Virtual memory puts a big invisible file on your hard disk. Very big. The size of the invisible file is equal to the amount of virtual memory in use plus all the installed RAM! So if you have a 32MB Mac and want to make it think it has 64MB (see Figures 9-8 and 9-9) using virtual memory, you'll have an invisible 64MB file on your hard disk taking up space (see Figure 9-10).

Of course, I had to know that the file was named VM Storage in order to use Find File to show it, but that's neither here nor there. Notice that you don't see VM Storage in the Macintosh HD window in Figure 9-10. That's because the VM Storage file is invisible. Insidious, isn't it?

RAM Doubler 2 doesn't use any permanent space on your hard disk to do its magic.
Many games don’t work if virtual memory is on. Some (but not all) will work with RAM Doubler 2.
Chapter 9: Memory and Other Seemingly Complicated Arcana

**RAM Doubler 2**

If you have to have more RAM but can't afford the chips, then consider RAM Doubler 2, an alternative virtual memory program from Connectix Corporation. It installs with a single click and magically transforms your 8MB Mac into a 16MB Mac (or your 32MB Mac into a 64MB Mac, or whatever). Its speed is much better than Apple's virtual memory. It doesn't require a permanent, invisible file on your hard disk, and it works with almost everything virtual memory works with. It's kind of like virtual memory without any of the side effects.

I'd be remiss if I didn't mention that if any single program has its Preferred size set higher than the amount of free RAM installed in your Mac, performance will more than likely be degraded. Even so, in the same situation, the degradation from Apple's virtual memory will likely be worse. While RAM Doubler 2 is a miracle, even miracles have limitations.

If you like virtual memory, you'll like RAM Doubler 2 even better. Even if you hate virtual memory, you may like RAM Doubler 2. If you need more RAM but can't afford it right now, give RAM Doubler 2 a try. It's the next best thing to real RAM.

Okay. So if after all of my advice you still want to use virtual memory, there are three more things you need to know. First, after you make changes in the Memory control panel, you have to restart your Mac for the changes to take effect. Second, virtual memory is more effective when you are using several small programs simultaneously than when you are using one large program. Finally, turning virtual memory on, even if you only set it to add 1 megabyte of virtual memory, allows many applications to run using less RAM on Macs with PowerPC processors.

Go back and take another look at Figure 9-4. See that little note at the bottom that says "Memory requirements will decrease by 1,673 if virtual memory is turned on in the Memory control panel"? It'll disappear (and ClarisWorks will require about 1.5MB less RAM to run) if you turn on virtual memory. This tip alone makes it worth turning on virtual memory even if you only set it to 1MB.

For what it's worth, programs also require less RAM under RAM Doubler 2.

---

**Faster than a speeding bullet:**
**It's a RAM disk**

A RAM disk enables you to use part of your installed RAM as a temporary storage device, a virtual disk made of silicon. Using a RAM disk is much, much faster than any other kind of disk and, if you're using a battery-powered Mac, much more energy efficient.
Many Macintoshes include a RAM disk feature. To find out if yours is one of them, open your Memory control panel. If you see RAM disk controls like those shown in Figure 9-11, your Mac has the RAM disk feature.

![Figure 9-11: If your Mac supports the RAM disk feature, you'll see these controls in your Memory control panel.](image)

Memory assigned to a RAM disk is not available for opening programs or loading extensions and control panels. So unless you have 8 or more megabytes of RAM, a RAM disk is probably not practical. Even with 16MB, it probably won't be useful.

RAM disks are wickedly fast while you use them, but they are temporary. When you shut down your Mac (or if the power is interrupted to a non-PowerBook Mac), the contents of a RAM disk are wiped out. In addition, certain kinds of System crashes can erase a RAM disk's contents. The contents of a RAM disk do, however, survive a restart.

Even so, you should never store your only copy of a file on a RAM disk. If you save files on a RAM disk, make sure to copy them to your hard disk every so often — just in case.

**Creating a RAM disk**

To create a RAM disk, click the On button in the RAM Disk portion of the Memory control panel (refer to Figure 9-11) and drag the slider to choose the percentage of the available memory that you want to use for your RAM disk. Close the control panel and restart your Mac. The new RAM disk appears on your desktop (see Figure 9-12).
Erasing a RAM disk
There are three ways to erase the contents of a RAM disk. One, of course, is to shut down your Mac. You'll see a warning that the contents of the RAM disk will be lost; when you click OK, it's gone.

You can also erase a RAM disk by doing the following:

- Selecting the RAM disk's icon and choosing Special→Erase Disk.
- Dragging everything on the RAM disk to the Trash and then choosing Special→Empty Trash.

Resizing or removing a RAM disk
To resize a RAM disk, use the slider in the Memory control panel to choose a new size; then restart your Mac.

The contents of a RAM disk are lost when you resize it, so copy anything important to your hard disk before you resize.

To remove a RAM disk, click the Off button in the Memory control panel and then restart your Mac. The RAM disk must be empty or the Off button is disabled.

Good things to try with a RAM disk
Some applications run a lot faster when they're on a RAM disk. Copy your favorite program to a RAM disk and give it a try.

Your Mac runs screamingly fast if your System Folder is on a RAM disk. You need at least 16 megs of RAM (and probably more) to create a RAM disk big enough for your System Folder.
It is possible to use a RAM disk containing just a System and a Finder as your startup disk. It's not very useful, but it is possible. Here's how you do it:

1. Create a RAM disk large enough to hold your System and Finder (about 6MB).
2. Create a new folder on the RAM disk. Name it System Folder.
3. Copy the System file and the Finder file from the System Folder on your hard disk to the newly created System Folder on the RAM disk.
4. Open the Startup Disk control panel and click your RAM disk's icon to designate it as the startup disk.
5. Restart your Mac.

Your Mac boots up from the RAM disk instead of your hard disk.

While this particular execution won't do much for you, if you have enough RAM to create a 9- or 10-megabyte RAM disk, you can add a few extensions and control panels to the System Folder on the RAM disk and have a relatively useful, blindingly fast startup disk.

Another thing to try is moving your favorite application to the RAM disk and running it from there. Many applications — including Web browsers — run significantly faster from a RAM disk.

And there you have it. More than you really need to know about RAM and your Macintosh!
Part III
U 2 Can B A Guru

The 5th Wave
By Rich Tennant

IF BOB DYLAN HAD PURSUED A CAREER IN COMPUTERS.

"PUT HIM IN FRONT OF A TERMINAL AND HE'S A GENIUS, BUT OTHERWISE THE GUY IS SUCH A BROODING, GLOOMY GUS HE'LL NEVER BREAK INTO MANAGEMENT."
In this part...

I discuss thousands of tips, tricks, and techniques that make using your Mac easier and more fulfilling. More succinctly, this part is about how things work and how you can make them work better.

After two chapters full of tips and tricks, I'll crawl through the Control Panels folder and discuss each and every control panel and its recommended settings.

Moving right along, I next delve into automating your Mac using AppleScript, complete with some easy-to-follow info that's guaranteed to get you scripting with the best of them.

Next, in what may be the most useful chapter in the book, I look at every single file installed with Mac OS 7.6. I'll tell you who needs it, how much RAM it uses, how much disk space it uses, and most important of all, how to get rid of it safely if you don't need it.

And finally, I introduce you to the World of the Wide Web, with an introduction to your Internet tools, including that new pup on the block, CyberDog.
Chapter 10

Sure-Fire, Easy-to-Use, No (Or Low)-Cost Timesaving Tips

In This Chapter
► Flying fingers
► In living color — or not
► Getting your Views under control

Some of what you're about to read has been mentioned somewhere in the first nine chapters already. But this chapter isn't a blatant attempt at upping my page count. No siree. This chapter is here because, by now, you lust for speed.

Now that you understand the basics, if you're normal, you wish your Mac worked faster. (You're not alone — all users wish that their Macs worked faster at some time, even those with Power Mac 9500s or PowerTower Pros.) So in this chapter, I cover things that can make your Mac at least seem faster, most of which won't cost you a red cent.

Let Your Fingers Do the Flying

One way to make your Mac faster is to make your fingers faster. Here are a couple of ways:

Use those keyboard shortcuts

I know I've told you this tip already, but the less often you remove your hand from the keyboard to fiddle with the mouse, the less time you'll waste. Learn to use those keyboard shortcuts. Memorize them. Make your fingers memorize them. The more keyboard shortcuts you use, the faster you'll get done with what you are doing. Trust me.
Learn to type better

Learning to type faster may be the very best way I know to make your Mac faster. As a Macintosh consultant and trainer, I get to spend a lot of time with beginners. And almost all of them are lousy typists. When they complain that their computer is too slow, I ask them to perform a task for me. Then I perform that same task for them. I can type about 50 words per minute, and I type without looking at the keyboard. I always accomplish the task in less time; if the task involves a lot of typing, I accomplish it in much less time.

Because you're there and I'm here, I can't provide you with as dramatic an illustration. But trust me, typing fast saves you time at your Mac — a lot. And this speed gain isn't just in word processors and spreadsheets. Once you're a decent touch-typist, you'll fly when you use those nifty keyboard shortcuts that I mention so frequently.

There are several fine typing programs out there, and any one of them will do just fine. Most cost under $30 by mail order and are worth every penny. I happen to like a program called Mavis Beacon Teaches Typing (from The Software Toolworks) for a number of reasons. First, it allows you to choose whether there should be one space or two after a period. The correct answer, of course, is one — at least if you're typing on a Mac.

What? You learned to put two spaces after a period in your high school typing class? Well, you learned wrong, at least if you're going to use a computer. The double-space after punctuation is a throwback to the days when typewriters were king and we had no personal computers or printers. Because typewritten text is monospaced (that is, each letter is the exact same width), a double-space after a punctuation mark looked better than a single space.

With the advent of the computer and laser printer, most fonts are no longer monospaced (Courier and Monaco are monospaced). Today, on most personal computers, most fonts are spaced proportionally. In other words, some characters are wider than others. The width of a space in a proportionally spaced font is just the right size to use a single space after punctuation. If you use a double-space, it looks unattractive.

Mavis Beacon Teaches Typing (or any of the typing programs) can teach you to type significantly faster in just two weeks. If you give it about 30 minutes per day of your undivided attention, you will learn to type quickly without looking down. Mavis Beacon includes timed speed and accuracy drills (see Figure 10-1) as well as a typing game (see Figure 10-2) where you try to type fast enough to keep your computerized opponent's car in the rearview mirror and not ahead of you. The program keeps track of your drills and lets you see graphs and charts of your progress at any time.
Chapter 10: Sure-Fire, Easy-to-Use, No (Or Low)-Cost Timesaving Tips

The important thing isn't how the typing program works or which program you buy. You simply need to commit the time. Just remember: The easiest way to speed up your Mac is to speed up your fingers.

End of sermon.
The Mac is not a typewriter

The Macintosh is more of a typesetting machine than a typewriter. So when you use a Macintosh, you should follow the rules of good typography, not the rules of good typewriting. If you want your documents to look truly professional, in addition to putting single spaces after punctuation, you need to understand the difference between inch and foot marks and typographer’s quotation marks. You also need to know when and how to use a hyphen (-), an en dash (--), and an em dash (—).

In other words, the Mac is not a typewriter. If you want to make your documents look more elegant and professional, get ahold of Robin Williams’s excellent book *The Mac Is Not a Typewriter*. It’s wonderful, easy to understand, and covers all the stuff I just mentioned (and much more) in great detail.

Why Living Color May Not Be So Great

Chances are good that your Macintosh has a color monitor (most do). And chances are also good that you keep that monitor set to the maximum number of colors it supports. That may be a mistake.

Monitor settings

Your screen consists of thousands of square dots (over 300,000 for the average Mac monitor) known as pixels (an acronym of sorts for picture element). Most 13” or 14” monitors display a picture that is 640 pixels wide by 480 pixels high — over 300,000 pixels on the screen for your Mac to deal with. Larger monitors have more pixels; smaller monitors have fewer.

The number of colors that you choose to display on your monitor has a significant impact on how quickly your screen updates. The more choices your Mac has to make about the color of each pixel, the longer it takes for the screen to update completely so that you can continue your work.

When I say *update*, I’m talking about the amount of time it takes for your screen to paint all the pixels their proper color or colors after opening or closing an icon or document. For example, when you open a color picture in a graphics application or open a window in the Finder, the screen updates until every element is drawn on-screen in its proper place and in its proper color.
Chapter 10: Sure-Fire, Easy-to-Use, No (Or Low)-Cost Timesaving Tips

Some people call screen updating screen *redrawing*. It means the same thing: the time you spend waiting for Finder windows to draw themselves completely, or the time it takes for documents to appear completely in their windows on-screen. When your screen is updating, you have no choice but to wait for it.

(You might sometimes hear this scourge referred to as *refreshing*, but that term is incorrect in this context. *Screen refresh rate* is a technical term, measured in hertz [Hz], that has to do with the video hardware. Even so, people use the three words — update, redraw, and refresh — more or less interchangeably.)

How quickly your screen updates depends on a few things, mostly CPU speed, hard disk speed, and video circuitry (built-in or on a video card).

You shouldn’t find it surprising that much of what’s in the rest of this chapter is about making your screen update faster no matter what CPU, hard disk, or video gear you have.

I admit that the faster your Mac, the less difference the techniques in this chapter will make to your overall performance. If you’ve got a Mac with a PowerPC 603/603e/604/604e chip, try my suggestions out for a while and see if you think they’re worth it. Because your Mac has relatively high performance, screen updating is relatively speedy, even with some of the options mentioned in this chapter turned on.

You be the judge.

Depending on your video card or internal video, you are able to choose from black and white, 4 colors, 16 colors, 256 colors, thousands of colors, or millions of colors.

You choose the number of colors that you want your screen to display in the Monitors & Sound control panel, which is shown Figure 10-3.

The Power Macintosh 9500 (whose Monitors control panel is displayed in Figure 10-3) has a video card that can only display thousands or 256 colors at once on my 20" monitor.

Most Macs today can display a maximum of millions of colors on a 14" monitor using built-in video circuitry. And many of these Macintosh models can be upgraded to display thousands or millions of colors on larger monitors by adding an inexpensive VRAM (video RAM) chip.
If you want more colors than your Mac model supports (even with additional VRAM) or want to use a larger monitor, you may need to purchase a video card that supports that combination of colors and size. Video cards range from a low of a couple of hundred dollars to several thousand dollars. For the big bucks, you can get a super-fast, accelerated video card capable of powering a 21" monitor set to display millions of colors with bells and whistles such as virtual desktops, hardware zoom and pan, and resolution switching.

If you choose the Black & White option, each pixel on the screen has only two options: to be black or white. If you choose 256 colors, each pixel on-screen can be any of 256 possible colors. If you choose millions of colors, each pixel on-screen can be any one of millions of possible colors. Unfortunately, not all Macs (mine included) offer Black & White as an option these days.

As you might expect, the more choices each pixel has, the more processing time your Mac requires to update the screen. So the more colors you choose in the Monitors & Sound control panel, the more sluggish your Mac will feel. Scrolling in many programs is much faster if you choose the Black & White option. And in some programs, 256 colors is faster than thousands or millions of colors.

So here's my advice: Unless your application requires color, set your monitor to Black & White for maximum performance. When you're using your word processor or spreadsheet, you probably don't need color anyway. Why make your Mac slower if you don't have to?

Use 1-bit color for speed and 8-bit color for games. Use millions of colors only if you need them (Photoshop, PageMaker, and so on).
In computerese, the number of colors that your monitor displays is often referred to as "bit depth" (or sometimes, "pixel depth"). In a nutshell, bit is short for binary digit, the smallest unit of information that the computer can understand. The bit depth describes how many bits of information can be sent to each pixel.

Here are the English translations for the most common bit depths:

- 1-bit means black and white.
- 8-bit means 256 colors.
- 16-bit means thousands of colors.
- 24-bit means millions of colors.

**Window color considerations**

If you choose to display colors on your monitor, the window color, as chosen in the Color control panel (shown in Figure 10-4), has a slight impact on your Mac's apparent speed.

The Window color setting manages the color of your window borders, scroll boxes, and scroll arrows. For all the same reasons mentioned previously, the Black & White option is faster than any of the colors.

I have to admit that this adjustment doesn't make much difference in your Mac's speed, but it makes a little. The older and slower your Mac, the more it'll help.
**A Mac with a view**

The Views control panel (shown in Figure 10-5) is another place where your choices affect how quickly your screen updates in the Finder.

![Figure 10-5:](image)

**Geneva: It's not just a city in Switzerland anymore**

Using the Geneva 9 font in the Finder is slightly faster than using most other fonts, as Geneva 9 is one of the fonts that your Macintosh stores in its ROM (Read-Only Memory).

**When bigger isn't better**

The smaller the icon, the faster the screen will refresh. In the List Views section of the Views control panel, the little tiny icon on the left is the fastest; the big, horsy-looking icon on the right is the slowest. (The one in the middle is, of course, in the middle.)

**It doesn't pay to calculate folder sizes**

I recommend that you deactivate Calculate folder sizes (that is, uncheck or clear its check box) to make the screen redraw faster in the Finder — or at least, to me, the screen feels like it redraws faster with this feature off.

Actually, the Finder is kind of smart about the Calculate folder sizes option. If you try to do anything in the Finder — make a menu selection, open an icon, move a window, and so on — while folder sizes are calculating, the Finder will interrupt the calculation and let you complete your task before it resumes calculating. So in theory, you should never notice a delay when Calculate folder sizes is on.
Try the Calculate folder sizes option both on and off. I don't know about you, but I find any noticeable delay unacceptable, and I notice a delay when it's turned on, even on very fast Macs. Maybe this feature is just annoying and not actually slowing things down, but I can't stand having it on. If I want to know how big a folder is, I select it and choose the Get Info command from the File menu (Command-I).

**Getting ahead-er and other stuff**

The rest of the check boxes in the List Views section of the Views control panel — Show disk info in header and Show size, kind, label, date, version, and comments — have a slight impact on screen update speed when you open a Finder window in any list view. The fewer items you have checked, the fewer items there are for the Finder to draw. As a result, the Finder updates windows faster.

The impact of these seven items on screen updating is pretty small, so your choice should be made based on what information you want to see in Finder windows, not whether choosing them will slow your Mac down. Play around with these options if you like, but unless your Mac is very slow, you probably won't notice much difference whether they're on or off.

**If you don't need it, turn it off or toss it out**

Chapter 14 is devoted to showing you how to turn off or eliminate Mac OS 7.6 features that you don't need or want. Read it carefully. Features like AppleTalk, file sharing, and QuickDraw GX and 3D use prodigious amounts of memory and can also slow down your Mac's CPU. If you don't need 'em, don't let 'em clog up your Mac. Read Chapter 14 carefully and then fine-tune your Mac for the best performance.

**What Else Can I Do?**

If you've tried every trick in the book (or at least in this chapter) and still think that your Mac is too slow, what can you do? Here are four suggestions:

- Get a new, faster model or upgrade yours. Apple and other companies keep putting out faster and faster Macs and Mac compatibles at lower and lower prices. From time to time, Apple offers reasonably priced upgrades that can transform your older, slower Mac into a speedy new one.

- Get an accelerator. I only offer this suggestion because one of you out there is considering it. I beg you, *don't do it*. I've rarely known an accelerator owner who hasn't discovered an incompatibility somewhere along the line.
Get an accelerated graphics card. Rather than attempt to accelerate your CPU, an accelerated graphics card is designed specifically to speed up one thing: the screen update rate. These things work, blasting pixels onto your screen at amazing speeds. They're extremely popular with graphic arts professionals who would otherwise suffer agonizingly slow screen redraws when working with 24-bit graphics.

Get a new hard disk. Depending on the speed of your Mac, a faster disk may provide a substantial speedup.
Chapter 11

Advanced Techniques for Beginners

In This Chapter
- Modifying your Apple menu
- Using startup items
- Tweaking the Control Strip

In the last chapter, I cover how to make your Mac faster. In this one, I'll show you ways to make it better. Indeed, if you haven't guessed already, this chapter is about ways to make your Mac easier to use, and letting it do the work instead of you.

Souping Up Your Apple Menu

A customized Apple menu is an absolute must in my book. It's the fastest, easiest, most happening way to manage your Mac. If you don't put your Apple menu to work for you, you're missing out on one of the best things Apple's done for you lately, especially with the new hierarchical folders.

The items in your Apple menu are sorted alphabetically by your Mac, so they appear in alphabetical order in the Apple menu. If you understand how the Macintosh sorts items in a list, you can use this knowledge to your advantage.

Tip

Remember, everything in your Apple Menu Items folder appears in your Apple menu.

If you want an item to appear at the top of the Apple menu, precede its name with a number (or a space).
In Figure 11-1, I forced the first four items on the menu to be Macintosh HD alias, Applications alias, Documents alias and Desk Accessories by preceding each one's name with a number. Because the Macintosh sorting algorithm sorts numbers before letters, these items now appear before the first alphabetical entry (Apple Menu Items alias) in numerical order.

![Figure 11-1: Controlling the order of items in the Apple menu with numbers.](image)

**Space cowboy**

A second, slightly prettier way to accomplish the same sort is to precede the item names with one or more spaces instead of numbers, as demonstrated in Figure 11-2.

In Figure 11-2, Macintosh HD alias has four spaces before its name; Applications alias has three spaces before its name; Documents alias has two spaces before its name; and Desk Accessories has a single space before its name.

![Figure 11-2: Controlling the order of items in the Apple menu with spaces.](image)
Chapter 11: Advanced Techniques for Beginners

**Divide and conquer**

You can create dividers in your Apple menu using the same principle. Say I want a dividing line after Desk Accessories. I just use the principles of Macintosh sorting to create a divider line of dashes using an empty folder (see Figure 11-3).

The divider appears between Desk Accessories and Apple Menu Items alias because the hyphens (the empty folder's name) sort after spaces but before letters (or numbers).

Instead of using an empty folder, make an alias of the Clipboard in your System Folder and use it for a divider instead. Using Clipboard aliases makes dividers at least somewhat useful, as you can choose one instead of using the Finder's Show Clipboard command. Just create an alias of the Clipboard, rename it ____________, and toss it in your Apple Menu Items folder.

There are plenty of interesting characters on your Mac keyboard that you can use instead of spaces to force a specific sorting order. The bullet (•, which you create by typing Option-8) sorts after the Z, so items with names preceded by a bullet sort at the bottom of the list after items starting with a Z (see Figure 11-4).
Figure 11-4: You can even use unusual characters to reorder your Apple menu.

Notice in Figure 11-4 that all the folder aliases in the Apple menu have hierarchical submenus. This feature is what makes all of my organizational tips so great. You can organize your Apple menu so that you can quickly get to any file on your hard disk.

Look, ma, no dividers!

If you want your dividers to look even spiffier, you can make them appear without an icon at all, just like what's shown in Figure 11-5. This trick is strictly cosmetic, but I think it looks cool.
Here's how to make icon-less dividers:

1. Open any graphics program and use its selection tool to select a patch of white about 1 inch square. Choose Edit→Copy to copy the white square to the Clipboard (see Figure 11-6).

2. Jump back to the Apple Menu Items folder and select the divider's icon.


   The Get Info window for that icon appears.

4. Click the icon in the Get Info window.

   A border appears around it.

5. Choose Edit→Paste (Command-V).

   The patch of white, which is invisible on the desktop and in the Apple menu, becomes the icon for the divider (see Figure 11-7).

Neat, huh?

All of these sorting and organizing tricks are easy once you get the hang of the way the Mac sorts items in folders. And the principles you learn here work in any window.
I use my sorting tricks in most of my folders. In Figure 11-8, I force the most frequently used items (Corresp '96, Databases, and Finances) to the top of the list by preceding their names with a space, and I force less important items (Books Done.sit, Other Done.sit, and Proposals Done.sit) to the bottom by preceding their names with a grave accent (\`).

When you press the tilde key (usually found in the upper left corner of the keyboard), your Mac types a grave accent (\`) if the Shift key isn’t down; it types a tilde (-) if the Shift key is held down. The tilde sorts after the Z in the Macintosh sorting scheme. (To be perfectly precise, the tilde sorts after the grave accent, which sorts after the Z.) Figure 11-9 shows other characters that sort after the tilde; these include ™ (Option-2) and • (Option-8). But the accent/tildes is handy, being right there in the corner of my keyboard.
Chapter 11: Advanced Techniques for Beginners

Rather than have me tell you about file sorting, why don't you give it a try for yourself? So go to your Mac right now (unless you've been there all along) and try all the tips you just learned.

If the stuff you've read so far in this chapter is not making sense or not working for you, make sure that the By Name command is selected in the View menu or that you've clicked the word Name in the window header so it's underlined. These sorting tips only work in the View by Name view.

Tip

Start Up Your Mornings Right

Don't overlook the convenience of the Startup Items folder in your System Folder. Everything in this special folder will launch automatically at startup.

Think about that for a second. What's the first thing you do after you turn on your Mac and the desktop appears? If your answer begins with the word "Open" or "Launch," you can save yourself some effort by putting an alias of the launched or opened item in the Startup Items folder. It will then launch automatically at startup.

If you work with a single database or spreadsheet file every day, why not put an alias of it in the Startup Items folder? When you turn on your Mac, that document automatically appears on the screen? Or if the first thing you do each morning is check your e-mail, put an alias of your e-mail program in the Startup Items folder.

You can even put a sound in the Startup Items folder. Thereafter, that sound will play as the Finder appears.

For this trick to work, the sound must be stored in the System 7 sound format. You can tell if a sound is in this common format by opening the sound file. If the sound is a System 7 sound, you will hear it play when you open it. Other sound file formats (such as AIFF, WAV, and so on) will do nothing or may display an "application can't be found" error message when you open them.

Most sounds floating around Mac circles these days are in the System 7 format.

Tip

The new Stickies feature is neat to have around all the time. If you put an alias of Stickies in the Startup Items folder, your sticky memos will always be available (see Figure 11-10).
Stickies knows that you're likely to want to use it all the time, so it's got a preference setting that not only puts an alias of it in the Startup Items folder, but it also makes sure that it launches into the background, making the Finder the active application at startup.

To use this feature, launch Stickies, choose Edit→Preferences, and check both the Launch at system startup and ... in the background check boxes (see Figure 11-11).

Not all programs are as considerate as Stickies, as the items in the Startup Items folder launch alphabetically, using that same Macintosh sorting order that I talked about in the previous section. And under ordinary circumstances, the last item to launch is the active application at the end of the startup sequence.

Stickies can launch itself and then make the Finder the active application.
So if you want the Finder to be the active application at startup and you've got several items in your Startup Items folder, just make sure that Stickies loads last and that you've checked the ...in the background check box in Stickies' preferences.

In other words, precede Stickies' name with a few Zs (or a tilde or bullet) to make it the last item in the list when you view the Startup Items window by name (Figure 11-12).

Control Strip Poker

One relatively new feature that can save you time and effort is the Control Strip, which (if it's turned on in the Control Strip control panel) appears somewhere on your screen.

With Control Strip, you can adjust your Mac's speaker volume, change monitor bit-depth and resolution, select a printer, and turn file sharing and AppleTalk on and off, all without visiting a control panel or the Chooser.

On becoming a (Control Strip) item. Or not.

There's more about Control Strip in Chapter 12, but for now, here are a couple of things you should know:

Control Strip modules live in a folder in your System Folder named (what else?) Control Strip Modules. If a module is in this folder at startup, it appears in your Control Strip on-screen.
Apple provides seven Control Strip items (see Figure 11-13). If you don’t want or need some of them, you can delete them (that is, trash ‘em) and make your Control Strip even shorter and more efficient.

One last thing: There are many freeware and shareware Control Strip modules available. For example, my bookmark program, URL Manager Pro, includes a module that lets me perform a number of actions right from my Control Strip (shown in Figure 11-14). You might also notice my Slot Machine Control Strip module sitting just to the left of URL Manager Pro.

Check out Chapter 12 for complete details about the full complement of Apple Control Strip modules.
The Control Panels folder contains (what else?) your control panels. What exactly are control panels? They're usually little miniprograms that control a single aspect of your Mac's operation.

I've talked about some of the control panels (Memory, Sharing Setup) earlier in this book, but because Mac OS 7.6 includes about 40 control panels for most Macs, in this chapter, I'll go through them one at a time, in alphabetical order, describing and suggesting settings for each and every one.

After a brief AppleScript interlude in Chapter 13, I continue this discussion in Chapter 14, "What Can Stay and What Can Go," with a full disclosure of how much memory and disk space each control panel uses and how to remove or temporarily disable ones that you don't need. I even explain why you might want to do this stuff.

I've included no-brainer settings at the end of many sections for those of you who just want to know how to set the thing and don't care what it does or why. These no-brainer settings are not the gospel, but they're a good place to start. (You can always come back and change them later after you figure out what they are and what they do!)

**Apple Menu Options**

The Apple Menu Options control panel has two functions:

- Turns the hierarchical submenus on or off.
- Lets you specify how many recent documents, applications, and servers your Mac should track.
The first function controls whether or not folders (and aliases of folders as well as disks) in the Apple menu display their contents when you highlight them. Put another way, the Submenus on/off switch (actually, a pair of radio buttons) turns the little triangles on and off. It works while the control panel is open, so try each choice and then pull down the Apple menu to see the results.

The second function requires that you check the Remember recently used items check box. When you do so, your Mac will remember the specified number of documents, applications, and servers for you. You'll find the remembered items in the similarly named folders in the Apple menu (see Figure 12-1).

The Mac remembers these items by creating aliases and putting them in the appropriate Recent Items folder. All three Recent Items folders are in the Apple Menu Items folder.

The Mac uses FIFO (first in, first out) to limit the number of items in each folder according to your choices in the Apple Menu Options control panel. Say you set the number of documents to 20. When you open document number 21, document 1 is forgotten. More long-windedly, when you open document number 21, your Mac creates an alias for document 21. It then deletes the alias for document number 1 so that there are again only 20 items in the folder, as you requested.

All of this stuff is done invisibly, without your knowledge or intervention.

Figure 12-1: The Apple Menu Options control panel and its two offspring: hierarchical submenus in the Apple menu and the two Recent Items folders in the Apple menu.
Apple Menu Options no-brainer setting: Submenus: On. Documents: 15. Applications: 15. Servers: 0 (unless, of course, you’re connected to a server, in which case it’s your call).

### AppleTalk

The AppleTalk control panel (see Figure 12-2) lets you choose how and where to network your Mac or Mac-compatible. Its main function is to enable you to select which port — Printer, Modem, Ethernet (if you have it; I do), or Remote Only for dial-in connections, as I discuss in Chapter 8.

![Figure 12-2: The AppleTalk control panel lets you choose where your network connection connects.](image)

But wait, there's more! You can choose Edit: User Mode, promote yourself to Administration level, and then password-protect your network settings and much more. Or choose File: Get Info (Command-I) to learn more than you need to know about your Mac and its addresses and software version numbers, which may someday come in handy (Figure 12-3).

Finally, choosing File: Configurations (Command-K) lets you create, rename, import, or export your specific configurations.

The AppleTalk control panel is particularly useful for PowerBook users who may have more than one network setup they'd like their Mac to remember. But the rest of us will probably use this control panel once and then forget about it forever.

At least now you can say you know what it is and what it does.
ATM

ATM is Adobe Type Manager, which eliminates the jaggies in Type 1 fonts on-screen. And if your printer doesn’t have built-in PostScript, it eliminates jaggies in your printed output.

It’s actually last in your list of control panels (remember the info about the order of stuff back in Chapter 11), but since its name really starts with an A, I cover it here instead of last.

ATM has been available from Adobe as an extra-cost add-on product for years; System 7.5 was the first time Apple included it in the box for free.

You only need ATM if you meet the following criterion: You are using PostScript Type 1 fonts.

If you don’t meet the criterion (meaning you only use TrueType fonts), click the Off button and be done with it.

~ATM no-brainer setting: (This assumes, of course, that you’re using Type 1 fonts. If you’re not, you shouldn’t bother using ATM — it’s a waste of RAM. Either turn it off from Extensions Manager or drag it out of the Control Panels folder; then restart your Mac to disable it.) Font Cache: 96K. Preserve Line Spacing: On (see Figure 12-4).

If you use many Type 1 fonts, or if screen updating seems unusually sluggish, try increasing the size of the font cache until the sluggishness goes away. But as with the disk cache in the Memory control panel, don’t forget that this cache uses RAM. The higher you set the font cache, the less RAM is available for applications.
AutoRemounter (PowerBooks Only)

This control panel deals with what happens to shared disks that you have mounted on your PowerBook desktop when you shut down or put your Mac to sleep. It’s shown in Figure 12-5. Sleeping, restarting, and shutting down all have the same effect on shared disks: The network connection is broken. With AutoRemounter, you have some control over what happens when you wake up or start up. Without it, you’d have to manually reestablish the network connection to each shared disk.

Note that this control panel only matters if you mount disks or volumes over a network; stand-alone Macs need never even open it.

The Remount Shared Disks choices are mutually exclusive (you can select only one of the three choices at a time):
After Sleep: This option automatically remounts any shared disks on your desktop when you put your Mac to sleep.

Always: This option automatically remounts any shared disks on your desktop when you put your Mac to sleep and remounts any shared disks on the desktop when you shut down or restart.

Off: This option disables the AutoRemounter control panel completely.

The Connect to Disks By choices are

Automatically Remounting: This option automatically remounts any shared disks on your desktop after you shut down, restart, or sleep (based on your selection in the Remount Shared Disks section) but does not require a password for the disk to be remounted.

Always Entering Passwords: This option automatically remounts any shared disks on your desktop after you shut down, restart, or sleep (based on your selection in the Remount Shared Disks section) but does require a password before the disk is remounted.

Don’t choose the Automatically Remounting option if the contents of shared disks are confidential. Someone else could awaken or restart your computer; selecting this option gives that person access to files on the remote disks. Choose the Always Entering Password option instead so that other users will only gain access to remote disks if they know the password.

Just a reminder that choices are, by their nature, mutually exclusive when you see a set of radio buttons. Radio buttons always signify that only one choice may be active at any time.

AutoRemounter no-brainer setting: If you don’t use file sharing, click the Off button and forget it. If you use file sharing, click Always and Automatically Remounting. (Choose Always Entering Passwords if your office is not secure.)

Brightness

This control panel lets you adjust the brightness of some monitors, mostly PowerBook and Duo models. The Install Mac OS program is smart and usually doesn’t install this control panel unless your monitor supports it (most don’t).

If the Brightness control panel was installed inadvertently on a Mac that doesn’t support it and you try to open it, an error message like the one in Figure 12-6 will tell you that your Mac can’t use this control panel. No big deal. Just trash it and forget it.
For those of you who can use the Brightness control panel, all I can say is that very few people have ever cast their gaze upon it and lived to tell the tale. Suffice it to say that this control panel has a slider bar to control screen brightness, and it gives you the option of setting up a keyboard shortcut to do the same thing. So few Mac users need to worry about this control panel that I won’t expose them to the curse by presenting a screen shot.

**Color**

The Color control panel governs the highlight color (the color of selected text), the window highlight color, and the color of accents in scroll bars and title bars. The options in this control panel are purely cosmetic.

There’s an Easter egg in the Color control panel. To see it, click repeatedly on the sample text below the word Highlight Color. Dean Yu and Vincent Lo are apparently the programmers of the Color control panel.

**Tip**

**Color no-brainer settings**: Whatever you like. Black and white is slightly faster for window highlights on some Macs, but it's not as pretty.

**ColorSync System Profile**

ColorSync is a color-matching technology that ensures color consistency between screen representation and color output. It is of no importance unless you are also using the ColorSync color-matching system on your printing devices and scanners.

I thought not.
So this control panel's settings are totally irrelevant. Nothing whatsoever will happen if you change them.

**ColorSync System Profile no-brainer settings:** Don’t touch it.

**Control Strip**

Show or hide the Control Strip by choosing the appropriate radio button in this control panel.

Use the Control Strip's built-in hide and show feature (demonstrated in Figure 12-7) to collapse and expand the strip on-screen. Click the little nub to expand it again.

**Figure 12-7:**

Click at either end of the Control Strip (circled, top) to collapse it to a little nub on-screen (bottom).

**Control Strip no-brainer settings:** Click the Show Control Strip radio button.

**Date & Time**

The Date & Time control panel lets you configure your Mac's internal clock, which many programs use, and configure the menu bar clock (see Figure 12-8).
To set the date or time

Click the number that you want to change in the Current Date or Current Time field. The number is highlighted when you click it, and a pair of arrows appears. Increase the selected number by clicking the up arrow; decrease it by clicking the down arrow. You can also use the arrow keys on the keyboard to increase or decrease the number. Or you can type a new number right over the selected number.

Use the Tab key to move from number to number. Month, day, year, hour, minute, second, and AM/PM are selected in sequence when you press the Tab key. If you want to move backward through the sequence, press Shift-Tab. As long as you hold the Shift key down, you’ll cycle through the numbers in reverse order as you press Tab.

Time and date formats

Your choices in the Date or Time Formats dialog boxes appears any place your Mac displays the date and time: in the menubar, in programs that date or time stamp documents, in the Finder (creation and modification dates), and so on.

To change formats, click the appropriate button. The Date Format dialog box (shown in Figure 12-9) lets you change the punctuation marks in the long date and the dividers in the short date.
You can change the display order of both long and short dates. Use the Weekday, Month, Day, or Year pop-up menu to change the order of the long date; click the Month/Day/Year pop-up menu to choose a different order for the short date.

The Time Format dialog box lets you choose a 12-hour or 24-hour clock and a bunch of other stuff, as Figure 12-10 shows.

**The rest of it**

The Daylight Savings Time check box sets the clock forward one hour (checked) or backward one hour (unchecked).

The Set Time Zone button lets you choose your time zone from a scrolling list.

Type the first letter of a big city near you to scroll to that city’s name in the list.
Is this thrilling or what?

Finally, the Clock Options button lets you do all kinds of fun stuff with your menu bar clock (see Figure 12-11). You can set the clock to chime on the hour or quarter-hour, and you can select custom fonts and colors.

![Figure 12-11: If you’re a tweak freak, you’ll have a field day with all of the menu bar clock’s options.](image)

Apple’s menu bar clock is based on Steve Christensen’s popular freeware menu bar clock, SuperClock, which many Mac users loved and revered long before Apple began including it back in System 7.5.

### Desktop Patterns

This control panel, shown in Figure 12-12, lets you select a decorative pattern for your desktop. To choose from the 74 available patterns, click the left- and right-arrow buttons on the Desktop Pattern window (or the left-arrow and right-arrow keys on the keyboard). When a pleasing one appears, click the Set Desktop Pattern button.

I lied: Desktop Patterns is an application, not a control panel. If you don’t believe me, view the Control Panels folder’s window by kind. Why did Apple choose to place it in the Control Panels folder? I don’t know, but it seems like as good a place for it as any.
Desktop Patterns is a vast improvement over earlier versions of the System, which offered only a handful of ugly patterns with a maximum of 8 colors. The Desktop Patterns control panel, er, application offers up to 256 colors and looks great in thousands or millions of colors as well.

This functionality was previously available in third-party programs like Wallpaper and Screenscapes, so it's nice that Apple is throwing in this utility for free.

**Dial Assist**

No cop-out, but this little doohicky was covered in clear and loving detail back in Chapter 8. Let's not waste trees, okay?

**Editor Setup (OpenDoc Only)**

If you installed OpenDoc, you have an Editor Setup control panel. As with the man behind the curtain in *The Wizard of Oz*, pay no attention to it now. (It's covered extensively in Chapters 15 and 16, if you can't stand the suspense.)
Energy Saver

Almost all recent Mac models are said to be Energy Star-compliant — they can turn themselves off at a specific time or after a specified idle period. If your Mac supports this feature, the Energy Saver control panel is installed when you install Mac OS 7.6. (If your Mac doesn’t support this control panel but it was somehow installed and you try to open it, you’ll see an error message haughtily informing you that your Mac can’t use it. No problemo. Trash the dastardly Energy Saver control panel and be done with it.)

In the top part of the dialog box, you can choose to have your computer go to sleep (a low-power mode) or shut down automatically after so many minutes of idle time (kind of like a killer screen saver).

The first time you restart your Mac after installing Mac OS 7.6, a helpful dialog box tells you that you now have Energy Saver and asks if you’d like to configure it now. Nice, eh?

To turn this feature on, move the slider until the appropriate time displays beneath it. To turn it off, slide the slider to Never. Figure 12-13 shows this little gadget.

![Energy Saver Control Panel](image)

Click the Show Details button and you’ll see two additional sliders to control your display and hard disk sleep patterns separately.

And if you click the Scheduled Startup and Shutdown button at the top of the Energy Saver window, you can choose to have your Mac start up or shut down once at a specific time, or you can set up a recurring shutdown (for example, shut down every day at 11:29 p.m., just in time for Dave).
If you're not around when one of these shut downs occurs and you have unsaved work in any application, you'll see a dialog box asking if you want to save your changes. The Mac won't shut down until you click a button in this dialog box. In fact, if you click the Cancel button in this dialog box, the shutdown is canceled along with the Save dialog box.

**CPU Energy Saver no-brainer settings**: Drag the slider to 30 or 45 minutes for sleep (not Shut Down); then remember to turn your Mac off manually when you're not going to need it for a while.

---

**Extensions Manager**

Extensions Manager is another program that's been around for years as freeware but made its first appearance as an Apple product in System 7.5 and has been overhauled extensively for Mac OS 7.6. Extensions Manager lets you turn extensions, control panels, startup items, and shutdown items on and off easily.

There's a longer, more technical discussion of why you need Extensions Manager, along with some tips, in Chapter 14. For now, here's how you use it.

Extensions and control panels load into memory if they're in the Extensions or Control Panels folders at startup. Without Extensions Manager (or one of its third-party counterparts such as Now Software's Startup Manager, Inline Software's INTPicker, or Casady & Greene's Conflict Catcher II), you would have to move an extension or control panel out of its special folder manually and then restart your Mac to disable it — which, as you might guess, isn’t much fun.

You still have to restart your Mac, but you can use Extensions Manager to turn individual control panels and extensions on and off without moving them manually.

You can work with Extensions Manager in the Finder by opening its icon or choosing Apple menu→Control Panels→Extensions Manager. Or you can work with it at startup, before any control panels or extensions load.

To open Extensions Manager at startup, hold down the spacebar on your keyboard until the Extensions Manager window appears (see Figure 12-14).

Regardless of which way you open it, you choose which items you want to turn on or off by clicking the box before their name (an X means the item is turned on). Your choices remain in effect until you change them in the Extensions Manager window.
You can create *Sets* with Extension Manager, groups of extensions and control panels that you want to use simultaneously. To create a set, click items in the list until the ones that you want turned on have Xs and the ones that you want turned off don't. When everything is just the way you like it, choose File→New Set. You'll be asked to name the set. After you do, the set will appear in the Sets menu as a custom set along with the pre-installed sets — Mac OS All and Mac OS Base. Sets can be quite convenient, as I explain in Chapter 14.

When you finish making your selections or creating sets, close the Extensions Manager window. If you used the spacebar to open Extensions Manager at start up, your Mac will start up with only the X-ed items loaded; if you're in the Finder, click Extensions Manager's Restart button for your selections to take effect.

The Mac OS Base set turns on only the most essential control panels and extensions, turning off memory hogs like QuickDraw 3D and QuickDraw GX (see Chapter 14 for details). Using it may regain some of your precious RAM for other purposes.
You can also turn on or off the entire Extensions, Control Panels, Startup Items, or Shutdown Items folders by clicking the On/Off box next to their name. In other words, turning off the Control Panels folder in Extensions Manager turns off all of your control panels at once. You’ll find Duplicate Set, Delete Set, and Rename Set commands in the File menu. They do what they say sound like they do.

**File Sharing Monitor**

The File Sharing Monitor control panel tells you which items on your local disk are currently being shared, how much network activity there is, and who is currently connected to your hard disk. It’s shown in Figure 12-15.

The only thing you can actually do with the File Sharing Monitor control panel is to disconnect connected users, which you do by clicking them so that they’re selected and then clicking the Disconnect button.

**General Controls**

This is the big fellow, the granddaddy of all control panels. Figure 12-16 doesn’t do it justice.

A whopping six different options are managed by General Controls.
Figure 12-16: The General Controls control panel is like six control panels in one.

Desktop options

The Show Desktop when in background check box determines whether the Finder shows through in the background when you've got another application open. Unchecking this option makes Finder windows and icons disappear when other programs are active, which means that the only way to switch to the Finder is to choose it from the Application menu. In other words, if you click outside of a word processor window, you don't pop into the Finder.

Checking the Show Desktop when in background option makes it more convenient to return to the Finder from other programs by clicking the desktop or a Finder window, but this feature may be more confusing for beginners.

The Show Launcher at system startup check box governs whether the Launcher is active. I ranted about Launcher earlier in the book, so I won't bore you with my vitriol. Suffice it to say that I don't find it very useful, but beginners might.

Shut Down Warning

If this check box is checked, you'll see a warning like the one in Figure 12-17 when you restart your computer after a crash, freeze, power interruption, or improper shutdown.
Folder Protection

If the Folder Protection check boxes are checked, items in those folders (System or Applications or both) can’t be renamed or deleted.

Insertion Point Blinking

This option sets the speed at which the text insertion point, a flashing vertical line, blinks in documents. Your choices are Slow, Medium, or Fast. I like Fast because I find it easiest to see.

Menu Blinking

This option controls whether or not menu items flash when you select them, and if they flash, how many times.

Off is the fastest setting.

Documents

This set of radio buttons determines what folder will be active in Open and Save dialog boxes:
Folder that contains the application: This option brings up the Open or Save dialog box ready to save or open files in the folder that contains the program you’re using. So if you’re using ClarisWorks and you choose File⇒Save or File⇒Open, the list of files you see in the Open or Save dialog box will be the contents of the ClarisWorks folder.

Last folder used in the application: This option brings up the Open or Save dialog box ready to save or open a file in the last folder you saved to or opened a document from. In other words, your Mac remembers for you.

Documents folder: This option will bring up the Open or Save dialog box ready to save or open a document in the Documents folder.

General Controls no-brainer settings:

For beginners


For more advanced users


Keyboard

The Keyboard control panel modifies how your keyboard responds to your keystrokes. It’s shown in Figure 12-18.
The Key Repeat Rate sets how fast a key will repeat when you hold it down. This feature comes into play when you hold down the dash key to make a line or the * key to make a divider.

The Delay Until Repeat option sets how long you have to hold down a key before it starts repeating.

The Keyboard Layout section allows you to choose a different keyboard layout for languages other than United States English.

Because changes to the Keyboard control panel take place immediately, you can open it and a word processor and experiment with its settings until you are comfortable.

**Keyboard no-brainer settings:** Look at Figure 12-18. Duplicate its settings. If you live somewhere other than the U.S. and see a familiar-sounding keyboard layout in the lower part of the window, select it.

Do not under any circumstances click the box at the bottom unless you have good reason to use foreign keyboard layouts on occasion. The Command-Option-spacebar keyboard shortcut, when turned on, can cause unpredictable behavior if you later forget you've turned it on. Use this thingie with caution, especially if you use Photoshop (which uses Command-Option-spacebar as the shortcut for Zoom Out).

**Labels**

The Labels control panel (shown in Figure 12-19) lets you change the names and colors of the labels in the Label menu.

To change a label's color, click directly on the color and then choose a new one in the color picker, which is shown more or less in Figure 12-20.
I know that all the colors on the color picker look gray in the picture, but on a color monitor, they are in color, I promise. To select a new color, just click in the color wheel or change the Hue Angle, Saturation, and/or Lightness settings.

For even more fun, click the More Choices button and check out the Apple RGB color picker, which uses sliders instead of a color wheel. Whee!

**Figure 12-20:** The color picker appears when you click a color in the Labels control panel.

---

**Launcher**

Launcher is Apple’s cheesy little file launcher. It lets you open items in its window with a single click, which saves you the trouble of rummaging through folders.

The Launcher window’s buttons reflect the contents of the Launcher Items folder in your System Folder (see Figure 12-21).

Whatever is in the Launcher Items folder appears as a button in the Launcher window. Single-clicking the button opens the item, which can be a file, a folder, a document, or a control panel, or (better yet) an alias of a file, a folder, a document, or a control panel.

If you want Launcher to start up automatically, there’s an option for that very thing in the General Controls control panel.
Figure 12-21: The Launcher window contains single-click launch buttons for each item in the Launcher Items folder.

If you like Launcher, read up on how to make it better in Chapter 6.

**Mac OS Easy Open**

Mac OS Easy Open (MEO) is the enabling technology that lets you choose another application to open a document when you don't have the actual application that created it. Figure 12-22 provides a demonstration.

Figure 12-22: This translation dialog box is part of Mac OS Easy Open.
If MEO isn't turned on or isn't installed, instead of this dialog box, you see an error message telling you that an application couldn't be found for this document.

The four check boxes in this control panel manage how the translation dialog box works (see Figure 12-23).

If you check Always Show Dialog Box, you must confirm your translation preference every time you open a document. In other words, if this item is checked, you see the dialog box shown back in Figure 12-22 every time you open a Photoshop file. If you uncheck this option, the second time (and every time thereafter) that you open a Photoshop file, it will automatically launch into the selected alternate program, in this example, SimpleText.

If you check the Include Applications On Servers option, MEO will look on all network volumes currently mounted for an application that can open the document.

If you don't have a high-speed network (such as Ethernet or Token Ring), launching a remote program can take a long, long time. You might want to consider leaving this option off unless you really, really need it.

The Auto Pick If Only 1 Choice option picks the appropriate program to open the file automatically (without the dialog box) if you only have one program capable of opening that file.

The Translate 'TEXT' Documents option, when turned on, evaluates all plain text files to see if they should be translated before opening. This increases your ability to read documents from other computers (DOS/WinDoze, mainly) but may slow the opening of Mac-created plain text documents. If you don't associate with people who use DOS or WinDoze, leave it unchecked for sure.

The Delete Preferences button deletes any links that you've created between documents and applications. Why would you need to delete preferences? If the Always Show Dialog Box option isn't checked and a document always
Part III: U 2 Can B A Guru

launches the wrong application, click Delete Preferences. The next time you try to open that document, you'll get a dialog box allowing you to choose a different application. In other words, the Delete Preferences button makes MEO forget any connections between documents and applications previously created in a translation dialog box.

**Tip**


**MacLinkPlus Setup**

If you chose to install the optional MacLinkPlus translators when you installed Mac OS 7.6, you'll have a MacLinkPlus Setup control panel in your Control Panels folder. My advice is, don't change a thing and don't mess with it unless someone or some software manual instructs you to. Okay?

**Map**

A lame little control panel that's virtually useless. I'm not gonna waste your time with it. Figure 12-24 shows a picture, just for kicks.

**Figure 12-24:** The mostly useless Map control panel.

**Memory**

Refer to Chapter 9, which covers nothing else.
Memory no-brainer settings: Cache Size: 32K. Virtual Memory: Off. 32-bit Addressing: On (unless you have 8 megabytes of RAM or less, in which case it should be Off). Ram Disk: Off.

**Modem**

The Modem control panel (shown in Figure 12-25) lets you choose which port your modem is connected to, as well as sound and dialing options (only available for internal modems, alas).

![Modem Control Panel](image)

**Monitors & Sound**

Here's where you control your Mac's monitor and audio options.

**Monitor**

Click the Monitor button at the top of the window. You can now select the number of colors in the Color Depth scrolling list and Grays or Colors by clicking the appropriate radio button. If your monitor and video card support what is known as multisync, you will also be able to change resolutions, as shown in Figure 12-26. Finally, some monitors allow you to adjust their Gamma settings, which makes white look slightly different.

**Sound**

Click the Sound button at the top of the window. You can adjust all of your Mac's sound levels by dragging the appropriate slider. Some options shown in Figure 12-27 may not be available on all computer models.
Alerts (beep sounds)

Click the Alerts button at the top of the window. Now you can choose your Mac's System Alert sound, also known as its beep sound (see Figure 12-28). The slider on the right controls System Alert (that is, beep) volume.
If you have a microphone that works with your Mac or have sounds you've downloaded or traded with others, you can add additional beep sounds using the SimpleSound desk accessory (for microphone recording), or by dragging any sound file onto the System Folder (for stored sounds).

Don't believe me? Here's how to record your own sound (microphone required, of course).

First choose Apple menu->SimpleSound.

1. Click the Add button.
   A recording dialog box appears (Figure 12-29).

2. Click the Record button.
3. Make your noise or sound.
4. Click the Stop button.
5. Name the sound.

Bingo. That's it. Your new sound appears in the list of sounds. Select it now as your beep sound if you like. See. Told you it was a piece of cake (as long as you have the microphone).
Mouse

This control panel, shown in Figure 12-30, sets the mouse tracking and double-click speeds.

![Figure 12-30: The Mouse control panel, where speed is king!]

The Mouse Tracking setting governs the relationship between hand movement on the mouse and cursor movement on the screen. Fast mouse-tracking settings send the cursor squirming across the screen with a mere flick of the wrist; slow mouse-tracking settings make the cursor crawl across in seemingly slow motion, even when your hand is flying. Set it as fast as you can stand it. I like the second-fastest speed, as shown in Figure 12-30. Try it. You may like it.

The Double-Click Speed setting determines how close together two clicks must be for the Mac to interpret them as a double-click and not two separate clicks. The leftmost button is the slow setting. It lets you double-click at an almost-leisurely pace. The rightmost is the fast setting (which I prefer). The middle button, of course, represents a double-click speed somewhere in the middle.

Changes in the Mouse control panel take place immediately, so you should definitely play around a little and see what settings feel best for you.

**Tip**

**Mouse no-brainer settings:** Mouse Tracking: Moderately fast. Double-click speed: Middle setting.

Numbers

Use this control panel to change the decimal and thousands separators (the period and comma in $1,000,000.00) as well as the symbol used to denote currency ($ in the U.S.A., £ in England, and so on). Figure 12-31 shows the Numbers control panel.
You could go through your entire life without ever needing to open the Numbers control panel.

**PC Exchange**

PC Exchange manages which Macintosh program launches when you open documents created on that other kind of computer, running that other operating system, MS-DOS (see Figure 12-32).

Apple throws in this application assignment — .TXT documents open in SimpleText — for free. If you'd prefer to read DOS files in a program other than SimpleText, click the application assignment to select it and then click the Change button (see Figure 12-33).
Figure 12-33: ClarisWorks will now launch when I open a DOS document with the .TXT suffix.

In the Change dialog box, you can change the three-letter suffix, the application program that you want to use to open that type of document, and the type of document.

If you click the Document Type pop-up and nothing happens, the type is set already for that document and you can't change it.

To remove an application assignment, select it by clicking and then click the Remove button.

Double-clicking an application assignment opens the dialog box, the same as selecting it and then clicking the Change button does.

The Add button in the PC Exchange control panel brings up the same dialog box shown in Figure 12-33. To create a new application assignment, make your choices in the dialog box and then click OK.

PPP

PPP is point-to-point protocol. It's how most Mac users communicate with the Internet. And Mac OS 7.6 is the first version to include it.

I hate to disappoint you but that's all you're going to get for now. I talk about this little puppy ad nauseam in the upcoming Internet chapter (that being Chapter 15). Stay tuned.
**QuickTime Settings**

This one's a no-brainer. It's probably already configured properly, in which case, leave it alone. Just check to make sure it's set as follows:

First choose AutoPlay from the pop-up menu if it's not already selected and then click both check boxes — Enable Audio CD AutoPlay and Enable CD-ROM AutoPlay. These settings enable your Mac to automatically start playing all audio CDs and some CD-ROM titles.

Now choose Music from the pop-up menu and make sure that QuickTime Music Synthesizer is checked.

That'll do it. Close it and forget it.

**Remote Access Setup**

This control panel is present only if Remote Access is installed. Refer to Chapter 8 for the gory details.

**Sharing Setup**

Ditto! Chapter 8 again!

**Speech**

Choose Voice from the Options pop-up menu (see Figure 12-34) to select the voice your Mac will use for speech-to-text applications. Now choose a voice from the 22 wild and wacky selections in the Voice pop-up. To check out your handiwork, click the speaker icon. Each voice says something different. My favorite is Fred who says, "I sure like being inside this fancy computer." If you think that's fun, try this: Launch SimpleText, type a few words and select them; then choose Sound<>Speak Selection (Command-H). Cute, eh?

For a really good time, choose Talking Alerts from the Options pop-up menu (see Figure 12-35) and click both check boxes. Choose Random from the list from the Speak the phrase pop-up menu and then close the Speech control panel. The next time a program puts an alert box up on the screen ("Save changes to the document 'untitled' before closing?") your favorite voice will speak it for you.
Figure 12-34: The Speech control panel—choose from 22 wild and wacky voices and make them talk slower or faster.

Figure 12-35: This one will really make you puke; set yours like mine and your Mac will speak alerts to you.

Even cuter. Here’s my guess: You’ll leave it turned on for maybe a week. Or less.

**Startup Disk**

With this control panel, you choose which hard disk or hard disk volume (if you’ve partitioned your hard disk) should act as the startup disk when more than one drive with a System Folder is connected to the Mac (see Figure 12-36).
Figure 12-36:
This Mac has three hard disks attached. Macintosh HD is selected, so it will be the startup disk.

TCP/IP

Sorry to disappoint again, but you'll have to read Chapter 15 if you want to know about this alphabet soup (and PPP too).

Text

Another control panel you'll never need. Unless, of course, you have a version of Mac OS 7.6 other than the U.S. version. If you use more than one language on your Macintosh, you can choose between them in this control panel, which is shown in Figure 12-37.
Users and Groups

I'm sorry if I sound like a broken record, but I cover this one in great detail in Chapter 8. If you need to know, that's where to go.

Views

I've mentioned the Views control panel more than once, most recently in Chapter 10, but what the heck. A pop-up menu lets you select a font to be used in the Finder (see Figure 12-38).

Figure 12-38: The Views control panel. Configure it properly and your Mac will feel faster.

Geneva, which is in your Mac's ROM, is the fastest font. Fancy fonts can make the Finder feel sluggish.

The Icon Views section lets you turn on an invisible grid in windows using Icon views (view by Icon, view by Small Icon) and on the desktop. Icons snap to the invisible grid, so your icons always line up in rows and columns, even without the Clean Up command.

In the Finder, holding down the Command key while dragging an icon temporarily reverses the grid setting. In other words, if Always Snap To Grid is checked, holding down the Command key turns the grid off temporarily; if Always Snap To Grid is unchecked, holding down the Command key turns the grid on.

A Staggered grid nudges every other icon up or down a few pixels. A straight grid lines up all the rows.
Chapter 12: Control Tweaks

The List Views section manages the appearance of Finder windows when they're in any of the list views. The three icons represent the size of icons in the list views. The small icon is the fastest of the three and also the least visually descriptive. The medium icon is a good compromise—it's more colorful and not terribly large. The large icon is all but useless, as it's so big in the lists that you can only see a few items at a time.

Calculate folder sizes puts the size (in K) next to each folder. It's discussed in Chapter 3 and Chapter 10 (I still say it makes your Mac feel more sluggish if it's turned on).

Show disk info in header tells you how much space has been used and how much space is remaining on the parent disk. It also tells you how many items are in a window (see Figure 12-39).

This header information is good to know, so I leave this option enabled on my Mac.

The six check boxes in the lower right of the Views control panel control what information is displayed in list views. Check the check boxes of ones that you want to see in the Finder.

**TIP**

**Views no-brainer settings:** See Figure 12-38. Make yours look like that.

**WindowShade**

WindowShade is a nifty little gadget that lets you roll up windows (like a window shade, get it?) at will. Figures 12-40 and 12-41 demonstrate. It works in any application with almost every kind of window.

If you don't like rolling up your windows with a double-click, you can click one of the modifier-key check boxes. If I were to click the check box for the Command key, I would have to Command-double-click to roll up windows. You can use any combination of the Command, Option, and Control keys along with two or three clicks.
Finally, the sound check box provides a whooshing sound when you roll up a window.

The freeware version of WindowShade has been popular for years. Kudos to Apple for adopting this wonderful and useful little piece of code.
Chapter 13
How to Write an AppleScript in 21 Minutes

In This Chapter
► What the heck is an AppleScript anyway?
► Finding AppleScript items
► Writing a simple script
► Saving a script

(The chapter title is, of course, a takeoff on Viki King's wonderful book about that other kind of script writing, How to Write a Movie in 21 Days.)

AppleScript is like a tape recorder for your Mac. It can record and playback things that you do, such as opening an icon or clicking a button.

Describing AppleScript to a Mac beginner is a bit like three blind men describing an elephant. One man might describe it as the Macintosh's built-in automation tool. Another might describe it as an interesting but often overlooked piece of enabling technology. The third might liken it to a cassette recorder, recording and playing back your actions at the keyboard. A fourth (if there were a fourth in the story) would assure you it looked like computer code written in a high-level language.

They would all be correct. AppleScript is the Mac's built-in automation tool (at least in System 7.5 and later, it's built in). It is a little-known (at least up to now) enabling technology. It is like a cassette recorder (for programs that support AppleScript recording). And scripts do look like computer programs (which could be because they are computer programs).

I call AppleScript a time and effort enhancer. AppleScript, if you just spend the time and effort it takes to learn it, will save you oodles of time and effort.
Therein lies the rub. This stuff isn't simple. There's no way in heaven I'm going to teach you how to use AppleScript in the next nine pages. Entire books have been written on the topic, for gosh sake!

And don't kid yourself. AppleScript is complicated and will take some effort to master. So rather than try to teach you how to use it, I'll try to show you what AppleScript can do for you, and I'll get you to the point where you can write a simple script of your own, all in about 21 minutes.

**What the Heck Is an AppleScript, Anyway?**

In the broadest sense, AppleScript is an enabling technology that lets you record and playback complex sequences of Macintosh events occurring in the Finder, programs, or any combination of the Finder and programs. In a narrower sense, AppleScript now makes it possible to automate multistep sequences, such as changing the bit depth of your monitor. What used to take at least three steps...

1. Open the Monitors control panel
2. Click a number of colors
3. Close the Monitors control panel

...can now be performed instantly and effortlessly with one script. This feature may not sound like much, but it can sure save you time and effort. The more often you perform a task each day, the more you should consider automating it (if, of course, it can be automated — not all tasks can be automated, as you'll soon see).

The AppleScript components are installed automatically when you install Mac OS 7.6. (I discuss the components one by one after a brief rant.)

AppleScript has been around for a few years, but before System 7.5, it wasn't included in Apple System software releases. Instead, it came in separate Scripter and Developer packages at additional cost. So it never really caught on with the masses. In the meantime, many forward-thinking developers have incorporated AppleScript support in their programs. Better still, that number is growing faster now that AppleScript is part of the System software.
Power users have been clamoring for this stuff for years. It's finally here, and it's only going to get better and more powerful as time goes on and more people get copies for free.

I encourage you, if you really want to master your Macintosh, to learn at least a bit of basic scripting. This chapter is a start, but your investment of time spent learning AppleScript will be repaid tenfold in time you save performing your daily tasks. And at the very least, some of the canned scripts that Apple provides — such as the one that turns file sharing on and off or adds an item's alias to your Apple menu — can save you time and effort every day.

The Script Editor requires at least 700K of free memory (Largest Unused Block in the About this Computer dialog box). If you don't have enough memory to use it, quit all open applications and try again. If that doesn't do it, open the Extensions Manager control panel, select the Mac OS 7.6 minimum option from the pop-up menu, and then restart your Mac. (Don't forget to turn this stuff back on later.)

What the Mac OS Installer Installs and Where It Installs It

Mac OS 7.6 includes a bevy of AppleScript-related items in various places on your hard disk. Some are essential to AppleScript's operation; the rest are merely convenient. Before you learn how to use them, here are your tools.

The AppleScriptLib and AppleScript extensions

(In the Extensions folder, which is in the System Folder)

These extensions are installed in the Extensions folder (in the System Folder). They are the engine that make AppleScript work. If they're not in the Extensions folder at startup, AppleScript won't work. They require no care or maintenance.

The Scripting Additions folder

(In the Extensions folder, which is in the System Folder)
This folder contains add-on parts of the AppleScript system. AppleScript is modular, so you can add new commands to AppleScript by merely dropping a new item into the Scripting Additions folder. Leave it be.

**AppleScript Guide**

(In the AppleScript folder, which is in the Apple Extras folder)

This item consists of a pair of SimpleText documents, Using AppleScript part 1 and Using AppleScript part 2.

Why is Using AppleScript in two parts? Because there's a limit to the size of SimpleText documents, and there's more stuff you need to know than can fit in a single document file. That's why, I think.

It doesn't matter why there are two of them. If you want to learn AppleScript, I strongly recommend that you read them. Both. They're dry but not as boring as they look once you get started.

**Script Editor**

(In the AppleScript folder, which is in the Apple Extras folder)

Script Editor is the program with which you edit scripts. Duh. I describe how to use it in a minute.

**The Automated Tasks folder**

(In the AppleScript folder, which is in the Apple Extras folder)

The Automated Tasks folder contains several useful scripts. Open and read the About Automated Tasks SimpleText document at your earliest convenience; it explains each of the tasks so I won't waste the space.

There's an alias of the Automated Tasks folder in your Apple Menu Items folder (Mac OS 7.6 put it there for you — isn't that thoughtful?), so you can select any of these useful scripts right from the Apple menu.

Please note that Apple may have changed the names of some of the scripts before this book went to press. Also note that Apple will probably add and remove some scripts that the Installer installs as time goes by. So if you can't seem to find on your hard drive some of the scripts that I mention on the next few pages, there's nothing wrong with your System. Apple just changed the software.
Chapter 13: How to Write an AppleScript in 21 Minutes

But wait, there's more

If you want to use AppleScript with programs other Mac OS 7.6 (many but not all of which are scriptable), they have to be AppleScript enabled, which means that they have to be adapted by their developers to work with AppleScript.

There are three levels of AppleScript support found in applications: scriptability, recordability, and attachability. Programs can support one, two, or all three levels.

Unfortunately, there is no easy way of telling whether a program is AppleScript enabled at all, much less if it's recordable or attachable. For what it's worth, the Finder supports all three levels.

Here are brief descriptions of the three levels of AppleScript support that you may find in third-party programs:

Scriptable programs
Scriptable means that the program can follow instructions sent by AppleScript scripts. Scriptable apps are the most common kind. If a program proclaims that it supports AppleScript, it's at this level at least.

Unfortunately, it's up to the developer to decide how much of the program is actually scriptable, so some programs are more scriptable than others. Microsoft Excel, FileMaker Pro, PageMaker (limited support), and Now Up-to-Date/Now Contact are a few scriptable programs I know of.

Recordable programs
Recordable programs go scriptable programs one better. Recordable means that you can record your actions in the program and automatically create an AppleScript script for future playback based on what you did within the program. Few programs are recordable yet.

Attachable programs
Attachable programs are even rarer than recordable ones. Attachable means that the program will let you attach a script to an item or element in a document, such as a cell in a spreadsheet, a button in a database, or a rectangle in a drawing. The Finder is attachable because you can attach a script to an icon.
What it all means

At this point, you should know at least this much:

- AppleScript is a kind of recording and playback mechanism for repetitive tasks on your Mac.
- Some programs, most notably Mac OS 7.6's Finder, can be scripted to do some things under script control.
- A few programs can record and attach scripts.

Notice I didn't say understand up there; I said know. To develop true understanding would require far more pages than I've got. But I had to mention this stuff so that when you try to use a script with a nonscriptable (or nonrecordable or nonattachable) program, you have at least a vague idea of why it's not working.

Writing a Simple Script

I agonized for a long time over this section. I wanted to teach you something useful, but it had to be easy enough to show in just a few pages.

I've realized that it can't be done. If a script is useful, it's going to require more explaining than I have space for. (And most of the easy, useful scripts are already done for you and thoughtfully placed in the Automated Tasks or More Automated Tasks folder.) So instead, I'm going to show how to write a script that's totally dumb but fun to watch.

If you want to see smart scripts, open any of the ones in the Automated Tasks or More Automated Tasks folders (in the AppleScript folder in the Apple Extras folder) and examine it closely.

1. Launch the Script Editor application.
   A new, untitled script appears on the screen.

2. Type My first stupid script in the description field at the top of the document window.

3. Click the Record button.
   After a brief pause, your screen should look more or less like Figure 13-1. Notice the tiny image of a cassette tape where the Apple menu's Apple logo used to be. It flashes to let you know that you're recording.
4. Make the Finder active by clicking the desktop or any open windows or choosing Finder in the Application menu.

5. Close all open windows (Option-Click any window's close box, hold the Option key and choose File/Close All, or use the keyboard shortcut Command-Option-W). If there are no open windows on your screen, ignore this step.

6. Create a new folder on the desktop (File/New Folder or Command-N).

7. Open the new, untitled folder and then click its title bar and drag it to a new location. The farther you drag it, the better.

8. Click the zoom box (on the far right side of the title bar) of the untitled folder window. Click it again.

9. Drag the folder to another new location.

10. Return to the Script Editor application and click the Stop button.

That's it! You've written your first script. It should look something like Figure 13-2. Don’t save it yet. (As you’ll see in a moment, there are choices yet to make about how to save your script.)
To see how your script works, click the Run button. Watch closely, as it happens fast. If you blinked and missed it, run the script again. It switches to the Finder, closes all open windows, creates a new folder, moves it, grows it, grows it again, and then moves it again.

I'm fudging a little when I say that you wrote a script. Actually, you recorded a script. If you had written it, you would have typed all the stuff between “tell application Finder” and “end tell” from memory, without actually performing the actions.

In fact, the most effective way to use AppleScript is a combination of recording and writing. First record your actions, then analyze the script, and then try to figure out ways to perform each action more efficiently by typing in different commands and trying them. To reach this level of scripting mastery, you need to know a lot more about the AppleScript language than this chapter can teach you.

Okay. You can return to the Finder and trash those untitled folders (one was created each time you ran the script).

So that’s how to record a script.

There is one more thing you should know: Unfortunately, many control panels are not scriptable (Monitors & Sound and Sharing Setup are special cases).

If a Script Is Any Good, It Should Be Saved

There are a three different ways to save a script. If you choose Save or Save As from the File menu in the Script Editor, a pop-up menu in the Save dialog box gives you your choices (see Figure 13-3).
The Text option creates a text file of your script. This script can be opened in any text editor for editing or reopened by Script Editor.

The Compiled Script option creates a Script Editor file. You can open, run, or modify the file with the Script Editor program.

The Application option creates a self-running script that executes when you open its icon.

The files in the Automated Tasks folder are scripts saved as applications.

If the Never Show Startup Screen check box is unchecked in the Save dialog box (it's checked in Figure 13-4), your script will display a startup screen with a Run button before it executes, as shown in Figure 13-5.
If you check the Stay Open check box, the script application remains open until you quit it. Scripts saved with this option usually look for something to happen and then perform an action.

The Alert When Folder Changes script in the More Automated Tasks folder is one of these stay-open-and-watch applications.

Run Only means the saved file can't be edited. You would use the Save As Run Only command (in the File menu) if you had a spiffy script that you didn't want others to see or modify. Anyway, a Run Only script can never be modified. If you choose Save As Run Only instead of Save or Save As, the resulting file will be a Run Only application or compiled script (you can't save a Run Only text file).
Chapter 14
What Can Stay and What Can Go

In This Chapter
- Reclamation theory
- Restoring deleted files
- Extensions and control panels explained
- Control panels
- Extensions
- The rest of the stuff in your System Folder

This chapter is by far the most useful chapter in the book. In this chapter, I go through the entire System Folder one item at a time. I show you how much RAM each item uses, how much disk space it occupies, and what (if any) side effects will occur if you delete or disable it.

There are no substitutes for RAM or hard disk space. But no matter how much you have, there will come a day when you need more of one or the other or both.

Yes, there are band-aids like virtual memory or RAM Doubler (for making your Mac think it has more RAM than it does) or Stuffit SpaceSaver or AutoDoubler or other compression software (for making your hard disk think it's bigger than it is). And yes, I think you can use programs like these safely most of the time.

Most of the time. RAM Doubler doesn't pose much threat, as it doesn't really deal with files or the file system. Compression software, on the other hand, adds another layer of complexity to your Mac. It's always expanding and compressing files in the background, reading and writing from the hard disk. So there's more chance for errors to occur. And all compression software extracts a noticeable performance penalty, slowing down your Mac anywhere from a little to a lot, depending on the compression software, your Mac model, and the speed of your hard disk.
My advice: Resort to those devices if you must, but *real* RAM and hard disk space are much better.

**Reclamation Theory**

RAM and hard disks are expensive. Thus, I created this chapter, a first, I believe, in System software book history, a chapter dedicated to telling you how to get rid of the deadweight among the 65 or so megabytes of files (assuming a full install of Mac OS 7.6 and all its optional bells and whistles) in your System Folder by deleting or disabling.

Let’s face it: Mac OS 7.6 puts a lot of files on your hard disk even if you don’t choose one of the optional installations. If you do install all of the options, it installs a whopping 545 files and folders, give or take a few. Not everybody needs every single one of these files; many of them can be deleted to free up (reclaim) hard disk space.

And another thing: Many control panels and extensions load into RAM at startup. So not only do they take up disk space, extensions and control panels can use up your valuable RAM too.

This chapter lists every item that Install Mac OS can install, including all the Custom installation options like QuickTime 3D, QuickTime GX, OpenDoc, Cyberdog, Remote Access, and so on. So unless you’ve installed every one of the custom options (see Appendix B), you may not see every file or folder mentioned in this chapter.

**Life After Death: The Truth about Restoring Deleted Files**

Before I can show you how to save RAM and disk space, I need to briefly cover a couple of important topics: backing up and reinstalling.

**Back up first**

If you don’t have a backup and you don’t have a set of Mac OS 7.6 install disks or the CD-ROM, DO NOT DELETE ANY FILES! I repeat: If you don’t have a backup and a set of Mac OS 7.6 install disks or CD, DON’T TRASH ANYTHING.
Other benefits of a lean, mean System Folder

There are a bunch of other benefits to keeping your System Folder lean and mean:

- The Apple menu submenu for the Control Panels folder will be shorter.
- The Control Panels folder will contain fewer items and thus be easier to manage.
- The Chooser will be less cluttered when you get rid of printer drivers you’ll never need.
- Your Mac may start up and run faster if you don’t load unneeded extensions and control panels.

That said, if you’re faithful about making backups (you should be, as you’ve heard me harp about it enough times by now; read Appendix B again if you’re still unclear), you can delete files with relative impunity. If you decide you miss them, restore them from your backup.

Beware if you only have one backup set of disks or cartridges. Your backup software may keep a mirror image of your hard disk on the backup media. In other words, when you delete a file from your hard disk, the backup software may delete it from the backup disk(s). Read your backup software manual carefully.

Install Mac OS: Restorer of lost items

Any System software file you delete can be restored if you have a set of Mac OS 7.6 install disks or the CD-ROM. The degree of difficulty you’ll encounter (and the amount of time it will take you) depends on what you need to restore.

To reinstall any extensions or control panels you delete, just run Install Mac OS (see Appendix A) and reinstall anything and everything in one fell swoop.

Certain other Mac OS functions, such as Apple Remote Access, OpenDoc, Cyberdog, and others, can be installed individually. Click the Customize button in Install Mac OS and you’ll see what’s what.

I still want to know why I can’t install just the Find File extension (or any other single extension or control panel) using the Custom Install option. Apple?

Anyway, that’s all you need to know at this time. It’s okay to trash any piece of Mac OS 7.6 as long as you have a set of Install disks (or the CD-ROM) so that you can reinstall it if you discover you need or want it.
Part III: U 2 Can B A Guru

Another thing to consider if you have a Zip, Jaz, SyQuest, or optical disk drive — perform a full install on a cartridge and set it aside for a rainy day. That way, if you delete something and later want it back, you can just drag it over rather than perform a complete reinstallation.

Just a thought. . . . Now let's move on and discover . . .

What, Exactly, Are Extensions and Control Panels?

Control Panels and Extensions appear first and second in the chapter because they make the most difference in reclaiming disk space and RAM. (I cover the rest of the System Folder later in the chapter.)

Extensions and control panels are a type of System software file with a special property: If they are not in the Control Panels or Extensions folder at startup, they do not load and/or will not function. (Or at least most won't. A few control panels can be used even if they aren't in the Control Panels folder at startup.)

Apple isn't the only one to make extensions and control panels. Many popular third-party programs, including famous names like After Dark, QuicKeys, and Now Utilities, are extensions or control panels.

Most extensions and control panels grab a certain amount of RAM when they load at startup. If you choose Apple menu→About this Macintosh right now, you'll see how much RAM they're using by looking at the bar for your System software, which includes the RAM used by all loaded extensions and control panels.

Some control panels can be run from a floppy disk. In other words, if you're really tight on hard disk space, you can copy certain control panels, such as Color or Date & Time, to a floppy disk and open the copy on the floppy if you need to change color, date, or time. Alas, this feature is only available with a handful of control panels. The rest must be in the System Folder at startup or they won't work. When in doubt, try it out.

Disabling 'em all with the Shift key

You can disable all control panels and extensions by holding down the Shift key during startup until you see the "Extensions Disabled" message appear beneath the "Welcome to Mac OS" greeting. That's what I've done in Figure 14-1. So my naked System software uses 4,019K of RAM, leaving me 94,166K available for running applications (the Largest Unused Block in Figure 14-1).
Sharp-eyed readers will notice that I have more RAM showing in my screen shot than in earlier chapters of the book (like Chapter 9). It's true. With prices at all-time lows, I got a 64MB RAM upgrade from TechWorks and slapped it into my Power Macintosh 9500.

Having lots of RAM is way cool. I never get "not enough memory to open the program" messages any more. Even with seven programs open at the same time!

**Discriminating disablimg with Extensions Manager**

When I use the Extensions Manager control panel to turn on all of the Mac OS 7.6 extensions and control panels (by choosing Mac OS 7.6 All from the Selected Set pop-up menu), the System software uses 7,477K of RAM, leaving me less RAM for programs (the Largest Unused Block in Figure 14-2). Notice that RAM used by "System Software" includes RAM grabbed at startup by optional stuff like QuickDraw GX, QuickDraw 3D, OpenDoc, and so on.
In the bad old days, disabling extensions and control panels was a messy affair that entailed moving them out of the Extensions or Control Panels folder manually and rebooting. It wasn't long before a wide variety of third-party extension/control panel managers appeared on the market. Prior to System 7.5, almost everyone I know used one.

Here's an example of why you might want to disable a few: You can reclaim more than a megabyte of RAM by just disabling the QuickDraw GX extension and the -ATM and control panel!

In the rest of the chapter, when I say how much RAM you save by disabling an extension or control panel, I mean that's how much RAM you save by turning it off (that is, unchecking it) in the Extensions Manager control panel. (Of course, you also save that amount of RAM if you delete the file totally.)

The disk space measurement for each file is the size shown in list view in the Finder. The Power Macintosh 9500 I used had a 2-gigabyte hard disk. If you have a larger disk, the files may occupy slightly more space on your disk than the numbers shown in this chapter, due to something called file allocation blocks, which is complicated and not important.

In other words, your mileage may vary — and my disk-size figures are just estimates provided for your convenience. Or, in other, other words, many of the files that "weigh" 32K on my 2-gig drive will "weigh" 16K or less on hard disks smaller than mine because of that file allocation block thing you don't need to know about.

The same goes for my RAM measurements. Your mileage may vary slightly. I measured RAM usage with a wonderful shareware extension/control panel manager called Symbionts, of which I'm proud to be a registered owner. If you use other software to measure RAM usage, your numbers may be slightly higher or lower.

One final thing: I performed all the testing for this chapter using a freshly installed copy of Mac OS 7.6 and all its optional parts. If you have other files in your System Folder, they're not part of the Mac OS.

In your System Folder, you'll see several folders with "(disabled)" after their names, such as Control Panels (disabled) and Extensions (disabled). Leave them alone. They are used by the Extensions Manager to disable control panels and extensions by moving them into these folders. Remember, if the control panel or extension isn't in the Control Panels or Extensions folder at startup, it doesn't load.
Control Panels

These control panels are covered in depth in Chapter 12. If you don't understand the cryptic comments or side effects, try reading that control panel's entry in Chapter 12.

Apple Menu Options
Disk Space: 60K
RAM Used: 47K
Side effects if disabled or deleted: Loss of Apple menu submenus and Recent Item tracking.
Comments: I'd keep it. I love submenus and Recent Item tracking. Unless I were terribly RAM-constrained (using an 8MB or even a 16MB Mac), I would never even consider disabling it, much less deleting it.

AppleTalk
Disk Space: 250K
RAM Used: 0
Side effects if disabled or deleted: Possible loss of printing and network services (shared disks, e-mail, and so forth).
Comments: If you're on a network, you definitely need it. If you have a printer connected, you definitely need it. Since it uses no RAM, I'd say leave it alone unless you're horribly short of disk space, in which case you may trash it. (But trust me, you'll probably want it back soon for one reason or another.)

Auto Remounter (PowerBook)
Disk Space: 32K
RAM Used: 12K
Side effects if disabled or deleted: Loss of capability to automatically remount disks after sleep or shutdown.
Comments: You only need it if you have a PowerBook you connect to a network. Otherwise, turn it off in Extensions Manager or trash it.

Color
Disk Space: 32K
RAM Used: 0
Side effects if disabled or deleted: Loss of capability to change window and text highlight color.
Comments: Keep it or you'll be stuck with the same window and text highlight color for the rest of your life. (Gasp.)
ColorSync System Profile

Disk Space: 32K
RAM Used: 0
Side effects if disabled or deleted: Loss of capability to use ColorSync.
Comments: Get rid of it unless you use ColorSync on all your monitors, printers, and scanners.

Control Strip

Disk Space: 63K
RAM Used: 28K
Side effects if disabled or deleted: Loss of use of Control Strip and all its modules.
Comments: If you like and use Control Strip, keep it; if you hate Control Strip and never want to see it again, trash it.

To save another 200-plus kilobytes of disk space, also trash the Control Strip Modules folder in the System Folder while you’re trashing the Control Strip control panel.

Date & Time

Disk Space: 95K
RAM Used: 5K
Side effects if disabled or deleted: Loss of capability to set Macintosh internal clock.
Comments: Keep it. If your hard disk is horribly crowded, this is one of the control panels that you can copy to a floppy disk and use, even if it wasn’t in the Control Panels folder at startup.

Desktop Patterns

Disk Space: 284K
RAM Used: 0
Side effects if disabled or deleted: Loss of capability to change desktop pattern.
Comments: Can be run from a floppy if you must.

DialAssist

Disk Space: 32K
RAM Used: 0
Side effects if disabled or deleted: Loss of dialing assistance for Apple Remote Access.
Comments: Keep it if you use ARA; otherwise, feel free to dump it.
Chapter 14: What Can Stay and What Can Go

**Editor Setup**
Disk Space: 284K  
RAM Used: 0  
Side effects if disabled or deleted: Loss of ability to choose OpenDoc parts editors.  
Comments: If you use OpenDoc (or Cyberdog), leave it alone. Otherwise, you don’t need it.

**Energy Saver**
Disk Space: 221K  
RAM Used: 0  
Side effects if disabled or deleted: No automatic screen dimming and sleep (on EnergyStar-compliant models only).  
Comments: If it works with your Mac and monitor and you like it, keep it. If not, trash it. But I warn you: Trashing it is not ecologically correct. See also *Energy Saver Extension* in the next section.

**Extensions Manager**
Disk Space: 189K  
RAM Used: 0  
Side effects if disabled or deleted: Loss of capability to enable and disable individual control panels and extensions.  
Comments: You need it. Keep it.

**File Sharing Monitor**
Disk Space: 32K  
RAM Used: 0  
Side effects if disabled or deleted: Loss of capability to monitor network traffic or disconnect users from your disk.  
Comments: If you don’t use file sharing, you don’t need it.

**General Controls**
Disk Space: 95K  
RAM Used: 24K  
Side effects if disabled or deleted: Too numerous to mention.  
Comments: Keep it. If 95K of hard disk space or 24K of RAM makes a difference to you, you’ve got bigger problems, and disabling or trashing the General Controls control panel isn’t going to help you.

You can get along without General Controls, but you won’t be able to change any of its settings without first putting it back in the Control Panels folder and restarting your Mac. It won’t run if you try to launch it from a floppy; it has to be in the Control Panels folder when you start up or it won’t work.
Keyboard
Disk Space: 32K
RAM Used: 0
Side effects if disabled or deleted: Loss of capability to specify key repeat speed and rate or choose foreign language keyboard layouts.
Comments: Keep it.

Labels
Disk Space: 32K
RAM Used: 0
Side effects if disabled or deleted: Loss of capability to change names or colors of labels (as seen in the Finder’s Label menu).
Comments: Your call. I never use it. But at a mere 32K of disk space, there’s not much to be gained by deleting it, and you might miss it some day.

Launcher
Disk Space: 130K
RAM Used: 0
Side effects if disabled or deleted: Loss of Launcher window.
Comments: You’ve already heard what I think about Launcher (Chapter 6, if you’ve forgotten already). I trashed mine.

Mac OS Easy Open
Disk Space: 189K
RAM Used: 0
Side effects if disabled or deleted: Loss of capability to configure Macintosh Easy Open (refer to Chapter 12).
Comments: Keep it.

MacLinkPlus Setup
Disk Space: 63K
RAM Used: 32K
Side effects if disabled or deleted: Loss of ability to configure MacLinkPlus translators.
Comments: If you never deal with files from DOS or WinDoze computers or never see messages that say, “an application can’t be found for this document,” you don’t need it. Still, I’d keep it if I were you.

Map
Disk Space: 63K
RAM Used: 0
Side effects if disabled or deleted: Loss of map.
Comments: Big deal. Trash it.
Chapter 14: What Can Stay and What Can Go

**Memory**
Disk Space: 63K  
RAM Used: 0  
Side effects if disabled or deleted: Too numerous (and awful) to mention (refer to Chapter 9 for details).  
Comments: Do not delete!

**Modem**
Disk Space: 252K  
RAM Used: 0  
Side effects if disabled or deleted: Possible loss or disruption of modem services.  
Comments: If you use a modem, keep it.

**Monitors & Sound**
Disk Space: 189K  
RAM Used: 0  
Side effects if disabled or deleted: Loss of capability to switch monitor color depths, alert sounds, and sound volume. Loss of additional capabilities if you have more than one monitor or a multisync monitor.  
Comments: Keep it.

**Mouse**
Disk Space: 32K  
RAM Used: 0  
Side effects if disabled or deleted: Loss of capability to change mouse tracking or double-click speed.  
Comments: Keep it.

**Numbers**
Disk Space: 32K  
RAM Used: 0  
Side effects if disabled or deleted: Loss of capability to change thousands separators, decimal separators, and symbols for currency.  
Comments: I've never used it.

**PC Exchange**
Disk Space: 347K  
RAM Used: 19K  
Side effects if disabled or deleted: Loss of capability to mount PC-formatted (DOS-formatted) floppy disks.  
Comments: If you never get or use DOS disks, you can safely delete it. If you occasionally have to deal with DOS disks, disable it with Extensions Manager and save 19K of RAM.
PPP
Disk Space: 473K
RAM Used: 0
Side effects if disabled or deleted: Loss of ability to connect to Internet.
Comments: If you use the Internet, keep it; if you don’t, you don’t need it.

If you’re on a network but don’t use the Internet, check with your network administrator before trashing this (or any other) piece of System Software.

QuickTime Settings
Disk Space: 32K
RAM Used: 0
Side effects if disabled or deleted: Loss of AutoPlay features for CDs and CD-ROMs and some MIDI (Musical Instrument Digital Interface) configuration options.
Comments: Your call. If you need it, you probably know it.

Remote Access Setup
Disk Space: 63K
RAM Used: 9K
Side effects if disabled or deleted: Loss of ability to access your Mac remotely.
Comments: Like the old doctor joke, if you want to make remote connections to your Mac, don’t trash it. Conversely, if you never dial in to your computer, trash that puppy.

Sharing Setup
Disk Space: 32K
RAM Used: 0
Side effects if disabled or deleted: Loss of capability to turn file sharing (and program linking) on or off.
Comments: You only need it if you use file sharing. If you never use file sharing, make sure it’s turned off before you delete it.

Speech
Disk Space: 126K
RAM Used: 37K
Side effects if disabled or deleted: Loss of ability to use Talking Alerts and Text-to-Voice.
Comments: Your call. It does use a little RAM and its 3-megabyte Voices folder, which you’ll find in the Extensions folder, takes up a bit of disk space. I think the voices are cute and am keeping them.
Chapter 14: What Can Stay and What Can Go

**Startup Disk**

- Disk Space: 32K
- RAM Used: 0
- Side effects if disabled or deleted: Loss of capability to choose a startup disk if more than one disk with a System folder is connected at startup.
- Comments: You may need it someday, especially if you’re going to add an additional storage device — external hard disk, SyQuest, Zip, Jaz, or magneto-optical disk drive, or whatever. I say keep it.

**TCP/IP**

- Disk Space: 315K
- RAM Used: 0
- Side effects if disabled or deleted: Loss of ability to connect to Internet.
- Comments: If you use the Internet, keep it; if you don’t, you don’t need it.

If you’re on a network but don’t use the Internet, check with your network administrator before trashing this (or any other) piece of System Software.

**Text**

- Disk Space: 32K
- RAM Used: 0
- Side effects if disabled or deleted: Loss of capability to choose Text Behaviors.
- Comments: If you only run the American version of Mac OS 7.6, you’ll probably never need it.

**Users & Groups**

- Disk Space: 32K
- RAM Used: 0
- Side effects if disabled or deleted: Loss of capability to create users and groups for file sharing.
- Comments: If you don’t use file sharing, you don’t need it.

**Views**

- Disk Space: 32K
- RAM Used: 0
- Side effects if disabled or deleted: Loss of capability to configure Finder views.
- Comments: Keep it.

**WindowShade**

- Disk Space: 32K
- RAM Used: 7K
- Side effects if disabled or deleted: Loss of capability to roll up windows.
- Comments: I love it. I’m keeping mine.
Control panels by RAM used

Table 14-1 is a quick-reference chart of the control panels in descending order of RAM usage.

<table>
<thead>
<tr>
<th>Control Panel</th>
<th>RAM Used</th>
</tr>
</thead>
<tbody>
<tr>
<td>~ATM</td>
<td>900K</td>
</tr>
<tr>
<td>Apple Menu Options</td>
<td>47K</td>
</tr>
<tr>
<td>Speech</td>
<td>37K</td>
</tr>
<tr>
<td>MacLinkPlus Setup</td>
<td>32K</td>
</tr>
<tr>
<td>Control Strip</td>
<td>28K</td>
</tr>
<tr>
<td>General Controls</td>
<td>24K</td>
</tr>
<tr>
<td>PC Exchange</td>
<td>19K</td>
</tr>
<tr>
<td>MacOS Easy Open</td>
<td>16K</td>
</tr>
<tr>
<td>Auto Remounter</td>
<td>12K</td>
</tr>
<tr>
<td>WindowShade</td>
<td>7K</td>
</tr>
<tr>
<td>Date &amp; Time</td>
<td>5K</td>
</tr>
</tbody>
</table>

The rest of the items in your Control Panels folder use no RAM, even if they’re in the Control Panels folder at startup.

Control panels by disk space used

Table 14-2 is a quick-reference chart of the control panels in descending order by amount of disk space they consume.
### Table 14-2: Control Panel Disk Space Usage

<table>
<thead>
<tr>
<th>Control Panel</th>
<th>Disk Space</th>
</tr>
</thead>
<tbody>
<tr>
<td>~ATM</td>
<td>1.4MB</td>
</tr>
<tr>
<td>PPP</td>
<td>473K</td>
</tr>
<tr>
<td>PC Exchange</td>
<td>347K</td>
</tr>
<tr>
<td>TCP/IP</td>
<td>315K</td>
</tr>
<tr>
<td>Desktop Patterns</td>
<td>284K</td>
</tr>
<tr>
<td>Modem</td>
<td>252K</td>
</tr>
<tr>
<td>AppleTalk</td>
<td>250K</td>
</tr>
<tr>
<td>Energy Saver</td>
<td>221K</td>
</tr>
<tr>
<td>Extensions Manager</td>
<td>189K</td>
</tr>
<tr>
<td>Mac OS Easy Open</td>
<td>189K</td>
</tr>
<tr>
<td>Monitors &amp; Sound</td>
<td>189K</td>
</tr>
<tr>
<td>Speech</td>
<td>126K</td>
</tr>
<tr>
<td>Date &amp; Time</td>
<td>95K</td>
</tr>
<tr>
<td>General Controls</td>
<td>95K</td>
</tr>
<tr>
<td>Apple Menu Options</td>
<td>63K</td>
</tr>
<tr>
<td>Control Strip</td>
<td>63K</td>
</tr>
<tr>
<td>Editor Setup</td>
<td>63K</td>
</tr>
<tr>
<td>Launcher</td>
<td>63K</td>
</tr>
<tr>
<td>MacLinkPlus Setup</td>
<td>63K</td>
</tr>
<tr>
<td>Map</td>
<td>63K</td>
</tr>
<tr>
<td>Memory</td>
<td>63K</td>
</tr>
<tr>
<td>Remote Access Setup</td>
<td>63K</td>
</tr>
</tbody>
</table>

AutoRemounter, Color, ColorSync System Profile, DialAssist, File Sharing Monitor, Keyboard, Labels, Mouse, Numbers, QuickTime Settings, Sharing Setup, Startup Disk, Text, Users & Groups, and Views use no appreciable amounts of RAM.
Extensions

There are three main types of extensions among the approximately 112 items in your Extensions folder:

- System extensions
- Chooser extensions
- AppleGuide documents

AppleGuide documents use no RAM, nor do most Chooser extensions. System extensions, on the other hand, almost always grab a bit of RAM at startup. There are also a couple of other kinds of files in the Extensions folder; I'll talk about them after I finish with the big three.

To see these items by type, open the Extensions folder and then choose View → By Kind. If the View by Kind option isn't available, use the Views control panel and enable Show Kind.

I want to start with the most important extensions, the ones that can save you lots of precious RAM if you disable or delete them (if, of course, you don't need them). I'm talking about your System extensions.

System extensions

**EM Extension**

Disk Space: 5K
RAM Used: 0
Side effects if disabled or deleted: Loss of use of Extensions Manager control panel.
Comments: Keep it.

Why is EM Extension first in an alphabetical list? Because Apple ships it with a space before the E so that it is first in alphabetical lists. Extensions load alphabetically, and because this is the extension that gives Extensions Manager its powers, it must load before the other extensions in order to turn them on or off.

Hold down the spacebar just after you power up your Mac to use Extensions Manager before other extensions begin to load.
Chapter 14: What Can Stay and What Can Go

**Apple Color SW Pro CMM (QuickDraw GX only)**

Disk Space: 63K  
RAM Used: 0  
Side effects if disabled or deleted: Possible loss of some color printing abilities under QuickDraw GX.  
Comments: If you use QuickDraw GX, you need it; if not, you don’t.

**Apple CD-ROM**

Disk Space: 95K  
RAM Used: 104K  
Side effects if disabled or deleted: Loss of use of CD-ROM drives.  
Comments: If you have a CD-ROM drive, keep it.

**Apple Guide**

Disk Space: 756K  
RAM Used: 24K  
Side effects if disabled or deleted: Loss of AppleGuide (interactive help).  
Comments: Tough call. It uses a great deal of disk space (if you count all its Guide files) and a significant amount of RAM, but I think it’s worth keeping. Delete or disable it only if you must.

**Apple Photo Access**

Disk Space: 189K  
RAM Used: 0  
Side effects if disabled or deleted: Loss of capability to open PhotoCD files.  
Comments: PhotoCD is the Kodak format for high-resolution image storage. PhotoCD files mostly come on CD-ROM discs. If you’re likely to encounter PhotoCD files, keep it. If you don’t have a CD-ROM drive, you definitely don’t need it.

**AppleScript**

Disk Space: 315K  
RAM Used: 41K  
Side effects if disabled or deleted: Loss of use of AppleScript scripts and Script Editor program.  
Comments: You read Chapter 13, right? You know whether you want to keep AppleScript. (I would.)

**Audio CD Access**

Disk Space: 32K  
RAM Used: 0  
Side effects if disabled or deleted: Loss of capability to play audio CDs (that is, your Pearl Jam and Elvis Costello CDs, or at least *my* Pearl Jam and Elvis CDs).  
Comments: If you don’t have a CD-ROM drive, you don’t need it. If you have a CD-ROM drive, you should probably keep it around, just in case.
**Clipping Extension**

Disk Space: 32K  
RAM Used: 0  
Side effects if disabled or deleted: Loss of Macintosh Drag and Drop features.  
Comments: Keep it.

**Color Picker**

Disk Space: 158K  
RAM Used: 2K  
Side effects if disabled or deleted: Loss of the new Apple Color Picker.  
Comments: This whole shebang refers to which Color Picker you see in programs that use a color picker to choose among colors (most graphics programs). To see one for yourself, open the Labels control panel and click any of the colors.

The new Color Picker is, in my humble opinion, prettier than the old one and probably easier to use. Trashing this extension usually has little consequence, but if you use color graphics programs of any sort, you might want to keep it around.

**ColorSync**

Disk Space: 599K  
RAM Used: 105K  
Side effects if disabled or deleted: Loss of use of ColorSync (Apple's color matching system for monitors, printing devices, and scanners).  
Comments: You probably don't need it unless you scan or print color images. And it uses a lot of RAM and disk space for something most people have no need for.

**Energy Saver Extension**

Disk Space: 95K  
RAM Used: 64K  
Side effects if disabled or deleted: No automatic screen dimming and sleep (on EnergyStar-compliant models only).  
Comments: If it works with your Mac and monitor and you like it, keep it. If not, trash it. But I warn you: Trashing it isn't ecologically correct.

**File Sharing Extension**

Disk Space: 221K  
RAM Used: 4K  
Side effects if disabled or deleted: Loss of file sharing capability.  
Comments: If you don't use file sharing, you can safely delete it.
**Find File Extension**

Disk Space: 32K  
RAM Used: OK  
Side effects if disabled or deleted: Loss of use of the new and improved Find File features (see Figure 14-3).  
Comments: The Mac OS 7.6 Find File is much better than older versions. It’s faster. It displays its results in a window (the old one takes you to your file in the Finder, which is much slower), and it can search on multiple criteria (that is, name and size, or date and label, and so on). The old Find File (see Figure 14-4) can only search for one thing at a time. I wouldn’t delete or disable it.

---

**Figure 14-3:** The Mac OS 7.6 Find File. Compare it to the old-style Find File shown in Figure 14-4.

**Figure 14-4:** The old-style Find File. This is what you get if you delete or disable the Find File extension.
**Finder Scripting Extension**

Disk Space: 221K  
RAM Used: 0K  
Side effects if disabled or deleted: Loss of use of AppleScript in the Finder.  
Comments: If you use AppleScript, don’t delete or disable it.

**Foreign File Access**

Disk Space: 63K  
RAM Used: 128K  
Side effects if disabled or deleted: Loss of capability to mount some CD-ROM disks.  
Comments: If you have a CD-ROM drive, you need it; if you don’t, you don’t.

**High Sierra File Access**

Disk Space: 32K  
RAM Used: 0K  
Side effects if disabled or deleted: Loss of capability to mount some CD-ROM disks.  
Comments: If you have a CD-ROM drive, you need it; if you don’t, you don’t.

**Internet Config Extension**

Disk Space: 32K  
RAM Used: 0K  
Side effects if disabled or deleted: Internet configuration options won’t be shared among applications.  
Comments: Cyberdog and other Internet programs may not work properly without it. If you use the Internet, keep it.

**ISO 9660 File Access**

Disk Space: 32K  
RAM Used: 0K  
Side effects if disabled or deleted: Loss of capability to mount some CD-ROM disks.  
Comments: If you have a CD-ROM drive, you need it; if you don’t, you don’t.  
(I’m sorry if I sound like a broken record, but that’s my advice.)

**MacinTalk 3 and MacinTalk Pro**

Disk Space: 378K and 819K, respectively  
RAM Used: 0  
Side effects if disabled or deleted: Loss of speech capabilities; see Speech control panel.  
Comments: If you want your Mac to talk to you, keep them; if not, don’t.  
Don’t forget to also trash the Voices folder (see next section), Speech control panel (previous section), and Speech Manager extension if you decide to trash these two.
Chapter 14: What Can Stay and What Can Go

**MacLinkPlus for Easy Open**
Disk Space: 158K
RAM Used: 0K
Side effects if disabled or deleted: Loss of automatic substitution of applications. You may experience the dreaded "An application can't be found for this document" error.
Comments: Keep it.

**Network Extension**
Disk Space: 95K
RAM Used: 0
Side effects if disabled or deleted: Loss of network services.
Comments: If you're on a network, keep it.

**Printer Share**
Disk Space: 95K
RAM Used: 12K
Side effects if disabled or deleted: Loss of capability to share certain devices, such as plotters, that could not be shared previously. Also, loss of the capability to password-protect color printers that use expensive printing materials.
Comments: If you're on a network, ask your network administrator before deleting or disabling.

**PrinterShare GX**
Disk Space: 63K
RAM Used: 0
Side effects if disabled or deleted: Loss of capability to share certain devices such as plotters that could not be shared previously. Also, loss of the capability to password-protect color printers that use expensive printing materials.
Comments: Only required if you're using QuickDraw GX. Check with your network administrator before deleting or disabling it, though.

**QuickDraw 3D**
Disk Space: 1.3MB
RAM Used: 0
Side effects if disabled or deleted: Loss of use of QuickDraw 3D.
Comments: You probably installed QuickDraw 3D for a reason. Therefore, keep it. Some game you like probably needs it.
QuickDraw GX

Disk Space: 3.2MB
RAM Used: 478K
Side effects if disabled or deleted: Loss of use of QuickDraw GX features (refer to Chapter 7).
Comments: It's a pig — half a megabyte of RAM and more than 3 megabytes of disk space. You should carefully consider whether the features of QuickDraw GX are worth the RAM and disk space they consume. Don't run it unless you need it. Also, unless your programs are specifically designed to take advantage of GX features, and most aren't, you won't see much advantage to using it.

QuickTime, QuickTime Musical Instruments, and QuickTime PowerPlug (PowerPC only)

Disk Space: 1.4MB, 473K, and 914K, respectively
RAM Used: less than 40K
Side effects if disabled or deleted: Loss of capability to play QuickTime movies or use QuickTime applications.
Comments: I leave mine enabled all the time, but I probably have more stuff that requires QuickTime than you do. If you use QuickTime, even occasionally, leave these items alone.

Remote Only

Disk Space: 32K
RAM Used: 0
Side effects if disabled or deleted: Can't access Mac from remote computer(s).
Comments: Keep it if you use Remote Access; dump it if you don't.

Shared Library Manager and Shared Library Manager PPC

Disk Space: 189K and 221K, respectively
RAM Used: 0
Side effects if disabled or deleted: Many programs and utilities will cease to function.
Comments: You need these. Don't delete them.

Speech Manager

Disk Space: 63K
RAM Used: 11K
Side effects if disabled or deleted: No speech. See also MacinTalk extensions, Speech control panel, and Voices folder.
Comments: Keep it if you want your Mac to speak.
Chapter 14: What Can Stay and What Can Go

**SystemAV**

Disk Space: 410K  
RAM Used: OK  
Side effects if disabled or deleted: Monitors & Sound control panel quits working.  
Comments: Don’t delete it.

**WorldScript Power Adapter**

Disk Space: 63K  
RAM Used: 23K  
Side effects if disabled or deleted: None, if you don’t use languages other than English. But rumor has it that this extension also speeds up some text and display functions on PowerPC Macs.  
Comments: Keep it.

**~AppleVision**

Disk Space: 378K  
RAM Used: 0  
Side effects if disabled or deleted: Only required if you have an AppleVision monitor. If so, you need it to use the Monitors & Sound control panel.  
Comments: If you don’t have an AppleVision monitor, by all means dump this sucker. (By the way, in case you were wondering, the little tilde at the start of this extension’s name forces it to bottom of this alphabetical list.)

**Chooser extensions**

Chooser extensions are extensions that appear in the Chooser desktop accessory when you open it. AppleShare is one of them; all the others are printer drivers, the software that your Mac requires to talk to a printer.

**AppleShare**

Disk Space: 78K  
RAM Used: 64K  
Side effects if disabled or deleted: Loss of use of file sharing.  
Comments: If you use file sharing, you need it; if you don’t, you don’t.

**Printer Drivers**

Disk Space: Between 63K and 819K each
RAM Used: 0
Side effects if disabled or deleted: None, as long as you leave the driver for your printer(s) — that is, the printer(s) that you use — in the Extensions folder.
Comments: You only need the driver or drivers that match the printer(s) you use. If you never use any color printer, for example, get rid of every Chooser extension with the word color in its name. If you never use an ImageWriter, get rid of all the ImageWriter Chooser extensions. And so on.

**PDD Maker GX**

Disk Space: 32K
RAM Used: 0
Side effects if disabled or deleted: Loss of capability to make PDD files (refer to Chapter 7 for details).
Comments: I'm keeping mine.

**Apple Guide documents**

There may be as many as ten Apple Guide documents in the Extensions folder.
Disk Space: 63K to 1.9MB
RAM Used: 0
Side effects if disabled or deleted: Loss of use of Apple Guide interactive help.
Comments: If you don't use Apple Guide, you can safely delete all of the Guide files. But I'd leave them alone. You never know when you'll need help, and if you delete these files, help won't be available when you need it.

**Other items in the Extensions folder**

**Desktop PrintMonitor and PrintMonitor**

Disk Space: 126K and 63K, respectively
RAM Used: 175K and 160K, respectively
Side effects if disabled or deleted: Loss of capability to print in background.
Comments: Keep them.

PrintMonitor and Desktop PrintMonitor are not extensions, although they live in the Extensions folder. They are both applications. Thus, they only use RAM when background printing is taking place.

If you have problems with background printing, try increasing PrintMonitor's (or Desktop PrintMonitor's, if you use desktop printers) preferred memory size (in the Get Info window).
Chapter 14: What Can Stay and What Can Go

**Ethernet (Built-In)**

- Disk Space: 95K
- RAM Used: 0
- Side effects if disabled or deleted: Can't use Ethernet.
- Comments: If you're not on an Ethernet network, you don't need it.

**OpenTptAppleTalkLib, OpenTptInternetLib, and OpenTransportLib**

- Disk Space: about 800K all together
- RAM Used: about 200K
- Side effects if disabled or deleted: Loss of ability to use Internet and networking features.
- Comments: Leave it alone if you use a network or the Internet. Even if you don't, you may someday need these things. Disable them in Extensions Manager if you must, but leave them on your hard disk if you can.

**VT102 Tool**

- Disk Space: 189K
- RAM Used: 0
- Side effects if disabled or deleted: Loss of ability to emulate VT102 terminal over modem.
- Comments: Unless you know what the above means and it matters to you, you can probably dump it.

**AppleScriptLib, ObjectSupportLib, and SOMObjects for Mac OS**

- Disk Space: about 300K all together
- RAM Used: 20K
- Side effects if disabled or deleted: Lots of stuff will stop working, including Cyberdog and any other OpenDoc programs.
- Comments: If you use OpenDoc, you need all three.

**PrintingLib**

- Disk Space: 600K
- RAM Used: 0
- Side effects if disabled or deleted: May lose ability to print.
- Comments: You need it for printing; don't delete it.

**QuickDraw 3D RAVE and QuickDraw 3D Viewer**

- Disk Space: 126K and 189K, respectively
- RAM Used: 0
- Side effects if disabled or deleted: QuickDraw 3D won't work.
- Comments: If you use QuickDraw 3D, keep 'em; if not, junk 'em.
Serial Port Arbitrator, Open Tpt AppleTalk Library, Open Tpt Internet Library, Open Transport Library, OpenTpt Modem, and OpenTpt Remote Access

Disk Space: a couple of megabytes
RAM Used: 200K
Side effects if disabled or deleted: Loss of Internet or network services.
Comments: If any of these items are in your System Folder, you need them.

Folders in the Extensions folder

There are also several folders in the System Folder; you may or may not need them or their contents.

Global Guide Files
This folder contains almost a megabyte of Apple Guide files for optional programs like Apple Audio, Apple Button, Apple Draw, Apple Image Viewer, OpenDoc Guide, and Apple 3DMF Viewer. Feel free to trash any that you don’t need.

Modem Scripts
This folder contains over 3MB of modem stuff, most of which you don’t need. You can trash all but the one that matches your modem if you need the disk space.

Multiprocessing
You don’t need this folder or its contents unless your Mac has multiple processors (few do, at least not so far).

OpenDoc Libraries
This folder contains files used by OpenDoc. If you use OpenDoc (or Cyberdog), leave it alone.

Printer Descriptions
This folder in your Extensions folder contains printer description files for 21 Apple printers. Each requires 15K of disk space and uses no RAM. You can delete all but the one (or ones) that match your printer or printers.

Scripting Additions
This one contains components of AppleScript. Removing any of the files in this folder may cause AppleScript to behave erratically. If you use AppleScript, leave this folder alone. If you don’t use AppleScript and never plan to, you can delete it.
Voices
This 3 MB folder contains the voices used by Speech and MacinTalk. If you don’t need the voices, you don’t need the folder. And if you only use one a couple of voices, delete the ones that you don’t use.

Extensions by RAM used
Table 14-3 is a quick-reference chart of the extensions, sorted in descending order by RAM usage.

<table>
<thead>
<tr>
<th>Extension</th>
<th>RAM Used</th>
</tr>
</thead>
<tbody>
<tr>
<td>QuickDraw GX</td>
<td>478K</td>
</tr>
<tr>
<td>OpenTransportLib</td>
<td>194K</td>
</tr>
<tr>
<td>Foreign File Access</td>
<td>128K</td>
</tr>
<tr>
<td>ColorSync</td>
<td>105K</td>
</tr>
<tr>
<td>Apple CD-ROM</td>
<td>103K</td>
</tr>
<tr>
<td>Printing Lib</td>
<td>97K</td>
</tr>
<tr>
<td>AppleShare</td>
<td>65K</td>
</tr>
<tr>
<td>Energy Saver Extension</td>
<td>64K</td>
</tr>
<tr>
<td>AppleScript</td>
<td>41K</td>
</tr>
<tr>
<td>QuickTime</td>
<td>37K</td>
</tr>
<tr>
<td>AppleGuide</td>
<td>24K</td>
</tr>
<tr>
<td>WorldScript Power Adapter</td>
<td>23K</td>
</tr>
<tr>
<td>ObjectSupportLib</td>
<td>18K</td>
</tr>
<tr>
<td>Printer Share</td>
<td>12K</td>
</tr>
<tr>
<td>Speech Manager</td>
<td>12K</td>
</tr>
</tbody>
</table>

All other extensions use 5K or less of RAM

Extensions by disk space used
To see a list of items in your Extensions folder in descending order of size, first use the Views control panel to turn on Calculate Folder Sizes; then choose View→By Size. The Extensions folder window now displays its contents in descending size order.
The Rest of the Stuff in Your System Folder

The installer installed more than just control panels and extensions. Here's what the rest of it does:

**Apple Menu Items**
The Apple Menu Items folder, covered extensively in Chapter 4, contains some folders, some desk accessories, and some applications.

The items in your Apple Menu Items folder only use RAM after you open them. So don't get rid of them to save RAM. If you're really short on disk space, Table 14-5 shows how much each Apple Menu Item uses.

<table>
<thead>
<tr>
<th>Item</th>
<th>Disk Space</th>
</tr>
</thead>
<tbody>
<tr>
<td>Graphing Calculator</td>
<td>512K</td>
</tr>
<tr>
<td>Apple System Profiler</td>
<td>100K</td>
</tr>
<tr>
<td>Find File</td>
<td>256K</td>
</tr>
<tr>
<td>Jigsaw Puzzle</td>
<td>112K</td>
</tr>
<tr>
<td>Stickies</td>
<td>112K</td>
</tr>
<tr>
<td>SimpleSound</td>
<td>96K</td>
</tr>
<tr>
<td>Note Pad</td>
<td>80K</td>
</tr>
<tr>
<td>Scrapbook</td>
<td>64K</td>
</tr>
<tr>
<td>Chooser</td>
<td>32K</td>
</tr>
<tr>
<td>AppleCD Audio Player</td>
<td>32K</td>
</tr>
<tr>
<td>Automated Tasks</td>
<td>32K</td>
</tr>
<tr>
<td>Calculator</td>
<td>32K</td>
</tr>
<tr>
<td>Control Panels</td>
<td>32K</td>
</tr>
<tr>
<td>Key Caps</td>
<td>32K</td>
</tr>
<tr>
<td>Remote Access Disconnect</td>
<td>32K</td>
</tr>
<tr>
<td>Shut Down</td>
<td>32K</td>
</tr>
</tbody>
</table>

The only one that's an easy call is Jigsaw Puzzle, which is totally useless. (Wife Lisa chimes in: "Don't tell them that! I like the Mac jigsaw puzzle — the kids can't hide the pieces.") The other items are all useful in some way, and I'd recommend keeping them around.
The difference between applications and desk accessories

I promised in Chapter 4 that I'd explain the difference between an application and a desk accessory (DA) here in Chapter 14. Being a man of my word, here goes:

Desk accessories are a throwback to System 4 and earlier, when there was no multitasking, and there was no way to run more than one program at a time. Desk accessories were miniprograms that could be used even while other programs were open.

These days, now that opening multiple programs is the norm, desk accessories are the same as other programs — with three little differences:

- In list views, under the Kind category, desk accessories are listed as desk accessories (duh), not applications.
- You can't change a desk accessory's Minimum or Preferred memory requirements.
- Every desk accessory uses 20K of RAM (in About This Macintosh).

For all intents and purposes, a desk accessory is the same as an application program.

**Clipboard**

- Disk Space: varies
- RAM Used: 0
- Side effects if disabled or deleted: Loss of Clipboard contents at the moment of deletion.
- Comments: This file is like a chameleon's tail — it regenerates if it's damaged or destroyed. So don't bother deleting it, it'll just grow back. Besides, why would you want to?

**Control Strip Modules**

- Disk Space: 112K, more or less
- RAM Used: 0
- Side effects if disabled or deleted: Loss of use of module if it's not in this folder.
- Comments: Don't delete it if you use Control Strip. Feel free to delete individual modules you don't use if you feel like it.

**DataViz**

Contains all your important file translation stuff. Don't delete it if you use Macintosh Easy Open or MacLinkPlus.
**Finder**
Disk Space: 512K
RAM Used: N/A
Side effects if disabled or deleted: Loss of use of Mac.
Comments: Don’t even think about it. Your Mac won’t boot without a Finder.

**Editors**
Contains the editors you need for use with OpenDoc. If you use OpenDoc, leave this folder alone.

**Fonts**
Contains your fonts; leave it be.

**Launcher Items**
Contains the items that show up in Launcher; you need it if you use Launcher. If you use Launcher, leave this folder alone. If you don’t, feel free to trash it.

**Preferences**
The Preferences folder is where all programs, extensions, control panels, and desk accessories store their preferences files. These files store information that the program (or extension, control panel, or desk accessory) needs to remember between uses.

Most preferences files regenerate themselves when deleted, so trashing them is usually a waste of time.

When you get rid of a program, extension, control panel, or desk accessory, there’s a good chance that it has left behind a preferences file in the Preferences folder. It’s not a bad idea to go into your Preferences folder every so often and trash any files that belong to software no longer on your hard disk.

For example, if you decide that you never want to use the Launcher control panel again, you can delete the Launcher Preferences file. Though Launcher Preferences only uses a few K of disk space, after a while, your Preferences folder may become quite crowded with preferences files that belong to software you don’t even have on your hard disk any longer.

Ack! I just looked at the Preferences folder on my Mac and discovered almost 200 preferences files, at least half from programs that I no longer have or use.

I’ll be right back — I’m going to practice what I preach and clean it up by trashing unneeded and unwanted prefs files.
I'm back. While I was doing my spring cleaning, I remembered another good tip having to do with preferences files: Trashing a program's preferences file can sometimes fix problems with the program itself.

If you have a program, extension, control panel, or desk accessory that's acting strange in any way, crashing, freezing, or quitting unexpectedly, look in the Preferences folder and see if it's got a preferences file. If it does, try deleting it. Then restart your Mac.

This tip doesn't always work, but it's worth a try if a program that used to work starts acting funky.

By the way, some programs store all of your customized settings (key combinations, macros, window positions, and so on) in their preferences files. If you delete these files, you may have to reset some of your customized settings in these programs. In most cases, that's no big deal, but in the case of, say, my Microsoft Word preferences, I'd have to spend about three hours recustomizing all my menus and keyboard shortcuts. Not fun. In fact, I keep a backup copy of my Word prefs on a floppy just in case the file gets corrupted or somebody comes along and changes things when I'm not around.

**Scrapbook File**

- Disk Space: varies
- RAM Used: 0
- Side effects if disabled or deleted: Loss of contents of Scrapbook.
- Comments: If you don't use Scrapbook, you can delete it. But if you have anything you care about in the Scrapbook, you'll lose it when you trash this file.

**System**

- Disk Space: 4.4MB
- RAM Used: N/A
- Side effects if disabled or deleted: Loss of use of Mac.
- Comments: Don't even think of it. Your Mac won't boot if this file isn't in the System Folder.
Chapter 15

Internet-Working

In This Chapter

- An overview of the Internet
- PPP and TCP/IP
- Cyberdog
- Riding the Information Superhighway

The Internet, sometimes referred to as the Information Superhighway, is a giant worldwide network of computers. With an Internet connection, you can view text and graphics on your computer, even if the text and graphics are sitting on a computer in Tokyo. The Internet allows you to send and retrieve messages and computer files to and from almost anywhere in the world — in milliseconds. Simply put, the Internet connects your Mac to a wealth of information residing on computers around the world.

Internet Overview (Brief)

The Internet, which is really nothing more than a giant conglomeration of connected computers, offers many kinds of services. This chapter covers the top three: World Wide Web, FTP (file transfer protocol), and electronic mail.

Other services offered on the Internet include live online chatting, bulletin board discussions called newsgroups, and video conferencing. After you've got your connection set up (something I cover in a moment), I urge you to check out these nifty features. Unfortunately, due to space limitations, that’s all I’m going to say about them.

The most interesting part of the Internet, at least in my humble opinion, is the World Wide Web, the part of the Internet that lets you surf to Web sites and view them on your computer with software called a browser.
Mac OS 7.6 is the first release to offer built-in Internet connectivity right out of the box. While previous versions provided some of the plumbing, in the form of MacTCP, it was still up to you to assemble appropriate programs — browser, PPP client (you don't need to know what that means yet, but you will in a moment), FTP client, e-mail program, and so on — on your own. Mac OS 7.6 comes with its own PPP client and Cyberdog, a pretty nifty little piece of software (actually, a collection of pieces of software; see the sidebar "What's Open, Doc?" for details) that allows you to browse the World Wide Web, send and receive electronic mail, download remote files via file transfer protocol, and more.

But before I can talk about Cyberdog, I must first discuss the underlying technology — Open Transport, OpenDoc (no relation), PPP, and TCP/IP — and then help you configure your Internet connection. When all of that is done, you can play with Cyberdog to your heart's content.

So with no further ado, let's get your Internet connection set up so that you can play with the dog.

Getting Set Up for Surfing

If you're a typical home user, need three things you need to surf the Internet:

- A modem
- An account with an Internet Service Provider
- Cyberdog, Open Transport PPP, and OpenDoc installed on your Mac

If you use your Mac in an office setting, you may use something called a net modem instead of a regular modem, or you may have an altogether different (and probably much faster) way of connecting to the Internet: ISDN or T1 lines. Your network administrator (the person you run to when something goes wrong with your computer) is going to have to set up your Mac if you connect to the Internet using something other than a modem.

It starts with the modem

A modem is a small, inexpensive device that turns data (that is, computer files) into sounds and then squirts them across phone lines. At the other end, another modem receives these sounds and turns them back into data (that is, your files).
### What's Open, Doc? (or “Everything you need to know about OpenDoc in one page or less”)

OpenDoc is Apple's new plug-in software architecture. OpenDoc uses software components — called parts — that can be dragged-and-dropped into documents created by any OpenDoc-aware application. You can combine parts from different Mac OS software developers to add tables, graphs, outlines, and even live Internet resources into your documents. Because OpenDoc is a cross-platform technology, documents created with OpenDoc can work across different computer platforms, including Mac OS, Windows, UNIX, and OS/2.

Unfortunately, at this time Cyberdog is the only OpenDoc program there is. Watch for this situation to change quickly, but not as quickly as I (or Apple) would like. For example, an OpenDoc version of ClarisWorks has been delayed, and no other major programs are OpenDoc compatible, at least not as I write these words.

Installing OpenDoc adds the following stuff to your Power PC computer (note that you can only install OpenDoc on Mac OS systems with PowerPC processors):

- OpenDoc system software (in the Extensions folder)
- The Stationery folder (at the root level of your hard disk)

When you install an OpenDoc part, a stationery file is placed in the Stationery folder. You can either double-click the Stationery icon to create a new document or drag the stationery into another document to add functionality to any OpenDoc-aware application or document.

When you install OpenDoc parts, the part editors are placed in the Editors folder. Editors are like mini-applications that handle different types of data, such as text, graphics, or Internet information. When an editor is installed, it works something like a system extension: Its functionality is available, but you don't open or use the editor itself. To use an editor, you need to locate the editor's stationery (in the Stationery folder on the root level of your hard drive).

To get OpenDoc parts, contact your favorite application developers to find out if they support OpenDoc, or visit Apple's OpenDoc Web site at http://opendoc.apple.com.

---

**Tip**

There are two things to know if you're going out to buy a modem.

- Make sure it runs at 28.8 Kbps or higher or you'll be very unhappy with the speed at which you surf.
- Make sure it includes a Mac cable. Windoze computers require a different kind of modem cable, so be sure to ask.

Now plug a phone line into the modem and plug the modem cable into the modem port on the back of your Mac. It's the one with the little phone icon next to it.

That's it. Now let's set up an account with an **ISP** (Internet service provider).
Your Internet service provider and you

Now that you have a modem, you need to select a company to provide you with access to the Internet. It’s kind of like choosing a long-distance company — prices and services offered vary, often from minute to minute.

The going rate for unlimited access to the Internet is $19.95 per month. If your service provider asks for considerably more than that, find out why.

Anyway, first select a provider. Several national online services that you’ve probably heard of provide Internet access. They include as CompuServe, America Online, and Prodigy. There are also pure Internet service companies like EarthLink and Netcom. AT&T and perhaps even your cable company are in the Internet business, so shop around for the deal that works best for you.

After you’ve chosen a provider and set up an account, you need four pieces of information to make your connection:

- Your user name
- Your password
- The local phone number that your modem dials to make a connection to your provider
- Your ISP’s server name and address

When you have all these pieces assembled, you’re ready to do some configuring.

Go configure: PPP and TCP/IP

Okay, there are a few steps left before you go online and have some real fun. Hang in there; it’s easy. Just follow my instructions.

Configure the Modem control panel

1. Choose Apple menu→Control Panels→Modem to open the Modem control panel. It’s shown in Figure 15-1.

2. Choose Modem Port from the Connect via pop-up menu.

3. Choose your modem model from the Modem pop-up list; if your model isn’t listed, choose one that sounds similar. If it doesn’t work (you’ll know soon), come back and choose another modem.

4. Close the Modem control panel by clicking its close box.

There. That wasn’t too bad, was it? Now on to the next step.
Configure the PPP control panel

1. Choose Apple menu > Control Panels > PPP to open the PPP control panel. (See Figure 15-2.)

2. Type your name, password, and ISP's phone number in the appropriate fields.

   Case matters in telecommunicating. An upper case "L" is not the same as a lower case "l" in addresses, passwords, and such. So be careful. And if something doesn't work, check to make sure that you've typed the words or numbers correctly.

3. Close the PPP control panel.

We're really cooking now. Just one more step before you go online!
Configure the TCP/IP control panel

1. Choose Apple menu: Control Panels: TCP/IP to open the TCP/IP control panel. (See Figure 15-3.)

![TCP/IP Control Panel](image)

2. Choose PPP from the Connect Via pop-up menu.
3. Choose Using PPP Server from the Configure pop-up menu.
4. Type your ISP's domain name into the Starting Domain Name field.
5. Type your ISP's name server address(es) into the Name Server Address field.
6. Close the TCP/IP control panel.

That's it. You're good to go. It's time to move on and meet your new puppy, Cyberdog.

**One Cool Puppy: Meet Your New Cyberdog**

Here's Apple's official description of Cyberdog: “Cyberdog is a suite of Internet components that allows you to browse the World Wide Web, receive and send e-mail, read articles from Usenet newsgroups, browse AppleTalk zones and servers, exchange files with FTP, and log into other computers with Telnet. Cyberdog provides tight integration between these components and with other OpenDoc applications. Cyberdog also allows you to customize your use of the Internet.”
That works for me. The nice part is you don't have to go out and find any software of your own; the downside is that other software — such as Netscape Navigator, Microsoft Internet Explorer, and others — may be more powerful and robust than Cyberdog.

I'm not fudging. It's just that all of these products keep getting updated with new functionality every few months. So it's kind of like an ongoing race that will never end. Right this second, the other products have some advantages over Cyberdog. By the time you read this, Cyberdog may have eclipsed them. Or not.

Unless you're relatively Internet savvy, I recommend sticking with Cyberdog. On the other hand, if you are Internet savvy, you should definitely try out other browsers, FTP clients, electronic mail managers, and such.

Cyberdog requires a Power Macintosh and at least 16 megabytes of RAM. (If less than 16MB of RAM is installed in your computer, use the Memory control panel to turn on virtual memory. Then set the amount of memory to 16MB and restart. For more details on virtual memory, see Chapter 9.)

Install OpenDoc before installing Cyberdog or it won't work.

Logging On

Before you can use Cyberdog, you must log on to your ISP's network. Here's how:

1. Choose Apple menu: Control Panels:PPP to open the PPP control panel.
2. Click the Connect button or press Return.

That's it. Your modem shrieks and squeals, and pretty soon the Status area of the PPP control panel shows that you are connected, as illustrated in Figure 15-4.

Compare the Status area shown in this picture to the Status area in Figure 15-2, which shows the PPP control panel before making a connection.

Leave the PPP control panel open while you're online. The little boxes above the words Send and Receive flash when information is going or coming. It doesn't tell you much, but it's fun to watch, and it does let you know that you're still connected.

If you want your connection to be made automatically when you launch Cyberdog in the future, click the Options button and then click the Connection tab at the top of the window. Then put a check in the box next to Connect automatically when starting TCP/IP applications. (See Figure 15-5.)
Figure 15-4: The PPP control panel. Note the information in the Status area when you're connected to the net.

Figure 15-5: Make a connection automatically whenever you launch Cyberdog (or any other Internet application such as Netscape Navigator or Internet Explorer).

I couldn't get this feature to work reliably for me; I usually have to launch PPP and click the Connect button to log on. Maybe it'll work better for you.
Meet your pup

Now that Modem, PPP, and TCP/IP are configured and you’re connected to the Internet, you’re finally ready to have some fun. Really. Here we go:

Launch Cyberdog. The Cyberdog notebook opens automatically, as shown in Figure 15-6.

Your Cyberdog Notebook

Apple’s taken the liberty of providing you with a few entries in your new Cyberdog notebook to get you started.

Whenever you visit a site on the Internet that you like and would like to remember, create an entry for it in your notebook by choosing Cyberdog -> Add Window to Notebook.

Your notebook can store many kinds of Internet addresses. It can store Web page addresses (such as the ones shown in Figure 15-5: Cyberdog Software Update Information, Cyberdog Home Page, Cyberdog Net Station, Feedback, Plug-ins, and so on). You can tell these items are Web pages by their icons, which look like little pages with a little triangle next to them.
In the next section, you take a quick peek at the starter stuff Apple provides. Then I give you a quick tour of a few of my favorite things on the Internet.

**Puttin’ on the dog**

Let’s pay a quick visit to the Cyberdog home page. Double click it in the Notebook window, and you’ll soon see a browser window that displays the Cyberdog home page, which looks something like Figure 15-7.

![Figure 15-7: Cyberdog's Web browser window, connected to the Cyberdog home page.](http://cyberdog.apple.com/prev/prx20info.html)
Chapter 15: Internet-Working

It'll probably look a little (or a lot) different, as Web pages are dynamic and constantly changing.

Now for the really cool part. Web pages are, by their nature, hyperlinked to other Web pages. These Web links appear as blue text with an underline, which means that with a single click, you can view a related document.

When your cursor is over a hot link, it turns into a paw print, as shown back in Figure 15-7. Most links are in blue text and underlined, but graphics can also be hot links. Move your cursor over a graphic; if it turns into a paw print, that graphic is a link to another page.

When I click in Figure 15-7, the browser magically takes me to the Cyberdog 2.0 Alpha 1 page.

Cyberdog keeps a history of each page you visit in a pop-up menu (see Figure 15-8). To return to a page visited previously, choose its name from this menu. But remember that this history is erased when you quit Cyberdog, so if you visit a site you like, make sure that and save its address in your notebook.

I highly recommend that you visit all the Cyberdog-related sites in your notebook. There's so much more to say about the Internet . . . that I could write a book about it. (And I have. Several, in fact.) Meanwhile, my editor is hounding me to finish this chapter without exceeding my page budget, so I'm going to be mercifully brief in the rest of my tour. Suffice it to say that this chapter barely scratches the surface. For more than a surface scratch, you'll have to buy one of my Internet books, or The Internet For Macs For Dummies (authored by Charles Seiter and published by IDG Books Worldwide, Inc.), or something.

Figure 15-8: The pop-up History menu remembers where you've been, at least where you've been since you started Cyberdog for this session.
Cyberdog can also send and receive electronic mail. Notebook addresses such as Human Interface Comments and Cyberdog Feature Suggestions are e-mail addresses. You can tell by their icons, which look like a person on top of a postcard.

If there's a feature you want to see in upcoming versions of Cyberdog, just double-click the Cyberdog Feature Suggestions item and send Apple an electronic mail message (see Figure 15-9). Choose your letterhead, type a few words, and then press the Send Now button. In a few moments, your message will arrive at Apple's Cyberdog laboratory, where it will be passed around and shared by dozens of geeky engineers with pocket protectors.

Figure 15-9: A feature suggestion ready to send to Apple.

Cyberdog also does FTP (file transfer protocol), which lets you access FTP sites where you can download files to your Mac. Double-click the entry for Apple Software Downloads (FTP), and you'll see a window offering the latest and greatest software files for your downloading pleasure, as shown in Figure 15-10.

Folders in Cyberdog windows act just like folders in the Finder; they can contain either documents, subfolders, or both. When you double-click a file, however, it is automatically downloaded to your desktop and placed in a folder named Cyberdog Downloads.
Finally, your notebook can store newsgroups, discussion bulletin boards where conversations between users can take place. Double-click the apple.cyberdog item to sample the newsgroup dedicated to your favorite Web-surfing pup, Cyberdog (see Figure 15-11).
Unfortunately, that's all I have time for. I'm sure there will be plenty of books about using Cyberdog and the Internet soon. In the meantime, I've shown you just enough to be dangerous. Now read the next section and have a ball surfing my favorite sites.

**Riding the Information Superhighway**

I'm not going to waste a lot of bandwidth (that's internet talk) on this section. What I am going to do is provide you with a list of cool places to visit on the Web, ones recommended and endorsed by yours truly.

Four excellent search engines to help you find stuff on the Internet:

- [http://www.yahoo.com/](http://www.yahoo.com/)

Three excellent sources of information about Macintoshes.


My weekly *Houston Chronicle* columns are archived at [http://www.mediamall.com/mmall/now/Dr.Mac/Dr.Maclist.html](http://www.mediamall.com/mmall/now/Dr.Mac/Dr.Maclist.html)


Huge site with tens of thousands of Mac files for your downloading pleasure: [http://www.shareware.com/](http://www.shareware.com/)


Funny, satirical Web-zine: [http://www.suck.com](http://www.suck.com)

The "Cool Internet Site of the Day" Web site: [http://www.infi.net/cool.html](http://www.infi.net/cool.html)

Oh yeah, and one last thing: Drop me an e-mail message and say, "Hi, I'm surfing the Internet with Cyberdog." Or something. My address is levitus@cis.compuserve.com.
Part IV
The Infamous Part of Tens

The 5th Wave
By Rich Tennant

Bob always had to have the newest and fastest Mac.

DANG! Now the 9500 has been upgraded!
In this part...

We’re in the home stretch now. Just three more chapters and you’re outta here.

These last three are a little different — they’re kind of like long top ten lists. I’d like you to believe that it’s because I’m a big fan of Dave, but the truth is, IDG Books has always put “Part of Tens” in books with... *For Dummies* in their titles, and this book must continue the tradition. Because IDG pays me, I’m doing these chapters their way. (Actually, it’s kind of fun.)

First, I briefly describe ten items that weren’t installed with Mac OS (but you might need someday). I show you what they do, how to install them, and why you might need them. A couple of them might actually be useful to you someday.

I then move on to a subject near and dear to my heart: Ten awesome things for your Mac that are worth spending money on.

Finally, you tour Dr. Mac’s top ten troubleshooting tips, for those times when good System software goes bad.
Chapter 16

Ten Pieces of System Software
You Might Someday Need

In This Chapter
- PowerBook options and other stuff
- Easy Access
- CloseView
- OpenDoc and OpenDoc Essentials
- Cyberdog
- Open Transport PPP
- MacLinkPlus
- QuickDraw 3D
- Apple Remote Access Client
- English Text-to-Speech
- QuickDraw GX

There's a bunch of stuff that's not installed when you perform an Easy Install, and it's all covered in this chapter. Maybe you won't need it, maybe you will, but there's no way to tell until you know what it is and what it does. (To learn how to install each component, see Appendix A.)

As they say in the Hokey Pokey, that's what it's all about.

You can use the Custom Remove option in the Installer pop-up menu to remove any of these items after you've installed them.

PowerBook Options and Other Stuff

There are a bunch of items that are (usually) not installed when you choose the Easy Install option in the Install Mac OS program.
Many of the items, particularly ones with PowerBook in their names, are installed automatically using the Easy Install option if your Mac is of the proper type. Others, like Easy Access and CloseView, can only be installed via Custom Install. See Appendix A for instructions on installing any or all of these components.

Two of these custom install items are so well worth knowing about — specifically, Easy Access and CloseView — that each has its own section.

**Easy Access**

Easy Access (shown in Figure 16-1) is a control panel designed primarily for people with impaired mobility. That doesn’t mean it might not come in handy for anyone.

Easy Access lets you do three things:

- Use the numeric keypad on your keyboard (instead of the mouse) to control the cursor on the screen.
- Type keyboard shortcuts without having to press both keys at the same time.
- Type very slowly.
Chapter 16: Ten Pieces of System Software You Might Someday Need

Figure 16-1:
The Easy Access control panel may come in handy for any user.

Mouse Keys

When you turn on Mouse Keys, the numeric keypad, instead of the mouse, controls the cursor. The 5 key is the mouse button; the 0 key is the click and hold button. The rest of the numbers control the cursor direction (see Figure 16-2).

Figure 16-2:
The numeric keypad controls the cursor. The 5 key is a click; the 0 key is a click and hold.

The keyboard shortcut Command-Shift-Clear toggles Mouse Keys on and off. If you have the audio feedback option checked, you'll hear a whoop when Mouse Keys is turned on and another when it's turned off.

The Mouse Keys radio buttons control the delay before movement occurs (after you press the key) and the speed at which the cursor travels across the screen.
**Slow Keys**

Slow Keys delays the Mac's recognition of keystrokes. In other words, if the acceptance delay is set to Long, you would have to hold down a key for almost two seconds for it to be recognized. This feature is designed to filter out inadvertent and accidental key presses.

**Sticky Keys**

Sticky Keys lets you type keyboard shortcuts one key at a time. In other words, to open an icon, you'd ordinarily press the Command and O keys simultaneously. Sticky Keys makes it possible to press the Command key first and then the O key after it.

The keyboard shortcut for turning Sticky Keys on and off is to press the Shift key five times in rapid succession. To lock the modifier key down, press it twice in rapid succession.

As illustrated in Figure 16-3, when you press the modifier key, you'll see a little icon in the upper right corner of your menu bar that gives you visual feedback on the state of Sticky Keys.

---

**Figure 16-3:**

Sticky Keys on (left); modifier key pressed and waiting for keystroke (center); and modifier key locked (right).

---

My take: It can come in handy. For example, in programs that don't have a nudge command for moving objects one pixel at a time using the arrow keys, Easy Access' Mouse Keys makes a decent substitute. It might be worth keeping around for this feature alone. You can always turn it off using Extensions Manager.
CloseView

CloseView blows up your screen. No, it doesn’t make it explode; it enlarges the image, and it can all be done with keyboard shortcuts!

The CloseView control panel appears in Figure 16-4. Figure 16-5 shows what happens when I turn Magnification on.

CloseView uses a lot of memory — from a few hundred to over a thousand K. If you can afford the RAM, it’s a useful little doohicky to have around. It can give you a zoom feature in programs that don’t allow zooming. On the other hand, hundreds of K is a lot of RAM to waste if you don’t use CloseView often.

My take: Install it but turn it off using Extensions Manager. If you need it, enable it in Extensions Manager and restart.
OpenDoc & OpenDoc Essentials

OpenDoc, as you recall from the previous chapter, is Apple's new plug-in software architecture. Since I just spent an entire chapter talking about it and Open Transport (no relation) and Cyberdog, I'll merely mention them briefly here for three reasons:

- They are optional.
- You might someday need them.
- I wouldn't have had ten items in this chapter otherwise.

Actually, OpenDoc, OpenDoc Essentials, QuickDraw 3D, and MacLinkPlus are installed by default unless you choose Customize in the installer and deselect them. But because they appear in the Custom Software Installation window (see Figure 16-6), I figured they belong in this chapter. Besides, QuickDraw 3D and MacLinkPlus aren't really explained elsewhere in this epic tome, and you'd think me a slacker if I didn't at least pay them lip service.
Also, see the third item in the preceding bulleted list.

**Figure 16-6:**
The Install Mac OS Custom Software Installation window. The items with check marks are installed by default; the others require you to actively select them.

---

**Cyberdog**

See the OpenDoc section.

**Open Transport PPP**

Ditto.

**MacLinkPlus**

MacLinkPlus, mentioned briefly in Chapters 12 and 14, is file translation software that enables you to

- Easily use DOS/Windows files on your Mac
- Convert Mac files into DOS/Windows files
- Convert between different Mac formats
When translating between different Mac and PC formats, such as Word for Mac and WordPerfect for Windows, MacLinkPlus makes sure the file's original formatting remains intact (that is, bold, italics, graphics, and so on). Once a file is translated, you can actually use the file in the new application format (in this case WordPerfect for Windows) just as if it had been originally created there! MacLinkPlus can convert thousands of combinations of files, including word processing, spreadsheet, graphics and database formats.

Perhaps the best thing about MacLinkPlus is that you don't see it until you need it. When you double-click a file that wasn't created by an application you have, Easy Open pops up choices of applications on your Mac you can open the file into with the help of MacLinkPlus file translation (see Figure 16-7).

You need MacLinkPlus if you use files created in DOS or Windows applications or files created in Macintosh applications different from the one you normally use (for example, you use Microsoft Word for the Mac, but your colleagues use ClarisWorks or WordPerfect). If neither condition applies to you, feel free to uninstall it (see Appendix A) and be done with it.

Chances are, you'll never need them, but there is a QuickStart Instruction Card that provides additional details if you do. If not, just kick back and forget it's even installed. It'll be there for you if you ever need it.

**QuickDraw 3D**

QuickDraw 3D enables your Macintosh computer to display three-dimensional graphics using applications designed to take advantage of QuickDraw 3D. It also provides a common file format called 3DF (short for 3D Metafile) for exchanging 3D documents and acceleration services that support plug-and-play accelerator cards.
Chapter 16: Ten Pieces of System Software You Might Someday Need

The following are required to install and run QuickDraw 3D:

- A PowerPC-based computer with a minimum of 16MB of memory RAM
- MacOS System 7.1.2 or later

After you’ve installed QuickDraw 3D, you’ll find a QuickDraw 3D folder inside your Apple Extras folder. It includes applications, 3D models, and textures that enable you to explore the 3D capabilities of your Macintosh. In this folder you should find:

- SimpleText version 1.3.1
- Scrapbook version 7.5.1

These applications let you open and interact with 3DMF models:

- A new Scrapbook File with sample 3DMF models
- A number of 3DMF models provided by Model Masters and Viewpoint Datalabs International

You can expect more applications using QuickDraw 3D in the near future, including new versions of application programs you may already own. Contact your software vendors for more information about their plans to support this new technology.

As of this writing there are no commercial products that take advantage of QuickDraw 3D. But check out the demos in the 3DMF Models Folder. I can already imagine how games will take advantage of this fast new graphics engine. And inexpensive QuickDraw 3D accelerator cards should be arriving on the scene real soon now.

Bottom line: QuickDraw 3D doesn’t do much yet, but it will. Keep an eye on this emerging technology.

For better performance, I strongly recommend that virtual memory be turned off if you’re going to use QuickDraw 3D.

Also, since QuickDraw 3D is optimized to display three-dimensional graphics of high quality, to obtain the best performance from your system, I also recommend that you set your system to display thousands or millions of colors.

Apple Remote Access Client

This is the last time I’m going to do this, I promise, but everything you ever wanted to know about Apple Remote Access can be found in Chapter 8.
**English Text-to-Speech**

With the English text-to-speech software installed, many Macintosh programs — including SimpleText — can read English text out loud.

The following are required to install and run English Text-to-Speech:

- A Macintosh or Power Macintosh computer
- Version 6.0.7 or later of System software
- At least 300K of RAM in addition to what the rest of your System software takes
- At least 5MB of space available on your hard disk

You can try out the text-to-speech software in the SimpleText program by following these steps:

1. Open any SimpleText document.
2. Click anywhere in the text to make sure nothing is selected.
3. Choose Speak All from the Sound menu. (If you cannot hear anything, you may have the sound turned all the way off. Check in the Monitors & Sound control panel.)
4. If you want the computer to stop reading, choose Stop Speaking from the Sound menu.

You can also try the following:

- To read a portion of the file, select the words you want to read then choose Speak Selection from the Sound menu.
- To have the computer speak in a different voice, select a voice from the Voices submenu in the Sound menu and then choose the Speak All or Speak Selection command from the Sound menu.

Check out the entry for the Speech control panel in Chapter 12 for more scintillating info on speaking and voices.

**QuickDraw GX**

Our final option is QuickDraw GX. I'm not going to say much about QuickDraw GX here except that it's optional and belongs in this chapter. Anything else I have to say I said in Chapter 7.
Okay. I’ll say one more thing: I think that for most people, the benefits of QuickDraw GX, at least today, aren’t worth the RAM it uses (almost a meg if you use ATM with it!).

Read Chapter 7 if you can’t remember what the benefits are. (I can’t. I just had to reread it myself!)

The last three items neatly round off this particular Part of Tens. They are installed using the Custom Install option in the QuickDraw GX installer. After installing them (see Appendix A), look for them in the QuickDraw GX Extras folder inside your Apple Extras folder.

Because all three items are application programs, you can copy them to a floppy disk after they’re installed on your hard disk. Then delete them from your hard disk. Run them from the floppy when you need them.

**LaserWriter Utility**

LaserWriter Utility is a multipurpose program for configuring your Apple laser printer. It doesn’t work with third-party printers, so don’t even try it.

Figure 16-8 shows its File and Utilities menus, which contain all the things it can do. If you need to do any of these things, just launch LaserWriter Utility and choose the command from the appropriate menu.

**Paper Type Editor**

Paper Type Editor lets you create new paper descriptions that you can use with the new-style Print dialog boxes (Chapter 7, remember?). This utility lets you specify paper with dimensions other than the ones that come with your Mac (letter, legal, and so on).
Type 1 Enabler

The Type 1 Enabler program converts Type 1 fonts to QuickDraw GX-compatible fonts, making them fully scalable so that they look better on-screen. Before conversion, you may only have one or two point sizes that look good on-screen. After conversion, the font will look good in any size you use, even odd numbers like 13 points.

It's a good idea to convert your Type 1 fonts if you're going to use QuickDraw GX.

To use Type 1 Enabler, launch it. You'll see a standard Open dialog box. Choose a single font suitcase or a folder full of Type 1 fonts that you want converted. Another Open dialog box will appear. Choose the Fonts folder in your System Folder as the destination for the converted fonts. Type 1 Enabler does the rest.
Chapter 17

Ten Ways to Make Your Mac Better by Throwing Money at It

In This Chapter

- Stuff I think you ought to buy

This is my favorite part. As you've probably figured out by now, I love souping up my Mac. I live to find ways of working smarter, saving time, and saving hand motion. And I revel in tweaking my Mac and Mac OS 7.6 So it gives me great pleasure to share this chapter, my personal top ten (actually, eleven, but don't tell my editor) things you can buy for your Mac to tweak it and make it faster, easier to use, and (I hope) more fun.

The items listed in this chapter are things I have, use every day, love dearly, and would buy again.

- **RAM**: It's worth every penny. If you have anything less than 16MB in your Mac, you'll like it a lot better if you upgrade to 32MB or more. (For what it's worth, RAM has never been cheaper than it is today.)

- **Backup software**: If your work means anything to you, get something that helps automate the task of backing up your files. Retrospect or DiskFit, both from Dantz Development, are the names to trust.

- **CD-ROM Drive**: Turn your boring Mac into a multimedia entertainment and education center. If you don't have one, you absolutely need one. Just make sure that you get at least a quad-speed drive if you're on a budget. If spending a few extra bucks doesn't bother you, get an 8x or 12x drive. And then buy a few . . .

- **CDs**: There are some great games, references, and educational titles out there. You'll love 'em, and so will your kids.

- **Games**: I just love Titanic, Bad Mojo, Alley 19 Bowling, Nascar Racing, and You Don't Know Jack. Gaming on the Mac has never been better. And by the way, all of the above come on CD-ROM only.
Part IV: The Infamous Part of Tens

- **Big monitor:** You'll spend less time scrolling and rearranging windows. You'll spend more of your time getting actual work done, which is a good thing, right? I use a multi-sync Sony 20sfl and love it to death.

- **Modem:** You're capacity to communicate will increase ten-fold. Join an online service, surf the Internet, e-mail your friends, and much, much more. Get a modem that can do at least 28.8 kbps (33.6 kbps modems are now available, and they aren't much more expensive). 14.4 kbps doesn't cut it anymore.

- **Now Utilities:** It puts Mac OS 7.6 on steroids. Use it for a week and you'll wonder how you ever lived without it.

- **QuicKeys:** This utility creates macros, called *shortcuts*, that can perform a task or a series of tasks (a *sequence*) with a single command. It's like AppleScript, only better.

- **Retrieve It:** This little-known utility from MVP Solutions searches for text within documents and even across the Internet. It's a great addition to Find File.

- **A New CPU:** If you've got any money left, consider upgrading to a newer, faster Mac or clone. They've never been faster, cheaper, or better-equipped.

So there you have it: eleven awesome ways to spend a big chunk of change. So ladies and gentlemen, start your checkbooks. Go forth, throw money at your Mac, but most of all, have fun.
Chapter 18

At Least Ten Things to Try When Good System Software Goes Bad

In This Chapter
- The dreaded Sad Mac
- The flashing question mark
- Startup crashes
- Reinstallation

I said Chapter 14 was "easily the most useful chapter in the book." It is. Unless you wake up one morning to find your Macintosh sick or dying. Then (and only then) is this chapter more useful because it's the one that is going to save your bacon.

As a bleeding-edge Mac enthusiast with almost ten years of Mac under my belt, I've had more than my share of Mac troubles. Over those years, I've developed an arsenal of tips and tricks that I believe can resolve more than 90 percent of Macintosh problems without a trip to the repair shop.

Disclaimer: Of course, if your hardware is dead, there's nothing you or I can do about it. But if your hardware is okay, there's a 90 percent chance that something (or a combination of things) in this chapter will get you up and running.

I know that there are more than ten things in this chapter. My editor, Tim Gallan, says it doesn't matter, that the "Part of Tens" in . . .For Dummies books is sort of just for show, and I don't really have to have ten of anything as long as I use the word ten in the chapter name.

Think of this chapter as yet another occasion where I give you more than your money's worth.
Dem Ol' Sad Mac Chimes of Doom Blues

One thing we all dread seeing is the Sad Mac icon (see Figure 18-1) and hearing that arpeggio in G minor better known as the Chimes of Doom.

The Sad Mac usually indicates that something very bad has happened to your Mac, often that some hardware component has bitten the dust. But Sad Macs are rather uncommon — many users go years without seeing one. If you've got one, don't despair. Yet. There is something you can try before you diagnose your Mac as terminal — something that just might bring it back to life! Try this:

1. Shut down your Mac.
2a. If your Mac came with a Disk Tools floppy disk, insert it.
   or
2b. If your Mac has an internal CD-ROM drive and came with a bootable CD-ROM System Software disk, insert that instead.
3. Restart your Mac.
4. If you are using a CD, you probably have to hold down the C key on your keyboard during startup.

If you see the Mac OS startup screen when you booted off your Disk Tools or CD-ROM, there's hope for your Mac. The fact that you boot from another disk indicates that there's a problem with your hard disk or your System Folder. Whatever it is, it will more than likely respond to one of the techniques discussed throughout the rest of this chapter, so read on.
If the forthcoming techniques don’t fix the problem, or you still see the Sad Mac icon when you start up with Disk Tools or CD, your Mac is toasted beyond my help and needs to go in for repairs.

Before you drag it down to the shop, you might try 1-800-SOS-APPL. They may well suggest something else you can try.

**Flashing Question Mark Problems**

Go through these steps in sequence. If one doesn’t work, move on to the next.

Now would be a good time to reread the “Question Mark and the Mysterians” section of Chapter 1, which explains the flashing question mark and why Disk Tools is the ultimate startup disk. Both are things you need to know before you continue.

---

**1-800-SOS-APPL**

This is a very good number to know. It’s Apple’s technical support line and it’s good for all Apple-branded products. If nothing in this chapter brings you relief, call Apple before you lug the box down to the repair shop. Maybe they know something I don’t.

In the bad old days, Apple’s stance on technical support was “Ask your Apple dealer.” That position, as you might guess, wasn’t very satisfying — at least not to users. So a few years ago, Apple saw the light and instituted direct, toll-free technical support via the aforementioned 1-800-SOS-APPL, a big win for Macintosh users.

I have, since the line opened up a few years ago, called a few times a year, often with an obscure problem. I have to say that they are very well informed at Apple tech support — they are batting close to 1000, believe it or not. These guys and gals do know their stuff.

There is a drawback to this service: You may have to wait a bit. Some days it takes 30 minutes to get a live person on the phone.

Call using a speaker phone. Enjoy the soothing music and continue with your work until you hear a live person.

On the other hand, I’ve often had my call answered on the first ring. I think it’s easier to get through first thing in the morning; they’re open from 6 a.m. to 6 p.m. Pacific time.
The Disk Tools disk or bootable CD-ROM System software disk are sooo important that it's a good idea to have more than one around. That way, if one copy gets misplaced, damaged, eaten by the dog, accidentally formatted, exposed to a strong magnetic field, or otherwise rendered useless, you won't be totally out of luck.

I keep a copy of Disk Tools in my middle desk drawer and several bootable CDs on the bookshelf.

If your System software came on floppies, it's a good idea to make copies of all of the Mac OS master installer disks and then use the copies to install. But that's a lot of disk copying, and I wouldn't blame you if you didn't bother. If a disk goes bad, you can easily get it replaced.

But if you don't have a working copy of Disk Tools, you can't do any of the stuff in the rest of the chapter. So make a copy of it right this minute before you forget. It's the most important floppy disk you own.

If you still see the flashing question mark after inserting the Disk Tools disk or System software CD-ROM, it's possible your Disk Tools or CD-ROM disk is damaged. As a last resort, try starting up your Mac with the floppy Install Disk 1 inserted if you have one. If you see the Installer, your copy of Disk Tools isn't functional. Try your backup copy.

**Start with something easy:**
**Rebuild the desktop**

Before attempting more drastic measures, try rebuilding the desktop.

Actually, rebuilding the desktop should go under the heading of preventive maintenance. Apple recommends rebuilding the desktop once a month, and so do I.

Another good time to rebuild the desktop is if you notice icons disappearing, changing, or being replaced by generic icons (see Figure 18-2). This problem is usually a result of a desktop that needs rebuilding.

The desktop you're rebuilding is an invisible database that keeps track of every file on your hard disk, manages what icon goes with which file, and manages which program launches when you open a document.

More strictly speaking, the desktop is a pair of invisible files called Desktop DB and Desktop DF. They're stored at root level, but you can only see them with special software designed to work with invisible files. Leave them alone.
Figure 18-2: If your formerly colorful icons turn generic, like these, try rebuilding the desktop.

Another good time to rebuild the desktop is if you start getting “an application can’t be found for this document” errors when you know that you have the application or have assigned a substitute using Macintosh Easy Open.

**How to actually do it**

Anyway, to rebuild the desktop, hold down the Command and Option keys during startup until you see the dialog box in Figure 18-3.

Figure 18-3: Yes, you do want to rebuild the desktop. Click OK.

After you click OK, you’ll see a thermometer window as the desktop is rebuilt. In a moment or two, it disappears and you’re off and running.

If you have more than one hard disk or hard disk partition, a dialog box like Figure 18-3 will appear for each disk that mounts on the desktop at startup. Click OK for every disk.

Oh yeah. You don’t need to rebuild the desktop of the Disk Tools disk, so you can click Cancel for that one. You need to deal with your hard disk, and rebuilding the desktop on the Disk Tools disk won’t do you any good.

Just remember to rebuild your desktop monthly to keep your Mac in tip-top shape. And rebuild it again if you see the flashing question mark.
Part IV: The Infamous Part of Tens

You’re going to attempt to boot from your hard disk now, so remove the Disk Tools disk from the drive and restart.

If you still see the flashing question mark, it’s time to ... 

**Send for the Ambulance:**

**Run Disk First Aid**

The next step in the program is to run the Disk First Aid application on your Disk Tools disk or System software CD.

The desktop file isn’t the only place where hard disks store information about themselves. There are BTrees, extent files, catalog files, and other creatively named invisible files involved in managing the data on your disks. Disk First Aid is a program that checks all these files and repairs ones that are damaged.

**How to actually do it**

If you haven’t done so already, restart your Mac with the Disk Tools disk in the floppy drive.

1. Launch the Disk First Aid application (see Figure 18-4).
2. Click the icon for your hard disk at the top of the Disk First Aid window (see Figure 18-5).
3. Click the Repair button.

Your Mac will whir and hum for a few minutes, and the results window will tell you what’s going on (see Figure 18-6).

Ultimately, Disk First Aid will tell you (you hope) that the disk appears to be okay. If so, restart your Mac without the Disk Tools or CD-ROM disk in the drive. If everything is okay, then go back to work.
Chapter 18: At Least Ten Things to Try When Good System Software Goes Bad

Figure 18-5: Click your hard disk's icon and then click Repair; Disk First Aid will do the rest.

Figure 18-6: Disk First Aid runs some tests and offers its diagnosis.

If Disk First Aid finds damage that it's unable to fix, a commercial disk recovery tool such as Norton Utilities for the Macintosh or MacTools may be able to repair the damage.

If the software can't repair the damage, you'll have to initialize your disk. But that's okay, right? You have that backup software and you use it.

If everything checks out with Disk First Aid, try to boot from your hard disk again. If you still get the flashing question mark, try ...
Installing new hard disk drivers

This section applies to Apple-brand hard disks only. If you have a third-party hard disk, the procedure will be different. Read your hard disk's manual before you continue. Sorry.

What you're going to attempt next is to install (update) your hard disk drivers.

Drivers are little invisible bits of code that tell your hard disk how to communicate with a Mac. They occasionally become damaged and need replacing. Done properly, the technique is completely harmless and can make the flashing question mark disappear.

How to actually do it

1. Restart your Mac using Disk Tools or your System software CD-ROM as your startup disk.

2. Launch the Drive Setup or Apple HD SC Setup application. It doesn't matter which, so launch whichever one you find first; they both do the same thing as far as you're concerned for this lesson.

3. If you're using Drive Setup, choose Functions->Update Driver (Figure 18-7); if you're using Apple HD SC Setup, click the Update button (Figure 18-8).

You should see a message telling you that the new driver won't be available until you restart your computer.

Do not click Initialize or choose Functions->Initialization Options! If you initialize your hard disk, it will be erased completely and irrevocably.
You get a warning or two first, but if you're not paying attention, a few false clicks (or presses of the Return key) and your hard disk is blank.

So update, don't initialize, okay?

If that solution doesn't get you up and running and you're still seeing that danged flashing question mark when you try to boot from your hard disk, don't despair. There are still a few things you can try, such as...

**The latest dance craze: Zapping the PRAM**

Sometimes your parameter RAM (PRAM) becomes scrambled and needs to be reset.

The PRAM is a small piece of memory that's not erased or forgotten when you shut down. It keeps track of things like printer selection in the Chooser, sound level, and monitor settings.

Try zapping your PRAM if your Monitors & Sound control panels or your Chooser seem to forget their settings when you shut down or restart.

**How to actually do it**

Restart your Mac and hold down Command-Option-P-R (that's four keys — good luck; it's okay to use your nose) until your Mac restarts itself again. It's kind of like a hiccup. You see the smiling Mac or flashing question mark for a second, and then that icon disappears and your Mac restarts.

Zapping the PRAM returns some control panels to their default settings (but, interestingly, not the date or time), so you may have to do some tweaking after zapping the PRAM.
SCSI voodoo

It is said that connecting more than one SCSI device — an external hard disk, SyQuest, Zip, Jaz, optical disk, scanner, and so on — requires the luck of the gods.

The first bugaboo is SCSI termination. According to Apple, the first and last device on a SCSI chain must have a terminator. No devices in between should have termination. Internal hard drives are always terminated. And the total length of a SCSI chain can be no more than 22 feet.

But sometimes you can’t get your SCSI chain to work by following the rules. Sometimes it requires terminating a drive in the middle of the chain as well as the first and last drives. Other times, a chain won’t work if the last device is terminated. The physical order of devices matters. And, of course, there are those SCSI ID numbers.

So if you’re seeing a flashing question marks still, and you have any external devices attached, shut down your Mac and unplug them. After they’re all disconnected, try restarting your Mac using the Disk Tools disk.

Never plug or unplug SCSI devices with the power on. Turn both your Mac and the device off before you attempt to connect or disconnect any cables.

If your Mac starts up when no SCSI devices are connected, you’ve got a problem on the SCSI chain: a termination problem, a bad cable, or a SCSI ID conflict.

I’ll be back: The terminator

A terminator is a plug that fits into the empty cable connector of the last device on your chain.

Some terminators are pass-through connectors, which can have a cable connected to them. Others block off that connector completely; these are known as block terminators.

If you see the flashing question mark and your last device isn’t terminated, terminate it. If it is terminated, unterminate it. If you have more than one device and your terminator is a pass-through terminator, connect it to a device in the middle of the chain (instead of the end) and try to start your Mac.

If you have two terminators and two or more devices, try two terminators, one in the middle and one at the end. This trick isn’t recommended, but sometimes that’s what it takes to make things work.
If all this terminator juggling isn’t working for you, try changing the physical order of the devices. If right now your Mac is connected to the hard disk, which is connected to the Zip drive, then try connecting the Zip drive to the Mac and the hard disk to the Zip drive.

I add and subtract SCSI devices more often in a year than most people do in two lifetimes. I’m always firing up some new storage device that someone wants me to check out. And I’ve had good luck since switching to a drive with Digital Active Termination.

Digital Active Termination senses how much termination your SCSI chain requires and then supplies it automatically. It’s almost a miracle, and it’s included on almost all storage devices from APS Technologies. Just put any device with Digital Active Termination at the end of your chain, and you are virtually guaranteed perfect termination, regardless of the number of devices in the chain or the physical order of the devices.

Cables: Cheap is bad
When troubleshooting SCSI problems, you should check your SCSI cables. If you can borrow others, try that option. Cheap cables, usually ones that are thin and flexible, are more prone to failure than heavy, shielded cables. Again, APS has excellent thick cables at fair prices.

Gotta have some ID: Unique SCSI ID numbers required
If you have multiple SCSI devices, don’t forget that each must have a unique SCSI ID between 0 and 7. Your internal hard disk has ID 0, so external devices can have numbers from 1 to 6. Internal CD-ROM drives are frequently assigned the ID number 3.

You usually select the ID number using a wheel or button on the back of the device. Just make sure that each drive in the chain has a unique number and you’re all set.

Try again to restart without the Disk Tools disk.

If nothing so far has cured the flashing question mark, you have to suspect damage to the System software on your hard disk.

So now you’re going to try to replace your old System software with fresh, new System software.

Reinstalling the System software
The reason that this procedure comes last in this section is that it takes the longest. The procedure is detailed at great length in Appendix A, affectionately known as “Anyone Can Install Mac OS 7.6.”
If nothing has worked so far

If my suggestions haven’t worked, if you’ve rebuilt the desktop, run Disk First Aid, installed new hard disk drivers, zapped your PRAM, disconnected all SCSI devices, and reinstalled your System software, and you’re still seeing the flashing question mark, then you’ve got big trouble.

You may have any one of the following problems:

- Your hard disk is dead and so is your floppy drive.
- Your hard disk is dead but your floppy drive is okay.
- Some other type of hardware failure.
- All of your startup disks — your Disk Tools and Install Disk 1 floppies and/or your System Software CD are all defective (unlikely).

The bottom line: If you’re still seeing the flashing question mark after trying all the stuff in the previous pages, you almost certainly need to have your Mac serviced by a qualified technician.

If You Crash at Startup

More of a hassle to solve than flashing question mark problems, but rarely fatal, startup crashes are another bad thing that can happen to your Mac.

A crash often involves a System Error dialog box, frozen cursor, frozen screen, or any other disabling event.

At startup is defined as any time between flicking the power key or switch (or restarting) and having full use of the Finder desktop.

A startup crash may happen to you someday. If it does, here’s what to do:

Restart without extensions and control panels

The first thing you need to do is establish whether an extension or control panel is causing the crash by starting up with all of them disabled.
How to actually do it

If your Mac is already on, choose Special- Restart, holding down the Shift key until you see “Extensions Disabled” in the Welcome to Mac OS window. After you see “Extensions Disabled,” you may release the Shift key.

If your Mac is off, power it up and hold down the Shift key until you see “Extensions Disabled” in the Welcome to Mac OS window. Again, you can release the Shift key after “Extensions Disabled” appears.

If your Mac starts up successfully when you hold down the Shift key but crashes or freezes when you don’t, you can deduce that one (or more) of your extensions or control panels is responsible for the crash. Read the section “Resolving extension and control panel conflicts.”

If your Mac still crashes when you hold down the Shift key, you can deduce that something is wrong with your System or Finder. Read the section “How to perform a clean System reinstallation” later in this chapter.

Resolving extension and control panel conflicts

If you're reading this section, you have an extension or control panel that is causing your Mac to crash at startup. The trick now is to isolate which one (or, occasionally, more than one) is causing your troubles. Chances are, it's a third-party extension or control panel, but you can't rule out Apple extensions and control panels either — they too can conflict with other extensions or control panels or become corrupted and not function properly.

Because you know that your Mac will start up with the Shift key down, you can use Extensions Manager to track down the rogue extension or control panel file.

I'm so happy Apple included Extensions Manager as part of System 7.5 and improved it a lot for Mac OS 7.6, I could turn back flips. You'll see why when I show you how to resolve your difficulties with Extensions Manager. Just imagine what a hassle it would be without EM.

How to actually do it

The first step is to establish whether any of the Apple Mac OS 7.6 extensions or control panels are causing problems.
1. Power up or restart your Mac and then press and hold the spacebar until the Extensions Manager window appears.

2. Choose Mac OS 7.6 all from the pop-up menu (see Figure 18-9) and then click the Extensions Manager window's close box to begin the startup process.

**Figure 18-9:** Choose Mac OS 7.6 all to load only the standard-issue Mac OS extensions and control panels. Then click the Continue button to begin the startup process.

**Situation 1:** You can now boot successfully, which means that the culprit must be one of your third-party extensions or control panels.

**Situation 2:** You still crash at startup, which means that the culprit must be one of the Mac OS extensions or control panels.

In Situation 1, repeat these steps until you crash again:

1. Power up or restart your Mac and then press and hold the spacebar until the Extensions Manager window appears.

2. Add one extension or control panel to the enabled list by clicking it so that a check mark appears.

3. Click the Continue button to begin the startup process.
If you start up successfully, you know that the extension or control panel you just added is not the culprit. Repeat these three steps, enabling one new item each time you restart, until you crash. When you do, the last extension or control panel you enabled is the culprit.

See the section called “Dealing with recalcitrant extensions and control panels” for possible solutions.

In Situation 2, repeat these steps until you stop crashing:

1. Power up or restart your Mac and then press and hold the spacebar until the Extensions Manager window appears.
2. Disable one of the currently enabled extensions or control panels by clicking it so that its check mark disappears.
3. Click the Continue button to begin the startup process.

Repeat these three steps, disabling one item each time you restart, until you stop crashing. When you do, the last extension or control panel you disabled was the culprit.

See the next section, “Dealing with recalcitrant extensions and control panels,” for some things you can try.

Sometimes you can tell which extension or control panel is causing your crash by looking carefully at the little icons that appear on the bottom of your screen during startup. Each icon you see represents a control panel or extension loading into memory. If you can determine which icon was the last to appear before the crash, you can try disabling it before going through the iterative and frustrating process of determining the culprit as described previously. You might get lucky and save yourself hours of boring detective work.

If you’ve got a good memory, enable or disable a few at a time in Step 2. Just keep track of what you’re doing and you can reduce the number of restarts it takes to find your offender.

**Dealing with recalcitrant extensions and control panels**

In the previous section, you determined which particular extension or control panel was giving you fits. In this section, I’ve got a couple of suggestions — replace and reorder — that may let you use the offending item anyway.
**How to replace a recalcitrant file**

1. Delete the guilty control panel or extension from your hard disk by dragging it to the Trash.

2. Open the Preferences folder in your System Folder and delete any preference file with the same name as the guilty file.

3. Replace the guilty file with a fresh copy from a master disk.

If it's an Apple extension or control panel, use the Install Mac OS program as described in Chapter 14. If it's a third-party product, follow the installation instructions in its manual.

Restart and see if the problem reoccurs.

If it does, you may still be able to use the recalcitrant extension or control panel by diddling with the loading order of extensions and control panels at startup.

**How to reorder a recalcitrant file**

To understand how to reorder, you must first understand why you need to reorder.

In some cases, extensions and control panels crash only if they load before or after another extension. Ergo, by diddling with the loading order, you can force one file to load before another.

How do you diddle the loading order, you ask? When extensions and control panels load at startup, they load in alphabetical order by folder. To wit:

1. The Extensions folder’s contents, in alphabetical order
   and then
2. The Control Panels folder’s contents, in alphabetical order
   followed by
3. Control panels or extensions loose in your System Folder (that is, not in the Extensions or Control Panels folders), in alphabetical order.

So if you've got a recalcitrant extension or control panel, try forcing it to load either first or last. This trick works more often than not.

To force an offending control panel or extension (Snapz Pro in this example) to load first, precede its name by several spaces and move it into the Extensions folder if it's a control panel. It will then load before any other extensions or control panels (see Figure 18-10).
By putting the Snapz Pro control panel in the Extensions folder (so that it loads before items in the Control Panels folder or System Folder) and preceding its name with several spaces, I ensured that Snapz Pro is the first to load.

Going the other way, to force an extension or control panel to load last, precede its name with several tildes and move it out of the Extensions folder and into the System Folder itself (see Figure 18-11).

By preceding the item's name with tildes and moving it out of the Extensions folder and into the System Folder itself, as shown, I've ensured that Snapz Pro will be the last extension or control panel to load.

More sophisticated startup managers, such as Now Utilities' Startup Manager and Casady & Greene's Conflict Catcher II, let you change the loading order of extensions and control panels by dragging them around, avoiding the inconvenience of renaming or moving them manually. I wish Extensions Manager had this capability. If you find yourself resolving many conflicts with extensions or control panels, one or the other utility is a good investment.
Both programs also perform the conflict resolution three-step boogie automatically. You just restart, tell the software whether the problem is gone, and then restart again. The software does all of the enabling and disabling and keeps track automatically. At the end, it tells you which file is the culprit. If you have many of these conflicts, one of these two programs is a worthwhile upgrade to the bare-bones Extensions Manager.

If you're still reading and your problem hasn't been resolved, there's one last thing you can try, namely, a clean System software installation.

**How to perform a clean System reinstallation**

This is a drastic final step. If nothing so far has fixed your startup problems, a clean System reinstallation, a.k.a. clean install, very well may. I saved this solution for last because it's the biggest hassle, and you don't want to go through the trouble if something easier can fix you up. So if you're doing a clean install, it's more or less your last hope.

Don't worry. This solution will most likely get you back on your feet. This one will fix all but the most horrifying and malignant of problems. So let's get to it.

---

**Clean versus regular installation**

To understand why you need to do a clean install, or even what a clean install is, you have to understand a little about how the Install Mac OS program works and what resources are.

Resources are the building blocks from which all programs, control panels, extensions, and so on, are built. The Install Mac OS program is, technically, a resource installer. It installs the resources that become programs, control panels, extensions, and so on.

And the Install Mac OS program is very smart about which resources it installs. It looks at your hard disk; then, if it sees a System Folder containing a System and a Finder, it installs only the resources it thinks you need. So, for example, if the Install Mac OS program sees a System and Finder, it looks to see if they contain the proper resources. If they do, it doesn't install anything, even if the resources are damaged.

Therein lies the rub. The Install Mac OS program can sometimes outsmart itself. If the reason your Mac is crashing is that a resource inside the System, Finder, a control panel, or an extension has become damaged or corrupted, the Install Mac OS program may not replace the defective resource if you perform a Regular Install.

A clean install, on the other hand, ensures that every single file and every single resource is replaced with a brand spanking new one. In fact, a clean install gives you a brand new System Folder.
The easy way to perform a clean install

Prior to System 7.5, clean installs were performed manually and were much harder to explain.

Thankfully, there is now a barely hidden shortcut in the Install Mac OS program that lets you perform a clean install automatically, with no muss or fuss. Here's how:

1. Start up or restart your Mac with Install Disk 1 in your floppy drive (or the Mac OS CD in your CD-ROM drive).
2. Launch the Install Mac OS program.
3. After performing the first four steps and choosing a hard disk to install the software on, you'll see a screen with Customize and Options... buttons at its bottom. Click the Options... button.
4. A dialog box will appear, as shown in Figure 18-12. Click the check box to Create new System Folder (clean installation) and click OK.
5. Click the Start button and feed disks if requested.

When the Install Mac OS program is through, you'll have a brand spanking new System Folder on your hard disk. Your old System Folder has been renamed Previous System Folder. Nothing has been removed from it.

The folder called Previous System Folder contains all your old third-party extensions, control panels, and fonts. Because it's possible, even likely, that one of these items contributed to your problem, I recommend that you reinstall them one item at a time. In other words, move one extension or control panel from Previous System Folder onto the new System Folder's icon. Then restart and work for a while to see if any problems occur before reinstalling another.
It's a good idea to trash the System and Finder in the Previous System Folder as soon as possible after performing the clean install.

It's simply a bad idea to have two System Folders on one hard disk, and as long as Previous System Folder has a System and a Finder in it, your Mac could confuse Previous System Folder with the real System Folder, and that confusion could cause you major heartache.

So delete the old System and Finder files, the ones in the Previous System Folder, now. Just in case. Thanks.

Don't forget that the System Folder is smart. If you drag a control panel or extension onto its icon (but not into its open window), it will put the file in the proper folder for you.
Part V
Appendixes

The 5th Wave

By Rich Tennant

"We should have this fixed in System 8."
I saved some important topics for last because, as an intelligent Mac user, you already know much of what I cover in these appendixes.

First, I cover installing Mac OS 7.6. The whole process has gotten quite easy with this version of the System software. You may wonder why I bothered to write about it.

Second, I deal with the whole process of backing up. You know that your files are important, and I'm sure that you already know how to copy files from your hard disk to a floppy or some other form of media. But just in case you don't, you'd better read this appendix.
Appendix A

Anyone Can Install Mac OS 7.6

The Mac OS 7.6 floppy disks or CD-ROM can install more than just System Software. So in the first section, I discuss the plain vanilla Easy Install installation.

An Easy Install includes OpenDoc, QuickDraw 3D, and MacLink Plus. If for some reason you don't want to install those components (read about them elsewhere in the book), click the Customize button and deselect them as shown in Figure A-1.

![Custom Software Installation](image)

After covering Easy Install, I then explain how to install Apple Remote Access Client, Cyberdog, Open Transport PPP, English Text-to-Speech, and QuickDraw GX, which require separate installation.

Finally, there are several other optional pieces of System Software — such as Easy Access and CloseView (see Chapter 17) — that require a separate custom installation process. I cover them in the final section.
If the reason you're installing (actually reinstalling) Mac OS 7.6 is that your Mac is acting up, you may need to perform a clean install. See the section in Chapter 18.

The procedure for installing Mac OS 7.6 is the same regardless of whether you're upgrading from an earlier version of System software or installing Mac OS 7.6 on an empty hard disk.

Ready? Take a deep breath.

**Installing Mac OS 7.6**

Shut down your Macintosh if it's turned on. Insert the floppy disk called Install Disk 1 or the Mac OS 7.6 CD-ROM and turn on your Mac. If you're starting up from a CD, hold down the C key on your keyboard.

Your Mac will start up. If you are installing from floppies, the Install MacOS program should launch automatically. (If it doesn't, double-click the icon named Install MacOS.) You'll see a comforting welcome screen like the one in Figure A-2. If you're installing from a CD, launch the Install MacOS program.

(Are you beginning to detect a pattern? Macs are warmer and fuzzier than other personal computers?)

Click the button for Step 1, Read important information (it's on the right and looks like a little newspaper). The SimpleText program launches and displays the Mac OS 7.6 Read Me file automatically. Read it. Now Quit (File: Quit or Command-Q). SimpleText quits and you're returned to the Install MacOS screen shown in Figure A-2.
Next, click the button for Step 2, Update your hard disk driver (it's on the right and looks like a hand on top of some boxes). The Drive Setup program launches automatically. At this point, you see a dialog box that says, "You may skip this step if either of the following is true: 'There are no Apple disk drives connected to this computer' or 'You have an Apple disk drive but it has been updated with a non-Apple driver.'" Unless you meet one of these two conditions, click the Continue button. And, of course, if you do meet one of the conditions, you can click the Skip button.

Assuming you click Continue, the next window you see is the Drive Setup window (see Figure A-3).

If you have more than one hard disk, you may have to click its name in the Drive Setup window.

![Figure A-3: The Drive Setup window, ready to update my Apple-brand hard disk's driver.](image)

Now Quit (File→Quit or Command-Q). Drive Setup quits and you're returned to the Install MacOS screen shown in Figure A-2. Click the button for Step 3. The Select Destination Disk window appears. If you have more than one hard disk, choose it from the pop-up menu. (See Figure A-4.)

Click the Select button or press Return. Select Destination Disk quits and you're returned to the Install MacOS screen shown in Figure A-2.

Are you having fun yet? Just a couple more clicks and we're there.

Click the button for Step 4. The Software Installation window appears, as shown in Figure A-5. For a standard Easy Install, click the Start button or press Return. (See the next two sections of this chapter for details on custom installations.)
Part V: Appendixes

Figure A-4: If you have multiple hard disks, select the one you want to install Mac OS 7.6 onto from this pop-up menu.

Figure A-5: The Software Installation window.

After a moment you see a progress box as the Installer checks your hard disk.

After another moment a license agreement appears on your screen. Click the Agree button (Figure A-6).

If you don’t click the Agree button, you can’t install the software. So read it if you want to, but if you’re not going to click Agree, you’re not going to run Mac OS 7.6.

If you’re installing from floppies, your Mac asks you to insert Install Disk 2. Do it. Later it asks for Install Disk 3, 4, 5, and so on. Eventually it asks you to insert Install Disk 1 again. That’s the signal that installation is almost over.

If you’re installing from a CD-ROM, just kick back and relax for a few minutes.

After a little more whirring and clicking, your Mac will politely inform you
that the installation was successful. Click the Quit button, restart your Mac, and away you go.

That's it. Your hard disk now has Mac OS 7.6 installed. Piece of cake. The hardest part is moving your arm.

**Custom Installs**

To install OpenDoc, OpenDoc Essentials, QuickDraw 3D, MacLinkPlus, Apple Remote Access Client, Cyberdog, Open Transport PPP, English Text-to-Speech, and QuickDraw GX, follow the directions in the previous section right up until the part where you clicked the Start button.

Don't forget that OpenDoc, OpenDoc Essentials, QuickDraw 3D, and MacLinkPlus were probably installed when you first installed Mac OS 7.6. Unless you manually deselected them when you first installed Mac OS 7.6, they're already installed. The following instructions show you how to install them if you haven't already.

Follow the instructions in the first section of this chapter right up to the part where you click the Start button. Then, instead of clicking the Start button, click the Customize button. The Custom Software Installation window appears. Click next to the names of the options you want to install.

You can quickly check their installation status (as shown in Figure A-7); it changes depending on whether or not their box is checked.

In this example, OpenDoc, OpenDoc Essentials, and Cyberdog will be installed when I click the Start button or press Return.
Each custom installation proceeds a little differently; here's how each of them works:

**OpenDoc**

The first thing you see after clicking the Start button is the OpenDoc splash screen. Click the Continue button. Another license agreement appears. Click Agree. The Install OpenDoc window appears. Click the Switch Disk button if necessary to select the proper disk for installation; then click Install or press Return.

This procedure performs an Easy Install of OpenDoc. You can choose to install any or all of the components in the OpenDoc set by choosing Custom Install from the pop-up menu. There's almost no reason I can think of for you to do that, but you can.

After some whirring and clicking (and inserting floppy disks if you are installing from floppies), you'll be told the installation was successful. Click the Quit button.

That's it!

**OpenDoc Essentials**

The first thing you see after clicking the Start button is the Install OpenDoc Essentials window. Click the Switch Disk button if necessary to select the proper disk for installation; then click Install or press Return.
After some whirring and clicking (and inserting floppy disks if you are installing from floppies), you’ll be told the installation was successful. Click the Quit button.

That’s it!

**QuickDraw 3D**

The first thing you see after clicking the Start button is the QuickDraw 3D splash screen. Click the Continue button. The Install QuickDraw 3D window appears. Click the Switch Disk button if necessary to select the proper disk for installation; then click Install or press Return.

This procedure performs an Easy Install. You can choose to install any or all of the components in the QuickDraw 3D set by choosing Custom Install from the pop-up menu. There’s almost no reason I can think of for you to do that, but you can.

After some whirring and clicking (and inserting floppy disks if you are installing from floppies), you’ll be told the installation was successful. Click the Quit button.

That’s it!

**MacLinkPlus**

The first thing you see after clicking the Start button is the MacLinkPlus splash screen. Click the OK button. The Install MacLinkPlus window appears. Click the Switch Disk button if necessary to select the proper disk for installation; then click Install or press Return.

This procedure performs an Easy Install of MacLinkPlus. You can choose to install any or all of the components in the MacLinkPlus set by choosing Custom Install from the pop-up menu. There’s almost no reason I can think of for you to do that, but you can.

After some whirring and clicking (and inserting floppy disks if you are installing from floppies), you’ll be told the installation was successful. Click the Quit button.

That’s it!
Apple Remote Access Client

The first thing you see after clicking the Start button is the Apple Remote Access Client splash screen. Click the Continue button. The Install Apple Remote Access Client window appears. Click the Switch Disk button if necessary to select the proper disk for installation; then click Install or press Return.

This procedure performs an Easy Install of Apple Remote Access Client. You can choose to install any or all of the components in the Apple Remote Access Client set by choosing Custom Install from the pop-up menu. There's almost no reason I can think of for you to do that, but you can.

After some whirring and clicking (and inserting floppy disks if you are installing from floppies), you'll be told the installation was successful. Click the Quit button.

That's it!

Cyberdog

The first thing you see after clicking the Start button is the Cyberdog splash screen. Click the Continue button. Another license agreement appears. Click Agree. The Install Cyberdog window appears. Click the Switch Disk button if necessary to select the proper disk for installation; then click Install or press Return.

This procedure performs an Easy Install of Cyberdog. You can choose to install any or all of the components in the Cyberdog set by choosing Custom Install from the pop-up menu. There's almost no reason I can think of for you to do that, but you can.

After some whirring and clicking (and inserting floppy disks if you are installing from floppies), you'll be told the installation was successful. Click the Quit button.

That's it!

Open Transport PPP

The first thing you see after clicking the Start button is the Open Transport PPP splash screen. Click the Continue button. The OT/PPP Installation window appears. Click the Switch Disk button if necessary to select the proper disk for installation; then click Install or press Return.
Appendix A: Anyone Can Install Mac OS 7.6

This procedure performs an Easy Install of Open Transport PPP. You can choose to install any or all of the components in the Open Transport PPP set by choosing Custom Install from the pop-up menu. In this case, there are some files — like modem scripts — that you may want to install individually.

After some whirring and clicking (and inserting floppy disks if you are installing from floppies), you'll be told the installation was successful. Click the Quit button.

That's it!

**English Text-to-Speech**

The first thing you see after clicking the Start button is the English Text-to-Speech splash screen. Click the Continue button. Another license agreement appears. Click Agree. The Install English Text-to-Speech window appears. Click the Switch Disk button if necessary to select the proper disk for installation; then click Install or press Return.

This procedure performs an Easy Install of English Text-to-Speech. You can choose to install any or all of the components in the English Text-to-Speech set by choosing Custom Install from the pop-up menu. There's almost no reason I can think of for you to do that, but you can.

After some whirring and clicking (and inserting floppy disks if you are installing from floppies), you'll be told the installation was successful. Click the Quit button.

That's it!

**Optional Mac OS Items**

Some Mac OS components — including useful ones such as Easy Access and CloseView — require separate installation using the Custom Install feature. (A complete list of the files available through this technique appears in a sidebar in Chapter 17.)

To install these optional components, follow the directions in the first section right up until the part where you click the Start button.

Instead of clicking the Start button, click the Customize button. The Custom Software Installation window appears. Unclick everything but Mac OS 7.6, as shown in Figure A-8.
Now click the Start button or press Return. You'll see the Welcome to Mac OS splash screen. Click the Continue button. Another license agreement appears. Click Agree. The Install System Software window appears. Finally, Click the Switch Disk button if necessary to select the proper disk for installation; then choose Custom Install from the pop-up menu as shown in Figure A-9.

Click the check box next to items you want to install and then click the Install button or press Return. After some whirring and clicking (and inserting floppy disks if you are installing from floppies), you'll be told that the installation was successful. Click the Quit button.

That's it!

And that's the end of this appendix!
Appendix A: Anyone Can Install Mac OS 7.6

Figure A-9: After choosing Custom Install from the pop-up menu, you can install any or all optional items.
Appendix B

Back Up Now or Regret It Later

Although Macs are generally reliable beasts, someday your hard disk will die. I promise. They all do. And if you haven’t backed up your hard disk, there’s a good chance that you’ll never see your files again. And if you do see them again, it’ll only be after paying Scott at the DriveSavers data recovery service a king’s ransom, with no guarantee of success. DriveSavers is the premier recoverer of lost data on hard disks. They do good work and can often recover stuff nobody else could. They charge accordingly.

I’m going to give you DriveSavers’ phone number. It’s 415-883-4232. Now pray you never need it. Back up often and you won’t. If, somehow, none of this sinks in, tell Scott I said “Hi.”

In other words, you absolutely, positively, without question MUST BACK UP. Just as you’ve adopted the Shut Down command and made it a habit, you must learn to back up your hard disk and back it up often.

How often is often? That depends on you. How much work can you afford to lose? If the answer is that losing everything you did yesterday would put you out of business, you need to back up daily, or possibly twice a day. If you’d only lose a couple of unimportant letters, you can back up less frequently.

Backing Up Is (Not) Hard to Do

There are lots of ways to back up your hard disk. Some are better than others.

The manual, “brute force” method

Drag your files a few at a time to floppy disks.

Yuk. If it sounds pretty awful, trust me, it is. It takes forever; you can’t really tell if you’ve copied every file; and there’s no way to only copy files that have been modified since your last backup. Almost nobody sticks with this method for long.
Commercial backup software

There's nothing else in this book that I'm going to insist that you buy, but you must buy backup software if you don't already have some.

For some unfathomable reason, Apple has never seen fit to provide backup software with new Macintoshes or include it with System software releases. I know some Performas have a crummy backup program, but Apple has left millions of Mac owners clueless.

Mac owners get nothing more than a brief passage regarding backing up in the Macintosh User's Guide. It ought to be in big red letters, in the first chapter, and include a warning from the Surgeon General or something. And it wouldn't kill them to provide a backup utility either. Sheesh, even DOS has a backup command, albeit a lousy one.

C'mon, Apple, give Mac owners a fair shake. At least include the Apple Backup program Performa owners get.

Fortunately, plenty of very good backup software is available for well under $100, including the excellent DiskFit Pro or DiskFit Direct from Dantz Development. If you want the best, most flexible, most powerful, top-of-the-line backup software, spend a little more and pop for Retrospect.

Backup software automates the task of backing up. The backup software remembers what is on each backup disk and only backs up files that have been modified since the last backup. Your first backup with commercial software should take no more than 90 minutes and a few dozen 1.4MB floppy disks. (Better: Zip, SyQuest, Bernoulli, magneto-optical, or Jaz disks.) Subsequent backups, called incremental backups in backup software parlance, should only take a few minutes.

Be sure to label the disks that you use for your backups because, during incremental backups, the backup software is going to ask you to "Please insert backup disk 7." If you haven't labeled your disks clearly, you have a problem.

Why You Need Two Sets of Backup Disks

You're a good soldier. You back up regularly. You think you're immune.

Now picture this: One day you take a floppy disk to QuicKopyLazerPrintz to print your resume on their laser printer. You make a few changes while at QuicKopyLazerPrintz and take the floppy home and stick it into your Mac.
Unbeknownst to you, the floppy became infected with a computer virus at QuickCopyLazerPrintz. (I discuss viruses in the "Virus trivia" sidebar.) When you inserted the disk into your Mac, the infection spread to your hard disk like wildfire.

Then you backed up. Your backup software, believing that all the infected files have been recently modified (well, they had — they’d been infected with a virus!), proceeds to back them up. You notice that the backup takes a little longer than usual, but otherwise, things seem to be okay.

A few days later, your Mac starts acting strangely. You borrow a copy of that excellent virus detection software, Disinfectant, and discover that your hard disk is infected. “Ah ha,” you exclaim. “I’ve been a good little boy/girl, backing up regularly. I’ll just restore everything from my backup disks.”

Not so fast, bucko. The files on your backup disks are also infected.

This scenario demonstrates why you need multiple backups. If you had several sets of backup disks, chances are pretty good that one of the sets would be clean.

I keep three backup sets. I use one on even-numbered days, one on odd-numbered days, and the third I update once a week and store in my bank’s vault. This scheme ensures that no matter what happens, even if my office burns, floods, is destroyed by a tornado or hurricane, or is robbed, I won’t lose more than a few days worth of work. I can live with that.

---

**Virus trivia**

A computer virus, in case you missed it in *Time* or *Newsweek*, is a nasty little piece of computer code that replicates and spreads from disk to disk. Most viruses cause your Mac to misbehave; some viruses can destroy files or erase disks with no warning.

If you use disks that have been inserted in other computers, you need some form of virus detection software. If you download and use files from Web and FTP sites on the Internet, you need some form of virus detection as well.

Don’t worry much if you download files from commercial online service such as America Online or CompuServe. They are very conscientious about viral infections. Do worry about that Web site called Pirates Den that an unsavory friend told you about.

John Norstad’s excellent virus detection and eradication software, Disinfectant, is widely available and is freeware. Just make sure that you have the latest version, as new viruses appear on the scene every so often, and Disinfectant (and all antivirus software) requires updating to detect and fight them.

On the commercial front, Virex and SAM (Symantec Anti-Virus for Macintosh) have

(continued)
their fans. I'm using Virex right now but have used others at one time or another and have never gotten a virus.

The big advantage of a commercial antivirus program is that the publisher will contact you each time a virus is discovered and provide you with a software update to protect you against the new strain. Or for a fee, the publisher can send you a new version of the software every time a new virus is found.

If you only use commercial software and don't download files from Web sites with strange names, you have a very low risk of infection. On the other hand, if you swap disks with friends regularly, shuttle disks back and forth to other Macs, use your disks at service bureaus or copy shops, or download files from various and sundry places on the Internet, you are at risk.

If you're at risk, either download a new copy of Disinfectant each time a new virus is discovered or buy a commercial antivirus program.
Numbers
3D graphics, 346
3DMF file format, 346–347
3DMF Models folder, 347

A
About Automated Tasks file, 284
About QuickDraw GX document, 155
access privileges, 192–196
depositing files, 195
everyone, 193–194
many folders at once, 196
one person or one group, 194
owner, 193–194
protecting folder, 196
read-only, 195
registered group or user, 193
actions, undoing, 66
active applications, 85–86
window, 32, 63
acute accent (Option-e) keyboard shortcut, 97
ADB (Apple Desktop Bus), 13
Adobe Photoshop, 125
alert sounds, 100, 270–271
Alerts control panel, 270–271
aliases, 20, 46, 59, 107, 139–146
adding to Apple menu, 144
Apple Menu Items folder, 107, 146
applications, 140–141
Automated Tasks folder, 284
Control Panels folder, 103
creation of, 140–141
desktop, 141–142
Documents folder, 199
dragging and dropping to start applications, 142–144
frequently used folders or documents, 141
hard disk, 144, 200
icons on desktop, 140
italic name of, 59
Launcher, 265
Launcher Items folder, 132–133
Startup Items folder, 241
temporary, 141
aligning icons on-screen, 78–79
alphabetical listing of icons, 70
Altavista search engine, 336
Apple CD-ROM extension, 307
Apple Color SW Pro CMM extension, 307
Apple Extras folder, 284
Apple Extras: QuickDraw GX Extras folder, 176
Apple Guide documents, 314. See also Mac OS Guide
Apple Guide extension, 307
Apple HD SC Setup, 360
startup disk, 15
Apple laser printer configuration, 349
Apple LocalTalk Locking Connector Kits, 183
Apple Locking Cable Kits, 183
Apple menu, 87, 88–102
adding alias to, 144
alphabetical sorting of, 235
author's sorting of, 240
Automated Tasks folder, 105
Bullet (Option-8) preceding name, 237
centering name in divider lines, 238
Clipboard aliases as divider lines, 237
Control Panels folder, 104
customizing, 105–107, 235–241
DAs (desk accessories), 87, 90–102
Desk Accessories folder, 106–107
divider lines, 237
empty folders, 237
folders, 102, 104
forcing items to appear at top of, 235–236
guage accent (') key, 240
Guy Kawasaki desktop example, 152
hard disk alias, 144
hierarchical submenus, 87, 102–103, 238
iconless divider lines, 238–239
My Favorite Programs folder, 107
numbers preceding name, 235–236
Recent Applications folder, 102, 104–105
Recent Documents folder, 104–105
Recent Servers folder, 104–105
space preceding name, 236
submenu for Control Panels folder, 293
submenus, 90
tilde (-) key and sorting, 240
tips for usage, 144
Apple Menu Items folder, 105
alias on desktop, 146
Automated Tasks folder, 284
aliases, 59, 107
automatically placing alias on, 144
disk space usage, 318
hard disk alias, 144
listing items by name, 105
Apple Menu Options control panel, 103–104
FIFO (first in, first out), 246
Apple Menu Options control panel (continued)
Remember recently used items option, 104
submenu, 144
tracking documents, applications, and servers, 245–246
turning hierarchical submenus on/off, 245–246
Apple menu➔About This Computer command, 16, 88–89, 209, 211, 294
Apple menu➔About This Macintosh command, 294
Apple menu➔Automated Tasks➔Add Alias to Apple Menu command, 144
Apple menu➔Chooser command, 184, 197, 200
Apple menu➔Control Panels command, 103
Apple menu➔Control Panels➔Apple Menu Options command, 104
Apple menu➔Control Panels➔AppleTalk command, 185
Apple menu➔Control Panels➔Extensions Manager command, 258
Apple menu➔Control Panels➔General Controls command, 132
Apple menu➔Control Panels➔Launcher command, 132
Apple menu➔Control Panels➔Memory command, 213, 215
Apple menu➔Control Panels➔Modems command, 326
Apple menu➔Control Panels➔PPP command, 327, 329
Apple menu➔Control Panels➔Sharing Setup command, 186, 202
Apple menu➔Control Panels➔TCP/IP command, 328
Apple menu➔Control Panels➔Users & Groups command, 188, 190
Apple menu➔Find File command, 60
Apple menu➔SimpleSound command, 9
Apple menu➔Simple Sound command, 271
Apple Photo Access extension, 307
Apple printer drivers, 155
Apple printers, 155
Apple Remote Access control panel, 203–206, 347
installing, 382
Apple RGB color picker, 265
Apple System Profiler, 91
Apple’s technical support lines, 355
apple.cyberdog newsgroup, 335
AppleCD Audio Player, 91–92
AppleScript
Apple Extras folder, 284
AppleScript enabled programs, 285
AppleScript folder, 284
AppleScript Guide, 284
AppleScriptLib extension, 283
attachable programs, 285
Automated Tasks folder, 284
extensions, 283
Extensions folder, 283
learning, 284
modules, 283–284
My first stupid script, 286–288
recordable programs, 285
recording multistep sequences, 282
sample scripts, 284
saving scripts, 288–289
Script Editor, 283–287, 289
scriptable programs, 285
Scripting Additions folder, 283–284
scripts looking for something to happen, 290
self-running script, 289
text file of script, 289
unable to edit scripts, 290
where Mac OS 7.6 installs parts of, 283–284
writing script, 286–288
AppleScript enabled programs, 285
AppleScript extension, 307
AppleScript folder, 284
AppleScript Guide, 284
AppleScript scripts, 105
AppleScriptLib extension, 283, 315
AppleShare extension, 313
AppleShare file servers, 202
AppleTalk, 184–185, 197
active or inactive, 157
choosing connection from, 185
printers, 156
reasons to use, 157
turning on, 184–185
AppleTalk control panel, 247, 297
AppleVision extension, 313
Application folder, 40
application icons, 20–21
Application menu, 85–86
Application➔Hide command, 86
Application➔Hide Others command, 86
Application➔Show All command, 86
Application➔Show command, 86
applications, 21. See also programs
active, 85–86
adding to Apple menu, 107
adjusting memory for, 211–212
aliases, 107, 139–141
amount of memory used by, 88
AppleScript enabled, 285
DAs (desk accessories) vs., 319
exchanging information with, 187
linking, 182, 187
memory, 210
multiple open at one time, 86
not enough memory for, 89
opening another
application's document, 266–268
Page Setup dialog box, 154, 163
Page Setup or Print Setup
commands, 158
Print dialog box, 154, 164
recently used, 104–105
reducing memory allocated
to, 89–90
searching network for, 267
starting by opening files, 142–144
storing, 139
tracking, 245–246
translators, 55
unable to open themselves, 127
windows, 27, 35
Applications folder, 135, 139
Archived Type 1 Fonts
folder, 176
Are you sure you want to
rebuild the desktop file
message, 357
arrow keys and scrolling
windows, 31
ATM (Adobe Type Manager)
control panel, 248, 304
attachable programs, 285
Audio CD Access extension,
92, 307
audio CDs, 91–92, 275
author
Apple menu sorting, 240
confessions of, 108–109
Auto Remounter control
panel, 297
AutoDoubler, 291
Automated Tasks folder,
105, 284, 289
automatically
launching items at startup,
241–243
loading extensions and
control panels, 258
opening parent files, 59
starting Launcher, 265
turning Macintosh off,
257–258
automating tasks, 105
AutoRemounter control
panel, 249–250

• B •
background printing,
167–168
backing up
brute force method, 387
commercial backup
software, 388
files, 122–123, 292–293
hard disk, 17
incremental backups, 388
labeling disks, 388
software, 351
two sets of disks, 388–389
viruses, 389
bad System software, 353
crashing at startup,
364–372
flashing question mark
problems, 355–364
reinstalling, 363
Sad Mac and chimes of
doom, 354–355
Balloon Help, 82, 154
Becker, Loftus E., Jr. (Lofty)
desktop example, 148
beep sounds, 270–271
Big Island Yo-Yo, 109
bit depth, 231
bitmap fonts, 180
black and white printing, 169
Bobker, Steven desktop
desktop example, 148
bootable CD-ROM, 15
booting, 16
bootstrapping, 16
borders, printing, 170
Brightness control panel,
250–251
Brown, Glenn desktop
desktop example, 149–150
browsers, 323–329
bugs, 126
built-in automation tool, 281
bullet character (Option-8)
keyboard shortcut, 133,
237, 240
busses, 13

• C •
cables
LocalTalk networks, 183
modems, 325
printers, 154
SCSI devices, 363
unplugging and plugging
in, 10
Calculator, 92–93
Cancel (Command-period)
keyboard shortcut
99–100
clicking icons, 22
Clipboard, 64–68, 319
aliases as divider lines in
Apple menu, 237
copying items to, 68
cutting item to, 66–67
pasting items from, 68
temporary storage area, 65
viewing contents, 67
Clipboard icon, 67
Clipping extension, 308
clock, configuring, 252–255
Close All Windows (Command-Option-W)
  keyboard shortcut, 287
close box, 33-34
Close Window (Command-W) keyboard shortcut, 33-34, 55, 101, 185
CloseView control panel, 343-344
closing windows, 32-34, 55
color
  consistency between
    screen representation and output, 251-252
monitors, 269
  number displayed on-screen, 229-230
printing, 169
  scroll bar accent, 251
text highlights, 251
time-saving tips, 228-233
title bar accent, 251
  window highlight, 251
Color control panel, 231, 251, 297
color monitors, 269
  bit depth, 231
  number of colors displayed, 229-230
pixels, 228
redrawing, 229
refreshing, 229
settings, 228-229
updating, 228
video cards, 230
window color, 231
Color Picker extension, 308
color-matching technology, 251-252
ColorSync extension, 308
ColorSync System Profile control panel, 251-252, 298
commands, 50
Apple menu: About This Computer, 16, 88-89, 209, 211
Apple menu: About This Macintosh, 294
Apple menu: Automated Tasks: Add Alias to Apple Menu, 144
Apple menu: Chooser, 184, 197, 200
Apple menu: Control Panels, 103
Apple menu: Control Panels: Apple Menu Options, 104
Apple menu: Control Panels: AppleTalk, 185
Apple menu: Control Panels: Extensions Manager, 258
Apple menu: Control Panels: General Controls, 132
Apple menu: Control Panels: Launcher, 132
Apple menu: Control Panels: Memory, 213, 215
Apple menu: Control Panels: Modems, 326
Apple menu: Control Panels: PPP, 327, 329
Apple menu: Control Panels: Sharing Setup, 186, 202
Apple menu: Control Panels: TCP/IP, 328
Apple menu: Control Panels: Users & Groups, 188, 190
Apple menu: Find File, 60
Apple menu: Shut Down, 9
Apple menu: SimpleSound, 271
Application: Hide, 86
Application: Hide Others, 86
Application: Show, 86
Application: Show All, 86
Change Setup, 173
Cyberdog: Add Window to Notebook, 331
Edit: Clear, 68, 99-100
Edit: Copy, 57, 68, 95, 99, 239
Edit: Cut, 66-67, 99
Edit: Paste, 57, 68, 95, 99, 239
Edit: Preferences, 242
Edit: Select All, 69
Edit: Show Clipboard, 67
Edit: Undo, 66
Edit: User Mode, 247
File: Close, 101, 185
File: Close All, 34, 287
File: Close Window, 33-34, 55
File: Configurations, 247
File: Duplicate, 43, 58
File: Find, 60-62, 94
File: Find Again, 62
File: Get Info, 26, 55-58, 239, 247
File: Go To Note, 98
File: Info, 89, 95, 212
File: Make Alias, 59, 107, 140, 144
File: New, 112
File: New Folder, 40, 54, 106, 287
File: New Group, 190
File: New Set, 259
File: New User, 188
File: Open, 23, 54, 61, 172
File: Open Enclosing Folder, 61
File: Page Setup, 63
File: Print, 54-55, 158, 164
File: Print Desktop, 63
File: Print Window, 63
File: Put Away, 38, 47, 60, 200
File: Quit, 376-377
File: Save, 114, 122, 204, 288
File: Save As, 121-123, 288
File: Sharing, 58, 192, 203
Functions: Initialization Options, 360-361
Functions: Update Driver, 360
Get Printer Info, 173
Help: About Help, 82
Help: Hide Balloons, 82
Help: Mac OS Guide, 83-84
Help: Shortcuts, 85
Help: Show Balloons, 82
keyboard shortcuts, 23
Open, 22
Printing: PPD Maker Setup, 178
Set Default Printer, 174
Show Manual Feed Alert, 174
Sound: Speak All, 348
Sound: Speak Selection, 275
Sound <> Stop Speaking, 348
Special <> Clean Up, 78–79
Special <> Clean Up Desktop, 78
Special <> Eject Disk, 37, 79
Special <> Empty Trash, 25–26, 56, 79, 221
Special <> Erase Disk, 36, 79, 221
Special <> Restart, 80, 365
Special <> Shut Down, 9, 81, 201
Special <> Sleep, 81
Start Print Queue, 173
Stop Print Queue, 173
toggling, 66
View <> by Date, 72
View <> by Icons, 69
View <> by Kind, 72
View <> by Label, 72
View <> by Name, 70, 105
View <> by Size, 71
View <> by Small Icons, 70
commercial backup software, 388
computers, booting, 16
confessions of author, 108–109
Configurations (Command-K) keyboard shortcut, 247
configuring
Apple laser printer, 349
Launcher, 132
Modem control panel, 326
PPP control panel, 327
TCP/IP control panel, 328
Conflict Catcher II, 109, 258, 369–370
Connect dialog box, 198–200
connecting
multiple SCSI devices, 362–363
printers to Macintosh, 154
connectors and LocalTalk networks, 183–184
control panels, 245, 294–296
accessing, 104
adding, 103
Alerts, 270–271
Apple Menu Options, 103, 245–247
Apple Remote Access, 203–206, 347
AppleTalk, 185, 247
ATM (Adobe Type Manager), 248
automatically loading, 258
AutoRemounter, 249–250
Brightness, 250–251
CloseView, 343–344
Color, 231, 251
ColorSync System Profile, 251–252
Control Strip, 243, 252
Date & Time, 103, 252–255
definition of, 103
Desktop Patterns, 255–256
DialAssist, 205–206, 256
disabling, 213, 294–304
disk space used, 304–305
Easy Access, 340–342
Editor Setup, 256
Energy Saver, 81, 257–258
Extensions Manager, 213, 258–260, 295
File Sharing Monitor, 201–202, 260
forcing to load first, 368–369
General Controls, 40, 103, 260–263
grouping, 259
icons, 21
Keyboard, 103, 263–264
Labels, 264–265
Launcher, 132–135, 265–266
MacLinkPlus Setup, 268
managing, 258–260
Map, 268
Memory, 103, 210, 213–217, 268–269
MEO (Mac OS Easy Open), 266–268
Modem, 269
Monitors & Sound, 229–230, 269
Mouse, 272
Numbers, 272–273
PC Exchange, 273–274
PPP (point-to-point protocol), 274
QuickTime Settings, 275
RAM (Random Access Memory) used, 294, 304
Remote Access Setup, 275
replacing and reordering, 367–369
resolving conflicts, 365–367
restarting without, 364–365
running from floppy disk, 294
scripts, 288
Sharing Setup, 186–187, 202–203, 274
Speech, 275–276
Startup Disk, 222, 276
System Folder, 297–305
TCP/IP, 277
Text, 277
third-party, 294
turning all on, 295
turning off, 211
Users & Groups, 188–191, 278
Views, 75, 78, 232–233, 278–279
WindowShade, 35, 279–280
The control panel cannot be used with this Macintosh message, 251
Control Panels folder, 103–104, 245, 258, 293–294
Control Strip control panel, 12, 243–244, 252, 298
Control Strip Modules, 243, 319
Control Strip Modules folder, 298
Cool Internet Site of the Day site, 336
Copy (Command-C) keyboard shortcut, 68, 99
copying
in folders, 41–43
items, 68
Could not find the application program message, 143
cover pages, printing, 168–169
crashing at startup
clean System reinstallation, 370–372
replacing and reordering
extensions and control panels, 367–369
resolving extension and control panel conflicts, 365–367
crashing at startup  
(continued)  
restarting without exten-
sions and control panels, 364–365  
currency, 272  
cursor, 24, 341  
Custom Software Installation 
window, 379–380  
customizing  
Apple menu, 105–107, 
235–241  
Control Strip, 244  
internal clock, 255  
Cut (Command-X) keyboard 
shortcut, 66–67, 99  
cutting items, 66–67  
Cyberdog, 324–325, 328–335, 
345  
apple.cyberdog 
newsgroup, 335  
feature suggestions, 334  
folders, 334  
FTP (file transfer protocol), 
334  
history of pages visited, 
333  
home page, 332–333  
hot links, 333  
installing, 382  
notebook page, 331  
sending and receiving 
e-mail, 334  
starting, 331  
storng information, 335  
Web pages, 331  
Cyberdog Downloads folder, 
334  
Cyberdog>Add Window to 
Notebook command, 
331

DAs (desk accessories), 87  
Apple System Profiler, 91  
AppleControl Audio Player, 
91–92  
aplications vs., 319  
Calculator, 92–93  
Chooser, 93, 154–157  
Find File, 94  
Graphing Calculator, 93–94  
Jigsaw Puzzle, 94–96  
Key Caps, 96–97  
Note Pad, 98  
putting into folder, 106–107  
Remote Access Disconnect, 
98  
Scrapbook, 99–100  
Shut Down, 101–102  
SimpleSound, 100  
Stickies, 100–101  
DataViz, 319  
Date & Time control panel, 
103, 252–255, 298  
Date Format dialog box, 
253–254  
dates, 253–254  
default printer, 174  
Delete key, 68  
deleting 
files, 79  
icons, 25  
items, 25, 68  
Mac OS 7.6 files, 292  
preferences files, 321  
Desk Accessories folder, 
106–107  
desktop, 12, 19–27  
aliases, 46, 59, 140–142  
aligning icons on, 78  
Apple Menu Items folder 
alias, 146  
cluttered, 47  
confessions of author, 
108–109  
control strip, 12  
desktop printer, 157  
disk icons, 46  
Glenn Brown example, 
149–150  
Guy Kawasaki example, 152  
icons, 19–27, 46, 76  
Lofty Becker example, 
148  
Open dialog box, 115  
patterns, 255–256  
printing, 63  
putting icons away, 47  
rebuilding, 356–358  
Rich Wolfson example, 
149–150  
Robin Williams example, 
147  
Robyn Ray example, 151  
samples, 147–152  
Save dialog box, 114–115  
saving documents to, 141  
selecting icons, 11  
Steven Bobker example, 
148  
Trash icon, 46  
windows, 27  
Desktop DB file, 356  
Desktop DF file, 356  
Desktop Patterns control 
panel, 255–256, 298  
desktop printer 
commands, 173–174  
drag and drop, 172  
icons, 26–27  
PDG (portable digital 
document) format, 178  
QuickDraw GX and 
commands, 177  
reason to use, 172  
special print jobs, 172  
viewing print queue, 
172–174  
Desktop PrintMonitor, 314  
devices 
connecting, 13  
local, 182  
DialAssist control panel, 
205–206, 256, 298  
dialog boxes 
canceling, 119  
check boxes, 52–53  
pop-up menus, 51  
radio buttons, 50–51  
text-entry boxes, 52  
DIMMs (dual inline memory 
module), 208  
Disinfectant, 389–390  
disk cache, 214–217  
Disk First Aid, 15  
flashing question mark 
problems, 358–359  
disk icons, 46  
disk space 
Apple Menu Items folder 
usage, 318  
control panel usage, 
304–305  
extension usage, 317–318  
Disk Tools, 15, 356  
restarting Macintosh with, 
360  
Sad Mac and Chimes of 
Doom, 354  
DiskFit, 351  
DiskFit Direct, 388
file sharing (continued)
description of, 182
disconnecting from shared
directory or disk, 200-201
disconnecting users, 201-202
Documents folder, 198-199
easily opening remote
Documents folder, 199
groups, 187-190
guests, 188, 191
information about shared
items, 260
linking programs, 182
local devices, 182
logging on remotely with
modem, 203-206
Macintosh owner, 188
monitoring, 201-202
networks, 182
password, 198
removing users or groups, 191
sharing directory or disk, 192-193
unsharing directory or disk, 203
users, 187-190
viewing shared items and
connected users, 201-202
File Sharing Monitor control
panel, 201-202, 260, 299, 308
File→Save command, 122
File→Close All command, 34, 287
File→Close command, 101, 185
File→Close Window com-
mand, 33-34, 55
File→Configurations com-
mand, 247
File→Duplicate command, 43, 58
File→Find Again command, 62
File→Find command, 60-62, 94
File→Get Info command, 26, 55-58, 239, 247
File→Go To Note command, 98
File→Info command, 89, 95, 212
File→Make Alias command, 59, 107, 140, 144
File→New command, 112
File→New Folder command, 40, 54, 106, 287
File→New Group command, 190
File→New Set command, 259
File→New User command, 188
File→Open command, 23, 54, 61, 172
File→Open Enclosing Folder
command, 61
File→Page Setup command, 63
File→Print command, 54-55, 158, 164
File→Print Desktop com-
mand, 63
File→Print Window com-
mand, 63
File→Put Away command, 38, 47, 60, 200
File→Quit command, 376-377
File→Save As command, 121-123, 288
File→Save command, 114, 204, 288
File→Sharing command, 58, 192, 203
FileMaker Pro, 285
files
aliases, 59
backing up, 122-123, 292-293, 387-389
deleting, 79
duplicating, 58
information about, 55-56
invisible, 126
labeling, 76-77
launching, 265
locating, 60-62, 94
locked, 56
management, 53-64, 131-146
Move & Rename, 126
naming, 117-118
opening, 54, 61, 132
opening and launching
programs, 142-144
organizing, 73
printing, 54-55
putting away, 60
quick openers for, 139-146
repeating find, 62
resaving, 122
saving under different
name, 121-123
sharing, 58, 93
sizes and PostScript,
170-171
translation software,
345-346
VM Storage, 126
with weird names, 126
Find (Command-F) keyboard
shortcut, 23, 60-62
Find Again (Command-G)
keyboard shortcut, 62
Find dialog box, 60-62
Find File extension, 94, 309
Find File Results window, 61
Finder, 26, 46, 320
ease of returning to, 261
Geneva font, 232
hiding windows and icons,
261
icon, 21, 26
managing window appear-
ances, 279
selecting font for, 278
startup disk, 15
Startup Items folder, 243
Finder Scripting extension,
310
first-time Macintosh user
tips, 9-12
flashing question mark
problems, 14-15
connecting multiple SCSI
devices, 362-363
installing new hard disk
drivers, 360-361
problems you may have,
364
rebuilding desktop,
356-358
running Disk First Aid,
358-359
zapping the PRAM, 361
floppy disk icons, 37-38
floppy disks
copying to hard disk, 43-45
ejecting, 37-39, 60, 118
initializing, 36
Macintosh, 36
Macintosh HFS Interchange Format, 37
PC, 36
preformatted, 36
ProDOS, 37
running control panels from, 294
folder icons, 20-21
folders, 21, 40
active in Open and Save dialog boxes, 262-263
aliases for frequently used, 141
Apple menu, 102, 104
calculating sizes of, 279
connecting to shared, 196-199
copying in, 41-43
copying or moving items, 74
disconnecting from shared, 200-201
frequently used items, 132
hierarchy, 41
icons, 40
management, 53-64
moving, 41-43
moving items into, 41-42
naming, 40
navigating through, 115-117
nested, 112-113
new, 40, 54, 119
opening, 61
Option-dragging, 43
path menu, 113
protecting, 262
root level, 138
sharing, 192-193
sizes of, 279
structure, 137
subfolders, 40-41
triangles next to, 73, 103
unsharing, 203
viewing contents, 73
viewing path, 113
weird-named, 126
fonts, 179-180, 320
converting PostScript Type I to QuickDraw GX-compatible, 350
eliminating jaggies on-screen, 248
including in PostScript file, 170
list views, 75
proportional, 226
removing, 180
selecting for Finder, 278
viewing characters in, 96-97
Force Quit (Command-Option-Esc) keyboard shortcut, 80
Foreign File Access extension, 310
foreign languages
keyboard, 264
Mac OS 7.6 version, 277
FTP (file transfer protocol), 334
Functions>>Initialization Options command, 360-361
Functions>>Update Driver command, 360

· G ·
games, 351
virtual memory, 218
General Controls control panel, 40, 103, 260-263, 265, 299
Geneva font, 232
Get Info (Command-I)
keyboard shortcut, 26, 55-56, 58, 89, 95, 212, 239, 247
Get Info window, 55-57, 89, 95, 212
Global Guide Files folder, 316
Graphing Calculator, 93, 94
grave accent (Option-) keyboard shortcut, 97
groups
file sharing and, 187-190
new, 190
registered, 193
removing, 191
guests, 191

· H ·
Hands-On icon, 4
happy Macintosh, 11-12
hard disks
alias, 144, 200
Applications folder, 135, 139
backing up, 17, 387-389
copying floppy disks to, 43-45
copying System Folder to, 45
deleting items from, 25
Documents folder, 135-137
folders at root level, 138
initializing, 360-361
installing drivers, 15, 360-361
mirror image of, 293
need for more space, 291-292
organizing, 135-139
problems with, 354
reinstalling OS to, 16
repairing hidden damage to, 15
root level, 45, 135
simple structure, 135
sleep patterns, 257
startup, 276
updating driver, 377
viewing icons on, 114
hardware
Big Island Yo-Yo, 109
failure and startup, 14
help, 81-85
Help menu, 81-85
Help>>About Help command, 82
Help>>Hide Balloons command, 82
Help>>Mac OS Guide command, 83-84
Help>>Shortcuts command, 85
Help>>Show Balloons command, 82
hierarchical submenus, 87, 102-103, 245-246
High Sierra File Access extension, 310
hot spot, 25
Hotbot search engine, 336
•1•

- 1-beam cursor, 24
- icon views, 69, 70
- icons, 19-27
- aliases, 20, 59
- aligning on-screen, 78-79
- alphabetical listing, 70, 79
- application, 20-21, 72
- changing to another icon, 57
- clicking, 22
- collections of, 57
- control panel, 21
- deleting, 25
- descending size order, 71
- desktop printer, 26-27, 171
- document, 20-21, 72
- double-clicking, 23
- extension, 21
- Finder, 21
- folders, 20-21, 40, 72
- fuzzy gray, 28
- inverting, 25
- keyboard movement
  among, 75-76
- label order, 72
- list views, 70-72
- locating, 60-62
- locked, 26
- Macintosh HD, 19
- modification date order, 72
- moving between disks,
  43-44
- next, 31
- Open dialog box, 115
- opening, 22-23
- PC disk, 36
- PPD Maker GX, 178
- printer, 155
- putting away, 47, 60
- renaming, 24
- residing on desktop, 46
- Save dialog box, 115
- selecting, 11, 45-46, 69, 106
- small, 70, 232
- snapping to invisible grid,
  278
- System software, 20-21
- Trash, 25
- viewing, 69-72
- viewing from Save dialog box, 114

Ignore Internal Disk (Delete-Option-Command-Shift)
keyboard shortcut, 15
inactive windows, 32
incremental backups, 388
information about
Macintosh, 91
initializing
floppy disks, 36
hard disks, 360-361
INITPicker, 258
insertion point blinking rate, 262
Install Disk 1, 376
Install Mac OS program, 293,
  370, 376
  clean reinstallation, 371
Create New System Folder option, 371
Custom Remove option, 339
Custom Software Installation window, 378-380
license agreement, 378
Mac OS 7.6 Read Me file, 376
  Options button, 371
  Select button, 377
  Software Installation window, 377
  updating hard disk driver, 377
installing
Apple Remote Access, 382
Cyberdog, 382
English Text-to-Speech, 383
fonts, 179-180
hard disk drivers, 15
MacLinkPlus, 381
new hard disk drivers,
  360-361
Open Transport PPP, 382-383
OpenDoc, 380-381
printer drivers, 155
QuickDraw 3D, 381
installing Mac OS 7.6
Apple Remote Access client, 382
Custom Install option, 379-383
Cyberdog, 382
Easy Install option, 375-379
English Text-to-Speech, 383
Install Disk 1, 376
Mac OS 7.6 CD-ROM, 376
MacLinkPlus, 381
Open Transport PPP,
  382-383
OpenDoc, 380
OpenDoc Essentials window, 380-381
optional items, 383-384
QuickDraw 3D, 381
internal clock configuration,
  252-255
Internet
browsers, 323-329
built-in connectivity, 324
case sensitivity, 327
configuring Modem control
  panel, 326
configuring PPP control
  panel, 327
configuring TCP/IP control
  panel, 328
Cyberdog, 328-329,
  331-335
getting set up for surfing,
  324-328
hot links, 333
ISPs (Internet service
  providers), 325-326
logging on to ISP's network, 329-331
modems, 324-325
online services access to,
  326
overview, 323-324
search engines, 336
sources of information
  about Macintosh, 336
storing addresses, 331
surfing to Web sites, 323
Internet Config extension,
  310
invisible files, 126
ISO 9660 File Access extension, 310
ISPs (Internet service
  providers), 325-326,
  329-331

•7•

Jigsaw Puzzle, 94-96
jolting Macintosh, 10
<table>
<thead>
<tr>
<th><strong>K</strong></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Kawasaki, Guy, 336</td>
<td></td>
</tr>
<tr>
<td>desktop example, 152</td>
<td></td>
</tr>
<tr>
<td>Key Caps, 96–97</td>
<td></td>
</tr>
<tr>
<td>keyboard</td>
<td></td>
</tr>
<tr>
<td>foreign language, 264</td>
<td></td>
</tr>
<tr>
<td>key delay, 264, 342</td>
<td></td>
</tr>
<tr>
<td>key repeat rate, 264</td>
<td></td>
</tr>
<tr>
<td>moving among icons, 75–76</td>
<td></td>
</tr>
<tr>
<td>responding to keystrokes, 263–264</td>
<td></td>
</tr>
<tr>
<td>scrolling windows, 31</td>
<td></td>
</tr>
<tr>
<td>Keyboard control panel, 103, 263–264, 300</td>
<td></td>
</tr>
<tr>
<td>keyboard shortcuts, 50, 225</td>
<td></td>
</tr>
<tr>
<td>Command-? (Mac OS Guide), 83–84</td>
<td></td>
</tr>
<tr>
<td>Command-A (Select All), 69, 106</td>
<td></td>
</tr>
<tr>
<td>Command-B (Clear), 99–100</td>
<td></td>
</tr>
<tr>
<td>Command-C (Copy), 68, 99</td>
<td></td>
</tr>
<tr>
<td>Command-Control-Power-On (Reset), 80</td>
<td></td>
</tr>
<tr>
<td>Command-D (Duplicate), 58</td>
<td></td>
</tr>
<tr>
<td>Command-D (Save to Desktop), 141</td>
<td></td>
</tr>
<tr>
<td>Command-E (Open Enclosing Folder), 61</td>
<td></td>
</tr>
<tr>
<td>Command-F (Find), 23, 60–62</td>
<td></td>
</tr>
<tr>
<td>Command-G (Find Again), 62</td>
<td></td>
</tr>
<tr>
<td>Command-H (Speak Selection), 275</td>
<td></td>
</tr>
<tr>
<td>Command-I (Get Info), 26, 55–56, 58, 89, 95, 212, 239, 247</td>
<td></td>
</tr>
<tr>
<td>Command-K (Configurations), 247</td>
<td></td>
</tr>
<tr>
<td>Command-M (Make Alias), 59, 107, 140, 144</td>
<td></td>
</tr>
<tr>
<td>Command-N (New Folder), 23, 40, 54, 106, 287</td>
<td></td>
</tr>
<tr>
<td>Command-O (Open), 23, 54, 61, 172</td>
<td></td>
</tr>
<tr>
<td>Command-Option (Rebuild Desktop), 357</td>
<td></td>
</tr>
<tr>
<td>Command-Option-Esc (Force Quit), 80</td>
<td></td>
</tr>
<tr>
<td>Command-Option-P-R (Zap PRAM), 361</td>
<td></td>
</tr>
<tr>
<td>Command-Option-W (Close All Windows), 287</td>
<td></td>
</tr>
<tr>
<td>Command-P (Print), 54, 153, 164</td>
<td></td>
</tr>
<tr>
<td>Command-period (Cancel), 39, 119</td>
<td></td>
</tr>
<tr>
<td>Command-Q (Quit), 376–377</td>
<td></td>
</tr>
<tr>
<td>Command-S (Save), 122, 204</td>
<td></td>
</tr>
<tr>
<td>Command-Shift-I (Eject Disk), 38</td>
<td></td>
</tr>
<tr>
<td>Command-Shift-3 (Picture of Desktop), 142</td>
<td></td>
</tr>
<tr>
<td>Command-Shift-Clear (Mouse Keys), 341</td>
<td></td>
</tr>
<tr>
<td>Command-V (Paste), 68, 99, 239</td>
<td></td>
</tr>
<tr>
<td>Command-W (Close Window), 33–34, 55, 101</td>
<td></td>
</tr>
<tr>
<td>Command-W (Close), 185</td>
<td></td>
</tr>
<tr>
<td>Command-X (Cut), 66–67, 99</td>
<td></td>
</tr>
<tr>
<td>Command-Y (Put Away), 38, 60, 200</td>
<td></td>
</tr>
<tr>
<td>Command-Z (Undo), 66</td>
<td></td>
</tr>
<tr>
<td>Delete-Option-Command-Shift (Ignore Internal Disk), 15</td>
<td></td>
</tr>
<tr>
<td>Option-e (acute accent), 97</td>
<td></td>
</tr>
<tr>
<td>Option-2 (TM character), 240</td>
<td></td>
</tr>
<tr>
<td>Option-8 (bullet character), 133, 237, 240</td>
<td></td>
</tr>
<tr>
<td>Option-i (circumflex (*)), 97</td>
<td></td>
</tr>
<tr>
<td>Option-u (umlaut), 97</td>
<td></td>
</tr>
<tr>
<td>Option-` (grave accent), 97</td>
<td></td>
</tr>
<tr>
<td>Option-- (tilde), 97</td>
<td></td>
</tr>
<tr>
<td>Shift key five times (Sticky Keys), 342</td>
<td></td>
</tr>
<tr>
<td>Shift-Tab (Previous Icon), 75–76</td>
<td></td>
</tr>
<tr>
<td>Shift-Tab (Previous Option), 253</td>
<td></td>
</tr>
<tr>
<td>Tab (Next Icon), 75–76</td>
<td></td>
</tr>
<tr>
<td>Tab (Next Option), 253</td>
<td></td>
</tr>
<tr>
<td>typing one key at a time, 342</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>L</strong></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Label menu, 76–77, 264–265</td>
<td></td>
</tr>
<tr>
<td>labeling files, 76–77</td>
<td></td>
</tr>
<tr>
<td>Labels control panel, 264–265, 300</td>
<td></td>
</tr>
<tr>
<td>LaserWriter 8 printer driver, 155</td>
<td></td>
</tr>
<tr>
<td>LaserWriter Utility, 349</td>
<td></td>
</tr>
<tr>
<td>Launcher control panel, 132–134, 261, 265–266, 300, 320</td>
<td></td>
</tr>
<tr>
<td>Launcher Items folder, 132–134, 265</td>
<td></td>
</tr>
<tr>
<td>launching files, 265</td>
<td></td>
</tr>
<tr>
<td>lightning storms, 10</td>
<td></td>
</tr>
<tr>
<td>linking applications, 182</td>
<td></td>
</tr>
<tr>
<td>list views, 279</td>
<td></td>
</tr>
<tr>
<td>additional controls for, 75</td>
<td></td>
</tr>
<tr>
<td>copying or moving items, 74</td>
<td></td>
</tr>
<tr>
<td>fonts, 75</td>
<td></td>
</tr>
<tr>
<td>subfolders, 74</td>
<td></td>
</tr>
<tr>
<td>switching between, 70–72</td>
<td></td>
</tr>
<tr>
<td>triangles, 73</td>
<td></td>
</tr>
<tr>
<td>local devices, 182</td>
<td></td>
</tr>
<tr>
<td>LocalTalk networks, 182–185</td>
<td></td>
</tr>
<tr>
<td>locating files and icons, 60–62</td>
<td></td>
</tr>
<tr>
<td>locked files, 56</td>
<td></td>
</tr>
<tr>
<td>locked icons, 26</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>M</strong></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Mac Addict site, 336</td>
<td></td>
</tr>
<tr>
<td>Mac OS 7.6, 8</td>
<td></td>
</tr>
<tr>
<td>built-in Internet connectivity, 324</td>
<td></td>
</tr>
<tr>
<td>definition of, 8</td>
<td></td>
</tr>
<tr>
<td>foreign language version, 277</td>
<td></td>
</tr>
<tr>
<td>full installation on Zip, optical, or SyQuest drive, 294</td>
<td></td>
</tr>
<tr>
<td>individual feature installation, 293</td>
<td></td>
</tr>
<tr>
<td>installation disks or CD-ROM, 293</td>
<td></td>
</tr>
<tr>
<td>installing, 375–384</td>
<td></td>
</tr>
<tr>
<td>what you will see after turning power on, 11–12</td>
<td></td>
</tr>
<tr>
<td>where it installs parts of AppleScript, 283–284</td>
<td></td>
</tr>
</tbody>
</table>
Mac OS 7.6 CD-ROM, 376
Mac OS 7.6 Read Me file, 376
Mac OS All set, 259
Mac OS Base set, 259
Mac OS Easy Open control panel, 300
Mac OS Guide, 83–84, 133, 154
Command-? keyboard shortcut, 83
MacInTalk 3 extension, 310
MacInTalk Pro extension, 310
Macintosh
ADB port, 13
application consistency, 164
automatically launching items at startup, 241–243
automatically turning itself off, 257–258
connecting printers to, 154
Energy Star-compliant, 257
first-time users, 9
information about, 91, 247
internal clock, 252–255
Internet sources of information about, 336
jolting, 10
lightenning storms, 10
newer, faster model, 352
restarting, 80
SCSI port, 13
shutting down, 9, 81, 101–102
sleep mode, 81
startup process, 13–16
turning on, 9
unplugging, 10
ways to make it better, 351–352
what you will see after turning power on, 11–12
Macintosh Duos, 250–251
Macintosh floppy disks, 36
Macintosh HD icon, 19, 28
Macintosh HFS Interchange Format floppy disks, 37
Macintosh Human Interface Guidelines, 164
Macintosh site, 336
MacLinkPlus, 268, 345–346, 381
MacLinkPlus for Easy Open extension, 311
MacLinkPlus Setup control panel, 268, 300
macros, 105, 282
MacTools, 26, 359
Macweek site, 336
Make Alias (Command-M) keyboard shortcut, 59, 107, 140, 144
making your Macintosh better, 351–352
managing files
aliases, 139–146
Launcher, 132–135
organization, 135–139
Map control panel, 268, 300
Mavis Beacon Teaches Typing, 226–227
McGraw, Dr. Paul, 53
memory, 207–213
adjusting for applications, 89–90, 211–212
amount free, 88–89
amount used, 88
disk cache, 214–217
extensions, control panels, and applications, 210
minimum amounts, 208
RAM (Random Access Memory), 207–213
RAM disk, 219–222
requirements, 56
Script Editor, 283
System software, 209–210
virtual, 217–219
where it is allocated to, 209–211
zapping the PRAM, 361
Memory control panel, 103, 213, 268–269, 301
disk cache, 214–217
RAM disk, 220–221
settings, 269
virtual memory, 219
menus
basics, 49–50
choosing items from, 23
command keyboard shortcuts, 23
commands, 50
dialog boxes and, 50
ellipses, 50
flashing items on, 262
menu items not available, 53–54
pop-up style, 51
pull-down, 49
MEO (Mac OS Easy Open) control panel, 266–268
Microsoft Excel, 285
mirror image of hard disk, 293
Modem control panel, 269, 301, 326
Modem Scripts folder, 316
modems, 324–325, 352
drivers, 155
logging on remotely, 203–206
Macintosh cable, 325
options, 269
plugging in, 325
speed, 325
monitors
adjusting brightness, 250–251
bit depth, 231
Gamma settings, 269
larger, 352
multisync, 269
number of colors displayed, 229–230, 269
pixels, 228
redrawing, 229
refreshing, 229
settings, 228–229
updating, 228
video cards, 230
window color, 231
Monitors & Sound control panel, 92, 229–230, 269, 301, 361
mouse, 11, 272
Mouse control panel, 272, 301
Mouse Keys (Command-Shift-Clear) keyboard shortcut, 341
Move & Rename file, 126
moving
doors, 41–43
icons between disks, 43–44
selected items, 11
windows, 31–32
Multiprocessing folder, 316
multisync monitors, 269
My Favorite Programs
folder, 107
My first stupid script,
286–288

**N**
naming
files, 117–118
folders, 40
navigating through folders,
115–118
nested folders, 112–113, 115
Network extension, 311
networks
AppleTalk, 184–185
choosing connections, 155
configurations, 247
file sharing, 182, 187–206
information about shared
items, 260
LocalTalk, 182–185
managing, 247
multiple zones, 185
password-protecting
settings, 247
program linking, 187
protocols, 184
searching volumes for
applications, 267–268
selecting port for, 247
shared disks and
PowerBooks, 249–250
user identities, 188–189
viewing shared items and
connected users,
201–202
New Folder (Command-N)
keyboard shortcut, 23,
40, 54, 106, 287
Next Icon (Tab) keyboard
shortcut, 75–76
Next Option (Tab) keyboard
shortcut, 253
non-Apple printers, 155, 177
non-PostScript printers, 248
Norton Utilities, 26, 359
Note Pad, 98
note-taking utility, 98
Now Contact, 109, 285
Now Up-To-Date, 109, 285
Now Utilities, 352
NowMenus, 109
NuBus, 13
numbers, 272
Numbers control panel,
272–273, 301
numeric keypad controlling
cursor, 341

**O**
ObjectSupportLib, 315
online services Internet
access, 326
Open (Command-O) key-
board shortcut, 23, 54,
61, 172
Open dialog box, 111,
122–125
active folder, 262–263
checking where opening
files, 116
Create button, 125
desktop, 115, 119
different ways of viewing
files, 124
Eject button, 118
icons, 115
Preview button, 125
selectively displaying
items, 127
top of hierarchical list, 119
weird-named files and
folders, 126
Open Enclosing Folder
(Command-E) keyboard
shortcut, 61
Open Tpt AppleTalk Library,
316
Open Tpt Internet Library,
316
Open Transport Library, 316
Open Transport PPP, 345,
382–383
OpenDoc, 256, 329, 380–381
OpenDoc architecture, 325,
344–345
OpenDoc Essentials window,
380–381
OpenDoc Libraries folder,
316
opening
documents, 123–125
files, 54, 61, 132
folders, 61
icons, 22–23
Trash, 25
windows, 28
OpenTpt Modem, 316
OpenTpt Remote Access,
316
OpenTptAppleTalkLib, 315
OpenTptInternetLib, 315
OpenTransportLib, 315
operating system, 8, 16
Option key, 34
organizing files, 135–139

**P**
Page Down key, 31
Page Setup dialog box, 63,
158
applications, 154, 163
dogcow, 161–162
Image & Text options, 162
Page Orientation option,
159–160
Paper pop-up menu, 159
PostScript options,
161–162
QuickDraw GX, 176
Scale option, 160
Visual Effects options,
161–162
Page Setup PostScript
Options dialog box, 162
Page Up key, 31
PageMaker, 285
paper
new descriptions for, 349
selecting type, 159
type printing on, 63
Paper Type Editor, 349
parent disk, 279
parent files, 59
pass-through connectors,
362
passwords, 198, 202–203
Paste (Command-V) key-
board shortcut, 68, 99,
239
pasting items, 68
path menu, 113
paths, 112–113
PC disk icon, 36
PC Exchange control panel, 273–274, 301
PC floppy disks, 36
PCI bus, 13
PCs, translating files from, 345–346
PDD (portable digital document) format, 178–179
peripheral device connections, 13
PhoneNet connectors, 184
PICT files, 125
Picture of Desktop (Command-Shift-3) keyboard shortcut, 142
pixel depth, 231
pixels, 93, 228
plain text files, 267
playing audio CDs, 91–92
Please insert the disk: message, 39
pointer, 24–25
pop-up style menus, 51
PostScript
converting Type 1 fonts to QuickDraw GX-compatible, 350
file sizes and, 170–171
fonts, 170, 180
printing, 161–162, 170
printing to file, 167, 170–171
selecting type, 170
PowerBooks, 247, 249–251, 340
PowerPC
Cyberdog, 329
Graphing Calculator, 93–94
OpenDoc architecture, 325
screen updating, 229
PPD (PostScript Printer Description) file, 173
PPD Maker GX extension, 314
PPD Maker GX icon, 178
PPP (point-to-point protocol) control panel, 274, 302, 329–331
PRAM (parameter RAM), 209, 361
Preferences dialog box, 101
preferences files, 320–321
Preferences folder, 320–321
preformatted floppy disks, 36
previewing PICT files, 125
Previous Icon (Shift-Tab) keyboard shortcut, 75–76
Previous Option (Shift-Tab) keyboard shortcut, 253
Previous System Folder, 371–372
Print (Command-P) keyboard shortcut, 54, 153, 164
Print dialog box, 63–64, 163–171
applications, 154, 164
desktop printers, 175
new descriptions for paper, 349
QuickDraw GX, 176
print queue, 172–174
Print-Background Printing dialog box, 167–168
Print-Color Matching dialog box, 169
Print-Cover Page dialog box, 168–169
Print-Error Handling dialog box, 170
Print-General dialog box, 165–167
Print-Layout dialog box, 170
Print-Save As File dialog box, 170–171
Printer Descriptions folder, 316
printer drivers, 155, 179
Printer Drivers extension, 313–314
Printer Share extension, 311
printers
Apple, 155
AppleTalk, 156–157
cables, 154
choosing, 154–157
connecting to Macintosh, 154
contacting manufacturer for printer drivers, 155
default, 174
desktop, 157
documentation, 153
icons, 26–27, 155
information about, 173
installing printer drivers, 155
non-Apple, 155
non-PostScript, 248
paper trays, 167
pausing for manual paper feed, 174
printing to, 167
QuickDraw GX, 154
SCSI, 157
selecting, 93
serial, 157
server-based, 157
StyleWriter, 171
testing, 158
PrinterShare GX extension, 311
printing
active window, 63
background, 167–168
border, 170
choosing printers, 154–157
color or black and white, 169
cover page, 168–169
default setup for, 167
desktop printer, 63, 171–175
documents, 63–64
eliminating jaggies, 248
files, 54–55
flipping pages horizontally or vertically, 161–162
landscape orientation, 159–160
negatives, 162
number of copies, 166
number of pages per sheet, 170
page orientation, 63
page setup, 158–163
paper source, 167
paper type, 159
portrait orientation, 159–160
PostScript, 161–162
PostScript errors, 170
to PostScript file, 167–171
QuickDraw GX, 175–179
scaling, 63, 160
type of paper, 63  
when to print, 168  
which pages, 166  
Printing>PPD Maker Setup command, 178  
PrintingLib, 315  
PrintMonitor, 314  
ProDOS floppy disks, 37  
programs, 21. See also applications  
Adobe Photoshop, 125  
Apple HD SC Setup, 15, 360  
attachable, 285  
AutoDoubler, 291  
Conflict Catcher II, 109, 258, 369-370  
Cyberdog, 324-325, 328-329, 331-335  
Disinfectant, 389-390  
Disk First Aid, 15, 358-359  
DiskFit, 351  
DiskFit Direct, 388  
DiskFit Pro, 388  
DragStrip, 135  
Drive Setup, 15, 360  
FileMaker Pro, 285  
INITPicker, 258  
Install Mac OS, 370-371  
MacTools, 26, 359  
Mavis Beacon Teaches Typing, 226-227  
Microsoft Excel, 285  
Norton Utilities, 26, 359  
Now Contact, 109, 285  
Now Up-To-Date, 109, 285  
Now Utilities, 352  
NowMenus, 109  
PageMaker, 285  
QuickKeys, 352  
RAM Doubler 2, 217-219, 291  
reading DOS files, 273-274  
recordable, 285  
Retrieve It, 352  
Retrospect, 351  
SAM (Symantec Anti-Virus for Macintosh), 389  
Screenscapes, 256  
scriptable, 285  
SimpleText, 112  
Square One, 135  
Startup Manager, 258, 369-370  
StuffIt SpaceSaver, 291  
SuperClock, 255  
Virex, 389-390  
Wallpaper, 256  
proportional fonts, 226  
protecting folders, 262  
protocols, 184  
pull-down menus, 49  
Put Away (Command-Y) keyboard shortcut, 38, 60, 200  
QuickDraw 3D extension, 311, 346-347, 381  
QuickDraw 3D folder, 347  
QuickDraw 3D RAVE, 315  
QuickDraw 3D Viewer, 315  
QuickDraw GX, 154, 175-179, 312, 348-349  
QuickKeys, 352  
QuickTime extension, 312  
QuickTime Musical Instruments extension, 312  
QuickTime PowerPlug extension, 312  
QuickTime Settings control panel, 275, 302  
Quit (Command-Q) keyboard shortcut, 376-377  
radio buttons, 50, 51, 250  
RAM (Random Access Memory), 8  
adding, 208, 351  
applications, 210-212  
amount free, 88-89  
amount used, 88  
control panel usage, 210, 304  
DIMMs (dual inline memory module), 208  
disk cache, 214-217  
extension usage, 210, 317  
minimum amounts, 208  
need for more, 291-292  
QuickDraw GX, 176  
SIMMs (single inline memory module), 208  
System software requirements, 209-210  
used by control panels and extensions, 294  
uses for, 213  
where it is allocated to, 209-211  
RAM disk, 219-222  
RAM Doubler 2, 217, 219, 291  
Rant & Rave icon, 4  
Ray, Robyn desktop example, 151  
Read Me file, 204  
Rebuild Desktop (Command-Option) keyboard shortcut, 357  
rebuilding desktop, 356-358  
Recent Applications folder, 102, 104-105  
Recent Documents folder, 104-105  
Recent Items folders, 246  
Recent Servers folder, 104-105  
recordable programs, 285  
recording alert sounds, 271  
scripts, 281  
recovering items deleted from Trash, 26  
reinstalling System software, 363  
Remote Access Client folder, 204  
Remote Access Disconnect, 98  
Remote Access Setup control panel, 275, 302  
remote computers, 200  
Remote Folders folder, 199  
Remote Only extension, 312  
removing fonts, 180  
renaming icons, 24  
resaving files, 122  
Reset (Command-Control-Power-On) keyboard shortcut, 80  
resizing windows, 28-30  
resources, 370  
restarting Macintosh, 80, 364-365  
Retrieve It, 352  
Retrospect, 351  
Return key, 114
scroll arrow, 30–31
scroll bars, 30–31, 251
scroll box, 30–31
scrolling windows, 30–31
SCSI (Small Computer System Interface), 13
SCSI devices, 362–363
SCSI ID numbers, 362–363
SCSI printers, 157
SCSI termination, 362–363
Search search engine, 336
Select All (Command-A) keyboard shortcut, 69, 106
selecting all icons, 69, 106
printers, 93
self-running scripts, 289
Serial Port Arbitrator, 316
serial printers, 157
server-based printers, 157
servers recently used, 104–105
tracking, 245–246
shared disks and PowerBooks, 249–250
Shared Library Manager extension, 312
Shared Library Manager PPC extension, 312
Shareware site, 336
sharing files, 58, 93. See also file sharing
Sharing Setup control panel, 186–187, 202–203, 274, 302
shortcuts, 85
shrinking windows, 28
Shut Down DA (desk accessory), 101–102
shutdown items, 258–260
shutting down Macintosh, 9, 81, 101–102, 261
SIMMs (single inline memory module), 208
SimpleSound, 100
SimpleText, 112, 178
size box, 29–30
sleep mode, 81
SneakerNet, 181
SOMObjects for Mac OS, 315
sound, 241, 269–270
alert sounds, 100
Sound control panel, 361
Sound>Speak All command, 348
Sound>Speak Selection command, 275
Sound>Stop Speaking command, 348
Speak Selection (Command-H) keyboard shortcut, 275
speaking text, 275–276
special characters, 96–97
Special menu, 77–81
Special>Clean Up command, 78–79
Special>Clean Up Desktop command, 78
Special>Eject Disk command, 37, 79
Special>Empty Trash command, 25–26, 56, 79, 221
Special>Erase Disk command, 36, 79, 221
Special>Restart command, 80, 365
Special>Shut Down command, 9, 81, 201
Special>Sleep command, 81
Speech control panel, 275–276, 302
Speech Manager extension, 312
speech-to-text applications, 275–276
Square One, 135
startup disk, 14, 15
Startup Disk control panel, 222, 276, 303
startup items, 258–260
Startup Items folder, 241–243
Startup Manager, 258, 369–370
startup process, 13–15
automatically launching items, 241–243
crashing at, 364–372
status line, 32
Stickies, 100–101
Sticky Keys (Shift key five times) keyboard shortcut, 342
sticky notes, 100–101
| Strawberry Pop-Tart Blow-Torches Web page, 336 |
| StuffIt SpaceSaver, 291 |
| StyleWriter, 171 |
| StyleWriter 1200 printer driver, 155 |
| subfolders, 74 |
| submenus, 87, 90, 102-103 |
| Suck zine site, 336 |
| SuperClock, 255 |
| System 7 format sounds, 241 |
| System and startup disk, 15 |
| System Error dialog box, 364 |
| system extensions, 306-313 |
| System file, 321 |
| System Folder, 40, 291 |
| benefits of small, 293 |
| control panels, 297-305 |
| Control Strip Modules, 243, 319 |
| copying to hard disk, 45 |
| disabled folders, 296 |
| editors, 320 |
| extensions, 306-314 |
| Finder, 26, 320 |
| fonts, 320 |
| Launcher items, 320 |
| ObjectSupportLib, 315 |
| Open Tpt AppleTalk Library, 316 |
| Open Tpt Internet Library, 316 |
| Open Transport Library, 316 |
| OpenTpt Modem, 316 |
| OpenTpt Remote Access, 316 |
| OpenTptAppleTalkLib, 315 |
| OpenTptInternetLib, 315 |
| OpenTransportLib, 315 |
| Preferences folder, 320-321 |
| PrintingLib, 315 |
| PrintMonitor, 314 |
| problems with, 354 |
| QuickDraw 3D RAVE, 315 |
| QuickDraw 3D Viewer, 315 |
| root level, 135 |
| Scrapbook file, 321 |
| Serial Port Arbitrator, 316 |
| SOMObjects for Mac OS, 315 |
| Startup Items folder, 241 |
| system extensions, 306-313 |
| System file, 321 |
| VT102 Tool, 315 |
| what not to store in, 138 |
| System software, 8, 21 |
| Apple Remote Access control panel, 347 |
| clean reinstallation, 370-372, 376 |
| CloseView control panel, 343-344 |
| Cyberdog, 345 |
| Easy Access control panel, 340-342 |
| English text-to-speech software, 348 |
| fixing bad, 353-372 |
| icons, 20-21 |
| items not installed during Easy Install, 340 |
| LaserWriter Utility, 349 |
| MacLinkPlus, 345-346 |
| memory requirements, 209-210 |
| Open Transport PPP, 345 |
| OpenDoc architecture, 344-345 |
| Paper Type Editor, 349 |
| PowerBook installation, 340 |
| QuickDraw 3D extension, 346-347 |
| QuickDraw GX, 348-349 |
| removing items of, 339 |
| Type 1 Enabler, 350 |
| what it does, 8 |
| you might need, 339-350 |
| SystemAV extension, 313 |
| ten ways to make your Macintosh better, 351-352 |
| terminators, 362-363 |
| testing printers, 158 |
| text highlight color, 251 |
| reading out loud, 348 |
| Scrapbook, 100 |
| selecting multiple items, 11 |
| Text control panel, 277, 303 |
| text file of scripts, 289 |
| text insertion point, 262 |
| text-entry boxes, 52 |
| third-party extensions and control panels, 294 |
| This Mac was shut down improperly message, 9 |
| tildes (Option--) keyboard shortcut, 97 |
| Time Format dialog box, 253-254 |
| time formats, 253-254 |
| time-saving tips, 225 |
| accelerated graphics card, 234 |
| accelerators, 233 |
| color, 228-233 |
| faster Macintosh model, 233 |
| keyboard shortcuts, 225 |
| monitors, 228-229 |
| new hard disk, 234 |
| typing faster, 226-227 |
| upgrading Macintosh, 233 |
| Tip icon, 4 |
| title bars, 31, 251 |
| TM character (Option-2) keyboard shortcut, 240 |
| toggling commands, 66 |
| TokenTalk, 184 |
| translation software, 345-346 |
| translators, 55 |
| Trash, 25 |
| dialog box when emptying, 58 |
| ejecting disks, 38 |
| emptying, 25, 79 |
| icon, 46 |
| locked files, 56 |
| locked icons, 26 |
| opening, 25 |
| recovering items deleted from, 26 |
The Trash contains X items.
  It uses X K of disk space
message, 58
TrueType fonts, 180
TrueType GX fonts, 180
turning on Macintosh, 9
Type 1 Enabler, 350
Type 1 fonts, 180
typing faster, 226–227
typography, 228–229

• U •
umlaut (Option-u) keyboard
shortcut, 97
Undo (Command-Z) keyboard
shortcut, 66
undoing actions, 66
unlocking locked icons, 26
unplugging Macintosh while
running, 10
users
discharging, 201–202
file sharing and, 187–190,
192–193
identities, 188–189
new, 188
owner, 193
registered, 190, 193
removing, 191
Users & Groups control
panel, 188–191, 278, 303

• V •
video cards, 230
View menu, 69–72
View by Date command, 72
View by Icons command, 69
View by Kind command, 72
View by Label command, 72
View by Name command, 70, 105
View by Size command, 71
View by Small Icons
command, 70
Views control panel, 71, 75,
78, 232–233, 278–279,
303
Virex, 389–390
virtual memory, 217–219,
291
viruses, 389–390
VM Storage file, 126, 217
Voice folder, 317
VT102 Tool, 315

• W •
Wallpaper, 256
Warning icon, 4
Web pages, 331, 333
Web sites, 323
weird names of folders or
files, 126
what you will see after
turning power on, 11–12
Williams, Robin desktop
example, 147
windoid, 84
windows, 27
active, 32
applications, 27, 35
available space amount, 32
close box, 33–34
closing, 32–34, 55
desktop, 27
enlarging, 28–29
hard disk space amount, 32
highlight color, 251
icon views, 69–70
inactive, 32
keyboard scrolling, 31
list views, 70–72
Macintosh HD, 28
managing appearance of,
279
moving, 31–32
number of items contained
in, 32, 279
opening, 28
resizing, 28–30
rolling up, 35, 279–280
scroll bars, 30–31
scrolling, 30–31
shrinking, 28
size box, 29–30
status line, 32
title bar, 31
viewing icons, 69–72
WindowShade effect, 35
zoom box, 28
WindowShade control panel,
35, 279–280, 303

Wolfson, Rich desktop
example, 149–150
world map, 268
WorldScript Power Adapter
extension, 313

• Y •
Yahoo search engine, 336

• Z •
Zap PRAM (Command-
Option-P-R) keyboard
shortcut, 361
ZD Net site, 336
zones, 185
zoom box, 28
Title of this book: Mac® OS 7.6 For Dummies®

My overall rating of this book: [Very good] [Good] [Satisfactory] [Fair] [Poor]

How I first heard about this book:
[Found in bookstore; name: ] [Book review: ] [Advertisement: ] [Catalog: ] [Word of mouth; heard about book from friend, co-worker, etc.: ] [Other: ]

What I liked most about this book:

What I would change, add, delete, etc., in future editions of this book:

Other comments:

Number of computer books I purchase in a year: [1] [2-5] [6-10] [More than 10]

I would characterize my computer skills as: [Beginner] [Intermediate] [Advanced] [Professional]

I use [DOS] [Windows] [OS/2] [Unix] [Macintosh] [Other: ]

I would be interested in new books on the following subjects:
[please check all that apply, and use the spaces provided to identify specific software]
[Word processing: ] [Spreadsheets: ] [Data bases: ] [Desktop publishing: ] [File Utilities: ] [Money management: ] [Networking: ] [Programming languages: ] [Other: ]

I use a PC at [please check all that apply]: [home] [work] [school] [other: ]

The disks I prefer to use are [5.25] [3.5] [other: ]

I have a CD ROM: [yes] [no]

I plan to buy or upgrade computer hardware this year: [yes] [no]

I plan to buy or upgrade computer software this year: [yes] [no]

Name: [Business title: ] [Type of Business: ]

Address ( [home] [work] [Company name: ]

Street/Suite#

City/State/Zipcode: Country

I liked this book! You may quote me by name in future IDG Books Worldwide promotional materials.

My daytime phone number is ___________________________
YES!
Please keep me informed about IDG’s World of Computer Knowledge. Send me the latest IDG Books catalog.

BUSINESS REPLY MAIL
FIRST CLASS MAIL    PERMIT NO. 2605    FOSTER CITY, CALIFORNIA

IDG Books Worldwide
919 E Hillsdale Blvd, STE 400
Foster City, CA 94404-9691
Mac® OS 7.6 For Dummies® is the fun way to master the latest version of the Macintosh operating system. Whether you’re brand new to the Macintosh environment or upgrading from older system software, bestselling author Bob LeVitus takes you on a friendly, informative tour of Mac OS 7.6. He explains how the features work in an easy-to-understand language so that you make the most of your time with your Mac.

Inside, find helpful advice on how to:

- Experience Cyberdog, OpenDoc, QuickTime 2.5, and all of the newest features of the system software
- Get your Mac up and running on the Internet in no time
- Tweak your control panel to customize the look and feel of Mac OS 7.6
- Save RAM and hard disk space with Bob’s guide to “What Can Stay and What Can Go”
- Manage your files and folders to keep your Mac neat and organized
- Automate your everyday tasks with a fun introduction to AppleScript
- Discover the techniques that the gurus use to squeeze every ounce of performance from their Macs
- Resolve extension and control panel conflicts with ease

- Master networking, file sharing, and printing
- Find out the difference between real and virtual memory

Let These Icons Guide You!

Points out shortcuts, tricks, and secrets worth noting
Highlights nerdy technical discussions that you can skip if you want to
Warns you of an irreverent, often emotional outburst by the author

Technical Review
by Dennis Cohen

About the Author
Bob LeVitus has been a contributing editor and columnist for MacUser since 1989. He has written over a dozen popular computer books. LeVitus is known for his expertise and his ability to translate techie jargon into usable advice for the rest of us. He is the author of IDG Books Worldwide’s Macintosh® System 7.5 For Dummies®.