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Introducing MacOffice
Gregg Keizer

The Macintosh, Apple's relative newcomer to the field of personal
computers, is changing the ways we work with and think about
computing. Its easy-to-use operating environment, dazzling graphics, and growing software base help make the Macintosh effective
as an educational tool, a home entertainment device, and a programmer's playground. But as thousands of new and experienced
computer users are discovering, the Macintosh is also custommade for business.
This idea, that the Macintosh is a superior business computer,
initially caught some people by surprise. IBM, after all, has conquered the business world forever . Right? And a computer as easy
to use and as powerful as the Macintosh can't really be effective
in a traditional office setting. Correct?
Wrong on both counts. Since Apple guided the Macintosh
into the business arena, surprising things have been happening.
Calling the package the Macintosh Office, even going so far as to
trademark the phrase, Apple has targeted the Mac at companies
both large and small, from the Fortune 1000 to the Mom-and-Pop
retail store down the street. Even more attractive, Apple has produced a network system, called AppleTalk, and a powerful laser
printer, the LaserWriter, to add shared peripherals and dose-totypeset-quality printing to the office. Third-party software and
hardware developers have swarmed to the Macintosh Office,
offering hard drives, file servers, and other products to enhance
the final Macintosh business environment.
MacOffice: Using the Macintosh for Everything ·explores the
power and the promise of Apple's revolutionary computer. What
you'll find here are practical uses of the machine and of some of
its most popular software. Actual demonstrations of the Macintosh's business capabilities show you just what you can do with
the computer. If you already have a Macintosh, you can get to
work immediately. And if you haven't bought a Macintosh yet,
MacOffice can give you an idea of what it will do for your office.
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Half a Million Sold
By the beginning of 1985, somewhere between 250,000 and
350,000 Macintoshes had been sold (the numbers obviously vary
according to whom you talk to). The Macintosh is still selling
briskly. During the first quarter of 1985, for instance, a computer
trade weekly reported that the Macintosh accounted for 20 percent of all specialty computer store sales. That's a larger percentage than any one IBM PC model (though not quite as large as the
IBM PC line taken as a whole). It's safe to assume, if sales remain
constant, that over half a million Macintosh computers will be on
desks when 1986 rolls around.
Apple aims for 10,000 AppleTalk connections by the end of
1985. AppleTalk connections point at the acceptance of the Macintosh Office concept. And it appears that this goal may well be
met. At the time of this writing Oune 1985), more than 2500
LaserWriters, Apple's main hardware contribution to the Macintosh Office idea, had been placed.
But you don't need ten Macintoshes, a LaserWriter or two,
and lengths of AppleTalk's cable to use the machine as an office
computer. Not every business is going to require that kind of
setup. Small businesses, particularly, may use only one or two
Macs. MacOffice: Using the Macintosh for Everything is written for
these businesses as well.

What Tells What
All the hardware in the world won't do a thing for you unless
you have the software, or programs, to tell it what to do. Software
is the most crucial component of a computer system. Without the
right software, your computer may not be able to do exactly what
you had planned, or if it can, it may do it poorly. It may look
sexy, but the Macintosh can't help you manage your business
without software.
That's where the Mac excels. In the year and a half since its
release, the Macintosh has seen some very impressive software
debut. The programs bundled with the machine, MacWrite and
MacPaint, were powerful in their own right. But third-party developers have released spreadsheets, databases, word processers,
terminal programs, and graphics packages which use the Macintosh's unique operating system to its fullest extent.
MacOffice: Using the Macintosh for Everything concentrates on
five Macintosh programs: Four are Microsoft products-Word, File,
Chart, and Multiplan-and the fifth is Apple's own MacTerminal.
vi
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These five weren't selected solely because of their abilities, though
they are among the best available in their specialties. Their acceptance and popularity also had something to do with it. Microsoft's
packages constantly show up on software best-seller lists.
MacTerminal was the first commercially produced terminal program for the Mac (there were several public domain terminal programs available prior to MacTerminal's release).
It does no good to show you how to use your Macintosh, especially if you already have the machine and some of its software,
if the descriptions are culled from programs you don't have or
aren't likely to buy. You're more likely to have or buy Multiplan
than any other Macintosh spreadsheet. Word, though not part of
the Macintosh package, is the most popular third-party Mac word
processor on the market. The other software used in MacO!fice
follow these criteria.
But What Can This Book Do for Me?

MacO!fice: Using the Macintosh for Everything is an anthology
showing what seven different Macintosh users and authors have
done with their computers and the various software packages.
These authors know the Macintosh-they've worked with the machine and they know what it can and cannot do. Each author has
explored a particular program, or a combination of programs, and
used it to accomplish a very specific task. Using Word to create
form letters. Adding graphs to reports or other documents with
Chart. Accessing other Macintoshes and other computers using
MacTerminal.
The applications, and that is what this book is all about, are
practical and can be used immediately in your own business. The
Accounts Receivable, Accounts Payable, and Balance Sheet templates created with Multiplan in Chapter 6, for instance, could be
entered and used as is. The information concerning the AppleTalk
network and the LaserWriter can prove helpful as you create your
own network, or as you try to decide if a network will prove valuable in your office.
Many chapters include step-by-step instructions detailing how
you can use a program, Multiplan, for example, to create these
applications. Figures and text walk you through the process,
showing you just what happens at almost every step. By reading
MacO!fice, with your Macintosh in front of you, you can end up
with an impressive collection of Macintosh capabilities.
vii
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But there's more to MacOffice than just a collection of applications. Within each chapter, countless hints, tips, and techniques
are discussed. Some are obvious, but perhaps overlooked in your
eagerness to get started with the machine and its software. Others
are more advanced and show you things that no manual can.
More important, these practical examples will give you ideas.
Perhaps you don't need a client list, as shown in Chapter 4, one
of the chapters which concentrates on File. But Chapter 4 will
show you how to use File most efficiently. You'll see ways to sort
information in the File documents you create, and you'll find out
how to create a variety of different File reports. Within a short
time, especially if you produce the sample applications as you
read, you'll be able to apply the information to whatever task you
need. All the chapters are like this. Not only are there applications and documentation, but the simple process of showing how
one thing can be done will invariably lead you to see another.
Learning by example is one of the main concepts behind this
anthology.

Information Everywhere
Not everything in MacOffice is concerned directly with business.
Other sections provide you with information about your Macintosh and its operating system. How to manage your disk files,
how to use valuable disk space most efficiently, what to consider
if you're thinking about upgrading your 128K Macintosh to the
optimum 512K Fat Mac (or adding even more memory-see
Chapter 9 for details on adding up to two megabytes of RAM).
The last chapter in MacOffice discusses and evaluates several Macintosh utilities that will make your work easier, sometimes even
make formerly impossible tasks possible. Almost everything you
need to get started with the Macintosh in your office is here, in
one place.

It's Just a Computer
The Macintosh can be an effective, powerful office tool. But
remelllber, that's all it is-a tool. It can make your office more efficient, but it can't make your business decisions for you. Some
people believe that simply buying a personal computer will solve
every problem. Unfortunately, not true. MacOffice is realistic. It
doesn't try to tell you how to run your office-it only shows you
how to get the best use from the computer and selected software.
The rest is up to you.
viii
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The Pictures
Almost all the figures included in this book were generated on the Macintosh,
then uploaded via modem to COMPUTE! Publications' Atex editorial/typesetting
system· and typeset on an Autologics APS-Micro 5 typesetter. Thanks go to Tony
Roberts, Production Director, and Charles Brannon, Program Editor, of COMPUTE! Publications, for creating this capability.
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The MacOffice for Everyone
Charles Brannon
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The IBM PC was once the uncontested champion of business
~= microcomputers, but it must now
face a feisty opponent-Apple's
l
Macintosh. It's not an easy fight for
. _ the Macintosh- IBM is firmly entrenched, both in the corporate mind and in offices throughout
the world. Many competitors have tried to find a unique niche in
some nook IBM overlooked, snapping up whatever morsels that
fall from Big Blue's table.
And yet Apple's "computer for the rest of us" is surviving, quite
well, thank you, in a market enthralled by IBM compatibility. A
computer that scoffs at this standard rarely has the last laugh.
Macintosh succeeds because it represents a fresh concept in
computing, a machine that is uniquely easy to learn and use, a
computer for complete novices that provides professional power.
How is this possible? To find out, let's take a look at the Macintosh user interface.
._

-

l
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The Macintosh User Interface
The user interface is more or less the personality of an application
or operating system. Through it you perform all your work. It's a
pipeline for communication. The user interface should communicate information clearly, in sufficient detail to keep you wellinformed, but not overwhelm you with information you don't
n eed. It should allow you to access all the program's functions
with a mininum of overhead. Ideally, the output of a program
should be instantly recognizable and understandable, communicated in a familiar way, not couched in computer jargon. A
word processing document should look like type on paper. When
your work is analogous to familiar tasks, you can use your computer immediately, just by applying the expertise you've learned
working in a more conventional office setting.
Many computers have no consistent user interface. The way
you operate a program varies widely between applications or even
within an application. Som e programs may require you to enter
3
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complex command lines and acknowledge you with cryptic messages. Others use control keys to enter commands. Even here, you
must still memorize the keystrokes, though they're often related
to the function they perform, such as Control-E for Erase. Programmable function keys are available on some machines to store
commonly used phrases or work as command keys. Some programs display menus, where you type a key to choose an option
from the display.
What's forgotten in all these approaches is that a huge majority of people who want to use a computer don't know how to
touch-type. How can you use a computer effectively if you must
hunt and peck to use the primary input device? It's asking a lot of
someone to learn to type just to talk to a machine. If the commands were displayed on the screen, and if there were some way
to point at the command you want, the keyboard problem would
be alleviated.

The Mouse Solution
The Macintosh uses a mouse controller as its pointing device.
Many people immediately associate the Macintosh with its mouse.
Their love or hatred begins (and sometimes ends) with the mouse,
but the real issue is not the use of the actual device, but with the
pointing method of accessing commands.
The mouse is a small box with a push button. A rubber ball is
nestled beneath the mouse. By pushing the mouse around on a
flat surface, the ball rolls and communicates the direction and
speed of spin to the computer. The screen cursor mimics the
movement of the mouse. Push the mouse away from you, and the
cursor moves up. Push it to the right, and the cursor follows. The
mouse is just one way to move a cursor on the screen. It's possible to use other pointing devices, such as light pens, touch tablets, or trackballs.
The mouse cursor is normally an arrow pointer, but it often
changes to different shapes depending on screen context. For example, the cursor can become a hand when used to grab objects
or a crosshair when used to draw a box around an object.
Using the mouse is tricky at first. Since the trackball of the
mouse must roll on a smooth, flat surface, you must dedicate
some desktop space for the mouse. It's not uncommon for beginners to run out of desk space when rolling the mouse around.
After some practice, though, mouse dexterity becomes second nature. Actually, very little desk space is needed to move the mouse.
4
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You don't even think about it. The pointing action is effortless.
Nonetheless, touch-typists complain that they have to move
their hands away from the keyboard to use the mouse. Yet the
same is true when pressing the cursor keys on most keyboards,
unless you have very long fingers. In any case, there are plenty of
keyboard shortcuts, even keys to move the cursor, depending on
the application.

Clicking and Dragging
After you've pointed to a screen location, you have to select it.
There are three basic mouse operations: the click (a single press
and release of the mouse button), the double-click (two clicks of
the mouse button in rapid succession), and the drag (holding
down the mouse button while moving the mouse to a new location). Clicking is generally used to highlight something or to select
it. The double-dick is a shortcut. Where a single click can select
something, a double-dick can start an application or open a file.
You don't really have to use it, since there are other ways of
opening a file or starting an application.
The drag is a more common operation than the double-dick.
You would drag when drawing a box around an object, for instance. You start drawing a box by holding down the mouse button. This sets one corner of the box. Still holding down the
button, you then move the mouse (drag) to where you'd like the
opposite corner of the box to be. When you let go, the box is finished. You can even pick up screen objects and drag them to new
locations.
Figure 1·1. A Variety of Icons

Rather than using a command-driven or keystroke-driven
user interface, the Macintosh can represent commands as words or
pictures on the desktop, commands that are pointed to, not typed
5
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out. Words or pictures by themselves can be incomplete, but a
captioned picture is a clear way of symbolizing something. Commands become less abstract and can even be thought of as objects. Object-oriented processing is another characteristic of the
Macintosh. The objects are usually called icons . An icon can represent a disk, an application, a data file, a tool like a paintbrush, or
a command option. You can erase a file from the disk just by
picking up the icon that represents that file and dropping it in the
Trashcan icon.

Pull-Down Menus
The screen could quickly become cluttered with such icons.
Menus are a good alternative for commands, but they also use a
lot of screen space. The Macintosh solution is to use pull-down
menus. The titles of each menu appear along the top of the screen.
You need merely to select the title by pointing to it with the
mouse, then pull it down while holding down the mouse button.
The menu options pop up. You hold down the button and pull
down until the option you want is highlighted, then let go of the
mouse button. A menu doesn't take up any screen space until it's
selected, and it goes away as soon as you've selected from it. A
menu also keeps you from having to memorize all the commands.
It can be used to perform a command as well as document what
commands are available. You usually know what menu to look
under, since the titles of the menus are always displayed. When a
menu option can also be accessed with the keyboard, the shortcut
key is displayed next to the option. Most shortcut keys are entered by holding down the Command key (shown on the keyboard as 3€) while pressing another key.
Figure 1-2. Pull-Down Menu

6
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Sometimes the use of a menu is inappropriate, for example,
trying to change the format of text when you have no text defined. The title of an inappropriate menu appears dimmed and
fuzzy. Some items within a menu may also be inappropriate, like
trying to Open a new document before you've Saved the one
you're working on. The inappropriate items also appear dimmed.
The mouse will not highlight these items, but will skip right past
them. There's never any ambiguity-you immediately know if a
certain command is allowed or even exists.

Windows
The Macintosh user interface imitates a desktop. The mouse
cursor is an extension of your hand and hovers above the
desktop. Files are shown on the desktop as miniature file folders
or pages of documents. Familiar objects like the wastebasket are
pictorially represented. Your work appears as a sheet of paper.
And you can display several of these sheets. Like paper, they can
be moved about the desktop, brought to the foreground, or
shoved beneath a stack. But unlike ordinary paper, a window's
size and shape can be changed. The idea of a window is to use
your one display to show several different screens.
The Macintosh uses overlapping windows to further enhance
the desktop illusion, so your computerized desk can be just as
sloppy as your real desk, although it's so simple to be organized
on the Macintosh that there's less of an excuse for disorder. While
you can display many windows, only one is active at a time. You
click on any visible portion of a window to make it active. It surfaces, burying any windows that would overlap. You can move
around and resize windows to make several visible simultaneously. You can, however, run out of screen space for windows
and find yourself shuffling through a pile of them trying to find a
particular one. It's best to carefully plan your window layout on
the screen. Many software packages offer special commands to
make it even easier to manage your windows.
There are two kinds of windows: the document window, which
can be resized, moved, and used to edit text, and the dialog box,
which can be used to alert you with a message, or let you enter
text or select options. A dialog box (like the one in Figure 1-4)
cannot be moved or resized.

7
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Document Windows
The name of a document window is displayed at the top, in the
title bar. A go-away box is shown at the far left of the title bar.
Clicking the go-away box makes the window disappear, revealing
whatever's beneath it. You can store more than a windowful of
text within a window. The window may show only a portion of a
large document, so there are several ways to display different
parts of it. Along the bottom and right side of the document window you'll see scroll bars. You can drag the small box within a
scroll bar to jump to a new part of the document. If the scroll bar
is empty, scrolling is disallowed or inappropriate. You can also
click on the arrows to scroll the text left or right, and up or down,
one line at a time. By clicking above or below the scroll bar box,
you scroll forward or backward by pages within the document.
Figure 1·3. Document Window

D
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This is a typicalidocument
window.!
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The small box at the lower-right corner is the size box. Dragging here lets you extend or retract this comer of the window,
effectively changing the size and shape of the window. You move
the window by dragging the title bar. This lets you drag a dottedline skeleton of the window to a new location. When you let go,
the window moves.
Some programs extend the options of a document window.
For example, many Microsoft applications let you choose between
8
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two sizes of a window, just by double-clicking on the title bar.
The shape of the mouse cursor may even change to remind you of
the functions of the various parts of a window.

Text Editing
You can click anywhere within the window to place the text
cursor, a blinking vertical line. This is the insertion point. The arrow cursor usually changes to an 1-beam cursor within the document area to remind you that clicking the mouse sets the insertion
point. You can type from the keyboard to insert text at the insertion point. The Backspace key is used for deleting single characters. You can move the insertion point within the document to
edit at different points. You can also define text, erase it, or save it
for later use.
To define a section of text, just click and drag the mouse
cursor across the text. The text is highlighted, and the window
scrolls automatically, if necessary, to let you define large sections.
You can define a single word or phrase by double-clicking on it.
The Shift key can be used to extend a selection. You could select
one word, then move the mouse cursor to the end of the sentence. You hold down Shift when you click, and the range extends from the defined word to the end of the sentence. (This
procedure is called Shift-click throughout this book.) You can also
select pictures in applications that allow it, usually by dragging a
box around the object.
Using the Clipboard
Once some text or an object is selected, you can erase it by selecting Clear from the Edit menu or by pressing the Backspace key (a
shortcut key). You can replace selected text by simply typing in
some new text. Or you can select Cut (or press Command-X) from
the Edit menu to put the selected text into a special buffer called
the Clipboard, a System file stored on your startup disk. Once cut,
the object or text disappears from the screen, but is safely stored
in the Clipboard. You can also select Copy (or press Command-C)
from the Edit menu to move the text or graphics into the Clipboard without erasing. The Clipboard can hold only one item at a
time, and it preserves this item until something else is copied or
cut into the Clipboard, or until the Macintosh's power is shut off.
The Edit menu is found in most applications. Text or graphics
cut into the Clipboard can be pasted into many applications. You
can paste text from the Clipboard at an insertion point by
9
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selecting Paste from the Edit menu or by pressing the shortcut
key, Command-V. You can also use Paste to replace any selected
text. Many applications will also accept graphics from the Clipboard. You could use MacPaint to draw a picture, copy the picture
into the Clipboard, then run MacWrite, and insert the picture into
your document.

Dialog Boxes
The dialog box is sometimes used just to tell you something. A
simple click, or a click within the OK box, is enough to tell the
Macintosh that you've read the message. The dialog box can also
be an area where you enter information. You can click on buttons
to tum options on and off. Some buttons are hollow squares
which hold an X when turned on. Others are hollow circles which
are filled with a solid circle when turned on. Another kind of button is a word or phrase surrounded by a rounded box.
Figure 1·4. Dialog Box
lmageWriter (standard or Wide)
Quality:
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Page Range: ® Rll
0 From:
Copies:
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Paper Feed: ®Continuous 0 Cut Sheet
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0

Draft
To:
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OK

B

(Cancel )

Edit fields are used to enter a single line of text. They appear
as rectangles that may contain a default segment of text. You can
click on an edit field to select it, then begin typing. Many dialog
boxes let you use the Tab key to skip between multiple edit fields.
You can cut from an edit field into the Clipboard or paste from
the Clipboard into an edit field.

Desk Accessories
One special menu is labeled with a small Apple logo. This menu
contains the desk accessories, special tools usable with almost all
applications. These tools are like small built-in applications,
considered handy enough to be made available at all times. The
desk accessories permit a limited form of concurrency, since you
can have them running while you work within another application. You can use many desk accessories simultaneously, although
10
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each opened desk accessory uses more processing time and slows
down everything else. The first item in the Apple menu is usually
something like About the.... It presents the name of the application, a brief description, and the version number and author(s) of
the program. The standard desk accessories are the Scrapbook,
Alarm Clock, Note Pad, Calculator, Key Caps, Control Panel, and
Puzzle. The desk accessories appear as objects on the desktop, and
can be moved around for convenience. Each accessory can be
cleared from the desktop by clicking on its go-away box.

Scrapbook
----

10

The Scrapbook is
like an extended
Clipboard. The
Clipboard can
hold only one
item at a time,
but the Scrapbook can hold
an entire portfolio of pictures
and text. The
Scrapbook is
filled by pasting
1 /2
P1CT
into it from the
Clipboard. You can scroll through the pictures and text in the
Scrapbook with its horizontal elevator. The item currently displayed can be cut or copied into the Clipboard to be pasted into
some other application.

Alarm Clock
The Alarm Clock is a realtime clock (as
long as you set it correctly) that's upf!l lli]:53:00 PM
dated from the Macintosh 's internal
clock/calendar. Be sure you have a fresh
AA battery installed in the back of the
machine to keep the clock alive. You can
pull out the clock and leave it on the desktop, but remember that
it will slow down the mainline application. The clock is set by
clicking on the little flag next to the time, which lowers the clock
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setting panel. Click on the picture of the clock dial to display the
time. Now click on each segment of the time (hours/minutes/
seconds), then on the tiny upfdown arrows to increment and decrement the clock digit. You can also type numbers from the keyboard. Click on the icon of the daily calendar to display the date.
You can click on each date segment (month/day /year) to count it
up or down. The alarm clock icon is used to display and change
the alarm time. When the alarm time is displayed, you can raise
or lower a tiny switch to turn the alarm function on or off. The
alarm clock icon changes when the alarm is set. The current date
or time is automatically selected and can be cut or copied into the
Clipboard.

Note Pad
~NotePad

The Note Pad is like a mini word
processor.

I

The Note Pad can be thought of as a
mini-word processor. You have ten
pages of notes. Just click within the
page to set the insertion point. You can
use the clipboard to cut text from or
paste into the Note Pad. To tum to the
next page, click on the upturned portion (dog ear) of the page. To go backward a page, click beneath the dog ear.

Calculator
The Calculator is a simple four-function calculator
with scientific notation. You can press the calculator
keys with the mouse cursor, but you can also enter
data and select functions from the keyboard. Just
type a number, a function ( + addition, - subtraction , * multiplication, I division}, another number,
then the = key. The number in the display of the
Calculator is automatically selected and can be cut
into the Clipboard. You can also paste a number
from the Clipboard into the Calculator's display.

12
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Key Caps
Key Caps is not a substitute

for the keyboard, although
you can actually type characters using the mouse. Its main
purpose is to show you what
special characters are available. Press the Shift key, the
Option key, and then Shift
and Option together to see all
the possibilities. Key Caps shows the status of every key. The
characters you type appear in the Key Caps display (while the
appropriate keys on the Key Caps keyboard flash), and you can
cut and paste from and to the Key Caps display using the Clipboard. Key Caps is also a way to get some text into the Clipboard
when your current application doesn't support text entry.

Control Panel
The Control Panel lets you customize some of the components of
the Macintosh user interface. As the name implies, there are various switches, sliders, and other adjustment controls pictorially
represented.
Figure 1-5. The Control Panel
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The slider bar at the left controls the speaker volume. The Macintosh beeps frequently, usually when you
make an error. If these sounds irritate you, click on and
drag the slider down. As might be expected, dragging it
up increases the volume, and down decreases the volume. You can drag it all the way down to 0 for no
sound at all.
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Another panel lets you see and
change the date and time. You change
.·
. the time just as you did with the
clock, by clicking on each segment of the date or time, then clicking on the tiny arrows displayed to count the number up or
down. You can also type the time and date from the keyboard.
The section at the upper right of the Control Panel lets you control the amount of visual feedback you get when selecting from a
menu. When you make a selection, the selected item flashes. You
can control the number of flashes, from 0 (no flash at all) to 3
(three flashes). Expert users might turn off the flashing to speed
things up.
The keyboard control
panel lets you change the repeat rate of the keys from
slow (0, the tortoise) to fast
(4, the hare). Underneath the repeat rate icon, you can control the
keyboard repeat sensitivity, that is, how long you have to hold
down a key before it starts repeating. Some people like the repeat
to start very quickly. Others might not like two or three keystrokes for every one they type.
The flashing insertion point lets you adjust the
blink rate of all insertion points. A rate of 2 is normal,
but some people like as little blinking as possible. A
rate of 1 gives a very slow blink, and rate 3 blinks
hyperactively.
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The picture of the moving mouse controller lets you
choose between two movement styles. With (1) clicked,
the cursor moves farther when you speed up your
mouse movement. This lets you cross the screen without
running out of desk space for the mouse. With (0)
clicked, the mouse moves at a constant speed. This can be better
when you need fine, predictable control of the mouse. It's really a
matter of personal preference.
Next to the mouse control is a panel
that lets you edit the background pattern of
the desktop . The box on the left is an
editing grid where you can design the actual
8 X 8 pattern used. To the right, you can
see what the pattern looks like in actual size, filling a small box.
The white bar on top of the filled box lets you pick from several
predefined patterns. Just click on the bar to change patterns. To
actually change the desktop pattern, click inside the filled box.
This section lets you control the time delay
between the two clicks of a double-dick selec+++ tion. If you don' t have a very fast finger, you'd
080 better click on the circle with more space between the two arrows (the leftmost). On the
other hand, you don't want two separate clicks mistaken for a
double-click, so you may want to choose the least amount of time
between clicks on the far right. The center selection is generally
the best compromise.

•••

Puzzle
Apple whimsically included this little game to
give harried executives an excuse to relax a bit.
The Puzzle is the computerized form of the sliding tiles puzzle. Try to get all the numbers in
order. Click on any tile adjacent to the empty
space to slide it into place. You can also click on
the end of a row or column to slide the whole
row or column into the empty space. You get a
new game every time you call up the Puzzle.
Click the go-away box when you've had enough of the game.
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New Desk Accessories
Several third-party companies now sell add-on desk accessories.
Accessories available include a terminal program, word processor,
spreadsheet, print spooler (lets you continue using your current
application during printing), graphics grabber (lets you "grab" a
part of the screen and cut it into the Clipboard), and more. The
advantage of using these packages is that as desk accessories,
they're always available. Desk accessories are an instant, and
easy, way to integrate two applications. And because desk accessories can run simultaneously with your application, you have the
powerful capability of multitasking-running two programs at the
same time. (Chapter 11 describes several commercial utilities
whieh can act as desk accessories.)
A new version 4.1 of the Finder (see below), adds Choose
Printer to the Apple (desk accessory) menu. It lets you install one
of several printer drivers (only the lmageWriter driver is included
by default), select which port (printer or modem) to use, and
whether or not the printer is connected to the AppleTalk network.

The Macintosh Finder
When you finish your work in any application, it's time to save it
to disk. As you may know or have painfully found out, anything
in the Macintosh's memory is lost when you turn off the power
(or when power is turned off for you, as in a thunderstorm). Computer memory is volatile. That's why it's important to store your
work on disk. Some form of nonvolatile mass storage is required
for any computer.
The Macintosh disk drive is one of the fastest microcomputer
disk drives, and the storage medium, the 3-1/2-inch microfloppy,
can hold over 400,000 characters. Managing that much information can be tricky. That's where the Finder comes into play.
The Finder lets you manipulate your documents and disks. It
can be considered an application, although it usually comes up
automatically when you turn your computer on with a disk in the
drive. It's not an integral part of the computer, but a specialized
program for managing the contents of your disks. Even if you use
only a few application programs, you'll have to use the Finder
occasionally, if only to start the applications you use.
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Finder Version 4.1
Apple's latest version of the Finder incorporates many conveniences, shortcuts, and additional features. It is completely
compatible with other versions of the Finder, and applications
that ran under the old Finder should have no problem working
with version 4.1. The new Finder is usually installed with a program called System Update. This program also updates the System
and ImageWriter files . Check with your Apple dealer to obtain System Update and version 4.1 of the Finder; the new features will
make it worth your while. The body of the following text deals
with the old Finder. Notes are added as appropriate to document
new or different features of version 4.1 of the Finder.
Figure 1-6. Finder Screen
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Files and Icons
Information is stored on disk in the form of files . Each file can be
thought of as a single file folder that holds sheets of paper or
other information. The Finder carries this analogy to the extreme.
When you insert a disk into the drive, the Finder displays a miniature icon of the disk, with the disk's name displayed beneath it.
You can see what's inside a disk by clicking on it and selecting
Open from the File menu. A shortcut is just to double-click on the
17
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disk icon. A window opens up, containing icons for every file on
the disk. The files may look like sheets of paper, or they may be
represented pictorially. A MacPaint document shows a paintbrush
painting across the paper. The MacTerminal icon is a telephone.
Applications normally have distinctive icons.
The files behave like actual objects. You can pick them up
and move them by dragging them (hold down the mouse button
to pick them up and keep the button down while you move the
mouse). This lets you arrange the files just like you would on a
real desktop. The window holding the files can be moved and resized. Use the scroll bars to scan through the disk folder or just
expand the disk folder if you can't see all the files.

Opening a File
A file can be opened by clicking on it, then selecting Open from
the File menu, or by simply double-clicking on its icon. If the file
was created by an application, and that application is on the disk,
the application starts up and automatically opens the associated
file. You can also open the application itself, then open any documents from within the application.
You can change the name of a selected file just by typing in a
new name. You can drag across the title of a file to select it, then
cut it into the Clipboard. You can also paste text from the Clipboard to create the file's name.

Using Folders
Some icons within the disk window are shaped like file folders.
These folders, including the Empty Folder, can hold other files,
even other folders. This lets you organize your files into groups.
For example, you could put all your MacPaint files into a folder
called Pictures and all your business correspondence in a folder
called Letters. Most disks, called startup disks, because you can put
them in the drive and start up the Macintosh with them, contain
the System Folder. If you double-dick on it, it opens up to show
you several files, including the System file, the Finder itself, the
lmageWriter file (supports the use of the ImageWriter printer), and
probably files storing the contents of the Clipboard, Scrapbook,
and Note Pad.
To create your own folder, you need to duplicate the Empty
Folder, then change the name of the duplicate. Click on the
Empty Folder, then select Duplicate from the File menu, or press
Command-D. Just click on the duplicate and retype the name.
18
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(With version 4.1, you can also select New Folder from the File
menu to create an empty folder.) You can now pick up and drag
files atop this folder. When the position of the file you're dragging
and that of the folder coincide, and when the folder turns dark,
let go of the button. The file you were dragging disappears, but is
actually inside the folder. You can open up the folder (doubleclick on it) to see its contents. You can use the same technique to
duplicate any file onto the same disk. (You'll see how to copy a
file to another disk in a moment.)
Deleting Files
An important part of disk management is removing files that are
no longer needed. A disk has a limited amount of space on it. The
System Folder takes up quite a bit of space, as does an application
program. You'll probably need to remove any unnecessary files
just to free up disk space for further storage. This is where you
use the Trashcan. Just drag any file you don't need on top of the
trashcan icon, and watch it disappear. The file isn't removed from
the disk just yet-it's actually still inside the Trashcan. You can
open it up to display its contents and remove the file if you
change your mind. The Trashcan is emptied (and the disk space
used by Trashcan items is freed) whenever you start an application or eject the disk. You can empty it yourself by selecting
Empty Trash from the Special menu.
Some memory is used to hold the information about the image of a disk on the desktop, including information about every
file. This limits how many disks you can display on the desktop.
Fortunately, you can discard the images of disks that you no
longer need to display by simply dragging the image of the disk
into the Trashcan. This doesn't do any harm to a disk, but just
frees up the memory used to hold the image. You cannot trash
the image of the startup disk or of a disk in any drive. (Version
4.1 of the Finder does let you trash any nonstartup disk. If you
trash a disk icon, Finder 4.1 ejects the disk if it's in a drive andremoves the disk image from the desktop. You can also use Shut
Down from the Special menu of Finder 4.1 to eject all disks and
restart the system.)
Saving Disk Space
Even if you delete unneeded files, you'll find yourself running out
of disk space fast. The System Folder alone uses almost half the
available disk space. There are a few ways to free up some extra
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room. You can delete the System Folder, freeing up 196K, but the
disk can then no longer be used to start up your Macintosh. Such
a disk is called a data disk rather than a startup disk. You can use
the data disk to store your files, but you'll still need a startup disk
to run your application from.
Another way to free up disk space is to remove the fonts
from the System file that you won't need. Unless you're using
MacWrite or MacPaint with a lot of fancy text, you probably won't
need very many fonts. Use the Font Mover application on the System Disk to move any unused fonts from your disk onto a file on
another disk. You can always restore the fonts later.
If you won't be using the lmageWriter printer (or don't have
one), you can erase its icon from the System Folder. You can copy
the file back onto the disk from the System Disk if you need to.
We'll see how to copy files in a bit.
You can free up 46K by deleting the Finder from the System
Folder. Without the Finder, though, that disk cannot be used to
display or modify a disk. A Finderless disk can be used as a
startup disk, though, as long as you want to start a particular
application automatically. When you turn on the Macintosh, the
application loads automatically instead of the FiQder. To make an
application the startup file, click on the application and use Set
Startup from the Special menu. If you need to restore the Finder,
copy it back to the disk and use Set Startup to make the Finder the
startup application.

Disk Swapping
To work with another disk, click on the disk icon, then select Eject
from the File menu, or press Command-E. The disk is ejected, but
its image remains on the desktop. Now insert the next disk you
want to work with. Its image appears. While working with another disk, you may be asked to insert the disk you originally
started up with. The Macintosh keeps some of its information on
disk so as not to overburden memory, and needs to refer to the
original disk at times. The disk in the internal drive is ejected, and
you're asked to insert the original disk. The original disk is read
from and ejected, and then you can return the disk you were
working with. You may need to swap disks like this several times.
It can be tedious, but there's no way around it short of buying an
external drive.
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Using an External Drive
The external drive is a timesaver. With an external drive, you can
keep your startup disk in the internal drive and store all your data
on the external drive. A data disk doesn't have to be a startup
disk, so you can remove the System Folder from the data disk,
freeing up a whopping 196K of disk space. You can use a data
disk with a single-drive Macintosh, but you'll have to swap disks
whenever the Macintosh needs to refer to the startup disk. The
external drive can behave just like the internal drive-you can
even start the Macintosh with the external drive. Because you can
have two disks loaded at the same time, you increase the speed
and convenience of using your computer. A second disk drive can
be more valuable than adding extra memory.
Copying Between Disks
To copy a file between disks, you need to display the images of
both disks. Eject whatever's in the drive and insert your other
disks until the disks concerned are displayed. With the images of
the disk you're copying from and the disk you're copying to
shown, you can just drag the file you'd like to copy from one disk
folder to another. With a single-drive system, you may need to do
several disk swaps before the job is done. But with both an internal and external drive, it's a snap.
You'll sometimes need to select more than one file at a time.
You may want to erase several files at once, instead of grabbing
each one and dunking it in the trash. Or you may need to copy a
whole slew of files. You may need to eject all the disks in all the
drives. To select more than one file or icon, just move to one corner of a group of files and drag to a diagonally opposite position.
This will pull a dotted-line box around the files. When all the files
you want to select are framed in the box, release the mouse button. All the files will turn dark, showing that they're selected. If
you need to highlight all the files, choose Select All from the Edit
menu. When moving a group of files, always drag the file in the
lower-right comer of the group. This file is the leader of the group
and should be the first to be moved onto another disk, into a
folder, or into the Trashcan.
When moving files around, it's not too hard to clutter your
desktop, just as with a real desk. Icons can rest upon and hide
other icons. Icons can be left on the desktop, orphaned from their
folders. To restore a file to its original position, select Put Back
from the File menu (not available in Finder version 4.1). To
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straighten a cluttered desktop, choose Clean Up from the Special
menu.
Copying an Entire Disk
With a dual-drive Macintosh, copying files or entire disks is easy.
Just drag the file or disk icons onto the image of the second disk.
But copying an entire disk of files with a single-drive Macintosh
can be a nightmare of constant disk swapping. Fortunately, you
can use the Disk Copy application found on the System Disk. Start
your Macintosh from the System Disk, and double-click on the
Disk Copy icon.
Disk Copy copies an entire disk. It reads one quarter of the
original disk at a time, filling all Macintosh memory, including the
memory used for the screen; this makes for some strange, twisting
patterns. Each quarter is dumped onto the disk you're copying to.
It takes only four disk swaps to copy the entire disk. You also
have the option of initializing the destination disk.
Initializing a Disk
A disk right out of the box is not customized for use with the
Macintosh, so it must be initialized before anything can be written
to it. If you insert a new disk into the Macintosh, it will be pronounced as unreadable, and you'll be asked if you want to initialize it. This can also happen if a disk has been damaged or if your
disk drive needs repair. Initializing a disk erases everything on
that disk, so be careful. You can also force the Macintosh to
initialize a disk by clicking on the disk's icon and selecting Erase
Disk from the Special menu. You must give a unique name to a
disk when you initialize it.
The contents of the disk are normally displayed as icons, but
you can display the names, size, type, and date of creation for all
files. The View menu lets you choose the kind of display you'd
like for each disk. View also lets you see more information than is
displayed in icon form. You can view by icons (the default setting), by name (alphabetical order), kind (System files, MacPaint
files, BASIC files, and so on, are grouped together), date (chronological order), or by size in bytes (highest to lowest). Pre-4.1 versions of the Finder did not let you treat documents displayed in
nonicon form as objects, so you had to switch to an icon display
to drag or copy files. Version 4.1 lets you select and move files
from a folder displayed by Name, Date, Size, or Kind. These files
change back to icons when moved onto the desktop.
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Getting Information
Another way to see more information about a file is to click on it
and choose Get Info from the File menu, or press Command-1. The
Information About window shows what kind of file it is (a folder, a
MacPaint picture, a System file), the size in bytes of the file, the
name of the disk holding the file, the date the file was created,
and the last date on which the file was modified. The Get Info
window gives you a four-line edit field where you can keep notes
about the file.
This window also presents a button you can click to lock the
file. A locked file cannot be changed. You can read it, but you
cannot modify or trash it. The only way to write to or erase the
file is to unlock it. You can lock an entire disk (also called writeprotection) by sliding the write-protect tab on the disk into the
closed position. A locked disk is hard to use, since the Macintosh
needs a portion of the disk as scratchpad area, but it's a good way
to protect a disk from accidental damage. Many people writeprotect a disk before copying it, just in case.

Permanence
When you set the clock, the Macintosh doesn't forget the time. In
fact, it continues to keep track of the time and date, even with the
power turned off. The speaker volume, set in the Control Panel, is
also remembered. You probably know that this is because of the
AA battery installed in the back of your Macintosh, but you may
not know that the Macintosh permanently remembers other information, with no battery required. Many of the other settings in
the Control Panel, such as the desktop pattern, are stored on your
startup disk. Each disk can have its own distinctive combination
of Control Panel settings.
Other information is also preserved on disk. When you
change the name of a file or a disk, this obviously has to be
saved. Also saved are the positions of all files, the sizes and positions of any active document windows, and the kind of file
viewing selected. In effect, the status of your desktop is preserved
for the next time you start up your computer.
This information is saved only when you start a new application or eject the disk. This is why it's important to eject the disk
only through the menus, not by inserting a paper clip into the
"emergency eject" hole. This mechanically ejects the disk, but
doesn't give the Macintosh a chance to update current information. For the same reason, don't turn off your Macintosh before
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you've ejected the disk. It's safest to always Quit (from the File
menu) your current application, return to the Finder, then select
Eject from the File menu (or Shut Down from the Special menu in
Finder version 4.1) before you turn off your machine.

Other Features of Finder Version 4.1
The latest System Update not only updates the Finder, but also the
System and ImageWriter files. The new ImageWriter file permits
full use of the wide carriage version of the ImageWriter, and adds
a 50 percent reduction selection to the Page Setup option of File.
The half-size printouts are sharper (but smaller, of course) than
normal ImageWriter printouts.
The new Finder allows you to install a MiniFinder that is used
only to start up applications. To create the MiniFinder, just select
the applications you'll normally use, then pull down Use MiniFinder from the Special menu. The MiniFinder will then be used
automatically when you quit an application or start up the system.
You can erase the Finder to free up disk space and use the
MiniFinder in place of it for starting applications. The MiniFinder
only lets you open applications, change drives, eject a disk, exit
back to the main Finder, or Shut Down the system. It's a small
program, though, so it's quicker and more convenient when you
don't need all the features of the Finder.

Hardware Options
The basic 128K Macintosh is quite a workhorse, but it does have
some limitations. The memory can be quickly filled by large
applications, requiring the Macintosh to resort to disk access as a
slow substitute for computer memory. But this can be impossible
if the disk is nearly full. You may never notice these limitations
when working with programs optimized for the 128K Macintosh,
programs like MacPaint and MacWrite, but the really powerful
applications like Word or Multiplan are memory-hungry. More and
more people are turning to Macintosh enhancements to beef up
their systems.

The Fat Mac
The so-called Fat Mac has 512K of memory, four times the memory of the 128K Macintosh, a half-megabyte-524,288 characters.
That's enough memory to store most novels, more memory than
many mainframe computers have. It's just enough to turn the
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Macintosh into an exceedingly powerful machine. The extra memory reduces the amount of disk access, so programs run faster,
sometimes much faster. It permits much larger documents in word
processing, huge spreadsheets, and ample buffers for uploading
and downloading in telecommunications. With the Switcher (see
Chapters 9 and 11), you can hold multiple programs in memory,
quickly switching between them, and cutting and pasting information between them.
Most important, the 512K memory encourages software
developers to write programs that take advantage of this extra
memory and provides room for growth. Before long, even 512K
will seem like a paltry amount of memory, and Macintosh owners
will be clamoring for multimegabyte machines. (See Chapter 9 for
information on doing just that.) But in the meantime, we'll have
to make do with more memory than most people know what to
do with.

External Disk Drive
An external disk drive can be an even more significant upgrade. It
simplifies, streamlines, and speeds up disk-to-disk transfer. It permits you to have 400K of permanent storage available at any
time. You can fill one disk with applications and use another for
data storage. Apple has promised a double-sided BOOK external
drive. This drive would use two read/write heads to read and
write to both sides of a 3-1/2-inch minifloppy. However, once
written to, the BOOK disks may not be readable on a 400K drive,
limiting disk interchangeability.
Using a Hard Disk Drive
Figure 1-7. Mountains of Information
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You can use only one external drive, though, since there is only
one disk drive port, and with no port on the disk drive, there's no
way to daisychain peripherals. If you need more than a total of
BOOK (400K internal, 400K external), or 1.2 megabytes (400K internal, BOOK external), or find the speed of the disk drives a bit
too slow, you need to investigate using a hard disk.
Floppy disks are flexible plastic disks coated with magnetic
material like that used for cassette tapes. The thin disks are kept
either in a flexible plastic jacket, with a portion exposed for
read/write access (5-1/ 4-inch floppies), or are encased in a rigid
plastic case with a retractable metal cover that protects the
readjwrite access area (3-1/2-inch microfloppies). Floppy disks
must be floppy, since the readfwrite head touches the disk,
requiring the disk itself to flex under pressure. A rigid disk surface
would be seriously scratched or damaged by the constant pressure
of the head.
The disk inside the envelope spins at about 300 rpm, but this
speed varies, depending on where the drive is trying to read. The
drive speeds up when reading the inside tracks and slows down
on the outside tracks so that every track passes by the readjwrite
head at the same speed.
A hard disk (sometimes called a fixed disk) uses a rigid magnetic platter instead of a flexible disk. By spinning at more than
10,000 rpm, the rigid platter creates a tiny windstorm above it.
The read/write head floats on this buffer of air, only a few microns away from the disk surface. From this perspective, a speck
of dust is a boulder, and a human hair a sequoia. Fortunately,
hard disks use fans and filters to keep out most dust and smoke.
The hard disk permits much greater accuracy in placing the
readfwrite head, so data can be packed in much more compactly.
Access time is also improved, since the hard disk spins so fast. A
hard disk can store anywhere from 5 to more than 150 megabytes
(millions of bytes). The most popular sizes are 10 and 20
megabytes.
Hard disks can be very susceptible to damage, given the low
tolerance for dust. With the head so close to the disk surface, even
a small bump can bring the head crashing down onto the disk,
gouging the disk surface and plowing up millions of bits of data.
A power failure can also stop the disk from spinning, canceling
the air cushion before the drive has a chance to retract the head.
Here, too, you'd get a head crash. A head crash is disastrous,
since with a hard disk, you have all your eggs in one basket, so to
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speak. You need some way to copy the contents of a hard disk to
some other medium for safekeeping. It would take 25 Macintosh
3-t/2-inch disks to hold the contents of a tO-megabyte drive, so
some people go so far as to buy a second hard disk to back up the
first one. An alternative is the streaming-tape backup system, a
high-speed magnetic tape drive. Some people use a special system
that backs up hard disks onto ordinary videocassettes. These
backup systems can be expensive, but so is t 0 to 40 megabytes of
information.
If you think managing your floppy disks is tricky, just wait
until you're working with tO,OOO,OOO bytes. Most Macintosh hard
drives pretend to be a multiple of normal disks. The Finder works
as it does with floppy disks, displaying disk icons for the simulated disks. It's especially important to use folders to organize
information on hard disks, or you'd have a desktop filled with
thousands of overlapping icons. The Macintosh can manage only
a limited number of disk icons and folders, though, so using a
hard disk on it can be cumbersome. Manufacturers are still
experimenting with ways to streamline the use of hard disks. A
new ROM and a new Finder from Apple are forthcoming, and
they should solve some of these problems.
Most Macintosh hard disks do not give a significant increase
in speed, either, since they must communicate via the serial port.
The serial port is plenty fast enough for disk drives, modems, and
printers, but is a serious speed bottleneck for use with a hard disk
drive. Even hard disks which are installed internally, attached directly to the computer circuitry, are not as fast as hard disk drives
used with other computers.

Hard Disk Manufacturers
Listed here are just some hard drive manufacturers. Like so much
concerned with the Macintosh, there are new products released almost every month. A good place to watch for these new products
is in computer magazines; Macintosh user groups (if there's one in
your area) are another excellent source of information. The following aren't recommendations, just examples of some of the hard
drives currently available-more to give you an idea of pricing
and power than anything else.
The Tecmar hard disk was one of the first hard disks for the
Macintosh, so it's especially popular. Many software packages use
the. Tecmar drive as their standard, although they may work with
other hard drives. The Tecmar drive runs $t,990 for a 5-megabyte
removable cartridge, $t,995 for a tO-megabyte fixed drive, $3,290
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for a tO-megabyte fixed drive with a 5-megabyte removable cartridge, and $3,290 for a drive with two 5-megabyte removable
cartridges. Tecmar's MacDrive's speed is approximately 5 megabits (610K) per second. They're available from Tecmar, Inc., 6225
Cochran Road, Solon, Ohio 44139.
Davong Systems manufactures 10-, 21-, 32-, and 43megabyte hard disks. Access time is 100 milliseconds for the 10and 21-megabyte drives, and 40 milliseconds for the 32- and 43megabyte disks. The Davong drives use a special utility program
called Volume Manager that permits you to partition the massive
amount of disk memory into individual volumes. Each volume is
used like a disk icon. The Volume Manager lets you combine volumes to store your files more compactly. Prices are $1,950 for the
10-megabyte drive, $2,795 for the 21-megabyte drive, $3,395 for
the 32-megabyte drive, and $3,995 for 43 megabytes. Available
from Davong Systems, Inc., 217 Humboldt Court, Sunnyvale,
California 94089.
General Computer Company, originally a designer of Atari
arcade games and the 7800 Pro System, have engineered a unique
10-megabyte internal hard drive, called the Hyperdrive. The internal hard drive retains the Macintosh's small foo~print (amount
of desk space required). Since the unit is installed inside your
computer, you need to ship your Macintosh to General Computer
for the upgrade. They promise a one to two week turnaround.
Apple has recently announced that this does not void your Macintosh warranty. General Computer can also install a memory upgrade to bring your total memory up to 512K. They claim their
hard disk is 7 times faster than other Macintosh hard drivesspeed of 5 megabits (61 OK) per second-and 20 times faster than
the internal microfloppy drive. Unlike external hard drives, the
Hyperdrive leaves all rear ports open for other peripherals, and
it's possible to start up your computer from the Hyperdrive. Price
is $2,795 with the 512K memory expansion, $2,195 without memory expansion. Available from General Computer Company, 215
First Street, Cambridge, Massachusetts 02142.
Iomega's Bernoulli box is a unique variation on hard disks.
Instead of using a readjwrite head that floats on a cushion of air
created by the high rpm's, the rigid disk itself floats due to the
Bernoulli principle-the same principle that permits airplanes to
fly. The disk floats up to a stationary head. There's no way for the
head to crash. If power is lost, the disk just softly falls away from
the head, solving a major anxiety for hard disk users. The Iomega
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Bernoulli box uses a removable cartridge. Each cartridge stores 5
megabytes, with a data transfer rate of 90K per second, not as fast
as most hard disks. Each cartridge is $59. The removable cartridge
means you can have an unlimited total amount of removable data,
and you can transport the media rather than the machine. The
Bernoulli box combines the best advantages of hard disks and
floppy drives. The price is $1,895, from Iomega Corporation, 4646
South 1500 West, Ogden, Utah 84403.

Printer Alternatives
Just as the bitmapped graphics screen is the key to the Macintosh's "what you see is what you get" concept, a printer that
can accurately reproduce the bitmap, or even improve on it, is a
must. Bitmapped printer graphics require lots of information, so
you need a fast printer. Apple's ImageWriter meets these needs. It
has square pixels with a 1:1 aspect ratio, just as the screen does,
so it can produce output with proportions close to what's shown
on the screen. But because it can print 1280 dots per line instead
of the Macintosh's 512 dots per line, the ImageWriter can improve
on the display. In fact, when you print text to the printer, the
Macintosh actually uses a font twice the size of the text on the
screen and reduces it on the printer. For example, Geneva 12 is
printed on the printer as a reduced Geneva 24.
Despite the ImageWriter's high performance, many people
don't like being limited to one printer. Apple's design makes it
difficult to use any other graphics or letter-quality printer with the
Macintosh, but clever engineers wouldn't let this go unchallenged.
The Macintosh versions of Okidata's 92 and 192 printers are designed to be perfectly compatible with the ImageWriter and Macintosh, and at a lower cost ($499).
The ImageWriter does a fair job of approximating various
typefaces and styles, but is still not quite letter-quality. Figure 1-8
shows samples of both ImageWriter (left) and letter-quality (right)
print.
For many people, nothing less than print indistinguishable
from the venerated Selectric will do. This hampered the acceptance of the Macintosh into the office, until several third-party
manufacturers found ways to attach non-Apple hardware to the
Macintosh.
Microsoft's MacEnhancer is a hardware/software combination
that lets you attach a wide range of peripherals not normally
compatible with the Macintosh. The MacEnhancer supports one
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Figure 1·8. Print Comparisons
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Centronics parallel port (IBM PC compatible) for parallel printers,
and two RS-232 serial ports (also IBM PC compatible) for use
with serial devices such as modems, plotters, and serial printers. It
includes software that installs as a desk accessory, ready to pull
down from any application. You can use almost any dot-matrix or
letter-quality printer with the MacEnhancer, since the software
translates ImageWriter codes into those needed by your printer.
MacEnhancer is $249, available from Microsoft Corporation,
10700 Northup Way, Box 97200, Bellevue, Washington 98009.
With the right cable, a wide variety of RS-232 serial printers
can be attached to the Macintosh, but you have to use these printers with software that can support them. For example, Microsoft
Word includes printer drivers for many popular letter-quality
printers. A new version of the Macintosh System program builds a
printer selection utility into the desk accessory menu, letting you
tell the Macintosh what kind of printer you're using. You can
print only text with many applications by selecting the Draft print
quality mode.

MacOfflce Tomorrow
The Apple Macintosh is still growing. More and more software
packages are becoming available, new and powerful tools for the
Macintosh office. Page layout programs let you cut and paste to
create whole pages of text and graphics, and print them to the
ImageWriter or the LaserWriter. The LaserWriter itself is opening
up new, inexpensive opportunities for quality production work.
This laser printer can be linked with other Macintoshes, hard
disks, even IBM PCs, in a fully communicative office system network (see Chapter 10 for complete details on this AppleTalk net30
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work concept). You can even run IBM programs on your Macintosh
with MacCharlie, a hardware emulator.
A lap portable "Flat Mac" isn't far away. The Macintosh of
the future may very well sport 5 megabytes of memory, 50 megabytes of ultrafast online mass storage, a large, crisp, super-highresolution color screen, a 68020 microprocessor with mainframe
speed and flexibility, and new software to match this power. We'll
wonder how we ever got along without it.
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The MacOffice Software
Selby Bat eman

Once familiar with Macintosh's easy-to-use
operating environment, you're ready to take
full advantage of the system's power and
flexibility in your own MacOffice. To accomplish this, you'll work with a sophisticated
group of four productivity programs developed by Microsoft, one
of the leaders in creating computer software: Word, a powerful
word processor; Multiplan, an electronic spreadsheet for financial
calculations and other quantitative work; File, a database information management system; and Chart, a business graphics program which also allows you to create charts and graphs from your
File and Multiplan programs.
Microsoft has tailored these packages to use all of the Macintosh fea tures. You'll find that each program is in tuitively easy to
learn. As your experience grows and your requirements become
more demanding, you'll also be surprised at how these programs
grow with you. And many of their functions can be integrated to
bring even more utility to your work.
You'll also be introduced to MacTermina /, a telecommunications program which lets the Macintosh communicate with
other computers. The documents and files you create with
Microsoft's application programs can be sent and received by the
Macintosh using MacTerminal (or a similar telecommunications
package).
The following hands-on sessions will introduce you to the basics of these programs. By the end of this chapter, you'll see how
to use each one in a simple but practical application. In later
chapters, you'll learn in detail how to use them every day in your
own MacOffice, creating specific procedures, forms, and templates
w hich will save you time and increase your productivity.

A Note on Disk Drives
For ease of use, Microsoft recommends that Word, Multiplan, File,
and Chart be used with an external disk drive in addition to the
internal Macintosh drive. However, each of these applications is
fully fun ctional with just the internal drive. The differences between the two are largely those of con venience and speed. With
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two drives, the documents and files you create can be placed on a
separate disk in the external drive while a copy of your master
applications disk resides in the internal drive. If you have only
one disk drive, you must go through additional disk swappingthat is, exchanging disks to save, copy, and handle other disk
management processes. Disk swapping with one drive can become
a tedious process for some of the procedures you'll learn. But the
benefits of these programs-even with one drive-outweigh the
inconveniences associated with swapping disks.
You'll be able to use all the procedures in this book no matter
what your disk configuration. The Macintosh will guide you in
virtually every action you encounter relating to disk management.
Your Macintosh manual has more information on this, and in later
chapters of this book you'll learn some advanced application techniques as well.
Each of the Microsoft applications is contained on a master
disk which has a special identification code that the Macintosh
must read when you start the program. You should make a copy
(or copies) of the master disks and use them rather than the masters. When you begin a session with one of the applications, the
Macintosh will ask for the master disk in order to read that identification code.

Making a Startup Disk
Making startup copies of the master disks is identical in each of
the four Microsoft applications. First, place the master disk in your
drive. After the program's icon appears on the screen, choose Eject
from the File menu, then insert an initialized disk (preferably
empty) after the master disk has ejected. (If you have two drives,
simply place the master disk in the internal drive and the blank
disk in the external drive.) Drag the master disk icon onto the
other disk's icon and release the mouse button.
A window will appear, asking whether you wish to replace
the contents of the second disk with that of the master disk. Click
OK, and your Macintosh will begin the process. Remember, if you
have any files on the second disk, they will be erased. If you have
a single-disk system, there can be more than 20 disk swaps to
complete the process. With two drives, no disk swaps are necessary. For a fuller treatment of disk space and memory management techniques, refer to Chapter 1 or the manual that came with
your Macintosh.
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(It's a good idea to take advantage of Microsoft's Backup Disk
Order service. For ten dollars and proof of purchase, Microsoft
will send you a duplicate master disk for the application you
purchased.)

Microsoft Word
No matter what the requirements of your MacOffice, chances are
that Word will be the foundation of much of your work. Word is
the first serious word processor available for the Macintosh .
Whether you're writing a short memo or preparing a 200-page report, Word lets you create and manipulate documents with ease.
Figure 2-1 . Microsoft Word Document
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If you've never used a word processor, Word on the Mac will
bring an entirely new experience to your writing. Learning Word is
easier and faster than other word processors. And once freed from
the cumbersome process of handling office paperwork on a typewriter, you'll wonder how you managed without Word and the
Macintosh.
If you're familiar with word processors for other computers,
you'll be pleased with the simplicity and freedom of creating,
editing, formatting, and printing documents with the Macintosh.
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The complicated command codes and special keyboard sequences
found on many other word processors have been replaced by a
menu system based on clear, descriptive terms written in everyday English and controlled by the click of a mouse. There's no
need to worry about running out of room with Word, since each
document is limited only by the amount of space on your diskas much as 50 to 60 pages of text.
Like most full-featured word processors, Word lets you type
your information on the keyboard, then make changes, move
blocks of text anywhere on the screen, and copy and save documents. The program also contains all of the other commands
which make a word processor so useful: adjusting text to the left,
right, or center; adding headers and footers to your documents;
searching and replacing text; placing footnotes and superscripts
and subscripts; and many more features.
But the Macintosh goes much further than other computers.
With Word, your documents may contain a variety of type styles,
called fonts, and different sizes of type as well. You're also free to
incorporate graphic images, files of data, and financial and statistical information into your memos, letters, and reports by integrating Microsoft's other programs into your Word documents.
Even very powerful writing, editing, and printing functionspreviously the domain of dedicated typesetting systems-are
yours with Word. Automatically number footnotes in documents.
Store blocks of text you often use, and then call them back with a
few clicks of the mouse. Use Word's multiple windows to move
among different documents. Change the layout of your documents
onscreen to see them exactly as they'll appear when printed.
These and many more options and features will quickly change
the way you deal with every aspect of writing and paperwork.

First Session-Word
When you're ready to write, Word is just the click
of a mouse away. Tum on the Macintosh, insert
your copy of the Word master disk, and in a meMicrosoft Word ment you'll see the Macintosh desktop. Doubleclick the Word icon to load the program into the
computer. Or make a single click on the icon to select it and then
click Open in the File menu. The Macintosh will instruct you
when it needs to read the identification code on the Word master
disk.
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After waiting a moment for the program to load, you're ready
to begin writing. The Macintosh screen is your sheet of paper,
with the familiar menu bar at the top, as in Figure 2-2.
Figure 2-2. Word Opening Screen
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At the upper-left corner of your empty sheet of paper you'll
see a flashing vertical bar. This is the point at which text will be
inserted when you begin typing. Next to the vertical bar is a diamond, marking the end point of any text which will be entered.
Centered below the menu bar is the as-yet untitled filename for
the memo you're about to create. (In Figure 2-2, the label has
been replaced with the name Word.)
Slowly roll the mouse across your desktop. Notice that when
the onscreen moving pointer is in the text area of the screen, it
takes the form of an 1-beam. When you move it off the text area,
it reverts to the familiar arrow.
Now type in the text just as you see it in Figure 2-3. As the
text reaches the right margin, it automatically jumps to the next
line. This feature is called word-wrap. You don't need to use the
Return key until you reach the end of a paragraph. If you make a
mistake as you type, simply press the Backspace key to erase the
error.
Figure 2-3. Initial Draft of Memo
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tr'he Initial results of our May 1 inventory have been very helpful in
determining the direction we should take during the next 12 months.
Simply put, we have seen amazing growth in the sales of our oversize trade
paperbacks, especially in the categories of art, travel, computer, and science
books. The mass market paperbacks have continued to sell well. Science
fiction and modern romance titles seem to be faring the best. Our hardback.
book. sates, however, were disappointing. We will have more detailed
information tabulated by category later this week..
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The text in Figure 2-3 should now be on your screen. This is
the initial draft of a memo to employees at The Book Haven, a retail bookstore. As manager of the store, you'll refine the rough
draft, add a heading, and insert .a store letterhead into the memo
as well.

Adding Text
.
. .

To insert text anywhere into your memo, simply position the pointer wherever you wish to
add or change the text. Move the pointer behind the period after
the word disappointing in the next to last line of the memo.
Now insert the following text into your memo: Trade paperback sales have jumped 20 percent over last year and mass
market titles have increased by 12 percent. At the same time,
our sales of hardbacks have decreased by 6 percent.
You'll notice that as you typed the new material, the last sentence of the memo moved ahead of your inserted text, automatically spacing the words correctly.

dlsappolnting.I

Reforming Text
Your memo now is more complete, but its appearance is a relatively uninviting block of words. With a few clicks of the mouse
and several keystrokes, the text can be divided into several indented paragraphs. Note that in Figure 2-4 the sentences have
been split and reformatted with indented first lines. To do this,
move the pointer in front of the first word on the first line. Click
the mouse once to bring the insertion point there. Then locate the
Tab key on the Macintosh keyboard and press it once. The line is
quickly indented and the rest of the words move to make room.
Next, place the pointer in front of the word Simply in the second sentence. Press the Return key and the block of text moves
down one line. Press the Tab key and the block is indented. Follow the same procedure, moving the pointer to a spot following
the word disappointing and before the word Trade in the fifth line
of that paragraph. Press the Return key once and the remaining
text moves down a line. Press Return again and you have created
a double-space between the paragraphs. Press Tab and this paragraph is indented as well. Follow the same procedure for the last
sentence-point, click, Return, Return, Tab-and your screen
should be identical to Figure 2-4.
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Figure 2-4. Reforming Text

*

File

Edit

Search

Character

Document

The initial results of our May 1 inventory have been very helpful in
determining the direction we should take during the next 12 months.
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science books. The mass market paperbacks have continued to sell well.
Science fiction and modern romance titles seem to be faring the best. Our
hardback book sales, however, were disappointing.

Trade paperback sales have jumped 20 percent over last year and
mass market titles .have increased by 12 percent. At the same time, our
sales or hardbacks have decreased by 6 percent.
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When you write your own memos, you may indent and space
your lines as you write. But no matter how the text looks, you can
always change it at any time.

Undo and Redo Commands
If you decide to add a final sentence to your memo, move the
pointer to the end of your text and click. Then type Please try to
develop some ideas for store layout to help promote sales in
different categories of books.
Perhaps you decide this last sentence is inappropriate. You can erase it by simply using
the Undo command in the Edit menu. Move the
pointer to Edit on the menu bar; click the
cut
[ OJllj
mouse and hold it down as you drag the
Paste
pointer to the first choice on the menu-Undo
[ IIJIH
:•:II
Typing.
Show Clipboard
Show Glossary
Show Ruler 3€ R
Show 'II
34:Y
Preferences ...
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As you release the mouse, that last sentence disappears. Quick and easy. Should you
immediately decide you liked the sentence after
all, move the pointer back to the Edit menu.
Now the menu reads Redo Typing. Drag the
pointer to that choice, release, and your sentence returns.

Show Ruler 8CR
Show 'II
8CY
Preferences ...

Editing Text
You're free at any time to change a word, phrase, or larger block
of text. For instance, you might decide to replace the word amazing in line 1 of the second paragraph with the word surprising.
There are several ways to accomplish that-by typing over the selected word, by using the Backspace key, or by choosing the Cut
selection from the Edit menu.
To select the word amazing for dele, of our May I invento·
tion, simply move the pointer to the beginJon we should take duril.
ning of the word, click and hold the
~ave seen Ni!iH!fMgrowtt mouse, then drag the pointer over the
·Ially in the categories (
;arket paperbacks t
word. It changes to white lettering outlined
·omance titles sE>
in black. Release the mouse. Begin typing
- were disapr
the word surprising. As soon as you begin,
the outlined word amazing disappears and begins to be replaced
by your new entry. You've now replaced one word with another .
.As an alternative, you can select the word amazing and press
the Backspace key. The word disappears and you can enter the
word surprising once more.
One more method for deleting a word-choose the Edit category on the menu bar, click and hold the mouse, and then drag
the pointer to Cut. Click the word surprising and drag the pointer
over it. Select Edit with a click, and then drag the pointer to Cut
and release. Surprising disappears. Move the pointer to where you
wish to reinsert the word, and type amazing.
Word offers you a variety of ways to insert and delete text.
The method you choose depends on your preference. You can
also move blocks of text anywhere in a document simply by
choosing to Cut and then Paste them back in a different area .
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Add Your Heading
To give you an idea of Word's versatility, let's add a heading to
the memo. Move the pointer to the top leftmost point in the text
area of your screen. Click the mouse button and press the Return
key ten times to move the text down. This gives you plenty of
room to add a heading. Move the pointer about halfway up in the
empty text area and click. Then type the following: TO: All
Employees <Press Return>; FROM: Joan Smith, Manager
<Press Return>; andRE: Initial Inventory Results. Your screen
should now be similar to Figure 2-5.
Figure 2-5. Memo Heading
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TO: All Employees
FROM: Joan Smith, Manager
RE: Initial Inventory Results

The initial results or our May 1 Inventory have been very helpful in
determining the direction we should take during the next 12 months.
Simply put, we have seen amazing groWth in the sales of our oversize
trade paperbacks, especially in the categories of art, travel, computer, and
science books. The mass market paperbacks have continued to sell well.
Science fiction and modern romance titles seem to be raring the best. Our
hardback book sales, however, were disappointing.

!,,
.
·
.!'
:,

, .,

If you would like to close up the space slightly between the
heading and the body of the text, simply move the pointer to the
leftmost point on the first line of text. The blinking vertical insertion point should now be at the extreme left of the screen, several
spaces from the indented beginning of text.
When making this adjustment, if your pointer went too far to
the left-off the text area-it's possible that when you clicked the
mouse the entire line was selected (white lettering on a black
background). To avoid this when moving the pointer, make sure
that the pointer is still in the !-beam shape. If it has changed to an
arrow, then you h ave left the text area.
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If this occurred, correct it by moving the pointer to a text-free
space on the screen and then clicking the mouse. The line will no
longer be selected and you can try again.

Split Screen
When you created the heading, you left the manager's name at
the bottom of the memo. You can delete that by selecting the
name and then choosing Cut from the Edit menu or simply pressing the Backspace key after the name has been selected. But by
now, the name has scrolled out of sight off the bottom of the
screen. To scroll up or down, use the vertical scroll bar at the
right of the screen.
Word also allows you to split the screen into two windows
wherever you wish for easier editing or to compare portions of
text. At the upper-right corner of the text area is a black rectangle
just above the scroll bar arrow. Move the pointer to the box, click
and hold the mouse, and drag the box about halfway down the
screen. Release the mouse button. You've created two windows in
which you can scroll independently.
Figure 2-6. Split Window with Text
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FROM: Joan Smith, Manager
RE: Initial Inventory Results
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The initial results of our May I inventory have been very helpful in
determining the direction we should take during the next 12 months.
Simply put, we have seen amazing groWth in the sates of our oversize
trade paperbacks, especially in the categories of art, travel, computer, and
science books. The mass market paperbacks have continued to sell well.
Science fiction and modern romance titles seem to be fa ring the best. Our
hardback book sates, however, were disappointing.

In the lower window, scroll toward the bottom of text until
you see Joan Smith, Ma nager. Now select and delete the name and
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title. To dispose of the split window, simply move the pointer to
the black window split bar and return it to the top of the vertical
scroll bar.

Add Your Letterhead
As a final touch, you'll create the store's letterhead at the top of
the memo. Move the pointer to the top left of the text area and
click. Type The Book Haven and then press Return; type 222
Main Street.
To create a more distinctive effect you can
center the letterhead and then change its type font
and size. Begin by selecting The Book Haven and
..lleft
the address; that is, move the pointer to the beginCentered
ning of the name, click, and drag the pointer across
Right
both lines. Then shift the pointer to Paragraph on
Justified
the menu bar. Click and hold the mouse. This
..ISingle Space
menu offers you several paragraphing alternatives .
Double Space
With your finger still holding down the mouse
Open Space
button, drag the pointer to Centered and release.
The name and address are centered. The name and
Formats ...
address are still selected, so move the pointer to an
Tabs...
XT
empty space on the screen and click to remove the
selection.
You can change the size and
Character Formats
OK
II
n
style
of the bookstore's name by
-Style
making
selections from the Character
(
)
Cancel
OBold
menu. First, select The Book Haven.
0 Italic
0 Underline
PositionSelect Shadow from the Character
0 Outline
®Normal
menu. Notice the change. Try select(2) Shadow
0 Superscript
ing
Small Caps from the same menu
[ZJ Small Caps
0 Subscript
for something different. Or choose
Font Name:
Formats. In a moment, you'll see the
1Q:
Chicago
Character Formats window. From this
~ ronl
111111window you can change the text
1:~·= I style
~e0n0e:C~ ~:
and position as well as the font
styles and sizes. Since The Book Haven is still selected, any change you make will be reflected in that
portion of the text. How about increasing the size of the name
from the present 12-point (outlined in the window in white lettering on black) to 24-point? Type the number 24. The Font Size
window registers the change. Press Return or click on OK and the
Character Formats window disappears. The name of the store has
been enlarged.
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Let's make one final change by putting the address in boldface. Select the address. Choose Bold from the Character menu.
Click once again in an area with no text to remove the selection.
Your screen should now look like Figure 2-7.
Figure 2-7. Memo with Letterhead
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You can make a permanent record of the memo by choosing

Save from the File menu. Type in the name for the memo and
then click the mouse on Save or press the Return key.
If you've already saved the document, you can keep an original and make a new version by selecting the Save As option from
the File menu. Type in the name you want to use, making sure
that it's different from the original document name.
With Word, what you see on the screen is what you get when
a document is printed out. Printing with Word is as easy as the
program's other features. The File menu contains four submenus
which help you in printing documents. Select Page Setup, Print,
Print Merge, and Printer Setup to familiarize yourself with their
features. See the Word manual and your Macintosh manual for
more details on printing features.
Word can also offer help if you forget the function of certain
options and features. Select About Microsoft Word from the Apple
menu. A window will appear with a list of topics which you can
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choose for further explanations. For those computer users who
may prefer keyboard control rather than the mouse for some functions, Word includes an optional keyboard control system which is
explained in detail in the manual.

Microsoft Multiplan
Putting financial and numerical information to work effectively is
at the core of any successful business. With Microcoft Multiplan,
your office has one of the most advanced electronic modeling,
planning, and accounting tools ever created.
Figure 2-8. A Multiplan Screen
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Since its introduction in 1979, the electronic spreadsheet has
revolutionized the way people work with numbers. Whether
you're developing an office budget, projecting a sales campaign,
analyzing your company's inventory, calculating a profit-loss ratio, or working on any of a hundred other projects, Multiplan will
enable you to pose the questions and find the answers faster and
easier.
Electronic spreadsheets are also the ultimate in " what if?"
planning. Change one number in your worksheet and all other
numbers are altered instantaneously. This capability allows you to
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try any number of variations in your calculations. What might
have taken hours or even days of work just ten years ago can be
accomplished with Multiplan in minutes or seconds.
Multiplan's greatest advantage over earlier spreadsheets is its
remarkable ease of use. You don't have to be a whiz at math or
remember complicated formulas for different functions. Multiplan
takes care of that. Once you've set up your worksheet the way
you want it-in everyday English terms-Multiplan offers you
easy-to-follow options.
But just because it's simple to use doesn't mean Multiplan
lacks the power and sophistication you expect from an electronic
spreadsheet. The built-in mathematical and statistical operations
include functions for mathematical and trigonometrical calculations, logical evaluations, and even text calculations, among other
features. From the simplest home budget calculation to the most
complex mathematical operation, Multiplan will make your work
with numbers easier and faster.

First Session-Multiplan
As with all Macintosh programs, start by turning your
computer on and inserting the disk. When the Multiplan
~
icon is on the screen, click it twice to get started. In a
moment, a portion of the Multiplan worksheet grid apMultiplan pears. The numbers in the vertical line at the left, running from 1 to 15, are the visible row numbers. The numbers in
the horizontal line, running from 1 to 6, are the visible column
numbers. Multiplan can contain up to 255 rows and 63 columns,
although they can't all fit on the screen at one time.
Each of the rectangular boxes below the column numbers and
to the right of the row numbers is called a cell, identified by the
row and column numbers which intersect on that space. For example, the black cell outlined in white at the upper left is at the
intersection of Row 1 and Column 1, and so is referred to as
R1C1. Note that the rectangle visible beneath the File menu contains the reference to the black cell-R1Cl. Move the pointer to
another cell on the screen, then click the mouse button andrelease. The black rectangle, referred to as the current cell, has
moved, and the cell reference has changed automatically in the
rectangle below the File menu. Practice moving the pointer across
the screen, changing the current cell and watching the cell reference shift. Most people prefer using the mouse, but if you want

h..
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Figure 2-9. Opening Multiplan Screen
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to change the current cell by using keys, the following keystrokes
allow you to do this:
Direction
Move right to next horizontal cell
Move down to next vertical cell
Move up to previous vertical cell
Move left to previous horizontal· cell

Key(s)
Press Tab key
Press Return key
Press Shift-Return keys
Press Shift-Tab keys

In Multiplan, you can enter text, numbers, or calculation formulas as part of your work. You can use the scroll bars to move
to other parts of the Multiplan worksheet. Remember, the current
cell is the insertion point for anything you enter in Multipla n.
To introduce Multiplan, let's create a simple monthly expense
report for a small business.
Move the pointer to R1C1 , click and hold the mouse, then
drag the pointer down the column to Row 11. Although Rows
1-11 are now highlighted in black, R1C1 remains the current cell.
Type the words Office Rent. The text is placed in the current cell.
The words also appear simultaneously in the long rectangle below
the menu bar. This is the formula ba r. When you press the Enter
key (not the Return key, which you might be more accustomed to
pressing), the word disappears from the formula bar and the current reference block changes to R2Cl.
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Type the following words, pressing Enter after each one. If
you make a typing error as you go along, press the Backspace key
to erase. Don't be concerned if some of the words are too long to
fit into the column. You'll correct that in a moment.
Payroll
Mailing Costs
Transportation
Utilities
Insurance
Loan Payments
Maintenance Agreements
Miscellaneous
Press the Enter key once more to move the current cell to RllCl.
Now type Total Costs and press Enter. The current cell jumps
back to RlCl.
Figure 2-1 0. Expense Categories
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Since some of the categories were too
long to fit into the column, you need to
widen column 1. Move the pointer to the
vertical divider between Column heads 1
and 2. The pointer will change from a
cross to a black bar with arrows pointing
left and right. This indicates that you can
change the margins of the columns horizontally. Click the mouse, and while holding it down, drag to the right until you
have about a quarter-inch between the end
of the word Agreements and the vertical line. Release. Column 1 is
now wide enough to show all of the words.
You may also change the
column widths by choosing ColColumn Width
umn Width from the Format menu
and typing in the size of a new
width for selected columns or for
D Set Rll Co lumns to Standard Width
all columns. This option can also
L:.li.K::~J [ Cancel ]
be used to return all columns to
standard width.
Let's track the company's expenses over a three-month
period. To show this, you can create a space at the top of the
worksheet to enter July, August, and September, the months for
which you have the most recent expense figures. To move the column of expense categories down two spaces, hold down the Shift
key and move the pointer to the head of Row 1, directly over the
number. Click the button twice while still holding down the Shift
key. The categories move down two spaces and the current cell
remains R1C1.
Move the pointer to R1C1; click and hold the mouse button
down while you drag the pointer horizontally across Columns 1
through 4, staying on Row 1. Release the button. With R1C1 still
the current cell, type Expenses: and press the Enter key. The current cell becomes R1 C2. Now type the names of the monthsJuly, August, September-pressing Enter after each.
You'll also want to enter the financial information for each of
the months in their respective categories. Begin by moving the
pointer to R3C2. Click and hold the mouse button, then drag
down through R11C2; in other words, all of the cells to the immediate right of the Expense categories. Release the button and
enter the following figures, pressing the Enter key after each.
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2000
9600
250
68
209
315
460
45
263

Before you add the total costs for July, enter the figures for
August and September as well. Move the pointer to R3C3. Click
the mouse and, while holding the button down, drag the pointer
to R11C4. Release the mouse. The cells for entering expenses for
August and September are now highlighted.
August September
2000
2000
10400
9600
212
365
119
65
300
350
315
315
460
460
45
45
350
110
Enter the numbers for each category. The first one-2000-is
the current cell, R3C3 (August). Type 2000 and press the Enter
key. Note that Multiplan moves the current cell horizontally to the
next cell, R3C4 (September). Type the September figure, also 2000,
and press Enter. The current cell jumps back to August, but at cell
R4C3. Continue to enter the figures until you've filled the highlighted cells. If you find that you've made an error, there are several methods of correction. Repeatedly press the Enter key, cycling
through the selected cells until you return to the cell containing the
error, then simply enter the information again. Or press Backspace
to delete the information and type it in again. Once you're satisfied with the results, your worksheet should look like Figure 2-11.
Since you're working with financial information, you need to
arrange the numbers to appear that way. First, move the pointer
to the Select menu, click and hold the mouse button, and drag
down the menu to All Cells. Release the button. Multiplan selects
all cells. Next, move the pointer to the Format menu, and click
and drag down to the Dollar option. The program shifts all numbers to dollar values. You can enhance that even more by again
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Figure 2·11. Expense Columns
4i File Edit Select Format Options Calculate

choosing the Format menu and dragging the pointer to Commas.
Commas will be inserted in numbers automatically where appropriate. Notice that Multiplan did not alter the text when you chose
the Dollar and Commas options. The program differentiates among
text, numbers, and formulas .
Your worksheet now shows that in R4C4 the number has
been replaced by a string of# symbols. This indicates that the
number, with its dollar signs and commas, is too long for the
available space. Move the pointer to the vertical bar between Column heads 4 and 5. Click on the bar and drag the margin line to
the right about a quarter-inch. When you release the mouse button, the margin for that column will be extended and the number,
$10,400.00, will have enough room to be displayed once again.

Calculating Totals
Multiplan's real power stems from its capacity to handle formulas
ranging from the simplest addition to the most complex scientific,
mathematical, and financial calculations. To give you an idea of
how Multiplan builds its formulas, let's look at how the program
manages a simple sum.
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Start by moving the pointer to R13C2. Click
and release the mouse button. The Total Costs
cell for July is now selected. Type an equal ( =)
sign in that cell. The symbol will also appear in the formula bar
near the top of your screen. Now move the pointer to the first
dollar amount under July, cell R3C2 ($2,000.00). Click the mouse
on that cell. The formula bar now has the first part of the formula
you're building. It should look like this: =R{-10}C.
Figure 2-12. Building Your Formula
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The formula so far means that the cell you've just clicked is
ten rows up in relation to the selected cell (R13C2). In other
words, the cell is defined in terms of its relative position to the selected cell. Now click and release on each of the dollar amounts in
the July column (Column 2). The formula near the top of your
screen becomes longer with each click, all in relation to the cell in
which you typed the = symbol. The formula bar has been enlarged to two lines to contain the complete formula.
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Figure 2-13. Complete Formula
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Press the Enter key and Multiplan automatically calculates the
sum of the expenses, then deposits the result in the selected box
at R13C2.
This is only one way that Multiplan lets you calculate a total.
With R13C2 as the current cell and the formula showing in the
formula bar, move the pointer to the Edit menu and choose Copy.
This will make a copy of the formula in the Clipboard. You can
use this copy of the formula to save time for adding other numbers which correspond to this formula .
Move the pointer to R13C3 (the Total Costs cell under the August column) and click the mouse. Select the Edit menu again and
choose Paste. Multiplan automatically calculates the total using the
formula you've saved.
While this is a relatively easy example, Multipla n allows several other ways to accomplish the same thing. As you work with
Multiplan later in this book and in your own work, you'll find
that the program lets you take even more shortcuts as your
knowledge increases.
Another way to get a total using the formula you've placed in
the Clipboard is to choose the Fill Right or the Fill Down command in the Edit menu. For example, click on R13C3 and then
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drag the pointer to the next cell to the right (R1 3C4). Release the
mouse bu tton and select Fill Right from the Edit menu. Multiplan
takes the formula and makes the calculations automatically. The
more totals you need to figure, the more time you save as
Multiplan takes care of things.
Figure 2- 14. Fill Right
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There are more than 40 different
functions in Multiplan,
..
COLUMNtl
ranging from such commonly
c.oso
[_
oK_ ;;;J
used calculations as SUM (addiCOUNTI)
DELTA()
tion) and AVERAGE (average of a
( Con cel )
DOLLAR ()
group of numbers) to more comEHPO
f Rl SEll
plex procedures such as ATAN
0
(finding the inverse tangent function of a number) and TAN (tangent of a number). To look at the
menu of these functions, select Paste Function from the Edit menu.
When the Paste Fu nction w indow opens, practice scrolling up and
down to see a list of all the functions.
Press Cancel to remove the Paste Functio11 window. In your
expense report example, you can quickly find the average of each
of the categories of expenditures. Make RIC5 the current cell and
type Average, then press the Enter key. You may find that your
AlAN()
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worksheet has automatically shifted one column to the left to let
you see Column 6, one beyond the column you're using.
Click on R3C5, making it the current cell. Then select Paste
Function from the Edit menu. Move the pointer to AVERAGE() and
click. Click OK to indicate your selection. Your choice appears in
both the current cell and in the formula bar above. To tell
Multiplan that you want to find the averages for Row 3, move the
pointer to R3C4, click and hold the mouse button, then drag from
R3C4 to R3C2. Release the button.
The formula has been automatically built for you in the formula bar. Press Enter and the calculation is placed in the current
cell. Since all three months have the same totals for that category
($2,000), there's no change. But now that the formula has been
created, you can copy it and use the Fill Down function from the
Edit menu to calculate the rest of the averages.
With R3CS as the current cell, select Copy from the Edit
menu. Multiplan makes a copy and places it in the Clipboard.
Click on the current cell and drag the pointer down until all the
cells in Column 5 from Row 3 to Row 13 are selected. Choose Fill
Down, and Multiplan computes the averages. If the averages don't
appear in dollar form, choose Dollar from the Format menu.
Figure 2-15. Expense Averages
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Printing
Printing your worksheets with Multiplan is a snap. By choosing
the Print option on the File menu, you can print out the entire
worksheet (all the cells with information), or you can print just a
portion of it.
If you don't wish to print the entire worksheet, drag the
pointer over the cells you do want to select. This can include anything on the worksheet, whether it's on the screen or not. Simply
keep dragging the pointer and Multiplan will bring the other cells
into view. Then choose the Print Selection Only option in the Print
window.
In later chapters, you'll learn many more ways to use
Multiplan to simplify complex calculations. You'll quickly find that
the range of what you can accomplish will increase without any
special abilities or knowledge of mathematics. Multiplan takes care
of it all for you.
As with Microsoft Word, Multiplan comes with a list of menu
definitions built into the About Multiplan feature of the Apple
menu. Take a few minutes before going on to call up this feature
and familiarize yourself with the various menus.

Microsoft File
If you have information to organize-names, addresses, business
accounts, payroll files, telephone numbers, inventory lists, client
contacts-File lets you record, search, sort, and report them
quickly and in a variety of ways. You can also insert that information into your documents with Word, make mailing lists and labels, create charts and graphs with Chart, incorporate data from
File into Multiplan and vice versa, and even customize files to
your own particular specifications.
The power of File lies in its great versatility. Like the card
and paper files you've probably already used, all the information
can be organized as you need it, whether alphabetically, chronologically, topically, or in any other way. With File, you create
records which are just like the pieces of paper or cards on which
you now keep information. Each piece of information in these
records is called a field.
But rather than having all of this data in static form-on
pieces of paper which are cumbersome to change-File gives you
a dynamic information management system. After you have set
up your file forms once, you can manipulate the information at
will. All with a few clicks of the mouse.
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Figure 2-16. Microsoft File

First Session-File
As with the other Microsoft programs,
turn on the computer and insert the File
disk. After several seconds you'll see the
Macintosh desktop with the File icon and
the Trashcan. But there's also a File.Help
icon with a question mark in its center.
File.Help contains what you would expect from its title,
approximately 20 different categories of File's procedures and
functions. As you become familiar with the program, these
explanations and reminders can quickly refresh your memory on
specific topics without your having to consult the File manual.
After this first session, take some time to return to File.Help
and browse through the menu of categories. Some of the topics
covered will be explained in more detail later in this book. You
may also receive help by moving the pointer to the function you
need help with and then simultaneously pressing the Command
key ( 8€} and the question mark.
For now, double-click on the File Master icon to bring up the
desktop. Then click twice on the File icon to get started. A window opens, asking you to name a new data file or to select a file
you've previously created.
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There are two differences between File and the other Microsoft
programs which you'll notice immediately. First, File asks you to
name your data file before you start rather than when you begin to
save your work. That brings up the second difference. Rather than
having to save your work periodically, File automatically saves your
input as you enter it.
Let's create a simple patient information list for a dentist's office. Type the words Patient Information. Then either move the
pointer to the New box and click or press the Enter key to register
the information.
The screen will go blank for a few seconds, and then you'll see
two windows appear, the top one called Patient Information and the
bottom labeled Form. It's within the Form window that you'll create
a specific structure for the data file you're building. In File, before
you enter any data, you must construct the form in which it will be
recorded, recalled, and manipulated.
Figure 2-17. Form Window
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Form

As you create the form, you'll decide whether each of the
fields in your data records will contain text, numbers, dates, or
pictures. The vertical insertion bar rests in a rectangle within the
Form window. This is the place in which you will type the names
for individual fields in File .
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Start by typing Last.N ame, leaving a period but no spaces between the words. Field names are more manageable in File when
they appear as one word. Now press the Return key.
File presents a dialog box asking you whether the information
you'll enter in this field is to be Text, Number, Date, or Picture.
Since this category of information is to be all text, click the OK
box. File automatically saves this information. Another field box
for a new entry has appeared. Type First.Name and press Return.
Click OK again to indicate a text category. If a particular data file
category is going to be text, you can simply press the Return key
twice to indicate that, rather than having to wait for the dialog box.
In the next new field box, type Telephone and enter this as
text also. Be sure to choose the information type carefully as you
build your form. Once chosen, you cannot go back to the form to
change it. The next category will be Address, a text field, followed by Next.Appoint. This is to be a Date field. Finally, type
Special.Notes, a text field which will contain patient information
and reminders. (Notice that the information in the Form window
scrolls to the left to make room for your additional categories of
information.)
List Helper
So far, you've been creating a data file form with the help of a
hidden but powerful function called List Helper. If you select the
Form menu at the top of the screen, you'll see that List Helper is
already checked. File automatically begins with that feature activated as a way to make your initial entry of information easier.
List Helper formats your data in columns which are easy to
see and work with. If List Helper is turned. off, you can create
more complex, personalized forms for your office's particular
needs. Later, after you've mastered the basics of File, you'll see
how to create these forms without List Helper.
Let's enter the first data into your Patient Information file.
Close the Form window for the moment by moving the pointer to
the box at the extreme left of the Form line and clicking the mouse
button. Or you can click the Patient Information line to activate
that window on top of the Form window.
Now enter the following patient information for the first line
of your data file. The insertion point begins at the left, under the
Last.Name category. Type Adams and press Return. The insertion
point jumps to the First.Name category. Type Samuel, then press
Return. Continue by entering 555-1209 for Telephone and 123
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Franklin Street for Address. You'll notice that the address you've
typed won't fit completely in its window. Don't worry about that
right now. You'll enlarge those windows in just a moment.
Continue by typing 5-28-86 in the Next.Appoint block. Press
Return and watch as File's List Helper automatically changes the
form to May 28, 1986. Finally, enter the note Rec. wisdom tooth
extract., a note to indicate that the dentist has previously recommended that a wisdom tooth be pulled.
When you press Return, the data file insertion point jumps
back to the left margin, ready for a new entry under Last.Name. In
the lower-left comer of your screen you'll also see two numbers
separated by a slash: 1/1. The first number indicates how many
records are in the window at the present time, while the second
indicates the total number of records in the data file itself.
Before entering the remaining patient records, you'll want to
adjust the width and possibly the depth of a couple of fields.
Using the horizontal scroll bar, move the Samuel Adams record until you can see both the Address and Special.Notes categories. Both
these boxes should be enlarged since they're more likely torequire the most room for data. Move the mouse pointer to the
Form menu, then click on the first item, Show Form. The Form window opens below your Patient Information data file. Be sure the
Address and Special.Notes categories are in view, this time on the
Form window. Move the pointer to the vertical divider between
the Address label and the N ext.Appoint label. The pointer will
change to a vertical bar with left and right pointers. Click and
hold the mouse button, then drag the bar to the right about a half
inch. As soon as you release the button, the margin enlarges on
the Form window and then automatically does the same thing in
your data file. Address should now be wide enough to contain 123
Franklin Street without cutting off any of the information.
To give yourself some working room, move the right margin
of the Address label in the Form window another quarter-inch
right in case later addresses are even longer. You can change the
margins at any time while working with your data files. File also
gives you the ability to have more than one line in a field by
dragging the bottom line downward.
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In the Form window, move the pointer to the bottom line in
the form you've created. The pointer will change to a horizontal
line with up and down arrows. Click and hold the mouse button
while you pull the pointer downward. The entire horizontal line
moves down, giving you a larger workspace. Pull down the line
until the vertical space within each box is about the same size as
another line of type. Then release the button. The field boxes in
both the Form and Datafile windows enlarge.
Notice what's occurred with the Special.Notes category. The
phrase Rec. wisdom tooth extract. has now changed to two lineswithout any work on your part.
Figure 2-18. Expanding
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Now that these changes have been made, close the Form window. Use the scroll bar to move back to the first data entry point
under Last.Name. In order to demonstrate a couple of File's features, enter the information you see in the figure below, just as
you did for the first patient. When you finish, your screen should
look like Figure 2-19.
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Figure 2-19. Patient Records
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Organization
One of the most important reasons for using a database as simple
and yet as powerful as File is to organize and find information far
faster than was possible under your previous file folder or card
system.
To give you a quick idea of a few of File's abilities, move the
pointer to the Organize menu, click, and then select Sort. A Sort
window appears in the center of your s~reen, with the same field
categories as your data file. Position the pointer underneath the
Last.Name label in the Sort window and click. Immediately, A->Z
appears, indicating that File will sort the last names from A to Z.
Click again, and File will sort the names in reverse order, Z->A.
Click once more and you again have the A->Z sort. Click the
mouse on the Sort option in the window and File will organize
your patient file from Adams to Webster.
Using the horizontal scroll bar, move the records to the left
until you see the Next.Appoint category. Choose Sort again from
the Organize menu. When the window appears, scroll to the right
until you see the Next.Appoint column. Click under that category,
and File presents the option of ordering your files by date from
1->9. Click again for reverse order.
You'll also see the number 2 in a narrow column to the left of
the number sort option. This indicates that the first sort, by
Last.Name, is still in effect. Since you no longer need that, click on
the Clear button. Now click again under Next.Appoint; the 1->9
option appears, this time with a 1 in the narrow column to its left.
Click on Sort, and in a moment the names will be sorted from the
most recent date to the latest date of appointments.
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Obviously, this is but the beginning of what File can do in
the office environment. In Chapter 4, you'll learn how to organize
your files in any form you want without the List Helper. You'll
also see how to easily accomplish complex searches of your database information, to cross-reference information within the data
file, and much more.
Everything you do with File, whether it's a simple address list
or a complex report, can be printed out. Using the Page Setup option in the File menu, you can structure your printed copy in numerous ways. And the Print option will work as easily with File
as it does with Word, Multiplan, and Chart.

Microsoft Chart
Nothing makes complex numeric information easier to understand
than an appropriate chart or similar graphic representation.
Microsoft's Chart creates these graphic forms for you in a variety
of ways.
More than 40 predesigned charts are included, all of which
can be modified by size, shape, line style, pattern, font size, and
other details. You can also add text within your charts anywhere
you wish. And Chart lets you move from one style of chart to another in seconds as you choose just the right graphic form for
your finished product.
Figure 2-20. Microsoft Chart
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Business presentation graphics have become a major component in the operations of many offices. Whether the occasion is a
sales proposal, a departmental report, a letter to stockholders, or
your own planning projections, well-done graphic representations
can make numeric data far easier to understand. With Chart, you
have one of the most sophisticated graphic creation tools
available.
Without having to be either an artist or statistician, you'll be
able to enter data and create charts after just a short introduction
to Chart. You can also insert data from Multiplan worksheets into
Chart forms. And then, if needed, you can transfer your charts
into Word documents.

First Session. Chart

Microsoft Chart

After you've inserted your Chart disk and chosen
the Microsoft Chart icon, two windows appear on
the screen. The smaller of the two is labeled New
Series, and is called the series window. The larger
window is marked Untitled, and is called the
Chart window.

Figure 2-21. Chart Opening Screen
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No matter what you create with Chart, you'll first enter your
data into the series window. When you work with Chart, the three
underlying functions you use are series, categories, and values. A
series is composed of different categories of information. Each
category has a value which corresponds to that category. For example, one category might be the months of the year, and its
corresponding values would be your company's total expenditures
per month.
Let's see how this works. Earlier, you were introduced to
Multiplan, and you created a simple three-month expense report.
The total expenses, by month, were $13,210 (July), $13,211 (August), and $14,300 (September).
Without using the dollar sign ($) or commas, type the July
number, 13210, and press the Enter key. Several things happened
when you entered the information. As soon as you began typing,
Chart created a third window and titled it with the word Series
and the current time of day. The numbers appeared under theY,
or Category, label. And a number 1 also appeared in the
corresponding space beneath the X, or Value, label.
Now enter the August and September numbers, 13211 and
14300, pressing the Enter key after each.
Your screen should look like Figure 2-22.
Figure 2-22. Entering Data
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Move the pointer to the Plot Series box above the numbers
and click. Behind the window in which you're working, you'll see
an Untitled column chart appear. Bring that chart to the front by
clicking the pointer on the Untitled window.
Chart has created a simple column chart covering the three
monthly categories along the horizontal, or X, axis, and the numeric values along the vertical, or Y, axis. The values have been
selected by Chart to be in increments of 200 initially, although
you'll change that in a moment to better show the relationships.
The program has initially labeled the chart with a Series name and
the time of day in which you created it.

Refinements
Now you'll begin to refine the chart, creating a name for this series, adding the names of the months, putting the numbers into
dollar form, and changing the style of chart.
To begin, bring out the Series window in which you typed in
the numbers. You may have to move the Chart window around a
bit to find it. (You can change the size and position of windows at
any time while working with Chart.)
Now move the pointer to the Data menu at the top of the
screen, and click the mouse. Since you're tracking expenses over a
three-month period, drag the pointer to Date and release the button. The window which appears shows the default names Chart
has given to the chart you're working on.
To make changes in this window, note that the Series Name
box is already selected. Simply type Third-Quarter Expenses. Do
not press Return or Enter. Instead, when you've finished typing,
move the pointer to the Category Name box, and select the X there
by clicking and dragging over the box. Type in the word Months.
Do the same thing for the Value Name, selecting it and typing in Totals. Then, after selecting the First Category rectangle, enter the word July. Since you want to show monthly increments
along the X, or Category, axis, move the pointer to the Months
circle and select it. The number 1 in the box at the left shows that
the increments will be one month at a time. Finally, click OK.
The changes in your chart should appear as in Figure 2-23.
(Since you did not designate a year for the months covered, Chart
chose the current year to display along the horizontal axis.)
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Figure 2-23. Third-Quarter Expenses

Third-Ou•rltr Exp•ns•s
14400
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To ch ange the Totals to dollar
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Align
Number Format
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Quarter Expenses, is selected. (It
@ 0o1111r
0 Center
may
be behind the chart itself.)
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Then
position the pointer over the
0 Declmlll
Format
menu, click the mouse butNumber of Decimllls: !2
ton, and drag the pointer to Values
TeHI Before: l
before releasing. The Values winl=========l
TeHt After:
dow will appear.
Choose Dollar under the
OK
) ( Ca n cel
Number Format heading, and then
click OK. The numbers in the chart and in the Series window will
reappear in dollar format.
When you first entered the figures for this graphic representation, Chart automatically set the values to a minimum of $13,200
and a maximum of $14,400, with increments of 200 in between.
To make the chart a bit more readable, you can change the increments and the high -low figures, and then experiment with a
few different styles of charts.
Ualues

,------====::::::
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First, move the pointer to the vertical Y-axis line, then click
and release the button. Two small circles will appear at either end
of the Y-axis, indicating that it's been selected. Select Axis from
the Format menu. The Value Axis window will appear, showing
the relationships which Chart automatically established based on
the figures you entered. Since the Minimum (13200) is already selected, type a new figure, 12800. Move the pointer to Maximum,
and select. Type 15000. Do the same thing with Major Unit, typing
in 400. Skip the Minor Unit and move the pointer to Category Axis
Crosses At:. Select and type in 12800. Click OK and Chart resets all
of the values you altered.
Figure 2-24. Resetting a Chart
li File Edit D11t11 Gillie
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Seeing how your information looks in different types of
charts is remarkably easy with Chart. Move the pointer to the Gallery menu; click and then hold the mouse button. You see seven
basic styles of charts listed. Each of these options has a submenu
of half a dozen different styles. Beyond these basic charts, there
are hundreds of possible variations for you to develop on your
own. Later in the book, you'll learn more about customizing your
own charts for almost any kind of information.
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As you look at the menu, notice that the
Column label has been checked. Chart uses that
form as the default chart with which to automatiBor ...
./Column ...
cally begin after you first enter data .
Line .. .
Drag the pointer down the menu until you
Pie .. .
come
to Line. Release the mouse and Chart offers
Scotter ...
seven different styles of line charts. Chart 1 is
Combinotion ...
preselected, so click the pointer on OK. Now
your data is redrawn into a simple line chart.
Figure 2-25. Line Chart
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Try a pie chart. Go back to the Ga llery menu, click on Pie,
and Chart presents you with six differen t kinds of pie charts. Select number 6 and click OK. Your third-quarter expenses are
quickly changed into a pie showing the percentage of the total expenses which each month equals.
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Figure 2-26. Pie Chart
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Go back to the Gallery menu and experiment with some of
the other styles of charts. Obviously, this is but the first step in
what can be one of the most powerful and creative tools in your
Macintosh library. With practice, you'll be able to customize almost any style of business presentation chart imaginable. And
printing out your charts, or portions of charts, is as easy a process
as it is for the other Microsoft applications . Simply use the Print
feature from the File menu or, to change the appearance of your
page, select the Page Setup option instead.

Apple's MacTerminal
One of the most useful and powerful functions of your Macintosh
is its ability to act as a telecommunications terminal, sending and
receiving information to and from other computers across the
room or across the country by telephone lines. If you need to
transmit a report, a letter, or even the manuscript of a book, the
Macintosh can telecommunicate information faster and more accurately than the swiftest paper transfer. And the same speed applies when you are working with any of the hundreds of online
databases, electronic mail systems, and computer services such as
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Dow Jones News/Retrieval, MCI Mail, CompuServe, The Source,
and others.
Figure 2-27. MacTermlnal Screen
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MacTerminal, a telecommunications software program from
Apple Computer, turns your Macintosh into what is called a
terminal emulator. Simply put, with MacTerminal your computer
mimics the operations of any of three sophisticated computer
terminals-the DEC VT100, the TTY (Teletype), or the IBM 3278.
What this means for your office is that the documents, tables,
charts, files, and programs which you create with Word, Multiplan,
File, and Chart can be sent to other computers. You can also insert
into your documents information of all kinds which you receive
from other computers.
Like the Microsoft programs to which you have been introduced, Apple's MacTerminal is easy to use. Pull-down menus,
icons, and Help screens offer you a wide choice of options without the complex command codes and key sequences required of
many other telecommunications programs.
To get started, all that you need are your Macintosh,
Ma cTerminal, and a modem-a device which modulates outgoing
information from digital data into analog tones which the telephone lines can carry. Another modem, connected to the
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computer to which you are sending data, must receive the information you send and demodulate the analog signals back to digital form. If your office uses several Macintoshes, they may be
linked directly by special cable rather than through telephone
lines. Most offices will not use dedicated lines, however. When
documents or files need to be sent, they will more than likely be
handled via modem.
As you begin, one of the decisions you must make is what
modem to choose. There are numerous modems on the market for
the Macintosh, and more are being introduced every day. Apple
Computer sells two, th~ Apple Modem 300 ($225) and the Apple
Modem 1200 ($495). The numbers-300 and 1200-refer to the
speed with which the respective modems send bits of data. That
is, 300 indicates the modem carries 300 bits per second (bps). A
1200 bps modem carries approximately 1200 bits per second.
Roughly, a 300 bps modem transmits approximately 30 characters
per second, while a 1200 bps modem is four times as fast.
Both the Apple Modem 300 and the Apple Modem 1200 are
intelligent modems. They can be directed to dial numbers for you,
for example, among a number of other options. There are a variety of functions you can change with either modem, although in
many cases you can use them without ever having to alter their
preset features.

Starting Up Mac Terminal
To begin, turn on the Macintosh and insert the MacTerminal disk.
In a moment, the Macintosh desktop will appear with the
MacTerminal icon in the upper-right corner of the screen. Doubleclick on the icon and the MacTerminal desktop opens.
Several different icons will be visible on the desktop. The Apple Cluster Controller and the AppleLine Supervisor icons have to
do with MacTerminal's ability to emulate an IBM 3278 computer
terminal. Consult the MacTerminal manual if you need to use
these special settings. The Mac-to-Mac icon, when selected, lets
your Macintosh communicate with another Macintosh without
changing any of the compatibility options. To get started, doubleclick on the MacTerminal icon on the desktop.
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Figure 2-28. The MacTerminal Desktop
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In a moment, you'll see the familiar
menu bar, containing the usual Apple, File,
and Edit menus. But MacTerminal also provides four other menus, each having to do
with how your Macintosh connects and
communicates with other computers. The
Termlnel .. .
Compatibility .. .
large white area taking up much of the
file Transfer.. .
screen is the terminal window, in which all
An swerback Message ...
of your online communication will be reShow Tab Rul er
corded as you send or receive data. You'll
probably use the Settings and Phone menus most often, establishing the precise configuration you need to communicate with other
computers.
Later, you'll learn the details of setting up your Macintosh,
modem, and terminal software to take advantage of these functions in your office work. You'll be introduced to procedures for
gaining access to the major telecommunications services. And
you'll also be shown how to transfer documents in such applications as Word and Multiplan from your Macintosh to other
computers. For now, let's look briefly at a few of the features
which a sophisticated terminal program like MacTerminal offers.
Dial... ~
Hang Up ...
Wall For Call ...
Phon e Settings ...
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Features
Check the Compatibility Settings under the Settings menu. There
are six functions listed in the window, but for most of your telecommunications work you may have to change only the Baud
Rate. Baud rate is a term generally used to refer to the speed of
the bits (per second) sent or received by your computer, modem,
and terminal software.
Figure 2-29. Compatibility Settings
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As you can see from Figure 2-29, MacTerminal offers 16 different baud rates. Although you're most likely to have a modem
which operates at either 300 or 1200 bps, a growing number of
modem manufacturers are producing units capable of 2400 bps.
The six parameters listed in the window are compatibility features which insure that your Macintosh and the computer with
which it is communicating are correctly matched. The first four
settings-Baud Rate, Bits per Character, Parity, and Handshakehave to do with how you send and receive information. The
remaining two-Connection and Connection Port-indicate how
the Macintosh is connected for communication.
The compatibility settings are preset on the Macintosh to be
matched with most of the large communication services. Depending on your telecommunications needs, you may have to alter
some of these parameters. Your MacTerminal manual will have
information to help you on this, and the computer system with
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which you'll be transmitting or receiving will usually have its set
parameters for you to match. If you currently have a modem,
change the baud rate setting to the number which matches the
speed of your modem by clicking on the appropriate circle.
Then click OK on the Compatibility Settings. When that window disappears, move the pointer back to Settings and select
Terminal. The Terminal Settings window becomes visible. For most
of your communications with online services, the preset options
you see are most likely correct.
Figure 2·30. Terminal Settings Window
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As your experience with telecommunications increases, so too
will your knowledge of many of the options you see in the Terminal Settings window in Figure 2-30. You don't have to worry
about the relative complexity of some of the settings right now.
For the most part, MacTerminal's options are preset for the most
common computer-to-computer communication. Click OK to remove the window.
Let's just take a quick walk through a typical log-on procedure for CompuServe, one of the major telecommunications services available to computer users. These services offer financial
news, games, computer shopping, banking at home, and many
more such options. Most of the manufacturers of modems and
telecommunications software offer free memberships and a limited
amount of free access time to CompuServe and other services
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when you buy their products. When you join one of the services,
you're given a user identification number and a private password
for your personal account. You're normally charged on a monthly
basis for the time you're logged onto the system.
With your modem connected and turned on, move the
pointer onscreen to the Phone menu. Drag down to Phone Settings.
In this example, you'll type the CompuServe phone number
into the long rectangular box. CompuServe and a few of the other
large services are accessed in many metropolitan areas through a
local telephone exchange. Once you have typed in the telephone
number, move the pointer to Tone, Pulse, or Mixed, depending on
the type of telephone you're using. Choose the number of rings
for the system-say, 3 or 4-and indicate your modem type. Then
click OK.
At this point, the system is ready to connect to CompuServe.
Move the pointer to the Phone menu and select Dial. A window
appears which indicates that your modem is dialing the telephone
number. A moment later, another message appears in the window, informing you that a connection has been established. At
this point, CompuServe will ask you to indicate the name of the
host computer you're calling. In this case, type CIS, which stands
for CompuServe Information Service. You will then be asked for
your ID and for your password as the key to entering this system.
As you'll see in Chapter 8, using MacTerminal to send andreceive documents and files is an easy process. You achieve real
effectiveness for your MacOffice when you are able to use all of
the Microsoft products together with MacTerminal to reach virtually anywhere in the world.
In the coming chapters, you'll find that the MacOffice concept
is as easy to use, efficient, and powerful as the Macintosh itself.
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Producing Form Letters with
Microsoft Word
Ario n R. Levitan

Microsoft Word for the Macintosh is an
extremely powerful writing program.
While power and complexity usually
go hand in hand in computer-based
word processing, the Macintosh user
interface makes much of Word's power
accessible to novice computer users.
This chapter will first familiarize you with entering, selecting,
and manipulating text, and it will then illustrate how to build custom form letters. While we'll review many of the features available in Word, this is not intended to be a reference guide, nor is it
a substitute for the Microsoft Word manual. It's expected that
you're familiar with the basics of using pull-down menus and
scroll bars and generally " mousing around. " The Apple Macintosh
manuals and the " Guided Tour" lessons that came with your system cover these areas in depth.
Microsoft recommends that you use a copy of the Word Master disk rather than the original. Before you begin, make a working copy of your Word Master disk by dragging the Master disk
icon to the icon of a blank disk. (See Chapter 1 for complete
instructions on making copies of entire disks.) Do not use the Disk
Copy utility that comes on the Macintosh System Disk to make a
working copy of Word.

Starting Word
• Turn on the power switch on the back of your Macintosh.
• Insert your working copy of the Microsoft Word disk.
• When the desktop appears, start Word by double-clicking the
icon labeled Microsoft Word.
• Upon startup, the working disk will be ejected and you'll be
prompted to insert the Word Master disk. (This happens even if
you're using a dual-drive system.) Your Macintosh will read the
disk identification, eject the Master disk, and tell you to insert
the copy again.
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Fig ure 3-1 . Desktop Startup
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A blank text entry screen appears on your Macintosh's screen,
labeled Untitled. You'll give the documents you create a name
when they're saved.
The blinking vertical line at the upper-left corner of the
screen is called the insertion point. The diamond-shaped character
after it is an end mark. The end mark shows where your document
currently ends.
Figure 3-2. Word Startup Screen
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Move the mouse around a bit. When the mouse pointer is
outside the white text entry area, it's the familiar left-pointing arrow of the Finder. It assumes a different shape, called the insertion
!-beam within the text entry area.
Move the insertion 1-beam toward the left of the screen. Slow
up as you approach the left edge of the screen and watch the 1beam carefully. The very first column of each line in the text area
cannot have characters en tered into it. This area is called the
selection bar. When you move the mouse into the selection bar, it
changes to a right-pointing arrow.
82

Chapter 3

At the right and bottom are scroll bars. Clicking and holding
on the arrows at either end of the bars allows you to move up,
down, left, or right within documents.

Getting Help
There are two ways to invoke the built-in help feature of Word.
One way is to access the help file by
-···-··-·--······----····--······-···-·····--.............. choosing the About Microsoft Word command
from the pull-down Apple menu at the top
Choose Printer
Scrapbook
left
of your screen. You'll be presented with
Alarm Clock
a dialog box that will allow you to select a
Note Pad
Calculator
topic from a list.
Key Caps
Control Panel
Puzzle

Figure 3-3. About Word
Getting Help
Opening WindO'-'S
Closing Windo'w'S & Quitting
S8v1 ng Documents
Printing

Word uersion 1.00
January 22, 1985
® 1985 Microsoft Corp.

Editing Documents
Using Glossaries
Shwi ng The Ruler
Shwing S ial Characters

100 % free memory

You can also ask for help on particular commands in a more
direct manner. Hold down the Command key ( 88) and press the
question mark (?) key. The mouse cursor will become a large
question mark.
Move the question mark to the pull-down menu command
that you want information about and select that command. Instead of the command executing, a Help window containing information about the selected command will open.
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Figure 3-4. Help Window
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You can close Help windows by clicking the Cancel button
within the window.

Entering Text
Let's begin by entering the text of a clause from a rental agreement for an apartment. Type the paragraph as it appears below.
The text will appear to the left of the blinking insertion point as
you type. If you make any mistakes, use the Backspace key to
erase to the left. The characters will disappear as the insertion
point moves back over them.
Figure 3-5. Text on Screen

a
~0

File

Edit

Seorch

Chorocter Porogroph

Doc um ent

Untitled

Lessee agrees not to keep any animals other than birds weighing less
than one (I) pound each. No more than two birds may be kept. Failure to
abide by this clause shall be deemed grounds for eviction, with all security
deposits forfe it to lessor.
5).

lo
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Don't hit the Return key until the very end of the paragraph.
Unlike a typewriter, there's no need for you to consciously move
the insertion point to the beginning of the next line when the current line is almost full. You may notice that Word w ill also
dynamically reformat, or wrap, the text you type in. As you approach the end of a line, Word moves the word you're typing to
the beginning of the next line if it's too large to fit at the end of
the current line.

Inserting Text
Let's add some provisions to this rental clause.
• Move the insertion 1-beam just after the word birds in the first
sentence and click the mouse button.
• Hit the spacebar and then type andjor fish.
• Move the insertion 1-beam just after the word security in the
third sentence and click the button.
• Hit the spacebar and then type and cleaning.
• Move the insertion 1-beam to the right of the period that ends
the paragraph and click.
• Hit the spacebar and type Lessee will be responsible for any
medical fees necessitated by removal of animals.
Figure 3-6. Finished, Unformatted Text

*
~0

File

Edit

Search

Chara cter

Paragraph

Document

clawsunf

5 ). Lessee agrees not to keep any animals other than birds and/or !ish
weighing less than one (I) pound each. No m ore than two birds may be
kept Failure to abide by this clause shall be deemed grounds for eviction,
with all security and cleaning deposits forfeit to lessor . Lessee will be
responsible for a ny medical fees necessitated by removal of animals.

<>

The Undo Command
The Undo command Jets you reverse your last action, which in
this case was entering a sentence. Suppose you decided that the
last sentence typed was not really necessary.
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Move the mouse pointer up to the Edit menu
and select Undo Typing. The sentence you just
typed will vanish.
rut
Move the mouse pointer back up to the Edit
l.llllll
PttS1<!
:•:lt
menu again and look at the selections. The selecI h~ IH
:•:11
tion which used to read Undo Typing has become
Show Cllpbo11rd
Show Glossory
Redo Typing. Select this option and the sentence
is
restored.
Show Ruler XR
MY
Show 'I
Many selections available on the pull-down
menus have keyboard equivalents if you don't
want to use the mouse. Take another look at the Undo Typing
selection. Its keyboard equivalent is the Command-Z key sequence (hold down the Command key while pressing the Z key).
Try the Command-Z combination. The sentence disappears once
again. Hit Command-Zone more time and your sentence is back.

Selecting Text
When you want to delete, move, copy, or change the appearance
of text, you must select the text you're going to work with. There
are several ways to select text. The more familiar you become
with the various methods, the more productive your time with
Word will be. Selected text appears as white letters on a black
background, as in Figure 3-7.
Figure 3-7. A Highlighted Paragraph
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• Select a character-Click to the left or right of a character and
drag across it.
• Select a word-Position the insertion 1-beam anywhere within a
word and double-click.
• Select a line-Move the mouse pointer into the selection bar
next to th e line and click once.
• Select a sentence-Press the Command key and click anywhere
within the sentence.
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• Select a paragraph-Move the mouse pointer into the selection
bar next to any line in the paragraph and double-click.
• Select a block of text-Position the insertion I-beam at the
beginning of the block and click. Then (a) hold the mouse button
down and drag to the end of the block, or (b) move the insertion
I-beam to the end of the block, hold down the Shift key, and
click.
• Select the entire document-Move the mouse pointer into the
selection bar, depress the Command key, and click.
Take some time now to practice selecting text in your sample
paragraph using these different methods. If you accidentally alter
the text, use the Undo command to reverse the unwanted change.

Operating on Selected Text
Once text has been selected, you can manipulate it. The most
common operations are deleting, moving, copying, and
formatting.
Deleting Text
You've already used the Backspace key to delete characters one at
a time. The Backspace key will also delete any block of selected
text. Try it by selecting a word, sentence, or paragraph and then
press the Backspace key once. The selected block vanishes. You
can also use Cut from the Edit menu (or Command-X) to accomplish the same thing.
Selected text may also be replaced by simply
Redo Typing xz
typing over the selection. Select the word fish in
the first sentence of the example you created earcopy
xc
lier by placing the insertion 1-beam anywhere
~:~"~;~
:~
within the word and double-clicking. Then type
show cupboard
gorillas (or any other animal of your choice) .
. . . ~.~-~-~--~-~-~-~-~~-~~.......... The selected text will be replaced by what you
show Ruler xR
type. Use the Undo Typing command to change
Show '~~
xv
the word back to J'1ish.
Preferences...
Moving Text
There's a difference between using the Backspace key and Cut.
The latter places a copy of the cut text into the Macintosh's Clipboard. The Clipboard can be used as a temporary holding area for
text that you want to paste elsewhere in your document. This allows you to move blocks of text easily. Try the following:
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Undo Copy

agz

rut

:)(:U

[O(Ut

:)(:[

•

..

t:h~IU

:)(:H

Show Clipboard
Show Glossary
Show Ruler agn
Show en
XY
Preferences ...

Select the first sentence of the paragraph in
Figure 3-6 by positioning the insertion bar anywhere within the sentence, holding down the
Command key, and clicking once. Remove the
sentence from the paragraph using Cut from the
Edit menu. Move the insertion 1-beam to the right
of the period that ends the paragraph and click.
Select Paste from the Edit menu (or press Command-V). The sentence which began the paragraph is now at the end.

Copying Text
xz
Cut

XH

Paste
XU
Clear
XB
Show Clipboard
Show Glossary
Show Ruler XR
Show en
!leY
Preferences ...

Select the sentence you just pasted in by using the
Command-dick procedure again. Choose Copy
from the Edit menu (or Command-C). A copy of
the selected text is placed in the Clipboard, leaving the original text intact. Move the insertion Ibeam to the beginning of the paragraph, click, and
use Paste to place a copy of the sentence now in
the Clipboard back at the front of the paragraph.
Delete the last sentence in the paragraph by
selecting it and hitting the Backspace key.

Formatting Text
Let's change the appearance of the text.
Move the insertion 1-beam anywhere within
Normal
the paragraph and click. Use the mouse to pull
-~~-~-;~·-··-·down the Paragraph menu and select Formats (or
centered
press Command-M). You'll see a dialog box. The
~~~~:ned
small box labeled Left Indent will be highlighted.
........................................

Type .5.

Move the mouse pointer to the center of the
small box labeled Right Indent and double-dick.
-~~~~~·······-......
······-· The box will become highlighted. Type .5 again.
--··---~--------··-·· ··
Move the pointer to the number 0 in the
Tabs...
xt
small box labeled Space Before and double-dick.
After the 0 becomes highlighted, type 1.
-~'Single space

Double Space
Open space
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Figure 3·8. Paragraph Formats Dialog Window
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Move the pointer to the button labeled OK and click. The
paragraph is reformatted with half-inch margins on either side
and with a blank line added before the paragraph.
Select the entire paragraph by moving the mouse cursor anywhere in the selection bar to the left of the text and double-click.
What's a contract without fine print? Select
Plain teHt
the Formats (Command-D) command from the
Bold
Character menu. You'll see another dialog box.
/181/C
Underline
Point the mouse to the small box under the words
mm~
Font Size and double-click. Type 10, move the
OO!I!lt!l(!)l!!l
Smllll Cli PS
mouse pointer to the OK button, and click. The
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entire paragraph changes to a smaller type size.
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lotmdh ...
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Figure 3·9.
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Saving Documents
New
Open ...
Close
Saue

xN

=~

xs

Save n._ ...
Page Setup ... ~
Print...
KP
Print Merge .. .
Printer Setup ...
KQ
Quit

Let's save this paragraph for later use. Select the
Save As command from the File menu. The Save
Current Document dialog box will appear. Type in
petclaws as the document name and click on the
OK button. The lease clause is saved to disk.

Figure 3-1 0. Save As Dialog Window
Saue Current Document as:

lpetclaw~

0

TeHt Only

Book Stuff
Saue

0

Make Backup

~)

!(

Eject

( Cancel ) j ( Drlue

Choose the Close (Command-W) command from the File
menu. The Word text entry screen disappears.
Select New (Command-N) from the File menu. A new, untitled document screen will be presented.

Building a Form Letter
In the following exercise we'll write a business letter to one of our
mythical tenants, then modify that letter so that we can send out
multiple customized versions to different tenants.
An advantage of Word's powerful formatting capabilities is
that you can defer decisions about the final appearance of documents until the written text is completed. You can focus all of
your attention on the content and meaning of the text, not on
how it looks. You don't need to interrupt your thoughts with constant decisions about word placement and spacing. While many
users may find this method disconcerting at first, our example will
illustrate the power of this approach.
Type the following text exactly as it appears below. <RET>
indicates where you should hit the Return key.
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<RET>
Conan & Cthulu Management Corp.<RET>
12709 Arkham Lane, Suite 200<RET>
Lovecraft, Massachusetts 44567 <RET>
June 19, 1985<RET>
Gregg Keizer<RET>
91927 Plynth<RET>
Larchmont, MA 02123<RET>
Mr. Keizer,<RET>
It has been brought to our attention that you are harboring an unauthorized pet in your apartment. Apparently your wombat has
been making quite a bit of noise late at night and has been
disturbing a number of the other residents of Heavy Metal
City.<RET>
We realize that the wombat has a long and honorable history in
its dealings with mankind. We have no doubt that your particular
wombat is both well mannered and considerate.<RET>
Unfortunately, Mr. Keizer, there can also be little doubt that harboring a wombat in your apartment is specifically forbidden by
the lease you signed upon moving into your apartment.<RET>
Please remove your pet within ten days of receipt of this letter.
Failure to do so may result in the loss of your lease.<RET>
We value you as a tenant and would hate to cancel your
lease.<RET>
Sincerely yours,<RET>
Irving Conan<RET>
General Manager<RET>

Formatting the Text
Using the scroll bar at the right of your screen, return to the top
of the document.
Select the line that begins Conan ... by moving the mouse
pointer to the selection bar, just left of the line, and then clicking.
Choose Formats from the Character menu. The box labeled Font
Size will already be highlighted. Type 14. Then move the mouse
pointer to the small box labeled Shadow and click. Click OK. Voila!
You've just changed the appearance of the firm's name.
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Figure 3-11. Character Formats Dialog Window
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Now let's position the letterhead: Select all three lines of
letterhead text by positioning the mouse in the selection bar to the
left of the first line, holding down the mouse button, and dragging downward until all three lines have been selected.
Choose Centered from the Paragraph menu. The letterhead
will be centered at the top of the document (Figure 3-12).
Let's move the date over to the right and open up some lines
before and after it.
• Select the line of text which contains the date and then select
Formats from the Paragraph menu.
• Double-click the zero in the Space Before box and type 2.
• Double-click the zero in the Space After box and type 3.
• Click the circle labeled Right in the box at the lower-left portion
of the dialog box.
• Click OK. The date will be placed at the right of your documents
and two and three blank lines have been inserted before and
after the date, respectively.
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Figure 3-12. Formatted Letterhead
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june 19, 1985
Gregg Keizer
91927Piynth
Larchmont, MA 02 123
Mr. Keizer,
It has been brought to our attention that you are harboring an unauthorized
pet In your apartment. Apparently your wombat has been making quite a
bit of noise late at night and has been disturbing a number of the other
residents of Heavy Metal City.
We realize that the wombat has a long and honorable history in its dealings
with mankind. We have no doubt that your particular wombat is both well
mannered and considerate.
Unfortunately, Mr. Keizer, there can also be little doubt that harboring a
w
tin ur a rtment is
ific
b dden b the lease u
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Figure 3-13. Filled-In Formats Window
4i File Edit Sea r ch Char ac t er Paragr aph Docum ent
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It has

petin~~~~~~~~~~~~~~~~~~~~~
bit or noise late at night and has been disturbing a number or the other
residents or Heavy Metal City.
We realize that the wombat has a long and honorable history in its dealings
with mankind. We have no doubt that your particular wombat is both well
mannered and considerate.
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Let's open up some spacing between the paragraphs of the
body of the form letter.
• Position the mouse pointer over the selection bar, directly to the
left of the salutation, Mr. Keizer.
Hold down the mouse button and drag downward toward
the bottom of the letter. The text will scroll when the mouse hits
the bottom edge. Keeping the mouse button pressed allows the
scrolling to continue. When you see the closing (Sincerely yours),
move the pointer above the line and adjust its position until the
last line highlighted is Sincerely yours. Release the mouse button.
• Choose Open Space from the Paragraph menu. A blank line will
be inserted before each selected paragraph.
The first line of each paragraph in the body of the letter
should be indented.
You can select blocks of paragraphs by moving the mouse
cursor from the end of the document to the beginning as well. Position the mouse cursor over the selection bar, directly to the left
of the line that begins We value you as a tenant... and click, holding the mouse button down. The text will scroll when the mouse
hits the top edge. When you see the salutation, move the mouse
pointer above the line and adjust its position until the last line
highlighted is the one that begins It has been brought to our attention. Release the mouse button.
Select Formats from the Paragraph menu. Double-click the box
labeled First Line and then type .5. Click OK and the first line of
all the selected paragraphs will be indented half an inch.
Move back to the bottom of the letter so that you can finish
up by formatting the closing. Select the last three lines and select
Formats from the Paragraph menu once again. If you feel like
experimenting, call it with the Command-M key combination
rather than the pull-down menu.
The insertion cursor will already be positioned at the Left Indent box. Type 3 and hit Return. The closing will be moved to the
right.
Let's open up some space for Irving's signature. Rather than
formatting, let's do it the lazy way. Position the insertion 1-beam
just to the left of the I in Irving and click. Then hit Return three
times.
That's it! Your letter is finished. Save it for posterity. Select
Save As from the File menu. When the dialog box appears, type
PetLetter and click OK or simply hit Return. Word will save the
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document under the name you just gave it. The mouse pointer
will turn into a wristwatch and won't change back to its normal
form until the save is finished. After the save is complete, the
page number displayed in the lower-left corner will be temporarily replaced with the number of characters in the document.
Figure 3-14. Finished Letter

Oeet ls@aillil-\@&rp.
12709 Arkham Lane, SUite 200
Lovecratt, Massachusetts 44567
june 19, 1985
Gregg KeiZer

91927 Plyntll
Larchmont, MA 0212 3
Mr. Keizer,

It has been brought to our attention that you are harboring an
unauthoriZed pet in your apartment. Apparently your wombat has l>Hn
making quite a bit of noise late at night and has been disturbing a number of
the other residents of Heavy Metal City.
We realize that the wombat has a long and honorable history in its
dealings with mankind. We have no doubt that your particular wombat is
both well mannered and considerate.
Unfortunately, Mr. KeiZer, there can also be liWe doubt that harboring
a wombat in your apartment is specifically forbidden by the lease you
signed upon moving into your apartment.
Please remove your pet within ten days of receipt of this letter.
Failure to do so may result in the toss of your lease.
We value you as a tenant and would hate to cancel your lease.
Sincerely yours,

~~
Irving Conan
General Manager
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Printing
Let's print the letter:
First, make sure your printer is loaded with paper and its
power is on. Select the Print command (Command-P) from the
File menu.
You'll see the dialog box shown in Figure 3-15. Make sure
that all settings are as shown and click OK. A copy of the letter
will be printed. Sit back and admire your work for a few moments
before you move on. You deserve a break.
Figure 3-15. Print Dialog Window
lmageWriter (Standard or Wide)
Quality:
0 High
® Standard
Page Range: ® All
0 From:
Copies:
Paper Feed:

0

0

®Continuous

0

ILi:[lJ
0

Draft
To:

0

~

(Cancel )

Cut Sheet

Form Letters
Writing the "renegade pet" letter was not particularly difficult, but
there are likely to be times when many similar versions of this letter will be required to send to different people. You could create a
series of slightly different versions of the letter and print each one
at a time. Depending on the number of copies involved, this could
be both labor intensive and a dead waste of time.
An easier way to accomplish this task is to use the form letter
capabilities of Microsoft Word. This involves using a main, or form,
document (which is merged using the Print Merge function) with a
merge document, which contains the information that will vary
from one version of the letter to the next.
This merge process is heavily used today by large businesses.
The most commonly encountered example is unsolicited promotional material, or "junk mail," as it is referred to by nonmarketing types.
Whatever we call it, such mail typically contains repeated references to a person's name and/or place of residence. It can also
contain text that is inserted only if a certain condition is true.
In the following example we'll create a separate merge document, modify our letter to become a form document, and then
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combine the two to create our own customized form letters.
In most respects a form document is like any other Word
document. It differs from regular documents in that it contains
marked positions and special instructions which allow Word to insert information while printing.
These marked positions are called fie lds. Each field represents
a group of characters that relate to one item of information. While
the field names can be virtually anything you choose, it's best to
select names which directly relate to the meaning of the characters
to be inserted at that point.
These field names will relate directly to collections of information contained in the merge document. The merge document
will hold a group of fields, or records, for each individual letter
we wish to print. Don' t worry if this sounds somewhat confusing.
It's not as a complicated as it seems.
Let's examine the form letter in Figure 3-14 and pick out the
specific items that may differ from letter to letter in an attempt to
categorize them.
Figure 3-16. Beginning of Letter with Items Boxed
raph

Document

@gMsBt.. ~~~ ~\\. ~12709 Arl<ham Lane, Suite 200
Lovecraft, Massachusetts 44567

,.,..---,....,.....-,....,...,..., i

·i

!June 19, 19851 i I'
I
!.

I

1.!

It has been brought to our attention that you are harboring an
unauthorized pet in your apartment. Apparently yourlwombatlhas been
making quite a bit of noise late at
and has been disturbing a number of
the other residents of
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Items
Category
June 19, 1985
Date
Mr. Gregg Keizer
Title, first name, last name
91927 Plynth, Larchmont, MA 02123 Address
wombat
Type of pet
Heavy Metal City
Housing development

We'll assume that all the letters will be from Conan & Cthulu
Management Corporation and that Irving will sign all the letters.

Merge File
Now you need a merge file to contain information on all tenants
who are harboring illegal pets.
Select New from the File menu. The letter will disappear for
the time being and a new, empty screen labeled Untitled will appear. Don't worry about the old letter. It's still around (albeit
incommunicado).
Since the number of spaces and return
xz characters between the items in the file will affect the final appearance of the document, select
I
Show
Paragraph (Command-Y) from the Edit
I OPI.l
Paste
menu (it actually says Show, followed by a syml. li.'ur
:•:11
bol which looks something like a backward P).
Show Clipboar d
Show Glossary
Drag toward the top of the letter. This makes visible
certain formatting characters which are norShow Rul
XR
mally
not seen; as a result entry errors in the
Pre ference s ...
merge file will be less likely.
Type in the file exactly as it appears in Figure 3-17.
II~

Figure 3· 17. Merge File with Show Paragraph On
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• titl&,·firs tnam&,.lastname ,.address,.place,·pet<J
Mr.,· Ia n,.Butterworth,·"2 3 5 I I.Northwestern.F2 19 •
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Mr .,. Thomas,.cunningham,. "2 3 160 .B&verly .• 2 0 I•
Augu stin,.MA. 02 132 ··,.Beverly .Arms,.cat<J
Ms.,.Mira,. Levitan •. "4 38 7 4· Sinai.Place •
Marchant,. MA.02 13 1",.Ger ber.T&rrac&,.gerbil<ll
Mr.,.Gregg,Keizer,."91927.Piynth•
Larchmont, MA. 02 123"",.Heavy .Metai-City,.wombat<J
¢
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The paragraph markers (those backward looking P's) are inserted by simply hitting Return, spaces are represented by small
dots between characters, and the large dots are called new-line indicators. New-line indicators are inserted by holding down the
Shift key and hitting Return.
The merge file is composed of records, and each record ends
with a Return (a paragraph marker). The first record of the file is
special and is called the header record. This record lists the field
names we've chosen in the order in which the information will
appear in subsequent data records.
Note that both the field names of the header record and the
field data within records are separated by commas. The records
that follow the header record contain the information that will be
inserted in the printed form letters. Each data record contains the
information that will be inserted in the form document to create a
unique version of the letter. Notice that the field names were chosen to describe their actual contents. Each data record contains the
first name, last name, address, place (name of the housing
development), and kind of pet involved.
The new-line indicators are necessary because we want the
information contained in the address field to be printed as multiple
lines. If you were to end the street address line with a Return,
Word's merge utility would interpret the Return character as the
end of a data record and would not be able to find any data to assign to the place and pet fields. In case you've been keeping track,
don't worry about a field for the date. We'll take care of that in
just a bit.
When you're sure everything has been entered correctly, select Hide Paragraph from the Edit menu. The special characters
will disappear from view-rest assured that they're still there.
Use the Save As command from the File menu to save the
document you've created. Name the file PetLetter. After saving,
select Close from the Edit menu. The original letter reappears.

Form Document
Now we'll tum the orginalletter into a form document by making
some changes, namely, all occurrences of the following:
Mr.
Gregg
Keizer
91927 Plynth Larchmont, MA 02123
Heavy Metal City
wombat

to
to
to
to
to
to

<<title»
« firstname >>
<<lastname>>
«address»
<<place»
«pet»
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Note: The « and » are international quotation marks used
within a form document to indicate the beginning and end of a
field name. They are not formed by using the less-than ( <) and
greater-than (>) keys on the Macintosh keyboard. The start-offield-name character ( «) is made by holding down the Option
key and pressing the back slash key (located right above the Return key). The end-of-field-name character (») is made by holding down both the Shift and Option keys while hitting back slash.
You may use Word's Change command to change everything
but the address, since it occupies two lines of text.
Let's change all occurrences of wombat to « pet».
Select Change (Command-H) from the Search
menu. The Change dialog box appears. The box laFind ...
beled Find What is highlighted. Type wombat and
Go To ...
double-click the box labeled Change To. Type
« pet» and click on the button labeled Change All. You may continue to make changes by filling in new values in the Find What
and Change To boxes and clicking Change All. When finished, you
can get rid of the Change box by clicking the go-away box (the
small box in the upper-left corner of the dialog box).
Remember to replace the two-line address with « address ».
Figure 3-18. Filled-In Change Box

"

Find What:
Change To:

I

Change

wombat
«pet>~

0Whole Word

0 Match Upper/ Lowercase

I

(nnd NeHt, (Change, then Find) (Change)-•iliTiT•I'illll:ll-

When you're through making these changes, take some time
to carefully inspect your work for errors. When you're sure all the
changes are correct, scroll to the top of the document.
Position the insertion beam anywhere on the line directly
above Conan & Cthulu Management Corp. and click. The insertion
point will appear at the very first character of the line at the left.

The DATA Statement
The very first thing in a form document must be a DATA statement, which tells Word which merge document contains the information it needs to fill in the fields defined within the letter.
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Type « DATA petlist » and hit Return. (Remember to use
the « and » symbols to delineate the beginning and end of the
DATA statement.)
Now let's take care of the date. Type
« SET date = ?What date do you want on the letters?»

and hit Return.
Move the insertion beam just to the right of the 5 in 1985,
hold down the mouse button, and drag to the left until June 30,
1985 is selected and highlighted. Be very careful not to select the
Return character at the end of the date.
Type « date ». The original date has been replaced with a
date field . The SET statement included before the date will prompt
you for the correct date when you print your customized letters.
ASK, IF, and INCLUDE
Let's add one final twist to the letter. We'll use three new form
letter commands that will allow us to print a different version of
the letter for those tenants who have already been warned about
keeping unauthorized pets.
Insert the following line between those containing the DATA
and SET statements. The result should look just like Figure 3-19.
« ASK quoteclaws=?Read « lastname» the riot act?»
Figure 3-19. Top of Document
•
~0

File Edit Search Charac ter Paragraph Document
petform

<<DATA pe tllst;,,
<<ASK quotecl aws~?Read «lastname» tile riot act ?»
«SET date•? Wha t date do you want on tile letters?,
~ijBjlQil ~fl.~.
12709 Arl<.ham Lane, Suite 200
Lovecraft, Massachusetts 44567

@gym.

«firstname, «lastname»,
«address,
<<title» ,<lastname»,
Page 1

:H ..
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Go down to the paragraph that en ds w ith moving into your
apartment. Position the insertion beam directly to the right of the
period that ends the paragraph and click. Insert the following text:
« IF quoteclaws="yes"»«INCLUDE petclaws» You have been
informed of our policy on pets before. We suggest you heed this
warning. « END IF»
It sh ould be formatted so that it looks like what you see in Figure

3-20.
Figure 3-20. Middle of Document

a

File

Edit

Searc h

Character

dealings with mankind . We have no doubt that your particular ccpet>> Is both
well mannered and considerate.
Unfortunately,«tltle» c<lastname», there can also be little doubt
that har boring a «pet>>In your apartment Is specttlcally forbidden by the
lease you signed upon moving into your apartment.
«IF quoteclaws•"yes"»«INCLUDE petdaWS»
You have been informed of our policy on pets before. We suggest you
heed this warn!ng.«ENDIF>~
Please remove your pet within ten days of receipt of this letter.
Failure to do so may result in the loss of your lease.
We value you as a tenant and would hate to cancel your lease.
Sincerely yours,

The additions we've just made to our form document will ask
if each tenant deserves a "second warning" letter. If th e answer to
the question "Read so-and-so the riot act?" is yes, Word will include th e con tract clause that we typed earlier and saved as
petclaws; it will also print a somewhat stern warning after it.
Save your work using Save As from th e File menu. Name th e
document petform.

Print Merge
Let's print this and see wh at the result looks like. The length of
this letter is just over a page. You can change th e top and bottom
margins of the printed documents so that the letter will fit on just
one page .
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While still in the petform document, select Page Setup from
the File menu. An ImageWriter setup box appears. In the Margins
section, enter 0 for both top and bottom margins, then click OK.
Figure 3·21. Page Setup Window
lmageWriter (Standard or Wide)
Paper:
® US Letter
0 R4 Letter
0 US Legal
0 International Fanfold [ cancel )
0 Computer Paper
0 Tall Adjusted 0 Wide
Orientation: ®Tall
Pagination:
® Normal pages 0 No breaks between pages
® None 0 50 percent
Reduction:
Top:

Margins:
,....lo---,1 Left: 11.25"

I

Bottom: 0

Gutter:l._o_"_

__,

IRight:l1.25"

Choose Print Merge from the File menu. You'll be asked if
Butterworth gets "the riot act" (the sterner form of the letter) read
to him. Just to be nice, type No and hit Return.
Figure 3-22. The Butterworth Question
Document

«DATA petlist»
«ASK quoteclawsa?Read «lastnamEh> the riot act?»
«SET
Read Butterworth the riot act1

«firstnamEh> «lastname»,
«address»
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You'll then be prompted to enter the date. You're asked for it
only once during the entire Print Merge session.
Another ImageWriter dialog box appears. Click OK. After a
few moments, the first customized letter will start to print. When
the letter is nearly finished, you'll be asked if the next tenant deserves the "riot act." Type Yes and hit Return. The letter now
printed will be different from the first one. Here are examples of
both types so that you can check your results.
Figure 3-23. The Riot Act Letters

july 19. 1985
Ian Butterworth,
23511 Northwestern F219
Northfield, MA 02 131
Mr. Butterworth,
It has been brought to our attention that you are harboring an
unauthorized pet in your apartment. Apparently your boa constrictor has
been making quite a bit of noise late at night and has been disturbing a
number of the other residents of Quiet oaks.
We realize that the bOa constrictor has a long and honorable history in
its dealings with mankind. We have no doubt that your particular boa
constrictor is both well mannered and considerate.
Unfortunately, Mr. Butterworth, there can also be little doubt that
harboring a boa constrictor in your apartment is spedficatly forbidden by
the lease you signed upon moving into your apartment.

Please remove your pet within ten days of receipt of this letter.
Failure to do so may result in the loss of your lease.
We value you as a tenant and would hate to cancel your lease.
Sincerely yours,

~~~
Irving Conan
General Manager
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Cgup,

it mil18illl'¥'MepmBi @arp.

12709 Afkham Lane, Suite 200
Lovecratt. Massachusetts 44567

July 19, 1985
Thomas Cunningham,
23160 Beverly •20 1
Augustin, MA 02 132

Mr. Cunningham,
It has been brought to our attention tllat you are harboring an
unauthorized pet in your apartment. ApparenUy your cat has been making
quite a bit of noise late at night and has been disturbing a number of the
other residents of Beverly Arms.
We realiZe that the cat has a long and honorable history in its dealings
with mankind. We have no doubt that your particular cat is both well
mannered and considerate.
Unfortunately, Mr. Cunningham, there can also be liWe doubt tllat
harboring a cat in your apartment is specifically forbidden by the lease you
signed upon moving into your apartment.
:)). Lessee euees not to keep any animals other than birds and/or fish
mghing less than one {1) pound each. No more than tw birds may be
kept. failure to abide by this <:lause shell be <leeme<S uoun<Js for
eviction. with ell security and cleaning deposits forfeit to lessor.

You have been informed of our poilcy on pets before. We suggest you
heed this warning.
Please remove your pet within ten days of receipt of this tetter.
Failure to do so may result in the loss of your lease.
We value you as a tenant and would hate to cancel your lease.
Sincerely yours,

~CD'~
Irving Conan
General Manager

Answer yes or no to subsequent "riot act" inquiries as needs
dictate. Relax for a bit after the last letter is printed. You've
earned another break.
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The Glossary
Microsoft Word provides for the use of custom glossaries for storing text which you use often and don't want to have to type into
your documents every time you use it. The Conan & Cthulu
letterhead and Irving Conan's closing, Sincerely yours, are examples of information that may be used in almost all of C & C's
correspondence.
Glossary entries have names which you choose when you enter them into the glossary. Entry names must consist of alphabetic
characters and may be as long as 64 characters. The most useful
aspect of glossary entries is that they may be stored in a glossary
file and can be recalled at will in future Word sessions. Any
formatting that was done to the original text is retained.
To recall text that's stored in the glossary, you simply type
the name you chose for that entry when it was stored and press
the Command and Backspace keys simultaneously.
Let's add the Conan & Cthulu letterhead and lrv's closing to
the glossary. Make sure that the petform document is on your
screen, then select the three lines that comprise the Conan &
Cthulu letterhead. Choose Copy from the Edit menu to copy the
letterhead into the Macintosh's Clipboard. Next, select Show Glossary from the Edit menu. A special dialog box, the Glossary window, appears.
Figure 3-24. Glossary Window
•

File

Edit

Search

Character

Paragraph

Document

petform
Glossary
page
<<DATA petlisL Name In Glossary:
footnote
«ASK quotecla 1candC
«SET datea?W L..._____;_ _ _ __ _ ,

.cdatEh>

Note that two glossary en tries are already in the window:

page and footnote. These are glossary entry names reserved for use
by Word.
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Type CandC in the Name in Glossary: text box. Choose Paste
from the Edit menu. The letterhead will be added to the glossary
file and the entry name will be added to the list box.
Close the window by clicking the go-away box at the upperleft corner of the window.
Select the lines at the bottom of the form letter that make up
Irving Conan's closing, beginning with Sincerely Yours and ending
with General Manager. Choose Copy from the Edit menu again. Select Show Glossary from the Edit menu, type Irvsig in the Name in
Glossary: text box, choose Paste from the Edit menu, and lrv's closing will be added to the glossary file. The entry name will also be
added to the list box. The window should look like Figure 3-25.
Figure 3·25. Glossary Window the Second Time

Glossary
page
footnote
CandC

Close the Glossary window.
Now save your original form document and select the Close
option of the File menu. The Word entry screen will disappear.
Choose New from the File menu. A new, pristine Word entry
screen appears.
Type CandC and then hold down the Command key. Hit the
Backspace key and the Conan & Cthulu letterhead jumps from its
resting place within the glossary to your document.
Now type Irvsig and hit the Command-Backspace key combination again. The closing appears, eagerly awaiting Irving's pen.
Let's leave using the Quit command. Don't bother to save the
current document, but do respond affirmatively to any questions
that ask if you wish to save the additions made to the glossary. If
glossary entries are not saved at the end of the session, they'll not
be saved to disk-and you won't be able to call on them at a later
date.
This ends our session with Microsoft Word.
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Using Word Without an External Disk Drive
Microsoft strongly recommends that Word be used with two disk
drives. The number and size of the files on the Word program disk
leave little room for documents. Single-drive users of Word who
attempt to store their documents on a separate disk are likely to
find the resulting disk swaps particularly frustrating.
If all the unneeded printer drivers, fonts, and documents are
removed from copies of the Word Master disk, there will be
enough room to store more than 60 pages of manuscript on the
program disk. This method does require some disk swapping at
startup time since the Word Master disk will be requested after a
copy is begun.
Here's how to free up the maximum amount of space on a
copy of the Word Master disk.

For all single drive users:
• Remove the sample document called MEMO. You may delete it
and other files mentioned in this list by throwing it in the
Trashcan.
• Word comes with printer drivers for a number of different printers. Remove all except for the one(s) needed for your own
printer.
• Once you're accustomed to using Word, remove the Word Help
document from the disk. Although you'll no longer be able to
use Word's help facility, this will free up a lot of space for your
documents.
Additional space reclamation tricks (recommended only for
users with a solid understanding of the Finder and its use):
• Using the Font Mover utility which comes with your original
Macintosh System Disk, remove any fonts you're not likely to use
in your work from the Word copy.
• If you have any of the various "resource mover" utilities that are
available from user groups or online databases, remove rarely
used desk accessories from the Finder. The Alarm Clock, Calculator, Note Pad, and Puzzle are good candidates.
• If you're feeling completely merciless, the Finder can be removed
after you make your copy of the Word Master disk a "startup
disk." This process does have a couple of disadvantages: You'll
not be able to manipulate documents and files using the Finder.
No desktop will appear upon starting Word. After quitting Word,
the disk will be ejected. Cumbersome as it may seem, it will buy
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back enough space for 40 or so additional pages of text. To make
your copy a startup disk:
(1) Turn your Macintosh on and insert any disk with a copy of
the Finder on it. Wait for the desktop to appear.
(2) Select Eject Disk from the Special menu. The disk will pop out
of the drive slot.
(3) Insert your copy of the Word Master disk. Select the Word icon
with a single mouse click.
(4) Select Set Startup from the Special menu.
(5) You'll be asked to verify that you want Word to be the startup
application. Click OK to continue.
(6) Open the System Folder by pointing to it and doubleclicking.
(7). Point to the Finder icon and click, holding down the mouse
button. Drag the icon over to the Trashcan.
(8) Select Empty Trash from the Special menu. The Finder will be
deleted.
(9) Eject the disk and turn your Macintosh off and back on. The
surgically altered Word disk may be inserted, and Word will start
automatically.

Numeric Keypad Support
While the Macintosh's mouse has greatly simplified the user-tocomputer interface, some critics have argued that constantly moving your hands away from the keyboard to handle a mouse tends
to slow down an experienced typist's production in Macintoshbased word processing. While this may be largely a matter of
taste, there are alternatives. We've already seen that many of the
commands available on the pull-down Word menus have keyboard
equivalents. What does seem to be lacking are keyboard equivalents for moving the insertion I-beam (cursor) and scrolling.
Although not documented in the Microsoft Word manual,
owners of the Macintosh numeric keypad will find that Word supports cursor movement and scroll keys via the keypad. Those who
are used to working with word processors on other computer systems or who are somewhat uncomfortable with using the mouse
for all cursor movement operations may find using a keypad helpful. A keypad does add a high degree of function to the Word keyboard; it makes moving the insertion I-beam small distances and
moderate scrolling much easier for some people (see Figure 3-26).
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Figure 3-26. Keypad Chart

Summary
We've only touched the surface of the facilities offered within
Microsoft Word. If you are new to word processing, you may have
been surprised at how easy Word is to use. Those who have used
other word processors are probably pleasantly surprised to experience the uncomplicated manner in which Word handles complex
tasks .
Feel free to experiment further. You'll find that Word has the
flexibility to adapt to any writing style and formatting requirements. The Microsoft reference guide that came with your copy of
Word is packed with information about the program's capabilities
and should be revisited often.
There's an old data processing saw whose teeth still cut quite
true. " The difference between a novice and an expert is having
read the manual."

110

Keeping Customer and Client
Lists with File
Sharon Zardetto Aker

e

Before you begin to work with File, there are terms with
which you should be familiar. A data file is a collection
of information, such as names, addresses, and phone
numbers. A data file is divided into records which store
groups of related items, like the name, address, and phone number of one person. Each item in a record is a field; each field has a
name, called a label. ("James" is a field in a record; " FirstName"
is a label.) A form is the way in which information in a record is
presented-a template that indicates where each field appears and
how it looks. The same data file can provide details for a mailing
label, an invoice, or a full page of information for each record.
You can make several forms for each data file: one for easy data
entry, another for quick scanning through records, and another for
printing the data. In this chapter, you're going to develop a database for an insurance agent that will keep track of client records.
When you open File, type Clients in the dialog box and click the
New button. (Click the Drive or Eject button first if you want the
data file stored on a disk other than the one which holds the File
application.)
z

Figure 4- 1. Starting a Data File
Name for New Da t afile:

ltt::EEJ;J

j Clien ts
or Sel ect a Data file:

~

0

ClientRecords

(

U~Hm

l

(

Eject

l

(

Ca nce l

l

(

Dri ue

l
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Creating Fields
File's main screen shows two windows, one labeled Clients, the
other Form. The Clients window is the Datafile window, where
you'll enter the information to be stored in each record. The Form
window in the lower half of the screen is used not only to design
various forms, but to define the fields you'll use in each record.
Figure 4-2. Two Windows

When you first set up a data file, you must think ahead and decide what kind of information will be stored. Figure 4-3 is a sample form that shows everything the insurance agent wants to store
in each record.
Later, you'll design this exact form for the Client
Type
data
file; first, though, you have to set up the fields.
@TeHt
0 Number There's a blinking cursor in the box in the Form winO Date
dow. To get started, just type FirstName and press
0 Picture
Return. A dialog box appears so that you can choose
the type of field. As you create each field, you must
define its type, according to the kind of information it will contain.
The possibilities are Text, Numeric, Date, and Picture. (Later, you
can format each field, deciding on style, font, justification, and so
on.) Since Text is already selected, and this is a text field, just
press Return again.
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Figure 4·3. Fuii·Page Form
Home.· 555-6 789

James
Jones
1715 Eagle Drive
Elmwood, NJ

fJ'orJ:: 555-8936

07864

Birthday: Jan 13, 1942

Occupation: Teacher
Employer: Elmwood Twsp

Spouse: Mary Ellen
Cross Ref: I t 0021
0000000000000000000000000000000000000000000000000000000000000000000000000000000000

Policy•
Type
Renew Dete
Premium

Homeowner
H3 87936039
3
Oct 5, 1986
$347.00

Ruto
A2 65980-098
2 cars
Dec 7, 1985
$687.00

Life
LT 989-7809
term
Jan 1, 1987
$198.00

0000000000000000000000000000000000000000000000000000000000000000000000000000000000

Commtnts

0000000000000000000000000000000000000000000000000000000000000000000000000000000

Annual Premf ums

$1232.00

Commission

$61.60

The field labels that you type switch to boldface when you're
finished; a heading of the same name appears in the Datafile window. The blinking cursor is waiting in a newly created box; this is
the New field, which is always available so that you can add a
new field to your record design. Type LastName and press Return
twice. This bypasses the dialog box and saves some time. As you
enter new field names, the Form window scrolls horizontally so
you can always see the New field; the Datafile window will not
scroll, but the labels are still being created. Now, add the following as Text fields:
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Street
WorkPhone

CityState
Occupation

Zip
Employer

HomePhone
SpouseName

Since number fields cannot contain anything except numeric characters (numbers, commas, decimals, and dollar signs), telephone numbers are
QDate
defined as text fields. A zip code should also be de0 Picture fined as text, because a number field will not hold a
leading zero, such as is in 07 461. Now, add a number field: type id# and press Return once. Click in the Number
button and press Return again.
Notice that the label is printed to the right of the field box;
numbers (and their labels) are automatically right-justified, although you can change this when you're formatting the field. The
agent will use the id# field to cross-reference some of the records.
For instance, two clients may have a joint homeowner policy, but
separate life insurance policies. Duplicate information will not
have to be entered in the data file, yet the agent will be able to
check on all the policies held by any family.
Now, create the cross-reference field. Make it a number field,
but use this shortcut: type Refl, press Return, the letter N, and
Return again. TheN selects the Number button in the dialog box.
A date field is needed for the client's birthday. Type BirthDate,
and press Return, the D key, and Return again; this will select the
Date button in the dialog box. Our hypothetical agent wants to
keep track of three kinds of policies for each client: Homeowners,
Auto, and Life. For each policy, the agent wants to keep track of
the following information: policy number, policy type, renewal
date, and annual premium.
Set up these fields as the types noted:
Type
QTeHt
@Number

Information
HO Policy
HO Type
HO Renewal
HO Premium
Car Policy
Car Type
Car Renewel
Car Premium
Life Policy
Life Type
Life Renewel
Life Premium
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Text
Text
Date
Number
Text
Text
Date
Number
Text
Text
Date
Number

Chapter 4

For the final entries, create a Text field named Comments, and two
numeric fields: Total and Commission.

Making Corrections
As you're typing field names, you can backspace and retype the
name. Once you've pressed Return, however, you can't do that
kind of correction; you must make any later corrections through a
Format window. Scroll the Form window back to the left so that
you can see the FirstName field, and double-click in it. The Format
window which opens presents you with several options. You can
correct the label, format it, and even change its type.
Figure 4-4. File Formatting

0

Format Field

I

Name:l
r-Type
@TeKt
0 Number
ooate
0 Picture

D Computed
Formula:

lndeK

((

OK

l

(Cancel)

Display- r-Riign- Style
0 Border
General
®Left
0 Center
Dollar
0 Underline
0Right
0 Bold
Percent
Decimal
0 Italic
Scientific Decimals~[] 0 Commas

0
0
0
0
0

I

Label corrections and format changes can be done at any
time. Changing the field type, however, can be done only during
the original setup; once you have entered information into the
data file, you can no longer change the field type. Click the Cancel
button for now. If you chose the wrong type for any field you created or misspelled any field name, you can take a minute now to
open a Format window and make the correction. Leave all the
other options at their current settings for now.

Entering Data
Since fields can be formatted at any time, you can enter some
information into the data file now and choose the formats later.
Activate the Datafile window by clicking anywhere in it, or by
closing the Form window. There's a record labeled New, with a
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blinking cursor in the first box, under the heading FirstName.
Type James and press Return; the cursor moves to the second
box. As soon as you type, a record number appears (in this instance, 1), and the New record shifts down a line. Continue entering data into the fields to match the information in the first
column in Table 4-1; when a field is to be left blank, just press
Return. Keep typing when you reach the edge of a field box-the
text will scroll. You can adjust the size of the boxes later. Press
Enter when you're finished, and the cursor goes to the first field
in the New record.
Type Mary Ellen in the first field of the
~ + [ ] New record and press Return. Using the information in Table 4-1, complete the second record.
CCIP!! dCI JoJ··n
Anytime you want a field in the current record
to repeat information from the previous record, press the Command key ( 38) and the quote key ('). Continue entering the information from Table 4-1, using this copy-down option wherever the
information matches. Enter the information for the other records
as shown so that you have ten records with which to work. If you
want to go back and change or correct any data you've entered,
you can move around in the Datafile window with the Return,
Command, Enter, and Option keys, as shown.
Adding the Shift key reverses the effect of
or rTab"l the key sequence: Shift-Return selects the preNe,\'t field
L___j vious field, Shift-Enter selects the first field of
the previous record, and so on. You can copy
~ + Enter ) the contents of one field into any other field
l___j
by using the Copy and Paste commands. (The
s~me field, ne,\'t record Command -quote option works only when you
want to copy from the same field in the pre( Enter )
vious record.) Select the field that you w~nt to
first fteld next record copy from, and choose Copy from the Edzt
"
menu; select the field you want to copy to,
(Option ] + Enter
and select Paste.

E:J

I

I I

Record one screen dob•'n
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Table 4-1. Insured Clients' Information

~
~

\0

Field
FirstName
LastName
Street
CityState
Zip
HomePhone
WorkPhone
Occupation
Employer
SpouseName
id#
Refl
Birthdate
HO policy
HO type
HO renewal
HO premium
Car policy
Car type
Car renewal
Car premium
Life policy
Life type
Life renewal
Life premium

Record 1
James
Jones
117 Eagle Dr
Elmwood, NJ
07864
555-6789
555-4567
Teacher
Elmwood
Mary Ellen
1001
1002
Jan 13,1942
H3 87936039
3
Oct 5,1986
$347
A2 65980-098
2 cars
Dec 7,1985
$687
LT 989-7809
term
Jan 1,1987
$198

Record 2
Mary Ellen
Jones
117 Eagle Dr
Elmwood, NJ
07864
555-6789
555-9756
Teacher
Elmwood
James
1002
1001
May 17,1948

LT 989-6834
term
Mar 15,1988
$172

Record 3
Jeremy
Clifford
3 Balder St
Halifax, NJ
07198
555-3829
555-2358
Doctor
self
Norma
1018
Sep 17,1934
H2 87363033
2
Oct 2,1986
$327
A3 87435-483
3 cars
Jun 4,1986
$845
LT 329-4857
whole
$750

Record 4
Robin
Zimmerman
27 Hollow Rd
Cliffside, NJ
07305
555-2837
555-5702
Cust
Bell
Gerald
1015
1020
Apr 15,1955
H3 84624003
3
Nov 5,1986
$540

Record 5
Gerald
Zimmerman
27 Hollow Rd
Cliffside, NJ
07305
555-2837
555-4857
Rep Writer
self
Robin
1020
1015
Jun 19, 1952

LT 567-4373
whole
$892

0

=r
0

"'0

-+

<D
....,

~

.....

N
0

()

Field
FirstName
LastName
Street
CityState
Zip

HomePhone
WorkPhone
Occupation
Employer
SpouseName
id#
Refl
Birthdate
HO policy
HO type
HO renewal
HO premium
Car policy
Car type
Car renewal
Car premium
Life policy
Life type
Life renewal
Life premium

Record 6
John
Messineo
14 Taylor St
Dover, NJ
07302
555-2907
555-1945
Mason
self
Joanne
1007

Record 7
Sarah
Billings
87 Krump Rd
Halifax, NJ
07198
555-9736
555-1944
Accountant
Ace Accnts

Record 8
William
Dykstra
19 Penny Ln
Orange, NJ
07893
555-3750
555-8823
Store Mgr
A&P

1024

1009

Nov 1,1953
H2 98685850
2
Feb 27,1986
$632

Sep 23,1955

Aug 1, 1947

A3 08678-954
3 cars
Jan 5,1986
$940

A2 98736-865
2 cars
Aug 15,1986
$827

LT 964-9875
whole
$945

Record 9
Cathy
Gretzky
907 Misty Rd
Orange, NJ
07893
555-3947
555-0037
X-Ray Tech
Orange Gen
Jeremy
1014
1025
Sep 25,1950
H1 73643957
1
Feb 7,1986
$575
A2 96365-8744
2 cars
Nov 25,1985
$684

Record 10
Jeremy
Gretzky
907 Misty Rd
Orange, NJ
07893
555-3947
555-0345
Lab Tech
Orange Gen
Cathy
1025
1014
Mar 14,1947

LT 874-8732
term
May 25, 1989
$208

=r
0

u-+
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....,
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Designing the Form
It's time to design the form so that the information will be presented effectively. Choose Show Form from the Form menu, and
the Form window reappears. The List Helper option in the Form
menu has kept your fields in the linear form you've been using so
far. This is the most convenient form for creating the fields at the
start, and for the initial entry of data. A simple horizontal listing
of data, however, is not the best way to view your records or to
print them. Select List Helper from the Form menu-since it's already selected, choosing it now toggles it off. The main form the
insurance agent needs is a single sheet of paper with all the information on it, as shown by Figure 4-3. The first thing to do is size
and position the fields as needed. Next, you'll create independent
labels to identify some of the items on the form. Finally, you'll
format each of the fields. To make room in which to work, the
dotted gray area of the Form window-the hide area-has to be
moved down. Place your cursor on the bottom edge of any field
until the cursor changes shape so that only two vertical arrows are
showing. Press the mouse button and drag the hide border down
to the bottom of the window. Scroll the window and drag the
hide line down further; scroll and drag again, until the line is at
the 8-inch mark. Now there is room to size and place the fields as
shown in Figure 4-5.
Because the Form window includes a ruler to help you place
fields accurately, you see less on the screen than you will on a
standard-width paper. As you're working, you can use the scroll
controls to move to the section of the window that you want. At
any one time, you'll be able to see a little less than half of the
form you're designing, as Figure 4-6 shows.

Moving and Sizing Fields
To move a field, click in it and drag it to the desired spot. If you
drag a field to the edge of the window, the window scrolls. You
can select more than one field at a time in order to move them together. One way to select multiple fields is to click in one field
and press the Shift key before you click in subsequent ones. Alternatively, you can enclose the desired fields in a selection rectangle
by beginning the rectangle in the white area of the screen and
pulling the lines across all the fields you want to include, much
like you see demonstrated in Figure 4-7.
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Figure 4-5. Size and Place

!BirthDate
!SpouseName
Ref

tl

Ho policy
HO renea11al
HO premium

Car policy
Car type
Car renewal
Car premium

Life poll~
Life type
Life renewal
Life premium

Comments

Total!

122

Commission!

C hapter 4

Figure 4-6. What You See

!0

Form

° FlrstNome llllstNome
Street
CityState

IHomeP
IWorkP i!i'i'

I
I

IZip

l;lii;

I

1-

rnu.p,lll

IDirthDote

IEmpiO! !i\!1:

ISpouseName

2-

Ref

11

3I Ho policy
IHO type
IHO renewol

I
I

I Cor policy
I Cor type
Cor renewol

I
I

II

I"'IL""'if-e-po-:1...11mm
I life tliPI mm
rP rPn<IO

Figure 4-7. Field Box Selection

0

Form
0

..···· ··············· ······---------··········-,········.

+

To resize a field, place the cursor at the right or
bottom edge, or at the bottom-right corner of the
I
box; the cursor will change from the cross used for
field selection to one of three shapes, depending on
where you place it. The cursor with the vertical ar'---+---'
rows lets you make the field deeper so that it is
J able to hold more than a single line of text. Place
'-----"!..
the cursor on the bottom edge of the field box and
drag down. If you put the cursor on the right edge of a field box,
it will change to a double horizontal arrow, allowing you to drag
right or left to change the length of the box. Placing the cursor at
the bottom-right corner of a field box means you can adj ust both
length and depth at the same time-the cursor changes to diagonal arrows when you position it correctly. If you h ave multiple
fields selected and change the size of one, the others will also be
changed. Move the fields around and size them until they match
Figure 4-5.
123
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Creating Independent Labels
The field boxes you've been moving around have labels in them that describe the fields into which you
can enter information in the Datafile window. You
L.~-~J.~~~-~~ ... 1 can also create independent labels that do not define
data fields in a record, but that will appear in every record to label certain fields or groups of fields. Look at Figure 4-3 again; the
words in boldface are independent labels, as are some of the other
labels on the form. To create an independent label, click in any
free space in the white area; a blinking cursor appears. Just start
typing-begin with the label Home. As soon as you begin typing,
the word is boxed. Independent label boxes differ from field
boxes: they have two thin lines across the top, with dotted lines
completing the rectangle. To select this type of box, click in the
area between the two top lines. A selected independent label will
have a black bar across its top.
Once an independent label is selected, you can resize or
move it just like a field box. Type the following labels, making the
boxes slightly larger than the words they contain. (Note: An independent label can have the same name as a field label.)
I

unselected

I

~---············---!

Home
Work:
Birthday:
Spouse:
Occupation:
Employer:

CrossRef:
HomeOwner
Auto
Life
Policy#
Type

Renew Date
Premium
Comments
Annual Premiums
Commission

Place each label in the appropriate spot, as shown in Figure 4-8.
Click in the Close box of the Form window so you can see the
Datafile window. Except for fonts and formatting, your data looks
much like Table 4-1.

Formatting Options
Choose Show Form again and double-dick on the
title bar of the Form window so that it expands to
full-screen size. Each field can have a variety of
formats, as you know from seeing the Format window in Figure 4-4. Style, alignment, and index formats are available for all but picture fields. The
style options available are the standard italic, bold,
and underline, with a border option also available.
style
Border
Underline
D Bold
D Italic
D Commas

D
D
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Figure 4-8. Independent Labels

:~!~~~~-~MJ BirthDate
:~P.9.~~~~ ISpouseName

:..~!.9.~-~B.~fJ

Ref

11

:_~omeOwner

:

HO policy
HO type
HO renewal
HO premium

:~~P'liito~:-.....---.....
Car policy
Car tipe
tar renewal
tar premium

Life policy
Life tupe
Life renewal
Life premium

:Comments:
Comments

All fields have borders to begin with-that's
why
they appear in boxes in the Datafile window
Oleft
right now. (Independent labels, which are always
0 Center
treated as text, can be formatted, too; they default to
0 Right
no border, but you can add a border if you want.)
You can choose from right, left, or center alignment, and the field
contents will be placed appropriately in the field area you define.
Rlign
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Indexed fields make searching and sorting faster. Index the
field(s) you are most likely to sort by or search for. Don't use the
index option unnecessarily, because the index file takes up disk
space. You should, however, index at least one field in a record
because File can then add new records to the data file more
quickly. Other options are available only for specific types of
fields. Since you've entered data into the data file, you can no
longer change the field type; when you open a Format window for
a field now, you'll get an abbreviated window whose contents
will depend on the type of field you are formatting. Text fields
have only style and alignment options. Text fields are originally
left-justified; you can change this to center or right-justified
through the Format window.
Figure 4·9. Text Fields Formatting
Format TeHt Field

D

lndeH

n

OK

D

Nome:
(Cancel)
Rlign
®Left
0 Center
0 Right

Style---,
D Border
D Underline
D Bold
D Italic

Number fields have the same style and alignment options as
text fields; number fields default to right-justification. There are
adqitional format options so you can choose how the number will
appear.
Figure 4·1 0. Number Fields
Format Number Field

D

lndeH ([
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)J

I (Cancel)

Name:liBi·
Display®General
0 Dollar
0 Percent
ODecimal
0 Scientific

OK

RlignOLeft
0 Center
@Right

Decimals:~

Style
181 Border
D Underline
D Bold
D Italic
D Commos
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The General display option prints a number the way you type
it; Dollar adds two decimal places and the dollar sign; Percent
adds the percent sign (you must enter the number as a decimal.5 for 50 percent); Decimal keeps the display at the number of
decimals you specify in the Decimal box; and Scientific display
uses scientific notation for large numbers. Another option for
number fields is that of computed field: the value placed in the
field will depend on the formula you provide. The formula can refer to any other number field(s) in the record. A number field cannot be both computed and indexed; if you choose one option, the
other will dim so that you can no longer select it. If you open a
Format window for a numeric field that already has information in
it in any record, the computed field option will not be availableonly File itself can put information into a computed field. Date
fields, in addition to having style and alignment options, can be
defined to appear in one of three forms.
The short form appears as 1/25/86. The meDisplay
dium
form abbreviates the month: ]an 25, 1986. The
0 Short
long
form
prints out the entire name of the month:
OMedium
January
25,
1986. When you select a form for a date
OLong
field, you're defining how the date will appear, not
how you must enter it; you can enter it in any of the forms, and it
will appear as specified. When you're entering a date into a
record, if you specify only the month and day, File fills in the current year; if you specify only the day, File fills in the current
month and year. If you press the Command key and the minus
sign key, File fills in the current date-month, day, and year.

Formatting the Fields
Although you work with field labels in the Form window, the
fields themselves are what you're formatting. Except for justification, the formatting options you choose will not show in the Form
window, but will be applied to the data entered in the Datafile
window. Double-clicking on any field opens its Format window.
When you want to assign the same format to multiple fields, you
can select them and open a single Format window. Begin a selection rectangle underneath the CityState field and drag upward until the two name fields and all the address fields are highlighted.
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Figure 4·11. Multiple Field Selection
FirstNam-e··ltU-stNsme·······l·················~

Street:
I
:
CitySt~te
I Zip
I
·······------------······························--.:

l

To open the Format window, double-click in any of theselected fields, choose Format from the Form menu, or press Command-D. Turn the Border option off for all the selected fields by
clicking in the check box; the X will disappear. Close the Format
window and double-click in the LastName field to open the Format
window again. Since records will often be sorted by last name,
click in the Index field box. Select all the following fields using the
Shift-click method, and tum off the Border option:
HomePhone
WorkPhone
Birthdate
Occupation
Employer
SpouseName

Since date fields default to the medium display, there's no
need to format the Birthdate field separately; its border can be
taken off as you format the whole group of fields. Open a Format
window for the id# field; index it and tum off the comma option.
The CrossRef field should also be formatted to exclude commas,
but it should not be indexed. The three premium fields (HO Premium, Car Premiun, and Life Premium) can all be formatted together: leave Border on, turn off the commas, and choose Dollar
format. The Total field is going to be a computed field that keeps
track of all the premium payments a client makes during the year.
Double-click on the field to open the Format window. Choose Dollar format, no border, no commas, and check the Computed box.
Enter the following formula:
HO premium+ Car premium+ Life premium

The Commission field is also a computed field. Set it for dollars, no commas, no border, and bold print. Click in the Computed
box and enter this formula:
Total*.OS

The asterisk is used for multiplication; this formula calculates 5
percent of the total annual premiums.
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Formatting the Independent Labels
Independent labels are formatted in the same
way as fields. It's sometimes difficult to select
s~.c..........
an independent label, since you have to be so
~"'I comments
accurate with the placement of the cursor;
drawing a selection rectangle is often quicker
even if you need to select only a single label. First, format the
Home and Work labels for italics. Next, do a multiple selection:

Birthday, Spouse, CrossRef, Occupation, Employer, HomeOwner,
Auto, and Life. A quick way to do this is to select the first three in
one rectangle, hold down the Shift key while you trace a rectangle
that includes the next two, and, while the Shift key is still down,
put another rectangle around the last three. Instead of changing
the format, change the font: Select Set Font from the Form menu,
choose Chicago, 12 point, and click OK. Now, skip down to the
Comments label, select it, and choose Set Font again. Leave the
font as Geneva, but change the size to 9 point. When you're back
in the Form window, alter the depth of the Comment label box so
that it fits the new fontsize, and move the box down closer to the
Comment field.

Final Touches
If you take a look at your Datafile window now, you'll see that
with the exception of the circles that separate sections of information, your screen looks just like Figure 4-3. To add the circles,
go back to the Form window and click in the area above the policy information. Hold down the Shift and Option keys, and press
the 8 key-you need about 85 circles to make the line. Since you
set a 9-point fontsize for the last label, that's still in effect. Select
this label when you're finished typing and format it for 12-point
size. Drag the right edge of the label box over to the edge of the
form so the entire line of circles will show. To make the other two
dividing lines without typing them, you can copy the one you just
made. Place the cursor within the label, making sure the I-beam
cursor is showing; double-click to highlight the contents of the label box. Choose Copy from the File menu, click where you want
the next line to be, and choose Paste. The full line of dots will be
placed in a new label box, but the box will have to be enlarged so
that you can see it all. Paste another copy near the bottom of the
form, under the Comments box.
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New Oatafile •.• 3€N
Open Form... 3€0
Close
3€W
Saue Form
Saue Form Rs •••
Page Setup •••
Print Form...

8£P

Quit

8£0

Many of File's menus change depending on
which window is active. When the Form window is active, the choices in the File menu refer to forms rather than records. Your first job
in printing a form is to choose the page
parameters. Make sure the Form window is
active and choose Page Setup from the File
menu.

Figure 4-12. Page Parameters

,...lm=a=g=e=W=ri===:te:=r=(=St=a=nd=a=rd=or=W=I=d=e)~::::::::==:======= n

D

OK
® US Letter
0 A4 Letter
0 us Legal
0 International Fanfold [cancel ]
0 Computer Paper
Orientation: ®Tall
0 Tall Adjusted 0 Wide
Pagination:
® Normal pages 0 No breaks between pages
Reduction:
® None
0 50 percent
Page Header:

Paper:

Page Footer:

~==============================~

~------------------------------------------------~

Left Margin: I 0.75

:=:====:

Top Margin: IL-1_ _ _ _ ___.

Right Margin: I 0.75

:=:====:

Bottom Margln:IL-1________,

The Paper and Orientation choices are the same as in other
Macintosh applications. Leave them at the defaults of US Letter
and Tall. Leave the margins at their default settings, too. In addition to these options, you can define a header or footer (or both)
for the page. Any or all of the following formatting commands
can be incorporated into the header or footer:
&L = Left align
&R = Right align
&C = Center align
&P = Page number
&D =Date
&T =Time
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For this printout, type the following in the header box:
&L&T&CClientForm&R&D

This header will have the current time at the left, the title
"ClientForm" in the center, and the date at the right. Note that
since the date is taken from the Macintosh's internal clock, it's always the date of the current printout, not the date on which you
originally created the form. Now you can choose Print Form from
the File menu and print the form in the quality you prefer.

Printing Records
Activate the Datafile window so that you can print your records.
Choose Page Setup again; leave the basic options at their default
settings. The new options that appear in this window are for
record printing only. Select Print Record Number so that each
record will be numbered. Turn off Print Grid Lines; this option
prints a solid line between each record on the page. Since the
form you designed takes a whole page, there's no need to have
grid lines. Tum off the Mailing Label option; its effect will be explained later, when you print mailing labels. Change the header to
&L&P&CClient Records&R&D

This will put the page number at the left, the title "Client Record"
in the center, and the current date at the right.

Saving Forms
Your data file is automatically saved as you enter information;
that's why you never need to use a Save command to save
records. The form you design is also automatically saved with the
data file. In fact, two views of the form are saved: the one you designed, and a List Helper version. If you click in the View 1 in the
lower-left comer of the Form window, you'll see the second view.
(The second view does not have to be a List Helper; you can design a form in this second view window.) Command-T also toggles you back and forth between views, in both the Form and
Datafile windows. Since many different forms can be used with a
single data file, you can save forms separately instead of with the
data file. Make sure the Form window is active, and select Save
Form As from the File window. When the dialog box appears, type
ClientForm and click Save.
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Another Form
Now you're going to design another form for the insurance agent,
one that gives the bare essentials of information on each client.
The easiest way to do this form is to start from scratch. Pull down
the Form menu and choose List Helper. A dialog box may appear,
asking if you want the current form saved with the data file. Since
you just saved the current form separately and want the new design to be saved with the data file, click No. Your form will
change to a List Helper form. Tum off List Help er again so that
you can design another form. Pull the hide line down to the 2inch mark. Create the labels and arrange the fields as shown in
Figure 4-13.
Figure 4· 13. Another Form Design
Client
I

James

Jones

Home
H3 87936039
Oct 5, 1986
$347.00

Total : $1232.00
Commission:
S61 .60

All to
A2 65980-098
Dec 7, 1985
$687.00

Life
...,.L=r-=9-=89=---=7:-=8~o9=--"~

Jon 1, 1987
$198.00

- -- - - - - -- - - -- ------ ------==-- Form
----------~

1

~
Ho pollc
HO ·renewal
HO premium

~
Car pollc
Cor renewal
Cor premium

~
life polic
life renewal
life premium

All the fields not used for this form must be dragged down
into the gray hide area. The information in these hidden fields is
not lost from the data file; it just no longer shows in the window.
You'll have to make the following format changes to get your new
form to match the one in Figure 4-13: For first and last names,
take off the borders and add boldface; italicize the policy titles;
and take the borders off the two computed fields in the upperright corner. With a form design only two inches deep, you can
see two forms on the screen at all times; this is convenient for
scrolling through the data file more quickly.
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Sorting
You can arrange your records in any order during a File session.
When you reopen the data file, the order won't be preserved, but
it's a simple matter to sort the records again. To sort the records
alphabetically by last name, select Sort from the Organize menuthe Sort window appears. If you enlarge the window (you don't
need to now), you would see boxes placed just as the fields and
labels are arranged on your form. The portion showing now is the
FirstName j LastName area of your form .
Figure 4-14. Sort Window

HtJme

AllttJ

Lif e

The boxes in the Sort window are divided into two sections.
The small section will contain a number that indicates the priority
of the sort on that field. You might, for instance, sort records by
last name and want them subsorted by first name in case records
contain the same last name. The larger section will hold a phrase
that indicates whether the sort is in descending or ascending order. Click in the box that corresponds to the LastName field. A 1
appears in the small box, and A->Z in the larger area. The 1 indicates that the first level of the sort will be made on this field; A>Z shows that the sort will be in normal alphabetic order. Since
some of the customers have the same last name, define the
FirstName field as the second-level sort. Click in the box that
corresponds to FirstName; a 2 and A->Z appear.
;;;O
Now click the Sort button, and the
J records will be sorted as specified. Scroll
n Sort D[ Clear I through the records to see the sort's effect.
I I A- >Z
121 A->Z I

-.1
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The next sort will be by total premiums,
with the highest listed first. Open the Sort
window again, and click on the Clear button;
this erases your last sort criteria. Scroll the
window until you can see the box for the Total field. Click in it,
and 1 and 1->9 appear. Click again in the large area of the box,
and the numbers reverse to 9->1, showing that the sort will be
made from highest to lowest; click the Sort button.
9-> 1

Searching Through Records
The Find option in File works a little differently from similar options in other Macintosh applications. Instead of finding the first
occurrence and then subsequent occurrences of the items you're
looking for, File finds all the records that match your search criteria and leaves only those records available in the Datafile window. (The records that don't match can be returned to the
window by choosing Show All Records from the Organize menu.)
Once you have a subgroup of records in the Datafile window, options such as sorting and printing will apply only to those records,
although another Find operation will look through the entire data
file. The group of "found" records can also be saved as a separate
data file by using the Save As option from the File menu.
Figure 4-1 5. The Find Window

(Clear

Home

I

Ruto

life

The first search you're going to try is one that finds all the
clients who pay less than $1,000 a year in total premiums. Choose
Find from the Organize menu. The Find window is similar to the
Sort window in that it's patterned after the way the record ap134
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pears; however, there are no boxes for the fields unless you
formatted them to have borders. This can be a little confusing
when you want to type in a field that has no border or independent label identifying its spot. Expand the Find window so that
you can see the entire record; notice that the blinking cursor is in
the spot which corresponds to the FirstName field.
Press Return twice; the cursor moves through the LastName
field and into the Total field. Since you want to see records with
totals under $1,000, simply type
<1000

Click the Find button, and File will find the six records that meet
this criterion. (The total number of records always appears in the
lower-left corner of the screen.) You can use all the standard relational operators in File:
> greater than
< less than
> = greater than or equal to
<=less than or equal to
= equal to
<> not equal to
These operators can be used on numeric, text, or date fields.
There's also a "range" operator. If you want to find all the records
with total premiums from one to two thousand dollars, you would
use
1000•..2000

in the Total field.
The equals operator does not have to be used; if you type a
word or number in the field area with no operator at all, File assumes you want an equals match. And, if you are searching for a
match, you can look for more than one thing at a time in a single
field by separating things with a comma. For example,
Mary,Molly

in the FirstName field will find all the records with either of those
entries.
"Wild cards" can also be used during a Find operation. A
wild card takes the place of one or more characters in the search
criteria. The asterisk stands for any number of characters. C* in
the LastName field finds all the clients whose names begin with C.
A question mark is used when a single character is missing: B?LL
would retrieve Bill, Ball, Bell, and so on. (File does not differen135
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tiate between upper- and lowercase when it's searching through
records.) Multiple criteria can be used in a Find: clients who have
both auto and life policies, or clients whose names begin in the
first half of the alphabet, pay more than $1,000 a year in premiums, and have both auto and life policies. Simply type in what
you want in each field of the Find window and let File do the rest.
Let's assume the insurance agent gives more attention to
larger accounts. It's October, and the agent wants to send a personal letter to any client whose homeowners policy is up for renewal-if the client has a large account. Open the Find window;
type >1000 in the Total field and Oct* in the HO renewal field.
File finds the two ·clients who need special attention this month.
For a final search, find all the clients who have life, but not homeowners, insurance. Type L* in the Life policy field and <>H* in
the Homeowners policy field. File finds the three clients who fit
this description. These criteria work because all the life policies
begin with the letter Land all homeowners policies with H; when
you want to search your own records in a similar manner, you'll
have to decide what to use. If, for instance, you wanted records
that were blank in a certain field, but that field might contain any
alphabetic character if it's filled in, you could tell File to select
records that have <A in that field.

Mailing Labels
File cannot print mailing labels more than one across, so you must
have single-column labels for your printer. You'll have to experiment with the mailing-label form you create to get the right fit.
Our agent uses mailing labels that are divided into two parts, the
upper part holding the agent's name and address, the lower part
the client's name and address. Switch to the second view of the
current form; the mailing label will be the alternate view stored
with the data file. Take off List Helper, and drag the hide line
down to the 2-inch mark. Hide all fields except the name and address. Lengthen .the remaining fields so that even the longest
entry in any record will fit comfortably. Stack the fields appropriately, and place them at the l-inch mark. Select all the fields,
open a Format window, and tum off the border option. Create
three independent labels for the agent's return address: B. J.
Sloane/134 South Street/Elmwood, NJ 07843. Make all the label
boxes the same size, and stack them over the field labels. Select
all three independent labels and format them for Bold style, Center
alignment.
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Figure 4-16. Mailing-Label Form
Client
B.J . Sloone
134 South Street
Elmwood, NJ 07643
Jom es
Jones
1715 Eegle Dri ve
Elmw ood, NJ

07864

~0

Fo~

:

i

B.J. sioone
1 S4

soutn street .

[.~!.~.'!'!".~.~-~-~-~~..~?.~~-~.!

VIew 2

The mailing label, as it appears in the
Datafile
window, has gaps between the first and
dt>leult formet
last names and between the contents of the
2ipl
CityState field and zip code. When you choose
nt>'"' tormet
Page Setup and click in the Mailing Label box, File
will remove these gaps before it prints the labels. The easiest way
to insert a single space between the CityState and Zip fields is to
lengthen the latter to include the space, then format it for right
alignment:
When printing mailing labels, also choose the No Breaks Between Pages option from the Page Setup window. This will prevent
the printer from advancing
Figure 4-17. Gaps Closed
the labels each time the
equivalent of a page has
been printed. The final
B.J. Sloone
output,
printed on bor134 South Street
dered
labels,
looks like
Elmwood, NJ 07843
this:
James Jones
1715 Eagle Dri ve
Elm woo d, NJ 07864
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Reports
File's Report function lets you present data in columnar format,
similar to the List Helper form. The advantage of a report is that it
lets you do calculations involving more than one record. Choose
Report from the Organize menu. The Report window which opens
has four titles in the left margin area: Sort, Heading, Field, and
Grand. The Sort line will later label the ascending or descending
sorts you select. In the Field line are the fields you defined for this
data file; the Heading line is identical to Field except that the
words are centered. The line following Grand is empty, since you
haven't defined any grand totals yet. You can put a field into one
of three areas in a report: Sorted, Not Sorted, and Not Shown. If
you've not used the Report window at all yet, everything will be
in the Not Shown area, and the Sort and Not Sorted areas won't
even be visible.
Figure 4·18. Report Window
Report

0

Summary Report

You'll design two reports. The first will
show the number of homeowners, auto, and life
policies the agent has issued; the average annual
premium each insured pays; and the total
commissions the agent receives. The second will
show how many clients the agent has in each
town. The first report doesn't need anything in
the Sorted area, but it does need five fields in the
Not Sorted area. Find the HO premium field by
scrolling horizontally. Select it and drag it to the
left. A vertical line will appear on the screen as
you drag-this line indicates where the field will
be placed when you let go of the mouse button.
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Continue dragging to the left (the window will scroll automatically) until the vertical line is covering the black bar in front of
the Not Shown area.
Release the mouse button, and the field appears in the Not
Sorted area. Do the same with the Car premium and Life premium
fields, and the Total and Commission fields, until they're all in the
Not Sorted area. The headings are the titles that will appear at the
top of the columns in your report. They default to the field title,
but you can change them with the usual Macintosh editing techniques. Click in the first three headings and change them to read
HO, Car, and Life. The length of each field in the report can be
changed.
Place the cursor on the right edge of the first premium field
and drag it to the left until it's about two-thirds its former size. Do
the same with the other premium fields. The fields in a report are
formatted independently of the Form window formats. Select the
three premium fields by Shift-clicking, and double-dick on one to
open the Format window. Select dollar, no commas, and center
alignment. Format the Total field for dollar, no commas, and right
alignment. Format the Commission field for dollar, no commas,
bold, and right alignment. Now it's time to let File know what
kind of calculations you want done. Place your cursor in the HO
column, in the Grand row, and double-dick. This box is called a
summary field, and the window which opens allows you to indicate what calculation it will hold. (Although the window says
"Format summary field," this is not the kind of formatting you
did for fields in a form.)
Function
Since you want to know how many homeD Total
owners policies there are, click in the Count box
D count
and then click OK. Do the same for the other two
D Rueroge premium columns. When you get to the Total colD Minimum umn, format the summary field for Average, so File
D MoHimum will print the average premium paid by each client.
D Std. Deu. The Commission summary field should be formatted
for Total. Each summary field shows the function
that you chose for it. Now, click in the Preview button, and File
will show you on the screen how your printed report will look.
When you actually print the report, you can use the Page
Setup command to add a header or footer to each page, as you did
earlier.
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Figure 4-19. Preview Your Report
Preulew

HO
$347.00
$327.00
$540.00

Cor
$667.00
$645.00

Ufe
$196.00
$172.00
$750.00
$692.00

$575.00

$940.00
$627.00
$664.00
$206.00
$945.00

$632.00
Total:
Count: 5
Average:

Total
$1232.00
$172.00
$1922.00
$540.00
$692.00
$940.00
$627.00
$1259.00
$206.00
$1577.00

Commission
$61.60
$8.60
$96.10
$27.00
$44.60
$47.00
$41.35
$62.95
$10.40
$78.85
$478.45

5

6
$956.90

Saving the Report
Just as one form (with two views) is always saved with a data file,
one report design is also automatically saved. A report can also be
saved separately, by choosing Save Report from the File menu.
There are new options in this dialog box: Specification and Text
Output. Specification saves the template that you designed so you
can use it again with the data file. Text Output saves the text of
the report, formatted in columns as it appeared in the Preview
window, so you can use it with Microsoft Word or as a new· data
file. Select Specification for now, and save the Report under the
name Policy Report. Now choose New Report form the File menu.
If a dialog box appears asking if you want the current report
saved with the data file, dick No, because you just saved it separately. When the New Report command is given, the Report window reverts to its original state.
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A New Report Design
This report will count the number of clients in
each city. The CityState field has to be placed in
the Sorted area for this to work. Drag the
CityState field to the extreme left of the screen
until the vertical gray line is past the black bar
which holds the Not Sorted area.

When you release the button, the
CityState field is in the Sorted area, A->Z
appears as the column heading, and a
new item appears in the left margin: by
_
CityState. When a field is placed in the
b Cl t Sto
Sorted area, not only will the information
in the report be sorted by that field, but things will also be
grouped by that field, as you'll soon see. If you want a reverse
sort, just click on the A->Z, and it changes to Z->A.
When the phrase by fieldname appears in the left margin,
summary fields are placed under each column in the report in the
new row. This means you can now find the number of clients in
each city or the average premium paid by clients in each city or
any other summary field format according to the cities which appear in the records. Drag the LastName field to the Not Sorted
area-make sure it's long enough to accommodate any name in
the data file . If you do this report using only the LastName field,
File will count how many different last names are in each city.
Since you want to count clients, and some share a last name,
move the id# field into the Not Sorted area, too. The CityState and
LastName fields don't need any format changes; however, you
should double-click on the id# field and set its format for no commas and left alignment. Change the CityState heading to Location,
the LastName heading to Clients, and erase the id# heading, leaving it blank. Now, double-click in the summary field under id#
(across from by CityState) and select Count. Preview your report
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now and you11 see that clients have been listed in groups according to the city in which they live. The total number of clients for
each location is also given.
Figure 4-20. Summary Fields for Subtotals
Preuiew
Locution
Cl1ffside, NJ

Clients
Z1mmermann
1o15
Zimmermann
1020
Count for Cliffside~ NJ:

------2

Dover, NJ
Messineo
_1_0_07_ _ __
Count for Dover~ NJ:
Elmwood, NJ

Count for

1001
1002

Jones
Jones
Elmwood~

NJ:

2

1018
Clifford
1024
Bill1ngs
Count for Holifox~ NJ:

2

1009
Dykstra
1014
Gretzky
1025
Gretzky
Count for Orange~ NJ:

3

Halifax, NJ

Orange, NJ

Return to the Report window and click in the Summary Report
box. A summary report gives you the totals without listing intermediate information; in this case, you'll get the number of clients
per city without the clients' names. Also, add a Grand Summary:
format the summary field under id#, in the Grand row, for Count.
Preview again to see the Summary Report, with clients per city and
total number of clients listed.
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Figure 4·21. Summaries Without Details
Location

Cltffs1deJ NJ
DoverJ NJ
ElmwoodJ NJ

2

HalifaxJ NJ
Orange, NJ

2
3

Count:

1
2

10

Printing Reports
When you want to print a report, you'll find a new option in the
Page Setup option: Start a new page when first column changes. If
you chose this option for the last report you designed, each time
the name of the city changed, the paper would be advanced to the
next page. The other Page Setup options remain the same as for
other printing procedures in File; you can choose paper and
orientation options, and define headers and footers. When you
want to print more than one report, you can do so from the
desktop if you've saved the report forms separately from the data
file. Just select the reports you want printed and choose Print from
the File menu; the reports will be printed in the order they appear
on the desktop. The data file itself, and the File application, must
be on an inserted disk in order for this to work.
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Merging with Word
Sharon Zardetto Aker

The ability to produce large numbers of letters, and
produce them quickly, can be invaluable to any office.
Reaching every client or customer by mail can be
effective and efficient, especially if you let your computer and
printer do most of the work for you.
With Microsoft Word and your Macintosh, you can personalize letters as much as you want. You can even generate letters
based on lists taken from data files you've already created with
Microsoft File. This integration makes your Macintosh, and thus
your MacOffice, even more powerful.

Word's Merge
Word has special merge commands that let you combine the text in
one document (called the main document here) with information in
another document (the merge document). Very often, your main

document will be some kind of form letter, while the merge document will be a list of names, addresses, and related information.
Microsoft's applications were designed to work together, so the
information you've put into File can be made available to Word as
a merge document. You can also create a merge document from
within Word. This chapter draws on the insurance agent's data file
that was designed in Chapter 4. (If you have that information in a
File data file already, continue with the next section in this chapter, "Making a File Merge Document." If you don't have the data
file, read through the next section, but prepare a merge document
as explained in "Making the Merge Document in Word.")

Making a File Merge Document
,

When you want a File document to be read by
Word, you have to save it in a special format. Open
File, and load the Client data file from Chapter 4. In

addition to saving the data file as a merge document, there are a few things that must be changed
to make the document more useful during the merge process.
When the Client data file is opened, choose Show Form and select
Microsoft File
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the Total field; double-click in it to open the Format window. Select decimal as the format and put in a zero for the number of
decimals.
Figure 5-1. Reformatting the Total Field
Format Number Field
Name:l Total

0

lndeH ((

OK

)J

I (cancel)

Display- Align- Style
0 General
0 Border
OLeft
0 Dollar
0 Center 0 Underline
0 Percent
0 Bold
®Right
®Decimal
0 Italic
0 Scientific Declmals:0 0 Commas

When you do comparisons with Word's merge option, you
can compare only whole numbers. By specifying zero decimal
places, the Total field shows only whole numbers. Now, choose
List Helper to line up the fields in the Form window and add three
text fields: Home?, Car?, and Life?. Rearrange the fields until
they're in this order:
FirstName
LastName
Street
CityState
Zip
HO policy
Home?
Car policy
Car?
Life policy
Life?
Total

Drag all the other fields into the hide area. The new fields are
going to be used as "yesjno" fields. Activate the Datafile window
and enter a yin the Home? field in each record that has a homeowner's policy; enter n if there's none. There's one exception-in
Sarah Billings's record, enter n in Car? even though she has an
auto policy. Complete the Car? and Life? fields similarly. You can
save the data file as it is now or sort it by last name before you
save it. If you want your records in a specific order when you
merge them in Word, they have to be sorted while still in File. To
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save the data file, choose Save As from the File menu. You'll be
asked if you want to save the changes with the data file; click
No-the changes were only for this merge document, not for the
data file itself. When the Save dialog box comes up, click the button for Text (Microsoft Print Merge) and save it as
ClientMailMerge.
Figure 5-2. Save the Altered Data File as Text
Soue Records Rs:

IClientMoiiMerge
Q Normol
® TeHt (Microsoft Print Merge)

File Moster

n Soue BI( Eject
Concel ] j [

Drlue

Since both the merge and main documents must be on the
same disk, it will save time if you save this document directly to
the disk you'll be using while working in Word.

Making the Merge Document In Word
To get an idea of how a merge document looks,
take a look at Figure S-3. It shows one created by
Microsoft 'w'ord

File.

Figure 5-3. Hard to Read

.n
0

)

FlrstNome LostNome
Cor poli cy Cor? Li fe policy Life? Totel
n
Soreh Billings
3487 Krump Road "Holifox, NJ"07198
A3 086 78-954
n
n
940
Jeremy
Clifford
387 Beldwin Street
"HelHex, NJ" 07198
H3 84624003
n
n
n
540
Wi lli em
Dykstre
89 Penny Lone
"Orenge, NJ"" 07893
A2 98736-865
y
n
827
!Hi\!
n
Cathy Gre t zky
907 Mis ty Park
··orenge, NJ" 07893
HI 73643957 !i!il!

~erem: ~~;~~:c: 874~~~~~~·ty Pe~k ;f;~ge,
2 96

NJ" 07893

illili

JemesJones 17 15 Eegle Drive "Elmwood, NJ"
07864
H3 87936039 ili!H
y
A2 65980- 098
y
LT 989-7809
y
1232
!!!!!!
Mery Ellen Jones 17 15 Eagle Drive "El mwood, NJ"
07864
Hili!
...
LT 989-6834
y
172
i:ili:
14
Street "Dover, NJ" 07302
H2 97685850

12!
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The words and phrases seem jumbled because the lines don't
fit on the screen properly. If you select the entire document,
change it to a 9-point font, move the right margin to the 9-inch
mark, and place tabs at intervals, it's easier to see how the information is stored.
Figure 5-4. After Formatting

Sarah
JtrtffiiJ
William
Cathy
J trtffiiJ
Jamu
Mary Elltn
John
Gorald
Robin

Dykstra
Grttzky
Grotzky
Jonu
Jonu
Mtssinoo
Zimmormann
Zimmormann

3487 Krump Road
387 Baldwin Stroot
89 PtM\1 LaM
907 Misty Park
907 Misty Park
171 S Eaglo Drivo
171 5 Eaglo Driv•
14 Taylor Stroot
27 Hollow Road
27 Hollow Road

Cit11 Stott
"Halifax , NJ"
"Halifax, NJ"
"Oran<J•, NJ"
"Orango, NJ"
"Orang• , NJ"
"Elmwood, NJ"
"Elmwood, NJ'•
"Dovor,NJ'•
"Cliffsldt, NJ"
"Cliffsldo, NJ"

&

Car policy
A3 08678·954

Ztp
07198
07198
07893
07893
07893
07198
07198
07893
07893
07893

H3 84624003

n
n

H173643957
••
H3 87936039

y

A2 6S9

ili!ii

H2 9768S8SO
""
H2 87363033

y
n
y

A3 874

l!:IJ!

:~ ::i il,l'l
~~~lj~

&

n

lift?

Total

n
n

940
S40
827
1259
208
1232
112
1577
892
1922

A2 98736·86:5
A2 96365-874
112 65980-098

y

A3 87435-483

n
n
y

LT
LT
LT
LT
LT
LT

874-8732
989-7809
989- 6834
964-9875
:567-4373
329-4857

y
y
y

y
y
y

!lW~

IIII
!IIIII
~mn

Each record, or group of information, is in a single paragraph;
the items in the records are separated by tabs, and the end of
each record is indicated by an invisible "Return" character. (You
can see the Return characters if you choose Show Paragraphs from
the Edit menu.) The field names, or headers, are shown in boldface and occupy the first line of the document. They, too, are
separated by tabs and end with a Return. There are quotes around
the items in the CityState field-any phrase with a comma has to
be enclosed by quotes in order to be treated as a single item.
Blank fields have a set of empty quotes in them. To create your
own merge document right within Word, you can type the document to match the one that File created; or, using the information
shown in the formatted document, you can type the merge document with either or both of the following variations:
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• Empty quotes do not have to be used for blank fields-you can
tab past the blank fields, leaving them completely empty.
• Commas can be used to separate the fields instead of tabs.
That's why an item which contains a comma must be enclosed
by quotes-the comma would be mistaken for a field separator.
If you use commas instead of tabs, an empty field must be indicated by an extra comma.
The beginning of the first entry could look like this:
Sarah Billings 3487 Krump Road 11Halifax, NJ" 07198 "" n

Or it can look like this:
Sarah,Billings,3487 Krump Road,"Halifax, NJ,"07198,n

Make sure that the field names are on the first line of the merge
document. They can be separated by commas instead of tabs, too.
Save the document under the name ClientMailMerge.

Creating a Main Document
The main document that you write in Word contains the text
which you want on every printed copy as well as indicators for
what is to be inserted from the merge document. Indicate the item
you want from the merge document by using its field name enclosed by special merge characters. Using this system, the salutation in a letter might look like this:
Dear «FirstName>>,

EJ
'Option)

IOpt1onl

[][]
«

»

Merge ]
( Characters

The opening merge character ( <<) is available as the Option-back slash character; the closing merge character (>>) is the Option-Shift-back
slash. (The back slash is the one over the right
side of the Return key.)
The first line of a main document must be
the name of the merge document from which the
data is to be obtained. The DATA statement is
used, followed by the name of the merge document-all enclosed by the merge characters. The
document shown in Figure S-5 will print out
personalized letters to all the agent's clients.
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Figure 5-5. Main Document
Main Document

2

10

••

~

4

5

-

<<DATA ClientMeilMerge»
<<FirstNome , <<LestNeme,
<<S treet»
<<C ityStote» <<ZiP»
Deer <<Fi rstNome »:
Just e brief note to remind you thet our Open House is
scheduled for e week from Seturdoy, on June 7 . Vou ore
we l come to drop by eny time between 10:00 o.m. end 4:00p.m ..
Coffee end ceke w ill be served throughout the doy. 1 hope to see
you then.
Sincerely,

There are some important things to note
about this document. First, the DATA statement at
the top tells Word which merge document to use
for the information. Notice the space between the
merge characters of the FirstName and LastName
fields. This means there will be a space printed
between the first and last names in the letter.
Printer ~e~up.. .
There's a space between the CityState and Zip
Quit
sc o fields for the same reason. A colon immediately
follows the FirstName field in the salutation-anything not enclosed by merge characters is treated as normal text in
a Word document, so the colon will be printed right after the inserted name. To print out the letters for this document, first save it
under any name you wish, then choose Print Merge from the File
menu.
The merge document does not have to be open for the merge
to work; Word can read it directly from disk. If you have the
merge document open, make sure that the main document is in
the active window before you choose Print Merge. The standard
printing options will appear so that you can set the parameters
you want. When you click OK, ten personalized form letters will
be printed.
3€ N
New
3€ 0
Open ...
se w
Close
3€S
Saue
SoueRs ...
Poge Setup ...
Print...
3€ P
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Figure 5·6. Form Letter
Jeremy Gretzky
907 Misty Park
Orange, NJ 07893
Dear Jeremy:
Just a brief note to remind you that our Open House is
scheduled for a week from Saturday, on June 7. Vou are
welcome to drop by any time between 10:00 a.m. and 4:00p.m ..
Coffee and cake will be served throughtout the day. 1 hope to
see you then.
Sincerely,

You can save the main letter just as you would any document. You might consider identifying Word documents as merge or
main documents. The merge document has the word Merge in it,
so you could save this document as OpenHouseMain. Using Merge
and Main as suffixes on all such documents will save time later.

Enhancing the Main Document
You can easily add two things to the OpenHouse letter to improve
its looks. First, the current date can be printed on each letter by
using the SET instruction. SET lets you define a field right in the
document. Using the new field name later in the main document
puts the defined piece of information in all your printed copies.
Change the heading of your letter to:
<<DATA ClientMailMerge»
<<SET date=May 23, 1985>>
<<FirstName»
<<LastName»
<<Street>>
<<CityState»
<<date>>
Dear «FirstName»:

Note that the merge characters enclose both the SET instruction and the definition, and are also used around the new field
name later in the letter. As an additional enhancement, you can
have the name and address printed in boldface. Whatever style is
used for the field name in the main document is the style in
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which the items will appear in the finished
just the point size and the font this way, to'
address fields and make them bold-either
menu or by pressing Command-Shift-B. It <
merge characters are also bold, so you can s
names at once, including the merge characte
date field so that the date appears in italics.
document now looks like Figure S-7.
Figure 5-7. Enhancements

«DATA CllentMe!IMerge,
«SET dete=Mey 23, 1985>>

cflrslNIIme,. cliiSlNIIme»
cSlreet,.
cCityStete. cZiP»

Deer «FirstNeme,,:

Letters printed with this new main documet
similar to the one shown in Figure S-8.
Figure 5·8. New, Improved Form Letter
Jemes Jones
1715 Eegle Drive
Elmwood, NJ 07693
1'16,Y :.?.)_. I 9ll5

DeerJemes:
Just e brief note to remind you thet our Open House i s
scheduled for e week from Seturdey, on June 7. You ere
welcome to drop by eny time between 10:00 e.m. end 4:00p.m..
Coffee end ceke will be served throughtout the dey. 1 hope to
see you then.
Sincerely,
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Conditional Instructions
You can create a main document that will have information inserted from the merge document only if a certain condition exists.
For such conditional insertions, the IF instruction is used. The IF
instruction and the condition are placed between the merge
characters. The "condition" is usually one that looks at the contents of some field in the merge document. If you want something
printed only if a client has a homeowner's policy, for instance,
you would check the Home? field:
« IF Home?= y"»
When the test condition (the y is the test condition in the
statement above) is something other than a number, it must be
placed in quotes. The text you want included in the letter if the
condition is met comes immediately after the merge characters. To
print the word HomeOwner, followed by a colon and the policy
number, you would use
« IF Home? = "y"» HomeOwner: « HO policy»
11

Figure 5·9. Conditions
Main Document
3
«DATA Cl i entMail Merge»
«Fi rstName>> <<Last Name>>
,, street,,
,,citystat e,, <<ZiP>>

Deer <<Fi r slNeme>>:
It's time for our ennual confer ence--can w e make 11 date to di scuss
your current insuronce, as w ell es possible edditions to your coverege?
I'll be ceiling nex t week t o se t up e con venient time f or our meet ing.

Si nce r ely,
Page 1

The field name HO policy is enclosed by merge characters so
that the information will be taken from the merge document. Another instruction, ENDIF, is placed in merge characters at the end
of the conditional text. In the example you've built so far, the HO
policy field is part of the conditional text, because you want the
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policy number printed only when there is a policy. The ENDIF
instruction thus comes after the HO policy field:
«IF Home?="y''»HomeOwner: «HO policy>> <<ENDIF>>

This document, with its right-justified lines of IF instructions,
will print letters which include the clients' policy numbers in the
heading.
This is one of the letters that would be printed when the
documents are merged:
Figure 5-1 0. A Conditional Form Letter
Cathy Gretzky
907 Misty Park
Orange, NJ 07893
HomeOwner: H 1 73643957
Car: A2 96365-87 4
Dear Cathy:
It's time for our annual conference--can we make a date to
discuss your current insurance, as well as possible additions to
your coverage? I'll be calling next week to set up a convenient
time for our meeting.
Sincerely,

Without the IF command, every letter would have the policy
title printed, regardless of whether or not there was a policy number to follow it. Some of the letters would end up looking like
this:
HomeOwner: H3 98474-298
Life:
Car:

Correcting the Merge Document
The first letter that's printed out with the last example is one to
Sarah Billings, and it has no policy numbers at all; this was the
record in which you entered a mistake, putting an n in the Car?
field. Since the merge document, even if it was created by File, is
a Word document, you can easily edit any mistakes. Open the
document ClientMailMerge and find the n in the Car? field of the
first record.
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Figure 5-11. Correcting Mistakes

=o
0

>

CllentMei iMerge
ll~

1.1

14

IS

•

FirstNome LastName
Street
CituState
Zip
Ho pohcy
Home?
b
Car policy Car? Life pl c hange this "n.
Sarah Billings
to a •y••
3487
}J"07 198
n
!ill!!
A3 08678-954
n
Jeremy
Cliffortl
387 Baldwin Street
"Halifax, NJ"07198
Iiiii·
....
H3 84624003
n
n
n
540
m~l:

--

--

Replace then with a y. Assume you noticed in your printouts
that Jeremy Clifford's records are not current. Although the latest
information has been entered in the File data file, that was after
this merge document was created. Correct the second record in
the merge document to reflect the fact that Mr. Clifford just insured his three cars:. Enter the policy number A3J98766-578, put a
y in the Car? field, and change the Total field to 1357. Now you
want to print only two letters, for the corrected records. With the
merge document still active, highlight the header (field names)
and the first two records and copy them. Open a new document
and paste in the copied material. Save the new document under
the name Corrections.
Go back to the main document and change the DATA statement to
« DATA Corrections»

If you use the Print Merge command again, only the two corrected records will be printed, because Word will look at the
Corrections merge document. Since it has served its purpose, you
can delete it from your disk at any time- the corrections are
permanently stored in the ClientMailMerge document. Change the
DATA statement back to
« DATA ClientMailMerge»

for the next section.

Or ELSE
A variation of the IF instruction allows you to specify text that
should be inserted if the stated condition is not met: the ELSE
instruction. The following main document tests for the value
stored in Total. Since that value is a number, the test condition is
not in quotes; and since it's a number, you can use the mathematical symbols for greater than (> ) and less than (< ), as well as the
equal sign.
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The agent sends each client a gift for the holidays. The value
of the gift is based on whether the client pays more or less than
$1,000 a year in premiums. This one document covers both
. situations.
Figure 5- 12. Gift Document
!10

Main Document
«DATA CltentMaflMerge>>
«SET date=November 23, 1985»
<<FirstName, <<LastName,
,,street,
<<CilyState» <<Ztp,

Dear <<FtrstNome,:
We wont to wis h oll our customers o heppy holidey.
Our ogency ts hosting en open house on December 5.
Pleose come by for coffee and coke, ond to receive o ho11dey
gift.
<<IF Total < I 000» You moy choose from on assortment of
steined-gloss window decorotions with o ho11dey theme; come
by eny ttme between 12:00 cmd 2:00.
<<ELSE, A photogropher wi ll be present to teke o fomfly
portrait; the beautiful I 0 x 13 co lor portreit will be sent to
you within two weeks. Come any time between 3:00 end 6:00.
<<END IF,
PI eose j ol n us t f you con.
Si ncerel y,

P.S. Consi der the enclosed persona11zed eddress lebels o
"Thank You· for placing your confidence In our ogency.

The two letters printed from this form will look like Figures
5-13 and 5-14.
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Figure 5-13. Inexpensive Gift Letter

Dear Mary Ellen:
We want to wish ell our customers a happy holiday.
Our agency Is hosting an open house on December 5.
Please come by for coffee and cake, and to receive a hol1day
gift.
You may choose from en assortment of stained-glass
window decorations with a holiday theme; come by any time
between 12:00 and 2:00.
Please Join us if you can.

Figure 5-14. Expensive Gift Letter

Dear Jeremy:
We want to wish all our customers a happy holiday.
Our agency is hosting en open house on December 5.
Please come by for coffee and cake, and to receive a holiday
gift.
A photographer wtll be present to take a fam11y portrait;
the beautiful 10 )( 13 color portrait w111 be sent to you wtthtn
two weeks. Come any time between 3:00 and 6:00.
Please join us if you can.

-

Making Lists
So far, every merge you've done results in a separate printed letter for each record in your merge document. Using the NEXT
command, you can get information from all the records into a
single printed document. Before sending out the holiday letter to
all his clients, our mythical agent sent a client list to his manager,
since it was her responsibility to provide the labels for sending out
the gift letters. The document looked like this:
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Figure 5-15. List Document

:o
0
••

5

«DATA CllentMallMerge >>

Suzanne:
The follo wing Is 11 li st of clien t s ond oddresses for the promot10nal
labels. See you at the monthly semlnorl
«FirstNome>> « lllstNome>>: ccSTREET >>, «CITYSTATE>>
«Firs tNome>> « llls tNome >>: « STREET>>, «CITYSTATE>>
«FirstNome>> « lllstNome >>: « STREET >>, « CITYSTATE>>

«ZIP>> « NEXT>>
«ZIP>> « NEXT>>
« ZIP>> «NEXT>>

~--------------------------------------------------------~
«Firs tNome>> « llls tNI!me ,,: « STREET>>, « CITYSTATE>> «ZIP>> «NEXT>>
«FirstNome>> « llls tNome >>: « STREET>>, «CITYSTATE >>
Poge

2

Note that the names are in boldface and the rest of the information is in Word's Small Caps option .
When you use the NEXT command, the information in the
next record is accessed without a new form being printed. Although you must have one line of information in your main document for every record you want included in the list, it's easy to
type the line once, then copy and paste it as many times as necessary. The final line doesn' t use the NEXT command at all.
The letter printed by this merge is shown in Figure 5-16.
Figure 5-16. List Letter
Suzonne:
The following is 6 lfst of clients end eddresses for the promoti on
lebel s. See you et the monthly s emlnorl
S11r11 Billing s: 3487 KRUMP ROAD, HAliF AX, NJ 07198
Jeremy Clffford: 387 8Al0\t'INSTREET, HALIFAX, NJ 07 198
Willi om Dykstrll: 89 PENNY LANE, ORANGE, NJ 07893
Cllthy Gretzky: 907 MISTY PARK, ORANGE, NJ 07893
Jeremy Gret zky : 907 MISTY PARK, ORANGE, NJ 07893
J11mes Jone s: 17 1S EAGLE DRIVE, ELMWOOD, NJ 07864
Mory Ellen Jones: 1715 EAGLE DRIVE, ELM'w'OOD, NJ 07864
John Mess Ineo: 14 TAYLOR STREET, DoVER, NJ 07302
Gerol II Zimmermonn: 27 HOLLO'w' ROAD, CLIFFSIDE, NJ 07305
Robin Zimmermonn: 27 HOLLO'w' ROAD, CLIFFSIDE, NJ 07305
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Some Final Notes
• When you use Word's merge option, it uses every record in the
merge document, whether or not it meets the criteria in a conditional merge. It's therefore possible to have an entirely blank
piece of paper scrolled through the printer during a print merge
operation. If you had used the condition
<<IF Total>lOOOO»

not one of the records would have met the condition. Yet, you
would still have a page, printed or not, for every record in your
merge document. If you want letters printed only for a subgroup
of records, select those records while still in File, and save the
subgroup as a separate merge document.
• The merge commands don't have to be typed in capital letters;
they appear in capitals in this text so they'll be easily seen. Any
combination of uppercase and lowercase letters is acceptable.
• The field names used in the main document are not case sensitive; that is, firstname, FIRSTNAME, and Firstname will all get
the information from the merge document field FirstName. However, since spaces are significant, First Name would not work.
• A print merge will not work unless the main document has been
named; this means you must save the main document before the
merge operation.
• If you'll be using the merge function with a File data file, plan
ahead: Sometimes you'll want a yesjno field, or a similar construct, to help with the merge. An especially convenient field is a
title field that would store Mr, Mrs, Ms, Dr, and so on, to use in
salutations.
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Accounting with Multiplan
Dan McNeill

In 1979, Daniel Fylstra, head of a small Boston
software firm, appeared at Apple Computer, Inc., to
demonstrate a new program. It was a spreadsheet,
an automatic calculating table-and a fundamental
innovation. Spreadsheets had never existed on any
computer, mainframe or micro, yet they proved to be the first serious business software for personal computers. Fylstra's program,
VisiCalc, was available only on the Apple II for almost a year.
Since it gave many people a compelling reason to buy this machine, it was a major factor behind Apple's success.
Multiplan is one of the best-known spreadsheets in the business. Like all spreadsheets, it displays a grid on the screen, somewhat like the mileage chart on a road map . You enter numbers or
letters into the grid and then manipulate them in a variety of
ways. Such a program has two virtues which make it well-suited
for accounting: large size and formulas.
Spreadsheets can be enormous. A table with only 5 or 6 rows
and columns would not profit much from computerization. But
most businesses maintain large, ongoing records with numerous
subcategories and entries, and for them the capacity of a spreadsheet is essential. Multiplan has 63 columns and 255 rows, for a
total of 16,065 cells. That's almost 10 percent of the number of
pixels on a Macintosh screen, so obviously these cells won't all fit
on the display at the same time. Instead, the screen acts like a
window onto the vast document beneath. You scroll that document up, down, or across the window, much as you scroll microfilm beneath a viewfinder, to see the whole record. The size of
spreadsheets makes it possible to create not only huge single
tables, but also to put several related tables on the same sheet for
easy cross-referencing.
Formulas give life to the spreadsheet, separating it forever
from paper and pencil. If you enter a formula into a cell instead of
a number or name, it will automatically calculate the value of the
cell as a function of another, or even several, cells. Suppose, for
instance, that you want to add up a column of figures. You enter
an addition formula in the total cell, and Multiplan finds the sum.
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When you alter any number in the column, the total changes instantly to reflect it. This power has made the spreadsheet almost
essential for financial management.
Spreadsheets do demand that you design your own layout, or
template. This requirement is the flip side of their great adaptability, and at first may seem complex and intimidating. Once you become accustomed to the environment, however, you'll find the
challenge not only relatively easy, but perhaps even enjoyable.
Template creation is something of an art, but it's an art anyone
can master.
In this chapter, you'll see some basic approaches to template
design and you'll create three accounting templates yourself. First,
however, a bit about Multiplan. A good part of the difficulty people
sense with template creation is really just difficulty in learning a
new program. Fortunately, Multiplan on the Macintosh is benign,
accommodating software, far easier to use than spreadsheets on
non-mouse-driven computers, and you'll grasp many of its powers
almost intuitively.

The Face of Multiplan
Spreadsheets like Multiplan have a distinctive structure, visible
as soon as you bring the program up on the Macintosh screen. A
lattice of dotted lines materializes, dividing most of the screen
into broad, short cells. Since these cells will contain data which
you'll want to refer to in formulas, you have to have some way of
naming them.
Hence, down the left appear the numbers 1 through 15, and
running across the top, 1 through 6. These are the row headers
and column headers, respectively. They indicate the number of
each row and column. The cell name derives from the intersection
of these rows and columns. Multiplan uses the abbreviations R for
row and C for column, and so expresses cell names as R1C5 or
R53C21. (This terminology is one of the few clumsy aspects of
Multiplan; most other spreadsheets use the cleaner letter plus
number syntax, as in 812.) The terms row and column may cause
some initial confusion, because we occasionally refer to vertical
series as rows, so it can take a little time to recognize cell locations
instantly. It may help to think of Rand Cas "Right" and "Chimney," the one being necessarily horizontal, the other vertical. If
you are ever unsure of the name of a cell you've selected, check
the cell reference box in the upper-left comer of the screen. This
box always displays it.
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When you boot up Multiplan, you' ll see cell RlCl darkened,
and RlCl in the cell reference box. Multiplan automatically starts
you off in the upper left of the spreadsheet-it has to start somewhere. The cell, like all darkened areas, is selected, and whatever
you type at this time appears in that cell.
Figure 6· 1. Your Multiplan Screen
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To select a diff~rent cell, click the cursor-the thick, white
cross in the middle of the screen-on a different cell, say, R6C2.
It turns dark, and cell RlCl becomes white.
You may want to see Multiplan's dimensions. To move it
horizontally or vertically, use the cursor to pull the squares in the
scroll bars, on the bottom and at the right. They'll zip you across
the entire spreadsheet. You'll also quickly see that the vertical
scroll bar is much more sensitive to tugging than the horizontal,
because Multiplan has so many more rows than columns.
Finally, like most Macintosh programs, Multiplan has a line of
menu names across the top. Of these, you may find yourself using
Edit and Format most often. In general, Edit lets you shift cell contents around, and Format adds trappings to them, such as dollar
signs and decimal points.
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Template Strategy
In a way, designing templates is like juggling. It looks harder than
it is, and with practice you develop the reflexes you need. The
main key is planning, and the five steps below provide a basic
guide to the template-creation process. Especially note that within
steps 2 through 4 is a suborder: (a) Selection, or placing the data;
(b) Entry, or getting it in; and (c) Formatting, or adjusting its
appearance. Of course, the entire schema is intended as a convenience, not a straitjacket. It's an aid to understanding, not apedantic regimen. Multiplan is very flexible, and you can and should
take advantage of any shortcut that suits your needs:
(1) Outline your spreadsheet on paper. You need only set
up the necessary labels, down the left andfor across the top.
These will form the skeleton of the template.
(2) Enter labels. Next, you transfer your framework to
Multiplan. This process entails (a) Selection-you must first select
the cell locations for your labels; (b) Entry-you then key them in;
and (c) Formatting-you may wish to center the labels or otherwise spruce them up.
(3) Enter data. Raw data-numbers and sometimes text-is
the meat on the matrix, and again it requires three steps: (a) Selection-the figures must go someplace; (b) Entry-Multiplan has
several shortcuts for data entry; and (c) Formatting-you may
want to add dollar signs, commas, and decimal points.
(4) Enter formulas. Formulas are the nerves of the spreadsheet. Here again you go through (a) Selection, (b) Entry, and (c)
Formatting. This tidy little order occasionally breaks down, however, since sometimes you must select and enter a formula, then
select and enter the raw data it will work on. We'll ignore this
problem and treat everything from formula entry on as Entry.
(5) Format the page. Once you've set up the spreadsheet, you
may want to embellish it. You can insert extra rows or columns,
add a title, alter column widths, and generally make the document more pleasing and easier to read. You can actually format
the page at almost any stage in the process, but we'll set it apart
and place it last to emphasize its distinctive and global nature.
Let's see these steps in action.

A Simple Spreadsheet
Suppose you're the head of the Wheel of Fortune Sales Company,
selling auto parts door-to-door. It seemed like a good idea at first,
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but business hasn't prospered, and you're down to two salespeople, Mr. Puget and Ms. Huron. You decide to analyze their
performance in Tulsa, Palm Beach, and Elko, the three cities they
worked last month. How do you begin?

On Paper, Outline the Spreadsheet
There are two variables: city and salesperson. You can list the
three cities down the left of the page and put a TOTAL row beneath them, then list the two salespeople across the top and put a
TOTAL column to the right of these. That's all you need. This 4
X 3 grid creates 12 squares for entry of data and formulas.

Enter the Labels
Since they form separate blocks-one column and one row-you
can do it in two chunks of selection/entry / formatting. First, let's
tackle the column :

Selection
• Drag the cursor from R2Cl to RSCl , darkening a four-cell column and leaving cell R2Cl enclosed by a white box.
Figure 6-2. Two levels of Selection
•

File Edit Select Formot Options Colculote

This, in effect, creates two levels of selection, indicated by the
white box and darkened block. The white box shows the entry
point, the cell where typed matter will appear. It's the immediate
selection. You can move the white box by pressing the Enter key.
The darkened column limits the extent of its movement and defines its course. This is the second-level selection, the selection of
where the immediate selection will appear.
Why have two selection levels? Because it simplifies data entry immensely. If the program lets you define the cells of a data
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block beforehand and determine the order of your entries, you can
just sit down and type, without having to select-and-enter, selectand-enter, over and over again. It's something like the difference
between delivering newspapers in one circular route throughout
the neighborhood, and returning home to pick up a paper after
each delivery. The Enter key is critical to this time-saving trick. It
does two things. First, it actually enters your material into the cell,
so you must press it after every entry. Second, it shuttles the
white box around, and you therefore have to master its movement
pattern, which resembles that of a typewriter carriage. Pressing
the Enter key moves the white box one cell to the right if possible.
If not possible, the box drops down one row and returns as far to
the left as it can. If it can move neither right nor down, it jumps
back to the first cell in the block. In the column already selected,
the selected box will move downward only.
Entry

• Type Tulsa and press Enter. The white box drops to R3Cl.
• Type Palm Beach and press Enter.
• Type Elko and press Enter.
• Type TOTAL and press Enter. The white box is now back to
R2Cl, the starting point.
If you'd entered text into these cells by clicking them one by
one, and then keying in city names, you'd still be at it.
Formatting

These names need no formatting. Multiplan aligns text to the left
automatically, and it looks fine in a lefthand column like this one.
Now let's repeat the selection-entry-formatting cycle with the
labels across the top:
Selection

• Drag the cursor from R1C2 to R1C4, darkening a three-cell row
(Figure 6-3).
Entry

• Type Mr. Puget and press Enter. The white box moves right, to
cell R1C3.
• Type Ms. Huron <Enter> and TOTAL <Enter>.
The names are now entered and, as before, aligned to the left.
Here, however, they look awkward, and they'll look downright
ugly after you type in the figures. So let's center them.
170

Chapter 6

Figure 6·3. Column Label Entry
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Formatting
• Pull down the Format menu.
• Release at Align Center.
You've now transferred your outline of the spreadsheet to the
software, and you're ready to start filling in the gaps.
Data Entry
It's easier to enter data after this smattering of Multiplan functions. The "data" in data entry refers to static information, figures
you already have rather than figures you'll derive. Thus, it will
occupy only six cells, three beneath Mr. Puget and three beneath
Ms. Huron.
Selection
• Drag the cursor from R2C2 across and down to R4C3, darkening
a rectangle of six cells, as in Figure 6-4.
Figure 6·4. Your Data Block
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You've selected the data block. To enter, you need remember
only to type left to right across one row, then the next, then the
last (Tulsa, Palm Beach, Elko).

Entry
• Type 3000 <Enter>, 2500 <Enter>, 800 <Enter>, 2700 <Enter>,
200 <Enter>, and 450 <Enter>.
Now the spreadsheet has all its raw data. As long as this area
is selected, however, you might as well make the bare figures refer
to real money.
Figure 6·5. The Data Is In
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Formatting
• Choose Dollar from the Format menu . The numbers now have
dollar signs, decimal points, and two extra zeros to the right.
• Choose Commas from the Format menu. The three numbers
greater than 1000 now have the appropriate commas. Choosing
Commas leaves a little check beside that option on the menu,
meaning that Multiplan will go ahead and add commas to all
other numbers. You may not want every figure in a spreadsheet
to have dollar signs and commas, since at some point a cluttered
look appears, but Multiplan certainly gives you the option.
Entering text and data gives you almost everything the
spreadsheet needs. Almost. It's like laying pipe and funneling
water toward the fountain. It's time to install that fountain and
watch it play.

Formulas
Formulas calculate numbers from other numbers on the sheet.
Clearly, the total row and column will contain such derived fig172
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ures. And, since every total cell will use the same formula, that
for addition, it makes sense to avoid entering that formula repeatedly. Note that here, as with label entry, you'll be entering formulas in two blocks. Start with Column 4.

Selection
• Drag the cursor from R2C4 to R4C4, darkening a three-cell
column.
Figure 6-6. Getting Ready for Formulas
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Entry
• Choose Paste Function from the Edit menu. The Paste Function
box appears, containing a list of formulas you can stick into cells.
• Pull this box's scroll bar down to reveal SUM(). This formula
adds the contents of a series of Multiplan cells.
• Click SUM().
Figure 6-7. Summing
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• Click the OK box. =SUM() will appear at R2C4. But the formula
is not complete. You have to fill in the parentheses, telling it
which cells to add. To do that, you must detour briefly into
selection again.
Figure 6·8. The Formula 's Not Quite Ready

• Drag the cursor from R2C2 to R2C3. A tightly dotted rectangle
now encases the two cells, nearly invisible.
• Press Enter.
The formula disappears from R2C4, and in its place is the
sum of R2C2 and R2C3. However, the formula remains the bedrock entry in the computer. The number at R2C4 is merely what
the computer displays and prints out. If you change the contents
of either R2C2 or R2C3, the amount in R2C4 will change
accordingly.
You still need to place the addition formula in the darkened
cells R3C4 and R4C4. However, since it's the same formula as the
one in R2C4, you can take a valuable shortcut. You can fill down.
Entry
• Choose Fill Down from the Edit menu.

Suddenly, the two new cells also have numbers in them. Fill
Down copies the formula at R2C4 into all selected cells below it. It
also conveniently adjusts the cell references, so the formula in
R3C4 refers to the amounts in Row 3 rather than Row 2, and
R4C4 to Row 4. Note that the white box was in the middle of the
column when you chose Fill Down and thus does not have to enclose the cell being copied. Multiplan works from the top cell in
the darkened area.
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Figure 6-9. Fill Down
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Formatting
• Choose Dollar from the Format menu.
Now the TOTAL column looks like the rest of the spreadsheet.
Let's use the same procedure to enter formulas into Row 5, across
the bottom.
Selection
• Drag the cursor from RSC2 to RSC4, darkening a three-cell row.
Figure 6-1 0. Totals Block
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Entry
• Choose Paste Function from the Edit menu.
• Click SUM().
• Click OK. Now enter contents for the formula .
• Drag the cursor from R2C2 down to R4C2, enclosing a three-cell
column with a dotted line.
• Press Enter. The sum of Mr. Puget's efforts appears in cell RSC2.
You then copy the formula across the row.
• Choose Fill Right from the Edit menu. The totals appear, and
again you should transform them into dollars and cents.

Formatting
• Choose Dollar from the Format menu.
Figure 6-11 . The Sample Spreadsheet
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Now you have a Multiplan spreadsheet. But look at it. It's
crammed into the upper-left corner. Too crowded. The page needs
serious enhancement.

Page Formatting
It's best if you first plan your formatting goals. The spreadsheet
will look better if you (1) put spaces between Rows 1 and 2, and
Rows 4 and 5; (2) dislodge it from the corner and center it; (3)
widen the city name column slightly; and (4) give the document a
title.
Multiplan has a quick way to add blank rows:
• Place the cursor on Row header 2, one of the numbers on the
·
left.
• Press the Shift key. This turns the cursor from a cross to a device
resembling a brick with an arrow pointing down from it.
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• Click the mouse button. The Macintosh whirs a bit, and Rows 2
and below shuffle down one. The contents of former Row 2 are
now in Row 3, Row 3 in Row 4, and so on. The new Row 2 is
blank.
• Release the Shift key.
Now place the cursor on Row header 6 and perform the same
operation: Shift, click, release Shift. The TOTAL row detaches from
the rest of the spreadsheet. It's easy at first to get confused about
where to place the cursor. It may help to think of the brick-andarrow cursor as glued to the row header it stands on, prepared to
separate it from all above.
Centering the spreadsheet is simple. To add three blank rows
at the top, place the cursor on Row header 1, press Shift, and click
three times. Three blank rows appear above the document. You
can move the spreadsheet to the right by essentially the same
method:
• Place the cursor over Column header 1.
• Press Shift. The cursor becomes a brick with an arrow toward
the right.
• Click the mouse. The spreadsheet inches to the right one column, leaving Column 1 blank.
• Release Shift.
Next, you'll need to widen the city name column, now Column 2. Again, Multiplan has a special feature to perform the task:
• Place the cursor on the right-hand edge of the header of the column you wish to alter. Here, it goes on the line between 2 and
3. Note that again it changes shape, becoming a vertical line
with arrows right and left.
• Click and move the cursor to the right as far as you want.
Release.
Note that you expand Column 2 at no sacrifice to the other
columns, which retain their original width. Moreover, if you want
to narrow a column, as you might if it contained, say, a list of
two-digit numbers, you simply move the cursor left instead of
right.
Finally, let's give the document a title. Call it Performance of
Salespeople and place it on Row 2. To center it properly, you'll
need to begin about two-thirds of the way across cell R2C2:
• Click R2C2.
• Press the space bar until you're about two-thirds across. The cell
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stays dark until you type a character, so if you aren't sure where
you are, type anything, then press Backspace to erase it.
• Type Performance of Salespeople. You'll see only a few letters
in R2C2, but the whole phrase appears above in the formula bar
to the right of the cell reference box.
• Press Enter. The walls of cells R2C3 and R2C4 disappear, and
the entire title appears across the top of the spreadsheet.
Figure 6-12 . The Finished Product
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You now have a real, working spreadsheet, humble though it
is. You've gone through the five main steps, and seen several
ways of selecting, entering, and formatting material. But there's
much more to Multiplan than this example suggests.

Some Shortcuts
Multipla n has numerous shortcuts which can save considerable
time in creating spreadsheets. These shortcuts can also give you
a greater sense of spreadsheet competence and improve your
appreciation of the program.

Selection
Multiplan lets you select more than just single cells, short rows
and columns, and rectangles. It permits selection of the following
items:
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Unconnected areas. You can select several separated areas at
the same time, then Enter. This feature is very important. For instance, you could have selected both label areas in the example at
once and then simply typed in all labels. To do so, you need to (1)
select one area, (2) hold down the Command key ( 38 ), and (3)
select all other areas. For instance, in the spreadsheet above, you
would:
• Drag the cursor from R2Cl to R5Cl, darkening a four-cell column, and release the mouse button.
• Press Command.
• Drag the cursor from R1C2 to R1C4, darkening a separate threecell row.
• Release Command.
Now, two distinct blocks are selected. Once again, for smooth
typing, you have to understand the order in which the white box
moves. With two blocks, as here, it simply proceeds through one,
then jumps to the upper-left cell of the other. With three or more
blocks, the white box follows the order in which you selected the
blocks. If your blocks are individual cells, you can return the
white box to the starting point after selection by pressing the Enter key.
However, if your blocks are quite large, you have to keep
pressing Enter- while the white box progresses through the final
block-before it will hop back to the start. You can eliminate this
irritation by selecting your second block first, then your third, and
so on-and your initial block last.
Irregular areas. You can select irregular areas (like T-shaped
areas) by selecting two different blocks adjacent to each other. For
entry purposes, however, the computer still sees them as different
blocks, and the white box progresses through them one block at a
time.
Entire row. To select all 63 cells in a row, dick the row
header. The row goes dark.
Entire column. To select the 255 cells in a column, click the
column header. The column goes dark.
Entire spreadsheet. To select every cell, pull down the Select
menu and release at All Cells. The whole spreadsheet goes dark.
Entry
Multiplan also has several shortcuts for entering information:
Cell copying. Fill Down and Fill Right replicate cell contents
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down or across many other cells. But you may just want to duplicate a cell or block of cells at another location, without releasing a
string of clones along the way. You can do so by following a
procedure very similar to Cut and Paste in Microsoft Word:
Selection
• Select the area to be copied.
• Choose Copy from the Edit menu.
• Click the cursor at the upper-left corner of the area you wish to
copy to. An insertion point, a dark cross with its lower and
right-hand bars elongated, appears. This marker indicates the
area to receive the copied material.
Entry
• Choose Paste from the Edit menu.
(If you wish to move cell contents without leaving an original behind, choose Cut from the Edit menu instead of Copy.)
Formulas. Paste Function provides one way to enter formulas
into cells, but there are several others. You can, for instance, simply
type the formula in, entering cells by clicking them. For instance:
• Type = (equal sign). You must begin every typed formula with
this character. Otherwise, Multiplan will think you're entering
text.
• Click the first cell of the formula, say, R5C2.
• Type an arithmetic operator, that is, + (addition), - (subtraction),
* (multiplication), I (division), % (percent), or " (exponentiation).
If you want to add, you can omit the operator. Multiplan also
has comparison operators, such as = and>.
• Click the next cell of the formula, say, R3C6.
• Continue until your formula is complete.
• Press Enter.
When you click a cell, Multiplan does not enter its cell name,
such as R3C6, but rather directions to the cell, such as RC[-4].
This method means that you can fill down formulas, and they'll
refer to the contents of their own rows or columns, as you saw in
the example. Instead of clicking cells, you can type their cell
names in if you like, and Multiplan will carry out the formula.
You can also use the Define Names option, as Multiplan's manual
explains.
Retracting mistakes. If you're mortal, you'll occasionally enter a piece of data incorrectly. Whenever you want to take anything back:
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• Choose Undo from the Edit menu.
The exact name of this helpful function changes according to
the act it's ready to undo, but it's always the first option on the
Edit menu. If you undo something, then want it back, you can
also undo the undo. However, you can withdraw only the last
thing you did. You can't keep choosing Undo till you're halfway
back through spreadsheet creation. To simply erase a selected cell
or block:
• Choose Clear from the Edit menu.
The Clear command is something of a roving garbage disposal, and most people find it very helpful.

Formatting
Multiplan has useful formatting tricks as well:
Changing all column widths. You can alter the width of all
columns in a few quick steps:
• Choose All Cells from the Select menu, darkening the
spreadsheet.
• Choose Column Width from the Format menu.
• Type 16.
• Click OK.
The columns are all now 16 characters wide.
Splitting the screen. You may have reason to work on two,
three, or four different parts of the spreadsheet at once. Rather
than going back and forth, you can split the screen into different
panes and operate on them simultaneously. The more panes you
have, of course, the less screen space each will have, though you
can set their size. Each pane gives you a window onto the whole
spreadsheet, so you could also, if you wanted, examine the same
section of Multiplan in four different panes. The panes have their
own scroll bars, so you can move them around independently of
each other. Here's how to create them:
• Place the cursor atop one of the small, black split bars. There are
two of them, located to the left and on top of the scroll bars.
• Drag the split bar into the scroll bar. To create two panes of
equal size, drag it halfway through. Twin solid lines now bisect
the screen, and two scroll bars have appeared where once there
was one. By dragging the white square in either scroll bar, you
can move the panes about.
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This much introduction will take you far. It's still not everything Multiplan can offer, but it gives you the groundwork. Let's
start creating some elementary accounting templates.

Accounts Receivable
We'll begin with a spreadsheet to keep track of accounts
receivable.
The first step is to ask, "What do I want such a spreadsheet
to do?" Of course, you want it to indicate the total accounts
receivable so that you can post this amount to the general ledger.
This task entails adding the debits for a certain period, adding the
credits, and subtracting the credits from the debits. As the sample
spreadsheet indicates, Multiplan will not groan under the weight
of this task.
Second, you should be able to isolate individual accounts, to
stay up-to-date on their status. A typical accounts receivable ledger contains separate accounts for each customer, and you enter
credit transactions into them as they occur. These accounts are
physically separate, on different pieces of paper. Conceivably, you
could arrange them all alphabetically on one list, with Customer
A's debits and credits appearing, then Customer B's, and so on.
To maintain alphabetical order on paper, however, you would
have to wedge new transactions in between old ones, and the list
would quickly become a jumble. On Multiplan, this barrier disappears. You can therefore include (a) a means of alphabetizing
customers' names and (b) a means of checking the current balance
on each customer's account.
Finally, you can add a few optional extras. Suppose you're
running a retail furniture outlet. You might want to note the item
purchased after each debit. You also might desire some indication
of the nature of the credit entries-usually cash, but sometimes
returns, allowances, or other things. You would, of course, want
the date of each transaction and the posting reference.
A skeleton outline of the spreadsheet is already apparent. In
the upper left will appear the Totals block: total debits, credits,
and overall balance. Conventionally, totals have appeared beneath
a column of figures because some person has had to use that column to add them up. But since Multiplan calculates figures automatically, you can put totals wherever you want, and the upper
left is a salient, easily referenced spot.
The main block of data will spread out beneath. Each row
will be devoted to a single transaction, and the columns will give
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you information about that transaction. You can create the following columns: Date, Customer, Code, P.R. (Posting Reference), Item,
Debit, Credit, Credit Type, and Balance. To find totals of individual
accounts receivable, you have to give each customer a numerical
code, hence, the Code column. The Balance column will contain
these running totals themselves.
You could extend the columns further to the right and include
information regarding, for example, aging the receivables. For instance, you could create a series of columns for overdue bills, with
headings like 1-30 Days, 31-60 Days, and so forth, and these
might give you valuable information about uncollectibles. But let's
stick with the kernel of the spreadsheet here.
Putting the template on Multiplan is next. Step 2 involves
entering the labels. You'll start by selecting the whole label area
at once, going from the second block to the end, and back to the
first, so the white box winds up in the upper left, where you want
to start.
Figure 6-13. Accounts Receivable Selection
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Selection
• Click R6C2, for Credit Total. This will be the second block in the
string.
• Press Command.
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• Click R8C2, for Balance Total. This block will come third.
• Drag from R12Cl across to R12C9 and release. This nine-cell label row extends beyond the screen, but when you pull the
cursor to the edge, the screen scrolls automatically to the right.
• Drag from R4Cl to R4C2, for TOTALS and Debit Total.
• Release Command.
The white box is in R4Cl, and you're ready to enter.

Entry
There are four blocks here, and so the order of entry must be figured out. The white box goes from R4Cl to R4C2, then jumps.
Where? It drops to R6C2, Credit Total, which is where you began,
and then follows the order of selection.
• Type TOTALS <Enter>, Debit Total <Enter>, Credit Total
<Enter>, Balance Total <Enter>, Date <Enter>, Customer
<Enter>, Code <Enter>, P.R. <Enter>, Item <Enter>, Debit
<Enter>, Credit <Enter>, Credit Type <Enter>, and Balance
<Enter>.
Now you face only the problem of appearance. You should
center these heads, of course. But let's first adjust the column
widths. The label Balance Total juts into the adjoining cell, and
there's no reason to wait till the end to eliminate this irritation:
Formatting
• Place the cursor between Column headers 2 and 3, and pull it
through 75 percent of Column header 3. Release.
• Narrow Columns 3 and 4-Code and P.R.-to 60 percent of their
current size.
• Expand Column 5-Item-by an additional 75 percent.
• Choose Align Center from the Edit menu.
The labels are now all entered, and the spreadsheet has rudimentary shape. It should look like Figure 6-14.
Step 3 is entry of raw data. Because of the formulas in the
Balance column, there are certain strictures which must be obeyed.
The customer code must be entered exactly, and two people cannot have the same code. Customer names should not vary,
though slightly more latitude is available here. But if you enter an
individual once as Smith, Bill and next as Bill Smith, this spreadsheet will think them different people. Finally, be certain to leave
Row 13, the row beneath the main label row, blank. It's more
than a matter of esthetics.
184

Chapter 6

Figure 6·14. Accounts Receivable Skeleton

Selection
The block for raw data in your model is seven rows deep-there
have been seven transactions-and extends from the Date column
on the left through the Credit Type column, Column 8. It does not
include the Balance column, which will be all formulas.
• Drag from R14Cl down and across to R20C8. This block again
covers an area wider than the screen.
Entry
The entry plan here is extremely simple-left-to-right, down, Return, left-to-right. You can also enter the transactions in any order
you want, for you're going to arrange them alphabetically and,
within each group, chronologically. However, be sure to format
dates with two digits for each variable, like 03 JOB /85 rather than
3/8/85. If you omit the zeros, Multiplan will treat 3J11J85 as if it
comes before 3JBJ85.
• Enter the unordered data (see Figure 6-15).
Figure 6·15. Data Entry
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Formatting
Now you should sort chronologically and alphabetically. As between two sorts on a list of data, one must take precedence over
the other. The dominant sort determines overall rank; the subsort
ranks items equal on the dominant sort. The dominant sort is always done last so that it can have finality. The dominant sort here
is the alphabetical, so you'll begin with the subsort, the
chronological:
• Select R14Cl through R20Cl, darkening seven cells in the Date
column.
• Choose Sort from the Edit menu. When the dialog box appears,
leave it at Ascending Order. Now the transactions are displayed
chronologically, and you can sort alphabetically.
• Select R14C2 through R20C2, darkening seven cells in the Customer column.
• Choose Sort from the Edit menu. Again, leave it in Ascending
Order.
Data entry is now complete. Individual customers are isolated, and their accounts displayed in chronological order.
Figure 6-16. Sort Selections tor Accounts Receivable
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All you need now are the formulas to quicken the table.
Step 4 involves devising and entering formulas. The formulas
here will be of two different degrees of difficulty. The totals formulas will be simple, and those in the Balance column somewhat
more complex. Let's start with the totals.
You have three totals: Debit, Credit, and Balance. Debit and
Credit totals are simply the sums of Columns 6 and 7, respectively. Balance Total is the difference between the two sums. Let's
do Debit Total first:
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Selection
• Click R5C2.
Entry
• Choose Paste Function from the Edit menu.
• Choose SUM().
• Click Column header 6. You've now entered all of the Debit column into the SUM formula.
• Press Enter.
The number 5780 appears immediately in R5C2.
Figure 6-17. Debit Total
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Repeat the process for the Credit Total:
• Choose Paste Function from the Edit m enu.
• Choose SUM( ).
• Click Column header 7, selecting the whole Credit column for
entry into the formula .
• Press Enter. The number 1825 should appear.
Balance Total is a difference rather than a sum, and no formula exists under Paste Function for differences. You have to enter
the formula yourself:
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• Click R9C2.
• Type =. The equal sign must kick off every direct formula .
• Click RSC2, type - (the hypen key acts as the minus symbol on
the Macintosh), and click R7C2. The formula is complete.
• Press Enter. The number 3955 should appear.
Figure 6·18. Balance Total

With the totals taken care of, you can finally move to Column
9, the Balance column. Consider the task. Each entry in this column
should indicate the status on that date of the customer's account.
Hence, you must know something about the previous balance in
the account. More precisely, you must know, first, if there is a
previous balance, and second, if so, what it is. If there is no previous balance, the formula is simply the current debit minus the
current credit. If there is a balance, the formula is that balance,
plus the current debit minus the current credit. Sound confusing?
Don't worry. Just follow the directions below and Multiplan will
figure it all out for you.
So you must first ascertain whether there has been a previous
balance. Since you've arranged the customers alphabetically and
chronologically, you could theoretically compare the name of the
current customer with the name of the previous customer. If they
differed, there would be no previous balance for the current cus188
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tomer. If they matched, there would be. However, the Multiplan
match formula refuses to work with text. It checks only numbers.
Hence, you have a column for numerical codes. Hence, too, you
need the blank row above the data block; otherwise, the formula
will compare numbers to labels and give an error message. The
strategy starts to make sense. What you'll do is ask the program
to compare the current code with the previous code. If they don't
match, you have a new account, and want only debit minus
credit. If they do match, you have an existing account, and want
previous balance, plus debit minus credit.
All this can be accomplished in the IF statement, one of the
more complex logic operations available in Multiplan. It has a
four-part structure. First is the command =IF. Then, within
parentheses, are three formulas separated by commas. The first is
the condition, the second the action to take if it's true, and the
third the action to take if it's false. For instance, suppose you
wanted to express
If A equals B, do 1, otherwise do 2

Using the IF statement, you'd write = IF(A = B,1,2).
With all this in mind, here are the steps to follow:
• Click R14C9.
• Type =IF(.
• Click R14C3, the Current Code.
• Type=.
• Click the cell above, R13C3, the Previous Code. (Note that since
Multiplan enters cell names in relative terms, it doesn't matter
that there can be no previous code here. This formula will work
fine on rows further down.)
• Type,. The comma ends the condition, and now you type in the
action Multiplan takes if the condition is true.
• Click R13C9, the Previous Balance.
• Type +.You don't have to type this plus sign, since if you type
nothing between clicks, Multiplan assumes you want to add. The
sign is included here only for clarity.
• Click R14C6, the Current Debit cell.
• Type-.
• Click R14C7, the Current Credit cell.
• Type ,. This ends the action if true. Now specify the action if the
condition is false and the two codes do not match.
• Click R14C6, the Current Debit cell.
• Type189
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• Click R14C7, the Current Credit cell.
• Type ). The statement is complete.
• Press Enter. The number 900 should appear in the cell. If you
look at the formula bar, you'll see the entire expression as
Mutliplan understands it.
Figure 6- 19. Balance Formula
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Now you need to enter this long formula into the rest of Column 9, so you'll call upon the Fill Down function.
• Select R14C9 through R20C9, a seven-cell column.
• Choose Fill Down from the Edit menu. The column fills up with
numbers. All the formulas are entered.
Remember, of course, that you've selected only cells R14C9
through R20C9. You could have extended the fill further down
into rows which as yet have no entries. In that case, the formula
would give zeros in the new cells, which would change as soon as
more transactions were entered. But unless you want a tower of
goose eggs in Column 9, you must remember to extend the formula every time you make new entries.
The spreadsheet now lacks only one thing: a title. This omission is easily remedied:
• Click R2C4.
• Type ACCOUNTS RECEIVABLE <Enter>.
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And that's it. The Accounts Receivable template is done and ready
to keep track of the credit you've bestowed.
Figure 6-20. Accounts Receivable Template
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After a time, you may want to print out the spreadsheet. The
screen provides a running indication of how many pages it will
occupy, by bold dashed lines. Notice that in Figure 6-20 there are
dashed lines between Columns 5 and 6, .and 11 and 12. There's
also a dashed line after every 39 rows. Since this spreadsheet is 9
columns X 20 rows, it will fit on two sheets of paper. When you
choose Print from the File menu, the computer will automatically
print the left part of the spreadsheet first, then the right. It will,
however, give you the entire two pages, down to Row 39. If you
want to limit printout to your actual spreadsheet, select it, then
click Selection in the Print dialog box.
You've done one whole, usable spreadsheet. It's very basic,
and if you want to expand it, you can easily add more columns to
the right. But it will work as is. And it leads right into a separate,
but related, spreadsheet, one for accounts payable.

Accounts Payable
Accounts payable are, of course, very similar to accounts receivable, except that you owe money rather than anticipate it. You
can therefore use the Accounts Receivable template as the framework for an accounts payable spreadsheet.
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The first step is to duplicate the existing template:
• Choose Save As from the File menu.
• Type AcctsPayable.
• Click Save.
After humming briefly, the Macintosh displays AcctsPayable on
the title line. Everything else looks the same, but in fact you're
now on a completely. different spreadsheet. AcctsReceivable is
stored in memory, and you have the copy, so you can alter it at
will.
Now, what do you need to do? First, you need to adjust some
labels. Customer is no longer apt, so replace it with Seller. ACCOUNTS RECEIVABLE becomes ACCOUNTS PAYABLE, and
Credit Type becomes Debit Type. Get rid of the Iterns column to
show a little more of what Multiplan can do. (You may very well
wish to retain it, with perhaps a new title of Explanation, to record
the nature of your expenses.) Moreover, since now your creditsyour obligations-exceed your debits-your actual paymentsyou must alter our Totals headings and formulas. You must also
enter completely new data, easy in concept, wearying in practice.
And finally, to act on this data, you need a slightly different Balance formula. Since here you're mainly adjusting a spreadsheet
rather than creating one from scratch, you'll proceed from block to
block: (1) Labels, (2) Totals block, (3) Data block, and (4) the Balance column, its own little world.
First, change the labels:
Selection
• Click R12C2, Customer.·
• Press Command.
• Click R12C7, Credit Type.
• Click R2C4, ACCOUNTS RECEIVABLE. This cell is your starting
point.
• Release Command.
Entry
• Type ACCOUNTS PAYABLE <Enter>, Seller <Enter>, Debit
Type <Enter>.
Next, clear the Item column:
Selection
• Click Column header 5.
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Entry
• Choose Clear from the Edit menu. Column 5 is now erased.
Eliminating the Item column leaves a column of blank cells,
as though the spreadsheet were hit by a vaporizer gun. In order to
join the halves, you must cut and paste.
Selection
• Drag the cursor from R12C6 down and across to R20C9, darkening a 9 X 4 cell rectangle.
• Choose Cut from the Edit menu.
• Click the cursor at the upper-left corner of R12C5. The insertion
point, the dark lopsided cross, appears.
Entry
• Choose Paste from the Edit menu.
Formatting
• Narrow Column 5, now Debits, to about 4/ 7 its current size so
that it equals Column 6. The labels are all set.
Figure 6-21. Totals Block
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Look at the Totals block (see Figure 6-21). Consider the headings. Debit Total is still on top even though in accounts payable it
will be the lesser figure, subtracted from Credit Total. You could,
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of course, leave them in this order. Multiplan doesn't care. But
then you'd have to change the formula under Balance Total, since
it subtracts the lower number from the higher. You'd also be stuck
with a strange-looking fossil from the accounts receivable document. So let's reverse the labels.
Selection
• Click R6C2, Credit Total. (You'll want to start entering data at

Debit Total.)
• Press Command.
• Click R4C2, Debit Total.
• Release Command.
Entry
• Type Credit Total <Enter> and Debit Total <Enter>.
Now go to the formulas themselves. The only one that needs
alteration is the Debit Total formula. The formula beneath the new
Credit Total label adds up the numbers in Column 6, which fortunately is now the Credit column by virtue of shifting to the left. It
doesn't need to be touched. The formula under Debit Total, however, adds Column 7, and instead should be adding Column 5.
Hence:
Selection
• Click R7C2. The old formula appears in the formula bar.
Entry
• Choose Paste Function from the Edit menu.
• Choose SUM().
• Click the header of Column 5, the Debits column.
• Press Enter. The number 5780 appears, and -3955 shows up as
the Balance Total as in Figure 6-22.
The Totals block is now taken care of-let's move to the data
block.
Selection
• Drag the cursor from R14Cl to R20C7, darkening alarge 7 X 7
rectangle.
Again, refrain from selecting the Balance column, for it's not
raw data. (Notice, however, that the numbers in it remain the
same. The relative addresses of the cells it refers to haven't
changed.)
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Figure 6·22. Altering a Formula
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~-Entry
• Type in the data, row by row, which you see in Figure 6-23. To
erase a cell you now want blank, such as R14CS, the first debit
cell, press Backspace and Enter.
Figure 6·23. Accounts Payable Data
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The data, now entered, must be sorted just as with the accounts receivable information:
Formatting
• Drag from Ri4Cl down to R20Cl, darkening a column of seven
dates.
• Choose Sort (Ascending) from the Edit menu.
• Drag from R14C2 down to R20C2, darkening a column of seven
sellers.
• Choose Sort (Ascending) from the Edit menu.
The sellers are sorted alphabetically and subsorted chronologically by date of transaction. The formula in the Balance column can now work.
·
Let's look at that Balance column. The formula is still
subtracting credits from debits. But, since credits are now larger
than debits, you really want the reverse. In all its intricate finery,
you want the Balance formula to look like this: IF Current Seller
equals Previous Seller, add Previous Balance to Current Credit
and subtract Current Debit, OTHERWISE take Current Credit and
subtract Current Debit. It's very close to the formula you used
earlier.
Selection
• Drag the cursor from R14C8 down to R20C8, darkening a sevencell column.
Entry
• Type =IF(.
• Click R14C3, the Current Code.
• Type=.
• Click R13C3, the Previous Code.
• Type ,. (The IF condition is ended, and you can proceed to the
course of action if it's true.)
• Click R13C8, the Previous Balance.
• Type+.
• Click R14C6, the Current Credit.
• Type-.
• Click R14C5, the Current Debit.
• Type ,. (The action if true is now stated, and you can move on to
the OTHERWISE action, the action if false.)
• Click R14C6, the Current Credit.
• Type-.
• Click R14C5, the Current Debit.
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• Type ). The right parenthesis ends the formula.
• Press Enter. Now, in the topmost cell, -1400 becomes 1400.
You can easily enter the formula into the remaining cells of the
column.
• Choose Fill Down from the Edit menu.
The spreadsheet is complete. Again, it's only a basis, a
foundation, and you may wish to expand upon it.
Figure 6-24. The Accounts Payable Spreadsheet
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Balance Sheet
Finally, let's create a simple balance sheet. As before, you'll start
by asking what you want it to do. The balance sheet should total
up assets in the lefthand column, and liabilities and proprietorship
in the right. It can also figure subtotals, such as for fixed and current assets. Finally, it can figure out the proprietorship itself. The
net worth of an enterprise is constantly changing, and it helps to
have the spreadsheet keep track of it.
The labels in this spreadsheet will be vertical rather than
horizontal, and will fill two columns. You can get them in easily:

Selection
• Drag from R2C3 to R15C3.
• Press Command.
• Drag from R2Cl to R15Cl.
• Release Command. The white box is now at R2Cl, ready to
enter.
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Entry
• Enter the labels, as shown in Figure 6-25. Many of them overlap
into the next cell, so you need to widen the column widths.
Figure 6-25. Balance Sheet Labels
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Formatting
• Pull Column 1 completely across Column 2.
• Pull Column 3 completely across Column 4. You've doubled the
size of the label columns. They need it.
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Figure 6-26. Increase Column Widths
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Next, enter data-the sums of the fundamental kinds of assets and liabilities:

Selection
• Drag from R2C4 down to R1SC4.
• Press Command.
• Drag from R2C2 down to R1SC2.
• Release Command. A purist would select three blocks here since
there are three small blocks of data, but these two columns will
let you get through almost as fast.
Entry
• Type <Enter>, 9000 <Enter>, 55000 <Enter>, 14000 < Enter>,
950 <Enter>, <Enter>, <Enter>, <Enter>, 17500 <Enter>,
12750 <Enter>, 2000 <Enter>, <Enter>, <Enter>, <Enter>,
< Enter>, 15000 < Enter>, 3000 < Enter>, 4000 < Enter>, 10000
<Enter>.

Formatting
• Choose Commas from the Format menu. Many of these numbers
are in the tens of thousands and commas are almost necessary.
When you've done this, the spreadsheet on your screen should
look like Figure 6-27.
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Figure 6-27. Data Entered and Commas Added
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You're left with six formulas to enter. All are simple:
Selection
• Click R7C2, the first Subtotal.
• Press Command.
• Click Rl3C2, the second Subtotal.
• Click R15C2, Total Assets.
• Click R7C4, Total Liabilities.
• Click R12C4, Proprietorship.
• Click R15C4, Total Liabilities and Proprietorship.
• Press Enter to return to R7C2.
Entry
The first formula is a simple summation of the four numbers
above the cell. You've done it several times before:
• Choose Paste Function from the Edit menu.
• Choose SUM().
• Drag from R3C2 down to R6C2.
• Press Enter.
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The second formula, another subtotal, is the same:
• Choose Paste Function from the Edit menu.
• Choose SUM().
• Drag from R10C2 down to R12C2.
• Press Enter.
The third formula adds these two subtotals together. With
only a pair of numbers, click your entries in:
• Type=.
• Click R7C2, then R13C2. Multiplan inserts the plus sign.
• Press Enter.
Now jump to the second column, to R7C4, Total Liabilities.
Again, sum up a column of figures:
• Choose Paste Function from the Edit menu.
• Choose SUM().
• Drag from R3C4 down to R6C4.
• Press Enter.
You've reach~d Proprietorship, the fifth and penultimate formula. The basic accounting formula, taught on the first day of
every beginning accounting class, is Assets = Liabilities + Proprietorship. It's always true, because Proprietorship is defined as
Assets minus Liabilities. You can stick Assets minus Liabilities
right into the R12C4 Proprietorship cell:
• Type=.
• Click R15C2, Total Assets.
• Type-.
• Click R7C4, Total Liabilities.
• Press Enter.
The final formula adds up Total Liabilities and Proprietorship.
Since this amount always equals Total Assets, by virtue of the formula, you could cheat and take it directly from the Total Assets
cell. But let's do it correctly:
• Type=.
• Click R7C4, Total Liabilities, then R12C4, Proprietorship.
• Press Enter.
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Figure 6-28. Balanced Formulas
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You're almost done. The spreadsheet could use a title and a
date of compilation. But there's only one row at the top. You need
to create more space.
• Place the cursor on Row header 1.
• Press Shift.
• Click four times.
Now you're ready to cap it all off:
Selection
• Click R2C3.
• Press Command.
• Click R4C3.
• Release Command.
• Press Enter.
Entry
• Type BALANCE SHEET <Enter> and December 31, 1984
< Enter>.
Formatting
• Choose Align Center from the Format menu and things should
look like Figure 6-29.
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Figure 6-29. Final Balance Sheet
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That's it.
And it's also just the beginning. In fact, spreadsheets can simplify so many other accounting documents that it almost seems
they were invented to brighten the accountant's day. And, as you
may have sensed, Multiplan on the Macintosh is one of the most
pleasant programs around.
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Reporting in Pictures:
Using Chart
Charles Brannon

The preceding chapters have shown the
Macintosh's power in manipulating text in
multiple fonts and styles, its ease in managing large amounts of information, and its
ability to juggle numbers and calculations
with ease. But if anything, the Macintosh is
known for graphics, partly due to the visual design of the Macintosh user interface, partly due to the Macintosh's exceptional
screen clarity and resolution.
Graphics bring text and numbers to life. If a picture is worth
a thousand words, a chart must be worth a thousand numbers.
Numbers are everywhere, filling spreadsheets, databases, and disk
upon disk with statistics, annual reports, tables of brine shrimp
behavior, marketing forecasts, company budgets, tax tables,
amortization schedules, and much more.
A chart illuminates an otherwise obscure table of numbers.
Patterns and relationships between series of numbers instantly become recognizable. Future trends can be seen in the extension of a
single line. Charts even let you "slant" the facts, emphasizing one
relationship between numbers while de-emphasizing others.
Where a monthly chart of profits may show frightening dips, a
ten-year chart tends to smooth out the jags by shrinking them in
scale. Charts are the darling of meetings, presentations, and
portfolios.
Before computers, chart making was an arcane art, requiring
painstaking precision. Using pen, ruler, and a list of data, the
chart maker tediously drew in the points and lines. Mistakes becarne ugly blotches. Coffee cups were used to draw circles. Labels
were hand-scrawled. The rough draft of the chart illustrated the
data, but was as ugly as rust on chrome. The chart was sometimes
redrawn by an art department or service, but it lost some of its accuracy as it was retraced or redrawn. A chart, though valuable,
was often not worth the trouble it took to create.
Microsoft's Chart ends the pain. It actually encourages you to
develop charts, and gives you the flexibility to manipulate and
customize your chart. Chart is a general-purpose chart-creation
program. It can create almost any conceivable chart. With this
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flexiblility comes great complexity. Fortunately, the Macintosh's
user interface makes the program manageable.

Fundamentals of Charting
The six basic kinds of charts in Microsoft's Chart are area, bar, column, line, pie, and scatter. They have several things in common:
bar and column charts are just variations in direction. Bar charts
run horizontally, column charts vertically. Area charts are like line
charts with the area beneath (or above) the line filled. Scatter
charts are like line charts with just the points on the line displayed. Pie charts are in a class of their own and don't have as
many options as the others.
Most charts have both a vertical (also referred to as Y) and a
horizontal (X) axis. The vertical axis represents values, while the
horizontal represents category. Chart can automatically fill in the
categories with sequential numbers or dates. You can define your
own categories as well, with either text or numbers.

Entering Data
The data for the chart comes from small windows called series.
Each series holds both the X and Y values for a chart. A value
associated with its category is called a data point. Say, you had a
series charting the number of beans required to fill various sizes
of cans. A data point on this series would be the bean count of a
particular size of can.
To produce a chart, you must first create any series required
to plot the data. Chart can automatically fill in the category (X)
information for you with a sequential list of numbers or by date.
Or you can fill in the category axis yourself with text or numbers.
The type of series you create is determined by the Data
menu. When typing in new data, as opposed to changing the type
of data, always bring the New Series window to the front by clicking on it. (You may need to move some windows to find it.) With
the New Series window active, select one of the Data types: Sequence, Date, Text, or Number. A dialog box appears, allowing you
to name the series, the category axis, and the value axis. By default, the series is named after the current time. The category axis
is called X and the value axis, Y. If this is acceptable, just click OK
or press Enter. Otherwise, use the Tab key to switch between the
edit fields (or click on the field you want to change), and type
new entries.
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For Sequence series, you can either accept the default starting
number and increment, or change them by clicking on the field
you want to change and start typing. If you just begin typing with
the New Series window active, Chart will choose for you a Sequence chart, automatically filling in the categories with 1, 2, 3, 4,
and so on, as you type. Date series allow you to set the starting
date with the three-digit month abbreviation, the day of the
month, and the four-digit year. The current date is used by default. You can increment the date by year, month, day, or weekdays. In our example, we'll select a Date series starting with
January 1981, incremented by month. We'll be plotting the number of pages of a magazine over several years of its circulation.
Figure 7-1. Date Series
Dote Series
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If you use a Date or Sequence series, you just enter data in the
value area. Type in all values as raw numbers. Don't try to format
your values with dollar signs or text. You do this by selecting Values from the Format menu. This allows you to select between various display formats, including dollar, scientific notation, and
variable number of decimal points. You can even include text
before and after the numbers. These settings also affect the labeling of theY-axis on the chart. If you use a Number or Text series,
you can toggle back and forth between editing categories and values with the Tab key. You can also double-dick on an entry to
edit it. The Enter key is used to go from field to field in a series,
and Return puts the cursor in the same column, but down one line.
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You've begun to enter the data for
the year 1981. The horizontal insertion
bar shows where the next entry will
appear. Chart fills in the date for you as
you go along, with the medium length
form of the date. You can select Categories from the Format menu to prevent
the year from being tagged onto each
month. Here's the data for 1981:
Issue Number of pages
176
Jul
Aug
160
Sep
160
Oct
184
Nov
184
Dec
192
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II

Issue
Jan
Feb
Mar
Apr
May
Jun

Number of pages
144
142
168
176
160
160

After you've completed entering the data for 1981, you can
click on the Plot Series box to graph the data. Chart automatically
displays a column chart. The series windows are still in front, so
click anywhere on the chart to bring it to the front.

The Chart Appears
Figure 7-2. Default Column Chart for 1981 Data
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The goal in charting the increase and decrease in the
magazine's page size is to
identify seasonal variations.
By plotting several years of
data, you'll be able to see if
the seasonal variations are
consistent year to year. For
[ Cancel
our purposes, a line chart is
more useful than this column chart, since a line chart fills in the gaps between data points
and highlights the dips and rises. The easiest way to change this
column chart to a line chart is through the Gallery. Select Line
from the Gallery chart to open the Line Chart Gallery. Choose line
chart 2 to avoid plotting the data points themselves. At this stage,
you're just interested in the trends, not the actual points on the
lines.
Figure 7-3. Line Chart for 1981 Data
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You can see that there's a dip at the beginning of the year,
followed by a sharp rise. The number of pages falls in early summer, peaks in July, falls in the autumn, and rises again near
Christmas. Now let's enter some more data and see how it compares. (Figure 7-4 shows the data for all years.) Bring the New Series window to the front, and select Date from the Data menu to
create a new series. All you change is the name of the series to
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1982 and the starting date to ]an 1, 1982. Continue to do this with

the other months until you've entered all four years. The screen
would look like Figure 7-4 if you rearranged and resized the windows so that all entries were visible.
Figure 7-4. Series for 1981-1984
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By clicking on all the Plot Series boxes, you can chart all the
data. Bringing the Chart window to the front shows all four years:
Figure 7-5. Comparing Four Years of Data
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Patterns from the Format menu to select a thicker line weight. By
clicking on Apply To All, you thicken them all. This dialog box
also lets you select the pattern of the line (which is set automatically) and the type of data point marker you'd like. At the moment, you're using an invisible pattern for data points since you
don't need them displayed.
Figure 7-7. The Plot Thickens
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You've got your basic chart completed, but there are still a
few things you can change to improve its appearance. The title of
the chart is chosen from the first series plotted, in this case, 1984.
(The title of the chart window is Untitled. This will change to the
file's name when you save the chart with Save As from the File
menu. When developing the figures, I naturally had to save my
work along the way, so the actual chart window title will vary in
these figures. See below for more information on saving your
chart.)
•
•
•
You'll change the chart title to Seasonal
•seasonal Variation~•
Variations, enlarge the title, and embolden it.
•
•
• Select the title by clicking on it. Eight small
boxes appear around the text. Each box, called a handle, can be
dragged to change the size and proportions of the text entry box.
Text inside the handles can be changed according to the usual
Macintosh editing rules. The insertion point is placed anywhere
within. Dragging selects text, and the Edit menu can be used to
cut, paste, and clear text.
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Select 1984 and replace it with Seasonal Variations. If you're
trying these examples out, don't worry that the new title won't fit
in the small box. The text is automatically reformed when you
press Enter. Now choose Text from the Format menu.
Figure 7-8. Text Format Dialog Box
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The Text Format box lets you
change the font (Geneva/New
•
•
•
York/Chicago), the style
(Italic/Bold), and font size
(Small/Medium/Large). For now, select New York, Bold, and Medium. The Text Format box also lets you detach this label from the
chart title. As a chart title, the label is positioned automatically by
the program. If you Unattach it, the title can be moved independently. It becomes a free-floating label. Free-floating labels can
also be created by clicking in any open space in the chart. A hollow + shows where the text will appear. The handles appear
when you start typing. Press Enter when you finish typing your
label. You can reattach a label to the chart title, the category axis,
the value axis, or to a particular series or data point. The label can
be positioned horizontally or vertically, and flushed left, right, or
center, both vertically and horizontally.
The chart is coming along nicely, but the limited plot size
area prevents the dates of the month from forming properly. Chart
automatically knows how to position the chart, but you can override this and change its size and position. First, move the chart
•

•

•

•Seasonal Variations•
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window to the upper left of the screen and drag the size box in
the lower-right corner of the Chart window to extend it as far as
possible. This gives a bigger workspace. Now choose Select Chart
(or press Command-A) from the Chart menu. This places handles
on the screen for the chart. Drag the lower-right handle all the
way down and across. The chart now uses the full screen area.
You can similarly select Select Plot Area from the Chart menu to
extend the size and change the position of the area of the window
where the chart itself is plotted. This is normally set automatically. You might want to limit the plot area to insert large sections
of text.
Figure 7-9. Completed line Chart Comparing Seasonal Variations
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Chart at Work
The seasonal variations are easier to see now that all the years are
plotted together. There's a consistent drop around August and a
predictable rise in December. If you change to an area chart, you
can highlight these similarities. Again, the easiest way to do this
is through the Gallery menu, but you can also just pull down
Main Chart Type from the Chart menu and choose the Area chart
type.
This is how the chart looks after you've selected a stacked
area chart. Each data point is stacked upon the next, so the points
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Figure 7·1 0. Stacked Area Chart Exaggerating Seasonal Similarities
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match more closely, highly exaggerating the seasonal similarities,
which is just w hat you're looking for. The thick line borders are
distracting, so you may want to change the border weight with
Patterns (Format menu).
Figure 7·11. Area Chart with Drop Lines
Muguzine Churt
Seusonul Vuriutions

8
0

1981
1982

I]]) 1983
•

J•n

Fob

Mor

Apr

M1y

Jun

Ju1
lssu•

Au9

Sop

Oct

Nov

1984

Ooc

217

Chapter 7

Here we've selected Drop Lines via Main Chart from the Format menu. Cleverly, Chart has changed the solid black pattern to
a striped one so that the drop lines are visible. This is typical of
the thoughtfulness put into Chart. The programmers of Chart have
anticipated the user's needs almost telepathically.

The Four-Year Plan
Now that you've plotted all four
years together, let's lay them end to
Series List
end and see the rise and fall of
Show Plot
magazine pages over the years. To
181 181 1984
do this, you need to paste all the
181 181 1983
data into a new series called
181 181 1982
1981-1984. Since the series win181 181 1981
dows
are hidden behind the chart,
( Concel
LttOK
select List from the Data menu (the
keyboard shortcut is Command-L).
The Data List command lets you control whether any of the series
are shown on the screen and whether or not you want a series
plotted. Just click on a box to turn the cross (X) on or off. When
you click OK, the series reappear.
To create the combined series, bring the New Series window
to the front and pull down Date from the Data menu to start a
new series. Change the series name to 1981-1984 and the starting
date to ]an 1, 1981, incremented by month. The category and
value names, Issue and #pages, have to be reentered. The
1981-1984 series window appears after you click OK.
Now you'll move the data from 1981-1984 into the new window. Click on the 1981 series to make it active, then click below
on either Issue or #pages to select the entire series. Choosing Copy
from the Edit menu (or pressing Command-C) copies the series
into the clipboard. You can then click on the 1981-1985 series and
paste the series from the Clipboard (keyboard shortcut is Command-V). Repeat the process with series 1982, 1983, and 1984. All
series have now been pasted together in the new window. Since
you'll just be working with this single combined series, select List
from the Data menu and unclick the Plot and Show boxes for the
series 1981, 1982, 1983, and 1984 to get them out of the way. They
haven't been deleted; they're just not visible or plotted on the
chart.
Go back to the Gallery to select a line chart and dick the Plot
Series box on the 1981-1984 series. The screen now looks like Figure 7-12.
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Figure 7-12. Preliminary Year-To-Year Line Chart
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You obviously need to clean a few things up. For one thing,
the dates are all too long-select Categories from the Format menu
and click off the Year box to remove the display of years. By the
way, if you've been following along with Chart, you'll find that it
takes quite awhile to redraw the chart. The data series are linked
directly to the chart. If you make a change in a plotted series, the
chart changes automatically. Chart needs some time to calculate
how to redraw a large chart, so you may want to select Manual
Redraw from the Chart menu and use Redraw Now (or press Command-=) when you want to redraw the chart. You can also click
off the Plot Series box on the series to prevent the chart from being plotted. After you make all your changes, you can turn automatic charting back on or reclick the Plot Series box.
Since the legend is no longer necessary (nor informative),
select the legend and choose Delete Legend from the Chart menu
to remove it. The complete chart should now look much like
Figure 7-13.
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Figure 7-13. Legend Gone, Dates Shortened
Magazine Chart
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As you can see, there's not enough room to display all the
months on the chart. Chart tries to fit the months in, but the
white space around the text erases the previous month. Also,
since the letter l is so thin, the month ]ul isn 't formatted like the
others. No matter how big you make the chart, the problem won't
go away. There just isn't a text size small enough to fit all the
months in. The chart can be saved as a MacPaint file, though, and
edited by MacPaint, where you can draw in tiny months with
FatBits, or use the text tool along with a very small font. You'll
see how to do this a bit later.
Right now, add some drop lines (lines extending from data
points to the X-axis) to divide the chart by year, and label these
drop lines. Chart has an automatic drop line feature that can be
selected with Main Chart from the Format menu, but this feature
adds drop lines for all data points. You just want to use them between years.
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The drop lines
will be constructed
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Before you move the arrow, select Patterns from the Format menu.
Use a checkered pattern and no arrow tip. The checkered pattern
gives a dotted line. You can now drag either end of the arrow into
place above and on Jan. The entire arrow can be moved by dragging it near the middle. Finally, finish up the lines by adding text
labels at the top tip .
Arrow P11ttern s

I8J

IElJ

Figure 7-14. Labels and Custom Drop Lines Added
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Forecasting
Chart is primarily a charting program, of course, but it does have
a few calculation features. Chart can take an existing series and
create a new series. The new series can be the average of the series, a trend (least squares approximation, or line fitting) of the
original series, an exponential growth curve of the original series
(curve fitting), a cumulative sum of the series, the difference between consecutive entries in the original series, the percentage of
total represented by each data point, or list of basic statistics
(number of points, maximum value, mininum value, average, median, standard deviation, and correlation coefficient).
Let's use the curve-fitting function (Growth) to try to foresee
the future page size of the magazine. Bring the 1981-1984 series to
the front, and select Analyze from the Data menu, then click on
Growth. The Growth series is calculated, so you can now select the
Plot Series box to display the growth curve.
Figure 7-15. Curve Fitting
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Overlay Charts
It's not hard to see the direction that page size is going-up, but
not too precipitously. Curve fitting is best illustrated by using an
overlay chart. With each data point displayed using the Scatter
chart type, you can use a line chart to plot the Growth curve. It's
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easy to see how well the curve fits the points. There are a few
combination charts in the Gallery, but they don't fit our needs
since they're combinations of column and line ch arts. Instead, you
should select Main Chart Type from the Chart menu to change the
main chart (representing the series 1981-1984) into a scatter chart.
The scatter chart is invisible since you didn't plot the data points
when you used a line chart; select Main Chart from the Format
menu, and click on Markers for Data Points. A shortcut to this
would be to select scatter chart 2 from the Gallery. You can n ow
select Overlay Chart Type from the Chart menu and choose a Line
overlay chart type. Select Overlay Chart from the Format menu to
disable Markers for Data Points.
Figure 7-16. Overlaying Charts
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File Operations
After you've finished your chart, or even while you're working on
it, it's a good idea to save the chart to disk. Even if you finished
the chart, you don't want to print it out and tum off the computer, only to discover a mistake in the chart. To save your data,
just select Save or Save As from the File menu, give the chart a
name if necessary, and the chart and all series are saved. You can
Open a new chart and bring in the complete chart with data, just
the chart format, or just the series. The New Data entry clears out
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all series, and New Format resets and removes all customized chart
features.
When you're ready to print, select Print from the File menu.
If you're using special paper or a special printer, you may need to
use Page Setup from the File menu before printing. The chart is
printed with higher resolution (more detail) on paper, so be prepared to wait awhile for your hardcopy.

Charting Data from Other Programs
Chart was designed to be able to integrate information from other
programs, primarily Microsoft's Multiplan spreadsheet. All transfer
is through the Clipboard, using the standard cut and paste functions. You can also pull a table of numbers from Word or
MacWrite and paste it into the New Series window. You can even
cut text from the Note Pad and create a series from it. Chart figures out the best way to arrange the data and creates as many series as necessary. Usually, Chart creates a new series for each row,
with each entry in the row a value. Let's try to cut this line of
numbers from Word into Chart:
Figure 7-17. Cutting from Word
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The line of numbers from this whimsical letter is made up. of
simple numbers with no commas, dollar signs, or other manual
formatting. You must remove any dollar signs, commas, trailing
minus signs, or text before you copy the numbers into the Clipboard. Each number is separated from the next by tabs (the Tab
key was pressed between each number). The tabs are delimiters.
Spaces are not legal delimiters for Chart. If you want to make sure
that a number is treated as text, enclose it in double-quote characters. You can now drag across the numbers and select Copy from
the Edit menu. The numbers are copied into the Clipboard. Since
the Clipboard is transient, also pull out the Scrapbook (see Chapter 1) and Paste the text into it.
You're now ready to open Chart and paste the numbers into a
new series. Unfortunately, there's a problem. The Clipboard isn't
universal among all programs, but is stored only in memory, or
on the startup disk if it can't fit in memory. The same is true for
the Scrapbook.
If you go back to the Finder and start up Chart, for instance,
you'll be using the Clipboard and Scrapbook from the Chart disk.
If you have both applications on the same disk, there's no problem. Otherwise, you'll have to copy the Scrapbook file (usually
found in the System Folder) onto the Chart disk. You follow this
same procedure anytime you need to move information via the
Clipboard and Scrapbook between disks.
You can then open the Scrapbook from within Chart and
copy the numbers into the Clipboard, ready to paste.
However you solved the problem, now bring the New Series
window to the fore and select Paste from the Edit menu. Chart
creates a new series named after the current time and selects a Sequence data series (as shown on the left in Figure 7-18). After you
switch to a text series, change the category and value names,
change the formatting of the value field, and type in the names of
the continental areas, the series appears as shown on the right
(you'll need to expand the window and adjust the column width
to see all the data, as was done here).
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Figure 7-18. Series Created from Clipboard
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It's now a simple matter of clicking the Plot Series box to get
the complete chart.
Figure 7- 19. Chart from Word
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The numbers used for the chart were too big to fit on the
chart page (nobody said overhauling a star was cheap!). You can
solve this in three ways: retype the data series to scale it down
and label the chart as charting data in the billions; remove the
value axis tick mark labels and add free-floating labels to take
their places; or expand the chart as was done before to fit it all in.
It's easiest just to expand the chart.
Or you can use a pie chart. A pie chart can show relative
relationships quite concisely. To get this chart, select pie chart 5
from the Gallery, then select each text label, and with Text from
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Format, click on Show, then Value, for each text label. This displays the dollar amount instead of the region name for each slice.
Use Add Legend to make the regions clear.
Figure 7-20. Pie Chart from Word
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Linking with Multiplan
Chart can set up a permanent link with Multiplan. If you change
your spreadsheet, Chart can look at the spreadsheet file and recalculate the chart. To set up the link, you must first define the
area of the spreadsheet you want to plot, copy this area of cells
into the Clipboard, then run Chart and paste the cells into an
empty series window. When you run Chart and open the chart
file, Chart will ask you to insert the disk containing your spreadsheet so that it can update the series.
This spreadsheet is being
used
to record the finishing
TeHI Seri es
positions of the three horse
Series Name:
races in the Triple Crown (the
data is fictional, of course).
Uelue Name:
The area we want to plot has
been ranged by dragging from
~..-.=oK
:.:.__..Jl [ cant e 1
th e upper-left cell. Select Copy
from the Edit menu to copy the selected range into the Clipboard.
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Figure 7-21. Multiplan Worksheet with Cells to Be Charted Selected
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Again, you may need to use the Scrapbook as a vehicle for moving Clipboard data from the Multiplan disk to your Chart disk unless you have both programs on the same disk. An ideal
alternative is to use Switcher (see Chapters 9 and 11), which lets
you use a common Clipboard between applications.
You're ready to paste the data from the Clipboard. You're going to be creating a text series, with the categories being the
names of the horses and the values being the place each horse
finished. Select Text from the Data menu and fill it out as shown
in the figure at the bottom of the previous page. This creates a series for the first race, the Kentucky Derby, and sets up the format
for the other two series.
Make sure the Kentucky Derby series is the active window,
then select Paste and Link from the Edit menu. You could also
simply select Paste, but your series would then not be updated if
you later change your spreadsheet. If you need to remove the link
later, just select Unlink from the Edit menu. After Paste and Link,
Chart creates three new series, one for each race. During this process, if Chart can't find the original spreadsheet file, you'll see a
dialog box which will insist that you insert the disk containing the
file. This same process will occur when you open the chart in the
future.
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It's now simply a matter of changing the series names to the
names of the races (it's not possible to cut the names of the races
from the spreadsheet) using Text from the Data menu, then selecting a chart type from the Gallery. Try using a horizontal bar chart,
which is ideal for representing a race. Bar chart 1 will serve
admirably. After expanding the chart area, the chart should look
like this.
Figure 7-22. Derby Bar Chart
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The bar chart seems to imply that the losers are ahead of the
winners. You need to reverse not merely the direction of the bars,
but the way the bars are plotted. As is, the bars start from 1 (first
place) and extend to 8 (last place) and 9 (horse didn't race). You
need the beginning point to be 9 so that the bars extend from last
place toward first place. And you don' t wat;\t the no-shows to appear on the chart at all. So, first click on the value (horizontal)
axis and change it to read as shown on the right in Figure 7-23.
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Figure 7-23. Value Axis
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To make the bars start at 9 and extend to 1, the category axis
must cross at 9. Since you don't want to display no-shows (a
place value of 9), starting the bar at 9 makes a zero-length bar for
the no-shows. The mininum chart value must be 1 so that the unused value of 0 is not charted. These two settings alone will do
the trick, but the bars will extend to the left. You need to imply a
race just by the appearance of the chart, so to make the bars extend to the right, click on Values in Reverse Order.
Figure 7-24. Bars to the Right
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The chart is finished by adding a horizontal bottom legend,
changing the title to The Triple Crown instead of the default Kentucky Derby, and moving the category tick labels to the right side
of the chart so that they don't interfere with the bars. Create the
legend by selecting Add Legend from Chart, click on the legend,
then choose Legend from Format and select a Bottom legend type.
Move the tick labels by clicking on the category (vertical) axis and
selecting Axis from the Format menu. Clicking on Low moves the
labels to the low (right, since the values are in reverse order) side
of the axis. The title can be enhanced with both Text and Patterns
from the Format menu . The title is Unatta ched so that it can be
moved to the bottom of the chart. Finally, cover up the 9 on the
chart, which is misleading, with an asterisk. Your final result
should resemble Figure 7-25.
Figure 7-25. The Triple Crown
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MacPaint Your Chart
You can even copy the chart as a graphics item and edit it with
MacPaint. Either press Command-Shift-3 to dump the entire
screen to a MacPaint file called Screen 0, Screen 1, Screen 2, and so
on, or select Copy Chart from Edit when the Chart window is active. If you use Copy Chart, select the option As Shown on Screen
instead of As Shown when Printed. You can then paste the chart
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into MacPaint (again, it's often best to do this through the Scrapbook). Copy Chart is neater than dumping the entire screen; only
the graphics inside the window are copied. However, it's good
only when the chart is smaller than the MacPaint window since
that's as big a picture as MacPaint will accept from the Clipboard.
If you use Command-Shift-3, you can load the screen dump
directly into MacPaint. You'll usually want to remove (using the
marquee selection tool and Clear from the Edit menu) all the
extraneous screen stuff, like the title bars and window edges.
Show Page from the Goodies menu is very helpful here; just drag
outside the dotted-line window to push those portions of the
drawing you want to remove off the paper. When you click OK,
these portions are gone. If you made a mistake, you can always
use Undo from Edit or Revert from File.
You can now add that personal artistic touch whiCh makes a
chart stand out among all others. Bar charts can be illustrated with
a pictorial representation of what's being charted. Pie charts can
be made to represent the kind of pie that's being illustrated (such
as segments of a silver dollar to represent the portions of a budget
spent). You can add external graphics to the chart, enhance the
text, add text in new fonts, and create those few charting items
not supported by Chart. Since MacPaint is so flexible and easy to
use, trust the artist in you to come up with a good result. We'll
end here with our own gallery of MacPaint-enhanced charts.
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Figure 7-26. MacPa/nt-Enhanced Line Chart
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Compa re with Figure 7-14. New tiny text is ad ded to fit in all the months. Arrows replace> symbols near years at top of chart. Chart title enhanced. line was copied
and shifted up and to the right. then lines were drawn to connect points. Threedimensional illusion enhanced with pattern shading. Icon drawn near •pages
Indication.
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Figure 7-27. MacPa/nt-Enhanced Pie Chart

Compare with Figure 7-20. I took a bit more artistic liberty with this one. The entire
chart was selected in pieces with the marquee, then reversed with Invert from the
Edit menu. The sun was created with a solid white circle. with the spray point con
used to fuzz out the edges of the sun's luminosity. The chart legend was d isassembled
with the marquee and redistributed among the dollar amounts. Such a block pottem
Is hard for the lmogewriter to print accurately, but COMPUTEI's proprietary t ypesetting
techniques let us print very clean Macintosh pictures.
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Figure 7·28. Triple Crown Winner
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Compare with Figure 7-25. Tiny horse lco_ns represent the winners of each race. The
asterisk used to cover up the 9 is neatly erased. A "blue ribbon" Is placed around the
first-place position. Dotted lines extend from the center of each cluster of bars to the
horse's name. The title is customized by designing a special font effect and adding
art. Finally. the large horses were added by tracing them through a sheet of transparent plastic. then affixing the plastic to the screen and tracing the outlines with the
paintbrush. FatBits was used to clean up loose bits.
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Sharing with Mac Terminal
Arion R. Levitan

Telecomputing, the process of sending
computer data over regular phone lines,
enables you to transfer work which you've
produced with your Microsoft applications to other Macintosh systems in remote locations. The remote system may be across town
or across an ocean. The process is exactly the same, regardless of
the distance involved.
A complete Microsoft File database, along with instructions
for its use contained in a Microsoft Word document, can be
transmitted via phone lines to virtually any Macintosh user. Telecomputing can even bridge the gap between Microsoft applications on different computers. For instance, Multiplan and Chart
files may be interchanged between your Macintosh and an IBM
PC or PC-compatible. With the proper PC utility, you can even
convert VisiCalc or Lotus 1-2-3 files into formats compatible with
Multiplan or Chart.
This sharing of information over both long and short distances can be invaluable to your business. Employees spread
across the country can keep in close contact with the main office,
even receive up-to-date instructions and data concerning clients,
sales leads, and product availability. Electronic communications
can take the place of long-distance phone calls or overnight mail
services. Instead of waiting to deliver something the next morning, telecomputing lets you do it now, this minute.

Telecomputing Theory
Before getting into the specifics of turning your Macintosh into an
electronic information system, however, some background information is in order. Telecommunications involves its own jargon.
Understanding the concepts involved can help stack the odds of
success in your favor.
In its simplest form, a telecomputing link consists of five elements: a terminal, RS-232-C interfaces, modems, a data link, and
a computer (also called the host system).

239

Chapter 8

Figure 8-1. The Telecomputlng Link
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Your Macintosh, when running a program like MacTerminal,
is your terminal. Your phone line is the data link, and the Macintosh already comes equipped with an RS-232-C interface (the
connector on the back of the machine with the phone symbol).
Thus, you need to buy only one piece of hardware to equip your
system for telecomputing-a modem (pronounced MOE-OEM).
A modem's job is to turn numeric data within computers into
sound (modulation), and change sound back into data (demodulation). Such a device MOdulates and DEModulates, hence the
name modem. (Direct-connect modems, like the Apple 1200, hook
right into your modular telephone jack and account for the bulk
of modems purchased today.)
The remote computer, or host, on the other end of the tetecomputing link can be anything from another Macintosh to a
large mainframe which supports multiple users.

Looking for a Modem
Since you have everything else (we're assuming that you're using

MacTerminal), the only thing you need to buy is the right modem.
That can be confusing. There are hundreds of different brands
available and usually several models of each brand. Finding the
best to fit your needs, and your pocketbook, can be intimidating.
Fortunately, there are few things you must deal with to
choose a modem that's right for you and your Macintosh.
Compatibility with both your computer and the terminal software
you intend to use is foremost. A modem that won't "talk" to your
Macintosh or the terminal software is of little use.
For many Macintosh owners, the most prudent purchase will
be one of the modems marketed by Apple. Their prices include
the proper cable to connect Macintosh and modem, and their
instruction booklets include chapters that deal specifically with
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using them with the computer. Another advantage is that since
it's the manufacturer's de facto standard modem, the special features of the Apple modems are likely to be supported by most
terminal software. The Apple modems also represent a fair value
for your dollar. Their pricing places them squarely in the middle
of the range for units offering similar features.

Other Brands
Modems made by other companies generally don't come with
connecting cables since there's some variation in the type of RS232-C plugs found on the back of different computers. A cable designed to connect these modems with a Macintosh must usually
be purchased separately.

How Much to Spend?
The major determinants of a modem's price are the maximum
speed at which it can send and receive data, and the number and
variety of other features it includes.
A low-end modem's top speed is usually 300 bits per second
(bps). Bits per second may sound somewhat technical, but since it
take 10 bits to send one character, just remember that a speed of
300 bps means approximately 30 chararacters are transmitted each
second. That's about 180 characters a minute. A modem in the
low end can range from $80 to $280, depending on what other
features are included.
Modems which can handle data transmissions at both 300
and 1200 bps (30 or 120 characters per second, respectively) cost
from $200 to $600.
Also available are 2400 bps modems which are twice as fast
as 1200 bps units, and operate on standard voice grade telephone
lines. They command a premium price ($700 to $1,000). Most
2400 bps units are also capable of 1200 and 300 bps transmission.
Is the premium commanded by medium- or high-speed units
a worthwhile investment? That depends. You must balance total
communications costs against the lesser amount of time required
to receive and/or transmit a given amount of data. The faster you
transmit data, for instance, the lower your long-distance phone
charges will be.

Features
Here are some of the features to look for when you're shopping
for a modem:
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• Autodial. Almost every modem marketed for the Macintosh can
automatically dial the telephone numbers of remote computer
systems. A few keystrokes or a couple of clicks of the mouse
place the call.
A flexible autodial system will support both pulse (rotary
type) and tone dialing. The ability to mix pulse and tone dialing
in the same sequence is a must if you live where the local telephone exchange does not react to tone dialing, or if you want to
use alternative long-distance services like MCI and Sprint.
• Autoanswer. Autoanswer allows your Macintosh, with the
appropriate software, to automatically receive files from other
computers that call in. This could be vital if you're expecting to
have others-your field agents or salespeople, for instancesend data to you outside office hours.
• Call Status Monitor. Some modems have internal speakers
which allow you to listen to the progress of the call, making it
easy to tell if the system is busy, or let you hear recorded messages informing you of a changed or disconnected number.
The bottom line? Stick with autodial modems like the Apple
modems or modems billed as Hayes (a very popular brand)
compatible. Make sure the modem you buy is supported by the
terminal software you wish to use. Let your pocketbook and intended use dictate the top speed of the modem.

Inside a Macintosh File
Your Macintosh is a unique computer. The file structure implemented in the Finder (Macintosh's user interface) and the way
it allows applications to handle files impose some special restrictions upon transferring Macintosh files between other Macintosh
systems or between a Macintosh and other types of computers.
Macintosh files consist of two elements, called forks. Most
Macintosh files contain both a data fork and a resource fork. Consider a letter written with Microsoft Word. The letter appears in
the Finder of your system as a document file. If the View option is
changed to anything other than By Icon, the Finder displays information about the file rather than a pictorial icon. One of the
pieces of information is the Kind of file.
Macintosh files are typically either applications, such as
Microsoft Word, or documents, which are normally associated with
the application used to create them. This relationship is referred
to as ownership. For example, a letter created with Microsoft Word
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is usually owned by Word. Opening the letter by either doubleclicking its icon or selecting the icon and then choosing Open from
the File menu makes the Macintosh attempt to call the application
which owns the letter. If the application is available, the computer
then loads the file. If the owner of the document is not available
on any disk in the system, the Finder tells you. Of course, the
document is then not opened.
Information relating to the kind of file and ownership is
stored in the resource fork of a Macintosh file. The resource fork
also contains special information about the file's appearance. For
instance, a Word document's resource fork carries all the information concerning the fonts used and the layout of the printed
form. For an application file, the resource fork holds information
about the environment the program expects to run in, including
data which defines the appearance of the application's icon.
On the other hand, the data fork of a Word document contains the actual text of the letter. There's no information in the
data fork itself about the appearance of the text on the Macintosh
screen. Similarly, the data fork of an application contains the actual code executed by the Macintosh when the application is run.
Yet the application cannot be run without other information in its
resource fork.
You don't see data and resource forks on the Macintosh
desktop. The Finder hides the file structure from you and presents
a unified icon.
There's a special type of Macintosh document file, a text file.
Text files are generally used to move textual data between different Macintosh applications. The rules of ownership for these
files are slightly relaxed, and applications must be specially constructed to recognize and manipulate them. For example, it's possible to load a text-only file created by Microsoft BASIC into Word.
Text-only files have little or no resource fork data and are also
fairly easy to transfer between the Macintosh and non-Mac
systems.
What does this all mean when it comes to file transfers?
When transferring files over telephone lines, it necessitates special
handling by the sending and receiving terminal software. To
transfer both the resource and data forks of a file directly, both
the sending and receiving systems must be aware of this special
file structure.
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The What and Why of XMODEM
An error in transmitting information may not be critical in some
cases. If the word COMPUTE! were changed to COMPOTE! during
transmission by line noise or some other error, you'd most likely
notice the mistake and be able to infer what the original word
was. You could change the error after the file was received by
loading the file into a word processor and editing the text.
That's not the case with much of the information in Macintosh files. Because much of the resource fork information is rigidly formatted, the received copy of a file must be an exact
duplicate of the original.
Trashing one or more pieces of information in a Macintosh
file is usually disastrous. Macintosh files transmitted with errors
are likely to be unusable.
The need for a reliable way to transfer perfectly exact copies
of files was something discovered early in telecommunications.
Ward Christensen, one of the coauthors of the first microcomputer
bulletin board system (BBS), developed a public domain terminal
program for CP/M computers called MODEM7. When MODEM7
users logged onto Christensen's BBS and wanted to transfer a file
between the two systems, they instructed the BBS to use a utility
program called XMODEM.
The ground rules laid down by Christensen back in 1976 are
still with us today, and the methodology is used by almost every
piece of terminal software around, including those that run on the
Macintosh.

How XMODEM Works
The file to be transmitted is essentially chopped up into pieces
(blocks) as it's being sent by the terminal software. Each
XMODEM block consists of the following elements:
• A special character that delineates the beginning of the block.
This character is the same for every block and is called a start of
header (SOH) character.
• A number which identifies the sequence number of the block.
Each time a new block is sent, this number is incremented by
one.
• A number used to insure that the block number is correct.
• A 128-byte chunk of the file being transferred. The file is
chopped up into these blocks on the sending end and is reassembled on the receiving end.
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• A number used to verify that the 128-byte block received is the
same that was sent. This number is called a checksum. The sum
of the hexadecimal values of all 128 characters in the block is
used to check that the data was cleanly received.
Here's what happens during a MacTerminal XMODEM file
transfer.
• If MacTerminal has been told that the remote system is another
Macintosh running MacTerminal, some special characters are sent
which tell the remote system the name of the file being sent and
its size.
• The remote system then sends an acknowledgment signal
consisting of a single character referred to as an ACK. The first
ACK received by your copy of MacTerminal means that theremote system is ready for the next block.
• A single XMODEM block is then sent to the remote system. The
MacTerminal software on the remote end starts to dissect the
block. It looks for the start of header character. By convention,
the block number is then checked for both validity and proper
sequence. It examines the 128 bytes of data and calculates what
it believes the checksum result should be. It then compares this
with the checksum that was tacked onto the end of the XMODEM
block by the sending system. If both the sent and calculated
checksums are the same, you can be reasonably sure that the
data received has no mistakes in it.
• As each block is successfully received by the remote system, another ACK is sent. If the block number or data was found to be
in error, or if a specified amount of time goes by without another block being received, the remote MacTerminal software
sends a character referred to as a NAK (negative acknowledgment). A NAK indicates a problem with the last block, and it
should be resent.
• When the file transfer is complete, a signal called end of transmission (EOT) is sent instead of an XMODEM block, concluding
the file transfer. A file transfer may be aborted if a single block
must be resent more than an agreed-upon number of times
(usually ten).

Downloading VIa XMODEM
Sending a file is often referred to as uploading. Receiving a file is
commonly referred to as downloading. Once you understand uploading, downloading is easy. The downloading process just
places your system on the receiving end of a file transfer.
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Getting Started
Make sure that you have the following:
• Modem with power supply and modular phone cords.
• Mac-to-modem cable (supplied with Apple brand modems-purchased separately for most others).
• Small screwdriver with insulated handle (not necessary for Apple brand modem cable).
Follow these next steps to connect your modem and get your
system ready to download a file.
1. Turn the Macintosh's power off and unplug it from the wall
outlet.
2. Discharge any static electricity that may have built up on your
body by touching the outside edge of one of the empty connectors on the back of the Macintosh. This is just a precaution to
minimize the chance of a static discharge, which could inadvertently damage some of the more sensitive components on
the Macintosh motherboard. Better safe than sorry.
3. Attach one end of the Mac-to-modem cable to your modem.
Only one end will fit. Tighten any screws just enough to firmly
secure plug to jack.
4. Attach end of cable with nine-pin connector to the Macintosh
connector symbolized by the phone symbol. Tighten any
screws just enough to firmly secure plug to jack.
5. Examine the modular jacks on the modem. Connect the modem
to the phone line as detailed in the manufacturer's instructions.
6. Most modems come with an external power transformer. Plug
one end into the external power jack of the modem and the
other end into a power outlet.
7. Turn the modem's power switch to the on position. If there is
an external switch on the modem labeled Voice fData, make
sure it's in the Voice position.
8. Plug your Macintosh back into its outlet.
9. Verify that your telephone is still working by lifting the receiver
off the hook and listening for a dial tone. If there's none,
double-check the accuracy and integrity of all your modular
jack connections.
Now let's take a look at how to transfer files from Mac-toMac via MacTerminal. Remember that two Macintosh systems are
involved.
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Starting Mac Terminal
Turn on your Macintosh and insert the MacTerminal disk. The
MacTerminal icon will appear, along with several MacTerminal
documents.
Figure 8-2. MacTermlnal Desktop
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Double-dick on the MacTerminal document labeled Mac-toMac. This document has almost all the settings necessary for a
Mac-to-Mac transfer ready for you.
A telecomputing session with another computer takes place
within MacTerminal documents. The menu bar contains pull-down
menus which are used to set up terminal parameters and initiate
file transfers.
Figure 8-3. MacTerm/na/lntroduction Screen
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The cursor appears at the location where incoming or outgoing
data may appear in the terminal display area. During XMODEM
Mac-to-Mac transfers, there will be very little to see since the actual data is not displayed as it's sent and received.
Select Compatibility from the Settings
menu. The following window will appear:
File Transfer•••
Answerback Messoge •••
Show Tob Ruler

Figure 8-4. Compatibility Window
Compatibility Settings

so

0110 0 13~.5
0300 0600
® 1200 01800 02000 02400
03600 04800 09600 019200

Boud Rate 0

075
0200

0150

Bits per Character
Porlty
Handshake
Connection

0

Euen

0

7 Bits

0

Odd

® None

0 HOn/HOff
® Modem

Connection Port

®

~~~

® 8 Bits
® None
0 Another Computer

0

~~~ ~

r;::::;)

~w~

The only item you need set is Baud Rate. This sets the transmission speed in bits per second. The use of the term baud is not
quite correct here. A 1200 bps modem, for example, actually operates at 600 baud. To be consistent with MacTerminal, however,
we'll use baud instead of bps.
Both systems in the telecomputing link must be set at the
same baud rate. Additionally, both the local and remote modems
must be capable of the speed selected. If, for example, both the local and remote terminal programs are set at 1200 baud, and one
system has an Apple 300 and the other an Apple 1200, no successful file transfer can take place.
If the maximum possible speed of one modem is lower than
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the maximum speed of the other, opt for the lower baud rate at
both ends. When you're done, click OK.
Now choose Phone Settings from the Phone
menu. You'll see the window shown in Figure
8-5.

Figure 8·5. Phone Settings Window
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Type in the complete phone number of the remote system. If
your phone line doesn't support tone dialing, click the button
marked Pulse. When you're through, dick OK.
If you'll be transferring files between the remote location and
your Macintosh in the future, use Save As from the File menu.
Name the file appropriately. If you're transferring files between
your Macintosh and the Zug Island office, Zug Island Office would
be a good choice.
Now the local and remote systems must do
things slightly differently. The operator of one
system should select Wait for Call from the
Phone menu while the operator of the other system should choose Dial from the same menu.
Either system can dial or wait for a call. The
difference is that, as you might expect, the dialer foots any phone charges associated with
the call.
The caller will see a dialog box similar to
the one in Figure 8-6.
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Figure 8·6. Dial Window
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When the calling system is answered, you'll hear a highpitched tone for a second or two . Then a dialog box will appear
stating that the connection has been established.
Figure 8·8. Connection Established

The connection Is est11blished.

To insure that everything is all right, try typing some messages back and forth, hitting the Return key after each line is entered. Your dialog might look something like this:
Figure 8·9. Pretransfer Dialog
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The party wishing to send a file then selects Send File from
the File menu . The standard Macintosh file selection window will
be presented.
Figure 8-10. File Window
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If the file you're transferring is on the current disk, doubleclick on its name. If you have an external drive, it's an excellent
idea to keep the files you're sending and receiving on that drive,
which may be selected by using the Drive button of the File window. If you're using a single-drive Macintosh and the file you
want to send is on a different disk, click Eject and insert the other
disk.
A scale will appear in the window, with a moving pointer
showing the progress of the file transmission.
If for some reason you decide to stop sending the file in the
middle of the process, hold down the Command key ( 38) and hit
the period (.). Otherwise, just sit back and relax, for the file transfer continues on its own. After the transfer is through, you can
type another message or two, such as " Got that, Herb" to make
sure everything went right. You may then choose to send another
file or switch roles with the other system. Its operator would send
you a file by selecting Send File on the other Macintosh.
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Figure 8-11. XMODEM Scale
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The real beauty of using MacTerminal in this manner is that no
action is required from the operator of the receiving system other
that placing the system in the Wait for Call mode. This means that
someone could just set the Zug Island Macintosh in Wait mode and
leave the system unattended. The sender can call at any time and
the receiving MacTerminal will automatically take care of saving and
naming all the files that are sent to it.
When you've finished sending and/ or receiving all the desired
files, either Macintosh operator should select Hang Up from the
Phone menu. You may then choose Quit from the File menu and return to the Macintosh desktop. Any files you received will be waiting for you there.

Mac to Other Systems
File interchangeability-Multiplan and Chart-special
formats. SYLK (SYmbolic LinK) files are specially formatted ASCII
files that make it possible to exchange documents among selected
Microsoft applications running on different machines. SYLK files
are created by using the SYLK option of the Save As menu selections of both Multiplan and Chart.
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Figure 8-12. SYLK Option Save
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Non-Mac versions of these packages include facilities for
saving their work as SYLK files also. IBM PC users who have the
PC versions of Multiplan and Chart can freely exchange their
work to and from the Macintosh and IBM program versions by
moving documents saved in SYLK format via a telecomputing file
transfer. A detailed description of the SYLK file format can be
found in the appendices of both the Multiplan and Chart manuals.
Some spreadsheet applications on the IBM PC use other special formats, notably DIF (Data Interchange Format), which is
used by VisiCalc, and DIF2 (DIF version 2), used by Lotus 1-2-3.
Utilities are available for the PC that will convert DIF and other
special formats to SYLK (one such utility, called CONVERTD, is
included with Release 2.0 of Microsoft Word for the IBM PC).
Once converted, they may be transferred directly into Macintosh
Multiplan or Chart.
File interchangeability-Word-special formats. There are
currently some limitations on moving formatted files between the
Macintosh and IBM versions of Microsoft Word. Release 1.05 (and
after) of Word for the Macintosh includes a separate, external utility program that will convert formatted IBM PC Word files into
Macintosh Word format.
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If you're unsure of what Word release you own, check the
About Microsoft Word command of the pull-down Apple menu
within Word.
Figure 8-13. About Microsoft Word
Gett1 ng He1p
Open1119 Wt ndovs
Closing Wlndovs & Quitting
Savi119 Documents
Printing
Printing form Documents
Editi nQ Documents
Ust ng Glossaries
Sho'w1119 The Ruler
Sho'wing Speciol Ch8recters

Q

Word uerslon 1.05
Rprtl24, 1985

I ,

® 1985 Microsoft Corp.
100 % free memory

a

Help

(

Cancel

)

If you have an earlier release and need the conversion program, contact Microsoft Product Support at 1-800-426-9400 for
further information on upgrading your copy.
As of this writing, no utility is available that will convert
formatted Macintosh Word documents into IBM Word format. Macintosh Word documents may be transferred into PC Word by using
the Text Only option of the Macintosh Word Save As Command.
After the text file has been transmitted to the PC, it may be
loaded into IBM Word. The document will lose all formatting,
including justification, centering, spacing, and character formats,
but the text itself will be intact.
Similarly, an ASCII (text only) file created by a word processor on any other microcomputer may be transferred and then
loaded into Macintosh Word. The file will probably need extensive
formatting and editing on the Macintosh to work it into the desired appearance.
File interchangeability-Microsoft File. At this time, Microsoft File is available only for the Macintosh. You can, however,
move a certain type of formatted text document into File. The text
document is organized by separating values with tab characters
and ending each line with a carriage return. File interprets each
tab-separated value as a field and each return-separated line as a
record. (See Chapter 4 for more information concerning fields and
records in File.) Such a text document can be merged into an
existing data file by selecting it from File's Open Datafile dialog
box. This type of text file can also be loaded into Multiplan and
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Chart. On the IBM PC, the CONVERTD utility, included with Release 2.0 of Word for the PC, will change files created by PC database programs such as DBASE II into formatted text files suitable
for File.

Transferring Flies Between Macintosh and Non-Macintosh
The only change in MacTerminal parameters that differs from our
previous example is selecting Other as the type of remote system
in the File Transfer Settings option of the Settings menu.
The other computer should be running terminal software that
supports XMODEM file transfers. Both systems should have the
same baud rate set. In addition, insure that the non-Macintosh
computer has the following options set:
• Local echo-On (also called half duplex)
This insures that any messages typed on the other computer's
keyboard will be visible to both parties.
• Bits per character-S (also called word length)
This option refers to the number of bits that comprise a
character.
• Parity-None
Parity schemes were once used to implement a simple form of
error checking. It is rarely used these days.
• Stop bits-1 (optional)
Some computers have this setting available. It specifies how
many bits are used to indicate the end of a character. The default
value is usually 1; the only other valid value for this parameter
is 2, and it is rarely used.
One computer should be set to answer the phone. The other
should be instructed to dial its counterpart. After the connection is
established, the Receive function should be invoked by the operator of the target system and the Send function by the operator
of the system transmitting a file.
The method of invoking the Send procedure on the Macintosh
remains exactly the same as before. If the Macintosh is receiving a
file, Receive File is selected from the File menu and a name manually assigned to the incoming file.
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Figure 8-14. File Menu and Receive File
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During the receive operation, the XMODEM scale is replaced
by a slightly different dialog box.
Figure 8-15. Receive Dialog Box

Recelulng the File •from IBM With Loue·. Size Is
unknown. To Cancel, hold down the • key and type a
period(.).
Blocks receiued:
0

The operator of the other system must insure that the commands required to invoke XMODEM Send and/or Receive are
selected.

Mac to Other Systems via Local Attachment
It's also possible to move data between systems located nearby
without using modems. The purpose of a modem is to turn data
into a form which can be sent as an audible signal over a phone
line. If the two systems are in the same room, a simple cable connection between the two systems will suffice. Since such a cable
obviates the need for using a modem on each computer, it's called
a modem eliminator, or null modem.
A modem eliminator will typically be used for transferring
data between two unlike computers. After all, if the two comput256
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ers are both Macintoshes, it's easier just to make a copy of the
disk rather than fool around with file transfers.
Eliminating the modem from a transfer link also allows you
to use higher transmission speeds since the data rate of the modem is no longer a factor. Transmission rates of 4800 or 9600 bps
are typically used for file transmission via null modem. A terminal
program running in the non-Macintosh computer is used to send
or receive data to and from the Macintosh end.
Your local Macintosh dealer should be able to put together a
null modem cable for you.

Notes for Non-Apple Modem Users
MacTerminal is somewhat finicky about what it expects to receive
from the modem. If the modem doesn't act just like an Apple modem, you may be told that no modem is attached. Fortunately,
owners of most Hayes-compatible modems can set their modems
so that MacTerminal thinks it's a genuine Apple. When the
MacTerminal screen first appears, type the following:
ATEO (hit Return key)
ATVO (hit Return key)

If you don't shut off the power to your modem between sessions,
these commands need not be entered again. An alternative is to
set the option switches of your modem so that (a) the modem does
not echo commands sent from the keyboard, and (b) numeric
rather than verbal result codes are used. Consult the manual of
your Hayes-compatible modem for the location of the switches
that control these options.
Owners of modems which accept a standard 25-pin RS-232
plug do not necessarily have to build a separate null modem cable
to transfer files directly from their Macintosh to another computer
in the same room. The plug may be removed from the modem
and plugged directly into the RS-232 port of the other system (a
female-to-female adapter plug may be required, depending upon
the type of plugs that must be mated together). While the cable is
not physically wired in the same way as a null modem, a special
option of MacTerminal can reverse the necessary connections. Setting Connection to Another Computer in the Compatibility dialog
box will temporarily tum the regular modem cable into a null
modem cable.
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Using Information Services for Intermediate Storage
Many of the commercial information services, like CompuServe
and The Source, offer file areas which subscribers may use to
store and retrieve files. Here, also, XMODEM file transfer is the
preferred method of moving data to and from your Macintosh.
Why would you want to take advantage of such a· storage
area? Consider our original file transfer example. Since only one
office needed a copy of the documents to be sent, it made sense
to call Zug Island directly. But what if 5 or even 50 offices were
involved? The local office could transfer a copy of the needed
file(s) only once to the file area of an information service. Theremote offices could all get the files by dialing into the information
service and downloading them. While all the phone calls would
usually be local rather than long distance, you must add in the
hourly access charge of the service when comparing the cost of
using this file storage area rather than dialing each office directly.
MacTerminal does impose a limitation on using information
services for file transfer. Since MacTerminal will not transfer the
resource fork information for a Macintosh file to anything other
than another Macintosh running MacTerminal, Mac files other
than text-only documents must be run through a conversion program. This conversion process turns the entire file into another
type of file called hexadecimal, or hex for short. The ASCII hex file
is then uploaded to the service. When downloaded by another
MacTerminal user, the hex file must be run through yet another
conversion process which will reverse the initial conversion and
go from hex to binary.
Fortunately, there is a widely used, inexpensive program for
the Macintosh called BinHex which will perform such conversions.
It's readily available at no charge from Macintosh user groups or
can be obtained for $10 from its author, Yves Lempereur, 28611B
Canwood Street, Agoura Hills, California 91301.
If you're willing to forgo using MacTerminal, there's an excellent terminal program called Red Ryder which is also available
from user groups. Release 5.0 and above of Red Ryder allows direct transfer of almost all Macintosh files to and from information
services with no conversion required. Red Ryder is also not subject
to the file size limitations of MacTerminal (MacTerminal will
XMODEM-transfer files and documents smaller than SOK to and
from non-Macintosh systems). If you need more information
about the latest release of Red Ryder, contact the FreeSoft Company, 10828 Lacklink, St. Louis, Missouri 63114.
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Copying Data from MocTerminol to Other Applications
New MacTerminal documents are preset to record incoming or
outgoing data (with the exception of data transferred via
XMODEM) as it scrolls off the top of the terminal screen. You can
select all or part of the data in a MacTerminal document and then
copy it to the Macintosh's Clipboard using the copy options provided. If the data is in columnar format, a special copy option is
available which makes moving such data into Word, Chart,
Multiplan, or File a snap.
Suppose you're logged onto a commercial information service
and have the following information on your screen:
Figure 8·16. Gold Quote Screen
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You can select the text you desire by dragging the mouse
cursor across it, or by choosing an insertion point at one end of
the text, holding down the Shift key, and clicking where you want
to end the selection . Choose the Copy Ta ble command from the
Edit menu .
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Figure 8-17. Copy Table Screen
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A copy of the selected text will be placed in the Clipboard
with the spaces between items replaced by a tab character. If you
have multiple selections that you wish to copy, the contents of the
Clipboard may be moved into the Macintosh's Scrapbook by
selecting Scrapbook from the Apple menu and choosing Paste from
the Edit menu.
After the telecomputing session is over and you've quit
MacTerminal, you can load another application (such as Mu ltiplan),
and the data residing in the Scrapbook and jor Clipboard can be
pasted into a new spreadsheet and manipulated as need be.
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Figure 8-18. Multiplan Gold Screen
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The Information Services
When you go online with an information service, a whole new
world of information opens up . You can gather a wide variety of
information without ever leaving your home, and this information
can either be printed out or stored in compact form as disk files.
Here are some of the services you're likely to see offered:

General
News, sports, and weather. Many services carry stories from
the UPI and/ or AP wires. The service may offer a menu of the
latest stories or allow you to search the wire for a particular story
or type of story. Online editions of daily newspapers, such as the
Washington Post, are also commonly found .
Online magazines. These magazines range from electronic
editions of print publications (like Popular Science or Family
Computing) to online exclusives.
Travel information. Airline scheduling and price information, including the definitive (and somewhat expensive) online
version of the Official Airline Guide, is often available. Restaurant
and hotel guides are common and may be more current than
printed versions.
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Government publications. Some databases carry the text of
Internal Revenue and/or Social Security Administration publications.
Research. Research databases let you search through abstracts
of thousands of magazine and journal articles drawn from the
technical and professional literature in selected subject areas such
as medicine, engineering, chemistry, education, social sciences,
and religion.
Many of the general information services feature an online
edition of an entire encyclopedia. Articles may be retrieved by
title (and in some cases by subject reference).

Financial
Business and financial information. Stock price quotations
are the most prevalent feature, but many services also include
fundamental financial data about major corporations, economic
analysis and forecasts, business news, journal articles, and
employment services.
Banking. Information utilities like CompuServe and Delphi
offer accounts through a number of banks, and the Bank of America has recently announced its own version of the electronic account. Most such accounts, for example, offer checkless electronic
funds transfers for paying bills to thousands of institutions.
Stock transactions. Brokerage accounts are available that
allow you to transact business online. The most ambitious of these
is the program announced by The Source in connection with
Spear Securities. This service lets you receive confirmation within
a couple of minutes of ordering. It provides many other benefits
such as automatic portfolio tracking (even putting together and
tracking paper portfolios to test a strategy without investing any
money). It even allows investors to get up-to-the-minute quote
information (without the usual exchange delay) before placing
orders.

Communications
One of the strong points of telecomputing services is their ability
to facilitate communication. Often, other computer users prove to
be a more valuable source of information than the pages of text
stored on a system. The services that are offered in this area include electronic mail, message boards, and direct online communications (computer conferencing).
Electronic mail. Electronic mail is a service whereby one user
can send a message to another. Typically, the user either
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composes the message online, or writes it offline, saves it to a file,
and then transfers that file.
Message boards. Message boards work somewhat like the
bulletin board in your local supermarket. Users can leave messages of general interest for all others to read. These boards are
usually organized by the subject of the messages (such as a
particular computer, like the Macintosh). Message boards are an
excellent place to buy or sell equipment, ask questions, and gain
the benefits of other users' experiences. Included in this category
are public ftle access areas, where users can retrieve program files
containing software written by others.
Conferencing. Conferencing is a term which is meant to include all direct user-to-user communication. During a conference,
everything that's typed at one user's keyboard appears on the other's display screen. Two users may carry on a private conversation
or many users may participate in a spirited free-for-all.

The Services at a Glance
MacTerminal comes packaged with a number of special offers for
membership in various commercial information services. Here's a
brief compendium of the most popular information services in operation today.
CompuServe's Consumer Information Service
CompuServe Information Service
5000 Arlington Centre Boulevard
P.O. Box 20212
Columbus, Ohio 43220
(800) 848-8199
(614) 457-0802 (in Ohio)
CompuServe is a consumer-oriented videotex service, with more
than 140,000 active subscribers. The Consumer Information Service (CIS) contains hundreds of databases, and CompuServe has
tried to structure this mammoth service so that it contains something to please everyone. Because of its low prices, variety of service, easy access, and easy-to-use structure of multiple menus and
online aids, joining CIS is an ideal way for average users to become acquainted with the advantages of telecomputing.
Along with the benefits, however, come several drawbacks.
The system is so large as to overwhelm and dismay beginners.
Even seasoned users may find it difficult to navigate. At times
there are so many users on the system that it's sluggish and unresponsive, especially during peak hours.
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Despite these minor problems, new users continue to pour
into the system. The reason is simple. For what's offered, the
price is hard to beat.
CompuServe's Executive Information Service
CompuServe Information Service
5000 Arlington Centre Boulevard
P.O. Box 20212
Columbus, Ohio 43220
(800) 848-8199
(614) 457-0802 (in Ohio)
The boom in business use of personal computers inspired CompuServe to develop an additional service for people who had never
debugged a program or played a computer game. The Executive
Information Service is CompuServe with a touch of class. It contains most of the databases as the Consumer Service, only clustered differently to appeal to business and professional users.
Some new services have also been added to beef up business and
investment coverage. All Executive Service subscribers also have
complete access to the Consumer Service, at the same rates as any
other member.
The Executive Information Service doesn't offer all that much
more than CompuServe's Consumer Service, but on the other
hand it doesn't cost much more, either. If you need financial
information or the news clipping service, you'll appreciate the improved layout and superior documentation offered by this service.
The Source
Source Telecomputing Corporation
1616 Anderson Road
McLean, Virginia 22102
(800) 336-3366
(703) 821-6666 (in Virginia)
Although it has fewer subscribers than CompuServe, The Source
appears to operate on the premise that quality is more important
than quantity.
It may not feature all the databases offered by CompuServe,
but it still offers almost every conceivable type of online service.
The Source is a smooth-running system that strikes a good balance between ease of use for beginners and power and flexibility
for more advanced users. It is a premium information service at
popular prices.
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Dow Jones News/Retrieval
Dow Jones and Company, Inc.
P.O. Box 300
Princeton, New Jersey 08540
(800) 257-5114
(609) 452-2000 (in New Jersey)
Dow Jones News/Retrieval provides detailed financial information
about public and private companies, current and historical stock
market quotes and averages, research and economic survey services, and business and economic news services that range from
current capsule summaries to the full text of the Wall Street Journal. In addition, it offers more general information services.
Dow Jones does not come cheap. Because of the rather steep
fee structure, prospective users of this service should be aware
that the same types of services (and in some cases, the same
databases) are often available elsewhere for a fraction of the cost.
Despite its relatively high cost and difficulty of use, Dow
Jones may be of interest to business users because of its dedication to quality and its high level of support.
Delphi
General Videotex Corporation
3 Blackstone Street
Cambridge, Massachusetts 02139
(617) 491-3393
Delphi is a relatively new information utility, but it already offers
services that rival, and in some cases surpass, those of the established giants. It offers full-featured database services, but is very
easy to operate. The electronic mail and conference sections are
very well implemented, and Delphi has some unique features,
such as the ability to send electronic mail to users of The Source
and CompuServe.
The biggest drawback to Delphi is its relatively small base of
users. With fewer than 6,000 subscribers, it's quite possible to log
on and be the only one on the system. Within its limits, Delphi
is a friendly, responsive system, with about the lowest possible
connect-time charges. Moreover, Delphi has some big changes
planned, which could make it more competitive with the major
information services.
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NewsNet
945 Haverford Road
Bryn Mawr, Pennsylvania 19010
(800) 345-1301
(215) 527-8030 (in Pennsylvania)
NewsNet is a research service that features the full text of dozens
of private industry newsletters, plus the UPI wire. It has innovative features such as an electronic clipping service that automatically deposits items on a designated subject into your
electronic mailbox.
The service carries newsletters in a wide range of subject categories from advertising and marketing to real estate and taxation.
MCI Mail
MCI Mail
Box 1001
1900 M Street, NW
Washington, DC 20036
(800) 624-2255
Electronic mail may be here, but it has yet to catch on in a big
way. There are a number of different services, such as Western
Union's Easylink and the Postal Service's Ecom, but they allow
electronic delivery only to subscribers of the same service. Of the
electronic mail services, MCI Mail does seem to come closest to
delivering on the promise of electronic communications. Paper
correspondence sent by MCI Mail can be customized with the
sender's letterhead and signatures so that it looks like a real letter.

Not the End
This chapter has shown how to transfer files from your Macintosh
to almost any other type of computer. But it's just briefly touched
on telecomputing theory and the world of information accessible
via a modem-equipped Macintosh running sophisticated terminal
software. The MacTerminal manual contains more detailed information on operating MacTerminal and the other features it provides. Readers who want more information on telecomputing
should consider acquiring an entire book devoted to the subject. If
your curiosity has been "double-clicked" by this chapter, you may
want to take note of COMPUTE!'s book MacTalk, Telecomputing on
the Macintosh for future reference.
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The word personal in personal computing
implies independence. With a computer,
you can do things it previously took an entire staff to do. If only for that reason, personal computers are revolutionizing today's
a
office. You can have independence, for
.
you're able to create your own reports, mant
t
age your own accounts, and locate almost any
kind of information. A word processor makes it easy to construct
anything ranging from annual reports to business letters. A spreadsheet program can help track accounts payable and accounts
receivable, providing up-to-date figures for the bottom line on demand. A database program can retrieve information very quickly.
But you also can use a personal computer to maintain direct
control over your office environment. Not just your own desk, but
throughout your office or even throughout your entire company.
Your support staff, consisting of secretaries, file clerks, accountants, graphic artists, project managers, and others, offer extended
office capabilities, but sometimes it's difficult to get the parts to
act as a whole. The computer allows you to directly supervise
personnel in the office next door or in th e branch office across the
country.
With the electronic office, you can retain control and maintain
independence.

/;J

(~*~)

Putting It All Together
The Macintosh's office presence is spreading. It's so quick and
easy to use that any executive can carry out many of the tasks
typically relegated to a support staff. And many of those functions
remaining with th e staff can be reviewed quickly and on demand.
The vice president of a software development firm boots her
Macintosh and starts a spreadsheet program, runs some calculations, and copies a range of numbers to the Clipboard. She quits
the spreadsheet program and opens a graphics program, instructing it to represent the data as a pie chart. She copies the graphics
into the Clipboard, opens the word processor, and types in a
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letter. She pastes the chart into the letter to describe the numbers
she's referring to. The result is handsome and presentable.
The Macintosh was designed to let you orchestrate several
programs to perform together in a harmonious manner. This
chapter shows how you can integrate several stand-alone programs to increase your productivity in the MacOffice.
In previous chapters, you learned how to use Microsoft's
Multiplan, Chart, Word, and File, as well as Apple's MacTerminal.
These are powerful applications, offering a wide array of features
to fill your business needs. The value of these programs increases
dramatically when you learn to move data from one application to
another. You can create charts and reports from your spreadsheet
calculations or write letters that include data from your database
and spreadsheet documents. It's all quite simple with the
Macintosh.

Free Integration
Several commercially available integrated software packages for
the Macintosh offer you a collection of programs that produce
data which can be moved from one component to another. Unfortunately, this capability has its price, a rather steep one. To fit
all these large applications into a disk that can hold only 400K of
information, integrated software must pare the features the individual components provide. What you end up with is one
powerful central component, such as a spreadsheet or database,
and a number of weaker applications to support it. If you were
shopping for software, you'd probably never give these secondary
programs serious consideration as separate applications. As Steven
Jobs, chairman of Apple Computer, puts it, "It's almost impossible
to have the best version of each program in the [integrated] package," adding that he thinks most integrated software "is a compromise" (Computer Systems News, May 6, 1985).
Why buy integrated software when you already have a number of powerful applications, like Microsoft Multiplan and Chart,
that you can integrate yourself? With a free program called
Switcher (available from Apple dealers and on CompuServe's
MAUG Forum, among other places), you can integrate the programs of your choice. Switcher lets you move from one program
to another even faster than you can with integrated packages.
Switcher also allows quick and easy transfer of data between files
of different programs.
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In this chapter of MacOffice: Using the Macintosh for Everything, you'll learn how to use Multiplan, File, Chart, MacTerminal,
and Word to perform a single task.

• •

Figure 9·1. Software for Integration

Multip'l.va

~

Microsoft Chart

Microsoft Word

~

Microsoft File

~

Mac:Ttrmtnal

We call the task project management. Our example is a simple
business application. We've emphasized the integration of the
applications rather than the applications themselves. Once you
understand how to integrate data from several stand-alone programs, you can develop your own more complex integrated Macintosh systems.

Project Management
Project management can be a very useful and time-saving task for
Macintosh computers in a business environment. In our example,
several projects are being worked on by several employees at the
same time, but in different offices. Employees enter their time
cards into their own Multiplan worksheets and send the information via telephone lines and modem each week to a project
manager. The project manager uses a second Multiplan worksheet
to summarize all the time cards for that week. The manager then
uses Microsoft File to maintain a database of weekly time card
summaries. This database is updated each week to track the time
spent on various jobs, informing the manager which employees
are working on which jobs, how much time each employee is
spending on each job, and how much total time each job is taking. File enables the manager to produce a variety of reports that
present this data according to specified criteria. Chart can be used
to create a pie chart to describe how an employee's time is divided among several different jobs. Finally, the project manager
can use Microsoft Word to prepare a letter containing the pie chart
from Chart, and perhaps a series of numbers from File, and send it
by modem to officers of the company.
Integration allows businesses to make more efficient use of
data generated by specialized programs. The Macintosh automates
the process of collecting, transmitting, and analyzing weekly data.
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It then gives you the freedom to incorporate the results into
charts, reports, and letters. Projects can be tracked as they
develop.

Creating the Time Card
In our example, each employee fills out a time card each week to
track the number of hours spent on each job. The time cards are
sent to the project manager by a modem controlled by MacTerminal. The manager uses a job summary template to collect all
the data from the time cards automatically, summarizing all the
hours spent on all the jobs by all the employees each week. In
this section, you'll see how to create just such a time card for each
employee of your firm.

Setting Up the Labels and Formatting
Your first task as project manager is to create a Multiplan
worksheet to serve as the time card. Insert your Multiplan disk
and double-click its icon to open the spreadsheet. First, you'll enter the labels above the dashed line as they appear in Figure 9-2.
Figure 9-2. Starting the Timecard Template
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11.

Select the first cell, type in Time Card, and press the Enter
key. Click on the Row 2, Column 2 cell (R2C2), type Employee
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Name:, and press Enter. Don't worry about typing more characters than the cell can hold. When you press Enter after making an
entry, Multiplan displays all the typed text into that cell, spilling
its extra into empty cells to the right.
In the same way, type Week Ending: in cell R3C2 and press
Enter. Now you'll enter a series of labels for Row 5. The best way
to do this is to select all the Row 5 cells into which you'll enter labels by dragging the mouse pointer from R5Cl to R5C9. All selected cells are highlighted. The current cell for data entry is cell
R5Cl. Type Job Number and press Enter (remember to press the
Enter key, not Return). The current cell indicator moves to the
next highlighted cell. Type Total into this cell and press Enter.
Type Sun into the next cell, Mon into the next, and so on, until
you've entered all the days of the week.
But the labels-Time Card, Job Number, the days of the week, and Totalv~General
would look better centered. To do that, seDollar
lect them all by clicking on the Row 5 head
Percent
No Decimal
(which displays the row number) to select
Decimal
this row, and Command-click (hold down
Scientific
the 88 while you click the mouse's button)
Bar Graph
cell RlCl to select it, too. Then choose Align
Number Of Decimals...
Center from the Format menu to complete
·-···-··········-····-················-·······················-····-·- the centering procedure.
Align Left
XF
Now you can adjust the column widths
Align Right
xH
to make your worksheet look like that of
···-································-······································ Figure 9-2. Select the column head for ColCommas
............................................................................... umn 1, choose Column Width from the Format menu, and specify 13 for the number of
Column Width ...
spaces (Figure 9-3).
Figure 9-3. Setting Column Width
Column Width
New Column Width:

'""""11......:~-----'

D Set All Columns to Standard Width
OK ~

( Cancel )
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Columns 3 through 9 contain the days of the week. Drag the
pointer from the Column 3 head to the Column 9 head to highlight them. Use the Cell Width option from the Format menu to set
the width to 5. Now click on the head for Column 2 and set Column width to 9.
The easiest way to enter the dividing lines is to use the repeat
function. The syntax for the repeat function is
REPTe'character'',number of repetitions)

:•:z

Ul\dO
Cut
Copy
Paste
Clear
Show Clipboard

88H
88C
88U
888

t>ns1 <~ <md Ul\k ...
UnUnk ...

Fill Right
Fill Down
Sort •••

Click on R6Cl and enter
= REPT(11 =",63). This will enter 63 equal
( =) characters stretched across Row 6.
Another way to enter the repeat function
is to choose Paste Function from the Edit
menu.
You can scroll through the various
formulas listed with the scroll bar on the
right side of the Paste Function dialog box.
When you find the formula, click to highlight the repeat formula (Figure 9-4).

88R
8&0

Figure 9-4. Formula Choices
NOlO
NPU()
OR()
PI()
ROUND()
ROWO
SIGN()
SINO

g

Paste Function

::;lt

II!I!

!!II!!
~l=i;t
!iii!!
!ill'

~

OK

;J

Cancel

J

~

!

Clicking OK enters the formula into the selected worksheet cell
with the blinking cursor inside the parentheses, waiting for your
entry. Type in 11 =",63 and press Enter.
The easiest way to enter the dividing line for Row 14 (again,
refer to Figure 9-2) is to copy the formula for the dividing line
from Row 6. Click cell R14Cl, type an equal sign, click cell R6Cl,
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and press Enter. This copies cell R6C1's contents into R14Cl. If
you ever go back and change the contents of cell R6C1, the Row
14 contents will also change automatically. This worksheet gives
you seven rows, for up to seven different jobs. You could add
more rows if you needed to track more jobs.

Entering the Formulas
Now you're ready to enter the formulas that will do all your
calculations. The formulas you need will calculate the row sums
for the employee's total time spent on each job and the column
sums, which show the total hours the employee spent working on
each day of that particular week.
Multiplan makes it very easy for you to enter formulas that
refer to other cells of the worksheet. Rather than typing R9C2, for
example, to refer to that particular cell, all you have to do is click
on the cell and Multiplan enters a relative cell reference into your
formula. The formula shows the location of this cell relative to the
cell in which you're entering the formula. If you were typing the
formula in cell R10C6 and clicked on the example cell R9C2,
Multiplan would enter that cell reference as R[ -1 ]C[- 4]. The contents of the square brackets count how many rows and columns
Multiplan must backtrack to get to the chosen cell. Notice that
R9C2 is one row up ( -1) from and 4 columns to the left ( -4) of
R10C6. You can enter references to a range of adjacent cells by
dragging the pointer, as you'll see in a moment.
To enter the first row sum equation, click cell R7C2 and type
an equal sign(=). This lets Multiplan know you're going to enter
a formula rather than a label or number. Choose Paste Function
from the Edit menu and scroll through the formulas until you find
SUM(). Click it, then click OK to insert the SUM formula in your
cell. SUM is used in several places to calculate totals of two or
more cells. The syntax for SUM is
SUM(starting cell:ending cell)
To enter the range of cells you want to sum, drag the pointer arrow across the cells from R7C8 to R7C2. Multiplan puts the reference to this range of cells automatically into your formula.
Displayed in the bar above your spreadsheet, your formula
looks like this: =SUM(RC( +l]:RC[ +7]). (The colon in the middle of the formula is the symbol for a range of cells.) This tells
Multiplan that you want a reference to the cells that extend from
one column to the right within this row (RC[ + 1]) to the cell seven
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columns to the right (RC[ + 7]). Press Enter. Since no values have
been typed into these summed cells, the total in the cell containing the formula is zero.
Let's see exactly how valuable relative cell references can be.
You must enter sum equations into the cells below cell R7C2.
Multiplan's Fill Down and Fill Right commands from the Edit
menu make it easy to copy cell contents into succeeding cells. To
copy your sum formula into the cells for the various jobs, drag the
mouse pointer from R7C2 to R13C2 to select these cells. Choose
Fill Down from the Edit menu, and you've finished.
You'll enter the totals for the columns that contain the number of hours spent working each day in the same way. Click cell
R15C2 and enter the SUM formula with the Paste Function command from the Edit menu. Now drag the mouse pointer from
R7C2 to R13C2 and press Enter. To put the formulas into the
remaining cells, drag the pointer arrow from cells R15C2 to
R15C9 and choose Fill Right from the Edit menu. Your time card
is now ready for use.

Protecting the Worksheet
Only some of the cells in the time card require data entry. The
rest of the cells-those that contain labels and formulas-can be
protected so that they can't accidentally be altered by anyone
using the time card. Worksheets are protected with a password
which must be entered to reverse the protection. Before you protect it, you must first define as unprotected any cells that are to
contain values put in by the user.
Highlight the blocks of cells for number entry. Select R7Cl
through R13Cl, then with Command-dick, select both R7C3
through R13C9 and the cells for the name and week ending entries, R2CS and R3C5 (Figure 9-5).
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Figure 9-5. Selecting Unprotected Cells
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File

Edit

Select

Freeze Titles
Title s

..~'Unfre ez e

Set Page Break
II<Hfl<ll'<! 1'<1!)<! !lnwl:

Format

Options

Calculate

Choose Remove Cell Protection from the
Options menu .
Now choose Protect Docum ent from
the Options menu. The dialog box (Figure
9-6) prompts you to specify a password.

Show Formul as
Ualues

..~'Show

Protec t Document ..•
..I'Unprot ect Do cument •••

Figure 9-6. Password ·
Protec t Document
Password:

"-II_ _ __ ____,

L:J!K~J

Cancel
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Make sure that you keep a record of the password you type in,
because if you have to alter the template's protected cells later,
you won't be able to unprotect the cells unless you know it.
When you've typed in a password, click OK. In situations not
requiring a password, you can just click OK in the dialog box
without typing anything. This allows anyone to unprotect the
document to make changes in values or labels by choosing
Unprotect Document from the Options menu. .
A protected document is displayed on the screen without row
and column numbers and without cell division lines. Dotted lines
indicate cells that can accept data . When the employee using the
time card types data into the first appropriate cell (don't do it yet)
and presses the Enter key, Multiplan automatically highlights the
next data entry cell. In this way, the user can move from one unprotected cell to another until all the data is entered.
Figure 9-7. Protected Document Format
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Edit
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FormBt
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C8lcul8te
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0

0

0

0

0

0
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Before you save the worksheet, click on cell R2C5 . Now save
it by choosing Save As from the File menu, naming it Time Card
1. When an employee opens the worksheet, the first data entry

cell (R2C5) will appear selected, ready for data entry.
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A Time Card for Each Employee
New
Open...
[lOS(~

Saue

Page setup...

. "..~~~~:.:.:"·"·······-········
Quit

For this simple example, there are only three
employees. That means you need two more time
cards for the other two employees. With Time Card
1 still on the screen, choose Save As from the File
menu and type in the name Time Card 2.
Click the Save button to save this worksheet on
your disk. Choose Save As again and type Time
Card 3. Now you have three different time card
templates on your disk, one for each employee.

Using the Time Card
The time card templates are ready to use. You distribute copies of
these time cards to the three employees required to keep track of
the time they spend on each job each week. Employees should be
instructed to fill in the time card with numbers assigned to the
various jobs they're working on. Each business uses a different
coding system for such job numbers. Frequently, these numbers
give valuable information about the jobs or projects. For example,
a software manufacturer's job number 300.20.45 might suggest
that this job is for the Macintosh division (300), that the specific
job is to develop an accounting program (20), and that this time is
being spent on the user's manual for the product (45).
Try filling in a time card. Notice what happens if you select
and try to fill in a cell other than those you've unprotected~ For
instance, try to fill in a space in the row labeled Time Card. You'll
see the dialog box shown in Figure 9-8.
Figure 9-8. Can't Change
~

lLU

Can't change
protected cells

H

OK

t)

Take a look at Figure 9-9-it shows a sample time card after it's
filled out by an employee.
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Figure 9-9. Completed Time Card
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Now you're ready to design the second Multiplan worksheet.

Creating the Job Summary Worksheet
The Job Summary worksheet will automatically collect information from all three time cards (Time Card 1, Time Card 2, and
Time Card 3 worksheets). This extraction of data from one
worksheet into another is accomplished by a powerful Multiplan
· feature called linking. Once you learn how to use linking, you'll
be able to design worksheets to perform sophisticated calculations
base.d on results from other, supporting worksheets. In this example, the time cards are the supporting worksheets for the job
summary worksheet. When a worksheet that's set up with links to
a supporting worksheet is opened, it automatically fetches the values from the cells of the supporting worksheet it's linked to.
Every time the time cards are updated for successive weeks, the
Job Summary worksheet, when opened, will have the new data
from all the time cards it's linked to .
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Creating the Labels
First, you'll set up the labels for the Job Summary worksheet.
Choose New from the File menu so you can start with a blank
worksheet. Enter the labels in Figure 9-10.
Figure 9·1 0. Job Summary Labels
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In Column 1, click cell R1C1 and Command-click cell R3C2 to select both these cells. Choose Align Center from the Format menu.
Drag across the heads for Columns 3 and 4 to select both columns, and again choose Align Center. Click cell R4C1 and enter
the formula =REPT("=",63) to insert the dividing line. (Remember, you can save yourself some typing by using the Paste Function command from the Edit menu to insert the formula.) Change
the width of the columns-highlight each by clicking on the column head and selecting Column Width from the Format menu.
Modify Columns 1, 2, 3, and 4 so that they are 13, 7, 15, and 12
wide, respectively. Now choose Save As from the File menu, give
this worksheet the title Job Summary, and click the Save button.
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Establishing the Links
To tell Multiplan which cells the Job
Summary worksheet should extract
from the Time Card worksheet, you'll
copy the cells to be linked from the
Time Card worksheet into the Clipboard with the Copy command, then
open the Job Summary worksheet, click
where the information is to go in, and
choose Paste and Link.

[ IHff Und o

Cut
Copy
Paste
Clear
Show Clipboard
Paste and Link ...
Unlmk ...
Paste Nome...
Paste Function ...
Hbsolufe fl<~fenm< P
Fill Right
Fill Down
Sort...

:•:l
3CR
3€0

Follow these steps to form your links:
• Open Time Card 1.
• Select the range of cells in Column 1 for the Job Number by
dragging (Figure 9-11).
Figure 9-11 . Dragging Column 1
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• Choose Copy from the Edit menu to copy this range of cells into
the Clipboard.
• Choose Open from the File menu and double-dick the Job Summary worksheet
• Click cell RSC1 as the insertion point, and choose Paste and Link
from the Edit menu. Click OK in the dialog box (Figure 9-12).
Figure 9·12. Paste and Link
Paste and Link
You are linking to R7C 1:R 13C 1 on time card 1.

0 Shift Cells Down
® Shift Cells Right
OK ~

( Cancel

• Before you go any further, save this worksheet using Save from
the File menu. (Note that the cells in Column 1 from Row 5 to
Row 11 have the contents Time Card 1 R7C1:R13Cl. This defines the worksheet from which the data is to be taken (Time
Card 1) and the range of cells from which the data is to be extracted (R7C1 to R13C1).
Let's continue with the total hours for each job. These values are in Column 2.
• Open Time Card 1.
• Select the range of cells in the Total column (Figure 9-13).
• Choose Copy from the File menu to copy the range of these cells
into the Clipboard.
• Choose Open from the File menu and double-dick the Job Summary worksheet.
• Click cell RSC2 as the insertion point and choose Paste and Link
from the Edit menu.
• Save this worksheet before you go any further.
Next, you'll copy the name of the employee from Time Card 1
and link it to the Job Summary worksheet.
• Open Time Card 1.
• Copy the contents of the employee name cell, R2C5, into the
Clipboard.
• Open the Job Summary worksheet.
• Click to select cell RSC3.
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Figure 9-13. Choosing from the Total Column
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• Choose Paste and Link from the Edit menu to complete the link.
Since the employee's name should be in the cells below RSC3,
carry out the following steps.
• Click to select R6C3.
• Type an equal sign ( = ) to start a formula entry.
• Click on cell RSC3, and press Enter.
This formula puts whatever is in cell RSC3 into R6C3. To repeat this formula in the cells below, drag from R6C3 to R11C3 to
select this range of cells in Column 3, and choose Fill Down from
the Edit menu. Save before you proceed.
Go back to the Time Card 1 worksheet and repeat the process
to link cell R3CS for the Week Ending entry into RSC4 of the Job
Summary worksheet. Make sure you fill the cells below with
week ending values as you ctid for the employee name column.
Save this worksheet before you proceed.
Now that you've established these links, each time the Job
Summary worksheet is opened, the linked values from Time Card
1 will be automatically inserted into Job Summary. This will save
the project manager a great deal of time. But you're not finished
yet. You still have to establish links for the other two employees,
those using Time Cards 2 and 3.
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• Open Time Card 2.
• Select the range of cells for the job number in Column 1.
• Choose Copy from the File menu to copy the range of these cells
into the Clipboard.
• Open the Job Summary worksheet.
• Click cell R12C1 as the insertion point (immediately below the
last linked cell from Time Card 1) and choose Paste and Link
from the Edit menu. Save this worksheet.
• Proceed as you did for Time Card 1 until the hours, employee
name, and week ending cells are all linked to the Job Summary
worksheet.
Repeat this process for Time Card 3.
Before you save the Job Summary
worksheet, make sure that Automatic
¥'Manual Calculation
Calculation is selected from the Calculate
menu. This insures that the employee
Iterate
..IDon't Iterate
names and week ending dates get copied
into the cells below the ones linked to the
set Completion Test
time cards. Finally, quit Multiplan.
St~lt~t;1 CmnJtl<~1 ion 1"<~~ t

...

Seffing Up the Database Form
Once the project manager receives time cards from the three
employees, he or she puts them on the same disk as the Job Summary worksheet while in the Finder. When the dialog box asks if
the items are to be replaced (refer to Figure 9-14), the manager
should answer yes, replacing the old time card values with the
current week's values.
Figure 9-14. Replacing Old with New
Replace Items with the same names
with the selected Items?

~~)

(cancel)

Opening the Job Summary worksheet automatically pulls in
all the required data from the three time cards (Figure 9-15).
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Figure 9-15. Automatic Entry
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Next, the project manager will take information from the Job
Summary worksheet and put it into a Microsoft File document. As
information in File, the data can be manipulated to yield a variety
of reports. Each week's data is added to this database. File is the
collecting and sorting facility for the project management
application.
Keep in mind that the Time Card and Job Summary
worksheets are volatile. Each week, new data is entered into a
time card and sent to the project manager, and the old time cards
are replaced with new values, which in tum feed into the job
summary to create a new summary for that particular week. The
stability in this project management paradigm comes from File.
File is the storehouse for all the information. Each week, new
information is pasted into File, along with the previous week's
data. The File document you'll prepare here will store a cumulative
compilation of all the data brought in from the time cards.

Creating the File Form
When you open Microsoft File, you're immediately presented with
a dialog box. Type Project Manager in the box labeled Name for
New Datafile and click the New button, just as illustrated in Figure
9-16.
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Figure 9-16. Opening File Dialog Box

•
Name for New Data file:

_,l(

I._P_ro-'j'-e_ct_M_a_n_a...::g_er_l_ _ _ _ _
or Select a Dataflle:
Good Restaurants
linda
Three Months Sales Quotas
uerbs

New

J

File Master

II[
,.-Ca-n-ce-1"""]

Eject

I ['-::n~rl,-tH-~'

This starts a new data file titled Project Manager. Before you
can put information into a data file, you must design a form that
contains the field names you want. The first field you'll use is Job
Number, so type Job Number at the insertion point (Figure 9-17)
and press Enter.
Figure 9- 17. First Field

*

File

Edit

Form
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File asks if this field is to hold text, a number, a date, or a
picture. Your job number has two decimal points in it, so it can't
really function as a number. Treat it as text. Click OK to accept it
as text data. The insertion point moves to the adjacent cell. Type
Hours here, select Number, and click OK. Type Employee in the
next cell and choose Text. For the last field, enter Date and choose
Date to define its type.
Figure 9-18. Date Type
-Type0 TeH t
ONumber
@Date
0 Picture

IFjjj(ll
~~

Notice that as you added fields to the form, they're duplicated in the List Helper window above the Form window.
Each field is the same width at this point. To adjust their column widths, move the mouse pointer to the lines between fields.
When the pointer changes to a double-headed arrow,
Figure 9-19. Column Widths
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drag to the right or left until your form resembles the one in Figure 9-20 (you don't have to be exact).
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Figure 9-20. File Form

Pasting the Data
Data from the Job Summary worksheet must now be pasted into
the data file.
• Quit File and eject the disk.
• Insert Multiplan and open it.
• Open the Job Summary worksheet. Assuming that the three time
cards have data in them and that all three are on the same disk
as the Job Summary worksheet, the data from the time cards will
automatically be pulled into the Job Summary worksheet by the
links you established earlier.
• Select all of the data by dragging the mouse diagonally from the
top-left corner cell of the block of data to the bottom-right corner (Figure 9-21). When you reach the bottom of the screen and
continue to move the mouse down, the entries will scroll upward
to allow you to select more items. Don't select the labels .
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Figure 9-21 . Choosing Data from Job Summary

• Choose Copy from the Edit menu to copy this data into the
Clipboard.
• Quit Multiplan and eject your Multiplan disk.
• Without turning off the Macintosh, insert the File disk. Doubleclick on th e Project Manager data file name to open.
• Click on the word New. This selects the New record as the insertion point for the data you're about to paste in.
• Choose Paste from the Edit window, and voila! Your data appears
·",
in your data file (Figure 9-22).
If you hear your disk drive spin once in a while, don 't worry.
Microsoft File automatically saves the file to disk every few seconds to prevent the accidental loss of data. When you quit File,
your data file is automatically saved for you.
Each week, the project manager w ill copy the data from the
Job Summary worksheet into the Clipboard and paste it into the
Fi le document. File makes it easy to analyze this data by allowing
you to sort your records in various ways.
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Figure 9-22. Data There
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Sorting the Records
3CF

Report...

Let's look at one way of sorting these
records. Suppose you want to have all entries for each job number together. This type
of sort is simple with File. Choose Sort from
the Organize menu and click in the box for
Job Number.
The number 1, followed by A-> 2 appears (Figure 9-23).

This lets you know that the Job Number is the first sort field (1),
that entries in this field will be read as text (A and Z), and that it
will be sorted in ascending order (-> ). If you click on A-> 2, it
turns into 2 ->A. You can toggle the order of sorting by doing this.
Start the process by clicking the Sort button. Your results should
resemble those shown in Figure 9-24.
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Figure 9-23. Starting a Sort

a

File

Edi t

Fo r m

Figure 9-24. Sorted by Job Number
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The job number field is treated as a text field because of the
double decimal. For this reason, the sort is performed on only the
first part of the job numbers, from the first digit to the first decimal point. This is acceptable in this example because you're interested only in having all entries for each job number sorted
together. Having them in numeric order isn't really important.
You'll see that there are a number of records which have zero
hours assigned to them. They're the unused rows of the time
cards. There's no point in keeping these records in the data file, so
you should delete them. Use the scroll box on the right to find the
beginning of a series of zero-hour entries, drag across the header
for each one, where the record number is, and choose Cut from
the Edit menu.
Figure 9-25. Deleting Records

•

Scroll down to the next series of zero records and cut those in
the same way. Continue until all zero entries have been removed
from the data file.
Now try sorting on all fields. Choose Sort from the Organize
menu, and click the hours, employee, and date fields . The 2 followed by A-> Z lets you know that the employee field is the second field and that it will be sorted as text in ascending alphabetic
order. The 3 and 1-> 9 in the date field let you know that the date
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field is the third sort field, that it's a number field, and that it will
be sorted in ascending order. The 4 followed by 1->9 in the hours
field indicates that this is the fourth sort, in ascending numeric order. Each low-level sort is carried out within the previous level
sort. This means, for example, that th e h ours within a series of
identical date fields will be sorted in ascending order.
Figure 9-26. All Sorts Ready
li

File Edit

Form

Click the Sort button to see your records sorted according to
the parameters you set up. (You really won't see the benefit of this
number of sort levels unless you have several weeks of records in
your File document.)

Creating Reports
File makes it easy to create a variety of reports from the data file
the project manager updates with each week's job summary information. These reports will prepare the data in an organized, tabular format with mathematical calculations carried out, if
necessary, on some of the fields. Unlike File's computed number
fields, a report's mathematical feature allows you to get totals
based on all the records in the data file. This can help the project
manager quickly obtain individual job totals, for example, as well
as grand totals for th e hours spent by all employees.
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Hilh~ lll'I:OI"d~

:•:fl

Show Rll Records

opens with all your fields listed, and with all
the sort conditions indicated.

aes

Sort...
RPport...

To create a report, choose Report from the
Organize menu. You'll see that a Report window

_

"R

Figure 9-27. Creating a Report
•

File

Edit

Form

~0

0

Report ~

If you move the
pointer between field division lines, the pointer
arrow will change to one
f7-!:~--F=...;.;==-r==~---+o=o
which points in four
directions. Drag the field
borders to widen or narrow your field widths.
These changes will be reflected in the reports that are generated.
You can alter the format of a field by double-clicking its
name. The Hours field will show a dialog box that looks like the
one in Figure 9-28.

0

summory Report
l=:=..!i~~~~;;:,:,;~~~;,:,:;,:.;.;.~~""'F.1=_}
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Figure 9·28. Format Field Dialog Box
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Suppose you want to get totals for each job. Double-dick the
cell under Hours called by Job Num to get a Summary dialog box
and click the Total box:
Figure 9-29. Field Summary-Total Hours by Job

Format Summary Field
Summary of Hours a by
'"Job Number"
Function
181 Total
D Count
D Auerage
OMinimum
OMaHimum
D Std. Deu.
N
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Now click the Summary Report button, then click the Preview button to have the report you've designed printed to the screen for your
examination. File will take a moment to do its work, and shortly
you'll see your report. It will resemble the one in Figure 9-30.
Figure 9·30. Total Hours Report

Job Number
100.23.17
100.29.00
10 1.00.00
108.22.22
200.30.23
62.09.04

Hours
16
15
21
24
16
30

Records processed: 11

This example presents very little data from your data file because it shows only grand totals for each job number. You can get
more information on your report by specifying that you also want
the total hours spent on each job by each employee. Double-click
the cell at the intersection of by Employee and Hours, click the Total box, and click OK. Now click Preview again to see your result
on the screen. Use the Pause button to freeze the scrolling report
if necessary.
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Figure 9-31. Previewing
•

File

Edit

Form

Organize

Job Number
Hours
Employee
100.23. 17
6 Jones, 8111
100.23. 17
_ _1_2 Smith, John
Total for 100.23. 17:
18
100.29.00
_ _1_5 Newabi, Suz1
Total for 100.29.00:
15
10 1.00.00
9 Jones, 8111
10 1.00.00
_ _1_2 Smith, John
Total for 101.00.00:
21

Now you can print your report by choosing
Print Report from the File menu.
880
You can see that as your records grow
ssw after months of entries, File's reporting
-·-·;~~-;~~;~~~-·-·--·-·--·-·-·
capability will prove to be a valuable way for
saue Report ns...
you to keep track of your projects by printing
...................................................................... out reports based on sorts and calculations
that you can define to suit your own information needs.
Quit
File's reporting capabilities give you a
wide range of tools for analyzing your data.
Spend some time experimenting with its features to learn how
they can help you. It's not difficult to use, but some practice is required to understand its powers and learn how to tap them.
New Report
Open Report •••
Close
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Integrating Chart and Multiplan
Integrated software packages allow you to create charts and
graphs from data generated from worksheets. You can do the
same thing with data from Multiplan. Charts and graphs will describe your data visually so that the viewer can draw conclusions
more quickly and easily. Microsoft Chart is a powerful charting
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program, offering features that graphics components of integrated
packages sometimes lack.
As an example of moving data from Multiplan to Chart, let's
take the total number of hours that employee Bill Jones spent on
each job and create a pie chart from these values, expressed as
percentages of the total time worked. This will help the project
manager understand how much time is being spent in each job as
a percentage of the total hours Jones works in a week. It will
make it easier for the manager to track the progress of the jobs
and estimate job costs.
• Start Multiplan.
• Open Time Card 3, Jones's current time card.
• Drag to select the ranges of cells that contain the job numbers
and the total hours for each job.
Figure 9-32. Selecting Job Numbers
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• Choose Copy from the Edit menu to put these cell ranges into
the Clipboard.
• Choose Show Clipboard from the Edit menu to see how a range
of numbers appears in the Clipboard.
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Figure 9-33. What's in the Clipboard
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• Quit Multiplan.
• Start Chart.
• Choose Show Clipboard from the Edit menu to see the numbers
stored there.
Figure 9-34. How Chart Shows Clipboard
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• Choose Paste from the Edit menu to paste the range of job numbers and hours from the Clipboard into the New Series window.
Figure 9-35. New Series
§0~ Time Allocation ~

Order: rr==J
1:81 Plot Series

:Q
r=

• Choose Text from the Data menu and type in
the names in Figure 9-36, using the Tab key to
move from one field to another. Click the OK
button.
Sort ...
Analyze ...
list...

3€l

Figure 9-36. Time Allocation, Job Number, and Total Hours
TeHt Series
Series Name:

!Time Allocation

I

Category Name: Job Number
Ualue Name:

T_o_ta_I_H_o_u_rs_ _ _ __....J

Ll

OK ~j

Cancel
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• Choose Pie from the Gallery menu, then select pie number 6, the one that shows
percentages.

Figure 9-37. Choose the Right Chart

e
3

OK

4

fj
Cancel

• Click the Plot box in the Data window to draw your chart.
Figure 9-38. Click Plot
•
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• Click on the Chart window to bring
it forward and choose Add Legend from
the Chart menu to get the result shown
in Figure 9-39.

Select Chart
Select Plot Rrea

3€R

B•~t1m w NOW

-/HU tom t~ tie fl(H II'<IHI

1'1nnun!

B•~t1mw

Show Chart Window

3€S

Figure 9-39. Final Pie

•

101.00.00

•

62.09 .04

•

108.22 .22

mm

100.23.17

0

200.30.23

• Now you can save and print your chart.
It's easy to move data from Multiplan to Chart. However, you
must plan for this in the design of your Multiplan worksheet.
Whenever two sets of data (such as the job number and total
hours in our example) are to be moved as X- andY-axes into
Chart, these ranges must be in adjacent columns in the Multiplan
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worksheet. If you had the total hours in Column 9 of the Time
Card worksheet, as logic would dictate, you would have been
forced to take extra, time-consuming steps to get both ranges into
Chart. Planning ahead can save you considerable time and
frustration.

Moving Data into Word
Word is a full-featured word processor. It can display text in columns, allow you to use footnotes, and even let you have four
word processing documents open at one time. For the purposes of
data integration, you can use Word as a host application for accumulating data from a number of sources. In our example, the
project manager can draft a letter and paste in a range of numbers
from Multiplan to support his or her decisions. Graphs from Chart
and several records from File can be imbedded within the letter.
This sort of integration can add value to your business correspondence. The integration of text and graphics from a variety of
sources is the Macintosh's main strength.
As an example of moving data into Word, let's move the pie
chart you just created into a letter. Bill Jones, employee number 3,
is working overtime, spending too much time on projects that
have been assigned small budgets. The project manager sees this
from the pie chart that describes Jones's allocation of his time for
each job. The manager sends Jones a letter illustrated by the chart.
Here are the steps for moving data from Chart to Word:
• Open Chart.
• Choose Open from the File menu and double-click the name of
the pie chart you saved earlier.
• Click on the window that contains the chart to bring it forward.
• Drag diagonally from the top-left corner of the pie chart to the
lower-right corner. The small boxes around the rectangular
perimeter of the chart indicate that the chart is now a selected
item. (Figure 9-40)
• Choose Copy Chart from the Edit menu to put the pie chart into
the Clipboard.
• Click As Shown on Screen in the dialog box, then click OK to put
the box away (Figure 9-41 ).
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Figure 9-40. Selecting the Chart
Form8t

•
1991S

•

101.00.00

•

62.0 9 .04

•

108 .2222

[[) 100.23.17

0

200.30.23

1391S

•

•

Figure 9-4 1. Put It Away
Copy Chart to Clipboard

@ Rs Shown on Screen
0 Rs Shown when Printed

OK ;_::::J

Cancel

• Quit Chart and open Word.
• Within the word processing document click where you want to
insert your pie chart.
• Choose Paste from the Edit menu. Your pie chart will appear in
your Wo rd document, just as shown in Figure 9-42.
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Figure 9-42. Chart Pasted In
•

File

Edit

Search

Character

Bill Jones
Houston Soft'w'ere Co.
111 E. MeinW.
Leucedie CA 91111

Document

1/ 13/B6

Dear Bill ,
1n studying the time cards for last 'w'eek, I noticed that you've been 'w'orki ng overtime. Of
course, I appreciate your enthusiasm for this difficult ne'w' assignment, but maybe there's
sometht ng 'w'e can do about tt.
If you study the pte chart I created from the time card date, you'll find that
Timt Allocotion

•

101.00.00

•

62.09.04

I

• To center your chart, first click it to select. A box will appear
around the chart. Drag the right bordering line of the chart to
the right until the chart is centered.
Figure 9-43. Chart Centered
•

File

Edit

Search

Character

Do cument
--===

-----~

-- -

Leucadia CA 91111
Dear Bill ,
In studying the time cards for lest 'w'ee k, I noticed that you've been 'Working overtime. Of .
course , I appreciate your enthusiasm for this difficult ne'w' assignment, but maybe there's
something 'w'e can do about it .
chart I created from the time cord
find that
Tim• Allocotion
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Following similar steps, you can paste items from Multiplan,
Chart, File, or most other Macintosh application programs into
your Word document. In this way you can let Word be the integration vehicle for all the various applications you're working in
harmony.

Sending Files with MacTerminal
To get the most benefit from your MacOffice and the integration
capabilities described here, you can use telecommunications to
transmit files from one Macintosh to another. All you need is an
Apple modem, or another Macintosh-compatible modem, and a
terminal program such as MacTerminal. In our example, this will
let employees send their weekly time cards to the project manager
instantly for immediate analysis.

Using MoeTerminal
Insert your MacTerminal program disk and
double-click the MacTerminal application icon.
Now you must set some of the parameters in
order to prepare for communicating with another Macintosh. Choose Phone Settings from
the Phone menu and type in the phone number of the line the
Macintosh on the receiving end is using. Set your modem's baud
rate.
Figure 9·44. Phone
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Choose File Transfer from the Settings
menu and check XModem and

MacTerminal.
Character Sets .••
Show Tab Ruler

Figure 9-45. Ready to Transmit
4i File Edit Commands

File Transfer Settings
Transfer Method
Remote System

® HModem
O
® MacTermlnal 0

TeHt
Other

Delay Between Chars

iu

Delay Between Line s

~ I 60th Second

II

60th Second

[81 Retain Line Breaks
[81 Word Wrap Outgoing TeHt

N(Jlll
lliH~n."

Close
Saue
Saue As ...

Page Setup ...
Print Sele< tion ."
Quit
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At this point, you're ready to call the remote
Macintosh and send the file. Let's use the example of the time card as the file to send. The
sending Macintosh chooses Dial from the Phone
menu, while the receiving Macintosh ch ooses
Wait for Call from the same menu . When you've
established contact, choose Send File from the
Edit menu.
From the dialog box, the sender should
double-dick the name of the file to send. The
receiver should see the dialog box shown in Figure 9-46.
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Figure 9·46. Receive
File Name:
Terminal

ITime Card 1
( Recelu'I;J

Eject
Cancel

Oriue

At this point the receiver can choose which drive the file will
be recorded on by clicking the Drive button.
Both the sender and the receiver will see a dialog box which
shows the progress of the transfer in terms of percentage completion. The file will be written to the receiver's disk. When the
transmission is complete, the file will appear in the receiver's disk
window of the Finder. Both parties can now choose Hang Up from
the Phone menu.
Quit MacTerminal, eject the disk, insert Multiplan, and open
it. Choose Open from the File menu and double-click the name of
the file you received. It will open in the normal way.

Compiling the Received Data
After receiving all the time cards, the project manager must insure
that they are named Time Card 1, Time Card 2, and Time Card 3,
just the way they were originally named when the Job Summary
worksheet was linked to the time cards. When the Job Summary
worksheet is opened, it will search the disk for these files by these
names. Remember, the job summary and time card files must be
on the same disk or at least in the external drive if you have one.
When the Job Summary worksheet is opened, the values from the
time cards are automatically inserted. Each week, new time cards
and a new job summary will be generated and compiled into the
Microsoft File form for analysis.

Using Switcher for Better Integration
When you're integrating data from several applications as described here, you'll find that a lot of time is spent quitting programs and juggling disks in and out of drives. This problem can
be resolved to some extent with the purchase of a hard disk drive.
By putting all your application programs and their associated
documents on the hard disk, you can quit one and open another
more quickly than by using individual application and data disks.
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Switch and Paste
~

A better resolution is a small program called Switcher.
Switcher is a utility program that makes integration beswnctt.r tween stand-alone programs extremely fast and easy.
Working with Macintoshes with at least 512K of RAM, Switcher
allows you to load several application programs into the machine's RAM and have them all active at the same time. You can
switch from one program to the other and back again with the
click of the mouse.
Data can be moved from one program to the other with
Switcher via the Clipboard. For example, you can take a range of
numbers from Multiplan, copy it into the Clipboard, switch to File
(without swapping disks), and paste the data into a data file. Then
you can .create a report from File and paste it into Word just by
switching.
In our project management example, you had to do a lot of
disk juggling to create your pie chart and paste it into Word. With
Switcher, you can do it like this:
• Copy a range of numbers from Multiplan into the Clipboard.
• Switch to Chart and paste them into the New Series window.
• Create a chart and copy it into the Clipboard.
• Switch to Word and paste the chart into your letter.
Without Switcher, this process would have taken at least ten times
longer. You would have had to quit, eject, and open three times.
Going back to the Finder each time takes a great deal of time. You
can switch between programs in this way faster than you can with
commercially sold integrated programs that cost over $500.
Switcher makes the Macintosh a joy to use.
~

Save Several Sets
With Macintosh application programs as large as Microsoft's, you
can have only three applications running at one time in a 512K
Macintosh. You can have Multiplan, File, and Word for one situation, and Multiplan, Chart, and MacTerminal for another.

310

Chapter 9

Figure 9·47. Switcher
II File l:di1 Switcher

Multiplan

MacWri te 4.5

Microsoft Chart

Double-click here to launch on opplicotion ...

~
~

Once you set up a series of applications, you can save
these sets as files on disk and open the one of your choice
Switcher Sot when needed.
As mentioned earlier, Switcher is free. Apple has released
Switcher to the public domain. You can get a copy of it from an
Apple dealer or by logging onto CompuServe with MacTerminal,
going to the Macintosh area, and downloading it. (The process
isn't quite as simple as the description, but it's not overly difficult.
Have someone familiar with CompuServe and the Apple Forum
area give you a hand if you've never downloaded anything
before.)

Switching to the Finder
By selecting the Finder as one of the programs to switch to, you
can go to the Finder from an application program such as
Multiplan and do some file management, such as deleting and
copying files, and then switch back to Multiplan. This can save
you even more time.

Switcher with Two-Megabyte Macs
Macintosh memory upgrades of at least two megabytes of RAM
are available from at least two third-party developers (see below).
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For less than the cost of the original upgrade to 512K, you can increase your Mac's internal memory to a whopping two megabytes!
In this roomy environment, Switcher is free to perform at its peak.
It can let you switch between eight different programs in a split
second. With the price of memory going down each month, a
two-megabyte Macintosh will be within the budgets of most of us.

The Success of the MacOffice
The Macintosh's ease of use will firmly entrench it in the business
environment. As businesses make the Macintosh their preferred
business tool, and as the Fortune 1000 companies buy them by
the score, software developers will accelerate their software offerings. As the machines's memory expands, software will become
increasingly powerful. After all, it's software that drives the hardware. And with more software, the Macintosh will become the
prominent force in the office environment.
RAM Upgrade Vendors
Bech-Tech (one-megabyte upgrades)
41 Tunnel Road
Hotel Claremont
Berkeley, CA 94705
(415) 548-4054

Levco (two-megabyte upgrades)
6160 Lusk Blvd., Suite C203
San Diego, CA, 92121
(619) 755-7827
Mass Tech (one-megabyte upgrades)
773 Boston Road
Groton, MA, 01450
(617) 448-3450
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Beyond MacOfficeNetworking
Paul Freiberger and Dan McNeill

Let's pull back now, rise up
through the ceiling of the
MacOffice as if we're on a
movie crane, and survey the
entire floor. From our airy
perspective, it's a warren of cubicles, with people moving
back and forth in the halls.
Some are carrying documents
from one office to another. Others are heading for the copier, and
still others are seated at their desks, working with Word or File.
Inspect the floor a little more closely-look for printers. Company printers can be laid out in two basic patterns. In the first,
there are numerous printers, one on each desktop. This approach
may seem commonsensical, but it's actually inefficient. If there are
20 offices in the firm and printers cost $500 apiece, the total price
of the machines is $10,000. Yet for most of the day, each one is
idle. Moreover, a $500 printer isn't exactly at the peak of technology. It's usually slow and noisy, and its output may even be
unsightly.
In the second pattern, the entire business has one printer. All
20 computers are connected to it and can use it at will. The company pays, say, $7,000 for Apple's LaserWriter, saving $3,000. In
return, it gets an excellent machine that can render almost typeset
quality results, enhancing the general company output and saving
even more on third-party typographic jobs.
Such an arrangement is called a network, or, sometimes, a local area network (LAN), to distinguish it from the wide-area networks that may cover states, nations, or even the entire globe.
Networking is possible because electricity travels at the speed of
light. If you have a mass-storage device like a hard disk on your
desk, your computer communicates with it almost instantaneously. You can put the hard disk in the basement of your building and communicate with it at virtually the same speed. In fact,
you can put it halfway around the world, in Sydney or New
Delhi, and still work with it. And if your computer can access
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printers and hard disks at a distance, others should be able to
string wires to them and access them, too. If you all share them,
naturally, you can pool the cost.
Since economy is a main objective of a network, its price
should not tum its savings into a laughable memory. In the example above, if the network cost $3,000-$150 per connectionits greater quality could certainly justify it, but since your total
outlay would again be $10,000, the network would no longer be
the fiscal hero of the office. If it were even more expensive, it
could be pointless. In fact, affordability has been a major problem
in this field. Wide-area networks like ARPANet have linked mainframes and minicomputers globally since the late 1960s, but
they've been costly, designed for costly machines. It's taken time
to make the technology economical for the much cheaper personal
computers. The first LAN was Ethernet, introduced commercially
by Xerox at the end of the 1970s, and since then LANs have gradually become more feasible.
Yet they've hardly spun webs throughout the corporate
world. Their price tags, while not forbidding, have remained
disturbing: from several hundred to over a thousand dollars per
connection. And since most require expensive cables which must
be installed and maintained by professional contractors-at even
further expense-they've acquired a daunting mystique. Moreover, since they've not been prevalent, little software has appeared for them, stunting their utility and so, in the classic
computer vicious circle, curbing their prevalence.
Yet a network called AppleTalk may soon alter this situation.
AT&T Information Systems estimates network product sales will
reach $287 million in 1985 and climb to $720 million by 1987. If
the field really does triple in three years, much of the credit will
likely go to this product.

AppleTalk
When Apple formally announced its Macintosh Office in January
1985, it unveiled its new approach to linking office computersthe AppleTalk Personal Network. AppleTalk was different. Until
it, most LAN manufacturers offered relatively high cable speed,
lengths of several miles, and support for hundreds of users.
There's nothing wrong with this, but their price had an unfriendly
effect on the wallet.
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In contrast, AppleTalk is inexpensive. It costs $50 per Macintosh, and its cable is also very cheap. Almost anyone who can
follow instructions can install it. Software seems to be appearing
for it at a decent clip, helping it realize its potential. AppleTalk is
also gregarious. You can use it not only with the Macintosh, but
with Apple 11-series computers and almost any other personal
computer including the IBM PC.
Figure 10-1. AppleTalk

The Apple Talk Network connection takes only a few minutes to Install.

" We think networking is going to start from the bottom up in
small work groups," says former Apple chairman Steve Jobs, and
the network reflects this small-is-sensible philosophy. It supports
only 32 users. It can extend no further than 1000 feet before data
begins to deteriorate. And its cable speed is somewhat slower
than its competitors'. These are real technical limitations, yet
they've helped slash the price of the system. More important,
their ultimate impact on quality has been slight. Apple has cleverly compensated for reduced size and cable speed, as you'll see.
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The Elements of AppleTalk
To make an economical, easy-to-use network, Apple first had to
decide on its structure. Networks come in several different structures, but three have achieved the greatest prominence:
• Star. A star network is shaped like an asterisk. At the hub is a
main switching station, which routes information from one computer or peripheral-one node-to another. If you send a spreadsheet to the individual in the next office, for instance, it travels
from your Macintosh to the central host and back out to your
neighbor. This arrangement is sometimes referred to as a
master jslave relationship. Of course, it's somewhat difficult to
hook up new nodes, since they must be wired all the way in to
the host. And if anything happens to the host, the network falls
to its knees. The office PBX (Private Branch Exchange) is a common type of star network.
Figure 10-2. Star Network

• Ring. As a star network is completely centralized, so a ring is

completely decentralized. In a ring network, each computer is
linked directly to the two computers closest to it, in daisychain
fashion. Messages constantly enter your computer, which checks
to see if it should receive them. If not, it hands them on to the
next. Thus, if you were to send a spreadsheet to someone on the
other side of the building, it would computer-hop until it found
its destination. A drawback to this structure is that if the ring
breaks at any point the network collapses.
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Figure 10-3. Ring Network

• Linear bus. The linear bus is something of a cross between the
star and the ring, and can be visualized as a freeway with onand off-ramps. The freeway proper is the trunk cable, which runs
near the computers and peripherals without passing through any
of them. Wires called droplines act as ramps between the nodes
and the cable. It's very easy to add or remove a computer from
such a system, and problems in one machine don't break the
back of the operation.
Figure 10-4. Linear Bus Network

Apple chose the linear bus for AppleTalk, and its components
are few. It requires, first, a trunk cable, available from Apple in
lengths of two or ten meters. This cable costs from 15 to 30 cents
per foot, compared with the $4 per foot for Ethernet's thick yellow
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cable. The difference in cost comes from the AppleTalk cable's
slower absolute speed and its consequent easier availability.
Second, it needs droplines so that computers can tap into the
trunk cable. An AppleTalk dropline is a cord with a small white
box on one end and a plug on the other. The box, called the
connector module, measures 3 X 2 X 1 inches, and attaches to the
trunk cable. The other end plugs into the computer. The $50
AppleTalk Connector Kit, which each node requires, comes with a
dropline, two meters of trunk cable, and a small cable extender, to
let you fit one length of cable into another.
Third, each computer needs an interface device. An interface
lets the computer communicate with the network. It usually comes
in two parts, one oriented to the machine, the other to the network. A modem is one kind of interface, translating between computer and phone lines. The Macintosh network interface is already
built-in, in a Zilog 8530 communications chip, and thus costs you
nothing. Apple lis and the IBM PC lack such a chip, and require
extra interface boards which may run a few hundred dollars.
Fourth, you need software, a set of instructions to tell your
computer how to exploit the linkup. Hardware without software is
about as useful as a book with blank pages. The AppleTalk systems software is called the Macintosh AppleTalk Manager. It becomes a part of the Macintosh operating system, filling about 6K
and enabling application programs to use AppleTalk. Of course,
you need applications to perform all the special tasks the network
is capable of, such as electronic mail and mass-storage access.
There are many third-party software packages for AppleTalk, and
Apple Computer has actively fostered their development.
Let's return to our baseline example. Installing AppleTalk in a
20-Macintosh company would cost $1,000 for the Kits, perhaps
$200 for the cable, nothing for the interfaces, and, if you wished
to use only the LaserWriter, nothing for extra software. The total
price would be $8,200, a savings of $1,800 over 20 cheap printers.
Of course, you might well want to purchase additional software
for applications like electronic mail, and such enhancements increase your cost. But they also give you powers impossible without a network.
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Capacities
Two prime virtues of AppleTalk are, of course, its cost and ease of
use. But the network is not simply a stripped-down version of
more expensive offerings. It's reasonably fast and compatible with
non-Apple computers, and these qualities make it a highly professional system.
The AppleTalk cable is something less than the Bonneville
Salt Flats of network wiring. It carries information at the "moderate" velocity of 230,400 bits per second (bps). It's thus much
faster than a modem, which has a standard speed of 1200 bps,
and a normal upper limit of around 9600 bps. At the same time, it
cannot compare with a network like Ethernet, which whisks data
about at ten million bits per second or more.
But bits per second is not the only measure of network speed.
A second factor, with the somewhat jargony name of throughput,
is also important. Throughput refers to the amount of data passing
through the cable. In general, the more nodes you link up to a
network, the slower the throughput. A system like Ethernet can
have thousands of nodes, whose combined messages can congest
the lines. In contrast, since AppleTalk holds no more than 32, its
avenues are relatively free.
AppleTalk throughput is heightened by Apple's "smart-node
strategy." "The decision we made was fundamental: put intelligence in the peripherals," says Jobs. The LaserWriter printer, for
instance, has more computational power than a Fat Mac. As a result, communication can be much less literal. The nodes can reduce messages to a skeletal code, send them, and reconstruct
them at the other end. For instance, if you wished to send a page
of typeset-quality graphics from an IBM PC to a printer via IBM's
PC Network, you'd have to transmit every bit, that is, over lOOOK.
But by using AppleTalk and a graphics language (called PostScript) in the LaserWriter, you can cut this total to about lOK.
Fewer bits per message means greater throughput and faster
speed.
AppleTalk is also nonexclusive. Apple itself is building the
means for it to communicate with the IBM PC, so the Macintosh
can enter the bailiwick of this widespread product. Moreover,
third parties are making it possible for almost any machine to
hook up to AppleTalk. Already, there are linkages to machines
that use the CP/M and Unix operating systems, and these, together with IBM's MS-DOS, cover the majority of personal business computers in the United States today.
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Setting It Up
Setting up the AppleTalk network is simple, but nonetheless demands a few precautions. Here are the basic steps:
Lay out the lengths of cable. You should first map out a
route for the cable; a floor plan may help you fix the location of
present and future nodes in your office. Once you know where it's
going, you can lay pieces of cable down, generally along the base
of the wall or elsewhere out of the way. The order in which you
string the nodes together makes no difference, but you must bear
certain rules in mind:
• Form the cable into a line, never a circle or a T. The line can
have as many bends or curlicues as you like, but it must have
two-and only two-identifiable ends.
• Do not leave a cable dangling at the end. The ends of the network must be actual machines.
• Limit the network to 1000 feet in length. If you need more cable,
the best thing to do is set up a second AppleTalk network. Two
networks can communicate between each other.
• For safety reasons, do not lay cables outdoors, through walls, or
in places where people might step on them. If you want thecable to pass through walls, you need either a metal conduit or the
Teflon-coated cable found in the AppleTalk Custom Wiring Kit.
Plug the cable into the connector modules. This links the
cable into a single line. Remember that you can have only 32
connector modules per network.
Turn off every machine you'll aHach to the cable. If the
machines are on, the network may inadvertently give two nodes
the same identification number, causing needless grief and
confusion.
Plug the droplines into the machines. If you have a Macintosh, the plug goes into the printer port. If you have a Macintosh XL or a Lisa (they're the same machine, just different
names), it goes into serial port B.
When adding new machines to the network, you basically adhere to this outline. If you're adding a computer to one end of the
network, first plug the new length of cable into the new connector
module, attach that new cable to the last connector module at the
end of the network, then switch off the machine and plug the
dropline into it.
If you're inserting a machine in the middle of the network,
the process is similar, but you must halt network operation mo322

Chapter 10

mentarily. After plugging the new cable into the new connector
module, you unplug existing cable from an existing connector.
Then you just slip the new cable-connector hookup in between.
Finally, you turn off the new machine and plug in the dropline.
If you want to remove a computer, say, to take a Macintosh
home for the night, just tum off the machine and unplug it from
the dropline. Since the connection between the cable and the
connector module remains intact, the network continues to function. (A dangling dropline is okay; a dangling cable is not.)

Configurations
You can arrange an AppleTalk network in numerous ways, and
this flexibility helps the system overcome the apparent limitation
of its size. The first three of the following configurations are intramural variations, means of arranging nodes within a single network. The last two are intermural, means of linking AppleTalk to
other networks and greatly expanding its range.
• The solo computer. The Macintosh has a small, fixed number of
ports in the back. If you want to use more peripherals than these
ports can accommodate, you can connect the computer to
AppleTalk and string your peripherals along the bus.
• Computers-only network. You can have nothing but computers
at the nodes, and use the network to shuttle documents back
and forth by electronic mail. This doesn't make best use of a network's capacities, but you may have special need for it.
• The classic arrangement. Most people attach numerous computers to a few costly peripherals, such as a printer or hard disk.
• AppleTalk-to-AppleTalk. If your company has more than 32
nodes, you can still use AppleTalk. Apple says its research shows
that "knowledge workers" spend 80 percent of their time interacting closely with 5 to 25 other people. In the remaining 20
percent, they're dealing with individuals beyond this sphere. So
it devised AppleTalk networks to communicate to each other,
with bridges that can fuse two or more networks into larger networks. AppleTalk uses three kinds of bridges: (1) The local bridge
connects networks within the same building; (2) the half-bridge
connects those that are remote, by means of modem, satellite
dish, or other method; and (3) the backbone bridge unites
AppleTalk networks via a high-speed system like Ethernet.
• Beyond AppleTalk. AppleTalk can also link up to mainframe
networks and other kinds of LANs, using gateways, which are
analogous to bridges.
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You'll see the intermural configurations at the end of this
chapter, but for now, let's turn to the principal bait Apple is waving before potential AppleTalk customers: the LaserWriter printer.

Printing
Printing is a key aspect of personal computers. Anyone who
works with words needs hardcopies, and often these copies serve
important esthetic functions. You don't want the business report
you labored on for months to look like it gushed forth from the
campus computer lab.
Yet most printers for personal computers have certain inherent flaws. Letter-quality printers, for instance, work like typewriters and yield solid, high-grade characters. But they're noisy
and slow and render graphics about as well as a monkey paints
with its toes. Dot-matrix printers are faster and do graphics well,
but they're also noisy and sometimes the dots are apparent in
their characters. Inkjet printers resemble dot-matrixes in quality,
except that they're very quiet. The champion, however, is the laser
printer. This device is exceedingly quick, silent, and versatile, and
its quality is outstanding. In fact, it has had no real defect at all,
except an astronomical cost.
But that cost is falling fast. For instance, the Hewlett-Packard
LaserJet now sells for $3,500, one of the lowest prices around. Apple's LaserWriter goes for $7,000, twice that amount. But the
LaserWriter offers so much more for the money that comparing
the two is rather like comparing the Macintosh with a game computer. They're both in the same category, but they dwell in separate worlds. Laser printers work very differently from other kinds
of printers. Letter-quality and dot-matrix machines, for instance,
actually strike the paper, hence their penetrating buzz-saw whine.
Inkjets squirt tiny bursts of ink onto the page. But laser printers
use the technology of office copiers. In fact, the heart of both the
HP LaserJet and Apple's LaserWriter is made by Canon, the
copier company.
This mechanism is called the print engine. It works by shooting a very fine laser be.am at a rotating drum which has a positive
electrical charge. Wherever the beam strikes, it neutralizes the
charge on the drum. The neutral spots attract the toner, a fine
inky powder which also has a positive charge and is therefore repelled by the rest of the drum. The drum continues to rotate and
soon touches paper with a negative charge. Positive and negative
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attract, and the toner moves from drum to paper. The paper then
slides through heated rollers, and the heat and pressure fuse the
toner to the page. A moment or so later, the printed paper
emerges from the machine, still a bit warm.

LaserWriter
The LaserWriter is fast. It can emit a page once every eight seconds. That's 300 characters per second (cps). By contrast, the
popular ImageWriter prints its coarse draft-quality letters at 120
cps, and its high-quality is slower still. Since the LaserWriter has
no element or pinheads hitting the paper, it's almost silent. And
laser technology permits exceptional quality. The resolution of
such a printer depends not on the size of the mechanical pinheads, as with a dot-matrix, but on the size of the laser beam itself. And that beam can be minute. The LaserWriter generates
images with a resolution of 300 dots per inch (dpi). In comparison, the ImageWriter prints out about 80 dpi. The contrast is st~n
tling. Indeed, LaserWriter output is so fine that you may confuse it
with typeset material from 2000-dpi printers, which cost tens of
thousands of dollars.
Figure 10-5. Apple's LaserWrlter

The LaserWriter. which retails for $6.995, offers Macintosh business users close-totypeset-quality graphics a nd documents.

The LaserWriter has still another advantage. Apple has minimized its maintenance problems. Its toner cartridge, which easily
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slips in and out, also contains the parts of the printer most likely
to wear out, so you don't have to tolerate slowly worsening quality or wait for the repair person every time some small problem
appears. The cartridge costs $99, and should be replaced every
2000 to 3000 pages, meaning that you pay from 3-1/3 to 5 cents
per page, depending on how much toner your work requires. Apple says that the machine will probably need service once every
40,000 pages, and major maintenance every 100,000.
This printer is an excellent example of the AppleTalk strategy
of maximizing intelligence at the nodes to minimize transmission
through the wires. The printer contains 1.5 megabytes of RAM1500K-three times that of the Fat Mac and 20 times that of the
HP LaserJet. The advantage of so much memory is that the LaserWriter can hold full-page images of graphics, a feature worth having since each LaserWriter page can have 6,800,000 dots. Since
laser printers print out a page at a time, this memory makes it
possible for the LaserWriter to crank out its graphics at impressive
speed.
The machine also has 500K of ROM. Its ROM contains an
assortment of type fonts and a special page-description programming language called PostScript. Developed by a company called
Adobe, PostScript is one of the treasures of the LaserWriter. The
type fonts are outlines of characters in four different styles: Times
Roman, Helvetica, Courier, and Symbol. (Fifty or more others will
soon become available.) The machine saves memory by not storing complete images of each font at every different size. Rather, it
uses PostScript to create fonts of any size you want. PostScript can
do this because it describes characters in proportional, not absolute, terms. For example, instead of treating a certain L as an object ten dots high with a four-dot projection to the right from the
base, PostScript describes it as a figure whose baseline is 40 percent as long as its stem. PostScript also adapts fonts to the highresolution LaserWriter environment. Thus, whereas the
ImageWriter renders curves of certain sizes with jagged edges, like
a staircase, PostScript rounds every letter off carefully, no matter
how large. Moreover, this software already makes it possible for
the Macintosh to work directly with true typeset-quality printers.
"PostScript is more important, in a way, than the LaserWriter,"
Jobs says.
Let's look at the process of using AppleTalk to operate the
LaserWriter. First, of course, you must link the printer to the network. Then you create pages on the Macintosh screen. Finally,
you send the pages to the LaserWriter and watch it take over.
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Hooking Up the LaserWriter
The LaserWriter is just one more node in the network and so is
fairly easy to set up. It does have a few special requirements that
you must address, but this effort will not tax your abilities.
First, like all nodes, the LaserWriter requires a dropline. You
buy a Kit for $50, and plug in the dropline exactly as you did with
the computers. In addition, however, you have to set the mode
switch on the back of the LaserWriter to AppleTalk. You also need
to purchase a toner cartridge, which isn't included with the
printer. Finally, when everything is attached, you tum the device
on. The LaserWriter needs two minutes to warm the rollers up every time you use it, so be careful not to send your document
while it's still cold. When ready, it emits a test print, a piece of
paper which tells you how many copies it has generated since first
use, as well as information about its port and switch settings.
The LaserWriter comes with a test disk, which has been preset to work on the printer. Try printing out the document on this
disk. If something goes awry, the problem is in the network. (The
printer has proven itself by generating the test print.) The test disk
also has version 4.5 of MacWrite, which you may wish to use for
future word processing.
The printer comes with a LaserWriter Installation Disk, which
enables you to put the necessary printer software and fonts on
your startup disks. You must place this software on every disk you
intend to print from.
If your network has more than one LaserWriter, you must
give each a different name so that you can specify the printer you
wish to send to. This operation is done with software, according
to instructions in the manual and again is magnificently simple.
Setting Type on the Screen
To print out, of course, you must first have a document. The
LaserWriter will work with any Macintosh software that has a
Macintosh print manager-that is, almost all of it. A few companies, such as PFS, have previously offered their own printer drivers, and PFS at least is making its programs compatible with the
LaserWriter. Of course, with a LaserWriter file in the Macintosh
System Folder, you'll have new fonts available onscreen. For instance, if you wish the document to appear in 12-point Helvetica,
you pull down the Font menu. Helvetica appears as a selection,
and you click it.
If you're producing newsletters or other documents that need
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a slick layout, you may want to consider a program called

PageMaker, sold for $495 by the Aldus Corporation, of Seattle,
Washington. (The company is named for Aldus Manutius, the sixteenth century Venetian printer-scholar credited with inventing
italics.) PageMaker is an electronic paste-up board, which enables
you to lay out pages for publication. Most Macintosh word
processors have a rudimentary layout capacity, allowing you, for
instance, to center passages. PageMaker greatly expands these features. It lets you easily place and crop graphics on the layout, set
column widths, and otherwise adorn the page. Then you fill the
empty spaces with text, correct it, move parts over to the next
page, and generally manipulate it at your convenience. PageMaker
was written with graphic artists in mind, and they seem to appreciate it. It requires a 512K Macintosh or a Macintosh XL, an external disk drive (or the built-in hard disk on the XL), and either
an ImageWriter or the LaserWriter.

Transmitting to the LaserWrlter
When ready to print, you select Print from the File menu, just as if
you had a desktop printer. A dialog box appears, and you choose
the options you want. Then you click OK. The print manager begins translating your file into the PostScript commands of the
LaserWriter. The Macintosh sends PostScript commands to the
printer one page at a time.
In a network, when two or more people want to use the
LaserWriter at once, backups can occur. You may have to wait until someone else has finished before you can use the printer. A
type of software called a print spooler solves this problem, letting
the printer store the incoming document temporarily while it
works on something else. When the printer is free, it starts on
your document. The only current print spooler for the LaserWriter
requires an Ethernet connection, but AppleTalk print spoolers
should be available by late 1985.
When the document reaches the LaserWriter, the machine
transforms PostScript commands into a dot pattern, which replicates in memory a map of the page. Following this map, the
printer directs its laser beam at the drum, and soon you have a
printed copy of what was on your Macintosh screen just a moment ago.
Printing is a vital office function, and a network can enhance
it for everyone. But an even more basic task is storage, for a computer can act only on what it has in memory. Here, too, a network
can be extremely valuable.
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Memory
Memory has always been a limitation of the Macintosh. Unfortunately, mass-storage devices like hard disks remain expensive,
currently starting at $1,000 to $2,000. Moreover, if every desktop
had a hard disk, your company would again face cost and use inefficiencies. With 20 offices, mass storage would cost between
$20,000 and $40,000. Duplication would be inevitable as several
people stored the same files. In addition, a good part of this expense would simply be wasted, since the larger the hard disk, the
better the bargain. One hard disk with 100 megabytes is much
cheaper than 20 with only 5 megabytes apiece. Thus, if a single
mass-storage device could serve the whole network as the
LaserWriter does, you would again save money and increase overall performance.
Hard disks can indeed function for a network, but often
they're enhanced and called file servers. A file server is a hard
disk with special features for multiple users. The main difference
between the two devices involves the number of people who can
simultaneously access a file. A file server lets several people use
the same file at once, while a hard disk limits access to one at a
time. A file server can also be adapted to network use in other
ways. It may let you have a greater number of different files or
files of larger size than a hard disk. And a good file server may go
straight to the page of the document you want rather than stopping for directions at every fork in the path. Think of a file server
as a file clerk, bringing you the information you request, while a
hard disk is simply the inert file of data, which you must pick
through yourself.
Apple has announced an AppleTalk file server for late 1985,
but a number of third-party memory products are already available. Before we discuss them, however, some caveats are in order.
This listing is far from complete, even as it's written, and new
products are springing upon the marketplace every week. Moreover, prices are always shifting, and those given here may have
changed by the time you start shopping. Most important, our
descriptions of these items are neither reviews nor recommendations. We mention them mainly to give you an idea of the state of
the market, and you should approach your purchase with your
normal discretion, as you would anything on display in a window.
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The Keeper
The Keeper, made by Micro-Design of Austin, Texas, is a massstorage device that works either with one Macintosh as a hard
disk or with an AppleTalk network as a file server. It comes in six
different versions, three with fixed drives, three with removable
ones. The fixed-drive file servers have 10, 20, or 30 megabytes
and currently sell for $2,195, $2,695, and $3,295, respectively. Of
the remaining three, one comes with a single 5-megabyte removable drive ($2,295), the second with two 5-megabyte removable drives ($3,595), and the third with one 5-megabyte
removable and one 5-megabyte fixed drives ($3,595). Extra 5megabyte cartridges cost $17 apiece. The advantage of fixed
drives, of course, is that all information is instantly available. The
disadvantage is that once you fill the memory up, you need another file server. Removable drives, on the other hand, may not
always be there when you want them, but they allow the file
server vast capacity and permit you to physically transport data.
The Keeper has other qualities. It has a built-in computer,
with 512K of RAM, so it can run more efficiently on AppleTalk.
You can also attach more than one of them to the network, in
which case you must give each a name. The disk manager program then keeps track of them for you. The device also allows for
security. You can establish passwords to gain access to certain volumes of files. For added security, of course, you can always place
confidential data on a removable disk.

Bernoullll Box
Another file server is the Bernoulli Box, made by Iomega, of Roy,
Utah. The Bernoulli Box uses five-megabyte removable cartridges
and retails for $1,895. This machine is partitioned into units of
one megabyte, which can be password-protected. The user selects
from among the different compartments. Only one person can access any one-megabyte division at a time, but he or she can have
several units on the Macintosh concurrently.

OmniDrlve
Corvus, of San Jose, California, makes a "shared hard disk" called
OmniDrive. OmniDrive is a fixed drive available in five sizes: 5megabyte ($1,495), 11-megabyte ($1,995), 21-megabyte ($2,995),
45-megabyte ($5,195), and 126-megabyte ($9,495). While the
Keeper and the Bernoulli Box include software as part of the pur330
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chase price, Corvus sells its OmniTalk program separately for
$395. OmniDrive prices illustrate the savings from buying large.
With software, a 126-megabyte OmniDrive costs about $9,900. If
it were in a company with 20 computers, each computer could
have around 6 megabytes for $495 apiece. In contrast, a single 5megabyte OmniDrive with software costs about $1,900.
The OmniTalk program makes a personal hard disk over into
a shared network system. It divides disk space into three categories: private, public, and controlled. Private volumes "belong"
to individuals, who can thus read and write to specific parts of the
drive. Corvus anticipates that most disk space will be taken up by
private volumes, which will hold reports and memos of interest
mainly to the volume owner. Public volumes can be read by all
users, rather like bulletin boards or those all-personnel memos
that always add a laugh to the day. These volumes would include
application programs and common information needed by many
people in the network, like certain databases. Normally, only a
few people possess the power to write to public volumes. Controlled volumes can be read by anyone and written to by anyone,
but only one person can write to them at a time. They provide a
means of sending electronic mail.

XL/Serve
If you have a Macintosh XL and would rather have the network
use its ten-megabyte hard disk than buy extra hardware, the
XLjServe program, from Infosphere, of Portland, Oregon, will let
it do so. For $195, XLjServe enhances the MacWorks XL software
to divide the hard disk into as many as 16 subvolumes. XLjServe
offers password protection, and volumes that can be either
"shared" (read-only) or "private" (read-write). It permits multiple
XLs in the network to increase network memory. XLjServe also
lets other computers use the XL's printer, and it provides for print
spooling, so users need not wait in line for printout. However,
though the software is compatible with the LaserWriter, it cannot
spool print for it.
Though Apple has discontinued the Macintosh XL, Infosphere
remains optimistic about XLjServe. Company spokesman David
Baasch says it will actively pursue the 40,000 to 50,000 existing
XL owners for whom the product will remain useful. But the software is not tied to the XL, he says, and Infosphere is already
adapting it for other hard disks. When it appears for them, of
course, it will probably have a different name.
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Communication
Communication, both intra- and inter-network, is a prime goal of
linking computers together. It's also a function that even the most
elementary network can carry out. Yet we've saved it till last for
several reasons. One is that some communication devices enable
you to reach out beyond AppleTalk itself, to connect with the
world; the topic thus has the greatest periphery of all. Another is
that many of the items below come in families, with special products for printing, storing, and other capacities which you've already seen. Hence, this is both a capstone and a catchall category,
united by the thread of communications, but otherwise farflung
and diverse.
One relatively simple program is Mail Center, offered by
Videx, of Corvallis, Oregon. Mail Center lets you send text and
graphics among AppleTalk computers. When you want to transmit a document, you open a window which displays all computers in the network able to receive. You select those you wish to
receive the message and then dispatch it. The program keeps a
record of successful receipts in a Send Log. This feature resembles
certified mail and, like it, protects you from accusations at the
other end that the document never came through.
Mail Center computers can receive messages even if they're
currently engaged, say, in word processing. You know that mail is
arriving when your disk drive starts to run and the solid apple
atop the menu bar changes to a blinking postal letter icon. To
read your correspondence, you click that letter icon and then the
icon of the new file. Mail Center comes in two different packets:
one for two Macintoshes ($299) and another for six ($499). Thus,
if you wanted to link up 18 computers, it would cost about
$1,500.
Ultra-Talk, from Lutzky-Baird Associates, of Culver City,
California, links AppleTalks to a computer based on AT&T's Unix
operating system. The software is sold in two parts. That for the
Unix machine costs $2,000, and that for each Macintosh in the
network is $300. Ultra-Talk is an all-purpose program, and one of
its major features involves using the Unix computer as a central
file library for data storage. (Unix machines are well-suited for
storage because their powerful file structure makes retrieval fast
and simple.) Files in this library may be designated originals or
copies. Whoever holds the original can read and write to it. Anyone who accesses a copy can alter only that copy, not the original.
Ultra-Talk also supports high-speed printers like the LaserWriter
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and allows electronic mail to one or many recipients in the system. Moreover, it oversees communication with other networks
and even with remote computers containing giant databases. The
software, finally, provides a backup capacity to insure against data
loss as well as security measures to keep out browsers.
Tri-Data of Mountain View, California, markets an AppleTalk
gateway it calls Netway 1000A. The Netway 1000A lets the Macintosh communicate with either an IBM 3270 BSC or an IBM 3270
SNA/SDLC minicomputer. It does so by getting the IBM host to
look upon the Netway 1000A as an IBM minicomputer controller.
Yet the Macintosh retains its distinctive pull-down menus, mouse
control, and cut-and-paste abilities. The device comes with 128K
RAM and one AppleTalk connection. Since it constitutes a node in
the network, it can support 31 Macintoshes. It's about 3 X 10 X
8 inches and weighs about 14 pounds. An AppleTalk network can
have several Netway 1000As. The hardware and software together cost $2,525.
Centram Systems West, of Berkeley, California, sells the
Transcendental Networking System-also called Tops-which
performs a panoply of tasks. It is actually available as an LAN itself, complete with hardware, but its software will work with an
existing AppleTalk network. Hookups are about $100 per Macintosh, and $300 per IBM PC.
Tops has interesting communications and memory capabilities. First, it does file conversion, translating files created on one
operating system into files for another. For instance, you can view
the directory of a remote hard disk of an IBM PC. Though its files
are oriented to the alien MS-DOS operating system, they appear
onscreen as Macintosh icons. If the application program at both
computers is the same-say, Multiplan-you can then access the
file you want by clicking. The Tops network converts it into its
own ~~standardized environment," carries it to the Macintosh, and
converts it again to run on the Macintosh operating system. You
can then manipulate it exactly as if it were originally written for a
Macintosh. The user of the remote computer does not realize that
a file has been accessed, and the transaction occurs as fast as if
the file were stored on your disk drive. Tops is compatible with
MS-DOS, Macintosh DOS, Lisa DOS, CP JM 80, and Unix, and
Centram says it can add other operating systems at the request of
manufacturers. Tops also supports the LaserWriter.
The second intriguing aspect of this product involves memory. Tops allows any computer in the network to read files on the
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disk drives of any other computer. It treats floppy disks the same
as hard disks so that, in effect, it converts the total disk memory
of the network into a pool which everyone can use-though you
can also protect specific files from undesired inspection. "You
shouldn't have to buy an expensive server to use the network,"
says Centram president Nat Goldhaber. Goldhaber concedes that
this approach is not particularly useful with floppy disks alone,
but says that some people do find it practical. If the network has
several Macintosh XLs, it can exploit their hard disk capacity and
become more generally useful. Centram plans to make Tops
compatible with any hard disk for the Macintosh.
Perhaps the best-known existing network is Ethernet, marketed by 3Com, of Mountain View, California. Ethernet was invented by 3Com president Robert Metcalfe in 1973, while he was
at Xerox. Since then, Metcalfe has worked with Xerox, Intel, and
DEC to popularize the network, and he estimates that there are
between 10,000 and 20,000 of them installed. Under the rubric
Ether Mac, 3Com makes a· variety of products which enable
AppleTalk users to tap into its network.
First, there is its 3Server, a $7,995 file server which offers 36
megabytes in fixed format, 512K RAM, an optional 60-megabyte
tape backup unit, and storage expandability to 252 megabytes.
The 3Server needs a port expansion board ($625) for the
AppleTalk dropline, and can handle up to 50 computers on
AppleTalk and Ethernet simultaneously. Thus, the file server can
deal with up to 31 Macintoshes on AppleTalk and 19 others on
Ethernet, all at once.
The 3Server also requires the software EtherShare ($695),
which supports Macintoshes connected via AppleTalk as well as
IBM PCs and compatibles connected via Ethernet. This software
allows file conversion between IBM PCs and Macintoshes, so the
two computers can swap information. It supports up to 200 volumes per 3Server, and these volumes can range in size from 64K
to 32 megabytes. Volumes can have password protection, and
they come in three different categories: private, public, and
shared. EtherShare also allows you to use Ethernet as a backbone
bridge to connect separate AppleTalks.
Also, 3Com offers the optional program EtherPrint, which
performs print spooling with the LaserWriter. To use it, you must
first connect the printer to the 3Server by a serial cable. When
you're ready to print, you issue the command on the Macintosh.
The computer sends the document to the 3Server, which stores it
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until the LaserWriter can get to it. During this time, the Macintosh
is available for other tasks, so you don't have to sit drumming
your fingers on your desk till printout. EtherPrint also enables
IBM PCs to use the LaserWriter for ASCII text documents.
Finally, you might look for a communications product from
Sytek, of Mountain View, California. Sytek has chosen to remain
mum about rumors of this forthcoming item, but we mention it
anyway because this company developed the hardware for IBM's
PC Network. If it is, as most suspect, a gateway between the PC
Network and AppleTalk, the product could be significant.
AppleTalk itself is already significant. It offers a way to cut
the cost and improve the quality of office automation at the same
time. It also offers capacities like electronic mail and file conversion which are hard to arrange without it. It isn't the most powerful network available, but it's one of the cleverest and least
expensive, and its presence suggests that the Day of the Office
Network may be arriving at last.
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Macintosh Utilities
Sharon Zardetto Aker

Even if you've mastered the workings
of the Macintosh and the programs
demon strated in this book, there are still
things you can do to increase your
computer's productivity. N umerous programs-utilities-can help you do such
things as increase the speed and efficiency of other applications, make
more room on your disks, and secure
your files from unauthorized access. Some of these special utilities
are described here, along with suggestions on how to make the
best use of them. Although the first two are strictly for 512K
Macs, the others can be used on 128K machines. You'll find a
complete listing of the products and their manufacturers at the
chapter's end.

Switcher
The Switcher utility, in effect, lets you create your own integrated
packages from the applications you use the most. With Switcher,
you can keep up to four applications open at the same time and
switch instantly from one to another without going back to the
desktop. Switcher divides the 512K Fat Mac's memory into as
many as four portions. Each segment acts as a 128K Macintosh,
running any installed application. A click in the Switcher arrow at
the top of the screen, or a press of Command-[ or Command-],
slides the current program off the screen and another one onto it.
Switcher has a number of options, including one that lets you
h ave a separate Clipboard for each insta lled application, or a common Clipboard for easy and instant transfer of information between programs. If you have a hard disk system, it will be easy to
put four applications into Switcher at once. It's more difficult to do
so when you work with two microfloppy drives, because the System Folder (consisting of the System file, Finder, and ImageWriter
icons a t the least), each application, and your documents must all
be on inserted disks if you want to avoid disk swapping while
you're working. It's easy to run two applications on a dual-drive
system, and reasonable to squeeze in three, but very difficult to
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have four available and still leave room for a sizable document.
Of course, two or three applications running at one time is sufficient for most purposes. Another great feature of Switch er is that
it lets you load the same application into more than one segment
of the partitioned memory. This means you can, for example,
have up to four Multiplans running concurrently; and with four
spreadsheets open at the same time, cutting or copying between
them or linking cells is a breeze.
Figure 11-1. Switcher Slides Word and Multiplan
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Mac-Memory Disk
A RAM disk is an area of the computer's memory that's treated just like a
-1 OO%
disk: a disk icon appears on the
desktop, you can copy applications
and/or documents to it, and do anything else that you normally can with a
microfloppy disk. The advantage of a
RAM disk is that the transfer of data
between it and the application you're
running is instantaneous. The
Mac•Memory Disk from Assimilation is a
RAM disk utility that lets you set aside
up to 316K for the RAM disk. By sliding a bar up a memory scale, you indicate how large the RAM disk should be.
You can create a RAM disk anytime you want to work with
one, or specify that one be created automatically whenever you
use the current physical disk as the startup disk. You can also
have files automatically copied to the RAM disk when it's created.
If you define the RAM disk to be the startup disk, it will need the
System and Finder copied to it, as well as the application you
want to run. With the basic System at lSOK, the Finder at 45K,
and Word at 125K, you'll have a hard time squeezing some
configurations onto a 316K RAM disk. (You'll also need the 25K
ImageWriter file if you're going to do any printing.) You will have
to alter the System file, as described later in this chapter, so that it
takes less room. Once you have an application on the RAM disk,
there are no disk-access delays when you're using it. Dialog boxes
appear instantly on the screen, Cut and Paste operations are done
in the blink of an eye, and the usual delay between giving a Print
command and the actual printing is cut down to seconds when
the file to print is saved to the RAM disk instead of a physical
disk. You shouldn't keep your document on the RAM disk (you
probably won't have room, anyway); like all RAM, if there's a
power interruption, all information is lost. .
Using a RAM disk with two drives actually gives you the
benefit of a third drive. When your application is on the RAM
disk, you can open a document on a disk in one drive and save it
onto a different disk in the second drive. Normally, moving a file
from one document disk to another involves a lot of disk swapping. A RAM disk also makes System file changes a breeze. When
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you use the Font and Desk Accessory Mover on a regular disk, as
described a bit later, a lot of time is taken up in the creation of
new files and the updating of the System file. You can, however,
put the System file on the RAM disk, update it in seconds, then
drag it back to the physical disk.

Font/DA Mover
Apple's original System Disk included a utility called
~
the Font Mover; the most recent System Disk release
includes a new utility called the Font fDA (Desk
Font/DA Mover Accessory) Mover, which is described here. If you
don't have the new Mover, ask your Apple dealer for a copy.
Before we explore how you can alter your System file, some
general information about desktop files is in order:
The System Folder. If you look inside the
System Folder on your desktop, you'll find six
.
icons: System file, Finder, ImageWriter, ClipNote Pad Flle board file, Scrapbook file, and Note Pad file. The
two desk accessory files contain the information
you have put in the Scrapbook and Note Pad.

rn
8

Scrapbook file

The amount of space these files take up varies
with how much information you've stored. The standard Scrapbook comes with about 9K of data in it,
lmagewriter while the Note Pad can hold a maximum of 2K.
You can put any of these icons in the Trashcan
and erase them from the disk. The next time you select the related
desk accessory from the Apple menu, you'll find it empty; a new
file is created as soon as you make the selection.
The Clipboard icon is always empty when you start; its contents-the things you Cut or Copy-disappear when you tum off
the computer.
The ImageWriter file lets your Macintosh and the application
you're using communicate with the printer. An update of the
ImageWriter file adds a new option, 50 percent reduction, to the
Page Setup dialog box.
The Finder is the program that gives you your
desktop: the pull-down menus, the commands available in
the menus, the option of erasing disks or removing files
from them, and so on. The most recent version of the
Finder Finder, at this writing, is 4.1; it takes about 41K of space
on the disk. (To find out what version you have, select About the

~

e

rn
16'
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Finder from the Apple menu.) Soon the Finder will be built into
the Macintosh's hardware and you won't have to give up any disk
space for it.
The System file defines the Macintosh environment. It contains, among other things, information
~
about what fonts are available when you use a font
Syst m F;le menu in any application, and what desk accessories
e
are available under the Apple menu. The System file
generally takes about 150K of space. However, since you can strip
it of many fonts and accessories, or add new ones to the System,
the size can vary greatly.
Moving fonts. To get an idea of why you might want to remove some fonts from the System, all you need to do is look at
how much room each font takes (1024 bytes make 1K, or
kilobyte).

In

Font
Chicago•
Geneva•
Geneva
Geneva•
Geneva
Geneva
Geneva
Geneva
Monaco•
Monaco

Size
12
9
10
12
14
18
20
24
9

12

Bytes
2940
2152
2200
2734
3568
4864
5848
7568
2026
2464

Font
New
New
New
New
New
New
New
New

York
York
York
York
York
York
York
York

Size
9
10
12
14
18
20
24
36

Bytes
032
2200
2734
3352
4516
5260
6832
13,780

• System Fonts

If you don't need the New York font for
your writing with Word, you can free up 40,706
SMALL CAPS
bytes (about 40K) by removing it. The fonts
ARE MADE
marked
with asterisks should always be kept in
FROM TWO
the
System;
these System Fonts are used by the
DIFFERENT
Macintosh
for
menus, dialog boxes, and on the
FONT SIZES
desktop. When you decide which font you want
to keep for your own use, make sure you keep
both the size you intend to use and the one twice that size. When
you print in high-quality Geneva-12, for instance, the Macintosh
looks to Geneva-24 for its "map." And, if you use Word's Small
Caps option, remember that it needs the uppercase letters from
two different font sizes. Small Caps-12 uses 14-point letters
whenever you use the Shift key.
Before you remove a font from the System file, you should
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make a copy of it; you can then save it in a separate file and load
it back into the System if you need it. Other fonts can be installed
into the system, too; in addition to Apple's Cairo and Los Angeles
fonts included on its System Disk, there are many companies that
make disks full of font files for you to use. Some are foreign language fonts, some include special symbols for such areas as
electrical engineering, and some are decorative fonts for
announcements and letterheads. To use the Font fDA Mover, open
it by double-clicking on the icon. The Mover's screen has two buttons so you can choose between working with fonts or with desk
accessories; click on the Font button.
Figure 11-2. Font/DA Mover Screen
®Font

Mouer

0 Desk Accessory

:'!1

Chic ago I 2

Geneua
Geneua
Geneua
Geneua
Geneua
Geneua

9
10
12
14
18
24

(

Chicago 12:

Remoue

)

2940 bytes
selected

System
on MasterDisk
Open ...

»Copy» )

l ,. (-H-e~lp- I
......)

l(

Quit

)

I

Storage
on FontDisk
(

Open ...

The quick brown foH jumped ouer the lazy d

Below the left window is the title System on (diskname), and
the window shows the fonts installed in the current system. To
copy any unwanted fonts into a new file, you have to create that
new file. Click on the Open button beneath the right window,
type the file name Fonts in the dialog box that appears, and click
in the Create button. The title Fonts on (diskname) appears below
the right window.
Click on an unwanted font in the left window; a sample of
the font appears at the bottom of the screen, and the number of
bytes that font uses is noted in the center. Drag or Shift-dick to
select all the unwanted fonts and sizes in the System file; the to.tal
number of bytes for all fonts is shown on the screen. Click in the
Copy button; the arrows will be pointing toward the right win344
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dow, the one you're copying to. After the fonts are copied to the
new file, you can click in the Remove button under the right window, and the selected fonts will be erased from the System. When
you quit the Mover, you'll find a new icon on the desktop, the file
with the copied fonts, labeled Fonts.
AscoE
This icon can be dragged to another disk to give more
room on the original disk. You may want to store each
font, with all its sizes, in its own appropriately named file
Fonts to make it easy to find. Use a similar procedure to install a
font into the System. Installed fonts still appear in the left window. Instead of creating a new file for the right window, open the
one that has the fonts you want. The file you open may be a font
file you created earlier, one from a commercial font disk, or even
a System file from another disk. Select the desired fonts in the
right window, and click the Copy button to copy them into the
current System.
Moving desk accessories. The desk accessories under the
Apple menu can also be removed in order to make more room on
the disk. As charming as the Puzzle is, you might rather have the
extra lK available for something else.
The standard accessories use a total of
approximately 28K space on the disk:
Alarm Clock
Bytes
Accessory
4008
Alarm Clock
Calculator
2444
Calculator
Control Panel
Control Panel 7951
Key Caps
1645
Key Caps
Note Pad
2512
Note Pad
932
Puzzle
Puzzle
Scrapbook
3109
Scrapbook

iii

In addition to the room for the accessory itself, some
accessories need extra space for the data files which store
the information you've created-like the Scrapbook and
Puzzle Note Pad files mentioned earlier. The procedure for copying, removing, and installing desk accessories is similar to
that for moving fonts. You'll find a special desk accessory icon on
the desktop when you create an accessory file.
Many desk accessories besides the standard ones are available. Some are in the public domain, which means they're free. If
you belong to a user group or use one of the large information
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services like CompuServe, it's easy to get the public domain
accessories. Another category of accessories is shareware; these
programs can also be obtained through user groups and CompuServe. A shareware program is nominally priced, and you send
money to the author only if you like the program enough to use
it. Finally, there are accessories available commercially. Many of
these are variations on the Note Pad and Calculator; there are numerous calendars and phonejaddress books. Some are full-blown
desk management systems; others are handy utilities that make
computing life easier. An especially convenient accessory called
Disklnfo is available as shareware. Once it's installed in your system, you can check what is on any disk without leaving the
application.
Figure 11-3. Dlsklnfo
Nomt
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Diskinfo lets you delete a file without going back to the
desktop; this feature is missing from almost all Macintosh applications and is hard to live without once you've used it a few times.
Two of the most versatile commercial desk accessories are described below.

Mac• Tracks
The single most useful utility program for any Macintosh application is Mac•Tracks. It installs as a desk accessory, so it's always
available from the Apple menu. With Mac•Tracks, you can define
your own Command-key sequences. You may have noticed that
the earlier Microsoft Macintosh programs have fewer Commandkey options than the later ones. Multiplan, for instance, does not
use Command-O for Open. You can remedy the situation by
installing Mac•Tracks on the Multiplan disk. When you select
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Mac-Tracks from your Apple menu, you're asked whether you
want to see the Library (a list of the sequences already defined) or
add a new command. To add a command, you press the Command key (X) and the letter or number that will stand for the
command; Mac-Tracks then begins "recording" your actions.
Both keyboard and mouse are recorded.
Figure 11·4. Mac•Tracks

@

1985 Assimilation Inc.

Quit

Record a key

To add an Open option to Multiplan, for instance, you would
press Command-O, then pull down the File menu and select
Open. Mac-Tracks gives you the option of having an action recorded, but not actually performed; you can also tum off the
recording process or begin it over again. A Mac•Tracks key option
overrides one already in a program; you can, for example, define
Command-N as New in Multiplan, overriding the original Name
command that comes with the application. In addition to using
the Command and the "storage" key, you can add either the Shift
or Option key, or both. As a result, most letters and numbers on
the keyboard can store four commands: Command-key, CommandOption-key, Command-Shift-key, and Command-Shift-Optionkey. (Some exceptions: Command-Shift-1 ejects the internal disk,
and Command-Shift-2 the external one; these cannot be overridden by Mac•Tracks.) So, if you use Command-N for New in
Multiplan, you could define Command-Shift-N for the Name
function.
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You can also record more than one action on a key. CommandQ is the Quit option for most applications. You might define
Command-Shift-Q as a Save and Quit instead of always using two
menu or keyboard commands for that sequence. There's no practical limit to the number of sequences you can put in Mac-Tracks.
A convenient series for any application is one that chooses Print
from the File menu, selects a quality print, and clicks the OK button: try Command-1 for high-quality printing, Command-2 for
standard, and Command-3 for draft. In Multiplan, you can also
add Command-Option-1 for high-quality printing of only theselected portion of the spreadsheet, and so on. The following table
gives some possibilities for a Mac-Tracks configuration of
Multiplan; the illustration shows how the Library looks after all
the keys are defined.
Possible Mac• Tra9ks Multiplan Table
Command
File menu
New
Open
Close
Save
Save As
Print

Keys

38-N
38-0
38-W
38 -S
38-A
38 -P

Comments
Replaces N for Name
W is used for Close in Word
Replaces S for Show Active Cell
Replaces A for All Cells
Replaces P for Page Break

Edit menu
Paste and Link
Unlink
Sort

38-U
38 -Shift-S

Select menu
All Cells
Last Cell
Name
Link
Show Active Cell
Define Name
Delete Name

88 -Option-A
All Select menu items use Option
3€ -Option-E
E for End
38 -Option-N
3€ -Option-L
3€ -Option-S
88 -Option-Shift-N
3€ -Option-D
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Replaces U for Remove Cell Protection
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Format menu
General
Dollar
Percent
No Decimal
Decimal
Scientific
Bar Graph
Align Left
Align Center
Align Right
Commas
Column Width

88-G

X-4
88-5
88-/
88-.
88-E
88 -Shift-S
88 -Shift-L
38-Shift-C
88-Shift-R

Replaces G for Center Alignment
The 4 key has the $ sign on it
The 5 key has the % sign on it

E is used in scientific notation
B without Shift already in use
Easier to remember than program's F
Easier to remember than program's G
Easier to remember than program's H

X-,
88-Shift-W

W without Shift already in use

Option menu
Freeze Titles
Unfreeze Titles
Set Page Break
Remove Page Break
Show Formulas
Show Values
Protect Document
Unprotect Document
Remove Cell Protection
Restore Cell Protection

X -Option-Z
X -Option-Shift-Z
X-Option-K
X -Option-Shift-K
38 -Option-F
88 -Option-V
X -Option-P
X -Option-Shift-P
X -Option-Shift-C
X -Option-C

All Option menu items use Option

Calculate menu
Automatic Calculation
Manual Calculation
Iterate
Don't Iterate

88 -Option-Shift-A
X -Option-Shift-M
X -1
X -Shift-I

Miscellaneous
Save and Quit
88 -Shift-Q
X -1
Print High Quality
Print Standard Quality 88-2
X -3
Print Draft Quality
Print Selection-High
88-1
Print Selection-Standard 38-2
Print Selection-Draft
88-3
88-0ption-Shift-U
Scroll screen up
88 -Option-Shift-D
Scroll screen down
38 -Option-Shift-R
Scroll screen right
88-0ption-Shift-L
Scroll screen left

Program's P used elsewhere

Program's U used elsewhere

Using default settings

Click in Selection Only button

Record click in scroll bar
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When you define a lot of functions in a single application, use
a system that will help you remember which key does what. In
this Multiplan configuration, for instance, when a function is
represented by a certain key sequence, its opposite uses the same
key sequence with the Shift key added-Freeze and Unfreeze Titles, Set and Remove Page Break, Protect and Unprotect Documents;
all the items in the Option and Select menus use the Option key in
the command sequence.
Figure 11·5. Mac•Tracks Library
Mnc•Trncks'" Llbrnr

- --

Rennme

-----------

Quit

OKe
Option Xn
ShftOptXn
Shift X b
Shift X c
Xw
Shift X w
X,

Rutomntlc Cnlculatlon
Bnr Grnph
Center Rlign
Close
Column Width
Commns
Declmnl
ShftOptX n Define Nnme
Option Xd Delete Nnme
X4
Dollnr
0 tion X z Freeze

x.

Mac•Tracks would be a wonderful utility even if it stopped
there, but there's more. You can record keyboard sequences,
which means you can print things like your name and address
with two keystrokes-it's like having Word's Glossary feature in
every application. You can even store paragraphs of text on a single key, so you can print form letters with standard clauses with
only a few keystrokes. When you get Mac•Tracks (and you
should!), defining all your key options is easier if the first recording you make is the one that selects Mac-Tracks from the Apple
menu and clicks the Add a key button.

Art Grabber
If you incorporate MacPaint graphics into any of your documents-whether as letterheads, illustrations, or enhanced Chart
graphics-Art Grabber is a desk accessory you'll greatly appreciate. The Art Grabber utility lets you open a MacPaint file from
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within any application. So, if you're working in Word and want to
get the illustration you need for your report, you can open the
MacPaint document without leaving Word, trace the section you
want copied to the Clipboard, close the Art Grabber window, and
paste the graphic into the Word document. This is much easier
than trying to keep an active Clipboard from MacPaint to Word, or
preparing a Scrapbook in MacPaint and transferring it to the Word
disk.
Figure 11-6. Art Grabber

Another advantage to using Art Grabber is that its window
opens to the size of the Macintosh screen, so you can get a larger
figure copied onto the Clipboard than if you're working in
MacPaint's window. (This feature is usable only on the 512K Macintosh; memory constraints on the 128K Macintosh keep the traceable area to about 2 X 4 inches.)

Lockeft
A utility called Lock•lt will prevent anyone without the correct
password from opening any document you've secured. Lock•lt lets
you assign a Master Password to the documents on a disk; this
Master Password lets you add, edit, and delete the passwords for
individual documents, which are assigned through the Lock•lt
program.
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When you try to open a document that has been
protected, a dialog box asks for the correct password;
only if it's supplied will the document open properly. In
Lock-It
addition to locking documents, Lock•lt encrypts their
contents; if anyone opens a locked document with another utility program, the document will still be unreadable.

Product Information
Switcher
Fontj DA Mover
Apple Computer, Inc.
20525 Mariani Avenue
Cupertino, CA 95014

Disklnfo
Maitreya Design
P.O. Box 1480
Goleta, CA 93116

Mac-Tracks
Mac-Memory Disk
Lock•It
Assimilation
Los Gatos, CA 95030

Art Grabber
Hayden Software
600 Suffolk Street
Lowell, MA 01854
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that knowledge to you. MacOffice: Using the Macintosh for
Everything reveals the power of the Macintosh and five
application packages-Microsoft's Word, File. Chart, and
Multiplan, and Apple's MacTerminal-as it shows you how to
transform your office into an efficient MacOffice.
There are practical applications you can use immediately. Techniques are demonstrated step by step. Hints, tips,
and tricks abound. Scores of illustrations show what you'll see
on the screen at almost every turn . From disk management
to data files, from client lists to customizing your working
environment, MacOffice includes everything you need to
create a complete computerized office.
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• Discussions of the Macintosh user interface. its desktop, and
desk accessories
• How to use Word to create form letters, even how to merge
information from File
• Complete instructions for setting up client and customer lists
with File
.
• Multiplan accounts receivable, accounts payable, and balance sheet templates
• Examples of generating charts and graphs using Chartand how to customize them with MacPaint
• Details on telecommunicating with MacTerminal, which
show you how to send and receive information across 'town
or across the country
• How to integrate all five applications. turning your Macintosh into a complete office system
• What to look for in networks, hard disks. and laser printers.
and how to connect them all
• And evaluations of valuable Macintosh utilities which make
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