Limited Warranty on Media and Manuals

If you discover physical defects in the media on which this software is distributed, or in the manuals distributed with the software, Apple will replace the media or manuals at no charge to you, provided you return the item to be replaced with proof of purchase to Apple or an authorized Apple dealer during the 90-day period after you purchased the software. In some countries the replacement period may be different, check with your authorized Apple dealer.

In all implied warranties, including implied warranties of merchantability and fitness for a particular purpose, are limited in duration to ninety (90) days from the date of the original retail purchase of this product.

Even though Apple has tested the software and reviewed the documentation, Apple makes no warranty or representation, either expressed or implied, with respect to this software, its quality, performance, merchantability, or fitness for a particular purpose. As a result, this software is sold “as is,” and you, the purchaser, are assuming the entire risk as to its quality and performance.

In no event will Apple be liable for direct, indirect, special, incidental, or consequential damages resulting from any defect in the software or its documentation, even if notified of the possibility of such damages. In particular, Apple shall have no liability for any programs or data stored in or used with Apple products, including the costs of recovering such programs or data.

The warranty and remedies set forth above are exclusive and in lieu of all others, oral or written, express or implied. No Apple dealer, agent, or employee is authorized to make any modification, extension, or addition to this warranty.

Some states do not allow the exclusion or limitation of implied warranties or liability for incidental or consequential damages, so the above limitation or exclusion may not apply to you. This warranty gives you specific legal rights, and you may also have other rights which vary from state to state.
MacDraw is a powerful tool for creating structured graphics: flow charts, architectural drawings, forms, presentation graphics, and much more. With MacDraw, it's easy to create precise, complex drawings and even easier to change and modify what you create.

This manual is your guide to learning and using MacDraw. It assumes that you've used another Macintosh™ application and already know how to use the mouse, choose from menus, and work with documents. See Macintosh, your owner's guide, if you need more information.

How to Get Started With MacDraw
You can learn MacDraw in several ways:

☐ Use the MacDraw Guided Tour disk and cassette and then read this manual. (We recommend this method.)

☐ Read Chapter 1, "Introducing MacDraw," and follow along with your Macintosh, if you like. Then turn to Chapter 2, "Using MacDraw," for step-by-step explanations of most MacDraw tasks.

☐ Jump right in and try it. (Many of you have probably done just that.)

Chapter 3, "MacDraw Reference," describes MacDraw concepts and commands in detail. Chapter 2, along with the glossary and index are all designed to help you find information quickly as you work with MacDraw.

A Word to MacPaint Users
MacPaint and MacDraw are both powerful drawing tools, each with its own strengths. Those of you familiar with MacPaint will find that MacDraw works a bit differently. MacDraw makes it easier to work precisely: with built-in rulers for accurate measurements, the ability to measure a selected object, and the ability to line up several shapes in designated ways. MacDraw can accommodate large drawings—up to 8 by 4 feet. And you can work on your entire document at once by reducing it.

You won't be able to erase portions of a MacDraw object or edit it with Fat Bits. That's because each MacDraw object is an entity unto itself: a square is always a square, a circle is always a circle, text is always text, and so forth. But you can change the way objects look by moving, resizing, and changing the fill pattern and border.

You won't be able to paste MacPaint images into MacDraw. You can paste MacDraw images into MacPaint and edit them there.
3 About This Manual
3 How to Get Started With MacDraw
3 A Word to MacPaint Users

6 Chapter 1: Introducing MacDraw
9 Introduction
10 The MacDraw Desktop
11 Objects
14 Text
16 Rulers
17 A Business Card Design

24 Chapter 2: Using MacDraw
27 Introduction
28 MacDraw Basics
41 MacDraw Text
49 Precision and Layout
56 MacDraw Documents

66 Chapter 3: MacDraw Reference
69 Introduction
70 The MacDraw Environment
71 Graphic Objects
74 Text
75 Stacking Order
75 Boundaries of Objects
77 Rulers
77 The Alignment Grid
78 Memory Limits
79 MacDraw Menus
79 Apple Menu
80 File Menu
84 Edit Menu
88 Style Menu
89 Font Menu
90 Layout Menu
96 Arrange Menu
100 Fill Menu
100 Lines Menu
101 Pen Menu
Chapter 1

Introducing MacDraw
Chapter 1 gives you an overview of MacDraw's basic concepts and features. You probably already know a little bit about MacDraw, especially if you've used the Guided Tour or tried the program yourself. If you want to take a break and find out more about MacDraw before continuing, read the first four sections of this chapter: "The MacDraw Desktop," "Objects," "Text," and "Rulers." If you'd rather use MacDraw right away, turn to page 17, and follow along with the illustrated example. Or go to Chapter 2, "Using MacDraw," where you'll find quick step-by-step summaries of most of the drawing and editing features you'll use with MacDraw.

This chapter assumes that you've used the Macintosh and one of its applications. You should already know how to point, click, choose commands from menus, and edit text.
When you start up MacDraw from the Finder, a new, untouched MacDraw document appears. A MacDraw document window has a title bar, a close box, scroll bars, a size box, and a palette of drawing tools.

The window shows you a portion of your document. A new MacDraw document is one 8- by 10-inch page. You can expand your document to more pages.
MacDraw regards every shape you draw as an object:

- text
- lines
- squares and rectangles
- round-corner rectangles
- circles and ovals
- arcs
- freehand shapes
- polygons
You create objects in the window by clicking a tool in the palette and drawing the desired shape: position the pointer where you want to begin, press, drag to where you want to end, and release the mouse button. You don’t have to be too careful about getting the object right the first time; it’s easy to fix later.

Once drawn, an object always remains until you remove it. Drawing another object on top may obscure the original object but doesn’t affect it otherwise. And every object can be individually manipulated. You can change an object’s size, fill pattern, and border width by choosing commands from MacDraw’s menus.

**Selecting**

You can change the way an object looks any time you like by selecting the object and doing something to it, such as moving it, choosing a different line width or pattern from a menu, or changing its size and dimensions.

You select a MacDraw object just as you select a document in the Finder; click with the selection pointer or draw a selection box around it. You select more than one object by enclosing the objects with a selection box or by holding down the Shift key while clicking each object individually.
When an object is selected, handles appear on the corners and midpoints of the boundary, an invisible rectangle that encloses the entire object. You’ll use handles to resize an object.

**Objects Overlap Like Windows**
Whenever you draw a new object, it goes in front of all other objects in the document. Like windows on your desktop, objects overlap in as many layers as you have objects. Unlike windows, objects do not come to the front when you select them. However, MacDraw lets you control the stacking order of objects with commands from the Arrange menu.
By arranging objects from top to bottom, you can combine several simple objects into a more complex drawing:

You can use text in your drawing to create titles, label parts of a drawing, or include longer passages. After you create text, it becomes an object that you can manipulate like other objects. You can also edit text like text in other Macintosh applications. MacDraw provides you with two types of text:

- **caption** text for labels
- **paragraph** text for long passages or for places where you want to control the width of the margins

You create caption text with the text tool. Click the tool, position the text pointer, click where you want the caption, and start typing. Use the Return key to start new lines while you're typing. End the entry by clicking elsewhere or pressing Enter.
Paragraph text is created differently. You first must create or select an object and then start typing. The text width is limited by the boundary of the selected object. As you type, words wrap to the next line. If you want to start a new line before you reach the margin, use the Return key.

This is paragraph text. Use it when you have a lot to say or display. The rectangle you see around it is a separate object—it is underneath the paragraph, and you can move it independently.
By choosing Show Rulers from the Layout menu, you can display rulers along the top and left sides of a document. Rulers help you make objects just the right size, line objects up with each other, and place objects at the right position in your drawing. The preset standard ruler measures in inches. By choosing the Custom Rulers command from the Layout menu, you can tailor the rulers to suit your needs—changing to metric, for example, or changing the number of divisions.

Thin dotted lines in each ruler follow the pointer as you move it, so you always know exactly where you're drawing in relation to the rulers.

You've just seen the basics of MacDraw. The next section takes you through an example showing you how to combine those basics into a drawing.
With MacDraw's structured graphics and text capabilities, creating a business card is easy. Read through this example to see how it's done. Better yet, follow along on your Macintosh to make this card into one of your own.

Start MacDraw like other Macintosh applications:

- **Turn on your Macintosh.**
- **Insert the MacDraw disk.**
- **Double-click the Draw disk icon.**
- **Double-click the MacDraw application icon.**

An untitled MacDraw document appears on your desktop, and MacDraw's menus appear. You're ready to begin drawing.
Most business cards are $3\frac{1}{2}$ by 2 inches. You can easily draw a rectangle this size by using MacDraw's standard rulers.

- Choose Show Rulers from the Layout Menu. Click the rectangle tool and draw a $3\frac{1}{2}$-by-2-inch rectangle.

![Rectangle Tool](image)

- Click the round-corner rectangle tool and draw a border within the rectangle.

You can make the border wider and give it a pattern.

- Choose a wide line from the Lines menu.
- Choose a pattern from the Pen menu.
Click the circle tool.

Draw four small, overlapping circles below the card outline. Select all of them and choose Group from the Arrange menu.

Grouping the circles allows you to manipulate them easily.
- Choose Duplicate twice from the Edit menu.

  Now you have three groups of four circles.

- Select each group in turn and choose a different pattern from the Fill menu.

- Move the groups so they overlap slightly.

- Select all the balloons and choose Group again from the Arrange menu.

  The balloons are finished.

  Now, move the balloons to the card and draw cords for them.
Position the pointer inside the balloons. Drag the balloons into the card.

Click the freehand shape tool and draw lines for the cords.

Use caption text for the business card.

Click the text tool and then click where you want to start typing.

Type a name and press the Enter key when you've finished.

The caption is selected, and the selection pointer is activated. You can use the Backspace key if you make a mistake while typing.

The text appears in the preset font, Chicago.
Choose a different style and font from the Style and Font menus.
Since the text for the phone number and address will be in a different font and size, you’ll start a new caption.

Click the text tool again and then click where you want the phone number and address.

Type the phone number and address.
Use the Return key to begin new lines.

Press the Enter key when you’ve finished.
Change the font or style for the phone number and address if you like.

Choose Save from the File menu.
You’ll be asked to name your document.
Type a title and click Save.

Choose Print from the File menu and click OK.

Choose Quit from the File menu.

You return to the Finder.

This chapter has been a brief overview of MacDraw. If you want to start using MacDraw now, turn to Chapter 2, “Using MacDraw,” for step-by-step instructions for MacDraw tasks. If you'd rather learn more about MacDraw's features, read Chapter 3, “MacDraw Reference.” It tells you about all of MacDraw's concepts and commands.
Dear Royce,

Here are the revised layouts for the General Sprocket Capabilities brochure. I've made the changes we discussed last week—the balance of photos is much better and it now has an overall cleaner look. I've also narrowed the column width to give the layout more white space. Please get back to me as soon as you look over these layouts for the meeting. A little more fine-tuning needed.

Best,
27 Introduction

28 MacDraw Basics
29 Drawing Simple Objects: Rectangles and Ovals
30 Drawing Linies, Polygons, Freehand Shapes, and Arcs
32 Selecting MacDraw Objects
34 Editing Objects
36 Moving Objects
37 Removing Objects
38 Duplicating Objects
39 Grouping and Ungrouping Objects
40 Changing the Stacking Order

41 MacDraw Text
42 Creating Captions
43 Creating Paragraphs
44 Selecting Text
45 Moving Text
46 Editing Text
48 Changing Text Characteristics

49 Precision and Layout
50 Aligning Objects
51 Measuring Objects
52 Using Rulers
54 Drawing to Scale
55 Creating MacDraw Stationery

56 MacDraw Documents
57 Handling MacDraw Documents
59 Moving Around in Your Document
60 Moving or Copying Between Documents
61 Changing Document Size or Orientation
62 Printing Documents
64 Using the Scrapbook
This is the chapter you’ll use most often while you’re working with MacDraw. Chapter 2 presents step-by-step instructions for MacDraw’s elementary tasks as well as instructions for some of the more complex tasks you’ll use to refine your drawings. It’s designed so you can find the information you need quickly and get right back to work.

You’ll find instructions for drawing, selecting, moving, and changing objects in the first section, “MacDraw Basics.” Text tasks are covered in the next section, “MacDraw Text.” “Precision and Layout” shows you how to use some of MacDraw’s special formatting and layout features. “MacDraw Documents” reviews Macintosh document handling as it applies to MacDraw.

“Using MacDraw” emphasizes step-by-step instructions for performing a task. If you’re looking for complete information on a particular MacDraw concept or command, see Chapter 3, “MacDraw Reference.”
This section presents the skills you'll need to create, edit, and move MacDraw objects.

MacDraw's tools are located in the drawing palette on the left side of a MacDraw document window. You select a tool and draw an object in the window. After you draw an object, the object is selected, and the selection pointer is activated so you can immediately move or edit the object.

Most of the tasks presented in this section apply to both graphic objects and text objects. Although text objects are generally treated as objects, they can be edited differently than graphic objects. Editing tasks that apply only to text are covered in the section "MacDraw Text."
**Drawing Simple Objects: Rectangles and Ovals**

Rectangles, ovals, and round-corner rectangles form the basis for many things you create with MacDraw. They're drawn with the current pattern and line width shown in the line/pattern box at the lower left corner of the document window. You can also select different fill patterns and line widths from the Fill, Lines, and Pen menus to take effect with the rectangle or oval you're drawing.

When you draw a new object, it is placed in front of all others. For more information on drawing tools, see "Graphic Objects," page 71.

1. **Click the desired tool in the drawing palette.**

   The tool is highlighted, and the pointer changes to a cross.

2. **Position the pointer in the drawing window, press the mouse button, drag to the desired location, and release.**

   Handles appear around the shape you drew to indicate it is selected. The drawing tool is unselected and the selection pointer is activated.

   You can now edit your shape any way you want.

   You can hold the Shift key while you're drawing to constrain ovals to circles and rectangles to squares.

   To continue using the same drawing tool, hold down the Command key and then draw again.
Drawing Lines, Polygons, Freehand Shapes, and Arcs

With the perpendicular lines and the diagonal lines tools, you don’t have to be very precise in moving the pointer, so you can draw straight lines quickly. Use the perpendicular lines tool for horizontal and vertical lines. Use the diagonal lines tool to draw a straight line between two points: the place where you press the mouse button and the place where you release it.

Use the polygon tool to draw shapes consisting of straight lines and angles, such as triangles, quadrilaterals, trapezoids, or open-ended shapes.

The freehand shape tool works like a pen on a sheet of paper. You can just draw a wavy line or a shape of your own making.

With the arc tool, you can draw a 90-degree arc of a circle or oval in any direction.

Polygons, freehand shapes, and arcs, when first drawn, are just outlines. Their fill pattern is a transparent one called None.

Holding the Shift key while drawing one of these shapes constrains it: lines are constrained to 45- or 90-degree angles, arcs to quarter circles, and polygon angles to 45 or 90 degrees.

To Draw Lines

- Click the perpendicular or diagonal lines tool.
- Position the pointer in the drawing window, press the mouse button, and drag to draw your line.
- Release the mouse button when the line is the length you want.

The line appears selected, with handles at both ends.

To Draw Polygons

- Click the polygon tool.
- Position the pointer in the drawing window, press the mouse button, and drag to the first corner of your polygon.
- At the corner, click, and drag to the next corner.
- Continue clicking and dragging at each corner.
- To end the polygon, release at the starting point, or double-click any place else.

The polygon is selected; handles appear around the boundary of the polygon.
To Draw Freehand Shapes

- Click the freehand shape tool.
- Position the pointer, press the mouse button, and drag to draw a line or shape.
- The shape is automatically selected.

To Draw Arcs

- Click the arc tool.
- Position the pointer, press, and drag to complete the arc.
- A 90-degree arc is drawn with handles around it and filled with None. The direction in which you drag determines the direction and curvature of the arc.
Selecting MacDraw Objects

In MacDraw, as in most Macintosh applications, you must select an object before you can do anything to it. Once you’ve selected an object, you can perform any of the MacDraw operations, including resizing, copying, rotating, duplicating, and grouping. An object you’ve just drawn is automatically selected.

In general, you select an object by clicking inside it with the selection pointer or by drawing a selection box around its boundary—the invisible rectangle surrounding the object. Handles appear on the boundary of a selected object.

Selecting more than one object allows you to perform operations on all of the selected objects at once. You can select objects in normal size and reduced views.

You can select any object, graphic or text, in the ways described here. See “Selecting Text” on page 44 for additional ways to select text.

To Select an Object

- Choose the selection pointer from the palette if it’s not already selected.
- Click anywhere along the border or inside the object.
- Or:
  - Position the selection pointer above and to the left of the object.
  - Press, drag diagonally below and to the right of the object, and release.
  - The object is selected. If it isn’t, try drawing a larger rectangle around the object. The rectangle drawn with the selection pointer must enclose the entire boundary of the object.

To Select an Object Filled With None

- Click the border of the object.
  - Objects with thin borders may be difficult to select in this manner.
- Or:
  - Use the selection pointer to draw a box around the object.
To Select More Than One Object

- Activate the selection pointer.
- Draw a box around all the objects you wish to select.

Or:
- Click the first object you wish to select.
- Hold down the Shift key.
- Click all other objects you wish to select.

Each additional object is selected as you click it. To unselect, click the object again.
- Release the Shift key.

To Unselect an Object While Others Are Selected

- Hold down the Shift key.
- Click each object you want to unselect.

Clicking an object again reselects it.
Editing Objects

It's never too late to change the characteristics of objects. You can make objects larger or smaller, change proportions, change the border, or change the fill pattern. For a full description of each editing command, see Chapter 3, "MacDraw Reference."

All editing operations work on one or more selected objects. See "Selecting MacDraw Objects" on page 32.

To Change the Fill Pattern of an Object

- Select the object.
- Choose a pattern from the Fill menu.
The object is filled with the new pattern. If you choose None, you'll be able to see objects or ruler lines behind the selected object.

To Change the Pattern and Width of a Border or Line

- Select the object.
- Choose a pattern from the Pen menu.
- Choose a new line width from the Lines menu.
You can also choose one of the arrowhead lines from the Lines menu to add arrows at the ends of lines.

To Change the Background Pattern of Text

- Click the text to select it.
- Choose a pattern from the Fill menu.
Sometimes text doesn't stand out clearly against a patterned background. Changing the style of text to shadow or outline will make it stand out. See "Changing Text Characteristics" on page 48.

Chapter 2: Using MacDraw
To Round Corners on Rectangles

- Select an existing rectangle.
- Choose Round Corners from the Edit menu.
  A dialog box appears.
- Choose a rounding option and click OK.
  You can also select a rounded-corner rectangle and change its rounding option. The larger the number you choose, the more rounded the corner will be.

To Resize Objects

- Select the object.
- Position the selection pointer on one of the handles, press the mouse button, and drag.
  You can stretch or shrink the object vertically, horizontally, or diagonally. You can keep changing the size of the object until you release the mouse button.

To Change the Preset Fill Pattern, Line Width, Font, or Style

- Click a tool in the drawing palette.
- Choose commands from the Font, Style, Fill, Lines, or Pen menus.
  - Draw a new object, or click the selection pointer tool to continue working.
  The new line width and fill pattern you chose is shown in the line/pattern box. Any choices you made from the Font and Style menus will affect new text. A pen pattern change affects the lines and borders of any new objects you draw.
Moving Objects

Once you've drawn an object, you can move it around to different places on the page, to another page, or to a different document. You move objects by dragging, cutting, and pasting.

Most of the time, the document you're working on is larger than the window. You can use MacDraw's Reduce and Reduce to Fit features from the Layout menu and then select objects to reposition them on the page or move them to another page.

As you drag objects, an outline of the boundary follows the pointer. To see the outline of objects as you drag, hold down the Option key. To constrain the movement of objects, press and hold the Shift key after you've started to drag. Movement is constrained vertically, horizontally, or diagonally.

If you don't want certain objects to be moved, you can "lock" them in place. See "Lock and Unlock" on page 98.

To move or copy objects to a different document, see "Moving or Copying Between Documents" on page 60.

To Move Objects Inside the Drawing Window

- Select the objects to be moved.
- Position the pointer within the selected area.
- Don't position the pointer on a handle, or you'll resize the object. If the selected object is filled with None, position the pointer on the border of the object.
- Drag to the new location and release the mouse button.
- As long as the mouse button is pressed, an outline of the object follows the pointer around. The object moves to the new location when you release the mouse button.

To Move Objects to Another Part of a Document

- Choose Reduce or Reduce to Fit from the Layout menu to see more of the document.
- Select the objects to be moved.
- Drag the objects to the new location.
- Choose Normal Size from the Layout menu to resume working.
Removing Objects

Removing objects from a document is similar to removing in other Macintosh applications: you select one or more objects and choose Cut or Clear, or press Backspace. Cut places the selection on the Clipboard, while Clear and Backspace do not.

If you have locked objects, you’ll need to choose Unlock from the Arrange menu in order to remove them.

<table>
<thead>
<tr>
<th>To Move an Object to the Clipboard</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Select the object.</td>
</tr>
<tr>
<td>• Choose Cut from the Edit menu.</td>
</tr>
<tr>
<td>The object disappears and is placed on the Clipboard.</td>
</tr>
<tr>
<td>You can now paste the object someplace else.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>To Completely Remove an Object</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Select the object.</td>
</tr>
<tr>
<td>• Choose Clear from the Edit menu or press Backspace.</td>
</tr>
<tr>
<td>The object disappears forever.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>To Remove All Objects in a Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Choose Select All from the Edit menu.</td>
</tr>
<tr>
<td>• Choose Clear from the Edit menu.</td>
</tr>
<tr>
<td>All objects are removed from the document and can’t be retrieved.</td>
</tr>
</tbody>
</table>
Duplicating Objects

You'll find it useful to make several copies of an object and position the copies later. Just repeat the Duplicate command from the Edit menu for as many copies as you want. Each copy appears selected, slightly below and to the right of the original.

1. Select one or more objects to be duplicated.
   You can select individual or grouped objects.

2. Choose Duplicate from the Edit menu.
   The duplicate appears, overlapping the original.

3. Drag the copy to where you want it.
   Choose Duplicate again if you want another copy. Once you've dragged the copy, the next copy will be placed the same distance away as the first copy is from its original.
Grouping and Ungrouping Objects

One of MacDraw's most powerful features is grouping, a way to combine several objects or groups together. A group acts as a single object. You can use grouping to organize several objects into something useful: a square and several lines become a three-dimensional box; text and a filled rectangle become a name badge; lines and small objects become small chairs, bushes, or people for an architectural drawing.

You can separate grouped objects with Ungroup from the Arrange menu to return them to the original individual objects or groups.

Grouping a locked object unlocks it.

To Group Objects

- Select all the objects you want to group.
- Choose Group from the Arrange menu.

The objects are grouped and selected. The group has a new boundary, replacing the individual boundaries of the objects.

To Ungroup Grouped Objects

- Select the group.
- Choose Ungroup from the Arrange menu.

The grouped objects revert to selected individual objects or groups.
Changing the Stacking Order

As with windows, every MacDraw object appears in front of or behind other objects. Each new object you draw is placed in front of all others. However, you can change the way objects overlap in a document with commands from the Arrange menu.

To Bring an Object in Front of or Send It Behind All Others

- Select the object you want to move.
- Choose Bring to Front or Send to Back from the Arrange menu.

The selected object is placed either in front of or behind all other objects.

To Place an Object in Front of or Behind a Selected Object

- Select the object you wish to move.
- Choose Cut or Copy from the Edit menu to place the object on the Clipboard.
- Select the object you want to paste in front of or behind.
- Choose Paste in Front or Paste in Back from the Arrange menu.

The contents of the Clipboard appear in front of or behind the selected object.
MacDraw text is an object in the sense that it has a boundary and can be selected, moved, rotated, and stacked. Text is different from text in a word processing document because each instance of MacDraw text (a text object) is independent of any other text in the document.

Certain MacDraw commands, such as those in the Style and Font menus, apply only to text. You can also use the Fill menu to change the background behind text.

You can create two types of text objects: captions and paragraphs. Captions work best as short labels, a few lines long. Paragraphs can be any length, with the width determined by the boundary of an existing object.

This section tells you how to create and edit text in captions and paragraphs.
Creating Captions

Captions are often single lines of text used as labels or headings. But they can be typed as several lines separated by returns. Word wraparound is not in effect with captions. New captions have the current fill pattern as a background.

When you create caption text, it is aligned halfway between the grid points closest to where you clicked to begin the caption. For more exact placement, turn the alignment grid off.

1. Click the text tool in the palette.
   The pointer changes to become the text pointer.
   You can make selections from the Style and Font menus now to take effect as you type, or you can change characteristics later.

2. Click where you want the text to start.
   You get the insertion point, a blinking vertical bar.

3. Type the text.
   If you want multiple lines, use the Return key for each new line.
   Pressing Enter confirms and selects your caption and activates the selection pointer.
   Clicking anywhere else also completes your caption but leaves the text tool activated.

Text Tool
Creating Paragraphs

Whether you use captions or paragraphs depends on your purpose. You can use paragraphs to take advantage of word wraparound and to confine text to specific areas. To create a paragraph, you'll first draw or select another object, usually a rectangle. You'll use this object as an aid to define the width of your paragraph.

A new paragraph has the current fill pattern as its background.

1. Create an object the approximate width of the paragraph you want to type. Or select an existing object.

You can make selections from the Style and Font menus to take effect as you type, or you can change characteristics later.

If you select more than one object, the boundary that encloses all the objects determines the paragraph's width.

2. Start typing the text.

The length of a line of text is determined by the width of the object you've selected. If a word crosses the right boundary of the object, the word jumps to the next line.

If you type more text than will fit in the object, the text continues below the object's boundary.

If you want blank lines in a paragraph or if you want to force a line break, use the Return key.

3. Press Enter to complete your paragraph.

The paragraph is selected.

Once your paragraph is completed, it becomes a separate object. The paragraph can now be moved away from the object used to determine its boundary.

You can remove the original object or you can group the object and the text if you want them to remain together. See "Grouping and Ungrouping Objects" on page 39.
Selecting Text

You can select entire captions and paragraphs as objects or select individual letters or words within them.

The way in which you select text determines what you can do with it. If you select text as an object, you can treat it like any other object: you can move it, group it, change its background and so on. If you select text with the text tool, you can edit portions of it, but you can’t do things you’d do to an object such as moving or resizing.

To Select a Caption or Paragraph as an Object

- Use the selection pointer to click the text.
- The text is selected in the same way as an object: handles appear around its boundary.

To Select Portions of Caption or Paragraph Text

- Click the text tool in the palette.
- Use the text pointer to select the insertion point, letters, or words by clicking or dragging in the text.
- Text selected in this manner is highlighted white on black.
- Double-clicking with the text tool selects the entire word.
- Triple-clicking selects the entire caption or paragraph.
Moving Text

Like other objects, captions and paragraphs can be moved by dragging, cutting, or pasting. In addition, you can move portions of a caption or a paragraph with Cut and Paste.

You can use MacDraw's Reduce or Reduce to Fit commands from the Layout menu to move the text across an area larger than the window.

To Move an Entire Caption or Paragraph

- Select the caption or paragraph by positioning the selection pointer inside it and clicking.
- Drag the text to the new location.

You can also choose Cut from the Edit menu to place the selected text on the Clipboard and then paste it in another part of the document or to a different document.

A caption or paragraph selected with the selection pointer can only be pasted in front of another object. It does not replace the selected object.

To Move Part of a Caption or Paragraph

- Select the text tool from the palette.
- Select the words you wish to move.
- Choose Cut or Copy from the Edit menu.

Cut removes the selected text and places it on the Clipboard. Copy places a copy of the selected text on the Clipboard, leaving the original selection intact.

- Click where you want to move the text.
- Choose Paste from the Edit menu.

The selected text appears in the new location.
Editing Text

Editing text in MacDraw is similar to editing text in other Macintosh applications: you can select, insert, cut, and paste.

To change characteristics of text such as styles or fonts, see "Changing Text Characteristics" on page 48.

<table>
<thead>
<tr>
<th>To Change Text as You Type</th>
<th>To Insert New Text</th>
<th>To Remove Text</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use the Backspace key.</td>
<td>Select the text tool from the palette.</td>
<td></td>
</tr>
<tr>
<td>If you are typing a caption or paragraph and make a mistake, use the Backspace key to erase previous characters. You can then retype them.</td>
<td>Position the pointer where you want to insert new text and click. The insertion point appears.</td>
<td></td>
</tr>
<tr>
<td>Type the new text.</td>
<td>Type the new text. The new text is inserted. The text tool remains active until you click another tool from the palette or press Enter.</td>
<td></td>
</tr>
<tr>
<td>If you insert new text in a caption, the line grows longer unless you use a return. If you insert new text in a paragraph, word wraparound rearranges the text to maintain the width of the paragraph.</td>
<td>Drag to select the text you wish to remove.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Choose Clear from the Edit menu, or press Backspace. The text is removed permanently. To remove text and place it on the Clipboard, use Cut from the Edit menu. If you use the Backspace key when a caption or paragraph is selected as an object, the entire caption or paragraph is removed.</td>
<td></td>
</tr>
</tbody>
</table>
To Paste Text Into a Caption or Paragraph

- Select the text tool from the palette.
- Position the pointer where you want to paste text and click.
  The insertion point appears.
- Choose Paste from the Edit menu.
  The new text is inserted in the font and style of the caption or paragraph. The text tool remains active until you click another tool in the palette.

To Replace Existing Text

- Use the text tool to select the text you want to replace.
- Type new text or paste text from the Clipboard.
  All the selected text is replaced with what you type or paste.
  If you select a caption or paragraph as an object, any new text typed or pasted takes the place of all text in the selection.

To Resize a Paragraph

- Select the paragraph with the selection pointer by clicking or drawing a selection box around it.
- Drag one of the handles.
  The boundary changes size according to the direction you drag. You'll notice the boundary grows no larger than needed to contain the text.
- When you've reached the desired new size for your paragraph, release the mouse button.
  The text rearranges itself to fill the new paragraph boundary.

You can't resize captions. You can, however, insert returns to break lines in a caption.
Changing Text Characteristics

You can change the font, style, size, alignment, spacing, and background pattern of text. These characteristics apply to all text in a caption or paragraph and any new text inserted or pasted later. Although you can't mix fonts or styles within a caption or paragraph, you can type a one-word caption in a different style or font and move it over a word in another caption or paragraph to simulate mixed styles. Changing the font or size of a paragraph may rearrange the text.

To Change the Font or Size of a Caption or Paragraph
- Select the caption or paragraph.
- You can select the caption or paragraph by clicking with the selection pointer, or you can select a portion of the text with the text pointer.
- Choose a new font or size from the Font menu.

To Change the Style, Alignment, or Spacing
- Select the caption or paragraph.
- Choose new styles, alignment, or spacing from the Style menu.
- See "Style Menu" on page 88 for details about styles, alignment, spacing, and case.

To Change the Background Pattern of Text
- Select the caption or paragraph.
- Choose a new pattern from the Fill menu.
- Text may not stand out clearly against certain patterns. Experiment with different text styles such as shadow and outline to get the effect you want.
At MacDraw's simplest level, you create objects and move them around on the page to make a drawing. However, MacDraw's unique layout and arranging commands allow you to manipulate objects into complex and precise drawings.

Rulers, the alignment grid, Show Size, and other commands allow you to position objects precisely, draw and resize them to exact measurements, and show drawings to scale. You can create a "template" document to keep track of favorite settings. "Creating MacDraw Stationery" at the end of this section shows you how.
**Aligning Objects**

1. Select the objects you wish to align.

   You can align objects in normal size or reduced views.

2. Choose Align Objects from the Arrange menu.

   A dialog box appears.

3. Click the alignment options you want and click OK.

   The objects align.

For more information about how objects align, see Chapter 3, "Align Objects" on page 99.

Chapter 2: Using MacDraw
Measuring Objects

To Draw Objects of a Certain Size

- Choose Show Size from the Layout menu.
- Select a tool from the palette and begin to draw.
- Numbers appear near the pointer, changing dynamically to indicate the size as you drag.
- Release the mouse button when you reach the desired size.

To Measure an Existing Object or Group

- Choose Show Size from the Layout menu.
- Select the object or group you wish to measure.
- Position the pointer in the lower right corner of the object.
- Without moving the mouse, press and hold the mouse button.
- As long as you don’t move the pointer, the size of the object or group shows. If you move the pointer, you’ll move the object.
- Fill patterns and objects underneath may make it difficult to read the measurements. Try moving the pointer to different parts of the object.

To Resize Objects Using Show Size

- Choose Show Size from the Layout menu.
- Make sure the selection pointer is activated.
- Select the object you want to resize.
- Position the pointer on one of the handles. Drag the handle and release when it’s the size you want.
- The measurements change dynamically as you resize.

With MacDraw’s Show Size command, you can measure existing objects or measure any object as you draw or resize it. Show Size measures the boundary of a given object or group:

- the length of diagonal and perpendicular lines
- the height and width of rectangles and ovals
- the height and width of arcs, polygons, freehand shapes, captions, and paragraphs
- the height and width of the boundary of multiple selections of objects
- the angle of an arc in degrees as you are reshaping it
- the length and height of each line of a polygon, as you draw it

Show Size measurements are in the scale you have chosen (see “Drawing to Scale” on page 54), either centimeters or inches, depending on which option is in effect for the rulers.

If you draw a selection box, Show Size displays the size of the selection box as you drag. It does not show the size of the object you’re selecting.
Using Rulers

A MacDraw document window has two rulers, one across the top and one down the left side. Rulers extend the full length and width of your document, measuring up to the maximum document size of 96 by 48 inches, or 243.84 by 121.92 centimeters.

You can show or hide rulers, change the starting or zero point, and change the units of measurement.

The major and minor divisions on the rulers control the appearance of ruler lines on the screen. The minor divisions also control the alignment grid. You can also use major divisions to indicate scale in your document. See “Custom Rulers” on page 90 for more information.

The place where the zero marks of the two rulers intersect is called the zero point. In a new document, the zero point is at the upper left corner. You can unlock the zero point and move it anywhere in the document. You can move the zero point to the exact center of a document or use it to measure objects precisely.

Rulers are hidden in a new document.

To Show or Hide Rulers

- Choose Show Rulers from the Layout menu to display rulers in your document window.
- Choose Hide Rulers from the Layout menu to remove rulers from your document window.

To Change the Spacing on Rulers

- Choose Custom Rulers from the Layout menu.
- Click Custom under the Ruler option.

The dialog box displays more options.

- Click one setting for Major Division Spacing and one setting for Number of Minor Divisions.
- Click OK.

The rulers readjust to reflect the new spacing choices. The ruler lines change, and the alignment grid now follows the Number of Minor Divisions setting.
To Use Metric Measurements

- Choose Custom Rulers from the Layout menu.
A dialog box appears. One of the options is Inch or Centimeter.
- Click Centimeter.
- Click OK.
The rulers show metric measurements. Show Size and Drawing Size will now also use metric measurements.

To Move the Zero Point

- Choose Custom Rulers from the Layout menu.
The dialog box appears.
- Click Unlocked for the zero point option.
- Click OK.
The dialog box disappears.
- Position the selection pointer in either ruler.
- Press and drag along the ruler or into the window to reposition the zero point.
Two perpendicular gray lines follow the pointer, showing where the zero point will be when you release the mouse button.
- Release the mouse button to confirm.

To Reset the Zero Point to the Preset Position

- From anywhere in your document: click the box where the two rulers meet.
The zero point returns to the upper left corner of the document.

Using Rulers
**Drawing to Scale**

Scale drawings represent objects as smaller or larger than they are in real life. Scale drawings are true to life because they keep the same proportions regardless of size.

To create scale drawings with MacDraw, you define the major divisions on a ruler as equal to some other scale: for example, one inch may equal eight feet.

When you've set up a drawing to scale, the numbering on the rulers as well as the Show Size command displays sizes in real-life measurements.

1. **Determine the document size and orientation.**
   
   Use the Drawing Size command from the Layout menu to define the size of your drawing, and Page Setup from the File menu to define the page size and orientation.

2. **Calculate the scale by comparing the size of the real-life object to the document size.**
   
   Divide the total width of the real-life object by the width of your document in inches or centimeters. The result is the scale.

3. **Choose Custom Rulers from the Layout menu and click Custom.**
   
   - Set Numbering Increments to the number you calculated for the scale.
   - Set Number of Minor Divisions to the scale or a multiple of the scale.
   
   Setting the number of minor divisions to correspond to the scale will let you use the alignment grid to draw accurately and constrain objects to desired fractions of a unit.
Creating MacDraw Stationery

As you become an experienced MacDraw user, you'll probably develop a favorite combination of settings or standard settings for different types of drawings. Rather than change all the settings each time you open a new document, you can create template documents, or stationery.

To Create Stationery

- Create or open a document and change any options or settings you'll want to use often.
- Use the Save As command to save to a meaningful name (like "Floorplan Template" or "Purchase Order Forms").
- Quit MacDraw and return to the Finder.
- Select the document and choose Get Info from the File menu.
- Click Locked to protect the document from being accidentally removed.

To Use Stationery

- From the Finder, select the document you want to use as a template.
- Choose Duplicate from the File menu and type a new name for the copy.
- Choose Open from the File menu to start MacDraw and begin working.

You're free to change the document as you like, and your stationery remains unchanged.
Working with documents in MacDraw is similar to other Macintosh applications, except that you can have as many as four documents open at once on your desktop. This capability can save you a lot of time if you need to switch back and forth between documents often.

This section shows you how to work with documents: how to create new documents and open existing ones, how to name and save them, how to move around in a document, how to move MacDraw objects between documents, how to change a drawing’s size, how to print, and how to use the Scrapbook.
## Handling MacDraw Documents

If you've handled documents in other Macintosh applications, you'll immediately be familiar with the procedures in MacDraw. The main difference is that you can have up to four documents open at once on the desktop.

When you first start up MacDraw by double-clicking its icon from the Finder, you get a new, untitled document.

For more detailed information on document handling from the Finder, see *Macintosh*, your owner's guide.

<table>
<thead>
<tr>
<th>To Create a New Document</th>
<th>To Open an Existing Document</th>
<th>To Activate an Open Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>Choose New from the File menu.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>A new, untitled document appears; you'll be asked to name it the first time you save it.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>New is dimmed if you already have four open documents. You'll have to close one of the documents before you can open another. See &quot;Close&quot; on page 81.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Choose Open from the File menu.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>A dialog box appears with a list of all the MacDraw documents that are on the disk.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>If the document you want is on a different disk, click the Eject button and insert the second disk. If you have two disk drives, insert the disk in the other drive and click Drive.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Select the document you want to work with by double clicking its name in the list of documents.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>You won't be able to open a document if there isn't enough memory available to hold it.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- Click anywhere in it to bring it to the top, making it the active document.

You may have to move or resize windows on top to find the document you want to activate.
To Name an Untitled Document

- Choose Save from the File menu.
- A dialog box appears.
- Type a name for your document.
- Click the Save button.
You'll get a message if the disk is full. Eject the disk and save to a different disk.

To Save a Document

- Choose Save from the File menu.
- If this is a new document, you'll be asked to name it. Otherwise, the document is saved with the same name on the same disk.
- Until you save a document on a disk, it is stored only temporarily while your Macintosh is on. Be sure to save often to prevent accidental loss.

To Save a Copy to a Different Name or Disk

- Choose Save As from the File menu.
- If you want to save to a different disk, click the Eject button to eject the current disk.
- Insert the disk you want to save the document to or click Drive if you have two disk drives.
- Type a new name for the document if you want; otherwise, it will replace the document with the same name.
- Click the Save button.
This saved version includes the changes you made to the document since the last time you saved it. Choosing Save will now save the document under the new name.

To Quit MacDraw

- Choose Quit from the File menu.
- You'll be asked to save any unsaved changes for each open document.
- Click Yes to save the changes and quit MacDraw.
- No to quit MacDraw without saving, or Cancel to retract the Quit command.
**Moving Around in Your Document**

A MacDraw document can be as small as 8 by 10 inches and as large as 8 by 4 feet. From the document window in normal size, you can only see a portion of your document at a time. To move to another part of your document, you can use the scroll bars on MacDraw’s windows or you can use MacDraw’s Reduce or Reduce to Fit commands to view your entire drawing.

**To Move Using Scroll Bars**

- Press on the scroll arrows, click the gray area of the scroll bar, or drag a scroll box.
- You can also use scroll bars in reduced views of your document.

**To Move With Your Entire Document in View**

- Choose Reduce to Fit from the Layout menu.
- You can now see your entire document in the window.
- Select an object or click near where you want to work.
- See “Selecting MacDraw Objects” on page 32.
- When you’ve finished working in the reduced view, you can return to normal size by choosing Normal Size from the Layout menu.
Moving or Copying Between Documents

Copying information between MacDraw documents is easy because you can have up to four MacDraw documents open on your desktop.

If there isn't enough memory to copy your selection to the Clipboard, you'll be warned by a dialog box.

You can also use the Scrapbook to store frequently used images to paste into your documents. See “Using the Scrapbook” on page 64.

1. Select the object you want to move or copy and choose Cut or Copy from the Edit menu.

The selection is placed on the Clipboard.

Cut removes the selection from the document. Copy leaves the selection in the document.

2. Open or activate another document and move to the place you want the selection to appear.

Click or select an object near where you want the copy to appear.

3. Choose Paste from the Edit menu.

The contents of the Clipboard appear at the selected spot in the document window.
Changing Document Size or Orientation

In MacDraw, you can control both the size of individual pages and the size of a document. Page size and orientation are controlled by the options you choose with the Page Setup command in the File menu. The overall size and number of pages of your document are controlled with Drawing Size in the Layout menu.

The preset MacDraw drawing size is one 8-by-10-inch page. You can increase the drawing size by rectangular increments up to 96 by 48 inches. When you print on standard 8½-by-11-inch paper, you get ¾-inch side margins and ½-inch top and bottom margins.

You can't make the drawing size smaller if doing so would omit pages with objects on them. You must remove everything from those pages first.

To Change the Page Size or Orientation

- Choose Page Setup from the File menu.
- Click a Paper option for the page size.
- Click Tall or Wide to change the paper orientation.
- Changing the paper orientation will change where page breaks fall in a multi-page document. For more information, see "Page Setup" on page 82.

To Change the Drawing Size

- Choose Drawing Size from the Layout menu.
- A dialog box appears with a matrix of rectangles. Each rectangle represents a page. Your current drawing size is represented by black rectangles.
- Click any square in the matrix.
- Your new drawing size is represented with black squares.
- Click OK to confirm your new drawing size.
The Apple Imagewriter printer is designed to be used with the Macintosh. See Macintosh, your owner's guide, for instructions on setting up the Imagewriter.

When you choose Page Setup or Print from the File menu, the printing resource must be on the disk. Refer to your owner's guide, Macintosh, or printer manual for instructions.

See the "Print One" command description on page 82 for another way to print.
4. Choose Print from the File menu.

A dialog box appears with print specifications you'll confirm each time you print.

5. Set the print specifications and click OK to confirm the command.

The document begins to print.

To stop printing, hold down the Command key and type a period (.)

The Quality and Paper Feed options appear set as they were the last time you printed. Print specifications are not saved with a document.
Using the Scrapbook

You can use the Scrapbook to bring information from another application into a MacDraw document or to paste MacDraw objects into other applications.

You can paste MacDraw objects into MacDraw, MacWrite, and MacPaint documents. Once pasted into a MacWrite or MacPaint document, MacDraw objects cannot be pasted back into MacDraw.

You can paste text from most other applications into MacDraw documents. You cannot, however, paste images created with MacPaint into a MacDraw document.

To Copy MacDraw Objects Into the Scrapbook

1. Select the objects you wish to copy.
2. Choose Copy from the Edit menu.
3. Choose Scrapbook from the Apple menu.

The Scrapbook appears on your desktop.

To Copy MacDraw Objects From the Scrapbook Into a MacDraw Document

1. Choose Scrapbook from the Apple menu.

The Scrapbook appears.

2. Scroll to the objects you wish to copy.
3. Choose Copy from the Edit menu.

The objects are copied to the Clipboard.

4. Click the Scrapbook's close box.
5. Use the selection pointer to click a place or select an object near where you want to paste the objects.

6. Choose Paste from the Edit menu. Or choose Paste in Front or Paste in Back from the Arrange menu.

To Copy the Scrapbook to a Different Disk

Often, you'll fill the Scrapbook with MacDraw objects you'd like to use with another disk or application.

- Insert the disk to which you want to copy the Scrapbook.

The disk must be a startup disk.

- Open the folder called "System Folder."

This folder contains the existing Scrapbook on this disk. If you want to keep its contents, you'll need to rename it.

- Click the Scrapbook file icon and type a new name.

- Eject the disk and insert the disk with the new Scrapbook.

- Open the System Folder and drag the Scrapbook file icon to the other disk's icon.

If you have one disk drive, you'll be asked to switch disks to complete the copy.

---

To Copy Text From the Scrapbook Into a MacDraw Document

- Choose Scrapbook from the Apple menu.

The Scrapbook appears.

- Scroll to the text you wish to copy.

- Choose Copy from the Edit menu.

The text is copied to the Clipboard.

- Close the Scrapbook.

- Use the selection pointer to click a place near where you want to paste the text.

- Choose Paste from the Edit menu.

Text appears as paragraph text in MacDraw's preset font, plain style, left aligned, and single spaced.
Contents

69 Introduction

70 The MacDraw Environment
71 Graphic Objects
71 Perpendicular Lines
71 Diagonal Lines
71 Rectangles, Round-Corner Rectangles, and Ovals
72 Arcs
73 Freehand Shapes
73 Polygons
74 Text
75 Captions
75 Paragraphs
75 Stacking Order
75 Boundaries of Objects
77 Rulers
77 The Alignment Grid
78 Memory Limits

79 MacDraw Menus
79 Apple Menu
80 File Menu
84 Edit Menu
88 Style Menu
89 Font Menu
90 Layout Menu
96 Arrange Menu
100 Fill Menu
100 Lines Menu
101 Pen Menu
This chapter is an overview and summary of the elements of MacDraw. It tells you about MacDraw without emphasizing how to learn it or how to do things with it.

The first part of this chapter tells you about the MacDraw environment, how to use the drawing tools, and how to work with different objects on the desktop. The second part describes in detail the commands in each menu. For step-by-step instructions on the drawing and layout tasks you can do with MacDraw, see Chapter 2, "Using MacDraw."
The MacDraw Environment

Everything you create in a MacDraw document is an object. MacDraw keeps track of pertinent information about each object: its geometry, its size, fill pattern, border pattern and width, its location, and its stacking order.

You create objects by choosing a tool from the drawing palette and then drawing or typing. The palette contains the selection pointer and nine tools that you use to create objects. Clicking one of the tools in the palette lets you use it.

- The selection pointer allows you to select, move, or resize existing objects.
- The text tool lets you create caption text and select and edit existing text.
- Each drawing tool allows you to draw an object of a particular shape.

The tool you click is highlighted in gray to show it’s selected. After you draw an object, MacDraw automatically activates the selection pointer so you can immediately manipulate what you just drew. If you want to draw more than one object with the same tool, hold down the Command key and then draw the next object.
You can easily change the characteristics of objects:

- All objects except text can have one of 4 border widths and 36 border patterns, including no border.
- Perpendicular and diagonal lines can be in any of 4 widths and 36 patterns and can have arrowheads on either or both ends.
- All objects except lines can be filled with any of 36 patterns, including a "transparent" pattern called None, which lets objects underneath show through.

You can draw several kinds of graphic objects in a document: perpendicular and diagonal lines, rectangles and squares with square or rounded corners, ovals and circles, arcs and wedges, freehand shapes, and polygons. Rectangles and ovals are created with the current line width and pattern, shown in the line/pattern box in the lower left corner of the window.

**Perpendicular Lines**
Created with the current line width and pen pattern. The line drawn is either horizontal or vertical, depending on which direction you draw. You can change the direction of the line before releasing the mouse button by going back to the starting point. Extend or shorten a line by dragging the handle at either endpoint. Add arrowheads to the ends by choosing arrowhead lines from the Lines menu.

**Diagonal Lines**
Created with the current line width, pen pattern, and arrowheads. A straight line is drawn between the start and endpoint. Using the Shift key constrains the line to 45 or 90 degrees. Extend, shorten, or change the direction of the line by dragging the handle at either endpoint. Add arrowheads to the ends by choosing arrowhead lines from the Lines menu.

**Rectangles, Round-Corner Rectangles, and Ovals**
Created with the current fill pattern, line width, and pen pattern. Use the Shift key to constrain a rectangle to a square or an oval to a circle. Resize by dragging one of the eight handles. Use Round Corners in the Edit menu to round the corners.
Arrows
Created with None and the current line width. An arc is always created as a 90-degree arc: a quarter circle or oval. The direction you draw determines the curvature of the arc. While drawing, you can go back to the starting point to change direction. Resizing an arc by dragging its handles changes its curvature and size. Reshaping by dragging either of the reshaping handles shortens or extends the degree of the arc. Use the Shift key to constrain an arc to a quarter circle.

Filling in an arc with a visible pattern produces a pie-shaped wedge with a border around the curved part only, not around the entire wedge.
Freehand Shapes
Created with None and the current line width. You can use the Smooth and Unsmooth commands from the Edit menu to create interesting effects. However, once you smooth or unsmooth a freehand shape, you cannot return it to its original incarnation.

Every freehand shape you draw, from the time you press the mouse button to the time you release it, is one object. If you continue drawing freehand shapes to create a picture, you may want to group them so you won’t inadvertently move a shape and disturb the effect you were trying to achieve. Use freehand shapes sparingly; they consume more memory than other objects.

Polygons
Created with None and the current line width. The Shift key constrains each angle of a polygon to 45 or 90 degrees. You can resize a polygon by dragging one of eight handles. If you choose Reshape Polygon from the Edit menu, you can drag a handle at any vertex to change the appearance of the polygon. You can smooth the corners of a polygon by choosing Smooth from the Edit menu.

To draw a polygon with cusps (pointed ends), hold down the Option key and begin to draw the polygon as you would normally (see page 30), except at each corner where you’d like a cusp, double-click. To end the polygon, release the Option key and double-click. Choose Smooth from the Edit menu. If you choose Reshape Polygon from the Edit menu, two handles appear at each corner where you double-clicked. When you reshape a
polygon with cusps, the handles don't show at the corners with cusps because there are two handles stacked on top of each other, canceling each other out. You can drag the handles away from each other to get rid of the cusp and create another corner.

You can add two different kinds of text objects to your document: a caption, usually a single line of text, and a paragraph, a block of text filling a rectangle.
All text inside a caption or paragraph can be in one font, one of eight font sizes, and a combination of six styles. It can be left, right, or center aligned, and single, one-and-a-half, or double spaced.

Commands in the Edit, Style, and Font menus affect all text in a caption or paragraph. Text selected with the text tool is affected by commands in the Edit menu and the Lowercase, Uppercase, and Title commands in the Style menu. New text has the current fill pattern as its background.

Captions
You create a caption by selecting the text tool from the palette, clicking anywhere in the document, and typing. You complete a caption by pressing Enter or clicking elsewhere. The caption appears as you type, on top of all other objects. If you want to move it, select the caption as an object and drag it to where you want it. You can also select and edit text within the caption with the text tool.

Paragraphs
To create a paragraph, select one or more objects and start typing. The width of the paragraph is set to the width of the boundary of the selected object. Press Enter to complete the paragraph. It becomes a separate object stacked in front of the object you first selected. You can drag a selected paragraph, like other objects, to a new location. Dragging its handles changes the shape of the boundary that the text fills. You can also select and edit text within the paragraph with the text tool.

When you draw a new object or group several objects together into one object, the new object or group is placed in front of all others. With commands in the Arrange menu, you can send an object to the back and uncover overlapped objects. Or you can select an object and bring it to the front to see it in its entirety.

You can insert an object between any two objects with the Paste in Front and Paste in Back commands in the Arrange menu (see page 96).

Each object you draw has a boundary, an invisible rectangle that encloses the object. The boundary is important for several reasons:

- When the alignment grid is on, the edges of the boundary always line up on the grid.
- When the object is selected, handles appear at the corners and edges of the boundary. Change the size of the object by dragging these handles.
When you use the Align Objects command in the Arrange menu, you're actually aligning the boundaries of the objects (or the centers of the boundaries), not the edges of the objects themselves.

If the object has a border, the border is centered on the boundary of the object. When two objects adjoin, their borders may overlap if you've chosen a wide border from the Lines menu.

Objects with identical boundaries, but different border widths appear to be different sizes.
The rulers along the top and left edges of the document are hidden in a new document; you can see them by choosing Show Rulers from the Layout menu. When they're showing, they help you make objects a specific size, line them up with each other, and place them at the right spot on the page. The Custom Rulers command in the Layout menu (see page 90) lets you customize the rulers.

The ruler lines are extensions of the rulers' tick marks. They help you lay out a drawing, but don't show when you print the document. You can hide them with the Hide Ruler Lines command in the Layout menu. The spacing of tick marks and ruler lines is set by the Custom Rulers command. MacDraw draws one ruler line for every major division on the ruler and draws lighter lines for minor divisions that are ½ inch apart or more.

Ruler measurements show actual distances for the printed document and approximate distances for the document displayed on the screen.

To help you line up things precisely, MacDraw provides an invisible alignment grid that controls the size and placement of objects. When you draw an object, its boundary automatically lines up to the alignment grid. When you move or change the size of the object, it remains on the alignment grid.
You can adjust the spacing of the alignment grid with the Number of Minor Divisions Spacing option in the Custom Rulers command (Layout menu). If you want to draw unconstrained objects, you can turn the alignment grid off with the Turn Grid Off command in the Layout menu. When you turn off the alignment grid or change its spacing, objects you've drawn on the previous alignment grid may be off the new one. To get those objects on the new alignment grid, select them and choose Align to Grid from the Arrange menu. If you want them to remain on the former alignment grid, be sure to not move them or change their size; they'll still be on the former alignment grid when you return to it.

You can see the alignment grid in action. When rulers are showing, thin lines in each ruler track the pointer. You'll notice these lines jump to the next tick mark or halfway between tick marks as you move the pointer.

The About MacDraw command in the Apple menu tells you how much memory is available to you, expressed as a percentage of total memory. The amount of memory available on your Macintosh affects certain aspects of working with MacDraw: the number of objects you can create, opening a new or existing document, and copying information to and from the Clipboard or the Scrapbook.

When you attempt to open a new or existing document, MacDraw determines the amount of memory available and compares it with the amount of memory the new document needs. If there's not enough memory available, you'll be warned with a dialog box.

Information held on the Clipboard (anything you copy with the Copy or Cut commands from the Edit menu) is stored in memory. If there's not enough memory for the cut or copy, you'll be warned with a dialog box. Copying information from the Scrapbook means you first copy to the Clipboard. If there's not enough memory to copy to the Clipboard, you'll be warned.

Other tasks you'll perform in MacDraw may be subject to the amount of memory available. If there's not enough memory available to complete an operation, you'll be warned by a dialog box. In general, if you're running low on memory, you can gain more by closing a document if you have more than one open or by removing some objects from a document.

If you're interested in the amount of memory different objects consume (we're talking bytes, folks), see Appendix B, "Objects and Memory Usage," on page 105.
MacDraw Menus

Some MacDraw menu commands are accompanied by the Command key symbol and a letter. To choose the command, you can hold down the Command key while typing the letter rather than pulling down the menu with the pointer.

Apple Menu

About MacDraw
This command shows the version number and author of MacDraw. It keeps track of the number of objects and the amount of memory they consume for the active document and for all open documents.

MacDraw Version 1.0
by Mark Cutler
© 1984 Apple Computer, Inc.

Active Document All
Number of objects: 18 18
Percent of Memory Used: 2 3

Desk Accessories
Choosing any of the desk accessories causes that accessory to appear as the active window. You can use the Edit menu to cut, paste, or copy the information in most accessories to other accessories or to a MacDraw document. You close an accessory by choosing Close from the File menu or by clicking the accessory's close box.
Some desk accessories particularly useful with MacDraw are:

- The Scrapbook, to store a repertoire of frequently used drawings or passages of text. You can also use it to move pictures or passages of text between documents or applications. See “Using the Scrapbook” on page 64.

- The Calculator, to do quick calculations and paste the results into a document. Choosing Copy or Cut automatically copies the display to the Clipboard.

- Key Caps, to see the complete set of foreign and special characters available with the Option and Shift keys. Hold down the Option key, Shift key, or both to see the optional characters available with the Chicago font. Note that different characters may be available with different fonts and sizes.

Commands in the File menu apply to MacDraw documents. With MacDraw, you can have up to four documents open at once; once four are open, you can’t choose New or Open until you close one of the others. You can’t open another document if there’s not enough memory to hold the document.

**New**
This command lets you open a new, untitled document. The document’s rulers, alignment grid, page setup, and drawing size are MacDraw’s preset options (see page 104).

**Open**
This command lets you open an existing MacDraw document. You select the document you want from a list that appears in a dialog box. The Open button in the box opens the document you’ve selected. The Drive and Eject buttons let you open a document on a different disk.
**Close**

This command closes the active window, whether it's a MacDraw document, a desk accessory, or the Clipboard. It's the same as clicking the window's close box. If you've made changes to a MacDraw document since the last time you saved it, you're given an opportunity to save the changes before closing the window.

**Save**

This command saves a copy of the active document on a disk, automatically replacing the document that has the same name. If you have more than one document on your desktop, you must activate each of the documents by clicking in it before you can save. Use Save when you want to update your document with your most recent changes. Use Save As when you want to save a copy without affecting the document on the disk.

If the document is untitled, MacDraw asks you to name the document before saving it. See “Save As” for a description of the dialog box you’ll see.

**Save As**

This command lets you save the active document under a different name or on a different disk. It creates a new document, leaving the original unchanged. Any further changes you make will be saved to this new document when you use the Save command.

Use Save As when you want to save your new work but keep a copy of the original as a backup, or when you want to move your work to another disk. (If you're using Save As just to make a backup copy, be sure to use Save first to update your changes on your disk.)

The Eject button ejects the named disk, allowing you to insert another disk. If you have an external disk drive, the Drive button allows you to switch between the internal and external drives. The Cancel button cancels the Save As operation, leaving your work unsaved. The PICT format button saves a MacDraw document in a special format, allowing other applications that use the PICT format to open MacDraw documents.
Revert
This command removes all changes to the document since the last time you saved it. It actually reopens the last saved version of the document from the disk you saved it on. The Cancel button lets you cancel the Revert command, leaving the current document with all its changes.

*If you choose Revert and can't supply the disk that has the last saved version on it, there's no escape:* you'll have to turn your Macintosh off and start it up again with the MacDraw disk, losing all changes to all documents since the last save. Use Revert only when you have the disk with the last saved version.

Print One
This command prints one copy of the active document, using either the last page setup and print specifications you set or MacDraw's preset specifications if you haven't changed them.

Page Setup
This command lets you specify the page size and orientation, affecting how your document is printed with Print and Print One. The options you choose in Page Setup are reflected in Drawing Size from the Layout menu.

Changes you make to Page Setup are saved with the document, so you'll usually set them only once for that document. The preset choices are US Letter and Tall.
Print
This command prints a copy of the active document using the specified settings. Print presents a dialog box offering you choices for printing your document:

- Text Only, One Font, One Size; Plain Text, Bold, and Underline Styles Only; Fastest Speed
- Screen-Quality Printing; Faster Than High Quality
- Highest Quality Printing
- Number of Copies to Be Printed
- Fanfold Paper Fed Continuously Into the Printer
- Specified Pages to Be Printed
- Single Sheets of Paper Fed Individually Into the Printer

The Quality and Paper Feed options, once set, retain their settings from printing to printing. However, the Page Range and Copies options return to their standard settings each time you choose Print.

The Page Range option lets you control which pages of a multi-page document will be printed. For example, if your drawing (as shown in Drawing Size in the Layout menu) is four pages wide and three pages tall, setting Page Range to "From: 6 To: 7" will print the two pages in the center of the document.

If there's no printing resource in the System Folder on the MacDraw disk, MacDraw can't print your document. (The printing resource is a file in the System Folder with the same name as the printer you're using, such as Imagewriter.)
A document that's larger than one page is printed in sets of pages, which you can tape together to form the whole drawing. If you've chosen Tall or Tall Adjusted orientation, MacDraw prints the drawing in vertical strips of pages starting at the left side of the drawing and moving to the right; if you've chosen Wide orientation, it prints the drawing in horizontal strips from the top to the bottom.

**Show Clipboard/Hide Clipboard**
These commands show or hide the Clipboard window, which contains what you last cut or copied. To close the Clipboard window, click the close box or choose Hide Clipboard.

**Quit**
This command leaves MacDraw and returns you to the Finder. If you've made changes since last saving any open document, you're given the opportunity to save those changes before quitting.

**Undo**
This command undoes the effects of your most recent editing change to an object.

**Cut**
This command removes selected objects or text from a document and places them on the Clipboard, replacing anything on the Clipboard.

**Copy**
This command copies selected objects or text to the Clipboard, replacing anything on the Clipboard.
**Paste**

This command places a copy of the Clipboard’s contents in your document. The copy is selected, and any previously selected objects are unselected.

You can paste objects or text into the Scrapbook. You can also paste pictures or text from the Scrapbook and text from the Calculator, Note Pad, or Key Caps into a MacDraw document. See “Using the Scrapbook” on page 64 and “Desk Accessories” on page 79.

**Pasting Objects**

An object is pasted in front of all other objects. Where the copy is placed depends on whether objects are selected:

□ If you’ve just opened the document and haven’t clicked in it yet, the copy is placed in the center of the document window.

□ If you’ve clicked somewhere in the document window, but haven’t selected anything, the copy is centered around the place you last clicked.

□ If an object is selected and visible in the window, the copy is placed on top of the selected object, or slightly below and to the right, if the objects are the same size.

□ If you’ve selected more than one object, the copy is centered within the boundary of all the previously selected objects.

Notice that Paste doesn’t replace the selected objects, as it does when you’re editing text. Objects are pasted in front of all other objects in the document. See “Paste in Front and Paste in Back” on page 97.

MacDraw does not accept “bitmapped” images. This includes any image created with MacPaint. If you try to paste a bitmap from the Clipboard or Scrapbook, nothing will be pasted.

**Pasting Text**

If you’ve selected text with the text tool, and the Clipboard contains text, then Paste replaces the selected text with the text on the Clipboard. The pasted text is in the font and style of the caption or paragraph you’re pasting into.

If you want to paste text as a new object, select an object or click where you want to paste. You can paste text from other applications via the Scrapbook and Clipboard. However, you’ll lose any formatting and style options. Once you’ve pasted text into MacDraw, you can edit and change its characteristics like any MacDraw text. Text pasted into MacDraw is always paragraph text in the preset font, plain style, left-aligned, and single spaced.
You can determine the width of text before you paste it. Select text with the text pointer. Copy the text to the Clipboard and choose Show Clipboard from the Edit menu. Drag the Clipboard's size box to the width you want the text to be. MacDraw rearranges the text to fill the new width. Choose Paste, and the text appears in the new width.

Clear
This command removes the selected objects or text without affecting the Clipboard. It's the same as pressing the Backspace key on the keyboard. This command is useful to eliminate objects when you are almost out of memory.

Duplicate
This command duplicates the selection, placing the copy slightly below and to the right of the original in the document. The copy is selected; you can immediately drag it to another location or duplicate it again. The copy is placed in front of all other objects in the document.
If you duplicate an object and immediately drag the copy to a new position, MacDraw will remember the distance you dragged it. If you duplicate again immediately, MacDraw places the next copy the same distance away from the first copy as the first copy is from the original.

Select All
This command selects all of the objects in the document. Choosing Select All and then Clear from the Edit menu removes all unlocked objects from a document.

Reshape Polygon/Reshape Arc
This command lets you reshape a polygon or extend or shorten the angle of an arc. By choosing Show Size from the Layout menu, you can see how the angle of the arc changes as you reshape. You can also reshape a smoothed polygon or a freehand shape made into a polygon with Smooth or Unsmooth. Reshape is dimmed unless you've selected a single arc or polygon.

Choosing Reshape changes the way in which the arc or polygon is selected. Instead of showing the usual eight handles on the boundary, an arc shows one handle at each endpoint, and a polygon shows one handle at each vertex. You can drag these handles individually to reshape the arc or polygon, but you can't resize or move an object while you're reshaping it. As you reshape, the fill pattern disappears. Selecting any other object or tool, or clicking elsewhere removes the reshaping handles and brings back the fill pattern.
**Smooth and Unsmooth**

The Smooth command rounds the angles of a polygon; the Unsmooth command changes a smoothed polygon back to its angular form and makes a freehand shape angular. These commands can’t be chosen unless the selection contains at least one freehand shape or polygon.

The Smooth command first turns a freehand shape into a polygon that approximates the shape you drew and then smooths that polygon by rounding the angles. The Unsmooth command takes a freehand shape (smoothed or not) and changes it to the polygon that approximates it. You can’t change a smoothed or unsmoothed freehand shape back to its original form.

**Round Corners**

This command lets you specify how rounded the corners of a rectangle are. You can’t choose it unless the selection contains at least one rectangle or round-corner rectangle. The dialog box presented by Round Corners gives you six choices of rounding, expressed in inches or millimeters.

```
Round Corners Radius:
  ○ 0"  ○ 1/8"  ○ 3/16"  ○ 1/4"  ○ 5/16"  ○ 3/8"
  [OK]  [Cancel]
```

Each corner of a rounded rectangle is a quarter circle. The rounding numbers in the dialog box define the radius of the circle that the corners are quarters of. A rounding of 0 gives square corners; choosing 1/4 inch gives rounding that starts 1/4 inch from the edges of the rectangle. Rectangles that are smaller than the rounding radius appear circular.

The commands in the Style menu set the style, alignment, line spacing, and case of text in a caption or paragraph.

Most commands in the Style menu always apply to all text in the caption or paragraph you’ve selected, even if you select a smaller range with the text tool. Only the case commands—Lowercase, Uppercase, and Title—act on selections made with the text tool.
Text Styles
You can choose either Plain Text or any of five text styles: bold, italic, underline, outline, or shadow, or any combination of the five. Choosing a style sets the text in that style and checks that choice in the menu; choosing a checked style removes that style from the text and unchecks that choice in the menu. If you’ve selected more than one caption or paragraph of text, the commands have their usual effect, but nothing in the menu is checked.

The preset style for newly typed text is Plain Text. To change styles before you type, first select the text tool for caption text, or select an object for paragraph text. Then choose the styles you want, one by one, from the Style menu.

Alignment
The Left, Right, and Center commands control how text is aligned inside a paragraph or caption. The preset choice is left aligned.

Spacing
The Single Space, 1½ Space, and Double Space commands control how text is vertically spaced within a paragraph or caption. The amount of space between lines varies with the font size. The preset option is single space.

Case Commands
The Lowercase, Uppercase, and Title commands change the case of text selected with the text tool or of all the text in a selected caption or paragraph. The Lowercase command changes all letters to lowercase; the Uppercase command changes all letters to uppercase. The Title command capitalizes the first letter of every word in the paragraph or caption. The case commands do not affect numbers, symbols, and accented characters.

The commands in the Font menu set the font and font size of all text in a selected caption or paragraph, even if you select a smaller range with the text tool. See “Changing Text Characteristics” on page 48 for instructions on changing the font or size of text.

Fonts
The MacDraw disk comes with seven fonts. The preset font is Chicago, 12 point, or the first font installed with Font Mover. To change the font or size before you type, first select the text tool for caption text, or select an object for paragraph text. Then choose the font or size you want from the Font menu. Text you paste into MacDraw that was created in any other application will be pasted in MacDraw’s current font and size.
You can use the Font Mover application on your Macintosh System disk to add or remove fonts. MacDraw lists only the first ten fonts you’ve installed on your MacDraw disk with the Font Mover. For more information on the Font Mover, see *Macintosh*, your owner’s guide, or your Apple dealer.

**Sizes**
MacDraw can display text in eight sizes, from 9 point to 48 point. The sizes that look best in the current font are outlined in the menu.

The Layout menu contains commands for working with large documents and creating precise drawings. These commands affect an entire document.

**Show Rulers/Hide Rulers**
These commands control the rulers along the top and left edges of the window. To display the rulers, choose Show Rulers.

When rulers are showing, thin dotted lines in the rulers follow the pointer as you move it in the document. By watching these lines, you can draw and move objects more precisely.

The standard inch ruler measures in inches, with divisions down to 1/8 inch. The standard centimeter ruler is ruled with divisions every two millimeters.

**Custom Rulers**
This command lets you customize the rulers. The measurements and spacing on the standard inch and centimeter rulers are sufficient for most kinds of documents. If you need special numbering or spacing, you can use the Custom Rulers command to change the ruler’s options. You also use Custom Rulers to change the spacing of the alignment grid. See “Using Rulers” on page 52 and “Drawing to Scale” on page 54 for some of the ways in which Custom Rulers can be useful.

When you choose Custom Rulers, MacDraw presents a dialog box with several options.
The On and Off options have the same effect as Show Rulers and Hide Rulers. They're here for your convenience, so you can see the rulers immediately after you change the options.

The Inch and Centimeter options let you choose between inch and metric measurements. All measurements in the document—on the rulers and with Show Size, Drawing Size, and Round Corners—will be displayed in the measurement system you set here. Switching between Inch and Centimeter changes the alignment grid; new objects you create after a change will be aligned to a different alignment grid. Use Align to Grid from the Arrange menu to place objects on the new alignment grid.

When you click Custom, more options appear:
The Major Division Spacing option controls how far apart the major divisions are. The major divisions on the ruler are numbered and marked by solid tick marks that extend beyond the ruler and become dotted ruler lines in the document. You can specify major divisions every $\frac{1}{2}$, 1, 1-1/2, or 2 inches. If you’re using centimeter rulers, you can specify major divisions every .5, 1, 1.5, or 2 centimeters.

The Number of Minor Divisions option controls how many tick marks are on the ruler between major divisions and sets the spacing for the alignment grid and ruler lines. You can divide each major division into as many as 32 minor divisions. These subdivisions form the alignment grid to which all objects are aligned. MacDraw shows as many of the minor divisions as it can, with tick marks in the ruler and dotted ruler lines in the document.

The Numbering Increments option is helpful for making scale drawings. Changing the increment changes only the numbering on the rulers, not the spacing of major or minor divisions. This option lets you create scale drawings in which one unit in the drawing equals a larger distance in real life. When you set the numbering increment to the scale of your drawing, the rulers and Show Size measure in real-life units. See “Drawing to Scale” on page 54.

The Zero Point option lets you specify whether the intersection of the rulers is fixed or movable. When the zero point is unlocked, clicking in a ruler moves the zero marking from its previous position (preset to the top left corner of the document) to the place where you clicked. For instructions on changing the zero point, see “Using Rulers” on page 52.

When the zero point is locked, it remains where you last set it and can’t be changed until you unlock it again.

**Normal Size**

This command sets the viewing scale of the document to its actual size: objects on the screen appear approximately the same size as they will when printed on paper.

When the document is normal size, the Enlarge command is dimmed, and the Normal Size command is checked. When you choose Normal Size, selected objects are centered in the window; if nothing is selected, the center of the document is displayed.
**Reduce to Fit**
This command reduces the viewing scale so that the entire document (as defined with the Drawing Size command from the Layout menu) fits in the current document window. You can do all normal drawing and editing while the document is reduced, although close work such as selecting text to edit becomes more difficult.

If you change the size of the window by dragging its size box, the drawing is reduced or enlarged to fit the new window size. The drawing always remains proportionally correct regardless of the dimensions of the window.

Rulers, ruler lines, and page breaks appear in the reduced view only if MacDraw can place them far enough apart to show clearly; otherwise, it omits them.

**Reduce**
This command reduces the viewing scale of your document by half, so you can see more of it in the window. You can do all normal drawing and editing while the document is reduced, although close work can become more difficult.
Choosing Reduce repeatedly lets you see more and more of the document. When reducing, MacDraw tries to keep the center of any selected objects centered in the window. Reducing the document until it fits entirely inside the window is the same as choosing Reduce to Fit.

Rulers, ruler lines, and page breaks appear in the reduced view only if MacDraw can place them far enough apart to show clearly; otherwise, they're omitted.

**Enlarge**
This command doubles the viewing scale of a previously reduced document, so objects appear larger and you see less of the document.

You can choose Enlarge repeatedly to see more and more of the document. When enlarging, MacDraw tries to keep the center of any selected objects centered in the window. Enlarging the document to its normal size is the same as choosing Normal Size.

**Turn Grid On/Turn Grid Off**
These commands control the invisible alignment grid that allows you to align objects precisely. The alignment grid is preset to On, so that objects you draw and move are constrained to the alignment grid’s spacing. Choosing Turn Grid Off removes the alignment grid’s constraints and lets you draw or move objects more freely. Choosing Turn Grid On restores the alignment grid’s constraints, so that new objects you draw and any objects you move are constrained to the alignment grid’s spacing.

The alignment grid’s spacing is controlled by the minor divisions on the ruler, whether or not rulers or ruler lines are visible. Use the Custom Rulers command to change the minor division spacing. If you change the alignment grid spacing, you can use the Align to Grid command in the Arrange menu to align objects to the new alignment grid. Otherwise the objects will remain off the alignment grid. Changing from inch to centimeter rulers changes the alignment grid’s spacing even though you may not have purposely chosen a different minor division spacing.

**Hide Ruler Lines/Show Ruler Lines**
These commands control the appearance of ruler lines, the dotted lines running vertically and horizontally across the document. In a new document, the ruler lines are showing. Choosing Hide Ruler Lines removes the ruler lines, and choosing Show Ruler Lines displays them again. Ruler lines never appear on the printed copies of the document.
With ruler lines showing, MacDraw tries to draw one ruler line for every minor division on the ruler. But to avoid cluttering the screen, MacDraw won’t place ruler lines closer than ¼ inch or 1 centimeter apart. If your minor divisions are closer than that, or if you’ve reduced your drawing, you may not see all (or any) ruler lines.

Ruler lines show regardless of whether the alignment grid is on or off. You control the alignment grid separately with the Turn Grid On/Turn Grid Off command.

**Show Size/Hide Size**
The Show Size command gives you the ability to measure sizes and distances in your document.

When the Show Size option is on, MacDraw displays a size, distance, or angle each time you draw a new object, draw a selection box, or press and hold the mouse button in a selected object. The measurement appears next to the pointer as a number or pair of numbers, in the measurement system you’ve chosen for the rulers. The meaning of the numbers depends on the action:

- When you draw or select any object except perpendicular or diagonal lines, the numbers indicate the height and width of the object’s boundary.
- When you draw, select, or resize a perpendicular or diagonal line, the number indicates the length of the line.
- When you draw a selection box, the numbers change dynamically to indicate the height and width of the selection box as you drag.
- When you select or resize a group of objects, the numbers indicate the total height and width of the boundary of the selection or group.
- As you’re drawing a polygon, the number shows the height and width of each line of the polygon as you draw it.
- When you resize objects, the numbers indicate the new height and width of the boundary.
- When you select an arc and choose Reshape from the Edit menu, pressing either reshaping handle shows the begin or end angle of the arc in degrees.

**Hide Page Breaks/Show Page Breaks**
These commands control the appearance of page breaks, marked by heavy striped lines in documents larger than one page (see “Drawing Size”). The page breaks are preset to be visible.
**Drawing Size**

This command lets you change the size of a document from the preset 8 by 10 inches to as large as 96 by 48 inches. Large drawings are printed in strips of pages, which you can tape together to form the whole drawing. When you choose Drawing Size, a dialog box appears with a matrix of pages showing the current and possible drawing sizes. The dimension and orientation of the pages reflect the options chosen in Page Setup from the File menu.

![Drawing Size dialog box]

The black squares represent the current drawing size. Click any square in the matrix to expand or reduce the drawing size. When you’re satisfied with the new drawing size, click the OK button; or click the Cancel button to leave the drawing size unchanged.

You can’t reduce the drawing size if the reduction would omit pages with objects on them. You must move or remove the objects on those pages before you can make the drawing smaller.

**Arrange Menu**

With the commands in the Arrange menu, you can control the arrangement of objects in the document and how they relate to each other. Commands in this menu affect only selected objects in the active document.

**Bring to Front and Send to Back**

These commands move selected objects in front of or behind all other objects in the document. Objects in front may overlap objects behind them.

If you bring a grouped selection to the front or send it to the back, the objects in that selection retain their stacking order in relation to each other.
**Paste in Front and Paste in Back**
These commands work like the Paste command (see page 85), but they allow you to change the stacking order of objects by pasting the Clipboard’s contents in front of or behind selected objects. If nothing’s selected, the Clipboard’s contents are pasted in front of (or behind) all objects in the document.

**Rotate Left and Rotate Right**
These commands rotate the selection clockwise (right) or counterclockwise (left) 90 degrees around the center of the selection. You can’t use the text tool to edit rotated text.

**Flip Horizontal and Flip Vertical**
These commands flip the selection horizontally or vertically around its center, making a “mirror image.” Flip Horizontal flips the image from one side to the other. Flip Vertical turns the image upside down and backward. You can’t use the text tool to edit flipped text.

**Group and Ungroup**
Group creates a single object composed of all the selected objects. It’s a convenience for creating one object out of many, allowing you to manipulate one complex object as a whole. It’s also useful for keeping related objects together—such as a picture and its caption. You can also group previously grouped objects.

Ungroup divides a grouped object into individual objects or groups. If a grouped object is formed of other grouped objects, ungrouping the larger object leaves the smaller groups intact. After ungrouping, the objects that comprise the group remain selected and retain their stacking order.

A grouped object acts in every way like several individually selected objects except that the handles appear on the boundary of the group, rather than on the individual objects. All the commands that work on individual objects will work identically on a grouped object.

The objects that comprise a group retain their stacking order when grouped, but the entire grouped object is brought in front of all other objects in the document. Any locked objects in the group are unlocked.

You cannot select text with the text tool after you’ve grouped a caption or paragraph; you’ll have to ungroup, edit the text, and group again.
Be sure to set the fill and pen patterns and line widths of individual objects before you group. Otherwise you'll need to ungroup before you can change an individual object within a group. Choosing a different fill pattern, line width, or pen pattern with a selected group will change those characteristics for all objects in the group.

**Lock and Unlock**
The Lock command lets you “anchor” an object in place so it can't be moved accidentally. When a selected object is locked, you can select it, copy it to the Clipboard, or group it. But you can't move, cut, clear, duplicate, rotate, or flip it; change its size, appearance, or stacking order; or align it to the alignment grid.

If you lock a caption or paragraph, you can still edit it, but you can't resize or move it or change its font or styles.

You can't reshape, smooth, or unsmooth polygons, freehand shapes, and arcs when they're locked. Grouping locked objects automatically unlocks them.

**Align to Grid**
This command moves and may resize selected objects to align to the current alignment grid. If you've changed the Number of Minor Divisions setting in the Custom Ruler command, moved or drawn objects on a different alignment grid, or moved or drawn objects while the alignment grid was turned off, you can use Align to Grid to make existing objects line up with those you'll draw on the new alignment grid.

Align to Grid adjusts objects so their boundaries fall on the current alignment grid. It affects only objects that were drawn or moved on a different alignment grid or with the alignment grid off. Align to Grid is dimmed if you've chosen Turn Grid Off.

Align to Grid affects different objects in different ways:

- The boundaries of rectangles and ovals align to the nearest grid points.
- Text aligns midway between the alignment grid's points.
- The top left corner of the boundaries of grouped objects and freehand shapes align to the grid.
- Each vertex of a polygon aligns to the nearest grid point.
Align Objects
This command aligns selected objects with each other—vertically or horizontally along the tops, bottoms, sides, or centers. You must select more than one object before you can choose Align Objects.

When you choose Align Objects, a dialog box appears, giving you two sets of three ways to align the objects.

Align Objects:
- Left Sides
- L/R Centers
- Right Sides
- Tops
- T/B Centers
- Bottoms

Align Objects moves the selected objects so that their boundaries line up the way you specify. MacDraw finds the boundary that encloses all the selected objects and aligns all the objects within that boundary:

- If you click Left Sides or Right Sides, the objects move so their boundaries line up with the leftmost or rightmost object.
- If you click L/R Centers (horizontal centers), the objects move until they are centered on the midpoint between their top and bottom boundaries.
- If you click Tops or Bottoms, the objects move so their top or bottom boundaries line up with the highest or lowest object.
- If you click T/B Centers (vertical centers), the objects move until they are centered around the midpoint between their right and left boundaries.

You can align both vertically and horizontally at the same time, but the objects will then clump together and overlap.

Note that Align Objects aligns the boundaries of the objects, not the actual edges of the objects' borders. Since objects with wide borders actually extend slightly outside their boundaries, objects with different border widths won't align in the way you might expect. If you want to align objects that have different border widths, turn the alignment grid off before drawing or moving the object with the wider border.
This menu offers 36 patterns to fill rectangles, round-corner rectangles, ovals, arcs, freehand shapes, polygons, and the background of captions and paragraphs. The special pattern called "None" makes an object into a frame, allowing objects behind it to show through.

Choosing a pattern from the Fill menu fills the selected objects with that pattern. You can see the current fill pattern, the pattern any new rectangle or oval will be filled with, in the line/pattern box at the bottom left corner of the window. To change the current fill pattern, select a drawing tool in the palette and choose a new pattern from the Fill menu.

You cannot edit or customize patterns. You can't fill a shape composed of individual lines. The preset pattern is white for rectangles and ovals. Arcs, freehand shapes, and polygons are always created with None. To change line patterns and borders, see "Pen Menu."

This menu changes the appearance of lines and the appearance of the borders of all objects except text. You can change the line or border width, and you can put arrowheads on lines (on either one end or both ends). To change the pattern for lines or borders, see "Pen Menu."

Choosing a line from the Lines menu changes selected perpendicular or diagonal lines or the border of selected objects to that line width. You can see the current line width (although you can't see whether it has arrowheads or not) in the line/pattern box at the bottom left corner of the window.
This menu offers 36 patterns for lines and borders. It operates on all objects except text.

Choosing a line pattern from the Pen menu changes the selected objects to that line or border pattern. You can see the current line pattern in the line/pattern box at the bottom left corner of the window.

You’ll notice that there are two ways to draw unbordered objects—either by choosing no border in the Lines menu, or by making the pen pattern match the fill pattern. Which method you use depends on whether the object you want to align is bordered or not.

- To align an unbordered object with another unbordered object, use no border from the Lines menu.
- To align an unbordered object with a bordered object, use the bordered object’s border width and choose the unbordered object’s fill pattern as the pen pattern.
**Appendix A:**
**Preset Options and Specifications**

<table>
<thead>
<tr>
<th>Option</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Window Size</td>
<td>$6\frac{7}{8}$ by $3\frac{7}{8}$ inches</td>
</tr>
<tr>
<td>Reduction</td>
<td>Normal Size</td>
</tr>
<tr>
<td>Ruler</td>
<td>Standard inch, 1-inch increments, 1-inch major divisions, $\frac{1}{8}$-inch minor divisions, not showing</td>
</tr>
<tr>
<td>Ruler Lines</td>
<td>Visible</td>
</tr>
<tr>
<td>Page Breaks</td>
<td>Visible</td>
</tr>
<tr>
<td>Zero Point</td>
<td>Top left corner, locked</td>
</tr>
<tr>
<td>Alignment Grid</td>
<td>On, $\frac{1}{8}$-inch spacing</td>
</tr>
<tr>
<td>Drawing Size</td>
<td>8 by 10 inches, one page</td>
</tr>
<tr>
<td>Print</td>
<td>Standard, All pages, one copy, Continuous</td>
</tr>
<tr>
<td>Page Setup</td>
<td>US Letter, Tall</td>
</tr>
<tr>
<td>Style</td>
<td>Plain Text, Left adjusted, Single Space</td>
</tr>
<tr>
<td>Font</td>
<td>Chicago, 12 point</td>
</tr>
<tr>
<td>Show Size</td>
<td>Off</td>
</tr>
<tr>
<td>Round Corners</td>
<td>$\frac{1}{4}$-inch radius</td>
</tr>
<tr>
<td>Fill Pattern</td>
<td>White</td>
</tr>
<tr>
<td>Lines</td>
<td>1 pixel wide, no arrowheads</td>
</tr>
<tr>
<td>Pen</td>
<td>Black</td>
</tr>
<tr>
<td>Maximum Drawing Size</td>
<td>96 by 48 inches</td>
</tr>
<tr>
<td>Maximum Number of Fonts</td>
<td>10</td>
</tr>
<tr>
<td>Object Type</td>
<td>Memory Usage</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-------------------------------------------</td>
</tr>
<tr>
<td>Lines, Rectangles, and Ovals</td>
<td>46 bytes per object</td>
</tr>
<tr>
<td>Text</td>
<td>62 bytes per caption or paragraph</td>
</tr>
<tr>
<td></td>
<td>plus 1 byte per character</td>
</tr>
<tr>
<td>Arcs</td>
<td>50 bytes per object</td>
</tr>
<tr>
<td>Freehand Shapes</td>
<td>46 bytes plus 2 bytes for each</td>
</tr>
<tr>
<td></td>
<td>1/8 inch of length</td>
</tr>
<tr>
<td>Polygons</td>
<td>46 bytes plus 8 bytes for each vertex</td>
</tr>
<tr>
<td>Grouped Objects</td>
<td>62 bytes plus the total of all objects in</td>
</tr>
<tr>
<td></td>
<td>the group</td>
</tr>
</tbody>
</table>
activate
To bring a window to the front by clicking in it. Also, to choose the selection pointer from the palette.

active window
The frontmost window on the desktop, where the next action will take place. The active window's title bar is highlighted.

alignment grid
An invisible drawing and moving aid. When the alignment grid is turned on, all objects drawn or moved are constrained to its spacing.

arc tool
A tool in MacDraw's palette used to draw 90-degree arcs.

Backspace key
A key on the Macintosh keyboard that moves the insertion point backward, removes a selection, or removes characters at the insertion point.

border
The outline of an object, usually drawn in a different pattern.

boundary
An invisible rectangle that encloses an object and is used to align objects.

caption text
Text created with the text tool. Caption text is usually one line.

choose
To pick a command from a menu by dragging.

circle tool
A tool in MacDraw's palette used to draw circles and ovals.

clear
To remove something permanently by selecting it and choosing Clear from the Edit menu.

click
To position the pointer on something and then press and quickly release the mouse button.

Clipboard
A holding place for the last object(s) you cut or copied.

close box
A small box on the left side of the title bar of an active window. You click it to close the window.
command
A word, usually in a menu, that describes an action for MacDraw to perform. Also a combination of the Command key and a letter on the keyboard that accomplishes the same action.

Command key
A key on the Macintosh keyboard. You can choose a command from a menu by holding down the Command key and typing another key.

constrain
To limit an object to a certain shape, direction, or angle while drawing it.

copy
To place something on the Clipboard by selecting it and choosing Copy from the Edit menu.

custom rulers
Rulers you tailor to your own specifications with the Custom Rulers command in the Layout menu.

cut
To remove something by selecting it and choosing Cut from the Edit menu. The object that is cut is placed on the Clipboard.

desktop
MacDraw's working environment—the menu bar and the gray area on the screen.

diagonal lines tool
A tool in MacDraw's palette used to draw a straight line between two points.

dialog box
A box that requests more information from you to allow MacDraw to complete a command.

document
A MacDraw document comprises text, objects, and information about objects.

document window
A window that displays a MacDraw document. A MacDraw document window includes scroll bars, a palette of drawing tools, a line/pattern box, and a size box.

double-click
To position the pointer and then press and release the mouse button twice in rapid succession without moving the mouse.
**drag**
To position the pointer on something, press and hold the mouse button, move the mouse, and release the mouse button.

**drawing size**
The number of pages that make up a document. You change the drawing size by choosing Drawing Size from the Layout menu.

**drawing tool**
A symbol in MacDraw’s palette. Selecting a drawing tool allows you to draw an object of that shape.

**duplicate**
To make a copy of selected objects by choosing Duplicate from the Edit menu.

**enlarge**
To double the viewing scale of a reduced document so objects appear larger.

**Enter key**
A key on the Macintosh keyboard that you press to confirm a text entry or command.

**fill pattern**
One of 36 patterns that shades the interior of an object. Fill patterns are represented in the Fill menu.

**Finder**
The “hub” of the Macintosh system. The Finder lets you manage your documents and change applications.

**flip**
To turn a selected object upside down or sideways to its mirror image.

**font**
A collection of letters, numbers, punctuation marks, and other typographical symbols with a consistent look.

**Font Mover**
An application that allows you to add to or remove fonts from a disk.

**freehand shape tool**
A tool in MacDraw’s palette used to draw freeform lines and shapes.

**group**
To combine two or more objects so that they act as one object. You can manipulate groups just as you do individual objects.
Guided Tour
The cassette tape and special disk that accompany MacDraw. Play the cassette along with the disk to learn about MacDraw.

handle
Small black squares that appear on the boundary of a selected object. Dragging a handle resizes the object.

insertion point
The spot in a caption or paragraph where text will be added or pasted. The insertion point is selected by clicking with the text pointer and is represented by a blinking vertical bar.

Key Caps
A desk accessory that shows you the optional character set.

line/pattern box
The box at the lower left corner of a MacDraw document window that displays the current line width and pen pattern on the left, and the current fill pattern on the right.

lock
To anchor a selected object in place by choosing Lock from the Arrange menu. You can’t move, remove, or resize a locked object.

memory
The place in the Macintosh main unit that stores information the Macintosh is working with.

None
A transparent pattern. Filling an object with None turns it into a frame.

normal size
A view of a MacDraw document in which objects appear the same size as they will when printed out.

object
The basic unit of MacDraw. An object can be a geometric shape or text.

Option key
A key on the Macintosh keyboard used like the Shift key to give an alternate interpretation to the key you’ve typed. You use it to type foreign characters or special symbols contained in the optional character set.

page break
Thick, striped lines in a MacDraw document that indicate the edges of individual pages.
page orientation
The way in which a document is printed, either upright or sideways on the page. MacDraw displays pages upright or sideways, depending on the orientation you choose.

page size
The measurements of a MacDraw page as defined in Page Setup from the File menu.

palette
A column of symbols on the left side of a MacDraw document symbol. You use the palette to draw, add text, and edit different objects in a document.

paragraph text
Text created in MacDraw that takes advantage of word wraparound.

paste
To put something back into a document that you cut or copied to the Clipboard. In MacDraw, you can paste objects in front of or behind other objects.

pen pattern
One of 36 patterns that shades lines or borders of objects. Pen patterns are represented in the Pen menu.

perpendicular lines tool
A tool in MacDraw's palette used to draw horizontal or vertical lines.

pointer
A small shape on the screen that follows the movement of the mouse.

polygon tool
A tool in MacDraw's palette used to draw polygons and open-ended objects.

press
To position the pointer on something and then push down and hold the mouse button without moving the mouse.

rectangle tool
A tool in MacDraw's palette used to draw rectangles and squares.

reduce
To see more of a MacDraw document by making it appear smaller in the document window.

reduce to fit
To make a MacDraw document small enough to fit inside the document window so you can see it in its entirety.
**reshape**
To change the shape of a polygon by dragging a reshaping handle located at each vertex or to change the angle of an arc by dragging a reshaping handle.

**resize**
To stretch, shrink, or change the proportions of an object by dragging one of its handles.

**Return key**
A key on the Macintosh keyboard that causes the insertion point to move to the beginning of the next line. It's also used in some cases to confirm a command or an entry.

**rotate**
To turn an object one quarter turn right or left.

**round-corner rectangle tool**
A tool in MacDraw's palette used to draw rectangles and squares with rounded corners.

**ruler**
Graphic representations of rulers across the top and down the left side of a MacDraw document. Rulers allow you to draw and measure precisely.

**ruler lines**
Dotted lines in the document window that are extensions of MacDraw's ruler divisions.

**save**
To store information on a disk.

**Scrapbook**
A desk accessory in which you can store frequently used pictures or text.

**scroll**
To move a document in its window so that a different part of it is visible.

**select**
To designate where the next action will take place. In MacDraw, you use the mouse techniques of clicking and dragging to select something.

**selection box**
A box drawn with the selection pointer. All objects enclosed by the box are selected.

**selection pointer**
An arrow-shaped pointer in MacDraw used for selecting and moving.
**size box**  
A box in the lower right corner of a window. Dragging the size box resizes the window.

**smooth**  
To round the corners of a polygon.

**stacking order**  
The order in which MacDraw objects overlap from front to back in a document.

**standard ruler**  
The preset rulers provided in a MacDraw document.

**style**  
A stylistic variation of a font. MacDraw provides six font styles: plain text, bold, italic, underline, outline, and shadow.

**text pointer**  
The pointer used to type caption text and to edit existing text.

**text tool**  
A tool in MacDraw's palette used to create caption text or edit existing text.

**tick mark**  
Lines on MacDraw's rulers that indicate subdivisions.

**ungroup**  
To separate a grouped object into the individual objects or groups that originally comprised it.

**unsmooth**  
To change a previously smoothed polygon back to its original shape.

**word wraparound**  
A feature of MacDraw for formatting text. As you reach the right margin of paragraph text, MacDraw moves the last whole word you've typed and the insertion point to the beginning of the next line.

**vertex**  
A corner or point of a polygon.

**viewing scale**  
The size of a MacDraw document on the screen as you're working with it. Commands from the Layout menu allow you to change the viewing scale.

**zero point**  
The place where MacDraw's rulers intersect.
Index

A
About MacDraw command 78, 79
activating
document 57
selection pointer 42, 70
adding
fonts 90
text 21-22
Align Objects command 50, 76, 99
Align to Grid command 78, 91, 94, 98
aligning
objects 50, 99
text 42, 48, 75, 89
alignment grid 49, 50, 52, 54, 76, 77, 98
boundaries 76
changing 78, 90, 91
preset 94, 104
turning off 78
Apple menu 79-80
application(s)
copying between 64, 85
quitting 23, 58, 84
arc 11, 30, 71, 72 See also object(s)
border 72
changing 87
constraining 72
drawing 31, 72
fill pattern 31, 72
locking 98
measuring 51
memory usage 105
resizing 72
arc tool 30, 31
Arrange menu 13, 96-99
arrowheads 34, 71, 100

B
Backspace key 21, 37, 46, 86
backup copy See saving
bitmapped images 85
blinking vertical bar See insertion point
bold text style 89
border 18, 76 See also Lines menu; Pen menu
changing 34, 100, 101
patterns 34, 70, 71, 101
preset 71
width 12, 34, 70, 71
boundary 13, 32, 75, 77
in aligning objects 99
in aligning to grid 98
measuring 51
object 76
text 15, 41, 47, 75
box, close 10, 79, 81
box, dialog See dialog box
box, line/pattern 29, 35, 71, 100, 101
box, selection 12, 32, 51
box, size 10, 86
Bring to Front command 40, 96
business card, designing 17-23

C
Calculator 80, 85
Cancel button 82
caption 14, 41, 70, 74
background pattern 34, 42, 48
creating 14, 42, 75
editing 46-48
font 48, 89
locking 98
measuring 51
memory usage 105
moving 45, 75
pasting into 47
removing 46
selecting 44
style 48, 88
Center text alignment command 89
Centimeter, Custom Rulers 91 See also metric measurements
changing
alignment grid 90, 91
alignment, text 48
background pattern, text 34, 48
borders 100, 101
document size 61
drawing size 96
font 48, 89
line pattern 34
line width 34
lines 100, 101
objects 12, 34-35, 71
page orientation 61
page setup 61
page size 61
rulers 16, 52, 90
spacing, text 48
stacking order 13, 14, 40, 96
style 48
text 44, 46-47, 48, 49
window size 10, 93
zero point 53
characters, foreign and special 80
circle(s) 11, 71
grouping 19-20
circle tool 19
Clear command 37, 46, 86, 87
clicking, double 44
clicking, triple 44
Clipboard 37, 40, 81, 84, 85, 86
and memory 60, 78
close box 10, 79, 81
Close command 79, 81
closing
desk accessory 79
document 81
window 81
Command key 63, 70, 79
commands 12 See also specific commands
keyboard 63, 70, 79
text only 41
Computer Paper, Page Setup command 82
Copies, Print command 83
Copy command 60, 64, 80, 84
copying 32
between applications 64, 85
between documents 60
objects 38, 64, 84
to Scrapbook 64, 85
Scrapbook to another disk 65
text 64, 84
corner radius, round-corner rectangle 88
creating
document 57
objects 12, 70
stationery 55
text 14, 42, 43, 75
cusps 73-74
Custom Rulers command 16, 52, 53, 54, 77, 90-92, 94
Cut command 37, 45, 46, 60, 80, 84
D
default options 104
alignment 89
document drawing size 11, 61, 96
fill pattern 100, 101
font 89
page size 11, 61
rulers 16, 90
spacing 89
style 89
deleting See Backspace key; Clear command
desk accessories 79-80, 81
desktop 10, 56
diagonal lines 30, 51, 71
diagonal lines tool 30
dialog box 57
Align Objects command 99
Custom Rulers command 53, 90
Drawing Size command 61, 96
Open command 57
Page Setup command 82
Print command 63
Round Corners command 88
Save As 58, 81
disk
fonts on 89, 90
full 58
Macintosh System 90
opening on another 57, 80
printing resource on 62
saving to another 58
tutorial 3
disk drive, external 57, 58, 80
document(s) 10
  activating 57
closing 81
copying between 60
creating 57, 78
moving between 60
moving in 59
naming 58
opening existing 57, 78
opening multiple 56, 57
opening new 17, 57
printing 62-63
reducing 93-94
reverting 82
saving 22, 58, 81
size 10, 52, 61, 78
template 49, 55
document window 10, 93
double-clicking 17, 44
Double Space command 89
drawing 12
  arc 30, 31, 72
circle 19, 71
freehand shape 30, 31
lines See lines
objects 29-31, 71-74
oval 29, 71
polygon 30, 73-74
rectangle 29, 71
round-corner rectangle 29, 71
scale 54
square 71
drawing lines See lines
Drawing Size command 54, 61, 82, 91, 96
drawing tools See palette
Drive button 57, 58, 80
Duplicate command 20, 38, 86-87
duplicating 20, 32, 38, 86-87

F
Fat Bits 3
File menu 80
Fill menu 29, 41, 100
fill pattern 70, 71, 75, 87, 98, 100, 101
caption 42
changing current 34, 35
disappearing 87
None 30, 32, 34, 71, 72, 73, 100
objects 20, 70, 100, 101
paragraph 43
filled arc 71, 72
Finder
  returning to 84
  starting from 10, 57
Flip Horizontal command 97
Flip Vertical command 97
font 89
  changing 22, 35, 48
  changing current 35, 89
pasted text 47, 85, 86
preset 89
size 89, 90
Font menu 41, 75, 89-90
Font Mover 89, 90
freehand shape 11, 71, 73 See also object(s)
drawing 21, 30, 31
fill pattern 32, 73
grouping 73
locking 98
measuring 51
memory usage 73, 105
moving 36
smoothing and unsmoothing 73, 88
freehand shape tool 30, 31

G
grid, alignment 50, 54, 76, 77, 98
  boundaries 76
  changing 90, 91
  preset 80, 94
  turning off 78
Group command 19, 20, 39, 73, 97-98
grouping 20, 32, 39
locked objects 98
and memory usage 105
text 44
handles 13, 32, 75
heading See caption
Hide Clipboard command 81, 84
Hide Page Breaks command 95
Hide Ruler Lines command 77, 94-95
Hide Rulers command 52, 90
Hide Size command 51, 95

I
Imagewriter printer 62
Inch, Custom Rulers command 91
inserting
text 46
objects 75
objects in front or behind 75, 97
insertion point 42, 46, 47
italic text style 89

J

K
Key Caps 80, 85
Key, command 63, 70, 79

L
label See caption
Layout menu 90-96
Left text alignment command 89
line/pattern box 29, 35, 71, 100, 101
line spacing, paragraph 75, 89
line width, drawing 35, 100
lines 11
arrowhead 34, 71, 100
changing 100
diagonal 30, 71
fill pattern 10, 71, 101
horizontal 30, 71
measuring 51
memory usage 105
perpendicular 30, 71
vertical 30, 71
width 71, 100
Lines menu 29, 100
Lock command 98
locking objects 36, 37, 39, 98
Lowercase command 75, 88, 89

M
MacDraw Guided Tour 3
Macintosh owner's guide 3, 57, 62, 64, 90
Macintosh System disk 90
MacPaint images 3, 64, 85
MacWrite 64
Major Division Spacing, Custom Rulers command 52, 92
margins 61
measuring 51, 52, 53, 91, 95
memory 60, 79, 86, 105
and freehand shapes 73, 105
limits 78
menu(s) 10
Apple 79-80
Arrange 13, 40, 75, 96-99
Edit 75, 84-88
File 80-84
Fill 75
Font 75, 89-90
Layout 90-96
Lines 100
Pen 101
Style 75, 88-89
metric measurements 53
minor divisions 78
moving
between applications 64, 85
between documents 60
constraining 36
in document 59
objects 36, 37
Scrapbook to another disk 65
text 44, 45, 75
zero point 53

N
naming a document 58
New command 57, 80
new document 57
ninety-degree arc 30, 72
None pattern 30, 32, 34, 71, 72, 73, 100
Normal Size command 59, 92, 94
Note Pad 85
Number of Minor Divisions, Custom Rulers command 52, 54, 92, 98
Numbering Increments, Custom Rulers command 54, 92
object(s) 11, 28, 70
aligning 50, 99
border 18, 70, 71, 76, 100, 101
boundaries 76
changing 12, 34-35, 71
copying 38, 84
creating 12, 29
fill pattern 20, 70, 100, 101
grouping and ungrouping 39
inserting 75
locking 36, 37, 39, 98
measuring 51, 52-53, 91, 95
memory usage 78, 105
moving 36, 96
pasting 45, 75, 85
removing 37, 87
reshaping 72, 73, 87, 95
resizing 13, 35, 49, 51
selecting 12-13, 32-33
size 70
stacking order 13, 70, 75, 97
text See text
unlocking 98
1 1/2 Space command 89
Open button 57, 80
Open command 57, 80
open-ended shapes 30 See also polygon
opening
Clipboard 84
desk accessories 79
existing document 57
multiple documents 56, 57
new document 17, 80
Option key 73, 80
outline text style 34, 89
oval 11, 71 See also circle; circle tool
arcs of 72
drawing 29, 71
measuring 51
memory usage 105
overlapping objects 13-14, 40, 97 See also stacking order

page
orientation 61, 82
size 10, 61, 82
page breaks 61, 93, 94, 95
Page Range, Print command 83

Page Setup command 54, 61, 62, 82
page specifications 62
palette 10, 12, 28, 70
Paper Feed, Print command 63, 83
Paper, Print command 61
paper size 61, 82
paragraph 14, 15, 41, 74
background pattern 34, 43, 48
blank lines in 43
creating 43, 75
editing 46-48
font 48, 89
line spacing 75, 89
locking 98
measuring 51
memory usage 105
moving 45, 75
pasted text 85
pasting into 47
removing 46
resizing 47
selecting 44
style 48, 88
width 75
word wraparound 15, 42, 43, 46
Paste command 45, 47, 60, 64, 85
Paste in Back command 40, 75, 97
Paste in Front command 40, 75, 97
pasting
between applications 64, 85
objects 40, 75, 85, 97
into Scrapbook 64
text 47, 85-86
pattern 10
background, text 34, 48
border 34, 70, 71, 101
changing 12, 34, 35, 48
disappearing while reshaping 87
fill 29, 70, 71, 98, 100, 101
line/pattern box 29, 35, 71, 100, 101
lines 71, 101
None 30, 32, 34, 71, 72, 73, 100
pen 35, 71, 98, 101
preset 71, 100
Pen menu 29, 101
pen pattern 35, 98, 101
perpendicular lines 51, 71
perpendicular lines tool 30
PICT format 81
plain text style 89
pointer 12
selection 10, 12, 16, 32, 70
text 14, 42
polygon 11, 30, 71, 73-74 See also object(s)
  aligning to grid 98
  constraining 73
  with cusps 73-74
drawing 30
fill pattern 30
locking 98
measuring 51
memory usage 105
reshaping 73-74, 87
resizing 73
smoothing and unsmoothing 73, 88
vertex 73
polygon tool 30
preset options 104
  alignment 89
document drawing size 10, 61, 96
  fill pattern 100, 101
  font 89
  page size 10, 61
rulers 16, 90
spacing 89
style 89
Print command 23, 62, 63
Print One command 82
printer, Imagewriter 62
printing 23, 62-63
  margin size 61
  specifications 63, 82
stopping 63, 83

Q
quadrilaterals 30
Quality, Print command 63, 83
quarter oval 72 See also ninety-degree arc
Quit command 23, 58, 84

R
radius, corner 88
rectangle 11, 71, 88
drawing 18, 29, 71
  measuring 51
memory usage 105
resizing 71
round-corner 18, 35, 71, 88
rounding corners 35

rectangle tool 18
Reduce command 36, 45, 59, 93-94
Reduce to Fit command 36, 45, 59, 93
reduced view 32, 93-94
removing
  fonts 90
  objects 37, 87
text 46
replacing text 47
Reshape Arc command 51, 87
Reshape Polygon command 73-74, 87
reshaping 72, 73, 87, 95 See also Show Size command;
  Smooth command
resizing 32
  objects 13, 35, 49, 51
  paragraphs 47
Return key 14, 15, 42, 43
Revert command 82
Right text alignment command 89
Rotate Left command 97
Rotate Right command 97
rotating objects 32, 97
round-corner rectangle tool 18
Round Corners command 35, 71, 88, 91
ruler lines 52
rulers 16, 49, 77, 90-91, 94
custom 16, 77, 90
hiding 52, 90
major divisions 52
metric 16, 53, 91
minor divisions 52, 54, 78, 95
numbering increments 54
off 91
on 91
preset 16, 90
in reduced view 93, 94
scale drawing 54
showing 52, 90
standard 16, 90
tick marks 77, 78
using 52, 53
Ryan's Express 17
Index
unbordered objects 101
underline text style 89
Undo command 84
Ungroup command 39, 97, 98
Unlock command 37, 98
unlocking objects 37, 39, 98
unselecting 33
Unsmooth command 73, 87, 88
Uppercase command 75, 88, 89
vertex 73
viewing scale 32, 92, 93, 94
Wide, Page Setup command 61, 82
window
closing 10, 81
document 10, 28, 36, 59, 85, 92, 93
size 10
word wraparound 15, 42, 43, 46
zero point 52, 53
Zero Point, Custom Rulers command 92
This book's binding lets it lie flat while you're working with your Macintosh. When you're using the book, keep the wraparound end flap tucked inside the back cover. To make it easy to spot the title when the book's on a shelf, fold the flap inside the front cover and set the book on the shelf with the title visible.