Approaching Macintosh
A Guide to Learning Macintosh Software
Main entry under title:

Approaching Macintosh.

Includes index.

1. Macintosh (Computer) I. Tchao, Michael C.
QA76.8.M3A67 1986 004.165 85-28742
ISBN 0-201-16497-3

Macintosh is a trademark of McIntosh Laboratories, Inc. licensed to Apple Computer, Inc.

Copyright © 1986 by Addison-Wesley Publishing Company

All rights reserved. No part of this publication may be reproduced, stored in a retrieval system, or transmitted, in any form or by any means, electronic, mechanical, photocopying, recording, or otherwise, without the prior permission of the publisher. Printed in the United States of America. Published simultaneously in Canada.

CDEFGHIJ-AL-89876
Some computer books teach their readers about computers by explaining that information can be represented by a series of 0's and 1's. Other computer books teach about computers by teaching their readers how to speak strange languages like BASIC and PL/I. Still other books teach their readers about computers by introducing them to long, complicated names like complementary metal-oxide-semiconductor.

*Approaching Macintosh* is not like those books. *Approaching Macintosh* teaches its readers about computers by teaching them how to use one. If learning by doing is the way you like to learn, we're sure you'll enjoy using this book. *Approaching Macintosh* focuses on software for the Apple® Macintosh™, a computer that is fast becoming a fixture on many college campuses.

This book is the result of two years of class testing on such unsuspecting subjects as Stanford University undergraduates, graduates, faculty, and staff. Using their input, *Approaching Macintosh* was designed to be an effective teaching tool in both self-paced and classroom teaching situations.

The book is divided into sections, each of which treats a general type of microcomputer application, such as word processing, database management, and graphics. Each section begins with an overview of the basic terms and concepts you'll be covering in that section. These sections will help you understand what this type of software can do and how it's typically used.

Every section contains one or more modules—the individual exercises that teach you how to use a specific software package. Each module should take about 1 to 1-1/2 hours to complete, and both introductory and advanced modules are provided for many software packages.

*Approaching Macintosh* was designed so that you can choose to complete the modules that interest you in whatever order you wish. However, it is recommended that you complete the Introduction to Macintosh module first, and that you complete the introductory modules before you start the advanced ones.

Before you begin a module, be sure to read the paragraphs labeled The Task carefully. These paragraphs explain what you're about to do and why. At the end of each module, read the Review paragraph to make sure you haven't missed the high points.

At the end of each section are Gallery documents that provide examples of how a software package is used. These gallery ideas should serve as a springboard for your own experimentation. Exercises are also provided to test your recall of the most important procedures and concepts of that section.
The important thing to remember when using Approaching Macintosh is that the authors sincerely want you have fun while you're learning. We've worked long, hard hours (and some legal holidays) to choose examples that will make you smile. Try not to disappoint us.

Michael Tchao
Bill Berner
Ron Fernandez
Dave Finkelstein
Cindy Frost
Albert Chu

Stanford, California
Thanks to all the people at Stanford University, Apple Computer, and the real world for making this book possible.

At Stanford, thanks to all the students, faculty and staff who took our course "Using the Macintosh at Stanford." You were our unsuspecting guinea pigs. Thanks to all of the CS1c teaching assistants who were our partners in crime.

Thanks to Lynn Takahashi, Dan'l Lewin, the Apple University Team, and the members of the Apple University Consortium for encouraging us to publish this book and for supporting us in our efforts. Thanks to Chris Espinosa, Moira Cullen, Stacey Bressler, and Nicole Kowalski for answering every question we could ask as well as many we would never have thought to ask. Also, thanks to the Macintosh User Education Group, the Apple Support Training Group and the scores of other folks at Apple who helped us out and cheered us on.

Thanks to our reviewers: Sheryl Blix, University of Washington; Shirley Fenton, University of Waterloo; James Gips, Boston College; Sandra Helmick, University of Missouri; Robert L. Oakman, University of South Carolina; and Andrea Butter. Your comments and suggestions kept us on our toes until the very end.

We'd like to extend special thanks to Stuart Reges, Assistant Chairman of the Department of Computer Science at Stanford University. Stuart inspired and supported both the book and the course it came from. He encouraged us to try something new and gave us the charter to do it.

Finally, special thanks to Berke Breathed for illustrating our cover. We think it's terrific.
Contents

Preface iii
Acknowledgements v

1 Approaching Macintosh
Introduction to Macintosh 1-2
Exercises 1-27

2 Graphics
About Graphics 2-2
MacPaint 2-6
Galleries 2-38
Exercises 2-40

3 Word Processing
About Word Processing 3-2
Introduction to MacWrite 3-6
Advanced MacWrite 3-34
Introduction to Microsoft Word 3-56
Advanced Microsoft Word 3-92
Galleries 3-119
Exercises 3-122

4 Spreadsheets
About Spreadsheets 4-2
Introduction to Multiplan 4-6
Advanced Multiplan 4-44
Galleries 4-72
Exercises 4-74
## Business Graphics

- About Business Graphics 5-2
- Microsoft Chart 5-6
- Galleries 5-38
- Exercises 5-42

## Database Management

- About Database Management 6-2
- Microsoft File Part 1 6-6
- Microsoft File Part 2 6-30
- Galleries 6-61
- Exercises 6-63

## Project Management

- About Project Management 7-2
- MacProject 7-6
- Galleries 7-40
- Exercises 7-42

## Reference

- Approaching Macintosh Plus 8-2
- Glossary 8-5
- Index 8-13
1 Approaching Macintosh

Introduction to Macintosh
Exercises
Approaching Macintosh

Welcome to the first step. Before you can begin to become a pro at personal computing, you’ll need a quick introduction to the Macintosh and how to work with it. If you’ve never used a Macintosh before—if you’ve never used a computer before—you’ll want to become familiar with the parts of the Macintosh and learn some basic terms and techniques that you’ll use throughout this book.

In order to complete this module, you’ll need:

- A Macintosh computer
- A MacWrite disk
- A blank disk (to serve as your personal data disk)
- A copy of Plato’s Republic (just kidding)

The Parts of a Macintosh

The diagram below shows the major parts of the Macintosh system and their appropriate names. These parts of the Macintosh that you can see and touch are called hardware.

<table>
<thead>
<tr>
<th>Macintosh</th>
<th>Screen</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disk</td>
<td>Disk Drive</td>
</tr>
<tr>
<td>External Disk Drive</td>
<td></td>
</tr>
<tr>
<td>Keyboard</td>
<td>Mouse</td>
</tr>
<tr>
<td>Paper</td>
<td>Printer</td>
</tr>
</tbody>
</table>

Use the diagram to locate the parts of the Macintosh system you’re using. (Yours may look slightly different.)

If you’re ever unsure of what a part of your Macintosh is called, or where it’s located, you can use this diagram for reference.

The Macintosh screen is much like the screen on your television set. It's different from screens on many other computers because it can display high-resolution (highly detailed) pictures. The Macintosh can display only black-and-white images, but it’s unique in that it displays black characters on a white background, much like you would see on a typewritten page.
The mouse is a small box about the size of a deck of playing cards that’s attached to the Macintosh with a thin cord. You’ll use the mouse to select and move objects on the Macintosh screen and to choose commands that tell the Macintosh what to do. You’ll learn how to use the mouse later.

The Macintosh uses 3-1/2 inch disks, which hold the software—the application programs that make the Macintosh work. These disks can also store the documents that you create. More about disks later.

Each Macintosh has an internal disk drive built into the main unit just under the screen. The disk drive reads information from the disk and writes new information to be stored there. In addition to the internal drive, you can add an external disk drive to the Macintosh to store larger programs and documents.

The Macintosh keyboard is laid out like a typewriter keyboard with a few notable exceptions:

**The Return key**
The Return key works much like the carriage return on a typewriter. When you’re typing, you’ll use the Return key to skip lines and to start new paragraphs.

**The Backspace key**
The Backspace key backspaces over and erases the previously typed character or the current selection. So if you make a mistake when typing, simply use the Backspace key to erase it.
Turning on the Macintosh

The Command key
The Command key is located just to the left of the spacebar. Many of the short cuts and special features you'll learn use the Command key.

The Option key
The Option key is located to the left of the Command key. Holding down the Option key while typing another key modifies that key.

Getting Started

Now that you know where everything is on your Macintosh, you're ready to learn how to make it work. The first task is easy—turning it on.

Ask anyone. They'll tell you that a Macintosh works best when it's turned on. The on/off switch is located on the left side on the back of your computer.

Turn on the Macintosh by flipping the on/off switch to the "on" position.

The Macintosh will beep softly, and a small picture of a disk with a flashing question mark will appear at the center of the screen.

If your screen remains dark, adjust the screen brightness control at the lower left edge of the front of your Macintosh.

The question mark appears because the Macintosh is waiting for you to insert a disk into the disk drive. It can't be just any disk, though. Everytime you turn on your Macintosh, the first disk you insert must be a startup disk.

Startup disks contain system files—information that the Macintosh needs to begin operating. System disks and most application disks (disks that contain application programs like MacWrite and MacPaint) can usually be used as startup disks.
The Macintosh Desktop

The System Folder

System Folder
6 items
225K in folder
64K available

System
Finder
Imagewriter
Clipboard File
Note Pad File
Scrapbook File

The Finder and System files must be present on any Startup Disk.

The Clipboard file temporarily stores items that you Cut or Copy.

The Imagewriter file (or a similar printer file) must be present to print.

The Note Pad and Scrapbook files hold the items stored in the Note Pad and Scrapbook desk accessories.

If you first try to insert a disk without the necessary system files (such as a blank disk or a disk containing only documents), the Macintosh will eject that disk and display a picture of a disk with a flashing "X".

Insert a MacWrite disk—label side up and metal end first—into the built-in disk drive.

Remember, a System disk, MacWrite disk, or MacPaint disk can be used as a startup disk. But in this case, you'll use a MacWrite disk.

First, an icon of a smiling Macintosh will appear, then a banner welcoming you to Macintosh. In a short while, the Macintosh desktop will appear.

One way to make computers easier to use is to make them more familiar. The Macintosh uses a desktop metaphor to make the tools you use and the things you do easier to understand. Small pictures, called icons, represent objects you already know, such as documents, folders, and even a trash can. Using the mouse, you move these desktop objects and choose commands from the menu bar at the top of the screen to tell the Macintosh what to do. You'll learn more about how to do this below.

The disk icon in the upper right hand corner of your desktop represents the disk that you just inserted.
Using the Mouse and the Pointer

Note that your desktop may not look exactly like this one. If the disk window isn't visible, you'll first need to open the disk icon. Read on.

There are icons to represent everything available for you to use on the Macintosh desktop. The way in which you tell the Macintosh you want to use something is by selecting its icon. You select icons and commands by using the mouse. Notice the black arrow on the screen; this is the pointer.

**Move the mouse back and forth.**

Notice that the pointer's movement on the screen follows your movement of the mouse.

**Lift up the mouse and look underneath.**

Notice the ball on the bottom of the mouse. When you move the mouse, the ball rolls and tells the pointer how to move. If the mouse ball is not touching a flat surface, the pointer doesn't move. Therefore, if you ever run out of room while moving the mouse, all you have to do is pick the mouse up and reposition it on a clear, flat area. Try this.

**Move the mouse and watch the pointer move on the screen.**

Then, pick up the mouse and place it somewhere else on your desk. Note that the pointer doesn't move while the mouse is lifted.

Now try another experiment with the mouse. You may at some point begin to worry that, if you're not careful with the mouse, you could run the pointer off the edge of the screen, never to be seen again. Not so.
The Macintosh Desktop

If you first try to insert a disk without the necessary system files (such as a blank disk or a disk containing only documents), the Macintosh will eject that disk and display a picture of a disk with a flashing "X".

Insert a MacWrite disk—label side up and metal end first—into the built-in disk drive.

Remember, a System disk, MacWrite disk, or MacPaint disk can be used as a startup disk. But in this case, you'll use a MacWrite disk.

First, an icon of a smiling Macintosh will appear, then a banner welcoming you to Macintosh. In a short while, the Macintosh desktop will appear.

One way to make computers easier to use is to make them more familiar. The Macintosh uses a desktop metaphor to make the tools you use and the things you do easier to understand. Small pictures, called icons, represent objects you already know, such as documents, folders, and even a trash can. Using the mouse, you move these desktop objects and choose commands from the menu bar at the top of the screen to tell the Macintosh what to do. You'll learn more about how to do this below.

The disk icon in the upper right hand corner of your desktop represents the disk that you just inserted.
Using the Mouse and the Pointer

Note that your desktop may not look exactly like this one. If the disk window isn't visible, you'll first need to open the disk icon. Read on.

There are icons to represent everything available for you to use on the Macintosh desktop. The way in which you tell the Macintosh you want to use something is by selecting its icon. You select icons and commands by using the mouse. Notice the black arrow on the screen; this is the pointer.

Move the mouse back and forth.

Notice that the pointer's movement on the screen follows your movement of the mouse.

Lift up the mouse and look underneath.

Notice the ball on the bottom of the mouse. When you move the mouse, the ball rolls and tells the pointer how to move. If the mouse ball is not touching a flat surface, the pointer doesn't move. Therefore, if you ever run out of room while moving the mouse, all you have to do is pick the mouse up and reposition it on a clear, flat area. Try this.

Move the mouse and watch the pointer move on the screen. Then, pick up the mouse and place it somewhere else on your desk. Note that the pointer doesn't move while the mouse is lifted.

Now try another experiment with the mouse. You may at some point begin to worry that, if you're not careful with the mouse, you could run the pointer off the edge of the screen, never to be seen again. Not so.
Try to move the pointer off the screen.

You can't. Honest. So don't worry about moving the mouse quickly across the desktop. If you should overshoot your target, simply move it back into position.

Now that you've learned how to move the mouse, here are a few basic mouse techniques that you'll need to know before you continue. Don't worry if they seem a bit confusing at first; they'll become clearer once you use them.

**Press**
As you might expect, pressing involves depressing the mouse button.

**Click**
To click an object, use the mouse to position the pointer over the object. Then press and release the mouse button.

**Double-Click**
You double-click an object by positioning the pointer over the object and clicking the mouse button twice in quick succession. Double-clicking is usually a shortcut to performing a specific command.

**Drag**
To drag, position the pointer at the desired location and press down the mouse button. With the mouse button depressed, move the mouse to drag the pointer accordingly.
Selecting

To Shift-click, hold down the Shift key while clicking the mouse button. Shift-clicking usually extends or adds to a selection.

One of the things that makes Macintosh easy to learn is that no matter what you do with Macintosh you do it in the same way:

- First, select an object.
- Then, choose a command to act on that object.

For example, if you want to duplicate a document or folder on the desktop, first you select it and then you choose the command to duplicate it.

To select something on the desktop, simply use the mouse to position the pointer above the object that you want to select, then click the mouse button. ("Clicking" means to quickly press and release the button on top of the mouse.) Practice selecting by choosing the trash can.

Select the Trash by positioning the pointer over the trash can icon at the lower right corner of the Macintosh desktop and clicking the mouse button.

Notice, that as you select an object, it becomes dark or highlighted. This highlighting helps you to quickly identify the current selection. If the Trash icon was already selected, it will already be highlighted.
If you change your mind about your selection, perhaps you decide you'd like to select something else, you need only to move the mouse pointer over it and click the mouse button. Your previous selection becomes "unselected" when the new selection is highlighted.

Move the pointer over the disk icon at the upper right of the screen and click the mouse button.

(Remember that you click by quickly pressing and releasing the mouse button.)

Notice that the disk icon is now highlighted and the Trash icon is unselected.

Once you've selected the object you'd like to work with, you'll need to choose a command to act on that selection. In general, you'll choose commands from the menu bar that runs across the top of the desktop.

To choose a command from a menu:

- First, use the mouse to position the pointer over the appropriate menu.
- Press and hold the mouse button to "pull down" the menu.
- While still holding down the mouse button, drag down until the appropriate command is highlighted.
- Finally, release the mouse button.

You'll "open" the trash can using this technique.

First, click to select the trash can icon again.

The Trash icon becomes highlighted, indicating that it's selected.

Position the pointer over the File menu (on top of the word File in the menu bar). Press and hold the mouse button.

A "pull down" menu of available commands appears from the menu bar.

You'll notice that some of the commands are dimmed (shown in grey) and can't be selected. These are commands that aren't appropriate at this time. (You can't "eject" the trash can, for instance.) By making it impossible to choose inappropriate commands, the Macintosh actually prevents you from making those little embarrassing mistakes.
You'll notice that, to the right of some of the commands listed in the menu, there is a letter preceded by a special symbol. That symbol corresponds to the symbol on the Command key located just to the left of the space bar.

By holding down the Command key and typing the letter listed, you can invoke the command without using the mouse to pull down the menu. You may want to use these keyboard shortcuts after you've become more familiar with the Macintosh.

While holding down the mouse button, drag the mouse downward until the pointer is over the Open command.

The Open command should be highlighted.

Release the mouse button.

An empty Trash window opens on the desktop. More about windows in a bit. Notice also that the Trash icon is now hollow, indicating that the Trash is now open.

If a window didn't appear, make sure that the Trash icon is selected before you choose Open from the File menu.

Use the technique you just learned to choose Close from the File menu.

Remember: Move the mouse pointer over the word File; press and hold the mouse button; drag down to the word "Close" and release the mouse button when Close is highlighted.
Practice opening and closing the Trash until you’ve mastered selecting commands from menus.

If the MacWrite disk window isn’t visible on your desktop, open the disk by selecting the MacWrite disk icon and choosing Open from the File menu.

A window is an area of the Macintosh screen that displays information. The disk window, for instance, displays the contents of the disk. The Trash window that you opened earlier displayed the contents of the Trash. The parts of a window are shown here.

**Anatomy of a Window**

- **Close Box**
- **Title Bar**
- **Scroll Arrow**
- **Scroll Box**
- **Scroll Bar**
- **Size Box**

**MacPaint Disk**

| 4 items | 364K in disk | 35K available |

- MacPaint
- tofu
- System Folder
Changing the Size of a Window

There are times when you want to work with a large window, in order to easily see what's inside. Other times you'll prefer a smaller window, in order to let you see more than one window on the desktop at a time.

To change the size of a window, you use the mouse to drag the size box in the bottom right corner of the window.

Position the mouse pointer on the size box and drag up and to the left.

As you drag, a dotted outline of the window follows. As you drag up, the window becomes shorter. As you drag to the left, the window becomes narrower. When you release the mouse button, the window changes size.

Experiment with resizing the window until you feel comfortable using the size box.

It's important to remember that changing the size of a window doesn't change the window's contents. Even though you may not be able to see everything in the window, its contents are still there.

But, if you can't see everything that's in the window, how can you get at it? A good question.

Whenever a window is too small to show its entire contents, the scroll bars along the right edge and bottom of the window will appear grey. By clicking the scroll arrows at either end of the scroll bar, you'll be able to scroll through the contents of the window that you can't see.
Using Multiple Windows

Using the size box, make the disk window small enough so that some of the icons are hidden from view.

Notice that the grey scroll bars indicate that some of the contents of the window is hidden.

Click on the scroll arrow that points to the right.

The icons that were hidden should zip by to the right. You can use the other scroll arrows to scroll up, down, or to the left as well.

As we mentioned earlier, you can have more than one open window on the desktop at a time. With multiple windows open, windows can overlap like pieces of paper lying on top of one another. The frontmost window—the window you're working in—is called the active window.

Open the Trash by selecting it and choosing Open from the File menu.

The Trash window is now the active window.
Activating a Window

Notice that the active window is the frontmost window and its title bar is highlighted with horizontal lines. This makes the active window easy to identify.

To activate a window, simply click anywhere inside it.

**Click in the MacWrite disk window to activate it.**

Note that the disk window now moves to the front and its title bar is highlighted. The Trash window is now behind the disk window.

Moving a Window

In order to work with multiple windows, it may be necessary to move a window around on the desktop. To move a window, simply drag it by its title bar.

**Move the disk window by dragging it by its title bar.**

Remember that to drag, press and hold the mouse button while moving the mouse. A dotted outline of the window follows. When you release the mouse button, the window snaps to its new location in a flash.
Using the Close Box

Note that if you move the window, it becomes the active window, whether it was active before or not.

Earlier, you learned that you could close the active window by choosing Close from the File menu. Another way to close the active window is to click in the small white close box at the top left corner of the window.

Close the Trash window by clicking in its close box.

The Trash window closes and the disk window becomes active.

Using a Desk Accessory

Under the Apple or "tl" menu at the top left of the menu bar are a number of desk accessories designed to make working with the Macintosh a little easier. Desk accessories can be opened at any time—either at the desktop or when you're using an application.

Choose Note Pad from the "tl" menu.

The Note Pad desk accessory will appear on the desktop. You can use this desk accessory to take messages when the phone rings or to list other tidbits of information that might otherwise get lost when you're working with your Macintosh.
Close the Note Pad by clicking in its close box.

You can experiment with the other desk accessories under the Apple menu. You'll learn more about these in later modules.

Next you'll learn how to manage the documents that you'll create.
You'll use MacWrite to create a sample document that you can save, place in a folder, and throw into the trash—all things you'll want to do with your real documents when that time comes.

Applications or application programs are tools used to create and modify documents. For instance, MacWrite is an application that you can use to create documents like letters to loved ones, term papers on genetic mutations, or textbooks on Macintosh software. Applications are usually represented by diamond-shaped icons on the desktop. The diamond-shaped icon labeled MacWrite is—you guessed it—the MacWrite application. You'll open it to create your first Macintosh document.

Earlier in this module, you learned to open an icon by selecting it and choosing Open from the File menu. As a shortcut, you can also open an icon by double-clicking on it.

Open the MacWrite icon by double-clicking on it.

In case you've forgotten, double-clicking means to click the mouse button twice in quick succession. The pointer will change to the wristwatch to indicate that the Macintosh is busy loading the application into its memory.
Don't worry if you don't know how to use MacWrite. You'll learn all about MacWrite in the Word Processing section of this book. All you need to do to create a new document for this example is type a little text and save it.

Type your name—or somebody else's name.

That's it! If you want to type more, you may. Use the Backspace key to correct any mistakes you make.

When you work with a document in most Macintosh applications, you're actually working with a temporary copy stored in the Macintosh's memory. The memory of the Macintosh isn't permanent, however, and if you or your local electric company should accidentally turn off the power to your Macintosh, all your work that hasn't been saved will unceremoniously vanish forever. No fun.

Saving a document places a copy of your work on your disk. Unlike information in the memory of your Macintosh, information stored on a disk doesn't disappear when you turn the power off. It's there for safekeeping. You should save your work by choosing Save from the File menu about every 15 minutes or so. That way, if the unthinkable should happen, you'll only lose a few minutes of work.
Opening an application loads it from the disk into the memory of the Macintosh.

Using the application, you create a document which is also temporarily stored in memory.

Saving transfers a copy of your document from memory to the disk for safe-keeping.

Imagine that the work you've just done is part of an important term paper on the history of asphalt. You'll want to save it using the Save command from the File menu.

Choose Save from the File menu.

A dialog box appears asking for the name of your document. The blinking vertical bar marks the insertion point—where the text you type will be inserted.

Type an interesting name for your document.
Click Save.

The disk drive will whir as the document is stored on the disk. With your document safely stored on the disk, you can leave or quit the application and return to the desktop.

Choose Quit from the File menu to quit MacWrite.

In a few seconds, the desktop will appear with an icon of your new document in the disk window. The icon of the document looks much like the icon of the application that created it—in this case MacWrite—and it's labeled with the name you gave it. If you wanted to open the document to print it or make changes, you'd simply open its icon; the application that created it would be loaded automatically.

If you look just below the title bar of the MacWrite disk window, you'll see a few mysterious looking numbers. The one on the left tells you how many items there are in the disk. The number in the center tells you how much space on the disk those items are using. And the number on the right tells you how much disk space remains available. These numbers will be different for different disks.

Disk space (also called storage), is measured in kilobytes, or K for short. Just to give you an idea of how big a kilobyte is, the one-page document you just created takes up about 2K on your disk.

A standard single-sided Macintosh disk (a disk that stores information on one side only) stores 400K of information. A Macintosh Plus double-sided disk (a disk that stores information on both the top and bottom surfaces of the disk) stores twice as much, or 800K.

The startup disk you're using now holds system files, the MacWrite application, and the document you created. If you were to create a number of large documents, you could easily use up all of the available space on the disk. You'd then receive a "disk is full" error message from the Macintosh and you'd have to throw some documents away, or transfer them to another disk. You'll learn how to do this in a minute.

System memory, the amount of memory inside the Macintosh, is also measured in kilobytes, or K. Macintoshes generally come in 128K, 512K, and 1024K varieties. You can check which kind of Macintosh you have by choosing About the Finder from the Apple menu.

Choose About the Finder from the Apple or "ti" menu at the far left of the menu bar.

A small white box will appear. The number at the bottom left of the box tells you how much memory is installed in your Macintosh.
Earlier, you learned that when you start an application, the Macintosh often loads it into its system memory. Also, with most applications, the document you're working on is also loaded into memory.

If your document uses all of the available system memory, you'll receive an "Out of Memory" error message. If this happens, you should first save your document by choosing Save from the File menu and then try to break the large document up into smaller pieces.

After working with the Macintosh for awhile, you'll accumulate a number of documents on your disk. Folders help you organize related documents into groups so that they'll be easier to find on the desktop. To create a new folder, use the New Folder command in the File menu.

Choose New Folder from the File menu.

A folder named "Empty Folder" will appear on the desktop. Before you put your document in the folder, you'll type a name for it.

Note: If you're using an older version of the Macintosh system software, the New Folder command may not be available. If this is the case, create an empty folder by selecting the Empty Folder icon and choosing Duplicate from the File menu.

Type "Report Folder" as the name of your folder.

To place your document in the folder, drag its icon over the icon of the folder. When the icon of the folder is highlighted, release the mouse button.
When you release the mouse button with the folder icon highlighted, the document disappears into the folder.

**Double-click on the folder to open it.**

A folder window opens on the desktop with your document inside. When you create other similar documents, you can group them in this folder to keep them organized.

When you work with a Macintosh, it’s often helpful to use two disks: an application disk, a startup disk with system files and the application you want to use; and a storage disk, a disk to store the documents you create. Using two disks, you can keep many of your old documents stored on your storage disk without running out of disk space on the applications disk.

To use a storage disk, you’ll need to learn how to copy files between disks. But first, you’ll prepare a blank disk to serve as your storage disk.

**Note:** This section contains different instructions for those with one or two disk drives. Make sure to read the set of instructions appropriate for your Macintosh system.

Before you can use any blank disk, you must prepare the disk to hold the information you’ll store on it. This process is called initializing. To initialize a blank disk on the Macintosh, simply insert the blank disk into a disk drive anytime after a startup disk has been inserted.
With One Disk Drive

Eject the startup disk from the disk drive by selecting the disk icon on the desktop and choosing Eject from the File menu.

In a few seconds the Macintosh will eject the disk. Note that the icons from that disk are now dimmed (grey) indicating that the disk is no longer in the disk drive.

Insert a blank disk into the disk drive.

With Two Disk Drives

Insert a blank disk into either disk drive.

If the external disk drive is empty, simply insert the blank disk into the drive.

If both drives are in use, eject one of the disks by selecting its icon and choosing Eject from the File menu.

Because an uninitialized disk is unreadable, when you insert a blank disk into a Macintosh, a dialog box will appear asking if you wish to initialize the disk or eject it.

Click Initialize to initialize the disk.

In a few seconds, a dialog box will appear asking you to name this disk. Just as with documents, you can name the disk almost anything.

Type your name followed by the word "Storage" and click OK.

Your disk's icon will appear on the desktop under the icon of the startup disk.
Now you're ready to place a copy of your document on your new storage disk. When you copy a document from one disk to another, the disk you're copying from is called the source disk, and the disk you're copying to is called the target or destination disk.

If the destination disk (the storage disk) isn't in the disk drive, eject the current disk and insert the destination disk.

The contents of the ejected disk will appear dimmed on the desktop, indicating that the disk has been ejected.

Make sure that the folder window is open and your document is visible.

Drag your document over the icon of the destination disk (the storage disk). When the icon of the disk is highlighted, release the mouse button.

The Macintosh will prompt you to insert one disk and then the other until the copying is complete.

With the source disk in the internal disk drive, insert the destination disk (the storage disk in this case) into the external disk drive (if it's not there already).

Make sure that the folder window is open and your document is visible.

Drag the icon of your document and position it over the icon of the destination disk. When the icon of the disk is highlighted, release the mouse button.

In a few seconds, the copy will be complete. You can open the destination disk icon to confirm that the copy was successful. In the disk window, you should see the icon of the document you copied.

When you drag the document icon to another disk, you make a copy of the document on that disk. The original document remains unchanged on the source disk. Since your document is now safely stored on your storage disk, you can throw away the original to free up space on the MacWrite disk. To do this, you'll drag the icon of your original document into the Trash.

Make sure the MacWrite disk is in a disk drive.

If the MacWrite disk is not in any drive, eject the current disk by selecting its icon and choosing Eject from the File menu. Then insert the MacWrite disk in its place.

Close the folder window by clicking in its close box.
When you throw away a folder, you throw away any document that’s inside.

Drag the folder over the Trash icon at the bottom right of the screen. When the Trash icon highlights, release the mouse button.

The folder, document and all, disappears into the Trash.

It’s inevitable. Someday, when you’re in a hurry or when it’s either very late or very early, you’ll accidentally throw away something that you really wanted to keep. Don’t dismay. If you catch your mistake quickly, you’ll be able to retrieve what you’ve thrown away.

Open the Trash by double-clicking on its icon.

The Trash window contains the folder you just threw away. Inside the folder is your document. (You can check if you’d like.) To retrieve an item from the Trash, simply drag it from the Trash window back onto the desktop.
Any document, folder, or application you throw into the Trash remains there until you 1) eject the disk, 2) open any application, or 3) choose Empty Trash from the Special menu.

Choose **Empty Trash from the Special menu.**

In a few seconds the folder will disappear from the Trash window.

Close the Trash window by clicking in its close box.

Whenever you finish working with the Macintosh, you should eject any disks in the disk drive(s) and turn off the power. To eject the disks, select their icons and choose Eject from the File menu. A quicker way to do this is to use the Shut Down command found in the Special menu.

**Choose Shut Down from the Special menu.**

The Macintosh will eject any disks from the disk drive(s) and restart.

Note: If you're using an older version of the Macintosh system software, the Shut Down command won't be available. You can accomplish the same result by ejecting the disks using the Eject command from the File menu and by switching the power off.

**Turn the power off.**
Congratulations! You've just completed the first step to becoming a Macintosh expert. If you feel you still need more information or practice, or if you have a quick question not covered here, consult Macintosh, your Macintosh owner's guide.

Since you've just completed the first module in this book, you should have learned:

• How to identify the parts of a Macintosh system
• How to work with the Macintosh desktop
• How to select objects by clicking on them with the mouse
• How to Press, Click, Double-Click, Drag, and Shift-Click with the mouse
• How to move, resize, and scroll through windows
• How to open an application by double-clicking on its icon and how to close an application by choosing Quit from the File menu
• How to use folders to organize documents
• How to throw away unwanted objects in the Trash and how to retrieve accidentally discarded objects from the Trash
• How to use the Shut Down command to eject all disks and restart the Macintosh
Exercises

1. Collect several articles and advertisements for personal computers. (Skip the ones filled with technical jargon.) Make a list of the most commonly mentioned features in the articles and ads. From your brief introduction to Macintosh, how does the Macintosh compare on these points?

2. Visit a computer store or any other place where you can try other computers. Spend a few minutes using a few other computers. Make a list comparing them. Which computers did you like or dislike? Why? Which computer would you choose to do your daily work?

3. Many computers display text (letters and numbers) differently than they display graphics (pictures and graphs). These computers often have a "Graphics Mode" and a "Text Mode". The Macintosh doesn't have a "Text Mode" and treats text simply as a special type of graphic. What are the advantages and/or disadvantages of this method?

4. Both system memory and disk space are measured in kilobytes, or K for short. Explain the difference between system memory and disk space.

5. What is the significance of the term "active window"? How do you know which window is the active window? How do you make a window the active window?

6. If a window is too small for you to see the icon you want, name two ways to find it.

7. Define the following terms:
   a) application
   b) desk accessory
   c) dialog box
   d) dimmed command
   e) document
   f) initialize
   g) mouse
   h) platypus (just kidding)
   i) Shift-click
   j) startup disk
8. Identify the parts of the desktop shown below.
2 Graphics

About Graphics
MacPaint
Galleries
Exercises

HOWDY DO!
Applications of computers in the area of graphics have become so widespread that the term "computer graphics" can be found attached to everything from motion pictures to medicine. A computer's ability to create and manipulate images quickly and skillfully has made it an indispensable tool in the field of graphics—especially where images must be changed or moved often.

On a personal computer like the Macintosh, drawing programs have been one of the most popular types of graphics applications. These applications which, transform the computer's screen into an electronic canvas, offer a set of computer drawing tools that can be used in much the same way as a pencil and paint brush.

The advantage these electronic drawing tools have over their standard counterparts is that they often make the difficult, cumbersome, and tedious tasks of drawing easier. Straight lines, perfect circles, and scaling are a snap with the appropriate drawing software. But computer drawing tools aren't merely electronic simulations of pencils and pens, nor are they a substitute for artistic skill. By providing electronic design tools which are different than their physical counterparts, computer drawing applications also open up a new medium of artistic expression.

MacPaint is a drawing application for the Macintosh. But more than that, MacPaint is the drawing application most responsible for the explosion in popularity of this type of application on microcomputers like the Macintosh.

From the day it was released, MacPaint's clever design and remarkable utility made it instantly the target of imitators. MacPaint, more than any other Macintosh application, demonstrates the advantages of the
Macintosh's mouse and high-resolution screen. But while some thought of MacPaint as a clever demonstration application, others were busy using it for everything from newsletters to architectural renderings, from X-ray analysis to mapping. The flexibility and features of MacPaint make it particularly well-suited for a number of surprisingly diverse graphics applications.

MacPaint features a number of tools for drawing lines, ovals, rectangles, polygons and free-form shapes. MacPaint also makes it easy to move, duplicate, invert, or flip any object or part of an object that you can draw. A selection of patterns, which can be modified by the user, makes shading and filling areas a snap. And FatBits allows you to make detailed changes to your drawing with ease.
MacPaint
The Task

Did you ever write a term paper in which you had to try to describe the wiggly border between two nations or the orientation of atoms in a particular molecule? There must have been times when you’ve wanted to describe something using pictures, not in words.

Come to think of it, you have that term paper on the history of the Ionic and Doric styles of ancient Greek architecture that’s due soon. Since the single most recognizable difference between the two styles is in the design of their capitals (the decorative tops of columns), you would like a drawing of the two different capitals in the term paper. Fine, but how can you quickly and easily draw the capitals, especially if you are not particularly gifted with pencil, pen, ruler, and markers? This is where MacPaint comes in handy.

Simplicity is the key to creating effective explanatory drawings. Both the general designs of the Doric and Ionic capitals can be reduced to a few basic geometric shapes, which are easily created with MacPaint’s drawing functions or tools.

Since each capital must sit on the top of a column, you will need to make two columns. Or will you? With the lasso and selection rectangle tools, you will make a single column quickly and easily, out of pre-defined shapes. But that’s not all. Using the same tools, you’ll be able to duplicate that column, and thus eliminate the need to draw it a second time.

After both capitals and columns are drawn, you’ll choose from MacPaint’s many shades and patterns and selectively add them to your drawing with the paint can.

In your drawing you’ll use MacPaint’s text functions. You’ll be able to add captions, identifying labels, and include historical information. Finally, your drawing will be ready for inclusion in that important term paper.

On the following page is an example of what your drawing will look like when you finish the module.
GRECIAN ORDERS

Doric Order
Flourishing between the 6th and 5th centuries B.C., the Doric Order was characterized by its mathematical and exacting demands for proper proportion. For example, the ratio between any two sides of the Parthenon is always 9 to 4.

Ionic Order
Less severe and mathematically rigorous than the Doric Order, the Ionic Order had its heyday between the 5th and 1st centuries. Without the Doric rules for scale and proportion, Ionic architects designed a far wider variety of temples and secular buildings.
You'll begin the module by opening the MacPaint application from the Macintosh desktop. You'll use the application to make a MacPaint document.

**Turn on the Macintosh and insert your MacPaint disk—label side up and metal end first—into the built-in disk drive.**

You'll soon see the Macintosh desktop with the icon of your MacPaint disk in the upper right-hand corner.

If necessary, double-click on the MacPaint disk icon to view its contents.

Now you'll open MacPaint by double-clicking the MacPaint icon.

Double-click on the MacPaint icon to open the application.

The MacPaint screen will appear in a few seconds.

Before you begin the drawing shown on page 7, familiarize yourself with the MacPaint screen and some of the functions of the application.

As with all Macintosh applications, the menu bar is located at the top of the screen. To see a list of the commands or options under any particular menu, click and hold the mouse button on the particular menu name. To choose a command or option, move the pointer to your choice and then release the mouse button. Peculiar to MacPaint are the Goodies and FontSize menus.
At the left side of the screen is the **tool palette**, a collection of 20 symbols representing the various MacPaint tools.

The **border palette** is located directly beneath the tool palette. The border palette controls the width of the lines you draw and the width of the borders around shapes. A check mark indicates the currently selected line width.

Located at the bottom of the MacPaint screen, the **pattern palette** contains 38 available patterns. The currently selected pattern is shown in the large rectangle furthest left in the palette.

The tools, borders, and patterns are used in the **drawing window**. The drawing window shows only a small part of the 8- by 10-inch area available to MacPaint users. You'll learn how to move the drawing window to view more of a MacPaint document.

Note that the paintbrush is the preselected tool. In the tool palette, the selected tool is highlighted. Make sure that the pointer is inside the drawing window. It will look like a black dot.

**Press and hold the mouse button while moving the mouse.**

As you may recall, this is known as dragging.

A black line appears. You have just painted in MacPaint.

Select the eraser tool by clicking on it. **Drag the eraser over your black line.**

The eraser removes the paintbrush line from the drawing window.
Patterns

Correcting Mistakes

Creating Ionic and Doric Columns

In the pattern palette, click on any pattern you desire. Note that the pattern you selected now appears in the large rectangle to the left in the pattern palette.

Select the paintbrush again and draw a new line or two.

The paintbrush now paints with the newly selected pattern.

Before going any further, you should erase any lines that you made in the drawing window while experimenting. A handy way to erase the entire drawing window is to double-click on the eraser icon in the tool palette.

Double-click the eraser icon.

The drawing window is now clear.

The most obvious way to correct mistakes is to use the eraser. Often, a more effective (and neater) solution is to use the Undo command in the Edit menu.

Using the paintbrush, make a horizontal line. Cross it with a vertical line.

Let's assume that you wish to keep the horizontal line, but the vertical line has to go.

From the Edit menu, choose the Undo command.

The vertical line disappears as the Macintosh undoes your last action, which was the creation of the vertical line.

Double-click the eraser icon to clear the drawing window.

The drawing window is clear again.

Familiarize yourself with the completed module example on page 7.

Pay some attention to the various parts of the example page. You'll want to make your capitals and columns roughly the same size and position as they are on the example page.

You will begin by creating the column. The Ionic and Doric capitals will be made later. The unfilled rounded rectangle tool will produce the vertical grooves found on the column.

Using the Shapes

Using the unfilled rounded rectangle icon in the tool palette.
This tool is located in the left column, seventh from the top.

Select the second line width from the top in the border palette by simply clicking on the second line width.

Move the pointer into the drawing window. Drag the cross-shaped pointer diagonally down and to the right.

Your goal is to make a tall, thin, rounded rectangle. In fact, it should be so thin that the top and bottom have no flat faces.

If necessary, select the eraser, drag it over the rounded rectangle and try again.

Next, you'll want to duplicate the rounded rectangle to make the vertical grooves found on Greek columns. When you wish to duplicate or move an object in MacPaint, you must first select the object with either the lasso or the selection rectangle.

Select the selection rectangle. Drag the pointer diagonally across the rounded rectangle.

Make sure the entire rounded rectangle is enclosed by the selection rectangle.
Move the pointer into the selection rectangle and drag.

The selection rectangle and its contents will move about the screen in response to movements of the mouse. You can reposition the rounded rectangle at will. Now you will duplicate the rounded rectangle.

First, position the rounded rectangle on the left side of the drawing window. Release the mouse button.

Press and hold down the Option key. Now, press and hold down the mouse button. Drag the mouse as before.
You have learned a speedy means of duplicating objects in MacPaint. Once a duplicated object is in the position you want, just lift up on the mouse button and click anywhere in the drawing window. The duplicate will be unselected and will be fixed in its new position.

If you press the Backspace key while an object is selected, that object will be removed from the drawing window. The rounded rectangle should still be selected.

Press the Backspace key.

Select the lasso.

Position the lasso near the remaining rounded rectangle. While holding the mouse button, move the lasso around the rounded rectangle.

As you drag the lasso, a line tracing its path will appear. Be sure that this line completely encircles the rounded rectangle. It isn't necessary to make a perfect circle or oval around the rounded rectangle.

Unlike the selection rectangle, which selects an entire surrounded area (including any white space), the lasso "shrinks" to conform to the contours of an object.

Position the pointer inside the selected area. Drag the rounded rectangle around the drawing window.

Repositioning objects with the lasso is very similar to repositioning them with the selection rectangle. As with the selection rectangle, you
can duplicate any object selected with the lasso by using the Option key.

Look closely again at the completed example. The top and bottom edges of the five column grooves are level. As you duplicate the rounded rectangle to make the other four grooves, you'll need some help keeping them level with one another. If you use the Shift key while duplicating, you will only be able to move the duplicates horizontally or vertically.

Position the rounded rectangle slightly to the left in the drawing window.

Press and hold the Option and Shift keys. Drag the duplicate rounded rectangle to the right a distance approximately equal to its width. Release the mouse button.

With the Shift key pressed, the duplicates will remain horizontally aligned with each other.

The duplicate rounded rectangle should still be selected.

With the Option and Shift keys, make three more duplicates, all approximately the same distance apart.

As long as the Option and Shift keys remain pressed, you can just press the mouse button again and drag. A duplicate will be left behind in the old position, and you can place the next duplicate in a new spot.
The grooves are now properly positioned. Examine the completed MacPaint document once more. Notice that the grooves are flush with the bottom of the column. You should also notice that the body of the column is simply a rectangle.

Select the clear rectangle tool from the tool palette. Then select the third line width in the border palette.

You will make a rectangle around the five grooves.

Position the cross-shaped pointer near the bottom left of the five grooves. Drag diagonally upward and to the right.
The grooves should be roughly centered horizontally in the rectangle. The bottoms of the grooves should extend beyond the bottom of the rectangle.

If the rectangle is not positioned correctly, you can choose Undo from the Edit menu and try again. When the rectangle is finished you can erase the rounded bottoms of the grooves.

Use the eraser to remove the bottoms of the grooves. Before dragging, press the Shift key to constrain the eraser's effects to a horizontal line.

If you miss and erase part of the rectangle, choose Undo and try again. Once the groove bottoms have been erased, the basic column for both Doric and Ionic capitals will be complete.

You should get into the habit of saving your work every 10 or 15 minutes. Should the unthinkable happen, you'll lose only a few minutes of your work.

Choose Save from the File menu. Name your document "Doric/Ionic". Click the Save button.
Add to the Scrapbook

You will eventually need a second column to complete the other half of this document. Rather than draw it again later, you'll store a copy in the Scrapbook so you can use it again.

The Scrapbook

The Scrapbook is a permanent storage space that can hold often-used text and graphics. You can add or subtract items from the Scrapbook as you wish. Since the contents of the Scrapbook are stored in the Scrapbook file on the disk, you have access to these items whenever you're using that particular disk.

Copy

To place a copy of an item in the Scrapbook, the first step is to select and copy it.

Use the lasso to select the column.

Remember, to select an item with the lasso, drag the lasso entirely around the object. The lasso "shrinks" to fit the selected object.

Choose Copy from the Edit menu.

The Copy command places a copy of the current selection on the Clipboard, a temporary storage area that can hold the selection as it is being moved or until you need it somewhere else in the drawing. The Clipboard holds only one selection at a time; copying another selection replaces the current contents of the Clipboard with the latest selection. That explains why something as important as the column should be kept in a permanent storage space like the Scrapbook. Also, since the
contents of the Clipboard are not stored permanently on the disk, turning off the Macintosh will erase the contents of the Clipboard.

Choose Scrapbook from the Apple menu.

(The Note: Because every Scrapbook is different, your Scrapbook will probably not look like the one shown above.)

The Scrapbook window displays the first of the images stored in the Scrapbook. The fraction in the lower left corner provides information about the Scrapbook images. For instance, the fraction "2/5" would mean that you were looking at the second of five stored images. (Make note of the current fraction on your Scrapbook.) If a Scrapbook is empty, there will be an "Empty Scrapbook" message in the window.

The gray bar across the bottom of the Scrapbook window is a scroll bar. Clicking within the bar, dragging the scroll box, or clicking the arrows at either end of the scroll bar allows you to look at different items in the Scrapbook. You cannot scroll through an empty Scrapbook.

You copied the column to the Clipboard just moments ago. Now you'll paste a copy into the Scrapbook.

While the Scrapbook is open, choose Paste from the Edit menu.

The Paste command inserts the current contents of the Clipboard into the Scrapbook. Under some circumstances, the Scrapbook window may be too small to show the entire image. Nevertheless, the entire image is stored in the Scrapbook.
Completing the Doric Capital

Note the change in the fraction in the lower left corner of your Scrapbook window.

The new fraction reflects the addition of one more image to the Scrapbook.

To close the Scrapbook, click in the close box, which is in the upper left corner of the Scrapbook window.

The Scrapbook window closes and MacPaint returns to the drawing window.

Now that the column is finished, you can complete the Doric capital. Look at the completed Doric capital. You'll begin by making the slanted underside of the Doric capital.

The Rubber Band Tool

Use the lasso to select the column. Position it in the center of the drawing window.

Select the rubber band tool in the tool palette. Then select the third line width in the border palette. Drag the pointer.

This tool makes a line that anchored to its starting point and connected with the pointer. The line remains connected to the pointer until the mouse button is clicked.

Drag the pointer to make a line approximately one inch long and angled at about 30° to the horizontal.

Select this line with the selection rectangle. Use the Option key and duplicate the line.
Choose Flip Horizontal from the Edit menu.

The selected line is flipped about its horizontal axis.

Flip Horizontal and the other commands in the lower half of the Edit menu (with the exception of the Fill command) work in conjunction with the selection rectangle only.

With the lasso, select and position both diagonal lines on the upper corners of the column.

Look at the completed example again. Now you'll need to make the very top of the Doric capital. This will be represented by a long, thin rectangle.

Use the unfilled-rectangle tool and the third line width in the border palette to make a long, relatively thin horizontal rectangle.

Select the rectangle with the lasso and maneuver it into position on top of the column.
You'll need to use the paintbrush to add some detail to the seam between the capital and the column. Look closely at the Doric column in the completed example. The current paintbrush shape is a little too large for that fine work, so you'll need to change the brush shape.

Choose Brush Shape from the Goodies menu.

A selection of all the available brush shapes appears.

Click on the smallest brush shape (bottom row, second from right).

No matter what size the paintbrush is, the Shift key will constrain the brush movements to horizontal and vertical lines only.

Make sure the current pattern is black. While holding down the Shift key, use the paintbrush to add the thin horizontal lines between the column and the capital.
Using FatBits

There may be a few parts of your Doric column that could use a little touching up. For instance, the horizontal lines between the column and the capital might need some extending or shortening. There is a way to do that kind of detailed work in MacPaint.

Choose FatBits from the Goodies menu.

FatBits allows you to alter MacPaint documents dot-by-dot. Virtually all MacPaint tools work while in FatBits, though in the enlarged scale, they may require some getting used to.

To see another section of the enlarged MacPaint drawing, you have to move the drawing while in FatBits. This is accomplished with the grabber.

Select the hand-shaped grabber from the tool palette and position it in the drawing window. Drag in any direction.

The FatBits window, like the drawing window, shows only a portion of the full page. The grabber allows you to push the MacPaint document around in the FatBit window.

Position the drawing so that the lines between the column and the capital are visible.
Select the pencil from the tool palette.

The pencil will draw in black if you begin on a white space. If you begin to draw on a dot, the pencil will erase any dot it runs into.

Look closely at the seam between the capital and the column. If some of the lines are shorter than they should be, extend them with the pencil. If they are too long, carefully erase them with the pencil.

Be sure to check the other side of the capital and column as well. When you are finished, get out of FatBits by choosing
FatBits once again from the Goodies menu.

It's about time to save your document once again.

Choose Save from the File menu.

To fill large areas with a pattern, you can use the paint can.

Select the paint can tool from the tool palette.

This tool fills closed areas with the currently selected pattern. Place the tip of the dripping paint can within any closed area (such as a closed loop or a solid black region), and then click. That area will be filled with the chosen pattern.

However, if the area you wish to fill has any gaps the pattern will leak out and fill a much larger area than you expected. If this should happen, proceed immediately to the Edit menu and choose Undo. Check your drawing closely and repair any leaks with the pencil in FatBits before using the paint can again.

It's a good idea to save your document just before using the paint can. If you don't catch a mistake in time to use the Undo command, you can choose Revert from the File menu. With Revert, your document (and the mistake) is replaced by the last saved version of the document.

Click on the gray pattern on the bottom row of the pattern palette, third from the left.

Position the paint can in the area outside of the grooves but still within the column. Click to fill the area.
With the same pattern, fill the upper portion of the capital. Click on the next darkest gray and fill the tapered section of the capital; then fill the grooves.

The Doric column and capital are now complete. Before beginning the Ionic column, practice with a few more MacPaint functions you'll need to finish the module.
Moving the Drawing Window

You have just completed one of the two capitals and columns needed for this document. Unfortunately, there probably isn't much room in the drawing window for the second capital and column. What you need to do is reposition the drawing window over the document page so you'll have room for the second capital and column. Only one-third of the entire page appears in the drawing window at any one time. With either the grabber or the Show Page command in the Goodies menu, you can easily move about the full 8" x 10" MacPaint drawing area.

Using Show Page

Choose Show Page from the Goodies menu.

A reduced view of the entire MacPaint page appears. The smaller dotted rectangle represents the drawing window's current position on the page. Now, you can either move the drawing window to another position on the page or you can move the entire drawing around the page.

To move the drawing window, you simply place the pointer inside the dotted rectangle and drag.

Position the pointer within the dotted rectangle. Drag and reposition the dotted rectangle so that it contains only the upper half of the completed Doric column and capital.

Click the OK button.
What you see inside the dotted rectangle while in Show Page corresponds with what you will see when you return to the standard MacPaint mode. When working on full-page drawings, Show Page makes it easy to return to any part of the page that may require further work.

Choose Show Page from the Goodies menu again.

You just practiced moving the drawing window around the page. You can also move the entire drawing around the document margins while in Show Page. To reposition the entire drawing, you place the pointer anywhere outside of the dotted rectangle and drag. Anything pushed beyond the document margins is erased when you leave Show Page.

Position the pointer anywhere outside the dotted rectangle and drag.
If you were to click "OK" now, the column and capital would be in a new position in the document. In the example above, clicking "OK" would place the capital and column in the lower left corner of the page.

Move the column back to the center of the page. Position the drawing window a small distance beneath the completed column.

Click OK.

Now you've given yourself some room to make the second capital. When you've finished both capitals, you will use Show Page once more to position the columns and capitals as in the completed example.
Creating the Ionic Capital

Many of the techniques used to make the Doric capital are also needed to make the Ionic capital. Because much of this should be familiar to you by now, the instructions are going to be in a much-shortened form. One suggestion—save your work after each step. Some mistakes are very difficult to correct. If you've saved after every step, you can always choose Revert from the Edit menu to correct such mistakes. While you may lose a few minutes of work by choosing Revert, it can save you more time than you would spend actually correcting those mistakes.

Like the Doric capital, the Ionic capital rests on a column. Remember the column you made for the Doric capital that was saved in the Scrapbook? Now you can reuse it here.

1. Copy the column from the Scrapbook and paste it into the drawing window.

   Open the Scrapbook, scroll through until you see the column, and choose Copy from the Edit menu. Close the Scrapbook and choose Paste. Since the column is still selected when it appears in the drawing window, you can drag it to the bottom center of the window. Now you have room to make the capital. Do not try to build the capital directly on top of the column. Make the capital above the column. It can then be selected and repositioned later.

Historically, Ionic capitals had spiral ornamentation. Because of the difficulty in drawing a smooth freehand spiral, the spirals will be approximated by a series of concentric circles. Remember how you duplicated the grooves for the column using the lasso and the Option key? Similarly, you will only make one set of concentric circles, even though the Ionic capital requires two. To make the second set, you'll duplicate the original with the lasso and Option key.

2. Use the unfilled oval tool and the Shift key to make several circles.

   The Shift key will constrain the unfilled oval tool so that it will make only circles.

   Use the lasso to position the circles within one another. Duplicate this set of concentric circles once it is finished.
The unfilled oval tool works like the rectangle tool—you simply drag diagonally. By holding the Shift key and dragging, the tool will produce only circles.

Do not try to make the circles within each other. Make them off to the side, select with the lasso and then position them within one another. Once you've made one "spiral," select and duplicate the whole thing with the lasso and the Option and Shift keys. The Shift key will keep the duplicate level with the original.

3. Use the rubber band tool with appropriate line widths to connect the spirals. Use FatBits, if necessary, to clean up the intersections of the lines and the spirals.
The Shift key will constrain the rubber band tool to horizontal, vertical, or 45°-angle lines.

4. Now select the entire capital with the lasso and position it on top of the column.

5. Use the paint can to fill the capital and column as shown.
6. Using Show Page, reposition the two finished column-and-capital combinations in the lower left corner of the page. Reposition the drawing window as shown.

7. Save your work.

In capsule form, you've just learned how to make an Ionic column. To finish the document you must add some explanatory captions with MacPaint text.
MacPaint's text function allows you to add words, sentences, and paragraphs to your drawings. Three menus in the MacPaint menu bar are devoted specifically to MacPaint text.

The Font menu allows you to select from a wide range of typefaces.

The FontSize menu allows you to choose from a variety of type sizes. Macintosh (and most typographers) use "points" to indicate the size of various typefaces—the higher the point number, the larger the font size.

The Style menu lets you emphasize words by creating bold, underlined, and italic text, as well as other options. The alignment commands allow you to align your text with the right edge, left edge, or center of a particular area of your drawing.

Use the grabber to position the drawing window directly to the right of the uppermost (Doric) column.

Select the text tool (the capital "A").

The pointer now looks like an I-bar.

Position the I-bar in the space between the capital and the edge of the MacPaint page. It should be centered horizontally and about as high as the top edge of the capital but not too close to the edge of the drawing window. Click the mouse button to set the insertion point.

The flashing insertion point will appear.

Type "Doric".
Press the Return key.

Type "Order".

Choose New York font from the Font Menu. Select 24 pt. from the FontSize menu. Choose Align Middle from the Style menu.

The text menus can be used to alter any text you've just typed. You can continually alter text until you reposition the I-bar and click the mouse button or until you select another tool. After that, the Font, FontSize, and Style of a particular block of text are fixed. If you decide you want to change the text later on, you have to erase and retype the text.

Position the I-bar underneath the "Doric Order" headline. Click the mouse button to set the insertion point. From the appropriate menus, choose New York, 12 pt., Plain text, and Align Middle. Type the following information about the Doric order.
Doric Order
Flourishing between the 6th and 5th centuries B.C., the Doric Order was characterized by its mathematical and exacting demands for proper proportion. For example, the ratio between any two sides of the Parthenon is always 9 to 4.

Ionic Order
Less severe and mathematically rigorous than the Doric Order, the Ionic Order had its heyday between the 5th and 1st centuries. Without the Doric rules for scale and proportion, Ionic architects designed a far wider variety of temples and secular buildings.

Except for the actual words, the procedures for adding text about the Ionic Order are identical to those used for the Doric Order.

Add the appropriate headline and text about the Ionic Order. Use the same Font, FontSize, and Style commands as used for the Doric Order text.

To make the "Grecian Orders" headline, move the drawing window to the top of the document using the Show Page command.

Select the text tool.
Set the I-bar in the middle of the drawing window. Use the following settings from the type menus: New York, 24 pt., Bold, and Align Middle. Type "Grecian Orders".

Finally, if there is room between the capitals and the historical information, add further identification labels to the diagrams. Refer to the completed example as needed.

Use the following settings: Geneva, 12 pt. (or smaller), Bold, and Align Right. (With Align Right, you position the insertion point where you want the right margin of the text to be.)

Use the rubber band tool to connect the labels with the appropriate part of the capitals.

You can now print your finished MacPaint page.

Choose Print Final from the File menu.

Make sure your Imagewriter is connected to the Macintosh and is turned on. For your information, Print Draft prints slightly faster but with a lower print quality.

Choose Quit from the File menu.

You're back at the Macintosh desktop.
Review

In this module, you've learned:

- How to use MacPaint's freehand drawing tools, specifically the pencil and the paintbrush
- How to correct mistakes by erasing or using the Undo command
- How to use the shape tools to create rectangles, rounded rectangles, egg shapes, and ovals
- How to select, reposition, and duplicate parts of your drawing with the lasso and selection rectangle
- How to Save and name your MacPaint document
- How to Cut, Copy, and Paste to and from the Clipboard and Scrapbook
- How to make straight lines of varying widths with the rubber band tool and the border palette
- How to use the Shift key to constrain shape tools, the rubber band, the paintbrush, and the movement of duplicated objects
- How to use FatBits to touch up and add small details to larger drawings
- How to move the drawing window around the page using the grabber and the Show Page command
- How to apply MacPaint's wide range of shades and patterns with the paint can
- How to add descriptions and labels to drawings with MacPaint's text functions
- How to print your finished document

What To Turn In

Turn in a copy of the finished document.
The Bean

Body of common seed plant: the bean

Unlike the columns in Doric/Ionic, the drawing done in the MacPaint module, the bean was drawn freehand, using the smallest paintbrush and the pencil. MacPaint's duplicating and flipping features helped reduce the time needed to draw the parts of the bean. For example, only the left cotyledon was drawn initially. Then it was duplicated and flipped horizontally. Parts of the duplicate were then erased and re-drawn so that the two cotyledons would be slightly different. The same procedure was used to make the leaves of the seedling.

MacPaint's text function produced neat, legible labels and these were connected to various points on the drawings with the rubber band. Show Page and the grabber were frequently used since both drawings are larger than the drawing window.
The earth's continental detail was added pixel-by-pixel with the pencil in FatBits. The oceans were added with the paint can using a grey from the pattern palette. The lines to the right of the earth were made with the rubber band. Two horizontal lines were drawn near each other, selected with the lasso, and then duplicated. The duplicate lines were then positioned underneath the original lines. This procedure was repeated until there were enough lines. Finally, all the lines were selected with the lasso, the ocean grey was selected from the pattern palette, and Fill was chosen from the Edit menu. The lines turned grey.

"EarthGram" was typed in Athens, 36 point, and selected with the lasso. The same grey used for the lines and oceans was selected from the pattern palette. Fill was chosen again. "EarthGram" turned grey. Another "EarthGram" was typed, selected with the lasso, and positioned over the grey letters to create the shadow effect.
1. Name the specific MacPaint tool, menu, or palette you would use to complete each task listed below. In some cases, a combination of tools, menus, or palettes may be required. (There is often several ways of completing the same task.)

   a) Drawing very detailed, fine work
   b) Drawing a very thick, wavy black line
   c) Drawing a very thick, wavy grey line
   d) Erasing (name at least three ways)
   e) Moving the drawing window about the document
   g) Drawing a perfect circle
   h) Filling a screen with perfect circles
   i) Move an entire drawing within the document margins
   j) Adding a pattern to an enclosed area
   k) Removing a pattern just added to an enclosed area

2. The Clipboard and Scrapbook are found in all Macintosh applications and work exactly as they do in MacPaint. Proper use of the Clipboard and Scrapbook can often save time and work when using Macintosh applications.

   In MacPaint, a drawing can be located in the drawing window, the Clipboard, the Scrapbook, or any combination of the three. For the following procedures, determine where the drawing(s) could be found.

   a) A drawing is selected with the lasso. Copy is chosen from the Edit menu.
   b) A drawing is selected with the lasso. Cut is chosen from the Edit menu.
   c) A drawing is selected with the selection rectangle. Copy is chosen from the Edit menu. The Scrapbook is opened and Paste is chosen from the Edit menu.
   d) Drawing A is selected with the selection rectangle. Cut is chosen from the Edit menu. Drawing B is selected with the lasso. Copy is chosen from the Edit menu.
   e) A drawing is on the Clipboard. It is not in the Scrapbook or in the document. The Scrapbook is not open. Paste is chosen from the Edit menu.
   f) A drawing is on the Clipboard. It is not in the Scrapbook or in the document. The Scrapbook is open. Paste is chosen from the Edit menu.

3. "Selecting" is an important action common to all Macintosh applications. You select menus. You select specific commands. You select documents and application icons before moving, duplicating, or opening them.

   In MacPaint, drawings can be selected in the drawing window with either the lasso or the selection rectangle. In what ways do these two tools work similarly? In what ways are they different? Which menu
commands work with both tools? Are there any menu commands that work only with the lasso? What are they? Are there any menu commands that work only with the selection rectangle? What are they?

4. While MacPaint's uses are as numerous as its users, the application is perhaps most commonly used for making announcement flyers. Make an eye-catching flyer describing an upcoming event. The flyer doesn't have to have any relation to any actual group or event. However, the flyer should include the name and nature of the event (party, debate, movie series, organizational meeting, etc.), the sponsors, date, time, and admission fee (if any). Use a few sizes and styles of text to emphasize important points. For decorative purposes, add an event or organization logo to the flyer as well as a map.
3
Word Processing

About Word Processing
Introduction to MacWrite
Advanced MacWrite
Introduction to Microsoft Word
Advanced Microsoft Word
Galleries
Exercises
About Word Processing

Word processing is the single most popular use of personal computers today. This is because word processing applications make it easy to compose, recompose, and reformat documents without erasers, correction fluid, or endless retyping.

Word processing software features the ability to add, delete, and move words, lines, and paragraphs in a snap, making it easy to make changes and correct errors. Thus, using word processing software significantly reduces the time it takes to create and edit a document. Also, some word processor users feel that the power to easily write, rewrite, and reformat their documents actually increases the quality of their writing.

Word processing involves three closely-related functions: typing, editing, and formatting.

Typing
Generally, to create a document, you simply type. The words you type are stored in the memory of the computer, and when you save your work, a copy of those words are stored on your disk.

Editing
The ability to easily edit, or change, the text you've typed is what makes word processing far more powerful than typing on a typewriter. Using a word processing application's editing functions, you can quickly move and change the words electronically without having to retype the entire document.

Formatting
Another job that word processing applications handle well is formatting the text you've typed. When you format a document, you determine what the document will look like when it is finally printed. Formatting
involves setting margins, tabs, indentation, and other similar attributes of your document.

To make this kind of formatting easier, the trend has been toward "What You See Is What You Get" (WYSIWYG) word processors, where the document appears on the screen of the computer exactly as it will appear when printed. The Macintosh's high resolution screen makes it well-suited for WYSIWYG word processing applications.

Integrating information from other applications has recently become an important feature of word processing software. The ability to insert a diagram or graph from a graphics application, a table from a spreadsheet, or even a paragraph from another word processing document can dramatically simplify the production of complex documents. The Macintosh's Cut, Copy, and Paste commands make this type of integration across applications possible.

MacWrite is a basic word processing application for the Macintosh, well-suited to short- and medium-length documents. While it may lack some of the more sophisticated features of other word processors, MacWrite has the advantage of being exceptionally easy to learn and use.

Notable features of MacWrite include:

**Multiple Fonts.** Like most Macintosh applications, MacWrite allows you to type in different typefaces, or fonts, in a variety of sizes and styles (boldface, italic, underlined, and others).

**Automatic Reformatting.** In MacWrite, any change in format (margin, tab, line spacing, page breaks, and so on) is displayed immediately on the screen so that it's always easy to see how your document will look when printed.

**Automatic Headers and Footers.** MacWrite allows you to automatically place headers and footers on each page, as well as providing for automatic page numbering.

**Integration.** MacWrite allows you to include charts, graphs, tables, and illustrations made using other Macintosh applications into your document.

**Search.** MacWrite allows you to find and replace any word (or partial word) in your document.
Microsoft Word starts with basic word processing features, and adds a number of additional features to handle long and more complex documents. These features include:

**Multiple Windows.** By allowing you to open as many as four windows, Word makes it easy to edit different documents or different parts of the same document simultaneously.

**Automatic Footnoting.** Word automatically numbers your footnotes and makes room for them at the bottom of each page, or at the end of a division.

**Special Formats.** Word can print documents in multi-column and other special formats.

**Glossary.** The glossary stores frequently used blocks of text or pictures for quick and easy insertion into the document.

**Print Merging.** Word's Print Merge command allows you to create customized form letters.
Introduction to MacWrite
The Task

Your classmates have honored you by choosing you to be coordinator of Tofu Fest 50, a festival celebrating the 50th anniversary of the introduction of tofu and other soybean products at your university. Your first step as the coordinator of this momentous occasion is to enlist the help of the local merchants. You'll need to draft a short, one-page letter to the merchants asking for their support and participation in Tofu Fest 50. Because MacWrite is well-suited to producing short documents, you'll use MacWrite to create and format your letter.

First, you'll type a draft of your letter. Then, you'll experiment with some of the basic MacWrite editing techniques, including selecting and replacing text and changing fonts.

Next, you'll use the basic formatting techniques found on the MacWrite ruler to set margins, paragraph indentation, line spacing, and alignment. You'll also use MacWrite's Cut, Copy, and Paste commands to move a block of text around in your document.

When you're finished, you'll save your new document and print a copy. The finished document should look like the one on the following page.
October 9, 1985

Dear Local Merchant:

As you know, this year marks the 50th anniversary of the introduction of tofu and other soybean products at this university. To celebrate this special demi-centennial, a number of student groups have joined to plan Tofu Fest 50, a week-long celebration of the spirit of soybean products and their role in university living.

To quote Jennifer Gaetz, head of the Student Soy Council and last year's Tofu Queen:

"The spirit of soy products has touched all of us on this campus. Never before has a food group created such feelings of camaraderie and togetherness. We truly are what we eat. As a result, the theme of this year's special festivities shall be 'Tofu Is You.'"

Minutes of preparation have gone into the planning and execution of the "Tofu Is You" campaign. We now need your support as a sponsor of this event to provide whatever money, supplies, or manpower you can donate to make Tofu Fest 50 the success we all want it to be.

Thanks in advance for your generous contributions.

Sincerely,

Julie MacCoy
Tofu Fest 50 Coordinator
Getting Started

First, you'll open MacWrite from the Macintosh desktop.

Turn on the Macintosh and insert your MacWrite disk—label side up and metal end first—into the built-in disk drive.

You'll soon see the Macintosh desktop with the icon of the MacWrite disk in the upper right-hand corner.

If necessary, double-click on the MacWrite disk icon to view the disk's contents.

Now you'll open MacWrite by double-clicking the MacWrite icon.

Double-click on the MacWrite icon to open MacWrite.

MacWrite opens a new document named "Untitled" in the MacWrite document window. If you're familiar with Macintosh windows, you should recognize the menu bar, the title bar, the close box, the scroll bar, and the size box. Inside the MacWrite document window are the ruler and a blinking vertical line, called the insertion point, which you'll learn more about later.

To create a MacWrite document, whether it be a letter to your first cousin or a marine biology term paper, all you need to do is type.

The blinking vertical bar marks the insertion point, the place where whatever you type will start.

Type "Dear Sir".
The words you type fill in behind the insertion point, as the blinking vertical bar moves to the right.

Removing text is as easy as pressing the Backspace key.

Use the Backspace key to remove "Sir" and replace it with "Local Merchant:".

Note that the Backspace key moves the insertion point backward, removing the letters and spaces. Holding down the Backspace key causes it to repeat, successively removing the characters to the left of the insertion point.

The Return key moves the insertion point down to the beginning of the next line, much like the carriage return key on an electric typewriter. You'll use it here to skip a line.

Press the Return key twice.

Word wraparound is a MacWrite feature that automatically starts a new line when you reach the right margin of your document. This means that you needn't press the Return key at the end of each line. You use the Return key only to start a new paragraph or to skip a line.

Type the following text without using the Return key:

As you know, this year marks the 50th anniversary of tofu and other soybean products at this university. To celebrate this special demi-centennial, a number of student groups have joined to plan Tofu Fest 50, a week-long celebration of the spirit of soybean products and their role in university living.
As you know, this year marks the 50th anniversary of tofu and other soybean products at this university. To celebrate this special demi-centennial, a number of student groups have joined to plan Tofu Fest 50, a week-long celebration of the spirit of soybean products and their role in university living.

Word wraparound makes it easy to type quickly, because you no longer have to worry about when to press the Return key. It also allows MacWrite to automatically reformat your paragraphs when you add or delete a sentence, change the margins, or change the text alignment.

Inserting new text into existing text is a simple matter of learning how to position the insertion point (that blinking vertical line that follows you when you type). To set a new insertion point, you'll need to use the mouse.

Position the pointer between the word "anniversary" and the word "of" in the first sentence.

As you know, this year marks the 50th anniversary of tofu and other soybean products at this university. To celebrate this special demi-centennial, a number of student groups have joined to plan Tofu Fest 50, a week-long celebration of the spirit of soybean products and their role in university living.
Notice that when you move the pointer from the menu bar or the scroll bar to inside the document window, the pointer changes to an I-bar. You'll use this pointer shape to set the new insertion point.

**With the pointer positioned directly before the word "of", click the mouse button to set the new insertion point.**

The new insertion point is now right before the word "of". That's where you'll insert a few extra words.

**Type "of the introduction" and a space.**

Note that the inserted text pushes everything after it out of its way, but word wraparound keeps things looking neat.

**Move the pointer (the I-bar) to the end of the paragraph and click to set the insertion point there.**

With the convenience of word wraparound, you may be tempted never to touch the Return key at all. Resist that temptation, though—you still need it to start new paragraphs and to skip lines. You'll use the Return key here to start a new paragraph, with a blank line separating it from the one you just typed.

**Press the Return key twice.**

Remember that Return—like most keys on the Macintosh keyboard—repeats if held down. If you get too many Returns, just backspace to remove them.

**Type the following:**

Hours of preparation have gone into the planning and execution of the "Tofu Is You" campaign. We now need your support as a sponsor of this event to provide whatever money, supplies, or manpower you can donate to make Tofu Fest 50 the success we all want it to be.

If it turns out that you've made a mistake (no one's perfect), MacWrite, like most Macintosh applications, allows you to undo your last action.

**Choose Undo Typing from the Edit menu.**
As you know, the 50th anniversary of the introduction of tofu and other soybean products at this university. To celebrate this special demi-centennial, a number of student groups have joined to plan Tofu Fest 50, a week-long celebration of the spirit of soybean products and their role in university living.

Hours of preparation have gone into the planning and execution of the "Tofu Is You" campaign. We now need your support as a sponsor of this event to provide whatever money, supplies, or manpower you can donate to make Tofu Fest 50 the success we all want it to be.

The last paragraph you typed is gone. But perhaps you've changed your mind and decided to keep that paragraph. You can undo the Undo command using Redo.

Choose Redo Typing from the Edit menu.

Your words return as quickly as they vanished. You'll see other uses for Undo and Redo later in the module. They're good commands to remember if you should make a major mistake—or just change your mind.

Now that you've learned how to type text to create your document, you may decide that you want to edit, or change, some of the things you've typed. Editing can be anything from deleting one letter to moving an entire paragraph. The important thing to remember is that no matter what type of editing you do, the general procedure will be the same:

First you make a selection. Then you act on that selection.

Making a selection means indicating which part of the document you wish to work with. To select text in MacWrite, simply drag across the appropriate text. To do this, position the pointer at the beginning of the word, hold the mouse button down, and drag the mouse to the right. When the pointer reaches the end of the word, release the mouse button.

Select the word "anniversary" in the first paragraph.
As you know, this year marks the 50th anniversary of the introduction of tofu and other soybean products at this university. To celebrate this special demi-centenniel, a number of student groups have joined to plan Tofu Fest 50, a week-long celebration of the spirit of soybean products and their role in university living.

Hours of preparation have gone into the planning and execution of the "Tofu Is You" campaign. We now need your support as a sponsor of this event to provide whatever money, supplies, or manpower you can donate to make Tofu Fest 50 the success we all want it to be.

Notice that the word "anniversary" is now highlighted. This is your visual indication that you've selected the right word.

You'll know if you've made a mistake because the word "anniversary" won't be highlighted. That's no problem, just try again.

A quicker way to select a single word is to double-click on it.

Double-click on the word "celebration" to select it.

Note that when you selected the word "celebration", the word "anniversary" became unselected. To avoid confusion (yours and MacWrite's), you generally make only one selection at a time. A new selection replaces your previous selection. So, if you want to cancel a selection (deselect), just click anywhere in your document.

Click the mouse anywhere in the document to deselect "celebration".

To select more than one word, just drag across them. Dragging the pointer down rather than across selects entire lines at a time.

To select the first paragraph, you would position the I-bar at the beginning of the paragraph, hold the mouse button down, drag down to the last line of the paragraph, and then continue dragging to the right until you reach the end of the line. Release the mouse button when the I-bar reaches the end of the line.

Select the entire first paragraph by dragging down and across.
Dear Local Merchant:

As you know, this year marks the 50th anniversary of the introduction of tofu and other soybean products at this university. To celebrate this special demi-centennial, a number of student groups have joined to plan Tofu Fest 50, a week-long celebration of the spirit of soybean products and their role in university living.

Hours of preparation have gone into the planning and execution of the "Tofu is You" campaign. We now need your support as a sponsor of this event to provide whatever money, supplies, or manpower you can donate to make Tofu Fest 50 the success we all want it to be.

Another shortcut to selecting large blocks of text is by shift-clicking. You do this by clicking to mark the start of your selection, moving to the end of the selection, and clicking the mouse button again while holding down the Shift key.

Mark the beginning of your document by clicking the mouse button before the word "Dear".

Clicking the mouse here serves two purposes: it deselects the previous selection and marks the beginning of your next selection.

Move the pointer to the end of the document (after "to be.").

Hold down the Shift key, then click the mouse button.
Changing Fonts

The entire area between your first click and your second is selected. This shortcut comes in especially handy when you're selecting a large piece of your document.

Practice selecting parts of your document until you're comfortable with the various techniques you've learned.

Selecting is an important part of using MacWrite. Make sure you know the selecting techniques before you continue.

You've learned the first half of the editing process—making the selection. Now you'll learn the second, how to do something to that selection.

Before continuing, click the mouse to deselect anything you might have selected.

Select the words "Tofu Fest 50" in the first paragraph by dragging across them.

You want to make these words stand out from the rest of the text. One way to do this is to change its typeface, or font. The Macintosh can use a variety of fonts, which are listed in the Font menu.

With the words "Tofu Fest 50" selected, choose Chicago from the Font menu.
Replacing a Selection

As you know, this year marks the 50-year anniversary of the introduction of tofu and other soybean products at this university. To celebrate this special semi-centennial, a number of student groups have joined to plan Tofu Fest 50, a week-long celebration of the spirit of soybean products and their role in university living.

Hours of preparation have gone into the planning and execution of the "Tofu is You" campaign. We now need your support as a sponsor of this event to provide whatever money, supplies, or manpower you can donate to make Tofu Fest 50 the success we all want it to be.

The words "Tofu Fest 50" are now in the Chicago font. The Chicago selection in the Font menu is checked. This font change nicely sets off these words from the rest of the text.

If you make a selection and type, your new words will replace the old selection.

Select "Hours" from the beginning of the second paragraph.

Remember, to select just double-click on the word.

Type "Minutes".

By typing "Minutes" while "Hours" was selected, you replaced your exaggeration with something a bit more truthful.

Formatting Techniques

When you format your document, you decide how it will look in its final form. This means setting the margins, tabs, indentations, line spacing, and text alignment that will appear when you print. You can have many different formats all within the same document.

Using Rulers

MacWrite uses rulers to set the format. The parts of a ruler are shown on the following page. While rulers appear in the document window, they aren't printed when you print your document.
When you start with a new (or "Untitled") document, MacWrite provides you with a preset ruler that you can use or change. This preset ruler sets the following format:

- A 1 1/8-inch left margin with no paragraph indentation
- A 1 1/2-inch right margin (at the 7-inch mark)
- A tab marker at the 5 1/2-inch mark
- Single spacing
- Left alignment

Though you can see only 1/8 inch of the left and right margins, the full margins will appear when you print your document. Think of yourself as looking through a small window at a standard page.

You can change these preset margins, add or move tabs, or change some other aspect of the preset format. You'll make some of these changes in the next paragraph you type.

**Position the insertion point at the end of your document.**

**Press the Return key twice and then type the following text:**

To quote Jennifer Gaetz, head of the Student Soy Council and last year's Tofu Queen:

The spirit of soy products has touched all of us on this campus. Never before has a food group created such feelings of camaraderie and togetherness. We truly are what we eat. As a result, the theme of this year's special festivities shall be "Tofu Is You."

All of the text no longer fits in your document window. To move
around in your document, you'll need to know how to use the scroll bars. If you don't remember how they work, here's a quick review.

So far in your document, you've used only one ruler to set the format for the entire document. MacWrite can use multiple rulers, allowing you to use different formats in the same document. Each ruler sets the format for the region between it and the following ruler.

You'd like to indent the quote you just typed and change the text style to make it stand out from the rest of the document. To indent it, you'll move both margins inward. Since you want to change the margins only for this one paragraph, you'll need to insert a new ruler to control formatting for this paragraph.

Inserting a ruler is much like inserting text: position the insertion point at the desired place and then insert the ruler using the Insert Ruler command in the Format menu.

Position the insertion point by clicking in the line after the phrase "Tofu Queen:"

Choose Insert Ruler from the Format menu.

A new ruler appears. Any formatting changes you make to this ruler will be reflected in the quote.

To change the right margins, you simply drag the right margin marker to the desired spot on the ruler.

To drag a margin marker, position the pointer on the marker, press and hold down the mouse button, and drag. When you have moved the
Drag the right margin marker to the left until you reach the 6 1/4-inch mark on the ruler.

If you accidentally miss the margin marker and click on the upper half of the ruler, you'll select it (the ruler will become highlighted). Don't worry—just move the pointer anywhere in your document, click, then try again. (Selecting rulers will be covered later.)

Another thing to notice is that you can't drag a margin marker past a tab marker. (Go ahead, try.) This is because it doesn't make sense to have a tab stop outside your document margins.

If you look closely at the left margin marker, you'll see that it looks a bit different from the right margin marker. This is because it's actually two different markers on top of each other.

The skinny black arrow is called the indentation marker. You use it to set the indentation of the first line of each paragraph. Remember that each time you press the Return key, you start a new paragraph. The position of the indentation marker determines where the first line of the paragraph will start.

It may take a few tries to pick up the indentation marker while leaving the margin marker behind. The best method is to position the pointer on the horizontal bar of the indentation marker, press the mouse button, and drag.
Drag the indentation marker to the ruler's 1 1/2-inch mark.

Minutes of preparation have gone into the planning and execution of the “Tofu Is You” campaign. We now need your support as a sponsor of this event to provide whatever money, supplies, or manpower you can donate to make Tofu Fest 50 the success we all want it to be.

To quote Jennifer Gaetz, head of the Student Soy Council and last year’s Tofu Queen:

The spirit of soy products has touched all of us on this campus. Never before has a food group created such feelings of camaraderie and togetherness. We truly are what we eat. As a result, the theme of this year’s special festivities shall be “Tofu Is You.”

Note that moving the indentation marker to the 1 1/2-inch mark on the ruler indents the first line of each paragraph. From now on, each time you press the Return key to start a new paragraph, MacWrite will move the insertion point to where you placed the indentation marker.

What would happen if you moved the left margin marker inside the indentation marker (to the right of it)?

Move the left margin marker to the 2-inch mark on the ruler.

Minutes of preparation have gone into the planning and execution of the “Tofu Is You” campaign. We now need your support as a sponsor of this event to provide whatever money, supplies, or manpower you can donate to make Tofu Fest 50 the success we all want it to be.

To quote Jennifer Gaetz, head of the Student Soy Council and last year’s Tofu Queen:

The spirit of soy products has touched all of us on this campus. Never before has a food group created such feelings of camaraderie and togetherness. We truly are what we eat. As a result, the theme of this year’s special festivities shall be “Tofu Is You.”
The first line is now "out-dented" and the following lines align to the new left margin.

This probably isn't the best format for the quote. You'd like to change your mind about that last action. Remember the Undo command?

Choose Undo Ruler Change from the Edit menu.

Remember that you can Undo only your last action. So be sure to choose Undo before you do anything else.

Drag the left margin marker to the 1 1/2-inch marker so that it lines up with the indentation marker.

Now the quote is nicely positioned.

The line spacing of your document is controlled by the three line-spacing boxes along the bottom of the ruler.

On both rulers the single-space box is highlighted, showing that single spacing is preselected for this document. To change the spacing, simply click the appropriate box.

Click the double-space box.

Minutes of preparation have gone into the planning and execution of the "Tofu is You" campaign. We now need your support as a sponsor of this event to provide whatever money, supplies, or manpower you can donate to make Tofu Fest 50 the success we all want it to be.

To quote Jennifer Geetz, head of the Student Soy Council and last year's Tofu Queen:

The spirit of soy products has touched all of us on this campus. Never before has a food group created such feelings

Everything you typed earlier now appears double-spaced. The middle box is for 1 1/2-spacing.

You'll probably agree that the original single-spacing looks best.

Restore single-spacing by clicking on the single-spacing box.
The four alignment boxes along the bottom right of the ruler allow you to vary the text alignment of your document. The preset ruler provides left alignment. To change the alignment, simply click the appropriate box. For center alignment, use the center-alignment box.

Click the center-alignment box.

Each line is now centered between the margins.

Similarly, for right alignment, use the right-alignment box.

Click the right-alignment box.

All lines are now flush up against the right margin. While this might not seem immediately useful, you're sure to come up with an appropriate occasion for right alignment.

With full justification, each line is aligned at both margins.

Click the full-justification box.

Note that typed lines that are ended by pressing Return (like the last line of a paragraph) are not aligned. Full justification works only with text that is word-wrapped.

You'll probably want to stick with left alignment for your letter.

Click the left-alignment box to restore left alignment.

You're back to where you started.
Sometimes the rulers clutter up the document so much that it's difficult to see what your document actually looks like. In these cases, it's helpful to hide the rulers.

Choose Hide Rulers from the Format menu.

You can now see the document without the rulers getting in the way. But what if you need to change the format?

Choose Show Rulers from the Format menu.

The rulers reappear.

You wanted to set the quote off from the rest of the text by changing the style of its text. MacWrite allows you to make your plain text italic, bold, underlined, shadowed, or outlined. It also allows you to combine these styles. To choose a style, or combination of styles, select the text and then choose the appropriate command from the Style menu.

In this case, you want the typestyle of the quote to be in italic.

Select the quote paragraph.

Remember, to select the paragraph, you can drag across the text or use the shift-click method.

Choose Italic from the Style menu.

The paragraph appears in italics.
Saving Your Work

It's a good idea to get into the habit of taking the time to save your work every 10 or 15 minutes. When you save a document, you place a copy of it onto your disk for safekeeping.

Every once in a great while, something unexpected may happen to cause your Macintosh to lose power. Because your Macintosh can't work without power, you might lose work that you were doing at the time. If you save frequently, you'll always have a recent backup copy.

Choose Save from the File menu.

The first time you save your document, a dialog box appears prompting you to give your document a name.

Type "Tofu Letter" followed by your initials as the name for this document.

Click the Save Button.

In a few moments, the dialog box disappears and your document is now saved on the disk. Now that your document is safe, feel free to take a small break.

Cut, Copy, and Paste

MacWrite's Cut, Copy, and Paste commands are powerful features that act on words, sentences, paragraphs, and rulers. These commands let you move blocks of text within a document or between documents without retyping.

Moving Text

In this case, you've decided to rearrange the paragraphs in your
document. You'd like the quote paragraph to come between the first and second paragraphs. You'll use Cut and Paste to move the quote paragraph above the second paragraph. The first step is to select the paragraph that you want to move.

Scroll to the last paragraph (beginning with "To quote").

When you move the paragraph, you want to save the formatting of the paragraph as well as the actual text. You can do this by moving the ruler controlling the format along with the text.

You'll use the shift-click method to select the block of text.

Position the l-bar before the words "To quote" and click.

Move the l-bar to the end of the quote (after "Tofu Is You."), then hold down the Shift key and click the mouse button.

Notice that everything in between the two clicks of the mouse is selected, including the ruler. Don't worry if the ending quotation marks don't appear to be a part of the current selection. Because of the italic typestyle, it appears as if it is not selected. You're now ready to use Cut.

Choose Cut from the Edit menu.

The selected area disappears. Choosing Cut removes the selected area and places it in a temporary holding area called the Clipboard.

Now you'll use the Paste command to transfer the selection from the Clipboard to its new location in the document.
Using the scroll bars, scroll until you reach the end of the first paragraph (the paragraph ends with "university living."), and click to set the insertion point after the final period that ends the paragraph.

Press Return twice to skip a line.

The vertical insertion bar should be flashing two lines below the first paragraph.

Choose Paste from the Edit menu.

A copy of the paragraph (with ruler) is pasted from the Clipboard into your document.

You can also remove an area by selecting it and pressing the Backspace key. However, when you use the Backspace key to remove a selection, the selection is not placed on the Clipboard, and you won’t be able to use the Paste command to reposition it.

A copy of the paragraph remains on the Clipboard even after you’ve pasted it. You can look at the contents of the Clipboard, just to be sure.

Choose Show Clipboard from the Edit menu.

The Clipboard window shows you that the paragraph is still there. If you want to see the whole paragraph, you’ll need to move and resize the window.

If you were to choose Paste again, you could insert another copy of the paragraph. This can be useful if you wish to make a number of copies of the same paragraph.

It’s important to remember that the Clipboard holds only one selection at a time. When you choose Cut or Copy from the Edit menu, your selection is placed on the Clipboard and remains there until you use Cut or Copy again.

Choose Hide Clipboard from the Edit menu.

You’ll notice that the formatting changes that you made to the quote paragraph were saved by moving the ruler with the paragraph.

Use the scroll bars to scroll so that the ruler you just moved is at the top of the screen.

Because a ruler controls the format of all text below it until the next ruler, the ruler you moved now controls the format for the paragraph below the quote. You’d like to return the paragraph below the quote paragraph to its original format. To do this, you’ll have to insert
another ruler between the quote and the last paragraph.

Since you want the format of the paragraph below the quote to match the format of the paragraph above the quote, you'll copy the top ruler and insert the copy after the quote.

Scroll up to the ruler at the top of the document, and select it by clicking anywhere in its top half.

The ruler becomes highlighted.

Choose Copy from the Edit menu.

When you choose Copy from the Edit menu, a copy of the ruler is placed on the Clipboard.

Scroll down to the end of the quote, and click to set the insertion point in the line between the paragraphs.

This is where you should paste the ruler.

Choose Paste from the Edit menu.

A copy of the ruler is pasted from the Clipboard and the text below reformats automatically.
You're almost done. You just need to change a few things before you're ready to turn in your document.

First you need to change the font of "Tofu Fest 50" in the last paragraph so that it is consistent with the first paragraph.

Select the words "Tofu Fest 50" in the last paragraph.

Choose Chicago from the Font menu.

You need to end your document with a little more typing.

Position the insertion point at the end of your document (after the phrase "want it to be.").

Press Return twice and then type "Thanks in advance for your generous contributions."

Now you'll type your closing and leave a space for your signature.

Press Return three times to skip two lines, type "Sincerely," and then press Return four times.

You've left a place to sign your name once it's printed, but now you need to type it. To make it stand out, you'd like to have your name be in boldface type.

You can change the style of the text as you type it by choosing the appropriate style from the Style menu, and then typing the text. You'll do that now with your name.
Underline
Superscript
Subscript

Choose Bold from the Style menu.

Type your name, then press Return.

You want the next line of text to be in plain text, so you need to change from the bold style.

Choose Plain Text from the Style menu.

Now type "Tofu Fest 50 Coordinator".

Like all proper letters, this one should have a date at the top of it. You'll add that now.

Scroll to the top of your document and click to set the insertion point before the first word of the letter.

Press Return four times since there should be some blank lines before the date.

Click on the line above the first line of text.

Notice that on the ruler there's a clear triangle marker at the 5 1/2-inch mark on the ruler. This is the preset tab and it's in the perfect position for your date. (You'll learn how to set tab markers in the Advanced MacWrite module.)

Press the Tab key to move the insertion point over to the 5 1/2-inch mark.

Type today's date and press Return twice.
Saving and Printing

Your letter is now finished and ready to be printed and sent out to the local merchants. But first you should save your document.

Choose Save from the File menu.

Since you saved your document earlier, there is already a name for your document. So this time when you choose Save, no dialog box comes up asking you to give your document a name. If you should want to save your document under a different name, choose Save As... from the File menu and you'll be prompted for another name.

Now that you've saved your work, you'll want to make a printed copy.

Make sure your printer is on, selected (the Select light should be on), and correctly connected.

Choose Print... from the File menu.

The standard Print dialog box asks you to set your print preferences each time you print.

Select High Quality by clicking in the circle next to High.

Since your document is only one page long, you don't need to worry about Page Range. If you wanted to print a portion of a larger document, you'd use Page Range to designate the numbers of the pages to be printed.

If you'd like multiple copies, enter the number in the box next to Copies.

Click OK to confirm your print settings.

In a few seconds, your document will begin to print.

Quitting

Choose Quit from the File menu.

You're back at the Macintosh desktop. Nice work.

Review

In this module, you've learned:

- How to create a MacWrite document by typing text
- How to select text by dragging across the words, double-clicking to select single words, and shift-clicking to select large blocks of text
- How to replace text by selecting it and typing
<table>
<thead>
<tr>
<th>What To Turn In</th>
</tr>
</thead>
<tbody>
<tr>
<td>Turn in the printed copy of your letter.</td>
</tr>
</tbody>
</table>

- How to change the font or style of the text using commands from the Font and Style menus
- How to format a document and change ruler settings for margins, indentations, line spacing, and text alignment
- How to use multiple rulers to create multiple formats in the document
- How to save your document on disk
- How to move or copy parts of your document (text or rulers or both) by using the Cut, Copy, and Paste commands
- How to print your document
Advanced MacWrite
The Task

Your letter to local businesses from the Introduction to MacWrite module is complete. Now you need to prepare a proposal to the University asking for funding, discussing what Tofu Fest 50 entails and how much it will cost.

A committee member has already started writing the proposal using MacWrite. His incomplete document is entitled "Tofu Proposal". You'll add the finishing touches to this document using MacWrite.

Since you'll want to use in your proposal the same quote from the Tofu Queen from your original letter, you'll learn how to copy text from another MacWrite document into your current one.

The committee member used MacDraw to create a diagram of the Tofu Pavilion and transferred it into the document. Unfortunately, its size and placement is off, so you'll learn how to resize and move pictures in MacWrite.

You'll also learn how to have headers and footers (text that appears on the top and bottom of each page), how to take advantage of MacWrite's automatic page numbering, and how to insert your own page breaks.

When you're finished, you'll save and print out your document, which should look like the one on the following pages.
Introduction
As you know, this year marks the 50th anniversary of the introduction of tofu and other soybean products at this university. To celebrate this special demi-centennial, a number of students groups have joined to plan Tofu Fest 50, a week-long celebration of the spirit of soybean products and their role in university living.

To quote Jennifer Gaetz, head of the Student Soy Council and last year's Tofu Queen:

"The spirit of soy products has touched all of us on this campus. Never before has a food group created such feelings of camaraderie and togetherness. We truly are what we eat. As a result, the theme of this year's special festivities shall be "Tofu Is You."

Let's work to make this the best Tofu Fest ever!

Tofu Pavilion
The Tofu Pavilion will be the focal point of Tofu Fest 50. The Pavilion will be completed by the 20th of November, with the stage, dunking pool, and decorations in place by opening day. See diagram below for details.
**Estimated Costs**

<table>
<thead>
<tr>
<th>Item</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tofu (1000 tons bulk)</td>
<td>$9,459.00</td>
</tr>
<tr>
<td>Tofu Queen's crown</td>
<td>$37.85</td>
</tr>
<tr>
<td>Pavilion rental fee</td>
<td>$2,050.00</td>
</tr>
<tr>
<td>Rental of exhibit tables</td>
<td>$873.99</td>
</tr>
<tr>
<td>Prizes</td>
<td>$2,345.67</td>
</tr>
<tr>
<td>Labor</td>
<td>$13,429.00</td>
</tr>
<tr>
<td>Miscellaneous</td>
<td>$999.99</td>
</tr>
</tbody>
</table>

-------------------------------

**Total** $29,195.50

**Proposal**

The Tofu Fest 50 committee would like the University to donate $29,195.50 to defer the costs of Tofu Fest 50. Of course it's possible that the University will need to take out a loan to provide the necessary funds. However, we believe this is a small price to pay for such a momentous occasion. The feelings of togetherness, school unity, camaraderie, and pride in the soybean as a food resource will be felt long after the University has made its last loan payment.
Getting Started

You'll begin by opening a MacWrite document from the Macintosh desktop.

Turn on the Macintosh, and insert your MacWrite disk—label side up and metal end first—into the built-in disk drive.

You'll soon see the Macintosh desktop with your MacWrite disk icon in the upper right-hand corner.

If necessary, double-click on your MacWrite disk icon to view the contents of your disk.

You should have an icon labeled "Tofu Letter", representing the document that you created in the previous MacWrite module. If you don't have this document on your disk, you'll need to go through the Introduction to MacWrite module to create the document.

In this module, you'll need to use your "Tofu Letter" document as well as the "Tofu Proposal" document that has been created and stored on the Approaching Macintosh Documents Disk. You will need to copy the "Tofu Proposal" document onto your MacWrite disk.

Copy the "Tofu Proposal" document to your MacWrite disk.

If you are unsure of how to do this, please see the Introduction to Macintosh module.

Make sure that both "Tofu Letter" and "Tofu Proposal" documents are on your MacWrite disk before you read any further.

Now you'll open the unfinished "Tofu Proposal" by double-clicking on its icon. Note that opening the "Tofu Proposal" document will automatically open MacWrite.

Double-click on the "Tofu Proposal" icon to open the unfinished document.

In a moment, the unfinished document appears.

Changing Text Styles

To make the proposal's headings stand out, you want them to be in boldface. You learned in the previous module that you can change text style by typing the text, selecting it, and then choosing a style from the Style menu.

Select the word "Introduction" at the beginning of your document.

You may have to scroll to get to the top of the document.
As you know, this year marks the 50th anniversary of the introduction of tofu and other soybean products at this university. To celebrate this special demi-centennial, a number of student groups have joined to plan Tofu Faire, a week-long celebration of the spirit of soybean products and their role in university living.

Let's work to make this the best Tofu Faire ever!

Tofu Pavilion
The Tofu Pavilion will be the focal point of Tofu Faire. The Pavilion will be completed by the 20th of November, with the stage, dunking pool, and

Choose Bold from the Style menu.

Do the same for the words "Tofu Pavilion" (midway through the document). Select them, and then choose Bold from the Style menu.

Remember the Tofu Queen's quote from the previous module? You'll want that same paragraph (including the formatting) in this document. Rather than typing that paragraph again, you'll use MacWrite's Copy and Paste functions to move a copy of the quote into your document.

Choose Close from the File menu.

A dialog box will appear asking you if you wish to save the changes you've made.

Click Yes to save your changes.

Your document is saved, then closed.

Choose Open... from the File menu.

The Open dialog box appears with a list of documents on your MacWrite disk. If your disk has a large number of MacWrite documents on it, you'll need to use the scroll bar to scroll through all of them.
Choose "Tofu Letter" by double-clicking on it.

Your letter appears.

Make sure that the rulers are visible. If they’re not, choose Show Rulers from the Format menu.

Use the scroll bars to scroll so that the quote paragraph (starting with "To quote") shows in the screen.
You'd like to keep the format for the quote paragraph intact when you transfer it to the proposal. To do this, you'll copy not only the text, but also the rulers that control the formatting.

Beginning with the words "To quote", drag through the document down to and including the ruler at the bottom of the quote paragraph.

Be sure that the rulers above and below the quote are selected (highlighted).

Choose Copy from the Edit menu.

A copy of the selected section and the formatting rulers is placed on the Clipboard.

Now you'll return to your "Tofu Proposal" document.

Close "Tofu Letter" by choosing Close from the File menu.

Open "Tofu Proposal" by choosing Open... from the File menu and double-clicking on the name of the document.

Although you're now in the "Tofu Proposal" document, the paragraph that you copied from the "Tofu Letter" document is still on the Clipboard.

Click to set the insertion point in the line after the first paragraph (in the line above "Let's work...").

Press Return to skip a line.
Now you'll paste the selection from your letter into your proposal.

**Choose Paste from the Edit menu.**

In a flash, a copy of your selection appears in your proposal—rulers and all.

![Image of MacWrite window](image)

It's a good idea to get into the habit of saving your work every 10 to 15 minutes. That way, if for some reason the power to your Macintosh goes out, you'll always have a recent backup copy of your work on disk.

**Choose Save from the File menu.**

Now you can breathe a little easier.

If you want to add a graph, diagram, or illustration to drive home your point, MacWrite is ready to oblige. Using the Cut, Copy, and Paste commands that you learned in the Introduction to MacWrite module, graphics from applications such as MacPaint or MacDraw can easily be inserted into your MacWrite document.

To copy a MacPaint graphic into a MacWrite document, you simply select the object while you were in MacPaint and choose Copy. As you've learned, choosing Copy places a copy of the current selection onto the Clipboard. Then you quit from MacPaint and open MacWrite. The copy is still on the Clipboard, so all you need to do is to position MacWrite's insertion point where you want the graphic to go, choose Paste and the graphic will be inserted. Note that this technique is very
similar to what you just did to copy the quote paragraph from one MacWrite document to another.

The Tofu Pavilion diagram already in your proposal document was created in MacDraw and then transferred to "Tofu Proposal" using the method described above.

**Scroll so you can see the entire Tofu Pavilion diagram.**

The Tofu Pavilion diagram is a bit too large for the document, and should be resized by shrinking it both vertically and horizontally. But before you can resize the diagram, you have to select it first.

**Select the diagram by clicking on it.**

A box will appear around the diagram with small black squares, called **handles**, along the bottom edge. The box shows that the diagram has been selected. You can't see the middle and left handles very well with this diagram, but they're there.

By dragging the handles, you can resize the diagram. The two corner handles allow you to drag diagonally, resizing the box horizontally and vertically, while the middle handle allows you to resize the picture vertically only. You'll use the bottom right handle, which resizes the box both vertically and horizontally.

To drag a handle, just position the mouse pointer on a handle, press the mouse button, and drag the mouse. An outline of the rectangle you're shaping follows you as you drag. Release the mouse button when the rectangle is the desired size and shape.
Drag the lower right handle up and to the left to compress the diagram about an inch each way.

Because the text in the diagram is being compressed as well, some of the words might become unreadable if compressed too much. You've now made the diagram a more appropriate size.

Unfortunately, the diagram is not quite in the right position yet. You'd like to have it centered on the page.

Select the diagram (if it isn't still selected).

As before, a box appears around the diagram, with handles along the bottom edge.

Using the mouse, move the pointer to the right edge of the box.

When you touch the pointer to the edge of the box, it should change from the vertical I-bar to an arrow-shaped pointer.

With the pointer in the shape of an arrow, press and hold down the mouse button. Drag the diagram to center it.
As you drag, an outline of the diagram follows you. When you release the mouse button, the diagram appears in its new location.

Click anywhere below the diagram to deselect the diagram.

The box disappears from around the chart, showing that the chart is no longer selected.

Don't worry if you see a thin grey line running across the screen. The line represents a page break—you'll learn more about page breaks later.

After the diagram, you'd like to add a table that lists the estimated costs of Tofu Fest 50. You'll format your table using both regular and decimal tabs. You'll insert the table after the heading "Estimated Costs".

Click to set the insertion point in the line after the words "Estimated Costs".

Scroll upwards to the end of the Tofu Queen's quote.

If the rulers are not showing, choose Show Rulers from the Format menu.

The ruler after the quote is the ruler that is controlling the formatting at the insertion point. But notice that on this ruler single spacing is in effect. However, you want your table to be 1 1/2-spaced.

Scroll down to where you set the insertion point.
Choose Insert Ruler from the Format menu.

This is the ruler you'll modify to make your table.

When you changed ruler settings in the Introduction to MacWrite module, you saw those changes affect everything below the ruler. You're going to make formatting changes to the new ruler, but you want these changes to affect the formatting of just the table and not the paragraph below the table.

To avoid changing the format of everything after the table, you'll insert two rulers, but you'll only make changes to the first one (the one you just inserted). When you choose Insert Ruler, the ruler that is inserted is a copy of the ruler above it. So if you insert another ruler now before making any changes to the one you just inserted, the formatting of the paragraph below will stay the same.

Press Return to skip a line.

Choose Insert Ruler from the Format menu.

You've now "protected" the paragraph below from any formatting changes.

Click in the 1 1/2-spacing box on the first of the two rulers.

The Macintosh uses two kinds of tabs: **regular tabs** and **decimal tabs**. Regular tabs work just like those on a typewriter, helping you to indent text or align columns. Decimal tabs set up columns of numbers so that the decimal point will align vertically. Decimal tabs are particularly useful for handling columns of currency.
Tabs are represented by tab markers, small hollow triangles placed along the ruler. Decimal tab markers can be distinguished from regular tab markers by the small decimal point in the center of the hollow triangle. MacWrite’s preset ruler has a tab stop at the 5 1/2-inch mark.

Tab markers are stored in a tab well. These are the little squares on the left of the ruler that have a picture of the appropriate tab marker.

You move a tab marker just as you move a margin marker—by dragging.

You’ll set the format for the table by setting a regular tab marker and a decimal tab on the ruler controlling the format for the table. You’ll get a regular tab marker from the regular tab well.

To drag a tab from a tab well, you position the pointer on the tab well. Press and hold down the mouse button and drag the tab up to the inch scale on the ruler. When the tab is at the position you want, release the mouse button.

Drag a regular tab marker out of the regular tab well, and set it at the 2-inch mark on the ruler.

Drag a decimal tab from the decimal tab well to the 5-inch mark on the ruler.

Remember that the decimal tab well is directly to the right of the regular tab well. Decimal tab markers look like regular tab markers, but have a decimal point in the center.
The ruler is now set for your table.

Click between the two rulers to set the insertion point for the table.

Press Return to insert a blank line.

Press the Tab key to move to the first tab stop and type "Tofu (1000 tons bulk)".

Note that the first tab—a regular tab—works just like a tab on a typewriter.

Press Tab to move to the decimal tab, and type "$9,459.00".

Press Return and then Tab to type the next line of the table.

Complete the table as shown.

Complete the table using the Return key to move to the next line and the Tab key to move to the next tab stop. Note that the decimal points in the second and third column line up underneath the decimal tab marker that you set earlier.

<table>
<thead>
<tr>
<th>Tofu (1000 tons bulk)</th>
<th>$9,459.00</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tofu Queen’s crown</td>
<td>$37.85</td>
</tr>
<tr>
<td>Pavilion rental fee</td>
<td>$2,050.00</td>
</tr>
<tr>
<td>Rental of exhibit tables</td>
<td>$873.99</td>
</tr>
<tr>
<td>Prizes</td>
<td>$2,345.67</td>
</tr>
<tr>
<td>Labor</td>
<td>$13,429.00</td>
</tr>
<tr>
<td>Miscellaneous</td>
<td>$999.99</td>
</tr>
<tr>
<td><strong>Total</strong></td>
<td><strong>$29,195.50</strong></td>
</tr>
</tbody>
</table>

Now's a good time to save your work.

Choose Save from the File menu.

The Find and Change commands found in the Search menu are powerful features of MacWrite. With these commands, you can locate
Finding and Changing the appearance of any word, combination of words, or partial word in your document, and change it quickly and easily.

The person who originally created this document was planning on calling this event the "Tofu Faire", but since then, the name has been changed to "Tofu Fest 50". You'll use the Change... command to find and change any appearance of the words "Tofu Faire".

Since both the Find... and Change... commands start their search from the insertion point, you should position the insertion point before the "Introduction" heading at the beginning of your document, so that the search will begin from there.

If necessary, scroll to the top of the document. Click right before the "Introduction" heading.

The text you should search for is the phrase "Tofu Faire". Any appearances should probably be changed to "Tofu Fest 50", but you'd like to "approve" of any substitutions before they are made. MacWrite's Change... command allows this.

Choose Change... from the Search menu.

The Change dialog box appears, prompting you to enter the phrase to change and what to change it to.

Type "Tofu Faire" in the Find what rectangle, and press the Tab key.

When you press the Tab key, the insertion point moves to the Change to rectangle. If you entered nothing in the Change to rectangle, MacWrite would simply remove each appearance of the words in your document.

Type "Tofu Fest 50" in the Change to rectangle.
Starting the Search

Find Next

Change, Then Find

The Partial Word choice at the bottom of the dialog box allows you to search for and change a portion of a word rather than a whole word. But you’re looking for whole words, so you should leave those settings unchanged.

Click the Find Next button to start the search.

Find Next finds the first appearance of the word after the insertion point in your document.

The first appearance of "Tofu Faire" is highlighted.

Click the Change, Then Find button.

MacWrite changes this first appearance of "Tofu Faire" to "Tofu Fest 50" and then locates the next appearance.

Using the Change, Then Find button gives you the opportunity to see each appearance of the word (or words) and confirm each change.

This next appearance of "Tofu Faire" you want changed to "Tofu Fest" and not to "Tofu Fest 50".

Close the dialog box by clicking in the close box.

"Tofu Faire" is still selected.

Type "Tofu Fest" to replace "Tofu Faire".

You can continue your search where you left off by choosing Change again.
Choose Change... from the File menu.

Notice how the rectangles still contain the words you typed.

You don’t need to confirm the rest of the changes, so you can use the Change All button. When you choose Change All, you are warned that you will not be able to undo this command, and given the opportunity to go ahead or cancel. If you go ahead, every appearance of the Find what is replaced by the Change to text.

Click Change All.

Click Go Ahead to continue with the Change All command.

All the necessary changes have now been made.

Close the Change dialog box by clicking in its close box in the upper left corner.

Adding a Footer

MacWrite allows you to add information at the top and/or bottom of each page. In these header and footer areas, you can put information such as page numbers, the current date, or the name of your document.

You'll now add a footer that includes the page number and the document name in boldface.

Choose Open Footer from the Format menu.

The Footer window appears.

MacWrite will be the focal point of Tofu Fest 50. The Pavilion will be completed by the 20th of November, with the stage, dunking pool, and decorations in place by opening day. See diagram below for details.
Automatic Page Numbering

Choose Bold from the Style menu.

Type "Tofu Fest 50 Proposal".

You're now ready to add the page number. MacWrite will number your pages automatically.

Above the ruler in the Footer window are three icons. The one to the far left, the number symbol (#), is the page-number icon. Using the mouse, drag the page-number icon to the right edge of what you just typed (right after the hyphen).

The correct page number will be automatically inserted in the document at the point where you placed the icon.

The other two icons above the ruler work in the same way. The calendar icon inserts the current date, and the clock icon inserts the current time.

Close the Footer window by clicking in its close box.

The footers now show up in your document window. (You may need to scroll to see them.)

If you don't want the footers to show in your document window, you can hide them by choosing Remove Footers from the Format menu. Once they're hidden, the Remove Footers command changes to Display Footers so you can always bring them back.

Displaying and Removing Footers
Headers work the same as footers, but appear at the top of each page. You won't use headers here, though.

Now you'll add a few final touches to your proposal.

Scroll through your document to read it over. The thin grey line you see after the footer represents the end of a page.

Depending on how much you compressed the Tofu Pavilion diagram, you may notice that the "Estimated Costs" heading appears awkwardly at the end of the first page. You'd like to move the heading to the next page so that it's right above the table.

To do this, you need to insert a page break so that the "Estimated Costs" heading starts a new page. Inserting a page break is like inserting enough blank lines to fill the current page. The effect is to push everything below the page break to the next page.

Click to set the insertion point before the words "Estimated Costs".

Choose Insert Page Break from the Format menu.

The heading moves from the last line on the first page to the top of the second page.

You can think of a page break as a space that expands or contracts whenever you add or remove text or graphics from the page.

You can select a page break by clicking anywhere in the empty area.
above the footer. The area will highlight, indicating that the page break is selected. If you want to delete the selected page break, simply press Backspace.

Saving Your Work

You've finished your proposal! You should save your changes before you quit.

Choose Save from the File menu to save your document.

In a few seconds, a copy of your finished proposal is saved on your MacWrite disk.

Printing a Copy

Choose Print... from the File menu to print a copy of your proposal.

Select high-quality printing and set the type of paper that you're using (cut sheet or continuous).

Now you're ready to return to the desktop.

Quitting

Choose Quit from the File menu.

You're back at the Macintosh desktop.

Review

In this module, you've learned:

• How to copy text and rulers from another MacWrite document by using Copy and Paste

• How to resize a graphic by selecting it and then dragging the appropriate handles

• How to move a graphic by selecting it, positioning the pointer on its border, and dragging it to its new position

• How to use the Change... command to replace every appearance of a word, or words, with something else

• How to insert a footer into your document, by choosing Open Footer and typing in the desired footer

• How to automatically number your pages by dragging the page-number icon to the appropriate place in your footer

• How to insert page breaks by choosing the Insert Page Break command

What To Turn In

Turn in a printed copy of your proposal.
Introduction to Microsoft Word
The Task

You have written the first draft of a research paper for a class (Anthropology 136, "Food and Culture") and you would like to revise it in this module. You'll learn the basic editing techniques used in Microsoft Word, how to use tabs, footnotes, and different formats for separate sections of the document (page numbering, page headers, and so on).

You'll use these techniques to fix any typos you made while typing the first draft; to create a title page, so that the paper has a more professional appearance; to include footnotes for which you did not have the proper citation when you typed your first draft; and finally, to include your name and the page number at the bottom of each page.

To do this module, you should be familiar with MacWrite. Many of the most basic text-entering and editing techniques described in that module will be required to do this one. If you have not already completed the MacWrite module, you should do so before starting this one.

When you are finished, you will print the revised version of your paper, which should look like the one on the next six pages.
The Wonderful World of Tofu

William J. Berner
Anthropology 136
Food and Culture
Introduction

Tofu is a food made from soybeans. Although not very popular in the United States (outside of California, anyway), it is very popular in the Far East. In Japan, for example, there are seven varieties of tofu that are widely used, and tofu is often an important protein source in the Japanese diet.

Nutritional Information

Tofu is high in protein, and can be used as a cheap protein source in many diets. Soybeans, tofu's main ingredient, yield more protein per acre than any other crop (Figure 1). In fact, soybeans are almost 35% protein. Furthermore, the protein in soybeans is complete (it contains all eight of the essential amino acids). Soybeans contain no cholesterol and almost no indigestible saturated fats.

Figure 1

Per Acre Protein Yields for Various Foods

<table>
<thead>
<tr>
<th>Food</th>
<th>% Protein</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dried frozen tofu</td>
<td>53</td>
</tr>
<tr>
<td>Fish</td>
<td>22</td>
</tr>
</tbody>
</table>
When evaluating the value of a food as a protein source, it is important to consider not only the quantity of protein in that food, but also the quality of the protein provided. Net Protein Utilization (NPU) is the measure usually used to compare the quality of protein found in different foods. Net Protein Utilization depends on a food's digestibility and the degree to which the eight essential amino acids making up the protein match the pattern required by the body. The table below lists the Net Protein Utilization of several different foods.

<table>
<thead>
<tr>
<th>Food</th>
<th>NPU (%)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fish</td>
<td>80</td>
</tr>
<tr>
<td>Beef and hamburger</td>
<td>67</td>
</tr>
<tr>
<td>Tofu</td>
<td>65</td>
</tr>
<tr>
<td>Chicken</td>
<td>65</td>
</tr>
</tbody>
</table>

The protein found in tofu is a good complement for that found in many grain products. Tofu contains an abundance of lysine, an essential amino acid that many grain products lack. As a result, tofu can be used as a protein booster by combining it with grain products, thus yielding a meal with a higher amount of usable protein than could be obtained by eating either of the foods separately.

Finally, tofu is an ideal diet food. Tofu contains only 9 calories per gram of protein, and only 12 calories per gram of usable protein. Tofu is also rich in minerals, with an abundance of calcium and iron.

The History and Culture of Tofu

A long and colorful history makes tofu as interesting historically and culturally as it is nutritionally. Tofu was known as early as 100 B.C. in parts of China. It became an indelible part of Chinese culture around 520 A.D. when Bhodidarma founded a great Zen school and engaged tofu in "Dharma combat" to prod tofu's understanding of the Buddha's way. He hailed its honest, straightforward nature and its "lovely white robes." Legends of Bhodidarma were passed on verbally; the earliest document to mention tofu was the *seitozoku*, written during the Sung Dynasty (960-1127).
Tofu was brought to Japan in the 6th century by numerous Buddhist monks. Although it appeared in Japan in the 6th century, tofu did not become a fixed part of Japanese culture until the Kamakura period. At that time, tofu blended well with the ruling Samurais' frugal life style.

As the use of tofu spread throughout Japan, the people developed their own methods of production, and Japanese tofu diverged somewhat from its Chinese counterpart in texture and flavor. When the Chinese Zen Master Ingen went to Japan in 1661, he was so taken aback with the form of Japanese tofu that he wrote this famous Japanese proverb:

Mame de
Shikaku de
Fawanka de

This proverb has a double meaning:

Made of soybeans,
Square, cleanly cut, or
And soft.
Practicing diligence,
Being proper and honest,
And having a kind heart.1

Indeed, this is only one of many Japanese proverbs centering around tofu. For instance, when a Japanese person wants to tell someone to "get lost" he may say, "Go bump your head against a corner of a cake of tofu and drop dead." Or when speaking of something as being hopeless, he might say, "It's as futile as trying to clamp two pieces of tofu together."2

In the United States, tofu is generally purchased at the supermarket, and only rarely bought from a specialty tofu shop or prepared at home. This is a shame, however, because the traditional tofu maker adds color and variety to the Japanese community. As Shurtleff says in The Book of Tofu, "[The tofu maker is] precise and graceful, joined in an effortless rhythm that, at times, [flows] like a dance." Tofu making is an art, and tofu makers are very careful to keep secret methods from slipping into a competitor's hands. In fact, traditional tofu masters have a saying that there are two things that they will not show another person: how to make babies and how to make tofu.3

2Shurtleff, p. 95.
3Shurtleff, p. 96.
Tofu reaches into one's life in a way that no other food can. Its historical and cultural value combine with outstanding nutrition to bring pleasure and protein to all those whose table it graces.
Bibliography


Getting Started

You'll begin by inserting the Microsoft Word disk into your Macintosh.

**Turn on the Macintosh and insert your Word disk—label side up and metal end first—into the built-in disk drive.**

You'll soon see the Macintosh desktop with the icon of your Word disk in the upper right-hand corner.

In this module, you'll need to use the "Tofu Paper" document that has been created and stored on the Approaching Macintosh Documents Disk. You will need to copy the "Tofu Paper" document onto your Word disk.

**Copy the "Tofu Paper" document onto the Word disk.**

If you are unsure of how to do this, please see the Introduction to Macintosh module.

Now you'll open "Tofu Paper" by double-clicking the "Tofu Paper" icon. Note that opening the "Tofu Paper" document will automatically open Microsoft Word.

**Double-click on the "Tofu Paper" icon on the Word disk to open the document.**

Word uses two symbols to show a page break, depending on what kind of page break it is. An equal sign, "=" is used to show a page break that Word inserts automatically, and a dotted line is used to show a page break that you tell Word to insert (more about page breaks in the Advanced Microsoft Word module).

Thus, when you first open a Word document, there is an equal sign in the upper left corner of the screen to indicate the beginning of the first page. Also note that a diamond is used to signify the end of the document.

The first thing you'd like to do is replace the abbreviation "U.S." in the first paragraph with "United States". To replace text, simply select what you want to change, and type the new text.

**Use the mouse to position the l-bar before the "U" in "U.S.", then press and drag across the full abbreviation.**

The text "U.S." is selected and should be highlighted.
The Selection Bar

Tofu is a food made from soybeans. Although not very popular in the United States (outside of California, anyway), it is very popular in the Far East. In Japan, for example, there are seven varieties of tofu that are widely used, and tofu is often an important protein source in the Japanese diet.

Nutritional Information

Tofu is high in protein, and can be used as a cheap protein source in many diets. Soybeans, tofu's main ingredient, yield more protein per acre than any other crop (Figure 1). In fact, soybeans are almost 35% protein. Furthermore, the protein in soybeans is complete (it contains all eight of the essential amino acids). Soybeans contain no cholesterol and almost no indigestible saturated fats.

Type "United States".

Notice that the selected text disappeared when you began typing "United States". This is because when you select text and then type, Word first clears the selection, and then inserts what you type in its place.

Dragging across text is the simplest way of selecting it. There are, however, other conventions in Word for selecting blocks of text easily.

Word uses a selection bar to provide other ways of selecting large blocks of text. The selection bar is located at the far left edge of your document.

Move the pointer into the selection bar just to the left of the text on the screen.

The pointer shifts right when you are in the selection bar.
Tofu is a food made from soybeans. Although not very popular in the United States (outside of California, anyway), it is very popular in the Far East. In Japan, for example, there are seven varieties of tofu that are widely used, and tofu is often an important protein source in the Japanese diet.

Nutritional Information

Tofu is high in protein, and can be used as a cheap protein source in many diets. Soybeans, tofu's main ingredient, yield more protein per acre than any other crop (Figure 1). In fact, soybeans are almost 35% protein. Furthermore, the protein in soybeans is complete (it contains all eight of the essential amino acids). Soybeans contain no cholesterol and almost no indigestible saturated fats.

Notice that there are two lines starting with "diets" that were accidently typed in the second paragraph. You'll remove one of them now.

While the pointer is in the selection bar, position it in front of the first line starting with "diets" in the second paragraph, and press the mouse button.

The entire line is selected and should be highlighted. When the pointer is in the selection bar, clicking in front of a line selects that line.

There are other ways to use the selection bar to select large blocks of text. For example, to select:

- a word: Double-click anywhere on the word.
- a sentence: Hold down the Command key and click anywhere inside the sentence.
- a paragraph: Double-click in the selection bar to the left of the paragraph.

Now you'll delete the line you've selected.

Press Backspace.

Backspace removes the selected text from the document.

Read the portion of the paper currently shown in the window.

The scroll bar lets you move a long document up or down in the
You want to insert a table showing the percent protein composition of different foods. You will put the table at the end of this paragraph, but first you will label it "Figure 2".

Position the insertion point at the end of the paragraph starting with "The quantity of protein..." by clicking after the word "protein.". 

Type in the following sentence (without pressing Return):

Figure 2 lists several foods and their percent protein by weight.

Press Return, and type "Figure 2". Then move the pointer into the selection bar, and click in front of the line you just typed.
The words "Figure 2" are now selected, and should be highlighted.

You would like "Figure 2" to appear in boldface.

Choose Bold from the Character menu.

The quantity of protein found in a food is usually measured as the percentage of the weight of a food that is protein. Figure 2 shows foods and their percent protein by weight.

**Figure 2**

When evaluating the value of a food as a protein source, consider not only the quantity of protein in that food, but the quality of the protein provided.

Soybeans are a very good protein source, as measured...

With Word, whenever you press return, you create a new paragraph. Therefore, the line containing "Figure 2" is a paragraph, and can be formatted using the appropriate commands from the Paragraph menu.

Choose Centered from the Paragraph menu.

Before you type in the table, it is necessary to deselect "Figure 2" and place the insertion point at the end of that line.

Use the mouse to position the l-bar to the right of "Figure 2" (which should be selected), and click.

The insertion point should now be after the "2" in "Figure 2".

Press Return.

Because Word copies the paragraph format from "Figure 2", the insertion point appears in the center of the screen. However, you would rather have the text of the table appear flush against the left margin.

Choose Left from the Paragraph menu.
Using Tabs

You are now ready to type in the information for the table. Because you will want the text to appear in two columns, you need to set appropriate tab stops.

Choose Tabs... from the Paragraph menu.

A ruler appears, with the Tabs dialog box below it.

The ruler displays the left and right margins, along with tab stops if any are set (in this case, none are). Notice that in the Tabs dialog box there are buttons to specify the alignment of characters about the tab stops (flush left, centered, flush right, or decimal point). You can also specify the "leader" characters that fill the space between text and tab stops. Leaders are especially useful for making forms that contain blanks, for example:

First Name____________________ Last Name____________________

(In this example, the underscore character was used as a leader.)

You insert a single tab by typing a distance (0.5 inch, 1.0 inch, and so on) in the Position box, and then clicking OK. Tabs can also be inserted by clicking at the appropriate place on the ruler.

Set the first tab stop at the 1-inch mark by moving the pointer into the area just below "1" on the ruler and clicking.

A tab marker appears at the place you clicked, indicating that the tab is set.
Note that you must click on the lower portion of the ruler, below the numbers. Also note that the position of your tab setting appears in the dialog box.

If you insert the tab in the wrong spot, you can use the mouse to reposition it by dragging it left or right to the appropriate position. You can also remove a tab by dragging it off the bottom of the ruler.

Your table will have two columns. The first will contain text labels, and the second will contain numbers. Because the second column will contain only numbers, you'll use a decimal tab, to force the decimal points for all of the numbers to line up.

Click Decimal for Alignment. Then set an additional tab at 4 inches by moving the pointer to the appropriate spot on the ruler and clicking.

You should now have two tabs set. One at 1 inch, and one at 4 inches.

When you are done, click OK.

You are ready to type column headings for your table.

Press Tab, and then choose Underline from the Character menu.

Now type "Food", then press Tab. Finally, type "% Protein", then press Return.
The formatting for your paper is set so Word automatically inserts a blank line between paragraphs, that is, each time you press Return. For the main text of the paper, this is fine, because you want a blank line between paragraphs. But you would not like a blank space between the lines of the table; therefore, you will use the Formats... command from the Paragraph menu to change this.

Press Backspace to delete the line you just inserted, then choose Formats... from the Paragraph menu.

A dialog box appears. Here you can specify a paragraph's left and right indentation, as well as the indentation of its first line (from the left edge of the paragraph).

You can also specify line spacing. Auto is the preset value; it means that Word adjusts spacing between lines automatically. Use Space Before and Space After to insert extra space before or after the paragraph.

The buttons on the lower left specify the alignment of the paragraph on the page (flush left, flush right, or center), and the boxes in the lower right can be used to ensure that certain paragraphs or lines are kept on the same page.

Notice that the entry in the Space After box is "1 li". This means that Word will insert one blank line after the paragraph. You'll change this value to 0 now.
Select the text in the Space After box by dragging across it. Then type "0 li". When you are done, click OK.

You are now ready to type in data for the table. The headings for the table are underlined, but you don't want the data for your table to be underlined. When you insert text, Word formats the new text exactly like the text immediately preceding the insertion point, so you'll need to specify plain text formatting before typing the rest of the table.

Choose Plain Text from the Character menu and press Return. Then enter the following text for the body of the table, being sure to press Tab before each entry, and Return at the end of each line:

<table>
<thead>
<tr>
<th>Food</th>
<th>% Protein</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dried frozen tofu</td>
<td>53</td>
</tr>
<tr>
<td>Fish</td>
<td>22</td>
</tr>
<tr>
<td>Chicken</td>
<td>21</td>
</tr>
<tr>
<td>Beef</td>
<td>20</td>
</tr>
<tr>
<td>Tofu</td>
<td>8</td>
</tr>
</tbody>
</table>

Your table should now look like this:

Before going any further, you'll save the changes you've made so far.

Choose Save from the File menu.

It's a good idea to save your documents often. This way you won't lose very much work if the power goes off unexpectedly (or when your roommate trips over the power cord).
Read over the next paragraph. When you are done, set the insertion point at the end of that paragraph (after the word "provided.")", and type "Net Protein Utilization (NPU)".

Word has a glossary feature which allows you to store frequently used text for easy retrieval. Because you'll be typing the phrase "Net Protein Utilization" quite often, it would be a good idea to store that phrase in the glossary.

Select the text "Net Protein Utilization" (by clicking and dragging across it). Then choose Copy from the Edit menu.

This stores the text on the Clipboard. Now, all you need to do is paste it into the glossary.

Choose Show Glossary from the Edit menu.

This activates the glossary window.

The current glossary entries are displayed on the right side of the window. The words "page" and "footnote" appear because page and footnote are predefined glossary entries. To define a new entry, you must type in a name and paste in the text.

Type "NPU" (for Net Protein Utilization).

This is your entry name. From now on, you'll be able to type this name in your document, and then use the glossary to expand it into the full phrase.
Using a Glossary Entry

Choose Paste from the Edit menu.

This completes the entry.

Close the glossary window by clicking in its close box or choosing Close from the File menu.

Select the insertion point to be after "(NPU)", then type:

is the measure usually used to compare the quality of protein found in different foods. NPU

Hold down the Command key and press Backspace.

Fish

Chicken

Beef

Tofu

When evaluating the value of a food as a protein source, it is important to consider not only the quantity of protein in that food, but also the quality of the protein provided. Net Protein Utilization (NPU) is the measure usually used to compare the quality of protein found in different foods. Net Protein Utilization

-Soybeans are a very good protein source, as measured by both the quantity and quality of protein that results from soybean production.

The protein found in tofu is a good complement for that found in many grain products. Tofu contains an abundance of lysine, an essential amino acid that many grain products lack. As a result, tofu can be used as a protein booster by combining it with grain products, thus yielding a meal with a higher amount of usable protein than could be obtained by eating either of the

Presto! "NPU" expands into "Net Protein Utilization".

Type in the remainder of the paragraph. Don't forget to use the glossary expansion for "Net Protein Utilization".

depends on a food's digestibility and the degree to which the eight essential amino acids making up the protein match the pattern required by the body. The table below lists the NPU (Command-Backspace) of several different foods.

You are now ready to type in the third figure for your paper. (The chart at the beginning and the table you inserted were the first two.) This will be a table very similar to the last one, but the steps are listed in case you have forgotten. The insertion point should be after the word "foods."). Set it there if it is not already.
Press Return.

Word inserts a blank line, and you are ready to type the table heading.

Choose Bold from the Character menu, and then type "Figure 3".

Next, format it correctly.

Choose Centered from the Paragraph menu, then press Return.

You're ready to type in the table, but first you must format it correctly.

Choose Left and then Tabs... from the Paragraph menu.

You'll set tabs for the table.

Set two tab stops. One with left alignment at 1 inch and one with decimal alignment at 4 inches by clicking the correct alignment buttons, and then clicking at the appropriate spots on the ruler. When you are finished, click OK.

Press Tab, then choose Underline from the Character menu.

Type "Food", press Tab, and finally type "NPU (%)".

You'll change formats so that there is no blank line between paragraphs.

Choose Formats... from the Paragraph menu.

A dialog box appears.

Change the value for Space After to "0 li". When you are finished, click OK.

Now you'll type in the NPU data.

Choose Plain Text from the Character menu and press Return.

Then type in the following text for the body of the table.

(Don't forget to press Tab after each entry, and Return at the end of each line.)

<table>
<thead>
<tr>
<th>Food</th>
<th>NPU (%)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fish</td>
<td>80</td>
</tr>
<tr>
<td>Beef and hamburger</td>
<td>67</td>
</tr>
<tr>
<td>Tofu</td>
<td>65</td>
</tr>
<tr>
<td>Chicken</td>
<td>65</td>
</tr>
</tbody>
</table>
Moving Paragraphs

used to compare the quality of protein found in different foods. Net Protein Utilization depends on a food’s digestibility and the degree to which the eight essential amino acids making up the protein match the pattern required by the body. The table below lists the Net Protein Utilization of several different foods.

Figure 3

<table>
<thead>
<tr>
<th>Food</th>
<th>NPU (%)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fish</td>
<td>60</td>
</tr>
<tr>
<td>Beef and hamburger</td>
<td>67</td>
</tr>
<tr>
<td>Tofu</td>
<td>65</td>
</tr>
<tr>
<td>Chicken</td>
<td>65</td>
</tr>
</tbody>
</table>

Soybeans are a very good protein source, as measured by both the quantity and quality of protein that results from soybean production.

The protein found in tofu is a good complement for that found in many grain products. Tofu contains an abundance of isoleucine, an essential amino acid that

Before going on, remember to save the changes that you’ve made so far.

Choose Save from the File menu.

The paper would read better if the next paragraph came before the two tables that you just inserted. Word’s selection bar and its special conventions for moving and copying text with the mouse make moving paragraphs easy. To move blocks of text with the mouse, just select the text that you want to move, use the mouse to position the I-bar where you want to move the text, and, while holding down the Shift and Option keys, press the mouse button.

Use the mouse to move the pointer into the selection bar anywhere to the left of the paragraph starting with "Soybeans are a very good...". Then double click.
used to compare the quality of protein found in different foods. Net Protein Utilization depends on a food's digestibility and the degree to which the eight essential amino acids making up the protein match the pattern required by the body. The table below lists the Net Protein Utilization of several different foods.

**Figure 3**

<table>
<thead>
<tr>
<th>Food</th>
<th>NPU (%)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fish</td>
<td>80</td>
</tr>
<tr>
<td>Beef and hamburger</td>
<td>67</td>
</tr>
<tr>
<td>Tofu</td>
<td>65</td>
</tr>
<tr>
<td>Chicken</td>
<td>65</td>
</tr>
</tbody>
</table>

Soybeans are a very good protein source, as measured by both the quantity and quality of protein that results from soybean production. The protein found in tofu is a good complement for that found in many grain products. Tofu contains an abundance of isoleucine, an essential amino acid that

The paragraph is selected and should be highlighted. When the pointer is positioned in the selection bar, double-clicking selects the entire paragraph.

Now you'll move the I-bar to the position where you would like to move the selected text.

**Click in the grey bar above the scroll box until the chart appears on the screen.**

The paragraph starting with "The quantity of protein found..." should be right below the chart.

Position the I-bar directly before the "T" at the beginning of the paragraph starting with "The quantity of protein..." and, while holding down the Shift and Option keys, press the mouse button.
The selected text moves into position just below the chart.

Note that if you accidentally clicked before holding down the Shift and Option keys, you will have deselected the text that you wanted to move. Use the scroll bar to move the paragraph starting with "Soybeans are a very good..." into view, reselect it, and try again.

You've moved backward a few screenfuls, so you'll have to catch up.

Reading as you go, scroll through the document until you come to the boldface header for the next section. The title of the next section is "The History and Culture of Tofu".

Read the first several paragraphs of this section, stopping after the paragraph beginning with "Indeed, this is only one...".

You want to include a footnote to cite the source that you used for this information.

Use the mouse to position the I-bar at the end of the paragraph (after the word "together."), and click.

Choose Footnote... from the Document menu.
Indeed, this is only one of many Japanese proverbs centering around tofu. For instance, when a Japanese person wants to tell someone to “get lost” he may say, “Go bump your head against a corner of a cake of tofu and drop dead.” Or when speaking of something as being hopeless, he might say, “It’s as futile as trying to clamp two pieces of tofu together.”

In the United States, tofu is generally purchased at the supermarket, and only rarely bought from a specialty tofu shop or prepared at home. This is a shame, however, because the traditional tofu maker adds color and variety...

A dialog box appears, asking if you would like an **Auto-numbered Reference**, or a **Footnote Reference Mark**.

If you choose Auto-numbered Reference, Word will number your footnotes for you. If you add or delete footnotes, Auto-numbering will also renumber. Alternatively, you can specify a Footnote Reference Mark (the Footnote Reference Mark appears in your document text to indicate the corresponding footnote text). A Footnote Reference Mark can be a letter, a number, or a phrase up to 10 characters long. For this paper, you want an Auto-numbered Reference.

**Click OK.**

Word places a "2" in your document, divides the screen in two, and also places a "2" in the lower window. The top window contains your document. The bottom window is the footnote window, the place where you insert your footnote text. A "2" has been inserted because this is this document’s second footnote (you may have seen the first on the previous screen). The reference for this footnote is the same as that for the last footnote, so you only have to type the author’s name and the page number.

**Type "Shurtleff, p. 95.".**

Because this footnote is a reference in a paper, you need to indent the first line of the reference.
may say, "Go bump your head against a corner of a cake of tofu and drop dead." Or when speaking of something as being hopeless, he might say, "It's as futile as trying to clamp two pieces of tofu together."²

In the United States, tofu is generally purchased at the supermarket, and only rarely bought from a specialty tofu shop or prepared at home. This is a shame, however, because the traditional tofu maker adds color and variety to the Japanese community. As Shurtleff says in The Book of Tofu, "The tofu maker is precise and graceful, joined in an effortless rhythm that, at times, [flows] like a dance." Tofu making is an art, and tofu makers are very careful to keep secret methods from slipping into a competitor's hands. In fact, traditional tofu masters have a saying that there are two things that

²Shurtleff, p. 95

Choose Formats... from the Paragraph menu.

A dialog box appears.

Double-click in the box labeled First Line, and type ".5". Then click OK.

The first line of your footnote "paragraph" is now indented 0.5 inch.

Look at the black line that divides the main text of your document from the footnote window.
may say, "Go bump your head against a corner of a cake of tofu and drop dead." Or when speaking of something as being hopeless, he might say, "It's as futile as trying to clump two pieces of tofu together.

In the United States, tofu is generally purchased at the supermarket, and only rarely bought from a specialty tofu shop or prepared at home. This is a shame, however, because the traditional tofu maker adds color and variety to the Japanese community. As Shurtleff says in *The Book of Tofu*, "The tofu maker is precise and graceful, joined in an effortless rhythm that, at times, [flows] like a dance." Tofu making is an art, and tofu makers are very careful to keep secret methods from slipping into a competitor's hands. In fact, traditional tofu masters have a saying that there are two things that

2Shurtleff, p. 95.

The small black box in the scroll box is called the *split bar*. You can close the footnote window by dragging the split bar off the screen (more on using multiple windows later).

**Close the footnote window by dragging the split bar to the bottom of the screen.**

The footnote window disappears.

**Read the rest of the text on the screen, then scroll to see the next screen.**

**Using Running Heads**

A *running head* is a block of text that appears on every page of the division (more on divisions later). Next, you'll create a running head so that your name and the page number appear at the bottom of each page. You can define a running head anywhere in the document, but it will not appear on any pages coming before the definition of the running head. Because you want your name and the page number to appear on each page, you must put your running head at the beginning of the document. If you defined the running head where you are working now, it would not appear on the first few pages of the document.

So that you don't lose your place when you insert the running head at the beginning of the document, you can use another of Word's features: *split windows*. With split windows, you can look at two parts of the document at the same time. This becomes useful when you are working at one location in the document and you need to briefly edit another without losing your place.
You'd also use split windows to quickly get information from one part of the document to insert in another. For example, you might want to look up the information about one of your sources in the bibliography while you were making a footnote citation.

Look closely at the scroll bar at the right edge of the screen. The small black box at the top is called the split bar. (You may remember seeing it when you were working with footnotes.)

 Drag the split bar approximately halfway down the scroll bar. Then release the mouse button.

 You now have two windows with the same file in them—two views of the same document. Both windows really do contain the same file; if you make changes in one window, they will appear in the other. Notice that both windows contain scroll boxes along the right edge of the window.

 Drag the scroll box for the bottom window up as far as possible.

 Notice that although you've moved to the beginning of the document in the lower window, the text in the top window doesn't move.

 You are now ready to type the text of your running head.

 Use the mouse to position the I-bar underneath the title of the paper, "The Wonderful World of Tofu", and press the mouse button to set the insertion point.
Type your name.

The text that you type will be in boldface. Whenever you insert text, it is formatted the same way as the text immediately preceding it.

Type "The Wonderful World of Tofu".

You would like the page number to appear to the right of your name. The easiest way to insert a space between your name and the page number is to set a tab stop.

Set a tab stop at the 5-inch mark by choosing Tabs... from the Paragraph menu, and typing "5". When you are finished, click OK.

Press Tab.

Remember that one of the predefined glossary entries was named page. You can insert the page number into your running head by expanding the page glossary entry.

You use the page glossary entry as you would any other. First you type the name of the entry, and then you expand it. The actual page number will not appear until you print the document, but Word places the glossary name in parentheses so that you will know that it's an expanded glossary entry.

Type "page", then expand the glossary entry by holding down the Command key and pressing Backspace.

Using the Page Glossary Entry
cultural value combine with outstanding nutrition to bring pleasure and protein to all those whose table it graces.

Bibliography

* The Wonderful World of Tofu
William J. Berner. *The Wonderful World of Tofu* (page)

Introduction
Tofu is a food made from soybeans. Although not very popular in the United States (outside of California, anyway), it is very popular in the Far East. In Japan, for example, there are seven varieties of tofu that are widely used.

"Page" appears as "(page)".

For the running head, you would like to have the text appear with plain character formatting.

Use the mouse to position the pointer in the selection bar to the left of your name, and press the mouse button.

The entire line is now selected, and should be highlighted. If it is not, the pointer was probably not positioned directly to the left of your name. Try again.

You would now like to format the paragraph as plain text.

Choose Plain Text from the Character menu.

Finally, you need to specify that this text is a running head so that it will appear on every page in the division (divisions will be explained more fully later).

Choose Running Head... from the Document menu.

A dialog box appears.
Here you can specify on which pages the running head is to appear (odd, even, and the first page) and whether it will appear at the top or the bottom of the page. The default is to have the running head appear on both odd and even pages, but not on the first page, and to have it positioned at the top of the page. You would like the running head to be at the bottom of the page.

Click the button labeled "Bottom", then click OK.

A "α" appears in the left margin to mark a running head. Remember that you can place the text for a running head anywhere in a document, but it will only appear on pages after its definition.
A document can be divided into different sections or divisions so that you can format them differently.

Different divisions can have unique running heads, as well as different styles of page numbering. In a longer manuscript (such as a thesis or a book), there may be many divisions with similar running heads, although the text of the running heads will not be the same for all divisions. For example, the running head for a chapter might be the chapter's title, so each chapter would have to be a separate division. There may also be sections (such as a preface or an appendix) in which you want to use a different style of numbering entirely (perhaps Roman numerals rather than Arabic ones).

You'll create a title page, and you'd like it to be in its own division.

Click after the word "Tofu" in the title.

Hold down the Command key and press Enter.

A double line appears at the border between two divisions.

You can change the format of a division with the Division Layout command.

Click anywhere below the double line (the division line), then choose Division Layout... from the Document menu.

A dialog box appears.
Here is an overview of the division settings:

**Break.** This changes the way that page breaks occur when you start a new division. You can have the old division format continue until the next page (continuous), the old division format continue until the next column (for multicolumn documents), a new page start with the new division (this is the preset value), or you can have the new division start on the next even- or odd-numbered page.

**Page Number Format.** You can have page numbers appear as Arabic numerals (1, 2, 3,...), upper-case Roman numerals (I, II, III,...), lower-case Roman numerals (i, ii, iii,...), or letters (lower case—a, b, c,..., or upper case—A, B, C,...).

**Footnotes Appear.** Footnotes can appear at the bottom of the page, or at the end of the division.

**Auto Page Numbering.** You can have Word number your pages automatically. You specify the position at which the page numbers will appear, as well as the number that begins the sequence.

**Running Head Position.** You specify a distance from the top or bottom of the page, depending on whether the running head is a header or a footer (appears at the top or bottom of the page, respectively).

**Number of Columns.** You can make a division multi-columned. Note that when you do this, you'll see only one long continuous column. You must print the document to see how it actually looks.
You'll tell Word to number your division starting from 1. This way, page numbering will not include the title page.

Click inside the box labeled Start Page Numbers At, then type "1". Finally, click OK.

However, remember that Word will not print the running head on the first page of the division.

Now you'll add the course number and title to the title page.

Click after the word "Tofu" in the title, press Return, and type your name.

Press Return, and type in the following two lines to complete the title page:

Anthropology 136
Food and Culture

To make the title stand out from the rest of the text on the page, you can insert some extra space after the paragraph containing the title.

Click anywhere inside the line "The Wonderful World of Tofu" in the title page division and choose Formats... from the Paragraph menu.

A dialog box appears.

Set the values of Space Before and Space After to "10 li".
When you are done, click OK.

Remove the second window by dragging the split bar to the bottom of the screen.

Your revision is now complete. All you need to do is print out the document.

Choose Print... from the File menu.

You are presented with the standard Print dialog box, which allows you to specify the printing quality (High, Standard, or Draft), the page range, the number of copies, and whether you have continuous-feed paper or single sheets.

None of the settings need to be changed for your document.

Click OK.

When you are done printing, you'll return to the desktop.

If the document doesn't print, your disk may be too full; remove some documents from your disk and try again.

Choose Quit from the File menu.

You will be asked if you would like to save any changes you have made. You certainly want to do that!

Click Yes.

You'll also be asked for the name of a document to save the current glossary in. You'll save the changes you've made in the Standard Glossary.

Click Save to save your changes in the Standard Glossary.

Your Word document closes, and you're back at the Macintosh desktop.
Review

In this module, you've learned:

• How to select text by dragging across small blocks of text, clicking in the selection bar to select lines, and double-clicking in the selection bar to select paragraphs

• How to replace text by selecting it and typing

• How to define tab stops using the Tabs... command

• How to format paragraphs to include blank lines before or after the paragraph

• How to define and use Glossary entries to store and retrieve frequently-used blocks of text

• How to define running heads to display the same text and the page number on every page of the document

• How to use footnotes

• How to create and format Divisions using the Division Layout... command

What To Turn In

Turn in a copy of your revised Tofu Paper document.
Advanced Microsoft Word
The Task

Imagine that you're a student looking for a job (not too difficult, is it?). You've prepared a standard resume and cover letter to send to a number of prospective employers. To make the best possible impression, you'd like to tailor each letter to the specific employer and type of position. But you'd rather not have to retype the bulk of the letter again and again for each employer.

Fortunately, using Microsoft Word's print merge capability, you can create "customized form letters" for each person on your list.

To do this, you'll modify your original cover letter and resume so that they can be easily customized. The resulting document is called the main document and contains the basic form of your letter, along with instructions on how to customize each individual letter.

Next you'll create a list of the names and addresses of those who you want to receive the document, and the unique elements that will customize each letter. This list is called the merge document, because it contains the special information that merges with the main document to create the customized letters.

Finally, you'll merge print the customized letter. For each employer listed in your merge document, Microsoft Word will create a customized letter by customizing the main document letter with the information that you entered in your merge document. The result will be letters that are similar—but personalized. Examples are shown on the next few pages.
Merge and Main Documents

Main Document

Merge Document

Customized Documents
Mr. Chuck Woolery  
Director of Personnel  
Soya-Nara Soy Foods, Incorporated  
31529 Rancho San Carlos Road  
Carmel, California 94705  

November 11, 1985  

Dear Mr. Woolery:

In June of this year I will be graduating from Stanford University with a Bachelor's degree in Science and Slavic Languages, and I am interested in obtaining a position with your firm as a soybean processor at your Carmel facility.

Ever since my early childhood I have been fascinated by the soy-foods industry and have recognized Soya-Nara Soy Foods, Incorporated as a leader in that industry. In addition, my course work in Science has given me a great deal of experience in laboratory settings.

I am sure you will agree that my background in Science and Slavic Languages provides me with the depth and breadth of experience necessary to work as a Soya-Nara Soy Foods, Incorporated soybean processor.

My resume is enclosed and provides additional details about my undergraduate work and extracurricular activities. I would appreciate the opportunity to meet with you to discuss how my education and experience would be consistent with your needs. I will call you in the next few days to answer any questions you might have about my qualifications and hopefully at that time we can set up a time to meet.

Thank you for your consideration.

Sincerely,

Jennifer Gaetz

enclosure
Jennifer Gaetz

352 Melton Way
Palo Alto, California 94301
(415) 898-0725

OBJECTIVE: To obtain a position as a soybean processor with a leading soy-food manufacturer.

EDUCATION:
9/82-6/86 
Stanford University, Stanford, California.
B.A.S. degree in Science and Slavic Languages, with a concentration in alternative food technologies. Extensive course work in soy-food research, statistics, and plant biology.

EXPERIENCE:
1/85-Present 
President. Slavic Languages Society.
Stanford University, Stanford, California. Organized finances and coordinated group activities.

8/84-1/85 
Laboratory Technician. New Food Laboratory,
Stanford University, Stanford, California. Performed research on alternative food products.

6/84-6/84 
Maintenance Manager. Roche Motel, Lodi, California.
Responsibilities included maintaining facilities and managing large cleaning staff.

6/83-9/83 

ADDITIONAL INFORMATION:

Tofu Queen, 1985 Tofu Fest.

Director: 1985 Stanford Chorale Round-up.

Enjoy horses, crocheting, and pipe organs.

REFERENCES: Available upon request.
Ms. Carol Merrill
Director of Personnel
Foreign Sport Magazine
386 Mayfield Avenue
East Palo Alto, California 94303

November 11, 1985

Ms. Merrill:

In June of this year I will be graduating from Stanford University with a Bachelor's degree in Science and Slavic Languages, and I am interested in obtaining a position with your firm as a translator at your East Palo Alto facility.

Ever since my early childhood I have been fascinated by the sports magazine industry and have recognized Foreign Sport Magazine as a leader in that industry. My three years as head of the Stanford Slavic Languages Society has given me experience in managing interpersonal relationships.

I am sure you will agree that my background in Science and Slavic Languages provides me with the depth and breadth of experience necessary to work as a Foreign Sport Magazine translator.

My resume is enclosed and provides additional details about my undergraduate work and extracurricular activities. I would appreciate the opportunity to meet with you to discuss how my education and experience would be consistent with your needs. I will call you in the next few days to answer any questions you might have about my qualifications and hopefully at that time we can set up a time to meet.

Thank you for your consideration.

Sincerely,

Jennifer Gaetz

enclosure
Jennifer Gaetz

352 Melton Way
Palo Alto, California 94301
(415) 898-0725

OBJECTIVE: To obtain a position translating Yugoslavian sports medicine journals for a leading sports magazine.

EDUCATION: 9/82-6/86 Stanford University, Stanford, California. B.A.S. degree in Science and Slavic Languages, with a concentration in alternative food technologies. Extensive course work in soy-food research, statistics, and plant biology.

EXPERIENCE: 1/85-Present President, Slavic Languages Society, Stanford University, Stanford, California. Organized finances and coordinated group activities.

8/84-1/85 Laboratory Technician. New Food Laboratory, Stanford University, Stanford, California. Performed research on alternative food products.

6/84-8/84 Maintenance Manager. Roche Motel, Lodi, California. Responsibilities included maintaining facilities and managing large cleaning staff.


ADDITIONAL INFORMATION:

Tofu Queen, 1985 Tofu Fest.

Director: 1985 Stanford Chorale Round-up.

Enjoy horses, crocheting, and pipe organs.

REFERENCES: Available upon request.
Getting Started

Complete the Introduction to Microsoft Word module.

Many of the concepts explained in the introductory module will be necessary to complete this one. Make sure that you've completed this module and understand the basics of Microsoft Word.

Turn on the Macintosh and insert your Microsoft Word disk—label side up and metal end first—into the built-in disk drive.

You'll soon see the Macintosh desktop with the icon of your Word disk in the upper right-hand corner.

In this module, you'll need to use the Cover Letter and Resume documents that have been created and stored on the Approaching Macintosh Documents Disk. You will need to copy the Cover Letter and Resume documents onto your Word disk.

Copy the Cover Letter and Resume documents to the Word disk.

If you are unsure of how to do this, please see the Introduction to Macintosh module.

Now you'll open Cover Letter by double-clicking on the Cover Letter icon. Note that opening the Cover Letter document will automatically open Microsoft Word.

Double-click on the Cover Letter document on the Word disk to open the document.

Your first step is to convert your standard cover letter into the main document used to generate the customized letters. To do this, you'll replace the employer-specific parts of the letter with merge fields. Merge fields mark the position where Microsoft Word will insert the special information for each customized letter.

For example, since the name and address for each letter is obviously different, you create merge fields to tell Word to look for a different employer name, street address, city, state, and ZIP code for each letter and to insert them in the appropriate positions when the letter is printed.

To create a merge field, you first think of a name for it. Then you type the name, enclosing it in special characters, "«" and "»", which tell Word that the enclosed text is a field. Note that these are not doubled less than and greater than signs, but special characters that you type in a special way:
Merge Instructions

Using the DATA Instruction

To get the "«", hold down the Option key and press the backslash (\) key located just below the Backspace key.

To get the "»", hold down the Shift and Option keys and press the backslash (\) key.

Make sure that you understand how to type these characters before continuing.

When you "merge print" copies of the main document, Word stops at each merge field and looks in the merge document to find the information that should be inserted at that position.

Aside from the merge fields, you can also place instructions in your main document to tell Microsoft Word what you want to do.

The DATA instruction must be the first instruction in the main document (it doesn't have to be the first word in your document, but it must come before any other instructions or fields). The DATA instruction tells Word the name of the merge document that contains the customized information that will be used in this document.

When you create your merge document later in this module, you'll call it "Cover Letter Data".

Use the mouse to move the l-bar to the beginning of the first line of the document, and click to set the insertion point.

Note that if you move the pointer too far to the left (inside the selection bar), you'll select the entire line rather than set the insertion point. If this happens, move the pointer slightly to the right, and click again to set the insertion point.

Type «DATA Cover Letter Data».

Remember:

• To get the "«", hold down the Option key and press the backslash (\) key located just below the backspace key.
• To get the "»", hold down the Shift and Option keys and press the backslash (\) key.
In June of this year I will be graduating from Stanford University with a Bachelor's degree in Science and Slavic Languages, and I am interested in obtaining a position with your firm as a technician at your San Francisco facility.

Ever since my early childhood I have been fascinated by the grout industry and have recognized Consolidated Grout as a leader in that industry. In addition, my course work in Science has given me a great deal of experience in laboratory settings.

I am sure you will agree that my background in Science and Slavic Languages provides me with the depth and breadth of experience necessary to work as a Consolidated Grout Technician.
Ms. Vana White  
Personnel Director  
Consolidated Grout  
778 Walton Avenue  
San Francisco, CA 94555

Dear Ms. White:

In June of this year I will be graduating from Stanford University with a B. Science and Slavic Languages, and I am interested in obtaining a position...

Press Backspace to delete the selection.

You can now create merge fields for the employer's name and address.

Creating Fields in Main Documents

Ms. Vana White  
Personnel Director  
Consolidated Grout  
778 Walton Avenue  
San Francisco, CA 94555

«Contact Title» «Contact First» «Contact Last»  
«Contact Position»  
«Company Name»  
«Company Street»  
«Company City» «Company State» «Company ZIP»

First, you'll create fields for the name of the contact person who will receive your letter.

Type "«Contact Title» «Contact First» «Contact Last»".

By replacing "Ms. Vana White" with the fields Contact Title, Contact
First, and Contact Last, you tell Word to find the title, first name, and last name of the addressee for each letter in the "Cover Letter Data" document. This way, you can just as easily write to a "Mr. Alex Travech" as a "Ms. Carol Merrill".

Now you'll replace the contact's position and the company name and address with appropriate fields.

Press Return. Then type the following four lines:

```
«Contact Position»
«Company Name»
«Company Street»
«Company City», «Company State», «Company ZIP»
```

Press Return after the last line to insert a blank line.

Your document should now look like this:

```
Dear Ms. White:

In June of this year I will be graduating from Stanford University with a B. Science and Slavic Languages, and I am interested in obtaining a position w
```

You should now begin to see the form that the main document will take. Before continuing, try to think of what other merge fields you will need to define before your letter will be complete.

Each time you print a batch of customized letters, you'd like to have Word ask you for the current date and use that date in every letter printed. The SET instruction allows you to set the contents of any field, in this case the date field, equal for all documents printed at that time. You can also use the SET instruction to have Word ask you, when you are print merging, for the value you'd like to use.
To use the SET instruction, you first define the field that you would like to set. Then, you insert the SET instruction itself, which has three parts:

- First, you type "SET" to tell Word that you’ll be setting the value of a field for all documents.
- Second, you type the name of the field that you’d like to set.
- Finally, you type an equal sign (=) followed by either a value for Word to assign, or a question for Word to ask you before printing.

If you know the value that you would like to assign to a field when you are creating the main document, then use that value. If, on the other hand, you are uncertain of the value that you’d like assigned to the field, you can have Word ask you for it when you do the actual printing.

To use a value, you simply type it in after the "=" sign. But if you want to have Word present you with a question, or prompt, then first type a question mark (?) and then the prompt that you would like. For example:

?What is the date?

The first question mark tells Word that what follows is a prompt, and "What is the date?" is the prompt Word will show before printing.

You’ll create a field for the date now, and then use the SET instruction to have Word ask you for the date before printing.

In the main document, select the date by dragging across it. Be sure not to include the blank line after the date in the selection. Then type "Date=" to replace it.

The Date field is now created. Next, you’ll type the SET command.

Now use the mouse to position the I-bar at the beginning of the line with the «Date» field in it, and click to set the insertion point.

Type "<SET Date= ?What is the Date?>".
Note that the SET instruction can be placed anywhere on the page, because it will not be printed. The Date field, however, must be placed where you want it to be printed—in this case, underneath the return address.

Next, you'll change the greeting.

Select "Ms. White" from the greeting, then type "Contact Title" «Contact First» «Contact Last».

If you accidentally deleted the colon (:), type another.

Read over the first paragraph.

In this letter, you are applying to be a technician, but this may be different, depending on the company you're contacting. You should create a field to store the title of the position you're applying for.

Select "technician", then type "Position».

Now you can apply for any job you'd like, and your letter will always be accurate.

You'll also replace "San Francisco" with the field «Company City».

Select "San Francisco" and type "Company City» to replace it.
Read over the next paragraph.

Can you see what text needs to be changed in this paragraph? If you apply to companies that make different products, you'll want to define a field to replace "grout" in the first sentence. You'll do that now.

Select "grout" and type "<Product>" to replace it.

Certainly "Consolidated Grout" in this letter must be replaced by the field "Company Name".

Select "Consolidated Grout", then type "<Company Name>" to replace it.
Using Conditional Instructions

Read the sentence starting with "In addition, my course work in...".

This sentence won't work with some of the letters you'll be sending. For some employers, you would like to stress your Science background. For others, you would rather emphasize your familiarity with Slavic languages. You can use the IF...ELSE...ENDIF instruction to have Word insert one block of text if the job is technical, and a different block of text if it is not.

The IF...ELSE...ENDIF instruction begins with a condition. In this case, the condition is "Is the job technical?" So the first portion of this conditional statement (the "IF" part) reads as follows:

«IF Job Type = "technical"»

After the "if" part, you insert the text that you would like to include if the condition is true. Next, you type the ELSE instruction:

«ELSE»

And then the text that Word should insert if the condition in the "if" part is false. In this case, you would type the text that you want Word to insert when you are applying for a job that is nontechnical.

Finally, you type the «ENDIF» instruction to mark the end of the instruction.
A Conditional Statement (and what it means)

If the job is technical, then print the following:
«IF Job Type="technical"»In addition, my coursework in Science has given me a great deal of experience in laboratory settings. «ELSE»My three years as head of the Stanford Slavic Languages Society has given me experience in managing interpersonal relationships. «ENDIF»

Or, if the job happens to be non-technical, print the following:

You'll enter the IF...ELSE...ENDIF instruction now.

Use the mouse to set the insertion point between the second and third sentences in this paragraph (between the words "industry." and "In"), and type the following instruction:
«IF Job Type="technical"»

Next, set the insertion point at the end of the paragraph (after the word "settings") and type:
«ELSE»My three years as head of the Stanford Slavic Languages Society has given me experience in managing interpersonal relationships.«ENDIF»
Note that for every IF instruction, there need not be an ELSE, but there must be an ENDIF instruction. This allows you to have one block of text inserted if a certain condition is true, and nothing if it is false.

Use the Scroll Bar to see the next paragraph.

There are two more blocks of text that must be replaced with appropriate fields.

Select "Consolidated Grout" and type "«Company Name»", then select "technician" and type "«Position»".

```
Character Paragraph Document
Cover Letter

My background in Science and Slavic Languages provides me with the necessary to work as a «Company Name» «Position». I appreciate the opportunity to meet with you to discuss how I will be consistent with your needs. I will call you in the next you might have about my qualifications and hopefully at that

Sincerely,
```
The INCLUDE instruction is used to have the contents of another Word document merged with the main document when you are print merging. The INCLUDE instruction takes one argument, the name of the document to be merged. You'll use the INCLUDE instruction now to include a copy of your resume with each cover letter.

The contents of the document specified in the INCLUDE instruction are inserted at the exact spot where the INCLUDE instruction appears. If you type the INCLUDE statement right at the end of your cover letter, your resume will start on the same page as the letter, and you'll probably remain unemployed. Instead, you can insert a page break before typing the INCLUDE statement, so your resume begins on a new page after the cover letter.

Click to set the insertion point after the word "enclosure" (at the very end of the document).

In Word, you insert a page break by holding down the Shift key and pressing the Enter key. You'll do this now.

Hold down the Shift key, and press Enter to insert a page break.

A page break is represented on the screen by a dotted line.

Now you'll be sure that the resume will print on its own page.

Click to set the insertion point below the dotted line, and type "<<INCLUDE Resume>>".
The INCLUDE instruction always has the form «INCLUDE Name». It inserts the text of the document "Name" at the point of the INCLUDE instruction. In this case, your resume will be printed at the same time as your cover letters, but on a separate page, of course.

There is still one more change that you want to make. You need to replace the job objective in your resume with a field, so that you can write a specific objective for each company you apply to.

Because Word allows you to have up to four windows open at a time, you can work with your resume document in one window without closing your letter in the other.

But first, you'll save the changes you've made.

Choose Save from the File menu.

Choose Open... from the File menu.

A dialog box appears with a list of documents from which to choose.

Open the "Resume" document by clicking on it and then clicking Open.

Note that if there are many documents on your disk, you may have to scroll to see the Resume document.

A window containing your resume appears on the screen.
Notice that the resume's window is not as large as the main document's window. You can, however, make the window "zoom up" to fill the screen.

Double-click on the title bar of the window containing your resume.

Double-clicking the title bar (or the size box at the lower right corner of the screen) makes a window fill the screen. You're now ready to replace the job objective text with a new objective field definition.

You'll use one of Word's short cuts to select the job objective now.

Hold down the Command key and click anywhere inside the sentence containing the job objective.

Holding down the Command key and clicking inside a sentence selects that sentence. You can now easily replace the text with a field definition.

Type "«Objective»".

That's it! You can now close the Resume document, saving the changes you have made.

Choose Save from the File menu.

Choose Close from the File menu.
The Merge Document

You now have your form letter written, but you still need to tell Word how many letters to print out. You must also specify values for each of the fields (Company Name, Company Street, and so on) in each of the letters to be printed. You store this information in the merge document.

Now you'll open a new document for the employer-specific merge data.

Choose New from the File menu.

A new document opens on the screen. This will be your merge document.

First, make the merge document's window zoom up to fill the screen.

Double-click the title bar of the "Untitled" window.

You're now ready to type in your merge document.

You've made the main document as general as possible by inserting fields in place of each piece of text that will change from one copy of the cover letter to another. In the merge document, you provide Word with the information it needs to customize the main document for each of its recipients.

A merge document is made up of data records. Data records hold the fields of text that are to be merged with the main document. Each separate data record holds the text for a different version of the main document. In your case, you will have one data record for each employer to whom you wish to mail a copy of the letter.

The first record in a merge document is a special one called the header record. This record lists the field names to be used in the merge document. For instance, in your document, you would like the header record to contain the following fields: Contact Title, Contact First, Contact Last, Contact Position, Company Name, Company Street, Company City, Company State, Company ZIP, Position, Product, Job Type, and Objective.

When you type in the header record, be sure not to press Return until you're finished. A Return in the merge document signifies the end of a data record, so "early" Returns will end the header record prematurely.

If you would like a Return that does not end a data record (for aesthetic purposes, perhaps), you can hold down the Shift key while pressing Return, and the data record can be continued beyond Return.
Type in the following line. Don't press Return until the very end.

Contact Title, Contact First, Contact Last, Contact Position,
Company Name, Company Street, Company City, Company State,
Company ZIP, Position, Product, Job Type, Objective

Press Return to mark the end of the Header Record.

Now you're ready to enter the data records for each of the employers who you want to receive your letter. You create a data record the same way you create a header record, only you use the appropriate information for each employer.

Type in the following data record (remember not to use Return):

Mr., Chuck, Woolery, Director of Personnel, "Soya-Nara Soy Foods, Incorporated", 31529 Rancho San Carlos Road, Carmel, California, 94705, soybean processor, soy-foods, Technical, To obtain a position as a soybean processor with a leading soy-food manufacturer.

Press Return to complete the data record.

Note that the value for Company Name has quotations around it. When you are typing in the merge records, you use commas to separate fields. If you want to include a comma in the text for a field, you must enclose the entire field in quotation marks.

You'll enter one more sample now.
Type in the following line (again, don't press Return until the very end):

Ms., Carol, Merrill, Director of Personnel, *Foreign Sport Magazine*, 586 Mayfield Avenue, East Palo Alto, California, 94303, translator, sports magazine, Nontechnical, To obtain a position translating Yugoslavian sports medicine journals for a leading sports magazine.

**Press Return to enter this record.**

Remember that you must end each record with a Return.

Your document should now look like this:

That's it for the merge document. You could type a long list of prospective employers, but for now, use these two as a sample.

**Choose Save from the File menu.**

You are presented with a dialog box asking you to name the document. Remember that inside the main document, you specified (in the DATA instruction), that you were going to use the file "Cover Letter Data" when you did your print merging; therefore you must assign that name to your merge document.

Type "Cover Letter Data", then click Save.

The merge document is saved onto your disk.
It's time to do some printing. Remember that you double-clicked the title bar to make the merge document window fill the screen. By double-clicking it again, you can make the window return to its original size.

Double-click on the title bar of the merge document to make it return to its original size.

You should now be able to see your main document peeking out from underneath your newly created merge document.

Click anywhere inside the main document window to bring it to the front.

Once your main document is active, you can print out your form letters.

Choose Print Merge... from the File menu.

In a few seconds, you are presented with a dialog box asking you what the date is.

Remember that we used the SET instruction to tell Word to prompt us for the date, and insert it in each letter that it prints.

Type in the date, for example:

November 11, 1985

When you are finished, click OK.
Next, you'll be presented with the Print dialog box.

Choose options as you would to print any other document.

When you are finished, click OK to start printing.

Soon, your two form letters will be sitting in front of you.

Choose Quit from the File menu.

If you have inadvertently made any changes to either of your files since the last time that both of them were saved, Word will ask you if you would like to save the changes before quitting.
<table>
<thead>
<tr>
<th>Review</th>
<th>In this module, you've learned:</th>
</tr>
</thead>
<tbody>
<tr>
<td>• How to create a main document for print merging by defining necessary merge fields and instructions</td>
<td></td>
</tr>
<tr>
<td>• How to work with multiple documents</td>
<td></td>
</tr>
<tr>
<td>• How to use conditional instructions (IF...ELSE...ENDIF) to insert different blocks of text</td>
<td></td>
</tr>
<tr>
<td>• How to use the INCLUDE instruction to combine documents for print merging</td>
<td></td>
</tr>
<tr>
<td>• How to create a merge document containing a header record and one data record for each letter that Word will produce</td>
<td></td>
</tr>
</tbody>
</table>

| What To Turn In | Turn in your two completed form letters. |
Microsoft Word Quick Reference

Commands

- New \&-N
- Open \&-O
- Close \&-W
- Print \&-P
- Save \&-S
- Quit \&-Q
- Undo \&-Z
- Clear \&-B
- Cut \&-X
- Copy \&-C
- Paste \&-Y
- Find \&-F
- Change \&-H
- Go To \&-G
- Show Ruler \&-R
- Show ¶ \&-Y
- Tabs \&-T
- Footnote \&-E
- Formats \&-D
- Repaginate \&-J

Font change \&-Shift-E-number
font numbers:
0 Chicago
1 New York
2 Geneva
3 Monaco
4 Dover
5 Dover PS

Erase paragraph format \&-Shift-P
Left \&-Shift-L
Right \&-Shift-R
Centered \&-Shift-C
Justified \&-Shift-J
Open space \&-Shift-O
Indent first line .5" \&-Shift-F
Nest paragraph .5" \&-Shift-N
Unnest paragraph \&-Shift-M
Hanging indent \&-Shift-T

Move Option-Shift-click
Copy Option-click
Copy format Option-\&-click

Optional Cursor Keys

- Adding Shift to any of these sequences extends the selection in the direction the cursor moves.
- Cursor Up Option-\&-o
- Page Up Option-\&-p
- Line Up Option-\&-
- Word Left Option-\&-j
- Cursor Left Option-\&-k
- Cursor Right Option-\&-l
- Word Right Option-\&-
- Beginning of sentence Option-\&-\-
- Left end of line Option-\&-\-k
- Right end of line Option-\&-\-l
- End of sentence Option-\&-\-

- Cursor Down Option-\&-, Page Down Option-\&-
- Line Down Option-\&/
- Bottom of Screen Option-\&-.
- End of Document Option-\&-.
Tofu Invitation

Tofu & Sake Tasting Party
You are cordially invited to a tofu and sake tasting party
to celebrate the kickoff of
Tofu Fest 90
a week-long celebration of the spirit of soybean products and their role in university living.
Join faculty and students to discuss such topics as:
The History of Tofu
and Soybeans and Society.
Please join us
Wednesday, November 15, 7 PM
East Asian Studies Department Lounge.

Although you could create an invitation like this in MacPaint, the large amount of text makes MacWrite the application to choose. In preparing this invitation, the bamboo borders were transferred from a MacPaint document by way of the Clipboard (using Copy and Paste). The bamboo graphics were then resized to make them wide enough to form an appropriate border. They were inserted into the header and the footer to allow for a two-page invitation with identical borders on each page. Double-spacing, center justification, and Venice font (in various styles and sizes) were used for the text.
The diagram above shows the major parts of a young bean plant. Fill in the name of each part and give a brief description of its function.

A: Name: ___________ Description: ___________
B: Name: ___________ Description: ___________
C: Name: ___________ Description: ___________
D: Name: ___________ Description: ___________

This document was written using Microsoft Word. All of the solid lines in this quiz were made by using the underscore as a leader character.

When you are defining tabs in Word, you can select a leader character, if you choose to use one. Then, when you press Tab, the space between the insertion point and the next tab stop is filled with the leader character.

The graphic used in this quiz was created using MacPaint and MacDraw.
The *Tofu Times* is a multi-column document created using Microsoft Word. You use Word's Division Layout command to make the document multi-columned. After choosing Division Layout, a dialog box will appear. You may change the number of columns by entering a value other than one in the box labeled "Number of Columns." In this case, "3" was entered into "Number of Columns" to make the newsletter a three-columned document. Note that for multi-columned documents, only one column appears on the screen; therefore, you must print the document to know exactly what it looks like.
Exercises

1. Based on your experience with word processing software, describe how you think writing a paper using a word processor differs from using a typewriter. Which would you rather use? Why?

2. How are MacWrite and Microsoft Word different? What are the features you like and dislike about each? If you could use either, when would you prefer to use MacWrite and when would you prefer to use Microsoft Word?

3. What is a What You See Is What You Get (WYSIWYG) word processor? Why is WYSIWYG important?

4. Why is the ability to integrate information from other applications important? Give examples of when you might use this ability.

5. Change the format of the letter you created in the Introduction to MacWrite module so that the entire document is full justified and the first line of each paragraph (except for the Tofu Queen's quote) is indented 1/4-inch. Describe the changes you need to make to the three rulers in your document.

6. Imagine that you're an author using MacWrite to write a book on a personal computer called the Macintosh. Suddenly, you discover that somebody in the marketing department has changed the name of the computer to Macintosh Plus. Describe the steps you would take to make the necessary changes to your document.

7. Think of a good use for Microsoft Word's Print Merge capability. Create your own merge and main documents and print the resulting customized documents.

8. In the Introduction to Microsoft Word module, your document includes two figures, one of which is split between pages. What is the best way to ensure that all of Figure 2 appears on one page?

9. In the Introduction to Microsoft Word module, you stored a short phrase in the Glossary. Microsoft Word Glossary entries can contain graphics as well as text. Using MacPaint, design a letterhead for yourself which includes your name, return address, and a graphic. Then, define a Glossary entry in a Word document that uses it.

10. What is a division (in terms of a Microsoft Word document)? In the Introduction to Microsoft Word module, you created a separate division to hold the title page. In a larger document (say a book or paper with several chapters, and perhaps an appendix), divisions become more important. Think of at least three parts of a large manuscript which would be formatted as separate divisions and explain why.
4 Spreadsheets

About Spreadsheets
Introduction to Microsoft Multiplan
Advanced Microsoft Multiplan
Galleries
Exercises

HOWDY DO!
A spreadsheet is a group of items (numbers or text) arranged in horizontal rows and vertical columns to emphasize relationships among them. One common application of a spreadsheet is an accountant's ledger books, where the columnar tables are used to keep track of the flow of money. Your checkbook register is a more familiar example of a spreadsheet. Each column of the register contains information for every transaction, and each row contains all of the information for one transaction.

For people who use spreadsheets to record a large number of complex numbers and relationships, a problem arises when the information in the spreadsheet needs to be changed. Imagine that you use the tabular format of a spreadsheet to calculate your payments on a car loan that you're thinking of taking out. You'd probably want to include numbers like the interest rate, the number of payments, the principal and others. If a single number changed, you'd have to recalculate all of the numbers affected by the change. A tedious and unpleasant task if you have a large spreadsheet, or one that changes often.

Enter spreadsheet applications software for your personal computer. An electronic spreadsheet. With it, the computer can do your calculations for you—even complex calculations—fast and with a high level of accuracy. You enter the numbers into the spreadsheet grid, enter formulas elsewhere in the grid, and the computer does the computation. A formula is a relationship between one or more numbers in the spreadsheet. For example, the formula

$$\text{Profit} = \text{Income} - \text{Expenses}$$
expresses the relationship between the number for income and the one for expenses.

Using the numbers and formulas you enter, a spreadsheet can quickly calculate the result. So quickly, in fact, that you can change the numbers in the spreadsheet and watch as the computer recalculates and updates the other related numbers automatically.

The ability to update formulas instantly is especially useful for what are often called "What If?" analyses. With "What If?" analyses, you use formulas to create numerical models that express the relationships between different quantities. "What if our sales doubled in July? How much extra tax would we pay?" "What if we closed our Boise office? How much money would we lose?" This kind of numerical modeling is used often in the sciences and the financial world to predict the behavior of various systems, whether they be mechanical systems such as the structure of an airplane, or economic systems such as the relationship between defense spending and inflation.

Microsoft Multiplan is an electronic spreadsheet program for the Macintosh. The Macintosh's unique user interface makes working with electronic spreadsheets easy by allowing you to use the mouse to select different parts of the worksheet, choose commands, and enter cell references.
Introduction to Microsoft Multiplan
The Task

As a budding entrepreneur, you decide to form a small business to sell sushi to the student body. This idea seems like a sure win. But to be sure, you want to calculate some of your expenses in order to estimate your expected profit.

One of your largest expenses will be purchasing and operating an automobile for picking up supplies and delivering sushi to various student residences.

You realize that once you include car payments, insurance, and gasoline expenses, your calculations can become quite complex. Therefore you have decided to use Microsoft Multiplan to help you estimate your car expenses.

You'll learn the basic spreadsheet techniques in Multiplan and use them to design a spreadsheet that calculates the monthly cost of owning and operating an automobile. Throughout the module, you'll use "What if?" analysis to answer questions such as, "What if I decide not to buy the Mazerati Biturbo?"

You'll use the results from this spreadsheet in the Advanced Microsoft Multiplan module, where you'll calculate the total revenues and expenses for your business.

When you're finished, your spreadsheet will look like the one shown on the following page.
<table>
<thead>
<tr>
<th>ITEM</th>
<th>AMOUNT</th>
</tr>
</thead>
<tbody>
<tr>
<td>Car Payments</td>
<td></td>
</tr>
<tr>
<td>Price of Car</td>
<td>$5000.00</td>
</tr>
<tr>
<td>Down Payment</td>
<td>$3000.00</td>
</tr>
<tr>
<td>Principal</td>
<td>$2000.00</td>
</tr>
<tr>
<td>Number of Payments</td>
<td>60</td>
</tr>
<tr>
<td>Interest Rate</td>
<td>1.00%</td>
</tr>
<tr>
<td>Subtotal</td>
<td>$60.74</td>
</tr>
<tr>
<td>Insurance</td>
<td></td>
</tr>
<tr>
<td>Liability</td>
<td>$50.00</td>
</tr>
<tr>
<td>Collision</td>
<td>$0.00</td>
</tr>
<tr>
<td>Fire/Theft</td>
<td>$1.00</td>
</tr>
<tr>
<td>Subtotal</td>
<td>$51.00</td>
</tr>
<tr>
<td>Gasoline</td>
<td></td>
</tr>
<tr>
<td>MPG</td>
<td>25</td>
</tr>
<tr>
<td>Price/gallon</td>
<td>$1.22</td>
</tr>
<tr>
<td>Miles/month</td>
<td>500</td>
</tr>
<tr>
<td>Subtotal</td>
<td>$24.40</td>
</tr>
<tr>
<td>Grand Total</td>
<td>$136.14</td>
</tr>
</tbody>
</table>
Getting Started

You'll begin by inserting the Multiplan disk into your Macintosh.

Turn on the Macintosh and insert your Multiplan disk—label side up and metal end first—into the built-in disk drive.

You'll soon see the Macintosh desktop with the Multiplan disk icon in the upper right-hand corner.

If necessary, double-click on the Multiplan disk icon to view its contents.

Now you'll open Multiplan by double-clicking the Multiplan icon.

Double-click on the Multiplan icon to open the application.

If you are using a backup copy of Multiplan, you will be asked to insert the master disk.

A new worksheet appears on the screen.

A Multiplan spreadsheet is made up of many small boxes called cells. In a Multiplan spreadsheet, cells are used to store pieces of information. A single cell can contain a text label, a number, or a formula (a relationship between other cells).

Each cell is referred to by its row and column number. For example, R1C1 is the cell at the intersection of row 1 and column 1 (in the upper left corner of the worksheet), and R2C10 is the cell at the intersection of row 2 and column 10.
Rows run horizontally across the worksheet. Each row is identified by a number appearing in the row header to the left of it.

Columns run vertically down the worksheet. Each column is identified by a number appearing in the column header at the top of it.

In a document, one or more cells may be highlighted (blackened). These cells are called the current selection. One of these cells will have a white border. This cell is referred to as the current cell. Any label, formula, or number that you type will be entered into the current cell.

Notice the two boxes above your worksheet. One contains the text "R1C1" and the other contains a blinking cursor. These two boxes make up the formula bar. The box on the left always contains the current cell address, which tells you the row and column of the current cell. When you start a new worksheet, the current cell is always R1C1. As you move around the spreadsheet, however, the current cell address constantly changes to let you know where you are.

To the right of the current cell address is the cell contents window. This window holds the actual information in the current cell. If the current cell contains a label or a number, you’ll see it here. If the current cell contains a formula, you’ll see the formula here and the computed result of the formula in the document.

There is one other item of interest in the formula bar—the cancel icon—but you can’t see it now. The reason you can’t see it is because you haven’t done anything, so there isn’t anything to cancel. As soon as you type something in the current cell, the cancel icon appears in the formula bar.

Now you’ll enter some text into the worksheet, so that you can see how the cancel icon works.

Type your name.
As you begin to type, three things happen.

- First, the text that you enter appears in the current cell.
- Second, the same text also appears in the cell contents window of the formula bar.
- Third, a small icon appears between the current cell address and the cell contents window in the formula bar (see the diagram above). This is the cancel icon. By clicking on the cancel icon, you cancel changes you have made to the current cell. In this case, clicking on the cancel icon will erase the text that you've typed.

**Click the cancel icon.**

Your name disappears from both the formula bar and the current cell.

The remaining items on the screen (the menu bar, title bar, scroll bars, and size box) should be familiar to you by now. If they are confusing, consult the Introduction to Macintosh module.

You start creating your worksheet by typing labels in cells.

The first labels you enter will be column headings for your spreadsheet. There will be two columns: one will contain labels describing the expenses, and the other will contain the corresponding values. You'll enter the two column-heading labels first.
Selecting a Cell

To select a cell, you position the pointer on the cell (the pointer will become a cross) and press the mouse button. Select cell R3C1, the cell at the intersection of the third row and first column, now.

Move the pointer into cell R3C1 and click.

Now the current selection, this cell is blackened, or highlighted. It is also the current cell because it has a white border.

Typing Text in the Current Cell

All text, numbers, and formulas that you type will be inserted into the current cell. The characters will also appear in the formula bar.

Type "ITEM".

If you make a mistake while typing this label, use the Backspace key to correct the error. Alternatively, you can use the mouse to move the cursor within the formula bar and correct the error using the standard Macintosh editing techniques.

Press the Enter key to accept this label.

When you are entering labels, numbers, or formulas, pressing the Enter key causes Multiplan to accept the entry but does not change the current cell location. Before a label or number is entered, you can't change its formatting.

Because this label is a column heading, it would look better if it's centered within the cell. You can control the way that a label is formatted by choosing the appropriate command from the Format
Moving through Your Spreadsheet

You'll center this label now.

With cell R3C1 still selected, choose Align Center from the Format menu.

Next, you'll insert a label in cell R3C2, the cell directly to the right of the current cell. You could use the mouse to select this cell, but there is an easier way. You can use special keys to accept what you have typed and move through your spreadsheet:

- **Return** moves the current cell **down** to the next row.
- **Shift-Return** moves the current cell **up** to the previous row.
- **Tab** moves the current cell **right** to the adjacent column.
- **Shift-Tab** moves the current cell **left** to the adjacent column.

### Keyboard Commands for Cell Movement

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift</td>
<td>moves one cell up</td>
</tr>
<tr>
<td>Return</td>
<td>moves one cell up</td>
</tr>
<tr>
<td>Shift</td>
<td>moves one cell left</td>
</tr>
<tr>
<td>Tab</td>
<td>moves one cell right</td>
</tr>
<tr>
<td>Return</td>
<td>moves one cell down</td>
</tr>
</tbody>
</table>

You'll use the Tab key to move the current cell to the next column now.

**Press Tab to move the current cell to the right.**

R3C2 becomes the current cell.

If you use keys to move beyond the area of the spreadsheet that is visible on the screen, Multiplan will automatically scroll the spreadsheet for you so that the current cell remains on the screen. To move more quickly through your spreadsheet, use the scroll bars along the right and bottom sides of the window.
Practice using the Return, Tab, Shift-Return, and Shift-Tab keys to move around the spreadsheet. When you are done, move back to cell R3C2.

Type "AMOUNT" to enter a label for the second column.

Also center this label within its cell.

Press Enter to accept this label. Then choose Align Center from the Format Menu.

Next, you'll enter a label for "Car Payments", the first expense that you'll calculate. But first you'll have to change the position of the current cell.

From R3C2, press Return to move down one row, and then Shift-Tab to move one cell to the left to cell R4C1.

The current cell should now be R4C1, directly below the cell containing "ITEM". When you type the label for this cell, all of the text may not fit in the cell, depending on which fonts are installed on your disk. Don't worry if all of the text doesn't fit in the cell, because as long as you can see it in the formula bar, Multiplan knows it's there.

Type "Car Payments".

Once the text has been entered, that is, after you have pressed the Enter key or selected another cell, the part of the text that will not fit in cell R4C1 will flow over into R4C2. There is nothing in that cell, so that's okay. However, if cell R4C2 contained some text or numbers, then only the part of the label that could fit in cell R4C1 would show up. The rest would still be there, but it would be hidden.

Enter the text now.

Press the Enter key.

All of the text appears on the screen, but when you enter a value for the down payment in R4C2, part of the label will be hidden, and the spreadsheet will look very cramped. Fortunately, Multiplan allows you to change the width of a column so that you can fit more or less text in it. You can change the width of the column containing the current cell by dragging the appropriate column head to the left or right.

Use the mouse to position the pointer between the column heads for column 1 and column 2.

The pointer should change shape to show a double arrow as you
position the pointer between the two column heads.

When the pointer changes shape, you can change the width of the column by dragging to the right or left.

Press the mouse button and drag to the right until the column is approximately twice the width of the original column.

Notice that when you change a column's width, all other columns shift left or right to accommodate the change.

The next cell that you want to enter a label in is R5C1.

Press Return to make R5C1 the current cell.

Your spreadsheet will be divided into four parts—Car Payments, Insurance, Gasoline, and Grand Total. Under the labels for each of these items, you'll list the expenses that determine the cost of that item. For example, to calculate your monthly car payment you need to know the price of the car, the down payment, the number of payments, and the interest rate. Since you use these numbers to determine the car payment, their labels will be indented under the Car Payment heading.

Press the space bar twice to indent, then type "Price of Car".
Enter the value $8000.00 for the price of the car in the cell to the right of the label you typed.

From cell R5C1, press the Tab key to move right to cell R5C2.

Cell R5C2, just to the right of "Car Payments", is now the current cell.

Type "8000", then press Enter to accept the label.

Notice that Multiplan "pushes" numbers against the right edge of the cell, and text against the left edge. Also, when you first enter numbers, they appear in general format, without commas, dollar, or percent signs. You can change this by choosing the appropriate commands from the Format menu. You'll format the price of the car as a dollar amount.

Make sure cell R5C2 is still selected. Then choose Dollar from the Format menu.
Notice that when you use a dollar format for numbers, several things happen. First, the selected cells show a dollar sign ($) before the numbers. Second, all the numbers appear with two places to the right of the decimal point. Third (and for now, you'll have to take our word on this one), negative numbers are shown in parentheses instead of with a minus sign, which is a common practice in spreadsheets.

You're ready to type in the rest of the information needed to calculate your car payments.

From cell R5C2, press Return to move down to the next row, and then Shift-Tab, to move one column to the left to cell R6C1.

Press the space bar twice and type "Down Payment".

Next, you'll enter a value for the down payment, and format it as a dollar amount.

Press Tab to move one cell to the right, to cell R6C2.

Type "3000", press Enter, and choose Dollar from the Format menu.
Now you're ready to move on to the next item, "Principal".

Move to cell R7C1 by pressing Return, and then Shift-Tab.

Cell R7C1 should be the current cell.

Press the space bar twice, then type "Principal". When you are finished, press Tab to move one cell to the right.

You're ready to enter the principal for your car loan, that is, the amount of money that you will have to borrow. The principal can be calculated from the price of the car and the down payment by using this formula:

\[ \text{Principal} = \text{Price of Car} - \text{Down Payment} \]

In our example, the principal is \$5000 (\$8000 - \$3000).

Noticing this, you could simply enter "5000" in cell R7C2, but then you would have to recalculate the value and reenter it each time that either the price of the car or the down payment changed. Because you will be considering many different cars, this would be a lot of work.

By using a formula, however, you can tell Multiplan to perform calculations on values contained in other cells and to display the results of these calculations automatically.

You'll enter a formula for the principal now.
The Equal Sign

In Multiplan, you must start all formulas with an equal sign, so that Multiplan knows they are formulas and not just text or numbers.

Make sure that cell R7C2 is the current cell. Select it if it's not. Then type an equal sign, "=".

Absolute References

To calculate the principal, you need to subtract the down payment from the car price. You'll type a formula to reference the two cells that contain these two amounts.

The easiest way to reference a cell in a formula is to simply type the cell's row and column address. This is known as an absolute reference. You'll enter the formula for the principal as the price of the car (R5C2) minus the down payment (R6C2). The formula tells Multiplan to take the number in cell R5C2, subtract the number in R6C2 from it, and store the result in R7C2.

Type "R5C2 - R6C2", then press Enter.

Notice that when you press Enter, the formula is still displayed in the formula bar, but that the result (5000) is now displayed in the worksheet.

The formula is now complete, but the result would look better with a dollar sign in front of it.

Choose Dollar from the Format menu.
There are two more numbers you will need to compute the amount of your car payments: the number of payments that you will make and the interest rate. Enter these values now.

Press Return, then Shift-Tab to move to cell R8C1.

R8C1 should be highlighted.

Press the space bar twice, type "Number of Payments", and then press Tab to move one cell to the right.

Now enter a value for the number of payments. Your car loan will be paid off in 60 monthly payments.

Type "60".

Finally, you'll enter the interest rate.

Press Return, then Shift-Tab to move to cell R9C1.

R9C1 should be highlighted.

Press the space bar twice, type "Interest Rate", and then press Tab to move one cell to the right.

To calculate the amount of your car payments, you will need the interest rate per month, not per year. For simplicity, we are going to assume a 12% per year rate, so the monthly rate will be 1%, or .01.

Type ".01", then press Enter.

You'll format the interest rate as a percent.

Choose Percent from the Format menu.

When you use a percent format with numbers, two things happen. First, the selected cells show a percent sign (%) after the numbers. Second, the numbers you have formatted show a decimal point and two places to the right of it.

You now have enough information to calculate your monthly car payments. But first, you'll need to type in a label.

Press Return, then Shift-Tab to move to cell R10C1.

Type "Subtotal", then press Enter.
You'll have three subtotals, one each for car payments, insurance, and gasoline. You'll look up the subtotals more often than the other numbers, so you want to be able to locate them easily. Therefore align the labels for the subtotals against the right edge of their cells, where they will be closer to their values.

With cell R10C1 still selected, choose Align Right from the Format menu.

You are now ready to enter a formula to compute the amount of your car payments. The formula you'll use is a common one used to calculate loan payments. You may have seen it in a math class. If not, don't be alarmed, just bear with us.

Car Payment = \[ \text{Principal} \times \exp(\text{Interest Rate} \times \# \text{ of Payments}) \] / \# of Payments

where "Principal" is the principal of the loan, "Interest Rate" is the rate of interest charged per payment period, and "# of Payments" is the total number of monthly payments that will be made.

"\exp()" means to take the exponential of what is in parentheses. You may have studied the exponential function in a math class. If not, don't worry.

You'll use the exponential function to calculate the amount of your car payments.

Press Tab to move one cell to the right.

You're ready to begin typing the formula. When you entered the formula for Principal, you used absolute references. That is, you looked up the address for each of the cells you referenced, and then typed it in. This can be a long and tedious process. Fortunately, there is a better way.

When you define a formula, you can have Multiplan automatically add cell references for you by simply clicking in the cell that you would like to reference. You'll enter your next formula this way, but first you must type an equal sign so Multiplan will know that what follows is a formula.

While R10C2 is still selected, type an equal sign, "=". Then click on cell R7C2.
Multiplan automatically inserts a cell reference for you.

This reference looks a bit different from the cell address you typed earlier. It's called a **relative reference**. Relative references differ from absolute references because, instead of referring to cells by their row and column numbers (like R10C1), they refer to cells by their position in relation to the current cell. For example:

<table>
<thead>
<tr>
<th>This reference</th>
<th>Refers to</th>
</tr>
</thead>
<tbody>
<tr>
<td>R[-3]C</td>
<td>The cell three rows above the current cell in the same column.</td>
</tr>
<tr>
<td>RC[3]</td>
<td>The cell three columns to the right of the current cell in the same row.</td>
</tr>
<tr>
<td>R[5]C[-3]</td>
<td>The cell five rows below and three columns to the left of the current cell.</td>
</tr>
</tbody>
</table>

In this case, R[-3]C refers to cell R7C2 because the current cell is R10C2.

Relative and absolute references work exactly the same way as long as you don't move your formulas to different parts of the worksheet. Even if you insert cells in the middle of your spreadsheet (you'll see how to do this in the advanced Multiplan module), Multiplan will automatically adjust all references (both relative and absolute) for you so that you don't have to retype them to account for the new cells.
The type of reference you use will make a difference when you copy a formula from one cell to another. When you copy a formula, an absolute reference will always refer to the same cell. For example, "R3C2" in a formula will always refer to cell R3C2. A relative reference, however, will refer to a different cell when the formula is copied.

For example, you have just inserted the reference "R[-3]C" in cell R10C2. In this case, the reference R[-3]C refers to R7C2 (the cell three rows above the current cell in the same column). If you copy this formula into cell R10C3, the reference will no longer refer to cell R7C2. This is because R7C2 is no longer "three rows above the current cell in the same column". If the formula is in cell R10C3, R7C3 will be referenced because it is three rows above R10C3 in the same column.

You're ready to type in the rest of the formula, but you have a problem. The formula listed above uses an exponential to compute the amount of your car payments. Fortunately, Multiplan has several built-in functions to help you calculate complicated formulas. Functions make your formulas easier to enter. Multiplan includes functions that calculate sums, averages, standard deviations, and so on. You use a function either by typing its name directly into the formula bar, or else by having it inserted automatically using the Paste Function command from the Edit menu.

You'll paste in a function to compute the exponential now, but first you must insert a multiplication sign, "*". Note that the asterisk (*) is often used to signify multiplication in computer applications.
Continue the formula in cell R10C2 by typing a multiplication sign, "\*". Then choose Paste Function... from the Edit menu.

You'll be presented with a list of functions that Multiplan recognizes.

Using the scroll bar, scroll until the function EXP() is in view.

Click on the EXP() function, so that EXP() is highlighted. Then click OK.

The beginning of a function EXP() appears in the formula bar with the insertion point between the two parentheses.
You include the argument of the function in parentheses. The argument that you'll use for the EXP() function is the interest rate multiplied by the number of payments (see the formula for car payments on page 20).

You'll use relative references to enter this argument now.

Click on cell R8C2 and type a multiplication sign, "*". Then click on cell R9C2.

Recall that R8C2 contains the number of payments, and R9C2 contains the interest rate.

Your formula is almost complete, but you still need to divide by the number of payments. You must be careful, though, because the insertion point is still inside the parentheses. If you type in the rest of your formula now, it will be considered part of the EXP() function. Therefore before you type in the rest of the formula, you'll set the insertion point after the closing parenthesis.

Move the pointer into the formula bar after the closing parenthesis, ")", and click to set the insertion point.

Finally, you can type in the rest of the function, which includes another relative reference to the number of payments.

Type a division sign, "/", then click on cell R8C2.

Your formula is now complete.
Using "What If?" Analysis

You've finished calculating your car payments, but you may be wondering why you used a spreadsheet in the first place; you probably could have done all of your figuring on a pocket calculator in two minutes. Spreadsheets are invaluable, however, when you want to do "What If?" analysis. "What If?" analysis involves three steps:

• First, you ask a "What If?" question about your spreadsheet. For example, "What if the price of the car I'm buying were $10,000 instead of $8000?"

• Second, you alter the appropriate cell or cells in your spreadsheet. In this case, to change the price of the car to $10,000, you would change the value of R5C2 to 10000.

• Third, you observe how different values in the spreadsheet change. In this case, you would probably be most interested in the final amount of your car payments.

You'll want a dollar format for this number.

Choose Dollar from the Format menu.

The formula remains in the formula bar, but the result, 151.84323 appears in the cell R10C2.
Next, you'll do a small-scale "What If?" analysis on the portion of the spreadsheet that you've completed so far by changing the price of the car you'll be buying to $10,000 from $8000.

Click on cell R5C2 to select it. Then, type "10000". Finally, press Enter to accept the change.

Three things happen. First, the value in R5C2 is changed to $10,000, which is probably not surprising to you.

Second, the principal of your loan, given in cell R7C2, has changed from $5000 to $7000. Remember that the principal of the loan is given by the formula:

\[ \text{Principal} = \text{Price of Car} - \text{Down Payment} \]

From this formula, you can see that if the price of the car has increased by $2000 (from $8000 to $10,000), then the Principal must also increase by $2000 (from $5000 to $7000). When one cell in the spreadsheet changes, Multiplan recalculates all of the formulas in the spreadsheet to reflect the change; this is why it's important to use formulas to express relationships between cells.

The third change occurred in cell R10C2, your monthly car payments. The amount of each car payment has gone from $151.84 to $212.58. Remember that the formula used to calculate your car payments is

\[ \text{Car Payment} = \frac{[\text{Principal} \times \exp(\text{Interest Rate} \times \# \text{ of Payments})]}{\# \text{ of Payments}} \]
Although this formula may be confusing, note that nothing to the right of the first multiplication sign, "x", has changed, but the principal has increased. From this, you should be able to see that the amount of your car payments will also increase. As further evidence, consider that if the principal—the amount you are borrowing—has increased, and you are still going to make the same number of payments at the same interest rate, then each payment will have to be larger.

The most important thing for you to understand now is that Multiplan recalculates the spreadsheet for you each time you change the numbers in one or more cells.

This completes your introduction to "What If?" analysis, but you'll use it again once you've completed more of your spreadsheet.

Before you calculate your insurance and gasoline costs, you should save the work that you've done so far.

Choose Save As... from the File menu.

You are presented with the Save dialog box. You'll type in the name for your document.

Type "Car Costs", then click Save.

The work you've done so far is now saved to disk.

A region is a group of cells that lie next to each other in the spreadsheet. You can simplify the process of entering information by selecting the region of cells where the information will reside before entering it. When you select the region first, Multiplan knows in advance which cells to use. As a result, both formatting and moving through the cells of the region is faster than working with each cell individually. You'll see how this works in a minute.

First, you'll select the region of cells you'll be using for this section.

Click on cell R11C1 and drag down and to the right until the pointer is on top of cell R14C2. Then, release the mouse button.
Eight cells should be highlighted, indicating that they are selected and the current cell should be R11C1. If not, try selecting the region again.

Next, you'll type the label for the section in the first cell of the region.

Type "Insurance", then press the Enter key twice.

Notice that each time you pressed the Enter key, Multiplan accepted your entry and moved to the next cell in the selection. Multiplan moves through a region in the same way that you move through a page of a book you are reading—from left to right and top to bottom.

When you reach the last cell in the selection, pressing the Enter key again moves the current cell back to the first cell of the selection. In this way, you can go back to make corrections if necessary. You'll use the Enter key now to practice moving completely through the selection and back to the beginning.

Press Enter until the current cell moves throughout the entire selected region and back to cell R12C1. You should have to press Enter once for each cell in the region, eight times in all.

You're now ready to enter the information you'll need to calculate the amount of your insurance premiums. You'll be buying three kinds of insurance—liability, collision, and fire/theft. First you'll enter a label for liability insurance.
Press the space bar twice to indent this label, then type "Liability". When you are finished, press Enter.

The current cell should now be R12C2. If you typed Return or Tab instead of Enter, then the region will be deselected. Reselect it and start over, being sure to press Enter after you type the first label.

You'll enter the estimate that you have for liability insurance. You know that it will cost you $150 for six months, so you'll use a formula to enter a monthly estimate of $150 divided by 6.

Type "=150/6", then press Enter.

Notice that Multiplan jumps to the next cell without giving you a chance to format the last as a dollar amount. Don't worry, later you can format all of the numbers at once.

Now enter information for collision insurance. It's $100 for six months.

Press the space bar twice, then type "Collision". When you are finished, press Enter and type "=100/6".

Your final estimate is for Fire/Theft insurance. It's $50 for six months.

Press Enter to move to cell R14C1.

Press the space bar twice, type "Fire/Theft", press Enter, and finally, type "= 50/6". When you are finished, press Enter to accept this formula.

All cells in the region should be completely filled.
<table>
<thead>
<tr>
<th>ITEM</th>
<th>AMOUNT</th>
</tr>
</thead>
<tbody>
<tr>
<td>Car Payments</td>
<td></td>
</tr>
<tr>
<td>Price of Car</td>
<td>$10,000.00</td>
</tr>
<tr>
<td>Down Payment</td>
<td>$3,000.00</td>
</tr>
<tr>
<td>Principal</td>
<td>$7,000.00</td>
</tr>
<tr>
<td>Number of Payments</td>
<td>60</td>
</tr>
<tr>
<td>Interest Rate</td>
<td>1.00%</td>
</tr>
<tr>
<td>Subtotal</td>
<td>$212.58</td>
</tr>
</tbody>
</table>

If you've made any errors, use the Enter key to move through the region and correct the mistake.

Next, calculate a subtotal for insurance, and then format all four numbers as dollar amounts.

Select cell R15C1, and type "Subtotal".

Press Enter.

Format this cell so that it's aligned correctly.

Choose Align Right from the Format menu.

Next, define a formula to calculate the total cost of your insurance premiums.

Press Tab to move to the right to cell R15C2.

You might enter the formula using absolute references and addition signs:

$$ = R12C2 + R13C2 + R14C2 $$

or using relative references and addition signs:


But it is easier to add cell values using the Multiplan function SUM().
You'll use SUM() now to calculate the insurance subtotal.

Choose Paste Function... from the Edit menu.

The function dialog box appears.

Use the scroll box to scroll through the list until you find the function named "SUM()". Click on it, and then click OK.

The beginning of a function, =SUM(), appears in the formula bar with the insertion point between the two parentheses. Multiplan automatically adds the equal sign for you.

You can specify an argument to a function as a range of cells when the argument is made up of a group of cells that lie next to each other on the spreadsheet. You specify a range of cells by typing a reference (relative or absolute) to the first cell, then typing a colon (:), and finally a reference (again, relative or absolute) to the last cell in the range.

This diagram shows several cell ranges, and the text you would type to include them as an argument to a function:

When working with relative references, though, it's not always easy to determine references for cells that are far from the current cell. Fortunately, you can enter a range as an argument by clicking on the first cell in the region (the one at the top left), and dragging through the region.
In this case, you want to sum cells R12C2, R13C2, and R14C2.
You'll enter a reference to the region they define as an argument to the SUM() function now.

Position the mouse pointer on cell R12C2. Press and hold the mouse button and drag down to cell R14C2. Then, release the mouse button.

As you drag, "R[-3]C : R[-1]C" appears in the formula bar to reflect the range that you've selected with the mouse.

Your formula is now complete.

Press Enter.

Multiplan accepts the formula. The result 50 should appear in the current cell.

Next you'll want to format all four numbers under Insurance as dollar amounts. To save time, you can select and format them all at once.

Select the region starting with cell R12C2 and extending down to cell R15C2 by dragging through it.

Remember, to select a region, position the mouse pointer over the first cell, press and hold the mouse button, and drag through to the last cell. Release the mouse button when your selection is complete.

Choose Dollar from the Format menu.

All values in the selection are now displayed with the dollar format.
You have one more subtotal to calculate, and then you'll be able to calculate the total cost of operating the car.

You must calculate the amount of money that you expect to spend on gasoline each month. There are three things you'll need to include: the number of miles per gallon you expect your car to get, the price per gallon you think you'll have to pay, and the number of miles you think you'll be driving each month. Then the total gasoline cost (per month) will be given by the formula:

\[
\text{Total Gasoline Cost} = \frac{(\text{MPG} \times \text{Miles per Month})}{\text{Price per Gallon}}
\]

You can enter all of the information at once by first selecting a region, and then typing the information. You'll need a region five rows tall and two rows wide, which you'll select now.

If cell R16C1 isn't visible, use the vertical scroll arrow to bring it into view.

Click on cell R16C1 and drag down to the right to cell R20C2. Then release the mouse button.
If the region you've selected doesn't look exactly like the one shown here, try again.

Note that if you try to drag down past the area visible on the screen, Multiplan scrolls the spreadsheet so that all of the selected area appears on the screen.

Now you'll enter the information that you have for your monthly gasoline expenses. Note that when you are working with a region, any individual formatting must be done later. Any formatting you do while the whole region is selected will affect every cell in the region.

Fill in the selected cells with the text shown below. Be sure to use Enter to move from one cell to the next. You can simply press Enter twice after the first cell to leave the second one blank. Click in the appropriate cells to create the relative references in the subtotal cell.

<table>
<thead>
<tr>
<th></th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
</tr>
</thead>
<tbody>
<tr>
<td>6</td>
<td>Down Payment</td>
<td>$3000.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Principal</td>
<td>$7000.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Number of Payments</td>
<td>60</td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Interest Rate</td>
<td>1.50%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Subtotal</td>
<td>$212.58</td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>Liability</td>
<td>$25.60</td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>Collision</td>
<td>$16.67</td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>Fire/Theft</td>
<td>$8.33</td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>Subtotal</td>
<td>$50.00</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Gasoline
MPG 25
Price/gallon 1.22
Miles/month 500

You'll want to reformat some of the information you just entered. Specifically, you'll use the dollar format for the gasoline price and the subtotal, and you'll align the label for subtotal against the right edge of its cell.
Using Names

Defining Names for Cells

You've now entered all the information you'll need to calculate your monthly car expenses. Now, you'll obtain a grand total using this formula:

Monthly Grand Total = Insurance + Car Payment + Gasoline

So far, you've been entering formulas with relative and absolute references. A more intuitive way to reference cells is by using names. You can give a name to a single cell or a group of cells and then reference them in formulas using the name. For example, the formula that calculates the amount of your car payments is in cell R8C2. If you would rather refer to R8C2 by name, you could call it something meaningful like Car_Payment.
Multiplan's rules for naming cells are:

- Names must start with a letter, but can consist of letters, numbers, periods (.), and underscores (_).
- Names cannot include spaces.
- Names cannot be cell references (for example, R8C2).
- Names can be up to 31 characters long.

Define names for each of the subtotals in your document.

Click on cell R10C2, then choose Define Name... from the Select menu.

The Define Name dialog box appears and prompts you for a name that will refer to the cell. The window with the scroll arrows shows previously defined names. Since you have not defined any names yet, none appear.

Below the window, there is a box in which you enter the name you will give to the cells that are selected.

If the selected cell (or the first cell in the selected range) contains a label, Multiplan will suggest that label as the cell name. In this case, "Subtotal" is the label for the selected cell, so Multiplan suggests the name "Subtotal". You might click OK to accept Multiplan's suggestion, but in this case, you want a more descriptive name.
You'll name the cell "Car_Payment".

Type "Car_Payment", then click OK.

Note that you must put an underscore between the two words because Multiplan doesn't allow blank spaces in names.

Before entering a formula for the total cost, you'll also define names for Insurance and Gasoline.

Use the procedure outlined above to define the name "Insurance" for cell R15C2 and "Gasoline" for cell R20C2.

Remember that to define each name, you must

• Select the cell.
• Choose Define Name from the Select menu.
• Type in the name, and click "OK".

Finally, you'll define a formula to calculate the total monthly cost of operating your car, but first you'll have to enter a label.

If necessary, use the horizontal scroll bar to bring R22C1 into view, then Select cell R22C1 and type "Grand Total".

Press Enter to accept this label.

Align this label right in its cell.

Choose Align Right from the Format menu.

Finally, define the formula.

Press Tab to move one cell to the right.

The current cell should be R22C2.

Enter the following formula:

\[ = \text{Car}_\text{Payment} + \text{Insurance} + \text{Gasoline} \]

Note that rather than cryptic cell references, you used the names that you defined in your formula—this makes it much easier to check your formulas for errors.

Press Enter to accept the formula.
"286.98053" appears in cell R22C2 if you've done everything correctly.

If an error message appears, make sure that you have not made any typing errors while entering the formula. If there is still a problem, redefine each of the names, and then reenter the formula, making sure that the names you defined are exactly the same as the names you use in the formula.

You'll want the Grand Total to appear with a dollar format.

Choose Dollar from the Format menu.

Now that your spreadsheet is complete, you can experiment with the full power of "What If?" analysis. The spreadsheet that you've created calculates the monthly cost of owning and operating a car, so your "What If?" analysis should be centered around the question: What if I buy this car rather than that one? You'll complete this cost analysis now for the following two cars:

<table>
<thead>
<tr>
<th></th>
<th>Porsche 944 (red)</th>
<th>Old Buick (rust)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Price of Car</td>
<td>$24,000 (new)</td>
<td>$5000 (used)</td>
</tr>
<tr>
<td>Liability</td>
<td>$300/6 months</td>
<td>$300/6 months</td>
</tr>
<tr>
<td>Collision</td>
<td>$250/6 months</td>
<td>$0/6 months</td>
</tr>
<tr>
<td>Fire/Theft</td>
<td>$60/6 months</td>
<td>$6/6 months</td>
</tr>
<tr>
<td>MPG</td>
<td>15 (maybe)</td>
<td>25</td>
</tr>
</tbody>
</table>

You'll calculate the monthly operating costs for both of these cars.
Enter the information given in the previous table for the Porsche 944. Now, your spreadsheet should look like this:

As you can see, the monthly cost of owning a Porsche 944 is $780.07. Now, calculate the monthly cost of owning an old rusty Buick.

Enter the information for the old Buick given in the table on the previous page. When you are done, your spreadsheet should look like this:
The cost of owning an old rusty Buick is only $136.14. Perhaps now you can truly appreciate the power of "What If?" analysis. You could have made these same calculations on paper, but you probably wouldn't have; it would have taken too long. "What If?" analysis takes much of the number crunching out of decision making, allowing managers to consider more options, and hopefully to make better decisions.

**Finishing Up**

Before closing, you will want to save and print your worksheet. You'll need this document to complete the Advanced Microsoft Multiplan module.

Choose **Save** from the **File** menu.

Your document is now saved on the disk.

When you print a Multiplan spreadsheet, you tell Multiplan how to format the page using the **Page Setup** command.

Choose **Page Setup**... from the **File** menu.

Here you can choose to print your spreadsheet with or without row and column numbers and gridlines. You can print it with a header or footer or both on each page, if you like. And you can control the printer margins for paper types.

Uncheck the box for "Row and Column Numbers" so that the printer won't print row or column numbers.

Type a footer for your spreadsheet, such as "Auto Expenses".

Click **OK**.

**Printing**

Next choose **Print**... from the **File** menu.

You are presented with the standard Print dialog box.

*Make sure that the printer is turned on, selected, and connected correctly to your Macintosh.*

Click **OK** when you're ready to print your spreadsheet.

Now you're ready to return to the desktop.

**Quitting**

Choose **Quit** from the **File** menu.

You're back at the Macintosh desktop.
Review

You've completed the introductory Microsoft Multiplan exercise for the Macintosh. If all has gone well, you've learned:

- How to select a cell by clicking on it
- How to type text labels in cells
- How to type numbers in cells
- How to format text labels using commands from the Format menu
- How to move through a spreadsheet using the Return, Tab, and Shift keys
- How to enter formulas using numbers, relative references, and absolute references
- How to use functions to make entering formulas easier
- How to do "What If?" analysis
- How to select a region by dragging across the cells in the region and how to move through a region using the Enter key
- How to format a region
- How to define names and use names in formulas
- How to save a Multiplan document on your disk
- How to print your document

What To Turn In

Turn in a copy of your printed spreadsheet. Be sure to save this document; you'll need it to complete the Advanced Microsoft Multiplan module.
Advanced Microsoft Multiplan
As stated in the Introduction to Microsoft Multiplan module, you are thinking of starting a business to sell sushi during lunchtime in the student union building. You have already done some preliminary cost analysis. Specifically, you have calculated the expected cost of owning and operating an automobile used to pick up supplies and deliver sushi to outlets around campus. You will now prepare a spreadsheet that will use that information, plus other projected costs and expected income, to calculate the amount of profit that your sushi business will produce if all of your projections are accurate.

There will be several parts to this Multiplan module. First, you'll create a list of business expenses.

Next, you'll use Multiplan's **Paste and Link** command to dynamically link the document you created in the introductory lab into the spreadsheet that you'll create in this one. Specifically, you'll insert your final result from the "Car Costs" document into a list of business expenses.

You'll also use Multiplan's **Iterate** command to calculate the amount of sushi that you'll need to sell just to break even.

Finally, you'll use the **Fill Right** command to copy the formulas you've defined to expand your one-month profit projection into a three-month profit projection.

When you're finished, your spreadsheet should look like the one shown on the next page.
<table>
<thead>
<tr>
<th></th>
<th></th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Sushi Dreams Profit Worksheet</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Number of Samplers</td>
<td>January</td>
<td>February</td>
<td>March</td>
<td>Total</td>
</tr>
<tr>
<td>4</td>
<td>200</td>
<td>300</td>
<td>300</td>
<td>800</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Expenses</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Rent</td>
<td>$600.00</td>
<td>$600.00</td>
<td>$600.00</td>
<td>$1800.00</td>
</tr>
<tr>
<td>8</td>
<td>Car</td>
<td>$136.14</td>
<td>$136.14</td>
<td>$136.14</td>
<td>$408.41</td>
</tr>
<tr>
<td>9</td>
<td>Raw Materials</td>
<td>$600.00</td>
<td>$900.00</td>
<td>$900.00</td>
<td>$2400.00</td>
</tr>
<tr>
<td>10</td>
<td>Wage Cost</td>
<td>$400.00</td>
<td>$400.00</td>
<td>$350.00</td>
<td>$1150.00</td>
</tr>
<tr>
<td>11</td>
<td>Total Expenses</td>
<td>$1736.14</td>
<td>$2036.14</td>
<td>$1986.14</td>
<td>$5758.41</td>
</tr>
<tr>
<td>12</td>
<td>Income</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>Sushi Samplers</td>
<td>$1600.00</td>
<td>$2400.00</td>
<td>$2400.00</td>
<td>$6400.00</td>
</tr>
<tr>
<td>14</td>
<td>Total Income</td>
<td>$1600.00</td>
<td>$2400.00</td>
<td>$2400.00</td>
<td>$6400.00</td>
</tr>
<tr>
<td>15</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>Profit</td>
<td>($136.14)</td>
<td>$363.86</td>
<td>$413.86</td>
<td>$641.59</td>
</tr>
<tr>
<td>17</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>18</td>
<td>FALSE</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>19</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>21</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>22</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>23</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>24</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>25</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>26</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>27</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>28</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>29</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>30</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>31</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>32</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>33</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>34</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>35</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>36</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>37</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>38</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>39</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Getting Started

Make sure that you have completed the Introduction to Microsoft Multiplan module.

Many of the concepts explained in the introductory module will also be used to complete this advanced module. You will also link the spreadsheet you create in this module with the one that you created in the introductory module.

Turn on the Macintosh and insert your Microsoft Multiplan disk—label side up and metal end first—into the built-in disk drive. Make sure the "Car Costs" document that you created in the introductory module is still on your disk.

You'll soon see the Macintosh desktop with the icon of the Multiplan disk in the upper right-hand corner.

If you haven't completed the introductory Multiplan module or have thrown out the spreadsheet you created with it, please go back over the earlier module before you attempt to do this. (You need the Car Costs spreadsheet from the introductory Multiplan module in order to complete the advanced Multiplan module.) And, while completing this advanced module, don't be shy about having another look at the introductory module to remind yourself about entering text and numbers, defining names, using formulas and functions, and other topics that it covered.

If necessary, double-click on the Multiplan disk icon to view its contents.

Now you'll open Multiplan by double-clicking the Multiplan icon.

Double-click on the Multiplan icon to open the application.

If you are using a backup copy of Multiplan, you'll be asked to insert the master disk; do so now.

Multiplan creates a new, untitled, document for you.

The spreadsheet that you will create in this module will be similar to the one that you created in the introductory module. Specifically, you will have labels along the left side of the worksheet, with the corresponding values to the right of them. From the introductory module, you know that the labels generally take up more room than the preset column width. Therefore before entering any text or numbers in the spreadsheet you'll increase the width of the first column.

Increase the width of the first column to approximately double its original size.
Remember that to change the width of a column, you must

- Use the mouse to position the pointer between the column head for the column you want to change and the column next to it.
- When the pointer changes shape to show a double arrow, drag to the right or left to change the width of the column.

You are now ready to enter a title for your worksheet.

Select Cell R1C2 and type "Sushi Dreams Profit Worksheet".
Press Enter to accept the label.

Remember that extra text will flow from one cell into the cell to the right as long as that cell is empty.

In the introductory module, you entered each row in order—first the label, then the number or formula. However, you're now familiar with Multiplan's basic editing techniques, so it'll be easier for you to first enter all the labels, and then all the numbers, and then do the formatting. This is because some of the tasks that you did for each cell in the introductory module could be done to many cells at the same time, such as formatting numbers or labels and defining names.

Your spreadsheet will be divided into two areas: expenses and income.

Because there will be several types of information in the first column, you must be careful about how you format different cells. You'll use three kinds of formatting: the two headers for expenses and income will be centered, the three totals (total expenses, total income, and
Naming Rows

profit) will be aligned right, and the rest of the cells will be aligned left.

Now you'll fill the first column with labels for your spreadsheet.

Enter labels in the first column of your worksheet until it looks like the one shown here. Use the appropriate commands from the Format menu to align them as described above and displayed below.

Because this spreadsheet is going to be a complicated one, you'll use, wherever possible, names for cell references so the formulas you define are easily understood. Instead of naming single cells, however, you'll name entire rows for this worksheet. This is because after you create a profit projection for one month, you'll use a copying shortcut to extend the analysis for three months. But to do this, you'll want the names you define to refer to entire rows, rather than single cells. That way, when you say

Rent + Car

in a formula, Multiplan will understand that you mean the value in the "rent" row for this month plus the value in the "car" row for this month.

The difference between naming a group of cells and naming an individual cell is important when you use names to reference cells in formulas. When you define a name for a single cell, and then use that name in a formula, the reference will be an absolute one to that cell. However, when you define a name for a group of cells, and then use that name in a formula, the reference will be a relative one to the cell that is at the intersection of the named region and the row or column that the

4-48 SPREADSHEETS: ADVANCED MICROSOFT MULTIPLAN
current cell is in. This is an important concept, but is not easily grasped; be sure that you understand how references to named cells work before you go on.

For now you'll name row 3 "Number of Samplers", but you must select a region before you can name it.

Click on row 3 in the row header.

The entire row is selected, and should be highlighted.

Choose Define Name... from the Select menu.
This time you should see the phrase "Number_of_Samplers" in the Name field of the dialog box. Multiplan put the name there because it found that label in the first column of row 3. "Number_of_Samplers" is a good name for the row because it describes the row's contents.

Click OK.

Remember that to define a name for a row, you must

- Select the row by clicking in its row header.
- Choose Define Name... from the Select menu.
- When the dialog box appears, either type in a name, or click OK to accept the name that Multiplan suggests (in this worksheet, you'll always accept Multiplan's suggestion).

Define names for the following rows.

<table>
<thead>
<tr>
<th>Give this row:</th>
<th>This name:</th>
</tr>
</thead>
<tbody>
<tr>
<td>row 6</td>
<td>Rent</td>
</tr>
<tr>
<td>row 7</td>
<td>Car</td>
</tr>
<tr>
<td>row 8</td>
<td>Raw_Materials</td>
</tr>
<tr>
<td>row 9</td>
<td>Wage_Cost</td>
</tr>
<tr>
<td>row 10</td>
<td>Total_Expenses</td>
</tr>
<tr>
<td>row 13</td>
<td>Sushi_Samplers</td>
</tr>
<tr>
<td>row 14</td>
<td>Total_Income</td>
</tr>
<tr>
<td>row 16</td>
<td>Profit</td>
</tr>
</tbody>
</table>
You're ready to enter numbers and formulas into your worksheet.

The first row in your worksheet, the one labeled "Number of Samplers," will contain your estimate of the number of "Sushi Samplers" (each plate of sushi that you sell will actually contain three kinds of sushi, so it's called a "Sushi Sampler") that you'll be able to sell in one month. From the surveys you've taken to estimate demand, you project that you'll be able to sell 200 Sushi Samplers the first month. You'll enter "200" for the number of samplers now.

Select cell R3C2 by clicking on it. Then type "200".

Next, you'll enter the amount that you'll have to pay for rent. This will be $600.

Select cell R6C2 by clicking on it. Then, type "600". Finally, press Enter to accept this number.

Eventually, you'll want to use a Dollar format with "Rent," but you'll take care of that later, after you've entered all of your numbers and formulas.

The next expense that you'll enter is the cost of operating the car that you'll use to pick up supplies and deliver sushi to various retail outlets around campus. You'll enter a total for that now, but you'll want to use the value you calculated in the introductory module.

You could copy the number from your Car Costs spreadsheet, but each
time you changed a number in the first spreadsheet (for example, to consider several different cars), you'd have to remember to update the number in this spreadsheet to reflect the change.

Fortunately, there is a better way. You can link the two spreadsheets so that every time the Grand Total cell in the "Car Costs" document changes, the changes will be reflected in this spreadsheet, too.

To link two spreadsheets, you simply copy the information from one spreadsheet (it will then be on the Clipboard), and then use the Paste and Link... command to paste it into the other document. Multiplan remembers where the information came from, and each time you open this spreadsheet, it also reads the linked information from the other.

For example, to link the "Car Costs" document with this one, you'll open the "Car Costs" document, copy the cell containing the Grand Total, return to this spreadsheet, and Paste and Link the information here.

You'll open the "Car Costs" document now.

Choose Open... from the File menu.

If Open is disabled, you have probably forgotten to press Enter to accept the number "600". Make sure you press Enter before selecting Open from the File menu.

You are presented with a dialog box asking if you would like to save the changes that you've made so far.

Click Yes.

Because this is a new document, you are asked to name it.

Type "Sushi Profits", then click Save.

You are presented with one more dialog box. Here you select the file that you would like to open. You want to open "Car Costs". If there are many documents on your disk, you might have to use the scroll arrows to find the "Car Costs" document.
Select the document named "Car Costs". Then, click Open.

The "Car Costs" document opens on your desktop. You'll want to copy the information that you would like to use to link the two spreadsheets. In this case, it is just one cell, the Grand Total Cell—R22C2.

If necessary, use the vertical scroll bar to bring cell R22C2 into view.
Next you'll copy the information.

Select cell R22C2, which should have a value for "Grand Total" in it, and choose Copy from the Edit menu.

Now return to "Sushi Profits".

Choose Open... from the File menu. When the dialog box appears, select the document named "Sushi Profits". Then, click Open.

The "Sushi Profits" worksheet opens. You're ready to Paste and Link the information.

If it is not the current cell, select cell R7C2. Choose Paste and Link... from the Edit menu.

You are presented with a dialog box telling you that you are linking to cell R22C2 in "Car Costs", and asking if you would like cells shifted down or shifted right. When you paste cells into a full worksheet, Multiplan must make room for them. Multiplan gives you a choice of either moving down or to the right, the cells that are in the way to make room for the new cells.

In this case, it really doesn't matter which direction you choose because there's nothing important either to the right of or beneath cell R7C2, the cell that you are going to fill.

Click OK to shift cells right.
A cross appears at the upper left corner of cell R6C2, marking the point where you pasted from the clipboard. The link is made. Note that you can refer to linked information in a formula, but you cannot change it or copy it. Linked information can only be changed in the source document.

Now you'll enter numbers for raw materials.

You've determined that it will cost you $3.00 in raw materials to produce each sushi sampler; therefore your monthly raw-material cost will be the number of sushi samplers you sell in a month multiplied by 3. Next, you'll enter a formula to calculate your monthly raw-material cost.

Select cell R8C2. Then, type "=". Remember that you must begin all formulas with "=".

Type "3 * ". Remember that you've already named row 3 "Number_of_Samplers". By including "Number_of_Samplers" in the formula, you'll add a relative reference to the cell that is at the intersection of row 3 and the column that the current cell is in. In this case, the reference will be to R3C2. Use the Paste Name... command to include a name in a formula.

Choose Paste Name... from the Edit menu and select the name "Number_of_Samplers". When you are done, click OK.
"600" appears in cell R8C2 if you've done everything correctly.

You're ready to enter a formula to calculate your wage cost. Unlike your raw-material cost, which depends on the amount of sushi that you sell, your wage cost is a fixed cost; it stays the same every month. In fact, you know that you'll have to hire someone to work 100 hours a month (25 hours each week), and that you'll pay at the rate of $4 an hour. You could just enter 400 in R9C2, because you know the amount will be fixed. You'll use a formula, however, in case you have to pay more than $4 an hour to lure students out of the library, or you need to hire more than 25 hours of help per week.

Press Return to move down one cell to R9C2. Then, type 

\[=100 \times 4\]  

Finally, press Enter to accept this formula.

You're ready to sum your expenses to obtain a total. You've defined names for the rows containing each of your expenses; therefore you can use the following formula to calculate their sum:

\[\text{Total Expenses} = \text{Rent} + \text{Car} + \text{Raw\_Materials} + \text{Wage\_Cost}\]

If it is not already the current cell, select cell R10C2. Then, type 

\[= \text{Rent} + \text{Car} + \text{Raw\_Materials} + \text{Wage\_Cost}\].

Note that you can type a name in a formula instead of pasting it in with the Paste Name... command.

Press Enter to accept the formula.
If you've done everything correctly, "1736.1373" appears in cell R10C2.

Although the names are defined for entire rows, when you use them in formulas, they are relative references to the cells at the intersection of the named row and the column that the current cell is in. For example, in the formula above, you could have replaced "Rent" with R[-4]C, and the formula, although less readable, would be functionally the same.

If you do get an error message, check to be sure that all of your names have been defined correctly and that you have typed them in correctly. If all else fails, try redefining names for the rows that you are using, and reentering the formula.

You're ready to enter values for the Income area of your worksheet.

Your only source of income will be from selling sushi samplers. To determine the amount of money you will make from selling sushi, you'll need to know how many samplers you'll sell, and the price you'll receive for each one.

The number of samplers has already been entered (in row 3). Because you've decided to charge $8 for each sushi sampler, your total income will be the number of samplers you sell multiplied by 8. You'll enter a formula to calculate this amount now.

Select cell R13C2 and type "=8 * Number_of_Samplers".
Finally, you'll calculate total income and profit. Because your total income results from selling sushi samplers, your total income will simply equal sushi income.

Press Return to move down one row.

The current cell should be R14C2.

Type "=Sushi_Samplers". Then, press Return twice to enter the formula and move down two rows to cell R16C2.

You'll make a formula for profit, which is simply total income minus total expenses.

Type "=Total_Income - Total_Expenses". Then, press Enter to accept this formula.

"-136.1373" should appear in cell R16C2.

Your profit statement is nearly complete. But you'll want to use a dollar format with some of the numbers in your spreadsheet.

It would be faster to format all of the cells at once, but you can't select all of column 2 and then use a dollar format with it because one of the numbers in column 2 (Number_of_Samplers) shouldn't have a dollar format. You'll now select the region of cells from rent (row 6) to profit (row 16). Then, you'll give all of the cells in the region a dollar format.

Select the region between cell R6C2 and cell R16C2.
Remember that to select a region you must

- Move the pointer on top of the first cell in the region.
- Press and hold the mouse button while dragging through the region to the last cell in the region.
- Release the mouse button.

You'll use a dollar format with the selected cells.

Choose Dollar from the Format menu.

All of the selected cells now have a dollar format. Notice that the result for profit has parentheses around it. That's because your profit was negative. Remember that Multiplan uses parentheses, rather than a minus sign (-), for negative numbers with a dollar format.

You've finished your profit statement for the first month. The results are not good, and it looks like you'll lose money if you go ahead with the business.

Before you decide to open your business, it's a wise idea to perform a break-even analysis. A break-even analysis will answer the question, "How many samplers must I sell in order to break even (not lose any money, but not make any, either)?"

You can use Multiplan's iteration feature to perform a break-even analysis. Here's the method you'll have Multiplan use to calculate the
number of samplers you would have to sell to break even:

- Set the Number_of_Samplers to be 1.
- Calculate the profit you would make if you sell one sampler.
- If that profit is negative, increase the Number_of_Samplers by 1, and recalculate the profit. Otherwise (if the profit is positive or 0) stop.

Using this method, Multiplan counts the minimum number of samplers you need to sell such that your profit isn't negative. This number is your break-even point because it is the number of samplers you must sell to avoid losing money.

You'll make the necessary changes to your spreadsheet to do this break-even analysis now.

This process of changing cells and calculating the worksheet over and over until a certain stopping condition is true is known as iteration. Next, you'll tell Multiplan that you'll be using iteration.

Choose Iterate from the Calculate menu.

When you are using iteration, Multiplan makes small changes to the worksheet and recalculates it over and over, hopefully getting a better answer with each calculation.

In this case, you are estimating the number of Sushi Samplers you will have to sell to break even. The iteration process will start by calculating the profit if you sell only one sampler. The answer Multiplan calculates during this first iteration will probably not be very close to the true answer. That is, you will probably have to sell many more than one sampler if your profit is going to be nonnegative. During the second iteration, Multiplan will calculate the profit you'll make if you sell two samplers. This answer will be closer to the true answer because you will lose less money selling two samplers than you will selling only one.

This process will go on forever unless you tell Multiplan when to stop. You use a completion test to tell Multiplan when to stop iterating. In this case, you'll want Multiplan to stop as soon as it has found a profit greater than or equal to zero; therefore your completion test will be

\[ \text{Profit} \geq 0 \]

Note that you use the two symbols ">" and "=" to test whether one number is either greater than or equal to another.
You'll enter the completion test now.

Select cell R17C2. Then, type "=Profit>=0". Finally, press Enter to accept this formula.

False appears in R19C2. Can you see why?

Next, you'll tell Multiplan to use this expression for the completion test when iterating.

Choose Set Completion Test from the Calculate menu.

You've told Multiplan that you'll be using iteration, and you've set a completion test. To complete your break-even analysis, you need only tell Multiplan which cell to do the counting in.

You can use the ITERCNT() function to calculate the number of iterations that Multiplan has done. ITERCNT() will be equal to 1 after the first iteration, 2 after the second, 3 after the third, and so on. You can replace the value in cell R3C2 with =ITERCNT() to have Multiplan calculate the profit for 1 sampler, then 2, then 3, and so on.

You'll change the number in cell R3C2 now.

Select cell R3C2. Then, choose Paste Function... from the Edit menu.

When the dialog box appears, select the function ITERCNT() (you will have to scroll to see it). Then, press OK.
That's it. As soon as you press Enter to accept the formula, Multiplan will begin counting, and won't stop until the break-even analysis is complete.

Press Enter.

A dialog box appears, showing the number of iterations that Multiplan has completed.

![Sushi Profits](image)

After about a minute, Multiplan stops iterating. When the silicon dust settles, you'll see that if you sell less than 228 sushi samplers, your business will lose money.

Fortunately, your market projections show that you'll be able to sell not 200 but 300 samplers the second month, and 400 in the third month of operation. Because of this, you'll want to see your quarterly (three-month) profits before you decide if you should open the business.

You'll expand your calculations to cover a three-month period in a moment, but first you'll want to change Number_of_Samplers from "=ITERCNT()" back to "200", and then create column headings for each month.

If cell R3C2 is not the current cell, select it now. Then, type "200". Finally, press Enter to accept this number.
Inserting a Row

You'll want to insert an extra row to hold the column headings. Multiplan allows you to insert a row by holding down the Shift key and clicking on the row heading where you would like to insert the new row. You'll insert a row below row 2 now.

Move the pointer on top of the row heading for row 2, and hold down the Shift key.

The pointer becomes a bar with an arrow pointing down.

Entering Column Headings

With the pointer on top of the row heading for row 2, and the Shift key held down, press the mouse button.

A new row is inserted, and all of the text and numbers below it are shifted down to make room.

Don't worry about any of your references becoming incorrect; Multiplan will update them for you.

Before entering column headings, you must select the cells where they belong.

Select the region from cell R3C2 to cell R3C5 (by dragging through it).

Now you'll enter the column headings.

Type "January", press Enter, type "February", press Enter, and type "March". Then, press Enter to move to the right to
Filling Formulas

You're ready to copy the formulas in column 2, but don't worry, you won't have to type in all of the formulas and numbers again, or even paste them one at a time. Using the Fill Right command, you'll be able to copy the formulas and numbers for January into the columns for February and March.

To use Fill Right, you must first select the area that will be filled as well as the area that you will fill it with. Don't worry about selecting an area that is too large to fit on the screen because Multiplan will scroll the worksheet for you automatically when you try to drag the pointer off the screen.

Move the mouse pointer to cell R4C2, press the mouse button, drag down and to the right to cell R17C4, then release the mouse button.

Now you'll fill the columns for February and March with the numbers and formulas for January.

Choose Fill Right from the Edit menu.
All of the formulas you've defined are copied, turning a one-month projection into a three-month projection. As soon as you change the values for the samplers you expect to sell in February and March, you'll have a three-month profit forecast.

Enter "300" in cell R4C3, and "400" in cell R4C4.

Note that when there is something in a Multiplan cell, you can change it by simply selecting the cell and typing the new information.

Look at your profit now. You see that the profit forecast is very different when you are selling more samplers!

You will now calculate three-month totals for expenses, income, and profit, but first you'll define names for columns 2, 3, and 4.

Click on Column 2 in its column head.

The entire column is selected, and should be highlighted.
Choose Define Name from the Select menu. Multiplan may suggest a name, just type "January" for the name of column 2, then click OK.

You'll also want to define names for columns 3 and 4.

Use the procedure given above to define the names "February" and "March" for column 3 and column 4.

Next, you'll calculate quarterly totals for your expenses, income, and profit. To do this, you'll calculate the three-month sum for Number of Samplers, and then use the Fill Down command to copy the formula for each of your expenses, income, and profit. Note that the quarterly total is simply the value for January plus the value for February plus the value for March.

Select cell R4C5. Then, type "=January + February + March". When you are finished, press Enter to accept the formula.
"900" appears in R4C5. You could go through all of your expenses, and then your income, and finally your profit, and for each one type in this formula, but that would be very tedious. Fortunately, there is a better way.

You can use the Fill Down command to copy a formula from one cell to a group of cells directly beneath it. To use the Fill Down command, you select the cell that contains the formula, and the cells in which you'd like to put a copy of the formula. Then, you choose Fill Down from the Edit menu.

In this case, you want to copy the formula in cell R4C5.

You'll use the Fill Down command now to copy the formula in cell R4C5, but first you'll select the cells that should contain a copy of the formula.

Select the region from cell R4C5 to cell R17C5 (by dragging through it).
Now you'll use the Fill Down command to copy the formula in the first cell of the region (R4C5) to the rest of the cells in the region.

Choose Fill Down from the Edit menu.

The formula is copied, and the correct monthly total appears in all of the cells of the region. Note, however, that for each row that has blank cells in the second, third, and fourth columns, a "0" appears in column 5. You'll remove the unwanted zeros now.
Using "What If?" Analysis

Clear each of the cells in column 5 that contain "0".

To clear a cell you must

- Select the cell.
- Press Backspace.

You'll want to use a dollar format with all of the cells in column 5 except for cell R4C5. You will now format all of these cells at once by first selecting the region that contains them, and then choosing Dollar from the Format menu.

Select the region from R7C5 to R17C5 (by dragging through it).

Choose Dollar from the Format menu.

According to your projections, you'll make $1091.59 in the first three months that you sell sushi. But what if your projections are wrong? You'll use What if? analysis now to see how much your profit projection changes if some of your estimates are not accurate.

First, you'll see what happens if you only sell 300 samplers in March.

Select cell R4C4. Then, type "300" and press Enter to accept the change.

Your quarterly profit plummets to $591.59!
Let's try another. What if the weather in March is particularly bad this year, and you are able to hire students to work for $3.50/hour rather than $4/hour (because it takes less money to lure them out of the sun)? You'll see how this would affect your profit forecast now.

Select cell R10C4.

The text "=100 * 4" appears in the formula bar.

Type "=100 * 3.50" to change the formula. Then, press Enter to accept the new formula.

Your profit increases to $641.59.

Note that you could also have moved the pointer into the formula bar, selected the "4", and typed "3.50". Both methods accomplish the same thing.

You're finished now, but before quitting, you'll save and print your worksheet.

Choose Save from the File menu.

The final version of your spreadsheet is saved to disk.

Choose Print... from the File menu.

You are presented with the Print dialog box.
Select High for Quality and either Continuous or Cut Sheet for Paper Feed.

Click OK when you're ready to print your spreadsheet.

You'll return to the desktop.

Review

You've now finished the Advanced Microsoft Multiplan module. In this module, you've learned:

- How to link spreadsheets so they will share information
- How to name rows and use names for rows in formulas
- How to format a group of cells by changing their alignment
- How to insert rows into the worksheet
- How to "Fill" formulas to avoid typing the same formulas many times
- How to use iteration to do a break-even analysis
- How to set a completion test for iteration

What To Turn In

Turn in a copy of your printed spreadsheet.
Using Microsoft Multiplan, this spreadsheet was created to replace the checkbook register that is found in every checkbook.

Using the Page Setup... command, the spreadsheet was made to print sideways by changing the orientation from Tall to Wide.

Fill Down was used to copy the same formula into all of the cells in column 7.

Only the SUM() function was used to create this spreadsheet.
This spreadsheet uses several Multiplan functions to calculate statistical information for a group of students who are in the same class. To make creating functions easier, names were given to the four regions in columns two, three, four, and five which contain test scores and final grades.

The AVERAGE() and STDDEV() functions were used to calculate the average and the standard deviation for each of the tests and the final grade. The highest and lowest grades in the class were calculated using the functions MAX() and MIN(). Finally, the COUNT() function was used to count the number of students in the class, and the conditional function IF() was used to print out a message if there were either any perfect scores or if anyone failed.
Exercises

1. What structure is used to store information in a spreadsheet? Be sure to discuss the relationship between rows, columns, and cells. A sketch may be helpful.

2. What are the advantages of using an electronic spreadsheet versus using a physical (paper) spreadsheet? What are the disadvantages?

3. What is "What If?" analysis? How is it used? Why is it useful? Give an example.

4. What is an absolute reference? What is a relative reference? What is the difference between an absolute and a relative reference? When is one preferred over another?

5. What is a function? How do functions make spreadsheets more useful?

6. What does it mean for a function to require one or more arguments? Give examples of functions which require arguments.

7. What are the advantages of naming cells?

8. What are the advantages to linking spreadsheets?

9. With Multiplan, you use the Macintosh mouse to move between cells in a spreadsheet. How would you do this on another computer without a mouse? Discuss the advantages and disadvantages of using a mouse.


11. Explain how Multiplan's Fill Right and Fill Down commands work to make entering groups of formulas easier.

12. What is a region? How do you select a region in Multiplan? How do you include a reference to a range of cells in a formula?
5 Business Graphics

About Business Graphics
Microsoft Chart
Galleries
Exercises
Because spreadsheets make numerical calculations fast and easy, computer users have the power to generate huge tables of numbers in the time it would originally have taken to complete a single calculation. But generating numbers is one thing, and understanding what they mean is quite another. With all these numbers available, it becomes important to be able to present them in a way that can be quickly and clearly understood.

Business graphics applications are designed to take a mountain of numbers and create charts and graphs that convey the information in a clearer, more easily understood way. When a group of numbers is presented graphically using a bar or line chart, for instance, it's often easier to spot trends and summarize the overall picture quickly.

Business graphics can clarify meaning and add impact to an otherwise confusing set of numbers. In short, business graphics applications can make a picture that's worth a thousand words (or numbers).

Of course you could use a graphics application like MacPaint to create a chart or graph. But the magic of a business graphics application is that it makes the artwork easy. In many cases, you simply enter the numbers you want to plot and choose the type of graph you'd like. The application does the rest.

What's more, business graphics applications make it easy to update your graphs with updated data. If the numbers that you're graphing should change, you can change your chart just as quickly. Try that when you're graphing with pencil and paper.

Also, in many cases, business graphics applications can be integrated with spreadsheets so that changing a number in the spreadsheet update the graph instantly.
Microsoft Chart is a business graphics applications package for the Macintosh. Chart takes advantage of the high-resolution graphics of the Macintosh to generate column, bar, pie, line, scatter, and area charts in a wide variety of styles and formats. Experimentation is easy with Chart so you can choose the style and format that makes your point best. If none of the preset formats suits you, Chart allows you to customize your chart with borders, legends, and labels as well as a selection of patterns and type styles.

Aside from making your chart visually interesting, Chart also allows you to sort, and analyze, and graph the data you enter using statistical functions and trend analysis. You can enter your data by typing, or use the Macintosh Clipboard to Cut and Paste from other applications like spreadsheets and databases.

While not as well integrated as truly "integrated software" like Microsoft Excel or Lotus Jazz, Chart has the ability to link a chart with a Multiplan spreadsheet so that changes in the spreadsheet will be reflected in the Chart.
Microsoft Chart
For your Social Psychology project on interpersonal relations, your group has just finished its survey on dating patterns at your school. The results are in and now they need to be summarized graphically for your final presentation. You'll need three different charts. But rather than laboriously drawing them by hand, you decide to let Microsoft Chart be your graphic artist.

In the first chart you create, you'll learn the basics of Microsoft Chart: how to enter data and plot it in a number of different chart types.

In the second chart, you'll create a scatter plot and use Chart's powerful data analysis capabilities to perform a trend analysis on your data.

In the third chart, you'll compare two sets of data by plotting them both on the same set of axes. You'll also use Chart's creative formatting capabilities to customize your chart.

With all this in store, you make a date for Wednesday night with Microsoft Chart and your favorite Macintosh....
How Couples Met
Note the inverse relationship
First-Date Activities

<table>
<thead>
<tr>
<th>Activity</th>
<th>Females</th>
<th>Males</th>
</tr>
</thead>
<tbody>
<tr>
<td>Movies</td>
<td>70</td>
<td>60</td>
</tr>
<tr>
<td>Party</td>
<td>50</td>
<td>40</td>
</tr>
<tr>
<td>Picnic</td>
<td>40</td>
<td>30</td>
</tr>
<tr>
<td>Race Track</td>
<td>30</td>
<td>20</td>
</tr>
<tr>
<td>Activity</td>
<td>20</td>
<td>10</td>
</tr>
<tr>
<td>Ball Game</td>
<td>60</td>
<td>50</td>
</tr>
<tr>
<td>Dinner</td>
<td>40</td>
<td>30</td>
</tr>
<tr>
<td>Dance</td>
<td>30</td>
<td>20</td>
</tr>
</tbody>
</table>

Dating Survey
Getting Started

You'll begin by opening Microsoft Chart from the desktop.

Turn on the Macintosh and insert the Microsoft Chart disk—label side up and metal end first—into the built-in disk drive.

You'll soon see the familiar Macintosh desktop with your Microsoft Chart disk icon in the upper right-hand corner.

If necessary, double-click on the Chart disk icon to view the contents of the disk.

Now you're ready to open Chart by double-clicking on its icon.

Double-click on the Chart icon to open the application.

In a few seconds, two windows appear on the Macintosh screen.

The smaller of the two windows, titled "New Series", is called a data window. When you enter new data into Chart, it will appear in a data window. Each group of numbers that you plot is called a data series and appears in its own data window. If you're working with more than one data series, you'll use one data window for each data series. The New Series data window is always available to add additional data series.

The larger window, labeled "Untitled", is known as the chart window. When you click the Plot Series box in your data window, the chart appears in the chart window.

Note that both windows can be moved and resized just like windows in other Macintosh applications. If you're a little rusty, moving and

5-10 BUSINESS GRAPHICS: MICROSOFT CHART
resizing windows is covered in the Introduction to Macintosh module.

The frontmost window on the Chart desktop is known as the active window. The title bar of the active window is highlighted. In this case the New Series window is active. You'll activate a window to bring it to the front so that you can work with it. For instance, when you're entering data, you'll activate the data window. When you want to see or make changes to your chart, you'll make the chart window active.

Now that you're familiar with the Chart desktop, you're ready to start your first chart.

A data series is a set of data points. Each data point is composed of a category and a value. The categories are plotted along the horizontal or X-axis, while the values are plotted along the vertical or Y-axis. Microsoft Chart takes a data series and plots it.

The population of the United States over ten years is an example of a data series. In this case, each data point would be comprised of a year (the category) and the population in that year (the value).

The data window on your screen is labeled "New Series" because it is used each time a new data series is created. The New Series window should be in front (active) any time you want to enter a new data series.

If necessary, activate the New Series window by clicking in it.

If you cannot see the New Series window, choose List... from the Data menu to bring the data window to the front.

Before entering your data, you should specify what type of category information you'll be entering. Chart recognizes four types of category information: Sequence, Date, Text, and Number.

With Sequence or Date information, you specify a starting point and the interval between points. Chart then calculates and enters the category for each data point as you enter the value. For instance, if your data was taken yearly, you would choose Date as the category type, enter the first year and choose one year as the interval between data points.

With Text and Number, you enter both categories and values. Text lets you enter any letters or words as a category, while Number accepts only numbers.

Notice that in the Data menu Sequence... has a check mark by it. This is because Microsoft Chart is preset to accept sequential data.

The data for your first chart is a summary of how the surveyed couples met. The categories will be the different ways in which the couples met, and the values will be how many of the couples surveyed met in
each way. The category type, then, will be Text.

Choose Text... from the Data menu.

A dialog box appears asking you to specify various properties of your series. For a text series, you can specify the name of the series, as well as the labels for the category and value axes. The text that already appears in the boxes was automatically preset by Microsoft Chart.

The Series Name box is highlighted, meaning that it is selected. If you now type a name for the series, your name will replace the one Chart has chosen automatically. If you make a mistake, you can use the Backspace key or any of the other Macintosh editing techniques you learned in the MacWrite module.

Type "How Couples Met" in the Series Name box.

Pressing the Tab key, instructs Chart to accept what you just entered and move on to the next box.

Press the Tab key to accept your entry and move to the next (Category Name) box.

Pressing the Return or Enter keys is the same as clicking OK, indicating that you have finished entering information. If you accidentally press Return, choose Text... from the Data menu to continue.

Type "How" in the Category Name box and press Tab.

The horizontal, or category, axis will now be labeled "How" for how couples met.
Type "Number" in the Value Name box.

The vertical, or value, axis will now be labeled "Number" for number of couples.

Click OK.

You've now named the chart and labeled the vertical and horizontal axes. Next you'll enter the data for your data series.

Notice that a new window appears that has the name and labels you just entered. There are now two data windows. Each time you create a new series, Chart creates a new data window. This means that a New Series is always available.

To enter your data in the data window, you simply type in a category or value and press—you guessed it—the Enter key.

Type in the data shown in the following data window, pressing Enter after each category or value.

Don't worry if you make a mistake while entering the data, you'll learn how to edit your entries next.
Editing in Chart is based on the same principles as editing in other Macintosh applications, like MacWrite. To position the insertion point, use the mouse to move the I-bar to where you want to insert or delete and click.

You've entered "art parties" when you really meant "at parties". It's a simple mistake that's easy to correct.

Using the scroll bars if necessary, position the I-bar after the "r" in "art" and click the mouse.

At this point you can insert or delete characters.

Press the Backspace key to remove the offending character.

You've entered all the data to create your data series. Next you're ready to plot that series in the chart window.

Click the Plot Series box above the Category column.

In a few seconds, a column chart appears in the chart window.

Part of the chart is covered by the data window. To bring it to the front you can either activate the chart window by clicking anywhere inside it, or you can use the Show Chart command in the Chart menu.

Choose Show Chart Window from the Chart menu.
There are many types of charts, and each type conveys information in a different way. In fact, determining the best type of chart for a particular data series depends on the type of data and the intended audience.

Chart can create seven types of charts: pie, bar, column, area, line, scatter, and combination. Each of these chart types has a number of variations available.

Chart's preselected chart type is a column chart. If you don't specify a chart type, Chart will automatically choose a column format.

Take a look at the chart you've created. As a column chart, it gives you
an idea of which types of meetings were more popular than others. But
it doesn't give a very good picture of what percentage of couples met in
the various ways. To determine which type of chart expresses your
data best, you'll experiment with some different types.

The Gallery menu shows the available chart types and allows you to
change types with a simple click of the mouse.

Choose Bar... from the Gallery menu.

The Bar Chart Gallery appears with one variation preselected.

Each Chart Gallery gives you a choice of several variations on a chosen
cart type. The differences (some are subtle) are reflected in the
numbered pictures.

The column and bar chart formats are quite similar in how they present
data, so perhaps the bar chart isn't the best choice for this data either.

Click the Cancel button.

Because the pie chart calculates percentages for you, it is probably best
suited to showing what proportion of couples met in the various ways.

Choose Pie... from the Gallery menu.

The Pie Chart Gallery appears with a number of possible formats.
You'll choose the format that displays the percentages next to each pie
wedge. You choose a format by clicking in the picture of the chart with
the desired format.

Choose #6 from the Pie Chart Gallery, and click OK.
Using Legends

Though Chart calculated and displayed the percentages for the data, it's impossible to tell which pie wedge represents which category without referring to the actual data series. Don't worry, Chart allows you to add a chart guide, called a legend, that matches each pie wedge with its corresponding category label.

Select Add Legend from the Chart menu.

The legend is added automatically.

Congratulations!

You've now created your first chart. You'll save it, print it, and move on.

Saving Your Chart

Choose Save As... from the File menu.

A dialog box appears on the screen asking you to name your chart.

Type "How Couples Met" and click Save.

In a few seconds your chart will be saved on your disk.

Printing a Chart

Chart allows you to print the contents of whichever window is currently active. If the data window is active, then the Print Data command allows you to print your data series. If the chart window is active, the Print Chart command allows you to print your chart.

You want to print the chart. So make sure the chart window is active.

If necessary, activate the chart window by clicking in it.

Make sure that your printer is on, selected (the Select light on the printer...
should be on), and connected correctly to your Macintosh.

Choose Print Chart... from the File menu.

The print dialog box appears. Make sure all the settings are correct for your printer and the paper you're using.

Click OK.

Choose Quit from the File menu.

Quitting takes you back to the Macintosh desktop. This is a natural stopping place in the lab, so you may wish to take a break.

Now that you're familiar with the basics of Chart, you're ready to create more sophisticated charts.

Open Microsoft Chart by double-clicking on its icon.

Your next set of data compares different responses for money spent on a date vs. the "self-rating of enjoyment" for that date. The "self-rating of enjoyment" is rated on a scale from 1 (terrible) to 10 (sheer ecstasy).

You'll enter the data using the techniques you learned while making your first chart. You'll choose the data series type and type in the data, pressing Enter after each category or value. The data is numerical, so you'll choose Number... from the Data menu.

Choose Number... from the Data menu.

A number series dialog box appears. Remember to press the Tab key to get from one box to the next.

Type "Dating and Money" as the Series Name.

Type "Money Spent" as the Category label.

Type "Enjoyment" as the Value label and click OK.

Enter the data as it appears in the following data window.
More Chart Types

You need to choose an appropriate chart type and format for this data series.

Choose Line... from the Gallery menu.

The preselected format for your line chart is fine, so click OK.

Click the Plot Series box in the "Dating and Money" data window.

Bring the chart window to the front by clicking anywhere in it.
Choosing Your Chart

Your group wants to determine whether there is a relationship between the amount of money spent on a date and the "self-rating of enjoyment" experienced on that date.

Notice that you entered two data points that had "0" as their category. Look in the chart window to see how these data points were plotted. There are two zeros along the horizontal axis corresponding to these two data points. It's as if Chart doesn't recognize that these categories are numerical and that two zeros should be plotted at the same place along the horizontal axis.

What you need is for the category axis to have a scale like the values axis does. With such a scale, the category of each data point would be plotted at its appropriate numerical place along the category (horizontal) axis, just like the value of the data point is plotted at its appropriate numerical place along the value (vertical) axis. The chart that provides a scale along both axes is the Scatter chart.

Choose Scatter... from the Gallery menu.

Click OK to accept the preselected gallery choice.

Scatter charts and numerical data series are designed to work together. In a scatter chart (and only in a scatter chart), a scale is created for both the category and the value axes instead of just the vertical axis. Thus, you find this to be the appropriate chart type to represent your data.

After looking at your chart, you think you see an inverse relationship emerging from the scattered points. Chart has built-in capabilities for analyzing data and detecting trends.
Because the analyze commands deal with the data you've entered, the data window must be active before you can use these commands.

Bring the data window to the front either by clicking in it or by choosing List... from the Data menu and clicking OK.

Choose Analyze... from the Data menu.

A dialog box appears asking you to choose how you would like to analyze the data.

Select Trend by clicking in the circle to its left.

Click OK.

Notice that Chart has created a new series of data, entitled "Trend of Dating and Money" and plotted it on the chart using white markers to distinguish the Trend series from the original one.

Activate the chart window by clicking in it.

For those of you who are statistically minded, Chart has just performed a linear regression using the method of least squares. For those of you not so statistically minded, Chart has determined the straight line that best fits the original data.

You'll notice that the line slopes downward. This indicates that, according to your data, there is an inverse relationship between how much money is spent on a date and how much enjoyment was experienced on the date. In other words, according to your survey, the more money your subjects spent on a date, the less enjoyment they experienced.
Perhaps you'd like to draw the viewer's attention to this inverse relationship. Chart allows you to draw arrows and add remarks.

First, you'll draw an arrow that points to the trend series.

To add an arrow, you first need to tell Chart where you want the arrow to go. To do this you position the mouse and click where you'd like the tail of your arrow.

Position the pointer about an inch to the right of one of the white markers that make up the Trend series and click.

A cross appears to mark where you've selected.

Choose Add Arrow from the Chart menu.

Notice the two small black squares, called handles. These handles show where the arrow will go and are used for resizing or repositioning the arrow. The handle at the lower right controls where the head (point) of the arrow will go, while the handle at the upper left controls the tail of the arrow. To move or resize an arrow, just drag the handles one at a time and release the mouse button when the handle is where you want the head or the tail of the arrow to go.

Drag the lower right handle until it almost touches the white marker.

The pointer becomes a four-way arrow while you drag.

Drag the other handle until the arrow looks like the one shown.

A line representing the arrow moves with you as you drag the handle.
Adding a Remark

Once you've pointed out the series, it's time to add your remark.

Click to the right of the arrow.

A cross appears marking where you selected. Don't worry about its exact placement since you'll move the text later.

Type "Note the inverse relationship".

The text appears on two lines surrounded by eight handles. By using the handles to change the size and shape of this rectangle, you can change the appearance of the text.
Reshaping Text

Drag the middle right handle about 1 1/2 inches to the right.

Notice that when you position the pointer on a handle, the pointer changes to a double arrow, indicating the directions in which you can move the handle. If you've dragged the handle far enough right, all the text will appear on one line.

If the text is still on two lines, drag the same handle a little further right.

Moving Text

You'd like to move the text next to the end of the arrow. To do this, you'll drag the rectangle to the new location.

Position the pointer on the perimeter of the rectangle between handles.

The pointer becomes a four-way arrow.

Drag the rectangle to the position indicated in the following chart.

An outline of the rectangle follows. When you release the mouse button, the text snaps to its new position.

Formatting the Data

There's just one more change for you to make to your chart. You can guess from the axis label that the numbers on the horizontal axis are dollar amounts. It would be nice if the numeric labels on the axis were labeled as dollars. Chart allows you to do this easily.

Since you're changing the data, the data window should be active.

Activate the "Dating and Money" data window by clicking in it.
It may take two tries to activate the right window. Remember, if you can't see a data window, you can bring it to the front by choosing List... and clicking OK.

Choose Categories... from the Format menu.

The Categories Format dialog box appears.

Select Dollar under the Number Format heading.

Notice that the number in the box indicating the number of decimals has changed from 0 to 2. You don't want to clutter up your chart, so you'd rather not have any decimals.

Double-click in the box after the phrase "Number of Decimals".

The entire Number of Decimals box should be highlighted.

Type the number 0.

Click OK.

Now all numbers in the category column are preceded by dollar signs. This change is reflected in the chart window as well.

You've now completed your second chart. Before moving on to your third chart, you should save and print your latest creation.

Choose Save As... from the File menu. Type a name before clicking Save.

Choose Print Chart... from the File menu.
Remember that the Chart window must be active (in front) in order to print the chart.

Choose Quit from the File menu.

Before moving on to your final chart, feel free to take a break.

Your Final Chart

Now that you're familiar with the basics of Chart, this third chart should be a cinch.

Double-click on the Chart icon.

After a few moments, the familiar chart and data windows will appear.

Your third chart will be a comparison between males' and females' responses for which activities they prefer for a first date. You'll have two series of data. The categories will be the activity and the values will be the percentage of favorable responses to the activity.

First, you'll type in your group's data for males. Your data includes text again, so be sure to choose Text from the Data menu.

Type "Males" as the Series Name.

Type "Activity" for the Category name and "Response %" for the Value name, then click OK.

Enter the data so that your data window looks like the one shown below.

![Data window](Image)
Plotting the Series

After all the data has been entered, plot the series by clicking in the Plot Series box.

The preset column chart appears in the chart window. Since you want to use a column graph for this data there's no need to choose another Gallery option.

Multiple Series

Well, that's half the battle. Now you'd like to plot the data for females on the same set of axes.

Activate the New Series window by clicking in it.

If for some reason you can't see the New Series window, remember to bring it to the front by choosing List... from the Data menu and clicking OK.

Choose Text... from the Data window.

Change the series name to "Females", but leave the category and the value names unchanged. Click OK.

This tells Chart that you'd like to enter a new data series with the same characteristics as the previous one.

Chart is now waiting for the data. Since all the categories for the two series are going to be the same, you can save extra typing by copying the original series into the new series and then changing the values.

Copying Data

Activate the data window entitled "Males". If necessary, use the scroll bars to scroll to the top of the data.

Position the pointer above the word "Movies".

The pointer should change to a horizontal 1-bar.

With the mouse button depressed, drag downward until the entire series is highlighted.

Choose Copy from the Edit menu.
A copy of the series is placed on the Clipboard. You'll now paste the copy of the series in the Females data window.

**Activate the "Females" data window by clicking in it.**

**Choose Paste from the Edit menu.**

Now you need to change the values to correspond to the data that you collected for females. You'll need to scroll to the top of the window.

**Double-click on the number 65 opposite the word "Movies".**

The number should become highlighted. If not, make sure the I-bar is directly over the number and try double-clicking again.

**Type the number 53.**

The new number replaces the old.

**Press the Enter key twice to skip to the next value.**

Notice that after you pressed the Enter key once, the word "Party" was highlighted. After you pressed it a second time, the corresponding value became selected.

**Change the rest of the series to match the values shown here.**
If you make mistakes while entering data, remember you can correct them using the Backspace key.

You’ll want to compare the values for females against the values for males. The best way to compare two series graphically is to plot them both on the same set of axes. Chart makes this easy.

**Click the Plot Series box in the Females data window.**

**Activate the chart window.**

Your chart now has two columns for each category.
Using Legends

Unfortunately, it is impossible at this stage to tell which column represents which series without referring to the actual data. This is another good place for a legend. A legend makes it possible to plot several graphs on the same set of axes without getting them confused.

Choose Add Legend from the Chart menu.

A legend is added automatically.

Plotting Order

Bring the Males and Females data windows to the front by choosing List... from the Data menu and clicking OK.

Notice the "Order" box in each of the windows. This refers to the order in which the series was plotted. The Males data series was plotted first, so a "1" appears in its order box and the first column for each category on the chart corresponds to the Males data series. Suppose you wanted to have the Females data series plotted first.

Activate the Females data window.

Double-click in the Order box to select it.

Type "1" to make this the first series plotted.

When you activate the chart window again, the series is replotted but this time the first column of each category refers to females and the Order box for the Males data series shows "2". This change is reflected in the legend as well.
The chart is basically complete. All that remains is to add some finishing touches. Remember, the idea is to make the chart both informative and eye-catching. Chart has two menus devoted solely to these goals: the Chart and Format menus. Unfortunately, you don't have time to cover all the features in these two menus, but you'll learn the basics.

To make room for the legend, Chart made the plot area (the area in which the chart is drawn) smaller. Now some of the category names are too wide. To fix this, make the chart bigger.

Drag the window by its title bar toward the upper left corner so it has room to grow.

Position the pointer in the resizing box in the lower right corner of the chart window.

Press the mouse button and drag outward to make the chart window larger so that it fills up most of the screen.

Notice that the window is larger but the actual chart size hasn't changed.

Choose Select Chart from the Chart menu.

Handles appear around the chart to show that the chart is selected.

Drag the lower right handle outward until it just touches the resizing box.
Changing a Legend

Moving a Legend

The Chart expands to fill most of the window. To unselect the chart, just click anywhere in the grey desktop outside the chart window.

You could make your chart look even less cramped if you could have the legend appear below the chart. Fortunately, this is easy to do.

You can select almost anything in the chart window simply by clicking on it. This is true for text, legends, patterns, axes, and so on. Once you've selected an item, you can change it in a variety of ways.

Select the legend by clicking anywhere on it.

Small black handles should appear around it.

Choose Legend... from the Format menu.

In a few seconds, the Legend dialog box appears.

Under the Type of Legend heading, click in the small circle next to "Bottom".

Click OK.
The legend moves beneath the chart, and the columns are no longer cramped. The legend would fit better in the lower left corner. You'll move the legend manually the same way you moved text earlier in this module: by dragging it to the desired position.

**Position the pointer on the perimeter of the legend.**

The pointer should change to a four-way arrow.

**Press the mouse button and drag the legend into the lower left corner as shown here.**

The Patterns... option is very useful in the creative formatting of your
chart. It allows you to alter the appearance and pattern of the selected object. Since the legend is currently selected, you can now change its background and/or border pattern.

With the legend still selected, choose Patterns... from the Format menu.

Change the border style to Round by clicking in the small circle just to the left of the word "Round". Click OK.

This rounds the corners of the legend border.

The chart's current title is "Females". But that name no longer applies, since the chart also contains data for Males. Fortunately, Chart allows you to change just about anything.

Click on the text "Females".

The title of the chart is now selected, and can be edited as in MacWrite. Your intent is to change the current title "Females" to a more general phrase, such as "First-Date Activities".

Double-click on the word "Females".

The entire title is now highlighted.

Type "First-Date Activities".

If the text area is too small, some of the letters may not fit. You can enlarge the area by dragging the handle at the center of the left edge to the left.
Note that the text area can be extended vertically in a similar fashion. However, enlarging it too much will interfere with the plot region.

With the title still selected, choose Text... from the Format menu.

A dialog box appears. You can change the font, the style, and the size of the letters in the title much like you change type styles and sizes in MacWrite, just by clicking in the circle to the left of the desired style or size.

Change the style to bold and the size to medium. Click OK.
You may have to resize the title rectangle in order to see it all. Remember to use the handles to resize the region.

You may select the contents of the entire chart, including the legend, the title, and the plot area, by using the Select Chart command.

Choose Select Chart from the Chart menu.

Choose Patterns... from the Format menu.

You will see a dialog box displaying a variety of patterns and styles.

Change the border weight to medium.

As you might expect, you do this by simply clicking on the border weight you desire. A dark outline is drawn around the chosen border weight to indicate that it has been selected.

Select a double border by clicking in the Double circle.

Click OK.

If your new border overlaps with your title or legend, click somewhere outside of the border (to unselect the chart). Then click on the text or legend. Use the handles around the text to move the selected area so it no longer overlaps.

You've now created a very professional-looking chart.

Choose Save As... from the File menu.

Name your new chart document "First Date".

Click the Save button.

Before printing a chart, you can set up a special format for the page. By choosing a wide orientation, you can get the chart to fill the entire page. You can also add special headers or footers—text that will appear on the top or bottom of the page.

Choose Page Setup... from the File menu.

The Page Setup dialog box appears, displaying various options.
Select Wide orientation.

Type "Dating Survey" in the page footer box. Then click OK.

Now go ahead and print your chart. Make sure the chart window is selected.

Choose Quit from the File menu.

You're back at the Macintosh desktop.

Review

In this module, you've learned:

• How to enter your data by creating a new series, specifying the data's type, and then typing in the data
• How to plot the data by clicking the Plot Series box and then choosing the appropriate chart type
• How to analyze data using the Analyze... command
• How to use the Patterns... command to customize borders
• How to use handles to move and resize a selected item
• How to format the data using the Categories... command
• How to use other creative formatting techniques to customize your chart, such as adding and moving legends, text, and arrows

What to Turn In

Turn in a copy of each of your three charts.
Microsoft Chart gives you a number of formatting options that give you a great deal of control over the way your chart presents its data. The impression your chart makes has a great deal to do with how you format it, as the two examples below illustrate.

The area chart above illustrates sales figures for a six-month period. Elements of its format were chosen specifically to accentuate what appears to be a very steep downward trend. Using the Patterns... command from the Format menu, a black fill pattern was selected to provide maximum contrast. Using the Select Plot Area command from the Chart menu, the plot area was reshaped to be taller and narrower, making the decline appear more drastic.
This second chart is the *same* type of area chart using the *same* data as the first. In this case, however, formatting commands were used to make the decline appear more gradual. A grey area fill pattern was chosen to provide less contrast with the white background. The Plot Area has been widened horizontally and lengthened vertically to make the decline appear shallower.
Line Versus Scatter Charts

Microsoft Chart can be used to plot numerical results from experiments done in the lab. In an experiment to measure cardiac output, measurements of the dye concentration in the blood were taken at one-second intervals. Because this data was taken at regular intervals, the data points should be equally spaced along the category axis.

Suppose the data wasn't taken at regular intervals, but instead, was taken randomly (at nonfixed time intervals). A plotted chart of this set of data, then, would show a sparser set of data points. Below is a line chart of the dye concentration in the blood plotted against random time intervals.

![Line Chart](image)

Notice that there is the same amount of space between the 1-second and 4-second marks on the axis as there is between the 12-second and 13-second marks. This changes the shape of the curve so that it is no longer accurate.

By changing the chart to a scatter chart (with lines connecting the data points), the categories are plotted at the correct place on the category axis scale. Thus, the curve remains accurate. Note how it differs from the previous line chart.

This illustrates the basic difference between a line chart and a scatter chart. In a line chart, the categories are equally spaced. In a scatter chart, the categories axis reflects the actual values of the data.
Exercises

1. What are the advantages of using a computer and an application like Microsoft Chart to create charts and graphs? What are the disadvantages?

2. What type of series (Sequence, Date, Text, or Number) would you use to put the following data? In each case, which would be the category and which would be the value?
   
a) The number of earthquakes in California in each of the years between 1970 and 1985.
   b) The amount of money a film made versus how many Oscars it won.
   c) The number of new cars Americans bought in 1985 and where they were made (Europe, Japan, or America).
   d) The number of customers through each of the numbered check stands at a supermarket.

3. What type of chart would you use if you were to plot the series in Exercise #2? (Limit your choices to Column, Pie, Line, and Scatter.) Plot and explain why you chose that chart type.

4. Chart allows you to plot two or more sets of data on the same set of axes. Give a few examples of different series that might be plotted this way.

5. Using formatting techniques you've learned, reformat the second chart that you created in the Chart module. Add a legend (position it where you think it looks best), enlarge the chart area, change the font and the style of the text, and add a border around the title. When you're finished, turn in a copy of your completed chart.
6 Database Management

About Database Management
Microsoft File Part 1
Microsoft File Part 2
Galleries
Exercises
About Database Management

Data bases are large, organized collections of related information, or data. A simple example of a data base is the telephone directory. The telephone directory is a listing of people, their addresses, and their phone numbers organized alphabetically by last name.

Database management is the storing, sorting, updating, retrieving, and summarizing of the information stored in a data base.

A data base is made up of groups of information called records. In the phone book example, each listing is a record. A typical listing would include pieces of information like last name, first name, address, and telephone number. Each of these pieces of information is called a field.

The Phone Book as Database

The information in a typical phone book entry—

Chung, Connie 879 Baykt MP............. 988-5654

is broken up into different fields—

<table>
<thead>
<tr>
<th>Name</th>
<th>Address</th>
<th>City</th>
<th>Phone Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chung, Connie</td>
<td>879 Baykt</td>
<td>Menlo Park</td>
<td>988-5654</td>
</tr>
</tbody>
</table>

A complete set of fields forms a record—

<table>
<thead>
<tr>
<th>Name</th>
<th>Address</th>
<th>City</th>
<th>Phone Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>212 Chung, Connie</td>
<td>879 Baykt</td>
<td>Menlo Park</td>
<td>988-5654</td>
</tr>
</tbody>
</table>

A set of records forms a data file—

<table>
<thead>
<tr>
<th>Phone Book</th>
<th>Name</th>
<th>Address</th>
<th>City</th>
<th>Phone Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>211 Chu, Bert</td>
<td>975 Boston</td>
<td>Palo Alto</td>
<td>322-9877</td>
<td></td>
</tr>
<tr>
<td>212 Chung, Connie</td>
<td>879 Baykt</td>
<td>Menlo Park</td>
<td>988-5654</td>
<td></td>
</tr>
<tr>
<td>213 Cronkite, Walter</td>
<td>2233 Lecumes</td>
<td>Atherton</td>
<td>544-8823</td>
<td></td>
</tr>
<tr>
<td>214 Roberts, Vicky</td>
<td>773 Green</td>
<td>Redwood City</td>
<td>217-2244</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>data file</th>
</tr>
</thead>
</table>

6-2 DATABASE MANAGEMENT: ABOUT DATABASE MANAGEMENT
For example, a record in the phone book database might look like this:

**Chung, Connie, 879 Baykt Street, 555-7670**

In this example, the number "555-7670" would be the number stored in the phone number field, "Chung" would be stored in the last name field, and so on.

Data bases are used virtually anywhere information needs to be organized, sorted, or reported. Schools often use data bases to keep track of students and their grades, and businesses can use them to keep track of inventory, and personnel information.

Traditional data bases can present some problems, however. Suppose, for some reason, that you want a list of everyone in the San Francisco area with the first name Bertha. If you got out your trusty copy of the telephone directory, you could go through the listings one by one, checking each entry for a Bertha from San Francisco. But because your telephone directory is organized only by last name, not by first name or city, your search would be long and tedious.

Not too long ago, people who do this sort of thing for a living got understandably tired of it and turned to computers for help. With computer data base managers, you can quickly and easily enter, update, sort, and find the information in your data base. You could organize a computerized phone book not only by last name, but also by city or first name, allowing you to find the Berthas from San Francisco in seconds, not hours (perhaps a mixed blessing).
Microsoft File is a database management application for the Macintosh. Taking advantage of the graphic capabilities of the Macintosh, File lets you easily design the way your data base or datafile will appear. Using the mouse, you design forms which you use to enter, view, and retrieve information from your datafile. Fields in the datafile may consist of text (for instance, a name), number (a price), a date, or even a picture from MacPaint or a chart from Microsoft Chart.

File also lets you use the information in the datafile to generate reports. A report is a way of presenting and summarizing the information in your datafile in tabular form. You can perform calculations of your information in a report.
Microsoft File
Part 1
The Task

It's time once again to decide which classes to take. Unfortunately, this is no easy task, since you have to schedule classes that don't conflict with each other while making sure your work load isn't too hard. To ensure that you end up a well-rounded student, your school has a distribution requirement that encourages you to take classes in a wide variety of areas: humanities, natural sciences, and social sciences.

With all these things to think of, how will you do it? Traditional class listings are organized by department, not by meeting times or by credits given. Going through the listings in search of classes could take several eternities because the information just isn't organized in the way that makes your job easy.

Fortunately, your student union has created a Microsoft File data base of many of the classes available, to help students in your situation. You'll use it to select the right courses to take—and to learn a little about how data bases are used.

You'll begin by organizing the data base—the datafile in Microsoft File lingo. First you'll sort the list of classes by department and course name, then you'll find all the classes that fulfill the social sciences distribution requirement. You'll then print a list of these classes.

Next, you'll generate a report on the different classes that fulfill the humanities and natural sciences distribution requirements. The report will be in the form of a table.

Finally, in Part 2 of the Microsoft File module, you'll actually create your own datafile to store information about classes you've already taken.
<table>
<thead>
<tr>
<th>Distribution</th>
<th>Credits</th>
<th>Course</th>
</tr>
</thead>
<tbody>
<tr>
<td>Humanities</td>
<td>3</td>
<td>Soy Products and Piety</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Tofu and the Reformation</td>
</tr>
<tr>
<td></td>
<td>4</td>
<td>Classical Scholarship</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Cosmic Change in Early Modernism</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The Operas of Beethoven</td>
</tr>
<tr>
<td></td>
<td>5</td>
<td>America 1938-1948</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Human Prehistory</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Shakespeare's Comedies</td>
</tr>
</tbody>
</table>

Minimum for Humanities: 3

<table>
<thead>
<tr>
<th>Natural Sciences</th>
<th>Credits</th>
<th>Course</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>3</td>
<td>Applied Mechanics: Statics</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Blood</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Differential Equations</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Fluid Mechanics</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Metabolic Processes</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Modern Physics</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Physical Chemistry</td>
</tr>
<tr>
<td></td>
<td>4</td>
<td>Rocks and Minerals</td>
</tr>
</tbody>
</table>

Minimum for Natural Sciences: 3

Count: 16
You'll begin by inserting the Microsoft File disk into your Macintosh.

Turn on the Macintosh and insert your Microsoft File disk—label side up and metal end first—into the built-in disk drive.

You'll soon see the Macintosh desktop with the icon of the Microsoft File disk in the upper right-hand corner.

In this module, you'll need to use the Class Listings document that has been created and stored on the Approaching Macintosh Documents Disk. You will need to copy the Class Listings document onto your Microsoft File disk.

Copy the Class Listings document to the Microsoft File disk.

If you're unsure of how to do this, please see the Introduction to Macintosh module.

Now you'll open Class Listings by double-clicking the Class Listings icon. Note that opening the Class Listings document will automatically open Microsoft File.

Double-click the Class Listings icon on the Microsoft File disk to open the document.

If you're using a backup copy of File, you'll need to insert your original Microsoft File master disk when instructed.

The Class Listings datafile window appears, displaying the first record of the datafile.
In the Class Listings datafile, each record contains information about a specific class. The individual pieces of information about each class—its name, department, instructor, and so on—are the fields for each record.

For example, in the record for the Soy Products and Piety course, Religious Studies appears in the Department field, Jay Gatsby in the Instructor field, 1:30 in the Time field, and so on.

Microsoft File displays the current datafile in the datafile window. Like any other window, you can move the window by dragging its title bar, or resize the window using the size box at the lower right of the window. You can scroll through the window using the scroll bars at the right and bottom of the window to view information not on the screen. Consult the Introduction to Macintosh module if you’re unfamiliar with windows and scrolling.

Notice the "30/30" in the lower left corner of the datafile window. The first number refers to how many records can be seen in the datafile window, while the second refers to how many records there are total in the Class Listings datafile. Currently, all 30 records in the Class Listings datafile are in the datafile window. You could see them all by scrolling through the datafile window.

Using the vertical scroll bar, scroll through all the records in the datafile window.

Notice that the last record has no information in it. This is the New record (hence the word New in the left margin where the record number should be). If you were to add another record, you would type its information into the New record.

Using the vertical scroll bar, return to the first record.

While scrolling through the records, you may have noticed that they weren’t organized in any particular fashion. That makes this class listing even less useful than the listings which are organized by department. Fortunately, File allows you to organize the records of a datafile in many different ways.

The first step toward making the datafile more organized is to sort the records, making it easier to pick useful classes.

Choose Sort... from the Organize menu.

You will be presented with the sort window.
The sort window is rather small compared to the size of a record. It is possible, however, to expand size of the sort window quickly. By double-clicking the title bar (the bar along the top of the window with the word "Sort" in it) or size box of the sort window, the window will expand in size to fill the entire screen.

**Double-click on the title bar of the sort window to expand the window.**

The sort window will expand in size and become the only window visible on the screen.

Notice that the sort window looks like a record with no data in the
fields. By clicking on a field in the sort window, you tell File that you want to sort the records according to the values in that field.

To make this class list at least as good as the others available, you should begin the organization of the datafile by sorting the courses by department.

**Click the Department field in the sort window.**

The Department field is the blank box next to the word "Department".

Notice that a "1" appears in a box at the left of the field and "A->Z" appears in the field. This means that the first sort of the records in the datafile will be done in ascending alphabetical order on this field. This way, all the courses in the English department will appear in the datafile before the courses in the Math department, which will be before the courses in the Religious Studies department (E before M before R, at least in the English alphabet).

You can clear the sort window by clicking **Clear**. You need to do this if you ever change the fields on which you want to sort, or if you mistakenly choose a field on which you don't want to sort.

Now that you've specified your sort field, you can begin the sort.

**Click Sort to sort the records.**

Notice that at the bottom of the screen Microsoft File tells you the progress of the sort.
Multiple Sorts

Using the scroll bar, scroll through the sorted records in the datafile window.

Notice that all the courses are sorted according to their department. However, notice also that courses in the same department are in no particular order. It would be nice to have all the courses in one department sorted by course name. A second sort should be performed.

Choose Sort... from the Organize menu.

The sort window appears again. Notice that the first sort, alphabetically according to the Department field, is still chosen.

To specify a second sort, simply click on the field you wish to perform the second sort. In this case, you'd like to perform a second sort on the Course field.

Click on the Course field in the sort window.
The Find... Command

A "2" appears in the box at the left of the field, and "A->Z" appears in the field. The "2" means that this field specifies a second sort—all the records will first be sorted by the Department field, and records with the same Department field will be sorted according to the Course field.

Click Sort to sort the records.

The records are now sorted by course name as well as by department.

Besides allowing you to sort your records according to a field value, File allows you to find records in the datafile that meet any requirements you choose. For example, you could find all the courses that are worth 3 credits, or that are in the English department, or that don't have a final exam. You can even combine all of these requirements, and find all the 3-credit English courses that don't have a final exam.

Choose Find... from the Organize menu.

The find window appears on your screen.
Find Operators

Notice the similarity between the find window and the sort window. The find window is also small compared to the size of a record, so it should be expanded in the same way the sort window was expanded.

Expand the find window by double-clicking on the find window title bar.

To specify values you want to find, simply type your requirements in the appropriate field. For instance, if you want to find all the courses that don't have a final exam, you simply type "No" in the Final field (the field to the right of the word "Final?").

You can also enter multiple requirements in the same field, simply by separating them by commas. For example, you can find all the courses in the English and Psychology departments by typing "English, Psychology" in the Department field.

There are several operators you can use when performing a Find.... The operators allow you to specify in greater detail the exact criteria you are looking for. Here's a list of operators you can use:

- \( = \) Match with values exactly equal to what you type.
- \( <> \) or \( >,< \) Match with values not equal to what you type.
- \( >, < \) Match with values greater than, less than what you type.
- ... Match with values between values you type.
Wild Cards

>= Match with values greater than or equal to what you type.

<= Match with values less than or equal to what you type.

For example, "3..5" in the Credits field will find all courses worth between 3 and 5 units of credits, while "<=3" in the Credits field finds all courses worth 3 or fewer credits.

You can also use the following operators to specify "wild cards". A wild card matches with any character or characters.

? Match a single character.

* Match any characters.

For example, "*le" would match "ale" and "pale," but "?le" would match only "ale" (since "?" matches with only one character).

You use wild cards to find words inside of or after other words. Recall that the Course Listings datafile has only one field for the instructor's name. The names are entered into the field first name first, last name second. If you wanted to find all the classes taught by Professor Smith, you could use the "*" wild card. You'd simply type "*Smith" into the instructor field, and Microsoft File would find these records.

By not using any operators or wild cards, Microsoft File searches for all entries that begin with what you type.

You can put values into any or all of the fields when performing a Find... The Clear option will clear all entered values.

Since your goal is to get a list of classes that satisfy the social sciences distribution requirement, you should use the Find... command to find all these classes.

Type "Social Sciences" in the Distribution field and click Find.
Notice that the numbers in the lower left-hand corner now say "9/30". This means that of the 30 records in the datafile, 9 were found that fulfill the social sciences distribution requirement. These 9 records are now the only records visible in the datafile window.

This list is still a little long; you can shorten it further by finding classes worth more than 3 credits.

Choose Find... from the Organize menu.

Note that the previous Find... requirement is still entered.

Type ">3" into the Credits field and click Find.

The datafile window now displays 7 classes (note the "7/30" in the lower left corner) that satisfy the Find... requirements you specified.

There may be some records that match the conditions you specified, but which you'd still rather not have visible in the datafile window.

Using the scroll bar, scroll through the records until the record for the class "Soy Foods and Nuclear Disarmament" is visible.

Notice that Professor Courtner's class requires several field trips. Since you like to spend your afternoons playing ultimate frisbee, you aren't going to sign up for this course. Therefore, you should hide this record from view.

Move the pointer over the record number for the class "Soy Foods and Nuclear Disarmament".

The pointer will change shape to a large, bold plus sign.
Click the mouse to select the record.

The record becomes highlighted.

Choose Hide Records from the Organize menu.

Choose Hide Records from the Organize menu. The record becomes highlighted.

Choose Hide Records from the Organize menu. The record becomes highlighted.

The record chosen is now hidden. Note that the numbers in the lower left corner now say "6/30."

To see all 30 records again, you would use the Show All Records command from the Organize menu. Don't choose this yet, though; you haven't printed a list of the classes yet.

Pull down the File menu.

Notice that there is a command to Save Records As... but not to save. This is because File automatically saves whatever changes you make to the datafile. You can't open a datafile, play with the values, and then quit without saving changes—changes are always saved.

Since you haven't altered any values, you really haven't changed this datafile. All the records are still intact, even those you can't see in the datafile window.

Now that you've made the list of classes into a more manageable size, you should print the list out to better view the information. The first thing you need to do is to choose the format in which the records will be printed.

Choose Page Setup... from the File menu.
Note the different options you have. Besides selecting paper type and orientation, you can choose to have a header (text that will appear at the top of each printed page) and a footer (text that appears at the bottom of each page). The Print Grid Lines option will cause the borders around the records to be printed. You can also choose to print out the record numbers. The Mailing Labels option is used when printing mailing labels (bet you figured this one out already).

Type in "Class List" for the Page Header. Select the Print Grid Lines option, but not the Print Record Numbers or Mailing Labels options.

An option is selected when there's an X in its box. Click the boxes to select and deselect the options as needed.

Click OK when you're finished.

Select Print Records... from the File menu.

The Print dialog box appears.

Click OK to begin printing.

You now have a printed list of classes to take.

Now that you've printed your list of classes to take, you'd like another printed list of the classes that fulfill the distribution requirements in the humanities and natural sciences. Since it's important to keep track of your work load, you'd like to compare these classes according to the number of credits they are worth. To create such a list, you'll need to
generate a report.

A report is a way of presenting the information in a datafile in table form (one column for each selected field). You can also perform various calculations on the data. Reports allow you to analyze the information you have, make summaries, and determine trends. For your report, you'll be taking advantage of the summarizing features.

You begin a report by finding the records that contain the information you want reported. Since you want a report on classes that fulfill the humanities and natural sciences distribution requirements, you'll want to have only these classes visible in the datafile window.

Because you used the Find... command earlier, currently only classes that are worth more than 3 credits and fulfill the social sciences distribution requirement are visible in the datafile window. You'll need to make all the records visible again, and then find the records you're interested in.

Choose Show All Records from the Organize menu.

All the records should now be visible in the datafile window.

Now find all the classes that fulfill the humanities or natural sciences distribution requirements.

Choose Find... from the Organize menu.

Click the Clear button.

Type "Natural Sciences, Humanities" into the Distribution field and click Find.
This way you'll find all the records that fulfill one of these distribution requirements. You don't have to sort the records since sorting will be done when the report is made.

Select Report... from the Organize menu.

You are presented with the report window. It may look a little confusing now, but things will become clear in a moment.

Like the sort and find windows, the report window is easier to work with if it has been expanded.

Expand the report window by double-clicking on the report window title bar.

The report window should now look like this:
There are many rows in the report form. Each of these rows has a title. The left-most column contains the titles of the various rows, and is therefore called the column of titles. Note that the entire title of each row may not be visible in the space provided.

The report window is divided up into three areas—Sort, Not Sorted, and Not Shown. Each area is divided by double lines. In the Sort area, you will see the Department and Course fields. That's because you previously performed a sort using these fields. If you hadn't performed a sort (for example, if you had just opened the datafile), this area would be empty.

The fields in the Sort area will be in the first columns of your report, and will determine the grouping and ordering of the data in the report. Note that the first field in the Sort area is the Department field. That's because you performed the first sort by department. Since the second sort was performed by course name, the Course field is the second field in the Sort area.

Next to the Sort area is the Not Sorted area. These fields are not sorted when they appear in the report.

Use the bottom scroll bar to scroll to the right until the Not Shown area is visible.

As you might suspect, fields placed in the Not Shown area will not appear when the report is printed.

You can move fields among the three areas by selecting them in the Field row and dragging them to another area. Since the report will compare the courses according to the credits they are worth, you should move the Credits field into the Sort area.
Scroll horizontally through the report window until the Credits field is visible.

Position the pointer over the Credits field in the Field row (the second row from the top). Press and hold the mouse button.

Move the field slightly to the right.

Notice the vertical line that appears in the form window.

Release the mouse button.

When you press and hold the mouse button, the field becomes selected, and a vertical dotted line appears in the window. When you drag the field, this dotted line will follow. The dotted line indicates where the field will be inserted when you let go of the mouse button. The report window will scroll automatically for you as you drag right or left.

While the pointer is positioned over the Credits field, press and hold the mouse button.

Drag the Credits field to the left until the dotted line is positioned in the Sort area between the Department field and the Course field.
Next, you'll need to move the Distribution field into the Sort area. Your first sort should be performed on this field, so you should make this the first field in the Sort area.

Move the Distribution field into the Sort area, in front of the Department field.

Since you don't really care which department the courses are in (your only concern is that they fulfill a distribution requirement), you can move the Department field into the Not Shown area.

Move the Department field from the Sort area into the Not Shown area.

You can move many fields at once by selecting them together and moving them all as one group. When you move the fields, only one dotted line will appear in the report window, and all the fields selected will be inserted where the dotted line is positioned.

You can select multiple fields by clicking one field and then shift-clicking the other fields. (Shift-clicking means to hold down the Shift key while clicking the mouse button.)

Since your report is concerned only with the Distribution, Credits, and Course fields, you should put the remaining fields into the Not Shown area.

Shift-click to select all the fields in the Not Sorted area.

Move all these fields into the Not Shown area.
You should now have the Distribution, Credits, and Course fields (in that order) in the Sorted area. The rest of the fields should be in the Not Shown area.

Note that there are no fields in the Not Sorted area. If you wanted to put a field in this area, you would drag it between the two sets of double lines.

One of the reasons why you'd generate a report rather than simply print a list of the records in the datafile is that a report allows you to perform calculations on your information. For example, you can count the number of courses which are worth 3 credits, or find the average number of papers written in English classes.

For your report, you'd like to know how many classes there are that fulfill the humanities and natural sciences distribution requirements, as well as the minimum number of credits you can take to fulfill the distribution requirements. You'll use summary fields to get this information.

Notice that there is a row titled Grand. You can get a grand summary for any field by applying various functions to the data. A grand summary is an overall summary of the data in a particular field for all the records in the datafile window.

Confused? Think of it this way: Each of the records uses the same fields to store information. Sometimes you'll want to see how the information for one record is related to the information in another record. To do this, you compare the values they have stored in the different fields.
For example, each record has a field to store the number of credits that course is worth. If you wanted to see what the average credit value of classes was, you would add up the values stored in the Credits field for each record, and divide by the number of records. That could become pretty tedious, especially if there were a lot of records. Fortunately, Microsoft File can perform calculations like this for you, by simply making a grand summary of the information in the Credits field.

Grand summaries perform calculations on the values in the fields so you don't have to.

Since you'd like to know how many courses fulfill the humanities and natural sciences distribution requirements, you should create a Grand Summary field to perform this count.

Click beneath the Course field in the row titled Grand.

The field becomes highlighted.

Choose Format Summary Field... from the Form menu.

A dialog box appears, presenting you with a list of functions you can perform on that field for all the records. These functions specify the summary to perform—for example, you can count the number of values, take averages, or find the standard deviation of values. Any and all functions listed can be selected, provided they apply; for example, File won't let you take the average of text values.

Since you want to know how many classes fulfill the distribution requirements, you should select the Count function. Note also that you can't choose anything else for this field. That's because the course names are text—and it's hard to take the average of letters.
Select Count and click OK.

"Count" now appears in this field.

Notice that one of the rows is entitled "by Distrib", which is short for "by Distribution", another "by Credits", and another "by Course". Because you are sorting by the Distribution, Credits, and Course fields, you can perform summaries for each separate value of these fields.

Whereas a grand summary summarizes information for all the records in the datafile window, a summary by one of the fields is performed for each different value of that field.

Since each record currently visible in the datafile window fulfills either the humanities or natural sciences distribution requirement (remember you performed a Find... to find only these records), a summary done by Distribution will be performed once for all the records which fulfill the humanities distribution requirement, and once again for all the records which fulfill the natural sciences distribution requirement (since these are the two different values of the Distribution field).

Whereas a grand summary will find the average of the credit values for all the classes, a summary by the Distribution field will find the average credit value for classes in each of the distribution areas.

Double-click below the Credits field in the row entitled "by Distrib".

Double-clicking a summary field is a short cut to getting the Format Summary Field dialog box.

Since you want to know what the minimum number of credits is that
you can take and still fulfill the distribution requirements, you should select the Minimum function.

Select Minimum and click OK.

File lets you preview how your report will look before you print it, so you won't waste time or paper printing.

Click Preview, and watch your report go by.

You can click the Pause button to pause the preview. If your report had many columns, and all of the columns of your report were not visible, you could use the scroll bar at the bottom of the report window to see them all after you've clicked Pause.

Click Done when you're done.

Note the minimum credit values for each distribution area. You can now see that to fulfill the humanities distribution requirement, you'll have to take a 4-credit class, while there is a 3-credit class that fulfills the natural sciences distribution requirement. Note also the total number of courses at the bottom of the report.

A Summary Report will give you a display of the results of the calculations you made in the summary fields. The individual entries will not be printed, only the values calculated by using the functions you specified in the "by Distrib" and Grand rows will be printed.

Reports are automatically saved with datafiles. If you change a report, though, you will be asked if you want to save the changes. You can also save reports separately (and subsequently open them directly from the desktop). When the report window is active, simply choose Save.
Report As from the File menu. You can save the report specification (the report design and the records the report is based on), or simply save the text of the report (as you saw it during the preview). The report text can be used as a document for Microsoft Word or as data for a print merge. See the Advanced Microsoft Word module for more information on print merging.

You print reports in the same fashion that you print records, with the exception of one special Page Setup option, which lets you start a new page each time the value in the first column changes (for example, you could have all the records for each distribution area printed on separate pages).

One nice thing about reports is that even if you change the data in the datafile, File remembers how the report should look and how it should be printed. So you can update the datafile and simply print out the updated report again without doing any work in the report window.

Choose Print from the File menu.

Click OK to print your report.

You're finished. You should now quit Microsoft File.

Choose Quit from the File menu.

You're back at the Macintosh desktop.

In this module, you've learned:

• What a database is and how an electronic database helps you organize information
• What fields, records, and datafiles are and how they are related
• How to sort the records of a datafile
• How to find records in a datafile that meet the requirements you set
• How to print the records of a datafile
• How to create, organize, and generate a report
• What summary fields are and how they are used

All that remains for you to learn about databases is how to create one yourself. To learn how to create a database, turn to the Microsoft File Part 2 module.

Turn in the printed list of records and the printed report.
Microsoft File
Part 2
The Task

In the Microsoft File Part 1 module, you learned how to organize the records of a datafile, and how to generate a report from the information stored in a datafile. Now you'd like to create your own datafile that will store information about the different classes you've taken during your college career.

To do this, you'll design a form to structure the information in your datafile. First you'll create fields to store course information: the course name, credit value, instructor's name, as well as fields to store the results of your test scores and your total course score. You'll also include fields for the weights of these different scores, allowing you to calculate your total course score. You'll then arrange the field locations so your datafile will be more readable. You'll also format the various fields to make the datafile more presentable. When the form is complete, you'll enter your data into the datafile.
<table>
<thead>
<tr>
<th>Score</th>
<th>Score</th>
<th>Weight</th>
</tr>
</thead>
<tbody>
<tr>
<td>Homework</td>
<td>75</td>
<td>20%</td>
</tr>
<tr>
<td>Midterm</td>
<td>80</td>
<td>20%</td>
</tr>
<tr>
<td>Final</td>
<td>88</td>
<td>50%</td>
</tr>
<tr>
<td>Other</td>
<td>91</td>
<td>10%</td>
</tr>
</tbody>
</table>

Course Score: 85.7

- Lab Project—Fusion
- Properties of Ferns

Course: Applied Nuclear Botany
Credits: 4
Instructor: Edgar Hess
Grade: A-
The first step in creating a new datafile is to open the Microsoft File application.

Turn on your Macintosh and insert the Microsoft File disk—label side up and metal end first—into the built-in disk drive.

If necessary, double-click on the disk icon to open it.

The Macintosh desktop appears. You'll now open Microsoft File.

Double-click the Microsoft File icon to open the File application.

If you're using a backup copy of File, you will be asked to insert your Microsoft File master disk.

When you open Microsoft File, you are presented with a dialog box asking whether you wish to open an existing datafile or create a new one. If you want to open an existing datafile, you would use the scroll box arrows to find the name of the file you want, and then double-click on it to open the document.

In this case, you want to create a new datafile. To do this, you need to give it a name. Microsoft File requires you to name your datafile before creating it.

Type "My Courses" as the name of the new datafile, and click New to continue.
Creating a Form

When you create a new datafile, you'll have to decide on how you will store your information. Since this datafile contains information about classes you have taken, you'll want a field for the course name, the instructor's name, the number of credits the course was worth, and the grade you received. You'll also need fields to store the various test scores and their weights.

You design a form to structure your data storage. When you design a form, you create fields to store your data and determine where these fields are positioned in the datafile. You can also add labels and text to make your datafile more readable. Therefore, when designing your form, you need to consider how you want your records to be presented in the datafile window.

For example, for the Course Listings datafile in the Microsoft File Part 1 module, we designed a form with fields for the course name, instructor's name, and the various course requirements. We also added labels to our form so that we could tell the different fields apart. We then positioned the fields so that the information they contained was presented in a straightforward manner.

Forms are created in the form window, which is the active window whenever you open a new datafile. You can therefore start designing your form right away. Behind the form window is the datafile window, with the name of your datafile, "My Courses", in the title bar.

The ruler on the left side of the form window is used to help you position and align fields. Fields placed in the grey hide area aren't visible in the datafile window. More on the hide area later.

Notice the flashing insertion point in the box with the border in the upper left corner of the form window. This is the new field. The
new field is the next field you should name.

The first piece of information you want to store is the course name, so you should now create a field to store the course name.

Type "Course Name" to name the new field.

Notice that when you start typing, a second field immediately appears to the right. This is the next new field. Whenever you name a field, File creates a new field for you to use.

Press Return when you finish typing the name.

When you press Return, you are presented with a dialog box asking you what type of information will be contained in this field—text, numbers, dates, or pictures.

Since the "Course Name" field will contain text, and text is already selected, you can simply click OK or press Return to make this field a text field.

Press Return to make Course Name a text field.

You have now made a field called Course Name that stores text. You can see it in the datafile window.

Some of the courses have names that are too long to fit in the Course Name field. Although File remembers the entire name, you're only able to see the portion of it that will fit in the box. Thus, you need to enlarge the field.

To resize a field, simply position the pointer at the right edge of the
field. When the pointer changes into a double-arrow, drag the mouse to the right to lengthen the field or to the left to shrink the field.

Position the pointer between the Course Name field and the new field.

The pointer will change to a double-arrow.

Drag the right border of the Course Name field to the right to lengthen the field. Continue dragging until the field is about half the size of the screen.

The dotted line indicates the new length of the field.

Even if a field is too small to display values in full, File still remembers everything that is stored in the field. Enlarging the field allows you to view the full contents of a field in the datafile window, but it doesn't increase the amount of information you can store in a field (which, by the way, is 32,767 characters maximum).

You should now make a field to hold the grade you received in the course, and another one to hold the instructor's name.

Click inside the new field (the field to the right of the Course Name field).

The insertion point now appears in the new field.

Type in "Grade" and press Return twice.

Remember that the default field type is text, so you simply press the Return key twice after naming a field to create a new text field.
The insertion point should now be inside the new field.

Type in "Instructor" and press Return twice.

Notice that as you enter more fields, the form window scrolls to the right automatically.

The next field you'll create will be to store the score you received on the final exam. This will be a number field.

Type "Final Score" as the name for the new field. Press Return when finished.

The Field Type dialog box appears.

Click Number and then click OK to make the Final Score field a number field.

You'll also want fields to hold your midterm score, as well as your homework score. An additional field would also be useful in case there were two midterms, a project, or papers that also contributed to your grade.

Type "Midterm Score" as the name for the new field. Press Return when finished.

The Midterm Score field, like the Final Score field, should be a number field. You can make the Midterm Score field a number field by pressing "n" (for "number") and then pressing Return. This way, you don't have to move your hands from the keyboard. Similarly, by pressing "p" you select the type picture, "d" selects the type date, and "t" selects the type text (in case you press an "n" or a "d" or a "p", and
then decide you want a text field after all).

Press "n" and then press Return to make the Midterm Score field a number field.

You should now create the remaining number fields. Don't worry about the sizes of the fields; you'll adjust these later.

Create the following fields by typing their names into the new fields one at a time. After typing each name, press Return, press "n", and press Return again to make the field a number field.

Homework Score
Other Score
Final Weight
Midterm Weight
Homework Weight
Other Weight
Course Score

If you had a score stored in the Other Score field, it would be nice to know what the score represented (for example, a project or a paper). So you'll need another field to hold a description of that score.

Make sure the insertion point is flashing inside the new field.

If necessary, click inside the new field.

Type "Description" to name the field. Press the Return key twice to make the Description field a text field.

Whoops! You forgot to make a field for the number of credits the course was worth! This field should be next to the Course Name field. What to do?

Don't panic. If you forget to create a field, or decide to add one later, just create the field and move it into the desired position.

To move a field, position the pointer over the field you want to move, then drag the field to the new location. When you press the mouse button, a vertical dotted line will appear in the form window. As you drag the field, this dotted line moves as well. When you release the mouse button, the field will be inserted where the dotted line is. If you drag past the right or left edge of the screen, the form window will scroll automatically.

Create a number field called "Credits".

Remember, to do this, type "Credits" into the new field, press Return, press "n", and press Return again.
Position the pointer over the Credits field.

The pointer changes shape to a four-way arrow.

Drag the field to the left until the dotted line is between the Course Name field and the Grade field.

The Credits field is now inserted between the Course Name field and the Grade field. The fields to the right of the insertion area have moved over to accommodate the field.

Notice that the Credits field is now next to the Course Name field in the datafile window.

Sometimes you'll want to hide a field (not have it visible in the datafile window). Perhaps you're showing this data base to your parents, and you don't want them to see the Grade field. You don't want to delete this field or any information you have stored in it; you just want to make it invisible.

By dragging this field into the hide area, the field will not be visible in the datafile window, but all the information stored in the field will be retained.

Position the pointer over the Grade field.

Drag the field down into the hide area.
Note that the Grade field is no longer visible in the datafile window.

To make a field visible again, simply drag it back in line with the other fields.

Drag the Grade field back up between the Credits field and the Instructor field.

The Grade field becomes visible again.

You've probably noticed that in the form you've created, the fields are lined up so that you can't see all the fields at once. It would be nice, though, to arrange the fields so that they are all visible at once (as they were in the Class Listings datafile in the Microsoft File Part 1 module).

You're also probably wondering why File automatically put all the fields on one line. That's because when you create a new datafile, File automatically used the List Helper option to keep the fields lined up.

Pull down the Form menu.

Notice that List Helper is checked. List Helper helps you make forms with fields that are aligned on one line.

When you resize a field, List Helper will move the fields to the right of the resized field to accommodate the new field size. List Helper will maintain the structure of your form, so that when you add, delete, or move a field, List Helper forces the other fields to adjust accordingly. If you hadn't been using List Helper when you resized and moved the different fields, you could have placed a field on top of another—the other fields would not have adjusted their positions.
By unchecking the List Helper option, you can arrange your fields in any manner you like. To uncheck the List Helper option, simply choose List Helper from the Form menu.

Choose List Helper from the Form menu.

You should now confirm that List Helper is unchecked.

Pull down the Form menu.

Notice that the List Helper option is no longer checked. This indicates that List Helper is now turned off.

You'll now resize the Course Name field again.

Lengthen the Course Name field so that it covers half of the Credits field.

Notice that the larger Course Name field covers up half the Credits field. The other fields did not shift over to make room for the larger Course Name field. This is because List Helper is now turned off.

Since you want to arrange fields over the entire area of the screen, it would be nice to have the form window as large as the screen area. You can expand the size of the form window the same way you expanded the find and sort windows before, by double-clicking on the form window title bar.

Expand the form window by double-clicking on the form window title bar.
You can now move fields easily any place you wish. Remember, however, that the shaded area is the hide area, and any fields placed there will not be visible in the datafile window. It's necessary, then, to move the hide line downward to create more space for the fields. You can do this now that the List Helper is turned off.

Position the pointer at the top of the hide area, on the hide line.

The pointer will change shape into an up-and-down arrow.

Drag the hide line down to the 3-3/4" mark.

Use the ruler at the left edge of the form window.
Moving Fields
Revisited

The white part of the window is where fields can be seen.

You're now ready to arrange the fields in the form window. You can move fields without List Helper the same way you move them with List Helper, except that now you can position them anywhere you like.

Drag the Course Name field down slightly from the top of the form window.

Drag the Credits field so it is positioned below the Course Name field. Leave a small amount of space between the two fields.
Move the Instructor field below the Credits field.

Move the Grade field to the right edge of the form window, across from the Course Name field.

The Final Score, Midterm Score, Homework Score, and Other Score fields should all be moved into place below the Instructor field. It would be easier to do this if you had them all visible on the screen and didn't have to scroll back and forth in the form window, dragging the fields over individually. By shift-clicking the four fields, you can select them all and drag them over together.

Using the horizontal scroll bar, scroll the form window until the Final Score field is visible.

Click the Final Score field.

Hold down the Shift key and click to select the Midterm Score, Homework Score, and Other Score fields.

All four fields should now be highlighted.

Drag the fields left until they are below the Instructor field.

All the fields move together. You should now unselect the fields.

Click anywhere in the white area to unselect the fields.

Position these fields as shown.
Now that you know how to move multiple fields, you should move the remaining fields into position.

Move the remaining fields into position as shown.

Remember to use the ruler to help you position the fields.

All the fields should now be visible on the screen. You'll now begin sizing, repositioning, adding labels, and formatting the fields.

First, the fields should be properly sized.
Resize the Course Name field so that it is about half the size of the form window.

Shrink the Credits field so that only the letters "ts" are visible in the field.

Enlarge the Instructor field so that it is as large as the Course Name field.

Shrink the Grade field so that only the letters "Gra" are visible in the field.

Move the Grade field so that it is against the right edge of the form window again.

You've now resized the top portion of your form.

It's also possible to resize several fields at once. Simply select the fields you wish to resize and resize any one of them. They will all shrink or expand accordingly.

Shift-click to select the Score fields (Final Score, Midterm Score, Homework Score, Other Score, and Course Score).

Shrink the Final Score field so that only the word "Score" is visible in the field.

All the selected fields will shrink as well.

You should now shrink the different Weight fields.

Click to select the Final Weight field.
Shift-click to select the remaining three Weight fields.

Shrink the Final Weight field until only the letters "ight" are visible in the field.

The other fields will also shrink.

With the List Helper turned off, you can resize a field vertically as well as horizontally. Simply position the pointer at the bottom of the field. The pointer will change to an up-and-down arrow. You can then drag the bottom of the field up or down to change the vertical size of the field. Positioning the pointer at the lower right-hand corner will allow you to resize the field diagonally (both vertically and horizontally at the same time).

Move the Description field so that it is next to the Other Weight field.

Position the pointer at the lower right-hand corner of the Description field.

The pointer becomes a diagonal double-arrow.

Drag the corner of the Description field down and to the right, so that the right edge of the field is against the edge of the screen and the field is twice as wide as it was before.
The next step in designing the form is adding labels. It's important to label the different fields, so that you can tell them apart in the datafile window.

You should now move the fields to the right, to allow room for the labels.

Shift-click to select the Course Name, Credits, and Instructor fields.

Move these fields about one inch to the right.
To add labels, you simply click in the form window where you want the label to appear. Then just start typing. The label will appear in a field of its own, which can also be moved and resized.

Position the pointer to the left of the Course Name field and click.

The insertion point will be flashing to the left of the field.

Type in the label "Course".

You resize the label the same way you resize a field.

Position the pointer at the right edge of the Course label.

The pointer will change into a double-arrow.

Drag the right edge of the label to the left to shrink the label. Shrink the label until the word "Course" fits snugly in the label.
You can now reposition the label by clicking and dragging the black bar on top of the label.

Position the pointer over the black bar on top of the label.

The pointer changes shape to a four-way arrow.

Drag the label next to the Course Name field. Leave a small amount of space between the label and the field.

You've just added a label for the Course Name field. Similarly, you should add labels to the other fields as well.
Label the Credits field, "Credits". Label the Instructor field, "Instructor". Label the Grade field, "Grade".

In each case, be sure to size the label so that the text fits snugly, and leave a small amount of space between the labels and the fields.

You should now label the different Score and Weight fields. You should also create two labels: one for the group of scores, and another one for the group of weights.

Position the pointer below the Instructor field and above the Score fields and click.

Type in the label, "SCORE".

Resize the label so that "SCORE" fits snugly inside it.

Position the label so that it is directly above the Score fields. The top of the label should be at about the 1-1/2" mark.
You should also make a label for the weights.

Create a label called "WEIGHT" across from the SCORE label and above the Weight fields.

You should now label the individual Score and Weight fields.

Label the Homework Score field, "Homework".

Label the Midterm Score field, "Midterm".

Label the Final Score field, "Final".

Label the Other Score field, "Other".

Label the Course Score field, "Course Score".

Size these labels so that they almost touch their respective Score fields.
To get the labels and fields to line up nicely as shown, it might be necessary for you to reposition some of the fields.

Reposition the Score fields and labels and the Weight fields as needed to make the labels and fields line up.

All that remains now is to format the different fields. Then your form will be complete.

You can format fields so that they display values in almost any form you choose. For text values, you can change the font style, size, and type; numbers can be displayed in decimal, scientific, dollar, or percent format. Values can be aligned to the left, right, or in the center of the field; you can also underline values, or make them bold or italic. In addition, you can put borders around the fields.

To format a field or label, you first select it and then choose Format... from the Form menu. You can also format multiple fields at once by selecting more than one field.

The first formatting operation you should perform is to format the major labels (the Course, Credits, Instructor, SCORE, and WEIGHT labels) so that they are underlined. To do this, you need to select these labels.

You can select multiple fields and labels by drawing a box around them. All the fields or labels inside the box will be selected.

Position the pointer in the white area below the Instructor label and next to the ruler.
Press the mouse button. Drag upwards and to the right until the pointer is over the Course label. Release the mouse button.

![Diagram of a software interface showing the Course, Credits, and Instructor labels selected.](image)

The Course, Credits, and Instructor labels are now selected.

While holding down the Shift key, select the SCORE and WEIGHT labels by clicking the white bar at the top of the labels.

It's very important to click on the white bar. If you don't, you won't select the field, and you'll unselect the currently selected fields. If this happens, just try again.

The five major labels should now be selected.

Choose Format Text... from the Form menu.

You will be presented with the Format Text dialog box.
Select the Style option Underline, and click OK.

These labels are now underlined.

The datafile, remember, is being created to store information about classes. Since you want to call attention to this information, the information should appear in **boldface** in the datafile.

Click anywhere on the white area to unselect the labels.

Shift-click to select the Course, Credits, Instructor, and Grade fields.

Continue shift-clicking to select all the Score and Weight fields, including the Course Score field.

Choose Format Field... from the Form menu.

You're presented with the Format Field dialog box.

Select the Style option Bold and click OK. Do not unselect the Style option Border.

These values will now be displayed in boldface.

You now need to format the Weight fields so that they display numbers in percent format.

Click anywhere in the white area to unselect the fields.

Shift-click to select the four Weight fields.
Choose Format Number Field... from the Form menu.

Note that the Decimals blank is selected. Currently, numbers are displayed to 2 decimal places. Since you don't want to display any decimal places, you should type "0".

Type "0" so that no decimal places are displayed.

Select the Display option Percent and click OK.

These values will now be displayed as percents with no decimals.

You should now format the Course Score field. Since your course score is computed from your scores on the final, midterm, and homework, the Course Score field will be a computed number field.

Computed number fields display numbers that are the results of calculations you define when you format the field. In this case, you want to multiply each score by its weight and add these values together to get your course score.

Select the Course Score field.

Choose Format Number Field... from the Form menu.

To make the Course Score field a computed number field, click the Computed box. Then click to position the pointer inside the Formula field, and type in the formula.

Click the Computed box.

Notice the field Formula is no longer dimmed (grey).

Click inside the Formula field to set the insertion point.

The flashing vertical insertion bar should now be inside the Formula field.

Type in the formula "Final Score * Final Weight + Midterm Score * Midterm Weight + Homework Score * Homework Weight + Other Score * Other Weight".

Note that File will perform multiplications before additions; thus, parentheses are not needed.

NOTE: It is very important that you type in the formula exactly as listed, or an error will result. If, when entering information into the datafile, you get the message "ERROR!" in the Course Score field, this means that the formula you entered relies upon a non-existent field. The most likely cause of this is that one of the field names is misspelled.
To correct the error, open the form window by choosing Show Form from the Form menu. Double-click on the Course Score field and choose Format Number Field... from the Form menu. Then edit the formula as needed. When you're finished, click OK and close the form window.

If the error still persists, it's possible that you misspelled one of the fields in the form window (for example, you named the Homework Score field Homework Score). Re-open the form window and verify that the different field names are correct.

Click OK or press Return to complete the formula.

There! Now all the fields have been formatted, and the form is ready for use. You can now start entering data into your datafile.

Data is always entered, displayed, sorted through, and searched in the datafile window. You should make that window active now by closing the form window.

Close the form window by clicking its close box.

The datafile window is now active. Notice the effects that the formatting operations had on the labels.
Notice that there is only one record in the datafile, the New record. To enter information in a datafile, you simply start typing. You jump to the next field by pressing the Return key. You can also click inside any field to position the insertion point there.

Since the insertion point is inside the Course field, you can just start typing in the name of the first course.

**Type in "Applied Nuclear Botanics" as the name for the first course.**

Notice that you are now working on record number 1. The New record has moved to below this record. Notice also that the value in the
Course Score field is 0; this is because there are no values in any of the other Score or Weight fields.

To get to the next field, just press Return.

Press the Return key to move the insertion point to the Grade field.

Type in "A-" and press Return.

You can also edit the information you’ve entered as if it were normal text. If the name of this course is actually "Applied Nuclear Botany", you should click to position an insertion point after the "s" in "Botanics". Then just edit the word as if you were in MacWrite or Microsoft Word.

Click to position the insertion point after the word "Botanics" in the Course Name field.

Backspace over the "ics".

Type in the letter "y".

You’ve just edited the name of the course. You should now finish entering information for this record.

Click to position the insertion point inside the Credits field.

File automatically checks the information you put in a field to make sure it is the right type.

Type "Four" and press Return.
Oops! Microsoft File didn't like that! Because the Credits field is a number field, it can't store text. You'll need to enter the numeral "4".

Press Return to get rid of the dialog box.

Type "4" and press Return.

Type in "Edgar Mess" for the Instructor's name. Press Return.

Now you can start entering the scores and their weights. Remember that the weights will be numbers between zero and one (a fifty percent weight = .5).

Type in "75" as the Homework Score and press Return.

Type in ".2" as the Homework Weight and press Return.

Notice now that the Course Score is 15, which is 75 * .2.

Finish entering information for this record. Use the following values:

- Midterm: Score 88, Weight .2
- Final: Score 88, Weight .5
- Other: Score 91, Weight .1
- Description: Lab Project—Fusion Properties of Ferns
You're all finished. Now print the record. Consult the section on printing records from the Microsoft File Part 1 module, if necessary.

Choose Print from the File menu.

Select your desired options and click OK.

Choose Quit from the File menu.

You're back at the Macintosh Desktop.

In this module, you've learned:

• How to create a new datafile
• How to design a form
• How to define different field types: text, number, picture, and date
• How to create fields and labels
• How to move and resize fields
• How to format fields and labels
• How to create a computed number field
• How to enter information in a datafile

Turn in the printed record.
Two different views of the Minerals datafile are shown here. To create a second view of your information, click the box in the lower left-hand corner of the form window that says "View 1". The box will then display "View 2", and resized fields will return to the standard length. To return to View 1, click this box again. You can format the two views independently. However, because they are views of the same form, they must have the same fields. If you don't want a field visible in one of the views, drag it into the Hide area. The picture field in View 2 was dragged into the Hide area for View 1.

Although File allows you to alter font styles and sizes (using the Set Font... command), it doesn't support subscripts or superscripts.
<table>
<thead>
<tr>
<th></th>
<th>Affiliation</th>
<th>Birthdate</th>
<th>Favorite Food</th>
<th>School</th>
<th>Major</th>
<th>Date Graduated</th>
<th>Quote</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Apple Computer, Inc.</td>
<td>May 15, 1963</td>
<td>Eggplant Tofu Stack-ups</td>
<td>Stanford University</td>
<td>Product Design</td>
<td>June 15, 1985</td>
<td>&quot;When things get tough, the tough get...things.&quot;</td>
</tr>
<tr>
<td></td>
<td>Michael Tchao</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Stanford University</td>
<td>December 3, 1962</td>
<td>Tofu and Tuna w/ Salsa</td>
<td>Stanford University</td>
<td>Economics</td>
<td>June 15, 1985</td>
<td>&quot;...and then some.&quot;</td>
</tr>
<tr>
<td></td>
<td>Bill Berner</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Arabian Horseworld Magazine</td>
<td>June 2, 1962</td>
<td>Tofu Soufflé</td>
<td>Stanford University</td>
<td>History and Art</td>
<td>June 15, 1985</td>
<td>&quot;Don't worry, I was a pre-med once.&quot;</td>
</tr>
<tr>
<td></td>
<td>Ron Fernandez</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

This datafile contains information about the authors of *Approaching Macintosh*. One difference between this datafile and those in the modules is the inclusion of picture and date fields. As much as we wanted to use phony birthdays, Microsoft File always checks the dates that you enter to make sure that they are valid (February 30, 1963, for example, would be rejected).

To create the pictures, photographs of the authors were taken and then digitized, converted to MacPaint images, copied to the Clipboard, and pasted into the fields. When formatting a picture field, you are offered the option to either clip the picture, so that it fits into the field, or scale the picture, so that the whole picture fits. Often the scale option can leave pictures distorted, as File tries to fit all the pixels into the field. So unless you want the entire picture visible, the clip option should be used.
1. If you were designing the Course Listings datafile for the Microsoft File Part 1 module, what type of field (text, date, number, or picture) would you make the Time field (the field that stores the time the course meets)? Why? Hint: It's not a picture field.

2. Microsoft File automatically saves any changes you make to a datafile. How, then, can you open a datafile, change some of the entries, and be able to quit without altering the datafile?

3. Sometimes you'll create a field, and then decide that it is of the wrong type. For example, you could create a number field to store ZIP codes (since ZIP codes are numbers) without realizing that Microsoft File will drop the first 0 from ZIP codes, turning the ZIP code 02134 into 2134. The ZIP code field should therefore be a text field.

Assuming you've already created a number field to store ZIP codes, how would you change the ZIP field from a number field to a text field, if:

   a) You haven't closed the form window yet?

   b) You've closed the form window and already entered two records into the datafile?

Hint: How does the Format Field... dialog box for the ZIP field change after values are entered into the field?

4. What fields would you use when creating a datafile to store:

   a) A list of your albums, tapes, and compact disks?

   b) A list of books you used in writing a research paper? (Note that you can use this list to create a bibliography.)

   c) A list of important historical battles from the Civil War?

Justify your answers.

5. Using Microsoft File, create a dorm datafile that will keep information about the different people in your dorm. If you don't live in a dorm, make a similar datafile for a club or group you belong to. You can have as many fields as you like, but be sure to include fields for the first and last names, home and school telephone numbers, home and school addresses, and birthdate.

6. Adapt the datafile you created in Exercise 5 so that you can print mailing labels from the datafile. Use Microsoft File's ability to have two views of the same form. Turn in a copy of the mailing list.
7

Project Management

About Project Management
MacProject
Galleries
Exercises
About Project Management

Project management involves planning and organizing projects. It involves the breaking down of large and sometimes complex projects into individual tasks. It involves critical dates and deadlines. It involves people, materials, and other resources. And it often involves the transaction or flow of money.

The preparation of a turkey dinner can be considered a project. You can’t carve the turkey until you’ve roasted it; but you can’t roast the turkey until you’ve stuffed it. These are tasks. You can’t start preparing the meal until you’ve come back from work at 3:00, and you must be finished by 7:00. These are deadlines. You’ll need a turkey, stuffing, an oven, a carving knife, and possibly, an assistant to help you clean up. These are resources.

In contrast to the turkey dinner example, leasing a new office building can also be a project. You, or your employees, will need to talk to a realtor, visit and select a suitable building, and arrange financing. You’ll have to close the deal before the end of next month when your present lease runs out. You and your staff will be dealing with real estate agents, owners, and bank managers. And you’ll definitely need to track the flow of money.

As you’re working on a project, you’ll always be concerned about meeting deadlines. You’ll be concerned if a task is delayed due to unforeseen problems. You’ll be concerned about cost overruns. You’ll want to be able to tell your employees just what they should be doing on any particular date to insure the most efficient use of their time and yours. For a large and complex task, this could become increasingly difficult to do.
One way to manage a complex project is to create a large timeline, listing each of the tasks of your project, who'll carry out that task, when they must begin, and when they must be finished. In addition to this timeline, you should also compile a table listing each of your resources, how much they cost, when they're available, and for how long. And while you're at it, you'll need an accountant to keep track of the money you're spending, and any money you may be taking in.

But things aren't even that simple. What if tomorrow a giant killer squid attacks your corporate headquarters, doubling the price of labor, and making your resources almost impossible to find? You'll have to redraw your project timeline to reflect the changes. How much will this change cost you? In money? In time?

MacProject is a project management tool that helps you do all of these things. That means you can plan, replan, anticipate, change, and recalculate your project.

You design your project with the visually-oriented schedule chart, also known as a Program Evaluation and Review Technique (PERT). You diagram the flow of tasks. You give them durations, and assign resources like people and materials to them, and you track income and expenditures. You set critical dates and deadlines.

Then you'll have easy access to information concerning your project. Which tasks should begin today? When should these tasks be completed? What should Employee A be doing tomorrow? How much will this project cost? And what about that giant killer squid?

More importantly, you'll be able to perform "What if?" analyses to answer questions like: What will happen if you put three more people on a particular task? How much will it cost? Will doing this enable you to meet your deadline? Or, what will happen if there is an unexpected delay in a task? How much will the project be delayed and how much will the delays cost?

By using MacProject to keep track of your project, you should be able to save both time and money. And after all, time is money.
As you make your rounds among the troops, you see before you the towers of Ilium, besieged by your own Greek forces. For you are Agamemnon, King and leader of the Greeks, in the war against Troy.

Actually you're daydreaming in your history class again, but the dream seems very real. You're wondering what it was like to be the leader of the Greek army; you're also wondering what you're going to do for your history project. As you listen to your teacher explain how the Greeks built a giant wooden horse to help them capture the city of Troy, you start to think about the planning and preparations that must have gone into this immense project. Why not use MacProject and your Macintosh to plan the construction of your own Trojan Horse? It's certainly an original idea.

Before you begin using MacProject, you need to decide what the different tasks are that comprise the project. The following are tasks that need to be completed for the successful defeat of Troy:

- A meeting of the War Council
- The size of Troy's gate must be measured
- The horse must be designed
- Wood needs to be obtained
- The wheels, base, and body of the horse must be built
- The trap door must be added
- The horse must be assembled
- The assault team must be chosen
- The assault team must be instructed in the use of the trap door
- The men must get in the horse
- The horse must be drawn to the gate of Troy
- Troy is then looted and burned

You'll begin by opening MacProject and creating a Schedule Chart for Project Trojan Horse. First you'll draw task boxes—one box for each of the project's different tasks. You'll also draw dependency lines to make tasks dependent on other tasks. You'll also turn some of the tasks into milestones to mark key points along the project's path.

Next, you'll set the project's start and finish dates. You'll also assign resources to the different tasks, and set the task durations. You'll enter
the costs of the different tasks and resources, and the incomes received from the tasks.

Since MacProject automatically calculates a schedule from the dates and durations you've assigned, you'll be able to determine the effect that a delay will have on the project's schedule as a whole. To ensure that the project is completed on time, you'll adjust the calendar MacProject uses to calculate dates, requiring your crews to work harder, but ensuring that the horse is completed before your deadline.

Your completed Schedule Chart will look similar to the one shown on the next few pages.
Project Trojan Horse

- Start: 5/22/83
- War Council Meeting: 5/20
- Agamemnon: 5/21
- 5/21: Aesophas
- Design Horse: 5/22
- Measure Size of Gate: 5/21
- Build Bases: 5/22
- 5/22: Pleiades
- Chop Trees for Wood: 5/23
- 5/23: Cretans
- Build Wheels: 5/24
- Build Base: 5/24
- Peloponnesians: 5/24
- Atticans: 5/24
- Build Body: 5/24
- 5/21: Odysseus
- Choose Assault Team: 5/31
Getting Started

You'll begin by creating a new MacProject document.

Turn on the Macintosh and insert the MacProject disk—label side up and metal end first—into the built-in disk drive.

You'll soon see the Macintosh desktop with the icon of your MacProject disk in the upper right-hand corner.

If necessary, double-click on the MacProject disk icon to view its contents.

Now you'll open MacProject by double-clicking on the MacProject icon.

Double-click on the MacProject icon to open the application.

The Schedule Chart

MacProject first opens to display the Schedule Chart window. Though MacProject uses seven different charts to display information about your project, all projects begin as Schedule Charts.

Task Boxes and Dependency Lines

Each of the tasks that comprise the project is represented in the Schedule Chart by a box, known (you guessed it) as a task box. One task box is drawn for each task.

Tasks that can be performed at the same time are drawn parallel to each other. A task that cannot begin until another task is completed is dependent on the first task. To show this dependency, the tasks are connected with a dependency line.
You have to do many things to make a Thanksgiving dinner. A list of some of those tasks may look like this:

1. Buy Food
2. Stuff Turkey
3. Roast Turkey
4. Make Cranberry Sauce

Each task is represented in MacProject as a box. Relationships between tasks are evident.

Drawing a task box is much like drawing a box in MacPaint or MacDraw. Simply position the pointer where you want the upper left corner of the box to be, then press the mouse button and drag the mouse diagonally. The first task will be that of simply starting the project; therefore the first task box you'll need to draw will be for the Start task.

Position the pointer near the left edge of the screen.

Press and hold the mouse button and drag the mouse down to the right. Release the mouse button when you've drawn a box about 3/4" by 1/2".

Don't worry if the box isn't the right size; you'll learn how to resize it later.

Notice the flashing insertion point inside the task box. To name this task, you simply begin typing.

Type "Start" to name this task.
Don't be concerned with the date in the upper left corner of the box. This is just a date that MacProject automatically assigns to a task as a starting date. After you draw all the tasks for this project, you'll go back and enter the real dates.

The project has now started. What's next? Agamemnon probably planned the construction of the Trojan Horse with his trusted advisors much in the same way you're using MacProject. The next task, then, should be a meeting of the war council.

To draw the next task, War Council Meeting, position the pointer to the right of the Start task, and draw another task box.

Draw the task box for the War Council Meeting to the right of the Start task box.

Type "War Council Meeting" to name this task.
Notice that as you name this task, MacProject automatically shifts the text inside the task box as needed. The task box shown is not large enough to show all the text.

MacProject will remember all the text you type when you name a task box. If the task box you drew is too small to contain the entire name of the task (like the one shown), just keep typing. You'll resize the War Council Meeting task box now.

If you move the pointer around the task boxes you drew, you'll notice that it changes shape. It appears as a plus sign outside the boxes, as an I-bar inside the boxes, and as an arrow at the edges of the boxes.

When the pointer is shaped like a plus sign, you can draw new task boxes. If you click the mouse when the pointer is shaped like the I-bar, you'll set an insertion point inside the task box, allowing you to edit the name of the task. By clicking the mouse when the pointer is shaped like an arrow, you can select a task box.

Position the pointer on the edge of the War Council Meeting task box and click the mouse button.
The box is now selected. The box has a dotted outline with black handles around it, which are used to resize the box.

To resize the War Council Meeting task box, position the pointer over one of the black handles. Press the mouse button and drag the mouse to resize the box.

Position the pointer over the handle in the lower right corner of the War Council Meeting task box.

Drag the handle to the left so the words "War Council Meeting" are clearly visible in the box.
Adding Dependency Lines

It's easy to add dependency lines to show that one task is dependent on another. Simply move the pointer from the left-hand task box (the pointer will change into an I-bar) and press the mouse button. Drag the mouse to the right until the pointer is inside the dependent task, and release the mouse button. (Note: Since the project flows from left to right, all dependency lines must be drawn from left to right. You can't draw a dependency line from right to left.)

Drag the mouse from the inside of the Start task to the inside of the War Council Meeting task to draw a dependency line between these two tasks.

Milestones

You may be wondering why there is a Start task, since starting the project isn't really a task at all. It's often useful, however, to be able to mark key points along the project path, such as the project start and completion. There may be sub-projects within the main project that you may want to mark as well. For example, you could mark the beginning and completion of the preparing the turkey tasks (stuffing, roasting, and basting) for the Thanksgiving feast. This way you'd identify this group of tasks as a sort of mini-project, separate from the tasks concerned with setting the table and preparing dessert.

Key points along the project path are called milestones. Since they are markers, milestones generally don't take up any time, so they don't have any duration.

Creating a Milestone

Since the Start task is really a milestone, you should change its task box into a milestone.
Adding Task Boxes:  
A Short Cut

Select the Start task box by clicking on its edge.

Choose Change to Milestone from the Task menu.

The Start task box changes into a milestone box with rounded corners.

Now that the war council has met, it's time for some reconnaissance.  
The size of Troy's gate should be measured, so you know how large to  
make the horse. There's a way to create a task that's dependent on  
another task. If you press the mouse button down inside the first task  
and drag to the right, you'll create a dependency line. When you let go  
of the mouse button, a new task box will appear, complete with a  
dependency line from the first task box.

Position the pointer inside the War Council Meeting task and  
press the mouse button.

Drag upward and to the right and release the mouse button.

A new task box appears.

Name this task "Measure Size of Gate".

You're beginning to realize what a complex project building a Trojan  
Horse is. There still remain the tasks of building the horse, choosing  
the assault team, adding the trap door... You'll need to expand your  
MacProject document to fit all the tasks involved. In preparation for  
these other tasks, you should move the task boxes you've drawn to a  
more central location.
Selecting Multiple Task Boxes

There are two ways of selecting multiple tasks boxes, each with its own advantages.

The first way of selecting more than one task box is to simply select each of the task boxes individually. While holding the Shift key down, click to select one of the task boxes, then keeping the Shift key down, click to select the others. This is a good method to use if you want to select boxes that aren't close to each other, or if you want to select only a few task boxes.

To select a number of task boxes that are closer to each other, position the pointer above and to the left of all the task boxes you want to select. Hold down the Shift key, and drag diagonally as if you were drawing a large box around all the task boxes you want to select. This is called Shift-dragging. It's important to hold down the Shift key, because if you don't, you'll end up drawing one big task box on top of the others.

Hold the Shift key down and click the mouse button to select the Start milestone. Shift-click to select the two remaining task boxes.

The task boxes will become highlighted when they are selected.

You can move a single task box by positioning the pointer on the edge of the task box and dragging the box to the new location. Be sure not to drag one of the handles or you'll resize it instead of moving it. If you've selected more than one task box, dragging any of the boxes will drag the others as well.

Drag the task boxes downward so the Start milestone is near the bottom of the screen.

Moving Task Boxes

7-17 PROJECT MANAGEMENT: MACPROJECT
The next step in giving yourself more room to draw task boxes is to increase the size of the Schedule Chart.

**Choose Set Chart Size... from the Layout menu.**

Notice that the area available to draw the Schedule Chart is currently 8" by 11". Notice also how much bigger the chart can become (up to 48" by 94"). To select the new chart size, just click on one of the boxes to define the size from the upper left corner. Your chart will probably require only one more page.

Click on the second box in the first row to set the Schedule Chart size to 16" by 11". Click OK when finished.

Most of the tasks involved in the construction of the Trojan Horse are performed in sequence—you measure the gate and design the horse and build the horse and pull the horse to the gate—with each of these tasks dependent on the task that preceded it. The Schedule Chart, then, will end up longer than it is wide, since there aren't too many tasks that are parallel to each other (performed at the same time).

Because the Schedule Chart will be longer than it is wide, you should use Wide paper orientation. Currently the drawing size is 16" long by 11" wide. By choosing Wide paper orientation you make the drawing size 8" long by 22" wide. You therefore have much more horizontal space to draw task boxes.

**Choose Page Setup from the File menu.**

Choose Wide paper orientation, and click OK.
You now have enough drawing area to draw the remaining task boxes.

You can always see the different portions of the Schedule Chart by using the scroll bars at the side and bottom of the window. You can, however, see the entire chart at one time.

Choose Show Entire Chart from the Layout menu.

What you see is an outline of the entire chart. The dotted rectangle represents the portion of the project that is visible in a normal view. You can click inside this rectangle and drag it to another location to see another part of the project. Or you can click outside the rectangle to reposition the entire chart relative to the paper. Note that this works much like the Show Page option in MacPaint.

To return to the normal view, simply click anywhere outside the white area that represents the paper.

Click outside of the white area to return to the normal view.

Now that you're an expert at drawing, naming, resizing, and moving task boxes, you should draw the remaining tasks that make up Project Trojan Horse.

Using the Schedule Chart shown on the next two pages as a guide, draw the remaining tasks for Project Trojan Horse.

Resize and move the task boxes as needed.

Remember that you can choose Show Entire Chart from the Layout menu to see how your Schedule Chart is progressing.
Brief Team on How to Use Trap Door

1/2

Assemble Horse

1/2

Horse

1/2/84

Completed

1/2

Add Trap Door

1/2

Men Get in Horse

1/2

Pull Horse to Gate

1/2

Sack and Plunder

1/2/84

Victory!
Now's a good time to save your work before moving on. It's a good habit to save your work every ten or fifteen minutes.

Choose Save from the File menu.

Name the document "Project Trojan Horse".

Click Save to save the document.

You can change the font styles and sizes used by MacProject. You can add annotation, or change the style of the text inside the task boxes.

You can select or edit MacProject text the same way you select and edit text in MacWrite. When you change the type size and style, you do it for all task boxes.

Click inside any of the task boxes.

Choose New York from the Fonts menu.

Notice that all the task boxes now have their titles displayed in New York font.

You can add annotation anywhere in the Schedule Chart. Simply click the mouse to set the insertion point, and start typing.

Use the scroll bars to make the upper left portion of the Schedule Chart visible.

Choose Geneva from the Fonts menu.

Choose 18-point and Bold from the Style menu.

Position the pointer in the upper left portion of the screen, and click the mouse button to set the insertion point.

Type "Project Trojan Horse".
Most projects have deadlines—dates by which the projects must be completed. Many also have an earliest possible starting date (projects can't always be started right away). You should now enter the earliest possible starting date for the construction of the Trojan Horse, and the latest acceptable finishing date for the project.

Before you can start setting dates, MacProject has to know how you want to measure task durations. A task's duration is the amount of time it takes to complete that task—three hours or two days or nine weeks.

**Choose Duration Scale... from the Dates menu.**

You can select from a wide variety of durations, depending on what the project is. For instance, if you were cooking dinner, the duration scale would be in hours—building the Pyramids, perhaps weeks or months.

**Make sure that Day is selected as the duration scale. Click OK.**

The project is on a strict timeline, and must be completed by a particular date. In this case, you'd all like to be home for your planned victory celebration during the Dionysian festival, so you'd like to complete the project by June 6th. You can set a latest finish date for any task; in this case, you want to set one for the final task, that of Victory.

**Select the Victory! milestone by clicking on its edge.**

**Choose Set Latest Finish... from the Dates menu.**
To set a date, click on the different blanks (month, day, and year) to select that blank and click the arrows to advance the numbers up or down. The Clear option will clear the latest finish date.

Click on the month blank.

Use the up arrow to change the month to 06.

Click on the day blank.

Use the up arrow to change the day to 06.

Click on the year blank.

Use the up arrow to change the year to 1985.

Click Set to set this date.
True, the Trojan Horse wasn't constructed in 1985, but MacProject's calendar doesn't go back several thousand years.

The earliest start date corresponds to the earliest possible date the project can begin. You set the earliest start date the same way you set the latest finish date. Again you can set an earliest start date for any task; right now you'll set it for the Start milestone.

Select the Start milestone by clicking on its edge.

Handles will appear around the milestone indicating that it has been selected.

Choose Set Earliest Start... from the Dates menu.

Click on the blanks and use the arrows to adjust the date to be 5/20/85. Click Set to enter this date.

As you enter these dates, notice that the dates shown in the corners of the task boxes change to reflect the dates you've set. Notice also that the date shown for the Start milestone is underlined; that's because it was a date set by you and not calculated by MacProject.

If you're wondering why all the dates are the same (5/20), it's because you haven't told MacProject how long any of these tasks take to complete, so MacProject thinks that all the tasks have durations of zero days. Since this is definitely not the case, you should enter the durations now.
Adding Task Information

Because all the tasks have been drawn and the start and finish dates set, you are now ready to tell MacProject how long each of the tasks will take to complete, and assign resources to the various tasks.

The Start milestone doesn't have a duration or use any resources, so the first task to add information to is the War Council Meeting task.

Select the War Council Meeting task by clicking on its edge.

Choose Show Task Info from the Task menu.

A task info window appears.

In this window you enter the duration of a task and assign up to six resources to the task. There are seven blanks—one for the duration of the task, and six for resources. Note that the Days blank is currently selected. Had you chosen a duration of hours or minutes for this project, this blank would be called Hours or Minutes, respectively. To move between the blanks, simply press the Tab key.

You should enter the task information now.

Type "2" in the Days blank to give this task a duration of two days. Press the Tab key to move to the next blank.

The first Resource blank is selected. The war council consists of Agamemnon and his trusted advisors, Odysseus and Achilles, so these three men are the resources for this task.

Type "Agamemnon" in the first Resource blank.
Press the Tab key to move to the next Resource blank

Type "Odysseus" and press the Tab key.

Type "Achilles" into the third Resource blank.

Choose Hide Task Info to hide the task info window.

Notice that the dates displayed around the tasks change as MacProject takes into account the new duration of this task.

You should now enter the task information for the Measure Size of Gate task. Apestalence will lead the reconnaissance team, so he is the resource for this task.

Select the "Measure Size of Gate" task.

Choose Show Task Info from the Task menu.

Give this task a duration of 1 day. Press the Tab key.

Type "Apestalence" in the first Resource blank.

Do not hide the task info window.

To simplify the process of entering task information, you can press the Return key to move to the next task box while keeping the task info window open.

Press the Return key to move to the next task.
MacProject selects the next task box—the one closest to the last selected task box (it will be probably be the Design Horse task, though it could be the Choose Assault Team task). You can now enter this task's information in the task info window.

Note that by pressing the Return key you jump to the task box that is drawn in the Schedule Chart closest to the task box that was selected, not to the first task dependent on the previously selected task. MacProject will scroll the Schedule Chart automatically to bring the selected task into view.

If you can't see the selected task, it may be because the task info window is covering it up. Position the pointer in the title bar of the task info window (over the words Task Info, for example) and drag the window to a new location on the screen. You should now be able to see the selected task box.

Assign the durations and resources to the remaining tasks.

Use the table of values shown.

<table>
<thead>
<tr>
<th>Task Name</th>
<th>Days</th>
<th>1</th>
<th>2</th>
<th>3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Choose Assault Team</td>
<td>3</td>
<td>Odysseus</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Design Horse</td>
<td>1</td>
<td>Billius Blassius</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Chop Trees for Wood</td>
<td>2</td>
<td>Pleiades</td>
<td>Cretans</td>
<td></td>
</tr>
<tr>
<td>Build Wheels</td>
<td>4</td>
<td>Cretans</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Build Base</td>
<td>4</td>
<td>Peleponesians</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Build Body</td>
<td>5</td>
<td>Atticans</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add Trap Door</td>
<td>1</td>
<td>Achilles</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Assemble Horse</td>
<td>3</td>
<td>Cretans</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Brief Team on How to Use Trap Door</td>
<td>1</td>
<td>Achilles</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Horse Completed</td>
<td>0</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Men Get in Horse</td>
<td>1</td>
<td>A-Team</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Pull Horse to Gate</td>
<td>1</td>
<td>Atticans</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sack and Plunder</td>
<td>3</td>
<td>Everyone</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Victory!</td>
<td>0</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Now is a good time to save your work again.

Choose Save from the File menu.

Examine the Schedule Chart. Some of the dependency lines and some of the tasks are highlighted (outlined in black). These tasks represent the critical path. The critical path shows the tasks that must be completed on time for the whole project to be completed on time.
The critical path has nothing to do with the importance of the tasks; rather, it reflects the amount of time needed to carry out the tasks. Since many tasks are performed simultaneously, it's possible to complete a task and not be able to continue because the next task is dependent on another, as yet uncompleted task. The critical path highlights these dependencies by showing that any change in the time taken by tasks on the critical path will affect the completion date of the project.

Using the scroll bars, bring the portion of the Schedule Chart containing the Build Wheels, Build Base, Build Body, Add Trap Door, and Assemble Horse tasks into view.

Notice that the critical path runs through the tasks of building the horse body and adding the trap door. The horse cannot be assembled until these tasks are completed, no matter how quickly the wheels and base were built. If it takes an extra day to build the body, then the horse will be assembled a day late, and the whole project will be off schedule by one day.

Tasks that aren't on the critical path have slack time. Slack time is a measure of how much extra time a task can take without delaying the completion of the project. For example, it takes four days to build the body and another day to add the trap door, for a total of five days for these two tasks. Building the base only takes three days, so after the base is built you still have to wait two days until the horse can be assembled. The task of building the base has a slack time of two days—you can take an extra two days to complete this task without throwing the project off schedule.

It's possible to see how much slack time any given task has, and to watch the progression of each task over time.

Choose Task Timeline from the Chart menu.
Here, each of the tasks is represented in bar-graph form, arranged in order by earliest starting date. Black diamonds are milestones. The grey area represents the amount of slack time any task has. Tasks all in white are critical tasks with no slack time.

Notice that the timeline at the top of the chart currently uses increments of one week. If you want to you can change the scale of the timeline.

Choose Timeline Scale from the Dates menu.
You can choose any of the timeline scales shown. Changing the timeline scale does not affect the duration scale. Since a timeline scale of one week is fine, you should leave the scale as it is.

**Click OK to return to the Resource Timeline.**

You can use the Show Entire Chart command from the Layout menu to see the entire Task Timeline in the same way you used it to see the entire Schedule Chart.

The Task Timeline allows you to visualize the progression of each task of the project over time. Similarly, you can see where and when the different resources are being used by examining the Resource Timeline.

Choose Resource Timeline from the Chart menu.

The Resource Timeline shows all the resources and what tasks they are working on at any given time. Again, the slack time of tasks is presented in grey. By looking at the Resource Timeline, you can see if you've accidentally assigned one person to two tasks at the same time, and you can see when people have a little free time to help out on tasks that may be falling behind schedule.

The Resource Timeline uses the same timeline scale as the Task Timeline, so setting the timeline scale affects both of these charts.

If you wish, you can add annotations to the Resource Timeline and Task Timeline charts in the same way you added it to the Schedule chart.
Entering Costs and Incomes

It's now time to look at the finances of the project—the costs of the various resources (such as the wages of the soldiers) and the income various tasks will bring in (looting, for instance, is often quite profitable).

You should first enter the costs of the different resources into the Resource Cost Entry Table.

Choose Resource Cost Entry from the Chart menu.

The Resource Cost Entry Table lists all the resources used by the project, along with the cost per day of using that resource. These are costs, such as wages or rent, that a resource uses on a per-day basis. For example, a worker may receive $80 a day, or it may cost $25 a day to rent equipment. The project currently uses 11 resources, but MacProject can handle up to 50 different resources.

You can specify a single or multiple accrual method. Single accrual means that a resource's cost is figured into the project cost once for each day it is used. Multiple accrual means that the resource's cost is figured in for each task that uses that resource on a given day. For example, if a soldier has two tasks to perform on a given day, and he receives $10/day, he would get $10 for that day using single accrual (his cost is only figured once for each day he works) but he would get $20 for that day using multiple accrual ($10 each for the two tasks).

To get an insertion point in the Cost/Day blank simply position the pointer over the blank and click. Click on an Accrual Method field to toggle it between multiple and single accrual.

Enter in the resource costs for Project Trojan Horse.

Use the values shown.
### Entering Task Costs and Incomes

You should now enter the fixed costs of the various tasks, as well as the fixed incomes that those tasks will bring in. You do this in the Task Cost Entry Table.

#### Choose Task Cost Entry from the Chart menu.

The Task Cost Entry Table contains fixed task costs and incomes. As in the Resource Cost Entry Chart, just click in a blank to get an insertion point there. You can then enter the desired values.

Some of the tasks have fixed costs (tools will be needed to build the horse, and there should be refreshments at the War Council Meeting) and income will be generated by some of the tasks (you can sell any extra wood you chop, and looting Troy will be profitable also). You should enter these values now.

Enter the various task costs and incomes using the values given in the table shown on the next page.

<table>
<thead>
<tr>
<th>Resource Name</th>
<th>Cost/Day</th>
<th>Accrual Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agamemnon</td>
<td>100.00</td>
<td>Multiple</td>
</tr>
<tr>
<td>Odysseus</td>
<td>75.00</td>
<td>Multiple</td>
</tr>
<tr>
<td>Achilles</td>
<td>62.50</td>
<td>Multiple</td>
</tr>
<tr>
<td>Apestalence</td>
<td>37.25</td>
<td>Multiple</td>
</tr>
<tr>
<td>Billius Blassius</td>
<td>225.00</td>
<td>Single</td>
</tr>
<tr>
<td>Pleiades</td>
<td>37.25</td>
<td>Single</td>
</tr>
<tr>
<td>Cretans</td>
<td>32.95</td>
<td>Single</td>
</tr>
<tr>
<td>Peleponesians</td>
<td>35.00</td>
<td>Single</td>
</tr>
<tr>
<td>Atticans</td>
<td>33.50</td>
<td>Single</td>
</tr>
<tr>
<td>A-Team</td>
<td>45.00</td>
<td>Single</td>
</tr>
<tr>
<td>Everyone</td>
<td>100.00</td>
<td>Single</td>
</tr>
</tbody>
</table>
### Task Name

<table>
<thead>
<tr>
<th>Task Name</th>
<th>Fixed Cost</th>
<th>Fixed Income</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>War Council Meeting</td>
<td>1200</td>
<td>0</td>
</tr>
<tr>
<td>Measure Size of Gate</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Choose Assault Team</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Design Horse</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Chop Trees for Wood</td>
<td>50</td>
<td>425</td>
</tr>
<tr>
<td>Build Wheels</td>
<td>25</td>
<td>0</td>
</tr>
<tr>
<td>Build Base</td>
<td>25</td>
<td>0</td>
</tr>
<tr>
<td>Build Body</td>
<td>25</td>
<td>0</td>
</tr>
<tr>
<td>Add Trap Door</td>
<td>10</td>
<td>0</td>
</tr>
<tr>
<td>Assemble Horse</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Brief Team on How to Use Trap Door</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Horse Completed</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Men Get in Horse</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Pull Horse to Gate</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Sack and Plunder</td>
<td>0</td>
<td>7550</td>
</tr>
<tr>
<td>Victory!</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

You should now return to the Schedule Chart.

**Choose Schedule Chart from the Chart menu.**

Notice the dates in the upper left corners of the task boxes. These dates are the Earliest Start dates for each of the tasks. It would also be nice to see what the Latest Finish date for each task is (the date by which the task must be completed for the project to be on schedule), as well as who is in charge of each of the tasks.

**Choose Show Dates from the Dates menu.**
You can display up to four dates, one in each corner of the task box. You can also display some of the resources used by the task. Click on an item's circle to display that item, or click on an already selected circle to stop displaying that item.

In addition to the Earliest Start date, click to have the Latest Finish date displayed in the lower right corner, and click to display a Resource in the upper right corner.

Click OK to return to the Schedule Chart.

You can now see the Earliest Start and Latest Finish date for each task, as well as the first assigned resource for each task.

If you look closely at the Earliest Start and Latest Finish dates, you'll see that many tasks won't even start until after their latest finish deadline has passed. This won't do at all, since it means the project won't be completed on time.

Fortunately, there is a solution to the problem (besides moving the starting date back or the finish date forward), and that is to adjust the calendar that MacProject uses to calculate dates.

Normally, MacProject assumes regular working conditions—an eight-hour day, with weekends and holidays off. Since the workers are Greek soldiers, it's highly unlikely they'll work less than 12 hours a day, or that they'll get weekends off.

Choose Calendar... from the Dates menu.
The clock on the left represents the working day. It is divided into one-hour sections. The hours in white are the hours during which work is performed; it's currently set for 9 AM to 5 PM. The calendar to the right represents days that are working days (those in white) and days that aren't (those in black).

Notice also the Calendar Range above the calendar. This is the range that the dates of your project can fall under. If you want your project to have dates outside this range (such as dates in the year 1990), you'll have to adjust the Calendar Range.

Adjusting the calendar is easy. Simply click anywhere on the clock to change an hour from working to nonworking (or vice versa), or click on a day to change it from working to nonworking (or vice versa).

By clicking on one of the years shown, or on the name of the month, you will be presented with up and down arrows. By clicking on the arrows, you can change the month or the year.

You should adjust the calendar now so that the project can be completed on schedule.

Click on the black section of the clock between 6 AM and 6 PM to give the soldiers a 12-hour work day.

Click OK to return to the Schedule Chart.

Use the scroll bars so the portion of the Schedule Chart containing the Victory milestone is visible.

As you can see, the numbers are almost perfect now, but you're still
one day behind schedule.

Choose Calendar... from the Dates menu.

Click on the year 1984. Use the arrows to change the year to 1985.

Click on the month January. Use the arrows to change the month to May.

Notice that the 27th of May is a holiday. Since the Greeks didn't celebrate Memorial Day, you can change this to a working day.

Click on the 27th of May to change it to a working day.

You should probably make the crew work on weekends also, but since this last change will put the project on schedule, it's not necessary.

Click OK to return to the Schedule Chart.

One of the main features of MacProject is its ability to instantly calculate the effects of delays or changes in the durations of the tasks upon the project as a whole. For example, it's rumored that Achilles isn't feeling well ever since he was shot in the heel. Assuming that he will need to rest for an extra three days before briefing the team on how to use the trap door, what effect will this have on the completion of the project? Do you want to assign anyone else to the task, in case Achilles doesn't recover in time?

Select the "Brief Team on How to Use Trap Door" task.

Open the task info window.

Change the duration of the task to four days.

Hide the task info window.

Notice that the critical path has now changed. The delay has made the briefing more critical to project completion than the assembly of the Horse. Notice also that you have pushed the earliest finishing time past the project deadline. Given this information, you might want to see that someone else is given this task instead of Achilles, or you may even want to make the troops work weekends.

Make sure the "Brief Team on How to Use Trap Door" task is still selected.

Open the task info window.
Save Your Work

Set the duration of this task back to one day.

You should save your work one last time.

Choose Save from the File menu.

The Project Table

Now that you've finished entering the information for Project Trojan Horse, you'll want to see all this information at once. The Project Table shows all the information MacProject has for each of the tasks, including start and finish dates, the task durations, costs and incomes, and the resources used by each task.

Choose Project Table from the Chart menu.

The entire project is summarized here for you. The Project Table is like a combination of all the other charts, giving you pertinent information for each task. Critical tasks are shown in bold type, just as in the Schedule Chart. This chart is not as visually effective as the Schedule Chart, Resource Timeline, or Task Timeline, but it does contain all of the information associated with the project.

Return to the Schedule Chart by choosing Schedule Chart from the Chart menu.

Printing

You can print a copy of any of the charts MacProject uses. Simply choose the chart you wish to print from the Chart menu, then choose Print... from the File menu. You should print the Schedule Chart you created so you can hand it in to your History professor.
Choose Print... from the File menu.

Click OK to print the Schedule Chart.

You now have a copy of your Schedule Chart. Your A+ in History is assured.

Choose Quit from the File menu.

You're back at the Macintosh desktop.

In this module, you've learned:

- How to draw task boxes by positioning the pointer and dragging
- How to create milestones using the Change to Milestone command
- How to add dependency lines by dragging from one task box to another
- How to enter a task's duration and assign resources to a task by selecting the task and pressing the Tab key
- How to set Earliest Start and Latest Finish dates for any task by selecting the task and choosing the appropriate command from the Dates menu
- How to set the calendar to match your work schedule
- What the critical path is
- Why tasks not on the critical path have slack time—they can be completed late yet still not delay the completion of the project
- How MacProject uses different charts to display information—from resource and task timelines to cost and income tables to the visually oriented Schedule Chart
- How MacProject helps you anticipate the effects that delays in task completion will have on the project as a whole

What to Turn In

Turn in a copy of the Schedule Chart you created.
"Tofu Pavilion" plans out the project of preparing the Tofu Pavilion for Tofu Fest 50, a week long celebration of the spirit of soybean products and their role in university living. Note that the critical path has two branches. Tasks along both branches must be kept on schedule to keep the project on schedule. The project manager for this project would want to pay particular attention to making sure people knew what they were supposed to be doing and when. The project manager would want to make sure people don’t have to perform tasks on separate branches of the critical path at the same time. Since there are two branches to the critical path, it might be wise to add more resources to the project, allowing some of the critical tasks to be completed in less time. This way there would be fewer critical tasks to worry about.
"Magazine Project" would be used by a student organization that wanted to produce a magazine or newsletter. The Task Timeline is shown here. There are two major branches to the project: the editorial (upper) branch, which is concerned with writing and developing stories and artwork, as well as the production process; and the business (lower) branch, which is concerned with financing the project—getting advertisers, collecting overdue bills, and applying for funding from the student government.

MacProject's ability to track finances is particularly useful here. Since you can calculate exactly how much the magazine will cost to produce and how much you will receive from advertisers, you can determine how much money to ask for from the student government—and you'll have figures to back it all up. The project was created using the same techniques that "Project Trojan Horse" used, except that the necessary income from the student government was calculated by examining the deficit between the production costs and advertising income.
1. What does it mean for a task to lie on the critical path? What does it mean for a task to have slack time?

2. Give examples of projects that would use the following duration scales:
   a) Minute
   b) Hour
   c) Day
   d) Week
   e) Month

3. You've just finished drawing all the task boxes for a project. What steps do you need to take in order to set the project's Latest Finish date to be July 4, 1987?

4. Sometimes it will not be possible to complete a project on time nor will it be possible to adjust the calendar or the project's start and finish dates. When this happens, you have to resort to other methods of putting the project on schedule. What methods can you think of that will shorten the amount of time it takes to complete a project without adjusting the project's start and finish dates or the calendar? Which of these methods will work on Project Trojan Horse? Which on the Magazine Timeline?

5. Imagine that you're in charge of organizing a dorm or club weekend ski trip. What are the different tasks that need to be done to insure a successful trip? How long do you think each of these tasks will take? Using MacProject, plan out the steps necessary for this trip. Make sure to account for signups, transportation, equipment, accommodations, and food. Remember to enter the costs of the different tasks (food, gas, etc.) into the Task Cost Entry table.

6. Draw Schedule Charts showing:
   a) The tasks you go through preparing for a big date with that special someone.
   b) The tasks you go through when writing a comprehensive research paper.

How linear were your Schedule Charts? What do these projects have in common that make them linear in nature? Do you think MacProject is useful for these projects? Why or why not?
Reference

Approaching Macintosh Plus
Glossary
Index
Approaching Macintosh Plus

Apple has introduced an enhanced version of the Macintosh called the Macintosh Plus. If the Macintosh you're using is either a Macintosh Plus or a Macintosh that has been upgraded to work like a Macintosh Plus, you'll need to know how these enhancements change the way you'll work with your Macintosh.

While the Macintosh Plus looks much like a standard Macintosh, there are some important differences in the way it works.

The Macintosh Plus comes standard with one megabyte (1024K) of system memory which can be upgraded to 4 megabytes. Because of the extra memory, you'll be able to create larger documents. Also, certain applications that take advantage of the extra memory may run faster.

The Macintosh Plus can use double-sided disks which store 800K of information, twice the storage capacity of the original single-sided Macintosh disks. The Macintosh Plus disk drives that use the double-sided disks (both the built-in disk drive and the 800K External Drive) can also read and write on single-sided disks. This means that disks that you've used with other Macintoshes should work with the Macintosh Plus.

Because the 800K Macintosh Plus disk drives store information on both sides of a double sided disk, single-sided disk drives in other Macintoshes cannot read the double-sided disks that you've created with the Macintosh Plus. If you insert a double-sided disk created with the Macintosh Plus into a single-sided disk drive, you'll be asked if you want to re-initialize the disk as a single-sided disk. Doing so will erase all of the information on the disk.

<table>
<thead>
<tr>
<th></th>
<th>400K Disk Drive</th>
<th>800K Disk Drive</th>
</tr>
</thead>
<tbody>
<tr>
<td>Single-Sided Disk</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Initialized one-sided</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Single-Sided Disk</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Initialized two-sided</td>
<td>no</td>
<td>no</td>
</tr>
<tr>
<td>Double-Sided Disk</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Initialized one-sided</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Double-Sided Disk</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Initialized two-sided</td>
<td>no</td>
<td>yes</td>
</tr>
</tbody>
</table>

REFERENCE: APPROACHING MACINTOSH PLUS
However, you can initialize double-sided disks so that information is stored on only one side of the disk. This, in effect, makes an 800K disk function as a 400K disk.

The Approaching Macintosh Documents Disk is a single-sided disk. This means that you'll be able to use the disk with any Macintosh or Macintosh Plus.

Newer Macintoshes, including the Macintosh Plus, organize files and folders on the Macintosh desktop more efficiently using the new Hierarchical File System, or HFS. With the new HFS, when you open a document from within an application (for example, when you choose Open from the File menu in MacWrite), you'll see a noticeable difference in the way the standard dialog boxes look and work.

A small icon appears just to the left of each item in the list. This icon indicates whether the item is a document, application, or folder. If the item is a folder, you can double-click to open that folder and view a list of its contents. If its contents includes another folder, double-clicking on that folder will list its contents, and so on.

In each case, the icon and name of the current folder or disk appears as a menu above the listing. By choosing the appropriate disk or folder from this menu, you'll return to that disk or folder.
Similarly, when you choose Save or Save As from the File menu, a new Save dialog box appears.

The Zoom Box

One convenient new feature of the Macintosh Plus is the zoom box. The zoom box is a small box found on the right side of the title bar of some windows. Clicking the zoom box expands a window to its maximum size so that you can view its contents more easily. Clicking the zoom box with the window expanded returns the window to its original size.
absolute reference
In a spreadsheet, a reference which always refers to the same cell or group of cells, even if you copy the formula containing the reference. For example, R12C3.

active window
The frontmost window on the desktop. The title bar of an active window is highlighted with horizontal lines.

Apple menu
The menu found under the symbol at the far left of the menu bar. The Apple menu contains desk accessories such as the Note Pad and the Scrapbook.

application program
A tool used to manipulate information. MacPaint and MacWrite, for example, are application programs for the Macintosh.

argument
Information needed by a function or an instruction to produce a result.

Backspace key
A key at the upper right-hand corner of the Macintosh keyboard that moves the insertion point one space to the left, removing the last character typed. The Backspace key also removes the current selection.

button
Clicking a button (usually found in a dialog box) designates, confirms, or cancels an action.

Cancel button
A button which, when clicked, cancels the command that brought up the dialog box.

cell
The basic unit of a spreadsheet in which you store numbers, labels, and formulas. A cell is the intersection of a row and a column.

choose
To pick a command from a pull-down menu. To choose a command, press the mouse button in the menu title, drag the mouse until the appropriate command is highlighted, and release the mouse button.

click
To quickly press and release the mouse button without moving the mouse.
**Clipboard**
A temporary holding place for the most recently cut or copied selection. The Clipboard can be used to transfer text, graphics, or other information between documents.

**close**
To remove a window from the desktop. To close a window, choose the Close command from the File menu, or click in the window's close box at the upper left corner of the title bar.

**close box**
The small white box on the left side in the title bar of an active window. Clicking in this box closes the window.

**command**
An action for the Macintosh to perform. Commands are usually found in the menus.

**Command key**
A special key found just to the left of the spacebar on the keyboard. When held down while another key is pressed, the Command key may have the same effect as choosing a command from a menu.

**cut**
To remove a selection using the Cut command from the Edit menu. The cut selection is stored temporarily on the Clipboard.

**data base**
An organized collection of related information (data).

**datafile**
The name given to a Microsoft File document. It consists of a collection of records organized into a data base.

**desk accessories**
Small applications that can be opened from the Apple menu, at any time—even while you're using another application. The Calculator, Scrapbook, and Note Pad are examples of desk accessories.

**desktop**
The area of the Macintosh screen where you do your work. The desktop includes the menu bar and grey area below it.

**dialog box**
A box which appears with a message to request more information from the user. The message can be a warning or error message.

**dimmed icon**
An icon representing a disk that has been ejected, or a document, folder, or application on a disk that has been ejected.
**disk**
The magnetic medium on which the Macintosh stores information.

**disk drive**
The disk drive (either internal—part of the Macintosh, or external—connected to the Macintosh) retrieves information from the disk and stores information on it.

**document**
What you create using a Macintosh application. Macintosh remembers the application you used to create your document, and opens the application automatically when you open your document.

**double-click**
A mouse technique used to perform a shortcut. To double-click, position the pointer on the desired item (for example, an icon) and click the mouse button twice in rapid succession without moving the mouse.

**drag**
To position the pointer on an item, press and hold the mouse button and move the mouse to a new location. Releasing the mouse button either confirms a selection or moves the item to a new location.

**Enter key**
A special key, found just to the right of the spacebar on the keyboard, that confirms or terminates an entry or a command.

**field**
In a data base, where one specific piece of information in a record is stored. A field can usually only hold one specific type of information (for example, text, number, and boolean).

**file**
A collection of information stored on a disk, usually a document.

**Finder**
An application used to manage disks, documents, folders, and applications on the Macintosh desktop.

**folder**
A holder for documents and applications on the desktop. You use folders to organize and group your documents and applications.

**font**
A collection of typographical symbols, such as letters, numbers, and punctuation marks that are visually related. An example of a Macintosh font is Geneva.
handles
Small black boxes that surround a selection, allowing you to resize or reshape it.

highlight
To make something stand out against its background. An item is usually highlighted to indicate that it has been selected or chosen.

l-bar
A special type of pointer used in entering and editing text.

icon
A small picture of an item on the Macintosh desktop, like a disk, a folder, and so on.

information window
A window that appears when you choose the Get Info command from the File menu. The information window contains such information as the size, type, and date of the currently selected disk, application, document, or folder.

initialize
To prepare a disk to receive information. All disks must be initialized before they can be used.

insertion point
The point in a document where something will be added. The insertion point is usually marked by a flashing vertical bar.

lock
Locking a disk prevents that disk from being altered. Locking a document prevents it from being discarded. To lock a disk, set the write protect tab at the upper right corner of the disk.

memory
The part of the Macintosh that stores information while you work with it. When you turn your Macintosh off, everything stored in memory is lost. Saving transfers a copy of the information in memory onto your disk for safe-keeping.

menu
A list of commands that appears when you press the mouse button while over the menu title in the menu bar. Dragging through the menu highlights each command in order. Releasing the mouse button while a command is highlighted chooses that command.

menu bar
The list of menu titles that runs across the top of the Macintosh desktop.
**mouse**
A small device that you move to control the pointer on the Macintosh screen. When you move the mouse, the pointer moves correspondingly on the screen.

**mouse button**
The button on the top of the mouse. In general, pressing the mouse button initiates some action on whatever is under the pointer, and releasing the button confirms the action.

**Note Pad**
A desk accessory that allows you to enter and edit small amounts of text while working on another document. Use the Note Pad to store phone numbers, messages, and other information that might otherwise get lost when you're working with your Macintosh.

**open**
Opening a document, application, folder, or disk creates a window from its icon.

**Option key**
A key used like the Shift key to give an alternate meaning to another key. You can use the Option key to type foreign characters or special symbols.

**paste**
To reposition the contents of the Clipboard—whatever was last cut or copied.

**pixel**
Stands for picture element, the dots that make up the images on the Macintosh screen.

**platypus**
A small, four-legged mammal not usually found in large cities.

**pointer**
A small shape on the screen that follows the movement of the mouse. Most often an arrow that points up and to the left (towards Alaska, for those in the continental United States. Note that if you live in Alaska, the mouse points somewhere else—we're not quite sure where, but most probably still up and to the left).

**press**
To position the pointer and then hold down the mouse button without moving the mouse.

**record**
One entry in a data base. A record is made up of fields that store the specific pieces of information.
relative reference
In a spreadsheet, a reference to a cell's position in relation to another cell. For example, RC[-6] means "the cell that is six columns to the left of this cell and in the same row." A relative reference will indicate a different cell each time the reference is moved.

report
A presentation of data base information in the form of a table. A report allows you to perform mathematical calculations on the information.

Return key
A key that moves the insertion point to the beginning of the next line. It's also, in some cases, used to confirm a command.

save
To store information on a disk. Saving transfers a copy of information in memory to the disk.

Scrapbook
A desk accessory in which you save frequently used pictures or text.

scroll
To move the contents of a window so that a different part of it is visible.

scroll arrow
An arrow on either end of a scroll bar. Clicking a scroll arrow moves the document or directory one line in the direction of the arrow. Pressing a scroll arrow scrolls the document continuously.

scroll bar
A rectangular bar that appears along the right or bottom edge of a window. Clicking in the grey area of the scroll bar moves the contents of the window a screenful at a time.

scroll box
A small, white box found in a scroll bar that indicates the position of the window's contents relative to the entire document. For instance, if the scroll box appears at the top of the scroll bar, the current window displays the first part of the document. Dragging the scroll box to a position on the scroll bar moves you to that position in the document.

select
To indicate where the next action will take place. Usually, selected items are highlighted to set them apart.

selection
The information or items affected by the next command. The selection is usually highlighted to make it stand out from its surroundings.
**shift-click**
To extend a selection by holding down the Shift key while you click or drag to select additional items.

**Shift key**
A key that, when pressed, causes a typed letter to appear in uppercase. Also causes the upper symbol to be typed when used with a number or symbol key.

**size box**
A box on the bottom right of some active windows that lets you resize a window.

**software**
Programs or instructions for the Macintosh to carry out.

**split bar**
In some Macintosh applications, a small box that can be used to divide a window into two or more panes. By dividing a window into panes, you can view more than one part of a document at the same time.

**startup disk**
A disk with the system files necessary to start the Macintosh when it's first switched on. Usually startup disks have a system folder with the System and Finder files on it.

**style**
A stylistic variation of a font, such as boldface, underline, or italic.

**Tab key**
A key that, when pressed, moves the insertion point to the next tab marker. In a dialog box, the Tab key usually moves the insertion point to the next rectangle to enter information.

**title bar**
The horizontal bar at the top of a window that displays the name of what's inside the window. Dragging the title bar lets you move the window on the desktop.

**tofu**
A food made from soybeans.

**window**
An area of the desktop that displays information. You view documents through windows that you open on the desktop. Windows can also be moved, overlapped, resized, scrolled, and closed.
Index

A
absolute reference 4-18; 8-5
active window 1-13:15; 5-11; 8-5
annotation 5-22
analyzing data 5-20:21, 5-37
Apple menu 1-15; 8-5
application 1-3:4, 1-16, 1-21, 1-26; 8-5
area chart 5-15
argument 3-109; 4-24; 8-5

B
Backspace key 1-3; 2-13; 3-9; 3-98:99; 4-11;
5-12, 5-14, 5-29; 8-5
bar chart 5-15
Border palette 2-9
Brush Shapes 2-21
Buick, old 4-38
button 8-5

C
cancel button 8-5
cancel icon 4-9:10
category 5-11
cell 4-8:10; 8-5
collection window 4-9:10
Change 3-47, 3-48, 3-53
chart window 5-10, 5-37
choose 8-5
click 8-5
clicking 1-7:8, 1-26; 3-65:66, 3-68:69, 3-76,
3-89; 7-13
Clear 4-68:69; 6-11; 7-24
clip 6-62
Clipboard 2-17, 2-37; 3-25:27, 3-40:42, 3-72;
4-52, 4-55; 5-28; 8-6
Close 1-10, 1-26; 8-6
box 1-15; 3-8, 3-73; 8-6
column 4-8:10, 4-46, 4-65:66
chart 5-15
header 4-9
number of 3-120
combination chart 5-15
command 8-6
key 1-4, 1-10; 8-6
completion test 4-60:61, 4-71
computed number fields 6-55
conditional instructions 3-117
Copy 2-17; 3-24, 3-31, 3-38, 3-40:42, 3-72,
3-89; 4-8, 4-21:22, 4-41, 4-51, 4-53:54, 4-71
copying 1-23; 3-75
two between documents 3-38, 3-53
rulers 3-26
data 5-27
creating:
form 6-33, 6-60
new document 1-17
critical path 7-28:29, 7-39
current selection 4-9, 4-11
Cut 2-37; 3-25, 3-31, 3-41; 8-6

D
data base 8-6
DATA instruction 3-114
data:
points 5-11
records 3-112, 3-113
series 5-10, 5-11
window 5-10
datafile 6-9; 8-6
window 6-9, 6-60
data series 5-11
deadlines 7-23
decimal tabs 3-45, 3-69
Define Name 4-36:37, 4-49, 4-50
dependency line 7-10, 7-15:16, 7-39
dependent 7-10
deselect 3-13
desk accessories 1-15, 1-16; 8-6
desktop 1-5, 1-26; 8-6
dialog box 1-18; 8-6
dimmed icon 8-6
disk 1-6, 1-17; 8-7
double sided 8-2
drive 1-3, 1-17, 1-19, 1-21:23, 1-25,
8-7
division 3-83, 3-85:87, 3-89
Division Layout 3-85, 3-89, 3-120
documents 1-16, 1-20:23, 1-26; 8-7
dollar format 4-16
double-click 1-7, 1-26; 3-13; 4-46; 8-7
drag 8-7
dragging 1-14; 2-9, 2-37; 4-13:14, 4-31:32,
4-41, 4-59
drawing window 2-9, 2-37
duration 7-23, 7-39
duplicate 1-8; 2-6, 2-11:12, 2-14, 2-37

E
Edit menu 2-10, 2-20
Cut 2-37, 3-25, 3-31, 3-41; 8-6
Copy 2-17, 3-24, 3-31, 3-38, 3-40:42, 3-72,
3-89, 4-8, 4-21:22, 4-41, 4-51, 4-53:54, 4-71

8-13 REFERENCE: INDEX
Paste 2-18, 2-37; 3-23:24, 3-72; 8-9

editing:
  information 6-58
text 3-12
eject 1-22, 1-26
Empty Trash 1-25
Enter key 4-11:13, 4-28:30, 4-41; 5-13; 8-7
entering data 5-13, 5-37; 6-56
equal sign 4-18
Eraser 2-9
erasing 2-37

F
FatBits 2-22, 2-37
field 3-98:99, 3-112; 6-9; 8-7
file 8-7
File menu 1-26
Fill:
  Down 4-66:68
  Right 4-64
Find 3-47:48; 6-13:16, 6-28
  operators 6-14
Finder 1-19; 8-7
Flip Horizontal 2-19
folder 1-20:21; 8-7
font 3-15:16; 8-7
  menu 2-33
Fontsize menu 2-8, 2-33
footer 3-50, 3-51, 3-53
footnote 3-72, 3-77:80
Reference Mark 3-78
window 3-78:80
formatting:
  charts 5-24, 5-37
  fields 6-54:55
  forms 6-39:52
  labels 6-52:54
text 3-16:24, 3-69:71
formula 4-8, 4-17:18, 4-20:25, 4-41, 4-71
  bar 4-9:11
functions 4-22:23

G
Grabber 2-22, 2-26, 2-37
Grand summary 6-24:26
general format 4-15
glossary 3-72:73, 3-82, 3-89; 8-5:11
window 3-72, 3-73

H
handles 3-42:43, 3-53; 5-22; 8-8
header 3-50, 3-52
  record 3-112:113, 3-117
hide:
  area 6-33, 6-38, 6-41
  line 6-41
  Rulers 3-23
hiding:
  fields 6-38:41
  records 6-16
hierarchical file system (HFS) 8-3
highlight 8-8
highlighted 1-8; 4-9, 4-49, 4-65

I
I-bar 1-18; 2-33; 3-11, 3-43; 5-14; 7-13, 7-15;
  8-8
icon 1-5; 4-8:10; 8-8
IF...ELSE...ENDIF instruction 3-106:108
indentation marker 3-19
information window 8-8
initialize 1-21:22; 8-8
inserting:
  graphics 3-41:42
  ruler 3-18
insertion point 2-33; 3-8, 3-10:11, 3-41;
  4-23:24, 4-31; 7-11, 7-13, 7-22; 8-8
instruction 3-99
iteration 4-59:62, 4-71

JKL
keyboard 1-3
label 4-9, 4-12, 4-19:20; 6-18, 6-33, 6-52:54;
  6-60
lasso 2-6, 2-13:14, 2-37
leader character 3-119
legend 5-17
line:
  chart 5-15, 5-40:41
  spacing 3-21, 3-70
linear regression 5-21
linking spreadsheets 4-51:55, 4-71
list helper 6-39:40
lock 8-8

M
Macintosh Plus 8-2:4
MacPaint 3-41; 7-19
MacWrite 5-14; 6-58; 7-22
main document 3-99
margin marker 3-18:19
memory 1-17, 1-19, 1-20; 8-2, 8-8
menu 1-9, 1-26; 8-8
  bar 1-5, 1-9; 2-8; 8-8
merge document 3-99, 3-112
milestone 7-15, 7-39

8-14 REFERENCE: INDEX
mouse 1-3, 1-6:8, 1-26; 4-10:14, 4-32:33; 8-9
button 8-9
moving:
a cell 4-12
a task box 7-17
a window 1-14
fields 6-21
multiple fields 6-23
text 3-24:26
multiple sort 6-12

N
name 4-35:37, 4-46:50, 4-65:66, 4-71
new:
field 6-33
record 6-33
Series window 5-11
not shown area 6-21
not sorted area 6-21
Note Pad 1-15; 8-9
Number series 5-11

OP
Open 1-9:10, 1-16, 1-26; 3-110:112; 8-9
Option key 1-4; 2-12, 2-14; 8-9
page:
break 3-52:53, 3-63, 3-109
glossary entry 3-82
number 3-50, 3-51, 3-82
page-number icon 3-51
Setup 5-36; 7-18
paint can 2-6, 2-24, 2-37
paintbrush 2-10, 2-21, 2-37
Paste 2-18, 2-37; 3-23:24, 3-72; 8-9
Pattern palette 2-9, 2-10
patterns 2-6, 2-9, 2-37; 5-33, 5-34, 5-37
pencil 2-6, 2-23, 2-37
percent format 4-19
pixel 8-9
platypus 3-39; 8-9
plot area 5-31
plotting a series 5-14, 5-37
plotting order 5-30
pointer 1-6:7; 3-10:11, 3-42:3-43, 3-46, 3-53, 3-64:66; 4-11, 4-13:14, 4-47, 4-59, 4-63:64; 7-11, 7-15; 8-9
Porsche 944 4-38
press 8-8
pressing 1-7
Preview Reports 6-27
Print 2-36:37; 3-30:31, 3-86:88; 4-40:41, 4-70:4-71
print merge 3-92, 3-115
prompt 3-103, 3-115

QR
Quit 1-26; 3-88; 4-40, 4-70
range 4-3:32, 4-36
record 6-9; 8-9
Redo 3-12
reference (spreadsheets) 4-18, 4-20:22, 4-3:32, 4-35, 4-48, 4-55:57, 4-63
region 4-27:34, 4-41, 4-48:49, 4-58:59, 4-64, 4-67:69
regular tabs 3-45, 3-46
relative reference 4-21, 4-55:57; 8-10
replacing 3-16
report 8-10
repositioning graphics 3-43
resize 7-14
fields 6-44:46
topics 3-42
Resource:
Cost Entry Table 7-32
Timeline 7-31
Return key 1-3; 3-9; 4-12; 7-27, 7-28; 8-10
row 4-8:9, 4-41, 4-48:50, 4-71
header 4-8, 4-49, 4-50
rubber band 2-19, 2-37
ruler 3-8, 3-16:17, 3-40, 3-44:45, 3-51
running head 3-80:87

S
Save 1-17:18; 2-16, 2-24, 2-37; 3-24, 3-71, 3-75, 3-88; 4-27, 4-32, 4-40:41, 4-52, 4-70; 6-17; 7-22; 8-10
Save As 4-27
scale 6-62
scatter chart 5-15, 5-20, 5-40:41
schedule chart 7-10, 7-18, 7-19, 7-22, 7-39
Scrapbook 2-17:19, 2-37; 8-10
file 2-17
screen 1-21
scroll 8-10
arrow 1-12:13; 4-33; 8-10
bar 1-12; 2-18; 3-8, 3-17:18; 4-23, 4-37, 4-53; 8-10
box 2-18; 4-31; 8-10
Search menu 3-47:48
select 8-10
task box 7-13, 7-17
selecting 1-8:9; 3-63:65, 3-89; 4-11, 4-27:28, 4-33, 4-52, 4-64:65; 7-13, 7-17
text 3-12:15, 3-30
selection 8-10
bar 3-64:66, 3-75:76, 3-83, 3-89
Rectangle 2-6, 2-11:13, 2-20, 2-37
Sequence series 5-11

8-15 REFERENCE: INDEX
Set:
  Chart Size 7-18
  Earliest Start 7-25, 7-39
  SET instruction 3-102, 104
  Latest Finish 7-23

setting:
  Calendar 7-35
dates 7-23
shape tools 2-10, 2-37
shift-click 1-8, 1-26; 3-14; 7-17; 8-11
Shift key 1-8; 2-14, 2-16, 2-21, 2-29, 2-31,
  2-37; 7-17; 8-11
-Return 4-12
-Tab 4-12

Show:
  Clipboard 3-26
  Dates 7-34
  Entire Chart 7-19
  Page 2-26:28, 2-37
size box 1-12; 3-8; 8-11
sizing fields 6-34, 35
slack time 7-29
software 8-11
Sort 6-9:12, 6-20:23, 6-28
  area 6-21
space:
  after 3-70, 3-74, 3-87
  before 3-70, 3-87
split:
  bar 3-80, 3-81, 3-88; 8-11
  windows 3-80
spreadsheet 4-6, 4-8:10, 4-12:14
standard glossary 3-88
startup disk 1-4:5; 8-11
summary:
  fields 6-24, 6-28
  report 6-27
style 8-11
Style menu 2-33
system disk 1-5

tab 3-29, 3-67:69, 3-71, 3-74, 3-82, 3-89
  key 3-29; 4-12; 7-26:27, 7-39; 8-11
  marker 3-29, 3-46
  well 3-46
task 7-10:16, 7-39
  box 7-10:16, 7-27, 7-28, 7-39
  Cost Entry 7-33
text 2-6, 2-33:34, 2-37; 3-10, 3-12:13,
  3-22:25, 3-30:31; 4-11; 5-37; 7-13, 7-22
  alignment 3-21
  series 5-11
time 7-28, 7-29

UV
Undo 2-10, 2-24, 2-37; 3-11:12, 3-50
value 5-11
View 6-61

W
What If? 4-6, 4-25:26, 4-38:39, 4-41, 4-69,
  4-70; 7-37
wild cards 6-15
window 1-11, 1-15, 1-26; 2-22; 8-11
word wraparound 3-11

XYZ
zoom box 8-4
In the olden days, before 1984, not many Stanford University undergraduates used personal computers—for a very good reason. Not very many undergraduates knew how—and not very many of them wanted to learn. After all, in those days it meant sleeping through endless lectures, wading through computer manuals as thick as the Manhattan Yellow Pages, and staying awake all night memorizing cryptic commands and equally cryptic error messages.

Then, on a particularly bright day in Stanford, California, some particularly bright undergraduates had a particularly bright idea: since only students really understood what other students were all about, they could teach each other about personal computers—Not just any personal computer, mind you, but the zippiest, friendliest, most engaging personal computer around—the Apple Macintosh.

So it was that this band of zany undergraduates worked long days, late nights, and a few legal holidays using their Macintoshes to help them get through school, and teaching other students how to do the same. They taught about how to use MacWrite to write home for money, how to use MacPaint to draw maps of Upper Malta, and how to use Microsoft Word to send out customized resumes to perspective employers.

They were an eclectic bunch—majoring in everything from Mechanical Engineering to History and Art. But they were friends, and as Stanford undergraduates, they shared a bizarre sense of humor, a readiness to work long hours for low pay, and a penchant for pulling all-nighters with the help of Ken’s House of Pancakes.

The result of their efforts is this book. And while some said it couldn’t be done, no one is more amazed to see it in print than the authors themselves.
Approaching Macintosh is a guide to learning Macintosh applications software. The idea for the book was conceived at Stanford University, a member of the Apple University Consortium. At Stanford, a great many students were interested in learning how to use computers—necessarily how to program them.

With these goals in mind, a group of enterprising Stanford undergraduates created "Using the Macintosh at Stanford," a very successful course that introduces students to applications software on the Macintosh. Notes and ideas stemming from the class were compiled and rewritten to produce this book.

Approaching Macintosh is based on the premise that learning about computers is easiest when you are actually using them. The book is organized into sections that teach the basic concepts of word processing, spreadsheets, database and project management, business graphics, and more. The sections contain modules, each of which focuses on a self-paced, hands-on tutorial. These tutorials teach the concepts associated with particular applications software by leading the reader through the creation of a sample document. Once the module is completed, the reader should feel comfortable enough with the application to begin using it.

HIGHLIGHTS

- Applications software covered includes: MacWrite, MacPaint, MacProject, Microsoft File, Microsoft Chart, Microsoft Multiplan, and Microsoft Word.
- Modular design allows instructors to select those modules that are best suited to their particular courses.
- Material has been extensively class tested at Stanford and other universities.
- Section introductions, reviews, and exercises make it easy to use this book either as a primary text or as a laboratory supplement.
- Unique "Gallery" sections provide finished documents using more sophisticated concepts that show the breadth of applications possible with the Macintosh.

IMPORTANT

The APPROACHING MACINTOSH DOCUMENTS DISK contains files necessary to complete five of the twelve modules, as well as sample documents discussed in the text. See the order form inside the book for more information on how to obtain your disk.
How To Use the
Approaching Macintosh Documents Disk:

The Approaching Macintosh Documents Disk contains documents that you'll need to complete some of the modules in this book. It also contains copies of all of the documents found in the "Gallery" sections throughout the book.

Since the Documents Disk does not contain system files, it cannot be used as a startup disk. In order to use the documents on the Documents Disk, you should copy the document you need onto the disk you're using. That way, you'll always be working with a copy of the original, and the original document will be available to use again.

To copy a document from the Documents Disk to an applications disk

With One Disk Drive:

• Insert an applications disk to start up the Macintosh. (An applications disk is a disk with an application, such as MacWrite, and the system files needed to start up the Macintosh.)
• Eject the applications disk by choosing Eject from the File menu.
• Insert the Approaching Macintosh Documents Disk.
• Use the scroll bars and open folders, if necessary, to find the document you want.
• Drag the icon of the document you want into the disk window of the applications disk.
• Swap disks as prompted until the copy is complete.

With Two Disk Drives:

• Insert an applications disk into the internal disk drive to start up the Macintosh. (An applications disk is a disk with an application, such as MacWrite, and the system files needed to start up the Macintosh.)
• Insert the Approaching Macintosh Documents Disk in the external disk drive.
• Use the scroll bars if necessary to find the document you want.
• Drag the icon of the document you want into the disk window of the applications disk.
• Your copy will be completed in a few seconds.

More details on copying documents, startup disks, applications, and other Macintosh fundamentals can be found in the Introduction to Macintosh module. Please complete this module first.