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Step 2 Enter the categories and values for the plan 

Since the New Series window has created a text series, we can begin entering 
data. For a text series, MacChart expects to see entries for both categories (a 
blank label is an acceptable entry) and values. After a category has been keyed 
in, press the Enter key, and the cursor will move to the values area on the same 
line. You can then enter a value, press the Enter key, and continue entering data 
until you are through. Enter the following data: 

Categories Values 

11/15 25 
50 

12/15 75 
100 

1/15 125 
150 

2/15 175 

Since our categories are the same for both goal and actual, we can save a 
little time by using them again for the actual data. Place the cursor to the left of 
the first category, 11 I 15, press down on the mouse button, and drag it to the 
end of the last value, 175. Release the mouse button, enter the Edit menu, and 
select Copy to place a copy on the Clipboard. 

Step 3 Create a new series for the actual data 

Click in on any visible portion of the New Series window and it will become 
active. Enter the Data menu and select Text. When the text series properties 
menu appears, enter the following labels: 

Title 

Title for categories 

Title values 

Step 4 Enter the actual data 

ACTUAL 

Progress 

Pages 

Since we have a copy of the plan data on the Clipboard, let's Paste it in now. 
Enter the Edit menu and select Paste. MacChart enters all of the data on the 
Clipboard. All we have to do is replace the goal figures with the actual figures. 
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Position the cursor to the right of the first value (25), click the mouse button to 
create an insertion point, and backspace enough times to erase the plan value. 
Then enter the actual value. Do this now for the actual values: 

11/15 33 
68 

12/15 103 
139 

1/15 168 
188 

2/15 188 

Step 5 Display a graph of the plan data 

Our series windows are set for the default (don't display chart). We can activate 
each window and click in the Plot box or do them both at one time by using the 
List option in the Data menu and clicking the Plot box for each series in the 
Series list. If you have numerous series windows, use the List option in the Data 
menu. We'll use the Plot box and illustrate a point or two along the way. Do the 
following: 

• Click in any area of the "plan" series window. 

• Click in the box next to Plot. 

• Click in any area of the Chart. 

When the Plot box is clicked, MacChart plots the data and displays the 
Chart. To move the series window to the back of the screen, click in any area of 
the Chart. At this point, your graph should resemble the graph illustrated in 
Figure 4.16. 

Step 6 Modify the chart type 

The default shape is a Column graph that is acceptable for comparing semi­
monthly values. However, we would also like to view any trend that might be 
developing. Let's use a Line graph for that purpose. Accordingly, do the 
following: 

• Enter the Gallery menu and select Line. 

• When the floating menu of sample line graphs appears, click in the box of the 
line graph that shows both markers (for the plot points) and lines. 

• Click the OK box. 
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Figure 4.16 Graph of Plan. 

Step 7 Add the actual data to the graph 

To keep abreast of my progress in writing the book, I entered the actual data 
beginning on November 15, 1982, and produced a graph on a semimonthly 
basis. Since we have all the actual figures, we'll see what the graph looks like 
with all the actual data in it. Click in the series window for the actual data and 
click the box next to Plot. MacChart adds the actual data to the graph. 

Step 8 Add grid lines 

When two sets of values are fairly close together (such as is the case in this case 
study), you may want to use grid lines to help distinguish the relative values. 
Let's add them to see if they help: 

• Enter the Chart menu. 

• Select Axis. 

• When the Chart axes menu appears, click in the box next to major grid Lines. 
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MacChart adds the major grid lines. At this point you may wish to 
experiment with the other grid line~ to see how they appear on the graph. 

ADD A LEGEND 

Although our line shapes are perfect for what we want to display, we can't tell 
from the graph which line represents plan data and which represents actual 
data. In this regard, the Legend can help us. Enter the Chart menu and select 
Show Legend. A Legend automatically appears. Reenter the Chart menu and 
observe that the legend command has changed to Hide Legend. The legend 
command switches back and forth between Show Legend and Hide Legend to 
permit us to display it or hide it whenever we want. 

When we added the Legend, MacChart automatically resized the Plot 
area to make room for the Legend. The Legend displays each type of Marker 
used in drawing the line graphs. Notice that the Legend labels, Plan and Actual, 
correspond to the Series titles we used. Now each of our line graphs are 
explained in the Legend area. 

Step 10 Final cosmetic changes 

As indicated earlier, you can change every single component in the Chart, 
including the size and location of text labels, and you can add a label if you 
desire. To illustrate how to use some of these features, let's make some final 
cosmetic changes to our graph. 

CHANGING THE VALUES LABEL 

Enter the Chart menu and choose Select Plot Area. The Plot area should now be 
surrounded by little black boxes. The boxes in the middle are for changing the 
size of the Plot in one dimension only. For example, try to drag the bottom 
middle box. It will only move up and down to shorten or lengthen the width of 
the Plot area. If you press down on the mouse button anywhere inside the Plot 
area (except in a size box), you can reposition the Plot. The same is true for the 
other components. 

Point the mouse inside the Plot area, press down on the mouse button, 
and drag the Plot a couple of inches to the right. Notice that the values label, 
Pages, moves with the Plot. It does so because it's automatically set to do so. 
Let's change that. Position the mouse directly on the values label, Pages. Click 
the mouse button to select it. Enter the Format menu and select Text. The Text 
menu illustrated in Figure 4.14 will appear. Notice that there are selection 
boxes for attaching the label, selecting font style and size and aligning the 
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label. Click the mouse button in the Unattached box to detach it from the axis. 
Click OK and we can move the values label. Drag it to the left of the screen and 
let go of the mouse button. 

POSITIONING AND SIZING THE PLOT 

Select the Plot area using the Select Plot Area option in the Chart menu. Drag it 
back to the left just short of the values label. Position the mouse pointer inside 
the middle-size control box on the right side of the Plot area. Press down and 
drag the mouse to the left just enough to make room for the Legend {if the 
Legend moves with the Plot, click inside the Legend, enter the Format menu, 
and select Legend and deselect Automatic Size and Position); click the OK box 
to continue. 

POSITIONING AND SIZING THE LEGEND 

Click inside the Legend. It too can now be adjusted as to size and position. Move 
it around and adjust its size until you feel comfortable with the cosmetics. 
Experiment with the features in the Legend Properties floating menu (select 
Legend from the Format menu). 

CHANGING THE TITLE 

Our main title is "PLAN,'' which isn't very descriptive. Initially, MacChart uses 
the Series title (for the data series ordered #1) for the main title. Let's change 
it. Click inside the title, PLAN. Enter the Format menu and select Text. Deselect 
automatic positioning. Select large type size and bold. We're ready to change 
the title. 

Click in front of the last letter to create an insertion point. Use the 
Backspace key to erase Plan. Key in the title, "STATUS OF BOOK" (no quotes). 
Press enter to accept the title. Now drag the title until it is positioned where you 
think it should be. That's all there is to it. Your fmished graph should resemble 
the graph illustrated in Figure 4.1 7. 

Step 11 Save the graph 

Had we actually created a graph on a bimonthly basis, we would have saved the 
graph after each update. To save our example, enter the File menu and select 
Save As. Use a descriptive file name such as "PROGRESS ON BOOK" (use any 
combination of characters except for the colon). 
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STATUS a= BOa< 

200 ~--------------------------------~ 
180 

160 

140 
120 

Pages 100 

80 

60 

40 
20 .................................................................................................................................................... . 

0 ~--------------------------------~ 
1U15 12/15 UlS 2115 

Progress 

Figure 4.17 Plan Compared to Actual. 

Step 12 Critique 

As I indicated earlier, it isn't necessary to use every MacChart feature for every 
graph. Several of the steps above were added to illustrate the features. There 
were other alternatives available to us. For example, we could have: 

• Used a Column graph 

• Entered blanks for all categories 

• Used a prefix of "P" for Plan and "A" for Actual 

• Used a category axis title of "Semimonthly Progress" 

• Added new labels (e.g., Plan and Actual) adjacent to the line graphs instead 
of using the Legend. We also could have had a two-title heading by adding a 
label: 

• USING THE Macintosh COMPUTER 

• Progress on book 

Our latemative approaches indicate just how flexible MacChart really is. 
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CLEARING DATA AND FORMATS 

After you have saved the graph, you might want to make further modifications 
or work on a new graph. Do the following: 

• If the Chart is not in front of the data windows, select it. 

• Enter the File menu and select New to erase all the formats and return to the 
default formats. 

• Select any data window. 

• Enter the File menu and select New to erase all the data windows. 

When you are ready for some fun, we'll move on to MacPaint. 



Chapter 5 

USING MacPaint 



M acPaint is essentially a free-form drawing tool. Whereas MacPlan, Mac­
Write, and MacChart are designed to produce structured end-products 

(i.e., spreadsheets, textual documents, and fmancial graphs), MacPaint isn't 
structured to produce anything at all! However, it can produce every shape 
imaginable. Our topics are: 

• Overview of MacPaint 

• Ways to use MacPaint 

• Working with MacPaint features 

• A MacPaint illustrated idea 

OVERVIEW OF MacPaint 

Imagine that you won a prize in a drawing. Your prize is unlimited use of 
everything in an artists' supply store. As you look around the store, you see 
pencils, erasers, paint brushes of assorted sizes, cans of spray paint, regular 
paint cans, rulers, templates for drawing shapes and characters, and a seem­
ingly endless supply of paper. In the beginning, you might experiment with the 
various templates to see what patterns develop. Add a dab of spray paint and 
perhaps paint some swirls, etc., to get the feel of the paint brushes. When you 
are through experimenting, you marvel at the kaleidoscope of patterns you 
have created. You begin to visualize some specific things you might create. 

If you are wondering what the introduction above has to do with Mac­
Paint, then wonder no more. Having MacPaint is like being in that artists' store. 
MacPaint provides you with all of the artists' tools and turns you loose with an 
endless supply of paper. With MacPaint, you can create anything you want. 

WAYS TO USE MacPaint 

While there are many ways to using MacPaint, they all fall into two general 
categories-creating useful end-products and having fun. 

Creating Useful End-Products 

While visualizing the artists' supply store, you might have concluded that 
sketches and paintings are the only primary end product. While it is certainly 
true that MacPaint can help you produce sketches and paintings, these are but 
one class of end-products you can create. Set aside your artists' smock and don 
your business hat for a moment. If you had a tool that could produce squares, 
straight lines, dotted lines, arrows, various shapes, and text, you could fmd a 
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business use for that tool. With such a tool, you can illustrate organizational 
relationships, office arrangements, relative locations, floor maps, street maps, 
document flowcharts, procedure flowcharts, etc. In that regard, MacPaint can 
help you produce end-products useful for business purposes. Similarly, if you 
are a student, these end-products might be equally useful to you. 

Having Fun 

You have probably devoted a lot of time and effort reading the preceding 
chapters. At this point, you deserve to have some fun. Take off your shoes and 
get comfortable. If you have a family, assemble the other family members. Let 
them enjoy playing with MacPaint too. After a work session of writing this 
book, my wife and daughter were eager to join in, take hold of MacMouse, and 
have some fun. Mesmerized by the endless patterns and shapes, we took turns 
using MacMouse to create yet a new design. MacMouse never ceased to amaze 
us with his endless variety of tricks. Caught up in the process, we found that 
hours would pass before we knew it. After a long day of work and school, we 
deserved it. 

WORKING WITH MacPaint FEATURES 

Having been turned loose in an artists' supply store, let's begin by looking 
around the store to see more clearly what is in it. After that, we'll see how to use 
things and what to do with them when we're done. Our topics are: 

• Understanding MacPaint' s components 

• Using MacPaint tools 

• Changing patterns 

• Modifying MacPaint paintings 

• Keyboard commands and other shortcuts 

• Storing, retrieving, and printing MacPaint paintings 

Understanding MacPaint's Components 

When you load in the MacPaint application program, MacPaint will display a 
blank piece of paper surrounded by shapes and patterns. As illustrated in 
Figure 5.1, the basic components consist of: 

• MacPaint tools 

• Line thickness box 
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• MacPaint patterns 

• Current pattern box 

MacPaint TOOLS 

Our tools are stored to the left of our blank piece of paper. We'll explore each 
tool shortly. 

LINE THICKNESS BOX 

At the bottom left of the screen is the line thickness box. To change the 
thickness. point MacMouse to the desired thickness and click the mouse button. 

CURRENT 
PATTERN 

BOX 

Figure 5.1 MacPaint's Components. 

PATTERNS 
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MacPaint PATTERNS 

To help get you started, MacPaint has created an array of patterns to choose 
from. To select a pattern, point MacMouse to the pattern and click the mouse 
button. 

CURRENT PATTERN BOX 

When you select a pattern, it is displayed in the current pattern box. 

Using MacPaint's Tools 

MacPaint's tools are represented by the icons in Figure 5.2. 
To facilitate our discussion of MacPaint' s tools, I have inserted their 

names alongside the icons. To select a tool, point MacMouse to the tool and click 
the mouse button. Let's see what each of them does. 

LASSO 

The lasso is used to capture objects with irregular shapes, including portions of 
a drawing. To capture an object (anything on the screen, including text), press 
down on the mouse button, drag the lasso around it, and release the mouse 
button. The lasso will then tighten up around the object at which time it can be 
modified (we'll discuss modifications in the next section). 

DOTTED RECTANGLE 

The dotted rectangle is also used to capture objects. Whatever is inside the 
rectangle, including any background area, will be captured. To capture an 
object with the dotted rectangle, press down on the mouse button, drag the 
mouse diagonally, and when the object is surrounded by the rectangle, release 
the mouse button. The object can then be modified. If you don't want to modify 
the object, click another tool. 

HAND 

Notice that the hand is turned and appears to be pulling or grabbing at 
something. The hand is pulling at the paper on the screen. What you see on the 
screen is only a portion of the drawing area you can use. To move the drawing 
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Figure 5.2 MacPalnt Tools. 
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paper, press down on the mouse button and drag the mouse in any direction. 
The paper moves in the same direction, exposing other areas of the drawing 
paper. 

To view the entire page, enter the Goodies menu and select Show Page. 
The view will then change to include the entire page. To return to the normal 
view, enter the Edit menu and Select Undo. 

TEXT 

You can create text anywhere you want to on the page. After clicking the Text 
box, position the mouse cursor at the desired location and click the mouse 
button to create an insertion point. Enter the Font, FontSize and/or Style menus 
to select the font type, size, and special features (bold, etc.), respectively. 

PAINT CAN 

The paint can is used to quickly fill an enclosed area (circle, rectangle, etc.). 
However, be careful using the paint can; if the area to be filled is not entirely 
enclosed, the paint will leak through and fill the next largest enclosed area. The 
paint used to fill an area is based on the current pattern selection. To fill an 
area, simply click inside the area. MacMouse will see to the rest. 

SPRAY CAN 

Unlike spray paints that we buy at the store, our MacPaint spray can never run 
out of paint. The type of paint is based on the current pattern box. Like a spray 
paint, the spray can sprays lots of little dots. Point the mouse to the desired 
location and drag the mouse around in any direction, including swirls, circles, 
etc. To stop spraying, let go of the mouse button. 

BRUSH 

Our store contains a large variety of paint brushes. The selection includes 
brushes of different lengths, shapes, and thicknesses. In addition, there are 
some brushes that paint dotted lines instead of solid lines. Like the paint and 
spray cans, the brush uses the paint in the current pattern box. To use the 
brush, press down on the mouse button and away you go. 

Brush selection. To select a brush, enter the Goodies menu and select Brush 
Shape. The floating menu illustrated in Figure 5.3 will appear. 
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Figure 5.3 Brush Selection Menu. 

Click the brush you want to use and the menu will disappear. By the way, you 
don't have to clean your brushes; MacMouse does that too. Love that mouse! 

Brush Mirrors. As a mirror reflects an image, so do the Brush Mirrors. Enter 
the Goodies menu and select Brush Mirror. The floating menu illustrated in 
Figure 5.4 will appear. 

(...__OK _ ___,J ( CNCEL J 

Figure 5.4 Brush Mirror Menu. 
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To select one or more mirrors, simply click them. To deselect the mirrors, 
click the None box. When you paint with the paint brush, using mirrors creates 
a symmetrical pattern. Use a swirling motion to create a kaleidoscope effect. 
This little goodie provides hours and hours of entertainment. 

PENCIL 

Use the pencil for free-hand drawing. The thickness of the lead can be adjusted 
in the line thickness box illustrated in Figure 5.1. To begin drawing with the 
pencil, click anywhere you want to and drag the mouse. Let go of the mouse 
button to stop drawing. If you need some help with straight lines, enter the 
Goodies menu and select Grid. Grid creates imaginary grid lines to help you 
draw straight lines. 

LINE 

Select the line and you can draw perfectly straight lines. The thickness of the 
line can also be adjusted in the line thickness box. As with the pencil, drag to 
draw and let go to stop. 

ERASER 

You can use the eraser to erase mistakes or create special effects. We'll discuss 
the eraser in the next section. 

RECTANGLE, OVAL, CIRCLE, AND POLYGON 

Selecting one of these enables you to create the respective shapes. Point the 
mouse to a desired location and drag it. The farther away you drag, the larger 
the shape you create. 

Notice that the tool box contains two of each of these shapes. The shape 
that is filled in creates a shape, the fill pattern of which is based on the current 
selection box. 

FREE FORM 

Use the Free form to create an enclosed shape of your choice. The Free form will 
continue drawing until you create an enclosed shape. As with Rectangle, etc., 
you can choose unfilled or filled. 
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Changing Fill Patterns 

In addition to using the standard fill patterns provided by MacPaint, you can 
customize existing fill patterns. To do this, click the pattern to be customized, 
enter the Goodies menu and select Edit Pattern. A floating menu will appear, 
which contains two boxes. The box on the left contains rows and columns of 
squares, some of which are white and others are black. The black squares 
represent the till pattern. To change a square from white to black or vice-versa, 
click the square. The box on the right shows the revised fill pattern. In addition 
to clicking a square, you can drag the mouse through the box; every square that 
is touched will change. 

When you are through editing the fill pattern, click the OK box to accept 
the changes you made or Cancel to revert back to the former fill pattern. The fill 
patterns are saved when you save your drawing. 

Modifying MacPaint Drawings 

You can modify your existing drawing whenever you desire. To facilitate 
making changes, use one of the following: 

• Undo 

• Erasing 

• Overlay 

• Fat Bits 

UNDO 

As with all Mac applications, Undo enables you to undo the most recent action. 

ERASING 

Since none of us are perfect (except MacMouse), we will make mistakes from 
time to time. Perhaps your pencil strayed too far or the spray can sprayed 
outside an area. MacPaint provides us five different ways that we can erase. 

Use the Eraser. Click the Eraser box and MacMouse will pass you the Eraser. 
Point to an area on the screen, press down on the mouse button, and hold it 
down. The mouse cursor turns into an Eraser. If you release the mouse button 
without dragging the mouse, only the area immediately under the Eraser will 
be erased. Dragging the mouse erases whatever comes underneath the Eraser. 
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So, for example, if a line extends too far (1) place the Eraser on top of the 
portion of the line you want to erase and click the mouse button or {2) drag the 
mouse until the portion of the line you want to eliminate is gone. 

You can also use the Eraser to create a white on black drawing. Using the 
Paint Can, fill the screen with black paint. Then use the eraser to eliminate 
portions of the black paint. 

Double-click the Eraser box. Double clicking the mouse button in the Eraser 
box erases the entire contents of the screen. 

Use the Lasso or Dotted Rectangle. Click the Lasso or Dotted Rectangle box. 
Then select an area with either tool. Enter the Edit menu and select Erase. The 
area enclosed by the tool will disappear. 

Drag the page. Select Show Page from the Goodies menu. When the page 
appears, position the mouse arrow outside the dotted rectangle and drag the 
image off the screen to erase it. 

OVERLAY 

Irrespective of the pattern fill previously used, you can use the same or another 
pattern to paint or draw on top of an area. For example, fill the screen with black 
paint. Then use the Eraser to paint over it (erasing is really overlaying). Finally, 
use the Pencil {or anything else for that matter) to draw in the area where the 
Eraser was used. The result is a double overlay (there isn't any limit to 
overlays). 

FAT BITS 

If you are familar with a little data processing terminology, then you know that 
a "bit" is short for binary digit. There are two numbers used in the binary 
numbering system--one and zero. In data processing, a one bit is used to 
designate an "on" state and a zero to designate an "off'' state. Now, let "on" 
stand for the color black and "off'' for the color white. If everything is off, our 
screen is white. 

We saw previously that we can change the fill pattern by selecting the Edit 
Pattern feature. Do you recall that the box on the left magnified the dots? Fat 
Bits (enlarged white and black squares-he, ho, ho) does the same thing to the 
screen as Edit Pattern does to the Fill pattern-it zooms in on a highly 
magnified portion of the screen. When you select Fat Bits, you can use the 
Pencil to make a white square ("off'' bit) change to black ("on" bit) and vice­
versa. Fat Bits is useful for making little Bitty changes in an image. When Fat 
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Bits is displayed, a small portion of the screen displays a split screen image of 
the entire screen to enable you to 

• Determine which portion of the screen is being displayed 

• See the effect of Fat Bits changes 

To leave Fat Bits, double-click the pencil. In addition to the features 
described above, you can invert, flip or rotate a selected shape by using the 
commands in the Edit menu. 

Keyboard Commands and Other Shortcuts 

Some features can be performed using the keyboard either as a substitute for 
the menus or to create additional features. In addition, double-clicking the 
mouse provides other shortcuts. 

KEYBOARD SUBSTITUTES 

Backspace 
Tilde -

Erases the selection 
Undo 

ADDITIONAL KEYBOARD COMMANDS 

Pressing down on the following indicated keys while dragging the mouse 
results in: 

Command key 
Option key 
Option key and Command key 
Shift key 

DOUBLE-CLICKING 

Copies a selected object 
Stretches or shrinks an object 
Makes multiple copies 
Constrains mouse movement to horizontal, 
vertical or diagonal directions 

Double-clicking the mouse when it is positioned in the following boxes results 
in: 

Dotted rectangle 
Brush 
Pencil 

Selects entire window 
Display Brush Shapes 
Leave or enter Fat Bits 
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Eraser 
Current pattern 

Erases entire window 
Display Edit Pattern 

Should you forget any of the above, enter the Goodies menu and select 
Short Cuts to display the related "help" screen. Click OK when you are ready to 
continue. 

Storing, Retrieving, and Printing MacPaint Paintings 

Inasmuch as the procedures for Saving, Opening, and Printing are similar to 
those for applications discussed in previous chapters, refer back to those 
chapters if you have forgotten any of them. However, if you have edited a fill 
pattern with the Edit Pattern feature, remember to Save your drawing or the 
pattern ynll be lost. 

A MacPaint ILLUSTRATED IDEA 

In addition to special purpose drawings such as those illustrated in Figures 5.1 
through 5.4 (as well as many of the illustrations elsewhere in this book), you 
can use MacPaint to create other charts such as the organization chart illus­
trated in Figure 5.5. 

Whereas, we're finished with the individual chapters, we still have one 
more application topic to cover--transferring data between applications. 

Figure 5.5 Organization Chart. 



Chapter 6 

TRANSFERRING 
DATA BETWEEN 

MACINTOSH 
APPLICATIONS 



Each of the applications individually is a treat. As if that weren't enough, you 
can transfer data between some of them. In this brief chapter, we'lllook at: 

• Applications that exchange data 

• Benefits of exchanging application data 

• How to exchange application data 

UNDERSTANDING WHICH APPLICATIONS CAN TRANSFER 
DATA 

At the date this book was written, data transfer was planned as follows: 

FROM 

MacPian 
MacPian 
MacChart 
MacPaint 

TO 

MacChart 
Mac Write 
Mac Write 
Mac Write 

BENEFITS OF TRANSFERRING APPLICATION DATA 

There are three principal benefits of the ability to transfer data from one 
application to another: 

• Time savings 

• Error elimination 

• Ability to consolidate date from multiple sources 

Time Savings 

Suppose that you have a recurring MacPlan application for which the results of 
calculations are used to prepare a MacChart graph. In the absence of data 
exchange, the MacPlan results must be manually entered into a MacChart data 
series window. If the data is voluminous or if the application is used frequently 
or repeatedly, the process of manually entering MacPlan results into MacChart 
could be time-consuming. In this regard, the ability to transfer data saves you 
time. 
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Eliminate Error Sources 

There are basically two types of errors that can result from relying on manual 
procedures to transfer data from one application to another: 

• Keying errors 

• Omissions 

The first type of error results from keying the data incorrectly. In our 
example, MacPlan results are manually transferred to MacChart. If the Mac­
Plan results are keyed incorrectly, then the MacChart will contain errors. The 
second type of error, omissions, results from the failure to transfer MacPlan 
results. Whatever the cause, be it fatigue, forgetfulness, or lack of training, if 
the data simply isn't transferred, then the second application will contain 
erroneous results. 

Ability to Consolidate Data Into One Document 

For illustrative purposes, assume that you are preparing a MacWrite report. 
Perhaps the report discusses the results of a forecast and contains recommen­
dations. You could end up with three separate documents: the MacWrite report 
itself; a MacPlan spreadsheet, which contains the forecast; and a MacChart 
graph depicting key observations. Instead of having three separate documents, 
why not consolidate the three documents into one? You could transfer the key 
numeric tables from MacPlan and the graph from MacChart right into the 
MacWrite document. 

HOW TO TRANSFER APPLICATION DATA 

The specific procedures used to transfer data from one Mac application to 
another vary according to the specific application and are subject to change in 
updated software releases. However, we'll discuss the initial procedures by 
application. 

Transferring Data From MacPian to MacChart 

The steps to transfer data from MacPlan to MacChart are as follows: 

• Select the columns in MacPlan that you want to transfer. 

• Copy the selected columns onto the Clipboard. 
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• Exit MacPlan and load MacChart. 

• Paste the contents of the Clipboard into a data series window, thereby 
establishing a link between the two. 

After a link has been established, the linked data in MacChart cannot be 
manually altered. When you Open the related MacChart file, MacChart will 
search the diskette looking for the MacPlan source file containing its data; 
accordingly, you should plan to have both files on the same diskette. 

Transferring Data to MacWrite 

The procedures to transfer data from MacPlan, MacChart, and MacPaint to 
MacWrite are simpler and do not create a permanent link. Accordingly, you can 
transfer data whenever you desire. 

To transfer data into MacWrite 

• Copy the data to be transferred onto the Clipboard and exit the source 
application. 

• Enter MacWrite and create an insertion point for the data to be transferred. 

• Paste the contents of the Clipboard into your MacWrite document. 

It probably wouldn't make much sense to transfer, for example, a large 
graph or painting into MacWrite if, once transferred, an entire page of a 
MacWrite document were to be consumed. Accordingly, after the transfer has 
been made, you can shrink a Mac Chart graph or MacPaint painting. To shrink 
them, click anywhere inside the graph or painting. A rectangle with three black 
size control boxes along its bottom edge will appear. 

• Drag the middle box up or down to adjust the vertical size. 

• Drag the left or right box in a horizontal direction to adjust the horizontal 
size. 

• Drag the left or right edge of the rectangle in a horizontal direction to 
relocate the insert. 

If you have already purchased a Mac, you have many hours of enjoyment 
ahead of you. If you are considering purchasing a Mac, the information con­
tained in Chapters 1 through 6 should help you make your decision. In either 
case, for a glimpse into Mac's future and the role you can play, read Chapter 7. 



Chapter 7 

COMING 
ATTRACTIONS 



I n Chapter 1 I indicated that it is impossible to predict whether planned 
enhancements will be forthcoming or whether, if forthcoming, they will be 

available on a timely basis. In that regard, purchase decisions should be made 
based on what is available today to avoid disappointments should enhance­
ments, be they software or hardware, not materialize. With these caveats in 
mind, we'll discuss coming attractions as it relates to additional software and 
the role you can play to influence software and hardware development. Our 
topics are 

• New software 

• How you can influence software development 

NEW SOFTWARE 

In Chapters 1 through 4 we discussed four general-purpose software packages: 
MacPlan, MacWrite, Mac Chart, and MacPaint. Based on the author's experi­
ence, observations at trade shows, and a review of other vendor systems, we 
should expect to see additional software for the Macintosh computer. Although 
no assurance can be given that the software discussed below will materialize, it 
seems reasonable that, if it does materialize, we should expect to see the 
following (note-some of the following software may be available at the time 
you read this book). 

Data management 

Noticeably absent is a mouse-oriented package to manipulate data as follows: 

• Data retrieval 

• Sorting 

• Search based upon selective criteria 

• User defined fields 

Programming languages 

Expect to see, as a minimum, a version of BASIC. BASIC is one of the most 
popular languages for end-users to develop simple programs that accomplish 
specific purpose tasks. Given the mouse and pull-down environment, it is likely 
that the version of BASIC will use these aids, thereby making programming 
easier for end-users. You can also expect to see a version of Pascal for the 
Macintosh. 
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Communications software 

Most microcomputers have communications software to enable users to trans­
fer files from one location to another (office to home, etc.) or access public data 
bases. Given that the Mac has two serial ports, it has the physical capacity to 
support a modem. There is a good possibility, then, that software will be 
developed to support communications. 

Provided that the Macintosh is successful in the marketplace, other 
software that probably would be developed includes: 

• Calendar functions 

• Electronic mail 

• Specific purpose templates 

• Tax planning and tax return calculations 

• Investment management 

• Games 

• Small business accounting functions 

If any of the software listed above or other software you desire is not 
available when you read this chapter, there is something you can do about it. 
Let's see what that is. 

HOW YOU CAN INFLUENCE SOFTWARE DEVELOPMENT 

There are two and only two reasons why commercial application software is 
developed: 

• In anticipation of market demand 

• In response to market demand 

The application software available when the Macintosh was introduced 
(and shortly thereafter) was developed in anticipation of market demand. Its 
developers undoubtedly did their homework in the market research area before 
committing substantial resources to software development. Nonetheless, those 
resources were committed in anticipation of the market demand that might 
exist when the Macintosh was introduced. 

The second reason that commercial software is developed is in response 
to market demand. It is this class of software that you and I can influence. If 
there is software that is not available that you would want, there is something 
you can do about it. Individually, our impact On market demand is negligible. 
Collectively, we, and others like us, represent the entire market demand curve. 
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If we let the appropriate parties know that there is a market for undeveloped 
software, we can influence its development and create our own coming attrac­
tions. So who are the appropriate parties and what can you do? A key player is, 
of course, Apple Computer, Inc., the creator of the computer. If you want to be 
heard and desire to influence software development for the Macintosh comput­
er, send a letter to, as a minimum, the parties listed below (tell others to do so as 
well). In addition, form a Macintosh Users Group and send letters from the user 
group: 

1. Steve Jobs, Chairman 
Apple Computer, Inc. 
20525 Mariani Avenue 
Cupertino, Ca 95014 

(408) 996-1010 

2. Vice President-Marketing 
Apple Computer, Inc. 
20525 Mariani Avenue 
Cupertino, Ca 95014 

3. Vice President-Marketing 
Microsoft Corporation 
10700 Northrup Way 
Bellevue, Wa 98004 

4. Editor 
Reston Computer Group 
Reston Publishing Co., Inc. 
11480 Sunset Hills Road 
Reston, Va 22090 

5. Your Apple dealer 

I sincerely hope that you have enjoyed this book. I (with a little help 
from MacMouse) certainly e[\joyed writing it for you. 
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MacPaint 
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