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Whom This 
Book Is For This book will be useful to you: 

No 
Programming or 
Electronics 

• If you own a Macintosh and one or more of the 
programs discussed and want practical instructions 
on doing particular tasks. 

• If you own a Macintosh but do not own the programs 
discussed and want to get a feel for what you can do 
with them. 

• If you are considering buying a Macintosh and want 
to learn what you can do with it and what working 
with it is like. 

This book explains only programs that you can buy and use 
without any knowledge of programming or electronics. It 
does not discuss programming and it does not explain how 
the Macintosh works electronically except for a few very 
simple matters helpful in using the applications. 

xi 
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Equipment 

What's 
Covered 

The Macintosh used in all the examples is the most common 
and least expensive version with 128K memory and one, 
internal disk drive. All the programs discussed in this book 
will run exactly as described on larger versions of the Mac. 
In some cases they will run a little faster, but the steps are 
exactly the same. 

Moving work from one diskette to another is simpler 
with two disk drives. Although the detailed instructions are 
always for one drive, different instructions for two drives 
are briefly discussed. 

Use of a hard disk drive varies from one brand to 
another, so you will have to follow the instructions that 
come with your hard disk. These instructions will affect 
only moving work from diskette to hard disk and vice versa 
and searching for files. 

Examples that involve printing assume you have an 
Apple Imagewriter printer, the standard printer that comes 
with the Mac. Other printers ar.e discussed briefly. 

A chapter on communications assumes you have a 
modem, a device that allows you to connect your Mac to 
other computers through telephone lines. 

All the programs discussed (except PFS:file) run on the 
Lisa exactly as described when you use MacWorks, a pro­
gram provided by Apple to make a Lisa work like a Mac. 

The first chapter shows you to how to run the Mac. If you 
are a new Mac owner, you should read it in addition to the 
Mac manual because it is more concise and because it dis­
cusses various programs that run on the Mac. 

The subsequent chapters offer precise instructions for 
several tasks and application programs. They cover every 
major area of Mac applications except games. I picked each 
task so that when you're finished you will have learned 
enough to start working in that application. 

• With MacWrite, you will prepare an illustrated 
resume and a letter to go to several recipients with 
different addresses; each letter will have a partly 
different content. 
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• With MacDraw, you will make a label for a cassette 
box and draw up plans for a kitchen. 

• With Microsoft Multiplan, you will prepare a simple 
profit forecast and set up the IRS's 1040 tax form on 
your Mac. 

• With Microsoft Chart you will prepare a variety of 
charts based on the Multiplan profit forecast. 

• With Microsoft Word, you will outline and design a 
college paper with running heads and footnotes; you 
will also prepare ran illustrated business brochure 
with a table from Multiplan. 

• With MacTerminal you will learn how to transmit 
files to and from an Apple II, how to browse and get 
information from The Source, and how to buy and 
sell stock with Trade*Plus. 

• With PC to Mac, you will learn how to transfer files to 
and from an IBM PC or similar machine. 

• With Augterm, you will see how to log into a large 
office automation system and send electronic mail. 

• With PFS:file and PFS:report, you will set up a simple 
file on a firm's suppliers, and extract lists that show 
the relation of the company to suppliers. 

• With Filevision, you will organize the same informa­
tion about suppliers on a US map and print mailing 
labels from the list. 

• With Factfinder, you will set up and search card-file­
like notes on the universe. 

With Macintosh, each program's format is similar and 
you can usually transfer material from one program to 
another ("software integration"). Macintosh: A Concise 
Guide to Applications Software explains Mac software 
integration and it also discusses three other programs you 
can use to support the programs discussed in 
depth: MacPaint can provide illustrations, including 
illustrations from commercial sources such as ClipArt, and 
it can be used as a tool to edit graphics from other applica­
tions. MegaMerge is used with MacWrite to make form 
letters, and ThinkTank 128 is used as a brain-storming and 
outlining tool with Microsoft Word. 
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Difference-from Manuals 

Most of the products discussed have excellent manuals 
(though some do not). This book differs from these manuals 
because it offers more practical uses for the software and 
because it is brief. Manuals are obliged to be complete and 
to provide information organized like a reference book, 
which this book does not. If you want to use any of the 
programs beyond the applications described here, you will 
need the manuals or other books dealing with the pro­
grams. 

Diminishing Detail 

The instructions at the beginning of each chapter are 
very detailed but the detail diminishes as you read along. 
Instructions in chapter 1 and in the chapter on Mac Write, a 
program that comes from Apple with the Macintosh, are 
very detailed. The other chapters assume you have used a 
Mac or have read these two chapters. 

A Minimum of jargon 

Macintosh: A Concise Guide to Applications Soft­
ware uses the language you think with. The computer must 
come to your mind, not the other way around. You will not 
find the word interface in this book. I do, however, intro­
duce a few technical terms where explaining around them 
would be unusually complex. 
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F(unning the Mac 

The Macintosh is a personal computer introduced by 
Apple in january 1984. It has been a phenomenal success in 
terms of sales; more Macs have been sold in the first year of 
it'sexistence than any other comparably priced computer. 
Moreover, within its price range, the Mac offers more com­
puting power, better screen resolution, and easier use than 
any other computer. From the viewpoint of the user, its 
chief claims to distinction are integrated software, the 
mouse, pull-down menus and style of presentation-what 
you see is what you get. Its chief drawbacks are that few 
programs have been written for it (compared to the Apple 
II, the IBM PC and similar machines), insufficient memory 
in the 128K model, limited storage on diskette, and no 
provision to install cards for adding functions. 

Historically, the Mac has a clear line of evolution, 
beginning with the development of mouse-pointing by the 
Augment group at SRI International, discussed in chapter 6, 
and continuing with the combination of the mouse with 
screen icons and pull-down menus by Xerox in the 70's, 
and sold in its powerful and expensive Star Computers. 
Apple continued the development with the more powerful 
and expensive Lisa computer. Mice and pull-down menus 
are now proliferating. 

The rest of this chapter explains the basics of using the 
Mac. The same material is covered in more detail in the 
Macintosh manual that comes with the computer, and in an 

1 
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The Power 
of Pointing 

excellent on-screen tutorial that follows a cassette that also 
comes with the Mac. Besides being briefer than the Mac 
manual, this chapter also strives to be comprehensible to 
someone who does not have a Mac at hand to play with. 

On the Macintosh you point to make things happen. You 
point at the things you want to change, and the menus to 
change them. You point by rolling something called a 
mouse. A mouse is a palm-sized, rounded rectangular box 
with a button on top, all attached to the Mac by a cord. In 
the belly of the mouse is a ball, which turns as you roll it. 
The turning of the ball is reported electrically to the com­
puter where a little mark on the screen, called the cursor, 
follows the motion of the mouse. You can roll the mouse 
on any surface that is not highly polished, such as glass. 

The headings of the menus are in a row across the top 
of the screen called the menu bar. To see the menus, roll the 
cursor to the heading and press the mouse button; the 
menus then appear. 

To use the menus, hold the mouse button down and 
roll the mouse until the cursor is in the menu item you 
want. Release the button and the item you have pointed to 
begins to execute (printing in the case of figure 1.1). Holding 
down the mouse button while moving the cursor is called 
dragging. 

In working with information on the screen, you will 
roll the mouse until the cursor reaches a certain point and 
press and release the mouse button, as in figure 1.2. In the 
case of text, a vertical line will appear that shows where 
text will appear when you type. As you type the text seems 
to come out of that line, called the insertion point. In the 
case of a dialog box, the item turns black to show that the 
next operation will happen there. 
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Figure 1.2 Pointing and clicking with the mouse 
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Using the 
Mouse 

The action of rolling the mouse to a place on the 
screen and pressing and releasing the button is called 
clicking. Figure 1. 7 shows the effect of clicking in a dialog 
box. You can also hold the mouse button down and drag 
the cursor over a portion of text to select several charac­
ters . 

' • File Edit Search 

10 
This Is a sample of text. 
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Co. Profit forcast : 

: :::o:: i 9.s:s ::::::::::: ::•:9.s:s:: ~: :::::::: i9:st 
$ 110.00 : $ 12 1. 00 : $ 133.1 0 

:::::: : :: ~2.~ :~:::::::::$:s ~: ;:?:~::~:: ~i. ~~~;:z~:. 
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Figure 1.3 Pointing and dragging with the Mouse 

These basic procedures vary depending on the pro­
gram running on the Mac. The cursor changes shape 
according to what you can do at any given moment. When 
you have to wait, the cursor changes to a wristwatch. And 
there are extensions, like pointing in the margin to move 
left or clicking three times to select a paragraph. 

Using the mouse is a physical activity like walking or swim­
ming (but not as hard to learn). You have to try it to feel it , 
and do it for a while to get used to it. The excellent Apple 
tutorial program does a good job at introducing the mouse. 
For most people it takes about an hour to get the hang of it 
and a few days to feel good about using it. Some people 
learn slower, some faster ; my friend who drew the portrait 
of Mary McCarthy in chapter 2 began to draw after less than 
an hour's use of the mouse. 

I've been using mice in one form or another for 15 
years because I worked on its development in the Augment 
group mentioned in Chapter 6. I have one piece of advice I 
have never seen in print. Put you wrist firmly on the desk or 
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table and move the mouse with your fingers . Most experi­
enced users hold the mouse this way without thinking 
about it. Some people seem to hold their whole arm in the 
air with just the mouse in their hand touching the desk . 
They thus end up trying to control the mouse with their 
shoulder, a powerful but unfine set of muscles. Putting 
your wrist on the table as a base lets you move the mouse 
with your wrist and finger muscles which are the most 
dexterous muscles. 

All Macintosh programs use the screen as the top of a desk . 
Below the menu bar on the desktop are "objects" that give 
you control over files and programs, and provide other 
information. Figure 1.4 shows a messy desktop. 

' a File Edit Ulew Special 

Figure 1.4 A messy desktop 

There are four kinds of objects on this desktop: 
windows, icons, folders , and boxes. Windows are the large 
square areas. The ones in this example hold icons and 
catalog the contents of diskettes. They can also hold text, 
art , numbers, or whatever else you are working with, and 
show the contents of documents . 

The borders of the Multiplan Master window in figure 
1.4 are shaded to show that it is the active window. This 
shading indicates that the window and its contents can be 
worked on. 
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The long rectangle in the lower left in this particular 
case is an alarm clock that shows the time. 

All the other objects on the desktop are icons. Icons 
are visible handles that allow you to start and stop, move 
and remove, the documents and applications programs you 
work with. You can move icons by putting the cursor on 
them, pressing down the mouse button and dragging them. 

In the preface I said that I would define jargon as the 
need arose. It has arisen. Two sets of words are used con­
fusingly in the Mac literature to refer to what you see on the 
desktop. The first three are program, application, and 
turnkey application. 

A program is the procedure a computer uses to do 
something. Programs include utilities most users never see, 
like the programs in the System Folder that keep things 
going. An application is a program that does something 
visibly useful. A turnkey application is a program that 
users can just turn on and use; it requires no knowledge of 
programming. All the programs discussed in this book are 
turnkey applications, and I use the word application as 
shorthand for turnkey application. 

The second group of jargon is file and document. File 
seems like a simple idea but it is hard to pin down. In terms 
of use, it is the material you have worked on that is stored in 
one place on your diskette. A somewhat more refined defi­
nition of file appears in chapter 8. 

Sometimes document is used as a synonym for file, 
and sometimes it has a more specific meaning. With 90% of 
the computers on earth, you start an application and then 
find a ftle for it to work on. The Mac works the other, 
handier way: you open a file and the Mac finds the right 
application. Sometimes document means this specific sort 
of file: a smart file that knows its own proper program. 

In figure 1.4, MacWrite, MacPaint, and Multiplan are 
icons for applications. If you click them twice, they will 
open out to a window; you can then use the program you 
have chosen. 

Mary's Portrait is a MacPaint document, as shown by 
the brush. Theron (partly concealed) and oa are MacWrite 
files, as shown by the image of text. The Multiplan files 
profit and 1040 (partly concealed) are shown by the image 
of a grid. Clicking twice on the icons of these files make the 
program open out to a window so you can use it. 
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Trash is a special icon. Dragging an icon into the trash 
removes it from the desktop. The Mac recycles the space on 
the diskette for future use. 

Folders are convenient places to put icons. When they 
are closed the icons are hidden within; when they are 
opened they turn into windows that let you see the icons 
they hold. The System Folder contains the icons of pro­
grams that run the system. Click twice on the folder to open 
it and see them. The Empty Folder is an endless supply of 
empty folders that can be used to store icons. 

Multiplan Master and wrt/pnt .cor on the upper right of 
the screen are the shadows of icons that remain when these 
windows, which catalog the contents of diskettes, are 
open. 

Windows 

At the margins of the windows are various pointing 
places that let you close it, move it around, and change its 
size (figure 1. 5). 

Figure 1.5 The anatomy of a window 

Windows are the workplace of almost all applications. 
Some applications, such as MacWrite, allow you to make a 
small window and leave other windows open on the 
desktop. Other applications, such as Microsoft Chart or 
Factfinder, display several windows that you use all at 
once. Applications such as MacPaint or ThinkTank use the 
whole screen and do not allow other windows to appear. 
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Dialog Boxes 

When you command a Macintosh application to do 
something (by pulling down a menu and selecting one of 
the items), the program may need more precise informa­
tion. In that case a dialog box will appear. Dialog boxes 
contain instructions, small squares or circles to check (by 
rolling the cursor inside and clicking the mouse button), 
and places for you to fill in text. For example, after you 
select Print (see figure 1.6), a printing dialog box will 
appear. 

Quality: 

Page Range: 

Copies: ~ 

Peper Feed: 

Figure 1.6 A typical Mac printing dialog box 

A dialog box can also contain a window with a scroll 
bar that allows you to scroll through a long list. Figure 1. 7 is 
the dialog box that most often comes up when you are 
using an application and want to open another document. 
In this case the user was employing Mac Write. The window 
displays a list of the Mac Write documents on the desktop. 
The user has moved the elevator to the middle of the list 
and has selected Mary McCarthy by clicking on it. When he 
or she clicks on the Open button, the Mary McCarthy docu­
ment will fill the window. 

forbltletters 10 
Open MecWrite o ... :lin 

old mary mea.:~ I! 
osc ""' 
Pieter !ll!il 
ProfSystems ~~ 
Reps Addresses 

Eject 

Cancel 

Figure 1. 7 A dialog box with scroll bar 
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The Standard Menus 

Three menus appear on the menu bar of all Macintosh 
applications: the Apple menu (shown by a silhouette of an 
apple), File, and Edit (figure 1.8). 

When you pull down a menu you see a list of com­
mands. Selecting a command causes that command to be 
executed. The commands appear in black or gray, and they 
may have ellipsis points (dots) after them (figure 1.9). 

Saue 
SaueRs ... 
Page Setup 
Print ... -.--. 
Quit '----

Figure 1.9 What you see on menus 

Show Clipboard 

If a command is gray you can't select it. Gray com­
mands appear to remind you that you may be able to use 
them in some other situation in that application. In figure 
1.9, for example, the user had no text to edit, and the Can't 
Undo command is therefore gray. 

Commands may change in other ways than going gray. 
For example, Undo will alternate with Can't Undo. 

Ellipsis points after a command show that the name of 
the command does not completely describe what it does; a 
dialog box will appear after you select it. 

Some commands that lead through dialog boxes lack 
ellipsis points, for example Page Setup, which does not 
show ellipsis points because there is no room for them. 

To the right of some commands you will see the sym­
bol of the command key, which is to the left of the space 
bar, and another character. The characters mean you can 
use that command by holding down the command key and 
pressing the key for the character next to it. (If you have 
used another computer you will recognize the similarity 
between the command key and the CONTROL key on most 
computers.) 

How experienced users employ commands from the 
keyboard depends on what they are used to and whether 
they are good typists. I will not discuss them in more detail 
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File Edit Ulew 
out the Finder ..• 

Scrapbook 
Alarm Clock 
Note Pad 
Calculator 
Key Caps 
Control Panel 
Puzzle 

Flgure1.10 The Apple menu 

Note Pad 

Keep up to eight pages of notes 
in the N,ote Pad. Click on the 
dog-ear.lto turn to the next 
following page. Click in the 
lower left corner to turn to the 
next previous page I 

Figure 1.12 The Notepad 

in this book, because you always learn more by pulling 
down the menu. As an experienced user you will find your 
own style of using commands from the keyboard . 

The Apple Menu The Apple menu (see figure 1.10) varies 
little from application to application. It lets you use some 
conveniences provided by Apple in the System Folder you 
saw on the screen in figure 1.4. 

About the ... When you select this item, information 
about the current application will appear on the screen. 

The Scrapbook. You can copy drawings or text into 
the scrapbook. You cannot edit material in the scrapbook, 
but you can copy it into other documents. The Scrapbook is 
part of the System Folder, so if you change the diskette in 
your internal disk drive, you change to another Scrapbook. 
To keep the same Scrapbook, you have to copy the file onto 
the new diskette. 

10 Scrapbook 

Uu tht Scrapbook toston o varitt"' of t•JC-t stttctlons and pictlltl which 
moy bt tronsftf"rtd bttvHn applkotionJ. rrom tht Edit rntn~.~, CYt or~ 
on it.m from tM Scrapbook, tMn Post• 1'\to on opplication docuntnt . 

It 

~ 

> 

IQI *''· r'\tj I .,. 121 
~ TEXT 

Figure 1.11 The Scrapbook 

The Notepad. You can copy or write text in the 
Notepad. You can then copy it into other applications. The 
Macintosh editing tools Copy, Cut, and Paste are available. 
Like the Scrapbook, the Notepad is part of the System 
Folder; if you change the diskette in your internal disk 
drive, you change to another Notepad unless you copy the 
file to the new diskette . 

The Alarm Clock. The Alarm Clock appears in figure 
1.4. A battery keeps time when the Mac is turned off. Some 
applications let you leave the clock on the desktop to show 
the time, others do not. You can set the clock to beep or 
flash on the menu bar at a certain time. 



Flgure1.13 The Calculator 

Figure 1.15 The Puzzle 
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The Calculator works like a pocket calculator. Press 
the buttons by clicking on them with the cursor. You can 
copy the result and paste it into applications . 

The Control Panel lets you control how some things 
work on the Macintosh. On the center panel, the pressing 
finger sets how long you hold down a key before it begins 
to repeat the character. The tortoise and the hare control 
how fast the character repeats once it has begun. 0 means 
no repeating. 

Figure 1.14 The Control Panel 

Keycaps. You can type many characters that are not 
on the standard keyboard on the Macintosh (see figure 
1.27). What characters you can type depends on the type­
face you are using. When you select Keycaps, a keyboard 
appears on the screen. You see the special characters by 
holding down the Option key. 

The Puzzle works just like the plastic versions you 
have probably seen. You move the elements by dragging 
them with the cursor. It 's good practice using the mouse. 

The File Menu The File menu controls the opening, clos­
ing, saving and printing of files . In some applications other 
items also appear. Figure 1.9 shows the File menu as it 
appears when you are working in MacWrite. 

Save stores the material now in the memory of the 
Mac onto the diskette. 

Save As ... stores the current document on the diskette 
in a file with a new name. 

Close lets you stop working on a current file. If you 
have made any change in it the system will give you a 
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chance to save it through a dialog box. Selecting Close on 
the File menu is exactly the same as clicking the close box 
on a window. 

Quit closes the file you are working on and the 
application program associated with it. Quit returns you to 
the desktop. 

Print calls a dialog box. In most cases you can control 
the number of copies you want, what page you want 
printed, and the quality of printing (see figure 1.6). Some 
applications allow you to control other matters, such as the 
width of mailing labels. If you are using typewriterlike 
printers the dialog box will be slightly different. 

People with no computer experience will find Mac 
printing easy to understand: by and large what the printer 
produces is what you see on the screen. People who have 
been working with computers are generally not used to 
that, so let me explain it. 

Characters or drawings on the screen of the Macintosh 
are made up of tiny dots (pixels) like the tiny dots in a 
newspaper photograph. The printing mechanism of the 
standard Macintosh printer, the Apple Imagewriter, is a 
bundle of tiny wires. A hammer strikes single wires against 
both the ribbon and the paper one at a time. In Standard 
printing quality, one wire dot prints for every black pixel 
on the screen. In High quality a program interpolates extra 
dots to smooth the effect. High quality takes longer than 
Standard printers. 

Draft quality prints only text. It uses characters that 
come in the printer's built-in memory. Draft quality is plain 
but clear and prints fast. 

Page Setup calls a dialog box that lets you adjust the 
printer to the size and the shape of the paper you are using 
and whether you want the image to come out on the paper 
upright or sideways. 

US Letter means 8 1/2 by 11 inches. A4 and Interna­
tional Fanfold are common sizes outside the United States. 
Tall means upright, the way you normally expect a letter to 
be printed. Wide means the screen image is printed side-

Peper: ® US letter 
ous legal 

Orlentetlon: ®Tell 

QR4letter ~ 
0 lntemetlonal Fanfold 
0 Tell Adjusted 0 Wide ( cancel ) 

Figure 1.16 The Page Setup dialog box 
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Figure 1.17 The File menu on the 
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U do XZ 

Cut XH 
Copy XC 
Paste XU 
Clear 

Show Clipboard 

Figure 1.19 A typical Macintosh 
Edit menu 
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ways. Wide is very useful for wide spreadsheets and is used 
to print the brochure in chapter 7. Tall Adjusted is for 
printing graphics; it insures that vertical printing does not 
distort the shape of a picture. 

Figure 1.17 shows the File menu when no application 
is open. The dark icon beside the menu shows that a Mac­
Write file has been selected. 

Duplicate will duplicate a selected file. 
Put Back will drag any icons belonging to the diskette 

back from the gray area of the desktop back to the window. 
Eject will eject the diskette. 
Get Info calls a dialog box that provides useful infor­

mation about the file, gives you a chance to lock or unlock 
it, and gives you a place to note information about it. 

Vha\ ICind of Applica\ion 
You Ua• to York With It 

Information about Theron 8/25 

Theron 8/25 

Kind: MatWrtte document 
Size: 5133 bytes, attounts for 6K on disk 

Th• ncm• of th• Diak~JU• Where: wrtlpnt.tor, Internal drtue 
A Which Driw Created: Frtday, August 24, 1984 at 12:09 PM 

Modified: Monday, Nouember 12, 1984 at 1 0:09 AM 

OLotked 

IR letter to the editor 

Figure 1.18 The file information dialog box 

The Edit Menu Like the File menu, the Edit menu varies 
considerably from application to application, but certain 
features almost always appear. 

The main function of the Edit menu is to let you 
remove, copy, and move things. When material is cut or 
copied, the system transfers it to a holding place called the 
Clipboard. The Clipboard keeps only the last item cut or 
copied. The Show Clipboard command will display the 
contents of the Clipboard. 

Figure I. 20 shows how text is edited and shows the 
contents of the Clipboard at each step. You select the 
material you want to cut by dragging the cursor over it. Pull 
down the Edit menu and select the Cut command. The 
material disappears from the text and appears on the Clip­
board. Select where the material is to appear. The Paste 
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an example . I~ Clipboard 

10 10~ Clipboard 

This is an example. only 

10~ Clipboard 

This is an examplelonlyl. only 

Figure 1.20 The Cut and Paste procedure with the contents of the Clipboard at 
each step 

command in the Edit menu puts it in place. The material is 
still on the Clipboard and you can copy it to as many 
locations as you want. 

The steps are the same when you use Copy instead of 
Cut; with Copy, though , the original text is not disturbed. 

These operations are central to all work on the Macin­
tosh . You do them a hundred times a day if you are a regular 
user, and they become second nature. 

The Clear command removes w hat you have selected 
without putting it on the Clipboard. The text immediately 
disappears and cannot be retrieved. 

Show Clipboard lets you see the clipboard and what 
is stored there. 
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Starting the Mac 

When you insert a diskette into a Macintosh and turn it 
on, you will see either a cartoon Macintosh with a happy 
face or one with a sad face. The sad face means the machine 
can't read the diskette for one of three reasons: 

• The diskette has never been used before. 

• The diskette is formatted for some other machine. 
The Apple Lisa, Hewlett-Packard personal com­
puters, and some other computers use diskettes that 
look like Macintosh diskettes but the Mac can't read 
their format. 

• The diskette is a Macintosh diskette but the data has 
been ruined-that is why you make backups! 

After the happy face, a welcome message from Macin­
tosh appears and then either the icon of the diskette on a 
gray background or a window containing the diskette's 
catalog of files appears. If only the icon appears, click twice 
on it and the window with the catalog will appear. 

Figure 1.21 shows the windows of two diskettes on the 
desktop, wrt/pnt.cor and Multiplan Master. When you 
open the window for a diskette, it leaves a shadow of its 
icon. The shadow is dark if the icon is selected and light if it 
is not. The window of a diskette present in a disk drive 
shows move bars and the icons are black lines on white; the 
window of a diskette absent from any drive lacks move bars 
and the icons are gray. 

You will find three items in these windows: programs, 
documents (or files), and folders. 

Program icons are generally diamond shaped, e.g., 
Multiplan in figure 1.21, whereas documents (files) are usu­
ally vertical rectangles, e.g., profit in figure 1.21. Software 
developers eager to give their product identity play loosely 
with these shapes. 
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!0- System Folder -
6 it•ms 200K in fold•r 281C ll¥1ifld 

~ ~ 
~~ F~ ~19~ 

Scr~book Fl1 Not• P~ Filt CHpbolrd Fit. K> , 
Q riW;1i~!l:li: ::fn!:!!!!!:m:il!~~iUnmH~Hili!HHiil!l!:H .,1• I C: 

Figure1.22 A typical System 
Folder that is open 

Figure 1.21 The desktop showing icon handling 

Open a document by clicking on it twice (a double 
click). The appropriate application will be fetched and a 
window will open so you can start work. Clicking twice on 
an application icon causes a window to open containing an 
empty document . 

Folders help keep order on a busy desktop. When you 
open a folder it forms a window. You can move documents 
or applications into the folder's window by dragging them 
w ith the cursor. When you close the folder , the documents 
or programs within will remain hidden until you open the 
folder again. Figure 1.22 shows a typical System Folder 
opened up. 

Some Other Views 

Two other menus are present when the desktop is 
inhabited by windows that show the catalog of diskettes 
rather than applications: the Special menu and the View 
menu. 

The Special menu will rearrange the icons more 
neatly (I wish I had such a command on my wooden 
desktop), delete the contents of the trash, and change what­
ever disk is in the disk drive into a blank diskette formatted 
for the Macintosh. Be careful abo ut that one! 
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O.s\rogs Icons In Tra•h 

Figure 1.23 The Special menu 

A word about the trash icon . The trash container is an 
icon like other icons. You can open it and see the contents. 
When you drag another icon into the trash it will remain 
there and you can open the trash window and drag it o ut if 
you change your mind. But an icon 's life is hanging by a 
thread when it is in trash . Not only will the Empty Trash 
command destroy it, but several automatic processes will 
gobble it up as well when space is needed on the diskette. 

The View menu changes the window that catalog a 
diskette into a list arranged alphabetically, by date, by size , 
or by kind of program or file . Figure 1.25 shows the list by 
date for the wrt/pnt.cor diskette. 

When icons are arranged as a list you can open them by 
clicking on their line in the list, but you cannot move them. 

wrtlpnt.cor 
Sin ·- ICW LllS~Illd 

6K n. • .-- 8/23 M~'Wdtt~t Mon*Hov 12, 1964 Q: 
3K f"w BU LeU H' ~'Wrttt doci.Mntnt Yod,Oct10 , 198< 

8K U s• MM!Yri tt docurntnt rrt, Sos> 1 ~ . 1-

8K Rt.C H.acYritt documtnt Sun, Jw9 26, 198< 

6K BM-..... s-. MacVrttt~t Yod, ""'122. 198< 

'JI( u Hlc'w'r'itt documtnt Tut , ""'ll~ , l98< 

8K ICPfA H~eVritt doeuntnt Frt , .N120, 198< 

200IC S.•t-fo!Mr fo- Yod, .N111 , 198< 

OK ~ltfo!Mr fo- Yod,.NI\20,198< 

~ tucVrlt• f!PPlic-oiHon Yod,Mo\12,198< 

61K HH Pat.t tpplic-o~tion Yod,Mo\1 2. 198< lo: 
0 1 I( lt;ll 

Figure 1.25 A view of the contents of a diskette by date 

Copying Icons and The ir Content 

You copy or move programs and files by copying the 
icons and then moving the copy to the new location . A 
Macintosh with one disk drive leaves you spending a lot of 
time pushing and pulling diskettes in and out of the disk 
drive in order to move documents or programs from one 
diskette to another. 
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STEP1 

STEP2 

STEP3 

STEP4 

STEPS 

STEPS 

STEP7 

Why copy a program onto another diskette? One rea­
son is to reduce wear on the diskette it came on. Another is 
to back up documents since diskettes do fail. (In the end, 
they all fail.) 

This is the procedure for copying: 

Insert the source diskette and turn on the Mac. 

If the window with the diskette catalog does not appear, 
double click on the icon. 

Click on the shadow image of the diskette icon to select the 
icon. 

Pull down the File menu and select Eject. The Macintosh 
will eject the diskette and the icons in the window will 
become gray to show that the system remembers them but 
that they are not present in the disk drive. 

Insert the destination for the copy. Adjust the windows 
until you can see the icon you want to copy. 

Select the icon to be copied and drag it toward an open 
space on the second window. A ghost image will go with 
the motion of the cursor. 

Figure 1.26 Copying the Multiplan document "Profit" from Multiplan Master to 
wrt/pnt.cor 

When you have the ghost image in place, release the mouse 
button. A dialog box will appear, instructing you to switch 
diskettes. At this point the Mac is copying all or part of the 
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file into its memory, changing diskettes, writing from 
memory onto the second diskette, asking for the first back, 
and so on. The copying process can take several diskette 
shuffles, depending on the size of the file and the size of 
your Mac's memory. 

In the end your source diskette will be in the disk drive 
and the second diskette will be in your hand with the new 
file on it. 

Note that this process copies the icon. If you want to 
remove it from the source diskette, you must trash it sepa­
rately. 

A program comes with the Mac system diskette that 
allows you to copy an entire diskette with only a few 
swaps. The copy program uses the special part of the 
machine's memory that is normally used for display. On 
the screen you see a pattern of black-and-white dots: that is 
what your bits look like as bits rather than as something a 
program recognizes and molds for you. The program is 
useful only for copying whole diskettes, however. 

If you have two disk drives, the process is similar but 
requires no disk shuffling. Both windows will show light 
icons because they are both present in drives. You drag the 
icon you want to copy from one to the other. 

One of the most intriguing features of the Macintosh is how 
it lets you use different typefaces on the screen and see 
them in print if you use the Imagewriter printer. The vari­
ety of faces and fonts let you design an attractive page that 
distinguishes and emphasizes different parts of the text for 
clarity all in your own style. 

Before we go further I need to define two more pieces 
of jargon, not computer jargon but typesetting jargon. Mac­
intosh gives you the power to almost be your own typeset­
ter, so I will offer you a chance to get acquainted with that 
language. A typeface is a set of characters, letters, numbers, 
punctuation marks, and other special characters, that share 
a common design. On the Macintosh, Toronto is the name 
of one typeface, Geneva another. All the sizes and styles 
(bold, underlined, italic, etc.) of Toronto are part of the 
Toronto typeface. A font is the shape and size of a face. 
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Character size is measured in points (see below), and 18-
point Toronto is one type font and 9-point Toronto is 
another. Both belong to the Toronto face. Mac Menus and 
documentation are inconsistent in the use of these terms. 

Many new Mac users write letters like the following. 

April 1 1985 

Dear Larry, 

I'm writing you on my new macintosh, which has a lot of 
fancy type effetcs. For example it has a lot of type faces named 
otter cities: 

Baa fraa.U.O lit hal hill' JJQtlae.) 
Los Angeles 
~~l.~ (Cairo) 
Chicago 
Geneva 
New York (looks like typing but has proportional spacing) 
nonaco (aonspaced) 
11aaK:B 
iodn 
ltheu ('Wbat cnald the claslipa af tba ParthaiiD tiUU7) 

Greek, Hebrew. Russian, and Japanese alphabets are available 
and others are on the way. 

Characters can all be big or small, superscript or subscript, bold. 

Italic, under/ined, OUtline, or lhaciOV. .JJC 

COIDitiDG,IODI. 

You can put accents on all the vowels: a, e, 1, o, u, a, o. u etc. 

many unusual characters are available if you hold down the 
Opt I on key. These are the ones in Toronto: ..f i '" £. ¢ § q • g a 
re <E ® • ¥ 0 eJ " " (Yes, real quotation marks for dialogue 
writers!). I « » a A B ® ... <B E. c; <; fi. 

Dirk 

Figure 1.27 A letter showing Mac typefaces 

The letter shows the faces currently available from 
Apple; a small industry has sprung up that designs fonts and 
sells them. They include other languages, such as Russian, 
Greek, Hebrew, andjapanese. 



Figure 1.28 A typical menu for 
selecting fonts 

Running the Mac 21 

Most applications can use any face you may acquire. 
Others do not; they include spreadsheets that require 
monospaced faces to fit their grid structure, and applica­
tions that make your Mac look like another computer termi­
nal. 

If you are using a letter quality printer (where a char­
acter key similar to a typewriter key strikes the paper 
instead of little wires}, you will not be able to print the 
different fonts you see, though you can get some of the 
effects such as boldface and underlining, depending on the 
printer. If you use a dot matrix printer other than the 
Imagewriter, what you get will depend on the program that 
comes with the printer. 

You change fonts and sizes with menus, which vary 
from application to application. 

The Macintosh goes along with the printing industry 
in measuring character size in points. A point is 1/72 of an 
inch. Thus, in a 9-point font the tallest characters are 9/72 
or 1/8 inch high. 72-point characters, available in some 
contexts on the Mac, are one inch high. 

The Macintosh stores only certain typeface sizes in 
memory and if you ask for an in-between size it calculates 
how to make it. As a result, the in-between sizes tend to 
look less finished than the stored sizes. To let you see how 
the calculated font will look, the stored sizes appear on 
menus in outline, whereas the calculated sizes are solid. 

Choosing Fonts 

These attractive and expressive fonts come at a serious 
cost of space. Fonts reside in the System file in the System 
Folder. A font may take up to 6K of the roughly 400K of 
space on your diskette. If you carry four fonts for a given 
face, they will use nearly 10% of the space on your diskette. 
To allow you to make choices about what fonts you want to 
use and how much space you want to allocate to fonts, 
Apple has provided a program called Font Mover. Font 
Mover can remove fonts from your System Folder, or copy 
them into a special document which you can then copy to 
other diskettes. Font Mover comes on the Macintosh's sys­
tem diskette! Here is the procedure for using Font Mover to 
construct a file with some fonts in it that can be copied to 
another diskette. On my own system, I keep a special 
diskette called Fonts, where I collect interesting typefaces. 
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STEP1 

STEP2 

Start with a diskette that has a System Folder and Font 
Mover on it. If your diskette lacks either of these files, move 
them on to it from another diskette by the disk-copying 
method described earlier. 

Click twice on the Font Mover icon to start it. The Font 
Mover dialog box will appear. Click on a font of your 
choice. Some information and a sample of the font will 
appear in the dialog box. 

Font Mouer 

In System Ole In Fonts file 
Rthens-18 ~ ( Help I ~ 
Calro-18 
•Chlca~-12 I ( £opy I 
•&ene -9 ~ ~ t 
&eneua-10 ~' ( Remout.' I 
&eneua-14 ~ •Monaco- 9 ( Quit I tQ 
Name: 
Point size: 
Disk Space: 

• reserued for system use 

Font Mouer 

In System file In Fonts file 
Rthens-18 10 Help 

•Chlcago-12 I •&eneua- 9 : ~.: 
Geneua-10 m~ &eneua-14 ~· 

•Monaco- 9 

~ »Copy» 

Remoue 

Qult I(; 
Name: Cairo 
Point size: 18 r81P 0 ~o~ 
Olsk Space: 5840 bytes 

• reserued for system use 

Figure 1.29 Selecting a font to move or remove in the Font Mover dialog box 



STEP3 

STEP4 

Figure 1.30 The Font Mover 
application and a 
Fonts file 

Software 
Integration 
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Check copy and the font will appear on the Fonts file side. 
Continue selecting until you have the fonts you want. 
Remember, you can see the rest of the list by clicking in the 
scroll bar. 

Check Quit. The system will take a while to actually move 
the fonts. When that task is done the application will close 
and a Fonts file will be visible on the desktop. 

Remember that font means both the shape and the size 
of the letters. If you plan to use 14-point Toronto often, 
include that font; if you plan to use it rarely, include only 
12-point and let the system calculate 14 from 12 when you 
need it. 

To move the fonts to a System Folder on another 
diskette, move the Fonts file and the Font Mover to the 
second diskette. Then start up the Font Mover application 
again and copy the fonts you want from the Fonts file to the 
System file. To remove fonts, click on them and check 
remove. 

It was only a few years ago when, if you wanted to stop 
using one application and use another, you had to turn off 
the computer. Information on one application could not be 
used on another. For example, if you had your budget 
forecast on a spreadsheet you could not put it into the text 
of a report or turn it into a chart. Moreover, commands 
were not the same. I worked with one program where 
holding down the control key and typing C meant put in 
text; the same sequence with another program meant stop 
the program. I made some bad mistakes. 

The trend now is toward software integration. Inte­
gration means that you can use a command to move from 
one program to another, that commands tend to work in 
the same way, and that you can transfer information from 
one application to another. Programs have been integrated 
in various ways with varing success, e.g., Appleworks on 
the Apple II, and Symphony, Framework, and Topview on 
IBM type machines. 

Apple has insured a substantial degree of software 
integration on the Macintosh by building some features into 
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FatMacs 

the computer and by issuing standards for those writing 
applications. 

The Mac insures that you never have to turn off the 
machine to reach another application. Usually you just 
close the window you are using and open another. Com­
mands tend to work the same way, as you have learned in 
the sections on editing and file handling above. And, within 
limits, you can move things from one application to 
another through the Scrapbook and Clipboard. For exam­
ple, you can move material from most spreadsheets into 
text, you can put graphics from graphic applications into 
most text applications, and you can sometimes generate 
pictures from numbers. Applications like spelling checkers, 
or the MegaMerge form letter generator discussed in chap­
ter 2, don't really do anything by themselves; they only 
work when integrated with other applications. Some soft­
ware developers like Lotus or Microsoft offer programs 
with a higher degree of integration than do other software 
developers. 

Integration is a step in making applications less like 
specialized tools and more like a fully equipped workshop. 
In the subject's covered below I emphasize the Macintosh's 
flexibility in this regard. 

This book uses a Macintosh with 128K internal memory. 
The 128K Mac is the cheapest and most common form of 
the machine and most programs for the Macintosh run on 
it. Apple also makes a Mac with 512K of memory, known 
colloquially as the Fat Mac. If you own a regular Mac it is 
possible to pay your Dealer to add parts and change it to a 
Fat Mac .. The difference is currently about one-third the 
price of the Mac but the upgrade will probably become less 
expensive in time. 

For some of the programs discussed in this book the 
large Mac offers the advantage of running them faster. The 
programs run faster because more information is stored in 
the machine's memory, allowing the Mac to get at it faster 
than on the diskette. In some cases the difference is that the 
program itself is stored in memory. For example, a program 
like Microsoft Word is too large to fit in the memory of the 
regular Mac. The designers wrote it to move the most-used 
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parts of the program into the regular Mac's memory; addi­
tional information is then read off the diskette, which 
occasions a noticeable delay. In the Fat Mac more of the 
program is in memory and such delays are fewer. Likewise, 
programs that work on a large file, such as a data base 
program searching through thousands of records, may 
store more of the records in memory on a 512K Mac and 
reduce delays while reading the disk. For example, Fact­
finder, discussed in the chapter on data bases, runs two to 
three times faster if you have more than a few "factsheets" 
to search. Not all programs will take advantage ot the larger 
memory however; it depends on the foresight of the pro­
grammers. Conversely, programs also exist that will run 
only on the larger machines. Two notable examples are 
ThinkTank 512 and)azz. 

ThinkTank is a text-handling system that gives you the 
power to control text by creating and easily rearranging an 
outline. The version for the 128K Mac discussed in this 
book allows you only to use an outline. ThinkTank 512 
allows you to put paragraphs of text under the outline 
headings. It also gives you some basic word-processing 
tools to edit and print text, automatic section numbering, 
page formatting, and the like. It is an excellent tool if you 
are preparing a document, such as a report, that follows an 
outline format. 

jazz is a packaged group of applications. It includes a 
word processor, a spreadsheet, a data base, business graph­
ics, and a terminal emulator. It requires both a 512K Mac 
and a second disk drive, which makes the cost of using)azz, 
including the cost of the program, about $2,000 more than 
the cost of using the programs described in detail in this 
book. None of the individual items in the jazz package are 
particularly superior by themselves to the equivalent pro­
grams discussed in this book, but jazz has the attractive 
advantage of carrying integration further than any software 
available for the 128K Mac. For example, you can run all the 
programs at once in separate windows. Moreover, you can 
change data in several files at once by only changing it in 
one file. Thus, if you have a spreadsheet open and change 
numbers that also appear in a report you're putting 
together on the word processor, the next time you open the 
word processor you will find the new numbers. 
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Future 
Developments 

The Macintosh is a highly successful product and we can 
expect to see it grow and change. Apple asserts its commit­
ment to what is called ''upward compatibility.'' That 
means that all the applications discussed in this book 
should run on all future versions of the Macintosh. The 
evolution of the Apple II family is evidence of Apple's good 
record on this promise. 

Improved versions of the programs discussed will 
probably appear. Again, most of the companies, such as 
Microsoft, are also committed to upward compatibility, 
which means that the changes will be additional functions 
(or improvements in efficiency) that will not change what 
is in the following chapters. Other companies may not be 
so careful about compatibility. 

What improvements might we expect? 

• More powerful Macs. Eventually we will see Macs 
with larger memories and larger screens, e.g., screens 
the size of the present Lisa screens. This change will 
not affect the steps in the examples in this book, but it 
will make them happen faster. Moreover, in some 
cases the applications in this book will do things they 
could not do before, such as large spreadsheets. 

• Smaller Macs. Physically smaller to fit in your lap, 
but running the same programs. 

• More hard disk drives. Using hard disk drives will 
not affect the applications in this book except, again, 
to make them work faster and, in the case of pro­
grams such as data bases, allow them to do the same 
things to more data. Hard disks may require some­
what different start-up procedures and they will 
affect how you handle files, sometimes in rather 
unpredictable ways. Hard disks with 100 times the 
storage capacity of a Mac diskette will be available 
before the end of the useful life of this book. Hard 
disks built into the Mac are also a possibility. 

• Double-sided disk drives. This is an inexpensive 
alternative to hard disks. The present Mac diskettes 
hold 400K of text using only one side of the diskette. 
Because the system and an application usually use 
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200-300K of that space, room is left for, say, only 
about 100 pages of text. The same machine with two 
disk drives using double-sided diskettes with 400K 
on each side has up to I600K of space, enough for 
most personal computer purposes. 

• Musical Macs. The Macintosh has excellent built-in 
musical abilities. It can sound in four-part harmony. 
No program that uses the Mac's musical abilities well 
was available at the time I wrote this book, but they 
are on the near horizon. By the time you read this you 
will probably be able to play the keyboard like a 
synthesizer, see the notes appear on the screen, and 
print the music. Look forward to the Music Composi­
tion System from Electronic Arts. 

• Talking Macs. The Mac's sound control will allow 
the proper program make the Mac "speak." It is not 
clear to me how useful this is outside of games and 
some education applications, but we will be hearing 
from the Mac. 

• Color Macs. When color Macs become available the 
big problem will be software. How to control the 
color? It will not affect text and spreadsheet pro­
grams very much; having different parts of a 
spreadsheet in different colors will improve clarity 
and emphasis, but it will not change the program 
fundamentally. Graphic programs, on the other 
hand, have a challenge in using color. If you look at 
the MacDraw screen in chapter 3, for example, where 
would you put the red, blue, and mix commands? 
With color Macs will come color printers. 

• Laser printers. The standard Mac printer, the 
Imagewriter, allows you to print graphics and fonts 
as you see them on the screen. Letter quality printers 
for the Mac do not print full graphics or the fonts on 
the screen and are usually three to four times the 
price of the Imagewriter. They offer the more formal 
appearance of typed text, and they are more durable. 
Laser printers work like the Imagewriter by making 
tiny dots on the paper, but the dots are smaller and 
more numerous. As a result the characters are more 
sculptured and have sharper edges. Laser printers 
will draw lines as sharp as the illustrations in this 
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book, which were typeset directly from MacPaint 
files. Large, expensive laser printers have been 
around for some time, but desktop models near the 
price of a letter quality printers should appear soon. 

• Future programs. In the future, programs will take 
more advantage of graphics, sound, and color. More 
programs will be written that require 5 12K more 
memory. What will they be like? Some predictions 
are possible. Many specialized programs will appear. 
The first programs to appear have been general pur­
pose, like spreadsheets and word processors, but as 
time passes people will have occasion to write more 
for particular purposes. Architectural drawing and 
other design aids are an obvious direction for the 
Mac. We will see accounting systems both for busi­
ness and the home, specialized data base and word 
processing systems for law and medical offices, 
games of all kinds, computer-aided instruction, and 
so on. A friend is currently writing a program for 
veterinarians that will display the electrocardiagram 
of dogs on the screen of the Mac. 

We will see more programs using artificial intel­
ligence. Roughly, artificial intelligence means programs 
that are able to make educated guesses. They will make 
possible smarter spelling checkers, limited punctuation 
and grammar checkers, more powerful data base systems, 
and expert systems where users can tap the insights of 
people knowledgeable in esoteric procedures. 

But not all changes can be predicted. Ten years ago no 
one had thought of electronic spreadsheets. Five years ago 
no one had thought programs like Factfinder or ThinkTank 
would run on personal computers. It is what has not been 
predicted that is the most important. 
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MaCWrite 

When you purchase a Macintosh, Apple includes Mac­
Write, a good word processing system for small docu­
ments. Compared to other word processing systems for 
computers in this price range, it is easy to learn how to use, 
has a variety of type styles are available, you can control the 
appearance of the characters and illustrations, and it can be 
integrated with other programs. MacWrites disadvantages 
are limited page formatting, limited kinds of selections, and 
limited ways of dealing with text currently beyond the 
screen. 

Mac Write makes full use of typefaces in a range of sizes 
to suit the way you want to present your ideas and to 
provide emphasis, clear organization, and an interesting 
appearance. You can copy illustrations from MacDraw, 
MacPaint, and some other Macintosh graphic programs to 
illustrate your text. The different fonts and illustrations 
you see on the screen are printed exactly as they appear on 
the Apple Imagewriter printer! You can also copy what 
appears on the screen from many other Mac programs, such 
as the spreadsheet results, and use it in MacWrite. It is 
possible to integrate Mac Write into several data base sys­
tems to correct their output, or produce in a single opera­
tion a series of form letters. 

This chapter shows you how to use Mac Write to write 
a simple letter. You will then use another program, Mega­
Mergens by MegahausTM, to generate a series of similar but 
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A Letter to 
Your 
Representative 

STEP1 

STEP2 

STEP3 

Figure 2.1 Selecting the MacWrite 
application 

STEP4 

modified letters. This chapter also shows you how to set up 
a resume, using various type sizes and styles, and how to 
copy an illustration into the resume from Mac Draw. 

In this section you will learn how to put text in a MacWrite 
file, correct errors, make small changes, and print a docu­
ment. 

Writing a Letter 

If your Macintosh is on, eject the current diskette and turn 
it off. Insert any diskette that includes the System Folder 
and Mac Write, and turn the machine on. 

You can change diskettes without turning off the 
machine, but turning off the Mac and starting over insures 
uniformity between these instructions and your Mac. 
These instructions also assume all formatting in MacWrite 
is still preset. You can find a discussion of reformatting in 
the Mac Write manual. 

If only the diskette icon appears, roll the mouse until the 
pointer touches it, then press and release the button on the 
mouse twice (double click) to see the catalog. 

Double click on the Mac Write icon. 
A MacWrite window will appear (see figure 2.2). 

Across the top of a MacWrite window appears a ruler, 
which is used for formatting. Figure 2.3 gives the functions 
of the formats. Later, I will discuss what you can do with 
the ruler. We don't need the ruler for this letter because we 
are going to accept the format as Apple set it, so our next 
step will be to hide the ruler. 

Pull down the Format menu and select Hide Rulers (see 
figure 2.4). The ruler will disappear. Note that when you 
roll the mouse to move the cursor from outside the window 
it is an arrow, but when you roll it inside the window it 
takes the form of anI-beam. The I-beam shows that you can 
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Figure 2.2 An untouched MacWrite window 

I Font Style 
' • File Edit Search Format Font Style 

Untitled 

Insert Ruler 

OpellHeader 

i 

Figure 2.3 MacWrite tools 
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Whitney Q. User 
12 34 Central Avenue 
Townsville. Illinois. 60606 

Figure 2.5 Typing in text 

-
Open Footer 
Display Headers 
Display Footers 
Set Page 11 ••• 
Insert Page Break 

I ntle Page 

(t-Lm) Figure 2.4 Hiding rulers 

use the cursor to insert or change text ; the arrow shows 
that you can use the cursor to control your work process 
with menus and dialog boxes. 

Press the Return key three times to make a wide top margin, 
and then type your address exactly as you would on a 
typewriter; press the Return key at the end of each line of 
the address. 

You will notice a thin , blinking, vertical line where 
your typing goes in . This blinking line is called the insertion 
point. Whenever you type text, the next character will 
appear to the right of this blinking line. By moving the 1-
beam with the mouse you can put the insertion point any­
where in the text. You cannot put it beyond the text, in the 
margins , or beyond the end of the text. 

If you don ' t like what you have just typed, you can 
erase everything back to the last time you pressed the 
mouse button by rolling the pointer up to the Edit menu, 
pulling the menu down, and selecting Undo Typing. 
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STEP7 

STEPS 

Continue typing the letter so it looks just like the one that 
appears in figure 2.8. Don't worry about mistakes; our next 
steps will show you how to correct them. At the end of 
short lines, the senator's address, the salutation, the clos­
ing, and the name, you have to press the Return key. You 
don't need to press the Return key at the end of regular 
lines; the computer takes care of moving the insertion point 
to the next line. 

At this point, the letter you have typed exists only in 
the volatile memory of the Macintosh. Now is ~ good time 
to save it in relatively permanent form on a diskette. 

Pull down the File menu and select Save. 
The dialog box in figure 2. 7 will appear. 

Saue current document as MacWrlte •.• 

( Eject 

Save ( Concel ) 

®Entire Document 0 TeHt Only 

Figure 2. 7 The file saving dialog box 
Figure 2.6 Saving a file 

Type in a name for the file; For Bit Letter is a good one. 
Typing mistakes are corrected by backspacing when you 
are typing in dialog boxes. 

Notice that when you gave the letter a name, the Save 
button turned from gray to black. When any word is in gray 
in a Mac menu or dialog box, it means you can't use that 
function right then. By giving the file a name, you make it 
possible to save it. When you have named the file, roll the 
mouse so the pointer is over the Save box, and press and 
release the mouse button. The process of rolling the pointer 
into a box in a dialog box, and pressing and releasing the 
mouse, is called checking. 

Correcting errors and making changes is an important 
part of word processing. Figure 2.8 shows the body of the 
letter with some errors. In the next few steps I will show 
you the simplest ways to make changes and correct errors. 



STEP9 

STEP10 
1 write to urge 
Masse4usetts to 
tie<l to the past 

Figure 2.9 The first step in 
selecting a word 

STEP11 

I write to ur; 
!I ME? to 
tie<l to the past 

Figure 2.10 A Word selected 
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' • file Edit Seerch form11t font Style 

iD for Bit Letter 
Dear Senator Hotspur. 

I write to urge your vote for the b!ll introduce<! by senator Digital of 
Massachusetts to establish money on the binary standard. We have been 
tie<l to the past long enough, the dollar should be base<l on something 
modern and something the US has a-plenty: bits. 

Senator D!gitars b!ll woUld insure that a b!lllon bytes were stored in 
fe<leral data banks for every dollar b!U m circulation. and I think tha$ a 
great idea . If you fall to support this bill, I will seriously consider voting 
for your opponent in upcoming elections. 

Sincerely, 
I 

Wh1tney Q. User. 

Figure 2.8 Text with errors 

:{ 

Use the scroll box or the scroll arrow to view the body of 
the letter. Note that the name of the Bay State is grossly 
misspelled. 

Roll the mouse until the 1-beam appears in the word you 
want to change. 

Double click the mouse. Black and white w ill reverse 
around the word , as in figure 2.10. When text is white on 
black, it is selected. 

Type the name of the state correctly. 
Notice what happened . With the first character you 

typed , the white on black returned to normal , and the new 
character appeared next to the blinking insertion point. 
Whenever you type text into an area that is white on black 
in MacWrite (or in dialog boxes, and in many other situa­
tions), the first character you type replaces the reversed 
material (even if it is many pages), and the insertion point 
appears to let you continue typing new material. 
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STEP13 

STEP14 

STEP15 

Roll the mouse until the 1-beam appears after the U in ''US.'' 
Click the mouse. The insertion point appears where you 
clicked. Type a period. Move the 1-beam after the S and 
click again. Type another period. You can add the apos­
trophe to " thats" in the second paragraph the same way. 

Roll the mouse until the 1-beam stands before the I in " If 
you fail.. .. " Drag the !-beam down into the next line. Text 
is now selected up through the point in the next line. Don't 
release the mouse button. 

' a File Edit Senrch Formnt Font Style 

10 For Bit letter 

Senator Morton K Hotspur 
Senate Office Building 
Washington, D.C. 

Dear Senator Hotspur. 

I write to urge your vote for the biU introduced by senator Digital of 
Massachusetts to establish money on the binary standard. We have been 
tied to tlle past long enough, tlle dollar should be based on something 
modern and something tlle U.S. has a-plenty: bits . 

Senator Digital's bill would insure that a billion bytes were stored In 
federal data banks tor and l think that·s a 

Sincerely, 
I 

Figure 2.11 Text selected 

While holding the mouse button down, roll the mouse to 
the right until the blackness embraces the end of the sen­
tence (see figure 2.12). Now release the mouse button. At 
this point any typing you do will replace the selected sen­
tence. The sentence is selected, vulnerable to change. But 
suppose you decide this sentence is OK after all? Move the 
mouse to any other point and click there. The black will 
turn to white once more and the next character you type 
will appear at the new insertion point. This process of 
canceling a selection by clicking somewhere else is very 
useful and is called deselecting. 

To summarize: you can correct errors or change let­
ters by: 

1. Replacing a word by moving the 1-beam into it, 
clicking twice, and then typing. 
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• a File Edit Search Format Font Style 

10 For Bit Letter 

senator Morton K Hotspur 
Senate Otr!ce Building 
Washington, D.C. 

!)ear senator Hotspur, 
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I write to urge your vote for the bill introduced by senator Digital or 
Massachusetts to establish money on the binary standard. We have been 
lied to the past long enough, the dollar should be based on something 
tnodern and something the U.S. has a-plenty: bits. 

:enator Digitars bill would Insure that a billion bytes wEtre stored In 
federal 

:incerely, I 

Figure 2.12 A sentence selected 

2. Replacing any amount of text by dragging the !­
beam over it and then typing. 

3. Typing any character, space, or backspace where 
the insertion point is blinking. 

MacWrite includes several other tools to correct and 
change text, including a way to move selections from one 
place to another or from another document , or from Mac­
Draw to illustrate your document. Most of these tools are 
explained below. 

Printing a Letter 

Most documents we write , like the letter to Senator 
Hotspur are not useful until they have been printed. The 
following printing instructions assume you are using an 
Apple Imagewriter. 

Here's the procedure to print your letter : 

Pull down the File menu and select Print (see figure 2.13). 
The printing dialog box (figure 2.14), will appear. If you 
have used the printer before , the preset values may differ 
from what app ears in the figure. 
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Figure 2.13 Telling the Mac to print 

STEP2 

STEP1 

STEP2 

STEP3 

Quality: 0 High 
Page Range: ® Rll 

Copies: EJ 
® Standard 0 Draft 

0 From: D To: D 
Paper Feed: 0 Continuous ®cut Sheet 

Figure 2.14 The dialog box for printing 

If you are using paper that feeds into the printer continu­
ously (fanfold or a roll), move the mouse arrow into the 
circle labeled Continuous and press the mouse button and 
release it. If any of the other options differ from figure 2.14, 
then move the mouse arrow into the appropriate circle and 
press the button and release it. Then move the arrow into 
the OK box and check it. 

A message will appear saying that the text is being 
recorded, then another message will appear that tells you 
that you can stop printing by holding down the Command 
key and typing a period. 

If you are using single sheets, a dialog box will prompt 
you to insert a sheet of paper; after inserting the paper, 
click the OK button. This box will appear whether or not 
paper is in your printer. Your letter will now be printed. 

You may want to go on now to set up a form letter to 
express your views to many representatives, or you may 
want to stop. If you want to go on, skip to the next section. 
If you want to stop, the following procedure will enable 
you to begin neatly later. 

How to Close Down 

Pull down the File menu and select Quit. A dialog box will 
appear and ask if you want to save your changes. 

Check Yes. After a few moments, the diskette icon will 
expand to show its contents. 

Pull down the File menu and select Eject. The diskette icon 
will collapse and the machine will eject the diskette. You 
can now work with other diskettes or turn off the machine. 



STEP1 

STEP2 

Get Info 381 
Put Batt 

Close 

Figure 2.15 Duplicating a file 
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STEP4 
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Letters to Your Representatives 

This section shows you how to use a mail merge pro­
gram to turn your letter to Senator Hotspur into letters to 
several representatives. The program is MegaMerge by 
Megahaus of San Diego. I chose it for this chapter because it 
is simple to use. A more powerful data base system could 
perform the same function but, because it would be more 
powerful, it would be more complicated to use. 

To use MegaMerge, you make a MacWrite file with 
labels that are formatted in a special font. MegaMerge will 
replace these labels with items from a list, which you also 
create in Mac Write. If you have only one disk drive, you 
must transfer these two files to a MegaMerge diskette, 
because MegaMerge is protected from copying; you cannot 
move the MegaMerge program to another diskette at your 
convenience. With two disk drives, you can keep the Mega­
Merge icon on one disk and your MacWrite files on the 
other. 

Start by putting the diskette that has Y· 'Ur letter to Senator 
Hotspur in the Mac. If the catalog does not appear, double 
click the icon of the diskette to create the catalog. Select the 
icon of the letter to Senator Hotspur. 

Pull down the File menu, and select Duplicate. A new 
icon named Copy of .... will appear. 

Rename this file "To Reps" by typing those characters. 
Remember, white-on-black text is replaced by whatever 
you type in. 

Double click to display the contents of the new file, which 
will be the same as the file you made above. 
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S&naoo OfCic& Building 
Washington, D.C. 

D&ar Senator Hotspur, 

Figure 2.16 Selecting a line 

STEP6 

STEP7 

STEPS 

STEP9 

STEP10 

Roll the mouse until the 1-beam is at the left of the senator 's 
name in the address; press the button and roll the mouse 
right to select the whole line. 

Type Name. 

Use steps 5 and 6 to replace Senate Office Building with 
Building and Senator Hotspur with Greeting. 
As is often the case, part of the text of the letter will vary 
with the recipient. One letter will go the secretary of the 
treasury, who is not elected, so we need to substitute an 
appropriate word for vote in some letters . 

I 

Whitney Q Us&r 
1234 Central Avenu& 
Townsvlll&, Illinois, 60606 

~ 
ltl!ili!.lOg 
Washington, D.C. 

D&ar~g. 

To Rep s 

I 

I writAI to urg& your ~RRQll for tll& blllintroduc&d by Senator Digital of 
Massachusetts to &Stablisb money on the binary standard. We have been 
ti&d to the past long enough, the dollar should be bas&d on something 
modern and something the u s. has a -plenty: bits. 

Figure 2.17 Putting general-purpose words in a form letter 

Select the word vote in the first line and replace it with 
support. Now to put our labels in a special font . 

Move the cursor to Name and select it and the following 
line, Building. Leave it selected. 

Pull down the Font menu and select an out-of-the-way font 
that is still readable , Venice for example (figure 2.18). The 
font you were using w ill change to Venice before your 
eyes. 



STEP11 

N~m~e 
llmldinq 
Was hington, D.C. 

Dear Ein:dinq, 

1 write to urge your s~pport for 

Figure 2.19 Standard letter with 
general words in a 
special font 
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STEP2 

STEP3 

STEP4 

N~m~e• 
llmldinq• 
Eireetinq• 
s~pport• 

\ 

Figure 2.20 Setting up address list 

10 

Whitney Q. User 
i234 Central Avenue 
Townsville, Illinois, 60606 

Washington, D.C. 

Figure 2.18 Changing the font 

Toronto 
Chicago 
Geneua 

.;'New Yorlc 
Monaco 
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Similarly, select and change the font of Greeting and Sup­
port. The letter will look like figure 2.19. 

Now to make the list of addresses. 

Pull down the File menu and select Close. A dialog box 
will appear, asking if you want to save your changes. Check 
Yes. The screen will go blank except for the command line. 

Pull down the File menu and select New. A file with a ruler 
at the top of the screen will appear (see figure 2.2). Again, 
you won' t need the ruler , so pull down the Format menu 
and select Hide Rulers. 

Pull down the Font menu and select Venice as in step 11 
above. 

Type " Name=", "Building=" , "Greeting= " , and "Sup­
port= " with a Return after each equal sign. Then type a 
backslash ( \) and then a Return. The screen should look 
like figure 2.20. 
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Figure 2.21 Copying a block of 
text in order to 
reproduce it 

STEP& 
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Figure 2.22 Pasting a block of text 

STEP7 

STEPS 

STEP9 

Now use Cut and Paste to save some typing. 

Select all the text by rolling the 1-beam to the upper left­
hand corner and then down to include the backslash. Pull 
down the Edit menu and select Copy. 

Set the insertion point after the backslash, pull down the 
Edit menu and select Paste (figure 2.22). A duplicate set of 
labels will appear below the first. Repeat the pasting three 
times. You can save "mousing" by holding down the Com­
mand key (the one with the quadrifoil design) and pressing 
the V key three times (see chapter 1 for a discussion of 
entering commands from the keyboard.). 

The process of selecting a piece of text, copying it, 
moving the insertion point somewhere, and finally pasting 
the text there is the basic way of duplicating text in Mac­
Write. Cutting a piece of text, moving the insertion point 
somewhere, and pasting the text there is the basic way of 
moving text in Mac Write. 

Now you can begin entering the names of your represen­
tatives. Use the scroll box to get back to the top of the file. 
Move the mouse after the equal sign following Name. Pull 
down the Font menu and select New York. Type the name 
of Senator Hotspur. 

Move the insertion point down to the next equal sign, select 
New York from the Font menu again, and type Senate 
Office Building. Continue this process until you have typed 
in a list like figure 2.23. You have to reselect the New York 
font each time otherwise MacWrite assumes you want to 
continue a line with the same font that began the line. 
Remember, everything you type in the New York font will 
appear in the letter just as it is typed. 

Pull down the File menu and select Quit. A dialog box will 
appear to ask if you want to save your changes; check Yes. 
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STEP11 

Figure 2.24 The MegaMerge icon 

Ntu'J~e.=Senator Harry Hotspur 
lh&Uc:[.\nq·~nate Office Building 
a.rutinq=Senator Hotspur 
SUJ'POfl"'vote 
\ 
Nca.me=~nator Katherine Glendower 

Bqi.ld.i.nq=Senate Office Building 
G.ruti..nq=Senator Glendower 
SUJ'pOrl=VOte 
\ 
Ntlflle.•Representative Pete Pistol 
Bqi.ld.\nq-House Office Building 
G.rutinqo:Representative Pistol 
SUJ'port=vote 

' 
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Ntlflle.==Secretary of Ule Treasury William OldcastJe 
Bqi.ld.\nq=Department of the Treasury 
G.rutinq== Secretary Oldcastle 
support--support 
\ 
Ntlflle.=President Harry Tudor 
!JuilcU114•The White House 
G.reett.rlq=Mr. President 
SUJ'port:vote 

' 
Figure 2.23 Mail list fi le 

Copy your two files, To Reps and Reps Addresses, onto the 
MegaMerge d iskette. If you are using two disk drives , you 
don ' t need to copy the files, but merely need to have the 
MegaMerge diskette in one of your drives. 

Turn off the Mac , insert the MegaMerge diskette , and turn it 
back on. Select the MegaMerge icon (see figure 2.24) and 
double click it. The MegaMerge command line will appear . 
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Preparing a 
Resume 

Pull down the Letter menu and select Open. The familiar 
Macintosh file opening dialog box will appear and display 
all the Mac Write files on the MegaMerge diskette. Select To 
Reps and then check Open (figure 2.25). Your file will 
appear in a window on the left of the screen. 

fed reps 2 
Lobel Letter ~!lli 
Reps Addresses ~~~ 
Semple Letter i!l~l 
Somple List ~ 
state reps 

M@QIM I Megahous/ ... 

~ I ( Eject ) 

Cancel ) I 
! 

Figure 2.25 Opening the letter file in MegaMerge 

Pull down the List menu, select Open, and open the Reps 
Addresses file. 

Pull down the Mergefont menu and select Venice, the 
font that defines your labels. 

Pull down the MegaMerge menu and select Print Pages. 
The dialog box to set up printing will appear. The preset 
choice is continuous form paper, and this example follows 
that choice, although you can use sheet fed. Accept the 
preset values and check OK. Your five letters to your five 
representatives will begin to print. 

This section shows you how to prepare a document using a 
somewhat more complicated format based on tabbing. It 
also shows how to set up a header and footer that will 
appear on every page, and how to copy an illustration from 
Mac Draw into your Mac Write document and print it. 

This exercise accepts the preset face and font, 12-point 
New York. The figures in this book may not be the same as 
your text if you use another font. 
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Figure 2.26 MacWrite tab wells 
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Figure 2.27 Setting tabs in 
MacWrite 
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Figure 2.28 Selecting underlining 
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Creating and Formatting the Resume 

Double click on the Mac Write icon. This time we are going 
to use the ruler that appears across the top of the window. 
At the left end below the ruler are a pair of triangles in boxes 
that are called tab wells. 

Point to the triangle without the dot in the center. Hold 
down the mouse button and you will find that you can drag 
a new triangle away. This endless supply of little triangles 
allows you to set tabs . Drag the tab triangle till the point 
touches the bottom of the 2 1/4-inch line (figure 2. 27). Your 
tabs are now set for the resume. 

Pull down the Style menu and select Bold. Next pull down 
the Style menu and select Underline. This exercise 
accepts the preset size, 12 point. If you had wanted a 
smaller point size, you could select it now. 

Type "Objective". It appears bold and underlined. 

Pull down the Font menu and select Plain Text. As men­
tioned before, the command characters that appear on the 
right of the fonts can also change the fonts. You have the 
option of controlling the style of font by typing, for exam­
ple, Command-P from the keyboard . 
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.~.1 ....... 1._ ... ,, ..... ..1.~.:.;!;;·•···1 ...•... 1 .... 

~G51 ~ 
Objec:Uve: A supen 
!solving ability 

Figure 2.29 A tabbed line before 
pressing the tab key 
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ObjecUve: A supervisory : 

solving ability 

Figure 2.30 A Tabbed line after 
pressing the tab key 
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Press the tab key and type; ''A supervisory job using my 
proven leadership and problem-solving ability.'' At this 
point the text will return to the left margin, but don't 
worry, it is easy to fix. 

With the mouse, move the 1-beam to the left of the second 
line, and click the mouse button so the blinking insertion 
point appears to the left of solving. Press the tab key and the 
second line of text will move to the right of the tab. 

Use the mouse to move the 1-beam to the end of the second 
line, and press the mouse button so the blinking insertion 
point appears after the period following ability. Press 
Return twice to double space. 

Pull down the Style menu and select Bold and 
Underlined. Type in "Experience:". The next words are 
bold only in our format. Unfortunately, you can't turn off 
style features one at a time; you have to return to plain style 
and build them up again. 

Pull down the Style menu and select Plain Text. Pull 
down the Style menu and select Bold. Press the tab key 
and then type ''Hillview school, ''(a space should follow 
the comma). 

Pull down the Style menu and select Plain Text again. 
Type ''Townsville, IL'', and press Return. 

Type '' 197 6-Present''. 

Press Tab and type; "Teacher and Administrator, Summer 
School Director.'' 

Press Return, press Tab, and type a "period" (.). Repeat 
these steps to vertical space (or make up things about Mary 
McCarthy's life). 
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Follow steps 11-13 to enter the text beginning 
1971-1976 in figure 2.31. 

Make up more years of Mary's employment if you 
want. 

Q12jectiye· A supervisory job using my proven leadership 
and problem solving ability 

bR2rieace: Hillview Scbool, Townsville , 11 
1976-Presnt Teacher and Adminstrator, Summer School Director 

Taught Science, math, and sixth and seventh grade 
Selected and trained summer school stat of 50 

.-
J 971- J 976 Liacola Scbool, Springfield I L 

Vice principal! 

Designed and instr!cted a comprehensive science 
curriculum 

Figure 2.31 The text of Mary McCarthy's resume 

Pull down the Style menu and select Bold and Underline. 
Type: ''Community Activities:''. Press Return, and pull 
down the Style menu and select Plain Text. 

Type "1976-1982", press Tab, and then type "Assistant 
Stage Manager, Eastern Illinois Light Opera." The text of 
the example resume is complete: you should now save the 
file before someone steps on the power cord. 

Pull down the File menu and select Save. When the dialog 
box appears give the file the title Mary McCarthy and then 
check Save. The screen will return to the text of the 
resume. 

Resumes need the job-hunter's name in bold at the 
beginning; to do this we will need to make further font 
changes and also change the function of the ruler. 

The Ruler Icon The ruler that you hid at the beginning of 
this section (figure 2.4) contains icons that let you control 
the format of your document. The pair of arrows just below 
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the l-inch marker control the margins. The larger, upper 
arrow controls the right margin; the smaller, lower arrow 
controls the indenting of the first lines of paragraphs. The 
arrow below the 7-inch marker controls the right margin. 
The three boxes left of center control line spacing. The left 
box shows single spacing, the middle one shows one and a 
half spacing, and the right box shows double spacing. The 
box that is white on black is the one that has been selected. 

The four boxes on the right control justifications (how 
words are arranged on the line). The left box shows left 
justification, all lines (unless you have indented the first 
paragraph) aligned at the left margin. The next box shows 
centered justification; each line is centered between the 
margins. The box to the right shows right justification; all 
lines are flush against the right margin. The far-right box 
shows full justification; spaces are inserted irregularly 
between words to make them flush with both the right and 
left margins (except for the first line of the paragraph, 
which is indented). 

A newly opened file has one ruler at the top. You can 
add more rulers to change the margins of a given paragraph. 
Each ruler controls what is below it, either down to the 
next ruler or to the end of the file. 

Use the scroll bar to move to the top of the file, and use the 
mouse to put the blinking insertion point at the very begin­
ning, to the left of Objective. 

Press Return four times to create space. Pull down the 
Format menu and select Insert Ruler. The top ruler will 
appear along with a new ruler above the text. You can later 
remove an added ruler just like text by selecting the ruler 
and then selecting Cut on the Edit menu. 

Roll the arrow up to the very top ruler and click the third 
box from the right, the one that shows centered text. 

Pull down the Style and select Bold, then pull it down 
again and select 14 Point. 

Type "Mary McCarthy" and hit Return twice to provide 
space. Mary McCarthy will appear 14-point, bold, and cen­
tered. The rest of the text is not centered because the 
domain of a ruler extends only down to the top of the next 
ruler. 
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Type "R". Hold down the Option key and type "e". Noth­
ing seems to happen, but you have laid the groundwork to 

give the word Resume a European look. Now type " esum". 
Again hold down the Option key and type "e" . Type "e" 
again. The result should look like figure 2.32. 

10 Mory Mccarthy 

iQ 
h 

Wii 
Mary McCarthy ~~~ 

Resume ~1!1 
Qi 

j if': 
i:l!i 

Ql;!j~ A su~rvisory job using my proven leadership and problem- IIi!!: 
solving ability. ,1 

b}>~ Hillview School, Townsville, 11 ~ ~~~~ 
1976-Now Teacb&r and Administrator. Summer School Director 

Taught science, math, and sixth and seventh grade ~: 
Selected and trained summer school staff of 50 ltf 

Figure 2.32 Resume heading 

The Option key gives you the power to type a large 
number of foreign and other special characters. You can 
see them by pulling down the Apple menu, selecting key­
caps, and holding down the Option key after the keyboard 
appears. Accents appear when you type the Option key and 
then type the vowel they modify (thus Option and e will 
accent a, e, i, o , and u) . 

Headers and Footers for the Resume 

MacWrite lets you define up to six lines of text that 
will appear at the top of every page (called a header), and 
up to six lines that will appear at the bottom of every page 
(called a footer). You define these lines by drawing down a 
special box from the Format menu where you write the 
text of each. The boxes include icons that will print the 
time, today's date, and the page number anywhere you 
want in the header or footer. You can omit the header and 
footer form the first page by selecting Title Page from the 
Format menu. 
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Pull down the Format menu and select Open Header. The 
header box will appear. 

10 He11d er 

t:l ll!J l!.J 
_!.f' a ,,.L , a , l.?,_,~_t__,__.-13 a......l .-a.......~~a,,..L....a....__8._._~.k-'---~....._...L..._.._~.l 

~~ ~~E) ~!&)[ii)[§i) 

IQ: 

Figure 2.33 The Window for controlling header format 

The Header Icons The header (and the footer) box con­
tains a number sign ( #) in the upper left; the # sign is an 
icon that will generate the page number when you put it 
into text . The two tiny numbers labeled 1 and 2 are the 
calendar icon, which will generate the date. The box on the 
upper right with the clock hands is the clock icon, which 
generates the time. 

Typing in the header (and footer) box is just like typing 
normally in MacWrite. Yo u can correct errors in the same 
way, copy text or illustrations to the headers in the same 
way and control formatting with the rulers in the same 
way. 

Since this is a resume, we don 't want to emphasize the 
header to much, so we will choose a modest typeface. 

Pull down the Style menu and select 9 Point. 

Roll the pointer into the upper , left-hand corner of the free 
space in the header box (just below the left end of the ruler) 
and type " Page". 

Type enough spaces to move the insertion point below the 
3 1/4-inch mar~ on the ruler. Type " Resume: Mary McCar­
thy''. Use the method described in step 6 above to type the 
accents . 

Roll the pointer to the # ico n in the upper, left-hand corner 
of the header window, and press the mouse button ; hold­
ing the button down, drag the icon to a stop just after Page 
and release the mouse button. Drag the calendar icon from 
just under header to below 6 1/4 on the ruler. (You can put 
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icons farther to the right; if you do, their message will print, 
but it will not appear fully on the screen.) Your header box 
should look like figure 2.34. 

Header 
~ 

~ ·-~t?.._._....J...._._._I3 1 I I 14 I I L..J_..E,_.~,k-~'----'--~ 

~~ -~ 1 I ~[I]!a)!il) 
Patt (:l R ....... H ... ~ HcC ... thoji lliJ 

Qi 

Figure 2.34 Page number and date as they appear in the header box 

Roll the pointer to the little box in the upper left of the 
striped top of the header box to close the box and click. The 
header box wi ll disappear. 

Pull down the Format menu and select Display Headers. 
Your header should look like figure 2.35. 

. Mary McCarthy 
Pot< I Bi•umi: Htry t1cCarthy S.pttml>or 4. iQ 

1'. 
1:!!! 

I 
I I I 121 :&,..-1-,_._,_13 1 I I l~_,_,_,_a_._._.!...............!&...o...J_o-'...o.;ll 

~~ -~[3 Rll!!!!!!!!l~-
I 

Mary McCarthy 

Resume 

_!.f:l • I I 1 2.-:&,~..L......._._LL_._._..._.__.__d_ ...... -L.... • .._._L~-~-~-a-~-'-~LL.....l.........._._J. ~~ 

~~ -~[3 !all!!!!!!!i!!il~-
,'fi 

1!""'-,_~_._._._t?~A.....J~-~~~.!....~-L ..... ~-d..~· ........ .._t~.-~~-:!~......t!......-·~_.-~1 a 
r.,'"""' -== - -=== 

Figure 2.35 A header including page number and date in the MacWrite 
window 

If you want to see your text without a header, select 
Remove Header from the Format menu . 

Footers are created just like headers. 

Pull down the Format menu and select Open Footer. The 
footer box will appear; it is exactly like the header box 
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except it is called a footer. The insertion point will be in the 
upper left corner again. 

Pull down the Style menu and select 9 Point. 

Type: " 1375 Delvin Road, Townsville, Illinois, 60606, 
(312} 222-7596". 

Click on the close box in the upper, left-hand corner of the 
footer box. 

Pull down the Format menu and select Display Footers. 

Use the scroll box to move down the resume to see your 
footer. 

Illustrating a Document 

I don't necessarily advise illustrating a resume; it 
depends on who you are and what kind of job you are 
looking for. But let us assume Mary wants to illustrate hers; 
it gives us a chance to see the integration of two Mac 
applications and appreciate how easy it is to move some­
thing from MacPaint (or MacDraw) into MacWrite. 

The story of the portrait in figure 2.39 illustrates the 
versatility of the Macintosh. I took my Mac with me on a 
vist to a friend in the country. I showed it to the friend, who 
has some computer experience and some talent and train­
ing in art, but who by occupation is a chemist. He had never 
seen a Macintosh or touched a mouse (the computer kind 
anyway). At the end of about half an hour's play and 15 
minutes concentrated effort, the portrait was as you see it 
except for some modest modifications I made for publica­
tion. 

In the majority of cases, you can move what you create 
in any other application into Mac Write. Of course, in Mac­
Write you don't have the tools you had in the original 
applications. You can't add to an illustration for example. 
Similarly, you can copy a table from a spreadsheet into 
Mac Write but you cannot then change a number and have 
the other numbers change by a formula as they would in 
their original application. Once the table is taken out of the 
spreadsheet, it is just a piece of the text; the supporting 
formula is gone. 
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In this operation we will open a MacPaint file, copy an 
illustration from it , open a Mac Write document, and paste 
the illustration into MacWrite. 

This exercise assumes that you have both Mary's 
resume in a MacWrite file as created above and Mary's 
portrait in a MacPaint file on the same diskette. If you don't, 
see the MacPaint manual to see how to make a simple 
drawing. Refer to the Mac manual or chapter 1 on putting 
two files on the same diskette. 

Move the pointer to the icon for the MacPaint file and 
double click. 

Select the lasso in the upper right-hand corner. Use the end 
of the lasso to draw a line around the portrait. The moment 
the line is complete, the lines that mark the edges of the 
portrait will become dashed lines that jiggle. 

Figure 2.36 A MacPaint drawing selected for copying 

Pull down the Edit menu and select Copy. A copy of the 
portrait goes to the Clipboard. 

Pull down the File menu and select Quit. The diskette 
catalog should reappear. 

Double click on the Mac Write file "Mary McCarthy." 
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STEPS Move the 1-beam above the heading, and click the mouse 
button to put the blinking insertion point there. Pull down 
the Edit menu and select Paste. The portrait will appear. 

Mary McCarthy 

~~ A su~rvisory job using my proven leadership and problem 
solving ability. 

Figure 2.37 A MacPaint drawing as it appears in a MacWrite document 

Printing 

Pull down the File menu and select Print. A dialog 
box will appear with printing choices (see figure 2.38). 

Quality: ®High 0 Standard 0 Draft ~ 

Page Range: ® Rll 0 From: D To: D 
Copies: 0 
Poper Feed: 0 Continuous ® Cut Sheet [ Canc:el ) 

Figure 2.38 The dialog box for printing 

Check High and Continuous or Cut Sheet depending on the 
paper you are using. Leave the other preset values. Check 
OK. If you are using cut sheet, another dialog box will ask 
you to check whether there is a sheet of paper in the 
printer. The printed resume will look like figure 2.39. 
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Pip I Ja<>uory 31. 19&5 

Ma.ry McCa.rt.by 

Resume 

Qb!cctjve· A supervisory job usina my proven leadership and problem 
solving ability. 

Hloerlence· Hillview School. Townsville. II 
1976-Now Teacher and Administrator. Summer School Director 

Tauaht science. math, and silthth and seventh grade 
Selected and trained summer school staff or 50 

Figure 2.39 Mary McCarthy's printed resume 
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MacDraw is a program from Apple that lets you draw 
and arrange objects in a defined format. It offers tools 
similar to those that architecture and engineering design 
programs offer on much more expensive computers. You 
can use a variety of fonts, as in MacWrite, and it offers 
essentially the same sizes and styles. You can set a visible or 
invisible grid in the drawing area that functions like a 
drafting machine; that is, it will keep your lines straight. 
The grid may be in inches, metric, or fractions of those 
measures. MacDraw allows you to fill drawn objects with a 
variety of patterns; patterns can also be used to form the 
texture of lines in a variety of thicknesses. Once you have 
drawn an object, you can attach it to other objects and 
move, expand, compress, or rotate them as one object. You 
can also put one object in front of another. 

MacDraw allows several files to be open on the desk at 
once, so work can be easily shifted from one file to another. 

Although the window in MacDraw exposes only about 
4 to 7 inches, the drawing itself can be as large as 40 by 120 
inches. Scrolling tools allow you to move the window over 
large drawings. Large drawings are set to print on adjoining 
sheets of 8 1/2-by-11 inch sheets of paper, but you may 
adjust the program to use other sizes. 

It is worth comparing MacDraw to MacPaint, another 
graphics program from Apple. Where MacDraw is architec­
tural, MacPaint is like hand-drawing or etching. Where 
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MacDraw enables you to draw straight lines or orderly 
curves, Mac Paint lets your line wander as freely, or as 
chaotically, as your hand does. 

In general, MacPaint resembles a fine arts medium. 
That is why I have not provided instructions for using it 
beyond the specific tasks discussed in chapter 7. Telling 
someone how to use MacPaint is like telling someone how 
to draw. As you will see, I draw badly, and I certainly don't 
know how to teach it. Thus, I find MacDraw more useful. 

To understand why MacDraw and MacPaint work so 
differently, it is useful to know how the information in 
MacDraw is held in the computer program. MacDraw's 
program works like someone drawing a graph on num­
bered graph paper. The computer stores some numbers, 
which determine how a line will be drawn. When you call 
for the drawing it generates the lines from the numbers. 
MacPaint constantly remembers every tiny dot on the 
screen, and gives you tools for drawing by turning those 
pixels black or white. You may have noticed that if you 
look closely at a newspaper picture or a television screen, it 
is made up of tiny dots. MacPaint lets you manipulate the 
screen version of those dots. 

One consequence of this is that MacPaint files take 
much more memory than MacDraw files or most graphic 
programs. MacPaint may use 14,000 bytes to store the 
image of one screen, which is 4% of the space on a 400K 
diskette, whereas MacDraw might use a quarter that much 
for the same image. 

You can move files from MacDraw to MacPaint-the 
software knows how to turn numbers into dots-but you 
cannot move files from Mac Paint to MacDraw; the software 
does not know how to turn dots into numbers. 

The following section gives specific instructions on 
making a label to list the contents of an audio cassette, and 
instructions on designing a simple kitchen. 

If you're like me, you copy records or broadcasts onto 
cassettes, or record friend's live performances and then 
scrawl unreadable notes on the blank label that comes with 
the cassette. I have learned to use MacDraw to create nicely 
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printed, and occasionally illustrated, labels for my cas­
settes. (The customs, morals , and possibilities of cassette 
copying are , by the way, very much like the issues of 
software and video cassette copying.) 

The Imagewriter prints by tapping the ribbon with 
tiny wires. The paper that best shows the results is thus not 
quite the same as that used with a typewriter. Paper that is 
too hard splatters the ink and makes a fuzzy impression, 
whereas paper that is to soft lets the ink smear. A bright 
white paper with a moderate matte has worked best for me. 
I used Neenah A von Brilliant White for the figures in this 
book that show printing. The figures from the screen are 
sent directly to the typesetter. 

Making a Cassette Label Template 

Put a diskette containing MacDraw in the Mac and turn it 
on. When the disk catalog appears , double click it. The 
MacDraw window will appear. 

• File 

. . ~ . . . . . . . . . ; . . . . . . ;::: 

··· ·· ···:········=· ·······:········=····· ···= ········= ········:····· ···=········=········= ··· ········· ········· 
. . . 

. . . . .. . ·:· .. · •· .. ·:·. . . ... . ... . . . . . . . 

.. ...... ...... ..... .. ; ... ..... ; ... .. .. . ; .. 

Figure 3.1 MacDraw window showing menus and tools 

The Apple , File, and Font menus contain commands 
that work almost exactly as in MacWrite. There are some 
extra Edit commands for reshaping drawings. 

The Layout menu controls how the drawing paper 
looks on the screen, its size and whether there is an auto­
matic grid. 

The Arrange menu allows you to rotate drawings, 
move one in front of another, and make other changes in 
layout. 
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...-Normal Size 
Reduce To Fit 
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Turn Grid Off 
Hide Grid Lines 

Figure 3.2 The MacDraw layout 
menu 
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Figure 3.4 Cursor-tracking lines 
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Figure 3.5 Changing the zero 
point of the rulers 
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The Fill menu allows you to fill figures with different 
textures, and the Line menu allows you to draw with the 
same textures. 

The Pen menu determines line width. 
The symbols along the left are the tools used to draw 

the shapes the symbols represent. 
Cassette boxes vary in size, but for the most part they 

are metric. 

Pull down the Layout menu and select Custom Rulers. 
The Scale of Ruler dialog box will appear. Check 

Centimeter, Unlocked, and then check OK. 

Scale of Ruler: ~0 
Ruler: Qon @Off 

Qlnch ®Centimeter 

@Standard QCustom Cancel 
Zero Point: QLocked ®Unlocked 

Figure 3.3 The Scale of Ruler dialog box 

Pull down the Layout menu and select Show Rulers. 
If the rulers are already present you don't need to do this 
(Hide Rulers will show instead). The metric ruler will 
appear, with major lines every centimeter and minor divi­
sions every 2 millimeters. 

While it is convenient to have the numbers of the ruler 
the same as the numbers we are using to measure our 
cassette label, it is not convenient to have the edge of the 
label at the edge of the paper. We unlocked the ruler for 
that reason and will now move the zero point. 

Roll the mouse so the cursor enters the empty box in the 
upper left corner where the rulers meet. Dotted lines will 
appear in the little box. These are the hairlines that will 
track the cursor when the rulers are visible . 

Hold down the mouse button and pull the flashing 
dotted lines diagonally to the right until the zero point is a 
centimeter and a half inside the window. 

The symbols to the left of the work area help you draw 
clean figures of their respective types any time one of the 
symbols has a tweedy gray background. This background 
indicates that you can do the type of work represented by 
that symbol. 
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A cassette label is a rectangle 9.6 by 10 em. To make the 
rectangle, roll the cursor into the area of the rectangle 
symbol and click. The rectangle will turn gray. The cursor 
becomes a tiny cross when it is in the work area. Roll it 
around a little. Two hairlines follow it in the vertical and 
horizontal rulers. These hairlines locate its position on the 
grid in centimeters. The grid will not let the cross rest 
between centimeters. 

Move the cross to the 0 point. Press down the mouse button 
and drag the cross diagonally down and to the right. Lines 
in flashing outline will appear. Drag diagonally until the 
right side of the rectangle is at 9.6 em, as measured by the 
hairline in the ruler, and until the bottom line is along the 
bottom of the window (7 em). Release the mouse button. 
The rectangle in figure 3. 7 should appear. 

: .. 

Figure 3. 7 A rectangle, drawn and selected 

Note that the rectangle is filled with a pattern (white) 
and that it has little squares at the corners and edges. These 
little squares are called handles; they show that the rec­
tangle is selected and vulnerable to change. The handles 
serve the same purpose that white on black does for a piece 
of text. The selection tool is the arrow at the top of the 
stack of symbols on the left margin. 

Correcting Mistakes In MacDraw, if you see you have 
made a mistake in drawing, it is best to clear it and start 
over. If the black selection squares are visible, you can pull 
down the Edit menu and select Clear. Clear is preferable to 
Cut since Clear instantly throws away the mistake. If the 
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Figure 3.9 Selecting Lines 
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selection squares are not visible, select the object by point­
ing near an edge and clicking; you can then clear it away. 

This cassette label is 10 em long, so you want to change 
the rectangle by making it longer, but not by clearing it 
away. 

Note that when you release the mouse button, the cursor 
turns back into an arrow. Click on the scroll arrows to 
move down the screen until you can see the 10-cm mark on 
the vertical ruler. Move the arrow to the black square in the 
middle of the bottom edge of the rectangle and press the 
mouse button. Drag the bottom of the rectangle downward 
until it reaches the 10-cm line on the grid paper. 

i!L .. ~ ...... . 

~ .. j ..... . 
~ .. ; ..... . 
12- .) ..... . 

11!! ) 00 .... ~. ---....--....--.......,.----,-----,-----:--.l~: ..... .. : 

Figure 3.8 Lengthening a rectangle 

The part of the cassette label that faces the spine when 
it is folded into the box and shows the title is 1.3 em wide 
and 1.6 em from the bottom of the label. When you fold the 
label into place, it is handy to have dotted lines to mark the 
fold. 

Click on a random spot in the work area outside the rec­
tangle to deselect the rectangle. The black squares vanish. 

Pull down the Lines menu and select the dashed line. 
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Figure 3.11 Selecting Save As 
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Click the mouse in the rectangle symbol in the left margin. 
Roll the cross to the point on the left side of the rectangle 
that is opposite the 8.4-cm mark on the ruler. Press down 
on the mouse button and drag the cross diagonally up to the 
7-cm point on the right side of the rectangle. A rectangle 
with dotted lines will appear. 

·~ .. --------------.----------------- :1~ 

.• ; ~· .. 
i--------------------------------- -u ... 

Figure 3.10 A second rectangle with dotted lines 

It's always a good idea to save your work from time to 
time. You should do so now because you have created a 
template that you can set aside for future cassette labels, 
saving you from making the same shape again. 

Pull down the File menu and select Save As. A dialog box 
will appear. 

Type ''Schock'' and check Save As • . . 

Saue the document as: 

)Schock 

Figure 3.12 The Save As dialog box 

Filling in a Cassette Label 

Macorawo... ·· 

( Eject 

Let's put the title and the names .of the selections on 
the label. I've chosen to make a label for my local New 
Wave group, Shock. The large letter Tin the symbols on the 
left of the work area is for Text. 

Move the cursor up to the T symbol and click the mouse. 
The background will turn tweedy gray. 

Let's start with the spine, where we will want a font 
size and style you can read. 
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Figure 3.13 Selecting 24 point 
from the Font menu 
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Pull down the Font menu. Note as the cursor passes over 
the work area it turns to the familiar I -beam that shows you 
can insert text. Note that the hairlines on the ruler continue 
to follow the I-beam. The preset font is Chicago, a good 
font for New Wave music. Select 24 point. 

Pull down the Style menu and select Bold. Pull it down 
again and select Title. Title will capitalize the first letter of 
each word. Pull it down again and select Shadow. 

Move the cursor until the hairlines show it is 7.9 em down 
and .2 em horizontally. It will be at the left end of the 
dotted rectangle that defines the spine. Click once to set the 
insertion point and type ''Shock.'' 

The logo of Shock is a lightning stroke. The funny-hat­
shaped symbol at the bottom of the stack of symbols on the 
left lets you draw irregular polygons. 

Select the symbol for drawing polygons. To draw poly­
gons, press down the mouse button to draw a line; you turn 
a corner by releasing the mouse button and pressing down 
again to do the next line. You can continue turning corners 
and drawing lines in any direction you want until you 
return to the first point. When your line touches the first 
point, MacDraw considers the polygon finished and selec­
tion handles appear. 

Move your cursor to a point inside the spine (the dotted 
rectangle) and draw a lightning bolt. You can probably do 
better than I did, but this is New Wave and refined packag­
ing is not required. 

···"'·····"'''"'"""'''"' ............................................ !.. . 
. ) "lllC!JtJ[l ~ .... J UL 

Figure 3.14 The label spine and the beginnings of a lightning stroke 
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Figure 3.16 Selecting a Pen 
pattern 
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Figure 3.17 Selecting a Fill pattern 
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MacDraw has some tools that can make the lightning 
bolt more graphic. We can thicken the line and turn it into a 
jagged pattern, and we can fill the inside of the figure with a 
lightning-like pattern. 

While the bolt is still selected, pull down the Lines menu 
and select the second thickest line (see figure 3.15). The 
lightning will appear with a thicker outline. 

Pull down the Pen menu. Select a jagged pattern, say the 
fifth pattern down in the outside column. 

Pull down the Fill menu, which will fill any figure with a 
pattern, and select the opposite diagonal bars (the fifth 
pattern down in the right-hand column). 

I like to put the artists on the smaller part of the label. Click 
on the T symbol to indicate that you want to write text. Pull 



STEP11 

STEP12 

STEP13 

STEP14 

STEP15 

STEP16 

STEP17 

MacDraw 63 

down the Font menu and select 12 Point. Pull down the 
Style menu and select Title. Move the cursor, which is 
now an 1-beam until the hairlines on the ruler are at 8. 8 em 
and .2 em. Type "Artists:." 

Click on the T to deselect what you have just typed. Pull 
down the Style menu and select Plain Text. Pull down the 
Font menu and select 9 point. Move the cursor until the 
hairlines are on 8.6 and 2.8 em. Type the names of the 
artists (Roger Carsner, Nat Ingalls, Tim Luntzel & Boreas 
van Nouhuys). You will need to type a Return between 
"Luntzel," and "&". 

The names of the cuts go on the more spacious side of the 
label. Click the mouse on the scroll arrow until the whole 
upper part of the label is in view. 

Pull down the Font menu and select 12 point. Pull down 
the Style menu and select Bold. 

Click on the T symbol. Move the cursor until the hairlines 
are on 1.2 and .2 em. Type ''Side 1.'' Move the cursor until 
the hairlines are on 4 and .2 em and type ''Side 2. '' 

Click on the T symbol again (to deselect "Side 1"). Pull 
down the Style menu and select Plain Text. Pull down the 
Font menu and select 10 point. 

To list the tunes exactly as they are in figure 3.20, move the 
cursor until the hairlines are at 1 and 2 em exactly. Type the 
names of the tunes. The length in minutes and seconds 
follows the name of each tune. Type a Return at the end of 
the length in seconds to begin a newline. 

Move the cursor until the hairlines are at 3.6 and 1 em. Type 
the names of the tunes on the second side and hit Return 
after the number of seconds. 
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Saue 
Saue As ... 
Reuert a 

··········-···-······· .. ·············· .. ·· .. ··········1 
Print One • 
Page Setup ••• 

Quit 8BQ 

Figure 3.18 Selecting Print from 
the File menus 

STEP19 

Put a moderately stiff paper in your printer (23 pounds is 
fine), and pull down the File menu and select Print (see 
figure 3 .18). The Print dialog box will appear (see figure 
3 .19). I assume you will use cut sheet paper to print the 
label. The values should correspond to figure 3.19; check 
OK. 

The !able should look like the one in figure 3.20. 

Quality: ®High 0 Standard 0 Draft CKJ 
Page Range: ® Rll 0 From: 0 To: D 
Copies: D 
Paper Feed: 0 Continuous ®Cut Sheet ( Cancel ) 

Figure 3.19 The printing dialog box 

' 

Dude 8:04 
Side 1 dobnnu ~ 7:sg 

Quiet Song 4:46 
Life WoLJid Be So Good 5:56 

Side 2 Rotk St.nok 3:56 
Destroy Rll the Nukes 16:46 
Mra Bi13:34 

-----------... -.. --- ..... -------- .. -· .. -------.. -------.- ... ----------.------ ... -

l"liltDtl~ 
t············································---·-···························· 
(i)ll[l0"(JO! Ro!l•r Ca•••r, N•t l•!lalls, Tim Luntzel 

e B•n•w: u•• N•uh•~w: 

Figure 3.20 The printed label 

Cut out the label along the solid lines. Fold it on the dotted 
lines. You will find it fits quite nicely into most plastic 
cassette containers. 



A Plan fora 
Kitchen 

STEP1 

STEP2 

STEP3 

Figure 3.22 Selecting Show Rulers 
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Once you have printed the label, you may not want to 
save the file unless you want to make a duplicate label. If 
you do, save the file as "Shock" as in step 8. 

This section tells you how to draw a plan for a simple 
kitchen. It illustrates some of the features that make Mac­
Draw handy for extensive design work, such as grouping 
and ungrouping objects, putting objects in front of or 
behind one another, and the use of a second file of often­
used stored objects. 

Open a new MacDraw file. 

Kitchens in the U.S. are not yet metric, so it is convenient 
for this drawing to use the scale of 1/2 inch = 1 foot. Pull 
down the Layout menu as in step 2 above and select 
Custom Rulers. The Scale of Ruler dialog box will 
appear. Cleek Custom. The dialog box will immediately 
expand. Click on Major Division Spacing 1/2, Number 
of Minor Divisions 6, then click on OK. 

Scale of Ruler: OK ~) 
Ruler: oon @Off 

®Inch 0 Centimeter 
OStandard ®Custom Cancel 

Zero Point: OLoclced ®Unlocked 
Major Dlulslon Spacing: 

®1/2 01 011/2 02 
Number of Minor Dlutstons: 

01 02 03 04 os ®6 
08 010 012 016 024 032 

Numbering Increments: 

®1 02 03 04 os 06 
08 010 012 016 024 032 

Figure 3.21 Scale of Ruler dialog box 

Pull down the Layout menu, se~ect Show Rulers, and 
drag the zero point in from the margin as in step 2 above. 

The L-shaped section of wall in figure 3.23 is the first 
thing you draw. I have put in the dimensions of a kitchen 
(shown completed in figure 3.43) so you can follow my 
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STEP4 

STEPS 

instructions more easily. The kitchen you draw will not 
have them. The wall is 4 feet long on one side, 5 feet on the 
other and, like all walls in this kitchen, 6 inches thick. It is a 
polygon, drawn with the funny-hat-shaped symbol at the 
bottom of the tools in the left margin. In drawing plans 
most things that are not rectangles are polygons. Although 
they are a little tricky at first, it is important to know how to 
draw them. 

···2-:-· r+========i <·····< 3 ····~········: ... ············ 

When drawing a dimensioned polygon, you click on a 
starting point and then line up the cursor at the next corner 
with the hairlines and click again. Moving the cursor more 
will start a second straight line from the end point, which 
you anchor by clicking once more. You continue this pro­
cess until you return to the starting point, for a closed 
polygon, or click twice, for an open polygon. 

Start at the zero point and draw the polygon as in figure 
3.23, drawing the sides in the numbered order and clicking 
once at each right angle. In figure 3.23 and in succeeding 
figures concerned with polygons, the arrows and numbers 
are to guide your strokes; they will not appear on your 
drawing. 

A 2-foot counter extends along this wall of the kitchen. 
Since this counter is rectangular, click on the rectangle 
symbol. Move the cursor, which turns into a tiny cross in 
the work area, until the hairlines are at 0 and 1. 5. Press the 
mouse and move the cursor until the hairlines read 2. 5 and 
10 (see figure 3.24). You will see the rectangle growing as 
you move the cursor. Release the mouse button. Don't 
worry that you have covered part of the wall-we'll get 
that back in a moment. 
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Figure 3.26 Selecting Bring to 
Front from the 
Arrange menu 
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Figure 3.24 Drawing a rectangular counter 

While the new rectangle is still selected, pull down the Fill 
menu and select the even gray color, the fifth pattern down 
on the left-hand column of patterns. Release the mouse 
button. 

With the arrow selected at the top of the tool symbols, 
move the cursor (now an arrow) next to a visible line of the 
wall. Click the mouse. The wall will be selected. 

• • • • • 0 • • • •• ~ •••••••• ~ 0 0 0 ••• 0 0 j ........ ~ ........ : . 

: : 

··it··· 

Figure 3.25 Selecting a partially hidden wall 

Pull down the Arrange menu and select Bring to Front. 
The outlines of the wall will appear but the lines of the 
counter still obscure the wall. With the wall still selected, 
pull down the Fill menu and select white. 
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STEP9 

: : : 

iJSd -..... -... ' ....... ' ....... -'.. ...... ' ....... . 
Figure 3.27 Drawing rectangular 

shelves 

STEP10 

STEP11 

STEP12 

STEP13 

STEP14 

·:········:········:· 

Figure 3.28 Selecting an arrowhead 

This corner of the kitchen has shelves 10 inches deep. 
Horizontal lines will mark the shelves. Click on the rec­
tangle. Move the cursor to the inside corner of the L-shaped 
wall you have already drawn. Move the cursor diagonally 
down and to the right until the hairline reaches 1 foot 4 
inches by 5 feet. Release the mouse button. 

While the new rectangle is still selected, pull down the Fill 
menu and select horizontal dashed lines, the seventh pat­
tern in the middle column. 

Following the procedure for drawing polygons in step 9, 
draw another L-shaped piece of wall 6 inches thick at the 
right-hand corner of the counter. Following step 8 fill it 
with white to show it is a wall. 

Following the procedure in steps 9 and 10, put a rectangular 
piece of shelving inside the elbow of this new wall and fill it 
with the horizontal stripes pattern. 

The gap in the wall of this kitchen is a passage to the 
dining room on the other side, and it must be labeled as 
such. The preset font for MacDraw is Chicago, which is not 
very suitable for even simple architectural drawings, so we 
need to change it. 

Pull down the Font menu and select Geneva. Move the 
cursor into the tool column and select T (for Text). Move 
the cursor, which will now turn to an 1-beam in the work 
area to show you can write text, and click somewhere 
above the passage. Type ''Passage''. 

Pull down the Lines menu and select the line with the 
arrow pointing to the right. This will tip your lines with an 
arrowhead at the ending point. 
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STEP16 
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Figure 3.29 Drawing an open 

polygon 
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Select the cross among the tool symbols; this makes any line 
you draw vertical or horizontal. Roll the cursor to a point 
above the passage, press down the mouse, and move the 
cursor downward; a line with an arrowhead pointing down 
will appear. 

The three-foot-wide counter on the left extends below 
what a single window can show, so we will have to draw it 
as an open polygon. Click on the polygon tool and begin 
with the hairlines at 6 and at 1/2 and draw a polygon as in 
step 9 with three steps, but do not close it. Instead, click the 
mouse twice at the last point, where the hairlines are at 6 
and 3 1/2 . 

STEP 17 Fill this open polygon with the same counter pattern as in 
step 6. 

STEP 18 The dishwasher is under the counter. Select the tool sym­
bol that shows a square with rounded corners. Move the 
cursor to a point just inside the upper left-hand corner of 
the new polygon, press down the mouse , and you will find 
yourself generating a rectangle with rounded corners. 

MacDraw gives you the power to draw rectangles with 
Figure 3.30 Drawing a rectangle rounded corners because Steve Jobs believes this shape is in 

with rounded corners the spirit of the ' 80's. 

STEP 19 We can fill in the diswasher with the counter pattern and 
label it to show that it is under the counter. With the 
dishwasher still selected, pull down the Fill menu and 
select the pattern we used for the counter, the fifth pattern 
down in the left-hand column of patterns (see step 6). Select 
the T (text symbol) and click the mouse in the open space to 
the right of the dishwasher. Type "Dishwasher". As in step 
15, select the cross and draw an arrow from right to left 
pointing at the dishwasher. 

STEP 20 Move the view down by scrolling tintil only the bottom end 
of the first wall is visible. 

Scrolling is what allows you to make MacDraw 
illustrations many times the size of a sheet of paper. 
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STEP 21 

Figure 3.32 Drawing a window 
with dotted lines 

STEP22 
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Figure 3.31 Moving the view to draw the middle part of the kitchen 

There is a 3-foot w indow above the sink. Draw a rectangle 
as in step 9 to represent the window (see figure 3.32). Pull 
down the Pen menu and select the sixth pattern down on 
the left side (scattered do ts); the do ts show this as a win­
dow. 

Now let's finish the kitchen. Scroll until the end of the 
counter is barely visible and the 13" mark on the rulers is 
showing. 

. . . 
t=::i"-i· ..... : ........ : ........ :·· ...... :· ..... ··: ........ : ........ : ..... ... ~· · .... ··~ •· ...... :· ....... : ........ : ... . 

... : ....... : ..... L .... ) ........ l ..... .. : ....... ; ....... , ........ ( ...... ! ........ : ........ : .. . 

1 

I i ; i ~ J i i: I :: :j 
Figure 3.33 Lowering the view to start the bottom half of the kitchen 
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STEP26 
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Use the polygon to draw the U-shaped lower wall of the 
kitchen; the wall extends to 13 feet on the bottom of the 
screen, to 10 feet on the right and back up to 11 feet. It is 6 
inches thick. 

With an open polygon as in step 16, complete the counter 
with the strokes in figure 3. 34. Pull down the Fill menu and 
select the counter pattern, the fifth pattern down on the 
left-hand column. 

II o t I .I 2J I 3J ~~ I 51 I 6 I 7 I a I 9 I 
··:········:········:·· 

1- . . . 
~ 

. . . 
··:········=········:··1+···: ........ : ......... : ........ : ........ : ........ : .. .. 
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~ ... 

1-

~ .. :1 ·····!· .... 5 ·1+···::··· .. ···: .................. ; ........ :······ 

..... l;tiq ...... : ... H·.: ........ ~ ........ ~··I+···' ........ ; ........ : ..... 1 ... ; ........... . 

-
1"'-'.1.11·····::····1·1··:········:· .. ·····:··~======i····· ... 

- . : : ~ ' ....,12~·-···::····~l··j········~········j··· .... ·j········j····· 3 ·········:········:········ 
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Figure 3.34 Drawing the other half of the counter 

Select the rounded rectangle and move the cursor so the 
hairlines are at 6 feet, 2 inches and 8 inches; press the 
button and draw the rounded rectangle diagonally down 
until 7 feet, 10 inches by 3 feet, 4 inches. The sink will 
appear. Select T, move the cursor a little to the left of center 
of the sink, and type ''Sink''. 

If you are doing work that resembles drafting, you will 
want to use a second file that contains parts you use often 
that you have already drawn, or that have been bought on a 
commercial disk with prepared images. This kitchen is not 
a big enough deal to justify such a file, but I will show you 
how to set it up here in order to illustrate the power of the 
Macintosh windows. 

Pull down the File menu and select Save As. The Save 
dialog box will appear. Type ''Kitchen'', and then check 
Save. 
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STEP27 

Figure 3.35 Making a New file 
from the file menu 

STEP28 

STEP29 

STEP30 

STEP31 

STEP32 

Figure 3.36 Drawing a rectangular 
stove top 

Pull down the File menu and select New. 
A new file will appear. 

Select the circle from the tool-drawing symbols. To make a 
true circle, not an oval, hold down the Shift key and draw a 
circle 1/3 inch in diameter. Pull down the Fill menu and 
select a fire-like pattern, the third from the bottom in the 
center column. This is a gas burner. 

With the arrow, move the cursor above and to the right of 
the burner. Press the mouse button. The cursor turns to a 
pointing hand. Move it down to the right as if you were 
drawing a rectangle. A flashing rectangle appears, which 
defines the area you will later cut. This is one way to select 
an object. 

Pull down the Edit menu and select Copy. The image of the 
burner is now in the memory of the program; you can still 
extract it to paste it somewhere else. 

You may have noticed that when you made the new 
file, so far untitled, that the upper edge of the file left the 
top edge of the Kitchen file visible, like papers stacked 
slightly ajar on a desktop. 

Move the point of the cursor arrow into the little bit of 
kitchen showing at the top of the screen and click the 
mouse. The kitchen file will appear. Note at the bottom of 
the screen the edge of the other file. 

Select the square, and move the cursor until the hairline is 
at 10 feet, 2 inches, and 2 feet, 2 inches. Press the mouse and 
move the cursor diagonally to draw a rectangle in the space 
at the end of the counter. 
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STEP34 

STEP35 

Figure 3.37 The burner in place 
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STEP38 
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Figure 3.38 Another open polygon 
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Select the pointer and move it into the rectangle you have 
drawn from the stove. Click the mouse button. You will 
not see anything happen. Although you did not see any­
thing happen, you have located the point where you will 
paste the burner; this is one of the few occasions in Macin­
tosh software where you get no real feedback on what you 
have done. 

Pull down the Edit menu and select Paste. The burner will 
appear on the stove. Little black squares around it will 
show that it is selected. It will probably not be just where 
you want it. 

Move the cursor into the center of the burner. Press the 
mouse button and move the cursor. A ghost image will 
appear. Roll the mouse to move the ghost image into one 
corner of the stove. Release the mouse. The burner has 
followed the ghost. 

Since the grid is in force, the burner is stopped from 
ending up in a messy place. 

Repeat the above steps three more times to install the other 
three burners. 

Draw a rectangle about 3 feet by 2 feet inside the L of the 
wall next to the stove. Select the T, click the mouse inside 
the new rectangle, and type ''Refrig. ''. 

Begin the right wall of the kitchen by drawing an open 
polygon as in figure 3.38. 
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STEP39 

Figure 3.39 Selecting a thick line 

STEP40 

Figure 3.40 A door 

STEP41 
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Figure 3.41 Selecting a group of 
objects 

The kitchen has to have doors. Pull down the Lines menu 
and select the second thickest line. 

Select the diagonal line symbol and draw a thick line from 
the corner of the door, hairlines at 11 and 10, to place where 
a door might be half open, with the hairlines at 9 and 12. 
Select the arc symbol. Pull down the Lines menu and select 
the thin line, second from the top. Draw a thin-lined arc 
from the free edge of the door, hairline at 9 and 12, to the 
edge of the wall, hairline at 8 and 10. 

The kitchen has another door, as we will see shortly. 
In a small plan like this it would be useless just to copy the 
door you have made into the other opening. But if you 
intended to draw more plans, it would be best to copy the 
door onto your spare parts file. To show how MacDraw 
works, we will do that. 

With the arrow symbol selected, move the cursor to a spot 
a little to the left and above the doorway. Press the mouse 
button. The cursor becomes a pointing hand, which shows 
you that you can select one or more objects. Move the 
cursor diagonally down and to the right. A flashing rec­
tangle will appear around the door and its arc of closing 
(see figure 3.41). When the rectangle encloses them, release 
the mouse button. Now they are selected. 
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Figure 3.42 Selecting group 
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With the door and its arc still selected, pull down the 
Arrange menu and select Group (figure 3.42). Note that 
the black selection squares shift to bracket both the door 
and the arc. Now you can treat them as a single object. 

The lower edge of the untitled file of spare parts should still 
be visible just below the edge of the "kitchen window." 
Click the mouse there and the file with the burner on it will 
rise to the front of the desktop. 

Click the mouse somewhere else on this file and then pull 
down the Edit menu and select Paste. The door will 
appear. 

Return to the kitchen window by clicking on the little bit 
that appears above the edge of the parts file. 

Scroll to bring the top of the kitchen back to view. Draw a 
small open polygon, as in step 16, to close the wall on the 
lower right and leave a three-foot opening opposite the 
dishwasher. 

The second kitchen door opens in, so we have to 
reverse it. Probably you would want to keep both a right­
and a left-handed door in your parts file. 

Return to the parts file as in step 43. Click somewhere else, 
pull down the Edit menu, and select Paste. Since the door 
still occupies the memory space set aside for cutting and 
pasting, a second door will appear. It will be selected. 

Pull down the Arrange menu and select Rotate Right. 
The door will rotate 90 degrees right. Pull down the 
Arrange menu and select Rotate Right again. Your door 
will be a mirror image of its former self. Of course you 
could have done the same thing by rotating left twice. Pull 
down the Edit menu and select Copy. 
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STEP49 

STEP 50 

Return to the kitchen by selecting its visible edge above the 
parts file. Move the cursor into the open doorway. Click the 
mouse. You will see the cursor turn, for a moment, into the 
hand; this is the visual feedback that lets you know you 
have selected a spot for pasting. Pull down the Edit menu 
and select Paste. The door will appear, but probably not in 
the right spot. 

Move the cursor to the middle of the door, press the mouse , 
and drag the ghost image to the correct spot. 

The kitchen is done. If you plan to build it you might 
want to add more shelves, but I will leave that to you. 

To print the plan, pull down the File menu and select 
Print. Use the procedure outlined earlier for the print 
dialog box. The kitchen should look like figure 3.43. 

·· ····· :··· ·····:···· ···· :········:····· ···:··· 
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Figure 3.43 The completed kitchen 
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Spreadsheets 
in General 

A p T E R F 0 u R 

fV1 ultiplan 

This chapter starts with a simple task: building a small 
table that predicts profit and loss with Microsoft Multiplan. 
It then continues with what appears to be a complicated 
task: creating an on-line version of the well-known IRS 
form 1040, which will prove less difficult with Multiplan 
than you might expect. 

Electronic spreadsheets are the most widely used form of 
personal computer programs. The spreadsheet idea is beau­
tifully simple. The computer draws an array of lines on the 
screen that looks like the lines of an accountant's record 
book (see figure 4.2). You can write numbers in the cells 
just the way an accountant does and you can add headings. 
But electronic spreadsheets give you power over the num­
bers. You can have a cell ten places down column B show 
the sum of the cells above it, or a certain percent of that 
sum, or the square root, etc. In fact, their are untold pos­
sibilities for this simple device. Spreadsheets have been 
created to solve some very complex business, engineering, 
and scientific problems, but they are most widely used for 
simple accounting and simple-to-complex cost projections. 
A spreadsheet makes it easy to change one number and see 
how it affects the other numbers, or to change a formula 
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The Character 
of Multiplan 

and see how the numbers affect each other under new 
rules. As a result, they are often used where someone is 
trying to see the effect of some change, e.g., what if we 
raised the price of our product? But they are almost as 
widely used just to save arithmetic. 

Multiplan on the Macintosh has two outstanding virtues 
that make it shine when compared to most other 
spreadsheets running on other personal computers. 

Most important, the visual, hand-eye quality of work­
ing with a Macintosh makes working with a spreadsheet 
much more like doing something by hand and less like 
mathematics. The commands of a typical spreadsheet con­
sist of esoteric strings of letters and numbers. For example 
to erase a certain column you might type: "/ZA10:A20", on 
the Mac you would erase it with a single rolling motion of 
the mouse. 

Second, Multiplan gives you the power to link 
spreadsheets. Each Multiplan spreadsheet is a single file. 
For example, the 1040 tax form file can be linked to another 
spreadsheet, Schedule A, for example, so that a certain cell 
in the 1040 will show whatever occupies the linked cell in 
schedule A. As you fill out the various forms that are sub­
sidiary to the 1040, the values will automatically enter the 
master form. 

When you buy Multiplan, you get a single, copy-pro­
tected diskette. A card comes with the product that entitles 
you to send away for a second disk at a modest fee, cur­
rently $10. If you buy Multiplan you should certainly take 
advantage of the offer. 

These exercises assume you work on a Multiplan mas­
ter diskette as supplied by Microsoft. Although you can't 
move your Multiplan application off the diskette it came 
on, you can move your files to other Mac diskettes. 



A Simple Model: 
Thorn &Co. 
Profit and Loss 
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STEP2 

Multiplan 79 

The management of Thorn & Company has created a sim­
ple template of the company's profit for the next few years. 
They base it on the profit for this year, and expected change 
in sales and the cost of goods. The template enables the 
company to enter only last year's numbers, see what their 
expectations led to, and change their expectations. 

You will create a Multiplan template that projects the 
profit and loss of Thorn & Co. for the next five years. It will 
look like figure 4.12. At first I will describe the steps very 
carefully, naming each keystroke and mouse motion so 
there will be no ambiguity; later, when you begin to repeat 
parts of the process (for example, setting up a row of cells 
by the same steps as you set up the preceding row), the 
description will grow less detailed. 

Here is the step-by-step process: 

Insert the Multiplan diskette and turn on the Mac. The 
catalog of the Multiplan Master diskette will look similar to 
figure 4.1. Profit is an example file used in the Multiplan 
manual. 

10 Multiplan Master 
13items 3141(- dtst 

~I 
Multiplon Multtplon .IW!p 

lllh 
UlliJ 
pt"Oflt 

Figure 4.1 The contents of the Multiplan Master diskette 

Q 

I 
Roll the mouse until the arrow is in the icon labeled Multi­
plan and press the mouse button twice (double click). An 
untitled Multiplan spreadsheet will appear. 

The names of the menus are at the top of the sheet. The 
numbers across the top and down the side name the cells. 
Thus, the cell that is black is called row 1, column 1 or RlCl. 
The black cell is selected, and if you type something it will 
appear there. RICI in the upper left-hand corner indicates 
the row and column address of the cell you have just 
selected. The blinking insertion point is in the rectangle on 
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...... ............... 

Figure 4.2. A Multiplan spreadsheet menus. 

the upper edge; anything you type appears here as well as in 
the cell you have selected. The hollow cross is the form of 
the cursor when it is on the spreadsheet. 

Roll the mouse until the hollow cross is in the first cell 
under column 3 heading in the top row. Click it. The 
identification of the current selected cell in the upper-left 
corner changes to R1C3. 

Roll the mo use until the cursor , now an arrow, to uches the 
word Format and then press the mouse button. The 
Format menu w ill appear. (This process is called pulling 
down the Format menu.) Holding down the mouse button, 
roll the pointer down the menu to Align Center, which 
will reverse black and w hite as you touch it (figure 4 .3). 
Release the mouse button . (This process is called selecting 
Align Center.) 

Type "Thorn & Co. Profit Forecast ". Note that the cell 
displays only what there is room to show, w hile the feed ­
back line near the top shows all you have typed. 
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File Edit Selef:t Format Options Caltl 

R1C3 ® Thorn & Co. Profit forec8st 

Untitled~ 

1 2 .. 
1 

--...;_~ ···· ··· ·· ·· ·· · ······ ·· ··· ·· ·········· 

._2___j ........ .. .... .... : .. ..... ... ........ : ........... ... ... . : .. ...... .... . . 
3 : : : 

----~ ·············· · ········ · ··················· ··· ··· · · · ··········· ········ . : : : 
Figure 4.4 Typing text in a Multiplan cell 

Select cell RICI again. The typing disappears from the feed­
back window and appears centered around cell RIC3. 

When text spills out of a cell, it will appear in adjacent 
cells if they are empty. 

----- ------------
--======---=:.::=::-_~--=-=-- _-::.---:- :---~~- --- --

....... ......................... .. .. ............. .. ..... . . . . . . . . . . 
············································ ···· ·················· ·· ····· ··· . . . . 

Figure 4.5 Centered text appearing in adjacent cells 

Cell RICI is selected . Press Return. Pressing Return selects 
the next cell down the column. Press Return again to leave 
a blank, then type "Sales". After another Return type: 
"Cost of Goods". 

lf you make a mistake, roll the cursor up to the feed­
back line in the window. It will turn into the 1-beam there, 
indicating that you can edit text in the usual manner. 

Press Return again and type dashes (or minus signs or 
hyphens-they are the same character) to fill up 5 cells. If 
you hold down the key the character will repeat. If you go 
too far, move the cursor up to the feedback line , insert the 
blinking insertion point at the end of the dashes, and back­
space. 

Return to RIC6 and type the following: "Profit", 
press Return; "% Profit", press Return; a line of dashes , 
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press Return; " Average", press Return ; and " Profit". 
Except for the numbers, the screen should look like figure 
4.6. 

11 

~----­----- Untitled - -

2 3 4 
Thorn & Co. Profit Forecast ........... .................... ....... .......... ..... .... ..... .... .. ...... ...... 

~ 1984 ~ : : .................... ............................. .. ..... . .. .... .... ... .......... 
Sales : 1 00 : : : ---- ... ..... ....... .... .......... . ... ......... . . . . . . r·,,, Cost of Goo 

................. ...................... .... . ..... . .. .. ... ...... ... .... .... .. .... . . . . 
Profit : : : : .... .... ...... . ....... .. ......... .. .. .... ... ........ ..... ...... ....... ..... ..... 
'l.Profit : : : : 

...... .. ........... ................ .. ... ... .. .. ... ... ... ..... .... .... ........... . . . . 
~-~~~.':!.~~ ---· ·=· ········ ......... : ..... ... .......... : ......... ......... : ... . 
Profit : : : : 
··· ···· ··· · ·· ·· ··· ·· ······ · ········ ·· ···· · ···· ·· ·· ·· ····· ···· · ··· ··············· . . . . . . . . 

Figure 4.6 Numbers in general format 

Roll the cursor to cell R1C2, and press the mouse button to 
select it. Type " 1984", press Return; type "100", press 
Return; and type " 50" (see figure 4 .6). These are all the 
numbers you need to generate this table! (Often you spend 
more time typing in the headings for spreadsheets than in 
entering in the figures themselves.) 

Most of the figures on this table should appear as dollars 
and cents . Roll the cursor to R3C2 (where it reads " 100" ), 
press the mouse button and , holding the button down, roll 
the curso r to RIOC5 , the lower left-hand corner of our 
table . Release the mouse button. This diagonal roll selects 
the entire rectangular area. 

Pull down the Format menu and select Dollar. 

Figure 4. 7 Selecting the dollar format 
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Figure 4.8 Inserting a formula into 
a cell 
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Select cell R2C3 (the cell to the right of "1984"). Type 
'' ,, = 

Typing an equal sign (=)as the first character of a cell 
tells Multiplan that the rest of what you type is a formula; 
the formula will govern the contents of that cell. The bold 
x in a circle appears next to the feedback line to remind 
you that you are typing a formula. 

Roll the cursor to cell R2C2 (where "1984" appears) and 
select it. 

You will notice the mysterious text "RC( - I)" appears 
in the cell and in the feedback line (see figure 4.8). This is 
the name of the cell that contains '' 1984'' relative to the cell 
that contains the formula. It means that it is in the same 
row and one column to the left (minus one column since 
Multiplan counts left to right). The cells locate one another 
relatively because when you copy a formula from one cell 
to another, as we shall shortly do, it is the location relative 
to the new cell that counts. Fortunately, on the Macintosh 
you don't have to worry about these relative locations very 
often, because you just point at the cells you want with the 
mouse. (On computers with more limited pointing these 
notations can drive you crazy.) 

Note that you can't conclude the process of entering a 
formula by selecting another cell: if you do, the system will 
think you want to add that other cell to the formula. You 
must use Return or Tab, which selects the cell to the right. 

Type"+ r' and press Return. You will notice that "1985" 
(1984 + 1) replaces the formula in the cell once it is 
unselected. Select it again if you want to see the formula. 

Thorn & Co. has simple and optimistic forecasts. They 
believe their sales will rise each year by 10% and their cost 
of goods, which includes all their costs, will rise by 5%. 

The formula for future sales is: sales times 110%. With cell 
R3C3 selected, type "= ", select the cell with "100" in it 
(R3C2), type "*1.10", and press Return. The "*" is the 
symbol for multiplication in many computer programs 
because it prevents confusion with the character (x). 

The formula for future cost of goods is: CoG times 105%. 
Similarly, with cell R4C3 selected, type''='', select the cell 
with "50" in it, type "*1.05", and press Return. 
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Figure 4.9 Profit in dollar format 
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Figure 4.11 Selecting and filling an 
area with a formula 
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The formula for profit is: sales minus CoG. Select the cell to 
the right of "Profit" (R6C2). Type"=", select the cell that 
contains "$100", type "- ", then select the cell that con­
tains "$50" and press Return. Presto, the profit appears. 

The formula for% profit is Profit Total Sales. Select the cell 
to the right of"% Profit" (R6C2). Type "= '', select the 
"Profit'' cell that contains "$50", type"/", then select the 
cell that contains ''$100'' and press Return.(''/'' is the usual 
symbol for division because most computers can't read or 
write the normal division sign.) The % profit appears, but it 
is in dollar format. 

Roll the cursor into the column box with the number 7 in it. 
Select that box. This selection governs the whole row. (You 
can select a whole column the same way by selecting the 
row box number). 

Pull down the Format menu and select Percent (figure 
4.10). We will leave "Average Profit" until we have some­
thing to average . 

Roll the cursor to the cell with "1985" in it (R2C3), select it 
and with the mouse button still down, roll to the cell in 
column 5 above the dotted line (R4C5) to select the whole 
area. Pull down the Edit menu and select Fill Right. Multi­
plan will fill all the values and the formulas to the right. The 
formulas will be adjusted to their new locations and your 
table will be complete. 

Select the rectangular area beginning with the cell that 
contains the profit figure (R6C2) to the cell that will hold 
the percent profit for 1987 (R7C5); pull down the Edit 
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menu and select Fill Right. Your profit and percent profit 
for each year will appear. 

Now that you have some figures to work with, you can 
establish average profit for these years. Spreadsheets have 
built-in functions that can be entered in equations. Multi­
plan has about 40 such equations. You can find them in the 
manual, or by pulling the Edit menu and selecting Paste 
Functions, which will show you a list. One of these func­
tions is average. 

Select the cell to the right of the cell that has "Profit" in it 
(R10C2) and type "= Average(" [only one parenthesis is 
correct]. Then select the cell that says 50.00% (R7C2) and 
all the other cells that contain percent profit. Their 
addresses appear in the feedback line as they are selected. 
Then complete the parenthesis by typing '')''. Press Return. 

You may have noticed that the sin "Cost of Goods" disap­
peared when you entered a number in an adjacent box. The 
columns' width is adjustable. Move the cursor to the row of 
numbers that heads the columns. The cursor changes to a 
bar with arrows coming out of each side. Place it over the 
line that separates column 1 from 2 and roll it a little to the 
right. A second line appears to show the motion. Release 
the mouse button and column 1 will widen to accommo­
date the title. The other columns will adjust automatically 
to the left. 

To save the file, pull down the File menu and select Save 
As (this is the first time you have saved the file and you need 
to give it a name). The file-save dialog box that appears is 
the standard box in Mac applications except for the SYLK 
option, which is important only when you are moving files 
from other computers (see the chapter on communications 
below). Type "Thorn & Co.", check Save, and your file is 
on the disk. Thorn & Co.'s profit and loss forecast is now 
complete. 

You may want to print the forecast. Multiplan offers 
some choices about how you can print it. Figure 4.12 shows 
an uncluttered version you can make as follows. 
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New Column Width: wl ~"--------' 

0 Set Rll Columns to Standard Width 

Figure 4.14 Multiplan column 
width dialog box 

Sales 
Cost of Goods 
Profit 
I Profit 

Average 
Profit 

Thorn & Co. Profit Forecast 
1984 1985 1986 

$100.00 $110.00 $121.00 
$50.00 52.5 55.125 
$50.00 $57.50 $65.88 
50.001 52.271 54.441 

53.311 

Figure 4.12 Printed profit forecast 

Pull down the File and select Page Setup. 

1987 
$133.10 

57.66125 
$75.22 
56.511 

Click on the squares beside Print Row and Column Num­
bers and Print Gridlines to omit those functions, then 
click on the OK box. 

0 R4 Letter OK Paper: ® us Letter 

0 us Legal 

Orientation: ®Tall 

0 International Fanfold 

0 Tall Rdjusted 0 Wide (Cancel ) 

0 Print Row and Column Numbers 

0 Print 6rldlines 

Page Header: I 
~==========================~ 

Page Footer: 
~-------------------------------~ 

Left Margin: !=I 0=. 7=5==:::::! 

Top Margin: ..... 1• ___ -J 

Right Margin: l=l 0=. 7=5 ==~ 
Bottom Margin: L..jl ___ ..J 

Figure 4.13 Multiplan page setup dialog box 

Select the whole table by selecting the upper left-hand 
corner box (RlCl) and rolling the cursor diagonally to the 
lower right (RIOC5). 

Pull down the File menu and select Print. Check boxes or 
circle to match figure 4.15, unless you are using continuous 
paper (roll or fanfold). If you are using continuous paper, 
check the Continuous circle. 

Check OK. If you are using cut sheets, a dialog box will 
ask you to insert paper, whether or not a sheet is in the 
printer. Insert a sheet if necessary and then check OK. The 
spreadsheet will begin printing. 



The1040 
Form 

Multiplan 87 

Quollty: ®High 0 stenderd 0 Droft ~ 
Page Benge: ® Rll 0 From: D To: D 
copies: 0 
Peper Feed: 0 Continuous ®Cut Sheet [ Concel ) 

181 Print Selection Only 

Figure 4.15 Print dialog box 

The great value of electronic spreadsheets is that you 
can play around with them. For example, if you change the 
1984 cost of goods from $50 to $80 (by selecting that cell, 
typing "80", and pressing Return), you will find the 1987 
profit instantly falls to $92 and the average profit to 25%. 

By following the steps below you can create an online 
version of the IRS 1040 form. The form used here was 
distributed in 1984 for the 1983 tax year. Future forms will 
differ, but the changes from year to year are small, and if 
you have gone through the process of creating the form 
once you will have the skill to update it. 

I designed this on-line version to look like the IRS 
form. Of course, it does not look exactly like it, but it's easy 
to copy from the on-line version onto IRS paper. That 
means a little extra work in setting up the electronic ver­
sion; for example, most IRS lines are numbered twice, once 
on the left and once on the right in the paper version of the 
form, so I have done it here also. The extra work is time 
well spent to make the user more comfortable. When you 
type in those extra line numbers, think of yourself as a 
programmer who is doing a little extra to make "a user­
friendly interface.'' 

A copy of an original 1040 would help you to follow 
the exercise. 

Numbers in the 1040 come from three sources: your 
head, other forms, and computation on other boxes in the 
1040. This form can't read your mind, of course, so num­
bers that come from your head-like the number of depen­
dents or how much of an overpayment you want to allocate 
to next year's taxes-must be supplied. 

You can set up any IRS form as a Multiplan 
spreadsheet. Space does not permit me to give instructions 
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beyond the 1040, but once you have gone through the 
process of creating an on-line version of the 1040, you 
should be able to develop other forms. With one exception, 
the 1040 illustrates all the issues to be found in the impor­
tant IRS forms. The exception is the taxable income tables 
where you look up your tax after you have computed your 
taxable income. These tables certainly can be on-line and 
have been, but as a practical matter it is a difficult, tedious, 
and error-prone process for a person to build them alone. 

With Multiplan you can link spreadsheets; thus, you 
can arrange for the total on another spreadsheet to appear 
in the appropriate box on the 1040. 

The on-line version below does all the computing for 
you inside the form, and provides some automatic error 
checking and warnings as well. If you have prepared and 
linked to supporting forms, filling out the 1040 involves 
supplying about 25 numbers (depending on the number of 
your dependents, etc.), while the on-line form supplies the 
remaining 40 or so. It does not make arithmetic errors. Of 
course you could make errors in building formulas that 
would create errors in your tax return, but Multiplan's 
error checking should warn you in the case of many mis­
steps. 

In order to use this form for your next year's taxes, 
you would have to create it on-line, make the changes 
necessary between this year and next, and create the neces­
sary supporting forms. You would then have to fill in the 25 
or so numbers that have to be entered by hand in this form, 
and more in the other forms. 

The on-line form lets you play around with different 
numbers. What if we put some more money in an IRA and 
gave more to the charity of our choice? Couples can 
explore whether to do a joint or single return, or whether 
to itemize deductions. Type in the different numbers in the 
1040 and supporting forms and their effect on the bottom 
line appears promptly and unambiguously. 

When you are satisfied with your presentation to the 
IRS, copy the numbers from the on-line version onto the 
IRS paper form. 

If you are interested in doing this exercise in order to 
understand what the computer or program can do, but 
don't really want to create a 1040, then do only the steps in 
"Setting up the Format" to "Tax computation" and then 
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skip to "Printing your form." You will still use all the basic 
functions discussed in this chapter. 

Setting up the Format 

Insert the Multiplan diskette and turn on the Mac. The 
catalog of the Multiplan Master diskette should look like 
figure 4.1. 

Roll the mouse until the arrow is in the icon labeled Multi­
plan and press the mouse button twice (double click). An 
untitled Multiplan spreadsheet will appear (see figure 4.2). 

Multiplan allows you to print on the width of the paper, 
which is necessary to accommodate the 1040. Pull down 
the File menu and select Page Setup (figure 4.13 ). Check 
Wide and OK. 

For Thorn & Co. you set column widths by eye, but the 
1040 requires more careful spacing. Roll the cursor into the 
heading box for column 1 and click it to select the whole 
column. Pull down the Format menu and select Column 
Width. The column width dialog box will appear (figure 
4.14). The area to enter the column width is black, so you 
can replace the old number by typing "8". Then check OK. 

You will want to center text in some columns. Select col­
umn 2, pull down the Format menu, and select Align 
Center. 

You will want to have dollar and cents figures with appro­
priate commas in some colun;1ns. · Select column 5, pull 
down the Format menu and select Dollar. Pull down the 
Format menu again and select Commas. 

In similar fashion set the width, alignment, and number 
formats of the columns according to the following table. 
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Figure 4.16 Entering the Filing 
Status heading 

STEP2 

STEP3 

Column Width Alignment Number Format 

1 8 Left 
2 5 Center 
3 35 Left 
4 5 Center 
5 12 Right Dollar, Commas 
6 5 Center 
7 12 Right Dollar, Commas 

I have omitted the boxes for contributions to presidential 
campaigns. 

Filing Status 

Because it does not use the columns the way the rest of 
the 1040 does: 

Select cell R2C1 and type "Filing"; press Return and type 
"Status"; press Return twice and type "Check"; press 
Return and type "only one"; press Return and type "box.". 
The screen should look like figure 4 .16. 

Select the box in column 3 opposite "Status" (R3C3) and 
type "Single". Also enter the other line of information in 
column 3. Selecting the cell below with the mouse confirms 
the entry above. Remember that if you make a mistake in 
typing you can correct it in the feedback line. 

Select the cell below ''box.'' (R8C1). Hold down the dash(-) 
key long enough to generate dashes across column 7. You 
can check on column 7 by clicking twice on the arrow 
pointing right in the bottom right corner of the window. If 
you have too many dashes or too few you can click in the 
feedback line and insert more or backspace to remove 
them. The form is 81 spaces wide, so you need only 81 
dashes. However, if you add too many you can scroll to 
column 8, select the cell with extra dashes, and type a space 
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Figure 4.17 Shows how this section should look when completed. 

to make them disappear. Figure 4.17 shows how this sec­
tion should look when completed. 

Saving and Naming 

By this time you have invested some time in this file , 
so it is a good time to save and name it. 

Pull down the File menu and select Save As. Type in the 
name " 1040." Check the Save box. You will notice that the 
name on the screen has changed to 1040. Many computer 
systems, by the way, will not let you name a file with a 
number . 

Exemptions 

Putting the exemptions section of the form into the 
on-line version gives us a chance to demonstrate simple 
error checking and the use of the IF construction. 

Select the lOth box in the first column (RlOCl) and type 
"Exemp-"; press Return and type "tions". 

Select the top cell of column 2 (R9C2) and type "6a" . Press 
Return three times. Type "6b". Press return four times. 
Type "6c", "6d ", and "6e" in the next three rows. 

Select the top cell in column 3 (R9C3) and type ·'Yourself' '. 
Press Return and type "65 or over"; press Return and type 
" Blind". Roll the mouse to select the cells that contain 
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" 65" and " Blind" ; pull down the Format menu and select 
Align Right. 

As before, define the cells for 65 and blind for your spouse, 
beginning with the cell to the right of 6b (R12C3). In the cell 
below " Blind" type " 6a + 6b". 

Select the cell in column 4 opposite 6c, type "6c" , press 
Return; type 6d, press Return; and type " 6e" and press 
Return. 

Enter ''Number of dependent children'' , ''Number of other 
dependents", and " Total number of exemptions" in the 
cells in column 3 (starting at Rl6C3), but do not align them 
right. 

At this point we can enter our first formula . One of the 
most important functions in the 1040 is SUM, which adds 
together a group of cells. In functions , "SUM" is as good as 
"sum" , so you do not have to worry whether it is upper or 
lowercase. 

Select the cell in column 4 nextto " 6a + 6b" (R15C4). Type 
" = sum(". Then select the five cells above it (RIOC4 
through Rl4C4). \Vhen you make a selection while building 
a formula , a fine line w ill appear around the selection 
(figure 4.18). Type ")" to close the parenthesis that defines 
what you want to sum up, and press Return. 

The numeral zero will appear in the box, since there 
are no entries in 6a + 6b. If you type numbers in any of the 
selected boxes, their sum will replace the zero. 

-:;:. ____ --- - ~-- --
~ - - --- ----=-~ - - 1040 

~- __ =-----------._ 
--- - --=--

· · · · ·· · · · · · · · · ~ · · ' fi~· · · ~ v~-~-~~~-, r· · · · · · · · · · · · · · · · · · · · · · · · · ·· · · · · · · · · · · · · · · · · · · · · · · r·········· .. ······! · 
~~:~~P.~: ::\ :: :::::::::::::: ::::::::::::::::::::::::::::: :::::::: :: :~:s: :~~ :?.~~~ I: : :: : : :: : i: 
lion:~ : : Blind ! ! 

Sb ,.,,,. OSO:.~;~:lJ 
.... .. ........ : .. . ~.C:: ... : ~u.'!l.~~~- .C?.~ .c:'.~P~_n_d~n- ~ . c_h_H c:'.r~n ............... .. : ... ~.C:: ... :. 

Figure 4.18 Selecting cells to enter a formula 
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You can enter cells into a formula by selecting them 
one by one. When you select cells one by one, Multiplan 
assumes you want to add them and supplies a '' + '' in the 
formula. 

Select the cell in column 5 adjacent to 6e {Rl8C5) and type 
"= (". Then select one by one the cells in column 5 adja­
cent to 6d (RI7C5) and 6c (R16C5) and the cell in column 4 
adjacent to 6a + 6b (R15C4). Type ")" and press Return. 

Note that $0.00 appears in the box. The column was set to 
dollar format earlier, but it should be in a simple number 
format. Select the box with $0.00 and then pull down the 
Format menu and select General. 

Multiplan gives you the power to name cells. You can 
then use the name in a formula. Considering the arcane way 
spreadsheets refer to cells relative to one another, names 
are very useful when you have a large spreadsheet (like the 
1040) and want to cite a number from a cell off screen. 

Select the cell in column 5 next to 6e (Rl8C5). Pull down 
the Select menu and select Define Name. The name defi­
nition dialog box will appear (figure 4 .19). Multiplan sug­
gests 6e as a name because it always suggests the contents of 
a nearby cell. Ignore the guess and type ''Ttlexemp'', then 
check OK. 

Draw a line of dashes across row 19 as you did for row 8. 
The exemptions section should look like figure 4. 20. It's a 
good time to save your file if you haven't yet. 

: 6a :vourself 

10 ~~~:~P.~:::1:::::::::~::::::::::::::::::::::::::::::::::::::::::::::~$:~r.:~~~r. ::::::::: :::::::::::::::: 
II tions : : Blind 

12 :::::::::::::::: ::~~::: :~~~:~~~ :::::::::::::::::.:::::.::::::::::::::::::::::::::: ::::::::: :::::::::::::::: 
13 : : 65 or over 
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Figure 4.20 The exemptions section 
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Income 

Now we come to the part of the form that is simple in 
structure and where our formulas begin to pay off. 

So far selecting boxes has led you down the rows, but 
now we are going to take a larger jump. 

Move the cursor to the scroll bar beneath the scroll box. 
The cursor turns into a pointing hand, which is Multiplan's 
form of the cursor when it is used for scrolling. Click once. 
One click should bring row 20 to the top of the screen. 

Select cell 21 in column (R21Cl) and type "Income". The 
dashed line between rows 28 and 29 indicates a page break 
in the final printed version. For clarity select the first cell in 
row 30 (R30Cl) and type "Income" again, press Return, 
and type "(cont.)". 

Select the top cell in column 2 (R20C2) and type "7". Press 
Return and insert the IRS line numbers in boxes in column 2 
as they appear in figure 4.21. 

3 I 1 T s I 6 I 7 

~ ............ .7. .... :~a9es, .. s.alar.t~.s.~Jtp~ 1 •• e~.c..................... .... .... ........... 7 
..1!- ~~~~-m-~ .... -~ .... : !.~~-~rest..t.nc;~~e .................................... : .......................... : ... 8 ...... . 
~ . . .. .. .. . .. .. _9a .. _ ~ ptv_t.d.ends ......... _.... . . . .. .. .. .................... 9.~ ........................ IIUJIIJIII.III ....... .. 
1 
23 ................. ~b ... ~Diy.1de~~ .. e.x~1~~1.C?~~ ........................... : ... ~.~ .. - ..................... ~111111.111111 ..... . 
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25 .. _ ........... 1.0 .... : R~fun(j~. o.f sta_te .a.~~ .1 oca ~- ta~.e~ ........ _ ... · ................... ____ ..... ~ .. ~ .9. __ _ 
Z6 ............... !.1 .... Attr:nony_~e~~t.y_e~ ............................... : ............................ ~ .. ~-~ ........ .. 
Z7 ................ ~-~ ... ~Bus111~s.~ .. 1n~o111~ .................................. :.......... : ~.2 .... ~ $59.00 
28 13 :capital Gains or loss (-) 13 

3 5 7 
29 . .!.4 .... :40.X c~p~~~-1 .. 9_a1~ d~~V.1b\J~.~~I'l....... ........ ...... ..... ........ ........... 14 

-~~~.o.rn~ .... .1.s .... :supplemer:'t~1.9a11'ls .. o.r ~~-~.s.<.~J, .. f.~-~-~-~79? ..... ... .... ........... 1 s 
( c_ol'lt .• ) .. · _1_6 .... Jul~y_t~xab1~ pen~IOf1S.. .. .................... ......... ... .. .. . ..... .. .... 16 
.............. :._~.?.a .. :<?t!l~r .. pens_t_o~~-~~-d ~nn_u1~-~~~ .................. J?.a ..................... 1111111i11W: ... · :. :: ·: ·:: 
............ ~ .. !.?.~ .. :Taxab~~ ar:nC?~~~ f~()m .. P~9.~J~. ... ........... ......... .... .. . 17b : 
............. : .. 1.~ ..... Re~t.s_,_ .. roy~!ties ·'. e~c.~ Jrom .s.c.~~~.I:J.l.~ ... E .............. ::: · : .. : ::.:::: ~: .1:~:: :::: :· :· · · .... · 
.............. : .. 1.9_ ... Fa~~-1ncome f~omSche_dul~.F... ... ....... ...... .. . 19 : 

.............. ~ .. ?.9.a .. ~To.tal .~nerr~p_l,~V'!le~~ ................................. ?.9.a .......... :::: ::· :::. llllllliill( 

.............. :. 20b .:Ta.~a~le arry9.u.nt_fr.o.'!l.P8.9~.1.! .............................................. 20!:> .. ~ ........... .. 

. .... .. .. ..... : .. 2.1 ..... ot.he~. t~c~~-~-- ...... .. .. . .. ........ .. .. .............. . .. . ..... . ... . . . .. .... ... . . 21 
39 22 :Total income 22 : $50 

Figure 4.21 Income on-line 
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Scroll to bring row 20 to the top of the screen again, and 
select the cell in R20C6 and again enter the column of 
numbers in the boxes. Multiplan lacks the horizontal stripes 
used by the IRS to mark out certain cells, but vertical bars 
(the right-most key on the second row of the keyboard) are 
a decent substitute. Twelve vertical bars fill a cell in column 
6. Note that if you hold down the Shift key and hit Return 
you move back a cell. 

Scroll line 20 to the top again and select the cell in column 
(R20C3). Type "Wages, salaries, tips, etc." and press 
Return. In the same way enter "Interest income", press 
Return, and type "Dividends", but instead of pressing 
Return after dividends, select the adjacent cell in column 4 
(R22C4) and type "9a". Then roll the mouse to select the 
cell beneath "Dividends" (R23C3) and type "Dividend 
Exclusions". Fill in columns 3 and 4 as in figure 4.21. 

Remember, you can backspace when you are typing in 
a cell and correct the text in the feedback window. When 
you see a cell that is fouled up, you can empty it by selecting 
it and then pulling down the Edit menu and selecting Clear. 
Then you can start over in that cell. The normal Macintosh 
command Cut appears on the Edit menu, but don't use Cut 
for the purpose of correcting what you've written in the 
cell; it lifts the cell itself out of the spreadsheet and other 
cells shift their position to fill the gap. 

Note that lines such as 13, Capitol gains, or 15, Supple­
mental gains, on the real 1040 instruct you to enter losses in 
parentheses. In using the Multiplan version on-line you 
enter them with a minus sign. 

Note that many of the items on this form come from 
other tax forms, e.g., Form 4797 or Schedule E, or the 
worksheet on page 10. Space does not permit me to present 
all the tax forms, but in a full on-line tax system would put 
these other files on your Mac diskette and the 1040 files 
would automatically pick up the results of those forms. To 
illustrate the point let's pretend that the profit of Thorn & 
Co. is the profit listed for you on Schedule C, Business 
Income. This is how to link that other Multiplan file to the 
1040, if the Thorn & Co. file is on the same diskette. 

Pull down the File menu and select Open. If you have not 
recently saved the file a dialog box will ask you to save 
changes. Then the Macintosh document selection dialog 
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box will appear (figure 4.22). The list of files will differ 
according to the history of your diskette. Select Thorn & 
Co. and check Open. The Thorn & Co. spreadsheet will 
appear. 

1040 
10408 
Filled 1040 
profit 
JhOIII G f 0 
untitled 
width teHt 

Select e document 

Multiplan Master 

Open ) j ( Eject 

cancel ) I 

Figure 4.22 Selecting the Thorn & Co. file to establish a link 

Select the first profit cell (R6C2}, pull down the Edit menu, 
and select Copy. The copy of the cell is now on the Clip­
board. 

Pull down the File menu and select Open. From the docu­
ment selection dialog box select 1040, and check Open. 
The 1040 will appear. 

Select the cell where business profit goes (R27C7). Pull 
down the Edit menu and select Paste and Link. The Paste 
and Link dialog box will appear (figure 4.23). This com­
mand will insert a cell, so it is necessary for you to check 
Shift Cells Down (that's why we made the link at this step, 
when no significant cell structure exists below it). Check 
OK. 

-~ iiltiitiiiit~-------------- .... -.. : . 
You are linking to R6C2 on Thorn & co. 

................................. ,. 
:9c ; $0.00 , 

® Shift Cells Down 

0 Shift Cells Right 

I OK ) ( Cancel ) 

·: .. i·a .. ··: ..................... : . 
. ~ --i- i .... ~ .. ---... -..... -...... : -
-~ .. ii ·--~ ........... so:·oo ·:· 
. ~ .. i 'j' ... ~ ..................... : -

·=··--~----------~ 

Figure 4.23 Paste and Link dialog box Figure 4.24 A value from Thorn & Co. appearing 
inthe1040 

The figure $50.00 will appear in the cell (figure 4-24). 
Now, any change in this cell in the Thorn & Co. spreadsheet 
will also change the figure in the 1040. 

Note on the Edit menu the Unlink command, which 
allows you to break links between spreadsheets. 
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Select the cell in column 7 opposite IRS form line 9c 
(R24C7). This cell uses a formula to get its total by subtract­
ing IRS line 9b from IRS line 9a. Type " = C'. Select the cell 
beside 9a (R22C5). Type a "-" (minus sign) to make the 
subtraction. Select the cell below (R24C5}, type ")" to 
complete the formula and then press Return. 

Select the cell for Total income (R39C7). Type" =sum(". 
Use the scroll bar to see the top of the column and select the 
cells in column 7 on IRS lines 7 and 8 (R20C7 and R21C7). 
Their location relative to the total cell will appear in the 
feedback line and, as above, a thin line will appear around 
the selected boxes. Release the mouse button. The IRS 
format interrupts the column of cells to be added, so two 
sums are necessary in the formula. Type ")+sum(". Begin a 
new selection 7 on IRS line 9c (R24C7) and drag it down to 
the cell in column 7 immediately above the total income 
cell (R38C7). When you move the cursor below the 
spreadsheet into the scroll bar area, the spreadsheet will 
scroll up to let you select cells that were out of sight. 
Release the mouse button and press Return. 

This is another cell you will use later so it is useful to name 
it. With the Total income cell (R39C7) selected, pull down 
the Select menu and select DeCme Name. The name selec­
tion dialog box will appear with some suggestions for 
names. Type "ttlin" and check OK. 

Fill row 40 with dashes. 

This completes the income section. It should look like 
figure 4-21. 

Adjustments to Income 

You may now feel comfortable enough with Multiplan 
to enter the captions after looking at figure 4.25, and you 
may be interested only in the formulas in this section. In 
that case skip to step 8. If you want to follow carefully the 
procedures of setting up the headings, begin with step 1. 

Select the second cell in column 1 below the new dashed 
line (R42C1) and type "Adjust-", "ments", "to", 
''Income'' with returns after each. 
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Figure 4.25 Adjustments to income as it appears on-line 
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Select the cell in column 2 below the new dotted line 
(R41C2). Type in the line numbers as they appear in figure 
4.25 , with returns after each number. 

Select the cell in column 3 below the new dotted line 
(R41C2). Type in the text as it appears in figure 4.25, with 
returns after each block of text. 

Select the cell in column 4 below the new dotted line 
(R4IC4). Type in the line numbers 23- 30 as they appear in 
figure 4.25 , with returns after each number. 

Select the top cell in column 6 under the new dashed line 
(R41C6) and fill it with vertical bars as above. Select R41C6 
again and drag the cursor down to select all the columns to 
IRS line 30 (R49C6). Leaving the cells selected, pull down 
the Edit menu and select Fill Down and release the mouse 
button. 

FormDI Options CDicuiDie 

xz 
XH~II!!!!!!!!!!!!!!!!!!! 
XC 040 
xu 

CleDr XB 1-----'--...:........L.--=----!--::7.--!---lill 
Show CllpboDrd 

.... :::::!ill 
••• I 

Figure 4.26 Filling a column with vertical bars 
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Select the cell below these vertical bars (R50C6), type '' 31'' 
and press Return. 

Fill row 51 with dashes. 

Scroll back to column 7 and select the cell in column 7 just 
above the dashed line and next to IRS line 30 (R50C7). Type 
'' =sum('' and select the top three cells in this section in 
column 5 (R41C5 through R43C5). Type ")+sum(". Skip 
the cell next to 25b and then select the next five cells down 
(R45C5 through R49C5). Then type")'' and press Return. 
The figure $0.00 will appear in the cell that gives the total 
for Total adjustments. 

This cell will be cited later so we will name it. Select the cell 
next to 30 (R50C7). Pull down the Select menu and select 
Define Name. Type "ttladj'' and check OK. 

Adjusted Gross 

Enter the heading in figure 4.27 and draw a dashed line in 
row 54. 

3 I 4 I s I 6 T 1 

.R ~-~J~~-t~-~-:. }.2 .... ~~.~j~~-~~-~- 9 !':~.~-~. !!1~-~.'n~ ........................... ~ .... . .................. ~. -~-? .... ~ ........ -~-~Q~ .09 .. 
S3 Gross ln. : : 

Figure 4.27 Adjusted gross income as it appears on-line 
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STEP3 

Now we will begin to use the names we have created. 
This line is income (which we have named ttlin) minus 
adjustments (which we have named ttladj). 

Select the cell in column 7 on IRS line 32 (R52C7). Type 
"= ttlin- ttladj" and press Return. "50.00" will appear. 
This is, of course, the $50.00 profit carried forward from 
Thorn&Co. 

Pull down the Select menu and select Define Name. Type 
"adjgrss" for the name and check OK. We will use that 
name in the next step. 

With regard to Adjusted gross income the IRS suggests 
"If this line is less than $10,000, see 'Earned Income 
Credit' (line 59), on page 16 of instructions.'' You can build 



100 MACINTOSH 

STEP4 

that suggestion into the on-line form by using an IF con­
struction. 

To use the IF function in Multiplan you set up a for­
mula that looks like this: "IF (true-or-false, what-happens­
if-its-true, does happen-if-it's-false). In this case we want to 
ask if the value of Adjusted gross income is over $10,000, 
and if so we want to print the suggestions; if it is not, we 
will do nothing. 

In Multiplan, a function will print something in a cell if 
it is in quotation marks. Note that < means "less than" in 
Multiplan math, and that we must leave the comma out of 
'' 10000'' because it would confuse the IF function. Also 
note that the pair of quotation marks next to each other at 
the end of the formula tell Multiplan to print nothing. 

Select the cell below Adjusted gross income (R53C3) and 
type: = "IF(adjgrss < 10000. "See Earned Income Credit 
(line 59) on page 16 of instructions.'','''')''. Press Return. 

Since the only income we are showing is the $50 from 
Thorn & Co., the suggestion does appear. Try changing < 
to > , or changing 10000 to 10 and see what happens. 

lzl 3 141 s 161 1 

sz ~-~J~~-~~-~-~. }? ... -~~~J~~-~~~- gr.~.~-~. ~!"!9.C?m~ ........................... ~ ......... ~ ..................... ~ .. ~? .... ~ ... ~ .1.9.9.~9!.99 .. 
53 Gross ln. :see 'Earned Income Cred1t'(11ne 59) on page 16 of 1nstruct1ons : 

Figure 4.28 Adjusted gross income after the introduction of an IF formula 
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Tax Computation 

If we had all the appropriate other files on line, you 
would not have to enter a single number by hand into this 
section. Tax computation would use several links if we had 
made the other files. 

Instead: 

Rows 56 and 57 make a page boundary in printing, so skip 
down to row 58 and put in the headings as they appear in 
figure 4.29. 

Select the cell in IRS line 33, column 7 (R57C7). Type 
'' = adjgrss'' and press Return. Naming' 'adjgrss'' above will 
make life simpler. 
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Figure 4.29 Tax computation as it appears on-line 
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With respect to line 35, the IRS instructs "Subtract line 
34a or 34b, whichever applies, from line 33." In a com­
plete tax setup, both these numbers would come by link 
from other spreadsheets. Since this subtraction reduces 
your tax payment, I assume that you will want to subtract 
the larger number. This assumption allows us to write 
another IF formula that would look like this (if we used IRA 
line numbers}: IF (34a > 34b, then 33-34a, otherwise 
33-34b) 

Select the cell to the right of line number 35 (R60C7). Type 
" =IF(". Select the cell next to line number 34a (R58C7). 
Type ''>''.Select the cell next to 34b (R56C7}. Type'',''. 
Select the cell next to 33 (R59C7). Type"-". Select the cell 
next to 34a (R58C7). Type ",". Select the cell next to 33 
(R57C7) again. Type "-". Select the cell next to 34b 
(R59C7). Type")" and press Return. 

The $50 figure should appear in the box; it is the same 
$50 carried forward from the link to Thorn & Co., with 
nothing subtracted from it since you have not entered any 
deductions in IRS lines 34a or 34b. Try putting numbers in 
those boxes and see what happens. 

Line 36 shows the total number of exemptions, which 
we named "ttlexemp", multiplied by $1000. 

If you have forgotten the names we used, you can see 
them at any time by pulling down the Select menu and 
selecting Delete Name. A dialog box will appear with a list 
of the names. You can cancel the dialog box without delet­
ing the names. 

Select the cell of column 7 in IRS line 36 (R61C7) and type 
"= ttlexemps * 1000, and press Return. Of course, the 
result is $0.00 because you did not list any exemptions. 
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The Return in the previous step will have selected the cell 
below, IRS line 3 7 (R62C7). Type " = ". Select the cell in 
IRS line 35 (R60C7). Type"-". Select the cell at R61C7 and 
press Return. The $50 from the Thorn & Co. will appear. 

In a fully realized version of this tax system, lines 37 
and 38 would be linked to other Multiplan spreadsheets. 
Line 40 is the sum of lines 3 7 and 38. 

Select the cell in IRS line 40 column 7 (R65C7). Type''=''. 
Select cells R64C7 and R63C7, and press Return. If you just 
select cells, Multiplan assumes you want to add and sup­
plies the plus sign. 

It will be useful to give this cell a name. Select it (R65C7) 
and pull down the Select menu and select Define Name. 
Type '.'taxcomp" and check OK. 

Credits, Other Taxes, and Payments 

In each of these sections all the lines except the totals 
at the bottom of each section would come from a link to 
another Multiplan spreadsheet in a fully developed on-line 
system. 

Enter the numbers and headings of these three sections as in 
figure 4.30. 

Since a page break falls neatly between IRS rows 57 
and 58, a dashed line is unnecessary. 

Line 48 sums the credits. Select the cell in column 7 in IRS 
line 48 (R74C7). Type "= ". Select the cell in column 5 in 
IRS line 41 (R67C5). Select in turn the cells below it down to 
IRS line 47 (cells R67C5 through R73C5). Press Return. 

Line 49 subtracts the total credits from the tax computation 
above. Remember we named the result of the tax computa­
tion ''taxcomp''. Select the cell in column 7 on IRS line 49 
and type '' = taxcomp-''. Then select the cell above it 
(R74C7) and press Return. 

Other taxes sums only the taxes in that section. Select the 
cell in column 7 and IRS line 56 (R83C7) and type "= ". 
Then select the cell in column 7 and IRS line 50 (R77C7) and 
each cell below it down to IRS line 55 (cells R77C7 through 
R82C7). Press Return. 
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81 .............. ~. -~-~- ... :~~-~-~J).~_~t~~-~.<?~I~L ~~-~~f.1~Y. .................... : ........ : ..................... ~- .~t ... ~- .................. . 

: 55 :rax on an IRA . : : 55 : 

::::::::::: :::~ ::~~: :: :~r.~·~a:.: :~~~:: :::::::::::::::::::::::::::.:::::::::: · ::::.:: ~: :::::::. ~: ::::::::: :::::::::::: :~~·::: ~: :· :::::: )Q~:99:: 
1 JzJ 3 141 s 1&1 1 

1 
8s ............. -~ .. ~.? .... J~-~-~r.~.l .. ~~-~-~m~. ~~-~-~~-~~-h~L~ ................... : .. ~.? .... ~- .................... JI.IJIIJIIUE. .................. .. 
86 P.~.Y.~~~-~~ .. ?.~ .... ~ ~-~-~~- ~~-~~~-~~-~-~- P.~Ym~~-~~--~ .~r-~.~..1.~.~~--. -~- -~-~---- : ..................... : IIIJIIIHII.: .................... . 
87 ............. -~ .. ?.~ .... :~~-~n~~ .. i.~~~~-~- ~ r.~.~~~- ............................. :. -~-~-- .. ~- .................... ~II.IJIUIIIJI:~~-~- P.~9.~ . .1.~ .. . 
88 ............. -~ .. ~.Q .... Am~~-~~ .. ~r.~m.f.~.~-~-~~.t?~ ......................... : .. ~.<? .... ~ ..................... UIUIII.IJIIJ. ................... . 

I 89 .............. : .. ~.L ... J~~-~~~--~-<?~~~.1 .. ~-~-~~f.1.~y -~~-~-- .................... ~. -~- ~ .... ~ ..................... ~II.IJII.IIII.IJ: .................... . 
1 
go ............. -~--~.? .... ~~r.~.~~t f<?r. ~P.~.~~~~-· .. r~~.l.~ .. ~n~ .~.t.l.~ ............ : .. ~.? .... : ..................... JIIIJ!II.IJIIJ. .................. .. 

r!.L ............. -~ .. ~} ... ~R~.9.~~~~-~~- !!1Y.~.~~m~~-~ .~.<?mP.~.~Y. ~ r.~-~~~- .... :. -~-~-- .. ~ ..................... UII.IIII.IJIIL ................... . 
9Z : 64 :rotal payments : : : 64 : $0. oo 

Figure 4.30 Credits, other taxes, and payments as they appear on-line 

STEPS 

STEP& 

IRS line 64 sums lines 57 through 63 just as line 49 in credits 
sums lines 41 through 47. Select the cell in column 7 in IRS 
line 64 (R92C7). Type '' = ''. Select the cell in column 5 in 
IRS line 57 (R85C5). Select the cells below it down to IRS 
line 63 (Cells R85C5 through R91C5). 

It is also useful to name your total payments. Select the cell 
in IRS line 64 and column 7 (R92C7). Pull down the Select 
menu and select Define Name. Type "ttlpaid" and check 
OK. 

The IRS instructs us in their line 59: "If line 33 is under 
$10,000, see page 16." Line 33 is the same as line 32, which 
we named ''ttladj.'' This suggestion can become an IF for­
mula: If what is in 33 is less than $10,000, see page 16, if not, 
continue. 

The empty cell in IRS line 59 column 7 is a convenient 
place for this formula. 
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STEP7 

STEP1 

z I 

Select the cell in IRS line 59 and column 7 (R87C7). Type: 
"= IF(ttladj < 10000, "see page 16"," ")". Since "ttladj" is 
less than $10,000, the suggestions will appear. 

Refund or Amount You Owe 

Set up the format and headings of this section as in figure 
4.31. 

3 I 4 I 5 T 6 1 7 
94 6S :Amount OVERPAID ; : : 6S ; 

o....::;....:_ ••••••••••••• ...................................................................................................................................... .. 

95 Refund o 66 :Amount to be REFUNDED : : : 66 : 
~ .................................................................................................................................................. .. 

1 
96 ~m~~.~t . .. ~.?. .. . ~~m~~.~~- .9t9~~r.r?.~Y.m~nL~9r.~~.~ . .v.~~r ..... ~ .. ~.? .... ~ ..................... ~JII.IIII.IIIL ................... . 
97 You owe 68 :AMOUNT YOU OWE . : : 68 : 

Figure 4.31 Refund or amount you owe 

STEP2 

STEP3 

IRS line 65 contains a number only if you paid more 
than your share of taxes; otherwise it contains nothing. 
Overpayment is the difference between payments and total 
tax; this can easily be expressed in a Multiplan IF function 
because of the work we have already done. The essence of 
the formula is: If total paid is more than total tax, then 
subtract tax from payments and show the result, otherwise 
show nothing. 

Select the cell in IRS line 65 and column 7 (R94C7). Type: 
"=If(ttlpaid>ttltax,ttlpaid-ttltax, "")" and press Return. 
Since the numbers currently in the form do not show over­
payment, nothing will appear. 

Lines 66 and 67 are where you dispose of overpay­
ments at your discretion. Since computers have no discre­
tion, I have nothing to say about these lines. 

Line 68 is the reverse formula from line 66, that is, 
when you owe more than you paid. 

Select the bottom left cell of the form (R97C7). Type the 
same formula as in step 2 above with ttlpaid and ttltax 
reversed: = If(ttltax > ttlpaid,ttltax-ttlpaid," ''). Nothing 
will appear since there are no numbers in these cells. 



Multiplan 105 

Printing your form 

Multiplan offers you the choice of printing your form 
with or without row and column numbering and with or 
without grid lines. With grid lines and without column 
numbering seem most appropriate for the IRS form. You 
can also add a header or a footer that will appear on every 
page. Finally, Multiplan allows you to select only part of the 
form to be printed. Figure 4.32 shows a form printed, with 
some hypothetical numbers in place. 

1040 u. S. lndtv1dua1 Tax Return 1983 

. . . . . . 
. ... ........ ········· .............................................................. : ......... : ...................... : ......... ······ ············. 
~ ~ ~ ,~9 . . . . . . . . . . . . . . . ............................................................. ~ ......... ~ ..................... ~ ......... ; . . . . . . .. . . . . . . . . .. 
~~~~~~ .............. ~~~9.1.~ ..................................................... ~ ......... ~ ..................... ~ ......... ~ .................. .. 
. .. .. .. .. .. .. . .. .. .. . .. ~~ r r.1.~~ .J~1~.t. r~t.~.r~ ............................... ~ ......... ~ ..................... ~ ......... : ................... . 
~h.~cr ............. ~~r.f.1.~~-~4!!.1?~r.~.~4!!J.e~~f.~ ......................... ~ ......... ~ ..................... : ........ ~ ...... , .......... .. 
~n.l.Y. .C?.':'~ .......... H4!!.~.~- ~r. ~~u.s~h.C?.l.~ ................................... ~ ......... : ..................... : ......... : .................... . 
~o.~.~ ................ ~!-!a.~ ~rY~".9. ~'~~.~~-~.r .>.. ............................ ~ ......... ~ .................... : ........ ~.... . ........... . 
···•··········•····································•·•·····•·•········•·········•·······••···•·•····•····•··············•·· ······•ooo ......• 0000 • 0 • 0 • 

• 0 ••• 00 ••••••• : ooo~o~ ... :'!.~~.~~~.l.f .......... 0 •• 0 0 •••• •••••••• •••••• ·······••o oo•• .. : . o••• .•.. : ... ······ •..... ······ : ......... : ..... 0 •• oo ...... ··-· 
~~.e~P.':" ... ~ ......... ~ .............................................. ~.~- .~.~ .OY.~f. ~ ......... ~ ..................... ~ ......... ~ .................. .. 
~.t.~~~ ....... ~ ................................................................ ~~~~~~- ........ ~ ..................... : ......... : .................. . 
. . . . . . . . . . . . . . ~ ... ~.~ ... ~ ~P-~.~~4!! .................................................... ~ ......... ~ ..................... ~ ......... ~ .................... . 
. . . .. .. . . .... . ~ ........ -~ .............................................. ~~-~f. .~.Y.~f. ~- ........ ~ ..................... ~ ......... : .................... . 

: : Bltnd: : : : · · ..... · · .... -~ ........ -~ ...................... · · ·· .... · ... · · .... · · .. · · ..... 68 .. +. 6t;~ · .. o .. · · ~· ................... · ~- ........ : · ·· · · ..... · .. · · · .. .. 
::::::::::::: :j:::~:~:: :~~~~~~r::~f :~~P.~~:~~~:~ :c:~~:(d:~~~: ::::::::::::: ::~: ::6:~: ::!: :::::::::::::: ::~:: ~: :::::::: i::: ::::::::::::::::.: 
............. -~ ... ~~.:.~~~-~~~r .. C?~ .C?~.~.er.. ~~P.~~-d~~t~ ................... ~ ... 6.~ ... ~ ................ ..1. .. ; ......... ~ .................... . 
. .... .... . . .. -~ ... 6.~ ... J~~~-~ .~~m~~-~ .. ~r .. ~?C~.~.S?~~-~~~ .................... ~- .. ~.e ... ~ ................. ~ .. : ......... ~ .................. . 

::::::::::: :::~:: :?.: :::~~~i9~~ ~: :~~~:~r.~~i~: ~~P~ ~::~~:~:;: :::::::::::::::: ::~: :::: ::::i: :::::::::::::::::::: i: ::?.:: ::i: :$~~~:opQ~:99·: 
~~~~~~- -~ ... e .... -~ ~.~~~r.~.~~ .. ~.r:-~~m~ ...................................... ~ ......... ~ ..................... ~ ... ~ .... ~ ... ~.1 .•. ?~~ :-.Q~ .. 
. . . .. .. . . .. .. . i ... 9.~ ... i D.~Y.t.~.~~~~ ................................................ ~ ... ~.~ ... ~ ......... $~~ :-.Q~ .. llliJIUJIUII .................... . 
. . . ...... .... . ~ ... ~.~ ... ~~~.t.~.~!"!~ .. ~-~~~~~-1.9~~ ................................ ~- .. ~.b ... ~- .................... ~II.IIIUIIUL .................. .. 

: 9c :ga-9b : : :gc : $0.00 · .... ·· ·· ..... ~ .. 1 a· .. ·~Reiuri"d8·;;; ·sta.ie .. ~·nd ·1oc·~·,· ·t:a-~·es ............. ~· ·· .... ·· ~- .... · · .. s.ss:·oo .. ~· ·1·o .. · · ~ ... ·· · · · · · · · · · · · ... · · 
:::::::::::::: i :: ~: ~: :: :i~~:1:~:~~v.:~:~~~,~~~::::: :::::::::::::::::::::::::::::: i: :::::::: j: ::::: ::i~~~:99:: j: :~:;:::: ~: :::::.:::::::::::::: 

: 12 :aus1nes tncome : : : 12 : $50.00 

:::::::::::::: i :: ~ i :: :~~~:.;:,~:~:( :~:a~n~: i~:j~~~: :~~ ). :::::::::::::::::::::::: j: :::::::: i: :::::::::::::::::::: j: :~i: :: j::::: ::':~~~ ~:99:: 
: 14 :401 capttal oa1n d1str1button : : : 14 : 

········- ....... ····••o••• ···················•••o••••········••o••••·····o••ooooooooo•·········•ooeo•o••······••o•························o········· --------------------------------------------------------------------

(continued) 
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j~~~~:~:: :~ ·.:~:$: :::j~~~P.;~m~~~:~i :9~;~~: :~r. :~~~:s:~< ~):;:f. ~~:r!j:~?.~?:: :::: i::: ::::::::::::::::::;: · ~:~:::: :::: · ::: ::_:: : :· ·- .: 
(~.~m .. J ... ~ .J~ .... J~.nY. -~~~~-~'~-P.~.~~~~~.~ ............................ ~ ......... ~ ..................... ~. J~... . ....... ~~~~.oq .. 
.............. ~ .. ~.?.~.J~~.~~r .. P..~!"!~.1.<?.n~.~.~~-~~.~~~~~-~~ .................. ~.J.?~ .. ~ ..................... ~IIIIIl.IIIIJ1 ........... _ ..... . 
. .. ...... .... . ~ .J?~ .. J~.~-~~~~ ·~-~~~~~ Jr.~.~ . .P.~.9.~ .. 1.~ ................. ~ ......... : ..................... ~. J?~ ..... . 
. . . .... .. .. .. . ~ .. ~.~ .... ~R~.~~.~ .... r.~.v~'~-t.~.~ , .. ~.~~-~ '· .~r.<?m. ~~~~~l:J.l.~ ... ~~ ......... ~ ..................... :. J~ ........... _ ..... _ ... .. 

: 19 :Farm 1ncome from Schedule F : : : 19 

::::::: :::::::j::?.Q:~::d~~~:~ :~~~m~~~v:~~~~: :::::::::::::::::::::::::: ::::~: :?:Q·~:: ~: :::: :::i~?.~:9q:: HujiOiifli ::::: · · ::::.:.::::::: 
.............. ~ .. ?.Q.~ .. ~T~.~.~~~~ .~.~~~~~ .rr.~.~. P.~.9.~ .. 1J ................. : ......... ~- .................... : .. ?.Qb ..................... .. 

: 21 :other tncome : : : 21 $3. 9S 

:::::::::::::: l ::?:?::::d~~~:~:~~~:~!ri~:: :::::::::::::::::::::::::::::::::::::::: ~: :::::::: ~: ::::::::::::::::::::1: :?:?:: :: : :$~9 ~:Q:~~ ~:~~:: 
--------~----------------------------------------------------------------------------
: ·.::::::: :::: :~ ::?:~::::~~~xf~:9: ~~i>:~~~~:~: ::::::::::.::::::::::::::::::::::::: ~: :?:~:::: ~::: ~:1: ~:o~~~:9q:: HliHOiiOH:::::: .. : :::::::::::: 
~-~J~~.~-:-... ~ .. ?.1 ... . J ~.P.J.<?.'l~~ .. ~-~P.~.~-~~~ ................................. ~- .?.~ .. .. ~ .................... JI.IJiliiiUt 0 ............ 0 .. .. 

m~o~~.~ .... -~ .. ?.~.~.JB~. ~~~.~-~~~.<?r!~ ........................................ ~ .. ?.~.~ .. ~ ... ... J~.~~~.Q9 .. ~ll.lllliiii.IJ~. 0 ................ 0. 

~~ .......... -~ .. ?.~.~.JR~ . .P.~Y.~~~~~- ........................................ ~- .?.~~ .. ~ ... ~~ •-~~Q~.Q~ .. ~II.IJIUIII.IJ~ .................. 0 

m~~.~~ ... ~ .. ?.~ ... . ~~~y~~~.~~J~ .. ~. ~~~9-~ ............................... ~- .?.~ .. .. ~ ..................... ~II.IJIIJIIUJ~ ................... . 
. . . . . .. . . . . .. . ~ .. ?.?. ... ~ ~~-~-~ ~~.v. f<?.~. ~~~.~~r. ~.~~ ................. 0 ........... ~ • • ?.? .... ~ ..................... ~ II.IJIUIIUL .................. . 
• • • •• • • • • .. • 0 -~ .. ?.~ ... . ~~J.t.~.~~Y.P..~~~ ............................ 0 ............. ~ • • ?.~ .. .. ~ ..................... ~lliJII.IIIliL... . ............ .. 
. . . .. .. . . .. .. -~ .. ?.~ ... . ~~~.~~-~~.~~ .. ~~.f.~ ...................................... ~ .. ?.~ .... ~ ...... J~.Q~~.Q9 .. ~II.IJII.IIIUL .... 0 ............ .. 

. .. .. .. . . .. .. -~ .. ~.Q .... ~P.~~.~~n ~~.v. J0~. ~-~-~ .................................... ~ .. ~.Q .... ~ ..................... ~ II.IIII.IIII.W ................... .. 

. . . .. . . . . . . . . . ~. J ~ .... ~T.~.t-~.1 .. ~.~J~~~ ffl.~.':'~.~- .................................. : ......... ~ ..................... ~ .. ~. ~ .... ~ ... ~ .1. ·-~~~~.Q~ .. 

~.~J~~-~~-~- ~ .. ~.? .... A.~j~~~~.~- 9~~-~.~. ~r!~.<?.'!!~ .............. 0 .......... L ........ L .................... ~ .. ~.? .... ~ .. $~~ •. Q.~!~.~~ .. 
Qr.<?.~~ .! ~ ~- ......... ~~~.~- :~~.~~~~ .1.~.~-~m~ .. ~t~~.t~'{l.t.~.~. ~~J .~!"! .P.~!J~. ~.~ .. C?f. t~~~r.~.~~.1.<?.~~ ......... ~ ................... .. 
······················································································································································· • • • • 0 • . . " . . . . . . . . 
······················································································································································· . . . . . . . . . . . . 

• • • • 0 • 

······················································································································································· .............. ~ .. ~.~ .... ~~m~~.~~- .~r.<?.~.n~~}? ............................... ~ ......... ~ ..................... ~ .. ~1 ... ~ .. $~~ •. Q.~! ~.~~ .. 
J~.~ ....... ~ .. ~.~.~. -~ ~~-~.'!!~~~-~. ~~a.~.t~.Y. f~.~m .~.~h~~-~.1-~ A ......... _ ~ ......... ~ ..................... ~. -~-~~ .. ~ ................... .. 

~~.'!'.P.~ .. -~ .. ~.~-~-. ~~~.~r~~Y.f.~~~ .. ~~.f~~~-~.~~- .~r! .P.~.Q~. ~.~ ......... ~ ......... ~ ..................... ~. ~-~~--: .... 0 .$.~-~~~.Q~ .. 
~~~.i~~ ..... ~. }o~ ... J':l.<?~t f.~Y~.f~~~~ .~.~-~f.~~Y. ........................... ~ ......... ~ ..................... !. 03.~ ... 0: .. $~?. ,0~.0.1.~.~-~ . 
. .. .. .. .. .. ... ~ .. ~.~ .... J ~.~~.1 .. ~.~P.~~-~.~!"!t~~~.rnP.~!~~-~- ................... ~ ......... ~ ..................... ~ .. 3.~ .... ~- .. ~~ •. Q.Q~~.09 .. 
... .. .. .... .. -~ .. ~.? .... J~.~.~~~~ .1~.~0~~~- ...................................... ~ ......... ~ ..................... : .. ~.?. -· : .. $~3 •. 6~.1.~.~.~ .. 
. .. .. .. .. .. .. . ~ .. ~.~ .... JJ~. Y.~m .~.~h~~.~.1.~ .. ~r.. r.~~·~··· .................... ~ ......... ~ ..................... : .. ~~- ... ~ ... $8,.2~~~-Q~ .. 
. . . . . . . . . . . . . ~. -~·~- ... ~~-~~1~!~~.~.1. -~~.~.~~.!f.~.'!'. P.~9.~ .. 1. ~ ••...•.•...•.••• ~ •..•••••. ~ •.••••••••..•••.•.••. ~. -~-~ •... : •......•••. 0 ••••••••• 

. .. .... .. .. . _ -~ .. ~.Q .... ~T~.t.~.1. -~~~ ................................................ ~ ......... ~- .................... ~. -~.Q .... : ... -~~ •. ?~~~.Q~ .. 

::::::::::::: :~ ::~: i: :: :~~r:~~j( ~-~-~~~-i~~h:v-::: :::::::::::::::::::::::::::::: :.·l: :~:~ ::::1::::::::::::::::::::: iti1:1iii:IHO~::: :::::::::::::::::: 
~r.~.~!~.~ ... ~ .J? .... J ~-~.~~9.~. ~~-~. ~r.~.~.t~ ................................... ~- .~.? .... ~ ......... $~~~-~9 .. JJII.IIIliJIIL ................... . 
. .. .. . . .. .. . . -~ .. ~.~ ... -~ t~x~.~~.~~~t ~ r.~.~~t .................................. ~- .~.~ .... ~- ..... J~.~~~.Q9 .. UIUIIUIIIJ ... 0 •• _ ............. . 

. . . . . .... .. . . -~ .. ~.1. ... ~~~.f~.t.~.l..P..~~~~-1.~.~~ .. ~ f.~.~-1~ ........................... ~ .. ~.~ .... ~ ........ l~~~-~~ .. )JillllliiiiJ .............. 0 ..... . 

. . . . . . . . . . . . . . ~ .. ~.~ .... ~ ~ r.~.~~~. f<?.~. ~~.1.1.~ .. ~~ r.~ ...................... 0 •••••••• ~ •• ~.~- ••• ~ •••••• ·'·~.~~~.99 .. JIIUIII.IJIIJ .................... . 

. . . . . . . . . . . . . . ~ .. ~-~- ... ~~~.~.~.~f.~-~~~ ............................................. ~ .. ~~ .... ~ ..................... Jlltllllllllr .................... . 

. .. .. .... .. .. -~ .. ~.? .... ~~~.~.1~~~-~~~.1 .. ~.~.~f.9.Y .. c;r.~.~~t ..................... ~ .. ~.? .... ~ ..... --'-~-~7.~.9~ .. ~llllll.llll.l[ -· ................ .. 

::::::::::: :::~: :;::: :: :l~:1::~;;~~::~:: :::::::::::::::::::::::::::::::::::::::: ~: ::::::::1::::::::::::::::::::: ~: :;:::: ::1::: ~~:::~~::~~:: 
--------------------------------------------------------------------------------------
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:::::::::::.:: ::~9::: :~~~:l:f~~:~P.~:~xrit:~:~~:i~~::::: :::::::::::::::::::::::: ::::::::: ~: :::::::::::::::::::: : :~:9:: :: ~:: :::::::::.::::::::: 
Other 51 :Alternative minimum tax : 51 : 

~ax~~· •••••• ~~· ••• :~:~·~~it.~~"M:~~i~O:.J.t;~~·~c.:~~. c·r~~ti • : .... · •..•• : .••• :::.: •• : ... : ·• : ·~~· •• :' ••• : ••••••••.•.• : ·. · . 
. .. .. .. . . . .. . . .. ~.~- .. -~~~-~-~~.1.~-~t~~ .~.<?~!~~. ~~-~~r.~~x ............................. ~ ...................... -~-~ .... ~ .................... . 

55 :rax on an IRA : 55 : $234.00 

:::::::::::::: ::~:~: :: .~i~:~a) :~~~ ::::::::.::::::::::::::::::::::::::::::::::::::: ::::::: ::!::::::::: :::::::::::: ::~:~::::~: :)?~:9~~~:?~:: 
-----------------------------------------------------~-----------------------------­············································································································· ········································· 

: 57 :Federal income tax withheld : 57 : $6,658.97 :IIIJIUIIIIJ: 
P.~:v:~~~:~~::~:~: :: :j ):~:~~: ~~:~1 ~:~~:~:~: P.~:v:~~~:~~::~ :~r:~:~::1:~~~:::: j: :~:~:: ::i: ::::::.::::::::::::: j 1iunmi1.): :::::::::::::::::::: 

: 59 :Earned income credit : 59 : :111111111111=see page 16 
::::::::::::: :~ j:9: :: :~~:~~~~~- :~r:~:~:r.~~:rri:~~:~:~: :::::::::::::::::::::::: :::~9:: :: ): ::::·: :::::::::::: jiii.liilliiif: ·: :: · ::: ·:·: :::::::: 
.............. ~ .. ~.~ .... J~~-~~~ .. ~.C?~~~-1 .. ~.~-~~r.i.~Y .~~.':' ...................... ~ .. ~.1.. .. ~- .................... JI.IJII.IIII.II~.... .. .......... .. 
. .. .. .. . . .. . . . ~ .. ~.? .... ~~ f.~.q~~. f~.~. ~P.~.~~~~.l..!~~.l. ~ .. ~~~ .9.1.1.~ ............ ~ .. ~.? .... ~ ..................... mi.IIII.IJIIJ:.... . ............. . 
. .. .. .. . . .. .. -~ .. ~.~- ... ~~~.9-~J~~-~~. !~Y.~.~~-~~~.t~.~.~P~.r:'Y. ~f.~.~~~- .... ; .. ~I ... ~ .................... HIIJIIIIIIIJ. ............... .. 
... .. .. . . ...... : .. ~~ .... J~~~l .. P.~Y~.~n~.~ ...................................... ~- ........ ~- .................... : ... ~ .... : ... ~~ •. ~~~~.~! .. 
······································································································································· ··············· 

: 65 :Amount OVERPAID . : . . 
Re·i~·,;·ci. oi. ··5·5· ... :;;:~c;~·,;t· tc) .be. RE.FuNc>ro ........................... ~· ....... ~ ..................... ~. ·5·5· ... ~ .................. . 

~:~~~:~~:: :j .:~t::: ~~:~~~~~: :~f :~~~~:p:~xrit:~:~~::~~:~: ri~:~: :v:~~r::::: ~: :~:?:::: ~: :::::::::: ·: ::::::::: iif1iillii1: ~::: :::::::::::::.:: ·: 
You owe : 68 :AMOUNT YOU OWE : : : 68 : $383.25 
•••••• 0 0 ....... : ••••••••• : 0 •••••••••••••••••••••••• 0 ••••••• 0 •••• 0 ••••••• 0 ••••• 0 ••••• 0 ••• : • 0 ••••••• : •••••••••••••• 0 •• 0 0 •• : ••••• 0 ••• ~ • • • •• 0 ••••• 0 0 •• 0 •• 

.............. j .. ·······j·· .. ·········· .. ··············································j·········j··········· .. ········j·········i· .. ·················· 

Figure4.32 

STEP1 

STEP2 

Here is how you would print such a view. 

Pull down the File menu and select Page Setup (see figure 
4.33). Check Unde and then check the Print Row and 
Column Numbers, which will keep them from being 
printed. Type "1040 U.S. Individual Tax Return 1983" and 
check OK. 

Paper: ®us Letter 0 R4 Letter 

0 US Legal 0 International Fanfold 

Orientation: 0 Tall 0 Tall Adjusted ® Wide 

D Print Row and Column Numbers 

1:81 Print Gridllnes 

Page Header:I~I-04-0-U-. S-. 1-n-dlu-id-u-ai-T-aH_R_e-tu_rn_l-98-~~-------, 

Page Footer: L----------------...J 
Left Margin: I 0. 75 

F===~ 
Top Margin: ~....I• __ __, 

Right Margin: !=I 0=.7=5 =~ 
Bottom Margin:!._ 1 __ _.~ 

Figure 4.33 Page Setup dialog box for the 1040 

Pull down the File menu and select Print. 
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A p T E R F v E 

Microsoft Chart 

Microsoft Chart displays numbers from Multiplan or 
new numbers added to Chart. You can choose from a rich 
array of charts to suit different data. Chart offers tools to 
emphasize and ornament the charts with borders and back­
grounds; there are also many font styles in different sizes. 
You can superimpose one chart on another, manipulate the 
axes, and find some basic statistics such as standard devia­
tion. The examples below barely hint at the variety of 
possibilities. 

If you are not satisfied with what you can do artisti­
cally with Chart, you can copy a completed chart into 
MacPaint. MacPaint allows you to touch it up with your 
own illustrations or those from commercial diskettes with 
ready-made art. You cannot, however, copy a chart back 
into Chart once it has been in MacPaint. 

Beginning Chart 

When you click on the Chart icon or on a file you have 
worked with before, two windows appear. One contains 
the chart and is normally full-screen size; the other contains 
the numbers and is smaller (see figure 5. 2). The small win­
dow called New Series always appears (there is a way to 
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hide it) and is similar to a pad of forms from which you can 
tear off new forms to type in the information you want as 
charts. Each new form is identified by the date when it was 
created, and you can rename it yourself later. 

Once you have created a basic chart, you select the 
chart or parts of it, pull down menus, and select dialog 
boxes that change how the chart looks. 

Chart takes a long time to start up, but is quick to 
change. When you start by clicking on the application icon 
or on a file, you will have to wait as long as half a minute. 
When you start up, you may be able to see the history of 
how you have arranged a series of numbers as the small 
windows appear and disappear, overlapping one another. 

Differences with Standard Mac Operations 

Chart has a somewhat different feel from MacWrite, 
Mac Draw, and Multiplan. First, you will probably work 
with more than one window at once: one where you type 
in numbers, the other where you show the chart. Second, 
you do more through dialog boxes than in Apple applica­
tions. Although Chart takes great advantage of the Macin­
tosh graphics in its displays, its commands have less of the 
freehand quality of other Apple. programs. Finally, as in 
Multiplan, the cursor often changes shape to reflect it's 
current function. For example, in a typical Apple program 
you move a window by putting the arrow cursor in the 
striped area at the top; in Chart, when the cursor enters that 
area it turns into several little arrows pointing up and down 
and left and right to indicate what you can do. The frequent 
changes in cursor shape are a little confusing at first, but 
they are coherent. 

You may recall the simpleminded profit-and-loss projec­
tion of Thorn & Co. discussed in the chapter on Multiplan. 
This section will show you how to put the information in 
figure 5 .12 into Microsoft Chart by hand. 
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STEP1 

STEP2 

Insert the Microsoft diskette and turn on the Mac. If the 
Chart diskette catalog does not appear, click twice on the 
icon of the Microsoft Chart diskette. Select the Chart icon 
and click twice. 

Figure 5.1 Staring up Microsoft Chart 

The Chart window, untitled and uncharted, will 
appear; overlapping it on the desktop will be the New 
Series window. New Series, enables you to enter numbers 
and define what you want to chart them against. 

Figure 5.2 A blank Chart and New Series window 

Type Thorn & Co's sales forecast , pressing Return between 
each number (100, 110, 121, 133.10; see figure 4.12). 

The instant you begin to type , Chart makes a new 
window for this series of numbers. When you are finished 
it will look like figure 5. 3. It has simply arranged the items 
by number: 1,2 ,3,4. The title is the time you began typing. 



STEP3 

TeHt ... 
Number ••• 

sort ••• 
Analyze .•• 

List... XL 

Figure 5.4 Selecting Date on the 
Date menu 

Order: 
0 Plot Series 

X 

1 
2 
3 
4 

y 

Figure 5.3 New Series window arranged by number 

Microsoft Chart 111 

We need to name the series "Sales" and establish that these 
are yearly figures . You can mark both the series of numbers 
and the fact that they are yearly figures through the Data 
menu. Pull down the Data menu and select Date. 

The Date Series dialog box will appear. The Series 
Name box is black when the dialog box first appears. 

Date Series 

Series Name: 

Category Name: 

Ualue Name: 

First Category: Ll F_e_b_1....:.,_1_9_o_s ________ ____, 

I nc.rllmllnt Each Category By 

®Years 0 Months o
0

Koays 0 Weekdays ~: 
cancel Iii 

Figure 5.5 Date Series dialog box 
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STEP4 

Figure 5.6 Sales series properly 
labeled 

STEPS 

Type ''Sales''. Move the cursor into the box labeled 
Category Name. It will turn to anI-beam, showing that 
you can add or change text in the usual Macintosh style. 
Backspace once to delete the X present in the box, and type 
"Years". Move the cursor to the box labeled Value Name, 
backspace once to remove theY, and type "Dollars". The 
box labeled First Category will show the current date. If it 
is not 1985, type "111/85". Check OK. 

The dialog box will disappear and the series window 
will appear correctly labeled (see figure 5.6). 

The horizontal line that curls at the end underlines 
your last number. It indicates that new typing will enter as a 
new row below the line. 

The numbers typed in are still not in dollar format. Pull 
down the Format menu and select Values (the right-hand 
column is always values, the left-hand column is always 
categories), (see figure 5.7). A Format dialog box will 
appear. Click on Dollar, and click OK (see figure 5.8). 

I Categories... • 

- P<11te111~... -

li~I.JP.nd ... 
l'ea«t ..• 
fllti~ ••• 
~<lin Ctwr1... T 

~ th•ei1<1~J t:twr1 ..• i 
Figure 5. 7 Selecting values 

to format 

Uelues 

Align 

OLeft 
ocenter 
@Right 

Number Format 

0 General 
(!kooner 
0Perc:ent 
ONoOec:lmal 
ODetlmol 

Number of Oeclmals:l ._ 2 ___ --J 

TeHt Before: I 
F======l 

TeHt After: L...l ------1 
OK ( Cancel ] 

Figure 5.8 Selecting a dollar format for values 
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STEP7 

Figure 5.10 Clicking on the New 
Series window to bring 
it to the top of the desk 

STEPS 

Microsoft Chart 113 

Now we are ready to ask Chart to make a chart. Check Plot 
Series on the Sales window. A chart will appear behind the 
series window. 

$ 140.00 

$1 20.00 

$100.00 

$80 .00 
Do11¥J 

$60.00 

$40.00 

$20.00 

$0.00 

Figure 5.9 The Chart appears 

The cost of goods is not yet part of the chart. Click on the 
part of the New Series window visible (figure 5.10), and 
then type Thorn & Co. 's yearly cost of goods, pressing 
Return (or Enter) between each number (50 , 52.50, 65.88, 
75.22; see figure 4.12). As in step 2 above , Chart will gener­
ate a new window named after the time you began typing. 

Repeat steps 3 through 6 , but fill in the series name in the 
Date dialog box with ''Cost of Goods'' . At the end of these 
steps , the cost of goods will appear on the chart behind the 
series window. 

l>oti¥S 

$140.00 

$120.00 

$1 00.00 

$40.00 

Figure 5.11 The Cost of Goods appearing 



114 MACINTOSH 

Rre11 •.. 
B11r ... 

STEP9 

STEP10 

STEP11 

Ch11r t fo 

1-
-"Column ... 

Line .. . 
Pie .. . 
Stillier ... 

Figure 5.15 Selecting Combination 
from the Gallery menu 

Repeat the steps above for Thorn & Co.'s profit (50, 57.50, 
65.88, 75.22) with the exception of filling out the Series 
Name on the Date dialog box with "Profit" . Click on the 
chart and it will come to the foregro und. 

0o11¥"'S 

$140 00 

$120.00 

$100.00 

$8000 

$6000 

$40 .00 

$20.00 

$0.00 

Untilled --=---- - - ---------------------

Figure 5.12 Thorn & Co. chart showing all series as columns 

The chart is not a fully successful graphic exposition yet 
because it lacks correct legends, and because profit is bur­
ied as a short column. Pull down the Chart menu and select 
Add Legend (see figure 5.13). The legend in figure 5.14 will 
appear. 

formot 
Mllln Chllrl Type ... 
Ouer111y Chort Type ... 
RHe s ... 

lldll ll r row 

Figure 5.13 Selecting Add Legend Figure 5.14 A Legend appears 

Pull down the Gallery menu and select Combination 
(figure 5 .15). The Gallery of combination charts will 
appear (figure 5 .16). Click on 2 and check OK. The Thorn & 
Co. profit picture will appear as in figure 5.17. Note that in 
this combination chart the dollars for profit are listed sepa­
rately on the right, which allows the profit line to appear at 
the top of the chart. 
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s~lu 

$ 140 00 $80.00 

$120 00 $70.00 

$ 100.00 $60.00 

$80.00 $50.00 
Doll.,-s $40 .00 

$6000 
$30.00 

$4000 $20.00 
$2000 $ 10.00 
. $0.00 $0.00 

OK [ Cencel ) 1985 1986 1987 1988 
Yurs 

Figure 5.16 Selecting a chart from the gallery Figure 5.17 Plot of Thorn & Co. sales, cost and profit 

STEP1 

STEP2 

Charting 
Thorn & Co. 
Profits the 
Easy Way 

Printing a chart 

With the chart on the top of the desktop pile, pull down the 
File menu and select Print Chart (you can also print the 
series of numbers). The usual Macintosh Print dialog box 
will appear . Click on high or standard quality (draft won 't 
work for pictures) and continuous or cuts sheet , depending 
on the paper you are using. Check OK. 

To save this work, pull down the File menu and select Save 
As. The usual Macintosh Save dialog box will appear. Type 
"Thorn" and check OK. 

Well , perhaps the easy way. The combination of Microsoft 
Multiplan and Chart allows you to copy tables from the 
Scrapbook onto the Clipboard, which will then draw charts 
just as if you had typed the numbers in. The tables can be 
from sources like a word processing system or from Multi­
plan. In the case of Multiplan, you can also establish a link 
(like the link between Multiplan files discussed in chapter 
4), so that you change the Multiplan file, the Chart also 
automatically changes. 

There are two complications, however. In the case of 
any table , Chart has a preset order of reading the columns 
and rows , which may not be the correct order for the chart 
you want. In the case of the link , diskette space is a prob­
lem. Microsoft Chart and Multiplan will not fit on the same 
diskette. If you have two disk drives, or one hard disk, 
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STEP1 

STEP2 

STEP3 

there is no problem, but if, as this book assumes, you have 
only one drive, you cannot support an automatic link. 

Chart chooses the order of reading columns and rows 
by whether the group is tall and narrow, or long and wide. 
If it is wide it reads row by row; if it is narrow or square it 
reads column by column . 

• ••• • • • • • • • ••• • • ' ••• 0 •••••••••••••••••• 

~ 4 Colu~ns : l..r-R~w b~ Ro~ 
.... ~;nu !'"' !"'' !'"'> .. ~. 3 .: ........ ~ ........ ; .. 

IIID !1111 IIID IDD ~ Rows ~ : 
0 ofDIDo 0 ~ 0 OfDIDo 0 miD 0 o]O 0 0 0 : 0 0 0 0]0 0 0 0 : 0 

00 0 oro~m-~oo~·+:Clo~:.n ... o~. OOOOooo~oOoo .o. : .. 

0 OID 0 m ·IDO 0 0 0
4 
~~':1~~0 0: .. 0 ~0 0 0-:. 

Ro~s ~ : ~ : o .. offiffio ooo.mffio. Jllo OoOOoOoo:oooooooooX:·ooooooo:ooooo .. o~o .... ooo:oo 

• • : • • • • • • • • • ~ • • • • : • • • • ~ • • : • • 0 • ~ • • • • : 

Figure 5.18 How Chart decides to read columns or rows 

The following 10 steps assume you have studied chap­
ter 4 on Multiplan. 

Insert the Multiplan diskette with Thorn & Co.'s profit 
forecast in the Mac. If the catalog does not appear, click 
twice on the Multiplan diskette icon to make it appear. 
Then click twice on the Thorn & Co. icon. 

In order to make Chart read row by row, the table 
must be wider than it is high. To make it wider, we need to 
remove the line of dashes (these would appear as a zero 
entry on the chart anyway). We are not interested in aver­
age profit for chart purposes, but it can be calculated later 
within the Chart program if needed. 

Move the cursor (a hollow cross) into the left margin of the 
table and select all of row 5 (figure 5 .19). Pull down the Edit 
menu and select Cut. 

Move the cursor into row 3 column 2 (100), and move it 
diagonally to row 5, column 5 (75.22). This selects all the 
numbers we want from this table (see figure 5.20). Pull 
down the Edit menu and select Copy. This stores a copy on 
the Clipboard. 
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l' nste Nnm~.. . 0 : $65.88 : $75.22 : 
Paste function... :?~:::::::: :s~: :4~ 'l,C :j~::s:i'li Pns1 H Nnml' ... 
Absolute flefermiOJ :•:r ------------------------· Paste function ... 

llbsolul<l fl <l f crenoJ :•:r 
.................... ....................... 

1-----------1 . . . 
XR .... ; .................. : .................. • 

Fill Right 
Fill Down xo 

.............................. . . fill Rlqht 

Figure 5.19 Cutting the dashed line out of the Thorn & Co. 

table 

Figure 5.20 Copying part of a Multiplan table onto 
the Clipboard 

STEP4 

STEPS 

STEPS 

STEP7 

Pull down the File menu and select Quit. A dialog box will 
appear that asks you if you want to save changes. You 
probably want to leave the Thorn & Co. file in its original 
form , so check No and click OK. The Thorn & Co. window 
will disappear and leave the Multiplan diskette catalog. 

Move the cursor into the Close box in the upper left-hand 
corner of the Multiplan diskette catalog and click twice to 
shrink the catalog into the icon. Note that the icon is then 
unselected. Click the mouse once on it to select it and then 
pull down the File menu and select Eject. 

As discussed in chapters 1 and 7, the Clipboard belongs 
to the memory in the machine , not any diskette. 

Just for verification, Pull down the Edit menu and select 
Show Clipboard. It will show your numbers for Thorn & 
Co. as in figure 5.21. 

10 Clipboard 
Sloo.oo Sllo.oo Sl2r.oo s1 :n.1o 
$50.00 52.5 55.125 57.88125 
$50.00 $57.50 $65.88 $75.22 

Figure 5.21 The Clipboard with no diskette in the slot 

Insert the Microsoft Chart diskette. Click twice on the 
Chart icon. An untitled Chart window and the New Series 
form will appear. 
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STEPS 

STEP9 

STEP10 

Pull down the Data menu and select Date. The Date Series 
dialog box will appear. Change the date in First Category to 
1/1/85 (or any other date in 1985), and then check OK. 

A new series window will appear. 

Pull down the Edit menu and select Paste. (If you had a 
hard disk or another disk drive, you would use Paste and 
Link to link information between this chart and the Thorn 
& Co. Multiplan table.) A series of New Series windows will 
appear named after the time. 

Figure 5.22 Generating a new series in a blank Chart file from the contents of 
the Clipboard 

Pull down the Data menu and select List (figure 5.23). The 
Series List dialog box will appear (figure 5.24). You can 
hide or show anything you want with this useful dialog 
box. If little boxes below Show have been checked, then 
they will appear on the screen. If the little boxes below 
Plot are checked, then they will be plotted. 

Number ••• 

Sort ••• 
Analyze ••• 

Figure 5.23 Selecting list from the 
Data menu 

Series List 

Show Plot 
181 181 Series 2:25:33 PM 
181 181 Series 2:31:24 PM 
181 ~ Series 2:31 :25 PM 

( OK ] [ cancel ] 

Figure 5.24 The Series List dialog box 

The Thorn & Co. chart will appear. Except for the 
Profit legend, it will be exactly as in figure 5.17. You can 
modify it with steps 10 and 11. 
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Is this way really easier? In the case of Thorn & Co. , 
with a small table, probably not. But if you have more data, 
or plan to change it frequently at the source and have two 
disk drives , it p robably is an easier method. 

The Gallery menu is a true candy shop of expository 
graphics. Merely pull down the Gallery menu, select the 
type of chart you are interested in, and a gallery of that type 
of chart appears. You pick one of the sample charts and in a 
few seconds, that version appears. Figures 5.25 through 
5.34 show some of the possibilities. All are not suited to 
Thorn and Co.'s data , but each is fun to try. 

3 4 

~-
OK [ Cancel ) 

Figure 5.25 Selecting an area chart 

S•lts 

$300J)() 

$2Sl.OO 

$200.00 

Ooll..-s $150.00 

$100.00 

$50.00 

$0.00 
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0 Yu rs 

Figure 5.26 An area chart of Thorn & Co. profit projections 
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Figure 5.27 Selecting a bar chart 

1988 

1987 

1986 

$0.00 $20,00$-40.00$60.00 $80.00 $100.0 $120.0 $140.0 

Do 11M' I 

Figure 5.28 Bar chart for Thorn & Co. 

Figure 5.29 Selecting a line chart 

0 0 0 
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$100.00~ 
$00.00 i . 
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$20.00 
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Figure 5.30 A line chart for Thorn & Co. 
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3 

' • 
OK Cencel 

Figure 5.31 Selecting a pie chart 

Figure 5.32 A pie chart for Thorn & Co. 

1 

r8 .... __ 
~ 

OK Cencel 

Figure 5.33 Selecting a scatter chart for Thorn & Co. (The sample charts 
where the lines gather together are log and double log charts) 

$140.00 
$130.00 
$120.00 
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0.11 $100.00 
¥S $90.00 
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$70.00 
$60.00 
$50.00 

• 
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v ...... 

Figure 5.34 A scatter chart is not very appropriate for sales forecast 
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STEP1 

STEP2 

~Thorn~ 
• • • 
• 51~1 • . . ~ . 

Figure 5.35 Selecting text on the 
chart 

STEP3 

Figure 5.36 Selecting text on the 
Format menu 

Playing With The Chart Gallery 

Borders and Faces 

Chart also offers many excellent tools for emphasizing 
or ornamenting elements of the chart. It is possible to select 
any element of the chart-the titles, legends, or the whole 
chart-and change elements like the typeface and the line 
quality. 

Return to the first version of the Thorn & Co. chart by 
pulling down the Gallery menu and selecting 
Combination; then select number two, which shows 
Profit as a line with it's own scale on the right. Check OK. 

You may have thought that Sales was not a good title for 
this chart. Roll the cursor, which is an arrow, near the word 
Sales, and click the mouse. Black squares will appear 
around Sales. Like the squares in MacDraw, they show that 
it is selected. 

Roll the mouse around the selection a little. You will 
see that the cursor changes into a double-headed arrow, 
which points horizontally, vertically, or diagonally, as it 
approaches the black squares. The changed cursor indi­
cates that you can move these squares by touching them 
with the cursor, holding down the mouse button (drag­
ging), and moving the cursor. 

Pull down the Format menu and select Text. 
The Text Format dialog box will appear. You can see 

that there are many possibilities. 

TeHt 

Font 
0 Geneua 0 I tallc 
0 New York 0 Bold 
®Chicago 

Rttoched To 
0 Unattoched 
®Chart ntle 
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Font Size 
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QLarge 
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Series Number: II 

F====~ 
Point Number: I 

Figure 5.37 The Text Format dialog box 
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Figure 5.38 Moving the Legends 
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Check the Chicago Font and Medium Font Size, and then 
check OK. 

When you move the cursor inside the selected area, defined 
by black squares, it turns into the 1-beam. Move the 1-beam 
to the right end of Sales and press the mouse button to put 
the blinking cursor there. Backspace until Sales disappears. 
Type "Thorn & Co. Forecast". 

Select the word "Dollars" on the right of the chart, pull 
down the Format menu and check Chicago, but make no 
other changes. Backspace to erase Dollars, and type ''Sales 
& Cost of Goods''. The system will supply carriage returns. 

Note that you can add other fonts to the list as dis­
cussed in the first chapter. 

Move the cursor into the box with the legends. Click the 
mouse. The selection squares will appear and the cursor 
will turn to arrows pointing up and down and right to left. 
Press the mouse button and slide the box into the lower 
right-hand corner. 

Move the cursor just right of $80.00 in the top right of the 
chart. Click the mouse. A hollow cross will appear. Type 
"Profit". As in the previous steps, pull down the Format 
menu, select Text, and check the Chicago font. 

If the text does not appear exactly where you want it, 
move the cursor near one of the black squares. The cursor 
will turn into arrows, indicating you can move the text. 

Pull down the Chart menu and select Select Chart (figure 
5 .40). Black boxes will appear to show that the whole chart 
is selected. 

Figure 5.40 Selecting Chart from the Chart menu 
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STEP10 Pull down the Format menu and select Pattern. The Pat­
tern dialog box will appear. Check the middle Border 
Weight and Shadow. Check OK. 

Patterns 

Background Pattern ® lnulslble 

••• ITIOE3DII~~Ifl ~ lif!I0ISI~ 

Border P11ttem 0 lnulslble 

••• 0 0 E3DII~~Ifl ~ lif!I0ISI~ 
Border Weight I o 
Border Style 
0 Norm111 0 Deuel 0 Double 0 Round ~Shadow 

[ OK ] [ Cancel 

Figure 5.41 Pattern dialog box 

Click anywhere else on the screen to remove the selec­
tion boxes, and the Thorn & Co. Chart will appear as in 
figure 5.42. 

Thorn & CO. Forecast 
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Figure 5.42 Thorn & Co. chart 
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Communications through 
l\.11acierrnioal aod ett 18[ 

Programs 

For some people, the most important thing about 
computers is that they can communicate with one another. 
The contrary idea that Steve Wozniac and others had, and 
that Steve Jobs and others have exploited, was to make a 
computer that you can use in the corner by yourself. Then 
what you can do depends on you and your machine alone. 
It's an important idea but the other idea remains: that 
communication is at the heart of information; that it is 
wonderful how many people can reach, add to, or change 
information that is in a single central computer. 

The Source illustrates one side of this phenomenon. A 
world of information and services is at your fingertips with 
your Mac, a modem, and a telephone. Electronic mail, 
discussed below in connection with Augment, is another 
kind of world, a world much like CB or, better, like ham 
radio, where people who are far apart but share common 
interests can communicate and not interrupt their work. I 
have enjoyed such a world. For example, I worked closely 
for several years with a programmer on computer publica­
tions projects and was instrumental in getting him a 
job-all by computer. It was some years later before I saw 
him for the first time. 

There are everyday, practical reasons to move files 
from one machine to another. What if you have an Apple II 
or an IBM personal computer and have just bought a Mac? 

125 
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How do you move your work to the Mac? (I answer that 
question below.) 

This chapter will show you how to use MacTerminal 
and the Apple program Access II to transfer files from a Mac 
to an Apple lie or lie and back; how to use the Dilithium PC 
To Mac and Back programs to transfer files from a Mac to 
and from an IBM personal computer, or a computer built to 
run like the IBM personal computer; how to use MacTer­
minal to reach the diverse on-line services of The Source; 
how to reach Trade* Plus and buy and sell stock; and how 
to use Augterm to reach Augment, the world's most power­
ful office automation system. 

The Source, Trade*Plus, and Augment are services to 
which you must subscribe. They charge by the hour and 
according to the degree and use you make of their com­
puter facilities. In the case of Trade*Plus you can arrange, 
through a broker, to actually buy and sell stocks, and 
through the Source, to buy a range of consumer goods. In 
each case the service supplies you with phone numbers and 
passwords that you must know in order to use the service. 

Computer hobbyists run many local on-line ''bulletin 
boards." They allow the inexpensive, often free, exchange 
of information and electronic mail. Other people who own 
Macs are often the best source of information about prob­
lems and programs: computer bulletin boards are a good 
way to get in touch with such people. 

The icon for MacTerminal is a telephone, which sells 
the program short since you can use it to communicate 
with other computers via a direct cable, and by a variety of 
other electronics, including the Apple cluster controller, 
which allows the Mac to work like one of many IBM termi­
nals attached to a large IBM computer. 

A word of warning. This chapter deals with very com­
plicated steps. The complications result from the many 
standards that compete to organize communication. Mac­
Terminal is adaptable and can accommodate many meth­
ods or "handshakes" as they are called in the business. At 
what speed, for example, are the characters going to be 
sent? 

More concretely, the plug on the cable must fit the 
socket in the other machine. Mac offers you a dozen pos­
sibilities, but you have to make the match. It is all a little like 
those societies where you are allowed to speak to but not 
marry your first cousins, marry but not touch or speak to 
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your second cousins, and marry and speak to but not touch 
your third cousins. The different rules make introductions 
lengthy and uneasy. You will see below that many steps 
match compatibility before any real relating is done. But 
that is the way it is in an industry where no one controls 
standards and that is the way it is likely to stay. 

Because the product of MacTerminal, PC to Mac and 
Back, and Augterm is communications rather than a file, 
using them differs from using programs like MacWrite or 
Multiplan, where what you get is a file. In most Macintosh 
applications a document is where you work on and store 
something you are working on. The document of a commu­
nications program is more like a window. When you click 
twice on the MacTerminal icon you create a window 
through which you can look into another computer. You 
may have to make some adjustments to that window before 
you can use it. You can in fact pass things through the 
window to the Scrapbook or files and then to other applica­
tions, or take ''snapshots'' of the window that you can pass 
on to other applications. While this is an important func­
tion, you do not work on information within MacTerminal 
itself, or within the other communications programs I dis­
cuss. 

Setting up the Apple II 

This section assumes you have an Apple lie or lie and 
the communications software called Access II from Apple. 
(The Access II program will not run on a II or II+ . A very 
similar program, Access III, exists for the Apple III.) Like 
most personal computers, but unlike the Macintosh, the 
Apple II acquires certain functions by means of cards, 
which users must insert into slots in the interior of the 
computer. These cards have electronics on them that sup­
plement the powers of the basic computer. Several cards 
exist for the Apple II to support communications with 
other computers. The card necessary for use with the 
Access II program is called a Super Serial Card, although it 
has nothing to do with a terrific soap opera. Super Serial 
Cards support either communications with other com-
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puters or with a printer. It is the common means by which 
Apple II's send pages to printers. To communicate with 
other computers the card requires some modifications that 
are simple for someone experienced with computer hard­
ware, but tricky for someone who is not. 

Make sure the Super Serial Card in the Apple II is in slot 2, 
and has the communications prom and dip switches set 
properly for communications functions. This is clearly 
specified in the excellent Access II manual. If you don't 
understand these terms, either study the manual carefully 
or get a knowledgeable person to help you. 

Connect the output socket on the Super Serial Card to the 
socket on the back of the Mac that shows the telephone 
icon. The cable that connects the Mac to the printer will fit 
fine, or any cable with the same set of plugs at each end. 

Insert the Access II diskette in the Apple II and turn on the 
machine. After various screens announcing the names of 
products, like the beginning of a movie, the Access II main 
menu will appear. (Access II is a menu-driven program.) 

A second diskette, and hence a second disk drive, is 
not absolutely necessary to use Access II. But the Access II 
program leaves very little room on the diskette it comes on, 
and if you want to move a file more than a few words long 
to the Apple II, you had better have a second drive. 

From the main menu type '' 3'' and press Return to evoke 
the setup menu. 

Type '' 2'' and then press Return. The speed menu will 
appear. The speed in force will be highlighted. If 9600 is 
not highlighted, type ''6'' and then press Return to select it. 
Press the ESC (for escape) key on the upper-left of the 
keyboard to Return to the settings menu. 

Type ''3'' and press Return. The parity menu will appear. It 
does not matter which parity you give these two computers 
to communicate so long as it matches. Type "1", press 
Return, and press ESC once to get back to the setup menu. 

If you plan to transfer files between these two 
machines often, the setup menu offers you the chance to 
save these settings on the diskette. With the save settings, 
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I Phone Keypad 
Terminal .•. ~ F.;: 

file Traitsfer •.. 
Answerback Message ••. 

Show Tab Ruler 

Figure 6.2 Selecting Compatibility 
from the Settings menu 

the next time you begin Access II you will not have to go 
through these steps to set up. 

Press ESC again to return to the main menu, type " 2" and 
press Return to get to what is called terminal mode. In 
terminal mode the Apple II will respond to the Mac 's key­
board rather than its own. The II is now waiting to hear 
from the Mac. 

Setting Up the Mac 

Insert a diskette with the MacTerminal program on it. If the 
disk catalog does not appear, click twice (double click) on 
the icon for the MacTerminal diskette to evoke it . 

A MacTerminal window will appear. The menus are 
discussed in appropriate sections below. Note that the bars 
at the sides contain no tools for scrolling. You can squeeze 
or expand the window by the size box in the lower right­
hand corner, but you can' t scroll in the normal way. Note 
that the cursor is an I-beam. 

' It file Edit Commands Settings Phone Keypad 

........... ........ ... ....... ....................... ...... ........................................... 110 Untitled 

Figure 6.1 The Mac Terminal window 

Pull down the Settings menu and select Compatibility 
(figure 6.2). (If you aren' t familiar with the process of 
pulling down menus and selecting items, see chapter 1.) 

The Compatibility dialog box will appear. 

Compatibility Settings 

Baud Rate 0 SO 0 75 0 110 0 134.5 

0 150 0 200 0 300 0 600 

0 1200 0 1BOO 0 2000 0 2400 

0 36~ 04BOO ® 9600 0 19200 

Bits per Charac1er 0 7 Bits ® 8 Bits 

Parity O Euen 0 0dd ® None 

Handshake ® HOn/ HOff O None 

Connection 0 Modem ® Rno1her Computer 

Connection Port ® I<?GI 0 IJ11 ~ r.::::::;"\ 
~~ 

Figure 6.3 The Compatibility dialog box set up to communicate with an Apple 
II using Access II 
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Figure 6.4 The file transfer 
settings dialogue box 
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In the Compatibility dialog box, check 9600 Baud and 
Another Computer; otherwise leave things as they are and 
check OK. 

Pull down Settings menu and select File Transfer. The 
File Transfer dialog box will appear. Check Modem and 
Other and then check OK. 

It is important that all the settings on the Mac agree 
with the settings on the Apple II. 

At this point, if you type a character on the Mac, the 
character will appear on the II and vice versa. Type a few 
characters to make sure it works. It is possible to transmit 
text from one to the other this way, but below I will show 
you a simpler method for long files. 

As MacTerminal documents are used, they tend to get 
cluttered, for example, the typing you may have done on 
the Apple II to see it appear on the Mac. If you are going to 
communicate between these two machines frequently, it 
would be a good idea to save the present file with correct 
settings with some such name as "lie." Then, whenever 
you want to start a session, you can duplicate the lie file and 
reserve a pristine document with the right settings. 

Mac To Apple II 

On the Apple II hold down the key with an outline apple 
and press ESC to Return to the main menu. Type "5" and 
press Return to receive a file. 

A screen will appear, asking you to supply the name of a file 
to hold the information that will come across. ·Assuming 
you have a second disk drive on the II, type "I 
seconddiskettename/frommac" and press Return. The 
"seconddiskettename" means whatever name you have 
given that diskette. Access II will offer you a list of file types 
with TEXT highlighted. Press Return to confirm that you 
will be receiving text. Note that Access II will not allow 
duplicate names, so if you transfer more than one file you 
must create and name a new file each time. 

On the Mac, pull down the File menu and select Send a 
File. 
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File Transfer Settings 

Transfer Method ® HModem 0 TeHt 

Remote System 0 MacTermlnal ®Other 

Delay Between Chars ju l I 60th Second 

Delay Between Lines l 0 I I 60th Second 

181 Retain Line Breaks 

181 word Wrap Outgoing TeHt 

Figure 6.5 Selecting Send A File from the File menu 

The File dialog box will appear (figure 6.6). You could 
select any text file, but the Notepad file is a simple example 
because it contains no formatting. See the section below on 
the PC to Mac for a discussion of the importance of format­
ting to file transfer. 

Clipboard File ~ 
Copy of lie 
Finder 
lie 
lmagewriter 
Mac Terminal 

~ 

II 
Send 

Cancel 

Figure 6.6 Selecting the Notepad file to transmit 

Terminal 

[ Eject ] 

Select the Notepad file and then check Send. 
A scale will appear on the Mac screen with a moving 

point that shows what percentage of the file has been sent. 
At the same time you should see the actual text go by on the 
Apple II screen. 

On the II press Return to confirm recording the transmis­
sion. 

Apple II to Mac 

On the II, press ESC to get to the main menu. Type ''4'' and 
press Return to get to the file transmission screen. 

A window will appear that requests the name of the 
file you want to send to the Mac. The file you just got from 
the Mac will do fine. 
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Mac to PC 
and Back 

STEP2 Type ''/seconddiskettename/frommac''. The ''second­
diskettename" is the name you gave the second diskette. 
Press N to decline the offer to use the Christiansen Protocol 
(don't worry about what that is). Press Return twice to 
ignore the issue of pausing between lines and characters, 
which is unnecessary between these two friendly com­
puters, and type Y to send the file. 

The text of the Notepad file will appear on the Mac 
screen. If you want to keep it in some other file, select it, 
copy it, and paste it into that file. 

This section uses a program called PC to Mac and Back from 
Dilithium. (For those who don't recall their Star Trek trivia, 
Dilithium is the technomagical crystal that powers the 
Enterprise.) Dilithium advertising stresses using the pro­
gram to transmit files between a Mac and an IBM personal 
computer, or one that works like an IBM personal com­
puter. In fact, the program is more widely useful and its 
functions largely overlap MacTerminal's. For example, it is 
possible to use The Source, or Trade*Plus, or typical local 
bulletin boards with PC to Mac and Back in pretty much the 
same way as described below. 

Both the Dilithium program and the manual use a 
vocabulary somewhat richer in computer jargon than this 
book and both tend to give information of interest only to 
computer hobbyists such as the information on the screen 
in figure 6.16. The manual includes a good treatment of 
computer bulletin boards. 

Preparing Files for Transfer 

When a computer program is designed to show some­
thing that is familiar to the user, more information has to be 
hidden behind the screen. The Multiplan screen show num­
bers and dashes. Behind the numbers stand the formulas 
that make them work, data that show how wide the col­
umns are, whether they are formatted with a decimal show­
ing, whether they are linked to other files and so on. 
Mac Write shows us a screen that looks like a piece of paper. 
Behind the screen are data to determine what the various 
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fonts are, whether they are bold, what the margins are, etc. 
Transmitting simple text or simple numbers from one com­
puter program to another is relatively straightforward. 
That is why when you type "y" for yes in using Trade*Plus 
or Augment below, it is simple to type and transmit. Trans­
mitting a sophisticated file like a MacWrite or a Multiplan 
file is more difficult because the program that receives the 
file can understand the characters or numbers, but cannot 
make sense of the information behind the screen. 

In the example of sending a file to the lie and back, I 
ducked the issue, for simplicity's sake, by using a Notepad 
file. Notepad files have no special formatting. The process 
for making text-only files, described below, will work as 
well for transfer to the lie as for transfer to IBM-type 
machines. 

Making a Multiplan SYLK File In the case of Multiplan, 
Microsoft has created the file format SYLK to allow trans­
mission of Multiplan files from one machine to another. In 
order to transfer a file to Multiplan running on an IBM-type 
machine, it is necessary to save it to the SYLK format. 

Assuming you have the Thorn & Co. file before you from 
chapter 4, pull down the File menu and select Save As. The 
Save As dialog box will appear. Type ''thorn & co'' to name 
the file, with a small t to differentiate it from the regular 
file, check SYLK, and check Save. 

Saue document es 

I thorn & co 

[ Saue ] ( Cancel 

0 Normal ® SYLK 

Figure 6. 7 Saving a SYLK file 

Multiplan ••• 

[ Eject 

Move the file to the PC to Mac disk by file transfer as 
described in chapter I. 

Making a Text-Only File MacWrite (and Microsoft 
Word) address this problem by allowing you to create files 
that have only text, not formatting information. It is possi-
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ble to transport such files to most other word processing 
systems. But you throw away the fonts, proportional spac­
ing, and other goodies like running heads and footnotes. 
The file will appear in the new system in whatever font is 
standard there and with each character taking up the same 
amount of space on the page, like a typewritten page. 

Assuming you have the For Bit Letter on your screen from 
chapter 2, pull down the File menu and select Save As. The 
Save As dialog box will appear (figure 6.8). Type "for bit 
letter'' to name the new file, using lower case to separate it 
from the regular file. Check Text Only and check Save. 

Soue current document as 

I for bit lette~ 

[ Seue~ ) ( Cancel 

MecWrtte ••• 

( Eject 

0 Entire Document ® TeHt Only 

Figure 6.8 Saving a file in the Text Only format 

v 
Sc 

Move the file to the PC to Mac disk by file transfer. 

Setting Up the Mac 

It is possible to set up a diskette so that an application 
immediately fills the screen without opening the catalog or 
clicking on the icon of the application. PC to Mac diskettes 
are set up this way. 

Insert the PC to Mac diskette and turn on the Mac. The 
screen will appear in "terminal mode" as in figure 6.9. If 
the catalog or the diskette icon appear, click on them to 
evoke the application. (Oversimplified a little, terminal 
mode mearis that the Mac is acting like a dumb terminal, just 
sending characters to another computer, which responds 
to them.) 
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Figure 6.9 PC to Mac screen in terminal mode 

Setting Up the IBM-Type Personal Computer 

Dilithium provides a diskette for the IBM-type com­
puter as well. The first time you use it is rather complicated 
because of the different operating systems (roughly the 

. equivalent of the Mac System Folder) that run on these 
machines. The diskette from Dilithium contains a program 
that will copy the operating system (called DOS for Disk 
Operating System with various version numbers) you are 
using from your diskette onto theirs. If you are using the PC 
to Mac program for the first time, follow the instructions in 
appendix A of the manual to set up your PC to Mac diskette 
correctly. 

Assuming your version of DOS is installed, put the PC 
to Mac diskette in the "A" drive and turn the machine on 
(many such computers have a way to restart the system 
without turning it off and on, which will work fine too). 

As in the case of the Mac diskette, the IBM-type disk­
ette comes with a startup program, which should present a 
billboardlike screen and then let you see the master screen 
of the PC to Mac program. If it does not, type "A:pctmac" 
and press Enter . 

Modem Cables, Eliminators, and other Connections 

The cable that Dilithium supplies includes a modem 
eliminator. That means you should plug it into a second 
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modem eliminator (called a ''null modem'' in the Dilithium 
manual) to counteract the first. 

IBM-type personal computers require cards that are 
bought separately and inserted in the computer to commu­
nicate with other computers. This program uses an IBM 
A TS or similar card. If such a card is installed correctly and 
available through your version of DOS, the words ''Coml 
available" or "Com2 available" will appear in the billboard 
screen. If they do not, you will have to check the hardware 
section of the Dilithium manual, or the manual that came 
with the computer or the card. 

Plug the cable supplied by Dilithium, which includes a 
modem eliminator, into the sockets that fit on the A TS or 
similar card in the IBM-type machine and into the socket 
with the phone icon on the MAC. 

Matching Communications 

The menus offer a variety of choices about the speed at 
which the two computers will communicate and the 
"mode" of data handling they will use. Any matching set 
will work for some purposes, but the most generally useful, 
if the two machines are connected by a direct cable, is 9600 
baud speed and PC to Mac mode, which are used in this 
example. 

On the Mac pull down the Control, Connector, Baud 
Rate, and Mode menus. If they do not match figures 6.10 
through 6.13, select the correct values. 

Connector 
! Erose Screen '!_c 
r---···-----

Keyboord Print 
.~Remote Ec:ho 

Smooth Scrolling 

.llluto Lf Off 
Ruto Lf Receiue 
Ruto LF Send 
Huto Lf Both 

Figure 6.10 Setting the Control menu for 
transferring files Between a 
Mac and an IBM-type 
personal computer 

BDUd 
v'Phone Socket 1 

Printer Socket 

~ 

Figure 6.11 Setting the cable socket 
for file transfer 
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Figure 6.14 Selecting Send from 
the File menu 
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Figure 6.12 Setting the speed at which 
the files will move between 
computers 

.IPC to Mat 

Figure 6.13 Selecting the PC to Mac 
File transfer method 

On the IBM-type machine press function key 9. The Config­
ure menu will appear. You can select the baud rate (9600), 
the transmission mode (PC to Mac), and some other param­
eters on that screen. If they do not match the values in step 1 
above, change them. In each list of choices, the choice that 
is in control is highlighted by contrasting color. You can 
move the highlight from one to another by pressing the 
arrow keys on the right side of the keyboard. 

Mac to PC 

On the IBM-type machine, press function key 1. 
The file-receiving screen will appear. It includes infor­

mation about the communications setup. 

On the Mac, pull down the File menu and select Send File. 
A dialog box will appear that is very similar to the 

normal Mac file-opening dialog box. The scroll box will 
show all the files on the diskette that you can send with the 
method you have chosen. Since we are using the PC to Mac 
transfer method, which can send any sort of file, all the files 
on the diskette are available, even the "pctmac" program 
itself. Of course, there would be no sense in transferring it 
since the program at the other end could make no sense of 
it. 
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lmogewriter 
Note Pod File 
PC to Moe 

p! ~lit] I PC to Moe& ... 

pctomoc 
Scropboolc File 
System 

Figure 6.15 Selecting a file to send 

I [ Eject 1 

[ Concel 1 I 

Some information will appear on the top of the screen: 
the length of the file , PC to Mac 's estimate of how long it 
will take to send it at the speed you have selected, and how 
many seconds the Mac has been waiting for the IBM-type 
machine to answer (see figure 6.16). The Mac will wait for 
an answer for up to a minute , and if it gets no response, it 
stops trying. If you set up the IBM-type machine correctly, 
it will quickly get a response and send the file. When that 
happens, a message to the effect that the transmission is 
complete will appear on the Mac (figure 6.17), and on the 
IBM-type machine. Note that the IBM operating system 
does not allow spaces in the names of files so it compresses 
the name to "thorn&co." 

Figure 6.16 The Mac screen while you are sending a file 

Figure 6.17 The Mac screen when you are done sending a file 

You could now use this file with the Multiplan com­
patible with the version of DOS running on the IBM-type 
machine. 
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Figure 6.20 The text-only icon is 
selected 
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PC to Mac 

For this example I assume you have sent the For Bit 
Letter file by exact I y the same procedure as carried the 
thorn & co file above. 

On the Mac, pull down the File menu and select Receive 
File. The Mac will anno unce its readiness on the screen. 
Again, if you do not send the other file right away it has a 
time-out mechanism, which appears on the screen as 
"waiting for remote to send, try # ," where # is a number 
up to ten. After about a minute, it gives up and reverts to 
terminal mode. These messages will be different if you are 
not using the PC to Mac method of file transmission. 

' * · I: <lit Control Connector Bllud Rille Mode Bre11k 

PC to Milt and Back 
Read\~ t o reeeive f l l e(s> . . 
t.Jol ting for fil e 1"10118 to be: r eeei ved frCMJ~ re111o te . <Cofi'Wflond . "' Conce l > 

Figure 6.18 Mac waiting for a file 

On the IBM-type machine press function key 2. 
The system goes into a sending display , which shows 

the method of sending files you are using (PC to Mac in this 
example), then asks you to type the name of the file you 
want to send. Type "forbitletter" and press Return . 

SEHO FILE -- Jrons fer ModP IS PC to na~ 
Enter F1l~~ ttu•~~(s) to s .... nd CEsc-Canc~l> f orh•tl.-ttf'"r 

Figure 6.19 Sending a file on the IBM-type machine 

Some more information about the duration of transfer 
and the length of the file will appear on both screens and 
the Mac will return to terminal mode. If you then close the 
PC to Mac window on the Mac, you will see the new 
"forbitfile" in the catalog. Note that some of the other file 
transfer methods require you to type the file name at the 
Mac end or to close the file , but the PC to Mac method takes 
care of all that. 

The returned file is text only (it contains no formatting 
such as boldface or footnotes) and will display the preset 
font that is current when you show it. Text-only files have a 
special icon that differentiates them from other word pro­
cessing programs such as MacWrite or Microsoft Word. 
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Modems, 
Modem 
Eliminators, and 
Noisy Phones 

Modems are boxes that attach to the telephone and to your 
computer. They convert electronic signals from your com­
puter into a wavering, screaming whistle. The wavers in 
the whistle carry characters through the telephone line to a 
modem at the other end, which reconverts them into elec­
tric signals for the computer. 

There are a variety of modems. Some modems 
embrace the telephone mouth piece with soft cups to catch 
the sound. More commonly, if your phone uses modular 
plugs like the plug the Mac keyboard uses, then you plug 
your modem into the wall socket of your telephone and 
plug your telephone into the modem. Modems commonly 
send and receive characters through the telephone at 30 
characters per second (called, strangely 300 baud) or 120 
characters a second (1200 baud). Some other speeds are 
available, including 180 characters per second and faster, 
but these involve special arrangements with the phone 
company. 

MacTerminal includes menu options that serve only 
certain Apple hardware products: the Apple Modem, 
Appline, and the Cluster Controller. Appline and the Clus­
ter Controller are used with the Macintosh to mimic certain 
IBM display terminals. 

Modems come with a variety of differing functions. 
The fancier ones allow you to store numbers in the com­
puter and use them without dialing, and allow the modem 
to answer the phone if another computer is calling. Mac­
Terminal is set up to take advantage of such features on two 
brands of modem: the Apple and the Hayes. Other modems 
that offer these functions will not necessarily work with 
Mac Terminal. 

I have elected to discuss MacTerminal with a simpler 
modem on the grounds that some users will already own 
simpler modems, and others will not want to buy the 
expensive Apple or Hayes products. My instructions are 
good for the Apple and Hayes products if you omit the 
added features available through MacTerminal. 

Unfortunately, how you use modems varies consider­
ably, so operation of your modem may differ even from my 
simple modem. The modem I have chosen is the Ven-tel 
212. One advantage ofVen-tel is excellent product support; 



j 

Communications through MacTerminal and Other Programs 141 

if you have a problem using your Yen-tel, the people at the 
other end of the customer support number have proven 
helpful and knowledgeable. 

Some little cables called "modem eliminators" and 
their remedies cause f~rther complications. One of the few 
standards in this area is that a computer should be able to 
recognize whether it is connected to a modem or to 
another computer. For recognition and other reasons the 
wires in a modem cross. The moment this standard was 
established people began to circumvent it. For one thing 
they invented a short stretch of cable with the wires 
crossed back called a modem eliminator that you can use if 
you want a computer to think a modem is there when none 
is. 

If you prepared an Apple to talk to a Mac, and followed 
the instructions in the Super Serial Card manual, you would 
have pulled out a chip in the card and turned it upside 
down. This inversion simulates a modem eliminator. Sev­
eral of the items to check in MacTerminal simulate or defeat 
a modem eliminator. It's a mess from the viewpoint of 
anyone but a specialist. All I can tell you is: follow the 
instructions of the modem manual, and if nothing seems to 
be happening, one of the first pieces of troubleshooting you 
do is to add or subtract a modem eliminator cable. In the 
examples below I state whether you need to use a modem 
eliminator in the specific setups I discuss. To confuse mat­
ters further, modem eliminators are sometimes called null 
modems. 

Another problem in using computers over the phone is 
noisy phone lines. If, for example, someone picks up 
another extension on your line you will see a bunch of 
strange characters on your screen and the computer you 
are connected to may receive strange commands. Static on 
the line may appear as strange characters or a strange 
response from the computer you are trying to use. For­
tunately, the character that most resembles noise is not part 
of the alphabet, but a control character that cancels com­
mands, so you most often get to try again and seldom ask 
the distant computer to do something you don't want. As in 
conversations, some connections are better than others; if 
strange characters keep appearing, hang up and start over. 
If problems on your line persist, call the phone company 
and ask them to check your line. 
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The Source is a service offered by the people who run the 
Readers Digest. By connecting to The Source you can get 
the latest sports and business news, and information about 
many other subjects; you can send and receive electronic 
mail from other Source users. You can shop, follow the 
stock market, buy and sell stock, post things for sale, scan 
airline schedules, make reservations, and do many other 
things, a list, which is growing daily. To use The Source you 
have to join a group, and you pay an hourly rate for using it. 
The address is in the back of the book; they will be happy to 
sign you up. 

Compuserve, Dow Jones, and Delphi offer similar 
services. 

Reaching The Source 

Using any public computer network involves several 
successive steps. You can get access to The Source through 
several networks in the U.S., but since the most common in 
the U.S. and the only one available in most countries out­
side it is Telenet, I have chosen Telenet for the example. 

Reaching The Source through Telenet involves five 
successive identification steps. The first is dialing the Tete­
net phone number. When you have made the telephone 
connection, Telenet will ask you to identify the type of 
terminal you are using; since people use hundreds of kinds 
of terminals, the Telenet programs must adjust to them. 
Telenet is only a means of reaching some computer, and it 
next asks you to identify which of the hundreds of com­
puters attached to Telenet you want to use. You supply the 
number of a Source computer, which The Source supplies 
to you with membership information. The Source com­
puter then asks for an identification number. This number 
tells The Source who to bill, among other things. It then 
asks for your password. This is a secret name that prevents 
other people from running up a bill on your account or 
reaching private information. Only then do you see the 
phrase "Welcome to the source." 

Connect your modem to the telephone. In the case of the 
Yen-tel 212 and many common modems; this means: 
unplug your (modular) phone from its wall connection and 
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Figure 6.21 Establishing contact 
with The Source 
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plug a cable from the modem in its place. Plug your phone 
into a socket in a box that goes with the modem, which you 
just connected to the telephone company. 

Connect your Mac to the modem. In the case of the Yen-tel 
212 and many similar modems this means: plug the Mac 
printer cable, or any similar cable, in the port on the Mac 
marked with a telephone icon, plug the printer cord of the 
Mac cable into either end of a modem eliminator (see 
above), and plug the modem eliminator into the socket on 
the modem labeled business machine. You can connect the 
cable that comes with the PC to Mac program directly from 
the Mac to the modem, because it includes a modem elim­
inator. 

Put a diskette with MacTerminal in the Mac and turn it on. If 
the catalog of the MacTerminal diskette does not appear, 
click twice on the diskette's icon to evoke it. Then click 
twice on the MacTerminal icon (a telephone). 

The MacTerminal window will appear (see figure 6.1). 
You need not change any preset values in the Settings 
menu if you want to communicate at 120 characters per 
second. The 120 characters per second setting gives faster 
response and it's more fun to use. Its disadvantages com­
pared to the other common speed, 30 characters per sec­
ond, are that The Source is more expensive at 120 
characters and that some modems won't run faster than 30 
characters per second. 

On a common modem such as the Ven-tel212, dial the local 
number of Telenet. When you hear a high-pitched scream 
from the telephone, flip the switch on the modem from V 
for voice to D for data. Then press Return on the Mac 
keyboard twice. If for some reason you do not connect, 
hang up the phone, flip back to V for voice and start over. 

Type "D1" and press Return. An at sign, "@",will appear. 

Type "c", press the space bar, and type your terminal 
identifier code, a number provided to you by The Source. 
Press Return. A message that says a terminal with your 
number is connected to The Source will appear. 
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Type '' ID'', then press the space bar, and type your ID 
number (also supplied by The Source). Press Return (see 
figure 6.21). (Note that the terminal identifier and ID num­
bers in this figure are mine.) 

The Source will ask for your password, a string of 
characters The Source will supply you (and which you can 
later change yourself). Press Return. 

The Source welcome message will appear (figure 
6. 22). The main menu gives you a chance to see some of the 
things The Source offers. 

II<T~7 <user 44> 1()9ged in Frida\1, 21 Sep 84 20: 17:24. 
U.l c:ooa, \IOU oro connected to THE SOtR:£. 
Last l09in Friday, 21 Sep 84 19:56:44. 

<C> COPYRIGHT SOURCE TELEC01PUTII'iG CORPORATIOH 1984. 

How at 1200 baud, an extra value service. 

fhis account has 254 minutes l"ttiiiining. 

lo!ELCOt1E TO THE SOURCE 

I US lNG THE SOURCE 
2 TODAY 
3 BUS I HESS UPOATE 
4 THE SOURCE I1A I tl 11EiiU 
15 IIHAT'S t!EI.I 
6 CotiiWID LEVEL 

En tor ita nwber or HELP _ 

Figure 6.22 The Source welcome message 

Getting Information from The Source 

Type "2" and press Return. The Today menu will appear. 

Ent.,. I tom nu11ber or HELP 2 ................. 
TODAY ****** 

Frida!,~ 

Septeaber 21, IQ84 

I A DAY TO REtiEMBER, BECAUSE ... 
2 YOUR HOROSCOPE FOR TODAY 
3 T\1 HIOHLIGHTS 
4 CRITIC'S CHOICE: A Soldier's Story - Go-eat Tansct Dra:aa 
5 OPIHIOH FORUM: A Bettor Post For Meese 
6 FEATURES: The Costs of Drug Abuse 
7 PEASOHALITIES: Ri~Jers at Grace land; People <Ferraro Lookal ikos Plcnti ful > 

ReiM!alber: For the latest neas of the day, type BULLETIH 
For all the sports results, bJPe SPORTS 

Enter I to• number or Holp _ 

Figure 6.23 The Source Today screen 
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You can find many things in The Source by going 
through the menus. If you have more specific desires, 
which you generally would if you were an experienced 
user, you can type the names of what you are interested in. 
For example, you may be interested in what is posted about 
Mac on the Apple bulletin board. 

Type ''Quit'' and press Return. An arrow (-)will appear. 
The arrow means The Source is waiting for commands. 

Qui ttlng .. 
-> post apple 
APPLE 

<R>eod, <PO>st, <PU>rge, <S>ccn, or <H>elp:s 

<C>atQ901'V, <U>str 10, <D>ate, <K>e..,.ord:k 

K...,.ord<s> or <H>elp: t1RC 

Figure 6.24 Searching for Apple Mac on the bulleting board 

Type ··Post Apple'' and press Return. A prompt menu will 
appear. 

Type .. S" for scan and press Return. 
A request for further definition of your search will 

appear. 

Type .. k" for keyword and press Return. Then type "mac" 
and press Return. Upper and lowercase can be used. 

A prompt will appear that includes Return to see all the 
listing. 

Press Return. 
A list of the current items related to the Mac on the 

Apple bulletin board will appear. 

I 21 SEP STP482 11RCIHTOSH STRRT UP C0t111Ati0<APPLE> 
2 21 SEP CL3631 I'IAC..FILE..VISiott<RPPLE> 
3 21 SEP STL769 I1AC FILEVISiott<FFPt.E> 
4 21 SEP STS403 me TO I Bn?<APPLE > 
5 20 SEP STX383 meiHTOSH ~-~-<APPLE> 
6 20 SEP STX383 I'IACIHTOSH ~--t1RCGAS-<APPLE> 
7 20 SEP STI765 P .D. me RAER<RPPL£> 
8 19 SEP B8Y944 USE OF lfRCIHTOSH/SPECIAI. C01111At1D<RPPLE> 
9 18 SEP STX416 HELP UITH I'IACIHTOSH t£EDED<RPPLE> 
10 18 SEP BCV376 11RCIHTOSH RRrt EXPArtSiott!! <APPLE> 
II 18 SEP B8J606 I'IACTEP HELP! <APPLE> 
12 18 SEP BBD32 llOU JotfES ST. Tfi.J( FOR nRC<RPPL£> 
13 18 SEP STX416 ST I1RC -> COMPUSERIJE<APPLE> 
14 17 SEP TCI989 ID>ICS <C> ott I'IACIHTOSH<RPPLE> 
15 16 SEP TCW21 11RCIHTOSH I.JPGRfU<APPLE> 
16 16 SEP CLI701 11RCIHTOSH HRRDORIUE FOR SALE<RPPLE> 
17 16 SEP BC0797 I1RC ROtf ROUTII'IES?<RPPLE> 
18 16 SEP TCG685 >» LQI.IEST PRICES ott 11AC S/11 «<<APPLE> 
19 15 SEP ST5468 I1AC nRCTERtiiHAL<RPPLE> 
20 15 SEP ST5468 I1RC 11RCTERtlltfAI.<RPPLE> 
21 15 SEP ST-.1263 11RCIHTOSH GRMES<GRMES> 
22 15 SEP STJ263 I'IACIHTOSH ~<APPLE> 

Enter it:GD<s>,<H>elp,or Return for 1110re : 

Figure 6.25 Apple Mac items on The Source bulletin board 
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Note that you can copy any information you see from 
the screen in MacTerminal and put it in the Scrapbook or on 
a file. 

To leave The Source, type "Quit" and press Return until 
the symbol of the top command level (-) appears. Then 
type "Off" and press Return. You can also leave The 
Source by hanging up the phone, but it will cost more, 
because the system will keep running for awhile at your 
expense. 

What is Trade*Plus? 

Trade* Plus allows you to connect to a central com­
puter where you can learn the state of the stock and bond 
markets, and the performance of individual stocks you 
follow. If you have established an account with a broker, 
you can buy and sell stocks, which will automatically 
appear in your on-line portfolio. At any instant you can see 
the automatically calculated value of your account, includ­
ing various tax factors and the like. Furthermore, with a 
program like MacTerminal you can copy the information 
about a stock or the state of your account onto your own 
diskette for further manipulation with, for example, Micro­
soft Chart. 

You can get information about how to join Trade* Plus 
by phoning or writing the addresses in the back of this 
book. As with The Source, you pay an hourly rate. 

Dow jones offers a similar service through its Straight 
Talk Program. 

How Trade* Plus Works 

To use Trade*Plus you use almost exactly the same 
steps as for The Source. When you have established contact 
a menu appears with numbered items. The items are 
arranged by number in layers. Whenever you want to see 
one of the items, you type the number and press Return. 
This process of typing in commands line by line and typing 
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~~~~~ n 
TERMINAL~ 

4 15 53P Corir£CTED 

Dt1007Saoo: ~ 
Password: 

Figure 6.26 Connecting to Trade· 
Plus 
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-welcon to Trade.Pius Service 
- Copo,ri;ht 1983 -

- 09:24 Pl1 EDT 'il/24/84 1205.06 +3.3 
-Stock !latch is l1cnu • 111-
••• TYPE N1JI'ISER TO 5a.ECT ... 
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a Return after each command is the way computers used to 
work in the bad old days. The Trade*Plus system is simple 
enough that despite its archaic command style it is rather 
simple to use, and it is clearly explained in the manual. For 
example, all things to do with ordering are numbered in the 
20's. You type 20, press Return, and you see the order 
menu. If you type 21 and press Return you see a menu about 
ordering stock. If you type 211 and press Return, you initi­
ate the procedure for ordering a stock. 

Set up the Mac exactly as for The Source (see' 'Reaching The 
Source" in this chapter). 

On a common modem such as a Ven-tel212, dial the local 
number of Telenet. When you hear a high-pitched scream 
from the telephone, flip the switch on the modem from V 
for voice to D for data. If you are using an Apple Macintosh 
modem follow the manual's instructions for dialing. 

Press Return on the Mac keyboard twice. "TERMINAL=" 
will appear. 

Type "Dl" and press Return. An at sign,"@", will appear. 

Type "c", press the space bar, and type your terminal 
identifier code (figure 6.26). Press Return twice. 

Trade* Plus will ask you for your user name, something 
Trade*Plus will supply when you join. Type it and press 
Return. 

Trade* Plus next asks for your password, which Trade* Plus 
will also supply to you when you join. Type it and press 
Return. The Trade*Plus welcome message will appear. 

Figure 6.27 The Trade*Pius welcome 
message 
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Type 1 and press Return to see the main menu. 

*** T""'E HUMBER TO SELECT ... fi"l 
- 1 MAIN MEI'PJ - U 

2 CHAHGE PASSIIOROS 
7 UPDATE DISKS 
8 HEllS 
9 HELP 

10 PRICE MENU 
20 ORDER MEI'PJ 
30 PORTFOL I 0 MENU 
40 RECORD MENU 
50 I HFORMAT I Ott MEt!U 
60 ANALYSIS MENU 

0 SlOtt OFF 

Figure 6.28 Trade*Pius main menu 

Type "Ur' to show the current values of your stocks. 

- TYPE ttmBER TO SELECT. . . LJ" 
- 111 STOCK &lATCH -
- Closing Prices -
- 09:29 Pit EDT 9/24184 1205.06 +3.3 

• STOCK CURRENT CHAt«lE TRiiO L Itt IT 
1 ARPL 26 518 - 318 + 
2 1Eit1 123 3/4 - 1/2 - u 
3 DEC 99 5/8 + 3/4 + U 
4 Gl1 77 118 + 1 u 
5 GE 55 718 + 5/8 + U 
6 EFH 32 5/8 - 3/8 -
7 ItER 31 1/2 - 1/4 + 
8 loiCI 20 318 • 118 -
9 ABC 72 1/4 U 

10 cas 82 118 - 1 SIB u 
11 RCA 35 3/4 - 1/8 
12 MCIC 7 1/4 + 118 + 
13 C\IGT 13 - 1/4 + L 
14 SPX 165.28 - .39 - U 
1s XMI 236.08 + .sa u 
16 ttvfl 95.38 - . 18 

- Type CTRL/C ta Escape -

Figure 6.29 Trade* Plus Stock Watch 

I do not actually own these stocks (this is a faked 
demonstration account provided by Trade*Plus). But let's 
pretend you do own them. You may want more informa­
tion about an individual stock. 

Type "113" and press Return. Trade*Plus will quote you 
the closing price of the most recent day and then ask for a 
stock symbol. In this example, type ''aapl'', the symbol for 
Apple Computer, and press Return. The current price of the 
stock and other information of interest to people who play 
the stock market will appear (figure 6.30). 

Trade* Plus asks you at the bottom if you want to see 
the same information for any other stock listed on the 
major stock exchanges. But let's go on to see the status of 
the accounts we have that house the various stocks. 
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~·~ ~~~~~ci~ ~~~~~T ;_ .. (@] 
- Closing Prices -
- 11:24 PM EDT 9/24!84..Jm06 +3.3 
> Stock Symbol ........ ~ 
APPLE COMPUTER I tiC 
Exchonge of Last Trado: NASOAQ/NMS 
Price: 26 5/8 
Bid: 26 1/2 
Ask: 26 5/8 
Trend: UP 
Change: - 3/8 
Dividend: 0.00 
Yield: o.o 
Earnings: 0.9S 
PIE Aotio: 28.0 
Prev. Close: 27 
Open Today: 26 3/4 
High Today: 27 
Low Today: 26 3/8 
UoiWIIe Today: 352,700 
> Another Quote: <Y,N> .. 

Figure 6.30 Information on a single stock 

Type "n" to refuse information about more stocks and 
then press Return twice. The TYPE NUMBER TO SELECT 
prompt will appear. Type "211" to ask to buy a stock. 

The Trade* Plus Order menu will appear. 

- Account: DIRK URN NOUHUYS ••""OEMO••• -
- T\IPQ CTRL/C to Esc:ope -

<N>ew Order, (C>anc:el ForHr Order, 
or < l>f Nothing Done Order . 

> Order Type: <N,C, I> ...... (nJ 
<P>ersonal, (I >RA, <K~ 

> Portfolio <P,I,K> ......... IPl 
> Stock Syatbo I . . . . . . . . . . . . '!22iill 

APPLE CotiPUTER INC 
Closing Price is. 26 5/8 
Bid....... 26 1/2 
Ask............. 26 5/8 

> <B>uy or <S>el I . fliJ 
<C>ash or <M>argin Account 

> Ac:c:ount <C,M> ............ t 
> Number of Shares ......... I 
> Price:Your Lie~it or <M>kt. 
> <G>TC or <D>ay Order .... 

<C>Mck, <S>ummit Fund, 
<F >unds in Ac:c:t 

> Pa.pent Method <C,S,F> III 
>Deliver Certificate: <Y,N>Iiil 
> Password ................. ~ 
You how OAOEAEO the folio-ing· 

Figure 6.31 The Trade*Pius order procedure 

Respond to the stock order procedure by typing the boxed 
characters in figure 6.31. After typing each character press 
Return, including where you type "Y" for yes or "N" for 
no. 

The Trade* Plus order confirmation will appear. 

Type ''Y'' to confirm the order and a binding message will 
go to your broker to buy the stock; your money is commit­
ted. 
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To quit Trade*Plus at any time, type "0" and press 
Return. If you are using a Ven-tel or similar modem, turn 
the switch from D to V and hang up the phone. 

Augment, currently offered as part ofTymshare's network 
services, is the outgrowth of many years of research at SRI 
that was led by Doug Engelhart; more thought has been 
given to this system than to anything else you have read 
about in this book. Incidentally, the invention of the mouse 
was part of that research. 

Engelhart and other researchers were the first to con­
sider what might be done on computers with text in a 
practical way, and the years' headstart allowed Augment to 
flower into the most powerful system available for office 
automation. Imagine that somewhere in the world there 
exists a system of paper and pencil, typewriters, libraries, 
postal service, publishers, book printers, card files, pub­
lishers; the Augment system offers a complete electronic 
version of it. It is also complex to learn fully (although some 
parts are easy to learn), and it tends to be expensive and 
slow. 

You can subscribe to Augment by getting in touch 
with the provider, currently Tymshare, at 20705 Valley 
Green Drive, Cupertino, CA 95014. 

How Augment Works 

The Augment organization provides its customers 
with a special Macintosh application, Augterm, that takes 
ove the Mac and makes it resemble a standard Augment 
terminal. The advantage of this program is that it allows 
selection of text on a distant computer with a mouse just as 
on a mouse-based local system. It also allows certain other 
information handling refinements. The disadvantage is that 
it does not allow the copying of files or any information to 
or from the Macintosh. Users of Augment can also use 
MacTerminal; in that case you can send and receive files 
roughly as described in other parts of this chapter, but 
cannot use the mouse to do things on the distant computer, 
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and you lose some of the power of Augment. The examples 
in this chapter use Augterm. 

To reach Augment you evoke the Augterm application 
and supply identification information to Tymnet similar to 
the way you supply identification information to Telenet 
for The Source and Trade *Plus. This identification infor­
mation includes identifying yourself to TENEX, the operat­
ing system that runs on the computers that support 
Augment. TENEX resembles what's in the System Folder on 
the Macintosh. Augment runs as an application based on 
TENEX. 

When you have identified yourself as an Augment 
user, the screen shows one workspace where you can point 
to things and work on them, as in a Macintosh application, 
rather than typing lines and ending them with carriage 
returns as on The Source or Trade*Plus. You can do a 
world of work with Augment, but we will go through only 
one small example: sending and receiving a simple elec­
tronic mail message. 

Starting Up Augment 

Put an Augterm diskette in the Mac. If the Augterm diskette 
catalog does not appear, click twice on the image of the 
Icon to evoke it. Click twice on the Augterm application. 
Augterm does not require a modem eliminator. 

The Augterm application will take over the screen. 
The three Macintosh menus allow you to copy the 

whole screen. The lozenge-shaped buttons across the top 
of the application window can be clicked to get certain 
Augment services. 

Dial the local Tymnet number, which Augment will supply. 
When you hear the high-pitched scream, if you are using a 
Ven-tel or similar modem, switch from V to D. X's, vertical 
lines, and sometimes other characters will appear to show 
you have made contact with Tymnet. 

Type "a" twice. The "a" let's Tymnet know what kind of 
terminal you are using, as does "Dl" in the case of The 
Source. An inscrutable number (the number of the part of 
Tymnet you have reached) will appear followed by ''Please 
log in.'' ''Log in'' is a piece of jargon that means to establish 
a connection. 
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Type your Tymnet identification, which Augment will sup­
ply, and press Return. The Tymnet identification in the 
example is " apple!"; yours will be different. The word 
"password" will appear. Type your password, which Aug­
ment will supply, and press Return. To safeguard its 
secrecy, the characters of your password will not appear. 

The Augment welcome message will appear (see figure 
6.32). 

Type your user name and press Return. 
The user name in the example is Horton, yours will be 

different. You can negotiate your user name with the Aug­
ment people when you buy the service; it is usually the 
personal name of a user or of a using organization. 

The prompt "(password)" will appear. 

pos.--d : c::::::J 
IJeiCOM to AUGtENT Ser,dce fro~~ Offic:e-15 

~ 
Cpos1000rd > c::::::J 
CAc:count> O 
.Job I 8 on TTY 10 27-Sep-84 17: 43 
Previous l o;ln: 27-Sep-84 16:50 

Figure 6.32 Connecting with Augment 

Type your Augment password and press Return. Again the 
text will not appear on the terminal. " Account" will 
appear. Press Return to accept the account preset to your 
name. 

Some information about the last time you used the 
system will appear followed by@. 

Type ''Aug'' and press Return. 
The Augment screen will appear. Augment uses the 

whole screen, like a Macintosh program, instead of scroll­
ing line by line the way Trade*Plus and The Source do. 

Augment has several functions and the user gets to 
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decide which function he or she wants to see first. You 
could, for example, see an editing system or a Multiplan­
like function. In this example the electronic mail function is 
preset to appear. Mail had been sent to Horton since the last 
time he logged in, so a message to that effect appears. 

In Augment you can type a question mark (?) at any 
time to get a listing of what you can do. 

Type " ?". 
A list of commands in the mail system will appear. 

l'llll c 1 
CUrrent o l tet""f'fllves ore 
<>Ac:t - <>Check <>eo..tnt Copv o treote 

Delete <>Ed i l Execute ( ' Elq>o..nge F.,......d Go to 
Holp ~ Logout """" <>Pass <>P ick~,o~p 

<>Point Print ().<it <>Reset Send <>Set 
<>Show <>Sort T\JP* <>Undele t e '!'>dale I 

<LF> <TFIS> \ 
C: 

Figure 6.33 Commands in the Augment mail system 

The Augment system has an on-line question-answer­
ing system similar to that of Microsoft Word, but much 
more extensive. Extensive on-line question-answering is a 
virtue of well-designed, large computer systems. In the 
case of Augment, you can call for help at any point in your 
work and the system will give a summary of what you are 
doing and a menu of related subjects. 

Roll the mouse up to the Help button at the top of the 
screen and click the mouse button. Help information will 
appear. 

tie• .all picked up 
C/T : 

no11 
t1o l l Is the RIJGI'£J1T S\bs\lst .. used t o send electroni c: .ai I t o one or ..or..., 

l ndlvici.lals and to f'eod and ~ .all vou ..-.eeive. It also at lou 1J0U to 
edl t tp.r .ai I befor"e swdin; It and to desl;n yt:A/1" OWt fon.al for o -SSQ941: . 
To r eceive your -a i l , \IOU need to requut a .allbox, .tlleh is..._...~ aall 
•Ill be delivered. Once IJOU hove o .a i I box, IJOU •I ll be: told .taen vou hove 
recel.....c:t new .ail . You then pick up these new .. u09es (In o .al l f i le 
created b\f PAJGtEHT ) us ing c:~s In 11ol I . You con r eod, pr int , sor t , f i le, 
and le<r'C:h for .ai I It-s u sln; c:o-onds In Mol l ; vou con also r.ad ond hcndle 
.ai 1 I t .. s us i nq co.aonds In other AlXH1EtfT subs\lst .. s* Includ ing the universal 
j-..plno co-or'Jds. Thus* t1ai I c:on be: w:ed alone or In conj\onC:tlon •ilh o ther 
AUCit£ttT sl.bS!pl..S and oppllcollons . Moll al so alio-s VOU to reeot'd "SSOOU 
and ~ts i n various cenlrol I i braries coiled jCM.rf'ICJis, for el ther private 
or public~ r"ef........-ce . 

1. Mlscei iCWWOUS a:nd o l lernole l ....-.s 
2 . too. to use t.he t1a I I sl.bsvs: t .. 
3 . ~.s in the f1oll .sl.bsystH 

Figure 6.34 The Augment mail system description 
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<To> hofoton 

2 new-mall 
2A TVM-DAP 

Figure 6.36 Addressing mail in 
Augment 

Roll the cursor up to the "Cmd Del" (for Command Delete) 
button at the top of the screen and click the mouse button. 

The Help information will disappear to reveal your 
current mail. Figure 6. 3 5 shows a typical list of messages to 
a member of the Augment staff. This staff member helped 
users w ith problems. By the way, this particular user has 
since joined a monastery , where even electronic mail can ' t 
reach him. 

MAIL C: 

2 new-.all 
2A Tvn-DAP-41J30C 19-..A.l- 84 Your 0 i rector.., 
28 TVM-DAP-4<13TG 19-Jun-84 Re : o-G Toclc>,l 
2C TYM-Dfi>-4U3TH 19-...a...r84 F i les 
20 TVM-Df*"- 4U823 21-.Jt..n-84 F i les: for Dole 
2E TYM-DFP-4U82A 2 1 -~-94 Re: F i les Not Tt\ere 
2F TYM-FEE0-41J80H 21-"""'-84 Re : Fi Its for Dole 
20 TVM-LMP-4YILV 27-...h.a-l-84 Probleas with Y04.r Di r on OF I~ 
2H TYI1-FEE0-4YittJ 27-..kll-84 Re: : PrcOI .. s •ith Your Dlr- on OF I5 
21 Tvn-EKM-4Y 10Z 27-Jun-84 DRH Core Poc:k-
2J T\oT1-U1P-"YU.t0 27-..Jun-84 Re : Proble•s •lth Your Oir on OF IS 
2K TYN-PKA-4Y49U 28-Jun-84 TestinQ ••• Ar-e You Out Thl:r"e'? 
2l MAILER- 4Z218 2-..-..1-84 Undo I iverobl o ""'I I : COR-DRH-4Z212 
2t1 MA ILER-4Zo4H8 3-..tul-84 Del I very ocknowle~e .. enl : COR-ORH-4Z4t1J 
2tt TVM-DAP-4Z53H 3-""-'1-84 Ac:k-Fkpt : Just CNckin' In 
20 TYf1-oFP-4ZS3P 3-.Jul-84 Re : .Just ~In' In 
2P TVI1-0fWI'-4Z9U. :J-.Jul-84 Re : TRS 80 
20 TYIH'I<A-50270 &-..-..1-84 HI 
2R TY!I-SGI(-508ZJ 9- ..-..1-84 F oo-.orded On t-
2S TVM-EKII-~120X 11-..-..1-84 Re : Hot t1ow Nulobor 

Figure 6.35 New mail for an Augment user 

This and similar systems have many powerful and 
complicated options, such as sending messages to members 
of a group, with or without the members knowing whether 
the message has been received ; however, it is easy still to 
send a plain message. 

Sending Mail through Augment 

Type "S" (for send), " N" (for new) and ho ld down the 
Command key and press key D. 

In using the Augment system, holding down the Mac­
intosh Command key does what Return does on The Source 
and Trade*Plus; it causes a command to execute . Upper or 
lowercase typing doesn't matter in any Augment com­
mand. The system will echo "Send New". Some characters 
follow "Send New" on the screen ; they allow you to use 
more complex options that are irrelevant at the moment. 
The system asks "(To)" . 
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STEP2 

STEP3 

<Cc:> michael 

2 nn-mai I 

Figure 6.37 Addressing a copy in 
Augment 

STEP4 

<Subject> Dellonstration of Mai I 

Figure 6.38 Giving a message a 
title in Augment 

STEPS 

STEP& 

<Send nocf?) Y/tf/C: 

Figure 6.40 Saying "Yes, Send the 
Mail Now." 

Type in your own user name to send the sample message to 
yourself, then hold down the Command key and press D to 
send. 

Augment will respond by asking if you want to send copies 
to anyone else. If you don't, hold down the Command key 
and key D and it will go on. If you do, type in the other 
user's name (Michael in the example) and hold down the 
Command key and key D. 

Augment will ask you for the subject (title) of the message. 
Type a title and then hold down the Command key and key 
D. 

The mysterious characters "M/1/(A]" appear. They are 
a prompt to let you know that you can type text, "T"; mark 
for selection with the mouse some text on the screen, ''M''; 
or address some offscreen text, ''(A)''. 

Augment will ask you for the message body. Type a mes­
sage; you can edit by backspacing with the Mac Backspace 
key and retyping. Again, hold down the Command key and 
press D twice when you have finished the message. 

2 1 
lkuCP 

<Message bod'.l> This is o test mess:aoe to demonstrate the Auglllcnt Mol I S..,Sto! 

Figure 6.39 Typing a message in Augment mail 

If you have a longer message that you want to com­
pose on your Mac without paying hourly charges to Aug­
ment, or to the mail system on The Source, you can transfer 
a file to either system with MacTerminal. The transfer is 
similar to the way you transferred the files between the Mac 
and the lie; send what you have transferred as the message 
to be sent. 

Augment will ask you if you want the message sent now. 
Type "Y" for Yes. It will say "Sent." 
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STEP7 You can't leave Augment directly from the mail system 
(except by hanging up the phone, which cause the same 
problem that it does with The Source and Trade* Plus: they 
will charge you for the time until the system discovers 
you're gone). Type "B" (for base, as in home base), hold 
down the Command key and press D. Then type '' lj'' (for 
Logout Job), and press the Command key and press D. The 
system will display some information about how long you 
used it and then the Tymnet message ''please log in'' will 
appear in case you want to use a different service on 
Tymnet. Now you can hang up. 
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Processing 

The bulk of this chapter is devoted to Microsoft Word. 
It also stresses moving things from one system to another, 
and it shows the use of an outline-handling program, a 
graphics program, and a spreadsheet program as additions 
to writing. 

Microsoft Word is a well-known word processing sys­
tem that runs on several personal computers. Microsoft has 
adapted it to the Macintosh, making use of the ability to 
vary fonts and selection with the mouse. It is an easy-to­
learn, powerful word processing system. It differs from 
standard Mac applications because sometimes what 
appears on the screen looks different from what is printed. 

If you write a file longer than will fit in the memory of 
the Mac, Word stores part of it on the diskette; thus you can 
write a document so long as there's space on the diskette. 
About two hundred pages is possible, although the time it 
would take to search through the whole thing means that 
documents based on chapter length is more useful. Word 
provides all the text-editing functions of MacWrite, plus 
some additions, such as the ability to select lines and para­
graphs. With Word you can print in several columns; you 
can have footnotes, that it will automatically number; and 
you can construct running heads or running footers. 

Word has to read and write from the diskette more 
frequently than any other program discussed in this book. 
It will do this if you have a long file, and because it does not 

157 



158 MACINTOSH 

Setting Up 
an Outline with 
ThinkTank 128 

keep its entire program in the Mac's memory. From time to 
time it has to look on the diskette to see how to do some­
thing you have commanded it to do. The result is slow 
response compared to MacWrite. Response time is some­
what better on a Mac with 512K memory. Slowness is the 
price you pay for the large range of features Word has. For 
someone like me who is writing book-length manuscripts, 
it is well worth it; for someone doing short letters, Mac­
Write is simpler to learn and probably more practical. 

This chapter first discusses creating an outline in an 
outline-handling system, moving it to Word, and then set­
ting up an academic paper with headings, running heads, 
and footnotes. Then it explains creating a 3-column bro­
chure, with illustrations from MacPaint, Multiplan, and 
Microsoft Chart. 

Although the bulk of this chapter is devoted to Microsoft 
Word, I'd like to begin by showing you ThinkTank 128, the 
ingenious outline-handling program from Living Video 
Text. ThinkTank allows you to write down ideas in a fast, 
freehand style and then rearrange them into an appropriate 
outline. You can display or print parts of the outline, or 
only the top-level items, leaving out the details. For larger 
versions of the Mac (512K memory or larger), a ThinkTank 
version is available that lets you attach blocks of text to the 
headings, turning it into a pretty fair word processing sys­
tem. 

Although ThinkTank uses the graphics possibilities of 
the Mac very ingeniously, it does not use them just the way 
most applications do. Like MacPaint, it takes over the 
whole screen and does not allow other windows. 

This example assumes you have been given the well­
known college assignment, "Define The Universe." Since 
this is a book about small computers, you do not have to 
provide more than one example. 

If you don't have ThinkTank but are using Microsoft 
Word, just type in the outline in figure 7. 9 exactly as you 
would in Mac Write. 



STEP1 

"' • file Edit EHtre FontSize 

II- """ llo<! 

Figure 7.1 A Blank ThinkTank 
screen 

STEP2 

STEP3 
• File Edit EHt 

+ The Universe 

EJ 

Figure 7.2 Beginning a ThinkTank 
outline 

STEP4 

+ The UnIverse 
- Space 
- Ti111e 
- Hatter 
- Energy 
- Stars 
- Moonlight 
- Ocean 
- Earth 
- Apples 
- Oranges 
- Mice 
- Hen 
- Uo111en 
- Love 
- Birth 
- Death 

1- Laugijted ~ 

Figure 7.3 An unarranged list in 
ThinkTank 
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Making an Outline 

Putting in the Parts 

Put a ThinkTank 128 diskette in the Mac. Select the 
ThinkTank icon. 

Before you can start working, a totally useless sign 
about ThinkTank appears. You will shortly see the 
ThinkTank screen with an outline heading, ''untitled,'' at 
the top (see figure 7 .1). A box surrounds untitled, showing 
that you can edit it. The vertical line cursor is at the right. 

Backspace 8 times to erase the word Untitled. Type: "The 
Universe". 

Press Return. An empty box will appear; the box is 
indented from the rest of the outline. (Pressing Return after 
naming an outline head causes the indentation). Note the 
( +) sign: it shows that there are subitems; the minus (-) 
shows there are no subitems under the heading. 

Type in some of the things that make up the universe 
as you think of them, one idea after another. 

Type the list in figure 7. 3, pressing Return after each item. 
If you make a mistake, backspace and retype as in step 2 
above; you can move up or down the list by clicking in the 
top or bottom margin. You can erase the contents of the 
box by pulling down the Edit menu and selecting Cut. 
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STEPS 

Figure 7.4 Selecting the Sort 
command 

+ The Un I vers 
1- Rpplei!l 
- Birth 
- Death 
- Earth 
- Energy 
- Laughter 
- Love 
- Malter 
- Men 
- Mice 
- Moon I ighl 
- Ocean 
- Oranges 
- Space 
- Stars 
- Tiae 
- Uo111en 

Figure 7.5 The Universe sorted 
alphabetically 

STEPS 

- nice 
ol- Moonlight! 

- Ocean 

Figure 7.6 Selecting a outline 
item to move 

Energy 
Lcfi?ghler 
Love 

Figure 7.7 Selecting a new 
location for an outline 
item 

Figure 7.8 Moonlight under Energy 

ThinkTank will sort lists alphabetically. Pull down the 
Extra menu and select Sort. 

When ThinkTank sorts, the screen does not go blank. 
Instead, you can see the items dance into place. It is an 
attractive quality of ThinkTank programming that you see 
things happening instead of having them occur myste­
riously inside the machine. Figure 7. 5 shows the results of 
an alphabetical sort. 

Organizing the Universe The organization in figure 7. 5 
will not satisfy the needs of a college paper. You might 
think, for example, that moonlight is a kind of energy, so 
the two should be grouped together. 

Move the cursor to Moonlight and click. The box that 
shows you can change it will appear. Put the point of the 
arrow inside the box and hold the mouse down for a 
moment. The box will turn gray and a pointer will appear 
to the left of the box (figure 7.6). Still holding down the 
mouse button, roll the mouse. You will discover the bullet­
like pointer moves. Move it below and indented to the right 
from Energy (figure 7. 7). Release the mouse button. Moon­
light will jump to its new location (figure 7 .8). 

Looking over the list, I thought some categories had to 
be added. You can add items to the outline at any time by 
selecting an item, pressing Return, and then typing the new 
item. 
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STEPS 

+ The Un I ver~e 
+ Events 

- Birth 

DillE~ 
- Laughter 

+ Feelings 
- Love 

+ Energy 
- Moonlight 

+ Matter 
+ Stars 

+ Planets 
+ Earth 

- Oranges 
- Ocean 
- Men 
- Mice 
- Uoaen 
- Apples 

- Space 
- Ti11e 

Figure 7.9 Organizing some parts 
of the universe 

STEP9 

I• naijterl 
- Space 
- Ti111e 

Figure 7.10 Hiding the subitems 
under matter 

STEP10 

I• naijterl 
• stare 
Space 

- Tillie 
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Return to the top of the outline by clicking in the top 
margin. Select The Universe, press Return, and then type 
"Events". Press Return again and type "Feelings". Press 
Return and type ''Planets''. 

Rearrange the items into the outline shown in figure 7.9. 
The list is now longer than the screen, but remember you 
can scroll the list up or down by putting the cursor in the 
top or bottom gray margin. You may not agree with this 
organization, but play along with it for the sake of the 
example. 

ThinkTank lets you hide or display subitems easily. Click 
twice on Matter. All the subitems of matter become hidden. 

Click twice on Matter and Stars will appear; click twice on 
Stars and Planets will appear; click twice on Planets and 
Earth will appear; click twice on Earth and the other items 
will appear. · 

+ Matter 
E:]!EI 
• + PleJtels 

+ Matter 
+ Stars 

I+ P I dJ\etsl 
+ Ea~h 

+ Matter 
+ Stars 

+ Planets 

~ - Oranges 
- Ocean 

Figure 7.11 Unfolding 
subitems: Stars 

Figure 7.12 Unfolding 
subitems: Planets 

Figure 7.13 Unfolding 
subitems: Earth 

Figure 7.14 Unfolding 
subitems: things 
on Earth 
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STEP11 

STEP1 

STEP2 

STEP3 

To close the file, pull down the File menu and select Quit. 
The usual Macintosh file-saving dialog box will appear. 
Type "The Universe" and check OK. 

Moving an Outline from ThinkTank to Microsoft 
Word 

Microsoft makes it impossible to copy a complete disk­
ette. Like most Microsoft products, you can apparently 
copy the diskette, but when you start the actual applica­
tion, the system requires the insertion of the original disk­
ette you bought from Microsoft. The advantage to 
Microsoft is, of course, higher profit. There is an advantage 
to you in their system over systems that simply don't let 
you copy the diskette: if you use a copy for your work the 
copy may get damaged or wear out, but the master diskette 
remains less worn or endangered. 

In the previous examples with Microsoft Multiplan 
and Chart, I ducked this issue to make procedures more 
simple. Why face this extra complication at this point? 
First, the Microsoft Word Master diskette is rather crowded 
and it is nearly impossible to do useful work with it on a 
Macintosh with only one drive. Several of the files are for 
demonstrations or other special purposes and can be left 
off the copy to make more space. The second reason is that 
working from a copy is just prudent. 

Make a copy of Microsoft Word and put your copy in your 
Mac. Pull the File menu and select Eject. 

When the Microsoft Word copy is out, put in the 
ThinkTank diskette with the file containing ''The Uni­
verse'' in it. If the ThinkTank catalog does not appear, click 
on the icon to evoke it. Click twice on the icon of Universe 
file. 

When the file comes up, "The Universe" will be 
boxed, which is ThinkTank's way of showing it is selected. 

Pull down the Edit menu and select Copy. A copy of the 
outline is now on the Clipboard. When you select an item 
for copying in ThinkTank, all the subitems go with it (in 
this case the whole outline). 
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Pull down the Edit menu and select Show Clipboard. The 
o utline will appear unfolded on the Clipboard. 

' 4i rue Edit r~<1nt ron1\inJ 

I• The Un i veroe I 
+ Event:~ 

+ The Universe 
+ Events 

- B lrth 
- Deeth 
- Laught er 

• Fee II ngo 
- Love 

+ Energy 
- noon I i ght 

+ net t er 
• Star~ 

• Planets 
+ Earth 

CllpboBrd iii 

- Orcngeo 
- Dcecn 

Figure 7.15 Transporting an outline out of ThinkTank via the Clipboard 

You have to close the Clipboard before you can quit. Pull 
down the Edit menu and select Hide Clipboard (this 
appears on the menu when the Clipboard is open). 

Pull down the File menu and select Quit. You are now 
done w ith ThinkTank. 

Pull down the File menu and select Eject . 

Take out the ThinkTank diskette and insert the copy of the 
Word diskette. When the Word diskette catalog appears , 
click twice on the Word ico n . 

The screen will go gray and a dialog box will appear 
with an image of two diskettes changing places and the 
request ; Please insert the disk : Tank. (Tank is the name of 
the ThinkTank diskette as it comes from the company). The 
Macintosh system has some housekeeping to do on the 
Tank diskette before it can continue. 

Insert the Tank diskette . After some whirring, the Macin­
tosh will eject the Tank diskette and with the same dialog 
box ask for the copy of the Microsoft Word diskette. 
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STEP10 

STEP11 

STEP12 

STEP13 

STEP14 

Insert the Word copy. After some more whirring, the Mac­
intosh will eject the copy of the Word diskette and the same 
dialog box will reappear with the message: Please insert the 
Word Master disk. Word will not give you access to an 
application until it has checked that you own a master 
diskette. 

Insert the Word Master diskette. After some further whir­
ring the friendly diskette exchange dialog box will appear 
and ask you to insert the Word copy. 

Insert a copy of the Word diskette. A blank Word screen 
will appear. Through all this your outline has remained safe 
on the Clipboard because the clipboard is in the machine's 
memory. 

Pull down the Edit menu and select Paste. The outline will 
appear in New York, the preset Word font (figure 7.16). 
This would be a good time to save the file. 

' 4 rue Edit Search Character Paragraph Document ' 
Untitled 

• The Universe ~ • Events 
• Birth ~ - Death 
- Laughter 

• Feelings 
~ - Love 

• Energy 
- Moonlight 

• Matter 
• Stars 

• Planets I! 
+ Earth 1:· 

- Oranges 
• Ocean 
-Men h: 
- Mice ~ - Women 

I Page 1 IOr -F ,. . .,. 
'·~@?' 'lC 

Figure 7.16 An outline moved from ThinkTank to Microsoft Word 

Pull down the File menu and select Save. The Word's Save 
dialog box will appear (figure 7 .17). It differs from similar 
Mac dialog boxes only in that you can choose to make an 
extra identical copy to back up your copy. 
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~MH"§MM 
f + Events 

Figure 7.18 Selecting a line in 
Word 
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+ The Universe 

Saue Cur~f!nt Document as: 

II 
0 TeHt Only 0 Malee Backup 

- Moonlight 
+ Matter 

Figure 7.17 The Word's Save dialog box 

word.slaue 

,.fi ==~:==,~==,,.~~a 1 ( EJect 

( Cancel ) I 

Type "Universe". The Save box will blacken to show you 
can use it. Check Save. 

The process is somewhat simpler with two disk 
drives. The Word Master diskette is put in the internal drive 
and the ThinkTank diskette in the second drive. This saves 
you the trouble of pulling the ThinkTank diskette in and 
out as in steps 7 through 11 above. You would still have to 
put in the Word Master diskette, though. 

Setting Up Headings in Word 

The paper we are creating will be clearer if it takes 
advantage of the changes in font size and style available for 
headings. 

Move the cursor next to the left margin of The Universe. As 
the cursor nears the margin, it changes from the 1-beam, 
which indicates that you can type text, to an arrow, which 
indicates that you can make selections. Click the mouse 
button. The whole line will turn black (figure 7 .18). In 
Word you select a line by moving the cursor to the margin 
beside it and clicking the mouse. 

The title, The Universe, should be centered. 
Recall that MacWrite and Word have a built-in defini­

tion of a word (a space or punctuation before and after it), 
so that you can click twice anywhere on a word and have 
just that word selected. Word also has built-in definition of 
a paragraph. A paragraph is anything with a line space 
(Return has to be pressed) in front of it and a line space after 
it. Thus, you can divide a paragraph by pressing Return in 
the middle of it. By this definition each of the headings that 
came from ThinkTank is a separate paragraph, as headings 
usually are. You can reformat the heading by using the 
Paragraph menu. 
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STEP2 

STEP3 

STEP4 

STEPS 

in the Character 
Formats dialog box 

STEPS 

Uniuerse 

+ tfhe Universe 
Figure 7.21 Setting the insertion 

point 

STEP7 

Pull down the Paragraph menu and select Centered. 

Pull down the Character menu and select Formats. 
The Character Formats dialog box will appear. 

Churocter Formats n OK J 
Style 
181 Bold [ Cancel 1 
D Italic 
D Underline Position-
0Smali Caps @Normal 
D Outline 0 Superscript 
0Shodow 0 Subscript 

Font Name: 
Chicogo 

~H~~:~::,I Geneua 
Monaco 

Figure 7.19 The Character Formats dialog box 

Check Bold. 
Word lets you select fonts and sizes with a method 

resembling the way you select files following the usual Mac 
Open command (see chapter 1). The dialog box that lists 
fonts contains scroll bars like the box that appears when 
you open files. 

Bring the 20-point font size into view by clicking on the 
arrow by Font Size and then select it. Check OK. 

The plus (+)and the spaces between it and "The" are 
still attached. On a computer screen spaces count; they 
occupy a position even though you cannot see them. You 
can insert and delete them just like characters . To show that 
the blinking insertion point and backspacing work the same 
way as in MacWrite , we will remove the plus and spaces 
before "The"; we will remove the rest more efficiently 
with search and replace in a moment. 

Roll the cursor next to the T in " The," Click the mouse. 
The blinking insertion point will appear. Press Backspace 
three times. 

As in steps 1 through 4, select each of the second-level 
headings (Events, Feelings, Energy, Matter, Space, and 
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- Tnu~ 

Figure 7.22 Selecting several lines 

STEP9 

STEP10 

+ Stars 
~~~ 

• lEarth 

Figure 7.23 Spaces may be 
underlined 

STEP11 

STEP12 

Figure 7.24 Selecting Change on 
the Search menu 
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Time), pull down the Character menu and select Formats, 
check bold, and select 14-point type. 

To make the third-level headings bold but not large , move 
the cursor to the margin next to "Birth." Slide it down the 
margin two more lines (see figure 7.22). Pull down the 
Character menu and select Bold. 

Select the other third-level headings (Love , Moonlight, and 
Stars) and make them bold. 

Select the only fourth-level heading, Planets, pull down the 
Character menu and select Underline. Note that the extra 
spaces on the line are underlined as well (see figure 7 . 23 ). 
Don't worry, we will get rid of them in a moment. 

Select Earth and its subitems, pull down the Character 
menu and select Italic. 

Now to get rid of the extra spaces, pluses, and dashes 
inherited from ThinkTank. Since we have no regular text 
yet, there is no reason to have any spaces in the file , so we 
can remove all spaces. 

First click before the T in The Universe to set the spot 
where the search will begin, and then pull down the 
Search menu and select Change. 

The Change dialog box will appear (see figure 7 .25). It 
has a close box and a move bar, so you can move it around 
like a window. The cursor will be preset to appear in Find 
What. 

Find Whot: 1-=~----=---~--! 
thonge To: L--------------1 

Whole Word 
~,._~(Change, then Find ) (Change) r--=c---""::':'7---, 

Figure 7.25 The Change dialog box 
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STEP13 

STEP14 

STEP15 

\ 

Press the space bar; this means you will be searching for 
spaces. Move the cursor into the box beside Change To:. Do 
not type anything; this means you will erase spaces. Click 
on the Change All button. Then click on the hide box in the 
Change dialog box. The headings will appear without 
spaces. 

Events 
-Birth 
-Death 
-Laughter 
Feelings 
-Love 
Energy 
-Moonlight 
Matter 
+Stars 
~ 
~E.ut.h 

-Or.'UJg~s 
-l.?c~ • .,n 
-M~n 
-Mk~ 

The Universe 
I 

Figure 7.26 The Universe without spaces 

Note that the space between The and Universe was 
inadvertent! y removed. 

Move the cursor between e and U, click to set the blinking 
insertion point, and press the space bar. 

Pull down the Search menu. Select Change, and replace 
the pluses and dashes with nothing, just as you erased the 
spaces. Now the screen will look like figure 7.27. 

Events 
Birth 
Death 
Laughter 
Feelings 
Love 
Energy 
Moonlight 
Matter 
Stars 
~ 
Earth 
l.?rangt9s 
Oc~an 
M~n 
Mil'~~ 

Figure 7.27 The outline ready for text 

The Universe 
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Figure 7.28 Setting the insertion 
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paragraph 
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I 
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Figure 7.29 Entering text 
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Putting In Text 

No actual text about the Universe will appear in this 
exercise. We will merely put in enough dummy text that we 
can use the running head and footnote features. But in 
doing so we will see the basics of handling text in Word. 

Set the blinking insertion point after the final h in Birth. 
Press Return twice. Putting a return in the text creates an 
empty paragraph (see above). 

Set the insertion point at the beginning of the new para­
graph. 

Type "Text" (Set a space after the word by pressing the 
space bar after you type the second t). 

Select the line by moving the cursor to the left margin. Pull 
down the Edit menu and select Copy. 

Move the blinking insertion point one space after Text as in 
figure 7.29. Pull down the Edit menu and select Paste. A 
second copy of the word will appear. 

Select the second capital T (figure 7.30) by holding down 
the mouse button while you drag the cursor across it. Type 
a lowercase t. 

Figure 7.30 Selecting a character 

Birth 
Text )ext 
Death 
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STEP7 

STEPS 

STEP9 

STEP10 

STEP11 

STEP12 

Click twice on text to select it. Pull down the Edit menu 
and select Copy. Pull down the Edit menu and select Paste. 

Continue this process until text extends partially onto a 
second line. (Hint: you can speed up the process by select­
ing several words at once, copying the group, and pasting 
it.) Type a period. Now you have a two-line sentence. 

Birth 
Text text text text text text text text text text text text text text text 
text. I 
Death 

Figure 7.31 A sentence 

Word has a built-in definition of a sentence. Hold down the 
Command key and click anywhere in the sentence. You 
have selected the sentence (see figure 7 .32). Pull down the 
Edit menu and select Copy. 

Birth •r·--······· Death 

Figure 7.32 Selecting a sentence 

Set the insertion point at the end of the sentence and pull 
down the Edit menu and select Paste. Now the paragraph 
has two sentences. 

To select a paragraph, move the cursor next to the left 
margin, as in selecting a line, and click twice. 

Pull down the Paragraph menu and select Formats. 
A ruler appears as in MacWrite. This ruler, however, 

does not rule everything below it, but only the paragraph 
currently selected. Each paragraph has its own ruler, which 
you can hide (most of the time) or show. Note that at the left 
end of the ruler is a tiny arrow with a white spot in it and 
the right margin an arrow with no spot. 

l-f~ ___ . ___ n ______ ~';~h-e~U~n-'3~iv __ e_r_s_e_,
4 
______ ,s ____ ~11 

Figure 7.33 The Microsoft Word ruler 
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Figure 7.34 The left end of the 
paragraph ruler 
enlarged 
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Figure 7.35 Setting paragraph 
indentation 
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The left arrow ru les the left margin of the paragraph, 
the right arrow rules the right margin , and the white dot, 
which will turn black when you move it onto a white 
background, rules the indenting of the first line. Figure 
7.34 shows them in enlarged form. 

Move the point of the cursor to the white dot , (it 's not as 
hard as it looks in the illustrations), press down the mouse 
button, and slide the cursor to the half-inch mark (see figure 
7 .35). As you move the cursor, the number in the First Line 
box in the Paragraph Formats dialog box also changes. 

Move the right margin arrow into the 4 1/2-inch mark. 

You can write in the boxes where numbers appear in the 
Paragraph dialog box. Replace 0 lines following each para­
graph with 1, and change the 0 in Left indent to 0.5 , and 
check OK. 

Uniuerse 
3 

The Universe 

Figure 7.36 Setting up paragraph indenting and line spacing 

The paragraph will appear as in figure 7. 3 7. 

Birth 
Text text text text text text text text text text text 

text text text text text text Text text text text text text 
text text text text text text text text text text text I 
Death 

Figure 7.37 The paragraph as formatted 
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Time! 
Text text tex 
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Figure 7.38 The page number box 
showing a second 
page count has risen 

to two 
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Figure 7.39 Selecting Footnote on 
the Document menu 

Select the paragraph. Pull down the Edit menu and select 
Copy. Set the insertion point after the heading Death and 
press Return to create space for a copied paragraph. Pull 
down the Edit menu and select Paste. 

Repeat the process of copying the paragraph of text after 
the headings Laughter, Love, Moonlight, Stars, Planets, 
Earth, Space, and Time. This will lengthen the paper to two 
pages. Of course, in a real paper you would type out para­
graphs discussing these topics. Note that the page count in 
the lower left-hand corner of the window turns to two. 

It is fairly easy to make a mistake and mix paragraphs 
so that, for example, the indenting of one of the headings 
takes over the indenting of the text. You can easily separate 
them by setting the insertion point at the proper boundary 
and pressing Return. Once they are separate, set the inser­
tion point in the paragraph with the wrong margins, pull 
down the Paragraph menu and select Format. The dialog 
box will appear and you can set the margins and line space­
ing correctly. 

This would be a good time to save the file again. 

Inserting Footnotes 

This section will show you how to attach the footnote 
"You've always got to keep your sense of humor." to the 
end of the text under Laughter. The footnote will then 
appear at the bottom of the page. If the paragraph were 
moved to another page the footnote would go with it. You 
could also put the footnote at the end of the paper. Word 
will number the footnote automatically, but it is possible to 
number by hand with *, t, etc., or any other character. 

Set the insertion point after the last character in the text 
about Laughter. 

Pull down the Document menu and select Footnote. 
The Footnote dialog box will appear. 
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Figure 7.42 Closing the footnote 
pane 
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Click OK. 

~ Auto-numbered Reference H OK g 
or ( Cancel ) 

Footnote Reference Mark: [I 

Figure 7.40 The Footnote dialog box 

The numeral 1 will appear where the insertion point 
was blinking and the window will divide into an upper and 
lower pane. The footnote number will appear in the lower 
pane that contains the blinking insertion point and you can 
begin typing your footnote there. 

text text text text text text. Text text text text 1:.&0 
Feelings 
Love 

Text text text text text text text t&xt t&xt t&xt t&XI 
text text text text text text. Text t&xt text text text t&x 

•You've always got to keep your sense or humour. 
<> 

Figure 7.41 Typing in a footnote 

To hide the footnote window, move the cursor into the 
pane bar (figure 7 .42), hold down the mouse, and drag the 
top of the pane to the bottom of the screen. The footnote 
will appear when you print the paper even though it might 
not appear on the screen (see figure 7 .48). 

The pane bar will return to the top of the screen. You 
can open the footnote window at any time to edit any 
footnote by holding down the Shift key, retouching the 
pane bar with the point of the arrow cursor, holding down 
the mouse button and dragging the pane bar down the 
screen. Editing footnotes is exactly like editing any other 
kind of text in Word. 

To delete a footnote, remove the reference number in 
the text. If numbering is automatic, Word will renumber 
any remaining notes. 

Running Heads 

Running heads are text that appear on every page of a 
document at the top above the regular body of text. Word 
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enables you to put a running head on every page, or one 
that appears on the odd (normally right-hand) pages and a 
different one on left (normally even-number) pages. You 
can also have running footers at the bottom of the page, but 
not both running heads and footers. This example shows 
one running head on the even (left) page-the name of the 
paper-and another on the odd (right) side-the name of 
the writer and the class assignment. 

You can put the running head anywhere in the text, 
but it will only take effect on the page where it appears and 
those following. It seems most orderly for this short paper 
to put it at the very beginning. But the very beginning is the 
title, in 20-point, bold, centered letters which is a little 
heavy for a running head.,You will need to create a new 
paragraph (by inserting a return) and give that paragraph an 
appropriate format for a running header. 

Set the insertion point at the very beginning of the paper. 
Press Return. Pull down the Character menu and select 
Formats. Alter the Formats dialog box by clicking on Bold 
to deselect it which leaves the text Plain; select Underline, 
and 12-point text. 

Cherac:ter Formats n OK I 
Style----. .. 
0 Bold ( Cenc:el ] 
Oltellc: 
181 Underline Position 
0 Smell Caps ®Normal 
0 Outline 0 Superscript 
0 Shedow 0 Subscript 

Figure 7.43 Setting up the format for a running head 

Pull down the Paragraph menu and select Normal. 

Type "The Universe" and then select the text. 

Pull down the Document menu and choose Running 
Head. The Running Head dialog box will appear. 
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Running Heed U OK D 

.-Occurs on- [ Cencel ) ... 

181 Odd Peges J~Position~ 0 Euen Peges ®Top 
181 First Pege 0 Bottom 

Figure 7.44 The running head dialog box 

Check: Odd Pages, First Page, and OK. Often the first page 
is a title page, where you wouldn't want the running head 
to appear, but since this example paper is only two pages 
long, the odd running head must appear on the first page if 
it is to appear at all. 

The running head symbol, a low, small double bracket 
that looks like a quotation mark from French or Spanish, 
appears in the left margin to show that this paragraph will 
not print where you see it, but rather as a running head (see 
figure 7 .45). 

The Uniyerst 

The Universe 

Figure 7.45 Running heads for odd and even pages with the right page head 
selected 

Set the insertion point at the end of the running head, press 
Return twice and type the name of the writer, his class, and 
date (Paul McCarthy, Cosmology 101, Mr. Occam, 
November 1, 1985). Select the text you have just typed. Pull 
down the Document menu and select Running Head. 
The boxes are preset to show the same header on both odd 
and even pages. Check Odd to reverse the preset; this lets 
the heading appear on Even only. Check OK. The mark of 
the running head will appear beside this text. 

Note the raised small "c" in McCarthy. Those of Irish 
or Scottish descent can obtain this fine touch by selecting 
the character, then pulling down the Character menu and 
selecting Superscript. 
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Page Numbers in Running Heads 

Word will number your pages automatically in the 
upper right-hand corner if you do not have running heads. 
Running heads preempt the space where the page numbers 
normally go. The simplest way to provide page numbers 
when you have rtinning heads is as follows. 

Select the end of your running head. Type "Page". Hold 
down the Command key and press Backspace. Page will be 
replaced with (page). The (page) is a place holder. The real 
page number will appear when you print the page. Figure 
7.46 shows this step halfway through. In the upper running 
head, (page) is in place; the lower running head is waiting 
for the Backspace key to be pressed while the Command 
key is down. 

r 
The Uniyerse (Jmg2). 

~ocarthy.~'U.Q.l. Mr. Occam. Novembtr 1 19_8.5hgd 
The Universe 

Figure 7.46 Making page numbers part of the running head 

When you put page numbers in a running head you are 
making use of a feature that Word calls a glossary. With the 
glossary feature you can put some short string of characters 
in a file and have something else replace it when you print. 
For example, to save typing you could insert@ and have 
some lengthy phrase replace it when you print. Word 
offers two types of glossary, those you define yourself, and 
a set of standard glossary items, one of which is the page 
number. A file of standard glossary items comes with 
Word. If you are using only one disk drive, it is necessary to 
have the glossary file on the diskette you are using in order 
to make page numbers appear in running heads. If you are 
using a second disk drive, the glossary file can be on either 
diskette. 

To make it clear in the printed version that the page num­
bers are page numbers, set the insertion point between the 
text and (page) and type spaces to separate the number 
from the rest of the heading. 
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re Uniyerse (~gtl 

~~~~L.l.QJ.. Mr Occam, November I 19.A5___(R§gt>. 
The Universe 

Figure 7.47 Running heads with spacing to set off page numbers from text 

STEP3 To print, pull down the File menu and select Print. The 
standard Mac printing dialog box will appear. Printed with 
the standard rather than the high-quality print style, the 
paper looks like figure 7. 48. 

The Unjverse 

Events 
Birth 

The Universe 

Te1t te1t tell te1t te1t tell te1t te1t telt tell te1t 
telt telt tell ten tell tell. Te1t telt tell tell tell ten 
telt teJt telt telt ten ten ten tell telt teJt ten~ 

De alb 
Te1t ten telt te1t ten ten telt ten telt teJt tell 

telt tett ten text ten telt. Text text ten ten tell ten 
ten telt text text te1t te1t teJt teJt ten te1t text. 

Lauabter 
Te1t text te1t text ten text tell text te1t text text 

teJt ten teJt tell telt ten. Tett text tell telt teJt teit 
tett ten text telt tell text text text text tett tell. • 

Feelings 
Love 

Text text tell tell tell tell tell tell tell tell te1t 
ten ten telt telt tell ten. Ten ten ten text tett telt 
ten teJt teJt text tell telt telt ten ten text text. 

Energy 
Moonlight 

Text text lett telt text text text text ten ten text text 
telt telt ten text text. Text tell text text telt tell tell te1t 
ten tell ten telt ten ten tell ten text. 

Malter 
StU I 

Ten ten ten tell tell ten ten tell text text telt 
ten text tell tett tell ten. Ten tell tell tell tell tell 
telt text ten telt telt telt telt teJt telt te1t text. 

El!JWL 
Te1t tell tell ten tell tett ten text text tell tell 

ten text tell text text tell. Text tett text tett tell text 
ten tell text ten tell tell tell ten text ten text. _ 

lfou·ve always got to keep your sense of humor. 

fl.ltl..MtCarthy Cosmology I 0 I Mr Occam November 1 198$ 2 
.E6rlb 

Ten text tell tell text tell ten tell text telttext 
text text text text text text. Text text tell text text text 
text ten telt tell tell text ten text tell te1t ten. 

OriD6e.f 
0t:e1o 
Men 
.Vi~ 
W'omtM 
Apples 
Space 

Text ten text text ten text tell telt te1t tell text 
ten ten text text telt text. Tell tell ten text text text 
tell text text text text text telt text text tett tett. 

Time 
Text tell text te1t text text te1t text te1t telt text 

te1t tell text text tell ten. Text text text telt te1t ten 
ten tell telt ten text text telt tell text text tell. 

Figure 7.48 Printed with standard rather than high quality print style 
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Figure 7.49 The catalog on a 
word diskette 

STEP2 

STEP3 

In this section we will create a brief brochure for Thorn & 
Co. The format is an 8112-by-11 inch sheet printed sideways 
in three columns and folded. This section demonstrates 
more than any other the possibilities and the number of 
steps and planning required to use material from several 
programs. It shows copying an illustration from a commer­
cial clipsheet diskette (CiickArt); copying a table from Mul­
tiplan; copying a chart from Chart; and editing in MacPaint. 

If you don't have ClickArt, you can use MacDraw to 
make an example. If you don't have Multiplan, you can 
type in a table in 12-point type in Mac Write. 

Setting up the Format 

Put the Word diskette in the Mac and turn it on. If the 
catalog does not appear, click twice on the diskette icon to 
evoke it. 

Word sometimes generates files for its own purposes 
during a task. They appear in the disk catalog with myste­
rious names like MWOOl and Font Widths. Don't worry 
about them, because there is nothing you can do with them; 
everything that needs to be done the program will do. 

Click twice on the Word icon to create a new Word file. 

After some whirring the machine will eject the diskette and 
show a message to put in the Word Master diskette (figure 
7. 50). Microsoft's copy prevention system requires this 
step. Remove the copy diskette and insert the master. After 
a little more whirring the system will eject the master 

Please Insert the Word 
Master disk I Cancel I 

Figure 7.50 Prompt box that requests insertion of the Word Master diskette 



STEP4 

STEPS 

Advanced Word Processing 179 

diskette and ask by name for the copy. Remove the master 
and insert the copy. An untitled Word file will appear. 

Pull down the File menu and select Page Setup. Check 
Wide Orientation. With three columns we need all the 
space we can get, so change the margins to 1/2 inch on both 
the left and right (see figure 7.51). Check OK. 

As usual in boxes with text within dialog boxes, you 
can edit it in the normal Macintosh way, see 1.3. 

Paper. ® US Letter 0R4 Letter 

OUS Legal 

Orientation: 0 Tall 

0 International Fanfold 

0 Tell Adjusted ®Wide 

Margins: 

Left: ~ Right: ~ 
Top: ~ Bottom:~ 

Gutter: ._I o_· -----' 

Figure 7.51 Page setup dialog box showing correct settings for horizontal, 
three-column printing 

Pull down the Document menu and select Division 
Layout. The Division Layout dialog box will appear. 
Check Column and change the number of columns from 1 
to 3. Check OK. 

.._ ... ,_ .. 
: Diuislon Layout I OK J : 

Brealc ,_Page Number Format-
0 Continuous ®Numeric ( Cancel ) 
®Column 0 Roman (upper) 
OPege 0 Roman (lower) ~Footnotes Appea::-1 
00dd 0 Rlphabetlc (upper) ® Dn Same Page 
OEuen 0 Rlphabetic (lower) 0 At End of Dlulslon 

0 Auto Page Numbering: Running Head Position: 

FromTop: ~ From Top: 

~ From Left: 7.25" From Bottom: . 
Start Page Numbers At:~ Number of Columns: 

~ Column Spacing: 

Figure 7.52 Division layout dialog box set for three-column printing 
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Figure 7.54 Thorn & Co. brochure 
headings 
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Pull down the Character menu and select Formats. For 
the title , set the format to 20-point New York, Bold, · 
Shadow. Check OK. 

.. 

Character Formats n OK I 
Style 
181 Bold ( Cancel J 
Oltalic 
0Under1ine Position-
0Smell Ceps @ Normel 
ODutline 0 Superscript 
~Sh8dow 0 Subscript 

Font Neme: 
II Chicago 

~ ""' I Size: 
Geneue 

li'i itAIMI Monaco w 
Figure 7.53 Character Format for 20-point, bold, shadow 

The blinking insertion point will remain at the beginning of 
the file . Type "Thorn & Co." and press Return twice. The 
letters will appear at the top of the screen (figure 7.54). 

Pull down the Character menu again and select Formats. 
Set the Character Format to 12-point , Chicago, Bold. 

Type the brochure headings (Financial Status, Market 
Share, Anticipated Growth, Marketing, Management, Com­
munity Responsibility, Product Line). Press Return twice 
between each heading. When you finish the screen should 
look like figure 7. 54 . 
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Figure 7.55 Setting the blinking 
insertion point to 
enter text 

STEP2 

STEP3 

STEP4 

Flaaaclal Status 
Text text text text text text text 
text. Text text text text. Text text 
text text text text text text. Text 
text text text text text. Text text 
text text text. Text text text text 
text text. 
Martel Sbare 

Figure 7.57 Dummy text for the 
brochure 

Advanced Word Processing 181 

Dummy Text 

We will use dummy text to fill out this brochure 
instead of actually writing out material under each heading. 

Set the insertion point between Financial Status and Market 
Share. 

Pull down the Character menu and select Normal (to turn 
off bold). 

Pull down the Character menu and select Formats. When 
the Character Formats dialog box appears, select tO-point 
Geneva. 

The steps in the previous section defined a three­
column format drawn horizontally across an eleven-inch 
piece of paper. That means each column is three inches 
wide. When you print the brochure it will appear in three 
columns, but on the screen you only see one column at a 
time. 

lt---------11;;...." -----------.; 

8.5" 
J, 

Figure 7.56 Basic design of the Thorn and Co. 

Type "Text" repeatedly to create a paragraph of dummy 
text. Because it is part of a column three inches wide, it will 
only appear on the left-hand part of the screen. 



182 MACINTOSH 

STEPS 

STEP1 

STEP2 

STEP3 

STEP4 

Copy the paragraphs of dummy text below l\Aarket Share, 
Management, Product Line, and Community Responsibil­
ity. 

Copying a Figure from a Commercial Clipsheet 

T /Maker offers diskettes under the name of ClickArt 
that provide useful, predrawn images that can be used in 
MacPaint. To use them you copy the image onto the Clip­
board and paste it into the text. In order to see the picture, 
you must have a copy of the MacPaint program available, a 
somewhat complicated process if you have only one disk 
drive. 

Thorn & Co. has chosen an image that is tall, slender, 
and noncontroversial. 

Pull down the File menu and select Quit. The file-saving 
dialog box will come up. Type "Thorn Brochure" and 
check OK. 

Pull down the File menu and select Eject. 

Insert a diskette that has the System Folder and Mac Paint on 
it. Then Eject it. 

Insert the ClickArt diskette. When the catalog appears, 
double click on a folder named Stuff. When the folder 
unfolds, double click on a MacPaint file named Americana 
(figure 7. 58). The Mac will eject the ClickArt diskette and 
display a message to insert the diskette with MacPaint on it. 
Do so. 

After several switches between the two diskettes, a 
collection of Americana will appear, including Wash­
ington, Lincoln, and the Liberty Bell. (If you have two 
drives, one can hold the ClickArt diskette and the other the 
diskette with MacPaint on it.) 

littt. ~s 8i9g.,. !IIIIlS Good C)UllS Mon littt. guv li!l!: 

J~ .L I 
Figure 7.58 Selecting Americana from the ClickArt Stuff Folder 
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Each MacPaint file can hold one printed page of pic­
tures , but the screen shows a smaller area. MacPaint has a 
command that shows you the whole page called Show 
Page. 

Pull down the MacPaint Goodies menu and select Show 
Page. 

Figure 7.60 is the full view of the page. Naturally , 
details are lost. The dotted rectangle shows where the 
screen lies. Touching the end of the cursor arrow to the 
edge of the dotted rectangle and pressing the mouse button 
lets you drag the screen to a different location. 

Figure 7.60 The Show Page view of Americana 

Drag the dotted rectangle until it includes the Statue of 
Liberty. Then click OK to return to a close view. 

To the left of the art area in MacPaint are the symbols 
of tools (as in MacDraw). If your statue is not showing 
completely you can move it by selecting the hand tool; the 
cursor turns into a hand. Move the hand into the picture, 
press the mouse button, and you can move the picture ''by 
hand. '' The rectangle at the top lets you copy things. It is 
called the marquee, because in action it produces a jiggling 
rectangular boarder like the lights around a marquee. 

Roll the cursor into the marquee and select it (figure 7.61). 
When you move the cursor into the image area, it turns into 
a cross. 
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Figure 7.61 Selecting the Marquee tool in MacPaint 

Set the cursor above and to the right of the Statue of Liberty 
and drag it diagonally down and to the right to generate a 
rectangle around it. 

iD Rmerlc11n11 -

Figure 7.62 The Statue of Liberty selected in MacPaint 

Pull down the Edit menu and select Copy. 
The Statue of Liberty is now on the Clipboard. 

Pull down the File menu and select Quit. Pull down the 
File menu and select Eject. 

When the Mac has ejected the diskette with MacPaint on it, 
insert the Word diskette with the Thorn Brochure file. 
When the catalog appears , open up the Thorn Brochure 
file . 

Set the insertion point in the blank space between Financial 
Status and the top of the page. Pull down the Edit menu and 
select Paste. The Statue of Liberty will appear. You will 
just be able to see the top of Financial Status at the bottom 
of the screen. 

Quit and save the changes. 
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Figure 7.63 Copying a selected 
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Copying a Chart From Chart 

Eject the Word diskette and insert the Chart diskette that 
contains the Thorn & Co. chart. Select the Thorn chart. 

The chart has to fit in a three inch width, so we want to 
make it as narrow as possible. This can be done partly with 
Chart and partly through editing in Mac Paint. 

Pull down the Chart menu and select Delete Legend to let 
the chart fill up the space. 

Pull down the Chart menu and select Select Plot Area. 
Black squares will appear to show that the plot is selected. 

Pull down the Edit menu and select Copy Chart. 
The Copy Chart to Clipboard dialog box will appear. 

The preset choice is As Shown on Screen. 

Copy Chart to Clipboard 

Figure 7.64 The Copy Chart to Clipboard dialog box 

Check OK to accept the preset choice. The Chart is now on 
the Clipboard. 

Pull down the File menu and select Quit. The dialog box 
will appear that asks if you want to save changes. Check No, 
leaving the chart the way it was before you hid the legends. 
Pull down the File menu again and select Eject. 

Insert a diskette with MacPaint on it. Select the MacPaint 
icon to create an empty MacPaint file . 

Pull down the Edit menu and select Paste. The chart will 
appear with the marquee flashing around it. Move the cur-
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Figure 7.65 Selecting the 
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sor anywhere outside the marquee area and click the mouse 
to stop the flashing. 

The dollar values on each side of the chart take up 
space, and could be replaced with text. The tools in Mac­
Paint include an eraser; it is the fifth sympol down in the 
column of tools next to the screen. 

Click in the eraser tool to select it. 

When you have chosen the eraser, the cursor will turn 
into a white square when it is in the image area. Pressing the 
mouse button lets you use the white square to erase any­
thing it touches . 

Erase the numbers on the sides of the chart. 

\0 .00 

0 .00 

Doll~rs 

198~ 1986 

./- Yu rs 

Figure 7.66 Erasing in MacPaint 

When you have erased the dollars at each side, select the 
chart with the marquee tool as above. Pull down the Edit 
menu and select Copy. The edited chart is now on the 
Clipboard. 

Pull down the File menu and select Quit. 

The dialog box that asks if you want to keep changes will 
appear. Check Yes, and your edited chart will be stored on 
the diskette in case the power fails during subsequent steps. 
A dialog box will appear that asks you to name the file; type 
"Edited Chart" and check Save. 

Pull down the File menu and select Eject . Insert the Word 
diskette with the Thorn Brochure on it. Click on the Thorn 
Brochure icon. 
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Set the insertion point on the blank line between Antici­
pated Growth and Marketing. Pull down the Edit menu and 
select Paste. The Chart w ill appear. 

Copying a Table from Multiplan 

Eject the Word diskette and put in the Multiplan diskette 
that carries the Thorn & Co. table . 

As in the case of the chart , we need to do some editing 
to make the table fit into the three-inch column. All the 
editing is possible inside Multiplan . The first step is to 
remove the odd cents from all the columns. 

Select the profit figures . 

... ........ ... . ... . -··· ·········· ........... . . . 
.......... : ... ........ ·-· ·· . -···· ······· ····=········· 

···:·· · ··············:········· 

Figure 7.68 Selecting the profit figures of Thorn & Co. for editing 

Pull down the Format menu and select No Decimal. 

Select the cell that contains Cost of Goods and type ''C of 
G"; press Return . 
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19M 1965 1966 I 
967 
sates 100 110 12 1 I 
33 
c of G 50 53 55 5 
6 
Profit 50 56 66 7 
5 

Figure 7.70 The Thorn & Co. 
profit table before 
reduction 
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Select the part of the table to be copied. 

Th & c P f it Forecast 
• l • - • ~ ~ • ' 

~ ' . - . 

,. :. : :: +. :, 

Figure 7.69 Part of the profit forecast selected to be copied to the Clipboard 

Pull down the Edit menu and select Copy. The edited table 
is now on the Clipboard. 

Pull down the File menu and select Quit. The dialog box 
will appear to ask if you want to save changes. Check No to 
leave the table the way you found it. 

Eject the Multiplan diskette, put in the Word diskette, and 
open the Thorn Brochure file . 

Fix the blinking insertion point below the chart, pull down 
the Edit menu and select Paste. 

The table will appear distorted because not all the text 
will fit on the line. 

Select the whole table. Pull down the Character menu and 
select Formats. On Formats , select 9-point type. 

The table will appear in the smaller type. The bro­
chure is now ready to print; the final version should look 
like figure 7 . 71. 
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T E R E G H T 

Databases do not come from as clear a model in the 
noncomputer world as word processors and spreadsheets. 
Word processors, at least in the beginning, had the mode of 
a magic typewriter, and spreadsheets had the model of a 
magic accountant's ledger. If data bases have a mode it is 
based on a file drawer filled with identical forms. 

Computers are good at storing and fetching such infor­
mation, and data bases have been with us on large, imper­
sonal computers for many years. When we make an 
airplane reservation, the person behind the counter sees on 
her or his screen the image of a form retrieved from a data 
base, and when the ticket is printed, it is part of that data 
base in a different format. When we buy a ticket from 
Ticketron, the image of the theater is a data base and the 
printed ticket is an image from that data base. When a 
police officer stops one of us in traffic and radios in our 
license number, someone at headquarters searches a data 
base. 

The computer searches quickly and efficiently 
because it is able to see information arranged in several 
orders simultaneously, allowing it to search as fast for one 
thing as for another. 

PFS:file, the second program described below, allows 
you to create an old-fashioned computer data base for 
yourself. It allows you to design a form, fill in information 
on as many copies as you like, and then print or display the 
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forms. You can also print lists of single items from the 
forms, say all the people named Smith in a personnel file. 

Filevision, the first program discussed, takes a new 
approach. The information is organized on a diagram. You 
essentially pin the forms to places on the diagram. Will a 
graphic approach help you? It depends partly on your data: 
do they suit a diagram? Are they, for example, based on the 
locations of things (e.g., a map is a powerful organizing 
image). It also depends on how your mind works; if you 
tend to think in pictures, Filevision might suit you. 

Factfinder, the third data base program discussed, fol­
lows a somewhat different model. The model for Fact­
finder is notes, such as those a student takes on 3-by-5 cards 
before writing a big paper. This model has also been around 
on big computers. There are several services (Dialog is one 
and Orbit is another) that essentially offer the index card­
file of a library and allow you to search through the file 
with specific words or phrases, called keywords. One vir­
tue of Factfinder is that you can write unconstrained by a 
rigid format like a form, which most data bases require. 

It will be useful in understanding how these three 
programs work-though not necessary to using them-if 
you understand three terms from computer jargon: field, 
record, and file. You hear these terms quite a bit in conver­
sations about programs and see them in computer text­
books, but there are not generally accepted definitions. So 
the somewhat rough and ready definitions below are as 
good as any. 

Afield is the computer equivalent of one box on a form, 
say last name, zip code, or serial number. 

A record is the computer equivalent of the whole form. 

A file is the computer equivalent of the drawerful of files; 
it is all the forms you can search in one pass. 

The designers of Filevision had the novel idea of using 
diagrams as a way of organizing information. In setting up a 
Filevision data base, you first draw, or borrow, a diagram 
and then attach nonvisual information, such as forms, to 
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parts of the diagram. This idea, which suits the Macintosh 
so well, came to the Filevision programmers before they 
knew about the Macintosh. Imagine their delight when just 
the machine to support it appeared on the market. 

Starting From Someone Else's Pictures 

As with most data base systems, in Filevision you 
spend a lot of time setting things up; you reap the rewards 
only over the following weeks, months, and years. In par­
ticular, in Filevision you have to make a diagram before you 
do anything else. Drawing in Filevision is 80% the same as 
drawing in Mac Draw. To save going over the ground in 
chapter 3, this exercise will adapt a map of the United 
States, which comes as an example on the Filevision disk­
ette. At the end of the exercise you will add a state to the 
United States, which will illustrate the basics of drawing in 
Filevision. 

Filevision uses the same sort of copy prevention 
scheme that Microsofts Word and Multiplan use. You can 
copy the diskette you buy from them, but when you use it, 
you must put the master diskette in briefly at the beginning 
of the session. 

Filevision Basics 

Copy the Filevision master diskette onto a blank diskette, 
including the System Folder, the applications icon, and the 
file called Map. (Space is pretty tight on a Filevision disk­
ette. If you are not working with two drives, you will 
probably want to remove some of the more stylized fonts 
such as Venice or London from the System Folder on your 
copy diskette.) 

Insert the copied diskette into the Mac and turn it on. When 
the catalog appears, click on the Filevision document Map. 
As Map is appearing, the Mac will prompt you to insert the 
Filevision master diskette for a moment. 

A map of the US, a set of menus, and a stack of tools, in 
the left margin, will appear. The tools are much like those 
in MacDraw or MacPaint. 

The Map file holds information about each state and a 
hypothetical chain of offices. The offices won't interest us, 
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Figure 8.2 Selecting State on the 
Types menu 
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Figure 8.1 The Filevision Map 

but we will use the states. To get a sense of how the 
programs work, let's look at the information attached to 
one state. 

Pull down the Types menu and select State. 
Note that State appears on the menu of this file, but not 

on Filevision menus in general. The person who drew the 
map defined State as a type and so it got a place on the 
menu. You will learn how to do that below. 
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Roll the cursor into Texas and click twice. The information 
screen for Texas w ill appear. 

lnformet1on for this St ele: 

Figure 8.3 The information screen for Texas 

Pull down the Tinker menu and select Highlight Some. 
The conditional highlighting screen w ill appear (fig­

ure 8.4). ln this graphic data base system the screen where 
you decide what stands· o ut on the diagram is also the 
screen where you decide what information you want . 

Figure 8.4 The conditional highlighting screen 

Check the box beside COMPUTER STORES. The heading 
on the right will change to COMPUTER STORES. 
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Check the box with :5 (equal to or less than). Type " 100". 
When you type on the left, the text also appears on the 

right. 

Check the box under the first And. You will see the lines 
that show which parr of the form you are changing shift to 
the box under the second And. This shift is an excellent use 
of the visual, interactive quality of the Mac to show you 
what you can do. 

Check COMPUTER STORES and ~ (greater than or equal 
to) and type " 6". The screen will now look like figure 8. 5. 

Figure 8.5 Setting up to show states with 100 or less and 6 or more computer 
stores 

Check Done. The map will appear with the proper states 
highlighted. 

Figure 8.6 States with 100 or less and 6 or more computer stores 
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According to Filevision, in 1984 only one state had less 
than 6 computer stores. Try your hand at finding which. 

Deleting Unwanted Types To find out about an office 
click on one of the diamonds, which are symbols of offices. 
In any case, these germane to our task. 

STEP 1 Pull down the Types Menu and select Office. 

STEP 2 Pull down the Tinker menu which now rules the type 

Figure 8. 7 Selecting Highlight all 
from the Tinker menu 

STEP3 

STEP4 

Office because you just selected it. Select Highlight all. 
The states will fade and the offices will be highlighted. 

'!..''' ·--~ ~ y 

Figure 8.8 Offices highlighted 

Pull down the Edit menu and select Clear. 
A dialog box will appear that points out that if you 

clear all highlighted objects you cannot undo the action. 

You ere about to clear all highlighted objects. 

Yo\wlll not be able to undo this ec:tlon. 

HF=!!!!!OK~'J 

.;.v ,0 o ot< 0 0 o,. 0 -· 0 0 o ·r 0 -0 0.,.. . ., ,... ;.-

Figure 8.9 This dialog box warns you that clearing highlighted objects is 
irrevocable 

Check OK. 
The map will appear without the symbols for Offices. 

Although there are no more offices, the type office still 
exists and you can create a new office at any time. 
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Figure 8.10 Selecting the asterisk 

from the Symbols 

menu 

STEP2 

Figure 8.11 The cursor turns into 
the symbol you have 
selected 

STEP3 

Figure 8.12 Setting the symbol on 

the map 
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Pull down the Types menu and select Delete. Since the 
Office type is still the selected type, the system will delete 
it. 

A dialog box will ask if you really want to delete the 
type Office and all objects of that type. Check OK. 

Adding Symbols 

Headquarters. The headquarters of Thorn & Co. is 
Atlanta. 

Pull down the Symbols menu and select the asterisk. 

The asterisk will appear on the left in the stack of 
tools. It is now a tool you can use to add to your data base. 

Filevision provides a small graphics editor, oddly 
located on the File menu, where you can design your own 
symbols so long as they are small enough to fit in the boxes 
in the Symbol menu. 

Roll the cursor into the new asterisk tool you have selected 
and click the button. The tool is selected. When you move 
the cursor away from it, you will see that the cursor 
becomes an asterisk. 

Roll the mouse so the tool is in Georgia. Click the mouse 
button. The asterisk will stick where you clicked with a box 
around it to show highlighting and the cursor will turn back 
into an arrow. 
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Adding Suppliers As a Type 

Pull down the Types menu and select Add Another. The 
Type Definition dialog box appears. 

Definiti on for this type: 

Figure 8.13 The Type Definition dialog box 

Now we will define a new type of data: suppliers. We 
will set up some fields that define what sort of information 
Thorn & Co. needs to keep about suppliers. We will create 
these fields by defining boxes for this information and 
labeling the boxes with the type of information to be filled 
in. 

Move the cursor into the box next to Type-name; the cursor 
will turn into an 1-beam to show you can insert text. Type 
"Suppliers" . 

Name and Link appear in all Filevision data items. 
Name will be the name of each supplier. Link allows you to 
link information from other Filevision files. 

Move the cursor to Add Field and click the mouse button. 
The click will confirm that you have named this type of 
item "Suppliers"; no Return is necessary. 

The Add Field button changed to Where? Move the cursor 
into the gray area; note that when it enters the gray area it 
becomes a pointing finger; this indicates that it can be used 
to fix the location of the next field. 
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Type " Address" . By touching the stretching handle with 
the point of the cursor and holding down the mouse , pull 
the Address box until it has enough space for an address. 

Figure 8.14 The data file ready to be named 

The Add Field button has turned to Copy Field. Click twice 
in the gray area and by similar steps create a City field. 

Add fields until the type definition box looks like figure 
8.15. Check the Done box. 

Def tnt t1on for thi s type: 

Figure 8.15 The type definition for suppliers 

Pull down the Symbols menu and select the large dia­
mond. It will appear on the tool stack at the left margin. 

Select the diamond from the tool stack. When the cursor 
slides into the work area it becomes a diamond. Move the 
diamond into Massachusetts and click to fix it there. 

Click Info . 
The blank you have designed will appear. When you 



200 MACINTOSH 

STEP11 

STEP1 

STEP2 

lnformolion for this Suppliers: 

Figure 8.16 Blank suppliers form 

move the cursor into any of the boxes , it will turn to an 1-
beam and you can type and edit in the boxes. 

Fill out the information so the form looks like figure 8.17. 
Then check Done. 

Create two or three other suppliers to give substance 
to the printing below. Sample information on three hypo­
thetical suppliers of Thorn & Co. appears on page 208. 

lnformolion for this Suppliers: 

Figure 8.17 Information about a particular supplier 

Creating An Object 

Pull down the Types menu and select State. 

Pull down the Lines menu and select the second fattest 
line. Select the freehand drawing tool at the bottom of the 



Figure 8.18 The state of Atlantis 
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tool stack. Draw a large island off the southeast coast as in 
figure 8.18. 

When you enclose the island, the pattern that is cur­
rently selected (here the stipple that fills the states) will find 
the island . Be sure to join your line to the starting point 
smartly so the pattern will fill. 

The island is now an object and you can attach infor­
mation to it just as you attached information to the symbols 
of the suppliers. 

Click on Info. A blank state information form will appear . 
Fill it out as in figure 8.19. 

Now Atlantis will appear in all the operations you do 
on states. For example, if you select Arkansas and click the 
Next button, Atlantis will brighten because it is next in 
alphabetical order. 

Information for this Stale: 

Figure 8.19 Information about Atlantis 

Printing 

Pull down the File menu. 
Print display prints exactly what you see on the 

screen. If highlighting is on, the objects are highlighted on 
the printed page. 

Print info prints the info displays for any number of 
items of the current type. It also allows some page format­
ting, page numbers, a running head, and running footer. 
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Figure 8.20 Printing in Rlevision 

Print list allows you to print a list of selected informa­
tion about the items of the type currently selected. You 
could, for example, print a list of the population of every 
state. 

Print labels allows you to design and print small 
labels such as mailing labels. 

Let's print labels. Select Print labels for this example. The 
Print label dialog box will appear. 

Figure 8.21 The Print label dialog box 

The preset label size is fine for this exercise but you 
could change the size of the dotted box by dragging the 
little black square handle on the lower right. The preset 
order of printing is alphabetical by name, but the Post 
Office requires that bulk mail be sorted by zip code so we 
will change it. 
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Click on the little double arrow at the right end of the Order 
printing based on box. The names of other fields you have 
created will pass as you click. Stop on zip. 

The preset label includes Link, which is not part of a 
mailing label. In the preset layout Link stands selected, 
which is shown by the handles and the line that leads to it 
from the format control box. 

Click on Remove Field. This step merely removes link from 
the label, but not from the system. 

You need the city, state, and zip on the mail label. Click on 
the Add Field button, it will turn to Where? As before, 
moving the cursor to the work area turns it into a pointing 
hand. Move the hand below the Address field and click. A 
field will appear there, but it will not be the City field. Click 
the little doubleheaded arrow in the format box, bottom 
center, and you will see the fields you have created pass 
before you. Stop on City. Adjust the field's location with 
the black, top-handle and its length with the black handle 
on the lower-left corner. 

Add the State field and Zip field so the label on looks like 
Figure 8.22. 

Figure 8.22 Filevision Print Labels dialog box ready to print 

Check Done. The regular Mac printing dialog box will 
appear. 

If you want gummed labels you have to load your 
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printer with them. They are available in most office supply 
stores on narrow waxed rolls. Insert them on the left of the 
platen, lined up with the small red line on the bail. Be sure 
to open the lever on your printer that allows for extra thick 
paper; if you don't, gummed labels can jam in the works of 
the printer, which is a hell of a mess to fix-believe me, I've 
done it. 

Check Continuous if you have a roll or a fanfolded labels, 
and low or high quality. Most mailing labels I see use a 
lower-quality printing than is available on a Macintosh. 

While you are printing, a box will appear that counts 
the number of labels you have printed. The labels will look 
like this: 

Ahab Whalebone 

431 Marble Road 

Cummaquid MA 

02637 

Hetera Hatties 

816 baleen Ave 

Ce8tonvi11e NC 

27588 

Mendocino Whites 

565 Front Street 

Mendocino 

Big Fleet 

CA 

94460 

4 t 2 State Street 
Bellingham WA 

98225 
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PFS:file runs on the Macintosh very much like it runs on any 
personal computer. The only difference is you locate things 
with the mouse instead of cursor buttons and you pull 
down menus instead of seeing them flash on the screen. 

PFS:file is one of the most widely used applications in 
personal computing. There are others that are more power­
ful and more flexible, but they are harder to use for the 
nonprogrammer. PFS:file is easy for the noncomputer per­
son to get hold of and is quite satisfactory for many applica­
tions, such as the personnel records of a small firm, parts 
lists, and other inventories. It has more sophisticated ways 
to search and filter than does Filevision. The amount of 
information you can deal with varies with the size of the 
individual forms and some other factors, but it is surpris­
ingly extensive on a Mac. You can store and search nearly 
3, 000 of the simple forms used in the examples below. 

The style of PFS:file and PFS:report are rooted in the 
old system of rows of clerks in open office environments 
typing data onto on-screen forms while programmers 
extracted from that data lists that other people read. These 
programs allow you to do those functions yourself. You 
can print a single form directly from PFS:report, but to 
extract lists or other different views from your data you 
need the second program, PFS:report, which comes on the 
same diskette. With PFS:report you can create various for­
mats and do some mathematics to extract new information 
from the source data. For example, in a parts list PFS:report 
can multiply the number of parts in stock by the price and 
give the value of inventory of each part; and it can total the 
whole column to give the total value of the inventory. 

The examples use the same information about the 
suppliers or Thorn & Co. as did the examples of Filevision. 

How PFS:file and PFS:report Work 

In PFS:file you design a report by fixing headings on 
the screen for your information. You make as many copies 
as you want of this blank form and fill in the information for 
particular subjects. You search for forms by calling up the 
blank form and entering the text you are searching for. You 
can print, copy and remove forms in the same way: by 
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identifying the form with a piece of text that appears in it. 
In PFS:report you number the fields you have defined 

and then all the items in that field will print in a column 
with that number. Or you may filter out forms and print 
only the items from the filtered forms in the numbered 
columns. You can add tags to the design of your printed 
report that will total, subtotal, and average the columns, 
and generate new columns by, for example, multiplying 
two of the old columns. 

Creating a Form 

Put the PFS diskette in the Mac and start up; click on the 
PFS:file icon if necessary. 

A dialog box will appear that asks you if you want to 
start a new file, see an old file, or quit (No, I don't know 
why you should want to quit at this point). 

Click on New. 
A dialog box appears (figure 8.23 ), which asks for a file 

name and offers you the chance to eject the diskette. If you 
eject the diskette you can insert an empty diskette and 
create your file there. A second diskette will give you more 
space and save wear on the master diskette, which you 
can't copy. You will have to reinsert the system diskette 
from time to time to let the program read itself. This simple 
example will fit on the PFS master diskette. 

Type: "Thorn & Co. Suppliers" and check OK. 

New file nome 

I Thorn & Co Suppliers 

Ok ( cancel I 

Figure 8.23 The New file dialog box 

PFS progrom 

( Eject 

Now you design your own form by putting in headings 
where you want your information to go. When you begin 
the screen is a blank sheet. You can click with the mouse 
anywhere on the screen and begin typing. Response to the 
click may be a little slow while the program locates the 
right point. Type headings. End each heading with a colon. 
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Data will go on the individual forms after the colon. When 
you have designed the form you can edit it with the usual 
Macintosh tools . 

ved? : ~w~• s 

Ha.e : 
Address : 

Cil11 : Stale : 
Phone : 

02631 

1 

... d ? , - ·~--

'"·d? : no

1
-­

Racaivad? :f----'r---_ Filled in 

Z ip : 

nont.hl\1 S h i p : 
O•ed : Due : Forms 
Co-.:nls : lanlc Form 

Figure 8.24 First design a form 

Layout the design as in figure 8 .25 . 

' * File Edit Functions Formats 

Thorn & Co Suppliers 

Fill In page I of the design. 

No•• : 
Address : 
C i ty : State : Z i p : 
Phone : 
Month l \,1 Sh i p : Rec:e i ve:d : 
Owed : Due Dote 

Coa111ent s : 

Figure 8.25 Thorn & Co. suppliers form in PFS-file 

Putting in Information 

Pull down the Functions menu and select Add forms. All 
the headings you created in the design will turn bold to 
show that this is the master form. 

Type '' Ahab Whalebone'' . Press Tab to move to the next 
item. Type in the information found in figure 8.26. 
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n-: ~hab llhalebone 
Address: 43 I narb 1 e Road 
Cltv: Cu11111aquid State: nA Zip: 02637 
Phonct: 617-363-7070 

=~·r ~~~P= 2000 ::e~~ ~~12' r 

Figure 8.26 The Thorn & Co. suppliers form filled out for Ahab Whalebone 

Enter information on three more suppliers so we can see 
how PFS:file searches and filters data. When you finish the 
Ahab Whalebone form, check the Continue Adding button 
to get a new, blank form. The information on three sup­
pliers follows: 

Name: Hatera Hatties 
Address: 816 Baleen Ave 
City: Ceatonville State: NC Zip: 27588 
Phone: 919-556-2940 
Monthly Ship: 3300 Received: no 
Owed: 0 Due Date: 0 

Name: Mendocino Whites 
Address: 565 Front Street 
City: Mendocino State: CA Zip: 94460 
Phone: 707-897-3831 
Monthly Ship: 2100 Received: yes 
Owed: 1987 Due Date: 

10/31 

Name: Big Fleet 
Address: 412 State Street 
City: Bellingham State: WA Zip: 98225 
Phone: 206-743-9178 
Monthly Ship: 2043 Received: yes 
Owed: 2345 Due Date: 

I 1111 

Searching for Forms 

When you finish filling out the forms for the suppliers, 
the form for Big Fleet should occupy the screen. 
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Pull down the Functions menu and select Find forms . 

formots 

Print this form 
Remoue this form 

Copy forms 
Copy design only 

Figure 8.27 The PFS:file Functions menu 

The screen will return to the blank form you first 
designed. PFS:file creates a second command and feedback 
area beneath the menu headings. The Find forms button 
will appear to the right of this area. 

a File Edit Functions Formots 

Thorn & Co Suppliers ----- ----
- -- ~~-- -

Page 1 -- pleose choose forms to find. 

ttoae : 
Address: I 

Figure 8.28 The Find first form button and command feedback area 

If you click on the Find first form button, the last form 
you created will appear and the button will change to Find 
next form. By clicking on it, you can leaf through the forms 
one by one, a useful approach if you have 4 forms, but not if 
you have 100 or 1,000. 

If you have leafed through your forms , pull down the 
Functions menu and select Find forms again. The blink­
ing insertion point will appear after the first item, Name:. 
Type "Ahab Whalebone" and click on the Find first form 
button. 

The whole form for that company will appear. When 
you type the complete text of any item in the blank and use 
the Find first form command, the system will find any form 
that matches that text. 

If more than one form matches, PFS:file will show the 
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first one first and you can then leaf through the other 
matching forms with the Find next button. 

Set the insertion point after Received?:. Type "yes" and 
click on the Find first form button. 

The program will search for suppliers that have deliv­
ered that month. The first to appear will be Mendocino 
Whites. If you click on Find next form, the form for the 
other supplier that has delivered, Big Fleet, will appear. 

In a real business file with hundreds of forms, you 
might not know exactly how an item was written; in that 
case you can use periods to represent uncertain characters. 

Select Find forms on the functions menu to see a blank 
master form. Set the insertion point after State:. Type 
'' .. C .. '' and click the Find first form button. 

Two suppliers are in states that have a C in their 
abbreviation, Mendocino Whites in California and Hattera 
Hatties in North Carolina. Mendocino Whites will appear, 
and clicking the Find next button will show Hattera Hat­
ties. 

You can also compare numbers. For example, you can 
use the mathematical sign > (greater than) to search out 
numbers over a certain size. 

Select Find forms on the Function menu, set the insertion 
point after Owed: and type '' > 1000' '. Then check the Find 
first form button. 

The form for Mendocino Whites will appear, the sup­
plier to which Thorn & Co. owes the most money. Clicking 
on the Find next button will show in descending order the 
other firms that Thorn & Co. owes more than $1,000 to. 

Before you begin the next steps devoted to printing, 
pull down the File menu and select Quit PFS:itle. 

Printing 

Within PFS:file you can print sections of the forms as 
they appear on the screen. PFS:report allows you to print 
the information rearranged into columns of similar items, 
and to do some calculation on those columns to create new 
columns, totals, averages, and the like. 
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Click twice on the PFS:report icon. A dialog box will appear 
that asks you if you want to open a PFS data file or Quit. 

Click on Open. 

Select ''Thorn & Co. Su ... '' (the system abbreviates the long 
name) and then check OK. 

A blank screen labeled with the file title will appear 
with the message "Please make a menu selection." 

Pull down the Formats menu and select Create a report 
format. 

A dialog box will appear where you can write the 
name of the report format. 

Type "Owed'' and check OK. 
Items are marked for printing by typing after the colon 

the number of the column you want them to appear in, 
counting from left to right. 

Set the insertion point after Name: and type "1". Then set 
the insertion point after Owed: and type '' 2''. 

You can total, subtotal, and average the columns you 
have defined using the symbols T, S, and A, respectively, 
after the column numbers. 

Add A and T to match figure 8.29. 

Thorn & Co. Suppliers 

Edit page 1 of the report format ·owed". 

City: 
PhOfte: 
nonthly Ship: 
O.ed:2AT 
c-ents: 

I 
State: Zip: 

Received?: 
Due Data: 

Figure 8.29 Report format screen set up to show the names of suppliers, the 
amount owed, the average, and the total 

Pull down the Functions menu and select Print a report. 
A blank version of the report you designed will appear with 
the message ''Please choose forms for the report.'' 

At this point you could select certain forms with the 
same tools you used to select certain forms for display in 
PFS:file. In the case of this small example, let's select items 
from all the forms. 
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STEP9 

STEP10 

" • File Edit Functions Formats 

Report Title 

I Money Owed to Suppliers 

Check the Print report button. 
The report printing dialog box will appear. We will 

print to the screen, but you could print the same report to 
paper, or store it on the diskette for future printing. 

Fill out the report printing dialog box to match figure 8.30. 
The report will look like figure 8. 31. 

t1one1.1 Owed to Supp I i ers 

tta11e Owed 

Ahab llha I obona I, 379 
Big Fleet 2,345 
Ha ltera Ha tt i es 0 

Print to 0 Printer ® Screen 0 Dlsle File 

0 Pause between pages t1end i c: i no llh i tas 1 , 987 

Lines per page ~ Page width ~ Average: 1, 428 
Total: 5, 711 

Printer codes 

0 Don't use predefined report format 

®owed 
Figure 8.31 Thorn & Co.'s debts to 

suppliers 

~ 
Ok ~( -Ca-n-ce-1....., 

Figure 8.30 Report printing dialog box set to print to the screen 

Factfinder 

You can also set up columns in PFS:report based on 
calculations from other columns, for example, the number 
of parts and the price might be in the original report and the 
value of the inventory could be a separate column on the 
printed version. 

Unlike Filevision and PFS:file, Factfinder is built to give you 
power over your notes. Although you can do some things 
with numbers, it is basically a way of storing text informa­
tion, much like an electronic 3-by-5-inch card; moreover, 
you search and print the notes that contain certain words. 

Because Factfinder works best on regular text, the 
following exercise (p214) does not regroup the Thorn & Co. 
suppliers but show arranging and retrieving a few refer­
ences for the college paper on The Universe discussed in 
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chapter 7. If you have not looked at chapter 7, it would 
probably help you to at least glance at the outline. of ''The 
Universe'' presented there. 

Factfinder does not let you copy the program to 
another diskette. You can get one free backup diskette 
from the manufacturer by sending in the warranty card. 
You can copy the program to a hard disk. It does give you 
the very limited ability to copy the program to other disk­
ettes, but the copy will only allow you to have 16 items in a 
list. Such copies are useful only as advertisements for Fact­
finder. This copy prevention leaves the user that has only 
one drive with an awkward choice: You can keep your files 
on the master diskette and have up to 50 one-page fact­
sheets, but you will be wearing out your irreplaceable mas­
ter diskette. Or you can put the data files on a second 
diskette, where you can have hundreds of one-page fact­
sheets, but you shuffle diskettes in and out often. 

Factfinder has, unfortunately, invented its own little 
terminology. I said that it is like keeping a file of 3-by-5 
cards on your diskette. The cards are called "factsheets" 
(variable-length records in data processing terms) and the 
whole bunch together is called a stack (a file in data process­
ing terms). There are some other odd terms on this program 
which make learning it a little slower, and writing about it a 
little more difficult, but they do not get in the way of using 
the program once you get the swing of it. 

How Factf1nder Works 

When you evoke the application the first time, you see 
a group of windows. On the left is a window called the 
factsheet, where you can type about 6 pages of text. You 
can expand this window to fill the whole screen if need be. 
A group of such factsheets that are filed and searched 
together are called a stack. You can select words or phrases 
in the factsheet by normal Macintosh selecting and they 
will appear in a window on the left, which keeps track of 
them. In another window you can type or copy these 
words and the system will show or print all the factsheets 
that contain them. Factfinder generates an index where 
you can find all the keywords for a file in case you want to 
review them. 
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STEP1 

STEP2 

Figure 8.32 Selecting Create 
Stack on the 
Factfinder menu 

STEP3 

STEP4 

STEPS 

Making a Factsheet 

Insert the Factfinder disk and click on its application to 
open it. 

A billboard screen appears that contains information 
about how much memory is available in the machine and 
how much space is o n the disk. 

Pull down the File menu and select Create Stack. 
A dialog box will ask you to name the stack, and offers 

you the opportunity to eject the diskette. 

Type ''The Universe'' and check OK. A set of blank Fact­
finder material will appear on the screen. 

' * File Edit Steck Factsheet Keys Utility Help 

I DIIii!i!!l Unnam ed Factsheet ~ Find In The Unluerse 
II IQ 

Find Fcc tsheets contcining: 

Keys for Unnamed Fectsheet 

erected on 1 1 I 1/ 64 
Modifi ed on 11/ 1/64 

I M 
Figure 8.33 What you see when you start Factfinder 

Now we can turn to putting text in the factsheets . 

Move the cursor into the factsheet window and click it to 
make the window active. The blinking insertion point will 
appear at the upper left. 

Type the fo llowing definition of the universe : " All created 
things viewed as constituting one system or whole; the 
creation; the cosmos. ' ' You can correct errors by backspac­
ing, and the normal Mac editing commands (Cut, Paste, and 
Copy) are available. 
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Figure 8.34 Selecting Change 
Name from the 
Factsheet menu 

STEP7 

STEPS 

10• Keys for Dlctlon11ry -

~Created on 1 1/5/84 
Modified on 11/5/84 

ALL CREATED T HINGS iil 
COSMOS 
CREATION 
SYSTEM 

tr; 

(@to~•~tl' l (c1e11r Ke!Js) 

II I 

Figure 8.36 The Keys for 
Dictionary window 
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Pull down the Factsheet menu and select Change Name 
(figure 8.34). A dialog box will appear to accept the name. 
Type " Dictionary" and check OK. 

You should select some keywords that Factfinder will 
later use to search for the dictionary definition. This is your 
handle on this information, so don 't be shy about selecting 
keywords. 

Select the words cosmos, creation, system, and the phrase 
" All created things" one at a time by dragging the cursor 
across them. 

You can also select a word in Factfinder by clicking 
twice, but the selection will include punctuation that is not 
separated from the word by spaces. In other words, what 
you get by double clicking is all the consecutive printing 
characters. Since you want future searches to find "cos­
mos" without having the comma as part of the keyword, it 
is better to select a word that has adjacent punctuation by 
dragging the cursor. 

Pull down the Keys menu and select Mark. 

Figure 8.35 Marking a word as a keyword 

When a keyword is marked, it appears alphabetically 
in the nearby Keys for Dictionary window. 



216 MACINTOSH 

STEP9 

STEP10 

STEP11 

Pull down the Factsheet menu and select New. When you 
ask to create a new factsheet , the program asks you if you 
want to preserve the changes you've made in the last fact­
sheet you worked with. Check OK. A new factsheet will 
then appear. Name it "Big Bang. " 

Type in text and select keywords to match figure 8.37. 

Scientific Amertccn 
October I 963 
Abstrcct : 
Across btlllons of llght-yecrs spcce 
Is c honeycomb of gclcctlc 
superclusters end huge voids. The 
structure mcy result from 
perturbcttons in t he density of 
metter ecrly in the big bong 

Figure 8.37 The Big Bang factsheet 

4 Fcctsheets In Steck 
4 Fcctsheets found 

Dlcttonc 

Princess Shlklshl 
Lucretius 

Create a new factsheet and then type in the poem by the 
12th century Japanese Princess Shikishi. 

1 slept In the pest. 
thct wl11 never come beck, 
cs though It wcs the present. 
Around the pillow In my drecms, 
The perfume of orenge blossoms 
flocted, 
like the frcgrcnce of the sleeves 
of the men who is gone 

4 Fcctsheets In Steck 
4 Fcctsheets found 

Figure 8.38 Quotation from Princess Shikishi and keywords 
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Some ideas are present in the poem that are not stated 
explicitly-something that happens in poetry, especially 
Japanese poetry. The speaker seems to be in love and it 
seems as if the man she loved has died. Note also that 
orange blossoms are relevant to " oranges, " one of the 
items in the outline in chapter 7, but it is not the same word. 
Here is how to supply these keywords that are not exactly 
present in the text but should be indexed. 

Click on the Keys for Dictionary window and type I I love''. 
You will see it appear in the box at the bottom. Check the 
Add button (or press Return). In the same way add " death" 
and "oranges. " Then select the other words to match fig­
ure 8.38 as you did above. 

Create a new factsheet , change its name to " Lucretius ," 
and mark some words for cataloging as in figure 8.39. 

Lucretius wrote "On the Nature of Things" about 75 
B.C. If his ideas seem to resemble the abstract from 
Scientific American, it shows that the more things change, 
the more they stay the same. 

ngs ... 
Listen carefully and I will explain 
by what motion the creative 
elements In matter make other 
elements and how after thct they 
break up end whet force compels 
them to move end the speed they 
t revel through the greet voi d. 

Figure 8.39 Quotation from Lucretius 

Finding Factsheets 

4 Factsheet s In Steck 
4 Factsheets found 

Dictionary 
Big Bong 
Princess Shlklshi 

Normally three windows besides the factsheet are visi­
ble on the Factfinder desktop (see figure 8.40). 
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STEP1 

STEP2 

!0~ Names Found ===:iii 
4 Fac tsheets in Slack 
2 Factsheets f ound 

Figure 8.41 Names found 

Find in Uniuerse 

Find Factsheets containing: 
( \/here You Pu\ Kao~vord a: lo all 

Flnd Factshe•ls 

Names Found 

4 Factsheets In Stack 
( \/he re You Choos• Vhich 1 4 Factsheets found 

facts heel l o Dis: play ) 
Dictionary 
Big Bang 

Princess Shlklshl 
IOiiii!!l Keys for lucretius lliiliiiliill 

Created on II / 2/B4 

l Vhoro You En\or Ko9vords \o }--- Modified on 11 /2/84 ~ 
lde nlif!:J Fa chhfl'ts 

MATTER 
MOTION i!o! 
NATURE 
UDID 

Figure 8.40 The Search window 

Click on the Find in The Universe window. 

Type "void " in the window. If the word " all" is in the 
window it searches for all factsheets. Double click o n " all" 
and type " void" to replace it. Pull down the Factsheet 
menu and select Find factsheets. 

The Names Found window will come to the front 
(figure 8.41). It shows that two factsheets are keyed to 
"void" and that Big Bang is selected. You could select 
Lucretius and display it. 

Click on the Big Bang factsheet. It shows buttons for 
controlling the view at the bottom. 

Figure 8.42 The Zoom, Previous, and Next Buttons on a factsheet 

Factfinder also maintains an index of the names , crea­
tion dates , and keywords of all your factsheets. You can 
look for items in the index and then use them to search. The 
index includes buttons to combine terms. 
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STEP4 

Find In Unluerse 

Find Factsheets containing: 

"UOID" and "SCIENTIFIC 
AMERICAN" 

Figure 8.44 Search for a factsheet 

with "Void" and 

"Scientific American" 
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STEP1 
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Pull down the Stack menu and select Show Index. The 
index will appear. 

~ lndeH of The Uniuerse 
KMES B/6 8AN6 
CREATE 0/CT/ONARI' 
e::~y L LICRETILIS ~ 

DATE PRINCESS SH/1(/SH/ 
DATE Creeted on 11/05/64 
JCEYS Modified on 11/05/64 

o ... 4 All CREATED THINGS 
5 ••• 9 COSMOS 
A.· .c CREATION 
D.· .F DEATH 

~:: :~ DREAMS 
n ... o LOVE 
P ••• R MAN 
s ... u MATTER 
II ••• Z MOTION 

NATURE 

Figure 8.43 The Factfinder Index window 

You Can Pick Factsh••t• by 
nam• 

You Can Pick Factshe.ts by 
Vh•n You mad• Th.ul 

ou Can Pick FactshNts by 
Vh•n You Chang.c:l Them 

Click on S ... V. The end of the index will appear. Select 
VOID and then click the move button. VOID will appear in 
the Find in The Universe window. Click on the and button; 
"and" will appear in the Find in The Universe window. 
Select "SCIENTIFIC AMERICAN" and click on the move 
button. The quotation marks separate real keywords from 
words that indicate their relation. You can insert words to 
show the relation between keywords either by writing 
them or by selecting them from the index window. 

Pull down the Stack menu and select Find factsheets. The 
Big Bang factsheet will be found. 

Printing Factsheets 

You can print a variety of information from the fact­
sheet through the Page Setup and Print items on the File 
menu; these not only do what their names imply, but also 
allow you to select what you print. 

Pull down the File menu and select Page Setup (see figure 
8.45). 
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STEP2 

STEP3 

Figure 8.46 Selecting Print on 

the Factfinder File 
menu 

STEP4 

Check items in the Page Setup dialog box to match figure 
8.45. The preset value is to print the factsheet only. There is 
no need to adjust Paper Length or Bottom Margin if you are 
using 8112-by-11 paper. Compressed Printing lets you put a 
lot of text in a narrow space, especially helpful if you are 
printing on 3-by-5 cards. 

0 Print only Factsheet TeHt 

® also print Names 

®also print Created: and Modified: 

® also print Keywords 

Paper Length c=J Inches and D 16ths 

Bottom Margin c=J Inches and D 16ths 
® Standard Print 0 Compressed Print 

Cancel 

Figure 8.45 The Page Setup dialog box 

Pull down the File menu and select Print. 
The Factfinder Print dialog box will appear. Print Fact­

sheet Names give you a list of all your factsheets by name. 
Print Keywords gives you a list of your keywords, which is 
useful if you are working with a large amount of Material. 

®Print Selected Factsheet 

0 Print Fectsheets found In lest search 

0 Print RLL Fact sheets in Stack 

0 Print Factsheet Names 

0 Print Keywords with occurrence counts 

OK Cancel 

Figure 8.47 The Factfinder Print dialog box 

Accept the preset values and check OK. The usual Mac 
Printing dialog box follows. Set it to fit your type of paper 
and check OK. 

If you have followed the steps of this example exactly, 
the dictionary factsheet will come off your printer like this: 

All created things viewed as constituting one system or whole; the creation; 
the cosmos. 



Access II 
Apple Computer 
20525 Mariani Avenue 
Cupertino, CA 95014 

Augterm 
Tymshare 
20705 Valley Green Drive 
Cupertino, CA 95014 

Factfinder 
Forethought 
1973 Landings Drive 
Mountain View, CA 94043 

Filevision 
Telos Software Products 
34 20 Ocean Park Boulevard 
Santa Monica, CA 90405 

MacDraw 
Apple Computer 
20525 Mariani Avenue 
Cupertino, CA 95014 

MacPaint 
Apple Computer 
20525 Mariani Avenue 
Cupertino, CA 95014 

Mac Write 
Apple Computer 
20525 Mariani Avenue 
Cupertino, CA 95014 

MegMerge 
5703 Oberline Drive 
San Diego, CA 92121 

Microsoft Chart 
Microsoft 
10700 Northrup Way 
Bellevue, W A 98004 

Microsoft Multiplan 
Microsoft 
10700 Northrup Way 
Bellevue, W A 98004 
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Microsoft Word 
Microsoft 
10700 Northrup Way 
Bellevue, W A 98004 

PFS:file & PFS:report 
Software Publishing Co. 
1901 Landings Drive 
Mou'ntainview, CA 9404 3 

PC to Mac 
dilithium Press Software 
8285 S.W. Nimbus 
Beaverton, OR 97005 

The Source 
1616 Anderson Road 
McLean, VA 22102 

ThinkTank 128 
Living Videotext 
1000 Elwell Court 
Palo Alto, CA 94303 

Trade*Plus 
POB60970 
Palo Alto, CA 94025 



1040,87 
9600-baud, 136 
A4, 12 
About the ... , 10 
Accents, 47 
Access II, 127 
Access III, 127 
Add legend (Microsoft Chart), 114 
adjusting column width (Multi-

plan), 85 
Ahab Whalebone, 200 
Adjusted Gross, 99 
Adjustments to income, 97 
Alarm Clock, 11 
Align Center (Multiplan), SOx, 89 
Apple Cluster Controller, 126 
Apple II, 127 
Apple III, 127 
Apple menus, 10 
Apple Modem, 140 
Applications, 6 
Appline, 140 
Arrows (MacDraw), 74 
Arrange menu, 67 
Arrow Tool, 68 
Artificial intelligence, 27 
Atlanta, 197 
Atlantis, 201 
ATS card, 136 
Augment, 1,4,150ffx 
Augterm, 151ffx 

Backspace, 32, 

Index 

Baud, 137,140x 
Bold, 43 
Borders (Microsoft chart}, 122 
Boxes, 5,8x,12 
Bring to Front (MacDraw), 67 
Brochure, 178 
Built-in functions (Multiplan), 85 
Bulletin Board, 126,142,145x 

Cables, 135 
Calculator, 11 
Cards, 128, 136x 
Cassette Label, 56 
Catalogues of diskettes, 17x,8 
Centering in Word, 166 
Change, 167 
Changing diskettes, 18 
Changing fonts(Microsoft Word) 

166 ' 
Character menu (Microsoft Word) 

166 ' 
Circle (MacDraw), 72 
Clear, 14x 
Clear (MacDraw), 58 
Clear (Multiplan}, 95 
Clicking, 4 
ClickArt, 182 
clicking, 4 
Clip art, 182 
Clipboard, 13x,ll7,163,164 
Clipboard (Microsoft Chart), 185 
Close, 7x,39 
Closebox, 7 

Close Down, 36 
Closing files, 39 
Cluster Controller, 140 
Conditional highlighting screen 

(Filevision), 194 
Column Width(Multiplan), 89 
Combination, 122 
Commas(Multiplan), 89 
Communication, 125 
Compatibility (MacTerminal), 129 
Continuous paper, 36 
Control Panel, 11 
Copy Prevention (Microsoft), 162 
Copy protection (Factfinder), 213 
Copying, 13,40 
Copying files, 17x, 162,182 
Copying programs, 17 
Copying whole diskettes, 17 
Correcting errors (MacDraw), 58 
Correcting errors (Multiplan), 81, 

90,95x 
Correcting typing errors, 33,34x 
Create a report format 

(PFS:report}, 211 
Credits, Other Taxes, and Pay-

ments, 102 
Cursor, 3x,31 
Cursor shapes, 109x, 122, 197 
Custom Rulers (MacDraw), 57 
Cut, 13, 14x 
Cut (Multiplan), 95 
Cut sheet paper, 36 
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Data, 190 
Data Bases, 190 
Data Menu(Microsoft Chart), 111 
Date, 17 
Date Series(Microsoft Chart), 111 
Date(Microsoft Chart), 111 
Define Name (Multiplan), 93x, 101 
Deselecting, 34x, 59 
Designing a form (Filevision), 199, 

206 
Desktop, 5. 7x 15 
iacritical marks, 47 
Diagrams, 191 
Dialog, 191 
Dialog Box, Typing in, 33 
Dialog Boxes, 8x,23 
Dilithium, 132,135 
Dip Switches, 128 
Diskette copying, 17 
Division layout(Microsoft Word), 

179 
Dollar(Microsoft Chart), 112 
Dollar(Multiplan), 89 
DOS (IBM operating system), 134 
Double Click, 2, 7x 
Double sided disk drives, 26 
Draft (quality printing), 12 
Dragging, 4 
Dummy text, 170 
Duplicate, 19x,37 
Duplicating files, 37 

Edit menu, 9, 13x 
Eject, 13x, 19,36,182 
Electronic Mail, 125,150,153x, 
Elevator, 7 
Empty trash, 17 
Engelhart, Doug, 150 
Entering formul in Multiplan, 83 
Eraser (MacPaint), 186 
Errors, correcting typing, 33,34x 
Exemptions, 91 

Faces, 19 
Factfinder, 191, 212,213x 
Factsheet (Factfinder), 213 
Factsheet Menu (Factfinder), 215 
Fanfold, 36 
Field, 191x, 206 
File, 5,6x,11,13,191x 
File copying, 17x, 162,182 
File Menu, 11 
File Names, 32 
File Saving, 32 
File Transfer, 133, 137x 
File transfer (MacTerminal), 130 
Files, 132 
Filevision, 191x 

Filevision tools, 193 
Filing Status, 90 
Fill Down (Multiplan), 98 
Fill Menu (MacDraw), 57 ,62x 
Fill Pattern, 62 
Fill Right (Multiplan), 84 
Find forms (PFS:file), 210 
First Category(Microsoft Chart), 

112 
Flashing Rectangle, 72 
Folders, 5, 7x 
Font File, 23 
Font Mover, 21x, 23 
Fonts, 19, 20-23x, 38,133 ff 
Fonts (Microsoft Chart), 123 
Footers, 47 
Footnotes, 134, 172x 
Form 1040, 87 
Format, 33 
Format (MacWrite), 43,47 
Format (Multiplan), 80,84 
Format Menu (Microsoft Chart), 

122 
Format(Microsoft Chart), 112 
Format(Multiplan), 89 
Forms, 191, 205, 206 
Formul, entering in Multiplan, 84 
Functions (Multiplan), 85 
Functions menu (PFS:file), 208 

209x 
Funny Hat, 67 ,61x 
Functions (Multiplan), 85 

Gallery(Microsoft Chart), 114 
General format (Multiplan), 93 
Georgia, 197 
Get Info (Filevision), 13 
Ghost image, 18 
Ghost image in MacDraw, 73 
Glossary(Microsoft Word), 176 
Goodies (MacPaint), 183 
Graphics editor (Filevision), 197 
Grouping Objects (MacDraw), 72 
Gummed labels, 203 

Hair Lines (MacDraw), 58 
Hand, 72,74 
Hand (Multiplan), 94 
Hand tool (MacPaint), 183 
Handles, 58,203 
Handles (Microsoft chart), 122 
Happy face, 15 
Hard disks, 26 
Header Icons, 48 
Headers, 47 
Headings, 159 
Help systems, 153 
Hide Rulers, 31 

High (quality printing), 12 

I-beam, 33 
1-beam (Multiplan), 81 
IBM A TS Card, 136 
Icons, 6,15,16x 
If construction (Multiplan), 100 
Illustrating, 29,50 
Imagewriter, 12x,29 
Income, 94 
Indenting (MacWrite), 46 
Indenting (Microsoft Word), 171 
Index,(Factfinder), 219 
Initialization, 15 
Insert Ruler, 46 
Inserting text, 34 
Insertion Point, 1, 2x,31,33 
Integrated Software, 2,23x,24,29 
International Fanfold, 12 
Inventory, 205 
Inverse Video, 33 

Japanese Poetry, 217 
Jobs, Steve, 69,125 
Justification, 46 

Keycaps, ll 
Keys for .... window (Factfinder), 

215 
Keys Menu(Factfinder), 215 
Keywords, 191x, 213,215 
Kitchen, 65 
Kitchen Sink, 69 

Labels, 202 
Larger memories, 25, 26x 
Laser printers, 27 
Lasso (MacPaint), 51 
Layout menu (MacDraw), 57 
Letter, 33 
Letter quality printer, 21 
Library, 191 
Line Thickness, 57,59x 
Lines Menu (Mac Draw), 57 ,62x 
Lines, selecting them, 165 
Linking Files (Multiplan), 96x,l15 
Lisa, Preface, 1,15, 28 
Login, 151 

MacDraw window, 56 
MacPaint, 51, 55, 108,182 ff, 185 
MacPaint tools, 184 
MacWrite Window, 31 
Mail Lists, 202 
Mail merge program, 37 
Mailing labels, 202x, 204 
Map, 193 
Margins (Microsoft Word), 171 
Marquee (MacPaint), 184 
MegaMerge, 29,37, 43x 



Memory, 19,21x, 157 
Menus, 2 
Mathematical functions (Multi­

plan), 85 
Mistakes, correcting them in Mac-

Draw, 58 
Modem, 140x,135 
Modem Eliminator, 141x,135 
Modular Phones, 140 
Mouse, 2,3,4x,150 
Move bar, 7 
Multiplan (with Microsoft Chart), 

116 
Multiplan SYLK File, 133 
Multiplan Window, 80 
Music, 27 
MWOOOl, 178 

New files, 39,72 
New Series (Microsoft Chart), 108, 

nox 
New series Window (Microsoft 

Chart), 111 
New York, 39 
Noisy Phones, 141 
Notepad, 10 
Notes, 191 
Null Modem, 136,141 

Object (Filevision), 200 
Open Footer, 49 
Open Header, 48 
Opening files, 409 
Orbit, 191 
Outlines, 159, 158x 

Page Count(Microsoft Word), 172 
Page numbering (MacWrite), 48 
Page numbers (Microsoft Word) 

176 
Page Setup, 13x 
Page setup (Microsoft Word), 179 
Page setup (Multiplan), 86, 107 
Panes, 173 
Paper Quality, 56 
Paragraph formats (Microsofl 

Word), 171x,174 
Paragraphs, 46 
Paragraphs (Microsoft Word), 165 
Password, 142 
Paste, 13, 14x,40,7 
Paste and Link (Multiplan), 96 
Pattern dialogue box (Microsoft 

Chart), 122 
PC, 132 
PC to Mac, 132 
PC to Mac cable, 143 
PC to Mac mode, 136 
Pen Menu (MacDraw), 57 ,62x 

Pen Pattern (MacDraw), 62 
PFS:file, 205x, 190 
PFS:report, 205 
Plain text, 43 
Playing around with tax numbers, 

88 
Playing with charts, 120 
Plots Series (Microsoft Chart), 113 
Poetry, 217 
Point (type sizes), 21 
Pointing, 2 
Polygons, 61,66x 
Printing, 12x,35 
Printing (Factfinder), 219 
Printing (Microsoft Chart), 115 
Printing (Multiplan), 105 
Printing (PFS:report), 211 
Printing Factsheets, 219 
Printing, (Filevision), 202 
Printing, (PFS:file), 210 
Program, 6x 
Program icons, 15 
Proportional spacing, 134 
Puzzle, 11 

Quit, 12 
Quitting applications, 36 

Readers Digest, 142 
Receive File(PC to Mac), 139 
Record, 191 
Rectangle with rounded corners, 

69 
Refund or Amount You Owe, 104 
Relative locations(Multiplan), 83 
Remove Headers (Mac Write), 49 
Removing Fonts, 21 
Replace, 33 
Replace a Word, 33 
Report printing (PFS:report), 212 
Reverse Video, 33 
Right Margin, 46 
Rotating objects (MacDraw), 75 
Ruler Icons (MacWrite), 46 
Rulers (MacDraw), 57 
Rulers (MacWrite), 46x 
Rulers (Microsoft Word), 170 
Running Footers (Microsoft 

Word), 173 
Running Heads (Microsoft Word), 

173 ff. 

Sad face,15 
Save, 11x,32 
Save As ... , 1lx, 134, 186 
Saving and not changing, 117 
Saving Files with two disk drives, 

165 
Scale of Ruler (MacDraw), 57,65x 

Scrapbook, 10 
Scroll bar, 7 
Scrolling, 7 
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Scrolling (Multiplan), 94 
Search and Change, 167 
Searching (Factfinder), 218 
Searching (Filevision), 194 
Searching (PFS:file), 209 ff 
Selected, 33 
Selecting a paragraph (Microsoft 

Word),l70 
Selecting a sentence (Microsoft 

Word), 170 · 
Selecting hidden objects (Mac­

Draw), 67 
Selecting Rows and Columns in 

Multiplan, 84 
Selecting Text, 34 
Selecting text (Microsoft Chart), 

122 
Send a file (MacTerminal), 131 
Send File (PC to Mac), 137 
Setting up a form (Filevision), 199, 

206 
Shadows of icons, 18 
Show Clipboard, 13 
Show page (MacPaint), 183 
Single sheets of paper, 36 
Software integration, 

23-24,50,178 
Source, The, 125, 142x 
Spaces (Microsoft Word), 166 
Special, 16, 17x 
Spreadsheets, 77, 190 
SRI, 2,150 
Stack (Factfinder), 213 
Standard (quality Printing), 12 
Standard menus, 9 
Star Trek, 132 
Starting an application, 30 
Starting the Mac, 15 
Statistics, 108 
Stock Market, 146,148x 
Style menu, 43,44 
Sub-items, 159 
Subscription services, 126 
Super Serial Card, 127,141 
Superscript, 175 
Switching active windows, 72 
SYLK, 85, 133 
Symbols (Filevision), 197 
Systems Folder, 16x 24 

Tab wells, 43 
Tabbing, 43,44 
Talking Macs, 27 
Tax Computation, 100 
Telenet, 142 
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Terminal mode, 134 
Texas, 194 
Text, 31 
Text Format Dialogue Box (Micro-

soft Chart), 122 
Text On ly File. 133, 134,139 
ThinkTank 128, 158 
Thorn & Co. , 79, 109, 116, 133. 178. 

197 .206 
Three-by-five Cards. 19 1, 212x 
Three-column format , 179x, 181 
Tinker Menu(Fi levision), 194 
Title page (MacWrite, 47 
T rade" Plus. 146x 
T rade"Pl us order procedures, 149 
Trash , 17x 
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T rue Circle, 72 
Turnkey application, 6 
T ymnet , 151 
T ymshare, 150 
T ype definition (File,·ision), 198 
Type faces. I9xff,29 
T ype fonts. 19x ff 
T ypefaces, changing in text , 38 
T ypes Menu (Filevision), 193 
T yping. 32 
T yping errors, correcting, 33,34x 

Underline, 43, 167 
Undo, 13 
Undo Typing, 31 
Uni ted States , 193 
Universe, 159,212,214 

Unlink , 96 
Upward compatibility, 26 
US Letter, 12 

Yen-tel, 140 
Venice, 38 
View, 17x 

W indows, 7x, l6 ,15 
Word, 33 
Word processors, 190 
Work files (Microsoft Word), 178 
Wozniac, Steve, 125 
Wrist watch, 4 

Xerox, I 

Zero po int (MacDraw), 57 
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Before you can click into high gear with 
your Mac, you need to know how to get 
where you're going. Macintosh: A Concise 
Guide to Applications Software gives you 
the basics of using Mac's word process­
ing, spreadsheet, drafting and design, 
and database management functions. It 
explains what the machine is capable of 
doing, then shows how to run the most 
popular applications programs. Clear, 
step-by-step instructions and as many as 
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smooth going. 

From MacWrites and MacDraws to Multi­
plan~ Microsoft Chart~ Microsoft Words 
and MacTerminal~ among many others, 
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most exciting and useful Mac software on 
the market. It tells you the ones to buy, 

gives detailed instructions on how to use 
them in realistic applications, and even 
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In addition, Macintosh shows how to 
create charts and illustrated brochures, 
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vices through public networks. 
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